Willkommen bei Silk Central 18.5

Willkommen bei Silk Central

  • Architektur
  • Lizenzierung von
  • Benutzeroberfläche
  • Schnellstartaufgaben
  • Installationshilfe

Neuerungen

  • Neuerungen in Silk Central
  • Versionshinweise

Beinhaltete Abschnitte

  • Mein Dashboard
  • Manuelle Ausführungsplanung
  • Qualitätsziele

Tutorials und Vorführungen

  • Schnellstartaufgaben
  • Anleitung zur manuellen Ausführungsplanung
  • Gratis Web-basiertes Training auf unserem Training Store

Codebeispiele

  • API-Hilfe

Online-Ressourcen

  • Micro Focus Homepage
  • Micro Focus Channel auf YouTube
  • Micro Focus Online-Dokumentation
  • Micro Focus SupportLine
  • Micro Focus Produkt-Aktualisierungen
  • Silk Central Wissensdatenbank
  • Silk Central Foren
  • Micro Focus On-demand Training

Feedback abgeben

  • Kontaktaufnahme mit Micro Focus
  • Senden Sie uns Ihr Feedback zu dieser Hilfe per E-Mail


Installations- und Systemkonfigurationshilfe

In dieser Installations- und Systemkonfigurationshilfe finden Sie alle Informationen, die Sie zum Installieren und Deinstallieren von Silk Central benötigen. Zusätzlich erhalten Sie Anweisungen zur Einrichtung Ihrer Silk Central-Infrastruktur.

  • Silk Central-Architektur
    Dieser Abschnitt enthält einen Überblick über die Architektur von Silk Central.
  • Installieren von Silk Central
    Die Silk Central Installations-DVD und das Setup Programm ermöglichen Ihnen, sämtliche Silk Central-Softwarekomponenten zu installieren.
  • Konfigurieren und Verwalten der Infrastruktur
    Instanzen und deren Silk Central-Dienste werden über eine gemeinsame Benutzeroberfläche namens Instanzen-Verwaltung verwaltet, auf welche Sie über die URL http://localhost:19100 auf dem Server wo Silk Central installiert ist zugreifen können.


Silk Central-Architektur

Dieser Abschnitt enthält einen Überblick über die Architektur von Silk Central.

Silk Central-Server

Der Server auf dem das Silk Central-Setup ausgeführt wurde.

Instanzen-Verwaltung

Instanzen und deren Silk Central-Dienste werden über eine gemeinsame Benutzeroberfläche namens Instanzen-Verwaltung verwaltet, auf welche Sie über die URL http://localhost:19100 auf dem Server wo Silk Central installiert ist zugreifen können.

Instanzen

Eine Instanz ist ein unabhängiges Set von Silk Central-Diensten (Anwendungsserver (AS), Front-End-Server (FE) und Diagrammserver (CS)), mit eigener Datenbank und eigenen Ausführungsservern (ES). Standardmäßig erstellt Silk Central eine einzelne Instanz namens silk für Sie. Die Standard-URL ist http://<Computername>:19120/login (keine Portinformationen nötig wenn Silk Central auf IIS läuft).

Proxy

Ein Proxy-Dienst wird auf dem Silk Central-Server installiert, um den Zugang zu den verschiedenen Instanzen zu verwalten. Die Dienste der verschiedenen Instanzen laufen auf unabhängigen Ports, aber aus Sicherheitsgründen und für eine größere Flexibilität, leitet der Proxy den Instanznamen auf die eigentlich URL um, und zwar in der folgenden Form: http://<Silk Central-Server>:19120/<Instanzname>.

Anwendungsserver (AS)

Der Anwendungsserver synchronisiert Aufgaben, wie etwa die Verteilung der Ausführungspläne, das Steuern der Ausführungsserver und die Verwaltung der Datenbankkonfiguration. Diese Aufgaben erfordern eine zentrale Steuerung, damit die konsistente und zuverlässige Ausführung gewährleistet ist. Außerdem wertet der Anwendungsserver die Ergebnisse aus, speichert diese in der Datenbank und sendet anhand der Erfolgsbedingungen Benachrichtigungen. Der Anwendungsserver verwendet Port 19122 für die Standard-Instanz. Für jede weitere Instanz wird dieser Wert um 100 erhöht.

Front-End-Server (FE)

Der Front-End-Server ist für die grafische Benutzeroberfläche zuständig. Er basiert auf HTML und kann mit einem beliebigen Webbrowser (z.B. Internet Explorer, Chrome und Firefox) aufgerufen werden. Der Benutzer sendet eine entsprechende HTTP-Anforderung an den Front-End-Server, und daraufhin wird eine Anmeldeseite zur Authentifizierung im Browser geöffnet. Nach der erfolgreichen Anmeldung kann der Benutzer auf die Anwendungen und Funktionen zugreifen, für die er über Berechtigungen verfügt. Der Front-End-Server kann als eigenständiger HTTP-Server ausgeführt oder in einen anderen Webserver (z. B. IIS) eingebunden werden. Der Front-End-Server verwendet Port 19110 für die Standard-Instanz. Die zweite Instanz verwendet Port 19220, und für jede weitere Instanz wird dieser Wert um 100 erhöht. Für sichere Verbindungen mit SSL verwendet der Server zudem Port 443. Der Front-End-Server kann über die URL http://<Silk Central-Server>:19120/<Instanzname> erreicht werden (die Standard-Instanz benötigt keinen Instanznamen).

Diagrammserver (CS)

Der Diagrammserver erzeugt die in den Berichten verwendeten Diagramme. Das System ermöglicht das Konfigurieren eines Pools von Diagrammservern. Die Verarbeitung wird dann durch einen internen Lastausgleichsmechanismus auf die Server im Pool verteilt. Mit einem Diagrammserver können auch Berichte erzeugt und direkt an den Endbenutzer gesendet werden. Der Diagrammserver verwendet Port 19126 für die Standard-Instanz. Für jede weitere Instanz wird dieser Wert um 100 erhöht.

Ausführungsserver (ES)

Der Ausführungsserver führt automatisierte Tests aus, die von autorisierten Benutzern geplant wurden. Die Benutzer sind für die richtige Konfiguration der Ausführungsserver und der sonstigen für die Ausführung erforderlichen Ressourcen verantwortlich. Es können mehrere Ausführungsserver installiert und konfiguriert werden, die unabhängig voneinander laufen. Der Ausführungsserver verwendet Port 19124 für die Standard-Instanz. Für sichere Verbindungen mit SSL verwendet der Server zudem Port 19125.

Agentencomputer:

- und -Agentencomputer werden aus dem Pool von Agentencomputern, die für den steuernden Computer verfügbar sind, bestimmten - und/oder Silk Performer-Projekten zugewiesen. Der steuernde Computer dient zusammen mit Silk Central als Ausführungsserver.
Silk Performer-Agenten
Auf den Silk Performer-Agentencomputern befinden sich die virtuellen Benutzer, die während der Lasttests verwendet werden. Einem Silk Performer-Projekt können so viele Agentencomputer hinzugefügt werden, wie virtuelle Benutzer für die Testausführung erforderlich sind. Die Konfiguration der Agenten wird mit Silk Performer durchgeführt. Nähere Informationen zur Agentenkonfiguration finden Sie in der Dokumentation zu Silk Performer.
Silk Test Classic-Agenten
Die -Agenten entsprechen den -Agenten, nur dass auf den -Agentencomputern Silk Performer-Tests ausgeführt werden.

Datenbankserver (DB)

Die dauerhafte Datenspeicherung wird durch ein relationales Datenbankmanagementsystem (RDBMS) implementiert. Der Datenbankserver verwendet die Ports 1433 (SQL Server) oder 1521 (Oracle).

Silk Meter-Lizenzserver

Silk Meter, die im Lieferumfang von Silk-Produkten enthaltene Lizenzierungssoftware, bestimmt, auf welche Funktionen der Anwendung Silk Central Sie zugreifen können. Weitere Informationen zur Lizenzierung finden Sie im Installationshandbuch zum jeweiligen Produkt. Silk Meter verwendet Port 5461.

Mandanten

Mandanten sind getrennte Einheiten innerhalb einer Silk Central-Instanz. Ein Mandant kann z.B. ein Kunde oder ein Geschäftsbereich eines Unternehmens sein. Mandanten erhöhen die Datensicherheit, aber im Gegensatz zu Instanzen verwenden sie dieselbe Datenbank und dieselben Silk Central-Dienste. Jeder Mandant besteht aus den folgenden Hauptobjekten:
  • Benutzerrollen und Berechtigungen
  • Benutzergruppen und Benutzerkonten
  • Projekte
  • Servergruppen, Ausführungsserver und Agentencomputer
  • Produkte mit Komponenten, Versionen und Builds
  • Allgemeine Ausführungstermine

Projekte

Projekte reflektieren in Silk Central üblicherweise ein Software-Projekt in Ihrer Firma, respektive die Arbeit eines Entwicklungsteams, mit gemeinsamem Release-Datum, Versionsverwaltungssystem, gemeinsamen Anforderungen, usw. Jedes Projekt besteht aus den folgenden Hauptobjekten:
  • Filter
  • Attribute
  • Anforderungseigenschaften
  • Testschritteigenschaften
  • Benachrichtigungen
  • Anforderungs- und Fehlerverwaltungsintegrationen
  • Integriertes Versionsverwaltungssystem
  • Datenquellen
  • Statusursachen

Wichtige Datei-Speicherorte

  • Instanzen-Verwaltungs- und Ausführungsserver Logdateien: C:\ProgramData\SilkCentral\log
  • Anwendungs-, Front-End- und Diagrammserver Logdateien: C:\ProgramData\SilkCentral\instance_<Instanznummer>_<Instanzname>\log
  • Speicherort für Hotfixes: C:\Program Files (x86)\\ Silk\hotfixes
  • Konfigurationsdateien: C:\Program Files (x86)\\ Silk\instance_<Instanznummer>_<Instanzname>\Conf
  • Plug-Ins: C:\Program Files (x86)\\ Silk\instance_<Instanznummer>_<Instanzname>\Plugins
  • Zuordnungsdateien für Office-Import: C:\ProgramData\SilkCentral\instance_<Instanznummer>_<Instanzname>\OfficeImportMappingFiles
Übergeordnetes Thema: Installations- und Systemkonfigurationshilfe
Zugehörige Tasks
Verwalten von Instanzen
Verwalten von Mandanten
Verwalten von Projekten


Installieren von Silk Central

Die Silk Central Installations-DVD und das Setup Programm ermöglichen Ihnen, sämtliche Silk Central-Softwarekomponenten zu installieren.

Der Computer, auf dem Silk Central installiert werden soll, muss die Systemanforderungen erfüllen. Das Installationsprogramm prüft, ob das System diese Voraussetzungen erfüllt, und ermöglicht dann das Installieren der erforderlichen Software.

Anmerkung: Sie müssen auf dem Computer über Administratorrechte verfügen, um Silk Central zu installieren.
  • Systemanforderungen und Voraussetzungen
    Für eine optimale Leistung von Silk Central wird die in diesem Abschnitt erläuterte Konfiguration empfohlen.
  • Installieren von Silk Central zu Evaluationszwecken
    Richten Sie eine Einzelplatzinstallation ein, bei der sämtliche Komponenten auf einem einzigen Computer installiert werden. Dieser Installationstyp ist nur für Evaluations- und Demozwecke geeignet.
  • Installieren von Silk Central
    Die Installations-DVD und das Setup Programm ermöglichen Ihnen, sämtliche Silk Central-Softwarekomponenten zu installieren.
  • Installieren eines Windows-Ausführungsservers
    Installieren Sie einen Windows-Ausführungsserver, um Tests auf entfernten Computern auszuführen.
  • Installieren eines Linux-Ausführungsservers
    Installieren Sie einen Linux-Ausführungsserver, um Tests auf entfernten Computern auszuführen.
  • Installieren von einem Hotfix
    Aktualisieren Sie Ihre Instanzen auf den aktuellsten Hotfix, wenn ein neuer Hotfix verfügbar ist.
  • Aktualisieren auf Silk Central 18.5
    Aktualisieren Sie auf Silk Central 18.5, um von Verbesserungen zu profitieren.
  • Silk Central
    Rufen Sie ein Lizenzierungsschema ab, und lizensieren Sie das Produkt, um den gesamten Funktionsumfang von Silk Central und den Support nutzen zu können.
  • Getestete und unterstützte Software
    Hier wird die Software aufgelistet, mit der Silk Central18.5 getestet wurde, sowie die Software, die von Silk Central unterstützt wird.
Übergeordnetes Thema: Installations- und Systemkonfigurationshilfe
Zugehörige Konzepte
Systemanforderungen und Voraussetzungen


Systemanforderungen und Voraussetzungen

Für eine optimale Leistung von Silk Central wird die in diesem Abschnitt erläuterte Konfiguration empfohlen.

Server-Systemvoraussetzungen

Systembereich | Anforderung
Prozessor | Intel Core i5 oder besser
Speicher | Mindestens 8 GB
Freier Festplattenspeicher | Mindestens 30 GB, außer für den Datenbankserver
Netzwerk | 100 MBit
Betriebssystem, DBMS, Webserver | Siehe Getestete und unterstützte Software.
Stromversorgung | Um Datenverluste bei einem Stromausfall zu vermeiden, wird für alle Umgebungen eine USV (unterbrechungsfreie Stromversorgung) empfohlen.
Für jede zusätzliche Instanz werden mindestens 10 GB zusätzlicher Festplattenplatz benötigt, sowie mindestens der folgende initiale Systemspeicher:
  • Front-End-Server: 500 MB
  • Anwendungsserver: 300 MB
  • Diagrammserver: 200 MB
Je nach Ihrem Workload könnten diese Werte noch höher sein.

Weitere Informationen zur optimalen Konfiguration von Silk Central erhalten Sie vom technischen Support oder Ihrem Technical Account Team.

Anforderungen an Ausführungsserver

Die tatsächlichen Anforderungen und Voraussetzungen, die ein Anwendungsserver erfüllen muss, richten sich nach der getesteten Anwendung (Application under Test, AUT) und der Art des Tests.

Für einen Lasttest müssen die Umgebungsanforderungen von Silk Performer erfüllt werden. Lasttests mit der Mindestkonfiguration können zu ungenauen Ergebnissen führen.

Beachten Sie bei Funktionstests die Umgebungsanforderungen von Silk Test. Für umfassende Tests (wie Browser-Wiedergaben) wird ein Arbeitsspeicher mit mindestens 2048 MB empfohlen.

Ein Linux Ausführungsserver benötigt Java Runtime Environment (JRE) 8.

Anforderungen an Proxy-Server

Wenn Sie Microsoft IIS für Silk Central verwenden möchten, installieren Sie zuerst die folgenden IIS-Erweiterungen, bevor Sie Silk Central installieren:
  • Application Request Routing (ARR)
  • URL Rewrite
Die aktuellsten Versionen dieser Erweiterungen können von der Seite IIS Downloads heruntergeladen werden.

Virtualisierung

Silk Central kann in der virtuellen Infrastrukturumgebung VMware vSphere Server ausgeführt werden.

Client-Systemvoraussetzungen

Systembereich | Anforderung
Prozessor | Intel Core i3 oder besser
Speicher | 2 GB
Browser
  • Google Chrome
  • Internet Explorer 10 oder höher (ohne Kompatibilitätsmodus)
  • Mozilla Firefox
  • Microsoft Edge

Die Benutzeroberfläche für manuelles Testen benötigt Java Runtime Environment (JRE) 7 Update 79 oder höher.

Übergeordnetes Thema: Installieren von Silk Central


Installieren von Silk Central zu Evaluationszwecken

Laden Sie zuerst die ausführbare Datei von Silk Central herunter, oder legen Sie die Silk Central-DVD in das DVD-Laufwerk ein.
Anmerkung: Da die Installation von Microsoft SQL Server Express Administratorrechte benötigt, scheitert die Installation wenn die Benutzerkontensteuerung (UAC) eingeschaltet ist. Schalten Sie die Benutzerkontensteuerung (UAC) auf dem Rechner aus, auf dem Sie Silk Central für Evaluationszwecke installieren möchten.

Richten Sie eine Einzelplatzinstallation ein, bei der sämtliche Komponenten auf einem einzigen Computer installiert werden. Beachten Sie, dass bei einer Einzelinstallation nicht die volle Leistung von Silk Central zur Verfügung steht. Dieser Installationstyp ist nur für Evaluations- und Demozwecke geeignet.

Anmerkung: Das .NET Framework 3.5 SP1 Setup kann nicht während der Installation von Silk Central unter Microsoft Windows Server 2008 R2, Windows Microsoft Windows Server 2008 R2 SP1 oder Microsoft Windows Server 2012 ausgeführt werden. Wenn .NET Framework 3.5 SP1 nicht in Ihrem System installiert ist, Ihr Betriebssystem Microsoft Windows Server 2008 R2, Windows Microsoft Windows Server 2008 R2 SP1 oder Microsoft Windows Server 2012 ist und Sie die Testversion von installieren möchten, installieren Sie .NET Framework 3.5 SP1 mithilfe von Windows Server Manager in Ihrem System, bevor Sie Silk Central installieren.
  1. Suchen Sie die ausführbare Datei von Silk Central, und doppelklicken Sie auf die Datei.
    Der InstallShield-Assistent wird geöffnet.
  2. Folgen Sie den Anweisungen des Installationsassistenten und klicken Sie auf den Dialogen jeweils auf Next oder OK.
  3. Lassen Sie auf dem Dialog Select Licensing Mode die Standardeinstellung auf Evaluation. Silk Central benötigt ein Datenbank-Repository. Für Evaluationszwecke empfehlen wir die Verwendung von Microsoft SQL Server Express, welches als Teil von Silk Central installiert werden kann. Stellen Sie sicher, dass das Kontrollkästchen Install Microsoft SQL Server 2008 Express SP1 aktiviert ist.
  4. Klicken Sie auf Next um die Installation abzuschließen.
Übergeordnetes Thema: Installieren von Silk Central
Zugehörige Konzepte
Systemanforderungen und Voraussetzungen
Silk Central


Installieren von Silk Central

Laden Sie zuerst die ausführbare Datei von Silk Central herunter, oder legen Sie die Silk Central-DVD in das DVD-Laufwerk ein. Stellen Sie sicher, dass Ihr System die Systemanforderungen und Voraussetzungen erfüllt.

  1. Suchen Sie die ausführbare Datei von Silk Central, und doppelklicken Sie auf die Datei.
    Wenn Sie die Silk Central-DVD verwenden, legen Sie die DVD ein. Wenn das Silk Central-Installationsprogramm nicht automatisch gestartet wird, wählen Sie Start > Ausführen, und geben Sie <DVD-Laufwerk>:\setup.exe ein. Der InstallShield-Assistent wird geöffnet.
  2. Der Begrüßungsbildschirm des Assistenten wird geöffnet. Der Assistent führt Sie durch die verschiedenen Installationsschritte. Klicken Sie auf Weiter.
  3. Wählen Sie die gewünschte Sprache aus, und klicken Sie dann auf Next. Das Fenster License Agreement wird angezeigt.
  4. Lesen Sie die Lizenzvereinbarung sorgfältig durch. Wenn Sie mit den Bestimmungen einverstanden sind, klicken Sie auf I accept the terms of the license agreement.
    Die Seite Setup Type wird geöffnet.
  5. Um den Silk Central-Ausführungsserver zu installieren, aktivieren Sie das Kontrollkästchen Install Execution Server. Um Microsoft Internet Information Services (IIS) zu verwenden, haken Sie das Kontrollkästchen Use Microsoft Internet Information Services an. Das Standardinstallationsziel wird im Bereich Destination path des Dialogs Setup Type angezeigt. Wenn Sie das Standardinstallationsverzeichnis ändern möchten, führen Sie die folgenden Schritte aus:
    1. Klicken Sie auf Durchsuchen. Der Dialog Ordner auswählen wird angezeigt.
    2. Wählen Sie das Installationsverzeichnis für Silk Central aus, und klicken Sie auf OK, um zum Dialogfeld Setup-Typ zurückzukehren.
    Anmerkung: Silk Central muss auf einem lokalen Laufwerk installiert werden. Wenn Sie ein ungültiges Installationsziel auswählen, wird eine Fehlermeldung angezeigt.
  6. Klicken Sie auf Weiter. Der Dialog Installation Options Summary wird mit den ausgewählten Installationsoptionen angezeigt.
  7. Überprüfen Sie die Informationen, und führen Sie einen der folgenden Schritte aus:
    • Wenn Sie Einstellungen ändern möchten, klicken Sie auf Back, um zum entsprechenden Dialog zurückzukehren.
    • Wenn Sie mit den Einstellungen zufrieden sind, klicken Sie auf Next, um mit der Installation zu beginnen.
    In der Statusleiste des Dialogs Setup Status werden Informationen zum Installationsvorgang angezeigt. Nach Abschluss der Installation wird der Dialog Select licensing mode angezeigt.
  8. Klicken Sie auf eins der folgenden Optionsfelder:
    • Evaluation – Installiert eine Testversion von Silk Central, die für einen Zeitraum von 45 Tagen alle Funktionen des Produkts uneingeschränkt zur Verfügung stellt. Die Verwendung ist auf zehn Silk Central-Benutzer und zehn Issue Manager-Benutzer beschränkt. Wenn Sie später auf die Vollversion upgraden möchten, wenden Sie sich an den Vertriebsbeauftragten. Aktivieren Sie das Kontrollkästchen Install Microsoft SQL Server 2008 Express SP1 um auch Microsoft SQL Server 2008 Express SP1 zu installieren.
    • Licensed – Installiert die Vollversion von Silk Central, für die eine Lizenz benötigt wird.
  9. Klicken Sie auf Weiter.
    Je nach den zur Installation ausgewählten Komponenten wird der Lizenz-Dialog geöffnet. Wenn Sie keine der Komponenten, für die eine Lizenzierung erforderlich ist, installiert haben, und der Dialog nicht geöffnet wird, fahren Sie mit dem nächsten Schritt fort. Führen Sie zur Installation der Lizenzdatei die folgenden Schritte durch:
    1. Klicken Sie auf OK, um das Verzeichnis mit der Lizenzdatei anzugeben. Das lokale System wird nach den Konfigurationsdateien für den Silk Meter-Lizenzserver durchsucht. Wenn das Programm die Dateien findet, werden die Konfiguration und der Typ des Lizenzservers angezeigt und für die Lizenzierung verwendet. Werden keine Konfigurationsdaten gefunden, wird der Dialog Select Silk Meter License Server mit den Standardeinstellungen geöffnet. Dieser Dialog enthält allgemeine Informationen zur Silk Meter-Lizenzierung. Detaillierte Informationen zur Silk Meter-Lizenzierung erhalten Sie, wenn Sie auf Open Silk Meter ReadMe klicken. Mit dieser Aktion öffnen Sie die Silk Meter-Dokumentation in Ihrem Standardbrowser.
      Anmerkung: Open Silk Meter ReadMe ist nicht verfügbar, wenn sich das Dokument nicht im Installationsverzeichnis befindet. Dieses Dokument steht nicht zur Verfügung, wenn ein Silk Central-Webpaket installiert wird.
    2. Wählen Sie in dem Listenfeld Application Silk Central als zu lizenzierende Anwendung aus.
    3. Klicken Sie auf eins der folgenden Optionsfelder:
      Lokalen oder Remote-Server verwenden
      Geben Sie in das Feld License Server Host den Namen des Computers ein, auf dem Silk Meter installiert ist. Ändern Sie den Standardwert für die Port-Nummer 5461 nur, wenn Ihr Netzwerkadministrator einen anderen Port konfiguriert hat. Klicken Sie auf Apply, um die Lizenzserverkonfiguration zu erzeugen. Klicken Sie auf Test Connection, um zu überprüfen, ob die Kommunikation mit dem Silk Meter-Server auf dem angegebenen Host über den konfigurierten Port möglich ist. Möglicherweise schlägt der Test der Verbindung mit dem Lizenzserver fehl, da zu diesem Zeitpunkt erforderliche Systembibliotheken noch nicht verfügbar sind. Die Bibliotheken werden erst später installiert.
      Anmerkung: Manchmal reicht die Angabe des Hostnamens für den Lizenzserver im Feld License Server Host, z. B. Lizenzserver, nicht aus. In diesem Fall wird gemeldet: There is no license server running on the hostname you specified. Geben Sie dann statt des Hostnamens den vollständigen Namen ein, z. B. licenseserver.mycompany.com.
      Server wird nicht verwendet (Einzelplatz)
      Führt Silk Meter als eigenständige Anwendung aus. Sie werden aufgefordert, eine Silk Meter-Lizenz zu importieren. Klicken Sie auf OK, und geben Sie das Verzeichnis mit der Lizenzdatei an.
    4. Klicken Sie auf Schließen, um wieder zum InstallShield-Assistent zurückzukehren.
  10. Klicken Sie auf Finish, um die Installation abzuschließen.
    Anmerkung: Wenn der InstallShield-Assistent eine Datei während der Installation nicht aktualisieren konnte, weil eine Systembibliothek von Windows gesperrt war oder der InstallShield-Assistent feststellt, dass das System neu gestartet werden muss, werden Sie aufgefordert, den Computer neu zu starten. Falls Sie den Computer nicht neu starten, können beim Zugriff auf Silk Central Probleme auftreten.

Der Dialog Instanzen-Verwaltung wird angezeigt, mit dem Sie Ihre Silk Central-Installation konfigurieren können. Weitere Information finden Sie unter Verwalten von Instanzen.

Übergeordnetes Thema: Installieren von Silk Central
Zugehörige Konzepte
Systemanforderungen und Voraussetzungen
Silk Central
Verwalten von Instanzen


Installieren eines Windows-Ausführungsservers

Installieren Sie einen Ausführungsserver auf jedem Computer, der als entfernter Silk Central-Ausführungsserver verwendet werden soll. Mit diesem Server werden die Silk Central-Tests auf entfernten Computern ausgeführt.

  1. Klicken Sie im Silk Central-Menü auf Hilfe > Tools > Windows-Ausführungsserver, und laden Sie das Windows-Ausführungsserverpaket herunter.
  2. Suchen Sie die ausführbare Datei von Silk Central, und doppelklicken Sie auf die Datei.
    Der InstallShield-Assistent wird geöffnet.
  3. Folgen Sie der Anleitung des Installationsassistenten.
  4. Klicken Sie auf Finish, um die Installation abzuschließen.
    Anmerkung: Wenn der InstallShield-Assistent eine Datei während der Installation nicht aktualisieren konnte, weil eine Systembibliothek von Windows gesperrt war oder der InstallShield-Assistent feststellt, dass das System neu gestartet werden muss, werden Sie aufgefordert, den Computer neu zu starten. Falls Sie den Computer nicht neu starten, können beim Zugriff auf Silk Central Probleme auftreten.
Übergeordnetes Thema: Installieren von Silk Central
Zugehörige Konzepte
Einrichten von Ausführungsservern
Systemanforderungen und Voraussetzungen
Zugehörige Tasks
Installieren eines Linux-Ausführungsservers


Installieren eines Linux-Ausführungsservers

Diese Anleitung ist für Silk Central-Benutzer gedacht, die Linux verwenden.

Installieren Sie einen Ausführungsserver auf jedem Computer, der als entfernter Silk Central-Ausführungsserver verwendet werden soll. Mit diesem Server werden die Silk Central-Tests auf entfernten Computern ausgeführt.

  1. Klicken Sie im Silk Central-Menü auf Hilfe > Tools > Linux-Ausführungsserver, und laden Sie das Linux-Ausführungsserverpaket herunter.
    Anmerkung: Das Linux-Ausführungsserverpaket enthält keine JRE. Stellen Sie sicher, dass Java Runtime Environment (JRE) 8 installiert ist. Sie können JRE unter Java SE Downloads herunterladen.
  2. Entpacken Sie die Datei tar.gz mit dem folgenden Befehl:
    gzip -d <Paket-Dateiname>.tar.gz

    Entpacken Sie dann die tar-Datei mit dem folgenden Befehl:

    tar xfz <Paket-Dateiname>.tar

    Der Name der Paketdatei ist LinuxExecServer-<Version>.

  3. Mit dem folgenden Befehl wechseln Sie in das Verzeichnis, in das die Paket-Datei extrahiert wurde:
    cd LinuxExecServer
  4. Starten Sie den Ausführungsserver mit dem folgenden Befehl:
    ./startExecServer.sh
    Anmerkung: Zwischengespeicherte Informationen und Log-Dateien werden in dem verborgenen Ordner ~/.LinuxExecServer-<version> in Ihrem Benutzerverzeichnis gespeichert. Auf die Log-Datei ExecServer.log kann auch über die Weboberfläche von Silk Central zugegriffen werden.
Anmerkung: Für Linux-Ausführungsserver werden gegenwärtig die Versionsverwaltungssysteme Subversion, Git und das virtuelle Dateisystem (VFS) von Apache Commons unterstützt.
Tests, die mit den folgenden Technologien erstellt wurden, werden bei der Ausführung auf einem Linux-Ausführungsserver nicht unterstützt:
  • Alle Silk Test-Technologien
  • .NET Explorer
  • Unified Functional Testing
  • MSTest
  • NUnit
  • Silk Performer
  • TestPartner
  • Windows Script Host
Diese Testtypen sind spezifisch für das Betriebssystem Microsoft Windows.
Übergeordnetes Thema: Installieren von Silk Central
Zugehörige Konzepte
Einrichten von Ausführungsservern
Zugehörige Tasks
Installieren eines Windows-Ausführungsservers


Installieren von einem Hotfix

Aktualisieren Sie Ihre Instanzen auf den aktuellsten Hotfix, wenn ein neuer Hotfix verfügbar ist.
  1. Suchen Sie auf dem Computer wo Silk Central installiert ist die ausführbare Datei, und doppelklicken Sie auf die Datei.
  2. Folgen Sie der Anleitung des Installationsassistenten.
  3. Wenn die Installation abgeschlossen wurde, öffnen Sie einen Browser und gehen Sie zur URL http://localhost:19100/ (falls sich die Seite nicht automatisch öffnet).
    Anmerkung: Die Seite Instanzen-Verwaltung ist nicht von einem anderen Rechner aus erreichbar.
    Die Seite Instanzen-Verwaltung wird geöffnet. Nun sollten Sie Ihren Browser-Cache zurücksetzen, sonst könnten Aktualisierungen in JavaScript und in den Stylesheets nicht aktiviert werden.
  4. Klicken Sie in der Spalte Version auf Hotfix <Version> installieren um die Aktualisierung zu starten. Ein Dialog zum Aktivieren des Wartungs-Modus wird angezeigt.
  5. Geben Sie einen Text ein, den Anwender sehen sollen wenn Sie versuchen Silk Central zu erreichen , zum Beispiel: Silk Central ist zur Zeit nicht verfügbar, da wir Wartungsarbeiten durchführen. Das System wird in Kürze wieder verfügbar sein. Klicken Sie auf Ja um den Wartungs-Modus zu aktivieren und die Aktualisierung zu starten.
  6. Nachdem die Aktualisierung abgeschlossen wurde, klicken Sie auf Starten um die Instanz wieder zu starten.
Wiederholen Sie die Instanzen-Verwaltung-Schritte für alle Instanzen, die Sie aktualisieren möchten.
Tipp: Erinnern Sie Ihre Benutzer daran, dass sie ihren Browser-Cache zurücksetzen, sonst könnten Aktualisierungen in JavaScript und in den Stylesheets nicht aktiviert werden.
Übergeordnetes Thema: Installieren von Silk Central
Übergeordnetes Thema: Verwalten von Instanzen


Aktualisieren auf Silk Central 18.5

Das Silk Central 18.5 Setup Programm entfernt automatisch die bestehende Installation, bevor es auf Silk Central 18.5 aktualisiert. Verwenden Sie nicht die Windows-Funktionalität Programme ändern oder entfernen, um die bestehende Silk Central-Installation zu entfernen, da sonst Ihre modifizierten Konfigurationsdateien gelöscht werden.

  1. Erstellen Sie vor dem Upgrade eine Sicherungskopie der Silk Central-Datenbank.
  2. Machen Sie eine Sicherungskopie Ihres Zertifikats, wenn Sie SSL aktiviert haben. Je nachdem in welchem Modus Sie Ihren Front-End-Server betreiben, müssen Sie das Zertifikat erneut in einen der folgenden Keystores importieren:
    • Im 64-Bit Modus: C:\Program Files (x86)\18.5\Silk Central Silk\instance_<Instanznummer>_<Instanzname>\lib\jre64\lib\security\cacerts
    • Im 32-Bit Modus: C:\Program Files (x86)\18.5\Silk Central Silk\instance_<Instanznummer>_<Instanzname>\lib\jre\lib\security\cacerts
    Weitere Informationen finden Sie unter Sichere Webserververbindungen mit SSL aktivieren.
  3. Installieren Sie Silk Central. Dadurch wird der NGINX-Proxy und die Instanzen-Verwaltung installiert. Sie können zusammen mit diesen Komponenten auch einen Ausführungsserver auf demselben Computer installieren. Die Datenbankeinstellungen werden automatisch aktualisiert. Nähere Informationen zu den erweiterten Einstellungen in den Konfigurationsdateien finden Sie unter Konfigurieren erweiterter Einstellungen.
    Anmerkung: Bei großen Datenbanken kann eine zu kleine Transaktionsprotokolldatei während des Updates zu einem Fehler führen. Sie verhindern dies, indem Sie für die Transaktionsprotokolldatei eine Größe von 5 GB festlegen.
  4. Wenn die Installation abgeschlossen wurde, öffnen Sie einen Browser und gehen Sie zur URL http://localhost:19100/ (falls sich die Seite nicht automatisch öffnet).
    Anmerkung: Die Seite Instanzen-Verwaltung ist nicht von einem anderen Rechner aus erreichbar.
    Die Seite Instanzen-Verwaltung wird geöffnet. Nun sollten Sie Ihren Browser-Cache zurücksetzen, sonst könnten Aktualisierungen in JavaScript und in den Stylesheets nicht aktiviert werden.
  5. Klicken Sie in der Spalte Version auf Upgrade auf <Version> um die Aktualisierung zu starten. Ein Dialog zum Aktivieren des Wartungs-Modus wird angezeigt.
  6. Geben Sie einen Text ein, den Anwender sehen sollen wenn Sie versuchen Silk Central zu erreichen , zum Beispiel: Silk Central ist zur Zeit nicht verfügbar, da wir Wartungsarbeiten durchführen. Das System wird in Kürze wieder verfügbar sein. Klicken Sie auf Ja um den Wartungs-Modus zu aktivieren und die Aktualisierung zu starten.
  7. Nachdem die Aktualisierung abgeschlossen wurde, klicken Sie auf Starten um die Instanz wieder zu starten.
Wiederholen Sie die Instanzen-Verwaltung-Schritte für alle Instanzen, die Sie aktualisieren möchten.
Tipp: Erinnern Sie Ihre Benutzer daran, dass sie ihren Browser-Cache zurücksetzen, sonst könnten Aktualisierungen in JavaScript und in den Stylesheets nicht aktiviert werden.
Übergeordnetes Thema: Installieren von Silk Central
Zugehörige Konzepte
Verbinden mit einer Datenbank
Zugehörige Tasks
Installieren von Silk Central
Installieren eines Windows-Ausführungsservers
Installieren eines Linux-Ausführungsservers


Silk Central

In diesem Abschnitt wird beschrieben, wie Sie ein Lizenzierungsschema für Silk Central abrufen und Silk Meter installieren. Sie benötigen zur Installation von Silk Meter Administratorrechte.

Anmerkung: Silk Central erfordert Silk Meter-Version 2008 oder höher sowie ein Silk Central-Lizenzierungsschema.

Installieren Sie Silk Meter einmal pro Lizenzserver. Wenn mehrere Lizenzserver vorhanden sind, werden entsprechend viele Lizenzierungsschemadateien benötigt (eine pro Lizenzserver). Ein Silk Meter-Lizenzserver kann Lizenzierungsschemas für mehrere Produkte verwalten.

Wenn Sie bereits ein Silk Central-Lizenzierungsschema erhalten haben, installieren Sie das Lizenzierungsschema auf Ihrem Lizenzserver. Wenn Sie noch kein Lizenzierungsschema erhalten haben, erzeugen Sie ein Lizenzierungsschema.

  • Lizenzverarbeitung
    Beschreibt die Lizenztypen, die in Silk Central verwendet werden, und wann Lizenzen ein- und ausgecheckt werden.
  • Erzeugen eines Silk Central-Lizenzierungsschemas
    Erstellen Sie ein Lizenzierungsschema für Silk Central, das in Silk Meter importiert werden kann.
  • Ermitteln der Hostkennung
    Ermitteln Sie die Hostkennung des Computers, auf dem Sie die Lizenzen installieren möchten. Die Hostkennung wird benötigt, um eine Silk Central-Lizenzierungsschema-Datei zu erhalten.
  • Installieren von Silk Meter
    Hier wird beschrieben, was Sie vor der Installation der Silk Meter-Lizenzserversoftware wissen müssen.
  • Silk Meter-Lizenzserverkonfiguration
    Erklärt die Silk Meter-Lizenzserverkonfiguration.
  • Ändern der Lizenzserverkonfiguration
    Bearbeiten Sie die Lizenzserverkonfiguration, wenn sich der Hostname oder der Port Ihres Silk Meter-Lizenzservers ändert.
Übergeordnetes Thema: Installieren von Silk Central
Zugehörige Tasks
Installieren von Silk Meter auf dem Lizenzserver


Lizenzverarbeitung

Silk Central bietet verschiedene Lizenztypen.

Benutzerbasierte Lizenzen

Diese Lizenzen werden vom Lizenzserver ausgecheckt, sobald ein Benutzer in einen bestimmten Bereich von Silk Central gelangt:

Lizenztyp | Bereich
Testmanager | Diese Lizenz wird ausgecheckt, wenn Sie nach Ihrer Anmeldung erstmalig auf einen Testmanagementbereich klicken. Die Silk Central-Testmanagementbereiche sind: Anforderungen, Tests, Ausführungsplanung, Verfolgung, Fehler (mit Ausnahme des Issue Manager-Bereichs) und Berichte.
Manuelles Testen | Diese Lizenz wird ausgecheckt, wenn Sie das Fenster Manuelles Testen öffnen. Eine Lizenz für manuelles Testen wird ausgecheckt sobald ein Test für die Offline-Ausführung heruntergeladen wird. Die Lizenz wird wieder eingecheckt sobald die Ergebnisse hochgeladen werden.
Fehlerverfolgung | Diese Lizenz wird ausgecheckt, wenn Sie auf Issue Manager zugreifen.
Beachten Sie Folgendes:
  • Wenn Sie auf Abmelden (Benutzer > Abmelden) klicken, werden die Lizenzen wieder am Lizenzserver eingecheckt, mit Ausnahme der Lizenzen für manuelles Testen, die zur Offline-Testausführung ausgecheckt wurden.
  • Wenn Sie sich nicht abmelden (sondern nur das Browserfenster schließen), wird die Lizenz erst bei Ablauf der Sitzung eingecheckt.

Die Seite Info (Hilfe > Info) zeigt an, wie viele Lizenzen derzeit verwendet werden und wie viele für den Mandanten verfügbar sind, auf dem Sie gerade eingeloggt sind.

Standort-Lizenzen

Diese Lizenzen schalten eine bestimmte Funktionalität für alle Benutzer frei, ohne Einschränkungen:

Lizenztyp | Bereich
Mobiles Testen | Diese Lizenz ermöglicht das Testen auf mobile Geräten (physische Geräte, Emulatoren und Simulatoren) für manuelles, automatisiertes und Konfigurationstesten.
Übergeordnetes Thema: Silk Central
Übergeordnetes Thema: Mandanten
Zugehörige Konzepte
Verwalten von Geräte-Anbietern
Zugehörige Tasks
Erstellen von Mandanten
Bearbeiten von Mandanten


Erzeugen eines Silk Central-Lizenzierungsschemas

Um Silk Central auszuführen, benötigen Sie eine gültige Lizenz. Wenn Sie Silk Central bereits erworben haben, können Sie mit unserem Online-Lizenzerzeugungsprogramm eine Lizenzierungsschema-Datei generieren. Wenn Sie das Online-Lizenzerzeugungsprogramm verwenden möchten, benötigen Sie einen Browser mit SSL-Unterstützung, wie z. B. Firefox oder Internet Explorer. Sie erhalten E-Mail mit den Anweisungen, wie Sie Ihre Lizenzierungsschema-Datei erzeugen können. Sollten Sie diese Anweisungen nicht erhalten, wenden Sie sich an den Kundendienst unter http://support.microfocus.com.

Übergeordnetes Thema: Silk Central
Zugehörige Konzepte
Installieren von Silk Central
Zugehörige Tasks
Installieren von Silk Meter auf dem Lizenzserver


Ermitteln der Hostkennung

Um eine Lizenzierungsschema-Datei zu erhalten, benötigen Sie die Hostkennung des Computers, auf dem Sie die Lizenzen installieren möchten. Für Floating-Lizenzen ist dies ein Rechner, auf dem Silk Meter installiert ist. Für Node-locked-Lizenzen ist es üblicherweise der Controller-Rechner.

  1. Öffnen Sie auf dem Rechner ein Befehlsfenster, und geben Sie ipconfig/all ein. Die Netzwerkadapter werden aufgelistet, sowie weitere Informationen.
  2. Notieren Sie die Hostkennung, die die MAC-Adresse oder die Physische Adresse Ihrer LAN-Karte ist, wie z. B. 00-BF-00-1C-D3-3D.
    Tipp: Je nachdem, wie Ihr System eingerichtet ist (virtuelle Maschinen, VPN-Verbindungen usw), kann Ihr Computer mehrere Netzwerkadapter mit unterschiedlichen MAC-Adressen haben. Notieren Sie unbedingt die Hostkennung Ihrer physischen LAN-Karte.
Übergeordnetes Thema: Silk Central


Installieren von Silk Meter

Wenn Sie bereits über eine Lizenzierungsschema-Datei für Silk Central verfügen, können Sie sie zusammen mit Silk Meter installieren. Wenn Sie keine gültige Silk Central Lizenz haben, können Sie mit unserem Online-Lizenzerzeugungsprogramm eine Lizenzierungsschema-Datei generieren.

Für die Installation und das Ausführen von Silk Meter auf Ihrem Lizenzserver wird keine Lizenzierungsschema-Datei benötigt. Sie können Silk Central jedoch erst verwenden, nachdem Sie die Lizenzierungsschema-Datei importiert haben. Eine Lizenzierungsschema-Datei kann mit dem Silk Meter Policy Administrator importiert werden.

Wenn mehrere Lizenzserver vorhanden sind, werden entsprechend viele Lizenzierungsschemadateien benötigt (eine pro Lizenzserver). Ein Silk Meter-Lizenzserver kann Lizenzierungsschema-Dateien für mehrere Produkte verwalten.

Lizenzserver Voraussetzungen für Silk Meter

Überprüfen Sie vor der Installation von Silk Meter die Versionshinweise, um sicherzustellen, dass der Lizenzserver die Anforderungen erfüllt.

  • Deinstallieren einer vorhergehenden Version von Silk Meter
    Deinstallieren Sie Silk Meter, bevor Sie die aktuelle Version installieren.
  • Installieren von Silk Meter auf dem Lizenzserver
    Installieren Sie die Silk Meter-Lizenzsoftware, um Ihre Silk-Produkte zu lizensieren.
Übergeordnetes Thema: Silk Central
Zugehörige Tasks
Erzeugen eines Silk Central-Lizenzierungsschemas


Deinstallieren einer vorhergehenden Version von Silk Meter

Falls Silk Meter bereits auf dem Lizenzserver installiert ist, müssen Sie das Programm deinstallieren, bevor Sie die aktuelle Version von Silk Meter installieren.

  1. Wählen Sie Start > Programme > Silk > Silk Meter > Uninstall.
  2. Klicken Sie auf Ja, um Silk Meter zu deinstallieren. Das Dialogfeld Einstellungen entfernen wird angezeigt.
  3. Klicken Sie auf Nein, damit Ihre Silk Meter-Einstellungen erhalten bleiben.
    Achtung: Klicken Sie auf Nein, damit die aktuell auf dem Silk Meter-Lizenzserver vorhandenen Lizenzierungsschemas erhalten bleiben.
  4. Starten Sie den Computer neu.
Silk Meter ist deinstalliert. Sie können jetzt die aktuelle Version von Silk Meter installieren.
Übergeordnetes Thema: Installieren von Silk Meter


Installieren von Silk Meter auf dem Lizenzserver

Überprüfen Sie vor der Installation von Silk Meter die folgenden Informationen:
  • Ihr Benutzerkonto verfügt über Administratorrechte.
  • Auf Ihrem Lizenzserver ist keine Instanz von Silk Meter installiert.
  1. Besuchen Sie die Product Updates Seite und suchen Sie nach Silk Meter.
  2. Laden Sie die aktuellsten Silk MeterInstallationsdateien herunter.
  3. Wechseln Sie zu dem Verzeichnis, in dem Sie die .exe-Datei gespeichert haben. Wenn Sie eine Standardinstallation durchführen möchten, folgen Sie einfach den Schritten des Silk Meter-Installationsassistenten und belassen Sie jeweils die Standardeinstellungen.
    Wichtig: Starten Sie den Computer neu, sobald Sie dazu aufgefordert werden.
Übergeordnetes Thema: Installieren von Silk Meter
Zugehörige Tasks
Erzeugen eines Silk Central-Lizenzierungsschemas


Silk Meter-Lizenzserverkonfiguration

Zur Ausführung jeder Version von Silk Central, muss Silk Meter auf einem Computer im Netzwerk installiert und konfiguriert werden.

Für die Kommunikation zwischen Silk Central und Silk Meter sind folgende Dateien und Variablen erforderlich:
  • SILK_CONFIG_PATH Umgebungsvariable
  • CosLicensingService.ref Datei
  • CosPropertyService.ref Datei
  • ls_segue.ref Datei
  • silkmeter.cfg Datei
Wichtig: Löschen Sie diese Dateien auf keinen Fall.

Das Silk Central-Installationsprogramm erstellt diese Objekte anhand der von Ihnen im Dienstprogramm Select Silk Meter License Server eingegebenen Werte.

Übergeordnetes Thema: Silk Central
Zugehörige Konzepte
Installieren von Silk Central


Ändern der Lizenzserverkonfiguration

Mit dem Dienstprogramm Select Silk Meter License Server kann die Lizenzserverkonfiguration geändert oder repariert werden. Dieses Werkzeug wird zusammen mit Silk Central installiert.

  1. Wählen Sie Start > Programme > Silk > Silk Central 18.5 > Verwaltungswerkzeuge > Lizenzserverkonfiguration auswählen. Das Dienstprogramm Select Silk Meter License Server wird geöffnet.
  2. Wählen Sie im Listenfeld Anwendung das Produkt, für das Sie den Lizenzserver konfigurieren möchten.
  3. Klicken Sie auf das Optionsfeld Lokalen oder Remote-Server verwenden, um einen Silk Meter-Lizenzserver zu konfigurieren.
  4. Geben Sie im das Feld License Server Host den Namen des Computers des Silk Meter-Lizenzservers ein. Der Wert im Feld Port-Nummer sollte nur geändert werden, wenn Ihr Netzwerkadministrator einen anderen Port konfiguriert hat.
  5. Klicken Sie auf Apply, um die Lizenzserverkonfiguration zu aktivieren.
  6. Klicken Sie auf Test Connection, um zu überprüfen, ob die Kommunikation mit dem Silk Meter-Server auf dem angegebenen Host über den konfigurierten Port möglich ist. Wenn die Verbindung hergestellt werden konnte, wird im Feld Status eine SUCCESS-Meldung angezeigt.
    Anmerkung: Manchmal reicht die Angabe des Hostnamens für den Lizenzserver im Feld License server host, z. B. Lizenzserver, nicht aus. Die Meldung Connection to Silk Meter license server failed wird angezeigt. Geben Sie dann statt des Hostnamens den vollständigen Namen ein, z. B. licenseserver.mycompany.com.
  7. Klicken Sie auf Schließen, um die Lizenzserverkonfiguration fertig zu stellen.
Übergeordnetes Thema: Silk Central


Getestete und unterstützte Software

Dieser Abschnitt listet die Software auf, mit der Silk Central18.5 getestet wurde, sowie die Software, die von Silk Central unterstützt wird.

Unterstützte Betriebssysteme

  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2016
  • Microsoft Windows 7 32-Bit/64-Bit Service Pack 1 (Ausführungsserver)
  • Microsoft Windows 8,1 32-Bit/64-Bit (Ausführungsserver)
  • Microsoft Windows 10 32-Bit/64-Bit (Ausführungsserver)
  • Android 4.4, 5.x, 6.x, 7.x, 8.x (Testen auf mobilen Geräten)
  • iOS 9.3, 10.x, 11.x (Testen auf mobilen Geräten)
Wichtig: Update für universelle C RunTime in Windows wird für alle Microsoft Windows-Betriebssysteme benötigt. Für Microsoft Windows Server 2016 wird die Installationsoption Windows Server (Server mit Desktopdarstellung) benötigt.

Unterstützte Linux-Betriebssysteme

Silk Central unterstützt Linux-Betriebssysteme nur für den Ausführungsserver.

  • Debian
  • Redhat Enterprise Linux
  • Suse Linux
  • Ubuntu

Unterstützte Webbrowser

  • Google Chrome
  • Internet Explorer 10 oder höher (ohne Kompatibilitätsmodus)
  • Mozilla Firefox
  • Microsoft Edge

Unterstützte Webserver

  • IIS 8 32-Bit/64-Bit
  • IIS 10 32-Bit/64-Bit

Unterstützte Datenbankmanagementsysteme

  • Microsoft SQL Server 2012 Service Pack 3
  • Microsoft SQL Server 2014 Service Pack 2
  • Microsoft SQL Server 2016
  • Oracle 11g (Version 11.2.0.4)
  • Oracle 12c (Version 12.1.0.2)

Integrierte Softwareunterstützung für Micro Focus

  • AccuRev 6.2
  • Caliber 11.4, 11.5
  • Mobile Center 2.51 oder höher
  • Silk Performer 18.5
  • Silk Test 18.5
  • StarTeam 15.x, 16.x
  • Silk TestPartner 6.3
  • Unified Functional Testing (UFT) 14.0

Unterstützte integrierte Software von Drittanbietern

  • VFS (Apache Commons Virtual File System)
  • Atlassian JIRA 6, 7
  • Bugzilla 4.4.12, 5.0.3
  • CA Agile Central
  • Git 2.14.2
  • IBM Rational ClearQuest 8,0
  • IBM Rational DOORS 9.5, 9.6
  • IBM Rational DOORS Next Generation 6.0
  • IBM Rational RequisitePro 7.1.3, 7.1.4
  • JUnit 4.11 oder höher
  • Microsoft Office Excel (.xlsx) zum Importieren von Tests und Anforderungen
  • Microsoft Office Word (.doc, .docx) zum Importieren von Anforderungen
  • Microsoft Visual Studio/Visual Studio Test Agent 2012, 2013, 2015
  • NUnit 2.6.4, 3.4.1
  • SAP Solution Manager 7.1
  • Subversion 1,9
  • Team Foundation Server 2012, 2013, 2015
  • VersionOne Enterprise Edition
  • VMware vCloud Director 5.5
Übergeordnetes Thema: Installieren von Silk Central


Konfigurieren und Verwalten der Infrastruktur

Eine Instanz ist ein unabhängiges Set von Silk Central-Diensten (Anwendungsserver (AS), Front-End-Server (FE) und Diagrammserver (CS)), mit eigener Datenbank und eigenen Ausführungsservern (ES). Standardmäßig erstellt Silk Central eine einzelne Instanz namens silk für Sie. Die Standard-URL ist http://<Computername>:19120/login (keine Portinformationen nötig wenn Silk Central auf IIS läuft).

  • Aufsetzen eines sicheren Silk Central-Systems
    Hier wird beschrieben, wie ein sicheres Silk Central-System aufgesetzt wird.
  • Verwalten von Instanzen
    Verwalten Sie Ihre Silk Central-Instanzen, fügen Sie neue hinzu oder löschen Sie welche.
  • Verwalten von Mandanten
    Der Bereich Systemverwaltung ist eine eigenständige Umgebung, in der die Mandanten von Silk Central konfiguriert werden.
  • Konfigurieren erweiterter Einstellungen
    Hier wird beschrieben, wie erweiterte Einstellungen zur Anpassung Ihres Silk Central-Systems konfiguriert werden.
Übergeordnetes Thema: Installations- und Systemkonfigurationshilfe


Aufsetzen eines sicheren Silk Central-Systems

Hier wird beschrieben, wie ein sicheres Silk Central-System aufgesetzt wird.
  • Allgemeine Richtlinien
    Nachdem Sie Silk Central installiert haben, sollten Sie folgende Richtlinien beachten, um Silk Central in einer sicheren Umgebung zu betreiben.
  • Sichere Webserververbindungen mit SSL aktivieren
    Wenn sich Ihre Benutzer nur über eine sichere Verbindung (SSL) zu Silk Central verbinden können sollen, aktivieren Sie SSL (Secure Sockets Layer) in Silk Central.
  • BIRT-Berichte in SSL-Umgebungen aktivieren
    Nachdem Sie Silk Central für die Verwendung einer sicheren Webserververbindung mit SSL konfiguriert haben, müssen BIRT-Berichte für diese Umgebung aktiviert werden.
  • Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver
    Konfigurieren Sie einen benutzerdefinierten SSL-Port, über den der Anwendungsserver mit einem Ausführungsserver kommuniziert.
  • Deaktivieren nicht verwendeter Ports auf Ausführungsservern
    Deaktivieren Sie Ports, die von Ausführungsservern nicht verwendet werden.
  • Kommunikation mit einem externen System über SSL
    Fügen Sie ein selbstsigniertes Zertifikat zu dem standardmäßigen Java-Keystore hinzu, um mit einem Host mit einem selbstsignierten Zertifikat über SSL zu kommunizieren.
Übergeordnetes Thema: Konfigurieren und Verwalten der Infrastruktur


Allgemeine Richtlinien

Nachdem Sie Silk Central installiert haben, sollten Sie folgende Richtlinien beachten, um Silk Central in einer sicheren Umgebung zu betreiben.
  • Ändern Sie zuerst das Kennwort des sysadmin-Benutzers. Weitere Informationen finden Sie unter Systemadministrator.
  • Konfigurieren Sie die LDAP-Authentifizierung, damit sich Benutzer über einen LDAP-Server bei Silk Central anmelden können. Weitere Informationen finden Sie unter LDAP-Authentifizierung.
  • Falls mehrere Gruppen mit Silk Central,arbeiten werden, stellen Sie sicher, dass Ihre Benutzer nur die Daten sehen können, die sie auch sollen. Richten Sie hierzu Instanzen oder Mandanten ein. Detaillierte Informationen hierzu finden Sie unter Verwalten von Instanzen und Verwalten von Mandanten.
  • Um sicherzustellen, dass Berichte mit erweiterten Abfragen keine Daten in der Datenbank verändern können, ziehen Sie in Betracht einen Datenbank-Benutzer für Lesezugriff zu erstellen und zu verwenden. Weitere Informationen finden Sie unter Datenbank (Seite).
  • Konfigurieren Sie Ihre Firewall so, dass nur von Silk Central verwendete Ports offen sind. Informationen über von Silk Central verwendete Ports finden Sie unter Silk Central-Architektur.
  • Machen Sie regelmäßig ein Backup Ihrer Datenbank.
  • Verwenden Sie die aktuellsten und unterstützen Betriebssystem-Versionen und stellen Sie sicher, dass regelmäßig Aktualisierungen durchgeführt werden.
  • Verwenden Sie die aktuellsten Versionen und Hotfixes von Silk Central. Registrieren Sie sich bei Micro Focus SupportLine unter http://supportline.microfocus.com, um die aktuellsten Neuigkeiten und andere Supportinformationen zu erfahren.
Übergeordnetes Thema: Aufsetzen eines sicheren Silk Central-Systems


Sichere Webserververbindungen mit SSL aktivieren

Wenn sich Ihre Benutzer nur über eine sichere Verbindung (SSL) zu Silk Central verbinden können sollen, aktivieren Sie SSL (Secure Sockets Layer) in Silk Central.

Weitere Informationen finden Sie unter Kommunikation mit einem externen System über SSL, BIRT-Berichte in SSL-Umgebungen aktivieren und Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver.

  1. Kopieren Sie Ihr Zertifikat und die Schlüsseldateien auf den Front-End-Server.
  2. Öffnen Sie die Datei nginx.conf.template im Ordner C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf mit einem Texteditor.
  3. Kommentieren Sie die folgenden Zeilen aus, indem Sie die #-Zeichen entfernen:
    #listen   443 ssl;
#ssl_protocols TLSv1.2 TLSv1.1 TLSv1;
#ssl_certificate    "C:/.../ssl/host.cert";
#ssl_certificate_key    "C:/.../ssl/host.key";
#add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
  4. Setzen Sie die Pfade für ssl_certificate und ssl_certificate_key auf den Ort wo Sie Ihr Zertifikat und die Schlüsseldateien hin kopiert haben. Geben Sie den entsprechenden Pfad mithilfe von Schrägstrichen statt Backslashes ein.
  5. Wenn Sie nur SSL-Verbindungen zulassen möchten, dass , kommentieren Sie die Zeile listen 19120; durch Hinzufügen von # aus.
  6. Optional: Um eine Weiterleitung vom unsicheren zum sicheren Port zu konfigurieren, fügen Sie eine neue server-Sektion mit der folgenden Syntax hinzu:
    server {
  listen <unsicherer Port>;
  server_name localhost;
  return 301 https://$host$request_uri;
  }
  7. Starten Sie den Silk Central Instanzen-Verwaltungsdienst mit dem Windows Dienstmanager neu.
Übergeordnetes Thema: Aufsetzen eines sicheren Silk Central-Systems


BIRT-Berichte in SSL-Umgebungen aktivieren

Nachdem Sie Silk Central für die Verwendung einer sicheren Webserververbindung mit SSL konfiguriert haben, müssen BIRT-Berichte für diese Umgebung aktiviert werden.
  1. Stoppen Sie über die Seite Instanzen-Verwaltung den Diagrammserverdienst der Instanz die Sie konfigurieren möchten.
  2. Verwenden Sie OpenSSL um mit der folgenden Befehlszeile einen PKCS #12 Keystore zu erstellen: openssl pkcs12 -export -in ./host.cert -inkey ./host.key > ./host.p12 Beispiel:
    openssl pkcs12 -export -in C:/ProgramData/SilkCentral/ssl/host.cert -inkey
C:/ProgramData/SilkCentral/ssl/host.key > C:/ProgramData/SilkCentral/ssl/host.p12
  3. Konvertieren Sie den Keystore host.p12 in einen Java-Keystore mit der folgenden Befehlszeile: keytool.exe -importkeystore -srckeystore ./host.p12 -destkeystore ./host.jks -srcstoretype pkcs12 Beispiel:
    "C:\Program Files (x86)\Silk\Silk Central
18.5\instance_1_silk\lib\jre\bin\keytool.exe"
-importkeystore -srckeystore C:/ProgramData/SilkCentral/ssl/host.p12 -destkeystore
C:/ProgramData/SilkCentral/ssl/host.jks -srcstoretype pkcs12
  4. Fügen Sie die folgenden Zeilen zur Konfigurationsdatei sc_ChartServer.processconfig des Diagrammservers hinzu, welche sich in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf befindet:
    <Service>
  <SystemProperties>
          ...
             <SystemProperty name="javax.net.ssl.trustStore" value="<Pfad zur host.jks-Datei>" />
             <SystemProperty name="javax.net.ssl.trustStorePassword" value="<Kennwort>" />
        </SystemProperties>
</Service>
    Beispiel:
    <Service>
  <SystemProperties>
          ...
             <SystemProperty name="javax.net.ssl.trustStore" value="C:/ProgramData/SilkCentral/ssl/host.jks" />
             <SystemProperty name="javax.net.ssl.trustStorePassword" value="changeit" />
        </SystemProperties>
</Service>
  5. Starten Sie den Diagrammserverdienst neu.
Übergeordnetes Thema: Aufsetzen eines sicheren Silk Central-Systems


Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver

Standardmäßig kommuniziert der Anwendungsserver über den SSL-Port 19125 mit den Ausführungsservern.

Anmerkung: Diese Schritte müssen für jeden Ausführungsserver durchgeführt werden, der über einen Nicht-Standard-SSL-Port angeschlossen werden soll.

So konfigurieren Sie einen benutzerdefinierten SSL-Port für einen Ausführungsserver:

  1. Deaktivieren Sie den Ausführungsserver, für den der SSL-Port konfiguriert werden soll.
  2. Halten Sie den Ausführungsserver an.
  3. Öffnen Sie die Datei SccExecServerBootConf.xml mit einem Texteditor. Diese Datei befindet sich auf dem Ausführungsserver im Ordner /conf/execserver des Silk Central-Verzeichnisses.
  4. Suchen Sie das XML-Tag <SSLPort>. Die Standardeinstellung dieses Tags lautet <19125>. Geben Sie die Portnummer ein, die Sie für die SSL-Kommunikation verwenden möchten.
  5. Speichern und schließen Sie die XML-Datei.
  6. Weisen Sie in Silk Central dem SSL-Port des Ausführungsservers den Wert zu, den Sie in der XML-Datei angegeben haben.
  7. Starten Sie den Ausführungsserver neu.
  8. Aktivieren Sie den Ausführungsserver wieder.
Übergeordnetes Thema: Aufsetzen eines sicheren Silk Central-Systems
Übergeordnetes Thema: Einrichten von Ausführungsservern
Zugehörige Tasks
Starten oder Stoppen eines lokalen Ausführungsserverdienstes
Aktivieren bzw. Deaktivieren von Ausführungsservern
Konfigurieren physischer Ausführungsserver


Deaktivieren nicht verwendeter Ports auf Ausführungsservern

Je nachdem, ob Sie eine SSL-Verbindung oder eine unsichere Verbindung zwischen dem Anwendungsserver und den Ausführungsservern verwenden, können Sie den jeweils nicht benötigten Port deaktivieren. Außerdem können Sie den Tomcat-Standardport deaktivieren, da dieser von Silk Central nicht genutzt wird.

Die folgenden Schritte müssen auf jedem Ausführungsserver durchgeführt werden, auf dem der nicht verwendete Port deaktiviert werden soll.

So deaktivieren Sie nicht verwendete Ports auf dem Ausführungsserver:

  1. Halten Sie den Ausführungsserver an.
  2. Öffnen Sie die Datei SccExecServerBootConf.xml in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5 Execution Server\conf\execserver auf dem Ausführungsserver.
  3. Suchen Sie die XML-Tags InsecurePort und SSLPort im Abschnitt RmiProxy der Datei.
  4. Das weitere Vorgehen hängt davon ab, ob Sie eine SSL- oder eine unsichere Verbindung zwischen dem Anwendungs- und dem Ausführungsserver eingerichtet haben:
    SSL-Verbindung
    Setzen Sie den InsecurePort-Wert auf 0.
    Unsichere Verbindung
    Setzen Sie den SSLPort-Wert auf 0.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Ausführungsserver neu.
Übergeordnetes Thema: Aufsetzen eines sicheren Silk Central-Systems
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Zugehörige Tasks
Verwalten von Instanzen


Kommunikation mit einem externen System über SSL

Falls das Zertifikat des Hosts, den Sie verbinden wollen, selbstsigniert ist, erhalten Sie eventuell die folgende Fehlermeldung:
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Anmerkung: Diese Fehlermeldung wird nicht für gültige Zertifikate angezeigt. Dies sind alle Zertifikate, die durch Zertifizierungsstellen signiert sind.

Um einen Server mit einem selbstsignierten Zertifikat zu verwenden, müssen Sie die folgenden Schritte vornehmen:

  1. Laden Sie das SSL-Zertifikat vom Server herunter. Verwenden Sie einen Browser, um das Zertifikat anzusehen und um es zu exportieren. Gehen Sie bei Mozilla Firefox zu Extras > Seiteninformationen > Sicherheit > Zertifikat anzeigen > Details > Exportieren.
  2. Starten Sie das Schlüssel- und Zertifikats-Managementtool Keytool. Keytool ist Teil Ihrer JRE-Installation und befindet sich in Ihrem JRE-Installationsverzeichnis, z.B. C:\Program Files (x86)\Silk\Silk Central <Version>\ instance_<Instanznummer>_<Instanzname>\lib\jre\bin. Weitere Informationen über Keytool finden Sie in der Java SE Technische Dokumentation.
  3. Um ein Zertifikat zu dem standardmäßigen Java-Keystore auf dem Front-End-Server und dem Anwendungsserver hinzuzufügen, geben Sie zum Beispiel den folgenden Befehl in Keytool ein:
    keytool
  -importcert
  -file CERTIFICATE.crt
  -keystore "C:\Program Files (x86)\Silk\Silk Central <version>\
   instance_<instance number>_<instance name>\lib\jre\lib\security\cacerts"
    Sie werden dann dazu aufgefordert, das Kennwort einzugeben.
  4. Geben Sie das standardmäßige Keystore-Kennwort ein, changeit.
  5. Starten Sie den Front-End-Server und den Anwendungsserver erneut, um den Keystore neu zu laden.
Übergeordnetes Thema: Aufsetzen eines sicheren Silk Central-Systems
Übergeordnetes Thema: Integrationen


Verwalten von Instanzen

Erstellen Sie zusätzliche Instanzen, wenn Sie die Testdaten und Testprozesse Ihrer Mandanten physisch trennen möchten. Dadurch wird die Datensicherheit erhöht und der Einfluss unabhängiger Benutzergruppen (z.B. Abteilungen) aufeinander reduziert. Durch Mandanten können Sie die Testdaten innerhalb einer Instanz zusätzlich logisch trennen.

Verwalten von Instanzen

Instanzen und deren Silk Central-Dienste werden über eine gemeinsame Benutzeroberfläche namens Instanzen-Verwaltung verwaltet, auf welche Sie über die URL http://localhost:19100 auf dem Server wo Silk Central installiert ist zugreifen können. Die Seite Instanzen-Verwaltung ist nicht von einem anderen Rechner aus erreichbar. Sie können folgende Aktionen für eine Instanz oder deren Dienste ausführen:
  • Klicken Sie auf Stopp oder Start, um einzelne Dienste anzuhalten oder wieder zu starten. Wenn Sie eine Instanz stoppen oder starten, werden sämtliche Dienste der Instanz angehalten/gestartet.
  • Klicken Sie auf Instanz löschen, um die Instanz zu löschen. Verwenden diese Option nur dann, wenn Sie sich absolut sicher sind, dass die Instanz nicht mehr benötigt wird! Diese Aktion löscht jedoch die Daten in der Datenbank nicht.
    Anmerkung: Um einen Ausführungsserver einem anderen Anwendungsserver zuzuweisen, müssen Sie die folgende Datei auf dem Computer löschen, auf dem der Ausführungsserver installiert ist: C:\ProgramData\SilkCentral\AgentBase\ItemObjects.ser.
  • Klicken sie auf Einstellungen, um die Instanz-Einstellungen zu konfigurieren.

Wartungs-Modus

Bevor Sie an einer Silk Central-Instanz Wartungsarbeiten vornehmen, während denen die Benutzer nicht mehr auf das System zugreifen können, können Sie Ihre Silk Central-Anwender im Voraus darüber informieren. Solche Wartungsarbeiten sind z.B. Die Installation eines Hotfixes oder die Einstellungen eines Dienstes zu ändern.
  1. Klicken sie auf der Seite Instanzen-Verwaltung auf Einstellungen, um den Dialog Einstellungen zu öffnen.
  2. Aktivieren Sie auf der Registerkarte Wartung das Kontrollkästchen Wartungs-Modus aktivieren.
  3. Geben Sie einen Text ein, den Anwender sehen sollen wenn Sie versuchen Silk Central zu erreichen , zum Beispiel: Silk Central ist zur Zeit nicht verfügbar, da wir Wartungsarbeiten durchführen. Das System wird in Kürze wieder verfügbar sein.
  4. Klicken Sie auf OK.
  5. Wenn Sie mit den Wartungsarbeiten fertig sind und alle Dienste wieder laufen, deaktivieren Sie den Wartungs-Modus so dass Ihre Anwender wieder auf Silk Central zugreifen können.

32-Bit-/64-Bit Modus

  1. Klicken sie auf der Seite Instanzen-Verwaltung auf Einstellungen, um den Dialog Einstellungen zu öffnen.
  2. Verwenden Sie die Modus-Liste der Instanz, um zu bestimmen ob die Front-End-, Anwendungs- und Ausführungsdienste im 32-Bit oder im 64-Bit-Modus laufen sollen. Beachten Sie bitte, dass Dienste nur im 64-Bit-Modus laufen können, wenn Sie auch ein 64-Bit-Betriebssystem verwenden. Wenn der Modus geändert wird, müssen die Instanzen-Dienste neu gestartet werden.
  3. Klicken Sie auf OK.

JMX-Messdaten

Wenn Sie über JMX auf Informationen zugreifen oder Aktionen ausführen möchten, benötigen Sie die JMX-Verbindung. Klicken Sie auf Einstellungen um den Einstellungen-Dialog zu öffnen. Wählen Sie auf der Registerkarte Server den gewünschten Server aus und kopieren Sie die JMX-Verbindung. Weitere Informationen finden Sie unter Konfigurieren der JMX-Einstellungen.

Erstellen einer neuen Instanz

Klicken Sie auf Neue Instanz, um eine weitere Instanz hinzuzufügen. Geben Sie der Instanz einen aussagekräftigen Namen, da dieser verwendet wird um die Dienste und Dateien der Instanz zu identifizieren. Er wird auch ein Teil der URL sein über die die Anwender auf die Instanz zugreifen.

Für jede zusätzliche Instanz werden mindestens 10 GB zusätzlicher Festplattenplatz benötigt, sowie mindestens der folgende initiale Systemspeicher:
  • Front-End-Server: 500 MB
  • Anwendungsserver: 300 MB
  • Diagrammserver: 200 MB
Je nach Ihrem Workload könnten diese Werte noch höher sein.

Weitere Informationen zur optimalen Konfiguration von Silk Central erhalten Sie vom technischen Support oder Ihrem Technical Account Team.

  • Installieren von einem Hotfix
    Aktualisieren Sie Ihre Instanzen auf den aktuellsten Hotfix, wenn ein neuer Hotfix verfügbar ist.
  • Starten oder Stoppen eines lokalen Ausführungsserverdienstes
    Verwenden Sie den Silk Central Service Manager um einen lokal installierten Ausführungsserverdienst zu starten oder zu stoppen.
  • Lastausgleichsmechanismus für Front-End-Server
    Der Lastausgleichsmechanismus wird verwendet um die Last (Datenverkehr auf der Website) auf mehrere Server zu verteilen, wodurch eine Leistungs- und Zuverlässigkeitssteigerung ermöglicht wird.
Übergeordnetes Thema: Konfigurieren und Verwalten der Infrastruktur
Zugehörige Konzepte
Silk Central-Architektur


Starten oder Stoppen eines lokalen Ausführungsserverdienstes

Verwenden Sie den Silk Central Service Manager um einen lokal installierten Ausführungsserverdienst zu starten oder zu stoppen.
  1. Doppelklicken Sie in der Windows-Taskleiste auf das Symbol Silk Central Service Manager. Der Dialog Silk Central Service Manager wird angezeigt.
  2. Klicken Sie auf Start oder Stop, um den Ausführungsserverdienst zu starten oder anzuhalten.
  3. Klicken Sie auf Query Status, um den aktuellen Status des Dienstes zu überprüfen.
  4. Wenn Sie Echtzeit-Aktivitäten überwachen möchten, starten Sie den Silk Central-Ausführungsserver mit einem Konsolenfenster:
    1. Aktivieren Sie das Kontrollkästchen Start with console.
    2. Klicken Sie auf Stop.
    3. Klicken Sie auf Start.
  5. Klicken sie auf Execution Server Logfile um die Lodatei zu öffnen. Die Protokolldatei wird im registrierten Texteditor geöffnet.
  6. Klicken Sie auf OK, um die Verwaltung des Ausführungsserverdienstes zu beenden. Der Service Manager wird geschlossen, ist aber in der Taskleiste weiterhin verfügbar.
Übergeordnetes Thema: Verwalten von Instanzen


Lastausgleichsmechanismus für Front-End-Server

Der Lastausgleichsmechanismus wird verwendet um die Last (Datenverkehr auf der Website) auf mehrere Server zu verteilen, wodurch eine Leistungs- und Zuverlässigkeitssteigerung ermöglicht wird.

Um einen Lastausgleichsmechanismus für die Front-End-Server von Silk Central einzurichten, fügen Sie der NGINX Proxy-Konfiguration weitere Front-End-Server hinzu, und NGINX verteilt dann die Last zwischen den Servern.

  • Konfigurieren des Lastausgleichsmechanismus für Front-End-Server
    Hier wird beschrieben wie weitere Front-End-Server für den Lastausgleichsmechanismus eingerichtet und konfiguriert werden.
Übergeordnetes Thema: Verwalten von Instanzen


Konfigurieren des Lastausgleichsmechanismus für Front-End-Server

Wenn Sie eine laufende Silk Central-Instanz haben, und die Anwender dieser Instanz aufgrund erhöhter Last eine Verschlechterung der Systemleistung verspüren, können Sie zusätzliche Front-End-Server einrichten um die Last aufzuteilen.

Ursprüngliche Situation:
  • Sie haben Silk Central auf Server A installiert.
  • Sie haben eine laufende Instanz mit Systemleistungsproblemen.
  • Sie wollen einen zusätzlichen Front-End-Server einrichten, um die Last aufzuteilen.

So fügen sie der Instanz für den Lastausgleichsmechanismus einen Front-End-Server hinzu.

  1. Installieren Sie Silk Central mit dem Silk Central-Setup auf Server B.
  2. Wenn die Installation abgeschlossen ist, gehen Sie auf Server B zur Instanzen-Verwaltung (http://localhost:19100).
  3. Da Sie lediglich einen Front-End-Server benötigen, deaktivieren Sie auf der Instanz, die Sie für den Lastausgleichsmechanismus verwenden möchten, den Anwendungs- und den Diagrammserver.
  4. Klicken Sie auf Einstellungen um den Einstellungen-Dialog dieser Instanz zu öffnen. Wählen Sie auf der Registerkarte Server den Front-End-Server aus und kopieren sie den Front-End-Server Port.
  5. Wechseln sie zu Server A und gehen Sie zur Instanz-Verwaltung (http://localhost:19100).
  6. Klicken Sie auf Einstellungen um den Einstellungen-Dialog Ihrer Instanz mit Systemleistungsproblemen zu öffnen und aktivieren sie den Wartungs-Modus.
  7. Öffnen sie im Dateisystem die Datei für benutzerdefinierte NGINX-Eigenschaften (C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf\nginxCustom.properties) und fügen Sie die URL des Front-End-Servers auf Server B hinzu (<SERVERNAME>:<PORT>). Verwenden sie hierfür den zuvor kopierten Front-End-Server Port. Notation: frontendservers.<INSTANZNAME>=<FE_URL1>{,<FE_URL2>,...,<FE_URLX>}

    Zum Beispiel: frontendservers.silk=localhost:19110,silkserver2:19320

    Achtung: Aufgrund von NGINX-Restriktionen kann der Port 19120 eines Front-End-Servers nicht verwendet werden. Verwenden sie immer die Portnummer vom Einstellungsdialog, wie in Schritt 4 beschrieben.
  8. Gehen Sie zurück zur Instanz-Verwaltung und klicken Sie auf Einstellungen um den Einstellungen-Dialog Ihrer Instanz mit Systemleistungsproblemen zu öffnen. Wählen Sie auf der Registerkarte Server den Anwendungsserver aus und kopieren sie den Anwendungsserver-Port.
  9. Um eine Verbindung zwischen dem Front-End-Server auf Server B und dem Anwendungsserver der Instanz auf Server A zu erstellen, öffnen Sie einen Web-Browser und navigieren Sie direkt zum Front-End-Server von Server B (http://<Server B>:<Font-End-Server Port>). Stellen Sie sicher, dass Sie den Port vom Einstellungsdialog verwenden, nicht 19120!
  10. Geben Sie auf der Anwendungsserververbindungs-Seite Host oder IP-Adresse und den kopierten Anwendungsserver-Port von Server A ein.
  11. Gehen Sie zurück zur Instanzen-Verwaltung und deaktivieren sie den Wartungs-Modus. Dadurch wird die NGINX-Konfiguration aktualisiert.

Wenn Ihre Anwender nun mit derselben URL wie zuvor die Instanz verwenden, wird ihre Last automatisch zwischen den Front-End-Servern auf Server A und Server B verteilt.

Übergeordnetes Thema: Lastausgleichsmechanismus für Front-End-Server


Verwalten von Mandanten

Im Bereich Systemverwaltung können Sie die Mandanten von Silk Central konfigurieren. Die Konfiguration von Mandanten umfasst folgende Tätigkeiten:

  • Erstellen, Verbinden und Trennen von Datenbanken.
  • Erstellen und Verwalten von Mandanten.
  • Konfigurieren der Infrastruktur des Silk Central-Mandanten (Diagrammserver, E-Mail-Server und Proxy-Verbindungen).
  • Warten von Systemdiensten durch die Analyse von Diagnosedaten und Systemlogdateien.
  • Systemadministrator
    Hier werden die Rolle und die Aufgaben des Systemadministrators beschrieben.
  • Datenbanken
    Hier wird die Verwendung einer Datenbank in Silk Central beschrieben.
  • Mandanten
    Mandanten sind getrennte Einheiten innerhalb einer Silk Central-Instanz. Ein Mandant kann z.B. ein Kunde oder ein Geschäftsbereich eines Unternehmens sein. Mandanten erhöhen die Datensicherheit, aber im Gegensatz zu Instanzen verwenden sie dieselbe Datenbank und dieselben Silk Central-Dienste.
  • Infrastruktur
    Hier werden der Diagrammserver, der E-Mail-Server und der System-Proxy beschrieben, aus denen die Systeminfrastruktur besteht.
  • Systemdiagnose
    Hier wird die Registerkarte "Systemdiagnose" beschrieben.
Übergeordnetes Thema: Konfigurieren und Verwalten der Infrastruktur
Zugehörige Konzepte
Silk Central-Architektur


Systemadministrator

Der Systemadministrator ist der einzige Benutzer, der Zugriff auf den Bereich Systemverwaltung hat. Gleichzeitig hat er nur auf diesen Bereich Zugriff. Er hat keinen Zugriff auf die eigentliche Silk Central-Benutzeroberfläche.

Sie erhalten Zugriff auf den Bereich Systemverwaltung, indem Sie sich mit den folgenden Daten anmelden:
  • Benutzername: sysadmin
  • Kennwort: sysadmin
Wichtig: Ändern Sie dieses Standardkennwort so bald wie möglich. Wir empfehlen eine Änderung des Kennworts, sobald Sie zum ersten Mal eine Verbindung zu einer Silk Central-Datenbank hergestellt haben. Klicken Sie zum Ändern des Kennworts im Menü des Bereichs Systemverwaltung (oben rechts) auf Kennwort ändern. Der Benutzername kann nicht geändert werden.

Wenn keine Datenbankverbindung vorliegt, wird der Systemadministrator automatisch in den Bereich Systemverwaltung weitergeleitet.

Übergeordnetes Thema: Verwalten von Mandanten


Datenbanken

Silk Central verwendet Datenbanken zum Speichern, Pflegen und Analysieren von Daten. Sie müssen eine Datenbankverbindung herstellen, bevor Sie mit Silk Central arbeiten können. Sie können mehrere Datenbanken erstellen, wobei jedoch immer nur eine Datenbank verbunden werden kann. Wenn Sie eine Verbindung mit einer neuen Datenbank herstellen möchten, müssen Sie zunächst die aktuelle Datenbankverbindung trennen.

Wenn Sie Datenbankverbindungen konfigurieren möchten, gehen Sie im Bereich Systemverwaltung auf die Seite Datenbank. Auf diese Seite kann nur der Systemadministrator zugreifen. Weitere Informationen finden Sie unter Systemadministrator.

Verwaltungsaufgaben, für die die Datenbankverbindung getrennt werden muss, sollten außerhalb der regulären Arbeitszeit durchgeführt werden. Setzen Sie die Benutzer über die Nicht-Verfügbarkeit und dessen Dauer in Kenntnis. Für weitere Informationen zur Konfiguration Ihrer Datenbank, wenden Sie sich bitte an die SupportLine. Wenn Sie Microsoft SQL Server verwenden, empfehlen wir Ihnen den Artikel Silk Central MSSQL Server Recommendations zu lesen.

  • Auswählen eines relationalen Datenbankmanagementsystems (RDBMS)
    Wählen Sie ein relationales Datenbankmanagementsystem (RDBMS) als Repository aus.
  • Berechtigungen für den Datenbankzugriff
    Weisen Sie Datenbankbenutzern Rollen zu, damit sie bestimmte Aufgaben durchführen können.
  • Erstellen von Datenbanken
    Hier wird beschrieben, wie eine neue Datenbank erstellt wird.
  • Verbinden mit einer Datenbank
    Hier wird beschrieben, wie eine Verbindung zu einer Silk Central-Datenbank hergestellt wird.
  • Trennen der Verbindung zu einer Datenbank
    Hier wird beschrieben, wie die Verbindung zu einer Silk Central-Datenbank getrennt wird.
  • ALM Repository-IDs
    Hier wird beschrieben, wie ein Repository identifiziert wird.
  • ALM URIs
    Hier wird beschrieben, wie ALM URIs verwendet werden.
  • Datenbank (Seite)
    Hier wird beschrieben, wie mithilfe der Seite Datenbank Verbindungen zu Datenbanken hergestellt und getrennt werden.
Übergeordnetes Thema: Verwalten von Mandanten
Zugehörige Konzepte
Systemadministrator
Zugehörige Verweise
Datenbank (Seite)


Auswählen eines relationalen Datenbankmanagementsystems (RDBMS)

Installieren Sie Oracle oder Microsoft SQL Server entsprechend der mit dem Datenbankmanagementsystem mitgelieferten Dokumentation.

Silk Central unterstützt folgende Datenbankmanagementsysteme:
  • Microsoft SQL Server 2012 Service Pack 3
  • Microsoft SQL Server 2014 Service Pack 2
  • Microsoft SQL Server 2016
  • Oracle 11g (Version 11.2.0.4)
  • Oracle 12c (Version 12.1.0.2)

In der folgenden Tabelle finden Sie die Voraussetzungen für die verschiedenen Datenbanktypen.

RDBMS Voraussetzungen
Oracle
  • Oracle-Tablespace.
  • Hostname des Servers und Portnummer, oder Single Client Access Name (SCAN). Der Standardport ist 1521.
  • Name der Oracle-Instanz ($ORACLE_SID).
  • Benutzername und Kennwort des Silk Central-Datenbankbenutzers. Der Benutzer benötigt Kontingente und ausreichende Berechtigungen.
Wenn Sie sich an Ihren Oracle-Administrator, wenn Sie Hilfe benötigen.
Anmerkung: In Oracle werden keine Datenbanken erstellt, sondern Schemas, die bestimmten Benutzernamen zugeordnet sind. Daher werden die Datenbanknamen nicht Oracle-Datenbanken, sondern Benutzernamen zugewiesen. Silk Central verweist auf solche Benutzernamen als Datenbanknamen.
Microsoft SQL Server
  • Hostname des Servers und Portnummer.
  • Benutzername und Kennwort für MS SQL Server.
  • Name für die Silk Central-Datenbank.
  • Benutzername und Kennwort des Silk Central-Datenbankbenutzers.
Anmerkung: Silk Central unterstützt nur Microsoft SQL Server-Server, die ohne Berücksichtigung der Groß-/Kleinschreibung eingerichtet wurden. Verwenden Sie Microsoft SQL Server Express nicht für Produktionsumgebungen, da die Anwendung im Vergleich zu einer vollständigen Datenbank-Serverinstallation nur eingeschränkte Möglichkeiten bietet.
Übergeordnetes Thema: Datenbanken


Berechtigungen für den Datenbankzugriff

Aus Sicherheitsgründen wird davon abgeraten, die Silk Central-Datenbank mit dem Datenbankadministrator-Benutzer zu verwalten. Dieses Thema führt die Datenbankrollen auf, die Sie bestimmten Aufgaben zuordnen können:

Microsoft SQL Server
Wenn Sie Microsoft SQL Server als DBMS für Silk Central einsetzen, werden für die Silk Central-Datenbank folgende Datenbank-Rollen/-Benutzerberechtigungen benötigt:
Entweder: Oder:
  • db_owner
  • db_ddladmin
  • VIEW SERVER STATE
  • db_datareader
  • db_datawriter
  • db_ddladmin
  • EXECUTE
  • VIEW SERVER STATE
Benutzer mit diesen Rollen/Berechtigungen können Tabellen in der Datenbank erstellen und konfigurieren, auf bereits vorhandene Datenbanken zugreifen sowie die Software installieren und aktualisieren.
Anmerkung: Für den Silk Central-Datenbankbenutzer sind diese Rollen/Berechtigungen erforderlich. Ansonsten treten Fehler auf.
Oracle
Wenn Sie Oracle als DBMS für Silk Central einsetzen, müssen für die Verwendung mit Silk Central folgende Benutzerberechtigungen für die Oracle-Datenbank gewährt werden:
  • CREATE SESSION
  • CREATE PROCEDURE
  • CREATE SEQUENCE
  • CREATE TABLE
  • CREATE TRIGGER
  • CREATE VIEW
Anmerkung: Der Silk Central-Datenbankbenutzer benötigt alle genannten Berechtigungen. Ansonsten treten Fehler auf. Um für die Systemdiagnose sämtliche datenbankbezogenen Analysedaten zu erhalten, wird empfohlen dem Datenbankbenutzer auch die Rolle SELECT_CATALOG_ROLE zuzuordnen.
Anmerkung: Der Oracle-Benutzer benötigt für die Arbeit mit Silk Central ausreichend Kontingente.
Wenn Sie Oracle als DBMS für Silk Central einrichten, beachten Sie bitte folgende Punkte in Bezug auf die Oracle-Umgebung:
  • Der temporäre Tablespace sollte mindestens 2 GB groß sein.
  • Auf der Festplatte muss genügend Speicherplatz für den temporären Tablespace vorhanden sein.
Übergeordnetes Thema: Datenbanken


Erstellen von Datenbanken

Wenn Silk Central zurzeit mit einer Datenbank verbunden ist, müssen Sie die Verbindung trennen, bevor Sie eine neue Datenbank erstellen können.

Anmerkung: Wenn Sie eine Testversion von Silk Centralinstalliert haben, wird automatisch eine Demo-Datenbank namens demodb angelegt und verbunden. In diesem Fall müssen Sie die folgenden Schritte nicht ausführen.

So erstellen Sie eine neue Datenbank:

  1. Wenn Sie bereits einen Silk Central-Anwendungsserver eingerichtet haben, wird die Seite für die Datenbank in einem Browserfenster angezeigt, und Sie können mit Schritt 3 fortfahren.
    Tipp: Alternativ können Sie mit einem Browser zur Silk Central-Site navigieren. Die Standard-URL ist http://<Computername>:19120/login (keine Portinformationen nötig wenn Silk Central auf IIS läuft). Wenn Sie bei der Installation von Silk Central die Option Standard Setup verwenden, wird die Seite Datenbank unmittelbar nachdem Sie die Verbindung zur Anwendung hergestellt haben, angezeigt. Auf dem Computer, auf dem der Front-End-Server installiert ist, können Sie auch Start > Programme > Silk > Silk Central > Silk Central18.5 > Silk Central Homepage wählen.
  2. Melden Sie sich bei Silk Central als Systemadministrator an. Weitere Informationen finden Sie unter Systemadministrator.
  3. Klicken Sie im Menü auf Datenbanken.
  4. Konfigurieren Sie die Einstellungen für die neue Datenbank. Weitere Informationen finden Sie unter Datenbank (Seite). Sie können eine Datenbank auf einem lokal installierten Microsoft SQL Server 2008 Express SP1, einem lokal installierten Microsoft SQL Server, einem Oracle-Server oder auf einem Netzwerkserver erstellen, auf dem MS SQL Server oder Oracle installiert sind. Silk Central unterstützt:
    • Microsoft SQL Server 2012 Service Pack 3
    • Microsoft SQL Server 2014 Service Pack 2
    • Microsoft SQL Server 2016
    • Oracle 11g (Version 11.2.0.4)
    • Oracle 12c (Version 12.1.0.2)
  5. Klicken Sie auf Datenbank verbinden und anschließend auf Ja. Der Dialog Neue Datenbank erstellen wird angezeigt.
  6. Geben Sie die Anmeldedaten des Datenbankadministratoren ein, und klicken Sie auf OK.
    Tipp: Wenn Sie eine lokale oder eine Netzwerk-Datenbank mit Microsoft SQL Server oder Oracle erstellen möchten, geben Sie die Anmeldedaten ein, die Sie von Ihrem Datenbankadministrator erhalten haben.
    Das Dialogfeld ALM Repository-ID anlegen wird angezeigt.
  7. Geben Sie eine eindeutige ALM Repository-ID ein, und klicken Sie auf OK.
  8. Sie werden benachrichtigt, dass das Repository erfolgreich erstellt wurde. Klicken Sie auf OK. Die Anmeldeseite wird angezeigt.
Die Datenbank wurde erstellt, und es ist eine Verbindung vorhanden. Nun können Sie sich bei Silk Central mit Ihrem Benutzernamen und Ihrem Kennwort anmelden.
Übergeordnetes Thema: Datenbanken
Zugehörige Konzepte
Systemadministrator
Zugehörige Verweise
Datenbank (Seite)


Verbinden mit einer Datenbank

So stellen Sie eine Verbindung zu einer Datenbank her:

  1. Wechseln Sie mit einem Webbrowser auf Ihre Silk Central-Seite. Die Standard-URL ist http://<Computername>:19120/login (keine Portinformationen nötig wenn Silk Central auf IIS läuft).
    Anmerkung: Wenn zurzeit keine Datenbankverbindung vorliegt, werden Sie automatisch in den Bereich Systemverwaltung weitergeleitet.
  2. Melden Sie sich bei Silk Central als Systemadministrator an. Weitere Informationen finden Sie unter Systemadministrator.
  3. Klicken Sie im Menü auf Datenbanken.
  4. Klicken Sie auf Datenbank trennen, um die aktuelle Datenbankverbindung zu beenden. Sie werden auf die Seite Datenbank weitergeleitet.
  5. Ändern Sie gegebenenfalls die Einstellungen. Weitere Informationen finden Sie unter Datenbank (Seite).
  6. Klicken Sie auf Datenbank verbinden.
Die Herstellung der Datenbankverbindung kann einige Minuten bis mehrere Stunden in Anspruch nehmen. Sobald eine Verbindung hergestellt wurde, wird ein Dialogfeld angezeigt. Klicken Sie auf OK. Die Silk Central-Anmeldeseite wird angezeigt.
Übergeordnetes Thema: Datenbanken
Zugehörige Konzepte
Systemadministrator
Zugehörige Verweise
Datenbank (Seite)


Trennen der Verbindung zu einer Datenbank

So trennen Sie eine Datenbankverbindung:

  1. Navigieren Sie mit einem Webbrowser auf Ihre Silk Central-Site. Die Standard-URL ist http://<Computername>:19120/login (keine Portinformationen nötig wenn Silk Central auf IIS läuft).
  2. Melden Sie sich bei Silk Central als Systemadministrator an. Weitere Informationen finden Sie unter Systemadministrator.
  3. Klicken Sie im Menü auf Datenbanken.
  4. Klicken Sie auf Datenbank trennen, um die aktuelle Datenbankverbindung zu beenden. Sie werden auf die Seite Datenbank weitergeleitet.
Übergeordnetes Thema: Datenbanken
Zugehörige Konzepte
Systemadministrator
Zugehörige Verweise
Datenbank (Seite)


ALM Repository-IDs

Jede Silk Central-Datenbank muss eine eindeutige Repository-ID besitzen. Diese ID wird in ALM URIs verwendet, um Silk Central-Anforderungen und Testläufe bei mehreren Silk Central-Repositorys eindeutig zu identifizieren. Die Repository-ID muss in allen Silk Central-Installationen im Unternehmen eindeutig sein. Die angegebene Repository-ID ist Bestandteil des ALM URIs. Weitere Informationen zu ALM URIs finden Sie unter ALM URIs. Verwenden Sie eine aussagekräftige ID, beispielsweiseUSCA01 für USA, California, Repository-Nr. 01, oder GEBE02 für Germany, Berlin, Repository-Nr. 02. Buchstaben, Zahlen, Punkt (.) und Minus (-) sind zulässige Zeichen. IDs müssen zwischen einem und 20 Zeichen lang sein.

ACHTUNG:
Wenn eine Repository-ID festgelegt wurde, kann sie nicht mehr geändert werden.
Übergeordnetes Thema: Datenbanken
Zugehörige Konzepte
ALM URIs


ALM URIs

Repository-IDs werden in Application Lifecycle Management Uniform Resource Identifiers (ALM URIs) aufgenommen. Mit ALM URIs können Elemente auf der gesamten ALM-Serverplattform verwendet, unterschieden und über eine Anwendung hinaus nachverfolgt werden. Unter anderem werden mit ALM URIs Silk Central-Anforderungen und Testläufe in mehreren Silk Central-Repositorys eindeutig identifiziert.

Die Syntax des ALM-Element-URIs lautet folgendermaßen:

<ALM URI> = alm://<source project>/<source element path>[?<source version>]
 <source project> = <source type>!<project identity>

Für Silk Central, <source type> = sctm. Für Issue Manager, <source type> = scim.

Die Projektidentität setzt sich folgendermaßen zusammen:

<project identity> = <repository ID>_<project ID>

<repository ID> ist ein eindeutiger Bezeichner für jedes Silk Central- und Issue Manager-Repository. Jedes Repository erzeugt einen eindeutigen Bezeichner, der im Repository gespeichert wird. Die Eindeutigkeit wird über alle installierten Repositorys hinweg gewährleistet. <project ID> ist ein Bezeichner für ein Silk Central- oder Issue Manager-Projekt. Dieser Bezeichner ist im Kontext eines Repository eindeutig.

Quellelementpfad:

Silk Central und Issue Manager referenzieren Artefakte mit der folgenden Syntax:

Native Anforderungen von Silk Central, bei denen es sich um Anforderungen handelt, die nicht mit einem externen Anforderungsmanagementsystem verknüpft sind, verwenden folgende Syntax:

<source element path> = /<requirement ID>;ns=requirement

Für Silk Central-Tests wird folgende Syntax verwendet:

<source element path> = /<test ID>;ns=test

Für Silk Central- und Issue Manager-Fehler wird folgende Syntax verwendet:

<source element path> = /<issue ID>;ns=issue
Beispiel eines ALM URIs:
alm://sctm!USCA01_23/602;ns=test

Silk Central-Repository USCA01, Projekt-ID 23, Element-ID 602, Elementtyp test.

Übergeordnetes Thema: Datenbanken
Zugehörige Konzepte
ALM Repository-IDs


Datenbank (Seite)

Auf der Seite Datenbank können Sie eine Datenbank mit Silk Central verbinden und die Verbindung wieder trennen.

Wenn keine Datenbankverbindung vorliegt, werden Sie automatisch auf die Seite Datenbank weitergeleitet.

Wenn eine Datenbankverbindung vorliegt, müssen Sie sich als Systemadministrator anmelden und auf Datenbank klicken, um auf die Seite Datenbank zu gelangen. Weitere Informationen finden Sie unter Systemadministrator.

Konfigurieren Sie die Datenbankverbindung mithilfe der folgenden Steuerelemente der Benutzeroberfläche:

Element | Beschreibung
DBMS-Hostname oder IP-Adresse Der Name des Computers, der das DBMS (Datenbankmanagementsystem) hostet. Geben Sie den Namen im Format <Computer Name>\<Instanz Name> ein.
Datenbanksystem
Beschreibung für den Hostnamen
Microsoft SQL Server
<Computername>\<Instanzname>. Zum Beispiel: localhost.
Anmerkung: Ein Instanzenname muss nur angegeben werden, wenn das DBMS mit einer Instanz installiert wurde.
Oracle Server
<Computername> oder Single Client Access Name (SCAN). Zum Beispiel: MyDBMSHost. Wenn Sie benutzerdefinierte Berichte mit einem direkten Datenbankzugriff erstellen möchten, definieren Sie einen DBMS-Hostnamen, der im gesamten Netzwerk verfügbar ist/sind.
DBMS-Typ | Der Typ des DBMS, auf den zugegriffen werden soll: MS SQL Server oder Oracle.
Port

Der Port, über den das DBMS Daten empfängt. Der Standardport für MS SQL Server, einschließlich Express, ist 1433. Der Standardport für Oracle ist 1521.
Datenbank / SID

Name der MSSQL Server-Datenbank oder Oracle SID, die von Ihrem Oracle-Administrator bereitgestellt wird. Um sich mit einer Oracle RAC Umgebung zu verbinden, geben Sie vor der SID einen Schrägstrich (/) ein.

Für Oracle-Datenbankadministratoren: Konfigurieren Sie die Oracle SID für die Verwendung des UTF8-Zeichensatzes.
Benutzername / Kennwort
Microsoft SQL Server, einschließlich Express
Datenbank-Benutzer mit ausreichendem Zugriff, oder ein gültiger Windows Domänen-Benutzer (Domäne\Benutzername). Wenn Sie die Windows-Authentifizierung verwenden, muss der Datenbank-Server LMv2 und NTLMv2 unterstützen. Single Sign-on ohne einen Benutzer anzugeben wird nicht unterstützt.
Anmerkung: Wenn Sie Silk Central evaluieren, lauten die Standard-Anmeldeinformationen sa / SilkCentral12!34.
Oracle Server
Datenbank-Benutzer mit ausreichendem Zugriff, welchen Sie von Ihrem Oracle-Administrator erhalten.
Wichtig: Bei Oracle-Servern darf der Name des Datenbankbenutzers keinen Punkt (.) enthalten.
Benutzername für Lesezugriff Ein optionaler Datenbankbenutzer mit schreibgeschütztem Zugriff auf alle Tabellen und Views der angegebenen Datenbank. Dieser Benutzer wird für die Ausführung von Aktionen verwendet, die nur Lesezugriff benötigen, z.B. die Ausführung von Berichten. Dies gewährleistet, dass die Ausführung von Berichten mit erweiterten Abfragen keine Daten in der Datenbank ändert, da erweiterte Abfragen negative Auswirkungen auf die Daten haben können. Der Zugriff auf die Datenbank mit einem Benutzer, der nur Lesezugriff hat, wirkt sich auch positiv auf die Leistung aus.

Wenn Sie als DBMS Microsoft SQL Server verwenden, erstellt Silk Central automatisch diesen Benutzer, wenn Sie einen Namen und ein Kennwort angeben. Wenn Sie als DBMS Oracle verwenden, muss der Benutzer vom Datenbankadministrator in Oracle erstellt und vom Silk Central-Administrator in Silk Central hinzugefügt werden.
Kennwort für Lesezugriff

Gültiges Kennwort für den im Feld Benutzername für Lesezugriff angegebenen Benutzer.
DBMS-Versionsinfo

Zeigt Versionsinformationen zu DBMS und Betriebssystem an.
ALM-Repository-ID | Zeigt die ALM URI des Repositorys an.
Datenbank verbinden / Datenbankverbindung trennen

Klicken Sie auf diese Schaltfläche, um eine DBMS-Verbindung herzustellen oder zu trennen.
Anmerkung: Wenn Sie eine ungültige ältere Version, aber höher als Version SilkCentral Test Manager 2009 SP1, eines Ausführungsservers verwenden, wird diese automatisch auf die aktuelle Version von Silk Central aktualisiert. Silk Central zeigt in der Ausführungsserverliste in der Spalte Information eine Nachricht betreffend der Aktualisierung an. Der zu aktualisierende Ausführungsserver wird erst nach Abschluss des Upgrade-Vorgangs verwendet.
Übergeordnetes Thema: Datenbanken
Zugehörige Konzepte
Systemadministrator


Mandanten

Mandanten sind getrennte Einheiten innerhalb einer Silk Central-Instanz. Ein Mandant kann z.B. ein Kunde oder ein Geschäftsbereich eines Unternehmens sein. Mandanten erhöhen die Datensicherheit, aber im Gegensatz zu Instanzen verwenden sie dieselbe Datenbank und dieselben Silk Central-Dienste.

Im Bereich Systemverwaltung können Sie Mandanten erstellen. Sie können verschiedene Mandanteneinstellungen vornehmen, die für die dem Mandanten zugeordneten Projekte gelten. Sie können die maximal verfügbaren Lizenzen pro Mandant aus den insgesamt verfügbaren Lizenzen festlegen. Sie können nur dann auf die Daten eines Mandanten zugreifen, wenn Sie bei diesem Mandanten angemeldet sind. Innerhalb eines Mandanten sind sämtliche Komponenten projektübergreifend verfügbar.

Wenn Sie Silk Central installieren, wird automatisch ein Standardmandanten erstellt. Wenn Sie für Silk Central ein Upgrade von einer älteren Version durchführen, werden vorhandene Projekte und Benutzer diesem Standardmandanten zugeordnet. Für jeden Mandanten wird ein Super User erstellt. Weitere Informationen finden Sie unter Super User. Sie können alle Mandanten löschen, benötigen jedoch mindestens einen Mandanten, um Projekte und Benutzerkonten erstellen und mit Silk Central arbeiten zu können.

  • Super User
    Hier wird der Super User beschrieben, der innerhalb eines Mandanten über sämtliche Berechtigungen verfügt.
  • Erstellen von Mandanten
    Hier wird beschrieben, wie Mandanten erstellt werden.
  • Bearbeiten von Mandanten
    Hier wird beschrieben, wie die Einstellungen eines Mandanten bearbeitet werden.
  • Entfernen von Mandanten
    Hier wird beschrieben, wie Mandanten entfernt werden.
  • Standard-Mandant
    Hier wird das Konzept des automatisch erstellten Standard-Mandanten beschrieben und erläutert, was der Standardstatus eine Mandanten ist und wie dieser Status festgelegt bzw. aufgehoben wird.
  • Lizenzverarbeitung
    Beschreibt die Lizenztypen, die in Silk Central verwendet werden, und wann Lizenzen ein- und ausgecheckt werden.
  • Mandanten (Seite)
    Hier wird die Seite Mandanten beschrieben.
  • Mandantenberechtigungen
    Mandantenberechtigungen für Server und Berichte.
Übergeordnetes Thema: Verwalten von Mandanten


Super User

Der Super User verfügt innerhalb eines Mandanten über sämtliche Berechtigungen. Im Gegensatz zum Super User kann der Systemadministrator nur die unterschiedlichen Mandanten einer Silk Central-Installation verwalten und hat keinen Zugriff auf die eigentliche Silk Central-Benutzeroberfläche.

Wenn der Systemadministrator einen neuen Mandanten erstellt, wird für diesen Mandanten automatisch ein Super User erstellt.

Melden Sie sich mit den folgenden Standard-Anmeldedaten als Super User an:

  • Benutzername: admin
  • Kennwort: admin
Wichtig: Ändern Sie dieses Standardkennwort so bald wie möglich. Klicken Sie zum Ändern des Kennworts im Menü auf Verwaltung > Benutzerverwaltung, dann auf die Registerkarte Konten und schließlich in der Tabelle auf admin. Der Benutzername kann nicht geändert werden.

Eine Liste sämtlicher Benutzerrollen und Berechtigungen finden Sie unter Benutzerrollen und Berechtigungen.

Übergeordnetes Thema: Mandanten
Zugehörige Konzepte
Anmeldeoptionen
Benutzerrollen und Berechtigungen
Benutzerrollen
Zugehörige Tasks
Anmelden bei Silk Central


Erstellen von Mandanten

So erstellen Sie einen Mandanten:
  1. Melden Sie sich bei Silk Central als Systemadministrator an. Weitere Informationen finden Sie unter Systemadministrator.
  2. Klicken Sie im Menü auf Mandanten.
  3. Klicken Sie auf Neuer Mandant. Das Dialogfeld Neuer Mandant wird angezeigt.
  4. Geben Sie den Mandantennamen und eine Beschreibung ein.
  5. Legen Sie die maximal gleichzeitig verfügbaren Lizenzen für diesen Mandanten im Bereich Lizenzlimits fest. Sobald die festgelegte Anzahl von Lizenzen in Verwendung ist, erhalten keine weiteren Benutzer mehr eine Lizenz auf diesem Mandanten. Dies ist vor allem dann hilfreich, wenn Sie z.B. sicherstellen wollen, dass ein wichtiger Mandant immer genügend Lizenzen zur Verfügung hat, während die Lizenzen für einen nicht so wichtigen Mandanten beschränkt sind. Die folgenden Regeln werden angewendet:
    • Kein Wert: Es wird kein Lizenzlimit festgelegt und der Mandant kann von den insgesamt verfügbaren Lizenzen Gebrauch machen.
    • 0 (Null): Der Mandant hat gar keine Lizenzen zur Verfügung, was effektiv sämtliche mit der entsprechenden Lizenz in Verbindung stehende Funktionalität deaktiviert.
    • Eine Zahl: Die Anzahl der Lizenzen, die dem Mandanten zur Verfügung stehen. Falls die festgelegte Zahl höher ist als die insgesamt verfügbaren Lizenzen, kann der Mandant von den insgesamt verfügbaren Lizenzen Gebrauch machen.
    Tipp: Die Anzahl der insgesamt verfügbaren Lizenzen wird unten auf der Seite Mandanten angezeigt.
  6. Klicken Sie auf OK.

Loggen Sie sich auf dem Mandanten als Super User ein, um mandantenspezifische Administrationsaufgaben zu erledigen. Weitere Informationen finden Sie unter Super User.

Übergeordnetes Thema: Mandanten
Zugehörige Konzepte
Systemadministrator
Lizenzverarbeitung
Super User
Zugehörige Verweise
Datenbank (Seite)


Bearbeiten von Mandanten

So bearbeiten Sie die Einstellungen eines Mandanten:
  1. Melden Sie sich bei Silk Central als Systemadministrator an. Weitere Informationen finden Sie unter Systemadministrator.
  2. Klicken Sie im Menü auf Mandanten.
  3. Klicken Sie in der Spalte Aktionen auf [image] (Bearbeiten). Das Dialogfeld Mandant bearbeiten wird angezeigt.
  4. Bearbeiten Sie den Mandantenamen und die Beschreibung.
  5. Legen Sie die maximal gleichzeitig verfügbaren Lizenzen für diesen Mandanten im Bereich Lizenzlimits fest. Sobald die festgelegte Anzahl von Lizenzen in Verwendung ist, erhalten keine weiteren Benutzer mehr eine Lizenz auf diesem Mandanten. Dies ist vor allem dann hilfreich, wenn Sie z.B. sicherstellen wollen, dass ein wichtiger Mandant immer genügend Lizenzen zur Verfügung hat, während die Lizenzen für einen nicht so wichtigen Mandanten beschränkt sind. Die folgenden Regeln werden angewendet:
    • Kein Wert: Es wird kein Lizenzlimit festgelegt und der Mandant kann von den insgesamt verfügbaren Lizenzen Gebrauch machen.
    • 0 (Null): Der Mandant hat gar keine Lizenzen zur Verfügung, was effektiv sämtliche mit der entsprechenden Lizenz in Verbindung stehende Funktionalität deaktiviert.
    • Eine Zahl: Die Anzahl der Lizenzen, die dem Mandanten zur Verfügung stehen. Falls die festgelegte Zahl höher ist als die insgesamt verfügbaren Lizenzen, kann der Mandant von den insgesamt verfügbaren Lizenzen Gebrauch machen.
    Tipp: Die Anzahl der insgesamt verfügbaren Lizenzen wird unten auf der Seite Mandanten angezeigt.
  6. Klicken Sie auf OK.
Anmerkung: Wenn Sie den Mandantenamen ändern, sollten Sie die Silk Central-Benutzer darüber informieren. Silk Central Benutzer müssen den Mandantennamen bei der Anmeldung eingeben.

Loggen Sie sich auf dem Mandanten als Super User ein, um mandantenspezifische Administrationsaufgaben zu erledigen. Weitere Informationen finden Sie unter Super User.

Übergeordnetes Thema: Mandanten
Zugehörige Konzepte
Systemadministrator
Lizenzverarbeitung
Super User
Zugehörige Verweise
Datenbank (Seite)


Entfernen von Mandanten

So entfernen Sie einen Mandanten:
  1. Melden Sie sich bei Silk Central als Systemadministrator an. Weitere Informationen finden Sie unter Systemadministrator.
  2. Klicken Sie im Menü auf Mandanten.
  3. Klicken Sie in der Spalte Aktionen auf [image] (Löschen).
  4. Klicken Sie zum Bestätigen auf Ja.
Übergeordnetes Thema: Mandanten
Zugehörige Konzepte
Systemadministrator
Zugehörige Verweise
Datenbank (Seite)


Standard-Mandant

Wenn Sie Silk Central installieren, wird automatisch ein Mandant (mit dem Namen Standard) erstellt und dieser als Standard-Mandant festgelegt. Wenn Sie den Standard-Mandanten ändern möchten, melden Sie sich bei Silk Central als Systemadministrator an, und klicken Sie auf Mandanten. Weitere Informationen finden Sie unter Systemadministrator.

Wenn Sie einen Mandanten als Standard festlegen möchten, klicken Sie auf Als Standard festlegen. Wenn Sie den Standardstatus aufheben möchten, klicken Sie auf Standard aufheben. Das Symbol [image] zeigt an, welcher Mandant zurzeit der Standard-Mandantt ist. Es ist möglich, dass kein Standard-Mandant festgelegt ist, aber es kann immer nur ein Mandant den Standardstatus aufweisen.

Der Zweck des Standard-Mandanten besteht darin, die Anmeldung zu vereinfachen: Wenn Sie sich bei Silk Central mit den Benutzerdaten des Standard-Mandanten anmelden, brauchen Sie keinen Mandantennamen anzugeben. Geben Sie nur den Benutzernamen ein. Dies ist vor allem bei Silk Central-Installationen mit nur einem Mandanten hilfreich. Wenn Sie für Silk Central ein Upgrade von einer älteren Version durchführen, bleibt der Anmeldevorgang unverändert.

Übergeordnetes Thema: Mandanten
Zugehörige Konzepte
Systemadministrator
Zugehörige Verweise
Datenbank (Seite)


Mandanten (Seite)

Melden Sie sich zum Öffnen dieser Seite bei Silk Central als Systemadministrator an, und klicken Sie auf Mandanten. Weitere Informationen finden Sie unter Systemadministrator.

Mithilfe dieser Seite können Sie Ihre Mandanten erstellen und verwalten. Klicken Sie auf die Schaltfläche Neuer Mandant, um einen neuen Mandanteb zu erstellen. Klicken Sie auf die Schaltflächen Als Standard festlegen oder Standard aufheben, um den Standardstatus des Mandanten zu ändern. Das Symbol [image] zeigt an, welcher Mandant zurzeit der Standard-Mandantt ist.

Die Tabelle enthält die folgenden Spalten:

Spalte | Beschreibung
Aktionen | Klicken Sie auf die Schaltflächen [image] oder [image] , um Mandanten zu löschen oder zu bearbeiten.
ID | Die Kennung des Mandanten.
Name | Der Name des Mandanten. Klicken Sie auf [image] , um den Namen zu bearbeiten. Wenn Sie den Mandantennamen ändern, sollten Sie die Silk Central Benutzer darüber informieren. Silk Central Benutzer müssen den Mandantennamen bei der Anmeldung eingeben.
Beschreibung | Hier wird der Mandant ausführlicher beschrieben. Klicken Sie auf [image] , um die Beschreibung zu bearbeiten.
Test Manager | Die maximale Anzahl von Test Manager Lizenzen, die gleichzeitig in Verwendung sein können.
Manuelles Testen | Die maximale Anzahl von Manuelles Testen Lizenzen, die gleichzeitig in Verwendung sein können.
Fehlerverfolgung | Die maximale Anzahl von Fehlerverfolgung Lizenzen, die gleichzeitig in Verwendung sein können.
Automatisiertes Testen | Die maximale Anzahl von Automatisiertes Testen Lizenzen, die gleichzeitig in Verwendung sein können.
Erstellt am | Datum, an dem der Mandant erstellt wurde.
Erstellt von | Der Name des Benutzers, der den Mandanten erstellt hat.
Geändert am | Datum, an dem der Mandant geändert wurde.
Geändert von | Der Name des Benutzers, der den Mandanten geändert hat.
Übergeordnetes Thema: Mandanten
Zugehörige Konzepte
Systemadministrator


Mandantenberechtigungen

Mithilfe dieser Seiten können Sie die Systemeinstellungen und -berechtigungen für Mandanten ändern.

Element | Beschreibung
Mandantenbenutzern Log-Ansichten zu Front-End- und Anwendungsservern anzeigen. | Wenn aktiviert, werden die Log-Registerkarten zu den Front-End- und Anwendungsservern auf der Benutzeroberfläche angezeigt (die Logs können Mandanten-spezifische Daten enthalten).
Erweiterte Berichte für Mandantenbenutzer zulassen. | Wenn aktiviert, sind Berichte mit erweiterten Abfragen möglich. Wenn nicht aktiviert, können die Berichte zwar ausgeführt werden, aber die Erstellung oder Bearbeitung neuer Berichte ist nicht möglich.
Verwalten von Berichtsvorlagen für Benutzer des Mandanten erlauben. | Wenn aktiviert, können Berichtsvorlagen hochgeladen, erstellt, bearbeitet und gelöscht werden. Hochgeladene Berichtsvorlagen können beliebigen SQL-Code enthalten und Daten anderer Mandanten lesen.
Übergeordnetes Thema: Mandanten
Zugehörige Konzepte
Definitionen von Berechtigungen


Infrastruktur

Enthält Einstellungen für Diagrammserver, E-Mail-Server und den System-Proxy.

  • Diagrammserver
    Hier werden die Rolle von Diagrammservern und die Art ihrer Verbindung zu Silk Central beschrieben.
  • E-Mail-Server
    Hier wird beschrieben, wie E-Mail-Server konfiguriert werden.
  • System-Proxy
    Hier wird beschrieben, wie ein System-Proxy konfiguriert wird. Die Ausführungsserver können über einen Proxy mit dem Anwendungsserver kommunizieren.
  • Anwendungsservergruppen
    Hier werden die Grundlagen der Silk Central-Anwendungsserver erläutert.
  • LDAP-Authentifizierung
    Hier wird die Konfiguration der LDAP-Authentifizierung beschrieben, damit sich Benutzer über einen LDAP-Server bei Silk Central anmelden können.
  • Agenten-Cluster für Silk Performer-Lasttests
    Agenten-Cluster für Silk Performer-Lasttests unterstützen dynamische Zuweisungen von Lasttest-Szenarien für mehrere Testagenten.
Übergeordnetes Thema: Verwalten von Mandanten


Diagrammserver

Ein Diagrammserver ist ein Dienst, der Daten berechnet und Diagramme erzeugt. Diese Diagramme werden mit der Silk Central-Anwendung angezeigt. Dieser Dienst kann im Rahmen der Silk Central-Installation auf einem Computer Ihrer Wahl installiert werden. Für die Anzeige von Diagrammen ist die Konfiguration einer Diagrammserver-Verbindung erforderlich.

Anmerkung: Sie können beliebig viele Diagrammserver-Verbindungen konfigurieren. Silk Central implementiert automatisch einen Lastausgleichsmechanismus für die Diagrammerzeugung.
  • Konfigurieren von Diagrammserver-Verbindungen
    Hier wird beschrieben, wie eine Diagrammserver-Verbindung konfiguriert wird.
  • Bearbeiten von Diagrammserver-Verbindungen
    Hier wird beschrieben, wie eine Diagrammserver-Verbindung bearbeitet wird.
  • Entfernen von Diagrammserver-Verbindungen
    Hier wird beschrieben, wie eine Diagrammserver-Verbindung entfernt wird.
  • Diagrammserver (Seite)
    Hier wird die Seite Diagrammserver beschrieben.
Übergeordnetes Thema: Infrastruktur


Konfigurieren von Diagrammserver-Verbindungen

So konfigurieren Sie eine Diagrammserver-Verbindung:

  1. Klicken Sie im Menü auf Infrastruktur > Diagrammserver
  2. Wenn ein Diagrammserver zusammen mit dem Anwendungsserver auf demselben Computer installiert wurde, wird automatisch eine Diagrammserver-Verbindung zu localhost konfiguriert.
  3. Optional: Wenn Ihre Diagrammserver mit dem Front-end Server über einen anderen URL kommunizieren sollen als den, mit dem auf die Web Benutzeroberfläche zugegriffen wird, klicken Sie auf Webdienst-URL konfigurieren geben Sie diesen URL im Textfeld ein. Dies ist zum Beispiel nötig, wenn Benutzer über einen Proxy auf die Web Benutzeroberfläche zugreifen, während Ihre Diagrammserver den internen URL oder die IP-Adresse des Front-end Servers benötigen.
  4. Klicken Sie auf Neuer Diagrammserver. Das Dialogfeld Neuer Diagrammserver wird angezeigt.
  5. Geben Sie den Hostnamen oder die IP-Adresse, den Port und die URL des Ortes ein, an dem der Diagrammdienst installiert ist. Der Standardport ist 19126, und die Standard-URL lautet ChartServer.
  6. Klicken Sie auf Prüfen, um eine Testverbindung zum Diagrammserver herzustellen. Das Dialogfeld Diagrammserver-Prüfung wird angezeigt.
    Anmerkung: Wenn der Test erfolgreich ist, wird ein Testbild angezeigt. Wenn der Test fehlschlägt, wird eine Fehlernachricht angezeigt. Überprüfen Sie die eingegebenen Daten und vergewissern Sie sich, dass auf dem Zielcomputer ein Diagrammserver installiert ist.
  7. Klicken Sie auf Schließen. War die Testverbindung erfolgreich, aktivieren Sie das Kontrollkästchen Aktiv, und klicken Sie auf OK.

Sie können beliebig viele Diagrammserver definieren. Silk Central implementiert automatisch einen Lastausgleichsmechanismus für die Diagrammerzeugung.

Anmerkung: Sie können nur dann eine Diagrammserver-Verbindung konfigurieren, wenn der Diagrammserverdienst auf dem Zielcomputer installiert ist. Weitere Information finden Sie in den Installationsanweisungen Ihrer Silk Central-Anwendung.
Übergeordnetes Thema: Diagrammserver


Bearbeiten von Diagrammserver-Verbindungen

So bearbeiten Sie eine Diagrammserver-Verbindung:

  1. Klicken Sie im Menü auf Infrastruktur > Diagrammserver
  2. Optional: Wenn Ihre Diagrammserver mit dem Front-end Server über einen anderen URL kommunizieren sollen als den, mit dem auf die Web Benutzeroberfläche zugegriffen wird, klicken Sie auf Webdienst-URL konfigurieren geben Sie diesen URL im Textfeld ein. Dies ist zum Beispiel nötig, wenn Benutzer über einen Proxy auf die Web Benutzeroberfläche zugreifen, während Ihre Diagrammserver den internen URL oder die IP-Adresse des Front-end Servers benötigen.
  3. Klicken Sie in der Spalte Aktionen auf [image] (Bearbeiten). Das Dialogfeld Diagrammserver bearbeiten wird angezeigt.
  4. Bearbeiten Sie Hostname oder IP-Adresse, den Port oder die URL des Ortes, an der Diagrammdienst installiert ist. Der Standardport ist 19126, und die Standard-URL lautet ChartServer.
  5. Aktivieren/deaktivieren Sie das Kontrollkästchen Aktiv, um den Server zu aktivieren/deaktivieren.
  6. Klicken Sie auf Prüfen, um eine Testverbindung zum Diagrammserver herzustellen. Das Dialogfeld Diagrammserver-Prüfung wird angezeigt.
    Anmerkung: Wenn der Test erfolgreich ist, wird ein Testbild angezeigt. Wenn der Test fehlschlägt, wird eine Fehlernachricht angezeigt. Überprüfen Sie die eingegebenen Daten und vergewissern Sie sich, dass auf dem Zielcomputer ein Diagrammserver installiert ist.
  7. Klicken Sie auf Schließen und dann auf OK.
Übergeordnetes Thema: Diagrammserver


Entfernen von Diagrammserver-Verbindungen

So entfernen Sie eine Diagrammserver-Verbindung:

  1. Klicken Sie im Menü auf Infrastruktur > Diagrammserver
  2. Klicken Sie in der Spalte Aktionen auf [image] (Bearbeiten). Das Dialogfeld Diagrammserver bearbeiten wird angezeigt.
  3. Deaktivieren Sie das Kontrollkästchen Aktiv, und klicken Sie auf OK.
  4. Klicken Sie in der Spalte Aktionen auf Löschen (Löschen).
  5. Klicken Sie zum Bestätigen auf Ja.
Anmerkung: Nun wird die Verbindung zum Server entfernt. Der Server selbst wird nicht entfernt.
Übergeordnetes Thema: Diagrammserver


Diagrammserver (Seite)

Melden Sie sich zum Öffnen der Seite bei Silk Central als Systemadministrator an, und klicken Sie auf Infrastruktur > Diagrammserver. Weitere Informationen finden Sie unter Systemadministrator.

Mithilfe dieser Seite können Sie die Verbindungen zu Ihren Diagrammservern verwalten. Klicken Sie auf Neuer Diagrammserver, um eine neue Diagrammserver-Verbindung zu konfigurieren. Webdienst-URL konfigurieren ermöglicht die Konfiguration einer alternativen URL mit der sich Ihre Diagrammserver zum Front-end Server verbinden können. Die Tabelle enthält die folgenden Spalten:

Spalte | Beschreibung
Aktionen | Klicken Sie auf die Schaltflächen [image] oder [image] , um Diagrammserver-Verbindungen zu löschen bzw. zu bearbeiten. Es können nur deaktivierte Verbindungen gelöscht werden.
URL des Diagrammservers | Zeigt die URL des Diagrammservers an. Syntax: http://<Computername oder IP-Adresse>:<Port>/ChartServer. Der Standardport ist 19126. Klicken Sie auf [image] , um die URL zu bearbeiten.
Status | Zeigt an, ob die Verbindung mit dem Diagrammserver aktiv oder inaktiv ist. Klicken Sie auf [image] (Bearbeiten), um den Status einer Verbindung zu ändern.
Erstellt am | Datum, an dem die Verbindung mit dem Diagrammserver erstellt wurde.
Erstellt von | Der Benutzer, der die Verbindung mit dem Diagrammserver erstellt hat.
Geändert am | Datum, an dem die Verbindung mit dem Diagrammserver geändert wurde.
Geändert von | Der Benutzer, der die Verbindung mit dem Diagrammserver geändert hat.
Übergeordnetes Thema: Diagrammserver


E-Mail-Server

Wenn Sie einen E-Mail-Server konfigurieren, kann Silk Central Sie über Ergebnisse Ihrer Anwendung benachrichtigen.

  • Konfigurieren von E-Mail-Servern
    Hier wird beschrieben, wie E-Mail-Server konfiguriert werden.
  • E-Mail-Server (Seite)
    Hier wird die Seite E-Mail-Server beschrieben.
Übergeordnetes Thema: Infrastruktur


Konfigurieren von E-Mail-Servern

So können Sie bis zu drei E-Mail-Server konfigurieren:
  1. Melden Sie sich bei Silk Central als Systemadministrator an. Weitere Informationen finden Sie unter Systemadministrator.
  2. Klicken Sie auf Infrastruktur > E-Mail-Server.
  3. Geben Sie in das Feld E-Mail-Adresse des Systemadministrators eine E-Mail-Adresse ein. Silk Central schickt Benachrichtigungen an diese Adresse.
  4. Geben Sie in das Feld "Von"-Adresse für E-Mails eine E-Mail-Adresse ein. Diese Adresse wird bei den Benachrichtigungen als Absender angezeigt.
  5. Geben Sie den Hostnamen oder die IP-Adresse des E-Mail-Servers in die Felder Server ein. Sie können bis zu drei E-Mail-Server konfigurieren.
  6. Wenn für die Server Anmeldedaten erforderlich sind, geben Sie diese in die Felder Benutzername und Kennwort ein.
  7. Klicken Sie auf Prüfen, um die Verbindung zu den Servern zu testen. Silk Central schickt eine Test-E-Mail an die E-Mail-Adresse, die Sie in Schritt 3 eingegeben haben.
  8. Wenn eine Fehlermeldung angezeigt wird, oder wenn Sie keine E-Mail erhalten, überprüfen Sie die Mail-Einstellungen. Stellen Sie sicher, dass der Hostname Ihres Mailservers korrekt angegeben wurde, und dass auf diesem Computer das SMTP-Protokoll ausgeführt wird.
    Anmerkung: SMTP mit TLS wird zur Zeit nicht unterstützt.
  9. Wenn Sie die Test-E-Mail erhalten, war der Test erfolgreich. Klicken Sie auf Speichern.
Übergeordnetes Thema: E-Mail-Server


E-Mail-Server (Seite)

Melden Sie sich zum Öffnen dieser Seite bei Silk Central als Systemadministrator an, und klicken Sie auf Infrastruktur > E-Mail-Server. Weitere Informationen finden Sie unter Systemadministrator.

Mithilfe dieser Seite können Sie bis zu drei E-Mail-Server konfigurieren. Die Seite enthält folgende Elemente:

Element | Beschreibung
E-Mail-Adresse des Systemadministrators | Gibt die E-Mail-Adresse des Silk Central-Systemadministrators an.
'Von'-Adresse für E-Mails | Legt fest, welcher Name im Feld Von angezeigt wird, wenn jemand eine E-Mail vom System empfängt. Das kann jede beliebige E-Mail-Adresse sein, z. B. System_Nachricht@meinUnternehmen.com.
Server 1 Server 2 Server 3 | Geben Sie die Hostnamen oder IP-Adressen der Server an, die Ihre E-Mail schicken. In vielen Unternehmen heißt dieser Server einfach Mail. Wenn Ihr Mailserver die SMTP-Authentifizierung (LOGIN PLAIN) verwendet, müssen Sie für den Mailserver einen gültigen Benutzernamen und ein gültiges Kennwort eingeben. Wenden Sie sich an Ihren Mailserver-Administrator, wenn Sie nicht über die zur Anmeldung erforderlichen Daten verfügen.
Prüfen | Sendet eine Test-E-Mail an den Empfänger, der im Textfeld E-Mail-Adresse des Systemadministrators definiert wurde.
Speichern | Speichert die Einstellungen.
Zurücksetzen | Löscht alle Werte in den Feldern.
Übergeordnetes Thema: E-Mail-Server


System-Proxy

Ausführungsserver eines Standorts können über einen Proxy mit dem Anwendungsserver kommunizieren. Sobald Sie (als Systemadministrator) einen Proxy-Server konfiguriert haben, können die Mandanten den Proxy aktivieren. Dafür müssen die Client-Benutzer im Menü auf Verwaltung > Ausführungsserver und dann in der Spalte Aktionen auf [image] (Bearbeiten) klicken und das Kontrollkästchen System-Proxy verwenden aktivieren.

  • Konfigurieren eines System-Proxy
    Hier wird beschrieben, wie und wo ein System-Proxy konfiguriert wird.
  • System-Proxy (Seite)
    Hier wird die Seite System-Proxy beschrieben.
Übergeordnetes Thema: Infrastruktur


Konfigurieren eines System-Proxy

So konfigurieren Sie einen System-Proxy:
  1. Melden Sie sich bei Silk Central als Systemadministrator an. Weitere Informationen finden Sie unter Systemadministrator.
  2. Klicken Sie auf Infrastruktur > System-Proxy.
  3. Geben Sie den Host und den Port des Proxy-Servers ein.
  4. Falls erforderlich, geben Sie den Benutzernamen und das Kennwort ein.
  5. Klicken Sie auf Prüfen, um die Verbindung zum Proxy-Server zu testen. Das Ergebnis des Tests wird in einem Dialogfeld angezeigt.
  6. Wenn keine Verbindung hergestellt werden konnte, sollten Sie Ihre Einstellungen überprüfen.
  7. Wenn eine Verbindung hergestellt werden konnte, klicken Sie auf Speichern. Der System-Proxy steht nun zur Verfügung.
Übergeordnetes Thema: System-Proxy


System-Proxy (Seite)

Melden Sie sich zum Öffnen dieser Seite bei Silk Central als Systemadministrator an, und klicken Sie auf Infrastruktur > System-Proxy. Weitere Informationen finden Sie unter Systemadministrator.

Mithilfe dieser Seite können Sie einen System-Proxy konfigurieren. Die Seite enthält folgende Elemente:

Element | Beschreibung
Host | Der Hostname oder die IP-Adresse des Computers, der als System-Proxy dienen soll.
Port | Die Portnummer, von der der System-Proxy empfängt. Der Standardport ist 8080.
Benutzername (optional) | Geben Sie einen gültigen Benutzernamen ein, wenn der Proxy-Server die Eingabe von Benutzerdaten erfordert.
Kennwort (optional) | Geben Sie ein gültiges Kennwort für den Benutzernamen ein.
Prüfen | Testet die Verbindung mit dem Proxy-Server unter Verwendung der angegebenen Benutzerdaten.
Speichern | Speichert die Einstellungen.
Zurücksetzen | Löscht alle Elemente auf dieser Seite.
Übergeordnetes Thema: System-Proxy


Anwendungsservergruppen

Der Anwendungsserver synchronisiert Aufgaben, wie etwa die Verteilung der Ausführungspläne, das Steuern der Ausführungsserver und die Verwaltung der Datenbankkonfiguration. Bevor Sie mit Silk Central arbeiten können, müssen Sie den Anwendungsserverstandort festlegen.

  • Festlegen des Standorts für den Anwendungsserver
    Legen Sie einen Standort für den Anwendungsserver an, wenn dieser nicht bereits automatisch konfiguriert wurde.
Übergeordnetes Thema: Infrastruktur


Festlegen des Standorts für den Anwendungsserver

Wenn Sie sich mit der Standard-Silk Central-Instanz verbinden, müssen Sie keinen Anwendungsserver-Standort festlegen. Das Setupprogramm konfiguriert automatisch Localhost als Anwendungsserver. In diesem Fall können Sie diese Anleitung überspringen. Weitere Informationen zu Installationsoptionen finden Sie in den Installationsanweisungen der Anwendung.

So stellen Sie eine Verbindung zum Anwendungsserver her:

  1. Sobald Sie die Silk Central-Software installiert haben, stellen Sie mit Ihrem Browser eine Verbindung zu Silk Central her.
    Tipp: Die Standard-URL ist http://<Computername>:19120/login (keine Portinformationen nötig wenn Silk Central auf IIS läuft).

    Die Meldung, dass die Verbindung zum Anwendungsserver noch nicht definiert wurde, wird angezeigt.

  2. Geben Sie den Hostnamen oder die IP-Adresse sowie den Port des Anwendungsservers ein. Der Anwendungsserver ist der Computer, auf dem Sie die Anwendungsserver-Komponente von Silk Central installiert haben. Der Standardport ist 19122.
  3. Klicken Sie auf Anmelden, um fortzufahren. Wenn Ihre Angaben korrekt sind und auf dem angegebenen Computer die installierte Software ausgeführt wird, werden Sie auf die Anmeldeseite zurückgeleitet.
Die Seite für die Verwaltung der Datenbank wird angezeigt.
Übergeordnetes Thema: Anwendungsservergruppen
Zugehörige Verweise
Datenbank (Seite)


LDAP-Authentifizierung

Konfigurieren Sie die LDAP-Authentifizierung, damit sich Benutzer über einen LDAP-Server bei Silk Central anmelden können.

LDAP (Lightweight Directory Access Protocol) ist ein offener Netzwerkprotokollstandard für den Zugriff auf Verzeichnisdienste. LDAP stellt einen Mechanismus zum Abfragen und Ändern von Informationen bereit, die sich in einer globalen Informationshierarchie, einem so genannten Directory Information Tree (DIT), befinden. Ein Directory Information Tree enthält normalerweise verschiedene Informationen zu verschiedenen Arten von Netzwerkobjekten, wie Benutzer, Drucker, Anwendungen und andere Netzwerkressourcen.

  • Silk Central LDAP-Integration
    Hier wird die LDAP-Integration in Silk Central beschrieben.
  • LDAP-Authentifizierungslogik
    Hier werden die Authentifizierungsmodi für die Verwendung zur LDAP-Authentifizierung beschrieben.
  • Hinzufügen von LDAP-Servern
    Fügen Sie einen LDAP-Server für die Verwendung mit Silk Central hinzu.
  • Bearbeiten von LDAP-Servern
    Bearbeiten Sie ein LDAP-Serverprofil, wenn Änderungen an der Konfiguration erforderlich sind.
  • Testen von LDAP-Servern
    Testen Sie die Verbindung zu einem LDAP-Server, um festzustellen, ob der Server Ihrem System zur Verfügung steht.
  • Löschen von LDAP-Servern
    Entfernen Sie ein LDAP-Serverprofil aus der Profilliste.
  • LDAP-Server (Seite)
    Hier werden die für Ihr System konfigurierten LDAP-Server aufgeführt.
Übergeordnetes Thema: Infrastruktur
Zugehörige Konzepte
An- und Abmelden


Silk Central LDAP-Integration

Der wichtigste Aspekt der LDAP-Integration in Silk Central ist die Benutzerauthentifizierung. Da es in den meisten Verzeichnissen nicht möglich ist, das Kennwort eines Benutzers abzurufen, muss jedes Mal, wenn ein Benutzer authentifiziert werden muss, auf LDAP zugegriffen werden.

Die LDAP-Integration in Silk Central unterstützt unverschlüsselte wie auch SSL-verschlüsselte Authentifizierung. Der Verzeichnisdienst muss entweder anonyme Abfragen zulassen, oder es muss ein Benutzer angegeben werden, der über Leserechte für das Verzeichnis verfügt.

Übergeordnetes Thema: LDAP-Authentifizierung


LDAP-Authentifizierungslogik

Authentifizierung im Standardmodus bedeutet, dass sich Benutzer nur über LDAP authentifizieren können, wenn ein LDAP-Server definiert und aktiviert ist. Authentifizierung im gemischten Modus bedeutet, dass sich Benutzer entweder über LDAP oder mit lokalen Benutzerdaten anmelden können. Wenn der Benutzer auf einem LDAP-Server verzeichnet ist, jedoch die falschen Anmeldeinformationen eingegeben hat, wird der Zugriff verweigert.

Anmerkung: Für beide Authentifizierungsmodi gilt, dass sich nur Benutzer anmelden können, deren Benutzername in der Silk Central-Datenbank enthalten ist.

Authentifizierung im Standardmodus

Die Authentifizierung im Standardmodus ist verfügbar, wenn mindestens ein LDAP-Server aktiv ist. Jeder definierte LDAP-Server wird überprüft, um festzustellen, ob ein Benutzer (mit einem bestimmten Benutzernamen und Kennwort) authentifiziert werden kann. Der Zugriff wird gewährt, wenn die Authentifizierung auf einem Server erfolgreich durchgeführt wird.

Authentifizierung im gemischten Modus

Wenn kein LDAP-Server definiert ist, können sich die Benutzer nur mit lokalen Benutzerdaten anmelden. Wenn mindestens ein LDAP-Server aktiv ist und ein Benutzerkonto für die Authentifizierung im gemischten Modus konfiguriert ist, wird jeder definierte LDAP-Server überprüft, um zu bestimmen, ob der Benutzer (mit einem bestimmten Benutzernamen und Kennwort) authentifiziert werden kann. Wenn der Benutzer auf keinem der definierten LDAP-Server verzeichnet ist, wird eine Authentifizierung mithilfe der lokalen Datenbank versucht. Der Zugriff wird verweigert, wenn die vom Benutzer eingegebenen Benutzerdaten auch in der lokalen Datenbank nicht enthalten sind. Wenn der Benutzer auf einem LDAP-Server verzeichnet ist, jedoch die falschen Anmeldeinformationen eingegeben hat, wird der Zugriff verweigert.

Übergeordnetes Thema: LDAP-Authentifizierung


Hinzufügen von LDAP-Servern

So konfigurieren Sie einen LDAP-Server für Silk Central:

  1. Klicken Sie im Menü auf Verwaltung > Systemeinstellungen.
  2. Klicken Sie auf die Registerkarte LDAP-Server.
  3. Klicken sie auf Neuer LDAP-Server. Das Dialogfeld Neuer LDAP-Server wird geöffnet.
  4. Geben Sie einen Namen und optional eine Beschreibung für den Server ein. Sie können für den LDAP-Server jeden beliebigen Namen festlegen; dieses Feld hat keinen Einfluss auf die tatsächlichen LDAP-Einstellungen.
  5. Markieren Sie das Kontrollkästchen Aktiv, um den Server für die Verwendung mit Silk Central zu aktivieren. Ist dieses Kontrollkästchen deaktiviert, stehen die Dienste des LDAP-Servers Silk Central nicht zur Verfügung.
  6. Geben Sie den Hostnamen oder die IP-Adresse des LDAP-Servers und den für den LDAP-Dienst zu verwendenden Port an. Der Standardport ist 389. Bei Verwendung von SSL lautet der LDAP-Standardport 636.
  7. Aktivieren Sie das Kontrollkästchen SSL verwenden, um eine Serververbindung über SSL herzustellen. Dieses Kontrollkästchen steht in engem Zusammenhang mit den im Feld Port definierten Einstellungen. Weitere Informationen über das Aufsetzen der Kommunikation über SSL finden Sie unter Kommunikation mit einem externen System über SSL.
  8. Optional: Geben Sie eine Domäne ein, wenn sich Ihre Benutzer mit dem Muster <Domäne>\<Benutzername> auf Silk Central anmelden sollen. Lassen Sie das Feld leer, wenn sich Ihre Benutzer ohne Domänennamen auf Silk Central anmelden sollen. Falls Ihre Silk Central-Installation aus mehreren Mandanten besteht, stellen Sie sicher, dass die angegebene LDAP-Domäne nicht gleich ist wie der Name irgendeines Mandanten, da das Anmeldemuster <Domäne>\<Benutzername> auch zum Anmelden auf die Mandanten verwendet wird.
  9. Optional: Geben Sie im Feld DN-Bind den Domänennamen des Benutzers ein, der zum Binden an den LDAP-Dienst verwendet werden soll. Dieser Benutzer muss über Leseberechtigungen für das Verzeichnis im angegebenen Basis-DN-Stamm verfügen. Enthält dieses Textfeld keine Angabe, wird der anonyme Zugriff verwendet. Ausgenommen sind LDAP-Server, die keinen anonymen Zugriff unterstützen.
  10. Geben Sie das Kennwort des Benutzers ein, der im Feld DN-Bind angegeben wurde. Dies ist nicht erforderlich, wenn ein anonymer Zugriff zulässig ist.
  11. Geben Sie die Stamm-Basis-DN für LDAP-Anfragen ein. Zum Beispiel DC=IhreFirma,DC=com.
  12. Optional: Geben Sie den Benutzer Filter ein, der für LDAP-Abfragen verwendet werden soll.

    Beispiel: (memberOf=CN=Development,CN=Users,DC=yourcompany,DC=com)

    In diesem Beispiel wird der eingeloggte Silk Central-Benutzer vom LDAP-Server abgefragt, jedoch nur wenn dieser Benutzer zum Development-Team gehört. Dies ist zum Beispiel dann hilfreich, wenn Sie die automatische Benutzerkonten-Erstellung aktivieren, aber sicherstellen möchten, dass Silk Central nur Konten für Mitglieder einer bestimmten LDAP-Gruppe anlegt.

  13. Optional: Um Ihre LDAP-Abfrage nach bestimmten Gruppen zu filtern, geben Sie einen Gruppen-Filter ein. Die Syntax ist gleich wie beim Benutzer Filter-Feld.
  14. Klicken Sie auf LDAP-Einstellungen konfigurieren, um Ihre LDAP-Attribute mit den Benutzer- und Gruppen-Einstellungen von Silk Central abzugleichen. Dies ist erforderlich, wenn Sie vor haben, Ihre Benutzer von einem LDAP-Server in Silk Central zu importieren.
  15. Optional: Sie können einstellen, dass Silk Central automatisch ein Silk Central-Benutzerkonto erstellt, wenn sich ein Benutzer zum ersten mal bei Silk Central anmeldet. Wenn in Silk Central für den eingegebenen Benutzernamen noch kein Benutzerkonto vorhanden ist, werden die eingegebenen Benutzerdaten vom LDAP-Server authentifiziert. Ist die Authentifizierung erfolgreich, wird in ein neues Konto mit dem eingegebenen Benutzernamen und dem Kennwort angelegt. Beim Anlegen eines neuen Kontos werden zunächst die allgemeinen Einstellungen, inlkusive Dashboard-Einstellungen, vom ausgewählten Silk Central-Benutzerkonto kopiert, welches als Vorlage dient. Vorname, Nachname und E-Mail-Adresse werden von den entsprechenden LDAP-Werten übernommen. Klicken hierzu neben Erstellen von Benutzerkonten auf Konfigurieren. Wählen Sie im Dialog Erstellen von Benutzerkonten einen Silk Central-Benutzer aus der Liste aus. Abhängig davon, wie Ihr LDAP-Server konfiguriert ist, kann es notwendig sein, die LDAP-Werte von Vorname, Nachname und E-Mail-Adresse anzupassen.
  16. Klicken Sie auf Testen, um die Verbindung zum LDAP-Server zu testen. Weitere Informationen finden Sie unter Testen von LDAP-Servern.
  17. Klicken Sie auf OK, um die Einstellungen zu speichern.
  18. Wenn Sie mehrere LDAP-Server verwenden: Geben Sie bei Reihenfolge eine Nummer an, um die Reihenfolge festzulegen, in der die LDAP-Server für die Authentifizierung abgefragt werden.
Übergeordnetes Thema: LDAP-Authentifizierung
Zugehörige Tasks
Importieren von Gruppen aus LDAP-Servern
Hinzufügen von Projekten
Bearbeiten von Projekten oder Projekt-Baselines
Bearbeiten von LDAP-Servern
Testen von LDAP-Servern


Bearbeiten von LDAP-Servern

So bearbeiten Sie ein LDAP-Serverprofil:

  1. Klicken Sie im Menü auf Verwaltung > Systemeinstellungen.
  2. Klicken Sie auf die Registerkarte LDAP-Server.
  3. Klicken Sie auf den Namen des LDAP-Servers, den Sie bearbeiten möchten. Das Dialogfeld LDAP-Server bearbeiten wird angezeigt.
  4. Geben Sie einen Namen und optional eine Beschreibung für den Server ein. Sie können für den LDAP-Server jeden beliebigen Namen festlegen; dieses Feld hat keinen Einfluss auf die tatsächlichen LDAP-Einstellungen.
  5. Markieren Sie das Kontrollkästchen Aktiv, um den Server für die Verwendung mit Silk Central zu aktivieren. Ist dieses Kontrollkästchen deaktiviert, stehen die Dienste des LDAP-Servers Silk Central nicht zur Verfügung.
  6. Geben Sie den Hostnamen oder die IP-Adresse des LDAP-Servers und den für den LDAP-Dienst zu verwendenden Port an. Der Standardport ist 389. Bei Verwendung von SSL lautet der LDAP-Standardport 636.
  7. Aktivieren Sie das Kontrollkästchen SSL verwenden, um eine Serververbindung über SSL herzustellen. Dieses Kontrollkästchen steht in engem Zusammenhang mit den im Feld Port definierten Einstellungen. Weitere Informationen über das Aufsetzen der Kommunikation über SSL finden Sie unter Kommunikation mit einem externen System über SSL.
  8. Optional: Geben Sie eine Domäne ein, wenn sich Ihre Benutzer mit dem Muster <Domäne>\<Benutzername> auf Silk Central anmelden sollen. Lassen Sie das Feld leer, wenn sich Ihre Benutzer ohne Domänennamen auf Silk Central anmelden sollen. Falls Ihre Silk Central-Installation aus mehreren Mandanten besteht, stellen Sie sicher, dass die angegebene LDAP-Domäne nicht gleich ist wie der Name irgendeines Mandanten, da das Anmeldemuster <Domäne>\<Benutzername> auch zum Anmelden auf die Mandanten verwendet wird.
  9. Optional: Geben Sie im Feld DN-Bind den Domänennamen des Benutzers ein, der zum Binden an den LDAP-Dienst verwendet werden soll. Dieser Benutzer muss über Leseberechtigungen für das Verzeichnis im angegebenen Basis-DN-Stamm verfügen. Enthält dieses Textfeld keine Angabe, wird der anonyme Zugriff verwendet. Ausgenommen sind LDAP-Server, die keinen anonymen Zugriff unterstützen.
  10. Geben Sie das Kennwort des Benutzers ein, der im Feld DN-Bind angegeben wurde. Dies ist nicht erforderlich, wenn ein anonymer Zugriff zulässig ist.
  11. Geben Sie die Stamm-Basis-DN für LDAP-Anfragen ein. Zum Beispiel DC=IhreFirma,DC=com.
  12. Optional: Geben Sie den Benutzer Filter ein, der für LDAP-Abfragen verwendet werden soll.

    Beispiel: (memberOf=CN=Development,CN=Users,DC=yourcompany,DC=com)

    In diesem Beispiel wird der eingeloggte Silk Central-Benutzer vom LDAP-Server abgefragt, jedoch nur wenn dieser Benutzer zum Development-Team gehört. Dies ist zum Beispiel dann hilfreich, wenn Sie die automatische Benutzerkonten-Erstellung aktivieren, aber sicherstellen möchten, dass Silk Central nur Konten für Mitglieder einer bestimmten LDAP-Gruppe anlegt.

  13. Optional: Um Ihre LDAP-Abfrage nach bestimmten Gruppen zu filtern, geben Sie einen Gruppen-Filter ein. Die Syntax ist gleich wie beim Benutzer Filter-Feld.
  14. Klicken Sie auf LDAP-Einstellungen konfigurieren, um Ihre LDAP-Attribute mit den Benutzer- und Gruppen-Einstellungen von Silk Central abzugleichen. Dies ist erforderlich, wenn Sie vor haben, Ihre Benutzer von einem LDAP-Server in Silk Central zu importieren.
  15. Optional: Sie können einstellen, dass Silk Central automatisch ein Silk Central-Benutzerkonto erstellt, wenn sich ein Benutzer zum ersten mal bei Silk Central anmeldet. Wenn in Silk Central für den eingegebenen Benutzernamen noch kein Benutzerkonto vorhanden ist, werden die eingegebenen Benutzerdaten vom LDAP-Server authentifiziert. Ist die Authentifizierung erfolgreich, wird in ein neues Konto mit dem eingegebenen Benutzernamen und dem Kennwort angelegt. Beim Anlegen eines neuen Kontos werden zunächst die allgemeinen Einstellungen, inlkusive Dashboard-Einstellungen, vom ausgewählten Silk Central-Benutzerkonto kopiert, welches als Vorlage dient. Vorname, Nachname und E-Mail-Adresse werden von den entsprechenden LDAP-Werten übernommen. Klicken hierzu neben Erstellen von Benutzerkonten auf Konfigurieren. Wählen Sie im Dialog Erstellen von Benutzerkonten einen Silk Central-Benutzer aus der Liste aus. Abhängig davon, wie Ihr LDAP-Server konfiguriert ist, kann es notwendig sein, die LDAP-Werte von Vorname, Nachname und E-Mail-Adresse anzupassen.
  16. Klicken Sie auf Testen, um die Verbindung zum LDAP-Server zu testen. Weitere Informationen finden Sie unter Testen von LDAP-Servern.
  17. Klicken Sie auf OK, um die Einstellungen zu speichern.
Übergeordnetes Thema: LDAP-Authentifizierung
Zugehörige Tasks
Hinzufügen von LDAP-Servern
Testen von LDAP-Servern


Testen von LDAP-Servern

So testen Sie die Verbindung zu einem LDAP-Server:

  1. Wenn Sie in Silk Central ein LDAP-Serverprofil hinzufügen oder bearbeiten, wird im Dialog LDAP-Server hinzufügen bzw. LDAP-Server bearbeiten die Schaltfläche Testen angezeigt.
  2. Klicken Sie auf Testen, um den Dialog LDAP-Konfiguration testen zu öffnen.
  3. Geben Sie im Feld Benutzername einen Benutzernamen ein, der für den Test der LDAP-Authentifizierung verwendet werden soll.
  4. Geben Sie im Feld Kennwort das Kennwort des Benutzers ein, der für den Test der LDAP-Authentifizierung verwendet werden soll.
  5. Klicken Sie auf Testen, um den Authentifizierungstest durchzuführen.
    Anmerkung: Wenn Tests fehlschlagen, werden auch LDAP-Fehlercodes angegeben.
    Ein Dialog zeigt an, ob der Test erfolgreich war.
  6. Klicken Sie auf Schließen, um wieder zum Dialog LDAP-Server hinzufügen bzw. LDAP-Server bearbeiten zurückzukehren. Wenn die Testverbindung nicht erfolgreich war, bearbeiten Sie Ihre Einstellungen und wenden Sie sich an den Systemadministrator. Beginnen Sie anschließend wieder mit Schritt 2.
Übergeordnetes Thema: LDAP-Authentifizierung
Zugehörige Tasks
Hinzufügen von LDAP-Servern
Bearbeiten von LDAP-Servern


Löschen von LDAP-Servern

So löschen Sie ein LDAP-Serverprofil:

  1. Klicken Sie im Menü auf Verwaltung > Systemeinstellungen.
  2. Klicken Sie auf die Registerkarte LDAP-Server.
  3. Wenn der LDAP-Server aktiv ist, müssen Sie ihn zuerst deaktivieren, bevor Sie ihn löschen können. Klicken Sie auf den Namen des LDAP-Servers, den Sie löschen möchten. Das Dialogfeld LDAP-Server bearbeiten wird angezeigt.
  4. Deaktivieren Sie das Kontrollkästchen Aktiv, um den Server zu deaktivieren, und klicken Sie auf OK.
  5. Klicken Sie in der Spalte Aktionen des LDAP-Servers, den Sie löschen möchten, auf Löschen (Löschen).
  6. Klicken Sie auf Ja, um das Löschen zu bestätigen.
Übergeordnetes Thema: LDAP-Authentifizierung


LDAP-Server (Seite)

Verwaltung > System > LDAP-Server

Auf der Seite LDAP-Server werden alle konfigurierten LDAP-Server aufgeführt. Mithilfe dieser Seite können Sie LDAP-Server verwalten.

Sie können auf dieser Seite die folgenden Aktionen ausführen:

  • Klicken Sie auf Neuer LDAP-Server, um einen neuen LDAP-Server zu konfigurieren.
  • Geben Sie bei Reihenfolge eine Nummer an, um die Reihenfolge festzulegen, in der die LDAP-Server für die Authentifizierung abgefragt werden.
  • Wählen Sie einen vorhandenen LDAP-Server in der Liste aus, um die Einstellungen zu bearbeiten.
  • Klicken Sie in der Spalte Aktionen auf Löschen (Löschen), um den LDAP-Server zu löschen (zuvor müssen Sie den LDAP-Server deaktivieren).
Übergeordnetes Thema: LDAP-Authentifizierung
Zugehörige Tasks
Hinzufügen von LDAP-Servern
Bearbeiten von LDAP-Servern
Testen von LDAP-Servern


Agenten-Cluster für Silk Performer-Lasttests

Neben der Zuweisung von Lasttest-Szenarien an einzelne Agenten kann in Silk Performer das Lasttest-Szenario auch Agenten-Clustern zugewiesen werden, die über definierte Fähigkeiten verfügen.Die dynamische Zuweisung von Lasttest-Szenarien durch Silk Performer entspricht zur Ausführungszeit bestimmten Lasttestanforderungen an die Wiedergabefähigkeiten der verfügbaren Agentencomputer. Diese in Silk Performer für Testagenten definierten Fähigkeiten werden verwendet, um die Zuweisungen der Lasttest-Szenarien pro Agenten zu optimieren. Wenn beispielsweise ein Test ein Lasttest-Szenario voraussetzt, das nur ein Agentencomputer erfüllen kann, auf dem ein SAPGUI-Mandanten installiert ist, dann kann die dynamische Zuweisung sicherstellen, dass das Lasttest-Szenario nur solchen verfügbaren Agenten zugewiesen wird, auf denen SAPGUI-Mandanten installiert sind. Darüber hinaus kann auch der Prozentsatz der erforderlichen Lasttest-Szenarien oder der virtuellen Benutzer, der jedem Agenten zugewiesen werden soll, konfiguriert werden. Dies stellt sicher, dass Agenten nicht über ihre Kapazitäten hinaus belastet werden.

Infolge der Ausführung eines Silk Performer-Tests wird aus dem entsprechenden Ausführungsserver eine Silk Central-XML-Datei für Agenten-Cluster für Lasttests ausgecheckt. Diese Datei wird während der Ausführung für die dynamische Zuweisung des Lasttest-Szenarios verwendet. Sie müssen in den Einstellungen unter Verwaltung > System den Speicherort der einem Agenten-Cluster für Lasttests zugehörigen XML-Datei angeben.

Ein Vorteil der dynamischen Zuweisung von Lasttest-Szenarien an Agenten-Cluster besteht darin, dass die erfolgreiche Ausführung von Tests nicht davon abhängt, dass eine statische Ausführungsumgebung für die Tests aufrechterhalten wird. Silk Performer kann die Last eines nicht verfügbaren Agenten dynamisch einem verfügbaren Agenten im gleichen Cluster zuordnen, der über dieselben Fähigkeiten verfügt. Dies ist besonders dann nützlich, wenn Silk Performer-Lasttests anhand von vordefinierten Ausführungsterminen in Silk Central verwaltet und ausgeführt werden. Silk Central ist nicht für die Verteilung der Lasttest-Szenarien auf die Agenten sowie die Verwaltung des Zustands einzelner Agenten zuständig.

Umfassende Informationen zur dynamischen Zuweisung von Lasttest-Szenarien finden Sie in der Silk Performer-Hilfe.

  • Hochladen von Dateien für Agenten-Cluster für Lasttests
    Bearbeiten Sie die Agenten-Cluster-Dateien für Lasttests Ihrer Projekte, um die dynamische Zuweisung von Lasttest-Szenarien in Silk Performer zu unterstützen.
  • Löschen von Dateien für Agenten-Cluster für Lasttests
    Löschen Sie eine Datei für Agenten-Cluster für Lasttests, um sie vom Anwendungsserver zu entfernen.
  • Bearbeiten von Dateien für Agenten-Cluster für Lasttests
    Bearbeiten Sie die Agenten-Cluster-Dateien für Lasttests Ihrer Projekte, um die dynamische Zuweisung von Lasttest-Szenarien in Silk Performer zu unterstützen.
  • Agenten-Cluster für Lasttests (Seite)
    Hier wird die aktuelle XML-Datei für Agenten-Cluster für Lasttests angezeigt.
Übergeordnetes Thema: Infrastruktur


Hochladen von Dateien für Agenten-Cluster für Lasttests

Hier wird beschrieben, wie Agenten-Cluster-Dateien für Lasttests in Ihrem Projekt zur Unterstützung der dynamischen Zuweisungen von Lasttest-Szenearien in Silk Performer hinzugefügt oder geändert werden.

So ändern Sie die Dateidefinition der Agenten-Cluster Ihres Projekts:

  1. Klicken Sie im Menü auf Verwaltung > Systemeinstellungen.
  2. Klicken Sie auf die Registerkarte Agenten-Cluster für Lasttests.
  3. Klicken Sie auf Hochladen.
  4. Navigieren Sie im Dialogfeld Agenten-Cluster-Datei hochladen zu dem Speicherort auf der lokalen Festplatte, in dem sich die Agenten-Cluster-Datei befindet. Wenn Sie die Datei hochladen, wird sie auf der Seite Agenten-Cluster für Lasttests angezeigt.
  5. Klicken Sie auf OK, um die Auswahl zu bestätigen.
Übergeordnetes Thema: Agenten-Cluster für Silk Performer-Lasttests
Zugehörige Tasks
Bearbeiten von Dateien für Agenten-Cluster für Lasttests


Löschen von Dateien für Agenten-Cluster für Lasttests

Löschen Sie eine Datei für Agenten-Cluster für Lasttests, um sie vom Anwendungsserver zu entfernen.

So löschen Sie eine Datei für Agenten-Cluster für Lasttests:

  1. Klicken Sie im Menü auf Verwaltung > Systemeinstellungen.
  2. Klicken Sie auf die Registerkarte Agenten-Cluster für Lasttests.
  3. Klicken Sie auf Löschen.
  4. Klicken Sie zum Bestätigen auf Ja.
Übergeordnetes Thema: Agenten-Cluster für Silk Performer-Lasttests


Bearbeiten von Dateien für Agenten-Cluster für Lasttests

So bearbeiten Sie die Dateidefinition der Agenten-Cluster Ihres Projekts:

  1. Klicken Sie im Menü auf Verwaltung > Systemeinstellungen.
  2. Klicken Sie auf die Registerkarte Agenten-Cluster für Lasttests.
  3. Klicken Sie auf den Namen der Agenten-Cluster-Datei für Lasttests, die Sie ändern möchten.
  4. Laden Sie die Datei herunter.
  5. Bearbeiten Sie die Datei in einem Editor.
  6. Laden Sie die Datei hoch. Weitere Informationen finden Sie unter Hochladen von Dateien für Agenten-Cluster für Lasttests.
Übergeordnetes Thema: Agenten-Cluster für Silk Performer-Lasttests
Zugehörige Tasks
Hochladen von Dateien für Agenten-Cluster für Lasttests


Agenten-Cluster für Lasttests (Seite)

Verwaltung > Systemeinstellungen > Agenten-Cluster für Lasttests

Auf der Seite Agenten-Cluster für Lasttests wird die aktuell konfigurierte XML-Datei für Agenten-Cluster für Lasttests angezeigt. Mithilfe dieser Seite können Sie Silk Performer-Agenten-Cluster für Lasttests zur Unterstützung von dynamischen Lasttest-Szenarienzuweisungen verwalten.

Sie können auf dieser Seite die folgenden Aktionen ausführen:

  • Klicken Sie auf die Schaltfläche Hochladen, um eine vorhandene XML-Datei für Agenten-Cluster für Lasttests hochzuladen.
  • Klicken Sie auf die Schaltfläche Löschen, um eine vorhandene XML-Datei für Agenten-Cluster für Lasttests zu entfernen.
  • Klicken Sie auf den Namen der Agenten-Cluster-Datei für Lasttests, um die Datei herunterzuladen und zu bearbeiten.
Übergeordnetes Thema: Agenten-Cluster für Silk Performer-Lasttests


Systemdiagnose

Über die Registerkarte Systemdiagnose können Sie Diagnosedaten und Systemlogdateien abrufen.

  • Systemdiagnose
    Hier wird beschrieben, wie Sie Systemdiagnosedaten anzeigen und herunterladen.
  • Front-End-Server-Logdateien
    Hier werden die Front-End-Server-Logdateien beschrieben.
  • Anwendungsserver-Logs
    Hier werden die Anwendungsserver-Logs beschrieben.
Übergeordnetes Thema: Verwalten von Mandanten
Zugehörige Konzepte
Für Micro Focus SupportLine erforderliche Informationen


Systemdiagnose

Über die Seite Systemdiagnose können Sie die folgenden Systeminformationen abrufen:

  • Produktversion.
  • Version und Typ der Datenbank.
  • Verwendete Integrationen.
  • Informationen zu Systemumgebung und Systemeigenschaften.
  • JDBC-Informationen.
  • Datenbankstatistiken: Anzahl der Projekte, Testtypen, Indizes, Trigger, Constraints.
  • Logdateien für Anwendungsserver und Front-End-Server.

Die Seite kann gezippt und in das lokale Dateisystem heruntergeladen werden. Klicken Sie dazu auf die Schaltfläche Download. Über die entsprechenden Kontrollkästchen können Sie die Server-Logdateien auswählen, die heruntergeladen werden sollen.

  1. Sie können extern auf die Systemdiagnose-Seite zugreifen oder, wenn Sie sich nicht mehr beim System anmelden können, lokal auf dem Computer auf dem der Front-End-Server läuft.
    • Für externen Zugriff:
      1. Melden Sie sich als Systemadministrator an.
      2. Klicken Sie auf Systemdiagnose > Systemdiagnose.
      3. Klicken Sie auf Systemdiagnose öffnen.
    • Wenn externer Zugriff nicht mehr geht:
      1. Navigieren Sie zu http://localhost:19120/systemdiagnostics oder http://127.0.0.1:19120/systemdiagnostics auf dem Computer, auf dem der Front-End-Server läuft (verwenden Sie nicht den Hostnamen oder die externe IP-Adresse des Servers).
  2. Über die entsprechenden Kontrollkästchen können Sie die Silk Central-Server-Logdateien auswählen, die heruntergeladen werden sollen.
  3. Klicken Sie auf Download, um die Daten zu zippen und in das lokale Dateisystem herunterzuladen.
Übergeordnetes Thema: Systemdiagnose
Übergeordnetes Thema: Kontaktaufnahme mit Micro Focus


Front-End-Server-Logdateien

Melden Sie sich zum Öffnen dieser Seite als Systemadministrator an, und klicken Sie auf Systemdiagnose > Front-End-Server-Logdateien. Weitere Informationen finden Sie unter "Systemadministrator".

Mithilfe dieser Seite können Sie Protokolldaten des Silk Central-Front-End-Serverdienstes anzeigen.

Zu jeder Log-Datei werden folgende Spalten angezeigt:

Spalte | Beschreibung
Aktionen | Klicken Sie auf die Schaltflächen [image] oder [image] , um Logdateien zu löschen oder herunterzuladen.
Name | Der Name der Logdatei.
Größe | Die physische Größe der Logdatei.
Datum | Datum, an dem die Logdatei zuletzt gespeichert wurde.
Übergeordnetes Thema: Systemdiagnose
Zugehörige Konzepte
Systemadministrator


Anwendungsserver-Logs

Melden Sie sich zum Öffnen der Seite als Systemadministrator an, und klicken Sie auf Systemdiagnose > Anwendungsserver-Logdateien. Weitere Informationen finden Sie unter "Systemadministrator".

Mithilfe dieser Seite können Sie Protokolldaten des Silk Central-Anwendungsserverdienstes anzeigen.

Zu jeder Log-Datei werden folgende Spalten angezeigt:

Spalte | Beschreibung
Aktionen | Klicken Sie auf die Schaltflächen [image] oder [image] , um Logdateien zu löschen oder herunterzuladen.
Name | Der Name der Logdatei.
Größe | Die physische Größe der Logdatei.
Datum | Datum, an dem die Logdatei zuletzt gespeichert wurde.
Übergeordnetes Thema: Systemdiagnose
Zugehörige Konzepte
Systemadministrator


Konfigurieren erweiterter Einstellungen

In diesem Abschnitt wird beschrieben, wie erweiterte Einstellungen zur Anpassung Ihres Silk Central-Systems konfiguriert werden.

  • Anmeldeoptionen
    Beschreibung der erweiterten Anmeldekonfigurationen.
  • Verdächtige Ausführungsdauer
    Hier wird beschrieben, wie Sie den Administrator per E-Mail benachrichtigen können, wenn eine Ausführung zu lange dauert.
  • Deaktivieren der Aktualisierung externer Fehlerstatistiken
    Hier wird beschrieben, wie Sie die Aktualisierung der Fehlerstatistiken externer Fehlerverfolgungsprofile deaktivieren.
  • Datums- und Zeitformate
    Hier wird beschrieben, wie mit benutzerdefinierten Einstellungen für Datums- und Zeitformate von Silk Central gearbeitet wird.
  • Hostnamensanzeige
    Hier wird beschrieben, wie der Hostname des Front-End-Servers in der Titelleiste des Webbrowsers angezeigt werden kann.
  • Speichern von Anhängen und Ergebnisdateien auf dem Dateisystem
    Standardmäßig speichert Silk Central alle Anhänge und Ergebnisdateien in der Datenbank, aber Sie können Silk Central so konfigurieren, dass es diese Dateien auf dem Dateisystem des Anwendungsservers speichert.
  • Konfigurieren von LQM Reporting Updater
    Konfigurieren Sie die Einstellungen (z. B. das Intervall) des Threads zur Aktualisierung der LQM Reporting-Tabellen (LQM Reporting Updater).
  • Ausführungstermine für die automatische LDAP-Synchronisierung planen
    Wenn Sie Benutzergruppen aus LDAP-Servern in Ihr Silk Central-System importiert haben, können Sie einen Ausführungstermin festlegen, zu dem Ihre Silk Central-Gruppen automatisch mit den Änderungen auf dem LDAP-Server synchronisiert werden.
  • Zwischenspeicherung von Daten in Tests
    Hier wird beschrieben, wie in Silk Central Daten zwischengespeichert werden, um die Skalierbarkeit des Front-End-Servers zu verbessern und die Datenbanklast zu verringern.
  • Konfigurieren der JMX-Einstellungen
    Hier werden die Servergruppen beschrieben, für die JMX-Einstellungen konfiguriert werden können.
  • Hostnamenauflösung des Ausführungsservers
    Ein Ausführungsserver wird unter Umständen nicht mehr vom Anwendungsserver erkannt, wenn sich seine IP-Adresse geändert hat.
  • Konfigurieren des Silk Central-Standorts in Issue Manager
    Konfigurieren Sie den Standort Ihrer Silk Central-Installation in Issue Manager, um Probleme aus Tests nachverfolgen zu können.
  • Deaktivieren nicht verwendeter Ports auf Ausführungsservern
    Deaktivieren Sie Ports, die von Ausführungsservern nicht verwendet werden.
  • Festlegen der Anzahl zuletzt angezeigter Berichte
    Legen Sie die Anzahl zuletzt angezeigter Berichte fest, zwischen denen im Bereich Berichte in dem Listenfeld Zuletzt verwendete Berichte gewählt werden kann.
  • Speichereinstellungen für Silk Central-Server
    Hier werden die Speichereinstellungen für die Silk Central-Server beschrieben.
  • Festlegen der maximalen Größe von Testschritt-Ergebnisdateien
    Hier wird beschrieben, wie die Größe von Ergebnisdateien begrenzt wird, die Tester während der Durchführung manueller Tests an Testschritte anhängen können.
  • Speichern von Perzentil-Markierungsdaten für Silk Performer-Testergebnisse
    Schalten Sie das Speichern von Perzentil-Markierungsdaten für Silk Performer-Testergebnisse frei, wenn Sie auf diese Informationen zugreifen möchten.
Übergeordnetes Thema: Konfigurieren und Verwalten der Infrastruktur


Anmeldeoptionen

Die folgenden beiden erweiterten Anmeldekonfigurationen sind verfügbar:

Benutzerdaten merken

Ändert die Standardeinstellung für die Option Benutzerdaten merken auf der Silk Central-Anmeldeseite.

Wenn Benutzer mit mehreren Browserfenster arbeiten, wird normalerweise für jede Browsersitzung eine eigene Lizenz ausgecheckt. Wenn die Option Benutzerdaten merken aktiviert ist, können einzelne Benutzer auf einem Computer mit mehreren Browsersitzungen arbeiten, ohne mehrere Lizenzen auszuchecken.

Jeder Benutzer kann bei Bedarf die Option Benutzerdaten merken aktivieren oder deaktivieren, nur der Administrator kann jedoch die Standardeinstellung festlegen.

Cookie-Dauer

Jedes Mal, wenn ein Benutzer auf Silk Central zugreift, wird ein Cookie mit kodierten Anmeldeinformationen erstellt. Diese Cookies werden gelöscht, wenn sich der Benutzer abmeldet oder wenn die Sitzung wegen einer Wartezeitüberschreitung beendet wird. Wenn die Option Benutzerdaten merken aktiviert ist, werden Cookies bei Wartezeitüberschreitungen von Sitzungen nicht gelöscht. Stattdessen bleiben sie über die angegebene Zeitdauer aktiv. Die Benutzer können dann weiter mit Silk Central arbeiten, statt nach jeder Wartezeitüberschreitung in einer Sitzung die Anmeldeinformationen erneut eingeben zu müssen. Standardmäßig bleiben Cookies 30 Tage lang aktiv. Die Einstellung dieser Gültigkeitsdauer kann vom Administrator angepasst werden.

  • Konfigurieren der Option "Benutzerdaten merken"
    Konfigurieren Sie die Option Benutzerdaten merken, damit einzelne Benutzer auf einem Computer mit mehreren Browsersitzungen arbeiten können, ohne mehrere Lizenzen auszuchecken.
  • Anpassen der Cookie-Dauer
    Durch das Anpassen der Gültigkeitsdauer von Anmelde-Cookies können Sie den Zeitraum ändern, für den das System Ihre Anmeldedaten speichert.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Zugehörige Konzepte
Super User
Zugehörige Tasks
Anmelden bei Silk Central


Konfigurieren der Option "Benutzerdaten merken"

So aktivieren oder deaktivieren Sie die Option "Benutzerdaten merken":
  1. Stoppen Sie den Front-End-Server der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei SccFrontendBootConf.xml in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\FontendServer auf dem Front-End-Server.
  3. Suchen Sie das XML-Tag BootConf\Options\Login\RememberLogin. Die Standardeinstellung dieses Tags lautet <RememberLogin>true</RememberLogin>.
  4. Legen Sie den Wert false fest, wenn das Kontrollkästchen Benutzerdaten merken auf der Anmeldeseite standardmäßig deaktiviert sein soll. Legen Sie den Wert true fest, wenn das Kontrollkästchen Benutzerdaten merken auf der Anmeldeseite standardmäßig aktiviert sein soll.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Front-End-Server neu.
Übergeordnetes Thema: Anmeldeoptionen
Zugehörige Tasks
Verwalten von Instanzen


Anpassen der Cookie-Dauer

So legen Sie die Gültigkeitsdauer von Anmelde-Cookies fest:

  1. Stoppen Sie den Front-End-Server der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei SccFrontendBootConf.xml in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\FontendServer auf dem Front-End-Server.
  3. Suchen Sie das XML-Tag BootConf\Options\Login\MaxCookieAge. Die Standardeinstellung dieses Tags lautet <MaxCookieAge>30</MaxCookieAge>.
  4. Legen Sie als Wert die Anzahl von Tagen fest, die Anmelde-Cookies auf den Computern der Benutzer aktiv bleiben sollen.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Front-End-Server neu.
Übergeordnetes Thema: Anmeldeoptionen
Zugehörige Tasks
Verwalten von Instanzen


Verdächtige Ausführungsdauer

Die Dauer der Test-Ausführung ist unterschiedlich. Wenn eine Ausführung jedoch zu lange dauert, kann der Benutzer, der die letzte Änderung an der Testsuite vorgenommen hat, per E-Mail benachrichtigt werden.

Silk Central sendet eine Benachrichtigung, wenn die Ausführung eines Tests einen längeren Zeitraum als definiert in Anspruch nimmt. Der Benutzer kann festlegen, wie lange die Ausführung eines Tests dauern darf, bevor eine E-Mail-Nachricht gesendet wird.

Anmerkung: Sie können auch einen Timeout für die einzelnen Tests einrichten. Geben Sie dazu die Eigenschaft Testausführungs-Timeout [s] im Abschnitt Erfolgsbedingungen des Bereichs Tests an.
  • Festlegen der verdächtigen Ausführungsdauer
    Legen Sie den Zeitraum fest, den die Ausführung eines Tests in Anspruch nehmen darf, bevor Silk Central eine Benachrichtigung an den Administrator sendet.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen


Festlegen der verdächtigen Ausführungsdauer

So legen Sie die verdächtige Ausführungsdauer fest:

  1. Stoppen Sie den Anwendungsserver der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei TmAppServerHomeConf.xml mit einem Texteditor.
    Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\AppServer auf dem Anwendungsserver.
  3. Suchen Sie den XML-Tag Config\ExecutionTracking\SuspicousDuration. Die Standardeinstellung für dieses Tag ist <SuspicousDuration>360</SuspicousDuration>.
  4. Legen Sie als Wert die Anzahl von Minuten fest, nach deren Ablauf Silk Central den Administrator über die Tests, die zu lange dauern, benachrichtigen soll.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Anwendungsserver neu.
Übergeordnetes Thema: Verdächtige Ausführungsdauer
Zugehörige Tasks
Verwalten von Instanzen


Deaktivieren der Aktualisierung externer Fehlerstatistiken

Die Aktualisierung der Fehlerstatistiken externer Fehlerverfolgungsprofile kann sehr speicherintensiv sein. Dadurch kann die Systemleistung beeinträchtigt werden. So deaktivieren Sie die Aktualisierung:
  1. Stoppen Sie den Anwendungsserver der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei TmAppServerHomeConf.xml mit einem Texteditor.
    Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\AppServer auf dem Anwendungsserver.
  3. Suchen Sie den XML-Tag Config/IssueStateUpdate/UpdateIssueUnitStatistics. Die Standardeinstellung dieses Tags lautet true.
  4. Setzen Sie den Wert auf false, um die Aktualisierung zu deaktivieren.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Anwendungsserver neu.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Zugehörige Tasks
Verwalten von Instanzen


Datums- und Zeitformate

Silk Central ermöglicht benutzerdefinierte Einstellungen für Datums- und Zeitformate. Jeder Silk Central-Benutzer kann seine Benutzereinstellungen ändern. Hierzu zählen auch Optionen für die Anzeige von Datumsformaten in Lang- und Kurzformen. Weitere Informationen finden Sie unter Bearbeiten von Benutzerkonten.

Silk Central zeigt Listen mit vordefinierten Datums- und Zeitformaten an, die Benutzer auswählen können. Silk Central-Administratoren können diese Listen mit benutzerdefinierten Formaten füllen.

Formatdefinition

Datums- und Zeitformate werden durch Datums- und Zeitformatstrings festgelegt. In Datums- und Zeitformatstrings werden nicht in Anführungszeichen gesetzte Buchstaben von "A" bis "Z" und von "a" bis "z" als Formatzeichen interpretiert, die die Komponenten einer Datums- oder Zeitangabe darstellen. Textzeichen können in einfache Anführungszeichen (') gesetzt werden, wenn sie nicht interpretiert werden sollen. "''" steht für ein einfaches Anführungszeichen. Alle anderen Zeichen werden nicht interpretiert; sie werden beim Formatieren einfach in den Ausgabestring kopiert oder beim Parsen mit dem Eingabestring abgeglichen.

Die folgenden Formatmusterbuchstaben sind definiert. Alle Zeichen von "A" bis "Z" und von "a" bis "z" sind reserviert:
Buchstabe | Datums- oder Zeitkomponente | Darstellung | Beispiele
G | Bezeichner des Zeitalters | Text | AD (Anno Domini, n. Chr.)
y | Jahr | Jahr | 1996; 96
M | Monat im Jahr | Monat | Juli; Jul; 07
w | Kalenderwoche | Zahl | 27
W | Woche im Monat | Zahl | 2
D | Tag im Jahr | Zahl | 189
t | Tag im Monat | Zahl | 10
F | Wochentag im Monat | Zahl | 2
E | Wochentag | Text | Dienstag; Di
ein | AM/PM-Markierung | Text | PM
H | Stunde (0-23) | Zahl | 0
k | Stunde (1-24) | Zahl | 24
K | Stunde mit AM/PM-Angabe (0-11) | Zahl | 0
h | Stunde mit AM/PM-Angabe (1-12) | Zahl | 12
m | Minute | Zahl | 30
s | Sekunde | Zahl | 55
S | Millisekunde | Zahl | 978
z | Zeitzone | Allgemeine Zeitzone | Pacific Standard Time; PST; GMT-08:00
Z | Zeitzone | RFC 822-Zeitzone | -0800

Die Buchstaben werden im Formatmuster für gewöhnlich wiederholt, da die genaue Darstellung durch ihre Anzahl festgelegt wird.

Nachfolgend werden die Einträge in der Spalte Darstellung der obigen Tabelle erläutert:
Element
Beschreibung
Text
Für das Formatieren gilt: Wenn mehr als 4 Buchstaben angegeben werden, wird das lange Datumsformat verwendet, andernfalls wird das kurze Datumsformat verwendet, sofern verfügbar. Für das Parsen gilt: Beide Formen werden unabhängig von der Anzahl der Buchstaben im Formatmuster akzeptiert.
Zahl
Für das Formatieren gilt: Die Anzahl der Buchstaben im Formatmuster entspricht der kleinsten Anzahl von Stellen, und kürzere Zahlen werden mit Nullen auf diese Anzahl von Stellen aufgefüllt. Für das Parsen gilt: Die Anzahl der Buchstaben im Formatmuster wird ignoriert, sofern sie nicht zum Trennen benachbarter Felder benötigt wird.
Jahr
Für das Formatieren gilt: Wenn 2 Buchstaben angegeben werden, wird die Jahresangabe auf 2 Stellen gekürzt; andernfalls wird sie als Zahl interpretiert.
Monat
Wenn 3 oder mehr Buchstaben angegeben werden, wird die Monatsangabe als Text interpretiert. Andernfalls wird sie als Zahl interpretiert.
Allgemeine Zeitzone
Zeitzonen werden als Text interpretiert, wenn sie einen Namen haben. Wenn weniger als 4 Buchstaben im Formatmuster angegeben werden, wird die für die Zeitzone gebräuchliche Abkürzung angezeigt, z. B. PST. Wenn das Formatmuster 4 oder mehr Buchstaben umfasst, wird der volle Name angezeigt, z. B. Pacific Standard Time.
RFC 822-Zeitzone
Das in RFC 822 beschriebene vierstellige Zeitzonenformat wird verwendet, z. B. -0800.

Beispiele

Die folgenden Beispiele zeigen, wie Datums- und Uhrzeitformatmuster in den USA interpretiert werden. Gegeben sind folgendes Datum und folgende Uhrzeit: 04.07.2001 12:08:56 Ortszeit, Zeitzone Pacific Standard Time.
Datums- und Zeitformate | Ergebnis
"dd.MM.yyyy. G 'um' HH:mm:ss z" | 04.07.2001. AD um 12:08:56 PDT
"EEE, MMM d, ''yy" | Wed, Jul 4, '01
"h:mm a" | 12:08 PM
"hh 'Uhr' a, zzzz" | 12 Uhr PM, Pacific Daylight Time
"K:mm a, z" | 0:08 PM, PDT
"yyyyy.MMMMM.dd GGG hh:mm aaa" | 02001.July.04 AD 12:08 PM
"EEE, d MMM yyyy HH:mm:ss Z" | Wed, 4 Jul 2001 12:08:56 -0700
"yyMMddHHmmssZ" | 010704120856-0700
  • Anpassen von Datums- und Zeitformaten
    Passen Sie Datums- und Zeitformate an, um die Daten Ihren Bedürfnissen entsprechend anzuzeigen.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Zugehörige Tasks
Hinzufügen von Benutzerkonten
Bearbeiten von Benutzerkonten
Löschen von Benutzerkonten


Anpassen von Datums- und Zeitformaten

So passen Sie Datums- und Zeitformate an:

  1. Stoppen Sie den Front-End-Server der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei SccFrontendBootConf.xml in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\FontendServer auf dem Front-End-Server.
  3. Suchen Sie das XML-Tag DateFormats. Aus den XML-Tags <LongDateFormats> und <ShortDateFormats> geht hervor, welche Datumsformate standardmäßig verfügbar sind. Sie können beliebige Formate hinzufügen oder löschen, die den Benutzern zur Verfügung bzw. nicht zur Verfügung stehen sollen.
  4. Geben Sie Zeitformate wie unter Datums- und Zeitformate beschrieben ein.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Front-End-Server neu.
Übergeordnetes Thema: Datums- und Zeitformate
Zugehörige Tasks
Verwalten von Instanzen


Hostnamensanzeige

Wenn Sie mit Webanwendungen auf mehreren Front-End-Servern arbeiten, kann es nützlich sein, zu wissen, auf welchem Host Sie gerade arbeiten. Silk Central stellt eine Einstellung zur Verfügung, mit der der Hostname des Front-End-Servers in der Titelleiste des Webbrowsers angezeigt werden kann.

  • Anzeigen und Verbergen des Hostnamen in der Registerkarte des Webbrowsers
    Zeigen Sie den Hostnamen des Silk Central-Front-End-Servers in der Registerkarte des Webbrowsers an oder blenden Sie ihn aus.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen


Anzeigen und Verbergen des Hostnamen in der Registerkarte des Webbrowsers

So zeigen Sie den Hostnamen in der Registerkarte des Webbrowsers an oder blenden ihn aus:

  1. Stoppen Sie den Front-End-Server der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei SccFrontendBootConf.xml in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\FontendServer auf dem Front-End-Server.
  3. Suchen Sie den XML-Tag DisplayHostNameInTitleBar im Abschnitt Options der Datei.
  4. Wenn Sie den Wert true festlegen, dann wird der Hostname des Front-End-Servers in der Registerkarte des Webbrowsers angezeigt, wenn Sie Silk Central aufrufen. Wenn Sie den Wert false festlegen – das ist der Standardwert –, wird kein Hostname angezeigt, und wenn Sie eine andere Zeichenfolge als Wert angeben, wird diese Zeichenfolge angezeigt. Der aktuell in Silk Central ausgewählte Arbeitsbereich wird immer angezeigt.

    Wenn der XML-Tag auf true gesetzt ist, zeigt der Browser z.B.: <Arbeitsbereich> | HOSTNAME.

    Wenn der XML-Tag auf false gesetzt ist, zeigt der Browser: <Arbeitsbereich> | Silk Central.

    Wenn benutzerdefinierter Text eingegeben wird, z.B. MeinEigenerText, zeigt der Browser folgendes an: <Arbeitsbereich> | MeinEigenerText.

    Wenn der XML-Tag leer gelassen wird, zeigt der Browser: <Arbeitsbereich>.

  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Front-End-Server neu.
Übergeordnetes Thema: Hostnamensanzeige
Zugehörige Tasks
Verwalten von Instanzen


Speichern von Anhängen und Ergebnisdateien auf dem Dateisystem

Standardmäßig speichert Silk Central alle Anhänge und Ergebnisdateien in der Datenbank, aber Sie können Silk Central so konfigurieren, dass es diese Dateien auf dem Dateisystem des Anwendungsservers speichert.
Obwohl es nicht empfehlenswert ist, Anhänge und Ergebnisdateien getrennt von den anderen Daten zu speichern, haben Sie evtl. gute Gründe diesen Ansatz zu bevorzugen (z.B. Kosten für Datenbank-Speicherplatz). Ein Nachteil dieses Ansatzes ist, dass Sie Ihre Daten doppelt warten müssen, d.h. Sie müssen ein Backup Ihrer Datenbank als auch Ihres Dateisystems machen. Wenn ein Datenbank-Backup eingespielt wird, muss auch das Dateisystem wiederhergestellt werden.
ACHTUNG:
Wenn Sie die Option aktivieren, dass Dateien auf dem Dateisystem gespeichert werden, stellen Sie sicher, dass niemals Änderungen an der Struktur dieses Speicherortes durchgeführt werden, und niemals Dateien verschoben, geändert oder gelöscht werden. Nur die Silk Central-Dienste und das System, das Sie für Backups und Wiederherstellungen verwenden, sollten Schreibrechte auf das angegebene Dateiablage-Verzeichnis haben.
  1. Aktivieren Sie den Wartungsmodus auf der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung. Weitere Information finden Sie unter Wartungs-Modus.
  2. Melden Sie sich auf Ihrer Instanz als System-Administrator an und trennen Sie die Datenbankverbindung. Weitere Informationen finden Sie unter Trennen der Verbindung zu einer Datenbank.
  3. Stoppen Sie die zu bearbeitende Instanz auf der Seite Instanzen-Verwaltung.
  4. Öffnen Sie die Datei SccAppServerBootConf.xml mit einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\AppServer auf dem Anwendungsserver.
  5. Suchen Sie den XML-Tag <StoreFilesOnFileSystem> im Abschnitt <Config>/<RdbmsSpecifics> der Datei. Setzen Sie den Wert dieses Tags auf true.
  6. Speichern und schließen Sie die XML-Datei.
  7. Starten Sie die Instanz auf der Seite Instanzen-Verwaltung wieder.
  8. Melden Sie sich auf Ihrer Instanz wieder als System-Administrator an. Auf der Datenbank-Seite sehen Sie ein neues Feld namens Dateiablage-Verzeichnis, in das Sie einen lokalen Pfad eingeben müssen (z.B. "c:/sc_files/testdb"). Dieser wird zum Speichern von Anhängen und Ergebnisdateien verwendet. Dieser Pfad muss bereits vorhanden sein und die Dienste des Front-End- und des Anwendungsservers müssen vollen Zugriff auf diesen Ordner haben.
  9. Klicken Sie auf Datenbank verbinden.
Nun werden sämtliche Anhänge und Ergebnisdateien auf dem angegebenen Speicherort gespeichert. Anhänge und Ergebnisdateien die bereits in der verbundenen Datenbank gespeichert sind werden schrittweise auf das Dateisystem verschoben. Sollte das Dateisystem nicht verfügbar sein, speichert Silk Central die Dateien in Datenbank-Blob-Tabellen und verschiebt sie zu einem späteren Zeitpunkt auf das Dateisystem, wenn dieses wieder verfügbar ist.

Achtung: Es gibt zur Zeit keine Möglichkeit, Dateien automatisch zurück in die Datenbank zu verschieben. Aktivieren Sie diese Option somit nur, wenn Sie permanent Dateien auf dem Dateisystem speichern möchten.

Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen


Konfigurieren von LQM Reporting Updater

Hier wird beschrieben, wie die Einstellungen (z. B. das Intervall) des Threads zur Aktualisierung der LQM Reporting-Tabellen (LQM Reporting Updater) konfiguriert werden.

So konfigurieren Sie die Einstellungen des LQM Reporting Updaters:

  1. Stoppen Sie den Anwendungsserver der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei TmAppServerHomeConf.xml mit einem Texteditor.
    Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\AppServer auf dem Anwendungsserver.
  3. Suchen Sie das XML-Tag LQMReporting. Folgende Einstellungen können geändert werden:
    UpdateInterval
    Legt das Intervall (in Sekunden) fest, in dem die LQM Reporting-Tabellen mit den neuesten Daten aktualisiert werden.
    MSSqlUpdateBatchSize
    Die Anzahl der Testtabellen, die gleichzeitig verarbeitet werden können. Die Batchgröße bestimmt, in welchem Umfang Speicher- und Prozessorressourcen auf dem Anwendungsserver für die Aktualisierung verwendet werden. Diese Einstellung gilt nur für MS SQL Server-Datenbanken.
    OracleUpdateBatchsize
    Diese Einstellung hat die gleiche Wirkung wie MSSqlUpdateBatchSize, sie wird aber für Oracle-Datenbanken verwendet.
    QueryTimeout
    Legt das Zeitlimit in Sekunden fest, nach dem Abfragen im LQM Reporting-Aktualisierungsprozess abgebrochen werden. 0 oder ein negativer Wert bedeutet, dass für die Abfragen kein Zeitlimit gilt.
    OracleCheckForUpdateStrategy
    Bestimmt die Art und Weise, wie beim Aktualisierungsprozess aus den Quelltabellen gelesen wird. Sie können zwischen NOWAIT und WAIT wählen.
    • NOWAIT: Wenn der Aktualisierungsprozess versucht, aus den Quelltabellen zu lesen, ein anderer Prozess aber gerade in diese Tabellen schreibt, wird der Aktualisierungsprozess beendet und der Vorgang beim nächsten Aufruf wiederholt.
    • WAIT: Der Aktualisierungsprozess fordert eine Tabellensperre an, wartet, bis andere Prozesse nicht mehr auf die Tabellen zugreifen, und liest dann die Daten aus den Quelldateien. Diese Einstellung hat den Vorteil, dass der Prozess immer ausgeführt wird, da er nicht auf das Entsperren einer Tabelle warten muss. Jedoch müssen alle anderen Prozesse, die nach Abschluss der LQM-Aktualisierung auf die Tabelle zugreifen möchten, auf die Freigabe der Tabellensperre durch den Aktualisierungsprozess warten.
  4. Speichern und schließen Sie die XML-Datei.
  5. Starten Sie den Anwendungsserver neu.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Zugehörige Tasks
Verwalten von Instanzen


Ausführungstermine für die automatische LDAP-Synchronisierung planen

Wenn Sie Benutzergruppen aus LDAP-Servern in Ihr Silk Central-System importiert haben, können Sie einen Ausführungstermin festlegen, zu dem Ihre Silk Central-Gruppen automatisch mit den Änderungen auf dem LDAP-Server synchronisiert werden.
So legen Sie einen Ausführungstermin fest, zu dem Ihre Silk Central-Gruppen automatisch mit den Änderungen auf dem LDAP-Server synchronisiert werden:
  1. Stoppen Sie den Anwendungsserver der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei TmAppServerHomeConf.xml mit einem Texteditor.
    Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\AppServer auf dem Anwendungsserver.
  3. Suchen Sie den XML-Tag LdapUpdate. Folgende Einstellungen können geändert werden:
    ScheduledTime
    Zeitpunkt (hh:mm, 24h-Uhr) zu dem die Daten von LDAP das erste Mal aktualisiert werden. ScheduledTime wird in der Zeitzone des Anwendungsserver-Systems interpretiert. Lassen Sie diese Einstellung leer, um die automatische Synchronisierung zu deaktivieren.
    UpdateIntervalInMinutes
    Dieses Intervall (in Minuten) definiert, wie oft die LDAP-Gruppen und Benutzer synchronisiert werden, und startet relativ zur angegebenen ScheduledTime. Minimalwert ist 1.
  4. Speichern und schließen Sie die XML-Datei.
  5. Starten Sie den Anwendungsserver neu.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Übergeordnetes Thema: Verwalten von Gruppen
Zugehörige Tasks
Importieren von Gruppen aus LDAP-Servern


Zwischenspeicherung von Daten in Tests

In Silk Central werden Daten in Tests zwischengespeichert, um die Skalierbarkeit des Front-End-Servers zu verbessern und die Datenbanklast zu verringern, wenn mehrere Benutzer gleichzeitig an einem Projekt arbeiten. Die Testhierarchie und Testfilter haben einen wesentlichen Einfluss auf Front-End- und Datenbankserver. Da die Testhierarchie und die Filter für bestimmte Projekte von verschiedenen Benutzern gemeinsam genutzt werden können, bietet sich die Zwischenspeicherung in diesen Bereichen an.

Zwischenspeicherung in Testhierarchien

Der Testhierarchie-Cache enthält sämtliche Hierarchieinformationen für Projekte, die sich im Arbeitsspeicher befinden, und überprüft die Datenbank in regelmäßigen Abständen auf Änderungen in der Hierarchie. Administratoren können das Verhalten des Caches mithilfe der Einstellung Cache/TestPlanTree/CheckForChangesInterval in der Konfigurationsdatei TMFrontendBootConf.xml anpassen. Diese Einstellung definiert den Zeitraum (in Sekunden), nach dem Hierarchieinformationen spätestens aktualisiert werden. Unabhängig von dieser Einstellung wird der Cache sofort aktualisiert, wenn ein Test, ein Ordner oder ein Container auf demselben Front-End-Server geändert wird. Die Einstellung Cache/TestPlanTree/CheckForChangesInterval wird nur wirksam, wenn Änderungen auf einem anderen Front-End-Server durchgeführt werden. Wenn ein Projekt länger als eine Stunde von keinem Benutzer verwendet wird, wird der gesamte Projekthierarchie-Cache gelöscht. Das Projekt wird dann beim nächsten Zugriff eines Benutzers neu geladen.

Zwischenspeicherung in Testfiltern

Im Filter-Cache werden die IDs von Tests, die die Kriterien bestimmter Filter erfüllen, für einen bestimmten Zeitraum zwischengespeichert, der sich nach der Einstellung für die minimale Cache-Dauer und nach der Ausführungszeit der einzelnen Filter richtet. Administratoren können dieses Verhalten mit zwei Eigenschaften beeinflussen, die sich unter Cache/FilterCache/ in der Konfigurationsdatei TMFrontendBootConf.xml befinden.

Die Eigenschaft MinimalLifeTime legt den Zeitraum (in Sekunden) fest, nach dem ein Filterergebnis frühestens aus dem Cache entfernt werden kann. Mit der Eigenschaft LifeTimeMultiplier kann diese Mindestspeicherdauer mit der Zeit in Beziehung gesetzt werden, die für die Ausführung der Filterabfrage benötigt wird. Wenn Sie beispielsweise den Multiplikator > 0 festlegen, ergibt sich die maximale Dauer für die Zwischenspeicherung eines Ergebnisses aus der MinimalLifeTime, oder der Ausführungsdauer der Abfrage, multipliziert mit LifeTimeMultiplier. Wenn Sie für eine Filterabfrage, deren Ausführung 1 Sekunde dauert, den Standardwert 30 für beides, für MinimalLifeTime und LifeTimeMultiplier übernehmen, bleibt das Filterergebnis 30 Sekunden lang im Cache. Dauert die Ausführung der Filterabfrage ein halbe Sekunde, bleibt das Ergebnis ebenfalls 30 Sekunden im Cache. Bei einer Ausführungsdauer von 2 Sekunden wird es jedoch 60 Sekunden zwischengespeichert.

Cache für Schlüsselwort-Empfehlungen

Wenn Sie im Keyword-Driven Test Editor Schlüsselwörter zu einem schlüsselwortgetriebenen Test oder einer Schlüsselwort-Sequenz hinzufügen, empfiehlt Silk Central welches Schlüsselwort Sie evtl. als nächstes verwenden möchten. Empfohlene Schlüsselwörter erscheinen oben in der Schlüsselwort-Liste und zeigen in einem Balkendiagramm an, wie hoch die Empfehlung von Silk Central ist.

Über die Eigenschaft RecommendationCache/ExpireAfterWrite in der Konfigurationsdatei TMFrontendBootConf.xml können Administratoren das Intervall einstellen, in welchem der Cache für Schlüsselwort-Empfehlungen aktualisiert wird.

JMX-Messdaten für die Zwischenspeicherung

Silk Central enthält JMX-Werte zur Überwachung von zugrunde liegenden Java-Prozessen und anderen prozessspezifischen Messdaten. Die JMX-Daten für den Testhierarchie- und Testfilter-Cache befinden sich in der JMX-Messdatenhierarchie unter borland.com/Frontend/TM.

Anmerkung: Diese und weitere Messdaten können mit Silk Performance Explorer und anderen Tools nachverfolgt werden.
  • JMX-Messdaten für die Zwischenspeicherung in Tests
    Die JMX-Daten für den Testhierarchie- und den Filter-Cache befinden sich auf Ihrem Front-End-Server in der JMX-Messdatenhierarchie unter borland.com/Frontend/TM.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Zugehörige Verweise
Verwalten von Schlüsselwörtern in einem Test
Verwalten von Schlüsselwörtern in einer Bibliothek
Welche Schlüsselwörter empfiehlt Silk Central?


JMX-Messdaten für die Zwischenspeicherung in Tests

Die JMX-Daten für den Testhierarchie- und den Filter-Cache befinden sich auf Ihrem Front-End-Server in der JMX-Messdatenhierarchie unter borland.com/Frontend/TM.

Messdaten für den Testhierarchie-Cache

Für den Testhierarchie-Cache sind zwei grundlegende Messdaten verfügbar. TestPlanTreeCache liefert Informationen darüber (NumberOfCachedProjects), wie viele Projekte sich gegenwärtig im Cache befinden. Alle Details des Projekt-Caches werden über den zweiten Messwert bereitgestellt: TestPlanTreeCache_<Nummer>. Dieser umfasst folgende Messwerte:

Messwert | Beschreibung
Hits | Die Anzahl der Zugriffe auf den Cache ohne implizite Datenbankanforderungen.
LastUpdateCheckDurationInMillis | Die Dauer der letzten Prüfung auf Aktualisierungen in der Datenbank in Millisekunden, siehe LastUpdateCheckTime.
LastUpdateCheckTime | Der Zeitpunkt der letzten Überprüfung auf Aktualisierungen.
LastUpdateDurationInMillis | Die Dauer der letzten Aktualisierung des Caches in Millisekunden, siehe LastUpdateTime, die aufgrund einer Änderung durchgeführt wurde.
LastUpdateTime | Der Zeitpunkt der letzten Cache-Aktualisierung, die aufgrund einer Änderung in der Testhierarchie durchgeführt wurde.
TreeInitializationTimeInMillis | Die Zeit in Millisekunden, die für das Laden der gesamten Projekthierarchie in den Cache erforderlich war. Dieser Wert ändert sich nicht, solange der Projekt-Cache geladen ist.
TreeSize | Die Anzahl der Testknoten im Projekt, d. h. Container, Ordner und Tests.
UpdateChecks | Die Anzahl der Überprüfungen auf Änderungen der Testhierarchie des Projekts, die seit der Initialisierung des Projekthierarchie-Caches durchgeführt wurden.
Updates | Die Anzahl der Aktualisierungen der zwischengespeicherten Hierarchie, die nach Änderungen an der Testhierarchie durchgeführt wurden.

Messdaten für den Filter-Cache

Der Messwert TestPlanFilterCache umfasst die folgenden drei Informationen:

Messwert | Beschreibung
Hits | Die Anzahl der Zugriffe auf den Cache, bei denen keine separate Ausführung des Filters für die Datenbank erforderlich war.
Misses | Gibt an, wie oft der Filter ohne Zugriff auf den Filter-Cache für die Datenbank ausgeführt wurde.
Größe | Die aktuelle Anzahl der zwischengespeicherten Filterergebnisse.
Übergeordnetes Thema: Zwischenspeicherung von Daten in Tests
Übergeordnetes Thema: Konfigurieren der JMX-Einstellungen


Konfigurieren der JMX-Einstellungen

Silk Central bietet eine Reihe von Standardports für die Konfiguration von JMX-Einstellungen.

Verfügbare Servergruppen für die Konfiguration von JMX-Einstellungen

Die Kommunikation über diese Standardports verläuft standardmäßig unverschlüsselt. SSL wird also nicht ausgeführt.
Wichtig: Micro Focus übernimmt keinerlei Verantwortung für Ihre JMX-Sicherheitseinstellungen. Bitte stellen sie sicher, dass Ihre IT-Abteilung die JMX-Sicherheit entsprechend konfiguriert.
festlegen | Beschreibung
com.sun.management.jmxremote.ssl | SSL ist standardmäßig auf false festgelegt.
com.sun.management.jmxremote.authenticate | Authentifizierung ist standardmäßig auf false festgelegt.
Sie können diese Einstellungen in den processconfig-Dateien in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf ändern. Beachten Sie, dass die JMX-Verbindung unsicher ist, solange eine der zwei Einstellungen noch auf false festgelegt ist.

Wenn Sie über JMX auf Informationen zugreifen oder Aktionen ausführen möchten, benötigen Sie die JMX-Verbindung. Klicken Sie auf Einstellungen um den Einstellungen-Dialog zu öffnen. Wählen Sie auf der Registerkarte Server den gewünschten Server aus und kopieren Sie die JMX-Verbindung. Weitere Information finden Sie unter Verwalten von Instanzen.

  • JMX-Messdaten für die Zwischenspeicherung in Tests
    Die JMX-Daten für den Testhierarchie- und den Filter-Cache befinden sich auf Ihrem Front-End-Server in der JMX-Messdatenhierarchie unter borland.com/Frontend/TM.
  • JMX-Messdaten für die Überwachung von LQM Reporting Updater
    Die JMX-Daten für LQM Reporting Updater befinden sich auf dem Anwendungsserver in der JMX-Wertehierarchie unter borland.com/LQMReporting/TM.
  • JMX-Messdaten für DataMart
    Die JMX-Daten für DataMart befinden sich auf dem Anwendungsserver in der JMX-Wertehierarchie unter borland.com/DataMart.
  • JMX-Messdaten für die LDAP-Synchronisierung
    Die JMX-Daten für die LDAP-Synchronisierung befinden sich auf dem Anwendungsserver in der JMX-Wertehierarchie unter borland.com/LdapUpdater.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen


JMX-Messdaten für die Überwachung von LQM Reporting Updater

Messdaten für LQM Reporting Updater

Die folgenden Messdaten sind verfügbar:

Messwert | Beschreibung
LastDataLoadResetTime | Der Zeitpunkt, zu dem die LQM Reporting-Tabellen das letzte Mal zurückgesetzt wurden. Wenn dieses Attribut den Wert Null hat, wurde während der Lebensdauer des Prozesses kein Reset durchgeführt.
LastDeleteDurationInMillis | Die Zeit, die zum Entfernen gelöschter Knoten aus den LQM Reporting-Tabellen benötigt wurde.
LastDeleteTestsCnt | Die Anzahl der Tests, die bei der letzten Ausführung gelöscht wurden.
LastInsertLQMTestsDuration | Die Zeit, die zum Einfügen neuer Tests in die Tabelle LQM_Tests erforderlich war.
LastInsertLQMTestPDAsDuration | Die Zeit, die zum Einfügen neuer Tests in die Tabelle LQM_TestPDAs erforderlich war.
LastInsertLQMTestUDAsDuration | Die Zeit, die zum Einfügen neuer Tests in die Tabelle LQM_TestUDAs erforderlich war.
LastRunFromDate | Der Beginn des Zeitraums, der im aktuellen Aktualisierungszyklus verarbeitet wird.
LastRunToDate | Das Ende des Zeitraums, der im aktuellen Aktualisierungszyklus verarbeitet wird.
LastSelectChangedDataIterateDurationInMillis | Die Zeit, die für das Iterieren geänderter Daten aufgewendet wurde.
LastSelectChangedDataQueryDurationInMillis | Die Zeit, die für das Abfragen geänderter Daten aufgewendet wurde.
LastTotalUpdateDurationInMillis | Die Gesamtdauer der zuletzt durchgeführten Aktualisierung.
LastUpdateFixedAttributesDurationInMillis | Die Dauer der letzten Aktualisierung fester Attribute.
LastUpdatePDAttributesDurationInMillis | Die Dauer der letzten Aktualisierung der Tabelle LQM_TestPDAs.
LastUpdatesNeededCheckDurationInMillis | Die Dauer (in Millisekunden) der letzten Überprüfung auf neue oder geänderte Daten.
LastUpdatesNeededCheckOracleWaitForTableLocksDuration | Oracle-Datenbanken erfordern bei der Überprüfung auf aktualisierte Tests ein besonderes Vorgehen. In bestimmten Fällen muss gewartet werden, bis Transaktionen, die andere Prozesse mit Testtabellen durchführen, abgeschlossen sind. Diese Wartezeit ist in diesem Attribut angegeben.
LastUpdateTestsDurationInMillis | Die Dauer der letzten Aktualisierung von Eigenschaften in der Tabelle LQM_Tests.
LastUpdateUDAttributesDurationInMillis | Die Dauer der letzten Aktualisierung der Tabelle LQM_TestUDAs.
Übergeordnetes Thema: Konfigurieren der JMX-Einstellungen


JMX-Messdaten für DataMart

DataMart Updater Messwerte

Die JMX-Daten für DataMart Updater befinden sich auf dem Anwendungsserver in der JMX-Wertehierarchie unter borland.com/DataMart/TM:

Messwert | Beschreibung
AverageCheckDurationInMilliseconds | Durchschnittszeit in Millisekunden für die Überprüfung von aktualisierten Zeilen
AverageUpdateDurationInMilliseconds | Durchschnittszeit in Millisekunden für die Aktualisierung von Zeilen
FailedCheckCount | Anzahl fehlgeschlagener Überprüfungen von Aktualisierungen
FailedUpdateCount | Anzahl fehlgeschlagener Aktualisierungen
FastestCheckInMilliseconds | Kürzeste Zeit in Millisekunden für die Überprüfung von aktualisierten Zeilen
FastestUpdateInMilliseconds | Kürzeste Zeit in Millisekunden für die Aktualisierung von Zeilen
ID | ID des DataMart Updater
IntervalInMilliseconds | Intervall in Millisekunden, in welchem der DataMart Updater ausgeführt wird
LastBlockedRunDate | Die Zeit um welche die Ausführung das letzte Mal blockiert wurde (wait for exclusive access failed)
LastFailedRunDate | Die Zeit um welche die Ausführung das letzte Mal fehlgeschlagen ist
LastSuccessfulRunDate | Die Zeit um welche die Ausführung das letzte Mal erfolgreich durchgelaufen ist
LatestDataLoadInfo | Information über die aktuellste Datenlast
SlowestCheckInMilliseconds | Längste Zeit in Millisekunden für die Überprüfung von aktualisierten Zeilen
SlowestUpdateInMilliseconds | Längste Zeit in Millisekunden für die Aktualisierung von Zeilen
SlowestWaitForExclusiveAccessInMilliseconds | Längste Zeit in Millisekunden für das Warten auf exklusiven Zugriff
StartupDate | Die Zeit um welche der DataMart Updater initialisiert wurde
SuccessfulCheckCount | Anzahl erfolgreicher Überprüfungen von Aktualisierungen
SuccessfulUpdateCount | Anzahl erfolgreicher Aktualisierungen

DataMart-Dienst Messwerte

Die JMX-Daten für den DataMart-Dienst befinden sich auf dem Anwendungsserver in der JMX-Wertehierarchie unter borland.com/DataMart/Service:

Messwert/Operation | Beschreibung
Aktiviert | Zeigt an, ob der DataMart-Dienst aktiviert oder deaktiviert ist.
disable() | Deaktiviert den DataMart-Dienst.
enable() | Aktiviert den DataMart-Dienst.
isEnabled() | Fragt ab, ob der DataMart-Dienst aktiviert oder deaktiviert ist.
Übergeordnetes Thema: Konfigurieren der JMX-Einstellungen


JMX-Messdaten für die LDAP-Synchronisierung

Die JMX-Daten für die LDAP-Synchronisierung befinden sich auf dem Anwendungsserver in der JMX-Wertehierarchie unter borland.com/LdapUpdater.
Messwert/Operation | Beschreibung
Enabled | Zeigt an, ob die automatische LDAP-Synchronisierung aktiviert oder deaktiviert ist.
LastDurationInMillis | Die Dauer der letzten LDAP-Synchronisierung in Millisekunden.
enable() | Aktiviert die automatische LDAP-Synchronisierung.
disable() | Deaktiviert die automatische LDAP-Synchronisierung.
Übergeordnetes Thema: Konfigurieren der JMX-Einstellungen


Hostnamenauflösung des Ausführungsservers

Ein Ausführungsserver wird unter Umständen nicht mehr vom Anwendungsserver erkannt, wenn sich seine IP-Adresse geändert hat. Wenn der Anwendungsserver neu gestartet wird, sollte er vom Ausführungsserver wieder erkannt werden.

Java speichert die Hostnamenauflösung in einem Cache, um sie vor DNS-Spionageangriffen zu schützen. In Silk Central können die Ergebnisse positiver Hostnamenauflösungen unendlich lange im Cache gespeichert werden. Dies lässt sich jedoch ändern, indem die Datei java.security auf dem Anwendungsserver bearbeitet wird. Dadurch wird der Anwendungsserver in die Lage versetzt, die Ausführungsserver selbst dann zu erkennen, wenn sich ihre IP-Adresse geändert hat.

Weitere Informationen über diese Java-Einstellung finden Sie auf der Seite Networking Properties.

  • Deaktivieren der Zwischenspeicherung von Hostnamenauflösungen
    Durch das Deaktivieren der Zwischenspeicherung von Hostnamenauflösungen (DNS) wird festgelegt, dass Hostnamenauflösungen niemals zwischengespeichert werden.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen


Deaktivieren der Zwischenspeicherung von Hostnamenauflösungen

So legen Sie fest, dass Hostnamenauflösungen niemals zwischengespeichert werden:

  1. Stoppen Sie den Anwendungsserver der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei java.security in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\lib\jre\lib\security auf dem Anwendungsserver. Falls Ihr Anwendungsserver im 64-Bit-Modus läuft, verwenden Sie stattdessen den Ordner jre64\lib\security.
  3. Suchen Sie die Zeile #networkaddress.cache.ttl=-1 und ändern Sie sie auf networkaddress.cache.ttl=0.
    Anmerkung: Das Kommentarzeichen "#" muss entfernt werden, damit diese Anweisung wirksam wird.
    ACHTUNG:
    Diese Änderung sollte mit Ihrem Netzwerkadministrator abgestimmt werden, da dadurch Sicherheitseinstellungen berührt werden.
  4. Speichern und schließen Sie die Datei.
  5. Starten Sie den Anwendungsserver neu.
Übergeordnetes Thema: Hostnamenauflösung des Ausführungsservers
Zugehörige Tasks
Verwalten von Instanzen


Konfigurieren des Silk Central-Standorts in Issue Manager

Hier wird beschrieben, wie der Standort der Silk Central-Installation in Issue Manager konfiguriert wird. Aufgrund dieser Konfiguration ist eine Nachverfolgung von Problemen in Issue Manager zu den entsprechenden Tests in Silk Central möglich. Weitere Informationen zur Verwendung der Nachverfolgungsfunktion finden Sie in der Issue Manager-Dokumentation.

So konfigurieren Sie den Silk Central-Standort in Issue Manager:

  1. Stoppen Sie den Front-End-Server der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei SRFrontendBootConf.xml in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\FontendServer auf dem Front-End-Server.
  3. Suchen Sie die XML-Tags Alm\ElementServiceEndpoint und Alm\LinkServiceEndpoint.
  4. Ersetzen Sie in beiden Tags den Standardwert localhost:19120 durch die Host- und Portinformationen Ihrer Silk Central-Installation. Wenn für die Silk Central-Installation derselbe Front-End-Server wie für die Issue Manager-Installation verwendet wird, und Sie für den Tomcat-Webserver den Standardport nutzen, können Sie die Standardwerte beibehalten.
  5. Speichern und schließen Sie die XML-Datei.
  6. Wenn Sie nicht den Standardport verwenden, passen Sie die Datei configuration.xml in \instance_<Instanznummer>_<Instanzname>\wwwroot\AlmServices1.0 an. Suchen Sie den XML-Tag connectString und geben sie die korrekten Ports ein. Beispiel:
    <properties>
   <name>connectString</name>
   <!-- value>com.borland.tm.system.endpoint=http://gershwin:19120/services/sccsystem;
      com.borland.tm.spi.endpoint=http://gershwin:19120/services/SpiService</value  -->
   <value>com.borland.tm.system.endpoint=http://MyHost:8555/services/sccsystem;
      com.borland.tm.spi.endpoint=http://MyHost:8555/services/SpiService</value>
</properties>
  7. Starten Sie den Front-End-Server neu.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Zugehörige Tasks
Verwalten von Instanzen


Festlegen der Anzahl zuletzt angezeigter Berichte

So legen Sie die maximale Anzahl von Berichten fest, die im Listenfeld Zuletzt verwendete Berichte angezeigt werden:

  1. Stoppen Sie den Front-End-Server der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei SccFrontendBootConf.xml in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\FontendServer auf dem Front-End-Server.
  3. Suchen Sie den XML-Tag <MRUListSize> im Abschnitt <Report> der Datei. Der Standardwert für dieses Tag ist 10.
  4. Setzen Sie den Wert auf die Maximalzahl zuletzt angezeigter Berichte in dem Listenfeld Zuletzt verwendete Berichte fest.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Front-End-Server neu.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen


Speichereinstellungen für Silk Central-Server

In diesem Abschnitt wird beschrieben, wie Sie die Speichereinstellungen der Silk Central-Server ändern können, wenn ein Fehler aufgrund von Speichermangel auftritt.

Die Größe des Java Heaps des Silk Central-Front-End-Servers und des Anwendungsservers wird standardmäßig auf 512 MB eingestellt (2048 MB für 64-Bit Front-End-Server). Falls Fehler aufgrund von Speichermangel angezeigt werden, zum Beispiel wenn Sie ein Projekt in Silk Central kopieren, versuchen Sie die Größe des Heaps am Front-End-Server oder Anwendungsserver zu erhöhen.

Der folgende Fehler ist ein Indikator dafür, dass die Größe des Java Heaps zu klein ist: java.lang.RuntimeException: java.lang.OutOfMemoryError: Java heap space at com.segue.scc.webgui.module.console.ProjectsUnit$CopyProjectThread.run(ProjectsUnit.java:1473) Caused by: java.lang.OutOfMemoryError: Java heap space. Dieser Fehler wird im Logfile des Front-End-Servers oder des Anwendungsservers aufgeführt. Ein weiterer Hinweis ist die folgende Fehlermeldung Das System arbeitet an der Grenze seiner Kapazität. Aus Sicherheitsgründen können sich keine weiteren Benutzer mehr anmelden, welche angezeigt wird, wenn Sie versuchen, sich auf Silk Central anzumelden.

  • Erhöhen der Größe des Java Heaps auf einem Silk Central-Server
    Erhöhen Sie die Größe des Java Heaps auf einem Silk Central-Server, um Fehler aufgrund von Speichermangel zu vermeiden.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen


Erhöhen der Größe des Java Heaps auf einem Silk Central-Server

Erhöhen Sie die Größe des Java Heaps auf einem Silk Central-Server, wenn Sie Fehler aufgrund von Speichermangel angezeigt bekommen.

Um die Größe des Java Heaps am Front-End oder Anwendungsserver zu erhöhen:

  1. Stoppen Sie die zu bearbeitende Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie mit einem Texteditor die Datei sc_<Server>.processconfig des Servers, für die Sie die Speicher-Einstellungen ändern möchten. Der Standardpfad für diese Dateien lautet C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf.
  3. Setzen Sie für 32-Bit-JVMs den Wert des Tags <JvmOption32bit name="-Xmx" unter <JvmOptions32bit>. Setzen Sie für 64-Bit-JVMs den Wert des Tags <JvmOption name="-Xmx" unter <JvmOptions>.
  4. Speichern und schließen Sie die XML-Datei.
  5. Starten Sie die Instanz erneut.
Übergeordnetes Thema: Speichereinstellungen für Silk Central-Server


Festlegen der maximalen Größe von Testschritt-Ergebnisdateien

Sie können die Größe von Ergebnisdateien begrenzen, die Tester während der Durchführung manueller Tests im Fenster Manuelles Testen an Testschritte anhängen können. Weitere Informationen finden Sie unter Anhängen von Ergebnisdateien.

So legen Sie die maximale Größe von Testschritt-Ergebnisdateien fest:

  1. Stoppen Sie den Front-End-Server der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei SccFrontendBootConf.xml in einem Texteditor. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\FontendServer auf dem Front-End-Server.
  3. Suchen Sie das XML-Tag <MaximumResultFileSizeInBytes>. Der Standardwert für dieses Tag ist 104857600 (100 MB).
  4. Legen Sie den Wert auf die gewünschte maximale Dateigröße fest. Geben Sie die Dateigröße in Byte ein.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Front-End-Server neu.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen
Zugehörige Konzepte
Manuelles Testen (Fenster)
Zugehörige Tasks
Anhängen von Ergebnisdateien


Speichern von Perzentil-Markierungsdaten für Silk Performer-Testergebnisse

Silk Performer-Testergebnisse enthalten eine große Menge Perzentil-Markierungsdaten, welche viel Platz in der Datenbank brauchen (TM_PerfReportPercentileMarker-Tabelle). Deshalb ist das Speichern dieser Informationen standardmäßig ausgeschaltet. So schalten Sie das Speichern von Perzentil-Markierungsdaten frei, wann immer Silk Performer-Testergebnisse gespeichert werden:
  1. Stoppen Sie den Anwendungsserver der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei TmAppServerHomeConf.xml mit einem Texteditor.
    Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\AppServer auf dem Anwendungsserver.
  3. Suchen Sie den XML-Tag Config/SilkPerformerResultStorage/StorePercentileMarkerData. Die Standardeinstellung dieses Tags lautet false.
  4. Setzen Sie den Wert auf true.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Anwendungsserver neu.
Übergeordnetes Thema: Konfigurieren erweiterter Einstellungen


Silk Central-Hilfe

Silk Central ist ein leistungsstarkes, umfassendes Managementsystem für den Software-Test. Silk Central optimiert Qualität und Produktivität Ihres Testprozesses und beschleunigt die Auslieferung erfolgreicher Software-Projekte bei gleichzeitiger Minimierung von Anwendungsfehlern. Es führt alle kritischen Phasen des Software-Tests in einem einzigen, Web-basierten Testsystem zusammen und ermöglicht es, lokalen und verteilten Software-Entwicklungsteams Erfahrungen, Ressourcen und wichtige Informationen gemeinsam zu nutzen.

  • Neuerungen in Silk Central 18.5
    Silk Central 18.5 beinhaltet wesentliche Erweiterungen und Änderungen.
  • Erste Schritte
    Dieser Abschnitt enthält einen Überblick über Silk Central.
  • Anforderungen
    Hier wird beschrieben, wie Anforderungen in Silk Central verwaltet werden.
  • Tests
    Hier wird beschrieben, wie Tests in Silk Central verwaltet werden.
  • Ausführungsplanung
    Hier wird beschrieben, wie Tests in Silk Central ausgeführt werden.
  • Fehlerverfolgung und Ergebnisanalyse
    Analysieren Sie Ihre Testergebnisse, erstellen und verfolgen Sie aufgetretene Fehler und verwenden Sie Berichte, um die Ergebnisse zu dokumentieren.
  • Verwaltung
    Nachdem Sie die anfängliche Konfiguration von Silk Central (Instanzenkonfiguration) abgeschlossen haben, werden Sie in den folgenden Abschnitten durch die Schritte geführt, die zum Einrichten von Benutzerkonten, Projekten, Servergruppen, Ausführungsservern usw. erforderlich sind. Diese Aufgaben müssen von einem Administrator durchgeführt werden.


Neuerungen in Silk Central 18.5

Silk Central 18.5 beinhaltet wesentliche Erweiterungen und Änderungen.

  • Verwaltung
    Hier werden die Verbesserungen aufgeführt, die im Verwaltungsbereich von Silk Central vorgenommen wurden.
  • Ausführungsplanung und Testausführung
    Hier werden die Verbesserungen aufgeführt, die in den Bereichen Ausführungsplanung und Testausführung von Silk Central vorgenommen wurden.
  • Tests
    Hier werden die Verbesserungen aufgeführt, die im Tests-Bereich von Silk Central vorgenommen wurden.
  • Issue Manager Erweiterungen
    Issue Manager, die integrierte Fehlerverfolgunslösung von Silk Central, wurde in Silk Central 18.5 massiv erweitert.
  • Integrationen
    Hier werden die Verbesserungen aufgeführt, die an den Integrationen in Silk Central vorgenommen wurden.
Übergeordnetes Thema: Silk Central-Hilfe


Verwaltung

  • Lokaler Zugriff auf die Systemdiagnose
    Wenn Silk Central die Anmeldung verweigert oder wegen Überlast nicht mehr reagiert, können Sie nun die Systemdiagnose-Seite trotzdem noch lokal auf Ihrem Front-End-Server öffnen (über http://localhost:19120/systemdiagnostics) um wertvolle Informationen für die Fehleranalyse zu erhalten.
Übergeordnetes Thema: Neuerungen in Silk Central 18.5


Lokaler Zugriff auf die Systemdiagnose

Wenn Silk Central die Anmeldung verweigert oder wegen Überlast nicht mehr reagiert, können Sie nun die Systemdiagnose-Seite trotzdem noch lokal auf Ihrem Front-End-Server öffnen (über http://localhost:19120/systemdiagnostics) um wertvolle Informationen für die Fehleranalyse zu erhalten.
Übergeordnetes Thema: Verwaltung
Zugehörige Tasks
Systemdiagnose


Ausführungsplanung und Testausführung

  • Verteilte Testausführung
    Silk Central unterstützt nun die verteilte Testausführung der einer Testsuite zugeordneten Tests, indem sämtliche Tests auf allen passenden Ausführungsservern gleichzeitig ausgeführt werden.
  • Testsuite-Attribute
    In der SOAP API von Silk Central werden Testsuite-Attribute nun berücksichtigt. Weitere Informationen hierzu finden Sie in der Javadoc von Silk Central.
Übergeordnetes Thema: Neuerungen in Silk Central 18.5


Verteilte Testausführung

Silk Central unterstützt nun die verteilte Testausführung der einer Testsuite zugeordneten Tests, indem sämtliche Tests auf allen passenden Ausführungsservern gleichzeitig ausgeführt werden.

Damit Ihre Ausführungsserver nicht überlastet werden, können Sie nun auch die Maximale Anzahl gleichzeitiger Ausführungen pro Ausführungsserver einstellen. Dies ist die maximale Anzahl von Testsuiten (Exklusive Testausführung deaktiviert), die gleichzeitig auf einem bestimmten Ausführungsserver laufen dürfen.

Ein weiterer großer Vorteil der verteilten Testausführung ist, dass der Ausführungsfortschritt von automatisierten Tests in den Tabellen Aktivitäten und Aktueller Testlauf sofort einsehbar ist. Bis jetzt war diese Information erst verfügbar, nachdem die Ausführung einer gesamten Testsuite abgeschlossen war.

Übergeordnetes Thema: Ausführungsplanung und Testausführung
Zugehörige Konzepte
Verteilte Testausführung
Zugehörige Tasks
Konfigurieren physischer Ausführungsserver


Testsuite-Attribute

In der SOAP API von Silk Central werden Testsuite-Attribute nun berücksichtigt. Weitere Informationen hierzu finden Sie in der Javadoc von Silk Central.
Anmerkung: Testsuite-Attribute werden in den Schnittstellen „bulk export/update“ von Silk Central noch nicht berücksichtigt.
Übergeordnetes Thema: Ausführungsplanung und Testausführung
Zugehörige Verweise
Verfügbare Webdienste


Tests

  • Gemeinsam verwendbare Testobjekte
    Tests können nun zur Wiederverwendung in anderen Projekten freigegeben werden, wodurch wiederkehrende Tests effizient verwaltet werden können. Wiederverwendete Tests haben eine Referenz zum Herkunftstest, um über Aktualisierungen (Testversion) informiert zu werden, welche dann akzeptiert oder übersprungen werden können. Zusätzlich werden wiederverwendete Tests den bestehenden Anforderungen in ihrem Projekt zugeordnet, gleichermaßen wie die Zuordnung im Herkunftstest.
  • Benutzerdefinierte Attribute in der Dokumentansicht von Tests anzeigen
    Benutzerdefinierte Attribute können nun unter Tests > Dokumentansicht angezeigt werden. Sie können Attribute für das Filtern und die Berichterstellung verwenden.
  • Testelemente mit Lesezugriff kopieren
    Testelemente können nun auch von Benutzern kopiert werden, die in einem Projekt nur Lesezugriff haben. Danach können Sie in Projekte eingefügt werden, in denen der Benutzer Schreibrechte hat.
Übergeordnetes Thema: Neuerungen in Silk Central 18.5


Gemeinsam verwendbare Testobjekte

Tests können nun zur Wiederverwendung in anderen Projekten freigegeben werden, wodurch wiederkehrende Tests effizient verwaltet werden können. Wiederverwendete Tests haben eine Referenz zum Herkunftstest, um über Aktualisierungen (Testversion) informiert zu werden, welche dann akzeptiert oder übersprungen werden können. Zusätzlich werden wiederverwendete Tests den bestehenden Anforderungen in ihrem Projekt zugeordnet, gleichermaßen wie die Zuordnung im Herkunftstest.

Erweiterte Testversionen

Wegen ihrer zentralen Rolle bei der Wiederverwendung von Tests, enthalten Testversionen nun Informationen über Parameter, Attribute, Eigenschaften, Erfolgsbedingungen und Vererbung.

Übergeordnetes Thema: Tests
Zugehörige Konzepte
Gemeinsam verwendbare Testobjekte
Versionen
Zugehörige Tasks
Gemeinsame Verwendung von Testobjekten aus Repository-Projekten
Hinzufügen von Projekten
Zugehörige Verweise
Projekteinstellungen (Seite)


Benutzerdefinierte Attribute in der Dokumentansicht von Tests anzeigen

Benutzerdefinierte Attribute können nun unter Tests > Dokumentansicht angezeigt werden. Sie können Attribute für das Filtern und die Berichterstellung verwenden.
Übergeordnetes Thema: Tests
Zugehörige Verweise
Tests (Dokumentansicht)


Testelemente mit Lesezugriff kopieren

Testelemente können nun auch von Benutzern kopiert werden, die in einem Projekt nur Lesezugriff haben. Danach können Sie in Projekte eingefügt werden, in denen der Benutzer Schreibrechte hat.
Übergeordnetes Thema: Tests


Issue Manager Erweiterungen

Issue Manager, die integrierte Fehlerverfolgunslösung von Silk Central, wurde in Silk Central 18.5 massiv erweitert.

Nahtlose Integration

Issue Manager nimmt einen weiteren Schritt in Richtung nahtlose Integration, indem optional der bereits vorhandene Benutzer-Kontext verwendet werden kann, um sich an eine lokale Issue Manager-Instanz anzumelden.

Aktualisierte Benutzeroberfläche

Die Seite Fehlerdetails wurde neu gestaltet um die wichtigsten Informationen über einen Fehler sofort zur Verfügung zu haben, und um effizienter mit Fehlern arbeiten zu können.

Übergeordnetes Thema: Neuerungen in Silk Central 18.5
Zugehörige Tasks
Hinzufügen von Issue Manager-Fehlerverfolgungsprofilen
Zugehörige Verweise
Fehlerdetailseite
Fehlerverfolgung (Seite)


Integrationen

  • Integrierte Mobile Center Unterstützung
    Silk Central 18.5 Ist nun mit Mobile Center integriert, damit Sie Ihre automatisierten Tests auf mobilen Geräten ausführen können, und zusätzlich diese mobilen Geräte Silk Test zur Verfügung stellen für die Erstellung und Ausführung von automatisierten funktionalen Tests.
  • Angabe eines Branches in Git-Versionsverwaltungsprofilen
    Sie können nun einen bestimmten Branch in Ihrem Git-Versionsverwaltungsprofil angeben, welcher für alle Testsuiten ausgecheckt wird, die dieses Profil verwenden. Sie können für eine bestimmte Testsuite immer noch einen anderen Branch verwenden, indem Sie den Namen des Branches im Feld Label der Versionsverwaltung in der entsprechenden Testsuite eingeben.
Übergeordnetes Thema: Neuerungen in Silk Central 18.5


Integrierte Mobile Center Unterstützung

Silk Central 18.5 Ist nun mit Mobile Center integriert, damit Sie Ihre automatisierten Tests auf mobilen Geräten ausführen können, und zusätzlich diese mobilen Geräte Silk Test zur Verfügung stellen für die Erstellung und Ausführung von automatisierten funktionalen Tests.
Übergeordnetes Thema: Integrationen
Zugehörige Tasks
Konfiguration von Geräte-Anbietern


Angabe eines Branches in Git-Versionsverwaltungsprofilen

Sie können nun einen bestimmten Branch in Ihrem Git-Versionsverwaltungsprofil angeben, welcher für alle Testsuiten ausgecheckt wird, die dieses Profil verwenden. Sie können für eine bestimmte Testsuite immer noch einen anderen Branch verwenden, indem Sie den Namen des Branches im Feld Label der Versionsverwaltung in der entsprechenden Testsuite eingeben.
Übergeordnetes Thema: Integrationen
Zugehörige Tasks
Hinzufügen von Git-Versionsverwaltungsprofilen


Erste Schritte

Silk Central unterstützt während des gesamten Entwicklungszyklus die Sicherstellung einer hohen Produktqualität.

Die heutigen E-Business-Lösungen werden immer komplexer, und daher ist die Zuverlässigkeit wichtiger als jemals zuvor. Aus diesem Grund ist die Sicherstellung der Produktqualität während des gesamten Entwicklungszyklus von entscheidender Bedeutung für den Erfolg. Dazu sollte die Produktqualität täglich durch die wichtigsten Tests überprüft werden. Silk Central unterstützt diese Vorgehensweise durch die automatisierte Testausführung anhand von frei konfigurierbaren Zeitplänen während der Produktentwicklung und nach der Bereitstellung. Der Status eines Produkts kann während der Entwicklung jederzeit durch Berichte mit unterschiedlichen Details überprüft werden.

Bei komplexen Softwareprojekten ist das umfassende Testen neuer Builds extrem wichtig. Durch die automatisierte Testausführung in Silk Central wird dabei kostbare Zeit eingespart.

  • Installieren und Lizenzieren von Silk Central
    Hier wird beschrieben, wie Silk Central installiert und lizenziert wird.
  • Silk Central Konzepte
    Hier werden die grundlegenden Konzepte von Silk Central erklärt, mit dessen Workflow, den verfügbaren Elementen, und wozu diese verwendet werden.
  • Benutzeroberfläche
    Hier finden Sie einen Überblick über die Benutzeroberfläche von Silk Central.
  • Schnellstartaufgaben
    Schnellstartaufgaben geben einen Überblick über die Aufgaben, die Sie wahrscheinlich am häufigsten mit Silk Central durchführen werden.
Übergeordnetes Thema: Silk Central-Hilfe


Installieren und Lizenzieren von Silk Central

Informationen zum Installieren und Lizenzieren von Silk Central finden Sie in der Online-Hilfe zur Silk Central-Installation, die sich auf der Installations-DVD von Silk Central befindet. Die Hilfe kann auch von der Silk Central-Download-Website heruntergeladen werden.

Übergeordnetes Thema: Erste Schritte
Zugehörige Konzepte
Installations- und Systemkonfigurationshilfe


Silk Central Konzepte

Hier werden die grundlegenden Konzepte von Silk Central erklärt, mit dessen Workflow, den verfügbaren Elementen, und wozu diese verwendet werden.
  • Workflow
    Der Testverwaltungs-Workflow von Silk Central besteht aus vier Hauptaktivitäten: Anforderungen definieren, Tests entwerfen, Ausführungsplanung und Tests ausführen, sowie Testergebnisse verfolgen und analysieren.
  • Anforderungen
    Eine Anforderung ist ein Zustand oder eine Fähigkeit die ein Anwender mit einer bestimmten Aufgabe erledigen muss, die die zu testende Anwendung (AUT) erfüllen muss.
  • Tests
    Ein Test oder Testfall umfasst die für die Ausführung notwendigen Vorbedingungen, die Menge der Eingabewerte (ein Eingabewert je Parameter des Testobjekts), die Menge der vorausgesagten Ergebnisse, sowie die erwarteten Nachbedingungen. Testfälle werden entwickelt im Hinblick auf ein bestimmtes Ziel bzw. auf eine Testbedingung, wie z.B. einen bestimmten Programmpfad auszuführen oder die Übereinstimmung mit spezifischen Anforderungen zu prüfen [nach IEEE 610].
  • Ausführungsplanung
    Im Bereich Ausführungsplanung können Sie die Testausführungen während der Entwicklung und der Tests steuern. Dies beinhaltet Tätigkeiten wie z.B. Testsuiten konfigurieren und deren Ausführung planen, Tests zu Testsuiten zuordnen, Abhängigkeiten von Testsuiten definieren sowie die Bereitstellung von Ausführungsservern und die dynamische Hardwarebereitstellung mit Schlüsselwörtern konfigurieren.
Übergeordnetes Thema: Erste Schritte


Workflow

Der Testverwaltungs-Workflow von Silk Central besteht aus vier Hauptaktivitäten: Anforderungen definieren, Tests entwerfen, Ausführungsplanung und Tests ausführen, sowie Testergebnisse verfolgen und analysieren.

Anforderungen definieren

Tests entwerfen

Ausführungsplanung und Tests ausführen

Testergebnisse verfolgen und analysieren

Übergeordnetes Thema: Silk Central Konzepte


Anforderungen

Eine Anforderung ist ein Zustand oder eine Fähigkeit die ein Anwender mit einer bestimmten Aufgabe erledigen muss, die die zu testende Anwendung (AUT) erfüllen muss. Verbinden Sie Ihre Anforderungen und Tests, um messen zu können, wie gut Ihre Software die definierten Anforderungen erfüllt. Mehrere Tests können eine einzelne Anforderung abdecken, und mehrere Anforderungen können von einem einzelnen Test abgedeckt sein.

Übergeordnetes Thema: Silk Central Konzepte


Tests

Test |  | Ein Test oder Testfall umfasst die für die Ausführung notwendigen Vorbedingungen, die Menge der Eingabewerte (ein Eingabewert je Parameter des Testobjekts), die Menge der vorausgesagten Ergebnisse, sowie die erwarteten Nachbedingungen. Testfälle werden entwickelt im Hinblick auf ein bestimmtes Ziel bzw. auf eine Testbedingung, wie z.B. einen bestimmten Programmpfad auszuführen oder die Übereinstimmung mit spezifischen Anforderungen zu prüfen [nach IEEE 610]. Silk Central unterstützt verschiedene Testtypen, und diese können je nach Bedarf strukturiert werden.
 | Testtypen
 | Manueller Test | Manuelle Tests sind Schritt-für-Schritt Anweisungen für Tester. Silk Central Stellt eine Benutzeroberfläche zur Verfügung, mit der manuelle Tests effizient durchgeführt werden können, inklusive der Option während des Testens Videos und Screenshots aufzunehmen. Manuelle Tests können bei Bedarf zu einem späteren Zeitpunkt dann auch in automatisierte Tests konvertiert werden.
 | Schlüsselwortgetriebener Test | Ein schlüsselwortgetriebener Test ist eine ausführbare Reihenfolge von Schlüsselwörtern. Ein schlüsselwortgetriebener Test kann wie jeder andere Test ausgeführt werden. Silk Central und Silk Test unterstützen die schlüsselwortgetriebene Testmethodologie und ermöglichen eine sehr enge Zusammenarbeit zwischen Automatisierungsingenieuren und Business Analysten, indem Automatisierungsingenieure ein wartbares Automatisierungs-Framework erstellen, welches aus gemeinsamen Objekten in Form von Schlüsselwörtern in Silk Test besteht. Diese Schlüsselwörter können dann von Business Analysten sowohl in Silk Test verwendet werden, um neue schlüsselwortgetriebene Tests zu erstellen, als auch in Silk Central, um existierende manuelle Tests zu automatisieren oder um neue schlüsselwortgetriebene Tests zu erstellen.
 | UFT-Test | Mit Unified Functional Testing (UFT) Software, früher HP QuickTest Professional (QTP) genannt, können funktionales Testen und Regressionstests für Software-Anwendungen und -Umgebungen automatisiert werden.
 | JUnit-Test | JUnit ist ein Unit-Test-Framework für die Java-Programmiersprache. Verwenden Sie diesen Testtyp für JUnit-, Silk4J- und Selenium-Tests.
 | NUnit-Test | NUnit ist ein Unit-Test-Framework für die Microsoft .NET-Programmiersprache.
 | MSTest-Test | MSTest ist ein Befehlszeilen-Tool von , welches Unit-Tests ausführt die mit Microsoft erstellt wurden. Verwenden Sie diesen Testtyp für MSTest- und Silk4NET-Tests.
 | ProcessExecutor-Test | Mit dem ProcessExecutor-Testtyp kann jede beliebige Befehlszeile ausgeführt werden.
 | .NET Explorer-Test | Der -Testtyp wird verwendet um bestimmte Silk Performer .NET Explorer-Skripts oder einen bestimmten Testfall eines Skripts auszuführen.
 | Silk Performer-Test | Silk Performer-Projekte können in Silk Central-Tests integriert und über Silk Central direkt ausgeführt werden. Dadurch stehen leistungsfähige Funktionen zur Analyse von Testergebnissen und Berichtserstellung zur Verfügung. Außerdem können Tests in Silk Central durch vorkonfigurierte Ausführungstermine automatisiert ausgeführt werden.
 | Silk Test Workbench-Test | Silk Test Workbench ist ein automatisiertes Testprogramm, das die Funktionstests komplexer Anwendungen beschleunigt. Silk Test Workbench bietet Unterstützung für Testanwendungen, die mit einer Vielzahl unterschiedlicher Entwicklungsprogramme hergestellt wurden, etwa Java, .NET, browserbasierte Webanwendungen und COM-Komponenten wie ActiveX-Steuerelemente und Automatisierungsobjekte.
 | Silk Test Classic-Test | Die Silk Central-Schnittstelle von Silk Test Classic ermöglicht Silk Test Classic-Benutzern die zuverlässige Ausführung automatisierter Tests. Jeder Testfall eines Silk Test Classic-Skripts wird in seinem eigenen Testlauf ausgeführt und produziert seine eigenen Ergebnisse.
 | Silk Test Classic-Plantest | Der Silk Test Classic Plan-Testtyp wird für Silk Test Classic Testpläne verwendet. Ein Testplan ist üblicherweise ein hierarchisch strukturiertes Dokument, welches die Testanforderungen beschreibt und die Befehle, 4Test-Skripts und Testfälle enthält, welche die Testanforderungen implementieren.
 | Silk TestPartner-Test | TestPartner ist ein Micro Focus-Produkt zum Testen von Web- und Microsoft Windows-basierten Anwendungen, die Microsoft-Technologie verwenden.
 | Teststruktur
 |  | Container werden für die Testelementstruktur auf höchster Hierarchiestufe verwendet. Silk Central verbindet ein definiertes Versionsverwaltungsprofil und ein Produkt mit einem Container, was einen Einfluss darauf hat, was Sie mit den Tests in einem bestimmten Container alles tun können.
 |  | Verwenden Sie Ordner zum Strukturieren Ihrer Tests innerhalb von einem Container.
 |  | Testpakete stellen eine Methode dar, die Struktur von Testtypen von Fremdherstellern in Silk Central zu unterstützen. Sie bestehen aus einem Paketstamm und einer beliebigen Hierarchie von Testsuiteknoten und Testknoten.
Übergeordnetes Thema: Silk Central Konzepte


Ausführungsplanung

Im Bereich Ausführungsplanung können Sie die Testausführungen während der Entwicklung und der Tests steuern. Dies beinhaltet Tätigkeiten wie z.B. Testsuiten konfigurieren und deren Ausführung planen, Tests zu Testsuiten zuordnen, Abhängigkeiten von Testsuiten definieren sowie die Bereitstellung von Ausführungsservern und die dynamische Hardwarebereitstellung mit Schlüsselwörtern konfigurieren.

Eine Testsuite besteht aus einer Reihe zugeordneter Tests, die sich im selben Container befinden. Eine Testsuite kann nach eingestellten Ausführungsterminen und auf bestimmten Ausführungsservern gestartet werden.

Unter dem Testen von Konfigurationen wird das Testen eines Systems mit allen unterstützten Software- und Hardware-Konfigurationen verstanden. Sie können Konfigurationssuiten mit zugeordneten Tests erstellen, so dass allen zu einer Konfigurationssuite hinzugefügten Testsuiten diese Tests zugeordnet werden.

Ein Testzyklus ist ein durch ein Start- und Enddatum definierter Zeitraum, für den manuelle Tester festgelegt wurden. Erstellen Sie Testzyklen um die Ausführung einer bestimmten Menge von Tests zu planen und durchzuführen.

Verwenden Sie Ordner, um Ihre Testsuiten, Konfigurationssuiten und Testzyklen zu strukturieren. Sie können auch Ordner innerhalb von Ordnern anlegen.

Übergeordnetes Thema: Silk Central Konzepte


Benutzeroberfläche

Hier finden Sie einen Überblick über die Benutzeroberfläche von Silk Central.

  • Benutzeroberfläche
    Hier finden Sie einen Überblick über die Benutzeroberfläche von Silk Central.
  • Dashboard
    Hier wird der individuelle Startbereich für Silk Central-Benutzer beschrieben.
  • Browsereinstellungen
    In diesem Abschnitt wird beschrieben, wie Sie die Browsereinstellungen ändern, um die Funktionalität und Leistung von Silk Central zu optimieren.
  • An- und Abmelden
    Hier wird beschrieben, wie Sie sich bei Silk Central an- und abmelden.
Übergeordnetes Thema: Erste Schritte


Benutzeroberfläche

Hier finden Sie einen Überblick über die Benutzeroberfläche von Silk Central.

Grundstruktur der Benutzeroberfläche

Die Benutzeroberfläche von Silk Central enthält:

  • Das Menü: Befindet sich im oberen Bereich der Benutzeroberfläche. Bietet schnellen Zugriff auf die Funktionsbereiche von Silk Central.
  • Der Arbeitsbereich: In diesem Beispiel enthält der Arbeitsbereich Registerkarten, in denen die Funktionsbereiche der aktuell ausgewählten Silk Central-Einheit angezeigt werden. Diese Ansicht ändert sich abhängig vom aktuell angewählten Arbeitsbereich.

Die Einheiten von Silk Central

Das Menü bietet schnellen Zugriff auf die Funktionsbereiche von Silk Central. Es enthält die folgenden Hauptkomponenten:

Start

Das neue Dashboard stellt Ihren persönlichen Ausgangspunkt dar. Sie können es anpassen, indem Sie verschiedene Panels hinzufügen und anordnen, die die für Ihre tägliche Arbeit benötigten Informationen enthalten.

Anforderungen

Hier können Sie während der Entwicklung Ihre Projektanforderungen anzeigen und verwalten. Hier können Sie die folgenden Aufgaben ausführen:

  • Erstellen, Bearbeiten und Löschen von Anforderungen.
  • Zuordnen von Tests zu Anforderungen.
  • Nachverfolgen der Änderungshistorie einer Anforderung.
  • Erzeugen von Testplänen aus Anforderungslisten.
Außerdem können Sie auf folgende Funktionen zugreifen und diese verwalten:
  • Die Eigenschaften der Anforderungen.
  • Externes integriertes Anforderungsverwaltungstool.
  • Anforderungsfilter.
  • Benachrichtigungen zur Information über Änderungen an den Anforderungen.

Tests

Ermöglicht das Erstellen und Verwalten von automatisierten und manuellen Tests. Außerdem können Sie auf folgende Funktionen zugreifen und diese verwalten:

  • Bibliotheken, aus denen häufig verwendete manuelle Tests, Testschritte und Schlüsselwörter wiederverwendet werden können.
  • Eigenschaften der einzelnen Testschritte für manuelle Tests.
  • Eigenschaften von Schlüsselwörtern und schlüsselwortgetriebenen Tests.
  • Testattribute.
  • Die Datenquellen, die für die Tests zur Verfügung stehen.
  • Versionsverwaltungsprofile, in denen diese Tests gespeichert sind.
  • Testfilter.
  • Benachrichtigungen zur Information über Änderungen an den Tests.
  • Version und Build eines Produkts, das mit einem bestimmten Test getestet wird.

Ausführungsplanung

Zeigt die Tests an und ermöglicht Ihnen, die dazugehörigen Ausführungen zu verwalten. Hier können Sie die folgenden Aufgaben ausführen:

  • Testsuiten konfigurieren.
  • Einer Testsuite Tests zuweisen.
  • Festlegen von Testsuiten-Abhängigkeiten.
  • Konfigurieren der Einrichtung von Ausführungsservern, einschließlich der Ausführungsserver, auf denen die Tests ausgeführt werden.
  • Planung und Verwaltung der manuellen Ausführung von Tests.
Außerdem können Sie auf folgende Funktionen zugreifen und diese verwalten:
  • Ausführungsfilter.
  • Testsuitepläne.
  • Version und Build eines Produkts, das mit einer bestimmten Testausführung getestet wird.
  • Benachrichtigung bei Änderungen am Ausführungsprozess.

Verfolgung

Zeigt die Seite Aktivitäten, die Seite Projektübergreifende Aktivitäten, den Projektübersichtsbericht und die Qualitätsziele an.

Auf der Seite Aktivitäten können Sie die vor Kurzem ausgeführten, aktuellen und bevorstehenden Testsuiteaktivitäten eines Projekts überprüfen.

Fehler

Hiermit können Sie die dem aktiven Projekt zugeordneten Fehler anzeigen und sie verwalten.

Außerdem können Sie auf folgende Funktionen zugreifen und diese verwalten:
  • Projekte im Issue Manager, wenn sich die Fehler im Issue Manager befinden.
  • Externe Fehlerverfolgungsprofile, in denen sich möglicherweise Fehler befinden können.

Berichte

Zeigt die Berichte, mit Informationen zu Anforderungen, Tests und Testsuiten an und ermöglicht Ihnen, sie zu verwalten. Hier können Sie die folgenden Aufgaben ausführen:
  • Erstellen von Berichten.
  • Herunterladen von Berichtsvorlagen.
  • Bearbeiten von Berichtsparametern.
  • Erstellen neuer Berichte aus vorinstallierten Vorlagen.

Bietet außerdem Zugriff auf Funktionsinformationen zur Codeanalyse. Hier können Sie ermitteln, in welchem Maß der Anwendungscode in Ihrer AUT (Application Under Test) durch Testfälle abgedeckt wird. Nehmen Sie hier für bestimmte Codeänderungen Abschätzungen bezüglich Aufwand, Kosten und Risiken vor.

Globale Suche

Das Textfeld Suchen nach ermöglicht die Suche über mehrere Bereiche von Silk Central. Die folgenden Bereiche werden bei einer globalen Suche berücksichtigt:
  • Anforderungen und deren Eigenschaften
  • Tests, Ordner, Container und deren Attributwerte, Eigenschaften und Parameter
  • Testschritte und deren Eigenschaften
  • Testsuiten, Konfigurationssuiten, Testzyklen, Ordner und deren Parameter
  • Bibliotheksordner, -schritte und Bibliotheken mit gemeinsam verwendbaren Testschritten
  • Fehler (Kurzbezeichnung und Beschreibung)
Anmerkung: Der Suchindex wird regelmäßig im Hintergrund aktualisiert. Dadurch kann es vorkommen, dass die Suchergebnisse manchmal nicht auf dem aktuellsten Stand sind.
Suchregeln:
  • Die Suche achtet nicht auf Groß-/Kleinschreibung.
  • Es wird einzeln nach allen eingegebenen Wörtern gesucht. Elemente sind ein Suchtreffer, wenn mindestens eines der Wörter gefunden wird, und je mehr Wörter gefunden werden, desto höher wird der Treffer gewertet.
  • Geben Sie Wörter, die gefunden werden müssen, mit einem + ein. Zum Beispiel "+Test +Type" liefert nur Resultate, die sowohl "Test" als auch "Typ“ enthalten.
  • Geben Sie Wörter, die nicht gefunden werden dürfen, mit einem - ein. Zum Beispiel "Test -Kopie" liefert nur Resultate, die "Test", aber nicht "Kopie von Test“ enthalten.
  • Um nach einer genauen Übereinstimmung zu suchen, geben Sie den Suchbegriff in Anführungszeichen ein, z.B. "kundenkonto verwaltung".
  • Soll nur der Name von Elementen durchsucht werden, oder nur die Beschreibung, geben Sie vor dem Suchbegriff name: resp. Description: ein. Zum Beispiel liefert name:test nur Ergebnisse in denen der Name der Elemente das Wort test enthält.
  • Übliche englische Worte wie 'a', 'the', 'and' werden ignoriert.
Beispiel:
name:"test element" -description:abgeschlossen
Dies liefert Resultate von Elementen in deren Namen den Begriff "test element" vorkommt und in deren Beschreibung der Begriff "abgeschlossen“ nicht vorkommt.

Projekte

Zeigt alle Projekte in Ihrer Silk Central-Installation auf oberer Ebene an und ermöglicht Ihnen so, alle Projekte zu verwalten. Hier können Sie außerdem zwischen Projekten umschalten und Projekteinstellungen verwalten.

Benutzer

Zeigt die Benutzereinstellungen an und ermöglicht Ihnen, diese zu verwalten. Außerdem können Sie hiermit folgendes:
  • Abmelden bei Silk Central.
  • Drucken Sie die aktuelle Seite in Silk Central aus.
  • Versehen Sie die aktuelle Silk Central-Seite mit einem Lesezeichen. Dies ist besonders hilfreich, um Berichte mit Lesezeichen zu versehen, bei denen die aktuellen Parameter in der mit einem Lesezeichen gekennzeichneten URL gespeichert werden.

Verwaltung

Zeigt die Verwaltungseinstellungen an und ermöglicht Ihnen, diese zu verwalten. Weitere Informationen finden Sie in den Themen Verwaltung in dieser Hilfe.

Hilfe

Klicken Sie, um die kontextbezogene Hilfe für die aktuelle Seite anzuzeigen. Außerdem bietet sie Zugriff auf folgende Dokumente:
  • Die Silk Central Dokumentation.
  • Tools, die im Lieferumfang von Silk Central enthalten sind.
  • Info. Anzeige von Versions- und Lizenzinformationen.

Befehle des Kontextmenüs

Silk Central unterstützt Kontextmenüs in vielen Elementen des Testmanagements (Tests, Anforderungen, Testsuiten, Ordner, Container, Berichte usw.). Kontextmenüs werden durch Klicken mit der rechten Maustaste geöffnet und enthalten normalerweise dieselben Befehle, die in der Symbolleiste des jeweiligen Bereichs zur Verfügung stehen. Für Elemente in Hierarchien enthalten Kontextmenüs Befehle zum Erweitern und Ausblenden dieser Elemente. Befehle, die für die ausgewählten Elemente nicht verfügbar sind, sind deaktiviert.

Übergeordnetes Thema: Benutzeroberfläche


Dashboard

Das Dashboard in Silk Central stellt Ihren persönlichen Ausgangspunkt dar. Sie können diesen Bereich anpassen, indem Sie verschiedene Panels hinzufügen und anordnen, die die für Ihre tägliche Arbeit benötigten Informationen enthalten.

Wenn Sie sich erstmals in Silk Central anmelden, enthält das Dashboard lediglich das Panel Einführung. Im oberen Bereich werden Datum und Uhrzeit Ihrer letzten Anmeldung angezeigt. Klicken Sie auf Fortsetzen der letzten Sitzung, um umgehend dort weiterzuarbeiten, wo Sie zuletzt aufgehört haben.

Über die Schaltflächen im oberen Bereich können Sie folgende Aktionen durchführen:
  • Klicken Sie auf Panel hinzufügen, um dem Dashboard ein Panel hinzuzufügen.
  • Klicken Sie auf Layout auswählen, um das Layout des Dashboards zu ändern.
  • Klicken Sie auf Dashboard zurücksetzen, um die Standardansicht des Dashboards wiederherzustellen. Dazu werden alle hinzugefügten Panels sowie Ihre angepassten Einstellungen entfernt.

Um Ihre Panels anzuordnen, klicken Sie auf die Kopfzeile eines Panels, und ziehen Sie es an die gewünschte Position. Ändern Sie die Größe eines Panels, indem Sie die Fußleiste ziehen (nur Panels mit Listen können angepasst werden).

Über die Schaltflächen in der Kopfzeile eines Panels können Sie folgende Aktionen durchführen:
  • Klicken Sie auf [image], um das Panel vom Dashboard zu entfernen.
  • Klicken Sie auf [image], um die Einstellungen des Panels zu konfigurieren.
  • Klicken Sie auf [image], um den Inhalt des Panels als PDF-Datei zu speichern.
  • Klicken Sie auf [image], um den Inhalt des Panels auszudrucken.

Sie müssen über entsprechende Berechtigungen verfügen, um die Inhalte der unterschiedlichen Panels anzeigen oder bearbeiten zu können.

  • Hinzufügen eines Panels zum Dashboard
    In diesem Abschnitt ist beschrieben, wie Sie Panels zum Dashboard hinzufügen.
  • Dashboard-Panels
    Hier werden die Panels beschrieben, die Sie Ihrem Dashboard hinzufügen können.
  • Silk Central Connect
    Hier wird beschrieben, was Silk Central Connect ist und wie Sie es anwenden können.
  • Berechtigungen für Dashboard-Panel
    In diesem Abschnitt wird beschrieben, welche Berechtigungen für die Anzeige oder zum Bearbeiten der Inhalte eines bestimmten Panels erforderlich sind.
  • Hinzufügen eines Berichts zu einem Dashboard-Panel
    Hier wird beschrieben, wie ein neuer Bericht erstellt und einem Dashboard-Panel hinzugefügt wird.
Übergeordnetes Thema: Benutzeroberfläche


Hinzufügen eines Panels zum Dashboard

So fügen Sie ein Panel zum Dashboard hinzu:

  1. Klicken Sie im Menü auf Startseite > Mein Dashboard.
  2. Klicken Sie oben links auf Panel hinzufügen. Das Dialogfeld Panel hinzufügen wird angezeigt. Darin sind die verfügbaren Paneltypen aufgeführt und kurz beschrieben.
  3. Wählen Sie ein Panel aus.
  4. Klicken Sie auf OK.
  5. Wählen Sie bei Bedarf ein Projekt und einen Zeitrahmen für das Panel aus. Wählen Sie <Aktuelles Projekt verwenden>, so dass das Panel immer die Daten des aktuell aktiven Projekts anzeigt.
  6. Klicken Sie auf OK.

Für viele Panels müssen Sie ein Projekt konfigurieren, da die meisten Panels nur die Daten eines Projekts anzeigen können. Um die gewünschten Daten für andere Projekte anzuzeigen, können Sie weitere Panels hinzufügen, oder konfigurieren Sie ein Panel mit der Option <Aktuelles Projekt verwenden>, um immer die Daten des derzeit aktiven Projekts anzuzeigen. Klicken Sie auf [image] (Konfigurieren) in der Kopfzeile eines Panels, um ein weiteres Projekt auszuwählen. Sie müssen über entsprechende Berechtigungen verfügen, um die Inhalte der unterschiedlichen Panels anzeigen oder bearbeiten zu können.

Übergeordnetes Thema: Dashboard


Dashboard-Panels

Für viele Panels müssen Sie ein Projekt konfigurieren, da die meisten Panels nur die Daten eines Projekts anzeigen können. Um die gewünschten Daten für andere Projekte anzuzeigen, können Sie weitere Panels hinzufügen, oder konfigurieren Sie ein Panel mit der Option <Aktuelles Projekt verwenden>, um immer die Daten des derzeit aktiven Projekts anzuzeigen. Klicken Sie auf [image] (Konfigurieren) in der Kopfzeile eines Panels, um ein weiteres Projekt auszuwählen. Sie müssen über entsprechende Berechtigungen verfügen, um die Inhalte der unterschiedlichen Panels anzeigen oder bearbeiten zu können.

Sie können Ihrem Dashboard folgende Panels hinzufügen:

Panel | Beschreibung
Zugewiesene Fehler | Dieses Panel enthält alle Fehler (die einem Test zugeordnet wurden) des ausgewählten Projektes. Klicken Sie auf die externe ID, wird der Fehler im externen Fehlerverfolgungssystem geöffnet.
Benutzerdefinierte Information | Dieses Panel enthält die vom Benutzer anpassbaren Informationen zu einem bestimmten Projekt. Benutzer mit der Berechtigung zum Verwalten von Projekten können Inhalte wie Text, Bilder oder Hyperlinks zum Panel hinzufügen. Klicken Sie auf Inhalt bearbeiten, um den HTML-Editor zu öffnen. Benutzer ohne Berechtigung zum Verwalten von Projekten sehen lediglich die Inhalte. Mit Hilfe des Panels können sich Benutzer Neuigkeiten, Beschreibungen oder verschiedene andere Informationen zum Projekt anzeigen lassen.
Einführung | Dieses Panel vermittelt eine kurze Einführung in Silk Central. Klicken Sie auf die Links unter Was gibt es Neues?, um weitere Informationen zu den neuesten Merkmalen von Silk Central anzuzeigen. Sie können auch der Micro Focus Community beitreten oder die Micro Focus SupportLine kontaktieren.
Fehler-Lebenszyklus | In diesem Panel wird für ein vordefiniertes Fehlerverfolgungsprofil die Anzahl der Fehler mit dem Status Offen, Behoben, Verifiziert, Geschlossen und Zurückgestellt aufgeführt. Wählen Sie ein Produkt aus der Liste aus. Klicken Sie zum Definieren eines Fehlerverfolgungsprofils im Menü auf Fehler und anschließend auf Fehlerverfolgungs-Integrationen und Neues Profil. Im Panel werden nur dann Daten angezeigt, wenn bereits ein Profil angelegt wurde.
Gefundene Fehler pro Tester | In diesem Panel wird die Anzahl der von den Testern angelegten Fehler in Form eines Balkendiagramms angezeigt. Werden die Daten gedruckt oder als PDF-Datei heruntergeladen, werden sie zusätzlich in Tabellenform dargestellt.
Mir zugewiesene manuelle Tests

In diesem Panel werden für ein ausgewähltes Projekt alle Ihnen zugeordneten Tests angezeigt.

Wenn die manuelle Testausführung mithilfe von Testzyklen vorgenommen wird, enthält die Liste sämtliche Tests, die auf der Seite Manuelle Ausführungsplanung die Zuordnung Kein zugewiesener Tester aufweisen. Dies gilt allerdings nur für Testzyklen, denen Sie als Tester zugewiesen sind. In einem typischen Teamwork-Szenario entscheiden die Tester eigenständig, welchen Test sie ausführen.

Wenn die manuelle Testausführung mithilfe von Testsuiten vorgenommen wird, enthält die Liste die Tests aus allen Testsuiten, denen kein Tester zugewiesen ist.

Klicken Sie auf [image] (Manuellen Test fortsetzen), um das Fenster Manuelles Testen zu öffnen.

Klicken Sie auf [image] (Ergebnisse manueller Tests anzeigen) um sämtliche Informationen über den Test und dessen Anhänge anzuzeigen.

Klicken Sie auf [image], um ausführliche Informationen zum Test, der Testsuite oder den Übergeordneter Knoten anzuzeigen.

Klicken Sie mit der rechten Maustaste auf einen Test und danach auf [image] um einen manuellen Test in Excel Format herunterzuladen und ihn offline auszuführen (mehrere Tests können mit Strg+Klick oder Umschalt+Klick ausgewählt werden). Nachdem Sie den Test ausgeführt haben, klicken Sie auf Ergebnisse von manuellen Offline-Testausführungen hochladen um die Ergebnisse hochzuladen.

Beim Starten eines Testzyklus (auf der Seite Manuelle Ausführungsplanung) vor dem Startdatum, werden die Tests dieses Testzyklus bereits im Panel angezeigt. Sie können diese Tests im Panel unsichtbar machen bis das Startdatum erreicht wird: Klicken Sie [image] in den Kopfdaten des Panels und haken Sie Zukünftige Testzyklen ausblenden an.
Manuelle Offline-Tests | In diesem Panel werden die Tests angezeigt, die von Testern heruntergeladen wurden. Zudem kann ein Test Manager Offline-Testausführungen abzubrechen und dadurch Lizenzen freizugeben.
Geplante und tatsächliche Ausführungszeit | In diesem Panel wird angezeigt, ob die Tester den Test eines Testzyklus termingerecht durchführen. Überschreiten die tatsächliche Ausführungsdauer und die verbleibende geplante Dauer die Kapazität, kann der Testzyklus möglicherweise nicht rechtzeitig beendet werden.
Qualitätsziel-Fortschritt | Dieses Panel enthält ein Diagramm mit zwei Balken für die beiden Werte des ausgewählten Qualitätsziels. Der obere Balken gibt die Anzahl der Tests an, die ausgeführt werden müssen, um das Qualitätsziel zu erreichen. Der untere Balken gibt die Anzahl der Tests mit dem Status Bestanden, Fehlgeschlagen, Nicht ausgeführt und N/V (nicht verfügbar) an, die diesen Qualitätszielwert besitzen. Wenn der untere Balken kürzer ist als der obere, sind den Testsuiten zu wenige Tests zugeordnet. Dies bedeutet, dass das Qualitätsziel nicht erreicht werden kann. Wählen Sie ein Qualitätsziel aus der Liste aus.
Berichts-Abonnement | Dieses Panel enthält die Ergebnisse eines Berichtsabonnements. Das Berichtsabonnement muss bereits vorhanden sein und Sie müssen auf dem Dialog Abonnement bearbeiten die Option Für Dashboard und externen Zugriff zur Verfügung stellen ausgewählt haben, um es verfügbar zu machen.
Status der Anforderungsabdeckung | In diesem Panel wird die Anforderungsabdeckung des ausgewählten Projekts angezeigt, unterteilt in Anforderungen mit den Status Bestanden, Fehlgeschlagen, Nicht ausgeführt und Nicht abgedeckt. Klicken Sie auf [image], um zur Dokumentansicht der Anforderungen zu gelangen.
Silk Central Connect
Silk Central Connect kombiniert Aspekte der Testausführungsaverwaltung und des Konfigurationstestens in einer einfach zu bedienenden Benutzeroberfläche, was die folgenden Vorteile mit sich bringt:
  • Eine einfache Ausführung all Ihrer Unit-Tests auf einer Vielzahl von Konfigurationen, welche eine Kombination von Betriebssystemen und Web-Browsern sind.
  • Setzt die Vorteile von Amazon Web Services wirksam ein, wodurch Sie ohne Vorinvestitionen auf einfachste Weise auf eine Vielzahl von Konfigurationen zugreifen können.
  • Eine enge Integration von Silk Central Connect und Silk4J, um eine möglichst einfache Testerstellung, -Wartung und -Ausführung zu ermöglichen.
  • Ergebnisanalyse auf einen Blick, wodurch Sie sämtliche Tests über alle verschiedenen Konfigurationen vergleichen können.

Weitere Informationen finden Sie unter Silk Central Connect.
Silk Performer-Leistungstrends | Das Silk Performer Performance-Trends-Panel zeigt den aktuellen Status des ausgewählten Silk Performer-Lasttests an, sowie dessen Testergebnisse, inklusive Ergebnistrends über die letzten Testläufe.
Status der derzeit laufenden manuellen Tests | In diesem Panel wird der Status aller zur Zeit ausgeführten manuellen Tests des definierten Projekts angezeigt. Test Manager haben eine Übersicht über blockierte Tests und können den Status von bereits ausgeführten Tests in laufenden Testausführungen überwachen.
Testbook | In diesem Panel werden in Echtzeit Updates aller Aktivitäten angezeigt, die während dem manuellen Test durchgeführt werden. Aktivitäten die im Testbook protokolliert werden, beziehen sich auf das Starten, Beenden und Bearbeiten laufender Testzyklen. Weitere Informationen finden Sie unter Testbook.
Testzyklus-Fortschritt | Dieses Panel enthält ein Burnup-Chart, das für den definierten Testzyklus die Tests mit den Status Bestanden, Fehlgeschlagen, In Arbeit und Nicht ausgeführt angibt. Es enthält ebenfalls die Meilensteine (in Form von Diamanten), falls Sie solche festgelegt haben. Wählen Sie einen Testzyklus aus der Liste aus.
Testzyklus Ergebnis-Zusammenfassung | In diesem Panel wird der Status des ausgewählten Testzyklus sowie der Fortschritt der einzelnen Tester angezeigt, die dem Testzyklus zugeordnet wurden. Die Balken erscheinen in der folgenden Reihenfolge: Anzahl der Fehlgeschlagenen Tests, der Verbleibenden Tests und der Bestandenen Tests. Der Tester mit den meisten fehlgeschlagenen Tests erscheint in der Liste ganz oben. Die Zahlen rechts neben den Balken geben die Abgeschlossenen Tests (linke Zahl) und die Zugewiesenen Tests (rechte Zahl) wieder. Kein zugewiesener Tester wird wie alle anderen Tester auch behandelt und einsortiert. Klicken Sie in der Ansicht Testzuordnung der Seite Manuelle Ausführungsplanung auf [image].
Testzyklus-Zeitverlauf | In diesem Panel werden für ein ausgewähltes Projekt alle Testzyklen als Balken auf einer Zeitleiste angezeigt. Beim Klicken auf einen Balken werden Sie auf die Seite Manuelle Ausführungsplanung weitergeleitet. Die Balken sind, je nach aktuellem Status des Testzyklus, unterschiedlicher Farbe: blau (läuft), orange (noch nicht gestartet), grau (beendet). Bewegen Sie die Maus über den Balken, um detaillierte Informationen über den Testzyklus zu erhalten.
Testfortschritt über Testzyklen | In diesem Panel wird die Zeit in Stunden für die Geplanten Tests (dargestellt durch einen Linie) sowie die Tests mit dem Status In Arbeit und Abgeschlossen (in gestapelten Flächendiagrammen) angezeigt. Mit Hilfe dieses Panels kann ein Testmanager vorhersagen, ob das Testteam die Tests rechtzeitig beenden wird. Das Startdatum in der Übersicht entspricht dem Startdatum des ersten Testzyklus. Das Enddatum in der Übersicht entspricht dem Enddatum des letzten Testzyklus. Nicht angegeben ist, wie viel Zeit das Testteam zur Ausführung der Tests benötigt hat.
Volatile Tests | In diesem Bereich wird angezeigt, wie häufig sich innerhalb eines Ausführungsplans der Status der Tests geändert hat. Tests ohne Statusänderungen und Testpakete werden hier nicht angezeigt. Die Tests werden entsprechend dem ausgewählten Projekt und Zeitrahmen angezeigt. Auf dieser Seite werden Testmanager auf solche volatilen Tests aufmerksam gemacht, die entweder auf einen instabilen Test hinweisen oder auf einen getesteten Bereich, in dem es vermehrt zu Softwarefehlern kommt.
Übergeordnetes Thema: Dashboard


Silk Central Connect

Silk Central Connect kombiniert Aspekte der Testausführungsaverwaltung und des Konfigurationstestens in einer einfach zu bedienenden Benutzeroberfläche, was die folgenden Vorteile mit sich bringt:
  • Eine einfache Ausführung all Ihrer Unit-Tests auf einer Vielzahl von Konfigurationen, welche eine Kombination von Betriebssystemen und Web-Browsern sind.
  • Setzt die Vorteile von Amazon Web Services wirksam ein, wodurch Sie ohne Vorinvestitionen auf einfachste Weise auf eine Vielzahl von Konfigurationen zugreifen können.
  • Eine enge Integration von Silk Central Connect und Silk4J, um eine möglichst einfache Testerstellung, -Wartung und -Ausführung zu ermöglichen.
  • Ergebnisanalyse auf einen Blick, wodurch Sie sämtliche Tests über alle verschiedenen Konfigurationen vergleichen können.
  • Übersicht
    Hier wird beschrieben, was Silk Central Connect ist und wie Sie es anwenden können.
  • Silk Central Connect-Architektur
    Dieser Abschnitt enthält einen Überblick über die Architektur von Silk Central Connect.
  • Voraussetzungen
    Hier werden die Voraussetzungen beschrieben, die nötig sind um mit Silk Central Connect zu arbeiten.
  • Konfigurieren der Versionsverwaltung
    Integrieren Sie Silk Central Connect mit Ihrem Subversion-Versionsverwaltungssystem, damit Silk Central Connect Projektdaten speichern kann.
  • Erstellen von Tests für Ihre Web-Anwendung
    Erstellen Sie Ihren Test und überprüfen Sie, wie Ihre Web-Anwendung in den verfügbaren Browsern auf Ihrer Standard-Servergruppe aussieht.
  • Erweitern der Tests für Ihre Web-Anwendung
    Erstellen Sie Tests um die Funktionalität Ihrer Web-Anwendung zu testen.
  • Gleichzeitiges Ausführen Ihrer Web-Anwendungstests auf verschiedenen Browsern
    Erweitern Sie Ihre Testumgebung, so dass die Tests für Ihre Web-Anwendung auf verschiedenen Browsern gleichzeitig ausgeführt werden.
  • Analysieren von Testergebnissen
    Analysieren Sie die Testergebnisse, nachdem Sie einen Test ausgeführt haben.
  • Planen von Ausführungsterminen für eine kontinuierliche Testausführung
    Planen Sie Ausführungstermine für Ihre Projekte, um sie täglich um eine bestimmte Zeit auszuführen.
  • Häufig gestellte Fragen
    Hier finden Sie Antworten zu häufig gestellten Fragen bezüglich Silk Central Connect.
Übergeordnetes Thema: Dashboard


Übersicht

Mit Silk Central Connect können Sie Webanwendungen mit Hilfe der Cloud und somit ohne großen Konfigurationsaufwand auf unterschiedlichen Desktop und mobilen Web-Browsern testen. Silk Central Connect:
  • Senkt die Ausführungszeit und Aufwände für Cross-Browser-Testen um bis zu 80%
  • Verringert die Gesamtbetriebskosten durch Nutzung vorkonfigurierter virtueller Hardware
  • Beschleunigt das Finden von Problemen durch visuelle Gegenüberstellung der verschiedenen Browser-Testergebnisse

Detaillierte Informationen zu Silk4J finden Sie im Silk4J User Guide.

Informationen über die Konfiguration Ihrer Testumgebung finden Sie auf Einrichten von Ausführungsservern.

Übergeordnetes Thema: Silk Central Connect


Silk Central Connect-Architektur

Silk Central Connect basiert auf der Architektur von Silk Central. Zusätzlich können Cloud-basierte Ausführungsserver verwendet werden. Wenn Sie eine interne Web-Anwendung in Ihrem Intranet über Cloud-basierte Ausführungsserver testen möchten, können Sie die Tunnel-Einstellungen auf "Lokale Intranetseite" umstellen. Mit dieser Einstellung öffnet der Silk Central-Anwendungsserver einen Tunnel zu den Cloud-basierten Ausführungsservern und wirkt dabei als Proxy, wodurch das Testen einer Webseite in Ihrem Intranet ermöglicht wird. Beachten Sie bitte, dass diese Option langsamer als eine direkte Verbindung ist, und somit nur wenn nötig verwendet werden sollte.

Übergeordnetes Thema: Silk Central Connect


Voraussetzungen

Um mit Silk Central Connect zu arbeiten, sind die folgenden Voraussetzungen nötig:
  • Silk Central muss auf Ihrem Arbeitsplatzrechner installiert sein.
  • Silk4J, das Silk Test-Plug-In für Eclipse, muss auf Ihrem Arbeitsplatzrechner installiert sein.
Übergeordnetes Thema: Silk Central Connect


Konfigurieren der Versionsverwaltung

Damit Silk Central Connect Tests speichern und ausführen kann, muss Silk Central Connect mit Ihrem Subversion (SVN) Versionsveraltungssystem integriert werden.

  1. Klicken Sie im Silk Central Connect-Panel auf SubversionVersionsverwaltung konfigurieren.
  2. Geben Sie im Feld URL die URL Ihres Subversion-Repositorys ein. Falls noch kein SVN-Repository konfiguriert ist, konfiguriert Silk Central Connect automatisch ein Datei-basiertes Repository.
    Wichtig: Ein Datei-basiertes Repository sollte nur zu Evaluationszwecken verwendet werden und keinesfalls für ein Produktivsystem. Außerdem kann dieses Repository nur vom lokalen Rechner aus erreicht werden und Silk4J muss ebenfalls auf diesem Rechner installiert sein.

    Läuft Ihr Subversion Server z.B. auf http://svn.mycompany.com und das Repository befindet sich im Verzeichnis TestAutomation/trunk, geben Sie im Feld URL http://svn.mycompany.com/TestAutomation/trunk ein.

  3. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Mit diesen Daten wird der Zugriff auf das Repository für alle Projekte durchgeführt. Falls Sie ein Datei-basiertes Repository verwenden, müssen weder Benutzername noch Kennwort angegeben werden.
  4. Klicken Sie auf Speichern.
Übergeordnetes Thema: Silk Central Connect


Erstellen von Tests für Ihre Web-Anwendung

Unmittelbar nach der Installation von Silk Central Connect und der Konfiguration von Subversion, können Sie eine neues Projekt für Ihre Web-Anwendung erstellen. Danach können Sie den eingebauten Verifikationslauf verwenden, um sich einen ersten Überblick zu besorgen, wie Ihre Web-Anwendung in den verfügbaren Browsern auf Ihrem lokalen Rechner aussieht.

  1. Klicken Sie im Silk Central Connect-Panel auf Neues Projekt. Der Dialog Neues Projekt wird angezeigt.
  2. Wenn Sie Silk Central Connect in einer vollständigen Silk Central Umgebung verwenden, können Sie Ihr Silk4J Projekt wahlweise einem bereits vorhandenen Silk Central Projekt zuweisen, oder ein neues Silk Central Projekt erstellen.
  3. Wenn Sie ein neues Projekt erstellen, geben Sie im Feld Projektname einen Namen für das Projekt ein.
  4. Geben Sie im Feld URL die URL der Testanwendung ein.
  5. Klicken Sie auf OK.
  6. Optional: Wenn Sie unter Verwendung von Cloud-basierten Ausführungsservern eine interne Web-Anwendung auf Ihrem Intranet testen, klicken Sie auf Tunnel-Einstellungen und wählen Sie Lokale Intranetseite aus. Mit dieser Einstellung öffnet der Silk Central-Anwendungsserver einen Tunnel zu den Cloud-basierten Ausführungsservern und wirkt dabei als Proxy, wodurch das Testen einer Webseite in Ihrem Intranet ermöglicht wird. Beachten Sie bitte, dass diese Option langsamer als eine direkte Verbindung ist, und somit nur wenn nötig verwendet werden sollte.
  7. Klicken Sie auf Tests ausführen.
  8. Wählen Sie alle verfügbaren Konfigurationen aus.
  9. Klicken Sie auf Tests ausführen.
  10. Klicken Sie auf Aktualisieren um zu überprüfen, ob.die Testausführung bereits beendet ist.
  11. Sobald die Testausführung beendet ist, klicken Sie auf den Startzeit-Link. Hier sehen Sie die Testergebnisse aller Konfigurationen. Der Standard-Testfall heißt validateAppearance.
  12. Klicken sie auf das Ergebnis der ersten Konfiguration. Hier sehen Sie detaillierte Testergebnisse, inklusive Screenshots der Testanwendung. Klicken Sie auf einen Screenshot, um ihr zu vergrößern.
  13. Klicken Sie durch die Ergebnisse um zu sehen, wie die Anwendung auf allen Konfigurationen aussieht.

    Tipp: Auf der Tastatur können Sie die Tasten Links und Rechts verwenden, um zwischen den Ergebnissen zu wechseln.
Übergeordnetes Thema: Silk Central Connect


Erweitern der Tests für Ihre Web-Anwendung

Um die hier aufgeführten Schritte auszuführen, sind folgende Voraussetzungen nötig:
  • Um Tests mit Silk4J aufzuzeichnen, muss eine aktuelle Version von Internet Explorer auf Ihrem System installiert sein. Informationen zu den unterstützten Versionen finden Sie in den Versionshinweise.
  • Informationen zu den unterstützten Browsern für die Wiedergabe finden Sie in den Silk Test Versionshinweise.
  • Um auf mobilen Browsern zu testen, müssen Sie einen Emulator auf Ihrem System installieren oder ein mobiles Gerät am System anschließen. Weitere Informationen zum Testen von mobilen Web-Anwendungen finden Sie im Mobile Testing Tutorial.
Nachdem Sie ein Projekt für eine Web-Anwendung erstellt haben, können Sie weitere Tests hinzufügen oder bestehende Tests erweitern um weitere Funktionalität der Web-Anwendung zu testen.
  1. So öffnen Sie ein Projekt in Eclipse:
    • Klicken Sie im Silk Central Connect-Panel, in der Spalte Aktion des entsprechenden Projekts, auf Mit Silk4J öffnen.
    • Klicken Sie auf der Übersichtsseite des Projekts auf Mit Silk4J öffnen.
    Wenn Sie ein Silk Central Connect-Projekt erstellen, wird eine Eclipse-Projektvorlage in Ihre angegebene Versionsverwaltung zurückgeschrieben, welche folgende Komponenten enthält:
    • src-Ordner: Der Speicherort Ihrer Tests
    • Lib-Ordner: Um weitere Java Bibliotheken für Ihr Silk4J-Projekt zu verwenden, speichern Sie diese in diesem Ordner. Wenn Tests ausgeführt werden, fügt Silk Central Connect alle JAR-Dateien in diesem Ordner zum Klassenpfad hinzu.
    • build.xml: Eine vorkonfigurierte ANT Build-Datei, die Silk Central Connect zum Bauen der Tests vor der Ausführung verwendet.
    • Weitere Eclipse-bezogene Dateien
  2. Zeichnen Sie weitere Tests mit Silk4J auf.
    1. Wählen Sie im Package Explorer das Projekt aus, dem Sie einen neuen Test hinzufügen möchten.
    2. Klicken Sie in der Symbolleiste auf Record Actions.
      • Wenn in Eclipse bereits eine Silk4J Testklasse geöffnet ist, werden die aufgezeichneten Aktionen in diese Datei geschrieben.
      • Wenn in Eclipse keine Silk4J Testklasse geöffnet ist, werden die aufgezeichneten Aktionen in eine neue Silk4J Testklassendatei geschrieben.

      Die Web-Anwendung und das Fenster Recording werden geöffnet. Silk4J erstellt einen Basisstatus und beginnt mit der Aufzeichnung.

    3. Führen Sie die Schritte aus, die Sie in der AUT (Anwendung unter Test) aufzeichnen möchten.
    4. Klicken Sie auf Stop Recording. Der Dialog Record Complete wird angezeigt.

    5. Das Feld Source folder wird automatisch mit dem Speicherort der Quelldateien des ausgewählten Projekts befüllt. Um einen anderen Quelldateien-Ordner auszuwählen, klicken Sie auf Select und gehen Sie zum gewünschten Ordner.
    6. Optional: Geben Sie im Feld Package den Paketnamen an. Um ein bestehendes Paket zu verwenden, klicken Sie auf Select und wählen Sie das gewünschte Paket aus.
    7. Geben Sie im Feld Test class den Namen der Testklasse ein.
    8. Geben Sie im Feld Test method den Namen der Testmethode ein.
    9. Klicken Sie auf OK.

    Detaillierte Informationen zu Silk4J finden Sie im Silk4J User Guide.

  3. Stellen Sie sicher, dass der Test erwartungsgemäß in Silk4J funktioniert.
    1. Klicken sie in der Symbolleiste von Silk4J auf Run selected Silk4J test(s).
    2. Wählen Sie auf dem Dialog Select Browser den Browser aus, mit dem Sie den Test wiedergeben möchten.

    3. Klicken Sie auf Run. Wenn der Test bestanden ist und die Testergebnisse wie erwartet sind, können Sie den Test zur Testgruppe des Projekts in Silk Central Connect hinzufügen.
  4. Klicken sie in der Symbolleiste von Silk4J auf Commit um die Projektänderungen in das Repository zurückzuschreiben.
  5. Zurück auf der Projektübersichtsseite in Silk Central Connect, klicken Sie auf Tests ausführen um alle Tests des Projekts auszuführen.
  6. Wählen Sie die Konfigurationen aus.

  7. Klicken Sie auf Tests ausführen.
  8. Sobald die Testausführung beendet ist, klicken Sie auf den Startzeit-Link. Hier sehen Sie die Testergebnisse aller Tests in allen Konfigurationen.

Wenn alle Tests in allen Konfigurationen wie erwartet durchlaufen, können Sie die Tests weiter anpassen oder einen Ausführungstermin für das Projekt definieren, so dass die Tests regelmäßig ausgeführt werden.

Übergeordnetes Thema: Silk Central Connect


Gleichzeitiges Ausführen Ihrer Web-Anwendungstests auf verschiedenen Browsern

Nachdem Sie verifiziert haben, dass Ihre Web-Anwendung auf allen verfügbaren Browsern auf Ihrem Arbeitsplatzrechner wie erwartet aussieht, können Sie weitere Ausführungsserver zu Ihrer Testumgebung hinzufügen, so dass die Tests für Ihre Web-Anwendung auf verschiedenen Browsern gleichzeitig ausgeführt werden.

Um Ihre Web-Anwendung auf weiteren Browsern zu testen, stehen drei Möglichkeiten zur Verfügung:

  1. Installieren Sie weitere Browser auf den bestehenden Ausführungsservern. Dies ermöglicht Ihnen zwar das Testen von zusätzlichen Browsern, jedoch wird für die Ausführung der Tests für Ihre Web-Anwendung mehr Zeit beansprucht, da jeder Browser der Reihe nach auf einem Ausführungsserver getestet wird.
  2. Fügen Sie Ihrer Testumgebung weitere Ausführungsserver hinzu. Dies ermöglicht Ihnen zusätzliche Browser zu testen, ohne dass die Ausführung der Tests wesentlich mehr Zeit in Anspruch nimmt. Die Tests werden, je nach verfügbaren Browsern auf den jeweiligen Servern, auf die Ausführungsserver verteilt. Diese Option setzt jedoch voraus, dass entsprechende Hardware benötigt wird. Weitere Informationen zum hinzufügen eines Ausführungsservers zu Ihrer Testumgebung finden Sie auf der Seite Konfigurieren physischer Ausführungsserver.
  3. Verbinden Sie sich mit der Cloud.
    Anmerkung: Um Ihre Tests in der Cloud ausführen zu können, benötigen Sie ein Cloud-Anbieter-Konto.

    Dies ermöglicht Ihnen eine Vielfalt an Browsern zu testen, ohne dass die Ausführung der Tests mehr Zeit in Anspruch nimmt und ohne dass mehr Hardware benötigt wird. Die zusätzlichen Kosten hängen direkt von Ihrem Testaufwand ab, d.h. von der Größe Ihres Test-Sets und wie oft Sie Tests ausführen.

Informationen über die Konfiguration Ihrer Testumgebung finden Sie auf Einrichten von Ausführungsservern.

Informationen über das gleichzeitige Testen verschiedener Browser mit schlüsselwortgetriebenen Tests finden Sie auf Cross-Browser-Testen mit schlüsselwortgetriebenen Tests.

Übergeordnetes Thema: Silk Central Connect


Analysieren von Testergebnissen

Nachdem Sie einen Test ausgeführt haben, können Sie die Testergebnisse analysieren.

  1. Auf dem Silk Central Connect-Panel kann der Status des letzten Testlaufs aller Projekte eingesehen werden.

  2. Klicken Sie auf den Namen eines Projekts um die Ergebnisse aller Tests und aller Testläufe dieses Projekts einzusehen.

    Die Seite Projektübersicht wird angezeigt.

  3. Klicken Sie auf der Seite Testergebnisse auf den Status eines bestimmten Testergebnisses, um das Ergebnis des Testlaufs für jede Konfiguration einzusehen.

  4. Klicken Sie auf der Seite Testergebnisse auf den Status eines Tests, um detaillierte Informationen wie Fehler-Logs und TrueLog-Dateien anzuzeigen.

Übergeordnetes Thema: Silk Central Connect


Planen von Ausführungsterminen für eine kontinuierliche Testausführung

Sie können Ausführungstermine für Ihre Projekte planen, um alle Tests täglich um eine bestimmte Zeit auszuführen.
Anmerkung: Wenn Sie Silk Central Connect in einer vollen Silk Central-Umgebung verwenden, können Sie stattdessen die erweiterte Ausführungstermin-Planung in Ausführungsplanung > Detailansicht > Ausführungstermin verwenden
.
  1. Klicken Sie im Silk Central Connect-Panel auf den Namen des Projekts, für welches Sie eine tägliche Ausführung planen möchten.
  2. Klicken Sie auf der Übersichtsseite des Projekts auf Zeitpunkt der täglichen Ausführung.
  3. Geben Sie den Zeitpunkt der täglichen Ausführung auf dem Dialog Zeitpunkt der täglichen Ausführung an.

  4. Wählen Sie von den verfügbaren Konfigurationen die aus, auf denen die Tests ausgeführt werden sollen. Falls Sie die Tests in diesem Projekt schon einmal ausgeführt haben, sind die Konfigurationen der letzten Testausführung vorgewählt. Falls sie noch keine Tests ausgeführt haben, sind alle Konfigurationen vorgewählt.
  5. Klicken Sie auf Speichern.
Alle Tests im Projekt werden auf den gewählten Konfigurationen zur angegebenen Zeit täglich ausgeführt. Der Ausführungstermin wird auf der Übersichtsseite des Projekts angezeigt. Der Ausführungstermin kann über die Entfernen-Schaltfläche gelöscht werden.
Übergeordnetes Thema: Silk Central Connect


Häufig gestellte Fragen

Dieser Abschnitt enthält Antworten zu häufig gestellten Fragen bezüglich Silk Central Connect.

  • Warum scheitern meine Silk4J Tests?
    Aktualisieren Sie Silk Central Connect und starten Sie Eclipse erneut, um sicherzustellen, dass die Verbindung zwischen Silk Central Connect und Silk4J funktioniert.
Übergeordnetes Thema: Silk Central Connect


Warum scheitern meine Silk4J Tests?

Sollte die Ausführung von Silk4J Tests aus Silk Central Connect nicht funktionieren, ist vermutlich die Verbindung zwischen Silk Central Connect und Silk4J unterbrochen. Probieren Sie folgendes, um die Verbindung wieder herzustellen: Falls Silk4J vor Silk Central Connect installiert wurde, starten Sie Eclipse oder den Open Agent erneut.

Übergeordnetes Thema: Häufig gestellte Fragen


Berechtigungen für Dashboard-Panel

Um Inhalte eines bestimmten Dashboard-Panels anzuzeigen oder zu bearbeiten, benötigen Sie folgende Berechtigungen:
Panel | Benötigte Berechtigung
Zugewiesene Fehler | Anzeigen von Tests und Ausführungen.
Benutzerdefinierte Information | Verwalten von Projekten ist zum Bearbeiten erforderlich. Für die Anzeige sind keine Berechtigungen nötig.
Einführung | Keine Berechtigung erforderlich.
Fehler-Lebenszyklus | Anzeigen von Projekteinstellungen.
Gefundene Fehler pro Tester | Anzeigen von Tests und Ausführungen.
Mir zugewiesene manuelle Tests | Ausführen von Tests.
Geplante und tatsächliche Ausführungszeit | Anzeigen von Testzyklen und Konfigurationen.
Qualitätsziel-Fortschritt | Anzeigen von Qualitätszielen.
Berichts-Abonnement | Keine Berechtigung erforderlich.
Status der Anforderungsabdeckung | Anzeigen von Anforderungen.
Silk Central Connect | Anzeigen von Tests und Ausführungen erfordert um Inhalte im Panel anzuzeigen. Weitere Berechtigung erfordert um auf andere Bereiche von Silk Central aus dem Panel hinaus zuzugreifen.
Silk Performer-Leistungstrends | Anzeigen von Tests und Ausführungen
Status der derzeit laufenden manuellen Tests | Anzeigen von Tests und Ausführungen
Testbook | Keine Berechtigung erforderlich.
Testzyklus-Fortschritt | Anzeigen von Testzyklen und Konfigurationen.
Testzyklus Ergebnis-Zusammenfassung | Anzeigen von Testzyklen und Konfigurationen.
Testzyklus-Zeitverlauf | Anzeigen von Testzyklen und Konfigurationen.
Testfortschritt über Testzyklen | Anzeigen von Testzyklen und Konfigurationen.
Volatile Tests | Anzeigen von Tests und Ausführungen.
Übergeordnetes Thema: Dashboard
Übergeordnetes Thema: Definitionen von Berechtigungen


Hinzufügen eines Berichts zu einem Dashboard-Panel

Das Berichts-Abonnement-Panel auf Ihrem Dashboard ermöglicht Ihnen die Anzeige von jedem verfügbaren Bericht im Bereich Berichte. Erstellen und konfigurieren Sie zuerst Ihren Bericht, und fügen Sie dann das Panel Ihrem Dashboard hinzu.
  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Abonnements.
  4. Klicken Sie auf Abonnement hinzufügen. Der Dialog Abonnement bearbeiten wird geöffnet.
  5. Geben Sie dem Abonnement im Feld Name einen Namen.
  6. Klicken Sie auf Parameter bearbeiten, um die Parameter des Abonnements zu ändern. Der Dialog Parameter bearbeiten wird geöffnet. Ändern Sie den Wert, und klicken Sie auf OK.
  7. Wählen Sie einen Ausführungstermin aus der Liste Ausführungstermin aus. Ist der gewünschte Ausführungstermin nicht vorhanden, können Sie diesen erstellen. Sie können auch keinen Ausführungstermin auswählen, z.B. für Abonnements die nur aufgrund von Testausführungsergebnissen ausgelöst werden.
  8. Klicken Sie auf Für Dashboard und externen Zugriff zur Verfügung stellen, um den Bericht einem Dashboard-Panel zur Verfügung zu stellen.
  9. Klicken Sie auf OK. Das neue Abonnement wird in der Liste Abonnements aufgeführt.
  10. Klicken Sie im Menü auf Startseite > Mein Dashboard.
  11. Klicken Sie oben links auf Panel hinzufügen. Das Dialogfeld Panel hinzufügen wird angezeigt. Darin sind die verfügbaren Paneltypen aufgeführt und kurz beschrieben.
  12. Wählen Sie Berichts-Abonnement. Im Dialog Panel konfigurieren werden alle verfügbaren Berichts-Abonnements angezeigt.
  13. Wählen Sie ein Berichts-Abonnement in der Liste aus, und klicken Sie auf OK. Das Panel wird dem Dashboard hinzugefügt.
Übergeordnetes Thema: Dashboard
Übergeordnetes Thema: Berichtsabonnements


Browsereinstellungen

Um die Funktionalität und Leistungsfähigkeit von Silk Central zu optimieren, passen Sie die folgenden Einstellungen in Ihrem Browser an:

  • Hierfür muss der Cache des Browsers aktiviert sein.
  • Wenn Sie über den Browser nicht auf Silk Central zugreifen können, fügen Sie im Browser den Silk Central-Server zur Liste der vertrauenswürdigen Websites hinzu.

In den Versionshinweisen finden Sie eine Liste der unterstützten Browser. Klicken Sie im Menü auf Hilfe > Dokumentation. Klicken Sie auf Silk Central 18.5 Versionshinweise.

Übergeordnetes Thema: Benutzeroberfläche


An- und Abmelden

Hier finden Sie Anleitungen zum An- und Abmelden bei Silk Central.

  • Anmelden bei Silk Central
    Hier wird beschrieben, wie Sie sich bei der Silk Central-Installation mit Ihren Benutzerdaten anmelden.
  • Abmelden von Silk Central
    Beschreibt, wie Sie sich von Silk Central abmelden.
Übergeordnetes Thema: Benutzeroberfläche
Zugehörige Konzepte
LDAP-Authentifizierung


Anmelden bei Silk Central

So melden Sie sich bei Silk Central an:

  1. Navigieren Sie zur URL Ihrer Silk Central-Installation.
  2. Geben Sie auf der Silk Central-Anmeldeseite Ihren Benutzernamen im Format <Mandant>\<Benutzername> und Ihr Kennwort ein. Wenn Sie sich bei Silk Central mit den Daten eines Benutzers des Standard-Mandanten anmelden, brauchen Sie den Mandantennamen nicht einzugeben. Geben Sie nur den Benutzernamen ein.

    Melden Sie sich mit den folgenden Standard-Anmeldedaten als Super User an:

    • Benutzername: admin
    • Kennwort: admin
  3. Wenn Sie das Kontrollkästchen Benutzerdaten merken aktivieren, bleiben Sie angemeldet, bis Sie die Registerkarte im Browser schließen. Wenn Sie das nächste Mal auf Silk Central zugreifen, sind Sie automatisch angemeldet.
  4. Klicken Sie auf Anmelden.
Sie gelangen direkt zu Ihrem persönlichen Dashboard. Klicken Sie oben auf der Seite Dashboard auf Setzen Sie Ihre Arbeit im zuletzt verwendeten Bereich fort, um umgehend dort zu beginnen, wo Sie zuletzt aufgehört haben.
Übergeordnetes Thema: An- und Abmelden
Zugehörige Konzepte
Anmeldeoptionen
Super User


Abmelden von Silk Central

So melden Sie sich von Silk Central ab:

  1. Navigieren Sie im Menü zu Benutzer:<Benutzername>.
  2. Klicken Sie auf Abmelden.
Übergeordnetes Thema: An- und Abmelden


Schnellstartaufgaben

Schnellstartaufgaben geben einen Überblick über die Aufgaben, die Sie wahrscheinlich am häufigsten mit Silk Central durchführen werden. Diese Aufgaben führen Sie Schritt für Schritt durch die wichtigsten Funktionen von Silk Central. Detaillierte Informationen finden Sie in den entsprechenden Bereichen in dieser Hilfe: Anforderungen, Tests, Ausführungsplanung und Fehlerverfolgung und Ergebnisanalyse.

  • Konfigurieren von benötigten Komponenten – Schnellstartaufgabe
    Bevor sie mit dem Aufbau Ihres Test-Frameworks beginnen können, müssen Sie zumindest ein Projekt und ein Produkt konfigurieren und, wenn Sie automatisierte Tests erstellen möchten, auch ein Versionsverwaltungsprofil.
  • Definieren von Anforderungen – Schnellstartaufgabe
    Verwalten Sie Ihre Anforderungen, so dass Sie sie Tests zuordnen können, um zu messen wie gut Ihre Software die erstellten Anforderungen abdeckt. Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren.
  • Entwerfen von Tests – Schnellstartaufgabe
    Entwerfen Sie Ihre Tests so, dass alle zugehörigen Funktionen mit sinnvollen Tests abgedeckt werden.
  • Ausführungsplanung und Ausführen von Tests - Schnellstartaufgabe
    Planen Sie die Testausführung und führen Sie Ihre Tests aus, um die Testdaten zu erhalten die Sie brauchen.
  • Verfolgen und Analysieren von Testergebnissen – Schnellstartaufgabe
    Testergebnisse können auf verschiedene Arten in Silk Central analysiert werden, je nachdem welche Testtypen Sie ausführen und welche Informationen Sie genau benötigen.
Übergeordnetes Thema: Erste Schritte


Konfigurieren von benötigten Komponenten – Schnellstartaufgabe

Bevor sie mit dem Aufbau Ihres Test-Frameworks beginnen können, müssen Sie zumindest ein Projekt und ein Produkt konfigurieren und, wenn Sie automatisierte Tests erstellen möchten, auch ein Versionsverwaltungsprofil. Sie können auch weitere Einstellungen konfigurieren, wie z.B. Filter, Eigenschaften, Attribute, usw. Sie benötigen SuperUser-, Administrator- oder Projektmanager-Berechtigungen um diese Aufgaben ausführen zu können.

Um die benötigten Komponenten zu konfigurieren müssen Sie folgende Aufgaben ausführen:

  1. Hinzufügen von Projekten
    Silk Central verwaltet Anforderungen, Tests, deren Ausführungen und Ergebnisse im Kontext eines Projekts. Deshalb ist die erste Aktivität die Erstellung eines Projekts.
  2. Hinzufügen von Produkten
    Silk Central speichert die Ergebnisse von Testausführungen im Kontext von Versionen und Builds eines bestimmten Produkts. Deshalb mus zuerst ein Produkt definiert werden, bevor Tests erstellt werden können.
  3. Konfigurieren von Versionsverwaltungsprofilen
    Für automatisiert Tests ist ein Versionsverwaltungsprofil eine weitere Voraussetzung. Automatisierte Tests in Silk Central repräsentieren eigentlich Testskripts in einem Versionsverwaltungssystem, auf die über Versionsverwaltungsprofile zugegriffen wird.
Übergeordnetes Thema: Schnellstartaufgaben


Hinzufügen von Projekten

Silk Central verwaltet Anforderungen, Tests, deren Ausführungen und Ergebnisse im Kontext eines Projekts. Deshalb ist die erste Aktivität die Erstellung eines Projekts.

So erstellen Sie ein Projekt:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie auf Neues Projekt. Die Seite Projekteinstellungen wird angezeigt.
  3. Geben Sie einen Projektnamen und eine Beschreibung ein.
  4. Wählen Sie den Projektverantwortlichen aus.
  5. Optional: Geben Sie für Ihr Projekt Tags ein. Wenn Sie viele Projekte haben, können Ihnen Projekt-Tags dabei helfen, diese zu filtern, indem Sie die Spalte Tags auf der Seite Projektliste verwenden.
  6. Optional: Um ein Projekt basierend auf der Vorlage für agile Projekte zu erstellen, wählen Sie im Listenfeld Projektvorlage den Eintrag Vorlage für agile Projekte aus.
  7. Klicken Sie auf Neues Projekt initialisieren oder Existierendes Projekt verwenden, um das Projekt als Issue Manager zu initialisieren. Weitere Informationen finden Sie im Abschnitt Initialisierung von Projekten als Issue Manager-Projekte.
  8. Geben Sie im Bereich Gemeinsam verwendbare Tests an, ob dies ein Repository-Projekt ist oder nicht. Wählen Sie eine der folgenden Optionen aus:
    • Keine gemeinsam verwendbaren Tests: Dieses Projekt verwendet keine Tests von anderen Projekten und seine eigenen Tests können auch nicht von anderen Projekten verwendet werden.
    • Stellt gemeinsam verwendbare Tests zur Verfügung: Dieses Projekt ist als Repository-Projekt konfiguriert, so dass andere Projekte die Tests dieses Projekts verwenden können.
    • Verwendet Tests von: Wählen Sie das Repository-Projekt aus, von dem gemeinsam verwendbare Tests verwendet werden.
  9. Im Bereich Gruppen werden verfügbare und zugewiesene Gruppen angezeigt. Weisen Sie die Gruppen je nach Bedarf zu. Mit Strg+Klick bzw. Umschalt+Klick können Sie mehrere Gruppen auswählen. Durch Klicken auf LDAP-Gruppen importieren können auch Gruppen von LDAP-Servern importiert werden. Weitere Informationen finden Sie unter Gruppen von LDAP-Servern importieren. Wenn keine Gruppen vorhanden ist, können Sie zunächst Gruppen erstellen und sie später dem Projekt zuordnen. Sie können die Zuordnung von Gruppen zum Projekt auch auf der Seite Gruppeneinstellungen vornehmen. Die Berechtigungen hängen von den Benutzerrollen ab. Weitere Informationen zu Benutzerberechtigungen finden Sie unter Benutzerrollen und Berechtigungen.
  10. Im Bereich Servergruppen werden verfügbare und zugewiesene Servergruppen angezeigt. Weisen Sie die Servergruppen je nach Bedarf zu. Mit Strg+Klick bzw. Umschalt+Klick können Sie mehrere Servergruppen auswählen. Wenn keine Servergruppe vorhanden ist, können Sie zuerst eine Servergruppe erstellen und sie später dem Projekt zuordnen. Sie können auch auf der Seite Einstellungen der Servergruppe dem Projekt eine Servergruppe zuordnen. Weitere Informationen finden Sie unter Verwalten von Servergruppen.
  11. Klicken Sie auf Speichern, um Ihre Einstellungen zu speichern. Sie gelangen zurück zur Seite Projektliste, auf der das neue Projekt jetzt angezeigt wird.
Übergeordnetes Thema: Konfigurieren von benötigten Komponenten – Schnellstartaufgabe
Nächstes Thema: Hinzufügen von Produkten


Hinzufügen von Produkten

Silk Central speichert die Ergebnisse von Testausführungen im Kontext von Versionen und Builds eines bestimmten Produkts. Deshalb mus zuerst ein Produkt definiert werden, bevor Tests erstellt werden können.

So fügen Sie ein neues Produkt hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf Neues Produkt. Der Dialog Neues Produkt wird geöffnet.
  4. Geben Sie einen Namen für das neue Produkt in das Feld Name ein.
  5. Geben Sie im Feld Beschreibung eine Beschreibung für das Produkt ein.
  6. Aktivieren Sie das Kontrollkästchen Aktiv, damit dieses Produkt für die Zuordnung zu Tests verfügbar ist.
  7. Klicken Sie auf OK, um das Produkt zu speichern.
    Anmerkung: Wird ein neues Produkt erstellt, erzeugt Silk Central automatisch eine neue Standardversion 1.0 und einen neuen Standard-Build 1 für dieses neue Produkt.
Übergeordnetes Thema: Konfigurieren von benötigten Komponenten – Schnellstartaufgabe
Vorheriges Thema: Hinzufügen von Projekten
Nächstes Thema: Konfigurieren von Versionsverwaltungsprofilen


Konfigurieren von Versionsverwaltungsprofilen

Für automatisiert Tests ist ein Versionsverwaltungsprofil eine weitere Voraussetzung. Automatisierte Tests in Silk Central repräsentieren eigentlich Testskripts in einem Versionsverwaltungssystem, auf die über Versionsverwaltungsprofile zugegriffen wird.
Weitere Informationen über die Konfiguration von Versionsverwaltungsprofilen finden Sie unter Versionsverwaltungsprofile.
Übergeordnetes Thema: Konfigurieren von benötigten Komponenten – Schnellstartaufgabe
Vorheriges Thema: Hinzufügen von Produkten


Definieren von Anforderungen – Schnellstartaufgabe

Verwalten Sie Ihre Anforderungen, so dass Sie sie Tests zuordnen können, um zu messen wie gut Ihre Software die erstellten Anforderungen abdeckt. Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren.

Um Anforderungen zu verwalten, müssen Sie einige oder alle der folgenden Schritte durchführen:

  1. Erstellen von Anforderungen
    Verbinden Sie Ihre Anforderungen und Tests, um messen zu können, wie gut Ihre Software die definierten Anforderungen erfüllt.
  2. Tests aus Anforderungen erzeugen
    Sie können Tests direkt aus der Anforderungshierarchie generieren und bestimmten Anforderungen Tests zuordnen. Die Hierarchie Anforderungen dient als Vorlage für die Testordner und Teststrukturen der neuen Hierarchie Tests.
  3. Externe Anforderungsverwaltungstools integrieren
    Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren.
Übergeordnetes Thema: Schnellstartaufgaben


Erstellen von Anforderungen

Verbinden Sie Ihre Anforderungen und Tests, um messen zu können, wie gut Ihre Software die definierten Anforderungen erfüllt.

So erstellen Sie eine neue Anforderung:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Hierarchie Anforderungen eine Anforderung oder den Stammknoten aus.
  3. Klicken Sie in der Symbolleiste auf [image] (Neue Anforderung) um eine neue Anforderung auf derselben hierarchischen Stufe zu erstellen, oder auf [image] (Neue untergeordnete Anforderung) um sie eine Stufe unterhalb der ausgewählten Anforderung zu erstellen. Das Dialogfeld Neue Anforderung wird angezeigt.
  4. Geben Sie einen Namen und eine Beschreibung für die Anforderung ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Optional: Deaktivieren Sie die Kontrollkästchen Vom übergeordneten Element übernehmen. In diesem Fall übernimmt die untergeordnete Anforderung keine Eigenschaften der übergeordneten Anforderung. Standardmäßig sind alle Kontrollkästchen aktiviert.
    Anmerkung: In der Detailansicht auf der Seite Eigenschaften und in der Dokumentansicht sind übernommene Eigenschaften mit Sternchen (*) markiert.
  6. Wählen Sie die Priorität, das Risiko und den Geprüft-Status in den entsprechenden Listen aus.
  7. Wenn benutzerdefinierte Anforderungen definiert wurden, werden diese unterhalb der Liste Geprüft aufgeführt. Geben Sie in das entsprechende Textfeld die benutzerdefinierten Eigenschaftendaten ein, die für diese Anforderung verfolgt werden sollen. Dies ist für geerbte Eigenschaften deaktiviert. Nähere Informationen zum Erstellen, Bearbeiten und Löschen von benutzerdefinierten Anforderungseigenschaften finden Sie unter Benutzerdefinierte Anforderungseigenschaften.
  8. So schließen Sie die Erstellung einer neuen Anforderung ab:
    • Klicken Sie auf OK, um die Anforderung zu erstellen und das Dialogfeld zu schließen.
    • Klicken Sie auf OK und neue Anforderung, um die Anforderung zu erstellen, das Dialogfeld geöffnet zu lassen und Daten zu einer weiteren Anforderung einzugeben.
    • Klicken Sie auf OK und neue untergeordnete Anforderung, um die Anforderung zu erstellen, das Dialogfeld geöffnet zu lassen und Daten zu einer untergeordneten Anforderung einzugeben.
Übergeordnetes Thema: Definieren von Anforderungen – Schnellstartaufgabe
Nächstes Thema: Tests aus Anforderungen erzeugen


Tests aus Anforderungen erzeugen

Sie können Tests direkt aus der Anforderungshierarchie generieren und bestimmten Anforderungen Tests zuordnen. Die Hierarchie Anforderungen dient als Vorlage für die Testordner und Teststrukturen der neuen Hierarchie Tests.

So erzeugen Sie aus der Detailansicht einen neuen Test:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf die Anforderung oder den Projektknoten, die/der in einen Testplan umgewandelt werden soll, und wählen Sie Tests erzeugen aus. Das Dialogfeld Tests zu Anforderungen erzeugen wird angezeigt. In diesem Dialogfeld können Sie festlegen, ob die untergeordneten Knoten der ausgewählten Anforderungsunterhierarchie in Tests oder Ordner konvertiert und ob die Hierarchie in einem neuen Container oder einem vorhandenen Container erzeugt werden soll.
  3. Geben Sie einen Namen für den neuen Testcontainer in das Feld Name eingeben ein, und wählen Sie ein Produkt in der Liste Produkt auswählen aus, um den Container im aktiven Silk Central-Projekt zu erstellen. In der Liste Produkt auswählen werden die von einem Projektmanager konfigurierten Produkte angezeigt. Weitere Informationen finden Sie unter Verwalten von Produkten, oder wenden Sie sich an den Projektmanager.
  4. Wenn Sie ein Versionsverwaltungsprofil erstellt haben, wählen Sie das gewünschte Profil in der Liste Versionsverwaltungsprofil auswählen aus. Weitere Informationen zu Quellverwaltungsprofilen finden Sie unter Versionsverwaltungsprofile, oder wenden Sie sich an den Silk Central-Administrator.
  5. Wenn die untergeordneten Anforderungen der ausgewählten Anforderung in den Test aufgenommen werden sollen, aktivieren Sie das Kontrollkästchen Untergeordnete Anforderungen einbeziehen. Dieses Kontrollkästchen ist standardmäßig aktiviert.
  6. Wenn die neuen Tests automatisch den zugrunde liegenden Anforderungen zugeordnet werden sollen, aktivieren Sie das Kontrollkästchen Neu erzeugte Tests zu Anforderungen zuordnen. Wenn diese Option deaktiviert ist, müssen die Tests den Anforderungen manuell zugeordnet werden.
    Anmerkung: Diese Option ist nicht verfügbar, wenn Ordner aus Anforderungshierarchie erzeugen ausgewählt wird.
  7. Klicken Sie auf OK, um den Test zu erstellen. Der neue Test hat dieselbe Struktur wie die Anforderungshierarchie.
  8. Es wird eine Meldung angezeigt. Klicken Sie auf Ja, wenn der Test im Bereich Tests angezeigt werden soll. Wenn der Bereich Anforderungen geöffnet bleiben soll, klicken Sie auf Nein.
Übergeordnetes Thema: Definieren von Anforderungen – Schnellstartaufgabe
Vorheriges Thema: Erstellen von Anforderungen
Nächstes Thema: Externe Anforderungsverwaltungstools integrieren


Externe Anforderungsverwaltungstools integrieren

Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren.

Weitere Informationen über die Integration von externen Anforderungsverwaltungstools finden Sie unter Anforderungsverwaltungstools.

Übergeordnetes Thema: Definieren von Anforderungen – Schnellstartaufgabe
Vorheriges Thema: Tests aus Anforderungen erzeugen


Entwerfen von Tests – Schnellstartaufgabe

Entwerfen Sie Ihre Tests so, dass alle zugehörigen Funktionen mit sinnvollen Tests abgedeckt werden.

Um Tests zu entwerfen, müssen Sie einzelne oder alle der folgenden Schritte durchführen:

  1. Strukturieren Ihrer Testelemente
    Sowohl die Produkt- als auch die Versionsverwaltungsprofil-Informationen werden pro Container definiert, welcher somit die oberste Hierarchiestufe der Testelementstruktur ist.
  2. Erstellen von Tests
    Erstellen Sie einen Test um eine bestimmte Funktionalität Ihrer Software zu testen.
  3. Zuordnen von Anforderungen zu Tests
    Verbinden Sie Ihre Anforderungen und Tests, um messen zu können, wie gut Ihre Software die definierten Anforderungen erfüllt.
Übergeordnetes Thema: Schnellstartaufgaben


Strukturieren Ihrer Testelemente

Silk Central speichert die Ergebnisse von Testausführungen im Kontext von Versionen und Builds eines bestimmten Produkts. Deshalb mus zuerst ein Produkt definiert werden, bevor Tests erstellt werden können. Für automatisiert Tests ist ein Versionsverwaltungsprofil eine weitere Voraussetzung. Automatisierte Tests in Silk Central repräsentieren eigentlich Testskripts in einem Versionsverwaltungssystem, auf die über Versionsverwaltungsprofile zugegriffen wird. Sowohl die Produkt- als auch die Versionsverwaltungsprofil-Informationen werden pro Container definiert, welcher somit die oberste Hierarchiestufe der Testelementstruktur ist.

Zum Anfangen erstellen wir der Einfachheit halber einen einzelnen Container:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Stammknoten aus, zu dem Sie den neuen Container als Unterknoten hinzufügen möchten.
    Anmerkung: Container können nicht verschachtelt werden, aber sie können Unterordner enthalten.
  3. Klicken Sie in der Symbolleiste auf Neuer Container, oder klicken Sie mit der rechten Maustaste auf den Knoten, und wählen Sie Neuer Container.

    Sie können auch mit der rechten Maustaste auf die Knoten und dann auf Neuer Container klicken.

    Ein neuer Containerstammknoten wird zur Testhierarchie hinzugefügt, und der Dialog Neuer Container wird geöffnet.
  4. Geben Sie einen Namen und eine Beschreibung für den Container ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wählen Sie im Listenfeld Produkt ein vordefiniertes Produkt für den Container aus. Weitere Informationen zum Hinzufügen eines Produktprofils finden Sie unter Hinzufügen von Produkten.
  6. Wählen Sie in der Liste Versionsverwaltungsprofil ein vordefiniertes Versionsverwaltungsprofil aus. Wenn Sie nicht beabsichtigen, Testquellen für den Container auszuchecken (wenn Sie beispielsweise nur manuelle Tests haben), wählen Sie --- aus.
    Anmerkung: Die Silk Central-Ausführungsserver rufen die Quelldateien für die im Container enthaltenen Tests aus dem definierten Versionsverwaltungsprofil ab. In Abhängigkeit des in Ihrem Versionsverwaltungsprofil angegebenen Pfades, können Sie im Feld Stammknoten des Containers einen untergeordneten Knoten angeben.
  7. Optional: Aktivieren Sie das Kontrollkästchen Arbeitsordner vor dem Start der Testausführung leeren.

    Falls aktiviert, werden Dateien die in der Versionsverwaltung gelöscht wurden auch im Arbeitsordner gelöscht. Standardmäßig aktiviert.

  8. Klicken Sie auf Durchsuchen..., und wählen Sie den Standardstammpfad des Containers aus.
  9. Optional: Wenn Silk Central in Silk Performer integriert ist, können Sie das Benutzerdefinierte Datenverzeichnis und Benutzerdefinierte Include-Verzeichnis definieren. In Silk Performer ist das Include-Verzeichnis in das System-Include-Verzeichnis und ein Benutzerdefiniertes Include-Verzeichnis unterteilt. Das Datenverzeichnis ist in ein Systemdatenverzeichnis und ein Benutzerdefiniertes Datenverzeichnis aufgeteilt. Weitere Informationen hierzu finden Sie in der Dokumentation zu Silk Performer.
  10. Im Bereich Verborgene Testeigenschaften des Dialogs können Sie festlegen, welche Eigenschaftstypen auf der Seite Eigenschaften (und auf der Seite Eigenschaften aller im Container gespeicherten Ordner) angezeigt werden. Diese Einstellungen wirken sich nicht auf die Anzeige der einzelnen Tests aus.
  11. Klicken Sie auf Bearbeiten, um die Einstellungen für verborgene Testeigenschaften anzupassen. Der Dialog Verborgene Testeigenschaften wird geöffnet.
  12. Deaktivieren Sie die Kontrollkästchen aller Testtypen, für die Eigenschaften angezeigt werden sollen.
  13. Klicken Sie auf OK, um die Einstellungen zu speichern und den Dialog Verborgene Testeigenschaften zu schließen.
  14. Klicken Sie auf Speichern, um Ihre Einstellungen zu speichern.
Übergeordnetes Thema: Entwerfen von Tests – Schnellstartaufgabe
Nächstes Thema: Erstellen von Tests


Erstellen von Tests

Erstellen Sie einen Test um eine bestimmte Funktionalität Ihrer Software zu testen.
Silk Central unterstützt standardmäßig zahlreiche Testtypen. Unter Verwalten von Tests können Sie den zu erstellenden Testtyp auswählen, wo Sie dann den Anweisungen in den referenzierten Themen folgen können.
Übergeordnetes Thema: Entwerfen von Tests – Schnellstartaufgabe
Vorheriges Thema: Strukturieren Ihrer Testelemente
Nächstes Thema: Zuordnen von Anforderungen zu Tests


Zuordnen von Anforderungen zu Tests

Verbinden Sie Ihre Anforderungen und Tests, um messen zu können, wie gut Ihre Software die definierten Anforderungen erfüllt.
So ordnen Sie Anforderungen manuell Tests zu:
  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Test aus, den Sie Anforderungen zuordnen möchten.
  3. Klicken Sie auf die Registerkarte Zugeordnete Anforderungen.
    Anmerkung: Wenn Sie einen Anforderungsfilter erstellt haben, können Sie diesen in der Filterliste oberhalb der Hierarchie Anforderungen auswählen. Um einen neuen Anforderungsfilter zu erstellen, klicken Sie im Menü auf Anforderungen > Detailansicht, und klicken Sie in der Symbolleiste auf Neuer Filter.
    Die Anforderungen, die Sie zuordnen können, werden in der Hierarchie Anforderungen angezeigt.
  4. Wählen Sie die Anforderungen aus, die Sie zuordnen möchten. Sie können mit den Tasten Strg und Umschalt entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Anforderungen auswählen.
  5. Klicken sie auf Gefilterte Anforderungen zuweisen um alle gefilterten Anforderungen dem ausgewählten Test zuzuordnen. Sie können Ihre Auswahl auch in den Bereich Zugeordnete Anforderungen ziehen und ablegen, oder neben einer Anforderung auf Zuordnen klicken. Das Zuordnen mehrerer gefilterter Anforderungen ist nur möglich, wenn ein Filter ausgewählt ist und Sie die Berechtigungen Verwalten von Anforderungen oder Tests und Ausführungen Verwalten besitzen.
    Anmerkung: Wenn im Dialogfeld Testplan aus Anforderungen erzeugen die Option Neu erzeugte Tests zu Anforderungen zuordnen aktiviert ist, werden die neuen Tests automatisch den entsprechenden Anforderungen zugeordnet. Dies ist die Standardeinstellung.
Übergeordnetes Thema: Entwerfen von Tests – Schnellstartaufgabe
Vorheriges Thema: Erstellen von Tests


Ausführungsplanung und Ausführen von Tests - Schnellstartaufgabe

Um die Testausführung zu planen und Ihre Tests auszuführen, müssen Sie einzelne oder alle der folgenden Schritte durchführen:

  • Planung und Ausführung automatisierter Tests
    Sie können eine Testsuite erstellen, um verwandte Tests zusammen auszuführen.
  • Planung und Ausführung manueller Tests
    In dieser Anleitung sind die Funktionen der Manuellen Ausführungsplanung anhand eines Beispiels dargestellt.
Übergeordnetes Thema: Schnellstartaufgaben


Planung und Ausführung automatisierter Tests

Sie können eine Testsuite erstellen, um verwandte Tests zusammen auszuführen.
  1. Erstellen von Testsuiten
    Sie können eine Testsuite erstellen, um verwandte Tests zusammen auszuführen.
  2. Manuelles Zuordnen von Tests zu Testsuiten
    Weisen Sie einen Test manuell einer Testsuite zu, damit dieser darin enthalten ist.
  3. Starten von Testsuiten
    Ausführen einzelner Testsuiten unabhängig von einem Ausführungstermin.
Übergeordnetes Thema: Ausführungsplanung und Ausführen von Tests - Schnellstartaufgabe


Erstellen von Testsuiten

Sie können eine Testsuite erstellen, um verwandte Tests zusammen auszuführen.
  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Hierarchie Testsuiten einen Ordner oder den Projektknoten aus.
  3. Klicken sie auf Neue untergeordnete Testsuite (Neue untergeordnete Testsuite) in der Symbolleiste, oder klicken Sie mit der rechten Maustaste auf den Ordner, die Testsuite oder den Knoten. Klicken Sie anschließend auf Neue untergeordnete Testsuite. Das Dialogfeld Neue Testsuite wird angezeigt.
  4. Geben Sie einen Namen und eine Beschreibung für die neue Testsuite ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wählen Sie in der Liste Container den gewünschten Container aus.
    Anmerkung: Sie können jeder Testsuite jeweils nur einen Container zuordnen. Es können ausschließlich Tests aus diesem Container ausgeführten werden.
    Die neueste Version bzw. der neueste Build, die für das Produkt definiert sind, zu dem der Container gehört, werden automatisch in die Listen Version und Build eingefügt.
  6. Wählen Sie aus den Listen Version und Build des Produkts aus. Diese Werte werden verwendet, wenn ein neuer Lauf der Testsuite gestartet wird. Sie können auch das Kontrollkästchen Aus Build-Informationsdatei lesen aktivieren. In diesem Fall werden die Version und der Build zu Beginn jedes Testlaufs aus der Build-Informationsdatei gelesen. Wenn auf dem Ausführungsserver eine Build-Informationsdatei vorhanden ist, wird diese standardmäßig für den Testlauf verwendet, und die Einstellungen im Dialog Neue Testsuite werden überschrieben.
  7. Wählen Sie in der Liste die Priorität der Testsuite aus. Bei automatisierten Testsuiten, wenn sich mehr als eine Testsuite in der Warteschlange befindet, aber nur ein Ausführungsserver verfügbar ist, werden die Testsuiten nach Priorität ausgeführt. Das Gleiche gilt auch, wenn zwar ein Ausführungsserver verfügbar ist, aber mehrere Testsuiten ein nicht verfügbares Mobilgerät benötigen.
  8. Im Feld Label der Versionsverwaltung können Sie optional eine vorhergehende Version für die Testsuite angeben. Die Bezeichnung muss auf eine Version im Versionsverwaltungssystem verweisen, der dieser Container zugeordnet ist. Wenn Sie das Feld leer lassen, wird die neueste Version der Testsuite abgerufen. Die Eigenschaft Label der Versionsverwaltung ist nur verfügbar, wenn der zugeordnete Container ein Versionsverwaltungsprofil verwendet, das die Versionsverwaltung unterstützt. Stellen Sie sicher, dass auf den Ausführungsservern ausreichend freier Speicherplatz verfügbar ist, wenn Sie mit mehreren Quelldateiversionen arbeiten. Jede Version wird auf jedem Ausführungsserver in einem eigenen Ordner gespeichert.
    Tipp: Wenn Sie für eine bestimmte Testsuite einen bestimmten Branch aus dem Repository auschecken möchten, geben Sie den Namen des Branches im Feld Label der Versionsverwaltung in der entsprechenden Testsuite ein.
  9. Klicken Sie auf OK, um die Testsuitehierarchie mit der neuen Testsuite zu aktualisieren.
Übergeordnetes Thema: Planung und Ausführung automatisierter Tests
Nächstes Thema: Manuelles Zuordnen von Tests zu Testsuiten


Manuelles Zuordnen von Tests zu Testsuiten

Weisen Sie einen Test manuell einer Testsuite zu, damit dieser darin enthalten ist.
  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite aus, der die ausgewählten Tests zugeordnet werden sollen.
  3. Klicken Sie auf die Registerkarte Zugeordnete Tests.
  4. Klicken Sie auf die Option Manuelle Zuweisung. Die Tests des Containers der ausgewählten Testsuite werden in der Testhierarchie angezeigt. Wenn Sie einen Testfilter erstellt haben, können Sie diesen oben in der Testhierarchie in der Filterliste auswählen. Wenn Sie einen neuen Testfilter erstellten möchten, klicken Sie im Menü auf Tests und anschließend in der Symbolleiste auf [image] (Neuer Filter).
  5. Wählen Sie die Tests aus, die Sie zuordnen möchten. Sie können mit den Tasten Strg und Umschalt entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Tests auswählen.
  6. Ziehen Sie Ihre Auswahl in den Bereich Zugeordnete Tests und legen Sie sie dort ab, oder klicken Sie links von irgendeinem Test auf Zuordnen. Wenn Sie einen Ordners oder Container der obersten Ebene zuordnen, werden alle darin gespeicherten untergeordneten Tests zugeordnet.
    Tipp: Klicken Sie mit der rechten Maustaste auf einen Knoten, um ihn zu erweitern oder auszublenden.
Übergeordnetes Thema: Planung und Ausführung automatisierter Tests
Vorheriges Thema: Erstellen von Testsuiten
Nächstes Thema: Starten von Testsuiten


Starten von Testsuiten

Ausführen einzelner Testsuiten unabhängig von einem Ausführungstermin.
  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie das Projekt, die Testsuite, den Ordner oder die Konfigurationssuite aus, oder verwenden Sie Strg+Klick oder Umschalt+Klick um mehrere Elemente auszuwählen.
  3. Klicken Sie in der Symbolleiste auf [image] (Ausführen). Dies ist für Testzyklen, Testsuiten innerhalb von Testzyklen, und nicht zugeordnete Tests deaktiviert. Das Dialogfeld Ausführen wird angezeigt.
  4. Legen Sie im Dialog Ausführen fest, welche Tests Sie ausführen möchten.
  5. Aktivieren Sie das Kontrollkästchen Gehe zu Aktivitäten-Seite, um nach dem Definieren der auszuführenden Tests zur Seite Aktivitäten zu wechseln.
Übergeordnetes Thema: Planung und Ausführung automatisierter Tests
Vorheriges Thema: Manuelles Zuordnen von Tests zu Testsuiten


Planung und Ausführung manueller Tests

In dieser Anleitung sind die Funktionen der Manuellen Ausführungsplanung anhand eines Beispiels dargestellt. Folgendes wird in diesem Beispiel vorausgesetzt:

  • Die Anforderungen sind gemäß einer Risk-Eigenschaft vollständig dokumentiert und kategorisiert.
  • 575 manuelle Tests sind vollständig dokumentiert, Anforderungen zugewiesen und gemäß einem Importance-Attribut kategorisiert, das die Notwendigkeit der Ausführung eines bestimmten Tests definiert.
  • Qualitätsziele, auch Projektausgangskriterien genannt, wurden basierend auf der Anforderungseigenschaft Risk und dem Testattribut Importance definiert. Diese Qualitätsziele bestimmen die erforderlichen Testebenen.
  • Es sind nur die Tests zu planen, die die Qualitätsziele am besten erfüllen.
  1. Übersicht
    Hier erhalten Sie einen Überblick über die Bereiche der Seite Manuelle Ausführungsplanung.
  2. Erstellen eines Testzyklus
    Hier wird beschrieben, wie Sie einen Testzyklus erstellen, indem Sie ein Startdatum, ein Enddatum und eine Kapazität angeben.
  3. Hinzufügen von manuellen Testern
    Hier wird beschrieben, wie Sie manuelle Tester zum Testzyklus hinzufügen und die Kapazität definieren.
  4. Auswählen von Tests und Zeitplanung
    Hier wird beschrieben, wie Sie Tests filtern, sortieren und gruppieren und dem Testzyklus zuordnen.
  5. Zuordnen von Tests zu manuellen Testern
    Hier wird beschrieben, wie Sie die Tests eines Testzyklus den manuellen Testern zuordnen.
  6. Ausführen von manuellen Tests
    Nachdem Sie nun Ihre Testsuite gestartet haben, können Sie Ihre manuellen Tests mit dem Fenster Manuelles Testen ausführen.
Übergeordnetes Thema: Ausführungsplanung und Ausführen von Tests - Schnellstartaufgabe


Übersicht

Die Seite Manuelle Ausführungsplanung besteht aus vier Bereichen, die auf zwei Bildschirme aufgeteilt sind. Im ersten Bildschirm, Testauswahl, können Sie die Tests für einen Testzyklus auswählen und zeitlich planen. Im zweiten Bildschirm, Testzuordnung, können Sie die Tests des ausgewählten Testzyklus den Testern zur Ausführung zuordnen.

Der Bildschirm Testauswahl ist in drei Bereiche unterteilt:

  • Links befindet sich der Abschnitt Filterkriterien. Mithilfe der Filterfunktion können Sie die hier angezeigten Tests auf die gewünschten begrenzen.
  • In der Mitte befindet sich der Abschnitt Relevante Tests. In dieser Liste werden alle verfügbaren Tests angezeigt. Wenn Sie einen Filter anwenden, werden nur die Tests angezeigt, die den Filterkriterien entsprechen.
  • Rechts befindet sich der Abschnitt Testzyklen. Hier können Sie Tests aus der mittleren Liste einem bestimmten Testzyklus zuordnen, also einem bestimmten Zeitraum.

Sie rufen den Bildschirm Testzuordnung auf, indem Sie oben rechts auf Testzuordnung >>> klicken. Dieser Bildschirm besteht aus zwei Bereichen:

  • Links befindet sich der Abschnitt Testzyklen. Dieser Bereich ist identisch mit dem im Bildschirm Testauswahl; er ist Teil beider Bildschirme.
  • Rechts befindet sich der Abschnitt Zugeordnete Tests. Diese Liste enthält die Tests, die dem aktuell ausgewählten Testzyklus hinzugefügt wurden. Hier können Sie die Tests aus der Liste in den Bereich Testzyklen ziehen und auf einem Tester ablegen.

Übergeordnetes Thema: Planung und Ausführung manueller Tests
Nächstes Thema: Erstellen eines Testzyklus


Erstellen eines Testzyklus

Als Erstes erstellen wir einen Testzyklus. Ein Testzyklus ist ein durch ein Start- und Enddatum definierter Zeitraum, für den manuelle Tester festgelegt wurden. Wir benennen den Testzyklus Woche 21 - Team A.
  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung.
  2. Klicken Sie rechts im Bereich Testzyklen auf Neuer Testzyklus. Das Dialogfeld Neuer Testzyklus wird angezeigt.
  3. Geben Sie den Namen des Testzyklus an – in unserem Fall Woche 21 – Team A.
  4. Wahlweise können Sie auch eine Beschreibung eingeben.
  5. Klicken Sie auf [image] neben Startdatum, um den Beginn des Testzyklus festzulegen.
  6. Klicken Sie auf [image] neben Enddatum, um das Ende des Testzyklus festzulegen.
  7. Geben Sie im Format hh:mm die Zeit an, die für diesen Testzyklus festgelegt wird (Kapazität). In unserem Beispiel ist dies 35:00.
  8. Klicken Sie auf OK.
Der Testzyklus wird nun im Bereich Testzyklen angezeigt. Es ist ersichtlich, dass zurzeit keine Tester zugeordnet sind. Als Nächstes ordnen wir dem Testzyklus Tester zu.

Übergeordnetes Thema: Planung und Ausführung manueller Tests
Vorheriges Thema: Übersicht
Nächstes Thema: Hinzufügen von manuellen Testern


Hinzufügen von manuellen Testern

Als Nächstes fügen wir unserem Testzyklus manuelle Tester hinzu. Außerdem definieren wir die Kapazität, die die einzelnen manuellen Tester für diesen Testzyklus haben.
  1. Klicken Sie in der Kopfzeile des Testzyklus Woche 21 - Team A auf ...Zugewiesene Tester bearbeiten. Das Dialogfeld Zugewiesene Tester bearbeiten wird angezeigt.
  2. Klicken Sie auf Manuelle Tester zuordnen. Der Dialog Manuelle Tester zuordnen wird angezeigt.
  3. Wählen Sie eine Benutzergruppe aus der Liste Verfügbar aus.
  4. Wählen Sie aus der Benutzergruppe in der Liste Verfügbar einen oder mehrere Benutzer aus.
  5. Klicken Sie auf Hinzufügen oder Alle hinzufügen, um Benutzer in die Liste Ausgewählte aufzunehmen.
  6. Klicken Sie auf OK. Die Benutzer werden nun der Liste im Dialogfeld Zugewiesene Tester bearbeiten hinzugefügt.
  7. Geben Sie für jeden hinzugefügten Benutzer im Feld Kapazität die Kapazität für den Testzyklus an. Verwenden Sie dazu das Format hh:mm.
  8. Klicken Sie auf Schließen.
Der Testzyklus zeigt nun die verfügbaren Ressourcen an; sowohl für den gesamten Testzyklus als auch für die einzelnen manuellen Tester. In einem Burndown-Chart werden die zugewiesenen Tests dargestellt, die noch nicht durchgeführt wurden. Nachdem wir den Testzyklus erstellt und manuelle Tester hinzugefügt haben, können wir im nächsten Schritt festlegen, welche Tests durchgeführt werden müssen.

Übergeordnetes Thema: Planung und Ausführung manueller Tests
Vorheriges Thema: Erstellen eines Testzyklus
Nächstes Thema: Auswählen von Tests und Zeitplanung


Auswählen von Tests und Zeitplanung

In diesem Thema wird erläutert, wie Sie unserem Beispieltestzyklus Tests zuordnen. Angestrebt wird die Auswahl derjenigen Tests, die die definierten Qualitätsziele am besten abdecken. Eines der Qualitätsziele basiert auf dem Anforderungsrisiko. Normalerweise werden Elemente mit hohem Risiko zuerst getestet.
  1. Aktivieren Sie links im Bereich Filterkriterien unter Qualitätsziele das Kontrollkästchen Anforderungsrisiko. In der Liste Relevante Tests werden nun nur die wichtigsten Tests angezeigt.
  2. Öffnen Sie im Bereich Relevante Tests das Kontextmenü der Kopfzeile einer Spalte, um die Tests zu sortieren, zu filtern oder zu gruppieren. Auf diese Weise können Sie die zu planenden Tests leichter auswählen.
  3. Wählen Sie einen oder mehrere Tests aus, ziehen Sie sie rechts in den Bereich Testzyklen, und legen Sie sie auf unserem Testzyklus ab. Wenn Sie einem Testzyklus Tests hinzufügen, wird die Anzeige der bereits verwendeten Ressourcen aktualisiert. Wenn Sie den Mauszeiger über diese Anzeige bewegen, werden detaillierte Informationen zur Gesamtkapazität, geplanten Dauer und verbleibenden Zeit angezeigt.
  4. Nachdem Sie alle Tests mit kritischem Risiko geplant haben, planen Sie als Nächstes die Tests mit hohem Risiko. Planen Sie danach die Tests mit mittlerem Risiko usw.

Die unserem Testzyklus zugeordneten Tests werden nun in der Zeile Kein zugewiesener Tester angezeigt. Im nächsten Schritt weisen wir manuellen Testern Tests zu.

Übergeordnetes Thema: Planung und Ausführung manueller Tests
Vorheriges Thema: Hinzufügen von manuellen Testern
Nächstes Thema: Zuordnen von Tests zu manuellen Testern


Zuordnen von Tests zu manuellen Testern

Wir weisen jetzt die im Testzyklus enthaltenen Tests manuellen Testern zu.
  1. Klicken Sie rechts oben auf Testzuordnung >>>. Der Bildschirm Testzuordnung wird angezeigt.
  2. Klicken Sie links im Testzyklus im Bereich Testzyklen auf die Zeile Kein zugewiesener Tester. Daraufhin werden alle Tests, die keinem Tester zugeordnet sind, im Bereich Zugeordnete Tests auf der rechten Seite angezeigt.
  3. Wählen Sie einen oder mehrere Tests aus, ziehen Sie sie in den linken Bereich von Testzyklen, und legen Sie sie auf einem manuellen Tester ab. Wenn einem manuellen Tester Tests zugeordnet werden, wird die Ressourcenanzeige entsprechend aktualisiert. Wenn Sie den Mauszeiger über diese Anzeige bewegen, werden detaillierte Informationen zur Kapazität, eingeplanten Zeit und verbleibenden Zeit angezeigt.
  4. Nachdem Sie die Tests manuellen Testern zugeordnet haben, klicken Sie auf ...Testzyklus starten, um die Tests zu starten.

Sobald der Testzyklus gestartet wurde, werden die manuellen Tester per E-Mail darüber informiert, welche Tests ihnen zugeordnet wurden. Sie können Ihrem persönlichen Dashboard einen Eingangsordner hinzufügen (Mir zugewiesene manuelle Tests). Darin werden alle Ihnen zugewiesenen Tests aufgeführt.

Übergeordnetes Thema: Planung und Ausführung manueller Tests
Vorheriges Thema: Auswählen von Tests und Zeitplanung
Nächstes Thema: Ausführen von manuellen Tests


Ausführen von manuellen Tests

Nachdem Sie nun Ihre Testsuite gestartet haben, können Sie Ihre manuellen Tests mit dem Fenster Manuelles Testen ausführen.
Klicken Sie zum Öffnen des Fensters Manuelles Testen im Menü auf Startseite > Mein Dashboard und anschließend im Panel Mir zugewiesene manuelle Tests auf [image] (Manuellen Test fortsetzen). Wenn dieses Panel nicht auf Ihrem Dashboard angezeigt wird, müssen Sie es hinzufügen. Weitere Informationen zum Dashboard und zu Panels finden Sie unter Dashboard.

Das Fenster Manuelles Testen ist leicht zu bedienen. Möchten Sie dennoch weitere Informationen zu diesem Thema, so finden Sie diese unter Manuelles Testen.

Übergeordnetes Thema: Planung und Ausführung manueller Tests
Vorheriges Thema: Zuordnen von Tests zu manuellen Testern


Verfolgen und Analysieren von Testergebnissen – Schnellstartaufgabe

Testergebnisse können auf verschiedene Arten in Silk Central analysiert werden, je nachdem welche Testtypen Sie ausführen und welche Informationen Sie genau benötigen.
Weitere Informationen über die Möglichkeiten der Ergebnisanalyse in Silk Central, inklusive Berichte und die Fehler- und Aktivitätsverfolgung, finden Sie unter Fehlerverfolgung und Ergebnisanalyse.
  • Analysieren von Testergebnissen automatisierter Tests
    Analysieren Sie die Ergebnisse von Testsuiteläufen für eine erweiterte Ursachenanalyse, oder vergleichen Sie die Ergebnisse mehrerer verschiedener Testläufe, um die Veränderung von Teststatus zu veranschaulichen.
  • Analysieren von Testergebnissen manuellerTests
    Verwenden Sie die Ansicht Ergebnisse der manuellen Tests um eine übersichtliche Ergebnisanzeige von manuellen Tests zu erhalten. Hier werden auch Informationen wie zugewiesene Fehler und Anhänge angezeigt.
  • Dashboard-Panels
    Das Dashboard in Silk Central stellt Ihren persönlichen Ausgangspunkt dar. Sie können diesen Bereich anpassen, indem Sie verschiedene Panels hinzufügen und anordnen, die die für Ihre tägliche Arbeit benötigten Informationen enthalten.
  • Berichte
    Verwenden Sie die Berichtsfunktionalität von Silk Central um Ihre Testergebnisse zu analysieren.
Übergeordnetes Thema: Schnellstartaufgaben


Analysieren von Testergebnissen automatisierter Tests

Die Ansichten Testergebnisse und Testsuitelauf-Vergleich bieten eine übersichtliche Ergebnisanzeige mit der Möglichkeit, sich bis in unterste Details hineinzuklicken (drill-down). Hier werden auch Informationen wie Anhänge, Screenshots, Nachrichten und Stacktraces angezeigt. Dies ermöglicht eine schnelle Ursachenanalyse von fehlgeschlagenen Testläufen, vor allem weil Sie auch die Ergebnisse verschiedener Testsuiteläufe nebeneinander vergleichen können.

Sie könnten zum Beispiel folgende Aufgaben interessant finden:
  • Analysieren der Läufe aller Konfigurationen innerhalb einer Konfigurationssuite oder innerhalb Testsuiten welche Konfigurationen repräsentieren.
  • Vergleichen von Läufen derselben Testsuite, z.B. um herauszufinden ob sich irgendwelche Teststatus verändert haben.
  • Gleichzeitiges Anzeigen aller fehlgeschlagenen Tests einer Testsuite.

So analysieren Sie die Ergebnisse von automatisierten Testläufen:

  1. Wählen Sie eine oder mehrere Ausführungen in den Tabellen Testläufe im Bereich Ausführungen oder in Aktivitäten > Letzte Testausführungen aus.
  2. Klicken Sie auf das Symbol Ergebnisse automatisierter Tests anzeigen, um die Ergebnisse einer einzelnen Ausführung zu analysieren, oder klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Ergebnisse automatisierter Tests vergleichen, um mehrere Ausführungen miteinander zu vergleichen.
  3. Klicken Sie auf ein Symbol im oberen Bereich der Seite oder auf ein Statussymbol in der Tabelle um detaillierte Informationen einzusehen, wie z.B. Anhänge, Screenshots, Nachrichten und Stacktraces.
    Tipp: Verwenden Sie das Kontrollkästchen Nur fehlgeschlagene Tests anzeigen, um die Anzahl der angezeigten Ergebnisse einzuschränken.
Übergeordnetes Thema: Verfolgen und Analysieren von Testergebnissen – Schnellstartaufgabe


Analysieren von Testergebnissen manuellerTests

Verwenden Sie die Ansicht Ergebnisse der manuellen Tests um eine übersichtliche Ergebnisanzeige von manuellen Tests zu erhalten, sowohl für beendete als auch nicht-beendete Testläufe. Hier werden auch Informationen wie zugewiesene Fehler und Anhänge angezeigt. Die Information ist sofort verfügbar. Die Information kann auch im PDF-Format gedruckt oder heruntergeladen werden.

Die Ansicht Ergebnisse der manuellen Tests besteht aus der Hierarchieanzeige auf der linken Seite und der Detailanzeige auf der rechten Seite.. Der Inhalt der Hierarchieanzeige hängt davon ab, was Sie beim Öffnen der Testergebnisanzeige ausgewählt haben. Haben Sie z.B. einen Testzyklus ausgewählt, so werden alle zugeordneten Tester und deren Tests angezeigt. Die Auswahl eines bestimmten Knotens aktualisiert die Anzeige mit Information basierend auf der aktuellen Auswahl.

Um die Ansicht Ergebnisse der manuellen Tests zu öffnen, klicken sie auf das Symbol Ergebnisse manueller Tests anzeigen ( [image]). Diese Funktionalität steht praktisch überall zur Verfügung, wo manuelle Tests angezeigt werden. Dies beinhaltet die Manuelle Ausführungsplanung, Dashboard-Panele, die Aktivitäten-Seiten und die Testläufe Tabellen in den Bereichen Ausführungen und Tests.

Übergeordnetes Thema: Verfolgen und Analysieren von Testergebnissen – Schnellstartaufgabe


Dashboard-Panels

Das Dashboard in Silk Central stellt Ihren persönlichen Ausgangspunkt dar. Sie können diesen Bereich anpassen, indem Sie verschiedene Panels hinzufügen und anordnen, die die für Ihre tägliche Arbeit benötigten Informationen enthalten.

Weitere Informationen zu Dashboard-Panels finden Sie unter Dashboard.

Übergeordnetes Thema: Verfolgen und Analysieren von Testergebnissen – Schnellstartaufgabe


Berichte

Weitere Informationen zu Berichten finden Sie unter Berichte.

Übergeordnetes Thema: Verfolgen und Analysieren von Testergebnissen – Schnellstartaufgabe


Anforderungen

In diesem Abschnitt wird beschrieben, wie Anforderungen in Silk Central verwaltet werden.

Eine Anforderung ist ein Zustand oder eine Fähigkeit die ein Anwender mit einer bestimmten Aufgabe erledigen muss, die die zu testende Anwendung (AUT) erfüllen muss. Verbinden Sie Ihre Anforderungen und Tests, um messen zu können, wie gut Ihre Software die definierten Anforderungen erfüllt. Mehrere Tests können eine einzelne Anforderung abdecken, und mehrere Anforderungen können von einem einzelnen Test abgedeckt sein.Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren. Im Bereich Anforderungen können Sie während der Entwicklung die Systemanforderungen verwalten und steuern. Sie können Anforderungen erstellen, ändern oder löschen, Tests mit Anforderungen verknüpfen, die Änderungshistorie nachverfolgen oder Tests direkt aus Anforderungslisten generieren.

  • Konfigurieren von Anforderungseigenschaften und Integrationen
    Wenn Sie Ihre Anforderungen in Silk Central verwalten möchten, können sie Anforderungseigenschaften, Filter und Änderungsbenachrichtigungseinstellungen konfigurieren. Wenn Sie Ihre Anforderungen in einem anderen System verwalten möchten, können sie dieses mit Silk Central integrieren um gleichzeitig die Anforderungsverwaltungsfunktionalität von Silk Central nutzen zu können, wie z.B. die Anforderungs- und die Testabdeckung. Sie benötigen SuperUser-, Administrator- oder Projektmanager-Berechtigungen um diese Aufgaben ausführen zu können.
  • Verwalten von Anforderungen
    Erstellen oder bearbeiten Sie Anforderungen, um ein gemeinsames Einverständnis über technische und nicht-technische Anforderungen zwischen Kunde und Entwicklungsteam zu etablieren.
  • Konfigurieren von Anforderungseigenschaften
    Konfigurieren Sie Anforderungseigenschaften, Anhänge, Flags und die Abdeckung.
  • Zuordnen von Tests zu Anforderungen.
    Ordnen Sie Ihre Anforderungen Tests zu, um messen zu können wie gut Ihre Software die erstellten Anforderungen abdeckt.
  • Importieren von Anforderungen
    Hier wird beschrieben, wie Anforderungen aus Microsoft Word Excel importiert werden.
  • Anforderungsansichten
    Hier werden die verfügbaren Ansichten im Bereich Anforderungen erklärt.
Übergeordnetes Thema: Silk Central-Hilfe


Konfigurieren von Anforderungseigenschaften und Integrationen

Wenn Sie Ihre Anforderungen in Silk Central verwalten möchten, können sie Anforderungseigenschaften, Filter und Änderungsbenachrichtigungseinstellungen konfigurieren. Wenn Sie Ihre Anforderungen in einem anderen System verwalten möchten, können sie dieses mit Silk Central integrieren um gleichzeitig die Anforderungsverwaltungsfunktionalität von Silk Central nutzen zu können, wie z.B. die Anforderungs- und die Testabdeckung. Sie benötigen SuperUser-, Administrator- oder Projektmanager-Berechtigungen um diese Aufgaben ausführen zu können.
  • Anforderungseigenschaften
    Hier werden die verfügbaren Arten von Anforderungseigenschaften erläutert.
  • Integration von Anforderungsverwaltungssystemen
    Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren.
  • Filter
    Hier wird beschrieben, wie Filter zum Auffinden der relevanten Informationen bei gleichzeitigem Ausschluss von nicht benötigten Details verwendet werden.
  • Änderungsbenachrichtigung
    Hier wird beschrieben, wie Sie eine E-Mail-Benachrichtigung bei Änderungen von Anforderungen oder Tests von anderen Benutzern einrichten können.
Übergeordnetes Thema: Anforderungen


Anforderungseigenschaften

Im folgenden Abschnitt werden die beiden verfügbaren Arten von Anforderungseigenschaften beschrieben.

  • Anforderungseigenschaften (Seite)
    Auf dieser Seite werden die benutzerdefinierten Anforderungseigenschaften und die berechneten Eigenschaften, die für das aktive Projekt verfügbar sind, aufgelistet.
  • Berechnete Anforderungseigenschaften
    In diesem Abschnitt wird erläutert, wie man mit berechneten Anforderungseigenschaften arbeitet.
  • Benutzerdefinierte Anforderungseigenschaften
    Hier wird die Verwendung von benutzerdefinierten Eigenschaftenfeldern für alle Anforderungen in einem ausgewählten Projekt beschrieben.
Übergeordnetes Thema: Konfigurieren von Anforderungseigenschaften und Integrationen
Übergeordnetes Thema: Projekteinstellungen


Anforderungseigenschaften (Seite)

Projekt:<Projektname> > Projekteinstellungen > Anforderungseigenschaften

Auf der Seite Anforderungseigenschaften werden die benutzerdefinierten Anforderungseigenschaften und die berechneten Eigenschaften angezeigt, die im aktiven Projekt verfügbar sind.

Berechnete Eigenschaften

Spalte | Beschreibung
Aktionen | Die Aktionen, die mit der berechneten Eigenschaft ausgeführt werden können.
Name | Der Name der berechneten Eigenschaft. Klicken Sie auf das Symbol Bearbeiten, um den Namen der berechneten Eigenschaft zu bearbeiten.
Formel | Enthält die tatsächliche Formel der berechneten Eigenschaft.
Klassifizierung | Eine Liste der Klassifizierungen für die berechnete Eigenschaft.
Erstellt am | Das Datum, an dem die Eigenschaft erstellt wurde.
Erstellt von | Der Name des Benutzers, der die Eigenschaft erstellt hat.
Geändert am | Das Datum, an dem die Eigenschaft zuletzt geändert wurde.
Geändert Von | Der Name des Benutzers, von dem die Eigenschaft zuletzt geändert wurde.

Benutzerdefinierte Eigenschaften

Spalte | Beschreibung
Aktionen | Die Aktionen, die mit der benutzerdefinierten Eigenschaft ausgeführt werden können.
Name | Der Name der Anforderungseigenschaft. Klicken Sie auf das Symbol Bearbeiten, um die Anforderungseigenschaft zu bearbeiten.
Typ | Der Typ der Eigenschaft. Siehe das Thema Typen der Testattribute und Anforderungseigenschaften für eine Beschreibung jedes Attributtyps.
Erstellt am | Das Datum, an dem die Eigenschaft erstellt wurde.
Erstellt von | Der Name des Benutzers, der die Eigenschaft erstellt hat.
Geändert am | Das Datum, an dem die Eigenschaft zuletzt geändert wurde.
Geändert Von | Der Name des Benutzers, von dem die Eigenschaft zuletzt geändert wurde.
Übergeordnetes Thema: Anforderungseigenschaften


Berechnete Anforderungseigenschaften

Mit Hilfe von berechneten Anforderungseigenschaften können Sie aus den Werten von systemeigenen oder benutzerdefinierten Eigenschaften einen Einzelwert auf der Grundlage einer benutzerdefinierten Formel erstellen. Dieser Wert wird anschließend einem bestimmten Bereich, der so genannten Klassifizierung zugeordnet. Ziel einer berechneten Anforderungseigenschaft ist es, den Namen der Klassifizierung in Tabellen anzuzeigen. Der Wert einer berechneten Anforderungseigenschaft wird überall dort angezeigt, wo die Werte von benutzerspezifischen Eigenschaften dargestellt sind (z. B. in der Dokumentansicht). Berechnete Anforderungseigenschaften können wie andere systemeigene oder benutzerspezifische Anforderungseigenschaften auch in Filtern und Qualitätszielen verwendet werden.

Jede berechnete Anforderungseigenschaft verfügt über eine standardmäßige Klassifizierung ohne Untergrenze. Alle anderen Klassifizierungen müssen eine untere Grenze aufweisen. Mit Hilfe der Klassifizierung können Sie einen Namen und einen Bereich für den Wert der berechneten Anforderungseigenschaft vorgeben. Der Name der Klassifizierung gibt an, wie der Wert in den Tabellen angezeigt wird. Wenn ein oder mehrere Werte in der Formel nicht gesetzt wurden oder die Auswertung der Formel an einer bestimmten Anforderung scheitert (z. B. wegen einer Teilung durch Null), erscheint als Wert für die berechnete Anforderungseigenschaft ---.

Sie können jede beliebige systemeigene oder selbst erstellte Eigenschaft aus einem Projekt in der Formel für eine berechnete Anforderungseigenschaft verwenden. Die systemeigene oder selbst erstellte Eigenschaft muss vom Typ Zahl, Text oder Liste sein, wobei nur eine Auswahl möglich ist. Die folgenden Operatoren sind in der Formel zulässig: + - * / ()

Einschränkung: Pro Projekt können bis zu fünf berechnete Anforderungseigenschaften definiert werden. Berechnete Anforderungseigenschaften können nicht in anderen berechneten Anforderungseigenschaften verwendet werden.
  • Erstellen einer berechneten Eigenschaft
    Hier wird beschrieben, wie berechnete Anforderungseigenschaften erstellt werden.
  • Berechnete Anforderungseigenschaft (Seite)
    Im Folgenden wird die Seite der berechneten Anforderungseigenschaften beschrieben.
  • Systemeigene Werte von Testschritteigenschaften
    Hier werden die Werte der verschiedenen systemeigenen Eigenschaften erläutert.
Übergeordnetes Thema: Anforderungseigenschaften


Erstellen einer berechneten Eigenschaft

Mit berechneten Anforderungseigenschaften können Sie eine Eigenschaft auf der Grundlage einer Reihe von Werten erstellen. Im Folgenden wird erläutert, wie Sie eine berechnete Anforderungseigenschaft mit dem Namen Benutzerdefiniertes Risiko mit drei Klassifikationen erstellen: Niedrig, Mittel und Hoch. Dazu wird die interne Eigenschaft Risiko und eine benutzerspezifische Eigenschaft namens Auswirkung des Typs Zahl verwendet (diese sollte im Vorfeld angelegt werden).

  1. Klicken Sie auf Anforderungen > Anforderungseigenschaften.
  2. Klicken Sie auf Neue berechnete Anforderungseigenschaft.
  3. Geben Sie im Feld Name den Text Benutzerspezifisches Risiko ein.
  4. Geben Sie im Feld Beschreibung den Text Berechnete Anforderungseigenschaft mit Risiko und Auswirkung (N, M, H) ein.
  5. Wählen Sie aus der Liste Eigenschaft einfügen den Eintrag Auswirkung aus. ${Business Impact} wird zum Feld Formel hinzugefügt.
  6. Wählen Sie aus der Liste Operator einfügen * aus. ${Business Impact}* wird zum Feld Formel hinzugefügt.
  7. Wählen Sie aus der Liste Eigenschaft einfügen den Eintrag Risiko aus. ${Business Impact}*${Business Risk} wird zum Feld Formel hinzugefügt.
  8. Benennen Sie in der Tabelle Klassifizierung den Eintrag in Niedrig um. Da alle berechneten Anforderungseigenschaften eine standardmäßige Klassifizierung ohne Untergrenze haben müssen, wird diese verwendet.
  9. Klicken Sie auf Klassifizierung hinzufügen. Eine neue Zeile wird zur Tabelle Klassifizierung hinzugefügt.
  10. Wählen Sie als Bezeichnung Mittel, und fügen Sie eine untere Grenze von 10 ein.
  11. Klicken Sie auf Klassifizierung hinzufügen. Eine neue Zeile wird zur Tabelle Klassifizierung hinzugefügt.
  12. Wählen Sie als Bezeichnung Hoch, und fügen Sie eine untere Grenze von 20 ein.
  13. Klicken Sie auf OK.
Daraufhin wird eine berechnete Anforderungseigenschaft mit dem Zusatz Niedrig, Mittel oder Hoch erstellt, wenn als Anforderung sowohl die Eigenschaft Auswirkung als auch Risiko eingestellt ist.
Übergeordnetes Thema: Berechnete Anforderungseigenschaften


Berechnete Anforderungseigenschaft (Seite)

Auf der Seite Berechnete Anforderungseigenschaft können Sie eine berechnete Anforderungseigenschaft zu einem Projekt hinzufügen oder bearbeiten. Klicken Sie zum Öffnen der Seite auf Anforderungen > Anforderungseigenschaften und anschließend auf eine bereits vorhandene berechnete Anforderungseigenschaft oder auf Neue berechnete Anforderungseigenschaft.

Name
Enthält den Namen Ihrer berechneten Anforderungseigenschaft.
Beschreibung
Geben Sie eine aussagekräftige Beschreibung für die berechnete Anforderungseigenschaft ein, indem Sie beispielsweise auf eine Formel oder Klassifizierung verweisen.
Formel
Enthält die Formel für Ihre berechnete Anforderungseigenschaft. Sie können die Formel manuell eingeben oder dies mit Hilfe der Listen Eigenschaft einfügen und Operator einfügen tun. Wenn Sie die Formel manuell eingeben, sollten die Feldnamen innerhalb der folgenden Struktur angegeben werden: ${}. Operatoren werden in dieser Form eingegeben.
Eigenschaft einfügen
Setzen Sie den Cursor an die Stelle, an der die Eigenschaft im Feld Formel erscheinen soll, und wählen Sie eine der systemeigenen oder benutzerdefinierten Eigenschaften aus der Liste aus, um sie hinzuzufügen.
Operator einfügen
Setzen Sie den Cursor an die Stelle, an der der Operator im Feld Formel erscheinen soll, und wählen Sie einen Operator aus.
Klassifizierungstabelle
Die Tabelle Klassifizierung wird verwendet, um die Werte der berechneten Anforderungseigenschaften in unterschiedliche Bereiche einzuteilen. Klicken Sie auf Klassifizierung hinzufügen, um eine neue Tabellenzeile hinzuzufügen. Geben Sie im Feld Name die Klassifizierung und im Feld Untergrenze den niedrigsten Wert für die berechnete Anforderungseigenschaft an. Im Zusammenhang mit Klassifizierung ist es wichtig, sich klar zu machen, dass nur der Name der Klassifizierung in der Tabelle erscheint und nicht die Werte der berechneten Anforderungseigenschaften. Beispiel: Der Name der Klassifizierung lautet Mittel, und die Untergrenze ist auf 5 festgelegt ist. Wenn jetzt der Wert der berechneten Anforderungseigenschaft 7 ist, dann wird, solange der untere Grenzwert für die nächste Klassifizierung größer als 7 ist, der berechnete Wert als Mittel angezeigt.
Übergeordnetes Thema: Berechnete Anforderungseigenschaften


Systemeigene Werte von Testschritteigenschaften

Die Werte der verschiedenen systemeigenen Eigenschaften können in den Formeln für berechnete Eigenschaften verwendet werden. Die Werte der unterstützten Eigenschaften sind weiter unten angegeben.

Risiko

Wertbezeichnung | Systemeigener Wert
Niedrig | 1
Mittel | 2
Hoch | 3
Kritisch | 4

Priorität

Wertbezeichnung | Systemeigener Wert
Niedrig | 1
Mittel | 2
Hoch | 3
Kritisch | 4

Geprüft

Wertbezeichnung | Systemeigener Wert
Nein | 0
Ja | 1
Übergeordnetes Thema: Berechnete Anforderungseigenschaften


Benutzerdefinierte Anforderungseigenschaften

Sie können bei allen Anforderungen des ausgewählten Projekts benutzerdefinierte Eigenschaftsfelder mit Anforderungen > Anforderungseigenschaften hinzufügen. Die benutzerdefinierten Eigenschaften stehen dann zusammen mit den Standardeigenschaften im Dialogfeld Anforderung bearbeiten zur Verfügung. Benutzerdefinierte Eigenschaften Anforderungen > Detailansicht > Eigenschaften. Wenn der einzige Wert einer Eigenschaft eine URL ist, stellt Silk Central automatisch eine Verknüpfung dar, was den direkten Zugriff auf andere Web-Anwendungen aus Silk Central heraus ermöglicht.

  • Erstellen einer benutzerdefinierten Anforderungseigenschaft
    Erstellen Sie eine neue benutzerdefinierte Anforderungseigenschaft, um sie für alle Anforderungen im aktiven Projekt verfügbar zu machen.
  • Typen der benutzerdefinierten Attribute und Anforderungseigenschaften
    Hier werden Details über die Typen der Attribute und Anforderungseigenschaften genauer dargelegt.
  • Bearbeiten benutzerdefinierter Anforderungseigenschaften
    Bearbeiten Sie eine benutzerdefinierte Anforderungseigenschaft.
  • Löschen benutzerdefinierter Anforderungseigenschaften
    Löschen Sie eine benutzerdefinierte Anforderungseigenschaft, um sie aus der Eigenschaftenliste zu entfernen.
Übergeordnetes Thema: Anforderungseigenschaften
Zugehörige Verweise
Anforderungseigenschaften (Seite)


Erstellen einer benutzerdefinierten Anforderungseigenschaft

So erstellen Sie eine benutzerdefinierte Anforderungseigenschaft:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Anforderungseigenschaften.
  3. Klicken Sie auf Neue Anforderungseigenschaft, um das Dialogfeld Neue Anforderungseigenschaft zu öffnen.
  4. Geben Sie einen Namen für die neue Eigenschaft in das Feld Name ein.
  5. Wählen Sie in der Liste Typ den Datentyp der neuen Eigenschaft aus. Siehe das Thema Typen der Testsattribute und Anforderungseigenschaften für eine Beschreibung jedes Attributtyps.
  6. Klicken Sie auf OK.
Ihre benutzerdefinierte Eigenschaft ist für alle Anforderungen im aktiven Projekt verfügbar.
Übergeordnetes Thema: Benutzerdefinierte Anforderungseigenschaften
Zugehörige Verweise
Typen der benutzerdefinierten Attribute und Anforderungseigenschaften


Typen der benutzerdefinierten Attribute und Anforderungseigenschaften

Silk Central unterstützt die folgenden Typen der Attribute und Anforderungseigenschaften:

Datum

Der Typ Datum unterstützt Datumswerte.

Liste

Der Typ Liste unterstützt Listen für Einzelauswahl und Mehrfachauswahl. Die Ansicht enthält folgende Steuerelemente:

  • Neues Element: Ermöglicht das Erstellen von Einträgen in die Liste. Klicken Sie hier, um das Dialogfeld Neues Element zu öffnen. Geben Sie Name und Numerisches Gewicht für das Listenelement ein, und klicken Sie auf OK.
    Anmerkung: Der Wert für das Feld Numerisches Gewicht wird für das Filtern verwendet, wenn bei den Filterkriterien eine der folgenden Operationen verwendet wird: >, >=, < oder <=. Wenn bei den Filterkriterien die Operationen = oder not verwendet werden, wird der Wert des Felds Name zum Vergleich herangezogen.
  • Reihenfolge: Verwenden Sie die Felder in dieser Spalte, um Ihre Attribute zu sortieren.
  • Mehrfachauswahl erlauben: Klicken Sie auf dieses Kontrollkästchen, um zuzulassen, dass Benutzer mehr als einen Wert aus der Liste auswählen können.
    Anmerkung: Sie können eine bestehende Einfachauswahl-Liste in eine Mehrfachauswahl-Liste umwandeln. Eine Mehrfachauswahl-Liste kann jedoch nicht in eine Einfachauswahl-Liste umgewandelt werden.
  • Aktionen: Verwenden Sie die Symbole in dieser Zeile, um Elemente in der Liste zu löschen oder zu bearbeiten.
Nummer

Der Typ Zahl unterstützt Ganzzahlenwerte oder Dezimalzahlenwerte. Die Ansicht enthält folgende Felder:

  • Mindestwert: Ist der kleinste Wert, den Sie in das Feld eingeben können.
  • Höchstwert: Ist der höchste Wert, den Sie in das Feld eingeben können.
  • Kommastellen: Wird verwendet, um festzulegen, wie viele Werte rechts von der Kommastelle gültig sind. Wählen Sie 0 für einen Ganzzahlwert oder 1, 2, 3 oder 4 für einen Dezimalwert ein.
Anmerkung: Benutzerdefinierte Attribute und Anforderungseigenschaften zeigen den aktuellen Wert an, wenn eine Aktualisierung an deren Spezifikationen vorgenommen werden (zum Beispiel, Änderungen am Minimalwert oder Maximalwert). Um die neue Spezifikation zu speichern, öffnen und speichern Sie die Komponente.
Text

Der Typ Text unterstützt jeden alphanumerischen Wert. Die Ansicht enthält folgende Felder:

  • Maximale Länge: Ist die maximale Anzahl von Zeichen, die in dem Feld eingegeben werden können. Um die Länge nicht zu beschränken, geben Sie 0 ein oder lassen Sie das Feld leer (gilt nur für Anforderungseigenschaften).
Übergeordnetes Thema: Benutzerdefinierte Anforderungseigenschaften
Übergeordnetes Thema: Attribute


Bearbeiten benutzerdefinierter Anforderungseigenschaften

So bearbeiten Sie eine benutzerdefinierte Anforderungseigenschaft:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Anforderungseigenschaften.
  3. Klicken Sie auf den Namen der Eigenschaft, die Sie bearbeiten möchten. Das Dialogfeld Anforderungseigenschaft bearbeiten wird geöffnet.
  4. Bearbeiten Sie den Namen der Eigenschaft im Textfeld Name. Wenn die Eigenschaft zur Verwendung verfügbar ist, wird der Name in Listen für Filter und Anforderungen angezeigt. Eigenschaften können bei globalen Filtern für das Filtern von Anforderungseigenschaften verwendet werden, und können auf Anforderungen angewendet werden.
  5. Bearbeiten Sie das Feld Beschreibung der Eigenschaft.
  6. Siehe das Thema Typen der Testsattribute und Anforderungseigenschaften für eine Beschreibung jedes Typs der Anforderungseigenschaften. Ihnen stehen verschiedene Bearbeitungsfunktionen abhängig vom Eigenschaftsdatentyp zur Verfügung.
  7. Klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Benutzerdefinierte Anforderungseigenschaften
Zugehörige Konzepte
Filter
Zugehörige Verweise
Typen der benutzerdefinierten Attribute und Anforderungseigenschaften


Löschen benutzerdefinierter Anforderungseigenschaften

So löschen Sie eine benutzerdefinierte Anforderungseigenschaft:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Anforderungseigenschaften.
  3. Klicken Sie auf Löschen. Ein Bestätigungsdialogfeld wird angezeigt.
  4. Klicken Sie auf Ja, um das Löschen zu bestätigen.
Übergeordnetes Thema: Benutzerdefinierte Anforderungseigenschaften


Integration von Anforderungsverwaltungssystemen

Wichtig: Bevor Sie Ihr System von Version 15.0 oder älter auf die aktuelle Version von Silk Central aktualisieren, führen Sie die Aktion Alles synchronisieren aus, um alle Ihre Anforderungen mit den integrierten Anforderungsverwaltungssystemen zu synchronisieren.
Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren. Die Integration wird auf der Seite Anforderungsmanagement in Projekt:<Projektname> > Projekteinstellungen konfiguriert.
Anmerkung: Anstatt nur Veränderungen über das integrierte System zuzulassen, können Sie auch einstellen, dass Anforderungen in Silk Central selbst hinzugefügt, bearbeitet und gelöscht werden können. Sie können Veränderungen direkt in der Benutzeroberfläche von Test Manager zulassen und/oder durch die Silk Central-Webdienste, indem Sie die entsprechenden Kontrollkästchen Anlegen, Bearbeiten und Löschen von Anforderungen über... aktivieren.

Silk Central unterstützt durch eine offene Schnittstelle die Integration externer Anforderungsverwaltungssysteme. Beliebige Systeme können in Silk Central integriert werden, indem ein Plug-In erstellt und installiert wird. Informationen über die Schnittstellen zur Integration externer Systeme finden Sie in der Silk Central-API-Hilfe.

  • Synchronisieren von Anforderungen
    Hier wird beschrieben, wie Eigenschaftenfelder von Anforderungen zwischen Silk Central und externen Anforderungsmanagementtools synchronisiert werden.
  • Atlassian JIRA Agile-Integration
    Hier wird beschrieben, wie Atlassian JIRA Agile in Silk Central integriert wird.
  • CA Agile Central-Integration
    Hier wird beschrieben, wie und Silk Central integriert werden.
  • Caliber-Integration
    Hier wird beschrieben, wie Caliber in Silk Central integriert wird.
  • IBM Rational DOORS-Integration
    Hier wird beschrieben, wie Silk Central und IBM Rational DOORS integriert werden.
  • IBM Rational DOORS Next Generation-Integration
    Hier wird beschrieben, wie IBM Rational DOORS Next Generation und Silk Central integriert werden.
  • IBM Rational RequisitePro-Integration
    Hier wird beschrieben, wie IBM Rational RequisitePro in Silk Central integriert wird.
  • SAP Solution Manager-Integration
    Hier wird beschrieben, wie Silk Central und SAP Solution Manager integriert werden.
  • Arbeiten mit externen Eigenschaften
    Beschreibt die Arbeit mit externen Eigenschaften in Silk Central.
  • Bearbeiten von Eigenschaftszuordnungen
    Ordnen Sie Eigenschaftsfelder zwischen Silk Central und einem externen Anforderungsverwaltungstool zu, um sicherzustellen, dass die Felder für Anforderungseigenschaften zwischen den Projekten korrekt ausgefüllt werden.
  • Löschen von Eigenschaftszuordnungen
    Löschen Sie eine Eigenschaftszuordnung.
  • Deaktivieren einer Anforderungsverwaltungsintegration
    Deaktivieren Sie die Integration in ein externes Anforderungsverwaltungstools, um alle Integrationsdaten und -funktionen zu deaktivieren.
  • Entfernen einer Anforderungsverwaltungsintegration
    Entfernen Sie die Integration in ein externes Anforderungsverwaltungstool, um alle diesbezüglichen Daten aus der Datenbank zu löschen.
Übergeordnetes Thema: Konfigurieren von Anforderungseigenschaften und Integrationen
Übergeordnetes Thema: Projekteinstellungen
Übergeordnetes Thema: Integrationen
Zugehörige Verweise
Anforderungseigenschaften (Seite)


Synchronisieren von Anforderungen

Durch die Synchronisierung von Anforderungen zwischen Silk Central und einem externen Anforderungsmanagementsystem kann Silk Central Änderungen erhalten, die in dem externen Anforderungsmanagementsystem aufgetreten sind. Wenn für ein Projekt eine externe RMS-Integration aktiviert ist, ist das Hauptsystem für Anforderungen automatisch das externe System. Das bedeutet, dass die Synchronisierung immer von dem externen RMS-System zu Silk Central ausgeführt wird. Anforderungen können in Silk Central nicht mehr bearbeitet werden. Eine Ausnahme stellen neu erstellte Anforderungen dar, die im externen System nicht vorhanden sind. Diese werden nur auf das externe (Haupt-)System hochgeladen, wenn die Option Hochladen von Anforderungen unter Einstellungen > Anforderungsmanagement aktiviert ist.

Mit der Zuordnungsfunktion können Eigenschaften zwischen Silk Central und einem externen Anforderungsmanagementsystem zugeordnet werden. So könnte z. B. das benutzerdefinierte Feld User in Silk Central mit dem Feld Field_2 in Caliber identisch sein. Die Zuordnungsfunktion gewährleistet, dass Änderungen an den Eigenschaften zwischen den Projekten richtig übernommen werden. Wenn Sie die Zuordnungsfunktion nicht verwenden, werden nur der Name und die Beschreibung der Anforderung zugeordnet. Weitere Informationen finden Sie unter Bearbeiten von Eigenschaftszuordnungen.

Anforderungen können auf die folgenden Arten synchronisiert werden:
Manuelle Synchronisierung
Klicken Sie auf Stammverzeichnisebene auf der Seite Eigenschaften auf Änderungen synchronisieren, um nur Anforderungen zu synchronisieren, die seit der letzten Synchronisierung geändert wurden. Diese Option ist nur für IBM Rational RequisitePro verfügbar.
Erzwungene manuelle Synchronisierung
Klicken Sie auf Stammverzeichnisebene auf der Seite Eigenschaften auf Alles synchronisieren, um die Synchronisierung aller Anforderungen zu erzwingen.
Automatische geplante Synchronisierung
Die Synchronisierung wird anhand von global definierten Silk Central-Zeitplänen durchgeführt.
Automatische Online-Synchronisierung
Änderungen an Anforderungen werden automatisch zwischen den Programmen übertragen. Diese Option ist nur für Caliber verfügbar. Dazu muss der Caliber-Mandant auf dem Anwendungsserver installiert sein und MPX muss auf dem Caliber-Server aktiviert werden (weitere Informationen zur MPX-Aktiviereung finden Sie im Caliber Installationshandbuch). Fügen Sie für die automatische Synchronisierung zwischen Caliber und Silk Central dem Anwendungsserver unter Programme\Silk\Silk Central <Version>\lib die Datei ss.jar hinzu, und starten Sie den Anwendungsserver neu. Die Datei erhalten Sie beim Kundendienst. Die Anforderungsdaten werden dann automatisch in Silk Central aktualisiert, wenn Änderungen in Caliber durchgeführt werden, und bei Änderungen an Testzuordnungen in Silk Central werden die Abhängigkeiten in Caliber aktualisiert. Diese Art der Online-Synchronisierung ist nur bei Projekten verfügbar, die mit der aktuellen Baseline konfiguriert sind.

Die automatische Synchronisierung von Anforderungen zwischen Silk Central und externen Anforderungsmanagementsystemen kann auch anhand von globalen Zeitplänen durchgeführt werden. Details zum Konfigurieren globaler Ausführungstermine finden Sie in den Themen Verwaltung in dieser Hilfe.

Anmerkung: Mit den Schaltflächen Caliber-Öffnen wird das Programm gestartet, das als Standardprogramm für Dateien mit der Erweiterung .crm registriert ist. Auf manchen Computern kann dies statt Caliber das Anzeigeprogramm für Anforderungen sein. Diese Funktion kann vom Administrator konfiguriert werden. Das Clientprogramm hat den Dateinamen caliberrm.exe. Bei ordnungsgemäßer Konfiguration wird das Programm für die in Silk Central ausgewählte Anforderung geöffnet.
Am Bindungssymbol des Projektknotens der Anforderungshierarchie ist der Status der Systemintegration zu erkennen:
Keine Konfiguration
RM-Integration ist nicht verfügbar.
Manuelle Konfiguration
Das Importieren, Hochladen und Synchronisieren von Anforderungen wird mit den entsprechenden Schaltflächen des Projektknotens in Anforderungen > Anforderungsansicht > Eigenschaften ausgeführt.
Auf Projektebene enthält die Seite Eigenschaften die folgenden Eigenschaften:
Eigenschaft | Beschreibung
System | Das externe Tool, dessen Integration aktiviert ist.
Status | Der Aktivierungsstatus der Integration.
Projektname | Der Name des externen Projekts, dem das Silk Central-Projekt zugeordnet ist.
Anforderungstypen | Die Anforderungstypen, die von den Projekten gemeinsam genutzt werden.
Letzte Synchronisierung | Datum und Uhrzeit der letzten Synchronisierung.
Letzter Synchronisierungsstatus | Der Status der letzten Synchronisierung einschließlich der Anzahl der erstellten, aktualisierten und gelöschten Elemente.
Anmerkung: Wenn die Integration zwischen Caliber und Silk Central mit automatischer Online-Synchronisierung aktiviert ist, wird im Projektknoten der aktuelle Status der Online-Überwachung von Anforderungsänderungen angezeigt. Die drei möglichen Statuswerte für solche Projekte sind: Verbunden (synchronisiert), Verbindung wiederhergestellt (Synchronisierung erforderlich) und Verbindung getrennt.
  • Synchronisieren von Anforderungen mit einem externen System
    Synchronisieren Sie Anforderungen zwischen Silk Central und einem externen Anforderungsmanagementtool.
  • Synchronisierung von Anforderungen nach Zeitplänen
    Definieren Sie einen globalen Zeitplan, um Anforderungen zwischen Silk Central und einem extern konfigurierten Anforderungsverwaltungssystem zu synchronisieren.
  • Definieren von E-Mail-Benachrichtigungen für automatische Synchronisierung
    Definieren Sie eine E-Mail-Benachrichtigung, die gesendet werden soll, wenn während der automatischen Synchronisierung von Anforderungen zwischen Silk Central und externen Anforderungsmanagementtools Fehler auftreten.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen
Zugehörige Tasks
Bearbeiten von Eigenschaftszuordnungen


Synchronisieren von Anforderungen mit einem externen System

Anmerkung: Verwenden Sie die Zuordnungsfunktion zum Zuordnen von Eigenschaftsfeldern. Wenn Sie die Zuordnungsfunktion nicht verwenden, werden nur der Name und die Beschreibung der Anforderung zugeordnet. Weitere Informationen finden Sie unter Bearbeiten von Eigenschaftszuordnungen.

Zum Synchronisieren von Anforderungen zwischen Silk Central und einem externen Anforderungsmanagementtool

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie den Projektknoten aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften. Auf der Seite Eigenschaften werden die Eigenschaften der ausgewählten Hierarchieelemente angezeigt.
  4. Klicken Sie Änderungen synchronisieren.
  5. Klicken Sie im Bestätigungsdialogfeld Anforderungen synchronisieren auf Ja, um die Synchronisierung zu starten. Nach Abschluss der Synchronisierung wird ein Dialogfeld mit statistischen Informationen, wie z. B. der Anzahl der erstellten, aktualisierten und gelöschten Anforderungen, angezeigt.
  6. Klicken Sie auf OK, um die Synchronisierung abzuschließen. Alle Änderungen, die im konfigurierten externen Anforderungsmanagementsystem an den zugeordneten Anforderungen vorgenommen wurden, werden nun in die Anforderungshierarchie übernommen.
Übergeordnetes Thema: Synchronisieren von Anforderungen
Zugehörige Tasks
Bearbeiten von Eigenschaftszuordnungen


Synchronisierung von Anforderungen nach Zeitplänen

Sie können globale Zeitpläne konfigurieren, um Anforderungen zwischen Silk Central und einem externen Anforderungsverwaltungssystem automatisch zu synchronisieren. Fügen Sie für die automatische Synchronisierung zwischen Caliber und Silk Central dem Anwendungsserver unter Program Files\Silk\Silk Central <Version>\lib die Datei ss.jar hinzu, und starten Sie den Anwendungsserver neu. Die Datei erhalten Sie vom Kundenservice.

So werden Anforderungen anhand von globalen Zeitplänen synchronisiert:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  3. Klicken Sie auf Ausführungstermine bearbeiten. Der Dialog Ausführungstermine bearbeiten wird geöffnet.
  4. Wählen Sie aus der Liste Änderungen synchronisieren einen vordefinierten globalen Ausführungstermin aus, um festzulegen wann Änderungen im externen System mit Silk Central synchronisiert werden sollen.
  5. Wählen Sie aus der Liste Alles synchronisieren einen vordefinierten globalen Ausführungstermin aus, um festzulegen wann alle Anforderungen im externen System mit Silk Central synchronisiert werden sollen.
  6. Klicken Sie auf OK.
Informationen über die Erstellung globaler Ausführungstermine finden Sie unter Hinzufügen globaler Ausführungstermine.
Übergeordnetes Thema: Synchronisieren von Anforderungen


Definieren von E-Mail-Benachrichtigungen für automatische Synchronisierung

Sie können eine E-Mail-Benachrichtigung definieren, durch die Benutzer informiert werden sollen, wenn während der automatischen Synchronisierung von Anforderungen zwischen Silk Central und externen Anforderungsmanagementtools Fehler auftreten. Den Empfängern der Benachrichtigungen werden Kopien der Logdateien für die Synchronisierung gesendet.

So konfigurieren Sie die E-Mail-Benachrichtigung zur automatischen Synchronisierung:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  3. Klicken Sie auf Benachrichtigung bearbeiten. Der Dialog Benachrichtigung bearbeiten wird angezeigt.
  4. Aktivieren Sie das Kontrollkästchen Benachrichtigung aktivieren.
  5. Wählen Sie im Listenfeld Benutzername den Namen des Empfängers aus.
  6. Geben Sie bei Bedarf die E-Mail-Adressen weiterer Empfänger in das Feld Weitere E-Mail-Adressen ein. Trennen Sie die E-Mail-Adressen jeweils durch einen Strichpunkt.
  7. Klicken Sie auf OK.
Übergeordnetes Thema: Synchronisieren von Anforderungen


Atlassian JIRA Agile-Integration

Silk Central ermöglicht die Integration mit Atlassian JIRA Agile, welches auf dem Projekt- und Fehlerverwaltungssystem JIRA basiert. Alle Fehlertypen (die allgemeinen Objekttypen in JIRA) können synchronisiert werden. Da Atlassian JIRA Agile die Möglichkeit bietet, kundenspezifische Fehlertypen zu erstellen, können Sie eine Liste von Atlassian JIRA Agile Fehlertypen in Silk Central erstellen, die Sie synchronisieren möchten, z.B. Fehler oder Verbesserungsvorschlag.

Folgende Atlassian JIRA Agile-Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: Atlassian JIRA 6, 7

Einschränkungen: Die Synchronisierung von JIRA-Anforderungen funktioniert nur für Anforderungen des konfigurierten JIRA-Projekts. Wenn Anforderungen mit Anforderungen (Epics) aus anderen JIRA-Projekten verknüpft sind, werden diese nicht mit-synchronisiert.

  • Aktivieren der Integration mit Atlassian JIRA Agile
    Aktivieren Sie die Integration mit Atlassian JIRA Agile um Anforderungen zu synchronisieren.
  • Atlassian JIRA Agile Eigenschaftszuordnung
    Hier wird beschrieben, wie Atlassian JIRA Agile-Eigenschaften wie Backlog und Priorität Silk Central-Eigenschaften zugeordnet werden und wie diese betrachtet und angepasst werden können.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Aktivieren der Integration mit Atlassian JIRA Agile

So aktivieren Sie die Integration mit Atlassian JIRA Agile:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt für die Integration aus.
  3. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  4. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  5. Klicken Sie auf Neue Anforderungsverwaltungs-Integration.
    Anmerkung: Anstatt nur Veränderungen über das integrierte System zuzulassen, können Sie auch einstellen, dass Anforderungen in Silk Central selbst hinzugefügt, bearbeitet und gelöscht werden können. Sie können Veränderungen direkt in der Benutzeroberfläche von Test Manager zulassen und/oder durch die Silk Central-Webdienste, indem Sie die entsprechenden Kontrollkästchen Anlegen, Bearbeiten und Löschen von Anforderungen über... aktivieren.
    Der Dialog Neue Anforderungsverwaltungs-Integration wird geöffnet.
  6. Wählen Sie Atlassian JIRA Agile in der Liste aus, und klicken Sie auf OK. Der Dialog Konfiguration bearbeiten wird geöffnet.
  7. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  8. Geben Sie die URL Ihres JIRA Agile Servers ein.
  9. Geben Sie für JIRA Agile einen gültigen Benutzernamen und ein Kennwort ein. Der Benutzername muss ein gültiger JIRA-Profilname sein.
  10. Geben Sie im Feld Fehlertypen die Fehlertypen ein, die Sie synchronisieren möchten. Trennen Sie mehrere Fehlertypen mit einem Semikolon. Alle Fehlertypen (die allgemeinen Objekttypen in JIRA) können synchronisiert werden. Da Atlassian JIRA Agile die Möglichkeit bietet, kundenspezifische Fehlertypen zu erstellen, können Sie eine Liste von Atlassian JIRA Agile Fehlertypen in Silk Central erstellen, die Sie synchronisieren möchten, z.B. Fehler oder Verbesserungsvorschlag.
  11. Optional: Um die Anzahl der zu synchronisierenden Anforderungen zu reduzieren, können Sie das Feld Benutzerdefiniertes JQL verwenden um Anforderungen zu filtern noch bevor sie synchronisiert werden. Erstellen Sie mit der Query Language (JQL) in Ihrem JIRA Agile-System eine Abfrage, welche Sie dann in das Benutzerdefiniertes JQL-Feld kopieren. JIRA
    Tipp:
    • Verwenden Sie in Ihrer JQL-Abfrage keine ORDER BY-Anweisungen.
    • Die JQL-Abfrage darf nicht über 128 Zeichen lang sein.
    • Die JQL-Abfrage überschreibt nicht die von Ihnen festgelegten Projekt- und Fehlertypen, sondern wird zusätzlich zu ihnen angewendet.
  12. Klicken Sie auf Verbindung testen, um die Gültigkeit der Host- und Anmeldeinformationen zu überprüfen. Wenn die Einstellungen richtig sind, wird ein Dialog mit der Meldung angezeigt, dass die Verbindung erfolgreich hergestellt werden konnte. Klicken Sie auf OK, um fortzufahren.
    Anmerkung: Wenn die Verbindung nicht hergestellt werden kann, wenden Sie sich an den Systemadministrator.
  13. Klicken Sie auf Laden. Das Listenfeld Projekt wird mit allen Projekten aus JIRA Agile gefüllt, für die Sie Berechtigungen haben.
  14. Wählen Sie aus dem Listenfeld Projekt das externe Projekt aus, in das das Silk Central-Projekt integriert werden soll.
  15. Klicken Sie auf OK, um die Einstellungen zu speichern.
Übergeordnetes Thema: Atlassian JIRA Agile-Integration


Atlassian JIRA Agile Eigenschaftszuordnung

Die folgenden Eigenschaften haben eine Standardzuordnung zwischen JIRA Agile und Silk Central:
  • User Stories die sich im Backlog von JIRA Agile befinden werden in Silk Central durch die Eigenschaft Sprint mit dem Wert Backlog abgebildet. Dies ermöglicht eine einfache Suche mittels einem Filter.
  • Die Standardwerte der Priorität von JIRA Agile User Stories werden der Eigenschaft Priorität in Silk Centralzugeordnet. Falls Sie nicht die Standardwerte für die Priorität von JIRA Agile User Stories verwenden, können Sie die Zuordnungskonfiguration anpassen.

JIRA Agile Backlog Stories in Silk Central betrachten

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Erstellen Sie einen neuen Filter mit den folgenden Kriterien:
    • Auswahlkriterien: Externe benutzerdefinierte Attribute
    • Eigenschaft: Sprint
    • Wert: Backlog
  3. Klicken Sie auf Anwenden um den Filter sofort anzuwenden, oder auf Speichern und anwenden um den Filter für zukünftige Verwendungszwecke zu speichern.

JIRA Agile Prioritätswerte zu Silk Central's Priorität zuordnen

Die Standardwerte der Priorität von JIRA Agile User Stories werden der Eigenschaft Priorität in Silk Centralwie folgt zugeordnet:
  • Blocker=SC_Priority_Critical
  • Critical=SC_Priority_High
  • Major=SC_Priority_Medium
  • Minor=SC_Priority_Low
  • Trivial=SC_Priority_Low
Falls Sie nicht die Standardwerte für die Priorität von JIRA Agile User Stories verwenden, oder wenn Sie die Zuordnung anpassen möchten, kann Ihr Silk Central Administrator die Zuordnungskonfiguration wie folgt anpassen:
  1. Halten Sie den Anwendungsserver an.
  2. Öffnen Sie die Datei propertyMappings.properties mit einem Texteditor. Diese Datei befindet sich im JIRA Agile Plugin JIRAAgile.zip auf dem Anwendungsserver im plugins Ordner.
  3. Suchen Sie nach dem Eintrag SC_Priority=Priority, unterhalb welchem Sie die Zuordnung der JIRA Agile Priorität zur Silk Central Priorität anpassen können.
    Anmerkung: Den Werten der Silk Central Priorität muss die Zeichenfolge SC_Priority_ vorangestellt werden.
  4. Speichern und schließen Sie die Datei.
  5. Starten Sie den Anwendungsserver neu.
Übergeordnetes Thema: Atlassian JIRA Agile-Integration
Zugehörige Tasks
Erstellen von Filtern
Starten oder Stoppen eines lokalen Ausführungsserverdienstes


CA Agile Central-Integration

Die Integration des Projektmanagement-Tools CA Agile Central ermöglicht Ihnen, User Stories festzulegen, die Sie später als Anforderung in Silk Central einsetzen können. Somit können Sie in Silk Central Tests erstellen, um diese Anforderungen abzudecken. Zum Aktualisieren der erstellten Tests mit möglichen Änderungen an den User Stories in CA Agile Central, müssen lediglich die Anforderungen synchronisiert werden.

Im Lieferumfang von Silk Central ist ein Mashup enthalten, mit dem Sie mit einer User Story verbundene Testabdeckungsinformationen von Silk Central in CA Agile Central anzeigen können. Sie können jeden Test in Silk Central mit einer oder mehreren User Storys in CA Agile Central verknüpfen. Um Tests mit einer User Story zu verknüpfen, weisen Sie jedem Test ein Attribut mit der ID der formatierten User Story in CA Agile Central zu.

Folgende User Story-Eigenschaften werden immer mit dem CA Agile Central REST-Service synchronisiert. Auch benutzerdefinierte Felder werden synchronisiert, sofern Sie in der Integrationskonfiguration festgelegt wurden. Diese Eigenschaften können Sie zum Filtern und Einordnen der User Stories verwenden:
Eigenschaft
Beschreibung
Name
Der Name der User Story in CA Agile Central.
CA Agile Central ID
Die Identifizierung der User Story in CA Agile Central. Diese Eigenschaft ist auch die externe ID der Anforderung in Silk Central.
Beschreibung
Die Beschreibung der User Story in CA Agile Central.
Iteration
Die Iteration in CA Agile Central, in die die User Story eingebunden ist.
Projekt
Das Projekt in CA Agile Central, in die die User Story eingebunden ist.
Release
Die Projektversion, in die die User Story eingebunden ist.
Zustand
Der Fortschrittsstatus der User Story in CA Agile Central. Folgende Status sind verfügbar:
  • Zugewiesen
  • Wird bearbeitet
  • Erledigt
  • Angenommen
Geschätzte Dauer des Plans (Story Punkte)
Die geschätzte Dauer zur Vollendung der Story in CA Agile Central. Die Dauer wird in Story-Punkten geschätzt.
  • Aktivieren der Integration mit CA Agile Central
    Aktivieren Sie die Integration mit CA Agile Central um Anforderungen zu synchronisieren.
  • Erstellen einer benutzerdefinierten HTML App in CA Agile Central
    Erstellen Sie mittels HTML oder Javascript Code eine benutzerdefinierte App in CA Agile Central, um Auskunft über User Story-bezogene Testabdeckung zu erhalten.
  • Verknüpfen von User Stories mit Tests in CA Agile Central
    Sie können Sie CA Agile Central User Stories mit Tests in Silk Central verknüpfen.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Aktivieren der Integration mit CA Agile Central

So aktivieren Sie die Integration mit CA Agile Central:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt für die Integration aus.
  3. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  4. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  5. Klicken Sie auf Neue Anforderungsverwaltungs-Integration.
    Anmerkung: Anstatt nur Veränderungen über das integrierte System zuzulassen, können Sie auch einstellen, dass Anforderungen in Silk Central selbst hinzugefügt, bearbeitet und gelöscht werden können. Sie können Veränderungen direkt in der Benutzeroberfläche von Test Manager zulassen und/oder durch die Silk Central-Webdienste, indem Sie die entsprechenden Kontrollkästchen Anlegen, Bearbeiten und Löschen von Anforderungen über... aktivieren.
    Der Dialog Neue Anforderungsverwaltungs-Integration wird geöffnet.
  6. Wählen Sie CA Agile Central in der Liste aus, und klicken Sie auf OK. Der Dialog Konfiguration bearbeiten wird geöffnet.
  7. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  8. Geben Sie die URL ein.
  9. Geben Sie für CA Agile Central einen gültigen Benutzernamen und ein Kennwort ein, oder stattdessen einen gültigen API Key. Mit einem API Key können Sie auf Ihr CA Agile Central-Abonnement zugreifen, ohne Ihren Benutzernamen und das Kennwort zu verwenden. Weitere Informationen über CA Agile Central-API Keys finden Sie auf der Seite CA Agile Central Application Manager.
  10. Optional: Wenn der direkte Zugriff auf das Internet eingeschränkt ist und der CA Agile Central REST-Dienst auf einem Rechner außerhalb des internen Netzwerks ausgeführt wird, geben Sie in den Feldern Proxy-Host und Proxy-Port einen Proxy an, über den Silk Central eine Verbindung mit CA Agile Central herstellen kann.
    Anmerkung: Um über einen Proxy eine Verbindung mit CA Agile Central herzustellen, müssen Sie beide Felder – Proxy Host und Proxy Port – ausfüllen.
  11. Optional: Wenn Sie benutzerdefinierte Felder synchronisieren möchten, geben Sie deren Namen, getrennt durch Kommas, im Feld Custom Fields ein. Die internen Feldnamen müssen verwendet werden, nicht die angezeigten.
  12. Klicken Sie auf Verbindung testen, um die Gültigkeit der Host- und Anmeldeinformationen zu überprüfen. Wenn die Einstellungen richtig sind, wird ein Dialog mit der Meldung angezeigt, dass die Verbindung erfolgreich hergestellt werden konnte. Klicken Sie auf OK, um fortzufahren.
    Anmerkung: Wenn die Verbindung nicht hergestellt werden kann, wenden Sie sich an den Systemadministrator.
  13. Klicken Sie auf OK.
  14. Klicken Sie auf Laden. Das Listenfeld Projektname wird mit allen Projekten aus den Arbeitsbereichen in CA Agile Central gefüllt, für die Sie Berechtigungen haben.
  15. Wählen Sie aus dem Listenfeld Projekt das externe Projekt aus, in das das Silk Central-Projekt integriert werden soll.
  16. Klicken Sie auf OK, um die Einstellungen zu speichern.
Übergeordnetes Thema: CA Agile Central-Integration


Erstellen einer benutzerdefinierten HTML App in CA Agile Central

Erstellen Sie mittels HTML oder Javascript eine benutzerdefinierte App in CA Agile Central, um Auskunft über User Story-bezogene Testabdeckung zu erhalten.

So erstellen Sie eine benutzerdefinierte HTML App:

  1. Wechseln Sie in CA Agile Central zu der Registerkarte, auf der sich die benutzerdefinierte App befinden soll.
  2. Klicken Sie auf Customize Page und danach auf Add App. Der Dialog App Catalog wird geöffnet.
  3. Unterhalb Custom, klicken Sie auf Custom HTML und danach auf Add This App.
  4. Geben Sie einen Titel ein und wechseln Sie dann zu Silk Central.
  5. Klicken Sie im Menü auf Hilfe > Tools.
  6. Klicken Sie auf CA Agile Central Iteration Status Mashup und kopieren Sie den HTML Code.
  7. Wechseln Sie zurück zu CA Agile Central und fügen Sie den HTML code in das Feld HTML ein.
  8. Passen Sie das Skript im Textfeld Ihrer Silk Central-Umgebung an:
    • Prüfen Sie, ob die gültige Skriptquelle festgelegt ist, z. B. <script type="text/javascript" src="http://localhost:19120/silkroot/script/sctm-toolkit.js"></script>.
    • Prüfen Sie, ob die gültige URL für Silk Central festgelegt ist, z. B. var SCTM_URL = "http://localhost:19120/".
    • Prüfen Sie, ob eine gültige Projekt-ID für Silk Central festgelegt ist, z. B. var SCTM_PROJECT_ID = 0.
    • Prüfen Sie, ob ein gültiger Attributname festgelegt ist, z. B. var SCTM_ATTRIBUTE_FOR_RALLY_US = "rallyattr".
    • Stellen Sie sicher, dass die Verwendung von FormattedID aus CA Agile Central aktiviert ist, var USE_FORMATTED_ID = true.
  9. Klicken Sie auf Speichern. Ihre benutzerdefinierte HTML App in CA Agile Central ist nun erstellt.
Übergeordnetes Thema: CA Agile Central-Integration


Verknüpfen von User Stories mit Tests in CA Agile Central

So verknüpfen Sie CA Agile Central User Stories mit Silk Central-Tests:

  1. Wählen Sie in Silk Central das Projekt mit den Tests aus, mit denen Sie die CA Agile Central User Stories verknüpfen möchten.
  2. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  3. Klicken Sie auf die Registerkarte Attribute.
  4. Klicken Sie auf Neues Attribut. Der Dialog Neues Attribut wird angezeigt.
  5. Geben Sie im Textfeld Name den Namen rallyattr ein.
  6. Wählen Sie Text in der Liste Typ aus.
  7. Klicken Sie auf OK, um das neue Attribut zu erstellen.
  8. Weisen Sie das neue Attribut jedem Test, mit dem Sie User Stories aus CA Agile Central verknüpfen möchten, zu.
  9. Legen Sie als Attributwert den Wert FormattedID der CA Agile Central User Story für den jeweiligen Test fest. Wenn Sie einem Test mehrere Stories zuordnen, trennen Sie die IDs durch ein Komma. Leerzeichen zwischen den IDs sind nicht zulässig. Beispiel: US10,US12,US14.
Übergeordnetes Thema: CA Agile Central-Integration


Caliber-Integration

Dieser Abschnitt beschreibt, wie Sie Caliber in Silk Central integrieren.

Wenn Sie die Caliber-Integration konfigurieren möchten, installieren Sie den Caliber-Mandanten auf dem Anwendungsserver und dem Front-End-Server von Silk Central. Außerdem muss die MPX-Unterstützung in Caliber aktiviert werden. Für die Konfiguration der Integration in Caliber müssen Caliber-Anmeldeinformationen definiert werden. Bei der Synchronisierung von Anforderungen zwischen Silk Central und Caliber wird anhand dieser Informationen die Anmeldung bei Silk Central vorgenommen und daher eine Silk Central-Lizenz ausgecheckt. Die Lizenz wird wieder freigegeben, sobald die Synchronisierung abgeschlossen ist. Wir empfehlen Ihnen, einen speziellen Silk Central-Benutzer für die Synchronisierung anzulegen, der von allen Silk Central-Anforderungsintegrationen verwendet werden sollte. Dadurch wird gewährleistet, dass nur eine einzige Caliber-Lizenz für die Synchronisierung eingesetzt wird.

Folgende Caliber Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: Caliber 11.4, 11.5

Anmerkung: Die benutzerdefinierten Caliber-Attribute Multiple selection user list und Multiple selection group list müssen den Silk Central-Testattributstypen und nicht den Listentypen zugeordnet werden.
  • Aktivieren der Integration mit Caliber
    Aktivieren Sie die Integration mit Caliber um Anforderungen zu synchronisieren.
  • Baseline-Unterstützung für Caliber-Integration
    Hier wird beschrieben, wie die aktuelle Baseline oder vorhandene benutzerdefinierte Baselines für Caliber-Integration ausgewählt werden.
  • Behandlung von Testzuordnungen in Caliber
    Hier wird beschrieben, wie Caliber Tests in Silk Central behandelt.
  • Kopieren von integrierten Caliber-Projekten
    Verwalten Sie Caliber-Baselines, um ein Caliber-integriertes Projekt zu kopieren.
  • Erstellen einer Baseline für ein integriertes Caliber-Projekt
    Verwalten Sie Caliber-Baselines, um eine Baseline eines Caliber-integrierten Silk Central-Projekts zu erstellen.
  • Tests aus Szenarien und Simulationen generieren
    Generieren Sie Tests aus den Caliber-Objekten Szenario und Simulation.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Aktivieren der Integration mit Caliber

So aktivieren Sie die Integration mit Caliber:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt für die Integration aus.
  3. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  4. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  5. Klicken Sie auf Neue Anforderungsverwaltungs-Integration.
    Anmerkung: Anstatt nur Veränderungen über das integrierte System zuzulassen, können Sie auch einstellen, dass Anforderungen in Silk Central selbst hinzugefügt, bearbeitet und gelöscht werden können. Sie können Veränderungen direkt in der Benutzeroberfläche von Test Manager zulassen und/oder durch die Silk Central-Webdienste, indem Sie die entsprechenden Kontrollkästchen Anlegen, Bearbeiten und Löschen von Anforderungen über... aktivieren.
    Der Dialog Neue Anforderungsverwaltungs-Integration wird geöffnet.
  6. Wählen Sie Caliber in der Liste aus, und klicken Sie auf OK. Der Dialog Konfiguration bearbeiten wird geöffnet.
  7. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  8. Geben Sie den Hostnamen des Computers ein, auf dem der externe Server installiert ist.
  9. Geben Sie für den Zugriff auf den Anforderungsmanagementserver einen gültigen Benutzernamen und ein Kennwort ein.
  10. Klicken Sie auf Verbindung testen, um die Gültigkeit der Host- und Anmeldeinformationen zu überprüfen. Wenn die Einstellungen richtig sind, wird ein Dialog mit der Meldung angezeigt, dass die Verbindung erfolgreich hergestellt werden konnte. Klicken Sie auf OK, um fortzufahren.
    Anmerkung: Wenn die Verbindung nicht hergestellt werden kann, wenden Sie sich an den Systemadministrator.
  11. Klicken Sie auf OK.
  12. Wählen Sie aus dem Listenfeld Projekt das externe Projekt aus, in das das Silk Central-Projekt integriert werden soll. Die für das ausgewählte Projekt verfügbaren Anforderungstypen werden nun im Feld Anforderungstypen angezeigt. Die für das ausgewählte Projekt verfügbaren Baselines werden automatisch im Feld Baseline angezeigt.
  13. Wählen Sie die Baseline des externen Projekts aus, die in das Silk Central-Projekt integriert werden soll. Die ausgewählten Einträge werden im Dialogfeld Konfiguration bearbeiten angezeigt.
  14. Klicken Sie auf OK.
  15. Wählen Sie mindestens einen Anforderungstyp aus dem externen Projekt aus, der in das Silk Central-Projekt integriert werden soll. Wählen Sie mithilfe von Strg+Klick mehrere Anforderungstypen aus.
  16. Klicken Sie auf OK, um die Einstellungen zu speichern.
Übergeordnetes Thema: Caliber-Integration


Baseline-Unterstützung für Caliber-Integration

Sie können die aktuelle Baseline oder vorhandene benutzerdefinierte Baselines für Caliber-Integration auswählen. Geänderte Anforderungen mit Baseline können nicht in Silk Central importiert werden. Anforderungen, die nicht zur aktuellen Baseline gehören, können in Caliber nur geändert werden, wenn die Version der für die Baseline verwendeten Anforderung geändert wird. Diese Änderungen werden nur in Silk Central-Anforderungen übernommen, wenn eine manuelle oder geplante Synchronisierung durchgeführt wird.

Sie können eine Baseline nach dem Importieren in Silk Central ändern. Sie können die konfigurierte Baseline in eine andere benutzerdefinierte Baseline oder die aktuelle Baseline ändern. Nach dieser Änderung wird bei der nächsten Synchronisierung der Baseline (manuell oder geplant) das Silk Central-Projekt aktualisiert, und die Anforderungen werden entsprechend aktualisiert, erstellt oder gelöscht. Wenn eine Baseline geändert wird, wird eine Meldung angezeigt, die besagt, dass die Änderungen nach der nächsten Synchronisierung wirksam werden.

Übergeordnetes Thema: Caliber-Integration


Behandlung von Testzuordnungen in Caliber

Die zugeordneten Tests werden als Abhängigkeiten synchronisierter Anforderungen in Caliber angezeigt, verwaltet und erstellt.

Die externe Nachverfolgung für Silk Central muss für ein Caliber-Projekt im Bereich Caliber-Administrator aktiviert sein, und es muss der richtige Silk Central-Front-End-Server konfiguriert werden. Klicken Sie auf Bearbeiten, um die externe Silk Central-Nachverfolgung für das richtige Projekt im Bereich Caliber-Administrator zu bearbeiten.

Wird ein Projekt mit einem Silk Central-Projekt synchronisiert, werden die den synchronisierten Silk Central-Anforderungen zugeordneten Tests als Abhängigkeiten der Caliber-Anforderungen angezeigt. Beim Bearbeiten dieser Zuordnungen in Silk Central, sind die Änderungen sofort in Caliber sichtbar.

Übergeordnetes Thema: Caliber-Integration


Kopieren von integrierten Caliber-Projekten

So behandeln Sie Caliber-Baselines beim Kopieren von Silk Central-Projekten:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  3. Überprüfen Sie, ob die gewünschte Baseline ausgewählt ist.
    Anmerkung: Wenn eine Baseline geändert wird, müssen Sie eine Synchronisierung vornehmen, um die Projektanforderungen mit den Baseline-Änderungen zu aktualisieren, bevor Sie ein entsprechendes Silk Central-Projekt kopieren können. Die Integrationskonfiguration wird nur kopiert, wenn eine andere Baseline als die aktuelle Baseline ausgewählt ist. Wenn Sie die aktuelle Baseline auswählen, müssen Sie festlegen, ob Sie die Integrationskonfiguration im ursprünglichen Projekt beibehalten oder in das kopierte Projekt verschieben möchten.
  4. Wenn die zu speichernde Baseline nicht ausgewählt ist, klicken Sie auf Konfiguration bearbeiten. Der Dialog Konfiguration bearbeiten wird angezeigt.
  5. Klicken Sie neben dem Feld Projektname auf Durchsuchen. Der Dialog Projekte durchsuchen wird geöffnet.
  6. Wählen Sie die zu speichernde Baseline aus, und bestätigen Sie Ihre Auswahl.
  7. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  8. Klicken Sie auf Projekt kopieren in der Spalte Aktionen des Projekts, das Sie kopieren möchten.
    Anmerkung: Weitere Informationen zum Kopieren eines Projekts finden Sie in den Themen zur Verwaltung in diesem Hilfesystem.
    Der Dialog Projekt kopieren wird angezeigt.
  9. Wählen Sie die Elemente aus, die in das neue Projekt kopiert werden sollen, und bestätigen Sie Ihre Auswahl.
  10. Wenden Sie die Baseline, mit der Sie weiterhin arbeiten möchten, auf das Silk Central-Projekt an.
    Anmerkung: Nach dem Kopieren eines Projekts sind das ursprüngliche Projekt und die Kopie identisch. Definieren Sie, mit welchem Projekt Sie weiterhin arbeiten möchten, indem Sie die entsprechende Baseline auf dieses Projekt anwenden.
Übergeordnetes Thema: Caliber-Integration


Erstellen einer Baseline für ein integriertes Caliber-Projekt

So erstellen Sie eine Baseline eines Caliber-integrierten Silk Central-Projekts:

  1. Erstellen Sie eine Baseline des Silk Central-Projekts. Sie werden während des Prozesses in Silk Central gefragt, ob die neue Baseline in Caliber integriert werden soll.
  2. Klicken Sie auf Ja. Wenn die neue Baseline erstellt ist, wird der Dialog Baseline Projekt - Projekteinstellungen bearbeiten geöffnet.
  3. Klicken Sie auf Bearbeiten, um die Integrationskonfiguration zu ändern.

    Der Dialog Konfiguration bearbeiten wird geöffnet.

  4. Klicken Sie neben dem Feld Projektname auf Durchsuchen. Der Dialog Projekte durchsuchen wird geöffnet.
  5. Wählen Sie ein Caliber-Projekt, eine Baseline und den Anforderungstyp für die Synchronisierung aus.
  6. Klicken Sie auf OK, um den Dialog Projekte durchsuchen zu schließen.
  7. Klicken Sie auf OK, um den Dialog Konfiguration bearbeiten zu schließen.
  8. Klicken Sie auf Fertig stellen, um den Dialog Baseline Projekt - Projekteinstellungen bearbeiten zu schließen.
Übergeordnetes Thema: Caliber-Integration


Tests aus Szenarien und Simulationen generieren

Generieren Sie Tests aus den Caliber-Objekten Szenario und Simulation.

So generieren Sie Tests aus den Caliber-Objekten Szenario und Simulation:

  1. Richten Sie die Integration mit Caliber ein. Weitere Informationen finden Sie unter Aktivieren der Integration in Caliber.
  2. Wählen Sie das Szenario oder die Simulation in der Anforderungshierarchie aus, aus der Sie die Tests erzeugen möchten.
  3. Klicken Sie auf der Registerkarte Eigenschaften auf Tests erzeugen. Das Feld Tests erzeugen wird geöffnet.
  4. Verwenden Sie Strg+Klick oder Umschalttaste+Klick zum Auswählen der Tests, die Sie erzeugen möchten.
  5. Klicken Sie auf Alle erzeugen, um alle Tests zu erzeugen, oder klicken Sie auf Ausgewählte erzeugen, um die ausgewählten Tests zu erzeugen. Die Testhierarchie wird angezeigt.
  6. Wählen Sie den Ordner aus, in dem Sie die neu erstellten Tests hinzufügen möchten.
    Anmerkung: Bereits im ausgewählten Zielordner vorhandene Tests werden nicht erstellt sondern aktualisiert. Es werden keine Tests aus dem Ordner gelöscht.
  7. Klicken Sie auf OK.
Übergeordnetes Thema: Caliber-Integration
Zugehörige Tasks
Synchronisieren von Anforderungen mit einem externen System
Aktivieren der Integration mit Caliber


IBM Rational DOORS-Integration

Dieser Abschnitt beschreibt, wie Sie Silk Central und IBM Rational DOORS integrieren. Silk Central 18.5 bietet eine Out-of-the-box-Unterstützung für IBM Rational DOORS, dank welcher Sie keinerlei zusätzlichen Konfigurationsaufwand in Ihrer DOORS-Installation haben. Falls Sie von Silk Central 15.5 oder einer älteren Version auf die aktuelle Version aktualisieren und benutzerdefinierte dxl-Dateien verwenden, müssen Sie die dxl-Dateien im Ordner lib\dxl Ihrer Silk Central Installation mit Ihren benutzerdefinierten dxl-Dateien überschreiben.

Folgende IBM Rational DOORS Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: IBM Rational DOORS 9.5, 9.6

  • Aktivieren der Integration mit IBM Rational DOORS
    Aktivieren Sie die Integration mit IBM Rational DOORS um Anforderungen zu synchronisieren.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Aktivieren der Integration mit IBM Rational DOORS

Um Silk Central und DOORS zu integrieren, installieren Sie den DOORS-Client auf dem Silk Central Front-End-Server. Falls Sie mehr als einen Front-End-Server Rechner verwenden, muss der DOORS-Client auf jedem Front-End-Server installiert werden, den Sie für die Integration mit DOORS konfiguriert haben.

So aktivieren Sie die Integration mit DOORS:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt für die Integration aus.
  3. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  4. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  5. Klicken Sie auf Neue Anforderungsverwaltungs-Integration.
    Anmerkung: Anstatt nur Veränderungen über das integrierte System zuzulassen, können Sie auch einstellen, dass Anforderungen in Silk Central selbst hinzugefügt, bearbeitet und gelöscht werden können. Sie können Veränderungen direkt in der Benutzeroberfläche von Test Manager zulassen und/oder durch die Silk Central-Webdienste, indem Sie die entsprechenden Kontrollkästchen Anlegen, Bearbeiten und Löschen von Anforderungen über... aktivieren.
    Der Dialog Neue Anforderungsverwaltungs-Integration wird geöffnet.
  6. Wählen Sie IBM Rational DOORS in der Liste aus, und klicken Sie auf OK. Der Dialog Konfiguration bearbeiten wird geöffnet.
  7. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  8. Geben Sie in das Feld RM-Dienst-URL die URL des Silk Central DOORS-Anforderungswebdienstes ein. Der Vorgabewert sollte bereits auf die korrekte Adresse zeigen. Zum Beispiel http://MeinSCHost:19120/services/doorsrequirementsmanagement.
  9. Geben Sie für den Zugriff auf den Anforderungsmanagementserver einen gültigen Benutzernamen und ein Kennwort ein.
  10. Der Standardpfad für die Installation von DOORS wird im Feld DOORS-Installationspfad angezeigt. Wenn dies nicht der richtige Pfad ist, geben Sie das korrekte Ziel innerhalb der Verzeichnisstruktur des Front-End-Servers ein.
  11. Klicken Sie auf Verbindung testen, um die Gültigkeit der Host- und Anmeldeinformationen zu überprüfen. Wenn die Einstellungen richtig sind, wird ein Dialog mit der Meldung angezeigt, dass die Verbindung erfolgreich hergestellt werden konnte. Klicken Sie auf OK, um fortzufahren.
    Anmerkung: Wenn die Verbindung nicht hergestellt werden kann, wenden Sie sich an den Systemadministrator.
  12. Klicken Sie neben dem Feld Projektname auf Durchsuchen, um den Dialog Anforderungstypen durchsuchen zu öffnen. Wählen Sie im Feld Projekt das externe Projekt für die Synchronisierung mit dem Silk Central-Projekt aus.

    Die für das ausgewählte Projekt verfügbaren Anforderungstypen werden nun im Feld Anforderungstypen angezeigt. Wählen Sie die zu synchronisierenden Anforderungstypen aus, und klicken Sie auf OK. Wählen Sie mithilfe von Strg+Klick mehrere Anforderungstypen aus.

    Die ausgewählten Einträge werden nun im Dialog Konfiguration bearbeiten angezeigt.
  13. Klicken Sie auf OK, um die Einstellungen zu speichern.
    ACHTUNG:
    Weil das DOORS-Anwendungsobjekt für die Kommunikation verwendet wird (und dieses Objekt keine Anmeldedaten unterstützt, sondern einen laufenden DOORS-Client erfordert), startet Silk Central jeden DOORS-Client-Prozess mit den angegebenen Anmeldedaten. Dieselben Daten werden dann für alle nachfolgenden Anwendungsobjekte verwendet. Deshalb wird gleichzeitig nur ein Satz von DOORS-Anmeldeinformationen für die Kommunikation unterstützt. Verwenden Sie dieselben DOORS-Anmeldeinformationen für alle Konfigurationen, damit Integrationsaufgaben auf dem Front-End-Server für alle Projekte gleichzeitig durchgeführt werden können. Wenn ein zweiter Anmeldeinformationssatz verwendet wird, arbeitet der zweite Satz erst, nachdem alle Sitzungen mit dem ersten Anmeldeinformationssatz die Zeit überschritten haben.
Übergeordnetes Thema: IBM Rational DOORS-Integration


IBM Rational DOORS Next Generation-Integration

Dieser Abschnitt beschreibt, wie Sie IBM Rational DOORS Next Generation und Silk Central integrieren. Silk Central 18.5 bietet eine Out-of-the-box-Unterstützung für IBM Rational DOORS Next Generation, dank welcher Sie keinerlei zusätzlichen Konfigurationsaufwand in Ihrer DOORS-Installation haben.
Anmerkung: Sämtliche Artefakte des Projekts werden synchronisiert, außer die DOORS-Sammelartefakte Module und Collection selbst.

Folgende IBM Rational DOORS Next Generation-Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: IBM Rational DOORS Next Generation 6.0

  • Aktivieren der Integration mit IBM Rational DOORS Next Generation
    Aktivieren Sie die Integration mit IBM Rational DOORS Next Generation um Anforderungen zu synchronisieren.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Aktivieren der Integration mit IBM Rational DOORS Next Generation

So aktivieren Sie die Integration mit IBM Rational DOORS Next Generation:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt für die Integration aus.
  3. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  4. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  5. Klicken Sie auf Neue Anforderungsverwaltungs-Integration.
    Anmerkung: Anstatt nur Veränderungen über das integrierte System zuzulassen, können Sie auch einstellen, dass Anforderungen in Silk Central selbst hinzugefügt, bearbeitet und gelöscht werden können. Sie können Veränderungen direkt in der Benutzeroberfläche von Test Manager zulassen und/oder durch die Silk Central-Webdienste, indem Sie die entsprechenden Kontrollkästchen Anlegen, Bearbeiten und Löschen von Anforderungen über... aktivieren.
    Der Dialog Neue Anforderungsverwaltungs-Integration wird geöffnet.
  6. Wählen Sie IBM Rational DOORS Next Generation in der Liste aus, und klicken Sie auf OK. Der Dialog Konfiguration bearbeiten wird geöffnet.
  7. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  8. Geben Sie im Feld DOORS Next Generation URL die vollqualifizierte URL des IBM Rational DOORS Next Generation-Servers ein, zum Beispiel https://MeinDOORSHost.MeineDomain.com:9443/rm.
  9. Geben Sie im Feld Authentication URL die vollqualifizierte URL des IBM Rational Jazz Team Servers ein, zum Beispiel https://MeinDOORSHost.MeineDomain.com:9443/jts.
    Anmerkung: Der neue IBM Rational Authentication Server wird für die Authentifizierung nicht unterstützt, nur der IBM Rational Jazz Team Server.
  10. Geben Sie für den Zugriff auf den IBM Rational DOORS Next Generation-Server einen gültigen Benutzernamen und ein Kennwort ein.
  11. Klicken Sie auf Verbindung testen, um die Gültigkeit der Host- und Anmeldeinformationen zu überprüfen. Wenn die Einstellungen richtig sind, wird ein Dialog mit der Meldung angezeigt, dass die Verbindung erfolgreich hergestellt werden konnte. Klicken Sie auf OK, um fortzufahren.
    Anmerkung: Wenn die Verbindung nicht hergestellt werden kann, wenden Sie sich an den Systemadministrator.
  12. Klicken Sie neben der Projektname-Liste auf Laden um die Liste mit den verfügbaren DOORS-Projekten zu füllen. Wählen Sie das externe Projekt aus, mit dem das Silk Central-Projekt synchronisiert werden soll.
  13. Klicken Sie auf OK, um die Einstellungen zu speichern.
Übergeordnetes Thema: IBM Rational DOORS Next Generation-Integration


IBM Rational RequisitePro-Integration

Die Themen in diesem Abschnitt beschreiben die Integration zwischen IBM Rational RequisitePro und Silk Central.

Wenn Sie die IBM Rational RequisitePro-Integration konfigurieren möchten, installieren Sie den IBM Rational RequisitePro-Client auf dem Front-End-Server von Silk Central.

Folgende IBM Rational RequisitePro-Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: IBM Rational RequisitePro 7.1.3, 7.1.4

  • Aktivieren der Integration mit IBM Rational RequisitePro
    Aktivieren Sie die Integration mit IBM Rational RequisitePro um Anforderungen zu synchronisieren.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Aktivieren der Integration mit IBM Rational RequisitePro

Anmerkung: Es kann nur eine IBM Rational RequisitePro-Integration pro Projekt konfiguriert werden.

So aktivieren Sie die Integration mit IBM Rational RequisitePro:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt für die Integration aus.
  3. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  4. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  5. Klicken Sie auf Neue Anforderungsverwaltungs-Integration.
    Anmerkung: Anstatt nur Veränderungen über das integrierte System zuzulassen, können Sie auch einstellen, dass Anforderungen in Silk Central selbst hinzugefügt, bearbeitet und gelöscht werden können. Sie können Veränderungen direkt in der Benutzeroberfläche von Test Manager zulassen und/oder durch die Silk Central-Webdienste, indem Sie die entsprechenden Kontrollkästchen Anlegen, Bearbeiten und Löschen von Anforderungen über... aktivieren.
    Der Dialog Neue Anforderungsverwaltungs-Integration wird geöffnet.
  6. Wählen Sie IBM Rational RequisitePro in der Liste aus, und klicken Sie auf OK. Der Dialog Konfiguration bearbeiten wird geöffnet.
  7. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  8. Geben Sie den Projektpfad (UNC) zum Rechner ein, auf dem der externe Server installiert ist.
  9. Geben Sie den UNC-Benutzernamen und das UNC-Kennwort für den Computer ein, auf dem der externe Server installiert ist.
  10. Geben Sie für den Zugriff auf den Anforderungsmanagementserver einen gültigen Benutzernamen und ein Kennwort ein.
  11. Klicken Sie auf Verbindung testen, um die Gültigkeit der Host- und Anmeldeinformationen zu überprüfen. Wenn die Einstellungen richtig sind, wird ein Dialog mit der Meldung angezeigt, dass die Verbindung erfolgreich hergestellt werden konnte. Klicken Sie auf OK, um fortzufahren.
    Anmerkung: Wenn die Verbindung nicht hergestellt werden kann, wenden Sie sich an den Systemadministrator.
  12. Klicken Sie auf Pakete & Anforderungstypen bearbeiten.

    Die ausgewählten Einträge werden im Dialog Konfiguration bearbeiten angezeigt.

    Anmerkung: Nur die Anforderungen der explizit ausgewählten Pakete werden synchronisiert. Wenn Sie ein übergeordnetes Paket auswählen, werden dessen untergeordnete Pakete nicht ausgewählt.
    Der Dialog Pakete & Anforderungstypen durchsuchen wird geöffnet. Die für das ausgewählte Projekt verfügbaren Pakete und Anforderungstypen werden nun in den entsprechenden Listenfeldern Pakete und Anforderungstypen angezeigt.
  13. Wählen Sie im Listenfeld Pakete mindestens ein Paket aus dem externen Projekt aus, das in das Silk Central-Projekt integriert werden soll. Wählen Sie mithilfe von Strg+Klick mehrere Pakete aus.
  14. Wählen Sie im Listenfeld Anforderungstypen mindestens einen Anforderungstyp aus dem externen Projekt aus, der in das Silk Central-Projekt integriert werden soll. Wählen Sie mithilfe von Strg+Klick mehrere Anforderungstypen aus.
  15. Klicken Sie auf OK. Der Dialog Pakete & Anforderungstypen durchsuchen wird geschlossen.
  16. Klicken Sie auf OK, um die Einstellungen zu speichern.
Übergeordnetes Thema: IBM Rational RequisitePro-Integration


SAP Solution Manager-Integration

Bitte kontaktieren Sie Ihren Verkaufsvertreter, um das SAP Solution Manager-Plug-In zu erwerben.

SAP Solution Manager ermöglicht den technischen Support für verteilte Systeme. Dazu gehören die Bereitstellung von Lösungen, die Bedienung sowie die kontinuierliche Verbesserung. SAP Solution Manager ist eine zentralisierte, robuste Lösung für Anwendungsmanagement und -verwaltung, die eine Kombination von Tools, Inhalten und direktem SAP-Zugriff bietet, um die Zuverlässigkeit von Lösungen zu verbessern und die Gesamtbetriebskosten zu reduzieren. Weitere Informationen zu SAP Solution Manager finden Sie in der Dokumentation von SAP Solution Manager.

Durch die Integration von Silk Central und SAP Solution Manager können SAP Solution Manager-Geschäftsprozesse und -Vorfälle als Silk Central-Anforderungen und -Fehler synchronisiert werden.

  • Systemanforderungen für die SAP Solution Manager Integration
    Hier werden die Systemanforderungen des Plug-Ins zur Integration von SAP Solution Manager beschrieben.
  • Konfigurieren von SAP Solution Manager
    Hier wird angegeben, wo Sie sich über die Konfiguration von SAP Solution Manager zur Integration mit Silk Central informieren können.
  • Hinzufügen von SAP Solution Manager-Fehlerverfolgungsprofilen
    Beschreibt das Erstellen eines Fehlerverfolgungsprofils für SAP Solution Manager.
  • Aktivieren der Anforderungsintegration in SAP Solution Manager
    Hier wird beschrieben, wie die Anforderungsintegration in SAP Solution Manager aktiviert werden kann.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Systemanforderungen für die SAP Solution Manager Integration

Für das Plug-In zur Integration von SAP Solution Manager gelten die folgenden Systemanforderungen:

  • Silk Central 12,1 oder höher
  • SAP Solution Manager 7.1
  • Der Silk Central Integration Hub für SAP Solution Manager muss in SAP Solution Manager installiert sein.
Übergeordnetes Thema: SAP Solution Manager-Integration


Konfigurieren von SAP Solution Manager

Konfigurieren von SAP Solution Manager, um die Integration mit Silk Central zu ermöglichen.

Weitere Informationen finden Sie unter Configuration_Guide_SilkCentral_Integration_Hub_for_SAP.pdf und User_Guide_SilkCentral_Integration_Hub_for_SAP.pdf im Lieferumfang des SAP Solution Manager Plug-Ins.

Damit für diese Integration gültige Verknüpfungen von SAP Solution Manager zu Silk Central verwendet werden können, muss der Front-End-Server von Silk Central einen gültigen vollqualifizierten Namen aufweisen.

Übergeordnetes Thema: SAP Solution Manager-Integration


Hinzufügen von SAP Solution Manager-Fehlerverfolgungsprofilen

So fügen Sie ein SAP Solution Manager-Fehlerverfolgungsprofil hinzu:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Fehlerverfolgung. Die Seite Fehlerverfolgung wird angezeigt. Hier werden alle Fehlerverfolgungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil, um den Dialog Neues Fehlerverfolgungsprofil zu öffnen.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Geben Sie eine Beschreibung für das neue Profil ein.
  6. Wählen Sie in dem Listenfeld Typ die Option SAP Solution Manager aus.
  7. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  8. Geben Sie die URL des Webdiensts Z-SCTM_ADAPTER von SAP Solution Manager ein.
  9. Klicken Sie auf Projekt laden, um alle Projekte vom Server zu laden und das Listenfeld Projekt zu füllen. Wählen Sie dann im Listenfeld Projekt ein Projekt aus.
  10. Klicken Sie auf Standard-Meldungstyp laden, um alle möglichen Meldungstypen zu laden und das Listenfeld Standard-Meldungstyp auszufüllen.
  11. Wählen Sie einen Meldungstyp aus dem Listenfeld Standard-Meldungstyp aus. Wenn Sie Links zu vorhandenen Incidents in SAP Solution Manager erstellen und den Meldungstyp nicht angeben, wird dieser Typ nicht dafür verwendet.
  12. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  13. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: SAP Solution Manager-Integration


Aktivieren der Anforderungsintegration in SAP Solution Manager

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt für die Integration aus.
  3. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  4. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  5. Klicken Sie im Abschnitt SAP Solution Manager auf Konfigurieren.
  6. Geben Sie die URL des Z_SCTM_ADAPTER-Webdiensts von SAP Solution Manager ein.
  7. Geben Sie Ihren Benutzernamen und Ihr Kennwort ein.
  8. Klicken Sie auf Verbindung testen, um die Gültigkeit der eingegebenen Host- und Benutzeranmeldeinformationen zu überprüfen. Wenn die Einstellungen korrekt sind, wird die Meldung Testverbindung war erfolgreich angezeigt.
  9. Klicken Sie auf Laden, um alle verfügbaren Projekte zu laden und das richtige Projekt auszuwählen.
  10. Optional: Aktivieren Sie das Kontrollkästchen Erstellen von Anforderungen ohne Zuordnung zulassen, damit die Erstellung und die Bearbeitung nicht zugeordneter Anforderungen in Silk Central-Projekten für eine Integration konfiguriert sind.
  11. Klicken Sie auf OK, um zu bestätigen und den Dialog zu schließen.
Übergeordnetes Thema: SAP Solution Manager-Integration


Arbeiten mit externen Eigenschaften

In diesem Abschnitt wird die Arbeit mit externen Eigenschaften in Silk Central beschrieben.

  • Bearbeiten externer Eigenschaften
    Bearbeiten Sie externe Eigenschaften.
  • Anzeigen externer Eigenschaften
    Zeigen Sie externe Eigenschaften an.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Bearbeiten externer Eigenschaften

So bearbeiten Sie externe Eigenschaften:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie die Anforderung aus, deren externe Eigenschaften bearbeitet werden sollen.
  3. Klicken Sie auf die Registerkarte Eigenschaften. Auf der Seite Eigenschaften werden die Eigenschaften der ausgewählten Hierarchieelemente angezeigt.
  4. Klicken Sie auf Externe Eigenschaften bearbeiten. Das Dialogfeld Externe Eigenschaften bearbeiten wird geöffnet. Hier werden alle Eigenschaften der externen Anforderung angezeigt. Nehmen Sie die gewünschten Änderungen vor.
    Anmerkung: Für die Eigenschaften, die bearbeitet werden können, sind in diesem Dialogfeld Eingabefelder und Steuerelemente vorhanden. Wenn für ein Attribut eine Zuordnungsregel vorhanden ist, wird nach seinem Namen ein Sternchen (*) angezeigt.
  5. Klicken Sie auf OK, um die Änderungen zu speichern und das Dialogfeld zu schließen.
Übergeordnetes Thema: Arbeiten mit externen Eigenschaften


Anzeigen externer Eigenschaften

So zeigen Sie externe Eigenschaften an:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie die Anforderung aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften. Auf der Seite Eigenschaften werden die Eigenschaften der ausgewählten Hierarchieelemente angezeigt.
  4. Klicken Sie auf Externe Eigenschaften anzeigen. Das Dialogfeld Externe Eigenschaften anzeigen wird geöffnet. Hier werden alle Eigenschaften der externen Anforderung angezeigt.
  5. Schließen Sie das Dialogfeld.
Übergeordnetes Thema: Arbeiten mit externen Eigenschaften


Bearbeiten von Eigenschaftszuordnungen

Mit der Zuordnungsfunktion können Eigenschaften zwischen Silk Central und einem externen Anforderungsverwaltungssystem zugeordnet werden. So könnte z. B. die benutzerdefinierte Anforderungseigenschaft User in Silk Central mit der Caliber-Eigenschaft User_ID identisch sein. Durch das Zuordnen dieser beiden Eigenschaften wird gewährleistet, dass beim Hochladen und Importieren von Anforderungen die richtigen Werte übernommen werden. Sind mehrere Anforderungstypen vorhanden, müssen Sie jeden Typ separat zuordnen.

Anmerkung: Wenn Sie die Zuordnungsfunktion nicht verwenden, werden nur der Name und die Beschreibung der Anforderung zugeordnet.

So bearbeiten Sie eine Eigenschaftszuordnung:

Anmerkung: Folgendes trifft nur auf synchronisierte Eigenschaften mit booleschen Werten zu: Da Silk Central boolesche Datentypen nicht unterstützt, müssen Sie eine Einfachauswahlliste mit den folgenden zwei Listenelementen erstellen:
  • Name = Ja, Numerisches Gewicht = 1
  • Name = Nein, Numerisches Gewicht = 0
Anmerkung: Wenn Sie Listen ordnen, müssen Eigenschaften von beiden Produkten gleich bezeichnete Optionen für jedes Listenelement aufweisen. Die Groß-/Kleinschreibung muss beachtet werden.
  1. Wählen Sie das Projekt aus.
  2. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  3. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  4. Klicken Sie auf Eigenschaftszuordnung bearbeiten des konfigurierten externen Systems. Der Dialog Eigenschaftszuordnung bearbeiten wird geöffnet.
  5. Wählen Sie in der Liste Anforderungstypen den externen Anforderungstyp aus. Alle benutzerdefinierten Anforderungen mit diesem Typ werden dann im Auswahlfeld darunter angezeigt.
  6. Wählen Sie die benutzerdefinierte Anforderungseigenschaft aus, die Sie zuordnen möchten.
  7. Wählen Sie im rechten Listenfeld die benutzerdefinierte Silk Central-Eigenschaft aus, die der ausgewählten externen Eigenschaft zugeordnet werden soll.
  8. Klicken Sie auf Zuordnung hinzufügen, um die Zuordnung vorzunehmen. Das Ergebnis wird im Feld Benutzerdefinierte Eigenschaftszuordnung angezeigt.
  9. Im Feld System-Eigenschaftszuordnung werden die beiden vorkonfigurierten Zuordnungen für den Namen und die Beschreibung der Anforderung angezeigt, die nicht entfernt werden können.
  10. Klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Löschen von Eigenschaftszuordnungen

So löschen Sie eine Eigenschaftszuordnung:

  1. Wählen Sie das Projekt aus.
  2. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  3. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  4. Klicken Sie auf Eigenschaftszuordnung bearbeiten des konfigurierten externen Systems. Der Dialog Eigenschaftszuordnung bearbeiten wird geöffnet.
  5. Wählen Sie im Feld Benutzerdefinierte Eigenschaftszuordnung die Zuordnung aus, die Sie löschen möchten.
  6. Klicken Sie auf Zuordnung entfernen.
  7. Klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Deaktivieren einer Anforderungsverwaltungsintegration

So deaktivieren Sie eine Integrationskonfiguration:

  1. Wählen Sie das Projekt aus.
  2. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  3. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  4. Klicken Sie auf die Schaltfläche Konfiguration deaktivieren des Anforderungsverwaltungssystems, dessen Integration deaktiviert werden soll.
Alle Integrationsdaten und -funktionen werden deaktiviert, aber nicht aus dem Projekt entfernt.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Entfernen einer Anforderungsverwaltungsintegration

So entfernen Sie eine Anforderungsverwaltungsintegration:

  1. Wählen Sie das Projekt aus.
  2. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  3. Klicken Sie auf die Registerkarte Anforderungsverwaltung.
  4. Klicken Sie auf Konfiguration entfernen für das Anforderungsverwaltungstool, für das Sie die Integration entfernen möchten. Diese Schaltfläche ist nur verfügbar, wenn die Konfiguration deaktiviert ist. Das Dialogfeld Externe Zuordnung entfernen wird geöffnet.
  5. Klicken Sie auf Ja.
Die Konfigurationsdaten werden dann aus der Datenbank entfernt.
Übergeordnetes Thema: Integration von Anforderungsverwaltungssystemen


Filter

Filter sind eine effiziente Möglichkeit, nur die relevanten Informationen anzuzeigen und die nicht benötigten Details auszublenden. Durch Filter werden nur die relevanten Elemente hervorgehoben. So können Sie Anforderungen, Testelemente und Testsuiten schnell sortieren. Durch globale Filter können Sie komplexe Filterkriterien erstellen, die in allen Bereichen von Silk Central zur Verfügung stehen. Sie brauchen dann nicht jedes Mal ein Filterkriterium zu definieren, wenn Sie eine Liste filtern möchten.

Sie können neue Filter erstellen, vorhandene Filter bearbeiten, Filter bearbeiten, Filter löschen oder die Filterfunktion auf Projektebene deaktivieren. Für Projekte sind keine Standardfilter vorhanden. Sie können über die Symbolleisten in den Silk Central-Bereichen und im Bereich Projekteinstellungen auf Filter zugreifen und sie bearbeiten.

Anmerkung: Filter können nicht für Berichte verwendet werden. Mit dem Filter Letzte Änderungen können Sie die Änderungen anzeigen, die seit Ihrer letzten Bestätigung von anderen Benutzern an den Tests im Projekt vorgenommen wurden. Mit den beiden rechten Schaltflächen in der Symbolleiste des Bereichs Tests (Änderungen anzeigen/Alle anzeigen und Bestätigen) können dann weitere Aktionen durchgeführt werden. Ihr Systemadministrator kann E-Mail-Benachrichtigungen zur Meldung von Änderungen der Tests einrichten. Die Benachrichtigungen enthalten Links, über die Sie direkt zu einer Ansicht mit den letzten Änderungen gelangen.
  • Erstellen von Filtern
    Erstellen eines Filters, um auf benötigte Informationen einzugrenzen.
  • Erstellen von erweiterten Filtern
    Hier wird beschrieben, wie erweiterte benutzerdefinierte Filter erstellt werden.
  • Bearbeiten von Filtern
    Bearbeiten eines Filters, um auf benötigte Informationen einzugrenzen.
  • Kopieren von Filtern
    Kopieren Sie einen Filter, um ihn zu bearbeiten und aus der Kopie einen neuen Filter zu erstellen.
  • Löschen von Filtern
    Löschen Sie einen Filter, wenn Sie die Informationsteilmenge nicht mehr benötigen.
  • Globale Filter - Details
    Details für globale Filter
  • Letzte Änderungen
    Hiermit können Sie effizient Änderungen und Neueinträge, die andere Benutzer an Anforderungen, Tests oder Testsuiten innerhalb des Projekts seit Ihrer letzten Änderungsbestätigung vorgenommen haben, anzeigen und bestätigen.
  • Anwenden von Filtern
    Wenden Sie einen benutzerdefinierten Filter auf die ausgewählte Hierarchie an.
Übergeordnetes Thema: Konfigurieren von Anforderungseigenschaften und Integrationen
Übergeordnetes Thema: Konfigurieren von Testeigenschaften und Integrationen
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten
Übergeordnetes Thema: Projekteinstellungen


Erstellen von Filtern

So erstellen Sie einen Filter:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Filter, um die Liste der aktuellen Filter anzuzeigen.
  3. Klicken Sie auf Neuer Filter. Das Dialogfeld Neuer Filter wird angezeigt.
  4. Geben Sie einen Namen für den neuen Filter ein. Dieser Name wird in den Listenfeldern angezeigt, wenn der Filter verfügbar ist.
  5. Wählen Sie in der Liste eine Kategorie aus, um den Filter in den Bereichen Anforderungen, Tests oder Ausführungsplanung von Silk Central verfügbar zu machen.
  6. Optional: Geben Sie eine Beschreibung für den neuen Filter ein.
  7. Optional: Aktivieren Sie das Kontrollkästchen Sichtbar für andere Benutzer, wenn der Filter für andere Benutzer sichtbar sein soll.
  8. Optional: Aktivieren Sie das Kontrollkästchen Bearbeitbar für andere Benutzer, wenn der Filter durch andere Benutzer bearbeitbar sein soll.
    Anmerkung: Wenn die Kontrollkästchen Sichtbar für andere Benutzer und Bearbeitbar für andere Benutzer aktiviert sind, ist der Filter öffentlich. Um nicht öffentliche (private) Filter zu löschen, müssen Sie der Besitzer des Filters sein oder die Berechtigung Löschen der privaten Filter anderer Benutzer haben.
  9. Wählen Sie aus der Liste Auswahlkriterien eine Kategorie von Filterkriterien aus. Die verfügbaren Auswahlkriterien richten sich nach der ausgewählten allgemeinen Filterkategorie.
    Anmerkung: Sie können auch Filter kombinieren, indem Sie Verschachtelter Testfilter oder Verschachtelter Anforderungsfilter auswählen. Durch die Auswahl einer dieser Kategorien, können Sie einem neuen Filter einen bestehenden Filter hinzufügen.
  10. Wählen Sie aus den jeweiligen Listen Eigenschaft, Operator und Wert für den Filter aus.
    Eigenschaft
    Die verfügbaren Eigenschaften richten sich nach der im vorherigen Schritt ausgewählten Filterkategorie. Legen Sie hier die Eigenschaft für den Filter fest. Wenn Sie eine Attributkategorie auswählen, werden in der Liste die benutzerdefinierten Attribute angezeigt.
    Operator
    Legen Sie hier den Filteroperator fest. Die verfügbaren Operatoren richten sich nach dem ausgewählten Eigenschaftstyp. Wenn Sie z. B. eine Eigenschaft mit dem Typ "String" auswählen, stehen die folgenden Operatoren zur Verfügung:
    Operator | Beschreibung
    = Die Zeichenfolge ist mit dem angegebenen Wert identisch.
    nicht | Die Zeichenfolge ist nicht mit dem angegebenen Wert identisch.
    enthält | Die Zeichenfolge enthält den angegebenen Wert.
    Enthält nicht | Die Zeichenfolge enthält den angegebenen Wert nicht.
    Wert
    Geben Sie den Wert für den Filter ein. Je nach dem ausgewählten Eigenschaftstyp handelt es sich bei dem Wert um eine Zeichenfolge, die in das Feld eingegeben werden kann, oder um vordefinierte Werte, die Sie aus der Liste auswählen können. In Strings können die Platzhalter * (beliebig viele Zeichen) und "?" (genau ein Zeichen) verwendet werden.
  11. Optional: Klicken Sie auf Hinzufügen, wenn Sie weitere Filterkategorien hinzufügen möchten. Wiederholen Sie die vorhergehenden Schritte, um die neuen Kategorien zu definieren.
    Anmerkung: Wenn Sie mehrere Filterkategorien konfigurieren, legen Sie zusätzlich fest, ob eine Kategorie (ODER-Beziehung) oder alle Kategorien (UND-Beziehung) erfüllt werden müssen. Wählen Sie dazu UND oder ODER aus. Verschachtelte UND- und ODER-Beziehungen sind nicht möglich.
  12. Optional: Wenn Sie nicht benötigte Filterkategorien entfernen möchten, klicken Sie auf Entfernen. Dadurch wird die letzte Filterkategorie entfernt.
  13. Klicken Sie auf OK, um den neuen Filter zu speichern, oder brechen Sie den Vorgang mit Abbrechen ab.
Übergeordnetes Thema: Filter


Erstellen von erweiterten Filtern

Sie können in einem erweiterten Filter mehrere einfache Filter kombinieren. Dadurch sind komplexe Filter möglich, die mehrere Filterkriterien gleichzeitig anwenden.

So erstellen Sie einen erweiterten benutzerdefinierten Filter:

  1. Wählen Sie aus dem Menü den gewünschten Bereich aus: Anforderungen, Tests oder Ausführungsplanung.
  2. Klicken Sie in der Symbolleiste auf [image] (Neuer Filter). Das Dialogfeld Neuer Filter wird angezeigt.
  3. Fall erforderlich, klicken Sie auf Erweitert, um das gesamte Dialogfeld anzuzeigen.
  4. Klicken Sie auf Hinzufügen, damit eine zweite Gruppe von Filtereinstellungen angezeigt wird.
  5. Wählen Sie einen logischen Operator für die Anwendung der Filterabfragen aus. Verknüpfen Sie die Filterkriterien mit dem Operator UND, wenn beide Kriteriengruppen erfüllt werden müssen. Wenn Sie den Operator ODER auswählen, muss nur eine von beiden Kriteriengruppen erfüllt werden.
  6. Wenn Sie eine Filterzeichenfolge löschen möchten, klicken Sie auf Löschen.
  7. Wenn eine weitere Gruppe von Filtereinstellungen angezeigt werden soll, klicken Sie auf Hinzufügen. Um eine nicht benötigte Gruppe von Filtereinstellungen zu entfernen, klicken Sie auf Entfernen.
Übergeordnetes Thema: Filter


Bearbeiten von Filtern

So bearbeiten Sie einen Filter:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Filter, um die Liste der aktuellen Filter anzuzeigen.
  3. Klicken Sie auf den Namen des Filters, den Sie bearbeiten möchten. Der Dialog Filter bearbeiten wird angezeigt.
  4. Ändern Sie den Namen und die Beschreibung des Filters.
  5. Wählen Sie aus der Liste Auswahlkriterien eine Kategorie von Filterkriterien aus. Die verfügbaren Auswahlkriterien richten sich nach der ausgewählten allgemeinen Filterkategorie.
    Anmerkung: Sie können auch Filter kombinieren, indem Sie Verschachtelter Testfilter oder Verschachtelter Anforderungsfilter auswählen. Durch die Auswahl einer dieser Kategorien, können Sie einem neuen Filter einen bestehenden Filter hinzufügen.
  6. Wählen Sie aus den jeweiligen Listen Eigenschaft, Operator und Wert für den Filter aus.
    Eigenschaft
    Die verfügbaren Eigenschaften richten sich nach der im vorherigen Schritt ausgewählten Filterkategorie. Legen Sie hier die Eigenschaft für den Filter fest. Wenn Sie eine Attributkategorie auswählen, werden in der Liste die benutzerdefinierten Attribute angezeigt.
    Operator
    Legen Sie hier den Filteroperator fest. Die verfügbaren Operatoren richten sich nach dem ausgewählten Eigenschaftstyp. Wenn Sie z. B. eine Eigenschaft mit dem Typ "String" auswählen, stehen die folgenden Operatoren zur Verfügung:
    Operator | Beschreibung
    = Die Zeichenfolge ist mit dem angegebenen Wert identisch.
    nicht | Die Zeichenfolge ist nicht mit dem angegebenen Wert identisch.
    enthält | Die Zeichenfolge enthält den angegebenen Wert.
    Enthält nicht | Die Zeichenfolge enthält den angegebenen Wert nicht.
    Wert
    Geben Sie den Wert für den Filter ein. Je nach dem ausgewählten Eigenschaftstyp handelt es sich bei dem Wert um eine Zeichenfolge, die in das Feld eingegeben werden kann, oder um vordefinierte Werte, die Sie aus der Liste auswählen können. In Strings können die Platzhalter * (beliebig viele Zeichen) und "?" (genau ein Zeichen) verwendet werden.
  7. Klicken Sie auf OK, um die geänderte Filterdefinition zu speichern.
Übergeordnetes Thema: Filter


Kopieren von Filtern

Erstellen Sie einen neuen Filter, indem Sie einen bestehenden Filter kopieren und seine Einstellungen ändern.

  1. Wählen Sie aus dem Menü den gewünschten Bereich aus: Anforderungen, Tests oder Ausführungsplanung.
  2. Wählen Sie in der Symbolleiste des ausgewählten Bereichs einen Filter aus dem Listenfeld aus.
  3. Klicken Sie auf Filter kopieren. Der Dialog Filter bearbeiten wird geöffnet, in dem die Einstellungen des Originalfilters angezeigt werden.
  4. Bearbeiten Sie die Eigenschaften des Filters, und klicken Sie auf OK.
Übergeordnetes Thema: Filter


Löschen von Filtern

So löschen Sie einen Filter:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Filter, um die Liste der aktuellen Filter anzuzeigen.
  3. Klicken Sie für den Filter, den Sie löschen möchten, auf Filter löschen. Ein Dialogfeld wird geöffnet, in dem Sie das Löschen bestätigen müssen.
  4. Klicken Sie auf Ja, um den ausgewählten Filter zu löschen. Wenn Sie auf Nein klicken, wird er nicht gelöscht. Wenn Sie auf Ja klicken, wird die Filterliste ohne den gelöschten Filter angezeigt.
Übergeordnetes Thema: Filter


Globale Filter - Details

Mit globalen Filtern können Sie alle Elemente eines Silk Central-Bereichs rasch sortieren, damit nur die relevanten angezeigt werden.

Zum Anzeigen der Details eines globalen Filters klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen > Filter und klicken dann auf den Namen des Filters.

Der Silk Central-Bereich, in dem ein neuer Filter verfügbar ist, wird durch Auswahl der allgemeinen Filterkategorie definiert.

Jeder globale Filter muss eine Eigenschaft, einen Operator und einen Wert aus den jeweiligen Listenfeldern haben:

Eigenschaft
Die verfügbaren Eigenschaften sind von der Filterkategorie abhängig. Legen Sie hier die Eigenschaft für den Filter fest. Wenn Sie eine Attributkategorie auswählen, werden in der Liste die benutzerdefinierten Attribute angezeigt.
Operator
Legen Sie hier den Filteroperator fest. Der Operator ist von dem Eigenschaftstyp abhängig. Wenn Sie z. B. eine Eigenschaft mit dem Typ "String" auswählen, stehen die Operatoren = (ist mit dem definierten Wert identisch), nicht (ist nicht mit dem definierten Wert identisch), enthält (enthält den definierten Wert) und enthält nicht (enthält den definierten Wert nicht) zur Verfügung.
Wert
Der Wert des Filters. Je nach dem ausgewählten Eigenschaftstyp handelt es sich bei dem Wert um eine Zeichenfolge, die in das Feld eingegeben werden kann, oder um vordefinierte Werte, die Sie aus der Liste auswählen können.
Übergeordnetes Thema: Filter


Letzte Änderungen

Der Filter Letzte Änderungen ermöglicht Ihnen, effizient Änderungen und Neueinträge, die andere Benutzer an Anforderungen, Tests oder Testsuiten innerhalb des Projekts seit Ihrer letzten Änderungsbestätigung vorgenommen haben, anzuzeigen und zu bestätigen.

Mit den beiden rechten Schaltflächen in der Symbolleiste des Bereich Tests (Änderungen anzeigen/Alle anzeigen und Bestätigen) können dann weitere Aktionen durchgeführt werden.

Anmerkung: Der Systemadministrator kann E-Mail-Benachrichtigungen zu Änderungen an den Tests konfigurieren. Die Benachrichtigungen enthalten Links, über die Sie direkt zu einer Ansicht mit den letzten Änderungen gelangen.
Übergeordnetes Thema: Filter


Anwenden von Filtern

Wenn Sie einen benutzerdefinierten Filter erstellt und gespeichert haben, können Sie ihn auf die ausgewählte Hierarchie anwenden. Benutzerdefinierte Filter können auf Anforderungen, Tests und Testsuiten angewendet werden. Es werden dann nur die Elemente in der Hierarchie angezeigt, die mit den Filterkriterien übereinstimmen.

Anmerkung: Die zurückgegebenen gefilterten Anforderungen können nur gelesen, nicht aber bearbeitet werden. Die Schaltfläche Eigenschaften bearbeiten ist für gefilterte Anforderungen deaktiviert.

So wenden Sie einen gespeicherten Filter an:

  1. Wählen Sie aus dem Menü den gewünschten Bereich aus: Anforderungen, Tests oder Ausführungsplanung.
  2. Wählen Sie in der Symbolleiste im Listenfeld Filter den gewünschten Filter aus.
  3. Es werden nun alle Elemente angezeigt, die den Filterkriterien entsprechen.
    Anmerkung: Wenn Sie den Filter entfernen und wieder alle Elemente anzeigen möchten, klicken Sie im Listenfeld Filter auf <Kein Filter>.
Übergeordnetes Thema: Filter


Änderungsbenachrichtigung

Sie können sich von Silk Central per E-Mail automatisch benachrichtigen lassen, wenn Anforderungen oder Tests von anderen Benutzern geändert werden. Die Benachrichtigungsfunktion kann von jedem Benutzer aktiviert werden. Nachdem die Benachrichtigung aktiviert wurde, führen Sie eine initiale Bestätigung aus. Ab dann können Sie die Änderungen überprüfen und bestätigen, die seit Ihrer letzten Bestätigung durchgeführt wurden. Um zu viele Benachrichtigungen zu vermeiden, wird bei Änderungen unabhängig von der Anzahl der Änderungen durch andere Benutzer seit der letzten Bestätigung nur eine E-Mail-Benachrichtigung gesendet. Die Benachrichtigungen enthalten Links, über die Sie direkt zu einer Ansicht mit den letzten Änderungen gelangen.

Bevor Sie die Änderungsbenachrichtigung für Anforderungen oder Tests aktivieren können, müssen Sie Ihre E-Mail-Adresse in den Benutzereinstellungen von Silk Central konfigurieren.

Anmerkung: Die Benachrichtigungsfunktion kann nur verwendet werden, wenn ein E-Mail-Server vom Administrator konfiguriert wurde. Wenn die Funktion nicht aktiviert ist, wenden Sie sich an den Silk Central-Administrator.
  • Aktivieren der Änderungsbenachrichtigung
    Durch Aktivieren der Änderungsbenachrichtigung erhalten Sie eine E-Mail-Benachrichtigung, wenn Anforderungen oder Tests von anderen Benutzern geändert werden.
  • Deaktivieren der Änderungsbenachrichtigung
    Durch Deaktivieren der Änderungsbenachrichtigung erhalten Sie keine E-Mail-Benachrichtigung mehr, wenn Anforderungen oder Tests von anderen Benutzern geändert werden.
  • Änderungen, die eine Änderungsbenachrichtigung auslösen
    Hier werden die Änderungen aufgelistet, die zu einer Änderungsbenachrichtigung führen.
  • Benachrichtigungen (Seite)
    Hier werden die Benachrichtigungsereignisse für das aktive Projekt aufgelistet.
Übergeordnetes Thema: Konfigurieren von Anforderungseigenschaften und Integrationen
Übergeordnetes Thema: Konfigurieren von Testeigenschaften und Integrationen
Übergeordnetes Thema: Projekteinstellungen


Aktivieren der Änderungsbenachrichtigung

So aktivieren Sie die Änderungsbenachrichtigung:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Benachrichtigungen.
  3. Klicken Sie auf E-Mail-Benachrichtigung konfigurieren, um den Dialog E-Mail-Benachrichtigung konfigurieren zu öffnen.
  4. Wenn Sie über Änderungen an Anforderungen im ausgewählten Projekt per E-Mail benachrichtigt werden möchten, aktivieren Sie das Kontrollkästchen Änderungen von Anforderungen.
  5. Wenn Sie per E-Mail über Änderungen an Tests im ausgewählten Projekt benachrichtigt werden möchten, aktivieren Sie das Kontrollkästchen Änderungen des Testplans.
  6. Klicken Sie auf OK, um die Änderungen zu speichern, oder klicken Sie auf Abbrechen, um den Vorgang abzubrechen.
Sie erhalten eine E-Mail bezüglich der Änderungen, für die eine Benachrichtigung aktiviert ist.
Übergeordnetes Thema: Änderungsbenachrichtigung


Deaktivieren der Änderungsbenachrichtigung

So deaktivieren Sie die Änderungsbenachrichtigung:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Benachrichtigungen.
  3. Klicken Sie auf E-Mail-Benachrichtigung konfigurieren, um den Dialog E-Mail-Benachrichtigung konfigurieren zu öffnen.
  4. Wenn Sie nicht über Änderungen an Anforderungen im ausgewählten Projekt per E-Mail benachrichtigt werden möchten, deaktivieren Sie das Kontrollkästchen Änderungen von Anforderungen.
  5. Wenn Sie nicht über Änderungen an Tests im ausgewählten Projekt per E-Mail benachrichtigt werden möchten, deaktivieren Sie das Kontrollkästchen Änderungen des Testplans.
  6. Klicken Sie auf OK, um die Änderungen zu speichern, oder klicken Sie auf Abbrechen, um den Vorgang abzubrechen.
Übergeordnetes Thema: Änderungsbenachrichtigung


Änderungen, die eine Änderungsbenachrichtigung auslösen

Wenn Sie die Änderungsbenachrichtigung aktiviert haben, um über Änderungen an Anforderungen oder Tests informiert zu werden, wird nach Ihrer Abmeldung eine E-Mail-Benachrichtigung an Sie gesendet. Eine E-Mail-Benachrichtigung wird an Sie gesendet, wenn eine der folgenden Einstellungen geändert wurde:
Bereich Änderungen
Anforderungen
  • Eine Anforderung wurde erstellt oder gelöscht.
  • Der Name oder die Beschreibung einer Anforderung wurde bearbeitet.
  • Eine Systemeigenschaft wurde bearbeitet.
  • Eine Anforderung wurde als obsolet gekennzeichnet.
  • Eine Anforderung wurde wiederhergestellt.
  • Ein Test wurde einer Anforderung zugeordnet oder von einer Anforderung entfernt.
  • Eine benutzerdefinierte Eigenschaft einer Anforderung wurde erstellt, bearbeitet oder gelöscht.
Tests
  • Ein Container wurde erstellt oder bearbeitet.
  • Ein Produkt wurde bearbeitet.
  • Ein Versionsverwaltungsprofil wurde bearbeitet.
  • "Arbeitsordner leeren" wurde bearbeitet.
  • Der Stammknoten wurde bearbeitet.
  • Das benutzerdefinierte Datenverzeichnis wurde bearbeitet.
  • Das Include-Verzeichnis wurde bearbeitet.
  • Die verborgenen Testeigenschaften wurden bearbeitet.
  • Die Silk Test Classic-Schnittstelle wurde bearbeitet.
  • Ein Testordner wurde erstellt, bearbeitet oder gelöscht.
  • Ein Test wurde erstellt, bearbeitet oder gelöscht.
  • Die geplante Dauer wurde bearbeitet.
  • Ein Testschritt wurde hinzugefügt oder bearbeitet.
Übergeordnetes Thema: Änderungsbenachrichtigung


Benachrichtigungen (Seite)

Projekt:<Projektname> > Projekteinstellungen > Benachrichtigungen

Auf der Seite Benachrichtigungen werden die Benachrichtigungsereignisse für das aktive Projekt aufgelistet. Für jedes Benachrichtigungsereignis werden auf der Seite Benachrichtigungen die folgenden Spalten angezeigt:

Spalte | Beschreibung
Benachrichtigungsereignisse | Der Name des für das aktive Projekt konfigurierten Benachrichtigungsereignisses.
Status | Status des Benachrichtigungsereignisses. Aktiv oder Inaktiv.

Klicken Sie in jedem Abschnitt auf die Schaltfläche Konfigurieren, um die Werte zu bearbeiten.

E-Mail

Bei aktiviertem E-Mail-Benachrichtigungsereignis wird eine E-Mail an den Benutzer gesendet, der das Ereignis aktiviert hat, wenn sich eine angegebene Einstellung das erste Mal ändert.

Anmerkung: Damit der Erhalt von E-Mail-Benachrichtigungen möglich ist, muss eine E-Mail-Adresse angegeben werden.

Anforderungsmarkierung

Sie können Benachrichtigungen für interne und externe Anforderungen unterschiedlich konfigurieren. Die gesamte Kennzeichnung von Anforderungen ist standardmäßig aktiviert. Weitere Informationen finden Sie im Thema Flags.

Übergeordnetes Thema: Änderungsbenachrichtigung


Verwalten von Anforderungen

Erstellen oder bearbeiten Sie Anforderungen, um ein gemeinsames Einverständnis über technische und nicht-technische Anforderungen zwischen Kunde und Entwicklungsteam zu etablieren.
  • Erstellen von Anforderungen
    Hier wird beschrieben, wie Anforderungen direkt in Silk Central erstellt werden und untergeordnete Anforderungen Eigenschaften von ihren übergeordneten Anforderungen übernehmen können.
  • Bearbeiten von Anforderungen
    Hier wird beschrieben, wie die Eigenschaften von Anforderungen bearbeitet werden.
  • Markieren von Anforderungen als obsolet
    Markieren Sie eine Anforderung als obsolet, wenn Sie derzeit nicht benötigt wird und Sie sie nicht löschen möchten.
  • Wiederherstellen obsoleter Anforderungen
    Konvertieren Sie eine obsolete Anforderung in den aktiven Status, um sie erneut zu verwenden.
  • Dauerhaftes Löschen obsoleter Anforderungen
    Löschen Sie eine obsolete Anforderung dauerhaft, wenn Sie nicht beabsichtigen, diese erneut zu reaktivieren.
  • Anforderungsberichte
    In diesen Berichten wird der Status der funktionellen Anforderungen ausgegeben (z. B. Anforderungen zu Kompatibilität, Benutzeroberfläche oder Funktionen), die während der Entwicklung erfüllt werden müssen.
  • Abdeckung
    Hier wird beschrieben, wie die Anforderungen durch Tests abgedeckt werden.
  • Flags
    Hier wird die Verwendung von Flags beschrieben.
Übergeordnetes Thema: Anforderungen


Erstellen von Anforderungen

So erstellen Sie eine neue Anforderung:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Hierarchie Anforderungen eine Anforderung oder den Stammknoten aus.
  3. Klicken Sie in der Symbolleiste auf [image] (Neue Anforderung) um eine neue Anforderung auf derselben hierarchischen Stufe zu erstellen, oder auf [image] (Neue untergeordnete Anforderung) um sie eine Stufe unterhalb der ausgewählten Anforderung zu erstellen. Das Dialogfeld Neue Anforderung wird angezeigt.
  4. Geben Sie einen Namen und eine Beschreibung für die Anforderung ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Optional: Deaktivieren Sie die Kontrollkästchen Vom übergeordneten Element übernehmen. In diesem Fall übernimmt die untergeordnete Anforderung keine Eigenschaften der übergeordneten Anforderung. Standardmäßig sind alle Kontrollkästchen aktiviert.
    Anmerkung: In der Detailansicht auf der Seite Eigenschaften und in der Dokumentansicht sind übernommene Eigenschaften mit Sternchen (*) markiert.
  6. Wählen Sie die Priorität, das Risiko und den Geprüft-Status in den entsprechenden Listen aus.
  7. Wenn benutzerdefinierte Anforderungen definiert wurden, werden diese unterhalb der Liste Geprüft aufgeführt. Geben Sie in das entsprechende Textfeld die benutzerdefinierten Eigenschaftendaten ein, die für diese Anforderung verfolgt werden sollen. Dies ist für geerbte Eigenschaften deaktiviert. Nähere Informationen zum Erstellen, Bearbeiten und Löschen von benutzerdefinierten Anforderungseigenschaften finden Sie unter Benutzerdefinierte Anforderungseigenschaften.
  8. So schließen Sie die Erstellung einer neuen Anforderung ab:
    • Klicken Sie auf OK, um die Anforderung zu erstellen und das Dialogfeld zu schließen.
    • Klicken Sie auf OK und neue Anforderung, um die Anforderung zu erstellen, das Dialogfeld geöffnet zu lassen und Daten zu einer weiteren Anforderung einzugeben.
    • Klicken Sie auf OK und neue untergeordnete Anforderung, um die Anforderung zu erstellen, das Dialogfeld geöffnet zu lassen und Daten zu einer untergeordneten Anforderung einzugeben.
Übergeordnetes Thema: Verwalten von Anforderungen
Zugehörige Konzepte
Benutzerdefinierte Anforderungseigenschaften


Bearbeiten von Anforderungen

So bearbeiten Sie die Eigenschaften einer Anforderung:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Hierarchie Anforderungen eine Anforderung aus.
  3. Klicken Sie in der Symbolleiste auf [image] (Bearbeiten). Sie können auch mit der rechten Maustaste auf eine Anforderung und anschließend auf Bearbeiten klicken, oder erst auf die Registerkarte Eigenschaften und anschließend auf Eigenschaften bearbeiten klicken. Das Dialogfeld Anforderung bearbeiten wird angezeigt.
  4. Geben Sie einen Namen und eine Beschreibung für die Anforderung ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Optional: Deaktivieren Sie die Kontrollkästchen Vom übergeordneten Element übernehmen. In diesem Fall übernimmt die untergeordnete Anforderung keine Eigenschaften der übergeordneten Anforderung. Standardmäßig sind alle Kontrollkästchen aktiviert.
    Anmerkung: In der Detailansicht auf der Seite Eigenschaften und in der Dokumentansicht sind übernommene Eigenschaften mit Sternchen (*) markiert.
  6. Wählen Sie die Priorität, das Risiko und den Geprüft-Status in den entsprechenden Listen aus.
  7. Wenn benutzerdefinierte Anforderungen definiert wurden, werden diese unterhalb der Liste Geprüft aufgeführt. Geben Sie in das entsprechende Textfeld die benutzerdefinierten Eigenschaftendaten ein, die für diese Anforderung verfolgt werden sollen. Dies ist für geerbte Eigenschaften deaktiviert. Nähere Informationen zum Erstellen, Bearbeiten und Löschen von benutzerdefinierten Anforderungseigenschaften finden Sie unter Benutzerdefinierte Anforderungseigenschaften.
  8. Klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Verwalten von Anforderungen
Zugehörige Konzepte
Benutzerdefinierte Anforderungseigenschaften


Markieren von Anforderungen als obsolet

Beim Löschen einer Anforderung wird diese endgültig entfernt. In einigen Fällen ist es sinnvoll, Anforderungen als obsolet zu markieren. Obsolete Anforderungen können verborgen, angezeigt und wiederhergestellt werden.

So markieren Sie eine Anforderung als obsolet:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Hierarchie Anforderungen eine Anforderung aus.
  3. Klicken Sie in der Symbolleiste auf Löschen (Löschen), oder klicken Sie mit der rechten Maustaste auf die Anforderung, und wählen Sie Löschen. Ein Dialogfeld wird angezeigt.
  4. Klicken Sie auf Ja.
    Anmerkung: Das Kontrollkästchen Endgültig löschen ist standardmäßig deaktiviert.
Anmerkung: Die als obsolet markierten Anforderungen werden in der Hierarchie Anforderungen in Kursivschrift angezeigt.

Wenn Sie obsolete Anforderungen anzeigen lassen möchten, klicken Sie in der Hierarchie Anforderungen mit der rechten Maustaste auf eine beliebige Anforderung und anschließend mit der linken Maustaste auf Obsolete Anforderungen anzeigen.

Wenn Sie obsolete Anforderungen verbergen möchten, klicken Sie in der Hierarchie Anforderungen mit der rechten Maustaste auf eine beliebige Anforderung und anschließend mit der linken Maustaste auf Obsolete Anforderungen verbergen.

Übergeordnetes Thema: Verwalten von Anforderungen


Wiederherstellen obsoleter Anforderungen

So stellen Sie eine obsolete Anforderung wieder her:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wenn die obsoleten Anforderungen verborgen sind, klicken Sie in der Hierarchie Anforderungen mit der rechten Maustaste auf eine beliebige Anforderung und anschließend mit der linken Maustaste auf Obsolete Anforderungen anzeigen.
  3. Klicken Sie mit der rechten Maustaste auf die obsolete Anforderung in der Hierarchie Anforderungen, und klicken Sie anschließend auf Wiederherstellen.
Anmerkung: Die als obsolet markierten Anforderungen werden in der Hierarchie Anforderungen in Kursivschrift angezeigt.

Wenn Sie die obsoleten Anforderungen wieder verbergen möchten, klicken Sie in der Hierarchie Anforderungen mit der rechten Maustaste auf eine beliebige Anforderung und anschließend mit der linken Maustaste auf Obsolete Anforderungen verbergen.

Übergeordnetes Thema: Verwalten von Anforderungen


Dauerhaftes Löschen obsoleter Anforderungen

So löschen Sie eine obsolete Anforderung dauerhaft:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wenn die obsoleten Anforderungen verborgen sind, klicken Sie in der Hierarchie Anforderungen mit der rechten Maustaste auf eine beliebige Anforderung und anschließend mit der linken Maustaste auf Obsolete Anforderungen anzeigen.
  3. Wählen Sie in der Hierarchie Anforderungen eine obsolete Anforderung aus.
  4. Klicken Sie in der Symbolleiste auf Löschen (Löschen), oder klicken Sie mit der rechten Maustaste auf die Anforderung, und wählen Sie Löschen. Ein Dialogfeld wird angezeigt.
  5. Klicken Sie auf Ja, um die Anforderung unwiederbringlich zu löschen.
Anmerkung: Die als obsolet markierten Anforderungen werden in der Hierarchie Anforderungen in Kursivschrift angezeigt.

Wenn Sie die obsoleten Anforderungen wieder verbergen möchten, klicken Sie in der Hierarchie Anforderungen mit der rechten Maustaste auf eine beliebige Anforderung und anschließend mit der linken Maustaste auf Obsolete Anforderungen verbergen.

Übergeordnetes Thema: Verwalten von Anforderungen


Anforderungsberichte

In diesen Berichten wird der Status der funktionellen Anforderungen ausgegeben (z. B. Anforderungen zu Kompatibilität, Benutzeroberfläche oder Funktionen), die während der Entwicklung erfüllt werden müssen.

Anforderungen können sich auch auf Produktmanagementziele beziehen, wie z. B. Zuverlässigkeit, Skalierbarkeit und Leistung. Mit den Anforderungsmanagementberichten kann ermittelt werden, ob eine ausreichende Testabdeckung zur Überprüfung der Systemvoraussetzungen während der Entwicklung erzielt wurde. Wenn ein Bericht auf eine Anforderung mit Inhalt im HTML-Format verweist, wird dieser bei der Berichtsausgabe gerendert.

  • Statusberichte
    Hier werden die im Bereich Anforderungen verfügbaren Statusberichte beschrieben.
  • Fortschrittsberichte
    Hier werden die im Bereich Anforderungen verfügbaren Fortschrittsberichte beschrieben.
  • Berichte
    Hier werden die für Anforderungen verfügbaren Dokumentenberichte beschrieben.
  • Bericht über alle zugeordneten Fehler
    Enthält eine detaillierte Liste aller Fehler, die im Zusammenhang mit einer Anforderung in den zugeordneten Tests aufgetreten sind.
Übergeordnetes Thema: Verwalten von Anforderungen
Übergeordnetes Thema: Standardberichte


Statusberichte

Folgende Statusberichte sind im Bereich Anforderungen verfügbar:
Anforderungsstatusübersicht
Eine gruppierte Zusammenfassung aller Anforderungen nach der aktuellen Abdeckung wird ausgegeben. Die Abdeckung wird durch die Statuswerte Bestanden, Fehlgeschlagen, Nicht ausgeführt und Nicht abgedeckt beschrieben.
Anforderungsabdeckung der obersten Ebene
Eine Liste aller Anforderungen der obersten Ebene wird ausgegeben. Für jede Anforderung wird die Anzahl der untergeordneten Anforderungen, die von dem Test abgedeckt bzw. nicht abgedeckt werden, angezeigt.
Status der Anforderungen mit einer höheren Priorität als 'X'
Eine Zusammenfassung aller Anforderungen nach der aktuellen Abdeckung wird ausgegeben. Die Anforderungen werden durch den Parameter Priority eingeschränkt, der die geringste berücksichtigte Priorität festlegt.
Anforderungsauswirkungsanalysebericht
In diesem Bericht werden die Informationen zum Test gruppiert nach der der Anforderung zugeordneten Testsuite angezeigt. Mit diesem Bericht erhalten Benutzer Einblick in Testkomponenten, auf die sich eine Änderung der Anforderung auswirken kann. Der Bericht enthält Name, Status, Datum/Uhrzeit der letzten Ausführung, manuelle Tester, geplante Zeit und Fehler der einzelnen Tests. Die folgenden Statuswerte werden verwendet:
Bestanden
Der Test hat bestanden.
Fehlgeschlagen
Der Test ist fehlgeschlagen.
--
Der Test ist einer Anforderung zugeordnet, wurde jedoch nicht zur Ausführung übermittelt.
Nicht ausgeführt
Der Test ist einer Anforderung zugeordnet und wurde zur Ausführung übermittelt, wurde jedoch noch nicht ausgeführt.
Bericht zur Nachverfolgung der Projektanforderung
Zeigt alle Anforderungen eines Projekts inklusive der zugeordneten Tests und Fehler an. Die folgenden Statuswerte werden verwendet:
Bestanden
Der Test hat bestanden.
Fehlgeschlagen
Der Test ist fehlgeschlagen.
--
Der Test ist einer Anforderung zugeordnet, wurde jedoch nicht zur Ausführung übermittelt.
Nicht ausgeführt
Der Test ist einer Anforderung zugeordnet und wurde zur Ausführung übermittelt, wurde jedoch noch nicht ausgeführt.
Übergeordnetes Thema: Anforderungsberichte


Fortschrittsberichte

Folgende Fortschrittsberichte stehen im Bereich Anforderungen zur Verfügung:
Anforderungsabdeckung in den Builds 'X' bis 'Y'
Eine Zusammenfassung aller Anforderungen nach der aktuellen Abdeckung wird ausgegeben. Die Anforderungen werden durch den Parameter Priority eingeschränkt, der die geringste berücksichtigte Priorität festlegt.
Anforderungsabdeckung der letzten 'X' Tage
Ein Abdeckungstrend wird aus der gesamten Anforderungsabdeckung für 'X' Tage ermittelt.
Spezifische Anforderungsabdeckung der letzten 'X' Tage
Ein Abdeckungstrend wird aus der spezifischen Anforderungsabdeckung für 'X' Tage ermittelt.
Übergeordnetes Thema: Anforderungsberichte


Berichte

Für Anforderungen sind folgende Dokumentenberichte verfügbar:
Alle Anforderungen
Zeigt die vollständigen Informationen zu allen Anforderungen.
Anforderungen mit untergeordneten Anforderungen
Die ausgewählte Anforderung wird mit ihrer Anforderungs-ID angezeigt. Alle Einzelheiten ihrer untergeordneten Anforderungen werden ebenfalls angezeigt.
Übergeordnetes Thema: Anforderungsberichte


Bericht über alle zugeordneten Fehler

Der Bericht Alle zugeordneten Fehler enthält eine detaillierte Liste aller Fehler, die im Zusammenhang mit einer Anforderung in den zugeordneten Tests aufgetreten sind, und erklärt die Beziehung zwischen Anforderungen, zugeordneten Tests und den aufgetretenen Fehlern. Als Eingabeparameter für einen Bericht Alle zugeordneten Fehler wird die Kennung der Anforderung angegeben.

Übergeordnetes Thema: Anforderungsberichte


Abdeckung

In diesem Abschnitt wird beschrieben, wie die Anforderungen durch Tests abgedeckt werden.

  • Abdeckungsmodi
    Hier werden die Abdeckungsmodi beschrieben, die für Anforderungen zur Verfügung stehen.
  • Wechseln zwischen Abdeckungsmodi
    Wechseln Sie zwischen den Modi für direkte und vollständige Abdeckung, um bei der Berechnung der Testabdeckung untergeordnete Anforderungen zu berücksichtigen oder nicht zu berücksichtigen.
  • Abdeckung (Seite)
    Hier wird der Status aller Tests angezeigt, die der Anforderung zugeordnet sind.
Übergeordnetes Thema: Verwalten von Anforderungen


Abdeckungsmodi

Silk Central bietet zwei Modi der Abdeckung. Vollständige und direkte Abdeckung. Der Status einer Anforderung berücksichtigt im Modus der vollständigen Abdeckung den Status von untergeordneten Anforderungen und ermöglicht eine kumulative Ansicht der Tests, die die Anforderung abdecken. Falls mindestens eine der untergeordneten Anforderungen den Status Nicht abgedeckt hat, dann lautet der vollständige Abdeckungsstatus der ausgewählten Anforderung Nicht abgedeckt, selbst wenn die übergeordnete Abdeckung den Status Abgedeckt aufweist. Im vollständigen Abdeckungsmodus kann problemlos überprüft werden, ob alle Anforderungen durch Tests abgedeckt werden.

Der Status einer Anforderung wird im Modus der direkten Abdeckung nur basierend auf dem Status der Tests, die der Anforderung direkt zugeordnet sind, berechnet. Die untergeordneten Anforderungen werden bei den Berechnungen nicht berücksichtigt.

Übergeordnetes Thema: Abdeckung


Wechseln zwischen Abdeckungsmodi

Hier schalten Sie zwischen dem vollständigen und dem direkten Abdeckungsmodus um:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie auf Direkte Abdeckung anzeigen / Vollständige Abdeckung anzeigen, um die direkte oder die vollständige Abdeckung anzuzeigen.
Übergeordnetes Thema: Abdeckung


Abdeckung (Seite)

Anforderungen > Detailansicht > Abdeckung

Auf der Seite Abdeckung, die Sie nur über die Detailansicht öffnen können, werden grundlegende Eigenschaften der ausgewählten Anforderung oder des Projekts angezeigt. Hier wird auch der Status aller Tests angezeigt, die der Anforderung zugeordnet sind, einschließlich der Anzahl und des prozentualen Anteils der bestandenen, fehlgeschlagenen, nicht ausgeführten und nicht abgedeckten Tests. Unter Gesamt wird eine Zusammenfassung der zugewiesenen Tests angezeigt. Die nicht durch Tests abgedeckten Anforderungen werden mit dem Status Nicht abgedeckt angezeigt.

Auf der Seite Detailansicht werden dieselben Abdeckungsstatusinformationen in einem "Thermometerfeld" dargestellt.

Wenn auch der Status der Tests angezeigt werden soll, die den untergeordneten Anforderungen zugeordnet sind, aktivieren Sie das Kontrollkästchen Vollständige Abdeckung.

Anmerkung: Sowohl in der Detailansicht als auch auf der Seite Abdeckung werden die Gesamtwerte der Tests auf der übergeordneten Ebene summiert. Anforderungsgesamtwerte enthalten beispielsweise Tests von untergeordneten Anforderungen, und Projektgesamtwerte enthalten Test von allen Anforderungen.

Auf der Seite Abdeckung werden die folgenden Eigenschaften für jede ausgewählte Anforderung oder jedes ausgewählte Projekt angezeigt.

Eigenschaft | Beschreibung

Anforderungsname

Projektname

 Der Name der Anforderung oder des Projekts.
Priorität | Die Priorität der Anforderung.
Risiko | Das Risiko der Anforderung.
Anzahl Anforderungen (Berechnet) | Die Gesamtzahl der abgedeckten Anforderungen. In dieser Zahl sind keine nicht abgedeckten Anforderungen und Ordner, denen keine Tests zugeordnet sind, enthalten. Dazu gehören beispielsweise Ordner, die die Abdeckung ihrer untergeordneten Anforderungen erben, jedoch selbst keine Anforderung sind.
Anzahl Anforderungen (Gesamt) | Die Gesamtzahl der Anforderungen (einschließlich Ordner) unterhalb der ausgewählten Entität.

Anforderungsstatus

Projektstatus

 Der Status der Anforderung oder des Projekts.
  • Bestanden
  • Fehlgeschlagen
  • Nicht ausgeführt
  • Nicht abgedeckt
Anzahl bestandener Anforderungen | Gesamtzahl und prozentualer Anteil der Anforderungen mit bestandenen Tests im Projekt.
Anzahl fehlgeschlagener Anforderungen | Gesamtzahl und prozentualer Anteil der Anforderungen mit fehlgeschlagenen Tests im Projekt.
Anzahl nicht ausgeführter Anforderungen | Gesamtzahl und prozentualer Anteil der Anforderungen mit nicht ausgeführten Tests im Projekt.
Anzahl nicht abgedeckter Anforderungen | Gesamtzahl und prozentualer Anteil der Anforderungen im Projekt, die nicht durch Tests abgedeckt werden.
Gesamt | Gesamtzahl der Anforderungen im Projekt.
Übergeordnetes Thema: Abdeckung
Zugehörige Verweise
Anforderungs-Dokumentansicht


Flags

An den Flag-Kennzeichnungen kann abgelesen werden, ob eine Anforderung geändert wurde oder überprüft werden muss. Anforderungen mit Flags werden in der Anforderungshierarchie mit Flag-Symbolen gekennzeichnet. In den Anforderungseigenschaften ist auch ein Abschnitt zum Anzeigen von Flag-Informationen vorhanden.

Sie können Flags nach Belieben hinzufügen und entfernen; das Flag ist für jeden sichtbar, der die Anforderung anzeigt. Sie können auch eine Anforderung sowie all ihre untergeordneten Elemente mit einem Flag versehen. Ein Element kann zu einem jeweiligen Zeitpunkt mit nur einem Flag versehen werden; wird ein Element, das bereits über ein Flag verfügt, neuerlich mit einem Flag versehen, wird das erste Flag überschrieben. Änderungen am Flag werden in der Anforderungshistorie festgehalten.

Wenn die Integration mit einem externen Anforderungsmanagementsystem durchgeführt wird, werden auch die Flags von neuen oder aktualisierten externen Anforderungen angezeigt. Die folgenden Beispiele veranschaulichen die Anwendung von Flags für integrierte Anforderungen:

  • Wenn Sie dem Anforderungsmanagementsystem nach einer anfänglichen Synchronisierung eine Anforderung hinzufügen, wird nachfolgend eine erneute Synchronisierung durchgeführt. Wenn die neue Anforderung dem Silk Central hinzugefügt wird, wird sie mit dem Flag added gekennzeichnet. Dieses deutet darauf hin, dass sie während einer Aktualisierung erstellt wurde.
  • Wenn Sie eine Anforderung bearbeiten, die mit Silk Central synchronisiert wurde, wird die Anforderung in Silk Central mit dem Flag updated gekennzeichnet. Dieses deutet darauf hin, dass sie aktualisiert wurde.
  • Festlegen eines Flags
    Versehen Sie eine Anforderung mit einem Flag, um andere darauf hinzuweisen, dass die Anforderung geändert wurde oder überprüft werden muss.
  • Löschen eines Flags
    Löschen Sie ein Flag aus einer Anforderung, wenn alle Änderungen angenommen oder die Anforderungen überprüft wurden.
  • Erstellen eines Filters für Anforderungen mit Flags
    Erstellen Sie einen Filter für Anforderungen mit Flags, um nur die Anforderungen in der Anforderungshierarchie anzuzeigen, für die die Filterbedingung gilt.
Übergeordnetes Thema: Verwalten von Anforderungen
Zugehörige Verweise
Benachrichtigungen (Seite)


Festlegen eines Flags

Versehen Sie eine Anforderung mit einem Flag, um andere darauf hinzuweisen, dass die Anforderung geändert wurde oder überprüft werden muss.

So versehen Sie eine Anforderung mit einem Flag:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. Klicken Sie mit der rechten Maustaste auf die Anforderung, und wählen Sie Flag > Flag setzen. Das Dialogfeld Flag setzen wird geöffnet.
  4. Geben Sie einen Kommentar zum Flag im Feld Kommentar ein.
  5. Wenn alle untergeordneten Elemente der aktuell ausgewählten Anforderung ebenfalls mit einem Flag versehen werden sollen, aktivieren Sie das Kontrollkästchen Flag für alle untergeordneten Anforderungen setzen.
  6. Klicken Sie auf OK.
    Anmerkung: Die Flag-Informationen sind auf der Seite Eigenschaften der Anforderung verfügbar.
Übergeordnetes Thema: Flags
Zugehörige Verweise
Anforderungseigenschaften (Seite)


Löschen eines Flags

Löschen Sie ein Flag aus einer Anforderung, wenn alle Änderungen angenommen oder die Anforderungen überprüft wurden.

So löschen Sie ein Flag aus der Anforderung:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. So löschen Sie ein einzelnes Flag: Klicken Sie mit der rechten Maustaste auf die Anforderung, und wählen Sie Flag > Flag löschen.
  4. So löschen Sie ein Flag für alle untergeordneten Elemente der ausgewählten Anforderung: Klicken Sie mit der rechten Maustaste auf die Anforderung, und wählen Sie Flag > Flag löschen - Untergeordnete Elemente einbeziehen . Die Flag-Informationen werden aus der Seite Eigenschaften der Anforderung entfernt.
Anmerkung: Das Flag lässt sich auch löschen, indem Sie in der Registerkarte Eigenschaften auf die Schaltfläche Flag löschen klicken.
Übergeordnetes Thema: Flags
Zugehörige Verweise
Anforderungseigenschaften (Seite)


Erstellen eines Filters für Anforderungen mit Flags

Erstellen Sie einen Filter für Anforderungen mit Flags, um nur die Anforderungen in der Anforderungshierarchie anzuzeigen, für die die Filterbedingung gilt.

So erstellen Sie einen Filter für Anforderungen mit Flags:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie auf Neuer Filter. Der Dialog Neuer Filter wird geöffnet.
  3. Wählen Sie in der Liste Auswahlkriterien den Eintrag Anforderungseigenschaft.
  4. Wählen Sie aus der Liste Eigenschaft die Option Anforderungsstatus aus.
  5. Wählen Sie aus der Liste Operator = aus.
  6. Wählen Sie einen der folgenden Werte aus der Liste Wert aus:
    Keine
    Kein Flag ausgewählt
    Manuell mit Flags gekennzeichnet
    Benutzer hat manuell ein Flag zu einer Anforderung hinzugefügt.
    Markiert als Neu
    Anforderung wurde erstellt.
    Markierung als Aktualisiert
    Anforderung wurde aktualisiert.
    Obsolet
    Anforderung ist als obsolet gekennzeichnet.
  7. Klicken Sie auf Speichern und Anwenden.
    Anmerkung: Wenn untergeordnete Anforderungen mit Flags versehen sind, aber mindestens eine übergeordnete Anforderung nicht mit Flags versehen ist, wird der vollständige Pfad zu den mit Flags versehenen untergeordneten Anforderungen angezeigt, aber die übergeordneten Anforderungen sind deaktiviert. Sie können das Flag für übergeordnete Anforderungen bei diesem Status weder festlegen noch löschen.
Übergeordnetes Thema: Flags
Zugehörige Verweise
Anforderungseigenschaften (Seite)


Konfigurieren von Anforderungseigenschaften

Konfigurieren Sie Anforderungseigenschaften, Anhänge, Flags und die Abdeckung.

Neben den festgelegten Standardeigenschaften können Sie in Silk Central auch eigene Anforderungseigenschaften erstellen. Diese benutzerdefinierten Anforderungen können – ebenso wie die Standardeigenschaften – im Dialogfeld Anforderung bearbeiten bearbeitet werden.

Klicken Sie zum Bearbeiten benutzerdefinierter Eigenschaften im Menü auf Anforderungen > Anforderungseigenschaften und anschließend auf Neue Anforderungseigenschaft.

Benutzerdefinierte Eigenschaften werden auf der Seite Eigenschaften und in der Dokumentansicht der Anforderungen in der Anforderungsdetailansicht angezeigt.

Weitere Informationen zu benutzerdefinierten Anforderungseigenschaften finden Sie unter Benutzerdefinierte Anforderungseigenschaften.

  • Ersetzen von Anforderungseigenschaften
    Hier wird beschrieben, wie der Eigenschaftswert einer oder mehrerer Anforderungen ersetzt wird.
  • Suchen nach Anforderungseigenschaften
    Verwenden Sie Suchen zum Auffinden von Anforderungseigenschaften, die den Suchkriterien entsprechen.
  • Anforderungseigenschaften (Seite)
    Hier werden allgemeine Informationen zur ausgewählten Anforderung oder zum ausgewählten Projekt angezeigt.
  • Anforderungsanhänge
    Hier wird beschrieben, wie Anforderungsanhänge verwendet werden.
Übergeordnetes Thema: Anforderungen
Zugehörige Konzepte
Benutzerdefinierte Anforderungseigenschaften


Ersetzen von Anforderungseigenschaften

So ersetzen Sie den Eigenschaftswert einer oder mehrerer Anforderungen:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie in der Symbolleiste auf Ersetzen (Ersetzen), oder klicken Sie mit der rechten Maustaste auf eine Anforderung und anschließend mit der linken Maustaste auf Ersetzen. Der Dialog Ersetzen wird angezeigt.
  3. Wählen Sie aus der Liste Suchen in eine Anforderungseigenschaft aus. Die Liste enthält alle standardmäßigen und benutzerdefinierten Eigenschaften.
  4. Im Bereich Suchen nach können Sie Ihre Suchkriterien festlegen. Die Steuerelemente des Bereichs Suchen nach variieren je nach der ausgewählten Eigenschaft. Zum Beispiel: Wenn Sie die Eigenschaft Risiko auswählen, werden zwei Listen angezeigt; wenn Sie die Eigenschaft Beschreibung auswählen, werden ein Textfeld und zwei Kontrollkästchen angezeigt.
  5. Geben Sie im Bereich Ersetzen durch den Wert ein, der die identifizierten Daten ersetzen soll.
  6. Optional: Aktivieren Sie das Kontrollkästchen Groß-/Kleinschreibung beachten, um Groß- und Kleinbuchstaben zu berücksichtigen.
  7. Optional: Aktivieren Sie das Kontrollkästchen Nur ganzes Wort suchen, um ausschließlich vollständige Vorkommen der Zeichenfolge zu berücksichtigen.
  8. Klicken Sie auf OK. Die erste Anforderung, die die Suchkriterien erfüllt, wird in der Hierarchie Anforderungen hervorgehoben.
  9. Klicken Sie auf eine der folgenden Optionen:
    • Ersetzen: Der Eigenschaftswert der hervorgehobenen Anforderung wird ersetzt.
    • Alle ersetzen: Der Eigenschaftswert aller Anforderungen, die den festgelegten Wert enthalten, wird ersetzt.
    • Weitersuchen: Die nächste Anforderung, die den festgelegten Wert enthält, wird hervorgehoben.
    • Rückwärts suchen: Die vorige Anforderung, die den festgelegten Wert enthält, wird hervorgehoben.
    • Erneut ersetzen: Der Dialog Ersetzen wird erneut geöffnet, und Sie können neue Werte festlegen.
    • Schließen: Der Dialog wird geschlossen.
    Anmerkung: Wenn Sie auf Alle ersetzen klicken, werden alle übernommenen Eigenschaften überschrieben. Zudem verlieren untergeordnete Anforderungen in diesem Fall ihre übernommenen Eigenschaften. Verwenden Sie den Befehl Ersetzen nur für eine übergeordnete Anforderung, wenn der neue Wert von der untergeordneten Anforderung übernommen werden soll.
Übergeordnetes Thema: Konfigurieren von Anforderungseigenschaften


Suchen nach Anforderungseigenschaften

Im Bereich Anforderungen können Sie über Suchen nach Anforderungen suchen, die bestimmte Suchkriterien erfüllen. Sie können Eigenschaftsdaten über den Befehl Ersetzen auch durch andere Werte ersetzen. Bei beiden Befehlen kann zum nächsten (Weitersuchen) und zum vorhergehenden Suchtreffer (Rückwärts suchen) gewechselt werden.

So suchen Sie nach einer Anforderung:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie in der Symbolleiste auf Suchen, um das Dialogfeld Suchen zu öffnen.
    Anmerkung: Sie können diesen Befehl auch ausführen, indem Sie mit der rechten Maustaste auf eine Anforderung klicken und Suchen auswählen.
  3. Wählen Sie aus der Liste Suchen in eine Anforderungseigenschaft aus. Die Liste enthält alle standardmäßigen und benutzerdefinierten Eigenschaften.
  4. Im Bereich Suchen nach können Sie Ihre Suchkriterien festlegen. Die Steuerelemente des Bereichs Suchen nach variieren je nach der ausgewählten Eigenschaft. Zum Beispiel: Wenn Sie die Eigenschaft Risiko auswählen, werden zwei Listen angezeigt; wenn Sie die Eigenschaft Beschreibung auswählen, werden ein Textfeld und zwei Kontrollkästchen angezeigt.
  5. Klicken Sie auf OK, um die Suche zu starten. Die erste Anforderung, die den Suchkriterien entspricht, wird in der Hierarchie markiert. Die erste Anforderung, die den Suchkriterien entspricht, wird in der Hierarchie markiert.
  6. Klicken Sie im Dialogfeld Suchen auf Weitersuchen, um in der Liste zur nächsten Anforderung zu wechseln, die mit den Suchkriterien übereinstimmt. Mit der Option Rückwärts suchen im Dialogfeld Suchen können Sie in der Liste zur vorherigen gefundenen Anforderung zurückkehren.
    Anmerkung: Wenn Sie die letzte bzw. erste Anforderung erreichen, die den Suchkriterien entspricht, und dementsprechend entweder auf Weitersuchen oder Rückwärts suchen klicken, wird die Suche erneut gestartet.
Übergeordnetes Thema: Konfigurieren von Anforderungseigenschaften


Anforderungseigenschaften (Seite)

Anforderungen > Detailansicht > Anforderungseigenschaften

Die Seite Anforderungseigenschaften zeigt Informationen über die ausgewählte Eigenschaft oder Projekt an.

Wenn Anforderungen mit einem externen Anforderungsmanagementsystem synchronisiert werden, werden Einträge manchmal mit einem Ausrufezeichen (!) gekennzeichnet. Das bedeutet, dass das gekennzeichnete Feld nicht dem externen Anforderungsmanagementsystem zugeordnet ist. Verwenden Sie die Zuordnungsfunktion zum Zuordnen von Eigenschaftsfeldern. Wenn Sie die Zuordnungsfunktion nicht verwenden, werden nur der Name und die Beschreibung der Anforderung zugeordnet. Weitere Informationen finden Sie unter Bearbeiten von Eigenschaftszuordnungen.

Mit einem Stern (*) gekennzeichnete Werte wurden von der übergeordneten Anforderung übernommen.

Klicken Sie auf Anforderungseigenschaften bearbeiten, um die angezeigten Eigenschaften zu bearbeiten.

Die folgende Tabelle gilt für die Anforderungen, die mit einem Flag gekennzeichnet sind.

Element | Beschreibung
Markiert durch | Gibt an, wer das Flag wann gesetzt hat.
Kommentar | Gibt die Kommentare für das Flag an.
Markierung löschen | Hier klicken, um das Flag zu löschen.

In der folgenden Tabelle werden die Eigenschaften der ausgewählten Anforderungen oder des ausgewählten Projekts, die auf der Seite Eigenschaften angezeigt werden, aufgelistet.

Eigenschaft | Beschreibung
Anforderungsname | Der Name der Anforderung.
Anforderungs-ID | Der Bezeichner der Anforderung.
Beschreibung | Die Beschreibung der Anforderung.
Priorität | Die für die Anforderung konfigurierte Priorität.
Risiko | Das für die Anforderung konfigurierte Risiko.
Geprüft | Der aktuelle Überprüfungsstatus der Anforderung. Ja oder Nein.
Benutzerdefinierte Eigenschaften | Wenn benutzerdefinierte Eigenschaften für die Anforderung konfiguriert wurden, werden sie hier aufgelistet.
Dokument | Das Quelldokument der Anforderung (sofern vorhanden).
Erstellt am | Das Datum, an dem die Anforderung erstellt wurde.
Erstellt von | Der Name des Benutzers, von dem die Anforderung erstellt wurde.
Geändert am | Das Datum, an dem die Anforderung zuletzt geändert wurde.
Geändert Von | Der Name des Benutzers, von dem die Anforderung zuletzt geändert wurde.
Übergeordnetes Thema: Konfigurieren von Anforderungseigenschaften
Zugehörige Konzepte
Synchronisieren von Anforderungen
Zugehörige Tasks
Bearbeiten von Eigenschaftszuordnungen


Anforderungsanhänge

Sie können Dateien oder Links als Anhänge für Anforderungen hochladen oder Anhänge löschen. Wenn Sie Anforderungen mit Anhängen ausschneiden und einfügen, werden die Anhänge automatisch kopiert.

Folgende Typen von Anhängen sind verfügbar:

  • Hochgeladene Dateien
  • Verweise auf UNC-Pfade
  • Verweise auf URLs einschließlich StarTeam-URLs
  • Anhängen von Dateien an Anforderungen
    Ordnen Sie einer Anforderung eine Datei als Anhang zu, um der Anforderung weitere Informationen hinzuzufügen.
  • Anhängen von Verknüpfungen an Anforderungen
    Ordnen Sie einer Anforderung einen Link zu, um der Anforderung weitere Informationen hinzuzufügen.
  • Anzeigen von Anforderungsanhängen
    Zeigen Sie einen Anforderungsanhang an, um zusätzliche Informationen zur Anforderung zu erhalten.
  • Dateien von Anforderungen herunterladen
    Laden Sie sämtliche angehängte Dateien einer Anforderung auf Ihre Festplatte herunter.
  • Anhänge von Anforderungen löschen
    Löschen Sie einen Anforderungsanhang, wenn die Informationen im Anhang nicht mehr benötigt werden.
  • Anforderungsanhänge (Seite)
    Hier werden die Dateien und Links aufgelistet, die der ausgewählten Anforderung zugeordnet sind.
Übergeordnetes Thema: Konfigurieren von Anforderungseigenschaften


Anhängen von Dateien an Anforderungen

So fügen Sie einer Anforderung eine Datei als Anhang hinzu:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. Klicken Sie auf die Registerkarte Anhänge.

    Wenn die Anforderungsmanagementintegration zwischen einem Silk Central-Projekt und einem Caliber-Projekt aktiviert ist, wird auf der Seite Anhänge die Schaltfläche Caliber öffnen angezeigt, über die Sie Anhänge direkt in Caliber verwalten können.

  4. Klicken Sie auf Datei hochladen. Das Dialogfeld Datei hochladen wird angezeigt.
  5. Klicken Sie auf Datei auswählen, und wählen Sie die zuzuordnende Datei im lokalen Dateisystem aus.
  6. Geben Sie eine Beschreibung für den Anhang ein.
  7. Klicken Sie auf OK. Der Anhang wird auf den Server hochgeladen und der ausgewählten Anforderung zugeordnet.
Übergeordnetes Thema: Anforderungsanhänge


Anhängen von Verknüpfungen an Anforderungen

So ordnen Sie einer Anforderung einen Link zu:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. Klicken Sie auf die Registerkarte Anhänge.

    Wenn die Anforderungsmanagementintegration zwischen einem Silk Central-Projekt und einem Caliber-Projekt aktiviert ist, wird auf der Seite Anhänge die Schaltfläche Caliber öffnen angezeigt, über die Sie Anhänge direkt in Caliber verwalten können.

  4. Klicken Sie auf Link einfügen. Das Dialogfeld Link einfügen wird angezeigt.
  5. Fügen Sie die URL in das Feld Link ein.
  6. Geben Sie eine Beschreibung für den eingefügten Link ein.
  7. Klicken Sie auf OK. Der Link wird der ausgewählten Anforderung zugeordnet.
Übergeordnetes Thema: Anforderungsanhänge


Anzeigen von Anforderungsanhängen

So zeigen Sie einen Anhang einer Anforderung an:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. Klicken Sie auf die Registerkarte Anhänge.

    Wenn die Anforderungsmanagementintegration zwischen einem Silk Central-Projekt und einem Caliber-Projekt aktiviert ist, wird auf der Seite Anhänge die Schaltfläche Caliber öffnen angezeigt, über die Sie Anhänge direkt in Caliber verwalten können.

Eine Liste aller der Anforderung zugeordneten Anhänge wird geöffnet. Die Namen der Anhänge dienen als Links. Wenn Sie auf den Namen eines Dateianhangs klicken, wird das Dialogfeld Speichern unter geöffnet, in dem Sie den Anhang auf dem lokalen Computer speichern können. Beim Klicken auf einen Link-Anhang wird das verknüpfte Ziel in einem neuen Browserfenster geöffnet.
Übergeordnetes Thema: Anforderungsanhänge


Dateien von Anforderungen herunterladen

So laden Sie alle Dateien von einer Anforderung herunter:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. Klicken Sie auf die Registerkarte Anhänge.

    Wenn die Anforderungsmanagementintegration zwischen einem Silk Central-Projekt und einem Caliber-Projekt aktiviert ist, wird auf der Seite Anhänge die Schaltfläche Caliber öffnen angezeigt, über die Sie Anhänge direkt in Caliber verwalten können.

  4. Klicken Sie im Bereich Anhänge auf Alle Dateien herunterladen. Je nachdem wie Sie die Download-Einstellungen Ihres Browsers konfiguriert haben, werden sämtliche angehängte Dateien als Zip-Archiv auf Ihre Festplatte heruntergeladen.
    Anmerkung: Um zu große Downloads zu verhindern, ist Alle Dateien herunterladen deaktiviert wenn Untergeordnete Anhänge einbeziehen aktiviert ist.
Übergeordnetes Thema: Anforderungsanhänge


Anhänge von Anforderungen löschen

So löschen Sie einen Anhang einer Anforderung:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. Klicken Sie auf die Registerkarte Anhänge.

    Wenn die Anforderungsmanagementintegration zwischen einem Silk Central-Projekt und einem Caliber-Projekt aktiviert ist, wird auf der Seite Anhänge die Schaltfläche Caliber öffnen angezeigt, über die Sie Anhänge direkt in Caliber verwalten können.

  4. Klicken Sie in der Spalte Aktionen des Anhangs, den Sie löschen möchten, auf Löschen.
  5. Klicken Sie im Bestätigungsdialogfeld auf Ja, um den Anhang aus dem Projekt zu löschen.
    Anmerkung: Sie können immer nur einen Anhang löschen.
Übergeordnetes Thema: Anforderungsanhänge


Anforderungsanhänge (Seite)

Anforderungen > Detailansicht > Anhänge

Auf der Seite Anhänge werden die Dateien und Anhänge aufgelistet, die der ausgewählten Anforderung zugeordnet sind. Die Anhänge sind standardmäßig in der Reihenfolge aufgelistet, in der Sie hochgeladen wurden. Die Liste kann jedoch nach dem Namen, dem Erstellungsdatum und dem erstellenden Benutzer sortiert werden.

Anmerkung: Wenn auch die Anhänge angezeigt werden sollen, die den untergeordneten Anforderungen der ausgewählten Anforderung zugeordnet sind, aktivieren Sie das Kontrollkästchen Untergeordnete Anhänge einbeziehen.
Anmerkung: Dateisymbole zeigen an, ob die Dokumente direkt der ausgewählten Anforderung oder einer untergeordneten Anforderung zugeordnet sind.
Einzelsymbol
Die Datei ist direkt der ausgewählten Anforderung zugeordnet.
Doppelsymbol
Die Datei ist einer untergeordneten Anforderung zugeordnet.

Auf der Seite Anhang werden die folgenden Spalten für jeden aufgelisteten Anhang angezeigt:

Spalte | Beschreibung
Aktionen | Klicken Sie auf Löschen , um den Anhang zu löschen.
Anhangssymbol | Hängt vom Typ des Anhangs ab.
Name | Der Name des Anhangs.
Größe | Die Größe des Anhangs.
Beschreibung | Die Beschreibung des Anhangs.
Erstellt am | Das Datum, an dem der Anhang erstellt wurde.
Erstellt von | Der Name des Benutzers, der den Anhang erstellt hat.
Übergeordnetes Thema: Anforderungsanhänge


Zuordnen von Tests zu Anforderungen.

Ordnen Sie Ihre Anforderungen Tests zu, um messen zu können wie gut Ihre Software die erstellten Anforderungen abdeckt.
  • Zuordnen von Tests aus der Tabellenansicht zu Anforderungen
    Ordnen Sie eine Test aus der Tabellenansicht einer Anforderung zu, um die Testabdeckung für die Anforderung anzuzeigen.
  • Manuelles Zuordnen von Tests zu Anforderungen
    Ordnen Sie einer Anforderung manuell eine Test zu, um die Testabdeckung für die Anforderung anzuzeigen.
  • Suchen nach zugeordneten Tests in der Testhierarchie
    Suchen Sie in der Testhierarchie einen zugeordneten Test, um zu bestimmen, in welchen Ordner oder Container der Test gehört.
  • Entfernen zugeordneter Tests
    Entfernen Sie einen zugeordneten Test aus einer Anforderung, wenn der Test nicht mehr auf die Anforderung bezogen ist.
  • Erzeugen von Tests aus der Anforderungsansicht
    Erzeugen Sie einen neuen Test in der Detailansicht im Bereich Anforderungen, um bestimmten Anforderungen Tests zuzuordnen.
  • Zugeordnete Tests (Seite)
    Hier werden die Tests angezeigt, die der ausgewählten Anforderung zugeordnet sind.
Übergeordnetes Thema: Anforderungen


Zuordnen von Tests aus der Tabellenansicht zu Anforderungen

So ordnen Sie eine oder mehrere Tests einer oder mehreren Anforderungen aus der Tabellenansicht des Testbereichs zu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Symbolleiste auf Tabellenansicht.
  3. Wählen Sie die Tests aus, die Sie den Anforderungen zuordnen möchten. Sie können mit den Tasten Strg und Umschalt entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Tests auswählen.
  4. Klicken Sie mit der rechten Maustaste auf die ausgewählten Tests, und wählen Sie Auswahl speichern aus.
  5. Klicken Sie auf Anforderungen > Detailansicht.
  6. Wählen Sie die Anforderung aus, der Sie die ausgewählten Tests zuordnen möchten.
  7. Klicken Sie auf die Registerkarte Zugeordnete Tests.
  8. Klicken Sie auf Gespeicherte Auswahl zuweisen.
    Anmerkung: Es werden nur die Tests zugewiesen, die sich im Container der Anforderungen befinden. Sie können die ausgewählten Tests mehr als einer Anforderung zuordnen. Sie können sie jedoch keiner Anforderung in einem anderen Projekt zuordnen. Die Auswahl bleibt so lange bestehen, bis Sie eine andere Auswahl treffen oder Silk Central schließen.
Übergeordnetes Thema: Zuordnen von Tests zu Anforderungen.


Manuelles Zuordnen von Tests zu Anforderungen

So ordnen Sie manuell Tests einer Anforderung zu:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. Klicken Sie auf die Registerkarte Zugeordnete Tests. Alle Tests, die Sie zuordnen können, werden im Fenster Test angezeigt.
  4. Wenn Sie einen Testsfilter erstellt haben, können Sie diesen in der Filterliste oberhalb des Fensters Test auswählen. Um einen neuen Testfilter zu erstellen, klicken Sie in der Symbolleiste des Bereichs Tests auf Neuer Filter.
  5. Wählen Sie die Tests aus, die Sie zuordnen möchten. Sie können mit den Tasten Strg und Umschalt entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Tests auswählen.
  6. Ziehen Sie Ihre Auswahl in den Bereich Zugeordnete Tests und legen Sie sie dort ab, oder klicken Sie links von irgendeinem Test auf Zuordnen. Beim Zuordnen eines Containers oder Testordners werden alle Tests, die sich in diesem Container oder Ordner befinden, der ausgewählten Anforderung zugeordnet. Tests in Unterordnern dieser Container und Ordner werden ebenfalls zugeordnet.
    Tipp: Klicken Sie mit der rechten Maustaste auf einen Knoten, um ihn zu erweitern oder auszublenden.
Übergeordnetes Thema: Zuordnen von Tests zu Anforderungen.


Suchen nach zugeordneten Tests in der Testhierarchie

So suchen Sie einen zugeordneten Test in der Testhierarchie:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie in der Symbolleiste auf Anforderungsansicht.
  3. Wählen Sie in der Hierarchie Anforderungen eine Anforderung aus, der mindestens eine Test zugeordnet ist.
  4. Klicken Sie auf die Registerkarte Zugeordnete Tests.
  5. Klicken Sie in der Spalte Aktionen eines Tests auf Lokalisieren, um herauszufinden, in welchem Testordner oder -container der Test gespeichert ist. Der betreffende Ordner oder Container wird dann im Fenster Tests markiert.
Übergeordnetes Thema: Zuordnen von Tests zu Anforderungen.


Entfernen zugeordneter Tests

So entfernen Sie einen zugeordneten Test:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie in der Symbolleiste auf Anforderungsansicht.
  3. Wählen Sie in der Hierarchie Anforderungen eine Anforderung aus, der mindestens eine Test zugeordnet ist.
  4. Klicken Sie in der Spalte Aktionen des zu löschenden Tests auf Löschen, oder wählen Sie mit Strg+Klick oder Umschalt+Klick mehrere Tests aus und drücken Sie die Entf-Taste.
    Anmerkung: Wenn Sie alle zugeordneten Tests der ausgewählten Anforderung entfernen möchten, klicken Sie auf Alle entfernen.
Übergeordnetes Thema: Zuordnen von Tests zu Anforderungen.


Erzeugen von Tests aus der Anforderungsansicht

Sie können Tests direkt aus der Anforderungshierarchie generieren und bestimmten Anforderungen Tests zuordnen. Die Hierarchie Anforderungen dient als Vorlage für die Testordner und Teststrukturen der neuen Hierarchie Tests.

So erzeugen Sie aus der Detailansicht einen neuen Test:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf die Anforderung oder den Projektknoten, die/der in einen Testplan umgewandelt werden soll, und wählen Sie Tests erzeugen aus. Das Dialogfeld Tests zu Anforderungen erzeugen wird angezeigt. In diesem Dialogfeld können Sie festlegen, ob die untergeordneten Knoten der ausgewählten Anforderungsunterhierarchie in Tests oder Ordner konvertiert und ob die Hierarchie in einem neuen Container oder einem vorhandenen Container erzeugt werden soll.
  3. Geben Sie einen Namen für den neuen Testcontainer in das Feld Name eingeben ein, und wählen Sie ein Produkt in der Liste Produkt auswählen aus, um den Container im aktiven Silk Central-Projekt zu erstellen. In der Liste Produkt auswählen werden die von einem Projektmanager konfigurierten Produkte angezeigt. Weitere Informationen finden Sie unter Verwalten von Produkten, oder wenden Sie sich an den Projektmanager.
  4. Wenn Sie ein Versionsverwaltungsprofil erstellt haben, wählen Sie das gewünschte Profil in der Liste Versionsverwaltungsprofil auswählen aus. Weitere Informationen zu Quellverwaltungsprofilen finden Sie unter Versionsverwaltungsprofile, oder wenden Sie sich an den Silk Central-Administrator.
  5. Wenn die untergeordneten Anforderungen der ausgewählten Anforderung in den Test aufgenommen werden sollen, aktivieren Sie das Kontrollkästchen Untergeordnete Anforderungen einbeziehen. Dieses Kontrollkästchen ist standardmäßig aktiviert.
  6. Wenn die neuen Tests automatisch den zugrunde liegenden Anforderungen zugeordnet werden sollen, aktivieren Sie das Kontrollkästchen Neu erzeugte Tests zu Anforderungen zuordnen. Wenn diese Option deaktiviert ist, müssen die Tests den Anforderungen manuell zugeordnet werden.
    Anmerkung: Diese Option ist nicht verfügbar, wenn Ordner aus Anforderungshierarchie erzeugen ausgewählt wird.
  7. Klicken Sie auf OK, um den Test zu erstellen. Der neue Test hat dieselbe Struktur wie die Anforderungshierarchie.
  8. Es wird eine Meldung angezeigt. Klicken Sie auf Ja, wenn der Test im Bereich Tests angezeigt werden soll. Wenn der Bereich Anforderungen geöffnet bleiben soll, klicken Sie auf Nein.
Übergeordnetes Thema: Zuordnen von Tests zu Anforderungen.
Zugehörige Konzepte
Verwalten von Produkten
Versionsverwaltungsprofile


Zugeordnete Tests (Seite)

Anforderungen > Detailansicht > Zugeordnete Tests

Auf der Seite Zugeordnete Tests werden alle Tests angezeigt, die der ausgewählten Anforderung zugeordnet sind. Wenn ein Test mehr als einer Testsuite zugeordnet ist und das Kontrollkästchen Anzeige im Testausführungskontext aktiviert ist, wird der Test für jede Testsuite in einer separaten Zeile der Tabelle angezeigt.

Alle Tests, die Sie zuordnen können, werden rechts in der Hierarchie Tests angezeigt. Um der ausgewählten Anforderung einen Test zuzuweisen, doppelklicken Sie auf den Eintrag in der Hierarchie, oder klicken Sie links neben dem Eintrag auf Zuordnen.

Wenn Sie einen Testfilter erstellt haben, können Sie diesen oben in der Testhierarchie in der Filterliste auswählen. Um einen neuen Testfilter zu erstellen, klicken Sie in der Symbolleiste des Bereichs Tests auf Neuer Filter.

Um neu erzeugte Tests den Anforderungen, aus denen sie erzeugt wurden, automatisch zuzuordnen, aktivieren Sie im Dialog Testplan aus Anforderungen erzeugen das Kontrollkästchen Neu erzeugte Tests zu Anforderungen zuordnen.

In der Standardansicht werden nur die Tests angezeigt, die direkt der ausgewählten Anforderung zugeordnet sind. Aktivieren Sie das Kontrollkästchen Vollständige Abdeckung, um zusätzlich alle Tests anzuzeigen, die untergeordneten Anforderungen zugeordnet sind. Wenn Vollständige Abdeckung aktiviert ist, werden die Tests, die der ausgewählten Anforderung nicht zugeschrieben, aber einer untergeordneten Anforderung zugeordnet sind, mit einer Überlagerung des Testtyp-Symbols angezeigt.

Wenn Sie einen Satz Tests aus Tests > Tabellenansicht in die Zwischenablage kopiert haben, klicken Sie auf Gespeicherte Auswahl zuweisen, um den gesamten Satz der ausgewählten Anforderung zuzuordnen. Klicken Sie auf Alles entfernen, um alle zugeordneten Tests von der Anforderung zu entfernen.

Klicken Sie mit der rechten Maustaste auf einen Test und anschließend auf Vorhandene Fehler zuordnen, um vorhandene Fehler einem oder mehreren Tests direkt über die Tabelle zuzuordnen. Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.

Auf der Seite Zugeordnete Tests werden folgende Spalten für jeden aufgelisteten Test angezeigt:

Spalte | Beschreibung
Aktionen Sie können folgende Aktionen für den zugeordneten Test ausführen:
  • Klicken Sie auf Löschen, um den zugeordneten Test aus der Anforderung zu entfernen.
  • Klicken Sie auf Suchen, um den zugeordneten Test in der Hierarchie Tests auf der rechten Seite aufzufinden.
Test | Der Name des zugeordneten Tests. Klicken Sie darauf, um den Test anzuzeigen und zu bearbeiten. Für Konfigurationstests werden die Tests für jede Konfiguration einzeln aufgeführt.
Testsuite | Diese Spalte wird nur angezeigt, wenn das Kontrollkästchen Anzeige im Testausführungskontext aktiviert ist. Name der Testsuite, die den zugeordneten Test enthält. Für Konfigurationstests.
Übergeordneter Knoten | Die Konfigurationssuite, der Ordner oder der Testzyklus, in dem die Testsuite ausgeführt wird. Klicken Sie die gewünschte Suite oder den Ordner in der Testsuitehierarchie an. Wenn die Testsuite nicht in einer Konfigurationssuite oder in einem Ordner enthalten ist, wird nichts angezeigt.
Status Der Status des zugeordneten Tests in jeder Testsuite, zu der der Test zugeordnet ist. Um den Status aller Läufe der angezeigten Tests in jeder Testsuite anzuzeigen, aktivieren Sie das Kontrollkästchen Anzeige im Testausführungskontext.
  • Bestanden
  • Fehlgeschlagen
  • Nicht ausgeführt
  • --
Für Tests oder Testpakete, die in einer Konfigurationssuite enthalten sind, ist der Status eine Aggregation aller Status von allen Konfigurationen innerhalb der Suite:
  • Wenn der Test nur der Konfigurationssuite zugeordnet ist, gilt der Status Bestanden nur, wenn der Test bei allen Konfigurationen bestanden ist. Falls der Status nicht für alle Konfigurationen Bestanden ist, wird der Status für den schlechtesten Testlauf mit der folgenden Priorität (von oben nach unten) übertragen:
    1. --
    2. Nicht ausgeführt
    3. Fehlgeschlagen
    4. Bestanden
    Der Status einer Anforderung, der dem Test zugeordnet ist, gilt als Fehlgeschlagen, wenn der Test in einer Konfiguration oder mehreren Konfigurationen fehlgeschlagen ist.
  • Wir empfehlen Ihnen nicht, den Test einer Konfigurationssuite und gleichzeitig einer oder mehreren Testsuiten zuzuordnen. In diesem Fall ist die Zusammenfassung des Konfigurationsstatus ein eigenständiger Status, unabhängig von den letzten Status der Testsuiten, die andere Status sind. Der Status, der zuletzt durchgeführt wurde, bestimmt den letzten Status des Tests.
  • Wenn der Test nur einer einfachen Testsuite zugeordnet ist, wird der Status auf den Status des letzten Testlaufs gesetzt.
Letzte Testausführung | Zeit und Datum der letzten Ausführung des Tests.
Fehler | Diese Spalte wird nur angezeigt, wenn das Kontrollkästchen Anzeige im Testausführungskontext nicht aktiviert ist. Die dem Test zugeordneten Fehler.
Übergeordnetes Thema: Zuordnen von Tests zu Anforderungen.
Zugehörige Konzepte
Benutzerdefinierte Symbole


Importieren von Anforderungen

Mit Silk Central können Sie Anforderungen aus Microsoft Word und Excel importieren. Sie können eine Anforderung in den Bereich Anforderungen importieren und anschließend alle darin enthaltenen Anforderungen in Silk Central verwalten. Der Import muss also nur einmal durchgeführt werden.

  • Importieren von Anforderungen aus einer Word-Datei
    Sie können Anforderungen aus einer Microsoft Word-Datei importieren, um die Anforderungen in Silk Central zu verwalten.
  • Aktualisieren von Anforderungen aus einer Word-Datei
    Aktualisieren Sie Anforderungen aus einer Microsoft Word-Datei, um die in der Word-Datei vorgenommenen Änderungen anzuwenden.
  • Word-Anforderungsdatei
    Beschreibt die Inhalte der Word-Anforderungsdatei, aus der Sie Anforderungen in Silk Central importieren können.
  • Importieren von Anforderungen aus einer Excel-Datei
    Sie können Anforderungen aus einer Microsoft Excel-Datei importieren, um die Anforderungen in Silk Central zu verwalten.
  • Aktualisieren von Anforderungen aus einer Excel-Datei
    Aktualisieren Sie Anforderungen aus einer Microsoft Excel-Datei, um die in der Excel-Datei vorgenommenen Änderungen anzuwenden.
  • Excel Anforderungs- und Zuordnungsdatei
    Hier wird der Inhalt der Excel-Anforderungsdatei und die entsprechende Zuordnung in Silk Central beschrieben.
Übergeordnetes Thema: Anforderungen


Importieren von Anforderungen aus einer Word-Datei

Vor dem Import von Anforderungen müssen Sie in Word eine Anforderungsdatei erstellen. Weitere Informationen finden Sie unter Word-Anforderungsdatei.

Silk Central verwendet die in der Word-Datei und in einer Zuordnungsdatei gespeicherten Informationen, um zu bestimmen, welche Daten zu speichern sind, und erfasst nur diejenigen Informationen, die mit bestimmten Stilen zugeordnet sind. Silk Central benötigt die Zuordnungsdatei, um die Anforderungen in der Word-Datei den Anforderungen in Silk Central zuzuordnen. Für den Import wird vorab eine Standardzuordnungsdatei namens RequirementsPropertiesDefaultMapping.xml ausgewählt. Sie können Ihre Anforderungen auch mit einer benutzerdefinierten Zuordnungsdatei zuordnen.

docx-Funktionalität: Die Funktionalität für docx ist mit der für doc bis auf die folgenden Verbesserungen identisch:
  • Bilder und andere eingebettete Objekte (OLE) (z. B.: PDF, Excel) werden erkannt und als Anhang an eine Anforderung importiert.
  • Beschreibungen können Links enthalten.

So importieren Sie Anforderungen aus einer Word-Datei in den Bereich Anforderungen:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf die Anforderung, die Sie als übergeordneten Knoten der importierten Anforderungen verwenden möchten, und wählen Sie Aus Word importieren. Das Dialogfeld Anforderung aus einer Word-Datei importieren wird geöffnet.
  3. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist RequirementsPropertiesDefaultMapping.xml.
  4. Optional: Klicken Sie auf [image], um die Zuordnungsdatei zu bearbeiten. Klicken Sie auf [image], um die Zuordnungsdatei zu löschen. Weitere Informationen finden Sie unter Word-Anforderungsdatei.
    Anmerkung: Für diese Aktionen werden die Berechtigungen Zuordnungsdateien für Office-Import bearbeiten respektive Löschen von Zuordnungsdateien für Office-Import benötigt.
  5. Aktivieren Sie das Kontrollkästchen Einmaliger Import, wenn es sich um einen einmaligen Massenimport von Anforderungen handelt, die nach dem Import nur noch in Silk Central gewartet werden. Mit dieser Option werden die Anforderungen direkt unterhalb des ausgewählten Knotens importiert, ohne einen übergeordneten Ordner zu erstellen. Die Funktion Aus Word aktualisieren... kann nach dem Import.nicht mehr verwendet werden, um die Anforderungen zu aktualisieren.
  6. Geben Sie entweder im Feld Anforderungsdatei den vollständigen Pfad der Anforderungsdatei ein, oder klicken Sie auf Datei auswählen, um die Anforderungsdatei zu suchen.
  7. Klicken Sie auf OK. Eine Meldung, dass die Datei erfolgreich importiert wurde, wird angezeigt. Klicken Sie auf OK, um die Meldung zu schließen.
Übergeordnetes Thema: Importieren von Anforderungen
Zugehörige Konzepte
Word-Anforderungsdatei
Zugehörige Tasks
Aktualisieren von Anforderungen aus einer Word-Datei


Aktualisieren von Anforderungen aus einer Word-Datei

Mit Silk Central können Sie aus Microsoft Word importierte Anforderungen aktualisieren. Sie können die Anforderungen im Word-Dokument ändern und anschließend im Bereich Anforderungen aktualisieren. In der Zuordnungsdatei können Sie auch die Zuordnung von Anforderungen im Bereich Anforderungen ändern.
Anmerkung: Nur Anforderungen, für die eine eindeutige externe ID in der zuvor importierten Word-Datei definiert wurde, können aktualisiert werden. Silk Central benötigt diese ID um zu wissen, welche Anforderung aktualisiert werden soll.
  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf den Knoten der zuvor importierten Anforderungen (z.B. Aus Datei 'AnforderungenBeispiel.docx') und wählen Sie Aus Word aktualisieren.... Der Dialog Anforderungen aus einer Word-Datei aktualisieren wird geöffnet.
  3. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist RequirementsPropertiesDefaultMapping.xml.
  4. Optional: Klicken Sie auf [image], um die Zuordnungsdatei zu bearbeiten. Klicken Sie auf [image], um die Zuordnungsdatei zu löschen. Weitere Informationen finden Sie unter Word-Anforderungsdatei.
    Anmerkung: Für diese Aktionen werden die Berechtigungen Zuordnungsdateien für Office-Import bearbeiten respektive Löschen von Zuordnungsdateien für Office-Import benötigt.
  5. Geben Sie entweder im Textfeld Anforderungsdatei den vollständigen Pfad der Anforderungsdatei ein, oder klicken Sie auf Durchsuchen, um die Anforderungsdatei zu suchen.
  6. Klicken Sie auf OK. Eine Meldung, dass die Aktualisierung erfolgreich war, wird angezeigt. Klicken Sie auf OK, um die Meldung zu schließen.
Übergeordnetes Thema: Importieren von Anforderungen
Zugehörige Konzepte
Word-Anforderungsdatei
Zugehörige Tasks
Importieren von Anforderungen aus einer Word-Datei


Word-Anforderungsdatei

Erstellen Sie eine Anforderungsdatei in Word um Anforderungen in Silk Central zu importieren oder zu aktualisieren. Definieren Sie Anforderungen und deren Hierarchie, sowie Prioritäten, Risiken, benutzerdefinierte Eigenschaften und den Überprüfungsstatus in der Anforderungsdatei.

Ordnen Sie die Anforderungen in der Anforderungsdatei mithilfe einer XML-Zuordnungsdatei den Anforderungen in Silk Central zu. Die Formate des Word-Dokuments werden mithilfe der Zuordnungsdatei den Anforderungseigenschaften in Silk Central zugeordnet. Sie können die Word-Formate beliebig benennen. Wichtig ist nur, dass Sie sie in der Zuordnungsdatei richtig zuordnen.

Wenn die Anforderungen aktualisierbar sein sollen, müssen Sie einen Stil für die externe ID festlegen und jeder einzelnen Anforderung in der Anforderungsdatei eine eindeutige externe ID zuweisen. Im folgenden Beispiel werden eine Beispielanforderung, zwei Unteranforderungen und die entsprechenden externen IDs aufgezeigt:
Word-Datei Verwendete Formate
Customer Account Management - Basics
ID_1
As user of the web shop I want to be able to ...
Medium
High
No

Customer Account Management - Personal Details
ID_1.1
As user of the web shop I want to be able to ...
Medium
Medium
No

Customer Account Management - Shipping Details
ID_1.2
As user of the web shop I want to be able to ...
Medium
Medium
No

Formatted with Word style "Heading 1"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

Formatted with Word style "Heading 2"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

Formatted with Word style "Heading 2"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

Im Feld Speichern unter können Sie optional den Namen der Zuordnungsdatei ändern. Diese Datei wird auf dem Anwendungsserver unter <Silk Central Datenverzeichnis>\OfficeImportMappingFiles\requirements\<Mandanten-ID> gespeichert, z.B. C:\ProgramData\SilkCentral\instance_<Instanznummer>_<Instanzname>\OfficeImportMappingFiles.

Übergeordnetes Thema: Importieren von Anforderungen
Zugehörige Tasks
Importieren von Anforderungen aus einer Word-Datei
Aktualisieren von Anforderungen aus einer Word-Datei


Importieren von Anforderungen aus einer Excel-Datei

Vor dem Import von Anforderungen müssen Sie in Excel eine Anforderungsdatei erstellen. Weitere Informationen finden Sie unter Excel Anforderungs- und Zuordnungsdatei.

Silk Central verwendet die in der Excel-Datei und in einer Zuordnungsdatei gespeicherten Informationen, um zu bestimmen, welche Daten zu speichern sind, und erfasst nur diejenigen Informationen, die mit bestimmten Spaltennamen zugeordnet sind. Silk Central benötigt die Zuordnungsdatei, um die Anforderungen in der Excel-Datei den Anforderungen in Silk Central zuzuordnen. Für den Import wird vorab eine Standardzuordnungsdatei namens RequirementPropertiesXlsxDefaultMapping.xml ausgewählt. Sie können Ihre Anforderungen auch mit einer benutzerdefinierten Zuordnungsdatei zuordnen.

Anmerkung: Das Importieren von Anhängen (Bilder, Grafiken) wird nicht unterstützt.

So importieren Sie Anforderungen aus einer Excel-Datei in den Bereich Anforderungen:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf die Anforderung, die Sie als übergeordneten Knoten der importierten Anforderungen verwenden möchten, und wählen Sie Aus Excel importieren. Der Dialog Anforderungen aus Excel-Datei importieren wird geöffnet.
  3. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist RequirementPropertiesXlsxDefaultMapping.xml.
  4. Optional: Klicken Sie auf [image], um die Zuordnungsdatei zu bearbeiten. Klicken Sie auf [image], um die Zuordnungsdatei zu löschen. Weitere Informationen finden Sie unter Excel Anforderungs- und Zuordnungsdatei.
    Anmerkung: Für diese Aktionen werden die Berechtigungen Zuordnungsdateien für Office-Import bearbeiten respektive Löschen von Zuordnungsdateien für Office-Import benötigt.
  5. Aktivieren Sie das Kontrollkästchen Einmaliger Import, wenn es sich um einen einmaligen Massenimport von Anforderungen handelt, die nach dem Import nur noch in Silk Central gewartet werden. Mit dieser Option werden die Anforderungen direkt unterhalb des ausgewählten Knotens importiert, ohne einen übergeordneten Ordner zu erstellen. Die Funktion Aus Excel aktualisieren... kann nach dem Import.nicht mehr verwendet werden, um die Anforderungen zu aktualisieren.
  6. Geben Sie entweder im Feld Anforderungsdatei den vollständigen Pfad der Anforderungsdatei ein, oder klicken Sie auf Datei auswählen, um die Anforderungsdatei zu suchen.
  7. Klicken Sie auf OK. Eine Meldung, dass die Datei erfolgreich importiert wurde, wird angezeigt. Klicken Sie auf OK, um die Meldung zu schließen.
Übergeordnetes Thema: Importieren von Anforderungen
Zugehörige Tasks
Aktualisieren von Anforderungen aus einer Excel-Datei
Zugehörige Verweise
Excel Anforderungs- und Zuordnungsdatei


Aktualisieren von Anforderungen aus einer Excel-Datei

Mit Silk Central können Sie aus Microsoft Excel importierte Anforderungen aktualisieren. Sie können die Anforderungen im Excel-Dokument ändern und anschließend im Bereich Anforderungen aktualisieren. In der Zuordnungsdatei können Sie auch die Zuordnung von Anforderungen im Bereich Anforderungen ändern.
Anmerkung: Nur Anforderungen, für die eine eindeutige externe ID in der zuvor importierten Excel-Datei definiert wurde, können aktualisiert werden. Silk Central benötigt diese ID um zu wissen, welche Anforderung aktualisiert werden soll.
  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf den Knoten der zuvor importierten Anforderungen (z.B. Aus Datei 'AnforderungenBeispiel.xlsx') und wählen Sie Aus Excel aktualisieren.... Der Dialog Anforderungen mit Excel-Datei aktualisieren wird geöffnet.
  3. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist RequirementPropertiesXlsxDefaultMapping.xml.
  4. Optional: Klicken Sie auf [image], um die Zuordnungsdatei zu bearbeiten. Klicken Sie auf [image], um die Zuordnungsdatei zu löschen. Weitere Informationen finden Sie unter Excel Anforderungs- und Zuordnungsdatei.
    Anmerkung: Für diese Aktionen werden die Berechtigungen Zuordnungsdateien für Office-Import bearbeiten respektive Löschen von Zuordnungsdateien für Office-Import benötigt.
  5. Geben Sie entweder im Textfeld Anforderungsdatei den vollständigen Pfad der Anforderungsdatei ein, oder klicken Sie auf Durchsuchen, um die Anforderungsdatei zu suchen.
  6. Klicken Sie auf OK. Eine Meldung, dass die Aktualisierung erfolgreich war, wird angezeigt. Klicken Sie auf OK, um die Meldung zu schließen.
Übergeordnetes Thema: Importieren von Anforderungen
Zugehörige Tasks
Importieren von Anforderungen aus einer Excel-Datei
Zugehörige Verweise
Excel Anforderungs- und Zuordnungsdatei


Excel Anforderungs- und Zuordnungsdatei

Erstellen Sie eine Anforderungsdatei in Excel um Anforderungen in Silk Central zu importieren oder zu aktualisieren. Definieren Sie Anforderungen und deren Hierarchie, sowie Prioritäten, Risiken, benutzerdefinierte Eigenschaften und den Überprüfungsstatus in der Anforderungsdatei.

Ordnen Sie die Anforderungen in der Anforderungsdatei mithilfe einer XML-Zuordnungsdatei den Anforderungen in Silk Central zu. Die Spalten des Excel-Dokuments werden mithilfe der Zuordnungsdatei den Anforderungseigenschaften in Silk Central zugeordnet. Um die Zuordnungsdatei zu bearbeiten benötigen Sie die Berechtigung Zuordnungsdateien für Office-Import bearbeiten.

Eigenschaftszuordnung

Klicken Sie auf den Dialogen Anforderungen aus Excel-Datei importieren oder Anforderungen mit Excel-Datei aktualisieren auf Zuordnung bearbeiten, um die Anforderungen in Ihrer Excel-Datei folgendermaßen Silk Central zuzuordnen:
  • Kopfzeile: Geben Sie die Zeile in Ihrer Excel-Anforderungsdatei an, welche die Spaltennamen enthält, die für die Zuordnung der Eigenschaften verwendet werden sollen.
  • Erste Datenzeile: Geben Sie die Zeile an, welche die erste Anforderung enthält. Diese und alle nachfolgenden Zeilen werden als Anforderungen interpretiert.
  • Trennzeichen: Geben Sie die Zeichen an, welche in den Eigenschaftswerten als Trennzeichen interpretiert werden sollen. Dies wird für Mehrfachlisten-Eigenschaften verwendet.
  • Name, Beschreibung: Geben Sie die Spaltennamen in der Kopfzeile an, welche dem Namen bzw. der Beschreibung von Anforderungen zugeordnet werden sollen.
  • Externe GUID: Geben Sie den Spaltennamen in der Kopfzeile an, welcher die eindeutige ID in Ihrer Anforderungsdatei für jede Anforderung enthält. Diese ID's können in Externe übergeordnete GUID verwendet werden, um eine Hierarchie Ihrer Anforderungen zu erstellen.
  • Externe übergeordnete GUID: Geben Sie den Spaltennamen in der Kopfzeile an, welcher die übergeordnete Anforderung einer Anforderung enthält. Geben Sie in Ihrer Anforderungsdatei die Externe GUID an, um das übergeordnete Element einer Anforderung zu spezifizieren. Enthält diese Zelle keine Daten, so wird die Anforderung direkt der Stammanforderung hinzugefügt. Die folgenden Regeln werden angewendet:
    • Enthält eine Anforderung keine ID eines übergeordneten Elements, wird sie der erzeugten Stammanforderung als untergeordnetes Element hinzugefügt.
    • Enthält eine Anforderung eine ungültige ID eines übergeordneten Elements, wird sie der erzeugten Stammanforderung als untergeordnetes Element hinzugefügt.
    • Enthält eine Anforderung ihre eigene ID als ID eines übergeordneten Elements, wird sie der erzeugten Stammanforderung als untergeordnetes Element hinzugefügt.
    • Entstehen durch die ID's von übergeordneten Elementen zyklische Abhängigkeiten zwischen zwei oder mehr Anforderungen, werden diese Anforderungen nicht in Silk Central importiert.
  • Priorität, Risiko, Geprüft: Geben Sie die Spaltennamen in der Kopfzeile an, welche den lokalisierten Werten dieser Eigenschaften zugeordnet werden sollen.
  • Falls Sie benutzerdefinierte Eigenschaften angelegt haben, geben Sie für jede die Spaltennamen in der Kopfzeile an, um sie korrekt zuzuordnen.
  • Speichern unter: Geben Sie den Namen an, mit dem Ihre Zuordnungsdatei gespeichert werden soll. Diese Datei wird auf dem Anwendungsserver unter <Silk Central Datenverzeichnis>\OfficeImportMappingFiles\requirements\xlsx\<Mandanten-ID> gespeichert, z.B. C:\ProgramData\SilkCentral\instance_<Instanznummer>_<Instanzname>\OfficeImportMappingFiles\requirements\xlsx\1.

Beispiel einer Excel-Anforderungsdatei

Im folgenden Beispiel werden eine Beispielanforderung, zwei Unteranforderungen und die entsprechenden externen IDs aufgezeigt. Dieses Beispiel einer Excel-Anforderungsdatei entspricht den Standard-Eigenschaftszuordnungen.
1 | RequirementName | RequirementDescription | ID | ParentID | Priorität | Risiko | Geprüft
2 | Kontenverwaltung - Grundlagen | Als Benutzer des Web Shops möchte ich ... | ID_1 |  | Mittel | Hoch | Nein
3 | Kontenverwaltung - Persönliche Daten | Als Benutzer des Web Shops möchte ich ... | ID_1.1 | ID_1 | Mittel | Mittel | Nein
4 | Kontenverwaltung - Versanddaten | Als Benutzer des Web Shops möchte ich ... | ID_1.2 | ID_1 | Mittel | Mittel | Nein
Übergeordnetes Thema: Importieren von Anforderungen
Zugehörige Tasks
Importieren von Anforderungen aus einer Excel-Datei
Aktualisieren von Anforderungen aus einer Excel-Datei


Anforderungsansichten

Silk Central bietet mehrere Ansichten und Werkzeuge an, mit denen Sie Ihre Anforderungen verwalten können.

  • Anforderungshierarchie
    Hier wird die Anforderungshierarchie beschrieben.
  • Anforderungssymbolleiste
    Ermöglicht Zugriff auf wichtige Befehle zum Verwalten von Anforderungen.
  • Anforderungs-Dokumentansicht
    Hier wird der Status aller Tests im aktiven Projekt in einem "Thermometerfeld" dargestellt.
  • Anforderungshistorie
    Hier wird beschrieben, wie eine Anforderungshistorie zum Verfolgen aller Änderungen an der Anforderung verwendet wird.
Übergeordnetes Thema: Anforderungen


Anforderungshierarchie

Die Anforderungen werden in einer hierarchischen Struktur (der Anforderungshierarchie) angezeigt, organisiert und verwaltet. Jeder Knoten in der Anforderungshierarchie entspricht einer Anforderung. Den Anforderungen können beliebig viele untergeordnete Anforderungen zugeordnet werden. Die Anzahl der Hierarchieebenen in der Anforderungshierarchie ist unbegrenzt.

Anmerkung: Wenn die Anforderungshierarchie mehr Elemente enthält, als auf einmal ohne Auswirkung auf die Antwortzeit angezeigt werden können, werden die Elemente stufenweise angezeigt. Mit Hilfe der Links mit den Seitennummern am unteren Ende der Registerkarte können Sie die in der Hierarchie enthaltenen Elemente seitenweise anzeigen. Klicken Sie zum Anzeigen aller Elemente in einer einzelnen Liste auf den Link [Alle].
  • Tastaturfunktionen (Anforderungen)
    Die Hierarchie kann mit der Tastatur bedient werden.
  • Ausblenden und Erweitern der Anforderungshierarchie
    Sie können die Anforderungshierarchie ausblenden und erweitern, um Ebenen der Hierarchie gemäß Ihren Anforderungen zu konsolidieren und anzuzeigen.
  • Filtern der Anforderungshierarchie
    Hier wird beschrieben, wie Sie einen Filter zur Anforderungshierarchie hinzufügen.
Übergeordnetes Thema: Anforderungsansichten


Tastaturfunktionen (Anforderungen)

Die folgenden Aktionen können für die ausgewählten Knoten ausgeführt werden:

Taste | Aktion
Aufwärts | Auswahl nach oben
Abwärts | Auswahl nach unten
Rechts | Element erweitern
Links | Untergeordnete Elemente ausblenden
F2 | Element bearbeiten
Strg+C | Element kopieren
Strg+X | Element ausschneiden
Strg+V | Element einfügen
Entf | Element löschen
Strg+Nach oben | Element nach oben verschieben
Strg+Nach unten | Element nach unten verschieben
Klicken | Ein Element markieren und als aktuelles Element merken.
Strg+Klick | Den Auswahlstatus des gewählten Elements ein- und ausschalten und mit weiteren Klicks weitere Elemente hinzufügen/entfernen.
Umschalt+Klick | Auswahl vom aktuell markierten Element bis zum neu angeklickten Element erweitern.
Umschalt+Nach oben | Das darüberliegende Element auswählen.
Umschalt+Nach unten | Das darunterliegende Element auswählen.
Eingabe | Element zuordnen (nur in den Zuordnungshierarchien)
Übergeordnetes Thema: Anforderungshierarchie


Ausblenden und Erweitern der Anforderungshierarchie

So können Sie die Anforderungshierarchie erweitern und ausblenden:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie den Anforderungsordner aus, und fahren Sie mit einer der folgenden Optionen fort:
    • Klicken Sie auf Erweitern links neben dem Namen des Anforderungsordners, um den Ordner einzublenden.
    • Klicken Sie auf Ausblenden links neben dem Namen des Anforderungsordners, um den Ordner auszublenden.
    • Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Erweitern oder Ausblenden. Mit dem Befehl im Kontextmenü können Sie zwei, drei oder alle Ebenen gleichzeitig einblenden.
Übergeordnetes Thema: Anforderungshierarchie


Filtern der Anforderungshierarchie

Wenn Sie eine untergeordnete Hierarchie filtern, werden nur der ausgewählte Knoten und die untergeordneten Knoten angezeigt. Alle anderen Knoten werden vorübergehend ausgeblendet. Dies ist vor allem dann hilfreich, wenn Sie ein PDF-Dokument mit einer Teilmenge aller Anforderungen generieren möchten.

So filtern Sie eine untergeordnete Hierarchie der Hierarchie Anforderungen:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie in der Hierarchie Anforderungen mit der rechten Maustaste auf eine Anforderung und anschließend auf Untergeordnete Hierarchie filtern.
    Anmerkung: Auf diese Weise wird automatisch ein benutzerdefinierter Filter in der Filterliste erstellt, die in der Symbolleiste platziert wird. Sie können diesen Filter speichern, indem Sie zunächst auf [image] (Filter bearbeiten) und anschließend auf Erweitert klicken und den Namen des Filters eingeben.
  3. Wenn Sie den Filter deaktivieren möchten, wählen Sie aus der Filterliste in der Symbolleiste die Option <Kein Filter> aus.
Übergeordnetes Thema: Anforderungshierarchie
Zugehörige Konzepte
Filter


Anforderungssymbolleiste

Anforderungen > (Detailansicht)

Anforderungen > (Dokumentansicht)

In der Anforderungssymbolleiste können Sie auf die wichtigsten Befehle für die Arbeit mit Anforderungen zugreifen.

Anmerkung: Einige Befehle in der Anforderungssymbolleiste sind in der Anforderungshierarchie auch in Kontextmenüs verfügbar.

Die folgenden Befehle sind in der Anforderungssymbolleise verfügbar:

Befehl | Symbol | Beschreibung
Detailansicht | Anforderungsansicht | Öffnet die Detailansicht, in der Sie die Eigenschaften einer Anforderung detailliert anzeigen können.
Dokumentansicht | Dokumentansicht | Öffnet die Dokumentansicht, in der ausgewählte Eigenschaften aller Anforderungen in einer einzigen Ansicht angezeigt werden.
Neue Anforderung | Neue Anforderung | Einem aktiven Projekt wird eine neue Anforderung hinzugefügt.
Neue untergeordnete Anforderung | Neue untergeordnete Anforderung | Der ausgewählten Anforderung wird eine neue untergeordnete Anforderung hinzugefügt.
Bearbeiten | Bearbeiten | Die ausgewählte Anforderung wird bearbeitet.
Löschen | Löschen | Die ausgewählte Anforderung wird als obsolet markiert oder unwiederbringlich gelöscht. Obsolete Anforderungen können verborgen, angezeigt und wiederhergestellt werden.
Ausschneiden | Ausschneiden | Eine Anforderung wird aus der Hierarchie Anforderungen ausgeschnitten und in der Zwischenablage gespeichert.
Kopieren | Kopieren | Eine Anforderung wird aus der Hierarchie Anforderungen in die Zwischenablage kopiert.
Einfügen | Einfügen | Eine Anforderung wird aus der Zwischenablage in die Hierarchie Anforderungen eingefügt.
Als untergeordnetes Element einfügen | Als untergeordnetes Element einfügen | Eine Anforderung wird aus der Zwischenablage als untergeordnete Anforderung in die aktuell ausgewählte Anforderung eingefügt.
Nach oben | Nach oben | Eine Anforderung wird in der Hierarchie Anforderungen nach oben verschoben.
Nach unten | Nach unten | Eine Anforderung wird in der Hierarchie Anforderungen nach unten verschoben.
Suchen | Suchen | Alle Anforderungen im aktiven Projekt werden basierend auf konfigurierbaren Parametern durchsucht.
Ersetzen | Ersetzen | Die Instanzen gefundener Werte werden durch einen neuen Wert ersetzt.
Neuer Filter | Neuer Filter | Es wird ein neuer Filter für die Hierarchie Anforderungen erstellt.
Filter |  | Die verfügbaren Filter für die Hierarchie Anforderungen werden aufgelistet.
Filter bearbeiten | Filter bearbeiten | Der ausgewählte Filter wird bearbeitet.
Filter löschen | Filter löschen | Der ausgewählte Filter wird gelöscht.
Filter kopieren | Filter löschen | Der ausgewählte Filter wird kopiert.
Änderungen anzeigen | Änderungen anzeigen | Die letzten Änderungen an den Anforderungen und ihren Eigenschaften werden angezeigt.
Bestätigen | Bestätigen | Die Änderungen an den Anforderungen und ihren Eigenschaften werden bestätigt.
Direkte Abdeckung anzeigen Vollständige Abdeckung anzeigen | Vollständige Abdeckung anzeigen Direkte Abdeckung anzeigen | Es wird zwischen den Modi "Direkte Abdeckung" und "Vollständige Abdeckung" hin und her gewechselt. Diese Schaltfläche ist in der Detailansicht deaktiviert.
Download als PDF | Download als PDF | Generiert eine PDF mit allen aktuell sichtbaren Knoten der Hierarchie Anforderungen und lädt diese PDF herunter. Diese Schaltfläche ist in der Detailansicht deaktiviert.
Übergeordnetes Thema: Anforderungsansichten


Anforderungs-Dokumentansicht

Anforderungen > Dokumentansicht

In der Dokumentansicht wird der Status aller Tests angezeigt, die dem aktiven Projekt zugeordnet sind, einschließlich Anzahl und prozentualer Anteil der bestandenen, fehlgeschlagenen, nicht ausgeführten und nicht abgedeckten Tests. In der Dokumentansicht werden diese Informationen zum Abdeckungsstatus in einem "Thermometerfeld" mit den folgenden Farben dargestellt:

Farbe | Beschreibung
Grün | Bestandene Tests.
Rot | Nicht bestandene Tests.
Orange | Noch nicht ausgeführte Tests.
Grau | Tests mit einem anderen Status.

Die nicht durch Tests abgedeckten Anforderungen werden mit dem Status Nicht abgedeckt angezeigt.

In der Dokumentansicht werden alle benutzerdefinierten Anforderungseigenschaften als Spalten dargestellt.

Anmerkung: Die Gesamtwerte aller derzeitig angezeigten Tests werden auf übergeordneter Ebene zusammengefasst. Wenn Sie die Hierarchie Anforderungen filtern, basieren die Gesamtwerte der Tests lediglich auf den gefilterten Anforderungen. Die Gesamtwerte der Anforderungen umfassen zum Beispiel Tests aller mit dem Filter gewählten untergeordneten Anforderungen, während die Gesamtwerte des Projekts Tests aller mit dem Filter gewählten Anforderungen umfassen.

Die Dokumentansicht speichert die Anzeigeeinstellungen individuell für jeden Benutzer und jedes Projekt.

Übergeordnetes Thema: Anforderungsansichten


Anforderungshistorie

Silk Central bietet eine vollständige Historie aller Änderungen, die an den Anforderungen vorgenommen wurden. Die Informationen in der Historie sind schreibgeschützt und können nicht geändert oder dauerhaft gelöscht werden.

Mit dem Filter Letzte Änderungen (Zugriff über die Schaltfläche Änderungen anzeigen in der Symbolleiste) können Sie rasch die zuletzt an den Anforderungen vorgenommenen Änderungen und Hinzufügungen überprüfen und bestätigen.

Anmerkung: Wenn Sie eine Anforderung mit der Option Endgültig löschen löschen, wird die als obsolet markierte Anforderung gelöscht. Wenn Sie alle zuletzt vorgenommenen Änderungen annehmen, wird ein Änderungseintrag in der Verlaufdatei des Projekts, zu dem die Anforderung gehört, vorgenommen.
  • Anzeigen der letzten Änderungen
    Zeigen Sie die letzten Änderungen an Anforderungen an.
  • Anzeigen der Historie einer Anforderung
    Hier wird beschrieben, wie die Historie einer Anforderung angezeigt werden kann.
  • Anforderungshistorie (Seite)
    Informationen zur Änderungshistorie der ausgewählten Anforderung oder des Projekts.
Übergeordnetes Thema: Anforderungsansichten


Anzeigen der letzten Änderungen

So zeigen Sie die letzten Änderungen an Anforderungen an:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie auf Änderungen anzeigen, um alle Anforderungen herauszufiltern, die seit der letzten Änderungsbestätigung keine Änderungen erfahren haben.
    Anmerkung: Der Filter für letzte Änderungen ist in der Dropdown-Liste Filter standardmäßig ausgewählt.
  3. Wenn Sie die Änderungen überprüft haben, können Sie sie mit Bestätigen akzeptieren. Nach dem Klicken auf Bestätigen wird der Filter Letzte Änderungen zurückgesetzt.
  4. Klicken Sie auf Alles anzeigen, um den Filter aufzuheben und alle Anforderungen anzuzeigen.
Übergeordnetes Thema: Anforderungshistorie
Zugehörige Konzepte
Letzte Änderungen


Anzeigen der Historie einer Anforderung

So zeigen Sie die Historie einer Anforderung an:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Wählen Sie in der Anforderungshierarchie die gewünschte Anforderung aus.
  3. Klicken Sie auf die Registerkarte Verlauf.
  4. Optional: Wenn die Anforderungsmanagementintegration zwischen einem Silk Central-Projekt und einem Caliber-Projekt aktiviert ist, können Sie auf der Seite Historie auf CaliberÖffnen klicken, um die Historie von synchronisierten Anforderungen direkt in Caliber anzuzeigen.
Die Eigenschaften aller von Silk Central protokollierten Revisionen werden in einer Tabelle angezeigt.
Übergeordnetes Thema: Anforderungshistorie


Anforderungshistorie (Seite)

Anforderungen > Detailansicht > <Anforderungen> > Historie

Auf der Seite Historie werden Details zur Überarbeitungshistorie einer Anforderung oder eines Projekts angezeigt. Bei folgenden Aktionen werden Einträge in die Anforderungshistorie geschrieben:

  • Hinzufügen einer neuen Anforderung
  • Bearbeiten einer Anforderung
  • Markieren einer Anforderung als obsolet
  • Hinzufügen eines Anhangs an eine Anforderung
  • Löschen eines Anhangs von einer Anforderung
  • Importieren oder Aktualisieren einer Anforderung in MS Word oder MS Excel

Für jede Änderung werden folgende Spalten auf der Seite angezeigt:

Spalte | Beschreibung
Rev. | Die Revisionsnummer. 1-n.
Geändert am | Datum und Uhrzeit der Änderung.
Geändert Von | Benutzer, der die Änderung vorgenommen hat.
Anmerkungen | Automatisch erzeugte Beschreibung der Änderung. Z. B. "gelöscht" oder "erstellt".
Anmerkung: Wenn die Seite mehr Elemente enthält, als gleichzeitig ohne Verschlechterung der Reaktionszeit angezeigt werden können, werden die Elemente stufenweise angezeigt. Verwenden Sie die Navigationsleiste unten auf der Seite, um die Elemente zu durchsuchen.
Übergeordnetes Thema: Anforderungshistorie


Tests

In diesem Abschnitt wird beschrieben, wie Tests in Silk Central verwaltet werden.

Ein Test oder Testfall umfasst die für die Ausführung notwendigen Vorbedingungen, die Menge der Eingabewerte (ein Eingabewert je Parameter des Testobjekts), die Menge der vorausgesagten Ergebnisse, sowie die erwarteten Nachbedingungen. Testfälle werden entwickelt im Hinblick auf ein bestimmtes Ziel bzw. auf eine Testbedingung, wie z.B. einen bestimmten Programmpfad auszuführen oder die Übereinstimmung mit spezifischen Anforderungen zu prüfen [nach IEEE 610]. Silk Central unterstützt verschiedene Testtypen, und diese können je nach Bedarf strukturiert werden. Im Bereich Tests können Sie die Tests während des gesamten Entwicklungszyklus steuern. Sie können sowohl automatisierte als auch manuelle Tests erstellen, planen und verwalten. Sie können Dateien und Verknüpfungen hochladen und sie Containern und Tests als Anhänge zuordnen. Sie können gefundene Fehler ganz einfach den Tests zuordnen, die zu ihrer Auffindung geführt haben. Sie können in dem Bereich auch die gesamte Änderungshistorie der Tests verfolgen.

  • Konfigurieren von Testeigenschaften und Integrationen
    Bevor sie mit dem Aufbau Ihres Test-Frameworks beginnen können, müssen Sie zumindest ein Projekt und ein Produkt konfigurieren und, wenn Sie automatisierte Tests erstellen möchten, auch ein Versionsverwaltungsprofil.
  • Strukturieren Ihrer Testelemente
    Silk Central speichert die Ergebnisse von Testausführungen im Kontext von Versionen und Builds eines bestimmten Produkts. Deshalb mus zuerst ein Produkt definiert werden, bevor Tests erstellt werden können.
  • Verwalten von Tests
    Fügen Sie Ihrem Test-Framework neue Tests hinzu oder bearbeiten Sie bestehende Tests.
  • Konfigurieren von Testeigenschaften
    Konfigurieren Sie Testeigenschaften wie Attribute, Parameter, Anhänge und Erfolgsbedingungen.
  • Ausführen eines Versuchslaufs eines Tests
    Führen Sie einen Versuchslauf eines Tests aus, um zu prüfen, ob der Test wie gewünscht funktioniert.
  • Bibliotheken
    Bibliotheken sind Sammlungen von Testschritten und Schlüsselwörtern, welche von Tests in verschiedenen Projekten geminsam verwendet werden können.
  • Zuordnen von Anforderungen zu Tests
    Verbinden Sie Ihre Anforderungen und Tests, um messen zu können, wie gut Ihre Software die definierten Anforderungen erfüllt.
  • Testberichte
    Hier werden die Berichte für Tests beschrieben.
  • Zugeordnete Testausführungen
    Fügen Sie Tests zu Testsuiten hinzu, um Ihre Testausführungen während der Entwicklungs- und der Testphase zu steuern.
  • Testansichten
    Hier werden die verfügbaren Ansichten im Bereich Tests erklärt.
Übergeordnetes Thema: Silk Central-Hilfe


Konfigurieren von Testeigenschaften und Integrationen

Bevor sie mit dem Aufbau Ihres Test-Frameworks beginnen können, müssen Sie zumindest ein Projekt und ein Produkt konfigurieren und, wenn Sie automatisierte Tests erstellen möchten, auch ein Versionsverwaltungsprofil. Sie können auch weitere Einstellungen konfigurieren, wie z.B. Filter, Eigenschaften, Attribute, usw. Sie benötigen SuperUser-, Administrator- oder Projektmanager-Berechtigungen um diese Aufgaben ausführen zu können.

  • Verwalten von Produkten, Komponenten und Builds
    Hier wird beschrieben, wie Produkte, Produktkomponenten, Produktversionen und Build-Nummern von Produktversionen erstellt und strukturiert werden.
  • Versionsverwaltungsprofile
    Mithilfe von Versionsverwaltungsprofilen kann Silk Central in externe Versionsverwaltungssysteme integriert werden. Mithilfe von Versionsverwaltungsprofilen kann definiert werden, von wo die Ausführungsserver von Silk Central die Quelldateien zur Testausführung abrufen.
  • Testschritteigenschaften
    Hier wird beschrieben, wie Sie mithilfe von Testschritteigenschaften Schritte in manuellen Tests um zusätzliche Eigenschaften erweitern.
  • Attribute
    Hier wird beschrieben, wie benutzerdefinierte Attribute zum Konfigurieren von Informationen für Tests und Testsuiten verwendet werden.
  • Datenquellen für datengetriebene Tests
    Bei datengetriebenen Tests werden Werte aus einer vorhandenen Datenquelle (z. B. Kalkulationstabelle oder Datenbank) verwendet. Die Verwaltung von Datenquellen geschieht auf Projektebene.
  • Filter
    Hier wird beschrieben, wie Filter zum Auffinden der relevanten Informationen bei gleichzeitigem Ausschluss von nicht benötigten Details verwendet werden.
  • Änderungsbenachrichtigung
    Hier wird beschrieben, wie Sie eine E-Mail-Benachrichtigung bei Änderungen von Anforderungen oder Tests von anderen Benutzern einrichten können.
Übergeordnetes Thema: Tests


Verwalten von Produkten, Komponenten und Builds

Mit Silk Central können Produkte, Produktkomponenten, Produktversionen und Build-Nummern von Produktversionen erstellt und strukturiert werden. Produktspezifikationen können dann Tests zugeordnet werden. Versionen und Builds können Testsuiten zugeordnet werden. Es ist sogar möglich, Produkte und Komponenten zu importieren, die zuvor in Issue Manager definiert wurden.

  • Komponenten sind eigenständige Produktelemente, die zu Testzwecken getrennt voneinander verfolgt werden.
  • Versionen sind Produktausgaben, die zu Entwicklungs- und Testzwecken getrennt voneinander verfolgt werden.
  • Builds sind Iterationen von Versionen, die zu Entwicklungs- und Testzwecken getrennt voneinander verfolgt werden.

Silk Central ermöglicht es auch, Zielplattformen für Tests festzulegen, z. B. Betriebssysteme. Ebenso wie einer Produkt-, Versions- und Buildkonfiguration kann einer Plattform ein Name, eine Beschreibung und der Status aktiv bzw. inaktiv zugeordnet werden.

  • Verwalten von Produkten
    Hier wird beschrieben, wie in Silk Central Produkte konfiguriert werden.
  • Verwalten von Komponenten
    Hier wird beschrieben, wie Komponenten in Produkten konfiguriert werden.
  • Verwalten von Versionen
    Hier wird beschrieben, wie Versionen in Produkten konfiguriert werden.
  • Verwalten von Builds
    Hier wird beschrieben, wie Builds in Versionen verwaltet werden.
  • Verwalten von Plattformen
    Hier wird beschrieben, wie in Silk Central Plattformen konfiguriert werden.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften und Integrationen
Übergeordnetes Thema: Verwaltung


Verwalten von Produkten

Hier wird beschrieben, wie in Silk Central Produkte konfiguriert werden.

  • Hinzufügen von Produkten
    Fügen Sie ein neues Produkt hinzu, um es zu Tests zuzuordnen.
  • Bearbeiten von Produkten
    Bearbeiten Sie ein vorhandenes Produkt.
  • Aktivieren und Deaktivieren von Produkten
    Hier wird beschrieben, wie in Silk Central ein vorhandenes Produkt aktiviert oder deaktiviert wird.
  • Sortieren der Produktliste
    Verschieben Sie Produkte in der Liste nach oben bzw. nach unten, und sortieren Sie die Produktliste automatisch.
  • Löschen von Produkten
    Löschen Sie ein vorhandenes Produkt, um es dauerhaft aus der Produktliste zu löschen.
  • Produktkonfiguration (Seite)
    Mithilfe dieser Seite können Sie Produkte, Komponente, Versionen und Builds konfigurieren.
Übergeordnetes Thema: Verwalten von Produkten, Komponenten und Builds


Hinzufügen von Produkten

So fügen Sie ein neues Produkt hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf Neues Produkt. Der Dialog Neues Produkt wird geöffnet.
  4. Geben Sie einen Namen für das neue Produkt in das Feld Name ein.
  5. Geben Sie im Feld Beschreibung eine Beschreibung für das Produkt ein.
  6. Aktivieren Sie das Kontrollkästchen Aktiv, damit dieses Produkt für die Zuordnung zu Tests verfügbar ist.
  7. Klicken Sie auf OK, um das Produkt zu speichern.
    Anmerkung: Wird ein neues Produkt erstellt, erzeugt Silk Central automatisch eine neue Standardversion 1.0 und einen neuen Standard-Build 1 für dieses neue Produkt.
Übergeordnetes Thema: Verwalten von Produkten


Bearbeiten von Produkten

So bearbeiten Sie ein vorhandenes Produkt:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie in der Spalte Aktionen des Produkts, das Sie bearbeiten möchten, auf Bearbeiten. Das Dialogfeld Produkt bearbeiten wird angezeigt.
  4. Nehmen Sie alle erforderlichen Änderungen vor. Sie können Namen, Beschreibung und den Aktiv-Status des ausgewählten Produkts ändern. Klicken Sie anschließend auf OK.
Übergeordnetes Thema: Verwalten von Produkten


Aktivieren und Deaktivieren von Produkten

So aktivieren oder deaktivieren Sie ein vorhandenes Produkt:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf das Symbol Status des Produkts, das Sie aktivieren oder deaktivieren möchten. Ein Dialogfeld wird geöffnet, in dem Sie das Aktivieren/Deaktivieren bestätigen müssen.
  4. Bestätigen Sie die Meldung, damit der Status des Produkts zwischen Aktiv und Inaktiv umgeschaltet wird.
Übergeordnetes Thema: Verwalten von Produkten
Übergeordnetes Thema: Verwalten von Versionen


Sortieren der Produktliste

So verschieben Sie Produkte in der Liste oder sortieren die Produktliste alphabetisch nach Namen:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie in der Spalte Aktionen des Elements, das Sie verschieben möchten, auf Nach oben oder Nach unten.
  4. Um die Liste alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren.
Übergeordnetes Thema: Verwalten von Produkten


Löschen von Produkten

So löschen Sie ein vorhandenes Produkt:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Deaktivieren Sie das Produkt, das Sie löschen möchten. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren von Produkten.
  4. Klicken Sie in der Spalte Aktionen des Produkts, das Sie entfernen möchten, auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  5. Klicken Sie auf Ja, um mit dem Löschvorgang fortzufahren. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen.
Übergeordnetes Thema: Verwalten von Produkten
Zugehörige Tasks
Aktivieren und Deaktivieren von Produkten


Produktkonfiguration (Seite)

Verwaltung > Produkte, Versionen und Builds > Produkte

Mithilfe dieser Seite können Sie Produkte, Komponente, Versionen und Builds konfigurieren.

Um ein neues Produkt zu erstellen, klicken Sie auf Neues Produkt. Um die Produkte alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren.

Zu jedem aufgeführten Produkt werden folgende Spalten angezeigt:

Spalte | Beschreibung
Aktionen Sie können für ein Produkt folgende Aktionen ausführen:
Verschiebt das Produkt in der Liste um eine Zeile nach oben.
Verschiebt das Produkt in der Liste um eine Zeile nach unten.
Ermöglicht die Bearbeitung des Namens, der Beschreibung und des Status des Produkts.
Löscht das Produkt dauerhaft. Produkte müssen inaktiv sein, bevor sie gelöscht werden können. Wenn ein Produkt bereits einem Test zugeordnet ist, darf es nicht gelöscht werden.
Name | Der Name des Produkts, wie er auf der Benutzeroberfläche und in Berichten angezeigt wird. Klicken Sie auf den Namen eines Produkts, um die Komponenten, Versionen und Builds des Produkts zu ändern.
Beschreibung | Ein Beschreibungstext für das Produkt.
Status | Der Status des Produkts kann Aktiv oder Inaktiv sein. Klicken Sie auf den Status, um den Status in Aktiv bzw. Inaktiv zu ändern.
Erstellt am | Datum, an dem das Produkt erstellt wurde.
Erstellt von | Der Name des Benutzers, der das Produkt erstellt hat.

Auf der Seite werden für ein ausgewähltes Produkt detaillierte Informationen zu enthaltenen Komponenten, Versionen und Builds angezeigt.

Sie enthält folgende Spalten zu den Komponenten des Produkts:

Spalte | Beschreibung
Aktionen | In dieser Spalte können Sie die Komponente löschen.
Name | Name der Komponente. Öffnet den Dialog Komponente bearbeiten.
Beschreibung | Beschreibung der Komponente.
Erstellt am | Datum, an dem die Komponente erstellt wurde.
Erstellt von | Der Name des Benutzers, der die Komponente erstellt hat.
Status | Status der Komponente. Aktiv oder Inaktiv. Klicken Sie auf den Status, um zwischen den Statusoptionen hin und her zu schalten.

Klicken Sie auf Neue Komponente, um eine neue Komponente zu erstellen. Um die Komponenten alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren. Um die Komponentenliste zu aktualisieren, klicken Sie auf Aktualisieren.

Die Seite enthält folgende Elemente zu den Versionen des Produkts:

Element | Beschreibung
Aktionen | In dieser Spalte können Sie die Version löschen oder in der Liste nach oben bzw. unten verschieben.
Name | Der Name der Version. Öffnet den Dialog Version bearbeiten.
Beschreibung | Beschreibung der Version.
Erstellt am | Datum, an dem die Version erstellt wurde.
Erstellt von | Der Name des Benutzers, der die Version erstellt hat.
Status | Status der Version. Aktiv oder Inaktiv. Klicken Sie auf den Status, um zwischen den Statusoptionen hin und her zu schalten.

Um eine neue Version zu erstellen, klicken Sie auf Neue Version. Um die Versionen alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren.

Die Seite enthält folgende Elemente zu den Builds des Produkts:

Element | Beschreibung
Aktionen | Sie können das Build löschen oder mit einem Tag kennzeichnen.
Name | Der Name des Builds. Öffnet den Dialog Build bearbeiten.
Beschreibung | Beschreibung des Builds.
Erstellt am | Datum, an dem das Build erstellt wurde.
Erstellt von | Der Name des Benutzers, der das Build erstellt hat.
Status | Status des Builds. Aktiv oder Inaktiv. Klicken Sie auf den Status, um zwischen den Statusoptionen hin und her zu schalten.

Um ein neues Build zu erstellen, klicken Sie auf Neues Build. Um die Build-Liste alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren. Um die Komponentenliste zu aktualisieren, klicken Sie auf Aktualisieren.

Anmerkung: Um diese Schaltflächen zu aktivieren, müssen Sie im Listenfeld Builds eine Version auswählen.

Klicken Sie auf Zurück, um zur Produktliste zurückzukehren.

Übergeordnetes Thema: Verwalten von Produkten


Verwalten von Komponenten

Komponenten sind eigenständige Produktelemente, die zu Testzwecken getrennt voneinander verfolgt werden.

  • Hinzufügen von Komponenten
    Fügen Sie eine neue Komponente hinzu, um diese beim Testen eines Produkts separat nachzuverfolgen.
  • Bearbeiten von Komponenten
    Bearbeiten Sie eine vorhandene Komponente eines Produkts.
  • Aktivieren und Deaktivieren von Komponenten
    Aktivieren oder Deaktivieren Sie eine vorhandene Komponente eines Produkts.
  • Sortieren der Komponentenliste
    Verschieben Sie Komponenten in der Liste nach oben bzw. nach unten, und sortieren Sie die Komponentenliste automatisch.
  • Löschen von Komponenten
    Löschen Sie eine vorhandene Komponente aus einem Produkt.
Übergeordnetes Thema: Verwalten von Produkten, Komponenten und Builds


Hinzufügen von Komponenten

So fügen Sie einem Produkt eine neue Komponente hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Klicken Sie auf Neue Komponente. Der Dialog Neue Komponente wird geöffnet.
  5. Geben Sie einen Namen für die neue Komponente in das Feld Name ein.
  6. Geben Sie im Feld Beschreibung eine Beschreibung der Komponente ein.
  7. Geben Sie den Typ der Komponente an. Sie können zwischen Software und Dokumentation wählen.
  8. Aktivieren Sie das Kontrollkästchen Aktiv, damit diese Komponente für die Zuordnung zu Produkten verfügbar ist.
  9. Klicken Sie auf OK, um die Komponente zu speichern, oder klicken Sie auf Abbrechen, um den Vorgang abzubrechen.
Übergeordnetes Thema: Verwalten von Komponenten


Bearbeiten von Komponenten

So bearbeiten Sie eine vorhandene Komponente eines Produkts:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Wählen Sie die Komponente, die Sie bearbeiten möchten.
  5. Das Dialogfeld Komponente bearbeiten wird angezeigt. In diesem Dialogfeld können Sie Namen, Beschreibung und den Aktiv-Status der ausgewählten Komponente ändern. Nehmen Sie die erforderlichen Änderungen vor, und klicken Sie dann auf OK.
    Anmerkung: Der Typ einer Komponente kann erst bearbeitet werden, nachdem Sie diese Komponente deaktiviert haben. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren von Komponenten.
Übergeordnetes Thema: Verwalten von Komponenten


Aktivieren und Deaktivieren von Komponenten

So aktivieren oder deaktivieren Sie eine vorhandene Komponente:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Klicken Sie auf das Symbol Status der Komponente, die Sie aktivieren oder deaktivieren möchten. Ein Dialogfeld wird geöffnet, in dem Sie das Aktivieren/Deaktivieren bestätigen müssen.
  5. Bestätigen Sie die Meldung, damit der Status der Komponente zwischen Aktiv und Inaktiv umgeschaltet wird.
Übergeordnetes Thema: Verwalten von Komponenten


Sortieren der Komponentenliste

So verschieben Sie Komponenten in der Liste oder sortieren die Komponentenliste alphabetisch nach Namen:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Wählen Sie im Listenfeld Komponententyp den Typ der Komponenten, die Sie sehen möchten.
  5. Klicken Sie in der Spalte Aktionen des Elements, das Sie verschieben möchten, auf Nach oben oder Nach unten.
  6. Um die Liste alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren.
Übergeordnetes Thema: Verwalten von Komponenten


Löschen von Komponenten

So löschen Sie eine vorhandene Komponente aus einem Produkt:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Deaktivieren Sie die Komponente, die Sie löschen möchten. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren von Komponenten.
  5. Klicken Sie in der Spalte "Aktionen" der Komponente auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  6. Klicken Sie auf Ja, um mit dem Löschvorgang fortzufahren. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen.
Übergeordnetes Thema: Verwalten von Komponenten


Verwalten von Versionen

Versionen sind Produktausgaben, die zu Entwicklungs- und Testzwecken getrennt voneinander verfolgt werden.

  • Hinzufügen von Versionen
    Fügen Sie einem Produkt eine neue Version hinzu, um eine bestimmte Ausgabe für Entwicklungs- und Testzwecke separat nachzuverfolgen.
  • Bearbeiten von Versionen
    Bearbeiten Sie eine vorhandene Version eines Produkts.
  • Aktivieren und Deaktivieren von Produkten
    Hier wird beschrieben, wie in Silk Central ein vorhandenes Produkt aktiviert oder deaktiviert wird.
  • Sortieren der Versionsliste
    Verschieben Sie Versionen in der Liste nach oben bzw. nach unten, und sortieren Sie die Versionsliste automatisch.
  • Löschen von Versionen
    Löschen Sie eine vorhandene Version eines Produkts, um es dauerhaft aus der Versionsliste zu entfernen.
Übergeordnetes Thema: Verwalten von Produkten, Komponenten und Builds


Hinzufügen von Versionen

So fügen Sie einem Produkt eine neue Version hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Klicken Sie auf Neue Version. Der Dialog Neue Version wird geöffnet.
  5. Geben Sie einen Namen für die neue Version in das Feld Name ein.
  6. Geben Sie im Feld Beschreibung eine Beschreibung für die Version ein.
  7. Aktivieren Sie das Kontrollkästchen Aktiv, damit diese Version für die Zuordnung zu Produkten verfügbar ist.
  8. Klicken Sie auf OK, um die Version zu speichern, oder klicken Sie auf Abbrechen, um den Vorgang abzubrechen.
Übergeordnetes Thema: Verwalten von Versionen


Bearbeiten von Versionen

So bearbeiten Sie eine vorhandene Version eines Produkts:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Wählen Sie die Version, die Sie bearbeiten möchten. Das Dialogfeld Version bearbeiten wird angezeigt.
  5. Nehmen Sie alle erforderlichen Änderungen für die ausgewählte Version vor. Sie können Namen, Beschreibung und den Aktiv-Status ändern. Klicken Sie anschließend auf OK.
Übergeordnetes Thema: Verwalten von Versionen


Sortieren der Versionsliste

So verschieben Sie Versionen in der Liste oder sortieren die Versionsliste alphabetisch nach Namen:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Klicken Sie in der Spalte Aktionen des Elements, das Sie verschieben möchten, auf Nach oben oder Nach unten.
  5. Um die Liste alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren.
Übergeordnetes Thema: Verwalten von Versionen


Löschen von Versionen

So löschen Sie eine vorhandene Version eines Produkts:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Deaktivieren Sie die Version, die Sie löschen möchten. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren von Versionen.
  5. Klicken Sie in der Spalte Aktionen des Produkts, das Sie entfernen möchten, auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  6. Klicken Sie auf Ja, um mit dem Löschvorgang fortzufahren. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen.
Übergeordnetes Thema: Verwalten von Versionen


Verwalten von Builds

Builds sind Iterationen von Versionen, die zu Entwicklungs- und Testzwecken getrennt voneinander verfolgt werden.

  • Hinzufügen von Builds
    Fügen Sie ein neues Build hinzu, um eine bestimmte Iteration einer Version zu testen.
  • Bearbeiten von Builds
    Bearbeiten Sie ein vorhandenes Build in einer Version.
  • Aktivieren und Deaktivieren von Builds
    Aktivieren oder Deaktivieren Sie das Build einer Version.
  • Sortieren der Build-Liste
    Verschieben Sie Builds in der Liste nach oben bzw. nach unten, und sortieren Sie die Build-Liste automatisch.
  • Markieren von Builds
    Durch Markieren können Sie einen bestimmten Testlauf eines Builds identifizieren.
  • Löschen von Builds
    Löschen Sie ein vorhandenes Build aus einer Version.
Übergeordnetes Thema: Verwalten von Produkten, Komponenten und Builds


Hinzufügen von Builds

So fügen Sie einer Version ein neues Build hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Wählen Sie in dem Listenfeld Builds für Version die Version aus, der Sie ein Build hinzufügen möchten.
  5. Klicken Sie auf Neues Build. Der Dialog Neues Build wird geöffnet.
  6. Geben Sie einen Namen für den neuen Build in das Feld Name ein.
  7. Geben Sie im Feld Beschreibung eine Beschreibung des Builds ein.
  8. Aktivieren Sie das Kontrollkästchen Aktiv, damit dieses Build für die Zuordnung zu Versionen verfügbar ist.
  9. Klicken Sie auf OK, um das Build zu speichern, oder brechen Sie den Vorgang mit Abbrechen ab.
Übergeordnetes Thema: Verwalten von Builds


Bearbeiten von Builds

So bearbeiten Sie ein vorhandenes Build in einer Version:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Wählen Sie das Build, das Sie bearbeiten möchten.
  5. Das Dialogfeld Build bearbeiten wird angezeigt. In diesem Dialogfeld können Sie Name, Beschreibung und den Aktiv-Status des ausgewählten Builds ändern. Nehmen Sie die erforderlichen Änderungen vor, und klicken Sie dann auf OK.
  6. Aktivieren Sie das Kontrollkästchen Gekennzeichnet, um das Build zu kennzeichnen.
Übergeordnetes Thema: Verwalten von Builds


Aktivieren und Deaktivieren von Builds

So aktivieren oder deaktivieren Sie ein vorhandenes Build:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Klicken Sie auf das Symbol Status des Builds, das Sie aktivieren oder deaktivieren möchten. Ein Dialogfeld wird geöffnet, in dem Sie das Aktivieren/Deaktivieren bestätigen müssen.
  5. Bestätigen Sie die Meldung, damit der Status des Builds zwischen Aktiv und Inaktiv umgeschaltet wird.
Übergeordnetes Thema: Verwalten von Builds


Sortieren der Build-Liste

So verschieben Sie Builds in der Liste oder sortieren die Build-Liste alphabetisch nach Namen:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Wählen Sie in dem Listenfeld Builds für Version die Version, deren Builds Sie sehen möchten.
  5. Klicken Sie in der Spalte Aktionen des Elements, das Sie verschieben möchten, auf Nach oben oder Nach unten.
  6. Um die Liste alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren.
Übergeordnetes Thema: Verwalten von Builds


Markieren von Builds

So löschen Sie Testläufe eines markierten Builds. Wenn die Testläufe, die Sie löschen möchten, markierte Builds enthalten, wird eine Warnmeldung angezeigt, in der Sie die Löschaktion bestätigen müssen. Wenn Sie durch Rechtsklicken auf den Ausführungsknoten eine Massenlöschung vornehmen (alle Elemente oder Elemente eines bestimmten Zeitraums), werden markierte Builds nicht gelöscht.

So markieren Sie ein vorhandenes Build:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Klicken Sie im Bereich Builds auf Build markieren in der Spalte Aktionen des Builds, den Sie markieren möchten. Ein Bestätigungsdialog wird geöffnet.
  5. Klicken Sie auf Ja, um mit dem Markieren fortzufahren. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen.
Übergeordnetes Thema: Verwalten von Builds


Löschen von Builds

So löschen Sie ein vorhandenes Build aus einer Version:
  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Produkte. Auf der Seite Produkte werden alle vorhandenen Produkte angezeigt.
  3. Klicken Sie auf einen Produktnamen. Die Seite Produktdetails wird für dieses Produkt angezeigt.
  4. Deaktivieren Sie das Build, das Sie löschen möchten. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren von Builds.
  5. Klicken Sie in der Spalte "Aktionen" des Builds auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  6. Klicken Sie auf Ja, um mit dem Löschvorgang fortzufahren. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen.
Übergeordnetes Thema: Verwalten von Builds


Verwalten von Plattformen

Richten Sie Zielplattformen für Test ein, z. B. Betriebssysteme. Ebenso wie einer Produkt-, Versions- und Build-Konfiguration können einer Plattform ein Name, eine Beschreibung und der Status "Aktiv" bzw. "Inaktiv" zugeordnet werden.

  • Hinzufügen von Plattformen
    Fügen Sie eine neue Zielplattform für Tests hinzu.
  • Bearbeiten von Plattformen
    Bearbeiten Sie eine vorhandene Plattform.
  • Aktivieren und Deaktivieren von Plattformen
    Aktivieren oder deaktivieren Sie eine vorhandene Plattform in Silk Central.
  • Sortieren der Plattformliste
    Verschieben Sie Plattformen in der Liste nach oben bzw. nach unten, und sortieren Sie die Plattformliste automatisch.
  • Löschen von Plattformen
    Löschen Sie eine vorhandene Plattform, um diese dauerhaft aus der Plattformliste zu löschen.
  • Plattformen (Seite)
    Mithilfe dieser Seite können Sie Plattformen konfigurieren.
Übergeordnetes Thema: Verwalten von Produkten, Komponenten und Builds


Hinzufügen von Plattformen

So fügen Sie eine neue Plattform hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Plattformen. Auf der Seite Plattformen werden alle vorhandenen Plattformen angezeigt.
  3. Klicken Sie auf Neue Plattform. Der Dialog Neue Plattform wird geöffnet.
  4. Geben Sie einen Namen für die neue Plattform in das Feld Name ein.
  5. Geben Sie im Feld Beschreibung eine Beschreibung für die Plattform ein.
  6. Aktivieren Sie das Kontrollkästchen Aktiv, damit diese Plattform für die Zuordnung zu Tests verfügbar ist.
  7. Klicken Sie auf OK, um die Plattform zu speichern.
Übergeordnetes Thema: Verwalten von Plattformen


Bearbeiten von Plattformen

So bearbeiten Sie eine vorhandene Plattform:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Plattformen. Auf der Seite Plattformen werden alle vorhandenen Plattformen angezeigt.
  3. Klicken Sie in der Spalte Aktionen der Plattform, die Sie bearbeiten möchten, auf Bearbeiten.
  4. Das Dialogfeld Plattform bearbeiten wird angezeigt. In diesem Dialogfeld können Sie Namen, Beschreibung und den Aktiv-Status der ausgewählten Plattform ändern. Nehmen Sie die erforderlichen Änderungen vor, und klicken Sie dann auf OK.
Übergeordnetes Thema: Verwalten von Plattformen


Aktivieren und Deaktivieren von Plattformen

Anmerkung: Plattformen, die einer Test zugeordnet sind, können nicht deaktiviert werden.

So aktivieren oder deaktivieren Sie eine vorhandene Plattform:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Plattformen. Auf der Seite Plattformen werden alle vorhandenen Plattformen angezeigt.
  3. Klicken Sie auf das Symbol Status der Plattform, die Sie aktivieren oder deaktivieren möchten. Ein Dialogfeld wird geöffnet, in dem Sie das Aktivieren/Deaktivieren bestätigen müssen.
  4. Bestätigen Sie die Meldung, damit der Status der Plattform zwischen Aktiv und Inaktiv umgeschaltet wird.
Übergeordnetes Thema: Verwalten von Plattformen


Sortieren der Plattformliste

So verschieben Sie Plattformen in der Liste oder sortieren die Plattformliste alphabetisch nach Namen:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Plattformen. Auf der Seite Plattformen werden alle vorhandenen Plattformen angezeigt.
  3. Klicken Sie in der Spalte Aktionen des Elements, das Sie verschieben möchten, auf Nach oben oder Nach unten.
  4. Um die Plattformen alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren.
Übergeordnetes Thema: Verwalten von Plattformen


Löschen von Plattformen

So löschen Sie eine vorhandene Plattform:

  1. Klicken Sie im Menü auf Verwaltung > Produkte, Versionen und Builds.
  2. Klicken Sie auf die Registerkarte Plattformen. Auf der Seite Plattformen werden alle vorhandenen Plattformen angezeigt.
  3. Deaktivieren Sie die Plattform, die Sie löschen möchten. Weitere Informationen finden Sie unter Aktivieren/Deaktivieren von Plattformen.
  4. Klicken Sie in der Spalte Aktionen der Plattform, die Sie entfernen möchten, auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  5. Klicken Sie auf Ja, um mit dem Löschvorgang fortzufahren. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen.
Übergeordnetes Thema: Verwalten von Plattformen
Zugehörige Tasks
Aktivieren und Deaktivieren von Plattformen


Plattformen (Seite)

Administration > Plattformen

Mithilfe dieser Seite können Sie Plattformen konfigurieren.

Um eine neue Plattform zu erstellen, klicken Sie auf Neue Plattform. Weitere Informationen finden Sie unter Hinzufügen von Plattformen.

Um die Plattformen alphabetisch nach Namen zu sortieren, klicken Sie auf Nach Namen sortieren. Weitere Informationen finden Sie unter Sortieren der Plattformliste.

Zu jeder aufgeführten Plattform werden folgende Spalten angezeigt:

Spalten | Beschreibung
Aktionen Der Benutzer kann mit einer Plattform die folgenden Aktionen ausführen:
Verschiebt die Plattform in der Liste um eine Zeile nach oben.
Verschiebt die Plattform in der Liste um eine Zeile nach unten.
Löscht die Plattform dauerhaft. Plattformen müssen inaktiv sein bevor sie gelöscht werden können. Wenn eine Plattform bereits einer Test zugeordnet ist, darf sie nicht gelöscht werden.
Name | Der Name der Plattform, so wie er auf der Benutzeroberfläche und in Berichten angezeigt wird. Klicken Sie auf den Namen einer Plattform, wenn Sie den Namen, die Beschreibung oder den Status der Plattform ändern möchten.
Beschreibung | Ein Beschreibungstext für die Plattform.
Status | Der Status der Plattform kann Aktiv oder Inaktiv sein. Klicken Sie auf den Status, um den Status in Aktiv bzw. Inaktiv zu ändern.
Erstellt am | Datum, an dem die Plattform erstellt wurde.
Erstellt von | Der Name des Benutzers, der die Plattform erstellt hat.
Übergeordnetes Thema: Verwalten von Plattformen
Zugehörige Tasks
Hinzufügen von Plattformen
Sortieren der Plattformliste


Versionsverwaltungsprofile

Mithilfe von Versionsverwaltungsprofilen kann Silk Central in externe Versionsverwaltungssysteme integriert werden. Mithilfe von Versionsverwaltungsprofilen kann definiert werden, von wo die Ausführungsserver von Silk Central die Quelldateien zur Testausführung abrufen.

Auf dem Ausführungsserver ist die doppelte Menge an freiem Festplattenspeicher zum Speichern von Quelldateien erforderlich, weil Silk Central die gesamte Verzeichnisstruktur aus der Versionsverwaltung auscheckt und dann ein Arbeitsverzeichnis mit den ausführbaren Quelldateien anlegt.

Weitere Versionsverwaltungssysteme können durch die Installation eines Plug-Ins konfiguriert werden. Für weitere Informationen hierzu, wenden Sie sich bitte an die Silk Central API Hilfe. Folgende Versionsverwaltungssysteme werden von Silk Central standardmäßig unterstützt:

  • AccuRev
    Hier wird beschrieben, wie AccuRev-Versionsverwaltungsprofile konfiguriert werden.
  • Apache Commons Virtual File System
    Hier wird beschrieben, wie die Virtual File System-Versionsverwaltungsprofile konfiguriert werden.
  • Git
    Hier wird beschrieben, wie Git-Versionsverwaltungsprofile konfiguriert werden.
  • Microsoft Team Foundation Server
    Hier wird beschrieben, wie Team Foundation Server-Versionsverwaltungsprofile konfiguriert werden.
  • Silk Test Workbench
    Hier wird beschrieben, wie Silk Test Workbench-Versionsverwaltungsprofile konfiguriert werden.
  • StarTeam
    Hier wird beschrieben, wie StarTeam-Versionsverwaltungsprofile konfiguriert werden.
  • Subversion
    Hier wird beschrieben, wie Subversion-Versionsverwaltungsprofile konfiguriert werden.
  • SilkTestPartner
    Hier wird beschrieben, wie TestPartner-Versionsverwaltungsprofile konfiguriert werden.
  • Universal Naming Convention
    Hier wird beschrieben, wie Universal Naming Convention-Versionsverwaltungsprofile konfiguriert werden.
  • Löschen von Versionsverwaltungsprofilen
    Löschen Sie ein vorhandenes Versionsverwaltungsprofil, wenn das Profil nicht mehr erforderlich ist.
  • Versionsverwaltungsprofile (Seite)
    Hier werden alle Fehlerverfolgungsprofile aufgelistet, die für die Integration von externen Versionsverwaltungssystemen in Silk Central konfiguriert sind.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften und Integrationen
Übergeordnetes Thema: Projekteinstellungen
Zugehörige Konzepte
API-Hilfe


AccuRev

In diesem Abschnitt wird beschrieben, wie AccuRev-Versionsverwaltungsprofile konfiguriert werden.

AccuRev ist ein Software-Konfigurationsverwaltungswerkzeug, welches dank seiner Stream-basierten Architektur komplexe Umgebungen mit paralleler und verteilter Software-Entwicklung unterstützt. So beschleunigen Sie den Software-Entwicklungsprozess und verbessern die Wiederverwendung Ihrer Sourcen.

Folgende AccuRev-Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: AccuRev 6.2

  • Hinzufügen von AccuRev-Versionsverwaltungsprofilen
    Erstellen Sie ein AccuRev-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus AccuRev abzurufen.
  • Bearbeiten von AccuRev-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes AccuRev-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von AccuRev-Versionsverwaltungsprofilen

So erstellen Sie ein AccuRev-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Versionsverwaltungsprofil wird geöffnet.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie AccuRev im Listenfeld Versionsverwaltungssystem aus.
  6. Falls erforderlich, geben Sie einen gültigen AccuRev-Benutzernamen und ein Kennwort ein.
  7. Geben Sie den Namen des AccuRev-Server ein, auf den Sie zugreifen möchten. Falls Sie nicht den Standard-Port von AccuRev verwenden, geben Sie <Servername>:<Port-Nummer> an.
  8. Geben Sie den Namen des AccuRev-Stream ein, zum Beispiel backing stream.
  9. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  10. Geben Sie den Projektpfad ein, den das Profil verwenden soll. Klicken Sie auf Durchsuchen, um den Dialog Projektpfad auswählen anzuzeigen. Der Dialog Projektpfad auswählen wird geöffnet. Wählen Sie in der Hierarchieansicht den gewünschten Projektpfad und klicken Sie auf OK. Wenn Sie das Feld leer lassen, wird das Stammverzeichnis als Projektpfad verwendet.
  11. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: AccuRev


Bearbeiten von AccuRev-Versionsverwaltungsprofilen

So ändern Sie ein AccuRev-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Repository verwendet.
  6. Ändern Sie den Namen des AccuRev-Server, auf den Sie zugreifen möchten. Falls Sie nicht den Standard-Port von AccuRev verwenden, geben Sie <Servername>:<Port-Nummer> an.
  7. Ändern Sie den Namen des AccuRev-Stream, zum Beispiel backing stream.
  8. Optional: Ändern Sie den Gemeinsamer Arbeitsordner, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  9. Ändern Sie den Projektpfad, den das Profil verwenden soll.
  10. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: AccuRev


Apache Commons Virtual File System

In diesem Abschnitt wird beschrieben, wie Virtual File System-Versionsverwaltungsprofile (VFS) konfiguriert werden.

Ein Virtual File System (VFS) ist eine Abstraktionsschicht über einem realen Dateisystem. Ein VFS soll Client-Anwendungen den einheitlichen Zugriff auf unterschiedliche Typen des realen Dateisystems ermöglichen. Apache Commons VFS stellt eine einzelne API für den Zugriff auf eine Vielzahl von Dateisystemen bereit. Es bietet eine einheitliche Ansicht der Dateien aus verschiedenen Quellen. Folgende Protokolle werden aktuell für VFS von Silk Central unterstützt:

Protokoll
Beschreibung
http
Kopiert die angegebene Datei. Bei diesem Protokolltyp wird auch das Kopieren und Entpacken von ZIP-, JAR- und anderen gepackten Dateien unterstützt. Dafür müssen Sie eine .zip-Datei auf einem HTTP-Server angeben. Zum Beispiel zip:http://myTestServer/myTests.zip. Die .zip-Datei wird auf dem Ausführungsserver extrahiert.
ftp
Kopiert die angegebene Datei. Bei diesem Protokolltyp wird auch das Kopieren und Entpacken von ZIP-, JAR- und anderen gepackten Dateien unterstützt.
smb
Server Message Block (smb) kopierte alle Dateien und Ordner. Dieses Protokoll kann anstelle eines UNC-Profils verwendet werden. Beispiel: Der smb-Pfad von VFS, smb://Servername/Pfadname-der-freigegebenen-Ressource, entspricht dem UNC-Pfad \\Servername\Pfadname-der-freigegebenen-Ressource.
Anmerkung: Wenn Sie einen neuen ProcessExecutor-Test erstellen, der VFS für die Versionsverwaltung verwendet, müssen Sie den vollständigen Pfad zur ausführbaren Datei im Feld Name der ausführbaren Datei eingeben.
  • Hinzufügen von VFS-Versionsverwaltungsprofilen
    Erstellen Sie ein VFS-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus VFS abzurufen.
  • Bearbeiten von VFS-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes VFS-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von VFS-Versionsverwaltungsprofilen

So erstellen Sie ein VFS-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Versionsverwaltungsprofil wird geöffnet.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie VFS im Listenfeld Versionsverwaltungssystem aus.
  6. Geben Sie den URL für das VFS-Repository ein, auf das Sie zugreifen möchten. Bei diesem Feld wird zwischen Groß- und Kleinschreibung unterschieden. Geben Sie den entsprechenden Protokolltyp in dem URL an:
    FTP
    ftp://<FTP Server-URL>
    HTTP
    http://<HTTP Server-URL>
    SMB
    smb://<Samba Server-URL>
    Anmerkung: HTTP, FTP und SMB werden auch für gepackte Dateien unterstützt. Um auf eine gepackte Datei zu zeigen, muss der URL in <Typ der gepackten Datei>:<Protokoll>://<Server-URL, der auf die gepackte Datei zeigt> geändert werden, damit der Typ der gepackten Datei einbezogen wird. Zum Beispiel: zip:http://193.80.200.135/<Pfad>/archive.zip oder jar:http://193.80.200.135/<Pfad>/archive.jar.
  7. Geben Sie einen gültigen Benutzernamen für VFS und das entsprechende Kennwort ein. Mit diesen Benutzerdaten wird der Zugriff auf das VFS-Repository durchgeführt. Das SMB-Protokoll unterstützt die Angabe des Domänennamens im Benutzernamen in folgender Form: domain/username.
  8. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  9. Geben Sie den Projektpfad ein, den das Profil verwenden soll. Klicken Sie auf Durchsuchen, um den Dialog Projektpfad auswählen anzuzeigen. Der Dialog Projektpfad auswählen wird geöffnet. Wählen Sie in der Hierarchieansicht den gewünschten Projektpfad und klicken Sie auf OK. Wenn Sie das Feld leer lassen, wird das Stammverzeichnis als Projektpfad verwendet.
  10. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: Apache Commons Virtual File System


Bearbeiten von VFS-Versionsverwaltungsprofilen

So ändern Sie ein VFS-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Ändern Sie den URL für das VFS-Repository, auf das Sie zugreifen möchten.
    Anmerkung: Bei diesem Feld wird zwischen Groß- und Kleinschreibung unterschieden.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Repository verwendet.
  7. Optional: Ändern Sie den Gemeinsamer Arbeitsordner, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  8. Ändern Sie den Projektpfad, den das Profil verwenden soll.
  9. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: Apache Commons Virtual File System


Git

In diesem Abschnitt wird beschrieben, wie Git-Versionsverwaltungsprofile konfiguriert werden.

Git ist ein verteiltes Revisionskontroll- und Versionsverwaltungssystem (SCM), bei dem vor allem auf eine performante Implementierung geachtet wurde. Jedes Git-Arbeitsverzeichnis ist ein vollständiges Repository, inklusive der Versionsgeschichte (history) und den kompletten Versionsverwaltungsressourcen, unabhängig von einer Netzwerkverbindung oder einem zentralen Server.

  • Hinzufügen von Git-Versionsverwaltungsprofilen
    Erstellen Sie ein Git-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus Git abzurufen.
  • Bearbeiten von Git-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes Git-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von Git-Versionsverwaltungsprofilen

So erstellen Sie ein Git-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Versionsverwaltungsprofil wird geöffnet.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie Git im Listenfeld Versionsverwaltungssystem aus.
  6. Geben Sie die URL für das Git-Repository ein, auf das Sie zugreifen möchten.
    Anmerkung: Bei diesem Feld wird zwischen Groß- und Kleinschreibung unterschieden.
  7. Falls erforderlich, geben Sie einen gültigen Git-Benutzernamen und ein Kennwort ein.
  8. Optional: Geben Sie einen Branch ein, um einen bestimmten Branch auszuchecken. Lassen Sie das Feld leer um den Master-Branch auszuchecken.
  9. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  10. Geben Sie den Projektpfad ein, den das Profil verwenden soll. Klicken Sie auf Durchsuchen, um den Dialog Projektpfad auswählen anzuzeigen. Der Dialog Projektpfad auswählen wird geöffnet. Wählen Sie in der Hierarchieansicht den gewünschten Projektpfad und klicken Sie auf OK. Wenn Sie das Feld leer lassen, wird das Stammverzeichnis als Projektpfad verwendet.
  11. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Tipp: Wenn Sie für eine bestimmte Testsuite einen bestimmten Branch aus dem Repository auschecken möchten, geben Sie den Namen des Branches im Feld Label der Versionsverwaltung in der entsprechenden Testsuite ein. Weitere Informationen finden Sie in Erstellen von Testsuiten. Diese Einstellung überschreibt den angegebenen Branch im Git-Versionsverwaltungsprofil.
Übergeordnetes Thema: Git
Zugehörige Tasks
Erstellen von Testsuiten


Bearbeiten von Git-Versionsverwaltungsprofilen

So ändern Sie ein Git-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Geben Sie die URL für das Git-Repository ein, auf das Sie zugreifen möchten.
    Anmerkung: Bei diesem Feld wird zwischen Groß- und Kleinschreibung unterschieden.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Repository verwendet.
  7. Optional: Geben Sie einen Branch ein, um einen bestimmten Branch auszuchecken. Lassen Sie das Feld leer um den Master-Branch auszuchecken.
  8. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  9. Geben Sie den Projektpfad ein, den das Profil verwenden soll. Klicken Sie auf Durchsuchen, um den Dialog Projektpfad auswählen anzuzeigen. Der Dialog Projektpfad auswählen wird geöffnet. Wählen Sie in der Hierarchieansicht den gewünschten Projektpfad und klicken Sie auf OK. Wenn Sie das Feld leer lassen, wird das Stammverzeichnis als Projektpfad verwendet.
  10. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Tipp: Wenn Sie für eine bestimmte Testsuite einen bestimmten Branch aus dem Repository auschecken möchten, geben Sie den Namen des Branches im Feld Label der Versionsverwaltung in der entsprechenden Testsuite ein. Weitere Informationen finden Sie in Erstellen von Testsuiten. Diese Einstellung überschreibt den angegebenen Branch im Git-Versionsverwaltungsprofil.
Übergeordnetes Thema: Git
Zugehörige Tasks
Erstellen von Testsuiten


Microsoft Team Foundation Server

In diesem Abschnitt wird beschrieben, wie Team Foundation Server-Versionsverwaltungsprofile (TFS) konfiguriert werden.

Folgende TFS Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: Team Foundation Server 2012, 2013, 2015

Anmerkung: Zum Hinzufügen eines TFS-Versionsverwaltungsprofils muss der Befehlszeilen-Client Microsoft Visual Studio Team Explorer Everywhere 2015 (Englische Ausgabe) auf dem Front-End-Server sowie auf jedem Ausführungsserver, auf dem Sie das Versionsverwaltungsprofil verwenden möchten, installiert werden. Sie können die CLC-Datei vom Microsoft Download Center herunterladen. Damit die Integration funktioniert, müssen Sie Team Explorer Everywhere zuerst ausführen und die Lizenzvereinbarung akzeptieren. Weitere Informationen hierzu finden Sie in diesem Knowledge Base Artikel.
  • Hinzufügen von TFS-Versionsverwaltungsprofilen
    Erstellen Sie ein TFS-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus TFS abzurufen.
  • Bearbeiten von TFS-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes TFS-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von TFS-Versionsverwaltungsprofilen

Zum Hinzufügen eines TFS-Versionsverwaltungsprofils muss der Befehlszeilen-Client Microsoft Visual Studio Team Explorer Everywhere 2015 (Englische Ausgabe) auf dem Front-End-Server sowie auf jedem Ausführungsserver, auf dem Sie das Versionsverwaltungsprofil verwenden möchten, installiert werden. Sie können die CLC-Datei vom Microsoft Download Center herunterladen. Damit die Integration funktioniert, müssen Sie Team Explorer Everywhere zuerst ausführen und die Lizenzvereinbarung akzeptieren. Weitere Informationen hierzu finden Sie in diesem Knowledge Base Artikel.

So erstellen Sie ein TFS-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Versionsverwaltungsprofil wird geöffnet.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie im Listenfeld Versionsverwaltungssystem die Option Team Foundation Server aus.
  6. Geben Sie den URL Ihrer TFS-Installation ein. Z. B.: http://tfsserver:8080/tfs.
  7. Geben Sie die Domäne des TFS-Benutzers ein.
  8. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Mit diesen Daten wird der Zugriff auf das Repository durchgeführt.
  9. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  10. Geben Sie den Projektpfad ein, den das Profil verwenden soll. Klicken Sie auf Durchsuchen, um den Dialog Projektpfad auswählen anzuzeigen. Der Dialog Projektpfad auswählen wird geöffnet. Wählen Sie in der Hierarchieansicht den gewünschten Projektpfad und klicken Sie auf OK. Wenn Sie das Feld leer lassen, wird das Stammverzeichnis als Projektpfad verwendet.
  11. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: Microsoft Team Foundation Server


Bearbeiten von TFS-Versionsverwaltungsprofilen

Zum Hinzufügen eines TFS-Versionsverwaltungsprofils muss der Befehlszeilen-Client Microsoft Visual Studio Team Explorer Everywhere 2015 (Englische Ausgabe) auf dem Front-End-Server sowie auf jedem Ausführungsserver, auf dem Sie das Versionsverwaltungsprofil verwenden möchten, installiert werden. Sie können die CLC-Datei vom Microsoft Download Center herunterladen. Damit die Integration funktioniert, müssen Sie Team Explorer Everywhere zuerst ausführen und die Lizenzvereinbarung akzeptieren. Weitere Informationen hierzu finden Sie in diesem Knowledge Base Artikel.

So ändern Sie ein TFS-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Ändern Sie den URL für das TFS-Repository, auf das Sie zugreifen möchten.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Repository verwendet.
  7. Optional: Ändern Sie den Gemeinsamer Arbeitsordner, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  8. Ändern Sie den Projektpfad, den das Profil verwenden soll.
  9. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: Microsoft Team Foundation Server


Silk Test Workbench

In diesem Abschnitt wird beschrieben, wie Silk Test Workbench-Versionsverwaltungsprofile konfiguriert werden.

Silk Test Workbench ist ein automatisiertes Testprogramm, das die Funktionstests komplexer Anwendungen beschleunigt. Silk Test Workbench bietet Unterstützung für Testanwendungen, die mit einer Vielzahl unterschiedlicher Entwicklungsprogramme hergestellt wurden, etwa Java, .NET, browserbasierte Webanwendungen und COM-Komponenten wie ActiveX-Steuerelemente und Automatisierungsobjekte. Mit Silk Test Workbench können Sie mit Ihren Anwendungen Benutzersitzungen aufzeichnen, um Tests zu erstellen, diese durch Validierungs- und Testlogik zu ergänzen und Tests erneut auszuführen, um sicherzugehen, dass die Anwendungen erwartungsgemäß funktionieren.

Anmerkung: Zum Hinzufügen eines Silk Test Workbench-Versionsverwaltungsprofils muss der Silk Test Workbench-Client auf dem Front-End-Server sowie auf jedem Ausführungsserver, auf dem Sie das Versionsverwaltungsprofil verwenden möchten, installiert werden.
  • Hinzufügen von Silk Test Workbench-Versionsverwaltungsprofilen
    Erstellen Sie ein Silk Test Workbench-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus Silk Test Workbench abzurufen.
  • Bearbeiten von Silk Test Workbench-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes Silk Test Workbench-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von Silk Test Workbench-Versionsverwaltungsprofilen

So erstellen Sie ein Silk Test Workbench-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil, um den Dialog Neues Fehlerverfolgungsprofil zu öffnen.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie Silk Test Workbench-Test im Listenfeld Versionsverwaltungssystem aus.
  6. Wählen Sie im Listenfeld Datenbanktyp SQL Server oder Oracle.
    Anmerkung: Der Datenbanktyp Microsoft Office Access wird nicht unterstützt. Für die Verbindung mit einer Silk Test Workbench Oracle-Datenbank besteht die Silk Test Workbench-Anforderung, dass der TNS-Name mit dem Hostnamen des Servers identisch sein muss.
  7. Geben Sie im Feld Datenbank-Server den Namen des Silk Test Workbench-Datenbankservers ein.
  8. Geben Sie im Feld Datenbank-Name den Namen der Silk Test Workbench-Datenbank ein.
  9. Geben Sie im Feld Datenbank-Port die Portnummer des Silk Test Workbench-Datenbankservers ein.
  10. Geben Sie im Feld Datenbank-Schema/Besitzername das Datenbank-Schema oder den Besitzernamen von Silk Test Workbench ein.
  11. Geben Sie im Feld Datenbank-Benutzer den Namen des Datenbankbenutzers ein.
  12. Geben Sie im Feld Datenbank-Kennwort das Kennwort für den Datenbankbenutzer ein.
  13. Optional: Geben Sie in den Feldern Silk Test Workbench-Benutzername und Silk Test Workbench-Kennwort gültige Silk Test Workbench-Benutzerdaten ein. Werden diese Felder leer gelassen, wird der Windows-Benutzer verwendet, unter dem der Ausführungsserverdienst läuft.
  14. Klicken Sie auf Projekt(e) laden. Alle Projekte werden in der Liste Projekte aufgeführt.
  15. Wählen Sie eines oder mehrere Projekte aus.
  16. Klicken Sie auf OK.
Übergeordnetes Thema: Silk Test Workbench


Bearbeiten von Silk Test Workbench-Versionsverwaltungsprofilen

So ändern Sie ein Silk Test Workbench-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Bearbeiten Sie den Silk Test Workbench-Datenbanktyp.
    Anmerkung: Der Datenbanktyp Microsoft Office Access wird nicht unterstützt.
  6. Bearbeiten Sie, soweit erforderlich, die anderen Einstellungen.
  7. Klicken Sie auf OK.
Übergeordnetes Thema: Silk Test Workbench


StarTeam

In diesem Abschnitt wird beschrieben, wie StarTeam-Versionsverwaltungsprofile konfiguriert werden.

StarTeam fördert durch die zentrale Kontrolle aller Projektkomponenten und -ressourcen die Kommunikation und Zusammenarbeit im Team. Durch den geschützten und doch flexiblen Zugriff wird sichergestellt, dass die Teammitglieder jederzeit und überall mithilfe der vielfältigen Auswahl an Web-, Desktop, IDE- und Befehlszeilen-Clients arbeiten können. StarTeam stellt eine umfassende Lösung dar, die integriertes Anforderungsmanagement, Änderungsmanagement, Fehlerverfolgung, Dateiversionsverwaltung, Diskussionsverfolgung sowie Projekt- und Taskmanagement beinhaltet.

Folgende StarTeam-Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: StarTeam 15.x, 16.x

  • Hinzufügen von StarTeam-Versionsverwaltungsprofilen
    Erstellen Sie ein StarTeam-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus StarTeam abzurufen.
  • Bearbeiten von StarTeam-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes StarTeam-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von StarTeam-Versionsverwaltungsprofilen

So erstellen Sie ein StarTeam-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Versionsverwaltungsprofil wird geöffnet.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie StarTeam im Listenfeld Versionsverwaltungssystem aus.
  6. Geben Sie den Hostnamen des StarTeam-Servers ein.
  7. Geben Sie den Port ein, über den die Verbindung zum StarTeam-Server hergestellt werden soll. Wenn diese Einstellung nicht geändert wurde, verwenden Sie den Standardport 49201.
  8. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Mit diesen Daten wird der Zugriff auf das Repository durchgeführt.
  9. Geben Sie an, ob das Profil die Verschlüsselung unterstützt.
  10. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  11. Geben Sie den Projektpfad ein, den das Profil verwenden soll. Klicken Sie auf Durchsuchen, um den Dialog Projektpfad auswählen anzuzeigen. Der Dialog Projektpfad auswählen wird geöffnet. Wählen Sie in der Hierarchieansicht den gewünschten Projektpfad und klicken Sie auf OK. Wenn Sie das Feld leer lassen, wird das Stammverzeichnis als Projektpfad verwendet.
  12. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: StarTeam


Bearbeiten von StarTeam-Versionsverwaltungsprofilen

So ändern Sie ein StarTeam-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Hier können Sie folgende Operationen durchführen:
    • Ändern Sie den Hostnamen des StarTeam-Servers.
    • Ändern Sie den Port, über den die Verbindung zum StarTeam-Server hergestellt werden soll. Wenn diese Einstellung nicht geändert wurde, verwenden Sie den Standardport 49201.
    • Geben Sie an, ob das Profil die Verschlüsselung unterstützt.
  6. Ändern Sie den Projektpfad, den das Profil verwenden soll.
  7. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Repository verwendet.
  8. Optional: Ändern Sie den Gemeinsamer Arbeitsordner, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  9. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: StarTeam


Subversion

In diesem Abschnitt wird beschrieben, wie Subversion (SVN)-Versionsverwaltungsprofile konfiguriert werden.

Subversion (SVN) ist der Nachfolger von Concurrent Versions System (CVS). Subversion verwaltet Versionen anhand von Transaktionsnummern. Bei jeder bestätigten Änderung wird die Transaktionsnummer erhöht.

Was in anderen Versionsverwaltungssystemen eine Bezeichnung (Label) ist, entspricht in Subversion einem Tag. Diese Tags werden in dem Subversion-URL verschlüsselt. Beispielsweise ist http://MyHost/svn/MyApp/trunk ein Subversion-URL und http://MyHost/svn/MyApp/tags/build1012 ein Subversion-Tag.

Silk Central unterstützt Subversion-Tags. Enthält ein Subversion-URL das Verzeichnis trunk, können Sie eine Bezeichnung wie z. B. tags/build1012 definieren. Diese Bezeichnung ersetzt trunk im Subversion-URL.

Anmerkung: Wenn Sie eine Bezeichnung definieren und der Subversion-URL kein Verzeichnis trunk enthält, löst Silk Central einen Fehler aus.
  • Hinzufügen von Subversion-Versionsverwaltungsprofilen
    Erstellen Sie ein Subversion-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus Subversion abzurufen.
  • Bearbeiten von Subversion-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes Subversion-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von Subversion-Versionsverwaltungsprofilen

So erstellen Sie ein Subversion-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Versionsverwaltungsprofil wird geöffnet.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie Subversion im Listenfeld Versionsverwaltungssystem aus.
  6. Geben Sie den URL für das Subversion-Repository ein, auf das Sie zugreifen möchten.
    Wenn Ihnen der URL für das Repository nicht bekannt ist, wenden Sie sich an den Subversion-Administrator.
    Anmerkung: Um SSH zu verwenden, fügen Sie ssh zu der URL hinzu. Zum Beispiel: svn+ssh://<hostname>:<port>.
  7. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Mit diesen Daten wird der Zugriff auf das Repository durchgeführt.
  8. Geben Sie einen gültigen SSH-Benutzernamen und ein SSH-Kennwort ein, oder ein SSH-Keyfile. Diese Anmeldeinformationen werden für den Zugriff auf den SSH-Server verwendet. Das Kennwort überschreibt das Keyfile. Falls Sie also nur über ein Keyfile verfügen, lassen Sie das Feld SSH-Kennwort leer. Falls Sie eine Keyfile verwenden, muss der Pfad der Keyfile für jeden Ausführungsserver, der das Versionsverwaltungsprofil verwendet, gültig sein.
  9. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  10. Geben Sie den Projektpfad ein, den das Profil verwenden soll. Klicken Sie auf Durchsuchen, um den Dialog Projektpfad auswählen anzuzeigen. Der Dialog Projektpfad auswählen wird geöffnet. Wählen Sie in der Hierarchieansicht den gewünschten Projektpfad und klicken Sie auf OK. Wenn Sie das Feld leer lassen, wird das Stammverzeichnis als Projektpfad verwendet.
  11. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: Subversion


Bearbeiten von Subversion-Versionsverwaltungsprofilen

So ändern Sie ein Subversion-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Ändern Sie die URL für das Subversion-Repository, auf das Sie zugreifen möchten. Wenn Ihnen die URL für das Repository nicht bekannt ist, wenden Sie sich an den Subversion-Administrator.
    Anmerkung: Wenn Sie die URL für das Subversion-Repository ändern und danach Dateien nicht auschecken können, löschen Sie das Verzeichnis für die Versionsverwaltungsspiegelungen auf dem Ausführungsserver. Zum Beispiel: C:\ProgramData\SilkCentral\SrcCtrlMirrors.
    Anmerkung: Um SSH zu verwenden, fügen Sie ssh zu der URL hinzu. Zum Beispiel: svn+ssh://<hostname>:<port>.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Repository verwendet.
  7. Geben Sie einen gültigen SSH-Benutzernamen und ein SSH-Kennwort ein, oder ein SSH-Keyfile. Diese Anmeldeinformationen werden für den Zugriff auf den SSH-Server verwendet. Das Kennwort überschreibt das Keyfile. Falls Sie also nur über ein Keyfile verfügen, lassen Sie das Feld SSH-Kennwort leer. Falls Sie eine Keyfile verwenden, muss der Pfad der Keyfile für jeden Ausführungsserver, der das Versionsverwaltungsprofil verwendet, gültig sein.
  8. Optional: Ändern Sie den Gemeinsamer Arbeitsordner, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden.
  9. Ändern Sie den Projektpfad, den das Profil verwenden soll.
  10. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: Subversion


SilkTestPartner

In diesem Abschnitt wird beschrieben, wie TestPartner-Versionsverwaltungsprofile konfiguriert werden.

TestPartner ist ein Micro Focus-Produkt zum Testen von Web- und Microsoft Windows-basierten Anwendungen, die Microsoft-Technologie verwenden. TestPartner zeichnet Benutzeraktionen auf, um schnell leistungsfähige Tests zu liefern. Jeder aufgezeichnete Test wird als eine Reihe von Aktionen in kurzen klaren Schritten angezeigt, die auch für unerfahrene Tester leicht verständlich sind. Sie können mit Hilfe der Anwendung Benutzersitzungen aufzeichnen, Validierungsfunktionen hinzufügen und die Sitzungen zu einem späteren Zeitpunkt erneut ausführen, um die ordnungsgemäße Funktion der Anwendung sicherzustellen.

Anmerkung: Zum Hinzufügen eines TestPartner-Versionsverwaltungsprofils muss der TestPartner-Client auf dem Front-End-Server sowie auf jedem Ausführungsserver, auf dem Sie das Versionsverwaltungsprofil verwenden möchten, installiert werden.
  • Hinzufügen von TestPartner-Versionsverwaltungsprofilen
    Erstellen Sie ein TestPartner-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus TestPartner abzurufen.
  • Bearbeiten von TestPartner-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes TestPartner-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von TestPartner-Versionsverwaltungsprofilen

So erstellen Sie ein TestPartner-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Versionsverwaltungsprofil wird geöffnet.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie TestPartner im Listenfeld Versionsverwaltungssystem aus.
    Anmerkung: Für die Verbindung mit einer TestPartner Oracle-Datenbank besteht die TestPartner-Anforderung, dass der TNS-Name mit dem Hostnamen des Servers identisch sein muss.
  6. Wählen Sie im Listenfeld Datenbanktyp SQL Server oder Oracle.
  7. Geben Sie im Feld Datenbank-Server den Namen des Datenbankservers ein.
  8. Geben Sie im Feld Datenbank-Name den Namen der Datenbank ein.
  9. Geben Sie im Feld Datenbank-Port die Portnummer des Datenbankservers ein.
  10. Geben Sie im Feld Datenbank-Schema/Besitzername das Datenbank-Schema oder den Besitzernamen ein.
  11. Geben Sie im Feld Datenbank-Benutzer den Namen des Datenbankbenutzers ein.
  12. Geben Sie im Feld Datenbank-Kennwort das Kennwort für den Datenbankbenutzer ein.
  13. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Mit diesen Daten wird der Zugriff auf das Repository durchgeführt.
  14. Filtern Sie mithilfe des Felds Projektpfad die in der Datenbank für Tests verfügbaren Skripts. Klicken Sie auf Durchsuchen, um den Dialog Projektpfad auswählen anzuzeigen.
    Im Dialogfeld Projektpfad auswählen können Sie aus drei Hierarchie-Ebenen wählen:
    Erste Ebene
    Die gesamte TestPartner-Datenbank. Wenn Sie diese Ebene auswählen, bleibt das Feld Projektpfad leer.
    Zweite Ebene
    Das TestPartner-Projekt.
    Dritte Ebene
    Der Skripttyp innerhalb eines angegebenen TestPartner-Projekts.

    Wählen Sie eine der vorangegangenen Optionen, und klicken Sie auf OK. Der Pfad wird dem Feld Projektpfad hinzugefügt.

  15. Klicken Sie auf OK.
Übergeordnetes Thema: SilkTestPartner


Bearbeiten von TestPartner-Versionsverwaltungsprofilen

So ändern Sie ein TestPartner-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Hier können Sie folgende Operationen durchführen:
    • Bearbeiten Sie den TestPartner-Datenbanktyp.
    • Bearbeiten Sie den TestPartner-Datenbankserver.
    • Bearbeiten Sie den TestPartner-Datenbanknamen.
    • Bearbeiten Sie die TestPartner-Nummer des TestPartner-Datenbankservers.
    • Bearbeiten Sie das/den TestPartner-Datenbank-Schema/Besitzername.
    • Bearbeiten Sie den TestPartner-Datenbankbenutzer.
    • Bearbeiten Sie das TestPartner-Datenbankkennwort.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Repository verwendet.
  7. Ändern Sie den Projektpfad, den das Profil verwenden soll.
  8. Klicken Sie auf OK.
Übergeordnetes Thema: SilkTestPartner


Universal Naming Convention

In diesem Abschnitt wird beschrieben, wie Universal Naming Convention-Versionsverwaltungsprofile (UNC) konfiguriert werden.

UNC steht für "Universal Naming Convention" oder "Uniform Naming Convention" und ist ein PC-Format zur Angabe des Speicherorts von Ressourcen in einem lokalen Netzwerk (LAN). UNC verwendet das folgende Format: \\Servername\Pfadname-der-freigegebenen-Ressource.

Beispielsweise wäre für den Zugriff auf die Datei test.txt im Verzeichnis Beispiele auf dem freigegebenen Server silo folgende Angabe erforderlich: \\silo\Beispiele\test.txt.

Sie können auch freigegebene Peripheriegeräte, z. B. Drucker, im UNC-Format angeben. Mit der UNC-Syntax soll ein Format bereitgestellt werden, das es ermöglicht, jede freigegebene Ressource durch eine eindeutige Adresse zu identifizieren.

UNC wird nur auf Microsoft Windows-Betriebssystemen unterstützt. Wenn Sie den Ausführungsserver unter einem anderen Betriebssystem ausführen möchten, können Sie stattdessen das Versionsverwaltungsprofil Apache Commons VFS verwenden.

  • Hinzufügen von UNC-Versionsverwaltungsprofilen
    Erstellen Sie ein UNC-Versionsverwaltungsprofil, um den Programmcode zur Testausführung aus UNC abzurufen.
  • Bearbeiten von UNC-Versionsverwaltungsprofilen
    Ändern Sie ein vorhandenes UNC-Versionsverwaltungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Versionsverwaltungsprofile
Übergeordnetes Thema: Versionsverwaltungsprofil-Integration


Hinzufügen von UNC-Versionsverwaltungsprofilen

So erstellen Sie ein UNC-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Versionsverwaltungsprofil wird geöffnet.
  4. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  5. Wählen Sie UNC im Listenfeld Versionsverwaltungssystem aus.
  6. Geben Sie den UNC-Pfad ein, auf den Sie zugreifen möchten. Dies ist der Pfad für das Verzeichnis, in dem die Testquellen gespeichert sind.
    Tipp: Um keine unnötigen Dateien auszuchecken, geben Sie einen Ordner auf einer Hierarchiestufe an, in dem sich die Quelldateien befinden, die tatsächlich zur Testausführung benötigt werden.
  7. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden. Falls Sie doch einen statischen Arbeitsordner verwenden möchten, stellen Sie sicher, dass sich dieser nicht innerhalb vom angegebenen UNC-Pfad befindet, da es sonst zu rekursiven Checkouts führt.
  8. Geben Sie einen gültigen UNC-Benutzernamen und ein UNC-Kennwort ein. Diese Benutzerdaten sind für den Zugriff auf den UNC-Pfad der Konfigurationsdatei erforderlich.
  9. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: Universal Naming Convention


Bearbeiten von UNC-Versionsverwaltungsprofilen

So ändern Sie ein UNC-Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf den Namen des Versionsverwaltungsprofils, das geändert werden soll. Der Dialog Versionsverwaltungsprofil bearbeiten wird geöffnet.
  4. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  5. Geben Sie den UNC-Pfad ein, auf den Sie zugreifen möchten. Dies ist der Pfad für das Verzeichnis, in dem die Testquellen gespeichert sind.
    Tipp: Um keine unnötigen Dateien auszuchecken, geben Sie einen Ordner auf einer Hierarchiestufe an, in dem sich die Quelldateien befinden, die tatsächlich zur Testausführung benötigt werden.
  6. Optional: Geben Sie in Gemeinsamer Arbeitsordner den Ordner ein, in den der Ausführungsserver von Silk Central die Quelldateien kopieren soll. Es muss sich dabei um einen lokalen Pfad handeln. Zum Beispiel: C:\TempSources\.
    Warnung: Es wird empfohlen dieses Feld leer zu lassen, so dass Silk Central selbst einen temporären Arbeitsordner bestimmt. Die Verwendung eines statischen Arbeitsordners kann bei parallelen Testausführungen zu unerwarteten Ergebnissen führen. Der temporäre Arbeitsordner kann mit dem vordefinierten Parameter #sctm_source_root_dir abgefragt werden. Falls Sie doch einen statischen Arbeitsordner verwenden möchten, stellen Sie sicher, dass sich dieser nicht innerhalb vom angegebenen UNC-Pfad befindet, da es sonst zu rekursiven Checkouts führt.
  7. Ändern Sie den UNC-Benutzernamen und das UNC-Kennwort. Diese Anmeldeinformationen sind für den Zugriff auf den UNC-Pfad der Konfigurationsdatei erforderlich.
  8. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.

Wenn die Verbindung erfolgreich hergestellt werden konnte, wird wieder die Seite Versionsverwaltung angezeigt.

Übergeordnetes Thema: Universal Naming Convention


Löschen von Versionsverwaltungsprofilen

So löschen Sie ein Versionsverwaltungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Versionsverwaltung. Die Seite Versionsverwaltung wird angezeigt. Hier werden alle Versionsverwaltungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie in der Spalte Aktionen des Fehlerverfolgungsprofils, das Sie löschen möchten, auf Versionsverwaltungsprofil löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  4. Klicken Sie auf Ja. Die Seite Versionsverwaltung wird wieder angezeigt.
Übergeordnetes Thema: Versionsverwaltungsprofile


Versionsverwaltungsprofile (Seite)

Projekt:<Projektname> > Projekteinstellungen > Versionsverwaltung

Mithilfe dieser Seite können Sie Profile zur Integration externer Versionsverwaltungssysteme in Silk Central konfigurieren. Klicken Sie auf Neues Profil, um ein neues Versionsverwaltungsprofil zu erstellen. Für jedes Versionsverwaltungsprofil werden auf der Seite die folgenden Spalten angezeigt:

Element | Beschreibung
Name | Der Name des Profils, so wie er in der Benutzeroberfläche von Silk Central und in Berichten angezeigt wird. Klicken Sie auf den Namen, um das betreffende Profil zu bearbeiten.
Typ | Das externe Versionsverwaltungssystem.
Arbeitsordner | Lokaler Arbeitsordner oder Arbeitsordner auf einem zugeordneten Netzwerklaufwerk, in den temporäre Quelldateien ausgecheckt werden.
Erstellt am | Datum, an dem das Versionsverwaltungsprofil erstellt wurde.
Erstellt von | Der Benutzer, der das Versionsverwaltungsprofil erstellt hat.
Geändert am | Datum, an dem das Versionsverwaltungsprofil zuletzt geändert wurde.
Geändert Von | Der Benutzer, der das Versionsverwaltungsprofil zuletzt geändert hat.
Aktionen | Versionsverwaltungsprofil löschen
Übergeordnetes Thema: Versionsverwaltungsprofile


Testschritteigenschaften

Mit Hilfe von Testschritteigenschaften können Sie Schritte in manuellen Tests um zusätzliche Eigenschaften erweitern. Fügen Sie eine benutzerdefinierte Testschritteigenschaft in Projekte:<Projektname> > Projekteinstellungen hinzu, um die Eigenschaft zu allen manuellen Testschritten im Projekt hinzuzufügen. Fügen Sie eine benutzerdefinierte Testschritteigenschaft in der Bibliothekenhierarchie hinzu, um eine benutzerdefinierte Testschritteigenschaft zu allen manuellen Testschritten in der Bibliothek hinzuzufügen. Die Testschritteigenschaften stehen dann zusammen mit den Standardeigenschaften im Dialogfeld Testschritt für manuelle Test bearbeiten zur Verfügung.

  • Erstellen von Testschritteigenschaften
    Erstellen Sie eine Testschritteigenschaft, um einen manuellen Testschritt zu erweitern.
  • Bearbeiten von Testschritteigenschaften
    Hier wird beschrieben, wie Testschritteigenschaften bearbeitet werden.
  • Löschen von Testschritteigenschaften
    Hier wird beschrieben, wie Testschritteigenschaften gelöscht werden.
  • Testschritteigenschaften (Seite)
    Hier werden alle Eigenschaften angezeigt, die in manuelle Testschritte im gesamten aktiven Projekt übernommen werden können.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften und Integrationen
Übergeordnetes Thema: Projekteinstellungen


Erstellen von Testschritteigenschaften

So erstellen Sie eine Testschritteigenschaft:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Testschritteigenschaften.
  3. Klicken Sie auf Neue Eigenschaft. Das Dialogfeld Neue benutzerdefinierte Testschritteigenschaft wird geöffnet.
  4. Geben Sie einen Namen für die neue Eigenschaft in das Feld Name ein.
    Anmerkung: Testschritteigenschaften werden immer mit dem Typ String deklariert.
  5. Klicken Sie auf OK, damit die Eigenschaft für alle manuellen Testschritte im ausgewählten Silk Central-Projekt verfügbar ist.
    Anmerkung: Um eine Testschritteigenschaft für eine Bibliothek zu erstellen, wählen Sie in der Bibliothekshierarchie den Bibliotheksknoten und fahren mit dem zweiten Schritt fort.
Übergeordnetes Thema: Testschritteigenschaften


Bearbeiten von Testschritteigenschaften

So bearbeiten Sie eine Testschritteigenschaft:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Testschritteigenschaften.
  3. Klicken Sie auf den Namen der Eigenschaft, die Sie bearbeiten möchten. Das Dialogfeld Testschritteigenschaft bearbeiten wird geöffnet.
  4. Bearbeiten Sie den Namen der Eigenschaft im Feld Name.
  5. Klicken Sie auf OK, um die Änderungen zu speichern, oder brechen Sie den Vorgang mit Abbrechen ab.
Übergeordnetes Thema: Testschritteigenschaften


Löschen von Testschritteigenschaften

So löschen Sie eine Testschritteigenschaft:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Testschritteigenschaften.
  3. Klicken Sie in der Spalte Aktionen der Eigenschaft, die Sie löschen möchten, auf Eigenschaft löschen. Ein Dialogfeld wird geöffnet, in dem Sie das Löschen bestätigen müssen.
  4. Klicken Sie auf Ja, um den Vorgang abzuschließen, oder auf Nein, um ihn abzubrechen.
Übergeordnetes Thema: Testschritteigenschaften


Testschritteigenschaften (Seite)

Projekt:<Projektname> > Projekteinstellungen > Testschritteigenschaften

Auf der Seite Testschritteigenschaften werden die Eigenschaften angezeigt, die für manuelle Testschritte im aktiven Projekt verfügbar sind. Auf der Seite Testschritteigenschaften werden für jede benutzerdefinierte Testschritteigenschaft folgende Spalten angezeigt:

Spalte | Beschreibung
Name | Der Name der Testschritteigenschaft.
Aktionen Die folgenden Aktionen können für eine Eigenschaft ausgeführt werden:
  • Eigenschaft löschen
  • Nach oben
  • Nach unten
Übergeordnetes Thema: Testschritteigenschaften


Attribute

Sie können benutzerdefinierte Attribute verwenden, um die Informationen für Tests und Testsuiten anzupassen. Die von Silk Central bereitgestellten Attribute (z. B. Priorität, Komponenten und Plattform) sind für viele Situationen ausreichend. Sie können aber auch eigene Attribute definieren, um Tests und Testsuiten spezifisch anzupassen oder für Kompatibilität mit bestimmten Testfällen zu sorgen.

  • Erstellen von benutzerdefinierten Attributen
    Erstellen Sie ein benutzerdefiniertes Attribut, um Informationen für Tests und Testsuiten anzupassen.
  • Typen der benutzerdefinierten Attribute und Anforderungseigenschaften
    Hier werden Details über die Typen der Attribute und Anforderungseigenschaften genauer dargelegt.
  • Bearbeiten von benutzerdefinierten Attributen
    Bearbeiten Sie ein benutzerdefiniertes Attribut, um die Anpassung auf Ihre Testanforderungen anzuwenden.
  • Löschen von benutzerdefinierten Attributen
    Löschen Sie ein benutzerdefiniertes Attribut, wenn die angepassten Informationen nicht mehr erforderlich sind.
  • Attribute (Seite)
    Hier werden die Attribute aufgelistet, die für das aktuelle Projekt erstellt wurden.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften und Integrationen
Übergeordnetes Thema: Projekteinstellungen


Erstellen von benutzerdefinierten Attributen

So erstellen Sie ein benutzerdefiniertes Attribut:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Attribute, um die Liste der aktuellen Attribute anzuzeigen.
  3. Klicken Sie auf Neues Attribut. Der Dialog Neues Attribut wird angezeigt.
  4. Geben Sie einen Namen für das neue Attribut ein. Mit diesem Namen kann in verschiedenen Listenfeldern auf das Attribut zugegriffen werden.
  5. Geben Sie eine Beschreibung für das neue Attribut ein.
  6. Wählen Sie das Attribut Typ aus. Siehe das Thema Typen der benutzerdefinierten Attribute und Anforderungseigenschaften für eine Beschreibung jedes Attributtyps.
  7. Klicken Sie auf OK.
Übergeordnetes Thema: Attribute
Zugehörige Verweise
Typen der benutzerdefinierten Attribute und Anforderungseigenschaften


Bearbeiten von benutzerdefinierten Attributen

So bearbeiten Sie ein benutzerdefiniertes Attribut:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Attribute, um die Liste der aktuellen Attribute anzuzeigen.
  3. Klicken Sie auf den Namen des Attributs, das Sie bearbeiten möchten. Das Dialogfeld Attribut bearbeiten wird angezeigt.
  4. Ändern Sie den Namen des Profils. Wenn das Attribut zur Verwendung verfügbar ist, wird der Name in Listenfeldern für Filter, Testsuiten und Tests angezeigt. Attribute können in globalen Filtern zum Filtern von Attributen verwendet und auf Tests und Testsuiten angewendet werden.
  5. Bearbeiten Sie das Feld Beschreibung des Attributs.
  6. Siehe das Thema Typen der benutzerdefinierten Attribute und Anforderungseigenschaften für eine Beschreibung jedes Attributtyps. Ihnen stehen verschiedene Bearbeitungsfunktionen abhängig vom Attributsdatentyp zur Verfügung.
  7. Klicken Sie auf OK. Die Liste Attribute wird wieder angezeigt.
Übergeordnetes Thema: Attribute
Zugehörige Konzepte
Testattribute
Filter
Zugehörige Verweise
Typen der benutzerdefinierten Attribute und Anforderungseigenschaften


Löschen von benutzerdefinierten Attributen

So löschen Sie ein benutzerdefiniertes Attribut:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Attribute, um die Liste der aktuellen Attribute anzuzeigen.
  3. Bevor Sie ein Attribut löschen können, muss es zunächst deaktiviert werden. Klicken Sie in der Spalte Status auf den Link oder das Symbol Aktiv und dann im Bestätigungsdialogfeld auf Ja, um das Attribut zu deaktivieren.
  4. Wenn das Attribut inaktiv ist, klicken Sie auf Attribut löschen, um es zu entfernen. Ein Dialog wird geöffnet, in dem Sie das Löschen bestätigen müssen.
  5. Klicken Sie auf Ja, um das Attribut zu löschen. Wenn Sie auf Nein klicken, wird es nicht gelöscht. Wenn Sie auf Ja klicken, wird die Seite Attribute ohne das gelöschte Attribut angezeigt.
  6. Falls ein Fehler gemeldet wird, überprüfen Sie, ob das Attribut auf einen Test oder auf eine Testsuite angewendet oder in einem globalen Filter verwendet wird. Sie können nur Attribute löschen, die aktuell nicht verwendet werden.
Übergeordnetes Thema: Attribute


Attribute (Seite)

Projekt:<Projektname> > Projekteinstellungen > Attribute

Auf der Seite Attribute werden die für das aktive Projekt erstellten Attribute angezeigt. Für jedes Attribut werden folgende Spalten auf der Seite Attribute angezeigt:

Spalte | Beschreibung
Aktionen | Die Aktionen, die mit dem Attribut ausgeführt werden können.
Name | Der Name des Attributs. Wenn das Attribut zur Verwendung verfügbar ist, wird der Name in Listenfeldern für Filter, Testsuiten und Tests angezeigt. Attribute können in globalen Filtern zum Filtern von Attributen verwendet und auf Tests und Testsuiten angewendet werden. Klicken Sie auf das Symbol Bearbeiten, um den Namen des Attributs zu bearbeiten.
Typ | Der Typ des Attributs. Siehe das Thema Typen der benutzerdefinierten Attribute und Anforderungseigenschaften für eine Beschreibung jedes Attributtyps.
Status | Der Status des Attributs (Aktiv oder Inaktiv).
Berichts-Spalte | Der Spaltenname des Attributs in der LQM Reporting-Tabelle. Mit diesem Spaltennamen können Sie das ausgewählte Attribut in der LQM Reporting-Tabelle abfragen. Detaillierte Informationen finden Sie in der Dokumentation zum Datenbankmodell.
Erstellt am | Das Datum, an dem das Attribut erstellt wurde.
Erstellt von | Der Name des Benutzers, der das Attribut erstellt hat.
Geändert am | Das Datum, an dem das Attribut zuletzt geändert wurde.
Geändert Von | Der Name des Benutzers, von dem das Attribut zuletzt geändert wurde.
Übergeordnetes Thema: Attribute
Zugehörige Verweise
Typen der benutzerdefinierten Attribute und Anforderungseigenschaften


Datenquellen für datengetriebene Tests

Bei datengetriebenen Tests werden Werte aus einer vorhandenen Datenquelle (z. B. Kalkulationstabelle oder Datenbank) verwendet. Die Verwaltung von Datenquellen geschieht auf Projektebene.
Tipp: Um Änderungen an einer Datenquelle in Silk Central zu bestätigen, müssen Sie das Datenquellenprofil jedes Mal mit der Datenquelle synchronisieren, nachdem die Datenquelle aktualisiert oder verändert wurde.
  • Begrenzungen für Datenquellen
    Datenquellen unterliegen bestimmten Begrenzungen um zu vermeiden, dass Silk Central durch übermäßige Datenerzeugung in einen instabilen Zustand gerät.
  • Konfigurieren von JDBC-Datenquellen
    Konfigurieren Sie eine JDBC-Datenquelle für datengetriebene Tests, um die Tests in Silk Central zu synchronisieren.
  • Konfigurieren von Excel- oder CSV-Datenquellen
    Konfigurieren Sie eine Microsoft Excel- oder CSV-Datenquelle für datengetriebene Tests, um die Tests in Silk Central zu synchronisieren.
  • Herunterladen einer Excel-Datei von einer Datenquelle
    Laden Sie eine Excel-Datei aus einer Silk Central-Datenquelle herunter.
  • Synchronisieren von Datenquellen
    Synchronisieren Sie eine Datenquelle, um die zugehörigen Tests mit den Änderungen in der Datenquelle zu aktualisieren.
  • Hochladen von aktualisierten Excel-Dateien zu einer Datenquelle
    Laden Sie eine aktualisierte Excel-Datei in die Datenquelle hoch, um die aktuell hochgeladene Datei zu ersetzen.
  • Löschen von Datenquellen
    Löschen Sie eine Datenquelle endgültig, wenn sie nicht mehr benötigt wird.
  • Datenquellenkonfigurationsseite
    Hier werden alle Datenquellen aufgelistet, die für die Integration von datengetriebenen Tests in Silk Central konfiguriert sind.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften und Integrationen
Übergeordnetes Thema: Projekteinstellungen
Zugehörige Konzepte
Datengetriebene Tests
Erstellen von datengetriebenen Tests


Begrenzungen für Datenquellen

Datenquellen unterliegen bestimmten Begrenzungen um zu vermeiden, dass Silk Central durch übermäßige Datenerzeugung in einen instabilen Zustand gerät.

Atomare vs. nicht-atomare Tests

Weitere Informationen über die in Silk Central verfügbaren Testtypen finden Sie unter Atomare und nicht-atomare datengetriebene Tests.

Begrenzungen

Datenquellen für datengetriebene Tests unterliegen den folgenden Standard-Begrenzungen:
  • 100 Zeilen für nicht-atomare Tests
  • 1000 Zeilen für atomare Tests
  • 20000 Zeilen+Zellen für XLSX-Datenquellen (20000 ist die Anzahl der Zeilen + die Anzahl der Zellen. Zum Beispiel: Wenn Sie 3000 Zeilen mit 6 Spalten haben, ist die berechnete Anzahl 3000 + (3000 * 6) = 21000, also wurde die Begrenzung überschritten.)
  • 220 Zeichen für DataSet-Namen ((Excel-Arbeitsblattnamen/Tabellennamen)
  • 220 Zeichen für Spalten-Schlüsselnamen
  • Die Länge aller aneinandergehängten Primärschlüssel bei JDBC-, Excel- und CSV-Datenquellen darf 255 Zeichen nicht überschreiten
  • 2000 Zeichen pro Zelle (längere Texte werden abgeschnitten). Beachten Sie, dass datengetriebene Silk Test Classic-Tests nur Datenquellen-Texte in Anführungszeichen akzeptieren. Ist ein Text in einer Zelle länger als 2000 Zeichen, wird der Text abgeschnitten und die hinteren Anführungszeichen fehlen, was zu einem Fehler führt.

Anpassung der Standard-Begrenzungen

Die Standard-Begrenzungen können bei Bedarf angepasst werden. Verändern Sie diese Werte mit Sorgfalt, um übermäßige Datenerzeugung zu vermeiden. Bevor sie diese Werte anpassen, stoppen Sie den Anwendungsserver und starten Sie ihn wieder nachdem Sie Ihre Änderungen gespeichert haben.

Die Zeilen-Begrenzungen für atomare und nicht-atomare Tests können in der Datei TmAppServerHomeConf.xml angepasst werden. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\AppServer auf dem Anwendungsserver. Ändern Sie die Werte der XML-Tags Config/DataDriven/MaxRowsAtomic und Config/DataDriven/MaxRows entsprechend.

Die XLSX-Zellenbegrenzung kann in der Datei configuration.properties im Excel Datenquellen-Plug-In (DS-Excel.zip) angepasst werden. Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Plugins auf dem Anwendungsserver. Ändern Sie den Wert der Eigenschaft excel.importcelllimit entsprechend.

Übergeordnetes Thema: Datenquellen für datengetriebene Tests


Konfigurieren von JDBC-Datenquellen

ACHTUNG:
Außerdem darf die Länge aller aneinandergehängten Primärschlüssel bei JDBC-Datenquellen 255 Zeichen nicht überschreiten.

So konfigurieren Sie eine JDBC-Datenquelle:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Datenquellen. Die Seite Datenquellen wird angezeigt. Hier werden alle Datenquellen aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neue Datenquelle, um den Dialog Neue Datenquelle zu öffnen.
  4. Geben Sie einen Namen für die Datenquelle ein.
  5. Wählen Sie im Listenfeld Typ der Datenquelle den Eintrag JDBC.
    Anmerkung: Wenn Sie eine ODBC-Datenquelle einrichten, müssen Sie die ODBC-Treiberklasse und den URL manuell einfügen. Zum Beispiel Treiberklasse: sun.jdbc.odbc.JdbcOdbcDriver, URL: jdbc:odbc:MeinDatenbankName. Sie müssen auch eine ODBC-Datenquelle in MS Windows in Verwaltung einrichten. Weitere Informationen hierzu finden Sie in der Microsoft Windows-Hilfe. Sind der Front-End-Server und der Anwendungsserver auf verschiedenen Computern installiert, dann stellen Sie sicher, dass der Name der in Microsoft Windows eingerichteten Datenquelle mit dem der ODBC-Datenquelle übereinstimmt. Bei diesen Namen wird zwischen Groß- und Kleinschreibung unterschieden.
  6. Wenn Sie JDBC als Datenquellentyp auswählen, wird das Feld Treiberklasse automatisch ausgefüllt. Ersetzen Sie im Feld URL den Hostnamen <hostname> durch den Namen des Computers, auf dem sich Ihre Datenquelle befindet, und ersetzen Sie den Datenbanknamen <databasename> durch den Namen der Zieldatenbank.
  7. Geben Sie in den Feldern Benutzername und Kennwort gültige Datenbank-Anmeldeinformationen ein.
  8. Optional: Wenn Sie mit einer Datenbank arbeiten, die mehrere Tabellen enthält, aber nur bestimmte Tabellen als Datenquelle verwenden möchten, können Sie nach diesen Tabellen suchen und sie auswählen:
    1. Klicken Sie neben dem Feld Tabellenfilter auf [...].
    2. Das Dialogfeld Tabellenfilter auswählen wird geöffnet. Wählen Sie die Tabellen aus, die Sie als Datenquelle verwenden möchten.
    3. Klicken Sie auf OK.
  9. Optional: Mithilfe der Auswahl der Schlüsselspalte wird für Tests angegeben, welche Arbeitsblattspalten einer Datenquelle als Primärschlüssel verwendet werden. Dies ist hilfreich, wenn an der Datenquelle Änderungen vorgenommen werden (etwa Zeilen in das Arbeitsblatt eingefügt oder daraus entfernt werden). Auch wenn die Datenquelle bearbeitet wurde, können die Tests noch erkennen, welche Spalten oder Zeilen verwendet werden sollen. Für aus datengetriebenen Datenquellen erstellte Tests werden keine Spaltennummern, sondern Schlüsselspaltenwerte im Namen verwendet. So konfigurieren Sie eine Schlüsselspalte:
    1. Klicken Sie neben dem Feld Schlüsselspalten auf [...].
    2. Das Dialogfeld Schlüsselspalte auswählen wird geöffnet. Wählen Sie in der Spaltenliste die Spalte aus, die als Schlüsselspalte fungieren soll.
    3. Klicken Sie auf OK.
  10. Klicken Sie im Dialogfeld Neue Datenquelle auf OK.
Übergeordnetes Thema: Datenquellen für datengetriebene Tests


Konfigurieren von Excel- oder CSV-Datenquellen

ACHTUNG:
Kennwortgeschützte Excel-Arbeitsblätter können nicht als Datenquelle für Silk Central konfiguriert werden. Entfernen Sie den Kennwortschutz eines Arbeitsblatts, um es als Datenquelle für datengetriebene Tests verwenden zu können. Die Länge aller aneinandergehängten Primärschlüssel bei Excel- und CSV-Datenquellen darf 255 Zeichen nicht überschreiten.

So konfigurieren Sie eine Microsoft Excel- oder CSV-Datenquelle:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Datenquellen. Die Seite Datenquellen wird angezeigt. Hier werden alle Datenquellen aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie auf Neue Datenquelle, um den Dialog Neue Datenquelle zu öffnen.
  4. Geben Sie einen Namen für die Datenquelle ein.
  5. Wählen Sie im Listenfeld Typ der Datenquelle den Eintrag MS Excel, um eine Microsoft Excel-Datenquelle zu konfigurieren, oder den Eintrag CSV, um eine CSV-Datenquelle zu konfigurieren.
  6. Wählen Sie im Listenfeld Versionsverwaltungsprofil das vorkonfigurierte Versionsverwaltungsprofil, unter dem Ihre Datendatei gespeichert ist. Weitere Informationen zur Konfiguration von Versionsverwaltungsprofilen finden Sie unter Versionsverwaltungsprofile.
  7. Klicken Sie auf Durchsuchen, um das Dialogfeld Versionsverwaltungspfad auswählen zu öffnen. Suchen Sie in Ihrem Versionsverwaltungsverzeichnis die Datenquellendatei des gewünschten Typs, und wählen Sie sie aus.
  8. Optional: Gilt nur für MS Excel. Wenn Sie mit einer Excel-Arbeitsmappe arbeiten, die mehrere Arbeitsblätter enthält, Sie aber nur bestimmte Arbeitsblätter als Datenquelle verwenden möchten, können Sie nach diesen Arbeitsblättern suchen und sie auswählen. Dazu gehen Sie folgendermaßen vor:
    1. Klicken Sie neben dem Feld Arbeitsblattfilter auf [...].
    2. Das Dialogfeld Arbeitsblattfilter auswählen wird geöffnet. Wählen Sie die Arbeitsblätter aus, die Sie als Datenquelle verwenden möchten.
    3. Klicken Sie auf OK.
  9. Optional: Mithilfe der Auswahl der Schlüsselspalte wird für Tests angegeben, welche Arbeitsblattspalten einer Datenquelle als Primärschlüssel verwendet werden. Dies ist hilfreich, wenn an der Datenquelle Änderungen vorgenommen werden (etwa Zeilen in das Arbeitsblatt eingefügt oder daraus entfernt werden). Auch wenn die Datenquelle bearbeitet wurde, können die Tests noch erkennen, welche Spalten oder Zeilen verwendet werden sollen. Für aus datengetriebenen Datenquellen erstellte Tests werden keine Spaltennummern, sondern Schlüsselspaltenwerte im Namen verwendet.
    Anmerkung: Gilt nur für MS Excel: Umfasst die Datenquelle mehrere Arbeitsblätter, können nur Spalten mit identischen Namen als Schlüsselspalten definiert werden.

    So konfigurieren Sie eine Schlüsselspalte:

    1. Klicken Sie neben dem Feld Schlüsselspalten auf [...].
    2. Das Dialogfeld Schlüsselspalte auswählen wird geöffnet. Wählen Sie in der Spaltenliste die Spalte aus, die als Schlüsselspalte fungieren soll.
    3. Klicken Sie auf OK.
  10. Klicken Sie im Dialogfeld Neue Datenquelle auf OK.
Übergeordnetes Thema: Datenquellen für datengetriebene Tests
Zugehörige Konzepte
Versionsverwaltungsprofile


Herunterladen einer Excel-Datei von einer Datenquelle

Anmerkung: Von JDBC- und ODBC-Datenquellen können keine Dateien heruntergeladen werden.

So laden Sie eine Excel-Datei aus einer Datenquelle herunter:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Datenquellen. Die Seite Datenquellen wird angezeigt. Hier werden alle Datenquellen aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie in der Spalte Aktionen auf das Symbol Herunterladen der Datenquelle, aus der Sie herunterladen möchten. Der Dialog Dateidownload wird angezeigt.
  4. Klicken Sie auf Öffnen, um die Datei sofort zu öffnen, oder auf Speichern, um das lokale Verzeichnis festzulegen, in das die Daten heruntergeladen werden sollen.
Übergeordnetes Thema: Datenquellen für datengetriebene Tests


Synchronisieren von Datenquellen

Sie müssen eine Datenquelle jedes Mal synchronisieren, wenn sie geändert oder aktualisiert wurde, damit Silk Central von diesen Änderungen erfährt. Bei der Synchronisierung einer Datenquelle werden die letzten Änderungen an die zugeordneten Tests weitergegeben.

So synchronisieren Sie eine aktualisierte Datenquelle:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Datenquellen. Die Seite Datenquellen wird angezeigt. Hier werden alle Datenquellen aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie in der Spalte Aktionen auf das zur Datenquelle gehörige Symbol Synchronisieren, um die Änderungen der aktualisierten Datei an die zugeordneten Tests weiterzugeben.
  4. Ein Dialog wird geöffnet, in dem Sie die Synchronisierung bestätigen müssen. Klicken Sie auf Ja, um alle Tests mit der aktualisierten Datenquelle zu synchronisieren. Wenn Sie auf Nein klicken, wird die Synchronisierung abgebrochen.
    ACHTUNG:
    Wenn Sie eine Datenquelle synchronisieren, werden alle Ausführungen, die von dieser Datenquelle abhängen, abgebrochen. Ergebnisse nicht abgeschlossener Tests dieser Testausführungen gehen verloren.
  5. Klicken Sie im Bestätigungsdialog auf OK.
Übergeordnetes Thema: Datenquellen für datengetriebene Tests


Hochladen von aktualisierten Excel-Dateien zu einer Datenquelle

Anmerkung: Zu JDBC- und ODBC-Datenquellen können keine Dateien hochgeladen werden.

So laden Sie eine Excel-Datei in eine Datenquelle hoch:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Datenquellen. Die Seite Datenquellen wird angezeigt. Hier werden alle Datenquellen aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie in der Spalte Aktionen auf das Symbol Hochladen der Datenquelle, aus der Sie herunterladen möchten.
  4. Klicken Sie im Dialogfeld Datei hochladen auf Durchsuchen....
  5. Wählen Sie die aktualisierte Excel-Datei aus, die die aktuell hochgeladene Excel-Datei ersetzen soll. Klicken Sie auf Öffnen.
  6. Klicken Sie im Dialogfeld Datei hochladen auf OK.
  7. Ein Dialogfeld wird geöffnet, in dem Sie bestätigen müssen, dass die vorhandene Datei überschrieben werden soll. Klicken Sie auf Ja, um fortzufahren.
  8. Nachdem die aktualisierte Datenquellendatei hochgeladen wurde, werden Sie in einem weiteren Dialogfeld gefragt, ob die Tests mit der aktualisierten Datenquelle synchronisiert werden sollen. Klicken Sie für eine sofortige Synchronisierung auf Ja, oder klicken Sie auf Nein, wenn die Synchronisierung später stattfinden soll.
    Anmerkung: Nach dem Hochladen einer aktualisierten Datenquellendatei müssen Sie die Datenquelle synchronisieren, damit die zugeordneten Tests aktualisiert werden.
Übergeordnetes Thema: Datenquellen für datengetriebene Tests


Löschen von Datenquellen

Anmerkung: Von Tests verwendete Datenquellen können nicht gelöscht werden.

So löschen Sie eine Datenquelle:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Datenquellen. Die Seite Datenquellen wird angezeigt. Hier werden alle Datenquellen aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie in der Spalte Aktionen auf das Symbol Löschen der Datenquelle, die Sie löschen möchten.
  4. Ein Bestätigungsdialogfeld wird geöffnet. Klicken Sie auf Ja, um die Datenquelle zu löschen. Wenn Sie auf Nein klicken, wird sie nicht gelöscht.
Übergeordnetes Thema: Datenquellen für datengetriebene Tests


Datenquellenkonfigurationsseite

Projekt:<Projektname> > Projekteinstellungen > Datenquellen

Auf der Seite Datenquellen werden alle Datenquellen aufgelistet, die für die Integration von datengetriebenen Tests in Silk Central konfiguriert sind. Klicken Sie auf Neue Datenquelle, um eine neue Datenquelle zu erstellen. Für jede Datenquelle werden folgende Spalten auf der Seite angezeigt:

Spalte | Beschreibung
Name | Der Name der Datenquelle, der in der Benutzeroberfläche von Silk Central und in Berichten angezeigt wird. Klicken Sie auf den Namen, um die Einstellungen der Datenquelle zu ändern.
Typ Typ der Datenquelle:
  • CSV
  • JDBC
  • MS Excel
Dateiname | Der Name der Datei, die als Datenquelle verwendet wird, zum Beispiel Datenquelle.xlsx.
Versionsverwaltungsprofil | Der Name des Versionsverwaltungsprofils, in welchem die Datendatei verwaltet wird.
Erstellt am | Das Erstellungsdatum der Datenquelle.
Erstellt von | Der Name des Benutzers, der die Datenquelle erstellt hat.
Geändert am | Das Datum, an dem die Datenquelle zuletzt verändert wurde.
Geändert Von | Der Name des Benutzers, von dem die Datenquelle zuletzt geändert wurde.
Aktionen Sie können folgende Aktionen für eine Datenquelle ausführen:
  • Löschen
  • Herunterladen
  • Hochladen
  • Synchronisieren
Übergeordnetes Thema: Datenquellen für datengetriebene Tests


Strukturieren Ihrer Testelemente

Silk Central speichert die Ergebnisse von Testausführungen im Kontext von Versionen und Builds eines bestimmten Produkts. Deshalb mus zuerst ein Produkt definiert werden, bevor Tests erstellt werden können.

Für automatisiert Tests ist ein Versionsverwaltungsprofil eine weitere Voraussetzung. Automatisierte Tests in Silk Central repräsentieren eigentlich Testskripts in einem Versionsverwaltungssystem, auf die über Versionsverwaltungsprofile zugegriffen wird. Sowohl die Produkt- als auch die Versionsverwaltungsprofil-Informationen werden pro Container definiert, welcher somit die oberste Hierarchiestufe der Testelementstruktur ist. Innerhalb von einem Container können Sie dann Ordner verwenden, um Ihre Testelemente entsprechend Ihren Anforderungen und Ihres Prozesses zu strukturieren.

Denken Sie daran, dass obwohl Sie mehrere Container haben können, aufgrund der Ergebnis-Build-Versionsbeziehung eine Testsuite immer nur Tests von einem einzigen Container ausführen kann. Entwerfen Sie Ihre Testelementstruktur deshalb entsprechend den Tests, die Sie gemeinsam in einer Testsuite ausführen möchten.

  • Container
    Container werden für die Testelementstruktur auf höchster Hierarchiestufe verwendet. Silk Central verbindet ein definiertes Versionsverwaltungsprofil und ein Produkt mit einem Container, was einen Einfluss darauf hat, was Sie mit den Tests in einem bestimmten Container alles tun können.
  • Ordner
    Verwenden Sie Ordner zum Strukturieren Ihrer Tests innerhalb von einem Container.
  • Testpakete
    Testpakete stellen eine Methode dar, die Struktur von Testtypen von Fremdherstellern in Silk Central zu unterstützen. Sie bestehen aus einem Paketstamm und einer beliebigen Hierarchie von Testsuiteknoten und Testknoten.
Übergeordnetes Thema: Tests


Container

Container werden für die Testelementstruktur auf höchster Hierarchiestufe verwendet. Silk Central verbindet ein definiertes Versionsverwaltungsprofil und ein Produkt mit einem Container, was einen Einfluss darauf hat, was Sie mit den Tests in einem bestimmten Container alles tun können.

Wenn Sie soweit sind, dass Sie Ihre Testausführungen planen können, stehen nur die Tests eines einzelnen bestimmten Containers zur Auswahl. Sie sollten somit in Betracht ziehen, möglichst wenige Container zu erstellen.

  • Hinzufügen von Containern
    Fügen Sie einen Container zu Tests hinzu, um ein anderes Versionsverwaltungsprofil als das für das Projekt definierte zu verwenden.
  • Hinzufügen von Verknüpfungen mit Containern
    Fügen Sie eine Verknüpfung zur Testhierarchie hinzu, um auf einen Container im selben Projekt zu verweisen.
  • Bearbeiten von Containern
    Bearbeiten Sie die Eigenschaften eines Containers.
Übergeordnetes Thema: Strukturieren Ihrer Testelemente


Hinzufügen von Containern

Anmerkung: Wir empfehlen, Container umsichtig zu verwenden, da sie das Produkt an das Versionsverwaltungsprofil binden.

So fügen Sie einen neuen Container hinzu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Stammknoten aus, zu dem Sie den neuen Container als Unterknoten hinzufügen möchten.
    Anmerkung: Container können nicht verschachtelt werden, aber sie können Unterordner enthalten.
  3. Klicken Sie in der Symbolleiste auf Neuer Container, oder klicken Sie mit der rechten Maustaste auf den Knoten, und wählen Sie Neuer Container.

    Sie können auch mit der rechten Maustaste auf die Knoten und dann auf Neuer Container klicken.

    Ein neuer Containerstammknoten wird zur Testhierarchie hinzugefügt, und der Dialog Neuer Container wird geöffnet.
  4. Geben Sie einen Namen und eine Beschreibung für den Container ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wählen Sie im Listenfeld Produkt ein vordefiniertes Produkt für den Container aus. Weitere Informationen zum Hinzufügen eines Produktprofils finden Sie unter Hinzufügen von Produkten.
  6. Wählen Sie in der Liste Versionsverwaltungsprofil ein vordefiniertes Versionsverwaltungsprofil aus. Wenn Sie nicht beabsichtigen, Testquellen für den Container auszuchecken (wenn Sie beispielsweise nur manuelle Tests haben), wählen Sie --- aus.
    Anmerkung: Die Silk Central-Ausführungsserver rufen die Quelldateien für die im Container enthaltenen Tests aus dem definierten Versionsverwaltungsprofil ab. In Abhängigkeit des in Ihrem Versionsverwaltungsprofil angegebenen Pfades, können Sie im Feld Stammknoten des Containers einen untergeordneten Knoten angeben.
  7. Optional: Aktivieren Sie das Kontrollkästchen Arbeitsordner vor dem Start der Testausführung leeren.

    Falls aktiviert, werden Dateien die in der Versionsverwaltung gelöscht wurden auch im Arbeitsordner gelöscht. Standardmäßig aktiviert.

  8. Klicken Sie auf Durchsuchen..., und wählen Sie den Standardstammpfad des Containers aus.
  9. Optional: Wenn Silk Central in Silk Performer integriert ist, können Sie das Benutzerdefinierte Datenverzeichnis und Benutzerdefinierte Include-Verzeichnis definieren. In Silk Performer ist das Include-Verzeichnis in das System-Include-Verzeichnis und ein Benutzerdefiniertes Include-Verzeichnis unterteilt. Das Datenverzeichnis ist in ein Systemdatenverzeichnis und ein Benutzerdefiniertes Datenverzeichnis aufgeteilt. Weitere Informationen hierzu finden Sie in der Dokumentation zu Silk Performer.
  10. Im Bereich Verborgene Testeigenschaften des Dialogs können Sie festlegen, welche Eigenschaftstypen auf der Seite Eigenschaften (und auf der Seite Eigenschaften aller im Container gespeicherten Ordner) angezeigt werden. Diese Einstellungen wirken sich nicht auf die Anzeige der einzelnen Tests aus.
  11. Klicken Sie auf Bearbeiten, um die Einstellungen für verborgene Testeigenschaften anzupassen. Der Dialog Verborgene Testeigenschaften wird geöffnet.
  12. Deaktivieren Sie die Kontrollkästchen aller Testtypen, für die Eigenschaften angezeigt werden sollen.
  13. Klicken Sie auf OK, um die Einstellungen zu speichern und den Dialog Verborgene Testeigenschaften zu schließen.
  14. Klicken Sie auf Speichern, um Ihre Einstellungen zu speichern.
Der neue Container wird zur Testhierarchie hinzugefügt.
Übergeordnetes Thema: Container
Zugehörige Konzepte
Versionsverwaltungsprofile
Zugehörige Tasks
Hinzufügen von Produkten


Hinzufügen von Verknüpfungen mit Containern

In der Testhierarchie können Sie eine Verknüpfung zu einem Container im selben Projekt hinzufügen. Verknüpfte Container werden im schreibgeschützten Modus an der Stelle angezeigt, an der die Verknüpfung in der Hierarchie eingefügt ist.

So fügen Sie eine Verknüpfung zu einem Container hinzu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste in der Testhierarchie auf den Knoten, unter dem der verknüpfte Container angezeigt werden soll.
  3. Wählen Sie Neue Verknüpfung, wenn Sie den Container auf der Hierarchieebene des ausgewählten Knotens verknüpfen möchten, oder wählen Sie Neue untergeordnete Verknüpfung, um den Container eine Ebene unterhalb des ausgewählten Knotens zu verknüpfen. Das Dialogfeld Container zum Verknüpfen auswählen wird geöffnet.
  4. Wählen Sie den Container aus, auf den Sie verweisen möchten.
    Anmerkung: Wenn für den Zielcontainer und den zu verknüpfenden Container unterschiedliche Versionsverwaltungsprofile konfiguriert sind, werden Sie in einem Bestätigungsdialogfeld gefragt, ob Sie die Verknüpfung wirklich erstellen möchten. Die Verknüpfung innerhalb eines Containers zu einem anderen Container mit einem anderen Versionsverwaltungsprofil kann zu Problemen führen, wenn Sie einen Test in einem verknüpften Container herunterladen oder ausführen möchten. Klicken Sie auf Nein, wenn Sie das benutzerdefinierte Include-Verzeichnis eines der Container zunächst ändern möchten, oder klicken Sie auf Ja, um die Verknüpfung trotzdem zu erstellen.
  5. Klicken Sie auf OK, um die Auswahl zu bestätigen.
Der verknüpfte Container wird als schreibgeschütztes Element im ausgewählten Container eingefügt. Alle Änderungen am Originalcontainer werden in den verknüpften Container übernommen.
Übergeordnetes Thema: Container


Bearbeiten von Containern

So bearbeiten Sie die Eigenschaften eines Containers:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests die Container aus, die Sie bearbeiten möchten.
  3. Klicken Sie in der Symbolleiste auf Bearbeiten. Sie können auch mit der rechten Maustaste auf den Container klicken und Bearbeiten auswählen. Das Dialogfeld Container bearbeiten wird geöffnet.
  4. Bearbeiten Sie die Eigenschaften des Containers.
  5. Klicken Sie auf OK, um die Änderungen anzuwenden.
Übergeordnetes Thema: Container
Zugehörige Verweise
Testeigenschaften


Ordner

Verwenden Sie Ordner zum Strukturieren Ihrer Tests innerhalb von einem Container.
  • Hinzufügen von Ordnern
    Fügen Sie einen neuen Ordner zur Testhierarchie hinzu.
  • Bearbeiten von Ordnern
    Bearbeiten Sie die Eigenschaften eines Ordners.
  • Sortieren von Ordnern
    Verschieben Sie Ordner in der Hierarchie Tests nach oben oder nach unten, um die Tests zu sortieren.
Übergeordnetes Thema: Strukturieren Ihrer Testelemente
Zugehörige Tasks
Ausschneiden, Kopieren, Einfügen und Löschen von Testelementen


Hinzufügen von Ordnern

So erstellen Sie einen neuen Ordner:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie das Testelement aus, nach dem Sie den neuen Ordner einfügen möchten.
  3. Klicken Sie auf Neuer untergeordneter Ordner in der Symbolleiste. Sie können auch mit der rechten Maustaste auf das Element klicken, und Neuer Ordner auswählen, um den neuen Ordner nach dem ausgewählten Element einzufügen, oder wählen Sie Neuer untergeordneter Ordner, um den Ordner als Unterknoten zum ausgewählten Element hinzuzufügen.
    Anmerkung: Bei Containern können Sie Ordner nur als Unterknoten einfügen.
    Ein neuer Ordnerknoten wird in der Testhierarchie eingefügt, und das Dialogfeld Neuer Ordner wird geöffnet.
  4. Geben Sie einen Namen und eine Beschreibung für den Ordner ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Klicken Sie auf OK, um die Einstellungen zu speichern.
Der neue Ordner wird zur Testhierarchie hinzugefügt.
Übergeordnetes Thema: Ordner


Bearbeiten von Ordnern

So ändern Sie einen Ordner:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Ordner in der Hierarchie aus.
  3. Klicken Sie in der Symbolleiste auf Bearbeiten. Sie können auch mit der rechten Maustaste auf den Ordner klicken und Bearbeiten auswählen. Das Dialogfeld Ordner bearbeiten wird geöffnet.
  4. Bearbeiten Sie den Namen und die Beschreibung des Ordners.
  5. Klicken Sie auf OK, um die Änderungen zu übernehmen.
Übergeordnetes Thema: Ordner


Sortieren von Ordnern

So verschieben Sie einen Ordner in der Hierarchie Tests nach oben oder unten:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Ordner in der Hierarchie aus.
  3. Klicken Sie in der Symbolleiste auf Nach oben, um den Ordner in der Hierarchie um eine Position nach oben zu verschieben, oder auf Nach unten, um den Ordner um eine Position nach unten zu verschieben.
Übergeordnetes Thema: Ordner


Testpakete

Testpakete stellen eine Methode dar, die Struktur von Testtypen von Fremdherstellern in Silk Central zu unterstützen. Sie bestehen aus einem Paketstamm und einer beliebigen Hierarchie von Testsuiteknoten und Testknoten.

Testpakete bieten den Benutzern detaillierte Informationen über einen Testsuitelauf. Testpakete, Suiteknoten und Testknoten können zusammen mit den zugehörigen Fehlerzuständen und Anhängen jeweils einzeln Anforderungen zugeordnet werden. Diese Funktionalität ähnelt der Funktionalität von gewöhnlichen Tests. Nachdem ein Drittanbietertest in ein Testpaket konvertiert wurde, können alle in dem Paket enthaltenen Tests einzeln ausgeführt werden. In einem Testpaket enthaltene Testknoten und Suiteknoten verfügen über eine zusätzliche Eigenschaft, nämlich die Externe ID.

Ein Vorteil von Testpaketen besteht darin, dass die Struktur mit jeder Testausführung automatisch gepflegt werden kann. Die Struktur eines Testpakets kann entsprechend den Ergebnissen der Testläufe aktualisiert werden. Die Datei <Silk Central Installationsordner>\wwwroot\silkroot\xsl\output.xsd enthält ein XML-Schema für die Struktur der XML-Ausgabedateien von Testpaketen.

Abgesehen von folgenden Ausnahmen werden in Testpaketen sämtliche Funktionen der einzelnen Tests aktiviert:

  • Testcontainer, die Testpakete enthalten, können nicht verknüpft werden.
  • Testpakete können nicht datengetrieben sein, weil sie keine datengetriebenen Eigenschaften besitzen.
  • Bei Testpaketknoten werden alle Erfolgsbedingungen (außer dem Testausführungs-Timeout) deaktiviert und ausgeblendet.
Anmerkung: Silk Performer-Tests, Silk Test Classic-Tests und manuelle Tests können nicht in Testpakete konvertiert werden, da die Struktur dieser Tests standardmäßig in Silk Central unterstützt wird.

Die Informationen, die die interne Struktur eines Testpakets bereitstellt, sind spezifisch. Wenn das Testpaket kopiert wird, sind diese Informationen nicht mehr konsistent. Um ein Testpaket wiederzuverwenden, müssen Sie das Testpaket kopieren, das kopierte Paket auf die übergeordnete Test zurücksetzen, den Test an Ihre Anforderungen anpassen und den geänderten Test dann in ein Testpaket konvertieren.

  • Erstellen eines Testpakets
    Erstellen Sie ein Testpaket aus einem Test eines Drittanbieters, um die Struktur des Drittanbieter-Testtyps in Silk Central zu spiegeln.
  • Verwenden von externen IDs
    Verwenden Sie Externe IDs zur eindeutigen Identifizierung von Testmethoden in Testpaketen.
  • Wiederverwendung eines Testpakets
    Verwenden Sie die Informationen in einem übergeordneten Knoten von Testpaketen zum Erstellen neuer Testpakete wieder.
  • Zurücksetzen eines Testpakets auf den Test
    Setzen Sie ein Testpaket auf den ursprünglichen Test zurück, um aus dem übergeordneten Knoten ein anderes Testpaket zu erstellen.
  • Bereinigen eines Testpakets
    Bereinigen Sie ein Testpaket, um nicht ausgeführte Tests aus dem Testpaket zu entfernen.
Übergeordnetes Thema: Strukturieren Ihrer Testelemente


Erstellen eines Testpakets

So erstellen Sie ein Testpaket aus einem Test eines Drittanbieters:

  1. Führen Sie den Test einmal aus, damit die Datei output.xml mit der Struktur des Testpakets erstellt wird. Weitere Informationen zum Ausführen eines Tests finden Sie unter Ausführen eines Versuchslaufs eines Tests.
  2. Klicken Sie im Menü auf Tests > Detailansicht.
  3. Klicken Sie in der Testhierarchie mit der rechten Maustaste auf den Test, und wählen Sie In Testpaket konvertieren. Die ausgewählte Test wird in eine Hierarchie konvertiert, welche die Struktur des letzten Ausführungsergebnisses darstellt.
Übergeordnetes Thema: Testpakete
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Verwenden von externen IDs

Externe IDs werden verwendet, um Testknoten und Testsuiteknoten in Testpaketen eindeutig zu identifizieren. Für jeden Testknoten und jeden Testsuiteknoten ist die Eigenschaft Externe ID verfügbar. Die automatisch generierte Externe ID identifiziert eine eindeutige Testmethode durch den voll qualifizierten Namen der Klasse und der Methode, der "~" vorangestellt wird.

Für JUnit Tests wird das folgende Schema für die automatisch generierte Externe ID verwendet: ~<Testpaket-Name>.<Klassen-Name>#<Methoden-Name>.

Beim Umstrukturieren von JUnit-Testklassen ist die automatische Generierung von Externe ID nicht anwendbar, weil die Ergebnisdaten von Tests, die vor der Umstrukturierung ausgeführt wurden, beim Erstellen eines neuen Tests verloren gehen. In diesem Fall muss die Externe ID für den Test manuell definiert werden. Die umstrukturierte Methode kann erneut eindeutig identifiziert werden, weil die Externe ID unverändert bleibt, wenn ein JUnit-Test verschoben oder der Name eines JUnit-Tests geändert wird. Die Externe ID kann im Quellcode manuell als annotation-Objekt festgelegt werden.

Das folgende Codebeispiel enthält eine solche annotation-Instanz für JUnit-Tests:

import java.lang.annotation.Retention;
import java.lang.annotation.RetentionPolicy;

@Retention(RetentionPolicy.RUNTIME)
public @interface ExternalId {
  String externalId();
}

Die annotation-Instanz kann in einem JUnit-Test verwendet werden, um Klassen und Methoden wie unten gezeigt auszuzeichnen:

import static org.junit.Assert.*;
import org.junit.Test;

import com.borland.runner.ExternalId;

@ExternalId(externalId="JUnit4test")
public class JUnit4test {

  @Test
  @ExternalId(externalId="MyExtId1")
  public void test1() {
    ...
  }

  @Test
  @ExternalId(externalId="MyExtId2")
  public void test2() {
    ...
  }
}

Beachten Sie, dass die Verwendung der Eigenschaft Externe ID mit JUnit runner 'org.junit.runners.Parameterized' bei Testmethoden nicht unterstützt wird, weil der Wert von Externe ID nicht eindeutig ist, wenn die Methode wiederholt mit unterschiedlichen Parametern ausgeführt wird. Um dieses Problem zu umgehen, könnte eine Externe ID auf Klassenebene angegeben werden; auf der Methodenebene muss sie jedoch weggelassen werden. Dazu ein Beispiel:

@RunWith(Parameterized.class)
@ExternalId(externalId="parameterizedWithExtId")
public class TestCaseParameterizedWithExternalId {

  @Parameters
  public static Collection<Object[]> parameterFeeder() {
    return Arrays.asList(new Object[][] {
        { "param_name1", "param_value1" }, // set of parameters per run, type matching constructor must exist!
        { "param_name3", "param_value3" },
        { "param_name2", "param_value2" },
      }
    );
  }

  private String paramName;
  private String paramValue;

  public TestCaseParameterizedWithExternalId(String paramName, String paramValue) {
    this.paramName = paramName;
    this.paramValue = paramValue;
  }

  @Test
  public void testWithParams() {
    System.out.println(String.format("run with parameter: name='%s', value='%s'", paramName, paramValue));
  }

}
Anmerkung: Die Externe ID kann nur für JUnit-Tests festgelegt werden, die mit JUnit 4.4 oder höher arbeiten.
Übergeordnetes Thema: Testpakete


Wiederverwendung eines Testpakets

Die Informationen, die die interne Struktur eines Testpakets bereitstellt, sind spezifisch. Wenn das Testpaket kopiert wird, sind diese Informationen nicht mehr konsistent. Um ein Testpaket wiederzuverwenden, müssen Sie das Testpaket kopieren, das kopierte Paket auf die übergeordnete Test zurücksetzen, den Test an Ihre Anforderungen anpassen und den geänderten Test dann in ein Testpaket konvertieren.

So verwenden Sie die Informationen in einem Testpaket wieder:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste in der Testhierarchie auf das Testpaket, das Sie erneut verwenden möchten, und wählen Sie Kopieren aus.
  3. Wählen Sie in der Testshierarchie den Knoten aus, zu dem Sie das kopierte Testpaket hinzufügen möchten.
  4. Klicken Sie mit der rechten Maustaste auf den ausgewählten Knoten, und wählen Sie Einfügen aus, um das kopierte Paket in der Hierarchie auf derselben Ebene hinzuzufügen, oder wählen Sie Als untergeordnetes Element einfügen aus, um das kopierte Testpaket als Unterknoten des ausgewählten Knotens hinzuzufügen.
    ACHTUNG:
    Die Informationen, die sich jetzt im kopierten Testpaket befinden, sind nicht konsistent.
  5. Klicken Sie mit der rechten Maustaste auf das kopierte Paket, und wählen Sie Paket auf Test zurücksetzen aus. Die Paketinformationen werden aus der übergeordneten Test entfernt.
  6. Bearbeiten Sie die Test, um sie an Ihre Anforderungen anzupassen. Weitere Informationen finden Sie unter Bearbeiten von Tests.
  7. Klicken Sie mit der rechten Maustaste auf die bearbeitete Test, und wählen Sie In Testpaket konvertieren aus.
Sie haben nun eine Kopie des ursprünglichen Testpakets mit unterschiedlichen Eigenschaften.
Übergeordnetes Thema: Testpakete
Zugehörige Tasks
Bearbeiten von Tests


Zurücksetzen eines Testpakets auf den Test

Setzen Sie ein Testpaket auf den ursprünglichen Test zurück, um aus dem übergeordneten Knoten ein anderes Testpaket zu erstellen.
Anmerkung: Des Zurücksetzen eines Testpaketes auf einen Test zeigt gewisse Informationen des Testlaufs nicht mehr an. Diese Informationen sind aber in der Ansicht Zeitverlauf bzw. in den Ergebnisdateien nach wie vor verfügbar.

So setzen Sie ein Testpaket auf den ursprünglichen Test zurück:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Testhierarchie mit der rechten Maustaste auf das Testpaket.
  3. Klicken Sie auf Paket auf Test zurücksetzen.
Das Testpaket wird auf den ursprünglichen Test zurückgesetzt.
Übergeordnetes Thema: Testpakete


Bereinigen eines Testpakets

So bereinigen Sie ein Testpaket:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Testhierarchie mit der rechten Maustaste auf das Testpaket.
  3. Klicken Sie auf Testpaket bereinigen.
Alle Tests, die während der letzten Ausführung des Testpakets nicht ausgeführt wurden, werden aus dem Testpaket entfernt.
Übergeordnetes Thema: Testpakete


Verwalten von Tests

Fügen Sie Ihrem Test-Framework neue Tests hinzu oder bearbeiten Sie bestehende Tests.
  • Testtypen
    Silk Central unterstützt standardmäßig die folgenden Testtypen:
  • Gemeinsam verwendbare Testobjekte
    Gemeinsam verwendbare Testobjekte und deren zugeordnete Anforderungen, welche in einem Repository-Projekt verwaltet werden, können in Zielprojekten wiederverwendet werden.
  • Bearbeiten von Tests
    Bearbeiten Sie einen Test, um die Eigenschaften des Tests zu ändern.
  • Drucken von Tests
    Drucken Sie Tests in der ausgewählten Reihenfolge.
  • Testläufe (Seite)
    Hier werden die Ergebnisse der Testausführung für den ausgewählten Test angezeigt.
  • Fehler (Seite)
    Hier können Fehler für den ausgewählten Test eingegeben und überwacht werden.
  • Versionen
    Beschreibt, wie Versionen von gemeinsam verwendbaren Objekten Tests verwendet werden.
Übergeordnetes Thema: Tests


Testtypen

Silk Central unterstützt standardmäßig die folgenden Testtypen:
  • Manuelle Tests
    Manuelle Tests sind Schritt-für-Schritt Anweisungen für Tester. Silk Central Stellt eine Benutzeroberfläche zur Verfügung, mit der manuelle Tests effizient durchgeführt werden können, inklusive der Option während des Testens Videos und Screenshots aufzunehmen. Manuelle Tests können bei Bedarf zu einem späteren Zeitpunkt dann auch in automatisierte Tests konvertiert werden.
  • Schlüsselwortgetriebene Tests
    Schlüsselwortgetriebenes Testen ist eine Software-Testmethodologie, die Schüsselwörter verwendet um eine zu testende Funktionalität zu symbolisieren. Schlüsselwortgetriebenes Testen kann dazu verwendet werden ein Automatisierungs-Framework zu erstellen.
  • Unified Functional Testing (UFT) Tests
    Mit Unified Functional Testing (UFT) Software, früher HP QuickTest Professional (QTP) genannt, können funktionales Testen und Regressionstests für Software-Anwendungen und -Umgebungen automatisiert werden.
  • JUnit-Tests
    JUnit ist ein Unit-Test-Framework für die Java-Programmiersprache. Verwenden Sie diesen Testtyp für JUnit-, Silk4J- und Selenium-Tests.
  • MSTest-Tests
    MSTest ist ein Befehlszeilen-Tool von , welches Unit-Tests ausführt die mit Microsoft erstellt wurden. Verwenden Sie diesen Testtyp für MSTest- und Silk4NET-Tests.
  • NUnit-Tests
    NUnit ist ein Unit-Test-Framework für die Microsoft .NET-Programmiersprache.
  • ProcessExecutor-Tests
    Mit dem ProcessExecutor-Testtyp kann jede beliebige Befehlszeile ausgeführt werden.
  • Silk Performer .NET Explorer-Tests
    Der -Testtyp wird verwendet um bestimmte Silk Performer .NET Explorer-Skripts oder einen bestimmten Testfall eines Skripts auszuführen.
  • Silk Performer-Tests
    Silk Performer-Projekte können in Silk Central-Tests integriert und über Silk Central direkt ausgeführt werden. Dadurch stehen leistungsfähige Funktionen zur Analyse von Testergebnissen und Berichtserstellung zur Verfügung. Außerdem können Tests in Silk Central durch vorkonfigurierte Ausführungstermine automatisiert ausgeführt werden.
  • Silk Test Classic-Tests
    Die Silk Central-Schnittstelle von Silk Test Classic ermöglicht Silk Test Classic-Benutzern die zuverlässige Ausführung automatisierter Tests. Jeder Testfall eines Silk Test Classic-Skripts wird in seinem eigenen Testlauf ausgeführt und produziert seine eigenen Ergebnisse.
  • Silk Test Workbench-Tests
    Silk Test Workbench ist ein automatisiertes Testprogramm, das die Funktionstests komplexer Anwendungen beschleunigt. Silk Test Workbench bietet Unterstützung für Testanwendungen, die mit einer Vielzahl unterschiedlicher Entwicklungsprogramme hergestellt wurden, etwa Java, .NET, browserbasierte Webanwendungen und COM-Komponenten wie ActiveX-Steuerelemente und Automatisierungsobjekte.
  • SilkTestPartner Tests
    TestPartner ist ein Micro Focus-Produkt zum Testen von Web- und Microsoft Windows-basierten Anwendungen, die Microsoft-Technologie verwenden.
  • Testen mit Windows Script Host
    Hier wird beschrieben, wie eine Umgebung für Hosting-Skripts mit Windows Script Host erstellt wird.
Übergeordnetes Thema: Verwalten von Tests


Manuelle Tests

Manuelle Tests sind Schritt-für-Schritt Anweisungen für Tester. Silk Central Stellt eine Benutzeroberfläche zur Verfügung, mit der manuelle Tests effizient durchgeführt werden können, inklusive der Option während des Testens Videos und Screenshots aufzunehmen. Manuelle Tests können bei Bedarf zu einem späteren Zeitpunkt dann auch in automatisierte Tests konvertiert werden.
  • Erstellen oder bearbeiten von manuellen Tests
    Erstellen oder bearbeiten Sie einen manuellen Test um Ihren manuellen Testern detaillierte Anweisungen zu geben.
  • Hinzufügen oder bearbeiten von manuellen Testschritten
    Bearbeiten Sie auf der Seite Testschritte einen manuellen Testschritt oder fügen Sie einen neuen hinzu.
  • Erstellen von manuellen Tests mit externen Lösungen
    Beschreibt die Verwendung der offenen Schnittstelle zur Erstellung manueller Tests außerhalb der Silk Central-Benutzeroberfläche.
  • Konvertieren von manuellen in automatisierte Tests
    Konvertieren Sie einen manuellen Test in einen automatisierten Test, bevor Sie den Test zu Ihren Regressionen hinzufügen.
  • Konvertieren von automatisierten in manuelle Tests
    Konvertieren Sie einen automatisierten Test in einen manuellen, z.B. um ihn danach wieder mit einem anderen Testtyp zu automatisieren.
  • Testschritte (Seite)
    Hier werden alle manuellen Testschritte aufgeführt, die in dem ausgewähltem Test oder im ausgewählten gemeinsam verwendbaren Objekt enthalten sind.
  • Test-Export, -Aktualisierung und -Import
    Hier wird beschrieben, wie bearbeitet werden können, indem man sie exportiert und aktualisiert, oder indem man sie importiert.
Übergeordnetes Thema: Testtypen
Zugehörige Konzepte
Verwalten von gemeinsam verwendbaren Objekten
Versionen
Test-Export, -Aktualisierung und -Import


Erstellen oder bearbeiten von manuellen Tests

So erstellen oder bearbeiten Sie einen manuellen Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Manueller Test aus.
  6. Geben Sie im Feld Geplante Dauer die erwartete Ausführungsdauer dieses manuellen Tests ein.
  7. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: Manuelle Tests
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Hinzufügen oder bearbeiten von manuellen Testschritten

Verwenden Sie die Seite Testschritte zum Hinzufügen und Bearbeiten von manuellen Testschritten eines Tests oder eines gemeinsam verwendbaren Objekts.

So bearbeiten Sie einen manuellen Testschritt oder fügen Sie einen neuen hinzu:

  1. Klicken Sie für ein gemeinsames Objekt im Menü auf Tests > Bibliotheken. Klicken Sie für Tests im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie oder der Bibliothekshierarchie den Knoten mit den zu bearbeitenden Testschritten aus.
  3. Klicken Sie auf die Registerkarte Testschritte.
  4. Klicken sie auf den zu bearbeitenden Testschritt oder verwenden Sie die Testschritte-Symbolleiste, um einen neuen Testschritt hinzuzufügen. Die Details des Testschritts werden in der Ansicht Testschritt bearbeiten angezeigt.
  5. Bearbeiten Sie den Namen, die Aktionsbeschreibung, die erwarteten Ergebnisse und die Eigenschaften des Testschritts in den entsprechenden Feldern. Sie können Werte aus Datenquellen als Parameter an manuelle Testschritte übergeben (siehe Hinzufügen eines Datenquellenwerts zu einem manuellen Testschritt). Parameter verwenden die Syntax ${<Name>}, z.B. ${benutzername}. Wird ein manueller Test in einen schlüsselwortgetriebenen Test konvertiert, werden diese Parameter automatisch dem generierten Schlüsselwort hinzugefügt.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  6. Führen Sie einen der folgenden Schritte aus, um die Bearbeitung des Testschritts abzuschließen:
    • Klicken Sie auf OK und neuer Testschritt, um Ihre Änderungen zu speichern und nach dem aktuellen Schritt einen weiteren hinzuzufügen.
    • Klicken Sie auf OK, um die Änderungen zu speichern.
    • Klicken Sie auf Abbrechen, um die Änderungen rückgängig zu machen.
Übergeordnetes Thema: Manuelle Tests
Übergeordnetes Thema: Verwalten von gemeinsam verwendbaren Objekten
Zugehörige Tasks
Hinzufügen eines Datenquellenwerts zu einem manuellen Testschritt


Erstellen von manuellen Tests mit externen Lösungen

Sie können die offene Schnittstelle des Silk Central verwenden, um manuelle Tests außerhalb der Silk Central-Benutzeroberfläche zu erstellen. Sie können eigene Lösungen erstellen und manuelle Tests automatisch erstellen, indem Sie die Webdienstaufrufe des Silk Central nutzen.

Die folgenden Methoden des tmplanning-Webdienstes können beim Erstellen von manuellen Tests aufgerufen werden:

  • getTestContainers
  • addManualTest
  • getCustomStepPropertyNames
  • getChildNodes
  • getNodeDetails
  • addNode
  • updateNode
  • startExecution

Eine detaillierte Beschreibung dieser Webdienstaufrufe finden Sie unter Verfügbare Webdienste.

Übergeordnetes Thema: Manuelle Tests
Zugehörige Verweise
Verfügbare Webdienste


Konvertieren von manuellen in automatisierte Tests

Sie können einen manuellen Test in einen automatisierten Test mit einem beliebigen unterstützten Testtyp konvertieren, wie z.B. schlüsselwortgetrieben, Silk Performer, Silk Test Classic, NUnit, JUnit und alle installierten Plug-Ins. Bei der Konvertierung werden Parameter des manuellen Tests in den automatisierten Test übernommen und automatisierte Parameter zur Spezifikation des neuen automatisierten Tests hinzugefügt.

Die folgenden Parameter werden vom manuellen in den automatisierten Test übernommen:
  • Name
  • Beschreibung
  • Zugeordnete Anforderungen
  • Zugeordnete Testsuiten
  • Zugeordnete Fehler
  • Anhänge
  • Testschritte

So konvertieren Sie einen manuellen Test in einen automatisierten Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Hierarchie Tests mit der rechten Maustaste auf den gewünschten manuellen Test, und wählen Sie Automatisieren mit....
  3. Wählen Sie einen automatisierten Testtyp aus dem Kontextmenü aus.
  4. Informationen zum Ausfüllen des Dialogs finden Sie im entsprechenden Thema in Erstellen von Tests.
Übergeordnetes Thema: Manuelle Tests
Zugehörige Konzepte
Verwalten von Tests
Zugehörige Tasks
Manuelles Ausführen automatisierter Tests
Schlüsselwortgetriebene Tests


Konvertieren von automatisierten in manuelle Tests

Sie können einen automatisierten in einen manuellen Test konvertieren. Dies ist z.B. hilfreich, wenn Sie einen automatisierten Test in einen anderen Testtyp konvertieren wollen, z.B. von Silk Test Classic nach Silk4J. In diesem Fall würden Sie den Silk Test Classic-Test in einen manuellen Test konvertieren, um ihn danach mit Silk4J zu automatisieren.
Anmerkung: Einschränkungen: Die Konvertierung auf einen manuellen Test funktioniert nur für automatisierte Standardtests, d.h. Tests ohne Paketknoten, datengetriebene Knoten oder verknüpfte Knoten.
  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Hierarchie Tests mit der rechten Maustaste auf den gewünschten automatisierten Test, und wählen Sie In manuellen Test konvertieren.
  3. Bestätigen Sie die Meldung.
    ACHTUNG:
    Testtyp-bezogene Eigenschaften werden gelöscht. Wenn ein automatisierter gerade läuft, werden die Testergebnisse gelöscht sobald der Testlauf fertig ist.
Übergeordnetes Thema: Manuelle Tests


Testschritte (Seite)

Tests > Detail Ansicht > <Manueller Test> > Testschritte

Tests > Bibliotheken > <gemeinsam verwendbares Objekt> > Testschritte

Auf der Seite Testschritte werden alle manuellen Testschritte des ausgewählten Tests oder des gemeinsam verwendbaren Objekts aufgelistet. Die Seite unterstützt die Mehrfachauswahl im Windows Explorer-Stil.

Um ein neues gemeinsam verwendbares Objekt zu erstellen, wählen Sie die gewünschten Testschritte aus, und klicken Sie auf Gemeinsam verwendbare Testschritte erzeugen.

Die Seite enthält die folgenden Symbolleistenelemente:

Symbolleistenelement | Beschreibung
Neuer Testschritt | Fügt am Ende der Liste einen neuen Testschritt hinzu.
Testschritt einfügen | Fügt vor dem ausgewählten Testschritt einen neuen Testschritt ein.
Neuer Aufruf gemeinsam verwendbarer Testschritte | Fügen Sie am Ende der Liste einen Aufruf des gemeinsam verwendbaren Objekts hinzu.
Aufruf gemeinsam verwendbarer Testschritte einfügen | Fügt vor dem ausgewählten Testschritt einen Aufruf für gemeinsam verwendbare Testschritte aus einer Bibliothek ein.
Löschen | Löscht die ausgewählten Testschritte aus der Liste.
Ausschneiden | Schneiden Sie den ausgewählten Testschritt aus der Liste aus und fügen Sie ihn in die Zwischenablage ein.
Kopieren | Kopiert die ausgewählten Testschritte in die Zwischenablage.
Einfügen | Fügt eine Kopie der Testschritte aus der Zwischenablage oberhalb der ausgewählten Zeile ein.
Nach oben | Verschiebt den ausgewählten Testschritt in der Liste eine Position nach oben.
Nach unten | Verschiebt den ausgewählten Testschritt in der Liste eine Position nach unten.
Anhänge verwalten Öffnet das Dialogfeld Anhänge, in dem Sie die folgenden Aktionen durchführen können:
Datei hochladen
Laden Sie eine Datei zu dem ausgewählten Testschritt hoch, und hängen Sie diese an den Testschritt an.
Link einfügen
Fügen Sie in den ausgewählten Testschritt einen Link ein.
Alle Dateien herunterladen
Laden Sie alle angehängten Dateien vom ausgewählten Testschritt herunter.
Löschen
Löschen Sie eine Datei oder einen Link.
Gemeinsam verwendbare Testschritte anzeigen | Wenn Testschritte des Tests oder des gemeinsam verwendbaren Objekts ein gemeinsam verwendbares Objekt aus einer Bibliothek aufrufen, können Sie hiermit die ursprünglichen Testschritte anzeigen. Die aufgelösten Testschritte sind durch einen Pfeil gekennzeichnet. Zum Aufrufen der Testschritte klicken Sie auf ihren Namen. Solange diese Ansicht aktiviert ist, können Testschritte nicht bearbeitet werden.
Gemeinsam verwendbare Testschritte ausblenden | Zeigt die von einem gemeinsam verwendbaren Objekt in einer Bibliothek aufgerufenen Testschritte als einen einzigen Schritt an. Aktivieren Sie zum Bearbeiten von Testschritten diese Ansicht.
Gemeinsam verwendbare Testschritte erzeugen | Erstellt aus den ausgewählten Testschritten ein gemeinsam verwendbares Objekt.
Aus Bibliothek extrahieren | Aufrufe aus anderen gemeinsam verwendbaren Objekten extrahieren. Alle Schritte in den in der Tabellenansicht ausgewählten Aufrufen werden kopiert und in den manuellen Test bzw. das gemeinsam verwendbare Objekt eingefügt.
Taste | Aktion
- | Nach oben
+ | Nach unten
Strg+A | Alles auswählen
Strg+C | Kopieren
Strg+X | Ausschneiden
Strg+V | Einfügen
Einfg | Einfügen
Entf | Löschen
Auf der Seite Testschritte werden die folgenden Tastenkombinationen für Testplanelemente unterstützt:

Die Schritte werden in einer Tabelle mit den folgenden Spalten angezeigt.

Spalte | Beschreibung
Reihenfolge | Anzahl der Schritte in der Ausführungsfolge.
Name | Der Name des Testschritts.
Aktionsbeschreibung | Aktion, die zur Ausführung des Testschrittes durchgeführt werden muss.
Erwartete Ergebnisse | Das erwartete Ergebnis des Testschrittes.
Anhänge | Die Anzahl der Links oder Dateien, die dem Testschritt beigefügt sind.

In der Ansicht Testschritt bearbeiten werden die Details des ausgewählten Testschritts angezeigt. Hier können Sie den Namen, die Aktionsbeschreibung, die erwarteten Ergebnisse und die Testschritteigenschaften des Testschritts ändern.

Die Ansicht Testschritt bearbeiten enthält folgende Schaltflächen:

Schaltfläche | Beschreibung
OK und neuer Testschritt | Klicken Sie auf diese Schaltfläche, um den bearbeiteten Testschritt zu speichern und einen weiteren Testschritt hinzuzufügen.
OK | Klicken Sie auf diese Schaltfläche, um den bearbeiteten Testschritt zu speichern.
Zurücksetzen | Klicken Sie auf diese Schaltfläche, um die Änderungen rückgängig zu machen.
Übergeordnetes Thema: Manuelle Tests
Übergeordnetes Thema: Verwalten von gemeinsam verwendbaren Objekten


Test-Export, -Aktualisierung und -Import

Durch die Integration von Silk Central und Excel stehen Ihnen zwei verschiedene Optionen zur Änderung von Tests zur Verfügung. Hierzu gehören:

  • Export und Aktualisierung: Anhand dieser Option können Sie Ihre Tests in Silk Central erstellen, nach Excel exportieren und dort Änderungen vornehmen. Anschließend werden die Tests in Silk Central wieder aktualisiert.
  • Import: Anhand dieser Option können Sie Tests in Excel erstellen und anschließend in Silk Central importieren.

In beiden Szenarios benötigen Sie zur Synchronisierung der Spalten in den beiden Produkten eine Zuordnungsdatei.

Anmerkung: Silk Central unterstützt derzeit nur den Import von .xslx-Dateien, und es können nur manuelle Tests importiert werden.
  • Regeln für Export, Aktualisierung und Import
    Hier wird das Ansprechen auf Import, Export und Aktualisierung beschrieben.
  • Export und Aktualisierung von Tests
    Hier wird beschrieben, wie Tests exportiert und aktualisiert werden.
  • Importieren von Tests
    Hier wird beschrieben, wie Tests aus Microsoft Excel importiert werden.
  • Zuordnungsdatei
    Hier werden Zuordnungsdateien für die Aktualisierung und den Import von Tests beschrieben.
  • Testversionsverwaltung
    Hier wird die Versionsverwaltung für Tests während eines Aktualisierungs- oder Importvorgangs in Excel beschrieben.
Übergeordnetes Thema: Manuelle Tests
Zugehörige Konzepte
Manuelle Tests


Regeln für Export, Aktualisierung und Import

Folgende Regeln gelten für die Vorgänge Export, Aktualisierung und Import:

Allgemeine Regeln

  • Wenn eine Testzeile in Excel keine TestID oder keinen Pfad enthält, wird sie als eigenständiger Test betrachtet, und wird in einem neuen Ordner im Testcontainer, aus der die Importfunktion ausgeführt wurde, erstellt.
  • Sie können bereits bestehende TestIDs hinzufügen, damit die Tests bei Aktualisierung mit bearbeitet werden. Außerdem können Sie bereits bestehende SharedStepIDs hinzufügen, um neue gemeinsam verwendbare Testschritte bei Import/Aktualisierung hinzuzufügen.
  • Neue automatisierte Tests werden weder importiert noch aktualisiert.
  • Geerbte Attributwerte werden nicht exportiert.
  • Wenn eine Test in Excel in eine andere Ordnerhierarchie verschoben wird, wird das während des Aktualisierungsvorgangs nicht berücksichtigt.
  • Wenn in einer Excel-Datei eine Test fehlt (d.h. wenn sie gelöscht wurde), wird diese Test bei der Aktualisierung nicht gelöscht.
  • Die Importfunktion verwendet die Pfad-Spalte für (neue) Ordnernamen.
  • Die Buchstaben A-Z können nicht als benutzerdefinierte Spaltennamen verwendet werden. Sie sind für die zur Zuordnung verwendete Excel A-Z-Spaltenbenennung reserviert.

Gemeinsam verwendbare Testschritte

  • Werden zum Importieren und Aktualisieren hinzugefügt.
  • Werden zur Aktualisierung gelöscht und neu abgerufen.
  • Werden nicht aktualisiert.
  • Wenn die in Excel angegebene SharedStepID in Silk Central nicht vorhanden ist, wird ein Fehler gemeldet.

Datengetriebene Tests

  • Nicht-atomare, untergeordnete datengetriebene Tests werden nicht exportiert.
  • Alle Tests können importiert werden, aber ihre datengetriebenen Eigenschaften können weder nach Excel exportiert noch von Excel importiert werden.
  • Die Aktualisierung aus Excel wird nur unterstützt, wenn der Zielordner keine datengetriebenen Tests enthält.
Übergeordnetes Thema: Test-Export, -Aktualisierung und -Import


Export und Aktualisierung von Tests

In diesem Abschnitt wird beschrieben, wie Tests von Microsoft Excel nach Silk Central exportiert und aktualisiert werden.

Wenn Sie umfangreiche Änderungen an vorhandenen Tests vornehmen möchten, verwenden Sie die Funktion Export-Aktualisierung nach Excel.

Anmerkung: Folgende Felder sind in Excel nicht bearbeitbar: Status, TestType, StepID und StepOrder.

Export und Aktualisierung – Überblick

Nachfolgend erhalten Sie einen allgemeinen Überblick über das Exportieren und Aktualisieren:

  • Wählen Sie den Container oder Ordner aus.
  • Führen Sie den Export nach Excel aus.
  • Nehmen Sie die Änderungen in Excel vor.
  • Überprüfen/erstellen Sie die Zuordnungsdatei.
  • Führen Sie die Aktualisierung in Silk Central aus.
  • Exportieren von Tests nach Excel
    Hier wird das Exportieren von Tests in Excel-Dateien beschrieben.
  • Aktualisieren von Tests aus Excel
    Laden Sie einen Test von Silk Central auf Excel herunter, um ihn dort zu aktualisieren.
Übergeordnetes Thema: Test-Export, -Aktualisierung und -Import


Exportieren von Tests nach Excel

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf einen Container oder einen Ordner mit den Tests, die Sie exportieren wollen.
  3. Wählen Sie Exportieren nach Excel... aus. Der Dialog Testplan-Export nach Excel wird angezeigt.
  4. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist TestPropertiesDefaultMapping.xml. Informationen zum Erstellen benutzerdefinierter Zuordnungsdateien finden Sie unter Bearbeiten von Zuordnungsdateien für Tests.
  5. Optional: Klicken Sie auf [image], um die Zuordnungsdatei zu bearbeiten. Klicken Sie auf [image], um die Zuordnungsdatei zu löschen.
    Anmerkung: Für diese Aktionen werden die Berechtigungen Zuordnungsdateien für Office-Import bearbeiten respektive Löschen von Zuordnungsdateien für Office-Import benötigt.
  6. Klicken Sie auf OK.
Die Testinformationen werden in der Excel-Datei gespeichert und können dann bearbeitet werden.
Übergeordnetes Thema: Export und Aktualisierung von Tests
Zugehörige Tasks
Aktualisieren von Tests aus Excel
Bearbeiten von Zuordnungsdateien für Tests


Aktualisieren von Tests aus Excel

Zum Aktualisieren von Tests in Excel müssen Sie den Test zunächst aus Silk Central exportieren.
  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf den Testcontainer oder Ordner mit den Tests, die Sie aktualisieren möchten.
  3. Wählen Sie Aus Excel aktualisieren... Der Dialog Tests aus Excel-Datei aktualisieren wird geöffnet.
  4. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist TestPropertiesDefaultMapping.xml. Informationen zum Erstellen benutzerdefinierter Zuordnungsdateien finden Sie unter Bearbeiten von Zuordnungsdateien für Tests.
  5. Optional: Klicken Sie auf [image], um die Zuordnungsdatei zu bearbeiten. Klicken Sie auf [image], um die Zuordnungsdatei zu löschen.
    Anmerkung: Für diese Aktionen werden die Berechtigungen Zuordnungsdateien für Office-Import bearbeiten respektive Löschen von Zuordnungsdateien für Office-Import benötigt.
  6. Wählen Sie die gewünschte Excel-Datei in dem Feld Testdatei (.xlsx) aus.
  7. Klicken Sie auf OK.
Übergeordnetes Thema: Export und Aktualisierung von Tests
Zugehörige Tasks
Exportieren von Tests nach Excel
Bearbeiten von Zuordnungsdateien für Tests


Importieren von Tests

In diesem Abschnitt wird beschrieben, wie Tests aus Microsoft Excel in Silk Central importiert werden.

Mit Silk Central können Sie Tests aus Microsoft Excel (Excel) in einen beliebigen Container oder Ordner des Bereichs Tests importieren und anschließend alle zugehörigen Tests in Silk Central verwalten und ausführen. Der Import muss also nur einmal durchgeführt werden.

Vor dem Importieren von Tests müssen Sie in Excel eine Testsdatei erstellen. Weitere Informationen finden Sie unter Testsdatei.

Silk Central arbeitet mit den in Excel und einer Zuordnungsdatei gespeicherten Informationen, um zu bestimmen, welche Daten abgespeichert werden. Silk Central verwendet eine Zuordnungsdatei, um die Tests in der Excel-Datei den Tests im Tests-Bereich zuzuordnen. Für den Import wird vorab die Standardzuordnungsdatei TestPropertiesDefaultMapping.xml ausgewählt. Sie können Ihre Tests auch mit einer benutzerdefinierten Zuordnungsdatei zuordnen. Weitere Informationen zum Zuordnen von Dateien finden Sie unter Bearbeiten von Zuordnungsdateien für Tests.

  • Importieren von Tests aus Excel-Dateien
    Sie können einen Test aus einer Microsoft Excel-Datei in den Bereich Tests importieren.
  • Testdateien
    Beschreibt den Inhalt der Excel-Datei für Tests, aus der Sie Tests importieren können.
Übergeordnetes Thema: Test-Export, -Aktualisierung und -Import
Zugehörige Konzepte
Testdateien
Zugehörige Tasks
Bearbeiten von Zuordnungsdateien für Tests


Importieren von Tests aus Excel-Dateien

So importieren Sie einen Test aus einer Excel-Datei in den Bereich Tests:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Hierarchie Tests mit der rechten Maustaste auf den Ordner oder den Container, dem Sie den importierten Testplan unterordnen möchten, und wählen Sie Aus Excel importieren. Der Dialog Test aus Excel-Datei importieren wird geöffnet.
  3. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist TestPropertiesDefaultMapping.xml. Informationen zum Erstellen benutzerdefinierter Zuordnungsdateien finden Sie unter Bearbeiten von Zuordnungsdateien für Tests.
  4. Optional: Klicken Sie auf [image], um die Zuordnungsdatei zu bearbeiten. Klicken Sie auf [image], um die Zuordnungsdatei zu löschen.
    Anmerkung: Für diese Aktionen werden die Berechtigungen Zuordnungsdateien für Office-Import bearbeiten respektive Löschen von Zuordnungsdateien für Office-Import benötigt.
  5. Aktivieren Sie das Kontrollkästchen Einmaliger Import, um die Tests direkt unter dem ausgewählten Knoten zu importieren, ohne einen gemeinsamen übergeordneten Ordner zu erstellen.
  6. Geben Sie entweder im Feld Testdatei den vollständigen Pfad der Testdatei ein, oder klicken Sie auf Datei auswählen, um die Testdatei zu suchen.
  7. Klicken Sie auf OK.
Übergeordnetes Thema: Importieren von Tests
Zugehörige Konzepte
Testdateien
Zugehörige Tasks
Bearbeiten von Zuordnungsdateien für Tests


Testdateien

Sie können in Excel eine Testsdatei erstellen, um Testpläne in Silk Central zu importieren. In der Testsdatei können Sie alle Tests und Testschritte einschließlich ihrer Eigenschaften, Attribute und Parameter definieren.

Sie können die Tests der Testdatei mithilfe einer XML-Zuordnungsdatei den entsprechenden Tests in Silk Central zuordnen. Die Zuordnungsdatei gibt die Position der Elemente in der Testdatei für Silk Central an. Sie können die Elemente der Testsdatei beliebig benennen. Wichtig ist nur, dass Sie sie in der Zuordnungsdatei richtig zuordnen. Weitere Informationen zum Zuordnen von Dateien finden Sie unter Bearbeiten von Zuordnungsdateien für Tests.

Anmerkung: Silk Central unterstützt derzeit nur den Import von .xslx-Dateien, und es können nur manuelle Tests importiert werden.

Eigenschaftszuordnung

Klicken Sie auf den Dialogen Tests aus Excel-Datei importieren oder Tests mit Excel-Datei aktualisieren auf Zuordnung bearbeiten, um die Tests in Ihrer Excel-Datei folgendermaßen Silk Central zuzuordnen:
  • Kopfzeile: Geben Sie die Zeile in Ihrer Excel-Testdatei an, welche die Spaltennamen enthält, die für die Zuordnung der Eigenschaften verwendet werden sollen.
  • Erste Datenzeile: Geben Sie die Zeile an, welche den ersten Test enthält. Diese und alle nachfolgenden Zeilen werden als Tests interpretiert.
  • Trennzeichen: Geben Sie die Zeichen an, welche in den Eigenschaftswerten als Trennzeichen interpretiert werden sollen. Dies wird für Mehrfachlisten-Eigenschaften verwendet.
  • Name, Beschreibung: Geben Sie die Spaltennamen in der Kopfzeile an, welche dem Namen bzw. der Beschreibung von Tests zugeordnet werden sollen.
  • Geplante Dauer: Die erwartete Ausführungsdauer dieses manuellen Tests.
  • Testschritt-Eigenschaften Der Name, die Aktionsbeschreibung und die erwarteten Ergebnisse des Testschritts.
  • IDs der zugeordneten Anforderungen: Wenn dem Test Anforderungen zugeordnet werden sollen, geben Sie mit einer kommagetrennten Liste die IDs dieser Anforderungen an. Stellen Sie sicher, dass diese Spalte in Excel als „Text“ formatiert ist, da die Zuordnung sonst nicht funktioniert.
Übergeordnetes Thema: Importieren von Tests
Zugehörige Tasks
Bearbeiten von Zuordnungsdateien für Tests


Zuordnungsdatei

Eine Zuordnungsdatei wird während des Aktualisierungsvorgangs der Export-Aktualisierung und während des Importvorgangs, d. h. beim Import von Daten aus Excel in Silk Central, verwendet.

  • Bearbeiten von Zuordnungsdateien für Tests
    Sie können beim Importieren eines Tests aus einer Excel-Datei die Zuordnungsdatei direkt in der Benutzeroberfläche bearbeiten.
Übergeordnetes Thema: Test-Export, -Aktualisierung und -Import


Bearbeiten von Zuordnungsdateien für Tests

Um die Zuordnungsdatei zu bearbeiten benötigen Sie die Berechtigung Zuordnungsdateien für Office-Import bearbeiten:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Hierarchie Tests mit der rechten Maustaste auf den Ordner oder den Container, dem Sie den importierten Testplan unterordnen möchten, und wählen Sie Aus Excel importieren. Der Dialog Test aus Excel-Datei importieren wird geöffnet.
  3. Klicken Sie auf Zuordnung bearbeiten. Das Dialogfeld Zuordnung bearbeiten wird geöffnet.
  4. Bearbeiten Sie in den Feldern die Variablen der Testdatei.
    Anmerkung: Weitere Informationen zu den Variablen in der Testdatei finden Sie unter Testdateien.
  5. Optional: Bearbeiten Sie den Namen der Zuordnungsdatei.
  6. Klicken Sie auf OK, um die Änderungen zu speichern, oder auf Abbrechen, um sie zu verwerfen.
Übergeordnetes Thema: Zuordnungsdatei
Zugehörige Konzepte
Testdateien


Testversionsverwaltung

Silk Central erstellt während des Import- und Aktualisierungsvorgangs neue Versionen von Tests.

Wenn Sie eine Aktualisierung von Excel in Silk Central vornehmen, werden zwei neue Versionen der Testhierarchie erzeugt. Während der Versionsverwaltung wird vor und nach der Aktualisierung ein Snapshot erstellt.

Export-Aktualisierung

Die Tests erhalten bei jeder Änderung oder beim Hinzufügen neuer Tests Standardkommentare, die anzeigen, dass die Tests über Excel aktualisiert wurden.

Import

Die Tests erhalten den Standardkommentar Erstellt.

Übergeordnetes Thema: Test-Export, -Aktualisierung und -Import
Zugehörige Tasks
Aktualisieren von Tests aus Excel


Schlüsselwortgetriebene Tests

Schlüsselwortgetriebenes Testen ist eine Software-Testmethodologie, welche den Entwurf von Tests von der Implementierung der Tests trennt, und dadurch die Beteiligung von zusätzlichen professionellen Gruppen, zum Beispiel Business Analysten, an dem Testautomatisierungsprozess ermöglicht. Silk Central und Silk Test unterstützen die schlüsselwortgetriebene Testmethodologie und ermöglichen eine sehr enge Zusammenarbeit zwischen Automatisierungsingenieuren und Business Analysten, indem Automatisierungsingenieure ein wartbares Automatisierungs-Framework erstellen, welches aus gemeinsamen Objekten in Form von Schlüsselwörtern in Silk Test besteht. Diese Schlüsselwörter können dann von Business Analysten sowohl in Silk Test verwendet werden, um neue schlüsselwortgetriebene Tests zu erstellen, als auch in Silk Central, um existierende manuelle Tests zu automatisieren oder um neue schlüsselwortgetriebene Tests zu erstellen.

  • Ein schlüsselwortgetriebener Test ist eine ausführbare Reihenfolge von Schlüsselwörtern. Ein schlüsselwortgetriebener Test kann wie jeder andere Test ausgeführt werden.
  • Eine Schlüsselwort-Sequenz ist ein Schlüsselwort, welches eine Kombination von anderen Schlüsselwörtern ist. Schlüsselwort-Sequenzen verbinden oft verwendete Schlüsselwortkombinationen in einem einzigen Schlüsselwort, wodurch Sie den Wartungsaufwand verkleinern und Ihre Tests sauber ordnen können.
  • Ein Schlüsselwort ist eine definierte Kombination von einer oder mehr Aktionen gegen ein Testobjekt. Ein Schlüsselwort kann mit verschiedenen Werkzeugen und in verschiedenen Programmiersprachen, zum Beispiel Java oder .NET, implementiert werden.

Das Erstellen von schlüsselwortgetriebenen Tests benötigt zwei Phasen:
  1. Das Entwerfen des Tests.
  2. Das Implementieren der Schlüsselwörter.
  • Vorteile von schlüsselwortgetriebenem Testen
    Zählt die Vorteile auf, welche sich aus der Verwendung der Methodik "Schlüsselwortgetriebenes Testen" für funktionales Testen und Regressionstests ergeben.
  • Schlüsselwörter
    Hier werden Schlüsselwörter beschrieben, und wie Sie sie verwenden können.
  • Test-Automatisierungs Übersicht
    Hier werden die Testautomatisierung und die Testautomatisierungs-Frameworks beschrieben.
  • Erstellen eines schlüsselwortgetriebenen Tests in Silk Central
    Erstellen Sie einen schlüsselwortgetriebenen Test für Ihr Testautomatisierungs-Framework.
  • Erstellen eines schlüsselwortgetriebenen Tests durch Automatisierung eines manuellen Tests
    Konvertieren Sie in Silk Central einen manuellen Test in einen automatisierten, schlüsselwortgetriebenen Test für Ihr Testautomatisierungs-Framework.
  • Verwalten von Schlüsselwörtern in einem Test
    Verwalten Sie Schlüsselwörter in einem schlüsselwortgetriebenen Test, um eine bestimmte Abfolge von Aufgaben festzulegen.
  • Verwalten von Schlüsselwörtern in einer Bibliothek
    Verwalten Sie Schlüsselwörter in einer Schlüsselwort-Sequenz, um eine bestimmte Abfolge von Aufgaben festzulegen.
  • Cross-Browser-Testen mit schlüsselwortgetriebenen Tests
    Lassen Sie durch Verwendung von Parametern Ihre schlüsselwortgetriebenen Tests über verschiedene Browser laufen.
  • Erstellen einer Bibliothek mit schlüsselwortgetriebenen Tests unter Verwendung von Java
    Erstellen Sie mit Java eine externe Bibliothek mit Schlüsselwörtern und laden Sie diese auf Silk Central hoch. Dadurch können sie ihr existierendes Test-Framework ganz einfach in Silk Central integrieren, z.B. wenn sie bereits Selenium Tests haben.
  • Hochladen einer Schlüsselwort-Bibliothek über die Befehlszeile
    Laden Sie eine externe Schlüsselwort-Bibliothek von einer Java-basierten Befehlszeile hoch, um Silk Central und Ihre schlüsselwortgetriebenen Tests in Ihr Continuous-Integration-Build-System (z.B. Jenkins) zu integrieren.
  • Ausführen von schlüsselwortgetriebenen Silk4J/Silk4NET-Tests ohne eine eine Bibliothek hochzuladen
    Führen Sie schlüsselwortgetriebene Silk4J/Silk4NET-Tests in Silk Central aus ohne eine Bibliothek hochzuladen.
  • Beispiel: Schlüsselwörter mit Parametern
    Hier wird beschrieben, wie sie Schlüsselwörter mit Parametern verwenden können.
  • Welche Schlüsselwörter empfiehlt Silk Central?
    Hier wird der grundsätzliche Algorithmus beschrieben, den Silk Central verwendet um Schlüsselwörter für schlüsselwortgetriebenes Testen zu empfehlen.
Übergeordnetes Thema: Testtypen


Vorteile von schlüsselwortgetriebenem Testen

Die Verwendung der Methodik "Schlüsselwortgetriebenes Testen" bietet folgende Vorteile:
  • Schlüsselwortgetriebenes Testen trennt die Testautomatisierung vom Entwurf eines Tests, und erlaubt somit eine bessere Arbeitsteilung und bessere Zusammenarbeit zwischen Testingenieuren welche Schlüsselwörter implementieren und Experten welche Testfälle entwerfen.
  • Tests können früh entwickelt werden, ohne Zugang zu der zu testenden Anwendung zu erfordern, und die Schlüsselwörter können später implementiert werden.
  • Tests können ohne Programmierkenntnisse entwickelt werden.
  • Langfristig betrachtet benötigen schlüsselwortgetriebene Tests weniger Wartungsaufwand. Sie müssen nur die Schlüsselwörter warten, wodurch sämtliche Tests, die diese Schlüsselwörter verwenden, automatisch aktualisiert werden.
  • Testfälle sind kurz und klar.
  • Testfälle sind für ein technisch weniger versiertes Publikum leichter zu lesen und zu verstehen.
  • Testfälle können ohne viel Aufwand geändert werden.
  • Neue Testfälle können bestehende Schlüsselwörter wiederverwenden, was unter anderem zu einer verbesserten Testabdeckung führt.
  • Die interne Komplexität der Schlüsselwortimplementierung ist für den Benutzer, welcher einen schlüsselwortgetriebenen Test erstellen oder ausführen muss, nicht sichtbar.
Übergeordnetes Thema: Schlüsselwortgetriebene Tests


Schlüsselwörter

Ein Schlüsselwort ist eine definierte Kombination von einer oder mehr Aktionen gegen ein Testobjekt. Ein Schlüsselwort kann mit verschiedenen Werkzeugen und in verschiedenen Programmiersprachen, zum Beispiel Java oder .NET, implementiert werden. In Silk Test ist ein Schlüsselwort eine annotierte Testmethode (@Keyword). Schlüsselwörter sind als Schlüsselwortobjekte gespeichert.

Schlüsselwortgetriebene Tests und ihre zugehörigen Schlüsselwörter können in Silk Central entworfen werden, während die eigentliche Implementierung in einem Tool für funktionales Testen gemacht wird. Silk Central und Silk Test unterstützen die schlüsselwortgetriebene Testmethodologie und ermöglichen eine sehr enge Zusammenarbeit zwischen Automatisierungsingenieuren und Business Analysten, indem Automatisierungsingenieure ein wartbares Automatisierungs-Framework erstellen, welches aus gemeinsamen Objekten in Form von Schlüsselwörtern in Silk Test besteht. Diese Schlüsselwörter können dann von Business Analysten sowohl in Silk Test verwendet werden, um neue schlüsselwortgetriebene Tests zu erstellen, als auch in Silk Central, um existierende manuelle Tests zu automatisieren oder um neue schlüsselwortgetriebene Tests zu erstellen.

Eine Schlüsselwort-Sequenz ist ein Schlüsselwort, welches eine Kombination von anderen Schlüsselwörtern ist. Schlüsselwort-Sequenzen verbinden oft verwendete Schlüsselwortkombinationen in einem einzigen Schlüsselwort, wodurch Sie den Wartungsaufwand verkleinern und Ihre Tests sauber ordnen können.

Übergeordnetes Thema: Schlüsselwortgetriebene Tests


Test-Automatisierungs Übersicht

Test-Automatisierung ist der Prozess, Software zu verwenden, um die Ausführung von Tests zu kontrollieren, indem man Überprüfungen verwendet um die tatsächlichen Ergebnisse der Ausführung mit den erwarteten Ergebnissen zu vergleichen.

Ein Test-Automatisierungs-Framework ist ein integriertes System, welches die Regeln für die Automatisierung eines spezifischen Produktes festlegt. Dieses System integriert die Tests, die Datenquellen der Tests, die Details der Objekte und verschiedene wiederverwendbare Module. Diese Komponenten müssen zusammengestellt werden, um einen Unternehmensablauf darzustellen. Das Framework bietet die Basis für die Test-Automatisierung und verringert den Aufwand für die Automatisierung.

Übergeordnetes Thema: Schlüsselwortgetriebene Tests


Erstellen eines schlüsselwortgetriebenen Tests in Silk Central

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test), oder wählen Sie in der Hierarchie durch Klicken mit der rechten Maustaste die Option Neuer untergeordneter Test.

    Ein neuer Testknoten wird in die Hierarchie eingefügt, und das Dialogfeld Neuer Test wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wählen Sie aus der Liste Typ den Testtyp Schlüsselwortgetriebener Test aus.
  6. Wählen Sie die Bibliothek aus, welche die zu verwendenden Schlüsselwörter enthält. Eine Bibliothek wird benötigt, um die vom schlüsselwortgetriebenen Test verwendeten Schlüsselwörter zu speichern.
  7. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: Schlüsselwortgetriebene Tests


Erstellen eines schlüsselwortgetriebenen Tests durch Automatisierung eines manuellen Tests

So konvertieren Sie inSilk Central einen manuellen Test in einen schlüsselwortgetriebenen Test:
  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf den manuellen Test in der Hierarchie Tests und wählen Sie Automatisieren mit ... > Schlüsselwortgetriebener Test aus dem Kontextmenü. Der Dialog Eigenschaften von schlüsselwortgetriebenem Test wird geöffnet.
  3. Wählen Sie die Bibliothek aus, welche die zu verwendenden Schlüsselwörter enthält. Eine Bibliothek wird benötigt, um die vom schlüsselwortgetriebenen Test verwendeten Schlüsselwörter zu speichern.
  4. Klicken Sie auf Fertig stellen.
Das Automatisieren eines manuellen Tests als einen schlüsselwortgetriebenen Test erstellt folgendes:
  • Der manuelle Test wird in einen automatisierten, schlüsselwortgetriebenen Test konvertiert, der einen Schlüsselwort-Entwurf für jeden einzelnen Testschritt enthält. Diese Schlüsselwörter werden zur Bibliothek hinzugefügt, die für den Test ausgewählt wurde.
  • Wenn der Test Aufrufe von gemeinsam verwendbaren Testschritten, welche bereits als Schlüsselwort-Sequenzen existieren, enthält, werden diese Schlüsselwort-Sequenzen referenziert.
  • Wenn der Test Aufrufe von gemeinsam verwendbaren Testschritten, welche nicht als Schlüsselwort-Sequenzen existieren, enthält, werden diese gemeinsam verwendbaren Testschritte referenziert und werden erweitert zu Schlüsselwort-Sequenzen, welche einen Schlüsselwort-Entwurf für jeden einzelnen Testschritt enthalten. Dies kann auch für geschachtelte gemeinsam verwendbare Testschritte (gemeinsam verwendbare Testschritte, welche weitere gemeinsam verwendbare Testschritte referenzieren) angewandt werden. Wenn die Hierarchie der geschachtelten gemeinsam verwendbaren Testschritte tiefer als 30 Ebenen ist, werden Schlüsselwort-Entwürfe für Aufrufe von gemeinsam verwendbaren Testschritten unterhalb dieser Ebene erstellt.
  • Wenn der Test Aufrufe von gemeinsam verwendbaren Testschritten in einer anderen Bibliothek enthält, werden Schlüsselwort-Entwürfe für diese Testschritte erstellt und referenziert.

Wenn Ihre Testschritte Parameter enthalten, die Sie in den generierten Schlüsselwörtern verwenden möchten, muss die Aktionsbeschreibung des Testschritts die korrekte Syntax verwenden. Parameter verwenden die Syntax ${<Name>}, z.B. ${benutzername}. Wird ein manueller Test in einen schlüsselwortgetriebenen Test konvertiert, werden diese Parameter automatisch dem generierten Schlüsselwort hinzugefügt.

Übergeordnetes Thema: Schlüsselwortgetriebene Tests


Verwalten von Schlüsselwörtern in einem Test

Tests > Detailansicht > <Test> > Schlüsselwörter
Auf der Seite Schlüsselwörter können Sie die Schlüsselwörter des ausgewählten schlüsselwortgetriebenen Tests verwalten. Folgende Aktionen sind möglich:
Aufgabe | Schritte
Öffnen eines Tests oder einer Schlüsselwort-Sequenz in Silk Test | Klicken sie auf Mit Silk Test öffnen um den ausgewählten Test oder die ausgewählte Schlüsselwort-Sequenz in Silk Test zu öffnen.
Hinzufügen eines Schlüsselworts
  1. Klicken Sie unterhalb der Liste von Schlüsselwörtern auf Neues Schlüsselwort, oder klicken Sie mit der rechten Maustaste auf ein Schlüsselwort und wählen Sie im Kontextmenü auf Schlüsselwort oberhalb einfügen.
    Anmerkung: Basierend auf der Häufigkeit ihrer Verwendung, können Sie Silk Central Schlüsselwörter empfehlen lassen. Die Empfehlung von Schlüsselwörtern können Sie im Kontextmenü mittels Schlüsselwort-Empfehlungen einschalten oder Schlüsselwort-Empfehlungen ausschalten ein- oder ausschalten. Weitere Informationen finden Sie unter Welche Schlüsselwörter empfiehlt Silk Central?.
  2. Wählen Sie aus der Liste bestehender Schlüsselwörter eines aus, oder geben Sie einen neuen Namen ein, um ein neues Schlüsselwort zu erstellen.
  3. Klicken Sie auf Speichern.
Alternativ können Sie auch den Bereich Alle Schlüsselwörter verwenden: Mittels Doppelklick oder durch Ziehen und Ablegen kann ein Schlüsselwort zum Test hinzugefügt werden.
Tipp: Mit der Kombination Strg+Klick können Sie mehrere Schlüsselwörter auswählen. Beim Ziehen und Ablegen werden sie genau in der Reihenfolge eingefügt, in der Sie sie nacheinander selektiert haben.
Löschen eines Schlüsselworts | Klicken Sie in der Spalte Aktionen des Schlüsselworts, das Sie löschen möchten, auf Löschen. Klicken Sie auf Speichern.
Ändern der Reihenfolge von Schlüsselwörtern | Ziehen Sie ein Schlüsselwort auf die gewünschte Position und legen Sie es ab. Klicken Sie auf Speichern.
Erstellen einer Schlüsselwort-Sequenz (ein Schlüsselwort bestehend aus mehreren Schlüsselwörtern)
  1. Wählen Sie in der Schlüsselwort-Liste die Schlüsselwörter aus, die Sie kombinieren möchten. Mit Strg+Klick bzw. Umschalt+Klick in der Spalte „Zeilennummer“ können Sie mehrere Schlüsselwörter auswählen.
  2. Klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Kombinieren aus.
  3. Geben Sie einen Namen und eine Beschreibung für die neue Schlüsselwort-Sequenz ein.
Extrahieren von Schlüsselwörtern aus einer Schlüsselwort-Sequenz | Klicken Sie mit der rechten Maustaste auf eine Schlüsselwort-Sequenz und wählen Sie Schlüsselwörter extrahieren. Die ursprüngliche Schlüsselwort-Sequenz wird durch die enthaltenen Schlüsselwörter ersetzt, sie wird aber nicht aus der Bibliothek gelöscht. Klicken Sie auf Speichern.
Kopieren und Einfügen von Schlüsselwörtern in Tests oder Schlüsselwort-Sequenzen
  1. Wählen Sie in der Schlüsselwort-Liste die Schlüsselwörter aus, die Sie kopieren möchten. Mit Strg+Klick bzw. Umschalt+Klick in der Spalte „Zeilennummer“ können Sie mehrere Schlüsselwörter auswählen.
  2. Drücken Sie die Tasten Strg+C um Ihre Auswahl zu kopieren, oder Strg+X wenn Sie die Schlüsselwörter verschieben möchten.
  3. Öffnen Sie den Test oder die Schlüsselwort-Sequenz in den/die Sie die Schlüsselwörter einfügen möchten und wählen Sie die Zeile aus, oberhalb der die Schlüsselwörter eingefügt werden sollen.
  4. Drücken Sie die Tasten Strg+V.
Tipp: Sie können Ihre ausgewählten Schlüsselwörter auch in Excel einfügen, und sie von dort wieder kopieren und in Ihre Tests oder Schlüsselwort-Sequenzen einfügen.
Definieren von Parametern für eine Schlüsselwort-Sequenz
  1. Klicken Sie oberhalb der Schlüsselwort-Liste auf Parameter. Der Dialog Parameter wird angezeigt.
  2. Klicken Sie auf Parameter hinzufügen.
  3. Geben Sie einen Namen für den neuen Parameter ein. Soll es sich um einen Ausgabeparameter handeln (liefert einen Wert, statt einen Eingabewert zu benötigen), aktivieren Sie das Kontrollkästchen Ausgabe.
  4. Klicken Sie auf OK.
  5. Klicken Sie auf Speichern.
Bearbeiten eines Schlüsselwort-Entwurfs
  1. Klicken Sie auf Bearbeiten in der Spalte Aktionen des Schlüsselwort-Entwurfs, den Sie bearbeiten möchten.
  2. Wählen Sie eine Gruppe für das Schlüsselwort aus, oder erstellen Sie eine neue Gruppe.
  3. Geben Sie eine Beschreibung für das Schlüsselwort ein. Diese Information ist wichtig für die Person, die das Schlüsselwort implementieren wird.
  4. Klicken Sie auf OK.
  5. Optional: Klicken Sie in ein Parameter-Feld hinein, um Parameter für das Schlüsselwort zu definieren. Wenn das Schlüsselwort mit Silk Test implementiert wird, erscheinen diese Parameter automatisch im generierten Code-Stub.
  6. Klicken Sie auf Speichern.
Suchen nach einem Schlüsselwort
Verwenden Sie das Suchfeld im Bereich Alle Schlüsselwörter um ein bestimmtes Schlüsselwort zu finden. Wenn Sie alphanumerische Zeichen eingeben, zeigt die Liste dynamisch alle Treffer an. Tipps für die Suche:
  • Die Suche achtet nicht auf Groß-/Kleinschreibung: aufgabeAusführen findet aufgabeausführen und AufgabeAusführen.
  • Um eine sogenannte CamelCase-Suche durchzuführen, geben Sie ausschließlich Großbuchstaben ein: KAE findet Kontakt Adresse Eingeben, Karten Ablaufdatum Eingeben and KontaktAdresseEingeben.
  • Es werden sowohl die Namen von Schlüsselwörtern als auch von Gruppen berücksichtigt: test findet alle Schlüsselwörter, die test enthalten, sowie alle Schlüsselwörter in Gruppen, deren Name test enthält.
  • ? ersetzt 0-1 Zeichen: benutzer?test findet benutzerTest und benutzer1Test.
  • * ersetzt 0-n Zeichen: mein*schlüsselwort findet meinSchlüsselwort, meinNeuesSchlüsselwort und mein_anderes_schlüsselwort.
  • <Zeichenfolge>. sucht nur in Gruppennamen: gruppe. findet alle Schlüsselwörter in Gruppen, deren Name gruppe enthält.
  • .<Zeichenfolge> sucht nur in Schlüsselwortnamen: .schlüsselwort findet alle Schlüsselwörter, die schlüsselwort enthalten.
  • <Zeichenfolge>.<Zeichenfolge> sucht nach Schlüsselwörtern in einer bestimmten Gruppe: gruppe.wort findet meinSchlüsselwort in der Gruppe meineGruppe.
  • Verwenden Sie Hochkommas um nach einer exakten Übereinstimmung zu suchen: 'Schlüsselwort' findet Schlüsselwort und MeinSchlüsselwort, aber nicht schlüsselwort.
Auffinden von Schlüsselwort-Entwürfen in Bibliotheken | Wenn Sie zur Bibliothek wechseln möchten, welche die Schlüsselwort-Entwürfe Ihres ausgewählten Tests oder der Schlüsselwort-Sequenz enthält, klicken Sie rechts oben auf Schlüsselwort-Entwürfe
Übergeordnetes Thema: Schlüsselwortgetriebene Tests
Zugehörige Konzepte
Zwischenspeicherung von Daten in Tests
Zugehörige Verweise
Verwalten von Schlüsselwörtern in einer Bibliothek
Welche Schlüsselwörter empfiehlt Silk Central?


Verwalten von Schlüsselwörtern in einer Bibliothek

Auf der Seite Schlüsselwörter unter Tests > Bibliotheken gibt es zwei unterschiedliche Ansichten, je nach ausgewähltem Objekt in der Bibliothekshierarchie.

Bibliothek

Wenn Sie eine Bibliothek ausgewählt haben, wird eine Liste aller Schlüsselwörter und Schlüsselwort-Sequenzen angezeigt, die sich in dieser Bibliothek befinden. Bibliotheken, in denen sich eine hochgeladene Schlüsselwort-Bibliothek befindet, werden mit dem Symbol [image] angezeigt. Folgende Aktionen sind möglich:
Task | Schritte
Ein Schlüsselwort implementieren (Code hinzufügen, so dass das Schlüsselwort in einem Test ausgeführt werden kann) Voraussetzungen: Wenn Ihr Schlüsselwort Parameter beinhaltet, muss für jeden Parameter ein Wert angegeben werden, bevor Sie das Schlüsselwort implementieren.
  1. Klicken Sie in der Spalte Aktionen auf Mit Silk Test implementieren (Mit Silk Test implementieren).
    Anmerkung: Falls Ihr Browser eine Sicherheitswarnung wegen dem Öffnen einer externen Anwendung anzeigt, bestätigen Sie diese Meldung.
  2. Der Silk Test-Client wird geöffnet. Ausführliche Informationen finden Sie in der Hilfe des Silk Test-Clients.
  3. Nachdem Sie ein Schlüsselwort implementiert haben, laden Sie es wieder auf Silk Central hoch.
Ein implementiertes Schlüsselwort in Silk Test bearbeiten. | Klicken Sie auf Mit Silk Test öffnen (Mit Silk Test öffnen), um ein Schlüsselwort im Silk Test-Client zu öffnen. Ausführliche Informationen finden Sie in der Hilfe des Silk Test-Clients.
Konvertieren eines Schlüsselwort-Entwurfs in eine Schlüsselwort-Sequenz (ein Schlüsselwort bestehend aus mehreren Schlüsselwörtern) | Klicken Sie in der Spalte Aktionen des Schlüsselworts, das Sie in eine Schlüsselwort-Sequenz konvertieren möchten, auf Schlüsselwort-Sequenz erstellen. Das ursprüngliche Schlüsselwort wird ersetzt durch eine Schlüsselwort-Sequenz mit demselben Namen, und der Schlüsselwort-Editor wird angezeigt.
Konvertieren einer Schlüsselwort-Sequenz in einen Schlüsselwort-Entwurf Sollten Sie versehentlich eine Schlüsselwort-Sequenz erstellt haben, möchten Sie diese vielleicht wieder in einen Schlüsselwort-Entwurf zurück konvertieren. Klicken Sie in der Spalte Aktionen auf Zu Schlüsselwort-Entwurf konvertieren (Zu Schlüsselwort-Entwurf konvertieren).
Anmerkung: Wenn eine Schlüsselwort-Sequenz in einen Entwurf konvertiert wird, wird die Schlüsselwort-Sequenz und alle darin enthaltenen Schlüsselwörter gelöscht. Diese Aktion kann nicht rückgängig gemacht werden.
Bearbeiten einer Schlüsselwort-Sequenz | Klicken Sie auf Gehe zu um die Schlüsselwort-Sequenz im Schlüsselwort-Editor zu öffnen.
Gruppieren von Schlüsselwörtern Um Schlüsselwörter in einer Bibliothek besser zu strukturieren, können Sie diese gruppieren:
  • Silk Central-Schlüsselwort-Sequenzen können in Unterordnern platziert werden. Die Ordnernamen werden als Gruppennamen übernommen und die Schlüsselwörter werden entsprechend in der Liste gruppiert.
  • Die Gruppen von implementierten Schlüsselwörtern müssen im Code festgelegt werden. Diese Gruppennamen werden von Silk Central übernommen und die Schlüsselwörter werden entsprechend in der Liste gruppiert.
Tests und Schlüsselwort-Sequenzen anzeigen, die ein bestimmtes Schlüsselwort oder eine bestimmte Schlüsselwort-Sequenz verwenden. | Um alle Tests und Schlüsselwort-Sequenzen anzuzeigen, die ein bestimmtes Schlüsselwort oder eine bestimmte Schlüsselwort-Sequenz verwenden, wählen Sie in der Liste der Schlüsselwörter den entsprechenden Eintrag aus. Die Liste Verwendet von zeigt sämtliche referenzierenden schlüsselwortgetriebenen Tests und Schlüsselwort-Sequenzen an. Klicken Sie einfach auf den Namen um zur entsprechenden Verwendung zu gelangen.
Schlüsselwörter in referenzierenden Tests und Schlüsselwort-Sequenzen ersetzen Um Verwendungen des ausgewählten Schlüsselwortes oder der ausgewählten Schlüsselwort-Sequenz mit einer anderen zu ersetzen, wählen Sie in der Liste der Schlüsselwörter den entsprechenden Eintrag aus und wählen Sie in der Liste Verwendet von die Objekte aus, in denen Sie die Verwendung ersetzen möchten.
  1. Wählen Sie das Schlüsselwort oder die Schlüsselwort-Sequenz aus, die Sie ersetzen möchten.
  2. Verwenden Sie in der Liste Verwendet von die Tastenkombinationen Strg+Klick oder Umschalttaste+Klick um die Objekte auszuwählen, in denen Sie die Verwendung ersetzen möchten.
  3. Klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Schlüsselwort in den ausgewählten Verwendungen ersetzen. Der Dialog Verwendungen ersetzen wird angezeigt.
  4. Wählen das Schlüsselwort aus, mit dem Sie das derzeitige Schlüsselwort ersetzen möchten.
  5. Falls das ausgewählte Schlüsselwort Parameter enthält, klicken Sie auf Weiter, ansonsten auf OK und der Vorgang ist erledigt.
  6. Die Parameter des ausgewählten Schlüsselwortes werden angezeigt. Geben Sie für jeden Parameter den entsprechenden Parameter des vorherigen Schlüsselwortes an, oder geben Sie einen Wert ein.
  7. Klicken Sie auf OK.

Schlüsselwort-Sequenz

Wenn Sie eine Schlüsselwort-Sequenz (ein Schlüsselwort bestehend aus mehreren Schlüsselwörtern) ausgewählt haben, wird auf der Seite Schlüsselwörter der Schlüsselwort-Editor angezeigt, mit dem Sie die Schlüsselwörter der ausgewählten Schlüsselwort-Sequenz verwalten können. Folgende Aktionen sind möglich:
Task | Schritte
Öffnen eines Tests oder einer Schlüsselwort-Sequenz in Silk Test | Klicken sie auf Mit Silk Test öffnen um den ausgewählten Test oder die ausgewählte Schlüsselwort-Sequenz in Silk Test zu öffnen.
Hinzufügen eines Schlüsselworts
  1. Klicken Sie unterhalb der Liste von Schlüsselwörtern auf Neues Schlüsselwort, oder klicken Sie mit der rechten Maustaste auf ein Schlüsselwort und wählen Sie im Kontextmenü auf Schlüsselwort oberhalb einfügen.
    Anmerkung: Basierend auf der Häufigkeit ihrer Verwendung, können Sie Silk Central Schlüsselwörter empfehlen lassen. Die Empfehlung von Schlüsselwörtern können Sie im Kontextmenü mittels Schlüsselwort-Empfehlungen einschalten oder Schlüsselwort-Empfehlungen ausschalten ein- oder ausschalten. Weitere Informationen finden Sie unter Welche Schlüsselwörter empfiehlt Silk Central?.
  2. Wählen Sie aus der Liste bestehender Schlüsselwörter eines aus, oder geben Sie einen neuen Namen ein, um ein neues Schlüsselwort zu erstellen.
  3. Klicken Sie auf Speichern.
Alternativ können Sie auch den Bereich Alle Schlüsselwörter verwenden: Mittels Doppelklick oder durch Ziehen und Ablegen kann ein Schlüsselwort zum Test hinzugefügt werden.
Tipp: Mit der Kombination Strg+Klick können Sie mehrere Schlüsselwörter auswählen. Beim Ziehen und Ablegen werden sie genau in der Reihenfolge eingefügt, in der Sie sie nacheinander selektiert haben.
Löschen eines Schlüsselworts | Klicken Sie in der Spalte Aktionen des Schlüsselworts, das Sie löschen möchten, auf Löschen. Klicken Sie auf Speichern.
Ändern der Reihenfolge von Schlüsselwörtern | Ziehen Sie ein Schlüsselwort auf die gewünschte Position und legen Sie es ab. Klicken Sie auf Speichern.
Erstellen einer Schlüsselwort-Sequenz (ein Schlüsselwort bestehend aus mehreren Schlüsselwörtern)
  1. Wählen Sie in der Schlüsselwort-Liste die Schlüsselwörter aus, die Sie kombinieren möchten. Mit Strg+Klick bzw. Umschalt+Klick in der Spalte „Zeilennummer“ können Sie mehrere Schlüsselwörter auswählen.
  2. Klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Kombinieren aus.
  3. Geben Sie einen Namen und eine Beschreibung für die neue Schlüsselwort-Sequenz ein.
Extrahieren von Schlüsselwörtern aus einer Schlüsselwort-Sequenz | Klicken Sie mit der rechten Maustaste auf eine Schlüsselwort-Sequenz und wählen Sie Schlüsselwörter extrahieren. Die ursprüngliche Schlüsselwort-Sequenz wird durch die enthaltenen Schlüsselwörter ersetzt, sie wird aber nicht aus der Bibliothek gelöscht. Klicken Sie auf Speichern.
Definieren von Parametern für eine Schlüsselwort-Sequenz
  1. Klicken Sie oberhalb der Schlüsselwort-Liste auf Parameter. Der Dialog Parameter wird angezeigt.
  2. Klicken Sie auf Parameter hinzufügen.
  3. Geben Sie einen Namen für den neuen Parameter ein. Soll es sich um einen Ausgabeparameter handeln (liefert einen Wert, statt einen Eingabewert zu benötigen), aktivieren Sie das Kontrollkästchen Ausgabe.
  4. Klicken Sie auf OK.
  5. Klicken Sie auf Speichern.
Bearbeiten eines Schlüsselwort-Entwurfs
  1. Klicken Sie auf Bearbeiten in der Spalte Aktionen des Schlüsselwort-Entwurfs, den Sie bearbeiten möchten.
  2. Wählen Sie eine Gruppe für das Schlüsselwort aus, oder erstellen Sie eine neue Gruppe.
  3. Geben Sie eine Beschreibung für das Schlüsselwort ein. Diese Information ist wichtig für die Person, die das Schlüsselwort implementieren wird.
  4. Klicken Sie auf OK.
  5. Optional: Klicken Sie in ein Parameter-Feld hinein, um Parameter für das Schlüsselwort zu definieren. Wenn das Schlüsselwort mit Silk Test implementiert wird, erscheinen diese Parameter automatisch im generierten Code-Stub.
  6. Klicken Sie auf Speichern.
Suchen nach einem Schlüsselwort
Verwenden Sie das Suchfeld im Bereich Alle Schlüsselwörter um ein bestimmtes Schlüsselwort zu finden. Wenn Sie alphanumerische Zeichen eingeben, zeigt die Liste dynamisch alle Treffer an. Tipps für die Suche:
  • Die Suche achtet nicht auf Groß-/Kleinschreibung: aufgabeAusführen findet aufgabeausführen und AufgabeAusführen.
  • Um eine sogenannte CamelCase-Suche durchzuführen, geben Sie ausschließlich Großbuchstaben ein: KAE findet Kontakt Adresse Eingeben, Karten Ablaufdatum Eingeben and KontaktAdresseEingeben.
  • Es werden sowohl die Namen von Schlüsselwörtern als auch von Gruppen berücksichtigt: test findet alle Schlüsselwörter, die test enthalten, sowie alle Schlüsselwörter in Gruppen, deren Name test enthält.
  • ? ersetzt 0-1 Zeichen: benutzer?test findet benutzerTest und benutzer1Test.
  • * ersetzt 0-n Zeichen: mein*schlüsselwort findet meinSchlüsselwort, meinNeuesSchlüsselwort und mein_anderes_schlüsselwort.
  • <Zeichenfolge>. sucht nur in Gruppennamen: gruppe. findet alle Schlüsselwörter in Gruppen, deren Name gruppe enthält.
  • .<Zeichenfolge> sucht nur in Schlüsselwortnamen: .schlüsselwort findet alle Schlüsselwörter, die schlüsselwort enthalten.
  • <Zeichenfolge>.<Zeichenfolge> sucht nach Schlüsselwörtern in einer bestimmten Gruppe: gruppe.wort findet meinSchlüsselwort in der Gruppe meineGruppe.
  • Verwenden Sie Hochkommas um nach einer exakten Übereinstimmung zu suchen: 'Schlüsselwort' findet Schlüsselwort und MeinSchlüsselwort, aber nicht schlüsselwort.
Auffinden von Schlüsselwort-Entwürfen in Bibliotheken | Wenn Sie zur Bibliothek wechseln möchten, welche die Schlüsselwort-Entwürfe Ihres ausgewählten Tests oder der Schlüsselwort-Sequenz enthält, klicken Sie rechts oben auf Schlüsselwort-Entwürfe
Übergeordnetes Thema: Schlüsselwortgetriebene Tests
Übergeordnetes Thema: Bibliotheken
Zugehörige Konzepte
Zwischenspeicherung von Daten in Tests
Zugehörige Verweise
Verwalten von Schlüsselwörtern in einem Test
Welche Schlüsselwörter empfiehlt Silk Central?


Cross-Browser-Testen mit schlüsselwortgetriebenen Tests

Schlüsselwortgetriebene Tests, die mit Silk Test implementiert wurden und den Parameter BrowserBaseState enthalten, können in Silk Central parametrisiert werden, so dass damit verschiedene Browser gleichzeitig getestet werden können. So konfigurieren Sie die zu testenden Browser:
  1. Erstellen Sie eine Konfigurationssuite und ordnen Sie ihr die schlüsselwortgetriebenen Tests zu, mit denen Sie mehrere Browser testen möchten. Weitere Informationen über das Erstellen von Konfigurationssuiten finden Sie in Erstellen einer Konfigurationssuite.
  2. Klicken Sie auf der Registerkarte Konfigurationen auf Parameter hinzufügen/entfernen und erstellen Sie einen neuen Parameter mit dem Namen silktest.configurationName.
  3. Klicken Sie auf Neue Konfiguration um die zu testenden Konfigurationen hinzuzufügen. Definieren Sie für jede Konfiguration den zu testenden Browser, indem Sie einen der folgenden Werte für den Parameter silktest.configurationName festlegen:
    • Internet Explorer
    • Firefox
    • Chrome
  4. Führen Sie die Konfigurationssuite aus.
Übergeordnetes Thema: Schlüsselwortgetriebene Tests


Erstellen einer Bibliothek mit schlüsselwortgetriebenen Tests unter Verwendung von Java

Erstellen Sie mit Java eine externe Bibliothek mit Schlüsselwörtern und laden Sie diese auf Silk Central hoch. Dadurch können sie ihr existierendes Test-Framework ganz einfach in Silk Central integrieren, z.B. wenn sie bereits Selenium Tests haben.
  1. Wählen Sie Hilfe > Tools und laden Sie das Java Schlüsselwort-Bibliothek-Tool herunter.
  2. Fügen Sie das heruntergeladene com.borland.silk.keyworddriven.jar zum Klassenpfad Ihres Java-Projekts hinzu.
  3. Erstellen Sie eine Java-Klasse, welche Ihre Schlüsselwörter enthalten wird.
  4. Annotieren Sie die Java-Methoden, die Sie als Schlüsselwörter verwenden möchten. Das folgende Beispiel zeigt eine Klasse, die ein einzelnes Schlüsselwort enthält:
    import com.borland.silk.keyworddriven.annotations.Argument;
import com.borland.silk.keyworddriven.annotations.Keyword;

public class Keywords {

  @Keyword("Mein Schlüsselwort")
  public void myKeyword(@Argument("Benutzername") String name) {
    System.out.println(name);
  }
}
  5. Kompilieren Sie Ihren Programmcode und erstellen Sie ein Java-Archiv (jar).
  6. Rufen Sie das in der heruntergeladenen jar-Datei enthaltene Befehlszeilen-Tool mit den folgenden Argumenten auf:
    • java
    • -jar com.borland.silk.keyworddriven.jar
    • -build
    • Name der Bibliothek, die generiert werden soll.
    • Art der Bibliothek, zur Zeit wird nur Java unterstützt.
    • Pfad der Binär-Dateien wo sich Ihre Schlüsselwort-Bibliothek befindet (jar-Datei) und, wenn nötig, sämtliche weitere erforderliche Bibliotheken.
    • Name des zu erstellenden Bibliothekspakets (zip-Archiv).
    Das folgende Beispiel zeigt die Kommandozeile zum Erstellen einer Schlüsselwort-Bibliothek:
    java -jar com.borland.silk.keyworddriven.jar -build
MyLibrary Java ./output "./output/library.zip"
Wählen Sie Tests > Bibliotheken > <Bibliothek> > Eigenschaften. Mit dem Befehlszeilen-Tool, oder im Bereich Schlüsselwort-Bibliothek, kann das generierte zip-Archiv auf Silk Central hochgeladen werden.
Übergeordnetes Thema: Schlüsselwortgetriebene Tests
Übergeordnetes Thema: Bibliotheken
Zugehörige Konzepte
Verwalten von Schlüsselwort-Bibliotheken und Bibliothekseigenschaften
Zugehörige Tasks
Hochladen einer Schlüsselwort-Bibliothek über die Befehlszeile


Hochladen einer Schlüsselwort-Bibliothek über die Befehlszeile

Laden Sie eine externe Schlüsselwort-Bibliothek von einer Java-basierten Befehlszeile hoch, um Silk Central und Ihre schlüsselwortgetriebenen Tests in Ihr Continuous-Integration-Build-System (z.B. Jenkins) zu integrieren.
So laden Sie Ihre Schlüsselwort-Bibliothek von einer Java-basierten Befehlszeile hoch:
  1. Wählen SieHilfe > Tools und laden Sie das Java Schlüsselwort-Bibliothek-Tool herunter.
  2. Rufen Sie das in der heruntergeladenen jar-Datei enthaltene Befehlszeilen-Tool mit den folgenden Argumenten auf:
    • java
    • -jar com.borland.silk.keyworddriven.jar
    • -upload
    • Bibliotheksname der Bibliothek in Silk Central, welche aktualisiert werden soll, oder neu erstellt wenn sie noch nicht existiert.
    • Paketname des zu erstellenden Bibliothekspakets (zip-Archiv), das hochgeladen werden soll.
    • Hostname:Port des Silk Central-Front-End-Servers.
    • Benutzername des Silk Central-Benutzers.
    • Kennwort des Silk Central-Benutzers.
    • Änderungsinformation in Hochkommas, welche die Änderungen an der Bibliothek beschreibt.
    • [-allowUsedKeywordDeletion], ein optionales Flag, welches das Löschen von in Tests oder Schlüsselwort-Sequenzen verwendeten Schlüsselwörtern erlaubt. Standardmäßig wird ein Fehler angezeigt, wenn versucht wird ein verwendetes Schlüsselwort zu löschen.
    Das folgende Beispiel zeigt die Kommandozeile zum Hochladen einer Schlüsselwort-Bibliothek auf Silk Central:
    java -jar com.borland.silk.keyworddriven.jar -upload
"Meine Bibliothek" "./output/library.zip" silkcentral:19120 scLogin
scPassword "Build xy: Fehlende Schlüsselwörter implementiert"
Übergeordnetes Thema: Schlüsselwortgetriebene Tests
Zugehörige Konzepte
Automatisierungsserver-Integrationen
Silk Central-Webdienste
Zugehörige Tasks
Erstellen einer Bibliothek mit schlüsselwortgetriebenen Tests unter Verwendung von Java


Ausführen von schlüsselwortgetriebenen Silk4J/Silk4NET-Tests ohne eine eine Bibliothek hochzuladen

Wenn Sie bereits ein bestehendes Testautomatisierungs-Framework haben, welches aus schlüsselwortgetriebenen Silk4J oder Silk4NET-Tests besteht, und Sie diese in Silk Central ausführen möchten, können Sie dies mit der Silk Central JUnit und Testpaket Funktionalität erreichen. Gehen Sie dazu wie folgt vor:
  1. Erstellen Sie ein Versionsverwaltungsprofil, welches auf die Artefakte Ihres Silk Test-Projekts verweist (siehe Versionsverwaltungsprofile).
  2. Erstellen Sie einen Container, der dieses Versionsverwaltungsprofil verwendet (siehe Hinzufügen von Containern).
  3. Erstellen sie einen JUnit-Test (siehe Erstellen von Tests) und konfigurieren Sie Folgendes:
    • Für schlüsselwortgetriebene Tests die in Silk4J implementiert sind:
      • Legen Sie den Klassenpfad fest. Wenn Sie die Standard-Buildstruktur von Silk Test verwenden, geben Sie .\output an.
      • Die .kdt-Dateien müssen sich im Ordner befinden, den Sie im Klassenpfad festgelegt haben, entweder verpackt in eine .jar-Datei oder in einem Ordner innerhalb des Klassenpfads.
    • Für schlüsselwortgetriebene Tests die in Silk4NET implementiert sind:
      • Legen Sie ./Keyword Driven Tests als Klassenpfad fest.

      • Erstellen Sie einen Parameter für den Container Ihrer Tests (siehe Erstellen benutzerdefinierter Parameter) mit dem Namen silktest.keyworddriven.dotnetassembly mit einem relativen Pfad zur .Net Assembly, z.B. \bin\Release\Silk4NETProject.dll.

      • Der Silk Test-Ordner "Keyword Driven Tests", welcher die .kdt-Dateien enthält, muss sich im Stammordner der Versionsverwaltung befinden.
  4. Weisen Sie den Test einer Testsuite zu (siehe Zugeordnete Tests).
  5. Optional: Nach der Ausführung können Sie mit der rechten Maustaste auf den Test klicken und In Testpaket konvertieren wählen, um die Paketstruktur zu erhalten (siehe Erstellen eines Testpakets).
Übergeordnetes Thema: Schlüsselwortgetriebene Tests


Beispiel: Schlüsselwörter mit Parametern

Dieser Abschnitt zeigt ein Beispiel, wie sie Schlüsselwörter mit Parametern verwenden können.

Erstellen Sie zuerst einen schlüsselwortgetriebenen Test, welcher die zu verwendenden Schlüsselwörter enthalten soll. Sie können dies entweder durch Aufzeichnung des gesamten schlüsselwortgetriebenen Tests erledigen, oder indem Sie einen neuen schlüsselwortgetriebenen Test erstellen und die Schlüsselwörter im Editor für schlüsselwortgetriebene Tests hinzufügen.

In diesem Beispiel enthält der schlüsselwortgetriebene Test die folgenden Schlüsselwörter:
Start application
Dies ist das Standardschlüsselwort welches die zu testende Anwendung startet und den Basisstatus setzt.
Login
Dieses Schlüsselwort meldet mittels Benutzernamen und Kennwort einen bestimmten Benutzer bei der zu testenden Anwendung an.
GetCurrentUser
Dieses Schlüsselwort gibt den Namen des Benutzers zurück, der zur Zeit bei der zu testenden Anwendung angemeldet ist.
AssertEquals
Dieses Schlüsselwort vergleicht zwei Werte.
Logout
Dieses Schlüsselwort meldet sich von der zu testenden Anwendung ab.

Als Nächstes werden dem Schlüsselwort die Parameter hinzugefügt. Öffnen Sie hierzu die Testskripts der Schlüsselwörter und fügen sie die Parameter den Methoden hinzu.

Um dem Schlüsselwort Login die Eingabeparameter UserName und Password hinzuzufügen, ändern Sie
@Keyword("Login")
public void login() {
  ...
}
um in
@Keyword("Login")
public void login(String UserName, String Password) {
  ...
}
Um dem Schlüsselwort GetCurrentUser den Ausgabeparameter UserName hinzuzufügen, ändern Sie
@Keyword("GetCurrentUser")
public void getCurrentUser() {
  ...
}
um in
@Keyword("GetCurrentUser")
public void getCurrentUser(OutParameter CurrentUser) {
  ...
}

Im Editor für schlüsselwortgetriebene Tests sollte der Test ungefähr so aussehen:

Nun können Sie den Parametern im Editor für schlüsselwortgetriebene Tests tatsächliche Werte zuweisen. Um im Schlüsselwort GetCurrentUser den Parameter UserName zu erhalten, geben Sie eine Variable an, zum Beispiel ${current user}. Der in der Variable enthaltene Wert kann dann an nachfolgende Schlüsselwörter weitergegeben werden.

Übergeordnetes Thema: Schlüsselwortgetriebene Tests


Welche Schlüsselwörter empfiehlt Silk Central?

Wenn Sie im Keyword-Driven Test Editor Schlüsselwörter zu einem schlüsselwortgetriebenen Test oder einer Schlüsselwort-Sequenz hinzufügen, empfiehlt Silk Central welches Schlüsselwort Sie evtl. als nächstes verwenden möchten. Empfohlene Schlüsselwörter erscheinen oben in der Schlüsselwort-Liste und zeigen in einem Balkendiagramm an, wie hoch die Empfehlung von Silk Central ist.

Silk Central empfiehlt die Schlüsselwörter basierend auf den folgenden Kriterien:

  • Wenn sie das erste Schlüsselwort in einem schlüsselwortgetriebenen Test oder einer Schlüsselwort-Sequenz definieren, sucht Silk Central nach ähnlichen Schlüsselwörtern, welche auch schon als erstes Schlüsselwort verwendet wurden. Je öfter ein Schlüsselwort verwendet wird, desto höher ist die Empfehlung.
  • Wenn Sie weitere Schlüsselwörter hinzufügen, empfiehlt Silk Central die Schlüsselwörter folgendermaßen:
    • Befindet sich bereits ein Schlüsselwort vor der Stelle, an der sie eine neues einfügen möchten, vergleicht Silk Central die Vorgänger-Schlüsselwörter sämtlicher schlüsselwortgetriebenen Tests und Schlüsselwort-Sequenzen und empfiehlt die Schlüsselwörter, die am häufigsten auf dieses Schlüsselwort folgen.
    • Befindet sich kein Schlüsselwort vor der Stelle, an der sie eine neues einfügen möchten, aber danach schon, vergleicht Silk Central die Nachfolger-Schlüsselwörter sämtlicher schlüsselwortgetriebenen Tests und Schlüsselwort-Sequenzen und empfiehlt die Schlüsselwörter, die am häufigsten vor diesem Schlüsselwort liegen.
  • Zusätzlich berücksichtigt Silk Central, wie ähnlich die gefundenen Schlüsselwörter sind. Stimmen z.B. Sowohl der Name wie auch die Gruppe von zwei Schlüsselwörtern überein, empfiehlt Silk Central diese Schlüsselwörter höher als wenn nur der Name übereinstimmt.
Übergeordnetes Thema: Schlüsselwortgetriebene Tests
Zugehörige Konzepte
Zwischenspeicherung von Daten in Tests
Zugehörige Verweise
Verwalten von Schlüsselwörtern in einem Test
Verwalten von Schlüsselwörtern in einer Bibliothek


Unified Functional Testing (UFT) Tests

Mit Unified Functional Testing (UFT) Software, früher HP QuickTest Professional (QTP) genannt, können funktionales Testen und Regressionstests für Software-Anwendungen und -Umgebungen automatisiert werden.
  • Erstellen oder Bearbeiten von Unified Functional Testing (UFT) Tests
    Erstellen oder bearbeiten Sie einen UFT-Test um UFT-Tests in Silk Central auszuführen.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Erstellen oder Bearbeiten von Unified Functional Testing (UFT) Tests

Um UFT-Tests ausführen zu können, muss die Unified Functional Testing-Software auf den gleichen Computern installiert sein, auf dem die Silk Central-Ausführungsserver installiert sind.

So erstellen oder bearbeiten Sie einen UFT-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Unified Functional Testing-Test aus. Klicken Sie auf Weiter.

    Der Dialog Unified Functional Testing-Testeigenschaften wird geöffnet.

  6. Wählen Sie im Feld Test den Versionsverwaltungs-Pfad des auszuführenden UFT-Tests aus.
    Tipp: Sie können entweder den Test selbst (.tsp) auswählen, oder den Pfad in dem sich der Test befindet.
  7. Optional: Aktivieren Sie die Option HPE UFT Add-ins validieren um alle definierten Add-ins des angegebenen UFT-Tests zu validieren.
  8. Optional: Aktivieren Sie die Option HPE UFT Anwendung anzeigen um die getestete Anwendung während der Testausführung anzuzeigen.
  9. Optional: Aktivieren Sie die Option Debug-Nachrichten ausgeben um Debug-Nachrichten an die Testergebnisse anzuhängen.
  10. Optional: Verwenden Sie die Kontrollkästchen Geerbt um die Einstellungen des übergeordneten UFT-Tests zu erben.
  11. Klicken Sie auf Fertig stellen.
Anmerkung: Parameter werden an den UFT-Test übergeben, indem Parameter mit demselben Namen wie die der im UFT-Test definierten Test-Parameter definiert werden.

Die ursprünglichen UFT-Ergebnisdateien, run_results.xml und run_results.html, können auf der Registerkarte Dateien in den Testergebnissen eingesehen werden.

Übergeordnetes Thema: Unified Functional Testing (UFT) Tests


JUnit-Tests

JUnit ist ein Unit-Test-Framework für die Java-Programmiersprache. Verwenden Sie diesen Testtyp für JUnit-, Silk4J- und Selenium-Tests.
  • Erstellen oder bearbeiten von JUnit-Tests
    Erstellen oder bearbeiten Sie einen JUnit-Test für Ihr Java Unit-Testing Framework.
  • Zugriff auf Silk Central-Parameter über Java-Systemeigenschaften
    Hier werden die Silk Central-Parameter aufgeführt, auf die Sie über Java-Systemeigenschaften in JUnit-Tests zugreifen können.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Erstellen oder bearbeiten von JUnit-Tests

So erstellen oder bearbeiten Sie einen JUnit-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag JUnit-Test aus. Klicken Sie auf Next.

    Der Dialog JUnit-Testeigenschaften wird geöffnet.

  6. Geben Sie einen gültigen, auf dem Ausführungsserver zu verwendenden Java-Klassenpfad an.

    Es wird die Verwendung eines relativen Klassenpfads empfohlen. Der relative Klassenpfad wird dann auf dem Ausführungsserver zum vollständigen Klassenpfad erweitert. Wenn ein relativer Klassenpfad verwendet wird, muss bei Änderungen des Speicherorts des Versionsverwaltungsprofils der Klassenpfad nicht geändert werden.

    Der relative Klassenpfad muss auf den Stammknoten des Testcontainers zeigen, der den JUnit-Test enthält, z. B. JUnit_tests. Der relative Klassenpfad auf dem Ausführungsserver wird dann so erweitert, dass er das Versionsverwaltungsprofil des Arbeitsordners, z. B. C:\temp, und die Namen der Testdateien, z. B. tests.jar enthält. Wenn Ihre Tests z.B. In einer JAR-Datei namens tests.jar verpackt sind und weitere für die Ausführung benötigte JAR-Dateien in einem Unterordner namens lib enthalten sind, würde Ihr Klassenpfad ./tests.jar;./lib/* heißen.

    Sie können auch einen vollqualifizierten Klassenpfad verwenden. Der voll qualifizierte Klassenpfad muss auf ein Archiv oder einen Ordner verweisen, in dem sich die Testklassen befinden.

  7. Optional: Geben Sie im Textfeld Testklasse den voll qualifizierten Namen der JUnit-Testklasse ein. Wird das Feld leer gelassen, werden alle Tests im Klassenpfad ausgeführt, aber nur wenn die JAR-Datei, welche die Tests enthält, explizit im Feld Klassenpfad angegeben wurde.
  8. Optional: Geben Sie im Feld Testmethode den Namen der betreffenden Testmethode ein. Diese Methode muss in der Testklasse verfügbar sein. Wenn das Textfeld Testmethode leer bleibt, werden alle in der Suite enthaltenen Tests ausgeführt.
  9. Optional: Geben Sie als Java-Startverzeichnis das Installationsverzeichnis der Java-Laufzeitumgebung (JRE) an. Der Pfad muss auf dem Ausführungsserver, auf dem der Test ausgeführt wird, gültig sein.
    Anmerkung: JUnit-Tests können in JRE 1.5 und höher ausgeführt werden. Verwenden Sie eine ältere Version von JRE, werden Meldungen wie java.lang.UnsupportedClassVersionError oder Unrecognized option: -javaagent im Register Meldungen angezeigt.
  10. Optional: Die Optionen für die Kommandozeile können Sie im Feld JVM Optionen angeben. Sie können mehrere Optionen festlegen, wobei auf die richtige Reihenfolge zu achten ist. Beispiel: Um die Mandanten-VM zu verwenden und als maximale Größe des Heaps 512 MB festzulegen, geben Sie -client -Xmx512m ein. Sie können auch Umgebungsvariablen verwenden, z.B. -Xmx${MY_MEMORY}.
  11. Aktivieren Sie das Kontrollkästchen Aufzeichnung der externen AUT-Abdeckung, um nur die Codeabdeckung für die aktuell getestete Anwendung zu ermitteln, die für die Testsuite im Bereich Einstellungen für die Codeanalyse unter Silk Central > Ausführungsplanung > Codeanalyse definiert ist. Wenn dieses Kontrollkästchen nicht aktiviert ist, wird die Codeabdeckung der virtuellen Maschine, auf der der Test ausgeführt wird, auch ermittelt.
  12. Optional: Geben Sie im Feld Testabdeckungs-Pfad die JAR-Bibliotheken oder Klassendateien ein, die hinsichtlich der Codeabdeckungsinformationen überwacht werden sollen. Beachten sie, dass hier der Abdeckungspfad des JUnit-Tests definiert wird, nicht der Pfad der zu testenden Anwendung.

    Es wird empfohlen, den relativen Abdeckungspfad vom Stammknoten des Containers zu verwenden, der dann auf dem Ausführungsserver erweitert wird. Sie können auch einen vollqualifizierten Pfad verwenden. Trennen Sie die Pfadangaben für die einzelnen JAR-Dateien jeweils durch ein Semikolon, wie in nachfolgenden Beispielen gezeigt:

    • tests.jar;C:\tests\testutils.jar
    • ${testenv}\tests.jar;${testenv}\testutils.jar
    Anmerkung: Die Einstellung des Abdeckungspfades wird nicht berücksichtigt, wenn das Kontrollkästchen Aufzeichnen der externen AUT-Abdeckung aktiviert ist.
  13. Klicken Sie auf Fertig stellen.
Anmerkung: Parameter werden an den Java-Prozess als Systemeigenschaften übergeben, z. B. -Dhost_under_test=10.5.2.133. Mit der Methode System.getProperty() greifen Sie auf die Systemeigenschaften zu. Mit host_under_test greifen Sie zum Beispiel auf die zuvor übergebene Eigenschaft System.getProperty(“host_under_test”); zu.
Übergeordnetes Thema: JUnit-Tests
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Zugriff auf Silk Central-Parameter über Java-Systemeigenschaften

Jede beliebige JUnit-Testklasse kann auf einen Testparameter des zugrundeliegenden Tests durch Auslesen der entsprechenden Java-Systemeigenschaft zugreifen. Jeder Parameter wird der ausführenden Java virtuellen Maschine über die -D-Option übergeben.

Neben den benutzerdefinierten Parametern können Sie jederzeit die folgenden Java-Systemeigenschaften aus einem JUnit-Test aufrufen:
Parameter
Beschreibung
#sctm_execdef_name
Der Name der aktuell ausgeführten Testsuite. Wenn die Ausführung aus dem Bereich Testplan heraus ausgelöst wurde, hat der Parameter den Wert Probelauf.
#sctm_execdef_id
Die numerische ID (Datenbankschlüssel) der Testsuite, die aktuell ausgeführt wird.
#sctm_product
Der im ausgeführten Container angegebene Name des Produkts.
#sctm_version
Der Name der Version, mit der die Ergebnisse der Ausführung assoziiert sind.
#sctm_build
Der Name der Version, mit der die Ergebnisse der Ausführung assoziiert sind.
#sctm_keywords
Eine durch Komma getrennte Liste mit Schlüsselwörtern, die für diese Testsuite definiert sind.
#sctm_test_results_dir
Der Verzeichnispfad, in dem die Ergebnisdateien des Tests liegen.
#sctm_test_name
Der Name des durchgeführten Silk Central Tests.
#sctm_test_id
Der numerische Bezeichner (Datenbankschlüssel) des durchgeführten Tests.
#sctm_source_root_dir
Der lokale Pfad des Hauptverzeichnisses vom Container, wo sich alle Dateien unter Versionsverwaltung befinden.
#external_id
Die eindeutige Kennung eines Tests in einem auszuführenden Testpaket. Diese kann als Filter verwendet werden, wenn nur bestimmte Tests in einem Testpaket ausgeführt werden sollen.

#is_test_package_root
Wenn true zutrifft, ist der ausgeführte Test der Stammknoten im Testpaket (Standardeinstellung). Wenn false zutrifft, werden nur durch #external_id definierte Tests im Testpaket ausgeführt.
#sctm_data_driven_parent_test_name
Der Name des übergeordneten Tests, falls der ausgeführte Test eine Datengetriebene Zeile ist.
#sctm_data_driven_parent_test_id
Die numerische Kennung (Datenbankschlüssel) des übergeordneten Tests, falls der ausgeführte Test eine Datengetriebene Zeile ist.
Übergeordnetes Thema: JUnit-Tests
Zugehörige Konzepte
Testparameter
Zugehörige Verweise
Vordefinierte Parameter


MSTest-Tests

MSTest ist ein Befehlszeilen-Tool von , welches Unit-Tests ausführt die mit Microsoft erstellt wurden. Verwenden Sie diesen Testtyp für MSTest- und Silk4NET-Tests.
  • Erstellen oder bearbeiten von MSTest-Tests
    Erstellen oder bearbeiten Sie einen MSTest-Test für Ihr Visual Studio Unit-Testing Framework.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Erstellen oder bearbeiten von MSTest-Tests

Anmerkung: Das MSTest-Plugin unterstützt nur die Testtypbereichstests. Die Ergebnisse aus anderen Testtypen werden ignoriert.

So erstellen oder bearbeiten Sie einen MSTest-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag MSTest-Test aus. Klicken Sie auf Next.

    Der Dialog MSTest-Testeigenschaften wird geöffnet.

  6. Sie können einen Container, eine Testliste, eine Testklasse oder eine einzelne Testmethode ausführen:
    • Um einen Container auszuführen, klicken Sie auf Durchsuchen neben dem Feld Testdateien und wählen Sie eine .dll-Datei aus. Um den Durchlauf einzuschränken, geben Sie einfach eine Testklasse bzw. sowohl eine Testklasse als auch eine Testmethode ein.
    • Um eine Testliste auszuführen, klicken Sie auf Durchsuchen neben dem Feld Testdateien und wählen Sie eine .vsmdi-Datei (Visual Studio Test-Metadaten) aus. Geben Sie im Feld Testplan Listenname einen Namen an. Sie können den Durchlauf einschränken, indem Sie sowohl eine Testklasse als auch eine Testmethode eingeben.
  7. Klicken Sie auf Fertig stellen.
Anmerkung: Um einen MSTest auf einem Ausführungsserver zu starten, muss eine Visual Studio-Distribution oder ein Visual Studio Test Agent installiert sein. Fügen Sie den Ordner, der MSTest.exe enthält, in Ihre Pfadvariable ein, und starten Sie den Ausführungsserver neu. Der Standardpfad ist: C:\Program Files (x86)\Microsoft Visual Studio <Version>\Common7\IDE. Aktuell wird MSTest unterstützt, welches mit Microsoft Visual Studio/Visual Studio Test Agent 2012, 2013, 2015 geliefert wird.
Übergeordnetes Thema: MSTest-Tests
Zugehörige Tasks
Starten oder Stoppen eines lokalen Ausführungsserverdienstes
Ausführen eines Versuchslaufs eines Tests


NUnit-Tests

NUnit ist ein Unit-Test-Framework für die Microsoft .NET-Programmiersprache.
  • Erstellen oder bearbeiten von NUnit-Tests
    Erstellen oder bearbeiten Sie einen NUnit-Test für Ihr Microsoft .NET Unit-Testing Framework.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Erstellen oder bearbeiten von NUnit-Tests

Anmerkung: Sie sollten den Ordner .\bin der NUnit-Installation zum Systempfad hinzufügen. Klicken Sie auf Start > Systemsteuerung > System > Erweitert > Umgebungsvariablen, um der Systemumgebungsvariablen PATH einen Pfad wie C:\Program Files\NUnit 2.2\bin hinzuzufügen.

So erstellen oder bearbeiten Sie einen NUnit-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag NUnit-Test aus. Klicken Sie auf Next.

    Der Dialog NUnit-Testeigenschaften wird geöffnet.

  6. Klicken Sie auf Durchsuchen, und wählen Sie die gewünschte NUnit-Assembly aus.
  7. Geben Sie das Arbeitsverzeichnis in das Feld NUnit-Verzeichnis ein.

    Für NUnit 2 ist dieses Verzeichnis der lokale Pfad zur Datei nunit-console.exe, z. B. C:\Programme\NUnit 2.2\bin. Für NUnit 3 ist dieses Verzeichnis der absolute Pfad zur Datei nunit3-console.exe, z. B. C:\Program Files (x86)\NUnit.org\nunit-console\nunit3-console.exe.

  8. Geben Sie im Feld NUnit-Optionen mindestens eine Befehlszeilenoption der NUnit-Konsole ein, um festzulegen, wie NUnit-Tests spezifiziert werden. Um beispielsweise die Ausführung des NUnit-Tests Flex4TestApp unter SilkTest.Ntf.Test.Flex zu definieren, legen Sie die Run-Option wie folgt fest:
    Für NUnit 2:
    /run:SilkTest.Ntf.Test.Flex.Flex4TestApp
    Für NUnit 3:
    /test:SilkTest.Ntf.Test.Flex.Flex4TestApp
    Anmerkung: Wenn Sie mehrere Optionen hinzufügen, müssen Sie die Optionen durch Schreiben von je einer Option in jeder Zeile im Feld trennen.
  9. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: NUnit-Tests
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


ProcessExecutor-Tests

Mit dem ProcessExecutor-Testtyp kann jede beliebige Befehlszeile ausgeführt werden.
  • Erstellen oder bearbeiten von ProcessExecutor-Tests
    Erstellen oder bearbeiten Sie einen ProcessExecutor-Test um eine ausführbare Datei zu starten.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Erstellen oder bearbeiten von ProcessExecutor-Tests

So erstellen oder bearbeiten Sie einen ProcessExecutor-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag ProcessExecutor-Test aus. Klicken Sie auf Weiter. Der Dialog ProcessExecutor-Testeigenschaften wird geöffnet.
  6. Geben Sie im Feld Name der ausführbaren Datei den vollqualifizierten Namen der ausführbaren Datei ein.
  7. Geben Sie im Feld Liste der Argumente alle Argumente der "Process Executor"-Testmethode ein.
    Anmerkung: Mehrfach-Argumente müssen in separaten Zeilen des Felds angegeben werden.
  8. Richten Sie den Arbeitsordner ein. Dies ist der Ordner, in dem die ausführbare Datei ausgeführt wird.
  9. Falls der ausgeführte Befehl JUnit Testergebnisdateien erzeugt, wie z.B. Ant oder Maven JUnit-Ausführungen, können Sie ein Ordnermuster festlegen, welches nach JUnit XML-Ergebnisdateien durchsucht wird. Der Speicherort des Ordners ist relativ zum Arbeitsordner anzugeben, z.B. testergebnisse. Der Stammordner in dem die Suche gestartet wird ist der Arbeitsordner. Von hier werden alle JUnit-Ausgabedateien geholt, deren Pfad das angegebene Muster beinhaltet.
Während der Ausführung der ausführbaren Datei können die zwei folgenden Umgebungsvariablen verwendet werden:
Umgebungsvariablen
Beschreibung
SCTM_EXEC_RESULTSFOLDER
Alle Dateien in diesem Ordner werden als Ergebnisdateien in Silk Central gespeichert. Wenn bei der Ausführung in diesem Verzeichnis eine output.xml-Datei erstellt wird, wird diese von Silk Central verarbeitet.
SCTM_EXEC_SOURCESFOLDER
Dies ist der Ordner, in dem sich alle Quelldateien während der Ausführung befinden.

Beispiel

Das folgende Beispiel enthält einen ProcessExecutor-Testtyp, welcher den Windows Script Host über die Befehlszeile mit dem /c-Schalter und zwei Parametern ausführt:

  • /c – Befehl, der festlegt, dass die Befehlszeile nach der Ausführung beendet werden sollte.
  • cscript – Windows Script Host.
  • parareadwrite.js – die jscript-Datei mit dem Namen parareadwrite.js
  • %SCTM_EXEC_RESULTSFOLDER% – die Silk Central-Variable, welche den Speicherort des Ordners Ergebnis auf dem Ausführungsserverrechner enthält. Die an diesem Speicherort gespeicherten Dateien werden automatisch auf Silk Central hochgeladen und sind über die Registerkarte Dateien des Testlaufs verfügbar. In diesem Beispiel erzeugt das Script parareadwrite.js die Datei output.xml, die in den Ordner Ergebnis geschrieben und zurück auf Silk Central hochgeladen wird.
Übergeordnetes Thema: ProcessExecutor-Tests
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Silk Performer .NET Explorer-Tests

Der -Testtyp wird verwendet um bestimmte Silk Performer .NET Explorer-Skripts oder einen bestimmten Testfall eines Skripts auszuführen.
  • Erstellen oder Bearbeiten von Silk Performer .NET Explorer-Tests
    Erstellen oder bearbeiten Sie einen -Test um Silk Performer .NET Explorer-Skripts oder einen bestimmten Testfall eines Skripts auszuführen.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Erstellen oder Bearbeiten von Silk Performer .NET Explorer-Tests

So erstellen oder bearbeiten Sie einen .NET Explorer-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Silk Performer .NET Explorer-Test aus. Klicken Sie auf Weiter.

    Das Dialogfeld .NET Explorer-Testeigenschaften wird geöffnet.

  6. Wählen Sie das .NET Explorer-Skript aus, das auf den Test angewendet werden soll. Das Skript ist eine .nef-Datei.
  7. Geben Sie den Pfad zur NetExplorer.exe-Ausführungsdatei auf dem Ausführungsserver an. Beispiel: C:\Programme\MyCustomSPFolder\DotNET Explorer\NetExplorer.exe. Sie können auf Ihrem Ausführungsserver auch eine Umgebungsvariable anlegen und diese referenzieren, z.B. ${SP_HOME}\NetExplorer.exe.
  8. Geben Sie im Feld Testfall den Namen des auszuführenden .NET Explorer-Testfalls ein. Wenn Sie das Feld leer lassen, werden alle Testfälle im Skript ausgeführt. Mehrere Testfälle können nicht angegeben werden.
    Anmerkung: Die Testfälle InitTestCase und EndTestCase werden immer ausgeführt.
  9. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: Silk Performer .NET Explorer-Tests
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Silk Performer-Tests

  • Erstellen oder Bearbeiten von Silk Performer-Tests
    Erstellen oder bearbeiten Sie einen Silk Performer-Test um Silk Performer-Projekte in Silk Central auszuführen.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools
Zugehörige Konzepte
Arbeiten mit Silk Performer-Projekten
Zugehörige Tasks
Erstellen oder Bearbeiten von Silk Performer-Tests


Erstellen oder Bearbeiten von Silk Performer-Tests

So erstellen oder bearbeiten Sie einen Silk Performer-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Silk Performer-Test aus. Klicken Sie auf Next.

    Der Dialog Silk Performer-Testeigenschaften - Projekt auswählen wird geöffnet.

  6. Klicken Sie auf Durchsuchen, um ein Silk Performer-Projekt auszuwählen, das in Ihrem lokalen Dateisystem gespeichert ist, und klicken Sie dann auf Weiter.
  7. Wählen Sie in der Liste Lasttest-Szenario eines der für das Projekt definierten Lasttest-Szenario-Profile aus.
  8. Klicken Sie auf Fertig stellen, um den Testfall zu erstellen.
Übergeordnetes Thema: Silk Performer-Tests
Zugehörige Konzepte
Arbeiten mit Silk Performer-Projekten
Silk Performer-Tests
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Silk Test Classic-Tests

Die Silk Central-Schnittstelle von Silk Test Classic ermöglicht Silk Test Classic-Benutzern die zuverlässige Ausführung automatisierter Tests. Jeder Testfall eines Silk Test Classic-Skripts wird in seinem eigenen Testlauf ausgeführt und produziert seine eigenen Ergebnisse.

Der Silk Test Classic Plan-Testtyp wird für Silk Test Classic Testpläne verwendet. Ein Testplan ist üblicherweise ein hierarchisch strukturiertes Dokument, welches die Testanforderungen beschreibt und die Befehle, 4Test-Skripts und Testfälle enthält, welche die Testanforderungen implementieren.

Beim Überwachen der Silk Test Classic-Testausführungen auf der Seite Aktivitäten ist für die aktuell ausgeführte Testsuite ein Link zur Detailansicht verfügbar. Hier kann der Status der aktuellen Testsuite überprüft werden. Bei der Ausführung von Silk Test Classic-Tests besteht der mittlere Teil dieser Ansicht aus zwei Bereichen: Im oberen Bereich werden allgemeine Informationen zu Test, Skript, Testfall und Testdaten angezeigt. Der untere Bereich enthält die von Silk Test Classic ausgegebenen Meldungen (zusammen mit ihrem Schweregrad).

In den vorhergehenden Versionen von Silk Central wurde Silk Test Classic in der Befehlszeile aufgerufen. Die neue Schnittstelle verwendet die Interprozesskommunikation. Sie können mit den Container-Einstellungen festlegen, ob die Silk Central-Schnittstelle von Silk Test Classic verwendet wird.

Für alle Silk Test Classic-Testparameter, die Sie nicht in der Benutzeroberfläche von Silk Test Classic mit den Silk Central-Testeigenschaften festlegen, werden die Standardeinstellungen von Silk Test Classic verwendet (z. B. aus der Datei partner.ini).

  • Erstellen oder Bearbeiten von Silk Test Classic-Tests
    Erstellen oder bearbeiten Sie einen Silk Test Classic-Test um Silk Test Classic-Tests in Silk Central auszuführen.
  • Erstellen oder bearbeiten von Silk Test Classic-Plantests
    Erstellen oder bearbeiten Sie einen Silk Test Classic-Plantest um die Struktur eines Testplans in Silk Central zu importieren.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools
Zugehörige Konzepte
Silk Test Classic-Tests
Zugehörige Tasks
Erstellen oder Bearbeiten von Silk Test Classic-Tests


Erstellen oder Bearbeiten von Silk Test Classic-Tests

So erstellen oder bearbeiten Sie einen Silk Test Classic-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Silk Test Classic-Test aus. Um mehrere Silk Test Classic-Testfälle gleichzeitig zu importieren, wählen Sie Silk Test Classic-Multi-Testfallimport aus. Klicken Sie auf Weiter.

    Der Dialog Testeigenschaften – Testskript auswählen wird geöffnet.

  6. Klicken Sie auf Durchsuchen und wählen Sie das Testskript entweder vom festgelegten Silk Test Classic-Projekt.oder vom Versionsverwaltungsverzeichnis aus. Das Testskript (.t, .g.t) wird relativ zum Stammknoten des Containers im Versionsverwaltungsprofil angegeben. Zum Beispiel /<Silk Test Classic-Projekt>/MeinSkript.t.
  7. Klicken Sie auf Weiter.

    Der Dialog Testeigenschaften - Testfall auswählen wird geöffnet.

    Anmerkung: Wenn das Silk Test Classic-Skript eine datengetriebene .g.t-Datei ist (z. B. SilkTestScript1.g.t), werden die Datenquellen vollständig über die Skriptdatei gesteuert und nicht über die datengetriebenen Eigenschaften von Silk Central. Wenn Sie eine datengetriebene Skriptdatei verwenden, ist das Kontrollkästchen Datengetrieben standardmäßig aktiviert. Weitere Informationen zu datengetriebenen Silk Test Classic-Tests finden Sie in der Dokumentation zu Silk Test Classic.
  8. Wählen Sie einen der in der Skriptdatei verfügbaren Testfälle aus, oder geben Sie einen benutzerdefinierten Testfall an. Wenn das Feld für den benutzerdefinierten Testfall bereits einen Wert enthält, wurde der Silk Test Classic-Test automatisch erstellt (durch die Exportfunktion von Silk Test Classic). Wenn Sie das benutzerdefinierte Feld verwenden, um den Testfall anzugeben, können Sie den Namen des Testfalls mit Klammern "()" beenden. In diesen Klammern können Sie Testdaten, einschließlich Parametern, angeben. Die im benutzerdefinierten Feld angegebenen Daten haben Vorrang vor den Werten der Eigenschaft Testdaten.
  9. Optional: Geben Sie zusätzliche Ausführungsargumente im Feld Testdaten ein. Diese Argumente werden während der Testausführung von Silk Test Classic verarbeitet. Wenn mehrere Argumente an Silk Test Classic übergeben werden, müssen sie jeweils durch ein Komma (,) getrennt werden. String-Argumente müssen in doppelten Anführungszeichen an Silk Test Classic übergeben werden ("). Wenn Sie komplexere Testdaten verwenden möchten, sollten Sie Parameter in den Testdaten verwenden (z. B. ${ParameterName}). Die Parameter werden bei der Ausführung der Tests automatisch ersetzt.
    Anmerkung: Dieses Feld hat eine maximale Länge von 2.000 Zeichen.
  10. Definieren Sie, ob der Test ein TrueLog bereitstellen soll.
    Tipp: Falls Sie ihre Tests mit dem Open Agent ausführen, muss diese Option sowohl in Silk Central als auch in Silk Test eingeschaltet sein, ansonsten wird kein TrueLog bereitgestellt. Datengetriebene Tests werden standardmäßig planbasiert ausgeführt. Wenn Sie einen datengetriebenen Test in skriptbasiertem Ausführungsmodus verwenden, müssen Sie die Einstellung DataDrivenScriptMode in dem Element Silk Test Classic von SccExecServerBootConf.xml ändern. Weitere Informationen hierzu finden Sie in der Dokumentation zu Silk Test Classic.
  11. Legen Sie bei Bedarf eine Optionssetdatei fest. Standardmäßig schließt Silk Central alle geöffneten Silk Test Classic-Optionssetdateien. Wenn Sie eine Optionssetdatei festlegen möchten, geben Sie den Dateinamen relativ zum Stammknoten des Containers im Versionsverwaltungsprofil an.
  12. Klicken Sie auf Fertig stellen, um den Silk Test Classic-Test zu erstellen.
    Anmerkung: Sie müssen bei Silk Test Classic-Testfällen, deren Ausführung länger als eine Stunde dauert, die Timeout-Einstellungen von Silk Central anpassen. Andernfalls nimmt Silk Central an, dass ein Fehler aufgetreten ist, und beendet die Ausführung. Weitere Informationen zum Festlegen der Timeout-Einstellungen finden Sie in den Themen zur Verwaltung in diesem Hilfesystem.
Übergeordnetes Thema: Silk Test Classic-Tests
Zugehörige Konzepte
Silk Test Classic-Tests
Silk Test Classic-Tests
Testparameter
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Erstellen oder bearbeiten von Silk Test Classic-Plantests

So erstellen oder bearbeiten Sie einen Silk Test Classic-Plantest:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Silk Test Classic-Plantest aus. Klicken Sie auf Next.

    Der Dialog Planeigenschaften wird geöffnet.

  6. Geben Sie im Feld Plandatei den vollqualifizierten Namen der auszuführenden Testplandatei (.pln) ein. Klicken Sie auf Durchsuchen, um nach der Datei zu suchen.
  7. Geben Sie im Feld Projektdatei den Namen des Silk Test Classic-Projekts ein, das die Umgebungseinstellungen enthält. Klicken Sie auf Durchsuchen, um nach der Projektdatei zu suchen.
  8. Geben Sie im Feld Optionsset den vollqualifizierten Namen der Optionssetdatei ein, die Umgebungseinstellungen enthält. Klicken Sie auf Durchsuchen, um nach der Optionssetdatei zu suchen.
  9. Geben Sie im Feld Datendatei für Attribute und Abfragen den Standardpfad zu der Testplaninitialisierungsdatei ein. Klicken Sie auf Durchsuchen, um nach der Testplaninitialisierungsdatei zu suchen.
  10. Geben Sie im Feld Name der Testplanabfrage den vollqualifizierten Namen der gespeicherten Testplanabfrage ein.
  11. Klicken Sie auf Fertig stellen.

Um die Struktur Ihres Silk Test Classic-Plan Tests inSilk Central zu verwalten, führen Sie einen Versuchslauf aus. Sobald der Versuchslauf erfolgreich beendet wurde, wird die output.xml-Datei zu den Ergebnisdateien des Testsuitelaufs hinzugefügt. Dadurch können Sie Ihren Test in ein Testpaket konvertieren, was Ihnen die volle Kontrolle über die Teststruktur gibt.

Übergeordnetes Thema: Silk Test Classic-Tests
Zugehörige Tasks
Erstellen eines Testpakets
Ausführen eines Versuchslaufs eines Tests


Silk Test Workbench-Tests

Silk Test Workbench ist ein automatisiertes Testprogramm, das die Funktionstests komplexer Anwendungen beschleunigt. Silk Test Workbench bietet Unterstützung für Testanwendungen, die mit einer Vielzahl unterschiedlicher Entwicklungsprogramme hergestellt wurden, etwa Java, .NET, browserbasierte Webanwendungen und COM-Komponenten wie ActiveX-Steuerelemente und Automatisierungsobjekte.
  • Voraussetzungen um STW.EXE mit Silk Central auszuführen
    Hier werden die Voraussetzungen beschrieben, die nötig sind um STW.EXE mit einem Silk Central-Ausführungsserver auszuführen.
  • Erstellen oder Bearbeiten von Silk Test Workbench-Tests
    Erstellen oder bearbeiten Sie einen Silk Test Workbench-Test um Silk Test Workbench-Tests in Silk Central auszuführen.
  • Öffnen von Silk Test Workbench im Kontext der Ergebnisdatei
    Hier wird beschrieben, wie Silk Test Workbench im Kontext der Ergebnisdatei geöffnet wird.
  • Anzeigen der Dateien mit den Ausführungsergebnissen für einen Visual Test
    Beschreibt, wie man Silk Test Workbench öffnet, um den letzten Screenshot für einen Visual Test anzuzeigen, wenn ein Wiedergabefehler auftritt.
  • Testplanparameter (Seite) - Silk Test Workbench
    Hier wird die Datentypzuordnung für Parameter für Silk Test Workbench beschrieben.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Voraussetzungen um STW.EXE mit Silk Central auszuführen

Um STW.EXE mit einem Silk Central-Ausführungsserver auszuführen und sich mit einer Silk Test Workbench-Datenbank zu verbinden, benötigen Sie die folgenden Voraussetzungen:
  1. Betreiben Sie den Silk Central-Ausführungsserver als Prozess, nicht als Dienst.
  2. Verwenden Sie für die Verbindung zur Silk Test Workbench-Datenbank die Datenbank-Authentifizierung. Für die Verbindung mit einer Silk Test Workbench-SQL Server Datenbank kann Silk Test Workbench sowohl die Windows- als auch die Datenbank-Authentifizierung verwenden.
  3. Richten Sie den Datenbankserver so ein, dass er einen statischen Port verwendet.
Werden diese Voraussetzungen nicht erfüllt, könnte Silk Test Workbench den folgenden Fehler melden, wenn Sie versuchen STW.EXE mit einem Silk Central-Ausführungsserver auszuführen:
Error 3: DSN, Benutzername oder Passwort falsch.
Übergeordnetes Thema: Silk Test Workbench-Tests


Erstellen oder Bearbeiten von Silk Test Workbench-Tests

So erstellen oder bearbeiten Sie einen Silk Test Workbench-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Silk Test Workbench-Test aus. Klicken Sie auf Next.

    Der Dialog Silk Test Workbench-Testeigenschaften - Projekt auswählen wird geöffnet.

  6. Wählen Sie in der Liste Silk Test Workbench-Test eines oder mehrere Skripts aus.
  7. Geben Sie im Feld Wiedergabeoptionen den Namen einer vordefinierten Wiedergabeoption für Silk Test Workbench ein, oder übernehmen Sie den Standardwert.
    Anmerkung: Für einen Silk Test Workbench-Test muss eine Wiedergabeoption festgesetzt werden. Um eine Option eines Silk Test Workbench-Tests zu löschen, wird die Wiedergabeoption auf den Standardwert zurückgesetzt.
  8. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: Silk Test Workbench-Tests
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Öffnen von Silk Test Workbench im Kontext der Ergebnisdatei

  1. Klicken Sie im Menü auf Ausführungsplanung.
  2. Wählen Sie Ihren Ausführungsplan.
  3. Klicken Sie auf die Registerkarte Testläufe.
  4. Klicken Sie im unteren Bereich in der Tabelle Testläufe auf die Ausführungs-ID des Tests, dessen Details Sie sich ansehen möchten. Das Dialogfeld Ergebnisse des Testlaufs wird geöffnet.
  5. Klicken Sie auf die Registerkarte Dateien.
  6. Klicken Sie auf die Datei result.stwx, um Silk Test Workbench im Kontext der Ergebnisdatei zu öffnen.
    Anmerkung: Silk Test Workbench muss auf dem Rechner, auf dem Sie die Datei öffnen möchten, installiert sein.
Übergeordnetes Thema: Silk Test Workbench-Tests


Anzeigen der Dateien mit den Ausführungsergebnissen für einen Visual Test

  1. Klicken Sie im Menü auf Ausführungsplanung.
  2. Wählen Sie Ihren Ausführungsplan.
  3. Klicken Sie auf die Registerkarte Testläufe.
  4. Klicken Sie im Bereich Letzte Testausführungen auf die Ausführungs-ID der relevanten Testsuite, um die Ausführungsergebnisse anzuzeigen.
  5. Die Spalte Aktionen zeigt alle Symbole und Links für Silk Test Workbench an:
    • detail.htm – Silk Test Workbench detaillierte Testschrittdatei.
    • result.stwx – zum Öffnen von Ergebnissen in Silk Test Workbench klicken.
    • error.png – zum Wechseln zum Screenshot des letzten Fehlers klicken.
Übergeordnetes Thema: Silk Test Workbench-Tests


Testplanparameter (Seite) - Silk Test Workbench

Tests > Detailansicht > <Testelement> > Datenmenge

Bei der Übergabe von Parametern von einem Silk Central-Test an einen Silk Test Workbench-Test, müssen diese Parameter in Silk Test Workbench als Eingabeparameter definiert sein und sie müssen in Silk Central den gleichen Namen haben, wie im Skript. Die folgenden Datentypen sollten verwendet werden:

Silk Central | Silk Test Workbench
String | Text
Zahl | Zahl (Long)
Zahl | Zahl (Long Long)
Zahl | Aufzählung
Gleitkomma | Zahl (Double)
Boolesch | Boolesch (Wahr/Falsch)
Übergeordnetes Thema: Silk Test Workbench-Tests
Übergeordnetes Thema: Testparameter


SilkTestPartner Tests

TestPartner ist ein Micro Focus-Produkt zum Testen von Web- und Microsoft Windows-basierten Anwendungen, die Microsoft-Technologie verwenden.
  • Erstellen oder Bearbeiten von Silk TestPartner-Tests
    Hier wird beschrieben, wie Sie die TestPartner-Testeigenschaften konfigurieren, um einen neuen TestPartner-Test zu erstellen.
  • Hinzufügen mehrerer TestPartner-Tests
    Sie können beim Erstellen eines neuen TestPartner-Tests mehrere TestPartner-Tests hinzufügen.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Erstellen oder Bearbeiten von Silk TestPartner-Tests

So erstellen oder bearbeiten Sie einen TestPartner-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Silk TestPartner-Test aus. Klicken Sie auf Next.

    Der Dialog Testeigenschaften – Testskript auswählen wird geöffnet.

  6. Klicken Sie auf Durchsuchen.

    Der Dialog Datei auswählen wird geöffnet. Die in diesem Dialogfeld verfügbaren Komponenten basieren auf dem im zugehörigen TestPartner-Versionsverwaltungsprofil definierten Projektpfad.

  7. Wählen Sie ein Skript in der Liste aus, und klicken Sie auf OK.
    Anmerkung: Informationen zum Hinzufügen mehrerer TestPartner-Tests finden Sie unter Hinzufügen mehrerer TestPartner-Tests.
  8. Geben Sie im Feld Wiedergabeoptionen den Namen einer vordefinierten Wiedergabeoption für TestPartner ein, oder übernehmen Sie den Standardwert.
  9. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: SilkTestPartner Tests
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests
Hinzufügen mehrerer TestPartner-Tests


Hinzufügen mehrerer TestPartner-Tests

Um mehrere TestPartner-Tests hinzuzufügen, führen Sie zunächst die unter Erstellen von Silk TestPartner Tests beschriebenen Schritte aus.

So fügen Sie mehrere TestPartner-Tests hinzu:

  1. Wählen Sie im Dialogfeld Neuer Test im Listenfeld Typ die Option TestPartner Test.
  2. Klicken Sie auf Weiter. Der Dialog Testeigenschaften – Testskript auswählen wird geöffnet.
  3. Klicken Sie auf Durchsuchen.

    Der Dialog Datei auswählen wird geöffnet. Die in diesem Dialogfeld verfügbaren Komponenten basieren auf dem im zugehörigen TestPartner-Versionsverwaltungsprofil definierten Projektpfad.

  4. Geben Sie im Feld Wiedergabeoptionen den Namen einer vordefinierten Wiedergabeoption für TestPartner ein, oder übernehmen Sie den Standardwert.
    Anmerkung: Die definierte Wiedergabeoption wird an alle importierten Skripte übergeben. Wenn Sie die Wiedergabeoption für ein Skript ändern müssen, bearbeiten Sie nach dem Import den Test.
  5. Klicken Sie auf Next.

    Das Dialogfeld Test Eigenschaften - Testskripte auswählen wird geöffnet.

  6. Wählen Sie im Feld TestPartner Testskripte mit Strg+Klick die zu importierenden Skripte aus.
  7. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: SilkTestPartner Tests
Zugehörige Tasks
Erstellen oder Bearbeiten von Silk TestPartner-Tests


Testen mit Windows Script Host

Windows Script Host (WSH) ist Bestandteil der Windows-Plattform und bietet eine Umgebung zur Arbeit mit Skripts. Wenn ein Skript auf dem Ausführungsserver ausgeführt werden soll, dient WSH als Host. WSH stellt dann die Objekte und Dienste für das Skript sowie die Umgebung zur Skriptausführung zur Verfügung. Neben anderen Aufgaben verwaltet WSH die Sicherheit und ruft die geeignete Skript-Engine auf.

  • Erstellen oder bearbeiten von Windows Script Host (WSH) Tests
    Erstellen oder bearbeiten Sie einen Windows Script Host (WSH) Test für WSH-konforme Testskripts.
  • Unterstützte Skriptsprachen
    Hier werden die von WSH unterstützten Skriptsprachen aufgelistet.
  • WSH-Testeigenschaften
    Hier werden die Eigenschaften beschrieben, die für WSH konfiguriert werden können.
  • Verwenden von Parametern in WSH-Tests
    Hier wird die Verwendung von Parametern in WSH-Tests beschrieben.
  • Anzeigen von Informationen, die vom WSH zurückgegeben wurden
    Hier wird beschrieben, wie die Informationen, die WSH für einen Test zurückgibt, angezeigt werden.
Übergeordnetes Thema: Testtypen
Übergeordnetes Thema: Integration von Test-Automatisierungstools


Erstellen oder bearbeiten von Windows Script Host (WSH) Tests

So erstellen oder bearbeiten Sie einen WSH-Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wenn Sie einen neuen Test erstellen, wählen Sie in der Typ-Liste den Eintrag Windows Script Host Test aus. Klicken Sie auf Weiter.

    Der Dialog Windows Scripting-Testeigenschaften wird geöffnet.

  6. Klicken Sie auf Durchsuchen, und wählen Sie ein Windows Scripting-Testskript aus.
  7. Legen Sie die erforderlichen weiteren Parameter im Feld Parameter fest.
    Anmerkung: Sie können andere Optionen hinzufügen, die an das Skript übergeben werden. Weitere Einzelheiten zu den Schaltern, die verwendet werden können, finden Sie im Thema WSH-Testeigenschaften und in der Windows Script Host-Dokumentation.
  8. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: Testen mit Windows Script Host
Zugehörige Tasks
Ausführen eines Versuchslaufs eines Tests


Unterstützte Skriptsprachen

WSH ist sprachunabhängig für WSH-kompatible Skript-Engines. Die Windows-Plattform unterstützt nativ Skripts, die in Visual Basic mit der Dateierweiterung .vbs und in Java Script mit der Dateierweiterung .js erstellt wurden.

Wenn Sie andere Skriptsprachen verwenden möchten, müssen die entsprechenden Interpreter auf dem Ausführungsserver installiert werden. Installieren Sie beispielsweise einen Perl-Interpreter auf dem Ausführungsserver, dann wird in der WSH-Umgebung die Perl-Skript-Engine für die Dateierweiterung .pls registriert. Wenn Sie nun eine Datei mit der Erweiterung .pls an WSH mit der ausführbaren Datei cscript.exe übergeben, wird der geeignete Interpreter für diesen Dateityp aufgerufen. Daher muss dem WSH-Mandanten (in diesem Fall der Silk Central-Ausführungsserver) das Vorhandensein des Perl-Interpreters nicht bekannt sein.

Anmerkung: Wenn Sie einen Skript-Interpreter installieren (z. B. Active Perl), sollten Sie diesen zunächst lokal auf dem Ausführungsserver durch einen Aufruf des WSH-Befehlszeilenprogramms mit einem Beispielskript testen, bevor Sie ein Skript in Silk Central ausführen. Öffnen Sie dazu auf dem Ausführungsserver eine Eingabeaufforderung, und geben Sie den folgenden Befehl ein: cscript <somescript>. Dabei ist <somescript> ein beliebiges Skript auf dem Ausführungsserver. Dieser Aufruf wird auch von Silk Central durchgeführt, wenn ein WSH-Test auf einem Ausführungsserver ausgeführt wird. Wenn das Skript ohne Fehler ausgeführt wird, dann wurde die Skript-Engine erfolgreich registriert.
Die folgenden Skriptsprachen sind WSH-kompatibel:
Skriptsprache
Dateiendung
Perl
.pls
Python
.py, .pyw
REXX
.REXX
TCL
.tcl
Übergeordnetes Thema: Testen mit Windows Script Host


WSH-Testeigenschaften

Eigenschaft | Beschreibung
Skript | Sie können jede Datei festlegen, für deren Skriptsprache eine Engine registriert ist. Skriptdateien, die der Versionsverwaltung unterliegen, werden automatisch an die Ausführungsserver weitergegeben (vergleichbar mit Testquellen für andere Teststypen).
Parameter Sie können folgende Einstellungen eingeben oder während der Ausführung des Tests an cscript.exe übergeben.
//B
Der Batch-Modus wird aktiviert, und es werden keine Eingabeaufforderungen angezeigt. Mit dieser Option können Sie verhindern, dass ein Skript während der unbeaufsichtigten Ausführung auf eine Benutzereingabe wartet.
//U
Für die Ein-/Ausgabeumleitung von der Konsole sollte Unicode verwendet werden.
//T:nn
Zeitüberschreitung in Sekunden. Mit diesem Wert wird die maximale Ausführungsdauer des Skripts festgelegt (Standardwert = keine Einschränkung). Durch diese Option wird eine übermäßig lange Skriptausführung verhindert. Ein Zeitgeber wird hierzu eingestellt. Wenn die Ausführungsdauer den angegebenen Wert überschreitet, wird die Skript-Engine durch Aufruf der Methode IActiveScript::InterruptThread abgebrochen. Es ist eine Rückrufmöglichkeit vorgesehen. Wenn eine Zeitüberschreitung auftritt, wird die Funktion OnTimeOut aufgerufen, um die Nachbereitung zu ermöglichen. Dadurch können zwar Endlosschleifen entstehen, jedoch ist die Verwendung dieser Option dennoch zu empfehlen.
//logo
Während der Ausführung wird ein Logo angezeigt, das am Anfang der Datei log.txt angegeben ist. Dies ist die Standardeinstellung.
//nologo
Während der Ausführung wird kein Logo angezeigt.
//D
Der Debugging-Modus wird aktiviert.
//E:engine
Das Skript wird mit der angegebenen Engine ausgeführt.
//Job:xxxx
Der angegebene WSH-Auftrag wird ausgeführt.
//X
Das Skript wird im Debugger ausgeführt.
Übergeordnetes Thema: Testen mit Windows Script Host


Verwenden von Parametern in WSH-Tests

Bei Parametern, die für eine WSH-Test definiert wurden, wird automatisch der Befehlszeile ein Name-Wert-Paar als zusätzliches Argument hinzugefügt, und die Parameter werden als Umgebungsvariablen für den aufgerufenen Prozess festgelegt. Dies ermöglicht es Ihnen, im WSH-Skript auf alle für die Test definierten Parameter zuzugreifen.

Eine Test ist mit myscript.js als Skript und //B als Schalter definiert. Der Test erfordert den Parameter IPAddress mit dem Wert 192.168.1.5 und den weiteren Parameter Port mit dem Wert 1492. Die sich für die WSH-Ausführung in diesem Beispiel ergebende Befehlszeile lautet:

csript myscript.js //B IPAddress=192.168.1.5 Port=1492
Übergeordnetes Thema: Testen mit Windows Script Host


Anzeigen von Informationen, die vom WSH zurückgegeben wurden

Das WSH-Skript muss für das Ausführungsergebnis die Datei output.xml im aktuellen Arbeitsverzeichnis des WSH-Tests erzeugen. Alle in diesem Verzeichnis befindlichen Dateien werden in der Datenbank gespeichert und können über die Dateiliste der Testausführung heruntergeladen werden. Dateien können von der Speicherung ausgenommen werden, indem ihre Namenserweiterungen im Projektbereich mit der Option zum Ignorieren der Namenserweiterungen in Ergebnissen angegeben werden.

Anmerkung: Das Arbeitsverzeichnis wird während der Ausführung eines WSH-Skripts dynamisch erstellt. Geben Sie beim Erstellen der Datei keinen absoluten Pfad an. Mit einem relativen Pfad kann auf das aktuelle Arbeitsverzeichnis verwiesen werden.

Alle von einem Skript an die WSH-Standardausgabe gesendeten Informationen werden zusätzlich in die Datei log.txt im aktuellen Arbeitsverzeichnis eingetragen. Diese Datei wird in der Datenbank gespeichert und kann über die Dateiliste der Testausführung angezeigt werden.

Das folgende Beispiel zeigt, wie Protokollinformationen aus einem Skript gedruckt werden:

 WScript.Echo "This info will be written to the log.txt file"

Die XML-Struktur der Datei output.xml beginnt mit dem Element ResultElement, das ein Attribut namens TestItem definiert. Dieses Attribut legt den Namen von ResultElement fest.

ResultElement muss ein Element mit dem Namen ErrorCount enthalten. Optional können ein WarningCount-Element und eine Liste von Incident-Elementen vorhanden sein.

Die Elemente ErrorCount und WarningCount müssen den Wert Null oder eine positive Zahl enthalten. Die Elemente ErrorCount und WarningCount des ResultElement-Elements der obersten Ebene werden zur Auswertung der Erfolgsbedingungen verwendet, um zu ermitteln, ob der Test bestanden wurde. Die XML-Datei kann weitere Elemente enthalten, die in der Benutzeroberfläche von Silk Central nicht angezeigt werden. Die Datei output.xml wird jedoch in der Datenbank gespeichert und kann über die Dateiliste der Testausführung angezeigt werden.

Die Incident-Elemente entsprechen Ereignissen, die während der Ausführung des WSH-Tests aufgetreten sind. Message und Severity werden in der Meldungsliste der Testausführungen in der Benutzeroberfläche von Silk Central angezeigt. Ein Incident-Element muss ein Message- und ein Severity-Element enthalten.

Das Element Severity muss einen der folgenden Werte enthalten:

  • Info
  • Warnung
  • Error (oder Exception)
  • Failure

Sie können weitere Informationen in der Ergebnisdatei speichern. Das ResultElement kann eine beliebige Anzahl von sub-ResultElements enthalten, sodass Informationen auf einfache Weise gruppiert werden können. Die Unterelemente machen die Ergebnisdatei übersichtlicher. Zur Kompatibilität mit JUnit- und NUnit-Tests sollte ResultElement-Elementen der Name "TestSuite" oder "Test" zugewiesen werden.

ResultElement kann die folgenden zusätzlichen Elemente enthalten:

  • FailureCount (Fehleranzahl)
  • RunCount (wenn ein Test mehrmals ausgeführt wird)
  • Timer (z. B. für die Testdauer)
  • WasSuccess (Kompatibilität mit NUnit-Ergebnisdateien)
  • Asserts (Kompatibilität mit NUnit-Ergebnisdateien)

Das Element Incident kann eine Liste von Detail-Elementen enthalten.

Das Element Detail enthält detaillierte Informationen zu einem Incident-Element. Es muss die Elemente TestName und Info definieren. TestName liefert Informationen dazu, wo Incident aufgetreten ist. Das Element Info enthält Informationen zum Incident-Element (z. B. Stacktrace).

Anmerkung: Bis zu Silk Central-Version 8.1 musste der Wert der Elemente Message und Info URL-kodiert sein (ISO-8859-1). Seit Version 8.1.1 ist die URL-Kodierung nicht mehr zulässig.

Beispielergebnisdatei

<ResultElement TestItem="WshOutputTest">
  <ErrorCount>1</ErrorCount>
  <WarningCount>1</WarningCount>
  <Incident>
    <Message>some unexpected result</Message>
    <Severity>Error</Severity>
    <Detail>
      <TestName>function main()</TestName>
      <Info>some additional info; eg. stacktrace</Info>
    </Detail>
  </Incident>
  <Incident>
    <Message>some warning message</Message>
    <Severity>Warning</Severity>
    <Detail>
      <TestName>function main()</TestName>
      <Info>some additional info; eg. stacktrace</Info>
    </Detail>
  </Incident>
</ResultElement>

Java Script-Beispiel

Mit dem folgenden Skript wurde die Beispieldatei erzeugt. Wenn Sie das Skript ausführen möchten, speichern Sie es mit der Dateierweiterung .js.

function dumpOutput(dumpFile)
{
  dumpFile.WriteLine("<ResultElement TestItem=\"WshOutputTest\">");
  dumpFile.WriteLine("  <ErrorCount>1</ErrorCount>");
  dumpFile.WriteLine("  <WarningCount>1</WarningCount>");
    dumpFile.WriteLine("  <Incident>");
    dumpFile.WriteLine("    <Message>some unexpected result</Message>");
    dumpFile.WriteLine("    <Severity>Error</Severity>");
    dumpFile.WriteLine("    <Detail>");
    dumpFile.WriteLine("      <TestName>function main()</TestName>");
    dumpFile.WriteLine("      <Info>some additional info; eg. stacktrace</Info>");
    dumpFile.WriteLine("    </Detail>");
    dumpFile.WriteLine("  </Incident>");
    dumpFile.WriteLine("  <Incident>");
    dumpFile.WriteLine("    <Message>some warning message</Message>");
    dumpFile.WriteLine("    <Severity>Warning</Severity>");
    dumpFile.WriteLine("    <Detail>");
    dumpFile.WriteLine("      <TestName>function main()</TestName>");
    dumpFile.WriteLine("      <Info>some additional info; eg. stacktrace</Info>");
    dumpFile.WriteLine("    </Detail>");
    dumpFile.WriteLine("  </Incident>");
  dumpFile.WriteLine("</ResultElement>");
}

function main()
{
  var outFile;
  var fso;
  fso = WScript.CreateObject("Scripting.FileSystemObject");
  outFile = fso.CreateTextFile("output.xml", true, true);
  outFile.WriteLine("<?xml version=\"1.0\" encoding=\"UTF-16\"?>");

  dumpOutput(outFile);
  outFile.Close();
  WScript.Echo("Test is completed");
}

main();
WScript.Quit(0);

Visual Basic-Skriptbeispiel

Das folgende Visual Basic-Skript generiert zudem die Beispielergebnisdatei und speichert sie als Output.xml. Wenn Sie das Skript ausführen möchten, speichern Sie es mit der Dateierweiterung .vbs.

WScript.Echo "starting"

Dim outFile
Dim errCnt
Dim warningCnt

outFile = "output.xml"
errCnt = 1 ' retrieve that from your test results
warningCnt = 1 ' retrieve that from your test results

Set FSO = CreateObject("Scripting.FileSystemObject")
Set oTX = FSO.OpenTextFile(outFile, 2, True, -1) ' args: file, 8=append/2=overwrite, create, ASCII

oTX.WriteLine("<?xml version=""1.0"" encoding=""UTF-16""?>")
oTX.WriteLine("<ResultElement TestItem=""PerlTest"">")
oTX.WriteLine("  <ErrorCount>" & errCnt & "</ErrorCount>")
oTX.WriteLine("  <WarningCount>" & warningCnt & "</WarningCount>")
oTX.WriteLine("  <Incident>")
oTX.WriteLine("    <Message>some unexpected result</Message>")
oTX.WriteLine("    <Severity>Error</Severity>")
oTX.WriteLine("    <Detail>")
oTX.WriteLine("      <TestName>function main()</TestName>")
oTX.WriteLine("      <Info>some additional info; eg. stacktrace</Info>")
oTX.WriteLine("    </Detail>")
oTX.WriteLine("  </Incident>")
oTX.WriteLine("  <Incident>")
oTX.WriteLine("    <Message>some warning message</Message>")
oTX.WriteLine("    <Severity>Warning</Severity>")
oTX.WriteLine("    <Detail>")
oTX.WriteLine("      <TestName>function main()</TestName>")
oTX.WriteLine("      <Info>some additional info; eg. stacktrace</Info>")
oTX.WriteLine("    </Detail>")
oTX.WriteLine("  </Incident>")
oTX.WriteLine("</ResultElement>")
Übergeordnetes Thema: Testen mit Windows Script Host


Gemeinsam verwendbare Testobjekte

Gemeinsam verwendbare Testobjekte und deren zugeordnete Anforderungen, welche in einem Repository-Projekt verwaltet werden, können in Zielprojekten wiederverwendet werden.

Wenn Ihr Projekt so konfiguriert ist, dass es Objekte eines bestimmten Repository-Projekts verwendet (siehe Hinzufügen von Projekten), können Sie diese Objekte wiederverwenden, indem Sie sie im Zielprojekt einfügen.

  • Gemeinsame Verwendung von Testobjekten aus Repository-Projekten
    Verwalten Sie gängige Testobjekte in einem Repository-Projekt und verwenden diese in anderen Projekten wieder.
  • Versionsverwaltung von gemeinsam verwendbaren Tests
    Aktualisieren Sie Ihre Tests auf die neueste Version des Tests im Repository-Projekt, oder befördern Sie Ihre Teständerungen in das Repository-Projekt.
Übergeordnetes Thema: Verwalten von Tests


Gemeinsame Verwendung von Testobjekten aus Repository-Projekten

Verwalten Sie gängige Testobjekte in einem Repository-Projekt und verwenden diese in anderen Projekten wieder.
Wenn Ihr Projekt so konfiguriert ist, dass es Objekte eines bestimmten Repository-Projekts verwendet (siehe Hinzufügen von Projekten), können Sie diese Objekte wiederverwenden, indem Sie sie im Zielprojekt einfügen.
So verwenden Sie Testobjekte aus einem Repository-Projekt:
  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Repository-Projekt aus.
  3. Klicken Sie im Menü auf Tests > Detailansicht.
  4. Klicken Sie auf Kopieren, um das Element in die Zwischenablage zu kopieren.
  5. Klicken Sie im Menü auf Projekte > Projektliste.
  6. Wählen Sie das Zielprojekt aus.
  7. Wählen Sie den Zielordner und/oder den Zielcontainer aus.
  8. Klicken Sie auf Einfügen. In den Testeigenschaften des wiederverwendeten Tests wird in Test-Referenz eine Verknüpfung zum Original angezeigt.
Anmerkung: Beim Kopieren eines Tests von einem Projekt in das Repository-Projekt wird auch eine Verknüpfung zum Test im Repository-Projekt erstellt, und der Test steht dann anderen Projekten zur Wiederverwendung zur Verfügung. Wenn ein Test mehrfach kopiert wird, zeigt die Verknüpfung auf die zuletzt angelegte Kopie.
Beachten Sie bei der Verwendung von Testobjekten aus einem Repository-Projekt Folgendes:
  • Das verwendende Projekt muss zur Verwendung von Objekten aus dem Repository-Projekt konfiguriert sein, sonst wird beim Kopieren und Einfügen keine Referenz zum Original erstellt.
  • Objekte können nur in einen bestehenden Container eingefügt werden.
  • Damit auch zugeordnete Anforderungen erhalten bleiben, muss im verwendenden Projekt das selbe Anforderungsverwaltungssystem konfiguriert sein wie im Repository-Projekt.
  • Datengetriebene Unterelemente, Testpaket-Unterelemente und verknüpfte Container können nicht wiederverwendet werden.
  • Geerbte Testeigenschaften, Parameter und Attribute werden in wiederverwendeten Tests nicht berücksichtigt. Beachten Sie, dass beim Übernehmen von Änderungen aus dem Originalobjekt Testeigenschaften, Parameter und Attribute verschwinden können, wenn Vererbung verwendet wird.
  • Zugeordnete Fehler werden nicht in wiederverwendete Tests kopiert.
  • Wenn Sie Testattribute verwenden, müssen diese den gleichen Namen und Typ in beiden Projekten haben.
  • Beim Kopieren eines Projekts und beim Erstellen einer Baseline bleiben die Referenzen zum Repository-Projekt erhalten. Beim Exportieren eines Projekts werden sie jedoch gelöscht.
  • Die Massen-Export/Aktualisierungs-Schnittstelle und die Webdienste berücksichtigen die Verknüpfungen zu den Originalen noch nicht.
  • Es können auch Ordner kopiert und eingefügt werden, inklusive deren vollständigen Hierarchie.
Übergeordnetes Thema: Gemeinsam verwendbare Testobjekte
Übergeordnetes Thema: Arbeiten mit der Testhierarchie
Zugehörige Tasks
Hinzufügen von Projekten
Bearbeiten von Projekten oder Projekt-Baselines


Versionsverwaltung von gemeinsam verwendbaren Tests

Das Verwalten von gängigen Tests in einem zentralen Repository-Projekt, und diese Tests in anderen Projekten wiederzuverwenden, erspart Ihnen die mehrfache Testverwaltung in mehreren Projekten. Sobald im Repository-Projekt eine neue Version eines Tests erstellt wird, wird dieser Test als Aktualisiert markiert (mit einem blauen, nach oben zeigenden Pfeil). Im Projekt in dem der Test wiederverwendet wird, klicken Sie mit der rechten Maustaste darauf und wählen Sie Änderungen in gemeinsam verwendbaren Tests > Änderungen übernehmen um den Test auf die neueste Version zu aktualisieren, oder wählen Sie Änderungen nicht übernehmen um die gegenwärtige Version zu belassen und die Markierung aufzuheben. Wenn im Repository-Projekt wieder eine neue Version erstellt wird, wird der Test erneut markiert werden.

Möglicherweise kommen Sie auch in die Situation, wo Sie einen wiederverwendeten Test im verwendenden Projekt aktualisieren, und Sie diese Änderungen auf den Originaltest im Repository-Projekt befördern möchten. Klicken Sie dazu auf der Registerkarte Historie auf Änderungen auf den gemeinsam verwendbaren Test anwenden Ihres Tests im verwendenden Projekt. Dadurch wird im verwendenden Projekt eine neue Testversion erstellt, und im Repository-Projekt wird ein Wiederherstellungspunkt sowie eine neue Version des gemeinsam verwendbaren Tests mit den aktuellen Änderungen erstellt. Andere Projekte, welche diesen Test wiederverwenden, erhalten eine Aktualisierungsmeldung.

Übergeordnetes Thema: Gemeinsam verwendbare Testobjekte
Zugehörige Konzepte
Versionen
Zugehörige Tasks
Erstellen einer Version
Anzeigen einer Version
Zurücksetzen auf eine frühere Version


Bearbeiten von Tests

So bearbeiten Sie einen Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test oder das Testpaket aus, den bzw. das Sie bearbeiten möchten.
  3. Klicken Sie in der Symbolleiste auf [image] (Bearbeiten).

    Sie können auch auf die Registerkarte Eigenschaften und dann auf Bearbeiten klicken oder mit der rechten Maustaste auf den Test oder das Testpaket klicken und Bearbeiten auswählen.

    Das Dialogfeld Test bearbeiten wird angezeigt.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  4. Bearbeiten Sie den Namen und die Beschreibung des ausgewählten Tests. Wenn es sich dabei um ein Testpaket handelt, ist das Kontrollkästchen Paketstruktur anhand des Ergebnisses aktualisieren verfügbar. Aktivieren Sie das Kontrollkästchen Paketstruktur anhand des Ergebnisses aktualisieren, wenn die Struktur des Testpakets den Ergebnissen der letzten Testsuiteausführung entsprechend aktualisiert werden soll.
  5. Konfigurieren Sie die Eigenschaften des Tests oder des Testpakets gemäß dem Testtyp, wie unter Konfigurieren von Testeigenschaften beschrieben.
Übergeordnetes Thema: Verwalten von Tests
Zugehörige Konzepte
Konfigurieren von Testeigenschaften
Testpakete


Drucken von Tests

So drucken Sie Tests:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Verwenden Sie Strg+Klick oder Umschalttaste+Klick, um die zu druckenden Tests auszuwählen.
  3. Klicken Sie mit der rechten Maustaste auf die Auswahl, und wählen Sie Tests drucken. Der Dialog Test-Details wird geöffnet.
  4. Klicken Sie auf Drucken oder Download als PDF.
Tipp: Sie können in der Hierarchie Tests auch Tests oder Ordner auswählen und Tests drucken wählen.
Übergeordnetes Thema: Verwalten von Tests


Testläufe (Seite)

Tests > Detailansicht > <Test> > Testläufe

Die Seite Testläufe ist in der Detailansicht für Testknoten verfügbar und zeigt die Ausführungsergebnisse der ausgewählten Tests an.

Die Tabellendarstellung auf der Seite Testläufe erleichtert das Filtern, Sortieren und Gruppieren von Testläufen.

Für jeden Testlauf werden folgende Spalten auf der Seite angezeigt:

Spalte | Beschreibung
Aktionen Aktionen, die Sie mit dem Testlauf ausführen können.
Neuer Fehler
Klicken Sie darauf, um den Dialog Neuer Fehler zu öffnen und einen neuen Fehler für den Test anzulegen.
Vorhandene Fehler zuweisen
Ermöglicht Ihnen, dem Test Fehler aus einem externen Fehlerverfolgungssystem zuzuordnen.
Status | Der Status der Testausführung. Bei Tests, die Bestandteil einer laufenden Testsuite sind, wird der Status entsprechend dem aktuellen Status des Testlaufs aktualisiert. Wenn der aktuelle Testlauf abgebrochen wird, wird der Status auf den Status vor dem Testlauf zurückgesetzt.
Statusursache | Die Ursache, weshalb ein bestimmter Testlauf den Status Bestanden, Fehlgeschlagen oder Nicht ausgeführt hat.
Testlauf-ID | Die Kennung des Testlaufs. Klicken Sie darauf, um den Dialog Ergebnisse des Testlaufs zu öffnen. Wenn der Test ausgeführt wird, klicken Sie darauf, um die Details der Ausführung anzuzeigen.
Testlauf-Typ | Die Spalte Testlauf-Typ zeigt den Testtyp für jeden Testlauf an. Der Testtyp kann sich zwischen zwei Testläufen ändern, zum Beispiel, wenn Sie einen manuellen Test in einen automatisierten umwandeln.
Startzeit | Der Zeitpunkt, zu dem der Testlauf gestartet wurde. Wenn es sich bei dem Test um einen manuellen Test handelt und dieser aktuell ausgeführt wird, fügt Silk Central dem Datum und der Uhrzeit (in Ausführung) hinzu.
Dauer | Die Dauer des Testlaufs im Format h/mm/ss.
Testsuite | Der Name der zugeordneten Testspezifikationenuite bzw. der Probeläufe, wenn die Ausführung ein Probelauf war oder die Ergebnisse hochgeladen wurden. Klicken Sie hier, um die Testsuite zu öffnen.
Ausgeführt von | Der Name des Ausführungsservers, auf dem der Test ausgeführt wurde.
Gefundene Fehler | Zeigt die Anzahl der Fehler an, die diesem Testlauf zugeordnet sind. Wenn dem Testlauf keine Fehler zugeordnet sind, ist die Spalte leer. Klicken Sie auf den Link, um die Seite Fehler des Bereichs Tests > Detailansicht für den Fehler anzuzeigen.
Fehler | Die Anzahl der Fehler, die während der Ausführung aufgetreten sind.
Warnungen | Die Anzahl der Warnungen, die während der Ausführung aufgetreten sind.
Version | Die getestete Version.
Build | Die getestete Build-Nummer.
Übergeordneter Knoten | Die Konfigurationssuite, der Ordner oder der Testzyklus, in dem die Testsuite ausgeführt wird. Klicken Sie die gewünschte Suite oder den Ordner in der Testsuitehierarchie an. Wenn die Testsuite nicht in einer Konfigurationssuite oder in einem Ordner enthalten ist, wird nichts angezeigt.
Testlauf-Kommentar | Bei Silk Performer-Testläufen verwendet Silk Performer diese Spalte, um beim Hochladen der Ergebnisse Informationen zum Testlauf hinzuzufügen. Bei allen anderen Testläufen können Sie in diese Spalte Informationen zum Testlauf einfügen.

Wählen Sie mit den Tasten Strg oder Umschalt zwei oder mehr Testläufe aus, um sie zu vergleichen. Klicken Sie Ihre Auswahl mit der rechten Maustaste an, und wählen Sie Ergebnisse automatisierter Tests vergleichen oder Berichte > Vergleich der Testläufe.

Übergeordnetes Thema: Verwalten von Tests
Zugehörige Konzepte
Vergleichsbericht zu Testläufen
Zugehörige Tasks
Testergebnisse mehrerer Testläufe vergleichen
Zuordnen von vorhandenen Fehlern
Zugehörige Verweise
Ergebnisse des Testlaufs


Fehler (Seite)

Tests > Detailansicht > <Testelement> > Fehler

Auf der Seite Fehler können Fehler für den ausgewählten Test, den ausgewählten Container oder den ausgewählten Ordner eingegeben und überwacht werden.

Neuer Fehler
Klicken Sie hier, um dem ausgewählten Test neue Fehler zuzuordnen. Diese Schaltfläche wird nur angezeigt, wenn es sich beim aktuell ausgewählten Objekt um einen Test handelt.
Vorhandene Fehler zuweisen
Klicken Sie hier, um dem ausgewählten Test Fehler aus einem externen Fehlerverfolgungssystem zuzuordnen. Diese Schaltfläche wird nur angezeigt, wenn es sich beim aktuell ausgewählten Objekt um einen Test handelt.
Fehlerstatus aktualisieren
Klicken Sie hier, um Fehlerstatuswerte zu aktualisieren.

Für jeden Fehler werden folgende Spalten auf der Seite angezeigt:

Spalte | Beschreibung
Aktionen | Die Aktionen, die mit dem Fehler ausgeführt werden können. Klicken Sie auf [image] , um den Fehler zu löschen. Externe Fehler werden nicht gelöscht.
Fehler-ID | Die dem Fehler automatisch zugewiesene ID. Klicken Sie hier, um den Fehler zu bearbeiten.
Zugeordneter Test | Der dem Fehler zugeordnete Test. Diese Spalte wird nur angezeigt, wenn es sich bei dem aktuell ausgewählten Objekt um einen Container oder Ordner handelt.
Zusammenfassung | Die Kurzbezeichnung des Fehlers.
Status | Der Status des Fehlers.
Externe ID | Die Angabe, ob der Fehler in einem externen Fehlerverfolgungssystem überwacht wird. Klicken Sie auf die Nummer eines externen Fehlers, um das externe Fehlerverfolgungssystem direkt aufzurufen.
Priorität | Die Priorität des Fehlers, wie sie im externen Fehlerverfolgungssystem definiert wurde. Diese Funktionalität wird von den folgenden Fehlerverfolgungssystemen unterstützt: Atlassian JIRA, Bugzilla, Silk Central Issue Manager, und StarTeam.
Ausführung des Tests | Die ID des Testlaufs, dem der Fehler zugeordnet ist. Klicken Sie auf die ID, um die Seite Details des Dialogfeldes Ergebnisse des Testlaufs des Bereichs Testausführung zu öffnen.
Erstellt am | Das Datum, an dem der Fehler erstellt wurde.
Erstellt von | Der Name des Benutzers, der den Fehler erstellt hat.
Profil | Der unter Silk Central > Einstellungen > Fehlerverfolgung definierte Name des Fehlerverfolgungsprofils.
Übergeordnetes Thema: Verwalten von Tests
Zugehörige Konzepte
Fehler
Issue Manager


Versionen

Versionen können für gemeinsam verwendbare Objekte (Testschritte und Schlüsselwörter) sowie für Tests erstellt werden. Eine Version ist eine Revision eines Elements in einem bestimmten Status. Datenmengen sowie geerbte Testeigenschaften, Parameter und Attribute werden in Testversionen nicht gespeichert.

Sie können Versionen von gemeinsam verwendbaren Objekten und Tests manuell erstellen oder frühere Versionen wiederherstellen. Alle Versionen eines gemeinsam verwendbaren Objekts oder eines Tests werden auf der Seite Verlauf des Elements aufgeführt. Wenn Sie ein Projekt kopieren, werden auch die Versionen kopiert. Wenn Sie mit gemeinsam verwendbaren Tests arbeiten, sehen Sie sich auch das Thema Versionsverwaltung von gemeinsam verwendbaren Tests an.

  • Erstellen einer Version
    Sie können eine Version eines gemeinsam verwendbaren Objekts oder eines Tests erstellen, um künftige Änderungen rückgängig machen zu können.
  • Anzeigen einer Version
    Zeigen Sie die Details einer Version an, um zu überprüfen, ob die Version Ihren Testanforderungen entspricht.
  • Vergleichen von Versionen
    Wenn Sie die Unterschiede zwischen zwei Versionen eines gemeinsam verwendbaren Objekts oder eines Tests anzeigen möchten, müssen Sie die Versionen vergleichen.
  • Zurücksetzen auf eine frühere Version
    Wenn Sie Änderungen an einem gemeinsam verwendbaren Objekt oder an einem Test rückgängig machen möchten, können Sie das Objekt auf eine frühere Version zurücksetzen.
  • Anzeigen der letzten Änderungen
    Zeigen Sie die letzten Änderungen an Tests an.
  • Anzeigen der Historie eines Tests
    Hier wird beschrieben, wie die Historie eines Tests angezeigt werden kann.
  • Historie (Seite)
    Hier wird die Änderungshistorie des ausgewählten Tests, Containers, Ordners oder Projekts angezeigt.
  • Bibliotheksverlauf (Seite)
    Hier wird der Verlauf der ausgewählten gemeinsam verwendbaren Objekte angezeigt.
Übergeordnetes Thema: Verwalten von Tests
Übergeordnetes Thema: Bibliotheken
Zugehörige Konzepte
Versionsverwaltung von gemeinsam verwendbaren Tests
Zugehörige Tasks
Erstellen einer Version
Anzeigen einer Version
Zurücksetzen auf eine frühere Version


Erstellen einer Version

Um Änderungen rückgängig machen zu können, die auf ein gemeinsam verwendbares Objekt oder einen Test angewendet werden sollen, erstellen Sie eine Version des Elements.

So erstellen Sie eine Version eines gemeinsam verwendbaren Objekts oder eines Tests:

  1. Klicken Sie für ein gemeinsames Objekt im Menü auf Tests > Bibliotheken. Klicken Sie für Tests im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Bibliothekshierarchie das gemeinsam verwendbare Objekt bzw. den Test in der Hierarchie Test aus.
  3. Klicken Sie in der Symbolleiste auf Version erstellen. Dieser Vorgang ist nur zulässig, wenn das gemeinsam verwendbare Objekt oder der Test geändert wurde. Der Dialog Version erstellen wird angezeigt.
  4. Optional: Geben Sie im Textfeld Kommentar einen Kommentar zur Version ein.
  5. Klicken Sie auf OK. Die neue Version wird auf der Seite Verlauf angezeigt.
Übergeordnetes Thema: Versionen
Zugehörige Konzepte
Versionsverwaltung von gemeinsam verwendbaren Tests
Versionen
Zugehörige Tasks
Anzeigen einer Version
Zurücksetzen auf eine frühere Version


Anzeigen einer Version

Um anzuzeigen, ob eine bestimmte Version eines gemeinsam verwendbaren Objekts oder eines Tests Ihren Testanforderungen entspricht, sehen Sie in den Versionsdetails nach.

So zeigen Sie die Versionsdetails eines gemeinsam verwendbaren Objekts oder eines Tests an:

  1. Klicken Sie für ein gemeinsames Objekt im Menü auf Tests > Bibliotheken. Klicken Sie für Tests im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Bibliothekshierarchie das gemeinsam verwendbare Objekt bzw. den Test in der Hierarchie Test aus.
  3. Klicken Sie auf die Registerkarte Verlauf.
  4. Klicken Sie mit der rechten Maustaste auf die Version, für die die Details angezeigt werden sollen.
  5. Klicken Sie auf Version <ID> anzeigen.
  6. Das Dialogfeld Version anzeigen wird angezeigt. Wenn die Version Anhänge enthält, können Sie die Anhänge anzeigen, indem Sie in der Spalte Anhänge im Abschnitt Testschritte auf deren Nummer klicken.
    Anmerkung: Mit den Pfeilen können Sie die Versionsnummer ändern und zusätzliche Versionen anzeigen.
Übergeordnetes Thema: Versionen
Zugehörige Konzepte
Versionsverwaltung von gemeinsam verwendbaren Tests
Versionen
Zugehörige Tasks
Erstellen einer Version
Zurücksetzen auf eine frühere Version


Vergleichen von Versionen

Wenn Sie die Unterschiede zwischen zwei Versionen eines gemeinsam verwendbaren Objekts oder eines Tests anzeigen möchten, müssen Sie die Versionen vergleichen.

So vergleichen Sie zwei Versionen eines gemeinsam verwendbaren Objekts oder eines Tests:

  1. Klicken Sie für ein gemeinsames Objekt im Menü auf Tests > Bibliotheken. Klicken Sie für Tests im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Bibliothekshierarchie das gemeinsam verwendbare Objekt bzw. den Test in der Hierarchie Test aus.
  3. Klicken Sie auf die Registerkarte Verlauf.
  4. Wählen Sie die zwei Versionen, die verglichen werden sollen, durch Strg+Klick aus.
  5. Klicken Sie mit der rechten Maustaste auf die Auswahl.
  6. Wählen Sie Version <x> und <y> vergleichen. Das Dialogfeld Versionen vergleichen wird mit einer Übersicht zu allen hinzugefügten, geänderten und entfernten Inhalten geöffnet.
    Anmerkung: Mithilfe der Pfeiltasten können Sie die Versionsnummern ändern und weitere Versionen vergleichen.
Übergeordnetes Thema: Versionen


Zurücksetzen auf eine frühere Version

Wenn Sie Änderungen an einem gemeinsam verwendbaren Objekt oder an einem Test rückgängig machen möchten, können Sie das Objekt auf eine frühere Version zurücksetzen. Beachten Sie beim Zurücksetzen auf eine frühere Version die folgenden Spezialfälle:
  • Hat sich der Wert eines geerbten Attributs im Vergleich zur aktuellen Version geändert, wird der aktuelle Wert von der zurückgesetzten Version geerbt.
  • Hat sich der Typ eines Attributs im Vergleich zur aktuellen Version geändert, wird das Attribut in der zurückgesetzten Version ignoriert.
  • Existiert der Wert eines Attributs vom Typ „Liste“ in der aktuellen Version nicht mehr, wird der ursprüngliche Wert zum Attribut wieder hinzugefügt, und in der zurückgesetzten Version verwendet.

So setzen Sie ein gemeinsam verwendbares Objekt oder einen Test auf eine frühere Version zurück:

  1. Klicken Sie für ein gemeinsames Objekt im Menü auf Tests > Bibliotheken. Klicken Sie für Tests im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Bibliothekshierarchie das gemeinsam verwendbare Objekt bzw. den Test in der Hierarchie Test aus.
  3. Klicken Sie auf die Registerkarte Verlauf.
  4. Klicken Sie mit der rechten Maustaste auf die Version, auf die das gemeinsam verwendbare Objekt oder der Test zurückgesetzt werden soll.
  5. Klicken Sie auf Version <ID> wiederherstellen.
  6. Das gemeinsam verwendbare Objekte oder der Test wird auf die ausgewählte Version zurückgesetzt, und auf der Seite Verlauf wird eine neue Version erstellt. Anhänge und Datensätze werden für Tests nicht zurückgesetzt.
Übergeordnetes Thema: Versionen
Zugehörige Konzepte
Versionsverwaltung von gemeinsam verwendbaren Tests
Versionen
Zugehörige Tasks
Erstellen einer Version
Anzeigen einer Version


Anzeigen der letzten Änderungen

So zeigen Sie die letzten Änderungen an Tests an:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie auf [image] Änderungen anzeigen, um alle Testselemente herauszufiltern, die seit der letzten Änderungsbestätigung keine Änderungen erfahren haben.
    Anmerkung: Der Filter für letzte Änderungen ist in der Dropdown-Liste Filter standardmäßig ausgewählt.
  3. Wenn Sie die Änderungen überprüft haben, können Sie sie mit Bestätigen akzeptieren. Nach dem Klicken auf Bestätigen wird der Filter Letzte Änderungen zurückgesetzt.
  4. Klicken Sie auf [image] Alles anzeigen, um den Filter aufzuheben und alle Tests anzuzeigen.
Anmerkung: Alle Testsänderungen werden mit einem Zeitstempel in die Testhistorie eingetragen.
Übergeordnetes Thema: Versionen
Zugehörige Konzepte
Letzte Änderungen


Anzeigen der Historie eines Tests

Silk Central bietet eine vollständige Historie aller Änderungen, die an den Tests vorgenommen wurden. Die Informationen in der Historie sind schreibgeschützt und können nicht geändert oder dauerhaft gelöscht werden.

So verfolgen Sie die Historie eines Testelements:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test aus der Testhierarchie.
  3. Klicken Sie auf die Registerkarte Verlauf.
Die Eigenschaften des Tests werden in einer Tabelle angezeigt.
Übergeordnetes Thema: Versionen


Historie (Seite)

Tests > Detailansicht > <Testelement> > Historie

Auf der Seite Historie werden die Revisionsinformationen des ausgewählten Tests, Containers, Ordners oder Projekts angezeigt. Sie enthält außerdem einen Eintrag für jede Projekt-Baseline, die das ausgewählte Element beinhaltet, einschließlich Links zur Baseline und dem entsprechenden Element in der Baseline. Falls das ausgewählte Element selbst im Rahmen einer Projekt-Baseline erstellt wurde, beinhaltet der erste Eintrag auf der Seite Historie Links zum Originalprojekt und dem entsprechenden, darin enthaltenen Element. Über die Links können nur aktive Projekte oder Baselines aufgerufen werden. Weitere Informationen zu Projekt-Baselines finden Sie in den Themen Verwaltung in dieser Hilfe.

Die Seite Historie enthält noch zusätzlich einen Eintrag für jede Version des ausgewählten Tests, sodass Sie neue Versionen erstellen, auf eine frühere Version zurücksetzen und zwei ausgewählte Versionen miteinander vergleichen können.

Für jede Änderung werden folgende Spalten auf der Seite angezeigt:

Spalte | Beschreibung
Aktionen | Nur für Versionseinträge. Folgende Aktionen können ausgeführt werden: Version anzeigen, Version wiederherstellen und Version löschen.
Version | Nur für Versionseinträge. Die Version des Tests.
Kommentar | Ein Kommentar zu den Änderungen.
Erstellt am | Datum und Uhrzeit der Änderung.
Erstellt von | Benutzer, der die Änderung vorgenommen hat.
Anmerkung: Wenn die Seite mehr Elemente enthält, als gleichzeitig ohne Verschlechterung der Reaktionszeit angezeigt werden können, werden die Elemente stufenweise angezeigt. Verwenden Sie die Navigationsleiste unten auf der Seite, um die Elemente zu durchsuchen.
Übergeordnetes Thema: Versionen
Zugehörige Konzepte
Versionen


Konfigurieren von Testeigenschaften

Konfigurieren Sie Testeigenschaften wie Attribute, Parameter, Anhänge und Erfolgsbedingungen.
  • Testeigenschaften
    Hier werden alle Eigenschaften und relevanten Informationen für den ausgewählten Test, den ausgewählten Ordner, das ausgewählte Testpaket oder den ausgewählten Container aufgeführt.
  • Testattribute
    Attribute sind frei erstellbare Merkmale, die auf Tests angewendet werden können. Sie können den Bereich Tests nach Tests mit einem bestimmten Attribut filtern und alle diese Tests zu Testsuiten zuordnen. Beispielsweise könnte ein Plattformattribut für die Produktkomponenten und ein Prioritätsattribut für die Tests erstellt werden.
  • Testparameter
    Parameter sind beliebig konfigurierbare Eingabewerte, die verschiedenen Testtypen auf unterschiedliche Weise zugewiesen werden können. Sie ermöglichen die Angabe von Testdaten bei der Definition von Tests.
  • Testanhänge
    Im Bereich Anhänge werden die Dateien und Links angezeigt, die als Anhänge für den ausgewählte Container, Ordner oder Test hochgeladen wurden.
  • Datengetriebene Tests
    Hier wird die Arbeit mit datengetriebenen Tests beschrieben.
  • Erfolgsbedingungen
    Hier wird beschrieben, wie Sie ermitteln können, ob ein Test erfolgreich war.
Übergeordnetes Thema: Tests
Zugehörige Konzepte
Testattribute
Testparameter
Testanhänge
Zugehörige Verweise
Testeigenschaften


Testeigenschaften

Tests > Detailansicht > Eigenschaften

Auf der Seite Eigenschaften können Sie auf alle Eigenschaften und relevanten Informationen des ausgewählten Knotens (Test, Testordner, Testpaket oder Container) zugreifen. Sie können die Informationen in jedem Bereich auf dieser Seite erweitern oder ausblenden. Dadurch können Sie genau die Informationen anzeigen, die für Sie von Interesse sind. Bei Testknoten werden die hier folgenden Eigenschaften während der Testerstellung festgelegt:

Eigenschaft | Beschreibung
Testname | Der Name des Tests.
Test-ID | Die Datenbankkennung des Tests.
Beschreibung Die Beschreibung des Tests.
Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
Status
Für Tests oder Testpakete, die in einer Konfigurationssuite enthalten sind, ist der Status eine Aggregation aller Status von allen Konfigurationen innerhalb der Suite:
  • Wenn der Test nur der Konfigurationssuite zugeordnet ist, gilt der Status Bestanden nur, wenn der Test bei allen Konfigurationen bestanden ist. Falls der Status nicht für alle Konfigurationen Bestanden ist, wird der Status für den schlechtesten Testlauf mit der folgenden Priorität (von oben nach unten) übertragen:
    1. --
    2. Nicht ausgeführt
    3. Fehlgeschlagen
    4. Bestanden
    Der Status einer Anforderung, der dem Test zugeordnet ist, gilt als Fehlgeschlagen, wenn der Test in einer Konfiguration oder mehreren Konfigurationen fehlgeschlagen ist.
  • Wir empfehlen Ihnen nicht, den Test einer Konfigurationssuite und gleichzeitig einer oder mehreren Testsuiten zuzuordnen. In diesem Fall ist die Zusammenfassung des Konfigurationsstatus ein eigenständiger Status, unabhängig von den letzten Status der Testsuiten, die andere Status sind. Der Status, der zuletzt durchgeführt wurde, bestimmt den letzten Status des Tests.
  • Wenn der Test nur einer einfachen Testsuite zugeordnet ist, wird der Status auf den Status des letzten Testlaufs gesetzt.
Letzte Testausführung | Der Zeitpunkt der letzten Ausführung des Tests. Bei Tests, die Bestandteil einer laufenden Testsuite sind, wird die letzte Ausführung anhand des aktuellen Testlaufs aktualisiert.
Zugeordnete Testausführungen Hier werden alle Testsuiten aufgelistet, die dem ausgewählten Test zugeordnet sind. Für jede Testsuite in der Liste werden die folgenden Spalten in der Tabelle angezeigt:
Spalte
Beschreibung
Testausführung
Der Name der Testsuite. Klicken Sie darauf, um die Testsuite anzuzeigen oder zu bearbeiten.
Status
Der Status des letzten Testlaufs in der Testsuite. Der Status lautet Nicht ausgeführt, wenn die Testsuite nicht im letzten Testlauf ausgeführt wurde. Für datengetriebene Tests oder Testpakete wird der Status der letzten Läufe in einem Balkendiagramm angezeigt.
Letzte Testausführung
Der letzte Ausführungstermin des Tests als Bestandteil der Testsuite.
Übergeordneter Knoten
Die Konfigurationssuite, der Ordner oder der Testzyklus, in dem die Testsuite ausgeführt wird. Klicken Sie die gewünschte Suite oder den Ordner in der Testsuitehierarchie an. Wenn die Testsuite nicht in einer Konfigurationssuite oder in einem Ordner enthalten ist, wird nichts angezeigt.
Erstellt am | Datum und Uhrzeit der Erstellung des Tests.
Erstellt von | Der Name des Benutzers, von dem der Test erstellt wurde.
Geändert am | Datum und Uhrzeit der letzten Änderung des Tests.
Geändert Von | Der Name des Benutzers, von dem der Test zuletzt geändert wurde.
Geplante Dauer [hh:mm] | Die geplante Ausführungsdauer des Tests. Nur für manuelle Tests.
Testeigenschaften | Testeigenschaften speziell für den Testtyp.
Erfolgsbedingungen | Alle Erfolgsbedingungen, die für den Test konfiguriert wurden. Bei Testpaketknoten werden alle Erfolgsbedingungen (außer dem Testausführungs-Timeout) deaktiviert und ausgeblendet.
Standard-Integrationsordner | Zeigt den Namen des Standardcontainers oder -ordners an, in dem die Tests aus externen Planungstools erstellt wurden. Weitere Informationen finden Sie unter Festlegen des Standardintegrationstestknotens für externe agile Planungssysteme.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften
Zugehörige Konzepte
Konfigurieren von Testeigenschaften
Testattribute
Testparameter
Testanhänge


Testattribute

Attribute sind frei erstellbare Merkmale, die auf Tests angewendet werden können. Sie können den Bereich Tests nach Tests mit einem bestimmten Attribut filtern und alle diese Tests zu Testsuiten zuordnen. Beispielsweise könnte ein Plattformattribut für die Produktkomponenten und ein Prioritätsattribut für die Tests erstellt werden.
Anmerkung: Attribute werden ähnlich wie Eigenschaften und Erfolgsbedingungen vererbt. Die Attribute des übergeordneten Knotens werden an sämtliche Unterordner und untergeordneten Tests weitergegeben.
  • Zuordnen von Attributen zu Tests
    Weisen Sie ein Attribut einem Test zu, um nach durch das angegebene Attribut bezeichneten Testkategorien zu filtern.
  • Bearbeiten von Testattributen
    Bearbeiten Sie ein Testattribut, um die Merkmale des Tests zu ändern.
  • Löschen von Testattributen
    Löschen Sie ein Attribut aus einem Test, wenn der Test nicht mehr vom Attribut bezeichnet wird.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften
Zugehörige Konzepte
Attribute
Konfigurieren von Testeigenschaften
Testparameter
Testanhänge
Zugehörige Verweise
Testeigenschaften


Zuordnen von Attributen zu Tests

So ordnen Sie Attribute zu Tests zu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test aus, dem Sie ein Attribut zuordnen möchten.
  3. Klicken Sie im Bereich Attribute auf Attribut hinzufügen. Das Dialogfeld Attribute hinzufügen wird angezeigt.
  4. Klicken Sie in der Spalte Hinzufügen des Attributs, das Sie zuordnen möchten, auf ( Attribut hinzufügen). Basierend auf dem ausgewählten Attributtyp wird ein Dialogfeld Attribut bearbeiten geöffnet, in dem Sie angeben können, welche der verfügbaren Attributwerte dem Test zugeordnet werden sollen.
  5. Wählen Sie den Attributwert aus, und klicken Sie auf OK, um das Attribut dem Test zuzuordnen.
Übergeordnetes Thema: Testattribute


Bearbeiten von Testattributen

So bearbeiten Sie ein Testattribut:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test aus, dessen Attribut Sie bearbeiten möchten.
  3. Klicken Sie im Bereich Attribute auf das Symbol Bearbeiten des Attributs, das Sie bearbeiten möchten. Das Dialogfeld Attribut bearbeiten wird angezeigt. Welche Optionen im Dialogfeld Attribut bearbeiten verfügbar sind, hängt vom ausgewählten Attributtyp ab.
  4. Wählen Sie den gewünschten Wert aus, und klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Testattribute


Löschen von Testattributen

So löschen Sie ein Testattribut:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test, aus dem Sie das zugeordnete Attribut löschen möchten.
  3. Klicken Sie im Bereich Attribute auf das Symbol Löschen des Attributs, das Sie löschen möchten. Ein Bestätigungsdialogfeld Attribut löschen wird angezeigt.
  4. Klicken Sie auf Ja, um das Attribut zu löschen.
    Anmerkung: Geerbte Attribute können nicht gelöscht werden.
Übergeordnetes Thema: Testattribute


Testparameter

Parameter sind beliebig konfigurierbare Eingabewerte, die verschiedenen Testtypen auf unterschiedliche Weise zugewiesen werden können. Sie ermöglichen die Angabe von Testdaten bei der Definition von Tests.

Die Testparameter, die sich in der Eigenschaft einer Test befinden (z. B. Testdaten für Silk Test Classic-Tests), werden oben angezeigt. Die nicht verwendeten Parameter werden am Ende der Liste hinzugefügt und deaktiviert.

Silk Performer
So werden z. B. in einem ausgewählten Silk Performer-Test vordefinierte Parameter für die Projektattribute verwendet.
JUnit, Silk4J
Jede beliebige JUnit- und Silk4J-Testklasse kann auf einen Testparameter des zugrunde liegenden Tests wie auf eine Java-Systemeigenschaft zugreifen. Das Startprogramm übergibt diese Parameter über das Argument -D an die VM. Innerhalb des Tests können die Werte des Parameters mithilfe von System.getProperty("myParam") angezeigt werden.
NUnit, Silk4NET
Für NUnit und Silk4NET wird jeder Parameter als Umgebungsvariable festgelegt. Innerhalb des Tests kann der Wert des Parameters mithilfe von Environment.GetEnvironmentVariable("myParam") angezeigt werden.
Silk Test Classic
Parameter können an Silk Test Classic übergeben werden, indem sie in Silk Central im Feld Testdaten in den Testeigenschaften des Silk Test Classic-Tests spezifiziert werden. Wenn Sie z.B. die Werte Ihrer Silk Central-Parameter Name und Password an Silk Test Classic übergeben möchten, geben Sie "${Name}", "${Password}" im Testdaten-Feld in den Testeigenschaften ein. Ihr Silk Test Classic-Skript benötigt ebenfalls zwei Parameter, welche diese Werte übernehmen werden.
Beispiel:
[-] testcase ProcessParams(STRING name, STRING password)
   [ ] Print(name)
   [ ] Print(password)
Externe Prozesse
Bei allen Tests, die im Rahmen eines externen Prozesses ausgeführt werden (WSH, Process Executor, NUnit, JUnit, MSTest, DotNetExplorer), wird jeder Parameter als Umgebungsvariable für diesen Prozess festgelegt. Das ist auch dann der Fall, wenn der Parametername mit dem Namen einer Betriebssystemvariable übereinstimmt, sodass der Wert der Systemvariable durch den Parameterwert ersetzt wird (außer wenn der Parameterwert eine leere Zeichenfolge ist).
Silk Test Workbench
Der Parameter muss mit demselben Namen im Silk Test Workbench-Test definiert werden, der bei der Ausführung in Silk Central festgelegt wird.
Testen von Konfigurationen
Sie können die Testparameter in einer Testsuite überschreiben. Weitere Informationen finden Sie unter Testsuiteparameter.
Benutzerdefinierte Testtypen
Weitere Informationen zu benutzerdefinierten Testtypen finden Sie in der Silk Central-API-Hilfe.
  • Vordefinierte Parameter
    Für Testausführungen stellt Silk Central Informationen zu den Eigenschaften von Testsuiteläufen in Form von Parametern zur Verfügung.
  • Erstellen benutzerdefinierter Parameter
    Erstellen Sie einen benutzerdefinierten Parameter, um Eingabewerte für verschiedene Testtypen zu konfigurieren.
  • Hinzufügen vordefinierter Parameter zu Silk Performer-Tests
    Hier wird das Hinzufügen vordefinierter Parameter zu Tests beschrieben.
  • Bearbeiten von vordefinierten Parametern
    Bearbeiten Sie den Wert von vordefinierten Parametern, wenn sich die Beschreibungen der Tests ändern.
  • Löschen von vordefinierten Parameterzuordnungen
    Löschen Sie eine vordefinierte Parameterzuordnung, wenn ein Test nicht mehr vom Parameter beschrieben wird.
  • Parameterverweise in Parameterwerten
    Hier wird die Verwendung von Parameterwerten, die Parameter enthalten, beschrieben.
  • Parameternotationen
    Hier werden die unterstützten Parameternotationen beschrieben.
  • Parameter-Token-Ersetzung während der Ausführung
    Hier wird beschrieben, wie Platzhalter durch den bei der Ausführung für den Parameter eingegebenen Wert ersetzt werden.
  • Testplanparameter (Seite) - Silk Test Workbench
    Hier wird die Datentypzuordnung für Parameter für Silk Test Workbench beschrieben.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften
Zugehörige Konzepte
Testsuite-Parameter
Konfigurieren von Testeigenschaften
Testattribute
Testanhänge
Zugehörige Verweise
Vordefinierte Parameter
Zugriff auf Silk Central-Parameter über Java-Systemeigenschaften
Testeigenschaften


Vordefinierte Parameter

Für Testausführungen stellt Silk Central Informationen zu den Eigenschaften von Testsuiteläufen in Form von Parametern zur Verfügung.
Diese Parameter können von Ihrem Testautomatisierungstool als Umgebungsvariablen ausgelesen werden (siehe Testparameter). Zusätzlich kann jede JUnit-Testklasse einen Testparameter des zugrunde liegenden Tests als Java-Systemeigenschaft auslesen (siehe Zugriff auf Silk Central-Parameter über Java-Systemeigenschaften). Verwenden Sie die AttributeGet-Methoden, um diese Parameter in einem Silk Performer-Skript auszulesen.

Diese Parameter können auch in Platzhaltern referenziert werden, wie in Parameter-Token-Ersetzung während der Ausführung beschrieben.

Auf folgende vordefinierte Parameter kann zugegriffen werden:

Parameter
Beschreibung
#sctm_execdef_name
Der Name der aktuell ausgeführten Testsuite. Wenn die Ausführung aus dem Bereich Testplan heraus ausgelöst wurde, hat der Parameter den Wert Probelauf.
#sctm_execdef_id
Die numerische ID (Datenbankschlüssel) der Testsuite, die aktuell ausgeführt wird.
#sctm_product
Der im ausgeführten Container angegebene Name des Produkts.
#sctm_version
Der Name der Version, mit der die Ergebnisse der Ausführung assoziiert sind.
#sctm_build
Der Name der Version, mit der die Ergebnisse der Ausführung assoziiert sind.
#sctm_keywords
Eine durch Komma getrennte Liste mit Schlüsselwörtern, die für diese Testsuite definiert sind.
#sctm_test_results_dir
Der Verzeichnispfad, in dem die Ergebnisdateien des Tests liegen.
#sctm_test_name
Der Name des durchgeführten Silk Central Tests.
#sctm_test_id
Der numerische Bezeichner (Datenbankschlüssel) des durchgeführten Tests.
#sctm_source_root_dir
Der lokale Pfad des Hauptverzeichnisses vom Container, wo sich alle Dateien unter Versionsverwaltung befinden.
#external_id
Die eindeutige Kennung eines Tests in einem auszuführenden Testpaket. Diese kann als Filter verwendet werden, wenn nur bestimmte Tests in einem Testpaket ausgeführt werden sollen.

#is_test_package_root
Wenn true zutrifft, ist der ausgeführte Test der Stammknoten im Testpaket (Standardeinstellung). Wenn false zutrifft, werden nur durch #external_id definierte Tests im Testpaket ausgeführt.
#sctm_data_driven_parent_test_name
Der Name des übergeordneten Tests, falls der ausgeführte Test eine Datengetriebene Zeile ist.
#sctm_data_driven_parent_test_id
Die numerische Kennung (Datenbankschlüssel) des übergeordneten Tests, falls der ausgeführte Test eine Datengetriebene Zeile ist.
Übergeordnetes Thema: Testparameter
Übergeordnetes Thema: Testsuite-Parameter
Zugehörige Konzepte
Testparameter
Zugehörige Verweise
Zugriff auf Silk Central-Parameter über Java-Systemeigenschaften


Erstellen benutzerdefinierter Parameter

So erstellen Sie einen benutzerdefinierten Parameter:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Testknoten aus, für den Sie einen neuen Parameter erstellen möchten.
  3. Klicken Sie im Bereich Parameter auf Benutzerdefinierten Parameter hinzufügen. Das Dialogfeld Benutzerdefinierten Parameter festlegen wird angezeigt.
  4. Geben Sie einen Namen für den Parameter ein.
  5. Wählen Sie im Listenfeld Typ den Parametertyp aus.
    • String
    • Nummer
    • Gleitkomma
    • Boolescher Wert
    • Passwort
    • Zeichen
  6. Definieren Sie den Parameterwert, den Sie dem ausgewählten Test zuordnen möchten.
    Anmerkung: Die Werte für Parameter mit dem Typ „String“ müssen in Anführungszeichen (“) eingegeben werden, wenn sie in Silk Test Classic-Testausführungen verwendet werden sollen.
  7. Klicken Sie auf OK.
    Anmerkung: Parameter werden automatisch auch allen Unterordnern und untergeordneten Tests des ausgewählten Knotens zugeordnet.
Übergeordnetes Thema: Testparameter


Hinzufügen vordefinierter Parameter zu Silk Performer-Tests

So fügen Sie einen vordefinierten Parameter zu einem Test hinzu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Testknoten aus, zu dem der Parameter hinzugefügt werden soll.
  3. Klicken Sie im Bereich Parameter auf Vordefinierten Parameter hinzufügen.
    Anmerkung: Die Schaltfläche Vordefinierten Parameter hinzufügen ist nur für Silk Performer-Tests verfügbar, bei denen die Eigenschaft Projekt bereits definiert ist.
    Das Dialogfeld Vordefinierten Parameter hinzufügen wird geöffnet. Hier werden alle Projektattribute aufgelistet, die in der Projektdatei verfügbar sind.
  4. Klicken Sie auf das Hinzufügen-Symbol der Parameter, die Sie hinzufügen möchten.
  5. Legen Sie im nächsten Dialogfeld den tatsächlichen Wert des Parameters fest.
  6. Klicken Sie auf Speichern, um den Parameter zum aktiven Knoten der Testhierarchie hinzuzufügen.
Übergeordnetes Thema: Testparameter


Bearbeiten von vordefinierten Parametern

So bearbeiten Sie einen vordefinierten Parameter:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Testknoten aus, in dem Sie einen Parameter bearbeiten möchten.
  3. Klicken Sie im Bereich Parameter auf das Symbol Bearbeiten des Parameters, den Sie bearbeiten möchten. Das Dialogfeld Benutzerdefinierten Parameter festlegen wird angezeigt.
  4. Bearbeiten Sie die gewünschten Parameterwerte.
    Anmerkung: Die geerbten Parameter können nicht bearbeitet werden. Wenn Sie den Wert eines Parameters ändern möchten, deaktivieren Sie das Kontrollkästchen Von übergeordneter Ebene erben. Der Name und Typ eines Parameters können nicht geändert werden.
Übergeordnetes Thema: Testparameter


Löschen von vordefinierten Parameterzuordnungen

So löschen Sie eine vordefinierte Parameterzuordnung:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Testknoten aus, für den Sie die Zuordnung eines vorhandenen Parameters löschen möchten.
  3. Klicken sie im Bereich Parameter auf Löschen in der Spalte Aktionen des Parameters, den Sie löschen möchten.
    Anmerkung: Die geerbten Parameter können nicht gelöscht werden. Wenn Sie einen geerbten Parameter löschen möchten, deaktivieren Sie vorher im Dialogfeld Parameter festlegen das Kontrollkästchen Von übergeordneter Ebene erben.
  4. Klicken Sie im Dialogfeld Parameter löschen auf Ja, um den Parameter zu löschen.
Übergeordnetes Thema: Testparameter


Parameterverweise in Parameterwerten

In den Parameterwerten kann auf andere Parameter verwiesen werden. Das Auswertungsergebnis dieser Parameter wird in der Benutzeroberfläche in Fettschrift angezeigt. Das folgende Beispiel zeigt die Verwendung eines solchen Parameters:
parameterA := aaa
parameterB := bbb + ${parameterA}
Ausgewertete Werte:
parameterA = aaa
parameterB = bbb + aaa
Übergeordnetes Thema: Testparameter


Parameternotationen

Die folgenden Parameternotationen werden unterstützt:

Für alle Tests:
${<parameter>}

Die folgenden Zeichen sind in Parameternamen nicht zulässig: "$", "{", "}" und "#"

Veraltete Notation für manuelle Tests:
#<parameter>#

Bei manuellen Tests sind die folgenden Zeichen für Parameternamen zulässig: 0-9, a-z, A-Z und _.

Zusätzliche Notation für Silk Test Classic-Tests:
$<parameter>

Bei Silk Test Classic-Tests sind die folgenden Zeichen für Parameternamen zulässig: 0-9, a-z, A-Z und _.

Übergeordnetes Thema: Testparameter


Parameter-Token-Ersetzung während der Ausführung

String-Werte für die Eigenschaften eines Tests können Platzhalter im folgenden Format enthalten: ${parametername}. parametername muss der Name eines Parameters sein, der in diesem Test definiert ist oder von ihm geerbt wurde. Während der Ausführung wird der Platzhalter durch den Wert des Parameters mit dem angegebenen Namen ersetzt. Dadurch lassen sich wiederholt auftretende Zeichenfolgen leichter ändern und gebräuchliche Definitionen bearbeiten.

Wenn Silk Central einen Parameter mit der Notation ${parametername} findet, wird zunächst überprüft, ob es sich um einen definierten Parameter handelt. Ist dies nicht der Fall, wird geprüft, ob der Parameter als Umgebungsvariable auf dem Ausführungsserver definiert ist. Die Werte der Umgebungsvariablen werden so verwendet, wie Sie zum Zeitpunkt des Hochfahrens des Ausführungsservers gesetzt waren. Der Name der Silk Central-Variable stimmt nur dann mit dem Namen der Umgebungsvariable überein, wenn die Groß-/Kleinschreibung identisch ist, oder wenn alle Zeichen entweder groß oder alle klein geschrieben sind. Beispiel: Die Silk Central-Variable stimmt mit der Umgebungsvariable SilkHome überein, wenn sie ${SilkHome}, ${silkhome} oder ${SILKHOME} heißt, aber nicht wenn sie ${silkHome} heißt.

Wenn beispielsweise der Wert einer JUnit-Klassenpfadseigenschaft junit.jar;${MyWorkingDir}/myclasses ist, und der Parameter MyWorkingDir den Wert C:/Temp/MyWorking hat, lautet der effektive Eigenschaftswert junit.jar;C:/Temp/MyWorking/myclasses.

Anmerkung: Ein Parameterwert kann auch andere Parameterplatzhalter enthalten. Dadurch können die Parameter verschachtelt werden.
Übergeordnetes Thema: Testparameter


Testanhänge

Im Bereich Anhänge werden die Dateien und Links angezeigt, die als Anhänge für den ausgewählte Container, Ordner oder Test hochgeladen wurden.

Wenn das Kontrollkästchen Untergeordnete Anhänge einbeziehen aktiviert ist, werden auch die Anhänge der untergeordneten Tests, Ordner und Container angezeigt.

  • Zuordnen von Dateien zu Testelementen
    Ordnen Sie eine Datei zu einem Testelement zu, um dem Test zusätzliche Informationen hinzuzufügen.
  • Zuordnen von Links zu Testelementen
    Ordnen Sie einen Link zu einem Testelement zu, um dem Test zusätzliche Informationen hinzuzufügen.
  • Anzeigen von Testanhängen
    Zeigen Sie einen Testsanhang an, um weitere Informationen zum Test zu erhalten.
  • Dateien von Testelementen herunterladen
    Laden Sie sämtliche angehängte Dateien eines Testelements auf Ihre Festplatte herunter.
  • Löschen von Anhängen in Testelementen
    Löschen Sie einen Anhang aus einem Testelement, wenn die zusätzlichen Informationen nicht mehr erforderlich sind.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften
Zugehörige Konzepte
Konfigurieren von Testeigenschaften
Testattribute
Testparameter
Zugehörige Verweise
Testeigenschaften


Zuordnen von Dateien zu Testelementen

So ordnen Sie Dateien zu Testelementen zu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Container, einen Ordner oder einen Test aus.
  3. Klicken Sie im Bereich Anhänge auf Datei hochladen. Das Dialogfeld Datei hochladen wird angezeigt.
  4. Klicken Sie auf Datei auswählen, und wählen Sie die gewünschte Datei aus.
  5. Optional: Geben Sie eine Beschreibung für den Anhang ein.
  6. Klicken Sie auf OK, um den Anhang zum Server hochzuladen und das ausgewählte Element zuzuordnen.
Übergeordnetes Thema: Testanhänge


Zuordnen von Links zu Testelementen

So ordnen Sie Links zu Testelementen zu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Container, einen Ordner oder einen Test aus.
  3. Klicken Sie im Bereich Anhänge auf Link einfügen. Das Dialogfeld Link einfügen wird angezeigt.
  4. Fügen Sie die URL in das Feld Link ein.
  5. Optional: Geben Sie eine Beschreibung für den eingefügten Link ein.
  6. Klicken Sie auf OK, um das ausgewählte Element zuzuordnen.
Übergeordnetes Thema: Testanhänge


Anzeigen von Testanhängen

Für ein ausgewähltes Testselement werden auf der Seite Anhänge zugeordnete Dateien und Links angezeigt. Die Anhänge werden standardmäßig in der Reihenfolge angezeigt, in der Sie hochgeladen werden. Sie können die Anhänge jedoch auch nach Spalten sortieren. Wenn auch die Anhänge angezeigt werden sollen, die den untergeordneten Elementen des ausgewählten Elements zugeordnet sind, aktivieren Sie das Kontrollkästchen Untergeordnete Anhänge einbeziehen.

So zeigen Sie die Anhänge einer Test an:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie das Element aus, für das Sie einen Anhang anzeigen möchten.
  3. Klicken Sie im Bereich Anhänge auf den Namen des Anhangs. Der Name der einzelnen Anhänge dient als Link. Wenn Sie auf den Namen eines Dateianhangs klicken, wird das Dialogfeld Speichern unter geöffnet, in dem Sie den Anhang auf dem lokalen Computer speichern können. Beim Klicken auf einen Link-Anhang wird das verknüpfte Ziel in einem neuen Browserfenster geöffnet.
Übergeordnetes Thema: Testanhänge


Dateien von Testelementen herunterladen

So laden Sie alle Dateien von einem Testelement herunter:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Container, einen Ordner oder einen Test aus.
  3. Klicken Sie auf die Registerkarte Anhänge.
  4. Klicken Sie im Bereich Anhänge auf Alle Dateien herunterladen. Je nachdem wie Sie die Download-Einstellungen Ihres Browsers konfiguriert haben, werden sämtliche angehängte Dateien als Zip-Archiv auf Ihre Festplatte heruntergeladen.
    Anmerkung: Um zu große Downloads zu verhindern, ist Alle Dateien herunterladen deaktiviert wenn Untergeordnete Anhänge einbeziehen aktiviert ist.
Übergeordnetes Thema: Testanhänge


Löschen von Anhängen in Testelementen

So löschen Sie einen Anhang in einem Testelement:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie das Element aus, aus dem Sie einen Anhang löschen möchten.
  3. Klicken sie im Bereich Anhänge auf Löschen in der Spalte Aktionen des Anhangs, den Sie löschen möchten.
  4. Klicken Sie im Bestätigungsdialogfeld auf Ja, um den Anhang aus dem Projekt zu löschen.
    Anmerkung: Sie können immer nur einen Anhang löschen.
Übergeordnetes Thema: Testanhänge


Datengetriebene Tests

Bei datengetriebenen Tests werden Werte aus einer vorhandenen Datenquelle (z. B. Kalkulationstabelle oder Datenbank) verwendet. Wenn Sie mit datengetriebenen Tests arbeiten möchten, müssen Sie zunächst eine Datenquelle konfigurieren. Weitere Information über die Konfiguration von Datenquellen finden Sie unter Datenquellen für datengetriebene Tests.

  • Erstellen von datengetriebenen Tests
    Erstellen Sie einen datengetriebenen Test.
  • Hinzufügen eines Datenquellenwerts zu einem manuellen Testschritt
    Fügen Sie einem manuellen Testschritt einen Datenquellenwert hinzu.
  • Herunterladen von CSV-Daten von einer Datenquelle
    Laden Sie CSV-Daten von einer Datenquelle herunter.
  • Bearbeiten von datengetriebenen Eigenschaften
    Bearbeiten Sie datengetriebene Eigenschaften.
  • Entfernen datengetriebener Eigenschaften
    Entfernen Sie alle datengetriebenen Eigenschaften, wenn diese nicht mehr relevant sind und wenn Sie eine Datenquelle löschen möchten.
  • Atomare und nicht-atomare datengetriebene Tests
    Hier werden die verfügbaren datengetriebenen Testtypen beschrieben.
  • Verwenden von Arbeitsblättern
    Hier wird beschrieben, wie Arbeitsblätter als Datenquellen für datengetriebene Tests verwendet werden.
  • Hinweise zum Datenimport
    Hier finden Sie zusätzliche Informationen zum Importieren von Daten aus externen Datenquellen.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften
Zugehörige Konzepte
Datenquellen für datengetriebene Tests
Erstellen von datengetriebenen Tests
Silk Test Classic-Tests


Erstellen von datengetriebenen Tests

So erstellen Sie einen datengetriebenen Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Erstellen Sie einen neuen Test. Weitere Informationen finden Sie unter Erstellen von Tests.
  3. Klicken Sie auf die Registerkarte Eigenschaften des neu erstellten Tests.
  4. Klicken Sie im Bereich Datengetriebene Eigenschaften auf Bearbeiten. Das Dialogfeld Datengetriebene Eigenschaften wird angezeigt.
  5. Wählen Sie in der Liste Datenquelle eine vorkonfigurierte Datenquelle aus. Weitere Information über die Konfiguration von Datenquellen finden Sie unter Datenquellen für datengetriebene Tests.
    Anmerkung: Ihre Datenquelle kann bis zu 100 Zeilen umfassen. Wenn sie mehr als 100 Zeilen enthält, müssen Sie im Dialogfeld Datengetriebene Eigenschaften eine Abfrage eingeben, die höchstens 100 Zeilen zurückgibt. Auf diese Weise können aus einer Datenquelle höchstens 100 Tests generiert werden.
  6. Klicken Sie auf Weiter.
  7. Wählen Sie einen Datensatz aus der Liste Datensatz aus. Bei Excel-Datenquellen ist dies der Name des Arbeitsblatts. Bei Datenbankdatenquellen ist dies der Tabellenname.
  8. Aktivieren Sie das Kontrollkästchen Jede Datenzeile als eigenen Test anzeigen, wenn für jede Zeile in der Datenmenge ein separater Test erstellt werden soll (nicht-atomarer Test). Bei deaktiviertem Kontrollkästchen wird für alle Zeilen ein einziger Test erstellt (atomarer Test). Weitere Informationen finden Sie unter Atomare und nicht-atomare datengetriebene Tests.
  9. Optional: Geben Sie im Feld Abfrage filtern eine SQL-Abfrage ein, um Ihre Daten auf der Grundlage dieser Abfrage zu filtern.
    Es werden nur Abfragen mit einfachen WHERE-Klauseln unterstützt. Wenn Sie die Daten z.B. So filtern möchten, dass nur Zeilen mit dem Inhalt Boston in der Spalte City dabei sind, geben sie die folgende Filterabfrage ein:
    City = 'Boston'
  10. Aktivieren Sie das Kontrollkästchen Datengetriebene Eigenschaften aktivieren, um die datengetriebene Testfunktion zu aktivieren. Die konfigurierte Datenquelle wird für diesen Test nur dann verwendet, wenn diese Einstellung aktiviert ist.
  11. Klicken Sie auf Fertig stellen, um die Änderungen zu speichern.
    Anmerkung: Die datengetriebenen Eigenschaften werden im Bereich Datengetriebene Eigenschaften der Seite Eigenschaften für Tests angezeigt.
    Anmerkung: Wenn Sie die datengetriebene Testfunktion von Silk Central mit Silk Performer-Skripts nutzen möchten, müssen Datenquellen mit Spaltennamen, die mit den entsprechenden Silk Performer-Projektattributen übereinstimmen, in Verbindung mit AttributeGet-Methoden verwendet werden.
Übergeordnetes Thema: Datengetriebene Tests
Zugehörige Konzepte
Datenquellen für datengetriebene Tests
Datengetriebene Tests
Zugehörige Tasks
Verwalten von Tests


Hinzufügen eines Datenquellenwerts zu einem manuellen Testschritt

So fügen Sie einen Datenquellenwert zu einem manuellen Testschritt hinzu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Erstellen Sie einen neuen datengetriebenen Test. Wählen Sie als Testtyp Manuell aus, und konfigurieren Sie Testschritte.
    Anmerkung: Um die Werte der Datenquelle anzuzeigen, erweitern Sie den Bereich Datengetriebene Eigenschaften auf der Seite Eigenschaften des Tests.
  3. Klicken Sie auf die Registerkarte Testschritte.
  4. Wählen Sie den Testschritt aus, in dem der Datenquellenwert verwendet werden soll.
  5. Geben Sie in das Feld Aktionsbeschreibung einen Parameter ein, der auf die betreffende Spalte in der Datenquelle verweist. Verwenden Sie dazu die Syntax ${<Spaltenname>}. Wenn z. B. die Kennwörter aus der Spalte Kennwort einer Kalkulationstabelle abgerufen werden sollen, geben Sie den Parameter ${Kennwort} ein. Bei der Ausführung des manuellen Testschritts wird dann der Parameter durch den Spaltenwert der Datenquelle ersetzt.
Übergeordnetes Thema: Datengetriebene Tests
Zugehörige Konzepte
Manuelle Tests


Herunterladen von CSV-Daten von einer Datenquelle

So laden Sie CSV-Daten von einer Datenquelle herunter:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie eine Test aus, in der die Datenquelle verwendet wird, von der Sie Daten herunterladen möchten.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie im Bereich Datengetriebene Eigenschaften in der Spalte Aktionen der Datenquelle oder der Datenmenge (je nachdem, welche Entität die gewünschten Daten enthält) auf Herunterladen.
  5. Wählen Sie das lokale Verzeichnis aus, in das die Daten heruntergeladen werden sollen.
  6. Klicken Sie auf OK, um die Daten im CSV-Format herunterzuladen.
Übergeordnetes Thema: Datengetriebene Tests
Zugehörige Konzepte
Manuelle Tests


Bearbeiten von datengetriebenen Eigenschaften

So bearbeiten Sie datengetriebene Eigenschaften:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie die Tests mit der Eigenschaft aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken sie im Bereich Datengetriebene Eigenschaften auf Bearbeiten in der Spalte Aktionen der Eigenschaft, den Sie bearbeiten möchten.
  5. Nehmen Sie die gewünschten Änderungen vor.
  6. Klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Datengetriebene Tests


Entfernen datengetriebener Eigenschaften

Entfernen Sie alle datengetriebenen Eigenschaften, wenn diese nicht mehr relevant sind und wenn Sie eine Datenquelle löschen möchten.
So entfernen Sie datengetriebene Eigenschaften:
  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests den Knoten aus, aus dem Sie die datengetriebenen Eigenschaften entfernen möchten.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie im Bereich Datengetriebene Eigenschaften auf Entfernen. Alle datengetriebenen Eigenschaften werden aus dem Knoten entfernt.
    Anmerkung: Die datengetriebenen Eigenschaften werden außerdem aus den Unterknoten entfernt, die die Eigenschaften des Knotens erben.
Übergeordnetes Thema: Datengetriebene Tests


Atomare und nicht-atomare datengetriebene Tests

Wenn Sie datengetriebene Tests durchführen möchten, sollten Sie sich zuerst mit den zwei dazu in Silk Central vorgesehenen Testtypen vertraut machen:
Atomare datengetriebene Tests
Hier wird für alle Datenzeilen in der Datenquelle ein einziges Testergebnis erzeugt. Daher ist der Test nur erfolgreich, wenn jede Datenzeile zum Erfolg führt. Wenn die Ausführung mit einer Datenzeile fehlschlägt, wird der gesamte Test als fehlgeschlagen gekennzeichnet.
Nicht-atomare datengetriebene Tests
Hier wird für jede Datenzeile in der Datenquelle ein eigener Test verwendet. Daher führt jede Datenzeile zu einem Testergebnis (bestanden oder fehlgeschlagen). Wenn Sie beispielsweise eine Kalkulationstabelle mit vier Zeilen als Datenquelle verwenden, erhalten Sie den ursprünglich von Ihnen erstellten Test (ein übergeordneter Test) und zusätzlich vier neue untergeordnete Knoten des Testplans (einen für jede Zeile).

Weitere Informationen über die Erstellung von datengetriebenen Tests finden Sie unter Erstellen von datengetriebenen Tests.

Der dabei erstellte übergeordnete Test verfügt über keine Parameter, da er lediglich als Strukturierungselement für ihre untergeordneten Knoten des Testplans dient und nicht als richtiger Test verwendet wird. Alle Werte der Datenquelle werden im Bereich Datengetriebene Eigenschaften des übergeordneten Tests angezeigt.

Beachten Sie beim Zuordnen eines übergeordneten Tests zu einer Anforderung, dass Links zu Anforderungen nur bei atomaren, datengetriebenen Tests vererbt werden.

Der übergeordnete Test eines nicht-atomaren, datengetriebenen Tests kann keiner Vorbereitung oder Nachbereitung zugeordnet werden, da dieser lediglich als Ordner verwendet wird. Sie können jedoch seine untergeordneten Knoten oder einen atomaren, datengetriebenen Test einer Vorbereitung oder Nachbereitung zuordnen.

Weitere Informationen über Begrenzungen für Datenquellen finden Sie unter Begrenzungen für Datenquellen.

Übergeordnetes Thema: Datengetriebene Tests


Verwenden von Arbeitsblättern

Wenn Sie ein Microsoft Excel-Arbeitsblatt als Datenquelle verwenden, sollten Sie die folgenden Richtlinien zum Konfigurieren datengetriebener Tests beachten:

  • Wählen Sie einen beschreibenden Spaltennamen. Die Datenquelle lässt sich dann in Silk Central einfacher verwalten.
  • Wenn Sie mehrere Arbeitsblätter verwenden, sollten die Spalten konsistent benannt werden. Dadurch lassen sich bestimmte Spalten durch einen Filter einfacher auswählen.
  • Verwenden Sie bestimmte Spalten als Schlüsselspalten. Dadurch kann Silk Central auch bei Änderungen an der Quelldatei weiterhin bestimmte Datenzeilen anhand des Schlüsselspaltenwertes erkennen. Die Werte in einer Schlüsselspalte sollten eindeutig sein.
Übergeordnetes Thema: Datengetriebene Tests


Hinweise zum Datenimport

Beim Importieren von Datenzeilen aus einer externen Datenquelle berücksichtigt Silk Central nicht die dort verwendete Sortierreihenfolge. Daher kann sich die Reihenfolge der Datenzeilen in Silk Central von der Reihenfolge in der externen Datenquelle unterscheiden. Silk Central ignoriert außerdem alle in der externen Datenquelle festgelegten Formatierungen. Wenn Sie z. B. in einem Excel-Arbeitsblatt für Datumswerte ein bestimmtes Format festgelegt haben, wird dieses von Silk Central ignoriert. Alle Datumswerte werden im Standardformat "JJJJ.MM.TT HH:MM:SS.M" importiert.

Anmerkung: Ihre Datenquelle kann bis zu 100 Zeilen umfassen. Wenn sie mehr als 100 Zeilen enthält, müssen Sie im Dialogfeld Datengetriebene Eigenschaften eine Abfrage eingeben, die höchstens 100 Zeilen zurückgibt. Auf diese Weise können aus einer Datenquelle höchstens 100 Tests generiert werden.
Übergeordnetes Thema: Datengetriebene Tests


Erfolgsbedingungen

Verwenden Sie Erfolgsbedingungen, um zu ermitteln, ob ein Test erfolgreich war. Jedem Testknoten oder Testsuiteknoten im Bereich Tests können eine oder mehrere Erfolgsbedingungen zugeordnet werden. Wird während der Ausführung einer Test eine ihr zugeordnete Erfolgsbedingung nicht erfüllt, dann wird die Testsausführung als fehlgeschlagen markiert. Dies gilt jedoch nicht für die Erfolgsbedingung des Testausführungs-Timeouts. Die Testsausführung wird hier als Nicht ausgeführt markiert. Bei einem Testpaket werden alle Erfolgsbedingungen mit Ausnahme des Testausführungs-Timeouts deaktiviert und ausgeblendet.

Wenn Sie in der Detailansicht einen Knoten in der Testhierarchie auswählen, werden auf der Seite Eigenschaften des Knotens in der Tabelle Erfolgsbedingungen alle Erfolgsbedingungen angezeigt, die für den ausgewählten Knoten konfiguriert sind. In der Tabelle werden folgenden Informationen zur Bedingung angezeigt: Name der Bedingung, ob die Bedingung aktiv ist, Maximalwert der Bedingung und ob die Bedingung geerbt ist.

Erfolgsbedingungen werden nur ausgewertet, wenn sie aktiv sind. Wie Erfolgsbedingungen aktiviert und deaktiviert werden, wird im Abschnitt Bearbeiten von Erfolgsbedingungen beschrieben. Welche Arten von Erfolgsbedingungen verfügbar sind, hängt vom Typ der Test ab. Die folgenden Erfolgsbedingungen stehen derzeit in Silk Central zur Verfügung.

Erfolgsbedingung
Beschreibung
Fehler zulässig
Die maximale Fehleranzahl, die für den Test zulässig ist. Erfolgsbedingung ist standardmäßig aktiv.
Warnungen zulässig
Die maximale Anzahl von Warnungen, die für den Test zulässig ist.
Testausführungs-Timeout [s]
Die maximale Timeout-Dauer in Sekunden, die für den Test zulässig ist.
Page Time: Avg. Page Time [s]
Die maximal zulässige durchschnittliche Ladedauer einer Seite.
Page Time: Max. Page Time [s]
Die maximal zulässige Ladedauer einer Seite.
Transaction Response Time: Avg. Trans(Busy)ok [s]
Die maximale durchschnittliche Reaktionszeit für eine Transaktion im Test.
Transaction Response Time: Max. Trans(Busy)ok [s]
Die maximale Reaktionszeit für eine Transaktion im Test.

Erfolgsattribute werden ähnlich wie Eigenschaften vererbt. Die Erfolgsbedingungen des übergeordneten Knotens werden an sämtliche Unterordner und untergeordneten Tests weitergegeben.

  • Bearbeiten von Erfolgsbedingungen
    Bearbeiten Sie eine Erfolgsbedingung, um die Bedingung auf veränderte Testanforderungen anzuwenden.
Übergeordnetes Thema: Konfigurieren von Testeigenschaften


Bearbeiten von Erfolgsbedingungen

Wenn Sie in der Detailansicht in der Testhierarchie einen Knoten auswählen, werden auf der Seite Eigenschaften des Knotens die Erfolgsbedingungen angezeigt, die dem Knoten zugeordnet sind. In der Tabelle Erfolgsbedingungen werden folgende Informationen zur Bedingung angezeigt: Name der Bedingung, ob die Bedingung aktiv ist, der Maximalwert der Bedingung und ob die Bedingung geerbt ist.

Anmerkung: Bei Testpaketknoten werden alle Erfolgsbedingungen (außer dem Testausführungs-Timeout) deaktiviert und ausgeblendet.

So bearbeiten Sie die Erfolgsbedingungen eines Tests:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie einen Container, einen Ordner oder einen Test aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften. Auf der Seite Eigenschaften werden die Eigenschaften der ausgewählten Hierarchieelemente angezeigt.
  4. Klicken Sie rechts neben Erfolgsbedingungen auf Bearbeiten. Das Dialogfeld Test bearbeiten wird geöffnet.
  5. Deaktivieren Sie das Kontrollkästchen Von übergeordneter Ebene erben der Erfolgsbedingungen, die Sie bearbeiten.
  6. Bearbeiten Sie die gewünschten Werte.
  7. Legen Sie mit den Aktiv-Kontrollkästchen fest, ob die Bedingungen aktiv oder inaktiv sind.
  8. Klicken Sie auf OK, um die Einstellungen zu speichern.
Übergeordnetes Thema: Erfolgsbedingungen


Ausführen eines Versuchslaufs eines Tests

Sie können einen Versuchslauf eines Tests ausführen, um zu prüfen, ob der Test wie gewünscht funktioniert.

So führen Sie einen Versuchslauf eines Tests aus:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Testhierarchie mit der rechten Maustaste auf den Test, den Sie überprüfen möchten.
  3. Wählen Sie Probelauf.
  4. Der Dialog Gehe zu Aktivitäten wird angezeigt. Wenn Sie zur Seite Aktivitäten wechseln möchten, klicken Sie auf Ja. Soll weiterhin die aktuelle Seite angezeigt werden, klicken Sie auf Nein. Weitere Informationen finden Sie unter Aktivitäten.
    Anmerkung: Aktivieren Sie das Kontrollkästchen Diese Meldung nicht mehr anzeigen, wenn das Dialogfeld mit der Frage zum Wechseln zur Seite Aktivitäten nicht mehr angezeigt werden soll. Diese Einstellung wird zurückgesetzt, wenn Sie sich bei Silk Central abmelden.

Nachdem Sie erfolgreich einen Probelauf beendet haben, können Sie nun Ihre Testausführungen planen.

Übergeordnetes Thema: Tests
Zugehörige Konzepte
Aktivitäten


Bibliotheken

Bibliotheken sind Sammlungen von Testschritten und Schlüsselwörtern, welche von Tests in verschiedenen Projekten geminsam verwendet werden können.

Gemeinsam verwendbare Objekte reduzieren die Anzahl der von der Testabteilung zu verwaltenden Testschritte und Schlüsselwörter. Bibliotheken werden in einer hierarchischen Struktur (der Bibliothekshierarchie) angezeigt, organisiert und verwaltet. In der Bibliothekshierarchie können Sie gemeinsam verwendbare Testschritte und Schlüsselwörter mit beliebiger Hierarchietiefe organisieren. Sie können jeden Knoten der Hierarchie bearbeiten oder löschen. Indem Sie mit der rechten Maustaste auf einen Knoten der Hierarchie klicken, können Sie den Knoten ausschneiden oder kopieren und an anderer Stelle einfügen. Mithilfe der Seite Sichtbarkeit legen Sie fest, für welche Projekte die ausgewählte Bibliothek sichtbar sein soll. Der Stammknoten der Bibliothekshierarchie hat den Namen Bibliotheken und kann nicht bearbeitet werden.

Die Seite Verwendungen der einzelnen Objekte listet Tests, gemeinsam verwendbare Objekte, Schlüsselwörter und Schlüsselwort-Sequenzen auf, die das ausgewählte Objekt aufrufen. Auf diese Weise können Sie die Auswirkung von Änderungen am Objekt abschätzen.

Anmerkung: Im Bibliotheksbereich können Objekte vom Testmanager, Tester und SuperUser erstellt, bearbeitet und angezeigt werden. Der Testmanager und der SuperUser können darüber hinaus Objekte im Bibliotheksbereich löschen. Benutzer mit den Rollen Projektmanager, Analytiker oder Berichtersteller können Objekte im Bibliotheksbereich anzeigen.
  • Erstellen einer Bibliothek
    Erstellen Sie eine Bibliothek, um eine Sammlung von manuellen Testschritten oder Schlüsselwörtern einzufügen, die von Tests und Projekten gemeinsam verwendet werden sollen.
  • Verwalten von Schlüsselwort-Bibliotheken und Bibliothekseigenschaften
    Verwalten Sie Ihre Schlüsselwort-Bibliotheken und die Eigenschaften des in der Bibliothekshierarchie ausgewählten Knotens.
  • Bibliotheken für Projekte verfügbar machen
    Verwalten Sie, welche Projekte auf die gemeinsam verwendbaren Objekte in der ausgewählten Bibliothek Zugriff haben.
  • Verwalten von Schlüsselwörtern in einer Bibliothek
    Verwalten Sie Schlüsselwörter in einer Schlüsselwort-Sequenz, um eine bestimmte Abfolge von Aufgaben festzulegen.
  • Erstellen einer Bibliothek mit schlüsselwortgetriebenen Tests unter Verwendung von Java
    Erstellen Sie mit Java eine externe Bibliothek mit Schlüsselwörtern und laden Sie diese auf Silk Central hoch. Dadurch können sie ihr existierendes Test-Framework ganz einfach in Silk Central integrieren, z.B. wenn sie bereits Selenium Tests haben.
  • Tastaturfunktionen (Bibliotheken)
    Die Hierarchie kann mit der Tastatur bedient werden und unterstützt die Mehrfachauswahl.
  • Verwalten von gemeinsam verwendbaren Objekten
    Beschreibt das Konzept von gemeinsam verwendbaren Objekten in Silk Central.
  • Versionen
    Beschreibt, wie Versionen von gemeinsam verwendbaren Objekten Tests verwendet werden.
Übergeordnetes Thema: Tests
Zugehörige Konzepte
Projekt-Baselines


Erstellen einer Bibliothek

  1. Klicken Sie im Menü auf Tests > Bibliotheken.
  2. Wählen Sie in der Bibliothekshierarchie den Stammknoten mit dem Namen Bibliotheken aus.
  3. Klicken Sie in der Symbolleiste auf Neue Bibliothek um eine neue Bibliothek zu erstellen.
    Anmerkung: Sie können auch mit der rechten Maustaste auf den Stammknoten klicken und dann auf Neue Bibliothek klicken.
Übergeordnetes Thema: Bibliotheken


Verwalten von Schlüsselwort-Bibliotheken und Bibliothekseigenschaften

Tests > Bibliotheken > <Bibliothek> > Eigenschaften

Um die Eigenschaften eines Knotens in der Bibliothekshierarchie anzuzeigen oder zu ändern, wählen Sie den Knoten aus und klicken auf die Registerkarte Eigenschaften.

Verwenden Sie die Schaltflächen Hochladen und Löschen im Bereich Schlüsselwort-Bibliothek, um eine externe Schlüsselwort-Bibliothek hochzuladen oder zu entfernen.

Übergeordnetes Thema: Bibliotheken
Zugehörige Tasks
Erstellen einer Bibliothek mit schlüsselwortgetriebenen Tests unter Verwendung von Java


Bibliotheken für Projekte verfügbar machen

Tests > Bibliotheken > <Bibliothek> > Sichtbarkeit

Auf der Seite Sichtbarkeit können Sie die ausgewählte Bibliothek für alle Projekte sichtbar machen, oder die Sichtbarkeit auf bestimmte Projekte beschränken. Klicken Sie zum Ändern der Sichtbarkeit einer ausgewählten Bibliothek für ein Projekt auf Sichtbarkeit bearbeiten.

Im Dialogfeld Sichtbarkeit bearbeiten werden die Projekte angezeigt, die der aktuelle Benutzer der Bibliothek zuweisen kann. Der Dialog enthält die folgenden Elemente:
Element | Beschreibung
Alle Projekte | Mit dieser Option ordnen Sie der Bibliothek alle Projekte zu.
Ausgewählte Projekte | Mit dieser Option ordnen Sie der Bibliothek ausgewählte Projekte aus der Liste zu.
Alle auswählen | Mit dieser Option ordnen Sie der Bibliothek alle aufgelisteten Projekte zu.
Auswahl aufheben | Mit dieser Option heben Sie die Zuordnung aller aufgelisteten Projekte zur Bibliothek auf.
Anmerkung: Projekte, die die Bibliothek derzeit verwenden, sind abgedunkelt dargestellt. Ihre Zuordnung zur Bibliothek kann nicht aufgehoben werden.

Wenn die Baseline eines Projekts, das gemeinsam verwendbare Objekte aufruft, erstellt wird, sind die Bibliotheken, in denen die gemeinsam verwendbaren Objekte enthalten sind, standardmäßig für die neue Projekt-Baseline sichtbar. Weitere Informationen zu Projekt-Baselines finden Sie in den Themen Verwaltung in dieser Hilfe.

Übergeordnetes Thema: Bibliotheken
Zugehörige Konzepte
Verwaltung


Tastaturfunktionen (Bibliotheken)

Die folgenden Aktionen können für die ausgewählten Knoten ausgeführt werden:

Taste | Aktion
Aufwärts | Auswahl nach oben
Abwärts | Auswahl nach unten
Rechts | Element erweitern
Links | Untergeordnete Elemente ausblenden
F2 | Element bearbeiten
Strg+C | Element kopieren
Strg+X | Element ausschneiden
Strg+V | Element einfügen
Entf | Element löschen
Klicken | Ein Element markieren und als aktuelles Element merken.
Strg+Klick | Den Auswahlstatus des gewählten Elements ein- und ausschalten und mit weiteren Klicks weitere Elemente hinzufügen/entfernen.
Umschalt+Klick | Auswahl vom aktuell markierten Element bis zum neu angeklickten Element erweitern.
Umschalt+Nach oben | Das darüberliegende Element auswählen.
Umschalt+Nach unten | Das darunterliegende Element auswählen.
Übergeordnetes Thema: Bibliotheken


Verwalten von gemeinsam verwendbaren Objekten

Ein gemeinsam verwendbares Objekt ist eine Sammlung von manuellen Testschritten und/oder Schlüsselwörtern, die in einer Bibliothek enthalten sind und von mehreren Tests in mehreren Projekten verwendet werden können.

  • Aufrufen gemeinsam verwendbarer Testschritte
    Hier wird beschrieben, wie ein gemeinsam verwendbares Objekt aus einer Bibliothek als einzelner Testschritt zu einem manuellen Test oder einem anderen gemeinsam verwendbaren Objekt hinzugefügt wird.
  • Erstellen eines gemeinsam verwendbaren Objekts
    Wenn Sie einen Satz mit Testschritten aus einem manuellen Test oder einem gemeinsam verwendbaren Objekt erneut verwenden möchten, erstellen Sie auf der Seite Testschritte ein gemeinsam verwendbares Objekt.
  • Extrahieren gemeinsam verwendbarer Testschritte von Bibliotheken
    Um einen manuellen Test oder ein gemeinsam verwendbares Objekt von anderen gemeinsam verwendbaren Objekten unabhängig zu machen, extrahieren Sie die Testschritte aus den Bibliotheken, welche die gemeinsam verwendbaren Objekte enthalten.
  • Verwalten von Eigenschaften von gemeinsam verwendbaren Testschritten
    Verwalten Sie alle Eigenschaften, die in manuelle Testschritte im gesamten aktiven Projekt übernommen werden können.
  • Hinzufügen oder bearbeiten von manuellen Testschritten
    Bearbeiten Sie auf der Seite Testschritte einen manuellen Testschritt oder fügen Sie einen neuen hinzu.
  • Objekte mit gemeinsam verwendbaren Testschritten exportieren und aktualisieren
    Hier wird beschrieben, wie Objekte mit gemeinsam verwendbaren Testschritten exportiert und aktualisiert werden.
  • Testschritte (Seite)
    Hier werden alle manuellen Testschritte aufgeführt, die in dem ausgewähltem Test oder im ausgewählten gemeinsam verwendbaren Objekt enthalten sind.
Übergeordnetes Thema: Bibliotheken


Aufrufen gemeinsam verwendbarer Testschritte

Um den Wartungsaufwand für dieselben Testschritte in verschiedenen Tests und Projekten zu reduzieren, fügen Sie einem Test oder einem gemeinsam verwendbaren Objekt als einmaligen Testschritt gemeinsam verwendbare Testschritte aus einer Bibliothek hinzu.

In einem gemeinsam verwendbaren Objekt können Sie nur einen Aufruf an alle Testschritte und keine Auswahl an Testschritten hinzufügen. Wenn ein Aufruf an ein gemeinsam verwendbares Objekt hinzugefügt wird, werden alle gemeinsam genutzten Testschritte im aufrufenden Test oder im gemeinsam verwendbaren Objekt als einzelner Testschritt angezeigt. Zusätzliche Testschritte können vor oder nach den aufgerufenen Testschritten hinzugefügt werden. Die ursprünglich gemeinsam verwendeten Testschritte werden nur während der Ausführung des referenzierenden Tests angezeigt. Das gemeinsam verwendbare Objekt kann nicht gelöscht werden. Wenn Sie es löschen möchten, müssen Sie zunächst alle zugehörigen Aufrufe entfernen.

Der Name des gemeinsam verwendbaren Objekts, dessen Testschritte aufgerufen werden, wird als Name des Testschritts auf der Seite Testschritte angezeigt. Klicken Sie auf den Namen, um auf das aufgerufene gemeinsam verwendbare Objekt zuzugreifen.

  • Hinzufügen eines Aufrufs gemeinsam verwendbarer Testschritte
    Fügen Sie einen Aufruf eines gemeinsam verwendbaren Objekts in einem manuellen Test oder in einem anderen gemeinsam verwendbaren Objekt hinzu.
  • Aufruf gemeinsam verwendbarer Testschritte (Dialogfeld)
    Mit Hilfe des Dialogs Aufruf gemeinsam verwendbarer Testschritte können Sie gemeinsam verwendbare Objekte in der Bibliothekshierarchie durchsuchen.
Übergeordnetes Thema: Verwalten von gemeinsam verwendbaren Objekten


Hinzufügen eines Aufrufs gemeinsam verwendbarer Testschritte

So fügen Sie einen Aufruf zu einem gemeinsam verwendbaren Objekt hinzu:

  1. Klicken Sie im Menü auf Tests > Detailansicht, um die gemeinsam verwendbaren Schritte zu einem Test hinzuzufügen, oder klicken Sie auf Tests > Bibliotheken, um die Testschritte zu einem anderen gemeinsam verwendbaren Objekt hinzuzufügen.
  2. Klicken Sie in der entsprechenden Hierarchie auf den Knoten, dem Sie die gemeinsam verwendbaren Testschritte hinzufügen möchten.
  3. Klicken Sie auf die Registerkarte Testschritte.
  4. Um die gemeinsam verwendbaren Testschritte am Ende der Liste mit den Testschritten hinzuzufügen, klicken Sie auf Neuer Aufruf gemeinsam verwendbarer Testschritte. Um sie oberhalb des ausgewählten Testschritts einzufügen, klicken Sie auf Aufruf gemeinsam verwendbarer Testschritte einfügen. Das Dialogfeld Aufruf gemeinsam verwendbarer Testschritte wird geöffnet.
  5. Wählen Sie in der Hierarchie den Knoten aus, dessen gemeinsam verwendbare Testschritte Sie hinzufügen möchten.
    Anmerkung: Bei einem Test werden in der Hierarchie nur die Bibliotheken angezeigt, die im aktiven Projekt sichtbar sind. Weitere Informationen finden Sie auf der Seite Sichtbarkeit.
  6. Klicken Sie auf OK.
Übergeordnetes Thema: Aufrufen gemeinsam verwendbarer Testschritte
Zugehörige Verweise
Bibliotheken für Projekte verfügbar machen


Aufruf gemeinsam verwendbarer Testschritte (Dialogfeld)

Mit Hilfe des Dialogs Aufruf gemeinsam verwendbarer Testschritte können Sie gemeinsam verwendbare Objekte in der Bibliothekshierarchie durchsuchen. Wählen Sie zum Öffnen des Dialogs in der Testhierarchie einen manuellen Test oder in der Bibliothekshierarchie ein gemeinsam verwendbares Objekt aus. Klicken Sie auf die Registerkarte Testschritte und dann auf Neuer Aufruf gemeinsam verwendbarer Testschritte.

Um in der Bibliothekshierarchie nach vorhandenen Bibliotheken, Ordnern und gemeinsam verwendbaren Objekten zu suchen, geben Sie im Feld Suchen den gesuchten Namen ein, und drücken Sie Eingabe. Die Groß-/Kleinschreibung wird nicht berücksichtigt, und es kann nach Wortteilen gesucht werden. Die gefundenen Bibliotheken und Ordner werden mit der gesamten untergeordneten Hierarchie angezeigt.

Übergeordnetes Thema: Aufrufen gemeinsam verwendbarer Testschritte


Erstellen eines gemeinsam verwendbaren Objekts

Gemeinsam verwendbare Objekte können in jedem manuellen Test bzw. in jedem gemeinsam verwendbaren Objekt auf der Seite Testschritte erstellt werden.

So erstellen Sie ein gemeinsam verwendbares Objekt:

  1. Klicken Sie für ein gemeinsames Objekt im Menü auf Tests > Bibliotheken. Klicken Sie für Tests im Menü auf Tests > Detailansicht.
  2. Navigieren Sie zur Seite Testschritte mit den gewünschten Testschritten des manuellen Tests bzw. des gemeinsam verwendbaren Objekts.
  3. Wählen Sie die Schritte mit Strg+Klick oder Umschalttaste+Klick aus.
  4. Klicken Sie auf Gemeinsam verwendbare Testschritte erzeugen. Der Dialog Gemeinsam verwendbare Testschritte erzeugen wird geöffnet.
  5. Geben Sie im Feld Name den Namen des neuen gemeinsam verwendbaren Objekts ein.
  6. Wählen Sie aus, wo in der Bibliothekshierarchie das neue Objekt gespeichert werden soll.
  7. Klicken Sie auf OK. Das gemeinsam verwendbare Objekt wird erstellt, und die ausgewählten Testschritte werden durch einen Aufruf dieses Objekts ersetzt.
Übergeordnetes Thema: Verwalten von gemeinsam verwendbaren Objekten


Extrahieren gemeinsam verwendbarer Testschritte von Bibliotheken

Um einen manuellen Test oder ein gemeinsam verwendbares Objekt von anderen gemeinsam verwendbaren Objekten unabhängig zu machen, extrahieren Sie die Testschritte aus den Bibliotheken, welche die gemeinsam verwendbaren Objekte enthalten. Alle aufgerufenen Testschritte werden dann in den manuellen Test oder das gemeinsam verwendbare Objekt kopiert.

So extrahieren Sie die in einem manuellen Test oder einem gemeinsam verwendbaren Objekt enthaltenen gemeinsam verwendbaren Testschritte:

  1. Klicken Sie für ein gemeinsames Objekt im Menü auf Tests > Bibliotheken. Klicken Sie für Tests im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der jeweiligen Hierarchie auf den Knoten, in dem die gemeinsam verwendbaren Schritte aufgelöst werden sollen.
  3. Klicken Sie auf die Registerkarte Testschritte.
  4. Wählen Sie die zu extrahierenden Schritte mit Strg+Klick oder Umschalttaste+Klick aus.
  5. Klicken Sie auf Aus Bibliothek herauslösen und bestätigen Sie den Vorgang im Meldungsfeld.
Übergeordnetes Thema: Verwalten von gemeinsam verwendbaren Objekten


Verwalten von Eigenschaften von gemeinsam verwendbaren Testschritten

Tests > Testschritteigenschaften

Tests > Bibliotheken > <Bibliothek> > Testschritteigenschaften

Sie können Eigenschaften von Testschritten in gemeinsam verwendbaren Objekten in der Bibliothekshierarchie erstellen, bearbeiten oder anzeigen, indem Sie die Bibliothek auswählen und auf die Registerkarte Testschritteigenschaften klicken. Auf der Seite Testschritteigenschaften werden die Eigenschaften angezeigt, die für manuelle Testschritte im aktiven Projekt verfügbar sind. Um eine neue Testschritteigenschaft zu erstellen, klicken Sie auf Neue Eigenschaft. Folgende Aktionen können auf eine Eigenschaft ausgeführt werden: Löschen, Nach oben und Nach unten.

Übergeordnetes Thema: Verwalten von gemeinsam verwendbaren Objekten
Zugehörige Konzepte
Testschritteigenschaften


Objekte mit gemeinsam verwendbaren Testschritten exportieren und aktualisieren

Wenn Sie umfangreiche Änderungen an vorhandenen Objekten mit gemeinsam verwendbaren Testschritten vornehmen möchten, verwenden Sie die Funktion Export-Aktualisierung nach Excel.

Export und Aktualisierung – Überblick

Nachfolgend erhalten Sie einen allgemeinen Überblick über das Exportieren und Aktualisieren:

  • Wählen Sie die Bibliothek aus.
  • Führen Sie den Export nach Excel aus.
  • Nehmen Sie die Änderungen in Excel vor.
  • Überprüfen/erstellen Sie die Zuordnungsdatei.
  • Führen Sie die Aktualisierung in Silk Central aus.
  • Exportieren von Objekten mit gemeinsam verwendbaren Testschritten nach Excel
    Exportieren Sie Objekte mit gemeinsam verwendbaren Testschritten nach Excel, um umfangreiche Änderungen vornehmen zu können.
  • Aktualisieren von Objekten mit gemeinsam verwendbaren Testschritten aus Excel
    Nachdem Sie Objekte mit gemeinsam verwendbaren Testschritten in Excel bearbeitet haben, aktualisieren Sie diese in Silk Central.
Übergeordnetes Thema: Verwalten von gemeinsam verwendbaren Objekten


Exportieren von Objekten mit gemeinsam verwendbaren Testschritten nach Excel

Exportieren Sie Objekte mit gemeinsam verwendbaren Testschritten nach Excel, um umfangreiche Änderungen vornehmen zu können.
  1. Klicken Sie im Menü auf Tests > Bibliotheken.
  2. Klicken Sie mit der rechten Maustaste auf die Bibliothek, in der sich die Objekte mit gemeinsam verwendbaren Testschritten befinden, die Sie exportieren möchten. Wählen Sie dann Exportieren nach Excel. Der Dialog Bibliothek in Excel-Datei exportieren wird angezeigt.
  3. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist LibraryPropertiesDefaultMapping.xml.
  4. Klicken Sie auf Zuordnung bearbeiten, um die Zuordnungsdatei zu bearbeiten. Der Dialog Zuordnung bearbeiten wird angezeigt.
  5. Geben Sie an welche Excel-Spalten den Eigenschaften und Testschritteigenschaften (falls vorhanden) zugeordnet werden sollen. Das folgende Beispiel soll die Zuordnung verdeutlichen:

    Zuordnung von Testschritteigenschaften

  6. Im Feld Speichern unter können Sie optional den Namen der Zuordnungsdatei ändern. Klicken Sie auf OK. Der Dialog Bibliothek in Excel-Datei exportieren wird angezeigt.
  7. Klicken Sie auf OK. Die Excel-Datei wird erzeugt und in Ihrem Browser heruntergeladen.
Öffnen Sie die Excel-Datei und bearbeiten Sie Ihre Objekte mit gemeinsam verwendbaren Testschritten. Speichern Sie die Datei, wenn Sie bereit sind Ihre Änderungen nach Silk Central hochzuladen.

Einschränkungen: Wenn Sie in Excel Objekte mit gemeinsam verwendbaren Testschritten erstellen, löschen oder verschieben, werden diese Änderungen beim Aktualisieren in Silk Central ignoriert.

Übergeordnetes Thema: Objekte mit gemeinsam verwendbaren Testschritten exportieren und aktualisieren
Zugehörige Tasks
Aktualisieren von Objekten mit gemeinsam verwendbaren Testschritten aus Excel
Zugehörige Verweise
Verwalten von Eigenschaften von gemeinsam verwendbaren Testschritten


Aktualisieren von Objekten mit gemeinsam verwendbaren Testschritten aus Excel

Nachdem Sie Objekte mit gemeinsam verwendbaren Testschritten in Excel bearbeitet haben, aktualisieren Sie diese in Silk Central.
  1. Klicken Sie im Menü auf Tests > Bibliotheken.
  2. Klicken Sie mit der rechten Maustaste auf die Bibliothek, in der sich die Objekte mit gemeinsam verwendbaren Testschritten befinden, die Sie aktualisieren möchten. Wählen Sie dann Aus Excel aktualisieren. Der Dialog Bibliothek mit Excel-Datei aktualisieren wird angezeigt.
  3. Wählen Sie im Listenfeld Zuordnungs-Datei wählen die Zuordnungsdatei aus. Die Standardzuordnungsdatei ist LibraryPropertiesDefaultMapping.xml.
  4. Optional: Klicken Sie auf Zuordnung bearbeiten, um die Zuordnungsdatei zu bearbeiten. Dies ist nur nötig, wenn die Zuordnungsdatei für das Exportieren der Objekte mit gemeinsam verwendbaren Testschritten verändert wurde, oder wenn die Kopfzeilen der Spalten in der Excel-Datei verändert wurden. Weitere Informationen über die Zuordnung von Eigenschaften finden Sie unter Exportieren von Objekten mit gemeinsam verwendbaren Testschritten nach Excel.
  5. Klicken Sie auf Datei auswählen, um die gewünschte Excel-Datei in dem Feld Bibliotheks-Datei (.xlsx) auszuwählen.
  6. Klicken Sie auf OK. Ihre Änderungen werden in Silk Central aktualisiert.
Übergeordnetes Thema: Objekte mit gemeinsam verwendbaren Testschritten exportieren und aktualisieren
Zugehörige Tasks
Exportieren von Objekten mit gemeinsam verwendbaren Testschritten nach Excel
Zugehörige Verweise
Verwalten von Eigenschaften von gemeinsam verwendbaren Testschritten


Bibliotheksverlauf (Seite)

Auf der Seite Verlauf wird der Verlauf des ausgewählten gemeinsam verwendbaren Objekts angezeigt.

Die Seite Verlauf enthält bei einem gemeinsam verwendbaren Objekt einen Eintrag für jede Objektversion und lässt Sie neue Versionen erstellen, Versionsdetails anzeigen, auf frühere Versionen zurücksetzen und Versionsunterschiede anzeigen.

Wenn Sie auf der Seite Verlauf nur Versionen und keine anderen Einträge anzeigen möchten, öffnen Sie das Kontextmenü der Kopfzeile der Spalte Version und wählen den Filter aus. Anschließend geben Sie 0 in das Feld > ein.

Auf der Seite werden für die einzelnen Einträge die folgenden Elemente aufgeführt:

Element | Beschreibung
Aktionen | Nur für Versionseinträge. Die Aktionen, die für eine ausgewählte Version ausgeführt werden können, sind Version anzeigen, Version löschen und Version wiederherstellen.
Version | Nur für Versionseinträge. Die Version des gemeinsam verwendbaren Objekts.
Kommentar | Ein Kommentar zu den Änderungen.
Erstellt am | Datum und Uhrzeit, an dem bzw. zu der dieser Historieneintrag erstellt wurde.
Erstellt von | Name des Benutzers, der diesen Historieneintrag erstellt hat.
Übergeordnetes Thema: Versionen


Zuordnen von Anforderungen zu Tests

Verbinden Sie Ihre Anforderungen und Tests, um messen zu können, wie gut Ihre Software die definierten Anforderungen erfüllt.
  • Zuordnen von Anforderungen zu Tests
    Ordnen Sie eine Anforderung einem Test zu, wenn die Anforderung vom Test abgedeckt werden soll.
  • Sortieren von zugeordneten Anforderungen
    Sortieren Sie die zugeordneten Anforderungen, um die Seite Zugeordnete Anforderungen an Ihre Anforderungen anzupassen.
  • Suchen nach zugeordneten Anforderungen
    Suchen Sie in der Hierarchie Verfügbare Anforderungen nach einer zugeordneten Anforderung, um sie einem Tests zuzuordnen.
  • Entfernen von Anforderungszuordnungen
    Entfernen Sie eine Anforderungszuordnung, wenn der Test die Anforderung nicht mehr abdeckt.
  • Zugeordnete Anforderungen (Seite)
    Hier werden die Anforderungen aufgelistet, die den ausgewählten Tests oder dem ausgewählten Projekt zugeordnet sind.
Übergeordnetes Thema: Tests


Zuordnen von Anforderungen zu Tests

So ordnen Sie Anforderungen manuell Tests zu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Test aus, den Sie Anforderungen zuordnen möchten.
  3. Klicken Sie auf die Registerkarte Zugeordnete Anforderungen.
    Anmerkung: Wenn Sie einen Anforderungsfilter erstellt haben, können Sie diesen in der Filterliste oberhalb der Hierarchie Anforderungen auswählen. Um einen neuen Anforderungsfilter zu erstellen, klicken Sie im Menü auf Anforderungen > Detailansicht, und klicken Sie in der Symbolleiste auf Neuer Filter.
    Die Anforderungen, die Sie zuordnen können, werden in der Hierarchie Anforderungen angezeigt.
  4. Wählen Sie die Anforderungen aus, die Sie zuordnen möchten. Sie können mit den Tasten Strg und Umschalt entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Anforderungen auswählen.
  5. Klicken sie auf Gefilterte Anforderungen zuweisen um alle gefilterten Anforderungen dem ausgewählten Test zuzuordnen. Sie können Ihre Auswahl auch in den Bereich Zugeordnete Anforderungen ziehen und ablegen, oder neben einer Anforderung auf Zuordnen klicken. Das Zuordnen mehrerer gefilterter Anforderungen ist nur möglich, wenn ein Filter ausgewählt ist und Sie die Berechtigungen Verwalten von Anforderungen oder Tests und Ausführungen Verwalten besitzen.
    Anmerkung: Wenn im Dialogfeld Testplan aus Anforderungen erzeugen die Option Neu erzeugte Tests zu Anforderungen zuordnen aktiviert ist, werden die neuen Tests automatisch den entsprechenden Anforderungen zugeordnet. Dies ist die Standardeinstellung.
Übergeordnetes Thema: Zuordnen von Anforderungen zu Tests
Zugehörige Tasks
Erzeugen von Tests aus der Anforderungsansicht


Sortieren von zugeordneten Anforderungen

So sortieren Sie die zugeordneten Anforderungen:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie eine Test aus.
  3. Klicken Sie auf die Registerkarte Zugeordnete Anforderungen.
  4. Klicken Sie auf die Spaltenüberschrift der Eigenschaft, nach der die Anforderungen sortiert werden sollen. An einem kleinen Abwärts- oder Aufwärtspfeil ist zu erkennen, ob in ab- oder aufsteigender Reihenfolge sortiert wird.
  5. Klicken Sie bei Bedarf erneut auf die Spaltenüberschrift, um die Sortierreihenfolge umzudrehen.
Übergeordnetes Thema: Zuordnen von Anforderungen zu Tests


Suchen nach zugeordneten Anforderungen

So suchen Sie in der Hierarchie Verfügbare Anforderungen nach zugeordneten Anforderungen:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie eine Test aus.
  3. Klicken Sie auf die Registerkarte Zugeordnete Anforderungen.
  4. Um zu ermitteln, in welchem Knoten der Hierarchie Verfügbare Anforderungen die Anforderung gespeichert ist, klicken Sie in der Spalte Aktionen auf Suchen.
Der Knoten der übergeordneten Anforderung wird erweitert, und die zugeordnete Anforderung wird blau hervorgehoben angezeigt.
Übergeordnetes Thema: Zuordnen von Anforderungen zu Tests


Entfernen von Anforderungszuordnungen

So entfernen Sie eine Anforderungszuordnung:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie einen Test aus, der mindestens eine Anforderung zugeordnet ist.
  3. Klicken Sie auf die Registerkarte Zugeordnete Anforderungen.
  4. Klicken Sie in der Spalte Aktionen der zugeordneten Anforderung auf Löschen, oder wählen Sie mit Strg+Klick oder Umschalt+Klick mehrere Anforderungen aus und drücken Sie die Entf-Taste.
    Anmerkung: Wenn Sie alle Anforderungszuordnungen des ausgewählten Tests entfernen möchten, klicken Sie auf Alles entfernen.
Übergeordnetes Thema: Zuordnen von Anforderungen zu Tests


Zugeordnete Anforderungen (Seite)

Tests > Detailansicht > <Testelement> > Zugeordnete Anforderungen

Auf der Seite Zugeordnete Anforderungen werden die Anforderungen angezeigt, die dem Test oder dem Projekt zugeordnet sind. Hier können Sie auch weitere Anforderungen hinzufügen. In der Hierarchie Verfügbare Anforderungen werden alle Anforderungen aufgelistet, die zugeordnet werden können.

Anmerkung: Wenn Sie einen Anforderungsfilter erstellt haben, können Sie diesen in der Filterliste oberhalb der Hierarchie Anforderungen auswählen. Um einen neuen Anforderungsfilter zu erstellen, klicken Sie im Menü auf Anforderungen > Detailansicht, und klicken Sie in der Symbolleiste auf Neuer Filter.

Für jede zugeordnete Anforderung werden folgende Spalten auf der Seite angezeigt:

Spalte | Beschreibung
Aktionen | Aktionen, die Sie mit der ausgewählten Anforderung ausführen können. Anforderung entfernen, Suchen und Beschreibung anzeigen.
Anforderung | Der Name der zugeordneten Anforderung. Klicken Sie darauf, um die Seite Anforderungen > Eigenschaften zu öffnen.
Priorität | Die Priorität der Anforderung.
Risiko | Das potenzielle Risiko der Anforderung.
Geprüft | Der Überprüfungsstatus der Anforderung.
Übergeordnetes Thema: Zuordnen von Anforderungen zu Tests


Testberichte

In diesem Abschnitt werden die mit Silk Central installierten Testberichte beschrieben. Die Testberichte liefern einen Überblick über den Fortschritt bei den Tests und den Status der Fehler in einem bestimmten Zeitfenster und Build-Bereich.

  • Statusberichte
    Hier werden die im Bereich Tests verfügbaren Statusberichte beschrieben.
  • Fortschrittsberichte
    Hier werden die im Bereich Tests verfügbaren Fortschrittsberichte beschrieben.
  • Berichte für manuelle Tests
    Hier werden die im Bereich Tests verfügbaren Berichte für manuelle Tests beschrieben.
  • Baseline-Testvergleichsbericht
    Im Bericht Baseline-Test-Vergleich wird ein Projekt mit der Projekt-Baseline verglichen und die Anzahl geänderter, gelöschter und erstellter Tests angezeigt.
  • Vergleichsbericht zu Testläufen
    Vergleichsberichte zu Testläufen vergleichen die letzten beiden Testläufe eines Tests und liefern detaillierte Informationen zu Kontext, Status, Fehlern, Warnungen, Dauer, Eigenschaften, Attributen, Parametern und Erfolgsbedingungen.
Übergeordnetes Thema: Tests
Übergeordnetes Thema: Standardberichte


Statusberichte

Folgende Statusberichte sind im Bereich Tests verfügbar:
Tests pro Komponente
Zeigt eine Übersicht über die Komponentenabdeckung der Tests. Dadurch kann ermittelt werden, welche Testaktivitäten erforderlich sind.
Implementierte Tests (pro Komponente)
Zeigt eine Übersicht über die Komponentenabdeckung der Tests, deren Attribut "Implementiert" den Wert "Ja" hat.
Fehlgeschlagene Tests (pro Komponente)
Zeigt eine Übersicht über die fehlgeschlagenen Tests pro Komponente. Dadurch können die kritischsten Komponenten in der Umgebung ermittelt werden.
Bestandene Tests (pro Container)
Zeigt eine Erfolgsquote für jeden Container anhand der Anzahl der bestandenen Tests.
Qualitätsziel-Planungsbericht

Stellt die Anzahl der Tests in jedem Zielkriterium zusammen mit der geplanten Dauer bis zum Zielkriterium.

Anmerkung: Der Wert für die geplante Dauer gilt nur für manuelle Tests. Für automatisierte Tests wird keine geplante Dauer angegeben.

Dieser Bericht wird für jedes in einem Projekt definiertes Qualitätskriterium auf drei verschiedenen Wegen geteilt:

  • Testing Scope – Vergleicht die Gesamtzahl der verfügbaren Tests gegen die Gesamtanzahl der benötigten Tests für jedes Element eines Qualitätskriteriums.
  • Required Planned Time – Vergleicht die benötigte Plannungszeit zwischen den Elementen der Qualitätskriterien.
  • Wertetabelle - Zeigt die Qualitätsziele von Tests und zugehörige Metriken an: Verfügbar, Qualitätsziel (%), Benötigt und Geplante Dauer für manuelle Tests.
Anmerkung: Für ein(e) Mehrfachauswahl-Attribut/Eigenschaft wird der Test für jeden zutreffenden Vorfall gezählt.
Qualitätsziel-Ausführungsbericht
Zeigt die Anzahl der für jedes einzelne Zielitem ausgeführten Tests an. Dieser Bericht ist in zwei Bereiche für jedes in einem Projekt definierte Qualitätsziel unterteilt.
  • Tabelle Ausführungsstatus - zeigt eine Liste mit allen Elementen der Qualitätsziele mit als Farbcode dargestelltem Ausführungsstatus und einem zusammenfassenden Wert an.
  • Wertetabelle - Zeigt die Qualitätsziele von Tests und ihre Ausführungsmetriken an: Bestanden, Fehlgeschlagen, Nicht ausgeführt, N/V, Gesamt, Tests bis zur Zielerreichung und Ausführungs-% zur Zielerreichung.
Statusübersicht für Tests
Zeigt eine Übersicht über den Status (Bestanden, Fehlgeschlagen, Nicht ausgeführt oder N/V) aller Tests.
Statusübersicht für Tests (pro Container)
Zeigt eine Übersicht über den Status (Bestanden, Fehlgeschlagen, Nicht ausgeführt oder N/V) aller Tests in einem bestimmten Container.
Übergeordnetes Thema: Testberichte


Fortschrittsberichte

Folgende Fortschrittsberichte sind im Bereich Tests verfügbar:
Testfortschritt in den Builds 'X' bis 'Y'
Der Fortschrittstrend der Tests wird anhand von den Statuswerten der jeweiligen Builds ausgegeben. Dazu muss das Start- und das End-Build für den Bereich festgelegt werden.
Abdeckung für manuelle Tests seit Build <X> (kumulativ)
Zeigt einen Fortschrittstrend der manuellen Tests (ohne automatisierte Tests) anhand der Statuswerte der jeweiligen Builds. Dazu muss ein Start-Build festgelegt werden, das als Grundlage der Kumulation dient.
Abdeckung für automatisierte Builds (nicht-kumulativ)
Der Fortschrittstrend der Tests wird anhand von den Statuswerten der jeweiligen Builds ausgegeben. Dazu müssen eine Version und ein Produkt angegeben werden. Der Bericht zeigt die Testabdeckung pro Build, die mit den automatisierten Tests erzielt werden konnte.
Fortschritt für bestimmten Testplanknoten in den letzten <X> Tagen
Zeigt einen Fortschrittstrend der Tests des Testplanknotens mit der angegebenen ID und für die letzten <X> Tage.
Testfortschritt in den letzten 'X' Tagen
Der Fortschrittstrend der Tests wird anhand von deren Statuswerten für die letzten 'X' Tage ausgegeben.
Testfortschritt in diesem Monat
Zeigt einen Fortschrittstrend der Tests anhand von deren Statuswerten für den aktuellen Monat.
Prozentanteil der erfolgreichen Tests in den letzten 'X' Tagen (pro Komponente)
Der prozentuale Anteil der in den letzten 'X' Tagen erfolgreich ausgeführten Tests wird für jede Komponente ausgegeben. Dadurch können die kritischsten Komponenten in der Umgebung ermittelt werden.
In den letzten 'X' Tagen erstellte Tests (pro Komponente)
Eine Liste der Tests, die in den letzten 'X' Tagen für jede Komponente erstellt wurden, wird ausgegeben. Durch diesen Bericht kann ermittelt werden, welche Komponenten noch nicht getestet wurden.
Übergeordnetes Thema: Testberichte


Berichte für manuelle Tests

Hier werden die im Bereich Tests verfügbaren Berichte für manuelle Tests beschrieben.
Verlauf der geplanten und tatsächlichen Ausführungszeit (pro Benutzer)
Zeigt eine Übersicht über die geplante und tatsächliche Ausführungszeit der abgeschlossenen manuellen Tests pro Benutzer für einen bestimmten Zeitraum.
Geplante und tatsächliche Ausführungszeit (Status pro Benutzer)
Zeigt den Fortschritt im Sinne von geplanten gegenüber tatsächlichen Stunden von derzeit ausstehenden manuellen Tests pro Benutzer an. Es werden nur die manuellen Tests berücksichtigt, deren Ergebnis vom zugewiesenen Benutzer eingegeben wurde.
Ergebnisdokument für manuellen Test
Ein druckbarer Testfallbericht der neuesten Ergebnisse über die letzte Ausführung aller Tests, welche der angegebenen Testsuite zugeordnet sind.
Ergebnisdokument für manuellen Test (Microsoft Word).
Ein einfach zu druckender manueller Testfallbericht für die neuesten Ergebnisse aller Tests, die einer bestimmten Testsuite in einem Microsoft Word-Dokument zugewiesen sind.
Ergebnisse manueller Tests nach Testsuite
Ein druckbarer Testfallbericht der neuesten Ergebnisse über die letzte Ausführung aller Tests, welche dem angegebenen Testsuiteordner oder Testzyklus zugeordnet sind.
Geplante und tatsächliche Ausführungszeit manueller Tests (Übersicht)
Zeigt eine tageweise Übersicht über die Abweichung zwischen der geplanten und tatsächlichen Ausführungszeit der manuellen Tests.
Übergeordnetes Thema: Testberichte


Baseline-Testvergleichsbericht

Im Bericht Baseline-Test-Vergleich wird ein Projekt mit der Projekt-Baseline verglichen und die Anzahl geänderter, gelöschter und erstellter Tests angezeigt.

Die Eingabeparameter für den Bericht Baseline-Test-Vergleich sind die Kennungen für das Projekt und die Baseline.

Übergeordnetes Thema: Testberichte
Zugehörige Tasks
Vergleichen eines Projekts mit einer Baseline


Vergleichsbericht zu Testläufen

Vergleichsberichte zu Testläufen vergleichen die letzten beiden Testläufe eines Tests und liefern detaillierte Informationen zu Kontext, Status, Fehlern, Warnungen, Dauer, Eigenschaften, Attributen, Parametern und Erfolgsbedingungen.
Anmerkung: Vergleichsberichte zu Testläufen eignen sich nicht dazu, manuelle mit automatisierten Tests zu vergleichen. Wenn der Name des Berichts (die beiden letzten Testläufe) enthält, können Sie nur die beiden letzten Testläufe der Testsuite oder des Tests vergleichen.
Übergeordnetes Thema: Testberichte


Zugeordnete Testausführungen

Fügen Sie Tests zu Testsuiten hinzu, um Ihre Testausführungen während der Entwicklungs- und der Testphase zu steuern.
  • Anzeigen zugeordneter Testausführungen
    Zeigen Sie alle Testsuiten an, denen der ausgewählte Test zugeordnet ist.
Übergeordnetes Thema: Tests


Anzeigen zugeordneter Testausführungen

So zeigen Sie alle Testsuiten an, denen der ausgewählte Test zugeordnet ist:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test aus, dessen Testsuitenzuordnung angezeigt werden sollen.
  3. Klicken Sie auf die Registerkarte Eigenschaften. Die vollständige Liste der Testsuiten, denen der ausgewählte Test zugeordnet ist, wird in der Tabelle Zugeordnete Testsuiten im Bereich Testausführungen angezeigt.
Übergeordnetes Thema: Zugeordnete Testausführungen
Zugehörige Verweise
Testeigenschaften


Testansichten

Silk Central bietet mehrere Ansichten und Werkzeuge an, mit denen Sie Ihre Tests verwalten können.

  • Arbeiten mit der Testhierarchie
    Hier wird beschrieben, wie die Hierarchie Tests verwendet wird.
  • Funktionen der Testsymbolleiste
    Ermöglicht Zugriff auf wichtige Befehle zum Verwalten von Tests.
  • Tests (Dokumentansicht)
    In der Dokumentansicht werden Informationen zum Status und zu den letzten Ausführungen aller Tests im ausgewählten Projekt angezeigt.
  • Arbeiten mit Tests in der Tabellenansicht
    In diesem Abschnitt wird beschrieben, wie Sie in der Tabellenansicht mit Tests arbeiten.
Übergeordnetes Thema: Tests


Arbeiten mit der Testhierarchie

Tests > Detailansicht

Die Tests werden wie Anforderungen in einer hierarchischen Struktur (die Hierarchie Tests) angezeigt, organisiert und verwaltet. In der Hierarchie Tests können die Tests in verschiedenen Hierarchieebenen organisiert werden. Jeder Knoten in der Hierarchie entspricht entweder einem Test, einem Ordner oder einem Container.

Anmerkung: Wenn die Seite mehr Elemente enthält, als gleichzeitig ohne Verschlechterung der Reaktionszeit angezeigt werden können, werden die Elemente stufenweise angezeigt. Verwenden Sie die Navigationsleiste unten auf der Seite, um die Elemente zu durchsuchen.
  • Tastaturfunktionen (Tests)
    Die Hierarchie kann mit der Tastatur bedient werden und unterstützt die Mehrfachauswahl.
  • Ausblenden und Erweitern der Testhierarchie
    Hier wird beschrieben, wie die verschiedenen Hierarchieebenen der Testhierarchie ausgeblendet und erweitert werden können.
  • Ausschneiden, Kopieren, Einfügen und Löschen von Testelementen
    Sie können Testelemente ausschneiden, kopieren, einfügen und löschen, um die Tests Ihres Projekts zu erstellen und zu verwalten.
  • Kopieren und Einfügen eines Testelements von einem Projekt in ein anderes
    Kopieren Sie ein Testelement aus einem Projekt, und fügen Sie es in ein anderes Projekt ein, um das Element in mehreren Projekten zu nutzen.
  • Gemeinsame Verwendung von Testobjekten aus Repository-Projekten
    Verwalten Sie gängige Testobjekte in einem Repository-Projekt und verwenden diese in anderen Projekten wieder.
  • Anordnen von Testelementen
    Hiermit können Sie Tests, Testordner und Testcontainer in der Hierarchie Tests auf Ihre Testanforderungen anpassen.
  • Festlegen des Standardintegrationstestknotens für externe agile Planungssysteme
    Legen Sie einen Knoten in der Testhierarchie als Standardintegrationsknoten für die Erstellung von Tests in Silk Central mit einem externen agilen Planungssystem fest.
  • Filtern nach einem Ordner oder Container
    Filtern Sie nach einem Ordner oder Container, um nur die Inhalte des Ordners oder Containers anzuzeigen.
  • Suchen von Testeigenschaften
    Suchen Sie nach einem bestimmten Eigenschaftswert, um alle Tests mit diesem Wert anzuzeigen.
  • Ersetzen von Testeigenschaften
    Hiermit können Sie nach einem bestimmten Eigenschaftswert suchen, um ihn in allen Tests, die diesen Wert enthalten, zu ersetzen.
  • Inhalt (Seite)
    Hier werden die untergeordneten Elemente des ausgewählten Projekts, Containers oder Ordners angezeigt.
Übergeordnetes Thema: Testansichten


Tastaturfunktionen (Tests)

Die folgenden Aktionen können für die ausgewählten Knoten ausgeführt werden:

Taste | Aktion
Aufwärts | Auswahl nach oben
Abwärts | Auswahl nach unten
Rechts | Element erweitern
Links | Untergeordnete Elemente ausblenden
F2 | Element bearbeiten
Strg+C | Element kopieren
Strg+X | Element ausschneiden
Strg+V | Element einfügen
Entf | Element löschen
Strg+Nach oben | Element nach oben verschieben
Strg+Nach unten | Element nach unten verschieben
Klicken | Ein Element markieren und als aktuelles Element merken.
Strg+Klick | Den Auswahlstatus des gewählten Elements ein- und ausschalten und mit weiteren Klicks weitere Elemente hinzufügen/entfernen.
Umschalt+Klick | Auswahl vom aktuell markierten Element bis zum neu angeklickten Element erweitern.
Umschalt+Nach oben | Das darüberliegende Element auswählen.
Umschalt+Nach unten | Das darunterliegende Element auswählen.
Eingabe | Element zuordnen (nur in den Zuordnungshierarchien)
Übergeordnetes Thema: Arbeiten mit der Testhierarchie


Ausblenden und Erweitern der Testhierarchie

Sie können je nach Bedarf die Ebenen in der Testhierarchie erweitern oder ausblenden.

So können Sie die Hierarchieebenen der Testhierarchie erweitern und ausblenden:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container oder Ordner aus, und fahren Sie mit einer der folgenden Optionen fort:
    • Klicken Sie auf Erweitern links neben dem Namen des Testelements, um das Element zu erweitern.
    • Klicken Sie auf Erweitern links neben dem Namen des Testelements, um das Element auszublenden.
    • Klicken Sie mit der rechten Maustaste auf das Element, und wählen Sie Erweitern oder Ausblenden aus.
Übergeordnetes Thema: Arbeiten mit der Testhierarchie


Ausschneiden, Kopieren, Einfügen und Löschen von Testelementen

Sie können über die Symbolleiste des Testbereichs bequem Testelemente in der Testhierarchie löschen, ausschneiden, kopieren und einfügen. Die Elemente können im selben Projekt oder in einem anderen Projekt eingefügt werden. Durch diese Bearbeitungsfunktionen wird das Erstellen und Verwalten der Tests Ihres Projekts vereinfacht.

Die Eigenschaften, Attribute, Parameter und Anhänge werden automatisch zusammen mit den Tests und Ordnern kopiert. Zuordnungen, Fehler, Testläufe und die Historie werden nicht kopiert.

Anmerkung: Container können nicht kopiert und eingefügt werden.

So schneiden Sie Testelemente aus, kopieren sie, fügen sie ein oder löschen sie:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests die Tests aus, die Sie bearbeiten möchten. Mehrere Elemente können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  3. Klicken Sie auf die Schaltfläche für die gewünschte Bearbeitungsfunktion:
    Schaltfläche
    Beschreibung
    Die ausgewählten Elemente werden in der Hierarchie gelöscht.
    Das ausgewählten Elemente werden ausgeschnitten und in der Zwischenablage gespeichert.
    Die ausgewählten Elemente werden in die Zwischenablage kopiert.
    Eine Kopie der Elemente in der Zwischenablage wird auf derselben Ebene des ausgewählten Elements eingefügt.
    Als untergeordnetes Element einfügen
    Eine Kopie der Elemente in der Zwischenablage wird als Unterknoten des ausgewählten Elements eingefügt.
    Anmerkung: Diese Befehle sind auch in den Kontextmenüs der Testhierarchie und über Tastenkürzel verfügbar.
Übergeordnetes Thema: Arbeiten mit der Testhierarchie
Zugehörige Verweise
Inhalt (Seite)


Kopieren und Einfügen eines Testelements von einem Projekt in ein anderes

So kopieren Sie einen Testordner oder einen Test zwischen Projekten:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Quellprojekt aus.
  3. Klicken Sie im Menü auf Tests > Detailansicht.
  4. Klicken Sie auf Ausschneiden, um das Element auszuschneiden, oder klicken Sie auf Kopieren, um das Element in die Zwischenablage zu kopieren.
  5. Klicken Sie im Menü auf Projekte > Projektliste.
  6. Wählen Sie das Zielprojekt aus.
  7. Wählen Sie den Zielordner und/oder den Zielcontainer aus.
  8. Klicken Sie auf Einfügen.
Anmerkung: Diese Befehle sind auch in den Kontextmenüs der Testhierarchie und über Tastenkürzel verfügbar.
Übergeordnetes Thema: Arbeiten mit der Testhierarchie


Anordnen von Testelementen

So ordnen Sie Tests, Testordner oder Testcontainer an:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests das Testelement, das Sie neu anordnen möchten.
  3. Klicken Sie auf Nach oben , um das gewählte Testelement einen Schritt nach oben zu bewegen, oder klicken Sie auf Nach unten , um das Testelement einen Schritt nach unten zu bewegen.
Übergeordnetes Thema: Arbeiten mit der Testhierarchie


Festlegen des Standardintegrationstestknotens für externe agile Planungssysteme

Damit in Silk Central mithilfe von Webdienstaufrufen Tests über ein externes agiles Planungssystem erstellt werden können, legen Sie einen Ordner oder Container in der Testhierarchie fest, der als Standardintegrationsknoten für die Tests dient. Wenn Sie keinen Standardintegrationsknoten angeben, wird eine Fehlermeldung angezeigt.

So legen Sie den Standardintegrationsknoten in der Testhierarchie fest:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Ordner oder den Container aus, den Sie als Integrationsstandardknoten festlegen möchten.
  3. Klicken Sie mit der rechten Maustaste auf den Ordner oder den Container, und wählen Sie Als Standard-Integrationsordner setzen aus.
    Anmerkung: Ist bereits ein Standardintegrationsknoten vorhanden, wird der neue Knoten als Standardknoten verwendet.
Der angegebene Standardintegrationsknoten wird aktiviert, und das externe agile Planungssystem kann Tests in diesem Speicherort erstellen.
Anmerkung: Der Standardintegrationsknoten wird auf der Seite Eigenschaften des Projekts angezeigt, in dem sich der Knoten befindet.
Übergeordnetes Thema: Arbeiten mit der Testhierarchie
Zugehörige Verweise
Testeigenschaften


Filtern nach einem Ordner oder Container

So filtern Sie nach einem Ordner oder Container:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste in der Hierarchie auf die Ordner oder den Container, nach dem Sie filtern möchten, und wählen Sie Untergeordnete Hierarchie filtern aus. In der Hierarchie werden nur die Inhalte des ausgewählten Ordners oder Containers und die Hierarchie bis zum Stammknoten der Hierarchie angezeigt.
Anmerkung: Wenn Sie den Filter entfernen und wieder alle Elemente anzeigen möchten, klicken Sie im Listenfeld Filter auf <Kein Filter>. Leere Ordner werden in der gefilterten untergeordneten Hierarchie nicht angezeigt.
Übergeordnetes Thema: Arbeiten mit der Testhierarchie


Suchen von Testeigenschaften

Sie können im Bereich Tests mit dem Befehl Suchen nach Werten von Testeigenschaften suchen, die bestimmten Suchkriterien entsprechen. Mit den Funktionen Weiter, Zurück, Anfang und Ende wechseln Sie zwischen allen gefundenen Vorkommen der angegebenen Eigenschaftswerte. Die Funktion Suchen steht in allen Plug-Ins und Funktionskategorien von Silk Central zur Verfügung.

Anmerkung: Datengetriebene Testeigenschaftswerte können mithilfe des Befehls Suchen gefunden werden.
Anmerkung: Wenn die Testhierarchie durch einen Filter eingeschränkt ist, wird die Funktion Suchen nur für diejenigen Tests ausgeführt, die nach der Filterung in der Testhierarchie verbleiben.

So suchen Sie einen bestimmten Wert einer Testeigenschaft:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Symbolleiste auf Suchen. Der Dialog Suchen wird angezeigt.
  3. Wählen Sie im Listenfeld Kategorie die funktionale Kategorie oder das Silk Central-Plug-In aus, das Sie durchsuchen möchten.
    Tipp: Wenn eine benutzerdefinierte Plug-In-Eigenschaft definiert wird, wird diese automatisch der Liste hinzugefügt.
  4. Wählen Sie im Listenfeld Suchen in die Eigenschaft aus, in der der Wert gesucht werden soll. Die in dieser Liste verfügbaren Eigenschaften variieren abhängig von der ausgewählten Kategorie.
  5. Geben Sie im Feld Suchen nach die Zeichenfolge ein, nach der gesucht werden soll.

    Optionale Einstellungen sind zur weiteren Qualifizierung der Suche verfügbar. Aktivieren Sie die entsprechenden Kontrollkästchen:

  6. Wählen Sie den Ort in der Testhierarchie aus, an dem Sie die Suche beginnen möchten. Folgende Optionen sind verfügbar:
    Optionsfeld
    Beschreibung
    Bei Auswahl beginnen
    Legt fest, dass die Suche bei dem aktuell ausgewählten Testelement beginnt.
    Beim Anfang beginnen
    Legt fest, dass die Suche beim obersten Element in der Testhierarchie beginnt.
    Nur in untergeordneten Hierarchien suchen
    Legt fest, dass die Suche nur in der Unterhierarchie durchgeführt wird, für die das ausgewählte Element der Testhierarchie Stammknoten ist.
  7. Aktivieren Sie die entsprechenden Kontrollkästchen, um die Abfrage weiter einzugrenzen. Folgende Kontrollkästchen stehen zur Verfügung:
    Auswahlfeld
    Beschreibung
    Groß-/Kleinschreibung beachten
    Legt fest, dass bei der Suche die Groß- und Kleinschreibung berücksichtigt wird.
    Anmerkung: Bei Verwendung eines SQL-Servers, der für die Berücksichtigung der Groß-/Kleinschreibung eingerichtet wurde, wird bei der Suche in den folgenden Feldern nur Groß-/Kleinschreibung berücksichtigt:
    • Testbeschreibung
    • Beschreibung manueller Testschritte
    • Aktionsbeschreibung manueller Testschritte
    • Erwartete Ergebnisse manueller Testschritte
    Nur ganzes Wort suchen
    Legt fest, dass in die Suchergebnisse nur ganze Wörter aufgenommen werden.
    Schreibgeschützte Werte einbeziehen
    Legt fest, dass in die Suchergebnisse Textstrings aufgenommen werden, die nicht direkt bearbeitet werden können, weil sie von einem anderen Test vererbt wurden, von einem verknüpften Container referenziert werden oder von einer Datenquelle beim datengetriebenen Testen aufgerufen werden.
  8. Klicken Sie auf Suchen, um mit der Suche zu beginnen und zum ersten von der Anfrage zurückgegebenen Testcontainer, Testordner oder zum ersten Test zu wechseln.
  9. Wenn Ihre Anfrage mehrere Testelemente ergibt, werden Ihnen mehrere Optionen zur Navigation durch diese Elemente gegeben.
    Anmerkung: Mit dem Befehl Suchen können Sie Testelemente suchen, die den Suchstring als geerbten Wert enthalten.
Übergeordnetes Thema: Arbeiten mit der Testhierarchie
Zugehörige Tasks
Ersetzen von Testeigenschaften


Ersetzen von Testeigenschaften

Mit dem Befehl Ersetzen lassen sich die aufgefundenen Eigenschaftswerte durch neue Werte ersetzen. Die Funktion Ersetzen steht in allen Plug-Ins und Funktionskategorien von Silk Central zur Verfügung.

Anmerkung: Datengetriebene Testeigenschaftswerte können mithilfe des Befehls Ersetzen ersetzt werden.
Anmerkung: Wenn die Testhierarchie gefiltert angezeigt wird, wird Ersetzen nur auf die Tests angewendet, die in der gefilterten Testhierarchie dargestellt werden.

So ersetzen Sie einen bestimmten Wert in den Testeigenschaften:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Symbolleiste auf Ersetzen. Der Dialog Ersetzen wird angezeigt.
  3. Wählen Sie im Listenfeld Kategorie die funktionale Kategorie oder das Silk Central-Plug-In aus, das Sie durchsuchen möchten.
    Tipp: Wenn eine benutzerdefinierte Plug-In-Eigenschaft definiert wird, wird diese automatisch der Liste hinzugefügt.
  4. Wählen Sie im Listenfeld Suchen in die Eigenschaft aus, in der der Wert gesucht werden soll. Die in dieser Liste verfügbaren Eigenschaften variieren abhängig von der ausgewählten Kategorie.
  5. Geben Sie im Feld Suchen nach die Zeichenfolge ein, nach der gesucht werden soll.

    Optionale Einstellungen sind zur weiteren Qualifizierung der Suche verfügbar. Aktivieren Sie die entsprechenden Kontrollkästchen:

  6. Geben Sie im Feld Ersetzen durch die Zeichenfolge ein, durch die die gefundenen Werte ersetzt werden sollen.
  7. Klicken Sie auf Suchen, um mit der Suche zu beginnen und zum ersten von der Anfrage zurückgegebenen Testcontainer, Testordner oder zum ersten Test zu wechseln. Oder klicken Sie auf Alle ersetzen, um alle Vorkommen des gefundenen Strings zu ersetzen.
  8. Wenn Ihre Anfrage mehrere Testelemente ergibt, werden Ihnen mehrere Optionen zur Navigation durch diese Elemente gegeben.
    Anmerkung: Der Befehl Ersetzen ermöglicht Ihnen jedoch nicht die Suche nach Testelementen, deren gesuchte Zeichenkette nur in einem vererbten Wert enthalten ist.
Übergeordnetes Thema: Arbeiten mit der Testhierarchie
Zugehörige Tasks
Suchen von Testeigenschaften


Inhalt (Seite)

Tests > Detailansicht > Inhalt

Auf der Seite Inhalt werden die untergeordneten Elemente des ausgewählten Projekts, Containers oder Ordners in der Hierarchie Tests angezeigt. Die Seite unterstützt die Mehrfachauswahl im Windows Explorer-Stil.

Tipp: Um den Inhalt des ausgewählten Ordners oder Containers anzuzeigen, drücken Sie die Eingabetaste oder doppelklicken Sie auf das ausgewählte Element. Drücken Sie die Rücktaste oder klicken Sie in der Symbolleiste auf Auf, um zur nächsten übergeordneten Ebene zu wechseln.
Anmerkung: Container können nicht kopiert oder eingefügt werden.
Tipp: Elemente auf der Seite Inhalt können genauso wie die in der Testhierarchie aufgeführten Elemente mit der rechten Maustaste angeklickt werden, um auf die Befehle im Kontextmenü zuzugreifen. Befehle, die nicht verfügbar sind, werden abgedunkelt angezeigt. Bevor Sie ein Testelement in die Seite Inhalt einfügen können, müssen Sie auf dieser Registerkarte zuerst ein Element auswählen.
Anmerkung: Wenn die Seite mehr Elemente enthält, als gleichzeitig ohne Verschlechterung der Reaktionszeit angezeigt werden können, werden die Elemente stufenweise angezeigt. Verwenden Sie die Navigationsleiste unten auf der Seite, um die Elemente zu durchsuchen.

Auf der Seite Inhalt werden die folgenden Tastenkombinationen für Testelemente unterstützt:

Taste | Aktion
Oben | Auswahl nach oben
Unten | Auswahl nach unten
Rechts | Auswahl aufheben
Links | Auswahl aufheben
F2 | Element bearbeiten
Strg+A | Alles auswählen
Strg+C | Element kopieren
Strg+X | Element ausschneiden
Strg+V | Element einfügen
Entf | Element löschen
Strg+Nach oben | Element nach oben verschieben
Strg+Nach unten | Element nach unten verschieben
Klicken | Ein Element markieren und als aktuelles Element merken.
Strg+Klick | Den Auswahlstatus des gewählten Elements ein- und ausschalten und mit weiteren Klicks weitere Elemente hinzufügen/entfernen.
Umschalt+Klick | Auswahl vom aktuell markierten Element bis zum neu angeklickten Element erweitern.
Umschalt+Nach oben | Auswahl nach oben erweitern
Umschalt+Nach unten | Auswahl nach unten erweitern
Pos1 | Ersten Eintrag auswählen
Umschalt+Pos1 | Bis zum ersten Eintrag auswählen
Ende | Letzten Eintrag auswählen
Umschalt+Ende | Bis zum letzten Eintrag auswählen
Übergeordnetes Thema: Arbeiten mit der Testhierarchie


Funktionen der Testsymbolleiste

Tests > Detailansicht

In der Testsymbolleiste können Sie auf die wichtigsten Befehle für die Arbeit mit Tests zugreifen.

Anmerkung: Die Befehle in der Testsymbolleiste sind in der Testhierarchie auch in Kontextmenüs verfügbar.

Die folgenden Befehle sind in der Testssymbolleiste verfügbar:

Befehl | Symbol | Beschreibung
Dokumentansicht | Dokumentansicht | Öffnet die Dokumentansicht, in der ausgewählte Eigenschaften aller Testelemente in einer einzigen Ansicht angezeigt werden.
Detailansicht | Testplanansicht | Öffnet die Detailansicht, in der Sie die Eigenschaften einzelner Tests detailliert anzeigen können.
Tabellenansicht | Tabellenansicht | Die Tabellenansicht mit allen Tests in einer Tabelle wird angezeigt.
Nach oben | Nach oben | Wechselt in der Navigationshierarchie um eine Ebene nach oben, ungeachtet dessen, wo sich aktuell der Cursor befindet.
Neuer Container | Neuer Container | Ermöglicht die Erstellung von neuen Containern.
Neuer untergeordneter Ordner | Neuer untergeordneter Ordner | Ermöglicht die Erstellung von neuen Ordnern als Unterknoten des ausgewählten Ordners oder Containers.
Neuer untergeordneter Test | Neuer untergeordneter Test | Ermöglicht die Erstellung von neuen Tests als Unterknoten des ausgewählten Ordners oder Containers.
Bearbeiten | Bearbeiten | Bearbeiten Sie das ausgewählte Testelement.
Version erstellen | Version erstellen | Erstellen Sie eine neue Version des ausgewählten manuellen Tests.
Löschen | Löschen | Löschen Sie das ausgewählte Testelement.
Ausschneiden | Ausschneiden | Schneiden Sie in der Testhierarchie ein Testelement aus, und speichern Sie es in der Zwischenablage.
Kopieren | Kopieren | Kopieren Sie aus der Testhierarchie ein Testelement in die Zwischenablage.
Einfügen | Einfügen | Fügen Sie in der Testhierarchie ein Testelement aus der Zwischenablage ein.
Als untergeordnetes Element einfügen | Als untergeordnetes Element einfügen | Fügen Sie ein Testelement aus der Zwischenablage als untergeordnetes Element in das ausgewählte Testelement ein.
Nach oben | Nach oben | Verschieben Sie ein Testelement innerhalb der Testhierarchie nach oben.
Nach unten | Nach unten | Verschieben Sie ein Testelement innerhalb der Testhierarchie nach unten.
Suchen | Suchen | Durchsuchen Sie mithilfe von konfigurierbaren Parametern alle Testelemente im aktiven Projekt.
Ersetzen | Ersetzen | Ersetzen Sie die Instanzen gefundener Werte durch einen neuen Wert.
Neuer Filter | Neuer Filter | Erstellen Sie einen neuen benutzerdefinierten Filter für die Testhierarchie.
Filter |  | Listet die verfügbaren Filter für die Testhierarchie auf.
Filter bearbeiten | Filter bearbeiten | Bearbeiten Sie den aktuell ausgewählten benutzerdefinierten Filter.
Filter löschen |  | Löschen Sie den aktuell ausgewählten benutzerdefinierten Filter.
Filter kopieren | Filter löschen | Kopieren Sie den aktuell ausgewählten benutzerdefinierten Filter.
Änderungen anzeigen | Änderungen anzeigen | Zeigen Sie die letzten Änderungen an den Tests an.
Bestätigen | Bestätigen | Bestätigen Sie die Änderungen an den Tests.
Als XLSX herunterladen | Bestätigen | Diese Funktionalität kann in der Dokumentansicht und Tabellenansicht verwendet werden. In der Dokumentansicht wird dadurch ein Excel-Arbeitsblatt erstellt, welches alle im Moment sichtbaren Zeilen enthält. In der Tabellenansicht wird dadurch ein Excel-Arbeitsblatt erstellt, welches alle Zeilen enthält, nicht nur die sichtbaren.
Übergeordnetes Thema: Testansichten


Tests (Dokumentansicht)

Tests > Dokumentansicht

In der Dokumentansicht werden Informationen zum Status und zu den letzten Ausführungen aller Tests im ausgewählten Projekt angezeigt.

Für jeden Container, jeden Ordner und jeden Test werden in der Dokumentansicht folgende Spalten angezeigt:

Element | Beschreibung
Letzte Testausführung | Zeitpunkt der letzten Ausführung des ausgewählten Tests oder des ausgewählten Projekts.
Status Der Status der letzten Ausführung. Läuft gerade ein Asuführung, so wird der Status Nicht ausgeführt angezeigt.
  • Bestanden
  • Fehlgeschlagen
  • Nicht ausgeführt
  • --
Für Container und Ordner wird in einer Statusleiste eine Reihe von Tests mit dem entsprechenden Status angezeigt.
Letzter Build | Build, für den die letzte Testausführung durchgeführt wurde.
Letzte beendete Testausführung | Zeitpunkt der letzten manuellen Testausführung die beendet ist. Für automatisierte Tests ist dieser Status identisch mit dem von Letzte Testausführung.
Status letzte beendete Testausführung | Status der letzten manuellen Testausführung die beendet ist. Für automatisierte Tests ist dieser Status identisch mit dem von Status.
Build letzte beendete Testausführung | Build, für den die letzte beendete manuelle Testausführung durchgeführt wurde. Für automatisierte Tests ist dieser Status identisch mit dem von Letzter Build.
Test-Anzahl | Anzahl der Tests.
Geplante Dauer | Zusammenfassung der Geplanten Dauer der manuellen Tests.
Zugewiesene Fehler | Die Anzahl der Fehler, die diesem Test zugeordnet sind.
Geändert am | Datum der letzten Änderung des ausgewählten Testelements.
Geändert Von | Benutzer, der zuletzt Änderungen am ausgewählten Testelement vorgenommen hat.
Attribute | Wenn Sie Ihren Tests Attribute zugeordnet haben, können Sie auswählen, dass diese in der Tabelle angezeigt werden. Attribute sind frei erstellbare Merkmale, die auf Tests angewendet werden können. Sie können Attribute für das Filtern und die Berichterstellung verwenden.
Übergeordnetes Thema: Testansichten


Arbeiten mit Tests in der Tabellenansicht

Die Tabellenansicht im Testbereich ergänzt die Dokumentansicht und die Detailansicht, indem das Filtern, Sortieren und Gruppieren einer großen Anzahl an Tests vereinfacht wird. In der Tabellenansicht lassen sich Übereinstimmungen zwischen Tests einfacher erkennen und bestimmte Testdaten leichter suchen. Da Standard-Windows-Tastenkürzel zur Verfügung stehen, können in der Tabellenansicht einzelne Gruppen von Tests mühelos ausgewählt und bearbeitet werden. In der Tabellenansicht können Sie Versuchsläufe von Tests ausführen und Tests aufrufen. Überdies können Sie Testsuiten erstellen, indem Sie mehrere Tests in der Tabellenansicht auswählen.

Die Tabellenansicht bietet einige Funktionen zum Anpassen der Ansicht, die die Verwaltung einer großen Anzahl von Tests erleichtern. Sie können Spalten anzeigen oder verbergen, die Spaltenbreite verändern und Spalten per Drag&Drop verschieben. Um die Leistung beim Einsatz einer Vielzahl von Tests zu verbessern, werden in den einzelnen Ansichten jeweils nur 50 Tests angezeigt. Sie können mit den Optionen Erste, Letzte, Weiter und Zurück durch die Seiten blättern. Sie können auch eine Seitenzahl im Feld Seite eingeben und die Eingabetaste drücken, um auf die angegebene Seite zu gelangen. Sortier-, Gruppierungs- und Filterfunktionen sind über Kontextmenübefehle verfügbar, damit Sie die Tests leichter anordnen und gruppieren sowie einfacher Übereinstimmungen zwischen Tests erkennen können. Alle Einstellungen für das Anpassen von Ansichten werden zusammen mit dem Projekt gespeichert und sind verfügbar, sobald Sie die Tabellenansicht öffnen.

  • Zugreifen auf Tests aus der Tabellenansicht
    Greifen Sie direkt aus der Tabellenansicht auf einen Test in der Ansicht Tests zu.
  • Erstellen einer Testsuite in der Tabellenansicht
    Erstellen Sie eine Testsuite in der Tabellenansicht, um Tests direkt der Testsuite zuzuordnen.
  • Modifizieren von Eigenschafts- oder Attributwerten für mehrere Tests
    Hier wird beschrieben, wie Sie Eigenschafts- und Attributwerte für mehr als einen Test ändern.
  • Anzeigen und Ausblenden von Spalten in der Tabellenansicht
    Sie können in der Tabellenansicht Spalten anzeigen und ausblenden, um die benötigten Informationen anzuzeigen.
  • Gruppieren von Tests in der Tabellenansicht
    Gruppieren Sie Tests in der Tabellenansicht, um das Anzeigen von Tests mit gemeinsamen Werten zu erleichtern.
  • Entfernen der Gruppierung von Tests in der Tabellenansicht
    Entfernen Sie die Gruppierung von Tests in der Tabellenansicht, um die Tests sortiert anzuzeigen.
  • Sortieren von Tests in der Tabellenansicht
    Hier wird beschrieben, wie Tests in der Tabellenansicht sortiert werden.
  • Anordnen von Spalten in der Tabellenansicht
    Ordnen Sie die Spalten in der Tabellenansicht neu an, um sie in der gewünschten Reihenfolge anzuzeigen.
  • Ändern der Spaltenbreite in der Tabellenansicht
    Ändern Sie die Spaltenbreite, um die Spalten mit der bevorzugten Breite anzuzeigen.
  • Filtern von Tests in der Tabellenansicht
    Hier wird beschrieben, wie Tests in der Tabellenansicht gefiltert werden.
  • Wiederherstellen der Standardeinstellungen in der Tabellenansicht
    Hier wird beschrieben, wie die Standardeinstellungen für die Tabellenansicht bei einem Projekt wiederhergestellt werden.
  • Zuweisen vorhandener Fehler zu Tests in der Tabellenansicht
    Hier wird beschrieben, wie vorhandene Fehler einem oder mehreren Tests in der Tabellenansicht zugewiesen werden können.
Übergeordnetes Thema: Testansichten


Zugreifen auf Tests aus der Tabellenansicht

Sie können direkt aus der Tabellenansicht auf einen Test in der Ansicht Tests zugreifen.

So greifen Sie direkt aus der Tabellenansicht auf die Seite Eigenschaften eines Tests zu.

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Klicken Sie auf den Namen des Tests, auf den Sie zugreifen möchten. Klicken Sie alternativ auf die Zeile des Tests, und wählen Sie Gehe zur Test aus.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Erstellen einer Testsuite in der Tabellenansicht

So erstellen Sie eine Testsuite in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Wählen Sie mithilfe der Mehrfachauswahl in der Tabellenansicht die Tests aus, die Sie der Testsuite zuordnen möchten.
  3. Klicken Sie mit der rechten Maustaste auf die Tests, und wählen Sie Testsuite erstellen. Das Dialogfeld Neue Testsuite wird angezeigt.
  4. Geben Sie die Spezifikationen Ihrer neuen Testsuite ein.
Anmerkung: Alle ausgewählten Tests müssen sich im gleichen Container befinden. Andernfalls wird die Testsuite nicht erstellt, und es wird eine Fehlermeldung angezeigt. Der Testcontainer wird im Dialogfeld Neue Testsuite vorab ausgewählt und kann nicht geändert werden.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten
Zugehörige Tasks
Erstellen von Testsuiten


Modifizieren von Eigenschafts- oder Attributwerten für mehrere Tests

So modifizieren Sie Eigenschafts- oder Attributwerte für mehrere Tests:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Wählen Sie die Tests aus, deren Eigenschaften oder Attribute Sie bearbeiten möchten. Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  3. Klicken Sie mit der rechten Maustaste, und wählen Sie Mehrfachbearbeitung. Das Dialogfeld Mehrfachbearbeitung wird geöffnet. In diesem Dialogfeld können Sie den Wert der ausgewählten Eigenschaft oder des ausgewählten Attributs auf den gleichen Wert für alle ausgewählten Tests festlegen.
    Tipp: Wenn Sie mit der rechten Maustaste auf die Spalte einer bestimmten Eigenschaft oder eines bestimmten Attributs klicken, wird dieses Element im Dialogfeld Mehrfachbearbeitung vorausgewählt.
  4. Wählen Sie Eigenschaften oder Attribute aus der Liste Kategorie aus.
  5. Wählen Sie den Namen der zu modifizierenden Eigenschaft bzw. des Attributs aus.
  6. Wählen Sie den Wert der Eigenschaft oder des Attributs aus, der auf alle ausgewählten Tests angewendet werden wird.
  7. Klicken Sie auf OK. Der ausgewählte Eigenschafts- oder Attributwert wird auf alle ausgewählten Tests angewendet.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Anzeigen und Ausblenden von Spalten in der Tabellenansicht

So zeigen Sie Spalten in der Tabellenansicht an oder blenden sie aus:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile einer Spalte.
  3. Erweitern Sie das Spalten-Untermenü, damit alle im Projekt verfügbaren Spalten angezeigt werden.
  4. Aktivieren Sie die Kontrollkästchen aller Spalten, die in der Tabellenansicht angezeigt werden sollen. Ihre Anzeigeeinstellungen für die Spalten werden gespeichert und jedesmal aktiviert, wenn Sie das aktive Projekt öffnen.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Gruppieren von Tests in der Tabellenansicht

Neben einer einfachen Sortierung nach Spalten können Sie Tests in Gruppen anordnen, um die Anzeige übersichtlicher zu gestalten. Die Gruppierung richtet sich nach gemeinsamen, in der zu gruppierenden Spalte enthaltenen Werten.

So gruppieren Sie Tests in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile einer Spalte, auf deren Werte die Gruppierung basieren soll, und wählen Sie Dieses Feld gruppieren. Die Tests werden daraufhin in Gruppen angeordnet, die auf gemeinsamen Werten basieren, die in der ausgewählten Spalte vorkommen.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Entfernen der Gruppierung von Tests in der Tabellenansicht

So entfernen Sie die Gruppierung von Tests in der Tabellenansicht.

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile irgendeiner Spalte.
  3. Deaktivieren Sie das Kontrollkästchen Gruppen anzeigen.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Sortieren von Tests in der Tabellenansicht

So sortieren Sie Tests in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte, nach der Sie die Tests sortieren möchten.
  3. Klicken Sie auf Aufsteigend sortieren, damit die Tests in aufsteigender Reihenfolge sortiert werden, oder klicken Sie auf Absteigend sortieren, um sie in absteigender Reihenfolge zu sortieren. Ihre Sortiereinstellungen werden gespeichert und jedes Mal aktiviert, wenn Sie das aktive Projekt öffnen.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Anordnen von Spalten in der Tabellenansicht

So ordnen Sie Spalten in der Tabellenansicht neu an:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Klicken Sie auf die Überschrift der Spalte, die Sie verschieben möchten, und halten Sie die Maustaste gedrückt.
  3. Ziehen Sie die Spalte an die gewünschte Position, und lassen Sie die Maustaste los. Ihre Anordnungseinstellungen für die Spalten werden gespeichert und jedes Mal aktiviert, wenn Sie das aktive Projekt öffnen.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Ändern der Spaltenbreite in der Tabellenansicht

So passen Sie die Spaltenbreite in der Tabellenansicht an:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Klicken Sie auf die vertikale Trennlinie der Spalte, deren Breite Sie ändern möchten, und halten Sie die Maustaste gedrückt.
  3. Ziehen Sie die Spaltentrennlinie an die gewünschte Position, und lassen Sie die Maustaste los. Ihre Breiteneinstellungen für die Spalten werden gespeichert und jedes Mal aktiviert, wenn Sie das aktive Projekt öffnen.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Filtern von Tests in der Tabellenansicht

Sie können die Liste der Tests nach Spaltenwerten filtern. Hier können Sie die folgenden Einstellungen festlegen:
  • Filterstrings, die auf textbasierte Datenfelder angewendet werden können.
  • Kalenderfilter für Datumsfelder mit den Operatoren Vor, Nach oder Am.
  • Numerische Operatoren für numerische Felder. >, < und =.
  • Filtern von Textwerten in der Tabellenansicht
    Filtern Sie Textwerte in der Tabellenansicht, um nur die Tests anzuzeigen, die den Filterkriterien entsprechen.
  • Filtern der Datumswerte in der Tabellenansicht
    Filtern Sie Datumswerte in der Tabellenansicht, um nur die Tests anzuzeigen, die den Filterkriterien entsprechen.
  • Filtern von numerischen Werten in der Tabellenansicht
    Filtern Sie numerische Werte in der Tabellenansicht, um nur die Tests anzuzeigen, die den Filterkriterien entsprechen.
  • Filtern von booleschen Werten in der Tabellenansicht
    Filtern Sie boolesche Werte in der Tabellenansicht, um nur die Tests anzuzeigen, die den Filterkriterien entsprechen.
  • Filtern von Werten mithilfe einer vordefinierten Liste in der Tabellenansicht
    Filtern Sie Werte mithilfe einer vordefinierten Liste in der Tabellenansicht, um nur die Tests anzuzeigen, die den Filterkriterien entsprechen.
  • Entfernen von bestimmten Filtern in der Tabellenansicht
    Entfernen Sie in der Tabellenansicht einen bestimmten Filter, der einer Spalte zugeordnet ist, um die ausgeschlossenen Tests anzuzeigen.
  • Entfernen von allen Filtern in der Tabellenansicht
    Entfernen Sie alle Filter für Spalten in der Tabellenansicht, um alle Tests anzuzeigen.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht
Zugehörige Konzepte
Filter


Filtern von Textwerten in der Tabellenansicht

So filtern Sie Textwerte in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit den Textwerten, auf denen der Filter basieren soll.
  3. Erweitern Sie im Kontextmenü das Untermenü Filter, um das Feld Filter anzuzeigen.
  4. Geben Sie eine Zeichenfolge in das Feld ein.
  5. Drücken Sie die Eingabetaste. Daraufhin werden in der gefilterten Liste dynamisch alle Tests angezeigt, die dem Filterkriterium entsprechen (im Fall der Namen von Testsuiten beispielsweise alle Namen, die die angegebene Zeichenfolge enthalten).
Übergeordnetes Thema: Filtern von Tests in der Tabellenansicht


Filtern der Datumswerte in der Tabellenansicht

So filtern Sie Datumswerte in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit Datumswerten, auf denen der Filter basieren soll.
  3. Zeigen Sie im Kontextmenü auf Filter, damit das Untermenü mit den Einträgen Vor, Nach und Am angezeigt wird.
  4. Zeigen Sie auf Nach, um das Datum anzugeben, ab dem alle späteren Tests angezeigt werden sollen. Zeigen Sie auf Vor, um das Datum anzugeben, ab dem alle früheren Tests angezeigt werden sollen. Zeigen Sie auf Am, um nur die Tests mit dem angegebenen Datum anzuzeigen. Der Kalender wird angezeigt.
  5. Wählen Sie mithilfe des Kalenders ein Datum aus (oder klicken Sie auf Heute, um das heutige Datum anzugeben).
    Tipp: Sie müssen explizit auf ein Datum klicken oder die Taste Eingabe drücken, um die Änderungen bei der datumsbasierten Filterung zu aktivieren.
    Daraufhin werden in der gefilterten Liste dynamisch alle Tests angezeigt, die dem Filterkriterium entsprechen.
Übergeordnetes Thema: Filtern von Tests in der Tabellenansicht


Filtern von numerischen Werten in der Tabellenansicht

So filtern Sie numerische Werte in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit den numerischen Werten, auf denen der Filter basieren soll.
  3. Erweitern Sie im Kontextmenü das Untermenü Filter, um die Operatoren >, < und = anzuzeigen.
  4. Geben Sie im Feld > einen numerischen Wert ein, wenn alle Tests angezeigt werden sollen, die diesen Wert überschreiten. Geben Sie im Feld < einen numerischen Wert ein, wenn alle Tests angezeigt werden sollen, die diesen Wert unterschreiten. Geben Sie im Feld = einen numerischen Wert ein, um nur diejenigen Tests anzuzeigen, die diesen Wert aufweisen; alle anderen Einträge werden ausgeschlossen.
    Anmerkung: Numerische Werte werden auf zwei Dezimalstellen gerundet.
  5. Drücken Sie die Eingabetaste. Daraufhin werden in der gefilterten Liste dynamisch alle Tests angezeigt, die dem Filterkriterium entsprechen.
Übergeordnetes Thema: Filtern von Tests in der Tabellenansicht


Filtern von booleschen Werten in der Tabellenansicht

So filtern Sie boolesche Werte in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit den booleschen Werten, auf denen der Filter basieren soll.
  3. Erweitern Sie im Kontextmenü das Untermenü Filter, um die verfügbaren Werte anzuzeigen.
  4. Wählen Sie entweder das Optionsfeld Ja oder das Optionsfeld Nein. Daraufhin werden in der gefilterten Liste dynamisch alle Tests angezeigt, die dem Filterkriterium entsprechen.
Übergeordnetes Thema: Filtern von Tests in der Tabellenansicht


Filtern von Werten mithilfe einer vordefinierten Liste in der Tabellenansicht

So filtern Sie Werte mit einer vordefinierten Liste in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit dem vordefinierten Filterwert (beispielsweise Knotentyp), auf dem der Filter basieren soll.
  3. Erweitern Sie im Kontextmenü das Untermenü Filter, um die verfügbaren Werte anzuzeigen.
  4. Aktivieren Sie die Kontrollkästchen der gewünschten Filterwerte. Es werden alle Tests angezeigt, die eines der ausgewählten Kriterien erfüllen.
Übergeordnetes Thema: Filtern von Tests in der Tabellenansicht


Entfernen von bestimmten Filtern in der Tabellenansicht

Anmerkung: Sie können gefilterte Spalten an ihrer Überschrift erkennen, die in fetter, kursiver Schrift angezeigt wird. Wenn Sie eine Spalte ausblenden, werden alle Filter entfernt, die auf diese Spalte angewendet wurden.

So entfernen Sie einen bestimmten Filter in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit dem Filter, den sie entfernen möchten.
  3. Deaktivieren Sie das Kontrollkästchen Filter.
Übergeordnetes Thema: Filtern von Tests in der Tabellenansicht


Entfernen von allen Filtern in der Tabellenansicht

Anmerkung: Sie können gefilterte Spalten an ihrer Überschrift erkennen, die in fetter, kursiver Schrift angezeigt wird. Wenn Sie eine Spalte ausblenden, werden alle Filter entfernt, die auf diese Spalte angewendet wurden.

So entfernen Sie alle Filter in der Tabellenansicht:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile irgendeiner Spalte und wählen Sie Filter zurücksetzen.
Übergeordnetes Thema: Filtern von Tests in der Tabellenansicht


Wiederherstellen der Standardeinstellungen in der Tabellenansicht

Durch Wiederherstellen von Standardeinstellungen der Tabelleneinsicht werden alle benutzerdefinierten Einstellungen für das aktuelle Projekt zurückgesetzt. Die benutzerdefinierten Einstellungen sind:
  • Spaltenreihenfolge
  • Spaltenbreite
  • Angezeigte und ausgeblendete Spalten
  • Angewendete Filter
  • Sortieren
  • Gruppierung

So stellen Sie die Standardeinstellungen für die Tabellenansicht wieder her:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Öffnen Sie das Kontextmenü der Kopfzeile irgendeiner Spalte und wählen Sie Ansicht zurücksetzen.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Zuweisen vorhandener Fehler zu Tests in der Tabellenansicht

So weisen Sie vorhandene Fehler einem oder mehreren Tests zu:
  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Klicken Sie mit der rechten Maustaste auf einen Test. Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  3. Klicken sie auf Vorhandene Fehler zuweisen, wählen Sie ein Profil aus und geben Sie im Feld Fehler-ID die Nummern der Fehler durch Kommas getrennt ein.
Übergeordnetes Thema: Arbeiten mit Tests in der Tabellenansicht


Ausführungsplanung

Im Bereich Ausführungsplanung können Sie die Testausführungen während der Entwicklung und der Tests steuern. Dies beinhaltet Tätigkeiten wie z.B. Testsuiten konfigurieren und deren Ausführung planen, Tests zu Testsuiten zuordnen, Abhängigkeiten von Testsuiten definieren sowie die Bereitstellung von Ausführungsservern und die dynamische Hardwarebereitstellung mit Schlüsselwörtern konfigurieren. Testsuiten werden in der Testsuitehierarchie angezeigt, organisiert und verwaltet. Jeder Testsuite können beliebig viele untergeordnete Tests zugeordnet werden. In der Testsuitehierarchie können Sie die Testsuiten in Ordnern mit beliebiger Hierarchietiefe organisieren.

  • Manuelle Ausführungsplanung
    Hier finden Sie Informationen zur manuellen Ausführungsplanung und zur Erstellung von Testsuiten auf der Basis von Qualitätszielen.
  • Testen von Konfigurationen
    Hier wird beschrieben, wie in Silk Central Konfigurationen getestet werden.
  • Verwalten von Testsuiten, Ordnern und Konfigurationssuiten
    Hier wird die Verwendung von Testsuiten in Silk Central beschrieben.
  • Ausführungsplanungsansichten
    Hier werden die verfügbaren Ansichten im Bereich Ausführungsplanung erklärt.
  • Arbeiten mit Silk Performer-Projekten
    Silk Performer-Projekte können in Silk Central-Tests integriert und über Silk Central direkt ausgeführt werden.
  • Silk Test Classic-Tests
    Hier wird beschrieben, wie Tests in Silk Test Classic ausgeführt werden.
Übergeordnetes Thema: Silk Central-Hilfe


Manuelle Ausführungsplanung

Sie rufen diese Seite auf, indem Sie auf Ausführungsplanung > Manuelle Ausführungsplanung klicken.

Bei der Planung des manuellen Testens besteht das Problem häufig darin, dass die Anzahl der auszuführenden Tests zu groß ist und nicht genügend Ressourcen verfügbar sind. Es ist wichtig, dass Sie diejenigen Tests ausführen, die den größten Nutzen bringen. Um Sie dabei zu unterstützen, ist die Seite Manuelle Ausführungsplanung in zwei Ansichten unterteilt:

Testauswahl
Wählen Sie manuelle Tests aus, und ordnen Sie sie Testzyklen zu.
Testzuordnung
Planen Sie die Ausführung von manuellen Tests im Detail. Legen Sie fest, welcher manuelle Tester welche Tests in einem bestimmten Testzyklus ausführen soll.

Um die Ansicht Testauswahl anzuzeigen, klicken Sie auf Ausführungsplanung > Manuelle Ausführungsplanung.

Um die Ansicht Testzuordnung anzuzeigen, klicken Sie auf Testzuordnung oben rechts auf der Seite Manuelle Ausführungsplanung. Um zur Ansicht Testauswahl zurückzukehren, klicken Sie oben links auf Testauswahl.

  • Schrittweise Anleitung
    In dieser Anleitung sind die Funktionen der Manuellen Ausführungsplanung anhand eines Beispiels dargestellt.
  • Testauswahl
    Hier werden die Ansicht Testauswahl, die Arbeit mit Testzyklen sowie das Filtern und Zuordnen von manuellen Tests beschrieben.
  • Testzuordnung
    Hier werden die manuellen Tests aufgeführt, die bestimmten Testzyklen und Testern zugeordnet sind.
  • Manuelles Testen
    Hier werden die Silk Central-Funktion "Manuelles Testen" und die effiziente Ausführung manueller Tests im Fenster Manuelles Testen beschrieben.
Übergeordnetes Thema: Ausführungsplanung
Zugehörige Verweise
Eigenschaften von Testzyklus (Seite)


Schrittweise Anleitung

In dieser Anleitung sind die Funktionen der Manuellen Ausführungsplanung anhand eines Beispiels dargestellt. Folgendes wird in diesem Beispiel vorausgesetzt:

  • Die Anforderungen sind gemäß einer Risk-Eigenschaft vollständig dokumentiert und kategorisiert.
  • 575 manuelle Tests sind vollständig dokumentiert, Anforderungen zugewiesen und gemäß einem Importance-Attribut kategorisiert, das die Notwendigkeit der Ausführung eines bestimmten Tests definiert.
  • Qualitätsziele, auch Projektausgangskriterien genannt, wurden basierend auf der Anforderungseigenschaft Risk und dem Testattribut Importance definiert. Diese Qualitätsziele bestimmen die erforderlichen Testebenen.
  • Es sind nur die Tests zu planen, die die Qualitätsziele am besten erfüllen.
  1. Überblick (schrittweise Anleitung)
    Hier erhalten Sie einen Überblick über die Bereiche der Seite Manuelle Ausführungsplanung.
  2. Erstellen eines Testzyklus (schrittweise Anleitung)
    Hier wird beschrieben, wie Sie einen Testzyklus erstellen, indem Sie ein Startdatum, ein Enddatum und eine Kapazität angeben.
  3. Hinzufügen manueller Tester (schrittweise Anleitung)
    Hier wird beschrieben, wie Sie manuelle Tester zum Testzyklus hinzufügen und die Kapazität definieren.
  4. Auswählen von Tests und Zeitplanung (schrittweise Anleitung)
    Hier wird beschrieben, wie Sie Tests filtern, sortieren und gruppieren und dem Testzyklus zuordnen.
  5. Zuordnen von Tests zu manuellen Testern (schrittweise Anleitung)
    Hier wird beschrieben, wie Sie die Tests eines Testzyklus den manuellen Testern zuordnen.
Übergeordnetes Thema: Manuelle Ausführungsplanung


Überblick (schrittweise Anleitung)

Die Seite Manuelle Ausführungsplanung besteht aus vier Bereichen, die auf zwei Bildschirme aufgeteilt sind. Im ersten Bildschirm, Testauswahl, können Sie die Tests für einen Testzyklus auswählen und zeitlich planen. Im zweiten Bildschirm, Testzuordnung, können Sie die Tests des ausgewählten Testzyklus den Testern zur Ausführung zuordnen.

Der Bildschirm Testauswahl ist in drei Bereiche unterteilt:

  • Links befindet sich der Abschnitt Filterkriterien. Mithilfe der Filterfunktion können Sie die hier angezeigten Tests auf die gewünschten begrenzen.
  • In der Mitte befindet sich der Abschnitt Relevante Tests. In dieser Liste werden alle verfügbaren Tests angezeigt. Wenn Sie einen Filter anwenden, werden nur die Tests angezeigt, die den Filterkriterien entsprechen.
  • Rechts befindet sich der Abschnitt Testzyklen. Hier können Sie Tests aus der mittleren Liste einem bestimmten Testzyklus zuordnen, also einem bestimmten Zeitraum.

Sie rufen den Bildschirm Testzuordnung auf, indem Sie oben rechts auf Testzuordnung >>> klicken. Dieser Bildschirm besteht aus zwei Bereichen:

  • Links befindet sich der Abschnitt Testzyklen. Dieser Bereich ist identisch mit dem im Bildschirm Testauswahl; er ist Teil beider Bildschirme.
  • Rechts befindet sich der Abschnitt Zugeordnete Tests. Diese Liste enthält die Tests, die dem aktuell ausgewählten Testzyklus hinzugefügt wurden. Hier können Sie die Tests aus der Liste in den Bereich Testzyklen ziehen und auf einem Tester ablegen.

Übergeordnetes Thema: Schrittweise Anleitung
Nächstes Thema: Erstellen eines Testzyklus (schrittweise Anleitung)


Erstellen eines Testzyklus (schrittweise Anleitung)

Als Erstes erstellen wir einen Testzyklus. Ein Testzyklus ist ein durch ein Start- und Enddatum definierter Zeitraum, für den manuelle Tester festgelegt wurden. Wir benennen den Testzyklus Woche 21 - Team A.
  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung.
  2. Klicken Sie rechts im Bereich Testzyklen auf Neuer Testzyklus. Das Dialogfeld Neuer Testzyklus wird angezeigt.
  3. Geben Sie den Namen des Testzyklus an – in unserem Fall Woche 21 – Team A.
  4. Wahlweise können Sie auch eine Beschreibung eingeben.
  5. Klicken Sie auf [image] neben Startdatum, um den Beginn des Testzyklus festzulegen.
  6. Klicken Sie auf [image] neben Enddatum, um das Ende des Testzyklus festzulegen.
  7. Geben Sie im Format hh:mm die Zeit an, die für diesen Testzyklus festgelegt wird (Kapazität). In unserem Beispiel ist dies 35:00.
  8. Klicken Sie auf OK.
Der Testzyklus wird nun im Bereich Testzyklen angezeigt. Es ist ersichtlich, dass zurzeit keine Tester zugeordnet sind. Als Nächstes ordnen wir dem Testzyklus Tester zu.

Übergeordnetes Thema: Schrittweise Anleitung
Vorheriges Thema: Überblick (schrittweise Anleitung)
Nächstes Thema: Hinzufügen manueller Tester (schrittweise Anleitung)


Hinzufügen manueller Tester (schrittweise Anleitung)

Als Nächstes fügen wir unserem Testzyklus manuelle Tester hinzu. Außerdem definieren wir die Kapazität, die die einzelnen manuellen Tester für diesen Testzyklus haben.
  1. Klicken Sie in der Kopfzeile des Testzyklus Woche 21 - Team A auf ...Zugewiesene Tester bearbeiten. Das Dialogfeld Zugewiesene Tester bearbeiten wird angezeigt.
  2. Klicken Sie auf Manuelle Tester zuordnen. Der Dialog Manuelle Tester zuordnen wird angezeigt.
  3. Wählen Sie eine Benutzergruppe aus der Liste Verfügbar aus.
  4. Wählen Sie aus der Benutzergruppe in der Liste Verfügbar einen oder mehrere Benutzer aus.
  5. Klicken Sie auf Hinzufügen oder Alle hinzufügen, um Benutzer in die Liste Ausgewählte aufzunehmen.
  6. Klicken Sie auf OK. Die Benutzer werden nun der Liste im Dialogfeld Zugewiesene Tester bearbeiten hinzugefügt.
  7. Geben Sie für jeden hinzugefügten Benutzer im Feld Kapazität die Kapazität für den Testzyklus an. Verwenden Sie dazu das Format hh:mm.
  8. Klicken Sie auf Schließen.
Der Testzyklus zeigt nun die verfügbaren Ressourcen an; sowohl für den gesamten Testzyklus als auch für die einzelnen manuellen Tester. In einem Burndown-Chart werden die zugewiesenen Tests dargestellt, die noch nicht durchgeführt wurden. Nachdem wir den Testzyklus erstellt und manuelle Tester hinzugefügt haben, können wir im nächsten Schritt festlegen, welche Tests durchgeführt werden müssen.

Übergeordnetes Thema: Schrittweise Anleitung
Vorheriges Thema: Erstellen eines Testzyklus (schrittweise Anleitung)
Nächstes Thema: Auswählen von Tests und Zeitplanung (schrittweise Anleitung)


Auswählen von Tests und Zeitplanung (schrittweise Anleitung)

In diesem Thema wird erläutert, wie Sie unserem Beispieltestzyklus Tests zuordnen. Angestrebt wird die Auswahl derjenigen Tests, die die definierten Qualitätsziele am besten abdecken. Eines der Qualitätsziele basiert auf dem Anforderungsrisiko. Normalerweise werden Elemente mit hohem Risiko zuerst getestet.
  1. Aktivieren Sie links im Bereich Filterkriterien unter Qualitätsziele das Kontrollkästchen Anforderungsrisiko. In der Liste Relevante Tests werden nun nur die wichtigsten Tests angezeigt.
  2. Öffnen Sie im Bereich Relevante Tests das Kontextmenü der Kopfzeile einer Spalte, um die Tests zu sortieren, zu filtern oder zu gruppieren. Auf diese Weise können Sie die zu planenden Tests leichter auswählen.
  3. Wählen Sie einen oder mehrere Tests aus, ziehen Sie sie rechts in den Bereich Testzyklen, und legen Sie sie auf unserem Testzyklus ab. Wenn Sie einem Testzyklus Tests hinzufügen, wird die Anzeige der bereits verwendeten Ressourcen aktualisiert. Wenn Sie den Mauszeiger über diese Anzeige bewegen, werden detaillierte Informationen zur Gesamtkapazität, geplanten Dauer und verbleibenden Zeit angezeigt.
  4. Nachdem Sie alle Tests mit kritischem Risiko geplant haben, planen Sie als Nächstes die Tests mit hohem Risiko. Planen Sie danach die Tests mit mittlerem Risiko usw.

Die unserem Testzyklus zugeordneten Tests werden nun in der Zeile Kein zugewiesener Tester angezeigt. Im nächsten Schritt weisen wir manuellen Testern Tests zu.

Übergeordnetes Thema: Schrittweise Anleitung
Vorheriges Thema: Hinzufügen manueller Tester (schrittweise Anleitung)
Nächstes Thema: Zuordnen von Tests zu manuellen Testern (schrittweise Anleitung)


Zuordnen von Tests zu manuellen Testern (schrittweise Anleitung)

Wir weisen jetzt die im Testzyklus enthaltenen Tests manuellen Testern zu.
  1. Klicken Sie rechts oben auf Testzuordnung >>>. Der Bildschirm Testzuordnung wird angezeigt.
  2. Klicken Sie links im Testzyklus im Bereich Testzyklen auf die Zeile Kein zugewiesener Tester. Daraufhin werden alle Tests, die keinem Tester zugeordnet sind, im Bereich Zugeordnete Tests auf der rechten Seite angezeigt.
  3. Wählen Sie einen oder mehrere Tests aus, ziehen Sie sie in den linken Bereich von Testzyklen, und legen Sie sie auf einem manuellen Tester ab. Wenn einem manuellen Tester Tests zugeordnet werden, wird die Ressourcenanzeige entsprechend aktualisiert. Wenn Sie den Mauszeiger über diese Anzeige bewegen, werden detaillierte Informationen zur Kapazität, eingeplanten Zeit und verbleibenden Zeit angezeigt.
  4. Nachdem Sie die Tests manuellen Testern zugeordnet haben, klicken Sie auf ...Testzyklus starten, um die Tests zu starten.

Sobald der Testzyklus gestartet wurde, werden die manuellen Tester per E-Mail darüber informiert, welche Tests ihnen zugeordnet wurden. Sie können Ihrem persönlichen Dashboard einen Eingangsordner hinzufügen (Mir zugewiesene manuelle Tests). Darin werden alle Ihnen zugewiesenen Tests aufgeführt.

Übergeordnetes Thema: Schrittweise Anleitung
Vorheriges Thema: Auswählen von Tests und Zeitplanung (schrittweise Anleitung)


Testauswahl

Die Ansicht Testauswahl ist die erste Ansicht, die nach dem Öffnen der Seite Manuelle Ausführungsplanung angezeigt wird. Hier können Sie die Liste der manuellen Tests mithilfe von Filtern und Qualitätszielen eingrenzen, Testzyklen erstellen und bearbeiten sowie gefilterte manuelle Tests zu Testzyklen zuordnen.

Die Ansicht Testauswahl ist in drei Bereiche unterteilt:
  • Links befindet sich der Abschnitt Filterkriterien. Mithilfe der Filter können Sie die hier angezeigten Tests auf die gewünschten begrenzen.
  • In der Mitte befindet sich der Abschnitt Relevante Tests. In dieser Liste werden alle verfügbaren Tests angezeigt. Wenn Sie einen Filter anwenden, werden nur die Tests angezeigt, die den Filterkriterien entsprechen.
  • Rechts befindet sich der Abschnitt Testzyklen. Hier können Sie Tests aus der Liste in der Mitte zu einem Testzyklus zuordnen.
  • Filterkriterien
    Hier wird beschrieben, wie Sie im Bereich Filterkriterien Filter und Qualitätsziele anwenden.
  • Relevante Tests
    Hier wird der Bereich Relevante Tests beschrieben.
  • Testzyklen
    Ein Testzyklus ist ein durch ein Start- und Enddatum definierter Zeitraum, für den manuelle Tester festgelegt wurden. Erstellen Sie Testzyklen um die Ausführung einer bestimmten Menge von Tests zu planen und durchzuführen.
Übergeordnetes Thema: Manuelle Ausführungsplanung


Filterkriterien

Der Bereich Filterkriterien bietet die folgenden Möglichkeiten zum Filtern:

Filter-Zusammenfassung

Führt alle Filter auf, die auf die Seite angewendet wurden.

Klicken Sie auf [image] neben einem Filter, um diesen Filter aus der Liste zu entfernen.

Test-Filter

Enthält eine Liste mit allen Testfiltern des aktuellen Projekts.

Wählen Sie einen Testfilter aus. Die gefilterten Tests werden im Bereich Relevante Tests angezeigt.

Qualitätsziele/Zuweisungs-Fortschritt

Zeigt die Qualitätsziele des Projekts und die Werte dieser Qualitätsziele an.

Wählen Sie einen oder mehrere Qualitätszielwerte aus. Die gefilterten Tests werden im Bereich Relevante Tests angezeigt.

Für jeden Qualitätszielwert wird ein Balken für den Zuweisungsfortschritt angezeigt. Der Balken zeigt die Anzahl der einer Testsuite zugeordneten Tests sowie die Anzahl der Tests an, die noch keiner Testsuite zugeordnet wurden.

Achtung: Die Werte umfassen manuelle und automatisierte Tests.

Wenn Sie den Mauszeiger über einen Balken bewegen, wird Folgendes angezeigt:

  • Die Anzahl der Relevanten Tests.
  • Die Anzahl der Tests zur Zielerreichung.
  • Die Anzahl der Bereits zugeordneten Tests.
  • Die Anzahl der Noch nicht zugeordneten Tests.

Wenn der Wert für Bereits zugeordnete Tests größer ist als der für Tests zur Zielerreichung, wird ein Ausrufezeichen angezeigt. Dies bedeutet, dass mehr Tests als notwendig zugeordnet sind.

Achtung: Die Werte umfassen manuelle und automatisierte Tests.
Container/Ordner

Zeigt die Container/Ordner-Testhierarchie an.

Wählen Sie einen Container oder Ordner aus, um im Bereich Relevante Tests nur die untergeordneten Tests dieses Knotens anzuzeigen.

Anmerkung: Sie können pro Qualitätsziel nur einen Testfilter und einen Zielwert auswählen.

Wenn Sie mehrere Qualitätszielwerte (von unterschiedlichen Qualitätszielen) oder einen Qualitätszielwert und einen Testfilter auswählen, werden in der Tabelle Relevante Tests nur die Tests angezeigt, die alle Kriterien erfüllen.

Übergeordnetes Thema: Testauswahl


Relevante Tests

Im Bereich Relevante Tests werden die manuellen Tests angezeigt, die den ausgewählten Filterkriterien entsprechen. Standardmäßig sind keine Qualitätsziele oder Filter ausgewählt, so dass alle manuellen Tests in der Tabelle aufgeführt werden.

Wählen Sie im Bereich Filterkriterien die gewünschten Filter und Qualitätszielwerte aus, um nur noch die entsprechenden manuellen Tests anzuzeigen.

Die Überschrift der Tabelle Relevante Tests gibt Folgendes an:

  • Die Anzahl der aktuell ausgewählten Tests.
  • Die gesamte geplante Dauer der aktuell ausgewählten Tests.

In der Tabelle können Sie folgende Aktionen durchführen:

  • Um einen manuellen Test zu einem Testzyklus zuzuordnen, ziehen Sie den Test auf die Kopfzeile des gewünschten Testzyklus.
  • Um einen manuellen Test einem manuellen Tester zuzuordnen, ziehen Sie den Test auf den gewünschten Tester im betreffenden Testzyklus.
  • Öffnen Sie das Kontextmenü der Kopfzeile einer Spalte, um die manuellen Tests zu sortieren, zu gruppieren oder zu filtern, Spalten hinzuzufügen oder zu entfernen, oder um Filter oder die Ansicht zurückzusetzen.
  • Klicken Sie mit der rechten Maustaste auf einen manuellen Test, um Details dazu anzuzeigen oder um den manuellen Test auszudrucken.
  • Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  • Sie können Tests mehrfach zuordnen, d. h. zu unterschiedlichen Testzyklen bzw. Testern. Wenn ein Test mindestens einmal zugeordnet ist, wird dies durch ein grünes Häkchen in der Spalte Zugeordnet angegeben.
  • Klicken Sie auf [image], um die Testdetails anzuzeigen.
  • Klicken Sie auf [image], um den Test in Tests Detailansicht anzuzeigen.
Übergeordnetes Thema: Testauswahl


Testzyklen

Ein Testzyklus ist ein durch ein Start- und Enddatum definierter Zeitraum, für den manuelle Tester festgelegt wurden. Erstellen Sie Testzyklen um die Ausführung einer bestimmten Menge von Tests zu planen und durchzuführen.

Im Bereich Testzyklen werden alle Testzyklen des aktuellen Projekts aufgeführt. Dies ist der zentrale Bestandteil der Seite Manuelle Ausführungsplanung und enthält sowohl die Ansicht Testauswahl als auch Testzuordnung. Die Testzyklen sind chronologisch geordnet.

Klicken Sie auf Neuer Testzyklus oben im Bereich Testzyklen, um einen neuen Testzyklus zu erstellen. Klicken Sie auf Testzyklen anzeigen/ausblenden, wenn Sie Testzyklen ausblenden möchten. Verwenden Sie zusätzlich das Feld Suche um nur Testzyklen anzuzeigen, die das Suchwort enthalten. Durch das Ausblenden von Testzyklen können Sie den Bereich Testzyklen ordentlich halten und dadurch die Leistung optimieren. Dies ist besonders hilfreich, wenn Sie viele Testzyklen haben.

Klicken Sie in der Kopfzeile eines Testzyklus auf Aktionen (...), um das Menü zu öffnen. Klicken Sie auf [image] um zum Testzyklus in der Ausführungsplanungshierarchie zu springen.

Klicken Sie in einem Testzyklus auf einen manuellen Tester. Die diesem Tester zugeordneten Tests werden im Bereich Zugeordnete Tests angezeigt.

Klicken Sie auf die Kopfzeile des gewünschten Testzyklus, um ihn auszuwählen. Die dem Testzyklus (aber keinem bestimmten manuellen Tester) zugeordneten Tests sind im Bereich Zugeordnete Tests aufgeführt. Wenn der Bereich Zugeordnete Tests nicht angezeigt wird, klicken Sie oben rechts auf Testzuordnung.

In den Feldern des Testzyklus wird Folgendes angezeigt:

  • Der Name des Testzyklus.
  • Das Start- und Enddatum.
  • Anhand eines Burndown-Charts wird der Testfortschritt sichtbar gemacht. Diesem Diagramm können Sie entnehmen, wie wahrscheinlich es ist, dass alle Tests bis zum Ende des Testzyklus abgearbeitet sind. Bewegen Sie die Maus über einen der Balken, um die Anzahl der Tests anzuzeigen, die noch nicht beendet wurden.
  • Die verbleibende Kapazität. Dieser Wert wird folgendermaßen errechnet: Die Summe der eingeplanten Zeit der zugeordneten Tests minus die Summe der Kapazitäten der manuellen Tester. Dieser Wert wird sowohl für den Testzyklus als auch für jeden einzelnen Tester angezeigt. Wenn einem Testzyklus oder einem manuellen Tester zu viele Tests zugeordnet sind, wechselt die Farbe des Felds von grün zu rot. Bewegen Sie die Maus über dieses Feld, um ausführliche Informationen dazu anzuzeigen.
  • Die Anzahl der zugeordneten und der beendeten Tests, sowohl für den Testzyklus als auch für jeden einzelnen Tester. Bewegen Sie die Maus über diese Werte, um ausführliche Informationen dazu anzuzeigen.
  • Die manuellen Tester, die den einzelnen Testzyklen zugewiesen sind. Klicken Sie auf die Anzahl der zugeordneten Tester, um Details dazu anzuzeigen oder auszublenden.
  • Erstellen von Testzyklen
    Hier wird beschrieben, wie Sie einen Testzyklus auf der Seite Manuelle Ausführungsplanung erstellen.
  • Hinzufügen manueller Tester zu einem Testzyklus
    Hier wird beschrieben, wie Sie manuelle Tester zu einem Testzyklus hinzufügen und die Kapazität angeben.
  • Bearbeiten zugeordneter Tester
    Hier wird beschrieben, wie Sie manuelle Tester zu Testzyklen hinzufügen und daraus entfernen und wie Sie die Kapazität für die einzelnen Tester festlegen.
  • Hinzufügen von Meilensteinen
    Hier wird beschrieben, wie Meilensteinen Ihren Testzyklen hinzugefügt werden können. Diese sind besonders nützlich, falls die Kapazität der Tester nicht gleichmäßig auf den gesamten Testzyklus aufgeteilt werden kann.
  • Zuordnen von Tests zu Testzyklen
    Hier wird beschrieben, wie Sie Tests auf der Seite Manuelle Ausführungsplanung zu Testzyklen zuordnen.
  • Zuordnen von Tests zu manuellen Testern
    Hier wird beschrieben, wie Sie die Tests eines Testzyklus den manuellen Testern zuordnen, um das Arbeitspensum auf die Mitarbeiter aufzuteilen.
  • Verschieben von Tests von einem Testzyklus in einen anderen
    Hier wird beschrieben, wie Sie auf der Seite Manuelle Ausführungsplanung Tests von einem Testzyklus in einen anderen verschieben.
  • Verschieben von Tests von einem Tester zu einem anderen
    Hier wird beschrieben, wie Sie Tests von einem Tester zu einem anderen Tester mit freier Kapazität verschieben, um das Arbeitspensum innerhalb eines Testzyklus zu verteilen.
  • Entfernen von Tests aus Testzyklen
    Hier wird beschrieben, wie Sie zugeordnete Tests auf der Seite Manuelle Ausführungsplanung aus Testzyklen entfernen.
  • Entfernen von Tests von manuellen Testern
    Hier wird beschrieben, wie Sie über die Seite Manuelle Ausführungsplanung Tests, die einem manuellen Tester zugeordnet sind, entfernen.
  • Importieren von Tests aus der Testsuite
    Beschreibt, wie manuelle Tests von einer Testsuite in einen Testzyklus importiert werden.
  • Synchronisierung von Testzyklen
    Synchronisieren Sie Testzyklen, wenn Sie die aktuellen Testläufe eines Testzyklus mit den Änderungen synchronisieren möchten, die in den zugeordneten Tests gemacht wurden.
  • Duplizieren von Testzyklen
    Hier wird beschrieben, wie Sie Testzyklen duplizieren.
  • Verbergen von Testzyklen
    Hier wird beschrieben, wie Testzyklen verborgen werden, um die Seite Manuelle Ausführungsplanung sauber zuhalten und die Leistung zu verbessern.
  • Starten von Testzyklen
    Hier wird beschrieben, wie Sie einen Testzyklus starten und damit alle diesem Testzyklus zugeordneten manuellen Tests ausführen.
  • Beenden von Testzyklen
    Hier wird beschrieben, wie Sie einen Testzyklus und damit alle diesem Testzyklus zugeordneten manuellen Tests beenden.
  • Löschen von Testzyklen
    Hier wird beschrieben, wie Sie Testzyklen löschen.
Übergeordnetes Thema: Testauswahl
Übergeordnetes Thema: Testzuordnung


Erstellen von Testzyklen

Anmerkung: Neue Testzyklen können Sie auch in der Detailansicht und der Dokumentansicht der Ausführungsplanung erstellen.

So erstellen Sie einen Testzyklus:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen auf Neuer Testzyklus. Das Dialogfeld Neuer Testzyklus wird angezeigt.
  3. Geben Sie einen Namen für den Testzyklus ein.
  4. Wahlweise können Sie auch eine Beschreibung eingeben.
  5. Klicken Sie auf [image] neben Startdatum, um den Beginn des Testzyklus festzulegen.
  6. Klicken Sie auf [image] neben Enddatum, um das Ende des Testzyklus festzulegen.
  7. Geben Sie im Format hh:mm die Zeit an, die für den Testzyklus festgelegt wird (Kapazität).

    Wenn Sie dem Testzyklus einen Tester hinzufügen, wird dieser Kapazitätswert durch die Summe der Testerkapazitäten ersetzt.

  8. Klicken Sie auf OK. Der Testzyklus wird dem Bereich Testzyklen hinzugefügt.
Übergeordnetes Thema: Testzyklen


Hinzufügen manueller Tester zu einem Testzyklus

Nachdem Sie einen Testzyklus erstellt haben, können Sie manuelle Tester und Kapazitäten hinzufügen.

Sie können manuelle Tester auch in der Detailansicht der Ausführungsplanung hinzufügen. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht. Klicken Sie links auf einen Testzyklus und dann auf Manuelle Tester zuordnen auf der Seite Eigenschaften.

So fügen Sie manuelle Tester zu einem Testzyklus hinzu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie in der Kopfzeile eines Testzyklus im Bereich Testzyklen auf ... > Zugewiesene Tester bearbeiten. Das Dialogfeld Zugewiesene Tester bearbeiten wird angezeigt.
  3. Klicken Sie auf Manuelle Tester zuordnen. Der Dialog Manuelle Tester zuordnen wird angezeigt.
  4. Wählen Sie die gewünschte Benutzergruppe aus der Liste Verfügbar aus.
  5. Wählen Sie in der Liste Verfügbar einen oder mehrere Benutzer aus. Mehrere Benutzer können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  6. Klicken Sie auf Hinzufügen oder Alle hinzufügen, um Benutzer in die Liste Ausgewählte aufzunehmen.
  7. Klicken Sie auf OK. Die Benutzer werden zur Liste der Tester hinzugefügt.
  8. Geben Sie für jeden Benutzer des Testzyklus im Feld Kapazität die Kapazität an. Verwenden Sie dazu das Format hh:mm.
  9. Klicken Sie auf Schließen. Die Kapazität eines Testzyklus ist die Summe der Kapazitäten der zugeordneten Tester.
Übergeordnetes Thema: Testzyklen


Bearbeiten zugeordneter Tester

Sie können manuelle Tester zu Testzyklen hinzufügen und daraus entfernen und die Kapazität für die einzelnen Tester festlegen.

So bearbeiten Sie zugeordnete Tester:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen in der Kopfzeile eines Testzyklus auf ... > Zugewiesene Tester bearbeiten. Das Dialogfeld Zugewiesene Tester bearbeiten wird angezeigt.
  3. Klicken Sie auf Manuelle Tester zuordnen. Der Dialog Manuelle Tester zuordnen wird angezeigt.
  4. Wählen Sie die gewünschte Benutzergruppe aus der Liste Verfügbar aus.
  5. Fügen Sie Tester hinzu, oder entfernen Sie Tester:
    • Wählen Sie einen oder mehrere Benutzer in der Liste Verfügbar aus, und klicken Sie auf Hinzufügen oder Alle hinzufügen.
    • Wählen Sie einen oder mehrere Benutzer in der Liste Ausgewählte aus, und klicken Sie auf Entfernen oder Alle entfernen.
    Mehrere Benutzer können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  6. Klicken Sie auf OK. Die betreffenden Benutzer werden nun in die Liste Zugewiesene Tester aufgenommen bzw. daraus entfernt.
  7. Geben Sie für jeden Benutzer des Testzyklus im Feld Kapazität die Kapazität an. Verwenden Sie dazu das Format hh:mm.
  8. Klicken Sie auf Schließen. Die Kapazität eines Testzyklus ist die Summe der Kapazitäten der zugeordneten Tester.
Sie können zugewiesene Tester auch in der Detailansicht bearbeiten. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht. Klicken Sie links auf einen Testzyklus und dann auf Manuelle Tester zuordnen auf der Seite Eigenschaften.
Übergeordnetes Thema: Testzyklen


Hinzufügen von Meilensteinen

Ein Meilenstein ist ein Ziel, dass zu einem bestimmten Datum erreicht werden muss. Meilensteine sind besonders hilfreich, wenn die Kapazität der Tester nicht gleichmäßig auf den gesamten Testzyklus aufgeteilt werden kann. Diese Meilensteine werden durch Markierungen auf dem Burnup-Chart dargestellt (auf dem Dokument) und entsprechen unterschiedlichen Daten und Kapazitäten.

Hier ein Beispiel der Meilensteine eines Testzyklus:

  • Mindestens 20 Prozent des Tests müssen am 13. September beendet sein.
  • Mindestens 50 Prozent des Tests müssen am 15. September beendet sein.
  • 100 Prozent des Tests müssen am 19. September beendet sein (Ende Testzyklus).

So fügen Sie einen Meilenstein hinzu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen in der Kopfzeile eines Testzyklus auf ...Meilensteine bearbeiten. Der Dialog Meilensteine bearbeiten wird angezeigt.
  3. Klicken Sie auf Meilenstein hinzufügen, legen Sie ein Datum und einen Prozentsatz des Testfortschritts fest und klicken Sie auf OK.
  4. Klicken Sie auf [image], um einen Meilenstein zu bearbeiten. Klicken Sie auf [image], um einen Meilenstein zu löschen.
  5. Fügen Sie zusätzliche Meilensteine hinzu und klicken Sie auf Schließen.
Anmerkung: Stellen Sie beim Duplizieren eines Testzyklus oder dem Bearbeiten des Start- und Enddatums sicher, dass sich die Meilensteine weiterhin innerhalb des für den Testzyklus definierten Zeitraums befinden.
Übergeordnetes Thema: Testzyklen


Zuordnen von Tests zu Testzyklen

So ordnen Sie einem Testzyklus Tests zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Wählen Sie im Bereich Relevante Tests Tests aus, und ziehen Sie sie auf die Kopfzeile des gewünschten Testzyklus. Sie können auch mit der rechten Maustaste auf einen Tester klicken und Ausgewählte Tests zuweisen zu <manueller Tester> auswählen. Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen. Die Tests werden dem Testzyklus hinzugefügt.
Anmerkung: Sie können ein und denselben Test verschiedenen Testzyklen/Testern zuordnen. Wenn ein Test mindestens einmal zugeordnet ist, wird in der Spalte Zugeordnet im Bereich Relevante Tests ein grünes Häkchen angezeigt.
Übergeordnetes Thema: Testzyklen


Zuordnen von Tests zu manuellen Testern

Anmerkung: Bevor Sie manuellen Testern Tests zuordnen können, müssen die Tester dem jeweiligen Testzyklus hinzugefügt werden.

Ordnen Sie die Tests den manuellen Testern zu, um das Arbeitspensum auf die Tester aufzuteilen.

Sie können ein und denselben Test verschiedenen Testzyklen/Testern zuordnen. Wenn ein Test mindestens einmal zugeordnet ist, wird in der Spalte Zugeordnet im Bereich Relevante Tests ein grünes Häkchen angezeigt.

Sie können manuellen Testern Tests auch in der Ansicht Testzuordnung zuordnen. Klicken Sie rechts oben auf Testzuordnung. Wählen Sie im Bereich Zugeordnete Tests Tests aus, und ziehen Sie sie auf einen manuellen Tester in einem Testzyklus.

So ordnen Sie manuellen Testern Tests zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie in einem Testzyklus auf Tester zugewiesen, um die Liste der manuellen Tester anzuzeigen.
  3. Wählen Sie im Bereich Relevante Tests Tests aus, und ziehen Sie sie auf einen manuellen Tester in einem Testzyklus. Sie können auch mit der rechten Maustaste auf einen Tester klicken und Ausgewählte Tests zuweisen zu <manueller Tester> auswählen. Legen Sie die ausgewählten Tests auf dem [image] Symbol ab, um sie allen Testern zuzuordnen. Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
Übergeordnetes Thema: Testzyklen


Verschieben von Tests von einem Testzyklus in einen anderen

Sie können Tests von einem Testzyklus in einen anderen verschieben. Dies ist beispielsweise dann erforderlich, wenn Sie nicht alle Tests rechtzeitig beenden können und die ausstehenden Tests in den nächsten Testzyklus verschieben möchten.

So verschieben Sie Tests von einem Testzyklus in einen anderen:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie rechts oben auf Testzuordnung. Die Seite Manuelle Ausführungsplanung wird in der Ansicht Testzuordnung angezeigt.
  3. Klicken Sie links im Bereich Testzyklen auf die Kopfzeile eines Testzyklus.
  4. Wählen Sie im Bereich Zugeordnete Tests Tests aus, und ziehen Sie sie auf einen anderen Testzyklus. Sie können auch mit der rechten Maustaste auf einen Tester klicken und Ausgewählte Tests zuweisen zu <manueller Tester> auswählen.

    Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.

Übergeordnetes Thema: Testzyklen


Verschieben von Tests von einem Tester zu einem anderen

Sie können Tests von einem Tester zu einem anderen Tester mit freier Kapazität verschieben, um das Arbeitspensum innerhalb eines Testzyklus zu verteilen.

So verschieben Sie einen Test von einem manuellen Tester zu einem anderen manuellen Tester:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie rechts oben auf Testzuordnung. Die Seite Manuelle Ausführungsplanung wird in der Ansicht Testzuordnung angezeigt.
  3. Klicken Sie links im Bereich Testzyklen auf einen manuellen Tester. Die diesem manuellen Tester zugeordneten Tests werden im Bereich Zugeordnete Testspezifikationen angezeigt.
  4. Wählen Sie im Bereich Zugeordnete Tests Tests aus, und ziehen Sie sie auf einen anderen manuellen Tester. Sie können auch mit der rechten Maustaste auf einen Tester klicken und Ausgewählte Tests zuweisen zu <manueller Tester> auswählen.

    Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.

Übergeordnetes Thema: Testzyklen


Entfernen von Tests aus Testzyklen

So entfernen Sie Tests aus einem Testzyklus:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie rechts oben auf Testzuordnung. Die Seite Manuelle Ausführungsplanung wird in der Ansicht Testzuordnung angezeigt.
  3. Klicken Sie links im Bereich Testzyklen auf die Kopfzeile eines Testzyklus. Die dem Testzyklus zugeordneten Tests werden im Bereich Zugeordnete Testspezifikationen angezeigt.
  4. Klicken Sie auf [image], um einen Test aus dem Testzyklus zu entfernen.

    Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.

Anmerkung: Sie können keine Tests bzw. Tester aus einem beendeten Testzyklus entfernen. Sie können einen Test lediglich kopieren, indem Sie ihn per Drag&Drop in einen anderen Testzyklus bzw. Tester ziehen.
Übergeordnetes Thema: Testzyklen


Entfernen von Tests von manuellen Testern

So entfernen Sie Tests von einem manuellen Tester:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie rechts oben auf Testzuordnung. Die Seite Manuelle Ausführungsplanung wird in der Ansicht Testzuordnung angezeigt.
  3. Klicken Sie links im Bereich Testzyklen auf einen manuellen Tester. Die diesem manuellen Tester zugeordneten Tests werden im Bereich Zugeordnete Testspezifikationen angezeigt.
  4. Sie können Tests aus dem Testzyklus entfernen oder lediglich vom betreffenden manuellen Tester entfernen und im gleichen Testzyklus belassen:
    • So entfernen Sie einen Test von einem manuellen Tester und aus dem Testzyklus: Klicken Sie auf [image].
    • So entfernen Sie einen Test von einem manuellen Tester, belassen ihn jedoch im betreffenden Testzyklus: Klicken Sie im Bereich Zugeordnete Testspezifikationen auf den gewünschten Test, und ziehen Sie ihn auf Kein zugewiesener Tester im Bereich Testzyklen.

    Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.

Anmerkung: Tests von einem manuellen Tester können nicht entfernt werden, wenn dieser einem abgeschlossenen Testzyklus zugewiesen ist. Sie können einen Test lediglich kopieren, indem Sie ihn per Drag&Drop in einen anderen Testzyklus bzw. Tester ziehen.
Übergeordnetes Thema: Testzyklen


Importieren von Tests aus der Testsuite

Um einen Tests aus einer Testsuite importieren zu können, benötigen Sie die Berechtigung Verwalten von Testzyklen und Konfigurationen.
So importieren Sie Tests aus einem Ausführungsplan:
  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen in der Kopfzeile eines Testzyklus auf ... > Importieren von Tests aus der Testsuite. Der Dialog Testsuite auswählen wird angezeigt.
  3. Wählen Sie eine Testsuite aus, und klicken Sie auf OK. Alle Tests der Suite werden innerhalb des Testzyklus mit dem Merkmal Kein zugewiesener Tester versehen.
Übergeordnetes Thema: Testzyklen


Synchronisierung von Testzyklen

Synchronisieren Sie Testzyklen, wenn Sie die aktuellen Testläufe eines Testzyklus mit den Änderungen synchronisieren möchten, die in den zugeordneten Tests gemacht wurden.
Um einen Testzyklus synchronisieren zu können, benötigen Sie die Berechtigung Verwalten von Testzyklen und Konfigurationen.
So synchronisieren Sie einen Testzyklus:
  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen in der Kopfzeile eines Testzyklus auf ... > Testzyklus synchronisieren.
  3. Bestätigen Sie die Meldung, wenn Sie sicher sind, dass die aktuellen Testläufe eines Testzyklus mit den Änderungen, die in den zugeordneten Tests gemacht wurden, synchronisiert werden sollen.
Übergeordnetes Thema: Testzyklen


Duplizieren von Testzyklen

Um einen Testzyklus duplizieren zu können, benötigen Sie die Berechtigung Verwalten von Testzyklen und Konfigurationen.
So duplizieren Sie einen Testzyklus:
  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen in der Kopfzeile eines Testzyklus auf ... > Testzyklus duplizieren. Der Dialog Testzyklus duplizieren wird angezeigt. Die Eigenschaften (Name, Beschreibung, Startdatum, Enddatum und Kapazität) werden kopiert und in die jeweiligen Felder eingetragen.
  3. Optional: Wählen Sie, wie die Testzuordnung kopiert werden soll. Sie können z.B. auswählen, dass Tests mit dem Status Bestanden nicht kopiert werden, wodurch Sie den Testzyklus nur mit Tests mit dem Status Fehlgeschlagen und Nicht ausgeführt wiederholen können.
  4. Klicken Sie auf OK. Der Testzyklus mit allen seinen zugewiesenen Tests und Testern wird dupliziert.
Übergeordnetes Thema: Testzyklen


Verbergen von Testzyklen

Hier wird beschrieben, wie Testzyklen auf der Seite Manuelle Ausführungsplanung angezeigt werden, um diese sauber zuhalten und die Leistung zu verbessern. Dies ist besonders dann hilfreich, wenn Sie mehrere Testzyklen einplanen.

So verbergen Sie einen Testzyklus:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen auf Testzyklen anzeigen/verbergen. Verwenden Sie zusätzlich das Feld Suche um nur Testzyklen anzuzeigen, die das Suchwort enthalten. Der Dialog Sichtbare Testzyklen wird angezeigt.
  3. Deaktivieren Sie alle verborgenen Testzyklen und klicken Sie auf OK. Um alle beendeten Testzyklen auszublenden, klicken Sie auf Beendete deselektieren.
    Tipp: Öffnen das Kontextmenü der Kopfzeile einer Spalte, um die Testzyklen zu sortieren, zu filtern oder zu gruppieren. Wenn mehrere Testzyklen ausgewählt sind, können Sie deren Anzeige mit der Leertaste ein- und ausschalten.
  4. Um einen bestimmten Testzyklus schnell zu verbergen, können Sie ebenfalls auf ... in der Kopfzeile eines Testzyklus und anschließend auf Testzyklus verbergen klicken.
  5. Um einen verborgenen Testzyklus erneut anzuzeigen, klicken Sie erneut auf Testzyklen anzeigen/verbergen und aktivieren Sie den Testzyklus.
Falls Sie einen Testzyklus auf der Seite Manuelle Ausführungsplanung verbergen, wird dieser weiterhin in der Hierarchie Testausführung, in der Detailansicht, der Dokumentansicht sowie in den Dashboard-Panels und den Berichten angezeigt. Die Anzeigeeinstellungen sind benutzerdefiniert. Jeder Benutzer kann festlegen, welche Testzyklen er anzeigen und welche er verbergen möchte.
Übergeordnetes Thema: Testzyklen


Starten von Testzyklen

Anmerkung: Bevor Sie einen Testzyklus starten, überzeugen Sie sich davon, dass das Startdatum des Testzyklus dem aktuellen Datum entspricht. Ist dies nicht der Fall, müssen Sie sicherstellen, dass Sie den Testzyklus zu einem anderen Datum starten können.

So starten Sie einen Testzyklus:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen in der Kopfzeile eines Testzyklus auf ... > Testzyklus starten.

    Ein Testzyklus kann nur einmal gestartet werden. Wenn der Testzyklus bereits begonnen hat, ist diese Aktion deaktiviert. Für einen laufenden Testzyklus wird zwischen dem Start- und Enddatum der Testfortschritt angezeigt. Für einen Testzyklus, der nicht begonnen hat, wird Nicht gestartet angezeigt. Ein beendeter Testzyklus wird als Beendet angezeigt.

    Der Dialog Testzyklus starten wird angezeigt.
  3. Wählen Sie die Version und den Build des Produkts aus, das Sie testen möchten. Es werden alle Produkte angezeigt, die im Container der zugeordneten Tests definiert sind.
    Anmerkung: Um die Version und den Build zu bearbeiten, nachdem ein Testzyklus gestartet wurde, klicken sie auf ... > Version und Build aktualisieren.
  4. Klicken Sie auf OK.

Die zugeordneten manuellen Tests werden an die manuellen Tester verteilt. Die Tester werden per E-Mail benachrichtigt, und die Tests werden im Dashboard der einzelnen Tester im Panel Mir zugewiesene manuelle Tests angezeigt.

Nach Beginn eines Testzyklus können laufende Tests noch geändert, die Produktversion und der Build geändert, zusätzliche Tests zugeordnet, Tests entfernt oder von einem Tester zu einem anderen verschoben werden.

Übergeordnetes Thema: Testzyklen


Beenden von Testzyklen

Anmerkung: Bevor Sie einen Testzyklus beenden, überzeugen Sie sich davon, dass das Enddatum des Zyklus dem aktuellen Datum entspricht. Ist dies nicht der Fall, müssen Sie sicherstellen, dass Sie den Testzyklus zu einem anderen Datum beenden können.

So beenden Sie einen Testzyklus:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie im Bereich Testzyklen in der Kopfzeile eines Testzyklus auf ... > Testzyklus beenden.

    Wenn der Testzyklus noch nicht begonnen hat, ist diese Aktion deaktiviert. Für einen Testzyklus, der nicht ausgeführt wird, wird zwischen dem Start- und Enddatum Noch nicht gestartet angezeigt. Für einen laufenden Testzyklus wird Testfortschritt angezeigt. Ein beendeter Testzyklus wird als Beendet angezeigt.

  3. Der Dialog Testzyklus beenden wird angezeigt. Wählen Sie die Aktion, die für Tests durchgeführt werden soll, die noch nicht ausgeführt wurden, und klicken Sie auf Beenden. Die ausgewählte Statusänderung wird nur auf nicht-ausgeführte Tests angewendet, für welche keine Statusursache gesetzt wurde.
Anmerkung: Beendete Testzyklen sind gesperrt. Sie können keine Tests bzw. Tester zu einem beendeten Testzyklus hinzufügen oder daraus entfernen. Sie können einen Test lediglich kopieren, indem Sie ihn per Drag&Drop in einen anderen Testzyklus bzw. Tester ziehen.
Übergeordnetes Thema: Testzyklen


Löschen von Testzyklen

Anmerkung: Sie können Testzyklen auch in der Detailansicht oder der Dokumentansicht der Ausführungsplanung löschen. Klicken Sie mit der rechten Maustaste auf einen Testzyklus und anschließend auf Löschen.

So löschen Sie einen Testzyklus:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie in der Kopfzeile eines Testzyklus im Bereich Testzyklen auf ...Testzyklus löschen.
  3. Klicken Sie im folgenden Bestätigungsdialogfeld auf Ja.
Übergeordnetes Thema: Testzyklen


Testzuordnung

Sie rufen diese Seite auf, indem Sie auf Ausführungsplanung > Manuelle Ausführungsplanung klicken. Klicken Sie oben rechts auf Testzuordnung.

Die Ansicht Testzuordnung ist die zweite Ansicht auf der Seite Manuelle Ausführungsplanung. Hier können Sie die dem ausgewählten Testzyklus zugeordneten manuellen Tests wie gewünscht planen.

  • Testzyklen
    Ein Testzyklus ist ein durch ein Start- und Enddatum definierter Zeitraum, für den manuelle Tester festgelegt wurden. Erstellen Sie Testzyklen um die Ausführung einer bestimmten Menge von Tests zu planen und durchzuführen.
  • Zugeordnete Tests
    Zeigt die manuellen Tests an, die dem ausgewählten Testzyklus oder manuellen Tester zugeordnet sind.
  • Manuelles Testen von Konfigurationen
    Hier wird beschrieben, wie Sie manuellen Tests im Bereich Zugeordnete Tests Konfigurationen zuweisen.
Übergeordnetes Thema: Manuelle Ausführungsplanung


Zugeordnete Tests

Im Bereich Zugeordnete Tests werden die Tests angezeigt, die dem ausgewählten Testzyklus oder manuellen Tester zugeordnet sind. Um die zugeordneten Tests mehrerer Tester eines Testzyklus anzuzeigen, wählen Sie die Tester in einem Testzyklus mit Strg+Klick oder Umschalt+Click aus.

Die Überschrift der Tabelle Zugeordnete Tests gibt Folgendes an:

  • Den Namen des aktuell ausgewählten Testzyklus.
  • Den Namen des aktuell ausgewählten Testers.

In der Tabelle können Sie folgende Aktionen durchführen:

  • Um einen manuellen Test zu einem anderen Testzyklus zuzuordnen, ziehen Sie den Test auf die Kopfzeile des gewünschten Testzyklus.
  • Um einen manuellen Test einem (anderen) manuellen Tester zuzuordnen, ziehen Sie den Test auf den gewünschten Tester im betreffenden Testzyklus.
  • Öffnen Sie das Kontextmenü der Kopfzeile einer Spalte, um die manuellen Tests zu sortieren, zu gruppieren oder zu filtern, Spalten hinzuzufügen oder zu entfernen oder um Filter oder die Ansicht zurückzusetzen.
  • Klicken Sie mit der rechten Maustaste auf einen manuellen Test, um die Testdetails anzuzeigen, Konfigurationen für den Test anzugeben oder um den Test aus dem Testzyklus zu entfernen.
  • Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  • Klicken Sie auf Von Testzyklus entfernen, um einen Test aus dem Testzyklus zu entfernen.
  • Klicken sie auf für Details auf Testdetails anzeigen.
  • Klicken sie für Ergebnisse auf Ergebnisse manueller Tests anzeigen.
  • Klicken Sie auf Gehe zum Test, um den Test in der Detailansicht von Tests anzuzeigen.
  • Um einen Test von einem manuellen Tester, nicht jedoch aus dem Testzyklus zu entfernen, ziehen Sie den Test im Testzyklus auf Kein zugewiesener Tester.
  • Um die Reihenfolge der Ausführung zu ändern, klicken Sie in das Feld Reihenfolge, geben Sie eine Reihenfolgennummer ein, und drücken Sie die Eingabetaste.
    Tipp: Wenn Sie Tests von mehreren Containern oder Konfigurationen zuordnen, sind die Reihenfolgennummern nicht eindeutig. In diesem Fall können Sie die Tests nach den Spalten Container oder Konfiguration gruppieren.
Anmerkung: Wenn Sie im Bereich Filterkriterien einen Filter oder einen Qualitätszielwert anwenden, werden die nicht dem Filter entsprechenden Tests in der Tabelle Zugeordnete Tests deaktiviert.
Übergeordnetes Thema: Testzuordnung


Manuelles Testen von Konfigurationen

Sie können einen manuellen Test mit verschiedenen Software- und Hardwarekonfigurationen ausführen.

So weisen Sie einem manuellen Test Konfigurationen zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Manuelle Ausführungsplanung. Die Seite Manuelle Ausführungsplanung wird angezeigt.
  2. Klicken Sie rechts oben auf Testzuordnung. Die Seite Manuelle Ausführungsplanung wird in der Ansicht Testzuordnung angezeigt.
  3. Klicken Sie mit der rechten Maustaste im Bereich Zugeordnete Tests auf einen Test.

    Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.

  4. Klicken Sie auf Konfigurationen auswählen. Der Dialog Konfigurationen auswählen wird angezeigt.
  5. Klicken sie auf > oder < um die ausgewählten Konfigurationen hinzuzufügen oder zu entfernen. Sie können auch eine neue Konfiguration erstellen, indem Sie im Feld Auswahl oder Eingabe von Konfigurationen einen neuen Namen eingeben und anschließend auf > klicken.

    Wenn Sie Ihre Konfigurationen ausführlicher bearbeiten und einrichten möchten, klicken Sie auf Ausführungsplanung > Konfigurationen.

    Für jede Konfiguration wird eine Instanz des Tests in die Tabelle Zugeordnete Tests aufgenommen.
    Anmerkung: Wenn Sie die Zuordnung einer Konfiguration entfernen, wird diese für den aktuell ausgewählten Tester deaktiviert. Anderen Testern zugeordnete Instanzen werden jedoch nicht entfernt.
  6. Klicken Sie auf OK.
Sie können die neuen Testinstanzen verschiedenen manuellen Testern und Testzyklen zuweisen.
Übergeordnetes Thema: Testzuordnung


Manuelles Testen

Die Silk Central-Funktion "Manuelles Testen" ermöglicht Testern die effiziente Ausführung manueller Tests. Das Fenster Manuelles Testen weist eine intuitive, leicht zu bedienende Benutzeroberfläche auf, die nur die für den manuellen Tester während des Testvorgangs relevanten Informationen enthält.

Manuelle Tester erhalten über das Dashboard-Panel Mir zugewiesene manuelle Tests schnellen Zugriff auf das Fenster Manuelles Testen. Weitere Informationen zum Dashboard und zu Panels finden Sie unter Dashboard. Der Dialog Manuelles Testen ist folgendermaßen aufgebaut: Im Übersichtsbereich werden die Tests aufgelistet, die sich in der ausgewählten Testsuite oder dem ausgewählten Testzyklus befinden. Im Testschrittbereich (unten) wird eine Liste der einzelnen Testschritte angezeigt, die für den ausgewählten Test konfiguriert wurden. Manuelle Tester können die Schritte von oben nach unten abarbeiten.

Als manueller Tester können Sie die einzelnen Tests und Testschritte abhaken, sobald Sie sie erfolgreich durchgeführt haben, einen Ergebnistext schreiben, Fehler erstellen und zuordnen sowie Ergebnisdateien anhängen. Darüber hinaus können Sie Screenshots und Videos aufzeichnen, um zu illustrieren, wie Sie einen Test oder Testschritt durchgeführt haben, oder um Fehler aufzuzeigen, die während des Testvorgangs aufgetreten sind.

Der integrierte Timer zeigt an, wie viel Zeit Sie für die Ausführung eines Tests benötigt haben, und der Testfortschritt wird in einem Balken dargestellt. Das Testbook (das in einem Panel angezeigt wird, das Sie Ihrem Dashboard hinzufügen können) zeigt Ihnen Aktualisierungen in Echtzeit zu allen Aktivitäten, die während der manuellen Tests für ein Projekt stattfinden.

  • Manuelles Testen (Fenster)
    Hier werden die Struktur und die einzelnen Bereiche des Fensters Manuelles Testen beschrieben.
  • Aufzeichnen von Screenshots
    Hier werden das Aufzeichnen von Screenshots und das Bearbeiten des Fensters Screenshots aufzeichnen mithilfe von Tastaturkommandos beschrieben.
  • Videos aufzeichnen
    Hier wird beschrieben, wie im Fenster Manuelles Testen Videos aufgezeichnet werden.
  • Anhängen von Ergebnisdateien
    Hier wird beschrieben, wie eine Ergebnisdatei angehängt wird.
  • Zuordnen oder Erstellen von Fehlern
    Hier wird beschrieben, wie ein neuer Fehler erstellt und ein vorhandener Fehler zugeordnet wird.
  • Auswählen von mobilen Geräten für manuelles Testen
    Wählen Sie ein mobiles Gerät aus (physisches Gerät, Emulator oder Simulator), auf dem Ihr manueller Test ausgeführt werden soll.
  • Codeanalyse starten
    Hier wird beschrieben, wie im Fenster Manuelles Testen die Codeanalyse gestartet wird.
  • Bearbeiten von Version und Build
    Hier wird beschrieben, wie die Version und der Build im Fenster Manuelles Testen bearbeitet werden.
  • Status von Tests und Testschritten
    Beschreibt, wie Silk Central automatisch einen Teststatus in Abhängigkeit der Schrittstatus errechnet und wie Sie einen Teststatus manuell festlegen können.
  • Drucken von manuellen Tests
    Hier wird beschrieben, wie ein manueller Test ausgedruckt oder als PDF heruntergeladen wird. Sie können die Testergebnisse per Hand in den Vordruck eintragen.
  • Testbook
    Beschreibt den Zweck und die Funktionen des Testbook.
  • Manuelle Offline-Tests
    Hier wird beschrieben, wie man manuelle Tests herunter- und hochlädt und wie man offline damit arbeitet.
Übergeordnetes Thema: Manuelle Ausführungsplanung
Zugehörige Konzepte
Dashboard


Manuelles Testen (Fenster)

Klicken Sie zum Öffnen des Fensters Manuelles Testen im Menü auf Startseite > Mein Dashboard und anschließend im Panel Mir zugewiesene manuelle Tests auf [image] (Manuellen Test fortsetzen). Wenn dieses Panel nicht auf Ihrem Dashboard angezeigt wird, müssen Sie es hinzufügen. Weitere Informationen zum Dashboard und zu Panels finden Sie unter Dashboard.

Sie können auch auf das Fenster Manuelles Testen auf der Seite Aktivitäten (klicken Sie im Menü auf Verfolgen > Aktivitäten) in der Tabelle Aktuelle Testausführungen oder auf der Seite Aktueller Testlauf zugreifen.

Das Fenster Manuelles Testen ist in zwei Bereiche unterteilt:
  • Der Übersichtsbereich (oben).
  • Der Testschrittbereich (unten).
  • Übersichtsbereich
    Hier werden die Gliederung und die Steuerelemente des Übersichtsbereichs beschrieben.
  • Bereich "Testschritte"
    Hier werden die Gliederung und die Steuerelemente des Bereichs "Testschritte" beschrieben.
  • Benutzeroberfläche von mobilen Geräten
    Wenn Sie ein mobiles Gerät zur manuellen Testausführung auswählen, wird Ihnen die Benutzeroberfläche von mobilen Geräten angezeigt.
Übergeordnetes Thema: Manuelles Testen
Zugehörige Konzepte
Dashboard


Übersichtsbereich

Der Übersichtsbereich ist der obere Bereich des Fensters Manuelles Testen.

Der Übersichtsbereich enthält folgende Bestandteile:

Element | Schaltfläche | Beschreibung
Testsuite oder Testzyklus | Der Name der Testsuite oder des Testzyklus, die/der die Tests enthält.
Einstellungen bearbeiten Klicken Sie auf die Schaltfläche, um folgende Einstellungen zu bearbeiten:
  • Sie können konfigurieren, ob der nächste Test/Testschritt automatisch ausgewählt werden soll, wenn der Status eines Tests/Testschritts sich ändert.
  • Sie können konfigurieren, welche zusätzlichen Testinformationen im Übersichtsbereich angezeigt werden.
  • Sie können bestimmte Aktionen ausblenden oder anzeigen (wie z. B. die Aktion Version und Build bearbeiten).
  • Sie können angeben, ob Videos mit oder ohne Audio aufgezeichnet werden sollen.
Diese Einstellungen können einzeln für jeden Benutzer definiert werden.
Fertig stellen | Klicken Sie auf Beenden, um den Testlauf zu beenden. Diese Option wird nur dann angezeigt, wenn Sie einen Test öffnen, der nicht zugeordnet oder einer Testsuite zugeordnet ist. Sie wird nicht angezeigt, wenn Sie einen Test öffnen, der einem Testzyklus zugeordnet ist. Wählen Sie die Aktion, die für Tests durchgeführt werden soll, die noch nicht ausgeführt wurden, und klicken Sie auf Beenden. Die ausgewählte Statusänderung wird nur auf nicht-ausgeführte Tests angewendet, für welche keine Statusursache gesetzt wurde.
Bestanden | Klicken Sie auf diese Schaltfläche, um den Status des aktuell ausgewählten Tests als Bestanden zu markieren und automatisch zum nächsten Test zu springen. Dies ist die Standardeinstellung der Schaltfläche.
Fehlgeschlagen | Klicken Sie auf diese Schaltfläche, um den Status des aktuell ausgewählten Tests als Fehlgeschlagen zu markieren und automatisch zum nächsten Test zu springen.
Testname | Die nun angezeigte Liste enthält alle Tests der ausgewählten Testsuite oder des ausgewählten Testzyklus mit ihren aktuellen Status. Klicken Sie auf einen Test oder drücken Sie die Auf und Ab Tasten, um durch Tests und ihre Testschritte zu navigieren. Wenn Sie die Ausführung eines Tests mit einer bestimmten Konfiguration festgelegt haben, wird der Name der Konfiguration in Klammern neben dem Namen des Tests angezeigt. Weitere Informationen finden Sie unter Testen mit manueller Konfiguration. Klicken Sie auf [image], um den Test in der Detailansicht im Bereich Tests anzuzeigen.
Zugeordnete Anforderungen | Klicken Sie auf diese Schaltfläche, um sich die Anforderungen anzeigen zu lassen, die dem Test zugeordnet wurden. Diese Schaltfläche wird nur dann angezeigt, wenn mindestens eine Anforderung zugeordnet wurde. Die Zahl neben der Schaltfläche gibt an, wie viele Anforderungen zugeordnet wurden.
Zugeordnete Fehler | Klicken Sie auf diese Schaltfläche, um sich die Fehler anzeigen zu lassen, die dem Test zugeordnet wurden. Diese Schaltfläche wird nur dann angezeigt, wenn mindestens ein Fehler zugeordnet wurde. Die Zahl neben der Schaltfläche gibt an, wie viele Fehler zugeordnet wurden. Das Dialogfeld Fehler zeigt sowohl die Fehler an, die dem Test zugeordnet wurden, als auch die Fehler, die den Testschritten zugeordnet wurden.
Zugeordnete Anhänge | Klicken Sie auf diese Schaltfläche, um sich die Anhänge anzeigen zu lassen, die dem Test zugeordnet wurden. Diese Schaltfläche wird nur dann angezeigt, wenn mindestens ein Anhang zugeordnet wurde. Die Zahl neben der Schaltfläche gibt an, wie viele Anhänge zugeordnet wurden.
Auf blockiert setzen/Auf nicht blockiert setzen | Klicken Sie die Schaltfläche um den Test auf blockiert/nicht blockiert zu setzen. Einen Test auf blockiert zu setzen ist ein nützlicher Hinweis darauf, dass ein Test nicht ausgeführt werden kann auf Grund bestimmter Einschränkungen, zum Beispiel ein Problem mit der IT Infrastruktur.
Teststatus | Der Status des Tests. Er kann automatisch oder manuell festgelegt werden. Klicken Sie auf [image] neben dem Statussymbol, um einen Status auszuwählen. Weitere Informationen finden Sie unter Status von Tests und Testschritten.
Version und Build bearbeiten

Klicken Sie auf diese Schaltfläche, um die Version und den Build zu bearbeiten. Weitere Informationen finden Sie unter Version und Build bearbeiten.
Testlauf-Kommentar | Geben Sie eine übersichtliche Beschreibung für den Testlauf ein. Dadurch kann der Überprüfungsprozess der Testausführung beschleunigt werden, da dieser Kommentar in den Testlauf-Tabellen angezeigt wird.
Screenshot erstellen | Klicken Sie auf diese Schaltfläche, um einen Screenshot des Bildschirms zu erstellen und ihn an den Test anzuhängen. Der aufgezeichnete Screenshot wird zur Liste mit Anhängen hinzugefügt. Weitere Informationen finden Sie unter Aufzeichnen von Screenshots.
Video aufzeichnen | Klicken Sie auf diese Schaltfläche, um ein Video zu den Aktionen auf dem Bildschirm aufzuzeichnen und es an den Test anzuhängen. Das Video wird zur Liste mit Anhängen hinzugefügt, und Sie können es auf Ihrem lokalen Dateisystem speichern. Weitere Informationen finden Sie unter Videos aufzeichnen.
Ergebnisdatei anhängen | Klicken Sie auf diese Schaltfläche, um eine Ergebnisdatei an den Test anzuhängen. Weitere Informationen finden Sie unter Anhängen von Ergebnisdateien.
Fehler zuweisen oder erzeugen | Klicken Sie auf diese Schaltfläche, um einen neuen Fehler zu erstellen und ihn an den Test anzuhängen oder um einen vorhandenen Fehler zuzuordnen. Weitere Informationen finden Sie unter Zuordnen oder Erstellen von Fehlern.
Gerät auswählen | Wählen Sie ein mobiles Gerät aus (physisches Gerät, Emulator oder Simulator), auf dem Ihr manueller Test ausgeführt werden soll. Weitere Informationen finden Sie unter Auswählen von mobilen Geräten.
Codeanalyse starten | Klicken Sie auf die Schaltfläche zum Starten der Codeanalyse. Der Dialog Codeanalyse starten wird angezeigt. Wählen Sie ein Profil, und geben Sie einen oder mehr Hostnamen ein. Wenn bereits Abdeckungsinformationen für diesen Test vorliegen, können Sie sie durch Aktivieren des Kontrollkästchens ersetzen. Klicken Sie auf Codeanalyse starten, um den Vorgang tatsächlich zu starten. Wenn Sie auf Codeanalyse beenden klicken, speichert Silk Central die Codeanalyseinformationen für den Testlauf.
Testausführung synchronisieren | Klicken Sie auf diese Schaltfläche, um einen Testlauf mit einem adaptierten Test zu synchronisieren. Wenn Sie bereits mit der Durchführung eines Tests begonnen haben und nun Änderungen an diesem Test in dem Bereich Tests vornehmen möchten, können Sie den Testlauf mit dem adaptierten Test synchronisieren.
Anmerkung: Sie können auch in einen beliebigen Bereich außerhalb des Dialogfelds oder auf [image] (Schließen) klicken, um ein Dialogfeld zu schließen.
Übergeordnetes Thema: Manuelles Testen (Fenster)
Zugehörige Tasks
Manuelles Testen von Konfigurationen
Bearbeiten von Version und Build
Aufzeichnen von Screenshots
Videos aufzeichnen
Anhängen von Ergebnisdateien
Zuordnen oder Erstellen von Fehlern
Zugehörige Verweise
Status von Tests und Testschritten


Bereich "Testschritte"

Der Bereich "Testschritte" befindet sich im Fenster Manuelles Testen unterhalb des Übersichtsbereichs.

Der Bereich "Testschritte" enthält:

Element | Schaltfläche | Beschreibung
Benötigte Zeit bearbeiten |  | Klicken Sie auf die Schaltfläche, um die tatsächliche Dauer des Tests manuell einzugeben. Wenn Sie das Fenster Manuelles Testen öffnen oder einen anderen Test auswählen, startet der Timer automatisch. Der blinkende Doppelpunkt zeigt an, dass der Timer läuft. Klicken Sie auf [image] , um den Timer anzuhalten, oder auf [image] , um den Timer zu starten. Die Zahlen links zeigen die tatsächliche Dauer an, die Zahlen rechts die geplante Dauer.
Fortschrittsbalken |  | Zeigt den Testfortschritt an. Der Fortschrittsbalken zeigt an, wie viele Testschritte bereits durchgeführt wurden.
Nachricht ins Testbook schreiben |  | Klicken Sie auf die Schaltfläche, um eine Nachricht im Testbook zu posten.
Bestanden |  | Klicken Sie auf diese Schaltfläche, um den Status des aktuell ausgewählten Testschritts als Bestanden zu markieren und automatisch zum nächsten Testschritt zu springen. Dies ist die Standardeinstellung der Schaltfläche.
Fehlgeschlagen |  | Klicken Sie auf diese Schaltfläche, um den Status des aktuell ausgewählten Testschritts als Fehlgeschlagen zu markieren und automatisch zum nächsten Testschritt zu springen. Dies ist die Standardeinstellung der Schaltfläche.
Details anzeigen/ausblenden |  | Klicken Sie auf diese Schaltfläche, um einen Testschritt anzuzeigen und detaillierte Informationen wie die Aktionsbeschreibung oder die Erwarteten Ergebnisse sowie alle Schaltflächen und das Ergebnisfeld anzuzeigen.
Name des Testschritts |  | Der Name des Testschritts. Testschritte mit dem Status Nicht ausgeführt werden fett angezeigt.
Zugeordnete Fehler |  | Klicken Sie auf diese Schaltfläche, um sich die Fehler anzeigen zu lassen, die dem Testschritt zugeordnet wurden. Diese Schaltfläche wird nur dann angezeigt, wenn mindestens ein Fehler zugeordnet wurde. Die Zahl neben der Schaltfläche gibt an, wie viele Fehler zugeordnet wurden.
Zugeordnete Anhänge |  | Klicken Sie auf diese Schaltfläche, um sich die Anhänge anzeigen zu lassen, die dem Testschritt zugeordnet wurden. Diese Schaltfläche wird nur dann angezeigt, wenn mindestens ein Anhang zugeordnet wurde. Die Zahl neben der Schaltfläche gibt an, wie viele Anhänge zugeordnet wurden.
Schrittstatus |  | Der Status des Schritts. Klicken Sie auf [image] neben dem Statussymbol, um einen Status auszuwählen. Silk Central errechnet automatisch einen Teststatus basierend auf den Schrittstatus. Weitere Informationen finden Sie unter Status von Tests und Testschritten.
Ergebnisfeld |  | Geben Sie den Ergebnistext in das Feld ein. Klicken Sie außerhalb des Feldes, um den Text zu speichern.
Screenshot erstellen |  | Klicken Sie auf diese Schaltfläche, um einen Screenshot des Bildschirms zu erstellen und ihn an den Testschritt anzuhängen. Der aufgezeichnete Screenshot wird zur Liste mit Anhängen hinzugefügt. Weitere Informationen finden Sie unter Aufzeichnen von Screenshots.
Video aufzeichnen |  | Klicken Sie auf diese Schaltfläche, um ein Video zu den Aktionen auf dem Bildschirm aufzuzeichnen und es an den Testschritt anzuhängen. Das Video wird zur Liste mit Anhängen hinzugefügt, und Sie können es auf Ihrem lokalen Dateisystem speichern. Weitere Informationen finden Sie unter Videos aufzeichnen.
Ergebnisdatei anhängen |  | Klicken Sie auf diese Schaltfläche, um eine Ergebnisdatei an den Testschritt anzuhängen. Weitere Informationen finden Sie unter Anhängen von Ergebnisdateien.
Fehler zuweisen oder erzeugen |  | Klicken Sie auf diese Schaltfläche, um einen neuen Fehler zu erstellen und ihn an den Testschritt anzuhängen, oder um einen vorhandenen Fehler zuzuordnen. Weitere Informationen finden Sie unter Zuordnen oder Erstellen von Fehlern.
Anmerkung: Sie können auch in einen beliebigen Bereich außerhalb des Dialogfelds oder auf [image] (Schließen) klicken, um ein Dialogfeld zu schließen.
Tipp: Sie können bei der Durchführung eines Tests die Tastatur verwenden: Wenn Sie den Status des ausgewählten Testschritts ändern möchten, drücken Sie Strg+Umschalttaste+A (für "bestanden") bzw. Strg+Umschalttaste+S (für "fehlgeschlagen"). Diese Tastenkombinationen lassen sich problemlos mit einer Hand drücken. Drücken Sie die Pfeiltasten Auf und Ab, um durch die einzelnen Tests und ihre Schritte zu navigieren, drücken Sie die Pfeiltaste Rechts, um einen Schritt zu erweitern, oder die Pfeiltaste Links, um ihn zu auszublenden. Wenn Sie ein Dialogfeld schließen möchten, drücken Sie auf Esc.
Übergeordnetes Thema: Manuelles Testen (Fenster)
Zugehörige Tasks
Aufzeichnen von Screenshots
Videos aufzeichnen
Anhängen von Ergebnisdateien
Zuordnen oder Erstellen von Fehlern
Zugehörige Verweise
Status von Tests und Testschritten


Benutzeroberfläche von mobilen Geräten

Wenn Sie ein mobiles Gerät zur manuellen Testausführung auswählen, wird Ihnen die Benutzeroberfläche von mobilen Geräten angezeigt.

Mit Ihrer Maus können Sie mit der emulierten Anzeige des Geräts interagieren. Verwenden Sie die Symbole auf der rechten Seite der Anzeige um das Gerät zu drehen, oder um Pinch-in und Pinch-out Aktionen auszuführen.

Verwenden Sie das Textsymbol, um Text in das aktuell aktive Feld einzugeben. Das Textsymbol unterstützt auch den „Input Method Editor“ (IME) für die Eingabe von Multibyte-Zeichen.

Einschränkungen für iOS:
  • Es kann nur ein Simulator pro Benutzersitzung ausgeführt werden, aber Tests können gleichzeitig auf mehreren physischen Geräten ausgeführt werden.
  • Die HOME-Taste wird beim Testen auf Sauce Labs Geräten nicht unterstützt.
  • Sollte ein Gerät nicht mehr erreichbar sein, beenden Sie den Geräte-Stream und starten Sie ihn erneut um mit Ihrem Test fortzufahren.
Übergeordnetes Thema: Manuelles Testen (Fenster)
Zugehörige Tasks
Auswählen von mobilen Geräten für manuelles Testen


Aufzeichnen von Screenshots

Wenn Sie im Fenster Manuelles Testen Tests durchführen, können Sie Screenshots von Ihrem Bildschirm aufzeichnen. Die aufgezeichneten Screenshots werden dem Test oder Testschritt zugeordnet. Diese Funktion ist besonders dann hilfreich, wenn ein Testschritt fehlschlägt und Sie ermitteln möchten, wann, wo und wie der Fehler aufgetreten ist.

Stellen Sie sicher, dass Java Runtime Environment (JRE) auf Ihrem Computer installiert ist und die Anwendung ausgeführt werden kann. Sie können JRE unter Java SE Downloads herunterladen. Wenn Ihr Browser NPAPI nicht unterstützt, schlägt Silk Central automatisch vor eine JNLP-Datei herunterzuladen, welche benötigt wird, um diese Funktionalität zu ermöglichen.

So erstellen Sie einen Screenshot:

  1. Öffnen Sie das Fenster Manuelles Testen. Weitere Informationen finden Sie unter Manuelles Testen (Fenster).
  2. Klicken Sie links auf [image] (Details anzeigen), um einen Testschritt zu erweitern.
  3. Klicken Sie auf [image] (Screenshot erstellen).Wenn Ihr Browser NPAPI nicht unterstützt, schlägt Silk Central automatisch vor eine JNLP-Datei herunterzuladen, welche benötigt wird, um diese Funktionalität zu ermöglichen. Nachdem die JNLP-Anwendung läuft, klicken Sie erneut auf [image]. Die Funktion Screenshots wird gestartet.
  4. Führen Sie eine der folgenden Aktionen aus:
    • Ziehen Sie mit der Maus ein Rechteck, um den aufzuzeichnenden Bereich auszuwählen.
    • Drücken Sie Eingabe, um einen Screenshot des gesamten Bildschirms aufzuzeichnen. Wenn Sie mehr als einen Monitor benutzen, werden die Bildschirme aller Monitore aufgezeichnet.
    • Drücken Sie Esc, um abzubrechen.
    Das Fenster Screenshots wird angezeigt.
  5. Bearbeiten Sie den Screenshot wie gewünscht. Sie können Texte und grafische Elemente wie Pfeile oder Rechtecke hinzufügen. Sie können im Editor mit der Tastatur folgende Aktionen durchführen:
    • Drücken Sie auf die Pfeiltasten, um die einzelnen Objekte (z. B. Rechtecke oder Pfeile) zu verschieben. Halten Sie Umschalt gedrückt, und drücken Sie auf die Pfeiltasten, um die Position präzise einzustellen.
    • Wählen Sie mithilfe des Tools Verschieben ein Objekt aus, und drücken Sie auf die Rücktaste oder Entf, um das Objekt zu entfernen.
    • Wenn Sie das Text-Tool verwenden, können Sie auf die Tasten Umschalt+Eingabe drücken, um die Eingabe zu bestätigen, oder auf Esc, um den Vorgang abzubrechen.
    • Drücken Sie auf Strg+C, um den Screenshot in die Zwischenablage zu kopieren.
  6. Klicken Sie auf Hochladen. Der Screenshot wird an den Testschritt angehängt.
  7. Klicken Sie auf [image], um den angehängten Screenshot anzuzeigen. Das Dialogfeld Anhänge mit einer Liste aller angehängten Dateien wird angezeigt.
  8. Klicken Sie auf [image] (Ergebnisdatei löschen), um die angehängten Ergebnisdateien zu löschen, oder auf [image] (Öffnen), um sie zu öffnen.
    Anmerkung: In diesem Dialog können Sie nur Dateien löschen, die Sie während des aktuellen Testlaufs angehängt haben. Dateien, die dem Test vor dem Start des Testzyklus/der Testsuite zugeordnet wurden, können nicht gelöscht werden.
Anmerkung: Sie können die in diesem Thema beschriebene Aufgabe sowohl auf Test- als auch auf Schrittebene ausführen.
Übergeordnetes Thema: Manuelles Testen
Zugehörige Konzepte
Manuelles Testen (Fenster)


Videos aufzeichnen

Wenn Sie Tests im Fenster Manuelles Testen durchführen, können Sie Videos des Testvorgangs aufzeichnen. Diese Funktion ist besonders dann hilfreich, wenn ein Testschritt fehlschlägt und Sie ermitteln möchten, wann, wo und wie der Fehler aufgetreten ist.

Das Video wird an den Testschritt angehängt, bei dem Sie die Aufzeichnung gestartet haben. Zum Beispiel: Wenn Sie die Aufzeichnung beim zweiten Schritt starten und während der Aufzeichnung mit dem dritten und vierten Schritt fortfahren, wird das Video an den zweiten Schritt angehängt.

Stellen Sie sicher, dass Java Runtime Environment (JRE) auf Ihrem Computer installiert ist und die Anwendung ausgeführt werden kann. Sie können JRE unter Java SE Downloads herunterladen. Wenn Ihr Browser NPAPI nicht unterstützt, schlägt Silk Central automatisch vor eine JNLP-Datei herunterzuladen, welche benötigt wird, um diese Funktionalität zu ermöglichen.

Einschränkungen:
  • Die Videoaufzeichnung wird nur auf Microsoft Windows-Mandantenrechnern unterstützt.
  • Die Videoaufnahme wird auf Microsoft Windows 10 N und KN Editionen nicht unterstützt.
  • Die Videoaufzeichnung von WPF-Fenstern in der klassischen Ansicht von Windows 7 wird nicht unterstützt.
  • Die Videoaufzeichnung in einer 4K-Auflösung wird nicht unterstützt.

So zeichnen Sie ein Video auf:

  1. Öffnen Sie das Fenster Manuelles Testen. Weitere Informationen finden Sie unter Manuelles Testen (Fenster).
  2. Klicken Sie links auf [image] (Details anzeigen), um einen Testschritt zu erweitern.
  3. Klicken Sie auf [image] (Video aufzeichnen). Wenn Ihr Browser NPAPI nicht unterstützt, schlägt Silk Central automatisch vor eine JNLP-Datei herunterzuladen, welche benötigt wird, um diese Funktionalität zu ermöglichen. Nachdem die JNLP-Anwendung läuft, klicken Sie erneut auf [image]. Wenn geeignete Audio-Geräte gefunden werden, wird das Video mit Audio aufgezeichnet. Sollten mehrere Audio-Geräte angeschlossen sein, wird das zuerst gefundene verwendet. Klicken Sie auf [image] um die Audioeinstellung zu aktivieren, da sie standardmäßig deaktiviert ist. Wenn Sie diese Einstellung ändern, müssen Sie die Video-Aufzeichnung neu starten. Das Fenster Videoaufzeichnung wird angezeigt und die Aufzeichnung startet automatisch.
  4. Wenn Sie fertig sind, klicken Sie auf Videoaufzeichnung stoppen.
  5. Geben Sie einen Ergebnisdateinamen ein, und klicken Sie auf Datei hochladen, um das Video an den Testschritt anzuhängen. Sie können auch auf Datei speichern klicken, um sie auf Ihrem lokalen Computer zu speichern.
  6. Klicken Sie auf Schließen.
  7. Wenn Sie das angehängte Video anzeigen möchten, klicken Sie auf [image]. Das Dialogfeld Anhänge mit einer Liste aller angehängten Dateien wird angezeigt.
  8. Klicken Sie auf [image] (Ergebnisdatei löschen), um die angehängten Ergebnisdateien zu löschen, oder auf [image] (Öffnen), um sie zu öffnen.
    Anmerkung: In diesem Dialog können Sie nur Dateien löschen, die Sie während des aktuellen Testlaufs angehängt haben. Dateien, die dem Test vor dem Start des Testzyklus/der Testsuite zugeordnet wurden, können nicht gelöscht werden.
Anmerkung: Sie können die in diesem Thema beschriebene Aufgabe sowohl auf Test- als auch auf Schrittebene ausführen.
Übergeordnetes Thema: Manuelles Testen
Zugehörige Konzepte
Übersichtsbereich
Bereich "Testschritte"
Manuelles Testen (Fenster)
Zugehörige Verweise
Status von Tests und Testschritten


Anhängen von Ergebnisdateien

Wenn Sie Tests im Fenster Manuelles Testen durchführen, können Sie an jeden Testschritt Ergebnisdateien anhängen.

So hängen Sie eine Ergebnisdatei an:

  1. Öffnen Sie das Fenster Manuelles Testen. Weitere Informationen finden Sie unter Manuelles Testen (Fenster).
  2. Klicken Sie links auf [image] (Details anzeigen), um einen Testschritt zu erweitern.
  3. Klicken Sie auf [image] (Ergebnisdatei anhängen). Der Systemdateimanager wird geöffnet.
  4. Suchen Sie die anzuhängende Datei, und bestätigen Sie die Auswahl. Die Datei wird an den Testschritt angehängt.
  5. Wenn Sie die anzuhängende Datei anzeigen möchten, klicken Sie auf [image]. Der Dialog Anhänge mit einer Liste aller angehängten Dateien wird angezeigt.
  6. Klicken Sie auf [image] (Ergebnisdatei löschen), um die angehängten Ergebnisdateien zu löschen, oder auf [image] (Öffnen), um sie zu öffnen.
    Anmerkung: In diesem Dialog können Sie nur Dateien löschen, die Sie während des aktuellen Testlaufs angehängt haben. Dateien, die dem Test vor dem Start des Testzyklus/der Testsuite zugeordnet wurden, können nicht gelöscht werden.
Anmerkung: Sie können die Größe der Ergebnisdateien begrenzen, die Tester hochladen dürfen. Weitere Informationen finden Sie unter Festlegen der maximalen Größe von Testschritt-Ergebnisdateien.
Anmerkung: Sie können die in diesem Thema beschriebene Aufgabe sowohl auf Test- als auch auf Schrittebene ausführen.
Übergeordnetes Thema: Manuelles Testen
Zugehörige Konzepte
Manuelles Testen (Fenster)
Zugehörige Tasks
Festlegen der maximalen Größe von Testschritt-Ergebnisdateien


Zuordnen oder Erstellen von Fehlern

Wenn Sie Tests im Fenster Manuelles Testen durchführen, können Sie jedem Testschritt Fehler zuordnen.

So ordnen Sie einen Fehler zu:

  1. Öffnen Sie das Fenster Manuelles Testen. Weitere Informationen finden Sie unter Manuelles Testen (Fenster).
  2. Klicken Sie links auf [image] (Details anzeigen), um einen Testschritt zu erweitern.
  3. Klicken Sie auf [image] (Fehler zuordnen oder erstellen). Das Dialogfeld Fehler zuordnen oder erstellen wird angezeigt.
  4. Wenn Sie vorhandene Fehler zuordnen möchten, klicken Sie auf Vorhandene Fehler zuordnen, und geben Sie im Feld Fehler-ID die Nummern der Fehler durch Kommas getrennt ein.
  5. Wenn Sie einen neuen Fehler erstellen möchten, klicken Sie auf Neuen Fehler erstellen. Geben Sie die Informationen zu dem Fehler in die entsprechenden Felder ein, und wählen Sie Werte aus den Listen aus.
  6. Klicken Sie auf OK. Der Fehler wird dem Testschritt zugeordnet.
  7. Wenn Sie den zugeordneten Fehler anzeigen möchten, klicken Sie auf [image]. Das Dialogfeld Fehler mit einer Liste aller zugeordneten Fehler wird angezeigt.
  8. Wenn Sie auf [image] (Fehler öffnen) klicken, werden Sie zu einem externen Fehlerverfolgungstool oder Issue Manager weitergeleitet. Klicken Sie auf [image] (Fehler löschen), um einen Fehler zu löschen.
    Anmerkung: Sie können in diesem Dialog ausschließlich Fehler löschen, die Sie während dem aktuellen Test zugeordnet haben. Fehler, die dem Test vor dem Start des Testzyklus/der Testsuite zugeordnet wurden, können nicht gelöscht werden.
Anmerkung: Beim Erstellen eines neuen Fehlers, erstellt Silk Central automatisch Links zu allen Ergebnisdateien, die aktuell dem Schritt/Test zugeordnet sind. Diese Links werden in der Fehlerbeschreibung des Fehlerverfolgungstools angezeigt. Dies ermöglicht es Ihnen, die Ergebnisdateien direkt aus dem Fehlerverfolgungstool herunterzuladen.
Anmerkung: Sie können die in diesem Thema beschriebene Aufgabe sowohl auf Test- als auch auf Schrittebene ausführen.
Übergeordnetes Thema: Manuelles Testen
Zugehörige Konzepte
Übersichtsbereich
Bereich "Testschritte"
Manuelles Testen (Fenster)
Zugehörige Verweise
Status von Tests und Testschritten


Auswählen von mobilen Geräten für manuelles Testen

Bevor Sie ein mobiles Gerät (physisches Gerät, Emulator oder Simulator) auswählen können, auf dem Ihr manueller Test ausgeführt werden soll, muss ein Geräteanbieter konfiguriert werden. Beachten Sie, dass der Geräteanbieter und Ihr aktuelles Projekt der selben Servergruppe zugeordnet sein müssen, sonst werden in der Liste keine Geräte angezeigt. Weitere Information finden Sie unter Verwalten von Geräte-Anbietern.
Tipp: Wenn Sie den Browser auf dem ausgewählten Gerät mit einer bestimmten URL öffnen möchten, definieren Sie einen Parameter mit dem Namen silkTest.url und geben Sie im Feld Wert die URL ein.
So wählen Sie ein mobiles Gerät aus:
  1. Öffnen Sie das Fenster Manuelles Testen. Weitere Informationen finden Sie unter Manuelles Testen (Fenster).
  2. Klicken Sie auf [image] (Gerät auswählen). Der Dialog Gerät auswählen wird angezeigt.
  3. Wählen Sie ein mobiles Gerät aus. Verwenden Sie das Suche-Feld und die Listen Plattform und Anwendung auf der linken Seite, im die Liste der verfügbaren Geräte zu filtern. Um eine native App zum Testen auf einem mobilen Gerät zu installieren, wählen Sie Native App in der Liste Anwendung auf der linken Seite aus. Geben Sie die URL oder den UNC-Pfad zur App im darunter liegenden Feld ein (iOS benötigt eine URL). Beispiel: \\fileserver\apps\testapp.apk
    Tipp: Verwenden Sie das Suchfeld um nach bestimmten Gerätetypen zu suchen, z.B. indem Sie nach Emulator oder Simulator suchen.
  4. Optional: Aktivieren Sie das Kontrollkästchen Nur physische Geräte verwenden, wenn Sie keine Emulatoren oder Simulatoren verwenden möchten.
  5. Optional: Deaktivieren Sie das Kontrollkästchen Verwendete oder blockierte Geräte verbergen um zu sehen, wer gerade Geräte in Verwendung hat.
  6. Klicken Sie auf Gerät starten um Ihren Test auf dem ausgewählten Gerät auszuführen.
Übergeordnetes Thema: Manuelles Testen
Zugehörige Konzepte
Manuelles Testen (Fenster)
Zugehörige Verweise
Benutzeroberfläche von mobilen Geräten


Codeanalyse starten

Wenn Sie im Fenster Manuelles Testen Tests ausführen, können Sie die Codeanalyse starten, um Informationen über den abgedeckten Code des manuellen Tests zu erhalten. Weitere Informationen über die Aktivierung der Codeanalyse finden Sie unter Aktivieren der Codeanalyse.

Stellen Sie sicher, dass Java Runtime Environment (JRE) auf Ihrem Computer installiert ist und die Anwendung ausgeführt werden kann. Sie können JRE unter Java SE Downloads herunterladen. Wenn Ihr Browser NPAPI nicht unterstützt, schlägt Silk Central automatisch vor eine JNLP-Datei herunterzuladen, welche benötigt wird, um diese Funktionalität zu ermöglichen.

So starten Sie die Codeanalyse:

  1. Öffnen Sie das Fenster Manuelles Testen. Weitere Informationen finden Sie unter Manuelles Testen (Fenster).
  2. Klicken Sie links auf [image] (Details anzeigen), um einen Testschritt zu erweitern.
  3. Klicken Sie auf Codeanalyse starten (Codeanalyse starten). Wenn Ihr Browser NPAPI nicht unterstützt, schlägt Silk Central automatisch vor eine JNLP-Datei herunterzuladen, welche benötigt wird, um diese Funktionalität zu ermöglichen. Der Dialog Codeanalyse starten wird angezeigt.
  4. Wählen Sie ein Profil, und geben Sie einen oder mehr Hostnamen ein. Wenn bereits Abdeckungsinformationen für diesen Test vorliegen, können Sie sie durch Aktivieren des Kontrollkästchens ersetzen. Klicken Sie auf Codeanalyse starten, um den Vorgang tatsächlich zu starten.
  5. Wenn Sie fertig sind, klicken Sie auf Codeanalyse beenden. Die Ergebnisse der Codeanalyse werden automatisch zum Testlauf hinzugefügt.
  6. Klicken Sie auf [image], um die angehängten Codeanalyse-Ergebnisse anzuzeigen. Klicken sie auf Berichte > Codeanalyse, um den Codeanalyse-Bericht anzuzeigen.
Anmerkung: Sie können die in diesem Thema beschriebene Aufgabe sowohl auf Test- als auch auf Schrittebene ausführen.
Übergeordnetes Thema: Manuelles Testen


Bearbeiten von Version und Build

Klicken Sie im Fenster Manuelles Testen im Übersichtsbereich auf [image] (Version und Build bearbeiten), um die Version und den Build zu bearbeiten. Wird die Schaltfläche nicht angezeigt, klicken Sie auf [image] (Einstellungen bearbeiten) und aktivieren Sie die Aktion.

Die Tests eines Testzyklus werden möglicherweise nicht mit nur einem Build durchgeführt, sondern mit mehreren. Dies gilt vor allem bei langen Testzyklen mit vielen Tests. Zum Beispiel: Die Tests 1 und 2 eines Testzyklus werden mit Build 315 durchgeführt, Test 3 desselben Testzyklus wird mit Build 316 durchgeführt.

Der konfigurierte Build und die konfigurierte Version werden für jeden Test gespeichert und in allen relevanten Tabellen in Silk Central angezeigt.

Beim Festlegen eines Build für einen Test wird dieser automatisch für alle Tests festgelegt, ...
  • die Ihnen oder keinem bestimmten Tester zugeordnet sind und
  • die noch nicht ausgeführt wurden (Tests mit dem Status Nicht ausgeführt) und
  • die demselben Projekt und Produkt angehören.

Ein Build muss somit nicht nochmals für die einzelnen Tests, die Sie ausführen, festgelegt werden.

Übergeordnetes Thema: Manuelles Testen


Status von Tests und Testschritten

Wenn Sie den Status eines Testschritts im Fenster Manuelles Testen festlegen, ändert sich auch der Status des Tests. Die folgende Tabelle zeigt, wie Silk Central den Teststatus basierend auf den Status der Testschritte berechnet:
Status | Beschreibung
Bestanden | Wenn alle Schritte bestanden wurden, wird der Teststatus auf Bestanden gesetzt. Keine Statusursachen von Testschritten werden auf den Status des Tests übertragen.
Fehlgeschlagen | Wenn alle Testschritte ausgeführt wurden und mindestens ein Schritt fehlgeschlagen ist, wird der Teststatus auf Fehlgeschlagen gesetzt. Die Statusursache des ersten fehlgeschlagenen Testschrittes wird als Statusursache für den Test verwendet.
Nicht ausgeführt | Der Teststatus wird so lange auf Nicht ausgeführt gesetzt, bis alle Testschritte ausgeführt wurden. Die Statusursache des ersten nicht-ausgeführten Testschrittes wird als Statusursache für den Test verwendet. Wenn Sie den Status von mindestens einem Schritt ändern, wird der Teststatus auf In Bearbeitung festgelegt.
In Bearbeitung | Der Status aller Tests bleibt so lange auf In Bearbeitung, bis alle Testschritte ausgeführt wurden.

Sie können den Teststatus auch manuell festlegen. Klicken Sie im Übersichtsbereich des Fensters Manuelles Testen im Bereich Testschritte eines Testschrittes auf [image] (Status auswählen) neben dem Statussymbol, und wählen Sie einen Status aus: Weitere Informationen über das Definieren von Statusursachen für jeden Status finden Sie in Statusursachen.

Abgesehen vom Status eines Tests, können Sie einen Test auch auf Blockiert setzen.Einen Test auf blockiert zu setzen ist ein nützlicher Hinweis darauf, dass ein Test nicht ausgeführt werden kann auf Grund bestimmter Einschränkungen, zum Beispiel ein Problem mit der IT Infrastruktur.

Beachten Sie Folgendes:
  • Ein manuell festgelegter Teststatus überschreibt den automatisch berechneten.
  • Wenn Sie einen Schrittstatus im Nachhinein ändern, wird der Teststatus erneut berechnet.
  • Sie können einen Teststatus manuell zurück auf Nicht ausgeführt setzen. Silk Central wird jedoch nie automatisch den Teststatus zurück auf Nicht ausgeführt setzen.
  • Sie können einen Teststatus manuell auf In Bearbeitung setzen, sogar wenn Sie keinen Schrittstatus ändern.
Übergeordnetes Thema: Manuelles Testen
Zugehörige Konzepte
Übersichtsbereich
Bereich "Testschritte"
Statusursachen
Zugehörige Tasks
Bearbeiten von Version und Build
Aufzeichnen von Screenshots
Videos aufzeichnen
Anhängen von Ergebnisdateien
Zuordnen oder Erstellen von Fehlern


Drucken von manuellen Tests

Sie können zu jedem Test ein Formular ausdrucken und die Ergebnisse, die Zeitdauer, den Status und weitere Informationen per Hand eintragen.

So drucken Sie einen manuellen Test aus:

  1. Klicken Sie im Menü auf Startseite > Mein Dashboard.
  2. Klicken Sie im Panel Mir zugewiesene manuelle Tests in der Spalte Aktionen auf [image] (Ergebnisse manueller Tests anzeigen). Die Anzeige von manuellen Testergebnissen wird geöffnet.
  3. Klicken Sie auf Drucken oder Download als PDF.
Übergeordnetes Thema: Manuelles Testen


Testbook

Das Testbook ist ein neues Dashboard-Panel, mit dem Ihnen Echtzeit-Updates zu allen Aktivitäten zur Verfügung stehen, die bei manuellen Tests stattfinden. Es zeigt an, wer welche Aktivität zu welchem Stadium der verschiedenen Testzyklen und Testsuiten ausgeführt hat. Das Testbook vereinfacht die Koordination und Zusammenarbeit unter Testern und Testmanagern.

Sie können die Einträge nach Benutzer, Aktion und Testzyklus filtern. Das Panel zeigt die Aktivitäten von nur einem Projekt an. Um ein Projekt für das Panel zu konfigurieren, klicken Sie auf [image] (Konfigurieren) im Kopfbereich des Panels. Um Aktivitäten in anderen Projekten anzuzeigen, können Sie mehr Panels hinzufügen. Weitere Informationen zu Panels finden Sie im Dashboard.

Für jeden Eintrag werden der Benutzername und (falls verfügbar) der vollständige Name angezeigt. Bei Unternehmen, die keine aussagekräftigen Benutzernamen verwenden, ist der vollständige Name eines Benutzers aussagekräftiger für die anderen Benutzer innerhalb eines Teams.

Im Fenster Manual Testing können Sie eine Nachricht im Testbook posten, indem Sie auf [image] klicken.

Einträge, die älter als 60 Tage sind, werden automatisch gelöscht. Um diese Standardeinstellung zu ändern, öffnen Sie die Datei Conf\AppServer\TMAppserverHomeConf.xml, und bearbeiten Sie folgende Einstellung: <MaximumActivityLogLifeTimeInDays>60</MaximumActivityLogLifeTimeInDays>

Folgende Aktivitäten werden im Testbook protokolliert:

Symbol | Aktivität | Symbol | Aktivität
 | Testzyklus gestartet |  | Test hinzugefügt
 | Testzyklus abgeschlossen |  | Test gestartet
 | Testzyklus entfernt |  | Test abgeschlossen
 | Meilenstein hinzugefügt |  | Test erneut zugewiesen
 | Meilenstein bearbeitet |  | Test entfernt
 | Meilenstein entfernt |  | Test blockiert
 | Mobilgerät ausgewählt |  | Nachricht gepostet
Übergeordnetes Thema: Manuelles Testen


Manuelle Offline-Tests

Mit manuellem Offline-Testen können Tests heruntergeladen und offline ausgeführt werden. Man kann die Resultate auch wieder nach Silk Central hochladen.

Tester verwenden das Mir zugewiesene manuelle Tests Panel um manuelle Tests herunterzuladen und die Resultate wieder nach Silk Central hochzuladen. Test Manager verwenden das Manuelle Offline-Tests Panel um eine Übersicht über manuelle Tests zu haben und heruntergeladene Tests zu verwalten.

Anmerkung: Eine Lizenz für manuelles Testen wird ausgecheckt sobald ein Test für die Offline-Ausführung heruntergeladen wird. Die Lizenz wird wieder eingecheckt sobald die Ergebnisse hochgeladen werden.
  • Herunterladen von manuellen Tests zur Offline-Ausführung
    Hier wird beschrieben, wie man manuelle Tests herunterlädt und wie man offline damit arbeitet.
  • Testergebnisse von manuellen Offline-Tests hochladen
    Hier wird beschrieben, wie die Ergebnisse eines manuellen Offline-Tests hochgeladen werden.
Übergeordnetes Thema: Manuelles Testen


Herunterladen von manuellen Tests zur Offline-Ausführung

In diesem Abschnitt wird aufgezeigt, wie Sie Tests herunterladen und wie Status, Statusursache und Ergebnis ausgefüllt werden, während Sie offline arbeiten.

  1. Navigieren Sie zu Startseite > Mein Dashboard. Stellen Sie sicher, dass das Mir zugewiesene manuelle Tests Panel sichtbar ist.
  2. Wählen Sie einen oder mehrere Tests aus. Klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Markierte manuelle Tests für Offline-Ausführung herunterladen. Sie können auch einen einzelnen Test markieren und Alle manuellen Tests der zugehörigen Testsuite für Offline-Ausführung herunterladen auswählen.
    Tipp: Nutzen Sie die Zeilen Pro Seite Option und die Sortier- und Filtermöglichkeiten, um genau die Tests aufzulisten, die Sie benötigen.
  3. Legen Sie auf dem Dialog Manuelle Tests für Offline-Ausführung herunterladen fest, wie die Tests in Excel gegliedert sein sollen:
    • Eigenes Arbeitsblatt für jeden Test (mit Testschritten) erzeugen
    • Ein Arbeitsblatt mit mehreren Tests (ohne Testschritte) erzeugen
  4. Wenn Ihre Tests Attribute enthalten, aktivieren Sie Attribute inkludieren. Sämtliche Attribute sind im heruntergeladenen Excel-Arbeitsblatt enthalten. So können Sie Ihre Tests nach den Attributen filtern.
  5. Wählen Sie Anhänge inkludieren um sämtliche Dateien herunterzuladen, die an die ausgewählten Tests und Testschritte angehängt sind. Beachten Sie, dass Anhänge nicht wieder zurück auf Silk Central hochgeladen werden können.
  6. Klicken Sie auf Herunterladen. Laden Sie die Excel-Datei herunter und speichern Sie sie.
  7. Öffnen Sie die Datei und füllen Sie den Status und das Ergebnis oder die Tatsächliche Dauer für jeden Schritt oder Test aus, je nach Format in dem Sie die Excel-Datei heruntergeladen haben.
  8. Speichern Sie die Datei.
Übergeordnetes Thema: Manuelle Offline-Tests
Zugehörige Tasks
Testergebnisse von manuellen Offline-Tests hochladen


Testergebnisse von manuellen Offline-Tests hochladen

Führen Sie die folgenden Schritte durch um die Testergebnisse von manuellen Offline-Tests nach Silk Central hochzuladen, nachdem Sie einen heruntergeladenen Test beendet haben.

  1. Navigieren Sie zu Startseite > Mein Dashboard. Stellen Sie sicher, dass das Mir zugewiesene manuelle Tests Panel sichtbar ist.
  2. Klicken Sie auf Ergebnisse von manuellen Offline-Testausführungen hochladen. Das Dialogfeld Ergebnisse von manuellen Offline-Testausführungen hochladen wird geöffnet.
  3. Klicken Sie auf Datei auswählen und navigieren Sie zu Ihrer Excel-Datei. Der Dialog Öffnen wird angezeigt.
  4. Wählen Sie die hochzuladende Datei aus und klicken sie auf Öffnen.
  5. Klicken Sie auf Hochladen. Ein Dialog informiert Sie über den Fortschritt.
  6. Klicken Sie auf OK.
Übergeordnetes Thema: Manuelle Offline-Tests
Zugehörige Tasks
Herunterladen von manuellen Tests zur Offline-Ausführung


Testen von Konfigurationen

Unter dem Testen von Konfigurationen wird das Testen eines Systems mit allen unterstützten Software- und Hardware-Konfigurationen verstanden.

Der Bereich Testausführung unterstützt das Tests von Konfigurationen durch die Möglichkeit zur Wiederverwendung der zugeordneten Tests. Sie können Konfigurationssuiten mit zugeordneten Tests erstellen, so dass allen zu einer Konfigurationssuite hinzugefügten Testsuiten diese Tests zugeordnet werden. Sie können Konfigurationssuiten aus bereits bestehenden Testsuiten erstellen und diese kopieren beziehungsweise ausschneiden und über die Hierarchie Testausführung in eine Konfigurationssuite einfügen. Silk Central ermöglicht das Hinzufügen oder Entfernen von Parametern, Schlüsselwörtern und manuellen Testern zu oder von Konfigurationen. Wenn Sie eine Konfigurationssuite aus einer bestehenden Testsuite erstellen, werden alle Ergebnisse der Testsuite in der Konfigurationssuite erhalten. Wenn Sie eine Testsuite kopieren und in eine bestehende Konfigurationssuite einfügen, werden diese Ergebnisse nicht erhalten.

Jede Testsuite der Konfigurationssuite wird in einer Tabelle angezeigt und kann darin bearbeitet werden. Sie können Testsuiten oder Konfigurationen, die spezifische Tests enthalten, über das Register Eigenschaften der Tests anzeigen. Sie können die Testsuiten oder Konfigurationen, die mit einer bestimmten Anforderung assoziiert sind, über das Register Zugeordnete Tests der Anforderung anzeigen.

Verwenden Sie zur Definition von Konfigurationen für automatisierte Tests die Seite Konfigurationssuite Konfigurationen. Um Konfigurationen für manuelle Tests zu definieren, verwenden Sie die Seite Konfigurationen.

  • Erstellen einer Konfigurationssuite
    Erstellen Sie eine Konfigurationssuite, um alle Testsuiten der Konfigurationssuite mit den gleichen Tests, speziellen Parametern oder Testumgebungseinstellungen auszuführen.
  • Erstellen einer Konfigurationssuite aus einer Testsuite
    Erstellen Sie eine Konfigurationssuite aus einer Testsuite, um zusätzliche Konfigurationen für die unterstützten Software- und Hardwarekonfigurationen hinzuzufügen.
  • Hinzufügen von Parametern zu einer Konfiguration
    Fügen Sie einer Konfiguration Parameter hinzu, um die zugehörigen Testsuiten mit den betreffenden Parametern auszuführen.
  • Entfernen von Parametern aus Konfigurationen
    Entfernen Sie Parameter aus einer Konfiguration, um die zugehörige Testsuite ohne die betreffenden Parameter auszuführen.
  • Zuordnen von Schlüsselwörtern zu einer Konfiguration
    Weisen Sie einer Konfiguration Schlüsselwörter zu, um die Ausführungsumgebung zu beschreiben.
  • Entfernen von Schlüsselwörtern aus Konfigurationen
    Entfernen Sie Schlüsselwörter aus einer Konfiguration, wenn diese die Ausführungsumgebung nicht mehr korrekt beschreiben.
  • Hinzufügen von manuellen Testern zu Konfigurationen
    Fügen Sie manuelle Tester einer Konfiguration mit manuellen Tests hinzu.
  • Entfernen einer Testerzuordnung aus einer Konfiguration
    Entfernen Sie eine Testerzuordnung aus einer Konfiguration.
  • Zuordnen von mobilen Geräten zu einer Konfiguration
    Ordnen Sie ein mobiles Gerät (physisches Gerät, Emulator oder Simulator) einer Konfiguration zu, auf der Ihre Testsuiten ausgeführt werden.
  • Konfigurationssuite Konfigurationen (Seite)
    Führt die Konfigurationen auf, die in einer Konfigurationssuite enthalten sind. Verwenden Sie zur Definition von Konfigurationen für automatisierte Tests die Seite Konfigurationssuite Konfigurationen. Verwenden Sie für manuelle Tests die Seite Konfigurationen.
  • Konfigurationen (Seite)
    Hier erhalten Sie einen Überblick über die Seite Konfigurationen. Die auf der Seite Konfigurationen definierten Konfigurationen können nur für manuelle Tests verwendet werden. Verwenden Sie zur Definition von Konfigurationen für automatisierte Tests die Seite Konfigurationssuite Konfigurationen.
Übergeordnetes Thema: Ausführungsplanung
Zugehörige Konzepte
Ausführungs-Statusübersicht-Bericht
Zugehörige Verweise
Eigenschaften von Testsuiten (Seite)
Zugeordnete Tests (Seite)
Ausführungstermin (Seite)


Erstellen einer Konfigurationssuite

So erstellen Sie eine Konfigurationssuite:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht oder Ausführungsplanung > Dokumentansicht.
  2. Klicken Sie mit der rechten Maustaste auf den Stammknoten oder einen Ordner in der Testsuitehierarchie, und wählen Sie Neue untergeordnete Konfigurationssuite, oder klicken Sie in der Symbolleiste auf Neue untergeordnete Konfigurationssuite. Der Dialog Neue Konfigurationssuite wird geöffnet.
  3. Geben Sie einen Namen und eine Beschreibung für die neue Konfigurationssuite ein.
  4. Wählen Sie in der Liste einen Container aus.
  5. Wählen Sie in den Listen eine Version und einen Build aus, oder aktivieren Sie das Kontrollkästchen Aus Build-Informationsdatei lesen, um Version und Build aus einer Datei auszulesen.
  6. Optional: Im Feld Label der Versionsverwaltung können Sie festlegen, dass frühere Versionen von Automatisierungsdateien anstelle der neuesten Versionen aus dem Versionsverwaltungssystem abgerufen werden.
    Anmerkung: Die Eigenschaft Label der Versionsverwaltung ist nur verfügbar, wenn der zugeordnete Container ein Versionsverwaltungsprofil verwendet, das die Versionsverwaltung unterstützt.
  7. Klicken Sie auf OK.
Übergeordnetes Thema: Testen von Konfigurationen


Erstellen einer Konfigurationssuite aus einer Testsuite

So erstellen Sie eine Konfigurationssuite aus einer bestehenden Testsuite:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Klicken Sie in der Testsuitehierarchie mit der rechten Maustaste auf die Testsuite, aus der Sie die Konfigurationssuite erstellen wollen und wählen Sie In Konfigurationssuite konvertieren. Silk Central erstellt einen neuen Konfigurationssuite-Knoten mit dem gleichen Namen, wie die ausgewählte Testsuite, in der Testsuitehierarchie und fügt die Testsuite als einen Konfigurationsunterknoten der Konfigurationssuite hinzu.
Wenn Sie eine Konfigurationssuite aus einer bestehenden Testsuite erstellen, werden alle Ergebnisse der Testsuite in der Konfigurationssuite erhalten. Wenn Sie eine Testsuite kopieren und in eine bestehende Konfigurationssuite einfügen, werden diese Ergebnisse nicht erhalten.
Übergeordnetes Thema: Testen von Konfigurationen


Hinzufügen von Parametern zu einer Konfiguration

So fügen Sie einen vordefinierten Parameter einer Konfiguration hinzu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuite-Hierarchie den Konfigurations-Knoten aus, zu dem der Parameter hinzugefügt werden soll.
  3. Klicken Sie auf die Registerkarte Konfigurationen.
  4. Klicken Sie auf Parameter hinzufügen/entfernen. Der Dialog Parameter hinzufügen/entfernen wird angezeigt. In der Liste Zugeordnete Parameter rechts im Dialog sind alle für die Konfiguration definierten Parameter aufgeführt.
  5. Wählen Sie in der Liste Wählen Sie einen Parameter aus oder geben Sie einen ein die Parameter, die den Anforderungen Ihrer Ausführungsumgebung entsprechen. Mit Strg+Klick bzw. Umschalttaste+Klick können Sie entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Parameter auswählen.
  6. Um einen Parameter aus der Liste Wählen Sie einen Parameter aus oder geben Sie einen ein hinzuzufügen, wählen Sie den Parameter aus, und klicken Sie auf >.
  7. Um einen neuen Parameter zu erstellen, geben Sie den Namen des Parameters im Feld Eingabe von Parametern ein, und drücken Sie die Eingabetaste oder klicken Sie auf >.
    Tipp: Eingaben im Feld Eingabe von Parametern werden automatisch vervollständigt. Wenn Sie alphanumerische Zeichen eingeben, wird ein vorhandener Parameter, der mit den eingegebenen Zeichen beginnt, automatisch in das Feld übernommen. Das Feld kann nicht verwendet werden, wenn in den Listen Auswahl von Parametern oder Zugeordnete Parameter mehrere Parameter ausgewählt sind.
  8. Klicken Sie auf OK. Der Dialog Parameter hinzufügen/entfernen wird geschlossen, und für jeden neuen Parameter erscheint eine neue Spalte in der Tabelle.
Übergeordnetes Thema: Testen von Konfigurationen


Entfernen von Parametern aus Konfigurationen

So entfernen Sie einen vordefinierten Parameter aus einer Konfiguration:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie den Konfigurations-Knoten aus, aus dem der Parameter entfernt werden soll.
  3. Klicken Sie auf die Registerkarte Konfigurationen.
  4. Klicken Sie auf Parameter hinzufügen/entfernen. Das Dialogfeld Parameter hinzufügen/entfernen wird angezeigt. In der Liste rechts im Dialogfeld sind alle für die Konfiguration definierten Parameter aufgeführt.
  5. Um einen Parameter aus der Liste zu entfernen, wählen Sie den Parameter aus, und klicken Sie auf <.
  6. Klicken Sie auf OK. Das Dialogfeld Parameter hinzufügen/entfernen wird geschlossen, und die Spalte des entfernten Parameters wird in der Tabelle nicht mehr angezeigt.
Übergeordnetes Thema: Testen von Konfigurationen


Zuordnen von Schlüsselwörtern zu einer Konfiguration

So weisen Sie einer Konfiguration Schlüsselwörter zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Konfigurationssuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Konfigurationen.
  4. Klicken Sie in die Spalte Schlüsselwörter der Konfiguration, der Sie ein Schlüsselwort zuweisen möchten. Der Dialog Schlüsselwörter zuordnen wird angezeigt.
  5. Wählen Sie in der Liste Schlüsselwörter auswählen die Schlüsselwörter aus, die den Anforderungen Ihrer Ausführungsumgebung entsprechen. Mit Strg+Klick bzw. Umschalttaste+Klick können Sie entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Schlüsselwörter auswählen.
    Tipp: Eingaben im Feld Schlüsselwörter eingeben werden automatisch vervollständigt. Wenn Sie alphanumerische Zeichen eingeben, wird ein vorhandenes Schlüsselwort, das mit den eingegebenen Zeichen beginnt, automatisch in das Feld übernommen. Das Feld kann nicht verwendet werden, wenn in den Listen Schlüsselwörter auswählen oder Zugewiesene Schlüsselwörter mehrere Schlüsselwörter ausgewählt sind.
    Tipp: Wenn Sie bei automatisierten Testsuiten nur über einige Ausführungsserver verfügen und keine Hardwarebereitstellung benötigen, kommen Sie möglicherweise mit den für jeden Ausführungsserver definierten reservierten Standardschlüsselwörtern aus. In solchen Fällen ist die Auswahl weiterer Schlüsselwörter nicht erforderlich.
  6. Klicken Sie auf >, um das Schlüsselwort in die Liste Zugewiesene Schlüsselwörter zu verschieben.
    Anmerkung: Bei automatisierten Testsuiten werden die Ausführungsserver, die den zugeordneten Schlüsselwörtern entsprechen, in der dynamisch aktualisierten Liste der passenden Ausführungsserver angezeigt. Diese Liste wird jedes Mal aktualisiert, wenn Sie ein Schlüsselwort hinzufügen oder entfernen. Klicken Sie in der Liste auf den Namen eines Ausführungsservers, um auf die Ausführungsserver in Verwaltung > Ausführungsserver zuzugreifen.
  7. Klicken Sie auf OK, um die Schlüsselwörter zu speichern und den Dialog Schlüsselwörter zuordnen zu schließen.
Übergeordnetes Thema: Testen von Konfigurationen


Entfernen von Schlüsselwörtern aus Konfigurationen

So entfernen Sie Schlüsselwort-Zuordnungen aus Konfigurationen:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Konfigurationssuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Konfigurationen.
  4. Klicken Sie in die Spalte Schlüsselwörter der Konfiguration, aus der Sie ein Schlüsselwort entfernen möchten. Das Dialogfeld Schlüsselwörter zuordnen wird angezeigt.
  5. Wählen Sie in der Liste Zugewiesene Schlüsselwörter die nicht mehr benötigten Schlüsselwörter aus. Mit Strg+Klick bzw. Umschalttaste+Klick können Sie mehrere Schlüsselwörter auswählen.
  6. Klicken Sie auf <, um die Schlüsselwort-Zuordnungen zu entfernen.
  7. Klicken Sie auf OK, um die Schlüsselwörter zu speichern und den Dialog Schlüsselwörter zuordnen zu schließen.
Anmerkung: Nicht mehr verwendete Schlüsselwörter werden automatisch aus dem System gelöscht.
Übergeordnetes Thema: Testen von Konfigurationen


Hinzufügen von manuellen Testern zu Konfigurationen

Bei Konfigurationen mit manuellen Tests können Sie auf der Seite Konfigurationen bestimmte Benutzer als manuelle Tester einer Konfiguration zuweisen. Sie können einer Konfiguration mehrere manuelle Tester zuweisen.

So weisen Sie einer Konfiguration einen manuellen Tester zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Konfigurationssuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Konfigurationen.
  4. Klicken Sie in die Spalte Manuelle Tester der Konfiguration, der Sie einen manuellen Tester zuweisen möchten. Das Dialogfeld Manuelle Tester wird angezeigt.
  5. Wählen Sie in der Liste Verfügbar die Benutzergruppe aus, zu der der Tester gehört. In der Liste werden daraufhin alle Mitglieder dieser Benutzergruppe angezeigt.
  6. Wählen Sie den Namen des Benutzers aus, den Sie als manuellen Tester zuweisen möchten.
  7. Klicken Sie auf Hinzufügen, um ihn der Liste Ausgewählt hinzuzufügen. Sie können auch auf Alle hinzufügen klicken, um alle Gruppenmitglieder als Tester zuzuweisen.
  8. Klicken Sie auf OK, um den Dialog Manuelle Tester zuordnen zu schließen.
Übergeordnetes Thema: Testen von Konfigurationen


Entfernen einer Testerzuordnung aus einer Konfiguration

So entfernen Sie einen Tester aus einer Konfiguration:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie den Konfigurations-Knoten aus, aus dem Sie die Testerzuordnung entfernen möchten.
  3. Klicken Sie auf die Registerkarte Konfigurationen.
  4. Klicken Sie in die Spalte Manuelle Tester der Konfiguration, aus der Sie einen manuellen Tester entfernen möchten. Das Dialogfeld Manuelle Tester wird angezeigt.
  5. Wählen Sie in der Liste Ausgewählte den Namen des zugeordneten Benutzers aus, den Sie entfernen möchten.
  6. Klicken Sie auf Entfernen, um den Benutzer aus der Liste Ausgewählte zu entfernen, oder klicken Sie auf Alles entfernen, um alle Zuordnungen von Testern zu entfernen.
  7. Klicken Sie auf OK, um den Dialog Manuelle Tester zuordnen zu schließen.
Übergeordnetes Thema: Testen von Konfigurationen


Zuordnen von mobilen Geräten zu einer Konfiguration

So ordnen Sie mobile Geräte einer Konfiguration zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Konfigurationssuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Konfigurationen.
  4. Wählen Sie ein mobiles Gerät, einen Gerätefilter oder eine native App aus.
    • Verwenden Sie die Liste auf der rechten Seite, um ein bestimmtes Gerät auszuwählen.
    • Wählen Sie in der Liste auf der rechten Seite Beliebiges Gerät aus, um einen Gerätefilter auszuwählen. Bearbeiten Sie diesen Filter mit dem Suchen-Feld, sowie mit den Listen Plattform und Anwendung auf der linken Seite.
      Tipp: Verwenden Sie das Suchfeld um nach bestimmten Gerätetypen zu suchen, z.B. indem Sie nach Emulator oder Simulator suchen.
    • Um eine native App zum Testen auf einem mobilen Gerät zu installieren, wählen Sie Native App in der Liste Anwendung auf der linken Seite aus. Geben Sie die URL oder den UNC-Pfad zur App im darunter liegenden Feld ein (iOS benötigt eine URL). Beispiel: \\fileserver\apps\testapp.apk
  5. Optional: Aktivieren Sie das Kontrollkästchen Nur physische Geräte verwenden, wenn Sie keine Emulatoren oder Simulatoren verwenden möchten.
  6. Optional: Aktivieren Sie das Kontrollkästchen Verwendete oder blockierte Geräte verbergen, um nur Geräte anzuzeigen die momentan verwendbar (frei) sind. Dies ist vor allem zur Ausführung von manuellen Tests nützlich, oder wenn sie eine Testsuite sofort ausführen möchten.
  7. Klicken Sie auf OK, um die mobile Geräteauswahl zu speichern.
Während der Ausführung wird entweder das ausgewählte Gerät oder das erste mit dem Filter übereinstimmende Gerät verwendet und blockiert, bis die Testsuite fertig ausgeführt wurde. Falls das mobile Gerät nicht verfügbar ist oder keine Geräte dem Filter entsprechen, bleibt der Ausführungs-Job in der Warteschlange, bis ein geeigneter Ausführungsserver oder ein mobiles Gerät verfügbar wird. Sauce Labs-Geräte sind eigentlich keine einzelnen Geräte, sondern eher Gerätetypen, weshalb Sie während Testausführungen nicht blockiert werden.
Übergeordnetes Thema: Testen von Konfigurationen
Zugehörige Konzepte
Verwalten von Geräte-Anbietern
Zugehörige Tasks
Auswählen von mobilen Geräten für automatisiertes Testen
Auswählen von mobilen Geräten für manuelles Testen
Zugehörige Verweise
Konfiguration von Geräte-Anbietern


Konfigurationssuite Konfigurationen (Seite)

Um diese Seite aufzurufen, klicken Sie auf Ausführungsplanung > Detailansicht > <Konfigurationssuite> > Konfigurationen.

Auf der Registerkarte Konfigurationen werden die Konfigurationen angezeigt, die in der Konfigurationssuite enthalten sind. Die Tabelle liefert Daten zur automatisierten Erzeugung von untergeordneten Testsuiten.

Wenn Sie eine neue Konfiguration zur Tabelle hinzufügen, wird eine neue Testsuite erzeugt, die mit der Konfigurationssuite ausgeführt wird.

Um eine neue Konfiguration zu definieren, klicken Sie auf Neue Konfiguration. Um einen Parameter hinzuzufügen oder zu entfernen, klicken Sie auf Parameter hinzufügen/entfernen.

Zu jeder aufgeführten Konfiguration werden folgende Spalten angezeigt:
Spalte | Beschreibung
Aktionen
  • Klicken Sie auf Konfiguration löschen, um die Konfiguration zu löschen.
  • Klicken Sie auf Konfiguration duplizieren, um die Konfiguration zu duplizieren.
Name | Der Name der Konfiguration. Klicken Sie auf den Namen, um ihn zu ändern.
Schlüsselwörter | Die Liste der Ausführungs-Schlüsselwörter, die der Konfiguration zugewiesen sind. Klicken Sie auf den Link, um die Liste zu ändern. Weitere Informationen finden Sie unter Zuordnen von Schlüsselwörtern zu einer Konfiguration.
Manuelle Tester | Die Liste der manuellen Tester, die der Konfiguration zugewiesen sind. Klicken Sie auf den Link, um die Liste zu ändern. Weitere Informationen finden Sie unter Hinzufügen von manuellen Testern zu Konfigurationen.
Auswahl Mobilgerät | Das mobile Gerät (physisches Gerät, Emulator oder Simulator), das der Konfiguration zugeordnet ist. Klicken sie auf die Verknüpfung um die mobile Geräteauswahl zu bearbeiten. Weitere Informationen finden Sie unter Zuordnen von mobilen Geräten zu einer Konfiguration.
Parameter | Die Tabelle kann über mehrere Parameterspalten verfügen. Klicken Sie auf Parameter hinzufügen/entfernen, um der Tabelle Parameter hinzuzufügen oder diese zu entfernen. Um einem Parameter einen Wert hinzuzufügen, klicken Sie in das Feld, und geben Sie den Wert ein. Weitere Informationen finden Sie unter Hinzufügen von Parametern zu einer Konfiguration.
Übergeordnetes Thema: Testen von Konfigurationen
Zugehörige Konzepte
Testsuite-Parameter
Zugehörige Tasks
Hinzufügen von Parametern zu einer Konfiguration
Zugehörige Verweise
Konfigurationen (Seite)


Konfigurationen (Seite)

Sie rufen diese Seite auf, indem Sie auf Ausführungsplanung > Konfigurationen klicken.

Die Seite Konfigurationen enthält eine Tabelle mit definierten Konfigurationen. Diese Konfigurationen können nur in Verbindung mit manuellen Tests verwendet werden. Verwenden Sie zur Definition von Konfigurationen für automatisierte Tests die Seite Konfigurationssuite Konfigurationen.

Um eine neue Konfiguration zu definieren, klicken Sie auf Neue Konfiguration. Um einen Parameter hinzuzufügen oder zu entfernen, klicken Sie auf Parameter hinzufügen/entfernen.

Zu jeder aufgeführten Konfiguration werden folgende Spalten angezeigt:
Spalte | Beschreibung
Aktionen
  • Klicken Sie auf Konfiguration löschen, um die Konfiguration zu löschen.
  • Klicken Sie auf Konfiguration duplizieren, um die Konfiguration zu duplizieren.
Name | Der Name der Konfiguration. Klicken Sie auf den Namen, um ihn zu ändern.
Auswahl Mobilgerät | Das mobile Gerät (physisches Gerät, Emulator oder Simulator), das der Konfiguration zugeordnet ist. Klicken sie auf die Verknüpfung um die mobile Geräteauswahl zu bearbeiten. Weitere Informationen finden Sie unter Zuordnen von mobilen Geräten zu einer Konfiguration.
Schlüsselwörter | Die Liste der Ausführungs-Schlüsselwörter, die der Konfiguration zugewiesen sind. Klicken Sie auf den Link, um die Liste zu ändern. Weitere Informationen finden Sie unter Zuordnen von Schlüsselwörtern zu einer Konfiguration.
Parameter | Die Tabelle kann über mehrere Parameterspalten verfügen. Klicken Sie auf Parameter hinzufügen/entfernen, um der Tabelle Parameter hinzuzufügen oder diese zu entfernen. Um einem Parameter einen Wert hinzuzufügen, klicken Sie in das Feld, und geben Sie den Wert ein. Weitere Informationen finden Sie unter Hinzufügen von Parametern zu einer Konfiguration.
Übergeordnetes Thema: Testen von Konfigurationen
Zugehörige Tasks
Hinzufügen von Parametern zu einer Konfiguration
Zugehörige Verweise
Konfigurationssuite Konfigurationen (Seite)


Verwalten von Testsuiten, Ordnern und Konfigurationssuiten

Eine Testsuite besteht aus einer Reihe zugeordneter Tests, die sich im selben Container befinden. Eine Testsuite kann nach eingestellten Ausführungsterminen und auf bestimmten Ausführungsservern gestartet werden. Verwenden Sie Ordner, um Ihre Testsuiten, Konfigurationssuiten und Testzyklen zu strukturieren. Sie können auch Ordner innerhalb von Ordnern anlegen.

Die Testsuiten werden für manuelle Tests und für automatisierte Tests auf dieselbe Weise erstellt und bearbeitet.

  • Erstellen von Testsuiten
    Sie können eine Testsuite erstellen, um verwandte Tests zusammen auszuführen.
  • Erstellen einer Testsuite in der Tabellenansicht
    Erstellen Sie eine Testsuite in der Tabellenansicht, um Tests direkt der Testsuite zuzuordnen.
  • Teststatusberechnung
    Hier wird beschrieben, wie der Status einer Testsuite berechnet wird.
  • Testsuite-Attribute
    Attribute sind frei erstellbare Merkmale, die auf Testsuiten angewendet werden können. Sie können Attribute für das Filtern und die Berichterstellung verwenden.
  • Testsuite-Parameter
    Hier wird beschrieben, wie Testsuiten Parameter, d. h. frei konfigurierbare Eingabewerte, zugeordnet werden.
  • Vorbereitung und Nachbereitung von Tests
    Hier wird beschrieben, wie Vorbereitungen und Nachbereitungen konfiguriert werden, um die Testumgebung auf die Tests vorzubereiten bzw. die Testumgebung so wiederherzustellen, wie sie vor den Tests war.
  • Konfigurieren von Testumgebungen
    Hier wird beschrieben, wie in Silk Central Testumgebungen konfiguriert werden.
  • Konfigurieren von Abhängigkeiten zwischen Testsuiten
    Hier wird beschrieben, wie Sie durch eine Abhängigkeit festlegen können, dass eine Testsuite automatisch ausgeführt wird, wenn das Ausführungsergebnis einer anderen Testsuite einen bestimmten Status aufweist.
  • Zugeordnete Tests
    Hier wird das Zuordnen von Tests zu Testsuiten beschrieben.
  • Ausführungstermine
    Hier wird beschrieben, wie Termine für die Ausführung von Testsuiten, Ordnern und Konfigurationssuiten festgelegt werden.
  • Ausführen von Tests, die Testsuiten zugeordnet sind
    Hier wird beschrieben, wie Tests ausgeführt werden, die Testsuiten in Silk Central zugewiesen sind.
  • Filter
    Hier wird beschrieben, wie Filter zum Auffinden der relevanten Informationen bei gleichzeitigem Ausschluss von nicht benötigten Details verwendet werden.
  • Screenshots
    Beschreibt wie Sie Screenshots von Ihren Tests erstellen können.
  • Videoaufnahme
    Hier wird beschrieben, wie Sie die Videoaufnahme verwenden können, um Videos Ihrer Tests zu erstellen.
  • Ergebnisse und Ergebnisdateien automatisch löschen
    Definieren Sie Regeln, nach denen veraltete Ergebnisse und Ergebnisdateien von Testsuiten bereinigt werden sollen. Dadurch wird die Datenbankgröße reduziert und Ihre Testsuiteläufe werden einfacher verwaltbar.
Übergeordnetes Thema: Ausführungsplanung


Erstellen von Testsuiten

So erstellen Sie eine Testsuite:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Hierarchie Testsuiten einen Ordner oder den Projektknoten aus.
  3. Klicken sie auf Neue untergeordnete Testsuite (Neue untergeordnete Testsuite) in der Symbolleiste, oder klicken Sie mit der rechten Maustaste auf den Ordner, die Testsuite oder den Knoten. Klicken Sie anschließend auf Neue untergeordnete Testsuite. Das Dialogfeld Neue Testsuite wird angezeigt.
  4. Geben Sie einen Namen und eine Beschreibung für die neue Testsuite ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wählen Sie in der Liste Container den gewünschten Container aus.
    Anmerkung: Sie können jeder Testsuite jeweils nur einen Container zuordnen. Es können ausschließlich Tests aus diesem Container ausgeführten werden.
    Die neueste Version bzw. der neueste Build, die für das Produkt definiert sind, zu dem der Container gehört, werden automatisch in die Listen Version und Build eingefügt.
  6. Wählen Sie aus den Listen Version und Build des Produkts aus. Diese Werte werden verwendet, wenn ein neuer Lauf der Testsuite gestartet wird. Sie können auch das Kontrollkästchen Aus Build-Informationsdatei lesen aktivieren. In diesem Fall werden die Version und der Build zu Beginn jedes Testlaufs aus der Build-Informationsdatei gelesen. Wenn auf dem Ausführungsserver eine Build-Informationsdatei vorhanden ist, wird diese standardmäßig für den Testlauf verwendet, und die Einstellungen im Dialog Neue Testsuite werden überschrieben.
  7. Wählen Sie in der Liste die Priorität der Testsuite aus. Bei automatisierten Testsuiten, wenn sich mehr als eine Testsuite in der Warteschlange befindet, aber nur ein Ausführungsserver verfügbar ist, werden die Testsuiten nach Priorität ausgeführt. Das Gleiche gilt auch, wenn zwar ein Ausführungsserver verfügbar ist, aber mehrere Testsuiten ein nicht verfügbares Mobilgerät benötigen.
  8. Im Feld Label der Versionsverwaltung können Sie optional eine vorhergehende Version für die Testsuite angeben. Die Bezeichnung muss auf eine Version im Versionsverwaltungssystem verweisen, der dieser Container zugeordnet ist. Wenn Sie das Feld leer lassen, wird die neueste Version der Testsuite abgerufen. Die Eigenschaft Label der Versionsverwaltung ist nur verfügbar, wenn der zugeordnete Container ein Versionsverwaltungsprofil verwendet, das die Versionsverwaltung unterstützt. Stellen Sie sicher, dass auf den Ausführungsservern ausreichend freier Speicherplatz verfügbar ist, wenn Sie mit mehreren Quelldateiversionen arbeiten. Jede Version wird auf jedem Ausführungsserver in einem eigenen Ordner gespeichert.
    Tipp: Wenn Sie für eine bestimmte Testsuite einen bestimmten Branch aus dem Repository auschecken möchten, geben Sie den Namen des Branches im Feld Label der Versionsverwaltung in der entsprechenden Testsuite ein.
  9. Klicken Sie auf OK, um die Testsuitehierarchie mit der neuen Testsuite zu aktualisieren.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten
Zugehörige Konzepte
Build-Informationen
Versionsverwaltungsprofil-Integration
Zugehörige Tasks
Erstellen einer Testsuite in der Tabellenansicht
Bearbeiten von Elementen der Testsuitehierarchie
Zugehörige Verweise
Eigenschaften von Testsuiten (Seite)


Teststatusberechnung

Jede Testsuite weist eine der folgenden Statusbedingungen auf:
Status
Bedingung
Bestanden
Alle betrachteten Testläufe der Testsuiten haben den Status Bestanden.
Fehlgeschlagen
Mindestens eine der relevanten Testsuiten hat den Status Fehlgeschlagen, aber keine davon hat den Status Nicht ausgeführt.
Nicht ausgeführt
Mindestens eine der relevanten Tests hat den Status Nicht ausgeführt.

Eine Test bezieht ihren Status aus dem Ergebnis ihres letzten Testsuitelaufs. Wenn Sie den Status des letzten Testsuitelaufs manuell ändern, ändert sich auch der Status der Test.

Anmerkung: Wenn der letzte Testsuitelauf gelöscht wird, dann wird der Status der Test auf den Status des vorherigen vorhandenen Testsuitelaufs zurückgesetzt. Wenn der gelöschte Testsuitelauf der einzige vorhandene Testsuitelauf war, wird der Status der Test auf N/V, d. h. den Status einer neu erstellten Test, zurückgesetzt.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten


Testsuite-Attribute

Attribute sind frei erstellbare Merkmale, die auf Testsuiten angewendet werden können. Sie können Attribute für das Filtern und die Berichterstellung verwenden.
Anmerkung: Attribute werden ähnlich wie Eigenschaften und Erfolgsbedingungen vererbt. Die Attribute des übergeordneten Knotens werden an sämtliche Unterordner und untergeordnete Testsuiten weitergegeben. Für den Projektknoten und den Knoten Probelauf können keine Attribute definiert werden.
  • Zuordnen von Attributen zu Testsuiten
    Weisen Sie ein Attribut einer Testsuite zu, um nach durch das angegebene Attribut bezeichneten Kategorien zu filtern und Berichte zu erstellen.
  • Bearbeiten von Testsuite-Attributen
    Bearbeiten Sie ein Testsuite-Attribut, um die Merkmale der Testsuite zu ändern.
  • Löschen von Testsuite-Attributen
    Löschen Sie ein Attribut aus einer Testsuite, wenn die Testsuite nicht mehr vom Attribut bezeichnet wird.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten


Zuordnen von Attributen zu Testsuiten

So weisen Sie einer Testsuite ein Attribut zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite aus, zu der Attribute zugeordnet werden sollen.
  3. Klicken Sie im Bereich Attribute auf Attribut hinzufügen. Das Dialogfeld Attribute hinzufügen wird angezeigt.
  4. Klicken Sie in der Spalte Hinzufügen des Attributs, das Sie zuordnen möchten, auf ( Attribut hinzufügen). Basierend auf dem ausgewählten Attributtyp wird ein Dialogfeld Attribut bearbeiten geöffnet, in dem Sie angeben können, welche der verfügbaren Attributwerte der Testsuite zugeordnet werden sollen.
  5. Wählen Sie den Attributwert aus, und klicken Sie auf OK, um das Attribut der Testsuite zuzuordnen.
Übergeordnetes Thema: Testsuite-Attribute


Bearbeiten von Testsuite-Attributen

So bearbeiten Sie ein Testsuite-Attribut:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite aus, deren Attribut Sie bearbeiten möchten.
  3. Klicken Sie im Bereich Attribute auf das Symbol Bearbeiten des Attributs, das Sie bearbeiten möchten. Das Dialogfeld Attribut bearbeiten wird angezeigt. Welche Optionen im Dialogfeld Attribut bearbeiten verfügbar sind, hängt vom ausgewählten Attributtyp ab.
  4. Wählen Sie den gewünschten Wert aus, und klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Testsuite-Attribute


Löschen von Testsuite-Attributen

So löschen Sie ein Testsuite-Attribut:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, aus der Sie das zugeordnete Attribut löschen möchten.
  3. Klicken Sie im Bereich Attribute auf das Symbol Löschen des Attributs, das Sie löschen möchten. Ein Bestätigungsdialogfeld Attribut löschen wird angezeigt.
  4. Klicken Sie auf Ja, um das Attribut zu löschen.
    Anmerkung: Geerbte Attribute und Attribute, die bereits in einem Testlauf verwendet wurden, können nicht gelöscht werden.
Übergeordnetes Thema: Testsuite-Attribute


Testsuite-Parameter

Um eine bestimmte Konfiguration auf eine Testsuite anzuwenden, können die dem Test zugeordneten Parameter auf der Seite Eigenschaften im Bereich Parameter der Testsuite außer Kraft gesetzt werden. Weitere Informationen zu Testparametern finden Sie unter Testparameter.

  • Vordefinierte Parameter
    Für Testausführungen stellt Silk Central Informationen zu den Eigenschaften von Testsuiteläufen in Form von Parametern zur Verfügung.
  • Erstellen von Testsuite-Parametern
    Hier wird das Hinzufügen neuer Parameter zu einer Testsuite beschrieben.
  • Überschreiben von Testparametern
    Hier wird beschrieben, wie Testparameter in einer Testsuite überschrieben werden können.
  • Entfernen von Testsuiteparametern
    Hier wird beschrieben, wie Sie einen Testsuite-Parameter aus einer Testsuite entfernen.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten
Zugehörige Konzepte
Testparameter


Erstellen von Testsuite-Parametern

So fügen Sie einen neuen Parameter zu einer Testsuite hinzu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Hierarchie Testausführung die Testsuite aus, der Sie einen neuen Parameter hinzufügen möchten.
  3. Klicken Sie im Bereich Parameter auf Neuer Testsuite-Parameter. Das Dialogfeld Neuer Testsuite-Parameter wird angezeigt.
  4. Geben Sie Namen und Wert des neuen Parameters in die entsprechenden Felder ein. Neue Testsuite-Parameter sind immer vom Typ "String". Es ist nicht möglich, einen anderen Typ zu definieren.
  5. Klicken Sie auf OK, um den Parameter der Testsuite hinzuzufügen.
    Anmerkung: Sie können keine Testsuite-Parameter erstellen, deren Namen mit denen von bestehenden Testsparametern aus der Testsuite identisch sind.
Zum Testen von Konfigurationen können Sie mehrere Testsuiten mit denselben Tests erstellen und anschließend verschiedene Konfigurationen auf der Seite Parameter definieren. Parameter aus verschiedenen Tests mit demselben Namen und Typ werden auf der Seite nicht mehrfach angezeigt. Wenn mehrere Parameter aus verschiedenen Tests mit demselben Namen existieren, können Sie nur einen dieser Parameter überschreiben.
Übergeordnetes Thema: Testsuite-Parameter


Überschreiben von Testparametern

Wenn mehrere Parameter unterschiedlichen Typs mit demselben Namen existieren, können Sie nur einen dieser Parameter überschreiben. Nur die Werte von Parametern desselben Typs und Namens werden bei der Ausführung mit dem betreffenden Wert überschrieben.

So überschreiben Sie einen Testparameter in einer Testsuite:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite aus, in der Sie einen Testparameter überschreiben möchten.
  3. Klicken sie im Bereich Parameter auf Parameterwert setzen in der Spalte Aktionen des Parameters, den Sie überschreiben möchten. Das Dialogfeld Wert des Testsuite-Parameters setzen wird angezeigt.
  4. Geben Sie den neuen Wert in das Feld ein.
  5. Klicken Sie auf OK.
Anmerkung: Klicken Sie auf Testsuiteparameter entfernen in der Spalte Aktionen des Parameters, wenn Sie das Überschreiben rückgängig machen möchten.
Übergeordnetes Thema: Testsuite-Parameter


Entfernen von Testsuiteparametern

Anmerkung: Testparameter können in einer Testsuite nicht entfernt werden. Nur Testsuite-Parameter können entfernt werden.

So entfernen Sie Testsuite-Parameter:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Hierarchie Ausführung die Testsuite aus, aus der Sie einen Parameter entfernen möchten.
  3. Klicken sie im Bereich Parameter auf Testsuite Parameter löschen in der Spalte Aktionen des Parameters, den Sie löschen möchten.
Übergeordnetes Thema: Testsuite-Parameter


Vorbereitung und Nachbereitung von Tests

Sie können in Silk Central für jede Testsuite eine Vorbereitung und eine Nachbereitung definieren. Die Vorbereitungen werden in Regel durch ein Skript oder einen manuellen Arbeitsschritt implementiert, um die Testumgebung auf die Tests vorzubereiten. Nachbereitungen werden typischerweise durch ein Skript oder einen manuellen Arbeitsschritt implementiert, um nach den Tests den ursprünglichen Zustand der Testumgebung wiederherzustellen. Wenn Sie die Vorbereitungen abbrechen, werden die normalen Tests nicht mehr ausgeführt. Jedoch wird mit den Nachbereitungen der ursprüngliche Zustand der Testumgebung wiederhergestellt.

Sie müssen die Vorbereitungs- und Nachbereitungstests erstellen, bevor Sie sie einer Testsuite zuordnen können. Mit Ausnahme von übergeordneten Tests mehrerer datengetriebener Testsinstanzen, kann jeder Test als Vorbereitung oder Nachbereitung verwendet werden. Sie erfordern keine spezielle Konfiguration und können automatisiert oder manuell ausgeführt werden. Einzige Voraussetzung ist, dass die erforderlichen Vorbereitungs- und Nachbereitungsvorgänge innerhalb Ihrer Testumgebung durchgeführt werden. Bei automatisierten Tests werden diese Vorgänge mit Hilfe eines Skripts durchgeführt. Bei manuellen Tests werden sie manuell durchgeführt.

Anmerkung: Die Herausforderung bei der Ausführung von Vorbereitungs- und Nachbereitungstests besteht darin, zu verhindern, dass ihr Ergebnis zusammen mit dem der normalen Tests ausgewertet wird. Silk Central führt daher diese Tests (automatisierte und manuelle) in eigenen Testsuiten aus. So können sich unvorhersehbare Auswirkungen von Vorbereitungs- und Nachbereitungstests nicht auf die eigentlichen Testergebnisse auswirken.
  • Kombinieren von automatisierten und manuellen Tests
    Hier wird beschrieben, wie mit Silk Central Kombinationen aus automatisierten und manuellen Tests in einer Testsuite verwendet werden können.
  • Konfigurieren von Vorbereitungen und Nachbereitungen
    Konfigurieren Sie Vorbereitungen und Nachbereitungen, um die Testumgebung auf die Tests vorzubereiten bzw. die Testumgebung so wiederherzustellen, wie sie vor den Tests war.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten


Kombinieren von automatisierten und manuellen Tests

Silk Central unterstützt Kombinationen aus automatisierten und manuellen Tests in einer Testsuite. Bei solchen Testsuiten werden die normalen Tests (manuelle und automatisierte) von Silk Central erst ausgeführt, wenn die Vorbereitungstests abgeschlossen sind. Silk Central stellt außerdem sicher, dass sämtliche normale Tests abgeschlossen sind, bevor die Nachbereitungstests ausgeführt werden.

Wenn Sie manuelle Tests mit automatisierten Tests kombinieren, werden die automatisierten Tests auf allen Ausführungsservern erst dann gestartet, wenn die Vorbereitungstests abgeschlossen sind. Falls manuelle Tests vorhanden sind, werden die normalen automatisierten Tests nach Abschluss der manuellen Vorbereitungen ausgeführt.

Übergeordnetes Thema: Vorbereitung und Nachbereitung von Tests


Konfigurieren von Vorbereitungen und Nachbereitungen

So definieren Sie einen Test als Vorbereitung oder Nachbereitung:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite aus, für die Sie einen Test als Vorbereitung oder Nachbereitung konfigurieren möchten.
  3. Wählen Sie im Bereich Testausführungs-Setup zwischen Vorbereitung und Nachbereitung aus.
    • Um eine Vorbereitung zu definieren, klicken Sie unter Vorbereitung auf Bearbeiten (Bearbeiten). Das Dialogfeld Vorbereitung bearbeiten wird angezeigt.
    • Um eine Nachbereitung zu definieren, klicken Sie unter Nachbereitung auf Bearbeiten (Bearbeiten). Das Dialogfeld Nachbereitung bearbeiten wird angezeigt.
    Ein Test kann derselben Testsuite nicht als Vorbereitung und als normaler Test oder Nachbereitung zugewiesen werden. Die Tests können aus jedem Container im Projekt stammen. Sie können daher Tests verwenden, denen andere Produkte und Versionsverwaltungsprofile als ihren übergeordneten Testsuiten zugeordnet sind.
  4. Wählen Sie in der Hierarchie Tests den gewünschten Test aus.
  5. Klicken Sie auf OK.
Wenn Sie fehlgeschlagene Tests erneut starten, werden die zugehörigen Vorbereitungen und Nachbereitungen ebenfalls wieder ausgeführt. Die Vorbereitungen und Nachbereitungen werden nicht mit den Probeläufen gestartet, da diese keine Testsuiten verwenden.
Übergeordnetes Thema: Vorbereitung und Nachbereitung von Tests


Konfigurieren von Testumgebungen

  • Testumgebung (Seite)
    Hier werden sämtliche Schlüsselwörter für die Hardwarebereitstellung angezeigt, die für die Testsuite definiert wurden. Außerdem werden die Zuweisungen von Benutzern zum Ausführen von manuellen Tests und die Zuweisungen von Silk Test Classic-AUT-Hosts zum Ausführen von Silk Test Classic-Tests angezeigt.
  • Hinzufügen oder entfernen von manuellen Testern
    Fügen Sie manuelle Tester einer Testsuite mit manuellen Tests hinzu oder entfernen Sie welche.
  • Dynamische Hardwarebereitstellung mit Schlüsselwörtern
    Die Technologie für die Hardwarebereitstellung von Silk Central erleichtert die Verwaltung von Testumgebungen mit zahlreichen Ausführungsservern. Statt für jede automatisierte Testsuite eine bestimmte statische Ausführungsserverzuordnung zu konfigurieren, kann Silk Central mithilfe von Schlüsselwörtern automatisch den für eine Testsuite geeigneten Ausführungsserver auswählen. Hierzu werden die Schlüsselwortlisten der einzelnen Testsuiten jeweils mit den Schlüsselwortlisten aller aktiven Ausführungsserver verglichen.
  • Exklusive Testausführung
    Die exklusive Testausführung bestimmt, ob Tests von anderen Testsuiten, die diese Einstellung ausgeschaltet haben, am gleichen Ausführungsserver gleichzeitig ausgeführt werden können (Deaktiviert), oder ob nur Tests von einer Testsuite gleichzeitig ausgeführt werden dürfen (Aktiviert).
  • Verteilte Testausführung
    Die verteilte Testausführung legt fest, ob die einer Testsuite zugeordneten Tests nacheinander auf dem ausgewählten Ausführungsserver ausgeführt werden (Deaktiviert) oder ob sie auf allen passenden Ausführungsservern verteilt und gleichzeitig ausgeführt werden (Aktiviert).
  • Auswählen von mobilen Geräten für automatisiertes Testen
    Wählen Sie ein mobiles Gerät aus (physisches Gerät, Emulator oder Simulator), auf dem Ihre Testsuite ausgeführt werden soll.
  • Codeanalyse
    Hier wird beschrieben, wie die Codeabdeckung mit Silk Central analysiert werden kann.
  • Hinzufügen eines Silk Test Classic-AUT-Hosts
    Fügen Sie einen Silk Test Classic-AUT-Host hinzu, wenn sich der Silk Test Classic-Agent auf einem anderen Computer als der Ausführungsserver befindet.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten


Testumgebung (Seite)

Ausführungsplanung > Detailansicht > <Testsuite> > Testumgebung

Auf der Seite Testumgebung werden sämtliche Schlüsselwörter für die Hardwarebereitstellung angezeigt, die für diese Testsuite definiert wurden. Mit diesen Schlüsselwörtern werden die Anforderungen an die Ausführungsumgebung für die Testsuite beschrieben. Der Ausführungsserver entspricht nur dann der ausgewählten, automatisierten Testsuite, wenn ihm alle für die Testsuite erforderlichen Schlüsselwörter zugeordnet wurden. Außerdem werden auf der Seite Testumgebung die Zuweisungen von Benutzern zum Ausführen von manuellen Tests und die Zuweisungen von Silk Test Classic-AUT-Hosts zum Ausführen von Silk Test Classic-Tests angezeigt.

Anmerkung: Neue Ausführungsserver werden unter Verwaltung > Ausführungsserver eingerichtet. Details zum Aufsetzen eines Ausführungsservers finden Sie unter Einrichten von Ausführungsservern.

Manuelle Testausführung

Eine Liste der manuellen Tester, die dieser Testsuite oder diesem Ordner zugewiesen sind. Klicken Sie auf Bearbeiten, wenn Sie die Liste der manuellen Tester bearbeiten möchten. Weitere Informationen finden Sie unter Hinzufügen oder entfernen von manuellen Testern.

Automatisierte Testausführung

Auf der Seite Testumgebung werden im Abschnitt Automatisierte Testausführung die folgenden Elemente angezeigt:
Element | Beschreibung
Zugewiesene Schlüsselwörter
Die der Testsuite zugewiesenen Schlüsselwörter.
Automatisierte Testsuiten
Mithilfe von Schlüsselwörtern wird automatisch der geeignete Ausführungsserver für jede Testsuite bestimmt.
Manuelle Testsuiten
Der manuelle Tester legt mit Schlüsselwörtern die entsprechende Testumgebung fest.
Weitere Informationen finden Sie unter Zuordnen von Schlüsselwörtern zu Testsuiten.
Schlüsselwortbezogene Liste potentieller Ausführungsserver für die Testumgebung zur Ausführungszeit | Listet die aktiven Ausführungsserver auf, deren Schlüsselwortlisten mit der Schlüsselwortliste dieser Testsuite übereinstimmen. Alle Schlüsselwörter aus der Schlüsselwortliste der Testsuite müssen in der Schlüsselwortliste des Ausführungsservers enthalten sein. Klicken Sie in der Liste auf den Namen eines Ausführungsservers, um auf die Ausführungsserverliste in Verwaltung > Ausführungsserver zuzugreifen.
Exklusive Testausführung | Die exklusive Testausführung bestimmt, ob Tests von anderen Testsuiten, die diese Einstellung ausgeschaltet haben, am gleichen Ausführungsserver gleichzeitig ausgeführt werden können (Deaktiviert), oder ob nur Tests von einer Testsuite gleichzeitig ausgeführt werden dürfen (Aktiviert). Das Deaktivieren der exklusiven Ausführung reduziert die benötigte Ausführungszeit und ist vor allem für das Testen auf mobilen Geräten nützlich, wo Testsuiten auf verschiedenen Geräten eines Geräte-Anbieters gleichzeitig ausgeführt werden können. Es sind keine Änderungen Ihrer aktuellen Ausführungskonfiguration nötig, wenn Sie die exklusive Testausführung deaktivieren. Weitere Information finden Sie unter Exklusive Testausführung.
Verteilte Testausführung | Die verteilte Testausführung legt fest, ob die einer Testsuite zugeordneten Tests nacheinander auf dem ausgewählten Ausführungsserver ausgeführt werden (Deaktiviert) oder ob sie auf allen passenden Ausführungsservern verteilt und gleichzeitig ausgeführt werden (Aktiviert). Es sind keine Änderungen Ihrer aktuellen Ausführungskonfiguration nötig, wenn Sie die verteilte Testausführung aktivieren. Weitere Information finden Sie unter Verteilte Testausführung.
Videoaufzeichnung
Legt fest, ob während der Ausführung einer Testsuite ein Video aufgezeichnet wird. Diese Einstellung überschreibt die Einstellungen für Videoaufzeichnungen der einzelnen Tests, die der Testsuite zugeordnet sind. Sie können einen der folgenden Werte auswählen:
Wert
Beschreibung
---
Die Videoaufzeichnung ist deaktiviert, wenn nicht recordVideo für die zugeordneten Tests eingestellt ist.
Nie
Die Videoaufzeichnung ist generell deaktiviert, auch wenn recordVideo für die zugeordneten Tests eingestellt ist.
Immer
Bei jeder Testsuiteausführung wird ein Video aufgezeichnet.
Im Fehlerfall
Wenn bei der Testsuiteausführung ein Fehler auftritt, wird ein Video aufgezeichnet.
Weitere Informationen finden Sie unter Videoaufnahme.
Screenshots
Legt fest, ob während der Ausführung einer Testsuite ein Screenshot aufgezeichnet wird. Diese Einstellung überschreibt die Einstellungen für Screenshots der einzelnen Tests, die der Testsuite zugeordnet sind. Sie können einen der folgenden Werte auswählen:
Wert
Beschreibung
---
Die Aufzeichnung von Screenshots ist deaktiviert, wenn nicht captureScreen für die zugeordneten Tests eingestellt ist.
Nie
Die Aufzeichnung von Screenshots ist generell deaktiviert, auch wenn captureScreen für die zugeordneten Tests eingestellt ist.
Im Fehlerfall
Wenn bei der Testsuiteausführung ein Fehler auftritt, wird ein Screenshot aufgezeichnet.
Weitere Informationen finden Sie unter Screenshots.
Bedingung zum Beenden der Ausführung
Legt fest, ob die Ausführung angehalten wird, wenn ein Test fehlschlägt oder nicht ausgeführt wird. Diese Einstellung ist vor allem dann hilfreich, wenn es nicht sinnvoll ist, mehrere Tests laufen zu lassen, sobald ein Test fehlschlägt. Mit dieser Einstellung können Sie Ressourcen sparen und sich früher benachrichtigen lassen, wenn ein Test fehlschlägt. Sie können einen der folgenden Werte auswählen:
Wert
Beschreibung
---
Die Ausführung wird auch dann fortgesetzt, wenn ein Test nicht ausgeführt wird oder fehlschlägt.
Im Fehlerfall
Die Ausführung wird nach dem ersten fehlgeschlagenen Test beendet.
Nicht ausgeführt
Die Ausführung wird nach dem ersten nicht ausgeführten Test beendet.
Im Fehlerfall oder bei Nicht Ausgeführt
Die Ausführung wird nach dem ersten fehlgeschlagenen oder nicht ausgeführten Test beendet.
Anmerkung: Wenn eine Ausführung angehalten wird, werden die Ergebnisse der erfolgreich durchgeführten Tests beibehalten. Testpakete (mit allen untergeordneten Tests) werden immer vollständig ausgeführt. Sie werden also nicht zeitweilig angehalten. Datengetriebene Tests werden jedoch angehalten, sobald ein untergeordneter Test fehlschlägt.
Silk Test Classic-AUT-Hostname

Eine Liste der Silk Test Classic-AUT-Hosts, die dieser Testsuite zugewiesen sind. Klicken Sie auf Bearbeiten, wenn Sie die Liste der Silk Test Classic-AUT-Hosts bearbeiten möchten. Weitere Informationen erhalten Sie unter Hinzufügen eines Silk Test Classic-AUT-Hosts.

Mobilgeräte-Auswahl

Zeigt das Mobilgerät an, das für die Ausführung der Testsuite ausgewählt wurde. Klicken Sie auf Bearbeiten, um ein anderes Gerät auszuwählen. Beachten Sie, dass der Geräteanbieter und Ihr aktuelles Projekt der selben Servergruppe zugeordnet sein müssen, sonst werden in der Liste keine Geräte angezeigt. Weitere Information finden Sie unter Verwalten von Geräte-Anbietern.

Einstellungen für die Codeanalyse

Die für diese Testsuite festgelegten Codeanalyseeinstellungen. Klicken Sie auf Aktiv/Inaktiv, um die Codeanalyse für diese Testsuite zu aktivieren bzw. zu deaktivieren. Weitere Information finden Sie unter Codeanalyse.

Übergeordnetes Thema: Konfigurieren von Testumgebungen
Zugehörige Konzepte
Videoaufnahme


Hinzufügen oder entfernen von manuellen Testern

Bei Testsuiten mit manuellen Tests können Sie auf der Seite Testumgebung bestimmte Benutzer als manuelle Tester einer Testsuite zuweisen. Sie können einer Testsuite mehrere manuelle Tester zuweisen.

So weisen Sie einer Testsuite einen manuellen Tester zu oder entfernen einen:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Testumgebung.
  4. Klicken Sie im Abschnitt Manuelle Testausführung auf Bearbeiten . Der Dialog Manuelle Tester zuordnen wird angezeigt.
  5. Wählen Sie die gewünschte Benutzergruppe aus der Liste Verfügbar aus.
  6. Fügen Sie Tester hinzu, oder entfernen Sie Tester:
    • Wählen Sie einen oder mehrere Benutzer in der Liste Verfügbar aus, und klicken Sie auf Hinzufügen oder Alle hinzufügen.
    • Wählen Sie einen oder mehrere Benutzer in der Liste Ausgewählte aus, und klicken Sie auf Entfernen oder Alle entfernen.
    Mehrere Benutzer können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  7. Klicken Sie auf OK, um den Dialog Manuelle Tester zuordnen zu schließen.
Übergeordnetes Thema: Konfigurieren von Testumgebungen


Dynamische Hardwarebereitstellung mit Schlüsselwörtern

Die Technologie für die Hardwarebereitstellung von Silk Central erleichtert die Verwaltung von Testumgebungen mit zahlreichen Ausführungsservern. Statt für jede automatisierte Testsuite eine bestimmte statische Ausführungsserverzuordnung zu konfigurieren, kann Silk Central mithilfe von Schlüsselwörtern automatisch den für eine Testsuite geeigneten Ausführungsserver auswählen. Hierzu werden die Schlüsselwortlisten der einzelnen Testsuiten jeweils mit den Schlüsselwortlisten aller aktiven Ausführungsserver verglichen.
  • Schlüsselwort-Konzepte
    Schlüsselwörter beschreiben in der Regel die Anforderungen an die Ausführungsumgebung, wie beispielsweise Plattform, Betriebssystem und vorinstallierte Anwendungen. Je nachdem, ob die Testsuite automatisch oder manuell ausgeführt wird, werden Schlüsselwörter unterschiedlich verwendet.
  • Erstellen neuer Schlüsselwörter
    Erstellen Sie neue Schlüsselwörter, um die Ausführungsumgebung zu beschreiben.
  • Zuordnen von Schlüsselwörtern zu Testsuiten
    Weisen Sie Testsuiten Schlüsselwörter zu, um die Ausführungsumgebung zu beschreiben.
  • Entfernen von Schlüsselwörtern aus Testsuiten
    Entfernen Sie Schlüsselwörter aus einer Testsuite, wenn diese die Ausführungsumgebung nicht mehr korrekt beschreiben.
Übergeordnetes Thema: Konfigurieren von Testumgebungen


Schlüsselwort-Konzepte

Schlüsselwörter beschreiben in der Regel die Anforderungen an die Ausführungsumgebung, wie beispielsweise Plattform, Betriebssystem und vorinstallierte Anwendungen. Je nachdem, ob die Testsuite automatisch oder manuell ausgeführt wird, werden Schlüsselwörter unterschiedlich verwendet.
Automatisierte Testsuiten
Wenn eine Testsuite ausgeführt wird, vergleicht Silk Central die Schlüsselwörter der Testsuite mit den Schlüsselwörtern aller verfügbarer Ausführungsserver. Die Testsuite wird dann auf dem zuerst erkannten Ausführungsserver ausgeführt, der über eine übereinstimmende Schlüsselwortliste verfügt.
Manuelle Testsuiten
Bei manuellen Testsuiten kann der manuelle Tester die Testumgebung mit Schlüsselwörtern festlegen.

Wenn eine automatisierte Testsuite auf mehreren Ausführungsservern ausgeführt werden muss, erstellen Sie eine Kopie der Testsuite und ordnen der Testsuite zusätzliche Schlüsselwörter zu, die den Schlüsselwörtern anderer Ausführungsserver entsprechen.

Reservierte Schlüsselwörter

Falls keine Hardwarebereitstellung für die Ausführung von automatisierten Testsuiten erforderlich ist, können Sie die reservierten Schlüsselwörter benutzen, die automatisch für jeden Ausführungsserver definiert werden. In diesem Fall ist es nicht erforderlich, den Ausführungsservern manuell Schlüsselwörter zuzuordnen. Stattdessen können Sie jede Testsuite direkt statisch einem Ausführungsserver zuordnen.

Jedem neu eingerichteten Ausführungsserver wird automatisch ein reserviertes Schlüsselwort zugeordnet. Reservierte Schlüsselwörter haben folgendes Format: #<execution server name>@<location name>.

Reservierte Schlüsselwörter sind nur beim Zuordnen von Schlüsselwörtern zu Testsuiten verfügbar.

Neben den reservierten Schlüsselwörtern, die automatisch für jeden definierten Ausführungsserver eingerichtet werden, werden auch für jeden Ausführungsservertyp reservierte Schlüsselwörter festgelegt.
#PHYSICAL
Beschränkt die Bereitstellung von Ausführungsservern auf physische Ausführungsserver.
#VIRTUAL
Beschränkt die Bereitstellung von Ausführungsservern auf virtuelle Ausführungsserver.

Schlüsselwörter und virtuelle Ausführungsserver

Schlüsselwörter werden virtuellen Ausführungsservern auf die gleiche Weise zugeordnet wie physischen Ausführungsservern. Sobald Sie mindestens einen virtuellen Ausführungsserver konfigurieren, wird das Schlüsselwort #VIRTUAL dynamisch erstellt und zum Zuordnen zu allen Testsuiten verfügbar gemacht. Wenn eine Testsuite auf einem virtuellen Computer ausgeführt werden soll, wählen Sie für die Testsuite das Schlüsselwort #VIRTUAL. Wenn einer Testsuite weder das Schlüsselwort #VIRTUAL noch das Schlüsselwort #PHYSICAL zugeordnet wurde, kann sie entweder auf einem virtuellen oder einem physischen Ausführungsserver ausgeführt werden, sofern die Einstellungen für die Ausführungsumgebung übereinstimmen. Wenn die Schlüsselwörter einer Test mehreren virtuellen Ausführungsservern entsprechen, wird der virtuelle Ausführungsserver ausgewählt, der zuerst erkannt wird.

Ausführung von Ordnern

Testsuiten können in Ordnern zusammengefasst werden, die wiederum Unterordner und Testsuiten enthalten können. Die Optionen für die Ausführung einer Testsuite sind auch für die Ausführung von Ordnern verfügbar.

Bei der Ausführung eines Ordners werden die darin enthaltenen Unterordner und Testsuiten wie folgt behandelt:
Schlüsselwörter des ausgeführten Ordners | Schlüsselwörter der darin enthaltenen Testsuite/Unterordner | Ausführung der darin enthaltenen Testsuite/Unterordner
Ohne Schlüsselwörter | Ohne Schlüsselwörter | Eine Testsuite ohne Schlüsselwörter erhält nach der Ausführung den Status NICHT AUSGEFÜHRT.
Ohne Schlüsselwörter | Mit Schlüsselwörtern | Ausführungsserver werden anhand der Schlüsselwörter der Testsuite bzw. Unterordner zugeordnet.
Mit Schlüsselwörtern | Ohne Schlüsselwörter | Ausführungsserver werden anhand der Schlüsselwörter des Ordners zugeordnet.
Mit Schlüsselwörtern | Mit Schlüsselwörtern | Ausführungsserver werden anhand der Schlüsselwörter des Ordners zugeordnet.
Anmerkung: Wenn ein Ordner manuell ausgeführt wird und wenn keine Schlüsselwörter zugeordnet wurden oder kein Ausführungsserver für die zugeordneten Schlüsselwörter gefunden wird, dann wird eine Testsuite als Nicht ausgeführt gekennzeichnet.
Übergeordnetes Thema: Dynamische Hardwarebereitstellung mit Schlüsselwörtern


Erstellen neuer Schlüsselwörter

So erstellen Sie neue Schlüsselwörter:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Testumgebung.
  4. Klicken Sie im Abschnitt Ausführungsumgebung auf Bearbeiten. Das Dialogfeld Schlüsselwörter zuordnen wird angezeigt. Alle Schlüsselwörter, die für die Ausführungsumgebung definiert worden sind, werden hier aufgeführt.
    Anmerkung: Die standardmäßig reservierten Schlüsselwörter für die einzelnen Ausführungsserver, #<execution server name>@<location name>, sind in der Liste enthalten.
  5. Geben Sie ein alphanumerisches Schlüsselwort in das Feld Schlüsselwort ein, das die Umgebungsanforderungen der Testsuite beschreibt.

    Als Schlüsselwort können beispielsweise der Name der Plattform, das Betriebssystem oder vorinstallierte Anwendungen dienen. Die folgenden Zeichen dürfen in Schlüsselwörtern nicht verwendet werden: #$?*\,;'".

    Anmerkung: Groß-/Kleinschreibung wird bei Schlüsselwörtern nicht berücksichtigt. Beispielsweise werden "Vista" und "vista" als identisch betrachtet.
  6. Drücken Sie die Eingabetaste. Das neue Schlüsselwort steht damit für die Zuordnung bereit.
Übergeordnetes Thema: Dynamische Hardwarebereitstellung mit Schlüsselwörtern


Zuordnen von Schlüsselwörtern zu Testsuiten

So ordnen Sie Testsuiten Schlüsselwörter zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Testumgebung.
  4. Klicken Sie im Abschnitt Ausführungsumgebung auf Bearbeiten. Das Dialogfeld Schlüsselwörter zuordnen wird angezeigt. Alle Schlüsselwörter, die für die Ausführungsumgebung definiert worden sind, werden hier aufgeführt.
    Anmerkung: Die standardmäßig reservierten Schlüsselwörter für die einzelnen Ausführungsserver, #<execution server name>@<location name>, sind in der Liste enthalten.
  5. Wählen Sie aus der Liste Schlüsselwörter auswählen oder eingeben ein Schlüsselwort aus, oder geben Sie ein neues Schlüsselwort ein. Mehrere Schlüsselwörter können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
    Tipp: Das Feld Schlüsselwörter auswählen oder eingeben wird automatisch vervollständigt. Wenn Sie alphanumerische Zeichen eingeben, wird ein vorhandenes Schlüsselwort, das mit den eingegebenen Zeichen übereinstimmt, automatisch in das Feld übernommen. Wenn mehrere Schlüsselwörter aus den Listen Schlüsselwörter auswählen oder eingeben oder Zugeordnete Schlüsselwörter ausgewählt sind, wird das Feld deaktiviert.
    Tipp: Wenn Sie nur über einige Ausführungsserver verfügen und keine Hardwarebereitstellung benötigen, kommen Sie möglicherweise mit den für jeden Ausführungsserver definierten reservierten Standardschlüsselwörtern aus. In solchen Fällen ist die Auswahl weiterer Schlüsselwörter nicht erforderlich.
  6. Klicken Sie auf >, um das Schlüsselwort in die Liste Zugeordnete Schlüsselwörter zu verschieben. Klicken Sie auf <, um die Schlüsselwörter aus der Liste zu entfernen. Sie können auch auf Schlüsselwörter klicken, um sie von einer Liste in die andere zu verschieben.
    Anmerkung: Die Ausführungsserver, die den zugeordneten Schlüsselwörtern entsprechen, werden nachfolgend in der dynamisch aktualisierten Liste der passenden Ausführungsserver angezeigt. Diese Liste wird jedes Mal aktualisiert, wenn Sie ein Schlüsselwort hinzufügen oder entfernen. Klicken Sie in der Liste auf den Namen eines Ausführungsservers, um auf die Ausführungsserver in Verwaltung > Ausführungsserver zuzugreifen.
  7. Klicken Sie auf OK, um die Schlüsselwörter zu speichern und den Dialog Schlüsselwörter zuordnen zu schließen.
Übergeordnetes Thema: Dynamische Hardwarebereitstellung mit Schlüsselwörtern


Entfernen von Schlüsselwörtern aus Testsuiten

So entfernen Sie Schlüsselwort-Zuordnungen von Testsuiten:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Testumgebung.
  4. Klicken Sie im Abschnitt Ausführungsumgebung auf Bearbeiten. Das Dialogfeld Schlüsselwörter zuordnen wird angezeigt. Alle Schlüsselwörter, die für die Ausführungsumgebung definiert worden sind, werden hier aufgeführt.
    Anmerkung: Die standardmäßig reservierten Schlüsselwörter für die einzelnen Ausführungsserver, #<execution server name>@<location name>, sind in der Liste enthalten.
  5. Wählen Sie in der Liste Zugewiesene Schlüsselwörter die nicht mehr benötigten Schlüsselwörter aus. Mit Strg+Klick bzw. Umschalttaste+Klick können Sie mehrere Schlüsselwörter auswählen.
  6. Klicken Sie auf <, um die Schlüsselwort-Zuordnungen zu entfernen.
  7. Klicken Sie auf OK, um die Schlüsselwörter zu speichern und den Dialog Schlüsselwörter zuordnen zu schließen.
Anmerkung: Nicht mehr verwendete Schlüsselwörter werden automatisch aus dem System gelöscht.
Übergeordnetes Thema: Dynamische Hardwarebereitstellung mit Schlüsselwörtern


Exklusive Testausführung

Die exklusive Testausführung bestimmt, ob Tests von anderen Testsuiten, die diese Einstellung ausgeschaltet haben, am gleichen Ausführungsserver gleichzeitig ausgeführt werden können (Deaktiviert), oder ob nur Tests von einer Testsuite gleichzeitig ausgeführt werden dürfen (Aktiviert). Das Deaktivieren der exklusiven Ausführung reduziert die benötigte Ausführungszeit und ist vor allem für das Testen auf mobilen Geräten nützlich, wo Testsuiten auf verschiedenen Geräten eines Geräte-Anbieters gleichzeitig ausgeführt werden können. Es sind keine Änderungen Ihrer aktuellen Ausführungskonfiguration nötig, wenn Sie die exklusive Testausführung deaktivieren.

Bevor Sie die gleichzeitige Ausführung aktivieren, beachten Sie Folgendes:
  • Alle Silk Central-Testtypen unterstützen die gleichzeitige Ausführung, außer Silk Test Classic, Silk Test Classic Plan und Silk Performer.
  • Ihre Testskripten sollten sich nicht gegenseitig in die Quere kommen, wenn sie gleichzeitig auf dem selben Rechner ausgeführt werden. Sie sollten keine Daten in gemeinsam verwendete Ordner schreiben, und die getestete Anwendung muss die gleichzeitig ausgeführten, geskripteten Aktionen unterstützen.
  • Das Feld Gemeinsamer Arbeitsordner im verwendeten Versionsverwaltungsprofil muss leer sein. Dadurch kann Silk Central einen temporären Arbeitsordner verwenden.
  • Läuft eine Testsuite auf einem Ausführungsserver, auf dem die exklusive Testausführung aktiviert ist, laufen keine weiteren Testsuiten gleichzeitig, egal was für Einstellungen diese haben.
  • Die Videoaufzeichnung steht bei Verwendung von paralleler Testausführung nicht zur Verfügung.
  • Weitere Information über das gleichzeitige Ausführen von Tests in Silk Test finden Sie an folgenden Stellen:
    • Gleichzeitiges Ausführen von Silk Test Workbench-Tests
    • Gleichzeitiges Ausführen von Silk4J-Tests
    • Gleichzeitiges Ausführen von Silk4NET-Tests
Übergeordnetes Thema: Konfigurieren von Testumgebungen


Verteilte Testausführung

Die verteilte Testausführung legt fest, ob die einer Testsuite zugeordneten Tests nacheinander auf dem ausgewählten Ausführungsserver ausgeführt werden (Deaktiviert) oder ob sie auf allen passenden Ausführungsservern verteilt und gleichzeitig ausgeführt werden (Aktiviert). Es sind keine Änderungen Ihrer aktuellen Ausführungskonfiguration nötig, wenn Sie die verteilte Testausführung aktivieren.

Bevor Sie die verteilte Ausführung aktivieren, beachten Sie Folgendes:
  • Wenn die einzelnen Tests einer Testsuite eine sehr kurze Ausführungszeit haben, wird durch die Aktivierung der verteilten Testausführung die Gesamtausführungszeit nicht verbessert, da der Verwaltungsaufwand für die Testbereitstellung, die Quellcodeverwaltung und das Sammeln der Ergebnisse die Vorteile der parallelen Testausführung überwiegt.
  • Alle Silk Central Testtypen unterstützen die verteilte Testausführung.
  • Wenn bereits ein Test die Codeabdeckung aufzeichnet, ist diese Information für andere Tests auf dem gleichen Ausführungsserver nicht verfügbar.
  • Wenn bereits ein Test ein Video aufzeichnet, ist diese Information für andere Tests auf dem gleichen Ausführungsserver nicht verfügbar.
  • Erfüllt ein Test eine Bedingung zum Beenden der Ausführung, werden all bereits laufenden und noch nicht gestarteten Tests gestoppt. Bereits laufende Tests erhalten den Status Fehlgeschlagen, noch nicht gestartete Tests den Status Nicht ausgeführt. Tests die vor dem Ereignis bereits den Status Bestanden hatten, behalten diesen Status.
  • Virtuelle Ausführungsserver werden bei der verteilten Testausführung nicht berücksichtigt.
Übergeordnetes Thema: Konfigurieren von Testumgebungen


Auswählen von mobilen Geräten für automatisiertes Testen

Bevor Sie ein mobiles Gerät (physisches Gerät, Emulator oder Simulator) auswählen können, auf dem Ihre Testsuite ausgeführt werden soll, muss ein Geräteanbieter konfiguriert werden. Beachten Sie, dass der Geräteanbieter und Ihr aktuelles Projekt der selben Servergruppe zugeordnet sein müssen, sonst werden in der Liste keine Geräte angezeigt. Weitere Information finden Sie unter Verwalten von Geräte-Anbietern.
So wählen Sie ein mobiles Gerät aus:
  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Hierarchie Testausführung die Testsuite aus, für die Sie mobiles Gerät auswählen möchten.
  3. Klicken Sie auf die Registerkarte Testumgebung.
  4. Klicken Sie im Abschnitt Auswahl Mobilgerät auf Bearbeiten . Der Dialog Gerät auswählen wird angezeigt.
  5. Wählen Sie ein mobiles Gerät, einen Gerätefilter oder eine native App aus.
    • Verwenden Sie die Liste auf der rechten Seite, um ein bestimmtes Gerät auszuwählen.
    • Wählen Sie in der Liste auf der rechten Seite Beliebiges Gerät aus, um einen Gerätefilter auszuwählen. Bearbeiten Sie diesen Filter mit dem Suchen-Feld, sowie mit den Listen Plattform und Anwendung auf der linken Seite.
      Tipp: Verwenden Sie das Suchfeld um nach bestimmten Gerätetypen zu suchen, z.B. indem Sie nach Emulator oder Simulator suchen.
    • Um eine native App zum Testen auf einem mobilen Gerät zu installieren, wählen Sie Native App in der Liste Anwendung auf der linken Seite aus. Geben Sie die URL oder den UNC-Pfad zur App im darunter liegenden Feld ein (iOS benötigt eine URL). Beispiel: \\fileserver\apps\testapp.apk
  6. Optional: Aktivieren Sie das Kontrollkästchen Nur physische Geräte verwenden, wenn Sie keine Emulatoren oder Simulatoren verwenden möchten.
  7. Optional: Aktivieren Sie das Kontrollkästchen Verwendete oder blockierte Geräte verbergen, um nur Geräte anzuzeigen die momentan verwendbar (frei) sind. Dies ist vor allem zur Ausführung von manuellen Tests nützlich, oder wenn sie eine Testsuite sofort ausführen möchten.
  8. Klicken Sie auf OK, um die mobile Geräteauswahl zu speichern.
Während der Ausführung wird entweder das ausgewählte Gerät oder das erste mit dem Filter übereinstimmende Gerät verwendet und blockiert, bis die Testsuite fertig ausgeführt wurde. Falls das mobile Gerät nicht verfügbar ist oder keine Geräte dem Filter entsprechen, bleibt der Ausführungs-Job in der Warteschlange, bis ein geeigneter Ausführungsserver oder ein mobiles Gerät verfügbar wird. Sauce Labs-Geräte sind eigentlich keine einzelnen Geräte, sondern eher Gerätetypen, weshalb Sie während Testausführungen nicht blockiert werden.

Um zu einem späteren Zeitpunkt Ihre mobile Geräteauswahl zu ändern oder zu löschen, verwenden sie die Schaltflächen Bearbeiten und Löschen.

Übergeordnetes Thema: Konfigurieren von Testumgebungen


Codeanalyse

Die herkömmliche Analyse der Codeabdeckung liefert Informationen darüber, welcher Code durch Tests abgedeckt wird. Dadurch wird normalerweise die Codeabdeckung für Bereichstests ermittelt. Die Codeanalysefunktion von Silk Central geht weit darüber hinaus. Sie liefert Daten für automatisierte und manuelle Bereichs-, Funktions- und Lasttests in verwalteten Umgebungen. Die Codeabdeckung wird gemessen, um den Testfortschritt zu verfolgen und die Testplanung zu unterstützen. Die innovative Codeanalysefunktion von Silk Central berücksichtigt die Beziehung zwischen bestimmten Tests und dem getesteten Code. Dadurch können die Auswirkungen und Abhängigkeiten von Codeänderungen aus der Testperspektive analysiert werden. Die Tests können besser optimiert werden, da sich feststellen lässt, welche Testläufe für eine bestimmte Codeänderung am ehesten relevant sind.

Der Bereich Codeanalyse enthält Daten zur Codeabdeckung für Anwendungen, Pakete/Namensräume, Klassen, Methoden und Anweisungen. Sie können hier durch eine Testauswirkungsanalyse ermitteln, welche Tests bei bestimmten Codeänderungen ausgeführt werden müssen. Außerdem können Sie mit einer Aufwandsanalyse feststellen, wie lange automatisierte und manuelle Tests ausgeführt werden müssen, um eine ausreichende Abdeckung der Codeänderungen zu erzielen. Jede dieser Codeanalyseaufgaben kann mit einem vorkonfigurierten Bericht durchgeführt werden. Der Bereich enthält eine Navigationshierarchie mit allen Produkten, die für das ausgewählte Projekt erstellt wurden. Sie können in der Produkthierarchie bestimmte Versionen und Builds auswählen.

  • Aktivieren der Codeanalyse
    Hier wird beschrieben, wie die Codeabdeckung mit Silk Central aktiviert werden kann.
  • Details (Seite)
    Hier werden die Codeabdeckungsinformationen zu den ausgewählten Produkten, Versionen und Builds auf Produkt-, Paket- und Klassenebene angezeigt.
  • Neueste Builds und Build-Versionen
    Hier wird beschrieben, wie Codeabdeckungsinformationen für die neusten verarbeiteten Builds und Versionen erhalten werden können.
  • Erzeugen von Berichten zur Auswirkung von Codeänderungen
    Erzeugen Sie Berichte zur Auswirkung von Codeänderungen, um alle Tests einzusehen, die bestimmte Klassen abdecken.
  • Klassen für Bericht auswählen (Dialog)
    Hier wird der Inhalt des Dialogs Klassen für Bericht auswählen beschrieben.
  • Anzeigen der Codeabdeckungsinformationen zu Paketen/Namensräumen
    In diesem Abschnitt wird beschrieben, wie die Codeabdeckungsinformationen zu Paketen/Namensräumen angezeigt werden.
Übergeordnetes Thema: Konfigurieren von Testumgebungen
Übergeordnetes Thema: Berichte


Aktivieren der Codeanalyse

Sie müssen Silk Central entsprechend konfigurieren, damit die Codeabdeckungsdaten der getesteten Anwendung erfasst werden. Sie können beliebig viele der in Testausführungen > Detailansicht > Testumgebung aufgeführten Testsuiten konfigurieren.
Tipp: Stellen Sie sicher, dass nur Codeanalyse-fähige Tests auf Ihre zu testende Anwendung zugreifen und dass nicht mehrere Tests gleichzeitig darauf zugreifen. Dadurch wird sichergestellt, dass die Codeanalysedaten korrekt sind und zu einem späteren Zeitpunkt einem bestimmten Test zugewiesen werden können.
  • Optionen für die Java-Codeanalyse
    Hier werden die Optionen für die Codeanalyse bei den unterstützten Java-Versionen beschrieben.
  • .NET Codeanalyse
    Hier wird die Konfiguration für die .NET Codeanalyse beschrieben.
  • Aktivieren der Codeanalyse für Testsuiten
    Aktivieren Sie die Codeanalyse für eine Testsuite zum Verfolgen des Testfortschritts.
Übergeordnetes Thema: Codeanalyse


Optionen für die Java-Codeanalyse

Zur Verwendung der Java-Codeanalyse für eine AUT müssen Sie die JVM der AUT mit einem Java Agent ausführen. Java Runtime Environment (JRE) Version 5 oder höher ist erforderlich. Die folgenden Optionen können bei allen unterstützten Java-Versionen verwendet werden:
Option
Beschreibung
port=19129
Optional: Port des Codeabdeckungsdienstes Wenn kein Port angegeben wird, wird Port 19129 verwendet.
coveragepath=[path1],[path2], ...
Pfade zu den .jar-Dateien werden vom Agenten abgedeckt. Wenn Teile eines Pfads Leerzeichen enthalten, müssen Sie Anführungszeichen verwenden. Zum Beispiel coveragepath="C:\Program Files\YourApplication\". Wenn ein Ordner angegeben wird, sucht der Agent rekursiv nach allen .class-Dateien in diesem Ordner. Wenn ein Ordner mit einem abschließenden Platzhalter angegeben wird, sucht der Agent nach .jar-Dateien in diesem Ordner. Das Ausführen des Agenten ohne Angabe eines Abdeckungspfads ist keine gültige Aktion.
java -javaagent:agent.jar=coveragepath=
"C:Program Files\YourApplication\" Aut.jar
includes=[package1]:[package2]:[package3]: ...
Optional: Nur Pakete, die mit diesen Paketen übereinstimmen, werden für die Abdeckung berücksichtigt. Platzhalter (*) sind für die Angabe der enthaltenen Pakete zulässig.
java -javaagent:agent.jar=includes=com.borland.* AUT.jar
excludes=[package1]:[package2]:[package3]: ...
Optional: Pakete, die in der Ausschlussoption angegeben werden, werden für die Codeabdeckung ignoriert. Platzhalter (*) sind für die Angabe der ausgeschlossenen Pakete zulässig.
java -javaagent:agent.jar=includes=com.borland.*;
excludes=com.borland.internal* AUT.jar
Anmerkung: Wenn sowohl Einschlüsse als auch Ausschlüsse in den Filtern angegeben sind, werden die Ausschlüsse zuerst ausgewertet. Wird eine Klasse über die Filter sowohl ein- als auch ausgeschlossen, wird diese Klasse ausgeschlossen, und es werden keine Abdeckungsdaten dafür generiert. Wenn die Filteroption nicht angegeben wird, werden Abdeckungsdaten für alle verwendeten Klassen generiert, es sei denn, die Abdeckungspfadoption wurde festgelegt. In diesem Fall werden Abdeckungsdaten für alle Klassen im Abdeckungspfad generiert.

Beispiel für Java-Codeanalyse

Beispiel für Windows:
"<java_home_directory>\bin\java" -javaagent:agent.jar=port=19129;
coveragepath=C:\dev\deploy\lib\library1.jar,C:\dev\deploy\lib\library2.jar;
includes=com.borland.*;excludes=com.borland.internal.* com.borland.MyApplication
Beispiel für Linux (mit Anführungszeichen):
"<java_home_directory>/bin/java" -javaagent:agent.jar="port=19129;
coveragepath=/tmp/dev/deploy/lib/library1.jar,/tmp/dev/deploy/lib/library2.jar;
includes=com.borland.*;excludes=com.borland.internal.*" com.borland.MyApplication
Übergeordnetes Thema: Aktivieren der Codeanalyse


.NET Codeanalyse

  • Installieren des Windows Codeanalyse-Systems und der DevPartner-Analysefunktionen
    Hier wird die Installation des Windows Codeanalyse-Systems und der DevPartner-Analysefunktionen beschrieben.
  • .NET Codeanalyse und manuelle Tests
    Hier werden die Schritte zur Verwendung der DevPartner Codeabdeckung beschrieben.
  • .NET Codeanalyse und automatisierte Tests
    Hier wird beschrieben, wie automatisierte Tests strukturiert werden.
  • Verwendung von DPAnalysis.exe
    Hier wird die Verwendung von dpanalysis.exe beschrieben.
Übergeordnetes Thema: Aktivieren der Codeanalyse


Installieren des Windows Codeanalyse-Systems und der DevPartner-Analysefunktionen

Bevor Sie diese Aufgabe ausführen können, stellen Sie sicher, dass Microsoft .NET Framework 3.5 auf dem Rechner installiert ist, auf dem das Codeanalyse-System installiert werden soll (der Rechner auf dem die zu testende Anwendung läuft). Ältere oder neuere Versionen von Microsoft .NET Framework funktionieren nicht!

  1. Gehen Sie zum Host-Rechner der zu testenden Anwendung.
  2. Öffnen Sie Silk Central.
  3. Gehen Sie zu Hilfe > Tools, und klicken Sie auf Windows Codeanalyse System. Eine Aufforderung zum Herunterladen von CAFramework.exe wird angezeigt. CAFramework.exe enthält die Installation für die Pakete Code Analysis Framework und DevPartner Analytics.
    Anmerkung: Testläufe des Codeanalyse-Systems von verschiedenen Ausführungsservern zur gleichen Zeit werden nicht unterstützt.
  4. Um die Installation zu starten, doppelklicken Sie auf die Download-Datei. Führen Sie die Installationsschritte des Windows Codeanalyse System aus. Zum Abschluss der Installation werden Sie aufgefordert, DevPartner Analytics zu installieren. Vergewissern Sie sich, dass das Kontrollkästchen DevPartner Analytics Installation im entsprechenden Installationsfenster aktiviert ist, und installieren Sie diese Komponente. Am Ende dieser Installation sind alle erforderlichen Dateien installiert, und der richtige Dienst wird gestartet. Der Name des Dienstes lautet Silk Central Code Analysis Service.
Übergeordnetes Thema: .NET Codeanalyse


.NET Codeanalyse und manuelle Tests

In den folgenden Abschnitten werden die erforderlichen Schritte zur Installation und Verwendung von DevPartner .NET Codeabdeckungskomponenten beschrieben, die mit Silk Central ausgeliefert werden. Das folgende Beispiel dient als Einführung für manuelle Tests und einen einzelnen AUT. Wenn Sie automatisierte Tests einsetzen möchten, sollten Sie zunächst die nachfolgenden Schritte gründlich lesen und anschließend das Thema .NET-Codeanalyse und automatisierte Tests.

Anmerkung: Um die Silk Central/.NET Codeabdeckungsfunktionen verwenden zu können, müssen die Micro Focus DevPartner Analytics Komponenten, Version 11.2 oder höher, verwendet werden.
Anmerkung: Für die .NET Codeanalyse ist es erforderlich, dass die PDB-Dateien, die während der Kompilierung der zu testenden .NET-Anwendung (AUT) generiert werden, im selben Verzeichnis abgelegt werden wie die auszuführenden Dateien des AUT. Sind die PDB für das AUT nicht verfügbar, kann die .NET-Codeanalysefunktion nicht genutzt werden.

Workflow für manuelle Tests

Ausführen von manuellen Tests
  1. Konfigurieren von DPAnalysis zum Starten des AUT
    Hier wird beschrieben, wie DPAnalysis konfiguriert werden muss, um Ihre AUT zu starten.
  2. Konfigurieren von Silk Central für die Codeanalyse
    Hier wird beschrieben, wie Silk Central für die Codeanalyse konfiguriert wird.
Übergeordnetes Thema: .NET Codeanalyse


Konfigurieren von DPAnalysis zum Starten des AUT

  1. Erzeugen Sie eine .BAT-Datei, die auf DPAnalysis.exe verweist. Ein Beispiel:
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe" /cov /USE_AUTOMATION_INTERFACE
/W "C:\Common\Development\MYAPP"
/P "C:\Common\Development\MYAPP\MyApp.exe"
  2. Zur besseren Lesbarkeit umfasst das Beispiel mehrere Zeilen. Ihre .BAT-Datei sollte sich in einer Zeile befinden. Nehmen Sie folgende Änderungen vor:
    1. Stellen Sie sicher, dass sich in der ersten Zeile der Installationspfad zu dpanalysis.exe befindet. Die beiden Schalter sind obligatorisch.
    2. Die zweite Zeile muss den Pfad zu Ihrer ausführbaren Datei und den PDBs enthalten.
    3. Die dritte Zeile enthält einen obligatorischen Schalter und muss den absoluten Pfad zu Ihrer Testanwendung sowie den Anwendungsnamen enthalten.
  3. Doppelklicken Sie auf die .BAT-Datei, damit DPAnalysis Ihre Anwendung startet.
Weitere Informationen zur Ausführung von DPAnalysis.exe finden Sie im Thema Verwendung von DPAnalysis.exe. Dieses Thema sowie verwandte Themen enthalten Informationen zu zusätzlichen Schaltern und zur Verwendung einer Konfigurationsdatei, sollten Sie mehrere Anwendungen testen.
Übergeordnetes Thema: .NET Codeanalyse und manuelle Tests
Nächstes Thema: Konfigurieren von Silk Central für die Codeanalyse
Zugehörige Konzepte
Verwendung von DPAnalysis.exe


Konfigurieren von Silk Central für die Codeanalyse

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Öffnen Sie eine vorhandene Testsuite, die einen manuellen Test mit Schritten zum Testen der Funktionen für Ihren AUT enthält.
  3. Klicken Sie auf die Registerkarte Testumgebung.
  4. Klicken Sie unter Einstellungen für die Codeanalyse auf Bearbeiten, um das Dialogfeld Einstellungen für die Codeanalyse bearbeiten anzuzeigen.
  5. Stellen Sie sicher, dass Codeanalyse aktivieren aktiviert ist.
  6. Wählen Sie aus der Liste Codeanalyse Profil DevPartner .NET-Codeanalyse.
  7. Geben Sie in das Feld Hostnamen den Hostnamen gefolgt von einem Doppelpunkt und der Portnummer ein. Zum Beispiel: localhost:19129

    Der standardmäßige Port für das Codeanalyse System lautet 19129. Sie können das Codeanalyse System so konfigurieren, dass es über einen gegebenen Port ausgeführt wird, indem Sie die folgende XML-Datei verwenden: <install dir>\Code Analysis\CodeAnalysisConfig.xml

  8. Klicken Sie auf OK.
  9. Führen Sie den Test aus, indem Sie im Bereich Testausführung auf Ausführen klicken.
  10. Vergewissern Sie sich, dass im Dialogfeld Ausführen Alle Tests aktiviert ist.
  11. Wählen Sie in Build für Testsuite setzen den richtigen Build für Ihre Testsuite aus.
  12. Klicken Sie auf OK.
Übergeordnetes Thema: .NET Codeanalyse und manuelle Tests
Vorheriges Thema: Konfigurieren von DPAnalysis zum Starten des AUT


.NET Codeanalyse und automatisierte Tests

In diesem Abschnitt werden zwei Szenarios beschrieben, die bei der Durchführung von Tests mit Codeabdeckung auftreten können. Außerdem werden geeignete Möglichkeiten zur Strukturierung von Tests innerhalb eines Ausführungsplans dargestellt. Die in den folgenden Abschnitten verwendeten Beispiele beziehen sich auf die Codeanalyse von DevPartner; bei anderen Codeanalysetools ist die Struktur jedoch ähnlich. Beispielsweise enthält Ihr Ausführungsplan andere Parameter zur Vor- und Nachbereitung.

Anmerkung: Zwischen dem Starten der AUT und dem Starten der Codeanalyse kann es Verzögerungen geben, wodurch evtl. Teile des Start-Codes der AUT nicht von der Codeanalyse aufgenommen werden.

Workflow für automatisierte Tests

  • Konfigurieren eines oder mehrerer Tests mit einer AUT
    Hier wird beschrieben, wie Sie Tests strukturieren, wenn Sie Szenarios mit einem oder mehreren Tests in einer einzigen Testsuite haben und eine zu testende Anwendung getestet werden soll.
  • Konfigurieren eines oder mehrerer Tests mit mehreren AUT
    Hier wird beschrieben, wie Sie Tests strukturieren, wenn Sie Szenarios mit einem oder mehreren Tests in einer einzigen Testsuite haben und mehrere zu testende Anwendungen getestet werden sollen.
Übergeordnetes Thema: .NET Codeanalyse
Zugehörige Tasks
Erstellen oder bearbeiten von ProcessExecutor-Tests


Konfigurieren eines oder mehrerer Tests mit einer AUT

Wenn Sie ein Szenario haben, bei dem Sie einen oder mehrere Tests in einer einzigen Testsuite haben und eine zu testende Anwendung getestet werden soll, können Sie Ihre Tests wie folgt strukturieren:

  1. Erstellen Sie einen ProcessExecutor-Test, der Ihre Codeanalyseanwendung startet. Die ProcessExecutor-Liste der Argumente sollte Ihr Codeanalyseprogramm starten. Ein Beispiel: start cmd /c start cmd /c D:\sctm\dps\startDPS_Simple1.bat, wobei startDPS_Simple1.bat Folgendes enthält:
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe"
/cov
/USE_AUTOMATION_INTERFACE
/O "D:\SCTM\temp"
/W "D:\SCTM\DPS\TESTAPP\SCTMCodeAnalysisTestApp\bin\Debug"
/P "D:\SCTM\DPS\TESTAPP\SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe"
  2. Erstellen Sie eine Testsuite.
  3. Klicken Sie auf Ausführungen > Detailansicht, wählen Sie eine Testsuite aus, und klicken Sie auf die Registerkarte Vorbereitung/Nachbereitung.
  4. Fügen Sie den zuvor erstellten Test als Vorbereitung hinzu.
  5. Fügen Sie einen Test zur Testsuite hinzu, der Ihre zu testende Anwendung anhand eines Testautomatisierungstools automatisiert.
  6. Optional: Fügen Sie der Testsuite einen weiteren Test hinzu, der Ihre zu testende Anwendung anhand eines Testautomatisierungstools automatisiert.
  7. Erstellen Sie einen ProcessExecutor-Test.
  8. Klicken Sie auf Ausführungen > Detailansicht, wählen Sie eine Testsuite aus, und klicken Sie auf die Registerkarte Vorbereitung/Nachbereitung.
  9. Fügen Sie den zuvor erstellten Test als Nachbereitung hinzu.
Die ProcessExecutor-Liste der Argumente sollte Ihr Programm schließen: start cmd /c taskkill /IM SCTMCodeAnalysisTestApp.exe.
Übergeordnetes Thema: .NET Codeanalyse und automatisierte Tests


Konfigurieren eines oder mehrerer Tests mit mehreren AUT

Wenn Sie ein Szenario haben, bei dem Sie einen oder mehrere Tests in einer einzigen Testsuite haben und mehrere AUT getestet werden sollen, können Sie Ihre Tests wie folgt strukturieren:

  1. Erstellen Sie einen ProcessExecutor-Test, der Ihre Codeanalyseanwendung startet. Die ProcessExecutor-Liste der Argumente sollte Ihr Codeanalyseprogramm starten. Ein Beispiel: start cmd /c start cmd /c D:\sctm\dps\two_app_dps.cmd, wobei two_app_dps.cmd Folgendes enthält:
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe"
/config D:\SCTM\DPS\configuration_file.xml
    und configuration_file.xml enthält Folgendes:
    <?xml version="1.0" ?>
<ProductConfiguration>
    <RuntimeAnalysis Type="Coverage" MaximumSessionDuration="1000" NoUIMsg="true" />
    <Targets RunInParallel="true">
        <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NM_USE_AUTOMATION_INTERFACE="1" >
            <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
            <Path>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
          SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe</Path>
            <Arguments></Arguments>
            <WorkingDirectory>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug</WorkingDirectory>
        </Process>
        <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" >
            <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
            <Path>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\
         QADSCTMMigration\bin\QADSCTMMigration.exe</Path>
            <Arguments></Arguments>
            <WorkingDirectory>D:\SourceCode\SVNQAD\Development\Development\
         SOURCECODE\QADSCTMMigration\bin</WorkingDirectory>
        </Process>
    </Targets>
</ProductConfiguration>
  2. Erstellen Sie eine Testsuite.
  3. Klicken Sie auf Ausführungen > Detailansicht, wählen Sie eine Testsuite aus, und klicken Sie auf die Registerkarte Vorbereitung/Nachbereitung.
  4. Fügen Sie den zuvor erstellten Test als Vorbereitung hinzu.
  5. Fügen Sie einen Test zur Testsuite hinzu, der Ihre erste zu testende Anwendung anhand eines Testautomatisierungstools automatisiert.
  6. Fügen Sie der Testsuite einen weiteren Test hinzu, der Ihre zweite zu testende Anwendung anhand eines Testautomatisierungstools automatisiert.
  7. Erstellen Sie einen ProcessExecutor-Test.
  8. Klicken Sie auf Ausführungen > Detailansicht, wählen Sie eine Testsuite aus, und klicken Sie auf die Registerkarte Vorbereitung/Nachbereitung.
  9. Fügen Sie den zuvor erstellten Test als Nachbereitung hinzu.
Die ProcessExecutor-Liste der Argumente sollte Ihre Programme schließen: start cmd /c taskkill /IM application1.exe /IM Application2.exe.
Übergeordnetes Thema: .NET Codeanalyse und automatisierte Tests


Verwendung von DPAnalysis.exe

DPAnalysis.exe ist die DevPartner Codeabdeckungsanwendung, die es Ihnen ermöglicht, .NET-Anwendungen zu profilieren. Die Anwendung wird unter Verwendung der Befehlszeile gestartet.

Sie können die Anwendung mit herkömmlichen Schaltern, so wie sie in diesen Themen dokumentiert sind, verwenden, oder Sie können zusätzliche Schalter hinzufügen, die auf eine Konfigurationsdatei verweisen. Bei einer außergewöhnlich langen Befehlszeile oder wenn Sie mehrere Anwendungen in einer einzigen Sitzung durchführen wollen, kann die Verwendung einer Konfigurationsdatei von Vorteil sein.

Der Schalter /USE_AUTOMATION_INTERFACE ist obligatorisch. Er veranlasst die benötigte automatische Schnittstellenumgebung für die Interaktion mit dem zu etablierenden System. Zudem wird die Lizenzprüfung dadurch umgangen. Dieser Schalter beansprucht keine Parameter.

  • DPAnalysis.exe von der Befehlszeile aus ausführen
    Hier wird beschrieben, wie dpanalysis.exe von der Befehlszeile aus ausgeführt werden kann.
Übergeordnetes Thema: .NET Codeanalyse


DPAnalysis.exe von der Befehlszeile aus ausführen

Die Installation DevPartner Studio Code Coverage enthält DPAnalysis.exe, ein in der Befehlszeile ausführbare Datei, die im Verzeichnis \Programme\Micro Focus\DevPartner Studio\Analysis\ installiert ist.

Verwenden Sie die folgende Syntax und die folgenden Schalter, um das Tool DevPartner Studio Code Coverage von der Befehlszeile aus auszuführen:

DPAnalysis  [/Cov] [/USE_AUTOMATION_INTERFACE] [/E|/D|/R]
[/W workingdirectory] [/PROJ_DIR] [/H hostmachine]
[/NOWAIT] [/NO_UI_MSG] [/N] [/F] [/A C:\temp1;C:\temp2]
[/NO_QUANTUM /NM_METHOD_GRANULARITY /EXCLUDE_SYSTEM_DLLS
/NM_ALLOW_INLINING /NO_OLEHOOKS /NM_TRACK_SYSTEM_OBJECTS]
{/P|/S} target [target arguments]

Beispiel

Sie können DPAnalysis.exe direkt von der Befehlszeile aus verwenden, indem Sie die Schalter zur Anleitung der Analysesitzung verwenden. Zum Beispiel startet die folgende Befehlszeile eine Codeabdeckungsitzung für die Anwendung: SCTMCodeAnalysisTestApp.exe.

dpanalysis.exe /cov /USE_AUTOMATION_INTERFACE /W "D:\SCTM\DPSCoverageIntegration\Test App\
SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\bin\Debug" /P
"D:\SCTM\DPSCoverageIntegration\Test App\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\bin
\Debug\SCTMCodeAnalysisTestApp.exe"
  • Parameter
    Hier wird der Befehlszeilen-Schalter für DPAnalysis beschrieben.
  • DPAnalysis-Konfigurationsdatei
    Hier wird die Konfigurationsdateioption für DPAnalysis beschrieben.
Übergeordnetes Thema: Verwendung von DPAnalysis.exe


Parameter

  • Analysearten-Schalter
    Hier werden die Analysearten-Schalter beschrieben.
  • Datensammlungs-Schalter
    Hier wird der Datensammlungs-Schalter für DPAnalysis beschrieben.
  • Andere Schalter
    Beschreibt andere optionale Schalter für DPAnalysis.exe.
  • Analyseoptionen
    Hier werden Analyseoptionen beschrieben.
  • Zielschalter
    Hier wird der Zielschalter für dpanalysis.exe beschrieben.
Übergeordnetes Thema: DPAnalysis.exe von der Befehlszeile aus ausführen


Analysearten-Schalter

Name | Beschreibung
/Cov[erage] | Stellt die Analysearten auf DevPartner Coverage-Analyse ein.
Anmerkung: DPAnalysis.exe instrumentiert keinen nicht verwalteten Code. Um Performance- oder Coverage-Analysedaten für eine nicht verwaltete Anwendung zu erfassen, müssen Sie zuerst die Anwendung instrumentieren.
Übergeordnetes Thema: Parameter


Datensammlungs-Schalter

Aktiviert oder deaktiviert die Datensammlung für ein gegebenes Ziel, doch startet das Ziel nicht. Optional.

Name | Beschreibung
/E[nable] | Aktiviert die Datensammlung für einen spezifizierten Prozess oder Dienst.
/D[isable] | Deaktiviert die Datensammlung für einen spezifizierten Prozess oder Dienst.
/R[epeat] | Profiling wird jederzeit auftreten, wenn Sie den spezifizierten Prozess ausführen, bis zu dem Punkt, an dem Sie den Schalter /D verwenden, um das Profiling zu deaktivieren.
Übergeordnetes Thema: Parameter


Andere Schalter

Diese Schalter sind optional.

Name | Beschreibung
/W[orkingDir] | Spezifizieren Sie das Arbeitsverzeichnis für den Zielprozess oder -dienst.
/PROJ_DIR | Spezifizieren Sie das Verzeichnis für das Projekt DevPartner Studio, welches zur Lokalisierung von Wiedergabelisten etc. verwendet wird.
/N[ewconsole] | Führen Sie den Prozess in einem separaten Befehlsfenster aus. Falls Sie DPAnalysis.exe zur Analyse der Konsolenanwendung verwenden, die eine Eingabe über die Tastatur erfordert, müssen Sie den Schalter /NewConsole verwenden, um ein Konsolenfenster zum Akzeptieren der Eingabe zu öffnen.
/INCLUSION_FILTER <filterFile>

Der Schalter /INCLUSION_FILTER ist optional, und ermöglicht die Spezifizierung einer Einschlussfilterdatei. Diese Datei wird verwendet, wenn die Abdeckungsdaten an das System im Silk Central-spezifischen XML-Format bereitgestellt werden. Es veranlasst das Berichtserstellungsprogramm alle Klassen herauszufiltern, die nicht in der Filterdatei spezifiziert wurden. Der Schalter verfügt, wie hier gezeigt, über einen einzelnen Parameter.

/INCLUSION_FILTER <filterFile>

Hier ist <filterFile> ein vollständig qualifizierter Pfad der Filterdatei, die für die Dauer des Programms genutzt wird.

Die untenstehende Beispieldatei Einschluss_Filter ist eine einfache XML-Datei, die eine Reihe an Klassen enthält, die im erstellten Bericht enthalten sein sollen. Weiterhin enthält sie den Wert <filterClasses>, welcher angibt, ob der Filter angewandt werden soll oder nicht.

<!--D:\Public\SCTM Work\ProdAPI_Tester_CSharp_LINES.dpcov-->
<inclusionInfo>
  <filterClasses>false</filterClasses>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_MsgStream</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_RecvTask</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_TimeStamp</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_Tracer</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CMsgRegisterClientReqMB</includedClass>
</inclusionInfo>
/A[ssembly_dir] | Nur für Abdeckungsanalysen. Eine Liste an Pfaden, die DLL/PDB-Dateien enthalten. Verwenden Sie diesen Schalter, um referenzierte, aber nicht geladene DLL/PDB-Dateien festzulegen, die in einer Abdeckungssitzungsdatei angezeigt werden sollen. Trennen Sie mehrere Pfade mit einem Semikolon (;).
Übergeordnetes Thema: Parameter


Analyseoptionen

Ein Beispiel für die Analyseoptionen ist:

<AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
Spalte | Typ
/NM_USE_AUTOMATION_INTERFACE | Ein benötigter Schalter im Abschnitt Analyseoption der Konfigurationsdatei. Der Wert muss "1" entsprechen.
/NO_QUANTUM | Deaktiviert Ausschluss der Zeit, die in anderen Threads verbracht wurde.
/NM_ALLOW_INLINING | Aktiviert Laufzeit-Instrumentierung von Inline-Methoden (nur Coverage und Performance).
/NO_OLEHOOKS | Deaktiviert Sammlung von COM.
Übergeordnetes Thema: Parameter


Zielschalter

Identifiziert entweder einen Prozess oder einen Dienst als das zu befolgende Ziel. Erforderlich. Wählen Sie nur eins. Alle Argumente, die einem Zielnamen oder -pfad folgen, werden zu Argumenten dieses Ziels.

Name | Beschreibung
/P[rocess] | Spezifizieren Sie einen Zielprozess (gefolgt von Argumenten für diesen Prozess)
/S[ervice] | Spezifizieren Sie einen Zieldienst (gefolgt von Argumenten für diesen Dienst)
/C[onfig] | Pfad zu Konfigurationsdatei
Übergeordnetes Thema: Parameter
Zugehörige Konzepte
DPAnalysis-Konfigurationsdatei


DPAnalysis-Konfigurationsdatei

Um Analysesitzungen mit einer XML-Konfigurationsdatei zu verwalten, lassen Sie DPAnalysis.exe aus der Befehlszeile mit dem /config-Schalter und einer richtig strukturierten XML-Konfigurationsdatei als dessen Ziel laufen. Zum Beispiel:

dpanalysis.exe /config c:\temp\configuration_file.xml

Indem Sie eine Konfigurationsdatei verwenden, können Sie mehrere Prozesse und Dienste profilieren und verwalten. Die Möglichkeit mehrere Prozesse zu profilieren, kann besonders zur Analyse von Webanwendungen nützlich sein.

Beispiel-Konfigurationsdatei

<?xml version="1.0" ?>
<ProductConfiguration>
  <RuntimeAnalysis Type="Coverage" MaximumSessionDuration="1000" NoUIMsg="true" />
     <Targets RunInParallel="true">
          <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NM_USE_AUTOMATION_INTERFACE="1" >
               <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
               <Path>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe</Path>
               <Arguments></Arguments>
               <WorkingDirectory>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug</WorkingDirectory>
          </Process>
          <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" >
               <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
               <Path>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\QADSCTMMigration\bin\QADSCTMMigration.exe</Path>
               <Arguments></Arguments>
               <WorkingDirectory>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\QADSCTMMigration\bin</WorkingDirectory>
          </Process>
     </Targets>
</ProductConfiguration>
  • AnalyseOptionen-Element
    Hier wird das AnalyseOptionen-Element für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • Argumente-Element
    Hier wird das Argumente-Element für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • Element BilderAusschließen
    Hier wird das Element BilderAusschließen für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • Host-Element
    Hier wird das Host-Element für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • Name-Element
    Hier wird das Name-Element für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • Pfadelement
    Hier wird das Pfadelement für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • Prozesselement
    Hier wird das Prozesselement für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • RuntimeAnalysis-Element
    Hier wird das runtimeanalysis-Element für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • Dienstelement
    Hier wird das Dienstelement für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • Zielelement
    Hier wird das Zielelement für die Konfigurationsdatei dpanalysis.exe beschrieben.
  • ArbeitsVerzeichnis-Element
    Hier wird das Element im ArbeitsVerzeichnis für die Konfigurationsdatei dpanalysis.exe beschrieben.
Übergeordnetes Thema: DPAnalysis.exe von der Befehlszeile aus ausführen


AnalyseOptionen-Element

Attribute, die mit AnalysisOptions arbeiten, unterscheiden sich abhängig von der Art der Analysesitzung, die Sie durchführen.

Anmerkung: DPAnalysis.exe ignoriert Attribute, die nicht zur Art der Analyse passen.
<AnalysisOptions
    SESSION_DIR = "c:\MyDir"
    SESSION_FILENAME = "myfile.dpcov"
    NM_METHOD_GRANULARITY = "1"
    EXCLUDE_SYSTEM_DLLS = "1"
    NM_ALLOW_INLINING = "1"
    NO_OLEHOOKS = "1"
    NM_TRACK_SYSTEM_OBJECTS = "1"
 NO_QUANTUM="1"
    NO_MACH5 = "1"
    FORCE_PROFILING = "1"
 ASSEMBLY_DIR = "C:\TEMP1;C:\TEMP2"
/>

SESSION_DIR

Optional. Verwenden Sie dies mit Coverage, Memory, Performance und Performance Expert. Legen Sie ein Verzeichnis zum Speichern der vom profilierten Ziel erstellten Sitzungsdatei fest. Ohne dieses Attribut wird die resultierende Sitzungsdatei im Benutzerverzeichnis Eigene Dokumente abgelegt. Wenn weder SESSION_DIR noch SESSION_FILENAME vorhanden ist, werden Sie am Ende der Sitzung von DPAnalysis.exe aufgefordert, den Speicherort anzugeben.

SESSION_FILENAME

Optional. Verwenden Sie dies mit Coverage, Memory, Performance und Performance Expert. Legen Sie einen Sitzungsnamen für die für dieses Ziel erstellte Sitzungsdatei fest. Ohne dieses Attribut erstellt DPAnalysis.exe einen eindeutigen Namen, indem der Bildname des Ziels mit einer Nummer kombiniert wird (z. B. iexplore1.dpprf). Wenn Sie einen Namen, aber kein Verzeichnis festlegen, wird die Datei im Benutzerverzeichnis Eigene Dokumente abgelegt. Wenn weder SESSION_FILENAME noch SESSION_DIR vorhanden ist, werden Sie am Ende der Sitzung von DPAnalysis.exe aufgefordert, den Speicherort anzugeben.

NM_METHOD_GRANULARITY

Optional. Verwenden Sie dies mit Performance, um die Granularität der Datensammlung auf Methodenebene festzulegen (standardmäßig wird die Zeilenebene verwendet). Legen Sie einen Wert 1 fest, um das Attribut einzurichten. Wenn Sie das Attribut weglassen, wird es deaktiviert.

EXCLUDE_SYSTEM_DLLS

Optional. Verwenden Sie dies mit Performance, um Systembilder auszuschließen. Legen Sie einen Wert 1 fest, um das Attribut einzurichten. Wenn Sie das Attribut weglassen, wird es deaktiviert.

NM_ALLOW_INLINING

Optional. Verwenden Sie dies mit Coverage und Performance, um die Ebene der Analysedetails festzulegen. Aktiviert die Laufzeit-Instrumentierung von Inline-Methoden. Das entspricht der Eigenschaft Instrumentieren von Inline-Funktionen. Legen Sie einen Wert 1 fest, um Inline-Funktionen zu instrumentieren. Lassen Sie das Attribut weg, um es zu deaktivieren.

NO_OLEHOOKS

Optional. Verwenden Sie dies mit Performance Analysis, um die Verfolgung von Systemobjekten zu aktivieren. Legen Sie einen Wert 1 fest, um das Attribut einzurichten. Wenn Sie das Attribut weglassen, wird es deaktiviert.

NM_TRACK_SYSTEM_OBJECTS

Optional. Verwenden Sie dies mit Memory Analysis, um System-Objektzuweisungen oder Objektzuweisungen von Dritten zu ignorieren, wenn zugewiesene Objekte verfolgt werden. Legen Sie einen Wert 1 fest, um das Attribut einzurichten. Wenn Sie das Attribut weglassen, wird es deaktiviert. Der Standardstatus (deaktiviert) ermöglicht Ihnen, Speicherzuweisungen anzusehen, die vorgenommen wurden, wenn die Anwendung System- oder andere nicht profilierte Ressourcen verwendet.

NO_QUANTUM

Optional. Verwenden Sie dies mit Performance und Performance Expert Analysis, um die Zeit auszuschließen, die für Threads oder andere laufende Anwendungen aufgewendet wurde. Legen Sie einen Wert 1 fest, um das Attribut einzurichten. Wenn Sie das Attribut weglassen, wird es deaktiviert.

FORCE_PROFILING

Optional. Verwenden Sie dies mit Performance und Coverage Analysis, um das Profiling von Anwendungen zu erzwingen, die ohne verwalteten Code oder DevPartner Native C/C++ Instrumentation geschrieben wurden. Legen Sie einen Wert 1 fest, um das Attribut einzurichten. Wenn Sie das Attribut weglassen, wird es deaktiviert.

ASSEMBLY_DIR

Optional. Verwenden Sie dies mit Coverage Analysis, um den bzw. die absoluten Pfad(e) festzulegen, die referenzierte, aber nicht geladene Assemblierungen enthalten, die in der Coverage-Sitzungsdatei angezeigt werden sollen. Trennen Sie mehrere Speicherorte mit einem Semikolon. Wenn Sie das Attribut weglassen, wird es deaktiviert.

Elementinformationen

Anzahl der gefundenen Elemente
0 oder 1 je Process oder Service.
Übergeordnete Elemente
Process, Service
Inhalt
Ohne

Anmerkungen

Optional. Legt Laufzeitattribute für den angegebenen Zielprozess oder -dienst fest. Die Attribute entsprechen DevPartner Coverage-, Memory- und Performance-Eigenschaften, die über das Fenster "Eigenschaften" in Visual Studio zugänglich sind.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung von AnalyseOptionen innerhalb eines Dienstes.

<Service CollectData="true">
  <AnalysisOptions NM_METHOD_GRANULARITY="1" EXCLUDE_SYSTEM_DLLS="1" NM_ALLOW_INLINING="1"
  NO_OLEHOOKS="1" ASSEMBLY_DIR="C:\TEMP">
</Service>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Argumente-Element

Syntax

<Arguments>/arg1 /arg2 /arg3</Arguments>

Attribute

Ohne

Elementinformationen

Anzahl der gefundenen Elemente
0 oder 1 je Process oder Service.
Übergeordnete Elemente
Process, Service
Inhalt
Ohne

Anmerkungen

Optional. Kein Standard wenn ausgelassen. Argumente die an den Zielprozess oder -dienst weitergegeben werden sollen.

Beispiel

Das folgende Beispiel verwendet Arguments innerhalb eines Process-Elements.

<Process CollectData="true">
 <Arguments>/arg1 /agr2 /arg3</Arguments>
</Process>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Element BilderAusschließen

Syntax

<ExcludeImages>
  <Image>ClassLibrary1.dll</Image>
  <Image>ClassLibrary2.dll</Image>
</ExcludeImages>

Attribute

Keine.

Elementinformationen

Anzahl der gefundenen Elemente
0 oder 1 je Process oder Service.
Übergeordnete Elemente
Process, Service
Inhalt
Image

Anmerkungen

Optional. Kein Standard wenn ausgelassen. Geben Sie eine Liste mit mindestens einem Bild (kein Maximalwert) ein. Diese wird beim Laden durch den Zielprozess oder -dienst nicht profiliert.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung von BilderAusschließen innerhalb eines Prozesselements. Beachten Sie, dass Bildelemente in BilderAusschließen enthalten sind.

<Process CollectData="true">
 <ExcludeImages>
   <Image>ClassLibrary1.dll</Image>
   <Image>ClassLibrary2.dll</Image>
 </ExcludeImages>
</Process>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Host-Element

Syntax

<Host>hostmachine</Host>

Attribute

Keine.

Elementinformationen

Anzahl der gefundenen Elemente
0 oder 1 je Process oder Service.
Übergeordnete Elemente
Process, Service.
Inhalt
Name des Host-Rechners.

Anmerkungen

Optional. Kein Standard wenn ausgelassen. Stellt den Host-Rechner auf den Zielprozess oder -dienst ein.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung eines Host innerhalb eines Service. Beachten Sie, dass das Beispiel das benötigte Name-Element enthält.

<Service CollectData="true">
  <Name>ServiceApp</Name>
  <Host>remotemachine</Host>
</Service>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Name-Element

Syntax

<Name>MyServiceName</Name>

Attribute

Keine.

Elementinformationen

Anzahl der gefundenen Elemente
1.
Übergeordnete Elemente
Service.
Inhalt
Dienstname.

Anmerkungen

Erforderlich. Der Name des Dienstes, so wie er beim Dienstkontrollmanager registriert wurde. Dies ist der gleiche Name, den Sie für den Befehl NET START des Systems verwenden würden.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung eines Name innerhalb eines Service.

<Service CollectData="true">
 <Name>ServiceApp</Name>
</Service>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Pfadelement

Syntax

<Path> c:\MyDir\target.exe </Path>

Attribute

Keine.

Elementinformationen

Anzahl der gefundenen Elemente
1.
Übergeordnete Elemente
Process.
Inhalt
Pfad zum Ausführbaren.

Anmerkungen

Erforderlich. Spezifizieren Sie einen voll qualifizierten oder relativen Pfad zum Ausführbaren. Sie können den ausführbaren Namen ohne den Pfad eingegeben, falls das Ausführbare im aktuellen Verzeichnis besteht.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung eines Pfads innerhalb eines Prozesselements.

<Process CollectData="true">
  <Path>ClientApp.exe</Path>
</Process>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Prozesselement

Syntax

<Process CollectData="true or false"
   Spawn="true or false"
      NoWaitForCompletion="true or false"
      NewConsole="true or false"
   RepeatInjection="true or false"> ...
</Process>

Attribute

Profiling wird jederzeit auftreten, wenn Sie den spezifizierten Prozess ausführen, bis zu dem Punkt, an dem Sie den Schalter /D verwenden, um das Profiling zu deaktivieren.

CollectData
Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Wahr gesetzt, wenn ausgelassen. Legt fest, ob Profiling für den Zielprozess aktiviert wird.
Erstellen
Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Wahr gesetzt, wenn ausgelassen. Legt fest, ob DPAnalysis.exe das festgelegte Ziel erstellen wird. Für aspnet_wp.exe oder w3wp.exe den Wert nicht auf Wahr setzen. DevPartner kann den Arbeitsprozess ASP.NET nicht direkt erstellen. Starten Sie den Arbeitsprozess ASP.NET, indem Sie die Zielwebseite öffnen.
NoWaitForCompletion
Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Falsch gesetzt, wenn ausgelassen. Standardmäßig wird gewartet, bis der Prozess abgeschlossen ist. Falls der Wert auf Wahr gestellt ist, wird DPAnalysis.exe veranlasst, zu warten, bis das Ziel mit der Ausführung begonnen hat. DPAnalysis.exe wird nicht auf Prozesse auf Remote-Rechnern warten (unter Verwendung des Host-Elements). Das MaximumSessionDuration-Attribut im RuntimeAnalysis-Element überschreibt NoWaitForCompletion.
NewConsole

Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Falsch gesetzt, wenn ausgelassen. Veranlasst DPAnalysis.exe das Ziel in seinem eigenen Konsolenfenster auszuführen. Standardmäßig wird das gleiche Fenster verwendet, in das Sie die Befehlszeile DPAnalysis.exe eingegeben haben. Falls Sie DPAnalysis.exe zur Analyse der Konsolenanwendung verwenden, die eine Eingabe über die Tastatur erfordert, müssen Sie den /NewConsole-Schalter verwenden, um ein Konsolenfenster zum Akzeptieren der Eingabe zu öffnen.

RepeatInjection
Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Falsch gesetzt, wenn ausgelassen. Dies veranlasst DPAnalysis.exe dazu, das Ziel jedes Mal zu profilieren, bis Sie das Attribut ausdrücklich auf Falsch setzen.

Elementinformationen

Anzahl der gefundenen Elemente
1 oder mehr
Übergeordnete Elemente
Target.
Inhalt
Analyseoptionen, Pfad, Argumenten, Arbeitsverzeichnis, BilderAuschließen.

Anmerkungen

Legt einen ausführbares Ziel fest.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung von Prozessen und unter Einschluss von Tags wie AnalyseOptionen, Pfad, Argumenten und ArbeitsVerzeichnis.

<Targets RunInParallel="true">
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NewConsole="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>ClientApp.exe</Path>
    <Arguments>/arg1 /agr2 /arg3</Arguments>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
</Targets>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


RuntimeAnalysis-Element

Syntax

<RuntimeAnalysis Type="Coverage" NoUIMsg="false"
NM_INCLUSION_FILTER="Q:\AppDir\InclusionFilter.xml">

Attribute

Typ
Erforderlich: Auswahlmöglichkeiten: Performance; Coverage; Memory; oder Expert. Gibt die Analysetypen für alle aufgelisteten Ziele an.
MaximumSessionDuration

Optional: Wenn keine Angabe, wird kein Standardwert verwendet. Wenn angegeben, begrenzt DPAnalysis.exe den Sitzungsdurchlauf auf den angegebenen Zeitraum. Wenn Sie zum Beispiel MaximiumSessionDuration="60" angeben und dann das Profiling eines Dienstes starten (wobei RestartAtEndOfRun="true" für den Dienst steht), hält DPAnalysis.exe nach 60 Sekunden den Dienst an und startet ihn neu.

NoUIMsg

Optional: wenn ausgelassen, falsch wird standardmäßig verwendet. Wenn auf true festgelegt, unterdrückt DPAnalysis.exe alle UI-Fehlermeldungen, die während der Sitzung auftreten könnten. Dieser Wert sollte auf true festgelegt werden, wenn Sitzungen unbeaufsichtigt ausgeführt werden oder wenn eine große Anzahl aufeinander folgender Tests ausgeführt werden.

NM_INCLUSION_FILTER

Optional: Ermöglicht die Spezifizierung einer Einschlussfilterdatei. Diese Datei wird verwendet, wenn die Abdeckungsdaten an das System im Silk Central-spezifischen XML-Format bereitgestellt werden. Es veranlasst das Berichtserstellungsprogramm alle Klassen herauszufiltern, die nicht in der Filterdatei spezifiziert wurden. Der Schalter verfügt über einen einzelnen Parameter.

Elementinformationen

Anzahl der gefundenen Elemente
1.
Übergeordnete Elemente
ProductConfiguration.
Inhalt
Keine.

Anmerkungen

Erforderlich. Legt den Analysetyp und die maximale Sitzungsdauer fest.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung von RuntimeAnalysis mit einem ProductConfiguration-Tag. In diesem Beispiel legt das Attribut Typ eine Leistungsanalyse mit einer maximalen Dauer von 1000 Sekunden und UI-Fehlermeldungsunterdrückung fest.

<?xml version="1.0" ?>
<ProductConfiguration xmlns="http://www.microfocus.com/products">
<RuntimeAnalysis Type="Performance" MaximumSessionDuration="1000" NoUIMsg="true"/>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Dienstelement

Syntax

<Service
      CollectData = "true or false"
      Start = "true or false"
      RestartIfRunning = "true or false"
      RestartAtEndOfRun = "true or false"
      RepeatInjection = "true or false"
      >
      ...
</Service>

Attribute

CollectData
Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Wahr gesetzt, wenn ausgelassen. Legt fest, ob Profiling für den Zieldienst aktiviert wird.
Start

Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Wahr gesetzt, wenn ausgelassen. Legt fest, ob DPAnalysis.exe das festgelegte Ziel starten wird. Wenn es auf Falsch gesetzt ist, wird Profiling für dieses Ziel aktiviert, doch es wird nicht gestartet werden; Profiling wird das nächste Mal, wenn der Dienst gestartet wird, starten (gleichgültig der Mittel).

RestartIfRunning

Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Falsch gesetzt, wenn ausgelassen. Wenn Sie RestartIfRunning auf Wahr einstellen, wird DPAnalysis.exe versuchen, den spezifischen Dienst neu zu starten, wenn es auf dem Host-Computer läuft.

RestartAtEndOfRun
Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Falsch gesetzt, wenn ausgelassen. Wenn Sie Wahr festlegen, wird DPAnalysis.exe versuchen, den Dienst nach Ablauf des Laufs neu zu starten (unter Erstellung einer Sitzungsdatei). Wenn der Dienst der einzige Prozess ist, der profiliert werden soll, stellen Sie dieses Attribut auf Falsch.
RepeatInjection
Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Falsch gesetzt, wenn ausgelassen. Dies veranlasst DPAnalysis.exe dazu, das Ziel jedes Mal zu profilieren, bis Sie das Attribut ausdrücklich auf Falsch setzen.

Elementinformationen

Anzahl der gefundenen Elemente
Die Konfigurationsdatei muss wenigstens 1 Process oder 1 Service Element enthalten.
Übergeordnete Elemente
Targets.
Inhalt
AnalyseOptionen, Pfad, Argumente, Arbeitsverzeichnis, BilderAuschließen, Name, Host.

Anmerkungen

Legt einen Zieldienst fest.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung eines Dienstes innerhalb eines Zielelements.

<Targets RunInParallel="true">
  <Service CollectData="true" Start="true" RestartIfRunning="true" RestartAtEndOfRun="true">
  <Name>ServiceApp</Name>
  </Service>
</Targets>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Zielelement

Syntax

<Targets RunInParallel="true or false">   ...
</Targets>

Attribute

RunInParallel

Optional. Spezifizieren Sie Wahr oder Falsch. Wird standardmäßig auf Wahr gesetzt, wenn ausgelassen. Wenn Sie mehr als ein Ziel spezifizieren, wird festgelegt, wie die Ziele ausgeführt werden. Wenn RunInParallel Wahr ist, startet DPAnalysis die Zielprozesse und -dienste einem nach dem anderen; mehrere Ziele werden zur gleichen Zeit ausgeführt (parallel). Andererseits startet DPAnalysis das Ziel N + 1 nur nachdem der Prozess N gestartet und verlassen wurde; Ziele laufen eines nach dem anderen (seriell).

Elementinformationen

Anzahl der gefundenen Elemente
1.
Übergeordnete Elemente
RuntimeAnalysis.
Inhalt
Prozess, Dienst.

Anmerkungen

Erforderlich. Startet einen Block von einem oder mehr <Process> oder <Service>-Einträgen. Zielprozesse und -dienste werden entsprechend der Auflistung in der Konfigurationsdatei gestartet.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung von Zielen zur Spezifizierung von einem <Dienst> und zwei <Prozess> Elementen. Beachten Sie das RunInParallel Wahr ist, sodass die Ziele für dieses Beispiel parallel laufen würden.

<Targets RunInParallel="true">
  <Service CollectData="true" Start="true">
    <AnalysisOptions NM_METHOD_GRANULARITY="0" EXCLUDE_SYSTEM_DLLS="1" />
                <Name>ServiceApp</Name>
                <Host>remotemachine</Host>
  </Service>
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>ClientApp.exe</Path>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>TestApp02.exe</Path>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
</Targets>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


ArbeitsVerzeichnis-Element

Syntax

<WorkingDirectory> c:\MyWorkingDir </WorkingDirectory>

Attribute

Keine.

Elementinformationen

Anzahl der gefundenen Elemente
1 pro Process oder Service.
Übergeordnete Elemente
Process, Service.
Inhalt
Pfad zum Zielverzeichnis.

Anmerkungen

Optional. Kein Standard wenn ausgelassen. Geben Sie das Arbeitsverzeichnis für den Zielprozess oder -dienst an.

Beispiel

Das folgende Beispiel zeigt eine Konstruktion unter Verwendung des ArbeitsVerzeichnisses innerhalb eines übergeordneten Prozesselements.

<Process CollectData="true">
<WorkingDirectory>c:\temp</WorkingDirectory>
</Process>
Übergeordnetes Thema: DPAnalysis-Konfigurationsdatei


Aktivieren der Codeanalyse für Testsuiten

So aktivieren Sie die Codeanalyse für eine Testsuite:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite in der Testsuitehierarchie aus.
  3. Klicken Sie auf die Registerkarte Testumgebung.
  4. Klicken Sie im Abschnitt Einstellungen für die Codeanalyse auf der Seite Testumgebung auf Bearbeiten. Der Dialog Einstellungen für die Codeanalyse bearbeiten wird angezeigt.
  5. Aktivieren Sie das Kontrollkästchen Codeanalyse aktivieren.
  6. Wählen Sie ein Profil aus der Liste Codeanalyse Profil aus.
  7. Geben Sie in das Feld Hostnamen die Hostnamen der Systeme ein (jeweils durch ein Komma getrennt), von denen die Codeanalyseinformationen erfasst werden sollen. Geben Sie auch den Port ein, wenn Sie nicht den Standardport 19129 verwenden möchten.

    Beispiel: Laborcomputer1, Laborcomputer2:8000, 198.68.0.1. Sie müssen bei jeder Testsuite die Hostnamen der Computer angeben, auf denen die zu testende Anwendung ausgeführt wird. So müssen z. B. bei einer Client/Server-Anwendung nicht nur die Codeabdeckungsinformationen des Clients (der möglicherweise direkt auf einem Anwendungsserver ausgeführt wird), sondern auch die des Servers (der wahrscheinlich auf einem anderen Computer läuft) erfasst werden. Dies gilt auch für mehrschichtige Anwendungen.

    Anmerkung: Bei der JUnit-Codeanalyse braucht kein Hostname eingegeben zu werden.
  8. Klicken Sie auf OK, um die Einstellungen zu speichern.
Anmerkung: Wenn die Codeanalyse für eine Testsuite aktiviert wird, werden bei allen nachfolgenden Ausführungen dieser Suite Codeabdeckungsinformationen von den angegebenen Hosts abgerufen. Bei der Überwachung einer Testausführung auf der Seite Aktivitäten von Silk Central ist zu sehen, dass vor den Testläufen zuerst die Quellen für die Tests und danach die vollständigen Codeabdeckungsinformationen erfasst werden. In jeden Silk Central-Ausführungsserver ist eine Controllerkomponente integriert, die während der Testausführung sämtliche angegebenen Hosts steuert. Für jede Test in der Testsuite startet und stoppt diese Komponente die zugeordneten Instanzen, erfasst die XML-basierten Codeabdeckungsdateien für die Tests und führt die Ergebnisse in einer einzigen Datei zusammen. Danach wird die zusammengeführte Codeabdeckungsdatei im Ausführungsergebnis gespeichert.
Übergeordnetes Thema: Aktivieren der Codeanalyse
Zugehörige Verweise
Testumgebung (Seite)


Details (Seite)

Berichte > Codeanalyse > Details

Auf der Seite Details werden die Codeabdeckungsinformationen zu den ausgewählten Produkten, Versionen und Builds auf Produkt-, Paket- und Klassenebene angezeigt.

In der Produkt-Ansicht werden die abgedeckten und nicht abgedeckten Pakete bestimmter Produkte und Produkt-Builds angezeigt. Wenn Sie in der Produkt-Ansicht auf einen Paketnamen klicken, werden die Codeabdeckungsinformationen zu den Klassen in diesem Paket angezeigt.

Die folgenden Attribute werden für das ausgewählte Produkt in der Produkt-Ansicht angezeigt:

Attribut | Beschreibung
Name | Produktname
Anweisungen | Gesamtzahl der Anweisungen
Pakete/Namensräume Histogrammansicht mit folgenden Abbildungen:
  • Prozentualer Anteil der abgedeckten Pakete/Namensräume
  • Anzahl der abgedeckten Pakete/Namensräume (in Grün)
  • Anzahl der nicht abgedeckten Pakete/Namensräume (in Rot)
Klassen Histogrammansicht mit folgenden Abbildungen:
  • Prozentualer Anteil der abgedeckten Klassen
  • Anzahl der abgedeckten Klassen (in Grün)
  • Anzahl der nicht abgedeckten Klassen (in Rot)
Methoden Histogrammansicht mit folgenden Abbildungen:
  • Prozentualer Anteil der abgedeckten Methoden
  • Anzahl der abgedeckten Methoden (in Grün)
  • Anzahl der nicht abgedeckten Methoden (in Rot)

In der Paket-Ansicht werden die abgedeckten und nicht abgedeckten Klassen bestimmter Produkte und Produkt-Builds angezeigt. Wenn Sie in der Paket-Ansicht auf einen Klassennamen klicken, werden die Codeabdeckungsinformationen zu den Methoden in dieser Klasse angezeigt.

Die folgenden Attribute werden für die Pakete des ausgewählten Produkts in mehreren Zeilen der Paket-Ansicht angezeigt:

Attribut | Beschreibung
Paket | Paketname
Anweisungen | Gesamtzahl der Anweisungen
Klassen Histogrammansicht mit folgenden Abbildungen:
  • Prozentualer Anteil der abgedeckten Klassen
  • Anzahl der abgedeckten Klassen (in Grün)
  • Anzahl der nicht abgedeckten Klassen (in Rot)
Methoden Histogrammansicht mit folgenden Abbildungen:
  • Prozentualer Anteil der abgedeckten Methoden
  • Anzahl der abgedeckten Methoden (in Grün)
  • Anzahl der nicht abgedeckten Methoden (in Rot)

In der Klassen-Ansicht werden die abgedeckten und nicht abgedeckten Methoden bestimmter Produkte und Produkt-Builds angezeigt.

Die folgenden Attribute werden für die einzelnen Methoden in mehreren Zeilen der Klassen-Ansicht angezeigt:

Attribut | Beschreibung
Name | Methodenname
Signatur | Methodensignatur
Anweisungen | Gesamtzahl der Anweisungen
Abgedeckt Abdeckungsstatus der Methode:
  • True bedeutet, dass die Methode abgedeckt ist.
  • False bedeutet, dass die Methode nicht abgedeckt ist.
Anmerkung: Wenn die Seite mehr Elemente enthält, als gleichzeitig ohne Verschlechterung der Reaktionszeit angezeigt werden können, werden die Elemente stufenweise angezeigt. Verwenden Sie die Navigationsleiste unten auf der Seite, um die Elemente zu durchsuchen.
Übergeordnetes Thema: Codeanalyse


Neueste Builds und Build-Versionen

Wenn Sie ein Produkt in der Navigationshierarchie auswählen, wird automatisch die Liste der Pakete und Klassen mit Abdeckungsinformationen zur zuletzt verarbeiteten Version (d. h. zum zuletzt verarbeiteten Build der Version) angezeigt. Wenn Sie eine Produktversion in der Navigationshierarchie auswählen, werden automatisch die Abdeckungsinformationen des zuletzt verarbeiteten Builds der Version angezeigt.

Anmerkung: Wenn Sie mehrere Anwendungen gegen das gleiche Build laufen lassen, wird die Abdeckung von allen Anwendungen zusammengefügt werden.
Anmerkung: Die Build-übergreifende Codeanalyse wird aktuell nicht von Silk Central unterstützt.
Übergeordnetes Thema: Codeanalyse


Erzeugen von Berichten zur Auswirkung von Codeänderungen

So erzeugen Sie einen Bericht zur Auswirkung von Codeänderungen:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt aus, dessen Codeabdeckungsdaten Sie analysieren möchten.
  3. Klicken Sie im Menü auf Berichte > Codeanalyse.
  4. Klicken Sie auf Bericht zur Auswirkung von Codeänderungen erstellen. Das Dialogfeld Klassen für Bericht auswählen wird angezeigt.
  5. Wählen Sie im Dialogfeld ein Produkt und eine Version aus, wenn Sie die vorgeschlagenen Werte nicht verwenden möchten.
  6. Geben Sie im Feld Filter die Filterkriterien für die Pakete/Namensräume ein. Wenn Sie beispielsweise published eingeben, werden nur die Pakete/Namensräume mit der Zeichenfolge published im Namen angezeigt.
  7. Wählen Sie ein Paket aus der Liste Pakete/Namensräume aus. Mit Strg + Klick bzw. Umschalt + Klick können Sie mehrere Pakete/Namensräume auswählen. Die im ausgewählten Paket/Namensraum verfügbaren Klassen werden in der Liste Klassen angezeigt.
  8. Wählen Sie in der Liste Klassen die Klasse aus, die Sie als Datenquelle für den Bericht verwenden möchten. Mit Strg + Klick bzw. Umschalt + Klick können Sie mehrere Klassen auswählen.
  9. Klicken Sie auf Hinzufügen. Die ausgewählten Klassen werden daraufhin der Liste Ausgewählte Klassen hinzugefügt.
  10. Wiederholen Sie diese Schritte, bis Sie der Liste Ausgewählte Klassen alle erforderlichen Klassen hinzugefügt haben. Sie können Klassen aus der Liste Ausgewählte Klassen entfernen, indem Sie die Einträge auswählen und auf Entfernen klicken, oder indem Sie auf Alle entfernen klicken.
  11. Wählen Sie in der Liste Bericht auswählen einen Bericht aus.
  12. Klicken Sie auf OK, um den Bericht anzuzeigen.
Übergeordnetes Thema: Codeanalyse
Zugehörige Konzepte
Berichte zur Auswirkung von Codeänderungen
Zugehörige Verweise
Klassen für Bericht auswählen (Dialog)


Klassen für Bericht auswählen (Dialog)

Berichte > Codeanalyse > Bericht zur Auswirkung von Codeänderungen erstellen

Im Dialog Klassen für Bericht auswählen können Sie Klassendateien als Quellen für Berichte zur Auswirkung von Codeänderungen auswählen. Der Dialog enthält die folgenden Elemente:

Element | Beschreibung
Produkt | Name des Produkts, für das Codeanalyseinformationen benötigt werden.
Version | Die Produktversion, für die Codeanalyseinformationen benötigt werden.
Filter | Hier können Kriterien zum Filtern der Pakete angegeben werden. Wenn Sie beispielsweise "published" eingeben, werden im Bericht zur Auswirkung von Codeänderungen nur die Pakete mit dieser Zeichenfolge im Namen angezeigt.
Pakete/Namensräume | Die Produkt-Pakete/Namensräume, die in der ausgewählten Version angegeben sind und abgedeckt werden sollen.
Klassen | Alle im ausgewählten Paket enthaltenen Klassen.
Hinzufügen | Mit dieser Schaltfläche können die ausgewählten Klassen zur Codeabdeckungsanalyse hinzugefügt werden.
Ausgewählte Klassen | Zeigt die Klassen an, die bereits für die Codeabdeckungsanalyse ausgewählt sind.
Entfernen | Entfernt die ausgewählten Klassen aus der Liste Ausgewählte Klassen.
Alles entfernen | Entfernt alle Klassen aus der Liste Ausgewählte Klassen.
Bericht auswählen | Art des Berichts zur Auswirkung von Codeänderungen.
Übergeordnetes Thema: Codeanalyse


Anzeigen der Codeabdeckungsinformationen zu Paketen/Namensräumen

So zeigen Sie die Codeabdeckungsinformationen zu Paketen/Namensräumen an:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie das Projekt aus, dessen Codeabdeckungsinformationen angezeigt werden sollen.
  3. Klicken Sie im Menü auf Berichte > Codeanalyse.
  4. Erweitern Sie in der Hierarchieansicht in der Codeanalyse-Hierarchie den Projektknoten, damit die verfügbaren Produkte zu sehen sind.
  5. Erweitern Sie einen Produktknoten, damit die verfügbaren Versionen angezeigt werden.
  6. Erweitern Sie einen Versionsknoten, damit die verfügbaren Builds angezeigt werden.
  7. Wählen Sie das gewünschte Build aus. Die Codeabdeckungsinformationen des ausgewählten Builds werden nun auf der Seite Details angezeigt.
Anmerkung: Wenn die Codeabdeckungsinformationen zu allen Produkten angezeigt werden sollen, klicken Sie in der Hauptsymbolleiste auf Alle Produkte anzeigen. Die Produkte der anderen Projekte werden unter dem Knoten Andere Projekte angezeigt.
Übergeordnetes Thema: Codeanalyse
Zugehörige Verweise
Details (Seite)


Hinzufügen eines Silk Test Classic-AUT-Hosts

Sie können Testsuiten mit Silk Test Classic-Tests so konfigurieren, dass sich der Silk Test Classic-Agent auf einem anderen Computer als dem Ausführungsserver befindet. Geben Sie in diesem Fall den Ausführungsort für den Silk Test Classic-Agent, den Hostnamen des Computers mit dem Silk Test Classic-AUT an.

So fügen Sie der ausgewählten Testsuite einen Silk Test Classic-AUT-Host hinzu oder bearbeiten diesen:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite aus, der Sie den Silk Test Classic-AUT-Host hinzufügen möchten.
  3. Klicken Sie auf die Registerkarte Testumgebung.
  4. Klicken Sie im Abschnitt Silk Test Classic-AUT-Hostname auf Bearbeiten. Der Dialog SilkTest AUT-Hostname bearbeiten wird angezeigt.
  5. Geben Sie in das Textfeld Hostname den Namen des Computers ein, auf dem der Silk Test Classic-Agent ausgeführt wird. Die richtige Konfiguration der Optionsdateien ist erforderlich. Informationen zur Befehlszeilenoption -m finden Sie in der Dokumentation zu Silk Test Classic.
  6. Klicken Sie auf OK, um den Silk Test Classic-AUT-Host der ausgewählten Testsuite hinzuzufügen.
Übergeordnetes Thema: Konfigurieren von Testumgebungen
Übergeordnetes Thema: Silk Test Classic-Tests
Zugehörige Konzepte
Angeben des Agenten für den Test (AUT)


Konfigurieren von Abhängigkeiten zwischen Testsuiten

Durch eine Abhängigkeit können Sie festlegen, dass eine Testsuite automatisch ausgeführt wird, wenn das Ausführungsergebnis einer anderen Testsuite einen bestimmten Status aufweist. Beispielsweise: "Wenn Testsuite A fehlschlägt, dann Testsuite B automatisch ausführen".

  • Hinzufügen abhängiger Testsuiten
    Fügen Sie abhängige Testsuiten hinzu, um die Testsuite basierend auf den Ergebnissen einer anderen Testsuite auszuführen.
  • Bearbeiten von Abhängigkeiten
    Bearbeiten Sie Abhängigkeiten, um die abhängige Testsuite von einer anderen Bedingung abhängig zu machen oder die Testumgebung der abhängigen Testsuite zu ändern.
  • Löschen von Abhängigkeiten
    Löschen Sie Abhängigkeiten, wenn die abhängige Testsuite nicht länger auf Basis der auslösenden Testsuite ausgeführt werden soll.
  • Abhängigkeiten (Seite)
    Hier werden die abhängigen und auslösenden Testsuiten der ausgewählten Testsuite angezeigt.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten


Hinzufügen abhängiger Testsuiten

So fügen Sie eine abhängige Testsuite hinzu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite aus, die als auslösende Testsuite dienen soll.
  3. Klicken Sie auf die Registerkarte Abhängigkeiten.
  4. Klicken Sie auf Abhängige Testsuite hinzufügen. Das Dialogfeld Abhängige Testsuite hinzufügen wird angezeigt.
  5. Wählen Sie in der Liste Bedingung die Bedingung aus, die zum Auslösen der abhängigen Testsuite führen soll.
    • Alle
    • Bestanden
    • Fehlgeschlagen
    • Nicht ausgeführt
    Wenn Sie Beliebig auswählen, wird die abhängige Testsuite unabhängig vom Status immer ausgelöst.
  6. Wählen Sie aus der Hierarchie Testsuites eine Testsuite aus.
  7. Legen Sie fest, wo die abhängige Testsuite ausgeführt wird.
    Option
    Beschreibung
    Wie in der abhängigen Testsuite festgelegt
    Die der abhängigen Testsuite zugeordneten automatisierten Tests werden auf dem Ausführungsserver ausgeführt, der für die abhängige Testsuite auf der Seite Testumgebung festgelegt wird. Die zugeordneten manuellen Tests werden den Benutzern zugewiesen, die für die abhängige Testsuite auf der Seite Testumgebung festgelegt werden.
    Ebenso wie bei den Ausführungsservern der ausgewählten Testsuite:
    Die der abhängigen Testsuite zugeordneten automatisierten Tests werden auf dem Ausführungsserver ausgeführt, der für die auslösende Testsuite auf der Seite Testumgebung festgelegt wird. Die zugeordneten manuellen Tests werden den Benutzern zugewiesen, die für die auslösende Testsuite auf der Seite Testumgebung festgelegt werden.
    Bestimmter: Ausführungsserver/Manueller Tester
    Wählen Sie in den Listenfeldern einen vorkonfigurierten Ausführungsserver und/oder einen manuellen Tester aus. Die der abhängigen Testsuite zugeordneten automatisierten Tests werden dann auf dem ausgewählten Ausführungsserver ausgeführt. Die der abhängigen Testsuite zugeordneten manuellen Tests werden dem ausgewählten manuellen Tester zugewiesen. Wenn Sie lediglich einen manuellen Tester und keinen Server auswählen, werden nur manuelle Tests ausgeführt. Wenn Sie lediglich einen Server und keinen manuellen Tester auswählen, werden nur automatisierte Tests ausgeführt.
  8. Klicken Sie auf OK, um die Abhängigkeit zu erstellen.
    Anmerkung: In Silk Central können keine gegenseitigen Abhängigkeiten zwischen Testsuiten erstellt werden. Sie können Bedingungen auswählen, die manuelle Tests erfüllen müssen. Wenn beispielsweise die ausgewählte Bedingung Fehlgeschlagen lautet und alle manuellen Tests bestanden wurden, aber einige automatisierte Tests fehlgeschlagen sind, werden nur die der abhängigen Testsuite zugeordneten automatisierten Tests ausgeführt.
Übergeordnetes Thema: Konfigurieren von Abhängigkeiten zwischen Testsuiten


Bearbeiten von Abhängigkeiten

Anmerkung: Um eine vorhandene Abhängigkeit zu bearbeiten, müssen Sie die auslösende Testsuite, in der eine bestimmte Bedingung zur Ausführung einer abhängigen Testsuite führt, auswählen. Sie können die Abhängigkeitseinstellungen nicht von der abhängigen Testsuite aus bearbeiten.

So bearbeiten Sie eine Abhängigkeit:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Abhängigkeiten.
  4. Klicken Sie im Bereich Abhängige Testsuite in der Spalte Aktionen der abhängigen Testsuite auf Einstellungen bearbeiten. Das Dialogfeld Abhängigkeit bearbeiten wird angezeigt.
  5. Wählen Sie in der Liste Bedingung die Bedingung aus, die zum Auslösen der abhängigen Testsuite führen soll.
    • Alle
    • Bestanden
    • Fehlgeschlagen
    • Nicht ausgeführt
    Wenn Sie Beliebig auswählen, wird die abhängige Testsuite unabhängig vom Status immer ausgelöst.
  6. Legen Sie fest, wo die abhängige Testsuite ausgeführt wird.
    Option
    Beschreibung
    Wie in der abhängigen Testsuite festgelegt
    Die der abhängigen Testsuite zugeordneten automatisierten Tests werden auf dem Ausführungsserver ausgeführt, der für die abhängige Testsuite auf der Seite Testumgebung festgelegt wird. Die zugeordneten manuellen Tests werden den Benutzern zugewiesen, die für die abhängige Testsuite auf der Seite Testumgebung festgelegt werden.
    Ebenso wie bei den Ausführungsservern der ausgewählten Testsuite:
    Die der abhängigen Testsuite zugeordneten automatisierten Tests werden auf dem Ausführungsserver ausgeführt, der für die auslösende Testsuite auf der Seite Testumgebung festgelegt wird. Die zugeordneten manuellen Tests werden den Benutzern zugewiesen, die für die auslösende Testsuite auf der Seite Testumgebung festgelegt werden.
    Bestimmter: Ausführungsserver/Manueller Tester
    Wählen Sie in den Listenfeldern einen vorkonfigurierten Ausführungsserver und/oder einen manuellen Tester aus. Die der abhängigen Testsuite zugeordneten automatisierten Tests werden dann auf dem ausgewählten Ausführungsserver ausgeführt. Die der abhängigen Testsuite zugeordneten manuellen Tests werden dem ausgewählten manuellen Tester zugewiesen. Wenn Sie lediglich einen manuellen Tester und keinen Server auswählen, werden nur manuelle Tests ausgeführt. Wenn Sie lediglich einen Server und keinen manuellen Tester auswählen, werden nur automatisierte Tests ausgeführt.
Übergeordnetes Thema: Konfigurieren von Abhängigkeiten zwischen Testsuiten


Löschen von Abhängigkeiten

So löschen Sie eine Abhängigkeit:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die auslösende Testsuite aus, in der Sie die Abhängigkeit löschen möchten.
  3. Klicken Sie auf die Registerkarte Abhängigkeiten.
  4. Klicken Sie in der Spalte Aktionen der betreffenden Ausnahme auf Löschen.
  5. Klicken Sie auf Ja im Dialogfeld Abhängigkeit löschen, um die Abhängigkeit zu löschen.
Übergeordnetes Thema: Konfigurieren von Abhängigkeiten zwischen Testsuiten


Abhängigkeiten (Seite)

Ausführungsplanung > Detailansicht > <Testsuite> > Abhängigkeiten
Anmerkung: Diese Seite wird nicht für Testsuiten angezeigt, die einem Testzyklus zugeordnet sind.

Auf der Seite Abhängigkeiten werden die abhängigen und auslösenden Testsuiten der ausgewählten Testsuite angezeigt.

Die Seite ist in zwei Bereiche unterteilt. Auslösende Testsuite sind Testsuiten, für die ein bestimmter Zustand die ausgewählte Testsuite auslöst. Abhängige Testsuite sind Testsuiten, die ausgelöst werden sobald die ausgewählte Testsuite einen bestimmten Zustand hat.

Auslösende Testsuite

Für jede Testsuite in der Liste werden die folgenden Spalten auf der Seite angezeigt:
Spalte | Beschreibung
Name | Der Name der auslösenden Testsuite, von der die ausgewählte Testsuite abhängig ist.
Bedingung | Die Bedingung der auslösenden Testsuite, die erfüllt werden muss, damit die ausgewählte Testsuite ausgeführt wird.

Abhängige Testsuite

Für jede Testsuite in der Liste werden die folgenden Spalten auf der Seite angezeigt:
Spalte | Beschreibung
Name | Der Name der abhängigen Testsuite, die von der ausgewählten Testsuite ausgelöst wird.
Bedingung | Die Bedingung der ausgewählten Testsuite, die erfüllt werden muss, damit die abhängige Testsuite ausgelöst wird.
Ausführungsserver / Benutzer | Der Ausführungsserver, auf dem die abhängige Testsuite ausgeführt wird, bzw. bei einer manuellen Testsuite der manuelle Tester, der den Test durchführt.
Aktionen | Die Aktionen, die für die ausgewählte Abhängigkeit ausgeführt werden können. Einstellungen bearbeiten und Abhängigkeit löschen.
Übergeordnetes Thema: Konfigurieren von Abhängigkeiten zwischen Testsuiten


Zugeordnete Tests

In diesem Abschnitt wird beschrieben, wie Tests zu Testsuiten zugeordnet werden.

  • Zuordnen von Tests aus der Tabellenansicht zu Testsuiten
    Fügen Sie einen Test aus der Tabellenansicht den Tests in einer Testsuite hinzu.
  • Manuelles Zuordnen von Tests zu Testsuiten
    Weisen Sie einen Test manuell einer Testsuite zu, damit dieser darin enthalten ist.
  • Zuordnen von Tests zu Testsuiten über einen Filter
    Fügen Sie über einen Filter einen Test zu den Tests in einer Testsuite hinzu.
  • Lokalisieren von Testsuiten zugeordneten Tests
    Hier wird beschrieben, wie manuell zugeordnete Tests in der Hierarchie Tests lokalisiert werden.
  • Entfernen zugeordneter Tests
    Hiermit wird die Zuordnung eines manuell zugeordneten Tests von einer Testsuite entfernt, wenn der Test nicht mehr benötigt wird.
  • Zugeordnete Tests (Seite)
    Hier werden alle Tests angezeigt, die der ausgewählten Testsuite zugeordnet sind.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten


Zuordnen von Tests aus der Tabellenansicht zu Testsuiten

Die der ausgewählten Testsuite zugeordneten Tests werden auf der Seite Zugeordnete Tests angezeigt.

So ordnen Sie einen oder mehrere Tests aus der Tabellenansicht einer oder mehreren Testsuiten zu:

  1. Klicken Sie im Menü auf Tests > Tabellenansicht.
  2. Wählen Sie die Tests aus, die Sie den Testsuiten zuordnen möchten. Mehrere Tests können Sie mithilfe von Strg+Klick oder Umschalttaste+Klick auswählen.
  3. Klicken Sie mit der rechten Maustaste auf die ausgewählten Tests, und klicken Sie anschließend auf Auswahl speichern.
  4. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  5. Wählen Sie die Testsuite aus, der die ausgewählten Tests zugeordnet werden sollen.
  6. Klicken Sie auf die Registerkarte Zugeordnete Tests.
  7. Klicken Sie auf Gespeicherte Auswahl zuweisen.
    Anmerkung: Es werden nur die Tests eingefügt, die sich im Container der Testsuite befinden. Sie können die ausgewählten Tests in mehrere Testsuiten einfügen. Sie können sie aber nicht in Anforderungen in einem anderen Projekt einfügen. Die Auswahl bleibt so lange bestehen, bis Sie eine andere Auswahl treffen oder Silk Central schließen.
Übergeordnetes Thema: Zugeordnete Tests
Zugehörige Tasks
Zuordnen von Tests zu Testsuiten über einen Filter
Manuelles Zuordnen von Tests zu Testsuiten


Manuelles Zuordnen von Tests zu Testsuiten

Die der ausgewählten Testsuite zugeordneten Tests werden auf der Seite Zugeordnete Tests angezeigt.

So ordnen Sie einer Testsuite manuell Tests zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite aus, der die ausgewählten Tests zugeordnet werden sollen.
  3. Klicken Sie auf die Registerkarte Zugeordnete Tests.
  4. Klicken Sie auf die Option Manuelle Zuweisung. Die Tests des Containers der ausgewählten Testsuite werden in der Testhierarchie angezeigt. Wenn Sie einen Testfilter erstellt haben, können Sie diesen oben in der Testhierarchie in der Filterliste auswählen. Wenn Sie einen neuen Testfilter erstellten möchten, klicken Sie im Menü auf Tests und anschließend in der Symbolleiste auf [image] (Neuer Filter).
  5. Wählen Sie die Tests aus, die Sie zuordnen möchten. Sie können mit den Tasten Strg und Umschalt entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Tests auswählen.
  6. Ziehen Sie Ihre Auswahl in den Bereich Zugeordnete Tests und legen Sie sie dort ab, oder klicken Sie links von irgendeinem Test auf Zuordnen. Wenn Sie einen Ordners oder Container der obersten Ebene zuordnen, werden alle darin gespeicherten untergeordneten Tests zugeordnet.
    Tipp: Klicken Sie mit der rechten Maustaste auf einen Knoten, um ihn zu erweitern oder auszublenden.
Übergeordnetes Thema: Zugeordnete Tests
Zugehörige Tasks
Zuordnen von Tests aus der Tabellenansicht zu Testsuiten
Zuordnen von Tests zu Testsuiten über einen Filter


Zuordnen von Tests zu Testsuiten über einen Filter

Die der ausgewählten Testsuite zugeordneten Tests werden auf der Seite Zugeordnete Tests angezeigt.

Bevor Sie die folgenden Schritte durchführen können, müssen Sie einen Filter mit der Kategorie Test erstellen. Weitere Informationen finden Sie unter Erstellen von Filtern. Sie können auch einen vorhandenen Filter auswählen.

So ordnen Sie über einen Filter einen oder mehrere Tests einer Testsuite zu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite aus, zu der Tests zugeordnet werden sollen.
  3. Klicken Sie auf die Registerkarte Zugeordnete Tests.
  4. Klicken Sie auf die Option Zuweisung durch Filter.
  5. Wählen Sie einen Filter aus der Liste aus.
Anmerkung: Wenn Sie in Tests > Tabellenansicht einer Testsuite Tests zuordnen, wird der Testzuordnungstyp automatisch auf Manuelle Zuweisung gesetzt, aber die zuvor gefilterten Tests verbleiben auf der Seite Zugeordnete Tests.
Übergeordnetes Thema: Zugeordnete Tests
Zugehörige Tasks
Zuordnen von Tests aus der Tabellenansicht zu Testsuiten
Manuelles Zuordnen von Tests zu Testsuiten
Erstellen von Filtern


Lokalisieren von Testsuiten zugeordneten Tests

So lokalisieren Sie manuell zugeordnete Tests in der Hierarchie Tests:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, für die Sie die zugeordneten Tests lokalisieren möchten.
  3. Klicken Sie auf die Registerkarte Zugeordnete Tests.
  4. Optional: Wählen Sie Manuelle Zuweisung aus, falls es nicht bereits ausgewählt ist.
  5. Klicken Sie in der Spalte Aktionen des betreffenden Tests auf Suchen , um herauszufinden, in welchem Testordner oder -container der Test gespeichert ist.
Der entsprechende übergeordnete Ordner wird in der Hierarchie Tests geöffnet, und der zugeordnete Test wird blau hinterlegt.
Übergeordnetes Thema: Zugeordnete Tests


Entfernen zugeordneter Tests

So entfernen Sie manuell zugeordnete Tests:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, von der Sie die Zuordnung entfernen möchten.
  3. Klicken Sie auf die Registerkarte Zugeordnete Tests.
  4. Klicken Sie in der Spalte Aktionen des zugeordneten Tests auf Löschen, oder wählen Sie mit Strg+Klick oder Umschalt+Klick mehrere Tests aus und drücken Sie die Entf-Taste.
    Tipp: Klicken Sie auf Alle entfernen, um alle zugeordneten Tests zu entfernen.
Übergeordnetes Thema: Zugeordnete Tests


Zugeordnete Tests (Seite)

Ausführungsplanung > Detailansicht > <Element für die Testausführung> > Zugeordnete Tests
Anmerkung: Diese Seite wird nicht für Testsuiten angezeigt, die einem Testzyklus zugeordnet sind.

Auf der Seite Zugeordnete Tests werden alle Tests angezeigt, die der ausgewählten Testsuite oder Konfigurationssuite zugeordnet sind. Fügen Sie auf dieser Seite der Testsuite oder Konfigurationssuite weitere Tests hinzu, entfernen Sie Tests aus der Testsuite oder Konfigurationssuite, oder ändern Sie die Ausführungsreihenfolge der zugeordneten Tests.

Wenn Sie einen Testfilter erstellt haben, können Sie diesen oben in der Testhierarchie in der Filterliste auswählen. Um einen neuen Testfilter zu erstellen, klicken Sie in der Symbolleiste des Bereichs Tests auf Neuer Filter.

Anmerkung: Die Änderungen auf dieser Seite werden sofort übernommen.
Anmerkung: Wenn diese Seite von einem Unterelement einer Konfigurationssuite aus geöffnet wird, können auf ihr keine Änderungen vorgenommen werden.

Die Seite enthält die folgenden Elemente:

Element | Beschreibung
Manuelle Zuweisung | Klicken Sie hier, um der Testsuite oder Konfigurationssuite manuell Tests zuzuordnen.
Reihenfolge der Tests verwenden | Markieren Sie diese Option, um für die zugeordneten Tests dieselbe Ausführungsreihenfolge wie im Bereich Tests festzulegen.
Gespeicherte Auswahl zuweisen | Klicken Sie hier, um eine Auswahl an Tests aus dem Bereich Tests > Tabellenansicht zuzuordnen.
Zuweisung durch Filter | Klicken Sie hier, um der Testsuite oder Konfigurationssuite automatisch auf der Basis eines vordefinierten Filters Tests zuzuweisen. Die verfügbaren Filter sind im Listenfeld enthalten.
Zugeordnete Tests | Menge der zur Testsuite oder Konfigurationssuite zugeordneten Tests.
Verbleibende Zeit im Testzyklus [hh:mm] Dieses Feld ist verfügbar, wenn sich eine Testsuite im Testzyklus befindet. Es gibt die Zeit an, die vom Testzyklus verbleibt, nachdem die kumulative geplante Dauer aller Tests von der Verfügbaren Zeit des Testzyklus subtrahiert wurde.
Anmerkung: Die Geplante Dauer ist nur für manuelle Tests vorgesehen.
Geplante Dauer Geschätzter Zeitaufwand, der zur Ausführung aller in der Testsuite oder Konfigurationssuite enthaltenen Tests erforderlich ist. Bei Konfigurationssuiten ist die Geplante Dauer die Summe aller geplanten Zeiten für alle in der Suite enthaltenen Konfigurationen.
Anmerkung: Die Geplante Dauer ist nur für manuelle Tests vorgesehen.
Liste zugeordneter Tests Für jeden zugeordneten Test werden folgende Spalten auf der Seite angezeigt:
Reihenfolge
Die Ausführungsreihenfolge der Tests. Deaktivieren Sie das Kontrollkästchen Reihenfolge der Tests verwenden, wenn die Ausführungsreihenfolge geändert werden soll. Klicken Sie in das Feld, geben Sie die neue Reihenfolge der Tests ein, und drücken Sie anschließend die Eingabetaste, um die Änderung zu bestätigen. Jede Änderung in einem Feld muss durch Drücken der Eingabetaste bestätigt werden. Wenn Sie die Reihenfolge mehrerer Tests ändern, ohne jedes Mal die Eingabetaste zu drücken, wird nur die letzte Änderung vor dem Drücken der Eingabetaste übernommen.
Aktionen
Wenn das Optionsfeld Manuelle Zuweisung angeklickt wird, können die folgenden Aktionen für zugeordnete Tests ausgeführt werden:
Aktion
Beschreibung
Entfernt den ausgewählten Test aus der Liste.
Sucht den ausgewählten Test in der Testhierarchie.
Test
Der Name des Tests. Klicken Sie hier, um im Bereich Tests auf den Test zuzugreifen.
Status

Status des letzten Testlaufs im Kontext der Testsuite oder Konfigurationssuite. Wenn der Test außerhalb des Kontexts der Testsuite oder Konfigurationssuite ausgeführt wird, ändert sich der angezeigte Status nicht. Wenn der Test noch nicht im Kontext der Testsuite oder Konfigurationssuite ausgeführt wurde, lautet der Status N/V.

Für Tests oder Testpakete, die in einer Konfigurationssuite enthalten sind, ist der Status eine Aggregation aller Status von allen Konfigurationen innerhalb der Suite:
  • Wenn der Test nur der Konfigurationssuite zugeordnet ist, gilt der Status Bestanden nur, wenn der Test bei allen Konfigurationen bestanden ist. Falls der Status nicht für alle Konfigurationen Bestanden ist, wird der Status für den schlechtesten Testlauf mit der folgenden Priorität (von oben nach unten) übertragen:
    1. --
    2. Nicht ausgeführt
    3. Fehlgeschlagen
    4. Bestanden
    Der Status einer Anforderung, der dem Test zugeordnet ist, gilt als Fehlgeschlagen, wenn der Test in einer Konfiguration oder mehreren Konfigurationen fehlgeschlagen ist.
  • Wir empfehlen Ihnen nicht, den Test einer Konfigurationssuite und gleichzeitig einer oder mehreren Testsuiten zuzuordnen. In diesem Fall ist die Zusammenfassung des Konfigurationsstatus ein eigenständiger Status, unabhängig von den letzten Status der Testsuiten, die andere Status sind. Der Status, der zuletzt durchgeführt wurde, bestimmt den letzten Status des Tests.
  • Wenn der Test nur einer einfachen Testsuite zugeordnet ist, wird der Status auf den Status des letzten Testlaufs gesetzt.
Letzte Testausführung
Datum und Uhrzeit des letzten Testlaufs im Kontext der Testsuite oder Konfigurationssuite. Wenn der Test außerhalb des Kontexts der Testsuite oder Konfigurationssuite ausgeführt wird, ändern sich das angezeigte Datum und die Uhrzeit nicht.
Geplante Dauer
Die geplante Ausführungsdauer des Tests.
Anmerkung: Die Geplante Dauer ist nur für manuelle Tests vorgesehen.
Test | Hier werden alle in der Testhierarchie enthaltenen Tests angezeigt, die für die Zuordnung zur ausgewählten Testsuite oder Konfigurationssuite verfügbar sind. Doppelklicken Sie auf einen Test, oder ordnen Sie den Test mithilfe der Schaltfläche Zuordnen der Testsuite oder Konfigurationssuite zu. Informationen über das Einfügen mehrerer Tests aus dem Bereich Tests in eine Testsuite oder Konfigurationssuite finden Sie im Thema Zuordnen von Tests aus der Tabellenansicht zu Testsuiten.
Übergeordnetes Thema: Zugeordnete Tests
Zugehörige Tasks
Zuordnen von Tests aus der Tabellenansicht zu Testsuiten


Ausführungstermine

Sobald Sie die Tests, die einer Testsuite, einem Ordner oder einer Konfigurationssuite zugewiesen werden sollen, festgelegt haben, können Sie auf der Seite Ausführungstermin den Ausführungstermin definieren, zu dem die Testsuite, ein Ordner oder eine Konfigurationssuite ausgeführt werden soll.

Es stehen drei Optionen zur Verfügung:
  • Keine
  • Ausführungstermin
  • Benutzerdefiniert
Anmerkung: Sie können Ausführungstermine für Testsuiten, Ordner oder Konfigurationssuiten festlegen. Wenn Sie den Ausführungstermin für einen Ordner oder eine Konfigurationssuite definieren, werden alle darin befindlichen Testsuiten zu diesem Zeitpunkt ausgeführt. Alle Testsuiten, Ordner oder Konfigurationssuiten ohne Schlüsselwörter erhalten den Status Nicht ausgeführt, wenn sie im Rahmen eines Ausführungstermins ausgeführt werden. Es sind keine Optionen für Ausführungstermine für Teile einer Projektkopie oder Baseline festgelegt, um zu verhindern, dass der letzte Testausführungsstatus verloren geht. Weitere Informationen über Kopien und Baselines von Projekten finden Sie unter Projekt-Baselines und Kopieren von Projekten oder Projekt-Baselines.

Explizite Testläufe

Explizite Testläufe ermöglichen es, Termine für die außerplanmäßige Ausführung von Tests festzulegen.

  • Festlegen eines benutzerdefinierten Ausführungstermins
    Legen Sie einen benutzerdefinierten Ausführungstermin fest, wenn eine Testsuite spezielle Planung erfordert.
  • Festlegen globaler Ausführungstermine
    Legen Sie allgemeine Ausführungstermine fest, gemäß denen die Tests einer Testsuite, eines Ordners oder einer Konfigurationssuite ausgeführt werden sollen.
  • Festlegen von keinem Ausführungstermin
    Legen Sie "ohne Ausführungstermin" für eine Testsuite, einen Ordner oder eine Konfigurationssuite fest, wenn die Tests nicht basierend auf einem Ausführungstermin ausgeführt werden sollen.
  • Ausführungsterminausnahmen
    Hier wird die Verwendung von Ausführungsterminausnahmen beschrieben.
  • Explizite Testläufe
    Hier wird die Verwendung von expliziten Testläufen beschrieben.
  • Ausführungstermin (Seite)
    Hier wird das Festlegen von Ausführungsterminen für Testsuiten, Ordner, Konfigurationssuiten und Berichtsabonnemente beschrieben.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten
Zugehörige Konzepte
Konfigurieren von Ausführungsterminen
Projekt-Baselines
Zugehörige Tasks
Kopieren von Projekten oder Projekt-Baselines


Festlegen eines benutzerdefinierten Ausführungstermins

So legen Sie einen benutzerdefinierten Ausführungstermin für eine Testsuite, einen Ordner oder eine Konfigurationssuite fest:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, den Ordner oder die Konfigurationssuite aus, für die/den Sie einen benutzerdefinierten Ausführungstermin konfigurieren wollen.
    Anmerkung: Wenn Sie einen geänderten allgemeinen Ausführungstermin als benutzerdefinierten Ausführungstermin speichern möchten, wählen Sie den allgemeinen Termin in dem Listenfeld aus und klicken auf Bearbeiten. Sie können nun die Einstellungen bearbeiten und als benutzerdefinierten Ausführungstermin speichern.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Wählen Sie die Option Benutzerdefiniert aus, damit die Optionen verfügbar sind.
  5. Klicken Sie auf Bearbeiten.
  6. Klicken Sie auf Bearbeiten neben dem Feld Von, und legen Sie mit den Kalenderoptionen den Ausführungsbeginn fest.
  7. Legen Sie das Intervall zwischen den Testausführungen fest.
  8. Legen Sie im Bereich Ausführen den Zeitpunkt des Ausführungsendes fest. Wählen Sie eine der folgenden Optionen aus:
    • Klicken Sie auf Endlos, um einen Ausführungstermin ohne festes Ende zu erstellen.
    • Klicken Sie auf n Anzahl.
    • Klicken Sie auf Bearbeiten neben dem Feld Bis, und legen Sie mit den Kalenderoptionen das Ausführungsende fest.
  9. Optional: Klicken Sie auf Ausnahme hinzufügen, und legen Sie Zeiträume fest, in denen die geplanten Elemente nicht ausgeführt werden.
  10. Optional: Klicken Sie auf Expliziten Testlauf hinzufügen, und legen Sie Termine für außerplanmäßige Testausführungen fest.
  11. Klicken Sie auf Speichern, um den benutzerdefinierten Ausführungstermin zu speichern.
Übergeordnetes Thema: Ausführungstermine
Zugehörige Tasks
Hinzufügen von Ausnahmen
Hinzufügen von expliziten Testläufen


Festlegen globaler Ausführungstermine

In Silk Central können Sie allgemeine Ausführungstermine definieren, die in Silk Central für die Zeitplanung von Testsuiten verwendet werden können. Auf diese Weise kann das Planen von Tests beschleunigt werden. Sie brauchen dann nur noch Ausführungstermine für jeden Test festlegen, für den eine spezielle Planung erforderlich ist.

So wählen Sie einen vordefinierten Ausführungstermin aus, der global in Silk Central verfügbar ist:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, den Ordner oder die Konfigurationssuite zur Konfiguration eines entsprechenden Ausführungstermins.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Aktivieren Sie das Optionsfeld Global.
  5. Wählen Sie im Listenfeld den gewünschten vordefinierten Ausführungstermin aus. Die Details dieses vordefinierten Ausführungstermins werden in der Kalenderansicht angezeigt. Wenn Sie den Ausführungstermin bearbeiten und als benutzerdefinierten Ausführungstermin speichern möchten, klicken Sie auf die Schaltfläche Bearbeiten.
    Anmerkung: Sie können allgemeine Ausführungstermine unter Verwaltung > Ausführungstermine konfigurieren.
Übergeordnetes Thema: Ausführungstermine
Zugehörige Tasks
Hinzufügen globaler Ausführungstermine
Bearbeiten globaler Ausführungstermine


Festlegen von keinem Ausführungstermin

So legen Sie fest, dass kein Ausführungstermin für eine Testsuite, einen Ordner oder eine Konfigurationssuite definiert werden soll:
  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, den Ordner oder die Konfigurationssuite aus, für die/den Sie festlegen möchten, dass die entsprechende Auswahl nicht basierend auf Ausführungsterminen ausgeführt werden soll.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Klicken Sie auf das Optionsfeld Ohne.
Übergeordnetes Thema: Ausführungstermine


Ausführungsterminausnahmen

Eine Ausnahme ist ein regelmäßig wiederkehrender Zeitraum, in dem die Tests ausgesetzt werden, beispielsweise während regelmäßiger wöchentlich wiederkehrender Ausschaltzeiten der Systeme oder an Wochenenden. Sie können einem Ausführungstermin beliebig viele Ausnahmen hinzufügen. Mit den Ausnahmen können Sie bestimmte Wochentage und Uhrzeiten festlegen, an denen keine Tests ausgeführt werden (selbst wenn Ausführungstermine konfiguriert sind). Die Tests könnten beispielsweise an den Wochenenden ausgesetzt werden.

  • Hinzufügen von Ausnahmen
    Fügen Sie eine Ausnahme zu einem benutzerdefinierten Ausführungstermin hinzu, um die Ausführung zu einem bestimmten Zeitpunkt zu unterbinden.
  • Bearbeiten von Ausnahmen
    Bearbeiten Sie Ausnahmen, um die Zeiträume zu ändern, in denen die Ausführungstermine nicht beachtet werden.
  • Löschen von Ausnahmen
    Löschen Sie Ausnahmen, wenn der Ausführungstermin zum Zeitpunkt der Ausnahme doch möglich ist.
Übergeordnetes Thema: Ausführungstermine


Hinzufügen von Ausnahmen

Anmerkung: Die allgemeinen Ausführungstermine können nur mit Administratorrechten geändert werden. Um eine Ausnahme in einem allgemeinen Ausführungstermin zu definieren, klicken Sie auf Verwaltung > Ausführungstermine.

So fügen Sie eine Ausführungsterminausnahme hinzu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie eine Testsuite, einen Ordner oder eine Konfigurationssuite aus, für den bzw. die Sie eine Ausführungsterminausnahme hinzufügen möchten.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Wählen Sie die Option Benutzerdefiniert aus, damit die Optionen verfügbar sind.
  5. Klicken Sie auf Ausnahme hinzufügen.
  6. Wählen Sie auf der Seite Ausführungsterminausnahme konfigurieren die Wochentage, an denen die Tests nicht ausgeführt werden sollen.
  7. Legen Sie die Zeiträume an diesen Tagen fest, in denen keine Testausführungen durchgeführt werden sollen.
  8. Klicken Sie auf OK. Die Ausnahmeeinstellungen werden nun auf der Seite Ausführungstermin angezeigt.
  9. Klicken Sie auf Speichern, um die Ausnahme dem aktuellen Ausführungstermin hinzuzufügen, oder geben Sie weitere Ausnahmen ein.
Übergeordnetes Thema: Ausführungsterminausnahmen
Zugehörige Verweise
Ausführungstermin (Seite)


Bearbeiten von Ausnahmen

So bearbeiten Sie eine Ausnahme:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, den Ordner oder die Konfigurationssuite aus, aus der Sie eine bereits konfigurierte Ausnahme bearbeiten wollen.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Klicken Sie in der Spalte Aktionen der betreffenden Ausnahme auf Ausnahme bearbeiten.
  5. Bearbeiten Sie die Ausnahme, und klicken Sie anschließend auf OK.
  6. Klicken Sie auf Speichern.
Übergeordnetes Thema: Ausführungsterminausnahmen
Zugehörige Verweise
Ausführungstermin (Seite)


Löschen von Ausnahmen

So löschen Sie eine Ausnahme:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, den Ordner oder die Konfigurationssuite aus, aus der Sie eine bereits konfigurierte Ausnahme löschen wollen.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Klicken Sie in der Spalte Aktionen der betreffenden Ausnahme auf Löschen.
Übergeordnetes Thema: Ausführungsterminausnahmen
Zugehörige Verweise
Ausführungstermin (Seite)


Explizite Testläufe

Als expliziter Testlauf wird die Ausführung einer Testsuite, eines Ordners oder einer Konfigurationssuite zu einem bestimmten, von Ihnen festgelegten Zeitpunkt bezeichnet, der unabhängig von dem für die Testsuite, den Ordner oder die Konfigurationssuite konfigurierten Ausführungstermin ist. Sie können beliebig viele explizite Testläufe hinzufügen.

  • Hinzufügen von expliziten Testläufen
    Fügen Sie explizite Testläufe zu einem benutzerdefinierten Ausführungstermin hinzu, wenn die geplante Testsuite, der Ordner oder die Konfigurationssuite einzeln zusätzlich ausgeführt werden soll.
  • Bearbeiten von expliziten Testläufen
    Bearbeiten Sie explizite Testläufe, um Datum und Uhrzeit von Testläufen zu ändern.
  • Löschen von expliziten Testläufen
    Löschen Sie explizite Testläufe, die nicht mehr benötigt werden.
Übergeordnetes Thema: Ausführungstermine


Hinzufügen von expliziten Testläufen

Anmerkung: Die allgemeinen Ausführungstermine können nur mit Administratorrechten geändert werden. Um einen expliziten Testlauf für einen allgemeinen Ausführungstermin zu definieren, klicken Sie auf Verwaltung > Ausführungstermine.

So fügen Sie einen expliziten Testlauf hinzu:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, den Ordner oder die Konfigurationssuite aus, für die Sie einen expliziten Testlauf hinzufügen wollen.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Wählen Sie die Option Benutzerdefiniert aus, damit die Optionen verfügbar sind.
  5. Klicken Sie auf Expliziten Testlauf hinzufügen.
  6. Klicken Sie auf der Seite Expliziten Testlauf konfigurieren auf Bearbeiten Bearbeiten, und wählen Sie das Datum und die Uhrzeit für die explizite Ausführung der Testsuite, des Ordners oder der Konfigurationssuite aus.
  7. Klicken Sie auf OK. Die Einstellungen des expliziten Testlaufs werden nun auf der Seite Ausführungstermin angezeigt.
  8. Klicken Sie auf Speichern, um den expliziten Testlauf hinzuzufügen, oder setzen Sie das Definieren neuer Testläufe fort.
Übergeordnetes Thema: Explizite Testläufe
Zugehörige Verweise
Ausführungstermin (Seite)


Bearbeiten von expliziten Testläufen

So bearbeiten Sie einen expliziten Testlauf:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, den Ordner oder die Konfigurationssuite aus, für die Sie einen bereits konfigurierten Testlauf bearbeiten wollen.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Klicken Sie in der Spalte Aktionen des betreffenden Testlaufs auf Expliziten Testlauf bearbeiten.
  5. Bearbeiten Sie den Testlauf, und klicken Sie anschließend auf Speichern.
Übergeordnetes Thema: Explizite Testläufe
Zugehörige Verweise
Ausführungstermin (Seite)


Löschen von expliziten Testläufen

So löschen Sie einen expliziten Testlauf:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie die Testsuite, den Ordner oder die Konfigurationssuite aus, aus der Sie einen bereits konfigurierten Testlauf löschen wollen.
  3. Klicken Sie auf die Registerkarte Ausführungstermin.
  4. Klicken Sie in der Spalte Aktionen des betreffenden Testlaufs auf Expliziten Testlauf löschen.
Übergeordnetes Thema: Explizite Testläufe
Zugehörige Verweise
Ausführungstermin (Seite)


Ausführungstermin (Seite)

Ausführungsplanung > Detailansicht > <Element für die Testausführung> > Ausführungstermin
Anmerkung: Diese Seite wird nicht für Testsuiten angezeigt, die einem Testzyklus zugeordnet sind.

Auf der Seite Ausführungstermin werden die Ausführungstermine der Testsuiten, Ordner, Konfigurationssuiten und Berichtsabonnemente festgelegt.

Die Seite bietet die folgenden Typen von Ausführungsterminen:

Typ des Ausführungstermins | Beschreibung
Kein | Klicken Sie auf diese Option, um Elemente nicht gemäß einem Ausführungstermin auszuführen. Alle in einer Kopie oder einer Baseline eines Projekts enthaltenen Ausführungstermine werden zunächst auf Ohne festgelegt.
Global | Klicken Sie auf diese Option, wenn Sie in dem Listenfeld einen vordefinierten Ausführungstermin für ein Element auswählen möchten. Die Auswahl eines globalen Ausführungstermins beinhaltet die dafür definierten Ausnahmen und expliziten Testläufe. Informationen zum Definieren globaler Ausführungstermine finden Sie in den Themen Verwaltung in dieser Hilfe. Bei der Auswahl eines globalen Ausführungstermins werden die Details des Ausführungstermins unterhalb des Optionsfeldes Benutzerdefiniert angezeigt.
Benutzerdefiniert | Klicken Sie auf diese Option, wenn Sie einen benutzerdefinierten Ausführungstermin für ein Element festlegen möchten. Klicken Sie auf Bearbeiten, um den benutzerdefinierten Ausführungstermin zu bearbeiten.

Zu jedem Typ von Ausführungsterminen werden auf der Seite Details angezeigt. Bei benutzerdefinierten Ausführungsterminen können die Details bearbeitet werden.

ACHTUNG:
Wenn Tests, die einem Element zugewiesen sind, nicht ausgeführt werden, dann liegt der Grund dafür eventuell darin, dass das Element noch aufgrund eines früheren Ausführungstermins ausgeführt wird und das Terminintervall kürzer als die Dauer der Ausführung ist. In diesem Fall können Sie entweder das Terminintervall erhöhen, die Leistung der ausgeführten Tests verbessern oder Tests aus der Testsuite herausnehmen. Zum Anzeigen der Logdatei des Anwendungsservers klicken Sie auf die Registerkarte Anwendungsserver-Logdatei unter Verwaltung > Logdateien.

Details des Ausführungstermins

Auf der Seite werden Details des Ausführungstermintyps angezeigt, die bei benutzerdefinierten Ausführungsterminen auch geändert werden können.
Element | Beschreibung
Von | Der Zeitpunkt, an dem der Ausführungstermin beginnt. Klicken Sie neben dem angezeigten Datum auf Bearbeiten, um Datum und Uhrzeit zu ändern.
Intervall | Das Intervall zwischen den Testausführungen.
Ausführungstermin an Sommerzeit anpassen Markieren Sie dieses Kontrollkästchen, um Ihren Ausführungstermin automatisch an die Sommerzeit anzupassen.
Anmerkung: Diese Anpassung funktioniert nur bei Intervallen, die ein Vielfaches von 2 sind, damit keine doppelten Testläufe beim Zurücksetzen der Zeit ausgeführt werden.
Ausführen Der Zeitpunkt, an dem der Ausführungstermin endet:
Endlos
Klicken Sie auf dieses Optionsfeld, wenn kein Ausführungsende festgelegt werden soll.
Anzahl
Klicken Sie Sie das Optionsfeld, und wählen Sie den gewünschten Wert aus dem Listenfeld aus, um eine bestimmte Anzahl von Ausführungen festzulegen.
Bis
Klicken Sie auf dieses Optionsfeld, wenn Sie einen bestimmten Zeitpunkt festlegen möchten. Klicken Sie neben dem angezeigten Datum auf Bearbeiten, um Datum und Uhrzeit zu ändern.
Ausnahme | Die für den Ausführungstermin definierten Ausnahmen. Um eine Ausnahme hinzuzufügen, klicken Sie auf Ausnahme hinzufügen.
Explizite Testläufe | Die für den Ausführungstermin definierten expliziten Testläufe. Um einen expliziten Testlauf hinzuzufügen, klicken Sie auf Expliziten Testlauf hinzufügen. Klicken Sie in der Spalte "Aktion" des ausgewählten Testlaufs auf Bearbeiten, um den Kalender zu öffnen und festzulegen, wann der explizite Testlauf stattfinden soll.
Übergeordnetes Thema: Ausführungstermine


Ausführen von Tests, die Testsuiten zugeordnet sind

In diesem Abschnitt wird beschrieben, wie Tests ausgeführt werden, die Testsuiten in Silk Central zugewiesen sind.

Sie können individuelle Testsuiten, Ordner und Konfigurationssuiten ausführen. In allen Fällen können Sie festlegen, ob alle zugewiesenen Tests oder nur die Tests, die bestimmte Statuskriterien erfüllen, ausgeführt werden sollen. Nachdem eine Testsuite mit automatisierten Tests begonnen hat, wird sie in die zentrale Ausführungs-Warteschlange gestellt. Nun wird ein geeigneter Ausführungs-Server zur automatisierten Ausführung der Tests anhand der passenden Schlüsselwörter und der Server-Verfügbarkeit ausgewählt. Wenn für die Testsuite eine Mobilgeräte-Auswahl konfiguriert wurde, wird für Tests auf Mobilgeräten ein Gerät für die Ausführung ausgewählt und reserviert. Falls kein Ausführungsserver oder kein mobiles Gerät zur Verfügung steht, bleibt der Ausführungs-Job in der Warteschlange, bis ein geeigneter Ausführungsserver oder ein mobiles Gerät verfügbar wird.

  • Starten von Testsuiten
    Ausführen einzelner Testsuiten unabhängig von einem Ausführungstermin.
  • Ausführen (Dialog)
    Im Dialogfeld Ausführen können Sie anhand von Filterkriterien festlegen, welche Tests ausgeführt werden sollen und für welches Produkt-Build der Testlauf ausgeführt werden soll.
  • Manuelles Ausführen automatisierter Tests
    Führen Sie einen automatisierten Test manuell durch, wenn der automatisierte Test aufgrund einer Systemkomponente fehlschlägt oder Sie das Ergebnis des automatisierten Tests überprüfen möchten.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten


Starten von Testsuiten

So führen Sie eine Testsuite unabhängig von einem Ausführungstermin aus:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie das Projekt, die Testsuite, den Ordner oder die Konfigurationssuite aus, oder verwenden Sie Strg+Klick oder Umschalt+Klick um mehrere Elemente auszuwählen.
  3. Klicken Sie in der Symbolleiste auf [image] (Ausführen). Dies ist für Testzyklen, Testsuiten innerhalb von Testzyklen, und nicht zugeordnete Tests deaktiviert. Das Dialogfeld Ausführen wird angezeigt.
  4. Legen Sie im Dialog Ausführen fest, welche Tests Sie ausführen möchten.
  5. Aktivieren Sie das Kontrollkästchen Gehe zu Aktivitäten-Seite, um nach dem Definieren der auszuführenden Tests zur Seite Aktivitäten zu wechseln.
Übergeordnetes Thema: Ausführen von Tests, die Testsuiten zugeordnet sind
Zugehörige Konzepte
Zugeordnete Tests
Zugehörige Verweise
Aktivitäten (Seite)
Ausführen (Dialog)


Ausführen (Dialog)

Ausführungsplanung > Detailansicht > <Element für die Testausführung> > Ausführen

Ausführungsplanung > Dokumentansicht > <Element für die Testausführung> > Ausführen

Im Dialogfeld Ausführen können Sie anhand von Filterkriterien festlegen, welche Tests ausgeführt werden sollen und für welches Produkt-Build der Testlauf ausgeführt werden soll. Zum Öffnen des Dialogs Ausführen wählen Sie eine Testsuite oder einen Ordner aus und klicken in der Symbolleiste auf Ausführen.

Element | Beschreibung
Alle Tests | Mit dieser Option führen Sie alle Tests aus.
Tests Wählen Sie diese Option, um nur die Tests auszuführen, die einer der folgenden Optionen entsprechen:
Option
Beschreibung
Mit Status Fehlgeschlagen
Wählen Sie diese Option, um alle Tests der gewählten Testsuite mit dem Status Fehlgeschlagen erneut auszuführen.
Mit Ausführungsstatus 'Nicht ausgeführt'
Wählen Sie diese Option, um alle Tests der gewählten Testsuite mit dem Status Nicht ausgeführt erneut auszuführen.
Nicht ausgeführt mit Build ...
Prüfen Sie diese Option, um alle Tests des gewählten Builds, die in diesem Build nicht ausgeführt wurden, erneut auszuführen. Tests, die in dem gewählten oder einem späteren Build ausgeführt wurden, werden nicht erneut ausgeführt.
Tests, bei denen seit der letzten Ausführung Fehler behoben wurden | Mit dieser Option werden nur solche Tests ausgeführt, für die seit der letzten Ausführung Fehler auf den Status Behoben gesetzt wurden.
Build für Testsuite setzen | Wählen Sie aus dem Listenfeld Build für Testsuite setzen eine vorausgegangene Build-Nummer aus, für die der Testlauf ausgeführt werden soll. Vorgabe für dieses Feld ist das aktuelle Build. Beachten Sie bitte, dass diese Option nicht zur Verfügung steht, wenn die Testsuite so konfiguriert ist, dass die Build-Nummer aus einer Build-Informationsdatei gelesen wird. Wenn ein Ordner Testsuiten enthält, denen jeweils unterschiedliche Produktversionen zugeordnet wurden, kann keine Build-Nummer zur Ausführung des Ordners ausgewählt werden.
Testlauf-Typ | Wählen Sie Ausführen wie spezifiziert, um alle ausgewählten Tests mit ihrem eigenen Testtyp auszuführen, oder wählen Sie Automatisierte Tests manuell ausführen, um alle Tests erneut manuell auszuführen.
Gehe zu Aktivitäten-Seite | Aktivieren Sie dieses Kontrollkästchen, um nach dem Definieren der auszuführenden Tests zur Seite Aktivitäten zu wechseln.
Übergeordnetes Thema: Ausführen von Tests, die Testsuiten zugeordnet sind
Zugehörige Konzepte
Ausführen von Tests, die Testsuiten zugeordnet sind


Manuelles Ausführen automatisierter Tests

Automatisierte Tests können aufgrund von Umgebungsproblemen zu unerwarteten Ergebnissen führen. Wenn bei einem solchen Test ein Fehler auftritt und Sie überprüfen möchten, ob der Fehler von einer Systemkomponente verursacht wird, oder wenn Sie wissen, dass die Ursache des Problems eine aktuell fehlerhafte Systemkomponente ist, können Sie den automatisierten Test manuell wiederholen.

So führen Sie einen automatisierten Test manuell durch:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie das Projekt, die Testsuite, den Ordner oder die Konfigurationssuite aus, oder verwenden Sie Strg+Klick oder Umschalt+Klick um mehrere Elemente auszuwählen.
  3. Klicken Sie in der Symbolleiste auf [image] (Ausführen). Dies ist für Testzyklen, Testsuiten innerhalb von Testzyklen, und nicht zugeordnete Tests deaktiviert. Das Dialogfeld Ausführen wird angezeigt.
  4. Legen Sie fest, welche Tests Sie ausführen möchten.
  5. Wählen Sie im Listenfeld Testlauf-Typ die Option Automatisierte Tests manuell ausführen. Alle ausgewählten Tests werden als manuelle Tests behandelt, und die Seite Aktueller Testlauf wird geöffnet.
Übergeordnetes Thema: Ausführen von Tests, die Testsuiten zugeordnet sind
Zugehörige Verweise
Ausführen (Dialog)


Screenshots

Sie können die Aufzeichnung von Screenshots für ein Testelement oder eine Testsuite erlauben. Die Screenshots werden den Ergebnisdateien auf den Seiten Dateien und Zeitverlauf des Dialogfeldes Ergebnisse des Tests hinzugefügt. Sie können dann die Screenshots analysieren , zum Beispiel wenn Fehler während der Tests aufgetreten sind.

Die Einstellung Screenshots auf der Seite Testumgebung einer Testsuite kann die Einstellung für ein spezifisches Testelement, welches der Testsuite zugeordnet ist, überschreiben.

  • Aktivieren der Aufzeichnung von Screenshots
    Aktivieren Sie die Aufzeichnung von Screenshots, um einen Screenshot ihres Tests zu den Ergebnisdateien hinzuzufügen.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten


Aktivieren der Aufzeichnung von Screenshots

Um die Aufzeichnung von Screenshots für einen Test zu aktivieren:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Container, einen Ordner oder einen Test aus.
  3. Öffnen Sie die Registerkarte Parameter.
  4. Klicken Sie auf Benutzerdefinierte Parameter hinzufügen. Das Dialogfeld Benutzerdefinierten Parameter festlegen wird angezeigt.
  5. Geben Sie im Feld Name den Text captureScreen ein.
  6. Wählen Sie im Listenfeld Typ die Option String aus.
  7. Im Feld Wert geben Sie eine der folgenden Eingaben ein:
    • onError, wenn Sie beim Auftreten eines Fehlers während der Ausführung der Testsuite einen Screenshot zu den Ergebnisdateien hinzufügen möchten.
    • Einen String oder nichts, wenn Sie keinen Screenshot zu den Ergebnisdateien hinzufügen möchten.
Übergeordnetes Thema: Screenshots


Videoaufnahme

Sie können die Videoaufnahme für Testelemente und Testsuiten aktivieren. Die Videos werden als WMV-Videodatei zu den Ergebnisdateien auf der Seite Dateien des Dialogfelds Ergebnisse des Testlaufs hinzugefügt. Sie können die Videos im Anschluss analysieren, zum Beispiel wenn während der Tests Fehler aufgetreten sind.

Die Einstellung Videoaufzeichnung auf der Seite Testumgebung von Testsuiten kann die Einstellung für ein bestimmtes Testelement der Testsuite überschreiben.

Einschränkungen:
  • Die Videoaufzeichnung wird nur auf Microsoft Windows-Mandantenrechnern unterstützt.
  • Die Videoaufnahme wird auf Microsoft Windows 10 N und KN Editionen nicht unterstützt.
  • Die Videoaufzeichnung von WPF-Fenstern in der klassischen Ansicht von Windows 7 wird nicht unterstützt.
  • Die Videoaufzeichnung in einer 4K-Auflösung wird nicht unterstützt.
Anmerkung: Um die Videoaufnahme auf einem Windows 2008 Ausführungsserver zu verwenden, müssen Sie die folgenden Serverfunktionen installieren:
  • Desktop Experience
  • Quality Windows Audio Video Experience
Um die Videoaufnahme auf einem Windows 2012 Ausführungsserver zu verwenden, müssen Sie die folgenden Serverfunktionen installieren:
  • Desktop Experience
  • Media Foundation
Achtung: Der Prozess der Videoaufnahme ist äußerst CPU-intensiv. Setzen Sie diese Funktion nur bei Bedarf ein. Für diese Funktion benötigen Sie ein System mit ausreichender CPU-Leistung, z. B. ein System mit mehreren CPUs.

Die Videoaufnahme für jeden einzelnen Testfall wird standardmäßig für JUnit 4-Tests und Silk Test Classic-Plantests unterstützt. Wenn Sie diese Funktion für andere Testtypen einsetzen möchten, müssen Sie mit den Methoden aus der TestCaseStartFinishSocketClient-Schnittstelle arbeiten. Weitere Informationen hierzu finden Sie unter Angabe von Beginn und Ende der Videoaufnahme.

  • Videoaufnahme aktivieren
    Aktivieren der Videoaufnahme, um ein Video Ihres Tests zu den Ergebnisdateien hinzuzufügen.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten
Zugehörige Konzepte
Angeben von Start und Ende von Videoaufnahmen


Videoaufnahme aktivieren

So aktivieren Sie die Videoaufnahme für einen Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Container, einen Ordner oder einen Test aus.
  3. Öffnen Sie die Registerkarte Parameter.
  4. Klicken Sie auf Benutzerdefinierte Parameter hinzufügen. Das Dialogfeld Benutzerdefinierten Parameter festlegen wird angezeigt.
  5. Geben Sie im Feld Name den Text recordVideo ein.
  6. Wählen Sie im Listenfeld Typ die Option String aus.
  7. Im Feld Wert geben Sie eine der folgenden Eingaben ein:
    • Always, wenn Sie ein Video bei jeder Durchführung einer Testsuite zu den Ergebnisdateien hinzufügen wollen.
    • onError, wenn Sie ein Video beim Auftreten eines Fehlers während der Durchführung einer Testsuite zu den Ergebnisdateien hinzufügen wollen.
    • Einen String oder nichts, wenn Sie kein Video zu Ihren Ergebnisdateien hinzufügen wollen.
Übergeordnetes Thema: Videoaufnahme


Ergebnisse und Ergebnisdateien automatisch löschen

Definieren Sie Regeln, nach denen veraltete Ergebnisse und Ergebnisdateien von Testsuiten bereinigt werden sollen. Dadurch wird die Datenbankgröße reduziert und Ihre Testsuiteläufe werden einfacher verwaltbar.

Um diese Aufgabe auszuführen benötigen Sie die Berechtigung Testsuitelauf löschen.

Mit der Zeit steigt die Menge von Ergebnissen und Ergebnisdateien Ihrer Testsuiteläufe. Nach einiger Zeit werden manche Ergebnisse vielleicht irrelevant, und die Verwaltung Ihrer Ergebnisse wird einfacher, wenn nur die wichtigen Informationen aufbewahrt werden. In Silk Central können sie Regeln definieren, nach denen unbenötigte Ergebnisse und Ergebnisdateien automatisch aufgeräumt werden.
  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie den Knoten aus, für den sie Regeln zur Ergebnisbereinigung erstellen möchten. Alle untergeordneten Knoten erben die festgelegten Regeln. Um Ergebnisbereinigungsregeln speziell für Probeläufe zu erstellen, wählen Sie in der Testsuitehierarchie den Knoten Probelauf aus. Probeläufe beinhalten z.B. hochgeladene Silk Performer Tests und Tests, die nur als Probelauf ausgeführt wurden.
  3. Klicken Sie im Bereich Ergebnisbereiningungs-Regeln auf der Seite Eigenschaften auf Neue Regel. Der Dialog Neue Ergebnisbereiningungs-Regel wird angezeigt.
  4. Geben Sie den Regeltyp an. Sie können entweder nur die Ergebnisdateien löschen, oder ganze Testläufe, inklusive den Ergebnisdateien.
  5. Wählen Sie in der Liste Lösche nach die Zeit aus, nach der die Regel das Löschen auslösen soll. Bereinigungsregeln werden nur ausgelöst, wenn für den ausgewählten Knoten neue Ergebnisse gespeichert werden.
    Anmerkung: Testläufe und Ergebnisdateien werden nicht gelöscht, wenn eine der folgenden Bedingungen gegeben ist:
    • Ein Testlauf mit einem markierten Build ist dabei
    • Ein Testlauf ist dabei, welcher der letzte Testlauf in dieser Testsuite ist
    • Ein Probelauf ist dabei, welcher der letzte Testlauf dieses Tests ist
    • Es gibt nur einen einzigen Testsuitelauf.
  6. Wenn sie den Regeltyp Ergebnisdateien löschen ausgewählt haben, können Sie im Feld Lösche nur Dateien vom Typ das Löschen auf bestimmte Dateitypen einschränken. Geben sie die Dateitypen als Komma-getrennte Liste ein, z.B. bmp, png. Lassen Sie das Feld leer um alle Dateitypen zu löschen.
  7. Klicken Sie auf OK.
Um eine Ergebnisregel zu ändern oder zu löschen, klicken sie auf das Symbol Bearbeiten oder Entfernen. Sie können eine Bereinigungsregel auch deaktivieren, indem den Status aktivieren/deaktivieren. Geerbte Regeln können auf dem Knoten editiert werden, auf dem Sie erstellt wurden.
Übergeordnetes Thema: Verwalten von Testsuiten, Ordnern und Konfigurationssuiten
Zugehörige Tasks
Löschen von Testlaufergebnissen
Löschen von Testläufen und Ergebnisdateien von Testsuiten
Zugehörige Verweise
Eigenschaften von Testsuiten (Seite)


Ausführungsplanungsansichten

Silk Central bietet mehrere Ansichten und Werkzeuge an, mit denen Sie Ihre Testplanung und -ausführung durchführen können.

  • Arbeiten mit der Testsuitehierarchie.
    Hier wird beschrieben, wie die Testsuitehierarchie verwendet wird.
  • Ausführungsplanung - Symbolleistenfunktionen
    Bietet wichtige Befehle zum Verwalten von Testsuiten.
  • Eigenschaften von Testsuiten (Seite)
    Hier werden die Eigenschaften des ausgewählten Elements (Projekt, Ordner, Testsuite, Testzyklus oder Konfigurationssuite) angezeigt.
  • Ausführungsplanung (Dokumentansicht)
    Hier werden die Eigenschaften aller Testsuiten, Ordner und Konfigurationssuiten im ausgewählten Projekt schreibgeschützt angezeigt.
  • Aktueller Testlauf (Seite)
    Diese Seite zeigt alle Informationen über die aktiven Testläufe der ausgewählten Testsuite an.
  • Ausführungsplanungshistorie (Seite)
    Informationen zur Ausführungsplanungshistorie des ausgewählten Projekts.
Übergeordnetes Thema: Ausführungsplanung


Arbeiten mit der Testsuitehierarchie.

Ausführungsplanung > Detailansicht

Ordner, Testsuiten, Konfigurationssuiten und Testzyklen werden in einer hierarchischen Struktur (der Hierarchie Testsuiten) angezeigt, gegliedert und verwaltet. Sie können verschiedene Hierarchie-Ebenen verwenden.

Anmerkung: Wenn die Seite mehr Elemente enthält, als gleichzeitig ohne Verschlechterung der Reaktionszeit angezeigt werden können, werden die Elemente stufenweise angezeigt. Verwenden Sie die Navigationsleiste unten auf der Seite, um die Elemente zu durchsuchen.
  • Tastaturfunktionen (Ausführungsplanung)
    Die Hierarchie kann mit der Tastatur bedient werden und unterstützt die Mehrfachauswahl.
  • Ausblenden und Erweitern der Testsuitehierarchie
    Hier wird beschrieben, wie die verschiedenen Hierarchieebenen der Testsuitehierarchie ausgeblendet und erweitert werden können.
  • Bearbeiten von Elementen der Testsuitehierarchie
    Bearbeiten Sie ein Element der Testsuitehierarchie, um es an veränderte Testanforderungen anzupassen.
  • Kopieren von Elementen der Testsuitehierarchie
    Kopieren Sie ein Element der Testsuitehierarchie und fügen Sie dieses ein, um die zugeordneten Tests, Filter und Ausführungstermine wiederzuverwenden.
  • Löschen von Elementen der Testsuitehierarchie
    Löschen Sie ein Element der Testsuitehierarchie, wenn die in diesem Element enthaltenen Tests nicht mehr benötigt werden.
  • Filtern der Testsuitehierarchie
    Hier wird beschrieben, wie Sie einen Filter zur Testsuitehierarchie hinzufügen.
  • Drucken zugeordneter Tests
    Drucken Sie die zugeordneten Tests als PDF Dokument oder auf einem lokalen Drucker aus.
  • Eigenschaften von Testzyklus (Seite)
    Hier werden die Eigenschaften eines ausgewählten Testzyklus angezeigt.
Übergeordnetes Thema: Ausführungsplanungsansichten


Tastaturfunktionen (Ausführungsplanung)

Die folgenden Aktionen können für die ausgewählten Knoten ausgeführt werden:

Taste | Aktion
Aufwärts | Auswahl nach oben
Abwärts | Auswahl nach unten
Rechts | Element erweitern
Links | Untergeordnete Elemente ausblenden
F2 | Element bearbeiten
Strg+C | Element kopieren
Strg+X | Element ausschneiden
Strg+V | Element einfügen
Entf | Element löschen
Klicken | Ein Element markieren und als aktuelles Element merken.
Strg+Klick | Den Auswahlstatus des gewählten Elements ein- und ausschalten und mit weiteren Klicks weitere Elemente hinzufügen/entfernen.
Umschalt+Klick | Auswahl vom aktuell markierten Element bis zum neu angeklickten Element erweitern.
Umschalt+Nach oben | Das darüberliegende Element auswählen.
Umschalt+Nach unten | Das darunterliegende Element auswählen.
Eingabe | Element zuordnen (nur in den Zuordnungshierarchien)
Übergeordnetes Thema: Arbeiten mit der Testsuitehierarchie.


Ausblenden und Erweitern der Testsuitehierarchie

Sie können je nach Bedarf Hierarchieebenen der Testsuitehierarchie erweitern oder ausblenden.

So können Sie die Hierarchieebenen der Testsuitehierarchie erweitern und ausblenden:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie einen Ordner in der Testsuitehierarchie aus, und führen Sie eine der folgenden Aktionen aus:
    • Klicken Sie auf Erweitern links neben dem Namen des Ordners, um den Ordner zu erweitern.
    • Klicken Sie auf Ausblenden links neben dem Namen des Ordners, um den Ordner auszublenden.
    • Klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Erweitern oder Ausblenden.
Übergeordnetes Thema: Arbeiten mit der Testsuitehierarchie.


Bearbeiten von Elementen der Testsuitehierarchie

So bearbeiten Sie ein vorhandenes Testsuite-Element:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite, den Ordner, den Testzyklus oder die Konfigurationssuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie im Bereich Details auf Bearbeiten. Der Dialog Bearbeiten wird angezeigt.
  4. Sie können das Element bearbeiten, indem Sie die Kriterien im Dialogfeld ändern. Wenn bei Testsuiten einer Testsuite keine Testläufe und keine Tests zugeordnet sind, können Sie für die Testsuite einen anderen Container aus dem Listenfeld Container auswählen.
  5. Klicken Sie auf OK, um das bearbeitete Element zu speichern.
Übergeordnetes Thema: Arbeiten mit der Testsuitehierarchie.
Zugehörige Tasks
Erstellen von Testsuiten
Zugehörige Verweise
Eigenschaften von Testsuiten (Seite)


Kopieren von Elementen der Testsuitehierarchie

So kopieren Sie eine Testsuite, einen Ordner oder eine Konfigurationssuite und fügen diese ein:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie das Element aus, das Sie kopieren möchten.
  3. Klicken Sie in der Symbolleiste auf Kopieren, oder klicken Sie mit der rechten Maustaste auf das Element, und wählen Sie Kopieren aus.
  4. Wählen Sie den Zielordner aus, in den das Element kopiert werden soll.
  5. Klicken Sie in der Symbolleiste auf Einfügen, oder klicken Sie mit der rechten Maustaste auf den Zielknoten, und wählen Sie Einfügen. Die Testsuitehierarchie wird dann mit einer Kopie des eingefügten Elements aktualisiert. Zusammen mit dem Element werden alle zugeordneten Tests, Filter und Ausführungstermine kopiert.
Übergeordnetes Thema: Arbeiten mit der Testsuitehierarchie.


Löschen von Elementen der Testsuitehierarchie

So löschen Sie eine Testsuite, einen Ordner oder eine Konfigurationssuite:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie das Element aus, das Sie löschen möchten.
  3. Klicken Sie in der Symbolleiste auf Löschen, oder klicken Sie mit der rechten Maustaste auf den Elementknoten, und wählen Sie Löschen.
  4. Klicken Sie im Bestätigungsdialogfeld auf Ja, um die Testsuite aus der Testsuitehierarchie zu löschen.

Beim Löschen eines Elements aus der Testsuitehierarchie werden die Ausführungsergebnisse von zugeordneten Tests ebenfalls gelöscht. Die Ausführungsergebnisse des Tests werden evtl. weiterhin in Berichten angezeigt, weil sie in der Datenbank gespeichert sind, die nicht unmittelbar nach dem Löschen des Elements aktualisiert wird.

Übergeordnetes Thema: Arbeiten mit der Testsuitehierarchie.


Filtern der Testsuitehierarchie

Führen Sie zum Filtern der Testsuitehierarchie die folgenden Schritte aus, damit nur der ausgewählte sowie untergeordnete Knoten angezeigt werden. Das ist dann hilfreich, wenn Sie einen Teil der Testsuite in einer PDF-Datei speichern möchten.
  1. Erstellen Sie einen benutzerdefinierten Filter, in dem die Testsuiten festgelegt sind, die Sie anzeigen möchten.
  2. Wählen Sie in der Hierarchie einen Ordner oder eine Konfigurationssuite aus, klicken Sie mit der rechten Maustaste, und wählen Sie Untergeordnete Hierarchie filtern aus.
Übergeordnetes Thema: Arbeiten mit der Testsuitehierarchie.


Drucken zugeordneter Tests

Sie können für jede Testsuite in der Hierarchie Testausführung ein Dokument erstellen, welches Informationen über alle Tests enthält die der Testsuite zugeordnet sind. Sie können dieses Dokument als PDF oder auf einem lokalen Drucker ausdrucken.

So drucken Sie Informationen über alle Tests, welche einer Testsuite zugeordnet sind, aus:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Klicken Sie in der Hierarchie Testausführung mit der rechten Maustaste auf die Testsuite und wählen Sie Zugeordnete Tests drucken. Der Dialog Test-Details wird geöffnet.
  3. Um die Informationen der zugeordneten Tests auf einem lokalen Drucker auszudrucken, klicken Sie Drucken. Um die Informationen in Form eines PDF Dokumentes zu speichern, klicken Sie Download als PDF.
Übergeordnetes Thema: Arbeiten mit der Testsuitehierarchie.


Eigenschaften von Testzyklus (Seite)

Ausführungsplanung > Detailansicht > <Testzyklus> > Eigenschaften

Die Seite Eigenschaften von Testzyklus ist verfügbar, wenn Sie in der Hierarchie Testsuiten einen Testzyklus auswählen und dann auf Eigenschaften klicken.

Klicken Sie auf Eigenschaften bearbeiten, um das Dialogfeld Testzyklus bearbeiten anzuzeigen. Darin können Sie Namen, Beschreibung und Geplante Dauer des Testzyklus bearbeiten.

Die folgende Tabelle enthält die verfügbaren Testzykluseigenschaften.

Eigenschaft | Beschreibung
Testzyklus-Name | Der Name des Testzyklus. Bearbeiten Sie diesen Wert im Dialogfeld Testzyklus bearbeiten. Klicken Sie auf [image] um zum Testzyklus im Bereich Manuelle Ausführungsplanung zu springen.
Testzyklus-ID | Die eindeutige ID des Testzyklus.
Beschreibung | Eine Beschreibung des Testzyklus. Bearbeiten Sie diesen Wert im Dialogfeld Testzyklus bearbeiten.
Status der letzten Ausführung | Der Status ist eine Kombination aller Teststatus des letzten Testlaufs in den Testsuiten des Testzyklus: Bestanden, Fehlgeschlagen, Nicht ausgeführt, oder N/V.
Start der letzten Ausführung | Die Startzeit der letzten Ausführung.
Testzyklus Startdatum | Das geplante Startdatum des Testzyklus.
Testzyklus Enddatum | Das geplante Enddatum des Testzyklus.
Kapazität [hh:mm] | Die erwartete Dauer des Testzyklus. Bearbeiten Sie diesen Wert im Dialogfeld Testzyklus bearbeiten. Wenn Sie dem Testzyklus manuelle Tester zuordnen, ist der Wert für Kapazität die Summe der Kapazität-Werte der einzelnen manuellen Tester.
Geplante Dauer [hh:mm] | Die kumulative geplante Dauer aller manuellen Tests in allen zugeordneten Testsuiten des Testzyklus.
Verbleibende Zeit [hh:mm] | Die nach Abzug der Geplanten Dauer von der Kapazität verbleibende Zeit.
Erstellt am | Das Datum der Erstellung des Testzyklus.
Erstellt von | Der Benutzer, der den Testzyklus erstellt hat.
Geändert am | Das Datum, an dem der Testzyklus zuletzt modifiziert wurde.
Geändert Von | Der Benutzer, der den Testzyklus zuletzt modifiziert hat.

Zugewiesene Tester

In diesem Bereich werden alle manuellen Tester aufgeführt, die an diesem Testzyklus mitarbeiten.

Eigenschaft | Beschreibung
Tester | Der Name des Testers.
Kapazität | Geben Sie hier im Format hh:mm an, wie lange dieser Tester für den Testzyklus verfügbar ist. Die Summe aller Kapazitätswerte der einzelnen Tester ergibt den Wert für die Kapazität des Testzyklus.
Manuelle Tester zuordnen | Klicken Sie hier, um das Dialogfeld Manuelle Tester zuordnen anzuzeigen, in dem Sie dem Testzyklus Tester zuordnen können.
Übergeordnetes Thema: Arbeiten mit der Testsuitehierarchie.
Zugehörige Konzepte
Manuelle Ausführungsplanung
Zugehörige Verweise
Eigenschaften von Testsuiten (Seite)
Testsuiteläufe (Seite)


Ausführungsplanung - Symbolleistenfunktionen

Ausführungsplanung > Detailansicht

Ausführungsplanung > Dokumentansicht

In der Testausführungssymbolleiste können Sie auf die wichtigsten Befehle für die Arbeit mit Testsuiten zugreifen.

Anmerkung: Die Befehle in der Symbolleiste für die Ausführungsplanung sind in der Testsuitehierarchie auch in Kontextmenüs verfügbar.

Die folgenden Befehle sind in der Symbolleiste für die Ausführungsplanung verfügbar:

Befehl | Symbol | Beschreibung
Detailansicht | Anforderungsansicht | Öffnet die Detailansicht, in der Sie die Eigenschaften eines einzelnen Elements der Testsuitehierarchie detailliert anzeigen können.
Dokumentansicht | Dokumentansicht | Öffnet die Dokumentansicht, in der ausgewählte Eigenschaften aller Testausführungen in einer einzigen Ansicht angezeigt werden.
Neuer untergeordneter Ordner | Dokumentansicht | Fügt einen neuen Ordner zu dem ausgewählten Projekt oder Ordner hinzu. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Neuer untergeordneter Testzyklus | Dokumentansicht | Fügt einen neuen Testzyklus zu dem ausgewählten Projekt oder Ordner hinzu.
Neue untergeordnete Konfigurationssuite | Dokumentansicht | Fügt eine neue Konfigurationssuite zu dem ausgewählten Projekt oder Ordner hinzu. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Neue untergeordnete Testsuite | Dokumentansicht | Fügt eine neue Testsuite zu dem ausgewählten Projekt, dem Ordner oder der Konfigurationssuite hinzu. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Bearbeiten | Bearbeiten | Öffnet das ausgewählte Element der Testsuitehierarchie zum Bearbeiten.
Löschen | Löschen | Löscht das ausgewählte Element aus der Testsuitehierarchie. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Ausschneiden | Ausschneiden | Schneidet ein Element der Testsuitehierarchie aus und speichert es in der Zwischenablage. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Kopieren | Kopieren | Kopiert ein Element der Testsuitehierarchie in die Zwischenablage. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Einfügen | Einfügen | Fügt ein Element aus der Zwischenablage in die Testsuitehierarchie ein. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Als untergeordnetes Element einfügen | Als untergeordnetes Element einfügen | Fügt ein Element aus der Zwischenablage als untergeordnetes Element in das aktuell ausgewählte Element der Testsuitehierarchie ein. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Ausführen |  | Starten Sie die Ausführung der Tests, die der Testsuite zugeordnet sind. Dieser Befehl ist deaktiviert für Testsuiten, die einem Testzyklus zugeordnet sind.
Neuer Filter | Neuer Filter | Erstellt einen neuen benutzerdefinierten Filter für die Testsuitehierarchie.
Filter |  | Listet die verfügbaren Filter für die Testsuitehierarchie auf.
Filter bearbeiten | Filter bearbeiten | Bearbeiten Sie den aktuell ausgewählten benutzerdefinierten Filter.
Filter löschen | Filter löschen | Löschen Sie den aktuell ausgewählten benutzerdefinierten Filter.
Filter kopieren | Filter löschen | Kopieren Sie den aktuell ausgewählten benutzerdefinierten Filter.
Download als PDF | Download als PDF | Diese Funktion ist nur in der Dokumentansicht aktiviert. Es wird eine PDF-Datei erzeugt, die alle aktuell sichtbaren Knoten der Testsuitehierarchie enthält.
Übergeordnetes Thema: Ausführungsplanungsansichten


Eigenschaften von Testsuiten (Seite)

Ausführungsplanung > Detailansicht > <Element der Testsuitehierarchie> > Eigenschaften

Auf der Seite Eigenschaften können Sie auf alle Eigenschaften des ausgewählten Elements (Projekt, Ordner, Testsuite, Testzyklus oder Konfigurationssuite) zugreifen. Sie können die Informationen in jedem Bereich auf dieser Seite erweitern oder ausblenden. Dadurch können Sie genau die Informationen anzeigen, die für Sie von Interesse sind.

Details

Der Bereich Details zeigt allgemeine Informationen über das ausgewählte Element an. Weitere Information finden sie unter Erstellen von Testsuiten und Bearbeiten von Elementen der Testsuitehierarchie.

Ausführungsstatus

Der Bereich Ausführungsstatus zeigt Informationen über die letzten Testläufe an. Der Status der letzten Ausführung zeigt den kumulierten Teststatus des letzten Testlaufs einer Testsuite an, oder den kumulierten Teststatus aller enthaltenen Testsuiten, für einen Ordner oder eine Konfigurationssuite. Die Dauer zeigt die Dauer des letzten Laufs einer Testsuite. Handelt es sich um Ordner oder Konfigurationssuiten, wird die kumulierte Dauer der letzten Läufe aller enthaltenen Testsuiten angezeigt. Im einfachsten Fall (automatisierte Tests auf lediglich einem Ausführungsserver oder nur manuelle Tests) entspricht die Dauer der Zeitspanne, die auf der Seite Testläufe für die letzte Ausführung angezeigt wird. Bei einer Kombination von automatisierten und manuellen Tests werden nur die automatisierten oder die manuellen Tests berücksichtigt, je nachdem, welche Tests später ausgeführt wurden. Wenn die Testsuite mehrere Tests enthält, wird die Dauer vom Start des ersten Tests bis zum Abschluss des letzten Tests gemessen. Zur Dauer zählt auch die zum Starten und Stoppen der Tests zwischen den Ausführungen benötigte Zeit.

Weitere Information finden Sie unter Analysieren von Testläufen.

Testausführungs-Setup

Der Bereich Testausführungs-Setup zeigt Informationen über zugewiesene Tests und Tester an. Weitere Information finden Sie unter Verwalten von Testsuiten, Ordnern und Konfigurationssuiten und Testzuordnung.

Attribute

Attribute sind frei erstellbare Merkmale, die auf Testsuiten angewendet werden können. Weitere Informationen finden Sie unter Testsuite-Attribute.

Parameter

Der Parameter-Bereich zeigt Informationen über Parameter an, welche frei konfigurierbare Eingabewerte für Testsuiten sind. Weitere Informationen finden Sie unter Testsuiteparameter.

Benachrichtigungen und Berichte

Mit den Kontrollkästchen im Bereich Benachrichtigungen und Berichte können Sie festlegen, ob Sie abhängig vom Ergebnis der Testausführung benachrichtigt werden möchten. Die Benachrichtigungsfunktion kann nur verwendet werden, wenn ein E-Mail-Server vom Administrator konfiguriert wurde. Sie müssen auch unter <Benutzername> > Benutzereinstellungen eine E-Mail-Adresse für Ihr Konto angeben. Zusätzliche können Sie Berichtsabonnemente auslösen, basierend auf dem Ergebnis der Ausführung. Die Liste der verfügbaren Berichte basiert auf den Berichten, für die ein Abonnement definiert wurde. Weitere Information finden Sie unter Verwalten von Berichtsabonnements.

Auswahlfeld | Beschreibung
Testsuiteläufe erfolgreich beendet wurden | Markieren Sie dieses Kontrollkästchen, um eine Benachrichtigungs-E-Mail zu erhalten, wenn ein Testsuitelauf erfolgreich beendet wurde.
Testsuiteläufe mit nicht bestandenen Tests beendet wurden | Markieren Sie dieses Kontrollkästchen, um eine Benachrichtigungs-E-Mail zu erhalten, wenn ein Testsuitelauf mit dem Status Nicht ausgeführt oder Fehlgeschlagen beendet wurde.
Testsuiteläufe abgeschlossen wurden, deren Anzahl nicht bestandener Tests sich geändert hat | Markieren Sie dieses Kontrollkästchen, um eine Benachrichtigungs-E-Mail zu erhalten, wenn sich beim Beenden der Ausführung die Anzahl von fehlgeschlagenen oder nicht ausgeführten Tests im Vergleich zum vorherigen Testlauf geändert hat.

Ergebnisbereiningungs-Regeln

Im Bereich Ergebnisbereiningungs-Regeln können sie Regeln definieren, um nicht mehr relevante Ergebnisse und Ergebnisdateien von Testsuiteläufen zu bereinigen. Weitere Information finden Sie unter Ergebnisse und Ergebnisdateien automatisch löschen.

Übergeordnetes Thema: Ausführungsplanungsansichten
Zugehörige Konzepte
Testen von Konfigurationen
Zugehörige Tasks
Bearbeiten von Elementen der Testsuitehierarchie
Erstellen von Testsuiten
Ergebnisse und Ergebnisdateien automatisch löschen
Verwalten von Berichtsabonnements
Zugehörige Verweise
Testsuiteläufe (Seite)


Ausführungsplanung (Dokumentansicht)

Ausführungsplanung > Dokumentansicht

Der Bereich Ausführungsplanung bietet zwei Ansichten auf Ausführungseigenschaften: Dokumentansicht und Detailansicht. Die Dokumentansicht bietet eine allgemeine, schreibgeschützte Ansicht der festgelegten Eigenschaften und Merkmale des letzten Testlaufs aller Testsuiten, Ordner und Konfigurationssuiten in dem ausgewählten Projekt. Mit der Dokumentansicht können Sie die Ausführung Ihrer Testsuiten planen. Durch die Anwendung von Filtern erhalten Sie eine Schätzung der Ausführungsdauer für die gefilterte Testsuitemenge.

In der Dokumentansicht werden zu einem ausgewählten Element in der Testsuitehierarchie die folgenden Spalten angezeigt:

Spalte | Beschreibung
Status | Die kumulierten Teststatus des letzten Testlaufs einer Testsuite, oder die kumulierten Teststatus aller enthaltenen Testsuiten, für einen Ordner oder eine Konfigurationssuite. Wenn Sie die Hierarchie Testsuiten filtern, basieren die Gesamtwerte der Teststatus lediglich auf den gefilterten Testsuiten.
Zugeordnete Tests | Gesamtzahl zugeordneter Tests. Wenn Sie die Hierarchie Testsuiten filtern, basiert die Anzahl der zugeordneten Tests lediglich auf den gefilterten Testsuiten.
Build | Das bei der Ausführung einer Testsuite verwendete Build.
Version | Die bei der Ausführung einer Testsuite verwendete Version.
Produkt | Produkt, auf dem der zugeordnete Container basiert.
Priorität | Bei automatisierten Testsuiten, wenn sich mehr als eine Testsuite in der Warteschlange befindet, aber nur ein Ausführungsserver verfügbar ist, werden die Testsuiten nach Priorität ausgeführt. Das Gleiche gilt auch, wenn zwar ein Ausführungsserver verfügbar ist, aber mehrere Testsuiten ein nicht verfügbares Mobilgerät benötigen.
Letzte Testausführung | Zeitpunkt, zu dem die Testsuite zum letzten Mal gestartet wurde.
Geplante Dauer | Geplante Gesamtzeit für alle manuellen Tests. Wenn Sie die Hierarchie Testsuiten filtern, basiert die geplante Zeit lediglich auf den gefilterten Testsuiten.
Dauer | Dauer des letzten Laufs einer Testsuite. Handelt es sich um Ordner oder Konfigurationssuiten, wird die kumulierte Dauer der letzten Läufe aller enthaltenen Testsuiten angezeigt. Wenn Sie die Hierarchie Testsuiten filtern, basiert die Dauer lediglich auf den gefilterten Testsuiten.
Nächste Testausführung | Der nächste geplante Termin für die Ausführung.
Container | Container mit allen Tests, die zu dieser Testsuite zugeordnet werden können.
Attribute | Wenn Sie Ihren Testsuiten Attribute zugeordnet haben, können Sie auswählen, dass diese in der Tabelle angezeigt werden. Attribute sind frei erstellbare Merkmale, die auf Testsuiten angewendet werden können. Sie können Attribute für das Filtern und die Berichterstellung verwenden.
Anmerkung: Die Testsuite-Gesamtwerte aller derzeitig angezeigten Testsuiten werden auf übergeordneter Ebene zusammengefasst. Wenn Sie die Hierarchie Testsuiten filtern, basieren die Testsuite-Gesamtwerte lediglich auf den gefilterten Testsuiten. Beispielsweise enthalten die Testsuite-Gesamtwerte Testläufe von allen untergeordneten Testsuiten, die mit dem Filter ausgewählt wurden, während die Projektgesamtwerte Testläufe von allen Testsuiten enthalten, die mit dem Filter ausgewählt wurden.
Übergeordnetes Thema: Ausführungsplanungsansichten


Aktueller Testlauf (Seite)

Ausführungsplanung > Detailansicht > <Testsuite> > Aktueller Testlauf

Zum Öffnen der Seite Aktueller Testlauf klicken Sie in der Testsuitehierarchie auf die gewünschte Testsuite und dann auf die Registerkarte Aktueller Testlauf. Die Seite Aktueller Testlauf zeigt alle Informationen über die aktiven Testläufe der ausgewählten Testsuite an. Für manuelle und automatisierte Testläufe werden unterschiedliche Seiten angezeigt.

Manuelle Testläufe

Auf der Seite Aktueller Testlauf wird der aktive manuelle Testlauf so lange angezeigt, bis er abgeschlossen ist. Für manuelle Tests, die einem Testzyklus zugeordnet sind, lautet der Titel der Seite Testlauf. Auf der Seite Testlauf wird der Testlauf auch nach dem Abschluss weiterhin angezeigt. Die Seite enthält zwei Tabellenansichten: Zugeordnete Tests und Testschritte. Zugeordnete Tests zeigt Informationen über den aktiven manuellen Testlauf und Testschritte Informationen über jeden Schritt des manuellen Tests. Sie können die Testläufe in der Ansicht Zugeordnete Tests nach ausgewählten Spalten filtern. Die Ansichten Details der Tests und Details des Testschritts enthalten zusätzliche Informationen.

Klicken Sie auf Neu laden, um die Seite Aktueller Testlauf neu zu laden. Wenn Sie die Testzuordnung in einer Testsuite geändert haben oder wenn Sie im Bereich Tests aktualisierte Tests haben, und Sie möchten diese Änderungen in den aktuellen Testlauf übernehmen, klicken Sie auf Aktuellen Testlauf synchronisieren. Dadurch werden alle zugeordneten Tests des aktuellen Testlaufs aktualisiert.

Wenn ein Testsuitelauf gestartet wird, während der Aktuelle Testlauf noch nicht beendet wurde, wird ein Hinweis angezeigt, dass neuere Testläufe verfügbar sind. Auf der Seite Aktivitäten können Sie Informationen über diese Testläufe einsehen.

Automatisierte Testläufe

Bei automatisierten Tests wird auf der Seite Aktueller Testlauf der Fortschritt der Ausführung angezeigt. Klicken Sie auf Aktualisieren, um die Seite Aktueller Testlauf neu zu laden. Für automatisierte Tests die auf einem mobilen Gerät laufen, klicken Sie auf Bildschirmvideo anzeigen um einen Live-Stream der Aktivitäten auf dem Gerät anzuschauen. Für Sauce Labs Geräte stehen keine Live-Streams zur Verfügung.

Übergeordnetes Thema: Ausführungsplanungsansichten
Zugehörige Tasks
Zuordnen von vorhandenen Fehlern


Ausführungsplanungshistorie (Seite)

Ausführungsplanung > Detailansicht > <Projekt> > Historie

Auf der Seite Historie werden Details zur Ausführungsplanungshistorie des ausgewählten Projekts angezeigt. Sie können Spalten anzeigen oder ausblenden, die Breite anpassen und Spalten verschieben, um deren Reihenfolge zu ändern. Klicken Sie auf die Spalten, um den Inhalt dieser zu filtern. Bei folgenden Aktionen werden Einträge in die Ausführungsplanungshistorie geschrieben:

  • Löschen einer Testsuite, eines Ordners, eines Testzyklus, einer Konfigurationssuite oder einer Konfiguration.
Anmerkung: Wenn die Seite mehr Elemente enthält, als gleichzeitig ohne Verschlechterung der Reaktionszeit angezeigt werden können, werden die Elemente stufenweise angezeigt. Verwenden Sie die Navigationsleiste unten auf der Seite, um die Elemente zu durchsuchen.
Übergeordnetes Thema: Ausführungsplanungsansichten


Arbeiten mit Silk Performer-Projekten

Silk Performer ist vollständig in die Silk Central-Bereiche Tests und Ausführungsplanung integriert. Silk Performer-Projekte können in Silk Central-Tests integriert und über Silk Central direkt ausgeführt werden. Dadurch stehen leistungsfähige Funktionen zur Analyse von Testergebnissen und Berichtserstellung zur Verfügung. Außerdem können Tests in Silk Central durch vorkonfigurierte Ausführungstermine automatisiert ausgeführt werden.

Informationen zum Konfigurieren der Silk Performer-Integration in Silk Performer finden Sie in der Hilfe von Silk Central.

Silk Performer-Projektdateien können von Silk Performer aus direkt in Silk Central geöffnet werden, um Skripts und Einstellungen zu ändern. Die geänderten Silk Performer-Projekte können dann wieder zu Silk Central übertragen werden, damit sie für zukünftige Testausführungen verfügbar sind.

Anmerkung: Der Begriff "Projekt" wird in Silk Performer und in Silk Central unterschiedlich verwendet. Ein Silk Performer-Projekt, das Sie zu Silk Central hochladen, wird zum Kernelement eines Silk Central-Tests. Silk Central-Projekte sind Entitäten der obersten Ebene, die mehrere Silk Performer-Projekte, Tests, Testsuiten und Anforderungen enthalten können.
  • Herunterladen von Silk Performer-Projekten
    Laden Sie Silk Performer-Projekte herunter, um unabhängig von Silk Central damit arbeiten zu können.
  • Öffnen von Silk Performer-Projekten
    Öffnen Sie Silk Performer-Projekte aus Silk Central zum Bearbeiten in Silk Performer.
  • Zugreifen auf Eigenschaften von Testsuiteläufen
    Während Silk Central Tests ausführt, stellt Silk Performer Informationen zu den Eigenschaften von Testsuiteläufen zur Verfügung.
  • Ausführen lokaler Silk Performer-Tests
    Führen Sie lokale Silk Performer-Tests zur manuellen Ausführung des Tests in Silk Performer aus.
  • Bearbeiten von Silk Performer-Testeigenschaften
    Bearbeiten Sie Silk Performer-Testeigenschaften, um sie an veränderte Anforderungen anzupassen.
  • Analysieren von Silk Performer-Testergebnissen
    Hier wird das Analysieren von Silk Performer-Testergebnissen beschrieben.
  • Herunterladen von Silk Performer-Testergebnissen
    Laden Sie Silk Performer-Testergebnisse herunter, um die vollständigen Ergebnisse eines bestimmten Testlaufs zu analysieren.
  • Hochladen von Silk Performer Testergebnissen
    Laden Sie Silk Performer-Testergebnisse zu Silk Central hoch, um sie einem Test zuzuordnen.
  • Arbeiten mit Silk Performance Explorer
    Mit Silk Performance Explorer können die Testläufe eingehend analysiert werden.
Übergeordnetes Thema: Ausführungsplanung
Zugehörige Konzepte
Silk Performer-Tests
Testparameter
Zugehörige Tasks
Erstellen oder Bearbeiten von Silk Performer-Tests
Zugehörige Verweise
Vordefinierte Parameter
Zugriff auf Silk Central-Parameter über Java-Systemeigenschaften


Herunterladen von Silk Performer-Projekten

Wenn Sie ein Silk Performer-Projekt öffnen, müssen Sie möglicherweise ein Silk Performer-Projekt aus einem Versionsverwaltungsprogramm auschecken, dann in Silk Performer bearbeiten und anschließend wieder in Silk Central einchecken. Dagegen wird beim Herunterladen eines Projekts eine eigenständige Kopie für die Arbeit in Silk Central erstellt. Die an den heruntergeladenen Projekten vorgenommenen Änderungen werden nicht automatisch in Silk Central übernommen.

So laden Sie ein Silk Performer-Projekt herunter:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Silk Performer-Test aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Scrollen Sie herunter zum Abschnitt Silk Performer-Testeigenschaften.
  5. Klicken Sie auf Projekt herunterladen. Es wird ein Dialogfeld mit der Frage angezeigt, ob Sie das angegebene Silk Performer-Projekt auf das lokale System herunterladen möchten.
  6. Klicken Sie auf Speichern, um die Datei in Silk Performer zu öffnen. Wenn Silk Performer noch nicht im Hintergrund geöffnet ist, wird das Programm gestartet.
  7. Das Dialogfeld Select Target Directory wird mit dem Standardpfad zum Speichern des angegebenen Silk Performer-Projekts geöffnet. Wenn Sie den vorgeschlagenen Pfadnamen verwenden möchten, klicken Sie auf OK. Klicken Sie andernfalls auf Browse, und wählen Sie den gewünschten Pfad aus.
    Anmerkung: Selbst wenn Sie eine Versionsverwaltungsintegration konfiguriert haben, werden Sie nicht zum Auschecken des Silk Performer-Projekts aufgefordert, da Sie mit einer eigenständigen Kopie außerhalb von Silk Central arbeiten.
    Anmerkung: Die von Silk Performer verwendeten Silk Central-Projekte können auch direkt in Silk Performer heruntergeladen werden. Weitere Informationen hierzu finden Sie in der Dokumentation zu Silk Performer.
Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten


Öffnen von Silk Performer-Projekten

So öffnen Sie ein Silk Performer-Projekt in Silk Central:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Silk Performer-Test aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Scrollen Sie herunter zum Abschnitt Silk Performer-Testeigenschaften.
  5. Klicken Sie auf Silk Performer-Projekt öffnen. Ein Dialog wird mit der Frage angezeigt, ob Sie die angegebene Silk Performer-Befehlsdatei (.spwbcmd) in Silk Performer öffnen möchten.
  6. Klicken Sie auf Öffnen, um die Datei in Silk Performer zu öffnen. Wenn Silk Performer noch nicht im Hintergrund geöffnet ist, wird das Programm gestartet. Der Dialog Select Target Directory wird mit dem Standardpfad zum Speichern des angegebenen Silk Performer-Projekts geöffnet.
  7. Wenn Sie den vorgeschlagenen Pfadnamen verwenden möchten, klicken Sie auf OK. Klicken Sie andernfalls auf Browse, und wählen Sie den gewünschten Pfad aus.
  8. Wenn Sie eine Versionsverwaltungsintegration für Silk Central konfiguriert haben (z. B. StarTeam), wird nun ein Anmeldefenster für den Versionsverwaltungsclient angezeigt. Geben Sie Ihre Anmeldeinformationen ein, und klicken Sie auf OK.
    Anmerkung: Die von Silk Performer verwendeten Silk Central-Projekte können auch direkt in Silk Performer geöffnet werden. Weitere Informationen hierzu finden Sie in der Dokumentation zu Silk Performer.
Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten


Zugreifen auf Eigenschaften von Testsuiteläufen

Während Silk Central Tests ausführt, stellt Silk Performer Informationen zu den Eigenschaften von Testsuiteläufen zur Verfügung. Mit den AttributeGet-Methoden können Sie auf die Testsuitelauf-Eigenschaften des Silk Performer-Skripts zugreifen. Die Werte der folgenden Eigenschaften können abgerufen werden:
Parameter
Beschreibung
#sctm_execdef_name
Der Name der aktuell ausgeführten Testsuite. Wenn die Ausführung aus dem Bereich Testplan heraus ausgelöst wurde, hat der Parameter den Wert Probelauf.
#sctm_execdef_id
Die numerische ID (Datenbankschlüssel) der Testsuite, die aktuell ausgeführt wird.
#sctm_product
Der im ausgeführten Container angegebene Name des Produkts.
#sctm_version
Der Name der Version, mit der die Ergebnisse der Ausführung assoziiert sind.
#sctm_build
Der Name der Version, mit der die Ergebnisse der Ausführung assoziiert sind.
#sctm_keywords
Eine durch Komma getrennte Liste mit Schlüsselwörtern, die für diese Testsuite definiert sind.
#sctm_test_results_dir
Der Verzeichnispfad, in dem die Ergebnisdateien des Tests liegen.
#sctm_test_name
Der Name des durchgeführten Silk Central Tests.
#sctm_test_id
Der numerische Bezeichner (Datenbankschlüssel) des durchgeführten Tests.
#sctm_source_root_dir
Der lokale Pfad des Hauptverzeichnisses vom Container, wo sich alle Dateien unter Versionsverwaltung befinden.
#external_id
Die eindeutige Kennung eines Tests in einem auszuführenden Testpaket. Diese kann als Filter verwendet werden, wenn nur bestimmte Tests in einem Testpaket ausgeführt werden sollen.

#is_test_package_root
Wenn true zutrifft, ist der ausgeführte Test der Stammknoten im Testpaket (Standardeinstellung). Wenn false zutrifft, werden nur durch #external_id definierte Tests im Testpaket ausgeführt.
#sctm_data_driven_parent_test_name
Der Name des übergeordneten Tests, falls der ausgeführte Test eine Datengetriebene Zeile ist.
#sctm_data_driven_parent_test_id
Die numerische Kennung (Datenbankschlüssel) des übergeordneten Tests, falls der ausgeführte Test eine Datengetriebene Zeile ist.
Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten


Ausführen lokaler Silk Performer-Tests

Lokale Tests sind Silk Performer-Tests, die manuell in Silk Performer und nicht mit einem vordefinierten Ausführungstermin automatisiert in Silk Central ausgeführt werden.

Anmerkung: Wenn Sie die datengetriebene Testfunktion von Silk Central mit Silk Performer-Skripts nutzen möchten, müssen Datenquellen mit Spaltennamen, die mit den entsprechenden Silk Performer-Projektattributen übereinstimmen, in Verbindung mit AttributeGet-Methoden verwendet werden (Kennwort-Attribute können nicht übergeben werden, sondern verwenden immer den im Skript definierten Wert).

So führen Sie einen lokalen Test in Silk Performer aus:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Silk Performer-Test aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Scrollen Sie herunter zum Abschnitt Silk Performer-Testeigenschaften.
  5. Klicken Sie auf Lokal ausführen. Ein Dialog wird mit der Frage angezeigt, ob Sie die angegebene Silk Performer-Befehlsdatei (.spwbcmd) ausführen möchten.
  6. Klicken Sie auf Öffnen, um das Projekt in Silk Performer zu öffnen. Wenn Silk Performer noch nicht im Hintergrund geöffnet ist, wird das Programm gestartet. Der Dialog Select Target Directory wird mit dem Standardpfad zum Speichern des angegebenen Silk Performer-Projekts geöffnet.
  7. Wenn Sie den vorgeschlagenen Pfadnamen verwenden möchten, klicken Sie auf OK. Klicken Sie andernfalls auf Browse, und wählen Sie den gewünschten Pfad aus. Der Dialog Silk Performer Workload Configuration wird mit den Lasttest-Einstellungen, die dem Silk Performer-Projekt zugeordnet sind, geöffnet.
  8. Nehmen Sie die gewünschten Lasttest-Einstellungen vor, und klicken Sie auf Run, um den Test zu starten und das Testergebnis in Silk Performer zu überwachen.
    Anmerkung: Wenn Sie auf Run klicken, ohne vorher die Lasttest-Einstellungen zu bearbeiten, wird der Silk Performer-Test genauso ausgeführt, als ob er direkt in Silk Central nicht lokal ausgeführt wird.
Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten


Bearbeiten von Silk Performer-Testeigenschaften

Anmerkung: Wenn Sie die datengetriebene Testfunktion von Silk Central mit Silk Performer-Skripts nutzen möchten, müssen Datenquellen mit Spaltennamen, die mit den entsprechenden Silk Performer-Projektattributen übereinstimmen, in Verbindung mit AttributeGet-Methoden verwendet werden.

So bearbeiten Sie die Silk Performer-Testeigenschaften:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Silk Performer-Test aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Scrollen Sie herunter zum Abschnitt Silk Performer-Testeigenschaften.
  5. Klicken Sie auf Silk Performer-Testeigenschaften bearbeiten.
  6. Fahren Sie mit der Konfiguration des Silk Performer-Tests fort.
Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten


Analysieren von Silk Performer-Testergebnissen

Mit Performance Explorer können die Silk Performer-Testergebnisse eingehend analysiert werden. Sie können dazu mit der Schaltfläche Ergebnisse analysieren die gewünschten Ergebnisse herunterladen. Zur Unterstützung der Analyse Ihrer Optimierungsschritte können Sie in Performance Explorer sogar die Statistiken mehrerer Testläufe mit Hilfe von benutzerdefinierten Vergleichsberichten direkt miteinander vergleichen.

Die Ergebnisse der mit Silk Central ausgeführten Tests können durch die entsprechenden Optionen auf der Seite Testläufe im Bereich Tests automatisch in Performance Explorer geladen werden.

Informationen zur Verwendung von Performance Explorer und zur Integration von Silk Performer in Silk Central finden Sie in der Dokumentation zu Silk Performer.

So öffnen Sie Silk Performer-Testergebnisse in Performance Explorer:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test aus, den Sie anzeigen möchten.
  3. Klicken Sie auf die Registerkarte Testläufe.
  4. Klicken Sie auf Ergebnisse analysieren in der Spalte Aktionen des Testlaufs, dessen Ergebnisse Sie herunterladen möchten. Ein Dialog Dateidownload wird mit dem Namen der Performance Explorer-Befehlsdatei (.sppecmd) angezeigt, die Sie herunterladen.
  5. Klicken Sie auf Öffnen, um die Ergebnisse in Performance Explorer zu öffnen. Sie können auch auf Speichern klicken, um die Ergebnisse lokal zu speichern.
  6. Wenn Performance Explorer noch nicht im Hintergrund geöffnet ist, wird das Programm jetzt gestartet. Es stellt dann eine Verbindung mit der Silk Central-Installation her und ruft die Ergebnisse des ausgewählten Testlaufs ab.
    Anmerkung: Zur Vorbereitung eines benutzerdefinierten Vergleichsberichts, in dem das Ergebnis mehrerer Testausführungen miteinander verglichen wird, können Sie die Ergebnisse weiterer Testausführungen auf der Seite Testläufe herunterladen. Die zusätzlichen Ausführungsergebnisse werden in der vorhandenen Instanz von Performance Explorer auf der Silk Central-Multifunktionsleiste angezeigt. Weitere Informationen zu benutzerdefinierten Vergleichsberichten finden Sie in der Dokumentation zu Performance Explorer.
Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten


Herunterladen von Silk Performer-Testergebnissen

Sie können die Testergebnisse herunterladen, wenn Sie die vollständigen Ergebnisse eines bestimmten Testlaufs analysieren oder eine komplette Analyse offline durchführen möchten. Da die Ergebnispakete häufig sehr große TrueLog-Fehlerdateien enthalten, können sie komprimiert und als LRZ-Dateien auf die lokale Festplatte heruntergeladen werden. Das Herunterladen auf den lokalen Computer ist auch bei einer langsamen Internetverbindung zu empfehlen.

So laden Sie Silk Performer-Testergebnisse herunter:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Hierarchie Tests einen Silk Performer-Test aus.
  3. Klicken Sie auf die Registerkarte Testläufe.
  4. Klicken Sie auf Ergebnisse herunterladen in der Spalte Aktionen des Testlaufs, dessen Ergebnisse Sie herunterladen möchten. Das Dialogfeld Dateidownload wird mit dem Namen der komprimierten Paketdatei (.ltz) angezeigt, die Sie herunterladen möchten.
  5. Klicken Sie auf Öffnen, um die Ergebnisse in Performance Explorer zu öffnen. Sie können auch auf Speichern klicken, um die Ergebnisse lokal zu speichern.
  6. Wenn Performance Explorer noch nicht im Hintergrund geöffnet ist, wird das Programm nun gestartet. Das Dialogfeld Projekt importieren wird mit dem Zielverzeichnis zum Speichern des Ergebnisses angezeigt. Wenn Sie das vorgeschlagene Verzeichnis verwenden möchten, klicken Sie auf OK. Klicken Sie andernfalls auf Durchsuchen, und wählen Sie den gewünschten Pfad aus. Die heruntergeladenen Ergebnisse werden dann in Performance Explorer angezeigt.
    Anmerkung: Wenn Sie das vorgeschlagene Projektverzeichnis verwenden, in dem die Ergebnispakete normalerweise gespeichert werden (im Allgemeinen empfohlen), dann werden die Ergebnisse mit allen anderen Silk Performer-Ergebnissen gespeichert, und Sie können mit dem Performance Explorer-Befehl Lasttestergebnisse hinzufügen darauf zugreifen.
Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten


Hochladen von Silk Performer Testergebnissen

Nachdem Sie einen lokalen Test in Silk Performer ausgeführt haben, können Sie das Testergebnis zu Silk Central hochladen und einem Test zuordnen.

So laden Sie das Ergebnis eines lokalen Silk Performer-Tests hoch:

  1. Führen Sie einen lokalen Silk Performer-Test aus. Weitere Informationen finden Sie unter Ausführen lokaler Silk Performer-Tests.
  2. Klicken Sie nach Abschluss des Tests im Menü Ergebnisse auf Upload Results to Silk Central. Das Fenster Anmelden des Assistenten Upload Results to Silk Central wird angezeigt.
  3. Geben Sie Ihr Kennwort ein, und klicken Sie auf Weiter.
    Anmerkung: Da es sich um einen lokalen Test handelt, sind dem Assistenten bereits der Hostname und Benutzername der Test bekannt, zu der die Testergebnisse hochgeladen werden sollen.
  4. Wählen Sie das Silk Central-Projekt aus, zu dem die Silk Performer-Ergebnisse hochgeladen werden sollen.
  5. Wählen Sie in der Hierarchieansicht den Test aus, zu dem die Ergebnisse hochgeladen werden sollen. Klicken Sie auf Weiter.
    Anmerkung: Sie können durch Klicken mit der rechten Maustaste über das Kontextmenü der Hierarchieansicht neue Tests, untergeordnete Tests, Ordner und/oder untergeordnete Ordner erstellen und dann dort die Ergebnisse speichern.
  6. Im nächsten Fenster können Sie die Versions- und Build-Nummer des zugeordneten Produkts eingeben, zu dem die hochgeladenen Ergebnisse gehören. Geben Sie außerdem den Status des Silk Performer-Tests an (z. B. Bestanden oder Fehlgeschlagen).
    Anmerkung: Falls während des Testlaufs Fehler aufgetreten sind, wird automatisch der Status Fehlgeschlagen zugewiesen.
  7. Klicken Sie auf Fertig stellen, um die Ergebnisse hochzuladen. Die hochgeladenen Ergebnisse werden unter Tests > Detailansicht > <Silk Performer Test> > Testläufe angezeigt.
Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten
Zugehörige Tasks
Ausführen lokaler Silk Performer-Tests


Arbeiten mit Silk Performance Explorer

Mit Silk Performance Explorer(Performance Explorer) können die Testläufe eingehend analysiert werden. Die Performance Explorer-Ergebnisanalyse kann direkt über die Testläufe auf der Seite Testläufe in den Bereichen Testausführungen und im Bereich Tests von Silk Central bzw. auf Performance Explorer selbst durchgeführt werden. Details zur Integration von Performance Explorer mit Silk Central finden Sie in der Performance Explorer-Dokumentation.

Die Ergebnisse von Ladungstestläufen in Silk Performer können auch auf Silk Central hochgeladen und den jeweiligen Tests zugeordnet werden. Weitere Informationen hierzu finden Sie in der Silk Performer-Hilfe.

Weitere Informationen zur Integration von Silk Central mit Silk Performer erhalten Sie in der Silk Performer-Hilfe und im Performance Explorer-User Guide.

Übergeordnetes Thema: Arbeiten mit Silk Performer-Projekten
Zugehörige Konzepte
Arbeiten mit Silk Performer-Projekten


Silk Test Classic-Tests

In diesem Abschnitt wird beschrieben, wie Tests in Silk Test Classic ausgeführt werden.

  • Hinzufügen eines Silk Test Classic-AUT-Hosts
    Fügen Sie einen Silk Test Classic-AUT-Host hinzu, wenn sich der Silk Test Classic-Agent auf einem anderen Computer als der Ausführungsserver befindet.
  • Automatisierte Ausführung von Silk Test Classic-Tests
    Hier wird die automatisierte Ausführung von Silk Test Classic-Tests beschrieben.
  • Automatisierte Ausführung von datengetriebenen Silk Test Classic-Testfällen
    Hier werden die Arten der Ausführung von datengetriebenen Silk Test Classic-Testfällen beschrieben.
  • Angeben des Agenten für den Test (AUT)
    Hier wird beschrieben, wie Hostname und Port für den Silk Test Classic Agenten für den Test (AUT) festgelegt werden.
  • Timeout-Einstellungen in Silk Test Classic
    Hier finden Sie Informationen zum Festlegen der Timeout-Einstellungen in Silk Test Classic.
  • Silk Test Classic-Logs
    Log-Dateien werden verwendet, um während der Testläufe die Daten für die verschiedenen Testfälle zu protokollieren.
Übergeordnetes Thema: Ausführungsplanung
Zugehörige Konzepte
Silk Test Classic-Tests
Zugehörige Tasks
Erstellen oder Bearbeiten von Silk Test Classic-Tests


Automatisierte Ausführung von Silk Test Classic-Tests

Alle Tests in einer Testsuite werden mit derselben Silk Test Classic-Instanz ausgeführt. Die Benutzeroberfläche von Silk Test Classic wird bei der Ausführung des ersten Silk Test Classic-Tests geöffnet und automatisch nach Abschluss des letzten Silk Test Classic-Tests geschlossen. Die Ausführung jedes Silk Test Classic-Tests führt zu einem eigenen Ergebnis. Falls die Benutzeroberfläche von Silk Test Classic während eines Tests unbeabsichtigt geschlossen werden sollte, wird sie bei der Ausführung des nächsten Silk Test Classic-Tests automatisch wieder geöffnet.

Übergeordnetes Thema: Silk Test Classic-Tests


Automatisierte Ausführung von datengetriebenen Silk Test Classic-Testfällen

Wenn das Kontrollkästchen Datengetrieben in den Silk Test Classic-Testeigenschaften aktiviert ist, wird jeder Silk Test Classic-Test für jede Datenzeile in der externen Datenquelle ausgeführt. Datengetriebene Tests werden standardmäßig planbasiert ausgeführt. Dabei werden die Ergebnisse aller Datenzeilen unter einem einzigen Knoten in der Ergebnisdatei (.res) angezeigt. Wenn Sie in der Datei SccExecServerBootConf.xml den Ausführungsmodus für einen datengetriebenen Test in skriptbasiert ändern, wird für jede Datenzeile ein Ergebnisknoten in der Ergebnisdatei (.res) erzeugt.

Übergeordnetes Thema: Silk Test Classic-Tests


Angeben des Agenten für den Test (AUT)

Wenn ein Silk Test Classic-Agent nicht auf demselben Computer wie der Silk Central-Ausführungsserver ausgeführt werden kann (z. B. wenn Tests auf anderen Plattformen als Windows durchgeführt werden), sollten Hostname und Port mit der Option Silk Test Classic-AUT-Hostname auf der Seite Testumgebung der Testsuite angegeben werden. Wenn die Option nicht konfiguriert ist, werden die Standardeinstellungen von Silk Test Classic (z. B. aus der Datei partner.ini) verwendet. Die Syntax für die AUT-Angabe lautet hostname:port. Der Agent muss vor der Testausführung manuell gestartet und zur Überwachung des angegebenen Ports konfiguriert werden. Standardmäßig wird das Protokoll TCP/IP für die Kommunikation zwischen den Silk Test Classic-Instanzen und den Silk Test Classic-Agenten verwendet. Konfigurieren Sie unbedingt beide Programme für dasselbe Protokoll.

Anmerkung: Gehen Sie sorgfältig vor, wenn mehrere Ausführungsserver einer Testsuite zugeordnet sind, da Silk Test Classic-Agenten immer nur mit einer Silk Test Classic-Instanz zusammenarbeiten können.
Übergeordnetes Thema: Silk Test Classic-Tests


Timeout-Einstellungen in Silk Test Classic

Sie müssen bei Silk Test Classic-Testfällen, deren Ausführung länger als eine Stunde dauert, die Timeout-Einstellungen von Silk Central anpassen. Andernfalls geht Silk Central davon aus, dass bei der Ausführung ein Problem aufgetreten ist und beendet Silk Test Classic. Details zur Einrichtung des Silk Test Classic-Timeouts finden Sie in den Themen Verwaltung in dieser Hilfe.

Übergeordnetes Thema: Silk Test Classic-Tests


Silk Test Classic-Logs

Die RMS-Log-Datei von Silk Test Classic wird verwendet, um während der Testläufe die Daten für die verschiedenen Testfälle zu protokollieren. Drei Typen von Datensätzen werden in diese Datei geschrieben: Status-, Speicher- und Benutzerdatensätze. Durch das Überwachen dieser Datei kann der RMS Remote Agent den Fortschritt jedes Testlaufs ermitteln.

Sie können mit der 4Test-Funktion PrintToRMSLog eigene Kommentare in die Benutzerdatensätze dieser Datei schreiben.

Beispiele:
PrintToRMSLog ("Error", "An intended error")
PrintToRMSLog ("Info", "testcase sleep1 started")
PrintToRMSLog ("Warning", "TestCase 1 started a second time")
Definition einer Benutzerfunktion in rms.inc:
PrintToRMSLog (STRING sMessageType, STRING sUserMessage)
Diese schreibt im folgenden Format in die Log-Datei:
U|{sTestCaseName}|{sScriptName}|{sArgStr}|{sUserMessage}|{sMessageType}
Übergeordnetes Thema: Silk Test Classic-Tests


Fehlerverfolgung und Ergebnisanalyse

Analysieren Sie Ihre Testergebnisse, erstellen und verfolgen Sie aufgetretene Fehler und verwenden Sie Berichte, um die Ergebnisse zu dokumentieren.
  • Analysieren von Testläufen
    Hier wird beschrieben, wie Testläufe mit Silk Central analysiert werden.
  • Verfolgung
    Hier wird beschrieben, wie die Verfolgungs-Hierarchie verwendet wird.
  • Fehler
    In diesem Abschnitt wird die Arbeit mit Fehlern in Silk Central beschrieben.
  • Berichte
    Hier wird die Arbeit mit Silk Central-Berichten beschrieben.
Übergeordnetes Thema: Silk Central-Hilfe


Analysieren von Testläufen

In diesem Abschnitt wird beschrieben, wie Testläufe mit Silk Central analysiert werden.

  • Analysieren von Testergebnissen manuellerTests
    Verwenden Sie die Ansicht Ergebnisse der manuellen Tests um eine übersichtliche Ergebnisanzeige von manuellen Tests zu erhalten. Hier werden auch Informationen wie zugewiesene Fehler und Anhänge angezeigt.
  • Analysieren von Testergebnissen automatisierter Tests
    Analysieren Sie die Ergebnisse von Testsuiteläufen für eine erweiterte Ursachenanalyse, oder vergleichen Sie die Ergebnisse mehrerer verschiedener Testläufe, um die Veränderung von Teststatus zu veranschaulichen.
  • Testergebnisse mehrerer Testläufe vergleichen
    Vergleichen Sie die Testergebnisse mehrerer Testläufe eines einzelnen Tests, um die Statusunterschiede zu visualisieren.
  • Ändern des Status eines Testlaufs
    Ändern Sie den Status eines bestimmten Testlaufs, um den Status manuell zu setzen.
  • Anzeigen von Details des Testlaufs
    Zeigen Sie Details eines Testlaufs an.
  • Löschen von Testlaufergebnissen
    Löschen Sie einzelne Testlaufergebnisse.
  • Löschen von Testläufen und Ergebnisdateien von Testsuiten
    Hier wird beschrieben, wie Testläufe und die Ergebnisdateien einer Testsuite, eines Ordners oder eines Projekts gelöscht werden.
  • Ergebnisse des Testsuitelaufs
    Hier werden die Details eines Testsuitelaufs angezeigt.
  • Ergebnisse des Testlaufs
    Hier werden die Details eines Testlaufs oder eines Testsuitelaufs angezeigt.
  • Testausführungsaktivitäten von datengetriebenen Tests anzeigen
    Zeigen Sie Testausführungsaktivitäten von datengetriebenen Tests an, um die korrekte Ausführung des Tests zu überwachen.
  • Testsuiteläufe (Seite)
    Hier werden statistische Informationen zu den Läufen der ausgewählten Testsuite angezeigt.
Übergeordnetes Thema: Fehlerverfolgung und Ergebnisanalyse


Analysieren von Testergebnissen manuellerTests

Verwenden Sie die Ansicht Ergebnisse der manuellen Tests um eine übersichtliche Ergebnisanzeige von manuellen Tests zu erhalten, sowohl für beendete als auch nicht-beendete Testläufe. Hier werden auch Informationen wie zugewiesene Fehler und Anhänge angezeigt. Die Information ist sofort verfügbar. Die Information kann auch im PDF-Format gedruckt oder heruntergeladen werden.

Die Ansicht Ergebnisse der manuellen Tests besteht aus der Hierarchieanzeige auf der linken Seite und der Detailanzeige auf der rechten Seite.. Der Inhalt der Hierarchieanzeige hängt davon ab, was Sie beim Öffnen der Testergebnisanzeige ausgewählt haben. Haben Sie z.B. einen Testzyklus ausgewählt, so werden alle zugeordneten Tester und deren Tests angezeigt. Die Auswahl eines bestimmten Knotens aktualisiert die Anzeige mit Information basierend auf der aktuellen Auswahl.

Um die Ansicht Ergebnisse der manuellen Tests zu öffnen, klicken sie auf das Symbol Ergebnisse manueller Tests anzeigen ( [image]). Diese Funktionalität steht praktisch überall zur Verfügung, wo manuelle Tests angezeigt werden. Dies beinhaltet die Manuelle Ausführungsplanung, Dashboard-Panele, die Aktivitäten-Seiten und die Testläufe Tabellen in den Bereichen Ausführungen und Tests.

Übergeordnetes Thema: Analysieren von Testläufen


Analysieren von Testergebnissen automatisierter Tests

Analysieren Sie die Ergebnisse von Testsuiteläufen für eine erweiterte Ursachenanalyse, oder vergleichen Sie die Ergebnisse mehrerer verschiedener Testläufe, um die Veränderung von Teststatus zu veranschaulichen.

Die Ansichten Testergebnisse und Testsuitelauf-Vergleich bieten eine übersichtliche Ergebnisanzeige mit der Möglichkeit, sich bis in unterste Details hineinzuklicken (drill-down). Hier werden auch Informationen wie Anhänge, Screenshots, Nachrichten und Stacktraces angezeigt. Dies ermöglicht eine schnelle Ursachenanalyse von fehlgeschlagenen Testläufen, vor allem weil Sie auch die Ergebnisse verschiedener Testsuiteläufe nebeneinander vergleichen können.

Sie könnten zum Beispiel folgende Aufgaben interessant finden:
  • Analysieren der Läufe aller Konfigurationen innerhalb einer Konfigurationssuite oder innerhalb Testsuiten welche Konfigurationen repräsentieren.
  • Vergleichen von Läufen derselben Testsuite, z.B. um herauszufinden ob sich irgendwelche Teststatus verändert haben.
  • Gleichzeitiges Anzeigen aller fehlgeschlagenen Tests einer Testsuite.

So analysieren Sie die Ergebnisse von automatisierten Testläufen:

  1. Wählen Sie eine oder mehrere Ausführungen in den Tabellen Testläufe im Bereich Ausführungen oder in Aktivitäten > Letzte Testausführungen aus.
  2. Klicken Sie auf das Symbol Ergebnisse automatisierter Tests anzeigen, um die Ergebnisse einer einzelnen Ausführung zu analysieren, oder klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Ergebnisse automatisierter Tests vergleichen, um mehrere Ausführungen miteinander zu vergleichen.
  3. Klicken Sie auf ein Symbol im oberen Bereich der Seite oder auf ein Statussymbol in der Tabelle um detaillierte Informationen einzusehen, wie z.B. Anhänge, Screenshots, Nachrichten und Stacktraces.
    Tipp: Verwenden Sie das Kontrollkästchen Nur fehlgeschlagene Tests anzeigen, um die Anzahl der angezeigten Ergebnisse einzuschränken.
Übergeordnetes Thema: Analysieren von Testläufen


Testergebnisse mehrerer Testläufe vergleichen

Vergleichen Sie die Testergebnisse mehrerer Testläufe eines einzelnen Tests, um die Statusunterschiede zu visualisieren.

Die Ansicht Testergebnisse bietet eine übersichtliche Ergebnisanzeige mit der Möglichkeit, sich bis in unterste Details hineinzuklicken (drill-down). Hier werden auch Informationen wie Anhänge, Screenshots, Nachrichten und Stacktraces angezeigt. Dies ermöglicht eine schnelle Ursachenanalyse von fehlgeschlagenen Testläufen, vor allem weil Sie die Ergebnisse verschiedener Testsuiteläufe nebeneinander vergleichen können.

  1. Wählen Sie zwei oder mehr Ausführungen in der Tabelle Testläufe aus (Tests > Detailansicht > <Test> > Testläufe).
  2. Klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Ergebnisse automatisierter Tests vergleichen, um mehrere Testläufe miteinander zu vergleichen.
  3. Klicken Sie auf ein Symbol im oberen Bereich der Seite oder auf ein Statussymbol in der Tabelle um detaillierte Informationen einzusehen, wie z.B. Anhänge, Screenshots, Nachrichten und Stacktraces.
    Tipp: Verwenden Sie das Kontrollkästchen Nur fehlgeschlagene Tests anzeigen, um die Anzahl der angezeigten Ergebnisse einzuschränken.
Übergeordnetes Thema: Analysieren von Testläufen
Zugehörige Verweise
Testläufe (Seite)


Ändern des Status eines Testlaufs

So ändern Sie manuell den Status eines Testlaufs:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Testläufe.
  4. Wählen Sie den Testsuitelauf aus. Im Bereich Test der Seite Testläufe sind die Testläufe aufgelistet.
  5. Klicken Sie auf die Ausführungs-ID des Tests. Das Dialogfeld Ergebnisse des Testslaufs wird angezeigt.
  6. Klicken Sie auf die Registerkarte Details.
  7. Klicken Sie auf Status ändern. Der Dialog Status ändern wird angezeigt.
  8. Wählen Sie den neuen Status des Testlaufs in dem Listenfeld Neuer Status aus.
  9. Geben Sie in das Feld Kommentar eine Erläuterung zu der manuellen Statusänderung ein.
    Anmerkung: Die Eingabe dieses Kommentars ist obligatorisch.
  10. Klicken Sie auf OK, um die Statusänderung zu bestätigen.
Anmerkung: Statusänderungen wirken sich auf die Historie aus. Zum Anzeigen der Historie aller Statusänderungen für den Testlauf klicken Sie auf die Registerkarte Meldungen im Dialogfeld Testlaufergebnisse.
Übergeordnetes Thema: Analysieren von Testläufen


Anzeigen von Details des Testlaufs

So lassen sich die Details eines Testlaufs anzeigen:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie aus der Hierarchie Testsuites eine Testsuite aus.
  3. Klicken Sie auf die Registerkarte Testläufe.
  4. Klicken Sie im unteren Bereich in der Tabelle Testläufe auf die Ausführungs-ID des Tests, dessen Details Sie sich ansehen möchten. Das Dialogfeld Ergebnisse des Testlaufs wird angezeigt.
  5. Klicken Sie auf die Registerkarte Details.
Übergeordnetes Thema: Analysieren von Testläufen


Löschen von Testlaufergebnissen

So löschen Sie die Ergebnisse eines bestimmten Testlaufs:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie in der Testsuitehierarchie die Testsuite aus, die Sie bearbeiten möchten.
  3. Klicken Sie auf die Registerkarte Testläufe.
  4. Klicken Sie in der Spalte Aktionen des Testlaufs, dessen Ergebnisse Sie löschen möchten, auf Ausführungsergebnisse löschen.
  5. Klicken Sie im Bestätigungsdialogfeld auf Ja, um die Löschung zu bestätigen.
Übergeordnetes Thema: Analysieren von Testläufen
Zugehörige Tasks
Löschen von Testläufen und Ergebnisdateien von Testsuiten
Ergebnisse und Ergebnisdateien automatisch löschen


Löschen von Testläufen und Ergebnisdateien von Testsuiten

Sie haben die Möglichkeit, ganze Testläufe (einschließlich der Ergebnisdateien und anderer Elemente und Informationen, die zu dem Testlauf gehören) oder nur die Ergebnisdateien der Testläufe zu löschen. Ergebnisdateien können Dateien sein, die viel Speicherplatz in der Datenbank erfordern, z. B. Videos oder Screenshots. Wenn Sie nur die Ergebnisdateien löschen, können Sie damit Ihre Datenbank aufräumen und Speicherplatz freigeben, während Sie sämtliche wichtigen Informationen zu den Testläufen beibehalten.

So löschen Sie Testläufe oder Ergebnisdateien:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Klicken Sie mit der rechten Maustaste auf eine Testsuite, einen Ordner, eine Konfigurationssuite oder ein Projekt aus der Hierarchie Testsuiten, und wählen Sie die Option Testläufe oder Ergebnisdateien löschen aus.
  3. Das Dialogfeld Testläufe oder Ergebnisdateien löschen wird angezeigt. Wählen Sie aus, was Sie löschen möchten:
    • Klicken Sie auf Alle Testläufe (inklusive Ergebnisdateien), um sämtliche Testläufe mitsamt der Ergebnisdateien zu löschen.
    • Klicken Sie auf Ergebnisdateien aller Testläufe, um nur die Ergebnisdateien, nicht aber die Testläufe selbst zu löschen.
  4. Aktivieren Sie die Option Innerhalb des Zeitraum von ... bis ..., um nur die Testläufe oder Ergebnisdateien einer bestimmten Zeitspanne zu löschen.
  5. Aktivieren Sie die Option Letzten Testlauf behalten, um sämtliche Testläufe (innerhalb des Zeitraums, falls angegeben) mit Ausnahme des letzten Testlaufs zu löschen.
  6. Klicken Sie auf OK.
Anmerkung: Testläufe markierter Builds werden mit dieser Aktion nicht gelöscht. Wenn Sie Testläufe markierter Builds löschen möchten, heben Sie die Build-Markierung unter Verwaltung > Produkte, Versionen und Builds > Produkte auf.
Anmerkung: Wenn mehrere Elemente gelöscht werden, tritt während des Löschens der Elemente aus der Datenbank eine leichte Verzögerung ein, bis die Benutzeroberfläche aktualisiert ist.
Anmerkung: Wenn Sie mit der rechten Maustaste auf einen Projektknoten klicken um alle Testläufe oder alle Ergebnisdateien des Projekts zu löschen, werden alle Testläufe oder alle Ergebnisdateien des Projekts von Probeläufen ebenfalls gelöscht.
Übergeordnetes Thema: Analysieren von Testläufen
Zugehörige Tasks
Löschen von Testlaufergebnissen
Ergebnisse und Ergebnisdateien automatisch löschen


Ergebnisse des Testsuitelaufs

Verfolgung > Aktivitäten > Letzte Testausführungen > Ausführungs-ID

Im Dialogfeld Ergebnisse des Testsuitelaufs werden Einzelheiten zum Testsuitelauf angezeigt.

Sie können das Dialogfeld auch über Ausführungsplanung > Detailansicht aufrufen. Wählen Sie die Testsuite aus, deren Details angezeigt werden sollen, klicken Sie auf die Registerkarte Testläufe, klicken Sie mit der rechten Maustaste auf den Testlauf, und wählen Sie Details anzeigen.

Das Dialogfeld enthält folgende Detaildaten:

Element | Beschreibung
Name der Testsuite | Der Name der Testsuite.
Testsuite-ID | Die eindeutige Kennung der Testsuite.
Ausführungs-ID der Testsuite | Die Kennung des Testsuitelaufs.
Startzeit | Der Zeitpunkt, zu dem der Testlauf gestartet wurde.
Dauer | Die Zeit, die zur Ausführung aller enthaltenen Tests benötigt wurde. Dazu zählen die Zeiten der Vorbereitung und Nachbereitung für den Test, für das Abrufen der Automatisierungsdateien und Codeabdeckung, das Starten der Ausführungstools und für andere Aufgaben. Bei manuellen Testausführungen bezieht sich dies auf die Zeit vom Start bis zum Abschluss der Ausführung.
Ausführungsserver | Der Ausführungsserver, welcher der Testsuite zugeordnet wurde.
Warnungen/Fehler | Die Anzahl der Warnungen und Fehler, die während des Testlaufs erzeugt wurden.
Status | Zeigt die Anzahl der bestandenen, fehlgeschlagenen und nicht ausgeführten Tests in einem Balkendiagramm an.
Version/Build | Version und Build-Nummer des Produkts, das für den Testlauf angegeben wurde. Diese werden entweder durch den Benutzer für diese Testsuite festlegt oder aus der Build-Informationsdatei zur Ausführungszeit gelesen. Wenn der Build gekennzeichnet ist, wird er fett und mit Markierter Build markiert.
Silk Test Classic-AUT-Hostname | Name des Silk Test Classic-AUT-Hosts (Agent Under Test).
Vorbereitung | Der Test, mit dem die Testumgebung für den Test vorbereitet wurde. Klicken Sie auf den Namen des Tests, um ihn anzuzeigen oder zu bearbeiten. Durch Klicken auf die Kennung des Tests können Sie das Dialogfeld Ergebnisse des Testlaufs öffnen.
Nachbereitung | Der Test, mit dem die Testumgebung nach dem Testlauf in ihren ursprünglichen Zustand zurückversetzt wurde. Klicken Sie auf den Namen des Tests, um ihn anzuzeigen oder zu bearbeiten. Durch Klicken auf die Kennung des Tests können Sie das Dialogfeld Ergebnisse des Testlaufs öffnen.

Das Dialogfeld Ergebnisse des Testsuitelaufs enthält zusätzliche Informationen über die beteiligten Dateien und die Meldungen, die während des Testsuitelaufs generiert wurden. Hier werden auch die zur Testsuite zugeordneten Tests aufgeführt.

Bei manuellen Tests klicken Sie auf Ergebnisse des manuellen Tests, um eine schreibgeschützte Version der Seite Aktuelle Testläufe mit detaillierten Informationen zum manuellen Test anzuzeigen.

Im Bereich Zugeordnete Tests werden alle Tests aufgeführt, die dieser Testsuite zugeordnet sind. Klicken Sie auf den Namen eines Tests, um ihn anzuzeigen oder zu bearbeiten, oder klicken Sie auf die Ausführungs-ID eines Tests, um das Dialogfeld Ergebnisse des Testlaufs zu öffnen.

Übergeordnetes Thema: Analysieren von Testläufen
Zugehörige Verweise
Ergebnisse des Testlaufs


Ergebnisse des Testlaufs

Auf der Seite Ergebnisse des Testlaufs werden Einzelheiten zum Testlauf oder zum Testsuitelauf angezeigt. Sie können die Seite folgendermaßen aufrufen:

  • Tests > Detailansicht > <Test> > Testläufe > <Ausführungs-ID>
  • Ausführungsplanung > Detailansicht > <Testsuite> > Testläufe > <Ausführungs-ID>
  • Ausführungsplanung > Detailansicht > <Testsuite> > Testläufe > Testläufe<Ausführungs-ID>
  • Verfolgung > Aktivitäten > Letzte Testausführungen > <Ausführungs-ID> > Zugeordnete Tests > <Ausführungs-ID>

Die Seite Ergebnisse des Testlaufs enthält folgende Registerkarten/Bereiche:

Registerkarte | Beschreibung
Details

Zeigt die Details des Testlaufs einschließlich der Dauer, des Ausführungspfads, der Ausführungs-ID der Testsuite für die Testsuite mit der Testausführung, eventuelle Warnungen/Fehler und den Ausführungskommentar an, falls ein solcher hinzugefügt wurde. Auf dieser Registerkarte können Sie den Status des Testlaufs ändern. Diese Möglichkeit ist hilfreich, wenn Sie den Status eines Testlaufs manuell ändern müssen.

Bei der manuellen Änderung des Status werden die Einzelheiten der Änderung in den Feldern Status, Status geändert am, Status geändert von, Vorheriger Status und Kommentar zur Statusänderung dieser Registerkarte angezeigt.
Zeitverlauf

Auf der Registerkarte Zeitleiste wird eine Tabelle angezeigt, die eine einfache Ergebnis- und Fehleranalyse von Testläufen ermöglicht. Dies geschieht durch die Kombination folgender Elemente:

  • Die Struktur der Testsuite, wenn eine output.xml-Datei verfügbar ist, einschließlich der Anzahl von Fehlern und Warnungen.
  • Vorfälle aus der output.xml-Datei.
  • Protokolleinträge und Meldungen.
  • Ergebnisdateien.

Die Einträge werden in chronologischer Reihenfolge aufgeführt, und die Ansicht enthält Kontrollkästchen, mit denen Sie nach den unterschiedlichen Elementtypen filtern können.

Sie können diese Registerkarte auch über die Aktionen Ergebnisse analysieren und Fehler analysieren in der Tabelle Ausführung des Tests aufrufen.

Anmerkung: Die Registerkarte wird für alle Testtypen außer für manuelle Tests und Silk Test Workbench-Tests angezeigt.
Statistik | Wird nur für Silk Test Classic-, Silk Performer- und manuelle Tests angezeigt. Diese Registerkarte enthält die spezifischen Details des ausgewählten Testtyps. Wenn Sie z. B. einen Silk Test Classic-Test auswählen, werden der Testfall, die Testdaten und sämtliche während des Testlaufs aufgetretenen Warnungen angezeigt.
Dateien Hier werden alle während des Testlaufs ausgegebenen Dateien unter Angabe ihrer Größe angezeigt. Die Namen der Silk Test Classic .rex -Dateien dienen als Download-Links. Die heruntergeladenen Dateien können direkt in einem Editor geöffnet werden.

Die obere Tabelle enthält Dateien, die dem Test zugeordnet sind, z. B. Ergebnisdateien oder manuell hochgeladene Dateien für manuelle Tests. Die untere Tabelle enthält Dateien, die der Testsuite zugeordnet sind, beispielsweise Log-Dateien der Ausführung oder Ergebnisse der Codeanalyse.

Klicken Sie in der Spalte Aktionen von Ergebnisdateien auf Datei löschen, um eine bestimmte Ergebnisdatei zu löschen. Beachten Sie, dass einige Dateien geschützt sind und nicht gelöscht werden können.

Klicken Sie auf Alle Dateien herunterladen, um alle vom Testlauf erzeugten Ergebnisdateien als Zip-Paket herunterzuladen.

Für Silk Test Workbench klicken Sie auf die Datei result.stwx, um Silk Test Workbench im Kontext der Ergebnisdatei zu öffnen.

Für Silk Test Workbench klicken Sie error.png, um die letzten Screenshots für einen Visual Test angezeigt zu bekommen, wenn ein Wiedergabefehler auftritt.
Meldungen

Hier werden alle während des Testlaufs ausgegebenen Meldungen zusammen mit ihrem Zeitstempel und dem Schweregrad angezeigt.
Erfolgsbedingungen | Wird nur für automatisierte Tests angezeigt. Hier werden die während der Testplanung unter Tests > Detailansicht > <Test> > Eigenschaften definierten Erfolgsbedingungen und die Ergebnisse des Testlaufs angezeigt. Anhand der Erfolgsbedingungen wird ermittelt, ob ein Test bestanden hat oder ob er fehlgeschlagen ist.
Datengetrieben | Wird nur für diejenigen datengetriebenen Tests angezeigt, bei denen ein einziger Test für alle Datenzeilen der Datenmenge verwendet wird. Auf dieser Registerkarte wird der Status der einzelnen Testläufe (pro Datenzeile) des Tests angezeigt. Wenn Sie auf einen Testlauf klicken, wird eine weitere Instanz des Dialogfelds Ergebnisse des Testlaufs mit Ausführungsdetails des ausgewählten Testlaufs geöffnet.
Attribute | Alle Attribute, die für den Test konfiguriert wurden.
Parameter | Alle Parameter, die für den Test konfiguriert wurden.

Die Elemente der Benutzeroberfläche, mit denen Sie die Ergebnisse eines Ausführungslaufs eines Tests näher betrachten können, sind in der folgenden Tabelle aufgeführt. Diese Elemente werden nur angezeigt, wenn das Dialogfeld Ergebnisse des Testlaufs von einer Testsuite aus geöffnet wird.

Element | Beschreibung
Bestandene überspringen | Dient zur Festlegung, welche Ergebnisse von Testläufen eines Tests angezeigt werden sollen, wenn die Ergebnisse mithilfe der Schaltfläche Vorheriges Ergebnis und Nächstes Ergebnis durchsucht werden. Wenn diese Option aktiviert ist, werden nur die Tests angezeigt, die einen anderen Status als Bestanden aufweisen.
< Vorheriges Ergebnis | Wechselt zu den Ergebnisdetails des vorherigen Tests im ausgewählten Testlauf der Testsuite.
Nächstes Ergebnis > | Wechselt zu den Ergebnisdetails des nächsten Tests im ausgewählten Testlauf der Testsuite.
Übergeordnetes Thema: Analysieren von Testläufen
Zugehörige Verweise
Ergebnisse des Testsuitelaufs


Testausführungsaktivitäten von datengetriebenen Tests anzeigen

So zeigen Sie die Testausführungsaktivitäten von datengetriebenen Tests an:

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Wählen Sie eine Testsuite aus, die auf einem datengetriebenen Test basiert.
  3. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  4. Klicken Sie auf die Ausführungs-ID der betreffenden Testsuite.
  5. Klicken Sie in der Tabelle Zugeordnete Tests auf die Ausführungs-ID eines datengetriebenen Tests.
    Anmerkung: Wenn Sie datengetriebene Tests mit mehreren Testinstanzen ausführen, wird für jede Datenzeile der Datenquelle ein Test angezeigt.
    Die Seite mit dem Ergebnis des ausgewählten Tests wird geöffnet.
  6. Klicken Sie auf die Registerkarte Datengetrieben. Hier werden alle ausgeführten Instanzen des Tests angezeigt.
    Anmerkung: Die datengetriebenen Eigenschaften des Tests werden auf der Seite Details in der Tabelle Datengetriebene Eigenschaften angezeigt.
  7. Klicken Sie auf den Namen der Instanz, um Details zur Ausführung des Tests für diese Instanz anzuzeigen.
    Anmerkung: Wenn Sie mit datengetriebenen Tests mit mehreren Testinstanzen arbeiten, wird für jede Datenzeile der Datenquelle eine eigene Instanz erstellt.
  8. Auf der Registerkarte Parameter werden die während des Testlaufs verwendeten Datenquellenwerte angezeigt.
Übergeordnetes Thema: Analysieren von Testläufen
Zugehörige Konzepte
Datengetriebene Tests


Testsuiteläufe (Seite)

Ausführungsplanung > Detailansicht > <Testsuite> > Testläufe

Auf der Seite Testläufe werden statistische Daten zu allen Läufen der ausgewählten Testsuite angezeigt.

Für Konfigurationssuiten werden alle Läufe der eingeschlossenen Konfigurationen auf der Seite angezeigt.

Für Testzyklen werden auf der Seite alle Testläufe der eingeschlossenen Testsuiten und Ordner angezeigt.

Die Seite ist in zwei separate Abschnitte unterteilt: der erste enthält die Testsuiteläufe und der zweite die Testläufe für den im ersten Bereich ausgewählten Testsuitelauf.

Die Tabellen können angepasst werden: Sie können Spalten anzeigen oder ausblenden, die Breite anpassen und Spalten verschieben, um deren Reihenfolge zu ändern. Klicken Sie auf die Spalten, um den Inhalt dieser zu sortieren, zu gruppieren oder zu filtern.

Klicken Sie mit der rechten Maustaste auf einen Testlauf, und wählen Sie Details anzeigen, um den Dialog Ergebnisse des Testsuitelaufs zu öffnen. Um mehrere Testsuiteläufe zu vergleichen, wählen Sie diese mit Strg+Klick bzw. Umschalttaste+Klick aus. Klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Ergebnisse automatisierter Tests vergleichen.

Im Bereich Testsuiteläufe sind die Testläufe der ausgewählten Testsuite aufgelistet. Legen Sie über die Menüleiste am Ende dieses Abschnitts fest, wie viele Zeilen Sie pro Seite anzeigen und wie Sie auf den Seiten navigieren möchten. Zu jedem Lauf werden auf der Seite folgende Spalten angezeigt:

Spalte | Beschreibung
Aktionen Aktionen, die Sie mit der Testsuite ausführen können.
Testläufe löschen
Klicken Sie auf die Kennung, um die Ergebnisse des Testlaufs zu löschen. Wenn Sie die Ergebnisse der ausgewählten Testläufe löschen, entfernt Silk Central die Testläufe aus der Seite Testläufe. Die Testläufe werden abgedunkelt dargestellt, bis die Löschung im Hintergrund abgeschlossen ist. Sie können auch mit der Taste Entf die Ergebnisse der Testläufe löschen. Für markierte Builds müssen Sie bestätigen, dass die Ergebnisse entfernen werden sollen.
Ergebnisse manueller Tests anzeigen (nur für manuelle Tests)
Klicken Sie hier, um die Ergebnisse eines einzelnen manuellen Testlaufs auf der Seite Ergebnisse der manuellen Tests anzuzeigen.
Ergebnisse automatisierter Tests anzeigen (nur für automatisierte Tests)
Klicken Sie hier, um die Ergebnisse eines einzelnen automatisierten Testlaufs auf der Seite Testergebnisse anzuzeigen.
ID | Die Kennung der Testsuite.
Testsuite | Der Name der ausgeführten Testsuite. Diese Spalte wird nur für Konfigurationssuites angezeigt.
Status | Statuszusammenfassung für den Testlauf. In einem Balken wird jeweils die Anzahl der Tests mit dem Status "Bestanden", "Fehlgeschlagen" bzw. "Nicht ausgeführt" angezeigt. Der Testlaufstatus jedes zugeordneten Tests wird im zweiten Bereich der Seite angezeigt.
Testlauf-ID | Die Kennung des Testsuitelaufs. Klicken Sie auf die Kennung, um die Ergebnisse des Testlaufs anzuzeigen.
Schlüsselwörter | Die der Testsuite zugeordneten Schlüsselwörter.
Ausgeführt von | Der Name des Ausführungsservers, auf dem der Testlauf ausgeführt wurde. Bei manuellen Tests wird hier der Name der Person angegeben, die den Testlauf ausgeführt hat.
Produkt | Die getestete Anwendung.
Version | Die Version, die der Benutzer für diese Testsuite festlegt oder die aus der Build-Informationsdatei zur Ausführungszeit gelesen wird. Diese Angabe kann unter Verwaltung > Produkte, Versionen und Builds > Produkte vorgenommen werden.
Build | Der Build, den der Benutzer für diese Testsuite festlegt oder der zur Ausführungszeit aus der Build-Informationsdatei ausgelesen wird. Diese Angabe kann unter Verwaltung > Produkte, Versionen und Builds > Produkte vorgenommen werden. Wenn der Build gekennzeichnet ist, wird er fett und mit Markierter Build markiert.
Startzeit | Der Zeitpunkt, zu dem der Testlauf gestartet wurde.
Dauer | Die Zeit, die zur Ausführung aller enthaltenen Tests benötigt wurde. Dazu zählen die Zeiten der Vorbereitung und Nachbereitung für den Test, für das Abrufen der Automatisierungsdateien und Codeabdeckung, das Starten der Ausführungstools und für andere Aufgaben. Bei manuellen Testausführungen bezieht sich dies auf die Zeit vom Start bis zum Abschluss der Ausführung.
Start-Typ | Zeigt, wie der Testlauf gestartet wurde. Manuell, durch einen Webdienst oder einen Ausführungstermin.
Starter-Name | Name des Ausführungstermins, Testers oder Webdienst-Benutzers, der die Ausführung gestartet hat.
Start-Art | Die im Dialog Testlauf festgelegte Art.
Übergeordneter Knoten | Der Name der übergeordneten Testsuite.
Testlauf-Kommentar | In dieser Spalte können Sie Informationen zum Testlauf hinzufügen. Sie können einen Kommentar bearbeiten, indem Sie mit der rechten Maustaste auf den Testlauf klicken und Testlauf-Kommentar bearbeiten auswählen.
Auswahl Mobilgerät | Der Gerätefilter, der auf der Seite Testumgebung definiert wurde, falls die Testsuite zur Ausführung auf einem mobilen Gerät konfiguriert wurde.
Verwendetes Gerät | Das Gerät, das dem Filter entsprach und tatsächlich zur Testausführung verwendet wurde, falls die Testsuite zur Ausführung auf einem mobilen Gerät konfiguriert wurde. Bei manuellen Tests wird das Gerät angezeigt, das zuletzt von einem Tester für diese Testsuite ausgewählt wurde.
Wenn Sie Ihren Testsuiten Attribute zugeordnet haben, können Sie auswählen, dass diese in der Tabelle angezeigt werden. Attribute sind frei erstellbare Merkmale, die auf Testsuiten angewendet werden können. Sie können Attribute für das Filtern und die Berichterstellung verwenden.

Im Bereich Testläufe sind die Testläufe für den ausgewählten Testsuitelauf aufgelistet. Legen Sie über die Menüleiste am Ende dieses Abschnitts fest, wie viele Zeilen Sie pro Seite anzeigen und wie Sie auf den Seiten navigieren möchten. Zu jedem Lauf werden auf der Seite folgende Spalten angezeigt:

Spalte | Beschreibung
Aktionen Aktionen, die Sie mit dem Testlauf ausführen können.
Ergebnisse anzeigen oder herunterladen
Wenn der Test, zu dem der Testlauf gehört, zu den Testtypen zählt, die Ergebnisdateien generiert, klicken Sie auf die Symbole, um die Ergebnisdateien anzuzeigen oder herunterzuladen.
Neuer Fehler
Klicken Sie darauf, um den Dialog Neuer Fehler zu öffnen und einen neuen Fehler für den Test anzulegen.
Vorhandene Fehler zuweisen
Ermöglicht Ihnen, dem Test Fehler aus einem externen Fehlerverfolgungssystem zuzuordnen.
Ergebnisse manueller Tests anzeigen
Klicken Sie darauf, um die Seite Aktueller Testlauf im schreibgeschützten Modus anzuzeigen.
Status | Statuszusammenfassung für den Testlauf. Für einen einzelnen Test wird ein Status angezeigt. Für ein Testpaket oder einen Testsuiteknoten wird in einem Balkendiagramm jeweils die Anzahl der Tests mit dem Status "Bestanden", "Fehlgeschlagen" bzw. "Nicht ausgeführt" angezeigt.
Statusursache | Die Ursache, weshalb ein bestimmter Testlauf den Status Bestanden, Fehlgeschlagen oder Nicht ausgeführt hat.
Testlauf-ID | Die Kennung des Testlaufs. Klicken Sie darauf, um den Dialog Ergebnisse des Testlaufs zu öffnen.
ID | Die Kennung des Tests. Diese Spalte wird standardmäßig verborgen.
Test | Der Name des Tests. Klicken Sie hier, um auf den Test in Tests > Detailansicht zuzugreifen. Das Symbol zeigt den jeweiligen Testtyp an.
Version | Die Version des Testlaufs wendet sich nur auf diesen an.
Startzeit | Datum und Uhrzeit, zu der der Testlauf gestartet wurde.
Dauer | Die Dauer des Testlaufs.
Ausgeführt von | Der Name des Ausführungsservers, auf dem der Testlauf ausgeführt wurde. Bei manuellen Tests wird hier der Name der Person angegeben, die den Testlauf ausgeführt hat.
Gefundene Fehler | Zeigt die Anzahl der Fehler an, die diesem Testlauf zugeordnet sind. Wenn dem Testlauf keine Fehler zugeordnet sind, ist die Spalte leer. Klicken Sie auf den Link, um die Seite Fehler des Bereichs Tests > Detailansicht für den Fehler anzuzeigen.
Fehler | Die Anzahl der im Testlauf aufgetretenen Fehler.
Warnungen | Die Anzahl der im Testlauf ausgegebenen Warnungen.
Build | Der Build des Testlaufs wendet sich nur auf diesen an.
Testlauf-Kommentar | Bei Silk Performer-Testläufen verwendet Silk Performer diese Spalte, um beim Hochladen der Ergebnisse Informationen zum Testlauf hinzuzufügen. Bei allen anderen Testläufen können Sie in diese Spalte Informationen zum Testlauf einfügen. Sie können einen Kommentar bearbeiten, indem Sie mit der rechten Maustaste auf den Testlauf klicken und Testlauf-Kommentar bearbeiten auswählen.
Übergeordnetes Thema: Analysieren von Testläufen
Zugehörige Konzepte
Vergleichsberichte zu Testsuiteläufen
Zugehörige Tasks
Zuordnen von vorhandenen Fehlern
Zugehörige Verweise
Aktivitäten (Seite)
Ergebnisse des Testlaufs


Verfolgung

Der Bereich Verfolgung enthält Informationen auf Projektebene, z. B. Aktivitäten, Projektübergreifende Aktivitäten, einen Projektübersichtsbericht und Qualitätsziele.

  • Aktivitäten
    In diesem Abschnitt wird beschrieben, wie bevorstehende, aktuelle und zurückliegende Testläufe verwaltet werden.
  • Projektübersichtsbericht
    Dieser Bericht bietet eine Übersicht über den Status des ausgewählten Projekts.
  • Silk Central, risikoorientiertes Testen und Qualitätsziele
    Hier wird beschrieben, wie Silk Central risikoorientiertes Testen unterstützt.
Übergeordnetes Thema: Fehlerverfolgung und Ergebnisanalyse


Aktivitäten

In diesem Abschnitt wird beschrieben, wie bevorstehende, aktuelle und zurückliegende Testläufe verwaltet werden.

  • Löschen von Testläufen in der Liste der letzten Testausführungen
    Löschen Sie die Ergebnisse eines Testlaufs, um den Testlauf aus der Liste Letzte Testausführungen zu entfernen.
  • Anzeigen und Ausblenden von Spalten auf der Seite "Aktivitäten"
    Aktivieren bzw. deaktivieren Sie die entsprechenden Kontrollkästchen, um auf der Seite Aktivitäten Spalten anzuzeigen bzw. auszublenden.
  • Eingeben von Fehlern auf der Seite "Aktivitäten"
    Geben Sie Fehler direkt auf der Seite Aktivitäten ein, wenn während eines Testlaufs Fehler gefunden werden.
  • Filtern von Testläufen auf der Seite 'Aktivitäten'
    Hier wird beschrieben, wie auf der Seite Aktivitäten Testergebnisse und Testsuiten gefiltert werden.
  • Gruppieren von Testläufen auf der Seite 'Aktivitäten'
    Hier wird beschrieben, wie Testsuiten oder Testergebnisse auf der Seite Aktivitäten gruppiert werden, um eine übersichtlichere Anzeige zu erzielen.
  • Entfernen von Aktivitätsfiltern
    Entfernen Sie auf Spalten angewendete Aktivitätsfilter auf der Seite Aktivitäten, um alle Spalten anzuzeigen.
  • Anordnen von Spalten auf der Seite 'Aktivitäten'
    Ordnen Sie Spalten auf der Seite Aktivitäten neu an, um die Anzeige des aktiven Projekts anzupassen.
  • Ändern der Breite von Spalten auf der Seite 'Aktivitäten'
    Ändern Sie die Breite von Spalten auf der Seite Aktivitäten, um die Anzeige des aktiven Projekts anzupassen.
  • Wiederherstellen der Standardanzeigeeinstellungen auf der Seite 'Aktivitäten'
    Stellen Sie die Standardanzeigeeinstellungen auf der Seite Aktivitäten wieder her, um alle benutzerdefinierten Einstellungen zurückzusetzen.
  • Sortieren von Testläufen auf der Seite 'Aktivitäten'
    Sortieren Sie Testläufe auf der Seite Aktivitäten, um die Anzeige des aktiven Projekts anzupassen.
  • Aktivitäten (Seite)
    Hier können Sie von einer zentralen Stelle aus bevorstehende, aktuelle und zurückliegende Testläufe verwalten.
  • Projektübergreifende Aktivitäten
    Ein Benutzer mit SuperUser-Berechtigungen kann alle auf die Ausführung bezogenen Aktivitäten projektübergreifend anzeigen.
Übergeordnetes Thema: Verfolgung
Zugehörige Konzepte
Ausführungsplanung
Zugehörige Verweise
Projektübergreifende Aktivitäten


Löschen von Testläufen in der Liste der letzten Testausführungen

So löschen Sie einen Testlauf aus der Liste Letzte Testausführungen:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Klicken Sie auf der Seite Aktivitäten im Bereich Letzte Testausführungen mit der rechten Maustaste auf den Testlauf, den Sie löschen möchten, und wählen Sie Ausführungsergebnisse löschen.
  3. Klicken Sie auf OK, um das Löschen zu bestätigen.
Übergeordnetes Thema: Aktivitäten


Anzeigen und Ausblenden von Spalten auf der Seite "Aktivitäten"

So zeigen Sie auf der Seite Aktivitäten Spalten an oder blenden sie aus:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile einer Spalte.
  3. Erweitern Sie die Spalten-Untermenüs, damit alle im Projekt verfügbaren Spalten angezeigt werden.
  4. Aktivieren Sie die Kontrollkästchen aller Spalten, die angezeigt werden sollen. Ihre Anzeigeeinstellungen für die Spalten werden gespeichert und jedesmal aktiviert, wenn Sie das aktive Projekt öffnen.
Übergeordnetes Thema: Aktivitäten


Eingeben von Fehlern auf der Seite "Aktivitäten"

Neue Fehler können direkt auf der Seite Aktivitäten eingegeben werden.

So geben Sie auf der Seite Aktivitäten einen Fehler ein:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Klicken Sie im Bereich Letzte Testausführungen auf die Ausführungs-ID der relevanten Testsuite, um die Ausführungsergebnisse anzuzeigen. Im unteren Bereich der Ansicht werden in der Tabelle Zugeordnete Tests die Tests angezeigt, die dem Testlauf zugeordnet sind.
  3. Klicken Sie in der Spalte Aktionen des Tests, dem Sie den Fehler zuordnen möchten, auf Neuer Fehler.
  4. Fahren Sie mit der Fehlerdefinition fort.
Übergeordnetes Thema: Aktivitäten


Filtern von Testläufen auf der Seite 'Aktivitäten'

Die auf der Seite Aktivitäten angezeigten Werte können nach Spaltenwerten gefiltert werden. Sie können Filterstrings angeben, zur Anwendung auf:

  • Textdatenfelder
  • Kalendarische Filter (mit den Operatoren Vor, Nach oder Am) für Datumsfelder
  • Numerische Operatoren (>, < und =) für numerische Felder.
  • Filtern von Textwerten auf der Seite "Aktivitäten"
    Filtern Sie auf der Seite Aktivitäten Textwerte, um alle Einträge anzeigen zu lassen, die den Filterkriterien entsprechen.
  • Filtern von Datumswerten auf der Seite "Aktivitäten"
    Filtern Sie auf der Seite Aktivitäten Datumswerte, um alle Einträge anzeigen zu lassen, die den Filterkriterien entsprechen.
  • Filtern von numerischen Werten auf der Seite "Aktivitäten"
    Filtern Sie auf der Seite Aktivitäten numerische Werte, um alle Einträge anzeigen zu lassen, die den Filterkriterien entsprechen.
  • Filtern von booleschen Werten auf der Seite "Aktivitäten"
    Filtern Sie auf der Seite Aktivitäten boolesche Werte, um alle Einträge anzeigen zu lassen, die den Filterkriterien entsprechen.
  • Filtern von Werten mithilfe einer vordefinierten Liste auf der Seite "Aktivitäten"
    Filtern Sie auf der Seite Aktivitäten Werte mithilfe einer vordefinierten Liste, um alle Einträge anzeigen zu lassen, die den Filterkriterien entsprechen.
Übergeordnetes Thema: Aktivitäten
Zugehörige Konzepte
Filter


Filtern von Textwerten auf der Seite "Aktivitäten"

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit den Textwerten, auf denen der Filter basieren soll.
  3. Erweitern Sie im Kontextmenü das Untermenü Filter, um das Textfeld Filter anzuzeigen.
  4. Geben Sie eine Zeichenfolge in das Feld ein.
  5. Drücken Sie die Eingabetaste. Daraufhin werden in der gefilterten Liste dynamisch alle Einträge angezeigt, die dem Filterkriterium entsprechen.
Übergeordnetes Thema: Filtern von Testläufen auf der Seite 'Aktivitäten'


Filtern von Datumswerten auf der Seite "Aktivitäten"

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit Datumswerten, auf denen der Filter basieren soll.
  3. Zeigen Sie im Kontextmenü auf Filter, damit das Untermenü mit den Einträgen Vor, Nach oder Am angezeigt wird.
  4. Wählen Sie eine der folgenden Registerkarten:
    1. Zeigen Sie auf Nach, um das Datum anzugeben, ab dem alle späteren Einträge angezeigt werden sollen.
    2. Zeigen Sie auf Vor, um das Datum anzugeben, ab dem alle früheren Einträge angezeigt werden sollen.
    3. Zeigen Sie auf Am, um nur die Einträge mit dem angegebenen Datum anzuzeigen.
    Der Kalender wird angezeigt.
  5. Wählen Sie mithilfe des Kalenders ein Datum aus (oder klicken Sie auf Heute, um das heutige Datum anzugeben).
    Tipp: Sie müssen explizit auf ein Datum klicken oder die Taste Eingabe drücken, um die Änderungen bei der datumsbasierten Filterung zu aktivieren.
    Daraufhin werden in der gefilterten Liste dynamisch alle Einträge angezeigt, die dem Filterkriterium entsprechen.
Übergeordnetes Thema: Filtern von Testläufen auf der Seite 'Aktivitäten'


Filtern von numerischen Werten auf der Seite "Aktivitäten"

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit den numerischen Werten, auf denen der Filter basieren soll.
  3. Erweitern Sie im Kontextmenü das Untermenü Filter, um die Operatoren > (größer als), < (kleiner als) und = (gleich) anzuzeigen.
  4. Wählen Sie eine der folgenden Registerkarten:
    1. Geben Sie im Feld > einen numerischen Wert ein, wenn alle Einträge angezeigt werden sollen, die diesen Wert überschreiten.
    2. Geben Sie im Feld < einen numerischen Wert ein, wenn alle Einträge angezeigt werden sollen, die diesen Wert unterschreiten.
    3. Geben Sie im Feld = einen numerischen Wert ein, um nur diejenigen Einträge anzuzeigen, die diesen Wert aufweisen; alle anderen Einträge werden ausgeschlossen.
    Anmerkung: Numerische Werte werden auf zwei Dezimalstellen gerundet.
  5. Drücken Sie die Eingabetaste. Daraufhin werden in der gefilterten Liste dynamisch alle Einträge angezeigt, die dem Filterkriterium entsprechen.
Übergeordnetes Thema: Filtern von Testläufen auf der Seite 'Aktivitäten'


Filtern von booleschen Werten auf der Seite "Aktivitäten"

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit den booleschen Werten, auf denen der Filter basieren soll.
  3. Erweitern Sie im Kontextmenü das Untermenü Filter, um die verfügbaren Werte anzuzeigen.
  4. Wählen Sie entweder das Optionsfeld Ja oder das Optionsfeld Nein. Daraufhin werden in der gefilterten Liste dynamisch alle Einträge angezeigt, die dem Filterkriterium entsprechen.
Übergeordnetes Thema: Filtern von Testläufen auf der Seite 'Aktivitäten'


Filtern von Werten mithilfe einer vordefinierten Liste auf der Seite "Aktivitäten"

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit dem vordefinierten Filterwert, auf dem der Filter basieren soll.
  3. Erweitern Sie im Kontextmenü das Untermenü Filter, um das Textfeld Filter anzuzeigen.
  4. Aktivieren Sie die Kontrollkästchen der gewünschten Filterwerte. Es werden alle Einträge angezeigt, die eines der ausgewählten Kriterien erfüllen.
Übergeordnetes Thema: Filtern von Testläufen auf der Seite 'Aktivitäten'


Gruppieren von Testläufen auf der Seite 'Aktivitäten'

Neben einer einfachen Sortierung nach Spalten können Sie Einträge in Gruppen anordnen, um die Anzeige übersichtlicher zu gestalten. Die Gruppierung richtet sich nach gemeinsamen, in der zu gruppierenden Spalte enthaltenen Werten.

  • Gruppieren von Testläufen auf der Seite "Aktivitäten"
    Gruppieren Sie Testsuiten oder Testergebnisse auf der Seite Aktivitäten, um eine übersichtlichere Anzeige zu erzielen.
  • Aufheben der Gruppierung von Testläufen auf der Seite "Aktivitäten"
    Heben Sie die Gruppierung von Testläufen auf der Seite Aktivitäten auf, um alle Testläufe in einer einzelnen Liste anzuzeigen.
Übergeordnetes Thema: Aktivitäten


Gruppieren von Testläufen auf der Seite "Aktivitäten"

So gruppieren Sie Einträge auf der Seite Aktivitäten:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile einer Spalte, auf deren Werte die Gruppierung basieren soll.
  3. Wählen Sie Dieses Feld gruppieren.

    Die Einträge werden daraufhin in Gruppen angeordnet, die auf gemeinsamen Werten basieren, die innerhalb der von Ihnen gewählten Spalte vorkommen.

Übergeordnetes Thema: Gruppieren von Testläufen auf der Seite 'Aktivitäten'


Aufheben der Gruppierung von Testläufen auf der Seite "Aktivitäten"

So heben Sie die Gruppierung auf:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile irgendeiner Spalte.
  3. Deaktivieren Sie das Kontrollkästchen Gruppen anzeigen.
Übergeordnetes Thema: Gruppieren von Testläufen auf der Seite 'Aktivitäten'


Entfernen von Aktivitätsfiltern

Anmerkung: Wenn Sie eine Spalte ausblenden, werden alle Filter entfernt, die auf diese Spalte angewendet wurden.

So entfernen Sie einen oder mehrere Filter:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte mit dem Filter, den sie entfernen möchten.
    Anmerkung: Sie können gefilterte Spalten an ihrer Überschrift erkennen, die in fetter, kursiver Schrift angezeigt wird.
  3. Führen Sie einen der folgenden Schritte aus:
    1. So entfernen Sie einen bestimmten Filter: Deaktivieren Sie das Kontrollkästchen Filter.
    2. So entfernen Sie alle Filter: Wählen Sie Filter zurücksetzen.
Übergeordnetes Thema: Aktivitäten
Zugehörige Konzepte
Filter


Anordnen von Spalten auf der Seite 'Aktivitäten'

So ordnen Sie auf der Seite Aktivitäten Spalten neu an:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Klicken Sie auf die Überschrift der Spalte, die Sie verschieben möchten, und halten Sie die Maustaste gedrückt.
  3. Ziehen Sie die Spalte an die gewünschte Position, und lassen Sie die Maustaste los.

    Ihre Anordnungseinstellungen für die Spalten werden gespeichert und jedes Mal aktiviert, wenn Sie das aktive Projekt öffnen.

Übergeordnetes Thema: Aktivitäten


Ändern der Breite von Spalten auf der Seite 'Aktivitäten'

So ändern Sie auf der Seite Aktivitäten die Breite von Spalten:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Klicken Sie auf die vertikale Trennlinie der Spalte, deren Breite Sie ändern möchten, und halten Sie die Maustaste gedrückt.
  3. Ziehen Sie die Spaltentrennlinie an die gewünschte Position, und lassen Sie die Maustaste los.

    Ihre Einstellungen für die Spaltenbreite werden gespeichert und jedes Mal aktiviert, wenn Sie das aktive Projekt öffnen.

Übergeordnetes Thema: Aktivitäten


Wiederherstellen der Standardanzeigeeinstellungen auf der Seite 'Aktivitäten'

Bei der Wiederherstellung der Standardanzeigeeinstellungen werden alle benutzerdefinierten Einstellungen (Spaltenanordnung, Spaltenbreite, ein- oder ausgeblendete Spalten, angewendete Filter, Sortierung und Gruppierung) für das aktuelle Projekt zurückgesetzt.

So stellen Sie die Standardanzeigeeinstellungen wieder her:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile irgendeiner Spalte.
  3. Wählen Sie Ansicht zurücksetzen.
Übergeordnetes Thema: Aktivitäten


Sortieren von Testläufen auf der Seite 'Aktivitäten'

So sortieren Sie Testläufe auf der Seite Aktivitäten:

  1. Klicken Sie im Menü auf Verfolgung > Aktivitäten.
  2. Öffnen Sie das Kontextmenü der Kopfzeile der Spalte, nach der Sie die Testläufe sortieren möchten.
  3. Klicken Sie auf Aufsteigend sortieren, damit die Testläufe in aufsteigender Reihenfolge sortiert werden, oder klicken Sie auf Absteigend sortieren, um sie in absteigender Reihenfolge sortieren zu lassen. Ihre Sortiereinstellungen werden gespeichert und jedes Mal aktiviert, wenn Sie das aktive Projekt öffnen.
Übergeordnetes Thema: Aktivitäten


Aktivitäten (Seite)

Verfolgung > Aktivitäten

Von der Seite Aktivitäten aus können Sie bevorstehende, aktuelle und zurückliegende Testläufe für einzelne Projekte verwalten. Die Tabellenansichten auf der Seite Aktivitäten bieten Optionen zum Filtern, Sortieren und Gruppieren, die für jeden Benutzer separat konfiguriert werden können. Sie können Spalten anzeigen oder verbergen, die Spaltenbreite verändern und Spalten durch Klicken und Ziehen verschieben.

Die Seite Aktivitäten ist in drei Bereiche unterteilt: Nächste Testausführungen, Aktuelle Testausführungen und Letzte Testausführungen. Die Größe der Tabellenansichten lässt sich durch Ziehen der Trennlinien zwischen den Ansichten ändern.

Für jeden Testlauf sind kontextbezogene Menübefehle verfügbar. Diese Befehle ermöglichen es Ihnen beispielsweise, direkt zu den aufgeführten Testsuiten zu navigieren, manuelle Tests fortzusetzen und Testlaufergebnisse zu verwalten.

Die Seite Aktivitäten erleichtert das Erkennen von Übereinstimmungen zwischen Testsuiten und das Suchen von bestimmten Testsuitedaten. Mithilfe von Standard-Windows-Tastenkürzeln können Testlaufeinträge markiert werden, so dass einzelne Gruppen von Testsuiten und Testergebnissen einfach ausgewählt und bearbeitet werden können. Über Kontextmenübefehle kann auf Sortier-, Gruppier- und Filterfunktionen zugegriffen werden, damit Testläufe besser angeordnet und gruppiert werden können. Alle Einstellungen für das Anpassen von Ansichten werden zusammen mit dem Projekt gespeichert und sind verfügbar, sobald Sie die Seite Aktivitäten öffnen.

Anmerkung: Die Daten auf der Seite Aktivitäten werden nicht automatisch aktualisiert. Klicken Sie auf Neu laden im unteren Bereich einer Ansicht, um den Seiteninhalt zu aktualisieren.
Anmerkung: Mit den Tasten Strg+Klick können Sie mehrere Ausführungen auswählen und alle mit einem Klick abbrechen.

Nächste Testausführungen

In der Ansicht Nächste Testausführungen werden die Testsuiten, deren Ausführung für die Zukunft geplant ist, angezeigt. Um die Leistung bei vielen Testsuiten zu verbessern, werden nur die ersten 50 bevorstehenden Testsuiten angezeigt. Mit den zur Verfügung stehenden Filterfunktionen können Sie auf weitere künftige Testsuiten zugreifen. Um eine Testsuite zu bearbeiten, klicken Sie mit der rechten Maustaste auf die Testsuite, und wählen Sie Zu Testsuite gehen, oder klicken Sie auf den Pfeil links neben dem Namen der Testsuite. Dadurch gelangen Sie zum Bereich Testausführungen. Hier können Sie die Details der Testsuite anzeigen und bearbeiten.

Standardmäßig werden alle Testsuiten nach der Startzeit sortiert. Die Spalten der Ansicht Nächste Testausführungen können weder sortiert noch gruppiert werden.

Durch Klicken auf den Doppelpfeil am rechten Rand der Titelleiste der Ansicht Nächste Testausführungen kann diese reduziert und erweitert werden.

Für jede Testsuite werden in der Ansicht Nächste Testausführungen die folgenden Spalten angezeigt:

Spalte | Beschreibung
ID | Kennung der geplanten Testsuite. Diese Spalte wird standardmäßig verborgen.
Testsuite/Ordner | Name der geplanten Testsuite oder des Ordners.
Schlüsselwörter | Der geplanten Testsuite zugewiesene Schlüsselwörter.
Manuelle Tester | Bei manuellen Tests enthält diese Spalte den Namen des manuellen Testers, dem der Test zugewiesen ist. Diese Spalte ist leer, wenn dem Test keine manuellen Tester zugewiesen wurden.
Priorität | Die Priorität, die der Testsuite zugeordnet wurde.
Startzeit | Geplante Startzeit des Testlaufs.
Übergeordneter Knoten | Die Konfigurationssuite, der Ordner oder der Testzyklus, in dem die Testsuite ausgeführt wird. Klicken Sie die gewünschte Suite oder den Ordner in der Testsuitehierarchie an. Wenn die Testsuite nicht in einer Konfigurationssuite oder in einem Ordner enthalten ist, wird nichts angezeigt.

Aktuelle Testausführungen

Die Ansicht Aktuelle Testausführungen enthält die Testsuiten, die gegenwärtig ausgeführt werden (sowohl automatisierte als auch manuelle Testläufe).

Wenn Sie die Ausführung einer Testsuite abbrechen möchten, klicken Sie in der Spalte Aktionen auf Abbrechen. Um eine Testsuite anzuzeigen oder zu bearbeiten, klicken Sie mit der rechten Maustaste auf die Testsuite, und wählen Sie Zu Testsuite gehen, oder klicken Sie auf den Pfeil links neben dem Namen der Testsuite. Um den Fortschritt der Ausführung anzuzeigen, klicken Sie mit der rechten Maustaste auf die automatische Testsuite, und wählen Sie Details anzeigen aus, oder klicken Sie auf die Verknüpfung Ausführungs-ID/Aufgaben-ID der Testsuite. Für automatisierte Tests die auf einem mobilen Gerät laufen, können Sie über die Detailansicht auch einen Live-Stream der Aktivitäten auf dem Gerät anschauen. Für Sauce Labs Geräte stehen keine Live-Streams zur Verfügung.

Solange ein manueller Test geöffnet ist, wird die zugehörige Testsuite in der Liste Aktuelle Testausführungen mit dem Status Ausstehend angezeigt. Klicken Sie in der Spalte Aktionen auf Manuellen Test fortsetzen, um das Fenster Manuelles Testen zu öffnen.

Um die Ergebnisse eines manuellen Tests anzuzeigen, klicken Sie mit der rechten Maustaste auf die manuelle Testsuite, und wählen Sie Details anzeigen aus, oder klicken Sie auf die Verknüpfung Ausführungs-ID/Aufgaben-ID der Testsuite, um die Seite Ergebnisse der Testsuite zu öffnen. Klicken Sie hier im Abschnitt Zugeordnete Testspezifikationen auf den Namen des manuellen Tests, um den Dialog Ergebnisse zu öffnen. Detaillierte Ergebnisse der manuellen Tests werden hier angezeigt. Klicken Sie auf der Seite Ergebnisse der Testsuite auf Ergebnisse des manuellen Tests, um zur Ansicht Manueller Test zu gelangen, in der Informationen über den Status des zugeordneten manuellen Tests angezeigt werden.

Die Seitenansichten für die aktuellen Ausführungen werden in Ansichten mit jeweils 20 Testsuiten aufgeteilt. Mit den Schaltflächen Anfang, Ende, Weiter und Zurück, die sich am unteren Rand der Ansicht Aktuelle Testausführungen befinden, können Sie in den Seiten vor- und zurückblättern. Sie können auch eine Seitenzahl in das Textfeld Seite eingeben und die Taste Eingabe drücken.

Für jede Testsuite werden in der Ansicht Nächste Testausführungen die folgenden Spalten angezeigt:

Spalte | Beschreibung
Aktionen Sie können folgende Aktionen für die Testsuite ausführen:
Abbrechen
Klicken Sie darauf, um die aktuelle Ausführung abzubrechen. Klicken Sie alternativ auf Löschen. Die Ausführungen werden so lange abgedunkelt dargestellt, bis die Löschung im Hintergrund abgeschlossen ist.
Anmerkung: Wenn die Ausführung zu einem Testzyklus gehört, ist die Aktion "Abbruch" deaktiviert. Das Symbol [image] und der Menüpunkt im Kontextmenü werden grau dargestellt, und diese Testläufe werden ignoriert, wenn Sie mehrere Testläufe abbrechen.
Manuellen Test fortsetzen
Klicken Sie, um das Fenster Manuelles Testen zu öffnen.
Ergebnisse manueller Tests anzeigen
Klicken Sie darauf, um die Seite Aktueller Testlauf im schreibgeschützten Modus anzuzeigen.
ID | Die Kennung der Testsuite. Diese Spalte wird standardmäßig verborgen.
Testsuite | Der Name der Testsuite.
Ausführungs-ID/Aufgaben-ID | Manuellen Tests wird vor der Ausführung eine Ausführungs-ID zugeordnet. Wenn der manuelle Test abgeschlossen ist, wird die Ausführungs-ID in die Ansicht Letzte Ausführungen übernommen. Automatisierten Tests wird vor der Ausführung eine Aufgaben-ID zugeordnet. Die Aufgaben-ID wird nicht in die Ansicht Letzte Ausführungen übernommen. Abgeschlossene Testsuiten erhalten in der Ansicht Letzte Testausführungen eine Ausführungs-ID.
Status | Status der aktiven Testsuite oder des manuellen Tests. Bei automatisierten Tests wird der Status durch einen Textwert angegeben. Bei manuellen Tests wird der Status durch ein farbiges Histogramm angezeigt. Die Statuswerte automatisierter Tests werden durch Textwerte beschrieben und können gefiltert werden. Manuelle Tests können gefiltert werden, indem relevante Eigenschaften im Untermenü Filter aktiviert werden.
Schlüsselwörter | Der Testsuite zugewiesene Schlüsselwörter.
Ausgeführt von
  • Bei manuellen Tests werden in dieser Spalte die Benutzer angezeigt, denen die Ausführung des manuellen Tests zugewiesen wurde. Diese Spalte ist leer, wenn dem Test keine manuellen Tester zugewiesen wurden.
  • Bei automatisierten Testausführungen wird in dieser Spalte der Name des Ausführungsservers angezeigt.
Priorität | Bei automatisierten Testsuiten, wenn sich mehr als eine Testsuite in der Warteschlange befindet, aber nur ein Ausführungsserver verfügbar ist, werden die Testsuiten nach Priorität ausgeführt. Das Gleiche gilt auch, wenn zwar ein Ausführungsserver verfügbar ist, aber mehrere Testsuiten ein nicht verfügbares Mobilgerät benötigen.
Startzeit | Der Zeitpunkt, zu dem die Ausführung der Testsuite gestartet wurde.
Verbleibende Zeit | Restzeit bis zum Abschluss des Tests. Bei manuellen Tests, für die keine geschätzte Dauer angegeben wurde, enthält diese Spalte den Wert Unbekannt.
Start-Typ Zeigt, wie der Testlauf gestartet wurde.
  • manuell
  • durch einen Webdienst
  • durch einen Ausführungstermin
  • durch eine Abhängigkeit
Starter-Name | Name des Ausführungstermins, Testers oder Webdienst-Benutzers, der die Ausführung gestartet hat.
Start-Art | Die im Dialog Testlauf festgelegte Art.
Übergeordneter Knoten | Die Konfigurationssuite, der Ordner oder der Testzyklus, in dem die Testsuite ausgeführt wird. Klicken Sie die gewünschte Suite oder den Ordner in der Testsuitehierarchie an. Wenn die Testsuite nicht in einer Konfigurationssuite oder in einem Ordner enthalten ist, wird nichts angezeigt.
Wenn Sie Ihren Testsuiten Attribute zugeordnet haben, können Sie auswählen, dass diese in der Tabelle angezeigt werden. Attribute sind frei erstellbare Merkmale, die auf Testsuiten angewendet werden können. Sie können Attribute für das Filtern und die Berichterstellung verwenden.

Letzte Testausführungen

In der Ansicht Letzte Testausführungen werden alle abgeschlossenen Testsuiteläufe angezeigt. Diese Liste kann gefiltert und sortiert werden, z.B. nach Startzeit der Ausführungen.

Um eine Testsuite anzuzeigen oder zu bearbeiten, klicken Sie mit der rechten Maustaste auf den Testsuitelauf, und wählen Sie Zu Testsuite gehen, oder klicken Sie auf den Pfeil links neben dem Namen der Testsuite. Um die Seite Ergebnisse der Testsuite eines Testsuitelaufs zu öffnen, klicken Sie mit der rechten Maustaste auf den Testlauf, und wählen Sie Details anzeigen, oder klicken Sie auf die Verknüpfung Ausführungs-ID der Testsuite. Hier werden Details zum ausgewählten Testlauf der Testsuite sowie die während der Ausführung erzeugten Dateien und Meldungen angezeigt. Um das Dialogfeld Ergebnisse eines Tests zu öffnen, klicken Sie im Teil Zugeordnete Tests der Seite Ergebnisse der Testsuite auf die Ausführungs-ID des Tests.

Wählen Sie mit den Tasten Strg+Klick mehrere Testsuiteläufe aus, um sie zu vergleichen. Klicken Sie mit der rechten Maustaste auf Ihre Auswahl, und klicken sie dann auf Ergebnisse automatisierter Tests vergleichen für automatisierte Tests, oder Berichte > Vergleich der Testsuiteläufe... für manuelle Tests.

Klicken Sie mit der rechten Maustaste auf eine Testsuite, und klicken Sie dann auf Testsuite ausführen, um sie auszuführen. Silk Central berücksichtigt alle zum aktuellen Zeitpunkt der Testsuite zugeordneten Tests, nicht die ursprünglich dem ausgewählten Testsuitelauf zugeordneten Tests.

Um einen Testsuitelauf zu löschen, klicken Sie mit der rechten Maustaste auf einen Testlauf, und wählen Sie die Option Ergebnisse löschen, oder klicken Sie in der Spalte Aktionen auf die zum Testlauf gehörige Schaltfläche Löschen.

Die Ansichten auf der Testergebnisseite sind in Ansichten mit jeweils 20 Testergebnissen unterteilt. Mit den Schaltflächen Anfang, Ende, Weiter und Zurück, die sich am unteren Rand der Ansicht Letzte Testausführungen befinden, können Sie in den Seiten vor- und zurückblättern. Sie können auch eine Seitenzahl in das Textfeld Seite eingeben und die Taste Eingabe drücken.

Durch Klicken auf den Doppelpfeil am rechten Rand der Titelleiste der Ansicht Letzte Testausführungen kann diese reduziert und erweitert werden.

Für jede Testsuite werden in der Ansicht Letzte Testausführungen die folgenden Spalten angezeigt:

Spalte | Beschreibung
Aktionen Sie können folgende Aktionen für die Testsuite ausführen:
Löschen
Klicken Sie darauf, um die Ergebnisse des Testsuitelaufs zu löschen. Die Ausführungen werden so lange abgedunkelt dargestellt, bis die Löschung im Hintergrund abgeschlossen ist. Klicken Sie alternativ auf Löschen, um den Testsuitelauf zu löschen. Für markierte Builds müssen Sie bestätigen, dass die Ergebnisse entfernen werden sollen.
Ergebnisse manueller Tests anzeigen
Klicken Sie darauf, um die Seite Aktueller Testlauf im schreibgeschützten Modus anzuzeigen.
ID | Die Kennung der ausgeführten Testsuite. Nicht zugeordnete Tests haben als ID den Wert n/v. Diese Spalte wird standardmäßig verborgen.
Testsuite | Der Name der ausgeführten Testsuite. Klicken Sie auf die Schaltfläche neben dem Namen, um die Testsuite in der Einheit Ausführungsplanung anzuzeigen.
Testlauf-ID | Dem Testlauf zugeordnete ID. Klicken Sie auf den Link, um Detaildaten zum Testlauf anzuzeigen.
Status | Zeigt die Anzahl der bestandenen, fehlgeschlagenen und nicht ausgeführten Tests in einem Balkendiagramm an. Die Spalte kann nicht gefiltert, sortiert und gruppiert werden.
Schlüsselwörter | Die Schlüsselwörter, die der Testsuite während der Ausführung zugeordnet wurden.
Ausgeführt von
  • Bei manuellen Tests werden in dieser Spalte die Benutzer angezeigt, denen die Ausführung des manuellen Tests zugewiesen wurde. Diese Spalte ist leer, wenn dem Test keine manuellen Tester zugewiesen wurden.
  • Bei automatisierten Testausführungen wird in dieser Spalte der Name des Ausführungsservers angezeigt.
Startzeit | Der Zeitpunkt, zu dem die Ausführung der Testsuite gestartet wurde.
Dauer | Die Zeit, die zur Ausführung aller enthaltenen Tests benötigt wurde. Dazu zählen die Zeiten der Vorbereitung und Nachbereitung für den Test, für das Abrufen der Automatisierungsdateien und Codeabdeckung, das Starten der Ausführungstools und für andere Aufgaben. Bei manuellen Testausführungen bezieht sich dies auf die Zeit vom Start bis zum Abschluss der Ausführung.
Produkt | Das getestete Produkt. Diese Spalte wird standardmäßig verborgen.
Version | Die Version, die der Benutzer für diese Testsuite festlegt oder die zur Ausführungszeit aus der Build-Informationsdatei ausgelesen wird. Diese Spalte wird standardmäßig verborgen.
Build | Der Build, den der Benutzer für diese Testsuite festlegt oder der zur Ausführungszeit aus der Build-Informationsdatei ausgelesen wird. Wenn der Build gekennzeichnet ist, wird er fett und mit Markierter Build markiert.
Start-Typ | Zeigt, wie der Testlauf gestartet wurde. Manuell, durch einen Webdienst oder einen Ausführungstermin.
Starter-Name | Name des Ausführungstermins, Testers oder Webdienst-Benutzers, der die Ausführung gestartet hat.
Start-Art | Die im Dialog Testlauf festgelegte Art.
Übergeordneter Knoten | Die Konfigurationssuite, der Ordner oder der Testzyklus, in dem die Testsuite ausgeführt wird. Klicken Sie die gewünschte Suite oder den Ordner in der Testsuitehierarchie an. Wenn die Testsuite nicht in einer Konfigurationssuite oder in einem Ordner enthalten ist, wird nichts angezeigt.
Auswahl Mobilgerät | Der Gerätefilter, der auf der Seite Testumgebung definiert wurde, falls die Testsuite zur Ausführung auf einem mobilen Gerät konfiguriert wurde.
Verwendetes Gerät | Das Gerät, das dem Filter entsprach und tatsächlich zur Testausführung verwendet wurde, falls die Testsuite zur Ausführung auf einem mobilen Gerät konfiguriert wurde. Bei manuellen Tests wird das Gerät angezeigt, das zuletzt von einem Tester für diese Testsuite ausgewählt wurde.
Wenn Sie Ihren Testsuiten Attribute zugeordnet haben, können Sie auswählen, dass diese in der Tabelle angezeigt werden. Attribute sind frei erstellbare Merkmale, die auf Testsuiten angewendet werden können. Sie können Attribute für das Filtern und die Berichterstellung verwenden.
Übergeordnetes Thema: Aktivitäten


Projektübergreifende Aktivitäten

Verfolgung > Projektübergreifende Aktivitäten

Auf der Seite Projektübergreifende Aktivitäten kann ein Benutzer mit SuperUser-Rechten projektübergreifend alle auf eine Testausführung bezogenen Aktivitäten betrachten. Zusätzlich zu allen auf der Seite Aktivitäten verfügbaren Optionen sind hier projektübergreifende Optionen verfügbar. Dies ermöglicht Rückschlüsse auf die Warteschlange der ausstehenden Ausführungen. Der SuperUser kann Testausführungen aus der Warteschlange entfernen, um Engpässe zu beseitigen.

Die Seite Projektübergreifende Aktivitäten ist nur für den SuperUser sichtbar. Diese Seite ist in die gleichen drei Bereiche wie die Seite Aktivitäten eingeteilt: Nächste Testausführungen, Aktuelle Testausführungen und Letzte Testausführungen. Alle drei Abschnitte enthalten eine zusätzliche Spalte mit der Projekt-ID.

Element | Beschreibung
Projekt-ID | Die ID des Projekts, zu dem die Testsuite gehört.
Übergeordnetes Thema: Aktivitäten


Projektübersichtsbericht

Silk Central > Verfolgung > Projektübersichtsbericht

Der Projektübersichtsbericht liefert einen Überblick über den Status des ausgewählten Projekts.

Übergeordnetes Thema: Verfolgung
Übergeordnetes Thema: Standardberichte
Zugehörige Verweise
Projektübersichtsbericht


Silk Central, risikoorientiertes Testen und Qualitätsziele

Bei der Software-Entwicklung muss oft ein Kompromiss zwischen Testzielen, Zeitaufwand und Kosten eingegangen werden. Häufig wird zur Bestimmung eines Gleichgewichts zwischen diesen Faktoren risikoorientiertes Testen eingesetzt.

Ein Schlüsselprinzip von risikoorientiertem Testen besteht im Einordnen von Tests abhängig von Faktoren, die für die Qualität und für den Endbenutzer der Anwendung wichtig sind.

Unabhängig von diesem Einordnungsvorgang können Qualitätsfachleute die richtige Auswahl an Tests abhängig von der verfügbaren Zeit und den gewünschten Zielen des Qualitätsprozesses bestimmen. Die Durchführung einer Teilmenge von Tests bringt ein gewisses Risiko mit sich. Eine geeignete Quantifizierung dieses Risikos gewährleistet, dass alle Aktoren im Verlauf des Prozesses informiert sind, was entscheidend für die erfolgreiche Implementierung von risikoorientiertem Testen ist.

In Silk Central sind die zum risikoorientierten Testen verwendeten Faktoren durch den Einsatz von Qualitätszielen vollständig benutzerdefiniert. Für jeden Listentyp, jedes benutzerdefinierte Attribut und jede Anforderungseigenschaft, die zur Einordnung von Testelementen verwendet werden, kann ein Qualitätsziel erstellt werden. Das ermöglicht dem Anwender, eine Teilmenge von Tests zu definieren, die ausgeführt werden müssen, damit das Projekt gewissen Qualitätskriterien entspricht. Die Berichterstellung mit Qualitätszielen ermöglicht Benutzern, den Aktoren Testplanung und Ausführungsvorgang, relevante Ziele, Zeitrahmen und Qualitätsbewertung der Testelemente mitzuteilen.

  • Qualitätsziele
    Hier werden die Qualitätskriterien für ein Projekt beschrieben.
  • Implementieren eines risikobasierten Tests anhand von Qualitätskriterien
    Implementieren Sie risikobasierte Tests in Silk Central anhand von Qualitätskriterien.
Übergeordnetes Thema: Verfolgung
Zugehörige Konzepte
Qualitätsziele
Zugehörige Verweise
Statusberichte


Qualitätsziele

Qualitätskriterien (Ausgangskriterien) sind eine Reihe an festlegbaren Testmetriken, die ein Projekt erfüllen muss, um eine akzeptable Qualität zu gewährleisten. Jedes Silk Central-Projekt kann ein oder mehrere Qualitätskriterien enthalten. Silk Central arbeitet zur Implementierung von risikobasiertem Tests auf Basis von Qualitätskriterien und ermöglicht Ihnen Planung, Testdurchläufe und Berichte auf die wichtigsten Tests in dem gewünschten Testzyklus einzugrenzen.

In Silk Central besteht ein Qualitätskriterium aus den folgenden zwei Elementen:

  • Einer Anforderung oder einem Test.
  • Einer der folgenden Optionen:
    • Einem benutzerdefinierten Attribut des Typs Liste mit einem entsprechenden Prozentsatzwert.
    • Einer der folgenden standardmäßigen Eigenschaften von Anforderungen: Priorität, Geprüft oder Risiko mit den jeweiligen Prozentangaben.

Beispiel Qualitätskriterium

Wenn eine Anforderung über die Eigenschaft von MyCustomRisk mit den Werten Hoch, Mittel und Niedrig verfügt, sollte es möglich sein, ein Qualitätskriterium wie folgt zu definieren:

Anforderungskriterium - MyCustomRisk
Hoch = 100 %
Mittel = 50 %
Niedrig = 10 %

Der Wert 100 % bedeutet, dass alle Tests, die dieses Ziel erfüllen (verbunden mit einer Anforderung, die den Attributwert Hoch erfüllt), müssen durchgeführt werden und bestehen, um das Kriterium zu erfüllen.

Berechtigungen

Der Zugriff auf Qualitätskriterien wird über Berechtigungen gesteuert. Weitere Informationen zu Berechtigungen erhalten Sie unter Berechtigungen für Qualitätskriterien.

  • Qualitätskriterienseite
    Zeigt eine Liste aller dem von Ihnen ausgewählten Silk Central-Projekt zugeordneten Qualitätsziele.
  • Qualitätskriterien hinzufügen
    Hier wird das Hinzufügen von Qualitätskriterien beschrieben.
  • Qualitätskriterien löschen
    Hier wird das Löschen von Qualitätskriterien beschrieben.
Übergeordnetes Thema: Silk Central, risikoorientiertes Testen und Qualitätsziele
Zugehörige Verweise
Berechtigungen für Qualitätskriterien
Statusberichte


Qualitätskriterienseite

Verfolgung > Qualitätsziele

Die folgenden Verwaltungselemente sind in der Registerkarte Qualitätskriterien verfügbar, die es Ihnen ermöglichen, Qualitätskriterien für ein Projekt zu erstellen, zu bearbeiten oder zu löschen.

Qualitätskriterientabelle

Spalte | Beschreibung
Qualitätszielname | Der Name des Kriteriums. Wählen Sie die Dropdown-Liste anhand des Spaltennamens, und wählen Sie dann Gruppen anzeigen, um alle Ziele in einer Liste anzuzeigen.
Name | Jeder Wert des Attributs oder der Eigenschaft des Typs Liste wird in der Spalte Name aufgegliedert.
Qualitätsziel (%) | Dieses Textfeld muss einen numerischen Wert zwischen 0 bis 100 enthalten. Der Wert entspricht dem Prozentsatz der zur Erfüllung des definierten Qualitätskriteriums benötigten Tests.

Schaltflächen

  • Ziele verwalten – Klicken Sie zum Anzeigen des Dialogfelds Verwalten von Qualitätskriterien.
  • Planungsbericht - Klicken Sie zum Anzeigen des Dialogfelds Planungsbericht Qualitätskriterien.
  • Ausführungsbericht – Klicken Sie zum Anzeigen des Dialogfelds Ausführungsbericht Qualitätskriterien.
Übergeordnetes Thema: Qualitätsziele


Qualitätskriterien hinzufügen

Bevor Sie ein Qualitätskriterium erstellen, müssen Sie ein benutzerdefiniertes Testattribut oder eine benutzerdefinierte Anforderungseigenschaft des Typs Liste erstellen, welches Sie für Ihre Qualitätskriterien verwenden wollen. Sie können alternativ die Anforderungsfelder Priorität, Geprüft oder Risiko verwenden.

Möchten Sie zum Beispiel, dass ein Qualitätskriterium eine benutzerdefinierte Anforderungseigenschaft mit den Werten Hoch, Mittel und Niedrig verfolgt, gehen Sie zuerst zu Projekte:<Projektname> Projekteinstellungen > Anforderungseigenschaften, und erstellen Sie eine benutzerdefinierte Typeigenschaft Liste, die diese Werte enthält.

Anmerkung: Sie können eine Eigenschaft oder ein Attribut nur einmal als Qualitätskriterium pro Projekt verwenden.
  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie ein Projekt aus.
  3. Klicken Sie auf Verfolgung > Qualitätsziele.
  4. Klicken Sie auf Qualitätskriterien verwalten. Das Dialogfeld Bearbeiten von Qualitätskriterien wird geöffnet.
  5. Geben Sie im Feld Neue Qualitätskriteriumsbezeichnung den Namen für Ihr Kriterium ein.
  6. In der Liste Attribute/benutzerdefinierte Eigenschaften wählen Sie das Element, das die Werte enthält, die Sie für Ihr Qualitätskriterium verwenden wollen. Die Liste enthält die folgenden Elementtypen:
    • Anforderungseigenschaft des Typs Liste.
    • Standard-Anforderungseigenschaften des Typs Priorität, Geprüft oder Risiko.
    • Testattribut des Typs Liste.
  7. Klicken Sie auf Neues Qualitätskriterium.
  8. Klicken Sie auf Schließen. Das Dialogfeld Bearbeiten von Qualitätskriterien wird geschlossen und das neue Kriterium wird zu der Tabelle Qualitätskriterien hinzugefügt.
  9. Für jeden Wert in der Liste geben Sie einen numerischen Wert von 0 bis 100 im Feld Prozentsatz an benötigten Tests zur Erfüllung des Ziels ein.
Übergeordnetes Thema: Qualitätsziele
Zugehörige Verweise
Typen der benutzerdefinierten Attribute und Anforderungseigenschaften


Qualitätskriterien löschen

So löschen Sie Qualitätskriterium:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie ein Projekt aus.
  3. Klicken Sie auf Verfolgung > Qualitätsziele.
  4. Klicken Sie auf Qualitätskriterien verwalten. Das Dialogfeld Bearbeiten von Qualitätskriterien wird geöffnet.
  5. Klicken Sie das Symbol Löschen neben dem Qualitätskriterium, das Sie löschen möchten.
Übergeordnetes Thema: Qualitätsziele


Implementieren eines risikobasierten Tests anhand von Qualitätskriterien

Der Benutzer möchte bei einem Projekt einen Kompromiss aus Testumfang, Zeitdauer und akzeptabler Anwendungsqualität sicherstellen. In den nachfolgenden Schritten wird ein allgemeiner Workflow erläutert, der darstellt, wie ein Benutzer anhand von Qualitätskriterien risikobasierte Tests implementieren kann.

Die Projektbeteiligten wollen sicherstellen, dass ausreichend Tests durchgeführt und die wichtigsten Anforderungen angemessen getestet werden. Die Daten für das nachfolgende Beispiel sind auch im Demo-Projekt enthalten, das in den neuen Silk Central-Versionen verfügbar ist.

  1. Wählen Sie ein Projekt aus.
  2. Erstellen Sie eine Anforderungseigenschaft des Typs Liste, um die Bedeutung der Anforderung zu erfassen. Erstellen Sie für dieses Beispiel die Anforderungseigenschaft Geschäftswert mit den Werten:
    • Niedrig
    • Mittel
    • Hoch
  3. Erstellen Sie ein Testattribut des Typs Liste, um den Typ des Testzwecks zu erfassen. Erstellen Sie außerdem das Testattribut Stufe mit den Werten:
    • Vollständig
    • Regression
    • Smoke
  4. Klicken Sie auf Verfolgung > Qualitätsziele.
  5. Erstellen Sie ein neues Qualitätsziel. Erstellen Sie für dieses Beispiel das Qualitätsziel Geschäftswert für die Anforderungseigenschaft mit dem Qualitätsziel (%):
    • Hoch - 100 %
    • Mittel - 75 %
    • Niedrig - 50 %
  6. Erstellen Sie ein neues Qualitätsziel. Erstellen Sie für das Beispiel das Qualitätsziel Testziele für das Testattribut mit dem Qualitätsziel (%):
    • Vollständig - 80 %
    • Regression - 50 %
    • Smoke - 100 %
  7. Ordnen Sie nach der Erstellung der Testkomponenten die Attribute und Eigenschaften den Anforderungen und Tests zu.
  8. Zum Festlegen des Testumfangs und um sicherzustellen, dass die Beteiligten mit dem Testumfang einverstanden sind, klicken Sie auf Berichte > Detailansicht.
  9. Klicken Sie auf Testplan > Statusbericht > Qualitätsziel-Planungsbericht.

    Dieser Bericht enthält die Anzahl und den Prozentsatz der Tests zu jedem Wert eines Qualitätsziels, die gesamte geplante Dauer für manuelle Tests und die Anzahl der Tests, die zum Erreichen des Ziels erforderlich sind, im Vergleich mit der Anzahl der im Projekt verfügbaren Tests.

    Qualitätsziel-Planungsbericht
  10. Nachdem der Plan akzeptiert und das Projekt die Tests durchlaufen hat, kann der Teststatus für die Qualitätsziele leicht anhand des Qualitätsziel-Ausführungsbericht bewertet werden.
  11. Klicken Sie auf Testplan > Statusbericht > Qualitätsziel-Ausführungsbericht. Qualitätsziel-Ausführungsbericht
Übergeordnetes Thema: Silk Central, risikoorientiertes Testen und Qualitätsziele


Fehler

Beschreibt die Arbeit mit Fehlern in Silk Central.

  • Erstellen neuer Fehler
    Hier wird beschrieben, wie ein neuer Fehler erstellt wird, um diesen einem Test hinzuzufügen.
  • Anzeigen von Fehlerstatistiken in der Dokumentansicht
    Zeigen Sie Fehlerstatistiken in der Dokumentansicht an.
  • Fehler Dokumentansicht
    Öffnen Sie die Dokumentansicht, um eine Tabelle mit den Fehlerstatistiken für das ausgewählte Projekt anzuzeigen.
  • Anzeigen von Fehlerstatistiken in der Detailansicht
    Öffnen Sie die Detailansicht, um die Fehlerstatistik anzuzeigen.
  • Fehler (Seite)
    Listet Fehler von allen Fehlerverfolgungssystemen auf, die für das ausgewählte Projekt konfiguriert sind.
  • Zuordnen von vorhandenen Fehlern
    Ordnen Sie einem Test einen vorhandenen Fehler zu.
  • Aktualisieren von Fehlerstatus
    So synchronisieren Sie den Fehlerstatus zwischen Silk Central und einem Fehlerverfolgungssystem.
  • Löschen von Fehlern (Fehlerreferenzen)
    Hier wird beschrieben, wie eine Fehlerreferenz in Silk Central gelöscht wird.
  • Issue Manager
    Dieser Abschnitt enthält einen Überblick über Issue Manager.
Übergeordnetes Thema: Fehlerverfolgung und Ergebnisanalyse


Erstellen neuer Fehler

Auf der Seite Fehler können Fehler für den ausgewählten Test erstellt werden.

So erstellen Sie einen neuen Fehler:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test aus, für den Sie einen neuen Fehler erstellen möchten.
  3. Klicken Sie auf die Registerkarte Fehler.
  4. Klicken Sie auf Neuer Fehler, um den Dialog Neuer Fehler zu öffnen.
  5. Wählen Sie das Profil des Fehlerverfolgungssystems, in dem der Fehler eingetragen werden soll.
    Anmerkung: Das hier ausgewählte Profil wird als Standardeinstellung für neue Fehler verwendet. Wenn Sie einen neuen Fehler einem Fehlerverfolgungssystem hinzufügen, werden Sie zur Eingabe der Anmeldeinformationen des Fehlerverfolgungssystems aufgefordert. Die eingegebenen Anmeldeinformationen werden automatisch für künftige Anmeldungen verwendet.
  6. Geben Sie eine kurze Zusammenfassung des Fehlers ein.
  7. Geben Sie eine aussagekräftige Beschreibung des Fehlers ein.
  8. Geben Sie Informationen über den Fehler an, indem Sie die Steuerelemente rechts im Dialog verwenden.
    Anmerkung: Diese Steuerelemente variieren je nach ausgewähltem Profil. Beispiel: Bei der Erstellung eines Fehlers, der mit Bugzilla bearbeitet werden soll, muss das Produkt, die Komponenten usw. angegeben werden. Soll ein Fehler mit JIRA bearbeitet werden, müssen weitere Werte (z. B. Fehlertyp oder Priorität) angeben werden.
  9. Klicken Sie auf OK, um den Fehler zu erstellen.
Übergeordnetes Thema: Fehler


Anzeigen von Fehlerstatistiken in der Dokumentansicht

So zeigen Sie Fehlerstatistiken in der Dokumentansicht an:

  1. Klicken Sie im Menü auf Fehler > Dokumentansicht.
  2. Wählen Sie in der Hierarchie Fehler den Knoten (Projekt, Fehlerverfolgungssystem oder Produkt) aus, dessen Statistiken angezeigt werden sollen.
Übergeordnetes Thema: Fehler


Fehler Dokumentansicht

Fehler > Dokumentansicht

In der Dokumentansicht wird eine Tabelle mit den Fehlerstatistiken zum ausgewählten Projekt angezeigt.

Spalte | Beschreibung
Datum | Datum und Uhrzeit der letzten Aktualisierung der Fehlerdetails.
Offen | Die Anzahl der Fehler mit dem Status Offen im ausgewählten Element (Projekt, Datenbank oder Produkt).
Behoben | Die Anzahl der Fehler mit dem Status Behoben im ausgewählten Element (Projekt, Datenbank oder Produkt).
Verifiziert | Die Anzahl der Fehler mit dem Status Verifiziert im ausgewählten Element (Projekt, Datenbank oder Produkt).
Geschlossen | Die Anzahl der Fehler mit dem Status Geschlossen im ausgewählten Element (Projekt, Datenbank oder Produkt).
Zurückgestellt | Die Anzahl der Fehler mit dem Status Zurückgestellt im ausgewählten Element (Projekt, Datenbank oder Produkt).
Übergeordnetes Thema: Fehler


Anzeigen von Fehlerstatistiken in der Detailansicht

So zeigen Sie Fehlerstatistiken in der Detailansicht an:

  1. Klicken Sie im Menü auf Fehler > Detailansicht.
  2. Wählen Sie in der Hierarchie Fehler den Knoten (Projekt, Fehlerverfolgungssystem oder Produkt) aus, dessen Statistiken angezeigt werden sollen.
  3. Mit den Kalenderfunktionen können Sie den Zeitraum für die Fehlerstatistiken festlegen. Klicken Sie auf den Link mit den Datumsangaben, um den Kalender zu erweitern.
  4. Legen Sie mit den Listenfeldern Von und Bis im Kalender den Zeitpunkt für den Beginn und das Ende der Fehlerstatistiken fest.
  5. Klicken Sie auf Aktualisieren, um die Diagrammansicht mit dem ausgewählten Zeitbereich zu aktualisieren.
Übergeordnetes Thema: Fehler


Fehler (Seite)

Fehler > Detailansicht > Fehler

Die Seite Fehler listet die Fehler aus allen Fehlerverfolgungssystemen auf, die für das ausgewählte Projekt konfiguriert sind. Die Seite enthält die folgenden Elemente:

Element | Beschreibung
Kalenderfunktionen | Ermöglicht Ihnen die Angabe eines Zeitrahmens, für den Fehler gemeldet werden sollen. Klicken Sie auf den Link mit den Datumsangaben, um den Kalender zu erweitern.
Aktualisieren | Die Fehleransicht wird mit den im Kalender vorgenommenen Datumsänderungen aktualisiert. Die Schaltfläche wird nur bei Änderungen angezeigt.
Übergeordnetes Thema: Fehler


Zuordnen von vorhandenen Fehlern

Auf der Seite Fehler können dem ausgewählten Test die in Fehlerverfolgungssystemen verwalteten Fehler zugeordnet werden.

So ordnen Sie einem Test vorhandene Fehler zu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Knoten des Tests aus, dem Sie einen Fehler zuordnen möchten.
  3. Klicken Sie auf die Registerkarte Fehler.
  4. Klicken Sie auf Vorhandene Fehler zuordnen, um den Dialog Vorhandene Fehler zuordnen zu öffnen.
  5. Wählen Sie das Profil des vorkonfigurierten Fehlerverfolgungssystems aus, mit dem der Fehler verfolgt wird.
  6. Geben Sie im Feld Fehler-ID die Nummern der Fehler durch Kommas getrennt ein.
  7. Klicken Sie auf OK.
Anmerkung: Sie können auch einer aktuell ausgeführten Testsuite auf den Seiten Aktueller Testlauf, Testläufe (in der Ausführungsplanung) und Testläufe (in Tests) einen vorhandenen Fehler zuordnen.
Übergeordnetes Thema: Fehler
Zugehörige Verweise
Aktueller Testlauf (Seite)
Testsuiteläufe (Seite)
Testläufe (Seite)


Aktualisieren von Fehlerstatus

So synchronisieren Sie den Fehlerstatus zwischen Silk Central und einem Fehlerverfolgungssystem:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test aus, in dem Sie den entsprechenden Fehler aktualisieren möchten.
  3. Klicken Sie auf die Registerkarte Fehler.
  4. Klicken Sie auf Fehlerstatus aktualisieren, um den Status der in Silk Central aufgelisteten Fehler mit den entsprechenden Fehlern im Fehlerverfolgungssystem zu synchronisieren.
Übergeordnetes Thema: Fehler


Löschen von Fehlern (Fehlerreferenzen)

So löschen Sie eine Fehlerreferenz:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie den Test aus, aus dem Sie den Fehler löschen möchten.
  3. Klicken Sie auf die Registerkarte Fehler.
  4. Klicken Sie in der Spalte Aktionen auf Löschen.
  5. Klicken Sie im Dialog Fehler löschen auf Ja, um den Fehler zu löschen.
Wichtig: Diese Aktion entfernt nur die Fehlerreferenz in Silk Central. Sie löscht nicht den Fehler selbst aus dem Fehlerverfolgungssystem.
Übergeordnetes Thema: Fehler


Issue Manager

Willkommen bei Issue Manager

Issue Manager ist ein leistungsstarkes Tool für die automatische Fehlerverfolgung. Sie können mit Issue Manager die Eingabe, Verarbeitung und Verwaltung von Fehlern optimal auf die Arbeitsabläufe in Ihrem Unternehmen abstimmen.

Issue Manager bietet Unterstützung bei der Verwaltung von Softwarefehlern, Dokumentationsproblemen, Erweiterungsanforderungen usw. Das Produkt wendet sich an Benutzer mit unterschiedlichen Aufgabenstellungen, wie Anwendungsentwickler, QS-Fachleute, Mitarbeiter des technischen Supports, Verfasser von Dokumentationen, Manager und IT-Profis.

Issue Manager verwendet eine Technik namens aktionsgetriebener Workflow. Mit dieser Workflow-Technologie wird ein Fehler während seines gesamten Lebenszyklus auf der Grundlage von Benutzeraktionen und Fehlerstatuswerten, die sich an den Workflow Ihres Unternehmens anpassen lassen, automatisch verschoben. Ab dem Zeitpunkt, an dem ein Fehler gemeldet wird bis zu dessen Behebung, sorgt Issue Manager für die automatische Zuordnung des Fehlers, sobald ein Benutzer eine Aktion in Bezug auf diesen Fehler ausführt.

Der Administrator definiert die Zuordnungsregeln und den Workflow, um die automatische Übermittlung von Fehlern an Postfächer von einzelnen Benutzern oder Benutzergruppen zu steuern. Benutzer mit entsprechender Berechtigung haben die Möglichkeit, die vordefinierte Fehlerzuordnung zu umgehen.

Issue Manager ermöglicht Ihnen die Ausführung folgender Aufgaben:

  • Fehler über eine Weboberfläche melden.
  • Fehler hinzufügen, überprüfen, neu zuordnen, beheben, bestätigen und schließen.
  • Detaillierte Informationen über beliebige Fehler anzeigen lassen.
  • Benutzerkonten und Postfächer anzeigen lassen.
  • E-Mail empfangen, wenn ein Fehler auf bestimmte Weise geändert wurde.
  • Mithilfe von Abfragen Fehlerinformationen aus der Datenbank abrufen.
  • Berichte und Diagramme erzeugen.
  • Fehler archivieren.
  • Erste Schritte mit Issue Manager
    Hier wird beschrieben, wie Sie Ihre Arbeit mit Issue Manager beginnen.
  • Verwenden von Issue Manager
    Bietet eine Einführung in Issue Manager.
  • Issue Manager-Verwaltung
    Hier wird die Beziehung zwischen Issue Manager und Silk Central beschrieben.
Übergeordnetes Thema: Fehler


Erste Schritte mit Issue Manager

Als Endbenutzer

Machen Sie sich mit den Aufgaben eines Endbenutzers vertraut.

Erstellen Sie eine einfache Datenbank und konfigurieren Sie diese, bevor Sie die Produktionsdatenbank Ihres Unternehmens erstellen. Weitere Informationen finden Sie unter Datenbanken.

Als Administrator

Bevor Sie mit Issue Manager arbeiten können, müssen Sie eine Datenbank einrichten. Weitere Informationen finden Sie unter Datenbanken.

  • Durchsuchen der Beispieldatenbank
    Durchsuchen Sie als Administrator die Beispieldatenbank, um sich mit den Funktionen von Issue Manager vertraut zu machen.
  • Leistungsumfang von Issue Manager
    Gibt einen Überblick über die Funktionen von Issue Manager.
Übergeordnetes Thema: Issue Manager
Zugehörige Konzepte
Datenbanken


Durchsuchen der Beispieldatenbank

Durchsuchen Sie als Administrator die Beispieldatenbank, um sich mit den Funktionen von Issue Manager vertraut zu machen. So durchsuchen Sie die Beispieldatenbank:
  1. Starten Sie Issue Manager, und melden Sie sich bei der Beispieldatenbank als dhart an (ein Mitarbeiter der Entwicklung mit uneingeschränkten Berechtigungen).
  2. Geben Sie für ein vorhandenes Produkt einen Fehler ein.
  3. Speichern Sie den Fehler. Issue Manager füllt auf der Seite Fehlerdetails die automatischen Felder des Registers Historie aus.
  4. Führen Sie mit dem Fehler eine Aktion durch, und füllen Sie den entsprechenden Aktionsdialog aus. Die Seite Fehlerdetails ändert sich. Nehmen Sie andere Aktionen vor, bis Sie mit dem Vorgang vertraut sind.
  5. Nehmen Sie einige Benutzerkonten unter die Lupe.
    1. Beachten Sie, welchen Gruppen die Benutzer zugeordnet sind.
    2. Untersuchen Sie die Sicherheitsberechtigungen der Benutzer.
    3. Notieren Sie die Standardpostfächer der Benutzer.
  6. Fügen Sie eine Gruppe hinzu.
    1. Weisen Sie der Gruppe Sicherheitsberechtigungen zu.
  7. Fügen Sie ein Postfach für einen neuen Benutzer hinzu.
    1. Ordnen Sie das Postfach der neuen Gruppe zu.
  8. Fügen Sie ein Konto für einen neuen Benutzer hinzu.
    1. Weisen Sie dem Benutzer das neue Postfach zu.
    2. Ordnen Sie dem Benutzerkonto alle übrigen Berechtigungen zu.
  9. Fügen Sie ein neues Produkt einschließlich seiner Zuordnungsregeln hinzu.
    1. Fügen Sie eine oder zwei Versionen für das Produkt hinzu.
    2. Ordnen Sie jeder Version eine oder zwei Plattformen zu.
  10. Melden Sie sich beim System ab.
  11. Melden Sie sich mit dem Namen des Benutzers an, den Sie zuvor angelegt haben.
  12. Um die Verarbeitung eines Fehlers im Verlauf des Workflows zu beobachten, geben Sie für das neue Produkt einen Fehler ein, und speichern Sie ihn.
    1. Der Fehler im Feld Zugeordnet zu wurde einem der Postfächer zugeordnet, die Sie in den Zuordnungsregeln festgelegt haben. Der Fehler befindet sich im Status Offen. Wählen Sie das Register Historie, und untersuchen Sie die dortigen Einträge.
    2. Wählen Sie das Register Historie, und untersuchen Sie die dortigen Einträge.
    3. Ordnen Sie den Fehler einem anderen Entwickler zu.
    4. Beobachten Sie, wie diese Aktion das Register Historie verändert.
    5. Ordnen Sie dem Fehler den Status Behoben zu, um auf den nächsten Status überzugehen. Das Feld Statusändert sich in Zu verifizieren. Das Feld Zugeordnet zu ändert sich in das Postfach, das Sie in Ihren Zuordnungsregeln festgelegt haben. Es handelt sich hierbei vermutlich um das Postfach des QS-Mitarbeiters.
    6. Ordnen Sie dem Fehler den Status Prüfen zu, der besagt, dass ein QS-Mitarbeiter überprüft hat, ob der Fehler behoben wurde. Der Fehler erhält danach den Status Geschlossen. Beobachten Sie wieder das Register Historie. Wie hat es sich verändert?
  13. Fügen Sie zwei Komponenten für das neue Produkt hinzu.
  14. Richten Sie Zuordnungsregeln für die Komponenten ein. Verwenden Sie andere Postfächer für das gesamte Produkt.
  15. Geben Sie einen weiteren Fehler für eine bestimmte Produktkomponente ein. Wiederholen Sie die Unterschritte von Schritt 12, um die Änderungen der Zuordnung zu beobachten.
    Anmerkung: Da der Workflow für alle Fehler gleich ist, durchläuft der Fehler dieselben Statuswerte.
  16. Ändern Sie auf der Seite Fehlerdetails eine Feldbezeichnung.
  17. Ändern Sie Produktcode in Produkt.
  18. Öffnen Sie die Seite Fehlerdetails für einen vorhandenen Fehler, um die Änderung zu beobachten.
  19. Fügen Sie Benutzerdefiniertes Register 1 ein neues Feld hinzu.
  20. Öffnen Sie die Seite Fehlerdetails für einen vorhandenen Fehler. Klicken Sie auf das Register Benutzerdefiniert, und betrachten Sie das neue Feld.
  21. Generieren Sie einige der vordefinierten Berichte, die im Bereich Berichte verfügbar sind.
Übergeordnetes Thema: Erste Schritte mit Issue Manager


Leistungsumfang von Issue Manager

Als umfassende Lösung für die Fehlerverfolgung bietet Issue Manager folgende Möglichkeiten:
  • Erstellen neuer Fehler:
  • Importieren von Fehlern: Der Silk Test-Assistent ermöglicht die Weiterleitung von Details zu Silk Test-Testfällen direkt an Issue Manager als Grundlage für neue Fehler. Auch Ausführungsergebnisse von Silk Central, die Probleme beinhalten, können als Grundlage für neue Fehler verwendet werden.
  • Verarbeitung von Fehlern: Mit Issue Manager können Sie Fehler anzeigen, neu zuordnen, beheben, überprüfen und schließen (die entsprechenden Berechtigungen variieren je nach Benutzertyp).
  • Hinzufügen von Dateien zu Issue Manager-Fehlern: Wenn Sie oder ein Kunde über Dateien verfügen, die für die Reproduktion eines Fehlers erforderlich sind, können Sie diese in Issue Manager laden und dem Fehler zuordnen. Dateien, die zur Bestätigung, Behebung oder Überprüfung eines Fehlers benötigt werden, lassen sich dann schnell und problemlos auffinden.
  • Anzeigen einer vollständigen Historie für jeden Fehler im System: Issue Manager zeichnet jede Aktion auf, die die Benutzer für einen Fehler ausführen. Der Standardeintrag für einen Fehler in der Historie enthält die für den Fehler ausgeführte Aktion, den Benutzer, der die Aktion ausgeführt hat, sowie Anmerkungen mit Erläuterungen zur Aktion.
  • Interagieren mit Arbeitsgruppen: Der Issue Manager-Administrator kann Arbeitsgruppen in Ihrem Unternehmen einrichten, deren Mitglieder über dieselben Berechtigungen, Zugriffsrechte, Postfächer und Zuordnungen verfügen. So können Sie mit einzelnen Benutzern, aber auch mit Benutzergruppen interagieren, die für ähnliche Aufgaben zuständig sind.
  • Abfragen des Systems nach Fehlerinformationen, die bestimmten Kriterien entsprechen: Sie können vordefinierte Abfragen verwenden, Abfragen auf der Grundlage eines Beispiels definieren sowie mit SQL erweiterte Abfragen erstellen.
  • Berichte und Graphen erstellen: Erstellen Sie vordefinierte Berichte auf Grundlage von Fehlerkriterien, die Sie angeben, oder erstellen Sie erweiterte Berichte mit SQL.
  • Definieren von Benachrichtigungen: Definieren Sie Benachrichtigungen, wenn sich Fehlerstatus oder Zuordnungen ändern.
  • Remote mit der Fehlerdatenbank interagieren: Geben Sie Fehler remote über das Internet ein und rufen Sie sie ab.
  • Tests Fehlern zuordnen: Mit Silk Central
Übergeordnetes Thema: Erste Schritte mit Issue Manager


Verwenden von Issue Manager

Die Issue Manager Hilfe bietet Informationen und Richtlinien, mit deren Hilfe Sie Fehler mit Issue Manager verfolgen können, um die Anforderungen Ihrer Softwareentwicklungsumgebung zu erfüllen.

  • Übersicht
    Dieser Abschnitt enthält einen Überblick über Issue Manager.
  • Eingeben von Fehlern
    Hier wird beschrieben, wie Fehler in Issue Manager erstellt und bearbeitet werden.
  • Arbeiten mit Fehlern
    Hier wird die Arbeit mit Fehlern beschrieben.
  • E-Mail-Benachrichtigung
    Hier wird beschrieben, wie E-Mail-Benachrichtigungen verwendet werden.
  • Berichte (Issue Manager)
    Hier werden Issue Manager-Berichte beschrieben.
  • Projekte (Issue Manager)
    Hier wird der projektbasierte Workflow von Issue Manager beschrieben.
Übergeordnetes Thema: Issue Manager


Übersicht

In diesem Abschnitt erhalten Sie einen Überblick über die Issue Manager UI. Er enthält die Seite Fehlerverfolgung die Seite Fehlerdetails, die Registerkarten Fehlerdetails und die Symbolleiste Fehlerverfolgung.

  • Fehlerverfolgung (Seite)
    Hier wird die Seite Fehlerverfolgung beschrieben.
  • Fehlerdetailseite
    Hier wird die Seite Fehlerdetails beschrieben.
Übergeordnetes Thema: Verwenden von Issue Manager


Fehlerverfolgung (Seite)

Klicken Sie im Menü auf Fehler > Fehlerverfolgung.

Übersicht

Auf der Seite Fehlerverfolgung wird eine Liste der Fehler in Ihrem Postfach angezeigt. Wenn Sie ein anderes Postfach anzeigen lassen möchten, wählen Sie eines aus der Anzeigen-Liste in der Symbolleiste aus. Postfächer können in Gruppen gegliedert werden. Um nur die Postfächer einer bestimmten Gruppe anzuzeigen, wählen Sie eine aus der Liste in der Symbolleiste aus. Sie können Spalten anzeigen oder verbergen, die Breite anpassen, und Spalten herumziehen um deren Reihenfolge zu verändern. Klicken Sie auf die Spalten, um den Inhalt dieser zu sortieren, zu gruppieren oder zu filtern. Klicken Sie in der Tabelle auf [image] (Fehler anzeigen), um die Details zu einem Fehler auf der Seite Fehlerdetails anzeigen zu lassen. Sie können auch die Nach Oben und Nach Unten-Tasten zur Navigation in der Liste verwenden, und die Eingabetaste zur Anzeige der Fehlerdetails drücken.

Verwenden Sie die Anzeigen-Liste um zu bestimmen, welche Fehler Sie anzeigen möchten:
  • Alle offenen Fehler: Zeigt alle Fehler aller Postfächer an, die sich nicht ein einem Endzustand befinden.
  • Alle Fehler: Zeigt alle Fehler aller Postfächer an, inklusive geschlossene Fehler.
  • <Postfach-Name>: Zeigt alle Fehler an, die dem ausgewählten Postfach zugeordnet sind.

Symbolleiste

Über die Schaltflächen in der Symbolleiste können Sie folgende Aktionen durchführen:
  • Klicken Sie auf [image] (Mein Posteingang), um die Fehlerliste Ihres Posteingangs anzuzeigen.
  • Klicken Sie auf Neuer Fehler, um einen neuen Fehler hinzuzufügen.
  • Klicken Sie auf Bestätigen (Als XLSX herunterladen), um die Fehlerliste in ein Excel-Arbeitsblatt zu exportieren.
  • Geben Sie eine Fehlernummer in das Symbolleistenfeld Gehe zum Fehler # ein, und drücken Sie die Eingabetaste, um schnell zu einem bestimmten Fehler zu gelangen.
  • Klicken Sie auf [image] (Silk Test Classic Intelligent Assistant öffnen). Dieses Symbol wird nur angezeigt, wenn der ShowSilkTestAssistant-Tag in der Datei SRFrontendBootConf.xml auskommentiert und auf true gesetzt ist. Weitere Informationen finden Sie unter Silk Test Intelligent Assistant.

Bulk-Aktualisierungen

Sie können mit den Tasten Strg und Umschalt entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Fehler auswählen. Basierend auf den Benutzerberechtigungen können folgende Aktionen auf mehrere Fehler ausgeführt werden (durch Rechtsklick auf Ihre Auswahl):
  • Fehler neu zuweisen, wenn keine geschlossenen Fehler ausgewählt sind.
  • Workflow-Aktionen ausführen, wenn die ausgewählten Fehler alle vom selben Typ sind und den gleichen Status haben. Beachten Sie, dass Workflow-Aktionen, die ein produktabhängiges Feld verwenden, nur dann möglich sind, wenn die ausgewählten Fehler das gleiche Produkt betreffen.
Übergeordnetes Thema: Übersicht
Zugehörige Konzepte
Silk Test Intelligent Assistant


Fehlerdetailseite

Klicken Sie im Menü auf Fehler > Fehlerverfolgung, wählen Sie aus der Liste in der Symbolleiste ein Postfach aus, und klicken Sie dann in der Tabelle auf [image] (Fehler anzeigen). Auf der Seite Fehlerdetails werden detaillierte Informationen über einen Fehler angezeigt.

Symbolleiste

Auf der Symbolleiste am oberen Seitenrand wird eine Liste der Aktionen angezeigt. Klicken Sie auf die Verknüpfungen, um an einem bestimmten Fehler zu arbeiten. Die angezeigten Verknüpfungen variieren je nach dem Status des Fehlers und nach Ihren Berechtigungen. Eine Liste sämtlicher Verknüpfungen finden Sie unter Aktionen für Fehler.

Klicken Sie auf [image] (Zurück zum Postfach) um zurück zur Fehlerliste auf der Seite Fehlerverfolgung zu gelangen. Dazu können Sie auch die Rücktaste verwenden.

Geben Sie eine Fehlernummer in das Symbolleistenfeld Gehe zum Fehler # ein, und drücken Sie die Eingabetaste, um schnell zu einem bestimmten Fehler zu gelangen.

Fehlerdetails

Unterhalb der Aktionsverknüpfungen werden die wichtigsten Informationen über den Fehler angezeigt, und Sie können Anhänge hinzufügen und Benachrichtigungen konfigurieren. Verwenden Sie die Anhänge- und Benachrichtigungen-Symbole unterhalb der Kurzbezeichnung, um Anhänge hinzuzufügen und Benachrichtigungen zu konfigurieren.
Name | Beschreibung
Vorheriger Fehler im Postfach | Zeigt die Daten des vorigen Fehlers in der Fehlerliste zum ausgewählten Postfach an. Dazu können Sie auch die Nach Oben und Nach Links-Tasten verwenden.
Nächster Fehler im Postfach | Zeigt die Daten des nächsten Fehlers in der Fehlerliste zum ausgewählten Postfach an. Dazu können Sie auch die Nach Unten und Nach Rechts-Tasten verwenden.
Anhänge | Ermöglicht Ihnen das Hinzufügen von Dateien mit zusätzlichen Informationen zu dem Fehler. Sie können die Dateien mit den Schaltflächen in der Spalte Aktionen bearbeiten und entfernen. Hierzu müssen Sie nicht zuerst auf Bearbeiten klicken.
Benachrichtigungen | Ermöglicht Ihnen das Konfigurieren von E-Mail-Benachrichtigungen. Issue Manager benachrichtigt Sie, wenn bestimmte Werte eines Fehlers sich ändern. Hierzu müssen Sie nicht zuerst auf Bearbeiten klicken.
Druckversion anzeigen | Zeigt eine Druckansicht der Daten des ausgewählten Fehlers an.

Registerkarten "Fehlerdetails"

Die Registerkarten "Fehlerdetails" werden unter den Fehlerdetails auf der Seite Fehlerdetails angezeigt. Bevor Sie die Werte auf den Registerkarten bearbeiten können (wie z. B. Hinzufügen von Kunden oder Ändern der Beschreibung), müssen Sie auf der Seite Fehlerdetails auf Bearbeiten klicken. Dazu können Sie auch die F2-Taste verwenden. Folgende Registerkarten sind verfügbar:
Name | Beschreibung
Beschreibung | Enthält eine Kurzbezeichnung und eine Beschreibung des Fehlers. Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
Historie | Verfolgt alle Änderungen zu dem Fehler nach. Zum Beispiel: Wann der Fehler erstellt wurde, von wem, Aktionen wie das erneute Zuweisen, Beheben, Verifizieren, Hinzufügen von Kunden, Dateien, Testfällen usw.
Kunden | Ermöglicht Ihnen das Hinzufügen von Informationen zu Kunden, die den Fehler gemeldet haben. Sie können die Kunden mit den Schaltflächen in der Spalte Aktionen bearbeiten und entfernen.
Abhängigkeit | Zeigt die mit dem Issue Manager-Fehler verknüpften Tests an. Geben Sie Ihre Silk Central-Anmeldeinformationen an, um diese Registerkarte zu aktivieren. Klicken Sie auf den Namen eines Tests, um zur Tests Detailansicht zu gelangen. Auf der Registerkarte Fehler der Tests Detailansicht sehen Sie alle Fehler, die dem Test zugewiesen wurden.
Benutzerdefiniert | Enthält sämtliche benutzerdefinierten Felder und Listen, die der Issue Manager-Administrator vorbereitet.
Testfälle | Ermöglicht das Hinzufügen von Silk Test-Testfällen. Mitarbeiter aus QS und Entwicklung können die Testfälle direkt durch Klicken auf [image] (Testfall ausführen) in der Spalte Aktionen ausführen. Silk Test-Testfälle können auch über den Silk Test Intelligent Assistant importiert werden. Diese Registerkarte wird nur angezeigt, wenn der ShowTestcasesTab-Tag in der Datei SRFrontendBootConf.xml auskommentiert und auf true gesetzt ist.
Übergeordnetes Thema: Übersicht
Zugehörige Tasks
Ausführen von Aktionen für Fehler
Zugehörige Verweise
Aktionen für das Arbeiten mit Fehlern


Eingeben von Fehlern

Diese Kapitel beschreibt, wie Fehler in Issue Manager erstellt und bearbeitet werden, wie der Silk Test Intelligent Assistant eingesetzt wird, um Fehler mit Silk Test-Ergebnisdateien zu erstellen und wie die Ergebnisse aus Silk Test exportiert werden.

  • Erstellen von Fehlern (Issue Manager)
    Hier wird beschrieben, wie Fehler in Issue Manager erstellt werden.
  • Bearbeiten von Fehlern (Issue Manager)
    Hier wird beschrieben, wie Fehler in Issue Manager bearbeitet werden.
  • Silk Test Intelligent Assistant
    Beschreibt den Silk Test Intelligent Assistant.
  • Importieren von Silk Test-Ergebnissen in Issue Manager
    Beschreibt den Import der Ergebnisse eines Silk Test-Tests in Issue Manager.
  • Exportieren von Ergebnissen aus Silk Test
    Hier wird beschrieben, wie Ergebnisse aus Silk Test exportiert werden.
  • Vorgeschlagene Änderungen
    Beschreibt, wie Issue Manager Änderungen an Fehlerstatus vorschlägt, wenn Sie Testfallergebnisse und Silk Test-Testfälle mit Fehlern verknüpfen.
Übergeordnetes Thema: Verwenden von Issue Manager


Erstellen von Fehlern (Issue Manager)

So erstellen Sie einen neuen Fehler in Issue Manager:
  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgung.
  2. Klicken Sie in der Symbolleiste auf [image] (Neuer Fehler).
  3. Wählen Sie die Werte für den Fehlertypen, das Produkt, die Version, die Plattform, die Komponente und die Einstufung.
    Anmerkung: Die hervorgehobenen Felder und Listen sind erforderlich.
    Bei der Eingabe der Werte ordnet Issue Manager dynamisch dem Fehler ein Postfach und einen anfänglichen Status auf der Basis der konfigurierten Rollen zu.
  4. Geben Sie eine Kurzbeschreibung und eine Beschreibung ein. Um eine Verknüpfung zwischen diesem und einem anderen Fehler zu erstellen, geben Sie im Feld Verknüpfter Fehler die Fehlernummer oder die Kurzbezeichnung des zu verknüpfenden Fehlers ein (mit Auto-Vorschlag). Verknüpfte Fehler finden Sie in der Registerkarte Historie.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Optional: Geben Sie weitere Informationen zum Fehler ein. Klicken Sie auf die Register und auf folgende Schaltflächen:
    • Kunde hinzufügen: Überwachen Sie die Informationen der Kunden, die den Fehler gemeldet haben.
    • Datei hinzufügen: Fügen Sie eine Datei mit zusätzlichen Informationen über den Fehler hinzu.
    • Testfall hinzufügen: Mitarbeiter der Bereiche QS und Entwicklung können die hinzugefügten Silk Test-Testfälle ausführen, indem sie auf [image] (Testfall ausführen) in der Spalte Aktionen des Registers Testfälle klicken. Silk Test-Testfälle können auch über den Silk Test Intelligent Assistant importiert werden.
    • Benachrichtigung hinzufügen: Legen Sie fest, ob die Benachrichtigung für einige Werte einer Fehleränderung per E-Mail gesendet werden sollen.
  6. Klicken Sie auf OK.
Die Seite Fehlerdetails wird geöffnet. Um zur Fehlerliste Ihres Postfachs zurückzukehren (Seite Fehlerverfolgung), klicken Sie auf [image] (Eigenes Postfach).
Übergeordnetes Thema: Eingeben von Fehlern


Bearbeiten von Fehlern (Issue Manager)

So bearbeiten Sie einen Fehler in Issue Manager:
  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgung.
  2. Klicken Sie in der Tabelle auf [image] (Fehler anzeigen). Die Seite Fehlerdetails wird geöffnet.
  3. Klicken Sie auf Bearbeiten.
  4. Bearbeiten Sie die Werte der Listen und Felder.
  5. Klicken Sie auf die Register, um weitere Fehlerdetails zu bearbeiten.
  6. Klicken Sie auf OK.
Die Änderungen werden in der Historie gespeichert. Klicken Sie auf das Register Historie, um die Änderungen anzuzeigen.
Übergeordnetes Thema: Eingeben von Fehlern


Silk Test Intelligent Assistant

Der Silk Test Intelligent Assistant analysiert die Testfälle in Silk Test-Ergebnisdateien (.rex). Der Assistant erstellt dann Testfallfehler, die mit Issue Manager verfolgt werden können.
Anmerkung: Das Symbol Silk Test Classic Intelligent Assistant öffnen wird nur angezeigt, wenn der ShowSilkTestAssistant-Tag in der Datei SRFrontendBootConf.xml auskommentiert und auf true gesetzt ist.

Basierend auf den Testfallergebnissen können Sie entweder neue Fehler erstellen oder existierende Fehler aktualisieren. Zum Beispiel: Wenn Sie einen Testfall ausführen und dieser fehlschlägt, kann der Intelligent Assistant den Testfall einem neuen Fehler zuordnen. QS-Mitarbeiter können daraufhin den zugeordneten Testfall direkt aus Issue Manager ausführen und ermitteln, ob der Fehler behoben wurde.

Sie können einem Fehler einen oder mehrere Testfälle zuordnen. Sie können jedoch keinen Testfall mehr als einem Fehler zuordnen. Der Intelligent Assistant betrachtet zwei Testfälle als identisch, die über denselben Skriptnamen und Testfallnamen sowie über dieselben Argumente verfügen.

Anmerkung: Sie können angeben, dass der Intelligent Assistant identische Testfälle, die auf verschiedenen Plattformen ausgeführt werden, als separate Testfälle ansehen soll. Der Intelligent Assistant schlägt dann die Behebung des Testfalls erst vor, wenn der Testfall auf allen Plattformen erfolgreich ausgeführt wird.
Übergeordnetes Thema: Eingeben von Fehlern
Zugehörige Verweise
Fehlerverfolgung (Seite)


Importieren von Silk Test-Ergebnissen in Issue Manager

So importieren Sie die Ergebnisse von Silk Test-Tests:
  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgung.
  2. Wählen Sie ein Postfach aus der Liste in der Symbolleiste aus.
  3. Klicken Sie in der Symbolleiste auf [image] (Silk Test Classic Intelligent Assistant öffnen).
  4. Suchen Sie eine .rex-Datei auf Ihrem Computer.
  5. Wählen Sie aus der Liste eine Plattform aus, um die Plattform, für die der Test ausgeführt wurde, als Faktor in der Konsolidierungslogik zu verwenden.
  6. Aktivieren Sie das Kontrollkästchen, um Tests einzubeziehen, für die keine Fehler vorliegen und die noch nicht mit einem Fehler verknüpft sind, und klicken Sie auf Weiter.
  7. Klicken Sie auf die Kontrollkästchen, um Testfälle auszuwählen, und klicken Sie auf eine der folgenden Schaltflächen:
    • Klicken Sie auf Neuer Fehler, um einen neuen Fehler zu erstellen und diesem einen Testfall zuzuweisen. Weitere Informationen finden Sie unter Erstellen von Fehlern (Issue Manager).
    • Klicken Sie auf Vorhandener Fehler und geben Sie eine Fehlernummer ein, um den Testfall zuzuweisen.
    Zugewiesene Testfälle werden nicht mehr in der Liste angezeigt.
  8. Klicken Sie auf Weiter.
  9. Bestätigen Sie die vorgeschlagenen Aktionen, und klicken Sie auf Fertig stellen.
Die Testfälle werden den Fehlern zugewiesen. Um die Testfälle auszuführen oder zu bearbeiten, klicken Sie auf die Schaltflächen in der Spalte Aktionen auf der Registerkarte Testfälle.
Übergeordnetes Thema: Eingeben von Fehlern


Exportieren von Ergebnissen aus Silk Test

So exportieren Sie Ergebnisse aus Silk Test:
  1. Klicken Sie in Silk Test auf Ergebnisse > Empfänger Issue Manager. Der Dialog Ergebnisse an Issue Manager senden wird geöffnet.
  2. Wählen Sie eine Ergebnisdatei (.res) aus.
  3. Klicken Sie auf OK. Der Intelligent Assistant wird gestartet. Die Registerkarte Intelligent Assistant wird angezeigt. Das Feld Exportierte Testergebnisse (.rex) enthält bereits den Pfad zur Ergebnisdatei.
  4. Klicken Sie auf Weiter. Der Dialog Tests zu Fehlern zuordnen wird angezeigt.
Folgen Sie den Schritten in Importieren von Silk Test-Ergebnissen in Issue Manager.
Übergeordnetes Thema: Eingeben von Fehlern


Vorgeschlagene Änderungen

Wenn Sie Testfallergebnisse und Silk Test-Testfälle mit Fehlern verknüpfen, vergleicht der Silk Test Intelligent Assistant die Ergebnisse und die aktuellen Informationen zu Fehlern, um eine Liste mit vorgeschlagenen Änderungen für Fehler zu erstellen.

Die Liste enthält für jeden Fehler eine vorgeschlagene Aktion sowie den neuen Fehlerstatus und die Begründung, die aus der Bestätigung der Aktion resultieren. Welche Aktion vorgeschlagen wird, hängt vom aktuellen Status und der aktuellen Begründung des Fehlers sowie von den Ergebnissen der zugeordneten Testfälle ab.

Der Silk Test Intelligent Assistant verwendet zur Erstellung der Liste mit Änderungsvorschlägen die folgende Gleichung:

[Aktueller Status und aktuelle Begründung] + [Testergebnis] = [Aktion, neuer Status und neue Begründung]

Beispiel: Angenommen, ein Fehler hat den Status Zu verifizieren und die Begründung Behoben. Wenn ein Testfall für diesen Fehler fehlschlägt, schlägt der Intelligent Assistant die Aktion IA-Abgelehnt vor. Nach Ausführung dieser Aktion hat der Fehler den Status Offen und die Begründung Abgelehnt. Die Gleichung würde für dieses Beispiel folgendermaßen aussehen:

[Zu verifizieren und Behoben] + [Test fehlgeschlagen] = [IA-Abgelehnt, Offen und Abgelehnt]

Übergeordnetes Thema: Eingeben von Fehlern


Arbeiten mit Fehlern

Issue Manager bietet eine Reihe von Aktionen, mit deren Hilfe Sie an Fehlern arbeiten können. Sie können z. B. Fehler als Behoben oder Implementiert markieren, Sie können angeben, dass Sie weitere Informationen benötigen oder dass ein Fehler kein Fehler mehr ist usw.

Die Schaltflächen für diese Aktionen werden rechts auf der Seite Fehlerdetails angezeigt. Eine Liste sämtlicher Aktionen finden Sie unter Aktionen für Fehler. Die Liste der Fehler hängt von dem Status des Fehlers und den Berechtigungen eines bestimmten Benutzers ab. Viele Aktionen können durch den Issue Manager Administrator konfiguriert und angepasst werden.

  • Aktionen für das Arbeiten mit Fehlern
    Hier werden alle Aktionen beschrieben, die Sie bei der Arbeit an einem Fehler verwenden können. Die Liste an Aktionen variiert je nach Status des Fehlers und nach Ihren Berechtigungen.
  • Ausführen von Aktionen für Fehler
    Beschreibt, wie Sie Aktionen für Fehler nutzen können.
  • Festlegen der Fehlerüberprüfungsoptionen
    Hier werden die Fehlerüberprüfungsoptionen und deren Festlegung beschrieben.
Übergeordnetes Thema: Verwenden von Issue Manager


Aktionen für das Arbeiten mit Fehlern

Die Seite Fehlerdetails zeigt oben eine Liste der Aktionen an. Klicken Sie auf die Verknüpfungen, um an einem bestimmten Fehler zu arbeiten. Die Verknüpfungen variieren je nach dem Status des Fehlers und nach Ihren Berechtigungen.

Hier können Sie die folgenden Aktionen ausführen:
Aktion | Beschreibung
Annehmen | Die im Fehler beschriebene Erweiterung bzw. der Dokumentationsfehler wird für die weitere Entwicklung genehmigt.
Kommentar hinzufügen | Ermöglicht es Ihnen, einen Kommentar über die an dem Fehler vorgenommene Aktion hinzuzufügen.
Problemumgehung | Der Fehler wird nicht sofort behoben, sondern es wird eine Problemumgehung dokumentiert.
Bereits fertig | Der Fehler wurde bereits behoben.
Zu entscheiden | Der Fehlerstatus wurde unterschiedlich bewertet. Die Entwicklungs-, Dokumentations- und QS-Abteilung müssen eine Entscheidung in Bezug auf diesen Fehlerstatus treffen.
Wie vorgesehen | Der Fehler ist eigentlich kein Fehler, da die Funktion ordnungsgemäß funktioniert.
Nicht machbar | Die angeforderte Erweiterung kann nicht implementiert werden.
Nicht behebbar | Der Fehler kann nicht behoben werden. Dies kann der Fall sein, wenn das Risiko oder der Zeitaufwand zu groß sind.
Fehler bestätigen | Der Fehler muss wirklich behoben werden.
In Projekt kopieren | Ermöglicht es Ihnen, die Fehler in ein anderes Projekt zu kopieren. Alle Kunden, angehängten Dateien und Testfälle werden mit dem Fehler kopiert. Benachrichtigungen werden jedoch nicht übertragen. Klicken Sie auf die Schaltfläche, wählen Sie ein Projekt in der Liste aus, und klicken Sie auf OK. Die Werte des Quell-Fehlers werden in die Felder und Listen übernommen. Bearbeiten Sie die Werte, und klicken Sie anschließend auf OK.
Zurückstellen | Ermöglicht es Ihnen, einen Fehler auf eine spätere Version zu verschieben.
Bearbeiten | Ermöglicht es Ihnen, die Werte der Felder und Listen auf der Seite Fehlerdetails und im Register Fehlerdetails zu bearbeiten.
Behoben | Der Fehler wurde behoben. Geben Sie den Build oder die Version an, in dem bzw. in der der Fehler behoben wurde.
Implementiert | Die Erweiterung wurde implementiert.
Doppelt eingetragen | Ein Fehler wurde doppelt eingetragen. Geben Sie die Fehlernummer des entsprechenden Fehlers ein. Dieser Fehler bleibt geöffnet.
Info erforderlich | Die Entwicklungsabteilung benötigt von der QS-Abteilung weitere Informationen zum Fehler. Dies kann der Fall sein, wenn ein Fehler nicht reproduziert werden kann oder die Beschreibung unklar ist.
Kein Fehler mehr | Der Fehler ist nicht mehr vorhanden. Dies kann der Fall sein, wenn eine neue Funktion oder eine andere Fehlerbehebung diesen Fehler behoben hat.
Kein Fehler | Es handelt sich um keinen Fehler. Die meldende Person hat eine Funktion missverstanden.
Nicht reproduzierbar | Der Fehler kann nicht reproduziert werden.
Neu zuweisen | Ermöglicht es Ihnen, einen Fehler einem unterschiedlichen Postfach zuzuordnen.
Ablehnen Es liegt eine der folgenden Situationen vor:
  • Der Fehler wurde behoben, kann aber nicht überprüft werden und wird deshalb zurückgewiesen.
  • Die angeforderte Erweiterung wurde nicht bestätigt.
Fehler erneut öffnen | Der Fehler wurde von der QS-Abteilung erneut geöffnet. Dies kann der Fall sein, wenn ein Fehler in einem vorherigen Build behoben wurde und in einem späteren Build erneut auftritt.
Verifizieren | Der Fehler wurde behoben, und die Fehlerbehebung wurde bestätigt.
Übergeordnetes Thema: Arbeiten mit Fehlern
Zugehörige Tasks
Ausführen von Aktionen für Fehler
Zugehörige Verweise
Fehlerdetailseite


Ausführen von Aktionen für Fehler

So führen Sie eine Aktion für einen bestehenden Fehler aus:
  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgung.
  2. Klicken Sie auf [image] (Eigenes Postfach), oder wählen Sie eine Gruppe und ein Postfach aus den Listen in der Symbolleiste aus.
  3. Klicken Sie in der Tabelle auf [image] (Fehler anzeigen). Die Seite Fehlerdetails wird geöffnet. Am oberen Seitenrand wird eine Liste der Aktionen angezeigt.
  4. Klicken Sie auf eine Aktionsverknüpfung und geben Sie die erforderlichen Werte in den Dialog ein.
Eine Liste sämtlicher Aktionen finden Sie unter Aktionen für Fehler.
Übergeordnetes Thema: Arbeiten mit Fehlern
Zugehörige Verweise
Fehlerdetailseite
Aktionen für das Arbeiten mit Fehlern


Festlegen der Fehlerüberprüfungsoptionen

Mit den Fehlerüberprüfungsoptionen legen Sie fest, wie Fehler bei jeder Erstellung eines neuen Fehlers oder bei jeder Bearbeitung eines vorhandenen Fehlers überprüft werden.

So definieren Sie die Fehlerüberprüfungsoptionen:

  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Optionen.
  3. Wählen Sie eine der folgenden Optionen aus:
    • Immer Standardzuordnung verwenden: Dies ist die Standard-Systemzuordnung.
    • Immer eigenen Fehler verifizieren: Alle eingegebenen Fehler werden zwecks Überprüfung an Sie zurückgeleitet.
    • Bei jedem neuen Fehler nachfragen: Hier können Sie für jeden einzelnen Fall festlegen, ob die Fehler an Sie zurückgeleitet werden sollen oder ob die Standard-Zuordnung verwendet werden soll.
Anmerkung: Für die Festlegung der Optionen benötigen Sie die Berechtigung Fehlerüberprüfungsoptionen. Der Issue Manager-Administrator kann Ihnen diese Berechtigung zuweisen. Wenn Sie nicht über diese Berechtigung verfügen, sind die Optionsschaltflächen deaktiviert.
Übergeordnetes Thema: Arbeiten mit Fehlern


E-Mail-Benachrichtigung

Sie können Issue Manager so konfigurieren, dass Sie beim Auftreten bestimmter vordefinierter Ereignisse benachrichtigt werden. Zu diesen Ereignissen gehören:
  • Neuzuweisung: Ein Fehler wird ohne Änderung des Status neu zugeordnet.
  • Statusänderung: Ein Fehler ändert seinen Status.
  • Jede Änderung: Durch eine Änderung an einem Fehler wird ein neuer Eintrag in der Historie generiert.
Der Issue Manager-Administrator kann zusätzliche Regeln für bestimmte Ereignisse festlegen. Sobald Regeln festgelegt wurden, können Benutzer E-Mail-Benachrichtigungen einrichten. Sie können systemweite Benachrichtigungen oder Benachrichtigungen für bestimmte Fehler festlegen. Für diese Aktionen benötigen Sie die folgenden Berechtigungen:
Aktion | Erforderliche Berechtigung
Definieren von Benachrichtigungsregeln | E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen
Definieren von E-Mail-Benachrichtigungen | E-Mail-Benachrichtigung pro Fehler
Definieren von systemweiten Benachrichtigungen | E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen

Der Systemadministrator muss die E-Mail-Server-Einstellungen konfigurieren. Ansonsten funktionieren E-Mail-Benachrichtigungen nicht.

Jeder Benutzer kann unabhängig von seinen Berechtigungen eine Standardbenachrichtigung festlegen. Wenn Sie diese Standardbenachrichtigung festlegen, benachrichtigt Issue Manager Sie, sobald ein anderer Benutzer Änderungen an einem Fehler in Ihrem Postfach vornimmt oder Ihrem Postfach einen neuen Fehler zuordnet.

  • Definieren von Benachrichtigungsregeln
    Hier wird beschrieben, wie Benachrichtigungsregeln festgelegt werden.
  • Definieren von E-Mail-Benachrichtigungen
    Hier wird beschrieben, wie E-Mail-Benachrichtigungen festgelegt werden.
  • Konfigurieren von Standardbenachrichtigungen
    Hier wird beschrieben, wie Issue Manager so konfiguriert werden kann, dass Sie benachrichtigt werden, wenn Benutzer Ihrem Eingangsordner Fehler zuordnen oder Änderungen an Fehlern in Ihrem Eingangsordner vornehmen.
Übergeordnetes Thema: Verwenden von Issue Manager
Zugehörige Konzepte
Einrichten von E-Mail-Benachrichtigungsregeln


Definieren von Benachrichtigungsregeln

Issue Manager bietet drei Standard-Benachrichtigungsregeln: Jede Änderung, Neuzuweisung und Statusänderung. So legen Sie zusätzliche Benachrichtigungsregeln fest:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie links auf Benachrichtigungsregeln.
  3. Klicken Sie auf Regel hinzufügen. Der Dialog Neue Benachrichtigungsregel wird angezeigt.
  4. Geben Sie einen Regelnamen, eine Beschreibung und eine WHERE-Klausel ein. Weitere Information finden Sie unter Definieren von E-Mail-Benachrichtigungsregeln.
  5. Markieren Sie das Kontrollkästchen Ist aktiv, um die Regel zu aktivieren.
  6. Klicken Sie auf OK.
Die Benachrichtigungsregel wird zur Liste hinzugefügt.
Anmerkung: Sie benötigen die Berechtigung E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen, um Benachrichtigungsregeln festlegen zu können.
Übergeordnetes Thema: E-Mail-Benachrichtigung
Zugehörige Tasks
Definieren von E-Mail-Benachrichtigungsregeln


Definieren von E-Mail-Benachrichtigungen

So legen Sie E-Mail-Benachrichtigungen an:
  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgung.
  2. Klicken Sie auf [image] (Eigenes Postfach), oder wählen Sie eine Gruppe und ein Postfach aus den Listen in der Symbolleiste aus.
  3. Klicken Sie in der Tabelle auf [image] (Fehler anzeigen). Die Seite Fehlerdetails wird geöffnet.
  4. Klicken Sie auf das Symbol für Benachrichtigungen.
  5. Klicken Sie auf Benachrichtigung hinzufügen. Der Dialog Benachrichtigung hinzufügen wird angezeigt.
  6. Geben Sie die erforderlichen Werte ein, und klicken Sie auf OK. Die Benachrichtigung wird zur Liste hinzugefügt.
Klicken Sie auf [image] (Benachrichtigung bearbeiten, um die Benachrichtigung zu bearbeiten, oder auf [image] (Benachrichtigung entfernen) der Spalte Aktionen, um die Benachrichtigung zu löschen. Weitere Informationen über die Konfiguration systemweiter Benachrichtigungen finden Sie unter Verwalten systemweiter Benachrichtigungen.
Übergeordnetes Thema: E-Mail-Benachrichtigung
Zugehörige Konzepte
Verwalten systemweiter Benachrichtigungen
Zugehörige Tasks
Hinzufügen von systemweiten Benachrichtigungen


Konfigurieren von Standardbenachrichtigungen

So konfigurieren Sie die Standardbenachrichtigung:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie links auf Optionen.
  3. Aktivieren Sie das Kontrollkästchen Benachrichtigen, wenn Benutzer mir Fehler zuordnen oder Änderungen an Fehlern in meinem Postfach vornehmen.
Anmerkung: Jeder Benutzer kann unabhängig von seinen Berechtigungen eine Standardbenachrichtigung festlegen. Die Betreffzeile und der Inhalt der Standardbenachrichtigung können in der Datei SRFrontendBootConf.xml konfiguriert werden.
Übergeordnetes Thema: E-Mail-Benachrichtigung


Berichte (Issue Manager)

Mit den umfassend anpassbaren Issue Manager-Berichten können Sie Daten in aussagekräftige Diagramme umwandeln. Issue Manager bietet zahlreiche vorkonfigurierte Berichte, die in drei Kategorien unterteilt sind. Diese Kategorien werden in der Hierarchie Berichte dargestellt:
  • Gängige Berichte
  • Textsuche
  • Managementberichte

Textsuchen sind Abfragen, die Berichtsdaten in Tabellenformat zurückgeben. Berichtsvorlagen werden entweder mit BIRT Report Designer, einem auf Eclipse basierendes Open-Source-Berichtstool, oder mit Microsoft Excel erstellt.

Wenn für das ausgewählte Projekt keine Daten vorliegen, oder wenn Sie nicht mit der korrekten Issue Manager-Datenbank verbunden sind, werden leere Berichte generiert.

Sie können Berichte mithilfe der benutzeroberflächenbasierten Tools oder mithilfe manuell geschriebenen SQL-Codes erstellen. Mit diesem erweiterten Ansatz sind die Möglichkeiten zur Abfrage und Darstellung von Daten in Berichten nahezu unbegrenzt.

Weitere Informationen zum Umgang mit Berichten finden Sie unter Berichte.

  • Erstellen von Berichten
    Hier wird beschrieben, wie ein Bericht in Issue Manager erstellt wird.
  • Hinzufügen von Unterberichten
    Hier wird beschrieben, wie Unterberichte, die die Ergebnisse mehrerer Berichte zusammenstellen, hinzugefügt werden.
  • Bearbeiten von Berichtseigenschaften
    Hier wird beschrieben, wie die Eigenschaften eines Berichts bearbeitet werden.
  • Bearbeiten von Berichtsparametern
    Hier wird beschrieben, wie die Parameter eines Berichts bearbeitet werden.
  • SOAP API von Issue Manager
    Beschreibt den Zugriff auf das Issue Manager-Repository mit Tools von Drittanbietern unter Verwendung der SOAP API.
Übergeordnetes Thema: Verwenden von Issue Manager
Zugehörige Konzepte
Berichte


Erstellen von Berichten

So erstellen Sie einen Issue Manager-Bericht:
  1. Klicken Sie im Menü auf Fehler > Berichte.
  2. Wählen Sie in der Hierarchie Berichte den gewünschten Ordner aus.
  3. Klicken Sie in der Symbolleiste auf [image] (Neuer untergeordneter Bericht). Der Dialog Neuen Bericht erstellen wird angezeigt.
  4. Geben Sie einen Namen und eine Beschreibung ein.
  5. Aktivieren Sie dieses Kontrollkästchen, wenn Sie Diesen Bericht anderen Benutzern zur Verfügung stellen möchten.
  6. Geben Sie eine Anwortzeit [s] ein, um festzulegen, wie lange Issue Manager wartet, bevor die Berichte abgeschlossen werden.
  7. Wählen Sie ein Standardregister und eine Ergebniskategorie in den Listen aus. Beim Zugriff auf einen Bericht über das Kontextmenü (z. B. Rechtsklick auf einen Test), werden Sie zum festgelegten Standardregister weitergeleitet.
  8. Wählen Sie ein Auswahlkriterium, eine Eigenschaft, einen Operator und einen Wert in den Listen aus. In Strings können die Platzhalter * (beliebig viele Zeichen) und "?" (genau ein Zeichen) verwendet werden.
  9. Klicken Sie auf Mehr, um einen zusätzlichen Abfragestring zu erstellen und den Operator AND oder OR für die Verbindung der Abfragestrings zu verwenden. Klicken Sie auf [image] (Entfernen), um Abfragestrings zu entfernen.
  10. Klicken Sie auf Weiter, um die Einstellungen der Spalten des Berichts zu konfigurieren. Sie können Spalten hinzufügen, Alles entfernen, die Reihenfolge durch einen Klick auf [image] festlegen (Nach oben) oder [image] (Nach unten), eine einzelne Spalten durch einen Klick auf [image] entfernen (Entfernen), die Sortierungs- und Gruppierungsoptionen festlegen und einen Alias eingeben.
  11. Klicken Sie auf Fertig stellen.

Sie können ebenfalls Berichte erstellen, indem Sie den SQL-Code von Hand eingeben. Klicken Sie im Dialog Neuen Bericht erstellen auf Erweitert, und geben Sie Ihren SQL-Code ein oder fügen Sie diesen ein. Weitere Informationen finden Sie unter Erstellen erweiterter Abfragen in SQL. Eine Liste aller verfügbaren Funktionsplatzhalter finden Sie unter SQL-Funktionen für benutzerdefinierte Berichte.

Übergeordnetes Thema: Berichte (Issue Manager)
Zugehörige Konzepte
SQL-Funktionen für benutzerdefinierte Berichte


Hinzufügen von Unterberichten

Sie können mit Hilfe von Unterberichten im aktuell ausgewählten Bericht die Ergebnisse mehrerer Berichte zusammenfassen. Die Ergebnisspalten und -zeilen eines Unterberichts werden an die Ergebnisse des ausgewählten Berichts angehängt.

So fügen Sie einen Unterbericht hinzu:

  1. Klicken Sie im Menü auf Fehler > Berichte.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie auf Unterbericht hinzufügen. Der Dialog Unterbericht hinzufügen wird angezeigt.
  5. Wählen Sie in der Berichtshierarchie den Unterbericht, den Sie an den aktuellen Bericht anhängen möchten.
  6. Klicken Sie auf OK. Unterberichte werden auf der Seite Eigenschaften des entsprechenden Berichts im Abschnitt Unterberichte angezeigt.
Wenn Sie einen Unterbericht löschen möchten, klicken Sie in der Spalte Aktionen auf [image] (Entfernen).
Übergeordnetes Thema: Berichte (Issue Manager)


Bearbeiten von Berichtseigenschaften

So bearbeiten Sie die Eigenschaften eines Berichts:
  1. Klicken Sie im Menü auf Fehler > Berichte.
  2. Wählen Sie in der Hierarchie Berichte den gewünschten Bericht aus.
  3. Klicken Sie in der Symbolleiste auf [image] (Bearbeiten). Der Dialog Bericht bearbeiten wird angezeigt.
  4. Bearbeiten Sie die gewünschten Werte.
  5. Klicken Sie auf Fertig stellen.
Weitere Informationen über die Steuerbefehle dieses Dialogs finden Sie unter Erstellen von Berichten.
Übergeordnetes Thema: Berichte (Issue Manager)


Bearbeiten von Berichtsparametern

So bearbeiten Sie die Parameter eines Berichts:
  1. Klicken Sie im Menü auf Fehler > Berichte.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Öffnen Sie die Registerkarte Parameter. Wenn für den Bericht Parameter festgelegt wurden, werden sie hier aufgelistet.
  4. Klicken Sie auf Parameter bearbeiten. Das Dialogfeld Parameter bearbeiten wird angezeigt.
  5. Bearbeiten Sie die Bezeichnung oder den Wert des gewünschten Parameters.
  6. Wählen Sie in der Liste Verwendung den Verwendungstyp des Parameters aus:
    • Konstanter Wert
    • Startzeit
    • Endzeit
  7. Klicken Sie auf OK.
Weitere Informationen zu Berichtsparametern finden unter Berichtsparameter (Seite).
Übergeordnetes Thema: Berichte (Issue Manager)
Zugehörige Verweise
Berichtsparameter (Seite)


SOAP API von Issue Manager

Zu Issue Manager gehört eine offene API (Application Programming Interface), über die mit Anwendungen von Drittanbietern auf das Repository von Issue Manager zugegriffen werden kann (beispielsweise, um einen Fehler zu übermitteln).

Die Schnittstelle, auf der die WSDL basiert, ist weiter unten dargestellt. Die Schnittstelle enthält auch die Dokumentation für die Methoden:

/**
* A Project object has a ProjectID and a ProjectName. The ProjectID
is used for all further methods
* for specifying the Issue Manager project you want to work on.
* @param sessionID
* @return Array of initialized Issue Manager projects available
for the user used for generating the sessionID
* @throws SQLException
*/

public Project[] getProjects(long sessionID) throws SQLException;

/**
* @param sessionId
* @param projectID
* @return the names of the 3 issue types
*/

public String[] getIssueTypes(long sessionId, int projectID)
throws RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @return Array of ProductNames that are configured for the
provided Issue Manager project
*/

public String[] getProducts(long sessionId, int projectID)
throws RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @param product
* @return Array of ReleaseNames that are configured for the
provided product
*/

public String[] getReleases(long sessionId, int projectID,
String product) throws RemoteException, MissingValueException,
SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @return Array of available PlatformNames
*/

public String[] getPlatforms(long sessionId, int projectID) throws
RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @param product
* @return Array of ComponentNames that are configured for the
provided product
*/

public String[] getComponents(long sessionId, int projectID,
String product) throws RemoteException, MissingValueException,
SQLException, LoginException;

/**
* The list of Severities can be grouped by IssueType or Product.
If the list is grouped by IssueType the
* parameter issueType has to be provided and the product parameter
can be empty. If the list is grouped by
* product issueType can be empty and the product has to be selected.
* @param sessionId
* @param projectID
* @param product
* @param issueType
* @return Array of values that can be used for entering an issue in
the given project when the provided
* IssueType/Product is selected.
*/

public String[] getSeverities(long sessionId, int projectID,String
product,String issueType) throws RemoteException,
MissingValueException, SQLException, LoginException,
NotExistingValueException;

/**
* @param sessionId
* @param projectID has to be a ProjectID delivered by
the method getProjects
* @param issueType has to be a values delivered by
the method getIssueTypes
* @param product has to be a values delivered by
the method getProducts
* @param release has to be a values delivered by
the method getReleases for the selected product
* @param platform has to be a values delivered by
the method getPlatforms
* @param component has to be a values delivered by
the method getComponents for the selected product
* @param severity has to be a values delivered by
the method getSeverities for the selected projectID
and IssueType/Product
* @param synopsis the Synopsis for the new issue
* @param description the Description for the new issue
* @return the Issue Number of the new issue
*/

public int saveNewIssue(long sessionId, int projectID,
String issueType, String product, String release, String
platform, String component, String severity, String
synopsis, String description) throws RemoteException,
MissingValueException, NotExistingValueException,
SQLException, LoginException;
Übergeordnetes Thema: Berichte (Issue Manager)


Projekte (Issue Manager)

Issue Manager verwendet einen projektbasierten Workflow. Dabei können nur Fehler angezeigt oder bearbeitet werden, die dem aktiven Projekt zugeordnet sind. Wenn Sie auf einzelne Fehler zugreifen möchten, müssen Sie ein Projekt auswählen. Klicken Sie im Menü auf Fehler > Projektliste und anschließend auf den Namen eines Projekts, um es zu aktivieren. Das ausgewählte Projekt bleibt so lange aktiv, bis Sie ein anderes Projekt auswählen.

  • Initialisieren der Repository-Konfiguration
    Sie müssen ein Projekt für Issue Manager initialisieren, um es verwenden zu können.
Übergeordnetes Thema: Verwenden von Issue Manager


Initialisieren der Repository-Konfiguration

Sie müssen ein Projekt für Issue Manager initialisieren, um es verwenden zu können.

Initialisierte Projekte werden in der Spalte Aktionen als initialisiert angezeigt.

So initialisieren Sie ein Projekt:

  1. Klicken Sie im Menü auf Fehler > Projektliste.
  2. Klicken Sie in der Spalte Aktionen auf [image] (Repository für Projekt <Projektname> initialisieren). Der Dialog Repository initialisieren wird angezeigt.
  3. Optional: Klicken Sie auf Beispieldaten erstellen, um Beispieldaten für die zu initialisierende Datenbank zu erstellen.
  4. Klicken Sie auf OK, um die Initialisierung zu starten. Der Dialog Konfigurationsassistent starten wird angezeigt.
  5. Klicken Sie auf Ja, um den Konfigurationsassistenten fortzusetzen, oder klicken Sie auf Nein, wenn Sie planen, Ihr Projekt später zu konfigurieren.
Weitere Informationen zur Konfiguration von Issue Manager finden Sie unter Issue Manager-Verwaltung.
Übergeordnetes Thema: Projekte (Issue Manager)
Zugehörige Konzepte
Issue Manager-Verwaltung


Issue Manager-Verwaltung

Neben der Verwaltung von Benutzerkonten und anderen Verwaltungsaufgaben teilt Issue Manager auch sein Datenbank-Repository mit Silk Central. Issue Manager-Projekte werden ebenfalls im Silk Central-Bereich Verwaltung erstellt, konfiguriert und verwaltet. Dadurch wird die vollständige Integration von Issue Manager-Projekten in Silk Central-Projekte ermöglicht.

Wenn Issue Manager zusammen mit Silk Central verwendet wird, können Projekte neben Fehlern auch zahlreiche andere Elemente enthalten, z. B. Anforderungen, Tests und Testsuiten.

Issue Manager-Projekte

Issue Manager verwendet einen projektbasierten Workflow. Dabei können nur Fehler angezeigt oder bearbeitet werden, die dem aktiven Projekt zugeordnet sind. Bevor Sie auf einen Fehler zugreifen können, müssen Sie im Bereich Projekte ein Issue Manager-Projekt auswählen. Das gewählte Projekt wird bei allen nachfolgenden Zugriffen auf Issue Manager als aktuelles Projekt verwendet, bis Sie ein anderes Projekt auswählen.

Initialisieren der Datenbankkonfiguration

Nachdem ein Projekt erstellt wurde, muss seine Datenbankverbindung initialisiert werden. Erst dann kann es als Issue Manager-Projekt genutzt werden.

  • Einrichten Ihrer Daten
    Beschreibt, wie Sie Informationen zu Ihrem Unternehmen in eine Datenbank eingeben können.
  • Routinemäßige Verwaltungsaufgaben
    Beschreibt die routinemäßigen Verwaltungsaufgaben, die Sie für Issue Manager ausführen müssen.
  • Optionale Funktionen
    Beschreibt optionale Funktionen, die für Issue Manager verfügbar sind.
  • Einrichten von Gruppen
    Hier wird beschrieben, wie Benutzergruppen in Issue Manager eingerichtet werden.
  • Einrichten von Postfächern
    Hier wird beschrieben, wie Postfächer in Issue Manager eingerichtet werden.
  • Einrichten von Benutzerkonten
    Hier wird beschrieben, wie Benutzergruppen zur Fehlerverwaltung eingerichtet werden.
  • Festlegen von Produkteinstellungen
    Hier wird beschrieben, wie Produkteinstellungen festgelegt werden.
  • Einrichten von Zuordnungsregeln
    Hier wird beschrieben, wie Sie Zuordnungsregeln festlegen können, um die Postfächer zu bestimmen, denen Fehler während ihres Lebenszyklus zugeordnet werden.
  • Anpassen der Seite "Fehlerdetails"
    Hier wird beschrieben, wie das Erscheinungsbild und Verhalten von Fehlerseiten geändert werden kann.
  • Anpassen des Workflow
    Hier wird beschrieben, wie Workflows angepasst werden.
  • Fehlerarchivierung
    Hier wird die Fehlerarchivierung beschrieben.
  • Einrichten von E-Mail-Benachrichtigungsregeln
    Beschreibt E-Mail-Benachrichtigungsregeln und Benachrichtigungen
Übergeordnetes Thema: Issue Manager


Einrichten Ihrer Daten

Wenn Sie sich mit der Verwendung von Issue Manager vertraut gemacht haben, können Sie Informationen zu Ihrem Unternehmen in eine Datenbank eingeben. Sie können diese Informationen auf der Seite Konfiguration eingeben. Um die Seite Konfiguration zu öffnen, klicken Sie auf Fehler > Konfiguration.

Der erste Schritt besteht darin, Informationen über den Workflow in Ihrem Unternehmen zu sammeln. Nehmen Sie sich Zeit für eine sorgfältige Planung. Um Issue Manager in Ihrem Unternehmen effektiv zu verwenden, müssen Sie Informationen zu den folgenden wichtigen Themen sammeln:
  • Personal
  • Produkte
  • Die Eignung der Seite Fehlerverfolgung, der Aktionsdialoge und des Workflows von Issue Manager für Ihr Unternehmen.
Führen Sie folgende Aktivitäten in folgender Reihenfolge aus:
  1. Sammeln Sie Informationen über die Mitarbeiter in Ihrem Unternehmen.
  2. Sammeln Sie Informationen über Produkte.
  3. Optional: Analysieren Sie die Schnittstelle und den Workflow von Issue Manager. Sie können die Seite Fehlerverfolgung, die Aktionsdialoge, die Liste der Einstufungen und den Workflow auf der Seite Konfiguration anpassen.
  4. Erstellen Sie Ihre eigene Datenbank, und füllen Sie sie mit den eingerichteten Daten.
  • Sammeln von Informationen über die Mitarbeiter Ihres Unternehmens
    Sammeln Sie Informationen über die Mitarbeiter Ihres Unternehmens, um Issue Manager effizient einsetzen zu können.
  • Sammeln von Informationen über Produkte
    Sammeln Sie Informationen über Produkte Ihres Unternehmens, um Issue Manager effizient einsetzen zu können.
  • Optional: Zuordnen der Schnittstelle und Workflows
    Ordnen Sie die Schnittstelle und Workflows von Issue Manager für den effizienten Einsatz von Issue Manager innerhalb Ihres Unternehmens zu.
Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
Datenbanken


Sammeln von Informationen über die Mitarbeiter Ihres Unternehmens

So sammeln Sie Informationen über die Mitarbeiter Ihres Unternehmens:
  1. Erstellen Sie eine Gruppenliste.
  2. Legen Sie fest, welche Berechtigungen und anfänglichen Fehlerstatuswerte für die einzelnen Mitglieder der Gruppen angemessen sind.
  3. Erstellen Sie eine Kontoliste. Jeder Benutzer, der sich bei Issue Manager anmeldet, muss über ein Konto verfügen.
  4. Legen Sie ein Benennungsschema für die Konten fest. Bedenken Sie auch die Gruppenzugehörigkeit, und weisen Sie, falls erforderlich, eines oder mehrere Postfächer zu. Stellen Sie sich folgende Fragen:
    • Welche Konten benötigen eigene Sicherheitsberechtigungen, die von den Berechtigungen der Gruppe nicht abgedeckt werden?
    • Sollen die anfänglichen Fehlerstatuswerte für dieses Konto von denen der Gruppe abweichen?
    • Soll bei der Anmeldung ein Kennwort erforderlich sein?
  5. Während Sie die Liste der Benutzerkonten überprüfen, notieren Sie sich, welche Benutzer Postfächer benötigen. Gibt es auch Gruppen, die Postfächer benötigen? Legen Sie ein Benennungsschema für Postfächer fest.
  6. Die Standardansicht kann für alle Benutzer angepasst werden. Alle Benutzer haben dieselbe Standardansicht für Postfächer. Zu dieser Ansicht gehören acht Informationsspalten.
Übergeordnetes Thema: Einrichten Ihrer Daten


Sammeln von Informationen über Produkte

So sammeln Sie Informationen über die Produkte Ihres Unternehmens:
  1. Erstellen Sie eine Liste der Produkte, Produktversionen und Plattformen für jede Version.
  2. Vergleichen Sie Ihre Liste der Plattformen mit der Liste unter Verwaltung > Plattformen.
  3. Erstellen Sie eine Liste der Software- und Dokumentationskomponenten für jedes Produkt. Komponenten (funktionale Bereiche) sind nicht erforderlich. Sie erlauben aber die Fehlerverfolgung auf Grundlage von Produkten, Versionen, Plattformen und Komponenten und ermöglichen die bessere Kontrolle über die Zuordnung von Fehlern.
  4. Erstellen Sie eine Liste von Einstufungen für Fehler. Die Werte dieser Liste werden in der Spalte Einstufung der Seite Fehlerverfolgung angezeigt. Sie können diese Liste nach Produkten oder Fehlertypen gruppieren oder als allgemeine Liste der Produkte und Fehlertypen anzeigen.
  5. Vergleichen Sie Ihre Liste mit der Liste unter Verwaltung > Werteliste.
  6. Legen Sie fest, welches Postfach einen Fehler in Abhängigkeit von einem bestimmten Produkt, einer Komponente, Version und Plattform aufnehmen soll. Diese Festlegung nennt man Zuordnungsregeln.
Übergeordnetes Thema: Einrichten Ihrer Daten


Optional: Zuordnen der Schnittstelle und Workflows

So ordnen Sie die Schnittstelle und Workflows von Issue Manager zu:
  1. Legen Sie das Erscheinungsbild und das Verhalten der Seite Fehlerverfolgung fest. Überlegen Sie, ob die folgenden Aktionen durchgeführt werden sollen:
    • Ändern Sie die Standardbezeichnungen der Spalten.
    • Fügen Sie Spalten hinzu, um zusätzliche Informationen zu sammeln.
    • Ändern Sie Felder im Dialog Aktion oder fügen Sie eigene Felder hinzu.
    Notieren Sie sich Ihre Änderungen in einer Liste. Es liegt in Ihrer Verantwortlichkeit, die Benutzer in Ihrem Unternehmen über alle Änderungen auf dem Laufenden zu halten.
  2. Überprüfen Sie, ob die Standard-Workflows die Verhältnisse in Ihrem Unternehmen richtig abbilden. Beobachten Sie jeden Status und die gültigen Aktionen für jeden Status. Reichen die Gruppenberechtigungen für die einzelnen Aktionen aus?
Übergeordnetes Thema: Einrichten Ihrer Daten


Routinemäßige Verwaltungsaufgaben

Gelegentlich fallen nach Abschluss der ursprünglichen Einrichtung routinemäßige Verwaltungsaufgaben an, um Issue Manager aktuell zu halten. Die folgenden sind die am häufigsten auftretenden Aufgaben:

Hinzufügen eines neuen Benutzers

Für neue Benutzer müssen Sie folgende Aufgaben ausführen:
  • Erstellen eines Postfachs (bei Bedarf), bevor das Konto eingerichtet wird.
  • Einrichten eines neuen Kontos und Zuordnen des Kontos zu einer vorhandenen Gruppe und (falls erforderlich) zu einem Postfach.
  • Hinzufügen der Postfächer des Benutzers zu den Weiterleitungsregeln, wenn der Benutzer durch automatische Zuordnung über Fehler benachrichtigt werden soll.

Entfernen eines Benutzers

Wenn ein Benutzer Ihre Organisation verlässt, sollten Sie folgende Aufgaben ausführen:
  • Deaktivieren Sie unverzüglich das Konto des Benutzers, sodass er sich nicht mehr anmelden kann. Sie können ein Konto nicht löschen, wenn ein Benutzer Fehler erstellt oder bearbeitet hat.
  • Ersetzen Sie in den Zuordnungsregeln alle Referenzen auf das Postfach des Benutzers durch ein anderes Postfach. Dadurch verhindern Sie, dass weiterhin Fehler in dieses Postfach gelangen.
    Anmerkung: Sie sollten Änderungen an den Zuordnungsregeln nur dann vornehmen, wenn keine anderen Benutzer bei Issue Manager angemeldet sind.
  • Leeren Sie das Postfach des Benutzers, indem Sie die Fehler anderen Postfächern zuordnen.
  • Löschen Sie das Postfach des Benutzers.

Zuordnungen neu verteilen

Wenn Benutzer die Arbeitsstelle wechseln, müssen Gruppenzuordnungen aktualisiert werden. Nehmen wir beispielsweise an, die QS-Mitarbeiterin Sarah wechselt in die Entwicklungsabteilung. Auch die Zuordnungsregeln müssen geändert werden, damit den Benutzern die Fehler zugeordnet werden, die in ihrem neuen Verantwortungsbereich liegen. Sarah sollte nun Fehler erhalten, die die Aufmerksamkeit einer Entwicklerin erfordern, statt derer der QS-Abteilung.

Wenn Benutzer das Projekt wechseln, müssen die Zuordnungsregeln an die neuen Zuständigkeiten angepasst werden. Außerdem müssen Sie dafür sorgen, dass das Standardpostfach weiterhin gültig ist. Angenommen, Judy ist eine Autorin, die bisher Handbücher für Produkt A erstellt hat, sich nun aber mit Dokumenten für Produkt B beschäftigt. In diesem Fall sollte das Standardpostfach von Judy – Judy - Dok (Produkt A) – in Judy - Dok (Produkt B) geändert werden.

Hinzufügen neuer Produktinformationen

Manchmal müssen Sie folgende Aufgaben ausführen:
  • Hinzufügen neuer Produkte.
  • Fügen Sie neue Versionen, Plattformen und Komponenten für bestehende Produkte hinzu.
  • Passen Sie die Zuordnungsregeln an neue Produkte, Komponenten, Versionen und Plattformen an.
Übergeordnetes Thema: Issue Manager-Verwaltung


Optionale Funktionen

Nachdem Sie Ihre Datenbank eingerichtet und sich mit der Verwendung von Issue Manager vertraut gemacht haben, können Sie folgende optionale Funktionen verwenden.

E-Mail-Benachrichtigung

Die E-Mail-Benachrichtigung erlaubt Benutzern von Issue Manager, sich per E-Mail benachrichtigen zu lassen, wenn im Zusammenhang mit einem Fehler bestimmte Ereignisse eintreten (z. B. Neuzuordnung oder Statusänderung). Benutzer mit der Berechtigung E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen können weitere Bedingungen für das Versenden von E-Mail-Benachrichtigungen definieren. Befragen Sie die Benutzer, unter welchen Umständen sie per E-Mail benachrichtigt werden möchten.

Archivieren von Fehlern

Je mehr Fehler die Datenbank enthält, umso länger dauert die Ausführung von Aktionen (z. B. von Abfragen). Damit die allgemeine Leistung nicht beeinträchtigt wird, erlaubt Issue Manager das Archivieren von Fehlern, die für Ihr Unternehmen nicht mehr von Bedeutung sind. Beim Archivieren werden die entsprechenden Fehler in der Datenbank isoliert. Abfragen können beispielsweise nur mit aktiven Fehlern durchgeführt werden.

Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
Einrichten von E-Mail-Benachrichtigungsregeln
Zugehörige Tasks
Archivieren von Fehlern


Einrichten von Gruppen

Je nach der Struktur Ihres Unternehmens kann es sich bei Gruppen um ganze Abteilungen, abteilungsübergreifende Projektteams oder abteilungsinterne Teams handeln.

Jede Gruppe kann unterschiedliche Sicherheitseinstellungen und Berechtigungen haben. Mit der Einrichtung einer Issue Manager-Gruppe wird auch festgelegt, an welchem Punkt Fehler, die durch die Gruppenmitglieder gemeldet werden, in den Workflow eintreten. Mit der Einrichtung einer Benutzergruppe wird festgelegt, welche Aktionen die Benutzer in Issue Manager durchführen können und wie Fehler, die durch den Benutzer gemeldet werden, zugeordnet werden.

Die Beispieldatenbank umfasst folgende Standardgruppen:
  • Unternehmen
  • Entwicklung
  • Dokumentation
  • Qualitätssicherung
  • F&E-Management
  • Technischer Support

Alle Issue Manager-Benutzer müssen unabhängig von ihren Aufgaben einer Gruppe zugeordnet sein. Ein Benutzer kann immer nur einer Gruppe zur selben Zeit angehören.

Gruppen müssen eingerichtet werden, bevor Sie Postfächer und Benutzerkonten konfigurieren, da jedes Postfach und jeder Benutzer einer Gruppe zugeordnet werden muss.

Anmerkung: Unter Verwaltung > Benutzerverwaltung können Gruppen auf der Registerkarte Gruppen erstellt, bearbeitet und gelöscht werden, Issue Manager-spezifische Gruppeneinstellungen können unter Fehler > Konfiguration > Gruppen vorgenommen werden.
  • Gruppeneigenschaften
    Hier werden die Eigenschaften der Gruppen in Issue Manager beschrieben.
Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
Einrichten von Benutzerkonten


Gruppeneigenschaften

Gruppen haben eine Vielzahl von Eigenschaften. Grundlegende Gruppeninformationen (z. B. der Gruppenname) sind im Register Gruppen unter Verwaltung > Benutzerverwaltung enthalten. Spezielle Gruppeneinstellungen für Issue Manager (z. B. anfängliche Status und bestimmte Berechtigungen) werden im Register Gruppen unter Fehler > Konfiguration angegeben.

Anmerkung: Sie müssen eine Gruppe erstellen, bevor Sie die spezifischen Gruppeneinstellungen für Issue Manager ändern können.
  • Gruppeninformationen
    Hier werden die Eigenschaften aufgelistet, die Sie für eine Gruppe unter Verwaltung > Benutzerverwaltung wählen können.
  • Anfänglicher Fehlerstatus
    Beschreibt den anfänglichen Fehlerstatus für eine Gruppe.
  • Sicherheitseinstellungen für Gruppen
    Hier werden die Sicherheitseinstellungen für Gruppen beschrieben.
Übergeordnetes Thema: Einrichten von Gruppen
Zugehörige Konzepte
Eigenschaften des Benutzerkontos


Gruppeninformationen

Die nachstehende Tabelle enthält die Eigenschaften, die Sie für eine Gruppe unter Verwaltung > Benutzerverwaltung wählen können.
Eigenschaft | Beschreibung
Name | Erforderlicher eindeutiger Name einer Gruppe, z. B. Dokumentation. Kann bis zu 20 Zeichen enthalten.
Description | Optional: Gruppenbeschreibung, z. B. Dokumentation erzeugt alle technischen Dokumente, einschließlich der Handbücher und Versionshinweise. Kann bis zu 80 Zeichen enthalten.
Account and Role Assignment | Den Benutzern müssen bestimmte Rollen zugeordnet werden.
Project Assignment | Eine Gruppe muss mindestens einem Projekt zugeordnet werden. Benutzer, die einer Gruppe zugeordnet sind, haben nur Zugriff auf die Projekte, die der entsprechenden Gruppe zugeordnet sind.
Übergeordnetes Thema: Gruppeneigenschaften


Anfänglicher Fehlerstatus

Der anfängliche Fehlerstatus ist der erste Status, der einem Problem-, Erweiterungs- oder Dokumentationsfehler zugeordnet wird, wenn er von Mitgliedern einer bestimmten Gruppe übergeben wird. Verschiedene Gruppen können für denselben Fehlertyp einen unterschiedlichen Anfangsstatus verwenden. Jeder Fehlertyp (Problem, Erweiterung und Dokumentation) kann sogar innerhalb einer Gruppe einen unterschiedlichen Anfangsstatus haben.

Sie können z. B. einem Software-Problem, das von Mitgliedern der Gruppe Entwicklung übergeben wurde, den Anfangsstatus Offen zuweisen, da Sie davon ausgehen, dass Entwickler genau beurteilen können, was ein Software-Problem ist. Dagegen können Sie einem Software-Problem, das von Mitgliedern der Gruppe "Firma" übergeben wird, den Anfangsstatus Ungeprüft zuordnen. So können Sie überprüfen, ob der Fehler tatsächlich neu ist, bevor Sie ihn an die Entwicklungsabteilung zur Behebung senden.

Issue Manager stellt eine Reihe von Standardstatuswerten bereit, aus denen Sie wählen können. Sie können auch Ihre eigenen Fehlerstatuswerte erstellen, bevor Sie die Gruppen in Ihrer Organisation erstellen.

Obwohl der Anfangsstatus für jedes Gruppenmitglied gilt, können Sie diese Einstellung für bestimmte Benutzer überschreiben.

Übergeordnetes Thema: Gruppeneigenschaften
Zugehörige Konzepte
Einrichten von Benutzerkonten
Anpassen des Workflow
Anfänglicher Fehlerstatus


Sicherheitseinstellungen für Gruppen

Sicherheitsberechtigungen legen fest, welche Aktivitäten alle Benutzer in einer Gruppe durchführen können. Sie können einem bestimmten Benutzer in einer Gruppe zusätzliche Berechtigungen zuweisen, indem Sie sein Konto bearbeiten. Berechtigungen, die der Gruppe des Benutzers erteilt wurden, können jedoch nicht entfernt werden.

Klicken Sie unter Fehler > Konfiguration > Gruppen auf Gruppeneinstellungen definieren, um Sicherheitsberechtigungen einer Gruppe zuzuordnen. Markieren Sie das Kontrollkästchen, um die entsprechende Berechtigung der Gruppe zuzuordnen. Um einer Gruppe SuperUser-Berechtigungen zu erteilen, markieren Sie alle Kontrollkästchen.

Folgende Tabelle listet alle Berechtigungen auf, die Gruppenmitgliedern zugeordnet werden können, um bestimmte Anpassungsaufgaben durchzuführen:
Auswahlfeld | Beschreibung
Gruppen, Postfächer und Benutzerkonten | Erstellen und Bearbeiten von Gruppen, Postfächern und Benutzerkonten, einschließlich von Berechtigungen.
Produkte | Erstellen und Bearbeiten von Produkten, Versionen, Plattformen und Komponenten. Bearbeiten der Liste Plattformen und anderer Listen.
Zuordnungsregeln | Festlegen, wie ein Fehler von einem Postfach zum nächsten gelangt, abhängig vom Produkt, der Version, der Plattform und der Komponente, für die der Fehler gemeldet wurde.
GUI-Anpassung | Anpassen von Feldern und Registern auf der Seite Fehlerdetails.
Workflow-Anpassung | Festlegen von Fehlerstatus und Aktionen, Aktionsberechtigungen, Hilfetext, Erscheinungsbild und Verwendung der Aktionsdialoge.
E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen | Festlegen von E-Mail-Benachrichtigungsregeln und E-Mail-Benachrichtigungen, die für alle Fehler in der Datenbank gelten.
Fehler archivieren | Entfernt ausgewählte Fehler von den zugeordneten Fehlern und Tabellen und legt diese im ARCHIV und den diesem zugeordneten Tabellen ab.
Die folgende Tabelle listet die Berechtigungen auf, die die Zuordnung von Fehlern und E-Mail-Benachrichtigungen beeinflussen:
Auswahlfeld | Beschreibung
Fehler neu zuweisen | Verschieben von Fehlern aus einem Postfach in ein anderes.
Fehlerüberprüfungsoptionen | Markieren, um die Standard-Zuordnungsregeln zu überschreiben.
E-Mail-Benachrichtigung pro Fehler | Hinzufügen von E-Mail-Benachrichtigungen zu bestimmten Fehlern.
Fehler eingeben/bearbeiten | Berechtigung, Fehler einzugeben und zu bearbeiten.
Übergeordnetes Thema: Gruppeneigenschaften
Zugehörige Konzepte
Einrichten von Benutzerkonten
Sicherheitseinstellungen für Benutzer
Umgehen der automatischen Zuordnung


Einrichten von Postfächern

Ein Postfach ist mit einem Posteingang vergleichbar. Alle offenen, aktiven Fehler, die einem bestimmten Benutzer oder einer bestimmten Benutzergruppe zugeordnet sind, werden an das Postfach übermittelt. Verwechseln Sie den Begriff des Postfachs nicht mit dem Benutzerkonto. Fehler werden immer Postfächern und nicht einem bestimmten Benutzer zugeordnet.

Anmerkung: Archivierte Fehler werden nicht in Postfächern angezeigt.

Wie werden Fehler Postfächern zugeordnet?

Durch die Zuordnungsregeln von Issue Manager werden Fehler automatisch an die richtigen Postfächer verteilt. Ein Fehler bleibt so lange in einem Postfach, bis der Benutzer eine Aktion mit ihm durchführt (z. B. bis ein Entwickler ein Problem behebt). Dann leitet Issue Manager den Fehler automatisch an das nächste Postfach weiter, wobei Ihre Workflow- und Zuordnungsregeln befolgt werden. Wird ein Fehler geschlossen, löscht Issue Manager ihn aus dem letzten Postfach.

Ein Fehler kann auch dadurch einem anderen Postfach zugeordnet werden, dass ein Benutzer mit der Berechtigung Fehler neu zuordnen ihn manuell dem anderen Postfach zuweist.

Welche Benutzer benötigen Postfächer?

Alle Benutzer, die Aktionen mit Fehlern durchführen, sollten über ein Postfach verfügen. Dazu gehören Entwickler, Qualitätssicherungsbeauftragte und Mitarbeiter der technischen Dokumentation. Benutzer, die Fehler nur melden oder inspizieren, benötigen kein Postfach. Dies gilt auch für Mitarbeiter des technischen Support, die routinemäßig beim Kunden gefundene Fehler melden, ohne bestimmte Aktionen durchzuführen.

Wie viele Postfächer benötigt ein Benutzer?

Ein Benutzer kann über mehrere Postfächer verfügen. So ist es beispielsweise sinnvoll, für Problemberichte von zwei verschiedenen Produkten auch zwei Postfächer zu verwenden. In diesem Fall könnten Sie die beiden Postfächer Dan - Dev (Produkt A) und Dan - Dev (Produkt B) einrichten.

Einzelpostfächer und Gruppenpostfächer

Postfächer können für einzelne Benutzer, Benutzergruppen oder Teilmengen von Fehlern eingerichtet werden. Angenommen, die QS-Mitarbeiter Sarah und Mike sind dafür verantwortlich, berichtigte Fehler in verschiedenen Produkten zu überprüfen. In diesem Fall würden Sie die beiden Postfächer Sarah - QS und Mike - QS einrichten.

Benutzer können Postfächer auch gemeinsam nutzen. Die Gruppe Produktmanagement benötigt beispielsweise nur ein Postfach, an das alle Erweiterungen gesendet werden. Die Gruppe überprüft in regelmäßigen Abständen die vorgeschlagenen Verbesserungen. In dieser Situation genügt ein einziges Postfach namens PM - Postfach.

Ein Postfach kann auch als Aufbewahrungsort für eine Teilmenge von Fehlern dienen. Sie können beispielsweise ein Postfach für alle zurückgestellten Fehler von Produkt C erstellen. In diesem Fall bietet sich ein Postfach namens Zurückgestellt (Produkt C) an.

Zuweisen des Standardpostfachs eines Benutzers

Wenn Sie ein Benutzerkonto einrichten, weisen Sie diesem Benutzerkonto ein Postfach zu. Dieses Postfach ist das Standardpostfach des Benutzers. Jeder Benutzer hat nur ein einziges Standardpostfach.

Anzeigen des Standardpostfachs und der weiteren Postfächer

Unter Fehler > Fehlerverfolgung können Sie sich Ihr Standardpostfach anzeigen lassen. Wenn das Standardpostfach nicht angezeigt wird, klicken Sie in der Symbolleiste auf Mein Postfach.

Um sich ein anderes als das Standardpostfach anzeigen zu lassen, wählen Sie ein anderes Postfach aus dem Listenfeld Postfach aus. Jeder Benutzer kann sich jedes beliebige Postfach anzeigen lassen. Nur ein Benutzer mit den entsprechenden Berechtigungen kann jedoch eine Aktion mit einem Fehler durchführen oder diesen neu zuweisen.

Standardansicht des Systems

Issue Manager stellt eine anfängliche Standardansicht der Postfächer für alle Benutzer bereit. Diese Standardansicht kann für alle Benutzer angepasst werden.

  • Hinzufügen eines Postfachs
    Hinzufügen eines Postfachs für einen Benutzer, um diesem Fehler zuzuweisen.
  • Bearbeiten eines Postfachs
    Bearbeiten eines Postfachs, um dieses den geänderten Benutzerrollen anzupassen.
  • Löschen eines Postfachs
    Das Löschen eines Postfachs ist nur möglich, wenn es keine Fehler enthält, nicht in den Zuordnungsregeln referenziert wird und nicht das Standardpostfach eines Benutzers ist.
  • Einrichten der anfänglichen Standardansicht für Postfächer
    Hier wird beschrieben wie die anfängliche Standardansicht für Postfächer in Issue Manager eingerichtet wird.
Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
Einrichten von Benutzerkonten


Hinzufügen eines Postfachs

Für jeden Benutzer, der Aktionen mit Fehlern durchführt, sollte mindestens ein Postfach erstellt werden.

Anmerkung: Um Postfächer hinzuzufügen, zu bearbeiten oder zu löschen, benötigen Sie die Berechtigung Gruppen, Postfächer und Benutzerkonten.

So fügen Sie ein Postfach hinzu:

  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Postfächer. Die Seite Postfächer wird geöffnet.
  3. Klicken Sie auf Postfach hinzufügen. Der Dialog Postfacheinstellungen wird angezeigt.
  4. Geben Sie einen Namen für das Postfach in das Feld Name ein.
    Jedes Postfach erfordert einen eindeutigen Namen, bestehend aus bis zu 50 Zeichen. Hier einige Beispiele für den Postfachnamen:
    • Dave (Entw.)
    • PM-Postfach
    • Jesse - Dok.
    • Dan - Entw. (Produkt A)
    • Dan - Entw. (Produkt B)
    Namen von Benutzerpostfächern können jedes beliebige Format haben. Sie sollten dieses Format jedoch konsequent einhalten. Hier einige Beispiele für das Format:
    • Benutzer (Gruppe)
    • Benutzer - Gruppe
    • Benutzer - Gruppe (Produktname)
    • user
    Gruppenpostfächer sollten einem einheitlichen Format folgen, wie zum Beispiel:
    • Gruppe
    • Gruppe (Produktname)

    Sonderzeichen sind nicht erlaubt. Postfachnamen werden auf der Seite Postfächer in ASCII-Sortierfolge angezeigt (Großbuchstaben zuerst).

  5. Klicken Sie im Listenfeld Gruppe auf die Gruppe, die diesem Postfach zugewiesen ist. Auf Grundlage dieser Zuordnung unterstützt Issue Manager Sie bei der selektiven Neuzuordnung von Fehlern. Angenommen, Denise aus der Gruppe Dokumentation ordnet einen Fehler in ihrem Postfach neu zu. Issue Manager öffnet den Dialog Neuzuweisung mit Dokumentation als Standardgruppe. Denise kann nun ein anderes Mitglied der Gruppe Dokumentation in der Liste Neues Postfach wählen, ohne die gesamte Postfachliste durchsuchen zu müssen.
  6. Optional: Geben Sie in das Feld Beschreibung eine Beschreibung des Postfachs ein. Die Beschreibung kann bis zu 80 Zeichen lang sein. Beispiel: Postfach des Entwicklers David Hanson oder Postfach von dhart für Fehler an Produkt B.
  7. Das Kontrollkästchen Ist Aktiv ist standardmäßig aktiviert.
    Anmerkung: Wenn das Postfach in den Zuordnungsregeln verwendet wird, können Sie das Kontrollkästchen Ist aktiv nicht deaktivieren.
  8. Klicken Sie auf OK, um das neue Postfach zu erstellen.
Übergeordnetes Thema: Einrichten von Postfächern


Bearbeiten eines Postfachs

Anmerkung: Um Postfächer hinzuzufügen, zu bearbeiten oder zu löschen, benötigen Sie die Berechtigung Gruppen, Postfächer und Benutzerkonten.

So bearbeiten Sie ein Postfach:

  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Postfächer. Die Seite Postfächer wird geöffnet.
  3. Klicken Sie auf den Namen des Postfachs, das Sie bearbeiten möchten. Der Dialog Postfacheinstellungen wird angezeigt.
  4. Bearbeiten Sie den Namen des Postfachs.
  5. Wählen Sie im Listenfeld Gruppe eine andere Gruppe aus.
  6. Bearbeiten Sie die Beschreibung des Postfachs.
  7. Markieren Sie das Kontrollkästchen Ist aktiv oder wählen Sie dieses ab.
    Anmerkung: Wenn das Postfach in den Zuordnungsregeln verwendet wird, können Sie das Kontrollkästchen Ist aktiv nicht deaktivieren.
  8. Klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Einrichten von Postfächern


Löschen eines Postfachs

Ein Postfach kann nur gelöscht werden, wenn es keine Fehler enthält, nicht in den Zuordnungsregeln referenziert wird und nicht das Standardpostfach eines Benutzers ist. Bevor Sie versuchen, ein Postfach zu löschen, bearbeiten Sie die Zuordnungsregeln, damit keine neuen Fehler an das Postfach gesendet werden, und ordnen Sie die Fehler, die sich im Postfach befinden, neu zu.

Anmerkung: Um Postfächer hinzuzufügen, zu bearbeiten oder zu löschen, benötigen Sie die Berechtigung Gruppen, Postfächer und Benutzerkonten.

So löschen Sie ein Postfach:

  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Postfächer. Die Seite Postfächer wird geöffnet.
  3. Klicken Sie in der Spalte Aktionen des Fehlers, den Sie löschen möchten, auf [image]. Ein Bestätigungsdialog wird geöffnet.
  4. Klicken Sie auf Ja, um das Postfach vom System zu löschen.
Übergeordnetes Thema: Einrichten von Postfächern
Übergeordnetes Thema: Einrichten von E-Mail-Benachrichtigungsregeln


Einrichten der anfänglichen Standardansicht für Postfächer

Bei der Installation von Issue Manager besteht die anfängliche Standardansicht für Postfächer aus den folgenden acht Spalten:
  • Einstufung
  • Fehler-Nr.
  • Produkt
  • Komponente
  • Version
  • Kurzbezeichnung
  • Erstellt von
  • Geändert von
Sie können die anfängliche Standardansicht für Postfächer aller Benutzer wie folgt anpassen:
  • Spalten hinzufügen oder entfernen.
  • Die Bezeichnung einer Spalte bearbeiten.
  • Die Sortierreihenfolge einer Spalte ändern.

Einzelne Benutzer können benutzerdefinierte anfängliche Ansichten von Postfächern erstellen.

  • Bearbeiten der Standardansicht für Postfächer
    Bearbeiten Sie die ursprüngliche Standardansicht für Postfächer, um die angezeigten Spalten zu ändern.
Übergeordnetes Thema: Einrichten von Postfächern


Bearbeiten der Standardansicht für Postfächer

Anmerkung: Um Postfächer hinzuzufügen, zu bearbeiten oder zu löschen, benötigen Sie die Berechtigung Gruppen, Postfächer und Benutzerkonten.
So bearbeiten Sie die ursprüngliche Standardansicht:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Postfachansichten. Die Seite Postfachansichten wird geöffnet. Auf dieser Seite werden alle Felder angezeigt, die Sie für die Ansicht eines Postfachs auswählen können. Die meisten der Felder stammen von der Seite Fehlerdetails. Andere, z. B. Historie-Einträge, Anzahl Kunden, Anzahl Dateien, Anzahl Tests und Benachrichtigungen beziehen sich auf die Anzahl der Einträge auf den Seiten Historie, Kunden, Anhänge, Testfälle und Benachrichtigungen auf der Seite Fehlerdetails. Die Seite Postfachansichten zeigt auch das Schema oder den DB-Feldnamen einer jeden Spalte an.
  3. Wählen Sie im Listenfeld Ansicht von Benutzer STANDARDANSICHT DES SYSTEMS aus. Um die Postfachansichten anderer Benutzer zu aktualisieren, wählen Sie stattdessen den entsprechenden Benutzer aus.
  4. Um eine Spalte zum Postfach hinzuzufügen, klicken Sie auf das Select Column, das der Spalte in der Liste der verfügbaren Felder entspricht.
  5. Um eine Spalte aus dem Postfach zu entfernen, klicken Sie auf das Deselect Column, das der Spalte in der Liste der Postfachspalten entspricht.
  6. Um die Bezeichnung einer Spalte und die Sortierfolge zu ändern, führen Sie folgende Schritte aus:
    1. Klicken Sie auf den Namen der Postfachspalte in der Spalte Postfach-Spaltenbezeichnung. Der Dialog Postfach-Spalteneigenschaften wird geöffnet.
    2. Geben Sie eine neue Bezeichnung für die Spalte in das Feld Postfach-Spaltenbezeichnung ein.
    3. Klicken Sie auf die entsprechende Optionsschaltfläche, um die Sortierfolge zu ändern.
    4. Klicken Sie auf OK.
  7. Um eine Spalte im Postfach nach links zu verschieben, klicken Sie auf Move Up. Um eine Spalte im Postfach nach rechts zu verschieben, klicken Sie auf Move Down.
  8. Klicken Sie auf Postfach anzeigen, um zur Seite Fehlerverfolgung zurückzukehren.
    Anmerkung: Wenn Sie die Standard-Postfachansicht oder die Ansicht eines anderen Benutzers aktualisiert haben, werden die Änderungen aktiv sobald die entsprechenden Benutzer sich ab- und wieder neu angemeldet haben.
Übergeordnetes Thema: Einrichten der anfänglichen Standardansicht für Postfächer


Einrichten von Benutzerkonten

Ein Benutzerkonto ist eine Sammlung von Informationen über einen bestimmten Benutzer. Jeder Benutzer ist einer Gruppe und – wenn er Aktionen mit Fehlern durchführt – einem Postfach zugeordnet. Ein Benutzerkonto kann durch ein Kennwort geschützt sein. Jede Person, die sich beim System anmeldet (z. B. um einen Fehler zu melden, eine Aktion durchzuführen oder nach Daten zu suchen), benötigt ein Benutzerkonto.

Anmerkung: Über die Registerkarte Konten unter Verwaltung > Benutzerverwaltung können Sie Benutzerkonten erstellen, bearbeiten und löschen.

Benutzerkonten übernehmen die Berechtigungen und anfänglichen Fehlerstatuswerte ihrer Gruppe. Benötigt ein bestimmter Benutzer erweiterte Berechtigungen oder andere anfängliche Statuswerte, müssen Sie sein Konto bearbeiten. Wenn Sie diese Einstellungen konfigurieren möchten, öffnen Sie die Registerkarte Benutzerkonten unter Fehler > Konfiguration.

Anmerkung: Bevor Sie Benutzerkonten einrichten können, müssen Sie zunächst Gruppen und Postfächer einrichten.
  • Eigenschaften des Benutzerkontos
    Beschreibt die fehlerbezogenen Eigenschaften für Benutzerkonten.
  • Anfänglicher Fehlerstatus
    Beschreibt den anfänglichen Fehlerstatus für einen Benutzer.
  • Sicherheitseinstellungen für Benutzer
    Beschreibt die Sicherheitseinstellungen für Benutzerkonten.
  • Bearbeiten eines Benutzerkontos.
    Bearbeiten eines Benutzerkontos, um die Berechtigungen dieses Benutzers zu ändern.
Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
Routinemäßige Verwaltungsaufgaben


Eigenschaften des Benutzerkontos

Die fehlerbezogenen Eigenschaften für Benutzerkonten werden auf dem Register Benutzerkonten unter Fehler > Konfiguration angegeben.

Anmerkung: Bevor Sie fehlerbezogene Kontoeigenschaften anzeigen oder bearbeiten können, müssen Sie ein Benutzerkonto erstellen.

Klicken Sie auf den Namen eines Benutzers auf dem Register Benutzerkonten, um die fehlerbezogenen Kontoeigenschaften zu bearbeiten.

In der folgenden Tabelle sind die fehlerbezogenen Kontoeigenschaften aufgeführt:
Eigenschaft | Beschreibung
Login | Erforderlicher eindeutiger Anmeldename für einen Benutzer. Kann bis zu 30 Zeichen enthalten. Sonderzeichen sind nicht erlaubt. Anmerkung: Sie können den Anmeldenamen in Issue Manager nicht bearbeiten.
Inbox | Das Standardpostfach des Benutzers. Sie können ein anderes Standardpostfach für den Benutzer aus dem Listenfeld Postfach auswählen.
Setting Group | Erforderlich. Die Gruppe, zu der der Benutzer gehört. Wenn Sie eine Gruppe aus dem Listenfeld Einstellungsgruppe auswählen, ordnet Issue Manager automatisch dem Benutzer die Standardwerte der Gruppe für ursprüngliche Fehlerstatus und Gruppensicherheitseinstellungen zu.
Übergeordnetes Thema: Einrichten von Benutzerkonten
Zugehörige Konzepte
Gruppeneigenschaften


Anfänglicher Fehlerstatus

Der anfängliche Fehlerstatus ist der erste Status, der einem Problem-, Erweiterungs- oder Dokumentationsfehler zugeordnet wird, wenn er von einem Benutzer übergeben wird. Die Standardwerte sind die Standardwerte für Gruppen, also die Werte, die der Gruppe zugewiesen werden, der der Benutzer angehört.

Die anfänglichen Standard-Fehlerstatuswerte eines bestimmten Benutzerkontos müssen geändert werden, wenn ein Benutzer beispielsweise einen höheren Grad technischer Kompetenz einnimmt. So könnte zu einer Gruppe technisch unbedarfter Manager z. B. auch eine technisch versierte Person gehören. Die Fehler, die dieser Benutzer meldet, sollten Issue Manager an einer späteren Stelle des Workflow übergeben werden.

Übergeordnetes Thema: Einrichten von Benutzerkonten
Zugehörige Konzepte
Anfänglicher Fehlerstatus


Sicherheitseinstellungen für Benutzer

Die Berechtigungen bestimmen, welche Aktivitäten der Benutzer durchführen kann. Die Standardberechtigungen für einen Benutzer sind die Berechtigungen der Gruppe, der der Benutzer angehört. Sie können einem bestimmten Benutzer in einer Gruppe zusätzliche Berechtigungen zuweisen, indem Sie sein Konto bearbeiten. Berechtigungen, die der Gruppe des Benutzers erteilt wurden, können jedoch nicht entfernt werden. Die Standardberechtigungen umfassen keine Schreibrechte.

Um einem Benutzerkonto Berechtigungen zuzuweisen, klicken Sie auf den Namen des Benutzers unter Fehler > Konfiguration > Benutzerkonten. Aktivieren Sie das entsprechende Kontrollkästchen, um dem Benutzer die entsprechende Berechtigung zuzuordnen.

Die folgende Tabelle listet die Berechtigungen auf, mit denen Benutzer bestimmte Anpassungsaufgaben durchführen können:
Auswahlfeld | Beschreibung
Gruppen, Postfächer und Benutzerkonten | Erstellen und Bearbeiten von Gruppen, Postfächern und Benutzerkonten, einschließlich von Berechtigungen.
Produkte | Erstellen und Bearbeiten von Produkten, Versionen, Plattformen und Komponenten. Bearbeiten der Liste Plattformen und anderer Listen.
Zuordnungsregeln | Festlegen, wie ein Fehler von einem Postfach zum nächsten gelangt, abhängig vom Produkt, der Version, der Plattform und der Komponente, für die der Fehler gemeldet wurde.
GUI-Anpassung | Anpassen von Feldern und Registern auf der Seite Fehlerdetails.
Workflow-Anpassung | Festlegen von Fehlerstatus und Aktionen, Aktionsberechtigungen, Hilfetext, Erscheinungsbild und Verwendung der Aktionsdialoge.
E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen | Festlegen von E-Mail-Benachrichtigungsregeln und E-Mail-Benachrichtigungen, die für alle Fehler in der Datenbank gelten.
Fehler archivieren | Entfernt ausgewählte Fehler von den zugeordneten Fehlern und Tabellen und legt diese im ARCHIV und den diesem zugeordneten Tabellen ab.
Die folgende Tabelle listet die Berechtigungen auf, die die Zuordnung von Fehlern und E-Mail-Benachrichtigungen beeinflussen:
Auswahlfeld | Beschreibung
Fehler neu zuweisen | Verschieben von Fehlern aus einem Postfach in ein anderes.
Fehlerüberprüfungsoptionen | Markieren, um die Standard-Zuordnungsregeln zu überschreiben.
E-Mail-Benachrichtigung pro Fehler | Hinzufügen von E-Mail-Benachrichtigungen zu bestimmten Fehlern.
Fehler eingeben/bearbeiten | Berechtigung, Fehler einzugeben und zu bearbeiten.
Übergeordnetes Thema: Einrichten von Benutzerkonten
Zugehörige Konzepte
Sicherheitseinstellungen für Gruppen


Bearbeiten eines Benutzerkontos.

Anmerkung: Sie benötigen die Berechtigungen der Gruppen, Postfächer und Benutzerkonten, um Benutzerkonten bearbeiten zu können.
So bearbeiten Sie die Berechtigungen und den anfänglichen Fehlerstatus eines Benutzerkontos:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Benutzerkonten. Die Seite Benutzerkonten wird geöffnet.
  3. Klicken Sie auf den Namen des Benutzers, dessen Berechtigungen Sie bearbeiten möchten. Der Dialog Benutzereinstellungen wird angezeigt.
  4. Ändern Sie die Berechtigungen des Benutzers sowie den anfänglichen Fehlerstatus.
  5. Wenn Ihre Änderungen gespeichert werden sollen, klicken Sie auf OK, andernfalls auf Abbrechen.
Übergeordnetes Thema: Einrichten von Benutzerkonten
Zugehörige Konzepte
Sicherheitseinstellungen für Benutzer
Anfänglicher Fehlerstatus


Festlegen von Produkteinstellungen

Neben der Fehlerverfolgung zu bestimmten Produkten ermöglicht Issue Manager auch die Verfolgung von Fehlern zu folgenden Aspekten:
  • Bestimmte Versionen eines Produkts
  • Bestimmte Plattformen, denen Produktversionen zugeordnet sind
  • Bestimmte Produktkomponenten

In Produktteams gibt es häufig mehrere Personen, die Code für eine bestimmte Anwendung schreiben. Mit Issue Manager können Sie Produkte und Komponenten mit bestimmten Postfächern verknüpfen. Darüber hinaus weist Issue Manager neue Fehler auf der Grundlage des Produkts, der Komponente, der Version und der Plattform automatisch den richtigen Entwicklern zu.

Anmerkung: Sie können Produkte, Komponenten, Versionen, Builds und Plattformen im Bereich Verwaltung von Silk Central erstellen und bearbeiten. Die einzigen Eigenschaften, die Sie über Issue Manager konfigurieren können, sind Produkt-Postfacheinstellungen.
Sie können selbst entscheiden, auf welche Art Sie Produkte von Komponenten unterscheiden möchten. Ein Produkt aus einer Abteilung kann in einer anderen Abteilung als Komponente definiert sein. Die folgenden grundlegenden Definitionen dienen als Hilfestellung:
Produkt
Ein Produkt ist eine Software, die unabhängig von anderer, im selben Lieferumfang enthaltener Software ausgeführt werden kann. Es kann bei Bedarf auch separat erworben werden. In einem Produkt ist das ausführbare Programm von der Codebasis getrennt. Ein Produkt kann aus mehreren Komponenten bestehen.
Komponente
Eine Komponente ist ein funktionaler Bereich eines Produkts. Eine Komponente kann nicht separat verkauft werden, und Benutzer sehen Komponenten nicht als eigenständige Produkte. Einem Produkt können eine oder mehrere Komponenten zugeordnet sein.
Version
Eine Version ist eine bestimmte Ausgabe oder ein bestimmtes Software-Build eines bestimmten Produkts. Bei einer Version kann es sich um ein internes Entwicklungs-Build oder um ein Build handeln, das an Kunden verschickt wird. Einem Produkt können mehrere Versionen zugeordnet sein. Eine bestimmte Version eines Produkts kann auf einer oder mehreren Plattformen verfügbar sein.
Plattform
Eine Plattform ist eine Umgebung, in der ein Produkt ausgeführt wird. Eine Plattform besteht aus einer beliebigen Kombination aus den folgenden Elementen:
  • Hardware.
  • Betriebssystem, z.B. Microsoft Windows.
  • Betriebssystem-Version, z.B. 8.1.
Viele der Werte, die für Produkte, Versionen, Plattformen und Komponenten definiert sind, werden auf der Seite Produkte unter Fehler > Konfiguration > Produkte angezeigt.
  • Festlegen von Postfacheinstellungen für ein Projekt
    Festlegen von Postfacheinstellungen für ein spezifisches Projekt, um die Postfächer einzustellen, denen Fehler zugeordnet werden sollen.
  • Löschen eines Produkts
    Löschen eines Produkts in Issue Manager, um dieses vom ausgewählten Projekt zu trennen.
Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
Einrichten von Zuordnungsregeln


Festlegen von Postfacheinstellungen für ein Projekt

So legen Sie Postfacheinstellungen für spezifische Produkte in Issue Manager fest:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Produkte. Die Seite Produkte wird geöffnet.
  3. Klicken Sie auf Festlegen von Produkteinstellungen. Der Dialog Produkteinstellungen wird angezeigt.
  4. Wählen Sie im Listenfeld Produkt das Produkt, für das Sie Postfacheinstellungen festlegen möchten.
    Anmerkung: Wenn Sie auf den Namen eines Produkts klicken, das bereits einem Fehler im Projekt zugeordnet wurde (Seite Produkte), können Sie diesen Schritt überspringen.
  5. Wählen Sie im Listenfeld Postfach "QS" das vordefinierte Postfach, dem Fehler zugeordnet werden sollen, die zur QS gehören und für das angegebene Produkt definiert wurden.
  6. Wählen Sie im Listenfeld Postfach "Entw" das vordefinierte Postfach, dem Fehler zugeordnet werden sollen, die zur Entwicklung gehören und für das angegebene Produkt definiert wurden.
  7. Wählen Sie im Listenfeld Postfach "Erw" das vordefinierte Postfach, dem Fehler zugeordnet werden sollen, die zur Erweiterungsanforderung gehören und für das angegebene Produkt definiert wurden.
  8. Wählen Sie im Listenfeld Postfach "Dok" das vordefinierte Postfach, dem Fehler zugeordnet werden sollen, die zur Dokumentation gehören und für das angegebene Produkt definiert wurden.
  9. Klicken Sie auf OK.
Übergeordnetes Thema: Festlegen von Produkteinstellungen


Löschen eines Produkts

Beim Löschen eines Produkts in Issue Manager wird das Produkt nicht wirklich aus dem Repository gelöscht, sondern nur vom ausgewählten Projekt getrennt, so dass über Issue Manager kein Zugriff auf das Produkt mehr möglich ist.
Anmerkung: Sie können ein Produkt nur dann löschen, wenn diesem keine Fehler zugeordnet wurden.

So löschen Sie ein Produkt aus dem aktiven Projekt:

  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Produkte. Die Seite Produkte wird geöffnet.
  3. Klicken Sie in der Spalte Aktionen des Produkts, das Sie löschen möchten, auf Löschen. Ein Bestätigungsdialog wird geöffnet.
  4. Klicken Sie auf Ja, um das Löschen auszuführen.
Übergeordnetes Thema: Festlegen von Produkteinstellungen


Einrichten von Zuordnungsregeln

Issue Manager bestimmt die Postfächer, denen Fehler während ihres Lebenszyklus zugeordnet werden, auf der Grundlage definierter Zuordnungsregeln, des aktuellen Status jedes Fehlers sowie der entsprechenden Statuseigentümer. Dieser ausgeklügelte Zuordnungsmechanismus erleichtert die schwierige Aufgabe der Fehlerverteilung enorm.

Der Status eines Fehlers ist der aktuelle Zustand. Verschiedene Status sind im Standard-Workflow von Issue Manager enthalten. Der Statuseigentümer ist die Rolle in Ihrem Unternehmen, die für die Durchführung von Aktionen mit einem Fehler in einem bestimmten Status verantwortlich ist.

Einige Beispiele für Fehlerstatuswerte und -eigentümer aus dem Standardfehler-Workflow:
Ungeprüft
Eine geeignete Person muss feststellen, ob es sich bei dem Fehler wirklich um einen Fehler oder Dokumentationsfehler handelt. Diese Rolle hat normalerweise der QS-Mitarbeiter.
Offen
Eine geeignete Person kann sich mit dem Code befassen. Diese Rolle hat normalerweise ein Entwickler.
Zu verifizieren
Eine geeignete Person muss überprüfen, ob der Fehler tatsächlich bereinigt wurde. Diese Rolle hat normalerweise ein QS-Mitarbeiter.

Verschiedene Fehler desselben Typs können mit verschiedenen Statuswerten in den Workflow eintreten, je nachdem, von wem sie gemeldet werden. Auch die Zuordnung hängt von verschiedenen Umständen ab. Ein von einem Entwickler gemeldeter Fehler tritt beispielsweise im Status "Offen" in den Workflow ein und wird daher dem Postfach eines Entwicklers zugeordnet. Ein von einem normalen Benutzer gemeldeter Fehler tritt im Status "Ungeprüft" in den Workflow ein und wird dem Postfach eines QS-Mitarbeiters zugeordnet. Der sogenannte Anfangsstatus wird über die Gruppeneinstellungen zugeordnet.

Ein Fehler wechselt in den nächsten Status im Workflow, wenn ein Benutzer eine Aktion mit ihm durchführt. Bestätigt beispielsweise ein QS-Mitarbeiter, dass ein gemeldeter ungeprüfter Fehler ein echter Fehler ist, wechselt der Fehler vom Status Ungeprüft in den Status Offen. Das wichtigste Ziel dieser Zuordnungslogik ist, dass der Fehler, sobald er als echter Fehler erkannt wurde, ohne manuelles Eingreifen aus dem Postfach des QS-Mitarbeiters in das Postfach des Entwicklers gelangt.

  • Zuordnungsregeln
    Beschreibt die Regeln, auf denen die Fehlerzuordnung basiert.
  • Festlegen von Regeln
    Beschreibt, wie Sie Zuordnungsregeln angeben können.
  • Hinzufügen von Zuordnungsregeln
    Hinzufügen einer Zuordnungsregel, um die Zuordnungsweise der Fehler festzulegen.
  • Bearbeiten von Zuordnungsregeln
    Bearbeiten einer vorhandenen Zuordnungsregel, um die Zuordnungsweise der Fehler zu ändern.
  • Löschen von Zuordnungsregeln
    Löschen Sie eine Zuordnungsregel, um die Zuordnungsweise der Fehler zu ändern.
  • Erneutes Anordnen von Zuordnungsregeln
    Ordnen Sie Zuordnungsregeln neu an, um ihre Reihenfolge zu ändern.
  • Umgehen der automatischen Zuordnung
    Hier wird beschrieben, wie Sie einzelnen Benutzern oder ganzen Gruppen erlauben können, die Standardzuordnung der Fehlerüberprüfung Ihres Unternehmens zu überschreiben.
Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
Anpassen des Workflow
Einrichten von Gruppen


Zuordnungsregeln

Die Weiterleitung von Fehlern beruht auf Regeln, die Sie für ein Produkt und die ihm zugeordneten Versionen, Plattformen und Komponenten erstellen. Dieser regelbasierte Mechanismus gibt Ihnen eine präzise Steuerungsmöglichkeit über die Verteilung der Fehler, da Fehler teilweise basierend auf einer Kombination folgender Kriterien zugeordnet werden:
  • Produkt
  • Komponente
  • Version
  • Plattform
  • Fehlerstatus
  • Statuseigentümer
Für jeden Kriteriensatz müssen die folgenden vier Postfächer zugewiesen werden:
  • Ein Postfach für die Überprüfung von Fehlern (normalerweise ein QS-Postfach)
  • Ein Postfach für die Behebung von Fehlern (normalerweise ein Entwicklungspostfach)
  • Ein Postfach für die Bearbeitung von Dokumentationsproblemen (ein Dokumentationspostfach)
  • Ein Postfach für Erweiterungsanforderungen (normalerweise ein Produktmanagementpostfach)

Beispiel

So können beispielsweise alle Produkt A-Fehler, die der Komponente Installationsprogramm und der Plattform Motif zugeordnet sind, an eine bestimmte Reihe von Postfächern weitergeleitet werden, während alle Produkt A-Fehler, die der Komponente Installationsprogramm für die Plattform Windows zugeordnet sind, an andere Postfächer gesendet werden.

Standardzuordnung

Neben den einzelnen Zuordnungsregeln verlangt Issue Manager die Definition einer Zuordnungsregel für das Produkt als Ganzes (d. h. eine Standardzuordnung). Bei der Standardzuordnung werden Fehler für alle Komponenten, Versionen und Plattformen eines bestimmten Produkts vier bestimmten Postfächern zugeordnet.

Jedes Postfach deckt folgende Bereiche ab:
  • QS
  • Entwicklung
  • Dokumentation
  • Erweiterungsanforderungen
So werden beispielsweise alle Erweiterungsanforderungen für Produkt X an das von Ihnen festgelegte Postfach für Erweiterungsanforderungen geleitet, unabhängig von der Komponente, der Plattform oder der Version.

Issue Manager verwendet die Standardzuordnungsregel nur, wenn andere Regeln fehlen oder nicht anwendbar sind. Mit anderen Worten: Standardzuordnungsregeln kommen nur zum Einsatz, wenn andere Regeln nicht geeignet oder nicht definiert sind.

Die Standardzuordnung wird während der Issue Manager-Produkteinrichtung festgelegt.

Analysieren der Prozesse in Ihrer Organisation

Analysieren Sie die Arbeitsaufteilung in Ihrer Organisation. Untersuchen Sie die Liste der Produkte, Versionen und Plattformen, und überprüfen Sie jede Komponente anhand dieser Liste. Stellen Sie sich z. B. folgende Fragen:

Für diese Komponente in dieser Version und auf dieser Plattform, wer, also welches Postfach, ist für die einzelnen Aktionen verantwortlich, z. B. Verifizieren, Beheben usw.?
Dann definieren Sie so viele Regeln, wie für die verschiedenen Kombinationen aus den vier Kriterien erforderlich sind:
  • Produkt
  • Version
  • Plattform
  • Komponente
Übergeordnetes Thema: Einrichten von Zuordnungsregeln
Zugehörige Tasks
Hinzufügen von Zuordnungsregeln
Bearbeiten von Zuordnungsregeln


Festlegen von Regeln

Jede Regel wird auf der Seite Zuordnungsregeln unter Fehler > Konfiguration > Zuordnungsregeln angegeben.

Anmerkung: Der Dialog Neue Zuordnungsregel verfügt über einen "wenn – dann"-Aufbau. Wenn auf einen Fehler bestimmte Bedingungen zutreffen, d. h. wenn er zu einer bestimmten Version, Plattform, Komponente und einem Fehlertyp gehört, dann wird er einem der vier angegebenen Postfächer zugeordnet. Welches der vier Postfächer das Ziel ist, hängt vom gegenwärtigen Status und Eigentümer des Fehlers ab.

Das Platzhaltersymbol %

Das Prozentzeichen (%) in den Feldern Version, Plattform und Komponente des Dialogs Neue Zuordnungsregel dient als Platzhalterzeichen, das für alle Zeichen stehen kann. Wenn Sie in alle drei Felder nur das Prozentzeichen eingeben, entspricht dies der Standardzuordnung. In diesem Fall würden alle Fehler unabhängig von ihrer Version, Plattform und Komponente den vier Postfächern zugeordnet.

Tipp: Um vom Gebrauch des Platzhalterzeichens profitieren zu können, müssen Sie konsistente Namen für Versionen, Komponenten und Plattformen vergeben.

Nachdem eine Regel gespeichert wurde, wird sie auf der Seite Zuordnungsregeln angezeigt. Diese Seite ist im Grunde eine Zuordnungstabelle für ein bestimmtes Produkt. Mithilfe des Listenfelds Produkt im oberen Bereich der Seite können Sie ein anderes Produkt auswählen.

Die Reihenfolge der Regeln ist wichtig

Die Reihenfolge der Regeln für eine Komponente ist wichtig. Issue Manager ordnet Fehler zu, indem ihr aktueller Status (z. B. Ungeprüft) der Reihe nach gegen jede Regel in der Tabelle ausgewertet wird. Sobald Issue Manager eine Übereinstimmung findet, wird die Regel ausgeführt. Gibt es keine Übereinstimmung, wird der Fehler anhand der Standardregeln zugeordnet. Die Standardzuordnungsregeln kommen erst zum Einsatz, nachdem alle anderen Regeln für ein bestimmtes Produkt angewendet wurden.

Beispiel

Version 4.% im Feld Version würde mit allen Versionen von Version 4 übereinstimmen: 4.0, 4.1, 4.1.1 usw.

Beispiel: So lesen Sie eine Zuordnungsregel

Sende z. B. Produkt A-bezogene Fehler für alle Versionen und Plattformen an das Postfach Sonja - Entw, wenn der Fehler den Status Offen hat, an das Postfach des QS-Mitarbeiters Mike - QS, wenn der Fehler den Status Zu verifizieren hat, an das Erweiterungsanforderungspostfach für Produkt A Dan -- Entw (Produkt A), wenn eine Erweiterung übergeben wird, und an das Postfach von Judy -Dok, wenn ein Dokumentationsfehler für die Komponente Anzeigen gemeldet wird.

Übergeordnetes Thema: Einrichten von Zuordnungsregeln
Zugehörige Konzepte
Statuseigentümer


Hinzufügen von Zuordnungsregeln

So fügen Sie eine Zuordnungsregel hinzu:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Produkte. Die Seite Produkte wird geöffnet.
  3. Wählen Sie aus dem Listenfeld Produkt das Produkt aus, für das Sie eine Zuordnungsregel definieren möchten.
  4. Klicken Sie auf Neue Zuordnungsregel. Der Dialog Neue Zuordnungsregel wird geöffnet.
  5. Wählen Sie die entsprechende Optionsschaltfläche, um festzulegen, ob es sich um einen Fehler vom Typ FEHLER oder ERWEITERUNGEN (SOFT) oder DOK-FEHLER (DOC) handelt.
  6. Wählen Sie eine vordefinierte Version aus dem Listenfeld Version aus. Oder geben Sie eine vordefinierte Version in das Feld Spezielles Kriterium ein. Wählen Sie nichts aus, also die gepunktete Linie, wenn alle Versionen berücksichtigt werden sollen.
  7. Wählen Sie eine vordefinierte Plattform aus dem Listenfeld Plattform aus. Oder geben Sie eine vordefinierte Version in das Feld Spezielles Kriterium ein. Wählen Sie nichts aus, also die gepunktete Linie, wenn alle Versionen berücksichtigt werden sollen.
  8. Wählen Sie eine vordefinierte Komponente aus dem Listenfeld Komponente aus. Oder geben Sie eine vordefinierte Komponente in das Feld Spezielles Kriterium ein. Wählen Sie nichts aus, also die gepunktete Linie, wenn alle Versionen berücksichtigt werden sollen.
    Anmerkung: Sie müssen für mindestens eine der Möglichkeiten (Version, Plattform oder Komponente) einen Wert auswählen. Andernfalls folgt die neue Zuordnungsregel denselben Kriterien wie die Standardregel.
  9. Wählen Sie im Bereich Dann zu diesen Postfächern zuordnen des Dialogs ein vordefiniertes Postfach für jede der vier folgenden Postfachkategorien aus:
    • Postfach "QS"
    • Postfach "Entwicklung"
    • Erweiterungspostfach
    • Postfach "Dokumentation"
  10. Klicken Sie auf OK. Die Regel wird gespeichert und zur Zuordnungstabelle hinzugefügt.
    Anmerkung: Wenn Sie Änderungen an der Zuordnungstabelle vorgenommen haben, speichert Issue Manager die Zuordnungsregeln und konfiguriert sie neu. Dieser Vorgang kann ein wenig Zeit beanspruchen.
Übergeordnetes Thema: Einrichten von Zuordnungsregeln


Bearbeiten von Zuordnungsregeln

So bearbeiten Sie eine vorhandene Zuordnungsregel:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Produkte. Die Seite Produkte wird geöffnet.
  3. Wählen Sie aus dem Listenfeld Produkt das Produkt aus, für das Sie eine Zuordnungsregel definieren möchten.
  4. Klicken Sie in der Spalte Aktionen der Regel, die Sie bearbeiten möchten, auf Edit Routing Rule. Der Dialog Zuordnungsregel bearbeiten wird geöffnet.
  5. Wählen Sie die entsprechende Optionsschaltfläche, um festzulegen, ob es sich um einen Fehler vom Typ FEHLER oder ERWEITERUNGEN (SOFT) oder DOK-FEHLER (DOC) handelt.
  6. Wählen Sie eine vordefinierte Version aus dem Listenfeld Version aus. Oder geben Sie eine vordefinierte Version in das Feld Spezielles Kriterium ein. Wählen Sie nichts aus, also die gepunktete Linie, wenn alle Versionen berücksichtigt werden sollen.
  7. Wählen Sie eine vordefinierte Plattform aus dem Listenfeld Plattform aus. Oder geben Sie eine vordefinierte Version in das Feld Spezielles Kriterium ein. Wählen Sie nichts aus, also die gepunktete Linie, wenn alle Versionen berücksichtigt werden sollen.
  8. Wählen Sie eine vordefinierte Komponente aus dem Listenfeld Komponente aus. Oder geben Sie eine vordefinierte Komponente in das Feld Spezielles Kriterium ein. Wählen Sie nichts aus, also die gepunktete Linie, wenn alle Versionen berücksichtigt werden sollen.
    Anmerkung: Sie müssen für mindestens eine der Möglichkeiten (Version, Plattform oder Komponente) einen Wert auswählen. Andernfalls folgt die neue Zuordnungsregel denselben Kriterien wie die Standardregel.
  9. Wählen Sie im Bereich Dann zu diesen Postfächern zuordnen des Dialogs ein vordefiniertes Postfach für jede der vier folgenden Postfachkategorien aus:
    • Postfach "QS"
    • Postfach "Entwicklung"
    • Erweiterungspostfach
    • Postfach "Dokumentation"
  10. Klicken Sie auf OK. Die Regel wird gespeichert und zur Zuordnungstabelle hinzugefügt.
    Anmerkung: Wenn Sie Änderungen an der Zuordnungstabelle vorgenommen haben, speichert Issue Manager die Zuordnungsregeln und konfiguriert sie neu. Dieser Vorgang kann ein wenig Zeit beanspruchen.
Übergeordnetes Thema: Einrichten von Zuordnungsregeln


Löschen von Zuordnungsregeln

So löschen Sie eine vorhandene Zuordnungsregel:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Produkte. Die Seite Produkte wird geöffnet.
  3. Wählen Sie aus dem Listenfeld Produkt das Produkt aus, für das Sie eine Zuordnungsregel definieren möchten.
  4. Klicken Sie in der Spalte Aktionen der Regel, die Sie löschen möchten, auf Zuordnungsregel entfernen. Der Bestätigungsdialog Zuordnungsregel löschen wird geöffnet.
  5. Klicken Sie auf Ja, um das Löschen auszuführen.
Übergeordnetes Thema: Einrichten von Zuordnungsregeln


Erneutes Anordnen von Zuordnungsregeln

So ordnen Sie Zuordnungsregeln neu an:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Produkte. Die Seite Produkte wird geöffnet.
  3. Wählen Sie aus dem Listenfeld Produkt das Produkt aus, für das Sie eine Zuordnungsregel definieren möchten.
  4. Klicken Sie in der Spalte Aktionen der Regel, die neu angeordnet werden soll, auf eines der folgenden Elemente:
    • Um die Regel in der Liste nach oben zu verschieben, klicken Sie auf Nach oben.
    • Um die Regel in der Liste nach unten zu verschieben, klicken Sie auf [image].
Übergeordnetes Thema: Einrichten von Zuordnungsregeln


Umgehen der automatischen Zuordnung

Sie können die im Unternehmen implementierte Standardzuordnung für die Fehlerüberprüfung für einzelne Benutzer oder Benutzergruppen ändern. So kann es beispielsweise Benutzern ermöglicht werden, zu überprüfen, ob ihre gemeldeten Fehler behoben wurden.

Ordnen Sie dem Benutzer oder der Gruppe die Fehlerüberprüfungsoptionen zu, damit diesem/dieser das Überschreiben ermöglicht wird. Benutzer mit dieser Berechtigung können dann unter Fehler > Konfiguration > Optionen eine der drei Zuordnungsstrategien auswählen.
Strategie
Beschreibung
Immer Standardzuordnung verwenden
Standardzuordnung für die Überprüfung. Der Fehler wird dem entsprechenden QS-Postfach zugeordnet.
Immer eigenen Fehler verifizieren
Issue Manager ordnet Fehler nicht dem vorgesehenen QS-Postfach, sondern den Postfächern der Benutzer zu, die den Fehler gemeldet haben.
Bei jedem neuen Fehler nachfragen
Issue Manager ermöglicht es den Benutzern, die Standardzuordnung immer bei der Meldung eines Fehlers zu überschreiben.

Eine Neuzuordnung setzt die Standardzuordnung außer Kraft

Die Neuzuordnung eines Fehlers ist ein Verfahren, mit dem der automatische Zuordnungsmechanismus außer Kraft gesetzt werden kann. Benutzer können mit der Aktion "Neu zuordnen" einen Fehler an das Postfach eines anderen Benutzers weiterleiten (normalerweise eines Benutzers in derselben Gruppe). Dazu ein Beispiel: Der Entwickler Bill geht in Urlaub und ordnet deshalb einen Softwarefehler mit dem Status "Offen" seinem Entwicklerkollegen Dan zu. Der Fehler hat weiterhin den Status "Offen", wurde aber neu zugeordnet.

Wenn ein Fehler nach einer Neuzuordnung wieder einen früheren Status im Workflow annimmt (weil Dan z. B. eine Fehlerbehebung ablehnt), speichert Issue Manager die Neuzuordnung. Später wird der Fehler wieder an das manuell zugeordnete Postfach (von Dan) gesendet und nicht an das ursprüngliche Postfach (von Bill).

Beispiel

Das folgende Beispiel mit einer zweifachen Neuzuordnung eines Fehlers verdeutlicht die Wirkungsweise einer Neuzuordnung. Der Fehler wird einmal im Status "Offen" und einmal im Status "Zu verifizieren" neu zugeordnet. Der QS-Mitarbeiter akzeptiert eine Fehlerbehebung nicht und weist dem Fehler wieder einen früheren Workflow-Status zu.
  1. Ein neuer Fehler tritt mit dem Status Offen in den Workflow ein. Aufgrund der Zuordnungsregeln wird der Fehler automatisch an das Postfach des Entwicklers Bill gesendet.
  2. Bill weist die Fehler dem Postfach des Entwicklers Dan zu.
  3. Dan deklariert den Fehler als behoben, sodass er den Status Zu verifizieren erhält.
  4. Die Zuordnungsregeln senden den Fehler an das Postfach des QS-Mitarbeiters Mike, damit dieser diesen überprüft.
  5. Mike ordnet den Fehler nun dem Postfach seiner Kollegin Sarah zu.
  6. Sarah lehnt die Fehlerbehebung ab, sodass der Fehler wieder den Status "Offen" erhält.
  7. Issue Manager sendet den Fehler mit dem Status "Offen" zurück an das Postfach von Dan, da dies der letzte Entwickler war, der für den Fehler in diesem Zustand eine Aktion ausgeführt hat.
  8. Dan implementiert erneut eine Fehlerbehebung, wodurch der Fehler wieder den Status "Zu verifizieren" erhält.
  9. Issue Manager sendet den Zu verifizieren-Fehler zurück an das Postfach von Sarah, da diese QS-Mitarbeiterin die letzte Aktion für den Fehler in diesem Zustand ausgeführt hat.

Ohne die erweiterte Zuordnung würde der Fehler im Status "Offen" (Schritt 7) an das Postfach von Bill gesendet, der ihn dann Dan neu zuordnen müsste. Im Status "Zu verifizieren" (Schritt 9) würde der Fehler dem Postfach von Mike zugeordnet, der ihn dann manuell dem Postfach von Sarah zuordnen müsste.

Übergeordnetes Thema: Einrichten von Zuordnungsregeln
Zugehörige Konzepte
Sicherheitseinstellungen für Gruppen


Anpassen der Seite "Fehlerdetails"

In Issue Manager kann das Erscheinungsbild und das Verhalten der Seiten Neuer Fehler und Fehlerdetails für vorhandene Fehler angepasst werden. Sie können beispielsweise eine Feldbezeichnung Ihrem Unternehmen anpassen (z. B. Build anstelle von Version).

Änderungen, die Sie an den Bezeichnungen der Seite Fehlerdetails vornehmen, werden an die meisten anderen Seiten und Dialoge weitergegeben, die über den Bereich Anpassung von Issue Manager aufgerufen werden.

Issue Manager ermöglicht auf der Seite Fehlerdetails eine Vielzahl von Anpassungen durchzuführen.
  • Bearbeiten Sie die Bezeichnungen und ändern Sie die Eigenschaften der Felder, die grundlegende Informationen eines Fehlers enthalten. Sie möchten beispielsweise die Bezeichnung Kurzbeschreibung auf Beschreibung ändern.
  • Bearbeiten Sie die Feldbezeichnungen im Bereich Automatische Felder.
  • Bearbeiten Sie die Registerbezeichnungen.
  • Definieren Sie Felder des Benutzerdefiniertes Register 1 und Benutzerdefiniertes Register 2. Sie können diese Felder ändern oder löschen oder eigene Felder hinzufügen. Benutzerdefiniertes Register 1 enthält standardmäßig vier Felder.
Die folgende Tabelle beschreibt, wo Sie die Informationen finden, die Sie benötigen, um eine Feldbezeichnung eines Standardfehlers oder einen Feldinhalt anzupassen:
Name | Feldbezeichnung bearbeiten? | Feldeigenschaften anpassen?
Fehlertyp | Anpassen von Feldern und Registerbezeichnungen | Ja.
Produkt | Anpassen von Feldern und Registerbezeichnungen | Ja. Siehe Bearbeiten von Produkten.
Version | Anpassen von Feldern und Registerbezeichnungen | Ja. Siehe Bearbeiten von Versionen.
Plattform | Anpassen von Feldern und Registerbezeichnungen | Ja. Siehe Bearbeiten von Plattformen.
Komponente | Anpassen von Feldern und Registerbezeichnungen | Ja. Siehe Bearbeiten von Komponenten.
Schweregrad | Anpassen von Feldern und Registerbezeichnungen | Ja.
Zusammenfassung | Anpassen von Feldern und Registerbezeichnungen | Nein. Kurzbezeichnung wird von Benutzern eingegeben.
Fehlernummer | Anpassen von Feldern und Registerbezeichnungen | Nein. Die Fehlernummer kann nicht angepasst werden.
Zugeordnet zu | Anpassen von Feldern und Registerbezeichnungen | Ja. Siehe Zuordnungsregeln.
Status | Anpassen von Feldern und Registerbezeichnungen | Ja. Siehe Anpassen des Workflowstatus.
Begründung | Anpassen von Feldern und Registerbezeichnungen | Ja. Siehe Begründung.
Aktionsversion | Aktionseigenschaften | Ja.
Die folgende Tabelle beschreibt, wo Sie die Informationen finden, die Sie benötigen, um eine Registerbezeichnung oder Registerfelder anzupassen:
Name | Registerbezeichnung bearbeiten? | Feld in Registern bearbeiten?
Beschreibung | Anpassen von Feldern und Registerbezeichnungen | Nein. Register Beschreibung wird von Benutzern ausgefüllt.
Historie | Anpassen von Feldern und Registerbezeichnungen | Nein. Register Historie wird von Issue Manager ausgefüllt. Sie können jedoch die Spalte Aktion anpassen. Siehe Informationen über den aktuellen Status.
Kunden | Anpassen von Feldern und Registerbezeichnungen | Nein. Benutzer können die vordefinierte Aktion Kunden hinzufügen durchführen.
Benutzerdefiniertes Register | Erstellen benutzerdefinierter Register | Ja. Siehe Bearbeiten von benutzerdefinierten Feldern.
  • Anpassen von Feldern und Registerbezeichnungen
    Hier wird erläutert, wie die Standardfehlerfelder, Registerbezeichnungen und automatischen Felder angepasst werden.
  • Eigenschaften zum Anpassen der Benutzeroberfläche
    Listet die Eigenschaften auf, die das Erscheinungsbild und die Verwendung der Felder auf der Seite Fehlerdetails festlegen.
  • Benutzerdefinierte Register und Felder
    Hier werden benutzerdefinierte Register und Felder in Issue Manager beschrieben.
Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
Zuordnungsregeln
Begründungen
Aktionseigenschaften
Informationen über den aktuellen Status
Benutzerdefinierte Register und Felder
Register Benutzerdefinierte Aktionsfelder
Zugehörige Tasks
Anpassen des Workflow-Status
Bearbeiten von Produkten
Bearbeiten von Versionen
Bearbeiten von Plattformen
Bearbeiten von Komponenten


Anpassen von Feldern und Registerbezeichnungen

Anmerkung: Sie benötigen das GUI customization-Recht, um die in diesem Thema beschriebenen Aufgaben auszuführen.
In diesem Abschnitt wird beschrieben, wie Standardfehlerfelder, Registerbezeichnungen und automatische Felder (mit Ausnahme des Feldes Aktionsversion) angepasst werden. Informationen zur Anpassung des Feldes Aktionsversion finden Sie unter Register Standardaktionsfelder. Sie können diese Felder weder löschen noch neue Felder hinzufügen. Sie können jedoch ihre Eigenschaften ändern. So haben Sie z. B. die Möglichkeit, die Bezeichnungen zu ändern, den Modus auszuwählen und die Gruppen einzuschränken, die über Berechtigungen zum Ausfüllen oder Ändern verfügen.

So ändern Sie Standardfehlerfelder und Registerbezeichnungen:

  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Standardfehlerfelder. Die Seite Standardfehlerfelder wird geöffnet.
    Anmerkung: Die Seite Standardfehlerfelder sieht aus wie die Seite Fehlerdetails.
  3. Wenn Sie eine Registerbezeichnung umbenennen möchten, führen Sie die folgenden Aktionen durch:
    1. Klicken Sie auf den Namen des Registers, das Sie bearbeiten möchten. Das Dialogfeld Register bearbeiten wird geöffnet.
    2. Ändern Sie ggf. den Namen des Registers.
    3. Klicken Sie auf OK.
  4. Wenn Sie die Eigenschaften eines Feldes bearbeiten möchten, führen Sie die folgenden Aktionen durch:
    1. Klicken Sie auf den Link eines Feldes, das Sie bearbeiten möchten. Das Dialogfeld Feldeigenschaften bearbeiten wird geöffnet.
    2. Ändern Sie ggf. die Eigenschaften des Feldes.
    3. Klicken Sie auf OK.
Übergeordnetes Thema: Anpassen der Seite "Fehlerdetails"
Zugehörige Verweise
Register Standardaktionsfelder
Eigenschaften zum Anpassen der Benutzeroberfläche


Eigenschaften zum Anpassen der Benutzeroberfläche

Die Felder auf der Seite Fehlerdetails verfügen über Eigenschaften, die ihr Erscheinungsbild und ihr Verhalten bestimmen. Die Eigenschaften legen beispielsweise die Bezeichnung und den Typ des Feldes fest (z. B. Kontrollkästchen oder Textfeld). Sie können die Eigenschaften eines Feldes im Dialog Feldeigenschaften bearbeiten anzeigen und bearbeiten. Klicken Sie unter Fehler > Konfiguration > Benutzerdefinierte Fehlerfelder oder unter Fehler > Konfiguration > Benutzerdefinierter Feld-Pool auf den Link des Feldes, das Sie bearbeiten möchten, um auf den Dialog Feldeigenschaften bearbeiten zuzugreifen.
Folgende Eigenschaften können geändert werden:
Eigenschaft
Beschreibung
Label
Text der Feldbezeichnung; maximal 20 Zeichen. Verwenden Sie einen Doppelpunkt, um die Bezeichnung vom Inhalt zu trennen. Sonderzeichen sind nicht erlaubt.
Steuerelementtyp
Nur aktiv, wenn benutzerdefinierte Felder erstellt werden. Der Typ des Steuerelements kann Kontrollkästchen, Datum, Textfeld oder Popup-Liste sein.
Schreibweise
Nur aktiv beim Typ Textfeld. Legt fest, welche Art von Zeichen der Benutzer in ein Textfeld eingibt. Mögliche Werte sind GROSS, klein und nicht beachten.
Listenname
Nur aktiv, wenn benutzerdefinierte Popup-Listen erstellt werden. Wählen Sie den Namen der benutzerdefinierten Liste, die die Werte für diese Popup-Liste festlegt.
Neuer Fehler oder neue Aktion - Modus
Beschreibt die Rolle des Feldes, wenn ein Benutzer einen neuen Fehler meldet.
Wert | Beschreibung
Erforderlich | Muss einen Wert enthalten.
Optional | Kann einen Wert enthalten oder leer sein.
Schreibgeschützt | Kann nicht bearbeitet werden.
Neuer Fehler oder neue Aktion - Gruppenrechte
Aktiv, wenn der Modus Erforderlich oder Optional ist. Berechtigungen legen fest, welche Gruppen einen Wert in dieses Feld eingeben dürfen.
  • Alle erteilt die Berechtigung für alle Gruppen.
  • Ausgewählte erteilt die Berechtigung nur den Gruppen, die Sie im Listenfeld auswählen. Ist ein Feld erforderlich oder optional und die Berechtigung auf bestimmte Gruppen beschränkt, ist das Feld für alle anderen Gruppen schreibgeschützt.
Vorhandener Fehler oder vorhandene Aktion - Modus
Beschreibt die Rolle des Feldes, wenn ein Benutzer einen vorhandenen Fehler bearbeitet.
Wert | Beschreibung
Erforderlich | Muss einen Wert enthalten.
Optional | Kann einen Wert enthalten oder leer sein.
Schreibgeschützt | Kann nicht bearbeitet werden.
Tipp: Ein Kontrollkästchen kann kein erforderliches Feld sein. Wenn Sie ein erforderliches Feld benötigen, können Sie es als Popup-Liste mit zwei gegensätzlichen Werten definieren, z. B. Ja und Nein.
Vorhandener Fehler oder vorhandene Aktion - Gruppenrechte
Aktiv, wenn der Modus Erforderlich oder Optional ist. Berechtigungen legen fest, welche Gruppen einen Wert in dieses Feld eingeben dürfen.
  • Alle erteilt die Berechtigung für alle Gruppen.
  • Ausgewählte erteilt die Berechtigung nur den Gruppen, die Sie im Listenfeld auswählen. Ist ein Feld erforderlich oder optional und die Berechtigung auf bestimmte Gruppen beschränkt, ist das Feld für alle anderen Gruppen schreibgeschützt.
Wert des zuletzt eingegebenen Fehlers merken
Wenn Sie dieses Kontrollkästchen aktivieren, zeigt die Seite Fehlerdetails den zuletzt gewählten Wert an. Nehmen wir beispielsweise an, dieses Kontrollkästchen ist für das Feld Produkt aktiviert. Wenn ein Benutzer, der einen Fehler meldet, zum ersten Mal einen Wert aus dem Listenfeld Produkt wählt (z. B. QS Partner), bleibt dieser Wert für künftige Eingaben erhalten. Meldet der Benutzer den nächsten Fehler, zeigt das Feld Produkt standardmäßig den Wert QS Partner an.
Übergeordnetes Thema: Anpassen der Seite "Fehlerdetails"


Benutzerdefinierte Register und Felder

In Issue Manager können Sie bis zu zehn benutzerdefinierte Felder pro Benutzerdefiniertes Register anlegen.

Benutzerdefinierte Register

Benutzerdefiniertes Register 1 auf der Seite Fehlerdetails enthält standardmäßig drei Felder. Sie können dem Register Felder hinzufügen, die Standardfelder bearbeiten oder die Felder löschen und von vorne beginnen.

Die folgende Tabelle beschreibt die Standardfelder von Benutzerdefiniertes Register 1.
Feld | Zweck | Modus | Typ/Wert
Automatisiert? | Gibt an, ob der Fehler automatisiert (in Regressionstests) oder manuell ist. | Optional | Kontrollkästchen. Standardmäßig nicht aktiviert.
Hinweis hinzufügen? | Gibt an, ob ein Element dieses Fehlers den Versionshinweisen des Produkts hinzugefügt werden soll. | Optional | Kontrollkästchen. Standardmäßig nicht aktiviert.
Dokumentation aktualisieren? | Gibt an, ob die Dokumentation zu diesem Fehler aktualisiert werden muss. | Optional | Kontrollkästchen. Standardmäßig nicht aktiviert.

Benutzerdefinierte Register 2 bis 4 sind leer.

Benutzerdefinierte Felder

Benutzerdefinierte Felder können an zwei Stellen auftreten:
  • In den benutzerdefinierten Registern auf der Seite Fehlerdetails.
  • In den Aktions-Dialogfeldern, die geöffnet werden, wenn ein Benutzer eine Aktion mit einem Fehler durchführt.
So erstellen oder bearbeiten Sie benutzerdefinierte Felder:
  1. Klicken Sie im Menü auf Fehler > Konfiguration.
  2. Klicken Sie auf Benutzerdefinierte Fehlerfelder. Die Seite Benutzerdefinierte Fehlerfelder wird geöffnet.
  3. Klicken Sie auf das benutzerdefinierte Feld, das Sie bearbeiten möchten. Gehen Sie wie in den Eigenschaften zum Anpassen der Benutzeroberfläche beschrieben vor.
Übergeordnetes Thema: Anpassen der Seite "Fehlerdetails"
Zugehörige Konzepte
Anpassen der Seite "Fehlerdetails"


Anpassen des Workflow

In den Themen dieses Abschnitts werden die Schlüsselkonzepte bezüglich der Workflows in Issue Manager beschrieben. Es werden die drei Standard-Workflows vorgestellt und gezeigt, wie sie bearbeitet werden können.

  • Aktionsgetriebener Workflow
    Kurze Beschreibung des Konzepts. Sollte als Fragment geschrieben werden. Enthält höchstens zwei Sätze.
  • Standard-Workflows
    Hier werden Standard-Workflows beschrieben.
  • Entwickeln eigener Workflows
    Enthält Themen, die beschreiben, wie Sie Ihren Workflow entwickeln können.
  • Anpassung des Workflow-Status
    Beschreibt die Anpassung des Workflow-Status.
  • Anpassen von Aktionen, Begründungen und von Aktionsdialogen
    Hier wird beschrieben, wie die Aktionen, Begründungen und Aktionsdialoge angepasst werden.
  • Aktionseigenschaften
    Hier werden die Aktionseigenschaften beschrieben.
  • Intelligent Assistant
    Hier wird der Standardsatz an Status/Begründungen beschrieben.
Übergeordnetes Thema: Issue Manager-Verwaltung


Aktionsgetriebener Workflow

Issue Manager verwaltet einen Fehler über den gesamten Lebenszyklus und einen aktionsgetriebenen Workflow. Aktionsgetriebener Workflow bedeutet, dass ein Fehler durch Benutzeraktionen von einem Status (d. h. einer Bedingung) zum nächsten befördert wird, bis ein Endstatus erreicht ist.

Anmerkung: Ein Workflow benötigt mindestens einen Endstatus. Der Endstatus ist der letzte Status im Workflow.

Beispiel

Im Standard-Workflow erhält ein neuer Fehler, der vom Kundensupport gemeldet wird, den Status Ungeprüft. Das bedeutet, dass noch niemand überprüft hat, ob es sich tatsächlich um einen Fehler handelt. Nach Prüfung der Situation bestätigt ein QS-Mitarbeiter, dass ein Fehler vorliegt. Der Fehler wird an einen Entwickler gesendet, der ihn beheben soll. In diesem Beispiel ist der anfängliche Fehlerstatus Ungeprüft, die durchgeführte Aktion ist Bestätigen, und der nächste Status ist Offen.

Wurde jedoch bereits ein identischer Fehler eingegeben, lautet die mit dem ungeprüften Fehler durchzuführende Aktion Doppelt eingetragen. Der nächste Status ist vermutlich Geschlossen. Eine andere Aktion mit dem ungeprüften Fehler befördert diesen also auch in einen anderen Status (in diesem Fall Geschlossen).

Manchmal behalten Fehler ihren gegenwärtigen Status auch nach einer Aktion. Dies gilt beispielsweise für die Aktion Kommentar hinzufügen, mit der ein Benutzer zur Beschreibung eines vorhandenen Fehlers einen Kommentar hinzufügt.

Vom System bereitgestellte Aktionen

Issue Manager bietet für jeden Status in jedem Workflow zwei vordefinierte Aktionen an:
Neu zuweisen
Ordnet einen Fehler einem anderen Postfach zu.
Bearbeiten
Erlaubt das Ändern von Feldern auf der Seite Fehlerdetails.

Diese Aktionen verändern den aktuellen Status des Fehlers nicht, da sich der Fehler im Workflow nicht vorwärts bewegt.

Aktionsinformationen

Ein Workflow definiert einen gültigen Satz von Aktionen, die in einem bestimmten Status durchgeführt werden können. Diese Aktionen werden im Fenster Workflows angezeigt. Die verfügbaren Aktionen hängen davon ab, welcher Fehlertyp und welcher Aktuelle Status in den Listen ausgewählt sind.

Aktionen stehen auf der Seite Fehlerdetails in Form von Schaltflächen zur Verfügung. Die verfügbaren Schaltflächen (d. h. Aktionen) variieren je nach Fehlertyp und aktuellem Status.

Statusinformationen

Statusinformationen werden in Issue Manager an vielen verschiedenen Stellen angezeigt. So sind beispielsweise jeder Gruppe und jedem Benutzerkonto drei anfängliche Statuswerte zugeordnet (jeweils ein Fehlertyp pro Fehler: Fehler, Erweiterung und Dokumentation).

Anfänglicher Status wirkt sich auf Lebenszyklus aus

Der anfängliche Status eines Fehlers hängt davon ab, welche Kenntnisse der den Fehler meldende Benutzer über diesen Fehlertyp hat. Meldet beispielsweise ein Mitarbeiter des technischen Supports einen Dokumentationsfehler, kann davon ausgegangen werden, dass seine Einschätzung richtig ist. Der Fehler muss behoben werden und erhält den anfänglichen Status Zu dokumentieren. Meldet der gleiche Mitarbeiter jedoch einen Softwarefehler, sind möglicherweise Zweifel angebracht, und der anfängliche Status des Fehlers im Workflow ist Ungeprüft. Verschiedene Gruppen können für denselben Fehlertyp einen unterschiedlichen Anfangsstatus verwenden. Weitere Informationen über anfängliche Statuswerte finden Sie unter "Anfänglicher Fehlerstatus".

Speichert ein Benutzer einen Fehler, weist Issue Manager dem Fehler automatisch den Anfangsstatus zu, der dem Benutzer zugeordnet ist. Wenn ein technischer Autor einen Dokumentationsfehler meldet, hat das Feld Status auf der Seite Fehlerdetails den Wert Zu dokumentieren. Das Feld Status ist ein automatisches Feld. Automatische Felder werden nicht vom Benutzer, sondern von Issue Manager ausgefüllt.

  • Statuseigentümer
    Beschreibt den Statuseigentümer.
  • Begründungen
    Beschreibt die Begründungen.
Übergeordnetes Thema: Anpassen des Workflow


Statuseigentümer

Jeder Status in einem Workflow, der kein Endstatus ist, hat genau einen Eigentümer. Der Statuseigentümer ist die Rolle in einem Unternehmen, die für die Durchführung von Aktionen mit einem Fehler in einem bestimmten Status verantwortlich ist. Betrachten wir zum Beispiel einen ungeprüften Fehler: Der Benutzer, der einen ungeprüften Softwarefehler bestätigt oder ablehnt, führt mit großer Wahrscheinlichkeit die Rolle "QS" aus. Der Statuseigentümer eines ungeprüften Fehlers ist also die Rolle "QS".

Ein Endstatus in einem Workflow hat keinen Eigentümer, da ein Fehler in diesem Status keinen verantwortlichen Benutzer benötigt, der eine Aktion mit ihm durchführt.

Issue Manager bietet vier mögliche Eigentümer für einen Status an, der kein Endstatus ist:

  • QS
  • Entwicklung
  • Dokumentation
  • Erweiterungen
Anmerkung: Beachten Sie, dass ein Statuseigentümer kein spezieller QS-Mitarbeiter und kein spezielles Postfach ist. Er hängt auch nicht von einem Produkt, einer Komponente, einer Version oder einer Plattform ab. Der Statuseigentümer ist die allgemeine Bezeichnung für eine verantwortliche Person in einem bestimmten Status.

Der Eigentümer ist eine wichtige Eigenschaft eines Status, da er zusammen mit den Zuordnungsregeln das spezielle Postfach bestimmt, an das der Fehler gesendet wird. Eine Beschreibung der Zuordnungsregeln finden Sie unter Einrichten von Zuordnungsregeln. Im folgenden Beispiel verwendet Issue Manager Zuordnungsregeln, Statuswerte und Statuseigentümer, um einen Fehler an ein bestimmtes Postfach zu senden.

Angenommen, Sie haben entschieden, dass der Eigentümer des Status Ungeprüft für alle Softwarefehler, unabhängig von Produkt, Komponente usw., die Rolle "QS" sein soll. Die Mitarbeiter, die diese Rolle einnehmen, bestätigen, dass ein gemeldeter Fehler tatsächlich ein Fehler ist. Im Dialog Statuseigenschaften des Status Ungeprüft wählen Sie also die Optionsschaltfläche QS-eigener Status. Um auf dieses Dialog Statuseigenschaften zuzugreifen, gehen Sie zu Fehler > Konfiguration > Workflows, und klicken Sie dann auf Status bearbeiten.

Überlegen Sie sich nun die Zuordnungsregeln für bestimmte Produkte. Wenn Sie Zuordnungsregeln einrichten (Fehler > Konfiguration > Zuordnungsregeln), geben Sie für jede Kombination aus Produkt, Komponente, Version und Plattform vier Postfächer an. Jede der vier Optionsschaltflächen für Statuseigentümer entspricht einem der vier Postfächer auf der Seite Zuordnungsregeln: QS, Entwicklung, Erweiterung und Dokumentation.

Beispiel

Eine Zuordnungsregel legt fest, dass ein Fehler, der zur E-Mail-Komponente einer beliebigen Version von Produkt C auf einer beliebigen Plattform gehört, einem der folgenden Postfächer zugeordnet wird: Mike - QS, Sonja - Entw, Dan - Entw (Produkt C) oder Judy - Dok.

Eines der vier Postfächer wird basierend auf zwei Faktoren ausgewählt: der aktuelle Fehlerstatus und der Eigentümer eines Status. Angenommen, der aktuelle Status des Fehlers ist Ungeprüft, und die Rolle "QS" ist der Eigentümer ungeprüfter Fehler. In diesem Fall wird der Fehler automatisch dem Postfach von Mike zugeordnet (Mike - QS).

Führt Mike eine Aktion mit dem Fehler durch, befördert er diesen in seinem Lebenszyklus in einen anderen Status, der einen anderen Eigentümer hat. Wieder ermittelt Issue Manager das geeignete Postfach. Als Grundlage dienen der aktuelle Fehlerstatus, der Statuseigentümer und die Zuordnungsregel für das Produkt, die Komponente, die Version und die Plattform.

Übergeordnetes Thema: Aktionsgetriebener Workflow
Zugehörige Konzepte
Einrichten von Zuordnungsregeln


Begründungen

Die von Issue Manager unterstützten Begründungen sind optionale, anpassbare Schlüsselwörter, die beschreiben, warum ein Fehler bei einer bestimmten Aktion seinen Status gewechselt hat.

Eine Reihe von Aktionen kann dazu führen, dass ein Fehler denselben Status erhält. So kann ein Fehler beispielsweise aus vielen verschiedenen Gründen geschlossen werden – er ist nicht reproduzierbar, er ist doppelt vorhanden, er ist kein Fehler. Ohne die Zusatzinformation der Begründung hat der Benutzer vom Lebenszyklus des Fehlers nur ein unvollständiges Bild.

Begründungen tragen auch dazu bei, die Anzahl der Statuswerte in Ihrem Workflow zu verringern. Anstatt beispielsweise mehrere Endstatuswerte zu definieren (Kein Fehler, Nicht reproduzierbar, Duplikat), reicht es aus, den Status Geschlossen um einige Begründungen zu erweitern, die darüber Auskunft geben, warum eine Aktion einen Fehler geschlossen hat (z. B. Geschlossen/Kein Fehler).

Begründungen werden sowohl in den Aktionsdialogen als auch auf der Seite Fehlerdetails angezeigt. Angenommen, die technische Autorin Judy findet in ihrem Postfach einen Dokumentationsfehler vor. Nach dem Lesen der Beschreibung erinnert sie sich daran, dass der Fehler bereits gemeldet wurde. Sie kennzeichnet den Fehler als Duplikat. Wenn der Dialog Doppelt eingetragen geöffnet wird, kann sie sehen, dass der Fehler von Zu dokumentieren nach Geschlossen/Doppelt verschoben wurde. Geschlossen ist der neue Status, und Doppelt ist die Begründung.

Zuordnen, Löschen und Beibehalten einer Begründung

Bei bestimmten Aktionen ordnet Issue Manager der Aktion eine Begründung zu und gibt sie an den nächsten Status weiter. Nachfolgende Aktionen können die Begründung löschen oder einfach beibehalten. Eine einmal zugeordnete Begründung bleibt normalerweise so lange bei dem Fehler, bis dieser seinen Endstatus im Workflow erreicht.

Angenommen, ein Entwickler behebt einen Fehler und führt die Aktion Behoben durch, um anzuzeigen, dass der Fehler behoben wurde. Die Aktion setzt die Begründung auf Behoben und sendet den Fehler von Offen an Zu verifizieren. Der QS-Mitarbeiter, der die Anfrage des Entwicklers prüft, bestätigt die Behebung, indem er die Aktion Verifiziert durchführt. Die Aktion behält die Begründung Behoben bei und versetzt den Fehler in den Status Geschlossen.

Es gibt auch Fälle, in denen die Begründung gelöscht werden soll, z. B. dann, wenn ein Fehler zu einem früheren Status im Workflow zurückkehrt. Angenommen, der QS-Mitarbeiter beurteilt die Anfrage des Entwicklers negativ und führt die Aktion Ablehnen durch, die den Fehler wieder in den Status Offen versetzt. Nun ergibt die Begründung Behoben keinen Sinn mehr. Sie sollte daher für die Aktion Ablehnen gelöscht werden.

Ob Begründungen zugeordnet, gelöscht oder beibehalten werden, hängt von der Einstellung im Dialog Neue Aktion für Status ab, das unter “Begründung” beschrieben ist. Klicken Sie auf Fehler > Konfiguration > Workflows, und klicken Sie auf Aktion hinzufügen, um den Dialog Neue Aktion für Status anzuzeigen.

Übergeordnetes Thema: Aktionsgetriebener Workflow


Standard-Workflows

Issue Manager stellt drei Standard-Workflows bereit – für Fehler, Dokumentationsfehler und Erweiterungen. Wie Sie die Standard-Workflows anpassen oder eigene Workflows erstellen können, erfahren Sie unter Entwickeln eigener Workflows.

  • Standard-Fehler-Workflow
    Enthält ein Diagramm des Standard-Fehler-Workflows.
  • Standard-Erweiterungs-Workflow
    Hier wird der Erweiterungs-Workflow beschrieben
  • Standard-Dokumentations-Workflow
    Hier wird der Standard-Dokumentations-Workflow beschrieben.
Übergeordnetes Thema: Anpassen des Workflow
Zugehörige Konzepte
Entwickeln eigener Workflows


Standard-Fehler-Workflow

Das folgende Diagramm enthält den Standard-Fehler-Workflow:

Die Aktionen Bearbeiten, Neu zuordnen, Kommentar hinzufügen und Problemumgehung hinzufügen fehlen in diesem Diagramm.

  • Bearbeiten und Neu zuordnen sind für jeden Status vordefiniert und können nicht geändert werden. Diese Aktionen verändern den Fehlerstatus nicht.
  • Kommentar hinzufügen ist für alle Statuswerte definiert und verändert den Fehlerstatus nicht.
  • Problemumgehung hinzufügen ist für die Statuswerte Offen, Zu verifizieren, Zu präzisieren und Geschlossen definiert und verändert den Fehlerstatus nicht.

Standardbegründungen im Fehler-Workflow

Um sich alle Begründungen anzeigen zu lassen, die im Standard-Fehler-Workflow zur Verfügung stehen, klicken Sie auf Fehler > Konfiguration > Workflows. Wählen Sie FEHLER als Fehlertyp, und beobachten Sie die gültigen Aktionen und Begründungen.

Beispiele

Gehen wir von einem normalen Ablauf des Standard-Fehler-Workflow aus. Ein Fehler wird gemeldet, tritt im Status Ungeprüft in den Workflow ein und wird dem Postfach eines QS-Mitarbeiters zugeordnet. Der Fehler wird bestätigt und an das Postfach eines Entwicklers gesendet (Status Offen). Der Entwickler erklärt sich zur Beseitigung des Fehlers bereit und führt die Aktion Behoben durch. Die Aktion Behoben sendet den Fehler mit der Begründung Behoben an Zu verifizieren. Der QS-Mitarbeiter, der den Fehler erhält, überprüft, ob er behoben wurde. Er führt zu diesem Zweck die Aktion Überprüfen durch, die den Fehler an den Status Geschlossen sendet. Die Begründung Behoben wird beibehalten.

Nun nehmen wir am obigen Beispiel eine kleine Änderung vor. Angenommen, der QS-Mitarbeiter weist die Feststellung des Entwicklers zurück, dass der Fehler behoben wurde. Der Fehler landet erneut im Postfach des Entwicklers, diesmal jedoch mit der Begründung Abgelehnt. Der Entwickler kann das Problem nicht nachvollziehen und führt die Aktion Weitere Info erforderlich durch. Der Fehler geht an Zu präzisieren. Der QS-Mitarbeiter kann an dieser Stelle zwischen den beiden Aktionen Doppelt eingetragen und Kein Fehler mehr wählen, oder er kann das Problem klären und den Fehler wieder an Offen senden.

Übergeordnetes Thema: Standard-Workflows


Standard-Erweiterungs-Workflow

Nachstehend wird der Erweiterungs-Workflow beschrieben.

Die Aktionen Bearbeiten, Neu zuordnen, Kommentar hinzufügen und Problemumgehung hinzufügen fehlen in diesem Diagramm.

  • Bearbeiten und Neu zuordnen sind für jeden Status vordefiniert und können nicht geändert werden. Diese Aktionen verändern den Fehlerstatus nicht.
  • Kommentar hinzufügen ist für alle Statuswerte in diesem Workflow definiert und verändert den Fehlerstatus nicht.
  • Problemumgehung hinzufügen ist für alle Statuswerte mit Ausnahme von Ungeprüft definiert und verändert den Fehlerstatus nicht.

Standardbegründungen im Erweiterungs-Workflow

Um sich alle Begründungen anzeigen zu lassen, die im Standard-Erweiterungs-Workflow zur Verfügung stehen, klicken Sie auf Fehler > Konfiguration > Workflows. Wählen Sie ERWEITERUNGEN als Fehlertyp, und beobachten Sie die gültigen Aktionen und Begründungen.

Beispiel

Angenommen, eine Erweiterungsanforderung wird akzeptiert und von einer Prüfgruppe (Status Ungeprüft) oder von einem Verwaltungsteam (Beim Management) an die Entwicklungsabteilung (Offen) gesendet. Das Verwaltungsteam erhält die Erweiterungsanforderung, wenn die Prüfgruppe die Aktion Vielleicht durchführt.

Lehnt die Prüfgruppe oder das Verwaltungsteam die Erweiterungsanforderung ab, wird der Fehler mit der Begründung Abgelehnt geschlossen. Diese Ablehnen-Aktion unterscheidet sich von der gleichnamigen Aktion Ablehnenfür einen Fehler im Status Zu verifizieren. In diesem Fall wird die Entwicklungsaktion (Implementiert, Nicht machbar, Bereits fertig oder Doppelt eingetragen) erörtert.

Übergeordnetes Thema: Standard-Workflows


Standard-Dokumentations-Workflow

Das folgende Diagramm enthält den Standard-Dokumentations-Workflow:

Die Aktionen Bearbeiten, Neu zuordnen und Kommentar hinzufügen fehlen in diesem Diagramm.

  • Bearbeiten und Neu zuordnen sind für jeden Status vordefiniert und können nicht geändert werden. Diese Aktionen verändern den Fehlerstatus nicht.
  • Kommentar hinzufügen ist für alle Statuswerte in diesem Workflow mit Ausnahme von Zu verifizieren definiert und verändert den Fehlerstatus nicht.

Standardbegründungen im Dokumentations-Workflow

Um sich alle Begründungen anzeigen zu lassen, die im Standard-Dokumentations-Workflow zur Verfügung stehen, klicken Sie auf Fehler > Konfiguration > Workflows. Wählen Sie DOK-FEHLER als Fehlertyp, und beobachten Sie die gültigen Aktionen und Begründungen.

Beispiel

Angenommen, ein Dokumentationsfehler tritt im Status Ungeprüft in den Workflow ein. An diesem Punkt kann der Prüfer eine von drei möglichen Aktionen durchführen. Er kann den Fehler akzeptieren, ablehnen oder als Duplikat eines anderen Fehlers kennzeichnen. Wird der Fehler abgelehnt oder als Duplikat gekennzeichnet, wird er mit der Begründung Abgelehnt oder Doppelt geschlossen. Hält der Prüfer den Fehler für einen Dokumentationsfehler, der behoben werden muss, erhält der Fehler den Status Zu dokumentieren und landet im Dokumentationspostfach. Der Dokumentationsverantwortliche kann an dieser Stelle zwei Aktionen durchführen: Behoben oder Doppelt eingetragen.

  • Die Aktion Behoben sendet den Fehler mit der Begründung Behoben an Zu verifizieren.
  • Die Aktion Doppelt eingetragen sendet den Fehler mit der Begründung Doppelt an den Status Geschlossen.

Wird der Fehler zu einem späteren Zeitpunkt behoben, erhält er den Status Geschlossen mit der Begründung Behoben. Wird die Behebung dagegen abgelehnt, kehrt der Fehler mit der Begründung Abgelehnt in ein Dokumentationspostfach zurück.

Übergeordnetes Thema: Standard-Workflows


Entwickeln eigener Workflows

Wenn Sie Ihren Workflow entwickeln möchten, besteht der einfachste und zuverlässigste Ansatz darin, Änderungen an einem der Standard-Workflows vorzunehmen (z. B. durch Bearbeiten eines Statusnamens). Das Ändern eines Standard-Workflows ist dem Erstellen eines neuen Workflows unbedingt vorzuziehen. Dies gilt besonders dann, wenn Sie wenig oder keine Erfahrung mit diesen Konzepten haben.

Folgende Elemente können beispielsweise angepasst werden:

  • Anzahl und Namen der Statuswerte, die ein Fehler durchläuft.
  • Aktionen, die in einem bestimmten Status erlaubt sind. Diese Aktionen werden im Fenster Workflows angezeigt.
  • Welcher Status geht aus einer Aktion im aktuellen Status hervor:
    Current State ---- Action 1 ---> New State 1
Current State ---- Action 2 ---> New State 2
  • Welche Gruppen haben die Berechtigung für die einzelnen Aktionen?
  • Das Erscheinungsbild der Aktionsdialoge, die angezeigt werden, wenn der Benutzer eine Aktion mit einem Fehler durchführt.

Voraussetzungen

Machen Sie sich mit dem Konzept der Statusdiagramme und Aktionen (Statusübergänge) vertraut.

  • Erstellen eines Statusdiagramms
    Hier wird beschrieben, wie ein Statusdiagramm erstellt wird.
  • Benennen der Aktionen mit Verben
    Benennen Sie Aktionen mit Verben um einen verständlichen Workflow zu modellieren.
  • Optimieren des Workflows
    Beschreibt die Optimierung des Workflows.
  • Hinzufügen von Statuseigentümern und Berechtigungen
    Hier wird beschrieben, warum Sie Statuseigentümer und Berechtigungen hinzufügen sollten.
  • Vorbereiten eines Dateneingabeformulars
    Beschreibt, wie ein Dateneingabeformular für einen Kunden-Workflow aussehen sollte.
Übergeordnetes Thema: Anpassen des Workflow


Erstellen eines Statusdiagramms

Zeichnen Sie auf einer Tafel oder auf Papier ein Statusdiagramm. Achten Sie darauf, dass jeder Status von einem Kästchen umgeben ist und ausreichend Platz hat.

Zeichnen Sie jede erlaubte Aktion zwischen zwei Statuswerten als Linie mit einem Pfeil. Jede Richtung steht für eine bestimmte Aktion.

Beispiel

Das folgende Beispiel stellt eine Auswahl der Statuswerte dar, die in Ihrem Workflow auftreten können. Wenn ein neuer Fehler eingegeben wird, leitet ihn eine verantwortliche Person in Ihrem Unternehmen zur Überprüfung an einen QS-Mitarbeiter weiter. Ist der QS-Mitarbeiter der Meinung, dass es sich bei dem gemeldeten Verhalten um einen neuen Fehler handelt, wird dieser zur Behebung an die Entwicklungsabteilung gesendet. Die Entwicklungsabteilung kann mit dem Fehler eine Vielzahl von Aktionen durchführen.

  • Das im Fehlerbericht beschriebene Verhalten ist beabsichtigt. Es liegt kein Fehler vor.
  • Der Fehler soll bis zur nächsten Version zurückgestellt werden.
  • Der Fehler kann nicht reproduziert werden.
  • Der Fehler wird behoben.

Dies sind natürlich bisher nur ungeprüfte Anfragen des Entwicklers. Ihr Workflow-Modell könnte diesen Sachverhalt durch folgende Statuswerte abbilden: Behoben?, Zurückgestellt?, Nicht reproduzierbar? und Kein Fehler? Die Fragezeichen machen deutlich, dass die Anfragen noch nicht durch einen QS-Mitarbeiter überprüft wurden.

Übergeordnetes Thema: Entwickeln eigener Workflows


Benennen der Aktionen mit Verben

Es empfiehlt sich, jeder Aktion ein Verb zuzuordnen. Bedenken Sie Situationen, in denen ein Fehler in einen früheren Status des Workflow zurückkehrt. Modellieren Sie diese negativen Aktionen. Wenn ein QS-Mitarbeiter beispielsweise die Anfrage eines Entwicklers zurückweist, landet der Fehler wieder in der Entwicklungsabteilung.

Wenn Sie sich über die verschiedenen Wege Gedanken machen, die ein Fehler nehmen kann, entdecken Sie möglicherweise auch fehlende "positive" Aktionen. Sie könnten beispielsweise feststellen, dass der QS-Mitarbeiter auch Fehlerberichte zurückweisen kann, wodurch letztendlich die entsprechenden Fehler geschlossen werden. Im folgenden Beispieldiagramm führt die Aktion Fehler ablehnen durch den QS-Mitarbeiter beispielsweise zum Status Kein Fehler. Stellen Sie sicher, dass alle Aktionen zu einem Endstatus führen.

Überprüftes Beispiel

Übergeordnetes Thema: Entwickeln eigener Workflows


Optimieren des Workflows

Wie leicht ersichtlich, ist das vorhergehende Diagramm zu kompliziert, um nützlich sein zu können. Um den Workflow zu vereinfachen, können Sie auf die Aktion Verteilen verzichten. Die Zuordnungsregeln von Issue Manager sorgen dafür, dass alle Fehler den richtigen Postfächern zugeordnet werden. Im obigen Diagramm können Sie den Status Neuer Fehler und die Aktion Verteilen löschen. Weisen Sie dem Fehler einen Anfangsstatus zu, in dem er von einem QS-Mitarbeiter geprüft werden kann. Nennen Sie diesen Status z. B. Ungeprüft.

Ein weiterer Mangel des Workflow sind die sich wiederholenden Statuswerte. Mit Hilfe der Methodik von Issue Manager können Sie redundante Statuswerte eliminieren, indem Sie jeder Aktion eine Begründung zuordnen. Vergeben Sie für jede Aktion, die eine Begründung erfordert, ein kurzes, beschreibendes Schlüsselwort. Eine ausführliche Erläuterung des Begriffs "Begründung" finden Sie unter “Begründungen”. Um Redundanzen aufzudecken, suchen Sie im Workflow nach sich wiederholenden Mustern. Im obigen Diagramm kann beispielsweise die letzte Reihe der Statuswerte (Kein Fehler, Zurückgestellt, Nicht repro und Behoben) zu einem einzigen Status (Geschlossen) zusammengefasst werden, wobei jede Aktion eine andere Begründung erhält (z. B. Geschlossen/Kein Fehler, Geschlossen/Behoben).

Die Reihe neben der letzten Reihe lässt sich ebenfalls zu einem einzigen Status zusammenfassen, der die Rolle der QS beim Überprüfen der Anfragen aus der Entwicklungsabteilung unterstreicht. Sie könnten diesen Status "Zu verifizieren" nennen. Sie können die Begründungen an dieser Stelle verwenden, um zu erklären, warum ein Fehler den Status gewechselt hat (ein Fehler kann z. B. den Status Zu verifizieren mit der Begründung Behoben oder Zurückgestellt annehmen). Die vier Abgelehnt-Aktionen der QS können zu einer einzigen Abgelehnt-Aktion zusammengefasst werden. In ähnlicher Weise lassen sich die vier Überprüft-Aktionen der QS zu einer einzigen Überprüft-Aktion zusammenfassen.

Beispiel

Übergeordnetes Thema: Entwickeln eigener Workflows


Hinzufügen von Statuseigentümern und Berechtigungen

Fehler werden über Fehlerstatus und den Statuseigentümer zugeordnet. Der Statuseigentümer ist die Rolle in Ihrem Unternehmen, die für einen Fehler in einem bestimmten Status verantwortlich ist. Im Standard-Workflow ist die QS beispielsweise für Fehler mit dem Status Ungeprüft zuständig.

Nun müssen Sie jedem Status im endgültigen Diagramm einen Eigentümer zuweisen. Zuletzt legen Sie fest, welche Gruppen die Berechtigung für die einzelnen Aktionen haben. Im Standard-Workflow dürfen beispielsweise nur Benutzer der Entwicklungsabteilung Fehler beheben (d. h. die Aktion Behoben durchführen).

Übergeordnetes Thema: Entwickeln eigener Workflows


Vorbereiten eines Dateneingabeformulars

Bereiten Sie optional ein Formular vor, um die Dateneingabe in Issue Manager zu vereinfachen. Da die Workflow-Informationen per Status eingegeben werden, sollte die erste Spalte den aktuellen Status und Eigentümer enthalten. Fügen Sie dann die folgenden Spaltentitel hinzu:

  • Aktionen, die im gegenwärtigen Status erlaubt sind.
  • Neuer Status, der sich aus jeder Aktion ergibt.
  • Begründung (falls anwendbar).
  • Berechtigungen – Die Gruppe(n), die die einzelnen Aktionen durchführen dürfen.

Ihr Dateneingabeformular sollte etwa so aussehen:

Status/Eigentümer | Aktionen | Neuer Status | Rechte
Übergeordnetes Thema: Entwickeln eigener Workflows


Anpassung des Workflow-Status

In den Standard-Workflows können die Namen, die Eigentümer, und die Beschreibungen von Statuswerten geändert werden. Sie können alle Statuswerte auf einmal eingeben oder ändern und dann alle Aktionen für die einzelnen Statuswerte hinzufügen. Sie können auch einen Status zusammen mit all seinen Aktionen eingeben und dann mit dem nächsten Status fortfahren.

  • Statuseigenschaften
    Beschreibt die Statuseigenschaften.
  • Anpassen des Workflow-Status
    Hier wird die Anpassung des Workflow-Status beschrieben.
Übergeordnetes Thema: Anpassen des Workflow


Statuseigenschaften

Statuswerte haben die folgenden Eigenschaften:

Name
Erforderlicher, eindeutiger Statusname, bis zu 20 Zeichen lang. Sonderzeichen sind nicht erlaubt.
Beschreibung
Optionale Beschreibung des Status mit praktisch unbegrenzter Länge.
Statuseigentümer
Wählen Sie einen Statuseigentümer aus, indem Sie die entsprechende Option aktivieren:
  • QS-eigener Status
  • Entwicklungseigener Status
  • Dokumentationseigener Status
  • Erweiterungsstatus
  • Niemand (Endstatus)
Übergeordnetes Thema: Anpassung des Workflow-Status


Anpassen des Workflow-Status

Sie benötigen die Workflow customization-Berechtigung, um diese Aufgaben durchzuführen.
  1. Klicken Sie auf Fehler > Konfiguration > Workflows. Die Seite Workflows wird angezeigt.
  2. Wählen Sie den Fehlertyp, der den Workflow repräsentiert und den Sie anpassen möchten.
  3. Fahren Sie folgendermaßen fort:
    Dem Workflow einen Status hinzufügen

    Klicken Sie auf die Schaltfläche Status hinzufügen. Fahren Sie mit Schritt 4 fort.

    Einen Status in diesem Workflow bearbeiten

    Wählen Sie in der Liste Status den zu bearbeitenden Status aus. Klicken Sie auf die Schaltfläche Status bearbeiten. Fahren Sie mit Schritt 4 fort.

    Einem Status in diesem Workflow Aktionen hinzufügen

    Siehe Anpassen von Aktionen, Begründungen und Aktionsdialogen. Beginnen Sie dort mit Schritt 3.

    Einen Status in diesem Workflow löschen

    Wählen Sie in der Liste Status den zu löschenden Status aus. Klicken Sie auf die Schaltfläche Löschen. Wählen Sie im Bestätigungsdialog Ja. Issue Manager löscht nur Statuswerte, die nie von einem Fehler referenziert wurden.

    Ändern eines weiteren Workflow
    Kehren Sie zu Schritt 2 zurück.
  4. Legen Sie die Eigenschaften des Status fest, oder ändern Sie sie. Orientieren Sie sich an den Informationen unter Statuseigenschaften.
Übergeordnetes Thema: Anpassung des Workflow-Status
Zugehörige Tasks
Anpassen von Aktionen, Begründungen und von Aktionsdialogen


Anpassen von Aktionen, Begründungen und von Aktionsdialogen

Lesen Sie diesen Abschnitt nur, wenn Sie vorhaben, die Aktionen in den Standard-Workflows zu ändern, die unter Standard-Workflows beschrieben sind. Bevor Sie fortfahren, lesen Sie den Abschnitt Aktionseigenschaften.
  1. Klicken Sie auf Fehler > Konfiguration > Workflows.
  2. Wählen Sie den anzupassenden Workflow in der Liste Fehlertyp.
  3. Wählen Sie in den Status der Aktionen, die Sie ändern möchten, in der Liste Status.
  4. Die Seite Workflows zeigt nun die Informationen an, die Sie in dieser Anleitung eingeben werden:
    • Alle Aktionen, die zu diesem Status gehören (wie sie in der Spalte Schaltflächenbezeichnung angezeigt werden).
    • Der Status, der auf den aktuellen Status folgt, wenn eine bestimmte Aktion durchgeführt wird.
    • Die Begründung für jede gültige Aktion (falls anwendbar).
    Anmerkung: Die Aktionen Bearbeiten und Neu zuordnen, die Issue Manager für alle Statuswerte vordefiniert, lassen sich nicht ändern und werden daher in diesem Dialog nicht angezeigt.
  5. Fahren Sie folgendermaßen fort:
    Aktion für den aktuellen Status hinzufügen
    Klicken Sie auf Aktion hinzufügen und fahren Sie mit Schritt 6 fort.
    Aktion für den aktuellen Status bearbeiten
    Wählen Sie die Aktion, die Sie bearbeiten möchten, in der Spalte Schaltflächenbezeichnung aus.
    Diesem Workflow einen neuen Status hinzufügen
    Wiederholen Sie Schritt 3 unter So passen Sie den Workflow-Status an.
    Sortierfolge einer Aktion in diesem Workflow ändern

    Klicken Sie für die Aktion, die Sie in der Liste nach oben oder nach unten verschieben möchten, auf die Schaltfläche Nach oben oder Nach unten (in der Spalte Aktionen).

    Eine Aktion aus einem anderen Workflow löschen
    Klicken Sie auf das Symbol Löschen (in der Spalte Aktionen) der Aktion, die Sie löschen möchten. Klicken Sie im Bestätigungsdialog auf Ja.
    Anmerkung: Issue Manager löscht nur Statuswerte, die nie von einem Fehler referenziert wurden.
    Ändern der Aktionen in einem anderen Workflow
    Kehren Sie zu Schritt 2 zurück.
    Ändern der Statuswerte in einem anderen Workflow
    Wiederholen Sie Schritt 2 unter So passen Sie den Workflow-Status an.
  6. Legen Sie im Dialog Neue Aktion für Status die Eigenschaften einer vorhandenen Aktion fest, oder ändern Sie sie. Orientieren Sie sich an den Informationen unter Aktionseigenschaften.
Übergeordnetes Thema: Anpassen des Workflow
Zugehörige Konzepte
Aktionseigenschaften
Zugehörige Tasks
Anpassen des Workflow-Status


Aktionseigenschaften

Nachdem Sie die Statuswerte in einem Workflow festgelegt haben, müssen Sie die Aktionen definieren, die jedem Status zugeordnet sind. Im Status Offen des Standard-Fehler-Workflow kann ein Entwickler beispielsweise die Aktionen Behoben oder Nicht behebbar usw. durchführen.

Jede Aktion verfügt über eine Gruppe von Eigenschaften, die ihr zugeordnet sind.

Allgemeine Eigenschaften

Die Eigenschaften einer Aktion sind vielfältig und decken folgende Bereiche ab:

  • Schaltflächenbezeichnung, die auf der Seite Fehlerdetails angezeigt wird.
  • Beschreibung der Aktion, die auf der Seite Historie angezeigt wird.
  • Neuer Status, der sich aus dieser Aktion ergibt.
  • Begründung.
  • Erscheinungsbild und Verwendung des Aktionsdialogs.
  • Gruppen, die diese Aktion ausführen dürfen.
  • Sortierfolge dieser Aktion.

Dialog Aktion von Status.

Aktionseigenschaften werden im Dialog Aktion von Status bearbeiten festgelegt. (Fehler > Konfiguration > Workflows).

  • Informationen über den aktuellen Status
    Hier werden die aktuellen Statusinformationen beschrieben.
  • Neue Statusliste
    Beschreibt die neue Statusliste.
  • Register Standardaktionsfelder
    Beschreibt das Register Standardaktionsfelder für Aktionseigenschaften.
  • Register Benutzerdefinierte Aktionsfelder
    Beschreibt das Register Benutzerdefinierte Aktionsfelder für Aktionseigenschaften.
  • Register Rechte
    Beschreibt das Register "Rechte" für Aktionseigenschaften.
Übergeordnetes Thema: Anpassen des Workflow
Zugehörige Tasks
Anpassen von Aktionen, Begründungen und von Aktionsdialogen


Informationen über den aktuellen Status

Name
Kann nicht bearbeitet werden. Zeigt den Namen des aktuellen Status an, für den Sie eine Aktion definieren oder bearbeiten (z. B. Aktion für Status bearbeiten – Ungeprüft).
Schaltflächenbezeichnung
Dieser Name wird auf der Schaltfläche angezeigt, die diese Aktion ausführt. Die Schaltfläche befindet sich auf der Seite Fehlerdetails. Die Bezeichnung darf maximal 30 Zeichen lang sein.
Aktionscode für Historie
Kurze Beschreibung der durchgeführten Aktion, maximal 20 Zeichen lang. Es empfiehlt sich, Großbuchstaben zu verwenden (z. B. VERIFIZIERT). Diese Beschreibung wird in der Spalte Aktionen des Registers Historie auf der Seite Fehlerdetails angezeigt.
Kurzhinweis
Optionaler Text, der als Kurzhinweis eingeblendet wird, wenn der Benutzer den Cursor über die Aktionsschaltfläche bewegt.
Beschreibung
Optionale Beschreibung der Aktion.
Übergeordnetes Thema: Aktionseigenschaften


Neue Statusliste

Name
Name des nächsten Status im Workflow, wenn mit einem Fehler diese Aktion durchgeführt wird. Wird beispielsweise im Standard-Workflow ein Fehler mit dem Status Ungeprüft als Fehler bestätigt, weist Issue Manager ihm den nächsten Status zu (Offen).
Begründung
Optionales Schlüsselwort, das beschreibt, warum ein Fehler vom aktuellen in den nächsten Status gewechselt hat, wenn diese Aktion durchgeführt wurde. Wählen Sie die entsprechende Option aus:
Keine Änderung
Keine Änderung bewirkt, dass das Schlüsselwort beibehalten wird, wenn der Fehler in den nächsten Status wechselt. Es wird im Feld Begründung der Seite Fehlerdetails angezeigt. Der folgende Workflow zeigt z. B. einen Fehler, der von einem Entwickler behoben wurde. Er erhält den Status Zu verifizieren und die Begründung Behoben. Überprüft ein QS-Mitarbeiter die Anfrage, erhält der Fehler den Status Geschlossen, während er die Begründung Behoben behält. Jeder Benutzer, der sich Fehler anzeigen lässt, kann auf diese Weise sehen, mit welcher Begründung ein Fehler geschlossen wurde.
Entfernen
Bewirkt, dass die Begründung für den aktuellen Status gelöscht wird, wenn der Fehler in den nächsten Status wechselt. Entfernen bietet sich an, wenn ein Fehler zum vorherigen Status im Workflow zurückkehrt (wenn z. B. ein Entwickler einen Fehler behoben hat, erhält der Fehler den Status Zu verifizieren und die Begründung Behoben). Wird die "Behebung" jedoch abgelehnt, geht der Fehler zurück an die Entwicklungsabteilung (Offen), und die Begründung Behoben wird gelöscht, da sie nicht mehr zutrifft. Wenn Sie Entfernen wählen, zeigt die Seite Workflows im Feld Begründung den Wert ENTFERNEN an. Der Benutzer sieht jedoch ein leeres Feld Begründung auf der Seite Fehlerdetails.
Setzen auf

Bewirkt, dass Sie der Aktion eine neue Begründung zuweisen können. Geben Sie ein Schlüsselwort von bis zu 20 Zeichen Länge ein. Verwenden Sie ausschließlich Großbuchstaben. Verwenden Sie Setzen auf, wenn eine Aktion einen Fehler in einen neuen Status überführt, der eine Begründung erfordert. Im Allgemeinen sollten Sie allen Aktionen, die von einem Entwickler durchgeführt werden, eine Begründung zuordnen.

Im Standard-Workflow sendet beispielsweise die Aktion Behoben im Status Offen den Fehler mit der Begründung Behoben an Zu verifizieren. Auf menschliche Vorgänge übertragen bedeutet dies, dass ein Entwickler, der angibt, einen Fehler behoben zu haben, den Fehler an einen QS-Mitarbeiter übergibt. Dieser kann auf der Seite Fehlerdetails nachschlagen, warum sich der Fehler in seinem Postfach befindet (der Fehler könnte sich auch dort befinden, weil der Entwickler ihn nicht beheben kann oder weil die Software planmäßig läuft).

Wenn Sie keine Begründungen verwenden

Begründungen sind optionale Schlüsselwörter, die dazu beitragen, die Anzahl der Statuswerte in Ihrem Workflow zu verringern. Anstelle mehrerer Endzustände (Kein Fehler, Nicht reproduzierbar, Nicht repro und Doppelt) reicht ein einziger Endzustand aus, wenn die Begründungen erklären, warum sich der Fehler im Status Geschlossen befindet. Wenn Sie keine Begründungen verwenden, benötigen Sie möglicherweise mehrere Endzustände. Ein Status wird zum Endstatus, indem Sie die Optionsschaltfläche Niemand (Endstatus) wählen, die sich im Feld Statuseigentümer des Dialogs Statuseigenschaften befindet.

Übergeordnetes Thema: Aktionseigenschaften


Register Standardaktionsfelder

Im Register Standardaktionsfelder im Dialog Neue Aktion für Status werden die Eigenschaften definiert, die das Verhalten und das Erscheinungsbild des Aktionsdialogs bestimmen. Dazu gehören unter anderem:

  • Das Feld Aktionshinweise in Aktionsdialogen.
  • Versionsinformation in Aktionsdialogen.
  • Zugehörige Fehlernummer eines verwandten Problems in Aktionsdialogen.
Aktionshinweise
Nicht verwendet
Der Dialog Aktion enthält nicht das Feld Aktionshinweise, wenn der Benutzer diese Aktion ausführt.
Optional
Der Dialog Aktion enthält das Feld Aktionshinweise. Der Benutzer hat die Möglichkeit, für die durchgeführte Aktion eigene Informationen einzugeben.
Erforderlich
Der Dialog Aktion enthält ein erforderliches Feld Aktionshinweise. In diesem Fall muss der Benutzer eigene Informationen über die Aktion eingeben.
Versionsinformation
Mit dieser Gruppe können Sie im Aktionsdialog eine Liste anzeigen lassen, aus der der Benutzer die Version wählen kann, für die die Aktion durchgeführt wird. Die vom Benutzer gewählte Version wird auch in einem der automatischen Felder auf der Seite Fehlerdetails angezeigt. Die Information ist besonders für bestimmte Aktionen hilfreich (z. B. beim Bestätigen, Beheben und Verifizieren von Fehlern). Bei Aktionen, die den aktuellen Status nicht ändern, ist sie nicht sinnvoll. Das Feld Versionsinformation kann einen von vier Werten annehmen:
Nicht verwendet
Der Aktionsdialog enthält die Liste nicht. Der Aktionsdialog für die Aktion Kommentar hinzufügen zeigt kein Listenfeld für Versionsinformationen an, weil für die Aktion Kommentar hinzufügen keine solchen Informationen erforderlich sind.

Wenn Sie Nicht verwendet wählen, zeigt die Seite Fehlerdetails ein leeres Feld Aktionsversion an. Dies kann beispielsweise der Fall sein, wenn der Benutzer im optionalen Aktionsdialog keine Informationen bereitstellt oder eine Aktion durchgeführt wurde, bei der kein Listenfeld verwendet wird.

Optional oder Erforderlich
Der Aktionsdialog enthält eine optionale oder erforderliche Liste, aus der der Benutzer eine Version auswählt. Das letzte automatische Feld auf der Seite Fehlerdetails zeigt die Version an, in der die Aktion durchgeführt wurde. Sie müssen die Bezeichnung des Listenfeldes angeben, um es für die Aktion verfügbar zu machen. Die Bezeichnung darf einschließlich eines abschließenden Doppelpunkts maximal 20 Zeichen lang sein. Die Standardfeldbezeichnung lautet Bestätigt in: für Bestätigungsaktionen; Behoben in: für Behebungsaktionen und Verifiziert in: für Verifizierungsaktionen. Die Bezeichnung wird sowohl im Aktionsdialog als auch auf der Seite Fehlerdetails angezeigt. Die Werte auf der Liste lassen sich von der im Verwaltungsmodul angegebenen Versionsliste ableiten.
Entfernen
Der vorherige Wert im letzten automatischen Feld der Seite Fehlerdetails wird gelöscht, und die Feldbezeichnung wird wieder auf den Standardwert festgelegt, Aktionsversion. Das Feld Bezeichnung in der Gruppe Versionsinformation ist deaktiviert. Entfernen bietet sich an, wenn ein Fehler nach einer Aktion wieder einen vorherigen Status im Workflow einnimmt. Beispiele aus dem Standard-Workflow sind die Aktionen Ablehnen und Fehler erneut öffnen. Ein Beispiel: Ein Entwickler führt die Aktion Behoben durch und trägt im Feld Behoben in eine bestimmte Versionsnummer ein. Diese Aktion sendet den Fehler an den Status Zu verifizieren. Der für den Fehler verantwortliche QS-Mitarbeiter lehnt die Anfrage des Entwicklers ab, dass der Fehler behoben wurde. Die Aktion "Ablehnen" versetzt den Fehler aus seinem aktuellen Status (Zu verifizieren) zurück in den vorherigen Status im Workflow (Offen).

Wenn die Begründung einer Aktion gelöscht wird, können Sie Entfernen als Wert für das Feld Versionsinformation auswählen.

Die vom Benutzer im Aktionsdialog gewählte Version wird auch auf der Seite Fehlerdetails angezeigt. Angenommen, ein Benutzer führt die Aktion "Behoben" durch, wählt im Listenfeld "Behoben in" die Version 4.1:prod aus und klickt auf OK. Wenn die Seite "Fehlerdetails" wieder angezeigt wird, enthält das Feld "Behoben in" die angegebene Version.

Zugehörige Fehlernummer
Ermöglicht, im Aktionsdialog ein Textfeld zu platzieren, in dem der Benutzer die Nummer eines verwandten Fehlers oder eines Fehlerduplikats eingeben kann. Diese Information ist hilfreich, wenn der Benutzer die Aktion Doppelt eingetragen im Fehler-Workflow oder die Aktion Bereits fertig im Erweiterungs-Workflow durchführt.
Nicht verwendet
Textfeld wird nicht im Aktionsdialog angezeigt.
Optional oder Erforderlich

Ein optionales oder erforderliches Textfeld wird im Aktionsdialog angezeigt. Sie müssen eine Bezeichnung für das Textfeld festlegen. Die Bezeichnung darf einschließlich eines abschließenden Doppelpunkts maximal 20 Zeichen lang sein. Die Standardfeldbezeichnung im Fehler-Workflow ist Duplikat von Nr.. Die Standardfeldbezeichnung im Erweiterungs-Workflow ist Siehe auch.

Die vom Benutzer im Aktionsdialog angegebene Fehlernummer wird auch im Feld Bemerkungen des Registers Historie der Seite Fehlerdetails angezeigt. Angenommen, ein Benutzer führt die Aktion Doppelt eingetragen für Fehler-Nr. 8 durch, gibt Fehler-Nr. 6 als Duplikat an und klickt auf OK. Wenn die Seite Fehlerdetails wieder angezeigt wird, enthält das Feld Bemerkungen den Satz Verwandt mit Fehlernummer n, wobei n der Wert des Feldes Duplikat von Nr. ist. Wenn das Feld Duplikat von Nr. optional ist und vom Benutzer nicht ausgefüllt wird, zeigt das Feld Bemerkungen den Wert des Feldes Aktionshinweise an.

Übergeordnetes Thema: Aktionseigenschaften


Register Benutzerdefinierte Aktionsfelder

Im Register Benutzerdefinierte Aktionsfelder des Dialogs Neue Aktion für Status können Sie dem Aktionsdialog einer bestimmten Aktion Felder hinzufügen.

Acht Feldpositionen
Diese Felder werden im Aktionsdialog zusätzlich zu den Standardaktionsfeldern angezeigt. Feld 1 bis Feld 4 werden im Aktionsdialog unten links angezeigt. Feld 5 bis Feld 8 werden im Aktionsdialog unten rechts angezeigt. Angenommen, im Listenfeld wird das Feld Stunden für Behebung ausgewählt. Es soll im Aktionsdialog der Aktion Behoben im Status Offen an der Position des ersten Feldes (Feld 1) angezeigt werden.
Quellen
Felder werden in den Listen des Registers Benutzerdefinierte Aktionsfelder aus zwei möglichen Gründen angezeigt:
  • Benutzerdefinierte Felder wurden über Fehler > Konfiguration > Benutzerdefinierte Fehlerfelder erstellt, um benutzerdefinierte Felder zu erstellen, die auch im Register Benutzerdefiniert in den Fehlerdetails angezeigt werden.
  • Benutzerdefinierte Felder wurden über Fehler > Konfiguration > Benutzerdefinierter Feld-Pool erstellt, welche nur für Aktionen relevant sind.
Definieren von Feldern in einem Aktionsdialog
  1. Klaicken Sie auf Fehler > Konfiguration > Benutzerdefinierte Fehlerfelder, um benutzerdefinierte Felder zu erstellen, die auch im Register Benutzerdefiniert in den Fehlerdetails angezeigt werden. Sie können auch benutzerdefinierte Felder verwenden, die über Fehler > Konfiguration > Benutzerdefinierter Feld-Pool erstellt wurden, welche nur für Aktionen relevant sind.
  2. Konfigurieren Sie die Feldeigenschaften, wie es unter Eigenschaften zum Anpassen der Benutzeroberfläche beschrieben ist.
  3. Die von Ihnen erstellten benutzerdefinierten Felder können dann in den Listenfeldern des Registers Benutzerdefinierte Aktionsfelder ausgewählt werden.
Übergeordnetes Thema: Aktionseigenschaften
Zugehörige Konzepte
Anpassen der Seite "Fehlerdetails"


Register Rechte

Im Register Rechte können Sie Sicherheitsstufen für bestimmte Aktionen festlegen, die nur von bestimmten Benutzergruppen durchgeführt werden dürfen.

Das Feld Sicherheit anwenden hat standardmäßig den Wert Nein (d. h. alle Gruppen haben die Berechtigung für alle Aktionen). Diese Einstellung wird im Fenster Workflows als (alle Gruppen) angezeigt. Um Sicherheitseinstellungen festzulegen, klicken Sie auf die Optionsschaltfläche Ja und wählen dann eine oder mehrere Gruppen aus, die die Berechtigung haben sollen, diese Aktion durchzuführen.

Berücksichtigen Sie dieses Beispiel für die Definition der Sicherheit für eine Aktion: Wenn ein Entwickler die Seite Fehlerdetails für einen Fehler im Status Offen öffnet, ist die Aktion Nicht behebbar verfügbar. Öffnet jedoch ein Benutzer, der kein Entwickler ist, die Seite Fehlerdetails für denselben Fehler, ist die Aktion ausgeblendet.

Übergeordnetes Thema: Aktionseigenschaften


Intelligent Assistant

Der Intelligent Assistant verwendet zum Verarbeiten von Testergebnissen einen Standardsatz von vier Status/Begründungs-Paaren, die den vier allgemeinen Statuswerten entsprechen, die der Standard-Workflow für Fehler definiert.

So lassen Sie sich die Standardstatuswerte und die Standardbegründungen anzeigen:

  1. Klicken Sie auf Konfiguration > Intelligent Assistant.
  2. Passen Sie die Zuordnung zwischen den allgemeinen Fehlerstatuswerten und den speziellen Issue Manager-Codes an.

    Wenn der Standard-Workflow für Fehler geändert wurde, müssen auch die Statuswerte und die Begründungen für die Ergebnisverarbeitung angepasst werden. Ändert der Administrator beispielsweise den Standard-Workflow so, dass Fehler, die auf ihre Behebung warten, den Status Ungeprüft erhalten, muss er auch den Statuswert für Fehler mit Status "Behoben", aber noch nicht getestet von Zu verifizieren in Ungeprüft ändern.

    Neben den Fehlerstatuswerten und Begründungen auf der Seite "Intelligent Assistant" verwendet Intelligent Assistant auch die Endstatuswerte, die für den Fehler-Workflow festgelegt sind. Endstatuswerte werden auf der Seite "Workflows" festgelegt. Der Standard-Endstatus ist Geschlossen.

Übergeordnetes Thema: Anpassen des Workflow


Fehlerarchivierung

Nachdem Sie Issue Manager für eine Weile eingesetzt haben, finden Sie möglicherweise Fehler in der Datenbank, die keine Bedeutung mehr haben (z. B. Fehler, die geschlossen wurden oder zu nicht unterstützten Produkten gehören). Je mehr Fehler die Datenbank enthält, um so länger dauert die Ausführung von Aktionen (z. B. von Abfragen). Sie können Fehler archivieren, um die Systemleistung zu optimieren. Danach können Sie die Aktionen mit der veringerten Anzahl von aktiven (also nicht archivierten) Fehlern durchführen.

Wenn Sie Fehler archivieren, verschiebt Issue Manager sie aus den DEFECT Tabellen in die ARCHIVE Tabellen. Alle Fehlerinformationen bleiben erhalten. (Im Vergleich dazu bleiben aktive Fehler in der DEFECT-Tabelle, und Benutzer können mit ihnen die gewohnten Aktionen durchführen.)

Die Benutzer können sich archivierte Fehler auf der Seite Fehlerdetails anzeigen lassen, aber keine Aktionen mit ihnen durchführen, da sie schreibgeschützt sind. Archivierte Fehler werden nicht in den Postfächern von Benutzern angezeigt. Die Benutzer können jedoch Abfragen, Berichte und Diagramme mit archivierten Fehlern erstellen. Archivierte Fehler werden in der Datenbank lediglich "versteckt", aber nicht gelöscht.

Anmerkung: Es empfiehlt sich, Fehler keinesfalls manuell zu löschen, da die Integrität der Daten sonst nicht mehr gewährleistet ist.

Sie können Ihre Produktionsdatenbank jedoch verkleinern, indem Sie eine neue benutzerdefinierte Datenbank erstellen, die aus der ursprünglichen Datenbank nur die aktiven Fehler und die dazugehörigen Informationen importiert.

Wenn Sie einen Fehler archivieren, der auf dem Desktop eines Benutzers angezeigt, aber nicht bearbeitet wird, erfährt der Benutzer erst dann von der Änderung, wenn er sich ab- und wieder anmeldet, das Programm beendet und den Issue Manager neu lädt oder versucht, mit dem Fehler eine Aktion durchzuführen.

Anmerkung: Issue Manager informiert Benutzer darüber, dass mit archivierten Fehlern keine Aktionen durchgeführt werden können.
  • Archivieren von Fehlern
    Hier wird beschrieben, wie Fehler archiviert werden.
Übergeordnetes Thema: Issue Manager-Verwaltung


Archivieren von Fehlern

So archivieren Sie Fehler:

  1. Klicken Sie im Menü auf Fehler > Konfiguration > Archiv.
  2. Wählen Sie das Produkt für die Fehler aus, die archiviert werden sollen.
  3. Im Feld Version werden die Versionen für das gewählte Produkt angezeigt. Wählen Sie die Version für die Fehler aus, die archiviert werden sollen. Wenn Sie Fehler in mehreren Versionen archivieren möchten, wählen Sie diese aus, indem Sie bei gedrückter Strg- oder Umschalt-Taste auf die gewünschten Versionen klicken.
  4. Klicken Sie auf die Schaltfläche Archiv.
  5. Klicken Sie im Bestätigungsfenster auf Ja, um die Archivierung zu starten.
Übergeordnetes Thema: Fehlerarchivierung


Einrichten von E-Mail-Benachrichtigungsregeln

Mithilfe der E-Mail-Benachrichtigung können Sie Issue Manager so konfigurieren, dass Sie oder andere Mitarbeiter Ihres Unternehmens bei bestimmten Ereignissen (z. B. Änderung eines Fehlerzustands) automatisch eine E-Mail erhalten.

E-Mail-Benachrichtigungsregeln

Benutzer können sich bei folgenden Ereignissen per E-Mail benachrichtigen lassen:

  • Ein Fehler wird einem anderen Postfach zugeordnet.
  • Ein Fehler wechselt in einen anderen Workflow-Status (z. B. von Ungeprüft zu Offen).
  • Jede Änderung an einem Fehler, die zu einem neuen Eintrag in der Historie des Fehlers führt (z. B. Änderung der Komponente, für die der Fehler geändert wurde).
  • Jedes andere von Ihnen definierte Ereignis (z. B. Senden einer E-Mail an den technischen Support, wenn ein bestimmter Fehler behoben ist).

Die obigen Ereignisse werden als Regeln bezeichnet. Die ersten drei Regeln sind vordefiniert. Sie können nicht geändert werden. Für spezielle Ereignisse können Sie so viele zusätzliche Regeln definieren, wie Sie möchten.

Benachrichtigungen

Eine E-Mail-Benachrichtigung weist Issue Manager an, eine E-Mail zu versenden, wenn ein Ereignis für einen Fehler stattfindet. Eine Benachrichtigung besteht aus einer E-Mail-Benachrichtigungsregel, die das Ereignis festlegt, dem Absender und dem Empfänger, dem Text der Nachricht, einer optionalen Betreffzeile, einer Einleitung und einem Nachsatz.

Der Benutzer muss jedem Fehler, der von Interesse ist, eine Benachrichtigung zuordnen. Nur Benutzer mit der Berechtigung E-Mail-Benachrichtigung für Fehler können einzelnen Fehlern Benachrichtigungen zuordnen.

Klicken Sie auf das Symbol Benachrichtigungen der Seite Fehlerdetails, um sich die Benachrichtigungen eines Fehlers anzeigen lassen.

Regeln können auch in Benachrichtigungen verwendet werden, die sich auf alle Fehler in der Datenbank beziehen. Solche Benachrichtigungen nennt man systemweite Benachrichtigungen.

Um systemweite Benachrichtigungen hinzuzufügen, benötigen Sie die Berechtigung E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen.
  • Definieren von E-Mail-Benachrichtigungsregeln
    Hier wird beschrieben, wie E-Mail-Benachrichtigungsregeln festgelegt werden.
  • Verwalten von E-Mail-Benachrichtigungsregeln
    Beschreibt die Verwaltung von E-Mail-Benachrichtigungsregeln.
  • Löschen eines Postfachs
    Das Löschen eines Postfachs ist nur möglich, wenn es keine Fehler enthält, nicht in den Zuordnungsregeln referenziert wird und nicht das Standardpostfach eines Benutzers ist.
  • Verwalten systemweiter Benachrichtigungen
    Hier wird beschrieben, wie systemweite Benachrichtigungen verwaltet werden.
Übergeordnetes Thema: Issue Manager-Verwaltung
Zugehörige Konzepte
E-Mail-Benachrichtigung


Definieren von E-Mail-Benachrichtigungsregeln

Voraussetzungen

Um eigene Regeln definieren zu können, müssen Sie folgende Voraussetzungen erfüllen:

  • Sie benötigen die Berechtigung E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen.
  • Sie müssen mit SQL vertraut sein, speziell mit der WHERE-Klausel.
  • Sie müssen mit dem Datenbankschema vertraut sein, speziell mit den Spalten der fehlerbezogenen Ansichten und Tabellen IM_V_Defects und IM_DefectHistory.
  • Sie müssen mit Ihrem Workflow und seinen Werten vertraut sein.

Tipps für WHERE-Klauseln in SQL

Hier sind einige wichtige Tipps, mit denen Sie syntaktisch und semantisch richtige WHERE-Klauseln erstellen können.

Referenzieren Sie sowohl IM_V_Defects als auch IM_DefectHistory.

Ihre WHERE-Klauseln erfordern vermutlich Referenzen sowohl auf IM_V_Defects als auch auf IM_DefectHistory. Die Ansicht IM_V_Defects speichert aktuelle Informationen über einen Fehler. Die Tabelle IM_DefectHistory speichert alle Aktionen, die mit dem Fehler durchgeführt wurden, und alle Auswirkungen dieser Aktionen auf bestimmte Fehlerfelder.

So finden Sie in IM_DefectHistory beispielsweise die Postfachzuordnung eines Fehlers vor und nach einer Aktion. Die entsprechenden Spalten heißen AssignedIN (Postfachzuordnung vor der Aktion) und AssignedOUT (Postfachzuordnung nach der Aktion).

Alle Aktionen mit Fehlern werden im Feld ActionCode der Tabelle IM_DefectHistory aufgezeichnet. Diese Aktionen werden als Aktionscodes in der Spalte Aktion der Registerkarte Historie angezeigt. Sie kennen solche Codes (z. B. BEHOBEN und VERIFIZIERT) aus der Beispieldatenbank.

Um sich die Aktionscodes für die meisten der Aktionen in Ihrer Datenbank anzeigen zu lassen, öffnen Sie den Dialog Aktion von Status bearbeiten für jeden Status (die Ausnahmen EINGEGEBEN, NEU ZUGEORDNET und GEÄNDERT sind hart codiert und können nicht angezeigt werden). Um den Dialog Aktion von Status bearbeiten für einen Status zu öffnen, wählen Sie Fehler > Konfiguration > Workflows. Klicken Sie auf den Namen des Status in der Spalte Schaltflächenbezeichnung. Beachten Sie den Wert im Feld Aktionscode für Historie.

Verwenden Sie Aliase
Die Ansichten und Tabellen haben Aliasnamen. Sie müssen den Alias D verwenden, um die Ansicht IM_V_Defects zu referenzieren, und den Alias DH, um die Tabelle IM_DefectHistory anzusprechen.
Identifizieren benutzerdefinierter Felder

Die benutzerdefinierten Felder in der Ansicht IM_V_Defects heißen Custom1, Custom2 usw., je nach ihrer Position auf den Registern. Jedes benutzerdefinierte Register hat bis zu 10 Felder, 1-10, 11-20 usw. Auf Benutzerdefiniertes Register 1 werden die ersten fünf Felder in der linken Spalte angezeigt, die Felder 6 bis 10 in der rechten Spalte (beide Male in absteigender Reihenfolge).

Den Schemanamen für ein bestimmtes benutzerdefiniertes Feld finden Sie unter Fehler > Konfiguration > Benutzerdefinierte Fehlerfelder. Im Dialogfeld für die Beispieldatenbank ist das Kontrollkästchen Hinweis hinzufügen? z. B. das vierte Feld in der linken Spalte von Benutzerdefiniertes Register 1. Das Gleiche gilt für Benutzerdefiniert4 in der Fehlertabelle.

Anmerkung: Wenn Sie die Position eines benutzerdefinierten Feldes ändern, müssen Sie auch alle E-Mail-Benachrichtigungsregeln ändern, die dieses Feld referenzieren.
Änderungen an benutzerdefinierten Feldern werden nicht protokolliert
Issue Manager protokolliert keine Änderungen an den benutzerdefinierten Feldern in der Tabelle IM_DefectHistory. Sie können zwar den aktuellen Wert eines benutzerdefinierten Feldes überprüfen, nicht aber vorherige Werte. So kann die WHERE-Klausel beispielsweise prüfen, ob das Kontrollkästchen Hinweis hinzufügen? aktiviert ist, nicht aber, ob das Kontrollkästchen seinen Wert geändert hat (von "Aktiviert" nach "Deaktiviert").
Zugreifen auf Werte von Kontrollkästchen

Der Wert eines deaktivierten Kontrollkästchens ist ‘.’ (ein Punkt). Der Wert eines aktivierten Kontrollkästchens ist 'X' (ein großes X).

Um beispielsweise alle Fehler abzurufen, für die Hinweis hinzufügen? aktiviert ist, fügen Sie in die WHERE-Klausel die folgende Anweisung ein:

D.Custom4 = 'X'

Beispiele für Regeln

Hier sind vier Situationen, in denen neue Regeln benötigt werden. Die beiden ersten Situationen setzen Regeln voraus, die in Benachrichtigungen für bestimmte Fehler angewendet werden. Die beiden letzten Situationen beziehen sich auf Regeln in systemweiten Benachrichtigungen. Auf jedes Beispiel folgt die WHERE-Klausel für die Beispieldatenbank.

Beispiel 1

Der technische Support und andere Gruppen verlangen Auskunft darüber, wann ein bestimmter Fehler den Status "Behoben" erhalten hat.

Die WHERE-Klausel sieht so aus:

DH.ActionCode = 'VERIFIED'

Der Wert für ActionCode in der Tabelle IM_DefectHistory wird aktualisiert, wenn ein Benutzer eine Aktion durchführt. Daher erhält der technische Support nur eine einzige E-Mail, nämlich dann, wenn die Aktion "Überprüfen" den Aktionscode "VERIFIZIERT" in die Tabelle IM_DefectHistory und in das Register Historie einträgt.

Wenn sich die Klausel auf die Begründung bezieht (Disposition in der Datenbank), würde sie so aussehen:

D.Disposition = 'FIXED'

In diesem Fall würde der technische Support mit großer Wahrscheinlichkeit mehrmals per E-Mail benachrichtigt, da die Begründung in der Datenbank weiterhin "BEHOBEN" lautet. Ein Benutzer, der nachträglich einen Kommentar hinzufügt oder den Fehler speichert, würde eine E-Mail auslösen, da die Regel immer noch erfüllt ist.

Beispiel 2

Ein gewöhnlicher Benutzer, der keine Aktionen mit Fehlern durchführt, möchte wissen, was mit einem Fehler geschehen ist, den er eingegeben hat. Er möchte per E-Mail benachrichtigt werden, wenn sich ein Entwickler dem Fehler zuwendet. Für den Workflow bedeutet dies, dass der Fehler soeben den Status Offen verlassen hat. Die WHERE-Klausel muss demzufolge prüfen, ob sich nach der Aktion der Status geändert hat.

Die WHERE-Klausel lautet:

DH.StatusIN = 'Dev-Ready'
AND DH.StatusOUT <> 'Dev-Ready'

Vor der Aktion war der Status Offen. Nach der Aktion erhielt der Fehler einen anderen Status.

Beispiel 3

Die Dokumentationsabteilung lässt alle Dokumentationsfehler an das Gruppenpostfach Dok (Produkt A) und nicht an das Benutzerpostfach Judy -- Dok senden. Der Dokumentationsmanager möchte per E-Mail benachrichtigt werden, wenn ein Fehler im Gruppenpostfach abgelegt wird.

Die WHERE-Klausel lautet:

DH.AssignedIN <> 'Doc (Product A)'
AND DH.AssignedOUT = 'Doc (Product A)'

Die Klausel bewirkt, dass eine E-Mail gesendet wird, wenn das Postfach vor der Aktion nicht Dok (Produkt A) war, nach der Aktion aber Dok (Produkt A) ist. Die E-Mail wird nur einmal gesendet, nämlich dann, wenn der Dokumentationsfehler dem Postfach Dok (Produkt A) zugeordnet wird.

Beachten Sie, dass der Dokumentationsmanager ohne den ersten Teil der WHERE-Klausel immer dann per E-Mail benachrichtigt wird, wenn mit dem Dokumentationsfehler eine Aktion durchgeführt wird und dieser dem Postfach "Dok (Produkt A)" zugeordnet ist. Obwohl die Regel möglicherweise zahlreiche E-Mails generiert, da die Benachrichtigung systemweit angewendet werden muss, fassen die beiden Teile der WHERE-Klausel die Regel zu einem einzigen Ereignis zusammen: wenn das Postfach zu Dok (Produkt A) wird.

Sie brauchen in dieser Regel den Fehlertyp DOK-FEHLER nicht anzugeben (obwohl es nicht falsch wäre), da das Postfach Dok (Produkt A) nur Dokumentationsfehler enthält.

Beispiel 4

Der Versionsmanager möchte im Lauf des nächsten Monats per E-Mail über schwer wiegende Fehler benachrichtigt werden, die nicht behoben werden konnten. Dies soll vor der Einführung einer größeren Versionsumstellung geschehen. Die WHERE-Klausel muss die Einstufung, Produkt B und den Aktionscode Nicht behebbar untersuchen, der zugeordnet wird, wenn ein Entwickler die Aktion Nicht behebbar durchführt.

Die WHERE-Klausel lautet:

D.Severity = '1: Fatal/Data Loss'
AND DH.ActionCode = 'Cannot-Fix'
AND D.ProductCode = 'Product B'

Diese Einschränkungen sind notwendig, da die WHERE-Klausel nur die Einstufung untersucht, trifft die Regel immer dann zu, wenn der Fehler geändert und gespeichert wird, denn die Einstufung ändert sich nur explizit durch eine Benutzereingabe.

Der Versionsmanager würde Unmengen von E-Mails erhalten, besonders dann, wenn die Regel in einer systemweiten Benachrichtigung zur Anwendung kommt. Er kann die Benachrichtigung allerdings einfach löschen, wenn der Versionszyklus beendet ist.

Tipps für WHERE-Klauseln

Gehen Sie vom Allgemeinen zum Speziellen vor. Überlegen Sie sich zuerst allgemeine Geschäftssituationen, die vielleicht E-Mail-Benachrichtigungsregeln erfordern. Fragen Sie beispielsweise alle Issue Manager-Benutzer, wann sie per E-Mail über Fehler benachrichtigt werden möchten. Finden Sie genau heraus, welche Informationen der Benutzer in einer E-Mail erwartet. Ein Benutzer könnte Ihnen beispielsweise erzählen, er möchte benachrichtigt werden, wenn ein Fehler behoben wurde. Bei näherer Betrachtung stellt sich jedoch heraus, dass er informiert werden möchte, wenn die Behebung des Fehlers durch einen QS-Mitarbeiter überprüft worden ist. Die beiden Ansätze erfordern möglicherweise unterschiedliche WHERE-Klauseln.

Wenn Sie glauben, die Bedürfnisse der Benutzer verstanden zu haben, übertragen Sie die Situation auf den Workflow Ihres Unternehmens.

Am Ende stellen Sie die WHERE-Klausel zusammen. Versuchen Sie, die WHERE-Klausel durch eine komplizierte Abfrage zu testen, um sicherzustellen, dass die Bedingungen auf die gewünschte Weise angegeben wurden.

Im Allgemeinen sollten Regeln für Benachrichtigungen, die sich auf einzelne Fehler beziehen, möglichst einfach und allgemein gehalten werden. Regeln für systemweite Benachrichtigungen sollten dagegen präzise und restriktiv formuliert werden, um übermäßiges E-Mail-Aufkommen zu vermeiden.

Stellen Sie sich die Frage, wie oft Benutzer E-Mails erhalten möchten – ein einziges Mal oder bei jeder Änderung. Wünscht der Benutzer nur eine einzige Mail, sollten Sie die Regeln mit mehreren Einschränkungen formulieren.

Übergeordnetes Thema: Einrichten von E-Mail-Benachrichtigungsregeln
Zugehörige Tasks
Definieren von Benachrichtigungsregeln


Verwalten von E-Mail-Benachrichtigungsregeln

Um E-Mail-Benachrichtigungsregeln hinzuzufügen, zu bearbeiten oder zu löschen, benötigen Sie die Berechtigung E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen.
So fügen Sie eine E-Mail-Benachrichtigungsregel hinzu, bearbeiten oder löschen sie:
  1. Klicken Sie auf Fehler > Konfiguration > Benachrichtigungsregeln.
  2. Fahren Sie je nach Aufgabe folgendermaßen fort:
    Regel hinzufügen

    Klicken Sie auf die Schaltfläche Regel hinzufügen. Der Dialog Neue Benachrichtigungsregel wird angezeigt. Fahren Sie mit Schritt 3 fort.

    Vordefinierte Regel bearbeiten
    Vordefinierte Regeln können nicht bearbeitet werden.
    Vordefinierte Regel löschen
    Vordefinierte Regeln können nicht gelöscht werden.
    Von Ihnen erstellte Regel bearbeiten

    Klicken Sie auf das Symbol Bearbeiten (in der Spalte Aktionen) der Regel, die Sie bearbeiten möchten. Fahren Sie fort, wie es unter Schritt 3 beschrieben ist.

    Von Ihnen erstellte Regel löschen

    Klicken Sie auf das Symbol Löschen (in der Spalte Aktionen) der Regel, die Sie löschen möchten. Klicken Sie im Bestätigungsfenster auf OK, um die Löschung zu bestätigen.

  3. Legen Sie im Dialog Neue Benachrichtigungsregel die folgenden Eigenschaften fest, oder ändern Sie sie:
    Regelname
    Erforderlicher eindeutiger Name; maximal 30 Zeichen. Der Name sollte möglichst aussagekräftig sein, da Regeln über ihren Namen zugeordnet werden.
    Beschreibung
    Optionale Beschreibung des auslösenden Ereignisses; maximal 250 Zeichen.
    WHERE-Klausel
    Erforderliche SQL WHERE-Klausel, die das auslösende Ereignis angibt; maximal 250 Zeichen. Verwenden Sie nicht das Schlüsselwort "WHERE".
  4. Klicken Sie auf OK, um Ihre Einstellungen zu speichern, oder auf Abbrechen zum Schließen ohne Speichern.

Beachten Sie folgende Punkte, nachdem Sie Regeln definiert haben:

E-Mail-Adressen für alle Benutzer angeben
Um E-Mail-Benachrichtigungen zu verwenden, müssen Benutzer eine gültige E-Mail-Adresse in ihrem Konto angeben.
Lassen Sie die E-Mail-Benachrichtigung von Ihrem Datenbankadministrator aktivieren.
Nach der Aktivierung der Funktion wird das Symbol Benachrichtigungen auf der Seite Fehlerdetails angezeigt.
Ihre Benutzer instruieren
Informieren Sie die Benutzer über die verfügbaren Regeln und ihre Bedeutung. Die Benutzer können sich die Regeln über Fehler > Konfiguration > Benachrichtigungsregeln anzeigen lassen.
Übergeordnetes Thema: Einrichten von E-Mail-Benachrichtigungsregeln
Zugehörige Tasks
Einrichten von Benutzerkonten


Verwalten systemweiter Benachrichtigungen

Die folgenden Abschnitte beschreiben die Verwaltung systemweiter Benachrichtigungen.

Anmerkung: Um systemweite Benachrichtigungen hinzuzufügen, zu bearbeiten oder zu löschen, benötigen Sie die Berechtigung E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen.
  • Hinzufügen von systemweiten Benachrichtigungen
    Hier wird beschrieben, wie eine systemweite Benachrichtigung hinzugefügt wird.
  • Bearbeiten von systemweiten Benachrichtigungen
    Hier wird beschrieben, wie systemweite Benachrichtigungen bearbeitet werden.
  • Löschen systemweiter Benachrichtigungen
    Hier wird beschrieben, wie systemweite Benachrichtigungen gelöscht werden.
  • Eingeben von Parametern im Betreff von Benachrichtigungen
    Hier werden die Parameter beschrieben, die im Feld Betreff einer Benachrichtigung verwendet werden können.
  • Aktivieren von Standard-E-Mail-Benachrichtigungen
    Hier wird beschrieben, wie Standard-E-Mail-Benachrichtigungen verwendet werden.
  • Anzeigen systemweiter Benachrichtigungen
    Hier wird beschrieben, wie systemweite Benachrichtigungen angezeigt werden.
Übergeordnetes Thema: Einrichten von E-Mail-Benachrichtigungsregeln
Zugehörige Tasks
Definieren von E-Mail-Benachrichtigungen
Hinzufügen von systemweiten Benachrichtigungen


Hinzufügen von systemweiten Benachrichtigungen

  1. Klicken Sie auf Fehler > Konfiguration > Systemweite Benachrichtigungen. Auf dieser Seite werden alle systemweiten Benachrichtigungen angezeigt.
  2. Klicken Sie auf Systemweite Benachrichtigung hinzufügen.
  3. Wählen Sie im Dialog Benachrichtigung hinzufügen einen Regelnamen aus der Liste.
  4. Wählen Sie ein Optionsfeld im Bereich Von des Dialogs die Rücksendeadresse aus:
    • Der Benutzer, der den Fehler bearbeitet (und dadurch die Benachrichtigung auslöst).
    • Anderer Benutzer (wählen Sie den Benutzer in der Liste aus).
  5. Geben Sie die E-Mail-Adresse des Empfängers in das Feld An ein. Wenn Sie mehrere Adressen eingeben, trennen Sie diese durch Kommas. In der Liste Adresse hinzufügen können Sie Benutzer auswählen.
    Anmerkung: Obwohl Sie im Feld An jede beliebige E-Mail-Adresse eingeben können, werden in der Liste Adresse hinzufügen nur Benutzer angezeigt, deren E-Mail-Adresse im Benutzerkonto angegeben ist. Aus diesem Grund empfiehlt es sich, für jedes Benutzerkonto eine E-Mail-Adresse zu definieren.
  6. Füllen Sie die optionalen Felder für den Nachrichtentext aus:
    • Betreff ist eine optionale Betreffzeile (maximal 80 Zeichen).
    • Einleitung ist ein optionaler Einleitungstext (maximal 250 Zeichen).
  7. Wählen Sie den Inhaltstyp der Nachricht aus:
    • Folgende Inhalte sind zulässig:
      • Fehlerkurzfassung: Die Informationen im oberen Bereich der Seite Fehlerdetails.
      • Fehlerkurzfassung mit Beschreibung: Fehlerkurzfassung und Informationen im Register Beschreibung.
      • Vollständige Fehlerdetails: Alle Fehlerinformationen (Standardeinstellung).
    • Nachsatz ist ein optionales Signaturfeld (maximal 250 Zeichen).
  8. Klicken Sie auf OK, um die Benachrichtigung zu speichern und den Dialog zu schließen.
Klicken Sie auf Regelname, um die Benachrichtigung zu bearbeiten. Wenn Sie eine Benachrichtigung löschen möchten, klicken Sie in der Spalte Aktionen auf [image] (Systemweite Benachrichtigung entfernen). Klicken Sie auf [image], um eine Kopie der Benachrichtigung zu erstellen.
Anmerkung: Sie benötigen die Berechtigung E-Mail-Benachrichtigungsregeln und systemweite Benachrichtigungen, um systemweite Benachrichtigungen zu definieren.
Übergeordnetes Thema: Verwalten systemweiter Benachrichtigungen
Zugehörige Konzepte
Eingeben von Parametern im Betreff von Benachrichtigungen
Verwalten systemweiter Benachrichtigungen
Zugehörige Tasks
Definieren von E-Mail-Benachrichtigungen


Bearbeiten von systemweiten Benachrichtigungen

  1. Klicken Sie auf Fehler > Konfiguration > Systemweite Benachrichtigungen. Auf dieser Seite werden alle systemweiten Benachrichtigungen angezeigt.
  2. Klicken Sie auf das Symbol Bearbeiten (in der Spalte Aktionen) der Benachrichtigung, die Sie bearbeiten möchten.
  3. Wählen Sie im Dialog Benachrichtigung hinzufügen einen Regelnamen aus der Liste.
  4. Wählen Sie ein Optionsfeld im Bereich Von des Dialogs die Rücksendeadresse aus:
    • Der Benutzer, der den Fehler bearbeitet (und dadurch die Benachrichtigung auslöst).
    • Anderer Benutzer (wählen Sie den Benutzer in der Liste aus).
  5. Geben Sie die E-Mail-Adresse des Empfängers in das Feld An ein. Wenn Sie mehrere Adressen eingeben, trennen Sie diese durch Kommas. In der Liste Adresse hinzufügen können Sie Benutzer auswählen.
    Anmerkung: Obwohl Sie im Feld An jede beliebige E-Mail-Adresse eingeben können, werden in der Liste Adresse hinzufügen nur Benutzer angezeigt, deren E-Mail-Adresse im Benutzerkonto angegeben ist. Aus diesem Grund empfiehlt es sich, für jedes Benutzerkonto eine E-Mail-Adresse zu definieren.
  6. Füllen Sie die optionalen Felder für den Nachrichtentext aus:
    • Betreff ist eine optionale Betreffzeile (maximal 80 Zeichen).
    • Einleitung ist ein optionaler Einleitungstext (maximal 250 Zeichen).
  7. Wählen Sie den Inhaltstyp der Nachricht aus:
    • Folgende Inhalte sind zulässig:
      • Fehlerkurzfassung: Die Informationen im oberen Bereich der Seite Fehlerdetails.
      • Fehlerkurzfassung mit Beschreibung: Fehlerkurzfassung und Informationen im Register Beschreibung.
      • Vollständige Fehlerdetails: Alle Fehlerinformationen (Standardeinstellung).
    • Nachsatz ist ein optionales Signaturfeld (maximal 250 Zeichen).
  8. Klicken Sie auf OK, um die Benachrichtigung zu speichern und den Dialog zu schließen.
Übergeordnetes Thema: Verwalten systemweiter Benachrichtigungen


Löschen systemweiter Benachrichtigungen

  1. Klicken Sie auf Fehler > Konfiguration > Systemweite Benachrichtigungen. Auf dieser Seite werden alle systemweiten Benachrichtigungen angezeigt.
  2. Klicken Sie auf das Symbol Löschen (in der Spalte Aktionen) der Benachrichtigung, die Sie löschen möchten.
  3. Klicken Sie im Bestätigungsdialog auf Ja, um die Löschung auszuführen.
Übergeordnetes Thema: Verwalten systemweiter Benachrichtigungen


Eingeben von Parametern im Betreff von Benachrichtigungen

Im Feld Betreff einer Benachrichtigung können Sie mit Hilfe von Parametern dynamische Betreffzeilen für E-Mail-Benachrichtigungen generieren.

Folgende Parameter sind erlaubt:

{ID}
Gibt die Fehlernummer zurück
{PROJ}
Gibt den Projektnamen zurück
{PROD}
Gibt das Produkt zurück
{COMP}
Gibt die Komponente zurück
{USER}
Gibt den Benutzer zurück, der den Fehler geändert hat
{RULE}
Gibt den Namen der Regel zurück, die die Benachrichtigung ausgelöst hat
{SYN}
Gibt die Kurzbeschreibung zurück
{STATE}
Gibt den aktuellen Fehlerstatus zurück
{SEV}
Gibt die Einstufung des Fehlers zurück
{REASON}
Gibt die aktuelle Begründung des Fehlers zurück
{CUSTOM1-40}
Gibt das benutzerdefinierte Feld mit der angegebenen Nummer zurück ({CUSTOM3} gibt beispielsweise den Wert im benutzerdefinierten Feld 3 zurück).

Wenn Sie z. B. eine E-Mail-Benachrichtigung erstellen möchten, die Sie benachrichtigt, wenn sich der Status eines Fehlers geändert hat, geben Sie im Feld Betreff den folgenden Text ein:

State of issue {ID} was changed by {user}.

Wenn nun beispielsweise der Mitarbeiter Bill (Benutzername bpetersson) den Fehler mit der Nummer 2 bereinigt, erhalten Sie eine E-Mail mit folgender Betreffzeile:

State of issue 2 was changed by bpetersson.
Übergeordnetes Thema: Verwalten systemweiter Benachrichtigungen


Aktivieren von Standard-E-Mail-Benachrichtigungen

Die Standardbenachrichtigungsfunktion kann unabhängig von den zugewiesenen Berechtigungen von jedem Benutzer aktiviert werden. Sie löst eine Benachrichtigung aus, wenn ein fremder Benutzer einen Fehler im eigenen Postfach ändert oder dem eigenen Postfach einen neuen Fehler zuordnet.

Anmerkung: Der Betreff und der Nachrichtentext können in der Datei SRFrontendBootConf.xml bereitgestellt werden.
  1. Klicken Sie auf Konfiguration > Optionen.
  2. Aktivieren Sie das Kontrollkästchen Benachrichtigen, wenn Benutzer mir Fehler zuordnen oder Änderungen an Fehlern in meinem Postfach vornehmen.
Übergeordnetes Thema: Verwalten systemweiter Benachrichtigungen


Anzeigen systemweiter Benachrichtigungen

Wenn ein Benutzer das Kontrollkästchen Systemweite Benachrichtigungen auf dem Benachrichtigungs-Dialog anzeigen aktiviert (Fehler > Konfiguration > Optionen), werden auf dem Dialog Benachrichtigung jedes Fehlers alle systemweiten Benachrichtigungen angezeigt. Außerdem werden die Benachrichtigungen aufgelistet, die dem aktiven Fehler zugeordnet sind.

  1. Klicken Sie auf Fehler > Konfiguration > Optionen.
  2. Aktivieren Sie das Kontrollkästchen Systemweite Benachrichtigungen auf dem Benachrichtigungs-Dialog anzeigen.
Übergeordnetes Thema: Verwalten systemweiter Benachrichtigungen


Berichte

  • Der Berichts-Data-Mart
    Hier wird der Berichts-Data-Mart beschrieben und wie Sie einfach und schnell Berichte damit erstellen können
  • Berichtsbereich
    Hier wird beschrieben, welche Themen in dem Berichtsbereich behandelt werden.
  • Codeanalyse
    Hier wird beschrieben, wie die Codeabdeckung mit Silk Central analysiert werden kann.
  • Standardberichte
    Hier werden die Standardberichte beschrieben.
Übergeordnetes Thema: Fehlerverfolgung und Ergebnisanalyse
Zugehörige Konzepte
Berichte (Issue Manager)


Der Berichts-Data-Mart

Silk Central bietet einen Data-Mart für den einfachen Zugang zu den wichtigsten Daten an. Dies erleichtert die Berichtserstellung und verbessert die Abfragezeiten dank wesentlich einfacheren SQL-Abfragen.

  • Übersicht
    Hier werden die Vorteile des Berichts-Data-Mart beschrieben.
  • Architektur
    Hier wird die Architektur des Berichts-Data-Mart beschrieben.
  • Wie Sie Berichte mit dem Data-Mart erstellen
    In diesem Abschnitt wird Anhand von realen Beispielen beschrieben, wie Sie Berichte mit den Data-Mart Ansichten erstellen können.
  • Fehlerdiagnose
    Beantwortet Fragen, die Sie zum Data-Mart haben könnten.
  • Referenz: Data-Mart Tabellen und Ansichten
    In diesem Abschnitt werden die Data-Mart Tabellen und Ansichten beschrieben, die für die einfache und schnelle Berichtserstellung verfügbar sind.
Übergeordnetes Thema: Berichte


Übersicht

Der Silk Central Berichts-Data-Mart ermöglicht den mühelosen Zugriff auf Daten für die Erstellung von Berichten. Er verschiebt die Daten aus den Produktivtabellen in die Ansichten, die für die Erstellung von erweiterten Berichten verwendet werden sollen. Die Vorteile sind:
  • Die klare Benennung von Tabellen und Ansichten, was Ihnen ermöglicht, die gesuchten Daten schnell zu finden.
  • Vorverarbeitete Daten, was Ihnen die Möglichkeit gibt auf aggregierte Daten zuzugreifen, ohne dass Sie selbst die Berechnungen machen müssen.
  • Leistungsverbesserung, da die Berichte viel einfachere und schnellere SQL-Abfragen verwenden können.
  • Eine geringere Abhängigkeit von der Last der Produktivdatenbank, was ebenfalls die Leistung verbessert und Belastungsspitzen entfernt.
Die aktuelle Version des Data-Marts deckt den Ergebnisbereich ab. Weitere Bereiche für die Berichtserstellung werden in zukünftigen Versionen hinzugefügt. Die folgenden Tabellen und Ansichten sind derzeit verfügbar:
  • Die DM_TestStatus Tabelle ist der Grundlage für statusbezogene Ansichten.
  • Die RV_TestStatusExtended Ansicht liefert detaillierte Informationen zu einer bestimmten Testausführung.
  • Die RV_LatestTestStatus Ansicht liefert Statusinformationen und erweiterte Informationen zu dem aktuellsten Testlauf eines Tests im Rahmen einer Testsuite und eines bestimmten Builds.
  • Die RV_MaxTestRunID Ansicht ist ein Helfer um die aktuellste Testlauf-ID für jeden Test, jede Testsuite und jede Build-Kombination abzurufen.
  • Die RV_TestingCycleStatus Ansicht liefert Status-Informationen zu Testzyklen.
  • Die RV_ExecutionPlanStatusPerBuild Ansicht ruft die aktuellsten Summen der Teststatus für jede Testsuite im Rahmen eines Builds ab.
  • Die RV_ExecutionPlanStatusRollup Ansicht ruft die Summen von bestehenden, fehlgeschlagenen und nicht ausgeführten Tests pro Testsuite oder im Rahmen eines Builds ab.
  • Die RV_ConfigurationSuiteStatus Ansicht listet die Status-Anzahlen aller Konfigurationssuiten und Konfigurationen pro Build auf.
Übergeordnetes Thema: Der Berichts-Data-Mart


Architektur

Daten werden im Hintergrund aus den Produktivdatenbanktabellen extrahiert und in die Data-Mart Tabellen und Ansichten zur einfachen und schnellen Abfrage geladen. Wenn die Belastung der Datenbank nicht zu hoch ist, werden die Daten normalerweise in weniger als einer Minute verfügbar sein, nachdem Veränderungen durchgeführt wurden. Wenn Sie als Systemadministrator eingeloggt sind, können Sie den aktuellsten Stand der Datenladeprozesse prüfen, indem Sie zu http://<server>:<port>/sctm/check/db navigieren und das Kontrollkästchen DM_TestStatus Table anhaken.

Anmerkung: Wenn Sie von einer Silk Central-Version aktualisieren, die den Data-Mart noch nicht enthielt (vor Version 13,0), werden die Data-Mart Tabellen und Ansichten mit den Daten vom Produktivssystem zunächst gefüllt. Abhängig von der Größe der Datenbank kann dieser Prozess einige Zeit dauern. Nachdem der Prozess abgeschlossen ist, können Sie auf die Daten zugreifen.

Übergeordnetes Thema: Der Berichts-Data-Mart


Wie Sie Berichte mit dem Data-Mart erstellen

Die folgenden Beispiele zeigen, wie Sie nützliche Berichte mit den Data-Mart Ansichten erstellen können.

  • Wie Sie Data-Mart Abfragen schreiben
    Schreiben Sie erweiterte Abfragen in SQL zur Berichterstellung.
  • Die Zuverlässigkeit von Tests in einer Testsuite
    In diesem Abschnitt wird beschrieben, wie Sie einen Bericht erstellen, der die Ergebnisse eines bestimmten Tests im Rahmen einer bestimmten Testsuite auflistet, um aufzuzeigen, wie sich die Testergebnisse im Laufe Zeit verändert haben.
  • Alle fehlgeschlagenen Tests in einem Ausführungsordner
    In diesem Abschnitt wird beschrieben, wie Sie einen Bericht erstellen, der alle fehlgeschlagenen Tests in einem Ausführungsordner auflistet.
  • Status des Testzyklus
    In diesem Abschnitt wird beschrieben, wie ein Bericht erstellt wird, der den aktuellen Status eines Testzyklus pro Tester und Build zeigt.
  • Status von Testsuitehierarchien
    In diesem Abschnitt wird beschrieben, wie Sie einen Bericht erstellen können, der die Anzahl bestandener, fehlgeschlagener und nicht ausgeführter Tests für einen bestimmten Testsuite-Ordner auflistet, gruppiert nach Build,.
  • Status einer Konfigurationssuite
    In diesem Abschnitt wird beschrieben, wie Sie einen Bericht erstellen können, der die Anzahl bestandener, fehlgeschlagener und nicht ausgeführter Tests für jede Konfiguration pro Build zurückgibt.
Übergeordnetes Thema: Der Berichts-Data-Mart


Wie Sie Data-Mart Abfragen schreiben

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den Ordner für den neuen Bericht aus. Dadurch legen Sie fest, wo der Bericht in der Ordnerhierarchie gespeichert wird.
  3. Klicken Sie auf Neuer untergeordneter Bericht in der Symbolleiste. Der Dialog Neuen Bericht erstellen wird angezeigt.
  4. Geben Sie einen Namen für den neuen Bericht ein. Mit diesem Namen wird der Bericht in der Berichtshierarchie angezeigt.
  5. Aktivieren Sie das Kontrollkästchen Diesen Bericht anderen Benutzern zur Verfügung stellen, wenn der Bericht für andere Benutzer freigegeben werden soll.
  6. Geben Sie im Feld Beschreibung eine Beschreibung des Berichts ein.
  7. Klicken Sie auf Erweiterte Abfrage, um das Feld Berichtsdatenabfrage zu öffnen. Fügen Sie vorhandenen Code ein, oder schreiben Sie neuen Code direkt in das Feld. Die Liste Platzhalter einfügen unterstützt Sie bei der Bearbeitung der SQL-Abfragen mit vordefinierten Funktionsplatzhaltern. Weitere Informationen finden Sie unter SQL-Funktionen für benutzerdefinierte Berichte.
    Anmerkung: Nach der manuellen Bearbeitung von SQL-Anweisungen für die Abfrage sollte deren Gültigkeit mit SQL überprüfen geprüft werden.
  8. Klicken Sie auf Fertig stellen, um die Änderungen zu speichern.
Übergeordnetes Thema: Wie Sie Berichte mit dem Data-Mart erstellen


Die Zuverlässigkeit von Tests in einer Testsuite

Das Problem

In einer kontinuierlichen Integrationsumgebung werden Tests idealerweise mindestens einmal pro Tag ausgeführt, um den täglichen Build zu testen und die Qualität der zu testenden Anwendung zu sichern. Um zu verstehen, wie zuverlässig Ihr Test-Set für die Messung der Qualität Ihrer AUT ist, ist es notwendig gelegentlich zu überprüfen, wie sich die Testergebnisse im Laufe der Zeit verändern. Vielleicht haben Sie beispielsweise Tests in Ihrem Test-Set, die ständig ihren Status verändern, was bedeutet, dass sie kein echtes Maß für Qualität sind.

Die Lösung

Verwenden Sie die Data-Mart Ansicht RV_TestStatusExtended um einen Bericht zu erstellen, der die Ergebnisse für einen bestimmten Test im Rahmen von einer bestimmten Testsuite auflistet. Dadurch können Sie sehen, wie sich die Testergebnisse im Laufe der Zeit verändert haben. Der Einfachheit halber beschränken wir die Ergebnisliste auf Tests von markierten Builds, damit wir nur bestimmte Meilenstein-Builds der zu testenden Anwendung in Betracht ziehen. Dieser Bericht sammelt Testergebnisdaten für Tests im Rahmen von Testsuiten und Builds. In der folgenden Abfrage

  • Wählen wir die Spalten aus, die wir von dieser Ansicht anzeigen möchten.
  • Beschränken wir das Ergebnis auf die ID des Tests, den wir untersuchen möchten, und die ID der Testsuite, zu dem der Test gehört.
  • Fügen wir eine Einschränkung hinzu, damit nur markierte Builds in Betracht gezogen werden.
SELECT TestName, ExecutionPlanName, VersionName, BuildName, TestRunID,
  PassedCount, FailedCount, NotExecutedCount
FROM RV_TestStatusExtended
WHERE TestID = ${TESTID|1|Test ID} AND ExecutionPlanID = ${EXECUTIONPLANID|1|Execution Plan ID} AND BuildIsTagged = 1
ORDER BY BuildOrderNumber
Das Ergebnis der SQL-Abfrage liefert alle Testläufe für den ausgewählten Test in der ausgewählten Testsuite. Im folgenden Beispiel sehen Sie, dass der Test für den Build 579_Drop2 wiederholt wurde:
TestName | Execution PlanName | Version Name | BuildName | TestRunID | Passed Count | FailedCount | NotExecutedCount
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 579_Drop02 | 7741797 | 59 | 5 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 579_Drop02 | 7745078 | 63 | 1 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 593_Drop03 | 7787437 | 63 | 1 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 605_Drop04 | 7848720 | 63 | 1 | 0
Übergeordnetes Thema: Wie Sie Berichte mit dem Data-Mart erstellen


Alle fehlgeschlagenen Tests in einem Ausführungsordner

Das Problem

Üblicherweise werden alle Testsuiten in einer Ordnerhierarchie strukturiert, die die verschiedenen Bereiche und Zwecke identifiziert, zu denen die Testsuiten und Tests in Verbindung stehen. Die Testsuiten werden regelmäßig in einer kontinuierlichen Integrationsumgebung oder bisweilen über einen gegebenen Zeitraum getriggert. Zur Folge haben Sie schöne Ausführungsstatistiken - leider nur für jede einzelne Testsuite.

Manchmal brauchen Sie jedoch eine allgemeine Übersicht über die Testergebnisse für einen bestimmten Bereich oder Zweck, um zu wissen und zu identifizieren, wo die Schwächen liegen.

Die Lösung

Verwenden Sie die Data-Mart-Ansicht RV_LatestTestStatus um einen Bericht zu erstellen, der eine Liste aller fehlgeschlagenen Tests für eine bestimmten Hierarchietiefe einer Testsuite zurückgibt.

Die folgende Abfrage wählt fehlgeschlagene Tests in einem Testsuite-Ordner aus, mit Zusatzinformationen wie dem Namen der Testsuite und des Builds.

SELECT TestID, TestName, ExecutionPlanID, ExecutionPlanName, BuildName
FROM RV_LatestTestStatus lts
INNER JOIN TM_ExecTreePaths ON lts.ExecutionPlanID = TM_ExecTreePaths.NodeID_pk_fk
WHERE TM_ExecTreePaths.ParentNodeID_pk_fk = ${executionFolderID|2179|Execution Folder ID}
  AND StatusID = 2
ORDER BY TestName
Die Abfrage macht Folgendes:
  • Verwendet die Ansicht RV_LatestTestStatus, um das aktuellste Testlaufergebnis abzurufen.
  • Enthält die Testsuitehierarchie (TM_ExecTreePaths), um alle Tests von allen Testsuiten in der Hierarchie abzufragen.
  • Verwendet die ID von dem Ordner der höchsten Ebene, wo die Analyse als ParentNodeID_pk_fk gestartet werden soll.
  • Enthält nur fehlgeschlagene Tests (StatusID = 2).

Die StatusID finden Sie in der tabelle TM_TestDefStatusNames.

Das Ergebnis der SQL-Query ist alle Tests in dem ausgewählten Testsuite-Ordner, für den der letzte Testlauf fehlgeschlagen ist.
TestID | TestName | ExecutionPlanID | ExecutionPlanName | BuildName
14073 | JUnitTestPackage | 2184 | CI Testing | 352
14107 | Volatile Tests | 2191 | Volatile Test | 352
Übergeordnetes Thema: Wie Sie Berichte mit dem Data-Mart erstellen


Status des Testzyklus

Das Problem

Ein Testzyklus kann komplex sein, da er Informationen über manuelle Tester, Tests, verschiedene Builds und Versionen von Produkten und möglicherweise auch Konfigurationen enthält. Um die Übersicht nicht zu verlieren, ist es wichtig die Antworten auf folgende Fragen zu finden:

  • Wie viele Tests wurden beendet?
  • Wie viele Tests pro Build haben bestanden oder sind fehlgeschlagen?
  • Sind die manuellen Tester noch beschäftigt oder können sie zusätzliche Arbeit anfangen?

Die Lösung

Verwenden Sie die Data-Mart Ansicht RV_TestingCycleStatus, um einen Bericht zu erstellen, der den Status eines Testzyklus pro Tester und pro Build zeigt. Damit haben Sie eine Übersicht über die Anzahl von bestandenen, fehlgeschlagenen oder nicht ausgeführten Tests, die nach manuellem Tester, Konfiguration und Build gruppiert sind.

SELECT BuildName, TesterLogin, TesterExecutionName,
  PassedCount, FailedCount, NotExecutedCount
FROM RV_TestingCycleStatus
WHERE TestingCycleID = ${testingCycleID|3|Testing Cycle ID}
ORDER BY BuildOrderNumber, TesterLogin
Die Abfrage macht Folgendes:
  • Sie verwendet die Ansicht RV_TestingCycleStatus als Datenquelle, da sie BuildName, TesterLogin und TesterExecutionName enthält, welche den generierten Namen von Tester, Konfiguration und Test darstellen.
  • Begrenzt die Daten auf die relevante Testzyklus-ID.
Das Ergebnis der SQL-Abfrage zeigt den Status pro Build und pro Tester.
BuildName | TesterLogin | TesterExecutionName | PassedCount | FailedCount | NotExecuted Count
352 |  | No specific tester (Test Assets) | 0 | 0 | 1
351 | admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 1 | 0
352 | admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 0 | 1
352 | gmazzuchelli | gmazzuchelli (English|Oracle10g|IE8|Tomcat - Test Assets) | 0 | 1 | 1
352 | jallen | jallen (German|Oracle11g|FF|Tomcat - Test Assets) | 1 | 1 | 0
352 | smiller | smiller (German|SQL2008|IE8|IIS - Test Assets) | 1 | 1 | 0

Für nicht zugeordnete Tests wird eine Gruppe "kein zugewiesener Tester" erstellt, mit leeren Werten für TesterLogin,TesterFirstName, und TesterLastName.

Falls Sie den Fortschritt des Testzyklus bezogen auf die Leistung von den manuellen Testern wissen möchten, hilft eine leichte Abwandlung der Abfrage:
SELECT TesterLogin, TesterExecutionName, SUM(PassedCount) PassedCount,
  SUM(FailedCount) FailedCount, SUM(NotExecutedCount) NotExecutedCount
FROM RV_TestingCycleStatus
WHERE TestingCycleID = ${testingCycleID|3|Testing Cycle ID}
GROUP BY TesterLogin, TesterExecutionName
ORDER BY TesterLogin
Die Abfrage wurde um Folgendes erweitert:
  • GROUP BY TesterLogin, TesterExecutionName um die übrigen Spalten zu bezeichnen.
  • SUM() zu den Zählern, um die Zahlen zusammenzufassen.
TesterLogin | TesterExecution Name | PassedCount | FailedCount | NotExecutedCount
 | No specific tester (Test Assets) | 0 | 0 | 1
admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 1 | 1
gmazzuchelli | gmazzuchelli (English|Oracle10g|IE8|Tomcat - Test Assets) | 0 | 1 | 1
jallen | jallen (German|Oracle11g|FF|Tomcat - Test Assets) | 1 | 1 | 0
smiller | smiller (German|SQL2008|IE8|IIS - Test Assets) | 1 | 1 | 0
Übergeordnetes Thema: Wie Sie Berichte mit dem Data-Mart erstellen


Status von Testsuitehierarchien

Das Problem

Es ist üblich, Testsuiten in einer hierarchischen Struktur unterzubringen, welche die verschiedene Testbereiche und Testzwecke abbildet. In einigen Fällen werden Sie zum Beispiel die gesamte Anzahl von bestandenen, fehlgeschlagenen und nicht ausgeführten Tests wissen möchten, um den Teststatus und somit die Qualität eines Testbereichs oder Testzwecks zu wissen.

Die Lösung

Verwenden Sie die Data-Mart Ansicht RV_ExecutionPlanStatusRollup um einen Bericht zu erstellen, der die Anzahl bestandener, fehlgeschlagener und nicht ausgeführter Tests für einen bestimmten Testsuite-Ordner auflistet, gruppiert nach Build.

SELECT BuildName, PassedCount, FailedCount, NotExecutedCount
FROM RV_ExecutionPlanStatusRollup
WHERE ExecutionFolderID = ${executionPlanID|43|Execution Plan ID}
Die Abfrage macht Folgendes:
  • Wählt BuildName und die Status-Anzahlen von der Ansicht RV_ExecutionPlanStatusRollup aus.
  • Bestimmt den Order der höchsten Ebene, von dem Sie den Status (ExecutionFolderID) haben wollen.
Das Ergebnis der SQL-Abfrage zeigt den Status der Testläufe in allen Testsuiten des ausgewählten Ordners an, aggregiert pro Build.
BuildName | PassedCount | FailedCount | NotExecutedCount
351 | 0 | 0 | 2
352 | 15 | 7 | 1
Sollten Sie an detaillierteren Informationen interessiert sein, beispielsweise an den Status-Anzahlen für jede Testsuite innerhalb einer ausgewählten Hierarchie, können Sie die Data-Mart Ansicht RV_ExecutionPlanStatusPerBuild verwenden:
SELECT eps.BuildName, eps.ExecutionPlanID, SUM(eps.PassedCount) PassedCount,
  SUM(eps.FailedCount) FailedCount, SUM(eps.NotExecutedCount) NotExecutedCount
FROM RV_ExecutionPlanStatusPerBuild eps
INNER JOIN TM_ExecTreePaths etp ON eps.ExecutionPlanID = etp.NodeID_pk_fk
WHERE etp.ParentNodeID_pk_fk = ${execFolderID|44|Execution Folder ID}
GROUP BY eps.ExecutionPlanID, eps.BuildOrderNumber, eps.BuildName
ORDER BY eps.BuildOrderNumber, eps.ExecutionPlanID
Die Abfrage macht Folgendes:
  • Verwendet die Ansicht RV_ExecutionPlanStatusPerBuild, um auf Testsuite-bezogenen Daten zuzugreifen (ExecutionPlanID und ExecutionPlanName). Die zuvor verwendete Ansicht RV_ExecutionPlanStatusRollup enthält voraggregierte Daten (zusammengezählte Daten), die zu diesem Zweck nicht geeignet sind, da Sie nicht nur die Ergebnisse für Testsuiten liefert, sondern auch für Ordner-Knoten.
  • Wählt alle Knoten eines bestimmten Ordners mittels JOIN der TM_ExecTreePath Tabelle aus, um die Hierarchieinformationen zu sammeln.
  • Bestimmt den Ordner der höchsten Ebene mit ExecutionFolderID. Da die Tabelle TM_ExecutionTreePaths auch eine Selbstreferenz für jede Testsuite enthält, können Sie diese Abfrage auch für ParentNodeID_pk_fk mit einer Testsuite-ID ausführen, was die Reihen einer bestimmten Testsuite zurückgeben würde.
  • Fügt ORDER BY BuildOrderNumber und ExecutionPlanID hinzu, um ein sauber geordnetes Ergebnis zu erhalten, beginnend mit dem ältesten Build und dessen Testsuiten.
Das Ergebnis der SQL-Abfrage liefert den Status der Testläufe in allen Testsuiten des ausgewählten Ordners.
BuildName | ExecutionPlanID | PassedCount | FailedCount | NotExecutedCount
351 | 2307 | 0 | 0 | 2
352 | 2184 | 11 | 2 | 0
352 | 2185 | 0 | 3 | 0
352 | 2186 | 2 | 1 | 0
352 | 2187 | 1 | 0 | 0
352 | 2191 | 0 | 1 | 0
352 | 2307 | 1 | 0 | 1
Übergeordnetes Thema: Wie Sie Berichte mit dem Data-Mart erstellen


Status einer Konfigurationssuite

Das Problem

Konfigurationssuiten ermöglichen Ihnen die gleichen Tests für mehrere Konfigurationen, zum Beispiel mehrere Browser oder Betriebssysteme, auszuführen. Um eine vernünftige Aussage über die Qualität und Zuverlässigkeit der zu testenden Anwendung machen zu können, werden Sie die Ergebnisse für jede individuelle Konfiguration verfolgen wollen.

Die Lösung

Verwenden Sie die Data-Mart Ansicht RV_ConfigurationSuiteStatus um einen Bericht zu erstellen, der die Anzahl bestandener, fehlgeschlagener und nicht ausgeführter Tests für jede Konfiguration pro Build zurückgibt.

SELECT BuildName, ConfigurationName, PassedCount, FailedCount, NotExecutedCount
FROM RV_ConfigurationSuiteStatus
WHERE ConfigurationSuiteID = ${configSuiteID|97|Configuration Suite ID}
ORDER BY BuildOrderNumber, ConfigurationName
Die Abfrage macht Folgendes:
  • Ruft die Status-Anzahlen pro Build von Testläufen von der Ansicht RV_ConfigurationSuiteStatus ab.
  • Beschränkt die Ergebnisse auf die Konfigurationssuite (ConfigurationSuiteID).
Das Ergebnis der SQL-Abfrage liefert den Status der Testläufe für jede Konfiguration.
BuildName | ConfigurationName | PassedCount | FailedCount | NotExecutedCount
350 | Chrome | 0 | 1 | 0
350 | Firefox | 0 | 1 | 0
350 | Internet Explorer | 0 | 1 | 0
351 | Chrome | 1 | 0 | 0
351 | Firefox | 1 | 0 | 0
351 | Internet Explorer | 0 | 1 | 0
352 | Chrome | 1 | 0 | 0
352 | Firefox | 1 | 0 | 0
352 | Internet Explorer | 1 | 0 | 0
In diesem Beispiel verwenden wir die ID der Konfigurationssuite, um alle Konfigurationen zu sammeln. Es ist auch möglich das Ergebnis auf bestimmte Builds zu beschränken. In diesem Fall müssten Sie BuildID,BuildName, oderBuildOrderNumber in der WHERE-Klausel einschließen.
Anmerkung: Die Ansicht RV_ConfigurationSuiteStatus enthält nur aggregierte Status-Anzahlen ohne testspezifische Daten. Um zusätzliche testspezifische Daten abzurufen, können Sie die Ansicht RV_LatestTestStatus verwenden.
Übergeordnetes Thema: Wie Sie Berichte mit dem Data-Mart erstellen


Fehlerdiagnose

  • Falsche oder Fehlende Daten
    Die aus Data-Mart Tabellen und Ansichten abgefragten Daten scheinen entweder falsch zu sein oder zu fehlen.
  • Der Data-Mart verlangsamt das System
    Der Data-Mart scheint eine negative Auswirkung auf die Systemleistung zu haben.
Übergeordnetes Thema: Der Berichts-Data-Mart


Falsche oder Fehlende Daten

Das Problem

Beim Abfragen von Daten aus einer Data-Mart Tabelle oder Ansicht sind die angegebenen Ergebnisse nicht aktuell oder sie fehlen.

Die Lösung

Die Data-Mart Tabellen und Ansichten werden regelmäßig im Hintergrund aber nicht in Echtzeit aktualisiert. Demzufolge kann es einige Sekunden bis Minuten dauern, bevor die Daten in die Data-Mart Tabellen geladen werden. Wenn das System unter schwerer Last läuft, wird die Leistung des Hintergrundprozess, der die Daten lädt, dadurch beeinflusst. Der Grund dafür ist, dass die anderen Prozesse eine höhere Priorität haben und den DataMartUpdater-Hintergrundjob temporär blockieren können. Führen Sie die Abfrage noch einmal aus, um die aktualisierten Daten abzufragen.

Wenn Sie als Systemadministrator eingeloggt sind, können Sie den aktuellsten Stand der Datenladeprozesse prüfen, indem Sie zu http://<server>:<port>/sctm/check/db navigieren und das Kontrollkästchen DM_TestStatus Table anhaken.

Anmerkung: Tests und die abhängigen Testläufe werden vom Data-Mart entfernt, wenn der Test gelöscht wird. Dies gilt auch für Tests, die durch die Bereinigung eines Testpakets gelöscht wurden.
Übergeordnetes Thema: Fehlerdiagnose


Der Data-Mart verlangsamt das System

Das Problem

Seit der Data-Mart ausgeführt wird, scheint die Gesamtleistung des Systems schlechter zu sein oder sich inkonsistent zu verhalten.

Die Lösung

Obwohl es nicht passieren sollte, ist es möglich den Data-Mart auszuschalten um zu prüfen, ob das Problem dadurch gelöst wird.
  1. Stoppen Sie den Anwendungsserver der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei TmAppServerHomeConf.xml mit einem Texteditor.Diese Datei befindet sich standardmäßig in C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\Conf\AppServer auf dem Anwendungsserver.
  3. Finden Sie den XML-Tag Config/DataMart/Enabled und stellen Sie den Wert auf false ein.
  4. Speichern und schließen Sie die XML-Datei.
  5. Starten Sie den Anwendungsserver neu.
Übergeordnetes Thema: Fehlerdiagnose


Referenz: Data-Mart Tabellen und Ansichten

Die folgenden Data-Mart Tabellen und Ansichten sind für die einfache und schnelle Berichterstellung verfügbar.

  • DM_TestStatus
    Die DM_TestStatus Tabelle ist der Grundlage für statusbezogene Ansichten.
  • Die Ansicht RV_TestStatusExtended
    Die RV_TestStatusExtended Ansicht liefert detaillierte Informationen zu einer bestimmten Testausführung.
  • Die Ansicht RV_LatestTestStatus
    Die RV_LatestTestStatus Ansicht liefert Statusinformationen und erweiterte Informationen zu dem aktuellsten Testlauf eines Tests im Rahmen einer Testsuite und eines bestimmten Builds.
  • Die Ansicht RV_MaxTestRunID
    Die RV_MaxTestRunID Ansicht ist ein Helfer um die aktuellste Testlauf-ID für jeden Test, jede Testsuite und jede Build-Kombination abzurufen.
  • RV_TestingCycleStatus
    Die RV_TestingCycleStatus Ansicht liefert Status-Informationen zu Testzyklen.
  • RV_ExecutionPlanStatusPerBuild
    Die RV_ExecutionPlanStatusPerBuild Ansicht ruft die aktuellsten Summen der Teststatus für jede Testsuite im Rahmen eines Builds ab.
  • RV_ExecutionPlanStatusRollup
    Die RV_ExecutionPlanStatusRollup Ansicht ruft die Summen von bestehenden, fehlgeschlagenen und nicht ausgeführten Tests pro Testsuite oder im Rahmen eines Builds ab.
  • RV_ConfigurationSuiteStatus
    Die RV_ConfigurationSuiteStatus Ansicht listet die Status-Anzahlen aller Konfigurationssuiten und Konfigurationen pro Build auf.
Übergeordnetes Thema: Der Berichts-Data-Mart


DM_TestStatus

Die DM_TestStatus Tabelle ist der Grundlage für statusbezogene Ansichten.

Die anderen Data-Mart Ansichten ermöglichen normalerweise einen einfacheren Zugriff auf detaillierten Daten, da diese Tabelle keinen direkten Zugriff auf Informationen wie den Namen eines Tests ermöglicht. Der Schlüssel dieser Tabelle ist die Kombination der Spalten TestID, ExecutionPlanID, BuildID, und TestRunID.

Reihe | Beschreibung
TestID | Die Kennung des Tests.
ExecutionPlanID | Die Kennung der Testsuite.
BuildID | Die Kennung des Builds.
TestRunID | Die Kennung des Testlaufs.
ExecutionRunID | Identifiziert den Ausführungslauf, in dem dieses Ergebnis generiert wurde.
StatusID | Der Status dieses Testlaufs (siehe TM_TestDefStatusNames).
ReasonID | Die Ursache für den Status dieses Testlaufs (siehe TM_ResultStatusReasons). Kann "null" sein.
PassedCount | Die Summe aller bestandenen Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
FailedCount | Die Summe aller fehlgeschlagenen Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
NotExecutedCount | Die Summe aller nicht ausgeführten Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
ProjectID | Die ID des Projekts, zu dem diese Reihe gehört.
TestStartTime | Der Zeitpunkt, zu dem der Testlauf gestartet wurde (UTC).
ExecutionStartTime | Der Zeitpunkt, zu dem der Ausführungslauf gestartet wurde (UTC).
TestDurationInMilliseconds | Die Dauer des Testlaufs in Millisekunden.
IsBlocked | Kennzeichnet den Testlauf als blockiert oder nicht blockiert
DbChangedAt | Der Zeitpunkt, zu dem diese Reihe zuletzt durch den Berichts-Data-Mart aktualisiert wurde.
Übergeordnetes Thema: Referenz: Data-Mart Tabellen und Ansichten


Die Ansicht RV_TestStatusExtended

Die RV_TestStatusExtended Ansicht liefert detaillierte Informationen zu einer bestimmten Testausführung.

Diese Ansicht liefert Informationen zu allen Testläufen, im Gegensatz zur Ansicht RV_LatestTestStatus, welche Statusinformationen und erweiterte Informationen zu dem aktuellsten Testlauf eines Tests im Rahmen einer Testsuite und eines bestimmten Builds liefert. Sie können diese Ansicht verwenden, um zum Beispiel einen Bericht, der jeden Testlauf von markierten Builds auflistet, zu erstellen. Der Schlüssel dieser Tabelle ist die Kombination der Spalten TestID, ExecutionPlanID, BuildID und TestRunID.

Anmerkung: Tests und die abhängigen Testläufe werden vom Data-Mart entfernt, wenn der Test gelöscht wird. Dies gilt auch für Tests, die durch die Bereinigung eines Testpakets gelöscht wurden.
Reihe | Beschreibung
TestID | Die Kennung des Tests.
ExecutionPlanID | Die Kennung der Testsuite.
BuildID | Die Kennung des Builds.
TestRunID | Die Kennung des Testlaufs.
ExecutionRunID | Identifiziert den Ausführungslauf, in dem dieses Ergebnis generiert wurde.
StatusID | Der Status dieses Testlaufs (siehe TM_TestDefStatusNames).
ReasonID | Die Ursache für den Status dieses Testlaufs (siehe TM_ResultStatusReasons). Kann "null" sein.
PassedCount | Die Summe aller bestandenen Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
FailedCount | Die Summe aller fehlgeschlagenen Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
NotExecutedCount | Die Summe aller nicht ausgeführten Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
ProjectID | Die ID des Projekts, zu dem diese Reihe gehört.
TestStartTime | Der Zeitpunkt, zu dem der Testlauf gestartet wurde (UTC).
ExecutionStartTime | Der Zeitpunkt, zu dem der Ausführungslauf gestartet wurde (UTC).
TestDurationInMilliseconds | Die Dauer des Testlaufs in Millisekunden.
IsBlocked | Kennzeichnet den Testlauf als blockiert oder nicht blockiert
DbChangedAt | Der Zeitpunkt, zu dem diese Reihe zuletzt durch den Berichts-Data-Mart aktualisiert wurde.
TestName | Der Name des Tests.
TestDescription | Die Beschreibung des Tests.
TestParentID | Die ID des übergeordneten Tests.
PlannedTimeInMinutes | Geplante Dauer dieses Tests in Minuten.
Reason | Name der Ursache. Kann Ursachen beinhalten, welche in der Zwischenzeit gelöscht wurden.
ExecutionPlanName | Der Name der Testsuite.
ExecutionPlanDescription | Die Beschreibung der Testsuite.
ExecutionParentFolderID | Die ID der übergeordneten Testsuite.
Priority | Die Priorität der Testsuite: 0 = Niedrig, 1 = Mittel, 2 = Hoch.
BuildName | Der Name des Builds, der für diesen Testlauf verwendet wurde.
BuildDescription | Die Beschreibung des Builds.
BuildOrderNumber | Die Reihenfolge des Builds.
BuildIsTagged | 1 wenn der Build markiert ist, 0 wenn nicht.
VersionID | Die ID der Version, zu der der Build gehört.
VersionName | Der Name der Version.
VersionDescription | Die Beschreibung der Version.
VersionOrderNumber | Die Reihenfolge der Version.
ProductID | Die ID des Produkts, zu dem der Build gehört.
ProductCode | Der Name des Produkts.
ProductDescription | Die Beschreibung des Produkts.
ProductOrderNumber | Die Reihenfolge des Produkts.
Übergeordnetes Thema: Referenz: Data-Mart Tabellen und Ansichten


Die Ansicht RV_LatestTestStatus

Die RV_LatestTestStatus Ansicht liefert Statusinformationen und erweiterte Informationen zu dem aktuellsten Testlauf eines Tests im Rahmen einer Testsuite und eines bestimmten Builds.

Benutzen Sie die Ansicht RV_TestStatusExtended, um Informationen über alle Testläufe abzufragen. Sie können diese Ansicht verwenden, um einen Bericht, der alle fehlgeschlagenen Tests in einem Ausführungsordner auflistet zu erstellen. Der Schlüssel dieser Tabelle ist die Kombination der Spalten TestID, ExecutionPlanID, BuildID, und TestRunID.

Reihe | Beschreibung
TestID | Die Kennung des Tests.
ExecutionPlanID | Die Kennung der Testsuite.
BuildID | Die Kennung des Builds.
TestRunID | Die Kennung des Testlaufs.
ExecutionRunID | Identifiziert den Ausführungslauf, in dem dieses Ergebnis generiert wurde.
StatusID | Der Status dieses Testlaufs (siehe TM_TestDefStatusNames).
ReasonID | Die Ursache für den Status dieses Testlaufs (siehe TM_ResultStatusReasons). Kann "null" sein.
PassedCount | Die Summe aller bestandenen Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
FailedCount | Die Summe aller fehlgeschlagenen Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
NotExecutedCount | Die Summe aller nicht ausgeführten Tests, die 0 oder 1 für allgemeine Tests ist und für Stammknoten von Testpaketen höher sein kann.
ProjectID | Die ID des Projekts, zu dem diese Reihe gehört.
TestStartTime | Der Zeitpunkt, zu dem der Testlauf gestartet wurde (UTC).
ExecutionStartTime | Der Zeitpunkt, zu dem der Ausführungslauf gestartet wurde (UTC).
TestDurationInMilliseconds | Die Dauer des Testlaufs in Millisekunden.
IsBlocked | Kennzeichnet den Testlauf als blockiert oder nicht blockiert
DbChangedAt | Der Zeitpunkt, zu dem diese Reihe zuletzt durch den Berichts-Data-Mart aktualisiert wurde.
TestName | Der Name des Tests.
TestDescription | Die Beschreibung des Tests.
TestParentID | Die ID des übergeordneten Tests.
PlannedTimeInMinutes | Geplante Dauer dieses Tests in Minuten.
Reason | Name der Ursache. Kann Ursachen beinhalten, welche in der Zwischenzeit gelöscht wurden.
ExecutionPlanName | Der Name der Testsuite.
ExecutionPlanDescription | Die Beschreibung der Testsuite.
ExecutionParentFolderID | Die ID der übergeordneten Testsuite.
Priority | Die Priorität der Testsuite: 0 = Niedrig, 1 = Mittel, 2 = Hoch.
BuildName | Der Name des Builds, der für diesen Testlauf verwendet wurde.
BuildDescription | Die Beschreibung des Builds.
BuildOrderNumber | Die Reihenfolge des Builds.
BuildIsTagged | 1 wenn der Build markiert ist, 0 wenn nicht.
VersionID | Die ID der Version, zu der der Build gehört.
VersionName | Der Name der Version.
VersionDescription | Die Beschreibung der Version.
VersionOrderNumber | Die Reihenfolge der Version.
ProductID | Die ID des Produkts, zu dem der Build gehört.
ProductCode | Der Name des Produkts.
ProductDescription | Die Beschreibung des Produkts.
ProductOrderNumber | Die Reihenfolge des Produkts.
Übergeordnetes Thema: Referenz: Data-Mart Tabellen und Ansichten


Die Ansicht RV_MaxTestRunID

Die RV_MaxTestRunID Ansicht ist ein Helfer um die aktuellste Testlauf-ID für jeden Test, jede Testsuite und jede Build-Kombination abzurufen.

Der Schlüssel dieser Tabelle ist die Kombination der Spalten TestID, ExecutionPlanID und BuildID.

Reihe | Beschreibung
TestID | Die Kennung des Tests.
ExecutionPlanID | Die Kennung der Testsuite.
BuildID | Die Kennung des Builds.
MaxTestRunID | Identifiziert den aktuellsten Testlauf des Tests im Kontext des Ausführungsplans und des Builds.
Übergeordnetes Thema: Referenz: Data-Mart Tabellen und Ansichten


RV_TestingCycleStatus

Die RV_TestingCycleStatus Ansicht liefert Status-Informationen zu Testzyklen.

Sie können diese Ansicht verwenden um einen Bericht, der den aktuellen Status eines Testzyklus zeigt zu erstellen.

TestingCycleID bezeichnet den Testzyklus und TesterExecutionID (sowie TesterExecutionName, UserID, CapacityInCycle, TesterLogin, TesterFirstName, TesterLastName) und wird verwendet, den zugeordneten Tester im Testzyklus zu identifizieren. Für Tests die keinem Tester zugeordnet, sind UserID, CapacityInCycle, TesterLogin, TesterFirstName, und TesterLastName null. Der Schlüssel dieser Tabelle ist die Kombination der Spalten TesterExecutionID und BuildID.

Reihe | Beschreibung
TestingCycleID | Die Kennung des Testzyklus.
TesterExecutionID | Identifiziert die Gruppe von Tests, die einem Tester zugeordnet sind.
TesterExecutionName | Der generierte Name der Gruppe von Tests, die einem Tester zugeordnet sind.
UserID | Die User-ID des Testers.
CapacityInCycleInMinutes | Die Kapazität für diesen Benutzer in diesem Testzyklus in Minuten.
TesterLogin | Der Loginname des Testers.
TesterFirstName | Der Vorname des Testers
TesterLastName | Der Nachname des Testers
PassedCount | Die Summe aller bestandenen Tests.
FailedCount | Die Summe aller fehlgeschlagenen Tests.
NotExecutedCount | Die Summe aller nicht ausgeführten Tests.
ProjectID | Die Kennung des Projekts.
BuildID | Die Kennung des Builds.
BuildName | Der Name des Builds, der für diesen Testlauf verwendet wurde.
BuildDescription | Die Beschreibung des Builds.
BuildOrderNumber | Die Reihenfolge des Builds.
BuildIsTagged | 1 wenn der Build markiert ist, 0 wenn nicht.
VersionID | Die ID der Version, zu der der Build gehört.
VersionName | Der Name der Version.
VersionDescription | Die Beschreibung der Version.
VersionOrderNumber | Die Reihenfolge der Version.
ProductID | Die ID des Produkts, zu dem der Build gehört.
ProductCode | Der Name des Produkts.
ProductDescription | Die Beschreibung des Produkts.
ProductOrderNumber | Die Reihenfolge des Produkts.
Übergeordnetes Thema: Referenz: Data-Mart Tabellen und Ansichten


RV_ExecutionPlanStatusPerBuild

Die RV_ExecutionPlanStatusPerBuild Ansicht ruft die aktuellsten Summen der Teststatus für jede Testsuite im Rahmen eines Builds ab.

Ordner und untergeordnete Knoten werden nicht berücksichtigt. Sie können diese Ansicht benutzen, um einen Bericht, der den Status Ihrer Testläufe für jede Testsuite in einem Ordner zeigt zu erstellen. Im Gegensatz zu RV_ExecutionPlanStatusRollup, hat diese Ansicht einen leichten Leistungsvorteil, da keine Hierarchie berücksichtigt wird um die Daten abzurufen. Der Schlüssel dieser Tabelle ist die Kombination der Spalten ExecutionPlanID und BuildID.

Reihe | Beschreibung
ExecutionPlanID | Die Kennung der Testsuite.
BuildID | Die Kennung des Builds.
ExecutionPlanName | Der Name der Testsuite.
ExecutionParentFolderID | Die ID der übergeordneten Testsuite.
PassedCount | Die Summe aller bestandenen Tests.
FailedCount | Die Summe aller fehlgeschlagenen Tests.
NotExecutedCount | Die Summe aller nicht ausgeführten Tests.
ProjectID | Die ID des Projekts, zu dem die Testsuite gehört.
BuildName | Der Name des Builds, der für diesen Testlauf verwendet wurde.
BuildDescription | Die Beschreibung des Builds.
BuildOrderNumber | Die Reihenfolge des Builds.
BuildIsTagged | 1 wenn der Build markiert ist, 0 wenn nicht.
VersionID | Die ID der Version, zu der der Build gehört.
VersionName | Der Name der Version.
VersionDescription | Die Beschreibung der Version.
VersionOrderNumber | Die Reihenfolge der Version.
ProductID | Die ID des Produkts, zu dem der Build gehört.
ProductCode | Der Name des Produkts.
ProductDescription | Die Beschreibung des Produkts.
ProductOrderNumber | Die Reihenfolge des Produkts.
Übergeordnetes Thema: Referenz: Data-Mart Tabellen und Ansichten


RV_ExecutionPlanStatusRollup

Die RV_ExecutionPlanStatusRollup Ansicht ruft die Summen von bestehenden, fehlgeschlagenen und nicht ausgeführten Tests pro Testsuite oder im Rahmen eines Builds ab.

Wenn es sich um Ordner handelt, enthalten die Zähler die Zahlen von allen Tests, auch in untergeordneten Ordnern. Sie können diese Ansicht benutzen, um einen Bericht, der den Status aller Testläufe in einem Ordner zeigt zu erstellen. Der Schlüssel dieser Tabelle ist die Kombination der Spalten ExecutionFolderID und BuildID.

Reihe | Beschreibung
ExecutionFolderID | Die Kennung der Testsuite.
BuildID | Die Kennung des Build.
PassedCount | Die Summe aller bestandenen Tests.
FailedCount | Die Summe aller fehlgeschlagenen Tests.
NotExecutedCount | Die Summe aller nicht ausgeführten Tests.
ProjectID | Die ID des Projekts, zu dem die Testsuite gehört.
BuildName | Der Name des Builds, der für diesen Testlauf verwendet wurde.
BuildDescription | Die Beschreibung des Builds.
BuildOrderNumber | Die Reihenfolge des Builds.
BuildIsTagged | 1 wenn der Build markiert ist, 0 wenn nicht.
VersionID | Die ID der Version, zu der der Build gehört.
VersionName | Der Name der Version.
VersionDescription | Die Beschreibung der Version.
VersionOrderNumber | Die Reihenfolge der Version.
ProductID | Die ID des Produkts, zu dem der Build gehört.
ProductCode | Der Name des Produkts.
ProductDescription | Die Beschreibung des Produkts.
ProductOrderNumber | Die Reihenfolge des Produkts.
Übergeordnetes Thema: Referenz: Data-Mart Tabellen und Ansichten


RV_ConfigurationSuiteStatus

Die RV_ConfigurationSuiteStatus Ansicht listet die Status-Anzahlen aller Konfigurationssuiten und Konfigurationen pro Build auf.

Sie können diese Ansicht benutzen, um einen Bericht, der den Status aller Testläufe für jede Konfiguration in einer Konfigurationssuite zeigt zu erstellen. Der Schlüssel dieser Tabelle ist die Kombination der Spalten ConfigurationID und BuildID.

Reihe | Beschreibung
ConfigurationSuiteID | Die Kennung der Konfigurationssuite.
ConfigurationID | Die Kennung der Konfiguration.
ConfigurationName | Der Name der Konfiguration.
BuildID | Die Kennung des Builds.
PassedCount | Die Summe aller bestandenen Tests.
FailedCount | Die Summe aller fehlgeschlagenen Tests.
NotExecutedCount | Die Summe aller nicht ausgeführten Tests.
ProjectID | Die ID des Projekts, zu dem diese Reihe gehört.
BuildName | Der Name des Builds, der für diesen Testlauf verwendet wurde.
BuildDescription | Die Beschreibung des Builds.
BuildOrderNumber | Die Reihenfolge des Builds.
BuildIsTagged | 1 wenn der Build markiert ist, 0 wenn nicht.
VersionID | Die ID der Version, zu der der Build gehört.
VersionName | Der Name der Version.
VersionDescription | Die Beschreibung der Version.
VersionOrderNumber | Die Reihenfolge der Version.
ProductID | Die ID des Produkts, zu dem der Build gehört.
ProductCode | Der Name des Produkts.
ProductDescription | Die Beschreibung des Produkts.
ProductOrderNumber | Die Reihenfolge des Produkts.
Übergeordnetes Thema: Referenz: Data-Mart Tabellen und Ansichten


Berichtsbereich

  • Übersicht
    Hier finden Sie einen Überblick über die Konzepte der Silk Central Berichte.
  • Erstellen und Anpassen von Berichten
    Hier wird beschrieben, wie Sie Berichte erstellen und an Ihre Bedürfnisse anpassen können.
  • Anzeigen von Berichten
    Generieren Sie einen Bericht, um ihn anzuzeigen.
  • Speichern von Berichten
    Speichern Sie einen Bericht.
  • Berichte mit Lesezeichen versehen
    Versehen Sie einen Bericht mit Lesezeichen, damit Benutzer den Bericht mit einem Klicken anzeigen können.
  • Anzeigen eines Berichts im PDF-Format
    Zeigen Sie einen Bericht im PDF-Format an.
  • Zugreifen auf zuletzt angezeigte Berichte
    Greifen Sie auf einen zuletzt angezeigten Bericht zu.
  • Berichtssymbolleiste
    Die Symbolleiste Berichte enthält wichtige Befehle für die Verwaltung von Berichten.
  • Berichtseigenschaften
    Hier wird die Arbeit mit Berichtseigenschaften beschrieben.
  • Berichtsparameter
    Hier wird die Arbeit mit Berichtsparametern beschrieben.
  • Daten (Seite)
    Hier wird eine schreibgeschützte tabellarische Vorschau der Ergebnisparameter und Werte des ausgewählten Berichts angezeigt.
  • Bericht (Seite)
    Hier werden Daten als formatierter Bericht angezeigt.
  • Projektübersichtsbericht
    Dieser Bericht bietet eine Übersicht über den Status des ausgewählten Projekts.
Übergeordnetes Thema: Berichte


Übersicht

Die Standardberichte in Silk Central sind in allen Projekten sichtbar und werden in der Hierarchie Berichte unter Globale Berichte aufgeführt. Diese Berichte können nicht bearbeitet werden, aber Sie können von einem Bericht eine Kopie anlegen, welche Sie beliebig anpassen können. Wenn Sie benutzerdefinierte Berichte innerhalb der Hierarchie Globale Berichte anlegen, sind diese Berichte ebenfalls für alle Projekte verfügbar. Sie können Berichte auch zwischen den Projekthierarchien und der Hierarchie Globale Berichte hin und her kopieren. Das Konzept globaler Berichte ermöglicht Ihnen eine flexible Verwaltung von Berichten über sämtliche Projekte in Silk Central hinweg.

Einschränkungen:
  • Da globale Berichte nicht im Kontext eines Projektes sind, müssen sie erweiterte Berichte sein (SQL).
  • Globale Berichte können keine Unterberichte von Projektberichten sein, und Unterberichte sind bei den globalen Berichten nicht verfügbar.

Berechtigungen für gemeinsam verwendbare globale Berichte

Da gemeinsam verwendbare globale Berichte in allen Projekten und für alle Benutzer verwendbar sind, benötigen Benutzerrollen mit den Rechten solche Berichte zu ändern oder zu löschen spezielle Berechtigungen: Gemeinsam verwendbare globale Berichte verwalten und Gemeinsam verwendbare globale Berichte löschen. Diese Berechtigungen gelten auch für Berichtsvorlagen die in gemeinsam verwendbaren globalen Berichten verwendet werden. Globale Berichte und Berichtsvorlagen, die anderen Benutzern nicht zur Verfügung stehen, können von Benutzerrollen mit den Standardberechtigungen für das Verwalten von Berichten bearbeitet und gelöscht werden. Dadurch ergeben sich folgende Spezialfälle:
  • Besitzt ein Benutzer nicht die Berechtigung Gemeinsam verwendbare globale Berichte verwalten, so ist das Kontrollkästchen Diesen Bericht anderen Benutzern zur Verfügung stellen in globalen Berichten und Ordnern deaktiviert.
  • Wenn ein gemeinsam verwendbarer Bericht kopiert und in die Hierarchie Globale Berichte eingefügt wird, ohne dass der Benutzer die Berechtigung Gemeinsam verwendbare globale Berichte verwalten besitzt, wird der Bericht auf nicht-gemeinsam-verwendbar umgestellt.
Übergeordnetes Thema: Berichtsbereich


Erstellen und Anpassen von Berichten

  • Erstellen von Berichten
    In diesem Abschnitt wird beschrieben, wie Berichte in Silk Central erstellt werden.
  • Arbeiten mit Unterberichten
    Hier wird die Arbeit mit Unterberichten beschrieben.
  • Berichtsvorlagen
    Hier wird die Arbeit mit Berichtsvorlagen beschrieben.
  • Berichtsabonnements
    Hier wird die Arbeit mit Berichtsabonnements beschrieben.
  • Arbeiten mit Diagrammen
    Beschreibt die Verwendung von Diagrammen in Berichten.
  • Anpassen von Berichten
    Hier wird beschrieben, wie Silk Central-Berichte angepasst werden.
Übergeordnetes Thema: Berichtsbereich


Erstellen von Berichten

Mit den Berichten von Silk Central können Daten schnell und einfach in aussagekräftige Diagramme und Graphen umgewandelt werden. Für die Bereiche Anforderungen, Tests und Fehler stehen vorinstallierte Berichte zur Verfügung.

Berichte werden entweder mit BIRT Report Designer, einem Open-Source-Berichtstool basierend auf Eclipse, Microsoft Word oder Microsoft Excel-Berichtsvorlagen erstellt. Silk Central arbeitet eng mit BIRT Report Designer zusammen, damit Sie leichter Berichte über Testdaten erstellen können. Die Berichtsfunktionalität von Silk Central ist hochgradig konfigurierbar. Das Programm verfügt über zahlreiche vorinstallierte Berichte und Berichtsvorlagen, die eine breite Palette von Anwendungen abdecken. Sie können über eine intuitive Benutzeroberfläche die vorinstallierten Berichte bearbeiten und eigene Berichte erstellen. Benutzern mit SQL-Kenntnissen stehen praktisch unbegrenzte Möglichkeiten zur Datenabfrage und -darstellung in angepassten Berichten zur Verfügung.

Tipp: Wenn ein leerer Bericht erzeugt wird, befinden sich möglicherweise keine Daten im ausgewählten Projekt oder es besteht keine Verbindung mit der betreffenden Silk Central-Datenbank. Berichte stehen nur offline zur Verfügung, wenn auf die Silk Central-Datenbank lokal zugegriffen werden kann.
  • Erstellen neuer Berichte
    Erstellen Sie einen neuen Bericht.
  • SQL-Funktionen für benutzerdefinierte Berichte
    Hier werden die verfügbaren Funktionsplatzhalter aufgelistet.
  • Erstellen erweiterter Abfragen in SQL
    Schreiben Sie erweiterte Abfragen in SQL zur Berichterstellung.
Übergeordnetes Thema: Erstellen und Anpassen von Berichten


Erstellen neuer Berichte

So erstellen Sie einen neuen Bericht:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den Ordner für den neuen Bericht aus. Dadurch legen Sie fest, wo der Bericht in der Ordnerhierarchie gespeichert wird.
  3. Klicken Sie auf Neuer untergeordneter Bericht in der Symbolleiste. Der Dialog Neuen Bericht erstellen wird angezeigt.
  4. Geben Sie einen Namen für den neuen Bericht ein. Mit diesem Namen wird der Bericht in der Berichtshierarchie angezeigt.
  5. Aktivieren Sie das Kontrollkästchen Diesen Bericht anderen Benutzern zur Verfügung stellen, wenn der Bericht für andere Benutzer freigegeben werden soll.
  6. Geben Sie in das Feld Timeout [s] die Zeitspanne in Sekunden ein, die Silk Central maximal auf den Abschluss von SQL-Abfragen wartet.
  7. Wählen Sie in der Liste Standardregister die Registerkarte, auf die Sie geleitet werden möchten, wenn Sie diesen Bericht aus einer der Listen kontextbezogener Berichte auswählen.
  8. Wählen Sie den gewünschten Ergebnistyp in der Liste Ergebniskategorie aus. Damit legen Sie die Datenbanktabelle und die Ansicht fest, die für den Bericht gefiltert wird. Sie können zwischen den folgenden Ergebnistypen wählen:
    Ergebnistyp
    Beschreibung
    Anforderung
    Die den Abfragekriterien entsprechenden Anforderungen im Bereich Anforderungen werden zurückgegeben.
    Test
    Die den Abfragekriterien entsprechenden Tests im Bereich Tests werden zurückgegeben.
    Testausführung
    Die den Abfragekriterien entsprechenden Ergebnisse ausgeführter Tests werden im Bereich Testausführungen zurückgegeben.
    Testsuite
    Die Testsuiten aus dem Testausführungsbereich werden zurückgegeben.
    Fehler
    Die Fehler (einschließlich importierter Fehler) werden zurückgegeben.
    Anforderungsfortschritt nach Builds
    Der Anforderungsfortschritt pro Build wird zurückgegeben.
    Anforderungsfortschritt nach Tagen
    Der tägliche Anforderungsfortschritt wird zurückgegeben.
    Testfortschritt nach Builds
    Der Testfortschritt nach Builds wird zurückgegeben.
    Testfortschritt nach Tagen
    Der tägliche Testfortschritt wird zurückgegeben.

    Für jeden Ergebnistyp stehen eigene Auswahlkriterien zur Verfügung. Legen Sie die Auswahlkriterien für den ausgewählten Ergebnistyp fest. Durch diese Kriterien werden die Eigenschaften anhand einer Ansicht oder anderer Merkmale (z. B. benutzerdefinierte Eigenschaften) gruppiert.

  9. Klicken Sie in der Liste Eigenschaft auf die Eigenschaft, nach der gefiltert werden soll. Bei manchen Auswahlkriterien sind die Eigenschaften dynamisch.
  10. Wählen Sie den Operator für die Abfrage aus. Welche Operatoren verfügbar sind, hängt von der Eigenschaft ab. Mögliche Operatoren sind =, nicht, ähnlich wie, und nicht ähnlich wie. Strings werden immer in Kleinschreibung verglichen. In Strings können die Platzhalter "*" (Übereinstimmung mit beliebig vielen Zeichen) und "?" (Übereinstimmung mit genau einem Zeichen) verwendet werden.
  11. Wählen Sie den Wert, nach dem die Abfrage gefiltert werden soll, oder geben Sie ihn ein. Bei datumsbasierten Eigenschaften wird das Feld Wert durch einen Kalender ersetzt, aus dem Sie ein Datum auswählen können.
  12. Optional: Wenn Sie einen weiteren Abfragestring hinzufügen möchten, klicken Sie auf Hinzufügen. Um einen vorhandenen String zu löschen, klicken Sie auf dessen Schaltfläche Löschen. Wenn mehrere Abfragestrings definiert sind, werden neben der Schaltfläche Hinzufügen die Optionsfelder UND und ODER angezeigt. Sie können damit festlegen, ob beide Kriterien erfüllt werden müssen oder nur ein Kriterium.
  13. Klicken Sie auf Weiter, um die Berichtsspalten im Dialog Neuer Bericht zu konfigurieren.
  14. Klicken Sie auf Spalten hinzufügen. Im Dialog Spalten hinzufügen werden alle verfügbaren Berichtsspalten angezeigt.
  15. Wählen Sie die Spalten aus, die im Bericht enthalten sein sollen, und klicken Sie auf OK. Mit der Kombination Strg+Klick können Sie mehrere Spalten auswählen.
    Anmerkung: Bei Testplanungsberichten ist die Liste der verfügbaren Spaltennamen um die Namen der Spalten aus der Tabelle LQM_V_Tests erweitert.
    Die ausgewählten Spalten werden im Dialog Neuer Bericht im tabellarischen Format angezeigt.
  16. Optional: Sie können festlegen, wie die Spalten im Bericht angezeigt werden. Für jede Spalte kann mit dem Aufwärts- und Abwärtspfeil in der Spalte Sortieren eine Sortierreihenfolge (aufsteigend, absteigend oder nicht sortiert) angegeben werden.
  17. Wenn mehrere Spalten zur Sortierung ausgewählt sind, wird in der Spalte Sortierreihenfolge ein Listenfeld angezeigt, mit dem Sie die Reihenfolge einfach ändern können. Legen Sie die entsprechenden Nummern nach Bedarf fest.
  18. Geben Sie für jede Spalte einen Alias ein. Dieser Name wird für die Spalte im erzeugten Bericht angezeigt.
  19. Durch die Gruppierung können Sie die SQL-Aggregationsfunktionen verwenden (z. B. Auswählen einer Anzahl von Elementen oder Abfragen einer Gesamtsumme von Werten). Wenn die SQL-Gruppierungsfunktionen verwendet werden sollen, aktivieren Sie im Dialog zur Spaltenauswahl das Kontrollkästchen Gruppieren nach.
  20. Für die Spalten ohne aktivierte SQL-Gruppierungsfunktionen wird standardmäßig die Aggregation verwendet (d. h. es wird ein Aggregatwert berechnet). Wählen Sie in der Liste Aggregation den entsprechenden Aggregationstyp aus. Folgende Typen sind verfügbar:
    • Anzahl
    • Summe
    • Durchschnitt
    • Minimum
    • Maximum
  21. Über die Spalte Aktionen kann die Spaltenliste in der Ansicht nach oben oder unten verschoben oder eine Spalte gelöscht werden.
  22. Klicken Sie auf Fertig stellen, um die Berichtserstellung abzuschließen.
Übergeordnetes Thema: Erstellen von Berichten


SQL-Funktionen für benutzerdefinierte Berichte

Zur Unterstützung fortgeschrittener Abfragen sind Platzhalter für die verschiedenen Funktionen vorhanden. Die Funktionsplatzhalter werden bei der Ausführung durch die entsprechenden SQL-Anweisungen ersetzt. Funktionen werden wie Parameter verwendet, jedoch beginnen ihre Namen mit dem Dollarzeichen ($). Platzhalter sind im Gegensatz zu Parametern definierte Berichtselemente, die nicht für eine bestimmte Testausführung angepasst werden können.

Die verfügbaren Funktionsplatzhalter sind in der folgenden Tabelle zusammengefasst:

Funktion | Beschreibung | Beispiel
$TODAY | Diese Funktion gibt das aktuelle Systemdatum auf dem Datenbankserver zurück. Sie können auch $TODAY-1 für "Gestern" oder $TODAY-7 für "Vor einer Woche" schreiben. | CreatedAt > ${$TODAY}
$DATE(Spalte) | Diese Funktion gibt das Datum ohne Uhrzeit zurück. |
$DATE('String') | Diese Funktion konvertiert die übergebene Zeichenfolge in ein Datum im Datenbankformat. | CreatedAt > ${$DATE('01/10/2005')}
$DAYS[p1;p2] | Diese Funktion berechnet die Anzahl der Tage zwischen den beiden übergebenen Datumswerten. Als Parameter kann eine Spalte der Tabelle bzw. Ansicht oder $TODAY übergeben werden. | Im folgenden Beispiel werden die in der letzten Woche erstellten Zeilen zurückgegeben: ${$DAYS[CreatedAt;$TODAY]} < 7
$WEEK(Param) | Diese Funktion gibt die Wochennummer des übergebenen Parameters ($TODAY oder Spalte) zurück. |
$MONTH(Param) | Diese Funktion gibt den nummerischen Monatswert des übergebenen Parameters ($TODAY oder Spalte) zurück. |
$YEAR(Param) | Diese Funktion gibt das Jahr des übergebenen Parameters ($TODAY oder Spalte) zurück. |
$USERID | Diese Funktion gibt die ID des aktuell angemeldeten Benutzers zurück. |
$USERNAME | Diese Funktion gibt den Benutzernamen des aktuell angemeldeten Benutzers zurück. |
$PROJECTID | Diese Funktion gibt die ID des aktuell ausgewählten Projekts zurück. |
$PROJECTNAME | Diese Funktion gibt den Namen des aktuell ausgewählten Projekts zurück. |
$REPORTNAME | Diese Funktion gibt den Namen des aktuell ausgewählten Berichts zurück. |
$REPORTID | Diese Funktion gibt die ID des aktuell ausgewählten Berichts zurück. |

Nachfolgend finden Sie den Code des vorinstallierten Berichts Anforderungen mit untergeordneten Anforderungen. In diesem Bericht wird eine ausgewählte Anforderung mit ihrer Anforderungs-ID angezeigt. Alle Einzelheiten ihrer untergeordneten Anforderungen werden ebenfalls angezeigt. Dieser Bericht zeigt, wie auf die Funktion $PROJECTID zugegriffen werden kann. Es sind auch die beiden Parameter "reqID" (Anforderungs-ID) und "reqProp_Obsolete_0" (veraltete Anforderungen anzeigen) vorhanden.

SELECT r.ReqID, r.ReqCreated, r.ReqName, r.TreeOrder
   FROM RTM_V_Requirements r INNER JOIN
   TM_ReqTreePaths rtp ON (rtp.ReqNodeID_pk_fk = r.ReqID)
   WHERE rtp.ParentNodeID_pk_fk=${reqID|22322|Requirement ID} AND
   r.ProjectID = ${$PROJECTID} AND
   r.MarkedAsObsolete=${reqProp_Obsolete_0|0|Show obsolete Requirements}
   ORDER BY r.TreeOrder ASC
Übergeordnetes Thema: Erstellen von Berichten


Erstellen erweiterter Abfragen in SQL

Erweiterte Berichte können manuell mit SQL-Anweisungen erstellt werden. Praktisch jede Berichtsfunktion kann mit SQL-Anweisungen ausgeführt werden. Voraussetzung ist allerdings, dass Sie das Datenbankschema kennen. Wenn Sie auf Erweiterte Abfrage klicken, werden die Listenfelder für die Abfragezeichenfolge ausgeblendet. Stattdessen wird das Feld Berichtsdatenabfrage geöffnet, in das Sie vorhandenen Code eingeben oder neuen SQL-Code schreiben können.
Einschränkung: Die SQL-Abfrage select top wird nicht unterstützt:

Sie können auch zunächst einen Abfragestring mit den unter Erstellen neuer Berichte genannten Listenfeldern erstellen. Wenn die Berichtskriterien gültig sind, wird die entsprechende SQL-Anweisung erzeugt und angezeigt, und dann können manuelle Änderungen im erweiterten Modus vorgenommen werden.

Anmerkung: Wenn Sie vom erweiterten Modus zurück in den Einfach-Modus wechseln, gehen die Änderungen am Code verloren.

So erstellen Sie eine erweiterte Abfrage in SQL:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den Ordner für den neuen Bericht aus. Dadurch legen Sie fest, wo der Bericht in der Ordnerhierarchie gespeichert wird.
  3. Klicken Sie auf Neuer untergeordneter Bericht in der Symbolleiste. Der Dialog Neuen Bericht erstellen wird angezeigt.
  4. Geben Sie einen Namen für den neuen Bericht ein. Mit diesem Namen wird der Bericht in der Berichtshierarchie angezeigt.
  5. Aktivieren Sie das Kontrollkästchen Diesen Bericht anderen Benutzern zur Verfügung stellen, wenn der Bericht für andere Benutzer freigegeben werden soll.
  6. Geben Sie im Feld Beschreibung eine Beschreibung des Berichts ein.
  7. Klicken Sie auf Erweiterte Abfrage, um das Feld Berichtsdatenabfrage zu öffnen. Fügen Sie vorhandenen Code ein, oder schreiben Sie neuen Code direkt in das Feld. Die Liste Platzhalter einfügen unterstützt Sie bei der Bearbeitung der SQL-Abfragen mit vordefinierten Funktionsplatzhaltern. Weitere Informationen finden Sie unter SQL-Funktionen für benutzerdefinierte Berichte.
    Anmerkung: Nach der manuellen Bearbeitung von SQL-Anweisungen für die Abfrage sollte deren Gültigkeit mit SQL überprüfen geprüft werden.
  8. Klicken Sie auf Fertig stellen, um die Änderungen zu speichern.
Übergeordnetes Thema: Erstellen von Berichten
Zugehörige Konzepte
SQL-Funktionen für benutzerdefinierte Berichte
Zugehörige Tasks
Erstellen neuer Berichte


Arbeiten mit Unterberichten

  • Hinzufügen von Unterberichten
    Sie können mit Hilfe von Unterberichten im aktuell ausgewählten Bericht die Ergebnisse mehrerer Berichte zusammenfassen.
  • Löschen von Unterberichten
    Löschen Sie einen Unterbericht aus einem Bericht, wenn die Berichte des Unterberichts nicht mehr im Bericht aggregiert werden sollen.
Übergeordnetes Thema: Erstellen und Anpassen von Berichten


Hinzufügen von Unterberichten

Sie können mit Hilfe von Unterberichten im aktuell ausgewählten Bericht die Ergebnisse mehrerer Berichte zusammenfassen. Wenn Sie einen Bericht als Unterbericht hinzufügen, werden die Ergebniszeilen und -spalten des Unterberichts an die Ergebnisse des ausgewählten Berichts angefügt.

So fügen Sie einen Bericht als Unterbericht hinzu:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie auf Unterbericht hinzufügen. Der Dialog Unterbericht hinzufügen wird angezeigt.
  5. Wählen Sie in der Berichtshierarchie den Unterbericht, den Sie an den aktuellen Bericht anhängen möchten.
  6. Klicken Sie auf OK, um die Änderung zu übernehmen. Unterberichte werden auf der Seite Eigenschaften des entsprechenden Berichts im Abschnitt Unterberichte angezeigt.
Übergeordnetes Thema: Arbeiten mit Unterberichten


Löschen von Unterberichten

So löschen Sie einen Unterbericht:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den Bericht mit dem zu löschenden Unterbericht aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie in der Spalte Aktionen des Unterberichts, den Sie löschen möchten, auf Löschen.
  5. Klicken Sie im Bestätigungsdialogfeld auf Ja, um die Löschung zu bestätigen.
Übergeordnetes Thema: Arbeiten mit Unterberichten


Berichtsvorlagen

Berichtsvorlagen definieren, wie die Daten eines Berichts dargestellt werden. Weitere Informationen über das Verwalten von Berichtsvorlagen finden Sie unter Verwalten von Berichtsvorlagen.

Da gemeinsam verwendbare globale Berichte in allen Projekten und für alle Benutzer verwendbar sind, benötigen Benutzerrollen mit den Rechten solche Berichte zu ändern oder zu löschen spezielle Berechtigungen: Gemeinsam verwendbare globale Berichte verwalten und Gemeinsam verwendbare globale Berichte löschen. Diese Berechtigungen gelten auch für Berichtsvorlagen die in gemeinsam verwendbaren globalen Berichten verwendet werden. Globale Berichte und Berichtsvorlagen, die anderen Benutzern nicht zur Verfügung stehen, können von Benutzerrollen mit den Standardberechtigungen für das Verwalten von Berichten bearbeitet und gelöscht werden.

  • Auswählen oder Hochladen von Berichtsvorlagen
    Wenn Sie auf dem lokalen System eine Berichtsvorlage erstellt haben, können Sie die Vorlage nach Silk Central hochladen.
  • Herunterladen von Berichtsvorlagen
    Laden Sie eine Berichtsvorlage herunter, um die Daten von Berichten in einem Format darzustellen, das Ihren Anforderungen entspricht.
  • Entfernen von Berichtvorlagen
    Hiermit wird die aktuelle Berichtvorlage gelöscht.
Übergeordnetes Thema: Erstellen und Anpassen von Berichten


Auswählen oder Hochladen von Berichtsvorlagen

So wählen Sie eine Vorlage aus oder laden Sie eine Vorlage von Ihrem lokalen System hoch:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie den Bericht aus, dem Sie die Vorlage zuordnen möchten.
  3. Klicken Sie auf die Registerkarte Bericht.
  4. Um eine Vorlage hochzuladen, klicken Sie auf den Link Hier klicken, um eine neue Berichtsvorlage hochzuladen, um den Dialog Berichtsvorlage hochladen zu öffnen.
    1. Geben Sie einen aussagekräftigen Namen und eine Beschreibung für die Vorlage ein.
    2. Wählen Sie im Feld Projekte das Projekt aus, dem Sie die Vorlage zuordnen möchten. Wenn Sie die Vorlage allen Projekten zuordnen möchten, wählen Sie Alle Projekte aus.
    3. Klicken Sie auf Durchsuchen, um die Vorlage auf dem lokalen System zu suchen.
    4. Klicken Sie auf OK, um die Vorlage hochzuladen.
  5. Um eine bestehende Vorlage auszuwählen, klicken Sie auf den Link Hier klicken, um eine Berichtsvorlage auszuwählen, um den Dialog Berichtsvorlage auswählen zu öffnen.
    1. Wählen Sie aus der Liste eine Vorlage aus, die geeignet ist die Daten des ausgewählten Berichts richtig darzustellen.
    2. Klicken Sie auf OK, um die Vorlage zu verwenden.
Übergeordnetes Thema: Berichtsvorlagen
Zugehörige Tasks
Herunterladen von Berichtsvorlagen


Herunterladen von Berichtsvorlagen

Mit den Silk Central-Berichtsvorlagen können die Berichtsdaten in verschiedenen Formaten ausgegeben werden. Als Vorlagen können Word-Dokumente, Excel-Arbeitsblätter, Berichtsvorlagen von BIRT Report Designer, XML-Dateien oder CSV-Dateien verwendet werden. Wenn Sie Silk Central-Berichtsvorlagen auf Ihr lokales System herunterladen, können Sie sie im BIRT Report Designer oder in Microsoft Excel oder Word bearbeiten. Nach der Bearbeitung eines heruntergeladenen Berichts können Sie ihn für anderen Benutzer wieder hochladen. Einzelheiten dazu finden Sie in der Anleitung Hochladen von Berichtsvorlagen.

So laden Sie eine vorhandene Berichtsvorlage zur Bearbeitung herunter:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie einen Bericht mit der Vorlage aus, die Sie ändern möchten.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie auf den Link der gewünschten Vorlage. Folgende Links stehen zur Verfügung:
    Leere BIRT-Berichtsvorlage erzeugen
    Sie erhalten die Berichtsdaten in Form einer generischen BIRT-Berichtsvorlage (leer). Die Datenquelle wurde bereits konfiguriert.
    .XLS/.XLSX-Berichtsvorlage erzeugen
    Sie erhalten eine Excel-Datei mit einem Arbeitsblatt, das die Daten enthält. In weiteren Arbeitsblättern können Sie zusätzliche Informationen hinzufügen, zum Beispiel Diagramme.
    Beispiel Word-Berichtsvorlage herunterladen
    Sie erhalten eine Word docx-Datei, die Sie für die Erstellung eines benutzerdefinierten Word-Berichts verwenden können. Die Word-Datei enthält Beispiele für die persönliche Anpassung der Vorlage, um die von Ihnen benötigten Daten dem Bericht hinzuzufügen.
    Berichtsdaten als .CSV-Datei herunterladen
    Sie erhalten die Berichtsdaten als CSV-Datei. Das Trennzeichen (, oder ;) ist von den Einstellungen Ihres Systems abhängig. Dies gilt auch für das Datumsformat.
    Berichtsdaten als .XML-Datei herunterladen
    Sie erhalten die Berichtsdaten im XML-Format. Dieses Format bietet den Vorteil, dass alle Daten in Unterberichten erhalten bleiben (beim CSV-Format ist dies nicht der Fall). Zugreifen auf Daten außerhalb von Silk Central – Sie können eine bestimmte URL für den Zugriff auf die Berichtsdaten eingeben. Verwenden Sie dazu das folgende Format:
    http://server/servicesExchange?hid=reportData&userName=<username>
&passWord=<password>&reportFilterID=<ID of the report>&type=<csv|xml>
&projectID=<ID of the project>
    .
  5. Der Dialog Dateidownload wird angezeigt. Klicken Sie auf Speichern, und laden Sie die Berichtsdatei je nach ausgewähltem Berichtstyp als .rptdesign-, docx-, xlsx- oder .xls-Datei auf Ihr lokales System herunter.
  6. Ändern Sie den Bericht wie gewünscht im BIRT Report Designer (für rptdesign-Dateien), in Word (für docx-Dateien) oder in Excel (für xls/xlsx-Dateien).
Übergeordnetes Thema: Berichtsvorlagen
Zugehörige Tasks
Auswählen oder Hochladen von Berichtsvorlagen


Entfernen von Berichtvorlagen

So entfernen Sie die Vorlage des aktuellen Berichts:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Hierarchie Berichte den Bericht, aus dem Sie eine Vorlage löschen möchten.
  3. Klicken Sie auf die Registerkarte Bericht.
  4. Klicken Sie auf Remove Report Template.
  5. Klicken Sie im folgenden Bestätigungs-Dialogfeld auf Yes.
Übergeordnetes Thema: Berichtsvorlagen


Berichtsabonnements

Berichte können auf der Registerkarte Abonnements im Bereich Berichte abonniert werden. Sie können konfigurieren wie, wo und wann Sie Berichte erhalten und die Berichts-Parameter verändern. Der Bericht wird im Hintergrund auf dem Anwendungsserver erstellt, basierend auf dem ausgewählten Ausführungstermin. Der Abonnent bekommt den Bericht per E-Mail zugeschickt oder er kann auf dem Dashboard angezeigt werden und ist auch von externen Seiten über eine URL zugänglich.

  • Verwalten von Berichtsabonnements
    Hier wird beschrieben, wie Berichtsabonnements verwaltet werden und wie Berichte abonniert werden.
  • Hinzufügen eines Berichts zu einem Dashboard-Panel
    Hier wird beschrieben, wie ein neuer Bericht erstellt und einem Dashboard-Panel hinzugefügt wird.
Übergeordnetes Thema: Erstellen und Anpassen von Berichten


Verwalten von Berichtsabonnements

Bitte beachten Sie Folgendes wenn Sie mit Abonnements arbeiten:
  • Wird der Benutzer gelöscht, der den Bericht erstellt hat, so wird der Ausführungstermin für den Bericht ebenfalls gelöscht, was den Bericht deaktiviert. Ein anderer Benutzer muss das Abonnement bearbeiten, um es wieder zu aktivieren.
  • Abonnements werden nicht mit kopiert, wenn Sie ein Projekt kopieren oder eine Projekt-Baseline generieren.
  • Abonnements werden nicht exportiert, wenn Sie ein Projekt exportieren.
  • Nachdem ein Abonnement erstellt wurde, können Sie es mit den entsprechenden Symbolen in der Spalte Aktionen bearbeiten oder löschen.
  • Für Berichte, welche für Dashboard-Panel und externen Zugriff konfiguriert sind, werden immer nur die zuletzt generierten Ergebnisse gespeichert und es gibt keine Historie.
  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Abonnements.
  4. Klicken Sie auf Abonnement hinzufügen. Der Dialog Abonnement bearbeiten wird geöffnet.
  5. Geben Sie dem Abonnement im Feld Name einen Namen.
  6. Klicken Sie auf Parameter bearbeiten, um die Parameter des Abonnements zu ändern. Der Dialog Parameter bearbeiten wird geöffnet. Ändern Sie den Wert, und klicken Sie auf OK.
  7. Wählen Sie einen Ausführungstermin aus der Liste Ausführungstermin aus. Ist der gewünschte Ausführungstermin nicht vorhanden, können Sie diesen erstellen. Sie können auch keinen Ausführungstermin auswählen, z.B. für Abonnements die nur aufgrund von Testausführungsergebnissen ausgelöst werden.
  8. Wählen sie im Bereich Ergebnisverarbeitung eine der folgenden Optionen:
    • Wenn Sie den Bericht als E-Mail versenden möchten, klicken Sie auf Als E-Mail versenden und wählen Sie das Format: Berichtsvorlage (Excel, BIRT), PDF (Datenansicht) oder XLSX (Datentabelle). Welche Optionen zur Verfügung stehen hängt davon ab, welche Vorlagen bereits konfiguriert wurden. Geben Sie dann die E-Mail-Adressen ein, an welche der Bericht gesendet werden soll. Sie können den Bericht an mehrere E-Mail-Adressen senden, indem Sie diese durch Kommas, Semikolons oder Leerzeichen trennen.
    • Wenn Sie den Bericht für ein Dashboard-Panel oder den Zugriff von externen Seiten verfügbar machen wollen, klicken sie auf Für Dashboard und externen Zugriff zur Verfügung stellen. Haben Sie diese Option ausgewählt, so ist der Bericht im Dashboard-Panel Berichts-Abonnement verfügbar, und Sie können den angezeigten Link in Webseiten, E-Mails, usw. einbinden. Dieser Link ist permanent, ändert sich nie, und benötigt weder Anmeldeinformationen noch eine Lizenz um angeizeigt zu werden. Beachten Sie bitte, dass bei der Verwendung von Vorlagen nur BIRT-Vorlagen grafisch dargestellt werden. Andere Vorlagen werden als Datentabelle dargestellt.
  9. Klicken Sie auf OK. Das neue Abonnement wird in der Liste Abonnements aufgeführt.
Um alle Berichtsabonnements zu verwalten, wählen Sie den Knoten Globale Berichte oder den Stammknoten des Projekts aus. Verwenden Sie die Symbole in der Spalte Aktionen um Berichtsabonnements zu bearbeiten oder zu löschen. Da gemeinsam verwendbare globale Berichte in allen Projekten und für alle Benutzer verwendbar sind, benötigen Benutzerrollen mit den Rechten solche Berichte zu ändern oder zu löschen spezielle Berechtigungen: Gemeinsam verwendbare globale Berichte verwalten und Gemeinsam verwendbare globale Berichte löschen. Diese Berechtigungen gelten auch für Berichtsvorlagen die in gemeinsam verwendbaren globalen Berichten verwendet werden. Globale Berichte und Berichtsvorlagen, die anderen Benutzern nicht zur Verfügung stehen, können von Benutzerrollen mit den Standardberechtigungen für das Verwalten von Berichten bearbeitet und gelöscht werden.

Beispiel: Einbindung des Links für externen Zugriff in einem IFrame

<html>
...
<body>
...
<iframe src="http://<front-end server>:19120/servicesExchange?hid=reportOutput&linkId=ec36a037-a59a-4899-a98c-5a4a4644811f"
 width="700" height="500"></iframe>
...
</body>
</html>
Übergeordnetes Thema: Berichtsabonnements
Zugehörige Verweise
Ausführungstermin (Seite)
Eigenschaften von Testsuiten (Seite)


Arbeiten mit Diagrammen

  • Anzeigen von Diagrammen
    Hier wird beschrieben, wie Diagramme angezeigt werden.
  • Drucken von Diagrammen
    Drucken Sie Diagramme.
  • Entfernen von Diagrammen
    Hier wird die aktuelle Diagrammvorlage aus dem gewählten Bericht entfernt.
  • Diagramm (Seite)
    Hier können Diagramme und Graphen zur Datenanalyse erstellt werden.
Übergeordnetes Thema: Erstellen und Anpassen von Berichten


Anzeigen von Diagrammen

So zeigen Sie ein Diagramm an:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Diagramm mit dem Standarddiagramm.
  4. Klicken Sie zum Auswählen eines anderen Diagrammtyps auf Diagrammtyp auswählen. Das Dialogfeld Diagrammtyp auswählen wird angezeigt.
  5. Wählen Sie aus der Liste Diagrammtyp einen Diagrammtyp aus.
  6. Aktivieren Sie die Anzeigeeigenschaften, die auf das Diagramm angewendet werden sollen:
    • 3D-Ansicht
    • Horizontale Rasterlinien anzeigen
    • Vertikale Rasterlinien anzeigen
    • Legende anzeigen
  7. Legen Sie fest, wie diese Diagrammeinstellungen gespeichert werden sollen:
    • Klicken Sie auf die Optionsschaltfläche Nur für den aktuellen Benutzer, wenn diese Diagrammeinstellungen die Standardeinstellungen für den aktuellen Benutzer überschreiben sollen.
    • Klicken Sie auf die Optionsschaltfläche Als Berichtsstandard, wenn die Diagrammeinstellungen für alle Benutzer verwendet werden sollen, die keine überschreibenden Einstellungen festgelegt haben. Diese Option wirkt sich nicht auf die Einstellungen einzelner Benutzer aus.
  8. Klicken Sie auf OK, um den neuen Diagrammtyp anzuzeigen.
    Anmerkung: Die hier festgelegten Diagrammeinstellungen werden als Standard für diesen Bericht verwendet. Wenn Sie mit den Standarddiagrammen und -graphen nicht die gewünschten Informationen erhalten, können Sie die Darstellung der abgefragten Daten mit den Berichtsfunktionen von Silk Central anpassen. Sie können das aktuelle Diagramm in einem eigenen Browserfenster öffnen, indem Sie oben auf der Seite Diagramm auf In neuem Fenster öffnen klicken.
Übergeordnetes Thema: Arbeiten mit Diagrammen


Drucken von Diagrammen

So drucken Sie das aktuelle Diagramm:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Diagramm.
  4. Klicken Sie auf Drucken. Die Diagrammdaten werden in einem neuen Fenster in einem druckbaren Format angezeigt. Außerdem wird das Druck-Dialogfeld des Betriebssystems geöffnet.
  5. Legen Sie die gewünschten Druckeinstellungen fest und klicken Sie auf OK, um das Diagramm zu drucken.
Übergeordnetes Thema: Arbeiten mit Diagrammen


Entfernen von Diagrammen

Beim Entfernen von Diagrammen wird lediglich die aktuell ausgewählte Diagrammvorlage aus dem ausgewählten Bericht entfernt. Die Diagrammvorlage wird nicht vollständig entfernt.

So entfernen Sie die aktuelle Diagrammvorlage aus dem ausgewählten Bericht.

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Diagramm.
  4. Klicken Sie auf Diagrammtyp entfernen. Das Dialogfeld Diagramm entfernen wird geöffnet.
  5. Wählen Sie eine der folgenden Optionen:
    • Wählen Sie Benutzereinstellungen entfernen (und schalten Sie auf den Standardbericht zurück), um die aktuellen Diagrammeinstellungen des Benutzers mit dem Diagramm zu löschen. Das Diagramm wird jetzt entsprechend der Standardeinstellungen des Berichts angezeigt. Wenn keine Standardeinstellungen festgelegt wurden, kann das Diagramm nicht angezeigt werden.
      Anmerkung: Diese Option steht nur zur Verfügung, wenn der aktuelle Benutzer besondere Diagrammeinstellungen festgelegt hat.
    • Wählen Sie im gewünschten Bericht Standarddiagrammeinstellungen entfernen, um eventuelle Standardeinstellungen mit dem Diagramm zu löschen. Benutzerspezifische Einstellungen werden von dieser Funktion nicht gelöscht.
      Anmerkung: Diese Option steht nur dann zur Verfügung, wenn für den Bericht Standarddiagrammeinstellungen festgelegt wurden.
  6. Klicken Sie auf OK, um die Diagrammvorlage zu löschen. Sie können gegebenenfalls den Link Zum Auswählen eines Diagrammtyps hier klicken anklicken, um dem ausgewählten Bericht eine neue Diagrammvorlage zuzuordnen.
Übergeordnetes Thema: Arbeiten mit Diagrammen


Diagramm (Seite)

Berichte > Detailansicht > Diagramm

Auf der Seite Diagramm können Diagramme und Graphen zur Datenanalyse erstellt werden. Auf dieser Seite werden aus den von der ausgewählten Berichtsabfrage abgerufenen Daten Standarddiagramme und -graphen erstellt. Dazu wird die interne Berichtsfunktion von Silk Central verwendet.

Folgende Standarddiagrammtypen sind verfügbar:
  • Flächendiagramm
  • Balkendiagramm
  • Horizontal gestapeltes Balkendiagramm
  • Liniendiagramm
  • Kreisdiagramm
  • Gestapeltes Balkendiagramm
Übergeordnetes Thema: Arbeiten mit Diagrammen


Anpassen von Berichten

  • Anpassen von BIRT-Berichtsvorlagen
    Verwenden Sie BIRT Report Designer zum Erstellen von benutzerdefinierten Berichtsvorlagen.
  • Anpassen der Word-Berichtvorlage
    Hier wird beschrieben, wie die Word-Berichtvorlage heruntergeladen und angepasst wird.
Übergeordnetes Thema: Erstellen und Anpassen von Berichten


Anpassen von BIRT-Berichtsvorlagen

Mit BIRT Report Designer (BIRT) können Sie vorinstallierte Berichtsvorlagen von Silk Central konfigurieren und benutzerdefinierte Berichtsvorlagen erstellen. Details zur Verwendung von BIRT finden Sie in den Themen zur Verwaltung in diesem Hilfesystem und der BIRT Report Designer-Dokumentation.

So laden Sie eine vorhandene Vorlage zur Bearbeitung herunter:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie einen Bericht aus, der die BIRT-Berichtsvorlage verwendet.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie auf Leere BIRT-Berichtsvorlage erzeugen. Sie erhalten die Berichtsdaten in Form einer generischen BIRT-Berichtsvorlage (leer). Die Datenquelle wurde bereits konfiguriert.
  5. Nehmen Sie die gewünschten Änderungen vor, nachdem Sie die Vorlage lokal gespeichert haben. Weitere Informationen zum Konfigurieren einer BIRT-Berichtsvorlage finden Sie in den Themen zur Verwaltung in diesem Hilfesystem.
  6. Wenn Sie die geänderte Berichtsvorlage hochladen möchten, klicken Sie im Menü auf Verwaltung > Berichtsvorlagen und anschließend auf Hochladen.
Übergeordnetes Thema: Anpassen von Berichten
Zugehörige Konzepte
Verwalten von benutzerdefinierten Berichtsvorlagen mit BIRT


Anpassen der Word-Berichtvorlage

Verwenden Sie die Word-Berichtvorlage, um einen benutzerdefinierten Bericht zu erstellen, der Ihren Anforderungen entspricht.

So laden Sie eine vorhandene Vorlage zur Bearbeitung herunter:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie einen Bericht aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie auf den Link Beispiel Word-Berichtsvorlage herunterladen. Verwenden Sie Ihren Browser, um die Datei auf dem lokalen System zu speichern.
  5. Verwenden Sie die verfügbaren Ergebnisspalten Ihres Berichts, um diesen über die in der Word-Berichtsvorlage enthaltenen Befehle wie gewünscht anzupassen.
  6. Wenn Sie die geänderte Berichtsvorlage hochladen möchten, klicken Sie im Menü auf Verwaltung > Berichtsvorlagen und anschließend auf Hochladen.
  • Word-Berichtsvorlage
    Beschreibt, wie Sie die Word-Berichtsvorlage sowie einen vollständig angepassten Beispielbericht bearbeiten.
Übergeordnetes Thema: Anpassen von Berichten


Word-Berichtsvorlage

Über die Vorlage

Verwenden Sie die Word-Berichtsvorlage, um einen angepassten Bericht zu erstellen. Die Vorlage verwendet Word-Merge-Felder, um erforderliche Daten abzurufen. Die Vorlage ist für docx-Dateien entworfen und unterstützt doc nicht. Einige Tipps für die ersten Schritte:
  • Um Merge-Felder in ein Microsoft Word-Dokument einzufügen, klicken Sie auf Insert > Quick Parts > Field > MergeField, oder drücken Sie Strg+F9.
  • Um ein Merge-Feld zu bearbeiten, klicken Sie mit der rechten Maustaste und wählen Sie dann Feld bearbeiten.
  • Sie können abgesehen von Merge-Feldern auch Standardtext in Ihrem Bericht verwenden und mischen.
  • Merge-Felder nehmen folgende Form an: « value ».

Allgemeine Berichtsinformationen

Das folgende Beispiel enthält Daten, die Sie im Kopfbereich Ihres Berichts verwenden können:

Feld | Beschreibung
${report.name} | Der Name des Berichts.
${report.projectName} | Der Name des Projekts, in dem der Bericht ausgeführt wird.
${report.description} | Die Beschreibung des Berichts.
${report.executedBy} | Der Anmeldename des Benutzers, der den Bericht ausgeführt hat.
${report.generatedOn} | Das Datum und die Uhrzeit, wann der Bericht ausgeführt wurde.
${report.generatedOnWeek} | Die Nummer der Woche, in der der Bericht ausgeführt wurde.

Zugreifen auf Daten

Die folgenden Abschnitte beschreiben, wie Sie auf die verschiedenen Daten für Ihren Bericht zugreifen und diese anzeigen.

Nach Index
«${rows[0].cols[3]}»
Nach Name
«${rows[0].ReqName}»
In Listen
Ein typischer Anwendungsfall wäre, durch alle Zeilen zu gehen und die Spalteninformationen für jede Zeile anzuzeigen. So erhalten Sie eine Datenliste:
«[#list rows as r]»
«${r.TestDefID}» - «${r.TestName}»
«[/#list]»

Der Anfang der Schleife wird definiert durch [#list rows as r] und das Ende durch [/#list]. Die Zeilendaten innerhalb der Schleifen werden mit r referenziert, wodurch Sie Test Name innerhalb der Schleife durch Referenzierung mit ${r.TestName} erhalten.

Das oben stehende Beispiel würde durch alle Zeilen gehen, und der ausgegebene Bericht würde eine Liste von Tests mit ID und Namen enthalten.

In Tabellen
Das Definieren von Anfang und Ende einer Schleife innerhalb einer Tabelle erfordert einen zusätzlichen Befehl zur Fortsetzung der Iteration innerhalb der Tabelle. Sie müssen zuerst den Befehl list für die Schleife in die erste Spalte Ihrer Tabelle eingeben und @before-row voranstellen. Sie müssen @after-row verwenden, um die Liste abzuschließen. Die folgende Tabelle zeigt, was Sie hierfür tun müssen.
«${headers[3]}»|«${headers[3].@name}» | «${headers[4]}»|«${headers[4].@name}»
«@before-row[#list rows as r]»«${r.ReqName}»«@after-row[/#list]» | «${r.ReqDescription.@html}»
Kopfzeilen und HTML
  • Auf Kopfzeilen von Daten können Sie über ein Merge-Feld namens headers zugreifen.
  • Kopfzeilen können auf verschiedene Weisen durch Anhängen von .@elementName oder .@name oder .@index angezeigt werden.
  • Einige Silk Central-Daten, wie z. B. viele Felder Beschreibung, werden als HTML gespeichert. Wenn Sie Ihre HTML-kodierten Texte basierend auf den Tags anzeigen möchten, hängen Sie das Attribut .@html an. Wenn Sie dieses Attribut nicht hinzufügen, sehen Sie dennoch den Text, aber er enthält das HTML-Markup. Beispiel: Wenn Ihre Quelldaten <b>Meine Berichtsbeschreibung</b> sind und Sie .@html verwenden, sehen Sie Meine Berichtsbeschreibung. Ansonsten sehen Sie: <b>Meine Berichtsbeschreibung</b>. Folgende HTML-Tags werden unterstützt: <b>, <strong>, <i>, <u>, <br>, <p>, and <a>.
Unterberichte
Auf Unterberichte können Sie mit dem Schlüsselwort sub zugreifen. Hängen Sie die Nummer des Unterberichts, auf den Sie zugreifen möchten, hinten an, z.B. sub1,sub2, etc.
Beispiel: Wenn ProjectID in der ersten Spalte Ihres Hauptberichts ist, greifen Sie darauf mit «${rows[0].ProjectID}» zu. Wenn TestID in der ersten Spalte des ersten Unterberichts ist, greifen Sie darauf mit «${sub1.rows[0].TestID}». So gehen Sie durch alle Zeilen des ersten Unterberichts und zeigen die Spalte TestID sowie die zweite Spalte an:
«[#list sub1.rows as sr]»
  «${sr.TestID}» «${sr.cols[1]}»
«[/#list]»

Fehlerdiagnose

Warum zeigt mein Bericht falsche Daten?
Referenzieren Sie Spalten anhand des Index? Wenn ja, bedenken Sie, dass die erste Spalte durch den Index 0 und nicht 1 referenziert wird.
Warum erhalte ich eine Fehlermeldung für ein bestimmtes Feld, wenn ich meinen Bericht herunterlade? Ich sehe dieses Feld nicht in meiner Vorlage.

Sie haben möglicherweise die Bezeichnung eines Feldes geändert, aber die Mail-Merge-Referenz weist noch immer den ursprünglichen Wert auf. Sie erhalten z. B. eine Fehlermeldung, dass das Feld ${r.requirementName} nicht existiert. In Ihrem Dokument sehen Sie das Feld ${r.reqName}. Wenn Sie mit der rechten Maustaste auf das Feld klicken und Feld bearbeiten auswählen, sehen Sie, dass die Referenz immer noch ${r.requirementName} lautet. Vergessen Sie nicht, die Mail-Merge-Felder über Feld bearbeiten zu ändern.

Beispielbericht

Der folgende Beispiel-Word-Bericht zeigt einen Bericht mit manuellen Tests, der Schritte enthält.

Anmerkung: Sie können dieses Beispiel nicht im aktuellen Zustand kopieren und einfügen. Es soll Ihnen verschiedene Arten der Verwendung von Berichtscodes für die verschiedenen Abschnitte in einem Bericht zeigen. Das unten angezeigte Beispiel ist in den Berichtsvorlagen als ManualTestResults.docx enthalten.
Report generated: «${report.generatedOn}» «${report.generatedOnWeek}»
«${report.name}»

Project Name          «${report.projectName}»
Report Description    «${report.description}»
Report Executed By    «${report.executedBy}»

«[#list rows as r]»«[#assign firstRow=(r_index==0 || rows[r_index-1].ManualTestDefID != r.ManualTestDefID)]»«[#if firstRow]»

«${r.TestDefinitionName}»
«${r.TestDefinitionDescription.@html}»

Status: «${r.StatusName}»

Planned Time [hh:mm]: «[#if r.PlannedTime!="null"]»«${r.PlannedTime}»«[#else]»00:00«[/#if]»
Used Time [hh:mm]: «[#if r.UsedTime!="null"]»«${r.UsedTime}»«[#else]»00:00«[/#if]»
Build: «${r.BuildName}»
Version: «${r.VersionName}»
Execution Plan: «${r.ExecDefName}»
Changed By: «${r.ChangedBy.@text}»
Changed On: «${r.ChangedAt.@text}»

«[/#if]»«[#if r.StepName != "null"]»«[#if firstRow]» Test Step Details:«[/#if]»
Step Name: «${r.StepName}»
Description: «${r.StepDescr.@html}»
Status: «${r.StepStatus}»
Result Info: «${r.StepResultInfo.@html}»
Expected Result: «${r.ExpectedResult.@html}»
«[/#if]»«[/#list]»
Übergeordnetes Thema: Anpassen der Word-Berichtvorlage


Anzeigen von Berichten

Für jede Vorlage wird ein bestimmtes Datenformat benötigt, damit sie brauchbare Informationen liefert. Daher sind nicht alle Vorlagen für sämtliche Berichtsabfragen geeignet. Wenn Sie versuchen, einen Bericht mit einer ungeeigneten Berichtsvorlage zu erzeugen, wird eine Fehlermeldung angezeigt. Sie können beispielsweise die Vorlage Vier Werte pro Zeile als Horizontalbalken für den Bericht Anforderungsstatusübersicht verwenden, da diese Microsoft Excel-Vorlage genau die vier Werte erfordert (Fehlgeschlagen, Bestanden, Nicht ausgeführt und Nicht abgedeckt), die von der Berichtsabfrage geliefert werden.

So erzeugen Sie einen Bericht:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Bericht.
  4. Klicken Sie auf den Link <Hier klicken, um eine Berichtsvorlage auszuwählen>. Der Dialog Berichtsvorlage auswählen wird angezeigt.
  5. Wählen Sie die gewünschte Vorlage aus.
  6. Klicken Sie auf OK, um den Bericht anzuzeigen.
Übergeordnetes Thema: Berichtsbereich


Speichern von Berichten

Wie ein Bericht lokal gespeichert wird, hängt davon ab, ob eine BIRT-Berichtsvorlage oder eine Excel- oder Word-Vorlage ausgewählt wurde. Bei einer Excel-Vorlage klicken Sie einfach im ausgewählten Bericht auf der Seite Eigenschaften auf den Link Excel-Berichtsvorlage herunterladen. Microsoft Excel wird daraufhin auf dem lokalen Computer gestartet, und der Bericht wird automatisch geladen. In Word klicken Sie auf Beispiel Word-Berichtsvorlage herunterladen.

Wenn Sie eine BIRT-Berichtsvorlage ausgewählt haben, gehen Sie zum Speichern des Berichts wie folgt vor.

So exportieren Sie den BIRT-Bericht im PDF-Format:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den Bericht aus, den Sie speichern möchten.
  3. Klicken Sie auf die Registerkarte Bericht.
  4. Klicken Sie in der Symbolleiste der Berichtsansicht auf Als PDF-Dokument anzeigen.
  5. Klicken Sie im Dialog Dateidownload auf Speichern, und speichern Sie das PDF-Dokument im gewünschten Verzeichnis.
Übergeordnetes Thema: Berichtsbereich


Berichte mit Lesezeichen versehen

Mit der Schaltfläche Lesezeichen können Sie den aktuell angezeigten Bericht sowie alle Parameter, die Sie auf der Seite Parameter definiert haben, mit einem Lesezeichen versehen. Sie können Lesezeichen-URLs an andere Benutzer Silk Centralsenden, wodurch diese sich mit nur einem Klick Berichte anzeigen lassen können.

Die Lesezeichen-URL enthält auch die Parameter, denen die Zeichenfolge rp_ vorangestellt ist. Datumswerte werden in der URL in Form entsprechender Long-Werte in UTC-Notation dargestellt.

Übergeordnetes Thema: Berichtsbereich


Anzeigen eines Berichts im PDF-Format

So zeigen Sie den aktuellen Bericht in der Berichtsansicht im PDF-Format an:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Bericht.
  4. Klicken Sie in der Symbolleiste der Berichtsansicht auf Als PDF-Dokument anzeigen. Der Bericht wird im PDF-Format angezeigt.
Übergeordnetes Thema: Berichtsbereich


Zugreifen auf zuletzt angezeigte Berichte

So wählen Sie einen zuletzt angezeigten Bericht:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Erweitern Sie in der Symbolleiste Berichte das Listenfeld Zuletzt verwendete Berichte.
  3. Wählen Sie den Bericht, den Sie anzeigen möchten.
Übergeordnetes Thema: Berichtsbereich


Berichtssymbolleiste

Silk Central > Berichte

Die Symbolleiste Berichte enthält wichtige Befehle für die Verwaltung von Berichten. Die Symbolleiste enthält die folgenden Elemente:

Element | Symbol | Beschreibung
Neuer untergeordneter Ordner | Neuer untergeordneter Ordner | Ermöglicht die Erstellung neuer Berichtsordner. Klicken Sie auf Neuer untergeordneter Ordner, um einen Namen und eine optionale Beschreibung für einen neuen Ordner zu definieren. Der neue Ordner wird als untergeordnetes Element des in der Berichtshierarchie aktuell ausgewählten Knotens angezeigt.
Neuer untergeordneter Bericht | Neuer untergeordneter Bericht | Ermöglicht die Erstellung neuer Berichte. Klicken Sie auf Neuer untergeordneter Bericht, um mithilfe des Dialogs Neuen Bericht erstellen einen neuen Bericht zu erstellen. Der neue Bericht wird als untergeordnetes Element des in der Berichtshierarchie aktuell ausgewählten Knotens angezeigt.
Bearbeiten | Bearbeiten | Bearbeiten Sie einen Bericht.
Löschen | Löschen | Löschen Sie einen Bericht.
Ausschneiden | Ausschneiden | Schneiden Sie einen Bericht aus, und fügen Sie in die Zwischenablage ein.
Kopieren | Kopieren | Kopieren Sie einen Bericht in die Zwischenablage.
Einfügen | Einfügen | Fügen Sie einen Bericht aus der Zwischenablage in die Berichtshierarchie ein.
Als untergeordnetes Element einfügen | Als untergeordnetes Element einfügen | Fügen Sie einen Bericht aus der Zwischenablage als Unterknoten des ausgewählten Knotens in die Berichtshierarchie ein.
Nach oben | Nach oben | Berichte in der Berichtshierarchie nach oben verschieben.
Nach unten | Nach unten | Berichte in der Berichtshierarchie nach unten verschieben.
Zuletzt verwendete Berichte |  | Liste der zuletzt angezeigten Berichte in absteigend nach Datum und Uhrzeit sortierter Reihenfolge. Wählen Sie in dieser Liste einen Berichtsnamen aus, um zu dem betreffenden Bericht zu navigieren. Jedes Mal, wenn ein Bericht geöffnet wird (durch Klicken auf Daten, Diagramm oder die Registerkarte Bericht), wird der betreffende Bericht am Anfang des Listenfeldes hinzugefügt. Wenn dagegen die zu einem Bericht gehörige Registerkarte Eigenschaften oder Parameter geöffnet wird, wird der Bericht der Liste Zuletzt verwendete Berichte nicht hinzugefügt. Die Liste Zuletzt verwendete Berichte ist bei neuen Benutzern oder Benutzern, die noch keinen Bericht erzeugt haben, leer. Der Administrator kann die Anzahl der in dieser Liste enthaltenen Berichte festlegen. Weitere Informationen finden Sie in den Verwaltungs-Themen in dieser Hilfe.
Übergeordnetes Thema: Berichtsbereich


Berichtseigenschaften

  • Bearbeiten von Berichtseigenschaften
    Bearbeiten Sie die Eigenschaften eines Berichts.
  • Berichtseigenschaften (Seite)
    Hier werden die grundlegenden Eigenschaften des ausgewählten Berichts angezeigt.
Übergeordnetes Thema: Berichtsbereich


Bearbeiten von Berichtseigenschaften

So bearbeiten Sie die Eigenschaften eines Berichts:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Klicken Sie auf die Registerkarte Eigenschaften.
  4. Klicken Sie auf Bearbeiten. Der Dialog Bericht bearbeiten wird angezeigt.
  5. Ändern Sie ggf. den Namen, die Beschreibung und Timeout [s] des Berichts.
  6. Aktivieren Sie das Kontrollkästchen Diesen Bericht anderen Benutzern zur Verfügung stellen, wenn der Bericht für andere Benutzer freigegeben werden soll.
  7. Wählen Sie in der Liste Standardregister die Registerkarte, auf die Sie geleitet werden möchten, wenn Sie diesen Bericht aus einer der Listen kontextbezogener Berichte auswählen.
  8. Sie können den Bericht auf zwei verschiedene Arten bearbeiten:
    • Einen einfachen Bericht erstellen: Generieren Sie SQL-Abfragen mithilfe der Listen Auswahlkriterien, Eigenschaft, Operator und Wert. Klicken Sie auf Mehr, um weitere Abfragestrings hinzuzufügen, und wählen Sie die Operatoren UND oder ODER aus, um die Abfragen miteinander zu kombinieren. Klicken Sie auf [image], um einen Abfragestring zu löschen.
    • Einen erweiterten Bericht erstellen: Wenn Sie mit SQL vertraut sind, können Sie den Abfragecode bearbeiten. Klicken Sie auf Erweiterte Abfrage, und ändern Sie den Abfragecode im Feld Berichtsdatenabfrage. Die Liste Platzhalter einfügen unterstützt Sie bei der Bearbeitung der SQL-Abfragen mit vordefinierten Funktionsplatzhaltern. Klicken Sie auf Einfach, um in den Einfach-Modus zu wechseln.
    Anmerkung: Nach der manuellen Bearbeitung von SQL-Anweisungen für die Abfrage sollte deren Gültigkeit mit SQL überprüfen geprüft werden.
  9. Klicken Sie auf Fertig stellen, um die Änderungen zu speichern.
Übergeordnetes Thema: Berichtseigenschaften


Berichtseigenschaften (Seite)

Berichte > Detailansicht > Eigenschaften

Auf der Seite Eigenschaften werden die Grundeigenschaften eines Berichts angezeigt. Hier können diese Eigenschaften oder die Berichtsvorlagen auch bearbeitet werden. Sie können Berichten auch Unterberichte hinzufügen.

Die Seite enthält folgende Elemente:

Elemente | Beschreibung
Berichtsname | Der Name des Berichts, der geändert werden kann.
Berichts-ID | Die systemdefinierte Kennung des Berichts.
Beschreibung | Eine Beschreibung des Berichts, die geändert werden kann.
Erstellt am | Das Datum, an dem der Bericht erstellt wurde. Standardberichte werden bei Erstellung einer Datenbank und der Verbindung mit dieser Datenbank erstellt.
Erstellt von | Der Name des Benutzers, der den Bericht erstellt hat. Standardberichte werden vom Benutzer Admin erstellt.
Geändert am | Das Datum, an dem der Bericht zuletzt geändert wurde.
Geändert Von | Der Name des Benutzers, von dem der Bericht zuletzt geändert wurde.
Renderer | Die aktuell zugewiesene Berichtsvorlage.
Standardregister | Die Registerkarte, die angezeigt wird, wenn Sie diesen Bericht in einer kontextbezogenen Berichtsliste auswählen.
Bearbeiten | Öffnet den Dialog Bericht bearbeiten.
Add Subreport | Fügt dem Bericht einen Unterbericht hinzu.
Berichtsvorlagen Folgende Berichtsvorlagen sind vorinstalliert:
Leere BIRT-Berichtsvorlage erzeugen
Sie erhalten die Berichtsdaten in Form einer generischen BIRT-Berichtsvorlage (leer). Die Datenquelle wurde bereits konfiguriert.
.XLS/.XLSX-Berichtsvorlage erzeugen
Sie erhalten eine Excel-Datei mit einem Arbeitsblatt, das die Daten enthält. In weiteren Arbeitsblättern können Sie zusätzliche Informationen hinzufügen, zum Beispiel Diagramme.
Beispiel Word-Berichtsvorlage herunterladen
Sie erhalten eine Word docx-Datei, die Sie für die Erstellung eines benutzerdefinierten Word-Berichts verwenden können. Die Word-Datei enthält Beispiele für die persönliche Anpassung der Vorlage, um die von Ihnen benötigten Daten dem Bericht hinzuzufügen.
Berichtsdaten als .CSV-Datei herunterladen
Sie erhalten die Berichtsdaten als CSV-Datei. Das Trennzeichen (, oder ;) ist von den Einstellungen Ihres Systems abhängig. Dies gilt auch für das Datumsformat.
Berichtsdaten als .XML-Datei herunterladen
Sie erhalten die Berichtsdaten im XML-Format. Dieses Format bietet den Vorteil, dass alle Daten in Unterberichten erhalten bleiben (beim CSV-Format ist dies nicht der Fall). Zugreifen auf Daten außerhalb von Silk Central – Sie können eine bestimmte URL für den Zugriff auf die Berichtsdaten eingeben. Verwenden Sie dazu das folgende Format:
http://server/servicesExchange?hid=reportData&userName=<username>
&passWord=<password>&reportFilterID=<ID of the report>&type=<csv|xml>
&projectID=<ID of the project>
.
Übergeordnetes Thema: Berichtseigenschaften


Berichtsparameter

  • Bearbeiten von Berichtsparametern
    Bearbeiten Sie die Parameter eines Berichts.
  • Berichtsparameter (Seite)
    Hier werden konfigurierbare Anweisungselemente angezeigt.
Übergeordnetes Thema: Berichtsbereich


Bearbeiten von Berichtsparametern

So bearbeiten Sie die Parameter eines Berichts:

  1. Klicken Sie im Menü auf Berichte > Detailansicht.
  2. Wählen Sie in der Berichtshierarchie den gewünschten Bericht aus.
  3. Öffnen Sie die Registerkarte Parameter. Wenn für den Bericht bereits Parameter definiert sind, werden diese hier angezeigt.
  4. Klicken Sie auf Parameter bearbeiten. Das Dialogfeld Parameter bearbeiten wird angezeigt.
  5. Bearbeiten Sie die Bezeichnung oder den Wert des gewünschten Parameters.
  6. Wählen Sie in der Liste Verwendung den Verwendungstyp des Parameters aus:
    • Konstanter Wert
    • Startzeit
    • Endzeit
  7. Klicken Sie auf OK.
Übergeordnetes Thema: Berichtsparameter


Berichtsparameter (Seite)

Berichte > Detailansicht > Parameter

Auf der Seite Parameter werden die konfigurierbaren Anweisungselemente angezeigt. Die Parameter können vor der Berichtsausführung auf der Seite Parameter definiert werden. Die Syntax für Parameter lautet: ${parametername|defaultvalue|guiname}. defaultvalue und guiname sind optional. Parameternamen dürfen keine Leerzeichen enthalten.

Wenn einem Bericht Parameter zugeordnet sind, können deren Werte vor jeder Berichtsausführung geändert werden. Die Parameterwerte werden im aktuellen Benutzerkontext gespeichert (d. h. die geänderten Werte sind nur für den Benutzer verfügbar, der sie bearbeitet hat). Wenn Sie für eine Berichtsausführung keine Parameterwerte festlegen, werden die Standardwerte der Berichtsdefinition verwendet.

Mit dem Listenfeld Verwendung können Sie den Verwendungstyp eines Parameters festlegen. Die möglichen Werte sind Konstanter Wert, Startzeit oder Endzeit. Startzeit und Endzeit werden für Berichte verwendet, die einen bestimmten Datumsbereich abfragen.

Wenn ein Bericht über Unterberichte verfügt, werden auch deren Parameter auf der Seite Parameter angezeigt, und ihre Werte werden nur im Kontext des ausgewählten Berichts gespeichert. Die Werte werden z. B. nur zusammen mit der aktuellen Unterberichtskonfiguration verwendet. Beim Erstellen neuer Berichte im Dialogfeld Neuen Bericht erstellen werden die Parameter im Bereich Auswahlkriterien definiert.

Übergeordnetes Thema: Berichtsparameter


Daten (Seite)

Berichte > Detailansicht > Daten

Auf der Seite Daten wird eine schreibgeschützte tabellarische Vorschau der Ergebnisse des ausgewählten Berichts angezeigt, mit der Möglichkeit diese zu sortieren und zu filtern. Die angezeigten Daten können über die Schaltfläche Daten herunterladen (.xlsx) nach Excel exportiert werden.

Sie können auf die von Ihnen gesuchten Anforderungen, Tests, Testsuiten und Issue Manager Fehlern direkt von der Ergebnisliste auf der Seite Daten zugreifen. Dazu muss Ihre Abfrage die Spalte ProjectID und die ID des Elements, zu dem Sie verknüpfen möchten, enthalten.
ID
Beschreibung
RequID
Fügen Sie diese Spalte in Ihre Abfrage ein, um eine Verknüpfung auf der Seite Daten eines Berichts zu Anforderungen zu ermöglichen.
TestDefID
Fügen Sie diese Spalte in Ihre Abfrage ein, um eine Verknüpfung mit Tests auf der Seite Daten eines Berichts zu ermöglichen.
ExecDefID
Fügen Sie diese Spalte in Ihre Abfrage ein, um eine Verknüpfung mit Testsuiten auf der Seite Daten eines Berichts zu ermöglichen.
DefectID
Fügen Sie diese Spalte in Ihre Abfrage ein, um eine Verknüpfung mit Issue Manager Fehlern auf der Seite Daten eines Berichts zu ermöglichen.

Wenn in den Ergebnissen der Abfrage die ProjectID und entweder die RequID, die TestDefID, die ExecDefID oder die DefectID enthalten ist, mit genau diesen Begriffen als Spaltennamen, werden auf der Seite Daten die Werte in der Spalte mit der ID des Elements als Link angezeigt.

Übergeordnetes Thema: Berichtsbereich


Bericht (Seite)

Berichte > Detailansicht > Bericht

Mit der Seite Bericht werden Daten als formatierter Bericht angezeigt. Wenn Sie dem Bericht noch keine Vorlage zugeordnet haben, können Sie auf der Seite Bericht eine Vorlage auswählen.

Wählen Sie die gewünschte Berichtsvorlage in dem Listenfeld aus. Hier stehen neben den vorinstallierten Vorlagen auch die mit dem Befehl Verwaltung > Berichtsvorlagen hochgeladenen benutzerdefinierten Berichtsvorlagen zur Verfügung.

Sie können auch eine vorhandene Vorlage herunterladen, indem Sie auf der Registerkarte Eigenschaften auf den Download-Link für das verwendete Berichtsformat klicken. Danach können Sie die Vorlage an Ihre Bedürfnisse anpassen.

Anmerkung: Berichte werden zwischengespeichert, um die Ausführungsgeschwindigkeit zu verbessern. Klicken Sie auf Aktualisieren, um die Berichtsdaten sofort zu aktualisieren.
Übergeordnetes Thema: Berichtsbereich


Projektübersichtsbericht

Berichte > Projektübersichtsbericht

Der Projektübersichtsbericht liefert einen Überblick über den Status des ausgewählten Projekts. Der Projektübersichtsbericht enthält die folgenden Abschnitte:

Abschnitt | Beschreibung
Allgemeine Berichtsinformationen | Allgemeine Informationen, wie den Namen des aktuellen Projekts, die Beschreibung des Berichts und das geplante Freigabedatum.
Anforderungen | Testabdeckungsstatus für die Anforderungen. Hier wird der Prozentsatz der Testabdeckung in Tabellen- und Diagrammform für alle Anforderungen und Anforderungen mit hoher Priorität angezeigt.
Tests | Testtypverteilung und Testausführungsergebnisse als Tabelle und als Diagramm für die Tests.
Übergeordnetes Thema: Berichtsbereich
Zugehörige Konzepte
Projektübersichtsbericht
Codeanalyse


Standardberichte

  • Kontextbezogene Berichte
    Beschreibung der dynamisch generierten Listen von bereichsspezifischen Berichten für Anforderungen, Tests und Testausführungen.
  • Anforderungsberichte
    In diesen Berichten wird der Status der funktionellen Anforderungen ausgegeben (z. B. Anforderungen zu Kompatibilität, Benutzeroberfläche oder Funktionen), die während der Entwicklung erfüllt werden müssen.
  • Testberichte
    Hier werden die Berichte für Tests beschrieben.
  • Ausführungsplanungsberichte
    In diesem Abschnitt werden die Berichte für die Ausführungsplanung beschrieben.
  • Fehler pro Komponente (Bericht)
    Der Bericht Fehler pro Komponente liefert einen Überblick über die Fehler zu jeder Komponente.
  • Berichte zur Codeabdeckung
    Beschreibt die Berichte zur Codeabdeckung.
  • Trendberichte zur Performanz
    Trendberichte zur Leistung zeigen, wie sich die Leistung der zu testenden Anwendung über den angegebenen Zeitraum entwickelt hat.
  • Projektübersichtsbericht
    Dieser Bericht bietet eine Übersicht über den Status des ausgewählten Projekts.
Übergeordnetes Thema: Berichte


Kontextbezogene Berichte

In den Bereichen Anforderungen, Tests und Testausführungen sind dynamisch erzeugte Listen von bereichsspezifischen Berichten verfügbar. Listen mit kontextbezogenen Berichten sind hilfreich, weil sie Berichtstypen enthalten, die sich direkt auf die aktuellen Aktivitäten beziehen.

Anforderungen
Kontextbezogene Berichtslisten in der Anforderungshierarchie bieten Berichte, die eine Anforderungs-ID als Eingabeparameter übernehmen.
Tests
Kontextbezogene Berichtslisten in der Testhierarchie bieten alle Berichte, die eine Test-ID als Eingabeparameter übernehmen.
Testausführungen
Kontextbezogene Berichtslisten in der Testsuitehierarchie bieten alle Berichte, die eine Testsuite-ID als Eingabeparameter übernehmen. Auf der Registerkarte Testläufe der Testsuite bieten kontextbezogene Berichtslisten alle Berichte an, die die folgende Konfiguration aufweisen:
  • Ergebniskategorie = Testsuite
  • Auswahlkriterium = Testsuitelauf
  • Eigenschaft = ID

Wenn Sie aus einer kontextbezogenen Berichtsliste einen Bericht auswählen, gelangen Sie direkt zu der Standardregisterkarte dieses Berichts im Bereich Berichte. Sie können diese Verknüpfung mit der Zielregisterkarte im Dialogfeld Bericht bearbeiten jedes Berichts konfigurieren.

In kontextbezogenen Berichtslisten gibt es zwei Arten von Berichten: Berichte, auf die Sie bereits zugegriffen haben, und solche, die bisher noch nicht verwendet wurden. Schon verwendete Berichte werden im Menü oberhalb einer Trennlinie angezeigt. Die Berichte erscheinen in chronologischer Reihenfolge mit dem zuletzt verwendeten Bericht am Anfang der Liste. Andere verfügbare Berichte, auf die noch nicht zugegriffen wurde, sind unterhalb der Trennlinie angeordnet.

Zusätzlich zu den vorkonfigurierten kontextbezogenen Berichten können Sie neue Berichte konfigurieren und diese sowie schon vorhandene Berichte in die kontextbezogenen Berichtslisten jedes Bereichs aufnehmen. Die Kontextbeziehung wird immer nur jedem einzelnen Bericht und immer nur für jeden einzelnen Benutzer hinzugefügt.

  • Zugreifen auf kontextbezogene Ausführungsberichte
    Greifen Sie auf einen kontextbezogenen Testsuitebericht zu.
  • Zugreifen auf kontextbezogene Testsuitelauf-Berichte
    Greifen Sie auf einen kontextbezogenen Testsuitelauf-Bericht zu.
  • Zugreifen auf kontextbezogene Anforderungsberichte
    Greifen Sie auf kontextbezogene Anforderungsberichte zu.
  • Zugreifen auf kontextbezogene Testberichte
    Greifen Sie auf kontextbezogene Testberichte zu.
  • Aktivieren von kontextbezogenen Ausführungsberichten
    Aktivieren Sie Testsuite- und Testlaufberichte, um sie in den Listen mit kontextbezogenen Berichten anzuzeigen.
  • Aktivieren von erweiterten kontextbezogenen Ausführungsberichten
    So aktivieren Sie einen erweiterten Bericht, damit er in den Listen kontextbezogener Berichte in der Testsuitehierarchie oder auf der Seite Testläufe angezeigt wird.
  • Aktivieren von erweiterten kontextbezogenen Anforderungsberichten
    Aktivieren Sie Anforderungsberichte, um sie in der Liste kontextbezogener Berichte anzuzeigen.
  • Aktivieren von erweiterten kontextbezogenen Anforderungsberichten
    Aktivieren Sie einen erweiterten Bericht, damit er in den Listen kontextbezogener Berichte im Bereich Anforderungen angezeigt wird.
  • Aktivieren von kontextbezogenen Testberichten
    Aktivieren Sie Testberichte, um sie in der Liste kontextbezogener Berichte anzuzeigen.
  • Aktivieren von erweiterten kontextbezogenen Testberichten
    Aktivieren Sie einen erweiterten Bericht, damit er in den Listen kontextbezogener Berichte im Bereich Tests angezeigt wird.
Übergeordnetes Thema: Standardberichte


Zugreifen auf kontextbezogene Ausführungsberichte

Anmerkung: Berichte müssen als kontextbezogene Berichte aktiviert sein, damit sie im Bereich Ausführungen verfügbar sind.

So greifen Sie auf einen kontextbezogenen Testsuitebericht zu:

  1. Klicken Sie im Menü auf Ausführungsplanung.
  2. Klicken Sie in der Testsuitehierarchie mit der rechten Maustaste auf eine Testsuite, und wählen Sie Berichte.
  3. Wählen Sie im Untermenü Berichte einen Bericht aus.

    Sie gelangen zur Registerkarte Parameter des ausgewählten Berichts im Bereich Berichte, wo der ID-Wert der Testsuite angezeigt wird.

    Anmerkung: Sie können diese Verknüpfung mit der Zielregisterkarte im Dialog Bericht bearbeiten konfigurieren.
  4. Bearbeiten Sie die Parameter des Berichts wie gewünscht.
  5. Schließen Sie die Konfiguration des Berichts auf den Seiten Daten, Bericht oder Diagramm ab.
Übergeordnetes Thema: Kontextbezogene Berichte


Zugreifen auf kontextbezogene Testsuitelauf-Berichte

Anmerkung: Berichte müssen als kontextbezogene Berichte aktiviert sein, damit sie im Bereich Ausführungen verfügbar sind.

Greifen Sie auf einen kontextbezogenen Testsuitelauf-Bericht zu.

  1. Klicken Sie im Menü auf Ausführungsplanung > Detailansicht.
  2. Klicken Sie auf die Registerkarte Testläufe.
  3. Klicken Sie mit der rechten Maustaste auf einen Testlauf, und wählen Sie Berichte.
  4. Wählen Sie im Untermenü Berichte einen Bericht aus.

    Sie gelangen zur Seite Parameter des ausgewählten Berichts im Bereich Berichte, wo der ID-Wert des Testlaufs angezeigt wird.

    Anmerkung: Sie können diese Verknüpfung mit der Zielregisterkarte im Dialog Bericht bearbeiten konfigurieren.
  5. Bearbeiten Sie die Parameter des Berichts wie gewünscht.
  6. Schließen Sie die Konfiguration des Berichts auf den Seiten Daten, Bericht oder Diagramm ab.
Übergeordnetes Thema: Kontextbezogene Berichte


Zugreifen auf kontextbezogene Anforderungsberichte

Anmerkung: Kontextbezogene Berichte sind im Bereich Anforderungen nur für die Berichte verfügbar, die eine Anforderungs-ID als Eingabeparameter akzeptieren.

So greifen Sie auf einen kontextbezogenen Anforderungsbericht zu:

  1. Klicken Sie auf Anforderungen > Detailansicht.
  2. Klicken Sie in der Anforderungshierarchie mit der rechten Maustaste auf eine Anforderung, und wählen Sie Berichte.
  3. Wählen Sie im Untermenü Berichte einen Bericht aus.

    Sie gelangen zur Seite Parameter des ausgewählten Berichts im Bereich Berichte, wo der ID-Wert der Anforderung angezeigt wird.

    Anmerkung: Sie können diese Verknüpfung mit der Zielregisterkarte im Dialog Bericht bearbeiten konfigurieren.
  4. Bearbeiten Sie die Parameter des Berichts wie gewünscht.
  5. Schließen Sie die Konfiguration des Berichts auf den Seiten Daten, Bericht oder Diagramm ab.
Übergeordnetes Thema: Kontextbezogene Berichte


Zugreifen auf kontextbezogene Testberichte

Anmerkung: Kontextbezogene Berichte sind im Bereich Tests nur für die Berichte verfügbar, die eine Test-ID als Eingabeparameter akzeptieren.

So greifen Sie auf einen kontextbezogenen Testbericht zu:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Klicken Sie in der Testhierarchie oder in der Tabellenansicht mit der rechten Maustaste auf einen Test, einen Ordner oder auf einen Container und wählen Sie Berichte.
    Anmerkung: Wenn Sie in der Tabellenansicht mehrere Tests auswählen, wird die kontextbezogene Berichtserstellung deaktiviert.
  3. Wählen Sie im Untermenü Berichte einen Bericht aus.

    Sie gelangen zur Seite Parameter des ausgewählten Berichts im Bereich Berichte, wo der ID-Wert des Tests angezeigt wird.

    Anmerkung: Sie können diese Verknüpfung mit der Zielregisterkarte im Dialog Bericht bearbeiten konfigurieren.
  4. Bearbeiten Sie die Parameter des Berichts wie gewünscht.
  5. Schließen Sie die Konfiguration des Berichts auf den Seiten Daten, Bericht oder Diagramm ab.
Übergeordnetes Thema: Kontextbezogene Berichte


Aktivieren von kontextbezogenen Ausführungsberichten

Hier wird beschrieben, wie kontextbezogene Testsuite- und Testlaufberichte aktiviert werden, damit sie in den Listen kontextbezogener Berichte angezeigt werden.

So aktivieren Sie einen einfachen Bericht, damit er in den Listen kontextbezogener Berichte in der Testsuitehierarchie oder auf der Registerkarte Testläufe angezeigt wird:

  1. Erstellen Sie einen neuen Bericht. Weitere Informationen finden Sie unter Erstellen neuer Berichte.
  2. Wählen Sie im Listenfeld Ergebniskategorie den Eintrag Testsuite.
  3. Wählen Sie die Auswahlkriterien für den kontextbezogenen Bericht aus.
  4. Wählen Sie im Listenfeld Eigenschaft den Eintrag ID.
  5. Geben Sie im Feld Wert einen Wert ein. Beispielsweise die ID-Nummer einer vorhandenen Testsuite oder eines vorhandenen Testlaufs.
  6. Klicken Sie auf Fertig stellen.
Übergeordnetes Thema: Kontextbezogene Berichte
Zugehörige Tasks
Erstellen neuer Berichte


Aktivieren von erweiterten kontextbezogenen Ausführungsberichten

So aktivieren Sie einen erweiterten Bericht, damit er in den Listen kontextbezogener Berichte in der Testsuitehierarchie oder auf der Seite Testläufe angezeigt wird:

  1. Erstellen Sie einen Bericht mit einem der folgenden Elemente:
    • Eine Testsuite-ID als Eingabeparameter für den Bericht, der in der Testsuitehierarchie angezeigt werden soll.
    • Eine Testsuite-Ausführungs-ID als Eingabeparameter für den Bericht, der auf der Registerkarte Testläufe angezeigt werden soll.

    Weitere Informationen unter Erstellen neuer Berichte und Erstellen erweiterter Abfragen in SQL.

  2. Damit die erweiterte Abfrage im Kontextmenü der Testausführungen im Bereich Testausführungen verfügbar ist, fügen Sie den Parameternamen execProp_Id_0 als Eingabe für ExecDef_ID_pk_fk ein. Angenommen, in den SQL-Anweisungen Ihres Berichts ist bereits ein Datenbank-Spaltenwert in Form von ExecDef_ID_pk_fk = 68 enthalten. Damit dem Bericht dynamisch ein Wert für den Spaltennamen zugewiesen werden kann, müssen Sie den statischen Wert 68 durch ${execProp_Id_0 | 68} ersetzen.
Übergeordnetes Thema: Kontextbezogene Berichte
Zugehörige Tasks
Erstellen neuer Berichte
Erstellen erweiterter Abfragen in SQL


Aktivieren von erweiterten kontextbezogenen Anforderungsberichten

Hier wird beschrieben, wie kontextbezogene Anforderungsberichte aktiviert werden, damit sie in den Listen kontextbezogener Berichte angezeigt werden.

So aktivieren Sie einen einfachen Bericht, damit er in der Liste kontextbezogener Berichte im Bereich Anforderungen angezeigt wird:

  1. Erstellen Sie einen neuen Bericht. Weitere Informationen finden Sie unter Erstellen neuer Berichte.
  2. Wählen Sie im Listenfeld Ergebniskategorie den Eintrag Anforderung.
  3. Wählen Sie die Auswahlkriterien für den kontextbezogenen Bericht aus.
  4. Geben Sie im Feld Wert einen Wert ein. Beispielsweise die ID-Nummer einer vorhandenen Anforderung.
Übergeordnetes Thema: Kontextbezogene Berichte
Zugehörige Tasks
Erstellen neuer Berichte


Aktivieren von erweiterten kontextbezogenen Anforderungsberichten

So aktivieren Sie einen erweiterten Bericht, damit er in den Listen kontextbezogener Berichte im Bereich Anforderungen angezeigt wird:

  1. Erstellen Sie einen Bericht, der eine Anforderungs-ID als Eingabeparameter verlangt.

    Weitere Informationen unter Erstellen neuer Berichte und Erstellen erweiterter Abfragen in SQL.

  2. Damit die erweiterte Abfrage im Kontextmenü der Testausführungen im Bereich Anforderungen verfügbar ist, fügen Sie den Parameternamen reqProp_Id_0 als Eingabe für Req_ID_pk_fk ein. Angenommen, in den SQL-Anweisungen Ihres Berichts ist bereits ein Datenbank-Spaltenwert in Form von Req_ID_pk_fk = 68 enthalten. Damit dem Bericht dynamisch ein Wert für den Spaltennamen zugewiesen werden kann, müssen Sie den statischen Wert 68 durch ${reqProp_Id_0 | 68} ersetzen.
Übergeordnetes Thema: Kontextbezogene Berichte
Zugehörige Tasks
Erstellen neuer Berichte
Erstellen erweiterter Abfragen in SQL


Aktivieren von kontextbezogenen Testberichten

Hier wird beschrieben, wie kontextbezogene Testberichte aktiviert werden, damit sie in den Listen kontextbezogener Berichte angezeigt werden.

So aktivieren Sie einen einfachen Bericht, damit er in der Liste kontextbezogener Berichte im Bereich Tests angezeigt wird:

  1. Erstellen Sie einen neuen Bericht. Weitere Informationen finden Sie unter Erstellen neuer Berichte.
  2. Wählen Sie im Listenfeld Ergebniskategorie den Eintrag Test.
  3. Wählen Sie die Auswahlkriterien für den kontextbezogenen Bericht aus.
  4. Geben Sie im Feld Wert einen Wert ein. Beispielsweise die ID-Nummer eines vorhandenen Tests.
Übergeordnetes Thema: Kontextbezogene Berichte
Zugehörige Tasks
Erstellen neuer Berichte


Aktivieren von erweiterten kontextbezogenen Testberichten

So aktivieren Sie einen erweiterten Bericht, damit er in den Listen kontextbezogener Berichte im Bereich Tests angezeigt wird:

  1. Erstellen Sie einen Bericht, der eine Test-ID, eine Ordner-ID oder eine Container-ID als Eingabeparameter verlangt.

    Weitere Informationen unter Erstellen neuer Berichte und Erstellen erweiterter Abfragen in SQL.

  2. Damit die erweiterte Abfrage im Kontextmenü der Testausführungen im Bereich Tests verfügbar ist, fügen Sie den Parameternamen tdProp_Id_0 als Eingabe für die Test-ID odertfProp_Id als Eingabe für die Ordner-ID oder Container-ID ein. Angenommen, in den SQL-Anweisungen Ihres Berichts ist bereits ein Datenbank-Spaltenwert in Form von TestDef_ID_pk_fk = 68 enthalten. Damit dem Bericht dynamisch ein Wert für den Spaltennamen zugewiesen werden kann, müssen Sie den statischen Wert 68 durch ${tdProp_Id_0 | 68} ersetzen.
Übergeordnetes Thema: Kontextbezogene Berichte
Zugehörige Tasks
Erstellen neuer Berichte
Erstellen erweiterter Abfragen in SQL


Ausführungsplanungsberichte

In diesem Abschnitt werden die mit Silk Central installierten Ausführungsplanungsberichte beschrieben. Um die Bewertung der Ergebnisse zu erleichtern, bieten Ausführungsplanungsberichte einen Überblick über den Fortschritt bei den Testsuiten und den Status der Fehler in einem bestimmten Zeitfenster und Build-Bereich.

  • Vergleichsberichte zu Testsuiteläufen
    Vergleichsberichte zu Testsuiteläufen bieten einen Überblick über den Vergleich zweier Testläufe einer Testsuite.
  • Bericht über Fehler des Testsuitelaufs
    Der Bericht über Fehler des Testsuitelaufs enthält eine detaillierte Liste aller Tests, die den Testsuitelauf nicht bestanden haben, und den Grund für ihren Fehlschlag.
  • Bericht über fehlgeschlagene Tests
    Der Bericht über Fehlgeschlagene Tests bietet eine Übersicht aller fehlgeschlagenen Tests eines Ordners oder Projekts im Bereich Ausführungen.
  • Bericht über nicht bestandene Tests pro Testsuite
    Der Bericht über Nicht bestandene Tests pro Testsuite gibt einen Überblick über alle nicht bestandenen Tests je Konfiguration für alle Konfigurationssuiten oder pro Testsuite für einen Ordner oder ein Projekt im Bereich Testausführung.
  • Ausführungs-Statusübersicht-Bericht
    Der Ausführungs-Statusübersicht-Bericht zeigt eine Übersicht des Status des letzten Testlaufs für jeden den Testsuiten des ausgewählten Knotens zugeordneten Test an.
Übergeordnetes Thema: Standardberichte


Vergleichsberichte zu Testsuiteläufen

Vergleichsberichte zu Testsuiteläufen bieten einen Überblick über den Vergleich zweier Testläufe einer Testsuite.
Anmerkung: Vergleichsberichte zu Testläufen eignen sich nicht dazu, manuelle mit automatisierten Tests zu vergleichen. Wenn der Name des Berichts (die beiden letzten Testläufe) enthält, können Sie nur die beiden letzten Testläufe der Testsuite oder des Tests vergleichen.
Die folgenden Berichte vergleichen zwei Testläufe einer Testsuite:
Vergleichsbericht zu Testsuiteläufen

Der Standardtestsuitelauf-Vergleichsbericht, bei dem zwei Testläufe der Testsuite miteinander verglichen werden.

Vergleich der Testsuiteläufe – Geänderter Status

Hier werden nur die Tests der beiden Testsuiteläufe miteinander verglichen, deren Status sich geändert hat.

Vergleich der Testsuiteläufe – Fehlgeschlagen in neuerer Ausführung

Hier werden nur die fehlgeschlagenen Tests der beiden Testsuiteläufe miteinander verglichen.

Der Testsuitelauf-Vergleichsbericht bietet folgende Informationen:
  • Änderungen im Status der Testsuiten
  • Fehleranzahl
  • Anzahl der Warnungen
  • Kontext, in dem die Testsuiten ausgeführt wurden
  • Ausführungsdauer der zugeordneten Tests
Anmerkung: Wenn sich der Status eines zugeordneten Tests zwischen den Testläufen, die miteinander verglichen werden, in Fehlgeschlagen geändert hat, dann wird der Test rot markiert. Wenn sich der Status eines zugeordneten Tests zwischen den Testläufen, die miteinander verglichen werden, in Bestanden geändert hat, dann wird der Test grün markiert.
Übergeordnetes Thema: Ausführungsplanungsberichte


Bericht über Fehler des Testsuitelaufs

Der Bericht über Fehler des Testsuitelaufs enthält eine detaillierte Liste aller Tests, die den Testsuitelauf nicht bestanden haben, und den Grund für ihren Fehlschlag.

Alle während des Testsuitelaufs aufgetretenen Fehler werden in diesem Bericht aufgelistet. Die Benutzer können rasch auf die Ergebnisse zugreifen und mühelos unerwartete Ereignisse im Testsuitelauf erkennen. Als Eingabeparameter für einen Bericht über Fehler des Testsuitelaufs wird die Kennung des Testsuitelaufs übergeben.

Übergeordnetes Thema: Ausführungsplanungsberichte


Bericht über fehlgeschlagene Tests

Der Bericht über Fehlgeschlagene Tests bietet eine Übersicht aller fehlgeschlagenen Tests eines Ordners oder Projekts im Bereich Ausführungen.

Sie können diesen Bericht für die Fehleranalyse verwenden, zum Beispiel während eines Konfigurationstests. Der Eingabeparameter für einen Bericht über Fehlgeschlagene Tests ist die Kennung der Konfigurationssuite, des Ordner oder des Projekts.

Übergeordnetes Thema: Ausführungsplanungsberichte


Bericht über nicht bestandene Tests pro Testsuite

Der Bericht über Nicht bestandene Tests pro Testsuite gibt einen Überblick über alle nicht bestandenen Tests je Konfiguration für alle Konfigurationssuiten oder pro Testsuite für einen Ordner oder ein Projekt im Bereich Testausführung.

Sie können diesen Bericht für die Fehleranalyse verwenden, zum Beispiel während eines Konfigurationstests. Der Eingabeparameter für einen Bericht über Nicht bestandene Tests pro Testsuite ist die Kennung der Konfigurationssuite, des Ordner oder des Projekts.

Übergeordnetes Thema: Ausführungsplanungsberichte
Zugehörige Tasks
Zugreifen auf kontextbezogene Ausführungsberichte


Ausführungs-Statusübersicht-Bericht

Der Ausführungs-Statusübersicht-Bericht zeigt eine Übersicht des Status des letzten Testlaufs für jeden den Testsuiten des ausgewählten Knotens zugeordneten Test an.

Als Eingabeparameter für einen Ausführungs-Statusübersicht-Bericht wird die Kennung des Knotens in der Testsuitehierarchie übergeben.

Übergeordnetes Thema: Ausführungsplanungsberichte


Fehler pro Komponente (Bericht)

Der Bericht Fehler pro Komponente liefert einen Überblick über die Fehler zu jeder Komponente.

Er ermöglicht nicht nur die grundlegende Fehlerverfolgung, sondern auch das Überwachen des Fehlertrends der verschiedenen Komponenten.

Übergeordnetes Thema: Standardberichte


Berichte zur Codeabdeckung

In diesem Abschnitt werden die mit Silk Central installierten Berichte zur Codeabdeckung beschrieben. Berichte zur Codeabdeckung bieten einen detaillierten Überblick über die Codeabdeckung des Produkts innerhalb eines Zeitraums oder Build-Bereichs.

  • Berichte zur Auswirkung von Codeänderungen
    Sie können mit diesen Berichten den voraussichtlichen Aufwand und die Risiken bestimmter Codeänderungen analysieren.
  • Trendbericht zur Codeabdeckung
    Zeigt den Trend der zunehmenden Codeabdeckung für Methoden, Klassen und Pakete für ein Produkt über einen ausgewählten Bereich von Builds.
  • Vergleichsbericht zur Methodenabdeckung
    Vergleicht die Methodenabdeckung für alle enthaltenen Pakete/Namensräume zwischen zwei Produkt-Builds.
Übergeordnetes Thema: Standardberichte


Berichte zur Auswirkung von Codeänderungen

Sie können mit den Berichten zur Auswirkung von Codeänderungen den voraussichtlichen Aufwand und die Risiken bestimmter Codeänderungen analysieren. Sie können dazu die gewünschten Klassen auswählen und dann durch Zuweisen von Berichtsvorlagen Berichte erzeugen, aus denen die Auswirkungen von Änderungen dieser Klasse ersichtlich sind. Sie können für die ausgewählten Klassen Berichtsvorlangen auswählen, um die Auswirkungen bestimmter Codeänderungen zu analysieren.

Mit dem Bericht Auswirkungen von Codeänderungen - Tests kann ermittelt werden, welche Tests nach Codeänderungen erneut ausgeführt werden müssen. Der Abdeckungsindex die durch den Test abgedeckten Methoden in den angegebenen Klassen/ die Gesamtzahl der Methoden in den angegebenen Klassen an.

Mit Bericht Auswirkungen von Codeänderungen - Testsuiten kann ermittelt werden, welche Testsuiten nach Codeänderungen erneut ausgeführt werden müssen.

Anwendungsfälle für Berichte

Nachfolgend sind einige typische Anwendungsfälle für Berichte zur Auswirkung von Codeänderungen aufgelistet:
Analyse der Auswirkungen
Sie möchten wissen, welche Tests bei bestimmten Codeänderungen ausgeführt werden müssen.
  • Wählen Sie die gewünschte Klasse aus.
  • Wählen Sie den Bericht zu Auswirkungen von Codeänderungen - Tests, und führen Sie ihn aus.
  • Überprüfen Sie die Liste der Tests für die Klassen, die in dieser Version geändert wurden.
Analyse des Aufwands
Sie möchten wissen, wie lange automatisierte und manuelle Tests zur Abdeckung bestimmter Codeänderungen durchgeführt werden müssen.
  • Wählen Sie die gewünschte Klasse aus.
  • Wählen Sie den Bericht zu Auswirkungen von Codeänderungen - Testsuiten, und führen Sie ihn aus.
  • Überprüfen Sie die erforderliche Dauer der automatisierten und manuellen Tests.
Übergeordnetes Thema: Berichte zur Codeabdeckung


Trendbericht zur Codeabdeckung

Zeigt den Trend der zunehmenden Codeabdeckung für Methoden, Klassen und Pakete für ein Produkt über einen ausgewählten Bereich von Builds.

Trenddiagramm zur Codeabdeckung

Zeigt den Gesamtprozentanteil der Codeabdeckung für das gewählte Produkt über den ausgewählten Build-Bereich an. Die Codeabdeckung für bestimmte Pakete/Namensräume, Klassen und Methoden wird jeweils getrennt angezeigt.

Trenddetails zur Codeabdeckung

Zeigt die Daten aus dem Trenddiagramm zur Codeabdeckung in tabellarischer Form an.

Übergeordnetes Thema: Berichte zur Codeabdeckung


Vergleichsbericht zur Methodenabdeckung

Vergleicht die Methodenabdeckung für alle enthaltenen Pakete/Namensräume zwischen zwei Produkt-Builds.

Verwenden Sie den Grenzwert-Parameter, um die Mindestmenge an Änderungen, die auftreten muss, damit ein Paket//Namensraum in den Bericht aufgenommen wird, anzugeben. Pakete//Namensräume mit einem kleineren Prozentsatz an Änderungen werden nicht im Bericht dargestellt. Es sind Grenzwerte im Bereich zwischen 0 und 100 Prozent zulässig.

Übergeordnetes Thema: Berichte zur Codeabdeckung


Trendberichte zur Performanz

Trendberichte zur Leistung zeigen, wie sich die Leistung der zu testenden Anwendung über den angegebenen Zeitraum entwickelt hat.

Die Eingabedaten für die Leistungsberichte werden durch Silk Performer-Lasttests bereitgestellt.

  • Trendbericht zu Average Page-Time
    Zeigt für alle Tests, die innerhalb des festgelegten Zeitraums für den angegebenen Test ausgeführt wurden, die Ausführungsdauer pro Seite an.
  • Trendbericht zur Average Transaction Busy-Time
    Zeigt für alle Tests, die innerhalb des festgelegten Zeitraums für den angegebenen Test ausgeführt wurden, die Ausführungsdauer pro Transaktion an.
  • Trendbericht zu Overall Page-Time
    Dieser Bericht zeigt die gesamten, für alle Benutzertypen summierten Seitenzeiten für alle Tests, die für die angegebene Test innerhalb des festgelegten Zeitraums ausgeführt wurden.
  • Trendbericht zur Overall Transaction Busy-Time
    Zeigt für alle Tests, die innerhalb des festgelegten Zeitraums für den angegebenen Test ausgeführt wurden, die über alle Benutzertypen aggregierte allgemeine Ausführungsdauer pro Transaktion an.
  • Trendbericht zur benutzerdefinierten Messung
    Zeigt für alle Tests, die innerhalb des festgelegten Zeitraums für den angegebenen Test ausgeführt wurden, den Durchschnittswert und den Minimum- und Maximumwert der definierten Messung(en) an.
Übergeordnetes Thema: Standardberichte


Trendbericht zu Average Page-Time

Zeigt für alle Tests, die innerhalb des festgelegten Zeitraums für den angegebenen Test ausgeführt wurden, die Ausführungsdauer pro Seite an. Der Leistungstrend der Zeiten (Page-Times) für die getesteten Seiten wird in einem Diagramm dargestellt.

Eingabeparameter

Für einen Trendbericht zu Average Page-Time sind folgende Eingabeparameter anzugeben:
Parameter
Beschreibung
Datum vom (TT-MMM-JJJJ)
Startdatum des gewünschten Zeitraums. Zum Beispiel: 06-DEZ-2008.
Datum bis (TT-MMM-JJJJ)
Enddatum des gewünschten Zeitraums. Zum Beispiel: 16-JAN-2009.
Testläufe mit mehr als <nnn> Fehlern ausschließen
Testläufe, die mehr Fehler als hier angegeben erzeugt haben, werden nicht in den Bericht aufgenommen. Mit dieser Einstellung können Sie verhindern, dass Ausreißer die Trendkurve verzerren.
Maximalwert für Y-Achse
Begrenzt die Y-Achse des Diagramms auf den angegebenen Wert. Aktive Zeiten pro Transaktion, die diesen Wert überschreiten, werden oben abgeschnitten. Durch diese Einstellung lässt sich verhindern, dass die Kurven durch Ausreißer verflacht werden.
Messungsfilter
Es werden nur diejenigen Metriken angezeigt, welche die angegebene Zeichenfolge in ihrem Namen enthalten. Dieses Feld muss ausgefüllt werden. Um alle verfügbaren Metriken anzuzeigen, legen Sie den Messungsfilter auf % fest. Wenn beispielsweise nur die Messungen angezeigt werden sollen, die an einer beliebigen Position in ihrem Namen die Zeichenfolge "unit" enthalten, dann legen Sie den Messungsfilter auf %unit% fest.
Test-ID
Identifizierung des Tests, dessen Bericht Sie anzeigen möchten.
Übergeordnetes Thema: Trendberichte zur Performanz


Trendbericht zur Average Transaction Busy-Time

Zeigt für alle Tests, die innerhalb des festgelegten Zeitraums für den angegebenen Test ausgeführt wurden, die Ausführungsdauer pro Transaktion an. Die Leistungstrends der Transaction Busy-Times für die getesteten Transaktionen werden in Trenddiagrammen dargestellt.

Eingabeparameter

Für einen Trendbericht zu Transaction Busy-Time sind folgende Eingabeparameter anzugeben:
Parameter
Beschreibung
Datum vom (TT-MMM-JJJJ)
Startdatum des gewünschten Zeitraums. Zum Beispiel: 06-DEZ-2008.
Datum bis (TT-MMM-JJJJ)
Enddatum des gewünschten Zeitraums. Zum Beispiel: 16-JAN-2009.
Testläufe mit mehr als <nnn> Fehlern ausschließen
Testläufe, die mehr Fehler als hier angegeben erzeugt haben, werden nicht in den Bericht aufgenommen. Mit dieser Einstellung können Sie verhindern, dass Ausreißer die Trendkurve verzerren.
Maximalwert für Y-Achse
Begrenzt die Y-Achse des Diagramms auf den angegebenen Wert. Aktive Zeiten pro Transaktion, die diesen Wert überschreiten, werden oben abgeschnitten. Durch diese Einstellung lässt sich verhindern, dass die Kurven durch Ausreißer verflacht werden.
Test-ID
Identifizierung des Tests, dessen Bericht Sie anzeigen möchten.
Transaktionsfilter
Es werden nur diejenigen Transaktionen angezeigt, welche die angegebene Zeichenfolge in ihrem Namen enthalten. Dieses Feld muss ausgefüllt werden. Um alle verfügbaren Transaktionen anzuzeigen, legen Sie den Transaktionsfilter auf % fest. Wenn beispielsweise nur die Transaktionen angezeigt werden sollen, die die Zeichenfolge "unit" an einer beliebigen Position in ihrem Namen enthalten, dann legen Sie den Transaktionsfilter auf %unit% fest.
Übergeordnetes Thema: Trendberichte zur Performanz


Trendbericht zu Overall Page-Time

Dieser Bericht zeigt die gesamten, für alle Benutzertypen summierten Seitenzeiten für alle Tests, die für die angegebene Test innerhalb des festgelegten Zeitraums ausgeführt wurden. Der Leistungstrend der Page-Times für die getestete Seite wird in einem Diagramm dargestellt.

Eingabeparameter

Für einen Trendbericht zu Overall Page-Time sind folgende Eingabeparameter anzugeben:
Parameter
Beschreibung
Datum vom (TT-MMM-JJJJ)
Startdatum des gewünschten Zeitraums. Zum Beispiel: 06-DEZ-2008.
Datum bis (TT-MMM-JJJJ)
Enddatum des gewünschten Zeitraums. Zum Beispiel: 16-JAN-2009.
Testläufe mit mehr als <nnn> Fehlern ausschließen
Testläufe, die mehr Fehler als hier angegeben erzeugt haben, werden nicht in den Bericht aufgenommen. Mit dieser Einstellung können Sie verhindern, dass Ausreißer die Trendkurve verzerren.
Maximalwert für Y-Achse
Begrenzt die Y-Achse des Diagramms auf den angegebenen Wert. Aktive Zeiten pro Transaktion, die diesen Wert überschreiten, werden oben abgeschnitten. Durch diese Einstellung lässt sich verhindern, dass die Kurven durch Ausreißer verflacht werden.
Test-ID
Identifizierung des Tests, dessen Bericht Sie anzeigen möchten.
Übergeordnetes Thema: Trendberichte zur Performanz


Trendbericht zur Overall Transaction Busy-Time

Zeigt für alle Tests, die innerhalb des festgelegten Zeitraums für den angegebenen Test ausgeführt wurden, die über alle Benutzertypen aggregierte allgemeine Ausführungsdauer pro Transaktion an. Der Leistungstrend der Transaction Busy-Times für die getesteten Transaktionen wird in einem Trenddiagramm dargestellt.

Eingabeparameter

Für einen Trendbericht zur Overall Transaction Busy-Time sind folgende Eingabeparameter anzugeben:
Parameter
Beschreibung
Datum vom (TT-MMM-JJJJ)
Startdatum des gewünschten Zeitraums. Zum Beispiel: 06-DEZ-2008.
Datum bis (TT-MMM-JJJJ)
Enddatum des gewünschten Zeitraums. Zum Beispiel: 16-JAN-2009.
Testläufe mit mehr als <nnn> Fehlern ausschließen
Testläufe, die mehr Fehler als hier angegeben erzeugt haben, werden nicht in den Bericht aufgenommen. Mit dieser Einstellung können Sie verhindern, dass Ausreißer die Trendkurve verzerren.
Maximalwert für Y-Achse
Begrenzt die Y-Achse des Diagramms auf den angegebenen Wert. Aktive Zeiten pro Transaktion, die diesen Wert überschreiten, werden oben abgeschnitten. Durch diese Einstellung lässt sich verhindern, dass die Kurven durch Ausreißer verflacht werden.
Test-ID
Identifizierung des Tests, dessen Bericht Sie anzeigen möchten.
Übergeordnetes Thema: Trendberichte zur Performanz


Trendbericht zur benutzerdefinierten Messung

Zeigt für alle Tests, die innerhalb des festgelegten Zeitraums für den angegebenen Test ausgeführt wurden, den Durchschnittswert und den Minimum- und Maximumwert der definierten Messung(en) an. Der Leistungstrend der Werte für jede getestete Messung wird in einem Diagramm dargestellt.

Eingabeparameter

Für einen Trendbericht zur benutzerdefinierten Messung sind folgende Eingabeparameter anzugeben:
Parameter
Beschreibung
Datum vom (TT-MMM-JJJJ)
Startdatum des gewünschten Zeitraums. Zum Beispiel: 06-DEZ-2008.
Datum bis (TT-MMM-JJJJ)
Enddatum des gewünschten Zeitraums. Zum Beispiel: 16-JAN-2009.
Testläufe mit mehr als <nnn> Fehlern ausschließen
Testläufe, die mehr Fehler als hier angegeben erzeugt haben, werden nicht in den Bericht aufgenommen. Mit dieser Einstellung können Sie verhindern, dass Ausreißer die Trendkurve verzerren.
Maximalwert für Y-Achse

Begrenzt die Y-Achse des Diagramms auf den angegebenen Wert. Messungen, die diesen Wert überschreiten, werden oben abgeschnitten. Durch diese Einstellung lässt sich verhindern, dass die Kurven durch Ausreißer verflacht werden.

Messungsname

Kennung der benutzerdefinierten Messung, zu der Sie den Bericht anzeigen möchten. Zum Beispiel: CreateTestDefinition.

Typ der Messung

Typ der benutzerdefinierten Messung. Zum Beispiel: Transaction(BusyTime)[s].

Test-ID
Identifizierung des Tests, dessen Bericht Sie anzeigen möchten.
Übergeordnetes Thema: Trendberichte zur Performanz


Verwaltung

Nachdem Sie die anfängliche Konfiguration von Silk Central (Instanzenkonfiguration) abgeschlossen haben, werden Sie in den folgenden Abschnitten durch die Schritte geführt, die zum Einrichten von Benutzerkonten, Projekten, Servergruppen, Ausführungsservern usw. erforderlich sind. Diese Aufgaben müssen von einem Administrator durchgeführt werden.
  • Benutzerrollen und Berechtigungen
    Hier wird beschrieben, wie Sie mit unterschiedlichen Benutzerrollen und Berechtigungen in Silk Central arbeiten.
  • Benutzerkonten und Gruppen
    Hier wird das Konzept von Benutzerkonten und Gruppen in Silk Central beschrieben.
  • Ausführungsumgebung
    Hier wird das Konzept der Ausführungsumgebung in Silk Central beschrieben.
  • Verwalten von Berichtsvorlagen
    Hier wird das Arbeiten mit Berichtsvorlagen in Silk Central beschrieben.
  • Audit-Log
    Hier wird beschrieben, wie Administratoren alle aufgezeichneten Silk Central-Benutzeraktivitäten mithilfe des Audit-Logs anzeigen können.
  • Server-Protokolldateien
    Server-Protokolldateien enthalten Informationen, die für Administrationen sehr hilfreich bei der Fehleranalyse sein können.
  • Integrieren von Aufgabenverwaltungssystemen
    Hier wird beschrieben, wie Sie externe Aufgabenverwaltungstools in Silk Central integrieren.
  • Verwalten von Produkten, Komponenten und Builds
    Hier wird beschrieben, wie Produkte, Produktkomponenten, Produktversionen und Build-Nummern von Produktversionen erstellt und strukturiert werden.
  • Verwalten von Wertelisten
    Hier wird die Verwendung von Wertelisten zur Definition von Werten für benutzerdefinierte Eigenschaften in benutzerdefinierten Fehlerregisterkarten beschrieben, die für Issue Manager konfiguriert werden können.
  • Konfigurieren von Ausführungsterminen
    Hier wird beschrieben, wie Sie allgemeine Ausführungstermine definieren, die in Silk Central zur Planung von Testsuiten verwendet werden können.
  • Zeitzonen
    Hier wird beschrieben, wie Zeitzonen in Silk Central behandelt werden.
  • Verwalten von Projekten
    Projekte reflektieren in Silk Central üblicherweise ein Software-Projekt in Ihrer Firma, respektive die Arbeit eines Entwicklungsteams, mit gemeinsamem Release-Datum, Versionsverwaltungssystem, gemeinsamen Anforderungen, usw.
  • Integrationen
    Hier werden die in Silk Central verfügbaren Integrationen beschrieben.
Übergeordnetes Thema: Silk Central-Hilfe


Benutzerrollen und Berechtigungen

In Silk Central sind Aufgaben designierten Benutzergruppen mit Zugriff auf bestimmte Projekte zugewiesen. Benutzer aus den Gruppen erhalten bestimmte Rollen in diesen Projekten. Benutzerberechtigungen werden durch den Benutzerrollentyp und die Gruppenmitgliedschaft konfiguriert. In diesem Thema werden die Berechtigungstypen und die den Benutzerrollen zugeordneten speziellen Berechtigungen detailliert beschrieben.

Jedes Benutzerkonto kann zu einer oder mehreren Gruppen gehören. Eine Gruppe legt fest, welche Rollen ein Benutzer in dieser Gruppe hat. Gruppen werden Projekten zugeordnet. Die Berechtigungen jedes einzelnen Benutzers sind daher von den für ihn definierten Gruppen-/Rollenzuordnungen abgeleitet. Definierte Berechtigungen gelten nur für die Projekte, die den Gruppen zugeordnet sind, in welchen der Benutzer eine Gruppen-/Rollenzuordnung hat.

  • Benutzerrollen
    Hier werden die Benutzerrollen beschrieben, die in Silk Central verfügbar sind.
  • Definitionen von Berechtigungen
    Hier werden die Berechtigungen beschrieben, die das Ausführen von Aufgaben und den Zugriff auf sichere Bereiche von Silk Central abdecken.
Übergeordnetes Thema: Verwaltung
Zugehörige Konzepte
Verwalten von Gruppen
Verwalten von Servergruppen
Super User
Benutzerrollen
Zugehörige Tasks
Hinzufügen von Projekten
Initialisieren von Projekten als Issue Manager-Projekte
Bearbeiten von Projekten oder Projekt-Baselines


Benutzerrollen

Die folgenden Benutzerrollen sind in Silk Central vordefiniert:
  • SuperUser
  • Administrator
  • Projektmanager
  • Testmanager
  • Tester
  • Analytiker
  • Berichtersteller
  • Rollen-Zuordnungs-Manager

Diese Rollen können nicht geändert oder gelöscht werden. Sie können aber kopiert und als Basis für benutzerdefinierte Rollen verwendet werden.

SuperUser

Die Rolle SuperUser ist eine spezielle Rolle, die sämtliche Berechtigungen über Silk Central hinweg erhält.

Administrator

Zu den Aufgaben eines Administrators gehört das Konfigurieren von Anwendungs-, Web- und Diagrammservergruppen, das Einrichten und Verwalten von Repositorys und Benachrichtigungseinstellungen, das Erstellen von Konten, das Konfigurieren von Servergruppen und Ausführungsservern usw.

Administratoren haben uneingeschränkten Zugriff auf Silk Central und Issue Manager.

Projektmanager

Projektmanager verwalten die Projekte, für die sie verantwortlich sind. Projektmanager haben keine Schreibberechtigungen im Bereich Silk Central-Verwaltung. Projektmanager können nur auf die Projekte zugreifen, denen sie als Projektmanager zugeordnet wurden. Bei diesen Projekten haben sie uneingeschränkten Schreibzugriff auf alle projektbezogenen Features. Projektmanager verfügen auch über alle Issue Manager-Berechtigungen für Projekte, die ihnen zugeordnet sind.

Testmanager

Testmanager sind für die Planung und Ausführung von Tests einschließlich des Löschens von Tests verantwortlich. Testmanager haben in Silk Central außerdem vollen Zugriff auf die Bibliotheken gemeinsam verwendbarer Testschritte und Schlüsselwörter, sowie vollen Lesezugriff auf den Bereich Anforderungen.

Tester

Die Tester-Rolle bezieht sich auf Silk Central-Berechtigungen. Zu den Aufgaben der Tester gehört die Planung und Ausführung von Tests. Tester können Tests allerdings nicht löschen. Tester haben außerdem vollen Lesezugriff auf den Bereich Anforderungen und können alle Objekte aus Bibliotheken gemeinsam verwendbarer Testschritte und Schlüsselwörter anzeigen, erstellen und bearbeiten.

Analytiker

Analytiker analysieren die Ergebnisse von Projekten, die ihnen zugeordnet wurden. Sie können weder Projekteinstellungen noch Ausführungstermine ändern und haben nur Leseberechtigungen.

Berichtersteller

Zusätzlich zu sämtlichen Rechten der Analytiker verfügen Berichtersteller auch über die Berechtigung zum Bearbeiten und Löschen von Berichten im Erweiterten Modus. Im erweiterten Modus können Berichtersteller SQL-Anweisungen für erweiterte Berichte eingeben, ändern und löschen. Informationen zu erweiterten Berichten finden Sie in der Silk Central-Hilfe.

Rollen-Zuordnungs-Manager

Rollen-Zuordnungs-Manager besitzen lediglich die Berechtigung, Rollen von Benutzern einer Gruppe zuzuordnen und zu entfernen, und nur Rollen die ihnen selbst auch zugeordnet sind. Sie können einer Gruppe keine Mitglieder hinzufügen oder von ihr entfernen, und sie können nur Rollen-Zuordnungen in Gruppen ändern, in denen sie selbst als Rollen-Zuordnungs-Manager definiert sind.

  • Hinzufügen von Benutzerrollen
    Fügen Sie eine Benutzerrolle hinzu.
  • Bearbeiten von Benutzerrollen
    Bearbeiten Sie eine Benutzerrolle.
  • Kopieren von Benutzerrollen
    Kopieren Sie eine Benutzerrolle, um eine benutzerdefinierte Rolle anzulegen.
  • Löschen von Benutzerrollen
    Löschen Sie eine Benutzerrolle.
  • Rolleneinstellungen (Seite)
    Mithilfe dieser Seite können Sie Benutzerrollen konfigurieren.
Übergeordnetes Thema: Benutzerrollen und Berechtigungen
Zugehörige Konzepte
Super User
Benutzerrollen und Berechtigungen


Hinzufügen von Benutzerrollen

So fügen Sie eine Benutzerrolle hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Rollen.
  3. Klicken Sie auf Neue Rolle.

    Die Seite Neue Rolle wird angezeigt.

  4. Geben Sie einen Namen für die neue Rolle ein.
  5. Optional: Geben Sie eine Beschreibung für die Rolle ein.
  6. Aktivieren Sie in der Liste Einstellungen für Berechtigungen das Feld Gestatten neben den Berechtigungen, die Sie der Rolle zuweisen möchten.
    Anmerkung: Wenn Sie eine übergeordnete Berechtigung aktivieren, werden automatisch auch alle untergeordneten Berechtigungen aktiviert. Wenn Sie nur einige untergeordnete Berechtigungen auswählen, wird die übergeordnete mit einem grauen Häkchen markiert, um anzuzeigen, dass in diesem Bereich nur Teilberechtigungen bestehen.
  7. Klicken Sie auf Speichern, um die Berechtigungseinstellungen für diese Rolle zu speichern.
Übergeordnetes Thema: Benutzerrollen


Bearbeiten von Benutzerrollen

Anmerkung: Vordefinierte Benutzerrollen können nicht bearbeitet werden. Benutzerdefinierte Rollen können bearbeitet werden.

So bearbeiten Sie eine Benutzerrolle:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Rollen.
  3. Klicken Sie in der Liste Rollen auf den Namen der Rolle, die Sie bearbeiten möchten.

    Die Seite Rolle bearbeiten wird angezeigt.

  4. Bearbeiten Sie ggf. den Namen der Rolle.
  5. Bearbeiten Sie ggf. die Beschreibung der Rolle.
  6. Aktivieren Sie in der Liste Einstellungen für Berechtigungen die Kontrollkästchen Gestatten für alle Berechtigungen, die Sie der Rolle zuweisen möchten. Deaktivieren Sie ausgewählte Berechtigungen, die für diese Rolle nicht gelten sollen.
    Anmerkung: Wenn Sie eine übergeordnete Berechtigung aktivieren, werden automatisch auch alle untergeordneten Berechtigungen aktiviert. Wenn Sie nur einige untergeordnete Berechtigungen auswählen, wird die übergeordnete mit einem grauen Häkchen markiert, um anzuzeigen, dass in diesem Bereich nur Teilberechtigungen bestehen.
  7. Klicken Sie auf Speichern, um die Berechtigungseinstellungen für diese Rolle zu speichern.
Übergeordnetes Thema: Benutzerrollen


Kopieren von Benutzerrollen

Tipp: Um eine benutzerdefinierte Rolle anzulegen, kopieren Sie zunächst eine vorhandene Benutzerrolle. Nach dem Kopieren benennen Sie die Rolle um und bearbeiten deren Berechtigungen entsprechend Ihren Vorstellungen.

So kopieren Sie eine Benutzerrolle:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Rollen.
  3. Klicken Sie in der Spalte Aktionen zu der Benutzerrolle, die Sie kopieren möchten, auf Rolle duplizieren. Die Kopie der Rolle wird daraufhin in der Benutzerrollenliste angezeigt. Hier können Sie sie umbenennen und anpassen.
Übergeordnetes Thema: Benutzerrollen


Löschen von Benutzerrollen

Anmerkung: Vordefinierte Benutzerrollen können nicht gelöscht werden. Benutzerdefinierte Rollen können gelöscht werden.

So löschen Sie eine Benutzerrolle:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Rollen.
  3. Klicken Sie in der Spalte Aktionen der Benutzerrolle, die Sie entfernen möchten, auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  4. Klicken Sie auf Ja, um den Vorgang zu bestätigen; klicken Sie auf Nein, um ihn abzubrechen. Wenn Sie auf Ja klicken, wird wieder die Liste der Benutzerrollen angezeigt. Die gelöschte Rolle ist nicht mehr vorhanden.
Übergeordnetes Thema: Benutzerrollen


Rolleneinstellungen (Seite)

Administration > Benutzerverwaltung > Rollen

Mithilfe der Seite Rolleneinstellungen können Sie Benutzerrollen konfigurieren. Die Seite enthält folgende Elemente:

Element | Beschreibung
Aktionen | Klicken Sie auf Rolle duplizieren , um eine Rolle zu duplizieren und die Kopie als Grundlage für eine neue benutzerdefinierte Rolle zu verwenden. Klicken Sie auf Rolle löschen , um eine Benutzerrolle zu löschen.
Name | Der Name der Benutzerrolle, so wie er auf der Benutzeroberfläche angezeigt wird.
Neue Zuweisung gestatten | Mit dieser Option können Sie zulassen bzw. verhindern, dass eine vorhandene Benutzerrolle neue Benutzerzuordnungen akzeptiert. Dies ist sinnvoll, wenn eine nicht mehr verfügbare Benutzerrolle noch von einigen Benutzerkonten verwendet wird.
Beschreibung | Eine Beschreibung der Benutzerrolle.
Erstellt am | Das Datum, an dem die Rolle erstellt wurde.
Erstellt von | Der Name des Benutzers, der die Rolle erstellt hat.
Übergeordnetes Thema: Benutzerrollen


Definitionen von Berechtigungen

So zeigen Sie die Berechtigungen in Silk Central an: Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung. Klicken Sie auf die Registerkarte Rollen. Klicken Sie in der Tabelle auf eine Rolle. Die Berechtigungen für diese Rolle werden angezeigt.

In diesem Abschnitt werden die Berechtigungen erläutert, die das Ausführen von Aufgaben und den Zugriff auf sichere Bereiche von Silk Central abdecken. Für jede Berechtigungskategorie ist eine eigene Liste vorhanden.

Anmerkung: Berechtigungen für vordefinierte Rollen können nicht bearbeitet werden.
  • Anforderungsberechtigungen
    Führt die Berechtigungen auf, die für Anforderungen zur Verfügung stehen.
  • Bibliotheksberechtigungen
    Führt die Berechtigungen auf, die für Bibliotheken zur Verfügung stehen.
  • Berechtigungen für Tests und Ausführungen
    Führt die Berechtigungen auf, die für Tests und Ausführungen zur Verfügung stehen.
  • Berechtigungen für die manuelle Ausführungsplanung
    Hier werden die Berechtigungen aufgeführt, die für die manuelle Ausführungsplanung verfügbar sind.
  • Fehler – Berechtigungen
    Führt die Berechtigungen auf, die für Fehler zur Verfügung stehen.
  • Berechtigungen für Qualitätskriterien
    Hier wird eine Liste mit den Berechtigungen angezeigt, die für Qualitätsziele zur Verfügung stehen.
  • Berechtigungen für Berichte
    Führt die Berechtigungen auf, die für Berichte zur Verfügung stehen.
  • Projektberechtigungen
    Führt die Berechtigungen auf, die für Projekte zur Verfügung stehen.
  • Berechtigungen für Projekteinstellungen
    Führt die Berechtigungen auf, die für Projekteinstellungen verfügbar sind.
  • Verwaltungsberechtigungen
    Führt die Berechtigungen auf, die für Verwaltungszwecke zur Verfügung stehen.
  • Berechtigungen für Dashboard-Panel
    In diesem Abschnitt wird beschrieben, welche Berechtigungen für die Anzeige oder zum Bearbeiten der Inhalte eines bestimmten Panels erforderlich sind.
Übergeordnetes Thema: Benutzerrollen und Berechtigungen
Zugehörige Verweise
Mandantenberechtigungen


Anforderungsberechtigungen

Die folgenden Berechtigungen sind für Anforderungen verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Anzeigen von Anforderungen |  | X |  | X | X | X | X
Verwalten von Anforderungen |  | X |  |  |  |  |
Löschen von Anforderungen |  | X |  |  |  |  |
Verwalten von Anforderungsverwaltungs-Integrationen |  | X |  |  |  | X |
Löschen von Anforderungsverwaltungs-Integrationen |  | X |  |  |  |  |
Übergeordnetes Thema: Definitionen von Berechtigungen


Bibliotheksberechtigungen

Die folgenden Berechtigungen sind für Bibliotheken verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Anzeigen von Bibliotheken |  | X |  | X | X | X | X
Verwalten von Bibliotheken |  |  |  |  | X | X |
Löschen von Bibliotheken |  |  |  |  |  | X |
Übergeordnetes Thema: Definitionen von Berechtigungen


Berechtigungen für Tests und Ausführungen

Die folgenden Berechtigungen sind für Tests und Ausführungen verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Anzeigen |  | X |  | X | X | X | X
Verwalten |  |  |  |  | X | X |
Löschen |  |  |  |  |  | X |
Ausführungen starten |  |  |  |  | X | X |
Ausführungen beenden |  |  |  |  | X | X |
Ausführen von Tests |  |  |  |  | X | X |
Manuelle Tests während Ausführung synchronisieren |  |  |  |  | X | X |
Testsuiteläufe löschen |  |  |  |  | X | X |
Verwalten der Versionsverwaltungs-Integrationen |  | X |  |  |  | X |
Löschen von Versionsverwaltungs-Integrationen |  | X |  |  |  | X |
Übergeordnetes Thema: Definitionen von Berechtigungen


Berechtigungen für die manuelle Ausführungsplanung

Die folgenden Berechtigungen sind für die manuelle Ausführungsplanung verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Anzeigen von Testzyklen und Konfigurationen |  | X |  | X | X | X | X
Verwalten von Testzyklen und Konfigurationen |  |  |  |  |  | X |
Löschen von Testzyklen und Konfigurationen |  |  |  |  |  | X |
Übergeordnetes Thema: Definitionen von Berechtigungen


Fehler – Berechtigungen

Die folgenden Berechtigungen sind für Fehler verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Verwalten der Fehlerverfolgungs-Integrationen |  | X |  |  |  | X |
Löschen von Fehlerverfolgungs-Integrationen |  | X |  |  |  | X |
Übergeordnetes Thema: Definitionen von Berechtigungen


Berechtigungen für Qualitätskriterien

Die folgenden Berechtigungen sind für Qualitätsziele verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Anzeigen von Qualitätszielen |  | X |  | X | X | X | X
Verwalten von Qualitätszielen |  | X |  |  |  | X |
Löschen von Qualitätszielen |  | X |  |  |  | X |
Übergeordnetes Thema: Definitionen von Berechtigungen


Berechtigungen für Berichte

Die folgenden Berechtigungen sind für Berichte verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Anzeigen von Berichten |  | X |  | X | X | X | X
Verwalten von Berichten |  | X |  |  | X | X | X
Verwalten erweiterter Berichte |  |  |  |  |  |  | X
Löschen von Berichten |  | X |  |  | X | X | X
Gemeinsam verwendbare globale Berichte verwalten |  |  |  |  |  |  | X
Gemeinsam verwendbare globale Berichte löschen |  |  |  |  |  |  | X

Berechtigungen für gemeinsam verwendbare globale Berichte

Da gemeinsam verwendbare globale Berichte in allen Projekten und für alle Benutzer verwendbar sind, benötigen Benutzerrollen mit den Rechten solche Berichte zu ändern oder zu löschen spezielle Berechtigungen: Gemeinsam verwendbare globale Berichte verwalten und Gemeinsam verwendbare globale Berichte löschen. Diese Berechtigungen gelten auch für Berichtsvorlagen die in gemeinsam verwendbaren globalen Berichten verwendet werden. Globale Berichte und Berichtsvorlagen, die anderen Benutzern nicht zur Verfügung stehen, können von Benutzerrollen mit den Standardberechtigungen für das Verwalten von Berichten bearbeitet und gelöscht werden. Dadurch ergeben sich folgende Spezialfälle:
  • Besitzt ein Benutzer nicht die Berechtigung Gemeinsam verwendbare globale Berichte verwalten, so ist das Kontrollkästchen Diesen Bericht anderen Benutzern zur Verfügung stellen in globalen Berichten und Ordnern deaktiviert.
  • Wenn ein gemeinsam verwendbarer Bericht kopiert und in die Hierarchie Globale Berichte eingefügt wird, ohne dass der Benutzer die Berechtigung Gemeinsam verwendbare globale Berichte verwalten besitzt, wird der Bericht auf nicht-gemeinsam-verwendbar umgestellt.
Übergeordnetes Thema: Definitionen von Berechtigungen


Projektberechtigungen

Die folgenden Berechtigungen sind für Projekte verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Verwalten von Projekten |  | X |  |  |  | X |
Löschen von Projekten |  | X |  |  |  | X |
Übergeordnetes Thema: Definitionen von Berechtigungen


Berechtigungen für Projekteinstellungen

Die folgenden Berechtigungen sind für Projekteinstellungen verfügbar:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Anzeigen der Projekteinstellungen |  | X |  | X | X | X | X
Projekteinstellungen verwalten |  | X |  |  | X | X |
Löschen von Projekteinstellungen |  | X |  |  |  | X |
Verwalten der Filter |  | X |  |  | X | X |
Löschen von Filtern |  | X |  |  | X | X |
Bearbeiten der privaten Filter anderer Benutzer |  | X |  |  |  | X |
Löschen der privaten Filter anderer Benutzer |  | X |  |  |  | X |
Zuordnungsdateien für Office-Import bearbeiten |  | X |  |  |  | X |
Übergeordnetes Thema: Definitionen von Berechtigungen


Verwaltungsberechtigungen

Die folgenden Berechtigungen stehen für die Verwaltung zur Verfügung:

 | Administrator | Projektmanager | Rollen-Zuordnungs-Manager | Analytiker | Tester | Testmanager | Berichtersteller
Anzeigen von Systemeinstellungen | X | X |  |  |  | X | X
Verwalten von Systemeinstellungen | X |  |  |  |  |  |
Anzeigen von Verwaltungseinstellungen | X | X | X |  |  | X | X
Verwalten von Verwaltungseinstellungen | X |  |  |  |  |  |
Verwalten der Rollen-Zuordnungen von Benutzern | X |  | X |  |  |  |
Löschen von Verwaltungseinstellungen | X |  |  |  |  |  |
Anzeigen und Löschen von Log-Dateien | X | X |  |  |  | X | X
Verwalten von Ausführungsservern | X |  |  |  |  |  |
Löschen von Ausführungsservern | X |  |  |  |  |  |
Aktivieren und Deaktivieren von Ausführungsservern | X |  |  |  |  |  |
Anzeigen von Produkten, Versionen und Builds | X | X |  |  |  | X | X
Verwalten von Produkten, Versionen und Builds | X |  |  |  |  |  |
Löschen von Produkten, Versionen und Builds | X |  |  |  |  |  |
Übergeordnetes Thema: Definitionen von Berechtigungen


Benutzerkonten und Gruppen

Für jeden Benutzer, der mit Silk Central arbeitet, muss ein Benutzerkonto angelegt werden. Eine oder mehrere Gruppen von Benutzern werden bestimmten Projekten zugeordnet. Nur mit einem Benutzerkonto, einer Benutzerrolle und einer Gruppenzuordnung kann ein Benutzer mit einem Silk Central-Projekt arbeiten.

  • Verwalten von Benutzerkonten
    Hier wird beschrieben, wie Sie Benutzerkonten verwalten können.
  • Verwalten von Gruppen
    Hier wird beschrieben, wie Gruppen verwaltet werden.
Übergeordnetes Thema: Verwaltung


Verwalten von Benutzerkonten

Benutzerkonten enthalten die Anmeldedaten und Konfigurationseinstellungen für einzelne Benutzer. Sie aktivieren auch die Anmeldung des Benutzers. Benutzerkonten werden Gruppenkonten mit einer oder mehreren Benutzerrollen für bestimmte Projekte zugeordnet. Die Benutzerrolle <i>SuperUser</i> ist die einzige Rolle, die u. a. Anwendungs-, Web- und Diagrammservergruppen konfigurieren sowie Repositories und Benachrichtigungseinstellungen anlegen und warten kann.

ACHTUNG:
Weil das SuperUser-Konto admin über alle Administratorrechte verfügt, sollten Sie sofort ein neues Kennwort für diesen Benutzer festlegen, um einen uneingeschränkten Zugriff auf diese Berechtigungen zu verhindern. Weitere Informationen zum Ändern des Kennworts finden Sie unter Ändern des Kennworts für das Systemadministrator-Konto.
  • Hinzufügen von Benutzerkonten
    Erstellen Sie in Silk Central ein Benutzerkonto.
  • Bearbeiten von Benutzerkonten
    Bearbeiten Sie ein Benutzerkonto in Silk Central.
  • Löschen von Benutzerkonten
    Löschen Sie ein Benutzerkonto.
  • Benutzereinstellungen (Seite)
    Mithilfe dieser Seite können Sie Benutzerkonten konfigurieren.
Übergeordnetes Thema: Benutzerkonten und Gruppen


Hinzufügen von Benutzerkonten

So fügen Sie ein Benutzerkonto hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Konten. Auf der Seite werden alle vorhandenen Benutzerkonten angezeigt. Wenn Sie diese Seite zum ersten Mal öffnen, ist das SuperUser-Konto admin das einzige Benutzerkonto.
  3. Klicken Sie auf Neuer Benutzer. Die Seite für das Hinzufügen neuer Benutzerkonten wird angezeigt.
  4. Geben Sie einen Benutzernamen und ein Kennwort für den Benutzer ein. Geben Sie zur Bestätigung das Kennwort ein zweites Mal ein.
  5. Aktivieren Sie das Kontrollkästchen Authentifizierung im gemischten Modus (LDAP), um sowohl die LDAP- als auch die auf lokalen Informationen basierende Authentifizierung zu aktivieren.
  6. Setzen Sie die Anmeldung auf Gesperrt, wenn Sie verhindern wollen, dass sich der Benutzer anmeldet.
  7. Geben Sie den Vornamen, den Nachnamen sowie die E-Mail-Adresse des Benutzers ein.
  8. Geben Sie die lokale Zeitzone des Benutzers ein, und wählen Sie ein Datumsformat, ein kurzes Datumsformat und den ersten Tag der Woche.
  9. Geben Sie das Seitenaktualisierungsintervall (in Sekunden), das CSV-Trennzeichen und den Standardausführungsserver an.
  10. Wählen Sie in dem jeweiligen Listenfeld eine Gruppen- und Rollendefinition aus.
  11. Klicken Sie auf Zuordnung hinzufügen, um dem Benutzerkonto eine Gruppen- und Rollenkombination hinzuzufügen.
  12. Wiederholen Sie die beiden vorigen Schritte, um dem Benutzerkonto alle gewünschten Gruppen- und Rollenkombinationen hinzuzufügen.
  13. Wenn Sie eine Gruppen- und Rollenkombination aus dem aktuellen Benutzerkonto entfernen möchten, klicken Sie in der Spalte Aktionen auf das Symbol Löschen.
  14. Klicken Sie auf Speichern, um Ihre Einstellungen zu speichern.
Übergeordnetes Thema: Verwalten von Benutzerkonten
Zugehörige Konzepte
Datums- und Zeitformate
Zugehörige Tasks
Bearbeiten von Benutzerkonten
Löschen von Benutzerkonten


Bearbeiten von Benutzerkonten

Ist ein Benutzerkonto einmal eingerichtet, können Sie jeden seiner Parameter, den Benutzernamen ausgenommen, bearbeiten.

Anmerkung: Die Änderungen eines Benutzerkontos werden erst mit der nächsten Anmeldung mit diesem Benutzerkonto wirksam. Fordern Sie den Benutzer bitte auf, sich ab- und dann wieder anzumelden.

So bearbeiten Sie ein Benutzerkonto:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Konten. Auf der Seite werden alle vorhandenen Benutzerkonten angezeigt. Wenn Sie diese Seite zum ersten Mal öffnen, ist das SuperUser-Konto admin das einzige Benutzerkonto.
  3. Klicken Sie auf den Benutzernamen des Benutzerkontos, das Sie bearbeiten möchten. Die Seite für die Konfiguration des Benutzerkontos wird angezeigt.
  4. Bearbeiten Sie das Kennwort wie gewünscht. Geben Sie zur Bestätigung das Kennwort ein zweites Mal ein.
  5. Aktivieren Sie das Kontrollkästchen Authentifizierung im gemischten Modus (LDAP), um sowohl die LDAP- als auch die auf lokalen Informationen basierende Authentifizierung zu aktivieren.
  6. Bearbeiten Sie, soweit erforderlich, die anderen Benutzereinstellungen.
  7. Wählen Sie in dem jeweiligen Listenfeld eine Gruppen- und Rollendefinition aus.
  8. Klicken Sie auf Zuordnung hinzufügen, um dem Benutzerkonto eine Gruppen- und Rollenkombination hinzuzufügen.
  9. Wiederholen Sie die beiden vorigen Schritte, um dem Benutzerkonto alle gewünschten Gruppen- und Rollenkombinationen hinzuzufügen.
  10. Wenn Sie eine Gruppen- und Rollenkombination aus dem aktuellen Benutzerkonto entfernen möchten, klicken Sie in der Spalte Aktionen auf Löschen.
  11. Klicken Sie auf Speichern, um Ihre Einstellungen zu speichern.
Übergeordnetes Thema: Verwalten von Benutzerkonten
Zugehörige Konzepte
Datums- und Zeitformate
Zugehörige Tasks
Hinzufügen von Benutzerkonten
Löschen von Benutzerkonten


Löschen von Benutzerkonten

ACHTUNG:
Die Löschung eines Benutzerkontos kann nicht rückgängig gemacht werden. Wenn Sie ein Benutzerkonto temporär unzugänglich machen möchten, können Sie das Konto sperren statt es zu löschen. Weitere Informationen zum Sperren von Benutzerkonten finden Sie unter Bearbeiten von Benutzerkonten.

So löschen Sie ein Benutzerkonto:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Konten. Auf der Seite werden alle vorhandenen Benutzerkonten angezeigt. Wenn Sie diese Seite zum ersten Mal öffnen, ist das SuperUser-Konto admin das einzige Benutzerkonto.
  3. Klicken Sie in der Spalte Aktionen des Benutzerkontos, das Sie entfernen möchten, auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  4. Klicken Sie auf Ja, um den Vorgang zu bestätigen; klicken Sie auf Nein, um ihn abzubrechen. Wenn Sie auf Ja klicken, wird wieder die Liste der Benutzerkonten angezeigt. Das gelöschte Konto ist nicht mehr vorhanden.
Übergeordnetes Thema: Verwalten von Benutzerkonten
Zugehörige Konzepte
Datums- und Zeitformate
Zugehörige Tasks
Hinzufügen von Benutzerkonten
Bearbeiten von Benutzerkonten


Benutzereinstellungen (Seite)

Verwaltung > Benutzerverwaltung > Konten > Neuer Benutzer/Benutzer bearbeiten

Mithilfe der Seite Benutzereinstellungen können Sie Benutzerkonten konfigurieren. Die Einstellungen für Benutzer stehen in engem Zusammenhang mit den Einstellungen für Gruppenkonten.

Sie können im Menü auf den Namen des Benutzers klicken, um die Seite Benutzereinstellungen für den angemeldeten Benutzer aufzurufen.

Anmerkung: Sie müssen mindestens eine Gruppen- und Rollenzuordnung definieren, um ein Benutzerkonto speichern zu können.
Anmeldedaten | Beschreibung
Anmeldung | Der Benutzername, der im Silk Central-Repository gespeichert werden soll. Wenn Sie Authentifizierung im gemischten Modus (LDAP) aktivieren, muss der eingegebene Benutzername mit dem definierten LDAP-Benutzernamen übereinstimmen.
Kennwort | Geben Sie ein gültiges Kennwort für den im Feld Benutzerdaten angegebenen Benutzer ein. Dieses Kennwort bezieht sich nicht auf das LDAP-Kennwort.
Kennwort bestätigen | Geben Sie das Kennwort zur Bestätigung noch einmal ein.
Authentifizierung im gemischten Modus (LDAP) | Aktivieren Sie dieses Kontrollkästchen, um sowohl die LDAP-Authentifizierung als auch die auf lokalen Benutzerdaten basierende Authentifizierung zu aktivieren. Wenn ein LDAP-Server vorhanden ist und Sie dieses Kontrollkästchen nicht markieren, ist nur die LDAP-Authentifizierung möglich.
Gesperrt | Aktivieren Sie dieses Kontrollkästchen, wenn Sie verhindern möchten, dass sich der Benutzer mit den gegebenen Benutzerdaten anmeldet. Das Benutzerkonto wird dadurch deaktiviert.
Allgemeine Daten | Beschreibung
Vorname | Geben Sie den Vornamen des Benutzers ein. Diese Angabe hat keinen Einfluss auf das Verhalten von Silk Central; sie dient lediglich zum Aufzeichnen der Benutzerkontaktdaten.
Nachname | Geben Sie den Nachnamen des Benutzers ein. Diese Angabe hat keinen Einfluss auf das Verhalten von Silk Central; sie dient lediglich zum Aufzeichnen der Benutzerkontaktdaten.
E-Mail | Geben Sie die E-Mail-Adresse des Benutzers ein. Diese Information wird für Benachrichtigungen verwendet.
Design | Wählen Sie eine Silk Central-Version aus, um das entsprechende Farbschema festzulegen, in welchem die Silk Central-Benutzeroberfläche für den ausgewählten Benutzer angezeigt wird.
Zeitzone | Die Zeitzone, in der sich der Benutzer befindet. Die Angabe der Zeitzone wird verwendet, um Zeit- und Datumsangaben in der lokalen Zeitzone des Benutzers anzuzeigen.
Datumsformat | Das gewählte Datumsformat wird in Listen, Berichten und im Kalender verwendet, wenn Silk Central ein langes Datumsformat anzeigt.
Kurzes Datumsformat | Das gewählte Datumsformat wird in Listen, Berichten und im Kalender verwendet, wenn Silk Central ein kurzes Datumsformat anzeigt.
Erster Tag der Woche | Der erste Tag der Woche bestimmt die Wochenansicht in Berichten.
CSV-Trennzeichen | Dieser String wird als Zeilentrennzeichen für die vom Benutzer heruntergeladenen CSV-Dateien verwendet. Berichte können als CSV-Dateien heruntergeladen werden.
Standard-Ausführungsserver | Der Standard-Ausführungsserver wird für Probeläufe automatisierter Tests eingesetzt.
Gruppen- und Rollenzuordnungen (Element) | Beschreibung
Gruppen- und Rollenzuordnungen (Tabelle) | Listet alle für den Benutzer vorhandenen Zuordnungen von Benutzergruppen/Benutzerrollen auf. Sie können Gruppen- und Rollenzuordnungen auch löschen, indem Sie auf Löschen neben der zu löschenden Zuordnung klicken.
Gruppe | Wählen Sie eine Gruppe aus, der dieser Benutzer zugeordnet werden soll. Dieses Listenfeld enthält die Benutzergruppen, die von einem Silk Central-Administrator definiert wurden. Gruppen die aus einem LDAP-Server importiert wurden, werden nur angezeigt, wenn der Benutzer diesen zugeordnet ist.
Benutzerrolle | Wählen Sie die Benutzerrolle aus, mit der der Benutzer der gewählten Gruppe zugeordnet werden soll. Die Liste enthält die vordefinierten Systemrollen und die benutzerdefinierten Rollen.
Hinzufügen | Klicken Sie auf diese Schaltfläche, um eine neue Benutzergruppen-/Benutzerrollenzuordnung mit der gewählten Gruppe und der gewählten Rolle zu definieren.
Übergeordnetes Thema: Verwalten von Benutzerkonten


Verwalten von Gruppen

Gruppen definieren den Zugriff auf bestimmte Projekte. Jeder Benutzer kann einer oder mehreren Gruppen zugeordnet werden, von denen er die Zugriffsrechte für die Projekte erbt, die für die gewählte Gruppe definiert wurden.

Anmerkung: Benutzer können zu Gruppen mit mehreren Rollen hinzugefügt werden, wodurch eine erweiterte Konfiguration von Benutzerberechtigungen ermöglicht wird.
  • Hinzufügen von Gruppen
    Erstellen Sie eine Gruppe.
  • Importieren von Gruppen aus LDAP-Servern
    Importieren Sie Gruppen aus LDAP-Servern und lassen Sie sich Ihre Silk Central-Benutzer automatisch erstellen.
  • Ausführungstermine für die automatische LDAP-Synchronisierung planen
    Wenn Sie Benutzergruppen aus LDAP-Servern in Ihr Silk Central-System importiert haben, können Sie einen Ausführungstermin festlegen, zu dem Ihre Silk Central-Gruppen automatisch mit den Änderungen auf dem LDAP-Server synchronisiert werden.
  • Bearbeiten von Gruppen
    Bearbeiten Sie eine Gruppe.
  • Löschen von Gruppen
    Löschen Sie eine Gruppe.
  • Gruppeneinstellungen (Seite)
    Mithilfe dieser Seite können Sie Benutzergruppen konfigurieren.
Übergeordnetes Thema: Benutzerkonten und Gruppen
Zugehörige Konzepte
Verwalten von Servergruppen
Benutzerrollen und Berechtigungen
Zugehörige Tasks
Hinzufügen von Projekten
Initialisieren von Projekten als Issue Manager-Projekte
Bearbeiten von Projekten oder Projekt-Baselines


Hinzufügen von Gruppen

So fügen Sie eine Gruppe hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Gruppen.
  3. Klicken Sie auf Neue Gruppe.
  4. Geben Sie im Feld Gruppenname einen Namen für die neue Gruppe ein.
  5. Geben Sie im Feld Beschreibung eine Beschreibung für die neue Gruppe ein.
  6. Wählen Sie in der jeweiligen Liste einen Benutzer mit einer Rollenzuordnung aus, und klicken Sie dann auf Auswahl hinzufügen, um der neuen Gruppe die Benutzer-/Rollenkombination hinzuzufügen.
    Anmerkung: Benutzerrollen, die so definiert sind, dass sie keine neuen Benutzerzuordnungen akzeptieren, werden nicht in der Liste angezeigt. Diese Einstellungen werden über die Schaltfläche Neue Zuweisung gestatten unter Verwaltung > Benutzerverwaltung > Rollen gesteuert.

    Für Gruppen die von einem LDAP-Server importiert wurden, können den Benutzern weitere Rollen zugewiesen werden und Rollenzuweisungen können auch entfernt werden, es muss jedoch mindestens eine Rollenzuweisung pro Benutzer vorhanden sein. Das Entfernen von Benutzern aus einer LDAP-importierten Gruppe kann nur auf dem LDAP-Server selbst durchgeführt werden.

  7. Wiederholen Sie diese Schritte, um alle gewünschten Benutzer- und Rollenkombinationen der Gruppe hinzuzufügen.
    Tipp: Es kann hilfreich sein, einem oder mehreren Benutzern der Gruppe die Rolle Rollen-Zuordnungs-Manager zuzuweisen. Rollen-Zuordnungs-Manager besitzen lediglich die Berechtigung, Rollen von Benutzern einer Gruppe zuzuordnen und zu entfernen, und nur Rollen die ihnen selbst auch zugeordnet sind. Sie können einer Gruppe keine Mitglieder hinzufügen oder von ihr entfernen, und sie können nur Rollen-Zuordnungen in Gruppen ändern, in denen sie selbst als Rollen-Zuordnungs-Manager definiert sind.
  8. Wenn Sie eine Benutzer- und Rollenkombination aus der aktuellen Gruppe entfernen möchten, klicken Sie in der Spalte Aktionen auf Löschen.
  9. Im Bereich Projektzuordnung(en) können Sie dieser Gruppe jedes vorhandene Projekt zuordnen.
  10. Klicken Sie auf Speichern.
Übergeordnetes Thema: Verwalten von Gruppen


Importieren von Gruppen aus LDAP-Servern

Importieren Sie Gruppen aus LDAP-Servern und lassen Sie sich Ihre Silk Central-Benutzer automatisch erstellen.
Bevor Sie Gruppen aus LDAP-Servern importieren können, muss zuerst ein LDAP-Server konfiguriert werden. Weitere Informationen finden Sie unter Hinzufügen von LDAP-Servern.
So importieren Sie LDAP-Gruppen und ihre zugewiesenen Benutzer in Silk Central:
  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Gruppen.
  3. Klicken Sie auf LDAP-Gruppe importieren. Der Dialog LDAP-Gruppe importieren wird geöffnet.
  4. Wenn Ihr LDAP-Server für die Verwendung einer Domäne konfiguriert wurde, wählen Sie eine LDAP-Domäne aus, wenn sich die importierten Benutzer mit dem Muster <Domäne>\<Benutzername> auf Silk Central anmelden sollen. Wählen Sie die Standard-Domäne aus, wenn sich die importierten Benutzer ohne Domänennamen auf Silk Central anmelden sollen.
  5. Wählen Sie den LDAP-Gruppe aus, die Sie importieren möchten.
  6. Wählen Sie die Silk Central Rolle aus. Alle Benutzer der ausgewählten LDAP-Gruppe werden mit dieser Rolle angelegt.
  7. Klicken Sie auf OK.
Nachdem Sie eine LDAP-Gruppe importiert haben, empfiehlt es sich die Gruppen-Einstellungen zu kontrollieren, insbesondere die Projektzuordnungen. Beachten Sie, dass keine Benutzer einer LDAP-Gruppe hinzugefügt oder von ihr entfernt werden können, da diese Zuordnung explizit nur über den LDAP-Server selbst gehandhabt wird. Sie können jedoch die Rollen der einzelnen Benutzer anpassen.
Tipp: Es kann hilfreich sein, einem oder mehreren Benutzern der Gruppe die Rolle Rollen-Zuordnungs-Manager zuzuweisen. Rollen-Zuordnungs-Manager besitzen lediglich die Berechtigung, Rollen von Benutzern einer Gruppe zuzuordnen und zu entfernen, und nur Rollen die ihnen selbst auch zugeordnet sind. Sie können einer Gruppe keine Mitglieder hinzufügen oder von ihr entfernen, und sie können nur Rollen-Zuordnungen in Gruppen ändern, in denen sie selbst als Rollen-Zuordnungs-Manager definiert sind.

Sämtliche aus LDAP-Servern importierte Gruppen werden automatisch aktualisiert. Weitere Informationen über die Änderung oder die Deaktivierung dieses Ausführungstermins finden Sie unter Ausführungstermine für die automatische LDAP-Synchronisierung planen.

Übergeordnetes Thema: Verwalten von Gruppen
Zugehörige Tasks
Hinzufügen von Projekten
Bearbeiten von Projekten oder Projekt-Baselines
Hinzufügen von LDAP-Servern
Ausführungstermine für die automatische LDAP-Synchronisierung planen


Bearbeiten von Gruppen

So bearbeiten Sie eine Gruppe:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Gruppen.
  3. Klicken Sie auf den Namen der Gruppe, die Sie bearbeiten möchten. Die Seite für die Konfiguration des Gruppenkontos wird angezeigt.
  4. Bearbeiten Sie ggf. den Namen im Feld Gruppenname. Bei Gruppen die von einem LDAP-Server importiert wurden, kann dieses Feld nicht bearbeitet werden.
  5. Bearbeiten Sie ggf. im Feld Beschreibung die Beschreibung der Gruppe.
  6. Wählen Sie in der jeweiligen Liste einen Benutzer mit einer Rollenzuordnung aus, und klicken Sie dann auf Auswahl hinzufügen, um der neuen Gruppe die Benutzer-/Rollenkombination hinzuzufügen.
    Anmerkung: Benutzerrollen, die so definiert sind, dass sie keine neuen Benutzerzuordnungen akzeptieren, werden nicht in der Liste angezeigt. Diese Einstellungen werden über die Schaltfläche Neue Zuweisung gestatten unter Verwaltung > Benutzerverwaltung > Rollen gesteuert.

    Für Gruppen die von einem LDAP-Server importiert wurden, können den Benutzern weitere Rollen zugewiesen werden und Rollenzuweisungen können auch entfernt werden, es muss jedoch mindestens eine Rollenzuweisung pro Benutzer vorhanden sein. Das Entfernen von Benutzern aus einer LDAP-importierten Gruppe kann nur auf dem LDAP-Server selbst durchgeführt werden.

  7. Wiederholen Sie diese Schritte, um alle gewünschten Benutzer- und Rollenkombinationen der Gruppe hinzuzufügen.
    Tipp: Es kann hilfreich sein, einem oder mehreren Benutzern der Gruppe die Rolle Rollen-Zuordnungs-Manager zuzuweisen. Rollen-Zuordnungs-Manager besitzen lediglich die Berechtigung, Rollen von Benutzern einer Gruppe zuzuordnen und zu entfernen, und nur Rollen die ihnen selbst auch zugeordnet sind. Sie können einer Gruppe keine Mitglieder hinzufügen oder von ihr entfernen, und sie können nur Rollen-Zuordnungen in Gruppen ändern, in denen sie selbst als Rollen-Zuordnungs-Manager definiert sind.
  8. Wenn Sie eine Benutzer- und Rollenkombination aus der aktuellen Gruppe entfernen möchten, klicken Sie in der Spalte Aktionen auf Löschen.
  9. Für Gruppen die von einem LDAP-Server importiert wurden, klicken Sie auf Mit LDAP synchronisieren, um allfällige Änderungen auf dem LDAP-Server mit Silk Central zu synchronisieren. Wenn ein Benutzer aus der Gruppe auf dem LDAP-Server entfernt wurde, werden sämtliche Rollenzuordnungen von der Gruppe entfernt. Wenn ein Benutzer zur Gruppe auf dem LDAP-Server hinzugefügt wurde, wird eine neue Rollenzuordnung mit der Standardrolle erstellt. Alle anderen Rollenzuordnungen bleiben unverändert.
    Anmerkung: Gruppenzuordnungen werden automatisch synchronisiert, sobald sich ein Benutzer auf Silk Central anmeldet.
  10. Im Bereich Projektzuordnung(en) können Sie dieser Gruppe jedes vorhandene Projekt zuordnen.
  11. Klicken Sie auf Speichern, um zur Seite Gruppen zurückzukehren.
Übergeordnetes Thema: Verwalten von Gruppen
Zugehörige Tasks
Löschen von Gruppen


Löschen von Gruppen

Sie können eine Gruppe erst löschen, nachdem alle Benutzer- und Rollenzuordnungen der Gruppe entfernt wurden. Diese Einschränkung trifft nicht auf Gruppen zu, die von einem LDAP-Server importiert wurden. Weitere Informationen über das Ändern von Gruppen finden Sie unter Bearbeiten von Gruppen.

So löschen Sie eine Gruppe:

  1. Klicken Sie im Menü auf Verwaltung > Benutzerverwaltung.
  2. Klicken Sie auf die Registerkarte Gruppen.
  3. Klicken Sie in der Spalte Aktionen der Gruppe, die Sie entfernen möchten, auf Gruppe löschen. Ein Bestätigungsdialog wird geöffnet.
  4. Klicken Sie auf Ja, um den Vorgang zu bestätigen; klicken Sie auf Nein, um ihn abzubrechen.
Anmerkung: Beim Löschen einer Gruppe, die von einem LDAP-Server importiert wurde, werden sämtliche Benutzer/Rollenzuordnungen auch gelöscht. Hat ein Benutzer einer gelöschten Gruppe keine Zuordnungen in irgendwelchen anderen Gruppen, so wird der Benutzer in Silk Central gelöscht.
Übergeordnetes Thema: Verwalten von Gruppen
Zugehörige Tasks
Bearbeiten von Gruppen


Gruppeneinstellungen (Seite)

Verwaltung > Benutzerverwaltung > Gruppen > Gruppe bearbeiten/Neue Gruppe

Mithilfe der Seite Gruppeneinstellungen können Sie Benutzergruppen konfigurieren. Die Einstellungen für Gruppen hängen eng mit den Einstellungen für Benutzerkonten zusammen. Die Seite enthält folgende Elemente:

Element | Beschreibung
Gruppenname | Gibt den Namen der Gruppe an, wie er in der Benutzeroberfläche angezeigt werden soll. Sie können einer Gruppe einen beliebigen Namen geben.
Beschreibung | Eine Beschreibung der Gruppe. Sie können jeden beliebigen Text als Beschreibung eingeben.
Konto- und Rollenzuordnung(en) | Listet alle für die Gruppe vorhandenen Benutzer/Rollen-Zuordnungen auf. Sie können Konto- und Rollenzuordnungen auch löschen, indem Sie auf Löschen neben der zu löschenden Zuordnung klicken.
Benutzer | Dieses Listenfeld enthält die Benutzerkonten, die von einem Administrator definiert wurden. Wählen Sie einen Benutzer aus, der der Gruppe zugeordnet werden soll.
Rollendefinition | Die Liste enthält die vordefinierten Systemrollen und die benutzerdefinierten Rollen. Wählen Sie die Benutzerrolle aus, mit der der Benutzer der Gruppe zugeordnet werden soll.
Auswahl hinzufügen | Klicken Sie, um eine neue Benutzerkonto- und Benutzerrollenzuordnung mit dem gewählten Benutzer und der gewählten Rolle zu definieren.
Projektzuordnung(en) | Enthält alle vorhandenen Projekte und zeigt an, ob ein Projekt dem Gruppenkonto hinzugefügt wurde. Aktivieren Sie das Kontrollkästchen neben einem Projekt, um das betreffende Projekt dem Gruppenkonto zuzuordnen. Wenn kein Projekt vorhanden ist, können Sie zuerst Projekte erstellen und sie später dem Gruppenkonto zuordnen.
Alles auswählen | Aktiviert die Kontrollkästchen aller aufgeführten Projekte.
Auswahl aufheben | Deaktiviert die Kontrollkästchen aller aufgeführten Projekte.
Übergeordnetes Thema: Verwalten von Gruppen


Ausführungsumgebung

Verwalten Sie die Ausführungsumgebung um festzulegen, wo Silk Central Tests ausgeführt werden. Die Ausführungsumgebung von Silk Central besteht aus physikalischen und virtuellen (Cloud-gehosteten) Ausführungsservern, welche in sogenannte Servergruppen gruppiert sind.

Servergruppen sind Container für Ausführungsserver. Informationen zum Einrichten von Ausführungsservern finden Sie unter Einrichten von Ausführungsservern. Da Silk Central die weltweite Verteilung von Points of Presence (PoPs), also die Verteilung von Ausführungsservern, unterstützt, ist es wünschenswert, Ausführungsserver in Servergruppen zusammenzufassen. Servergruppen müssen sich nicht auf Lokalität beziehen, sondern können einfach dazu verwendet werden, die Ausführungsserver in verwaltbare Einheiten zu gruppieren.

Die Ausführungsserver von Silk Central sind für die Ausführung geplanter Tests, beispielsweise Silk Test Classic- und Silk Performer-Skripts, verantwortlich. Ausführungsserver können entweder physikalische oder virtuelle (Cloud-gehostete) Rechner sein.

  • Verwalten von Servergruppen
    Hier wird das Konzept der Servergruppen in Silk Central beschrieben.
  • Einrichten von Ausführungsservern
    Hier wird das Konzept der Ausführungsserver von Silk Central beschrieben.
  • Cloud Integration
    Hier wird beschrieben, wie Sie Cloud Profile konfigurieren um mit Anbietern von öffentlichen oder privaten Cloud Services zu integrieren.
  • Verwalten von Geräte-Anbietern
    Geräte-Anbieter sind Computer, die als Host für mobile Emulatoren und Simulatoren dienen und/oder physische mobile Geräte angeschlossen haben, auf welche zum Ausführen von Tests zugegriffen werden kann.
Übergeordnetes Thema: Verwaltung


Verwalten von Servergruppen

Servergruppen sind Container für Ausführungsserver. Informationen zum Einrichten von Ausführungsservern finden Sie unter Einrichten von Ausführungsservern. Da Silk Central die weltweite Verteilung von Points of Presence (PoPs), also die Verteilung von Ausführungsservern, unterstützt, ist es wünschenswert, Ausführungsserver in Servergruppen zusammenzufassen. Servergruppen müssen sich nicht auf Lokalität beziehen, sondern können einfach dazu verwendet werden, die Ausführungsserver in verwaltbare Einheiten zu gruppieren.

Anmerkung: Silk Central erstellt automatisch eine Standardservergruppe namens Local.
  • Hinzufügen von Servergruppen
    Erstellen Sie eine neue Servergruppe, um einen Container für Ausführungsserver hinzuzufügen.
  • Bearbeiten von Servergruppen
    Bearbeiten Sie eine Servergruppe.
  • Löschen von Servergruppen
    Löschen Sie eine vorhandene Servergruppe.
  • Neue Servergruppe (Dialog)
    Mithilfe dieses Dialogs können Sie die Einstellungen für eine Servergruppe konfigurieren.
Übergeordnetes Thema: Ausführungsumgebung
Zugehörige Konzepte
Einrichten von Ausführungsservern
Verwalten von Gruppen
Benutzerrollen und Berechtigungen
Zugehörige Tasks
Hinzufügen von Projekten
Initialisieren von Projekten als Issue Manager-Projekte
Bearbeiten von Projekten oder Projekt-Baselines


Hinzufügen von Servergruppen

So fügen Sie eine neue Servergruppe hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Klicken Sie auf Neue Servergruppe.

    Das Dialogfeld Neue Servergruppe wird angezeigt.

  3. Geben Sie einen Namen für die Servergruppe ein.
  4. Wenn Sie für die Servergruppe einen Proxy-Server angegeben haben, dann wählen Sie System-Proxy verwenden, indem Sie das betreffende Kontrollkästchen aktivieren. Weitere Informationen finden Sie unter Konfigurieren eines System-Proxy.
  5. Im Bereich Servergruppen-Proxy können Sie einen Proxy-Server definieren, über den die Ausführungsserver dieser Servergruppe mit dem Anwendungsserver kommunizieren werden.
  6. Geben Sie im Feld Hostname den Namen des Computers an, auf dem der Proxy-Dienst ausgeführt wird.
  7. Geben Sie im Feld Port die Port-Nummer des Proxy-Hosts ein.
  8. Ist für den Proxy-Server eine Authentifizierung mit Benutzernamen und Kennwort erforderlich, dann geben Sie diese Informationen in die Felder Benutzername und Kennwort ein.
  9. Im Bereich Projekte wird eine Liste vorhandener Projekte angezeigt. Aktivieren Sie die Kontrollkästchen Zugeordnet der Projekte, die dieser Servergruppe zugeordnet werden sollen.
  10. Klicken Sie auf OK, um die neue Servergruppe hinzuzufügen.
Übergeordnetes Thema: Verwalten von Servergruppen
Zugehörige Tasks
Konfigurieren eines System-Proxy


Bearbeiten von Servergruppen

Hier wird beschrieben, wie eine Servergruppe bearbeitet wird.

So bearbeiten Sie eine Servergruppe:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Wählen Sie die Servergruppe, die Sie ändern möchten, und klicken Sie auf Bearbeiten.

    Das Dialogfeld Servergruppe bearbeiten wird angezeigt.

  3. Ändern Sie, wenn erforderlich, den Namen der Servergruppe.
  4. Wenn Sie für die Servergruppe einen Proxy-Server angegeben haben, dann wählen Sie System-Proxy verwenden, indem Sie das betreffende Kontrollkästchen aktivieren. Weitere Informationen finden Sie unter Konfigurieren eines System-Proxy.
  5. Im Bereich Servergruppen-Proxy können Sie einen Proxy-Server definieren, über den die Ausführungsserver dieser Servergruppe mit dem Anwendungsserver kommunizieren werden.
  6. Geben Sie im Feld Hostname den Namen des Computers an, auf dem der Proxy-Dienst ausgeführt wird.
  7. Geben Sie im Feld Port die Port-Nummer des Proxy-Hosts ein.
  8. Ist für den Proxy-Server eine Authentifizierung mit Benutzernamen und Kennwort erforderlich, dann geben Sie diese Informationen in die Felder Benutzername und Kennwort ein.
  9. Im Bereich Projekte wird eine Liste vorhandener Projekte angezeigt. Aktivieren Sie die Kontrollkästchen Zugeordnet der Projekte, die dieser Servergruppe zugeordnet werden sollen.
  10. Klicken Sie auf OK.
Übergeordnetes Thema: Verwalten von Servergruppen
Zugehörige Tasks
Konfigurieren eines System-Proxy


Löschen von Servergruppen

Tipp: Sie können eine Servergruppe erst löschen, nachdem alle zugeordneten Ausführungsserver aus der Servergruppe entfernt wurden. Weitere Informationen finden Sie unter Löschen von Ausführungsservern.

So löschen Sie eine Servergruppe:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Wählen Sie die Servergruppe, die Sie löschen möchten, und klicken Sie auf Löschen. Ein Dialogfeld wird geöffnet, in dem Sie das Löschen bestätigen müssen.
  3. Klicken Sie auf Ja, um die Servergruppe zu entfernen, oder klicken Sie auf Nein, um den Vorgang abzubrechen.
Übergeordnetes Thema: Verwalten von Servergruppen
Zugehörige Tasks
Löschen von Ausführungsservern


Neue Servergruppe (Dialog)

Verwaltung > Ausführungsumgebung > Ausführungsserver > Neue Servergruppe

Mithilfe des Dialogs Neue Servergruppe können Sie Servergruppen konfigurieren.

Element | Beschreibung
Name | Gibt den Namen der Servergruppe an, wie er auf der Benutzeroberfläche und in Berichten angezeigt werden soll.
System-Proxy verwenden | Wenn diese Einstellung aktiviert ist, werden alle Ausführungsserver dieser Servergruppe gezwungen, über den definierten System-Proxy mit dem Anwendungsserver zu kommunizieren. Wenn diese Einstellung nicht aktiviert ist, kommuniziert der Anwendungsserver direkt mit den Ausführungsservern, sofern kein Proxy für die Servergruppe definiert wird. Dieses Kontrollkästchen ist deaktiviert, wenn kein System-Proxy definiert ist.
Servergruppen-Proxy

In diesem Bereich können Sie einen Proxy-Server definieren, über den die Ausführungsserver dieser Servergruppe mit dem Anwendungsserver kommunizieren sollen. Lassen Sie die Felder leer, wenn die Ausführungsserver dieser Servergruppe direkt mit dem Anwendungsserver kommunizieren sollen, oder wenn Sie die Option System-Proxy verwenden aktiviert haben. Sie können auch einen System-Proxy und einen Servergruppen-Proxy definieren. In diesem Fall wird die Kommunikation über beide Proxies geleitet.

Der definierte Servergruppen-Proxy muss Secure Sockets Layer (SSL) unterstützen. Alle Ausführungsserver müssen den SSL-Port des Proxy-Servers verwenden. Weitere Informationen zu Ausführungsservereinstellungen finden Sie unter Einrichten von Ausführungsservern.
Hostname | Der Name des Computers, auf dem der Proxy-Dienst installiert ist
Port | Die Port-Nummer des Proxy-Hosts. Der Standardport ist 443.
Benutzername | Wenn der Proxy-Server eine Authentifizierung durch Benutzername- und Kennworteingabe erfordert, geben Sie hier einen gültigen Benutzernamen ein.
Kennwort | Ist für den Proxy-Server eine Authentifizierung durch Benutzernamen und Kennwort erforderlich, dann geben Sie ein gültiges Kennwort für den im Feld Benutzername angegebenen Benutzer ein.
Zugeordnete Projekte | Enthält eine Liste aller vorhandenen Projekte. Aktivieren Sie das Kontrollkästchen neben einem Projekt, um das Projekt der Servergruppe zuzuordnen. Wenn kein Projekt vorhanden ist, können Sie zuerst Projekte erstellen und sie später dem Gruppenkonto zuordnen. Weitere Informationen finden Sie unter Hinzufügen von Projekten. Die ausgewählten Projekte haben Zugriff auf die Ausführungsserver dieser Servergruppe.
Alles auswählen | Aktiviert die Kontrollkästchen aller aufgeführten Projekte.
Auswahl aufheben | Deaktiviert die Kontrollkästchen aller aufgeführten Projekte.
Übergeordnetes Thema: Verwalten von Servergruppen
Zugehörige Tasks
Einrichten von Ausführungsservern
Hinzufügen von Projekten


Einrichten von Ausführungsservern

Die Ausführungsserver von Silk Central sind für die Ausführung geplanter Tests, beispielsweise Silk Test Classic- und Silk Performer-Skripts, verantwortlich. Ausführungsserver können entweder physikalische oder virtuelle (Cloud-gehostete) Rechner sein.

Um Silk Test Classic- und Silk Performer-Tests ausführen zu können, muss die Software Silk Test Classic oder Silk Performer auf dem gleichen Computer installiert sein, auf dem die Silk Central-Ausführungsserver installiert sind.

Beachten Sie den Abschnitt Multibyte Support in der Silk Performer Hilfe, wenn Sie Silk Performer-Skripts für Multibyte-Anwendungen oder Webseiten ausführen.

Weitere Informationen zur Installation von Ausführungsservern finden Sie in Installieren von Silk Central. Für Informationen über Silk Test Classic und Silk Performer, wenden Sie sich an die jeweilige Produktdokumentation.

  • Hardwarebereitstellung mit Schlüsselwörtern
    Hier wird beschrieben, wie Testumgebungen mit einer großen Anzahl an Ausführungsservern verwaltet werden.
  • Konfigurieren physischer Ausführungsserver
    Konfigurieren Sie einen physischen Ausführungsserver.
  • Konfigurieren von Ausführungsservern in der Cloud
    Konfigurieren Sie einen Ausführungsserver in der Cloud.
  • Erstellen und zuweisen von Schlüsselwörtern zu einem Ausführungsserver
    Erstellen Sie neue Ausführungsserver-Schlüsselwörter und weisen Sie sie einem Ausführungsserver zu, um festzulegen, welche Ausführungen auf einem Server vorgenommen werden sollen.
  • Aktivieren bzw. Deaktivieren von Ausführungsservern
    Aktivieren oder deaktivieren Sie einen Ausführungsserver in einer Servergruppe.
  • Löschen von Ausführungsservern
    Löschen Sie einen vorhandenen Ausführungsserver, um die Verbindung des Servers zu Ihrer Anlage zu trennen.
  • Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver
    Konfigurieren Sie einen benutzerdefinierten SSL-Port, über den der Anwendungsserver mit einem Ausführungsserver kommuniziert.
  • Dialog "Neuer Ausführungsserver/Ausführungsserver bearbeiten"
    Hier wird beschrieben, wie Sie die zu einer Servergruppe gehörigen Ausführungsserver konfigurieren.
Übergeordnetes Thema: Ausführungsumgebung
Zugehörige Konzepte
Installieren von Silk Central
Zugehörige Tasks
Installieren eines Windows-Ausführungsservers
Installieren eines Linux-Ausführungsservers


Hardwarebereitstellung mit Schlüsselwörtern

Die Technologie für die Hardwarebereitstellung von Silk Central erleichtert die Verwaltung von Testumgebungen mit zahlreichen Ausführungsservern. Statt auf die Definition direkter 1:1-Beziehungen zwischen den einzelnen Ausführungsservern und Testsuiten angewiesen zu sein, kann Silk Central mithilfe von Schlüsselwörtern automatisch den für eine Testsuite geeigneten Ausführungsserver auswählen. Hierzu werden die Schlüsselwortlisten der einzelnen Testsuiten jeweils mit den Schlüsselwortlisten aller aktiven Ausführungsserver verglichen.

Schlüsselwörter beschreiben in der Regel die Umgebung eines Ausführungsservers, z. B. Plattform, Betriebssystem und vorinstallierte Anwendungen. Wenn eine Testsuite ausgeführt wird, vergleicht Silk Central die Schlüsselwörter der Testsuite mit den Schlüsselwörtern aller verfügbarer Ausführungsserver. Die Testsuite wird dann auf dem Ausführungsserver ausgeführt, der der Schlüsselwortliste der Testsuite entspricht. Wird kein passender Ausführungsserver gefunden, dann wird die Testsuite nicht ausgeführt. Falls mehrere Ausführungsserver mit passenden Schlüsselwortlisten vorhanden sind, dann wird die Testsuite auf dem ersten erkannten Ausführungsserver ausgeführt.

Silk Central weist physikalischen Ausführungsservern automatisch Schlüsselwörter zu, basierend auf welche Browser installiert sind und welche mobilen Geräte angeschlossen sind, wenn auf dem Ausführungsserver Silk Test installiert ist.

Reservierte Standardschlüsselwörter

Falls keine Hardwarebereitstellung erforderlich ist, können Sie auf die reservierten Schlüsselwörter zurückgreifen, die automatisch für jeden Ausführungsserver definiert werden. In diesem Fall ist es nicht erforderlich, den Ausführungsservern manuell Schlüsselwörter zuzuordnen. Stattdessen können Sie jede Testsuite direkt statisch einem Ausführungsserver zuordnen.

Jedem neu eingerichteten Ausführungsserver wird automatisch ein reserviertes Schlüsselwort zugeordnet. Reservierte Schlüsselwörter haben folgendes Format:
 #<execution server name>@<location name>

Reservierte Schlüsselwörter sind nur beim Zuordnen von Schlüsselwörtern zu Testsuiten verfügbar. Beim Zuordnen von Schlüsselwörtern zu Ausführungsservern sind sie weder verfügbar noch brauchbar.

Neben den reservierten Schlüsselwörtern, die automatisch für jeden definierten Ausführungsserver eingerichtet werden, werden auch für jeden Ausführungsservertyp reservierte Schlüsselwörter festgelegt.

#PHYSICAL

Beschränkt die Bereitstellung von Ausführungsservern auf physische Ausführungsserver.

#VIRTUAL

Beschränkt die Bereitstellung von Ausführungsservern auf virtuelle Ausführungsserver.

Schlüsselwörter und virtuelle Ausführungsserver

Schlüsselwörter werden virtuellen Ausführungsservern auf die gleiche Weise zugeordnet wie physischen Ausführungsservern. Sobald Sie mindestens einen virtuellen Ausführungsserver konfigurieren, wird das Schlüsselwort #VIRTUAL dynamisch erstellt und zum Zuordnen zu allen Testsuiten verfügbar gemacht. Wenn eine Testsuite auf einem virtuellen Computer ausgeführt werden soll, wählen Sie für die Testsuite das Schlüsselwort #VIRTUAL. Wenn einer Testsuite weder das Schlüsselwort #VIRTUAL noch das Schlüsselwort #PHYSICAL zugeordnet wurde (oder beide zugeordnet wurden), kann sie entweder auf einem virtuellen oder einem physischen Ausführungsserver ausgeführt werden, sofern die Einstellungen für die Ausführungsumgebung übereinstimmen. Wenn die Schlüsselwörter einer Testsuite mehreren virtuellen Ausführungsservern entsprechen, wird der virtuelle Ausführungsserver ausgewählt, der zuerst erkannt wird.

Übergeordnetes Thema: Einrichten von Ausführungsservern


Konfigurieren physischer Ausführungsserver

Physische Ausführungsserver laufen auf einem physischen Rechner oder auf einer virtuellen Maschine (VM). So konfigurieren Sie einen physischen Ausführungsserver:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Wählen Sie die Servergruppe, für die Sie einen Ausführungsserver konfigurieren möchten.
    • Um einen neuen Ausführungsserver anzulegen, klicken Sie auf Neuer physikalischer Ausführungsserver.
    • Um einen vorhandenen Ausführungsserver zu bearbeiten, klicken Sie in der Spalte Aktionen auf die betreffende Bearbeiten-Schaltfläche.
    Anmerkung: Ausführungsserver müssen vor dem Bearbeiten ihrer Eigenschaften deaktiviert werden. Schlüsselwörterlisten aktiver Ausführungsserver können jedoch bearbeitet werden.
  3. Geben Sie im Feld Hostname oder IP-Adresse eine gültige IP-Adresse oder einen Hostnamen ein.
  4. Geben Sie einen Namen für den Ausführungsserver in das Feld Name ein.
  5. Klicken Sie auf Schlüsselwörter, um Schlüsselwörter aus einer Liste auszuwählen oder neue beschreibende Schlüsselwörter für den Ausführungsserver hinzuzufügen. Diese Schlüsselwörter werden während der Ausführung analysiert, um dynamisch für jede Ausführung den passenden Server auszuwählen. Weitere Informationen finden Sie unter Erstellen und zuweisen von Schlüsselwörtern zu einem Ausführungsserver.
  6. Erweiterte Einstellungen müssen nur bearbeitet werden, wenn Sie nicht die Standardeinstellungen verwenden. Geben Sie im Feld Port den Port an, von dem der Ausführungsserver empfängt.
    Anmerkung: Aktivieren Sie das Kontrollkästchen SSL verwenden, wenn die Verbindung zum Ausführungsserver über SSL hergestellt werden soll.
    Tipp: Informationen zum Verbinden eines Ausführungsservers über einen Nicht-Standard-SSL-Port, finden Sie unter Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver.
  7. Optional:Geben Sie im Feld Maximale Antwortzeit die maximale Antwortzeit in Sekunden ein. Wenn der Ausführungsserver in der angegebenen Zeit nicht erreichbar ist, wird eine E-Mail Benachrichtigung an die Silk Central-Administratoren gesendet. Sollen Silk Central-Administratoren keine E-Mail Benachrichtigung erhalten, geben Sie 0 ein.
  8. Optional: Ändern Sie die Maximale Anzahl gleichzeitiger Ausführungen auf diesem Ausführungsserver, falls erwünscht. Wenn Ihre Testsuiten für die gleichzeitige Ausführung konfiguriert wurden, ist dies die Anzahl von Testsuiten die gleichzeitig auf diesem Ausführungsserver laufen können. Bedenken Sie, dass zu viele gleichzeitige Testausführungen einen großen Einfluss auf die Leistung des Ausführungsservers haben können und möglicherweise zum Fehlschlagen von Testausführungen führen können.
  9. Klicken Sie auf OK, um die Einstellungen zu speichern. Wenn Sie eine Fehlermeldung erhalten, stellen Sie sicher, dass Ihre Einstellungen korrekt sind, dass das Netzwerk ordnungsgemäß konfiguriert ist und dass auf dem Ausführungsserver, der gerade eingerichtet wird, die erforderliche Software installiert ist.
    Wichtig: Da die Installation eines Ausführungsservers Administratorrechte benötigt, scheitert die automatisierte Aktualisierung wenn die Benutzerkontensteuerung (UAC) eingeschaltet ist. Schalten Sie UAC auf allen Rechnern aus, auf denen ein Ausführungsserver läuft.
    Anmerkung: Wenn Sie eine ungültige ältere Version, aber höher als Version SilkCentral Test Manager 2009 SP1, eines Ausführungsservers verwenden, wird diese automatisch auf die aktuelle Version von Silk Central aktualisiert. Silk Central zeigt in der Ausführungsserverliste in der Spalte Information eine Nachricht betreffend der Aktualisierung an. Der zu aktualisierende Ausführungsserver wird erst nach Abschluss des Upgrade-Vorgangs verwendet.
Übergeordnetes Thema: Einrichten von Ausführungsservern
Zugehörige Tasks
Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver
Erstellen und zuweisen von Schlüsselwörtern zu einem Ausführungsserver


Konfigurieren von Ausführungsservern in der Cloud

Ausführungsserver in der Cloud laufen auf einem Cloud-Anbieter, wie z.B. VMware vCloud. So konfigurieren Sie einen Ausführungsserver in der Cloud:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Wählen Sie die Servergruppe, für die Sie einen Ausführungsserver konfigurieren möchten.
    • Um einen neuen Ausführungsserver anzulegen, klicken Sie auf Neuer virtueller Ausführungsserver.
    • Um einen vorhandenen Ausführungsserver zu bearbeiten, klicken Sie in der Spalte Aktionen auf die betreffende Bearbeiten-Schaltfläche.
    • Um die aufgelisteten Ausführungsserver zu synchronisieren, welche Vorlagen eines Cloud-Anbieters verwenden, wählen Sie die Registerkarte Cloud-Anbieter. Klicken Sie in der Spalte Aktionen auf [image], um die Liste der Ausführungsserver zu synchronisieren, welche Vorlagen dieses Cloud-Anbieters verwenden. Dadurch werden sämtliche virtuelle Ausführungsserver dieses Profils gelöscht, welche eine Vorlage verwenden die in der Zwischenzeit gelöscht wurde. Zusätzlich werden die Vorlagen von automatisch erstellten virtuellen Ausführungsservern aktualisiert, nachdem ein Hotfix installiert wurde.
    Anmerkung: Ausführungsserver müssen vor dem Bearbeiten ihrer Eigenschaften deaktiviert werden. Schlüsselwörterlisten aktiver Ausführungsserver können jedoch bearbeitet werden.
  3. Wählen Sie aus den konfigurierten Cloud-Anbieter-Profilen in der Liste Cloud-Anbieter aus, in welcher Cloud die virtuelle Umgebung eingerichtet werden soll. Dies geschieht, wenn der Ausführungsserver für einen automatisierten Testlauf gebraucht wird.
  4. Wählen Sie die Image-Vorlage aus der Liste Vorlage für virtuelles Image aus, von der für jeden automatisierten Testlauf eine Instanz erzeugt wird. Je nach Cloud-Anbieter besteht eine Image-Vorlage aus mindestens einem Image für virtuelle Maschinen. Ein Silk Central Ausführungsserver muss auf mindestens einem Virtuellen-Maschinen-Image laufen. Falls die Version des Ausführungsservers veraltet ist, so wird sie automatisch aktualisiert, nachdem eine virtuelle Umgebung für einen automatisierten Testlauf eingerichtet wurde. Der Einrichtungsvorgang ist schneller, wenn auf dem VM-Image bereits eine aktuelle Version des Ausführungsservers läuft.
  5. Geben Sie einen Namen für den Ausführungsserver in das Feld Name ein.
  6. Klicken Sie auf Schlüsselwörter, um Schlüsselwörter aus einer Liste auszuwählen oder neue beschreibende Schlüsselwörter für den Ausführungsserver hinzuzufügen. Diese Schlüsselwörter werden während der Ausführung analysiert, um dynamisch für jede Ausführung den passenden Server auszuwählen. Weitere Informationen finden Sie unter Erstellen und zuweisen von Schlüsselwörtern zu einem Ausführungsserver.
  7. Erweiterte Einstellungen müssen nur bearbeitet werden, wenn Sie nicht die Standardeinstellungen verwenden. Geben Sie im Feld Port den Port an, von dem der Ausführungsserver empfängt.
    Anmerkung: Aktivieren Sie das Kontrollkästchen SSL verwenden, wenn die Verbindung zum Ausführungsserver über SSL hergestellt werden soll.
    Tipp: Informationen zum Verbinden eines Ausführungsservers über einen Nicht-Standard-SSL-Port, finden Sie unter Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver.
  8. Optional:Geben Sie im Feld Maximale Antwortzeit die maximale Antwortzeit in Sekunden ein. Die VM wird heruntergefahren, wenn der Ausführungsserver auf dem Cloud-Anbieter nicht innerhalb der definierten Zeit erreichbar ist. Geben Sie 0 ein, wenn Sie die VM in so einem Fall nicht herunterfahren möchten (Sie müssen den Testlauf dann manuell abbrechen, wenn die VM gar nicht mehr erreichbar ist).
  9. Klicken Sie auf OK um Ihre Einstellungen zu speichern und den Ausführungsserver, entsprechend den definierten Schlüsselwörtern, für automatisierte Testläufe freizugeben. Sollten Sie eine Fehlermeldung erhalten, überprüfen Sie ob die Port-Einstellungen korrekt sind und ob ein Ausführungsserver auf dem VM-Image installiert ist. Falls die Fehlermeldung erwähnt, dass der Ausführungsserver ein ungültige Version hat, können Sie die Meldung ignorieren, da der Server automatisch für jeden automatisierten Testlauf aktualisiert wird.
Übergeordnetes Thema: Einrichten von Ausführungsservern
Zugehörige Konzepte
Cloud Integration
Cloud Integration
Zugehörige Tasks
Hinzufügen von Cloud Profilen
Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver
Erstellen und zuweisen von Schlüsselwörtern zu einem Ausführungsserver


Erstellen und zuweisen von Schlüsselwörtern zu einem Ausführungsserver

So erstellen Sie neue Schlüsselwörter und weisen sie einem Ausführungsserver zu:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Wählen Sie eine Servergruppe, um zur Liste der für diese Servergruppe definierten Ausführungsserver zu gelangen.
  3. Klicken Sie in der Spalte Aktionen eines vordefinierten Ausführungsservers auf Bearbeiten, oder klicken Sie auf Neuer physikalischer Ausführungsserver oder Neuer virtueller Ausführungsserver, um Schlüsselwörter für einen neuen Ausführungsserver zu erstellen.
    Anmerkung: Silk Central weist physikalischen Ausführungsservern automatisch Schlüsselwörter zu, basierend auf welche Browser installiert sind und welche mobilen Geräte angeschlossen sind, wenn auf dem Ausführungsserver Silk Test installiert ist. Klicken Sie in der Spalte Aktionen auf [image] um die Liste der zugewiesenen Schlüsselwörter zu aktualisieren.
  4. Klicken Sie auf Schlüsselwörter. Der Dialog Schlüsselwörter zuordnen wird angezeigt.
  5. Geben Sie im Textfeld Auswahl oder Eingabe von Schlüsselwörtern ein neues Schlüsselwort ein, oder wählen Sie ein vorhandenes Schlüsselwort aus, das die Umgebung des Ausführungsservers beschreibt, beispielsweise die Plattform, das Betriebssystem und vorinstallierte Anwendungen. Die folgenden Zeichen dürfen in Schlüsselwörtern nicht verwendet werden: # $ ? * \ , ; ' "
    Anmerkung: Wenn Sie mit einer neuen Silk Central-Installation arbeiten, sehen Sie möglicherweise keine verfügbaren Schlüsselwörter. Für jeden für das System konfigurierten Ausführungsserver werden reservierte Schlüsselwörter erstellt, die allerdings im Dialog Schlüsselwörter zuordnen nicht angezeigt werden. Diese reservierten Schlüsselwörter sind nur beim Zuordnen von Schlüsselwörtern zu Testsuiten verfügbar.
    Mit Strg+Klick bzw. Umschalttaste+Klick können Sie entsprechend dem üblichen Vorgehen bei der Markierung mehrerer Einträge mehrere Schlüsselwörter auswählen. Beachten Sie, dass das Textfeld Auswahl oder Eingabe von Schlüsselwörtern deaktiviert ist, wenn mehrere Schlüsselwörter ausgewählt sind. Falls keine Hardwarebereitstellung erforderlich ist, können Sie die reservierten Schlüsselwörter benutzen, die automatisch für jeden Ausführungsserver definiert werden. In diesem Fall ist es nicht erforderlich, den Ausführungsservern manuell Schlüsselwörter zuzuordnen.
  6. Klicken Sie auf Hinzufügen (>), um das Schlüsselwort in die Liste Zugewiesene Schlüsselwörter zu verschieben.
  7. Klicken Sie auf OK, um die Schlüsselwörter zu speichern und den Dialog Schlüsselwörter zuordnen zu schließen.
Übergeordnetes Thema: Einrichten von Ausführungsservern
Zugehörige Tasks
Konfigurieren eines benutzerdefinierten SSL-Ports für Ausführungsserver


Aktivieren bzw. Deaktivieren von Ausführungsservern

  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Wählen Sie eine Servergruppe, um zur Liste der für diese Servergruppe definierten Ausführungsserver zu gelangen.
  3. Klicken Sie in der Spalte Status des zu aktivierenden bzw. deaktivierenden Ausführungsservers auf Aktivieren/Deaktivieren.
    Wichtig: Da die Installation eines Ausführungsservers Administratorrechte benötigt, scheitert die automatisierte Aktualisierung wenn die Benutzerkontensteuerung (UAC) eingeschaltet ist. Schalten Sie UAC auf allen Rechnern aus, auf denen ein Ausführungsserver läuft.
    Anmerkung: Wenn Sie eine ungültige ältere Version, aber höher als Version SilkCentral Test Manager 2009 SP1, eines Ausführungsservers verwenden, wird diese automatisch auf die aktuelle Version von Silk Central aktualisiert. Silk Central zeigt in der Ausführungsserverliste in der Spalte Information eine Nachricht betreffend der Aktualisierung an. Der zu aktualisierende Ausführungsserver wird erst nach Abschluss des Upgrade-Vorgangs verwendet.
Übergeordnetes Thema: Einrichten von Ausführungsservern
Zugehörige Tasks
Löschen von Ausführungsservern


Löschen von Ausführungsservern

Tipp: Um Dateninkonsistenzen zu vermeiden, müssen Sie den Ausführungsserver deaktivieren, bevor Sie ihn löschen können. Weitere Informationen finden Sie unter Aktivieren bzw. Deaktivieren von Ausführungsservern.
Anmerkung: Die eigentliche Softwareinstallation bleibt von der Löschung eines Ausführungsservers unberührt. Durch die Löschung wird einfach die Verbindung mit dem Ausführungsserver getrennt. Sie können einen zuvor gelöschten Ausführungsserver wieder hinzufügen. Um einen Ausführungsserver einem anderen Anwendungsserver zuzuweisen, müssen Sie die folgende Datei auf dem Computer löschen, auf dem der Ausführungsserver installiert ist: C:\ProgramData\SilkCentral\AgentBase\ItemObjects.ser.
  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Wählen Sie eine Servergruppe, um zur Liste der für diese Servergruppe definierten Ausführungsserver zu gelangen.
  3. Klicken Sie in der Spalte Aktionen des Ausführungsservers, den Sie entfernen möchten, auf Löschen.
Übergeordnetes Thema: Einrichten von Ausführungsservern
Zugehörige Tasks
Aktivieren bzw. Deaktivieren von Ausführungsservern


Dialog "Neuer Ausführungsserver/Ausführungsserver bearbeiten"

Verwaltung > Ausführungsumgebung > Ausführungsserver > Neuer Ausführungsserver/Ausführungsserver bearbeiten

Mithilfe des Dialogs Neuer Ausführungsserver/Ausführungsserver bearbeiten können Sie Ausführungsserver in einer Servergruppe bearbeiten.

Element | Beschreibung
Name | Definiert den Namen des Ausführungsservers. Dieser Name wird in allen Tabellen und Ergebnisberichten für Ausführungen auf diesem Computer angezeigt. Es können bis zu 100 Zeichen eingegeben werden.
Beschreibung | Eine Beschreibung des Ausführungsservers. Sie können jeden beliebigen Text als Beschreibung eingeben.
Physischer Ausführungsserver | Wählen Sie diese Option, um einen physischen Rechner als Ausführungsserver festzulegen.
Host oder IP-Adresse

Gibt den Computernamen oder die IP-Adresse des Computers an, auf dem der Ausführungsserver installiert ist.

In einigen Netzwerken wird der Ausführungsserver u. U. nur dann gefunden, wenn der volle Name des Hosts mit dem Domänennamen angegeben wird, z. B. BeispielHost.BeispielDomäne.
Port | Legt den Port des im Feld Hostname oder IP-Adresse definierten Computers fest, von dem der Ausführungsserver empfängt. Der Standardport ist 19124.
SSL verwenden

Aktivieren Sie dieses Kontrollkästchen, wenn der Anwendungsserver über Secure Sockets Layer (SSL) eine Verbindung mit dem Ausführungsserver herstellen soll. Der Standard SSL-Port ist 19125.

Wenn ein Proxy-Server für die Servergruppe verwendet wird, der dieser Ausführungsserver zugeordnet ist, müssen Sie für Port 443 SSL verwenden aktivieren.
Maximale Antwortzeit [s]

Für virtuelle Ausführungsserver: Geben Sie im Feld Maximale Antwortzeit die maximale Antwortzeit in Sekunden ein. Die VM wird heruntergefahren, wenn der Ausführungsserver auf dem Cloud-Anbieter nicht innerhalb der definierten Zeit erreichbar ist. Geben Sie 0 ein, wenn Sie die VM in so einem Fall nicht herunterfahren möchten (Sie müssen den Testlauf dann manuell abbrechen, wenn die VM gar nicht mehr erreichbar ist).

Für physische Ausführungsserver: Geben Sie im Feld Maximale Antwortzeit die maximale Antwortzeit in Sekunden ein. Wenn der Ausführungsserver in der angegebenen Zeit nicht erreichbar ist, wird eine E-Mail Benachrichtigung an die Silk Central-Administratoren gesendet. Sollen Silk Central-Administratoren keine E-Mail Benachrichtigung erhalten, geben Sie 0 ein.
Schlüsselwörter | Listet die Schlüsselwörter auf, die dieser Testsuite zugeordnet wurden. Anhand der Schlüsselwörter kann die Hardwarebereitstellungstechnologie von Silk Central für jede Testsuite dynamisch den am besten geeigneten Ausführungsserver identifizieren. Klicken Sie auf Schlüsselwörter, um die Schlüsselwortliste für diesen Ausführungsserver zu bearbeiten.
Übergeordnetes Thema: Einrichten von Ausführungsservern


Cloud Integration

Silk Central ermöglicht die Integration mit Anbietern von öffentlichen oder privaten Cloud Services, indem Cloud Profile konfiguriert werden. Cloud Profile basieren auf einem Plug-in Konzept, welches Ihnen die Möglichkeit bietet Ihr eigenes Plug-in für einen bestimmten Cloud Anbieter zu entwickeln. Ein Cloud-Anbieter Plug-in richtet vor jedem automatisierten Testlauf eine virtuelle Umgebung ein.
Anmerkung: Die Cloud API wird voraussichtlich in einer zukünftigen Version von Silk Central Änderungen erhalten. Wenn Sie diese API verwenden, kann die Aktualisierung auf eine zukünftige Version von Silk Central bedeuten, dass Sie Ihre Plug-in Implementation anpassen müssen.
  • Hinzufügen von Cloud Profilen
    Fügen Sie ein Cloud Profil hinzu um mit Anbietern von öffentlichen oder privaten Cloud Services zu integrieren.
  • Bearbeiten von Cloud Profilen
    Bearbeiten Sie ein Cloud-Profil, wenn Sie die Einstellungen ändern müssen wie auf einen Anbieter von öffentlichen oder privaten Cloud-Diensten zugegriffen wird.
  • Löschen von Cloud Profilen
    Löschen Sie ein Cloud-Profil, wenn Sie den Zugriff auf einen bestimmten Anbieter von öffentlichen oder privaten Cloud-Diensten nicht mehr benötigen.
  • VMware vCloud Integration
    Hier finden Sie Informationen rund um VMware vCloud und die Einschränkungen der Integration.
  • Cloud-Anbieter (Seite)
    Hier werden die für Ihr System konfigurierten Cloud-Anbieter-Profile aufgeführt.
Übergeordnetes Thema: Ausführungsumgebung
Zugehörige Konzepte
Cloud Integration
Zugehörige Tasks
Konfigurieren von Ausführungsservern in der Cloud


Hinzufügen von Cloud Profilen

Fügen Sie ein Cloud Profil hinzu um mit Anbietern von öffentlichen oder privaten Cloud Services zu integrieren.
  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Klicken Sie auf die Registerkarte Cloud-Anbieter.
  3. Klicken Sie auf Neues Profil. Der Dialog Neues Cloud-Anbieter-Profil wird angezeigt.
  4. Wählen Sie im Listenfeld Typ der installierten Plug-Ins den Cloud Provider aus, auf den Sie zugreifen möchten. VMware vCloud und Amazon Web Services werden standardmäßig unterstützt.
  5. Geben Sie einen Namen für das neue Profil in das Textfeld Name ein. Dieser Name wird in der Liste der Profile angezeigt, wenn Sie einen Ausführungsserver in der Cloud anlegen.
  6. Geben Sie gültige Benutzerdaten in den Textfeldern Benutzername und Passwort ein. Bei Amazon Web Services entsprechen diese dem Access Key und dem Secret Key.
  7. So konfigurieren Sie ein VMware vCloud-Profil (überspringen Sie diesen Schritt, wenn Sie ein anderes Profil konfigurieren):
    1. Geben Sie die URL nur mit dem Hostnamen ein, ohne den Suffix /cloud/org/<Organisationsname>, welcher benötigt wird wenn Sie auf das System mit einem Browser zugreifen. Beispiel: https://vdirectorweb.
    2. Optional: Version: Lassen Sie das Textfeld leer wenn Sie VMware vCloud Director 5.5 (Standard) verwenden. Geben Sie V5.1 ein wenn Sie vCloud Director 5.1 verwenden.
    3. Organisation: Geben Sie den Namen der vCloud Organisation ein auf die Sie zugreifen möchten, zum Beispiel dev_org.
  8. So konfigurieren Sie ein Amazon Web Services-Profil (überspringen Sie diesen Schritt, wenn Sie ein anderes Profil konfigurieren):
    1. Region: Wählen Sie die Region aus, in der die Instanz ausgeführt werden soll.
    2. Instanz-Typ: Die Instanz-Typen, welche von Amazon zur Verfügung gestellt werden. Dies bestimmt z.B. wie viel RAM und CPU Ihre Instanz haben wird. Beachten Sie, dass dies auch einen Einfluss auf die Kosten hat. Weitere Informationen finden Sie auf der Seite Amazon EC2-Instances.
    3. Instanz bei Fehler nicht terminieren: Wählen Sie true, wenn die Instanz nicht terminiert werden soll, falls ein Verbindungsfehler zwischen dem Anwendungsserver und der Amazon-Instanz auftritt.
  9. Klicken Sie auf Verbindung testen um eine Testverbindung mit dem Cloud Anbieter herzustellen.
  10. Klicken Sie auf OK, um die Einstellungen zu speichern.
Falls der ausgewählte Cloud-Provider Vorlagen mit dem Namen "Micro Focus Silk Central Execution Server 18.5.0.x" besitzt, werden diese Vorlagen automatisch als virtuelle Ausführungsserver importiert. Es werden nur Vorlagen mit exakt derselben Version wie die Ihrer laufenden Silk Central-Umgebung importiert (siehe Hilfe > Info).
Übergeordnetes Thema: Cloud Integration
Zugehörige Tasks
Konfigurieren von Ausführungsservern in der Cloud


Bearbeiten von Cloud Profilen

Bearbeiten Sie ein Cloud-Profil, wenn Sie die Einstellungen ändern müssen wie auf einen Anbieter von öffentlichen oder privaten Cloud-Diensten zugegriffen wird.
Wichtig: Falls virtuelle Umgebungen, welche auf diesem Profil basieren, bereits eingerichtet sind (siehe Spalte Hochgefahrene Instanzen), kann eine Änderung der Profileinstellungen dazu führen, dass Silk Central diese ungenutzten Umgebungen nicht mehr automatisch löschen kann.
  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Klicken Sie auf die Registerkarte Cloud-Anbieter.
  3. Klicken Sie in der Spalte Aktionen auf [image], um die Liste der Ausführungsserver zu synchronisieren, welche Vorlagen dieses Cloud-Anbieters verwenden. Dadurch werden sämtliche virtuelle Ausführungsserver dieses Profils gelöscht, welche eine Vorlage verwenden die in der Zwischenzeit gelöscht wurde. Zusätzlich werden die Vorlagen von automatisch erstellten virtuellen Ausführungsservern aktualisiert, nachdem ein Hotfix installiert wurde.
  4. Klicken Sie in der Spalte Aktionen des Profils, das Sie bearbeiten möchten, auf [image] (Bearbeiten). Der Dialog Cloud-Anbieter-Profil bearbeiten wird angezeigt.
  5. Geben Sie einen Namen für das neue Profil in das Textfeld Name ein. Dieser Name wird in der Liste der Profile angezeigt, wenn Sie einen Ausführungsserver in der Cloud anlegen.
  6. Geben Sie gültige Benutzerdaten in den Textfeldern Benutzername und Passwort ein. Bei Amazon Web Services entsprechen diese dem Access Key und dem Secret Key.
  7. So konfigurieren Sie ein VMware vCloud-Profil (überspringen Sie diesen Schritt, wenn Sie ein anderes Profil konfigurieren):
    1. Geben Sie die URL nur mit dem Hostnamen ein, ohne den Suffix /cloud/org/<Organisationsname>, welcher benötigt wird wenn Sie auf das System mit einem Browser zugreifen. Beispiel: https://vdirectorweb.
    2. Optional: Version: Lassen Sie das Textfeld leer wenn Sie VMware vCloud Director 5.5 (Standard) verwenden. Geben Sie V5.1 ein wenn Sie vCloud Director 5.1 verwenden.
    3. Organisation: Geben Sie den Namen der vCloud Organisation ein auf die Sie zugreifen möchten, zum Beispiel dev_org.
  8. So konfigurieren Sie ein Amazon Web Services-Profil (überspringen Sie diesen Schritt, wenn Sie ein anderes Profil konfigurieren):
    1. Region: Wählen Sie die Region aus, in der die Instanz ausgeführt werden soll.
    2. Instanz-Typ: Die Instanz-Typen, welche von Amazon zur Verfügung gestellt werden. Dies bestimmt z.B. wie viel RAM und CPU Ihre Instanz haben wird. Beachten Sie, dass dies auch einen Einfluss auf die Kosten hat. Weitere Informationen finden Sie auf der Seite Amazon EC2-Instances.
    3. Instanz bei Fehler nicht terminieren: Wählen Sie true, wenn die Instanz nicht terminiert werden soll, falls ein Verbindungsfehler zwischen dem Anwendungsserver und der Amazon-Instanz auftritt.
  9. Klicken Sie auf Verbindung testen um eine Testverbindung mit dem Cloud Anbieter herzustellen.
  10. Klicken Sie auf OK, um die Einstellungen zu speichern.
Übergeordnetes Thema: Cloud Integration


Löschen von Cloud Profilen

Löschen Sie ein Cloud-Profil, wenn Sie den Zugriff auf einen bestimmten Anbieter von öffentlichen oder privaten Cloud-Diensten nicht mehr benötigen.
Wichtig: Wenn ein Profil gelöscht wird, werden auch alle Ausführungsserver gelöscht die dieses Profil verwenden, sowie alle Testausführungen die diese Ausführungsserver verwenden. Falls virtuelle Umgebungen, welche auf diesem Profil basieren, bereits eingerichtet sind (siehe Spalte Hochgefahrene Instanzen), kann eine Änderung der Profileinstellungen dazu führen, dass Silk Central diese ungenutzten Umgebungen nicht mehr automatisch löschen kann.
  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Klicken Sie auf die Registerkarte Cloud-Anbieter.
  3. Klicken Sie in der Spalte Aktionen des Profils, das Sie löschen möchten, auf [image] (Löschen). Ein Bestätigungsdialogfeld wird geöffnet.
  4. Klicken Sie auf Ja, um mit dem Löschvorgang fortzufahren. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen.
Übergeordnetes Thema: Cloud Integration


VMware vCloud Integration

Zuordnungen

Die verfügbaren Vorlagen für vCloud-Ausführungsserver entsprechen den vApp-Vorlagen in lokalen (nicht-öffentlichen) Katalogen von vCloud. Sie werden als <Katalogname> - <vApp-Vorlagenname> aufgelistet.

Das Einrichten einer virtuellen Umgebung für einen Testlauf erstellt eine neue vApp in vCloud Director, deren Name auf der Vorlage basiert und das Suffix - for Silk Central <Zeitstempel> hat.

Anforderungen für die Anpassung des Gastbetriebssystems

Damit der Silk Central-Ausführungsserver korrekt hochgefahren werden kann, muss in vCloud Director in den VM-Eigenschaften der vApp-Vorlage die Anpassung des Gastbetriebssystems folgendermaßen aktiviert und konfiguriert werden: Da der Ausführungsserver in einer Benutzersitzung gestartet wird, soll ein Windows-Login nur einmal durchgeführt werden, nachdem ein VM-Neustart durch die Anpassung des Gastbetriebssystems initiiert wurde.
  • Aktivieren Sie Allow Local Administrator Password und Login as Administrator automatically
  • Geben Sie ein Kennwort an, oder lassen Sie von vCloud ein neues generieren
  • Deaktivieren Sie Administrator must change password on first login
  • Stellen Sie sicher, dass in Windows selbst kein Automatisches Anmelden aktiviert ist, da ansonsten eine doppelte Anmeldung erfolgen würde, durch das Hochstarten des Ausführungsservers durch den Anpassungs-Neustart.

Einschränkungen

  • Für die Silk Central vCloud-Integration können nur vApp-Vorlagen in lokalen (nicht-öffentlichen) Katalogen verwendet werden. Öffentliche Kataloge können zwar benutzt werden, um Vorlagen organisationsübergreifend zu kopieren oder zu verschieben, jedoch stehen diese Vorlagen Silk Central nicht zur Verfügung. Grund für diese Einschränkung ist, dass es Probleme geben kann, wenn eine vApp aus einer Vorlage in einem öffentlichen Katalog erstellt wird, wenn diese Vorlage aus einer anderen Organisation stammt. Das Problem entsteht, weil das vDC (virtuelles Datacenter) und das Netzwerk die der Vorlage zugeordnet sind, keine Gültigkeit in einer anderen Organisation haben.
  • Keine "Fencing"-Unterstützung. Silk Central unterstützt nicht, dass mehrere VMs innerhalb einer vApp über eine bekannte IP-Adresse miteinander kommunizieren, da jede eingerichtete VM dynamisch eine neue IP-Adresse erhält.
  • vApp-Vorlagen mit der Einstellung Create Identical Copy werden nicht unterstützt. Wenn Sie eine vApp-Vorlage für Silk Central erstellen, überprüfen Sie, dass in den Eigenschaften der vApp-Vorlage die Option Customize VM settings eingeschaltet ist. Ist diese Option auf Identical Copy eingestellt, erscheint eine Fehlermeldung sobald Silk Central versucht eine vApp einzurichten, die auf solch einer Vorlage basiert. Beachten Sie bitte, dass diese Option nur während dem Erstellen einer vApp-Vorlage eingestellt werden kann.
  • Der Zugriff auf kommerzielle Dienstanbieter, die eine vCloud REST API zur Verfügung stellen, wurde nicht getestet, könnte aber funktionieren. Die Integration wurde mit VMware vCloud Director 5.5 getestet, welcher als private Cloud installiert wurde.
  • Um IP-Zuordnungskonflikte zu vermeiden, sollten Sie vApp-Vorlagen mit DHCP IP-Modus für den Netzwerkadapter konfigurieren. Falls diese Einstellung nicht konfiguriert ist, kann das erstmalige Hochfahren einer VM dazu führen, dass vApp-Rechner eine alte, statische IP-Adresse haben, welche sie erhalten haben als die Vorlage gespeichert wurde. Die korrekte IP-Adresse wird erst aktualisiert, wenn VMware eine Anpassung des Gastbetriebssystems durchführt, wodurch die IP-Konfiguration erneuert und ein Neustart durchgeführt wird. Silk Central konfiguriert immer einen statischen IP-Pool-Modus (angewandt nach der Anpassung des Gastbetriebssystems), egal was in der Vorlage eingestellt ist.
  • Sollten Sie im virtuellen Datencenter (VDC) mehr als ein Netzwerk verwenden, stellen Sie in der vApp-Vorlage ein, welches Netzwerk verwendet werden soll. Silk Central ordnet den in der Vorlage eingestellten VM-Netzwerkadapter den vDC-Netzwerknamen zu, um das richtige vDC-Netzwerk bei der Bereitstellung einer neuen vApp zu verwenden.
  • Falls auf der VM-Vorlage ein Ausführungsserver installiert ist, der unter Version 15.0 ist, so muss dieser im Modus Als Prozess laufen
Übergeordnetes Thema: Cloud Integration


Cloud-Anbieter (Seite)

Verwaltung > Ausführungsumgebung > Cloud-Anbieter

Die Seite Cloud-Anbieter führt alle konfigurierten Cloud-Anbieter-Profile auf. Mithilfe dieser Seite können Sie die Cloud-Anbieter-Profile verwalten.

Sie können auf dieser Seite die folgenden Aktionen ausführen:

  • Klicken Sie auf Neues Profil, um ein neues Cloud-Anbieter-Profil zu erstellen.
  • Klicken Sie in der Spalte Aktionen auf [image] (Bearbeiten) um die Einstellungen zu bearbeiten.
  • Klicken Sie auf Löschen (Löschen) in der Spalte Aktionen, um ein Cloud-Anbieter-Profil zu löschen.
  • Klicken Sie in der Spalte Aktionen auf [image], um die Liste der Ausführungsserver zu synchronisieren, welche Vorlagen dieses Cloud-Anbieters verwenden. Dadurch werden sämtliche virtuelle Ausführungsserver dieses Profils gelöscht, welche eine Vorlage verwenden die in der Zwischenzeit gelöscht wurde. Zusätzlich werden die Vorlagen von automatisch erstellten virtuellen Ausführungsservern aktualisiert, nachdem ein Hotfix installiert wurde.
Übergeordnetes Thema: Cloud Integration


Verwalten von Geräte-Anbietern

Geräte-Anbieter sind Computer, die als Host für mobile Emulatoren und Simulatoren dienen und/oder physische mobile Geräte angeschlossen haben, auf welche zum Ausführen von Tests zugegriffen werden kann.

Physische mobile Geräte, Emulatoren und Simulatoren, die an einem so genannten Geräte-Anbieter angeschlossen, respektive installiert sind, stehen Ihren Testingenieuren und Testsuiten zur Verfügung. Sowohl manuelle als auch automatisierte Tests können dann direkt auf diesen mobilen Geräten ausgeführt werden.

Die Software von heute muss auf verschiedensten Plattformen und mobilen Geräten laufen, wodurch diese Funktionalität vor allem zum Testen von Konfigurationen nützlich ist, über alle Plattformen und Geräte die Ihre Software unterstützt.

  • Konfiguration von Geräte-Anbietern
    Konfigurieren Sie einen Geräte-Anbieter, um Ihre Anwendungen auf mobilen Geräten (physische Geräte, Emulatoren und Simulatoren) zu testen.
  • Installieren des Silk Test Information Service auf einem Mac
    Installieren Sie das Information Service auf einem Mac um Apple Safari oder mobile Anwendungen auf einem iOS mit Silk Test zu testen.
  • Löschen von Geräte-Anbietern
    Löschen Sie einen Geräte-Anbieter, wenn die angeschlossenen Geräte nicht mehr für Testausführungen verwendet werden sollen.
Übergeordnetes Thema: Ausführungsumgebung
Zugehörige Tasks
Zuordnen von mobilen Geräten zu einer Konfiguration
Auswählen von mobilen Geräten für automatisiertes Testen
Auswählen von mobilen Geräten für manuelles Testen
Zugehörige Verweise
Konfiguration von Geräte-Anbietern
Lizenzverarbeitung


Konfiguration von Geräte-Anbietern

Konfigurieren Sie einen Geräte-Anbieter, um Ihre Anwendungen auf mobilen Geräten (physische Geräte, Emulatoren und Simulatoren) zu testen.

Stellen Sie sicher, dass die Installationsanforderungen erfüllt sind, bevor Sie einen bestimmten Geräte-Anbieter konfigurieren:
  • Silk Test Information Service: Bevor ein Geräte-Anbieter konfiguriert werden kann, muss zuerst der Silk Test Information Service auf dem Rechner/den Rechnern installiert werden, welche Ihre Geräte zur Verfügung stellen werden.
    1. Laden Sie die Setup-Datei von Micro Focus SupportLine herunter.
    2. Führen Sie die Setup-Datei aus und folgen Sie dann einfach den Schritten des Installationsassistenten. Informationen über das Aufsetzen eines Geräte-Anbieters auf einem Mac finden Sie unter Installieren des Silk Test Information Service auf einem Mac.
  • Mobile Center und Sauce Labs: Wenden Sie sich an die Silk Test-Dokumentation:
    • Testen von mobilen Anwendungen mit Silk Test Workbench
    • Testen von mobilen Anwendungen mit Silk4J
    • Testen von mobilen Anwendungen mit Silk4NET

So konfigurieren Sie einen Geräte-Anbieter:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Klicken Sie auf die Registerkarte Geräte-Anbieter.
  3. Wählen Sie die Servergruppe, für die Sie einen Geräte-Anbieter konfigurieren möchten.
    • Um einen neuen Geräte-Anbieter zu erstellen, klicken Sie auf Neuer Geräte-Anbieter.
    • Um einen vorhandenen Geräte-Anbieter zu bearbeiten, klicken Sie in der Spalte Aktionen auf die betreffende Bearbeiten-Schaltfläche.
    Anmerkung: Der gleiche Geräte-Anbieter kann zu mehreren Servergruppen hinzugefügt werden.
  4. Wählen Sie den Geräte-Anbieter-Typ.
    • Silk Test Information Service: Geben Sie die Silk TestInformation Service URL des Computers ein, an den die mobilen Geräte angeschlossen sind bzw. betrieben werden. Dies kann eine IP-Adresse, eine URL oder ein Hostname, z.B. http://<Computername>:22901. Wenn kein Port angegeben wird, wird Standard-Port 22901 angehängt.
    • Sauce Labs: Geben Sie Ihren Sauce Labs Benutzer-Namen und Ihren Sauce Labs Access Key ein. Ihren Access Key finden Sie auf https://saucelabs.com unter My Account. Wenn Sie Sauce Labs Geräte für manuelles Testen verwenden möchten, muss ein Silk Test Information Service in der Liste ausgewählt werden. Wenn kein Silk Test Information Service ausgewählt wurde, können Sauce Labs Geräte nur für automatisiertes Testen verwendet werden.
    • Mobile Center: Geben Sie Ihre Mobile Center URL, Ihren Benutzernamen und Ihr Kennwort ein.
  5. Geben Sie einen sprechenden Namen für den Geräte-Anbieter in das Feld Name ein.
  6. Klicken Sie auf Verbindung testen. Kann die Verbindung hergestellt werden, klicken Sie auf OK.
Übergeordnetes Thema: Verwalten von Geräte-Anbietern
Zugehörige Konzepte
Verwalten von Geräte-Anbietern
Zugehörige Tasks
Zuordnen von mobilen Geräten zu einer Konfiguration
Auswählen von mobilen Geräten für automatisiertes Testen
Auswählen von mobilen Geräten für manuelles Testen


Installieren des Silk Test Information Service auf einem Mac

Anmerkung: Um das Information Service auf einem Mac zu installieren, benötigen Sie Administrationsrechte auf dem Mac.

Um Tests für Apple Safari auf einem Mac zu erstellen und auszuführen, oder für mobile Anwendungen auf einem iOS oder einem Android-Gerät das an einen Mac angeschlossen ist, installieren Sie das Silk Test Information Service (Information Service) auf dem Mac, und verwenden Sie dann den Dialog Remote Locations um sich mit einem Windows-Rechner zu verbinden, auf dem Silk Test installiert ist.

So installieren Sie das Information Service auf einem Mac:

  1. Stellen Sie sicher, dass ein Java SDK auf dem Mac installiert ist.
  2. Falls Sie mobile Anwendungen auf einem iOS-Gerät testen möchten, stellen Sie sicher, dass Xcode auf dem Mac installiert ist.
  3. Öffnen Sie die Information Service Installationsdatei, SilkTestInformationService<Version>-<Build-Nummer>.pkg.
    • Falls Sie die Information Service Installationsdatei während der Installation von Silk Test heruntergeladen haben, öffnen Sie den Ordner macOS im Silk Test-Installationsordner, z.B. C:\Program Files (x86)\Silk\SilkTest.
    • Falls Sie die Information Service Installationsdatei nicht während der Installation von Silk Test heruntergeladen haben, können Sie sie von Micro Focus SupportLine herunterladen.
  4. Kopieren Sie die Datei SilkTestInformationService<Version>-<Build-Nummer>.pkg auf den Mac.
  5. Führen Sie SilkTestInformationService<Version>-<Build-Nummer>.pkg aus um das Information Service zu installieren.
  6. Folgen Sie der Anleitung des Installationsassistenten.
  7. Wenn Sie nach dem Kennwort gefragt werden, geben Sie das Kennwort des zur Zeit angemeldeten Mac-Benutzers ein.
  8. Wenn sich Apple Safari öffnet und fragt, ob SafariDriver vertraut werden soll, klicken Sie auf Trust.
    Anmerkung: Sie können SafariDriver nur installieren, wenn Sie direkt auf dem Mac eingeloggt sind, nicht wenn Sie über eine Remote-Verbindung darauf zugreifen.
Um die Installation abzuschließen, meldet das Installationsprogramm den angemeldeten Mac-Benutzer ab. Um zu verifizieren, dass das Information Service korrekt installiert wurde, melden Sie sich auf dem Mac an und klicken Sie auf das Silk Test-Symbol oben rechts auf dem Bildschirm, um die verfügbaren Geräte und Browser zu sehen.
Tipp: Sollte das Silk Test-Symbol nicht erscheinen, starten Sie den Mac neu.
Übergeordnetes Thema: Verwalten von Geräte-Anbietern


Löschen von Geräte-Anbietern

Löschen Sie einen Geräte-Anbieter, wenn die angeschlossenen Geräte nicht mehr für Testausführungen verwendet werden sollen.
  1. Klicken Sie im Menü auf Verwaltung > Ausführungsumgebung.
  2. Wählen Sie eine Servergruppe, um zur Liste der für diese Servergruppe definierten Geräte-Anbieter zu gelangen.
  3. Klicken Sie in der Spalte Aktionen des Geräte-Anbieters, den Sie entfernen möchten, auf Löschen.
Übergeordnetes Thema: Verwalten von Geräte-Anbietern


Verwalten von Berichtsvorlagen

Silk Central stellt eine Vielzahl vorinstallierter Berichte zur Verfügung, mit denen Sie Daten zu Analysezwecken schnell und einfach in präsentationsreife Informationen umwandeln können. Die Standardberichte können mit Microsoft Excel, Microsoft Word oder BIRT, einem auf Eclipse basierenden Open-Source-Berichtstool für Webanwendungen, angepasst werden. Sie können mit diesen Programmen auch völlig neue Berichte erstellen.

Da gemeinsam verwendbare globale Berichte in allen Projekten und für alle Benutzer verwendbar sind, benötigen Benutzerrollen mit den Rechten solche Berichte zu ändern oder zu löschen spezielle Berechtigungen: Gemeinsam verwendbare globale Berichte verwalten und Gemeinsam verwendbare globale Berichte löschen. Diese Berechtigungen gelten auch für Berichtsvorlagen die in gemeinsam verwendbaren globalen Berichten verwendet werden. Globale Berichte und Berichtsvorlagen, die anderen Benutzern nicht zur Verfügung stehen, können von Benutzerrollen mit den Standardberechtigungen für das Verwalten von Berichten bearbeitet und gelöscht werden.

Silk Central-Berichte unterstützen das Bitmap-Format (.bmp) nicht. Bilder müssen in den Formaten JPEG, GIF oder PNG vorliegen.

  • Verwalten von benutzerdefinierten Berichtsvorlagen mit BIRT
    Hier wird beschrieben, wie in Silk Central mit BIRT gearbeitet wird.
  • Anpassen vorhandener Berichtsvorlagen
    Passen Sie vorhandene BIRT-Berichtsvorlagen an, um benutzerdefinierte Berichte zu erstellen.
  • Bearbeiten von Berichtsvorlageneigenschaften
    Bearbeiten Sie die Eigenschaften einer Silk Central-Berichtsvorlage, wie z.B. ihren Namen, die Beschreibung, oder für welche Module die Vorlage verwendet werden kann.
  • Herunterladen von Berichtsvorlagen
    Laden Sie eine Silk Central-Berichtsvorlage herunter, um sie mit dem BIRT Report Designer oder Microsoft Excel zu bearbeiten.
  • Hochladen von Berichtsvorlagen
    Laden Sie eine benutzerdefinierte Silk Central-Berichtsvorlage hoch, um diese anderen Benutzern zur Verfügung zu stellen.
  • Aktualisieren von Berichtsquellen
    Aktualisieren Sie eine Berichtsvorlage durch eine geänderte Vorlagendatei, um einen benutzerdefinierten Bericht in Silk Central zu verschieben.
  • Löschen von Berichtsvorlagen
    Löschen Sie eine Berichtsvorlage, um sie aus den verfügbaren Berichten zu entfernen.
  • Berichtsvorlagen (Seite)
    Mithilfe dieser Seite können Sie Berichtsvorlagen verwalten.
Übergeordnetes Thema: Verwaltung


Verwalten von benutzerdefinierten Berichtsvorlagen mit BIRT

Silk Central arbeitet eng mit Business Intelligence and Reporting Tools (BIRT) Report Designer zusammen, damit Sie leichter Berichte über Test-, Build-, Fehler- und Anforderungsdaten erstellen können.

Nachdem Sie eine Kopie von BIRT Report Designer heruntergeladen haben, können Sie die Kernberichte von Silk Central anpassen und eigene Berichte hinzufügen. Informationen zur Ausführung und Anpassung von Berichten finden Sie in der Hilfe zur Anwendung.

Weitere Informationen über BIRT Report Designer erhalten Sie im Online-Hilfesystem von BIRT Report Designer. Weitere Informationen, Beispiele und Demonstrationen zum BIRT Report Designer finden Sie unter http://www.eclipse.org/birt. Zudem gibt es eine aktive Newsgroup (news.eclipse.org).

Für die Arbeit mit benutzerdefinierten BIRT-Berichten müssen folgende Softwarevoraussetzungen erfüllt sein:

  • BIRT Report Designer
  • Zugriff auf Silk Central mit Administratorrechten
Anmerkung: Silk Central-Berichte unterstützen das Bitmap-Format (.bmp) nicht. Bilder müssen in den Formaten JPEG, GIF oder PNG vorliegen.
  • Installieren von BIRT von Silk Central
    Wenn Sie BIRT von Silk Central installieren, werden automatisch alle erforderlichen Konfigurationseinstellungen für Silk Central angewendet.
  • Einrichten des Datenbankzugriffs für eine neue Berichtsvorlage
    Richten Sie den Datenbankzugriff von BIRT Report Designer auf die Silk Central-Datenbank ein, um eine neue Berichtsvorlage zu erstellen.
  • Einstellungen für BIRT-Datenquellen
    Hier sind die Einstellungen beschrieben, die Sie konfigurieren müssen, um von BIRT auf Silk Central zuzugreifen.
Übergeordnetes Thema: Verwalten von Berichtsvorlagen
Zugehörige Tasks
Anpassen von BIRT-Berichtsvorlagen


Installieren von BIRT von Silk Central

In dieser Anleitung wird beschrieben, wie Sie BIRT Report Designer von Ihrer Silk Central-Installation aus installieren. Wenn Sie BIRT auf diese Weise installieren, wird die für Silk Central notwendige Konfiguration automatisch ausgeführt.

So installieren Sie BIRT von Silk Central aus:

  1. Navigieren Sie zu Hilfe > Tools.
  2. Klicken Sie auf den Link BIRT RCP Report Designer.
  3. Nachdem Sie das komprimierte Installationspaket heruntergeladen haben, extrahieren Sie die komprimierten Dateien in ein Verzeichnis auf Ihrem System, beispielsweise C:\BIRT.
    Anmerkung: Wenn bei der Extraktion der Installationsdateien mit der Windows-Funktionalität für komprimierte Ordner ein Fehler auftreten sollte, verwenden Sie stattdessen ein Extraktionsprogramm wie WinZip oder WinRAR.
  4. Starten Sie BIRT.exe von dem Verzeichnis aus, in das Sie die Dateien extrahiert haben.
Übergeordnetes Thema: Verwalten von benutzerdefinierten Berichtsvorlagen mit BIRT


Einrichten des Datenbankzugriffs für eine neue Berichtsvorlage

Bevor Sie mit BIRT Report Designer eine neue Berichtsvorlage erstellen können, müssen Sie den Datenbankzugriff auf das Silk Central-Repository einrichten, das Sie abfragen möchten.

So richten Sie den Datenbankzugriff für eine neue Berichtsvorlage ein:

  1. Wählen Sie in BIRT Report Designer das Menü File > New > New Report aus.
  2. Führen Sie alle Schritte im Assistenten New Report aus.
  3. Öffnen Sie den Resource Explorer.
  4. Klicken Sie im Resource Explorer auf Shared Resources > conf > birt > library.rptlibrary > Data Sources > Data Source, und ziehen Sie die gewünschte Datenquelle in das Verzeichnis Data Sources Ihres Berichts, das sich im Fenster Outline befindet.
  5. Klicken Sie im Resource Explorer auf Shared Resources > conf > birt > library.rptlibrary > Report Parameters, und ziehen Sie die vier Berichtsparameter sourceUser, sourcePassword, sourceURL und sourceDriver in das Verzeichnis Report Parameters Ihres Berichts, das sich im Fenster Outline befindet.
  6. Doppelklicken Sie auf die neu importierte Datenquelle, um den Dialog Edit Data Source zu öffnen.
  7. Geben Sie gültige Werte in die Felder Driver Class und Database URL ein. Weitere Informationen finden Sie unter Einstellungen für BIRT-Datenquellen.
  8. Klicken Sie auf Test Connection, um die Einstellungen zu testen. Wenn die Datenbankverbindung hergestellt wurde, können Sie mit dem Entwurf der neuen Berichtsvorlage fortfahren.
  9. Klicken Sie auf OK.
Übergeordnetes Thema: Verwalten von benutzerdefinierten Berichtsvorlagen mit BIRT


Einstellungen für BIRT-Datenquellen

Mit dem BIRT-Dialog New JDBC Data Source Profile richten Sie den Datenbankzugriff auf ein vorhandenes Silk Central-Repository ein. Um den Dialog New JDBC Data Source Profile zu öffnen, klicken Sie in der Outline mit der rechten Maustaste auf Data Sources. Klicken Sie dann in der Übersicht auf New Data Source, wählen Sie JDBC Data Source, und klicken Sie auf Next >.

Um eine Verbindung mit einer MS SQL Server- oder einer MS SQL Server Express-Datenbank herzustellen, verwenden Sie die folgenden Benutzerdaten:

Element | String
Treiberklasse | net.sourceforge.jtds.jdbc.Driver
Treiber-URL
MS SQL Server
jdbc:jtds:sqlserver://<HOST>:<PORT>/<DATENBANK>
MS SQL Server Express
jdbc:jtds:sqlserver://<HOST>:<PORT>/<DATENBANK>;instance=<INSTANZENNAME>
HOST
Host-Name oder IP-Adresse des Computers, auf dem der Datenbankserver installiert ist.
PORT
Port-Nummer des Datenbankmanagementsystems. Der Standardwert ist 1433.
DATENBANK
Der Name der Datenbank.
INSTANZENNAME
Nur für MS SQL Server Express. Instanzenname der Datenbankinstanz. Die Standardinstanz von MS SQL Server Express ist localhost\SQLExpress.

Um eine Verbindung mit einer Oracle-Datenbank herzustellen, verwenden Sie die folgenden Benutzerdaten:

Element | String
Treiberklasse | oracle.jdbc.OracleDriver
Treiber-URL jdbc:oracle:thin:@<HOST>:<PORT>:<DATENBANK>
HOST
Host-Name oder IP-Adresse des Computers, auf dem der Datenbankserver installiert ist.
PORT
Port-Nummer des Datenbankmanagementsystems. Der Standardwert ist 1521.
DATENBANK
Oracle-SID.
Übergeordnetes Thema: Verwalten von benutzerdefinierten Berichtsvorlagen mit BIRT


Anpassen vorhandener Berichtsvorlagen

SilkCentralBMC TM ART Central ermöglicht Ihnen, BIRT-Berichtsvorlagen herunterzuladen und anzupassen. Diese Berichtsvorlagen enthalten alle Informationen, die notwendig sind, um eigene, angepasste Berichtsvorlagen für die Verwendung mit Silk Central-Modulen zu erstellen.

Anmerkung: Silk Central-Berichte unterstützen das Bitmap-Format (.bmp) nicht. Bilder müssen in den Formaten JPEG, GIF oder PNG vorliegen.

So erstellen Sie einen Bericht mit Hilfe einer Silk Central-Vorlage:

  1. Klicken Sie im Menü auf Verwaltung > Berichtsvorlagen. Die Seite Berichtsvorlagen wird mit allen bisher hochgeladenen Berichtsvorlagen angezeigt.
  2. Klicken Sie in der Spalte Aktionen auf Berichtsvorlage herunterladen.
  3. Speichern Sie die Vorlagendatei <Dateiname>.rptdesign auf Ihrem lokalen System.
  4. Öffnen Sie die heruntergeladene Vorlagendatei in BIRT Report Designer.
  5. Ändern Sie die Gestaltung des Berichts wie erforderlich. Hinweise zur Gestaltung von Berichten erhalten Sie im Online-Hilfesystem von BIRT Report Designer.
  6. Um eine Vorschau auf Ihren Bericht zu erhalten, wählen Sie im Run-Menü View Report > As HTML. So konfigurieren Sie, in welchem Browser die Berichtsvorschau angezeigt wird:
    • Klicken Sie auf Window > Preferences > Web Browser, aktivieren Sie Use external web browser und wählen Sie einen Browser aus.
    • Klicken Sie auf Window > Preferences > Report Design > Preview und aktivieren Sie das Kontrollkästchen Always use external browsers.
  7. Wenn Sie zum ersten Mal die Berichtsvorschau öffnen, wird der Dialog Parameter eingeben angezeigt, in dem Sie eine gültige Sitzungs-ID eingeben müssen. Geben Sie die folgende URL in einem Browser ein, um eine gültige Sitzungs-ID zu generieren. http://<HOST>:<PORT>/services/sccsystem?method=logonUser&userName=<BENUTZERNAME>&plainPasswd=<KENNWORT>.
    Parameter
    Beschreibung
    HOST
    Hostname oder IP-Adresse des Computers, auf dem Silk Central installiert ist.
    PORT
    Portnummer des Silk Central-Front-End-Servers. Der Standardwert ist 19120, wenn Sie auf SilkCentralBMC TM ART Central über einen alleinstehenden Webserver zugreifen, und 80, wenn Sie auf Silk Central über IIS zugreifen.
    BENUTZERNAME/KENNWORT
    Gültige Benutzerdaten eines Silk Central-Benutzers.
    Anmerkung: Die Reihenfolge der gültigen Benutzerdaten BENUTZERNAME und KENNWORT ist sehr wichtig.
  8. Wenn irgendwann Ihr bearbeiteter Bericht keine Daten mehr zurückgibt, liegt wahrscheinlich eine Zeitüberschreitung Ihrer Sitzungs-ID vor (das Zeitlimit beträgt 10 Minuten). Schließen Sie den Webbrowser und wählen Sie im Run-Menü erneut View Report > As HTML. Wiederholen Sie den vorigen Schritt, um eine neue Sitzungs-ID zu generieren.
Übergeordnetes Thema: Verwalten von Berichtsvorlagen


Bearbeiten von Berichtsvorlageneigenschaften

Nachdem Sie eine neue benutzerdefinierte Berichtsvorlage mit BIRT Report Designer, Word oder Excel erstellt haben und diese nach Silk Central hochgeladen haben, können Sie deren Eigenschaften bearbeiten, wie z.B. ihren Namen, die Beschreibung, oder für welche Module die Vorlage verwendet werden kann.

  1. Klicken Sie im Menü auf Verwaltung > Berichtsvorlagen. Die Seite Berichtsvorlagen wird mit allen bisher hochgeladenen Berichtsvorlagen angezeigt.
  2. Klicken Sie auf den Namen der Berichtsvorlage, für die Sie Berechtigungen und Zuordnungen einrichten oder bearbeiten möchten. Der Dialog Berichtsvorlage bearbeiten wird angezeigt.
  3. Verwenden Sie die Felder Name, Dateiname und Beschreibung um die Berichtseigenschaften zu bearbeiten.
  4. In der Liste Module können Sie auswählen, ob die Berichtsvorlage für Issue Manager und/oder für Test Manager-Berichte verwendet werden kann.
  5. Haben Sie die Bearbeitung abgeschlossen, klicken Sie auf OK, um die Änderungen für die Berichtsvorlage zu speichern. Die von Ihnen vorgenommenen Änderungen werden sofort wirksam. Benutzer sehen die Änderungen, sobald sie das nächste Mal auf die Liste der Berichte zugreifen oder sie aktualisieren.
Übergeordnetes Thema: Verwalten von Berichtsvorlagen


Herunterladen von Berichtsvorlagen

Die Berichtsvorlage des ausgewählten Berichts, einschließlich des Layouts, wird heruntergeladen. Wenn Sie Silk Central-Berichtsvorlagen auf Ihr lokales System herunterladen, können Sie sie bearbeiten. Nach der Bearbeitung eines heruntergeladenen Berichts können Sie ihn für anderen Benutzer wieder hochladen. Weitere Informationen finden Sie unter Hochladen von Berichtsvorlagen.

So laden Sie eine Silk Central-Berichtsvorlage herunter:

  1. Klicken Sie im Menü auf Verwaltung > Berichtsvorlagen. Die Seite Berichtsvorlagen wird mit allen bisher hochgeladenen Berichtsvorlagen angezeigt.
  2. Klicken Sie in der Spalte Aktionen des Berichts, den Sie herunterladen möchten, auf Berichtsvorlage herunterladen. Der Dialog Dateidownload wird angezeigt.
  3. Klicken Sie auf Speichern, und laden Sie die Berichtsdatei je nach ausgewähltem Berichtstyp auf Ihr lokales System herunter.
  4. Ändern Sie nun den Bericht wie gewünscht im BIRT Report Designer (für rptdesign-Dateien), in Word (für docx-Dateien) oder in Excel (für xls/xlsx-Dateien).
Übergeordnetes Thema: Verwalten von Berichtsvorlagen


Hochladen von Berichtsvorlagen

Wenn Sie Silk Central-Berichtsvorlagen hochladen, werden sie für andere Benutzer verfügbar. Sie möchten vielleicht eine Berichtsvorlage, die Sie mit BIRT Report Designer, Microsoft Word oder Microsoft Excel bearbeitet haben, hochladen. Sie können einen Bericht nur dann ausführen, wenn Sie auf das mit dem Bericht verbundene Projekt und das Modul zugreifen können.

Tipp: Vorlagen müssen mit zusätzlichen Informationen konfiguriert werden, damit sie identifiziert werden können, sobald sie auf Silk Central hochgeladen wurden.
Anmerkung: Silk Central-Berichte unterstützen das Bitmap-Format (.bmp) nicht. Bilder müssen in den Formaten JPEG, GIF oder PNG vorliegen.

So laden Sie eine benutzerdefinierte Vorlage als neuen Bericht hoch:

  1. Klicken Sie im Menü auf Verwaltung > Berichtsvorlagen. Die Seite Berichtsvorlagen wird mit allen bisher hochgeladenen Berichtsvorlagen angezeigt.
  2. Klicken Sie unten auf der Seite auf Hochladen. Der Dialog Berichtsvorlage hochladen wird angezeigt.
  3. Geben Sie einen Namen für den Bericht ein.
  4. Optional: Geben Sie eine Beschreibung des Berichts ein.
  5. Wählen Sie im Listenfeld Module die Module, denen der Bericht zugeordnet werden soll. Halten Sie die Taste Strg gedrückt, um mehrere Module auszuwählen.
  6. Klicken Sie auf Durchsuchen neben dem Feld Datei.
  7. Suchen und wählen Sie die Vorlagendatei, die Sie als Grundlage für die Berichtsvorlage verwenden möchten. Die Datei muss die Dateierweiterung rptdesign, docx, xlsx, oder xls aufweisen.
  8. Klicken Sie auf OK, um die Berichtsvorlage für die Verwendung in Silk Central hochzuladen.
Übergeordnetes Thema: Verwalten von Berichtsvorlagen


Aktualisieren von Berichtsquellen

Die Aktualisierung einer vorhandenen Silk Central-Berichtsvorlage erlaubt Ihnen, einen Bericht, den Sie mit BIRT Report Designer, Microsoft Word oder Microsoft Excel angepasst haben, in Silk Central zu verschieben und ihn für andere Benutzer verfügbar zu machen.

ACHTUNG:
Die mit Silk Central gelieferten Berichtsvorlagen werden automatisch aktualisiert, wenn Sie auf eine neue Version upgraden. Es ist daher wichtig, dass Sie Ihre benutzerdefinierten Berichtsvorlagen in einem eigens dafür vorgesehenen Ordner speichern oder diese Berichtsvorlagen als neue Vorlagen hochladen. Weitere Informationen finden Sie unter Hochladen von Berichtsvorlagen.

So aktualisieren Sie eine Berichtsvorlage durch eine geänderte Vorlagendatei:

  1. Klicken Sie im Menü auf Verwaltung > Berichtsvorlagen. Die Seite Berichtsvorlagen wird mit allen bisher hochgeladenen Berichtsvorlagen angezeigt.
  2. Klicken Sie in der Spalte Aktion des Berichts, den Sie aktualisieren möchten, auf Aktualisieren.
  3. Klicken Sie im Dialog Berichtsvorlage aktualisieren auf Durchsuchen, um die Vorlagendatei zu suchen und auszuwählen, die die vorhandene Vorlagendatei ersetzen soll. Die Datei muss die Dateierweiterung rptdesign, docx, xlsx, oder xls aufweisen.
  4. Klicken Sie auf OK, um die Datei herunterzuladen und dabei die Datei zu überschreiben, die bisher als Berichtsvorlage verwendet wurde.
Übergeordnetes Thema: Verwalten von Berichtsvorlagen


Löschen von Berichtsvorlagen

Sie können einen Silk Central-Bericht aus der Liste verfügbarer Berichte entfernen.

So löschen Sie einen Silk Central-Bericht:

  1. Klicken Sie im Menü auf Verwaltung > Berichtsvorlagen. Die Seite Berichtsvorlagen wird mit allen bisher hochgeladenen Berichtsvorlagen angezeigt.
  2. Klicken Sie in der Spalte Aktion des Berichts, den Sie löschen möchten, auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  3. Klicken Sie auf Ja, um den Bericht aus der Liste zu löschen.
Übergeordnetes Thema: Verwalten von Berichtsvorlagen


Berichtsvorlagen (Seite)

Verwaltung > Berichtsvorlagen

Mithilfe der Seite Berichtsvorlagen verwalten Sie Berichtsvorlagen, die Sie Silk Central zur Berichtserstellung zur Verfügung stellen möchten. Berichtsvorlagen sind global in allen Projekten und für alle Berichte verwendbar.

Klicken Sie auf Hochladen, um eine neue Berichtsvorlage von Ihrer Festplatte oder einem UNC-Pfad in Silk Central hochzuladen.

Zu jedem aufgeführten Bericht werden folgende Spalten angezeigt:

Spalte | Beschreibung
Titel | Der Name der Berichtsvorlage, wie er in der Benutzeroberfläche der Anwendung angezeigt wird.
Dateiname | Der Name der physischen Berichtsvorlagendatei.
Hochgeladen am | Datum, an dem die Berichtsvorlage in Silk Central hochgeladen wurde.
Hochgeladen von | Der Name des Benutzers, der die Berichtsvorlage in Silk Central hochgeladen hat.
Modul | Die Silk Central-Anwendung, die auf die Berichtsvorlage zugreifen kann. Wenn eine Vorlage keinem Modul zugeordnet ist, kann sie in jeder Anwendung verwendet werden.
Aktionen Diese Spalte enthält Aktionssymbole, mit denen der Benutzer die folgenden Aktionen mit einer Berichtsvorlage ausführen kann:
Aktualisieren
Ersetzt die aktuell hochgeladene Vorlage durch eine neue Vorlage.
Herunterladen
Lädt die Vorlage auf den lokalen Computer herunter.
Löschen
Löscht die Vorlage dauerhaft.
Übergeordnetes Thema: Verwalten von Berichtsvorlagen


Audit-Log

Verwaltung > Log-Dateien > Audit-Log

Die Audit-Log-Datei ermöglicht es Administratoren, alle aufgezeichneten Silk Central-Benutzeraktivitäten einzusehen. In der Log-Datei werden Informationen zu allen An- und Abmeldevorgängen sowie zu allen Änderungen der Silk Central-Datenbank (z. B. Projekte, Tests, Ausführungstermine) gespeichert.

Sie können die Einträge der Log-Datei mithilfe der unten aufgeführten Funktionen bearbeiten und an Ihre persönlichen Anforderungen anpassen.

Sortieren nach Spalte

Klicken Sie auf eine Spaltenüberschrift, um die aufgeführten Daten nach der betreffenden Spalte zu sortieren. Wenn Sie nochmals auf die gleiche Spaltenüberschrift klicken, wird die Sortierreihenfolge von aufsteigend in absteigend geändert.

Auswahl eines Bereichs im Kalender

Klicken Sie auf den angezeigten Zeitraum, um den Kalender zu erweitern. In den Zeilen Von und Bis des Kalenders können Sie ein Start- und ein Enddatum für den Zeitraum angeben, dessen Daten angezeigt werden sollen. Nachdem Sie in den Listenfeldern für Von und Bis jeweils ein Datum angegeben haben, klicken Sie auf Aktualisieren, um die Anzeige der Audit-Protokolldaten dem gewählten Zeitraum entsprechend zu aktualisieren.

Mit den Links Tag, Woche, Monat, Quartal, [letzte 7 Tage], [letzte 31 Tage] können Sie den Kalender umgehen und stattdessen die Daten der betreffenden Zeiträume direkt anzeigen.

Sie können den ausgewählten Zeitraum mit den Pfeilen Früher und Später jeweils um die gewählte Zeitspanne nach vorne und nach hinten verschieben, z. B.:
  • Einen Tag
  • Eine Woche
  • Ein Monat
  • Ein Quartal

Mit Vergrößern und Verkleinern kann der im Audit-Log angezeigte Zeitraum verlängert und verkürzt werden. Durch einmaliges Klicken auf Vergrößern wird der Zeitraum um 50 % verlängert. Durch einmaliges Klicken auf Verkleinern wird der Zeitraum um 50 % verkürzt.

Wenn im Kalender ein benutzerdefinierter Zeitraum angezeigt wird, z. B. nachdem vergrößert oder verkleinert wurde, kann der gewählte Zeitraum mit den linken Schaltflächen (Früher oder Später) jeweils um die Hälfte der gewählten Zeitspanne nach vorn oder hinten verschoben werden.

Tipp: Nach der Festlegung eines neuen Zeitraums klicken Sie auf Aktualisieren, um den Bericht zu aktualisieren.

Filtern

Mithilfe der Filteroptionen können Sie gezielt die zu analysierenden Protokolldaten anzeigen.

Die aufgeführten Daten können nach folgenden Kriterien gefiltert werden:
Anmeldung
Zeigt die Aktionen an, die im Zusammenhang mit einer bestimmten Benutzeranmeldung ausgeführt wurden.
Objekt
Zeigt die Aktionen an, die an einem bestimmten Datenbankelement ausgeführt wurden, z. B. Projekt oder Servergruppe.
Vorgang
Zeigt ausgewählte Vorgänge an, z. B. Anmelden, Abmelden, Erstellen oder Löschen.
  • Zugreifen auf das Audit-Log und Anzeigen des Audit-Logs
    Greifen Sie auf das Audit-Log zu, und zeigen Sie es an, um alle aufgezeichneten Benutzeraktivitäten zu prüfen.
  • Audit-Log (Seite)
    Mit Hilfe dieser Seite können Sie alle aufgezeichneten Silk Central anzeigen.
Übergeordnetes Thema: Verwaltung


Zugreifen auf das Audit-Log und Anzeigen des Audit-Logs

So zeigen Sie das Audit-Log an:

  1. Klicken Sie im Menü auf Verwaltung > Log-Dateien.
  2. Klicken Sie auf die Registerkarte Audit-Log.
  3. Wählen Sie einen Kalenderbereich aus, um die Liste der Protokolleinträge einzuschränken.
  4. Mithilfe der Filteroptionen können Sie gezielt die zu analysierenden Protokolldaten anzeigen.
Übergeordnetes Thema: Audit-Log


Audit-Log (Seite)

Verwaltung > Log-Dateien > Audit-Log

Mit Hilfe der Seite Audit-Log können Sie alle aufgezeichneten Silk Central anzeigen.

Element | Beschreibung
Kalenderbereich | Wählen Sie einen Kalenderbereich aus, um die Liste der Protokolleinträge einzuschränken.
Filterbereich | Mithilfe der Filteroptionen können Sie gezielt die zu analysierenden Protokolldaten anzeigen. Klicken Sie auf Aktualisieren, um die Liste den Filtereinstellungen entsprechend zu aktualisieren.
Ergebnisbereich | In diesem Bereich werden aufgezeichneten Daten angezeigt. Mithilfe der Seitennummern können Sie verschiedene Seiten auswählen. Klicken Sie auf eine Spaltenüberschrift, um die Daten nach der festgelegten Spalte zu sortieren.

Detaillierte Informationen zu den Kalender- und Filteroptionen finden Sie unter Audit-Log.

Übergeordnetes Thema: Audit-Log


Server-Protokolldateien

Der Front-End-Server, der Anwendungsserver und der Ausführungsserver erstellen Protokolldateien. Diese Dateien enthalten wertvolle Informationen für die Fehleranalyse. Silk Central ermöglicht es Administratoren, diese Dateien mithilfe der Webschnittstelle direkt anzuzeigen, zu durchsuchen und herunterzuladen.

  • Herunterladen von Server-Protokolldateien
    Laden Sie eine Server-Protokolldatei auf Ihren lokalen Computer herunter, um die Daten, z. B. in Microsoft Excel, genauer zu analysieren.
  • Analysieren von Server-Logdateien
    Analysieren Sie eine Server-Protokolldatei, um zu prüfen, ob es fehlerhafte Server-Aktivitäten gibt.
  • Löschen von Server-Protokolldateien
    Löschen Sie eine vorhandene Server-Protokolldatei, wenn Sie die Daten nicht mehr benötigen.
  • Verwalten von Logdateien
    Hier wird beschrieben, wie Sie festlegen können, wie viele Details in Server-Logdateien aufgenommen werden .
  • Front-End-Server-Log (Seite)
    Mithilfe dieser Seite können Sie Protokolldaten des Silk Central-Front-End-Serverdienstes anzeigen.
  • Anwendungsserver-Log (Seite)
    Mithilfe dieser Seite können Sie Protokolldaten des Silk Central-Anwendungsserverdienstes anzeigen.
  • Ausführungsserver-Log (Seite)
    Mithilfe dieser Seite können Sie Protokolldaten des Silk Central-Ausführungsserverdienstes anzeigen.
Übergeordnetes Thema: Verwaltung


Herunterladen von Server-Protokolldateien

Sie können eine Server-Protokolldatei im CSV-Format auf Ihren lokalen Computer herunterladen, um sie zum Beispiel in Microsoft Excel genauer zu analysieren.

So laden Sie eine Server-Protokolldatei herunter:

  1. Klicken Sie im Menü auf Verwaltung > Logdateien.
  2. Klicken Sie auf die Registerkarte des Servers, zu dem die Logdatei gehört.
    • Front-End-Server-Logdatei
    • Anwendungsserver-Log
    • Ausführungsserver-Log
    Eine chronologisch geordnete Liste von Logdateien wird angezeigt. Die Namen der Logdateien setzen sich aus dem Namen der Serverkomponente und einem Suffix mit einer Zeitangabe zusammen. Die aktuellen Protokolldateien tragen die Namen FrontendServer.log, AppServer.log und ExecServer.log.
    Anmerkung: Um nach einer Logdatei des Ausführungsservers zu suchen, navigieren Sie über seine Servergruppe zu diesem Ausführungsserver.
  3. Klicken Sie in der Spalte Aktionen der Protokolldatei auf Herunterladen. Alternativ: Um den Inhalt der Protokolldateien vor dem Herunterladen anzuzeigen, klicken Sie auf den Namen der gewünschten Protokolldatei. Die ausgewählte Protokolldatei wird zusammen mit ihren chronologisch geordneten Einträgen angezeigt. Klicken Sie unten auf der Seite auf die Schaltfläche Als CSV herunterladen.
  4. Um die Daten in einem Tabellenverarbeitungsprogramm anzuzeigen, wählen Sie im folgenden Dialogfeld Öffnen. Zum Speichern der Daten auf der Festplatte wählen Sie Speichern.
Übergeordnetes Thema: Server-Protokolldateien


Analysieren von Server-Logdateien

So wird eine Server-Protokolldatei analysiert:

  1. Klicken Sie im Menü auf Verwaltung > Logdateien.
  2. Klicken Sie auf die Registerkarte des Servers, zu dem die Logdatei gehört.
    • Front-End-Server-Logdatei
    • Anwendungsserver-Log
    • Ausführungsserver-Log
    Eine chronologisch geordnete Liste von Logdateien wird angezeigt. Die Namen der Logdateien setzen sich aus dem Namen der Serverkomponente und einem Suffix mit einer Zeitangabe zusammen. Die aktuellen Protokolldateien tragen die Namen FrontendServer.log, AppServer.log und ExecServer.log.
    Anmerkung: Um nach einer Logdatei des Ausführungsservers zu suchen, navigieren Sie über seine Servergruppe zu diesem Ausführungsserver.
  3. Klicken Sie auf den Namen der Protokolldatei, die Sie ansehen möchten. Die ausgewählte Protokolldatei wird zusammen mit ihren chronologisch geordneten Einträgen angezeigt.
  4. Mithilfe der Filteroptionen können Sie die aufgezeichneten Protokolldaten seitenweise ansehen.
    Die aufgeführten Daten können nach folgenden Kriterien gefiltert werden:
    Schweregrad
    Zeigt Ereignisse des gewählten Schweregrads an.
    Log-Stufe
    Zeigt Ereignisse an, die der gewählten Log-Stufe entsprechen. Detailliertere Protokolldaten können nur angezeigt werden, wenn auch auf dem Server die entsprechende Log-Stufe festgelegt ist. Weitere Informationen zum Konfigurieren der Log-Stufe eines Servers finden Sie unter Log-Stufen.
    Modul
    Zeigt Protokolldaten für ein ausgewähltes Modul an. Protokolldaten können nur dann angezeigt werden, wenn das jeweilige Produkt (das Modul) installiert und mit dem Front-End-Server verbunden ist, auf den Sie zugreifen.
Übergeordnetes Thema: Server-Protokolldateien


Löschen von Server-Protokolldateien

ACHTUNG:
Durch die Löschung wird die Protokolldatei dauerhaft von dem Server entfernt. Sie können sich die in der gelöschten Datei protokollierten Daten nicht mehr anzeigen lassen.

So löschen Sie eine Server-Protokolldatei:

  1. Klicken Sie im Menü auf Verwaltung > Logdateien.
  2. Klicken Sie auf die Registerkarte des Servers, zu dem die Logdatei gehört.
    • Front-End-Server-Logdatei
    • Anwendungsserver-Log
    • Ausführungsserver-Log
    Eine chronologisch geordnete Liste von Logdateien wird angezeigt. Die Namen der Logdateien setzen sich aus dem Namen der Serverkomponente und einem Suffix mit einer Zeitangabe zusammen. Die aktuellen Protokolldateien tragen die Namen FrontendServer.log, AppServer.log und ExecServer.log.
    Anmerkung: Um nach einer Logdatei des Ausführungsservers zu suchen, navigieren Sie über seine Servergruppe zu diesem Ausführungsserver.
  3. Klicken Sie in der Spalte Aktionen der Protokolldatei, die Sie entfernen möchten, auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  4. Klicken Sie auf Nein, um die Protokolldatei beizubehalten; oder klicken Sie auf Ja, um die Protokolldatei aus der Liste zu entfernen. Haben Sie auf Ja geklickt, wird die Liste der Protokolldateien neu aufgebaut, wobei die gelöschte Protokolldatei nicht mehr enthalten ist.
Übergeordnetes Thema: Server-Protokolldateien


Verwalten von Logdateien

Jeder Silk Central-Server protokolliert seine Aktivitäten in einer Log-Datei. Weitere Informationen über Silk Central-Server finden Sie unter Silk Central-Architektur. Wenn Anwendungs- oder Systemfehler auftreten, stellen diese Logdateien wertvolle Informationen hinsichtlich der Hauptproblemursachen zur Verfügung. Sie können festlegen, wie viele Details in Server-Logdateien aufgenommen werden .

Auf die Logdateien für die Silk Central-Server kann über Verwaltung > Logdateien zugegriffen werden.

  • Ändern der Log-Stufen der Silk Central-Server
    Ändern Sie die Detailstufe des Silk Central-Servers, um Daten aus Logdateien ein- oder auszuschließen.
Übergeordnetes Thema: Server-Protokolldateien
Zugehörige Verweise
Silk Central-Architektur


Ändern der Log-Stufen der Silk Central-Server

Die folgenden Server erzeugen Logdateien:
  • Front-End-Server
  • Anwendungsserver
  • Ausführungsserver

So ändern Sie die Log-Stufe eines Silk Central-Servers:

  1. Stoppen Sie den Server, für den Sie die Log-Stufe ändern möchten.
  2. Je nachdem, für welchen Server Sie die Log-Stufe ändern möchten, öffnen Sie die entsprechende Datei in einem Texteditor:
    Front-End-Server
    SccFrontendBootConf.xml, im Ordner /conf/frontendserver des Verzeichnisses Silk Central auf dem Front-End-Server.
    Anwendungsserver
    SccAppServerBootConf.xml, im Ordner /conf/appserver des Verzeichnisses Silk Central auf dem Anwendungsserver.
    Ausführungsserver
    SccExecServerBootConf.xml, im Ordner /conf/execserver des Verzeichnisses Silk Central auf dem Ausführungsserver.
  3. Suchen Sie den XML-Tag <LogLevel> im Abschnitt <Log> der Datei.
  4. Legen Sie als Wert die Log-Stufe fest, die zur Protokollierung der Daten verwendet werden soll. Die folgenden Log-Stufen sind verfügbar:
    Wert | Log-Stufe | Beschreibung
    0 | Übersicht | Der Server protokolliert nur die wichtigsten Informationen in den Logdateien. Dies ist die Standardeinstellung.
    1 Detailliert Der Server protokolliert zusätzliche Informationen in den Logdateien:
    Front-End-Server
    Verbindungsdaten und Daten zur Ereignisweiterleitung.
    Anwendungsserver
    Aktivitäten im Zusammenhang mit der Ausgabe und dem Abruf von Ergebnissen.
    Ausführungsserver
    Aktivitäten im Zusammenhang mit der Transaktionsausführung.
    2 Beschreibend Der Server protokolliert zusätzliche Informationen in den Logdateien:
    Front-End-Server
    Benutzerverwaltungsdaten, z. B. Cookie-Verwaltung.
    Anwendungsserver
    Detaillierte Informationen im Zusammenhang mit der Ausgabe und dem Abruf von Ergebnissen.
    Ausführungsserver
    Detaillierte Informationen zur Transaktionsausführung und Bandbreite.
    3 | Debuggen | Dies ist die detaillierteste Log-Stufe, die nur zum Debuggen schwerer Fehler verwendet werden sollte.
  5. Speichern und schließen Sie die XML-Datei, und starten Sie dann den Server neu.
Übergeordnetes Thema: Verwalten von Logdateien


Front-End-Server-Log (Seite)

Verwaltung > Logdateien > Front-End-Server-Log

Mithilfe dieser Seite können Sie Protokolldaten des Silk Central-Front-End-Serverdienstes anzeigen.

Zu jeder Log-Datei werden folgende Spalten angezeigt:

Spalte | Beschreibung
Aktionen | Klicken Sie auf die Schaltflächen [image] oder [image] , um Logdateien zu löschen oder herunterzuladen.
Name | Der Name der Logdatei.
Größe | Die physische Größe der Logdatei.
Datum | Datum, an dem die Logdatei zuletzt gespeichert wurde.

Verwaltung > Logdateien > Front-End-Server-Log > Dateiname, Front-End-Server-Log .

Wenn Sie auf den Name einer Log-Datei klicken, wird die Liste mit den Protokolldetails angezeigt. Die Liste enthält die folgenden Elemente:

Element | Beschreibung
Filterbereich | Mithilfe der Filteroptionen können Sie die Liste nach Kategorie, Log-Stufe und Modul filtern. Klicken Sie auf Aktualisieren, um die Liste den Filtereinstellungen entsprechend zu aktualisieren.
Tabellenbereich Enthält die folgenden Protokolldaten:
Schweregrad
Kategorie des Ereignisses:
  • System-Info
  • Warnung
  • Fehler
Log-Stufe
Log-Stufe des Ereignisses:
  • OV = Übersicht
  • DT = Detailliert
  • VB = Beschreibend
  • DB = Debuggen

Klicken Sie auf Zurück, um zur Seite Front-End-Server-Log zurückzukehren. Zum Herunterladen der Log-Datei auf Ihren lokalen Computer als CSV-Datei, klicken Sie auf Als CSV herunterladen.

Übergeordnetes Thema: Server-Protokolldateien


Anwendungsserver-Log (Seite)

Verwaltung > Log-Dateien > Anwendungsserver-Log

Mithilfe dieser Seite können Sie Protokolldaten des Silk Central-Anwendungsserverdienstes anzeigen.

Zu jeder Log-Datei werden folgende Spalten angezeigt:

Spalte | Beschreibung
Aktionen | Klicken Sie auf die Schaltflächen [image] oder [image] , um Logdateien zu löschen oder herunterzuladen.
Name | Der Name der Logdatei.
Größe | Die physische Größe der Logdatei.
Datum | Datum, an dem die Logdatei zuletzt gespeichert wurde.

Verwaltung > Logdateien > Anwendungsserver-Log > Anwendungsserver-Log-Dateiname.

Wenn Sie auf den Name einer Log-Datei klicken, wird die Liste mit den Protokolldetails angezeigt. Die Liste enthält die folgenden Elemente:

Element | Beschreibung
Filterbereich | Mithilfe der Filteroptionen können Sie die Liste nach Kategorie, Log-Stufe und Modul filtern. Klicken Sie auf Aktualisieren, um die Liste den Filtereinstellungen entsprechend zu aktualisieren.
Tabellenbereich Enthält die folgenden Protokolldaten:
Schweregrad
Kategorie des Ereignisses:
  • System-Info
  • Warnung
  • Fehler
Log-Stufe
Log-Stufe des Ereignisses:
  • OV = Übersicht
  • DT = Detailliert
  • VB = Beschreibend
  • DB = Debuggen

Klicken Sie auf Zurück, um zur Seite Anwendungsserver-Log zurückzukehren. Zum Herunterladen der Log-Datei auf Ihren lokalen Computer als CSV-Datei, klicken Sie auf Als CSV herunterladen.

Übergeordnetes Thema: Server-Protokolldateien


Ausführungsserver-Log (Seite)

Verwaltung > Log-Dateien > Ausführungsserver-Log

Mithilfe dieser Seite können Sie Protokolldaten des Silk Central-Ausführungsserverdienstes anzeigen.

Zu jeder Servergruppe werden folgende Spalten angezeigt:

Spalte | Beschreibung
Speicherort | Zeigt alle verfügbaren Servergruppen an.
Ausführungsserver | Zeigt die Anzahl der Ausführungsserver pro Servergruppe an.
Status | Zeigt zusammenfassende Statusinformationen zu den Ausführungsservern der Servergruppe an.

Verwaltung > Log-Dateien > Ausführungsserver-Log > Name der Servergruppe

Wenn Sie auf den Namen einer Servergruppe klicken, wird eine Liste der zur ausgewählten Servergruppe gehörigen Ausführungsserver angezeigt. In der Liste werden zu jedem Ausführungsserver folgende Spalten angezeigt.

Spalte | Beschreibung
Name des Ausführungsservers | Der Name des Ausführungsservers.
Host | Der Name des Computers, auf dem der Ausführungsservers installiert ist.
Typ | Die Silk Central-Anwendung, für die der Ausführungsserver konfiguriert ist. Für Silk Central wird immer der Typ Silk Central angegeben.
Zugeordnete Aufgaben | Die Anzahl der Aufgaben, die gegenwärtig auf dem Ausführungsserver geplant sind.
Status | Der Status des Ausführungsservers. Aktiv oder Inaktiv.

Klicken Sie auf Zurück, um zur Liste der Servergruppen zurückzukehren.

Verwaltung > Log-Dateien > Ausführungsserver-Log > Name der Servergruppe > Name des Ausführungsservers

Wenn Sie auf den Namen eines Ausführungsservers klicken, wird die Liste der Log-Dateien für den ausgewählten Ausführungsserver angezeigt. Zu jeder Log-Datei werden folgende Spalten angezeigt:
Spalte | Beschreibung
Aktionen | Klicken Sie auf die Schaltflächen [image] oder [image] , um Logdateien zu löschen oder herunterzuladen.
Name | Der Name der Logdatei.
Größe | Die physische Größe der Logdatei.
Datum | Datum, an dem die Logdatei zuletzt gespeichert wurde.

Klicken Sie auf Zurück, um zur Liste der Ausführungsserver zurückzukehren.

Verwaltung > Log-Dateien > Ausführungsserver-Log > Name der Servergruppe > Name des Ausführungsservers > Dateiname, Ausführungsserver-Log

Wenn Sie auf den Name einer Log-Datei klicken, wird die Liste mit den Protokolldetails angezeigt. Die Liste enthält die folgenden Elemente:

Element | Beschreibung
Filterbereich | Mithilfe der Filteroptionen können Sie die Liste nach Kategorie, Log-Stufe und Modul filtern. Klicken Sie auf Aktualisieren, um die Liste den Filtereinstellungen entsprechend zu aktualisieren.
Tabellenbereich Enthält die folgenden Protokolldaten:
Schweregrad
Kategorie des Ereignisses:
  • System-Info
  • Warnung
  • Fehler
Log-Stufe
Log-Stufe des Ereignisses:
  • OV = Übersicht
  • DT = Detailliert
  • VB = Beschreibend
  • DB = Debuggen

Klicken Sie auf Zurück, um zur Seite Ausführungsserver-Log zurückzukehren. Zum Herunterladen der Log-Datei auf Ihren lokalen Computer als CSV-Datei, klicken Sie auf Als CSV herunterladen.

Übergeordnetes Thema: Server-Protokolldateien


Integrieren von Aufgabenverwaltungssystemen

Mithilfe der Vorlage für agile Projekte können Tests externer Aufgabenverwaltungstools in Silk Central integriert werden.

Die Vorlage für agile Projekte ist ein Silk Central-Projekt mit den vordefinierten Attributen "Release" und "Sprint". Bei der Erstellung eines Projekts auf der Basis der Vorlage für agile Projekte werden ein leerer Unterordner und ein Container für das neue Projekt erstellt. Die Tests des externen Aufgabenverwaltungssystems können dann in die Vorlage eingefügt werden. Informationen zum Erstellen eines Projekts mithilfe der Vorlage für agile Projekte finden Sie unter Hinzufügen von Projekten.

Folgende Aufgabenverwaltungstools werden von Silk Central gegenwärtig standardmäßig unterstützt:

Aufgabenverwaltungssystem
Beschreibung
VersionOne

VersionOne ist ein Projektplanungs- und Projektmanagementsystem, das speziell auf die agile Softwareentwicklung abgestimmt ist. Es umfasst agile und iterative Verwaltungsfunktionen, etwa für die Release-Planung, die Iterationsplanung und -verfolgung, das User Story- und Backlog-Management und die Aufgabenverwaltung.

  • Integrieren von VersionOne in Silk Central
    Hier wird beschrieben, wie Tests von VersionOne integriert werden, um sie mit Silk Central zu verwalten.
Übergeordnetes Thema: Verwaltung


Integrieren von VersionOne in Silk Central

So integrieren Sie Tests von VersionOne in Silk Central:
  1. Fügen Sie ein neues Silk Central-Projekt hinzu, und wenden Sie die Vorlage für ein agiles Projekt auf das Projekt an. Informationen zum Hinzufügen eines auf einer agilen Vorlage basierenden Projekts zu Silk Central finden Sie unter Hinzufügen von Projekten.
  2. Öffnen Sie den Datei-Explorer.
  3. Navigieren Sie zu der XML-Konfigurationsdatei von VersionOne (VersionOneConfig.xml). Der Standardpfad für die Datei lautet C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<Instanznummer>_<Instanzname>\wwwrootAS\VersionOneIntegration.
  4. Öffnen Sie die VersionOne-XML-Konfigurationsdatei in einem Editor.
  5. Legen Sie die entsprechenden Einstellungen in dieser Datei fest. Ausführliche Informationen zu den Einstellungen in der VersionOne-XML-Konfigurationsdatei finden Sie in den Kommentaren zu VersionOneConfig.xml.
  6. Speichern und schließen Sie die Konfigurationsdatei.
    Anmerkung: Sie müssen den Anwendungsserver nach der Bearbeitung der Konfigurationsdatei nicht neu starten, da die Datei automatisch aktualisiert wird.
  7. Navigieren Sie in Silk Central zum Bereich Tests. Der leere Container ist als unvollständig gekennzeichnet, da Sie ein Produkt auswählen müssen.
  8. Klicken Sie auf den Container, öffnen Sie die Registerkarte Eigenschaften, und klicken Sie auf den Produkt-Link, um das Produkt auszuwählen.

VersionOne ist nun in Silk Central integriert. Neue Testaufgaben in VersionOne, für die Sie einen entsprechenden Benutzer festgelegt haben, werden als manuelle Tests in den Standardintegrationsordner im ausgewählten Silk Central-Projekt eingefügt. Der Teststatus wird nun zwischen Silk Central und VersionOne ausgetauscht.

Änderungen an der VersionOne-Intergration werden in der Datei VersionOneIntegration.log protokolliert. Der Standardpfad für die Log-Datei lautet C:\ProgramData\SilkCentral\instance_<Instanznummer>_<Instanzname>\log\.

Anmerkung: Um VersionOne in eine japanische Version von Silk Central zu integrieren, müssen Sie in der Registrierung die Startoptionen des Anwendungsserverdienstes auf -Dfile.encoding=utf-8 ändern.
Übergeordnetes Thema: Integrieren von Aufgabenverwaltungssystemen


Verwalten von Wertelisten

Wertelisten dienen zur Definition von Werten für benutzerdefinierte Eigenschaften in benutzerdefinierten Fehlerregisterkarten, die für Issue Manager unter Fehler > Konfiguration eingestellt werden können. Hinweise zu benutzerdefinierten Fehlereigenschaften und Registerkarten finden Sie in den Themen Issue Manager in dieser Hilfe.

  • Hinzufügen von Wertelisten
    Fügen Sie eine neue Werteliste hinzu, um benutzerdefinierte Eigenschaften in benutzerdefinierten Fehlerregisterkarten zu füllen.
  • Bearbeiten von Wertelisten
    Bearbeiten Sie eine vorhandene Werteliste.
  • Bearbeiten einzelner Werte
    Bearbeiten Sie einzelne Werte in einer Werteliste.
  • Aktivieren und Deaktivieren von Wertelisten
    Aktivieren oder deaktivieren Sie eine vorhandene Werteliste in Silk Central.
  • Aktivieren und Deaktivieren einzelner Werte
    Aktivieren oder deaktivieren Sie einen einzelnen Wert in einer Werteliste.
  • Sortieren von Werten in Wertelisten
    Verschieben Sie Werte in der Liste nach oben bzw. nach unten, und sortieren Sie die Werteliste automatisch.
  • Löschen von Wertelisten
    Löschen Sie eine vorhandene Werteliste.
  • Löschen einzelner Werte
    Löschen Sie einzelne Werte aus einer Werteliste.
  • Werteliste (Seite)
    Mithilfe dieser Seite können Sie Wertelisten konfigurieren.
Übergeordnetes Thema: Verwaltung


Hinzufügen von Wertelisten

So fügen Sie eine neue Werteliste hinzu:

  1. Klicken Sie im Menü auf Verwaltung > Wertelisten.
  2. Klicken Sie auf Neue Liste. Der Dialog Neue Werteliste wird geöffnet.
  3. Geben Sie in das Feld Name einen Namen und in das Feld Beschreibung eine Beschreibung für die neue Werteliste ein.
  4. Wählen Sie im Listenfeld Gruppieren nach einen Parameter aus, nach dem die Liste gruppiert werden soll.

    Diese Auswahl ist endgültig und kann nicht mehr geändert werden, nachdem Sie die Liste gespeichert haben. Das Gruppieren von Werten bedeutet, dass jedem Wert in Ihrer Liste ein Wert aus der Liste zugeordnet werden muss, die Sie im Listenfeld Gruppieren nach ausgewählt haben. Das Nicht-Gruppieren von Werten bedeutet, dass Sie eigene Werte definieren können.

  5. Klicken Sie auf Neuer Wert, um einen Wert in die Liste einzufügen. Der Dialog Neuer Wert wird geöffnet.
  6. Geben Sie einen Namen und eine Beschreibung für den neuen Wert ein.
  7. Wählen Sie ggf. im Listenfeld Gruppieren nach einen Wert aus.
  8. Wählen Sie im Listenfeld Einfügen nach die Position des neuen Werts innerhalb der Liste vorhandener Werte, oder wählen Sie <letzter Eintrag>, damit der neue Wert an das Ende der Liste angehängt wird.
  9. Klicken Sie auf OK, um den Wert zu speichern. Der neue Wert wird im Dialog Neue Werteliste angezeigt.
  10. Fügen Sie so viele weitere Werte ein, wie erforderlich sind, um die Werteliste zu vervollständigen.
  11. Klicken Sie auf OK, um die Werteliste zu speichern.
Übergeordnetes Thema: Verwalten von Wertelisten


Bearbeiten von Wertelisten

So bearbeiten Sie eine vorhandene Werteliste:

  1. Klicken Sie im Menü auf Verwaltung > Wertelisten.
  2. Klicken Sie auf den Namen der Werteliste, die Sie bearbeiten möchten. Der Dialog Werteliste bearbeiten wird geöffnet.
  3. Ändern Sie für die ausgewählte Werteliste die Einstellungen Name, Beschreibung und Gruppieren nach. Klicken Sie anschließend auf OK.
    Anmerkung: Jeder einzelne Wert, der in dieser Liste enthalten ist, kann ebenfalls bearbeitet werden. Details zum Bearbeiten einzelner Werte finden Sie unter Bearbeiten einzelner Werte.
Übergeordnetes Thema: Verwalten von Wertelisten


Bearbeiten einzelner Werte

So bearbeiten Sie einzelne Werte in einer Werteliste:

  1. Klicken Sie im Menü auf Verwaltung > Wertelisten.
  2. Klicken Sie auf den Namen der Werteliste, die Sie bearbeiten möchten. Der Dialog Werteliste bearbeiten wird geöffnet.
  3. Klicken Sie auf den Namen des Werts, den Sie bearbeiten möchten. Das Dialogfeld Wert bearbeiten wird geöffnet.
  4. Ändern Sie ggf. Namen und Beschreibung des Werts.
  5. Klicken Sie auf OK, um die Änderungen zu speichern.
Übergeordnetes Thema: Verwalten von Wertelisten


Aktivieren und Deaktivieren von Wertelisten

Anmerkung: Sie können die Werteliste Fehlertypen nicht deaktivieren, da diese Liste von Issue Manager benötigt wird.

So aktivieren oder deaktivieren Sie eine vorhandene Werteliste:

  1. Klicken Sie im Menü auf Verwaltung > Wertelisten.
  2. Klicken Sie auf das Symbol Status der Werteliste, die Sie aktivieren/deaktivieren möchten. Ein Dialogfeld wird geöffnet, in dem Sie das Aktivieren/Deaktivieren bestätigen müssen.
  3. Bestätigen Sie die Meldung, damit der Status der Werteliste zwischen Aktiv und Inaktiv umgeschaltet wird.
    Anmerkung: Jeder einzelne Wert, der in dieser Liste enthalten ist, kann ebenfalls aktiviert oder deaktiviert werden. Detaillierte Informationen zum Aktivieren oder Deaktivieren einzelner Werte finden Sie unter Aktivieren und Deaktivieren einzelner Werte.
Übergeordnetes Thema: Verwalten von Wertelisten


Aktivieren und Deaktivieren einzelner Werte

So aktivieren oder deaktivieren Sie einzelne Werte in einer Werteliste:

  1. Klicken Sie im Menü auf Verwaltung > Wertelisten.
  2. Klicken Sie auf den Namen der Werteliste, die den Wert enthält, den Sie aktivieren oder deaktivieren möchten. Das Dialogfeld Werteliste bearbeiten wird geöffnet.
  3. Klicken Sie auf das Symbol Status des Wertes, den Sie aktivieren oder deaktivieren möchten. Ein Bestätigungsdialogfeld wird geöffnet.
  4. Klicken Sie auf OK, um die geänderte Werteliste zu speichern.
Übergeordnetes Thema: Verwalten von Wertelisten


Sortieren von Werten in Wertelisten

So verschieben Sie Werte in der Liste oder sortieren die Wertelisten alphabetisch nach Wertenamen:

  1. Klicken Sie im Menü auf Verwaltung > Wertelisten.
  2. Klicken Sie auf den Namen der Werteliste, in der die Werte enthalten sind, die Sie sortieren möchten. Das Dialogfeld Werteliste bearbeiten wird geöffnet.
  3. Klicken Sie in der Spalte Aktionen des Elements, das Sie verschieben möchten, auf Nach oben oder Nach unten.
  4. Um die Werteliste alphabetisch nach Wertenamen zu sortieren, klicken Sie auf Nach Wert sortieren. Das Dialogfeld Nach Wert sortieren wird angezeigt.
  5. Wählen Sie die Sortierreihenfolge Aufsteigend oder Absteigend, und klicken Sie auf OK.
  6. Klicken Sie im Dialogfeld Werteliste bearbeiten auf OK, um die aktualisierte Werteliste zu speichern.
Übergeordnetes Thema: Verwalten von Wertelisten


Löschen von Wertelisten

So löschen Sie eine vorhandene Werteliste:

  1. Klicken Sie im Menü auf Verwaltung > Wertelisten.
  2. Deaktivieren Sie die Werteliste, die Sie löschen möchten. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren von Wertelisten.
  3. Klicken Sie in der Spalte „Aktionen“ der Werteliste, die Sie entfernen möchten, auf Löschen. Ein Bestätigungsdialog wird geöffnet.
  4. Klicken Sie auf Ja, um mit dem Löschvorgang fortzufahren. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen.
    Anmerkung: Jeder einzelne Wert, der in dieser Liste enthalten ist, kann ebenfalls gelöscht werden. Details zum Löschen einzelner Werte finden Sie unter Löschen einzelner Werte.
Übergeordnetes Thema: Verwalten von Wertelisten


Löschen einzelner Werte

So löschen Sie einzelne Werte aus einer Werteliste:

  1. Klicken Sie im Menü auf Verwaltung > Wertelisten.
  2. Klicken Sie auf den Namen der Werteliste, in der der Wert enthalten ist, den Sie löschen möchten. Der Dialog Werteliste bearbeiten wird geöffnet.
  3. Deaktivieren Sie den Wert, den Sie löschen möchten. Weitere Informationen finden Sie unter Aktivieren und Deaktivieren einzelner Werte.
  4. Klicken Sie in der Spalte Aktionen des Werts, den Sie löschen möchten, auf Löschen.
  5. Klicken Sie im Dialog Werteliste bearbeiten auf OK, um die aktualisierte Werteliste zu speichern.
Übergeordnetes Thema: Verwalten von Wertelisten


Werteliste (Seite)

Administration > Liste mit Werten

Mithilfe dieser Seite können Sie Wertelisten konfigurieren. Zu jeder aufgeführten Werteliste werden folgende Spalten angezeigt:

Spalte | Beschreibung
Name | Der Name der Werteliste, so wie er auf der Benutzeroberfläche und in Berichten angezeigt wird. Klicken Sie auf den Namen einer Werteliste, wenn Sie den Namen, die Beschreibung oder den Status der Werteliste ändern möchten.
Gruppieren nach | Zeigt an, ob eine Werteliste nach Produkt oder Fehlertypen gruppiert ist oder ob sie Nicht gruppiert ist.
Status | Der Status der Werteliste kann Aktiv oder Inaktiv sein. Klicken Sie auf den Status, um den Status in Aktiv bzw. Inaktiv zu ändern. Die Standardwerteliste Fehlertypen kann nicht deaktiviert werden, weil sie eine in Issue Manager verwendete Schlüsselkomponente ist.
Erstellt am | Datum, an dem die Werteliste erstellt wurde.
Erstellt von | Der Name des Benutzers, der die Werteliste erstellt hat.
Geändert am | Datum, an dem die Werteliste zuletzt geändert wurde.
Geändert Von | Der Name des Benutzers, der die Werteliste zuletzt geändert hat.
Aktionen
Sie können für eine Werteliste folgende Aktionen ausführen:
Löscht die Werteliste dauerhaft. Wertelisten müssen inaktiv sein, bevor sie gelöscht werden können. Wenn eine Werteliste bereits Fehlern geordnet ist, darf sie nicht gelöscht werden.

Klicken Sie auf Neue Liste, um eine neue Werteliste zu erstellen.

Übergeordnetes Thema: Verwalten von Wertelisten


Konfigurieren von Ausführungsterminen

Sie können allgemeine Ausführungstermine definieren, die in Silk Central zur Planung von Testsuiten verwendet werden können. Auf diese Weise kann das Planen von Testsuiten beschleunigt werden. Sie brauchen dann nur noch Ausführungstermine für Testsuiten festzulegen, für die eine spezielle Planung erforderlich ist. Weitere Information über die Anwendung von Ausführungsterminen finden Sie unter Ausführungstermine.

Ausnahmen

Sie können Wochentage und Tageszeiten angeben, an denen Tests nicht ausgeführt werden sollen. Beispielsweise, wenn Sie nicht möchten, dass Tests am Wochenende ausgeführt werden.

Explizite Testläufe

Sie können Zeitpunkte festlegen, zu denen Tests unabhängig von den konfigurierten Ausführungsterminen ausgeführt werden müssen.

  • Hinzufügen globaler Ausführungstermine
    Fügen Sie einen neuen globalen Ausführungstermin hinzu, um Testsuiten in Silk Central zu planen.
  • Bearbeiten globaler Ausführungstermine
    Bearbeiten Sie einen vorhandenen globalen Ausführungstermin.
  • Aktivieren und Deaktivieren von globalen Ausführungsterminen
    Aktivieren oder deaktivieren Sie einen vorhandenen globalen Ausführungstermin in Silk Central.
  • Löschen von globalen Ausführungsterminen
    Löschen Sie einen vorhandenen globalen Ausführungstermin.
  • Festlegen von Ausnahmen
    Legen Sie Ausnahmen fest, um zu definieren wann geplante Tests nicht ausgeführt werden sollen.
  • Festlegen von expliziten Testläufen
    Legen Sie explizite Testläufe fest, um die Zeitpunkte zu bestimmen, an denen Tests ausgeführt werden müssen.
  • Ausführungsterminkonfiguration (Seite)
    Mithilfe dieser Seite können Sie allgemeine Ausführungstermine für Silk Central konfigurieren.
Übergeordnetes Thema: Verwaltung
Zugehörige Konzepte
Ausführungstermine


Hinzufügen globaler Ausführungstermine

So wird ein neuer globaler Ausführungstermin hinzugefügt:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungstermine. Auf der Seite Ausführungstermine werden alle vorhandenen globalen Ausführungstermine angezeigt.
  2. Klicken Sie auf Neuer Ausführungstermin. Die Seite Ausführungstermin konfigurieren wird angezeigt.
  3. Geben Sie einen Namen für den neuen Ausführungstermin in das Feld Name ein. Es empfiehlt sich daher die Zeitzone im Namen anzugeben, z.B. „Täglich um 18 Uhr EST“, so dass die Anwender wissen wann die Ausführung tatsächlich stattfindet.
  4. Geben Sie im Feld Beschreibung eine Beschreibung für den Ausführungstermin ein.
  5. Klicken Sie neben Von auf Bearbeiten, um ein Startdatum und eine Startuhrzeit für den Ausführungstermin zu definieren. Alle Datums- und Uhrzeitwerte werden in der Datenbank entsprechend der Zeitzone GMT gespeichert. Die Darstellung der Werte basiert auf der Benutzereinstellung Zeitzone. Wenn z.B. ein Administrator in New York einen globalen Ausführungstermin anlegt, der jeden Tag um 18 Uhr ausgeführt wird, so wird dieser für einen Benutzer in Paris, der diesen Ausführungstermin für seine Testsuite verwendet, um Mitternacht ausgeführt.
  6. Definieren Sie das Intervall, nach dessen Ablauf die Ausführung wiederholt wird. Der gültige Zeitraum reicht von 1 Minute bis zu 36 Tagen.
  7. Aktivieren Sie das Kontrollkästchen Ausführungstermin an Sommerzeit anpassen, um den Ausführungstermin automatisch an die Sommerzeit anzupassen.
  8. Klicken Sie neben "Ausführen" auf Bearbeiten, um festzulegen, wann die Ausführung beendet werden soll. Klicken Sie auf Endlos, um die Ausführung für eine unbestimmte Zeit festzulegen, oder auf Bis, um sie für einen bestimmten Zeitraum anzugeben.
  9. Wenn Sie bestimmte Wochentage oder Tageszeiten angeben möchten, an denen der Test nicht ausgeführt werden soll, dann klicken Sie auf Ausnahme hinzufügen. Weitere Informationen finden Sie unter Festlegen von Ausnahmen.
  10. Möchten Sie einen Zeitpunkt angeben, an dem der Test ausgeführt werden muss, dann klicken Sie auf Expliziten Testlauf hinzufügen. Weitere Informationen finden Sie unter Festlegen expliziter Testläufe.
  11. Klicken Sie auf Speichern, wenn Sie die Definition des Ausführungstermins abgeschlossen haben.
Übergeordnetes Thema: Konfigurieren von Ausführungsterminen
Zugehörige Tasks
Festlegen von expliziten Testläufen
Festlegen von Ausnahmen
Festlegen globaler Ausführungstermine


Bearbeiten globaler Ausführungstermine

So ändern Sie einen globalen Ausführungstermin:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungstermine. Auf der Seite Ausführungstermine werden alle vorhandenen globalen Ausführungstermine angezeigt.
  2. Klicken Sie auf den Namen des Ausführungstermins, den Sie bearbeiten möchten. Die Seite Ausführungstermin konfigurieren wird angezeigt.
  3. Ändern Sie den Namen des Ausführungstermins im Feld Name. Es empfiehlt sich daher die Zeitzone im Namen anzugeben, z.B. „Täglich um 18 Uhr EST“, so dass die Anwender wissen wann die Ausführung tatsächlich stattfindet.
  4. Ändern Sie die Beschreibung des Ausführungstermins im Feld Beschreibung.
  5. Klicken Sie neben Von auf Bearbeiten, um ein neues Startdatum und eine neue Startuhrzeit für den Ausführungstermin zu definieren. Alle Datums- und Uhrzeitwerte werden in der Datenbank entsprechend der Zeitzone GMT gespeichert. Die Darstellung der Werte basiert auf der Benutzereinstellung Zeitzone. Wenn z.B. ein Administrator in New York einen globalen Ausführungstermin anlegt, der jeden Tag um 18 Uhr ausgeführt wird, so wird dieser für einen Benutzer in Paris, der diesen Ausführungstermin für seine Testsuite verwendet, um Mitternacht ausgeführt.
  6. Ändern Sie das Intervall, nach dessen Ablauf die Ausführung wiederholt wird. Der gültige Zeitraum reicht von 1 Minute bis zu 36 Tagen.
  7. Aktivieren Sie das Kontrollkästchen Ausführungstermin an Sommerzeit anpassen, um den Ausführungstermin automatisch an die Sommerzeit anzupassen.
  8. Klicken Sie neben "Ausführen" auf Bearbeiten, um festzulegen, wann die Ausführung beendet werden soll. Klicken Sie auf Endlos, um die Ausführung für eine unbestimmte Zeit festzulegen, oder auf Bis, um sie für einen bestimmten Zeitraum anzugeben.
  9. Wenn Sie bestimmte Wochentage oder Tageszeiten angeben möchten, an denen der Test nicht ausgeführt werden soll, dann klicken Sie auf Ausnahme hinzufügen. Weitere Informationen finden Sie unter Festlegen von Ausnahmen.
  10. Möchten Sie einen Zeitpunkt angeben, an dem der Test ausgeführt werden muss, dann klicken Sie auf Expliziten Testlauf hinzufügen. Weitere Informationen finden Sie unter Festlegen expliziter Testläufe.
  11. Klicken Sie auf Speichern, wenn Sie die Änderung des Ausführungstermins abgeschlossen haben.
Übergeordnetes Thema: Konfigurieren von Ausführungsterminen
Zugehörige Tasks
Festlegen von expliziten Testläufen
Festlegen von Ausnahmen
Festlegen globaler Ausführungstermine


Aktivieren und Deaktivieren von globalen Ausführungsterminen

So aktivieren oder deaktivieren Sie ein vorhandenes Produkt:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungstermine. Auf der Seite Ausführungstermine werden alle vorhandenen globalen Ausführungstermine angezeigt.
  2. Klicken Sie auf das Symbol Status des Ausführungstermins, den Sie aktivieren oder deaktivieren möchten. Ein Dialogfeld wird geöffnet, in dem Sie das Aktivieren/Deaktivieren bestätigen müssen.
  3. Bestätigen Sie die Meldung, damit der Status des Ausführungstermins zwischen Aktiv und Inaktiv umgeschaltet wird.
Übergeordnetes Thema: Konfigurieren von Ausführungsterminen


Löschen von globalen Ausführungsterminen

So löschen Sie einen vorhandenen globalen Ausführungstermin:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungstermine. Auf der Seite Ausführungstermine werden alle vorhandenen globalen Ausführungstermine angezeigt.
  2. Klicken Sie in der Spalte Aktionen des Ausführungstermins, den Sie löschen möchten, auf Löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  3. Klicken Sie auf Ja, um den ausgewählten Ausführungstermin einschließlich aller Ausnahmen und expliziten Testläufe zu löschen, oder klicken Sie auf Nein, um den Ausführungstermin beizubehalten.
    Anmerkung: Sobald ein globaler Ausführungstermin von einer Test verwendet wird, können Sie ihn nicht löschen. Sie müssen zuerst alle Testen einem anderen Ausführungstermin zuordnen.
Übergeordnetes Thema: Konfigurieren von Ausführungsterminen


Festlegen von Ausnahmen

So legen Sie Ausnahmen fest:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungstermine. Auf der Seite Ausführungstermine werden alle vorhandenen globalen Ausführungstermine angezeigt.
  2. Klicken Sie auf den Namen des Ausführungstermins, den Sie bearbeiten möchten.
  3. Klicken Sie auf der Seite Ausführungstermin konfigurieren auf Ausnahme hinzufügen.
  4. Wählen Sie auf der Seite Ausführungsterminausnahme konfigurieren die Wochentage, an denen die Tests nicht ausgeführt werden sollen.
  5. Legen Sie die Zeiträume an diesen Tagen fest, in denen keine Testausführungen durchgeführt werden sollen.
  6. Klicken Sie auf OK, nachdem Sie die Ausführungsterminausnahme definiert haben, oder klicken Sie auf Abbrechen, um den Vorgang abzubrechen. Die Einstellungen für die Ausnahmen werden jetzt auf der Seite Ausführungstermin konfigurieren angezeigt.
  7. Klicken Sie auf Speichern, um die Ausnahme dem aktuellen Ausführungstermin hinzuzufügen, oder geben Sie weitere Ausnahmen ein.
    Tipp: Sie können Ausnahmen bearbeiten oder löschen, indem Sie in der Spalte Aktionen der zu ändernden Ausnahme auf Bearbeiten oder Löschen klicken.
Übergeordnetes Thema: Konfigurieren von Ausführungsterminen


Festlegen von expliziten Testläufen

So legen Sie explizite Testläufe fest:

  1. Klicken Sie im Menü auf Verwaltung > Ausführungstermine. Auf der Seite Ausführungstermine werden alle vorhandenen globalen Ausführungstermine angezeigt.
  2. Klicken Sie auf den Namen des Ausführungstermins, den Sie bearbeiten möchten.
  3. Klicken Sie auf der Seite Ausführungstermin konfigurieren auf Expliziten Testlauf hinzufügen.
  4. Klicken Sie auf der Seite Expliziten Testlauf konfigurieren auf Bearbeiten, um einen Zeitpunkt für den expliziten Testlauf festzulegen.
  5. Klicken Sie auf OK, sobald Sie die Definition des expliziten Testlaufs abgeschlossen haben, oder klicken Sie auf Abbrechen, um den Vorgang abzubrechen. Die Einstellungen für die expliziten Testläufe werden jetzt auf der Seite Ausführungstermin konfigurieren angezeigt.
  6. Klicken Sie auf Speichern, um den expliziten Testlauf dem aktuellen Ausführungstermin hinzuzufügen, oder geben Sie weitere explizite Testläufe ein.
    Tipp: Sie können explizite Testläufe bearbeiten oder löschen, indem Sie in der Spalte Aktionen auf Bearbeiten oder Löschen des expliziten Testlaufs klicken, den Sie ändern möchten.
Übergeordnetes Thema: Konfigurieren von Ausführungsterminen


Ausführungsterminkonfiguration (Seite)

Administration > Ausführungstermine

Mithilfe dieser Seite können Sie allgemeine Ausführungstermine für Silk Central konfigurieren. Zu jedem Ausführungstermin werden folgende Spalten angezeigt:

Spalte | Beschreibung
Aktionen Diese Spalte enthält Aktionssymbole, mit denen der Benutzer die folgenden Aktionen mit dem Ausführungstermin ausführen kann:
Löscht den Ausführungstermin dauerhaft. Eine Löschung ist nicht zulässig, wenn der Ausführungstermin bereits Testsuiten zugeordnet wurde.
Name | Der Name des Ausführungstermins, wie er auf der Benutzeroberfläche und in Berichten angezeigt wird. Klicken Sie auf den Namen eines Ausführungstermins, wenn Sie seinen Namen, die Beschreibung oder den Status ändern möchten.
Beschreibung | Ein Beschreibungstext für den Ausführungstermin.
Status | Der Status des Ausführungstermins kann Aktiv oder Inaktiv sein. Klicken Sie auf den Status, um den Status in Aktiv bzw. Inaktiv zu ändern.
Erstellt am | Datum, an dem der Ausführungstermin erstellt wurde.
Erstellt von | Der Name des Benutzers, der den Ausführungstermin erstellt hat.

Klicken Sie auf Neuer Ausführungstermin, um einen neuen Ausführungstermin zu erstellen.

Übergeordnetes Thema: Konfigurieren von Ausführungsterminen


Zeitzonen

Silk Central ist dafür konzipiert, Tests über ein Netzwerk von Ausführungsservern auszuführen. Weil solche Netzwerke dank des Internets weltweit verteilt sein und mehrere Zeitzonen umspannen können, ist es wichtig zu wissen, wie Zeitzonen in Silk Central gehandhabt werden.

Alle Datums- und Uhrzeitwerte werden in der Datenbank entsprechend der Zeitzone GMT gespeichert. Die Darstellung der Werte basiert auf der Benutzereinstellung Zeitzone. Dies muss vor allem dann berücksichtigt werden, wenn Sie Ausführungstermine anlegen, die weltweit verwendet werden. Wenn z.B. ein Administrator in New York einen globalen Ausführungstermin anlegt, der jeden Tag um 18 Uhr ausgeführt wird, so wird dieser für einen Benutzer in Paris, der diesen Ausführungstermin für seine Testsuite verwendet, um Mitternacht ausgeführt. Es empfiehlt sich daher die Zeitzone im Namen anzugeben, z.B. „Täglich um 18 Uhr EST“, so dass die Anwender wissen wann die Ausführung tatsächlich stattfindet.

Informationen über die Einstellung von Zeitzonen finden Sie unter Hinzufügen von Benutzerkonten.

Die folgenden Anforderungen müssen erfüllt sein:

  • Anwendungsserver und Front-End-Server sollten sich in der gleichen Zeitzone befinden. Es ist nicht sinnvoll, diese Server an unterschiedlichen WAN-Standorten einzurichten, weil der Anwendungsserver eng mit einem oder mehreren Front-End-Servern zusammenarbeitet. Zudem greifen sowohl die Front-End-Server als auch der Anwendungsserver direkt auf die Datenbank zu.
  • Ausführungsserver können sich in anderen Zeitzonen befinden und sowohl vom Anwendungsserver als auch von anderen Ausführungsservern getrennt sein.
Übergeordnetes Thema: Verwaltung
Zugehörige Tasks
Hinzufügen von Benutzerkonten


Verwalten von Projekten

Projekte reflektieren in Silk Central üblicherweise ein Software-Projekt in Ihrer Firma, respektive die Arbeit eines Entwicklungsteams, mit gemeinsamem Release-Datum, Versionsverwaltungssystem, gemeinsamen Anforderungen, usw.

Der Bereich Projekte bietet einen Überblick über alle Projekte in Ihrer Silk Central-Installation. Sie umfasst eine Liste der Projekte, die Sie zuletzt aktiviert haben, und ermöglicht Ihnen, zwischen verschiedenen Projekten zu wechseln. Wenn Sie als SuperUser, Administrator oder Projektmanager angemeldet sind, können Sie die globalen Einstellungen für Silk Central-Projekte festlegen. Diese globalen Projekteinstellungen gelten für alle Benutzer, die an den betreffenden Projekten arbeiten.

  • Arbeiten mit Projekten
    Hier wird das Konzept der Projekte in Silk Central beschrieben.
  • Build-Informationen
    In diesem Abschnitt wird die Verwendung von Build-Informationsdateien beschrieben.
  • Vergleichen eines Projekts mit einer Baseline
    Verwenden Sie einen kontextbezogenen Bericht zum Vergleichen eines Projekts und einer Projekt-Baseline.
  • Auswählen von Projekten
    Wählen Sie im Bereich Projekt ein Projekt aus, um es zu aktivieren.
  • Projektliste
    Hier werden alle der Silk Central-Installation zugeordneten Projekte und Projekt-Baselines aufgelistet.
  • Wechseln zu einem der zuletzt verwendeten Projekte
    Hier wird beschrieben, wie Sie schnell zu einem der letzten fünf verwendeten Projekte wechseln können.
  • Projekteinstellungen
    In diesem Abschnitt wird beschrieben, wie Projekteinstellungen konfiguriert werden.
  • Projektvorlagen
    Hier wird das Konzept der Projektvorlagen in Silk Central beschrieben.
Übergeordnetes Thema: Verwaltung
Zugehörige Konzepte
Silk Central-Architektur


Arbeiten mit Projekten

In diesem Thema wird das Konzept der Projekte in Silk Central beschrieben.

Silk Central verwaltet Anforderungen, Tests, deren Ausführungen und Ergebnisse im Kontext eines Projekts. Deshalb ist die erste Aktivität die Erstellung eines Projekts. Projekte dienen als Container für verwandte Aufgaben- und Ergebnismengen. Ressourcen, z. B. Projektmanager und Analytiker, werden Projekten durch Zuweisung zu Benutzergruppen zugeordnet, die Zugriffsrechte für bestimmte Projekte besitzen.

  • Hinzufügen von Projekten
    Erstellen Sie ein Projekt, um die Arbeit mit Silk Central zu beginnen.
  • Projekt-Baselines
    Hier wird das Konzept der Projekt-Baselines in Silk Central beschrieben.
  • Bearbeiten von Projekten oder Projekt-Baselines
    Bearbeiten Sie ein vorhandenes Projekt bzw. eine vorhandene Projekt-Baseline.
  • Aktivieren oder deaktivieren von Projekten und Projekt-Baselines
    Aktivieren oder deaktivieren Sie ein vorhandenes Projekt oder eine Projekt-Baseline.
  • Kopieren von Projekten oder Projekt-Baselines
    Kopieren Sie ein vorhandenes Projekt oder eine vorhandene Projekt-Baseline in ein neues Projekt.
  • Löschen von Projekten und Projekt-Baselines
    Löschen Sie ein vorhandenes Projekt oder eine Projekt-Baseline.
  • Exportieren von Projekten
    Hier wird beschrieben, wie ein Projekt exportiert wird, um die Projektdaten außerhalb von Silk Central zu archivieren.
  • Importieren von Projekten
    Hier wird beschrieben, wie Projekte reimportiert werden, die zuvor aus Silk Central exportiert wurden.
  • Projekt kopieren (Dialog)
    Mithilfe dieses Dialogs können Sie ein vorhandenes Projekt in ein neues Projekt kopieren.
  • Projekteinstellungen (Seite)
    Mithilfe dieser Seite können Sie die Projekteinstellungen konfigurieren.
  • Initialisieren von Projekten als Issue Manager-Projekte
    Beschreibt die Initialisierung eines Projekts als Issue Manager-Projekt.
Übergeordnetes Thema: Verwalten von Projekten


Hinzufügen von Projekten

So erstellen Sie ein Projekt:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie auf Neues Projekt. Die Seite Projekteinstellungen wird angezeigt.
  3. Geben Sie einen Projektnamen und eine Beschreibung ein.
  4. Wählen Sie den Projektverantwortlichen aus.
  5. Optional: Geben Sie für Ihr Projekt Tags ein. Wenn Sie viele Projekte haben, können Ihnen Projekt-Tags dabei helfen, diese zu filtern, indem Sie die Spalte Tags auf der Seite Projektliste verwenden.
  6. Optional: Um ein Projekt basierend auf der Vorlage für agile Projekte zu erstellen, wählen Sie im Listenfeld Projektvorlage den Eintrag Vorlage für agile Projekte aus.
  7. Klicken Sie auf Neues Projekt initialisieren oder Existierendes Projekt verwenden, um das Projekt als Issue Manager zu initialisieren. Weitere Informationen finden Sie im Abschnitt Initialisierung von Projekten als Issue Manager-Projekte.
  8. Geben Sie im Bereich Gemeinsam verwendbare Tests an, ob dies ein Repository-Projekt ist oder nicht. Wählen Sie eine der folgenden Optionen aus:
    • Keine gemeinsam verwendbaren Tests: Dieses Projekt verwendet keine Tests von anderen Projekten und seine eigenen Tests können auch nicht von anderen Projekten verwendet werden.
    • Stellt gemeinsam verwendbare Tests zur Verfügung: Dieses Projekt ist als Repository-Projekt konfiguriert, so dass andere Projekte die Tests dieses Projekts verwenden können.
    • Verwendet Tests von: Wählen Sie das Repository-Projekt aus, von dem gemeinsam verwendbare Tests verwendet werden.
  9. Im Bereich Gruppen werden verfügbare und zugewiesene Gruppen angezeigt. Weisen Sie die Gruppen je nach Bedarf zu. Mit Strg+Klick bzw. Umschalt+Klick können Sie mehrere Gruppen auswählen. Durch Klicken auf LDAP-Gruppen importieren können auch Gruppen von LDAP-Servern importiert werden. Weitere Informationen finden Sie unter Gruppen von LDAP-Servern importieren. Wenn keine Gruppen vorhanden ist, können Sie zunächst Gruppen erstellen und sie später dem Projekt zuordnen. Sie können die Zuordnung von Gruppen zum Projekt auch auf der Seite Gruppeneinstellungen vornehmen. Die Berechtigungen hängen von den Benutzerrollen ab. Weitere Informationen zu Benutzerberechtigungen finden Sie unter Benutzerrollen und Berechtigungen.
  10. Im Bereich Servergruppen werden verfügbare und zugewiesene Servergruppen angezeigt. Weisen Sie die Servergruppen je nach Bedarf zu. Mit Strg+Klick bzw. Umschalt+Klick können Sie mehrere Servergruppen auswählen. Wenn keine Servergruppe vorhanden ist, können Sie zuerst eine Servergruppe erstellen und sie später dem Projekt zuordnen. Sie können auch auf der Seite Einstellungen der Servergruppe dem Projekt eine Servergruppe zuordnen. Weitere Informationen finden Sie unter Verwalten von Servergruppen.
  11. Klicken Sie auf Speichern, um Ihre Einstellungen zu speichern. Sie gelangen zurück zur Seite Projektliste, auf der das neue Projekt jetzt angezeigt wird.
Übergeordnetes Thema: Arbeiten mit Projekten
Zugehörige Konzepte
Verwalten von Gruppen
Verwalten von Servergruppen
Benutzerrollen und Berechtigungen
Zugehörige Tasks
Initialisieren von Projekten als Issue Manager-Projekte
Bearbeiten von Projekten oder Projekt-Baselines
Importieren von Gruppen aus LDAP-Servern
Hinzufügen von LDAP-Servern
Gemeinsame Verwendung von Testobjekten aus Repository-Projekten


Projekt-Baselines

In diesem Abschnitt wird das Konzept der Projekt-Baselines in Silk Central beschrieben.

Eine Projekt-Baseline ist eine Momentaufnahme eines Projekts zu einem gegebenen Zeitpunkt. Baselines können für jedes beliebige Projekt oder auch für andere Baselines erstellt werden. Die Projekt-Baseline enthält außerdem den letzten Lauf jeder Testsuite des Projekts. In einer Projekt-Baseline enthaltene Optionen für den Ausführungstermin werden zunächst nicht festgelegt, um den Testausführungsstatus der letzten Läufe beizubehalten. Mit Projekt-Baselines können Sie beispielsweise eine Momentaufnahme eines Projekts direkt nach der Einführung einer neuen Version speichern. Der Baseline Vergleichsbericht in Silk Central zeigt die Anzahl der Tests im Projekt an, die derzeit von der Baseline abweichen. Weitere Informationen zum Bericht finden Sie in der Silk Central-Hilfe.

Für jede neue Projekt-Baseline, die ein Element des Bereichs Tests enthält, beinhaltet die Seite Historie des Elements einen Eintrag mit Links zur Projekt-Baseline und zu dem entsprechenden Element der Projekt-Baseline. Wurde das Element selbst als Teil einer Projekt-Baseline erstellt, enthält der erste Eintrag der Seite Historie Links zum Originalprojekt und zu dem entsprechenden Element des Originalprojekts.

Wenn Tests im Originalprojekt Aufrufe von Objekten mit gemeinsam verwendbaren Testschritten oder Schlüsselwörtern aus Bibliotheken beinhalten, können Sie während der Erstellung der Projekt-Baseline festlegen, ob alle Aufrufe aufgehoben oder beibehalten werden sollen. Die Projekt-Baseline verfügt über dieselbe Transparenz gegenüber der Bibliotheken wie das Originalprojekt. Weitere Informationen zu gemeinsam verwendbaren Testschritten und Schlüsselwörtern finden Sie unter Bibliotheken in der Silk Central-Hilfe.

Anmerkung: Projekt-Baselines können mit den Rollen Administrator, Projektmanager und SuperUser erstellt werden.
  • Erstellen einer Baseline für ein Projekt
    Sie erstellen eine Baseline für ein vorhandenes Projekt, um eine Momentaufnahme dieses Projekts zu einem gegebenen Zeitpunkt zu erstellen.
Übergeordnetes Thema: Arbeiten mit Projekten
Zugehörige Konzepte
Bibliotheken


Erstellen einer Baseline für ein Projekt

ACHTUNG:
Beim Erstellen einer Baseline für ein Projekt kann die Datenbank je nach Größe des Projekts für mehrere Minuten gesperrt werden. Daher sollten Sie Baselines für Projekte nur während Zeiten geringer Auslastung erstellen, wenn die Benutzeraktivitäten in Silk Central minimal sind.
Anmerkung: Wenn das Originalprojekt Ausführungstermine enthält, werden in der neuen Baseline keine Optionen für den Ausführungstermin festgelegt, um den Testausführungsstatus der letzten Läufe beizubehalten. Auf der Seite Historie wird beim Erstellen einer Baseline jedem in der Baseline enthaltenen Element eines Tests ein Eintrag bezüglich der Baseline hinzugefügt.

So erstellen Sie eine Baseline für ein Projekt:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie in der Spalte Aktionen des Projekts, für das Sie eine Baseline erstellen möchten, auf Baseline erzeugen. Der Dialog Baseline erzeugen wird angezeigt.
  3. Geben Sie einen Namen und eine Beschreibung für die neue Baseline ein.
  4. Optional: Wenn das Projekt Tests enthält, die gemeinsam verwendbare Testschritte oder Schlüsselwörter aus Bibliotheken verwenden, legen Sie im Abschnitt Behandlung gemeinsam verwendeter Testschritte fest, wie die gemeinsam verwendbaren Testschritte behandelt werden sollen.
    • Klicken Sie auf Bibliotheken kopieren um alle Verweise auf gemeinsam verwendbare Testschritte und auf Schlüsselwörter in den ursprünglichen Bibliotheken aufzulösen, und stattdessen auf Elemente in neu erstellten Kopien dieser Bibliotheken zu verweisen. Mit dieser Option können Sie eine Projekt-Baseline für Verlaufs- oder Auditzwecke erstellen.
    • Klicken Sie auf Referenzen zu gemeinsam verwendeten Testschritten beibehalten um alle Verweise auf gemeinsam verwendbare Testschritte und auf Schlüsselwörter in den ursprünglichen Bibliotheken beizubehalten. Mit dieser Option können Sie eine Arbeitskopie für laufende Testanforderungen erstellen, z. B. für eine neue Projektversion.
  5. Optional: Wenn das Projekt manuelle oder schlüsselwortgetriebene Tests enthält, definieren Sie im Abschnitt Versionierung manueller Tests, ob für die Tests im Originalprojekt und in der Baseline eine neue Version erstellt werden muss.
    • Aktivieren Sie das Kontrollkästchen Neue Version für alle manuellen und schlüsselwortgetriebenen Tests im Originalprojekt erstellen, um neue Versionen für alle manuellen und schlüsselwortgetriebenen Tests mit gemeinsam verwendbaren Objekten im Originalprojekt zu erstellen.
    • Aktivieren Sie das Kontrollkästchen Neue Version für alle manuellen und schlüsselwortgetriebenen Tests in Baseline erstellen, um neue Versionen für alle manuellen und schlüsselwortgetriebenen Tests mit gemeinsam verwendbaren Objekten in der Baseline zu erstellen. Wenn Sie Bibliotheken kopieren ausgewählt haben, werden auch neue Versionen für alle Elemente in den kopierten Bibliotheken erstellt.
    Anmerkung: Für datengetriebene Instanzen werden keine Versionen erstellt.
  6. Klicken Sie auf OK. Der Dialog Baseline Projekt wird mit der Meldung angezeigt, dass der Vorgang mehrere Minuten dauern kann.
  7. Klicken Sie auf Ja, um fortzufahren. Der Dialog Baseline Projekt – Projekteinstellungen bearbeiten wird geöffnet. Es enthält die Integrationskonfiguration zusammen mit allen für das Originalprojekt konfigurierten Versionsverwaltungsprofilen.
  8. Klicken Sie auf die jeweilige Schaltfläche Bearbeiten, um die Projekt-Baseline mit der entsprechenden Baseline, Verzweigung, Bezeichnung oder einem anderen Referenzpunkt im Versionsverwaltungsprofil zu verknüpfen oder die Integrationskonfiguration zu bearbeiten.
    Anmerkung: Weitere Informationen zum Bearbeiten von Versionsverwaltungsprofilen finden Sie in der Silk Central-Hilfe.
  9. Klicken Sie auf Fertig stellen, um die Erstellung der Baseline abzuschließen.
  10. Klicken Sie im Dialog Baseline Projekt auf Ja, um die neue Baseline zu aktivieren.
Übergeordnetes Thema: Projekt-Baselines


Bearbeiten von Projekten oder Projekt-Baselines

So bearbeiten Sie ein vorhandenes Projekt bzw. eine vorhandene Projekt-Baseline:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie in der Aktionsspalte des zu bearbeitenden Projekts oder der Projekt-Baseline auf Bearbeiten.
    Anmerkung: Das Projekt bzw. die Projekt-Baseline muss inaktiv sein.
  3. Bearbeiten Sie, wenn erforderlich, Projektnamen und Beschreibung.
  4. Ändern Sie, wenn notwendig, den Projektverantwortlichen.
  5. Aktivieren Sie das Kontrollkästchen Aktiv, um das Projekt bzw. die Projekt-Baseline zu aktivieren.
  6. Optional: Geben Sie für Ihr Projekt Tags ein. Wenn Sie viele Projekte haben, können Ihnen Projekt-Tags dabei helfen, diese zu filtern, indem Sie die Spalte Tags auf der Seite Projektliste verwenden.
  7. Geben Sie im Bereich Gemeinsam verwendbare Tests an, ob dies ein Repository-Projekt ist oder nicht. Wählen Sie eine der folgenden Optionen aus:
    • Keine gemeinsam verwendbaren Tests: Dieses Projekt verwendet keine Tests von anderen Projekten und seine eigenen Tests können auch nicht von anderen Projekten verwendet werden.
    • Stellt gemeinsam verwendbare Tests zur Verfügung: Dieses Projekt ist als Repository-Projekt konfiguriert, so dass andere Projekte die Tests dieses Projekts verwenden können.
    • Verwendet Tests von: Wählen Sie das Repository-Projekt aus, von dem gemeinsam verwendbare Tests verwendet werden.
  8. Im Bereich Gruppen werden verfügbare und zugewiesene Gruppen angezeigt. Weisen Sie die Gruppen je nach Bedarf zu. Mit Strg+Klick bzw. Umschalt+Klick können Sie mehrere Gruppen auswählen. Durch Klicken auf LDAP-Gruppen importieren können auch Gruppen von LDAP-Servern importiert werden. Weitere Informationen finden Sie unter Gruppen von LDAP-Servern importieren. Wenn keine Gruppen vorhanden ist, können Sie zunächst Gruppen erstellen und sie später dem Projekt zuordnen. Sie können die Zuordnung von Gruppen zum Projekt auch auf der Seite Gruppeneinstellungen vornehmen. Die Berechtigungen hängen von den Benutzerrollen ab. Weitere Informationen zu Benutzerberechtigungen finden Sie unter Benutzerrollen und Berechtigungen.
  9. Im Bereich Servergruppen werden verfügbare und zugewiesene Servergruppen angezeigt. Weisen Sie die Servergruppen je nach Bedarf zu. Mit Strg+Klick bzw. Umschalt+Klick können Sie mehrere Servergruppen auswählen. Wenn keine Servergruppe vorhanden ist, können Sie zuerst eine Servergruppe erstellen und sie später dem Projekt zuordnen. Sie können auch auf der Seite Einstellungen der Servergruppe dem Projekt eine Servergruppe zuordnen. Weitere Informationen finden Sie unter Verwalten von Servergruppen.
  10. Klicken Sie auf Speichern, um Ihre Einstellungen zu speichern. Sie gelangen wieder zur Seite Projektliste.
Übergeordnetes Thema: Arbeiten mit Projekten
Zugehörige Konzepte
Verwalten von Gruppen
Verwalten von Servergruppen
Benutzerrollen und Berechtigungen
Zugehörige Tasks
Hinzufügen von Projekten
Initialisieren von Projekten als Issue Manager-Projekte
Importieren von Gruppen aus LDAP-Servern
Hinzufügen von LDAP-Servern
Gemeinsame Verwendung von Testobjekten aus Repository-Projekten
Aktivieren oder deaktivieren von Projekten und Projekt-Baselines


Aktivieren oder deaktivieren von Projekten und Projekt-Baselines

Anmerkung: Sie können ein vorhandenes Projekt oder eine Projekt-Baseline auch auf der Seite Projektliste aktivieren oder deaktivieren. Weitere Informationen finden Sie unter Bearbeiten von Projekten.

So aktivieren oder deaktivieren Sie ein Projekt oder eine Projekt-Baseline:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie in der Spalte Status des Projekts oder der Projekt-Baseline, die Sie aktivieren oder deaktivieren möchten auf Aktivieren/Deaktivieren. Ein Dialogfeld wird geöffnet, in dem Sie das Aktivieren/Deaktivieren bestätigen müssen.
  3. Bestätigen Sie dies, damit der Status des Projekts zwischen Aktiv und Inaktiv umgeschaltet wird.
Übergeordnetes Thema: Arbeiten mit Projekten
Zugehörige Tasks
Bearbeiten von Projekten oder Projekt-Baselines


Kopieren von Projekten oder Projekt-Baselines

Kopieren Sie ein vorhandenes Projekt oder eine vorhandene Projekt-Baseline in ein neues Projekt.

Wenn das Originalprojekt oder die Baseline Ausführungstermine enthält, werden beim Kopieren keine Optionen für den Ausführungstermin festgelegt.

ACHTUNG:
Beim Kopieren eines Projekts oder einer Projekt-Baseline kann die Datenbank je nach Größe des zu kopierenden Projekts bzw. der Projekt-Baseline für mehrere Minuten gesperrt werden. Daher sollten Sie Projekte oder Projekt-Baselines nur während Zeiten geringer Auslastung kopieren, wenn die Benutzeraktivitäten in Silk Central minimal sind.
Tipp: Die Leistung der Datenbank kann vor allem dann signifikant reduziert werden, wenn große Projekte in die Datenbank geschrieben werden. Wir empfehlen dringend, dass Sie in Ihrem nächsten Wartungsfenster einen Index-Rebuild für Ihr Silk Central-Datenbankschema durchführen.

So kopieren Sie ein Projekt oder eine Projekt-Baseline:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie auf Projekt kopieren in der Spalte Aktionen des zu kopierenden Projekts oder der Projekt-Baseline. Der Dialog Projekt kopieren wird angezeigt.
  3. Geben Sie im Feld Neuer Projektname einen Namen für das neue Projekt ein.
  4. Aktivieren Sie die Kontrollkästchen für alle zusätzlichen Arten von Informationen, die in das neue Projekt kopiert werden sollen. Wenn das Kontrollkästchen Testhistorie aktiviert ist, werden auch die Versionen kopiert. Detaillierte Informationen zu den Kontrollkästchen finden Sie unter Projekt kopieren (Dialog).
  5. Klicken Sie auf OK.
  6. Wird kein Issue Manager-Projekt für das zu kopierende Projekt initialisiert, fahren Sie mit Schritt 10 fort. Wird ein Issue Manager-Projekt initialisiert, erscheint ein Dialog:
    • Klicken Sie auf Ja und fahren Sie mit Schritt 10 fort, wenn Sie das vorhandene Issue Manager-Projekt verwenden möchten.
    • Klicken Sie auf Nein und fahren Sie mit Schritt 7 fort, wenn Sie das vorhandene Issue Manager-Projekt nicht verwenden sondern kopieren möchten.
  7. Aktivieren Sie das Kontrollkästchen Fehler kopieren, um alle im Quellprojekt vorhandenen Fehler in das neue Projekt zu kopieren.
  8. Aktivieren Sie das Kontrollkästchen Archivierte Fehler kopieren, um alle archivierten Fehler des Quellprojekts in das neue Projekt zu kopieren.
  9. Klicken Sie auf OK.
  10. Klicken Sie im Dialog Projekt kopieren auf Ja, um zu bestätigen, dass der Kopiervorgang beginnen soll und dass Sie wissen, dass der Vorgang mehrere Minuten dauern kann. Ist der Kopiervorgang abgeschlossen, informiert Sie ein Meldungsfenster darüber, was kopiert wurde, und Sie werden gefragt, ob das Projekt aktiviert werden soll. Dadurch wird das Projekt in der Projektansicht von Silk Central verfügbar.
Übergeordnetes Thema: Arbeiten mit Projekten


Löschen von Projekten und Projekt-Baselines

ACHTUNG:
Wenn Sie ein Projekt oder eine Projekt-Baseline löschen, werden alle zugehörigen Ergebnisse dauerhaft aus dem Repository gelöscht. Zudem werden alle mit dem Projekt oder der Projekt-Baseline verknüpften Inhalte gelöscht. Wenn die Ergebnisse weiterhin verfügbar sein sollen, wird empfohlen, Projekten bzw. Projekt-Baselines den Status "Inaktiv" zuzuweisen, anstatt sie zu löschen. Weitere Informationen zum Deaktivieren von Projekten und Projekt-Baselines finden Sie unter Aktivieren oder Deaktivieren von Projekten und Projekt-Baselines.

So löschen Sie ein Projekt oder eine Projekt-Baseline:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie auf Löschen in der Spalte Aktionen des zu löschenden Projekts oder der Projekt-Baseline.
    Anmerkung: Das Projekt bzw. die Projekt-Baseline muss inaktiv sein.
    Ein Dialog wird geöffnet, in dem Sie das Löschen bestätigen müssen.
  3. Klicken Sie auf Ja, um das Projekt bzw. die Projekt-Baseline zu löschen. Wenn Sie auf Nein klicken, wird der Vorgang abgebrochen. Wenn Sie auf Ja klicken, wird wieder die Projektliste angezeigt. Das gelöschte Projekt bzw. die gelöschte Projekt-Baseline wird nicht mehr aufgeführt.
Übergeordnetes Thema: Arbeiten mit Projekten


Exportieren von Projekten

Sie können ein Projekt einschließlich aller Projektdaten als .zip-Datei auf Ihren lokalen Computer exportieren. Die ist vor allem dann hilfreich, wenn Sie die Daten außerhalb von Silk Central archivieren möchten.

So exportieren Sie ein Projekt:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie in der Spalte Aktionen auf [image] (Projekt exportieren).
  3. Klicken Sie im Bestätigungsdialog auf OK.
  4. Geben Sie einen Speicherort auf Ihrem Computer an, an dem Sie die Projektdaten speichern möchten. Silk Central speichert die Projektdaten in einer .zip-Datei.
Achtung: Bevor Sie den Export oder Import von Projekten starten, lesen Sie die nachstehenden Empfehlungen aufmerksam durch.
  • Der Export/Import großer Projekte mit umfassenden Projektdaten kann viel Zeit in Anspruch nehmen (bis zu mehreren Stunden).
  • Die Dateigröße kann sich von Projekt zu Projekt extrem unterscheiden und hängt von verschiedenen Faktoren ab, zum Beispiel: Von der Anzahl Komponenten, der Anzahl Testausführungen, den Anhängen, den Codeabdeckungsstatistiken, und vor allem von den Testergebnisdateien.
  • Wir empfehlen es Ihnen, die Größe eines Projekts vor dem Export zu minimieren. Sie sollten in diesem Sinne unnötige Daten und besonders nicht verwendete Ergebnisdateien entfernen. Wenn Ihr Projekt die Größe von 1.2 GB überseigt, erhalten Sie beim Importieren den Fehler Request entity is too large. Wenn Sie die Größe des Projekts nicht mehr reduzieren können, haben Sie die Möglichkeit die Upload-Begrenzung in der Datei nginx.conf.template in C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf zu erhöhen, indem Sie die Eigenschaft client_max_body_size anpassen.
  • Die Leistung der Datenbank kann vor allem dann signifikant reduziert werden, wenn große Projekte in die Datenbank geschrieben werden. Wir empfehlen dringend, dass Sie in Ihrem nächsten Wartungsfenster einen Index-Rebuild für Ihr Silk Central-Datenbankschema durchführen.
  • Einige Browser haben Einschränkungen für die Größe von hochgeladenen Dateien, zum Bespiel Internet Explorer. Sollte das Projekt, welches Sie importieren möchten, diese Größe übersteigen, scheitert das Importieren. Verwenden Sie in diesem Fall einen anderen Browser, um das Problem zu vermeiden.
  • Bitte seien Sie sich bewusst, dass der Export/Import Silk Central und den Datenbankserver erheblich belastet. Der Export/Import sollte außerhalb der Arbeitszeiten durchgeführt werden (z. B. nachts oder am Wochenende) oder wenigstens dann, wenn die Silk Central-Belastung niedrig ist und keine Benutzer angemeldet sind.
  • Der Export/Import von Daten stützt sich besonders auf die Datenbank und deren Inhalt. Enthält die Datenbank bereits Datenunstimmigkeiten, kann der Import eines Projekts fehlschlagen. Wir empfehlen es Ihnen deshalb, den Import sofort nach dem Export durchzuführen, um die Gültigkeit, die Datenkonsistenz und die Wiederherstellbarkeit sicherzustellen.
  • Wenn Sie die Projektdaten erneut importieren möchten, verwenden Sie dieselbe .zip-Datei, die Sie bereits exportiert haben. Andere Formate werden nicht akzeptiert. Sie können die Daten nur in dieselbe Silk Central-Version und Datenbankversion importieren, die Sie bereits für das Exportieren der Daten verwendet haben.
  • Falls Sie Fragen in Bezug auf den Export/Import haben, wenden Sie sich an den Kundensupport.
Übergeordnetes Thema: Arbeiten mit Projekten


Importieren von Projekten

Silk Central-Projekte können exportiert werden, um die Projektdaten außerhalb von Silk Central zu archivieren. Wenn Sie die Daten, alle Ergebnisse, Berichte usw. anzeigen möchten, müssen Sie das Projekt reimportieren.

Beim Import von Projektdaten müssen Sie dieselbe Silk Central-Version und dieselbe Datenbankversion verwenden, die Sie auch für den Export der Daten verwendet haben. Sie können jedoch Projektdaten auf denselben oder einen anderen Datenbankserver mit derselben Version, die auch für den Datenexport verwendet wurde, importieren.

So importieren Sie ein Projekt:

  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie oben auf Projekt importieren. Das Dialogfeld Projekt importieren wird angezeigt.
  3. Suchen Sie eine .zip-Datei auf Ihrem Computer, und klicken Sie auf OK. Silk Central lädt die Daten hoch.
    Anmerkung: Bei der .zip-Datei muss es sich um eine Datei handeln, die zuvor von Silk Central exportiert wurde.
    Anmerkung: Die .zip-Datei wird auf den Front-End-Server hochgeladen und anschließend in die Datenbank importiert. Daher muss auf dem Front-End-Server genügend Speicherplatz zum Speichern der .zip-Datei vorhanden sein.
  4. Klicken Sie auf Ja, um den Import zu starten. Beachten Sie Folgendes:
    • Silk Central verarbeitet jeweils nur einen Import.
    • Silk Central schreibt Audit-Logdateien, wenn ein Import gestartet oder abgeschlossen wird bzw. fehlschlägt.
    • Der Import wird im Hintergrund verarbeitet. Sie werden per E-Mail benachrichtigt, wenn der Import abgeschlossen ist. Stellen Sie sicher, dass Sie eine E-Mail-Adresse und einen E-Mail-Server konfiguriert haben, bevor Sie den Import starten. Andernfalls erhalten Sie keine Benachrichtigung. Weitere Informationen finden Sie unter Konfigurieren von E-Mail-Servern und Benutzereinstellungen (Seite).
    • Das Projekt wird in der Projektliste angezeigt, wenn der Import abgeschlossen ist.
Achtung: Bevor Sie den Export oder Import von Projekten starten, lesen Sie die nachstehenden Empfehlungen aufmerksam durch.
  • Der Export/Import großer Projekte mit umfassenden Projektdaten kann viel Zeit in Anspruch nehmen (bis zu mehreren Stunden).
  • Die Dateigröße kann sich von Projekt zu Projekt extrem unterscheiden und hängt von verschiedenen Faktoren ab, zum Beispiel: Von der Anzahl Komponenten, der Anzahl Testausführungen, den Anhängen, den Codeabdeckungsstatistiken, und vor allem von den Testergebnisdateien.
  • Wir empfehlen es Ihnen, die Größe eines Projekts vor dem Export zu minimieren. Sie sollten in diesem Sinne unnötige Daten und besonders nicht verwendete Ergebnisdateien entfernen. Wenn Ihr Projekt die Größe von 1.2 GB überseigt, erhalten Sie beim Importieren den Fehler Request entity is too large. Wenn Sie die Größe des Projekts nicht mehr reduzieren können, haben Sie die Möglichkeit die Upload-Begrenzung in der Datei nginx.conf.template in C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf zu erhöhen, indem Sie die Eigenschaft client_max_body_size anpassen.
  • Die Leistung der Datenbank kann vor allem dann signifikant reduziert werden, wenn große Projekte in die Datenbank geschrieben werden. Wir empfehlen dringend, dass Sie in Ihrem nächsten Wartungsfenster einen Index-Rebuild für Ihr Silk Central-Datenbankschema durchführen.
  • Einige Browser haben Einschränkungen für die Größe von hochgeladenen Dateien, zum Bespiel Internet Explorer. Sollte das Projekt, welches Sie importieren möchten, diese Größe übersteigen, scheitert das Importieren. Verwenden Sie in diesem Fall einen anderen Browser, um das Problem zu vermeiden.
  • Bitte seien Sie sich bewusst, dass der Export/Import Silk Central und den Datenbankserver erheblich belastet. Der Export/Import sollte außerhalb der Arbeitszeiten durchgeführt werden (z. B. nachts oder am Wochenende) oder wenigstens dann, wenn die Silk Central-Belastung niedrig ist und keine Benutzer angemeldet sind.
  • Der Export/Import von Daten stützt sich besonders auf die Datenbank und deren Inhalt. Enthält die Datenbank bereits Datenunstimmigkeiten, kann der Import eines Projekts fehlschlagen. Wir empfehlen es Ihnen deshalb, den Import sofort nach dem Export durchzuführen, um die Gültigkeit, die Datenkonsistenz und die Wiederherstellbarkeit sicherzustellen.
  • Wenn Sie die Projektdaten erneut importieren möchten, verwenden Sie dieselbe .zip-Datei, die Sie bereits exportiert haben. Andere Formate werden nicht akzeptiert. Sie können die Daten nur in dieselbe Silk Central-Version und Datenbankversion importieren, die Sie bereits für das Exportieren der Daten verwendet haben.
  • Falls Sie Fragen in Bezug auf den Export/Import haben, wenden Sie sich an den Kundensupport.
Übergeordnetes Thema: Arbeiten mit Projekten
Zugehörige Tasks
Konfigurieren von E-Mail-Servern
Zugehörige Verweise
Benutzereinstellungen (Seite)


Projekt kopieren (Dialog)

Projekte > Projektliste > Projekt kopieren

Mithilfe dieses Dialogs können Sie ein vorhandenes Projekt in ein neues Projekt kopieren.

Anmerkung: Aktivieren Sie die Kontrollkästchen für alle zusätzlichen Arten von Informationen, die in das neue Projekt kopiert werden sollen. Wenn Sie keine zusätzlichen Informationen auswählen, wird ein leeres Projekt kopiert, das lediglich Gruppenzuordnungen, Servergruppenzuordnungen und Projekteinstellungen aufweist.
Element | Beschreibung
Neuer Projektname | Legt den Namen des neuen Projekts fest, in welches das vorhandene Projekt kopiert wird.
Neue Projektbeschreibung | Legt die Beschreibung des neuen Projekts fest, in welches das vorhandene Projekt kopiert wird.
Einstellungen | Aktivieren Sie dieses Kontrollkästchen, wenn Projekteinstellungen, Filter, Attribute, benutzerdefinierte Anforderungseigenschaften, Änderungsbenachrichtigungen und Integrationskonfigurationseinstellungen in das neue Projekt kopiert werden sollen. Informationen über Integrationskonfigurationseinstellungen von Fremdherstellern werden nicht kopiert.
Anforderungshierarchie (beinhaltet Anforderungseinstellungen) | Aktivieren Sie dieses Kontrollkästchen, wenn die Anforderungshierarchie inklusive aller Informationen zu jeder Anforderung (Eigenschaften, Anhänge usw.) kopiert werden soll. Informationen über Anforderungen von Fremdherstellern werden nicht kopiert. Wurde ein Projekt für ein externes Anforderungsmanagementsystem konfiguriert, dann werden Sie gefragt, ob die Einstellungen für dieses System in die Projektkopie übertragen werden sollen.
Anforderungshistorie | Aktivieren Sie dieses Kontrollkästchen, wenn die historischen Daten zu den einzelnen Anforderungen kopiert werden sollen. Diese Option ist nur verfügbar, wenn das Kontrollkästchen Anforderungshierarchie aktiviert ist.
Testhierarchie (beinhaltet Testeinstellungen) | Aktivieren Sie dieses Kontrollkästchen, wenn die Testhierarchie inklusive aller Informationen zu den einzelnen Tests kopiert werden soll. Wenn Sie die Kontrollkästchen Anforderungshierarchie und Testhierarchie gleichzeitig aktivieren, werden neben den oben aufgeführten Informationen auch die Informationen zur Beziehung zwischen Anforderungen und Tests (zugewiesene Anforderungen und zugewiesene Tests) kopiert.
Testhistorie | Aktivieren Sie dieses Kontrollkästchen, wenn die historischen Daten zu den einzelnen Tests kopiert werden sollen. Diese Option ist nur verfügbar, wenn das Kontrollkästchen Testhierarchie aktiviert ist.
Testsuitehierarchie (beinhaltet Testhierarchie) | Aktivieren Sie dieses Kontrollkästchen, wenn die Testsuitehierarchie inklusive aller Informationen zu den einzelnen Testsuiten kopiert werden soll.
Letzter Testlauf von Tests | Aktivieren Sie dieses Kontrollkästchen, wenn der letzte Testlauf der einzelnen Tests kopiert werden soll. Diese Option ist nur verfügbar, wenn das Kontrollkästchen Testsuitehierarchie aktiviert ist. Wenn die Kontrollkästchen Anforderungshierarchie, Testsuitehierarchie und Letzter Testlauf von Tests aktiviert sind, werden alle Hierarchien vollständig kopiert. Die Beziehung zwischen diesen Hierarchien wird ebenfalls hergestellt.
Berichte | Aktivieren Sie dieses Kontrollkästchen, um alle projektbezogenen Berichte in das neue Projekt zu kopieren.

Für Issue Manager zeigt der Dialog die folgenden zusätzlichen Kontrollkästchen an:

Projekt kopieren – Issue Manager (Dialogoption) | Beschreibung
Fehler kopieren | Aktivieren Sie dieses Kontrollkästchen, um alle im Quellprojekt vorhandenen Fehler in das neue Projekt zu kopieren.
Archivierte Fehler kopieren | Aktivieren Sie dieses Kontrollkästchen, um alle archivierten Fehler des Quellprojekts in das neue Projekt zu kopieren.

Wenn Sie keines dieser beiden Kontrollkästchen aktivieren, werden keine Daten zu Fehlern in das neue Projekt kopiert.

Quellprojektkonfigurationsdaten werden automatisch in das neue Projekt kopiert. Hierzu gehören:

  • Produkte
  • Benutzeroberflächenkonfiguration
  • Benachrichtigungsregeln und systemweite Trigger
  • Zuordnungsregeln
  • Workflow
  • Benutzeransichten von Postfächern
  • Arbeitsgruppen
  • Postfächer
  • Benutzerkontokonfiguration
Übergeordnetes Thema: Arbeiten mit Projekten


Projekteinstellungen (Seite)

Projekt > Neues Projekt

Mithilfe der Seite Projekteinstellungen können Sie Projekte konfigurieren. Die Seite enthält folgende Elemente:

Element | Beschreibung
Projektname | Gibt den Namen des Projekts an, wie er auf der Benutzeroberfläche und in Berichten angezeigt werden soll.
Beschreibung | Eine Beschreibung des Projekts. Sie können jeden beliebigen Text als Beschreibung eingeben.
Projektverantwortlicher | Gibt den Eigentümer des Projekts an. Das gewählte Benutzerkonto verfügt über keine speziellen Berechtigungen. Diese Einstellung dient lediglich Informationszwecken.
Aktiv | Markieren Sie dieses Kontrollkästchen, um das Projekt zu aktivieren. Inaktive Projekte werden in Ihrer Anwendung nicht angezeigt.
Tags | Wenn Sie viele Projekte haben, können Ihnen Projekt-Tags dabei helfen, diese zu filtern, indem Sie die Spalte Tags auf der Seite Projektliste verwenden.
Projektvorlage | Dieses Listenfeld definiert, ob ein Projekt auf einer agilen Projektvorlage basiert. Wählen Sie Vorlage für ein agiles Projekt, um als Basis für das Projekt die Vorlage für agile Projektmanagement-Tools zu verwenden, oder wählen Sie <Keine>, um ein einfaches Projekt zu erstellen.
Issue Manager-Integration Wählen Sie eine der folgenden Optionen aus:
  • Kein Projekt: Es wurde keine Issue Manager-Integration erstellt.
  • Neues Projekt initialisieren: Das neue Projekt wird als Issue Manager-Projekt initialisiert. Wenn Sie unten auf der Seite auf Speichern klicken, wird ein Dialog angezeigt, in dem Sie alle erforderlichen Einstellungen für das Projekt (Gruppen, Postfächer, Produkte usw.) konfigurieren können.
  • Existierendes Projekt verwenden: Ein bestehendes Projekt wird verwendet. Wählen Sie ein Projekt aus der Liste aus. Wenn das Projekt zuvor nicht als Issue Manager-Projekt konfiguriert war, müssen Sie alle erforderlichen Einstellungen konfigurieren. Es wird ein Dialog angezeigt, wenn Sie auf Speichern klicken. Wenn das Projekt bereits zuvor als Issue Manager-Projekt konfiguriert war, müssen Sie nur die Anmeldeinformationen und die Statuszuordnung angeben.
Gemeinsam verwendbare Tests Wählen Sie eine der folgenden Optionen aus:
  • Keine gemeinsam verwendbaren Tests: Dieses Projekt verwendet keine Tests von anderen Projekten und seine eigenen Tests können auch nicht von anderen Projekten verwendet werden.
  • Stellt gemeinsam verwendbare Tests zur Verfügung: Dieses Projekt ist als Repository-Projekt konfiguriert, so dass andere Projekte die Tests dieses Projekts verwenden können.
  • Verwendet Tests von: Wählen Sie das Repository-Projekt aus, von dem gemeinsam verwendbare Tests verwendet werden.
Gruppen | Im Bereich Gruppen werden verfügbare und zugewiesene Gruppen angezeigt. Weisen Sie die Gruppen je nach Bedarf zu. Mit Strg+Klick bzw. Umschalt+Klick können Sie mehrere Gruppen auswählen. Durch Klicken auf LDAP-Gruppen importieren können auch Gruppen von LDAP-Servern importiert werden. Weitere Informationen finden Sie unter Gruppen von LDAP-Servern importieren. Wenn keine Gruppen vorhanden ist, können Sie zunächst Gruppen erstellen und sie später dem Projekt zuordnen. Sie können die Zuordnung von Gruppen zum Projekt auch auf der Seite Gruppeneinstellungen vornehmen. Die Berechtigungen hängen von den Benutzerrollen ab. Weitere Informationen zu Benutzerberechtigungen finden Sie unter Benutzerrollen und Berechtigungen.
Servergruppe | Im Bereich Servergruppen werden verfügbare und zugewiesene Servergruppen angezeigt. Weisen Sie die Servergruppen je nach Bedarf zu. Mit Strg+Klick bzw. Umschalt+Klick können Sie mehrere Servergruppen auswählen. Wenn keine Servergruppe vorhanden ist, können Sie zuerst eine Servergruppe erstellen und sie später dem Projekt zuordnen. Sie können auch auf der Seite Einstellungen der Servergruppe dem Projekt eine Servergruppe zuordnen. Weitere Informationen finden Sie unter Verwalten von Servergruppen.
Übergeordnetes Thema: Arbeiten mit Projekten


Initialisieren von Projekten als Issue Manager-Projekte

Wenn Sie ein neues Projekt in Silk Central erstellen, können Sie das Projekt in ein Issue Manager-Projekt integrieren:
  1. Klicken Sie im Menü auf Projekte > Projektliste. Auf der Seite Projekte werden alle vorhandenen Projekte und Projekt-Baselines angezeigt.
  2. Klicken Sie auf Neues Projekt. Die Seite Projekteinstellungen wird angezeigt.
  3. Konfigurieren Sie die Einstellungen. Weitere Informationen finden Sie unter Hinzufügen von Projekten.
  4. In der Zeile Issue Manager-Integration können Sie Folgendes auswählen:
    • Neues Projekt initialisieren: Initialisiert ein neues Issue Manager-Projekt und integriert es in das neu erstellte Silk Central-Projekt.
    • Bestehendes Projekt erneut verwenden: Ein bestehendes Issue Manager-Projekt wird in das neu erstellte Silk Central-Projekt integriert. Wählen Sie ein Projekt aus der Liste aus. Die Anmeldeinformationen und die Statuszuordnung müssen konfiguriert werden.
  5. Klicken Sie unten auf der Seite auf Speichern. Das neue Projekt wird erstellt und in der Projektliste angezeigt. Der Dialog Issue Manager-Projekt konfigurieren wird angezeigt.
  6. Konfigurieren Sie Ihre Gruppeneinstellungen, und klicken Sie auf Weiter.
  7. Klicken Sie auf Postfach hinzufügen, um Postfächer manuell zum Projekt hinzuzufügen. Klicken Sie auf Postfächer erstellen, um automatisch Postfächer für alle Benutzer zu erstellen, die dem Projekt zugewiesen sind. Sie können das Kontrollkästchen aktivieren, sodass automatisch Postfächer für Benutzer und Benutzergruppen erstellt werden, die zu einem späteren Zeitpunkt zugewiesen werden. Klicken Sie auf Weiter.
  8. Definieren Sie Ihre Produkteinstellungen, und klicken Sie auf Schließen.
  9. Geben Sie die Standard-Anmeldeinformationen an, und klicken Sie auf OK. Der eingegebene Benutzername muss Teil der Benutzergruppe sein, die Sie dem Projekt zugewiesen haben.
  10. Konfigurieren Sie, wie externe und interne Eigenschaften zugeordnet werden sollen, und klicken Sie auf OK.
Anmerkung: Sie können den Initialisierungsprozess jederzeit abbrechen. Um die Initialisierung später abzuschließen, müssen Sie diese Einstellungen auf der Seite Fehlerverfolgungsprofil, der Seite Issue Manager Projektliste und der Seite Issue Manager Konfiguration konfigurieren.
Übergeordnetes Thema: Arbeiten mit Projekten


Build-Informationen

Die Build-Informationsdateien enthalten die bei den Testläufen verwendeten Versions- und Build-Informationen. Die Build-Informationsdateien werden im Allgemeinen auf dem Ausführungsserver gespeichert und gesucht, der den Testlauf ausführt. Wenn eine Build-Informationsdatei dort nicht gefunden werden kann, dann wird auf dem Anwendungsserver nach ihr gesucht. Diese Vorgehensweise lohnt sich, wenn mehrere Ausführungsserver vorhanden sind und auf allen dieselbe Build-Informationsdatei verwendet werden soll. Es wird dann lediglich eine einzige Build-Informationsdatei auf dem Anwendungsserver benötigt. Auf dem Anwendungsserver wird direkt nach den Build-Informationsdateien für automatisierte Tests, denen kein Ausführungsserver zugewiesen ist, und für alle manuellen Tests gesucht.

In Silk Central können die Testergebnisse mit den Build-Informationen verglichen werden, um nur die Ergebnisse für bestimmte Build-Nummern anzuzeigen.

  • Aktualisieren von Build-Informationen
    Beschreibt, wie die Build-Informationen aktualisiert werden.
  • Erstellen von Build-Informationsdateien
    Erstellen Sie eine Build-Informationsdatei zum Speichern der Build-Informationen für ein Silk Central-Projekt.
Übergeordnetes Thema: Verwalten von Projekten


Aktualisieren von Build-Informationen

Die Build-Informationsdateien werden manuell erstellt und konfiguriert. Wenn ein neues Build zum Testen auf einem Ausführungsserver verfügbar ist, aktualisieren Sie die Build-Informationen mit der neuen Build-Nummer.

Sie können die Build-Informationen auf zweierlei Weise aktualisieren:

  • Durch manuelles Bearbeiten der Dateien beim Installieren eines neuen Builds.
  • Durch eine automatisierte Aktualisierung der Build-Informationsdatei, z. B. mit einem VB-Skript.
Übergeordnetes Thema: Build-Informationen


Erstellen von Build-Informationsdateien

So erstellen Sie eine Build-Informationsdatei:
  1. Navigieren Sie auf dem Anwendungsserver zu: C:\ProgramData\SilkCentral\instance_<Instanznummer>_<Instanzname>\BuildInfos.
  2. Erstellen Sie eine Build-Informationsdatei für Ihr Projekt basierend auf der Vorlagedatei BuildInfoExample.xml. Die Vorlagedatei enthält folgenden Code:
    <ProjectBuildInfo>
  <BuildEntryList>
       <BuildEntry name="Demo Product">
            <Version>3.1</Version>
            <BuildNr>350</BuildNr>
    </BuildEntry>
       <BuildEntry name="Product2">
            <Version>4.2</Version>
            <BuildNr>613</BuildNr>
    </BuildEntry>
  </BuildEntryList>
</ProjectBuildInfo>
    Anmerkung: Das Element BuildEntryList enthält eine Liste von BuildEntry-Elementen. Mit den BuildEntry-Tags, die vom Namensattribut der BuildEntry-Elemente definiert sind, werden die jeweiligen Produkte angegeben.
  3. Ändern Sie die Datei entsprechend Ihrer Umgebung.
    Version
    Die Nummer der Version, die aktuell zum Testen verfügbar ist. Die Nummer muss nicht für jeden Ausführungsserver gleich sein.
    BuildNr
    Die Nummer des Builds, die aktuell zum Testen verfügbar ist. Die Nummer muss nicht für jeden Ausführungsserver gleich sein.
  4. Optional: Wenn bestimmte Ausführungsserver andere Versionen und Build-Informationen verwenden sollen, verteilen Sie die veränderte Build-Informationsdatei auf die entsprechenden Ausführungsserver unter C:\ProgramData\SilkCentral\BuildInfos. Für Linux-Ausführungsserver muss die Datei im Benutzer-Heimverzeichnis unter ~/.LinuxExecServer-18.5.0/BuildInfos/ gespeichert sein.
  5. Wenn Sie die Dateien erstellt haben, müssen Sie den Dateinamen in den Einstellungen des betreffenden Projekts angeben. Klicken Sie auf Projekte:<Projektname> > Projektliste, um eine Liste der Ihnen zugeordneten Projekte anzuzeigen. Wählen Sie dann das Projekt aus, mit dem Sie die Build-Informationen verknüpfen möchten.
    Anmerkung: Dieser Schritt muss durchgeführt werden, bevor Sie den Ausführungstermin von Tests im Projekt festlegen. Andernfalls werden die bereits geplanten Tests nicht aktualisiert.
  6. Klicken Sie auf die Registerkarte Projekteinstellungen.
  7. Klicken Sie auf Bearbeiten, um die Projekteinstellungen des ausgewählten Projekts zu bearbeiten. Das Dialogfeld Projekteinstellungen bearbeiten wird angezeigt.
  8. Geben Sie den Namen der zuvor erstellten XML-Datei in das Feld Name der Build-Informationsdatei ein.
  9. Klicken Sie auf OK, um die Änderungen zu übernehmen. Von nun an liest Silk Central bei allen Testausführungen die Build-Informationen aus der angegebenen Datei und vergleicht diese mit dem Testergebnis.
Übergeordnetes Thema: Build-Informationen


Vergleichen eines Projekts mit einer Baseline

Bei Projekten mit Baselines können Sie den Bericht Baseline-Vergleich verwenden, um alle Änderungen an den Tests im Projekt anzuzeigen, die ab dem Erstellen der Baseline vorgenommen wurden.

So zeigen Sie den Bericht an:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Wählen Sie über Umschalttaste+Klick das Projekt und die Baseline des Projekts aus, die verglichen werden sollen.
    Tipp: Zur einfacheren Auswahl der Baselines klicken Sie nicht auf den Namen der Baseline. Klicken Sie stattdessen in eine andere Spalte.
  3. Klicken Sie mit der rechten Maustaste auf die Auswahl.
  4. Wählen Sie Berichte > Baseline-Testplan-Vergleich.
    Anmerkung: Der Bericht Baseline Vergleich muss einmal ausgeführt werden, damit er im Kontextmenü angezeigt wird. Ist der Bericht ausgegraut, führen Sie ihn einmal im Bereich Bericht aus.
Übergeordnetes Thema: Verwalten von Projekten


Auswählen von Projekten

So wählen Sie ein Projekt aus:

  1. Klicken Sie im Menü auf Projekte > Projektliste.
  2. Klicken Sie auf den Namen des gewünschten Projekts.
    Anmerkung: Sie können nur aktive Projekte auswählen.
Übergeordnetes Thema: Verwalten von Projekten


Projektliste

Projekt:<Projektname> > Projektliste

Auf der Seite Projektliste werden alle der Silk Central-Installation zugeordneten Projekte und Projekt-Baselines alphabetisch aufgeführt. Die Seite kann gefiltert aber nicht sortiert werden. Die Projekte werden nach Name sortiert angezeigt. Inaktive Projekte und Projekt-Baselines sind deaktiviert.

Projekt-Baselines werden nach ihrem Erstellungsdatum sortiert, mit einem speziellen Symbol gekennzeichnet und als Unterknoten des entsprechenden Projekts angezeigt.

Weitere Informationen finden Sie unter Verwalten von Projekten.

Die folgenden Spalten werden für jedes Projekt und jede Projekt-Baseline angezeigt.

Spalte | Beschreibung
Aktionen | Löschen Projekt bearbeiten Projekt kopieren Baseline erzeugen Projekt exportieren Anmerkung: Diese Spalte wird verborgen, wenn der aktuelle Benutzer nicht über Berechtigungen zum Ändern oder Löschen von Projekten verfügt.
Projekt | Der Name des Projekts. Klicken Sie das gewünschte Projekt an, um es zu aktivieren.
Projekt-ID | Die Kennung des Projekts.
Status | Aktiv oder Inaktiv. Klicken Sie auf den Status, um zwischen den Statusoptionen hin- und her zu schalten.
Beschreibung | Die Projektbeschreibung.
Projektverantwortlicher | Gibt den Eigentümer des Projekts an. Das gewählte Benutzerkonto verfügt über keine speziellen Berechtigungen. Diese Einstellung dient lediglich Informationszwecken.
Freigabedatum | Legt das geplante Freigabedatum für das Projekt fest.
Erstellt am | Datum und Uhrzeit, zu der das Projekt erstellt wurde.
Erstellt von | Der Name des Benutzers, der das Projekt erstellt hat.
Geändert am | Datum und Uhrzeit, zu der das Projekt geändert wurde.
Geändert Von | Der Name des Benutzers, von dem das Projekt zuletzt geändert wurde.
Tags | Wenn Sie viele Projekte haben, können Ihnen Projekt-Tags dabei helfen, diese zu filtern, indem Sie die Spalte Tags auf der Seite Projektliste verwenden. Verwenden Sie Strg+Klick oder Umschalt+Klick um mehrere Projekte auszuwählen. Klicken Sie mit der rechten Maustaste auf Ihre Auswahl und wählen Sie Tags bearbeiten um die Tags von mehreren Projekten gleichzeitig zu bearbeiten. Anmerkung: Das Filtern nach Tags verwendet eine OR-Klausel, d.h. es werden alle Projekte angezeigt, die irgendeinen der ausgewählten Tags enthalten.
Übergeordnetes Thema: Verwalten von Projekten
Zugehörige Konzepte
Arbeiten mit Projekten


Wechseln zu einem der zuletzt verwendeten Projekte

Sie können schnell zwischen den fünf Silk Central-Projekten wechseln, die Sie zuletzt verwendet haben.

So öffnen Sie eines der fünf zuletzt geöffneten Projekte:

  1. Klicken Sie im Menü auf Projekte.
  2. Klicken Sie in der Liste Zuletzt verwendete Projekte auf den Namen des Projekts, auf das Sie zugreifen möchten. Sie können an dem ausgewählten Projekt weiterarbeiten.
Übergeordnetes Thema: Verwalten von Projekten


Projekteinstellungen

Projekteinstellungen sind Einstellungen, die für ein bestimmtes Projekt gelten, z. B. das Freigabedatum des Projekts.

  • Konfigurieren von Projekteinstellungen
    Konfigurieren Sie die Einstellungen eines Projekts, um es anzupassen.
  • Filter
    Hier wird beschrieben, wie Filter zum Auffinden der relevanten Informationen bei gleichzeitigem Ausschluss von nicht benötigten Details verwendet werden.
  • Attribute
    Hier wird beschrieben, wie benutzerdefinierte Attribute zum Konfigurieren von Informationen für Tests und Testsuiten verwendet werden.
  • Anforderungseigenschaften
    Hier werden die verfügbaren Arten von Anforderungseigenschaften erläutert.
  • Testschritteigenschaften
    Hier wird beschrieben, wie Sie mithilfe von Testschritteigenschaften Schritte in manuellen Tests um zusätzliche Eigenschaften erweitern.
  • Änderungsbenachrichtigung
    Hier wird beschrieben, wie Sie eine E-Mail-Benachrichtigung bei Änderungen von Anforderungen oder Tests von anderen Benutzern einrichten können.
  • Integration von Anforderungsverwaltungssystemen
    Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren.
  • Integration von Fehlerverfolgungsprofilen
    Hier wird beschrieben, wie Sie Silk Central in externe Fehlerverfolgungssysteme integrieren.
  • Versionsverwaltungsprofile
    Mithilfe von Versionsverwaltungsprofilen kann Silk Central in externe Versionsverwaltungssysteme integriert werden. Mithilfe von Versionsverwaltungsprofilen kann definiert werden, von wo die Ausführungsserver von Silk Central die Quelldateien zur Testausführung abrufen.
  • Datenquellen für datengetriebene Tests
    Bei datengetriebenen Tests werden Werte aus einer vorhandenen Datenquelle (z. B. Kalkulationstabelle oder Datenbank) verwendet. Die Verwaltung von Datenquellen geschieht auf Projektebene.
  • Statusursachen
    Hier wird beschrieben, wie Statusursachen den Status eines manuellen Testlaufs qualifizieren.
  • Projekteinstellungen (Seite)
    Hier werden allgemeine Informationen über das aktive Projekt aufgelistet.
Übergeordnetes Thema: Verwalten von Projekten


Konfigurieren von Projekteinstellungen

So konfigurieren Sie die Projekteinstellungen:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Aktivieren Sie die Registerkarte Projekteinstellungen, damit die aktuellen Einstellungen angezeigt werden. Die Seite Projekteinstellungen wird angezeigt.
  3. Klicken Sie auf Bearbeiten, um die aktuellen Einstellungen zu ändern.
  4. Das Dialogfeld Projekteinstellungen bearbeiten wird angezeigt. Hier können Sie die folgenden Einstellungen festlegen:
    Name der Build-Informationsdatei
    Build-Informationsdateien enthalten Projektinformationen, wie z. B. Build-Nummer, Build-Log-Pfad, Fehler-Log-Pfad und Build-Pfad. Geben Sie in dieses Feld den Namen der Build-Informationsdatei des Projekts ein. Die Build-Informationen in dieser Datei werden von allen Testsuiten gelesen.
    Geplantes Freigabedatum
    Legen Sie für Ihr Projekt das geplante Freigabedatum fest.
    Folgende Dateitypen in Ergebnissen ignorieren
    Legen Sie die Erweiterungen der Ergebnisdateien oder anderen Dateitypen fest, die nicht als Ergebnisse für Testsuiten gespeichert werden sollen.
    Anmerkung: Die Dateierweiterungen müssen jeweils durch ein Komma getrennt werden (z. B. "xlg, *_, res"). Die Änderungen an den Optionen Name der Build-Informationsdatei und Folgende Dateitypen in Ergebnissen ignorieren wirken sich nicht auf Tests aus, deren Ausführungstermin bereits konfiguriert ist. Wenn Sie Aufgaben erneut an die Ausführungsserver verteilen möchten, müssen Sie die Ausführungstermine der Tests neu festlegen oder die Verbindung zur Datenbank trennen und wieder herstellen.
  5. Klicken Sie auf OK, um die Projekteinstellungen zu speichern.
Übergeordnetes Thema: Projekteinstellungen
Zugehörige Konzepte
Build-Informationen


Integration von Fehlerverfolgungsprofilen

Mit Hilfe von Fehlerverfolgungsprofilen kann Silk Central in externe Fehlerverfolgungssysteme integriert werden.

Weitere externe Fehlerverfolgungssysteme können durch die Installation eines Plug-Ins konfiguriert werden. Weitere Informationen finden Sie unter Fehlerverfolgungs-Integrationen. Durch die Definition von Fehlerverfolgungsprofilen können Sie Tests im Bereich Tests mit Fehlern in Verfolgungssystemen von Drittanbietern verknüpfen. Die Statuswerte der verknüpften Fehler werden vom externen Verfolgungssystem in regelmäßigen Abständen aktualisiert.

  • Zuordnen von Fehlerstatuswerten
    Ordnen Sie die vorhandenen Fehlerstatuswerte eines externen Fehlerverfolgungssystems den Fehlerstatuswerten von Silk Central zu, damit Silk Central beim Abfragen von internen und externen Fehlern die Fehler korrekt auflisten kann.
  • Atlassian JIRA
    Hier wird beschrieben, wie Atlassian JIRA-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.
  • Bugzilla
    Hier wird beschrieben, wie Bugzilla-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.
  • IBM Rational ClearQuest
    Hier wird beschrieben, wie IBM Rational ClearQuest-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.
  • Issue Manager
    Hier wird Issue Manager, das Fehlerverfolgungswerkzeug von Silk Central, beschrieben.
  • SAP Solution Manager-Integration
    Hier wird beschrieben, wie Silk Central und SAP Solution Manager integriert werden.
  • Microsoft Team Foundation Server
    Hier wird beschrieben, wie Team Foundation Server-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.
  • StarTeam-Fehlerverfolgungsprofile
    Hier wird beschrieben, wie StarTeam-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.
  • Löschen von Fehlerverfolgungsprofilen
    Löschen Sie ein vorhandenes Fehlerverfolgungsprofil, wenn das Profil nicht mehr erforderlich ist.
  • Fehlerverfolgungsprofile (Seite)
    Hier werden alle Fehlerverfolgungsprofile aufgelistet, die für die Integration von externen Fehlerverfolgungssystemen in Silk Central konfiguriert sind.
Übergeordnetes Thema: Projekteinstellungen
Übergeordnetes Thema: Integrationen
Zugehörige Konzepte
Integration der Fehlerverfolgung


Zuordnen von Fehlerstatuswerten

Nachdem Sie ein neues Fehlerverfolgungsprofil definiert haben, sollten Sie die vorhandenen Fehlerstatuswerte eines externen Fehlerverfolgungssystems den Fehlerstatuswerten von Silk Central zuordnen. Dadurch kann Silk Central eine korrekte Liste erstellen, wenn interne und externe Fehler abgefragt werden.

So ordnen Sie Fehlerstatuswerte zu:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Fehlerverfolgung. Die Seite Fehlerverfolgung wird angezeigt. Hier werden alle Fehlerverfolgungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie in der Spalte Aktionen des Fehlerverfolgungsprofils, das Sie bearbeiten möchten, auf Zuordnung des Fehlerverfolgungsprofils bearbeiten. Das Dialogfeld Statuszuordnung bearbeiten wird geöffnet.
  4. Ordnen Sie die internen Statuswerte den entsprechenden externen Statuswerten zu, indem Sie die jeweiligen Einträge in den Listenfeldern auswählen. Die vorhandenen Fehlerstatuswerte der externen Fehlerverfolgungssoftware werden in der Spalte Extern aufgeführt. Die internen Statuswerte von Silk Central stehen in den Listenfeldern der Spalte Intern zur Auswahl.
  5. Haben Sie jedem externen Statuswert einen internen Statuswert zugeordnet, klicken Sie auf OK, um Ihre Einstellungen zu speichern, oder klicken Sie auf Abbrechen, um den Vorgang abzubrechen.
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Atlassian JIRA

Dieser Abschnitt beschreibt, wie Atlassian JIRA (JIRA)-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.

Das JIRA-Plug-In verwendet für die Integration die Java-API von Silk Central und die REST API von JIRA.

Folgende Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: Atlassian JIRA 6, 7

Wenn Sie einem Test einen externen JIRA-Fehler zuordnen, können Sie die Fehler-ID mit oder ohne Projektschlüssel eingeben. Zum Beispiel: PROJEKT-13 oder einfach 13.

Silk Central Unterstützt folgende JIRA-Feldtypen:
  • Text Field (< 255 characters) /Free Text Field (unlimited text)
  • Select List (single choice) /Select List (multiple choices)
  • Date Picker /Date Time Picker
    Anmerkung: Diese Feldtypen werden als Textfelder zur Verfügung gestellt und müssen wie in JIRA formatiert sein: Date Picker: tt/MMM/jj (zum Beispiel 24/Mar/16), Date Time Picker: tt/MMM/jj h:mm a (zum Beispiel 24/Mar/16 4:11 AM)
  • Group Picker (single group) /Group Picker (multiple groups)
  • Project Picker (single project)
  • User Picker (single user) /User Picker (multiple users)
    Anmerkung: In JIRA Version 5 und niedriger werden Benutzer nicht angezeigt, welche nur zur Standardgruppe jira-users gehören.
  • Version Picker (single version) / Version Picker (multiple versions)
Alle anderen JIRA-Feldtypen werden als einzeilige Textfelder in Silk Central dargestellt.

Folgende JIRA-Systemfelder werden nicht unterstützt: Original Estimate, Remaining Estimate, Attachment, und Labels.

  • Hinzufügen von Atlassian JIRA-Fehlerverfolgungsprofilen
    Erstellen Sie ein JIRA-Fehlerverfolgungsprofil, um Tests im Bereich Tests Fehlern in JIRA zuzuordnen.
  • Bearbeiten von Atlassian JIRA-Fehlerverfolgungsprofilen
    Ändern Sie ein vorhandenes JIRA-Fehlerverfolgungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Hinzufügen von Atlassian JIRA-Fehlerverfolgungsprofilen

So fügen Sie ein JIRA-Fehlerverfolgungsprofil hinzu:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf Neues Profil, um den Dialog Neues Fehlerverfolgungsprofil zu öffnen.
  3. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  4. Geben Sie eine Beschreibung für das neue Profil ein.
  5. Wählen Sie Atlassian JIRA in der Liste Typ aus.
  6. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Der Benutzername muss ein gültiger JIRA-Profilname sein. Diese Benutzerdaten werden für den Zugriff auf Ihr JIRA-Fehlerverfolgungssystem verwendet.
    Wichtig: Verwenden Sie die Benutzerdaten eines JIRA-Kontos mit ausreichenden Berechtigungen, da fehlende Berechtigungen in JIRA zu Inkonsistenzen führen können, wenn das Plug-In mittels diesem Konto versucht, Fehler hinzuzufügen oder zu verändern. Das JIRA-Konto benötigt die folgenden Berechtigungen für jedes Projekt, das in Silk Central verwendet wird:
    • Projekte durchsuchen (Browse Projects)
    • Fehler erstellen (Create Issues)
    • Zuweisbarer Benutzer (Assignable User)
    • Berichtersteller ändern (Modify Reporter)

    Außerdem muss das JIRA-Konto in der Lage sein, sich auf Ihrer JIRA-Anwendung anzumelden.

  7. Geben Sie im Feld URL den Hostnamen des JIRA-Servers und den Port an, mit dem eine Verbindung zum Server hergestellt wird.
  8. Klicken Sie auf Projekt laden, um alle Projekte vom Server zu laden und das Listenfeld Projekt zu füllen. Wählen Sie dann im Listenfeld Projekt ein Projekt aus.
  9. Optional: Wählen Sie in der Liste Alle Felder anzeigen die Option true um alle verfügbaren JIRA-Felder im Fehlerdialog anzuzeigen, sonst werden nur die benötigten Felder angezeigt. Wird „true“ ausgewählt, muss der JIRA-Benutzer, der für das Fehlerverfolgungsprofil festgelegt wurde, in JIRA über Administratorrechte verfügen.
  10. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  11. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: Atlassian JIRA
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Bearbeiten von Atlassian JIRA-Fehlerverfolgungsprofilen

Werden der Server oder die Benutzerdaten Ihres Fehlerverfolgungssystems geändert, müssen Sie auch Ihr Fehlerverfolgungsprofil entsprechend ändern.

So bearbeiten Sie ein Atlassian JIRA-Fehlerverfolgungsprofil:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf den Namen des Fehlerverfolgungsprofils, das Sie ändern möchten. Der Dialog Fehlerverfolgungsprofil bearbeiten wird angezeigt.
  3. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  4. Bearbeiten Sie das Feld Beschreibung des Profils.
  5. Optional: Wählen Sie im Listenfeld einen neuen Typ für das Fehlerverfolgungsprofil aus.
  6. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Der Benutzername muss ein gültiger JIRA-Profilname sein. Diese Benutzerdaten werden für den Zugriff auf Ihr JIRA-Fehlerverfolgungssystem verwendet.
    Wichtig: Verwenden Sie die Benutzerdaten eines JIRA-Kontos mit ausreichenden Berechtigungen, da fehlende Berechtigungen in JIRA zu Inkonsistenzen führen können, wenn das Plug-In mittels diesem Konto versucht, Fehler hinzuzufügen oder zu verändern. Das JIRA-Konto benötigt die folgenden Berechtigungen für jedes Projekt, das in Silk Central verwendet wird:
    • Projekte durchsuchen (Browse Projects)
    • Fehler erstellen (Create Issues)
    • Zuweisbarer Benutzer (Assignable User)
    • Berichtersteller ändern (Modify Reporter)

    Außerdem muss das JIRA-Konto in der Lage sein, sich auf Ihrer JIRA-Anwendung anzumelden.

  7. Bearbeiten Sie im Feld URL den Hostnamen des JIRA-Servers und den Port, mit dem eine Verbindung zum Server hergestellt wird.
  8. Wenn Sie das JIRA-Projekt ändern möchten, klicken Sie auf Projekt laden, um alle Projekte vom Server zu laden und das Listenfeld Projekt zu aktualisieren. Wählen Sie dann im Listenfeld Projekt ein Projekt aus.
  9. Optional: Wählen Sie in der Liste Alle Felder anzeigen die Option true um alle verfügbaren JIRA-Felder im Fehlerdialog anzuzeigen, sonst werden nur die benötigten Felder angezeigt. Wird „true“ ausgewählt, muss der JIRA-Benutzer, der für das Fehlerverfolgungsprofil festgelegt wurde, in JIRA über Administratorrechte verfügen.
  10. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  11. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: Atlassian JIRA
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Bugzilla

Dieser Abschnitt beschreibt, wie Bugzilla-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.

Das Bugzilla-Plug-In verwendet bei der Integration die Java-API von Silk Central. Silk Central kommuniziert mit Bugzilla mithilfe der Redstone XML-RPC-Bibliothek über den mit Bugzilla 3.0 eingeführten XML-RPC Bugzilla-Webdienst. Für die Integration von Bugzilla muss ein SOAP::Lite-Paket für den Webserver installiert sein. Installieren Sie beispielsweise für die Debian-Verteilung das Paket libsoap-lite-perl.

Folgende Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: Bugzilla 4.4.12, 5.0.3

  • Hinzufügen von Bugzilla-Fehlerverfolgungsprofilen
    Erstellen Sie ein Bugzilla-Fehlerverfolgungsprofil, um Tests im Bereich Tests Fehlern in Bugzilla zuzuordnen.
  • Bearbeiten von Bugzilla-Fehlerverfolgungsprofilen
    Ändern Sie ein vorhandenes Bugzilla-Fehlerverfolgungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Hinzufügen von Bugzilla-Fehlerverfolgungsprofilen

So fügen Sie ein Bugzilla-Fehlerverfolgungsprofil hinzu:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf Neues Profil, um den Dialog Neues Fehlerverfolgungsprofil zu öffnen.
  3. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  4. Geben Sie eine Beschreibung für das neue Profil ein.
  5. Wählen Sie Bugzilla in der Liste Typ aus.
  6. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  7. Geben Sie die URL Ihrer Bugzilla-Installation ein. Zum Beispiel http://bugzillaserver/bugzilla.
  8. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  9. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: Bugzilla
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Bearbeiten von Bugzilla-Fehlerverfolgungsprofilen

Werden der Server oder die Benutzerdaten Ihres Fehlerverfolgungssystems geändert, müssen Sie auch Ihr Fehlerverfolgungsprofil entsprechend ändern.

So bearbeiten Sie ein vorhandenes Bugzilla-Fehlerverfolgungsprofil:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf den Namen des Fehlerverfolgungsprofils, das Sie ändern möchten. Der Dialog Fehlerverfolgungsprofil bearbeiten wird angezeigt.
  3. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  4. Bearbeiten Sie das Feld Beschreibung des Profils.
  5. Optional: Wählen Sie im Listenfeld einen neuen Typ für das Fehlerverfolgungsprofil aus.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  7. Ändern Sie die URL Ihrer Bugzilla-Installation.
  8. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  9. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: Bugzilla
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


IBM Rational ClearQuest

Dieser Abschnitt beschreibt, wie IBM Rational ClearQuest-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.

Die IBM Rational ClearQuest-Produkte stellen eine flexible Fehler-/Änderungsverfolgung und eine automatische Workflow-Unterstützung zur Verfügung. Die beiden Kernprodukte heißen IBM Rational ClearQuest (ClearQuest) und IBM Rational ClearQuest MultiSite (ClearQuest Multisite). Um mit ClearQuest-Profilen arbeiten zu können, muss auf dem Computer, auf dem der Silk Central Front-End-Server ausgeführt wird, die ClearQuest-Clientsoftware installiert sein. Detaillierte Informationen zur Installation von ClearQuest finden Sie in der ClearQuest-Dokumentation.

Folgende Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: IBM Rational ClearQuest 8,0

  • Hinzufügen von ClearQuest-Fehlerverfolgungsprofilen
    Erstellen Sie ein ClearQuest-Fehlerverfolgungsprofil, um Tests im Bereich Tests Fehlern in ClearQuest zuzuordnen.
  • Bearbeiten von ClearQuest-Fehlerverfolgungsprofilen
    Ändern Sie ein vorhandenes ClearQuest-Fehlerverfolgungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Hinzufügen von ClearQuest-Fehlerverfolgungsprofilen

So fügen Sie ein ClearQuest-Fehlerverfolgungsprofil hinzu:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf Neues Profil, um den Dialog Neues Fehlerverfolgungsprofil zu öffnen.
  3. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  4. Geben Sie eine Beschreibung für das neue Profil ein.
  5. Wählen Sie in dem Listenfeld Typ die Option IBM Rational ClearQuest aus.
  6. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  7. Geben Sie das Repository-Info Ihrer ClearQuest-Installation ein. Dies ist der Datenbankname, der in der ClearQuest-Mandantenoftware definiert ist. Der Name der Beispliel-Datenbank ist SAMPL.
    Anmerkung: Es ist nicht möglich mehr als ein ClearQuest Schema Repository zu benutzen. Silk Central verbindet sich mit dem Standard ClearQuest repository.
  8. Geben Sie den Fehlertyp von ClearQuest an. Wenn in Silk Central ein Fehler eingegeben wird, speichert ClearQuest den Fehler zusammen mit dem Fehlertyp, den Sie in diesem Feld angegeben haben. Der Standardfehlertyp ist Fehler.
  9. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  10. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: IBM Rational ClearQuest
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Bearbeiten von ClearQuest-Fehlerverfolgungsprofilen

Werden der Server oder die Benutzerdaten Ihres Fehlerverfolgungssystems geändert, müssen Sie auch Ihr Fehlerverfolgungsprofil entsprechend ändern.

So bearbeiten Sie ein vorhandenes ClearQuest-Fehlerverfolgungsprofil:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf den Namen des Fehlerverfolgungsprofils, das Sie ändern möchten. Der Dialog Fehlerverfolgungsprofil bearbeiten wird angezeigt.
  3. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  4. Bearbeiten Sie das Feld Beschreibung des Profils.
  5. Optional: Wählen Sie im Listenfeld einen neuen Typ für das Fehlerverfolgungsprofil aus.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  7. Ändern Sie das Repository-Info Ihrer ClearQuest-Installation. Dies ist der Datenbankname, der in der ClearQuest-Mandantenoftware definiert ist. Der Name der Beispliel-Datenbank ist SAMPL.
    Anmerkung: Es ist nicht möglich mehr als ein ClearQuest Schema Repository zu benutzen. Silk Central verbindet sich mit dem Standard ClearQuest repository.
  8. Ändern Sie den Fehlertyp von ClearQuest. Wenn in Silk Central ein Fehler eingegeben wird, speichert ClearQuest den Fehler zusammen mit dem Fehlertyp, den Sie in diesem Feld angegeben haben.
  9. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  10. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: IBM Rational ClearQuest
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Issue Manager

Issue Manager ist das Fehlerverfolgungswerkzeug von Silk Central und vollständig in Silk Central integriert. Mit ihm können Fehler mit Systemanforderungen und ausgeführten Tests korreliert werden.

Die Testfehler können unter Tests > Detailansicht > Fehler hinzugefügt und verwaltet werden. Weitere Informationen finden Sie in den Issue Manager-Themen in dieser Hilfe.

  • Hinzufügen von Issue Manager-Fehlerverfolgungsprofilen
    Erstellen Sie ein Issue Manager-Fehlerverfolgungsprofil, um Tests im Bereich Tests Fehlern in Issue Manager zuzuordnen.
  • Bearbeiten von Issue Manager-Fehlerverfolgungsprofilen
    Ändern Sie ein vorhandenes Issue Manager-Fehlerverfolgungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen
Zugehörige Konzepte
API-Hilfe


Hinzufügen von Issue Manager-Fehlerverfolgungsprofilen

So fügen Sie ein Issue Manager-Fehlerverfolgungsprofil hinzu:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf Neues Profil, um den Dialog Neues Fehlerverfolgungsprofil zu öffnen.
  3. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  4. Geben Sie eine Beschreibung für das neue Profil ein.
  5. Wählen Sie in dem Listenfeld Typ Issue Manager aus.
  6. Aktivieren Sie das Kontrollkästchen Lokales Repository um das integrierte Issue Manager-Profil zu verwenden, welches Teil Ihrer Silk Central-Instanz ist. Deaktivieren Sie diese Option, um sich mit einem externen Issue Manager-System zu verbinden, in welchem Fall Sie gültige Benutzerdaten angeben müssen.
  7. Geben Sie die Issue Manager-URL Ihrer Issue Manager-Installation ein. Dies ist die URL, die Sie für die Anmeldung bei Issue Manager verwenden, jedoch ohne die Erweiterung login am Ende. Falls Sie die Option Lokales Repository ausgewählt haben, lassen Sie die Standard-URL im Feld. Lautet Ihre Standard-URL für Issue Manager beispielsweise http://IssueManager/login, dann wäre http://IssueManager die korrekte URL für Ihre Installation.
  8. Optional: Wenn Issue Manager mit dem Front-end Server über eine andere URL kommunizieren soll als die, mit der auf die Web-Benutzeroberfläche zugegriffen wird, geben Sie diese URL im Textfeld Webdienst-URL ein. Dies ist zum Beispiel nötig, wenn Benutzer über einen Proxy auf die Web-Benutzeroberfläche zugreifen, während Issue Manager die interne URL oder die IP-Adresse des Front-end Servers benötigt.
  9. Gehen Sie wie folgt vor:
    1. Klicken Sie auf Projekte laden. Dadurch wird das Listenfeld Projekt mit allen initialisierten Issue Manager-Projekten gefüllt, auf die der angegebene Benutzer zugreifen kann. Beachten Sie, dass nur die Projekte aufgeführt werden, für die Issue Manager-Benutzergruppen definiert wurden, und wenn der angegebene Benutzer Mitglied von wenigstens einer dieser Benutzergruppen ist.
    2. Wählen Sie das Projekt, in dem Issue Manager-Fehler verwaltet werden.
    ACHTUNG:
    Es wird davon abgeraten, identische Projekte für Issue Manager und Silk Central zu verwenden, da dies die Arbeit mit beiden Tools an künftigen Projekten einschränken kann.
  10. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  11. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: Issue Manager
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Bearbeiten von Issue Manager-Fehlerverfolgungsprofilen

Werden der Server oder die Benutzerdaten Ihres Fehlerverfolgungssystems geändert, müssen Sie auch Ihr Fehlerverfolgungsprofil entsprechend ändern.

So bearbeiten Sie ein Issue Manager-Fehlerverfolgungsprofil:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf den Namen des Fehlerverfolgungsprofils, das Sie ändern möchten. Der Dialog Fehlerverfolgungsprofil bearbeiten wird angezeigt.
  3. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  4. Bearbeiten Sie das Feld Beschreibung des Profils.
  5. Optional: Wählen Sie im Listenfeld einen neuen Typ für das Fehlerverfolgungsprofil aus.
  6. Aktivieren Sie das Kontrollkästchen Lokales Repository um das integrierte Issue Manager-Profil zu verwenden, welches Teil Ihrer Silk Central-Instanz ist. Deaktivieren Sie diese Option, um sich mit einem externen Issue Manager-System zu verbinden, in welchem Fall Sie gültige Benutzerdaten angeben müssen.
  7. Bearbeiten Sie die Issue Manager-URL Ihrer Issue Manager-Installation, wenn deren Servergruppe geändert wurde. Dies ist die URL, die Sie für die Anmeldung bei Issue Manager verwenden, jedoch ohne die Erweiterung login am Ende. Lautet Ihre Standard-URL für Issue Manager beispielsweise http://IssueManager/login, dann wäre http://IssueManager die korrekte URL für Ihre Installation.
  8. Optional: Wenn Issue Manager mit dem Front-end Server über eine andere URL kommunizieren soll als die, mit der auf die Web-Benutzeroberfläche zugegriffen wird, geben Sie diese URL im Textfeld Webdienst-URL ein. Dies ist zum Beispiel nötig, wenn Benutzer über einen Proxy auf die Web-Benutzeroberfläche zugreifen, während Issue Manager die interne URL oder die IP-Adresse des Front-end Servers benötigt.
  9. Wenn Sie das Issue Manager-Projekt ändern möchten, klicken Sie auf Projekt laden, um alle Projekte vom Server zu laden und das Listenfeld Projekt zu aktualisieren. Wählen Sie dann im Listenfeld Projekt ein Projekt aus.
  10. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  11. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: Issue Manager
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Microsoft Team Foundation Server

Dieser Abschnitt beschreibt, wie Team Foundation Server (TFS)-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.

Folgende Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: Team Foundation Server 2012, 2013, 2015

  • Installieren eines Team Foundation Server Webdienst Service Proxy
    Installieren Sie einen Team Foundation Server Webdienst Proxy als Schnittstelle zum TFS.
  • Hinzufügen von TFS-Fehlerverfolgungsprofilen
    Erstellen Sie ein TFS-Fehlerverfolgungsprofil, um Tests im Bereich Tests Fehlern in TFS zuzuordnen.
  • Bearbeiten von TFS-Fehlerverfolgungsprofilen
    Ändern Sie ein vorhandenes TFS-Fehlerverfolgungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Installieren eines Team Foundation Server Webdienst Service Proxy

Um mit einem TFS zu kommunizieren, müssen Sie einen Team Foundation Server Webdienst Proxy als Schnittstelle zum TFS installieren.

So installieren Sie einen TFS-Proxy-Dienst:

  1. Installieren Sie Microsoft Visual Studio Team Explorer von http://www.microsoft.com/downloads/details.aspx?FamilyID=fe4f9904-0480-4c9d-a264-02fedd78ab38.
  2. Installieren Sie IIS und das Webbereitstellungs-Tool, z. B. mit dem Webplattform-Installationsprogramm von http://www.microsoft.com/web/downloads/default.aspx.
  3. Laden Sie den Team Foundation Server Webdienst Proxy unter Hilfe > Tools herunter.
  4. Entpacken Sie das heruntergeladene Paket.
  5. Öffnen Sie eine Befehlszeile, und geben Sie DotNetTfsWebServiceProxy.deploy.cmd /Y, um den Proxy-Dienst zu installieren. Wenn eine Fehlermeldung angezeigt wird, die besagt, dass ASP.NET 4 erforderlich ist, finden Sie weitere Informationen unter http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx.
  6. Öffnen Sie den IIS Manager.
  7. Überprüfen Sie, ob die neue Website vorhanden ist.
  8. Öffnen Sie im Stammordner des virtuellen Verzeichnisses die Datei Web.config.
  9. Ändern Sie im Abschnitt appSettings der Datei den Wert des Schlüssels WorkItemTrackingCacheRoot zum lokalen Verzeichnis. Zum Beispiel:
    <appSettings>
  <add key="WorkItemTrackingCacheRoot" value="C:\temp" />
</appSettings>
  10. Wenn das von Ihnen angegebene Verzeichnis nicht existiert, erstellen Sie es.
  11. Gewähren Sie Allen vollständige Rechte für das angegebene Verzeichnis.
Weitere Informationen zum Bereitstellen der ASP.NET-Webanwendung finden Sie unter http://msdn.microsoft.com/en-us/library/ee942158.aspx.
Anmerkung: Wenn Sie Silk Central von Version 16.5 oder früher aktualisieren, müssen Sie den TFS Proxy-Dienst neu einrichten. Löschen Sie den bestehenden TFS Proxy-Dienst und fahren Sie oben bei Schritt 3 fort. Starten Sie IIS neu wenn Sie fertig sind.
Übergeordnetes Thema: Microsoft Team Foundation Server


Hinzufügen von TFS-Fehlerverfolgungsprofilen

Um Silk Central zu aktivieren und Zugriff auf TFS-Fehler zu erhalten, müssen Sie einen Team Foundation Server Webdienst Proxy von Micro Focus konfigurieren.
Wichtig: Dabei handelt es sich nicht um den Team Foundation Server Proxy von Microsoft.

So fügen Sie ein TFS-Fehlerverfolgungsprofil hinzu:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf Neues Profil, um den Dialog Neues Fehlerverfolgungsprofil zu öffnen.
  3. Geben Sie einen Namen für das neue Profil ein. Dieser Name wird in Listen angezeigt, die eine Auswahl von Profilen anbieten.
  4. Geben Sie eine Beschreibung für das neue Profil ein.
  5. Wählen Sie im Listenfeld Typ die Option Team Foundation Server <Version> aus.
  6. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  7. Geben Sie die Domäne des TFS-Benutzers ein.
  8. Geben Sie den URL Ihrer TFS-Installation ein. Zum Beispiel http://tfsserver:8080/tfs.
  9. Geben Sie die Sammlung ein, zu der das Projekt gehört. Z. B.: Standardsammlung. Alle Projekte in der Sammlung werden im Listenfeld Projekte aufgeführt.
  10. Wählen Sie aus dem Listenfeld das Projekt aus.
  11. Geben Sie die URL des TFS-Proxy ein. Zum Beispiel http://tfsproxyserver/DotNetTfsWebServiceProxy_deploy/TfsWebServiceProxy.asmx.
  12. Klicken Sie auf Arbeitselementtyp laden. Das Listenfeld Arbeitselementtyp wird mit den verfügbaren Arbeitselementtypen ausgefüllt.
  13. Wählen Sie aus dem Listenfeld den Arbeitselementtyp aus.
  14. Klicken Sie auf Anfangsstatus laden. Im Listenfeld Anfangsstatus werden die Status angezeigt, die für den ausgewählten Arbeitsaufgabentyp zulässig sind.
  15. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  16. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: Microsoft Team Foundation Server
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Bearbeiten von TFS-Fehlerverfolgungsprofilen

Werden der Server oder die Benutzerdaten Ihres Fehlerverfolgungssystems geändert, müssen Sie auch Ihr Fehlerverfolgungsprofil entsprechend ändern.

So bearbeiten Sie ein vorhandenes TFS-Fehlerverfolgungsprofil:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf den Namen des Fehlerverfolgungsprofils, das Sie ändern möchten. Der Dialog Fehlerverfolgungsprofil bearbeiten wird angezeigt.
  3. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  4. Bearbeiten Sie das Feld Beschreibung des Profils.
  5. Optional: Wählen Sie im Listenfeld einen neuen Typ für das Fehlerverfolgungsprofil aus.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  7. Geben Sie die Domain des TFS-Benutzers ein.
  8. Bearbeiten Sie die URL und die Collection der TFS-Installation.
  9. Wählen Sie ein anderes Projekt aus.
  10. Bearbeiten Sie die URL und den Port des TFS-Proxy.
  11. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
Übergeordnetes Thema: Microsoft Team Foundation Server


StarTeam-Fehlerverfolgungsprofile

Dieser Abschnitt beschreibt, wie StarTeam-Fehlerverfolgungsprofile für die Integration in Silk Central konfiguriert werden.

Das Softwareänderungsmanagement- und Konfigurationsverwaltungsprogramm StarTeam ermöglicht es, den Softwareentwicklungsprozess bis zur Marktreife zu koordinieren und zu verwalten.

Um mit StarTeam-Profilen arbeiten und die Verknüpfungen für Änderungsanforderungen in StarTeam nutzen zu können, muss die StarTeam Cross-Platform Client-Software auf dem Computer installiert sein, auf dem der Browser ausgeführt wird.

Folgende Versionen werden zur Zeit für die Integration mit Silk Central unterstützt: StarTeam 15.x, 16.x

  • Hinzufügen von StarTeam-Fehlerverfolgungsprofilen
    Erstellen Sie ein StarTeam-Fehlerverfolgungsprofil, um Tests im Bereich Tests Fehlern in StarTeam zuzuordnen.
  • Bearbeiten von StarTeam-Fehlerverfolgungsprofilen
    Ändern Sie ein vorhandenes StarTeam-Fehlerverfolgungsprofil, wenn sich der Server oder Anmeldeinformationen ändern.
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Hinzufügen von StarTeam-Fehlerverfolgungsprofilen

So fügen Sie ein StarTeam-Fehlerverfolgungsprofil hinzu:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf Neues Profil, um den Dialog Neues Fehlerverfolgungsprofil zu öffnen.
  3. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  4. Geben Sie eine Beschreibung für das neue Profil ein.
  5. Wählen Sie in dem Listenfeld Typ StarTeam aus.
  6. Geben Sie einen gültigen Benutzernamen und ein Kennwort ein. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  7. Geben Sie den Hostnamen Ihres StarTeam-Servers und den Port ein, mit dem eine Verbindung zum Server hergestellt wird. Wenn diese Einstellung nicht geändert wurde, verwenden Sie den Standardport 49201.
  8. Geben Sie die Art der Verschlüsselung an, die das Profil unterstützt.
  9. Klicken Sie auf Projekt laden, um alle Projekte vom Server zu laden und das Listenfeld Projekt zu füllen. Wählen Sie dann im Listenfeld Projekt ein Projekt aus.
  10. Klicken Sie auf Ansicht laden, um alle Ansichten des ausgewählten Projekts vom Server zu laden und das Listenfeld Ansicht zu füllen. Wählen Sie danach eine Ansicht im Listenfeld Ansicht aus.
  11. Klicken Sie auf Statusfeld laden, um alle Aufzählungsfelder für Änderungsanforderungen zu laden und das Listenfeld Statusfeld zu füllen. Wählen Sie dann im Listenfeld Statusfeld ein Statusfeld aus. Wenn Sie in StarTeam einen benutzerdefinierten Workflow verwenden, ist dieses Feld das Workflow-Treiberfeld in StarTeam, das dem Silk Central-Statuswert zugeordnet ist.
  12. Wählen Sie einen Typ aus dem Listenfeld Linktyp aus.
    starteam://
    Über Links vom Typ Externe ID auf der Registerkarte Fehler wird der Cross-Platform Client geöffnet.
    http://
    Über Links vom Typ Externe ID auf der Registerkarte Fehler wird der Fehler in der StarTeam-Web-UI geöffnet.
  13. Wenn Sie http:// im Listenfeld Linktyp ausgewählt haben, geben Sie die Webserveradresse der StarTeam-Web-UI in das Feld WebServer ein.
  14. Wählen Sie Yes oder No im Feld Workflow aus. Wählen Sie Yes, wenn die im Workflow angegebenen erforderlichen Felder in der ausgewählten Ansicht angezeigt werden sollen.
  15. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  16. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: StarTeam-Fehlerverfolgungsprofile
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Bearbeiten von StarTeam-Fehlerverfolgungsprofilen

Werden der Server oder die Benutzerdaten Ihres Fehlerverfolgungssystems geändert, müssen Sie auch Ihr Fehlerverfolgungsprofil entsprechend ändern.

So bearbeiten Sie ein StarTeam-Fehlerverfolgungsprofil:

  1. Klicken Sie im Menü auf Fehler > Fehlerverfolgungs-Integrationen. Auf der Seite Fehlerverfolgung werden alle Fehlerverfolgungsprofile angezeigt, die für das System erstellt wurden.
  2. Klicken Sie auf den Namen des Fehlerverfolgungsprofils, das Sie ändern möchten. Der Dialog Fehlerverfolgungsprofil bearbeiten wird angezeigt.
  3. Ändern Sie den Namen des Profils. Dieser Name wird in Listen angezeigt, die auswählbare Profile anbieten.
  4. Bearbeiten Sie das Feld Beschreibung des Profils.
  5. Optional: Wählen Sie im Listenfeld einen neuen Typ für das Fehlerverfolgungsprofil aus.
  6. Ändern Sie den Benutzernamen und das Kennwort. Diese Benutzerdaten werden für den Zugriff auf das Fehlerverfolgungssystem verwendet.
  7. Bearbeiten Sie den Hostnamen Ihres StarTeam-Servers und den Port, mit dem eine Verbindung zum Server hergestellt wird.
  8. Ändern Sie die Art der Verschlüsselung, die das Profil unterstützt.
  9. Wenn Sie das StarTeam-Projekt ändern möchten, klicken Sie auf Projekt laden, um alle Projekte vom Server zu laden und das Listenfeld Projekt zu aktualisieren. Wählen Sie dann im Listenfeld Projekt ein Projekt aus.
  10. Klicken Sie auf Ansicht laden, um alle Ansichten des ausgewählten Projekts vom Server zu laden und das Listenfeld Ansicht zu füllen. Wählen Sie danach eine Ansicht im Listenfeld Ansicht aus.
  11. Klicken Sie auf Statusfeld laden, um alle Aufzählungsfelder für Änderungsanforderungen zu laden und das Listenfeld Statusfeld zu füllen. Wählen Sie dann in dem Listenfeld Statusfeld ein Statusfeld aus. Wenn Sie in StarTeam einen benutzerdefinierten Workflow verwenden, ist dieses Feld das Workflow-Treiberfeld in StarTeam, das dem Silk Central-Statuswert zugeordnet ist.
  12. Wählen Sie einen Typ aus dem Listenfeld Linktyp aus.
    starteam://
    Über Links vom Typ Externe ID auf der Registerkarte Fehler wird der Cross-Platform Client geöffnet.
    http://
    Über Links vom Typ Externe ID auf der Registerkarte Fehler wird der Fehler in der StarTeam-Web-UI geöffnet.
  13. Wenn Sie http:// im Listenfeld Linktyp ausgewählt haben, geben Sie die Webserveradresse der StarTeam-Web-UI in das Feld WebServer ein.
  14. Wählen Sie Yes oder No im Feld Workflow aus. Wählen Sie Yes, wenn die im Workflow angegebenen erforderlichen Felder in der ausgewählten Ansicht angezeigt werden sollen.
  15. Klicken Sie auf OK.

    Silk Central versucht mithilfe der bereitgestellten Informationen eine Verbindung zum externen System herzustellen.

    Anmerkung: Tritt ein Fehler auf, überprüfen Sie die bereitgestellten Informationen, oder wenden Sie sich an den Administrator.
  16. Wenn die Verbindung erfolgreich hergestellt wurde, werden Sie in einem Bestätigungsdialog gefragt, ob Sie die internen Fehlerstatuswerte den Statuswerten des neu erstellten Profils zuordnen möchten.
    • Klicken Sie auf Ja, und fahren Sie mit der Anleitung Zuordnen von Fehlerstatuswerten fort.
    • Klicken Sie auf Nein, wenn Sie die Statuswerte später zuordnen möchten.
Übergeordnetes Thema: StarTeam-Fehlerverfolgungsprofile
Zugehörige Tasks
Zuordnen von Fehlerstatuswerten


Löschen von Fehlerverfolgungsprofilen

So löschen Sie ein Fehlerverfolgungsprofil:

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Fehlerverfolgung. Die Seite Fehlerverfolgung wird angezeigt. Hier werden alle Fehlerverfolgungsprofile aufgeführt, die für das System erstellt wurden.
  3. Klicken Sie in der Spalte Aktionen des Fehlerverfolgungsprofils, das Sie löschen möchten, auf Fehlerverfolgungsprofil löschen. Ein Bestätigungsdialogfeld wird geöffnet.
  4. Klicken Sie auf Ja.
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Fehlerverfolgungsprofile (Seite)

Projekt:<Projektname> > Projekteinstellungen > Fehlerverfolgung

Mithilfe dieser Seite können Sie Profile zur Integration externer Fehlerverfolgungssysteme in Silk Central konfigurieren. Klicken Sie auf Neues Profil, um ein neues Fehlerverfolgungsprofil zu erstellen. Für jedes Fehlerverfolgungsprofil werden auf der Seite die folgenden Spalten angezeigt:

Spalte | Beschreibung
Name | Der Name des Profils, so wie er in der Benutzeroberfläche von Silk Central und in Berichten angezeigt wird. Klicken Sie auf den Namen, um das betreffende Profil zu bearbeiten.
Typ | Das externe Fehlerverfolgungssystem.
Anmeldung | Der Anmeldename, mit dem eine Verbindung zwischen Silk Central und dem Fehlerverfolgungssystem hergestellt wird.
Repository-Info | Der physische Standort des Fehlerverfolgungssystems. Hostname oder URL.
Erstellt am | Datum, an dem das Fehlerverfolgungsprofil erstellt wurde.
Erstellt von | Der Benutzer, der das Fehlerverfolgungsprofil erstellt hat.
Aktionen
Die folgenden Aktionen können für ein Fehlerverfolgungsprofil ausgeführt werden:
  • Fehlerverfolgungsprofil löschen
  • Zuordnung des Fehlerverfolgungsprofils bearbeiten
Übergeordnetes Thema: Integration von Fehlerverfolgungsprofilen


Statusursachen

Statusursachen qualifizieren den Status eines manuellen Testlaufs. Damit können sie festlegen, weshalb ein bestimmter Testlauf den Status Bestanden, Fehlgeschlagen oder Nicht ausgeführt hat. Sie können bis zu fünf Ursachen für jeden Status definieren. Für den Status Bestanden ist die Ursache Nicht unterstützt bereits vordefiniert, sowie für den Status Fehlgeschlagen die Ursache Nicht gelöst. Zusätzliche Ursachen für jeden Status zu definieren hilft Ihnen dabei, den Status eines Testlaufs genauer zu qualifizieren. Sie könnten z.B. die folgenden Ursachen für die Status definieren:
  • Bestanden Nicht unterstützt
  • Fehlgeschlagen Nicht gelöst, Systemabsturz, Hilfe nicht verfügbar, Anwendung hängt
  • Nicht ausgeführt Antwort ausständig - intern, Antwort ausständig - Kunde, Testumgebung nicht verfügbar
  • Definieren von Statusursachen
    Definieren Sie Statusursachen, um den Status von Testläufen zu qualifizieren.
Übergeordnetes Thema: Projekteinstellungen
Zugehörige Verweise
Status von Tests und Testschritten
Berechtigungen für Tests und Ausführungen


Definieren von Statusursachen

Sie benötigen die Berechtigung Tests und Ausführungen Verwalten, um Statusursachen hinzuzufügen oder zu bearbeiten, und Tests und Ausführungen Löschen um Statusursachen zu löschen. Weitere Informationen finden Sie in Berechtigungen für Tests und Ausführungen.

  1. Klicken Sie im Menü auf Projekt:<Projektname> > Projekteinstellungen.
  2. Klicken Sie auf die Registerkarte Statusursachen.
  3. Klicken Sie unterhalb vom Status, dem Sie eine neue Ursache hinzufügen wollen, auf Statusursache hinzufügen. Eine neue Statusursache wird der Liste hinzugefügt.
  4. Klicken Sie in das Textfeld der neuen Statusursache und geben Sie einen beschreibenden Text ein.
  5. Drücken Sie die Eingabe-Taste um den Text zu speichern.
Bereits vorhandene Texte von Statusursachen können auch bearbeitet werden, indem Sie in das Textfeld der Statusursache klicken, einen beschreibenden Text eingeben, und danach wieder die Eingabe-Taste drücken.
Übergeordnetes Thema: Statusursachen


Projekteinstellungen (Seite)

Projekt:<Projektname> > Projekteinstellungen > Projekteinstellungen

Auf der Seite Projekteinstellungen werden die folgenden allgemeinen Informationen des aktiven Projekts angezeigt:

Element | Beschreibung
Name der Build-Informationsdatei | Build-Informationsdateien enthalten Projektinformationen, wie z. B. Build-Nummer, Build-Log-Pfad, Fehler-Log-Pfad und Build-Pfad. Geben Sie in dieses Feld den Namen der Build-Informationsdatei des aktiven Projekts ein. Die Build-Informationen in dieser Datei werden von allen Testsuiten gelesen.
Geplantes Freigabedatum | Das geplante Freigabedatum des aktiven Projekts im Format MM/TT/JJJJ.
Folgende Dateitypen in Ergebnissen ignorieren | Die Erweiterungen der Ergebnisdateien oder anderen Dateitypen, die nicht als Ergebnisse für Testsuiten gespeichert werden sollen.
Übergeordnetes Thema: Projekteinstellungen
Zugehörige Konzepte
Build-Informationen


Projektvorlagen

In diesem Thema wird das Konzept der Projektvorlagen in Silk Central beschrieben.

Die Vorlage für agile Projekte ermöglicht die Interaktion von Silk Central mit VersionOne oder anderen agilen Projektmanagementsystemen. Die Vorlage ist ein Projekt mit den Attributen "Release" und "Sprint". Wenn Sie mit dieser Vorlage ein neues Projekt erstellen, werden automatisch ein Standardcontainer und ein Standardordner erstellt. Die von dem Projektmanagementsystem erstellten Tests werden im Standardordner gespeichert. Für den Container und den Ordner sind weder ein Versionsverwaltungsprofil noch ein Produkt festgelegt. Sie sind deshalb als unvollständig markiert.

Übergeordnetes Thema: Verwalten von Projekten


Integrationen

Silk Central kann in/mit viele(n) verschiedene(n) Tools für verschiedene Zwecke integriert werden.

  • Codeanalysetools-Integration
    Hier wird die Integration mit Codeanalysetools beschrieben.
  • Integration von Fehlerverfolgungsprofilen
    Hier wird beschrieben, wie Sie Silk Central in externe Fehlerverfolgungssysteme integrieren.
  • Integration von Anforderungsverwaltungssystemen
    Durch die Integration eines externen Anforderungsverwaltungssystems können Sie die Anforderungsverwaltungsfunktionen von Silk Central mit denen des betreffenden Systems koordinieren.
  • Versionsverwaltungsprofil-Integration
    Hier wird beschrieben, wie Versionsverwaltungsprofile integriert werden.
  • Integration von Test-Automatisierungstools
    Hier wird die Integration mit Testautomatisierungstools beschrieben.
  • Automatisierungsserver-Integrationen
    Wenn Sie Silk Central und Ihren Automatisierungsserver, wie z.B. Jenkins, integrieren, können Sie Ihre Testausführungen in Ihr Continuous-Integration-Build-System integrieren.
  • Kommunikation mit einem externen System über SSL
    Fügen Sie ein selbstsigniertes Zertifikat zu dem standardmäßigen Java-Keystore hinzu, um mit einem Host mit einem selbstsignierten Zertifikat über SSL zu kommunizieren.
Übergeordnetes Thema: Verwaltung


Codeanalysetools-Integration

  • DevPartner Codeabdeckungsintegration
    Hier wird die Integration mit der Komponente Codeanalyse von DevPartner Studio beschrieben.
Übergeordnetes Thema: Integrationen


DevPartner Codeabdeckungsintegration

Silk Central kann mit der Komponente Codeanalyse von DevPartner Studio integriert werden. Durch diese Integration können Sie die Codeanalyse in .NET-Anwendungen durchführen.

Weitere Information finden Sie unter .NET Codeanalyse.

Übergeordnetes Thema: Codeanalysetools-Integration
Zugehörige Konzepte
.NET Codeanalyse


Versionsverwaltungsprofil-Integration

  • AccuRev
    Hier wird beschrieben, wie AccuRev-Versionsverwaltungsprofile konfiguriert werden.
  • Apache Commons Virtual File System
    Hier wird beschrieben, wie die Virtual File System-Versionsverwaltungsprofile konfiguriert werden.
  • Git
    Hier wird beschrieben, wie Git-Versionsverwaltungsprofile konfiguriert werden.
  • Microsoft Team Foundation Server
    Hier wird beschrieben, wie Team Foundation Server-Versionsverwaltungsprofile konfiguriert werden.
  • Silk Test Workbench
    Hier wird beschrieben, wie Silk Test Workbench-Versionsverwaltungsprofile konfiguriert werden.
  • StarTeam
    Hier wird beschrieben, wie StarTeam-Versionsverwaltungsprofile konfiguriert werden.
  • Subversion
    Hier wird beschrieben, wie Subversion-Versionsverwaltungsprofile konfiguriert werden.
  • SilkTestPartner
    Hier wird beschrieben, wie TestPartner-Versionsverwaltungsprofile konfiguriert werden.
  • Universal Naming Convention
    Hier wird beschrieben, wie Universal Naming Convention-Versionsverwaltungsprofile konfiguriert werden.
Übergeordnetes Thema: Integrationen


Integration von Test-Automatisierungstools

  • Unified Functional Testing (UFT) Tests
    Mit Unified Functional Testing (UFT) Software, früher HP QuickTest Professional (QTP) genannt, können funktionales Testen und Regressionstests für Software-Anwendungen und -Umgebungen automatisiert werden.
  • JUnit-Tests
    JUnit ist ein Unit-Test-Framework für die Java-Programmiersprache. Verwenden Sie diesen Testtyp für JUnit-, Silk4J- und Selenium-Tests.
  • MSTest-Tests
    MSTest ist ein Befehlszeilen-Tool von , welches Unit-Tests ausführt die mit Microsoft erstellt wurden. Verwenden Sie diesen Testtyp für MSTest- und Silk4NET-Tests.
  • NUnit-Tests
    NUnit ist ein Unit-Test-Framework für die Microsoft .NET-Programmiersprache.
  • ProcessExecutor-Tests
    Mit dem ProcessExecutor-Testtyp kann jede beliebige Befehlszeile ausgeführt werden.
  • Silk Performer .NET Explorer-Tests
    Der -Testtyp wird verwendet um bestimmte Silk Performer .NET Explorer-Skripts oder einen bestimmten Testfall eines Skripts auszuführen.
  • Silk Performer-Tests
    Silk Performer-Projekte können in Silk Central-Tests integriert und über Silk Central direkt ausgeführt werden. Dadurch stehen leistungsfähige Funktionen zur Analyse von Testergebnissen und Berichtserstellung zur Verfügung. Außerdem können Tests in Silk Central durch vorkonfigurierte Ausführungstermine automatisiert ausgeführt werden.
  • Silk Test Classic-Tests
    Die Silk Central-Schnittstelle von Silk Test Classic ermöglicht Silk Test Classic-Benutzern die zuverlässige Ausführung automatisierter Tests. Jeder Testfall eines Silk Test Classic-Skripts wird in seinem eigenen Testlauf ausgeführt und produziert seine eigenen Ergebnisse.
  • Silk Test Workbench-Tests
    Silk Test Workbench ist ein automatisiertes Testprogramm, das die Funktionstests komplexer Anwendungen beschleunigt. Silk Test Workbench bietet Unterstützung für Testanwendungen, die mit einer Vielzahl unterschiedlicher Entwicklungsprogramme hergestellt wurden, etwa Java, .NET, browserbasierte Webanwendungen und COM-Komponenten wie ActiveX-Steuerelemente und Automatisierungsobjekte.
  • SilkTestPartner Tests
    TestPartner ist ein Micro Focus-Produkt zum Testen von Web- und Microsoft Windows-basierten Anwendungen, die Microsoft-Technologie verwenden.
  • Testen mit Windows Script Host
    Hier wird beschrieben, wie eine Umgebung für Hosting-Skripts mit Windows Script Host erstellt wird.
Übergeordnetes Thema: Integrationen


Automatisierungsserver-Integrationen

Mit den Silk Central Webdiensten können Sie Ihre Testausführungen in Ihr Continuous-Integration-Build-System integrieren. Falls Sie Jenkins als Automatisierungsserver verwenden, können Sie das Silk Central-Integrations-Plugin direkt von der Jenkins Plugin-Seite herunterladen.

Übergeordnetes Thema: Integrationen
Zugehörige Konzepte
Silk Central-Webdienste
Zugehörige Tasks
Hochladen einer Schlüsselwort-Bibliothek über die Befehlszeile


API-Hilfe

In der API-Hilfe finden Sie Informationen darüber, wie Plug-Ins erstellt und verteilt werden, um Tools von Drittanbietern in Silk Central zu integrieren. Sie enthält Webdienst-Spezifikationen und API-Beschreibungen und erläutert, wie Plug-Ins in Silk Central integriert werden.

  • Einführung
    Diese Hilfe gibt einen Überblick über die API, die implementiert wurde, damit Sie Anwendungen von Drittanbietern in Silk Central integrieren können.
  • Erstellen von Plug-Ins
    Beschreibt die Aufgaben, die bei der Erstellung aller Arten von Plug-Ins ausgeführt werden müssen.
  • Integration der Codeabdeckung
    Hier werden die APIs beschrieben, die zur Integration der Codeabdeckung nötig sind.
  • Integration der Versionsverwaltung
    Hier wird beschrieben, wie Sie benutzerdefinierte Versionsverwaltungs-Plug-Ins für Silk Central konfigurieren.
  • Integration der Fehlerverfolgung
    Dieser Abschnitt erläutert, wie Plug-Ins erstellt werden, die die Integration eines externen Fehlerverfolgungssystems erlauben.
  • Anforderungsverwaltungs-Integrationen
    Hier wird erläutert, wie Sie die Anforderungsverwaltungsfunktionen von Silk Central in Anforderungsverwaltungssysteme von Drittanbietern integrieren können.
  • Integration von Drittanbieter-Testtypen
    Dieser Abschnitt erläutert, wie Sie benutzerdefinierte Plug-Ins für Testtypen erstellen, die nicht zur Standardreihe der verfügbaren Testtypen gehören (Silk Performer, Silk Test Classic, manuelle Tests, NUnit, JUnit und Windows Scripting (WSH)).
  • Cloud Integration
    Hier wird beschrieben, wie Silk Central mit Anbietern von öffentlichen oder privaten Cloud Services integriert werden kann.
  • Silk Central-Webdienste
    Erläutert die verfügbaren Webdienst-Schnittstellen.


Einführung

In diesem Handbuch finden Sie Informationen darüber, wie Plug-Ins erstellt und verteilt werden, um Tools von Drittanbietern in Silk Central zu integrieren. Sie enthält Webdienst-Spezifikationen und API-Beschreibungen und erläutert, wie Plug-Ins in Silk Central integriert werden.

Anmerkung: In dieser Hilfe wird davon ausgegangen, dass Sie mit der Implementierung und der Verwendung von Webdiensten vertraut sind.

Übersicht

Silk Central stellt eine API für die Integration von Anwendungen von Drittanbietern bereit. Mit den APIs von Silk Central können Sie vorhandene Tools zur Versionsverwaltung, Fehlerverfolgung und Anforderungsverwaltung integrieren, indem Sie Silk Central-Plug-Ins konfigurieren. Silk Central wird mit einer Reihe von Beispiel-Plug-Ins ausgeliefert.

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Silk Central-Integrations-Plug-Ins

Die Silk Central-Plug-Ins werden ohne Mängelgewähr und Gewährleistung jedweder Art geliefert. Micro Focus schließt hiermit jegliche ausdrückliche, konkludente, gesetzliche oder sonstige Gewährleistung aus, insbesondere die stillschweigende Gewährleistung der handelsüblichen Qualität, der Eignung für einen bestimmten Zweck, der Virenfreiheit, der Genauigkeit bzw. Vollständigkeit, des stillen Genusses, des ungestörten Besitzes und der Nichtbeeinträchtigung von Eigentumsrechten Dritter.

Die Verwendung der Plug-Ins erfolgt auf eigenes Risiko. Micro Focus schließt hiermit jegliche Haftung für unmittelbare, mittelbare oder spezielle Schäden, für Schadenersatz und für Folgeschäden jedweder Art, insbesondere entgangenen Gewinn, aus, die sich aus der Verwendung der Plug-Ins ergeben oder damit in Beziehung stehen.

Übergeordnetes Thema: API-Hilfe


Erstellen von Plug-Ins

Übersicht

In diesem Abschnitt wird beschrieben, wie Sie Plug-Ins für Silk Central erstellen. Hier werden nur die Aufgaben erläutert, die bei der Erstellung aller Arten von Plug-Ins ausgeführt werden müssen.

Plug-In-Art

Silk Central stellt mehrere Plug-In-APIs bereit. Jede API stellt eine Art dar.

Kompilierung

In den Versionshinweisen zu Silk Central finden Sie die zum Entwickeln und Kompilieren von Plug-Ins geeignete Java-Version. Dies ist für die Kompatibilität mit dem JRE von Silk Central wichtig.

Testumgebung

Nach dem Entwickeln von Plug-In-Klassen und dem Implementieren einer Arten-API können Sie ein Plug-In-Paket (JAR- oder ZIP-Datei) erstellen.

  • Wenn Ihr Plug-In keine weiteren Abhängigkeiten aufweist (oder von Bibliotheken abhängt, die bereits Teil von Silk Central sind), brauchen Sie nur eine JAR-Datei zu erstellen, die Ihre Klassen enthält.
  • Hängt Ihr Plug-In von anderen Bibliotheken ab, kopieren Sie diese Bibliotheken in das Unterverzeichnis lib, und packen Sie alle Bibliotheken in einem ZIP-Archiv.

Legen Sie die erstellte Datei im Plug-In-Verzeichnis <application server installation directory>\plugins\ ab.

Anmerkung: Damit das neue Plug-In in Silk Central verfügbar wird, müssen Sie den Anwendungsserver und den Front-End-Server neu starten. Weitere Informationen zum Neustart von Servern finden Sie in den Themen zur Verwaltung in diesem Hilfesystem.

Verteilung

Nachdem die Plug-In-Arten in Silk Central bekannt sind, steht auch fest, welche Arten von welchen Servern (Ausführungsserver, Anwendungsserver und Front-End-Server) benötigt werden. Jedes Plug-In kann auf dem Anwendungsserver installiert werden. Silk Central verteilt die Plug-Ins automatisch auf die richtigen Server.

Übergeordnetes Thema: API-Hilfe
Zugehörige Konzepte
Integration der Versionsverwaltung
Integration der Fehlerverfolgung
Anforderungsverwaltungs-Integrationen
Integration von Drittanbieter-Testtypen
Integration der Codeabdeckung
Cloud Integration


Integration der Codeabdeckung

Die in diesem Kapitel besprochene Java API-Schnittstelle wird benötigt, um Plug-Ins für Silk Central zu erstellen, die die Integration eines externen Codeabdeckungs-Tools erlauben.

Die Codeabdeckungs-Tools liefern Informationen darüber, welcher Code durch Tests abgedeckt wird. Silk Central liefert standardmäßig die folgenden Codeabdeckungs-Tools:
  • Silk Central Java Codeanalyse (Java Code Analysis Agent)
  • DevPartner Studio .NET Codeanalyse (Windows Code Analysis Framework)
Anmerkung: Wenn Ihre zu testende Anwendung unter Linux läuft, lesen Sie das Thema Installation des Codeanalyse Systems in einer Linux-AUT-Umgebung.

Falls die zwei vorher genannten Tools nicht ausreichend sind, können Sie Ihre eigene Integration zur Codeabdeckung erstellen und verteilen. Siehe Creating Your Own Code Coverage Plugin.

Anmerkung: Zusätzlich zur Verteilung Ihrer maßgeschneiderten Anwendung auf dem Anwendungsserver (Details im Thema Plug-Ins erstellen) müssen Sie Ihre maßgeschneiderte Anwendung auf dem Codeanalyse Systemserver verteilen. Hier befindet sich Ihr AUT und Codeabdeckungs-Tool. Der Pfad lautet wie folgt: \Silk\Silk Central <version>\Plugins
  • Erstellen Ihres eigenen Codeabdeckungs-Plug-Ins
    Hier wird das Erstellen von Codeabdeckungs-Plug-Ins beschrieben.
  • Installation des Codeanalyse-Systems in einer Linux-AUT-Umgebung
    Hier wird beschrieben, wie das Codeanalyse-System in einer Linux-AUT-Umgebung installiert wird.
Übergeordnetes Thema: API-Hilfe
Zugehörige Konzepte
Erstellen von Plug-Ins
Integration der Versionsverwaltung
Integration der Fehlerverfolgung
Anforderungsverwaltungs-Integrationen
Integration von Drittanbieter-Testtypen
Testumgebung


Erstellen Ihres eigenen Codeabdeckungs-Plug-Ins

In diesem Thema wird beschrieben, wie ein Codeabdeckungs-Plug-In erstellt wird. Sie sollten mit dem Silk Central-Baseline-Konzept vertraut sein. In Silk Central wird vor jedem Lauf eine Baseline benötigt. Eine Baseline enthält alle Namensräume/Pakete/Klassen/Methoden der Testanwendung.

Anmerkung: Das Silk Central-API erfordert die Rücksendung einer XML-Datei für Codeabdeckungsläufe. Dies bedeutet, dass Sie zusätzliche Schritte unternehmen müssen, um Ihre Daten abzurufen, wenn das Codeabdeckungs-Tool die Codeabdeckungsinformationen in einer Datenbank speichert.
Anmerkung: Testläufe des Codeanalyse-Systems von verschiedenen Ausführungsservern zur gleichen Zeit werden nicht unterstützt.
  1. Fügen Sie dem Klassenpfad die Bibliothek scc.jar hinzu. Diese Bibliothek enthält die Schnittstellen, die Sie erweitern müssen. Sie finden die jar-Datei im Verzeichnis lib des Silk Central-Installationsverzeichnisses.
  2. Fügen Sie die folgenden zwei Importanweisungen hinzu:
    import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfile;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfileException;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisResult;
  3. Erstellen Sie eine Klasse, die CodeAnalysisProfile implementiert.
  4. Fügen Sie alle benötigten Methoden aus der Codeabdeckungsschnittstelle hinzu, welche in den folgenden Schritten aufgelistet sind. Sie können sich für dessen Definition entweder auf die Sample Interface Class beziehen und die Methoden manuell implementieren, oder Sie können den Inhalt von Sample Profile Class kopieren und einfügen, da es die Definitionen für Importe und Methoden bereits enthält.
    Anmerkung: Die Methoden in den folgenden Schritten, die Sie schreiben werden, werden von Silk Central abgerufen, wenn sie benötigt werden. Das heißt, Sie werden diese nicht direkt abrufen.
  5. Code getBaseline. Diese Methode sollte eine XML-Datei erzeugen, die alle Namensräume/Pakete/Klassen/Methoden der Anwendung enthält. Details über das Format der Datei finden Sie in der Themendatei XML-Beispieldatei. Überprüfen Sie die XML-Daten unter Verwendung der XSD-Beispieldatei. Details über XSD finden Sie im Thema Codeabdeckung XSD.

    Diese Funktion wird aufgerufen, bevor mit der Abdeckung begonnen wird, und wird entweder durch das Starten eines Testlaufs des Silk Central-Ausführungsservers ausgelöst, um die Codeanalyse zu starten und alle abzudeckenden Objekte darzustellen. Die Ausgabe muss unter Verwendung des im XML-Schema spezifizierten Formats, welches im Installationsorder CA-Framework enthalten ist, in XML konvertiert werden.

  6. Code startCoverage. Dieser Aufruf sollte dem Codeabdeckungs-Tool mitteilen, mit der Datensammlung zu beginnen. Geben Sie true zurück, wenn die Operation gestartet wurde.

    Dies wird durch das Silk Central-Codeabdeckungssystem aufgerufen, nachdem die Methode getBaseLine() abgeschlossen ist. Jetzt sollten Sie das Codeabdeckungs-Tool zum Sammeln von Codeabdeckungsdaten starten.

  7. Code stopCoverage. Dieser Aufruf sollte dem Codeabdeckungs-Tool mitteilen, die Datensammlung zu beenden. Geben Sie true zurück, wenn die Operation erfolgreich durchgeführt wurde.

    Dies wird nach startCoverage aufgerufen und wird ausgelöst wenn der Silk Central-Ausführungsserver einen Testlauf beendet hat.

  8. Code getCoverage. Dies erzeugt eine XML-Datei mit den gesammelten Daten von den zwischen den Methoden startCoverage undstopCoverage gesammelten Daten. Details über das Format der Datei finden Sie im Thema XML-Beispieldatei. Überprüfen Sie die XML-Daten unter Verwendung der XSD-Beispieldatei. Details über XSD finden Sie im Thema Codeabdeckung XSD.

    Diese Funktion wird nach stopCoverage() aufgerufen und gibt alle gesammelten Abdeckungsdaten zurück. Die Ausgabe muss unter Verwendung des im XML-Schema spezifizierten Formats in XML konvertiert werden.

  9. Code GetName. Dies sollte den Namen bereitstellen, der als Referenz für das Codeabdeckungs-Tool verwendet wird. So wird zum Beispiel dieser Wert als einer der Werte im Listenfeld Codeanalyse Profil im Dialog Einstellungen für die Codeanalyse bearbeiten verwendet.

    Dies wird zuerst durch das Silk Central-Codeabdeckungssystem aufgerufen. Der Name des Plug-Ins wird in der Codeabdeckungs-Liste in Silk Central angezeigt.

  10. Integrieren Sie das Plug-In in ein Jar-Archiv, und platzieren Sie das Jar-Archiv in einer ZIP-Datei.
  11. Verteilen Sie Ihr Plug-In auf die folgenden Servergruppen:
    • Im Verzeichnis Plugins des Silk Central-Installationsordners.
    • Im Verzeichnis Plugins der CA-Framework-Installation.
  • Beispielprofilklasse
    Hier wird eine Beispielprofilklasse beschrieben.
  • Codeabdeckung-XSD
    Hier wird die Codeabdeckung-XSD-Datei beschrieben.
  • XML-Beispieldatei
    Hier wird die XML-Beispieldatei für die Codeabdeckungsintegration API beschrieben.
Übergeordnetes Thema: Integration der Codeabdeckung


Beispielprofilklasse

Diese Beispieldatei stellt alle benötigten Methoden, Importe und Hilfsmittel für das Codeabdeckungs-Plug-In dar.

//Add the library scc.jar to your classpath as it contains the interfaces that
//must be extended. The JAR file can be found in the lib directory of the Test
//Manager installation directory.
//
//make sure to include these imports after adding the scc.jar external reference
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfile;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfileException;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisResult;

public class myProfileClass implements CodeAnalysisProfile{

  // This function is called first by the Silk Central Code Coverage framework
  // The name of the plug-in is displayed in the code coverage drop down in Silk Central
  @Override
  public String getName() {
    // The name of the plugin cannot be an empty string
    return "my plugin name";
  }

  // This function is called before starting coverage,
  // this should return all of the objects to be covered and needs to be
  // converted into xml using the format specified in the XML schema
  // CodeCoverage.xsd included in the CA-Framework installation folder.
  // This is triggered by the Silk Central Execution Server starting a test run
  // to start code analysis.
  @Override
  public CodeAnalysisResult getBaseline() throws CodeAnalysisProfileException {
    CodeAnalysisResult result = new CodeAnalysisResult();
    try{
      String baselineData = MyCodeCoverageTool.getAllCoveredObjectsData();
      String xmlString = xmltransformXML(baselineData);
      result.Xml(xmlString);
      String myCustomLogMessage = "Code Coverage baseline successfully retrieved.";
      result.AddLogMsg(myCustomLogMessage);
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
    return result;
  }

  //This function is called by the Silk Central Code Coverage Framework after the getBaseLine() method is complete
  //this is where you should start my code coverage tool
  //collecting code coverage data

  @Override
  public boolean startCoverage() throws CodeAnalysisProfileException {
    try{
      MyCodeCoverageTool.StartCollectingCoverageData();
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
  }
  //This function is called after startCoverage,
  //This is triggered by the Silk Central Execution Server finishing a test run
  //to stop code analysis
  //Call to my code coverage tool to stop collecting data here.
  @Override
  public boolean stopCoverage() throws CodeAnalysisProfileException {
    try{
      MyCodeCoverageTool.StopCollectingCoverageData();
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
  }
  // This function is called after stopCoverage(),
  // and should return all the coverage data collected and needs to be
  // converted into xml using the format specified in the XML schema
  // CCoverage.xsd included in the CA-Framework installation folder

  @Override
  public CodeAnalysisResult getCoverage() throws CodeAnalysisProfileException {
    CodeAnalysisResult result = new CodeAnalysisResult();
    try{
      String coverageData = MyCodeCoverageTool.getActualCoverageData();
      String xmlString = xmltransformXML(coverageData);
      result.Xml(xmlString);
      String myCustomLogMessage = "Code Coverage successfully retrieved.";
      result.AddLogMsg(myCustomLogMessage);
    }catch(Exception e){
     throw new CodeAnalysisProfileException(e);
    }

    return result;
  }

  private String transformXML(String myData){
    //code to transform from my data to the Silk CentralM needed xml
    ...
    return xmlString;
  }

}
Übergeordnetes Thema: Erstellen Ihres eigenen Codeabdeckungs-Plug-Ins


Codeabdeckung-XSD

Im Folgenden finden Sie die Codeabdeckung-XSD, welche Sie verwenden sollten, um die von Ihrem Codeabdeckungs-Tool erstellte XML-Datei zu validieren. Dieses Dokument kann hier gefunden werden: <CA Framework installation>\CodeAnalysis\CodeCoverage.xsd.

<xs:schema id="data" xmlns="" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:element name="coverage">
    <xs:complexType>
      <!--type will be method when defined as a child to class or line when defined as a child to method-->
      <xs:attribute name="type" type="xs:string" />
      <!--hits for the definition file will be 0, the update file will define the hits count-->
      <xs:attribute name="hits" type="xs:string" />
      <!--the total count will be sent with both the definition and update file, both counts will match-->
      <xs:attribute name="total" type="xs:string" />
      <!--this will be an empty string for the definition file, the line numbers will be sent in the update file delimited by a colon-->
      <xs:attribute name="lines" type="xs:string" />
    </xs:complexType>
  </xs:element>
  <xs:element name="data">
    <xs:complexType>
      <xs:choice minOccurs="0" maxOccurs="unbounded">
        <xs:element ref="coverage" />
        <xs:element name="class">
          <xs:complexType>
            <xs:sequence>
              <xs:element name="sourcefile" minOccurs="0" maxOccurs="unbounded">
                <xs:complexType>
                  <!--full path to the code file-->
                  <xs:attribute name="name" type="xs:string" />
                </xs:complexType>
              </xs:element>
              <xs:element ref="coverage" minOccurs="0" maxOccurs="unbounded" />
              <xs:element name="method" minOccurs="0" maxOccurs="unbounded">
                <xs:complexType>
                  <xs:sequence>
                    <xs:element ref="coverage" minOccurs="0" maxOccurs="unbounded" />
                  </xs:sequence>
                  <!--
                      <field_signature> ::= <field_type>
                      <field_type>      ::= <base_type>|<object_type>|<array_type>
                      <base_type>       ::= B|C|D|F|I|J|S|Z
                      <object_type>     ::= L<fullclassname>;
                      <array_type>      ::= [<field_type>

                      The meaning of the base types is as follows:
                      B byte signed byte
                      C char character
                      D double double precision IEEE float
                      F float single precision IEEE float
                      I int integer
                      J long long integer
                      L<fullclassname>; ... an object of the given class
                      S short signed short
                      Z boolean true or false
                      [<field sig> ... array

                      example signature for a java method 'doctypeDecl' with 3 string params and a return type void

                          doctypeDecl : (Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;)V

                      refer to org.apache.bcel.classfile.Utility for more information on signatureToString
                  -->
                  <xs:attribute name="name" type="xs:string" />
                  <!--method invokation count, this will be 0 for the definition file-->
                  <xs:attribute name="inv" type="xs:string" />
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="name" type="xs:string" />
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:complexType>
  </xs:element>
</xs:schema>
Übergeordnetes Thema: Erstellen Ihres eigenen Codeabdeckungs-Plug-Ins


XML-Beispieldatei

Die Codeabdeckung API erwartet XML im folgenden Format.

Sie können auch das bereitgestellte XSD-Beispieldokument verwenden, um Ihre XML-Datei zu validieren.

<!--  Generated by 'MyPluginTool'at '2010-11-05T16:11:09'
 -->
<data>
  <class name="ProjectA.ClassA1">
    <sourcefile name="C:\Users\TestApp\ProjectA\ClassA1.cs"/>
    <coverage hits="8" total="8" type="method"/>
    <coverage hits="30" total="30" type="line"/>
    <method inv="2" name="ClassA1  : ()V">
      <coverage hits="3" lines="11:2,12:2,14:2" total="3" type="line"/>
    </method>
    <method inv="2" name="BoolByteMethod  : (LSystem/Boolean;LSystem/SByte;)V">
      <coverage hits="3" lines="17:2,18:2,19:2" total="3" type="line"/>
    </method>
    <method inv="1" name="CharStringMethod  : (LSystem/Char;LSystem/String;)V">
      <coverage hits="3" lines="38:1,39:1,40:1" total="3" type="line"/>
    </method>
    <method inv="2" name="DateMethod  : (LSystem/DateTime;)V">
      <coverage hits="3" lines="22:2,23:2,24:2" total="3" type="line"/>
    </method>
    <method inv="1" name="DecimalMethod  : (LSystem/Decimal;LSystem/Single;LSystem/Double;)V">
      <coverage hits="4" lines="27:1,28:1,29:1,30:1" total="4" type="line"/>
    </method>
    <method inv="1" name="IntMethod  : (LSystem/Int32;LSystem/Int64;LSystem/Int16;)V">
      <coverage hits="3" lines="33:1,34:1,35:1" total="3" type="line"/>
    </method>
    <method inv="1" name="passMeArrays  : (LSystem/Int32[];LSystem/Decimal[];)V">
      <coverage hits="6" lines="51:1,52:1,53:1,55:1,56:1,58:1" total="6" type="line"/>
    </method>
    <method inv="1" name="passMeObjects  : (LSystem/Object;LSystem/Object/ClassA1;)V">
      <coverage hits="5" lines="43:1,44:1,45:1,46:1,48:1" total="5" type="line"/>
    </method>
  </class>
  <class name="TestApp.Form1">
    <sourcefile name="C:\Users\TestApp\Form1.Designer.cs"/>
    <coverage hits="2" total="10" type="method"/>
    <coverage hits="24" total="110" type="line"/>
    <method inv="1" name="btnClassA_Click  : (LSystem/Object;LSystem/Object/EventArgs;)V">
      <coverage hits="3" lines="25:1,26:1,27:1" total="3" type="line"/>
    </method>
    <method inv="1" name="CallAllClassAMethods  : ()V">
      <coverage hits="21" lines="35:1,36:1,37:1,38:1,39:1,40:1,41:1,42:1,43:1,44:1,45:1,46:1,48:1,49:1,50:1,51:1,52:1,53:1,54:1,55:1,56:1" total="21" type="line"/>
    </method>
  </class>
</data>
Übergeordnetes Thema: Erstellen Ihres eigenen Codeabdeckungs-Plug-Ins


Installation des Codeanalyse-Systems in einer Linux-AUT-Umgebung

Die folgenden Schritte sollten ausgeführt werden, wenn das von Ihnen zu erstellende Codeabdeckungs-Plug-In mit der zu testenden .NET-Anwendung auf dem Linux-Betriebssystem interagieren soll.

  1. Das Codeanalyse System für Linux ist verfügbar unter Hilfe > Tools > Linux Codeanalyse System. Laden Sie dieses herunter und kopieren Sie es in die Stammkonten oder einen anderen Ordner auf der Linux-Maschine.
  2. Stellen Sie sicher, dass Java Runtime Environment (JRE) 8 auf dem Computer installiert ist, wo die zu testende Anwendung läuft.
  3. Entpacken Sie CA-Framework.tar.gz.
  4. Legen Sie das Codeanalyse-Plug-In im Ordner <Installationsverzeichnis>/18.5 Silk Central/Plugins ab.
  5. Wechseln Sie zum Verzeichnis <Installationsverzeichnis>/18.5 Silk Central/Code Analysis.
  6. Finden Sie das Shellskript startCodeAnalysisFramework.sh, welches den Prozess CA-Framework ausführt.
  7. Führen Sie den folgenden Befehl aus, um die Datei in das Unix-Format zu konvertieren: dos2unix startCodeAnalysisFramework.sh.
  8. Führen Sie den folgenden Befehl aus, um die benötigten Berechtigungen einzustellen, die zur Ausführung des Shellskripts notwendig sind: chmod 775 startCodeAnalysisFramework.sh.
  9. Führen Sie das folgende Shellskript aus, um den CAFramework-Prozess auszuführen: ./startCodeAnalysisFramework.sh.
Das Codeanalyse-System ist zur Verwendung von Silk Central aus bereit.
Übergeordnetes Thema: Integration der Codeabdeckung


Integration der Versionsverwaltung

Mithilfe von Versionsverwaltungsprofilen kann Silk Central in externe Versionsverwaltungssysteme integriert werden.

Sie können in benutzerdefinierte Versionsverwaltungs-Plug-Ins konfigurieren und festlegen, wo die Ausführungsserver von Silk Central den Programmcode für die Testausführung abrufen sollen.

Sehen Sie sich die Sourcen des Pakets com.segue.scc.vcs.subversion auf C:\Program Files (x86)\\Silk\instance_<Instanznummer>_<Instanzname>\Plugins\subversion.zip an, um zu erfahren wie diese Elemente zusammenspielen.

  • Schnittstelle der Versionsverwaltungsintegration
    Führt die Schnittstellen auf, die für die Versionsverwaltungsintegration verwendet werden.
  • Konventionen für die Integration der Versionsverwaltung
    Hier wird erläutert, dass jede Implementierung einen Standardkonstruktor zur Verfügung stellen und jede Schnittstellenmethode SourceControlException festlegen muss.
Übergeordnetes Thema: API-Hilfe
Zugehörige Konzepte
Erstellen von Plug-Ins
Integration der Fehlerverfolgung
Anforderungsverwaltungs-Integrationen
Integration von Drittanbieter-Testtypen
Integration der Codeabdeckung


Schnittstelle der Versionsverwaltungsintegration

Silk Central unterscheidet zwischen SourceControlProfile und VersionControlProfile. Der Unterschied besteht darin, dass SourceControlProfile im Gegensatz zu VersionControlProfile keine Versionsnummern hat.

Die folgenden Silk Central-Schnittstellen werden für die Versionsverwaltungsintegration verwendet:
  • SourceControlProfile
  • VersionControlProfile
  • SourceControlProfileData
  • SourceControlException
  • SourceControlInfo

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Übergeordnetes Thema: Integration der Versionsverwaltung


Konventionen für die Integration der Versionsverwaltung

Jede Implementierung muss einen Standardkonstruktor und (optional) einen Konstruktor mit einem SourceControlProfileData-Parameter zur Verfügung stellen. Fehlt der optionale Konstruktor, muss ein Grundgerüst für SourceControlProfileData bereitgestellt werden.

Da in jeder Schnittstellenmethode die auszulösende SourceControlException festgelegt wird, ist es nicht erlaubt, in einer von der Schnittstelle verwendeten Methode eine RuntimeException auszulösen.

Übergeordnetes Thema: Integration der Versionsverwaltung


Integration der Fehlerverfolgung

Die in diesem Kapitel besprochene Schnittstelle wird benötigt, um Plug-Ins für Silk Central zu erstellen, die die Integration eines externen Fehlerverfolgungssystems (Issue Tracking System, ITS) erlauben.

Durch die Definition von Fehlerverfolgungsprofilen können Sie Tests im Bereich Tests mit Fehlern in Verfolgungssystemen von Drittanbietern verknüpfen. Die Statuswerte der verknüpften Fehler werden von externen Verfolgungssystemen in regelmäßigen Abständen aktualisiert.

Sehen Sie sich die Sourcen des Pakets com.segue.scc.issuetracking.bugzilla3 auf C:\Program Files (x86)\Silk\Silk Central18.5\instance_<Instanznummer>_<Instanzname>\Plugins\Bugzilla3.zip an, um zu erfahren wie diese Elemente zusammenspielen.

  • Java-Schnittstelle
    Hier wird beschrieben, wie eine Fehlerverfolgungs-Integration auf Basis der Java-API implementiert wird.
Übergeordnetes Thema: API-Hilfe
Zugehörige Konzepte
Erstellen von Plug-Ins
Integration der Versionsverwaltung
Anforderungsverwaltungs-Integrationen
Integration von Drittanbieter-Testtypen
Integration der Codeabdeckung
Integration von Fehlerverfolgungsprofilen


Java-Schnittstelle

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Build-Umgebung

Fügen Sie dem Klassenpfad die Bibliothek scc.jar hinzu. Diese Bibliothek enthält die Schnittstellen, die Sie erweitern müssen. Sie finden die jar-Datei im Verzeichnis lib des Silk Central-Installationsverzeichnisses.

Sie müssen zwei Schnittstellen/Klassen erweitern:
  • com.segue.scc.published.api.issuetracking82.IssueTrackingProfile
  • com.segue.scc.published.api.issuetracking.Issue

Klassen/Schnittstellen

  • IssueTrackingProfile
  • IssueTrackingData
  • Issue
  • IssueTrackingField
  • IssueTrackingProfileException
Übergeordnetes Thema: Integration der Fehlerverfolgung


Anforderungsverwaltungs-Integrationen

Anforderungsverwaltungssysteme (Requirements Management System, RMS) von Drittanbietern können in Silk Central integriert werden, um Anforderungen zu verknüpfen und zu synchronisieren.

In diesem Abschnitt erfahren Sie, wie sich mit Hilfe der Java-API Plug-Ins implementieren lassen, um die Anforderungen in Silk Central mit den Anforderungen des Anforderungsverwaltungssystems eines Drittanbieters zu synchronisieren. In diesem Abschnitt werden die Schnittstellen beschrieben, die ein Anforderungs-Plug-In und seine Bereitstellung identifizieren.

Die bereitgestellte JAR- oder ZIP-Datei unterstützt das Standard-Plug-In-Konzept von Silk Central. Sie wird automatisch an alle Front-End-Server verteilt und ermöglicht so den Zugriff auf Tools von Drittanbietern zum Zweck der Konfiguration und Synchronisation. Das Plug-In implementiert eine spezielle Schnittstelle, mit deren Hilfe es von Silk Central als Anforderungs-Plug-In erkannt wird. Es stellt die benötigten Daten für die Anmeldung bei einem Tool eines Drittanbieters bereit.

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Wenn Sie Informationen zu weiteren Plug-Ins benötigen, wenden Sie sich an den Kundensupport.

  • Java-Schnittstellen
    Führt die Schnittstellen der Anforderungs-Plug-In-API auf.
Übergeordnetes Thema: API-Hilfe
Zugehörige Konzepte
Erstellen von Plug-Ins
Integration der Versionsverwaltung
Integration der Fehlerverfolgung
Integration von Drittanbieter-Testtypen
Integration der Codeabdeckung
Testumgebung


Java-Schnittstellen

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Die grundlegende Schnittstelle für den Anfang ist RMPluginProfile (com.segue.tm.published.api.requirements.javaplugin). RMPluginProfile gibt an, dass das Plug-In ein Anforderungs-Plug-In ist.

Die Anforderungs-Java-Plug-In-API umfasst die folgenden zusätzlichen Schnittstellen:
  • RMAction
  • RMAttachment
  • RMDataProvider
  • Optional: RMIconProvider
  • RMNode
  • RMNodeType
  • RMPluginProfile
  • RMProject
  • RMTest
  • RMTestParameter
  • Optional: RMTestProvider
  • RMTestStep
Übergeordnetes Thema: Anforderungsverwaltungs-Integrationen
Zugehörige Konzepte
Testumgebung


Integration von Drittanbieter-Testtypen

Silk Central erlaubt das Erstellen benutzerdefinierter Plug-Ins für Testtypen, die nicht zur Standardreihe der verfügbaren Testtypen gehören. Die Standardreihe umfasst Silk Performer, Silk Test Classic, manuelle Tests, NUnit, JUnit und Windows Scripting Host (WSH). Nach dem Erstellen eines neuen Testtyp-Plug-Ins wird der benutzerdefinierte Testtyp in dem Listenfeld Typ des Dialogfeldes Neue Test zusammen mit den Standard-Testtypen angezeigt, die in Silk Central für neue Tests zur Verfügung stehen.

Ein Plug-In legt fest, welche Eigenschaften benötigt werden, um eine Test zu konfigurieren und die Ausführung eines Tests zu implementieren. Die Metadaten der Eigenschaften werden über eine XML-Konfigurationsdatei definiert.

Das Ziel des Plug-In-Ansatzes besteht darin, Tests zu unterstützen, die auf gebräuchlichen Test-Frameworks wie JUnit und NUnit oder auf Skriptsprachen (WSH) beruhen. Dies erleichtert die Anpassung von Silk Central an eine spezielle Testumgebung. Die klar definierte öffentliche API von Silk Central erlaubt die Implementierung einer eigenen Lösung, die den Anforderungen automatisierter Tests entspricht. Silk Central kann durch jedes Drittanbieter-Tool erweitert werden, das über eine Java-Implementierung oder über die Befehlszeile aufgerufen werden kann.

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Die in Javadoc beschriebenen Klassen sind in der Datei tm-testlaunchapi.jar enthalten.

Wenn Sie Informationen zu weiteren Plug-Ins benötigen, wenden Sie sich an den Kundensupport.

Dieser Abschnitt enthält ein Codebeispiel, das den Teststyp "Process Executor" implementiert. Mit "Process Executor" kann eine beliebige ausführbare Datei aufgerufen werden. Es erweitert die öffentliche Klasse "Process Test Launcher". Weitere Informationen finden Sie im Beispiel Teststart-Plug-In, das Sie unter Hilfe > Tools herunterladen können, sowie in der Datei Readme.txt.

  • Plug-In-Implementierung
    Beschreibt die Richtlinien der API und ihrer Callback-Schnittstelle.
  • Struktur der API
    Führt die Struktur der API für die Integration von Drittanbieter-Testtypen detailliert auf.
  • Beispielcode
    Enthält ein Codebeispiel, das den Testtyp "Process Executor" implementiert, mit dem eine ausführbare Datei aufgerufen werden kann und das die öffentliche ExtProcessTestLaunchBean-Klasse erweitert.
  • XML-Konfigurationsdatei
    Erläutert, dass die XML-Konfigurationsdatei Metadaten über das Testtyp-Plug-In eines Drittanbieters enthält.
  • Benutzerdefinierte Symbole
    Zeigt, wie Symbole für benutzerdefinierte Testtypen entworfen werden, damit der Testtyp schnell erkannt werden kann.
  • Testumgebung
    Erläutert, wie Testtyp-Plug-Ins von Drittanbietern verteilt werden.
  • Angeben von Start und Ende von Videoaufnahmen
    Hier wird beschrieben, wie Sie für Silk Central definieren können, dass Sie einen bestimmten Testfall eines Tests von einem Drittanbieter aufzeichnen wollen.
Übergeordnetes Thema: API-Hilfe
Zugehörige Konzepte
Erstellen von Plug-Ins
Integration der Versionsverwaltung
Integration der Fehlerverfolgung
Anforderungsverwaltungs-Integrationen
Integration der Codeabdeckung


Plug-In-Implementierung

Die Richtlinien der API basieren auf dem weit verbreiteten Java Beans-Konzept. Entwickler können dadurch auf einfache Weise Teststart-Plug-Ins implementieren. Damit der Java-Code keine Textinformationen enthält, werden Metadaten von Eigenschaften in einer XML-Datei festgelegt.

Die Plug-In-Implementierung ist in einem .ZIP-Archiv komprimiert und implementiert eine Callback-Schnittstelle, um integriert werden zu können. Weitere Schnittstellen werden vom Plug-In-Framework bereitgestellt. Sie ermöglichen der Implementierung den Zugriff auf Informationen oder Rückgabewerte.

  • Komprimierung
    Erläutert, wie Plug-Ins komprimiert werden.
  • Übergabe von Parametern an das Plug-In
    Erläutert, auf welche Parametertypen das Plug-In zugreift und wie Parameter an das Plug-In übergeben werden.
Übergeordnetes Thema: Integration von Drittanbieter-Testtypen


Komprimierung

Das Plug-In ist in einem ZIP-Archiv komprimiert, das die Java-Codebase und die XML-Konfigurationsdatei enthält. Im Archiv befinden sich außerdem einige Implementierungen von Teststart-Plug-Ins. Die Codebase kann in einem Java-Archiv (.jar) oder direkt in .class-Dateien enthalten sein, wobei die Ordner die Struktur des Java-Pakets darstellen.

Die TestLaunchBean-Plug-In-Klasse folgt dem Bean-Standard und implementiert die TestLaunchBean-Schnittstelle. Die XML-Konfigurationsdatei im zip-Archiv hat denselben Namen wie ihre Klasse. Dadurch können Sie mehrere Plug-Ins und XML-Dateien in einem einzigen Archiv komprimieren.

Übergeordnetes Thema: Plug-In-Implementierung


Übergabe von Parametern an das Plug-In

Wenn ein Plug-In auf der ExtProcessTestLaunchBean-Klasse basiert, wird jeder Parameter in dem vom Plug-In gestarteten Prozess automatisch als Umgebungsvariable festgelegt. Das ist auch dann der Fall, wenn der Parametername mit dem Namen einer Systemvariable übereinstimmt, sodass der Wert der Systemvariable durch den Parameterwert ersetzt wird (außer wenn der Parameterwert eine leere Zeichenfolge ist).

Die Plug-In-Schnittstelle erlaubt den uneingeschränkten Zugriff auf alle benutzerdefinierten Parameter, die im Bereich Tests von Silk Central definiert wurden. Für Testtypen von Drittanbietern werden nur benutzerdefinierte Parameter unterstützt. Das Plug-In kann keine vordefinierten Parameter verwenden. Die Implementierung entscheidet darüber, ob und wie Parameter für spezielle Tests definiert werden.

Mit der Methode getParameterValueStrings() der Schnittstelle TestLaunchPluginContext können Sie einen Container mit Zuordnungen zwischen Parameternamen (Schlüssel) und ihren Werten in der String-Darstellung abrufen.

Bei JUnit-Testtypen kann jede beliebige JUnit-Testklasse auf einen benutzerdefinierten Parameter des zugrunde liegenden Tests wie auf eine Java-Systemeigenschaft zugreifen. Das Startprogramm übergibt diese Parameter über das Argument "-D" an die ausführende VM.

Übergeordnetes Thema: Plug-In-Implementierung


Struktur der API

Diese Abbildung zeigt detailliert die Struktur der API für die Integration von Drittanbieter-Testtypen.

Struktur der API

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Verfügbare Schnittstellen

  • TestLaunchBean
  • ExtProcessTestLaunchBean
  • TestLaunchPluginContext
  • TestSourceContext
  • TestLaunchResultDrain
Übergeordnetes Thema: Integration von Drittanbieter-Testtypen


Beispielcode

Dieser Beispielcodeblock implementiert den Testtyp "Process Executor", mit dem eine ausführbare Datei aufgerufen werden kann und das die öffentliche ExtProcessTestLaunchBean-Klasse erweitert.

package com.borland.sctm.testlauncher;

import java.io.File;
import java.io.IOException;
import java.util.ArrayList;

import com.segue.tm.published.api.testlaunch.ExtProcessTestLaunchBean;
import com.segue.tm.published.api.testlaunch.TestLaunchResultDrain;

/**
 * Implements an Silk Central test type that can be used to launch
 * any executables, for example from a command line.
 * Extends Silk Central published process test launcher class,
 * see Silk Central API Specification (in Help -> Documentation) for
 * further details.
 */
public class ProcessExecutor extends ExtProcessTestLaunchBean {

  // test properties that will be set by Silk Central using appropriate setter
  // methods (bean convention),
  // property names must conform to property tags used in the XML file

  /**
   * Represents property <command> defined in ProcessExecutor.xml.
   */
  private String command;

  /**
   * Represents property <arguments> defined in ProcessExecutor.xml.
   */
  private String arguments;

  /**
   * Represents property <workingfolder> defined in ProcessExecutor.xml.
   */
  private String workingfolder;

  /**
   * Java Bean compliant setter used by Silk Central to forward the command to be
   * executed.
   * Conforms to property <command> defined in ProcessExecutor.xml.
   */
  public void setCommand(String command) {
    this.command = command;
  }

  /**
   * Java Bean compliant setter used by Silk Central to forward the arguments
   * that will be passed to the command.
   * Conforms to property <arguments> defined in ProcessExecutor.xml.
   */
  public void setArguments(String arguments) {
    this.arguments = arguments;
  }

  /**
   * Java Bean compliant setter used by Silk Central to forward the working
   * folder where the command will be executed.
   * Conforms to property <workingfolder> defined in
   * ProcessExecutor.xml.
   */
  public void setWorkingfolder(String workingfolder) {
    this.workingfolder = workingfolder;
  }

  /**
   * Main plug-in method. See Silk Central API Specification
   * (in Help &gt; Documentation) for further details.
   */
  @Override
  public boolean execute(long time, TestLaunchResultDrain context)
    throws InterruptedException {
    try {
      String[] cmd = getCommandArgs(context);
      File workingDir = getWorkingFolderFile(context);
      String[] envVariables = getEnviromentVariables(context);

      int processExitCode = runExternalProcess(cmd, envVariables, workingDir,
        context.getLog());

      boolean outputXmlFound = handleOutputXmlIfExists(context);

      if (! outputXmlFound && processExitCode != 0) {
        // if no output.xml file was produced, the exit code indicates
        // success or failure
        context.publishMessage(TestLaunchResultDrain.SEVERITY_ERROR,
          "Process exited with return code "
          + String.valueOf(processExitCode));
        context.updateErrors(1, 0);
        // set error, test will get status 'failed'
      }
    } catch (IOException e) {
      // prints exception message to Messages tab in Test Run
      // Results
      context.publishMessage(TestLaunchResultDrain.SEVERITY_FATAL,
        e.getMessage());
      // prints exception stack trace to 'log.txt' that can be viewed in Files
      // tab
      e.printStackTrace(context.getLog());
      context.publishErrors(1, 0);
      return false; // set test status to 'not executed'
    }
    return true;
  }

  /**
   * Initializes environment variables to be set additionally to those
   * inherited from the system environment of the Execution Server.
   * @param context the test execution context
   * @return String array containing the set environment variables
   * @throws IOException
   */
  private String[] getEnviromentVariables(TestLaunchResultDrain context)
    throws IOException {
    String[] envVariables = {
      "SCTM_EXEC_RESULTSFOLDER="
      + context.getTempResultsDir().getAbsolutePath(),
      "SCTM_EXEC_SOURCESFOLDER="
      + sourceAccess().getTestContainerRootDir().getAbsolutePath(),
    };
    return envVariables;
  }

  /**
   * Let Silk Central parse the standard report xml file (output.xml) if exists.
   * See also Silk Central Web Help - Creating a Test Package. A XSD file
   * can be found in Silk Central Help -&gt; Tools -&gt; Test Package XML Schema
   * Definition File
   * @param context the test execution context
   * @return true if output.xml exists
   * @throws IOException
   */
  private boolean handleOutputXmlIfExists(TestLaunchResultDrain context)
    throws IOException {
    String outputFileName = context.getTempResultsDir().getAbsolutePath()
    + File.separator + TestLaunchResultDrain.OUTPUT_XML_RESULT_FILE;
    File outputfile = new File(outputFileName);
    boolean outputXmlExists = outputfile.exists();
    if (outputXmlExists) {
      context.parseStdResultFile(outputfile);
      context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
        String.format("output.xml parsed from '%s'", outputFileName));
    }
    return outputXmlExists;
  }

  /**
   * Retrieves the working folder on the Execution Server. If not configured
   * the results directory is used as working folder.
   * @param context the test execution context
   * @return the working folder file object
   * @throws IOException
   */
  private File getWorkingFolderFile(TestLaunchResultDrain context)
    throws IOException {
    final File workingFolderFile;
    if (workingfolder != null) {
      workingFolderFile = new File(workingfolder);
    } else {
      workingFolderFile = context.getTempResultsDir();
    }
    context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
      String.format("process is exectued in working folder '%s'",
        workingFolderFile.getAbsolutePath()));
    return workingFolderFile;
  }

  /**
   * Retrieves the command line arguments specified.
   * @param context the test execution context
   * @return an array of command line arguments
   */
  private String[] getCommandArgs(TestLaunchResultDrain context) {
    final ArrayList<String> cmdList = new ArrayList<String>();
    final StringBuilder cmd = new StringBuilder();
    cmdList.add(command);
    cmd.append(command);
    if (arguments != null) {
      String[] lines = arguments.split("[\\r\\n]+");
      for (String line : lines) {
        cmdList.add(line);
        cmd.append(" ").append(line);
      }
    }
    context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
      String.format("executed command '%s'", cmd.toString()));
    context.getLog().printf("start '%s'%n", cmd.toString());
    return (String[]) cmdList.toArray(new String[cmdList.size()]);
  }
}
Übergeordnetes Thema: Integration von Drittanbieter-Testtypen


XML-Konfigurationsdatei

Die XML-Konfigurationsdatei enthält Metadaten über das Testtyp-Plug-In eines Drittanbieters.

  • Plug-In-Metadaten
    Plug-In-Metadaten stellen Informationen über das Plug-In und den Teststyp bereit.
  • Allgemeine Metadaten für Eigenschaften
    Beschreibt die allgemeinen Daten, die für alle bearbeitbaren Eigenschaften gleich sind.
  • Metadaten für String-Eigenschaften
    Führt die Typen der Metadaten für String-Eigenschaften auf, die in dem Plug-In verfügbar sind.
  • Metadaten für Dateieigenschaften
    Führt die Typen der Metadaten für Dateieigenschaften auf, die in dem Plug-In verfügbar sind.
Übergeordnetes Thema: Integration von Drittanbieter-Testtypen


Plug-In-Metadaten

Plug-In-Metadaten stellen Informationen über das Plug-In und den Teststyp bereit. Die folgenden Metadatentypen sind verfügbar:

Typ | Beschreibung
id | Ein interner String, der den Typ identifiziert und in allen installierten Plug-Ins eindeutig ist.
label | Der Text, der in Auswahllisten und Bearbeitungsdialogfeldern der Benutzeroberfläche für den Typ angezeigt wird.
description | Zusätzlicher Text, der den Teststyp beschreibt.
version | Zur Unterscheidung verschiedener Versionen eines Typs.
Übergeordnetes Thema: XML-Konfigurationsdatei


Allgemeine Metadaten für Eigenschaften

Für bearbeitbare Eigenschaften gibt es zusätzlich zu den typspezifischen Informationen allgemeine Informationen, die für jeden Eigenschaftstyp gleich sind. Der Name einer Eigenschaft muss den Namen entsprechen, die im Code durch get<<propertyname>>-Methoden definiert werden. Das erste Zeichen muss ein Kleinbuchstabe sein.

Typ | Beschreibung
label | Dieser Text wird in der Benutzeroberfläche angezeigt.
description | Zusätzlicher Text, der die Eigenschaft beschreibt.
isOptional | Der Wert "true" bedeutet, dass keine Benutzereingabe erforderlich ist.
default | Der voreingestellte Wert der Eigenschaft, wenn ein neuer Test erstellt wird. Der Wert muss dem Typ der Eigenschaft entsprechen.
Übergeordnetes Thema: XML-Konfigurationsdatei


Metadaten für String-Eigenschaften

Hier werden die Typen der Metadaten für String-Eigenschaften aufgeführt, die in dem Plug-In verfügbar sind.

Typ | Beschreibung
maxLength | Die maximale Zeichenanzahl, die der Benutzer eingeben kann.
editMultiLine | Gibt an, ob das Eingabefeld mehrere Zeilen haben soll.
isPassword | Bei true wird die Eingabe des Benutzers in *** umgewandelt.
Übergeordnetes Thema: XML-Konfigurationsdatei


Metadaten für Dateieigenschaften

Hier werden die Typen der Metadaten für Dateieigenschaften aufgeführt, die in dem Plug-In verfügbar sind.

Bei bestimmten Dateiwerten wird unterschieden, ob es sich um eine Datei ohne Versionsverwaltung mit absolutem Pfad auf dem Ausführungsserver oder um eine Datei mit Versionsverwaltung handelt. Der Pfad von Dateien unter Versionsverwaltung ist immer relativ zum Stammverzeichnis des Containers. Solche Dateien werden normalerweise verwendet, um eine auszuführende Testquelle anzugeben. Absolute Pfade auf dem Ausführungsserver verweisen normalerweise auf ein Tool oder eine Ressource, die den Test auf dem Ausführungsserver aufruft.

Typ | Beschreibung
openBrowser | Der Wert true bedeutet, dass ein Browser geöffnet werden soll, um die Datei aus den Dateien in einem Container auszuwählen.
isSourceControl | Der Wert true bedeutet, dass die Datei aus einem Versionsverwaltungssystem stammt.
fileNameSpec | Bezeichnet eine Einschränkung für zulässige Dateinamen wie im Standard-Dialogfeld "Durchsuchen" von Windows.
Übergeordnetes Thema: XML-Konfigurationsdatei


Benutzerdefinierte Symbole

Sie können eigene Symbole für Ihren Testtyp entwerfen, damit der Testtyp schnell erkannt werden kann. Um diese Symbole für das Plug-In festzulegen, für das Sie in der XML-Konfigurationsdatei den Bezeichner PluginId definiert haben, müssen Sie die folgenden vier Symbole in das Stammverzeichnis des Plug-Ins kopieren.

Name | Beschreibung
<PluginId>.gif | Das Standardsymbol für Ihren Testtyp. Zum Beispiel: ProcessExecutor.gif.
<PluginId>_package.gif | Das Symbol für den Testpaketstamm und die Suiteknoten für den Fall, dass Sie einen Test des angegebenen Testtyps in ein Testpaket konvertieren. Zum Beispiel: ProcessExecutor_package.gif.
<PluginId>_linked.gif | Das Symbol wird verwendet, wenn der einem Test übergeordnete Ordner mit einem Container verknüpft wird. Zum Beispiel: ProcessExecutor_linked.gif.
<PluginId>_incomplete.gif | Das Symbol wird verwendet, wenn das Produkt oder das Versionsverwaltungsprofil des übergeordneten Containers des Tests nicht definiert ist.
Beachten Sie beim Erstellen eines neuen Symbols für einen Testtyp folgende Regeln:
  • Verwenden Sie nur GIF-Symbole. Bei der Dateierweiterung wird die Groß-/Kleinschreibung berücksichtigt. Die Dateierweiterung muss immer in Kleinbuchstaben (.gif) angegeben werden.
  • Entfernen Sie alte oder ungültige Symbole unter <Silk Central deploy folder>\wwwroot\silkroot\img\PluginIcons, da die Symbole andernfalls im Stammverzeichnis des Plug-Ins nicht durch die neuen Symbole ersetzt werden.
  • Das Symbol hat eine Größe von 16x16 Pixel.
  • Maximal sind 256 Farben für Symbole zulässig.
  • Das Symbol beinhaltet 1 Bit für die Transparenz.
Übergeordnetes Thema: Integration von Drittanbieter-Testtypen


Testumgebung

Das ZIP-Archiv mit dem Plug-In muss sich im Unterverzeichnis Plugins im Installationsverzeichnis von Silk Central befinden. Um Plug-Ins zu integrieren, die sich in diesem Verzeichnis befinden, starten Sie den Anwendungsserver und den Front-End-Server mithilfe von Silk Central Service Manager neu.
Anmerkung: Andere Integrationsverfahren werden nicht unterstützt.

Immer wenn ein Archiv geändert wird, müssen diese beiden Server neu gestartet werden. Das Archiv wird automatisch zu den Ausführungsservern hochgeladen.

Anmerkung: Entfernen Sie niemals ein Plug-In-Archiv, nachdem ein auf diesem Plug-In basierender Test erstellt wurde. Ein Test, der auf einem nicht mehr vorhandenen Plug-In-Archiv beruht, löst bei Änderung oder Ausführung unbekannte Fehler aus.
Übergeordnetes Thema: Integration von Drittanbieter-Testtypen


Angeben von Start und Ende von Videoaufnahmen

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Wenn Sie für Silk Central ein neues Drittanbieter-Test-Plug-In erstellen, das einen Drittanbieter-Testtyp zur Unterstützung mehrerer Testfälle in einer einzelnen Testausführung enthält, und Sie aufgezeichnete Videos zu bestimmten Testfällen zuordnen möchten, dann stehen Ihnen zwei Möglichkeiten zur Verfügung.

Drittanbieter-Tests, die in dem Plug-In ausgeführt werden

Für diese Tests empfehlen wir die Verwendung der Methoden indicateTestStart und indicateTestStop der Klasse TestLaunchResultDrain.

Drittanbieter-Tests, die in einem externen Prozess ausgeführt werden

Für diese Tests können Sie einen TCP/IP-basierten Dienst zum Senden von START- und FINISH-Meldungen an den Port des Silk Central-Ausführungsservers verwenden. Die zu verwendende Portnummer kann von ExecutionContextInfo.ExecProperty#PORT_TESTCASE_START_FINISH im Plug-In abgefragt werden. Der Port ist auch als Umgebungsvariable #sctm_portTestCaseStartFinish im Testprozess verfügbar, wenn das Plug-In ExtProcessTestLaunchBean erweitert. Anhand dieser Meldungstypen wird der Ausführungsserver informiert, dass ein Testfall in dem Test begonnen oder beendet wurde. Die Meldungen müssen im Unicode- (UTF8) oder ASCII-Format verschlüsselt sein.
Meldungstyp
Format
START
START <Test Name>, <Test ID> <LF>, wobei LF den ASCII-Code 10 hat.
FINISH
FINISH <Test Name>, <Test ID>, <Passed> LF, wobei LF den ASCII-Code 10 hat. Passed kann True oder False sein. Wenn die Videoaufzeichnung so eingestellt ist, dass sie Im Fehlerfall ausgeführt wird, wird das Video nur im Ergebnis gespeichert, wenn Passed auf Falsch gesetzt ist.

Wenn die Anfrage erkannt wurde, gibt der Ausführungsserver die Meldung OK zurück; andernfalls gibt er eine Fehlermeldung aus. Warten Sie immer erst die Reaktion des Ausführungsservers ab, bevor Sie den nächsten Testfall ausführen, da das aufgezeichnete Video und der tatsächliche Testfall sich sonst möglicherweise nicht entsprechen.

Basiert der externe Prozess, in dessen Rahmen der Test ausgeführt wird, auf einer Java-Umgebung, empfehlen wir die Verwendung der Methoden indicateTestStart und indicateTestStop der Klasse TestCaseStartFinishSocketClient, die in der Datei tm-testlaunchapi.jar enthalten ist.

Übergeordnetes Thema: Integration von Drittanbieter-Testtypen
Zugehörige Konzepte
Videoaufnahme


Cloud Integration

Silk Central ermöglicht die Integration mit Anbietern von öffentlichen oder privaten Cloud Services, indem Cloud Profile konfiguriert werden. Cloud Profile basieren auf einem Plug-in Konzept, welches Ihnen die Möglichkeit bietet Ihr eigenes Plug-in für einen bestimmten Cloud Anbieter zu entwickeln. Ein Cloud-Anbieter Plug-in richtet vor jedem automatisierten Testlauf eine virtuelle Umgebung ein.
Anmerkung: Die Cloud API wird voraussichtlich in einer zukünftigen Version von Silk Central Änderungen erhalten. Wenn Sie diese API verwenden, kann die Aktualisierung auf eine zukünftige Version von Silk Central bedeuten, dass Sie Ihre Plug-in Implementation anpassen müssen.

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Die Basisschnittstelle ist CloudProviderProfile (com.segue.scc.published.api.cloud). Die Schnittstelle CloudProviderProfile spezifiziert den Zugang und den Umgang mit einem externen Cloud-System. Die Implementation eines Cloud-Anbieter Plug-Ins soll folgendes erreichen:
  • Aufzeigen, welche Eigenschaften in einem Cloud-Anbieter-Profil konfiguriert werden müssen, um von extern auf einen Anbieter dieses Typs zugreifen zu können.
  • Validieren von Profileigenschaften und Überprüfung der Verbindung zum Cloud-Anbieter.
  • Eine Liste verfügbarer Image-Vorlagen vom Cloud-Anbieter beziehen.
  • Einrichten einer virtuellen Umgebung, basierend auf der ausgewählten Image-Vorlage, und aufzeigen der extern erreichbaren Hostadressen.
  • Überprüfen, ob eine virtuelle Umgebung eingerichtet und am Laufen ist.
  • Löschen einer bestimmten virtuellen Umgebung.
Übergeordnetes Thema: API-Hilfe
Zugehörige Konzepte
Cloud Integration
Erstellen von Plug-Ins
Zugehörige Tasks
Konfigurieren von Ausführungsservern in der Cloud


Silk Central-Webdienste

Webdienste erfordern keine besonderen Einstellungen. Sie werden auf jedem Front-End-Server standardmäßig aktiviert. Wenn z. B. http://www.yourFrontend.com/login der URL ist, über den Sie auf Silk Central zugreifen, sind http://www.yourFrontend.com/Services1.0/jaxws/system (Legacy-Dienste auf http://www.yourFrontend.com/Services1.0/services) und http://www.yourFrontend.com/AlmServices1.0/services die Basis-URLs für den Zugriff auf die verfügbaren Webdienste.

Wenn Sie mit Ihrem Browser auf den Basis-URL zugreifen, wird eine einfache HTML-Liste aller verfügbaren Webdienste angezeigt. Diese Liste wird von JAX-WS bereitgestellt. Silk Central verwendet den SOAP-Stack https://jax-ws.java.net/.

Der Basis-URL stellt Links zu XML-Dateien im WSDL (Web Service Definition Language)-Standard bereit, wobei jede Datei die Schnittstelle eines bestimmten Webdienstes beschreibt. Diese Dateien sind nur für Programme verständlich. Deshalb lesen SOAP-fähige Mandanten (z. B. Silk Performer Java Explorer) WSDL Dateien, wodurch Informationen abgerufen werden, die erforderlich sind, um Methoden der entsprechenden Webdienste aufzurufen.

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Anmerkung: Die vor Version 2008 in Silk Central implementierten Original-Webdienste sind weiterhin unter http://hostname:port/services verfügbar.

  • Webdienste – Kurzanleitung
    Enthält Voraussetzungen, ein Anwendungsfallbeispiel und weitere Themen zur Integration von Webdiensten.
  • Sitzungen
    Erläutert, wie die Authentifizierung über Webdienste eine Sitzungs-ID zurückgibt und auf eine Sitzung verweist.
  • Verfügbare Webdienste
    Führt die verfügbaren Webdienste auf.
  • Services Exchange
    Dieser Abschnitt erläutert die HTTP-basierten Schnittstellen, die für Berichte, Anhänge, Testpläne, Ausführungen und Bibliotheken in Services Exchange zuständig sind.
  • Demo Client für Webdienste
    Beschreibt den Demo Client für Webdienste. Mit diesem Tool kann die Verwendung von Silk Central-Webdiensten vorgeführt werden.
Übergeordnetes Thema: API-Hilfe


Webdienste – Kurzanleitung

Dieser Abschnitt enthält Voraussetzungen, ein Anwendungsfallbeispiel und weitere Themen zur Integration von Webdiensten.

  • Voraussetzungen
    Erläutert im Einzelnen, was Sie vor dem Entwickeln eines Webdienst-Clients wissen sollten.
  • Einführung in Webdienste
    Erläutert, wie die Webdienstbibliothek heruntergeladen wird, JAR-Archive entpackt werden und nach der automatisch generierten Java-Klasse YourWebService gesucht wird.
  • Webdienst-Client – Übersicht
    Enthält eine Übersicht über das Erstellen eines Webdienst-Clients mit SOAP-Paketen, WSDL und dem Tool WSDL2Java.
  • Anwendungsfallbeispiel: Hinzufügen einer Anforderung
    Aufbauend auf den vorausgehenden Schritten dieses Abschnitts schließt dieses Thema den Anwendungsfall "Eine Anforderung zu Silk Central hinzufügen" ab.
Übergeordnetes Thema: Silk Central-Webdienste


Voraussetzungen

Bevor Sie versuchen, Webdienst-Clients zu erstellen, sollten Sie die folgenden Voraussetzungen erfüllen:

  • Sie benötigen grundlegende Kenntnisse in der objektorientierten Programmierung (OOP). Erfahrung mit Java ist hilfreich, da die Beispiele in dieser Sprache vorliegen. Für Entwickler ohne Java-Kenntnisse, aber mit Erfahrung in C++, C#, Python oder Perl sollten die Beispiele kein Problem darstellen. Erfahrungen im Umgang mit Collections wie HashMaps und Listen sind von Vorteil.
  • Gelegentlich werden JUnit-Tests erwähnt. Diese Java-Testumgebung ist nicht erforderlich, aber hilfreich.
  • Einige praktische Kenntnisse der Webdienst-Technologie sollten vorhanden sein. Diese Hilfe stellt keinen Lehrgang über Webdienste oder SOAP dar. Der Leser sollte jedoch zumindest einen "Hello World!"-Webdienst-Client programmiert und erfolgreich ausgeführt haben.
  • Machen Sie sich mit der Webdienst-Architektur von Silk Central vertraut.
Übergeordnetes Thema: Webdienste – Kurzanleitung
Zugehörige Konzepte
Silk Central-Webdienste


Einführung in Webdienste

Stellen Sie anhand der Silk Central Versionshinweise sicher, dass Sie die geeignete Java SDK-Version installiert und in die PATH-Variable aufgenommen haben.

Hilfreich ist auch das JUnit-Archiv im Klassenpfad. Sie können die Datei JUnit.jar von http://www.junit.org/index.htm herunterladen.

  1. Stellen Sie sicher, dass der bin-Ordner des Java SDK in Ihrem PATH eingetragen ist.
  2. Führen Sie den folgenden Befehl aus, der auf die WSDL des gewünschten Webdienstes zeigt:
    wsimport -s <Pfad wo die generierten Dateien gespeichert werden sollen> -Xnocompile
-p <Paketstruktur die Sie für Ihren yourWebService-Client verwenden möchten>
http://<URL zu Ihrem Dienst>/yourWebService?wsdl
  3. Suchen Sie nach der automatisch generierten Java-Klasse YourWebService. Diese Klasse ist bereits einsatzfähig und kann jede Methode ausführen, die YourWebService bereitstellt.
Übergeordnetes Thema: Webdienste – Kurzanleitung


Webdienst-Client – Übersicht

Webdienste verwenden normalerweise SOAP anstelle des HTTP-Protokolls. In einem solchen Szenario werden SOAP-Pakete gesendet. Wenn Collections und andere komplexe Objekte in SOAP-Paketen gebündelt werden, ist es kaum möglich, die ASCII-Datenstrukturen zu lesen und zu bearbeiten. Unerfahrene Entwickler sollten nicht versuchen, einen Webdienst-Client durch direkte Bearbeitung von SOAP-Paketen zu erstellen. Erfahrene Entwickler erstellen normalerweise keine Webdienst-Clients auf SOAP-Paket-Ebene. Ein solches Vorgehen wäre mühsam und fehleranfällig. Aus diesem Grund stellen alle wichtigen Programmiersprachen Entwicklungs-Kits für Webdienste bereit. In Silk Central wird Java API for XML Web Services (JAX-WS) zur Erstellung von Webdiensten und Clients verwendet, die über SOAP-Nachrichten kommunizieren.

Unabhängig von der Programmiersprache (Java, C++, C#, Perl oder Python) folgt die Erstellung von Webdienst-Clients einem immer gleichen Muster:

  1. Weisen Sie einem Entwicklungs-Kit die Webdienst-WSDL zu.
  2. Ermitteln Sie einen Client-Rumpf.
  3. Bearbeiten Sie den in Schritt 2 generierten Client-Rumpf so, dass Sie einen funktionsfähigen Client erhalten.
JAX-WS folgt diesem Muster. In unseren Beispielen wird das Tool wsimport (im JDK enthalten) verwendet, um Client-Rümpfe aus der WSDL zu erstellen.Weitere Informationen über die Verwendung von wsimport finden Sie auf JDK Tools and Utilities documentation. In der obigen Übersicht werden folgende Schalter verwendet:
  • -s: Das Ausgabeverzeichnis der Client-Rümpfe
  • -p: Das Zielpaket. In dieser Paketstruktur einsetzen

Beispiel: wsimport -s <Standort der generierten Stubs> -p <Zielpaket> <WSDL>

Das Tool wsimport generiert mehrere Klassen, die einen Client für den Webdienst unterstützen. Wenn der Name des Dienstes YourWebService ist, werden die folgenden Klassen ausgegeben:

  • YourWebService: Eine Schnittstelle, die YourWebService repräsentiert.
  • YourWebServiceService: Eine generierte Klasse, die den Locator YourWebService repräsentiert, z.B. um eine Liste der verfügbaren Ports zu erhalten (Service-Endpunkt-Schnittstellen)
  • WSFaultException: Eine Ausnahme-Klasse, die aus wsdl:fault abgebildet wird
  • WsFaultBean: Asynchrones Antwort-Bean, abgeleitet von wsdl:message
  • Serializeable Objects: Objekte auf Seiten des Clients, die Objekten entsprechen, die YourWebService verwendet.

Erstellen Sie eine neue Java-Klasse namens YourWebServiceClient, um einen JAX-WS-Client zu generieren, mit dem Silk Central-Webdienste verwendet werden können. Der Webdienst muss durch einen Port gebunden werden; ein Port ist ein logisches Objekt, das als Proxy für den Remote-Dienst auftritt. Beachten Sie, dass der Port durch die Ausführung des wsimport-Tools im oberen Schritt erstellt wurde. Um diesen Proxy zu erhalten, rufen Sie die Methode getRequirementsServicePort auf dem Dienst auf:

// Bind to the Requirements service
  RequirementsServiceService port = new RequirementsServiceService
    (new URL("http", mHost, mPort, "/Services1.0/jaxws/requirements?wsdl"));
  RequirementsService requirementsService = port.getRequirementsServicePort();

Danach können Sie die Methode logonUser des Dienstes aufrufen, indem Sie Benutzername und Kennwort übergeben, um eine Sitzungs-ID zu erhalten:

// Login to Silk Central and get session ID
  String sessionId = requirementsService.logonUser(mUsername, mPassword);
Übergeordnetes Thema: Webdienste – Kurzanleitung


Anwendungsfallbeispiel: Hinzufügen einer Anforderung

Aufbauend auf den vorausgehenden Schritten dieses Abschnitts schließt dieses Thema den Anwendungsfall "Eine Anforderung zu Silk Central hinzufügen" ab.

Bevor Sie fortfahren, müssen Sie die folgenden Voraussetzungen erfüllt haben:

  • Sie haben die Schritte für den Webdienst requirements abgeschlossen.
  • Eine funktionierende POJO- oder JUnit-Klasse mit Bindungs- und Anmeldemethoden wurde erstellt.
  • Sie haben die anderen Silk Central-API-Hilfethemen gelesen.
  1. Stellen Sie mit Hilfe der Anmeldemethode mit Benutzerinformationen die Bindung zum Dienst her.
  2. Speichern Sie die Sitzungs-ID aus vorherigen Schritt.
  3. Konstruieren Sie ein Anforderungsobjekt, das die gewünschten Daten enthält.
  4. Rufen Sie die Methode updateRequirement mit der Sitzungs-ID, der Projekt-ID und dem Anforderungsobjekt auf, das Sie generiert haben.
  5. Speichern Sie die von der Methode updateRequirement zurückgegebene Anforderungs-ID.
  6. Erstellen Sie ein PropertyValue-Array mit den Anforderungseigenschaften.
  7. Rufen Sie die Methode updateProperties mit dem zuvor erzeugten Array auf.
wsimport erstellt die genannten Webdienst-Objekte:
  • Requirement
  • PropertyValue

Die OOP-Methoden der genannten Objekte können nun verwendet werden, um den Webdienst in Anspruch zu nehmen. Das umständliche Zusammenstellen von SOAP-Paketen ist dadurch überflüssig. Im Folgenden finden Sie Auszüge aus dem Code, der benötigt wird, um den Testfall auszuführen.

/** project ID of Silk Central project */
private static final int PROJECT_ID = 0;

/** propertyID for requirement risk */
public static final String PROPERTY_RISK = "Risk";

/** propertyID for requirement reviewed */
public static final String PROPERTY_REVIEWED = "Reviewed";

/** propertyID for requirement priority */
public static final String PROPERTY_PRIORITY = "Priority";

/** propertyID for requirement obsolete property */
public static final String PROPERTY_OBSOLETE = "Obsolete";

// Get the Requirements service
RequirementsService service = getRequirementsService();

// Login to Silk Central
String sessionId = login(service);

// Construct Top Level Requirement
Requirement topLevelRequirement = new Requirement();
topLevelRequirement.setName("tmReqMgt TopLevelReq");
topLevelRequirement.setDescription("tmReqMgt TopLevel Desc");

PropertyValue propRisk = new PropertyValue();
propRisk.setPropertyId(PROPERTY_RISK);
propRisk.setValue("2");
PropertyValue propPriority = new PropertyValue();
propPriority.setPropertyId(PROPERTY_PRIORITY);
propPriority.setValue("3");
PropertyValue[] properties = new PropertyValue[] {propRisk, propPriority};

/*
* First add requirement skeleton, get its ID
* service is a binding stub, see above getRequirementsService() snippet
* sessionId is the stored session ID, see above login() snippet
*/
int requirementID = service.updateRequirement(sessionId, PROJECT_ID, topLevelRequirement, -1);

// Now loop through and set properties
for (PropertyValue propValue : properties) {
propValue.setRequirementId(requirementID);
service.updateProperty(sessionId, requirementID, propValue);
}

// Add Child Requirement
Requirement childRequirement = new Requirement();
childRequirement.setName("tmReqMgt ChildReq");
childRequirement.setDescription("tmReqMgt ChildLevel Desc");
childRequirement.setParentId(requirementID);
propRisk = new PropertyValue();
propRisk.setPropertyId(PROPERTY_RISK);
propRisk.setValue("1");
propPriority = new PropertyValue();
propPriority.setPropertyId(PROPERTY_PRIORITY);
propPriority.setValue("1");
properties = new PropertyValue[] {propRisk, propPriority};

int childReqID = service.updateRequirement(sessionId, PROJECT_ID, childRequirement, -1);

// Now loop through and set properties
for (PropertyValue propValue : properties) {
propValue.setRequirementId(requirementID);
service.updateProperty(sessionId, childReqID, propValue);
}

// Print Results
System.out.println("Login Successful with mSessionID: " + sessionId);
System.out.println("Top Level Requirement ID: " + requirementID);
System.out.println("Child Requirement ID: " + childReqID);
Anmerkung: Diesen Beispliel-Code finden Sie auch in der Klasse com.microfocus.silkcentral.democlient.samples.AddingRequirement des „Web Services Demo-Client'“.
Übergeordnetes Thema: Webdienste – Kurzanleitung


Sitzungen

Silk Central-Daten sind gegen unberechtigten Zugriff geschützt. Bevor der Zugriff auf Daten erlaubt wird, müssen Anmeldeinformationen vorgelegt werden. Dies gilt nicht nur für die Arbeit mit dem HTML-Front-End, sondern auch für die Kommunikation mit Silk Central über SOAP-Aufrufe.

Der erste Schritt beim Abfragen von Daten oder beim Ändern der Konfigurationseinstellungen von Silk Central besteht daher in der Authentifizierung. War die Authentifizierung erfolgreich, wird eine Benutzersitzung generiert, die die Ausführung der nachfolgenden Operationen im Kontext dieser Anmeldung erlaubt.

Wenn auf Silk Central über einen Webbrowser zugegriffen wird, sind die Sitzungsinformationen für den Benutzer nicht sichtbar. Der Browser verwaltet Sitzungsinformationen über Cookies. Im Gegensatz zum Zugriff auf Silk Central über HTML müssen SOAP-Aufrufe diese Sitzungsinformationen manuell verwalten.

Die Authentifizierung über Webdienste erfolgt durch den SOAP-Aufruf logonUser des benötigten Webdienstes. Der Methodenaufruf gibt eine Sitzungs-ID zurück, die zur Identifizierung der auf dem Server generierten Sitzung und zugleich als Schlüssel für den Zugriff auf Silk Central im Kontext dieser Sitzung dient.

Jeder nachfolgende SOAP-Aufruf, der eine Sitzung zur Ausführung benötigt, übernimmt eine zurückgegebene ID als Parameter, prüft ihre Gültigkeit und wird im Kontext der entsprechenden Sitzung ausgeführt.

Das folgende Java-Codebeispiel zeigt einen einfachen Zugriff auf Silk Central über Webdienste sowie die Verwendung der Sitzungs-ID:
long sessionID = systemService.logonUser("admin", "admin");
Project[] projects = sccentities.getProjects(sessionID);

Silk Central-Sitzungen, die über Webdienste generiert werden, können nicht explizit beendet werden. Sie enden stattdessen automatisch, wenn sie für einen bestimmten Zeitraum nicht benutzt werden. Nachdem eine Sitzung durch ein Timeout auf dem Server beendet wurde, lösen nachfolgende SOAP-Aufrufe beim Versuch, auf die Sitzung zuzugreifen, eine Ausnahme aus.

Eine Demo-Anwendung können Sie in Silk Central unter Hilfe > Tools > Web Services Demo-Client herunterladen. Dieses Demoprojekt verwendet den tests-Webdienst von Silk Central, der Sie beim Kennenlernen der Webdienst-Schnittstelle unterstützt.

Übergeordnetes Thema: Silk Central-Webdienste


Verfügbare Webdienste

Die folgende Tabelle zeigt die verfügbaren Silk Central-Webdienste. Sie können auf Silk Central auch über HTTP-basierte Schnittstellen zugreifen.. Weitere Informationen finden Sie unter Services Exchange.

Anmerkung: Unter der WSDL-URL finden Sie auch systeminterne Webdienste, die sich nicht zum Erstellen von Webdienst-Mandanten eignen. In diesem Dokument werden nur die öffentlichen Webdienste beschrieben.

Einzelheiten über die verfügbaren Java-Klassen und -Methoden finden Sie in Javadoc. Wenn der Link nicht funktioniert, klicken Sie im Silk Central-Menü auf Hilfe > Dokumentation > Silk Central API Spezifikation, um Javadoc zu öffnen.

Anmerkung: Bei Verwendung von Webdiensten werden Zeiten vom System stets in der koordinierten Weltzeit (UTC) zurückgegeben. Geben Sie alle Zeiten in den verwendeten Webdiensten ebenfalls in UTC-Notation an.
Name des Webdiensts (Schnittstelle) | WSDL-URL | Beschreibung
system (SystemService) | /Services1.0/jaxws/system?wsdl | Der Stammdienst, der für die Authentifizierung sorgt und einfache Dienstmethoden bereitstellt.
administration (AdministrationService) | /Services1.0/jaxws/administration?wsdl | Dieser Dienst ermöglicht den Zugriff auf die Entitäten Projekt und Produkt von Silk Central.
requirements (RequirementsService) | /Services1.0/jaxws/requirements?wsdl | Dieser Dienst ermöglicht den Zugriff auf den Bereich Anforderungen von Silk Central.
tests (TestsService) | /Services1.0/jaxws/tests?wsdl | Dieser Dienst ermöglicht den Zugriff auf den Bereich Tests von Silk Central.
executionplanning (ExecutionPlanningService) | /Services1.0/jaxws/executionplanning?wsdl | Dieser Dienst ermöglicht den Zugriff auf den Bereich Ausführungsplanung von Silk Central.
filter (FilterService) | /Services1.0/jaxws/filter?wsdl | Dieser Dienst ermöglicht das Erstellen, Lesen, Aktualisieren und Löschen von Filtern.
issuemanager (IssueManagerService) | /Services1.0/jaxws/issuemanager?wsdl | Dieser Dienst ermöglicht den Zugriff auf Issue Manager.
Übergeordnetes Thema: Silk Central-Webdienste


Services Exchange

Dieser Abschnitt erläutert die HTTP-basierten Schnittstellen, die für Berichte, Anhänge, Testpläne, Ausführungen und Bibliotheken in Services Exchange zuständig sind.

Sie können auf Silk Central auch über Webdienste zugreifen. Weitere Informationen finden Sie unter Verfügbare Webdienste.

Anmerkung: Bei Verwendung von Webdiensten werden Zeiten vom System stets in der koordinierten Weltzeit (UTC) zurückgegeben. Geben Sie alle Zeiten in den verwendeten Webdiensten ebenfalls in UTC-Notation an.
  • reportData-Schnittstelle
    Führt die Parameter der Schnittstelle reportData auf. Über die Schnittstelle reportData werden die Daten eines Berichts angefordert.
  • TMAttach-Schnittstelle
    Führt die Parameter der Schnittstelle TMAttach auf.
  • Schnittstelle createTestPlan
    Führt die Parameter der Schnittstelle createTestPlan auf.
  • Schnittstelle exportTestPlan
    Führt die Parameter der Schnittstelle exportTestPlan auf.
  • Schnittstelle updateTestPlan
    Führt die Parameter der Schnittstelle updateTestPlan auf.
  • Schnittstelle createRequirements
    Führt die Parameter der Schnittstelle createRequirements auf.
  • Schnittstelle exportRequirements
    Führt die Parameter der Schnittstelle exportRequirements auf.
  • Schnittstelle updateRequirements
    Führt die Parameter der Schnittstelle updateRequirements auf.
  • Schnittstelle updateRequirementsByExtID
    Führt die Parameter der Schnittstelle updateRequirementsByExtID auf.
  • Schnittstelle createExecutionDefinitions
    Führt die Parameter der Schnittstelle createExecutionDefinitions auf.
  • Schnittstelle exportExecutionDefinitions
    Führt die Parameter der Schnittstelle exportExecutionDefinitions auf.
  • Schnittstelle updateExecutionDefinitions
    Führt die Parameter der Schnittstelle updateExecutionDefinitions auf.
  • Schnittstelle createLibraries
    Führt die Parameter der Schnittstelle createLibraries auf.
  • Schnittstelle exportLibraryStructure
    Führt die Parameter der Schnittstelle exportLibraryStructure auf.
  • Schnittstelle exportLibraryStructureWithoutSteps
    Führt die Parameter der Schnittstelle exportLibraryStructureWithoutSteps auf.
  • Schnittstelle getLibraryInfoByName
    Führt die Parameter der Schnittstelle getLibraryInfoByName auf.
Übergeordnetes Thema: Silk Central-Webdienste


reportData-Schnittstelle

Über die Schnittstelle reportData werden die Daten eines Berichts angefordert. Die folgende Tabelle enthält die Parameter der Schnittstelle reportData.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=reportData | sid | Sitzungs-ID: Benutzer-Authentifizierung
 | reportFilterID | ID des Berichtsfilters
 | type | Format des Antwortrumpfs: (csv oder xml)
 | includeHeaders | Berichtskopfzeilen einschließen. (true oder false)
 | userName | (Optional) Benutzername: Anstelle von sid verwendet
 | passWord | (Optional) Kennwort: Anstelle von sid verwendet
 | projectID | Die eindeutige Kennung des Projekts

Beispiel: http://<front-end URL>/servicesExchange?hid=reportData&reportFilterID=<id>&type=<csv or xml>&includeHeaders=<true or false>&userName=<user>&passWord=<password>&projectID=<id>

Beispiel für die reportData-Schnittstelle

String reportID = "<id>";
   String user = "<user>";
   String pwd = "<pwd>";
   String host = "<any_host>";

    URL report = new URL("http", host, 19120,
    "/servicesExchange?hid=reportData" +
     "&type=xml" + // or csv
     "&userName=" + user +
     "&passWord=" + pwd +
     "&reportFilterID=" + reportID +
     "&includeHeaders=true" +
     "&rp_execNode_Id_0=1" +
     "&projectID=27);

   BufferedReader in = new BufferedReader(new InputStreamReader(report.openStream(), "UTF-8"));

   StringBuilder builder = new StringBuilder();
   String line = "";

   while ((line = in.readLine()) != null) {
       builder.append(line + "\n");
   }

   String text = builder.toString();
   System.out.println(text);
 }
Falls für den Bericht Parameter benötigt werden, müssen Sie den folgenden Code für jeden Parameter zu der URL des Berichts hinzufügen:
 "&rp_parametername=parametervalue"
In diesem Beispiel ist der Parameter rp_execNode_Id_0 auf den Wert 1 gesetzt.
Anmerkung: Den Namen von Parametern, die an den Dienst reportData übergeben werden, muss die Zeichenfolge rp_ vorangestellt werden. Beispiel: /servicesExchange?hid=reportData&type=xml&sid=<...>&reportFilterID=<...>&projectID=<...>&rp_TestID=<...>
Übergeordnetes Thema: Services Exchange


TMAttach-Schnittstelle

Über die Schnittstelle TMAttach werden Anhänge zu einer Test oder Anforderung hochgeladen. Die folgende Tabelle enthält die Parameter der Schnittstelle TMAttach.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=TMAttach | sid | Sitzungs-ID: Benutzer-Authentifizierung
 | entityType | Typ der Zielentität: (Test, Anforderung oder TestStepParent)
 | entityID | ID der Zielentität: (Test-ID, Anforderungs-ID oder ID des manuellen Tests)
 | description | Beschreibung des Anhangs. URL-codierter Text, der den Anhang beschreibt.
 | isURL | Bei true ist der Anhang ein URL. Bei false ist der Anhang eine Datei.
 | URL | Optional - Anzuhängender URL.
 | stepPosition | Optional – Der Name des Testschritts. Bezeichnet den Schritt eines manuellen Tests (z. B. 1 für den ersten Schritt). Die Reihenfolge ist obligatorisch, wenn entityType den Wert TestStepParent hat.
 | userName | (Optional) Benutzername: Anstelle von sid verwendet
 | passWord | (Optional) Kennwort: Anstelle von sid verwendet

Beispiel: http://<front-end URL>/servicesExchange?hid=TMAttach&entityType=<test, requirement, or TestStepParent>&entityID=<id>&description=<text>&isURL=<true or false>&URL=<URL>&stepPosition=<number>&userName=<user>&passWord=<password>

Beispiel für den Webdienst TMAttach

Der folgende Quelltext ruft zum Hochladen eines binären Anhangs mit Apache HtmlClient eine geeignete HTTP-POST API ab. Pro Anfrage kann nur ein Anhang hochgeladen werden.

Pro Anfrage kann nur ein Anhang hochgeladen werden. Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

import org.apache.commons.httpclient.*; // Apache HttpClient

    String sessionID = null;
    String testNodeID = null; // receiving test
    File fileToUpload = null; // attachment
    String AttachmentDescription = ""; // descriptive text

    HttpClient client = new HttpClient();
    String formURL = "http://localhost:19120/
        servicesExchange?hid=TMAttach" +
        "&sid=" + sessionID +
        "&entityID=" + testNodeID +
        "&entityType=Test" +
        "&isURL=false";
    PostMethod filePost = new PostMethod(formURL);
    Part[] parts = {
        new StringPart("description", attachmentDescription),
        new FilePart(fileToUpload.getName(), fileToUpload)
    };
    filePost.setRequestEntity(new MultipartRequestEntity(parts,
        filePost.getParams()));
    client.getHttpConnectionManager().
        getParams().setConnectionTimeout(60000);
    // Execute and check for success
    int status = client.executeMethod(filePost);
    // verify http return code...
    // if(status == httpStatus.SC_OK) ...
Übergeordnetes Thema: Services Exchange


Schnittstelle createTestPlan

Über die Schnittstelle createTestPlan werden neue Tests erstellt. Die HTTP-Antwort des Aufrufs enthält die XML-Struktur der geänderten Tests. Sie können die Kennungen der neuen Knoten der aktualisierten XML-Teststruktur entnehmen.

Die folgende Tabelle enthält die Parameter der Schnittstelle createTestPlan.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=createTestPlan | sid | Sitzungs-ID – Benutzerauthentifizierung
 | parentNodeID | ID des Containers, dem der neue Test in der Testhierarchie hinzugefügt wird.
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=createTestPlan&parentNodeID=<id>&userName=<user>&passWord=<password>

Die Definitionsdatei für das XML-Schema, mit der überprüft wird, ob Testpläne über den URL des Front-End-Servers http://<Host>/silkroot/xsl/testplan.xsd heruntergeladen oder aus dem Installationsordner <Silk Central-Installationsordner>/wwwroot/silkroot/xsl/testplan.xsd des Front-End-Servers kopiert werden können.

Beispiel für den Webdienst createTestPlan

Im folgenden Quelltext werden die Tests mithilfe von Apache HttpClient erstellt.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createTestPlan", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadTestPlanUtf8("testPlan.xml");
StringPart xmlFileItem = new StringPart("testPlan", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

Pro Anfrage kann nur ein Anhang hochgeladen werden. Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Testbeispiel

Der folgende Code zeigt ein Beispiel eines Tests, der mithilfe des Dienstes Silk Central undcreateTestPlan in updateTestPlan hochgeladen werden kann.

  <TestPlan xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/testplan.xsd">

  <Folder name="Folder1" id="5438">
    <Description>Description of the folder</Description>
    <Property name="property1">
      <propertyValue>value1</propertyValue>
    </Property>
    <Test name="TestDef1" type="plugin.SilkTest">
      <Description>Description of the test</Description>
      <Property name="property2">
        <propertyValue>value2</propertyValue>
      </Property>
      <Property name="property3">
           <propertyValue>value3</propertyValue>
           <propertyValue>value4</propertyValue>
      </Property>
      <Parameter name="param1" type="string">string1</Parameter>
      <Parameter name="param2" type="boolean">true</Parameter>
                        <Parameter name="paramDate" type="date">01.01.2001</Parameter>
      <Parameter name="paramInherited" type="string"
        inherited="true">
        inheritedValue1
      </Parameter>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
    </Test>
    <Test name="ManualTest1" id="5441" type="_ManualTestType"
      plannedTime="03:45">
      <Description>Description of the manual test</Description>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
      <Step id="3" name="StepC">
        <ActionDescription>do it now"</ActionDescription>
        <ExpectedResult>
          everything should come as you wish
        </ExpectedResult>
      </Step>
    </Test>
    <Folder name="Folder2" id="5439">
      <Description>Description of the folder</Description>
      <Property name="property4">
        <propertyValue>value5</propertyValue>
      </Property>
      <Parameter name="param3" type="number">123</Parameter>
      <Folder name="Folder2_1" id="5442">
        <Description>Description of the folder</Description>
        <Test name="TestDef2" type="plugin.SilkPerformer">
          <Description>Description of the test</Description>
          <Property name="_sp_Project File">
            <propertyValue>ApplicationAccess.ltp</propertyValue>
          </Property>
          <Property name="_sp_Workload">
            <propertyValue>Workload1</propertyValue>
          </Property>
        </Test>
        <Test name="TestDef3" type="JUnitTestType"
          externalId="com.borland.MyTest">
          <Description>Description of the test</Description>
          <Property name="_junit_ClassFile">
            <propertyValue>com.borland.MyTest</propertyValue>
          </Property>
          <Property name="_junit_TestMethod">
            <propertyValue>testMethod</propertyValue>
          </Property>
          <Step id="1" name="StepA">
            <ActionDescription>do it</ActionDescription>
            <ExpectedResult>everything</ExpectedResult>
          </Step>
          <Step id="2" name="StepB">
            <ActionDescription>and</ActionDescription>
            <ExpectedResult>everything should come</ExpectedResult>
          </Step>
        </Test>
      </Folder>
    </Folder>
  </Folder>
</TestPlan>
Übergeordnetes Thema: Services Exchange


Schnittstelle exportTestPlan

Mithilfe der Schnittstelle exportTestPlan werden Testpläne als XML-Dateien exportiert. Die folgende Tabelle enthält die Parameter der Schnittstelle exportTestPlan.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=exportTestPlan | sid | Sitzungs-ID – Benutzerauthentifizierung
 | nodeID | Der Knoten mit dieser ID und rekursiv alle untergeordneten Knoten werden exportiert.
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=exportTestPlan&nodeID=<id>&userName=<user>&passWord=<password>

Beispiel für den Webdienst exportTestPlan

Im folgenden Quelltext werden die Tests mithilfe von Apache HttpClient exportiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportTestPlan", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Übergeordnetes Thema: Services Exchange


Schnittstelle updateTestPlan

Mithilfe der Schnittstelle updateTestPlan werden Tests durch bestehende Stammknoten aus XML-Dateien aktualisiert. Die HTTP-Antwort des Aufrufs enthält die XML-Struktur der geänderten Tests. Sie können die Kennungen der neuen Knoten der aktualisierten XML-Teststruktur entnehmen.

Die folgende Tabelle enthält die Parameter der Schnittstelle updateTestPlan.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=updateTestPlan | sid | Sitzungs-ID – Benutzerauthentifizierung
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=updateTestPlan&userName=<user>&passWord=<password>

Die Definitionsdatei für das XML-Schema, mit der überprüft wird, ob Testpläne über den URL des Front-End-Servers http://<Host>/silkroot/xsl/testplan.xsd heruntergeladen oder aus dem Installationsordner <Silk Central-Installationsordner>/wwwroot/silkroot/xsl/testplan.xsd des Front-End-Servers kopiert werden können.

Beispiel für den Webdienst updateTestPlan

Im folgenden Quelltext werden die Tests mithilfe von Apache HttpClient aktualisiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
String xml = loadTestPlanUtf8(DEMO_TEST_PLAN_XML);
HttpClient client = new HttpClient();

URL webServiceUrl = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateTestPlan",
    sessionID));
StringPart testPlanXml = new StringPart(DEMO_TEST_PLAN_XML, xml,
  "UTF-8");
testPlanXml.setContentType("text/xml");
Part[] parts = {testPlanXml};
PostMethod filePost = new PostMethod(webServiceUrl.toExternalForm());
filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

Pro Anfrage kann nur ein Anhang hochgeladen werden. Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Testbeispiel

Der folgende Code zeigt ein Beispiel eines Tests, der mithilfe des Dienstes Silk Central undcreateTestPlan in updateTestPlan hochgeladen werden kann.

  <TestPlan xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/testplan.xsd">

  <Folder name="Folder1" id="5438">
    <Description>Description of the folder</Description>
    <Property name="property1">
      <propertyValue>value1</propertyValue>
    </Property>
    <Test name="TestDef1" type="plugin.SilkTest">
      <Description>Description of the test</Description>
      <Property name="property2">
        <propertyValue>value2</propertyValue>
      </Property>
      <Property name="property3">
           <propertyValue>value3</propertyValue>
           <propertyValue>value4</propertyValue>
      </Property>
      <Parameter name="param1" type="string">string1</Parameter>
      <Parameter name="param2" type="boolean">true</Parameter>
                        <Parameter name="paramDate" type="date">01.01.2001</Parameter>
      <Parameter name="paramInherited" type="string"
        inherited="true">
        inheritedValue1
      </Parameter>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
    </Test>
    <Test name="ManualTest1" id="5441" type="_ManualTestType"
      plannedTime="03:45">
      <Description>Description of the manual test</Description>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
      <Step id="3" name="StepC">
        <ActionDescription>do it now"</ActionDescription>
        <ExpectedResult>
          everything should come as you wish
        </ExpectedResult>
      </Step>
    </Test>
    <Folder name="Folder2" id="5439">
      <Description>Description of the folder</Description>
      <Property name="property4">
        <propertyValue>value5</propertyValue>
      </Property>
      <Parameter name="param3" type="number">123</Parameter>
      <Folder name="Folder2_1" id="5442">
        <Description>Description of the folder</Description>
        <Test name="TestDef2" type="plugin.SilkPerformer">
          <Description>Description of the test</Description>
          <Property name="_sp_Project File">
            <propertyValue>ApplicationAccess.ltp</propertyValue>
          </Property>
          <Property name="_sp_Workload">
            <propertyValue>Workload1</propertyValue>
          </Property>
        </Test>
        <Test name="TestDef3" type="JUnitTestType"
          externalId="com.borland.MyTest">
          <Description>Description of the test</Description>
          <Property name="_junit_ClassFile">
            <propertyValue>com.borland.MyTest</propertyValue>
          </Property>
          <Property name="_junit_TestMethod">
            <propertyValue>testMethod</propertyValue>
          </Property>
          <Step id="1" name="StepA">
            <ActionDescription>do it</ActionDescription>
            <ExpectedResult>everything</ExpectedResult>
          </Step>
          <Step id="2" name="StepB">
            <ActionDescription>and</ActionDescription>
            <ExpectedResult>everything should come</ExpectedResult>
          </Step>
        </Test>
      </Folder>
    </Folder>
  </Folder>
</TestPlan>
Übergeordnetes Thema: Services Exchange


Schnittstelle createRequirements

Über die Schnittstelle createRequirements werden neue Anforderungen erstellt. Die HTTP-Antwort des Aufrufs enthält die XML-Struktur der geänderten Anforderungen. Sie können die Kennungen der neuen Knoten der aktualisierten XML-Anforderungsstruktur entnehmen.

Die folgende Tabelle enthält die Parameter der Schnittstelle createRequirements.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=createRequirements | sid | Sitzungs-ID – Benutzerauthentifizierung
 | parentNodeID | ID des Containers, dem die neue Anforderung in der Anforderungshierarchie hinzugefügt wird.
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=createRequirements&parentNodeID=<id>&userName=<user>&passWord=<password>

Die Definitionsdatei für das XML-Schema, mit der überprüft wird, ob Anforderungen über den URL des Front-End-Servers http://<Host>/silkroot/xsl/requirements.xsd heruntergeladen oder aus dem Installationsordner <Silk Central-Installationsordner>/wwwroot/silkroot/xsl/requirements.xsd des Front-End-Servers kopiert werden können.

Beispiel für den Webdienst createRequirements

Im folgenden Quelltext werden die Anforderungen mithilfe von Apache HttpClient erstellt.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createRequirements", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadRequirementsUtf8("requirements.xml");
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

Pro Anfrage kann nur ein Anhang hochgeladen werden. Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Anforderungen – Beispiel

Der folgende Code zeigt ein Beispiel einer Anforderung, die mithilfe des Diensts Silk Central,createRequirements undupdateRequirements in updateRequirementsByExtID hochgeladen werden kann.

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
Übergeordnetes Thema: Services Exchange


Schnittstelle exportRequirements

Mithilfe der Schnittstelle exportRequirements werden Anforderungen als XML-Dateien exportiert. Die folgende Tabelle enthält die Parameter der Schnittstelle exportRequirements.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=exportRequirements | sid | Sitzungs-ID – Benutzerauthentifizierung
 | nodeID | Der Knoten mit dieser ID und rekursiv alle untergeordneten Knoten werden exportiert.
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid
 | includeObsolete | Optional: Definieren Sie true oder false. Wird standardmäßig auf true gesetzt, wenn ausgelassen. Definieren Sie false um obsolete Anforderungen auszuschließen.

Beispiel: http://<front-end URL>/servicesExchange?hid=exportRequirements&nodeID=<id>&userName=<user>&passWord=<password>

Beispiel für den Webdienst exportRequirements

Im folgenden Quelltext werden die Anforderungen mithilfe von Apache HttpClient exportiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportRequirements", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedRequirementResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedRequirementResponse);

Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Übergeordnetes Thema: Services Exchange


Schnittstelle updateRequirements

Mithilfe der Schnittstelle updateRequirements werden Anforderungen durch bestehende Stammknoten aus XML-Dateien aktualisiert. Die Anforderungen werden in der Anforderungshierarchie durch die interne Knoten-ID von Silk Central definiert. Der Knoten der Anforderungshierarchie und alle untergeordneten Knoten werden aktualisiert. Neue Knoten werden hinzugefügt und fehlende Knoten als obsolet gekennzeichnet. Verschobene Knoten werden wie in Silk Central verschoben. Die HTTP-Antwort des Aufrufs enthält die XML-Struktur der geänderten Anforderungen. Sie können die Kennungen der neuen Knoten der aktualisierten XML-Anforderungsstruktur entnehmen.

Die folgende Tabelle enthält die Parameter der Schnittstelle updateRequirements.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=updateRequirements | sid | Sitzungs-ID – Benutzerauthentifizierung
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=updateRequirements&userName=<user>&passWord=<password>

Die Definitionsdatei für das XML-Schema, mit der überprüft wird, ob Anforderungen über den URL des Front-End-Servers http://<Host>/silkroot/xsl/requirements.xsd heruntergeladen oder aus dem Installationsordner <Silk Central-Installationsordner>/wwwroot/silkroot/xsl/requirements.xsd des Front-End-Servers kopiert werden können.

Beispiel für den Webdienst updateRequirements

Im folgenden Quelltext werden die Anforderungen mithilfe von Apache HttpClient aktualisiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateRequirements", sessionID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
string xmlFile = loadRequirementsUtf8(fileName);
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

Pro Anfrage kann nur ein Anhang hochgeladen werden. Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Anforderungen – Beispiel

Der folgende Code zeigt ein Beispiel einer Anforderung, die mithilfe des Diensts Silk Central,createRequirements undupdateRequirements in updateRequirementsByExtID hochgeladen werden kann.

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
Übergeordnetes Thema: Services Exchange


Schnittstelle updateRequirementsByExtID

Mithilfe der Schnittstelle updateRequirementsByExtID werden Anforderungen durch bestehende Stammknoten aus XML-Dateien aktualisiert. Die Anforderungen werden durch externe IDs identifiziert. Der Knoten der Anforderungshierarchie und alle untergeordneten Knoten werden aktualisiert. Neue Knoten werden hinzugefügt und fehlende Knoten als obsolet gekennzeichnet. Verschobene Knoten werden wie in Silk Central verschoben. Die HTTP-Antwort des Aufrufs enthält die XML-Struktur der geänderten Anforderungen. Sie können die Kennungen der neuen Knoten der aktualisierten XML-Anforderungsstruktur entnehmen.

Die folgende Tabelle enthält die Parameter der Schnittstelle updateRequirementsByExtID.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=updateRequirementsByExtID | sid | Sitzungs-ID – Benutzerauthentifizierung
 | nodeID | Die ID des zu aktualisierenden Knotens der Anforderungshierarchie.
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=updateRequirementsByExtID&nodeID=<id>&userName=<user>&passWord=<password>

Die Definitionsdatei für das XML-Schema, mit der überprüft wird, ob Anforderungen über den URL des Front-End-Servers http://<Host>/silkroot/xsl/requirements.xsd heruntergeladen oder aus dem Installationsordner <Silk Central-Installationsordner>/wwwroot/silkroot/xsl/requirements.xsd des Front-End-Servers kopiert werden können.

Beispiel für den Webdienst updateRequirementsByExtID

Im folgenden Quelltext werden die Anforderungen mithilfe von Apache HttpClient aktualisiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",&nodeID=%s",
    "updateRequirementsByExtID",
    sessionID, rootNodeId));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
string xmlFile = loadRequirementsUtf8(fileName);
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

Pro Anfrage kann nur ein Anhang hochgeladen werden. Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Anforderungen – Beispiel

Der folgende Code zeigt ein Beispiel einer Anforderung, die mithilfe des Diensts Silk Central,createRequirements undupdateRequirements in updateRequirementsByExtID hochgeladen werden kann.

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
Übergeordnetes Thema: Services Exchange


Schnittstelle createExecutionDefinitions

Über die Schnittstelle createExecutionDefinitions werden neue Testsuiten erstellt. Die HTTP-Antwort des Aufrufs enthält die XML-Struktur der geänderten Testsuiten. Sie können die Kennungen der neuen Knoten der aktualisierten XML-Testsuitestruktur entnehmen.

Die folgende Tabelle enthält die Parameter der Schnittstelle createExecutionDefinitions.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=createExecutionDefinitions | sid | Sitzungs-ID – Benutzerauthentifizierung
 | parentNodeID | ID des Knotens, dem die neue Testsuite in der Testsuitehierarchie hinzugefügt wird.
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=createExecutionDefinitions&parentNodeID=<id>&userName=<user>&passWord=<password>

Die Definitionsdatei für das XML-Schema, mit der überprüft wird, ob Testsuiten über den URL des Front-End-Servers http://<Host>/silkroot/xsl/executionplan.xsd heruntergeladen oder aus dem Installationsordner <Silk Central-Installationsordner>/wwwroot/silkroot/xsl/executionplan.xsd des Front-End-Servers kopiert werden können.

Beispiel für den Webdienst createExecutionDefinitions

Im folgenden Quelltext werden die Testsuiten mithilfe von Apache HttpClient erstellt.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createExecutionDefinitions", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadExecutionDefinitionsUtf8("executionplan.xml");
StringPart xmlFileItem = new StringPart("executionplan", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

Pro Anfrage kann nur ein Anhang hochgeladen werden. Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Testsuite – Beispiel

Der folgende Code zeigt ein Beispiel eines Ausführungsplans, der mithilfe des Diensts Silk Central undcreateExecutionDefinitions in updateExecutionDefinitions hochgeladen werden kann. In diesem Fall wird ein benutzerdefinierter Ausführungstermin für eine der Testsuiten erstellt, und einer Testsuite werden Tests zugeordnet, sowohl manuell als auch mittels Filter. Im Beispiel wird zudem eine Konfigurationssuite mit Konfigurationen erstellt.

<ExecutionPlan xmlns="http://www.borland.com/ExecPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/executionplan.xsd">

  <Folder name="Folder1">
    <Description>Description of the folder</Description>
    <ExecDef name="ExecutionDefinition1" TestContainerId="1">
      <Description>Description1</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <forever>true</forever>
        </end>
        <Interval day="1" hour="2" minute="3"></Interval>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>
      <ReadFromBuildInfoFile>true</ReadFromBuildInfoFile>
      <Priority>High</Priority>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ExecDef>
    <ExecDef name="ExecutionDefinition2" TestContainerId="1">
      <Description>Description2</Description>
      <Build>1</Build>
      <Version>1</Version>
      <Priority>Low</Priority>
      <SourceControlLabel>Label1</SourceControlLabel>
      <DependentExecDef id="65">
        <Condition>Passed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Server" id="1"/>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="70">
        <Condition>Failed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="68">
        <Condition>Any</Condition>
        <Deployment>
          <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
        </Deployment>
      </DependentExecDef>
    </ExecDef>

    <ConfigSuite name="ConfigSuite1" TestContainerId="1">
      <Description>ConfigSuite1 desc</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <times>1</times>
        </end>
        <Interval day="1" hour="2" minute="3"/>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>

      <ConfigExecDef name="Config1">
        <Description>Config1 desc</Description>
        <Priority>Medium</Priority>
      </ConfigExecDef>

      <ConfigExecDef name="Config2">
        <Priority>Medium</Priority>
        <DependentExecDef id="69">
          <Condition>Any</Condition>
          <Deployment>
            <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
          </Deployment>
        </DependentExecDef>
      </ConfigExecDef>

      <Build>8</Build>
      <Version>2</Version>
      <SourceControlLabel>ConfigSuite1 label</SourceControlLabel>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ConfigSuite>
  </Folder>
</ExecutionPlan>
Übergeordnetes Thema: Services Exchange


Schnittstelle exportExecutionDefinitions

Mithilfe der Schnittstelle exportExecutionDefinitions werden Testsuiten als XML-Dateien exportiert. Die folgende Tabelle enthält die Parameter der Schnittstelle exportExecutionDefinitions.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=exportExecutionDefinitions | sid | Sitzungs-ID – Benutzerauthentifizierung
 | nodeID | Der Knoten mit dieser ID und rekursiv alle untergeordneten Knoten werden exportiert.
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=exportExecutionDefinitions&nodeID=<id>&userName=<user>&passWord=<password>

Beispiel für den Webdienst exportExecutionDefinitions

Im folgenden Quelltext werden die Testsuites mithilfe von Apache HttpClient exportiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportExecutionDefinitions", sessionID,
  NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedExecutionPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedExecutionPlanResponse);

Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Übergeordnetes Thema: Services Exchange


Schnittstelle updateExecutionDefinitions

Mithilfe der Schnittstelle updateExecutionDefinitions werden Testsuiten mittels XML-Dateien aktualisiert. Die HTTP-Antwort des Aufrufs enthält die XML-Struktur der geänderten Testsuiten. Sie können die Kennungen der neuen Knoten der aktualisierten XML-Testsuitestruktur entnehmen.

Die folgende Tabelle enthält die Parameter der Schnittstelle updateExecutionDefinitions.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=updateExecutionDefinitions | sid | Sitzungs-ID – Benutzerauthentifizierung
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=updateExecutionDefinitions&userName=<user>&passWord=<password>

Die Definitionsdatei für das XML-Schema, mit der überprüft wird, ob Testsuiten über den URL des Front-End-Servers http://<Host>/silkroot/xsl/executionplan.xsd heruntergeladen oder aus dem Installationsordner <Silk Central-Installationsordner>/wwwroot/silkroot/xsl/executionplan.xsd des Front-End-Servers kopiert werden können.

Beispiel für den Webdienst updateExecutionDefinitions

Im folgenden Quelltext werden die Testsuites mithilfe von Apache HttpClient aktualisiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
string xml = loadExecutionPlanUtf8(DEMO_EXECUTION_PLAN_XML);
HttpClient client = new HttpClient();

URL webServiceUrl = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateExecutionDefinitions",
    sessionID));
StringPart ExecutionPlanXml = new StringPart(DEMO_EXECUTION_PLAN_XML, xml,
  "UTF-8");
ExecutionPlanXml.setContentType("text/xml");
Part[] parts = {ExecutionPlanXml};
PostMethod filePost = new PostMethod(webServiceUrl.toExternalForm());
filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

Pro Anfrage kann nur ein Anhang hochgeladen werden. Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Testsuite – Beispiel

Der folgende Code zeigt ein Beispiel eines Ausführungsplans, der mithilfe des Diensts Silk Central undcreateExecutionDefinitions in updateExecutionDefinitions hochgeladen werden kann. In diesem Fall wird ein benutzerdefinierter Ausführungstermin für eine der Testsuiten erstellt, und einer Testsuite werden Tests zugeordnet, sowohl manuell als auch mittels Filter. Im Beispiel wird zudem eine Konfigurationssuite mit Konfigurationen erstellt.

<ExecutionPlan xmlns="http://www.borland.com/ExecPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/executionplan.xsd">

  <Folder name="Folder1">
    <Description>Description of the folder</Description>
    <ExecDef name="ExecutionDefinition1" TestContainerId="1">
      <Description>Description1</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <forever>true</forever>
        </end>
        <Interval day="1" hour="2" minute="3"></Interval>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>
      <ReadFromBuildInfoFile>true</ReadFromBuildInfoFile>
      <Priority>High</Priority>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ExecDef>
    <ExecDef name="ExecutionDefinition2" TestContainerId="1">
      <Description>Description2</Description>
      <Build>1</Build>
      <Version>1</Version>
      <Priority>Low</Priority>
      <SourceControlLabel>Label1</SourceControlLabel>
      <DependentExecDef id="65">
        <Condition>Passed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Server" id="1"/>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="70">
        <Condition>Failed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="68">
        <Condition>Any</Condition>
        <Deployment>
          <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
        </Deployment>
      </DependentExecDef>
    </ExecDef>

    <ConfigSuite name="ConfigSuite1" TestContainerId="1">
      <Description>ConfigSuite1 desc</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <times>1</times>
        </end>
        <Interval day="1" hour="2" minute="3"/>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>

      <ConfigExecDef name="Config1">
        <Description>Config1 desc</Description>
        <Priority>Medium</Priority>
      </ConfigExecDef>

      <ConfigExecDef name="Config2">
        <Priority>Medium</Priority>
        <DependentExecDef id="69">
          <Condition>Any</Condition>
          <Deployment>
            <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
          </Deployment>
        </DependentExecDef>
      </ConfigExecDef>

      <Build>8</Build>
      <Version>2</Version>
      <SourceControlLabel>ConfigSuite1 label</SourceControlLabel>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ConfigSuite>
  </Folder>
</ExecutionPlan>
Übergeordnetes Thema: Services Exchange


Schnittstelle createLibraries

Über die Schnittstelle createLibraries werden neue Bibliotheken erstellt. Die HTTP-Antwort des Aufrufs enthält die XML-Struktur der geänderten Bibliotheken. Sie können die Kennungen der neuen Knoten der aktualisierten XML-Bibliotheksstruktur entnehmen.

Die folgende Tabelle enthält die Parameter der Schnittstelle createLibraries.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=createLibraries | sid | Sitzungs-ID – Benutzerauthentifizierung
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid

Beispiel: http://<front-end URL>/servicesExchange?hid=createLibraries&userName=<user>&passWord=<password>

Die Definitionsdatei für das XML-Schema, mit der überprüft wird, ob Bibliotheken über den URL des Front-End-Servers http://<Host>/silkroot/xsl/libraries.xsd heruntergeladen oder aus dem Installationsordner <Silk Central-Installationsordner>/wwwroot/silkroot/xsl/libraries.xsd des Front-End-Servers kopiert werden können.

Beispiel für den Webdienst createLibraries

Im folgenden Quelltext werden die Bibliotheken mithilfe von Apache HttpClient erstellt.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s",
  "createLibraries", sessionID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadTestPlanUtf8("libraries.xml");
StringPart xmlFileItem = new StringPart("libraries", xmlFile, "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts, filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Bibliotheken – Beispiel

Der folgende Code zeigt ein Beispiel einer Bibliothek, die mithilfe des Dienstes Silk Central in createLibraries hochgeladen werden kann. Neue Bibliotheken können in beliebigen Projekten verwendet werden, sofern im Abschnitt GrantedProjects keine Projekte angegeben sind.

<LibraryStructure xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/libraries.xsd">

  <Library name="Library 1">
    <Folder name="Folder 1">
      <Folder name="Folder 1.1">
        <SharedSteps name="Basic create user steps">
          <Step name="Login">
            <ActionDescription>
              Login with user admin.
            </ActionDescription>
            <ExpectedResult>Succesful login.</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
          <Step name="Create User">
            <ActionDescription>Create user tester</ActionDescription>
            <ExpectedResult>User created</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
          <Step name="Logout">
            <ActionDescription>
              Logout using start menu
            </ActionDescription>
            <ExpectedResult>Logged out.</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
        </SharedSteps>
      </Folder>
    </Folder>
    <GrantedProjects>
      <ProjectId>0</ProjectId>
      <ProjectId>1</ProjectId>
    </GrantedProjects>
  </Library>
</LibraryStructure>
Übergeordnetes Thema: Services Exchange


Schnittstelle exportLibraryStructure

Über die Schnittstelle exportLibraryStructure können Bibliotheken, Ordner und Objekte mit gemeinsam verwendbaren Testschritten als XML-Dateien exportiert werden. Die folgende Tabelle enthält die Parameter der Schnittstelle exportLibraryStructure.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=exportLibraryStructure | sid | Sitzungs-ID – Benutzerauthentifizierung
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid
 | nodeID | Der zu exportierende Bibliotheksknoten oder -ordner in der Bibliothekshierarchie. IDs von Knoten mit gemeinsam verwendbaren Testschritten sind unzulässig.

Beispiel: http://<front-end URL>/servicesExchange?hid=exportLibraryStructure&userName=<user>&passWord=<password>&nodeID=<id>

Beispiel für den Webdienst exportLibraryStructure

Im folgenden Quelltext werden die Bibliotheken mithilfe von Apache HttpClient exportiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportLibraryStructure", sessionID, NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Übergeordnetes Thema: Services Exchange


Schnittstelle exportLibraryStructureWithoutSteps

Über die Schnittstelle exportLibraryStructureWithoutSteps können Bibliotheken, Ordner und Objekte mit gemeinsam verwendbaren Testschritten als XML-Dateien exportiert werden. Die Schritte der Objekte mit gemeinsam verwendbaren Testschritten werden nicht exportiert. Die folgende Tabelle enthält die Parameter der Schnittstelle exportLibraryStructureWithoutSteps.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=exportLibraryStructureWithoutSteps | sid | Sitzungs-ID – Benutzerauthentifizierung
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid
 | nodeID | Der zu exportierende Bibliotheksknoten oder -ordner in der Bibliothekshierarchie. IDs von Knoten mit gemeinsam verwendbaren Testschritten sind unzulässig.

Beispiel: http://<front-end URL>/servicesExchange?hid=exportLibraryStructureWithoutSteps&userName=<user>&passWord=<password>&nodeID=<id>

Beispiel für den Webdienst exportLibraryStructureWithoutSteps

Im folgenden Quelltext werden die Bibliotheken mithilfe von Apache HttpClient exportiert.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportLibraryStructureWithoutSteps", sessionID, NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Übergeordnetes Thema: Services Exchange


Schnittstelle getLibraryInfoByName

Die Schnittstelle getLibraryInfoByName gibt die ID, den Namen und die Beschreibung aller benannten Bibliotheken zurück. Die Schnittstelle gibt nur die Eigenschaften von Bibliotheken, nicht aber ihre Hierarchie zurück. Die folgende Tabelle enthält die Parameter der Schnittstelle getLibraryInfoByName.

Schnittstellen-URL | Parameter | Beschreibung
http://<front-end URL>/servicesExchange?hid=getLibraryInfoByName | sid | Sitzungs-ID – Benutzerauthentifizierung
 | userName | Optional: Benutzername – Anstelle von sid
 | passWord | Optional: Kennwort – Anstelle von sid
 | libraryName | Der Name der Bibliothek

Beispiel: http://<front-end URL>/servicesExchange?hid=getLibraryInfoByName&userName=<user>&passWord=<password>&libraryName=<name>

Beispiel für den Webdienst getLibraryInfoByName

Im folgenden Quelltext werden Bibliotheksinformationen mithilfe von Apache HttpClient abgerufen.

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s",
  "getLibraryInfoByName", sessionID, LIBRARY_NAME));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String response = fileGet.getResponseBodyAsString();
System.out.println(response);

Apache HttpComponents können Sie von http://hc.apache.org/downloads.cgi herunterladen. Die erforderlichen Bibliotheken entnehmen Sie der Dokumentation der Komponente.

Übergeordnetes Thema: Services Exchange


Demo Client für Webdienste

Der Demo Client für Webdienste ist ein Tool zur Demonstration der Verwendung von Silk Central-Webdiensten. Sie können den Client über Hilfe > Tools herunterladen.

Der Demo Client für Webdienste zeigt alle unter Tests > Testsattribute verwalten verfügbaren Attribute für die einzelnen Tests und alle Eigenschaften für die einzelnen verfügbaren Testtypen an.
Achtung: Mit dem Demo Client für Webdienste kann die Verwendung von Webdiensten demonstriert werden. Verwenden Sie den Demo Client nicht in einer Produktionsumgebung.
Übergeordnetes Thema: Silk Central-Webdienste


Kontaktaufnahme mit Micro Focus

Micro Focus ist bestrebt, technischen Support und Beratung auf höchstem Niveau anzubieten.Micro Focus leistet weltweiten Support, der sich durch fristgerechten und zuverlässigen Service auszeichnet, um so den Geschäftserfolg jedes einzelnen Kunden zu ermöglichen.

Support können alle Kunden in Anspruch nehmen, die einen Wartungs- und Supportvertrag abgeschlossen haben, sowie potenzielle Kunden, die unsere Produkte testen. Unsere hochqualifizierten Mitarbeiter kümmern sich umgehend und professionell um Ihre Anfragen.

Gehen Sie zu http://supportline.microfocus.com/assistedservices.asp, um Ihre Supportanfrage direkt an die Micro Focus SupportLine zu richten, oder senden Sie eine E-Mail an supportline@microfocus.com.

Besuchen Sie die Micro Focus SupportLine unter http://supportline.microfocus.com, um die aktuellsten Neuigkeiten und andere Supportinformationen zu erfahren. Benutzer, die die Website erstmals besuchen, müssen sich dazu registrieren.

  • Für Micro Focus SupportLine erforderliche Informationen
    Hier werden die Informationen angegeben, die Micro Focus SupportLine benötigt, um die Anfragen der Kunden zu bearbeiten.
  • Systemdiagnose
    Hier wird beschrieben, wie Sie Systemdiagnosedaten anzeigen und herunterladen.


Für Micro Focus SupportLine erforderliche Informationen

Wenn Sie sich an die Micro Focus SupportLine wenden, geben Sie bitte nach Möglichkeit die folgenden Informationen an. Je mehr Informationen Sie mitteilen, desto besser kann Ihnen die Micro Focus SupportLine zur Seite stehen.

  • Name und Versionsnummer aller Produkte, die Ihrer Meinung nach Probleme bereiten.
  • Hersteller und Modell Ihres Computers.
  • Systeminformationen wie Name und Version des Betriebssystems, Angaben zu den Prozessoren und zum Speicher.
  • Ausführliche Beschreibung des Problems, Schritte zur Wiederholung der Fehlersituation.
  • Exakter Wortlaut aller relevanten Fehlermeldungen.
  • Ihre Seriennummer.

Sie finden diese Nummern in der Betreffzeile und im Text der Lieferbenachrichtigungs-E-Mail, die Sie von Micro Focus erhalten haben.

Übergeordnetes Thema: Kontaktaufnahme mit Micro Focus
Zugehörige Konzepte
Systemdiagnose


Aktivieren oder Deaktivieren der HTML-Antwortkomprimierung

So aktivieren oder deaktivieren Sie die HTML-Antwortkomprimierung:

  1. Stoppen Sie den Front-End-Server der zu bearbeitenden Instanz auf der Seite Instanzen-Verwaltung.
  2. Öffnen Sie die Datei server.xml in einem Texteditor. Diese Datei befindet sich auf dem Front-End-Server im Ordner /conf/frontendserver des Silk Central-Verzeichnisses.
  3. Suchen Sie das XML-Tag Connector.
  4. Fügen Sie den Connector-Tags compression="on" und compressableMimeType="text/html,text/xml,text/plain,text/css,text/javascript,application/xml" hinzu. Das Servlet komprimiert alle Antworten mit gzip. Gzip stammt aus Apache Tomcat Native.
  5. Speichern und schließen Sie die XML-Datei.
  6. Starten Sie den Front-End-Server neu.
Zugehörige Tasks
Verwalten von Instanzen


Reuse_Creating or Editing Tests

So erstellen Sie einen neuen Test:

  1. Klicken Sie im Menü auf Tests > Detailansicht.
  2. Wählen Sie in der Testhierarchie den Container- oder Ordnerknoten aus, in den ein neuer Test eingefügt werden soll, oder wählen Sie den zu bearbeitenden Test.
  3. Klicken Sie in der Symbolleiste auf Neuer untergeordneter Test (Neuer untergeordneter Test) oder auf [image] (Bearbeiten).

    Der Dialog Neuer Test/Test bearbeiten wird angezeigt.

  4. Geben Sie einen Namen und eine Beschreibung für den Test ein.
    Anmerkung: Silk Central unterstützt in Beschreibungsfeldern HTML-Formatierungen sowie das Ausschneiden und Einfügen von HTML-Inhalten.
  5. Wählen Sie aus der Liste Typ den Testtyp aus.
  6. Klicken Sie auf Weiter, und wechseln Sie zum entsprechenden Thema für den ausgewählten Testtyp unter Konfigurieren von Testeigenschaften.
Anmerkung: Mithilfe der öffentlichen und umfassend dokumentierten API von Silk Central können Sie eigene Lösungen zur Durchführung automatisierter Tests implementieren. Silk Central lässt sich durch seine offene Programmierschnittstelle um externe Tools erweitern, die aus einer Java-Implementierung oder in der Befehlszeile aufgerufen werden können.
Anmerkung: Während des gesamten Konfigurationsvorgangs für Tests stehen für alle Testtypen die Kontrollkästchen Von übergeordneter Ebene erben zur Verfügung, mit denen die Einstellungen der übergeordneten Entität übernommen werden können.