Silk Central 18.5 へようこそ

Silk Central へようこそ

  • アーキテクチャ
  • ライセンス管理
  • UI のツアー
  • クイック スタート タスク
  • インストール ヘルプ

新機能

  • Silk Central の新機能
  • リリース ノート

主なセクション

  • マイ ダッシュボード
  • 手動実行計画
  • 品質目標

チュートリアルとデモンストレーション

  • クイック スタート タスク
  • 手動実行計画ウォークスルー
  • Training Store の無料の Web ベース トレーニング

コード サンプル

  • API ヘルプ

オンライン リソース

  • Micro Focus のホーム ページ
  • YouTube の Micro Focus チャンネル
  • Micro Focus オンライン ドキュメント
  • Micro Focus SupportLine
  • Micro Focus Product Updates
  • Silk Central Knowledge Base
  • Silk Central Community Forums
  • Micro Focus On-demand Training

フィードバックをお寄せください

  • Micro Focus へのお問い合わせ
  • このヘルプに関するフィードバックを電子メールでお送りください


インストールとシステム設定ヘルプ

インストールとシステム設定ヘルプには、Silk Central のインストールおよびアンインストールの際に必要となるすべての情報が記載されています。また、Silk Central インフラストラクチャの設定方法についても説明します。

  • Silk Central のアーキテクチャ
    Silk Central のアーキテクチャの概要について説明します。
  • Silk Central のインストール
    Silk Central のインストール DVD およびセットアップ プログラムを使用して、すべての Silk Central ソフトウェア コンポーネントをインストールできます。
  • インフラストラクチャの構成と管理
    インスタンスと Silk Central サービスは、インスタンス管理 という共通 UI を通じて管理されます。この UI には、Silk Central をインストールしたサーバー上からのみ、http://localhost:19100 という URL を使用してアクセスできます。


Silk Central のアーキテクチャ

Silk Central のアーキテクチャの概要について説明します。

Silk Central サーバー

Silk Central セットアップが実行されるサーバー。

インスタンス管理

インスタンスと Silk Central サービスは、インスタンス管理 という共通 UI を通じて管理されます。この UI には、Silk Central をインストールしたサーバー上からのみ、http://localhost:19100 という URL を使用してアクセスできます。

インスタンス

インスタンスは、独立した Silk Central サービス群（アプリケーション サーバー（AS）、フロントエンド サーバー（FE）、チャート サーバー（CS））で、それ自身のデータベースと実行サーバー（ES）との接続を持ちます。デフォルトでは、Silk Central は silk という名前のインスタンスを 1 つだけ作成します。 デフォルトの URL は、http://<コンピュータ名>:19120/login (IIS 上で Silk Central を実行する場合はポート番号は不要です) です。 データ セキュリティを高め、独立したユーザー グループ（事業部など）間での互いの影響を低減させるために、さまざまなクライアントの処理やテスト データ自身を物理的に分離する必要がある場合に、別のインスタンスを作成します。クライアント機能を使用すると、1 つのデータベース内の 1 つのインスタンスのデータを論理的に分離することができます。

プロキシ

プロキシ サービスは Silk Central サーバー上にインストールされ、さまざまなインスタンスへのアクセスを制御します。各インスタンスのサービスは、専用のポートで実行していますが、セキュリティと柔軟性向上のため、http://<Silk Central サーバー>:19120/<インスタンス名> 形式のアクセスを、プロキシがインスタンス名から実際の URL にルーティングします。

アプリケーション サーバー (AS)

アプリケーション サーバーは、スケジュールの配布、実行サーバーの制御、データベース構成の管理などのタスクを同期させる働きをします。これらのタスクには、アプリケーション動作の一貫性と信頼性を確保するための仲介役が中央に必要です。また、アプリケーション サーバーは、結果を評価して、それをデータベースに保存し、成功条件に基づいて警告を送信することも行います。デフォルト インスタンスでは、アプリケーション サーバーはポート 19122 を使用します。インスタンスを追加すると、100 を加算したポートが使用されます。

フロントエンド サーバー (FE)

フロントエンド サーバーは、グラフィカル ユーザー インターフェイスを担当するものです。このサーバーは HTML をベースにしているので、Internet Explorer、Firefox、Chrome などの任意の Web ブラウザからアクセスすることができます。ユーザーが適切な HTTP 要求をフロントエンド サーバーに送信すると、認証用のログイン ページが表示されます。ログインに成功すると、ユーザーは、それぞれのユーザー権限に応じたアプリケーションを使用できます。フロントエンド サーバーは、スタンドアロンの HTTP サーバーとして動作することも、Web サーバー (たとえば、IIS など) に接続することもできます。デフォルト インスタンスでは、フロントエンド サーバーはポート 19110 を使用します。次のインスタンスはポート 19220 を使用し、以降、インスタンスを追加するたびに、100　を加算したポートが使用されます。SSL を使用したセキュアな接続では、ポート 443 も使用します。フロントエンド サーバーには、URL http://<Silk Central サーバー>:19120/<インスタンス名>（デフォルト インスタンスではインスタンス名は必要ありません）を使ってアクセスできます。

チャート サーバー (CS)

チャート サーバーは、レポートに掲載するグラフの生成に使用されます。チャート サーバーのプールを設定することができます。組み込みの負荷分散メカニズムでは、このプールを使用してグラフ生成処理を分散させます。チャート サーバーはまた、レポートの生成とエンドユーザーへの直接配信にも使用され、エンド ユーザーは配信されたレポートをブラウザで閲覧することができます。デフォルト インスタンスでは、チャート サーバーはポート 19126 を使用します。インスタンスを追加すると、100 を加算したポートが使用されます。

実行サーバー (ES)

実行サーバーは、権限のあるユーザーによってスケジュールされた自動テストを実行します。ユーザーは、テスト実行に必要な実行サーバーと追加リソースを適切に設定しなければなりません。互いに独立に動作する複数の実行サーバーをインストールし設定することも可能です。デフォルト インスタンスでは、実行サーバーはポート 19124 を使用します。SSL を使用したセキュアな接続では、ポート 19125 も使用します。

エージェント コンピュータ：

Silk Performer と Silk Test Classic のエージェント コンピュータは、コントローラ コンピュータで使用できるエージェント コンピュータのプールから、特定の Silk Performer または Silk Test Classic プロジェクトに割り当てられます。Silk Central と組み合わせると、コントローラ コンピュータは実行サーバーの機能を果たします。
Silk Performer エージェント
Silk Performer エージェント コンピュータは、負荷テスト時に実行される仮想ユーザーのホストになります。必要な数の仮想ユーザーを実行できるように、エージェント コンピュータをいくつでも必要なだけ Silk Performer プロジェクトに追加できます。エージェントの構成は、Silk Performer を通じて行います。エージェントの設定の詳細については、Silk Performer のドキュメントを参照してください。
Silk Test Classic エージェント
Silk Performer エージェントが Silk Test Classic テストのホストとなる以外は、Silk Test Classic エージェントにも、Silk Test Classic エージェントと同じルールが適用されます。

データベース サーバー (DB)

システムの永続性は、RDBMS (リレーショナル データベース管理システム) を使って実装されています。データベース サーバーは、ポート 1433 (SQL Server) または 1521 (Oracle) を使用します。

Silk Meter ライセンス サーバー

ユーザーがアクセス可能な Silk Central アプリケーション機能は、Silk 製品に付属するライセンス管理ソフトウェアである Silk Meter により決定されます。ライセンス管理の詳細については、製品のインストール ガイドを参照してください。Silk Meter はポート 5461 を使用します。

クライアント

クライアントは Silk Central インスタンス内の個別のユニットです。クライアントには顧客または企業内の部門などを設定できます。クライアントはセキュリティを向上させますが、インスタンスとは異なり、同じデータベースと Silk Central サービスが共有されます。 各クライアントは次の主要なエンティティで構成されます。
  • ユーザー ロールとアクセス許可
  • ユーザー グループとユーザー アカウント
  • プロジェクト
  • ロケーション、実行サーバー、エージェント コンピュータ
  • コンポーネント、バージョン、ビルドを持つ製品
  • グローバル スケジュール

プロジェクト

Silk Central のプロジェクトは、通常、会社のソフトウェア プロジェクトを反映したもので、開発チームの作業それぞれに対して、共通のリリース日、ソース管理システム、要件などがあります。 各プロジェクトは次の主要なエンティティで構成されます。
  • フィルタ
  • 属性
  • 要件のプロパティ
  • ステップのプロパティ
  • 通知
  • 要件管理ツールおよび問題追跡ツールとの統合
  • ソース管理システムとの統合
  • データ ソース
  • ステータスの理由

重要なファイルの場所

  • インスタンス管理と実行サーバーのログ ファイル：C:\ProgramData\SilkCentral\log
  • アプリケーション、フロントエンド、チャート サーバーのログ ファイル：C:\ProgramData\SilkCentral\instance_<インスタンス番号>_<インスタンス名>\log
  • ホットフィックスの場所：C:\Program Files (x86)\Silk\Silk Central18.5\hotfixes
  • 設定ファイル：C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf
  • プラグイン：C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Plugins
  • Office インポート マッピング ファイル：C:\ProgramData\SilkCentral\instance_<インスタンス番号>_<インスタンス名>\OfficeImportMappingFiles
親トピック: インストールとシステム設定ヘルプ
関連タスク
インスタンスの管理
クライアントの管理
プロジェクトを管理する


Silk Central のインストール

Silk Central のインストール DVD およびセットアップ プログラムを使用して、すべての Silk Central ソフトウェア コンポーネントをインストールできます。

Silk Central をインストールするには、お使いのコンピュータ システムが最小要件を満たしている必要があります。インストール プログラムは、システムを検査して、必要なソフトウェアをオプションでインストールします。

注: Silk Central をインストールするには、そのコンピュータ上で管理者権限を持っている必要があります。
  • システム要件および前提条件
    Silk Central の最適なパフォーマンスのために、このセクションで概要を説明する構成をお勧めします。自作機 (ベアボーンキット、ショップ ブランド機を含む) は動作保証外です。
  • Silk Central を評価用にインストールする
    スタンドアロン インストールのセットアップを行います。この場合、すべての機能が単一のマシン上にインストールされます。このインストール タイプは、評価またはデモンストレーション用途のみに使用してください。
  • Silk Central をインストールする
    Silk Central のインストール DVD およびセットアップ プログラムを使用して、すべての Silk Central ソフトウェア コンポーネントをインストールできます。
  • Windows 実行サーバーをインストールする
    Windows 実行サーバーをインストールして、リモート コンピュータ上でテストを実行できるようにします。
  • Linux 実行サーバーをインストールする
    Linux 実行サーバーをインストールして、リモート コンピュータ上でテストを実行できるようにします。
  • ホットフィックスをインストールする
    ホットフィックスが利用可能になったとき、インスタンスを最新のホットフィックスに更新できます。
  • Silk Central 18.5 にアップグレードする
    Silk Central 18.5 にアップグレードして、拡張された機能を利用します。
  • Silk Central のライセンス管理
    ライセンス ポリシーを取得し、ユーザーの製品が Silk Central の完全な機能とサポートを受けることができるようにします。
  • テスト済みおよびサポートされているソフトウェア
    Silk Central18.5 がテストされたソフトウェア、および Silk Central がサポートするソフトウェアの一覧を示します。
親トピック: インストールとシステム設定ヘルプ
関連概念
システム要件および前提条件


システム要件および前提条件

Silk Central の最適なパフォーマンスのために、このセクションで概要を説明する構成をお勧めします。自作機 (ベアボーンキット、ショップ ブランド機を含む) は動作保証外です。

サーバー システムの要件

システム領域 | 要件
CPU | Intel Core i5、またはより高性能な CPU
メモリ | 最低 8 GB
空きディスク容量 | 最低 30 GB、データベース サーバーを除く
ネットワーク | 100 Mbit
オペレーティング システム、データベース管理システム、Web サーバー | テスト済みおよびサポートされているソフトウェアを参照してください。
電源供給 | 停電時のリスクを減少するため、すべての環境に対する無停電電源装置 (UPS)
追加するインスタンスごとに、最低 10 GB の追加のディスク容量と、次の最低メモリが必要になります。
  • フロントエンド サーバー：500 MB
  • アプリケーション サーバー：300 MB
  • チャート サーバー：200 MB
作業内容に応じて、これらの値はより高くなる可能性があります。

Silk Central の最適な構成の詳細については、テクニカル サポートまたはテクニカル アカウント チームに問い合わせてください。

実行サーバーの要件

実行サーバーに対する実際の要件と前提条件は、テスト対象アプリケーション (AUT) やテストのタイプに依存します。

負荷テストについては、Silk Performer の環境要件を参照してください。最小限の構成での負荷テストは、不正確な結果につながります。

機能テストについては、Silk Test の環境要件を参照してください。Web ブラウザのリプレイなど、集中的なテストについては、最小 2048 MB のメイン メモリが推奨されます。

Linux 実行サーバーは、Java Runtime Environment (JRE) 8 が必要です。

プロキシ サーバーの要件

Silk Central で Microsoft IIS を使用する場合は、Silk Central をインストールする前に、次の IIS 拡張機能をインストールする必要があります。
  • Application Request Routing (ARR)
  • URL Rewrite
IIS Downloads ページから、これらの拡張機能の最新版をダウンロードできます。

仮想化

Silk Central は仮想インフラストラクチャ環境 (VMware vSphere サーバー) での実行がテストされています。

クライアント側のシステム要件

システム領域 | 要件
プロセッサ | Intel Core i3、またはより高性能な CPU
メモリ | 2 GB
Web ブラウザ
  • Google Chrome
  • Internet Explorer 10 以降 (互換モード以外)
  • Mozilla Firefox
  • Microsoft Edge

手動テスト UI は、Java Runtime Environment (JRE) 7 Update 79 以降 が必要です。

親トピック: Silk Central のインストール


Silk Central を評価用にインストールする

作業を開始する前に、 Silk Central の実行可能ファイルをダウンロードするか、Silk Central の DVD を DVD ドライブに挿入します。
注: Microsoft SQL Server Express インストールには管理者権限が必要なため、UAC が有効化されていると、インストールに失敗します。Silk Central を評価用にインストールする場合は、コンピュータの UAC を無効にしてください。

スタンドアロン インストールのセットアップを行います。この場合、すべての機能が単一のマシン上にインストールされます。スタンドアロン インストールでは、Silk Central の完全なパフォーマンスは実現されません。このインストール タイプは、評価またはデモンストレーション用途のみに使用してください。

注: Microsoft Windows Server 2008 R2、Windows Microsoft Windows Server 2008 R2 SP1、または Microsoft Windows Server 2012 での Silk Central のインストール中は、.NET Framework 3.5 SP1 のセットアップを実行できません。システムに .NET Framework 3.5 SP1 がインストールされていないうえ、オペレーティング システムが Microsoft Windows Server 2008 R2、Windows Microsoft Windows Server 2008 R2 SP1、または Microsoft Windows Server 2012 であり、Silk Central の評価版をインストールする場合、Silk Central をインストールする前に、Windows Server Manager を使用して .NET Framework 3.5 SP1 をシステムにインストールします。
  1. Silk Central の実行可能ファイルを探し、ダブルクリックします。
    InstallShield ウィザードが開きます。
  2. セットアップ ウィザードの指示に従って、すべてデフォルト設定のままで Next か OK を各ダイアログでクリックしてインストールを進めます。
  3. Select Licensing Mode ダイアログで、デフォルト設定 (Evaluation) のままにします。 Silk Central にはデータベース リポジトリが必要です。評価目的の場合は、Silk Central と一緒にインストールされる Microsoft SQL Server Express を使用することをお勧めします。Install Microsoft SQL Server 2008 Express SP1 チェック ボックスがチェックされていることを確認してください。
  4. Next をクリックしてインストールを完了します。
親トピック: Silk Central のインストール
関連概念
システム要件および前提条件
Silk Central のライセンス管理


Silk Central をインストールする

作業を開始する前に、 Silk Central の実行可能ファイルをダウンロードするか、Silk Central の DVD を DVD ドライブに挿入します。 使用するシステムが システム要件および前提条件 の各項目を満たしていることを確認してください。

  1. Silk Central の実行可能ファイルを探し、ダブルクリックします。
    Silk Central の DVD をお持ちの場合、DVD を挿入します。Silk Central セットアップ プログラムが自動的に開始されない場合は、スタート > ファイル名を指定して実行... を選択し、<DVD drive>:\setup.exe を入力して、 セットアップ プログラムを手動で開始します。 InstallShield ウィザードが開きます。
  2. ウィザードの Welcome ページが開いたら、ウィザードの指示に従ってセットアップ手順を進めます。Next をクリックし、続行します。
  3. 使用する言語を選択して、Next をクリックします。 License Agreement が開きます。
  4. 使用許諾契約の条項を注意深くお読みください。これらの条項に同意する場合には、I accept the terms of the license agreement をクリックします。
    Setup Type ページが開きます。
  5. Silk Central 実行サーバーをインストールするには、Install Execution Server チェック ボックスにチェックを付けます。Microsoft Internet Information Services (IIS) を使用する場合は、Use Microsoft Internet Information Services チェック ボックスにチェックを付けます。 デフォルトのインストール先は Setup Type ページの Destination path セクションに表示されます。デフォルトのインストール ディレクトリを変更するには、以下のステップを実行します。
    1. Browse をクリックします。 Choose Folder ダイアログ ボックスが開きます。
    2. Silk Central をインストールするフォルダを指定し、OK をクリックして Setup Type ページに戻ります。
    注: Silk Central は、ローカル ドライブにインストールする必要があります。無効なインストール先を指定した場合には、エラー メッセージが表示されます。
  6. Next をクリックし、続行します。 Installation Options Summary ページに、選択した設定内容が一覧表示されます。
  7. 提示された情報を確認し、以下のステップのいずれかを行います。
    • 設定を変更するには、Back をクリックして、該当するページに戻ります。
    • 必要な設定をし終えたら、Next をクリックして、インストール処理を開始します。
    Setup Status ページの進捗バーにより、インストール処理の状況がわかります。完了すると、Select licensing mode ページが開きます。
  8. 次のオプション ボタンのいずれか 1 つをクリックします。
    • Evaluation - Silk Central の評価版をインストールすると、製品のすべての機能を 45 日間使用できます。使用は、10 Silk Central ユーザーと 10 Issue Manager ユーザーに制限されています。後から、製品版へのアップグレードをご希望の場合には、営業担当までお問い合わせください。追加で Microsoft SQL Server 2008 Express SP1 をインストールする場合は、Install Microsoft SQL Server 2008 Express SP1 チェック ボックスをチェックします。
    • Licensed - ライセンスが必要な Silk Central の無制限版をインストールします。
  9. Next をクリックします。
    インストールにおいて選択したコンポーネントに応じて、Licensing ページが開く場合があります。ライセンス管理を必要とするコンポーネントをインストールしておらず、このページが開かない場合は、次のステップに進んでください。 ライセンス ファイルをインストールするには、次のステップを行います：
    1. OK をクリックし、ライセンス ファイルの場所を指定します。 このライセンス ユーティリティは、ローカル システム内に、Silk Meter ライセンス サーバーの設定ファイルがあるかどうか確認します。ファイルが見つかれば、ライセンス サーバーの設定とタイプが表示され、ライセンス管理に利用されます。設定データが見つからない場合は、Select Silk Meter License Server ページがデフォルトの設定と共に表示されます。 このページでは、Silk Meter ライセンス管理についての一般的な情報を提供しています。Silk Meter ライセンス管理の詳細については、Open Silk Meter ReadMe をクリックします。これにより、デフォルト ブラウザで Silk Meter ドキュメントが開きます。
      注: ドキュメントがインストール ソース ディレクトリで利用できない場合は、Open Silk Meter ReadMe ボタンは利用できなくなっています。このドキュメントは、一般に、Silk Central Web パッケージをインストールしている場合は利用できなくなっています。
    2. Application リスト ボックスで、ライセンス管理を行うアプリケーションとして Silk Central を選択します。
    3. 次のオプション ボタンのいずれか 1 つをクリックします。
      Using local or remote server
      License Server Host フィールドに、Silk Meter がインストールされているコンピュータの名前を入力します。ネットワーク管理者が別のポートを定義したのでない限り、デフォルト ポート番号 5461 は変更しないでください。Apply をクリックして、ライセンス サーバーの設定を生成します。Test Connection をクリックして、指定したホスト、ポート上で Silk Meter サーバーがアクセス可能かどうかを確認します。ライセンス サーバーへの接続テストは、インストール時には失敗することがあります。これは、必須システム ライブラリが、あとからソフトウェア パッケージと共にインストールされるために、その時点ではまだ利用できない場合があるためです。
      注: 場合により、License Server Host フィールドに、ライセンス サーバーの名前を licenseserver など単純な名前で指定すると、うまくいかない場合があります。there is no license server running on the hostname you specified (指定されたホスト名上にはライセンス サーバーが実行されていません) というメッセージ ボックスが開きます。この問題を解決するには、licenseserver.mycompany.com など、完全修飾名によるホスト名を再度指定してください。
      Not using server (standalone)
      Silk Meter をスタンドアロンで実行します。Silk Meter のライセンス ファイルをインポートするようプロンプトが表示されます。Yes をクリックし、ライセンス ファイルの場所を指定します。
    4. Close をクリックして、InstallShield ウィザードに戻ります。
  10. Finish をクリックしてインストールを完了させます。
    注: InstallShield ウィザードがインストール時にファイルの更新に失敗した場合 (例、システム ライブラリが Windows によってロックされていた場合)、またはそれ以外の理由で InstallShield ウィザードがシステムを再起動する必要があることを検出した場合、コンピュータを再起動するようにプロンプトが表示されます。この場合、コンピュータを再起動しないと、Silk Central へのアクセスに問題が発生する可能性があります。

インスタンス管理 ページが表示され、Silk Central インストールの設定を行うことができます。詳細については、「インスタンスの管理」を参照してください。

親トピック: Silk Central のインストール
関連概念
システム要件および前提条件
Silk Central のライセンス管理
インスタンスの管理


Windows 実行サーバーをインストールする

リモート Silk Central 実行サーバーとして使用する POP（Point of Presence）それぞれに実行サーバーをインストールします。実行サーバーは、Silk Central テストをリモート コンピュータ上で実行します。

  1. Silk Central メニューで、ヘルプ > ツール > Windows 実行サーバー をクリックして、Windows 実行サーバー パッケージをダウンロードします。
  2. Silk Central の実行可能ファイルを探し、ダブルクリックします。
    InstallShield ウィザードが開きます。
  3. インストール ウィザードの指示に従います。
  4. Finish をクリックしてインストールを完了させます。
    注: InstallShield ウィザードがインストール時にファイルの更新に失敗した場合 (例、システム ライブラリが Windows によってロックされていた場合)、またはそれ以外の理由で InstallShield ウィザードがシステムを再起動する必要があることを検出した場合、コンピュータを再起動するようにプロンプトが表示されます。この場合、コンピュータを再起動しないと、Silk Central へのアクセスに問題が発生する可能性があります。
親トピック: Silk Central のインストール
関連概念
実行サーバーを設定する
システム要件および前提条件
関連タスク
Linux 実行サーバーをインストールする


Linux 実行サーバーをインストールする

このタスクは、Linux を使用する Silk Central ユーザー用です。

リモート Silk Central 実行サーバーとして使用する POP（Point of Presence）それぞれに実行サーバーをインストールします。実行サーバーは、Silk Central テストをリモート コンピュータ上で実行します。

  1. Silk Central メニューで、ヘルプ > ツール > Linux 実行サーバー をクリックして、Linux 実行サーバー パッケージをダウンロードします。
    注: Linux 実行サーバー パッケージには、JRE は含まれていません。Java Runtime Environment (JRE) 8 がインストールされていることを確認してください。JRE は、Java SE Downloads からダウンロードできます。
  2. 次のコマンドを使用して、パッケージ ファイル tar.gz を展開します。
    gzip -d <パッケージ ファイル名>.tar.gz

    その後、tar ファイルを次のコマンドを使用して展開します。

    tar xfz <パッケージ ファイル名>.tar

    パッケージ ファイルの名前は、LinuxExecServer-<バージョン> です。

  3. 次のコマンドを使用して、パッケージ ファイルを展開したディレクトリに移動します。
    cd LinuxExecServer
  4. 次のコマンドを使用して、実行サーバーを開始します。
    ./startExecServer.sh
    注: キャッシュ情報とログ ファイルは、お使いのホーム ディレクトリの隠しフォルダ ~/.LinuxExecServer-<バージョン> に保存されています。ExecServer.log ログ ファイルは、Silk Central の Web インターフェイスからもアクセスすることが可能です。
注: 現在、Linux 実行サーバーに対してサポートされているソース管理システムは、Subversion、Git および Apache Commons Virtual File System (VFS) です。
以下の技術で作成されたテストでは、Linux 実行サーバーでの実行はサポートされません。
  • すべての Silk Test 技術
  • .NET Explorer
  • Unified Functional Testing
  • MSTest
  • NUnit
  • Silk Performer
  • TestPartner
  • Windows Script Host
これらのテスト タイプは、Microsoft Windows オペレーティング システムのプラットフォーム特有のものです。
親トピック: Silk Central のインストール
関連概念
実行サーバーを設定する
関連タスク
Windows 実行サーバーをインストールする


ホットフィックスをインストールする

ホットフィックスが利用可能になったとき、インスタンスを最新のホットフィックスに更新できます。
  1. Silk Central がインストールされているコンピュータ上で、セットアップ ファイルに移動してダブルクリックします。
  2. インストール ウィザードの指示に従います。
  3. インストールが完了したら、ブラウザを開き、URL http://localhost:19100/ に移動します（自動的に開かない場合）。
    注: リモート コンピュータからは インスタンス管理 ページにアクセスできません。
    インスタンス管理 ページが表示されます。この時点で、ブラウザー キャッシュを消去してください。消去しないと、JavaScript やスタイル シートに対する修正が有効にならないことがあります。
  4. アップグレードを開始するには、バージョン 列に表示された Hotfix <バージョン> のインストール リンクをクリックします。 メンテナンス モードを開始するためのダイアログが表示されます。
  5. Silk Central にアクセスしようとしたユーザーに対して表示されるテキストを入力します。例：現在、システムを更新中のため、Silk Central を利用できません。再びオンラインになるまで、しばらくお待ちください。はい をクリックすると、メンテナンス モードが開始され、アップグレードが始まります。
  6. 更新が完了したら、 開始 をクリックして、再びインスタンスを開始します。
インスタンス管理 のステップを、更新したいすべてのインスタンスに対して繰り返します。
ヒント: ブラウザー キャッシュを消去するようユーザーに通知してください。消去しないと、JavaScript やスタイル シートに対する修正が有効にならないことがあります。
親トピック: Silk Central のインストール
親トピック: インスタンスの管理


Silk Central 18.5 にアップグレードする

Silk Central 18.5 セットアップは、Silk Central 18.5 にアップグレードする前に既存のインストールを自動的に削除します。Windows の プログラムの追加と削除 機能を使用して以前の Silk Central をアンインストールすると、カスタマイズした設定ファイルも削除してしまうため、使用しないでください。

  1. 新しいバージョンへアップグレードを始める前に、Silk Central データベースのバックアップ コピーを作成してください。
  2. SSL を有効化している場合、証明書ファイルのバックアップ コピーを作成してください。フロントエンド サーバーを実行しているモードによって、次のパスのいずれかに証明書を再インポートする必要があります。
    • 64 ビット モードの場合：C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\lib\jre64\lib\security\cacerts
    • 32 ビット モードの場合：C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\lib\jre\lib\security\cacerts
    詳細については、「SSL による Web サーバーとのセキュアな接続を有効にする」を参照してください。
  3. Silk Central をインストールします。これにより、NGINX プロキシと インスタンス管理 がインストールされます。 前で挙げたコンポーネント群と同じコンピュータ上に、実行サーバーもインストールしたい場合には、他のコンポーネントと一緒に実行サーバーもインストールします。 データベースの設定は自動的に更新されます。設定ファイルの高度な設定についての情報は、 「高度な設定」を参照してください。
    注: 大きなデータベースの場合、データベース トランザクション ログのサイズが小さいと、アップグレード時にエラーが発生する可能性があります。エラーを回避するには、データベース トランザクション ログのサイズを 5 GB に設定します。
  4. インストールが完了したら、ブラウザを開き、URL http://localhost:19100/ に移動します（自動的に開かない場合）。
    注: リモート コンピュータからは インスタンス管理 ページにアクセスできません。
    インスタンス管理 ページが表示されます。この時点で、ブラウザー キャッシュを消去してください。消去しないと、JavaScript やスタイル シートに対する修正が有効にならないことがあります。
  5. アップグレードを開始するには、バージョン 列に表示された <バージョン> にアップグレード リンクをクリックします。 メンテナンス モードを開始するためのダイアログが表示されます。
  6. Silk Central にアクセスしようとしたユーザーに対して表示されるテキストを入力します。例：現在、システムを更新中のため、Silk Central を利用できません。再びオンラインになるまで、しばらくお待ちください。 はい をクリックすると、メンテナンス モードが開始され、更新が始まります。
  7. 更新が完了したら、 開始 をクリックして、再びインスタンスを開始します。
インスタンス管理 のステップを、更新したいすべてのインスタンスに対して繰り返します。
ヒント: ブラウザー キャッシュを消去するようユーザーに通知してください。消去しないと、JavaScript やスタイル シートに対する修正が有効にならないことがあります。
親トピック: Silk Central のインストール
関連概念
データベースへ接続する
関連タスク
Silk Central をインストールする
Windows 実行サーバーをインストールする
Linux 実行サーバーをインストールする


Silk Central のライセンス管理

このセクションでは、Silk Central のライセンス ポリシーの取得方法と、Silk Meter のインストール方法について説明します。 Silk Meter をインストールするには、管理者権限を持っている必要があります。

注: Silk Central には、Silk Meterバージョン 2008 以降と Silk Central ライセンス ポリシーが必要です。

Silk Meter のインストールは、ライセンス サーバー 1 つにつき 1 回です。 複数のライセンス サーバーを持っている場合には、複数のライセンス ポリシー ファイルが必要となります。各ファイルは、それぞれ特定のライセンス サーバーに関連付けられています。 1 つの Silk Meter ライセンス サーバーが、複数の製品のためのライセンス ポリシーを処理することができます。

Silk Central ライセンス ポリシーを既にお受け取りの場合には、そのライセンス ポリシーをライセンス サーバー上へインストールしてください。 ライセンス ポリシーをまだ受け取っていない場合には、ライセンス ポリシーを生成します。

  • ライセンスの扱い
    Silk Central で使用されるライセンス タイプと、ライセンスがチェック アウトおよびチェック インされる時期について説明します。
  • Silk Central ライセンス ポリシーを生成する
    Silk Central ライセンス ポリシーを生成します。これは後から Silk Meter へインポートすることができます。
  • ホスト ID を調べる
    ライセンスをインストールするコンピュータのホスト ID を調べます。Silk Central ライセンス ポリシー ファイルを得るためには、ホスト ID が必要です。
  • Silk Meter のインストール
    Silk Meter ライセンス サーバー ソフトウェアをインストールする前に知っておく必要がある事項について説明します。
  • Silk Meter ライセンス サーバーの構成
    Silk Meter ライセンス サーバーの構成について説明します。
  • ライセンス サーバーの構成を変更する
    Silk Meter ライセンス サーバーのホスト名またはポートが変更された場合は、ライセンス サーバーの設定を変更します。
親トピック: Silk Central のインストール
関連タスク
ライセンス サーバー上へ Silk Meter をインストールする


ライセンスの扱い

Silk Central は、さまざまな種類のライセンスを提供します。

1 ユーザー ライセンス

これらのライセンスは、ユーザーが Silk Central の特定の領域に入るとすぐにチェック アウトされます。

ライセンス タイプ | 領域
テスト管理 | このライセンスは、ログイン後に初めてテスト管理領域にアクセスしたときにチェック アウトされます。Silk Central テスト管理領域は、要件、テスト、実行計画、追跡、問題 (Issue Manager 領域を除く)、および レポート です。
手動テスト | このライセンスは、手動テスト ウィンドウを開いたときにチェック アウトされます。 手動テスト ライセンスは、テストがオフライン実行用にダウンロードされたときにチェックアウトされます。このライセンスは結果をアップロードした時に戻されます。
問題追跡 | このライセンスは、Issue Manager にアクセスしたときにチェック アウトされます。
次の点に注意します。
  • ログ アウト (ユーザー > ログアウト) をクリックすると、ライセンスはライセンス サーバーに再度チェック インされます (オフライン テスト用にチェックアウトされた手動テスト ライセンスは除く)。
  • ログ アウトしない (およびブラウザ ウィンドウを閉じただけの) 場合、ライセンスはセッションが期限切れになったときのみチェック インされます。

バージョン情報 ページ (ヘルプ > バージョン情報) には、現在使用中のライセンス数と、現在ログインしているクライアントに対して利用可能なライセンス数が表示されます。

サイト ライセンス

このライセンスは、すべてのユーザーに対して特定の機能セットを制限無しに有効にします。

ライセンス タイプ | 領域
モバイル テスト | このライセンスは、手動テスト、自動テスト、構成テストにおいて、モバイル デバイス（物理デバイス、エミュレータ、シミュレータ）上でテストできるようにします。
親トピック: Silk Central のライセンス管理
親トピック: クライアント
関連概念
デバイス プロバイダを管理する
関連タスク
クライアントを作成する
クライアントを編集する


Silk Central ライセンス ポリシーを生成する

Silk Central を実行するには、有効なライセンスが必要です。Silk Central を購入すると、オンラインのライセンス生成プログラムを使用してライセンス ポリシー ファイルを生成できます。オンラインのライセンス生成プログラムにアクセスするには、Firefox や Internet Explorer などの SSL 対応ブラウザが必要です。ライセンス ポリシー ファイルの生成方法に関する指示が含まれた電子メールを受け取ります。これらの指示がなかった場合は、http://support.microfocus.com でカスタマー ケアにお問い合わせください。

親トピック: Silk Central のライセンス管理
関連概念
Silk Central のインストール
関連タスク
ライセンス サーバー上へ Silk Meter をインストールする


ホスト ID を調べる

ライセンス ポリシー ファイルを得るためには、ライセンスをインストールするマシンのホスト ID を知る必要があります。フローティング ライセンスの場合は、Silk Meter がインストールされたライセンス サーバーです。ノードロック ライセンスの場合は、通常はコントローラ マシンになります。

  1. マシン上でコマンド プロンプトを開いて、コマンド ipconfig/all を入力します。 ネットワーク アダプタとさまざまな情報が表示されます。
  2. LAN カードの MAC アドレスまたは物理アドレスであるホスト ID (00-BF-00-1C-D3-3D など) を確認します。
    ヒント: 仮想マシンや VPN 接続が設定されている場合など、システムの設定によっては、コンピュータに異なる MAC アドレスを持つ複数のネットワーク アダプタが存在することがあります。物理 LAN カードのホスト ID を確認してください。
親トピック: Silk Central のライセンス管理


Silk Meter のインストール

Silk Central ライセンス ポリシー ファイルをお持ちの場合には、Silk Meter をインストールする際に、そのポリシーをインストールすることができます。有効な Silk Central ライセンスをお持ちでない場合は、オンラインのライセンス生成プログラムを使用してライセンス ポリシー ファイルを生成してください。

ライセンス サーバー上に Silk Meter をインストールして実行するためには、ライセンス ポリシー ファイルは必要ありません。しかし、Silk Centralを実行する前に、ライセンス ポリシー ファイルをインポートする必要があります。Silk MeterPolicy Administrator. を使用してライセンス ポリシー ファイルをインポートできます。

複数のライセンス サーバーを持っている場合には、複数のライセンス ポリシー ファイルが必要となります。各ファイルは、それぞれ特定のライセンス サーバーに関連付けられています。1 つの Silk Meter ライセンス サーバーで、複数の製品のライセンス ポリシー ファイルを管理できます。

Silk Meter ライセンス サーバーの要件

Silk Meter をインストールする前に、リリース ノートを参照して、ライセンス サーバーが要件を満たしていることを確認します。

  • 以前のバージョンの Silk Meter をアンインストールする
    最新バージョンをインストールする前に、Silk Meter をアンインストールします。
  • ライセンス サーバー上へ Silk Meter をインストールする
    Silk Meter ライセンス管理ソフトウェアをインストールして、Silk 製品のライセンスを管理します。
親トピック: Silk Central のライセンス管理
関連タスク
Silk Central ライセンス ポリシーを生成する


以前のバージョンの Silk Meter をアンインストールする

Silk Meter の以前のバージョンがライセンス サーバーにインストールされている場合は、最新バージョンの Silk Meter をインストールする前にアンインストールする必要があります。

  1. スタート > すべてのプログラム > Silk > Silk Meter > Uninstall を選択します。
  2. Yes をクリックして Silk Meter をアンインストールします。 Remove Settings ダイアログ ボックスが開きます。
  3. No をクリックした場合には、Silk Meter の設定が保持されます。
    重要: 現在、Silk Meter ライセンス サーバー上に存在するライセンス ポリシーを維持するには、No をクリックしなければなりません。
  4. コンピュータを再起動します。
Silk Meter がアンインストールされ、最新バージョンの Silk Meter がインストール可能になりました。
親トピック: Silk Meter のインストール


ライセンス サーバー上へ Silk Meter をインストールする

Silk Meter をインストールする前に、以下の情報を確認してください。
  • ユーザー アカウントに管理者権限があること。
  • Silk Meter のインスタンスがライセンス サーバーにインストールされていないこと。
  1. 製品更新サイト を開いて、Silk Meter を検索します。
  2. 最新の Silk Meterインストール ファイル をダウンロードし保存します。
  3. EXE ファイルを保存した場所まで移動して、ダブルクリックします。 標準インストールの場合、デフォルトのオプションで Silk Meter インストール ウィザードの指示に従ってください。
    重要: セットアップによってコンピュータを再起動することを要求された場合は、コンピュータを再起動します。
親トピック: Silk Meter のインストール
関連タスク
Silk Central ライセンス ポリシーを生成する


Silk Meter ライセンス サーバーの構成

Silk Central のいずれのバージョンを実行する場合にも、Silk Meter をネットワーク内にあるコンピュータ上にインストールし、構成しなければなりません。

Silk Central と Silk Meter の間の通信プロセスは、次のファイルおよび変数によって設定されています。
  • SILK_CONFIG_PATH 環境変数
  • CosLicensingService.ref ファイル
  • CosPropertyService.ref ファイル
  • ls_segue.ref ファイル
  • silkmeter.cfg ファイル
重要: これらのファイルは削除しないでください。

Silk Central セットアップ プログラムが、Select Silk Meter License Server ユーティリティのフィールドに入力された値を基に、これらのオブジェクトを作成します。

親トピック: Silk Central のライセンス管理
関連概念
Silk Central のインストール


ライセンス サーバーの構成を変更する

Select Silk Meter License Server ユーティリティを使用して、ライセンス サーバーの設定を変更または修正します。このユーティリティは、Silk Central セットアップによってインストールされます。

  1. スタート > すべてのプログラム > Silk > Silk Central 18.5 > 管理ツール > ライセンス サーバー構成の変更 を選択します。 Select Silk Meter License Server ユーティリティが開きます。
  2. Application リスト ボックスから、ライセンス サーバーを設定する製品を選択します。
  3. Using local or remote server オプション ボタンをクリックして、Silk Meter ライセンス サーバーを設定します。
  4. License Server Host フィールドに、Silk Meter ライセンス サーバーのコンピュータ名を入力します。 ネットワーク管理者が別のポートを定義したのでないかぎり、Port Number は変更しないでください。
  5. Apply をクリックして、ライセンス サーバーの設定をアクティブ化します。
  6. Test Connection をクリックして、指定したホスト、ポート上で Silk Meter サーバーがアクセス可能かどうかを確認します。 接続に成功すると、Status フィールドに SUCCESS メッセージが表示されます。
    注: 場合により、ライセンス サーバー ホスト フィールドに、ライセンス サーバーの名前を licenseserver など単純な名前で指定すると、うまくいかない場合があります。Silk Meter ライセンス サーバーとの接続に失敗しました というメッセージ ボックスが開きます。この問題を解決するには、licenseserver.mycompany.com など、完全修飾名によるホスト名を再度指定してください。
  7. Close をクリックして、ライセンス サーバーの設定を完了します。
親トピック: Silk Central のライセンス管理


テスト済みおよびサポートされているソフトウェア

このセクションでは、Silk Central18.5 がテストされたソフトウェア、および Silk Central がサポートするソフトウェアの一覧を示します。

サポートするオペレーティング システム

  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2016
  • Microsoft Windows 7 32 ビット/64 ビット サービス パック 1 (実行サーバー)
  • Microsoft Windows 8.1 32 ビット/64 ビット (実行サーバー)
  • Microsoft Windows 10 32 ビット/64 ビット (実行サーバー)
  • Android 4.4、5.x、6.x、7.x、8.x (モバイル デバイスのテスト)
  • iOS 9.3、10.x、11.x (モバイル デバイスのテスト)
重要: 「Windows での汎用の C ランタイムの更新プログラム」は、すべての Microsoft Windows オペレーティング システムで必要です。Microsoft Windows Server 2016 の場合、Windows Server (デスクトップ エクスペリエンス) インストール オプションを選択する必要があります。

サポートする Linux オペレーティング システム

Silk Central は、Linux オペレーティング システムを実行サーバーに限りサポートします。

  • Debian
  • Redhat Enterprise Linux
  • Suse Linux
  • Ubuntu

サポートする Web ブラウザ

  • Google Chrome
  • Internet Explorer 10 以降 (互換モード以外)
  • Mozilla Firefox
  • Microsoft Edge

サポートする Web サーバー

  • IIS 8 32 ビット/64 ビット
  • IIS 10 32 ビット/64 ビット

サポートするデータベース管理システム

  • Microsoft SQL Server 2012 サービス パック 3
  • Microsoft SQL Server 2014 サービス パック 2
  • Microsoft SQL Server 2016
  • Oracle 11g (バージョン 11.2.0.4)
  • Oracle 12c (バージョン 12.1.0.2)

サポートする統合された Micro Focus ソフトウェア

  • AccuRev 6.2
  • Caliber 11.4、11.5
  • Mobile Center 2.51 以降
  • Silk Performer 18.5
  • Silk Test 18.5
  • StarTeam 15.x、16.x
  • Silk TestPartner 6.3
  • Unified Functional Testing (UFT) 14.0

サポートする統合されたサードパーティ ソフトウェア

  • Apache Commons Virtual File System (VFS)
  • Atlassian JIRA 6、7
  • Bugzilla 4.4.12、5.0.3
  • CA Agile Central
  • Git 2.14.2
  • IBM Rational ClearQuest 8.0
  • IBM Rational DOORS 9.5、9.6
  • IBM Rational DOORS Next Generation 6.0
  • IBM Rational RequisitePro 7.1.3、7.1.4
  • JUnit 4.11 以降
  • Microsoft Office Excel (.xlsx) (テストと要件のインポート用)
  • Microsoft Office Word (.doc、.docx) (要件のインポート用)
  • Microsoft Visual Studio/Visual Studio Test Agent 2012、2013、2015
  • NUnit 2.6.4、3.4.1
  • SAP Solution Manager 7.1
  • Subversion 1.9
  • Team Foundation Server 2012、2013、2015
  • VersionOne Enterprise Edition
  • VMware vCloud Director 5.5
親トピック: Silk Central のインストール


インフラストラクチャの構成と管理

インスタンスは、独立した Silk Central サービス群（アプリケーション サーバー（AS）、フロントエンド サーバー（FE）、チャート サーバー（CS））で、それ自身のデータベースと実行サーバー（ES）との接続を持ちます。デフォルトでは、Silk Central は silk という名前のインスタンスを 1 つだけ作成します。 デフォルトの URL は、http://<コンピュータ名>:19120/login (IIS 上で Silk Central を実行する場合はポート番号は不要です) です。

  • セキュアな Silk Central システムのセットアップ
    このセクションでは、セキュアな Silk Central システムをセットアップする方法について説明します。
  • インスタンスの管理
    Silk Central インスタンスの追加、削除、メンテナンスを行います。
  • クライアントの管理
    システム管理 領域は、Silk Central のクライアントの設定を行うのに使用される個別の環境です。
  • 高度な設定
    高度な設定によって Silk Central システムをカスタマイズする方法について説明します。
親トピック: インストールとシステム設定ヘルプ


セキュアな Silk Central システムのセットアップ

このセクションでは、セキュアな Silk Central システムをセットアップする方法について説明します。
  • 一般的なガイドライン
    Silk Central をインストールしたら、セキュアな環境になるように Silk Central をセットアップするために、次のガイドラインを考慮する必要があります。
  • SSL による Web サーバーとのセキュアな接続を有効にする
    セキュアな接続 (SSL: Secure Sockets Layer) だけを使用して Silk Central にアクセスさせたい場合は、SSL を使用するように Silk Central を設定します。
  • SSL 環境で BIRT レポートを有効にする
    Silk Central を SSL を使用したセキュアな Web サーバー接続を使用するように構成した場合、この環境で BIRT レポートが機能するように設定する必要があります。
  • 実行サーバーの標準ではない SSL ポートを設定する
    アプリケーション サーバーが実行サーバーと通信するためのカスタム SSL ポートを設定します。
  • 実行サーバー上の使用されていないポートを無効にする
    実行サーバーで使用されていないポートを無効にします。
  • SSL による外部システムとの通信
    自己署名証明書を持つホストと SSL 経由で通信するには、デフォルトの Java キーストアに自己署名証明書を追加します。
親トピック: インフラストラクチャの構成と管理


一般的なガイドライン

Silk Central をインストールしたら、セキュアな環境になるように Silk Central をセットアップするために、次のガイドラインを考慮する必要があります。
  • まずはじめに、sysadmin のデフォルトのパスワードを変更します。詳細については、「Silk Central システム管理者」を参照してください。
  • LDAP サーバーを使用して Silk Central にログインできるようにするには、LDAP 認証を構成します。詳細については、「LDAP 認証」を参照してください。
  • 複数のグループが Silk Central を使用する場合は、ユーザーが想定されたデータだけにアクセスできるように、インスタンスやクライアントを作成します。詳細については、「インスタンスの管理」および「クライアントの管理」を参照してください。
  • 詳細クエリによるレポートの実行によりデータベース内のデータが変更されないようにするために、読み取り専用のデータベース ユーザーを作成して使用するようにします。詳細については、「[データベース] ページ」を参照してください。
  • Silk Central が使用するポートだけが開かれるように、ファイアウォールを設定します。Silk Central が使用するポートの詳細については、「Silk Central アーキテクチャ」を参照してください。
  • データベースのバックアップを定期的に行います。
  • 最新のサポートされているバージョンのオペレーティング システムを使用して、アップデートが定期的に適用されるようにします。
  • Silk Central の最新のバージョンおよびホットフィックスを使用します。最新のサポートからのお知らせを入手したり、その他のサポート情報にアクセスするために、Micro Focus SupportLine に登録します（http://supportline.microfocus.com）。
親トピック: セキュアな Silk Central システムのセットアップ


SSL による Web サーバーとのセキュアな接続を有効にする

セキュアな接続 (SSL: Secure Sockets Layer) だけを使用して Silk Central にアクセスさせたい場合は、SSL を使用するように Silk Central を設定します。

詳細については、「SSL による外部システムとの通信」、「SSL 環境で BIRT レポートを有効にする」、「実行サーバーの標準ではない SSL ポートを設定する」を参照してください。

  1. 証明書とキー ファイルをフロントエンド サーバーのコンピュータにコピーします。
  2. nginx.conf.template ファイル（C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf）をテキスト エディターで開きます。
  3. 次の行の # を削除してコメントを解除します。
    #listen   443 ssl;
#ssl_protocols TLSv1.2 TLSv1.1 TLSv1;
#ssl_certificate    "C:/.../ssl/host.cert";
#ssl_certificate_key    "C:/.../ssl/host.key";
#add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
  4. ssl_certificate と ssl_certificate_key のパスを、証明書とキー ファイルをコピーした場所に設定します。バックスラッシュの代わりにスラッシュを使用してパスを指定します。
  5. SSL 接続のみを許可したい場合は、listen 19120; の行に # を追加してコメントにします。
  6. 省略可能：非セキュア ポートからセキュア ポートへリダイレクトするように設定するには、次の構文の新しい server セクションを追加します。
    server {
  listen <非セキュア ポート>;
  server_name localhost;
  return 301 https://$host$request_uri;
  }
  7. Windows サービス マネージャーを使用して、Silk Central Instance Administration Service を再起動します。
親トピック: セキュアな Silk Central システムのセットアップ


SSL 環境で BIRT レポートを有効にする

Silk Central を SSL を使用したセキュアな Web サーバー接続を使用するように構成した場合、この環境で BIRT レポートが機能するように設定する必要があります。
  1. インスタンス管理 ページを使用して、設定するインスタンスのチャート サーバー サービスを停止します。
  2. 次のコマンド ラインを実行して、OpenSSL を使用して PKCS #12 キーストアを作成します：openssl pkcs12 -export -in ./host.cert -inkey ./host.key > ./host.p12 例：
    openssl pkcs12 -export -in C:/ProgramData/SilkCentral/ssl/host.cert -inkey
C:/ProgramData/SilkCentral/ssl/host.key > C:/ProgramData/SilkCentral/ssl/host.p12
  3. 次のコマンド ラインを実行して、host.p12 キーストアを Java キーストアに変換します：keytool.exe -importkeystore -srckeystore ./host.p12 -destkeystore ./host.jks -srcstoretype pkcs12 例：
    "C:\Program Files (x86)\Silk\Silk Central
18.5\instance_1_silk\lib\jre\bin\keytool.exe"
-importkeystore -srckeystore C:/ProgramData/SilkCentral/ssl/host.p12 -destkeystore
C:/ProgramData/SilkCentral/ssl/host.jks -srcstoretype pkcs12
  4. チャート サーバー構成ファイル sc_ChartServer.processconfig（C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<インスタンス番号>_<インスタンス名>\Conf にあります）に次の行を追加します。
    <Service>
  <SystemProperties>
          ...
             <SystemProperty name="javax.net.ssl.trustStore" value="<host.jks ファイルへのパス>" />
             <SystemProperty name="javax.net.ssl.trustStorePassword" value="<パスワード>" />
        </SystemProperties>
</Service>
    例：
    <Service>
  <SystemProperties>
          ...
             <SystemProperty name="javax.net.ssl.trustStore" value="C:/ProgramData/SilkCentral/ssl/host.jks" />
             <SystemProperty name="javax.net.ssl.trustStorePassword" value="changeit" />
        </SystemProperties>
</Service>
  5. チャート サーバー サービスを再起動します。
親トピック: セキュアな Silk Central システムのセットアップ


実行サーバーの標準ではない SSL ポートを設定する

アプリケーション サーバーが実行サーバーと通信するためのデフォルト SSL ポートは、19125 です。

注: この手順は、標準ではない SSL ポートから接続する実行サーバーごとに行う必要があります。

実行サーバーの標準ではない SSL ポートを設定するには：

  1. 標準ではない SSL ポートを設定する実行サーバーを非アクティブにします。
  2. 実行サーバーを停止します。
  3. SccExecServerBootConf.xml ファイルをテキスト エディタで開きます。 このファイルは、実行サーバー上の Silk Central ディレクトリの /conf/execserver フォルダにあります。
  4. <SSLPort> という XML タグを探します。 このタグは、デフォルトで <19125> に設定されています。 この値を SSL 通信で使用するポート番号に変更します。
  5. XML ファイルを保存して閉じます。
  6. Silk Central で、XML ファイルに指定した値を実行サーバーの SSL ポートに設定します。
  7. 実行サーバーを再起動します。
  8. 実行サーバーを再びアクティブにします。
親トピック: セキュアな Silk Central システムのセットアップ
親トピック: 実行サーバーを設定する
関連タスク
ローカル実行サーバー サービスを開始または停止する
実行サーバーをアクティブまたは非アクティブにする
物理実行サーバーを設定する


実行サーバー上の使用されていないポートを無効にする

アプリケーション サーバーと実行サーバーの間で、SSL 通信または通常の (セキュアではない) 通信のどちらを使用しているかによって、場合により使用されていないポートを無効にします。デフォルトの Tomcat ポートを無効にすることもできます。 Silk Central は、このポートを使用しません。

使用されていないポートを無効にするには、実行サーバーごとに次の手順を実行する必要があります。

実行サーバー上の使用されていないポートを無効にするには：

  1. 実行サーバーを停止します。
  2. SccExecServerBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、実行サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5 Execution Server\conf\execserver になります。
  3. ファイルの RmiProxy セクションで InsecurePort および SSLPort という XML タグを探します。
  4. アプリケーション サーバーと実行サーバーの間で、SSL 通信または通常の通信のどちらを使用しているかによって、次の設定を行います。
    SSL 通信
    InsecurePort の値を 0 に設定します。
    通常の通信
    SSLPort の値を 0 に設定します。
  5. XML ファイルを保存して閉じます。
  6. 実行サーバーを再起動します。
親トピック: セキュアな Silk Central システムのセットアップ
親トピック: 高度な設定
関連タスク
インスタンスの管理


SSL による外部システムとの通信

接続先ホストの証明書が自己署名されている場合は、次のようなエラー メッセージが表示される場合があります。
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
注: 認証機関で署名された有効な証明書の場合、このエラー メッセージは表示されません。

自己署名証明書が設定されたサーバーを使用するには、次の手順を実行する必要があります。

  1. サーバーから SSL 証明書をダウンロードします。 ブラウザを使用して証明書を表示し、証明書をエクスポートします。たとえば、Mozilla Firefox では、ツール > ページの情報 > セキュリティ > 証明書を表示 > 詳細 > エクスポート に移動します。
  2. キーおよび証明書管理ツールの Keytool を起動します。 Keytool は JRE インストール環境に含まれており、JRE インストール フォルダにあります (C:\Program Files (x86)\Silk\Silk Central <バージョン>\instance_<インスタンス番号>_<インスタンス名>\lib\jre\bin など)。Keytool に関する情報は、『Java SE Technical Documentation』を参照してください。
  3. フロントエンド サーバーおよびアプリケーション サーバーでデフォルトの Java キーストアに証明書を追加するには、Keytool で次のコマンドなどを入力します。
    keytool
  -importcert
  -file CERTIFICATE.crt
  -keystore "C:\Program Files (x86)\Silk\Silk Central <version>\
   instance_<instance number>_<instance name>\lib\jre\lib\security\cacerts"
    パスワードを入力するようプロンプトが表示されます。
  4. デフォルトのキーストア パスワード changeit を入力します。
  5. フロントエンド サーバーおよびアプリケーション サーバーを再起動して、キーストアを再読み込みします。
親トピック: セキュアな Silk Central システムのセットアップ
親トピック: 統合


インスタンスの管理

データ セキュリティを高め、独立したユーザー グループ（事業部など）間での互いの影響を低減させるために、さまざまなクライアントの処理やテスト データ自身を物理的に分離する必要がある場合に、別のインスタンスを作成します。クライアント機能を使用すると、1 つのデータベース内の 1 つのインスタンスのデータを論理的に分離することができます。

インスタンスの管理

インスタンスと Silk Central サービスは、インスタンス管理 という共通 UI を通じて管理されます。この UI には、Silk Central をインストールしたサーバー上からのみ、http://localhost:19100 という URL を使用してアクセスできます。 リモート コンピュータからは インスタンス管理 ページにアクセスできません。以下のアクションをインスタンスまたは個々のサービスに対して実行できます。
  • サービスを個別に停止または開始するには、 停止 または 開始 をクリックします。インスタンスを停止または開始すると、インスタンスのすべてのサービスが停止または開始します。
  • インスタンスを削除するには、 インスタンスの削除 をクリックします。インスタンスが本当に必要ないことを確認してから、このアクションを使用してください。このアクションは、データベース中のデータの削除は行いません。
    注: 実行サーバーを他のアプリケーション サーバーに割り当てるには、実行サーバーをインストールしたコンピュータ上で次のファイルを削除する必要があります：C:\ProgramData\SilkCentral\AgentBase\ItemObjects.ser
  • インスタンスの設定を変更するには、 設定 をクリックします。

メンテナンス モード

新しいホットフィックスをインストールしたり、サービスの設定を変更する場合など、Silk Central インスタンスにユーザーがアクセスできないようにして、インスタンスのメンテナンスを実行します。このとき、インスタンスがメンテナンス中であることを、Silk Central ユーザーに知らせることができます。
  1. インスタンス管理 ページで、 設定 をクリックして、設定 ダイアログを開きます。
  2. メンテナンス タブで、メンテナンス モードを開始する チェック ボックスをオンにします。
  3. Silk Central にアクセスしようとしたユーザーに対して表示されるテキストを入力します。例：現在、システムを更新中のため、Silk Central を利用できません。再びオンラインになるまで、しばらくお待ちください。
  4. OK をクリックします。
  5. メンテナンスが完了し、すべてのサービスが再び実行されたら、メンテナンス モードを停止し、ユーザーが Silk Central に再びアクセスできるようにします。

32 ビット/64 ビット モード

  1. インスタンス管理 ページで、 設定 をクリックして、設定 ダイアログを開きます。
  2. フロントエンド サーバー、アプリケーション サーバー、チャート サーバーのサービスを 32 ビット モードで実行するか、64 ビット モードで実行するかを変更する場合は、インスタンス タブの モード リストを使用します。64 ビット モードでサービスを実行するには、64 ビット オペレーティング システムが必要です。モードを変更するには、インスタンス サービスを停止する必要があります。
  3. OK をクリックします。

JMX 測定

JMX の情報にアクセスしたり、オペレーションを実行するには、JMX 接続文字列が必要です。 設定 をクリックして、設定 ダイアログを開きます。サーバー タブで、目的のサーバーを選択し、JMX 接続 に表示されている文字列をコピーします。詳細については、「JMX 設定を構成する」を参照してください。

新しいインスタンスの作成

追加のインスタンスを作成するには、インスタンスの新規作成 をクリックします。インスタンスの名前は、インスタンスのサービスやファイルを識別するのに使用したり、ユーザーがインスタンスにアクセスする URL の一部になるため、意味のある名前をつけることをお勧めします。

追加するインスタンスごとに、最低 10 GB の追加のディスク容量と、次の最低メモリが必要になります。
  • フロントエンド サーバー：500 MB
  • アプリケーション サーバー：300 MB
  • チャート サーバー：200 MB
作業内容に応じて、これらの値はより高くなる可能性があります。

Silk Central の最適な構成の詳細については、テクニカル サポートまたはテクニカル アカウント チームに問い合わせてください。

  • ホットフィックスをインストールする
    ホットフィックスが利用可能になったとき、インスタンスを最新のホットフィックスに更新できます。
  • ローカル実行サーバー サービスを開始または停止する
    Silk Central Service Manager を使用すると、ローカルにインストールした実行サーバー サービスを開始または停止できます。
  • フロントエンド サーバーのロード バランシング
    ロード バランシングは、いくつかのサーバー上に負荷（Web トラフィック）を分散し、パフォーマンスと信頼性を高めて、ユーザー エクスペリエンスの向上を実現するために使用されます。
親トピック: インフラストラクチャの構成と管理
関連概念
Silk Central のアーキテクチャ


ローカル実行サーバー サービスを開始または停止する

Silk Central Service Manager を使用すると、ローカルにインストールした実行サーバー サービスを開始または停止できます。
  1. Windows タスク バーの Silk Central Service Manager トレイ アイコンをダブルクリックします。 Silk Central Service Manager ダイアログが表示されます。
  2. Start または Stop をクリックして、実行サーバー サービスを開始または停止します。
  3. Query Status をクリックすると、サービスの現在のステータスを確認できます。
  4. リアルタイムの動作を監視したい場合は、コンソール ウィンドウを表示して Silk Central 実行サーバーを起動します：
    1. Start with console チェック ボックスをオンにします。
    2. Stop をクリックします。
    3. Start をクリックします。
  5. Execution Server Logfile をクリックすると、ログ ファイルを表示できます。 登録されているテキスト エディタでログ ファイルが開きます。
  6. OK をクリックして 実行サーバー サービスの管理を終了します。 Service Manager が閉じますが、システム トレイではアクティブなままです。
親トピック: インスタンスの管理


フロントエンド サーバーのロード バランシング

ロード バランシングは、いくつかのサーバー上に負荷（Web トラフィック）を分散し、パフォーマンスと信頼性を高めて、ユーザー エクスペリエンスの向上を実現するために使用されます。

Silk Central のフロントエンド サーバーのロード バランシングでは、追加のフロントエンド サーバーの情報を NGINX プロキシ構成に追加することによって、NGINX がフロントエンド サーバー間での負荷の分散を行います。

  • フロントエンド サーバーに対するロード バランシングの設定
    ロード バランシングするように追加のフロントエンド サーバーをセットアップし、設定する方法について説明します。
親トピック: インスタンスの管理


フロントエンド サーバーに対するロード バランシングの設定

Silk Central インスタンスを実行しており、このインスタンスのユーザーが負荷の増大によるパフォーマンスの問題を感じた場合、負荷を分散するために追加のフロントエンド サーバーをセットアップできます。

最初の状況：
  • サーバー A 上に Silk Central をインストールしている。
  • 実行中のインスタンスのパフォーマンスが不足している。
  • 負荷を分散するためにフロントエンド サーバーを追加したい。

ロード バランシングするために、このインスタンスにフロントエンド サーバーを追加するには：

  1. Silk Central のセットアップを使用して サーバー B 上に Silk Central をインストールします。
  2. セットアップが完了したら、サーバー B 上の インスタンス管理 ページにアクセスします（http://localhost:19100）。
  3. フロントエンド サーバーだけが必要なので、ロード バランシングに使用するインスタンスのアプリケーション サーバーとチャート サーバーを停止します。
  4. 設定 をクリックして、インスタンスの 設定 ダイアログを開きます。サーバー タブで、フロントエンド サーバーを選択し、フロントエンド サーバーのポート をコピーします。
  5. サーバー A 上で インスタンス管理 ページにアクセスします（http://localhost:19100）。
  6. 設定 をクリックして、パフォーマンスが不足しているインスタンスの 設定 ダイアログを開き、メンテナンス モードを開始します。
  7. ファイル システムで、NGINX カスタム プロパティ ファイル（C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf\nginxCustom.properties）を開き、サーバー B 上のフロントエンド サーバーの URL（<サーバー名>:<ポート>）を追加します。ここで、ポートはコピーした フロントエンド サーバーのポート を使用します。 記述方法：frontendservers.<インスタンス名>=<FE_URL1>{,<FE_URL2>,...,<FE_URLX>}

    例：frontendservers.silk=localhost:19110,silkserver2:19320

    重要: NGINX の制約のため、フロントエンド サーバーのポート 19120 を使用することはできません。ポート番号は、必ずステップ 4 で述べた [設定] ダイアログから取得してください。
  8. パフォーマンスが不足しているインスタンスの インスタンス管理 ページに戻り、 設定 をクリックして、 設定 ダイアログを開きます。サーバー タブで、アプリケーション サーバーを選択し、アプリケーション サーバーのポート をコピーします。
  9. サーバー B 上のフロントエンド サーバーと サーバー A 上のインスタンスのアプリケーション サーバー間の接続を確立するために、Web ブラウザーを開き、サーバー B のフロントエンド サーバーに http://<サーバー B>:<フロントエンド サーバーのポート> を使用して直接アクセスします。19120 ではなく、[設定] ダイアログのポートを使用してください。
  10. アプリケーション サーバーの接続ページで、ホストまたは IP アドレス とコピーした サーバー A の アプリケーション サーバーのポート を入力します。
  11. インスタンス管理 ページに戻り、メンテナンス モードを解除します。これにより、NGINX の設定が更新されます。

ユーザーが以前と同じ URL を使ってインスタンスにアクセスすると、サーバー A とサーバー B 上のフロントエンド サーバー間で自動的にロード バランシングされます。

親トピック: フロントエンド サーバーのロード バランシング


クライアントの管理

システム管理 領域を使用すると Silk Central のクライアントの設定を行うことができます。クライアントの設定はには、次の作業が含まれます。

  • データベースの作成、接続、切断。
  • クライアントの作成、管理。
  • Silk Central クライアントのインフラストラクチャの設定 (チャート サーバー、電子メール サーバー、プロキシ接続)。
  • 診断情報とシステム ログ ファイルの分析による、システム サービスのメンテナンス。
  • Silk Central システム管理者
    Silk Central システム管理者のロールおよび目的について説明します。
  • データベース
    Silk Central でのデータベースの使用方法について説明します。
  • クライアント
    クライアントは Silk Central インスタンス内の個別のユニットです。クライアントには顧客または企業内の部門などを設定できます。クライアントはセキュリティを向上させますが、インスタンスとは異なり、同じデータベースと Silk Central サービスが共有されます。
  • インフラストラクチャ
    システム インフラストラクチャを構成するチャート サーバー、電子メール サーバー、システム プロキシについて説明します。
  • システム診断
    [システム診断] タブについて説明します。
親トピック: インフラストラクチャの構成と管理
関連概念
Silk Central のアーキテクチャ


Silk Central システム管理者

Silk Central システム管理者は システム管理 領域にアクセスできる唯一のユーザーであり、Silk Central システム管理者はこの領域にしかアクセスできません。 このユーザーは実際の Silk Central ユーザー インターフェイスへのアクセス権限を持ちません。

システム管理 領域にアクセスするには、次の認証情報を使用します。
  • ユーザー名：sysadmin
  • パスワード：sysadmin
重要: できるだけ早くこのデフォルトのパスワードを変更してください。 Silk Central データベースに最初に接続した後に変更することをお勧めします。 パスワードを変更するには、システム管理 領域 (右上) のメニューの パスワードの変更 をクリックします。 ユーザー名は変更できません。

データベースに接続していない場合は、Silk Central システム管理者は自動的に システム管理 領域に移動します。

親トピック: クライアントの管理


データベース

Silk Central はデータベースを使用して、データの格納、維持管理、分析を行います。Silk Central を使用する前に、データベースへの接続を確立する必要があります。複数のデータベースを構築できますが、一度に接続できるデータベースは 1 つだけです。新しいデータベースに接続するには、まず現在のデータベースから切断する必要があります。

データベース接続を設定するには、システム管理 領域の データベース ページに移動します。Silk Central システム管理者のみがこのページにアクセスできます。詳細については、「Silk Central システム管理者」を参照してください。

データベースの切断が必要な管理タスクは、ユーザーのいない時間帯に実行してください。システムを利用できなくなることとその期間について、ユーザーに必ず通知してください。データベースの設定についての詳細は、SupportLine にお問い合わせください。 Microsoft SQL Server を使用している場合、『Silk Central MSSQL Server Recommendations』を読まれることをお勧めします。

  • リレーショナル データベース管理システムを選択する
    リポジトリとして使うリレーショナル データベース管理システム (RDBMS) を選択します。
  • データベース ユーザーの権限
    データベース ユーザーに特定のロールを割り当てることにより、特殊なタスクを行えるようになります。
  • データベースを作成する
    新しいデータベースを作成する方法を説明します。
  • データベースへ接続する
    Silk Central データベースへの接続方法について説明します。
  • データベースから切断する
    Silk Central データベースから切断する方法について説明します。
  • ALM リポジトリ ID
    リポジトリが識別される仕組みについて説明します。
  • ALM URI
    ALM URI が使用される仕組みについて説明します。
  • [データベース] ページ
    データベース ページを使用したデータベースへの接続、およびデータベースからの切断方法について説明します。
親トピック: クライアントの管理
関連概念
Silk Central システム管理者
関連資料
[データベース] ページ


リレーショナル データベース管理システムを選択する

Oracle または Microsoft SQL Server を、各リレーショナル データベース管理システム (RDBMS) のドキュメントの指示に従い、インストールして設定します。

Silk Central は次のデータベース管理システムをサポートします。
  • Microsoft SQL Server 2012 サービス パック 3
  • Microsoft SQL Server 2014 サービス パック 2
  • Microsoft SQL Server 2016
  • Oracle 11g (バージョン 11.2.0.4)
  • Oracle 12c (バージョン 12.1.0.2)

以下の表では、各データベース タイプに対する要件が記載されています。

RDBMS 用意するもの
Oracle
  • Oracle 表領域。
  • サーバーのホスト名とポート番号、または Single Client Access Name（SCAN）。デフォルトのポートは 1521 です。
  • Oracle のインスタンス名（$ORACLE_SID）。
  • Silk Central データベース ユーザーの名前とパスワード。ここでのユーザーは、十分な割り当て領域と権限を持っている必要があります。
これについて手助けが必要な場合には、必要に応じて Oracle の管理者にお問い合わせください。
注: Oracle はデータベースを作成するのではなく、特定のユーザー名に割り当てられるスキーマを作成します。このため、データベース名は、Oracle データベースに割り当てられるのではなく、代わりにユーザー名に割り当てられます。Silk Central は、このようなユーザー名を データベース名 として参照します。
Microsoft SQL Server
  • サーバーのホスト名とポート番号。
  • MS SQL Server のシステムユーザー名とパスワード。
  • Silk Central データベースの名前。
  • Silk Central データベース ユーザーの名前とパスワード。
注: Silk Central は、大文字/小文字を区別しないようにセットアップされた Microsoft SQL Server サーバーのみをサポートします。Microsoft SQL Server Express は、完全なデータベース サーバー インストールと比較して、機能が制限されているため、運用環境で使用することはできません。
親トピック: データベース


データベース ユーザーの権限

セキュリティ リスク上、Silk Central データベースの維持管理にデータベースの管理者ユーザーを利用することは、推奨していません。このトピックでは、次のように、特定のタスクで使用することのできるデータベース ロールについて一覧表示します：

Microsoft SQL Server
Microsoft SQL Server を Silk Central の DBMS とする場合、Silk Central データベースに対して次のデータベース ユーザー ロール/権限が必要になります。
いずれか または
  • db_owner
  • db_ddladmin
  • サーバー状態の表示
  • db_datareader
  • db_datawriter
  • db_ddladmin
  • 実行
  • サーバー状態の表示
これらのロールと権限によって、データベースのテーブルの作成や設定、作成済みのデータベースでの作業、ソフトウェアのインストールや更新が許可されます。
注: Silk Central データベース ユーザーには、これらのロールと権限が必要となります。さもなければ、エラーが発生します。
Oracle
Oracle を Silk Central の DBMS とする場合、Silk Central で作業するために、次の Oracle データベース ユーザー権限を設定します。
  • CREATE SESSION
  • CREATE PROCEDURE
  • CREATE SEQUENCE
  • CREATE TABLE
  • CREATE TRIGGER
  • CREATE VIEW
注: Silk Central データベース ユーザーには、前出のすべての権限が必要となります。さもなければ、エラーが発生します。システム診断ですべてのデータベース関連の分析データを取得するには、さらに SELECT_CATALOG_ROLE をデータベース ユーザーに割り当てることを推奨します。
注: ここでの Oracle ユーザーは、Silk Central で作業するために、十分な割り当て領域を持っている必要があります。
Silk Central に対して Oracle DBMS を設定している場合には、Oracle の環境が次の要件を満たしているかどうか確認してください：
  • 最低 2GB の一時表領域が利用可能であること。
  • 一時表領域のサイズを処理するために十分なディスク領域があること。
親トピック: データベース


データベースを作成する

現在、Silk Central がデータベースに接続している場合は、新しいデータベースを作成する前に、データベースを切断する必要があります。

注: 評価セットアップ パッケージを使用して Silk Central をインストールした場合、demodb という名前のデモ データベースが自動的に作成され、接続されます。この場合、以下の手順を行う必要はありません。

データベースを新規作成するには：

  1. 既に Silk Central アプリケーション サーバーがセットアップされている場合、ブラウザ ウィンドウに データベース ページが表示されます。この場合、ステップ 3 に進みます。
    ヒント: または、Web ブラウザで Silk Central サイトを参照してもかまいません。デフォルトの URL は、http://<コンピュータ名>:19120/login (IIS 上で Silk Central を実行する場合はポート番号は不要です) です。 Silk Central のインストール時に 標準セットアップ オプションを使用した場合は、アプリケーションに接続するとすぐに データベース ページが表示されます。フロントエンド サーバーがインストールされているコンピュータで、スタート > プログラム > Silk > Silk Central > Silk Central18.5 > Silk Central Home Page を選択してもかまいません。
  2. Silk Central に Silk Central システム管理者としてログインします。 詳細については、「Silk Central システム管理者」を参照してください。
  3. メニューで データベース をクリックします。
  4. 新しいデータベースを設定します。 詳細については、「[データベース] ページ」を参照してください。 データベースを作成できる環境は、ローカルにインストールされた Microsoft SQL Server 2008 Express SP1、ローカルにインストールされた Microsoft SQL Server または Oracle、あるいは Microsoft SQL Server または Oracle がインストールされているネットワーク サーバーです。Silk Central では、以下をサポートしています。
    • Microsoft SQL Server 2012 サービス パック 3
    • Microsoft SQL Server 2014 サービス パック 2
    • Microsoft SQL Server 2016
    • Oracle 11g (バージョン 11.2.0.4)
    • Oracle 12c (バージョン 12.1.0.2)
  5. データベースに接続 をクリックし、はい をクリックします。 データベースの新規作成 ダイアログ ボックスが表示されます。
  6. データベース管理者の認証情報を入力し、OK をクリックします。
    ヒント: ローカルで (またはネットワークで) Microsoft SQL Server データベースまたは Oracle データベースを作成している場合は、データベース管理者から提供されたログイン情報を入力します。
    ALM リポジトリ ID の作成 ダイアログ ボックスが表示されます。
  7. 一意の ALM リポジトリ ID を入力し、OK をクリックします。
  8. リポジトリが正常に作成されたことが通知されます。OK をクリックします。 ログイン ページが表示されます。
データベースが作成され、接続されます。これでユーザー名とパスワードを使用して Silk Central にログインできるようになりました。
親トピック: データベース
関連概念
Silk Central システム管理者
関連資料
[データベース] ページ


データベースへ接続する

データベースに接続するには：

  1. Web ブラウザで、Silk Central サイトを参照します。 デフォルトの URL は、http://<コンピュータ名>:19120/login (IIS 上で Silk Central を実行する場合はポート番号は不要です) です。
    注: 現在データベースに接続していない場合には、システム管理 領域に自動的に移動します。
  2. Silk Central に Silk Central システム管理者としてログインします。 詳細については、「Silk Central システム管理者」を参照してください。
  3. メニューで データベース をクリックします。
  4. データベースから切断 をクリックし、現在のデータベースから切断します。 データベース ページに移動します。
  5. 必要に応じて設定を変更します。 詳細については、「[データベース] ページ」を参照してください。
  6. データベースに接続 をクリックします。
データベースへの接続の確立には、数分から最大で数時間かかることがあります。接続が確立されると、ダイアログ ボックスが表示されます。OK をクリックします。Silk Central ログイン ページが表示されます。
親トピック: データベース
関連概念
Silk Central システム管理者
関連資料
[データベース] ページ


データベースから切断する

データベースとの接続を解除するには：

  1. Web ブラウザで、自分の Silk Central サイトを参照します。 デフォルトの URL は、http://<コンピュータ名>:19120/login (IIS 上で Silk Central を実行する場合はポート番号は不要です) です。
  2. Silk Central に Silk Central システム管理者としてログインします。 詳細については、「Silk Central システム管理者」を参照してください。
  3. メニューで データベース をクリックします。
  4. データベースから切断 をクリックし、現在のデータベースから切断します。 データベース ページに移動します。
親トピック: データベース
関連概念
Silk Central システム管理者
関連資料
[データベース] ページ


ALM リポジトリ ID

各 Silk Central データベースには、一意のリポジトリ ID が割り当てられている必要があります。 この ID は、Silk Central の要件やテストを複数の Silk Central リポジトリにわたって一意に識別するために、ALM URI で使用されます。 リポジトリ ID は、会社の Silk Central インストールの中で一意でなければなりません。 与えられたリポジトリ ID は、ALM URI の一部になります。 ALM URI の詳細については、「ALM URI」を参照してください。 説明的な ID を使用することをお勧めします。たとえば、USCA01 (USA、California、リポジトリ #01)、GEBE02 (Germany、Berlin、リポジトリ #02) などです。 ID として使用できる文字は、英文字、数字、ピリオド (.)、マイナス (-) です。 ID の文字数は、1 から 20 文字でなければなりません。

注意:
リポジトリ ID は、一度設定したら変更することはできません。
親トピック: データベース
関連概念
ALM URI


ALM URI

リポジトリ ID は、ALM URI (Application Lifecycle Management Uniform Resource Identifier) の一部になります。 ALM URI は、ALM サーバー プラットフォーム内の要素のアドレスを指定する手段を提供します。これにより、アプリケーション間で要素を識別したり追跡することが可能になります。 また、ALM URI は、Silk Central の要件やテストを複数の Silk Central リポジトリにわたって一意に識別するために使用されます。

ALM 要素の URI の構文は次のとおりです。

<ALM URI> = alm://<source project>/<source element path>[?<source version>]
 <source project> = <source type>!<project identity>

Silk Central の場合は <source type> = sctm です。 Issue Manager の場合は <source type> = scim です。

プロジェクト ID は次のように作成されます。

<project identity> = <repository ID>_<project ID>

<repository ID> は、Silk Central と Issue Manager の各リポジトリに対して一意の ID です。 各リポジトリは、そのリポジトリ内に保存される一意の ID を生成します。 ID の一意性は、インストール済みのすべてのリポジトリで保証されます。 <project ID> は、Silk Central または Issue Manager プロジェクトの ID です。 この ID は、各リポジトリのコンテキスト内で一意です。

ソース要素パスは次のとおりです。

Silk Central と Issue Manager については、成果物の参照に次の構文が使用されます。

Silk Central のネイティブ要件 (外部要件管理システムにリンクされていない要件) では、次の構文が使用されます。

<source element path> = /<requirement ID>;ns=requirement

Silk Central のテストでは、次の構文が使用されます。

<source element path> = /<test ID>;ns=test

Silk Central および Issue Manager の問題では、次の構文が使用されます。

<source element path> = /<issue ID>;ns=issue
ALM URI の例：
alm://sctm!USCA01_23/602;ns=test

Silk Central リポジトリは USCA01、プロジェクト ID は 23、要素 ID は 602、要素タイプは test です。

親トピック: データベース
関連概念
ALM リポジトリ ID


[データベース] ページ

データベース ページでは、Silk Central によりデータベースに接続したり、データベースから切断したりできます。

接続しているデータベースがない場合は、データベース ページに自動的に移動します。

データベースに接続している場合、Silk Central システム管理者としてログインし、データベース をクリックして データベース ページにアクセスする必要があります。詳細については、「Silk Central システム管理者」を参照してください。

次の UI コントロールを使用してデータベース接続を設定します。

項目 | 説明
DBMS ホスト名/IP アドレス DBMS (データベース管理システム) をホストしているコンピュータの名前。名前は、<コンピュータ名>\<インスタンス名> 形式で入力します。
データベース システム
ホスト名の説明
Microsoft SQL Server
<コンピュータ名>\<インスタンス名>。例：localhost
注: インスタンス名は、DBMS がインスタンスを使用してインストールされている場合のみ必要となります。
Oracle Server
<コンピュータ名> または Single Client Access Name（SCAN）。例：MyDBMSHost。データベースに直接アクセスしてカスタム レポートを作成する場合、ネットワーク上のどこでも使用できる DBMS ホスト名 を定義します。
DBMS タイプ | アクセスする DBMS のタイプ (Microsoft SQL Server または Oracle)。
ポート

DBMS がリスンするポート。Microsoft SQL Server (Express を含む) のデフォルトのポートは、1433 です。Oracle のデフォルトのポートは、1521 です。
データベース/SID

Microsoft SQL Server のデータベース名、または Oracle 管理者から提供された Oracle SID。Oracle RAC 環境に接続する場合は、SID の前にスラッシュ（/）をつけます。

Oracle データベース管理者への注意事項：UTF-8 文字セットを使用するように Oracle SID を構成してください。
ユーザー名/パスワード
Microsoft SQL Server (Express を含む)
十分な資格情報を持つデータベース ユーザー、または、有効な Windows ドメイン ユーザー（ドメイン\ユーザー名）。Windows 認証を使用する場合、データベース サーバーが LMv2 および NTLMv2 をサポートしていなければなりません。ユーザーを指定しないシングル サインオンはサポートされません。
注: Silk Central の評価用データベースのデフォルトの資格情報は、sa / SilkCentral12!34 です。
Oracle Server
Oracle 管理者から提供された 十分な資格情報を持つデータベース ユーザー。
重要: Oracle Server の場合、データベース ユーザー名にピリオド (.) を含めることはできません。
読み取り専用ユーザー名 指定されたデータベース内のすべてのテーブルとビューに対して、読み取り専用アクセスのみ可能な任意指定のデータベース ユーザー。このユーザーは、レポートの実行などの読み取り権限のみを必要とする操作に対して使用されます。これにより、詳細クエリによるレポートの実行によりデータベース内のデータを変更することがなくなります。 詳細クエリの実行は、データに悪影響を与える可能性があるからです。読み取り専用ユーザーによるデータベースのアクセスはパフォーマンスに対しても良い影響があります。

DBMS が Microsoft SQL Server の場合、名前とパスワードを指定すると、このユーザーが Silk Central で自動的に作成されます。DBMS が Oracle の場合、データベース管理者は Oracle にユーザーを作成する必要があり、Silk Central 管理者はそのユーザーを Silk Central に追加する必要があります。
読み取り専用パスワード

指定した 読み取り専用ユーザー名 の有効なパスワード。
DBMS バージョン情報

DBMS およびオペレーティング システムのバージョン情報を表示します。
ALM リポジトリ ID | リポジトリの ALM URI を表示します。
データベースに接続 / データベースから切断

このボタンをクリックすると、DBMS に接続、または DBMS から切断します。
注: 実行サーバーのバージョンが不適切な古いバージョンであっても、それが SilkCentral Test Manager 2009 SP1 よりも後である場合、その実行サーバーは最新の Silk Central バージョンに自動的にアップグレードされます。実行サーバーのリストの 情報 列に、アップグレードに関するメッセージが Silk Central によって表示されます。アップグレード手順が完了しない限り、そのアップグレード中の実行サーバーは使用されません。
親トピック: データベース
関連概念
Silk Central システム管理者


クライアント

クライアントは Silk Central インスタンス内の個別のユニットです。クライアントには顧客または企業内の部門などを設定できます。クライアントはセキュリティを向上させますが、インスタンスとは異なり、同じデータベースと Silk Central サービスが共有されます。

システム管理 領域を使用するとクライアントを生成できます。さまざまなクライアント設定項目を設定できます。その設定はクライアントに割り当てられているプロジェクトに影響を与えます。利用可能なライセンス全体のプールから、クライアントごとに使用可能なライセンスの最大数を制限するために指定できます。クライアントにログインした場合にのみ、そのクライアントのデータにアクセスできます。クライアント内では、プロジェクト間ですべての資産にアクセスできます。

Silk Central をインストールすると、デフォルトのクライアントが自動的に作成されます。古いバージョンから Silk Central をアップグレードする場合、すべての既存のプロジェクトとユーザーがこのデフォルトのクライアントに割り当てられます。各クライアントに対してスーパー ユーザーが作成されます。詳細については、「スーパー ユーザー」を参照してください。すべてのクライアントを削除できますが、プロジェクトやユーザーを作成したり、Silk Central で作業したりする場合には、少なくとも 1 つのクライアントが必要です。

  • スーパー ユーザー
    クライアント内のすべてのアクセス許可を持つスーパー ユーザーについて説明します。
  • クライアントを作成する
    クライアントの作成方法について説明します。
  • クライアントを編集する
    クライアントの設定を編集する方法について説明します。
  • クライアントを削除する
    クライアントの削除方法について説明します。
  • デフォルト クライアント
    自動的に作成されるデフォルト クライアントの基となる概念、クライアントのデフォルト ステータス、デフォルト ステータスの設定および設定解除の方法について説明します。
  • ライセンスの扱い
    Silk Central で使用されるライセンス タイプと、ライセンスがチェック アウトおよびチェック インされる時期について説明します。
  • クライアント ページ
    クライアント ページについて説明します。
  • クライアントのアクセス許可
    クライアントのサーバーおよびポートのアクセス許可を説明します。
親トピック: クライアントの管理


スーパー ユーザー

スーパー ユーザーは、クライアント内のすべてのアクセス許可を持ちます。一方、Silk Central システム管理者は Silk Central インストールのさまざまなクライアントの管理のみを行い、実際の Silk Central UI にはアクセスできません。

Silk Central システム管理者がクライアントを新規作成すると、このクライアントに対してスーパー ユーザーが自動的に作成されます。

スーパー ユーザーとしてログインするには、次の認証情報（デフォルト）を使用します。

  • ユーザー名：admin
  • パスワード：admin
重要: できるだけ早くこのデフォルトのパスワードを変更してください。パスワードを変更するには、メニューで 管理 > ユーザー管理 をクリックし、アカウント タブをクリックしてグリッドで admin をクリックします。ユーザー名は変更できません。

使用可能なすべてのユーザー ロールとアクセス許可のリストについては、「ユーザー ロールとアクセス許可」を参照してください。

親トピック: クライアント
関連概念
ログイン オプション
ユーザー ロールとアクセス許可
ユーザー ロール
関連タスク
Silk Central にログインする


クライアントを作成する

クライアントを作成するには：
  1. Silk Central に Silk Central システム管理者としてログインします。 詳細については、「Silk Central システム管理者」を参照してください。
  2. メニューで クライアント をクリックします。
  3. クライアントの新規作成 をクリックします。 クライアントの新規作成 ダイアログ ボックスが表示されます。
  4. クライアント名 と 説明 を入力します。
  5. ライセンス制限 セクションに、このクライアントで同時に使用することができるライセンス数の最大値を指定します。指定した数のライセンス数が使用中になると、ユーザーは選択したクライアントでライセンスを獲得できなくなります。これは、重要なクライアントに対して利用可能なライセンスを十分確保し、そうでないクライアントに制限を加えたい場合などに特に有効です。 以下のルールが適用されます。
    • 値なし：ライセンス制限は適用されません。クライアントは利用可能なライセンスのすべてを使用できます。
    • 0 (ゼロ)：クライアントはライセンスを獲得できません。選択したライセンスに関連するすべての機能が使用できなくなることを意味します。
    • 任意の数：クライアントが獲得できるライセンス数。利用可能なライセンスの総量よりも大きい数値を指定すると、クライアントは利用可能なライセンスのすべてを使用できます。
    ヒント: 利用可能なライセンスの総量は、クライアント ページの下部に表示されます。
  6. OK をクリックします。

クライアント固有の管理タスクを実行するために、スーパー ユーザーとしてクライアントにログインします。詳細については、「スーパー ユーザー」を参照してください。

親トピック: クライアント
関連概念
Silk Central システム管理者
ライセンスの扱い
スーパー ユーザー
関連資料
[データベース] ページ


クライアントを編集する

クライアントの設定を編集するには：
  1. Silk Central に Silk Central システム管理者としてログインします。 詳細については、「Silk Central システム管理者」を参照してください。
  2. メニューで クライアント をクリックします。
  3. アクション 列の [image] (編集) をクリックします。 クライアントの編集 ダイアログ ボックスが表示されます。
  4. クライアント名 と 説明 を編集します。
  5. ライセンス制限 セクションに、このクライアントで同時に使用することができるライセンス数の最大値を指定します。指定した数のライセンス数が使用中になると、ユーザーは選択したクライアントでライセンスを獲得できなくなります。これは、重要なクライアントに対して利用可能なライセンスを十分確保し、そうでないクライアントに制限を加えたい場合などに特に有効です。 以下のルールが適用されます。
    • 値なし：ライセンス制限は適用されません。クライアントは利用可能なライセンスのすべてを使用できます。
    • 0 (ゼロ)：クライアントはライセンスを獲得できません。選択したライセンスに関連するすべての機能が使用できなくなることを意味します。
    • 任意の数：クライアントが獲得できるライセンス数。利用可能なライセンスの総量よりも大きい数値を指定すると、クライアントは利用可能なライセンスのすべてを使用できます。
    ヒント: 利用可能なライセンスの総量は、クライアント ページの下部に表示されます。
  6. OK をクリックします。
注: クライアント名 を変更する場合は、Silk Central ユーザーに通知します。Silk Central ユーザーはログイン ページに正しいクライアント名を入力する必要があります。

クライアント固有の管理タスクを実行するために、スーパー ユーザーとしてクライアントにログインします。詳細については、「スーパー ユーザー」を参照してください。

親トピック: クライアント
関連概念
Silk Central システム管理者
ライセンスの扱い
スーパー ユーザー
関連資料
[データベース] ページ


クライアントを削除する

クライアントを削除するには：
  1. Silk Central に Silk Central システム管理者としてログインします。 詳細については、「Silk Central システム管理者」を参照してください。
  2. メニューで クライアント をクリックします。
  3. アクション 列で [image] (削除) をクリックします。
  4. 問題がなければ はい をクリックします。
親トピック: クライアント
関連概念
Silk Central システム管理者
関連資料
[データベース] ページ


デフォルト クライアント

Silk Central をインストールすると、クライアント (名前は デフォルト) が自動的に作成され、このクライアントのステータスがデフォルトに設定されます。 デフォルト ステータスを持つクライアントを定義するには、Silk Central に Silk Central システム管理者としてログインし、クライアント をクリックします。 詳細については、「Silk Central システム管理者」を参照してください。

クライアントをデフォルトとして設定するには、デフォルトに設定 をクリックします。 デフォルト ステータスの設定を解除するには、デフォルト設定の解除 をクリックします。 アイコン [image] により、現在どのクライアントがデフォルト クライアントであるかが示されます。 デフォルト クライアントを定義しないこともできますが、デフォルト ステータスを持つことのできるクライアントは一度に 1 クライアントのみです。

デフォルト クライアントの目的は、ログインを簡略化することです。つまり、デフォルト クライアントのユーザーが Silk Central にログインする場合、クライアント名を省略することができます。 ユーザー名のみを入力します。 これは、クライアントが 1 つだけの Silk Central インストールの場合に特に便利です。 古いバージョンから Silk Central をアップグレードする場合、ログイン動作は以前と同じです。

親トピック: クライアント
関連概念
Silk Central システム管理者
関連資料
[データベース] ページ


クライアント ページ

このページアクセスするには、Silk Central に Silk Central システム管理者としてログインし、クライアント をクリックします。詳細については、「Silk Central システム管理者」を参照してください。

このページを使用すると、クライアントの作成および管理が可能です。クライアントの新規作成 をクリックして、新しいクライアントを作成します。デフォルトに設定 または デフォルト設定の解除 をクリックして、クライアントのデフォルトのステータスを変更します。アイコン [image] により、現在どのクライアントがデフォルト クライアントであるかが示されます。

ページのグリッドには、次の列があります。

列 | 説明
アクション | (削除) および [image] (編集) のボタンをクリックし、クライアントを削除または編集します。
ID | クライアントの識別子。
名前 | クライアントの名前。 (編集) をクリックし、名前を編集します。クライアント名を変更する場合は、Silk Central ユーザーに通知します。Silk Central ユーザーはログイン ページに正しいクライアント名を入力する必要があります。
説明 | クライアントの詳細を説明します。 (編集) をクリックし、説明を編集します。
テスト管理 | テスト管理用ライセンスの同時使用可能な最大数。
手動テスト | 手動テスト用ライセンスの同時使用可能な最大数。
問題追跡 | 問題追跡用ライセンスの同時使用可能な最大数。
自動テスト | 自動テスト用ライセンスの同時使用可能な最大数。
作成日時 | クライアントが作成された日時。
作成者 | このクライアントを作成したユーザー。
変更日時 | クライアントが変更された日時。
変更者 | このクライアントを変更したユーザー。
親トピック: クライアント
関連概念
Silk Central システム管理者


クライアントのアクセス許可

このページを使用して、システム設定およびクライアントのアクセス許可を変更します。

項目 | 説明
フロントエンド サーバーとアプリケーション サーバー ログ ビューをクライアント ユーザーに表示する | オンにすると、UI にフロントエンド サーバーとアプリケーション サーバー ログのタブが表示されます (ログにはクライアント固有のデータが含まれることがあります)。
詳細レポートをクライアント ユーザーに許可する | オンにすると、詳細クエリによるレポートが有効になります。オフにしてもレポートを実行できますが、新しいレポートを作成したり編集したりはできません。
レポート テンプレートの管理をクライアント ユーザーに許可する | オンにすると、レポート テンプレートのアップロード、編集、更新、削除が有効になります。レポート テンプレートには任意の SQL を含めることができ、他のクライアントのデータを読み取る可能性があります。
親トピック: クライアント
関連概念
アクセス許可の定義


インフラストラクチャ

チャート サーバー、電子メール サーバー、システム プロキシの設定も含まれます。

  • チャート サーバー
    チャート サーバーの役割および Silk Central への接続方法について説明します。
  • 電子メール サーバー
    電子メール サーバーを設定する方法について説明します。
  • システム プロキシ
    システム プロキシを設定する方法について説明します。 システム プロキシを設定すると、実行サーバーがプロキシを介してアプリケーション サーバーと通信できるようになります。
  • アプリケーション サーバーの場所
    Silk Central アプリケーション サーバーの基礎について説明します。
  • LDAP 認証
    LDAP サーバーを使用して Silk Central にログインできるように LDAP 認証を構成する方法について説明します。
  • Silk Performer 負荷テスト エージェント クラスタ
    Silk Performer 負荷テスト エージェント クラスタと、それによる複数のテスト エージェント間での動的な作業負荷割り当てのサポートについて説明します。
親トピック: クライアントの管理


チャート サーバー

チャート サーバーは、データを計算してグラフを作成するサービスです。 作成されたグラフは、Silk Central アプリケーションに表示されます。 このサービスは、Silk Central のセットアップで任意のコンピュータにインストールできます。 グラフを表示するには、チャート サーバー接続を設定する必要があります。

注: チャート サーバーはいくつでも必要に応じて設定できます。 Silk Central は、グラフ生成用に負荷分散メカニズムを自動的に実装します。
  • チャート サーバー接続を設定する
    チャート サーバー接続を設定する方法について説明します。
  • チャート サーバー接続を編集する
    チャート サーバー接続を編集する方法を説明します。
  • チャート サーバー接続を削除する
    チャート サーバー接続の削除方法について説明します。
  • [チャート サーバー] ページ
    チャート サーバー ページについて説明します。
親トピック: インフラストラクチャ


チャート サーバー接続を設定する

チャート サーバー接続を設定するには：

  1. メニューで インフラストラクチャ > チャート サーバー をクリックします。
  2. チャート サーバーがアプリケーション サーバーと同じコンピュータにインストールされている場合、localhost へのチャート サーバー接続が自動的に設定されます。
  3. 省略可能： ユーザーが Web ユーザー インターフェイスにアクセスするのに使用する URL 以外の URL を使用して、チャート サーバーがフロントエンド サーバーと通信する必要がある場合、Web サービス URL の設定 をクリックして、テキスト フィールドに URL を入力します。ユーザーがプロキシを介して Web ユーザー インターフェイスにアクセスする場合など、チャート サーバーはフロントエンド サーバーの内部 URL や IP アドレスを使用するため、必要になります。
  4. チャート サーバーの新規作成 をクリックします。 チャート サーバーの新規作成 ダイアログ ボックスが表示されます。
  5. チャート サービスがインストールされている ホスト名または IP アドレス、ポート、URL を入力します。デフォルトのポートは 19126、デフォルトの URL は ChartServer です。
  6. 確認 をクリックして、チャート サーバーへのテスト接続を確立します。 チャート サーバーの確認 ダイアログ ボックスが表示されます。
    注: テストが成功すると、テスト画像が表示されます。テストが失敗すると、エラー メッセージが表示されます。入力したデータを検査し、チャート サーバーがターゲット マシンにインストールされていることを確認します。
  7. 閉じる をクリックします。テスト接続が成功した場合は、アクティブ チェック ボックスをオンにして、OK をクリックします。

チャート サーバーはいくつでも必要に応じて設定できます。 Silk Central は、グラフ生成用に負荷分散メカニズムを自動的に実装します。

注: チャート サーバー サービスがターゲット コンピュータにインストールされている場合にのみ、チャート サーバー接続を設定できます。詳細については、Silk Central アプリケーションのインストール手順を参照してください。
親トピック: チャート サーバー


チャート サーバー接続を編集する

チャート サーバー接続を編集するには：

  1. メニューで インフラストラクチャ > チャート サーバー をクリックします。
  2. 省略可能： ユーザーが Web ユーザー インターフェイスにアクセスするのに使用する URL 以外の URL を使用して、チャート サーバーがフロントエンド サーバーと通信する必要がある場合、Web サービス URL の設定 をクリックして、テキスト フィールドに URL を入力します。ユーザーがプロキシを介して Web ユーザー インターフェイスにアクセスする場合など、チャート サーバーはフロントエンド サーバーの内部 URL や IP アドレスを使用するため、必要になります。
  3. アクション 列の [image] (編集) をクリックします。 チャート サーバーの編集 ダイアログ ボックスが表示されます。
  4. チャート サービスがインストールされている ホスト名または IP アドレス、ポート、URL を編集します。デフォルトのポートは 19126、デフォルトの URL は ChartServer です。
  5. アクティブ チェック ボックスをオン/オフにして、サーバーをアクティブ/非アクティブにします。
  6. 確認 をクリックして、チャート サーバーへのテスト接続を確立します。 チャート サーバーの確認 ダイアログ ボックスが表示されます。
    注: テストが成功すると、テスト画像が表示されます。テストが失敗すると、エラー メッセージが表示されます。入力したデータを検査し、チャート サーバーがターゲット マシンにインストールされていることを確認します。
  7. 閉じる をクリックし、OK をクリックします。
親トピック: チャート サーバー


チャート サーバー接続を削除する

チャート サーバー接続を削除するには：

  1. メニューで インフラストラクチャ > チャート サーバー をクリックします。
  2. アクション 列の [image] (編集) をクリックします。 チャート サーバーの編集 ダイアログ ボックスが表示されます。
  3. アクティブ チェック ボックスをオフにして、OK をクリックします。
  4. アクション 列の 削除 (削除) をクリックします。
  5. 問題がなければ はい をクリックします。
注: これでサーバーへの接続が削除されます。 サーバー自体が削除されるわけではありません。
親トピック: チャート サーバー


[チャート サーバー] ページ

このページにアクセスするには、Silk Central に Silk Central システム管理者としてログインし、インフラストラクチャ > チャート サーバー をクリックします。詳細については、「Silk Central システム管理者」を参照してください。

このページを使用して、チャート サーバーへの接続を管理します。チャート サーバーの新規作成 をクリックして、新しいチャート サーバー接続を設定します。Web サービス URL の設定 で、チャート サーバーがフロントエンド サーバーに接続する際に使用する URL を別途設定することができます。ページのグリッドには、次の列があります。

列 | 説明
アクション | (削除) および [image] (編集) のボタンをクリックして、チャート サーバー接続を削除または編集します。接続を削除するには、接続を非アクティブ化する必要があります。
チャート サーバーの URL | チャート サーバーの URL を表示します。構文：http://<コンピュータ名または IP アドレス>:<ポート>/ChartServer。デフォルトのポートは 19126 です。 (編集) をクリックして URL を編集します。
ステータス | チャート サーバーへの接続がアクティブか非アクティブかを表示します。 (編集) をクリックして、接続のステータスを変更します。
作成日時 | チャート サーバー接続が作成された日時。
作成者 | このチャート サーバー接続を作成したユーザー。
変更日時 | チャート サーバー接続が変更された日時。
変更者 | このチャート サーバー接続を変更したユーザー。
親トピック: チャート サーバー


電子メール サーバー

電子メール サーバーを設定するときには、Silk Central からアプリケーションの結果について通知されます。

  • 電子メールサーバーを設定する
    電子メール サーバーを設定する方法について説明します。
  • [電子メール サーバー] ページ
    電子メール サーバー ページについて説明します。
親トピック: インフラストラクチャ


電子メールサーバーを設定する

最大 3 つの電子メール サーバーを設定するには：
  1. Silk Central に Silk Central システム管理者としてログインします。 詳細については、「Silk Central システム管理者」を参照してください。
  2. インフラストラクチャ > 電子メール サーバー をクリックします。
  3. システム管理者の電子メール アドレス に電子メール アドレスを入力します。 Silk Central はこのアドレスに通知を送信します。
  4. 電子メールに使用する差出人アドレス に電子メール アドレスを入力します。 このアドレスは、通知の送信者として表示されます。
  5. サーバー フィールドに、自分の電子メール サーバーのホスト名または IP アドレスを入力します。 最大 3 つまでの電子メール サーバーを設定できます。
  6. サーバーで認証情報が必要な場合は、それらを ユーザー名 および パスワード フィールドに入力します。
  7. 確認 をクリックし、サーバーへの接続をテストします。 Silk Central により、手順 3 で入力した電子メール アドレスにテスト電子メールが送信されます。
  8. エラー メッセージが表示される場合、または電子メールを受信しない場合は、電子メールの設定を確認します。電子メール サーバーのホスト名が正しいこと、およびそのコンピュータで SMTP プロトコルが実行されていることを確認します。
    注: TLS を使用した SMTP は現在サポートされていません。
  9. テスト電子メールを受信したら、テストは成功です。保存 をクリックします。
親トピック: 電子メール サーバー


[電子メール サーバー] ページ

このページにアクセスするには、Silk Central に Silk Central システム管理者としてログインし、インフラストラクチャ > 電子メール サーバー をクリックします。 詳細については、「Silk Central システム管理者」を参照してください。

このページを使用すると、最大 3 つまでの電子メール サーバーを設定できます。 このページには、次の項目があります。

項目 | 説明
システム管理者の電子メール アドレス | Silk Central システム管理者の電子メール アドレスを指定します。
電子メールに使用する差出人アドレス | システムから送信される電子メールの 差出人 フィールドに表示される名前を指定します。 任意の電子メール アドレスを使用できます（たとえば、System_message@mycompany.com）。
サーバー 1 サーバー 2 サーバー 3 | 電子メールを送信するサーバーのホスト名または IP アドレスを指定します。 多くの企業では、このサーバーは単にメールと呼ばれます。 電子メール サーバーが SMTP 認証 (LOGIN PLAIN) を使用する場合は、電子メール サーバーの有効なユーザーとパスワードを入力する必要があります。 ログイン認証情報がわからない場合は、メール サーバーの管理者に問い合わせてください。
確認 | システム管理者の電子メール アドレス フィールドで定義した受信者にテスト用の電子メールを送信します。
保存 | 設定を保存します。
キャンセル | フィールドのすべての値をクリアします。
親トピック: 電子メール サーバー


システム プロキシ

特定のロケーションの実行サーバーは、プロキシを介してアプリケーション サーバーと通信を行います。 ユーザー (Silk Central システム管理者として) がプロキシ サーバーを設定すると、クライアントがプロキシを使用できるようになります。 プロキシ サーバーを設定するには、メニューで 管理 > 実行サーバー をクリックし、アクション 列で [image] (編集) をクリックして、システム プロキシを使用 チェック ボックスをオンにします。

  • システム プロキシを設定する
    システム プロキシを設定する方法および場所について説明します。
  • [システム プロキシ] ページ
    システム プロキシ ページについて説明します。
親トピック: インフラストラクチャ


システム プロキシを設定する

システム プロキシを設定するには：
  1. Silk Central に Silk Central システム管理者としてログインします。 詳細については、「Silk Central システム管理者」を参照してください。
  2. インフラストラクチャ > システム プロキシ をクリックします。
  3. ホスト および ポート に、プロキシ サーバーのホストとポートを入力します。
  4. 必要に応じて、ユーザー名 と パスワード を入力します。
  5. 確認 をクリックし、プロキシ サーバーへの接続をテストします。 ダイアログ ボックスにテスト結果が表示されます。
  6. 接続を確立できなかった場合は、設定が正しいことを確認します。
  7. 接続を確立できた場合は、保存 をクリックします。 これで、システム プロキシを使用できるようになりました。
親トピック: システム プロキシ


[システム プロキシ] ページ

このページにアクセスするには、Silk Central に Silk Central システム管理者としてログインし、インフラストラクチャ > システム プロキシ をクリックします。 詳細については、「Silk Central システム管理者」を参照してください。

このページは、システム プロキシの設定に使用します。 このページには、次の項目があります。

項目 | 説明
ホスト | システム プロキシとして使用するコンピュータのホスト名または IP アドレスです。
ポート | システム プロキシがリスンするポート番号です。 デフォルトのポートは 8080 です。
ユーザー名 (省略可能) | プロキシ サーバーでログイン認証情報が必要な場合は、有効なユーザー名を入力します。
パスワード (省略可能) | ユーザー名の有効なパスワードを入力します。
検査 | 指定した認証情報でプロキシへの接続をテストします。
保存 | 設定を保存します。
キャンセル | このページのすべての項目をクリアします。
親トピック: システム プロキシ


アプリケーション サーバーの場所

アプリケーション サーバーは、スケジュールの配布、実行サーバーの制御、データベース構成の管理などのタスクを同期させる働きをします。Silk Central を使用するには、先に、アプリケーション サーバーの場所を指定する必要があります。

  • アプリケーション サーバーの場所を指定する
    自動的に設定されなかった場合に、アプリケーション サーバーの場所を指定します。
親トピック: インフラストラクチャ


アプリケーション サーバーの場所を指定する

デフォルトの Silk Central インスタンスに接続する時に、アプリケーション サーバーの場所を指定する必要はありません。セットアップで localhost がアプリケーション サーバーとして自動的に設定されます。その場合は、この手順を省略できます。セットアップ オプションの詳細については、アプリケーションのインストール手順を参照してください。

アプリケーション サーバーのロケーションを指定するには：

  1. Silk Central ソフトウェアがインストールされたら、Web ブラウザを使用して Silk Central に接続します。
    ヒント: デフォルトの URL は、http://<コンピュータ名>:19120/login (IIS 上で Silk Central を実行する場合はポート番号は不要です) です。

    アプリケーション サーバーの接続がまだ定義されていないことを伝える確認メッセージが表示されます。

  2. アプリケーション サーバーの ホスト または IP アドレス と ポート を入力します。 アプリケーション サーバーは、Silk Central のアプリケーション サーバー コンポーネントをインストールしたコンピュータです。デフォルトのポートは 19122 です。
  3. ログイン をクリックして次に進みます。 指定した情報が正しく、それぞれのコンピュータでインストールされているソフトウェアが稼働している場合は、ログイン ページに戻ります。
データベース管理 ページが表示されます。
親トピック: アプリケーション サーバーの場所
関連資料
[データベース] ページ


LDAP 認証

LDAP サーバーを使用して Silk Central にログインできるようにするには、LDAP 認証を構成します。

LDAP（Lightweight Directory Access Protocol）は、ディレクトリ サービスへのアクセスを提供することを目的として設計されているオープン ネットワーク プロトコル標準です。 LDAP は、ディレクトリ情報ツリー（DIT）に存在する情報を照会したり変更したりするためのメカニズムを提供します。 ディレクトリ情報ツリーは、通常、ユーザー、プリンタ、アプリケーション、その他のネットワーク リソースなど、さまざまな種類のネットワーク オブジェクトに関する広範囲の情報を格納しています。

  • Silk Central LDAP 統合
    Silk Central における LDAP 統合について説明します。
  • LDAP 認証ロジック
    LDAP 認証に使用できる認証モードについて説明します。
  • LDAP サーバーを追加する
    Silk Central で使用する LDAP サーバーを追加します。
  • LDAP サーバーを編集する
    LDAP サーバー プロファイルを編集して、設定を変更します。
  • LDAP サーバーをテストする
    LDAP サーバーへの接続をテストして、システムでそのサーバーを利用できるかどうか確認します。
  • LDAP サーバーを削除する
    プロファイル リストから LDAP サーバー プロファイルを削除します。
  • [LDAP サーバー] ページ
    システムに構成されている LDAP サーバーのリストが表示されます。
親トピック: インフラストラクチャ
関連概念
ログインおよびログアウト


Silk Central LDAP 統合

Silk Central における LDAP 統合の最も重要な側面は、ユーザー認証です。ほとんどのディレクトリではユーザーのパスワードを取得できないので、ユーザーが認証を受ける必要があるたびに、LDAP にアクセスする必要があります。

Silk Central LDAP 統合は、プレーンテキストと SSL の両方の認証をサポートします。ディレクトリ サービスが匿名のクエリを許可するか、またはディレクトリに対する読み取り権限を持つユーザーが提供される必要があります。

親トピック: LDAP 認証


LDAP 認証ロジック

標準モード認証とは、1 つの LDAP サーバーが定義されアクティブである場合に、ユーザーが LDAP に対してのみ認証できることを意味します。混合モード認証とは、ユーザーは LDAP またはローカル認証情報のどちらかでログインできることを意味します。ユーザーが LDAP サーバーでは既知であっても、認証情報が正しくない場合は、アクセスは拒否されます。

注: どちらの認証モードの場合も、ユーザーは Silk Central データベースにユーザー名が存在する場合にのみログインできます。

標準モード認証

標準モード認証は、少なくとも 1 つの LDAP サーバーがアクティブのときに有効になります。定義されている各 LDAP サーバーが検査されて、ユーザーを（特定のユーザー名とパスワードで）認証できるかどうかが判定されます。いずれか 1 つのサーバーで認証が成功すると、アクセスが許可されます。

混合モード認証

LDAP サーバーが定義されていない場合は、ユーザーはローカル認証情報でのみログインできます。少なくとも 1 つの LDAP サーバーがアクティブであり、ユーザー アカウントが混合モード認証を使用するように設定されている場合は、定義されている各 LDAP サーバーが検査されて、ユーザーを（特定のユーザー名とパスワードで）認証できるかどうかが判定されます。定義されているすべての LDAP サーバーでユーザーが不明の場合は、ローカル データベース認証が試みられます。ローカル認証情報でもユーザーが不明の場合は、アクセスは拒否されます。ユーザーが LDAP サーバーでは既知であっても、認証情報が正しくない場合は、アクセスは拒否されます。

親トピック: LDAP 認証


LDAP サーバーを追加する

Silk Central で使用するために LDAP サーバーを設定するには：

  1. メニューで 管理 > システム設定 をクリックします。
  2. LDAP サーバー タブをクリックします。
  3. LDAP サーバーの新規作成 をクリックします。 LDAP サーバーの新規作成 ダイアログ ボックスが表示されます。
  4. サーバーの 名前 と任意で 説明 を入力します。LDAP サーバーの任意の名前を定義できます。このフィールドは、LDAP の実際の設定には影響を与えません。
  5. アクティブ チェック ボックスをオンにして、Silk Central でのサーバーの使用を有効にします。オフにすると、Silk Central は LDAP サーバーのサービスを利用できなくなります。
  6. LDAP サーバーの ホスト名 または IP アドレスを入力し、LDAP サービスに使用する ポート を入力します。デフォルトのポートは 389 です。SSL を使用する場合のデフォルトの LDAP ポートは 636 です。
  7. SSL を通じてサーバーに接続するには、SSL を使用する チェック ボックスをオンにします。このチェック ボックスは、ポート フィールドで定義した設定と密接に関係します。SSL を使用した通信を設定する方法については、「SSL による外部システムとの通信」を参照してください。
  8. 省略可能：ユーザーが Silk Central に <ドメイン>\<ユーザー名> 形式でログインする必要がある場合は、ドメイン を指定します。ドメイン名を入力せずに Silk Central にログインする場合は、このフィールドは空のままにしておきます。Silk Central インストールが複数クライアントで構成されてる場合、<ドメイン>\<ユーザー名> ログイン形式はクライアントを指定してログインする際にも使用するため、指定した LDAP ドメイン名がクライアント名と競合していないことを確認してください。
  9. 省略可能：バインド DN フィールドに、LDAP サービスへのバインドに使用するユーザーのドメイン名を入力します。このユーザーには、ベース DN で指定するルートからのディレクトリに対する読み取り権限が必要です。このフィールドを空白にすると、匿名アクセスをサポートしていない LDAP サーバーを除き、匿名アクセスが使用されます。
  10. バインド DN で指定したユーザーの パスワード を入力します。匿名アクセスを許可する場合は不要です。
  11. LDAP クエリの ベース DN ルートを入力します。たとえば、「DC=yourcompany,DC=com」と入力します。
  12. 省略可能：LDAP クエリに使用する ユーザー フィルタ を入力します。

    例： (memberOf=CN=Development,CN=Users,DC=yourcompany,DC=com)

    この例は、Silk Central のログイン ユーザーに対して、Development チームのメンバーであるユーザーだけを LDAP サーバーにクエリします。アカウントの自動作成を有効化した際に、ある LDAP グループのメンバーのアカウントのみを Silk Central に作成させたい場合に有用です。

  13. 省略可能：特定のグループで LDAP クエリをフィルタするには、グループ フィルタ を指定します。この構文は、ユーザー フィルタ フィールドの構文と同じです。
  14. LDAP プロパティの設定 をクリックして、LDAP 属性を Silk Central のユーザーとグループ設定にマップできます。この設定は、LDAP サーバーから Silk Central にユーザーをインポートする場合には不可欠です。
  15. 省略可能： Silk Central が自動的に Silk Central ユーザー アカウントを作成するタイミングを、ユーザーが Silk Central に始めてログインしたときに限定することができます。入力したログイン名のユーザー アカウントが Silk Central に存在しない場合、入力した認証情報は LDAP サーバーによって認証されます。認証に成功すると、入力したログイン名とパスワードをもつ新しいアカウントが Silk Central に作成されます。新しく作成されたアカウントに対して、あらかじめテンプレートとして選択された Silk Central ユーザーの汎用的な設定値（ダッシュボード設定を含む）が最初にコピーされます。氏名とメール　アドレスが LDAP 値からクエリされます。この設定をは行うには、 ユーザー アカウントの作成 の隣にある 設定 をクリックします。ユーザー アカウントの作成 ダイアログ ボックスで、リストから Silk Central ユーザー を選択します。LDAP の設定によっては、氏名やメール アドレスに対して LDAP 値を適用する必要がある場合があります。
  16. テスト をクリックして、LDAP サーバーへの接続テストを実行します。 詳細については、「LDAP サーバーをテストする」を参照してください。
  17. OK をクリックして、設定を保存します。
  18. 複数の LDAP サーバーを使用している場合：順序 列に番号を指定して、認証の問い合わせを行う LDAP サーバーの優先順位を決定します。
親トピック: LDAP 認証
関連タスク
LDAP サーバーからグループをインポートする
プロジェクトを追加する
プロジェクトとプロジェクト ベースラインを編集する
LDAP サーバーを編集する
LDAP サーバーをテストする


LDAP サーバーを編集する

LDAP サーバー プロファイルを編集するには：

  1. メニューで 管理 > システム設定 をクリックします。
  2. LDAP サーバー タブをクリックします。
  3. 編集する LDAP サーバー プロファイルの名前をクリックします。 LDAP サーバーの編集 ダイアログ ボックスが表示されます。
  4. サーバーの 名前 と任意で 説明 を入力します。LDAP サーバーの任意の名前を定義できます。このフィールドは、LDAP の実際の設定には影響を与えません。
  5. アクティブ チェック ボックスをオンにして、Silk Central でのサーバーの使用を有効にします。オフにすると、Silk Central は LDAP サーバーのサービスを利用できなくなります。
  6. LDAP サーバーの ホスト名 または IP アドレスを入力し、LDAP サービスに使用する ポート を入力します。デフォルトのポートは 389 です。SSL を使用する場合のデフォルトの LDAP ポートは 636 です。
  7. SSL を通じてサーバーに接続するには、SSL を使用する チェック ボックスをオンにします。このチェック ボックスは、ポート フィールドで定義した設定と密接に関係します。SSL を使用した通信を設定する方法については、「SSL による外部システムとの通信」を参照してください。
  8. 省略可能：ユーザーが Silk Central に <ドメイン>\<ユーザー名> 形式でログインする必要がある場合は、ドメイン を指定します。ドメイン名を入力せずに Silk Central にログインする場合は、このフィールドは空のままにしておきます。Silk Central インストールが複数クライアントで構成されてる場合、<ドメイン>\<ユーザー名> ログイン形式はクライアントを指定してログインする際にも使用するため、指定した LDAP ドメイン名がクライアント名と競合していないことを確認してください。
  9. 省略可能：バインド DN フィールドに、LDAP サービスへのバインドに使用するユーザーのドメイン名を入力します。このユーザーには、ベース DN で指定するルートからのディレクトリに対する読み取り権限が必要です。このフィールドを空白にすると、匿名アクセスをサポートしていない LDAP サーバーを除き、匿名アクセスが使用されます。
  10. バインド DN で指定したユーザーの パスワード を入力します。匿名アクセスを許可する場合は不要です。
  11. LDAP クエリの ベース DN ルートを入力します。たとえば、「DC=yourcompany,DC=com」と入力します。
  12. 省略可能：LDAP クエリに使用する ユーザー フィルタ を入力します。

    例： (memberOf=CN=Development,CN=Users,DC=yourcompany,DC=com)

    この例は、Silk Central のログイン ユーザーに対して、Development チームのメンバーであるユーザーだけを LDAP サーバーにクエリします。アカウントの自動作成を有効化した際に、ある LDAP グループのメンバーのアカウントのみを Silk Central に作成させたい場合に有用です。

  13. 省略可能：特定のグループで LDAP クエリをフィルタするには、グループ フィルタ を指定します。この構文は、ユーザー フィルタ フィールドの構文と同じです。
  14. LDAP プロパティの設定 をクリックして、LDAP 属性を Silk Central のユーザーとグループ設定にマップできます。この設定は、LDAP サーバーから Silk Central にユーザーをインポートする場合には不可欠です。
  15. 省略可能： Silk Central が自動的に Silk Central ユーザー アカウントを作成するタイミングを、ユーザーが Silk Central に始めてログインしたときに限定することができます。入力したログイン名のユーザー アカウントが Silk Central に存在しない場合、入力した認証情報は LDAP サーバーによって認証されます。認証に成功すると、入力したログイン名とパスワードをもつ新しいアカウントが Silk Central に作成されます。新しく作成されたアカウントに対して、あらかじめテンプレートとして選択された Silk Central ユーザーの汎用的な設定値（ダッシュボード設定を含む）が最初にコピーされます。氏名とメール　アドレスが LDAP 値からクエリされます。この設定をは行うには、 ユーザー アカウントの作成 の隣にある 設定 をクリックします。ユーザー アカウントの作成 ダイアログ ボックスで、リストから Silk Central ユーザー を選択します。LDAP の設定によっては、氏名やメール アドレスに対して LDAP 値を適用する必要がある場合があります。
  16. テスト をクリックして、LDAP サーバーへの接続テストを実行します。 詳細については、「LDAP サーバーをテストする」を参照してください。
  17. OK をクリックして、設定を保存します。
親トピック: LDAP 認証
関連タスク
LDAP サーバーを追加する
LDAP サーバーをテストする


LDAP サーバーをテストする

LDAP サーバーへの接続をテストするには：

  1. Silk Central で LDAP サーバー プロファイルを追加または編集する場合、LDAP サーバーの新規作成 ダイアログ ボックスまたは LDAP サーバーの編集 ダイアログ ボックスに、テスト ボタンが表示されます。
  2. テスト をクリックすると、LDAP 設定のテスト ダイアログ ボックスが表示されます。
  3. テスト ユーザー名 フィールドに、LDAP 認証のテストに使用するユーザー名を入力します。
  4. また、テスト パスワード に、LDAP 認証のテストに使用するユーザーのパスワードを入力します。
  5. テスト をクリックして認証のテストを実行します。
    注: テストが失敗した場合は、LDAP のエラー コードも表示されます。
    ダイアログ ボックスにテストが成功したかどうかが表示されます。
  6. 閉じる をクリックすると、LDAP サーバーの新規作成 ダイアログ ボックスまたは LDAP サーバーの編集 ダイアログ ボックスに戻ります。 テスト接続が失敗した場合は、設定を編集するか、システム管理者に支援を依頼してください。 その後、ステップ 2 からやり直してください。
親トピック: LDAP 認証
関連タスク
LDAP サーバーを追加する
LDAP サーバーを編集する


LDAP サーバーを削除する

LDAP サーバー プロファイルを削除するには：

  1. メニューで 管理 > システム設定 をクリックします。
  2. LDAP サーバー タブをクリックします。
  3. LDAP サーバーがアクティブである場合は、削除する前に非アクティブにする必要があります。削除する LDAP サーバー プロファイルの名前をクリックします。 LDAP サーバーの編集 ダイアログ ボックスが表示されます。
  4. アクティブ チェック ボックスをオフにしてサーバーを非アクティブにし、OK をクリックします。
  5. 削除する LDAP サーバーの アクション 列で、 削除 (削除) をクリックします。
  6. はい をクリックして、削除を確定します。
親トピック: LDAP 認証


[LDAP サーバー] ページ

管理 > システム > LDAP サーバー

LDAP サーバー ページには、構成されているすべての LDAP サーバーのリストが表示されます。このページは、 LDAP サーバーの管理に使用します。

このページでは、次のアクションを実行できます。

  • LDAP サーバーの新規作成 をクリックして、新しい LDAP サーバーを構成します。
  • 順序 列に番号を指定して、認証の問い合わせを行う LDAP サーバーの優先順位を決定します。
  • リストで既存の LDAP サーバーをクリックし、設定を編集します。
  • アクション 列で 削除 (削除) をクリックし、LDAP サーバーを削除します (事前に LDAP サーバーを非アクティブにする必要があります)。
親トピック: LDAP 認証
関連タスク
LDAP サーバーを追加する
LDAP サーバーを編集する
LDAP サーバーをテストする


Silk Performer 負荷テスト エージェント クラスタ

作業負荷を個々のエージェントへ割り当てる以外に、ユーザーには、能力が定義されているエージェントのクラスタへ、Silk Performer 作業負荷を割り当てる、という選択肢があります。 Silk Performer の動的作業負荷割り当て機能は、指定した負荷テスト要件と実行時に利用可能なエージェント コンピュータの再生機能を一致させます。 Silk Performer においてエージェントに対して定義されている能力は、エージェントに対する作業負荷の割り当ての最適化に使用されます。 たとえば、あるテストが、SAPGUI クライアントが入っているエージェント コンピュータのみが提供できる作業負荷を必要としている場合、動的作業負荷割り当て機能は、テストの作業負荷が、SAPGUI クライアントが入っている利用可能なエージェントに対してのみ割り当てられるようにできます。 さらに、各エージェントに確保できる必須作業負荷もしくは仮想ユーザーのパーセンテージも設定できるので、エージェントが自分の能力を超えて稼働させられる、ということもないようにできます。

Silk Performer テストの実行の際、Silk Central 負荷テスト エージェント クラスタ XML ファイルは、適切な実行サーバーからチェックアウトされ、実行中に動的作業負荷割り当てに使用されます。 ユーザーは、プロジェクトの負荷テスト エージェント クラスタ XML ファイルの場所を、 管理 > システム 設定で指定する必要があります。

負荷テスト エージェント クラスタに対する作業負荷の動的な割り当ての利点は、テスト実行の成功は、静的なテスト実行環境の維持に左右されない、という点です。 Silk Performer は、利用できないエージェントの作業負荷を、同じ能力を持つ同じクラスタ内に存在する利用可能なエージェントに動的に割り当てることができます。 この機能は、Silk Performer 負荷テストが、Silk Central において事前定義されたスケジュールを元に管理および実行されている際には、特に有益です。 作業負荷をエージェント間でどのようにバランスを取るか、および、個々のエージェントの健全性については、Silk Central の観点から検討しなければならない問題ではありません。

動的な作業負荷割り当ての詳細については、Silk Performer のヘルプを参照してください。

  • 負荷テスト エージェント クラスタ ファイルをアップロードする
    Silk Performer の動的作業負荷割り当てをサポートするプロジェクトの負荷テスト エージェント クラスタ ファイルを追加または変更します。
  • 負荷テスト エージェント クラスタ ファイルを削除する
    負荷テスト エージェント クラスタ ファイルを削除して、アプリケーション サーバーから取り除きます。
  • 負荷テスト エージェント クラスタ ファイルを編集する
    Silk Performer の動的作業負荷割り当てをサポートするプロジェクトの負荷テスト エージェント クラスタ ファイルを編集します。
  • [負荷テスト エージェント クラスタ] ページ
    現在の負荷テスト エージェント クラスタの XML ファイルが表示されます。
親トピック: インフラストラクチャ


負荷テスト エージェント クラスタ ファイルをアップロードする

Silk Performer の動的作業負荷割り当てをサポートするプロジェクトの負荷テスト エージェント クラスタ ファイルを、追加または変更する方法について説明します。

プロジェクトのエージェント クラスタ ファイルの定義を変更するには：

  1. メニューで 管理 > システム設定 をクリックします。
  2. 負荷テスト エージェント クラスタ タブをクリックします。
  3. アップロード をクリックします。
  4. エージェント クラスタ ファイルのアップロード ダイアログ ボックスで、ローカル ディスク上のエージェント クラスタ ファイルのロケーションを参照します。 ファイルをアップロードすると、それが 負荷テスト エージェント クラスタ ページに表示されます。
  5. OK をクリックし、選択内容を確定します。
親トピック: Silk Performer 負荷テスト エージェント クラスタ
関連タスク
負荷テスト エージェント クラスタ ファイルを編集する


負荷テスト エージェント クラスタ ファイルを削除する

負荷テスト エージェント クラスタ ファイルを削除して、アプリケーション サーバーから取り除きます。

負荷テスト エージェント クラスタ ファイルを削除するには：

  1. メニューで 管理 > システム設定 をクリックします。
  2. 負荷テスト エージェント クラスタ タブをクリックします。
  3. 削除 を選択します。
  4. 問題がなければ はい をクリックします。
親トピック: Silk Performer 負荷テスト エージェント クラスタ


負荷テスト エージェント クラスタ ファイルを編集する

プロジェクトのエージェント クラスタ ファイルの定義を編集するには：

  1. メニューで 管理 > システム設定 をクリックします。
  2. 負荷テスト エージェント クラスタ タブをクリックします。
  3. 変更する負荷テスト エージェント クラスタ ファイルの名前をクリックします。
  4. ファイルをダウンロードします。
  5. エディタでファイルを編集します。
  6. ファイルをアップロードします。 詳細については、「負荷テスト エージェント クラスタ ファイルをアップロードする」を参照してください。
親トピック: Silk Performer 負荷テスト エージェント クラスタ
関連タスク
負荷テスト エージェント クラスタ ファイルをアップロードする


[負荷テスト エージェント クラスタ] ページ

管理 > システム設定 > 負荷テスト エージェント クラスタ

負荷テスト エージェント クラスタ ページには、現在構成されている負荷テスト エージェント クラスタの XML ファイルが表示されます。 このページを使用して、動的作業負荷割り当てをサポートする Silk Performer 負荷テスト エージェント クラスタ ファイルを管理します。

このページでは、次のアクションを実行できます。

  • アップロード をクリックすると、負荷テスト エージェント クラスタの XML ファイルをアップロードできます。
  • 削除 をクリックすると、既存の負荷テスト エージェント クラスタの XML ファイルを削除できます。
  • 負荷テスト エージェント クラスタ ファイルの名前をクリックし、そのファイルをダウンロードして編集します。
親トピック: Silk Performer 負荷テスト エージェント クラスタ


システム診断

システム診断 タブを使用すると、診断情報やシステム ログ ファイルを取得できます。

  • システム診断
    システム診断を表示およびダウンロードする方法について説明します。
  • フロントエンド サーバー ログ
    フロントエンド サーバー ログ ファイルについて説明します。
  • アプリケーション サーバー ログ
    アプリケーション サーバー ログについて説明します。
親トピック: クライアントの管理
関連概念
Micro Focus SupportLine が必要とする情報


システム診断

システム診断 ページには、次のシステム情報を取得するための次の方法が備わっています。

  • 製品バージョン。
  • データベースのバージョンとタイプ。
  • 使用したインテグレーション。
  • システム環境情報とシステムのプロパティ。
  • JDBC 情報。
  • データベース情報：プロジェクト、テスト タイプ、インデックス、トリガ、制約の数。
  • アプリケーション サーバーとフロントエンド サーバーのログ。

ダウンロード ボタンをクリックして、ページの内容を ZIP してローカル ファイル システムにダウンロードすることができます。サーバー ログに対応するチェック ボックスをチェックすると、サーバー ログをダウンロードすることができます。

  1. システム診断 ページには、リモートから、もしくはフロントエンド サーバーを実行しているローカル マシンからアクセスすることができます。ローカルからのアクセスの場合は、システムにログインする必要はありません。
    • リモート アクセスの場合：
      1. Silk Central システム管理者としてログインします。
      2. システム診断 > システム診断 をクリックします。
      3. システム診断を開く をクリックします。
    • ローカル アクセスの場合：
      1. フロントエンド サーバーを実行しているマシン上で、http://localhost:19120/systemdiagnostics または http://127.0.0.1:19120/systemdiagnostics を開きます（ホスト名やサーバーの外部 IP アドレスは使用できません）。
  2. ダウンロードする Silk Central サーバー ログを選択します。チェック ボックスを使用して選択します。
  3. ダウンロード をクリックし、データを zip して、ローカルのファイルシステムにダウンロードします。
親トピック: システム診断
親トピック: Micro Focus へのお問い合わせ


フロントエンド サーバー ログ

このページにアクセスするには、Silk Central システム管理者としてログインし、システム診断 > フロントエンド サーバー ログ をクリックします。 詳細については、「Silk Central システム管理者」を参照してください。

このページは、Silk Central フロントエンド サーバー サービスのログ情報の表示に使用します。

ログ ファイルごとに、次の列がページに表示されます。

列 | 説明
アクション | (削除) および [image] (ダウンロード) のボタンをクリックして、ログ ファイルを削除またはダウンロードします。
名前 | ログ ファイルの名前。
サイズ | ログ ファイルの物理的サイズ。
日時 | ログ ファイルが最後に物理的に保存された日時。
親トピック: システム診断
関連概念
Silk Central システム管理者


アプリケーション サーバー ログ

このページにアクセスするには、Silk Central システム管理者としてログインし、システム診断 > アプリケーション サーバー ログ をクリックします。 詳細については、「Silk Central システム管理者」を参照してください。

Silk Central アプリケーション サーバー サービスのログ情報の表示に使用します。

ログ ファイルごとに、次の列がページに表示されます。

列 | 説明
アクション | (削除) および [image] (ダウンロード) のボタンをクリックして、ログ ファイルを削除またはダウンロードします。
名前 | ログ ファイルの名前。
サイズ | ログ ファイルの物理的サイズ。
日時 | ログ ファイルが最後に物理的に保存された日時。
親トピック: システム診断
関連概念
Silk Central システム管理者


高度な設定

このセクションでは、高度な設定によって Silk Central システムをカスタマイズする方法について説明します。

  • ログイン オプション
    機能強化されたログイン設定について説明します。
  • 疑わしい実行時間
    実行に時間がかかりすぎている場合に管理者に電子メールで通知する方法について説明します。
  • 外部の問題統計の更新を無効にする
    外部の問題追跡プロファイルの問題統計の更新を無効にする方法について説明します。
  • 日時の書式
    Silk Central に備えられている、ユーザー定義の日時の書式設定を使用する方法について説明します。
  • ホスト名の表示
    Web ブラウザのタイトル バーでフロントエンド サーバーのホスト名を表示する方法について説明します。
  • 添付ファイルと結果ファイルをファイル システムに保存する
    デフォルトでは、Silk Central はすべての添付ファイルと結果ファイルをデータベースに格納しますが、これらのファイルをアプリケーション サーバーのファイル システム上に保存するように Silk Central を設定できます。
  • LQM Reporting Updater を設定する
    LQM レポート作成テーブルを更新するスレッド (LQM Reporting Updater) の間隔およびその他の設定を行います。
  • LDAP グループの自動同期スケジュールを作成する
    Silk Central システムで LDAP サーバーからユーザー グループをインポートした場合、LDAP サーバー上で行われた変更で Silk Central グループを自動的に同期するスケジュールを指定できます。
  • テストのデータ キャッシング
    Silk Central で、キャッシングを利用して、フロントエンド サーバーのスケーラビリティの向上とデータベース負荷の削減を図る仕組みについて説明します。
  • JMX 設定を構成する
    JMX 設定を構成できる場所について説明します。
  • 実行サーバー ホスト名の解決
    実行サーバーは、IP アドレスが変わると、もうアプリケーション サーバーから認識されなくなる可能性があります。
  • Silk Central の場所を Issue Manager で設定する
    Silk Central インストールの場所を Issue Manager で設定して、問題から関連するテストをトレースできるようにします。
  • 実行サーバー上の使用されていないポートを無効にする
    実行サーバーで使用されていないポートを無効にします。
  • MRU レポートの最大数を設定する
    レポート ユニットにある 最近使ったレポート リスト ボックスに表示される MRU (Most Recently Used：最近使用された) レポートの最大数を設定します。
  • Silk Central サーバーのメモリ設定
    Silk Central サーバーのメモリ設定について説明します。
  • ステップの結果ファイルの最大サイズを設定する
    手動テストの実行時にテスト担当者がテスト ステップに添付できる結果ファイルの最大サイズを制限する方法について説明します。
  • Silk Performer 結果のパーセンタイル マーカー データを格納する
    Silk Performer 結果のパーセンタイル マーカー データにアクセスしたい場合に格納できます。
親トピック: インフラストラクチャの構成と管理


ログイン オプション

次の 2 つのログイン設定が機能強化されています。

ログイン情報の保存

Silk Central ログイン ページの ログイン情報を保存する オプションのデフォルト設定が変更されています。

通常、ユーザーが複数のブラウザ ウィンドウで作業をしている場合には、ブラウザのセッションごとに 1 つのライセンスが必要です。ログイン情報を保存する を有効にすると、1 人のユーザーが 1 台のコンピュータで複数のブラウザ セッションを使っていても、使用するライセンスは 1 つで済みます。

ログイン情報を保存する オプションは、各ユーザーが必要に応じて有効にしたり無効にしたりすることができますが、デフォルト設定を指定できるのは管理者です。

Cookie の有効期間

ユーザーが Silk Central にアクセスするたびに、エンコードされたログイン情報を持つ Cookie が作成されます。この Cookie は、ユーザーがログアウトするかセッションがタイムアウトすると破棄されます。ただし、ログイン情報を保存する オプションが有効になっている場合には、セッションがタイムアウトしても Cookie は破棄されません。指定の有効期間内は Cookie はアクティブなままです。この機能によって、ユーザーはセッションがタイムアウトするたびにログイン情報を入力し直さなくても、Silk Central を使い続けることができます。デフォルトでは、Cookie の有効期間は 30 日です。有効期間の設定を変更できるのは管理者です。

  • ログイン情報を保存するオプションを設定する
    ログイン情報を保存する オプションを設定して、1 人のユーザーが 1 台のコンピュータで複数のブラウザ セッションを使っていても、使用するライセンスが 1 つで済むようにします。
  • Cookie の有効期間を調整する
    ログイン Cookie の有効期間を調整して、システムにログイン情報を保存する期間を変更します。
親トピック: 高度な設定
関連概念
スーパー ユーザー
関連タスク
Silk Central にログインする


ログイン情報を保存するオプションを設定する

ログイン情報を保存するオプションを有効または無効にするには：
  1. インスタンス管理 ページで、変更するインスタンスのフロントエンド サーバーを停止します。
  2. SccFrontendBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、フロントエンド サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\FontendServer になります。
  3. BootConf\Options\Login\RememberLogin という XML タグを探します。 このタグは、デフォルトで <RememberLogin>true</RememberLogin> に設定されています。
  4. この値を false に設定すると、ログイン ページを開いたときにデフォルトで ログイン情報を保存する チェック ボックスがオフになります。この値を true に設定すると、ログイン ページを開いたときにデフォルトで ログイン情報を保存する チェック ボックスがオンになります。
  5. XML ファイルを保存して閉じます。
  6. フロントエンド サーバーを再起動します。
親トピック: ログイン オプション
関連タスク
インスタンスの管理


Cookie の有効期間を調整する

ログイン Cookie の有効期間を設定するには：

  1. インスタンス管理 ページで、変更するインスタンスのフロントエンド サーバーを停止します。
  2. SccFrontendBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、フロントエンド サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\FontendServer になります。
  3. BootConf\Options\Login\MaxCookieAge という XML タグを探します。 このタグは、デフォルトで <MaxCookieAge>30</MaxCookieAge> に設定されています。
  4. ユーザーのコンピュータ上でログイン Cookie を何日間有効にするかの値を設定します。
  5. XML ファイルを保存して閉じます。
  6. フロントエンド サーバーを再起動します。
親トピック: ログイン オプション
関連タスク
インスタンスの管理


疑わしい実行時間

テスト の実行時間はさまざまですが、実行に時間がかかりすぎている場合には、実行計画に最後の変更を加えたユーザーはに電子メールで通知を送ることができます。

テスト 実行がある時間よりも長くかかると、Silk Central は通知を送ります。ユーザーは、テスト 実行にどれだけの時間がかかったときに電子メールを送るかを設定することができます。

注: テスト 領域の 成功条件 にある 実行タイムアウト [秒] プロパティを指定することで、特定のテストごとにタイムアウトを設定することもできます。
  • 疑わしい実行時間を設定する
    疑わしい実行時間を設定して、Silk Central が管理者に通知を送信するまでの テスト の許容実行時間を定義します。
親トピック: 高度な設定


疑わしい実行時間を設定する

疑わしい実行時間を設定するには：

  1. インスタンス管理 ページで、変更するインスタンスのアプリケーション サーバーを停止します。
  2. TmAppServerHomeConf.xml ファイルをテキスト エディタで開きます。
    このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\AppServer になります。
  3. Config\ExecutionTracking\SuspicousDuration という XML タグを探します。 このタグは、デフォルトで <SuspicousDuration>360</SuspicousDuration> に設定されています。
  4. テスト 実行に時間がかかりすぎているときに、何分後に Silk Central が管理者に通知を出すかの値を設定します。
  5. XML ファイルを保存して閉じます。
  6. アプリケーション サーバーを再起動します。
親トピック: 疑わしい実行時間
関連タスク
インスタンスの管理


外部の問題統計の更新を無効にする

外部の問題追跡プロファイルの問題統計の更新は多くのメモリを使用する場合があります。これによりパフォーマンスが低下する可能性もあります。更新を無効にするには：
  1. インスタンス管理 ページで、変更するインスタンスのアプリケーション サーバーを停止します。
  2. TmAppServerHomeConf.xml ファイルをテキスト エディタで開きます。
    このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\AppServer になります。
  3. Config/IssueStateUpdate/UpdateIssueUnitStatistics という XML タグを探します。 このタグは、デフォルトで true に設定されています。
  4. 値を false に設定して、更新を無効にします。
  5. XML ファイルを保存して閉じます。
  6. アプリケーション サーバーを再起動します。
親トピック: 高度な設定
関連タスク
インスタンスの管理


日時の書式

Silk Central では、ユーザー定義の日時の書式を設定できます。Silk Central ユーザーは、各自が自分専用のユーザー設定を変更することができます。その設定には、日付をカスタマイズ表示するための長い日付と短い日付の書式のオプションが含まれます。詳細については、「ユーザー アカウントを編集する」を参照してください。

Silk Central によって、定義済みの日時の書式のリストが提示されます。ユーザーは、このリストから選択を行うことができます。Silk Central 管理者は、このリストにカスタマイズした書式を追加することができます。

パターン定義

日時の書式は、日時のパターン文字列で指定します。日時のパターン文字列内では、引用符で囲まない「A」から「Z」までと「a」から「z」までの文字は、日時の文字列の構成要素を表すパターン文字として解釈されます。テキストを解釈させないためには、一重引用符「'」を使います。「''」 は一重引用符を表します。その他の文字はどれも解釈されません。整形時にはそのまま出力文字列にコピーされ、解析時には入力文字列と照合されます。

次のパターン文字が定義されています。それ以外の「A」から「Z」までと「a」から「z」までの文字はすべて予約済みです。
文字 | 日時の構成要素 | 表示 | 使用例
G | 紀元の指定 | テキスト | AD
y | 年 | 年 | 1996、96
M | 年内の月 | 月 | July、Jul、07
w | 年内の週番号 | 数 | 27
W | 月内の週番号 | 数 | 2
D | 年内の日番号 | 数 | 189
d | 月内の日番号 | 数 | 10
F | 月内の何度目の曜日か | 数 | 2
E | 曜日 | テキスト | Tuesday、Tue
a | 午前/午後の指定 | テキスト | PM
H | 24 時間表記の時間（0 から 23） | 数 | 0
k | 24 時間表記の時間（1 から 24） | 数 | 24
K | 午前/午後表記の時間（0 から 11） | 数 | 0
h | 午前/午後表記の時間（1 から 12） | 数 | 12
m | 時間内の分 | 数 | 30
s | 分内の秒 | 数 | 55
S | ミリ秒 | 数 | 978
z | タイム ゾーン | 一般的なタイム ゾーン | Pacific Standard Time、PST、GMT-08:00
Z | タイム ゾーン | RFC 822 タイム ゾーン | -0800

文字の数によって正確な表示方法が決まるため、パターン文字は通常、繰り返されます。

次のリストでは、上の表の 表示 列の項目について説明します。
項目
説明
テキスト
整形時には、パターン文字の数が 4 以上であれば完全形式を使用し、4 未満のときには短縮形式があればそれを使用します。解析時には、パターン文字の数に関係なく、両方の書式を受け入れます。
数
整形時には、パターン文字の数が最低桁数になり、足りない部分はゼロで埋められます。解析時には、隣接する 2 つのフィールドを分けるのに必要な場合を除いて、パターン文字の数は無視されます。
年
整形時には、パターン文字の数が 2 であれば 2 桁に短縮して表示され、それ以外のときには数として解釈されます。
月
パターン文字の数が 3 以上であれば月はテキストとして解釈され、それ以外のときには数として解釈されます。
一般的なタイム ゾーン
タイム ゾーンは、名前が付けられているときにはテキストとして解釈されます。パターン文字の数が 4 未満の場合には、タイム ゾーンの短縮形が表示されます（PST など）。パターン文字の数が 4 以上であれば、完全名が表示されます（Pacific Standard Time など）。
RFC 822 タイム ゾーン
RFC 822 の 4 桁のタイム ゾーン書式が使われます（-0800 など）。

使用例

次の例は、日時のパターンが米国でどのように解釈されるかを示したものです。例に使った日時は、2001-07-04 12:08:56 ローカル タイム、太平洋標準時タイム ゾーンです。
日時のパターン | 結果
"yyyy.MM.dd G 'at' HH:mm:ss z" | 2001.07.04 AD at 12:08:56 PDT
"EEE, MMM d, ''yy" | Wed, Jul 4, '01
"h:mm a" | 12:08 PM
"hh 'o''clock' a, zzzz" | 12 o'clock PM, Pacific Daylight Time
"K:mm a, z" | 0:08 PM, PDT
"yyyyy.MMMMM.dd GGG hh:mm aaa" | 02001.July.04 AD 12:08 PM
"EEE, d MMM yyyy HH:mm:ss Z" | Wed, 4 Jul 2001 12:08:56 -0700
"yyMMddHHmmssZ" | 010704120856-0700
  • 日時の書式をカスタマイズする
    自分のニーズに合わせて日付を表示するために、日時の書式設定をカスタマイズします。
親トピック: 高度な設定
関連タスク
ユーザー アカウントを追加する
ユーザー アカウントを編集する
ユーザー アカウントを削除する


日時の書式をカスタマイズする

日時の書式をカスタマイズするには：

  1. インスタンス管理 ページで、変更するインスタンスのフロントエンド サーバーを停止します。
  2. SccFrontendBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、フロントエンド サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\FontendServer になります。
  3. DateFormats という XML タグを探します。 <LongDateFormats> および <ShortDateFormats> の XML タグに、デフォルトで利用可能な日付の書式が示されています。書式を追加してユーザーが利用できるようにしたり、書式を削除して利用できないようにしたりできます。
  4. 日時の書式は、「日時の書式」の説明に従ってください。
  5. XML ファイルを保存して閉じます。
  6. フロントエンド サーバーを再起動します。
親トピック: 日時の書式
関連タスク
インスタンスの管理


ホスト名の表示

複数のフロントエンド サーバー上の Web アプリケーションを使って作業している場合には、どのホスト上で作業しているかがわかると便利です。 Silk Central では、Web ブラウザのタイトル バーにフロントエンド サーバーのホスト名を表示するかどうかを設定することができます。

  • Web ブラウザのタブ名でのホスト名の表示/非表示を切り替える
    Web ブラウザのタイトル バーでの Silk Central フロントエンド サーバーのホスト名の表示/非表示を切り替えます。
親トピック: 高度な設定


Web ブラウザのタブ名でのホスト名の表示/非表示を切り替える

Web ブラウザのタブ名でのホスト名の表示/非表示を切り替えるには：

  1. インスタンス管理 ページで、変更するインスタンスのフロントエンド サーバーを停止します。
  2. SccFrontendBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、フロントエンド サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\FontendServer になります。
  3. ファイルの Options セクションで DisplayHostNameInTitleBar という XML タグを探します。
  4. 値を true に設定すると、Silk Central にアクセスしたときに、フロントエンド サーバーのホスト名が Web ブラウザのタイトル バーに表示されます。値を false（デフォルト値）に設定するとホスト名は表示されず、値をそれ以外の文字列に設定すると指定した文字列が表示されます。Silk Central で現在選択されているユニットは、常に表示されます。

    たとえば、XML タグを true に設定すると、ブラウザには<ユニット> | ホスト名 が表示されます。

    タグを false に設定すると、ブラウザには<ユニット> | Silk Central が表示されます。

    たとえば、MyCustomText というカスタム テキストを入力した場合は、ブラウザには<ユニット> | MyCustomText が表示されます。

    タグを空に設定すると、ブラウザには<ユニット> | が表示されます。

  5. XML ファイルを保存して閉じます。
  6. フロントエンド サーバーを再起動します。
親トピック: ホスト名の表示
関連タスク
インスタンスの管理


添付ファイルと結果ファイルをファイル システムに保存する

デフォルトでは、Silk Central はすべての添付ファイルと結果ファイルをデータベースに格納しますが、これらのファイルをアプリケーション サーバーのファイル システム上に保存するように Silk Central を設定できます。
添付ファイルと結果ファイルを他のデータと異なる場所に保存することは推奨しませんが、このアプローチが理にかなっている場合もあります（データベース空間のコストなど）。このアプローチの欠点は、データを 2 箇所でメンテナンスしなくてはならないことです。つまり、データベースとファイル システムの両方をバックアップする必要があります。データベース バックアップをリストアする際には、ファイル システムもリストアする必要があります。
注意:
ファイル システムにファイルを保存するように設定した場合、この場所にあるファイルを直接操作して移動、更新、削除したり、その構造を変更することは絶対にしないでください。Silk Central サービスとバックアップとリストアに使用するシステムだけが、ファイル ストアのルート ディレクトリ で指定したディレクトリへの書き込み権を持つべきです。
  1. インスタンス管理 ページで、変更するインスタンスをメンテナンス モードに切り替えます。詳細については、「メンテナンス モード」を参照してください。
  2. Silk Central システム管理者としてインスタンスにログインし、データベースから切断します。詳細については、「データベースから切断する」を参照してください。
  3. インスタンス管理 ページで、変更するインスタンスを停止します。
  4. SccAppServerBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\AppServer になります。
  5. ファイルの <Config>/<RdbmsSpecifics> セクションで <StoreFilesOnFileSystem> という XML タグを探します。このタグの値を true に設定します。
  6. XML ファイルを保存して閉じます。
  7. インスタンス管理 ページで、インスタンスを再起動します。
  8. Silk Central システム管理者としてインスタンスに再びログインします。データベース ページに ファイル ストアのルート ディレクトリ という新しいフィールドが表示されます。このフィールドで、添付ファイルと結果ファイルの保存に使用するローカル パス（c:/sc_files/testdb など）を定義します。このパスは既に存在している必要があり、フロントエンド サーバーとアプリケーション サーバーのサービスは、このフォルダに対する完全なアクセス許可が必要です。
  9. データベースに接続 をクリックします。
すべての添付ファイルと結果ファイルが指定した場所に保存されます。接続したデータベースに既に格納されている添付ファイルと結果ファイルは、ファイル システムに徐々に移動されます。ファイル システムが利用可能でない場合、Silk Central はデータベースの BLOB テーブルにファイルを格納し、後でファイル システムが利用可能になった時点で、ファイル システムに移動します。

ファイルをデータベースに自動的に戻す方法は現在ありません。ファイルをファイル システムに保存するという決定が将来的に変更されることがない場合にのみ、このオプションを有効にしてください。

親トピック: 高度な設定


LQM Reporting Updater を設定する

LQM レポート作成テーブルを更新するスレッド (LQM Reporting Updater) の間隔およびその他の設定を行う方法について説明します。

LQM Reporting Updater を設定するには：

  1. インスタンス管理 ページで、変更するインスタンスのアプリケーション サーバーを停止します。
  2. TmAppServerHomeConf.xml ファイルをテキスト エディタで開きます。
    このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\AppServer になります。
  3. LQMReporting という XML タグを探します。 次の設定を変更できます。
    UpdateInterval
    LQM レポート作成テーブルが最新のデータで更新される間隔を秒単位で定義します。
    MSSqlUpdateBatchSize
    同時に処理されるテスト テーブルの数。このバッチ サイズによって、アプリケーション サーバーで更新プロセスのために使用されるメモリとプロセッサ リソースの量が決まります。この設定は、Microsoft SQL Server データベース専用です。
    OracleUpdateBatchsize
    MSSqlUpdateBatchSize と同様ですが、Oracle データベースの設定です。
    QueryTimeout
    LQM レポート作成の更新プロセスがタイムアウトになり、クエリが中止されるまでの時間を秒単位で指定します。0 または負の値を指定すると、クエリはタイムアウトしません。
    OracleCheckForUpdateStrategy
    更新プロセスがソース テーブルからデータを読み込む方法を決定します。指定できる値は、NOWAIT または WAIT です。
    • NOWAIT：更新プロセスがソース テーブルからデータを読み込もうとしたときに、他のプロセスがこれらのテーブルに書き込みをしている場合、更新プロセスは終了し、次回呼び出されたときに再試行します。
    • WAIT：更新プロセスは、テーブル ロックを取得し、他のプロセスがテーブルへのアクセスを終了するのを待って、ソース テーブルからデータを読み込みます。この設定の良い点は、更新プロセスが必ず実行されることです。テーブルのロックが解除されるのを待つ必要がありません。悪い点は、LQM 更新プロセスの後にテーブルにアクセスしようとする他のすべてのプロセスがブロックされ、更新プロセスがテーブル ロックを解除するまで待たなければならないことです。
  4. XML ファイルを保存して閉じます。
  5. アプリケーション サーバーを再起動します。
親トピック: 高度な設定
関連タスク
インスタンスの管理


LDAP グループの自動同期スケジュールを作成する

Silk Central システムで LDAP サーバーからユーザー グループをインポートした場合、LDAP サーバー上で行われた変更で Silk Central グループを自動的に同期するスケジュールを指定できます。
LDAP サーバー上で行われた変更で Silk Central グループを同期するスケジュールを定義するには：
  1. インスタンス管理 ページで、変更するインスタンスのアプリケーション サーバーを停止します。
  2. TmAppServerHomeConf.xml ファイルをテキスト エディタで開きます。
    このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\AppServer になります。
  3. LdapUpdate という XML タグを探します。 次の設定を変更できます。
    ScheduledTime
    LDAP からデータを最初に更新するタイムスタンプ（24 時間制の hh:mm 形式）ScheduledTime はアプリケーション サーバーのシステム環境のタイムゾーンで読み込まれます。自動同期を無効にする場合には、この設定を空にしてください。
    UpdateIntervalInMinutes
    LDAP グループとユーザーの同期が、ScheduledTime で開始から繰り返し実行する間隔（分）を指定します。最小値は 1 です。
  4. XML ファイルを保存して閉じます。
  5. アプリケーション サーバーを再起動します。
親トピック: 高度な設定
親トピック: グループをメンテナンスする
関連タスク
LDAP サーバーからグループをインポートする


テストのデータ キャッシング

Silk Central では、テスト でのキャッシングを利用して、フロントエンド サーバーのスケーラビリティの向上と、複数のユーザーが同じプロジェクトで同時に作業する際のデータベース負荷の削減を図っています。テスト ツリーとテスト フィルタは、フロントエンド サーバーとデータベース サーバーにかなりの負荷を与えます。特定のプロジェクトに対する テスト ツリーとフィルタの情報は、複数のユーザーの間で共有されるので、この領域はキャッシングに非常に適しています。

テスト ツリーのキャッシング

テスト ツリーのキャッシュは、メモリで現在使用中のプロジェクトのすべてのツリー情報を保持します。また、定期的にデータベースをチェックし、ツリーに変更がないかどうかを確認します。管理者は、TMFrontendBootConf.xml 設定ファイルの Cache/TestPlanTree/CheckForChangesInterval を設定することによって、キャッシュの動作を変更できます。これは、ツリー情報が古いままになっている期間の最大値（秒）を表します。この設定に関係なく、同じフロントエンド サーバー上のテスト、フォルダ、またはコンテナに変更が生じた場合は、直ちにキャッシュに変更が反映されます。Cache/TestPlanTree/CheckForChangesInterval の設定は、別のフロントエンド サーバー上で変更が生じた場合にのみ関係します。プロジェクトが 1 時間より長い時間ユーザーに使われてない場合は、そのプロジェクト ツリーのキャッシュ全体がクリアされます。そのプロジェクトは、次回ユーザーがそのプロジェクトにアクセスしたときに再ロードされます。

テスト フィルタのキャッシング

フィルタのキャッシングを利用すると、特定のフィルタ基準に一致するテストの ID が、指定した期間 (キャッシュの最小時間設定に基づく) または各フィルタの実行時間だけキャッシュされます。管理者は、TMFrontendBootConf.xml 設定ファイルの Cache/FilterCache/ の 2 つのプロパティを設定することによって、この動作を変更できます。

第 1 のプロパティ MinimalLifeTime は、フィルタ結果がキャッシュから削除されるまでの最小時間（秒）を定義します。第 2 のプロパティ LifeTimeMultiplier は、この最小時間の設定がフィルタのクエリの実行時間に依存するようにします。たとえば、係数を > 0 に設定すると、フィルタ結果がキャッシュに保持される最大時間は MinimalLifeTime、またはクエリの実行時間を LifeTimeMultiplier 倍した値になります。したがって、フィルタのクエリの実行時間が 1 秒の場合、MinimalLifeTime と LifeTimeMultiplier にデフォルト値（共に 30）を使用すると、フィルタ結果は 30 秒間キャッシュされます。フィルタのクエリの実行時間が 30 秒の場合は、フィルタ結果は、やはり 30 秒間キャッシュされます。一方、フィルタのクエリの実行時間が 2 秒の場合は、フィルタ結果は 60 秒間キャッシュされます。

レコメンド エンジンのキャッシング

キーワード駆動テスト エディター でキーワード駆動テストにキーワードを追加するとき、Silk Central は、そのテストの次のキーワードとして使用する可能性のある既存のキーワードを推薦します。推薦するキーワードはキーワード リストの上位にリストされ、Silk Central がどの程度そのキーワードを推薦しているかが、棒グラフの塗りつぶした長さによって示されます。

管理者は、TMFrontendBootConf.xml 設定ファイルの RecommendationCache/ExpireAfterWrite プロパティを設定することによって、レコメンド キャッシュの更新間隔を変更できます。

キャッシュに関する JMX 測定

Silk Central では、基盤となる Java プロセスを監視するための JMX 読み取り測定、およびその他のプロセス固有の測定を提供しています。テスト ツリーのキャッシュおよびテスト フィルタのキャッシュについての JMX 情報は、borland.com/Frontend/TM の JMX measures (JMX 測定) ツリーにあります。

注: Silk Performance Explorer やその他のツールを使用して、これらの測定を追跡することができます。
  • テストのキャッシュについての JMX 測定
    テスト ツリーのキャッシュおよびフィルタのキャッシュについての JMX 情報は、フロントエンド サーバーの borland.com/Frontend/TM の JMX measures (JMX 測定) ツリーにあります。
親トピック: 高度な設定
関連資料
テストのキーワードを管理する
ライブラリのキーワードを管理する
Silk Central のキーワード レコメンド機能


テストのキャッシュについての JMX 測定

テスト ツリーのキャッシュおよびフィルタのキャッシュについての JMX 情報は、フロントエンド サーバーの borland.com/Frontend/TM の JMX measures (JMX 測定) ツリーにあります。

テスト ツリー キャッシュの測定

テスト ツリーのキャッシュに対しては、2 つの主要な測定を利用できます。TestPlanTreeCache は、現在キャッシュされているプロジェクトの数の測定のみを提供します（NumberOfCachedProjects）。プロジェクトのキャッシュについてのすべての詳細情報は、2 番目の測定から得ることができます（TestPlanTreeCache_<number>）。この測定は、実際には次の測定から構成されています。

測定 | 説明
Hits | データベースへの要求が行われず、キャッシュが使用された回数。
LastUpdateCheckDurationInMillis | 前回の更新（LastUpdateCheckTime を参照）で、データベース内の更新をチェックするためにかかった時間（ミリ秒）。
LastUpdateCheckTime | 前回の更新のチェックが発生した時間。
LastUpdateDurationInMillis | 前回の更新（LastUpdateTime を参照）で、変更が発生してからキャッシュを更新するまでにかかった時間（ミリ秒）。
LastUpdateTime | テスト ツリー内での変更によって、最後にキャッシュの更新が発生した時間。
TreeInitializationTimeInMillis | プロジェクト ツリー全体をキャッシュにロードするためにかかった時間（ミリ秒）。この値は、プロジェクト キャッシュがロードされている場合は変更されません。
TreeSize | プロジェクト内のテスト ノード (テスト コンテナ、テスト フォルダ、およびテスト) の数。
UpdateChecks | プロジェクト ツリーのキャッシュが初期化されてから、このプロジェクトの テスト ツリーに対して行われた変更をチェックした回数。
Updates | テスト ツリー内での変更によって、キャッシュされたツリーが更新された回数。

テスト フィルタ キャッシュの測定

TestPlanFilterCache 測定は、次の 3 つの測定から構成されています。

測定 | 説明
Hits | キャッシュが使用され、別個にデータベースに対するフィルタを実行する必要がなかった回数。
Misses | フィルタ キャッシュが使用されず、フィルタがデータベースに対して実行された回数。
Size | 現在のキャッシュされたフィルタ結果の数。
親トピック: テストのデータ キャッシング
親トピック: JMX 設定を構成する


JMX 設定を構成する

Silk Central では、JMX 設定を構成するために、いくつかのデフォルト ポートが用意されています。

JMX 設定を構成することができる場所

デフォルト ポート上での通信は、デフォルトでは暗号化されておらず、つまり、SSL は動作していません。
重要: Micro Focus は、ユーザーの JMX セキュリティ設定に関する責任を負いません。御社の IT 部門が JMX セキュリティを適切に構成していることをご確認ください。
設定 | 説明
com.sun.management.jmxremote.ssl | SSL は、デフォルトでは false に設定されています。
com.sun.management.jmxremote.authenticate | 認証機能は、デフォルトでは false に設定されています。
これらの設定は、C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<インスタンス番号>_<インスタンス名>\Conf にある processconfig ファイルで変更できます。2 つの設定のいずれかが false に設定されている場合、JMX 接続はセキュリティで保護されていません。

JMX の情報にアクセスしたり、オペレーションを実行するには、JMX 接続文字列が必要です。 設定 をクリックして、設定 ダイアログを開きます。サーバー タブで、目的のサーバーを選択し、JMX 接続 に表示されている文字列をコピーします。 詳細については、「インスタンスの管理」を参照してください。

  • テストのキャッシュについての JMX 測定
    テスト ツリーのキャッシュおよびフィルタのキャッシュについての JMX 情報は、フロントエンド サーバーの borland.com/Frontend/TM の JMX measures (JMX 測定) ツリーにあります。
  • LQM Reporting Updater を監視するための JMX 測定
    LQM Reporting Updater に関する JMX 情報は、borland.com/LQMReporting/TM の JMX measures（JMX 測定）ツリーにあるユーザーのアプリケーション サーバーの箇所にあります。
  • DataMart についての JMX 測定
    DataMart に関する JMX 情報は、borland.com/DataMart の JMX measures（JMX 測定）ツリーにあるユーザーのアプリケーション サーバーの箇所にあります。
  • LDAP 同期についての JMX 測定
    LDAP 同期に関する JMX 情報は、borland.com/LdapUpdater の JMX measures（JMX 測定）ツリーにあるユーザーのアプリケーション サーバーの箇所にあります。
親トピック: 高度な設定


LQM Reporting Updater を監視するための JMX 測定

LQM Reporting Updater の測定

次の測定を使用できます。

測定 | 説明
LastDataLoadResetTime | 最後に LQM レポート作成テーブルのリセットが実行された時間を返します。この属性が NULL の場合、このプロセスでリセットが実行されたことがないことを示します。
LastDeleteDurationInMillis | 削除済みノードを LQM レポート作成テーブルから削除するためにかかった時間。
LastDeleteTestsCnt | 前回の実行で削除されたテストの数。
LastInsertLQMTestsDuration | LQM_Tests テーブルに新しいテストを挿入するためにかかった時間。
LastInsertLQMTestPDAsDuration | LQM_TestPDAs テーブルに新しいテストを挿入するためにかかった時間。
LastInsertLQMTestUDAsDuration | LQM_TestUDAs テーブルに新しいテストを挿入するためにかかった時間。
LastRunFromDate | 現在の更新サイクルの処理が開始された時間を返します。
LastRunToDate | 現在の更新サイクルの処理が終了する時間を返します。
LastSelectChangedDataIterateDurationInMillis | 変更されたデータの走査にかかった時間。
LastSelectChangedDataQueryDurationInMillis | 変更されたデータを問い合わせるためにかかった時間。
LastTotalUpdateDurationInMillis | 前回の更新の実行にかかった時間の合計。
LastUpdateFixedAttributesDurationInMillis | 前回の修正された属性に対する更新にかかった時間。
LastUpdatePDAttributesDurationInMillis | LQM_TestPDAs テーブルの前回の更新にかかった時間。
LastUpdatesNeededCheckDurationInMillis | 前回の新しいデータまたは変更されたデータのチェックにかかった時間（ミリ秒）。
LastUpdatesNeededCheckOracleWaitForTableLocksDuration | Oracle では、更新されたテストをチェックするときに、特別な処理が必要です。場合により、他のプロセスがテスト テーブルに対するトランザクションを終了するまで待機する必要があります。これらのトランザクションを待機した時間が、この属性で測定されます。
LastUpdateTestsDurationInMillis | LQM_Tests テーブルのプロパティに対する前回の更新にかかった時間。
LastUpdateUDAttributesDurationInMillis | LQM_TestUDAs テーブルの前回の更新にかかった時間。
親トピック: JMX 設定を構成する


DataMart についての JMX 測定

DataMart Updater の測定

DataMart Updater に関する JMX 情報は、borland.com/DataMart/TM の JMX measures（JMX 測定）ツリーにあるユーザーのアプリケーション サーバーの箇所にあります。

測定 | 説明
AverageCheckDurationInMilliseconds | 更新された行の確認に使用された平均時間（ミリ秒）
AverageUpdateDurationInMilliseconds | 行の更新に使用された平均時間（ミリ秒）
FailedCheckCount | 更新の確認に失敗した数
FailedUpdateCount | 更新に失敗した数
FastestCheckInMilliseconds | 更新された行の確認に使用された最短時間（ミリ秒）
FastestUpdateInMilliseconds | 行の更新に使用された最短時間（ミリ秒）
Id | DataMart Updater の ID
IntervalInMilliseconds | DataMart Updater の実行頻度を定義する間隔（ミリ秒）
LastBlockedRunDate | 実行が最後にブロックされた時間（排他アクセスの待機に失敗）
LastFailedRunDate | 実行が最後に失敗した時間
LastSuccessfulRunDate | 実行が最後に成功した時間
LatestDataLoadInfo | 最後のデータ読み込みに関する情報
SlowestCheckInMilliseconds | 更新された行の確認に使用された最長時間（ミリ秒）
SlowestUpdateInMilliseconds | 行の更新に使用された最長時間（ミリ秒）
SlowestWaitForExclusiveAccessInMilliseconds | 排他アクセスの待機に使用された最長時間（ミリ秒）
StartupDate | DataMart Updater が初期化された時間
SuccessfulCheckCount | 更新の確認に成功した数
SuccessfulUpdateCount | 更新に成功した数

DataMart サービスの測定

DataMart サービスに関する JMX 情報は、borland.com/DataMart/Service の JMX measures（JMX 測定）ツリーにあるユーザーのアプリケーション サーバーの箇所にあります。

測定/オペレーション | 説明
Enabled | DataMart サービスが有効か無効か
disable() | DataMart サービスを無効化する
enable() | DataMart サービスを有効化する
isEnabled() | DataMart サービスが有効か無効かの問い合わせ
親トピック: JMX 設定を構成する


LDAP 同期についての JMX 測定

LDAP 同期に関する JMX 情報は、borland.com/LdapUpdater の JMX measures（JMX 測定）ツリーにあるユーザーのアプリケーション サーバーの箇所にあります。
測定/オペレーション | 説明
Enabled | 自動 LDAP 同期が有効か無効か
LastDurationInMillis | 最後の LDAP 同期の継続時間 (ミリ秒)
enable() | 自動 LDAP 同期を有効化する
disable() | 自動 LDAP 同期を無効化する
親トピック: JMX 設定を構成する


実行サーバー ホスト名の解決

実行サーバーは、IP アドレスが変わると、もうアプリケーション サーバーから認識されなくなる可能性があります。アプリケーション サーバーを再起動すると、実行サーバーが再び認識されるはずです。

Java では、キャッシュを用いてホスト名解決の結果を保存することで、DNS なりすまし攻撃を防ぎます。Silk Central では、成功したホスト名解決の結果が永久にキャッシュされますが、これは、アプリケーション サーバー上のファイル java.security を編集することで変更することができます。これにより、アプリケーション サーバーは、実行サーバーの IP アドレスが変わっても、それらを認識することができます。

Java の設定についての詳細は、『Networking Properties』ページを参照してください。

  • ホスト名解決のキャッシュを無効にする
    ホスト名解決（DNS）のキャッシュを無効にして、ホスト名解決がキャッシュされないように指定します。
親トピック: 高度な設定


ホスト名解決のキャッシュを無効にする

ホスト名解決がキャッシュされないように指定するには：

  1. インスタンス管理 ページで、変更するインスタンスのアプリケーション サーバーを停止します。
  2. java.security ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<インスタンス番号>_<インスタンス名>\lib\jre\lib\security になります。アプリケーション サーバーを 64 ビット モードで実行している場合は、jre64\lib\security フォルダを代わりに使用します。
  3. 行 #networkaddress.cache.ttl=-1 を探して networkaddress.cache.ttl=0 に変更します。
    注: また、記号「#」を削除して、この行のコメント化を解除する必要もあります。
    注意:
    これを行う際にセキュリティ面での懸念があるかもしれないので、変更を行う際には、事前にネットワーク管理者に確認をとってください。
  4. ファイルを保存して閉じます。
  5. アプリケーション サーバーを再起動します。
親トピック: 実行サーバー ホスト名の解決
関連タスク
インスタンスの管理


Silk Central の場所を Issue Manager で設定する

Silk Central インストールの場所を Issue Manager で設定する方法について説明します。これにより、Issue Manager の問題から Silk Central の関連するテストへのトレーサビリティが有効になります。トレーサビリティ機能の使用方法の詳細については、Issue Manager のドキュメントを参照してください。

Silk Central の場所を Issue Manager で設定するには：

  1. インスタンス管理 ページで、変更するインスタンスのフロントエンド サーバーを停止します。
  2. SRFrontendBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、フロントエンド サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\FontendServer になります。
  3. Alm\ElementServiceEndpoint および Alm\LinkServiceEndpoint という XML タグを探します。
  4. 両方のタグのデフォルト値 localhost:19120 を、ご使用の Silk Central インストールのホストおよびポート情報で置き換えます。 ご使用の Silk Central が Issue Manager と同じフロントエンド サーバーを使用しており、かつ Tomcat Web サーバーをデフォルト ポートで使用している場合、デフォルト値のままにすることができます。
  5. XML ファイルを保存して閉じます。
  6. デフォルト ポートを使用しない場合は、\instance_<インスタンス番号>_<インスタンス名>\wwwroot\AlmServices1.0 にある configuration.xml を編集します。connectString という XML タグを探して、正しいポートを設定します。 例：
    <properties>
   <name>connectString</name>
   <!-- value>com.borland.tm.system.endpoint=http://gershwin:19120/services/sccsystem;
      com.borland.tm.spi.endpoint=http://gershwin:19120/services/SpiService</value  -->
   <value>com.borland.tm.system.endpoint=http://MyHost:8555/services/sccsystem;
      com.borland.tm.spi.endpoint=http://MyHost:8555/services/SpiService</value>
</properties>
  7. フロントエンド サーバーを再起動します。
親トピック: 高度な設定
関連タスク
インスタンスの管理


MRU レポートの最大数を設定する

最近使ったレポート リスト ボックスに表示される MRU レポートの最大数を設定するには：

  1. インスタンス管理 ページで、変更するインスタンスのフロントエンド サーバーを停止します。
  2. SccFrontendBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、フロントエンド サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\FontendServer になります。
  3. ファイルの <Report> セクションで <MRUListSize> という XML タグを探します。 このタグのデフォルト値は、10 です。
  4. 最近使ったレポート リスト ボックスに表示されるようにするレポートの最大数を示す値を設定します。
  5. XML ファイルを保存して閉じます。
  6. フロントエンド サーバーを再起動します。
親トピック: 高度な設定


Silk Central サーバーのメモリ設定

このセクションでは、OutOfMmemory エラーが発生した場合に、Silk Central サーバーのメモリ設定を変更する方法について説明します。

Silk Central フロントエンド サーバーおよびアプリケーション サーバーの Java ヒープ サイズは、デフォルトで 512 MB (64 ビット フロントエンド サーバーは 2048 MB) に設定されています。Silk Central でプロジェクトをコピーする場合などに OutOfMemory エラーが発生する場合は、フロントエンド サーバーまたはアプリケーション サーバーのヒープ サイズを増やしてみてください。

次のエラーは、Java ヒープ サイズが小さすぎる場合に発生します：java.lang.RuntimeException: java.lang.OutOfMemoryError: Java heap space at com.segue.scc.webgui.module.console.ProjectsUnit$CopyProjectThread.run(ProjectsUnit.java:1473) Caused by: java.lang.OutOfMemoryError: Java heap space。このエラーは、フロントエンド サーバーまたはアプリケーション サーバーのログファイルに記録されます。同じ様な指針となるエラー メッセージ「システムの容量は限界に近づいています安全のため、ユーザーはあらたにログインできません。」が表示されることがあります。このメッセージは、Silk Central にログインしようとすると表示されます。

  • Silk Central サーバーの Java ヒープ サイズを大きくする
    Silk Central サーバーの Java ヒープ サイズを大きくしてメモリ エラーを防止します。
親トピック: 高度な設定


Silk Central サーバーの Java ヒープ サイズを大きくする

OutOfMemory エラーが発生する場合に Silk Central サーバーの Java ヒープ サイズを大きくします。

フロントエンド サーバーまたはアプリケーション サーバーで Java ヒープ サイズを大きくするには：

  1. インスタンス管理 ページで、変更するインスタンスを停止します。
  2. メモリ設定を変更するサーバーの sc_<サーバー>.processconfig ファイルを、テキスト エディターで開きます。これらのファイルのデフォルト パスは C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<インスタンス番号>_<インスタンス名>\Conf です。
  3. 32 ビット JVM の場合は、<JvmOptions32bit> の下にある <JvmOption32bit name="-Xmx" タグで値を設定します。64 ビット JVM の場合は、<JvmOptions> の下にある <JvmOption name="-Xmx" タグで値を設定します。
  4. XML ファイルを保存して閉じます。
  5. インスタンスを再び開始します。
親トピック: Silk Central サーバーのメモリ設定


ステップの結果ファイルの最大サイズを設定する

手動テストの実行時にテスト担当者がテスト ステップに添付できる結果ファイルのサイズは、手動テスト ウィンドウで設定できます。詳細については、「結果ファイルを添付する」を参照してください。

ステップの結果ファイルの最大サイズを設定するには：

  1. インスタンス管理 ページで、変更するインスタンスのフロントエンド サーバーを停止します。
  2. SccFrontendBootConf.xml ファイルをテキスト エディタで開きます。 このファイルのデフォルト パスは、フロントエンド サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\FontendServer になります。
  3. <MaximumResultFileSizeInBytes> という XML タグを探します。このタグのデフォルト値は 104857600、つまり 100 MB です。
  4. この値を許可する最大ファイル サイズに設定します。ファイル サイズはバイト単位で入力します。
  5. XML ファイルを保存して閉じます。
  6. フロントエンド サーバーを再起動します。
親トピック: 高度な設定
関連概念
[手動テスト] ウィンドウ
関連タスク
結果ファイルを添付する


Silk Performer 結果のパーセンタイル マーカー データを格納する

Silk Performer 結果には、データベース (テーブル TM_PerfReportPercentileMarker) の多くの空間を消費するパーセンタイル マーカー データが大量に含まれています。よって、この情報の格納はデフォルトで無効化されています。Silk Performer 結果が格納されるときにパーセンタイル マーカー データの格納を有効にするには、次手順を実行します。
  1. インスタンス管理 ページで、変更するインスタンスのアプリケーション サーバーを停止します。
  2. TmAppServerHomeConf.xml ファイルをテキスト エディタで開きます。
    このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\AppServer になります。
  3. Config/SilkPerformerResultStorage/StorePercentileMarkerData という XML タグを探します。このタグは、デフォルトで false に設定されています。
  4. 値を true に設定します。
  5. XML ファイルを保存して閉じます。
  6. アプリケーション サーバーを再起動します。
親トピック: 高度な設定


Silk Central ヘルプ

Silk Central は、強力で総合的なソフトウェア テスト管理ツールです。Silk Central を使用してユーザーのテスト プロセスの品質および生産性を高めることにより、アプリケーション障害のリスクを低減しつつ、良好なソフトウェア プロジェクトをより迅速に提供できます。本製品は、あらゆる重要なソフトウェア テスト フェーズを、スケーラブルな Web ベースの単一テスト システム上に統合しています。これにより、ローカルそして各地に分散したソフトウェア開発チームは、経験やリソース、そして重要な情報を共有することができます。

  • Silk Central 18.5 の新機能
    Silk Central 18.5 では、大幅な機能拡張と変更が導入されました。
  • 入門
    このセクションでは、Silk Central の概要を説明します。
  • 要件
    Silk Central で要件を管理する方法について説明します。
  • テスト
    Silk Central でテストを管理する方法について説明します。
  • 実行計画
    Silk Central でテストを実行する方法について説明します。
  • 問題追跡と結果分析
    テスト結果を分析し、発生した問題を作成したり追跡したり、さらに、レポートを使用して結果を文書化します。
  • 管理
    Silk Central の初期設定（インスタンス構成）が完了したら、次のセクションに従って、ユーザー アカウント、プロジェクト、ロケーション、実行サーバーなどのセットアップに必要なステップを実行できます。この作業は、管理者が実行する必要があります。


Silk Central 18.5 の新機能

Silk Central 18.5 では、大幅な機能拡張と変更が導入されました。

  • 管理
    Silk Central の管理領域に対して行われた機能強化について説明します。
  • 実行計画とテスト実行
    Silk Central の実行計画とテスト実行領域に対して行われた機能強化について説明します。
  • テスト
    Silk Central のテスト領域に対して行われた機能強化について説明します。
  • Issue Manager の強化
    Silk Central の組み込みの問題追跡ソリューションである Issue Manager が Silk Central 18.5 で大幅に強化されました。
  • インテグレーション
    Silk Central の統合に対して行われた機能強化について説明します。
親トピック: Silk Central ヘルプ


管理

  • システム診断へのローカル アクセス
    Silk Central にログインできなかったり、過負荷により応答がなくなった場合に、根本原因解析用の情報を収集するために、フロントエンド サーバー マシンの システム診断 ページ（http://localhost:19120/systemdiagnostics）にローカルからアクセスできるようになりました。
親トピック: Silk Central 18.5 の新機能


システム診断へのローカル アクセス

Silk Central にログインできなかったり、過負荷により応答がなくなった場合に、根本原因解析用の情報を収集するために、フロントエンド サーバー マシンの システム診断 ページ（http://localhost:19120/systemdiagnostics）にローカルからアクセスできるようになりました。
親トピック: 管理
関連タスク
システム診断


実行計画とテスト実行

  • 分散実行
    Silk Central は、1 つの実行計画に割り当てられた複数のテストの分散実行をサポートするようになりました。 すべての一致した実行サーバー上で複数のテストが並列に実行されます。
  • 実行計画属性
    実行計画属性を Silk Central の SOAP API で使用できるようになりました。詳細については、Silk Central の Javadoc を参照してください。
親トピック: Silk Central 18.5 の新機能


分散実行

Silk Central は、1 つの実行計画に割り当てられた複数のテストの分散実行をサポートするようになりました。 すべての一致した実行サーバー上で複数のテストが並列に実行されます。

さらに、実行サーバーが過負荷になることを避けるため、実行サーバーごとに 最大同時実行数 を設定できるようになりました。これは、ある実行サーバー上で実行できる実行計画の最大数になります（排他的実行 設定が無効の場合)。

分散実行ではさらに、自動テスト実行の進捗状況を アクティビティ および 現在の実行 グリッドで即座に把握できる利点もあります。以前は、この情報は、実行計画の実行が完了した後にのみ利用可能でした。

親トピック: 実行計画とテスト実行
関連概念
分散実行
関連タスク
物理実行サーバーを設定する


実行計画属性

実行計画属性を Silk Central の SOAP API で使用できるようになりました。詳細については、Silk Central の Javadoc を参照してください。
注: ただし、Silk Central の一括エクスポート/更新インターフェイスには、まだ対応していません。
親トピック: 実行計画とテスト実行
関連資料
利用可能な Web サービス


テスト

  • 共有テスト資産
    プロジェクトのテストを共有できるようになりました。何度も使用するテストをセントラル リポジトリ プロジェクトで効率よくメンテナンスし、他のプロジェクトで再利用できます。他のプロジェクトの再利用テストは、元のテストへの参照を持ち、更新（テストのバージョン）時に情報を受け取ります。ユーザーは、その更新を適用するかスキップするかを選択できます。さらに、再利用テストでは、その元のテストの要件割り当てと同じになるように、そのプロジェクトの既存の要件が割り当てられます。
  • テスト ドキュメント ビューでのカスタム属性の表示
    テスト > ドキュメント ビュー にカスタム属性を表示できるようになりました。フィルタやレポートに対して、属性を使用できます。
  • 読み取り専用アクセス権でのテスト資産のコピー
    プロジェクトに対して読み取り専用のアクセス権しか持たないユーザーがテスト資産をコピーできるようになりました。これにより、書き込み権を持つプロジェクトにテスト資産を貼り付けることができます。
親トピック: Silk Central 18.5 の新機能


共有テスト資産

プロジェクトのテストを共有できるようになりました。何度も使用するテストをセントラル リポジトリ プロジェクトで効率よくメンテナンスし、他のプロジェクトで再利用できます。他のプロジェクトの再利用テストは、元のテストへの参照を持ち、更新（テストのバージョン）時に情報を受け取ります。ユーザーは、その更新を適用するかスキップするかを選択できます。さらに、再利用テストでは、その元のテストの要件割り当てと同じになるように、そのプロジェクトの既存の要件が割り当てられます。

テストのバージョン機能の拡張

テスト資産の共有を実現するために、テストのバージョンに、パラメータ、属性、プロパティ、成功条件、継承情報が含まれるようになりました。

親トピック: テスト
関連概念
共有テスト資産
バージョン
関連タスク
リポジトリ プロジェクトのテスト資産の再利用
プロジェクトを追加する
関連資料
[プロジェクト設定] ページ


テスト ドキュメント ビューでのカスタム属性の表示

テスト > ドキュメント ビュー にカスタム属性を表示できるようになりました。フィルタやレポートに対して、属性を使用できます。
親トピック: テスト
関連資料
テスト ドキュメント ビュー


読み取り専用アクセス権でのテスト資産のコピー

プロジェクトに対して読み取り専用のアクセス権しか持たないユーザーがテスト資産をコピーできるようになりました。これにより、書き込み権を持つプロジェクトにテスト資産を貼り付けることができます。
親トピック: テスト


Issue Manager の強化

Silk Central の組み込みの問題追跡ソリューションである Issue Manager が Silk Central 18.5 で大幅に強化されました。

シームレスな統合

Issue Manager のローカル インスタンスにログインするために、既存のユーザー コンテキストを再利用することにより、Issue Manager はよりシームレスな統合が実現されました。

ユーザー インターフェイスの更新

問題の詳細 ページのデザインが新しくなり、問題についての関連情報が参照しやすくなり、より効率的に問題を扱えるようになりました。

親トピック: Silk Central 18.5 の新機能
関連タスク
Issue Manager の問題追跡プロファイルを追加する
関連資料
[問題の詳細] ページ
[問題追跡] ページ


インテグレーション

  • Mobile Center のサポート
    Silk Central 18.5 は、Mobile Center と統合され、モバイル デバイス上で自動機能テストを実行できるようになりました。さらに、これらのモバイル デバイスは、Silk Test での自動機能テストの作成と実行に利用できます。
  • Git ソース管理プロファイルでのブランチの指定
    Git ソース管理プロファイルで特定のブランチを定義して、このプロファイルを使用するすべての実行計画でのチェックアウトに使用できるようになりました。従来どおり、各実行計画の ソース管理ラベル フィールドでブランチ名を指定して、特定の実行計画に対して別のブランチを使用することもできます。
親トピック: Silk Central 18.5 の新機能


Mobile Center のサポート

Silk Central 18.5 は、Mobile Center と統合され、モバイル デバイス上で自動機能テストを実行できるようになりました。さらに、これらのモバイル デバイスは、Silk Test での自動機能テストの作成と実行に利用できます。
親トピック: インテグレーション
関連タスク
デバイス プロバイダを設定する


Git ソース管理プロファイルでのブランチの指定

Git ソース管理プロファイルで特定のブランチを定義して、このプロファイルを使用するすべての実行計画でのチェックアウトに使用できるようになりました。従来どおり、各実行計画の ソース管理ラベル フィールドでブランチ名を指定して、特定の実行計画に対して別のブランチを使用することもできます。
親トピック: インテグレーション
関連タスク
Git ソース管理プロファイルを追加する


入門

Silk Central は、開発サイクル全体を通して製品の品質向上を促進します。

今日の e ビジネス システムはますます複雑化しており、信頼性はかつてないほど重要になっています。 そのため、開発サイクル全体を通して製品の品質を保証することが、成功の重要な鍵を握っています。 製品の品質を絶えずチェックする最もよい方法は、主要なテストを日常的に実行することです。 Silk Central では、自由に設定できるスケジュールに従ってテストを自動的に実行できるので、製品の開発中も配置後も役に立ちます。 また、さまざまな詳細レベルのレポートが提供されるので、開発中の製品のステータスをチェックすると言っても、Web ブラウザで HTML レポートをチェックする程度の簡単な作業になります。

複雑なソフトウェア プロジェクトでは、新しいビルドの徹底的なテストが非常に重要です。 Silk Central では、そのプロセスが自動化されるので、時間と工数が節約されます。

  • Silk Central のインストールとライセンス
    Silk Central をインストールし、ライセンスを管理する方法について説明します。
  • Silk Central の概念
    このセクションでは、基本的なワークフロー、利用可能な資産とその使用方法などを含む、Silk Central の基本概念を説明します。
  • ユーザー インターフェイス
    Silk Central のユーザー インターフェイスの概要を説明します。
  • クイック スタート タスク
    クイック スタート タスクは、ユーザーが Silk Central を使用して実行する必要があると想定される主要なタスクの概要です。
親トピック: Silk Central ヘルプ


Silk Central のインストールとライセンス

Silk Central のインストールとライセンスの詳細については、『Silk Central インストール ヘルプ』を参照してください。このドキュメントは、Silk Central のインストール DVD および Silk Central ダウンロード サイトから入手できます。

親トピック: 入門
関連概念
インストールとシステム設定ヘルプ


Silk Central の概念

このセクションでは、基本的なワークフロー、利用可能な資産とその使用方法などを含む、Silk Central の基本概念を説明します。
  • ワークフロー
    Silk Central のテスト管理ワークフローは、次の 4 つの主要な作業で構成されます：要件の定義、テストの設計、実行計画とテストの実行、テスト結果の追跡と分析。
  • 要件
    要件とは、テスト対象アプリケーション (AUT) で機能すべき特定のタスクを実行するために、ユーザーが要求する条件または能力を定義したものです。
  • テスト
    テストまたはテスト ケースは、入力値、実行の前提条件、期待する結果、実行の事後条件のセットであり、特定の目的またはテスト条件に対して開発されます（あるプログラム パスの試行や、特定の要件に対する適合性の検証など [IEEE 610 以降]）。
  • 実行計画
    実行計画 領域を利用すると、開発とテストの期間中、絶えずテスト実行を管理することができます。この領域では、実行計画の構成、実行計画のスケジュール、実行計画へのテストの割り当て、実行計画の依存関係のセットアップ、および実行サーバーの配置の構成、キーワードによる動的なハードウェア プロビジョニングの構成などを行うことができます。
親トピック: 入門


ワークフロー

Silk Central のテスト管理ワークフローは、次の 4 つの主要な作業で構成されます：要件の定義、テストの設計、実行計画とテストの実行、テスト結果の追跡と分析。

要件の定義

テストの設計

実行計画とテストの実行

テスト結果の追跡と分析

親トピック: Silk Central の概念


要件

要件とは、テスト対象アプリケーション (AUT) で機能すべき特定のタスクを実行するために、ユーザーが要求する条件または能力を定義したものです。要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。複数のテストが 1 つの要件をカバーすることも、複数の要件が 1 つのテストによってカバーされることも可能です。

親トピック: Silk Central の概念


テスト

テスト |  | テストまたはテスト ケースは、入力値、実行の前提条件、期待する結果、実行の事後条件のセットであり、特定の目的またはテスト条件に対して開発されます（あるプログラム パスの試行や、特定の要件に対する適合性の検証など [IEEE 610 以降]）。Silk Central は、さまざまなテスト タイプをサポートしており、いくつかの方法でテストを構造化できます。
 | テスト タイプ
 | 手動テスト | 手動テストは、テスト担当者に対してテストの手順を説明するものです。 Silk Central は、ビデオの記録、画面イメージのキャプチャなど、テストの実行中に行えるさまざまな機能を持った、手動テストを効率よく実行するための UI を提供します。必要に応じて、後から手動テストを自動テストに変換することもできます。
 | キーワード駆動テスト | キーワード駆動テスト は、実行可能なキーワードのコレクションです。キーワード駆動テストは、他のテストと同様に再生することができます。 Silk Central と Silk Test はキーワード駆動テストをサポートしており、Silk Test のキーワードの形式での共有資産として構成されるメンテナンス可能な自動化フレームワークを自動化エンジニアが開発することによって、自動化エンジニアとビジネス アナリスト間で密接な共同作業を行うことができます。その後、これらのキーワードは、Silk Test で新しいキーワード駆動テストを作成したり、Silk Central で既存の手動テスト資産を自動テストに変換したり、新しいキーワード駆動テストを作成するために、ビジネス アナリストが使用することができます。
 | UFT テスト | 以前は HP QuickTest Professional（QTP）として知られていた Unified Functional Testing（UFT）ソフトウェアは、ソフトウェア アプリケーションに対する機能テストと回帰テストの自動化と環境を提供します。
 | JUnit テスト | JUnit は、Java プログラム言語用の単体テスト フレームワークです。JUnit、Silk4J、Selenium テストに、このテストタイプを使用します。
 | NUnit テスト | NUnit は、Microsoft .NET プログラム言語用の単体テスト フレームワークです。
 | MSTest テスト | MSTest は、Visual Studio で作成した単体テストを実行するための、Microsoft のコマンド ライン ツールです。MSTest、Silk4NET テストに、このテストタイプを使用します。
 | ProcessExecutor テスト | ProcessExecutor テスト タイプは、任意のコマンド ラインを実行するために使用できます。
 | .NET Explorer テスト | Silk Performer .NET Explorer テスト タイプは、.NET Explorer スクリプトやスクリプトの特定のテスト ケースを実行するために使用します。
 | Silk Performer テスト | Silk Performer プロジェクトは、Silk Central のテストに統合し、Silk Central を通じて直接実行することができます。これにより、強力なテスト結果分析とレポート作成が可能になります。また、無人テスト（あらかじめ構成されたスケジュールに基づいて Silk Central で自動的に実行されるテスト）も可能です。
 | Silk Test Workbench テスト | Silk Test Workbench は、複雑なアプリケーションの機能テストを推進するための自動テスト ツールです。Silk Test Workbench は、Java、.NET、ブラウザベースの Web アプリケーション、COM コンポーネント（ActiveX コントロールと自動オブジェクトの両方を含む）などのさまざまな開発ツールを使って開発されたアプリケーションのテストをサポートします。
 | Silk Test Classic テスト | Silk Central の Silk Test Classic インターフェイスは、ユーザーに Silk Test Classic を自動化する信頼性の高い手段を提供します。Silk Test Classic スクリプトの各テストケースは、それぞれのテスト実行の中で実行され、それぞれに結果を作成します。
 | Silk Test Classic 計画テスト | Silk Test Classic 計画テスト タイプは、Silk Test Classic テスト計画に対して使用できます。テスト計画は、通常、階層化されたドキュメントで、テスト要件が記述されており、そのテスト要件を実装するステートメント、4Test スクリプト、テスト ケースを含んでいます。
 | Silk TestPartner テスト | TestPartner は、Microsoft 技術を使用する Web ベースおよび Microsoft Windows ベースのアプリケーションをテストする Micro Focus の製品です。
 | テスト構造
 |  | テスト コンテナは、最上位層でテスト資産を構造化するために使用します。 Silk Central では、定義したソース管理プロファイルと製品をコンテナと関連付けるため、特定のコンテナのテストに対して行えることに影響を与えます。
 |  | フォルダは、コンテナ内のテストを構造化するために使用します。
 |  | テスト パッケージは、Silk Central 内からのサードパーティ テスト タイプの構造に対するサポートを提供するもので、パッケージ ルートと、スイート ノードおよびテスト ノードの任意の階層から構成されます。
親トピック: Silk Central の概念


実行計画

実行計画 領域を利用すると、開発とテストの期間中、絶えずテスト実行を管理することができます。この領域では、実行計画の構成、実行計画のスケジュール、実行計画へのテストの割り当て、実行計画の依存関係のセットアップ、および実行サーバーの配置の構成、キーワードによる動的なハードウェア プロビジョニングの構成などを行うことができます。

実行計画は、単一のテスト コンテナに格納されている割り当て済みテストの集まりです。 実行計画は、設定可能なスケジュールで実行することができるほか、指定した実行サーバーに配置することができます。

構成テストは、サポートされる各ソフトウェア構成とハードウェア構成に関するシステムのテストを行う処理です。 構成スイートは、割り当て済みの一連のテストと共に作成できます。構成スイートに追加するすべての実行計画にも、一連のテストが割り当てられます。

テスト サイクルとは、開始日時、終了日時、および手動テスト担当者のリストで構成される定義済みの期間です。手動テストの特定のセットを計画し、実行するために、テスト サイクルを作成します。

フォルダを使用して、実行計画、構成スイート、テスト サイクルを構造化することができます。 フォルダ内にフォルダを作成することもできます。

親トピック: Silk Central の概念


ユーザー インターフェイス

このセクションでは、Silk Central のユーザー インターフェイスの概要を説明します。

  • UI のツアー
    Silk Central のユーザー インターフェイスの概要を説明します。
  • ダッシュボード
    Silk Central ユーザー用にカスタマイズされた開始領域について説明します。
  • ブラウザ設定
    ブラウザの設定を調整し、Silk Central の機能とパフォーマンスを最適化する方法について説明します。
  • ログインおよびログアウト
    Silk Central のログインおよびログアウトの方法について説明します。
親トピック: 入門


UI のツアー

このトピックでは、Silk Central のユーザー インターフェイスの概要を説明します。

UI の基本構造

Silk Central の UI には、次の項目があります。

  • メニュー：ユーザー インターフェイスの上部にあります。Silk Central の機能ユニットに簡単にアクセスできます。
  • ワークスペース：この例では、ワークスペース はタブ化された領域で、現在選択している Silk Central ユニットの機能作業領域が表示されています。このビューはユーザーの作業ユニットにより変わります。

Silk Central のユニット

メニュー から Silk Central の機能ユニットに簡単にアクセスできます。次の主なセクションがあります。

ホーム

ユーザーの個人用開始領域となる、ダッシュボードが表示されます。日常作業に必要な情報を提供するさまざまなパネルを追加し、並べ替えることによりダッシュボードをカスタマイズできます。

要件

プロジェクト要件を表示し、開発中に絶えずプロジェクト要件を管理できます。以下のタスクを実行できます。

  • 要件の作成、変更、削除。
  • テストと要件の関連付け。
  • 要件の変更履歴の追跡。
  • 要件リストからのテスト計画の生成。
さらに、次の項目にもアクセスと管理ができます。
  • 要件のプロパティ。
  • 統合された外部要件管理ツール。
  • 要件フィルタ。
  • 要件の変更を知らせる通知。

テスト

自動テストや手動テストの作成、管理を行うことができます。さらに、次の項目にもアクセスと管理ができます。

  • ライブラリ。ライブラリにある一般に使用される手動テスト、テスト ステップ、およびキーワードを再利用できます。
  • 手動テストの各テスト ステップのプロパティ。
  • キーワード駆動テストのキーワードのプロパティ。
  • テスト属性。
  • テストに使用できるデータ ソース。
  • これらのテストが保存されるソース管理プロファイル。
  • テスト フィルタ。
  • テストの変更を知らせる通知。
  • 特定のテストでテストされる製品のバージョン/ビルド番号。

実行計画

テストを実行する実行を表示し、管理できます。以下のタスクを実行できます。

  • 実行計画の構成。
  • 実行計画へのテストの割り当て。
  • 実行計画間の依存関係のセットアップ。
  • テストが実行される実行サーバーを含む実行サーバー配置の構成。
  • テストの手動実行の計画および管理を行います。
さらに、次の項目にもアクセスと管理ができます。
  • 実行フィルタ。
  • 実行スケジュール。
  • テストの特定の実行でテストされる製品のバージョン/ビルド番号。
  • 実行プロセスに関連する変更について知らせる通知。

追跡

アクティビティ ページ、全プロジェクト アクティビティ ページ、プロジェクト概要レポート、品質目標 が表示されます。

アクティビティ ページには、実行計画のアクティビティが、最近の実行、現在の実行、および今後の実行に分類され、プロジェクト単位で表示されます。

問題

アクティブ プロジェクトに関係する問題を表示し、管理できます。

さらに、次の項目にもアクセスと管理ができます。
  • Issue Manager のプロジェクト (問題が Issue Manager 内にある場合)。
  • 外部問題追跡プロファイル (問題が外部問題追跡システムにある場合)。

レポート

要件、テスト、実行計画の情報を示すレポートを表示し、管理できます。以下のタスクを実行できます。
  • レポートの生成。
  • レポート テンプレートをダウンロード。
  • レポート パラメータの編集。
  • インストール済みのテンプレートに基づく新規レポートの作成。

さらに、コード分析機能の情報にアクセスすることもできます。これらを使用すると、テスト対象のアプリケーション (AUT) のコードがテスト ケースでカバーされている割合を評価できます。特定のコード変更に伴う労力、コスト、リスクを十分な情報に基づいて見積もりできます。

グローバル検索

検索 フィールドを使用すると、Silk Central のいくつかの資産に対して検索を実行することができます。次の資産がグローバル検索を実行する際の対象となります。
  • 要件とそのプロパティ
  • テスト、フォルダ、テスト コンテナ、およびその属性値、プロパティ、パラメータ
  • テスト ステップとそのプロパティ
  • 実行計画、構成スイート、テスト サイクル、フォルダ、およびそのパラメータ
  • ライブラリ フォルダ、ステップ、共有ステップ
  • 問題（概要と説明が検索対象）
注: 検索インデックスは定期的にバックグラウンドで更新されます。検索結果は若干古い場合があります。
検索ルール
  • 検索では大文字小文字は区別されません。
  • 入力されたすべての単語は、別々に検索されます。少なくとも 1 つの単語が検索で一致した項目が見つかります。クエリに一致する単語が多いほど、一致率が上がります。
  • + 接頭辞を単語に付けて必須一致クエリを指定します。たとえば、「+test +type」は、test と type の両方と一致した結果だけが返されます。
  • - 接頭辞を単語に付けて不一致クエリを指定します。たとえば、「test -copy」は、test と一致した結果を返しますが、 copy of test は含まれません。
  • 完全一致する単語群を検索する場合は、単語群を引用符で囲みます（「"customer account management"」など）。
  • 項目の名前や説明に検索を限定するには、検索単語に name: や description: などの接頭辞を指定します。たとえば、「name:test」は、項目の 名前 に test という単語が含まれている結果だけを返します。
  • a、the、and などの一般的な英単語は無視されます。
例：
name:"test item" -description:closed
この検索は、test item というフレーズを含んだ名前で、説明に closed という単語を含まない項目を返します。

プロジェクト

Silk Central インストール内のすべてのプロジェクトについて、テスト管理の観点からの概要が表示され、それらを管理できます。さらに、プロジェクト間の移動、プロジェクト設定の管理が可能となります。

ユーザー

ユーザー設定を表示し、管理できます。さらに、次の項目が実行できます。
  • Silk Central からログアウトします。
  • 現在の Silk Central ページを印刷します。
  • 現在の Silk Central ページをブックマークします。レポートをブックマークすると、現在のパラメータがブックマークされた URL に保存されるため、特に便利です。

管理

管理設定を表示し、管理できます。詳細については、この『ヘルプ』の「管理」トピックを参照してください。

ヘルプ

クリックすると、現在のページの状況依存ヘルプが表示されます。さらに次の項目にアクセスできます。
  • Silk Central ドキュメント。
  • Silk Central に同梱されているツール。
  • バージョン情報。バージョンおよびライセンス情報が表示されます。

コンテキスト メニュー コマンド

Silk Central では、多くのテスト管理要素 (テスト、要件、実行計画、フォルダ、コンテナ、レポートなど) で Windows 方式のコンテキスト メニューをサポートします。マウスの右クリックで利用できる、コンテキスト メニュー コマンドには通常、各ユニット ツールバーから利用できるコマンドが含まれます。ツリー ビューにリストされている要素の場合は、コンテキスト メニューにはツリー ビュー要素の展開と折りたたみコマンドがあります。選択した要素で利用できないコマンドは無効になっています。

親トピック: ユーザー インターフェイス


ダッシュボード

Silk Central のダッシュボードは、ユーザー個人用の開始領域です。日常作業に必要な情報を提供するさまざまなパネルを追加し、並べ替えることによりカスタマイズできます。

Silk Central に初めてログインしたときに、ダッシュボードには はじめに パネルのみ表示されます。マイ ダッシュボードの上部には、前回のログイン日時が表示されます。また、「作業を中断した場所から再開します」リンクが表示されている場合は、このリンクをクリックすることで前回作業していた領域にすばやく移動できます。

上部にある該当ボタンをクリックして、以下のアクションを実行します。
  • パネルの追加 をクリックしてダッシュボードにパネルを追加します。
  • レイアウトの変更 をクリックしてダッシュボードのレイアウトを変更します。
  • ダッシュボードのリセット をクリックしてダッシュボードの表示をデフォルト設定に戻します。追加したパネルとカスタマイズした設定がすべて削除されます。

パネルを並べ替えるには、パネルのヘッダーをクリックして、希望する位置にドラッグします。パネルのフッターをドラッグするとパネルのサイズを変更できます（リストを表示するパネルのみ）。

パネルのヘッダーにある該当ボタンをクリックして、以下のアクションを実行します。
  • をクリックしてダッシュボードからパネルを削除します。
  • をクリックしてパネルの設定を構成します。
  • をクリックしてパネルの内容を PDF として保存します。
  • をクリックしてパネルの内容を印刷します。

異なるパネルの内容を表示または編集するには、特定のアクセス許可が必要になります。

  • パネルをダッシュボードに追加する
    パネルをダッシュボードに追加する方法について説明します。
  • ダッシュボード パネル
    ダッシュボードに追加可能なパネルについて説明します。
  • Silk Central Connect
    Silk Central Connect とは何か、またその使い方について説明します。
  • ダッシュボード パネルのアクセス許可
    特定のパネルの内容を表示、編集するのに必要なアクセス許可を説明します。
  • ダッシュボード パネルにレポートを追加する
    レポートを作成し、ダッシュボード パネルに追加する方法について説明します。
親トピック: ユーザー インターフェイス


パネルをダッシュボードに追加する

パネルをダッシュボードに追加するには：

  1. メニューで ホーム > マイ ダッシュボード をクリックします。
  2. 左上にある パネルの追加 をクリックします。 パネルの追加 ダイアログ ボックスが開き、利用可能なパネルが各パネルの簡単な説明と共に一覧表示されます。
  3. パネルを選択します。
  4. OK をクリックします。
  5. 必要に応じて、パネルの プロジェクト と 期間 を選択します。パネルで <現在のプロジェクトを使用する> を選択すると、現在アクティブなプロジェクトのデータが常に表示されます。
  6. OK をクリックします。

パネルには特定のプロジェクトのデータのみが表示されるため、ほとんどの場合でパネルにプロジェクトを設定する必要があります。他のプロジェクトに対して適切なデータを並べて表示するためにいくつかのパネルを追加したり、パネルに対して <現在のプロジェクトを使用する> を設定して現在のアクティブ プロジェクトのデータを常に表示するようにできます。パネルのヘッダーにある [image] (設定) をクリックして、別のプロジェクトを設定します。異なるパネルの内容を表示または編集するには、特定のアクセス許可が必要になります。

親トピック: ダッシュボード


ダッシュボード パネル

パネルには特定のプロジェクトのデータのみが表示されるため、ほとんどの場合でパネルにプロジェクトを設定する必要があります。他のプロジェクトに対して適切なデータを並べて表示するためにいくつかのパネルを追加したり、パネルに対して <現在のプロジェクトを使用する> を設定して現在のアクティブ プロジェクトのデータを常に表示するようにできます。パネルのヘッダーにある [image] (設定) をクリックして、別のプロジェクトを設定します。異なるパネルの内容を表示または編集するには、特定のアクセス許可が必要になります。

ダッシュボードに追加可能なパネルは以下のとおりです。

パネル | 説明
割り当て済み問題 | このパネルは、選択したプロジェクトのすべての問題 (テストに割り当てられたもの) を表示します。外部 ID をクリックすると、外部の問題追跡システムでその問題が開きます。
カスタム情報 | このパネルには、特定のプロジェクトに関するカスタマイズ可能な情報が表示されます。プロジェクトの管理 許可を持つユーザーは、パネルにテキスト、画像、ハイパーリンクといった内容を追加できます。内容の編集 をクリックして、HTML エディタを開きます。プロジェクトの管理 許可を持たないユーザーは、内容の表示のみが可能です。パネルは、ニュース、説明、プロジェクトに関連するその他の情報を表示させるのに使用できます。
はじめに | このパネルには、Silk Central に関する簡単な説明が表示されます。新機能 の下にあるリンクをクリックして、Silk Central の最新の機能についての詳細な情報を参照します。また、Micro Focus Community に参加したり、Micro Focus SupportLine に問い合わせすることもできます。
問題のライフ サイクル | このパネルは、定義された問題追跡プロファイルの 対応開始、解決、検証終了、対応完了 および 先送り の問題の数を表示します。リストから 製品 を選択します。問題追跡プロファイルを定義するには、メニューで 問題 をクリックし、問題追跡インテグレーション および プロファイルの新規作成 をクリックします。プロファイルが定義されている場合、パネルにはデータのみが表示されます。
テスト担当者ごとの作成済み問題数 | このパネルは、テスト担当者ごとの作成済み問題数を棒グラフで表示します。印刷するか PDF としてダウンロードすると、問題の数は表形式でも表示されます。
ユーザーに割り当てられた手動テスト

このパネルは、ユーザーに割り当てられた選択済みプロジェクトのテストをすべて表示します。

テスト サイクルを利用して手動テスト実行を編成している場合は、手動実行計画 ページの テスト担当者なし に割り当てられたすべてのテストもリストに表示されます。ただし、これは、自分がテスト担当者として割り当てられているテスト サイクルに限られます。テスト担当者が実行するテストを自分で決定するのは、通常のチームワーク シナリオです。

実行計画を利用して手動テスト実行を編成している場合は、テスト担当者が割り当てられていないすべての実行計画のテストもリストに表示されます。

(手動テストの続行) をクリックすると、手動テスト ウィンドウが開きます。

(手動テスト結果の表示) をクリックすると、ビューが開き、テストに関するすべてのデータと添付情報が表示されます。

をクリックすると、テスト、実行計画 または 実行計画の親 についての詳細情報が表示されます。

テストを右クリックして [image] をクリックすると、手動テストがオフラインで実行用に Excel 形式でダウンロードできます (複数のテストを選択する場合は、Ctrl + クリック または Shift + クリック を使用します)。テストを実行した後に、オフライン手動テスト結果のアップロード ボタンをクリックして結果をアップロードできます。

開始日前にテストサイクルを (手動実行計画 ページで) 開始した場合、このテスト サイクルのテストは既にパネルに表示されています。このようなテストを開始日に到達するまでパネルで非表示にすることができます。パネルのヘッダーにある [image] をクリックして、未来のテスト サイクルを非表示 をチェックします。
オフライン手動テストの概要 | このパネルは、テスト担当者がダウンロードしたテストを表示します。テスト管理者はオフライン実行を中止して、ライセンスを解放することができます。
実行時間の計画値と実績値 | このパネルは、テスト サイクルのテスト担当者がテストの実行でスケジュールに沿っているかを表示します。実際に使用した時間と残りの予定時間の合計が最大利用可能時間より大きい場合、テスト サイクルが時間内に完了しないリスクがあります。
品質目標の進捗状況 | このパネルは、選択した品質目標のそれぞれの値を 2 つの棒で示したグラフを表示します。上の棒は、品質目標を満たすために実行する必要のあるテストの数を示します。下の棒は、 テストの品質目標値と共に、合格、失敗、未実行、および N/A (適用不可) のテストの数を示します。下の棒の方が上の棒よりも短い場合、実行計画に割り当てられたテストの数が少なすぎます。これは、品質目標を達成できないことを意味します。リストから 品質目標 を選択します。
レポート配信登録 | このパネルは、レポート配信登録の結果を表示します。レポート配信登録は、あらかじめ定義されている必要があります。 配信登録の編集 ダイアログ ボックスで ダッシュボードと外部アクセス を選択することで、利用可能になります。
要件カバレッジ ステータス | このパネルには、選択したプロジェクトの 合格、失敗、未実行、未カバー 要件の 4 つの要件カバレッジが表示されます。 をクリックすると、要件ドキュメント ビュー に進みます。
Silk Central Connect
Silk Central Connect は、テスト実行管理と構成テストの特徴を兼ね備えた使いやすいインターフェイスを提供する製品で、次のメリットを持ちます。
  • さまざまな種類の構成 (オペレーティング システムと Web ブラウザーの組み合わせ) 上ですべての自動ユニット テストを簡単に実行可能。
  • 先行投資無くさまざまな種類の構成に簡単にアクセスできるという、Amazon Web Services のメリットを利用できます。
  • Silk Central Connect と Silk4J が密に統合されたことによる、テストの作成、保守、実行の容易化。
  • サイド バイ サイド結果分析により、さまざまな構成にまたがるすべてのテストを比較可能。

詳細については、「Silk Central Connect」を参照してください。
Silk Performer パフォーマンス傾向 | Silk Performer パフォーマンス傾向 パネルには、選択した Silk Performer 負荷テストの最近の実行の傾向情報や現在のステータスと利用可能な結果が表示されます。
現在実行中の手動テストのステータス | このパネルは、指定したプロジェクトのすべての実行中の手動テストのステータスを表示します。テスト管理者は、現在ブロックされているテストを確認したり、実行中の実行のうち、すでに実行されたテストのステータスを監視することができます。
テストブック | このパネルは、手動テスト中に行われたすべてのアクティビティに関するリアルタイム更新を表示します。テストブックのログに記録されるアクティビティは、テストの開始と終了および実行中テスト サイクルの編集です。詳細については、「テストブック」を参照してください。
テスト サイクルの進捗状況 | このパネルは、定義されたテスト サイクルの 合格、失敗、実行中 および 未実行 テストのバーンアップ チャートを表示します。また、指定している場合はマイルストーンも (ダイヤモンドとして) 表示されます。リストから テスト サイクル を選択します。
テスト サイクル結果の概要 | このパネルには、選択したテスト サイクルのステータスおよびテスト サイクルに割り当てられている各テスト担当者の進捗ステータスが表示されます。バーには順番に、失敗したテスト の数、残りのテスト の数、合格したテスト の数が表示されます。失敗したテストの数が最も多いテスト担当者がリストの最上部に表示されます。バーの右側の数は、完了したテスト数 (左の数字) と 割り当て済みテスト (右の数字) を表します。テスト担当者なし も他のすべてのテスト担当者と同様に処理され、並べられます。 をクリックすると、手動実行計画 ページの テストの割り当て ビューに移動します。
テスト サイクル タイムライン | このパネルは、選択したプロジェクトのテスト サイクルのすべてをタイムラインに棒で表示します。棒をクリックすると、手動実行計画 ページに移動します。棒はテスト サイクルの現在のステータスに従って異なる色がついています。 青は進行中、オレンジは開始前、グレーは終了です。棒の上にマウスを移動すると、テスト サイクルに関する詳細情報がわかります。
全テスト サイクルにわたるテストの進捗状況 | このパネルには、予定された テストの時間 (単位は時間、折れ線で表示)、実行中 および 完了した テストの時間 (積み重ね面グラフで表示) が表示されます。このパネルは、テスト チームが時間内にテストを完了させることができるかどうかをテスト管理者が予測するのに役立ちます。グラフの開始日は最初のテスト サイクルの開始日です。グラフの終了日は最後のテスト サイクルの終了日です。パネルには、テスト チームがテストを実行するのに実際にかかった時間は表示されません。
不安定なテスト | このパネルには、ある実行計画でテストのステータスが変更された回数が表示されます。ステータス変更のなかったテストおよびテスト パッケージはパネルには表示されません。選択したプロジェクトおよびテスト期間に応じてテストが表示されます。このパネルで不安定なテストを確認することにより、テスト管理者はテストが安定していないか、またはバグが頻発するテスト領域に気付くことができます。
親トピック: ダッシュボード


Silk Central Connect

Silk Central Connect は、テスト実行管理と構成テストの特徴を兼ね備えた使いやすいインターフェイスを提供する製品で、次のメリットを持ちます。
  • さまざまな種類の構成 (オペレーティング システムと Web ブラウザーの組み合わせ) 上ですべての自動ユニット テストを簡単に実行可能。
  • 先行投資無くさまざまな種類の構成に簡単にアクセスできるという、Amazon Web Services のメリットを利用できます。
  • Silk Central Connect と Silk4J が密に統合されたことによる、テストの作成、保守、実行の容易化。
  • サイド バイ サイド結果分析により、さまざまな構成にまたがるすべてのテストを比較可能。
  • 概要
    Silk Central Connect とは何か、またその使い方について説明します。
  • Silk Central Connect のアーキテクチャ
    Silk Central Connect のアーキテクチャの概要について説明します。
  • 前提条件
    Silk Central Connect で作業するのに必要な前提条件を示します。
  • ソース管理の設定
    Silk Central Connect と Subversion ソース管理システムが統合することによって、Silk Central Connect はプロジェクト データを格納することができます。
  • Web アプリケーション テストを作成する
    テストを作成し、デフォルトのロケーションで利用可能なブラウザで Web アプリケーションがどのように見えるかを検証します。
  • Web アプリケーション テストをカスタマイズする
    Web アプリケーションの機能をテストするためのテスト セットを作成します。
  • Web アプリケーション テストを複数のブラウザで並列に実行する
    Web アプリケーションのテストを複数のブラウザで並列に実行するようテスト環境を強化します。
  • テスト結果の分析
    テストの実行後にテスト結果を分析します。
  • 継続的に実行するためにテストをスケジュールする
    毎日指定した時間にテストを実行するようにプロジェクトにスケジュールを作成します。
  • よくある質問
    Silk Central Connect に関するよくある質問について回答します。
親トピック: ダッシュボード


概要

Silk Central Connect は、デスクトップやモバイル Web ブラウザ上の Web アプリケーションを、わずらわしいセットアップや設定を行わずにテストするために、クラウドのパワーを利用する新しい方法です。Silk Central Connect：
  • クロス ブラウザ テストに必要な時間と労力を最大 80% 程度低減します
  • さまざまなブラウザ用にハードウェアをセットアップする必要がなくなることにより、所有することにより生じるトータル コストを低減します
  • さまざまなブラウザでのアプリケーションの失敗を視覚的に識別することによって問題をより早く解決します

Silk4J に関する情報については、『Silk4J ユーザー ガイド』を参照してください。

テスト環境の設定についての情報は、「実行サーバーを設定する」を参照してください。

親トピック: Silk Central Connect


Silk Central Connect のアーキテクチャ

Silk Central Connect は、Silk Central のアーキテクチャをベースにしています。さらに、クラウド ベースの実行サーバーを使用することができます。クラウド ベースの実行サーバーを使って、イントラネット上の内部 Web アプリケーションをテストする場合は、ローカル イントラネット Web サイトのテスト用のトンネル設定を行うことができます。この設定を行うと、Silk Central アプリケーション サーバーはクラウド ベースの実行サーバーへのトンネルを開き、ローカル イントラネットの Web サイトのテストを可能にするためのプロキシとして動作します。このオプションは直接接続に比べて遅いため、必要な場合にのみ選択してください。

親トピック: Silk Central Connect


前提条件

Silk Central Connect で作業するには、次の前提条件を満たす必要があります。
  • Silk Central が、環境にインストールされている必要があります。
  • Silk4J (Eclipse 用の Silk Test プラグイン) が、環境にインストールされている必要があります。
親トピック: Silk Central Connect


ソース管理の設定

Silk Central Connect がテストを格納して実行できるようにするために、Silk Central Connect と Subversion (SVN) ソース管理システムを統合する必要があります。

  1. Silk Central Connect パネルで、Subversion ソース管理の設定 をクリックします。
  2. URL フィールドに、Subversion リポジトリの URL を入力します。SVN リポジトリが設定されていない場合、Silk Central Connect は自動的にファイル ベースのリポジトリを設定します。
    重要: ファイル ベースのリポジトリは評価目的でのみ使用し、実際の運用時に使用すべきではありません。また、このリポジトリはローカル マシンでのみアクセス可能なので、Silk4J もこのコンピュータにインストールする必要があります。

    たとえば、Subversion サーバーの場所が http://svn.mycompany.com で、リポジトリが TestAutomation/trunk の下にある場合、URL フィールドには「http://svn.mycompany.com/TestAutomation/trunk」を入力します。

  3. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。これらの認証情報は、すべてのプロジェクトに対してリポジトリにアクセスするために使用されます。ファイル ベースのリポジトリを使用している場合は、ユーザー名 と パスワード は必要ありません。
  4. 保存 をクリックします。
親トピック: Silk Central Connect


Web アプリケーション テストを作成する

Silk Central Connect をインストールして Subversion を設定した後、Web アプリケーションの新しいプロジェクトを直接作成できます。そして、組み込みの検証実行を使用して、ローカル マシンで利用可能なブラウザそれぞれで Web アプリケーションの最初のスクリーンショットを撮影できます。

  1. Silk Central Connect パネルで、プロジェクトの新規作成 をクリックします。 新しいプロジェクト ダイアログ ボックスが表示されます。
  2. Silk Central Connect を完全な Silk Central 環境で使用している場合は、新しい Silk4J プロジェクトを既存の Silk Central プロジェクトに追加するか、新しい Silk Central プロジェクトを作成して追加するかを選択できます。
  3. 新しいプロジェクトを作成する場合、プロジェクト名 フィールドに新しいプロジェクトの名前を入力します。
  4. URL フィールドに、テスト アプリケーションの URL を入力します。
  5. OK をクリックします。
  6. 省略可能： クラウド ベースの実行サーバーを使って、イントラネット上の内部 Web アプリケーションをテストする場合は、トンネル設定 をクリックして、ローカル イントラネット Web サイト を選択します。 この設定を行うと、Silk Central アプリケーション サーバーはクラウド ベースの実行サーバーへのトンネルを開き、ローカル イントラネットの Web サイトのテストを可能にするためのプロキシとして動作します。このオプションは直接接続に比べて遅いため、必要な場合にのみ選択してください。
  7. テストの実行 をクリックします。
  8. すべての利用可能な構成を選択します。
  9. テストの実行 をクリックします。
  10. 更新 をクリックして、実行が完了したかどうか確認します。
  11. 実行が終了したら、開始日時のリンクをクリックします。 すべての構成のテスト結果を参照できます。デフォルトのテスト ケースは、validateAppearance と呼ばれます。
  12. 最初の構成のテスト結果をクリックします。 テスト アプリケーションのスクリーンショットを含む、テスト結果の詳細を参照できます。スクリーンショットをクリックして、拡大表示できます。
  13. すべての結果をクリックして、すべての構成でアプリケーションがどのように見えるかを確認できます。

    ヒント: キーボードの Left キーと Right キーを使用して、結果を切り替えることができます。
親トピック: Silk Central Connect


Web アプリケーション テストをカスタマイズする

このトピックで説明する操作を実行するには、次の前提条件を満たす必要があります。
  • Silk4J を使ってテストを記録するために、Internet Explorer の現在のバージョンがシステムにインストールされている必要があります。サポートされているバージョンのリストについては、『リリース ノート』を参照してください。
  • 再生するためにサポートされているブラウザのリストについては、『Silk Test リリース ノート』を参照してください。
  • モバイル ブラウザのテストを行うために、システムにエミュレータをインストールするか、モバイル デバイスを接続する必要があります。モバイル Web アプリケーションのテストの詳細については、『モバイル テスト チュートリアル』を参照してください。
Web アプリケーション用のプロジェクトを作成した後、さらにテストを追加したり、既存のテストを Web アプリケーションの追加の機能をテストするように拡張することができます。
  1. Eclipse でプロジェクトを開くには、以下のいずれかを実行します。
    • Silk Central Connect パネルで、プロジェクトに対応する アクション 列にある Silk4J で開く をクリックします。
    • プロジェクトの概要ページで、Silk4J を開く をクリックします。
    Silk Central Connect プロジェクトを作成するときに、Eclipse プロジェクト テンプレートが次の資産と共に、指定したコントロールにコミットされます。
    • src フォルダ：新しいテストが格納される場所。
    • Lib フォルダ：Silk4J プロジェクトで追加の Java ライブラリを使用する場合に、このフォルダに追加します。Silk Central Connect は、テストを実行するときに、このフォルダにあるすべての jar ファイルをクラスパスに追加します。
    • build.xml：事前に設定された ANT ビルド ファイルで、Silk Central Connect はテストを実行する前にビルドするために使用します。
    • その他の Eclipse 関連ファイル
  2. Silk4J で追加のテストを記録します。
    1. パッケージ エクスプローラー で、新しいテストを追加するプロジェクトを選択します。
    2. ツールバーの 操作の記録 をクリックします。
      • Silk4J テスト クラスが Eclipse 上で開いた場合、記録した操作はこのファイルに記録されます。
      • Silk4J テスト クラスが Eclipse 上で開いていない場合、記録した操作は新しい Silk4J テスト クラス ファイルに記録されます。

      Web アプリケーションと記録中 ウィンドウが開きます。Silk4J は基本状態を作成し、記録を開始します。

    3. AUT に対して記録したい手順を実行します。
    4. 記録の停止 をクリックします。記録完了 ダイアログ ボックスが開きます。

    5. ソース フォルダ フィールドは、選択したプロジェクトのソース ファイルの場所で、自動的に埋められています。別のソース フォルダを使用するには、選択 をクリックし、使用するフォルダまで辿っていきます。
    6. 省略可能：パッケージ フィールドに、パッケージ名を指定します。 既存のパッケージを使用するには、選択 をクリックし、使用するパッケージを選択します。
    7. テスト クラス フィールドに、テスト クラスの名前を指定します。
    8. テスト メソッド フィールドに、テスト メソッドの名前を指定します。
    9. OK をクリックします。

    Silk4J に関する情報については、『Silk4J ユーザー ガイド』を参照してください。

  3. テストが期待通りに動作することを Silk4J で確認します。
    1. Silk4J ツールバーの 選択した Silk4J テストを実行 をクリックします。
    2. ブラウザーの選択 ダイアログ ボックスで、テストを再生するブラウザを選択します。

    3. 実行 をクリックします。 テストが合格し、テスト結果が期待通りなら、テストを Silk Central Connect のプロジェクトのテスト セットに追加できます。
  4. Silk4J ツールバーで、コミット をクリックして、プロジェクトの変更をリポジトリにコミットします。
  5. Silk Central Connect のプロジェクトの概要ページに戻り、テストの実行 をクリックしてプロジェクトのすべてのテストを実行します。
  6. 構成を選択します。

  7. テストの実行 をクリックします。
  8. 実行が終了したら、開始日時のリンクをクリックします。 すべてのテストとすべての構成のテスト結果を参照できます。

すべてのテストがすべての構成で期待通り実行した場合、テスト セットをさらに拡張したり、プロジェクトをスケジュール設定して繰り返し実行することができます。

親トピック: Silk Central Connect


Web アプリケーション テストを複数のブラウザで並列に実行する

ローカル マシンですべての利用可能なブラウザ上で期待通り Web アプリケーションが動作することを確認したら、テスト環境にさらに実行サーバーを追加して、Web アプリケーションのテストを複数のブラウザで並列に実行できます。

Web アプリケーションを追加のブラウザでテストするには、次の 3 つの方法があります。

  1. 既存の実行サーバーに追加のブラウザをインストールする この方法は、追加のブラウザをテストすることができますが、ブラウザが実行サーバー上で順番にテストされるため、テスト対象アプリケーションに対してテスト セットを実行するために必要な時間は増加します。
  2. テスト環境に追加の実行サーバーを追加する この方法は、テスト セットの実行時間を大幅に増加させることなく、追加のブラウザをテストできます。各サーバーの利用可能なブラウザに基づいて、実行サーバー間でテストが分散されます。ただし、この方法は、ハードウェア要件を高めます。テスト環境に実行サーバーを追加する方法の詳細については、「物理実行サーバーを設定する」を参照してください。
  3. クラウドに接続する
    注: テストをクラウドで実行することができるようにするには、クラウド プロバイダのアカウントが必要です。

    この方法は、テスト セットの実行時間を増加させることも必要な追加のハードウェアもなく多種多様なブラウザをテストできます。追加のコストは、テスト作業 (テスト セットを実行する頻度とテスト セットの規模) に直接影響を受けます。

テスト環境の設定についての情報は、「実行サーバーを設定する」を参照してください。

複数のブラウザーに対するキーワード駆動テストの実行についての詳細は、「キーワード駆動テストを使用したクロス ブラウザ テスト」を参照してください。

親トピック: Silk Central Connect


テスト結果の分析

テストを実行した後、テスト結果を検討できます。

  1. Silk Central Connect パネルで、すべてのプロジェクトの最新のテスト事項のステータスを参照できます。

  2. 特定のプロジェクトのすべてのテストとすべてのテスト実行の結果を参照するには、プロジェクトの名前をクリックします。

    プロジェクトの概要ページが開きます。

  3. テスト結果 ページで、特定のテスト結果のステータスをクリックすると、すべての構成に対するテスト実行の結果を参照できます。

  4. テスト結果 ページで、テストのステータスをクリックすると、エラー ログや TrueLog ファイルを含む詳細な情報を表示できます。

親トピック: Silk Central Connect


継続的に実行するためにテストをスケジュールする

毎日同じ時間にプロジェクトのすべてのテストを実行するようにプロジェクトにスケジュールを作成できます。
注: 完全な Silk Central 環境で Silk Central Connect を使用している場合は、より高機能なスケジュール機能を 実行計画 > 詳細ビュー > スケジュール を
代わりに使用できます。
  1. Silk Central Connect パネルで、毎日実行するスケジュールを作成したいプロジェクトの名前をクリックします。
  2. プロジェクトの概要ページで、テストのスケジュール をクリックします。
  3. テストのスケジュール ダイアログ ボックスで、毎日テストを開始すべき時間を指定します。

  4. 利用可能な設定のリストから、テストを実行すべき構成を選択します。 プロジェクトのテストを既に実行した場合は、最後の実行で使用した構成があらかじめ選択されています。テストを実行していない場合は、すべての構成があらかじめ選択されています。
  5. 保存 をクリックします。
プロジェクトのすべてのテストが、毎日指定した時間に選択した構成で実行されます。スケジュールされた時間は、プロジェクトの概要ページに表示されます。スケジュールの隣にある削除ボタンをクリックして、スケジュールを削除できます。
親トピック: Silk Central Connect


よくある質問

このセクションでは、Silk Central Connect に関するよくある質問について回答します。

  • Silk4J テストが失敗する理由
    Silk Central Connect を更新して、Eclipse を再起動し、Silk Central Connect と Silk4J との接続が機能していることを確認します。
親トピック: Silk Central Connect


Silk4J テストが失敗する理由

Silk Central Connect から Silk4J テストを実行すると機能しない場合、Silk Central Connect と Silk4J との接続が機能していない場合があります。以下を実行して接続を再度確立してください。Silk4J が Silk Central Connect の前にインストールされた場合、Eclipse または Open Agent を再起動します。

親トピック: よくある質問


ダッシュボード パネルのアクセス許可

特定のダッシュボード パネルの内容を表示、編集するには、次のアクセス許可が必要です。
パネル | 必須アクセス許可
割り当て済み問題 | テストと実行の表示。
カスタム情報 | 編集には プロジェクトの管理 が必要です。 表示にはアクセス許可は不要です。
はじめに | アクセス許可は不要です。
問題のライフ サイクル | プロジェクト設定の表示。
テスト担当者ごとの作成済み問題数 | テストと実行の表示。
ユーザーに割り当てられた手動テスト | テストの実行。
実行時間の計画値と実績値 | テスト サイクルと構成の表示。
品質目標の進捗状況 | 品質目標の表示。
レポート配信登録 | アクセス許可は不要です。
要件カバレッジ ステータス | 要件の表示。
Silk Central Connect | このパネルに情報を表示するには、テストと実行の表示 が必要です。パネルから Silk Central のほかの領域にアクセスするには、さらにそのアクセス権が必要です。
Silk Performer パフォーマンス傾向 | テストと実行の表示
現在実行中の手動テストのステータス | テストと実行の表示
テストブック | アクセス許可は不要です。
テスト サイクルの進捗状況 | テスト サイクルと構成の表示。
テスト サイクル結果の概要 | テスト サイクルと構成の表示。
テスト サイクル タイムライン | テスト サイクルと構成の表示。
全テスト サイクルにわたるテストの進捗状況 | テスト サイクルと構成の表示。
不安定なテスト | テストと実行の表示。
親トピック: ダッシュボード
親トピック: アクセス許可の定義


ダッシュボード パネルにレポートを追加する

レポート ユニットで利用可能な任意のレポートを使用して、ダッシュボードの レポート配信登録 パネルに既存のレポートを表示することができます。まず、レポートを作成して設定してから、ダッシュボードにパネルを追加します。
  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. 配信登録 タブをクリックします。
  4. 配信登録の追加 をクリックします。 配信登録の編集 ダイアログ ボックスが開きます。
  5. 名前 フィールドで配信登録の名前を指定します。
  6. 配信登録でパラメータを変更するには、パラメータの編集 をクリックします。 パラメータの編集 ダイアログ ボックスが開きます。値 を変更して、OK をクリックします。
  7. スケジュール リストからスケジュールを選択します。希望するスケジュールが存在しない場合は、作成する必要があります。スケジュールを選択せずに、テスト実行の結果に基づいてトリガーされるだけの配信登録を作成することもできます。
  8. ダッシュボードと外部アクセス をクリックして、レポートをダッシュボード パネルで利用できるようにします。
  9. OK をクリックします。 新しい配信登録が 配信登録 リストに表示されます。
  10. メニューで ホーム > マイ ダッシュボード をクリックします。
  11. 左上にある パネルの追加 をクリックします。 パネルの追加 ダイアログ ボックスが開き、利用可能なパネルが各パネルの簡単な説明と共に一覧表示されます。
  12. レポート配信登録 を選択します。 パネルの設定 ダイアログ ボックスが表示され、使用できるレポート配信登録がすべて表示されます。
  13. リストからレポート配信登録を選択して、OK をクリックします。 パネルが ダッシュボード に追加されます。
親トピック: ダッシュボード
親トピック: レポート配信登録


ブラウザ設定

Silk Central の機能とパフォーマンスを最適化するには、ブラウザで以下の設定を調整します。

  • ブラウザのキャッシュが有効になっていることを確認してください。
  • ブラウザから Silk Central にアクセスする際に問題が生じる場合は、Silk Central サーバーをブラウザの信頼済みサイトに追加します。

サポートされているブラウザのリストについては、リリース ノートを参照してください。 メニューで、ヘルプ > ドキュメント をクリックします。 Silk Central 18.5 リリース ノート をクリックします。

親トピック: ユーザー インターフェイス


ログインおよびログアウト

このセクションの手順では、Silk Central のログインおよびログアウトの方法について説明します。

  • Silk Central にログインする
    Silk Central のインストールへの移動方法、アカウント認証情報を使用したログイン方法について説明します。
  • Silk Central からログアウトする
    Silk Central からのログアウト方法について説明します。
親トピック: ユーザー インターフェイス
関連概念
LDAP 認証


Silk Central にログインする

Silk Central にログインするには：

  1. Silk Central インストールの URL に移動します。
  2. Silk Central ログイン ページで、ユーザー名 に <クライアント>\<ユーザー名> 形式でユーザー名を、パスワード にパスワードを入力します。 デフォルト クライアントのユーザーで Silk Central にログインする場合、クライアント名を入力する必要はありません。ユーザー名のみを入力します。

    スーパー ユーザーとしてログインするには、次の認証情報（デフォルト）を使用します。

    • ユーザー名：admin
    • パスワード：admin
  3. ログイン情報を保存する チェック ボックスをオンにすると、ブラウザーのタブを閉じるまでログインしたままの状態になります。次に Silk Central にアクセスするときには、自動的にログイン状態になります。
  4. ログイン をクリックします。
個人の ダッシュボード に移動します。ダッシュボード ページの上部にある ここをクリックすると前回作業していた領域が開きます リンクをクリックすると、前回作業していた領域にすばやく移動できます。
親トピック: ログインおよびログアウト
関連概念
ログイン オプション
スーパー ユーザー


Silk Central からログアウトする

Silk Central からログアウトするには：

  1. メニューで、ユーザー:<ユーザー名> に移動します。
  2. ログアウト をクリックします。
親トピック: ログインおよびログアウト


クイック スタート タスク

クイック スタート タスクは、ユーザーが Silk Central を使用して実行する必要があると想定される主要なタスクの概要です。これらのタスクは、チュートリアルとしての役割を果たし、Silk Central のコア機能をベスト プラクティスに従って使用する方法をステップごとに示しています。詳細については、このヘルプの関連するセクションを参照してください：「要件」、「テスト」、「実行計画」、「問題追跡と結果分析」

  • 必要な資産の設定 - クイック スタート タスク
    テスト フレームワークの構築を始める前に、少なくともプロジェクトと製品を設定する必要があります。自動テストを作成する予定があれば、ソース管理プロファイルも設定する必要があります。
  • 要件の定義 - クイック スタート タスク
    要件を管理し、テストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。 外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。
  • テストの設計 - クイック スタート タスク
    有用なテストを使用して、関連するすべての機能をカバーするようにテストを設計します。
  • 実行計画とテストの実行 - クイック スタート タスク
    テストを計画し実行することで、必要なテスト データを入手します。
  • テスト結果の追跡と分析 - クイック スタート タスク
    Silk Central でテスト結果を分析する方法には、分析したい情報や、実行したテスト タイプに応じて、いくつかの方法があります。
親トピック: 入門


必要な資産の設定 - クイック スタート タスク

テスト フレームワークの構築を始める前に、少なくともプロジェクトと製品を設定する必要があります。自動テストを作成する予定があれば、ソース管理プロファイルも設定する必要があります。フィルタ、プロパティ、属性などのほかの設定を行う必要がある場合もあります。これらのタスクの実行には、スーパーユーザー、システム管理者、またはプロジェクト マネージャの権限が必要です。

必要な資産を設定するには、次の作業を実行する必要があります。

  1. プロジェクトを追加する
    Silk Central は要件、テスト、およびその実行と結果を、プロジェクトに関連付けて管理します。 よって、まずはじめにプロジェクトを作成する必要があります。
  2. 製品を追加する
    Silk Central は、ある特定の製品のバージョンとビルドを関連させてテスト実行の結果をトラッキングします。このため、テストを作成する前に、製品 を定義する必要があります。
  3. ソース管理プロファイルを設定する
    自動テストの場合は、テストを作成する前に、ソース管理プロファイル も準備する必要があります。 Silk Central の自動テストは、実際はソース管理システムにあるテスト スクリプトです。 ソース管理システムにアクセスするためには、ソース管理プロファイルを設定する必要があります。
親トピック: クイック スタート タスク


プロジェクトを追加する

Silk Central は要件、テスト、およびその実行と結果を、プロジェクトに関連付けて管理します。 よって、まずはじめにプロジェクトを作成する必要があります。

プロジェクトを作成するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. プロジェクトの新規作成 をクリックします。 プロジェクト設定 ページが表示されます。
  3. プロジェクト名 と 説明 に入力します。
  4. プロジェクトの所有者 を選択します。
  5. 省略可能：プロジェクトに対する タグ を入力します。多くのプロジェクトがある場合、プロジェクト タグを使用すると、プロジェクト リスト ページの タグ 列を使用してフィルタすることができます。
  6. 省略可能：アジャイル プロジェクト テンプレートに基づいてプロジェクトを作成するには、アジャイル プロジェクト テンプレート を プロジェクト テンプレート リスト ボックスから選択します。
  7. プロジェクトを Issue Manager プロジェクトとして初期化するには、新しいプロジェクトの初期化 または 既存のプロジェクトの再利用 をクリックします。詳細については、「プロジェクトを Issue Manager プロジェクトとして初期化する」を参照してください。
  8. 共有テスト セクションで、プロジェクトがリポジトリ プロジェクトであるかどうかを定義します。以下のオプションのいずれかを選択します。
    • テストを共有しない：このプロジェクトは他のプロジェクトのテストを参照しません。また、このプロジェクトのテストが他のプロジェクトから参照されることもありません。
    • テストを共有する：このプロジェクトをリポジトリ プロジェクトとして、テストを他のプロジェクトから参照できるように設定します。
    • 共有テストの参照元：このプロジェクトがテストを参照するリポジトリ プロジェクトを選択します。
  9. グループ セクションには、利用可能なグループと割り当て済みグループのリストが表示されます。グループの割り当ては必須です。Ctrl + クリック または Shift + クリック を使用すると、複数のグループを選択できます。LDAP グループのインポート をクリックして、LDAP サーバーからグループをインポートすることもできます。詳細については、「LDAP サーバーからグループをインポートする」を参照してください。ユーザー グループが存在しない場合は、後でユーザー グループを作成してから割り当てることができます。また、グループ/プロジェクトの割り当ては、グループの設定 ページで設定することもできます。権限は、ユーザー ロールによって異なります。ユーザー権限については、「ユーザー ロールとアクセス許可」を参照してください。
  10. ロケーション セクションには、利用可能なロケーションと割り当て済みロケーションのリストが表示されます。ロケーションの割り当ては必須です。Ctrl + クリック または Shift + クリック を使用すると、複数のロケーションを選択できます。ロケーションが存在しない場合は、後でロケーションを作成してから割り当てることができます。また、ロケーション/プロジェクトの割り当ては、ロケーション設定 ページで設定することもできます。詳細については、「ロケーションを管理する」を参照してください。
  11. 保存 をクリックして設定を保存します。
    プロジェクト リスト ページに戻ります。新しいプロジェクトが一覧表示されます。
親トピック: 必要な資産の設定 - クイック スタート タスク
次のトピック: 製品を追加する


製品を追加する

Silk Central は、ある特定の製品のバージョンとビルドを関連させてテスト実行の結果をトラッキングします。このため、テストを作成する前に、製品 を定義する必要があります。

新しい製品を追加するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品の新規作成 をクリックします。 製品の新規作成 ダイアログ ボックスが表示されます。
  4. 名前 フィールドに、新しい製品の名前を入力します。
  5. 説明 フィールドに、製品の説明を入力します。
  6. アクティブ チェック ボックスをオンにして、この製品と テスト との関連付けを有効にします。
  7. OK をクリックして、製品を保存します。
    注: 製品を作成すると、Silk Central によって、その製品に対するデフォルトのバージョン 1.0 とデフォルトのビルド 1 が、自動的に作成されます。
親トピック: 必要な資産の設定 - クイック スタート タスク
前のトピック: プロジェクトを追加する
次のトピック: ソース管理プロファイルを設定する


ソース管理プロファイルを設定する

自動テストの場合は、テストを作成する前に、ソース管理プロファイル も準備する必要があります。 Silk Central の自動テストは、実際はソース管理システムにあるテスト スクリプトです。 ソース管理システムにアクセスするためには、ソース管理プロファイルを設定する必要があります。
ソース管理プロファイルの設定に関する詳細は、「ソース管理プロファイル」を参照してください。
親トピック: 必要な資産の設定 - クイック スタート タスク
前のトピック: 製品を追加する


要件の定義 - クイック スタート タスク

要件を管理し、テストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。 外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。

要件を管理するには、以下のタスクの一部または全部を実行する必要があります。

  1. 要件を作成する
    要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。
  2. 要件からテストを生成する
    要件 ツリーからテストを直接生成して、テストを特定の要件に割り当てることができます。要件 ツリーは、新しい テスト ツリーのテスト フォルダ/テスト構造のテンプレートとなります。
  3. 外部要件管理ツールを統合する
    外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。
親トピック: クイック スタート タスク


要件を作成する

要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。

新しい要件を作成するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリーで、要件またはルート ノードを選択します。
  3. 同じ階層に新しい要件を作成する場合は、ツールバーの [image] (要件の新規作成) をクリックし、選択した要件の下の階層に作成する場合は、 [image] (子要件の新規作成) をクリックします。 要件の新規作成 ダイアログ ボックスが開きます。
  4. 名前 と 説明 フィールドに、要件の名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 省略可能： 親から継承 チェック ボックスをオフにします。この場合、子要件は親要件からプロパティを継承しません。デフォルトでは、すべてのチェック ボックスがオンになっています。
    注: プロパティ ページの 詳細ビュー および ドキュメント ビュー で、継承されたプロパティにはアスタリスク (*) がマークされます。
  6. リストで、優先度、リスク、および レビュー済み から適切なステータスを選択します。
  7. カスタム要件が定義されている場合は、レビュー済み リストの下に表示されます。該当するフィールドに、この要件と一緒に追跡するカスタム プロパティのデータを入力します。これは、継承したプロパティでは無効化されています。カスタム要件プロパティの作成、編集、および削除の詳細については、「カスタム要件プロパティ」を参照してください。
  8. 新しい要件の作成を完了するには：
    • OK をクリックして要件を作成し、ダイアログ ボックスを閉じます。
    • 適用して新しい要件へ をクリックすると、要件が作成され、別の要件のデータを入力するためにダイアログ ボックスは開いたままになります。
    • 適用して新しい子要件へ をクリックすると、要件が作成され、子要件のデータを入力するためにダイアログ ボックスは開いたままになります。
親トピック: 要件の定義 - クイック スタート タスク
次のトピック: 要件からテストを生成する


要件からテストを生成する

要件 ツリーからテストを直接生成して、テストを特定の要件に割り当てることができます。要件 ツリーは、新しい テスト ツリーのテスト フォルダ/テスト構造のテンプレートとなります。

詳細ビュー から新しいテストを生成するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. テストに変換する要件またはプロジェクトのノードを右クリックし、テストの生成 を選択します。 要件からのテストの生成 ダイアログ ボックスが表示されます。このダイアログ ボックスを利用して、選択した要件サブツリーのリーフ ノード (最下位ノード) をテストに変換するか、テスト フォルダに変換するかを指定できます。また、このツリーを新しいテスト コンテナ内に生成するか、既存のコンテナ内に生成するかも指定できます。
  3. 名前の入力 フィールドに新しいテスト コンテナの名前を入力し、製品の選択 リストから製品を選択して、アクティブな Silk Central プロジェクト内にコンテナを作成します。 製品の選択 リストには、プロジェクト マネージャによって構成された製品がインポートされています。詳細については、『プロジェクトを管理する』を参照するか、プロジェクト マネージャに問い合わせてください。
  4. ソース管理プロファイルを定義している場合は、ソース管理プロファイルの選択 リストから、テストのソースを管理するために使用するソース管理プロファイルを選択します。 ソース管理プロファイルの詳細については、「ソース管理プロファイル」を参照するか、Silk Central 管理者に問い合わせてください。
  5. テストで選択した要件の子要件をすべて含めるには、子要件を含める チェック ボックスをオンにします。 このチェック ボックスは、デフォルトでオンになっています。
  6. 新規のテストを、その作成元となった要件に自動的に割り当てるには、新規に生成したテストを要件に割り当てる チェック ボックスをオンにします。 このオプションをオフにした場合は、テストを手動で要件に割り当てる必要があります。
    注: 生成方法として 要件ツリーのリーフ ノードからテスト フォルダを生成する がオンになっている場合、このオプションは利用できません。
  7. OK をクリックして、テストを作成します。 新しいテストは、要件 ツリーと同じ構造になります。
  8. メッセージ ボックスが表示されます。はい をクリックして テスト 領域にテスト計画を表示するか、いいえ をクリックして、要件 領域のままにします。
親トピック: 要件の定義 - クイック スタート タスク
前のトピック: 要件を作成する
次のトピック: 外部要件管理ツールを統合する


外部要件管理ツールを統合する

外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。

外部要件管理ツールの統合についての詳細は、要件管理ツール を参照してください。

親トピック: 要件の定義 - クイック スタート タスク
前のトピック: 要件からテストを生成する


テストの設計 - クイック スタート タスク

有用なテストを使用して、関連するすべての機能をカバーするようにテストを設計します。

テストを設計するには、以下のタスクの一部または全部を実行する必要があります。

  1. テスト資産を構造化する
    製品とソース管理プロファイルの情報の両方を テスト コンテナ レベルに指定するため、このノードは、テスト資産構造における最上位層のノードとなります。
  2. テストを作成する
    ソフトウェアの特定の機能をテストするために、テストを作成します。
  3. テストに要件を割り当てる
    要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。
親トピック: クイック スタート タスク


テスト資産を構造化する

Silk Central は、ある特定の製品のバージョンとビルドを関連させてテスト実行の結果をトラッキングします。このため、テストを作成する前に、製品 を定義する必要があります。自動テストの場合は、テストを作成する前に、ソース管理プロファイル も準備する必要があります。 Silk Central の自動テストは、実際はソース管理システムにあるテスト スクリプトです。 ソース管理システムにアクセスするためには、ソース管理プロファイルを設定する必要があります。 製品とソース管理プロファイルの情報の両方を テスト コンテナ レベルに指定するため、このノードは、テスト資産構造における最上位層のノードとなります。

まずはじめに、単純に 1 つのコンテナを作成します：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、新しいコンテナをサブノードとして追加するルート ノードを選択します。
    注: コンテナを入れ子にすることはできませんが、コンテナにサブ フォルダを追加することはできます。
  3. ツールバーの テスト コンテナの新規作成 をクリックするか、ノードを右クリックし、テスト コンテナの新規作成 を選択します。

    ノードを右クリックして、テスト コンテナの新規作成 を選択することもできます。

    新しいコンテナ ルート ノードが テスト ツリーに追加され、テスト コンテナの新規作成 ダイアログ ボックスが表示されます。
  4. コンテナの 名前 と 説明 を入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 製品 リスト ボックスから、このテスト コンテナに関連付ける定義済みの製品を選択します。製品プロファイルの追加の詳細については、「製品を追加する」を参照してください。
  6. ソース管理プロファイル リスト ボックスから、定義済みのソース管理プロファイルを選択します。 テスト コンテナでテスト ソースをチェックアウトしない場合は (手動テストのみの場合など) 、--- を選択します。
    注: Silk Central 実行サーバーは、コンテナに含まれているテストのプログラム ソースを、定義済みのソース管理プロファイルから取得します。ソース管理プロファイルで指定したパスによっては、テスト コンテナの ルート ノード フィールドにサブノードを使用するように指定できます。
  7. 省略可能：テストを実行する前に作業フォルダをクリアする チェック ボックスをオンにします。

    オンにした場合、ソース管理システムから削除されたファイルは、作業フォルダからも削除されることになります。デフォルトはオンです。

  8. コンテナの保存先となるデフォルトのルート パスを指定するには、参照... をクリックして、その場所に移動します。
  9. 省略可能：Silk Central が Silk Performer と統合されている場合は、カスタム データ ディレクトリ と カスタム インクルード ディレクトリ を定義できます。 Silk Performer では、インクルード ディレクトリは、システム インクルード ディレクトリと カスタム インクルード ディレクトリに分かれています。データ ディレクトリは、システム データ ディレクトリと カスタム データ ディレクトリに分かれています。その他の情報については、Silk Performer のドキュメントを参照してください。
  10. このダイアログ ボックスの プロパティを表示しないテスト タイプ フィールドを利用して、テスト コンテナの プロパティ ページ、およびこのコンテナ内のすべてのテスト フォルダの プロパティ ページに表示するテスト プロパティ タイプを指定できます。 これらの設定は、個々のテストの表示には影響を与えません。
  11. 編集 をクリックして、非表示のテスト プロパティ設定を調整します。 プロパティを表示しないテスト タイプ ダイアログ ボックスが表示されます。
  12. プロパティを表示するテスト タイプのチェック ボックスをすべてオフにします。
  13. 設定を保存して プロパティを表示しないテスト タイプ ダイアログ ボックスを閉じるには、OK をクリックします。
  14. 保存 をクリックして設定を保存します。
親トピック: テストの設計 - クイック スタート タスク
次のトピック: テストを作成する


テストを作成する

ソフトウェアの特定の機能をテストするために、テストを作成します。
Silk Central は、さまざまな種類のテストをサポートしています。「テストを管理する」を参照して、作成したいテスト タイプを選択したら、それぞれのトピックの手順に従ってください。
親トピック: テストの設計 - クイック スタート タスク
前のトピック: テスト資産を構造化する
次のトピック: テストに要件を割り当てる


テストに要件を割り当てる

要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。
要件を手動でテストに割り当てるには：
  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、要件を割り当てるテストを選択します。
  3. 割り当て済み要件 タブをクリックします。
    注: 要件フィルタを作成した場合は、要件 ツリーの上にあるフィルタ リストから要件フィルタを選択できます。新しい要件フィルタを作成するには、メニューの 要件 > 詳細ビュー をクリックし、ツールバーの フィルタの新規作成 をクリックします。
    割り当て可能なすべての要件が、要件 ツリーに表示されます。
  4. 割り当てる要件を選択します。 キーボードの Ctrl または Shift キーを使用すると、標準ブラウザの複数選択機能を使用して、複数の要件を選択することができます。
  5. すべてのフィルタ済み要件の割り当て をクリックして、すべてのフィルタ済み要件を選択したテストに割り当てるか、選択した項目をドラッグして 割り当て済み要件 領域にドロップするか、要件の左側にある 割り当て をクリックして、要件を選択したテストに割り当てます。すべてのフィルタ済み要件の割り当ては、フィルタが選択されており、かつ 要件の管理 または 資産の管理 アクセス権のいずれかを持つ場合にのみ有効です。
    注: 要件からのテストの生成 ダイアログ ボックスで 新規に生成したテストを要件に割り当てる チェック ボックスをオンにすると、新規に生成したテストを生成元となった要件に自動的に割り当てることができます。これは、デフォルトの動作です。
親トピック: テストの設計 - クイック スタート タスク
前のトピック: テストを作成する


実行計画とテストの実行 - クイック スタート タスク

テストを計画し、実行するには、以下のタスクの一部または全部を実行する必要があります。

  • 自動テストを計画および実行する
    関連するテストをまとめて実行するために、実行を作成します。
  • 手動テストを計画および実行する
    このウォークスルーでは、手動実行計画 の機能を例を使って示します。
親トピック: クイック スタート タスク


自動テストを計画および実行する

関連するテストをまとめて実行するために、実行を作成します。
  1. 実行計画を作成する
    関連するテストをまとめて実行するために、実行計画を作成します。
  2. 手動で実行計画に割り当てる
    テストを手動で実行計画に割り当て、実行するテストに含めます。
  3. 実行計画を実行する
    スケジュールから独立して個々の実行計画を実行します。
親トピック: 実行計画とテストの実行 - クイック スタート タスク


実行計画を作成する

関連するテストをまとめて実行するために、実行計画を作成します。
  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、フォルダまたはプロジェクト ノードを選択します。
  3. ツールバーで 子実行計画の新規作成 (子実行計画の新規作成) をクリックするか、フォルダ、テスト サイクル、またはノードを右クリックして 子実行計画の新規作成 をクリックします。 実行計画の新規作成 ダイアログ ボックスが表示されます。
  4. 実行計画の名前と説明を入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. テスト コンテナ リストからテスト コンテナを選択します。
    注: 1 つの実行計画には、1 つのテスト コンテナしか割り当てることはできません。このテスト コンテナから 1 つのテストのみを実行できます。
    このコンテナが属する製品で定義されている最新のバージョンとビルドが、バージョン リスト ボックスと ビルド リストに自動的にインポートされます。
  6. バージョン リストと ビルド リストから、製品のバージョンとビルドをそれぞれ選択します。 この実行計画の新規実行の開始時には、これらが使用されます。また、ビルド情報ファイルからの読み込み チェック ボックスをオンにすることもできます。この場合、バージョンおよびビルドは、各実行の開始時に、アプリケーション サーバーのビルド情報から読み込まれます。実行サーバー上でビルド情報ファイルが使用できる場合は、テスト実行時に、デフォルトでこのファイルが使用され、実行計画の新規作成 ダイアログ ボックスの設定が上書きされます。
  7. 優先度 リストから、実行計画の優先度を選択します。 自動実行計画の場合、複数の実行計画がキューに入れられたが、1 台の実行サーバーのみが使用可能な場合、優先度 によって、最初に実行される実行計画が決定されます。実行サーバーが使用可能でも、複数の実行計画が使用できないモバイル デバイスを必要としている場合も同様です。
  8. オプションとして、実行計画を最新バージョンよりも前のバージョンにするように、ソース管理ラベル フィールドに指定することができます。このラベルは、ソース管理システムで管理されている特定のバージョン (テスト コンテナが関連付けられているもの) を指す必要があります。このフィールドに何も指定されていない場合、実行計画の最新バージョンが取得されます。ソース管理ラベル プロパティが有効になるのは、関連付けられているテスト コンテナでバージョン管理をサポートするソース管理プロファイルが使用される場合のみです。ソース ファイルの複数のバージョンを扱う場合には、実行サーバーに十分な空きディスク領域があることを確認してください。どの実行サーバーでも各バージョンが専用のフォルダに保存されます。
    ヒント: 特定の実行計画に対して、リポジトリの特定のブランチをチェック アウトするには、各実行計画の ソース管理ラベル フィールドでブランチ名を指定します。
  9. OK をクリックして 実行 ツリーを更新すると、新規に作成した実行計画が表示されます。
親トピック: 自動テストを計画および実行する
次のトピック: 手動で実行計画に割り当てる


手動で実行計画に割り当てる

テストを手動で実行計画に割り当て、実行するテストに含めます。
  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 選択したテストを割り当てたい実行計画を選択します。
  3. 割り当て済みテスト タブをクリックします。
  4. 手動割り当て オプションをクリックします。 選択した実行に関連するテスト コンテナのすべてのテストは、テスト ツリーに表示されます。テスト フィルタを作成した場合は、テスト ツリーの上にあるフィルタ リストから選択できます。新しいテスト フィルタを作成するには、メニューの テスト をクリックし、ツールバーの [image] (フィルタの新規作成) をクリックします。
  5. 割り当てるテストを選択します。 キーボードの Ctrl または Shift キーを使用すると、標準ブラウザの複数選択機能を使用して、複数のテストを選択することができます。
  6. 選択した項目をドラッグし、割り当て済みテスト 領域にドロップするか、テストの左側にある 割り当て をクリックします。 フォルダまたはトップレベル コンテナを割り当てると、それを親とするすべての子テストが、選択されている実行計画に割り当てられます。
    ヒント: ノードを右クリックして展開、折りたたみを行います。
親トピック: 自動テストを計画および実行する
前のトピック: 実行計画を作成する
次のトピック: 実行計画を実行する


実行計画を実行する

スケジュールから独立して個々の実行計画を実行します。
  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、実行するプロジェクト、実行計画、または構成スイートを選択します。 ここでは、Ctrl+クリック や Shift+クリック を使用して、複数の要素を選択できます。
  3. ツールバーの [image] (実行) をクリックします。これは、テスト サイクル、テスト サイクル内の実行計画、未割り当てテストに対しては利用できません。 実行 ダイアログ ボックスが表示されます。
  4. 実行 ダイアログ ボックスで 実行するテストを定義します。
  5. アクティビティ ページへ移動 チェック ボックスをオンにすると、実行用のテストを定義した後に アクティビティ ページに進みます。
親トピック: 自動テストを計画および実行する
前のトピック: 手動で実行計画に割り当てる


手動テストを計画および実行する

このウォークスルーでは、手動実行計画 の機能を例を使って示します。例は以下の仮説を使用しています。

  • 要件は完全に文書化され、Risk プロパティによって分類されています。
  • 575 の手動テストが完全に文書化され、要件に割り当てられ、特定のテストの実行の必要性を定義する Importance 属性によって分類されています。
  • プロジェクト終了条件 とも呼ばれる品質目標は要件プロパティ Risk とテスト属性 Importance に基づいて定義されています。これらの品質目標は必要なテストのレベルです。
  • 計画するテストは品質目標を最もよく達成できるテストのみです。
  1. 概要
    [手動実行計画] ページの領域の概要を示します。
  2. テスト サイクルを作成する
    開始日時、終了日時、および最大利用可能時間を定義し、テスト サイクルを作成する方法について説明します。
  3. 手動テスト担当者を追加する
    手動テスト担当者をテスト サイクルに追加する方法と最大利用可能時間を定義する方法について説明します。
  4. テストを選択してスケジューリングする
    テストをフィルタし、ソートし、グループ化する方法とそれらをテスト サイクルに割り当てる方法について説明します。
  5. 手動テスト担当者にテストを割り当てる
    テスト サイクルのテストを手動テスト担当者に割り当てる方法について説明します。
  6. 手動テストを実行する
    実行計画を開始したら、手動テスト ウィンドウを使用して、手動テストを実行する段階に入ります。
親トピック: 実行計画とテストの実行 - クイック スタート タスク


概要

手動実行計画 ページは 4 つの領域で構成され、2 つの画面に表示されます。最初の画面の テストの選択 画面では、テスト サイクルのテストを選択し、スケジュールすることができます。2 番目の画面の テストの割り当て 画面では、選択したテスト サイクルのテストを、実行するテスト担当者に割り当てることができます。

テストの選択 画面は以下の 3 つの領域に分かれています。

  • 左側の フィルタ条件 領域。フィルタ機能により、次の領域に表示するテストを絞り込むことができます。
  • 中央の 一致したテスト 領域。このリストには、使用可能なテストがすべて表示されます。フィルタを適用すると、フィルタ処理されたテストだけが表示されます。
  • 右側の テスト サイクル 領域。中央のリストからこの領域内の定義した期間を表すテスト サイクルにテストを割り当てることができます。

テストの割り当て 画面にアクセスするには、右上にある テストの割り当て >>> をクリックします。この画面は以下の 2 つの領域に分かれています。

  • 左側の テスト サイクル 領域。この領域は テストの選択 画面上の領域と同じです。つまり、両方の画面に表示されます。
  • 左側の 割り当て済みテスト 領域。このリストには、現在選択しているテスト サイクルに追加されたテストが表示されます。この領域のリストから テスト サイクル 領域にテストをドラッグし、テスト担当者にドロップすることができます。

親トピック: 手動テストを計画および実行する
次のトピック: テスト サイクルを作成する


テスト サイクルを作成する

最初のステップでは、テスト サイクルを作成します。テスト サイクルとは、開始日時、終了日時、および手動テスト担当者のリストで構成される定義済みの期間です。テスト サイクルに 週21 という名前を付けます。
  1. メニューで、実行計画 > 手動実行計画 をクリックします。
  2. 右側の テスト サイクル 領域で、テスト サイクルの新規作成 をクリックします。 テスト サイクルの新規作成 ボックスが表示されます。
  3. テスト サイクルの名前を入力します。ここでは、週21 と入力しました。
  4. オプションで説明を入力します。
  5. 開始日 の横にある [image] をクリックし、テスト サイクルの開始日時を設定します。
  6. 終了日 の横にある [image] をクリックし、テスト サイクルの終了日時を設定します。
  7. hh:mm 形式で、このテスト サイクルに必要な時間 (最大利用可能時間) を入力します。ここでは、35:00 と入力しました。
  8. OK をクリックします。
テスト サイクル 領域にテスト サイクルが表示されます。現時点では、テスト担当者は割り当てられていません。次のステップでは、テスト担当者を割り当てます。

親トピック: 手動テストを計画および実行する
前のトピック: 概要
次のトピック: 手動テスト担当者を追加する


手動テスト担当者を追加する

次のステップでは、手動テスト担当者をテスト サイクルに追加します。各手動テスト担当者がこのテスト サイクルで使用する最大利用可能時間も定義します。
  1. テスト サイクル 週21 のヘッダーで、... > 割り当て済みテスト担当者の編集 をクリックします。 割り当て済みテスト担当者の編集 ダイアログ ボックスが表示されます。
  2. テスト担当者の追加/削除 をクリックします。 テスト担当者の追加/削除 ダイアログ ボックスが表示されます。
  3. 選択可能 リストからユーザー グループを選択します。
  4. 選択可能 リストのユーザー グループから 1 つ以上のユーザーを選択します。
  5. 追加 または すべて追加 をクリックして、ユーザーを 選択済み リストに追加します。
  6. OK をクリックします。 ユーザーが 割り当て済みテスト担当者の編集 ダイアログ ボックスのリストに追加されました。
  7. 追加された各ユーザーに対して、テスト サイクルの最大利用可能時間を 最大利用可能時間 フィールドに hh:mm 形式で設定します。
  8. 閉じる をクリックします。
テスト サイクル全体および各手動テスト担当者の両方の利用可能なリソースがテスト サイクルに表示されます。未完了の割り当て済みテストがバーンダウン チャートに表示されます。テスト サイクルを作成し、手動テスト担当者を追加したら、実行するテストを次のステップで決定します。

親トピック: 手動テストを計画および実行する
前のトピック: テスト サイクルを作成する
次のトピック: テストを選択してスケジューリングする


テストを選択してスケジューリングする

このトピックでは、テストをテスト サイクルに割り当てる方法について説明します。目標は、定義された品質目標を最もよくカバーするテストを選択することです。品質目標は要件のリスクに基づく場合があります。一般的には、高リスクを持つ状態をまず最初にテストします。
  1. 左側の フィルタ条件 の 品質目標 で、Requirement Risk チェック ボックスをオンにします。 一致したテスト のリストを重要なテストに絞り込みます。
  2. 一致したテスト 領域で、列ヘッダーのコンテキスト メニューを開き、テストをソート、フィルタ、またはグループ化します。これにより、スケジュールが必要なテストを選択しやすくなります。
  3. 1 つまたは複数のテストを選択し、右側の テスト サイクル 領域にドラッグして、テスト サイクルにドロップします。 テスト サイクルにテストを追加すると、既に使用されているリソースのインジケータが更新されます。このインジケータの上にマウスを移動すると、総最大利用可能時間、予定時間、残り時間に関する詳細情報が表示されます。
  4. 最重要リスクを持つすべてのテストをスケジューリングしたら、高リスクを持つテストをスケジューリングします。その後、中リスクを持つテストをスケジューリングし、以下同様の手順を繰り返します。

テスト サイクルに割り当てられたテストが テスト担当者なし 行に移動しました。次のステップでは、手動テスト担当者を割り当てます。

親トピック: 手動テストを計画および実行する
前のトピック: 手動テスト担当者を追加する
次のトピック: 手動テスト担当者にテストを割り当てる


手動テスト担当者にテストを割り当てる

ここでテスト サイクルのテストを手動テスト担当者に割り当てます。
  1. 右上にある テストの割り当て >>> をクリックします。 テストの割り当て 画面が表示されます。
  2. 左側の テスト サイクル 領域で、テスト サイクルの テスト担当者なし 行をクリックします。 テスト担当者に割り当てられていないすべてのテストが、右側の 割り当て済みテスト 領域に表示されます。
  3. 1 つまたは複数のテストを選択し、左側の テスト サイクル 領域にドラッグして、手動テスト担当者にドロップします。 手動テスト担当者にテストを割り当てると、リソース インジケータが更新されます。このインジケータの上にマウスを移動すると、最大利用可能時間、予定時間、残り時間に関する詳細情報が表示されます。
  4. 手動テスト担当者へのテストの割り当てが完了したら、... > テスト サイクルの開始 をクリックしてテストを開始します。

テスト サイクルを開始すると、テストが割り当てられたことを示す電子メールが各手動テスト担当者に送信されます。テスト用受信トレイ (ユーザーに割り当てられた手動テスト) を個人のダッシュボードに追加することができます。ユーザーに割り当てられたすべてのテストがここに一覧表示されます。

親トピック: 手動テストを計画および実行する
前のトピック: テストを選択してスケジューリングする
次のトピック: 手動テストを実行する


手動テストを実行する

実行計画を開始したら、手動テスト ウィンドウを使用して、手動テストを実行する段階に入ります。
手動テスト ウィンドウを開くには、メニューで ホーム > マイ ダッシュボード をクリックし、ユーザーに割り当てられた手動テスト パネルで [image] (手動テストの続行) をクリックします。ダッシュボードにこのパネルが表示されていない場合は、追加する必要があります。ダッシュボードとパネルの詳細については、「ダッシュボード」を参照してください。

手動テスト ウィンドウは、直感的に使用できますが、手動テストについての詳細な情報が必要な場合は、「手動テスト」を参照してください。

親トピック: 手動テストを計画および実行する
前のトピック: 手動テスト担当者にテストを割り当てる


テスト結果の追跡と分析 - クイック スタート タスク

Silk Central でテスト結果を分析する方法には、分析したい情報や、実行したテスト タイプに応じて、いくつかの方法があります。
レポート、問題/アクティビティ追跡を含む Silk Central の結果分析機能についての情報は、「問題追跡と結果分析」を参照してください。
  • 自動テスト結果を分析する
    実行計画の実行のテスト結果を表示し、拡張された根本原因分析を行ったり、複数の実行の結果をテストのステータスの変化を可視化して比較します。
  • 手動テストの結果の分析
    手動テスト結果 ビューを使用して、添付した問題や添付情報のようなすべての情報を含む手動テストの結果ビューを簡単に参照することができます。
  • ダッシュボード パネル
    Silk Central のダッシュボードは、ユーザー個人用の開始領域です。日常作業に必要な情報を提供するさまざまなパネルを追加し、並べ替えることによりカスタマイズできます。
  • レポート
    Silk Central のレポート機能を使用して、テスト結果を分析できます。
親トピック: クイック スタート タスク


自動テスト結果を分析する

テスト結果 ビューと実行の比較 ビューは、結果の概要を読みやすくするために、完全なドリルダウン機能を提供します。結果ファイル、スクリーンショットのサムネイル、メッセージ、スタックトレースなどのすべての情報が含まれます。これによって、とくに、複数の実行結果を横に並べて比較することもできるため、失敗したテスト実行の根本原因をすばやく分析できます。

たとえば、次の興味深いタスクを実行できます。
  • 構成スイート内または構成を表す実行計画内のすべての構成の実行を分析する
  • 同じ実行計画の実行を比較する (ステータスが変更されたテストを見つけ出すためなど)
  • 実行計画のすべての失敗したテストを一度に表示する

自動テストの実行結果を分析するには：

  1. 実行の 実行 グリッドまたは アクティビティ > 最近の実行 グリッドで、1 つ以上の実行を選択します。
  2. 自動テスト結果を表示します アイコンをクリックして、単一実行の結果を分析するか、選択項目を右クリックして 自動テスト結果の比較 を選択し、複数の実行を比較します。
  3. ページの上部にあるアイコン、または特定のステータス アイコンをクリックして、結果ファイル、スクリーンショットのサムネイル、メッセージ、スタックトレースなどの詳細な情報にアクセスします。
    ヒント: 失敗したテストのみ表示 チェック ボックスを使用して、表示する結果を絞り込むことができます。
親トピック: テスト結果の追跡と分析 - クイック スタート タスク


手動テストの結果の分析

完了または未完了のコンテキストのいずれかのテスト実行があるとき、手動テスト結果 ビューを使用して、添付した問題や添付情報のようなすべての情報を含む手動テストの結果ビューを簡単に参照することができます。この情報のすべては直ちに表示されます。同様に、PDF 版の印刷やダウンロードも可能です。

手動テスト結果 ビューは、左側にツリー ビューが、右側に詳細ビューがあります。ツリー ビューは結果ビューを開いた時に選択中の内容に基づきます。たとえば、テスト サイクルを選択した場合、すべての割り当て済みテスト担当者とそのテストが表示されます。特定のノードを選択すると、選択に応じた情報で詳細ビューが更新されます。

手動テスト結果 ビューを開くには、手動テストを参照するほぼすべてのコンテキストで、テストの 手動テスト結果の表示 アイコン ( [image]) をクリックします。これは、手動実行計画、ダッシュボード パネル、アクティビティ ページ、実行計画の 実行 グリッド、およびテストの 実行 グリッドから行うことができます。

親トピック: テスト結果の追跡と分析 - クイック スタート タスク


ダッシュボード パネル

Silk Central のダッシュボードは、ユーザー個人用の開始領域です。日常作業に必要な情報を提供するさまざまなパネルを追加し、並べ替えることによりカスタマイズできます。

ダッシュボード パネルについての詳細は、「ダッシュボード」を参照してください。

親トピック: テスト結果の追跡と分析 - クイック スタート タスク


レポート

レポートについての詳細は、「レポート」を参照してください。

親トピック: テスト結果の追跡と分析 - クイック スタート タスク


要件

このセクションでは、Silk Central で要件を管理する方法について説明します。

要件とは、テスト対象アプリケーション (AUT) で機能すべき特定のタスクを実行するために、ユーザーが要求する条件または能力を定義したものです。要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。複数のテストが 1 つの要件をカバーすることも、複数の要件が 1 つのテストによってカバーされることも可能です。外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。要件 領域を利用すると、開発中に絶えずシステム要件を管理できます。要件を作成、変更、削除したり、要件にテストを関連付けたり、履歴で変更を追跡したり、要件リストからテストを直接生成したりできます。

  • 要件と統合を設定する
    Silk Central で要件を管理する場合、要件プロパティ、フィルタ、変更通知を設定できます。他のシステムで要件を管理している場合、Silk Central と統合し、要件やテスト カバレッジなどの Silk Central の要件管理機能を利用することができます。これらのタスクの実行には、スーパーユーザー、システム管理者、またはプロジェクト マネージャの権限が必要です。
  • 要件を管理する
    顧客と開発者間での技術的または非技術的な同意事項を規定したり保守するために、要件の追加や編集を行います。
  • 要件プロパティを設定する
    要件プロパティ、添付ファイル、フラグ、カバレッジを設定します。
  • テストと要件を関連付ける
    要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。
  • 要件のインポート
    Microsoft Word または Excel から要件をインポートする方法を説明します。
  • 要件ビュー
    要件 領域で利用可能なビューについて説明します。
親トピック: Silk Central ヘルプ


要件と統合を設定する

Silk Central で要件を管理する場合、要件プロパティ、フィルタ、変更通知を設定できます。他のシステムで要件を管理している場合、Silk Central と統合し、要件やテスト カバレッジなどの Silk Central の要件管理機能を利用することができます。これらのタスクの実行には、スーパーユーザー、システム管理者、またはプロジェクト マネージャの権限が必要です。
  • 要件のプロパティ
    利用可能な要件プロパティのタイプを説明します。
  • 要件管理ツールとの統合
    外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。
  • フィルタ
    フィルタを使用して、無関係な情報を除外しながら必要な情報を確実に見つける方法について説明します。
  • 変更通知
    要件やテストが他のユーザーによって変更されたときの電子メール通知の設定方法について説明します。
親トピック: 要件


要件のプロパティ

次のセクションでは、利用可能な 2 つのタイプの要件プロパティを説明します。

  • [要件プロパティ] ページ
    アクティブ プロジェクトで使用できるカスタム要件プロパティおよび計算プロパティのリストを表示します。
  • 計算プロパティ
    計算要件プロパティの使い方を説明するトピックを含んでいます。
  • カスタム要件プロパティ
    選択したプロジェクトで扱われているすべての要件に対するカスタム プロパティ フィールドの使用方法について説明します。
親トピック: 要件と統合を設定する
親トピック: プロジェクト設定


[要件プロパティ] ページ

プロジェクト:<プロジェクト名> > プロジェクト設定 > 要件プロパティ

要件プロパティ ページには、アクティブ プロジェクトで使用できるカスタム要件プロパティと計算プロパティのリストが表示されます。

計算プロパティ

列 | 説明
アクション | 計算プロパティに対して実行できるアクション。
名前 | 計算プロパティの名前。 計算プロパティを編集するには、編集 アイコンをクリックします。
数式 | 計算プロパティの実際の数式の名前を表示。
分類 | 計算プロパティの分類のリストを表示。
作成日時 | このプロパティが作成された日時。
作成者 | このプロパティを作成したユーザー。
変更日時 | このプロパティが最後に変更された日時。
変更者 | このプロパティを最後に変更したユーザー。

カスタム プロパティ

列 | 説明
アクション | カスタム プロパティに対して実行できるアクション。
名前 | 要件プロパティの名前。 要件プロパティを編集するには、編集 アイコンをクリックします。
タイプ | プロパティのタイプ。属性の各タイプの説明については、「テスト属性および要件プロパティのタイプ」を参照してください。
作成日時 | このプロパティが作成された日時。
作成者 | このプロパティを作成したユーザー。
変更日時 | このプロパティが最後に変更された日時。
変更者 | このプロパティを最後に変更したユーザー。
親トピック: 要件のプロパティ


計算プロパティ

計算プロパティは、内部プロパティやカスタム プロパティの値を使って定義した数式から計算された 1 つの値を作成するために使用されます。計算された値は、分類 と呼ばれるラベル付けされた範囲に分けられます。計算プロパティを使用すると、グリッドに分類の 名前 が表示されます。計算プロパティの値は、カスタム プロパティの値が表示される場所すべてに表示されます (ドキュメント ビューなど)。また、他の内部またはカスタム要件プロパティと同様に、計算プロパティをフィルタや品質目標に使用できます。

それぞれの計算プロパティは、下限値のないデフォルトの分類を持ちます。他の分類にはすべて下限値が必要です。分類を使用すると、計算プロパティの値に対して名前と範囲を設定できます。分類の名前は、グリッドに値がどのように表示されるかを表します。数式に使用されているプロパティに値が設定されていないものがある場合、または数式の評価に失敗した場合 (0 で除算など)、計算プロパティの値に --- が表示されます。

計算プロパティの数式には、プロジェクト内の内部プロパティまたはカスタム プロパティを使用できます。内部プロパティまたはカスタム プロパティは、数値、テキスト、または単一選択 リスト 型である必要があります。数式には、+ - * / () 演算子を使用できます。

制約事項: プロジェクトごとに 5 つの計算プロパティまで使用できます。計算プロパティを他の計算プロパティの内部で使用することはできません。
  • 計算プロパティを作成する
    計算プロパティの作成方法について説明します。
  • [計算プロパティ] ページ
    [計算プロパティ] ページの説明です。
  • 内部プロパティの値
    複数の内部プロパティの値について説明します。
親トピック: 要件のプロパティ


計算プロパティを作成する

計算プロパティは、値の範囲に基づくプロパティを作成するのに使用します。この手順では、3 つに分類 (低、中、高) される カスタム リスク という計算プロパティの作成を例に、計算プロパティの作成方法について説明します。内部プロパティの リスク、および 数値 タイプ の 影響 という名のカスタム プロパティ (このカスタム プロパティは前もって作成しておく必要があります) を使用します。

  1. 要件 > 要件プロパティ をクリックします。
  2. 計算プロパティの新規作成 をクリックします。
  3. 名前 フィールドに、タイプ カスタム リスク と入力します。
  4. 説明 フィールドに、リスクと影響を使用した計算プロパティ (低、中、高) と入力します。
  5. プロパティの挿入 リストから Business Impact を選択します。 ${Business Impact} が 数式 フィールドに追加されます。
  6. 演算子の挿入 リストから * を選択します。 ${Business Impact}* が 数式 フィールドに追加されます。
  7. プロパティの挿入 リストから Business Risk を選択します。 ${Business Impact}*${Business Risk} が 数式 フィールドに追加されます。
  8. 分類 グリッドのデフォルトの行で、エントリの名前を 低 に変更します。すべての計算プロパティには、下限値を持たないデフォルトの分類を含める必要があるため、この分類が使用されます。
  9. 分類の追加 をクリックします。 分類 グリッドに新しい行が追加されます。
  10. 分類の名前を 中 とし、10 の 下限値 を追加します。
  11. 分類の追加 をクリックします。 分類 グリッドに新しい行が追加されます。
  12. 分類の名前を 高 とし、20 の 下限値 を追加します。
  13. OK をクリックします。
以上で、影響 プロパティと リスク プロパティの両方を要件に設定すると、低、中、高 の値が設定される計算プロパティが作成されました。
親トピック: 計算プロパティ


[計算プロパティ] ページ

計算プロパティ ページは、計算プロパティをプロジェクトに追加したり、編集するのに使用します。このページにアクセスするには、要件 > 要件プロパティ をクリックして、既存の計算プロパティ、もしくは 計算プロパティの新規作成 をクリックします。

名前
計算プロパティの名前が表示されます。
説明
数式または分類のように、計算プロパティの内容を表す説明を入力します。
数式
計算プロパティの数式が表示されます。数式は手入力できる他、プロパティの挿入 リストおよび 演算子の挿入 リストを使用して入力することもできます。数式を手入力する場合は、フィールド名を ${} の構造内に記入する必要があります。演算子はこの構造の間に入ります。
プロパティの挿入
数式 フィールド内でプロパティを入力する場所にカーソルを移動させ、リストからシステム プロパティまたはカスタム プロパティを 1 つ選択して追加します。
演算子の挿入
数式 フィールド内で演算子を入力する場所にカーソルを移動させ、演算子を選択します。
分類グリッド
分類 グリッドは、計算プロパティの値にさまざまな範囲を設定するのに使用します。分類の追加 をクリックし、グリッドに新しい行を作成します。名前 フィールドは分類の特定に、下限値 フィールドは計算プロパティの下限値を決定するのに使用します。分類を使用する際は、グリッドに表示されるのは計算プロパティの値ではなく、分類の 名前 であることに注意してください。たとえば、分類の 名前 が 中 (下限値 は 5) で、計算プロパティの値が 7 の場合、次の分類の下限値が 7 よりも大きい限り、計算値には 中 と表示されます。
親トピック: 計算プロパティ


内部プロパティの値

複数の内部プロパティの一部の値は、計算プロパティの数式で使用できます。 サポートされるプロパティの値は下記のとおりです。

リスク

値名 | 内部値
低 | 1
中 | 2
高 | 3
最重要 | 4

優先度

値名 | 内部値
低 | 1
中 | 2
高 | 3
最重要 | 4

レビュー済み

値名 | 内部値
いいえ | 0
はい | 1
親トピック: 計算プロパティ


カスタム要件プロパティ

要件 > 要件プロパティ で、選択したプロジェクトで扱われているすべての要件にカスタム プロパティ フィールドを追加することができます。カスタム プロパティはその後、要件の編集 ダイアログ ボックスでデフォルト プロパティと共に編集することができます。カスタム プロパティは、要件 > 詳細ビュー > プロパティ に表示されます。プロパティの値が URL の場合だけ、Silk Central は自動的にリンクとして表示し、Silk Central から他の Web アプリケーションに直接アクセスできるようになります。

  • カスタム要件プロパティを作成する
    カスタム要件プロパティを作成して、アクティブなプロジェクト内のすべての要件で使用できるようにします。
  • カスタム属性と要件プロパティのタイプ
    属性と要件プロパティのタイプの詳細について説明します。
  • カスタム要件プロパティを編集する
    カスタム要件プロパティを編集します。
  • カスタム要件プロパティを削除する
    カスタム要件プロパティを削除して、プロパティ リストから削除します。
親トピック: 要件のプロパティ
関連資料
[要件プロパティ] ページ


カスタム要件プロパティを作成する

新規のカスタム要件プロパティを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 要件プロパティ タブをクリックします。
  3. プロパティの新規作成 をクリックして、要件プロパティの新規作成 ダイアログ ボックスを表示します。
  4. 新しいプロパティの名前を 名前 フィールドに入力します。
  5. タイプ リストから新しいプロパティのデータ タイプ を選択します。 属性の各タイプの説明については、「テスト属性および要件プロパティのタイプ」を参照してください。
  6. OK をクリックします。
カスタム プロパティは、アクティブなプロジェクト内のすべての要件で使用できます。
親トピック: カスタム要件プロパティ
関連資料
カスタム属性と要件プロパティのタイプ


カスタム属性と要件プロパティのタイプ

Silk Central では、次のタイプの属性および要件プロパティがサポートされています。

日付

日付 タイプでは、日付値がサポートされています。

リスト

リスト タイプでは、単一選択リストまたは複数選択リストがサポートされています。このタイプには、以下のコントロールがあります。

  • 項目の新規作成：リストにエントリを作成できます。クリックすると、項目の新規作成 ダイアログ ボックスが表示されます。リスト項目の 名前 と 加重数値 を入力して、OK をクリックします。
    注: 加重数値 フィールドの値は、フィルタ条件で次の演算子が使用されている場合にフィルタリングで使用されます：>、>=、<、または <=。フィルタ条件で = または 不一致 の演算子が使用されている場合は、名前 フィールドの値が比較に使用されます。
  • 順序：この列のフィールドを使用して、属性を並べ替えます。
  • 複数選択を許可する：このチェック ボックスをオンにすると、リストから複数の値を選択できます。
    注: 既存の単一選択リストを複数選択リストに変換できます。ただし、複数選択リストを単一選択リストに変更することはできません。
  • アクション：この行のアイコンを使用して、リスト内の各項目を削除、または編集します。
数値

数値 タイプでは、整数値または小数値がサポートされています。次のフィールドがあります。

  • 最小値： フィールドに入力できる最小値を表します。
  • 最大値： フィールドに入力できる最大値を表します。
  • 小数点以下の桁数： 小数点以下の有効桁数を定義するために使用します。整数値の場合は 0 を選択し、小数値の場合は 1、2、3、または 4 を選択します。
注: 定義が更新された場合でも、カスタムの属性および要件プロパティには現在の値が表示されます（たとえば 最小値 や 最大値 が変更された場合）。新しい定義を適用するには、資産を開いて保存します。
テキスト

テキスト タイプでは、すべての英数値がサポートされています。次のフィールドがあります。

  • 最大の長さ： フィールドに入力できる最大文字数を表します。0 を入力するか、このフィールドを空のままにすると、文字数制限がなくなります（要件プロパティのみ）。
親トピック: カスタム要件プロパティ
親トピック: 属性


カスタム要件プロパティを編集する

以前作成したカスタム要件プロパティを編集するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 要件プロパティ タブをクリックします。
  3. 編集対象のプロパティの名前をクリックします。 要件プロパティの編集 ダイアログ ボックスが表示されます。
  4. 名前 フィールドに入力されているプロパティ名を編集します。 プロパティを使用できる場合は、フィルタと要件のリストに名前が表示されます。 プロパティは、要件に適用でき、要件プロパティによってフィルタリングするためにグローバル フィルタで使用できます。
  5. プロパティの 説明 を編集します。
  6. 要件プロパティの各タイプの説明については、「テスト属性および要件プロパティのタイプ」を参照してください。 プロパティのデータ タイプに応じて、異なる編集オプションがあります。
  7. OK をクリックして、変更を保存します。
親トピック: カスタム要件プロパティ
関連概念
フィルタ
関連資料
カスタム属性と要件プロパティのタイプ


カスタム要件プロパティを削除する

以前作成したカスタム要件プロパティを削除するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 要件プロパティ タブをクリックします。
  3. 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックして、削除を確定します。
親トピック: カスタム要件プロパティ


要件管理ツールとの統合

重要: Silk Central 15.0 以前のバージョンから現在のバージョンにアップグレードする前に、すべて同期 を実行して統合した要件管理ツールとすべての要件の同期を取ってください。
外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。統合は、プロジェクト:<プロジェクト名> > プロジェクト設定 の 要件管理 ページで設定します。
注: 統合ツールで要件を編集するだけでなく、Silk Central で作成、編集、削除することもできます。Silk Central の UI や Silk Central の Web サービスからの直接変更を許可するには、対応する ... による要件の作成、編集、削除を許可する チェック ボックスをオンにします。

Silk Central では、オープン インターフェイスを通じて、外部の要件管理システム（RMS）との統合をサポートしています。プラグインを作成して Silk Central に統合すると、任意の RMS を統合できます。外部 RMS を適切に統合できるインターフェイスの詳細については、『Silk Central API ヘルプ』を参照してください。

  • 要件の同期
    Silk Central と外部要件管理ツールの間で要件プロパティ フィールドを同期する方法について説明します。
  • Atlassian JIRA Agile との統合
    Atlassian JIRA Agile を Silk Central と統合する方法について説明します。
  • CA Agile Central との統合
    Silk Central と CA Agile Central を統合する方法について説明します。
  • Caliber との統合
    Caliber を Silk Central と統合する方法について説明します。
  • IBM Rational DOORS との統合
    Silk Central と IBM Rational DOORS を統合する方法について説明します。
  • IBM Rational DOORS Next Generation との統合
    Silk Central と IBM Rational DOORS Next Generation を統合する方法について説明します。
  • IBM Rational RequisitePro との統合
    IBM Rational RequisitePro を Silk Central と統合する方法について説明します。
  • SAP Solution Manager との統合
    Silk Central と SAP Solution Manager を統合する方法について説明します。
  • 外部プロパティで作業する
    Silk Central で外部プロパティで作業する方法について説明します。
  • プロパティ マッピングを編集する
    プロジェクト間で要件プロパティ フィールドを正確にインポートするため、Silk Central と外部要件管理ツールとの間のプロパティ フィールドをマップします。
  • プロパティ-マッピング値ペアを削除する
    プロパティ-マッピング値ペアを削除します。
  • 要件管理のインテグレーション設定を無効にする
    外部要件管理ツールのインテグレーションを無効にして、すべてのインテグレーション データと機能を無効にします。
  • 要件管理のインテグレーション設定を削除する
    外部要件管理ツールのインテグレーションを削除し、すべての関連データのデータベースをクリアします。
親トピック: 要件と統合を設定する
親トピック: プロジェクト設定
親トピック: 統合
関連資料
[要件プロパティ] ページ


要件の同期

Silk Central と外部 RMS の間で要件の同期を有効にすると、同期を実行するたびに外部 RMS での変更を Silk Central が受信できます。プロジェクトで外部 RMS インテグレーションを有効にした場合、要件のマスタ システムは自動的に外部システムになります。つまり、同期は常に外部 RMS ツールから Silk Central に実行されます。要件は Silk Central で編集できなくなります。外部ツールにない要件を新規作成した場合は例外です。要件のアップロードを有効にする オプションが 設定 > 要件管理 で有効である場合にのみ、外部 (マスタ) システムにアップロードできます。

プロパティ マッピング機能により、Silk Central と外部要件管理ツールの間でプロパティ フィールドをマッピングできます。たとえば、User という Silk Central 内のカスタム フィールドを Field_2 という Caliber 内のプロパティ フィールドと等価にすることができます。プロパティ マッピング機能のおかげで、要件プロパティ フィールドの変更がプロジェクト間で必ず正確に反映されるようになります。プロパティ マッピング機能を使用しないと、要件の名前と説明だけがマップされます。詳細については、「プロパティ マッピングを編集する」を参照してください。

要件の同期には、以下のようにいくつかの方法があります。
手動同期
プロパティ ページのルート フォルダ レベルで 変更の同期 をクリックすると、最後の同期以降に変更された要件のみが同期されます。このオプションは、IBM Rational RequisitePro では利用できません。
強制手動同期
プロパティ ページのルート フォルダ レベルで すべて同期 をクリックすると、すべての要件の強制同期が行われます。
自動予定同期
Silk Central で定義されたグローバル スケジュールに基づいて行われます。
自動オンライン同期
要件の変更はツール間で自動的に反映されます。このオプションは、Caliber の場合にのみ使用できます。アプリケーション サーバー上に Caliber クライアントがインストールされており、Caliber サーバー上で MPX が有効化されている必要があります (MPX の有効化についての詳細は、『Caliber インストール ガイド』を参照してください)。Caliber と Silk Central の間で自動同期を有効にするには、ファイル ss.jar をアプリケーション サーバーの Program Files\Silk\Silk Central <バージョン>\lib に追加し、アプリケーション サーバーを再起動します。ファイルを入手するには、カスタマー ケアに問い合わせてください。Caliber で変更が行われると、Silk Central で要件データが自動的に更新され、Silk Central でテスト割り当てが変更されると、Caliber でのトレースが更新されます。このタイプのオンライン同期は、プロジェクトが現在のベースラインで設定される場合にのみ利用可能です。

Silk Central と外部要件管理ツールの間で要件がグローバル スケジュールに基づいて自動的に同期されるように構成できます。グローバル スケジュールの設定の詳細については、この『ヘルプ』の「管理」トピックを参照してください。

注: Caliber を開く ボタンをクリックすると、.crm という拡張子のファイルを開くデフォルト プログラムとして登録されているプログラムが開きます。一部のマシンでは、これは Caliber ではなく要件ビューアである場合があります。この動作はシステム管理者が変更できます。クライアント プログラムは caliberrm.exe というものです。適切に構成すると、このプログラムは Silk Central で選択されている要件に対して開きます。
要件 ツリーのプロジェクト ノードに表示されるバインダ アイコンは、プロジェクトの RM インテグレーションのステータスを示します。
未設定
RM インテグレーションは利用できません。
手動設定
要件のインポート、アップロード、同期化は、要件 > 要件ビュー > プロパティ のプロジェクト ノードで対応するボタンをクリックすることでのみ実行できます。
プロジェクト レベルの プロパティ ページには、以下のプロパティが用意されています。
プロパティ | 説明
システム | インテグレーションが有効になっている外部ツール。
ステータス | インテグレーションが有効になっているかどうか。
プロジェクト名 | Silk Central プロジェクトが関連付けられている外部プロジェクトの名前
要件タイプ | プロジェクト間で共有される要件タイプ。
前回の同期 | 前回の同期の日付と時刻。
前回の同期のステータス | 作成、更新、削除された項目の数を含む、前回の同期のステータス。
注: Caliber と Silk Central との自動オンライン同期を使用したインテグレーションが有効になると、プロジェクト ノードに、オンライン要件変更リスナの現在のステータスが表示されます。このようなプロジェクトのステータスは、[接続済み] (同期済み)、[再接続] (同期を推奨)、および [接続解除] の 3 つです。
  • ツール間で要件を同期する
    Silk Central と外部に構成されている要件管理ツールとの間で要件を同期します。
  • スケジュールに基づいた要件の同期
    グローバル スケジュールを定義して、Silk Central と外部に構成されている要件管理ツールとの間で要件を同期します。
  • 自動同期イベントの電子メール通知を定義する
    電子メール通知を定義して、Silk Central と外部要件管理ツールとの間の要件の自動同期中にエラーが発生したときに送信します。
親トピック: 要件管理ツールとの統合
関連タスク
プロパティ マッピングを編集する


ツール間で要件を同期する

注: プロパティ マッピング機能を使用して、プロパティ フィールドをマップします。 プロパティ マッピング機能を使用しないと、要件の名前と説明だけがマップされます。 詳細については、「プロパティ マッピングを編集する」を参照してください。

Silk Central と外部に構成されている要件管理ツールとの間で要件を同期するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリーでプロジェクト ノードを選択します。
  3. プロパティ タブをクリックします。 プロパティ ページには、選択したツリー要素のプロパティが表示されます。
  4. 変更の同期 をクリックします。
  5. 確認用の 要件の同期 ダイアログ ボックスで はい をクリックして、同期を開始します。 同期が完了するとダイアログ ボックスが開かれ、そこに作成、更新、および削除された要件数などの同期の統計が表示されます。
  6. OK をクリックして、同期を完了します。
    外部に構成されている要件管理ツールでマップされている要件に対して行われた更新が、要件 ツリーに反映されます。
親トピック: 要件の同期
関連タスク
プロパティ マッピングを編集する


スケジュールに基づいた要件の同期

グローバル スケジュールを設定して、Silk Central と外部に構成されている要件管理ツールとの間で要件を自動的に同期することができます。Caliber と Silk Central の間で自動同期を有効にするには、ファイル ss.jar をアプリケーション サーバーの Program Files\Silk\Silk Central <バージョン>\lib に追加し、アプリケーション サーバーを再起動します。ファイルを入手するには、カスタマ ケアに問い合わせてください。

グローバルに定義されたスケジュールに基づいて、要件を同期するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 要件管理 タブをクリックします。
  3. スケジュールの編集 をクリックします。 スケジュールの編集 ダイアログ ボックスが開きます。
  4. 外部システムでの変更を Silk Central と同期させるスケジュールを定義するには、変更の同期 リストから定義済みのグローバル スケジュールを選択します。
  5. 外部システムのすべての要件を Silk Central と同期させるスケジュールを定義するには、すべて同期 リストから定義済みのグローバル スケジュールを選択します。
  6. OK をクリックします。
グローバル スケジュールの作成についての詳細は、「 グローバル スケジュールを追加する」を参照してください。
親トピック: 要件の同期


自動同期イベントの電子メール通知を定義する

電子メール通知を定義して、Silk Central と外部要件管理ツールとの間の要件の自動同期中にエラーが発生したときに、ユーザーに警告することができます。通知の受信者はすべて、同期化ログ ファイルのコピーを受け取ります。

自動同期イベントの電子メール通知を定義するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 要件管理 タブをクリックします。
  3. 通知の編集 をクリックします。 通知の編集 ダイアログ ボックスが表示されます。
  4. 通知の有効化 チェック ボックスをオンにします。
  5. ユーザー名 リスト ボックスからユーザー名を選択します。
  6. 必要に応じて、その他の電子メール アドレス フィールドに他の受信者の電子メール アドレスを追加します。複数の電子メール アドレスは、セミコロンで区切ります。
  7. OK をクリックします。
親トピック: 要件の同期


Atlassian JIRA Agile との統合

Silk Central は Atlassian JIRA Agile との要件統合を提供します。これは、プロジェクトと問題追跡システム JIRA に基づきます。すべての課題タイプ (JIRA の汎用オブジェクト タイプ) を同期することができます。Atlassian JIRA Agile では、カスタム課題タイプを作成することができきるため、同期したい Atlassian JIRA Agile 課題タイプのリストを Silk Central に指定できます (たとえば、Bug または Improvement など)。

Silk Central の統合が現在サポートしている Atlassian JIRA Agile のバージョンは次の通りです： Atlassian JIRA 6、7

制限事項：JIRA 要件の同期は、設定した JIRA プロジェクトの要件に対してのみ機能します。要件が他の JIRA プロジェクトの要件 (エピック) にリンクされている場合、このような要件は同期されません。

  • Atlassian JIRA Agile との統合を有効にする
    Atlassian JIRA Agile との統合を有効にして要件の同期をとります。
  • Atlassian JIRA Agile プロパティ マッピング
    Backlog や Priority などの Atlassian JIRA Agile のプロパティがどのように Silk Central でマップされ、どのように表示、カスタマイズされるかを説明します。
親トピック: 要件管理ツールとの統合


Atlassian JIRA Agile との統合を有効にする

Atlassian JIRA Agile との統合を有効にするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. インテグレーションを確立するプロジェクトを選択します。
  3. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  4. 要件管理 タブをクリックします。
  5. インテグレーションの新規作成 をクリックします。
    注: 統合ツールで要件を編集するだけでなく、Silk Central で作成、編集、削除することもできます。Silk Central の UI や Silk Central の Web サービスからの直接変更を許可するには、対応する ... による要件の作成、編集、削除を許可する チェック ボックスをオンにします。
    インテグレーションの新規作成 ダイアログ ボックスが開きます。
  6. リストから Atlassian JIRA Agile を選択して、次へ をクリックします。 設定の編集 ダイアログ ボックスが開きます。
  7. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  8. JIRA Agile サーバーの URL を入力します
  9. ユーザー名 と パスワード に、JIRA Agile 用のユーザー名とパスワードをそれぞれ入力します。ユーザー名には、有効な JIRA ユーザー プロファイル名を指定してください。
  10. 課題タイプ フィールドに、同期したい課題タイプをセミコロン (;) で区切って指定します。 すべての課題タイプ (JIRA の汎用オブジェクト タイプ) を同期することができます。Atlassian JIRA Agile では、カスタム課題タイプを作成することができきるため、同期したい Atlassian JIRA Agile 課題タイプのリストを Silk Central に指定できます (たとえば、Bug または Improvement など)。
  11. 省略可能： 同期する要件の数を制限したい場合には、カスタム JQL フィールドを使用して、同期を実行する前に要件をフィルタすることができます。JIRA Agile システムで JIRA クエリ言語 (JQL) を使用してクエリを作成し、カスタム JQL フィールドにコピー＆ペーストしてください。JQL の詳細については、Atlassian の『Advanced Searching Documentation』を参照してください。
    ヒント:
    • JQL クエリの ORDER BY ステートメントを使用することはできません。
    • JQL 文字列は、128 文字を超えることはできません。
    • JQL クエリは、設定したプロジェクトや課題タイプに追加して使用されます。これらの設定を打ち消すことはありません。
  12. 接続のテスト をクリックし、入力したホストとユーザー情報が正しいかどうかを確認します。 設定が正しければ、接続のテスト に成功したことを示すメッセージが表示されます。OK をクリックして、先に進みます。
    注: 接続を確立できない場合は、システム管理者に問い合わせてください。
  13. 読み込み をクリックします。 プロジェクト リスト ボックスには、アクセスが許可されている JIRA Agile のすべてのプロジェクトが表示されます。
  14. プロジェクト リストで、Silk Central プロジェクトと統合する予定の外部プロジェクトを選択します。
  15. OK をクリックして、設定を保存します。
親トピック: Atlassian JIRA Agile との統合


Atlassian JIRA Agile プロパティ マッピング

次のプロパティは、JIRA Agile と Silk Central との間でデフォルトのマッピングがあります。
  • JIRA Agile の Backlog にあるユーザー ストーリーは、Backlog に設定された Sprint プロパティ値を持つことで Silk Central に反映されます。フィルタを作成することによって、それらを簡単に検索することができます。
  • JIRA Agile のユーザー ストーリーのデフォルトの Priority 値は、Silk Central の 優先度 プロパティにマップされます。JIRA Agile のデフォルトの Priority 値を使用していない場合は、このマッピングをカスタマイズできます。

JIRA Agile Backlog ストーリーを Silk Central で表示する

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 次の条件を持つフィルタを新しく作成します。
    • 選択基準:外部カスタム属性
    • プロパティ:Sprint
    • 値:Backlog
  3. 適用 をクリックして、フィルタを直ちに適用するか、または、保存および適用 をクリックして、将来再利用するために、フィルタを保存します。

JIRA Agile Priority 値を Silk Central の優先度にマッピングする

JIRA Agile のユーザー ストーリーのデフォルトの Priority 値は、Silk Central の 優先度 プロパティに次のようにマップされます。
  • Blocker=SC_Priority_Critical
  • Critical=SC_Priority_High
  • Major=SC_Priority_Medium
  • Minor=SC_Priority_Low
  • Trivial=SC_Priority_Low
JIRA Agile のデフォルトの Priority 値を使用していないか、マッピングをカスタマイズしたい場合は、Silk Central 管理者は次のようにして設定をカスタマイズできます。
  1. アプリケーション サーバーを停止します。
  2. propertyMappings.properties ファイルをテキスト エディタで開きます。このファイルは、アプリケーション サーバーの plugins フォルダにある JIRA Agile プラグイン ファイルの JIRAAgile.zip 内にあります。
  3. SC_Priority=Priority を検索します。これ以降を編集することにより、JIRA Agile の Priority 値を Silk Central の 優先度 にマッピングするのをカスタマイズすることができます。
    注: Silk Central Priority 値は、接頭辞 SC_Priority_ が必要です。
  4. ファイルを保存して閉じます。
  5. アプリケーション サーバーを再起動します。
親トピック: Atlassian JIRA Agile との統合
関連タスク
フィルタを作成する
ローカル実行サーバー サービスを開始または停止する


CA Agile Central との統合

プロジェクト管理ツールである CA Agile Central を統合すると、Silk Central で要件として使用できるユーザー ストーリーを定義できます。次に、これらの要件をカバーするテストを Silk Central で作成します。作成したテストを CA Agile Central の該当するユーザー ストーリーに加えられた変更で更新するには、要件の同期をとります。

マッシュアップは Silk Central と同梱されており、Silk Central からのユーザー ストーリーに関連するテストカバレッジ情報を CA Agile Central で表示できます。Silk Central の各テストを CA Agile Central の 1 つ以上のユーザー ストーリーにリンクできます。テストをユーザー ストーリーにリンクするには、CA Agile Central の書式整形されたユーザー ストーリー ID 値を持つ属性を各テストに割り当てます。

次のユーザー ストーリーのプロパティは、常に CA Agile Central REST サービスから同期化されます。カスタム フィールドが統合の設定で指定されている場合、カスタム フィールドも同期化されます。これらのプロパティを使用して、ユーザー ストーリーのフィルタリングと分類に役立てることができます。
プロパティ
説明
Name
CA Agile Central でのユーザー ストーリーの名前。
CA Agile Central ID
CA Agile Central でのユーザー ストーリーの識別子。このプロパティは、Silk Central での要件の外部 ID です。
Description
CA Agile Central でのユーザー ストーリーの説明。
Iteration
ユーザー ストーリーが含まれている CA Agile Central のイテレーション。
Project
ユーザー ストーリーが含まれている CA Agile Central のプロジェクト。
Release
ユーザー ストーリーが含まれているプロジェクト リリース。
State
CA Agile Central でのユーザー ストーリーの進捗状態。以下の状態を利用できます。
  • Defined
  • In-Progress
  • Completed
  • Accepted
Plan Estimate (Story Points)
ユーザー ストーリーが完了するための CA Agile Central での見積もり時間。時間はストーリー ポイントで見積もられます。
  • CA Agile Central との統合を有効にする
    CA Agile Central との統合を有効にして要件の同期をとります。
  • CA Agile Central でカスタム HTML App を作成する
    HTML または JavaScript コードを使用して、ユーザー ストーリーに関連したテスト カバレッジ情報を表示する CA Agile Central のカスタム App を作成します。
  • CA Agile Central ユーザー ストーリーをテストへリンクする
    Silk Central で、CA Agile Central ユーザー ストーリーをテストにリンクします。
親トピック: 要件管理ツールとの統合


CA Agile Central との統合を有効にする

CA Agile Central との統合を有効にするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. インテグレーションを確立するプロジェクトを選択します。
  3. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  4. 要件管理 タブをクリックします。
  5. インテグレーションの新規作成 をクリックします。
    注: 統合ツールで要件を編集するだけでなく、Silk Central で作成、編集、削除することもできます。Silk Central の UI や Silk Central の Web サービスからの直接変更を許可するには、対応する ... による要件の作成、編集、削除を許可する チェック ボックスをオンにします。
    インテグレーションの新規作成 ダイアログ ボックスが開きます。
  6. リストから CA Agile Central を選択して、次へ をクリックします。 設定の編集 ダイアログ ボックスが開きます。
  7. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  8. URL を入力します。
  9. 有効な CA Agile Central の ユーザー名 と パスワード 資格情報を入力するか、有効な API キー を代わりに入力します。API キーは、ユーザー名とパスワードを使用せずに CA Agile Central サブスクリプション データにアクセスするために使用できます。 CA Agile Central API キーに関する情報は、『CA Agile Central Application Manager』ページを参照してください。
  10. 省略可能： インターネットへの直接アクセスが制限されている場合で、CA Agile Central REST サービスが内部ネットワークの範囲外のマシンに配置されている場合は、プロキシ ホスト と プロキシ ポート フィールドを使用して Silk Central が CA Agile Central に接続できるプロキシを指定します。
    注: プロキシを使用して CA Agile Central に接続するには、プロキシ ホスト と プロキシ ポート の両方のフィールドを入力する必要があります。
  11. 省略可能： カスタム フィールドを同期したい場合は、その名前を カスタム フィールド フィールドに入力します (コンマ区切り)。表示名ではなく、内部フィールド名を使用する必要があります。
  12. 接続のテスト をクリックし、入力したホストとユーザー情報が正しいかどうかを確認します。 設定が正しければ、接続のテスト に成功したことを示すメッセージが表示されます。OK をクリックして、先に進みます。
    注: 接続を確立できない場合は、システム管理者に問い合わせてください。
  13. OK をクリックします。
  14. 読み込み をクリックします。 プロジェクト リスト ボックスには、アクセスが許可されている CA Agile Central のすべてのワークスペースから、すべてのプロジェクトが表示されます。
  15. プロジェクト リスト ボックスで、Silk Central プロジェクトと統合する予定の外部プロジェクトを選択します。
  16. OK をクリックして、設定を保存します。
親トピック: CA Agile Central との統合


CA Agile Central でカスタム HTML App を作成する

HTML または JavaScript を使用して、ユーザー ストーリーに関連したテスト カバレッジ情報を表示する CA Agile Central のカスタム App を作成します。

カスタム HTML App を作成するには：

  1. CA Agile Central で、カスタム App の保存場所となるタブに移動します。
  2. Customize Page をクリックし、Add App をクリックします。 App Catalog が表示されます。
  3. Custom の下にある Custom HTML をクリックし、Add This App をクリックします。
  4. タイトルを入力し、Silk Central に切り替えます。
  5. メニューで ヘルプ > ツール をクリックします。
  6. CA Agile Central イテレーション ステータス マッシュアップ をクリックし、HTML コードをコピーします。
  7. CA Agile Central に戻り、HTML コードを HTML フィールドに貼り付けます。
  8. Silk Central 環境に合わせて、フィールドでスクリプトを設定します。
    • 有効なスクリプト ソース（<script type="text/javascript" src="http://localhost:19120/silkroot/script/sctm-toolkit.js"></script> など）が設定されているかどうかを確認します。
    • Silk Central の有効な URL（var SCTM_URL = "http://localhost:19120/" など）が設定されているかどうかを確認します。
    • 有効な Silk Central のプロジェクト ID（var SCTM_PROJECT_ID = 0 など）が設定されているかどうかを確認します。
    • 有効な属性名（var SCTM_ATTRIBUTE_FOR_RALLY_US = "rallyattr" など）が設定されているかどうかを確認します。
    • CA Agile Central で FormattedID の使用が有効（var USE_FORMATTED_ID = true）になっていることを確認します。
  9. 保存 をクリックします。 CA Agile Central でカスタム HTML App が作成されます。
親トピック: CA Agile Central との統合


CA Agile Central ユーザー ストーリーをテストへリンクする

CA Agile Central ユーザー ストーリーを Silk Central テストにリンクするには：

  1. Silk Central で、CA Agile Central ユーザー ストーリーのリンク先となるテストを含むプロジェクトを選択します。
  2. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  3. 属性 タブをクリックします。
  4. 属性の新規作成 をクリックします。 属性の新規作成 ダイアログ ボックスが表示されます。
  5. 名前 フィールドに rallyattr と入力します。
  6. テキスト を タイプ リストから選択します。
  7. OK をクリックして、新しい属性を作成します。
  8. CA Agile Central ユーザー ストーリーのリンク先となる各テストに、新しい属性を割り当てます。
  9. 各テストに対して、適切な CA Agile Central ユーザー ストーリーの FormattedID の値となる、属性の値を設定します。複数のストーリーを 1 つのテストに割り当てる場合は、ID をカンマで区切ります(間に空白は含めない)。例：US10,US12,US14。
親トピック: CA Agile Central との統合


Caliber との統合

このセクションでは、Caliber を Silk Central と統合する方法について説明します。

Caliber インテグレーションを設定する前に、Silk Central アプリケーション サーバーとフロントエンド サーバーに Caliber クライアントをインストールする必要があります。また、Caliber で MPX サポートが有効になっていることを確認してください。Caliber とのインテグレーションを設定するには、Caliber ログイン認証情報の定義が必要です。Silk Central と Caliber 間で要件を同期するときは常に、これらの認証情報が Silk Central へのログインに使用され、Silk Central ライセンスがチェックアウトされます。このライセンスは同期プロセスが完了するとすぐに解放されます。同期専用の Silk Central ユーザー（すべての Silk Central 要件統合で使用される）を作成することを推奨します。これにより単一の Caliber ライセンスのみが同期プロセスに対して使用されることが保証されます。

Silk Central の統合が現在サポートしている Caliber のバージョンは次の通りです： Caliber 11.4、11.5

注: Caliber のユーザー定義属性 複数選択ユーザー リスト および 複数選択グループ リスト は、リスト タイプではなく、Silk Central テキスト属性タイプにマップする必要があります。
  • Caliber との統合を有効にする
    Caliber との統合を有効にして要件の同期をとります。
  • Caliber インテグレーションのベースライン サポート
    Caliber インテグレーション用に現在のベースラインまたは既存のユーザー定義ベースラインを選択する方法について説明します。
  • Caliber でテスト割り当てを処理する
    Silk Central でのテスト割り当てが Caliber でどのように処理されるかについて説明します。
  • Caliber に統合されたプロジェクトをコピーする
    Caliber に統合されたプロジェクトをコピーするため、Caliber のベースラインを管理します。
  • Caliber に統合されたプロジェクトのベースラインを作成する
    Caliber に統合された Silk Central プロジェクトのベースラインを作成するため、Caliber ベースラインを管理します。
  • シナリオとシミュレーションからテストを生成する
    Caliber オブジェクトの シナリオ と シミュレーション からテストを生成します。
親トピック: 要件管理ツールとの統合


Caliber との統合を有効にする

Caliber との統合を有効にするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. インテグレーションを確立するプロジェクトを選択します。
  3. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  4. 要件管理 タブをクリックします。
  5. インテグレーションの新規作成 をクリックします。
    注: 統合ツールで要件を編集するだけでなく、Silk Central で作成、編集、削除することもできます。Silk Central の UI や Silk Central の Web サービスからの直接変更を許可するには、対応する ... による要件の作成、編集、削除を許可する チェック ボックスをオンにします。
    インテグレーションの新規作成 ダイアログ ボックスが開きます。
  6. リストから Caliber を選択して、次へ をクリックします。 設定の編集 ダイアログ ボックスが開きます。
  7. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  8. ホスト名 に、外部サーバーがインストールされているマシンの名前を入力します。
  9. ユーザー名 と パスワード に、要件管理サーバー用のユーザー名とパスワードをそれぞれ入力します。
  10. 接続のテスト をクリックし、入力したホストとユーザー情報が正しいかどうかを確認します。 設定が正しければ、接続のテスト に成功したことを示すメッセージが表示されます。OK をクリックして、先に進みます。
    注: 接続を確立できない場合は、システム管理者に問い合わせてください。
  11. OK をクリックします。
  12. プロジェクト リスト ボックスで、Silk Central プロジェクトと統合する予定の外部プロジェクトを選択します。 選択したプロジェクトで利用可能な要件タイプは、要件タイプ フィールドに自動的にインポートされます。選択したプロジェクトで利用可能なベースラインは、ベースライン フィールドに自動的にインポートされます。
  13. Silk Central プロジェクトと統合する外部プロジェクトから、ベースライン を選択します。 選択結果が 設定の編集 ダイアログ ボックスに表示されます。
  14. OK をクリックします。
  15. Silk Central プロジェクトに統合する外部プロジェクトから、要件タイプを 1 つ以上選択します。 複数の要件タイプを選択するには、Ctrl + クリック を使用します。
  16. OK をクリックして、設定を保存します。
親トピック: Caliber との統合


Caliber インテグレーションのベースライン サポート

Caliber インテグレーション用に現在のベースラインまたは既存のユーザー定義ベースラインを選択することができます。変更したベースライン要件を Silk Central にインポートできません。現在のベースラインにない要件を Caliber で変更できるのは、そのベースラインに使用されている要件のバージョンを変更する場合のみです。そのような変更内容は、同期化が手動で、あるいはスケジュールに従って実行されるときにのみ、Silk Central 要件内で更新されます。

ベースライン を Silk Central にインポートした後は、変更を加えることができます。設定済みのベースラインを別のユーザー定義ベースラインや現在のベースラインに変更することができます。このような変更を行うと、手動で、あるいはスケジュールに従ってベースラインの同期化を次回に実行したときに、Silk Central プロジェクトが更新され、要件の更新、作成、削除が必要に応じて行われます。ベースラインを変更すると、変更内容が次回に同期化を実行した後に有効になるというメッセージが表示されます。

親トピック: Caliber との統合


Caliber でテスト割り当てを処理する

割り当てられたテストは、Caliber で同期された要件のトレース (「トレース先」) として表示、管理、作成されます。

Silk Central の外部トレーサビリティは、Silk Central 管理者内で Caliber プロジェクトに対して有効になっている必要があり、同時に正しい Caliber プロジェクトが設定されている必要があります。 Caliber 管理者内の正しいプロジェクトの Silk Central 外部トレーサビリティの 編集 をクリックします。

プロジェクトが Silk Central プロジェクトと同期されているとき、同期された Silk Central 要件の割り当て済みテストは、Caliber 要件の追跡 (「追跡先」) として表示されます。 これらの Silk Central での割り当てを編集する場合、変更は Caliber でただちに反映されます。

親トピック: Caliber との統合


Caliber に統合されたプロジェクトをコピーする

Silk Central プロジェクトをコピーする際に Caliber のベースラインを管理するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 要件管理 タブをクリックします。
  3. 保存するベースラインが選択されていることを確認します。
    注: ベースラインが変更されている場合は、関連する Silk Central プロジェクトをコピーする前に、同期を実行してベースラインの変更内容で更新する必要があります。現在のベースライン以外のベースラインが選択されている場合にのみ、インテグレーション設定がコピーされます。現在のベースラインを選択されている場合は、インテグレーション設定を元のプロジェクトに残すか、コピー先のプロジェクトに移動するかを指定する必要があります。
  4. 保存するベースラインが選択されていない場合は、設定の編集 をクリックします。 設定の編集 ダイアログ ボックスが表示されます。
  5. プロジェクト名 フィールドの横にある 参照 をクリックします。 プロジェクトの参照 ダイアログ ボックスが表示されます。
  6. 保存するベースラインを選択して、選択を確定します。
  7. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  8. コピー元のプロジェクトの アクション 列で、 プロジェクトのコピー をクリックします。
    注: プロジェクトのコピーの詳細については、この『ヘルプ』の「管理」トピックを参照してください。
    プロジェクトのコピー ダイアログ ボックスが表示されます。
  9. 新規プロジェクトにコピーする項目を選択して、選択を確定します。
  10. 作業で継続して使用するベースラインを、Silk Central プロジェクトに適用します。
    注: プロジェクトのコピー後は、元のプロジェクトとコピーされたプロジェクトは同じになります。対応するベースラインを適用して、どちらで作業を継続するかを定義します。
親トピック: Caliber との統合


Caliber に統合されたプロジェクトのベースラインを作成する

Caliber に統合された Silk Central プロジェクトのベースラインを作成するには：

  1. Silk Central プロジェクトのベースラインを作成します。 新しいベースラインに対して Caliber の統合を有効にするかどうかを尋ねる Silk Central メッセージ ボックスが、処理中に表示されます。
  2. はい をクリックします。 新しいベースラインが作成されると、プロジェクトのベースライン化 - プロジェクト設定の適用 ダイアログ ボックスが表示されます。
  3. 編集 をクリックして、要件インテグレーションの設定を変更します。

    設定の編集 ダイアログ ボックスが開きます。

  4. プロジェクト名 フィールドの横にある 参照 をクリックします。 プロジェクトの参照 ダイアログ ボックスが表示されます。
  5. Caliber プロジェクト、ベースライン、および同期の要件タイプを選択します。
  6. OK をクリックして、プロジェクトの参照 ダイアログ ボックスを閉じます。
  7. OK をクリックして、設定の編集 ダイアログ ボックスを閉じます。
  8. 完了 をクリックして、プロジェクトのベースライン化 - プロジェクト設定の適用 ダイアログ ボックスを閉じます。
親トピック: Caliber との統合


シナリオとシミュレーションからテストを生成する

Caliber オブジェクトの シナリオ と シミュレーション からテストを生成します。

Caliber オブジェクトの シナリオ と シミュレーション からテストを生成するには：

  1. Caliber との統合を設定します。 詳細については、「Caliber との統合を有効にする」を参照してください。
  2. 要件 ツリーで、テストの生成元となる シナリオ または シミュレーション を選択します。
  3. プロパティ タブで、テストの生成 をクリックします。 テストの生成 ダイアログ ボックスが表示されます。
  4. Ctrl + クリック または Shift + クリック を使用して、生成するテストを選択します。
  5. すべて生成 をクリックしてすべてのテストを生成するか、選択項目の生成 をクリックして選択されたテストを生成します。 テスト ツリーが表示されます。
  6. 生成されたテストを追加するフォルダを選択します。
    注: 選択した追加先フォルダに既に存在するテストは、作成されず、更新されます。フォルダ内のどのテストも削除されません。
  7. OK をクリックします。
親トピック: Caliber との統合
関連タスク
ツール間で要件を同期する
Caliber との統合を有効にする


IBM Rational DOORS との統合

このセクションでは、IBM Rational DOORS を Silk Central と統合する方法について説明します。Silk Central18.5 は、IBM Rational DOORS のサポートを簡単に実現でき、DOORS のインストールをカスタマイズする必要はありません。ただし、Silk Central 15.5 以前からアップグレードする場合や、カスタマイズした dxl ファイルを使用している場合は、Silk Central のインストール フォルダにある lib\dxl フォルダのすべての dxl ファイルをカスタマイズした dxl ファイルで上書きする必要があります。

Silk Central の統合が現在サポートしている IBM Rational DOORS のバージョンは次の通りです： IBM Rational DOORS 9.5、9.6

  • IBM Rational DOORS との統合を有効にする
    IBM Rational DOORS との統合を有効にして要件の同期をとります。
親トピック: 要件管理ツールとの統合


IBM Rational DOORS との統合を有効にする

Silk Central と DOORS を統合するには、Silk Central のフロントエンド サーバー マシンで DOORS クライアントをインストールします。複数のフロントエンド サーバー マシンを使用している場合、DOORS との統合を設定するため、すべてのフロントエンド サーバーに DOORS クライアントをインストールする必要があります。

DOORS との統合を有効にするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. インテグレーションを確立するプロジェクトを選択します。
  3. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  4. 要件管理 タブをクリックします。
  5. インテグレーションの新規作成 をクリックします。
    注: 統合ツールで要件を編集するだけでなく、Silk Central で作成、編集、削除することもできます。Silk Central の UI や Silk Central の Web サービスからの直接変更を許可するには、対応する ... による要件の作成、編集、削除を許可する チェック ボックスをオンにします。
    インテグレーションの新規作成 ダイアログ ボックスが開きます。
  6. リストから IBM Rational DOORS を選択して、次へ をクリックします。 設定の編集 ダイアログ ボックスが開きます。
  7. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  8. RM サービスの URL フィールドに、Silk Central の DOORS 要件用 Web サービスの URL を入力します。 通常、正しい値がデフォルトで設定されます。例：http://MySCTMHost:19120/services/doorsrequirementsmanagement。
  9. ユーザー名 と パスワード に、要件管理サーバー用のユーザー名とパスワードをそれぞれ入力します。
  10. デフォルトの DOORS クライアント インストール パスが、DOORS インストール パス フィールドに表示されます。このパスが正しくない場合は、フロントエンド サーバー ディレクトリ構造内の正しい場所を入力します。
  11. 接続のテスト をクリックし、入力したホストとユーザー情報が正しいかどうかを確認します。 設定が正しければ、接続のテスト に成功したことを示すメッセージが表示されます。OK をクリックして、先に進みます。
    注: 接続を確立できない場合は、システム管理者に問い合わせてください。
  12. プロジェクト名 フィールドの横にある 参照 をクリックして、要件タイプの参照 ダイアログ ボックスを開きます。プロジェクト フィールドで、Silk Central プロジェクトと同期する外部プロジェクトを選択します。

    選択したプロジェクトで利用可能な要件タイプは、要件タイプ フィールドに自動的にインポートされます。同期する要件タイプを選択し、OK をクリックします。複数の要件タイプを選択するには、Ctrl + クリック を使用します。

    これで、選択結果が 設定の編集 ダイアログ ボックスに表示されます。
  13. OK をクリックして、設定を保存します。
    注意:
    DOORS アプリケーション オブジェクトは通信に使用され、このオブジェクトがログイン データをサポートしておらず、DOORS クライアントの起動を必要とするため、Silk Central は、各 DOORS クライアント プロセスを、提供されたログイン データと共に起動し、それに続くすべてのアプリケーション オブジェクトに同じデータを使用します。このため、一度に 1 セットの DOORS ログイン認証情報のみが通信でサポートされます。ユーザーが同じ DOORS 認証情報をすべての構成に対して使用することを推奨します。これにより、フロントエンド サーバー上から、すべてのプロジェクトに対して一度に統合を実行できます。2 セット目の認証情報を使用する場合、最初の認証セットを利用したセッションがすべてタイムアウトしてはじめて 2 セット目が有効になります。
親トピック: IBM Rational DOORS との統合


IBM Rational DOORS Next Generation との統合

このセクションでは、Silk Central を IBM Rational DOORS Next Generation と統合する方法について説明します。Silk Central 18.5 は、IBM Rational DOORS Next Generation のサポートを簡単に実現でき、DOORS のインストールをカスタマイズする必要はありません。
注: DOORS コレクション成果物である モジュール と コレクション 自身を除く、プロジェクトのすべての成果物が同期化されます。

Silk Central の統合が現在サポートしている IBM Rational DOORS Next Generation のバージョンは次の通りです：IBM Rational DOORS Next Generation 6.0

  • IBM Rational DOORS Next Generation との統合を有効にする
    IBM Rational DOORS Next Generation との統合を有効にして要件の同期をとります。
親トピック: 要件管理ツールとの統合


IBM Rational DOORS Next Generation との統合を有効にする

IBM Rational DOORS Next Generation との統合を有効にするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. インテグレーションを確立するプロジェクトを選択します。
  3. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  4. 要件管理 タブをクリックします。
  5. インテグレーションの新規作成 をクリックします。
    注: 統合ツールで要件を編集するだけでなく、Silk Central で作成、編集、削除することもできます。Silk Central の UI や Silk Central の Web サービスからの直接変更を許可するには、対応する ... による要件の作成、編集、削除を許可する チェック ボックスをオンにします。
    インテグレーションの新規作成 ダイアログ ボックスが開きます。
  6. リストから IBM Rational DOORS Next Generation を選択して、次へ をクリックします。 設定の編集 ダイアログ ボックスが開きます。
  7. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  8. DOORS Next Generation URL フィールドに、IBM Rational DOORS Next Generation サーバーの完全修飾 URL を入力します（https://MyDOORSHost.MyDomain.com:9443/rm など）。
  9. Authentication URL フィールドに、IBM Rational Jazz Team Server の完全修飾 URL を入力します（https://MyDOORSHost.MyDomain.com:9443/jts など）。
    注: 新しい IBM Rational Authentication Server を使用した認証はサポートしていません。 IBM Rational Jazz Team Server だけがサポートされます。
  10. Username と Password に、IBM Rational DOORS Next Generation サーバー用のユーザー名とパスワードをそれぞれ入力します。
  11. 接続のテスト をクリックし、入力したホストとユーザー情報が正しいかどうかを確認します。 設定が正しければ、接続のテスト に成功したことを示すメッセージが表示されます。OK をクリックして、先に進みます。
    注: 接続を確立できない場合は、システム管理者に問い合わせてください。
  12. プロジェクト名 の隣にある 読み込み をクリックして、利用可能な DOORS プロジェクトをリストに読み込ませます。Silk Central プロジェクトと同期する外部プロジェクトを選択します。
  13. OK をクリックして、設定を保存します。
親トピック: IBM Rational DOORS Next Generation との統合


IBM Rational RequisitePro との統合

このセクションのトピックでは、IBM Rational RequisitePro と Silk Central の統合について説明します。

また、IBM Rational RequisitePro 統合を構成するには、Silk Central フロントエンド サーバーに IBM Rational RequisitePro クライアントをインストールする必要があります。

Silk Central の統合が現在サポートしている IBM Rational RequisitePro のバージョンは次の通りです：IBM Rational RequisitePro 7.1.3、7.1.4

  • IBM Rational RequisitePro との統合を有効にする
    IBM Rational RequisitePro との統合を有効にして要件の同期をとります。
親トピック: 要件管理ツールとの統合


IBM Rational RequisitePro との統合を有効にする

注: プロジェクトごとに 1 つの IBM Rational RequisitePro との統合を設定できます。

IBM Rational RequisitePro との統合を有効にするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. インテグレーションを確立するプロジェクトを選択します。
  3. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  4. 要件管理 タブをクリックします。
  5. インテグレーションの新規作成 をクリックします。
    注: 統合ツールで要件を編集するだけでなく、Silk Central で作成、編集、削除することもできます。Silk Central の UI や Silk Central の Web サービスからの直接変更を許可するには、対応する ... による要件の作成、編集、削除を許可する チェック ボックスをオンにします。
    インテグレーションの新規作成 ダイアログ ボックスが開きます。
  6. リストから IBM Rational RequisitePro を選択して、次へ をクリックします。 設定の編集 ダイアログ ボックスが開きます。
  7. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  8. プロジェクト パス (UNC) に、外部サーバーがインストールされているマシンへの UNC プロジェクト パスを入力します。
  9. UNC ユーザー名 と UNC パスワード に、外部サーバーがインストールされているマシンの UNC ユーザー名と UNC パスワードをそれぞれ入力します。
  10. ユーザー名 と パスワード に、要件管理サーバー用のユーザー名とパスワードをそれぞれ入力します。
  11. 接続のテスト をクリックし、入力したホストとユーザー情報が正しいかどうかを確認します。 設定が正しければ、接続のテスト に成功したことを示すメッセージが表示されます。OK をクリックして、先に進みます。
    注: 接続を確立できない場合は、システム管理者に問い合わせてください。
  12. パッケージと要件タイプの編集 をクリックします。

    選択結果が 設定の編集 ダイアログに表示されます。

    注: 同期されるのは、明示的に選択されたパッケージの要件だけです。親パッケージを選択しても、その親の子パッケージは選択されません。
    パッケージと要件タイプの参照 ダイアログ ボックスが開きます。選択したプロジェクトで利用可能なパッケージと要件タイプは、パッケージ リスト ボックスと 要件タイプ リスト ボックスに自動的にインポートされます。
  13. パッケージ リスト ボックスで、Silk Central プロジェクトと統合する外部プロジェクトから、パッケージを 1 つ以上選択します。 複数のパッケージを選択するには、Ctrl + クリック を使用します。
  14. 要件タイプ リスト ボックスで、Silk Central プロジェクトと統合する外部プロジェクトから、要件タイプを 1 つ以上選択します。 複数の要件タイプを選択するには、Ctrl + クリック を使用します。
  15. OK をクリックします。 パッケージと要件タイプの参照 ダイアログ ボックスが閉じます。
  16. OK をクリックして、設定を保存します。
親トピック: IBM Rational RequisitePro との統合


SAP Solution Manager との統合

SAP Solution Manager プラグインをご購入の場合は、営業担当者まで連絡ください。

SAP Solution Manager は、分散システム、ソリューションの展開のカバー、操作、継続的改善に対する技術サポートを行いやすくします。SAP Solution Manager は、ツール、コンテンツ、および SAP への直接アクセスを組み合わせて、ソリューションの信頼性を向上し、総所有コストを低下する、集中型の堅牢なアプリケーション管理ソリューションです。SAP Solution Manager の詳細については、SAP Solution Manager のドキュメントを参照してください。

Silk Central と SAP Solution Manager 間の統合を使用すると、Silk Central の要件と問題として、SAP Solution Manager のビジネス プロセスとインシデントを処理できます。

  • SAP Solution Manager との統合のシステム要件
    SAP Solution Manager 統合プラグインのシステム要件について説明します。
  • SAP Solution Manager を設定する
    Silk Central との統合で SAP Solution Manager を設定するための情報を入手できる場所について説明します。
  • SAP Solution Manager の問題追跡プロファイルを追加する
    SAP Solution Manager の問題追跡プロファイルを構成する方法について説明します。
  • SAP Solution Manager との要件インテグレーションを有効にする
    SAP Solution Manager で要件インテグレーションを有効にする方法について説明します。
親トピック: 要件管理ツールとの統合
親トピック: 問題追跡プロファイル統合


SAP Solution Manager との統合のシステム要件

SAP Solution Manager 統合プラグインのシステム要件を以下に示します。

  • Silk Central 12.1 以降
  • SAP Solution Manager 7.1
  • Silk Central Integration Hub for SAP Solution Manager は、SAP Solution Manager にインストールする必要があります。
親トピック: SAP Solution Manager との統合


SAP Solution Manager を設定する

Silk Central との統合を有効にするために SAP Solution Manager を設定します。

詳細については、SAP Solution Manager プラグインに含まれている Configuration_Guide_SilkCentral_Integration_Hub_for_SAP.pdf と User_Guide_SilkCentral_Integration_Hub_for_SAP.pdf を参照してください。

この統合が SAP Solution Manager から Silk Central への有効なリンクを取得するには、Silk Central のフロントエンド サーバー マシンに有効な完全修飾名が付けられている必要があります。

親トピック: SAP Solution Manager との統合


SAP Solution Manager の問題追跡プロファイルを追加する

SAP Solution Manager の問題追跡プロファイルを追加するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 問題追跡 タブをクリックします。 問題追跡 ページに、システムで作成されているすべての問題追跡プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、問題追跡プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. 新しいプロファイルの 説明 を入力します。
  6. SAP Solution Manager を タイプ リスト ボックスから選択します。
  7. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  8. SAP Solution Manager の Z-SCTM_ADAPTER Web サービスの URL を入力します。
  9. プロジェクトの読み込み をクリックすると、サーバーからすべてのプロジェクトがロードされ、プロジェクト リスト ボックスに表示されます。プロジェクト リスト ボックスからプロジェクトを選択します。
  10. デフォルト インシデントの種類の読み込み をクリックしてすべての使用可能なインシデント タイプをロードし、デフォルト インシデントの種類 リスト ボックスを表示します。
  11. デフォルト インシデントの種類 リスト ボックスからインシデント タイプを選択します。 SAP Solution Manager の既存インシデントへのリンクを作成する場合で、インシデント タイプを指定しない場合、このタイプが使用されます。
  12. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  13. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: SAP Solution Manager との統合


SAP Solution Manager との要件インテグレーションを有効にする

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. インテグレーションを確立するプロジェクトを選択します。
  3. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  4. 要件管理 タブをクリックします。
  5. SAP Solution Manager セクションで、設定 をクリックします。
  6. SAP Solution Manager の Z_SCTM_ADAPTER Web サービスの URL を入力します。
  7. ユーザー名 と パスワード を入力します。
  8. 接続のテスト をクリックし、ホストとユーザー情報が正しいことを確認します。 設定が正しければ、接続のテストに成功しました というメッセージが表示されます。
  9. 読み込み をクリックして、使用可能なすべてのプロジェクトを読み込み、該当するものを選択します。
  10. 省略可能：未割り当て要件の作成を有効にする チェック ボックスをオンにして、マップされていない要件を、インテグレーションが設定された Silk Central プロジェクトで作成および編集できるようにします。
  11. OK をクリックして、ダイアログ ボックスを確認し、閉じます。
親トピック: SAP Solution Manager との統合


外部プロパティで作業する

このセクションでは、Silk Central における外部プロパティで作業する方法について説明します。

  • 外部プロパティを編集する
    外部プロパティを編集します。
  • 外部プロパティを表示する
    外部プロパティを表示します。
親トピック: 要件管理ツールとの統合


外部プロパティを編集する

外部プロパティを編集するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 外部プロパティを編集する要件を選択します。
  3. プロパティ タブをクリックします。 プロパティ ページには、選択したツリー要素のプロパティが表示されます。
  4. 外部プロパティの編集 をクリックします。 外部プロパティの編集 ダイアログ ボックスが表示されます。 この外部要件のすべてのプロパティが表示されます。 必要なプロパティをすべて編集します。
    注: このダイアログ ボックスで編集可能なプロパティには、入力フィールドとコントロールが示され、それを使用してプロパティを編集できます。 プロパティにマッピング規則が存在する場合は、そのプロパティの末尾にアスタリスク（*）が表示されます。
  5. 変更を保存してダイアログ ボックスを閉じるには、OK をクリックします。
親トピック: 外部プロパティで作業する


外部プロパティを表示する

外部プロパティを表示するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件を選択します。
  3. プロパティ タブをクリックします。 プロパティ ページには、選択したツリー要素のプロパティが表示されます。
  4. 外部プロパティの表示 をクリックします。 外部プロパティの表示 ダイアログ ボックスが表示されます。 この外部要件のすべてのプロパティが表示されます。
  5. ダイアログ ボックスを閉じます。
親トピック: 外部プロパティで作業する


プロパティ マッピングを編集する

プロパティ マッピング機能を利用すると、Silk Central と外部要件管理ツールとの間のプロパティ フィールドをマップできます。たとえば、User という Silk Central 内のカスタム要件プロパティを User_ID という Caliber 内のカスタム プロパティと等価にすることができます。プロパティ マッピング機能によって、要件のアップロードやインポートの際に、プロジェクト間で要件プロパティ フィールドが正確にインポートされるようになります。要求のタイプが複数ある場合は、それぞれのタイプごとにマップする必要があります。

注: プロパティ マッピング機能を使用しないと、要件の名前と説明だけがマップされます。

プロパティ マッピングを編集するには：

注: 論理値のプロパティを同期する場合は、次のマッピングが使用されます。Silk Central では論理データ型はサポートされていないため、次の 2 つのリスト項目を持つ単一の選択リストを作成する必要があります。
  • 名前 = はい、加重数値 = 1
  • 名前 = いいえ、加重数値 = 0
注: リストをマップする場合は、両方の製品について、要件プロパティの各リスト項目に同じ名前のオプションが存在する必要があります。名前では、大文字/小文字が区別されます。
  1. プロジェクトを選択します。
  2. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  3. 要件管理 タブをクリックします。
  4. 設定されている外部ツール用の プロパティ マッピングの編集 をクリックします。 プロパティ マッピングの編集 ダイアログ ボックスが開きます。
  5. 要件タイプ リスト ボックスから外部要件のタイプを選択します。そのタイプのカスタム要件が、すべて下の選択ボックスに表示されます。
  6. マッピングを設定するカスタム要件プロパティを選択します。
  7. 右側のリスト ボックスから、選択された外部カスタム プロパティへのマッピングを作成する Silk Central カスタム プロパティを選択します。
  8. マッピングの追加 をクリックして、要件をマップします。 その結果が、カスタム プロパティ マッピング ボックスに表示されます。
  9. システム プロパティ マッピング ボックスには、要件名と説明に対する設定済みのマッピングが 2 つ表示されます。これらを削除することはできません。
  10. OK をクリックして、変更を保存します。
親トピック: 要件管理ツールとの統合


プロパティ-マッピング値ペアを削除する

プロパティ-マッピング値ペアを削除するには：

  1. プロジェクトを選択します。
  2. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  3. 要件管理 タブをクリックします。
  4. 設定されている外部ツール用の プロパティ マッピングの編集 をクリックします。 プロパティ マッピングの編集 ダイアログ ボックスが開きます。
  5. カスタム プロパティ マッピング 選択ボックスで、プロパティ-マッピング値ペアを選択します。
  6. マッピングの削除 をクリックします。
  7. OK をクリックして、変更を保存します。
親トピック: 要件管理ツールとの統合


要件管理のインテグレーション設定を無効にする

要件管理のインテグレーション設定を無効にするには：

  1. プロジェクトを選択します。
  2. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  3. 要件管理 タブをクリックします。
  4. インテグレーションを無効にする要件管理ツールの 設定の無効化 ボタンをクリックします。
すべてのインテグレーション データと機能が無効になります。ただし、プロジェクトから削除されるわけではありません。
親トピック: 要件管理ツールとの統合


要件管理のインテグレーション設定を削除する

要件管理のインテグレーションを削除するには：

  1. プロジェクトを選択します。
  2. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  3. 要件管理 タブをクリックします。
  4. インテグレーションを削除する要件管理ツールの 設定の削除 をクリックします。 このボタンは、設定が無効になっている場合にのみ有効になります。 外部関連付けの削除 ダイアログ ボックスが表示されます。
  5. はい をクリックします。
すべての関連データがデータベースから削除されます。
親トピック: 要件管理ツールとの統合


フィルタ

フィルタは、こまごました無関係な情報を除外しつつ必要な情報を正確に見つけるための効率的な手段となります。フィルタを利用すると、自分のニーズに関係のある要素だけを強調表示し、テストの要素と実行計画をすばやくソートすることができます。グローバル フィルタを定義することで、Silk Central 全体を通して利用可能な複雑なフィルタ条件を作成できるので、リストをフィルタリングする必要があるたびにフィルタ条件を定義しなくても済みます。

独自のニーズに応じて、新規フィルタの作成、既存フィルタの編集、フィルタの選択、フィルタの削除、フィルタリングの無効化をプロジェクト レベルで行うことができます。プロジェクトには、デフォルト フィルタは含まれません。フィルタへのアクセスおよび編集は、Silk Central ユニットのツールバーおよび プロジェクト設定 ユニットから行うことができます。

注: フィルタはレポートには適用されません。最近の変更点 フィルタを使用すると、ユーザーが最後に変更を承認してから他のユーザーがプロジェクト全体でテストに対して行った変更や追加の内容を、表示したり承認することができます。テスト 領域にある 変更点のみ表示/すべて表示 トグル ボタンと 承認 ボタンは、他のユーザーがどのような変更を行ったかを調べるのに役立ちます。システム管理者は、テストの設定が変更されたときにそれを警告するように、電子メール通知を設定することができます。電子メールによる警告には、最近の変更点を直接表示できるリンクが付いています。
  • フィルタを作成する
    フィルタを作成して、表示情報を制限します。
  • 詳細フィルタを作成する
    詳細カスタム フィルタを作成する方法について説明します。
  • フィルタを編集する
    フィルタを編集して、表示情報を制限します。
  • フィルタをコピーする
    フィルタをコピーし、編集して、コピーから新しいフィルタを作成します。
  • フィルタを削除する
    情報サブセットが不要になった場合に、フィルタを削除します。
  • グローバル フィルタの詳細
    グローバル フィルタに関する詳細について説明します。
  • 最近の変更点
    ユーザーが最後に変更を承認してから他のユーザーがプロジェクト全体で要件やテスト、実行計画に対して行った変更や追加の内容を、効率的に表示したり承認することができます。
  • フィルタを適用する
    選択したツリーにカスタム フィルタを適用します。
親トピック: 要件と統合を設定する
親トピック: テストと統合を設定する
親トピック: 実行計画、フォルダ、構成スイートを管理する
親トピック: プロジェクト設定


フィルタを作成する

フィルタを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. フィルタ タブをクリックして、利用可能なフィルタのリストを表示します。
  3. フィルタの新規作成 をクリックします。 フィルタの新規作成 ダイアログ ボックスが表示されます。
  4. 新しいフィルタの名前を 名前 フィールドに入力します。 フィルタが選択可能なときに、この名前がリスト ボックスに表示されることになります。
  5. リストから カテゴリ を選択して、Silk Central の 要件、テスト、または 実行計画 領域でフィルタを使用できるようにします。
  6. 省略可能： 新しいフィルタの説明を 説明 フィールドに入力します。
  7. 省略可能：他のユーザーに対してフィルタを表示できるようにするには、他のユーザーが表示可能 チェック ボックスをオンにします。
  8. 省略可能：他のユーザーがフィルタを編集できるようにするには、他のユーザーが編集可能 チェック ボックスをオンにします。
    注: 他のユーザーが表示可能 および 他のユーザーが編集可能 のチェックがオンになっている場合、フィルタは公開されます。非公開 (プライベート) フィルタを削除するには、フィルタの所有者となるか、他のユーザーの非公開フィルタの削除 許可が必要となります。
  9. 選択基準 リストからフィルタの基準となるカテゴリを選択します。選択可能なカテゴリは、選択した全般的なフィルタ カテゴリによって決まります。
    注: 入れ子テスト フィルタ や 入れ子要件フィルタ を選択することで、フィルタを組み合わせることができます。これらのカテゴリの 1 つを選択すると、既存のフィルタを新しいフィルタに含めることができます。
  10. フィルタの プロパティ、演算子、および 値 を、それぞれのリストから選択します。
    プロパティ
    選択可能なプロパティは、前のステップで選択したフィルタ カテゴリによって決まります。フィルタ設定の定義対象となるプロパティを指定します。属性をカテゴリとして選択した場合は、プロパティ リストにはクエリ対象のカスタム属性が含まれています。
    演算子
    フィルタ演算子を指定します。演算子は、選択したプロパティ タイプによって決まります。たとえば、文字列フィールド タイプのプロパティを選択した場合、選択可能な演算子は以下のとおりです。
    演算子 | 説明
    = 文字列は定義済みの値と等しい
    不一致 | 文字列は定義済みの値と異なる
    含む | 文字列には定義済みの値が含まれる
    含まない | 文字列には定義済みの値が含まれない
    値
    フィルタ処理を適用する値を入力します。選択したプロパティ タイプによって、値は、フィールドに入力できる文字列か、リスト ボックスから選択できる定義済み値の集合のどちらかになります。文字列で利用できるワイルドカードは、* (任意の数の文字) および ?(必ず 1 つの文字に一致) です。
  11. 省略可能：新しいフィルタに複数の選択条件を追加する場合は、1 つ追加 をクリックします。この手順を繰り返して、新しい選択条件を定義します。
    注: 複数の選択条件を定義する場合は、既存の条件に加えてさらに条件を満たす必要があるのかどうか (AND 関係)、あるいは選択条件のいずれかが満たされたときにフィルタリングの結果が真になるのか (OR 関係) を指定する必要があります。AND か OR のいずれかを選択して、選択条件間の関係を定義します。入れ子になった AND/OR 関係は定義できません。
  12. 省略可能：選択条件を減らすには 1 つ削除 をクリックします。その結果、最後に追加された選択条件が削除されます。
  13. OK をクリックして新しいフィルタを保存します。この操作を中止する場合は、キャンセル をクリックします。
親トピック: フィルタ


詳細フィルタを作成する

詳細カスタム フィルタを利用すると、サンプル フィルタを組み合わせて、複数のフィルタ条件を同時に適用する複雑なフィルタを作成できます。

詳細カスタム フィルタを作成するには：

  1. メニューで、要件、テスト、または 実行計画 の中の適切な領域を選択します。
  2. ツールバーで [image] (フィルタの新規作成) をクリックします。 フィルタの新規作成 ダイアログ ボックスが表示されます。
  3. 必要に応じて、詳細 をクリックしてダイアログ ボックス全体を表示します。
  4. 1 つ追加 をクリックして、2 つ目のフィルタ パラメータ セットを定義するためのフィールドを表示します。
  5. フィルタ クエリの適用に使用する論理演算子を選択します。 たとえば、論理演算子 AND でフィルタされる要素は両方の条件セットを満たす必要があり、論理演算子 OR でフィルタされる要素は条件セットの一方または両方を満たす必要があります。
  6. フィルタ パラメータ文字列を削除するには、 削除 をクリックします。
  7. 追加のフィルタ パラメータ フィールドを表示して、フィルタ クエリを追加するには、1 つ追加 をクリックします。 余分なフィルタ パラメータ セットを削除するには、1 つ削除 をクリックします。
親トピック: フィルタ


フィルタを編集する

フィルタを編集するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. フィルタ タブをクリックして、利用可能なフィルタのリストを表示します。
  3. 編集対象のフィルタの名前をクリックします。 フィルタの編集 ダイアログ ボックスが表示されます。
  4. プロファイルの 名前 と 説明 を編集します。
  5. 選択基準 リストからフィルタの基準となるカテゴリを選択します。選択可能なカテゴリは、選択した全般的なフィルタ カテゴリによって決まります。
    注: 入れ子テスト フィルタ や 入れ子要件フィルタ を選択することで、フィルタを組み合わせることができます。これらのカテゴリの 1 つを選択すると、既存のフィルタを新しいフィルタに含めることができます。
  6. フィルタの プロパティ、演算子、および 値 を、それぞれのリストから選択します。
    プロパティ
    選択可能なプロパティは、前のステップで選択したフィルタ カテゴリによって決まります。フィルタ設定の定義対象となるプロパティを指定します。属性をカテゴリとして選択した場合は、プロパティ リストにはクエリ対象のカスタム属性が含まれています。
    演算子
    フィルタ演算子を指定します。演算子は、選択したプロパティ タイプによって決まります。たとえば、文字列フィールド タイプのプロパティを選択した場合、選択可能な演算子は以下のとおりです。
    演算子 | 説明
    = 文字列は定義済みの値と等しい
    不一致 | 文字列は定義済みの値と異なる
    含む | 文字列には定義済みの値が含まれる
    含まない | 文字列には定義済みの値が含まれない
    値
    フィルタ処理を適用する値を入力します。選択したプロパティ タイプによって、値は、フィールドに入力できる文字列か、リスト ボックスから選択できる定義済み値の集合のどちらかになります。文字列で利用できるワイルドカードは、* (任意の数の文字) および ?(必ず 1 つの文字に一致) です。
  7. OK をクリックして、編集したフィルタ定義を保存します。
親トピック: フィルタ


フィルタをコピーする

既存のフィルタをコピーし、設定を変更して新しいフィルタを作成します。

  1. メニューで、要件、テスト、または 実行計画 の中の適切な領域を選択します。
  2. 選択した領域のツールバーで、リスト ボックスからフィルタを選択します。
  3. フィルタのコピー をクリックします。 フィルタの編集 ダイアログ ボックスが開き、元のフィルタの設定が表示されます。
  4. フィルタのプロパティを編集して、OK をクリックします。
親トピック: フィルタ


フィルタを削除する

フィルタを削除するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. フィルタ タブをクリックして、利用可能なフィルタのリストを表示します。
  3. 削除するフィルタの フィルタの削除 をクリックします。 削除の確認を求めるメッセージが確認ダイアログ ボックスに表示されます。
  4. はい をクリックすると選択したフィルタは削除され、いいえ をクリックすると削除は中止されます。 はい をクリックした場合は、フィルタ リストに戻ります。削除したフィルタは表示されません。
親トピック: フィルタ


グローバル フィルタの詳細

グローバル フィルタを使用すると、Silk Central 領域で要素をすばやくソートして、自分のニーズに関係のあるものだけを強調表示することができます。

グローバル フィルタの詳細を表示するには、メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 > フィルタ をクリックし、フィルタの名前をクリックします。

新しいフィルタを特定のどの Silk Central 領域で使用できるかは、全般的なフィルタ カテゴリを選択することで定義されます。

各グローバル フィルタでは、プロパティ、演算子、値が、それぞれのリスト ボックスで指定されている必要があります。

プロパティ
利用可能なプロパティ（そのフィルタ カテゴリによって変わる）。これは、フィルタ設定の定義対象となるプロパティを指定します。属性カテゴリを選択した場合は、プロパティ リストにクエリ対象のカスタム属性が含まれます。
演算子
フィルタ演算子を指定します。演算子はプロパティのタイプによって変わります。たとえば、文字列フィールド タイプのプロパティを選択した場合、選択可能な演算子は、=（定義済みの値と等しい）、不一致（定義済みの値と異なる）、含む（文字列の中に定義済みの値を含んでいる）、含まない（文字列の中に定義済みの値を含んでいない）となります。
値
フィルタ処理を適用する値。選択したプロパティ タイプによって、値は、フィールドに入力できる文字列か、リスト ボックスから選択できる定義済み値の集合のどちらかになります。
親トピック: フィルタ


最近の変更点

最近の変更点 フィルタを使用すると、ユーザーが最後に変更を承認してから他のユーザーがプロジェクト全体で要件やテスト、実行計画に対して行った変更や追加の内容を、効率的に表示したり承認することができます。

ツールバーの右端にある 変更点のみ表示/すべて表示 トグル ボタン と 承認 の 2 つのボタンは、他のユーザーがどのような変更を行ったかを調べるのに役立ちます。

注: システム管理者は、テストの設定が変更されたときにそれを警告するように、電子メール通知を設定することができます。 電子メールによる警告には、最近の変更点を直接表示できるリンクが付いています。
親トピック: フィルタ


フィルタを適用する

カスタム フィルタを作成して保存すると、そのフィルタを選択したツリーに適用できます。 カスタム フィルタは、要件、テスト、実行計画に対して適用できます。 適用されたフィルタの条件に一致する要素だけが、ツリーに表示されます。

注: フィルタで選出された要件は読み取り専用フォームで返され、編集できません。 フィルタで選出された要件に対しては プロパティの編集 ボタンが無効になります。

保存されているフィルタを適用するには：

  1. メニューで、要件、テスト、または 実行計画 の中の適切な領域を選択します。
  2. ツールバーの フィルタ リスト ボックスから、適用するフィルタを選択します。
  3. フィルタの条件に一致するすべての要素が表示されます。
    注: フィルタ処理を削除して、すべての要素を表示するには、ツールバーの フィルタ リスト ボックスから <フィルタなし> を選択します。
親トピック: フィルタ


変更通知

Silk Central では、要件やテストが他のユーザーによって変更されたときに電子メールでユーザーに通知することができます。各ユーザーは、変更通知を有効にするかどうかを選択できます。通知を有効すると、最初の確認を実行できます。 その後、最後の確認以降に発生した変更を確認することができます。通知が大量に送られるのを回避するため、変更が 1 つ行われると、最後の確認以降、他のユーザーがどれほど変更を行ったかにかかわらず、ユーザーには電子メール警告が 1 通だけ送信されます。電子メールによる警告には、最近の変更点を直接表示できるリンクが付いています。

要件やテストの変更通知を有効にする前に、Silk Central のユーザー設定で電子メール アドレスを構成する必要があります。

注: 変更通知が機能するのは、電子メール サーバーが管理者によって設定されている場合だけです。変更通知が有効になっていない場合は、Silk Central 管理者に連絡してください。
  • 変更通知を有効にする
    要件やテストが他のユーザーによって変更されたときに電子メール通知を受信するため、変更通知を有効にします。
  • 変更通知を無効にする
    要件やテストが他のユーザーによって変更されたときに電子メール通知を受信しないようにするため、変更通知を無効にします。
  • 変更通知のトリガとなる変更
    変更通知のトリガとなる変更のリストを示します。
  • [通知] ページ
    アクティブ プロジェクトの通知イベントが一覧表示されます。
親トピック: 要件と統合を設定する
親トピック: テストと統合を設定する
親トピック: プロジェクト設定


変更通知を有効にする

変更通知を有効にするには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 通知 タブをクリックします。
  3. メール通知の設定 をクリックして、メール通知の設定 ダイアログ ボックスを開きます。
  4. 現在選択されているプロジェクトで要件が変更されたときに電子メールによる通知を受ける場合は、要件の変更 チェック ボックスをオンにします。
  5. 現在選択されているプロジェクトでテストが変更されたときに電子メールによる通知を受ける場合は、テストの変更 チェック ボックスをオンにします。
  6. 通知設定を保存する場合は OK をクリックし、変更内容を保存せずに操作を中止する場合は キャンセル をクリックします。
有効にした通知に加えられた変更に関して、電子メールで通知されます。
親トピック: 変更通知


変更通知を無効にする

変更通知を無効にするには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 通知 タブをクリックします。
  3. メール通知の設定 をクリックして、メール通知の設定 ダイアログ ボックスを開きます。
  4. 現在選択されているプロジェクトで要件が変更されても電子メールによる通知を受けない場合は、要件の変更 チェック ボックスをオフにします。
  5. 現在選択されているプロジェクトでテストが変更されても電子メールによる通知を受けない場合は、テストの変更 チェック ボックスをオフにします。
  6. 通知設定を保存する場合は OK をクリックし、変更内容を保存せずに操作を中止する場合は キャンセル をクリックします。
親トピック: 変更通知


変更通知のトリガとなる変更

要件またはテストに変更が加えられたことを示す変更通知をアクティブにすると、ログアウト後に電子メールによる警告が送信されます。電子メールによる警告は、以下の 1 つまたは複数の設定が変更された場合に送信されます。
領域 変更
要件
  • 要件が作成または削除される。
  • 要件の名前または説明が編集される。
  • システム プロパティが編集される。
  • 要件に廃止マークが付けられる。
  • 要件が復元される。
  • テストが要件に割り当てられる、または削除される。
  • 要件のカスタム プロパティが作成、編集、または削除される。
テスト
  • コンテナが作成または編集される。
  • 製品が編集される。
  • ソース管理プロファイルが編集される。
  • "作業フォルダのクリア" が編集される。
  • ルート ノードが編集される。
  • カスタム データ ディレクトリが編集される。
  • インクルード ディレクトリが編集される。
  • 非表示テスト プロパティが編集される。
  • Silk Test Classic インターフェイスが編集される。
  • テスト フォルダが作成、編集、または削除される。
  • テストが作成、編集、または削除される。
  • 予定時間が編集される。
  • テスト ステップが追加または編集される。
親トピック: 変更通知


[通知] ページ

プロジェクト:<プロジェクト名> > プロジェクト設定 > 通知

通知 ページには、アクティブ プロジェクトの通知イベントが一覧表示されます。通知 ページには、通知イベントごとに以下の列が表示されます。

列 | 説明
通知イベント | アクティブ プロジェクトにセットアップされている通知イベントの名前。
ステータス | 通知イベントのステータス。[アクティブ] または [非アクティブ]。

各セクションの 設定... ボタンをクリックして、値を編集します。

電子メール

電子メール通知イベントが有効になっていると、指定された設定のいずれかが最初に変更された際に、電子メール通知がそのイベントを有効にしたユーザーに送られます。

注: 電子メール通知を受信するには、電子メール アドレスを指定する必要があります。

要件フラグ

内部要件と外部要件では、異なる通知設定を指定できます。デフォルトでは、要件フラグはすべて有効になっています。詳細については、「フラグ」を参照してください。

親トピック: 変更通知


要件を管理する

顧客と開発者間での技術的または非技術的な同意事項を規定したり保守するために、要件の追加や編集を行います。
  • 要件を作成する
    要件を Silk Centralで直接作成する方法および子要件がその親要件からどのようにプロパティを継承するかについて説明します。
  • 要件を編集する
    要件のプロパティを編集方法について説明します。
  • 要件に廃止マークを付ける
    要件が現在必要なくなっても削除しない場合には、要件に廃止マークを付けます。
  • 廃止された要件を回復する
    廃止された要件をアクティブ ステータスに変更して、再度使用します。
  • 廃止された要件を完全に削除する
    廃止された要件を再度アクティブにしない場合は、完全に削除します。
  • 要件レポート
    要件レポートは、開発中に達成すべき機能的な要件（互換性要件、GUI 要件、機能要件など）のステータスの詳細を示します。
  • カバレッジ
    テストで要件をカバーする方法について説明します。
  • フラグ
    フラグを使用する方法について説明します。
親トピック: 要件


要件を作成する

新しい要件を作成するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリーで、要件またはルート ノードを選択します。
  3. 同じ階層に新しい要件を作成する場合は、ツールバーの [image] (要件の新規作成) をクリックし、選択した要件の下の階層に作成する場合は、 [image] (子要件の新規作成) をクリックします。 要件の新規作成 ダイアログ ボックスが開きます。
  4. 名前 と 説明 フィールドに、要件の名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 省略可能： 親から継承 チェック ボックスをオフにします。この場合、子要件は親要件からプロパティを継承しません。デフォルトでは、すべてのチェック ボックスがオンになっています。
    注: プロパティ ページの 詳細ビュー および ドキュメント ビュー で、継承されたプロパティにはアスタリスク (*) がマークされます。
  6. リストで、優先度、リスク、および レビュー済み から適切なステータスを選択します。
  7. カスタム要件が定義されている場合は、レビュー済み リストの下に表示されます。該当するフィールドに、この要件と一緒に追跡するカスタム プロパティのデータを入力します。これは、継承したプロパティでは無効化されています。カスタム要件プロパティの作成、編集、および削除の詳細については、「カスタム要件プロパティ」を参照してください。
  8. 新しい要件の作成を完了するには：
    • OK をクリックして要件を作成し、ダイアログ ボックスを閉じます。
    • 適用して新しい要件へ をクリックすると、要件が作成され、別の要件のデータを入力するためにダイアログ ボックスは開いたままになります。
    • 適用して新しい子要件へ をクリックすると、要件が作成され、子要件のデータを入力するためにダイアログ ボックスは開いたままになります。
親トピック: 要件を管理する
関連概念
カスタム要件プロパティ


要件を編集する

要件のプロパティを編集するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリーで要件を選択します。
  3. ツールバーの [image] (編集) をクリックします。 または、要件を右クリックして 編集 をクリックするか、プロパティ タブをクリックして プロパティの編集 をクリックします。 要件の編集 ダイアログ ボックスが表示されます。
  4. 名前 と 説明 フィールドに、要件の名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 省略可能： 親から継承 チェック ボックスをオフにします。この場合、子要件は親要件からプロパティを継承しません。デフォルトでは、すべてのチェック ボックスがオンになっています。
    注: プロパティ ページの 詳細ビュー および ドキュメント ビュー で、継承されたプロパティにはアスタリスク (*) がマークされます。
  6. リストで、優先度、リスク、および レビュー済み から適切なステータスを選択します。
  7. カスタム要件が定義されている場合は、レビュー済み リストの下に表示されます。該当するフィールドに、この要件と一緒に追跡するカスタム プロパティのデータを入力します。これは、継承したプロパティでは無効化されています。カスタム要件プロパティの作成、編集、および削除の詳細については、「カスタム要件プロパティ」を参照してください。
  8. OK をクリックして、変更を保存します。
親トピック: 要件を管理する
関連概念
カスタム要件プロパティ


要件に廃止マークを付ける

要件を削除すると、それらの要件は完全に破棄されます。要件に廃止マークを付けることが適切な場合があります。廃止された要件は、非表示、表示、回復することができます。

要件に廃止マークを付けるには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリーで要件を選択します。
  3. ツールバーの 削除 (削除) をクリックするか、要件を右クリックして、削除 を選択します。 ダイアログ ボックスが表示されます。
  4. はい をクリックします。
    注: 完全に破棄 チェック ボックスは、デフォルトでオフになっています。
注: 廃止された要件は、要件 ツリーに斜体で表示されます。

廃止された要件を表示するには、要件 ツリーでいずれかの要件を右クリックし、廃止した要件の表示 をクリックします。

廃止された要件を非表示にするには、要件 ツリーでいずれかの要件を右クリックし、廃止した要件の非表示 をクリックします。

親トピック: 要件を管理する


廃止された要件を回復する

廃止された要件を回復するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 廃止された要件が表示されていない場合は、要件 ツリーでいずれかの要件を右クリックして、廃止した要件の表示 をクリックします。
  3. 要件 ツリーで廃止された要件を右クリックし、回復 をクリックします。
注: 廃止された要件は、要件 ツリーに斜体で表示されます。

廃止された要件を再度非表示にするには、要件 ツリーでいずれかの要件を右クリックし、廃止した要件の非表示 をクリックします。

親トピック: 要件を管理する


廃止された要件を完全に削除する

廃止した要件を完全に削除するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 廃止された要件が表示されていない場合は、要件 ツリーでいずれかの要件を右クリックして、廃止した要件の表示 をクリックします。
  3. 要件 ツリーで、廃止された要件を選択します。
  4. ツールバーの 削除 (削除) をクリックするか、要件を右クリックして、削除 を選択します。 ダイアログ ボックスが表示されます。
  5. はい をクリックすると、要件が完全に削除されます。
注: 廃止された要件は、要件 ツリーに斜体で表示されます。

廃止された要件を再度非表示にするには、要件 ツリーでいずれかの要件を右クリックし、廃止した要件の非表示 をクリックします。

親トピック: 要件を管理する


要件レポート

要件レポートは、開発中に達成すべき機能的な要件（互換性要件、GUI 要件、機能要件など）のステータスの詳細を示します。

要件は、信頼性、スケーラビリティ、パフォーマンスなどの製品管理の目的にも関係します。要件管理レポートは、開発期間中にシステム要件を満たしていることを確認するため、適切なテスト カバレッジが設定されているかを管理者が判断するのに役立ちます。レポートが HTML 形式のコンテンツを含む要件を参照するときには、そのコンテンツはレポート内でレンダリングされます。

  • ステータス レポート
    要件 領域で使用できるステータス レポートについて説明します。
  • 進捗レポート
    要件 領域で使用できる進捗レポートについて説明します。
  • 文書レポート
    要件で使用できる文書レポートについて説明します。
  • すべての関連する問題レポート
    要件に対して割り当てられたテストに関連する、すべての問題の詳細リストを表示します。
親トピック: 要件を管理する
親トピック: デフォルトのレポート


ステータス レポート

以下のステータス レポートは、要件 領域で使用できます。
要件ステータス概要
すべての要件を現在の要件カバレッジ別にまとめて表します。カバレッジは、[合格]、[失敗]、[未実行]、[未カバー] という 4 つのステータスで表現されます。
最上位要件カバレッジ
すべての最上位要件の一覧を表します。要件ごとに、子要件の数が、テストでカバーされているものとカバーされていないものに分けて表示されます。
優先度が 'X' より高い要件のステータス
優先度が指定値より高いすべての要件を現在の要件カバレッジ別に集計して表します。返される要件グループは Priority パラメータで限定されます。このパラメータは、データで考慮の対象となる最低の要件優先度を指定するものです。
要件影響度分析レポート
テストの詳細を、要件に関連付けられた実行計画にグループ化して表示します。このレポートを使用すると、ユーザーは、要件の変更によって影響を受ける可能性のあるテスト資産について把握することができます。レポートには、名前、ステータス、前回の実行日時、手動テスト担当者、予定時間、各テストの問題が含まれます。以下のステータスが使用されます。
合格
テストが合格しました。
失敗
テストが失敗しました。
N/A
テストは要件に関連付けられていますが、実行に指定されていません。
未実行
テストは要件に関連付けられ、実行に指定されていますが、まだ実行されていません。
プロジェクト要件トレーサビリティ レポート
プロジェクト内のすべての要件が、関連するテストおよび問題と共に表示されます。以下のステータスが使用されます。
合格
テストが合格しました。
失敗
テストが失敗しました。
N/A
テストは要件に関連付けられていますが、実行に指定されていません。
未実行
テストは要件に関連付けられ、実行に指定されていますが、まだ実行されていません。
親トピック: 要件レポート


進捗レポート

以下の進捗レポートは、要件 領域で使用できます。
ビルド 'X' から 'Y' までの要件カバレッジ
優先度が指定値より高いすべての要件を現在の要件カバレッジ別に集計して表します。返される要件グループは Priority パラメータで限定されます。このパラメータは、データで考慮の対象となる最低の要件優先度を指定するものです。
過去 'X' 日間の要件カバレッジ
'X' 日間の要件カバレッジ全体を見たときの、要件カバレッジの動きを表します。
過去 'X' 日間の特定の要件カバレッジ
'X' 日間の特定のカバレッジを見たときの、要件カバレッジの動きを表します。
親トピック: 要件レポート


文書レポート

以下の文書レポートは、要件で使用できます。
すべての要件
すべての要件について、完全な要件情報が記述されます。
要件と子要件
選択した要件がその要件 ID と共に表示されます。その要件の子要件に関する詳細が表示されます。
親トピック: 要件レポート


すべての関連する問題レポート

すべての関連する問題レポートでは、要件に割り当てたテストに関連するすべての問題が詳細リストで表示され、要件、割り当てられたテスト、発生した問題間の関係の説明も表示されます。すべての関連する問題 レポートの入力パラメータは、要件の識別子です。

親トピック: 要件レポート


カバレッジ

このセクションでは、テストで要件をカバーする方法について説明します。

  • カバレッジ モード
    要件で使用できるカバレッジ モードについて説明します。
  • カバレッジ モードを切り替える
    完全カバレッジ モードと直接カバレッジ モードを切り替えて、テスト カバレッジ計算に子要素を含めるか除外します。
  • [カバレッジ] ページ
    要件に割り当てられているすべてのテストのステータスが表示されます。
親トピック: 要件を管理する


カバレッジ モード

Silk Central には、2 種類のカバレッジ モードがあります。 これらのカバレッジ モードは、完全カバレッジと直接カバレッジです。 完全カバレッジ モードの要件のステータスでは子要件のステータスが考慮され、テストの累積カバレッジを確認できます。 少なくとも 1 つの子要件のステータスが [未カバー] の場合は、要件のカバレッジ ステータスが [カバー] であっても、選択された要件の完全カバレッジ ステータスは [未カバー] になります。 完全カバレッジ モードでは、テストで要件がカバーされているかどうかを簡単に評価することができます。

直接カバレッジ モードの要件のステータスは、要件に直接割り当てられたテストのステータスのみに基づいて計算されます。 子要件は、計算に考慮されません。

親トピック: カバレッジ


カバレッジ モードを切り替える

完全カバレッジ モードと直接カバレッジ モードを切り替えるには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 直接カバレッジの表示 / 完全カバレッジの表示 をクリックして、直接カバレッジまたは完全カバレッジをそれぞれ表示します。
親トピック: カバレッジ


[カバレッジ] ページ

要件 > 詳細ビュー > カバレッジ

詳細ビュー でのみアクセスできる カバレッジ ページには、選択した要件またはプロジェクトの基本プロパティが表示されます。また、[合格]、[失敗]、[未実行]、[未カバー] の状態にあるテストの数と割合を含め、要件に割り当てられているすべてのテストのステータスも表示されます。割り当てられているすべてのテストの集計は、総計 に表示されます。テストでカバーされていない要件は [未カバー] と表示されます。

詳細ビュー ページには、同じカバレッジ ステータス情報が「温度分布」グラフで表示されます。

選択した要件に直接割り当てられているすべてのテストのステータスだけでなく、その要件の子要件に割り当てられているすべてのテストのステータスも表示するには、完全カバレッジ チェック ボックスをオンにします。

注: 詳細ビュー および カバレッジ ページでは、テストの総計は親レベルにまとめられます。たとえば、要件の総計には子要件のテストが、プロジェクトの総計には全要件のテストが、それぞれ含まれます。

カバレッジ ページには、選択した要件またはプロジェクトごとに以下のプロパティが表示されます。

プロパティ | 説明

要件名

プロジェクト名

 選択した要件またはプロジェクトの名前。
優先度 | 選択した要件に割り当てられた優先度。
リスク | 選択した要件に割り当てられたリスク。
要件数 (計算値) | カバーされた全要件の総数。カバーされていない要件やテストが割り当てられていないフォルダは、この数には含まれません。たとえば、子要件のカバレッジは継承していても、それ自体が要件ではないフォルダは含まれません。
要件数 (総計) | 選択したエンティティ以下の全要件の総数。 フォルダを含む。

要件ステータス

プロジェクト ステータス

 選択した要件またはプロジェクトのステータス。
  • 合格
  • 失敗
  • 未実行
  • 未カバー
合格要件数 | プロジェクト内の要件の中で、テストが合格しているものの総計と割合。
失敗要件数 | プロジェクト内の要件の中で、テストが失敗しているものの総計と割合。
未実行要件数 | プロジェクト内の要件の中で、テストが未実行のものの総計と割合。
未カバー要件数 | プロジェクト内の要件の中で、テストでカバーされていないものの総計と割合。
総計 | プロジェクト内の要件の総数。
親トピック: カバレッジ
関連資料
[要件] の [ドキュメント ビュー]


フラグ

フラグを使用することで、要件が変更されたこと、または要件のレビューが必要なことを知らせることができます。 フラグの付いた要件は、要件ツリーでフラグ アイコンが表示されます。 要件プロパティには、フラグ情報を表示するためのセクションもあります。

フラグは必要に応じて追加および削除できます。他のユーザーは要件を確認するときにフラグを確認できます。 フラグは要件とそのすべての子要素に付けることができます。 1 つの項目に同時に付けられるフラグは 1 つだけです。既にフラグの付いた項目にフラグを設定すると、前のフラグは上書きされます。 要件フラグの変更は、要件変更履歴で管理されます。

外部要件管理ツールと統合している場合、新しい外部要件や更新された外部要件によるフラグも表示されます。 統合された要件に対して、どのようにフラグが適用されるかに関するシナリオを次に示します。

  • 要件管理ツールに初回同期の後で要件を追加してから、それ以降の同期を実行する場合、Silk Central に要件が新しく追加されると、その要件には (新規) フラグが表示され、更新時に作成されたことを示します。
  • Silk Central と同期済みの要件を編集すると、Silk Central ではその要件に (更新) フラグが付けられ、更新されたことを示します。
  • フラグの設定
    要件にフラグを設定して、要件が変更されたこと、または要件のレビューが必要なことを他のユーザーに知らせます。
  • フラグのクリア
    すべての変更が承認されるか、要件が確認されたときに、要件からフラグをクリアします。
  • フラグが付けられた要件にフィルタを作成する
    フラグが付けられた要件にフィルタを作成して、フィルタ条件に適用する要件のみが 要件 ツリーに表示されるようにします。
親トピック: 要件を管理する
関連資料
[通知] ページ


フラグの設定

要件にフラグを設定して、要件が変更されたこと、または要件のレビューが必要なことを他のユーザーに知らせます。

要件にフラグを設定するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 要件を右クリックして、フラグ > フラグの設定 を選択します。 フラグの設定 ダイアログ ボックスが開きます。
  4. フラグのコメントを コメント フィールドに入力します。
  5. 現在選択されている要件のすべての子要素にフラグを設定するには、子の要件にフラグを設定する チェック ボックスをオンにします。
  6. OK をクリックします。
    注: フラグ情報は、要件の プロパティ ページで使用できます。
親トピック: フラグ
関連資料
[要件プロパティ] ページ


フラグのクリア

すべての変更が承認されるか、要件が確認されたときに、要件からフラグをクリアします。

要件からフラグをクリアするには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 単一フラグをクリアするには：要件を右クリックして、フラグ > フラグのクリア を選択します。
  4. 選択した要件のすべての子要素のフラグをクリアするには：要件を右クリックして、フラグ > フラグのクリア - 子を含める を選択します。 フラグ情報が、要件の プロパティ ページから削除されます。
注: 要件の プロパティ ページで フラグのクリア をクリックして、フラグをクリアすることもできます。
親トピック: フラグ
関連資料
[要件プロパティ] ページ


フラグが付けられた要件にフィルタを作成する

フラグが付けられた要件にフィルタを作成して、フィルタ条件に適用する要件のみが 要件 ツリーに表示されるようにします。

フラグが付けられた要件にフィルタを作成するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. フィルタの新規作成 をクリックします。 フィルタの新規作成 ダイアログ ボックスが開きます。
  3. 選択基準 リストから 要件プロパティ を選択します。
  4. プロパティ リストから 要件の状態 を選択します。
  5. 演算子 リストから = を選択します。
  6. 値 リストから以下のいずれかの値を選択します。
    なし
    フラグが選択されていません。
    フラグ設定 (手動)
    ユーザーが要件にフラグを手動で追加しました。
    フラグ設定 (新規)
    要件が作成されました。
    フラグ設定 (更新)
    要件が更新されました。
    廃止
    要件が廃止としてマークされています。
  7. 保存 および 適用 をクリックします。
    注: 子要件にフラグが付けられ、1 つまたは複数の親要件にフラグが付いていない場合は、フラグが付けられた子要件の完全パスは表示されますが、親要件は無効になります。この状態の親要件に対しては、フラグの設定またはクリアはできません。
親トピック: フラグ
関連資料
[要件プロパティ] ページ


要件プロパティを設定する

要件プロパティ、添付ファイル、フラグ、カバレッジを設定します。

特定のデフォルト プロパティ以外にも、Silk Central では独自の要件プロパティを作成できます。これらのカスタム プロパティは、デフォルト プロパティと同じように 要件の編集 ダイアログ ボックスで編集可能です。

アクティブ プロジェクトにカスタム プロパティを作成するには、メニューで 要件 > 要件プロパティ をクリックし、要件プロパティの新規作成 をクリックします。

カスタム プロパティは、プロパティ ページの 詳細ビュー と、[要件] の ドキュメント ビュー に表示されます。

カスタム要件プロパティの詳細については、「カスタム要件プロパティ」を参照してください。

  • 要件プロパティを置換する
    1 つまたは複数の要件のプロパティ値の置換方法について説明します。
  • 要件プロパティを検索する
    検索 を使用して、検索条件に一致する要件プロパティを見つけます。
  • [要件プロパティ] ページ
    選択した要件またはプロジェクトに関する概要が表示されます。
  • 要件への添付
    要件への添付を使用する方法について説明します。
親トピック: 要件
関連概念
カスタム要件プロパティ


要件プロパティを置換する

1 つまたは複数の要件のプロパティ値を置換するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. ツールバーで 置換 (置換) をクリックするか、要件を右クリックして 置換 をクリックします。 置換 ダイアログ ボックスが表示されます。
  3. 検索範囲 リストから要件プロパティを選択します。 このリストにはデフォルト プロパティとカスタム プロパティがすべて含まれます。
  4. 検索文字列 領域に、検索条件を定義します。 検索文字列 領域の UI コントロールは、選択したプロパティによって異なります。例：プロパティ リスク を選択するとリストが 2 つ表示され、プロパティ 説明 を選択するとテキスト フィールドが 1 つとチェック ボックスが 2 つ表示されます。
  5. 置換文字列 領域に、特定のデータを置換する値を入力します。
  6. 省略可能：大文字/小文字を区別 チェック ボックスをオンにすると、大文字と小文字が区別されます。
  7. 省略可能：完全に一致するものを検索 チェック ボックスをオンにすると、文字列に完全に一致するインスタンスのみが含まれます。
  8. OK をクリックします。 検索条件に一致する最初の要件が、要件 ツリーで強調表示されます。
  9. 次のいずれかをクリックします。
    • 置換：強調表示した要件のプロパティ値を置換します。
    • すべて置換：定義した値を含むすべての要件のプロパティ値を置換します。
    • 次を検索：定義した値を含む次の要件を強調表示します。
    • 前を検索：定義した値を含む前の要件を強調表示します。
    • 新しい置換：新しい値を設定するために、置換 ダイアログ ボックスを開き直します。
    • 閉じる：ダイアログ ボックスを閉じます。
    注: すべて置換 をクリックすると、継承したプロパティがすべて上書きされます。 この場合、子要件も継承設定をすべて失います。 子要件に新しい値が継承されるようにするには、親オプションに対してのみ 置換 を使用します。
親トピック: 要件プロパティを設定する


要件プロパティを検索する

要件 領域では、検索 コマンドを使用して、特定の検索条件に一致する要件を見つけることができます。また、置換 コマンドを使用して、見つかったプロパティ データを、指定の別データに置き換えることができます。いずれのコマンドにも 次を検索 機能と 前を検索 機能があるため、見つかったすべてのプロパティを順に確認できます。

要件を検索するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. ツールバーの 検索 を選択して、検索 ダイアログ ボックスを開きます。
    注: このコマンドは、要件を右クリックして 検索 を選択することによっても実行できます。
  3. 検索範囲 リストから要件プロパティを選択します。 このリストにはデフォルト プロパティとカスタム プロパティがすべて含まれます。
  4. 検索文字列 領域に、検索条件を定義します。 検索文字列 領域の UI コントロールは、選択したプロパティによって異なります。例：プロパティ リスク を選択するとリストが 2 つ表示され、プロパティ 説明 を選択するとテキスト フィールドが 1 つとチェック ボックスが 2 つ表示されます。
  5. OK をクリックして、検索を開始します。 検索条件に一致する最初の要件が、ツリー ビューで強調表示されます。 検索条件に一致する最初の要件が、ツリー ビューで強調表示されます。
  6. 検索条件に一致する要件リストの次の要件に進むには、検索 ダイアログ ボックスの 次を検索 をクリックします。 検索条件に一致する要件リストの前の要件に戻るには、検索 ダイアログ ボックスの 前を検索 をクリックします。
    注: 検索条件に一致する要件リストの最後または先頭に到達し、次を検索 または 前を検索 をそれぞれクリックすると、検索が最初から開始します。
親トピック: 要件プロパティを設定する


[要件プロパティ] ページ

要件 > 詳細ビュー > プロパティ

要件プロパティ ページには、選択した要件またはプロジェクトに関する概要が表示されます。

要件が外部の要件管理システムと同期しているときは、項目に感嘆符（!）が付くことがあります。これは感嘆符の付いたフィールドが外部の要件管理システムにマップされていないことを示します。プロパティ マッピング機能を使用して、プロパティ フィールドをマップします。プロパティ マッピング機能を使用しないと、要件の名前と説明だけがマップされます。詳細については、「プロパティ マッピングを編集する」を参照してください。

アスタリスク（*）が付いた項目の値は、親の要件から継承した値です。

要件プロパティの編集 をクリックして、表示されたプロパティを編集します。

以下の表は、フラグが設定されている要件にのみ適用されます。

項目 | 説明
フラグ設定者 | フラグの設定者と設定日を示します。
コメント | フラグのコメントを示します。
フラグのクリア | クリックしてフラグを削除します。

以下の表に、プロパティ ページに表示される、選択した要件またはプロジェクトのプロパティを示します。

プロパティ | 説明
要件名 | 要件の名前。
要件 ID | 要件の識別子。
説明 | 要件の説明。
優先度 | 要件に設定されている優先度。
リスク | 要件に設定されているリスク。
レビュー済み | 要件の現在のレビュー ステータス。はい または いいえ。
カスタム プロパティ | 要件にカスタム プロパティが設定されている場合は、ここに表示されます。
ソース文書 | この要件の元になったソース文書（存在する場合）。
作成日時 | この要件が作成された日時。
作成者 | この要件を作成したユーザーの名前。
変更日時 | この要件が最後に変更された日時。
変更者 | この要件を最後に変更したユーザーの名前。
親トピック: 要件プロパティを設定する
関連概念
要件の同期
関連タスク
プロパティ マッピングを編集する


要件への添付

複数のファイルやリンクを要件への添付情報としてアップロードしたり、添付情報を削除したりできます。添付情報の付いた要件をカット＆ペーストすると、その添付情報も自動的に一緒にコピーされます。

選択できる添付情報の種類は以下のとおりです。

  • アップロード ファイル
  • UNC パスへの参照
  • URL への参照（StarTeam URL を含む）
  • 要件にファイルを添付する
    要件にファイルを添付して要件に情報を追加します。
  • 要件にリンクを添付する
    要件にリンクを添付して要件に情報を追加します。
  • 要件への添付を表示する
    要件への添付を表示して、要件に関する追加情報を取得します。
  • 要件からのファイルのダウンロード
    要件からすべての添付ファイルをローカル ディスクにダウンロードします。
  • 要件から添付情報を削除する
    添付ファイルの情報が不要になった場合に、要件への添付を削除します。
  • [要件] の [添付情報] ページ
    選択した要件に添付されているファイルおよびリンクが一覧表示されます。
親トピック: 要件プロパティを設定する


要件にファイルを添付する

要件にファイルを添付するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 添付情報 タブをクリックします。

    Silk Central プロジェクトと Caliber プロジェクトの間で要件管理の統合が有効になっていると、添付情報 ページに Caliber を開く ボタンが表示され、要件の添付を Caliber で直接管理できます。

  4. ファイルのアップロード をクリックします。 ファイルのアップロード ダイアログ ボックスが表示されます。
  5. ファイルの選択 をクリックして、添付するファイルをローカル ファイル システムから選択します。
  6. 説明 フィールドに、添付ファイルの説明を入力します。
  7. OK をクリックします。 添付ファイルがサーバーにアップロードされ、選択した要件に関連付けられます。
親トピック: 要件への添付


要件にリンクを添付する

要件にリンクを添付するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 添付情報 タブをクリックします。

    Silk Central プロジェクトと Caliber プロジェクトの間で要件管理の統合が有効になっていると、添付情報 ページに Caliber を開く ボタンが表示され、要件の添付を Caliber で直接管理できます。

  4. リンクの添付 をクリックします。 リンクの添付 ダイアログ ボックスが表示されます。
  5. リンク フィールドに URL を入力します。
  6. 説明 フィールドに、添付するリンクの説明を入力します。
  7. OK をクリックします。 選択した要件にリンクが関連付けられます。
親トピック: 要件への添付


要件への添付を表示する

要件への添付を表示するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 添付情報 タブをクリックします。

    Silk Central プロジェクトと Caliber プロジェクトの間で要件管理の統合が有効になっていると、添付情報 ページに Caliber を開く ボタンが表示され、要件の添付を Caliber で直接管理できます。

要件に関連付けられているすべての追加情報のリストが開きます。各添付の名前はリンクとして機能します。ファイル添付のリンクをクリックすると 名前を付けて保存 ダイアログ ボックスが開き、添付ファイルをローカルのファイル システムにダウンロードできます。リンク添付のリンクをクリックすると、新しいブラウザ ウィンドウが開き、直接リンク先が表示されます。
親トピック: 要件への添付


要件からのファイルのダウンロード

要件からすべてのファイルをダウンロードするには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 添付情報 タブをクリックします。

    Silk Central プロジェクトと Caliber プロジェクトの間で要件管理の統合が有効になっていると、添付情報 ページに Caliber を開く ボタンが表示され、要件の添付を Caliber で直接管理できます。

  4. 添付情報 セクションで、すべてのファイルのダウンロード をクリックします。 ブラウザのダウンロード設定がどのように設定されているかに依存して、すべての添付ファイルがローカル ディスクに zip アーカイブとしてダウンロードされます。
    注: 過度なダウンロードを防ぐため、子要素の添付情報を含める がオンの場合、すべてのファイルのダウンロード は無効になります。
親トピック: 要件への添付


要件から添付情報を削除する

要件への添付を削除するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 添付情報 タブをクリックします。

    Silk Central プロジェクトと Caliber プロジェクトの間で要件管理の統合が有効になっていると、添付情報 ページに Caliber を開く ボタンが表示され、要件の添付を Caliber で直接管理できます。

  4. 削除する添付情報の アクション 列で、 削除 をクリックします。
  5. 確認ダイアログで はい をクリックして、プロジェクトから添付情報を削除します。
    注: 1 度に 1 つの添付情報しか削除できません。
親トピック: 要件への添付


[要件] の [添付情報] ページ

要件 > 詳細ビュー > 添付情報

添付情報 ページには、選択した要件に添付されているファイルおよびリンクが一覧表示されます。添付情報はアップロードされた順に表示されますが、名前、作成日時、作成者 の各プロパティでリストをソートすることができます。

注: 選択した要件の子要件に関連付けられた添付情報を表示するには、子要素の添付情報を含める チェック ボックスをオンにします。
注: 文書が選択した要件に直接添付されているのか、または選択した要件の子要件に添付されているのかは、ファイル アイコンを見るとわかります。
一重のアイコン
ファイルは選択した要件に直接添付されています。
二重のアイコン
ファイルは選択した要件の子要件に添付されています。

添付情報 ページには、表示された添付情報ごとに以下の列が表示されます。

列 | 説明
アクション | 削除 をクリックして添付情報を削除します。
添付アイコン | 添付情報のタイプによって異なります。
名前 | 添付ファイルの名前。
サイズ | 添付情報のサイズ。
説明 | 添付情報の説明。
作成日時 | この情報が添付された日時。
作成者 | この情報を添付したユーザー。
親トピック: 要件への添付


テストと要件を関連付ける

要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。
  • グリッド ビューから要件にテストを割り当てる
    グリッド ビュー から要件にテストを割り当て、要件のテスト カバレッジを表示します。
  • テストを要件に手動で割り当てる
    テストを要件に手動で割り当て、要件のテスト カバレッジを表示します。
  • テスト ツリーでの割り当て済みのテストの検索
    テスト ツリーで割り当て済みのテストを見つけて、そのテストが属すテスト フォルダまたはコンテナを判断します。
  • テストの割り当てを削除する
    テストが要件に関連しなくなった場合に、割り当て済みテストを要件から削除します。
  • 詳細ビューからテストを生成する
    要件 領域の 詳細ビュー から新しいテストを生成し、特定の要件にテストを割り当てます。
  • [割り当て済みテスト] ページ
    選択した要件に割り当てられているテストをすべて一覧表示します。
親トピック: 要件


グリッド ビューから要件にテストを割り当てる

テスト領域の グリッド ビュー から、1 つまたは複数のテストを、1 つまたは複数の要件に割り当てるには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. ツールバーで、 グリッド ビュー をクリックします。
  3. 要件に割り当てるテストを選択します。 キーボードの Ctrl または Shift キーを使用すると、標準ブラウザの複数選択機能を使用して、複数のテストを選択することができます。
  4. 選択したテストを右クリックし、選択の保存 を選択します。
  5. メニューで 要件 > 詳細ビュー をクリックします。
  6. 選択したテストを割り当てる要件を選択します。
  7. 割り当て済みテスト タブをクリックします。
  8. 保存された選択の割り当て をクリックします。
    注: 要件テスト コンテナに存在するテストのみ、割り当てられます。選択したテストは、1 つ以上の要件に割り当てることはできますが、別のプロジェクトの要件に割り当てることはできません。選択内容は、ユーザーが別の選択を保存するか Silk Central を閉じるまで保持されます。
親トピック: テストと要件を関連付ける


テストを要件に手動で割り当てる

テストを要件に手動で割り当てるには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 割り当て済みテスト タブをクリックします。 割り当て可能なすべてのテストが、テスト ウィンドウに表示されます。
  4. テスト フィルタを作成した場合は、テスト ウィンドウの上にあるフィルタ リストから選択できます。 新しいテスト フィルタを作成するには、テスト 領域に移動し、ツールバーの フィルタの新規作成 をクリックします。
  5. 割り当てるテストを選択します。 キーボードの Ctrl または Shift キーを使用すると、標準ブラウザの複数選択機能を使用して、複数のテストを選択することができます。
  6. 選択した項目をドラッグし、割り当て済みテスト 領域にドロップするか、テストの左側にある 割り当て をクリックします。 テスト コンテナやテスト フォルダを割り当てると、これらのコンテナまたはフォルダ内に存在するすべてのテストが、選択した要件に割り当てられます。また、これらのコンテナまたはフォルダのサブフォルダ内に存在するテストも割り当てられます。
    ヒント: ノードを右クリックして展開、折りたたみを行います。
親トピック: テストと要件を関連付ける


テスト ツリーでの割り当て済みのテストの検索

テスト ツリーで割り当て済みのテストを検索するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. ツールバーの 要件ビュー をクリックします。
  3. 要件 ツリーから、テストが少なくとも 1 つ割り当てられている要件を選択します。
  4. 割り当て済みテスト タブをクリックします。
  5. テストの アクション 列で 検索 をクリックして、そのテストが保存されているテスト フォルダまたはコンテナを検索します。 対応するテスト フォルダまたはコンテナが、テスト ウィンドウで強調表示されます。
親トピック: テストと要件を関連付ける


テストの割り当てを削除する

テストの割り当てを削除するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. ツールバーの 要件ビュー をクリックします。
  3. 要件 ツリーから、テストが少なくとも 1 つ割り当てられている要件を選択します。
  4. 削除する割り当て済みテストの アクション 列で、 割り当ての削除 をクリックするか、Ctrl+クリック や Shift+クリック を使用して複数のテストを選択してから Del キーを押します。
    注: 選択されている要件からすべてのテスト割り当てを削除するには、すべて削除 をクリックします。
親トピック: テストと要件を関連付ける


詳細ビューからテストを生成する

要件 ツリーからテストを直接生成して、テストを特定の要件に割り当てることができます。要件 ツリーは、新しい テスト ツリーのテスト フォルダ/テスト構造のテンプレートとなります。

詳細ビュー から新しいテストを生成するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. テストに変換する要件またはプロジェクトのノードを右クリックし、テストの生成 を選択します。 要件からのテストの生成 ダイアログ ボックスが表示されます。このダイアログ ボックスを利用して、選択した要件サブツリーのリーフ ノード (最下位ノード) をテストに変換するか、テスト フォルダに変換するかを指定できます。また、このツリーを新しいテスト コンテナ内に生成するか、既存のコンテナ内に生成するかも指定できます。
  3. 名前の入力 フィールドに新しいテスト コンテナの名前を入力し、製品の選択 リストから製品を選択して、アクティブな Silk Central プロジェクト内にコンテナを作成します。 製品の選択 リストには、プロジェクト マネージャによって構成された製品がインポートされています。詳細については、『プロジェクトを管理する』を参照するか、プロジェクト マネージャに問い合わせてください。
  4. ソース管理プロファイルを定義している場合は、ソース管理プロファイルの選択 リストから、テストのソースを管理するために使用するソース管理プロファイルを選択します。 ソース管理プロファイルの詳細については、「ソース管理プロファイル」を参照するか、Silk Central 管理者に問い合わせてください。
  5. テストで選択した要件の子要件をすべて含めるには、子要件を含める チェック ボックスをオンにします。 このチェック ボックスは、デフォルトでオンになっています。
  6. 新規のテストを、その作成元となった要件に自動的に割り当てるには、新規に生成したテストを要件に割り当てる チェック ボックスをオンにします。 このオプションをオフにした場合は、テストを手動で要件に割り当てる必要があります。
    注: 生成方法として 要件ツリーのリーフ ノードからテスト フォルダを生成する がオンになっている場合、このオプションは利用できません。
  7. OK をクリックして、テストを作成します。 新しいテストは、要件 ツリーと同じ構造になります。
  8. メッセージ ボックスが表示されます。はい をクリックして テスト 領域にテスト計画を表示するか、いいえ をクリックして、要件 領域のままにします。
親トピック: テストと要件を関連付ける
関連概念
製品を管理する
ソース管理プロファイル


[割り当て済みテスト] ページ

要件 > 詳細ビュー > 割り当て済みテスト

割り当て済みテスト ページには、選択した要件に割り当てられているテストがすべて一覧表示されます。テストが複数の実行計画に割り当てられており、実行コンテキストで表示する チェック ボックスがオンの場合、テストは、実行計画ごとにグリッドの異なる行として表示されます。

割り当て可能なテストはすべて、右側の テスト ツリーに表示されます。選択した要件にテストを割り当てるには、ツリー内のエントリをダブルクリックするか、エントリの左にある 割り当て をクリックします。

テスト フィルタを作成した場合は、テスト ツリーの上にあるフィルタ リストから選択できます。新しいテスト フィルタを作成するには、テスト 領域に移動し、ツールバーの フィルタの新規作成 をクリックします。

新しく生成したテストを生成元となった要件に自動的に割り当てるには、要件からのテストの生成 ダイアログ ボックスで 新規に生成したテストを要件に割り当てる チェック ボックスをオンにします。

デフォルトのビューでは、選択した要件に直接割り当てられたテストのみが表示されます。選択した要件の子要件に割り当てられたテストもすべて表示するには、完全カバレッジ チェック ボックスをオンにします。完全カバレッジ チェック ボックスがオンの場合、選択した要件に割り当てられておらず、かつ、その要件の子要件に割り当てられているテストのテスト タイプ アイコンにはオーバーレイが表示されます。

一連のテストを テスト > グリッド ビュー からクリップボードにコピーした場合は、保存された選択の割り当て をクリックして、選択した要件にセット全体を割り当てます。要件から割り当て済みテストをすべて削除するには、すべて削除 をクリックします。

既存の問題を 1 つまたは複数のテストにグリッドで直接割り当てるには、テストを右クリックしてから 既存の問題の割り当て をクリックします。Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。

割り当て済みテスト ページには、表示されたテストごとに以下の列が表示されます。

列 | 説明
アクション 割り当て済みテストでは、以下のアクションを実行できます。
  • 削除 をクリックして、割り当て済みテストを要件から削除します。
  • 検索 をクリックして、右側の テスト ツリーで割り当て済みテストを検索します。
テスト | 割り当てられているテストの名前。クリックすると、テストを表示および編集できます。構成テストでは、各構成に対してテストが別々に表示されます。
実行計画 | この列は、実行コンテキストで表示する チェック ボックスがオンの場合にのみ表示されます。割り当てられているテストを含む実行計画の名前です。これは、構成テスト用です。
実行計画の親 | 実行計画が実行されるコンテキスト内にある構成スイート、フォルダ、またはテスト サイクル。 クリックすると、実行計画 ツリー内のスイートまたはフォルダにアクセスできます。 構成スイートまたはフォルダに実行計画が含まれていない場合は、何も表示されません。
ステータス テストが割り当てられている各実行計画における、割り当て済みテストのステータス。各実行計画における割り当て済みテストの、すべての実行のステータスを表示するには、実行コンテキストで表示する チェック ボックスをオンにします。
  • 合格
  • 失敗
  • 未実行
  • N/A
構成スイートに含まれているテストまたはテスト パッケージでは、ステータスは、そのスイート内のすべての構成の、すべてのステータスを集約したものとなります。
  • 構成スイートにのみ割り当てられているテストは、すべての構成で合格となった場合にのみ、ステータスが 合格 になります。すべての構成でステータスが 合格 でない場合、最も低い実行のステータスが反映されます。反映の優先度は次に示す順序 (上から下へ) となります。
    1. N/A
    2. 未実行
    3. 失敗
    4. 合格
    テストに割り当てられた要件のステータスは、そのテストが 1 つ以上の構成で失敗すると、失敗 になります。
  • 構成スイートと 1 つ以上の単純な実行計画にテストを割り当てることはお勧めしません。ただし、この場合は、1 つのステータスが構成ステータスの集約ステータスに、もう 1 つのステータスが実行計画の前回のステータスとなります。前回実行されたステータスがテストの前回のステータスとなります。
  • テストが単純な実行計画にのみ割り当てられている場合、ステータスは前回のテスト実行のステータスに応じて更新されます。
前回の実行 | テストが前回実行された日時。
問題 | この列は、実行コンテキストで表示する チェック ボックスがオフの場合にのみ表示されます。このテストに関連付けられた問題。
親トピック: テストと要件を関連付ける
関連概念
カスタム アイコン


要件のインポート

Silk Central を使用すると、Microsoft Word および Excel から要件をインポートできます。要件を 要件 領域にインポートして、Silk Central に含まれているすべての要件を管理できます。手動テストのインポートは、1 回限りのイベントです。

  • Word ファイルから要件をインポートする
    要件を Silk Central で管理するため、Microsoft Word ファイルから要件をインポートします。
  • Word ファイルから要件を更新する
    Microsoft Word ファイルから要件を更新して、Word ファイルに加えられた変更を適用します。
  • Word 要件ファイル
    Silk Central に要件をインポートできる Word 要件ファイルの内容を説明します。
  • Excel ファイルから要件をインポートする
    要件を Silk Central で管理するため、Microsoft Excel ファイルから要件をインポートします。
  • Excel ファイルから要件を更新する
    Microsoft Excel ファイルから要件を更新して、Excel ファイルに加えられた変更を適用します。
  • Excel 要件とマッピング ファイル
    Excel 要件ファイルの内容と、対応する Silk Central のマッピング ファイルについて説明します。
親トピック: 要件


Word ファイルから要件をインポートする

要件をインポートする前に、Word で要件ファイルを作成する必要があります。詳細については、「Word 要件ファイル」を参照してください。

Silk Central は Word ファイルとマッピング ファイルに保存されている情報を使用して、保存するデータを判断し、特定のスタイルにマップされている情報のみを取得します。Silk Central は、マッピング ファイルを使用して、Word ファイル内の要件を Silk Central の要件にマップします。RequirementsPropertiesDefaultMapping.xml という名前のデフォルトのマッピング ファイルが、インポート用にあらかじめ選択されます。独自にカスタマイズしたマッピング ファイルを選択して、要件をマップできます。

docx 機能：docx は doc と同じ機能に加え、以下の改善が行われています。
  • 画像とその他の埋め込みオブジェクト (OLE)(PDF、Excel など) が要件の添付ファイルとして検出され、インポートされます。
  • 説明にハイパーリンクを含めることができます。

Word ファイルから 要件 ユニットに要件をインポートするには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. インポートした要件の親ノードとして使用する要件を右クリックし、Word からインポート... を選択します。 Word ファイルから要件のインポート ダイアログ ボックスが表示されます。
  3. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは RequirementsPropertiesDefaultMapping.xml です。
  4. 省略可能： をクリックして、マッピング ファイルを編集します。 をクリックして、マッピング ファイルを削除します。詳細については、「Word 要件ファイル」を参照してください。
    注: これらのアクションを実行するには、Office インポート マッピング ファイルの編集/Office インポート マッピング ファイルの削除 アクセス許可がそれぞれ必要になります。
  5. 要件のインポートを一度だけ行い、インポート後の保守は Silk Central でのみ行う場合は、ワンタイム インポート チェック ボックスをチェックします。このオプションを選択すると、ルート フォルダを作成せずに、選択したノードの直下に要件をインポートします。インポート後にインポートした要件を更新するために、Word から更新... オプションを使用できません。
  6. 要件ファイルの完全修飾パスを 要件ファイル フィールドに入力するか、ファイルを選択 (または、参照) をクリックして要件ファイルを検索します。
  7. OK をクリックします。 インポートに成功した場合は、メッセージが表示されます。OK をクリックして、メッセージを閉じます。
親トピック: 要件のインポート
関連概念
Word 要件ファイル
関連タスク
Word ファイルから要件を更新する


Word ファイルから要件を更新する

Silk Central では、Microsoft Word からインポートされた要件を更新できます。Word 文書で要件を変更し、それを 要件 領域で更新できます。また、マッピング ファイルを変更して、要件 領域で要件のマッピングを変更することもできます。
注: 一意の外部 ID が以前にインポートされた Word ファイルに定義されている場合のみ、要件を更新できます。Silk Central は、更新が必要な要件を識別するために、この ID を必要とします。
  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 以前にインポートした要件の親ノード (たとえば ファイル 'RequirementExample.docx' からインポートされました など) を右クリックして、Word から更新... を選択します。 Word ファイルから要件を更新 ダイアログ ボックスが開きます。
  3. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは RequirementsPropertiesDefaultMapping.xml です。
  4. 省略可能： をクリックして、マッピング ファイルを編集します。 をクリックして、マッピング ファイルを削除します。詳細については、「Word 要件ファイル」を参照してください。
    注: これらのアクションを実行するには、Office インポート マッピング ファイルの編集/Office インポート マッピング ファイルの削除 アクセス許可がそれぞれ必要になります。
  5. 要件ファイルの完全修飾パスを 要件ファイル フィールドに入力するか、参照 をクリックして要件ファイルを検索します。
  6. OK をクリックします。 更新に成功した場合は、メッセージが表示されます。OK をクリックして、メッセージを閉じます。
親トピック: 要件のインポート
関連概念
Word 要件ファイル
関連タスク
Word ファイルから要件をインポートする


Word 要件ファイル

Word で要件ファイルを作成し、要件を Silk Central にインポートしたり、更新したりできます。要件ファイルには、要件とその階層に加えて、プロパティ、リスク、レビュー ステータス、およびカスタム プロパティを定義できます。

要件ファイル内の要件を Silk Central の要件にマップするには、XML マッピング ファイルを使用します。マッピング ファイルは、Word 文書のスタイルを Silk Central の要件プロパティにマップします。マッピング ファイルで適切にマップしていれば、Word スタイルには任意の名前を付けられます。

要件を更新できるようにするには、外部 ID のスタイルを定義し、一意の外部 ID を要件ファイルの各要件に割り当てる必要があります。次の例では、サンプル要件、2 つのサブ要件、および対応する外部 ID を示しています。
Word ファイル 適用されるスタイル
Customer Account Management - Basics
ID_1
As user of the web shop I want to be able to ...
Medium
High
No

Customer Account Management - Personal Details
ID_1.1
As user of the web shop I want to be able to ...
Medium
Medium
No

Customer Account Management - Shipping Details
ID_1.2
As user of the web shop I want to be able to ...
Medium
Medium
No

Formatted with Word style "Heading 1"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

Formatted with Word style "Heading 2"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

Formatted with Word style "Heading 2"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

必要に応じて、名前を付けて保存 フィールドのマッピング ファイルの名前を変更します。このファイルは、アプリケーション サーバー上の <Silk Central データ ディレクトリ>\OfficeImportMappingFiles\requirements\<クライアント ID> (たとえば、C:\ProgramData\SilkCentral\instance_<インスタンス番号>_<インスタンス名>\OfficeImportMappingFiles) に保存されます。

親トピック: 要件のインポート
関連タスク
Word ファイルから要件をインポートする
Word ファイルから要件を更新する


Excel ファイルから要件をインポートする

要件をインポートする前に、Excel で要件ファイルを作成する必要があります。詳細については、「Excel 要件とマッピング ファイル」を参照してください。

Silk Central は Excel ファイルとマッピング ファイルに保存されている情報を使用して、保存するデータを判断し、特定のスタイルにマップされている情報のみを取得します。Silk Central は、マッピング ファイルを使用して、Excel ファイル内の要件を Silk Central の要件にマップします。RequirementPropertiesXlsxDefaultMapping.xml という名前のデフォルトのマッピング ファイルが、インポート用にあらかじめ選択されます。独自にカスタマイズしたマッピング ファイルを選択して、要件をマップできます。

注: 添付情報 (イメージやグラフ) のインポートはサポートされていません。

Excel ファイルから 要件 ユニットに要件をインポートするには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. インポートした要件の親ノードとして使用する要件を右クリックし、Excel からインポート... を選択します。 Excel ファイルから要件のインポート ダイアログ ボックスが表示されます。
  3. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは RequirementPropertiesXlsxDefaultMapping.xml です。
  4. 省略可能： をクリックして、マッピング ファイルを編集します。 をクリックして、マッピング ファイルを削除します。詳細については、「Excel 要件とマッピング ファイル」を参照してください。
    注: これらのアクションを実行するには、Office インポート マッピング ファイルの編集/Office インポート マッピング ファイルの削除 アクセス許可がそれぞれ必要になります。
  5. 要件のインポートを一度だけ行い、インポート後の保守は Silk Central でのみ行う場合は、ワンタイム インポート チェック ボックスをチェックします。このオプションを選択すると、ルート フォルダを作成せずに、選択したノードの直下に要件をインポートします。インポート後にインポートした要件を更新するために、Excel から更新... オプションを使用できません。
  6. 要件ファイルの完全修飾パスを 要件ファイル フィールドに入力するか、ファイルを選択 (または、参照) をクリックして要件ファイルを検索します。
  7. OK をクリックします。 インポートに成功した場合は、メッセージが表示されます。OK をクリックして、メッセージを閉じます。
親トピック: 要件のインポート
関連タスク
Excel ファイルから要件を更新する
関連資料
Excel 要件とマッピング ファイル


Excel ファイルから要件を更新する

Silk Central では、Microsoft Excel からインポートされた要件を更新できます。Excel 文書で要件を変更し、それを 要件 領域で更新できます。また、マッピング ファイルを変更して、要件 領域で要件のマッピングを変更することもできます。
注: 一意の外部 ID が以前にインポートされた Excel ファイルに定義されている場合のみ、要件を更新できます。Silk Central は、更新が必要な要件を識別するために、この ID を必要とします。
  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 以前にインポートした要件の親ノード (たとえば ファイル 'RequirementExample.xslx' からインポートされました など) を右クリックして、Excel から更新... を選択します。 Excel ファイルから要件を更新 ダイアログ ボックスが開きます。
  3. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは RequirementPropertiesXlsxDefaultMapping.xml です。
  4. 省略可能： をクリックして、マッピング ファイルを編集します。 をクリックして、マッピング ファイルを削除します。詳細については、「Excel 要件とマッピング ファイル」を参照してください。
    注: これらのアクションを実行するには、Office インポート マッピング ファイルの編集/Office インポート マッピング ファイルの削除 アクセス許可がそれぞれ必要になります。
  5. 要件ファイルの完全修飾パスを 要件ファイル フィールドに入力するか、参照 をクリックして要件ファイルを検索します。
  6. OK をクリックします。 更新に成功した場合は、メッセージが表示されます。OK をクリックして、メッセージを閉じます。
親トピック: 要件のインポート
関連タスク
Excel ファイルから要件をインポートする
関連資料
Excel 要件とマッピング ファイル


Excel 要件とマッピング ファイル

Excel で要件ファイルを作成し、要件を Silk Central にインポートしたり、更新したりできます。要件ファイルには、要件とその階層に加えて、プロパティ、リスク、レビュー ステータス、およびカスタム プロパティを定義できます。

要件ファイル内の要件を Silk Central の要件にマップするには、XML マッピング ファイルを使用します。マッピング ファイルは、Excel 文書の列を Silk Central の要件プロパティにマップします。マッピング ファイルの編集には、Office インポート マッピング ファイルの編集 アクセス許可が必要です。

プロパティ マッピング

Excel ファイルから要件をインポート または Excel ファイルから要件を更新 ダイアログで、マッピングの編集 をクリックし、Excel ファイルの要件から Silk Central へのマッピングを次のようにに定義します。
  • ヘッダー行：プロパティとのマッピングに使用する列名を含んだ Excel 要件ファイルの行を指定します。
  • 最初のデータ行：最初の要件を含んだ行を指定します。この行とそれ以降のすべての行が要件として読み取られます。
  • 区切り文字：プロパティ値内で区切り文字として解釈される文字を指定します。複数リスト プロパティとして使用されます。
  • 名前、説明：要件名と説明にマップされるヘッダー行の列名をそれぞれ指定します。
  • 外部 GUID：各要件に対する要件ファイル内での一意な ID を含むヘッダー行の列名を指定します。この ID は、要件を階層化するために、外部親 GUID で使用することができます。
  • 外部親 GUID：要件の親を含むヘッダー行の列名を指定します。要件ファイルで、要件の親を指定するために、親の 外部 GUID を入力します。このセルにデータが含まれない場合には、要件は生成されたルート要件に直接追加されます。以下のルールが適用されます。
    • 要件に親 ID が設定されていない場合は、生成したルート要件の子として追加されます。
    • 要件に無効な親 ID が設定されている場合は、生成したルート要件の子として追加されます。
    • 要件自身の外部 ID を親 ID として設定した場合は、生成したルート要件の子として追加されます。
    • 2 つ移住斧要件間で、親 ID による循環依存性がある場合は、Silk Central にインポートされません。
  • 優先度、リスク、レビュー済み：これらのプロパティのローカライズされた値にマップされるヘッダー行の列名をそれぞれ指定します。
  • カスタム プロパティが定義されている場合は、正しくマップされるようにそれぞれに対してヘッダー行に列名を指定します。
  • 名前を付けて保存：指定したマッピング情報を保存するファイル名を指定します。このファイルは、アプリケーション サーバー上の <Silk Central データ ディレクトリ>\OfficeImportMappingFiles\requirements\xlsx\<クライアント ID> (たとえば、C:\ProgramData\SilkCentral\instance_<インスタンス番号>_<インスタンス名>\OfficeImportMappingFiles\requirements\xlsx\1) に保存されます。

Excel 要件ファイルの例

次の例では、サンプル要件、2 つのサブ要件、および対応する外部 ID を示しています。この Excel 要件ファイルの例では、デフォルトのプロパティ マッピングに一致します。
1 | RequirementName | RequirementDescription | ID | ParentID | Priority | Risk | Reviewed
2 | Customer Account Management - Basics | As user of the web shop I want to be able to ... | ID_1 |  | 中 | 高 | いいえ
3 | Customer Account Management - Personal Details | As user of the web shop I want to be able to ... | ID_1.1 | ID_1 | 中 | 中 | いいえ
4 | Customer Account Management - Shipping Details | As user of the web shop I want to be able to ... | ID_1.2 | ID_1 | 中 | 中 | いいえ
親トピック: 要件のインポート
関連タスク
Excel ファイルから要件をインポートする
Excel ファイルから要件を更新する


要件ビュー

Silk Central が提供するいくつかのビューとツールを使用して、要件の管理を行うことができます。

  • 要件ツリー
    要件 ツリーについて説明します。
  • [要件] ツールバーの機能
    要件を管理するための重要なコマンドが用意されています。
  • [要件] の [ドキュメント ビュー]
    アクティブなプロジェクトに割り当てられたすべてのテストのステータスが「温度分布」グラフで表示されます。
  • 要件履歴
    要件履歴を使用して、要件に加えられたすべての変更を追跡する方法について説明します。
親トピック: 要件


要件ツリー

要件は、要件 ツリーという階層ツリー構造で表示、編成、および維持管理されます。 要件 ツリーの各ノードは 1 つの要件を表します。 各要件には、子要件をいくつでも関連付けることができます。 要件 ツリーでは、任意の数の階層レベルで要件を体系的に整理することができます。

注: 要件 ツリーに、一度に表示した場合に応答に影響がでるほど要素がある場合は、要素は順に表示されます。 ツリーの一番下にあるページ番号のリンクにより、タブに含まれる要素（一度に 1 ページ）を参照できます。 単一のリストとしてすべての要素を表示するには、[すべて] リンクを選択します。
  • キーボード操作 (要件)
    ツリーでのキーボード操作について説明します。
  • 要件ツリーを折りたたんだり展開する
    要件 ツリーを折りたたんだり展開して、表示ニーズに応じて階層レベルの集約と表示を行います。
  • 要件ツリーのフィルタリング
    要件ツリーにフィルタを追加する方法について説明します。
親トピック: 要件ビュー


キーボード操作 (要件)

選択したノードでは、以下のアクションを実行できます。

キー | アクション
Up | 選択項目を上に移動
Down | 選択項目を下に移動
Right | 要素を展開
Left | 要素を折りたたみ
F2 | 要素を編集
Ctrl+C | 要素をコピー
Ctrl+X | 要素を切り取り
Ctrl+V | 要素を貼り付け
Del | 要素を削除
Ctrl+Up | 要素を上に移動
Ctrl+Down | 要素を下に移動
クリック | 要素を選択して、現在の要素として設定
Ctrl + クリック | クリックした要素の選択状況の切り替え、または他の要素をクリックして選択項目への追加/削除
Shift + クリック | 現在の選択要素から新規選択要素までの範囲の選択
Shift+Up | 上の要素を選択
Shift+Down | 下の要素を選択
Enter | 要素の割り当て（割り当てツリーでのみ）
親トピック: 要件ツリー


要件ツリーを折りたたんだり展開する

要件 ツリーを折りたたんだり展開するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリーで要件フォルダを選択し、次のいずれかのオプションで操作を続行します。
    • 要件フォルダ名の左にある 展開 をクリックして、フォルダを展開します。
    • 要件フォルダ名の左にある 折りたたみ をクリックして、フォルダを折りたたみます。
    • フォルダを右クリックして、展開 または 折りたたみ を選択します。 コンテキスト メニューを使用すると、2 つ、3 つまたはすべてのレベルを一度に展開することができます。
親トピック: 要件ツリー


要件ツリーのフィルタリング

サブツリーをフィルタする場合は、選択したノードおよび子ノードのみが表示されます。 他のノードはすべて一時的に非表示となります。 これは、すべての要件のサブセットが記された PDF を生成する場合に特に便利です。

要件 ツリーのサブセットをフィルタするには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリーで要件を右クリックし、サブツリーのフィルタ表示 をクリックします。
    注: これにより、フィルタ リストにカスタム フィルタが作成され、ツールバーに配置されます。 このフィルタを保存する場合は、 [image] (フィルタの編集) をクリックして 詳細 をクリックし、フィルタの名前を入力します。
  3. フィルタを無効にするには、ツールバーのフィルタ リストから <フィルタなし> を選択します。
親トピック: 要件ツリー
関連概念
フィルタ


[要件] ツールバーの機能

要件 > 詳細ビュー

要件 > ドキュメント ビュー

要件ツールバーには、要件を管理するための重要なコマンドがあります。

注: 要件ツールバーのコマンドの一部は、要件 ツリーのコンテキスト メニューからも利用できます。

要件ツールバーには、以下のコマンドが含まれています。

コマンド | アイコン | 説明
詳細ビュー | 要件ビュー | 単一の要件のプロパティを詳しく表示できる、詳細ビュー を表示します。
ドキュメント ビュー | ドキュメント ビュー | すべての要件の選択したプロパティが単一のビューで示される、ドキュメント ビュー を表示します。
要件の新規作成 | 要件の新規作成 | アクティブ プロジェクトに新しい要件を追加します。
子要件の新規作成 | 子要件の新規作成 | 選択した要件に新しい子要件を追加します。
編集 | 編集 | 選択した要件を編集します。
削除 | 削除 | 選択した要件に廃止マークを付けるか、完全に破棄します。 廃止された要件は、非表示、表示、回復することができます。
切り取り | 切り取り | 要件 ツリーから要件を切り取り、クリップボードに保存します。
コピー | コピー | 要件 ツリーからクリップボードに、要件をコピーします。
貼り付け | 貼り付け | クリップボードから 要件 ツリーに、要件を貼り付けます。
子として貼り付け | 子として貼り付け | クリップボードから現在選択されている要件に、要件を子要件として貼り付けます。
上へ移動 | 上へ移動 | 要件 ツリーで要件を上へ移動します。
下へ移動 | 下へ移動 | 要件 ツリーで要件を下へ移動します。
検索 | 検索 | 構成可能なパラメータに基づいてアクティブ プロジェクトのすべての要件を検索します。
置換 | 置換 | 検出された値のインスタンスを新しい値で置き換えます。
フィルタの新規作成 | フィルタの新規作成 | 要件 ツリーに対して、新しいフィルタを作成します。
フィルタ |  | 要件 ツリーに使用できるフィルタを一覧表示します。
フィルタの編集 | フィルタの編集 | 選択したフィルタを編集します。
フィルタの削除 | フィルタの削除 | 選択したフィルタを削除します。
フィルタのコピー | フィルタの削除 | 選択したフィルタをコピーします。
変更点のみ表示 | 変更点のみ表示 | 要件およびそのプロパティに加えた最近の変更点を表示します。
承認 | 承認 | 要件およびそのプロパティに加えた変更点を承認します。
直接カバレッジの表示 完全カバレッジの表示 |  | 直接カバレッジ モードと完全カバレッジ モードを切り替えます。 このボタンは 詳細ビュー では無効になっています。
PDF としてダウンロード | PDF としてダウンロード | 要件 ツリーで現在表示されているすべてのノードが含まれる PDF を生成し、ダウンロードします。 このボタンは 詳細ビュー では無効になっています。
親トピック: 要件ビュー


[要件] の [ドキュメント ビュー]

要件 > ドキュメント ビュー

ドキュメント ビュー には、[合格]、[失敗]、[未実行]、[未カバー] のテストの数と割合を含め、アクティブなプロジェクトに割り当てられているすべてのテストのステータスが表示されます。ドキュメント ビュー には、このカバレッジ ステータス情報が以下の色で「温度分布」グラフで表示されます。

色 | 説明
緑色 | 合格したテスト。
赤色 | 失敗したテスト。
オレンジ色 | まだ実行されていないテスト。
灰色 | 他のステータスのテスト。

テストでカバーされていない要件は [未カバー] と表示されます。

ドキュメント ビュー には、列としてすべてのカスタム要件プロパティが表示されます。

注: テストの合計は、現在表示されているすべてのテストに関して親レベルになります。要件 ツリーにフィルタを適用した場合、テストの合計はフィルタリングされた要件にのみ基づきます。たとえば、要件の合計にはフィルタによって選択されるすべての子要件からのテストが含まれ、プロジェクトの合計にはフィルタによって選択されるすべての要件からのテストが含まれます。

ドキュメント ビュー では、ユーザーおよびプロジェクトごとにそれぞれで表示設定が保存されます。

親トピック: 要件ビュー


要件履歴

Silk Central では、要件に加えられたすべての変更の完全な履歴が提供されます。履歴情報は読み取り専用で、編集したり完全に削除することはできません。

ツールバーの 変更点のみ表示 をクリックすることによりアクセスできる 最近の変更点 フィルタを使用すると、要件に対して行われた最近の変更と追加の内容を効率的に表示および承認できます。

注: 完全に破棄 オプションを使用して要件を削除すると、廃止としてマークされた要件が削除されます。最近の変更をすべて承認した場合には、要件が属するプロジェクトの履歴ファイルに変更履歴の新しいエントリが追加されます。
  • 最近の変更点を表示する
    要件に対する最近の変更点を表示します。
  • 要件の履歴を追跡する
    要件の履歴を追跡する方法について説明します。
  • [要件] の [履歴] ページ
    選択した要件またはプロジェクトの改訂履歴が詳しく表示されます。
親トピック: 要件ビュー


最近の変更点を表示する

要件に対する最近の変更点を表示するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 変更点のみ表示 をクリックして、最後の変更承認以降に変更された要件を除くすべての要件を除外します。
    注: 最近の変更点フィルタが、フィルタ リスト ボックスで自動的に選択されます。
  3. 変更内容を確認したら、 承認 をクリックして、変更を承認できます。 [承認] 機能によって、"最近の変更点" フィルタはリセットされます。
  4. すべて表示 を再びクリックすると、フィルタが解除され、すべての要件が表示されます。
親トピック: 要件履歴
関連概念
最近の変更点


要件の履歴を追跡する

要件の履歴を表示するには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリー から要件を選択します。
  3. 履歴 タブをクリックします。
  4. 省略可能：Silk Central プロジェクトと Caliber プロジェクトの間で要件管理の統合が有効になっている場合は、履歴 ページの Caliber を開く をクリックして、同期された要件の履歴を Caliber で直接表示することができます。
Silk Central がログを取ったすべてのリビジョンのプロパティが表形式で表示されます。
親トピック: 要件履歴


[要件] の [履歴] ページ

要件 > 詳細ビュー > <要件> > 履歴

履歴 ページには、選択した要件またはプロジェクトの改訂履歴が詳しく表示されます。以下の作業を行うと、要件履歴に新たな記載が追加されます。

  • 新しい要件を追加する
  • 要件を編集する
  • 要件に廃止マークを付ける
  • 要件に添付情報を追加する
  • 要件から添付情報を削除する
  • MS Word または MS Excel から要件をインポートまたは更新する

変更ごとに、次の列がページに表示されます。

列 | 説明
リビジョン | リビジョン番号。1 から n。
変更日時 | 変更の日付と時刻。
変更者 | 変更を行ったユーザー。
メモ | 自動生成される変更の説明。例：「削除されました」または「作成されました」など。
注: ページに、一度に表示した場合に応答に影響が出るほど多くの要素がある場合、要素は順に表示されます。ページの下部にあるナビゲーション ツールバーを使用して、要素全体をブラウズすることができます。
親トピック: 要件履歴


テスト

このセクションでは、Silk Central でテストを管理する方法について説明します。

テストまたはテスト ケースは、入力値、実行の前提条件、期待する結果、実行の事後条件のセットであり、特定の目的またはテスト条件に対して開発されます（あるプログラム パスの試行や、特定の要件に対する適合性の検証など [IEEE 610 以降]）。Silk Central は、さまざまなテスト タイプをサポートしており、いくつかの方法でテストを構造化できます。 テスト 領域を使用すると、システム開発ライフサイクル全体にわたって絶えずテストを管理できます。自動テストや手動テストの作成、スケジュールおよび管理を行うことができます。ファイルやリンクを添付情報としてアップロードし、テスト コンテナやテストに関連付けることができます。見つかった問題とその発見につながったテストを簡単に関連付けできます。また、領域内のテストのすべての変更の履歴も追跡できます。

  • テストと統合を設定する
    テスト フレームワークの構築を始める前に、少なくともプロジェクトと製品を設定する必要があります。自動テストを作成する予定があれば、ソース管理プロファイルも設定する必要があります。
  • テスト資産を構造化する
    Silk Central は、ある特定の製品のバージョンとビルドを関連させてテスト実行の結果をトラッキングします。このため、テストを作成する前に、製品 を定義する必要があります。
  • テストを管理する
    テスト フレームワークに新しいテストを追加したり、既存のテストを設定します。
  • テスト プロパティを設定する
    属性、パラメータ、添付ファイル、成功条件などのテスト プロパティを設定します。
  • テストを試験実行する
    テストを試験実行して、テストが意図したとおりに動作するかどうかを確認します。
  • ライブラリ
    ライブラリは、複数のプロジェクトのテスト間で共有されるテスト ステップキーワードのコレクションです。
  • 要件とテストを関連付ける
    要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。
  • テスト レポート
    テスト関連のレポートについて説明します。
  • 割り当て済み実行計画
    テストを実行計画に割り当てると、開発とテストの期間中、絶えずテスト実行を管理することができます。
  • テスト ビュー
    テスト 領域で利用可能なビューについて説明します。
親トピック: Silk Central ヘルプ


テストと統合を設定する

テスト フレームワークの構築を始める前に、少なくともプロジェクトと製品を設定する必要があります。自動テストを作成する予定があれば、ソース管理プロファイルも設定する必要があります。フィルタ、プロパティ、属性などのほかの設定を行う必要がある場合もあります。これらのタスクの実行には、スーパーユーザー、システム管理者、またはプロジェクト マネージャの権限が必要です。

  • 製品、コンポーネント、バージョン、ビルドを管理する
    製品、製品コンポーネント、製品バージョン、および製品バージョンのビルド番号を作成および整理する方法について説明します。
  • ソース管理プロファイル
    ソース管理プロファイルにより、Silk Central を外部のソース管理システムと統合できます。ソース管理プロファイルを定義することで、Silk Central の実行サーバーがテスト実行用のプログラム ソースを取得する場所を定義できます。
  • ステップ プロパティ
    ステップ プロパティを使用して手動テスト ステップを追加プロパティで拡張する方法について説明します。
  • 属性
    カスタム属性を使用して、テストと実行計画の情報をカスタマイズする方法について説明します。
  • データ駆動型テスト向けのデータ ソース
    データ駆動型テストとは、スプレッドシートやデータベースなど、既存のデータ ソースに含まれる値を元に行うテストのことです。データ ソースは、プロジェクトごとの範囲で管理されます。
  • フィルタ
    フィルタを使用して、無関係な情報を除外しながら必要な情報を確実に見つける方法について説明します。
  • 変更通知
    要件やテストが他のユーザーによって変更されたときの電子メール通知の設定方法について説明します。
親トピック: テスト


製品、コンポーネント、バージョン、ビルドを管理する

Silk Central では、製品、製品コンポーネント、製品バージョン、および製品バージョンのビルド番号を作成および整理できます。そして、製品の指定項目はテストに関連付けられ、バージョンおよびビルドは実行計画に関連付けられます。Issue Manager で事前に定義された製品およびコンポーネントをインポートすることもできます。

  • コンポーネントは、テストの目的でそれぞれ追跡される別個の製品要素です。
  • バージョンは、開発およびテストの目的でそれぞれ追跡される製品リリースです。
  • ビルドは、開発およびテストの目的でそれぞれ追跡されるバージョンの繰り返しです。

また Silk Central により、テスト向けにオペレーティング システムなどのプラットフォーム指定をセットアップできます。製品、バージョン、およびビルド セットアップと同様に、プラットフォームには名前、説明、およびアクティブまたは非アクティブのステータスを指定できます。

  • 製品を管理する
    Silk Central で製品を設定する方法について説明します。
  • コンポーネントを管理する
    製品内のコンポーネントを設定する方法について説明します。
  • バージョンを管理する
    製品内のバージョンを設定する方法について説明します。
  • ビルドを管理する
    バージョン内のビルドを管理する方法について説明します。
  • プラットフォームを管理する
    Silk Central でプラットフォームを設定する方法について説明します。
親トピック: テストと統合を設定する
親トピック: 管理


製品を管理する

Silk Central で製品を設定する方法について説明します。

  • 製品を追加する
    新しい製品を追加して、テスト と関連付けます。
  • 製品を編集する
    既存の製品を編集します。
  • 製品をアクティブまたは非アクティブにする
    Silk Central で既存の製品をアクティブまたは非アクティブにする方法について説明します。
  • 製品リストをソートする
    製品をリスト内で上下に移動したり、製品リストをアルファベット順にソートしたりします。
  • 製品を削除する
    既存の製品を削除して、製品リストから恒久的に削除します。
  • [製品] 設定ページ
    このページは、製品、コンポーネント、バージョン、およびビルドの設定に使用します。
親トピック: 製品、コンポーネント、バージョン、ビルドを管理する


製品を追加する

新しい製品を追加するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品の新規作成 をクリックします。 製品の新規作成 ダイアログ ボックスが表示されます。
  4. 名前 フィールドに、新しい製品の名前を入力します。
  5. 説明 フィールドに、製品の説明を入力します。
  6. アクティブ チェック ボックスをオンにして、この製品と テスト との関連付けを有効にします。
  7. OK をクリックして、製品を保存します。
    注: 製品を作成すると、Silk Central によって、その製品に対するデフォルトのバージョン 1.0 とデフォルトのビルド 1 が、自動的に作成されます。
親トピック: 製品を管理する


製品を編集する

既存の製品を編集するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 編集する製品の アクション 列で、 編集 をクリックします。 製品の編集 ダイアログ ボックスが表示されます。
  4. 選択した製品の 名前、説明、および アクティブ ステータスに必要なすべての変更を加え、OK をクリックします。
親トピック: 製品を管理する


製品をアクティブまたは非アクティブにする

既存の製品をアクティブまたは非アクティブにするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. アクティブまたは非アクティブにする製品に関連付けられた ステータス アイコンをクリックします。 確認ダイアログ ボックスに、アクティブ化/非アクティブ化を確認するメッセージが表示されます。
  4. メッセージを確認して、製品のステータスを [アクティブ] と [非アクティブ] で切り替えます。
親トピック: 製品を管理する
親トピック: バージョンを管理する


製品リストをソートする

製品をリスト内で上下に移動したり、製品リストを名前のアルファベット順にソートしたりするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 移動する項目の アクション 列で、 上へ移動 または 下へ移動 をクリックします。
  4. リストを名前のアルファベット順にソートするには、名前でソート をクリックします。
親トピック: 製品を管理する


製品を削除する

既存の製品を削除するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 削除対象の製品を非アクティブにします。 詳細については、「製品をアクティブおよび非アクティブにする」を参照してください。
  4. 削除する製品の アクション 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  5. はい をクリックして削除を実行します。または、いいえ をクリックして削除を中止します。
親トピック: 製品を管理する
関連タスク
製品をアクティブまたは非アクティブにする


[製品] 設定ページ

管理 > 製品/バージョン/ビルド > 製品

このページは、製品、コンポーネント、バージョン、およびビルドの設定に使用します。

製品の新規作成 をクリックして、新しい製品を作成します。名前でソート をクリックして、製品を名前のアルファベット順にソートします。

リスト内の製品ごとに、次の列がページに表示されます。

列 | 説明
アクション 製品に対して次のアクションを実行できます。
製品をリストの 1 つ上の行に移動します。
製品をリストの 1 つ下の行に移動します。
製品の名前、説明、およびステータスを編集します。
製品を完全に削除します。製品は削除する前に非アクティブにする必要があります。製品が既にテストに関連付けられている場合は削除できません。
名前 | GUI およびレポートに表示される製品の名前。製品の名前をクリックして製品のコンポーネント、バージョン、およびビルドを変更します。
説明 | 製品のテキスト説明。
ステータス | 製品のステータス（[アクティブ] または [非アクティブ]）。ステータスをクリックして、ステータスを [アクティブ] と [非アクティブ] で切り替えます。
作成日時 | 製品が作成された日時。
作成者 | この製品を作成したユーザー。

ページには、選択した製品に含まれているコンポーネント、バージョン、およびビルドの詳細が表示されます。

製品のコンポーネントについては、次の列が表示されます。

列 | 説明
アクション | この列では、コンポーネントを削除できます。
名前 | コンポーネントの名前。クリックすると、コンポーネントの編集 ダイアログ ボックスが開きます。
説明 | コンポーネントの説明。
作成日時 | コンポーネントが作成された日時。
作成者 | コンポーネントを作成したユーザー。
ステータス | コンポーネントのステータス。アクティブ または 非アクティブ。クリックしてステータスを切り替えます。

コンポーネントの新規作成 をクリックして、新しいコンポーネントを作成します。名前でソート をクリックして、コンポーネントを名前のアルファベット順にソートします。更新 をクリックしてコンポーネント リストを保存します。

製品のバージョンについては、次の項目が表示されます。

項目 | 説明
アクション | この列では、バージョンを削除したり、バージョンをリスト内で上下に移動したりできます。
名前 | バージョンの名前。クリックすると、バージョンの編集 ダイアログ ボックスが開きます。
説明 | バージョンの説明。
作成日時 | バージョンが作成された日時。
作成者 | バージョンを作成したユーザー。
ステータス | バージョンのステータス。アクティブ または 非アクティブ。クリックしてステータスを切り替えます。

バージョンの新規作成 をクリックして、新しいバージョンを作成します。名前でソート をクリックして、バージョンを名前のアルファベット順にソートします。

製品のビルドについては、次の項目が表示されます。

項目 | 説明
アクション | ビルドを削除したり、ビルドにタグ付けしたりできます。
名前 | ビルドの名前。クリックすると、ビルドの編集 ダイアログ ボックスが開きます。
説明 | ビルドの説明。
作成日時 | ビルドが作成された日時。
作成者 | ビルドを作成したユーザー。
ステータス | ビルドのステータス。アクティブ または 非アクティブ。クリックしてステータスを切り替えます。

ビルドの新規作成 をクリックして、新しいビルドを作成します。名前でソート をクリックして、ビルド リストを名前のアルファベット順にソートします。更新 をクリックしてコンポーネント リストを保存します。

注: これらのボタンを有効にするには、ビルド リスト ボックスで特定のバージョンを選択する必要があります。

製品リストに戻るには、戻る をクリックします。

親トピック: 製品を管理する


コンポーネントを管理する

コンポーネントは、テストの目的でそれぞれ追跡される別個の製品要素です。

  • コンポーネントを追加する
    新しいコンポーネントを追加して、製品のテスト時に個別に追跡します。
  • コンポーネントを編集する
    製品内の既存のコンポーネントを編集します。
  • コンポーネントをアクティブまたは非アクティブにする
    製品の既存のコンポーネントをアクティブまたは非アクティブにします。
  • コンポーネント リストをソートする
    コンポーネントをリスト内で上下に移動したり、コンポーネント リストをアルファベット順にソートしたりします。
  • コンポーネントを削除する
    既存のコンポーネントを製品から削除します。
親トピック: 製品、コンポーネント、バージョン、ビルドを管理する


コンポーネントを追加する

新しいコンポーネントを製品に追加するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. コンポーネントの新規作成 をクリックします。 コンポーネントの新規作成 ダイアログ ボックスが表示されます。
  5. 名前 フィールドに、新しいコンポーネントの名前を入力します。
  6. 説明 フィールドに、コンポーネントの説明を入力します。
  7. タイプ からコンポーネントのタイプを選択します。 選択可能な値は、ソフトウェア と ドキュメント です。
  8. アクティブ チェック ボックスをオンにして、このコンポーネントと製品との関連付けを有効にします。
  9. OK をクリックしてコンポーネントを保存します。この操作を中止する場合は、キャンセル をクリックします。
親トピック: コンポーネントを管理する


コンポーネントを編集する

製品内の既存のコンポーネントを編集するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. 編集対象のコンポーネントを選択します。
  5. コンポーネントの編集 ダイアログ ボックスが表示され、選択されているコンポーネントの 名前、説明、および アクティブ ステータスが表示されます。 必要な変更をすべて行った後、OK をクリックします。
    注: コンポーネントのタイプを編集するには、まずそのコンポーネントを非アクティブにする必要があります。 その他の情報については、「コンポーネントをアクティブおよび非アクティブにする」を参照してください。
親トピック: コンポーネントを管理する


コンポーネントをアクティブまたは非アクティブにする

既存のコンポーネントをアクティブまたは非アクティブにするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. アクティブまたは非アクティブにするコンポーネントに関連付けられた ステータス アイコンをクリックします。 確認ダイアログ ボックスに、アクティブ化/非アクティブ化を確認するメッセージが表示されます。
  5. メッセージを確認して、コンポーネントのステータスを [アクティブ] と [非アクティブ] で切り替えます。
親トピック: コンポーネントを管理する


コンポーネント リストをソートする

コンポーネントをリスト内で上下に移動したり、コンポーネント リストを名前のアルファベット順にソートしたりするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. コンポーネント タイプ リスト ボックスから、コンポーネントを表示するコンポーネント タイプを選択します。
  5. 移動する項目の アクション 列で、 上へ移動 または 下へ移動 をクリックします。
  6. リストを名前のアルファベット順にソートするには、名前でソート をクリックします。
親トピック: コンポーネントを管理する


コンポーネントを削除する

既存のコンポーネントを製品から削除するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. 削除対象のコンポーネントを非アクティブにします。 その他の情報については、「コンポーネントをアクティブおよび非アクティブにする」を参照してください。
  5. コンポーネントの [アクション] 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  6. はい をクリックして削除を実行します。または、いいえ をクリックして削除を中止します。
親トピック: コンポーネントを管理する


バージョンを管理する

バージョンは、開発およびテストの目的でそれぞれ追跡される製品リリースです。

  • バージョンを追加する
    新しいバージョンを製品に追加して、開発およびテストの目的で特定のリリースを個別に追跡します。
  • バージョンを編集する
    製品内の既存のバージョンを編集します。
  • 製品をアクティブまたは非アクティブにする
    Silk Central で既存の製品をアクティブまたは非アクティブにする方法について説明します。
  • バージョン リストをソートする
    バージョンをリスト内で上下に移動したり、バージョン リストをアルファベット順にソートしたりします。
  • バージョンを削除する
    既存のバージョンを製品から削除して、バージョン リストから恒久的に削除します。
親トピック: 製品、コンポーネント、バージョン、ビルドを管理する


バージョンを追加する

新しいバージョンを製品に追加するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. バージョンの新規作成 をクリックします。 バージョンの新規作成 ダイアログ ボックスが表示されます。
  5. 名前 フィールドに、新しいバージョンの名前を入力します。
  6. 説明 フィールドに、バージョンの説明を入力します。
  7. アクティブ チェック ボックスをオンにして、このバージョンと製品との関連付けを有効にします。
  8. OK をクリックしてバージョンを保存します。この操作を中止する場合は、キャンセル をクリックします。
親トピック: バージョンを管理する


バージョンを編集する

製品内の既存のバージョンを編集するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. 編集対象のバージョンを選択します。 バージョンの編集 ダイアログ ボックスが表示されます。
  5. 選択したバージョンの 名前、説明、および アクティブ ステータスに必要なすべての変更を加え、OK をクリックします。
親トピック: バージョンを管理する


バージョン リストをソートする

バージョンをリスト内で上下に移動したり、バージョン リストを名前のアルファベット順にソートしたりするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. 移動する項目の アクション 列で、 上へ移動 または 下へ移動 をクリックします。
  5. リストを名前のアルファベット順にソートするには、名前でソート をクリックします。
親トピック: バージョンを管理する


バージョンを削除する

既存のバージョンを製品から削除するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. 削除対象のバージョンを非アクティブにします。 詳細については、「バージョンをアクティブおよび非アクティブにする」を参照してください。
  5. 削除する製品の アクション 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  6. はい をクリックして削除を実行します。または、いいえ をクリックして削除を中止します。
親トピック: バージョンを管理する


ビルドを管理する

ビルドは、開発およびテストの目的でそれぞれ追跡されるバージョンの繰り返しです。

  • ビルドを追加する
    新しいビルドを追加して、バージョンの特定のイテレーションをテストします。
  • ビルドを編集する
    バージョン内の既存のビルドを編集します。
  • ビルドをアクティブまたは非アクティブにする
    バージョンの既存のビルドをアクティブまたは非アクティブにします。
  • ビルド リストをソートする
    ビルドをリスト内で上下に移動したり、ビルド リストをアルファベット順にソートしたりします。
  • ビルドにタグ付けする
    タグ付けすることにより、ビルドの特定のテスト実行を識別できます。
  • ビルドを削除する
    既存のビルドをバージョンから削除します。
親トピック: 製品、コンポーネント、バージョン、ビルドを管理する


ビルドを追加する

新しいビルドをバージョンに追加するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. バージョンのビルド リスト ボックスで、ビルドの追加先となるバージョンを選択します。
  5. ビルドの新規作成 をクリックします。 ビルドの新規作成 ダイアログ ボックスが表示されます。
  6. 名前 フィールドに、新しいビルドの名前を入力します。
  7. 説明 フィールドに、ビルドの説明を入力します。
  8. アクティブ チェック ボックスをオンにして、このビルドとバージョンとの関連付けを有効にします。
  9. OK をクリックしてビルドを保存します。この操作を中止する場合は、キャンセル をクリックします。
親トピック: ビルドを管理する


ビルドを編集する

バージョン内の既存のビルドを編集するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. 編集対象のビルドを選択します。
  5. ビルドの編集 ダイアログ ボックスが表示され、選択されているビルドの 名前、説明、および アクティブ ステータスが表示されます。 必要な変更をすべて行った後、OK をクリックします。
  6. ビルドにタグ付けするには、タグの設定 チェック ボックスをオンにします。
親トピック: ビルドを管理する


ビルドをアクティブまたは非アクティブにする

既存のビルドをアクティブまたは非アクティブにするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. アクティブまたは非アクティブにするビルドに関連付けられた ステータス アイコンをクリックします。 確認ダイアログ ボックスに、アクティブ化/非アクティブ化を確認するメッセージが表示されます。
  5. メッセージを確認して、ビルドのステータスを [アクティブ] と [非アクティブ] で切り替えます。
親トピック: ビルドを管理する


ビルド リストをソートする

ビルドをリスト内で上下に移動したり、ビルド リストを名前のアルファベット順にソートしたりするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. バージョンのビルド リスト ボックスから、ビルドを表示するバージョンを選択します。
  5. 移動する項目の アクション 列で、 上へ移動 または 下へ移動 をクリックします。
  6. リストを名前のアルファベット順にソートするには、名前でソート をクリックします。
親トピック: ビルドを管理する


ビルドにタグ付けする

タグ付けされたビルドの実行を削除できます。タグ付けされたビルドを含む実行を削除しようとすると、警告が表示され、アクションを確認する必要があります。実行ノードを右クリックして一括削除 (すべてまたは特定の期間) を実行する場合、タグ付けされたビルドは削除されません。

既存のビルドにタグ付けするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. ビルド セクションで、タグ付けするビルドの アクション 列にある ビルドにタグを設定 をクリックします。 確認ダイアログ ボックスが表示されます。
  5. はい をクリックしてタグ付けを実行します。または、いいえ をクリックしてタグ付けを中止します。
親トピック: ビルドを管理する


ビルドを削除する

既存のビルドをバージョンから削除するには：
  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. 製品 タブをクリックします。 製品 ページに、既存のすべての製品が一覧表示されます。
  3. 製品名をクリックします。 その製品の 製品の詳細 ページが開きます。
  4. 削除対象のビルドを非アクティブにします。 詳細については、「ビルドをアクティブおよび非アクティブにする」を参照してください。
  5. ビルドの [アクション] 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  6. はい をクリックして削除を実行します。または、いいえ をクリックして削除を中止します。
親トピック: ビルドを管理する


プラットフォームを管理する

テスト で指定するオペレーティング システムなどのプラットフォームを管理します。製品、バージョン、およびビルド セットアップと同様に、プラットフォームには名前、説明、およびアクティブまたは非アクティブのステータスを指定できます。

  • プラットフォームを追加する
    テスト 向けに新しいプラットフォーム指定を追加します。
  • プラットフォームを編集する
    既存のプラットフォームを編集します。
  • プラットフォームをアクティブまたは非アクティブにする
    Silk Central で既存のプラットフォームをアクティブまたは非アクティブにします。
  • プラットフォーム リストをソートする
    プラットフォームをリスト内で上下に移動したり、プラットフォーム リストをアルファベット順にソートしたりします。
  • プラットフォームを削除する
    既存のプラットフォームを削除して、プラットフォーム リストから恒久的に削除します。
  • [プラットフォーム] 設定ページ
    このページは、プラットフォームの設定に使用します。
親トピック: 製品、コンポーネント、バージョン、ビルドを管理する


プラットフォームを追加する

新しいプラットフォームを追加するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. プラットフォーム タブをクリックします。 プラットフォーム ページに、既存のすべてのプラットフォームが一覧表示されます。
  3. プラットフォームの新規作成 をクリックします。 プラットフォームの新規作成 ダイアログ ボックスが表示されます。
  4. 名前 フィールドに、新しいプラットフォームの名前を入力します。
  5. 説明 フィールドに、プラットフォームの説明を入力します。
  6. アクティブ チェック ボックスをオンにして、このプラットフォームと テスト との関連付けを有効にします。
  7. OK をクリックして、プラットフォームを保存します。
親トピック: プラットフォームを管理する


プラットフォームを編集する

既存のプラットフォームを編集するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. プラットフォーム タブをクリックします。 プラットフォーム ページに、既存のすべてのプラットフォームが一覧表示されます。
  3. 編集するプラットフォームの アクション 列で、 編集 をクリックします。
  4. プラットフォームの編集 ダイアログ ボックスが表示され、選択されているプラットフォームの 名前、説明、および アクティブ ステータスが表示されます。 必要な変更をすべて行った後、OK をクリックします。
親トピック: プラットフォームを管理する


プラットフォームをアクティブまたは非アクティブにする

注: テスト に関連付けられているプラットフォームは非アクティブにできません。

既存のプラットフォームをアクティブまたは非アクティブにするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. プラットフォーム タブをクリックします。 プラットフォーム ページに、既存のすべてのプラットフォームが一覧表示されます。
  3. アクティブまたは非アクティブにするプラットフォームに関連付けられた ステータス アイコンをクリックします。 確認ダイアログ ボックスに、アクティブ化/非アクティブ化を確認するメッセージが表示されます。
  4. メッセージを確認して、プラットフォームのステータスを [アクティブ] と [非アクティブ] で切り替えます。
親トピック: プラットフォームを管理する


プラットフォーム リストをソートする

プラットフォームをリスト内で上下に移動したり、プラットフォーム リストを名前のアルファベット順にソートしたりするには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. プラットフォーム タブをクリックします。 プラットフォーム ページに、既存のすべてのプラットフォームが一覧表示されます。
  3. 移動する項目の アクション 列で、 上へ移動 または 下へ移動 をクリックします。
  4. プラットフォーム リストを名前のアルファベット順にソートするには、名前でソート をクリックします。
親トピック: プラットフォームを管理する


プラットフォームを削除する

既存のプラットフォームを削除するには：

  1. メニューで、管理 > 製品/バージョン/ビルド をクリックします。
  2. プラットフォーム タブをクリックします。 プラットフォーム ページに、既存のすべてのプラットフォームが一覧表示されます。
  3. 削除対象のプラットフォームを非アクティブにします。 詳細については、「プラットフォームをアクティブおよび非アクティブにする」を参照してください。
  4. 削除するプラットフォームの アクション 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  5. はい をクリックして削除を実行します。または、いいえ をクリックして削除を中止します。
親トピック: プラットフォームを管理する
関連タスク
プラットフォームをアクティブまたは非アクティブにする


[プラットフォーム] 設定ページ

管理 > プラットフォーム

このページは、プラットフォームの設定に使用します。

新しいプラットフォームを作成するには、プラットフォームの新規作成 をクリックします。詳細については、「プラットフォームを追加する」を参照してください。

プラットフォーム リストを名前のアルファベット順にソートするには、名前でソート をクリックします。詳細については、「プラットフォーム リストをソートする」を参照してください。

リスト内のプラットフォームごとに、次の列がページに表示されます。

列 | 説明
アクション ユーザーは、プラットフォームに対して次のアクションを実行できます。
プラットフォームをリストの 1 つ上の行に移動します。
プラットフォームをリストの 1 つ下の行に移動します。
プラットフォームを完全に削除します。プラットフォームは削除する前に非アクティブにする必要があります。プラットフォームが既にテストに関連付けられている場合は削除できません。
名前 | GUI およびレポートに表示されるプラットフォームの名前。プラットフォームの名前をクリックしてプラットフォームの名前、説明、およびステータスを変更します。
説明 | プラットフォームのテキスト説明。
ステータス | プラットフォームのステータス（[アクティブ] または [非アクティブ]）。ステータスをクリックして、ステータスを [アクティブ] と [非アクティブ] で切り替えます。
作成日時 | プラットフォームが作成された日時。
作成者 | このプラットフォームを作成したユーザー。
親トピック: プラットフォームを管理する
関連タスク
プラットフォームを追加する
プラットフォーム リストをソートする


ソース管理プロファイル

ソース管理プロファイルにより、Silk Central を外部のソース管理システムと統合できます。ソース管理プロファイルを定義することで、Silk Central の実行サーバーがテスト実行用のプログラム ソースを取得する場所を定義できます。

Silk Central はソース管理ツリーをチェックアウトし、実行可能なソース ファイルで作業ディレクトリを生成するので、実行サーバーにはソース ファイルを格納するためにソース ファイルの 2 倍の空きディスク領域が必要です。

カスタム プラグインをインストールすることにより、その他のソース管理システムを構成することができます。詳細については、『Silk Central API ヘルプ』を参照してください。現在、以下のソース管理システムは Silk Central で特別な設定をせずにサポートされています。

  • AccuRev
    AccuRev ソース管理プロファイルを構成する方法について説明します。
  • Apache Commons 仮想ファイルシステム
    仮想ファイル システムのソース管理プロファイルを構成する方法について説明します。
  • Git
    Git ソース管理プロファイルを構成する方法について説明します。
  • Microsoft Team Foundation Server
    Team Foundation Server ソース管理プロファイルを構成する方法について説明します。
  • Silk Test Workbench
    Silk Test Workbench ソース管理プロファイルを構成する方法について説明します。
  • StarTeam
    StarTeam ソース管理プロファイルを構成する方法について説明します。
  • Subversion
    Subversion ソース管理プロファイルを設定する方法について説明します。
  • Silk TestPartner
    TestPartner ソース管理プロファイルを構成する方法について説明します。
  • Universal Naming Convention
    Universal Naming Convention ソース管理プロファイルを構成する方法について説明します。
  • ソース管理プロファイルを削除する
    プロファイルが不要になった場合に、既存のソース管理プロファイルを削除します。
  • [ソース管理プロファイル] ページ
    内部または外部のソース管理システムを Silk Central に統合するために構成された問題追跡プロファイルがすべて一覧表示されます。
親トピック: テストと統合を設定する
親トピック: プロジェクト設定
関連概念
API ヘルプ


AccuRev

このセクションでは、AccuRev ソース管理プロファイルを構成する方法について説明します。

AccuRev は、ストリーム ベースのアーキテクチャを利用して、複雑な平行開発および分散開発環境を解決することで、開発プロセスを加速させ、資産の再利用を改善させることができるソフトウェア構成管理ツールです。

Silk Central の統合が現在サポートしている AccuRev のバージョンは次の通りです：AccuRev 6.2

  • AccuRev ソース管理プロファイルを追加する
    AccuRev ソース管理プロファイルを作成して、AccuRev からテスト実行用のプログラム ソースを取得します。
  • AccuRev ソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の AccuRev のソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


AccuRev ソース管理プロファイルを追加する

AccuRev ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、ソース管理プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. ソース管理システム リスト ボックスから AccuRev を選択します。
  6. 必要に応じて、有効な AccuRev ユーザー名 と パスワード を入力します。
  7. アクセスする AccuRev サーバーの AccuRev サーバー の名前を入力します。AccuRev のデフォルト ポートを使用していない場合は、<サーバー名>:<ポート番号> 形式で入力します。
  8. AccuRev ストリーム の名前 (「backing stream」など) を入力します。
  9. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  10. このプロファイルで使用する プロジェクト パス を入力します。参照 をクリックして、プロジェクト パスの選択 ダイアログ ボックスを開きます。 プロジェクト パスの選択 ダイアログ ボックスが開きます。ツリー ビューから対象のプロジェクト パスを選択し、OK をクリックします。このフィールドを空欄のままにすると、プロジェクト パスはルート ディレクトリに設定されます。
  11. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: AccuRev


AccuRev ソース管理プロファイルを編集する

AccuRev ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. ユーザー名 と パスワード を編集します。 これらの認証情報は、ユーザーのリポジトリにアクセスするために使われます。
  6. アクセスする AccuRev サーバーの AccuRev サーバー の名前を編集します。AccuRev のデフォルト ポートを使用していない場合は、<サーバー名>:<ポート番号> 形式で入力します。
  7. AccuRev ストリーム の名前 (「backing stream」など) を編集します。
  8. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を編集します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  9. このプロファイルで使用する プロジェクト パス を編集します。
  10. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: AccuRev


Apache Commons 仮想ファイルシステム

このセクションでは、仮想ファイル システム（VFS）のソース管理プロファイルを構成する方法について説明します。

VFS とは、実際のファイル システムの上に位置する抽象化層です。VFS は、クライアント アプリケーションが様々なファイル システムに同じ方法でアクセスできるようにすることを目的としています。Apache Commons VFS は、多様なファイル システムへアクセスするための、単一の API を提供しています。これにより、様々なソースからのファイル群を、単一のビューで表すことができます。Silk Central が VFS に対して現在サポートしているプロトコルは、以下のとおりです。

プロトコル
説明
http
指定されたファイルをコピー。また、このプロトコル タイプでは、ZIP、JAR、およびその他の ZIP したファイルのコピーと解凍がサポートされています。.zip ファイルは http サーバーに対して指定する必要があります。たとえば、zip:http://myTestServer/myTests.zip のようになります。.zip ファイルは、実行サーバー上で抽出されます。
ftp
指定されたファイルをコピー。また、このプロトコル タイプでは、ZIP、JAR、およびその他の ZIP したファイルのコピーと解凍がサポートされています。
smb
サーバー メッセージ ブロック (smb) は、すべてのファイルおよびフォルダをコピーします。このプロトコルは、UNC プロファイルの代わりに使用できます。たとえば、VFS smb パス smb://server-name/shared-resource-path は、UNC パス \\server-name\shared-resource-path に相当します。
注: ソース管理に VFS を使用する新しい ProcessExecutor テストを作成する場合は、実行可能ファイル名 フィールドで実行可能ファイルの完全パスを指定する必要があります。
  • VFS ソース管理プロファイルを追加する
    VFS ソース管理プロファイルを作成して、VFS からテスト実行のプログラム ソースを取得します。
  • VFS ソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の VFS ソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


VFS ソース管理プロファイルを追加する

VFS ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、ソース管理プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. VFS を ソース管理システム リスト ボックスから選択します。
  6. アクセスする VFS リポジトリ の URL を入力します。このフィールドでは、大文字と小文字が区別されます。 適切なプロトコル タイプを URL に指定します。
    FTP
    ftp://<FTP サーバーの URL>
    HTTP
    Http://<HTTP サーバーの URL>
    SMB
    smb://<Samba サーバーの URL>
    注: HTTP、FTP、および SMB が、また ZIP ファイルに対してもサポートされています。ZIP ファイルの指定には、<ZIP ファイル タイプ>:<プロトコル>://<ZIP ファイルをポイントするサーバーの URL> のように、ZIP ファイルのタイプを含むように URL を次のように調整する必要があります。たとえば次のようになります。zip:http://193.80.200.135/<パス>/archive.zip または jar:http://193.80.200.135/<パス>/archive.jar。
  7. ユーザー名 と パスワード に VFS の有効なユーザー名とパスワードを入力します。 これらの認証情報は、ユーザーの VFS リポジトリにアクセスするために使われます。SMB プロトコルでは、 次の形式でユーザー名にドメイン名を含めることができます：domain/username
  8. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  9. このプロファイルで使用する プロジェクト パス を入力します。参照 をクリックして、プロジェクト パスの選択 ダイアログ ボックスを開きます。 プロジェクト パスの選択 ダイアログ ボックスが開きます。ツリー ビューから対象のプロジェクト パスを選択し、OK をクリックします。このフィールドを空欄のままにすると、プロジェクト パスはルート ディレクトリに設定されます。
  10. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: Apache Commons 仮想ファイルシステム


VFS ソース管理プロファイルを編集する

VFS ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. アクセスする VFS リポジトリ の URL を編集します。
    注: このフィールドでは、大文字と小文字が区別されます。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、ユーザーのリポジトリにアクセスするために使われます。
  7. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を編集します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  8. このプロファイルで使用する プロジェクト パス を編集します。
  9. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: Apache Commons 仮想ファイルシステム


Git

このセクションでは、Git ソース管理プロファイルを構成する方法について説明します。

Git は、速度を重視した分散バージョン管理/ソースコード管理 (SCM) システムです。すべての Git 作業ディレクトリは、完全な履歴および完全なバージョン トラッキング能力を兼ね備えたリポジトリで、ネットワーク アクセスやセントラル サーバーに依存しません。

  • Git ソース管理プロファイルを追加する
    Git ソース管理プロファイルを作成して、Git からテスト実行用のプログラム ソースを取得します。
  • Git ソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の Git のソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


Git ソース管理プロファイルを追加する

Git ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、ソース管理プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. ソース管理システム リスト ボックスから Git を選択します。
  6. アクセスする Git リポジトリ の URL を入力します。
    注: このフィールドでは、大文字と小文字が区別されます。
  7. 必要に応じて、有効な Git ユーザー名 と パスワード を入力します。
  8. 省略可能：特定のブランチをチェックアウトするには、ブランチ を指定します。このフィールドが空の場合は、マスター ブランチがチェックアウトされます。
  9. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  10. このプロファイルで使用する プロジェクト パス を入力します。参照 をクリックして、プロジェクト パスの選択 ダイアログ ボックスを開きます。 プロジェクト パスの選択 ダイアログ ボックスが開きます。ツリー ビューから対象のプロジェクト パスを選択し、OK をクリックします。このフィールドを空欄のままにすると、プロジェクト パスはルート ディレクトリに設定されます。
  11. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

ヒント: 特定の実行計画に対して、リポジトリの特定のブランチをチェック アウトするには、各実行計画の ソース管理ラベル フィールドでブランチ名を指定します。詳細については、実行計画を作成する を参照してください。この設定は、Git ソース管理プロファイルで指定した ブランチ 設定を上書きします。
親トピック: Git
関連タスク
実行計画を作成する


Git ソース管理プロファイルを編集する

Git ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. アクセスする Git リポジトリ の URL を入力します。
    注: このフィールドでは、大文字と小文字が区別されます。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、ユーザーのリポジトリにアクセスするために使われます。
  7. 省略可能：特定のブランチをチェックアウトするには、ブランチ を指定します。このフィールドが空の場合は、マスター ブランチがチェックアウトされます。
  8. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  9. このプロファイルで使用する プロジェクト パス を入力します。参照 をクリックして、プロジェクト パスの選択 ダイアログ ボックスを開きます。 プロジェクト パスの選択 ダイアログ ボックスが開きます。ツリー ビューから対象のプロジェクト パスを選択し、OK をクリックします。このフィールドを空欄のままにすると、プロジェクト パスはルート ディレクトリに設定されます。
  10. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

ヒント: 特定の実行計画に対して、リポジトリの特定のブランチをチェック アウトするには、各実行計画の ソース管理ラベル フィールドでブランチ名を指定します。詳細については、実行計画を作成する を参照してください。この設定は、Git ソース管理プロファイルで指定した ブランチ 設定を上書きします。
親トピック: Git
関連タスク
実行計画を作成する


Microsoft Team Foundation Server

このセクションでは、Team Foundation Server（TFS）ソース管理プロファイルを構成する方法について説明します。

Silk Central の統合が現在サポートされている TFS のバージョンは次の通りです： Team Foundation Server 2012、2013、2015

注: TFS ソース管理プロファイルを追加するには、Microsoft Visual Studio Team Explorer Everywhere 2015 コマンドライン クライアント (英語版) が、フロントエンド サーバーとユーザーがソース管理プロファイルを使用する各実行サーバーにインストールされる必要があります。CLC は Microsoft Download Center からダウンロードできます。統合を機能させるためには、Team Explorer Everywhere を実行し、ライセンス条項に同意する必要があります。詳細については、Knowledge Base の記事を参照してください。
  • TFS ソース管理プロファイルを追加する
    TFS ソース管理プロファイルを作成して、TFS からテスト実行のプログラム ソースを取得します。
  • TFS ソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の TFS ソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


TFS ソース管理プロファイルを追加する

TFS ソース管理プロファイルを追加するには、Microsoft Visual Studio Team Explorer Everywhere 2015 コマンドライン クライアント (英語版) が、フロントエンド サーバーとユーザーがソース管理プロファイルを使用する各実行サーバーにインストールされる必要があります。CLC は Microsoft Download Center からダウンロードできます。統合を機能させるためには、Team Explorer Everywhere を実行し、ライセンス条項に同意する必要があります。詳細については、Knowledge Base の記事を参照してください。

TFS ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、ソース管理プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. Team Foundation Server を ソース管理システム リスト ボックスから選択します。
  6. インストールした TFS の URL を入力します たとえば、http://tfsserver:8080/tfs などです。
  7. TFS ユーザーの ドメイン を入力します。
  8. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、リポジトリにアクセスするために使用されます。
  9. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  10. このプロファイルで使用する プロジェクト パス を入力します。参照 をクリックして、プロジェクト パスの選択 ダイアログ ボックスを開きます。 プロジェクト パスの選択 ダイアログ ボックスが開きます。ツリー ビューから対象のプロジェクト パスを選択し、OK をクリックします。このフィールドを空欄のままにすると、プロジェクト パスはルート ディレクトリに設定されます。
  11. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: Microsoft Team Foundation Server


TFS ソース管理プロファイルを編集する

TFS ソース管理プロファイルを追加するには、Microsoft Visual Studio Team Explorer Everywhere 2015 コマンドライン クライアント (英語版) が、フロントエンド サーバーとユーザーがソース管理プロファイルを使用する各実行サーバーにインストールされる必要があります。CLC は Microsoft Download Center からダウンロードできます。統合を機能させるためには、Team Explorer Everywhere を実行し、ライセンス条項に同意する必要があります。詳細については、Knowledge Base の記事を参照してください。

TFS ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. アクセスする TFS リポジトリ の URL を編集します。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、ユーザーのリポジトリにアクセスするために使われます。
  7. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を編集します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  8. このプロファイルで使用する プロジェクト パス を編集します。
  9. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: Microsoft Team Foundation Server


Silk Test Workbench

このセクションでは、Silk Test Workbench ソース管理プロファイルを構成する方法について説明します。

Silk Test Workbench は、複雑なアプリケーションの機能テストを推進するための自動テスト ツールです。Silk Test Workbench は、Java、.NET、ブラウザベースの Web アプリケーション、COM コンポーネント（ActiveX コントロールと自動オブジェクトの両方を含む）などのさまざまな開発ツールを使って開発されたアプリケーションのテストをサポートします。Silk Test Workbench を使用することで、アプリケーションでユーザー セッションを記録して、テストの作成、検証およびテストのロジックの追加によるテストの拡張、およびテストの再生を行うことで、アプリケーションが期待どおりに機能することを確認できます。

注: Silk Test Workbench ソース管理プロファイルを追加するには、Silk Test Workbench クライアントが、フロントエンド サーバーとユーザーがソース管理プロファイルを使用する各実行サーバーにインストールされる必要があります。
  • Silk Test Workbench ソース管理プロファイルを追加する
    Silk Test Workbench ソース管理プロファイルを作成して、Silk Test Workbench からテスト実行用のプログラム ソースを取得します。
  • Silk Test Workbench ソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の Silk Test Workbench のソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


Silk Test Workbench ソース管理プロファイルを追加する

Silk Test Workbench ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、問題追跡プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. Silk Test Workbench テスト を ソース管理システム リスト ボックスから選択します。
  6. データベースの種類 リスト ボックスから、SQL Server または Oracle のいずれかのデータベースを選択します。
    注: Microsoft Office Access のデータベース タイプはサポートされていません。Silk Test Workbench Oracle データベースに接続する場合、Silk Test Workbench では、TNS 名とホスト サーバー名が同一である必要があります。
  7. データベース サーバー フィールドに、Silk Test Workbench データベース サーバーの名前を入力します。
  8. データベース名 フィールドに、Silk Test Workbench データベースの名前を入力します。
  9. データベース ポート フィールドに、Silk Test Workbench データベース サーバーのポート番号を入力します。
  10. データベース スキーマ/所有者名 フィールドに、Silk Test Workbench データベース スキーマまたは所有者名を入力します。
  11. データベース ユーザー フィールドに、データベース ユーザーの名前を入力します。
  12. データベース パスワード フィールドに、データベース ユーザーのパスワードを入力します。
  13. 省略可能：Silk Test Workbench ユーザー名 フィールドと Silk Test Workbench パスワード フィールドそれぞれに、Silk Test Workbench ユーザーの名前とパスワードを入力します。これらのフィールドが空の場合は、実行サーバー サービスを実行している Windows ユーザーが使用されます。
  14. 取得 をクリックします。 すべてのプロジェクトが、プロジェクト リストに一覧表示されます。
  15. 1 つまたは複数のプロジェクトを選択します。
  16. OK をクリックします。
親トピック: Silk Test Workbench


Silk Test Workbench ソース管理プロファイルを編集する

Silk Test Workbench ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. Silk Test Workbench データベースの種類 を編集します。
    注: Microsoft Office Access のデータベース タイプはサポートされていません。
  6. 必要に応じて、他の設定を編集します。
  7. OK をクリックします。
親トピック: Silk Test Workbench


StarTeam

このセクションでは、StarTeam ソース管理プロファイルを構成する方法について説明します。

StarTeam は、すべてのプロジェクト資産を集中制御することで、チームのコミュニケーションとコラボレーションを促進します。保護された柔軟なアクセスが提供されているため、チームのメンバーは、Web、デスクトップ、IDE、コマンドラインの広範な選択肢からクライアントを選び、いつでもどこででも作業することができます。 StarTeam は、ユニークで総合的なソリューションを提供しています。これには、統合された要件管理や変更管理、欠陥追跡、ファイルのバージョン管理、スレッド化対応ディスカッション、プロジェクトやタスクの管理などがあります。

Silk Central の統合が現在サポートしている StarTeam のバージョンは次の通りです：StarTeam 15.x、16.x

  • StarTeam ソース管理プロファイルを追加する
    StarTeam ソース管理プロファイルを作成して、StarTeam からテスト実行用のプログラム ソースを取得します。
  • StarTeam のソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の StarTeam のソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


StarTeam ソース管理プロファイルを追加する

StarTeam ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、ソース管理プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. ソース管理システム リスト ボックスから StarTeam を選択します。
  6. ホスト名 にユーザーの StarTeam サーバーを入力します。
  7. ポート に StarTeam サーバーと接続するために使用するポート番号を入力します。 ポートが変更されていない場合、デフォルト ポート 49201 を使用します。
  8. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、リポジトリにアクセスするために使用されます。
  9. プロファイルで 暗号化 をサポートするかどうかを指定します。
  10. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  11. このプロファイルで使用する プロジェクト パス を入力します。参照 をクリックして、プロジェクト パスの選択 ダイアログ ボックスを開きます。 プロジェクト パスの選択 ダイアログ ボックスが開きます。ツリー ビューから対象のプロジェクト パスを選択し、OK をクリックします。このフィールドを空欄のままにすると、プロジェクト パスはルート ディレクトリに設定されます。
  12. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: StarTeam


StarTeam のソース管理プロファイルを編集する

StarTeam ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. 次のことを行うことができます。
    • StarTeam サーバーの ホスト名 を編集します。
    • StarTeam サーバーに接続するために使用するポートを編集します。 ポートが変更されていない場合、デフォルト ポート 49201 を使用します。
    • プロファイルで 暗号化 をサポートするかどうかを指定します。
  6. このプロファイルで使用する プロジェクト パス を編集します。
  7. ユーザー名 と パスワード を編集します。 これらの認証情報は、ユーザーのリポジトリにアクセスするために使われます。
  8. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を編集します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  9. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: StarTeam


Subversion

このセクションでは、SubVersion（SVN）ソース管理プロファイルを設定する方法について説明します。

Subversion（SVN）は、Concurrent Versions System（CVS）から派生したものです。 Subversion は、トランザクション番号を使用してバージョン管理を行います。 コミットするたびに、トランザクション番号が増加していきます。

他のソース管理システムが ラベル と呼んでいるものは、Subversion では タグ と称されています。 これらのタグは、Subversion URL 内にエンコードされます。 たとえば、http://MyHost/svn/MyApp/trunk は Subversion URL であり、http://MyHost/svn/MyApp/tags/build1012 は Subversion タグです。

Silk Central は、Subversion タグをサポートしています。 Subversion URL に trunk ディレクトリが含まれている場合、ユーザーはラベル tags/build1012 を定義できます。 このラベルが、SubVersion URL の trunk と置き換えられます。

注: Subversion URL に trunk が含まれていない場合にラベルを定義すると、Silk Central でエラーとなります。
  • Subversion ソース管理プロファイルを追加する
    Subversion ソース管理プロファイルを作成して、Subversion からテスト実行用のプログラム ソースを取得します。
  • Subversion ソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の Subversion ソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


Subversion ソース管理プロファイルを追加する

Subversion ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、ソース管理プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. Subversion を ソース管理システム リスト ボックスから選択します。
  6. アクセスする Subversion リポジトリ の URL を入力します。
    リポジトリの URL が不明な場合は、Subversion の管理者にお問い合わせください。
    注: SSH を使用するには、URL に ssh を追加します (svn+ssh://<hostname>:<port> など)。
  7. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、リポジトリにアクセスするために使用されます。
  8. 有効な SSH ユーザー名 および SSH パスワード または SSH キーファイル を入力します。 これらの認証情報は、SSH サーバーにアクセスするために使用されます。キーファイルよりもパスワードが優先されるため、キーファイルのみを持っている場合には、SSH パスワード フィールドを空のままにします。キーファイルを使用する場合は、ソース管理プロファイルを使用するすべての実行サーバー上でキーファイルへのパスが有効である必要があります。
  9. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  10. このプロファイルで使用する プロジェクト パス を入力します。参照 をクリックして、プロジェクト パスの選択 ダイアログ ボックスを開きます。 プロジェクト パスの選択 ダイアログ ボックスが開きます。ツリー ビューから対象のプロジェクト パスを選択し、OK をクリックします。このフィールドを空欄のままにすると、プロジェクト パスはルート ディレクトリに設定されます。
  11. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: Subversion


Subversion ソース管理プロファイルを編集する

Subversion ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. アクセスする Subversion リポジトリの URL を編集します。 リポジトリの URL が不明な場合は、Subversion の管理者にお問い合わせください。
    注: Subversion リポジトリ の URL を編集しようとする際、ファイルをチェックアウトできない場合には、実行サーバー上にあるソース管理ミラー ディレクトリを削除してください。 たとえば、C:\ProgramData\SilkCentral\SrcCtrlMirrors のようになります。
    注: SSH を使用するには、URL に ssh を追加します (svn+ssh://<hostname>:<port> など)。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、ユーザーのリポジトリにアクセスするために使われます。
  7. 有効な SSH ユーザー名 および SSH パスワード または SSH キーファイル を入力します。 これらの認証情報は、SSH サーバーにアクセスするために使用されます。キーファイルよりもパスワードが優先されるため、キーファイルのみを持っている場合には、SSH パスワード フィールドを空のままにします。キーファイルを使用する場合は、ソース管理プロファイルを使用するすべての実行サーバー上でキーファイルへのパスが有効である必要があります。
  8. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を編集します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。
  9. このプロファイルで使用する プロジェクト パス を編集します。
  10. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: Subversion


Silk TestPartner

このセクションでは、TestPartner ソース管理プロファイルを構成する方法について説明します。

TestPartner は、Microsoft 技術を使用する Web ベースおよび Microsoft Windows ベースのアプリケーションをテストする Micro Focus の製品です。TestPartner は、ユーザーの操作を記録して、強力なテストをすばやく作成します。記録された各テストは、一連の操作が明確で簡潔なステップとして表示され、初心者から熟練者までのすべてのテスト担当者が簡単に理解できます。アプリケーションとユーザー セッションの記録、検証関数の追加、および後でセッションの生成を行うことにより、アプリケーションが期待どおりに動作するようにできます。

注: TestPartner ソース管理プロファイルを追加するには、TestPartner クライアントが、フロントエンド サーバーとユーザーがソース管理プロファイルを使用する各実行サーバーにインストールされる必要があります。
  • TestPartner ソース管理プロファイルを追加する
    TestPartner ソース管理プロファイルを作成して、TestPartner からテスト実行用のプログラム ソースを取得します。
  • TestPartner ソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の TestPartner のソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


TestPartner ソース管理プロファイルを追加する

TestPartner ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、ソース管理プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. ソース管理システム リスト ボックスから TestPartner を選択します。
    注: TestPartner Oracle データベースに接続する場合、TestPartner では、TNS 名とホスト サーバー名が同一である必要があります。
  6. データベースの種類 リスト ボックスから、SQL Server または Oracle のいずれかのデータベースを選択します。
  7. データベース サーバー フィールドに、データベース サーバーの名前を入力します。
  8. データベース名 フィールドに、データベースの名前を入力します。
  9. データベース ポート フィールドに、データベース サーバーのポート番号を入力します。
  10. データベース スキーマ/所有者名 フィールドに、データベース スキーマまたは所有者名を入力します。
  11. データベース ユーザー フィールドに、データベース ユーザーの名前を入力します。
  12. データベース パスワード フィールドに、データベース ユーザーのパスワードを入力します。
  13. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、リポジトリにアクセスするために使用されます。
  14. テストに使用できるスクリプトをデータベースからフィルタ処理するには、プロジェクト パス フィールドを使用します。参照 をクリックして、プロジェクト パスの選択 ダイアログ ボックスを開きます。
    プロジェクト パスの選択 ダイアログ ボックスには、選択可能な 3 レベルのツリーが表示されます。
    第 1 レベル
    TestPartner データベース全体です。このレベルを選択すると、プロジェクト パス フィールドは空のままになります。
    第 2 レベル
    TestPartner プロジェクトです。
    第 3 レベル
    指定された TestPartner プロジェクト内のスクリプト タイプです。

    上記のいずれかのオプションを選択して、OK をクリックします。パスが プロジェクト パス フィールドに追加されます。

  15. OK をクリックします。
親トピック: Silk TestPartner


TestPartner ソース管理プロファイルを編集する

TestPartner ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. 次のことを行うことができます。
    • TestPartner データベースの種類 を編集します。
    • TestPartner データベース サーバー を編集します。
    • TestPartner データベース名 を編集します。
    • TestPartner データベース サーバーの TestPartner 番号を編集します。
    • TestPartner データベース スキーマ/所有者名 を編集します。
    • TestPartner データベース ユーザー を編集します。
    • TestPartner データベース パスワード を編集します。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、ユーザーのリポジトリにアクセスするために使われます。
  7. このプロファイルで使用する プロジェクト パス を編集します。
  8. OK をクリックします。
親トピック: Silk TestPartner


Universal Naming Convention

このセクションでは、Universal Naming Convention（UNC）ソース管理プロファイルを構成する方法について説明します。

Universal Naming Convention または Uniform Naming Convention の頭文字である UNC は、LAN （ローカル エリア ネットワーク）上のリソースの場所を指定するための PC 形式です。UNC では、以下の形式が使用されます：\\server-name\shared-resource-pathname。

たとえば、共有サーバー silo 上のディレクトリ examples にあるファイル test.txt にアクセスするには次のように記述します：\\silo\examples\test.txt。

また、UNC を使用して、プリンタなどの共有周辺装置を識別することもできます。UNC の基になっている考え方は、各共有リソースを固有のアドレスで識別できるような形式を提供することです。

UNC は、Microsoft Windows オペレーティング システムでのみサポートされています。非 Windows 実行サーバーの利用を計画している場合には、代わりに、Apache Commons VFS ソース管理プロファイルを利用することができます。

  • UNC ソース管理プロファイルを追加する
    UNC ソース管理プロファイルを作成して、UNC からテスト実行のプログラム ソースを取得します。
  • UNC ソース管理プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の UNC ソース管理プロファイルを変更します。
親トピック: ソース管理プロファイル
親トピック: ソース管理プロファイル統合


UNC ソース管理プロファイルを追加する

UNC ソース管理プロファイルを作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. プロファイルの新規作成 をクリックして、ソース管理プロファイルの新規作成 ダイアログ ボックスを開きます。
  4. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  5. UNC を ソース管理システム リスト ボックスから選択します。
  6. アクセスする UNC パス を入力します。 これは、テスト ソースが配置される場所へのパスです。
    ヒント: テストの実行に実際に必要となるソースが存在する階層レベルのフォルダを指定して、不要なファイルがチェック アウトされないようにします。
  7. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。静的作業フォルダを指定する必要がある場合は、UNC パス 内のフォルダを指定しないようにしてください。指定すると、再帰的にチェックアウトされることになります。
  8. UNC ユーザー名 と UNC パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、設定ファイルの UNC パスにアクセスするために必要です。
  9. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: Universal Naming Convention


UNC ソース管理プロファイルを編集する

UNC ソース管理プロファイルを変更するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. ソース管理プロファイルの名前をクリックします。 ソース管理プロファイルの編集 ダイアログ ボックスが開きます。
  4. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  5. アクセスする UNC パス を入力します。 これは、テスト ソースが配置される場所へのパスです。
    ヒント: テストの実行に実際に必要となるソースが存在する階層レベルのフォルダを指定して、不要なファイルがチェック アウトされないようにします。
  6. 省略可能：Silk Central 実行サーバーがソース ファイルをコピーする 共通作業フォルダ を入力します。 作業フォルダにはローカル パスを指定する必要があります。たとえば、C:\TempSources\ などです。
    警告: このフィールドを空のままにすることを推奨します。 この場合、Silk Central は一時的な作業フォルダを代わりに使用します。静的な作業フォルダを指定すると、並列実行の実行時に予期しない結果になる可能性があります。一時的な場所は、定義済みパラメータ #sctm_source_root_dir で取得できます。静的作業フォルダを指定する必要がある場合は、UNC パス 内のフォルダを指定しないようにしてください。指定すると、再帰的にチェックアウトされることになります。
  7. UNC ユーザー名 と UNC パスワード を編集します。 これらの認証情報は、設定ファイルの UNC パスにアクセスするために必要です。
  8. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。

テスト接続が成功すると、ソース管理 ページに戻ります。

親トピック: Universal Naming Convention


ソース管理プロファイルを削除する

ソース管理プロファイルを削除するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ソース管理 タブをクリックします。 ソース管理 ページに、システムで作成されているすべてのソース管理プロファイルが一覧表示されます。
  3. 削除するソース管理プロファイルの アクション 列で、ソース管理プロファイルの削除... をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックします。
    ソース管理 ページに戻ります。
親トピック: ソース管理プロファイル


[ソース管理プロファイル] ページ

プロジェクト:<プロジェクト名> > プロジェクト設定 > ソース管理

このページは、外部ソース管理システムと Silk Central を統合するためのプロファイルを構成するために使用されます。プロファイルの新規作成 をクリックして、新しいソース管理プロファイルを作成します。ソース管理プロファイルごとに、以下の列がページに表示されます。

項目 | 説明
名前 | Silk Central GUI およびレポートに表示されるプロファイルの名前。名前をクリックしてプロファイルを編集します。
タイプ | 外部ソース管理システム。
作業フォルダ | 一時ソースのチェックアウト先である、ローカルまたはマップされた作業フォルダ。
作成日時 | ソース管理プロファイルが作成された日時。
作成者 | このソース管理プロファイルを作成したユーザー。
変更日時 | ソース管理プロファイルが最後に変更された日時。
変更者 | このソース管理プロファイルを最後に変更したユーザー。
アクション | ソース管理プロファイルの削除
親トピック: ソース管理プロファイル


ステップ プロパティ

プロパティを追加して手動テストのステップを拡張するには、ステップ プロパティを使用します。 プロジェクト:<プロジェクト名> > プロジェクト設定 でカスタム ステップ プロパティをプロジェクトに追加して、プロジェクト内のすべての手動テスト ステップにプロパティを追加します。 ライブラリ ツリーでカスタム ステップ プロパティをライブラリに追加して、ライブラリ内のすべての手動テスト ステップにカスタム ステップ プロパティを追加します。 ステップ プロパティはその後、手動テストのステップの編集 ダイアログ ボックスでデフォルト プロパティと共に編集することができます。

  • ステップ プロパティを作成する
    ステップ プロパティを作成して、手動テスト ステップを拡張します。
  • ステップ プロパティを編集する
    ステップ プロパティの編集方法について説明します。
  • ステップ プロパティを削除する
    ステップ プロパティの削除方法について説明します。
  • [ステップ プロパティ] ページ
    アクティブ プロジェクトで扱う手動テスト ステップに設定可能なプロパティがすべて一覧表示されます。
親トピック: テストと統合を設定する
親トピック: プロジェクト設定


ステップ プロパティを作成する

ステップ プロパティを新規作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ステップ プロパティ タブをクリックします。
  3. プロパティの新規作成 をクリックします。 ステップ プロパティの新規作成 ダイアログ ボックスが開きます。
  4. 新しいプロパティの名前を 名前 フィールドに入力します。
    注: ステップ プロパティ フィールドは常に文字列型として宣言されます。
  5. OK をクリックすると、選択した Silk Central プロジェクトで扱われているすべての手動テスト ステップでプロパティを使用できるようになります。
    注: ライブラリに対してステップ プロパティを作成するには、ライブラリ ツリーでライブラリ ノードを選択し、2 番目の手順から続行します。
親トピック: ステップ プロパティ


ステップ プロパティを編集する

作成済みのステップ プロパティを編集するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ステップ プロパティ タブをクリックします。
  3. 編集するプロパティの名前をクリックします。 ステップ プロパティの編集 ダイアログ ボックスが開きます。
  4. 名前 フィールドに入力されているプロパティ名を編集します。
  5. OK をクリックして変更内容を保存します。変更内容を保存せずに編集を中止する場合は、キャンセル をクリックします。
親トピック: ステップ プロパティ


ステップ プロパティを削除する

作成済みのステップ プロパティを削除するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ステップ プロパティ タブをクリックします。
  3. 削除するプロパティの アクション 列で プロパティの削除 をクリックします。 削除の確認を求めるメッセージが確認ダイアログ ボックスに表示されます。
  4. はい をクリックして操作を完了するか、いいえ をクリックして中止します。
親トピック: ステップ プロパティ


[ステップ プロパティ] ページ

プロジェクト:<プロジェクト名> > プロジェクト設定 > ステップ プロパティ

ステップ プロパティ ページには、アクティブ プロジェクトで扱う手動テスト ステップに設定可能なプロパティがすべて一覧表示されます。 ステップ プロパティ ページには、カスタム ステップ プロパティごとに以下の列が表示されます。

列 | 説明
名前 | ステップ プロパティの名前。
アクション プロパティに対して、以下のアクションを実行できます。
  • プロパティの削除
  • 上へ移動
  • 下へ移動
親トピック: ステップ プロパティ


属性

カスタム属性を使用して、テストと実行計画の情報をカスタマイズすることができます。Silk Central の統合機能により、優先度、コンポーネント、プラットフォームなどいくつかの属性が利用可能になっていますが、カスタム属性を定義して、自分のニーズに合うようにテストや実行計画を分類したり、テストを特定のテスト ケースと互換性のあるものにすることもできます。

  • カスタム属性を作成する
    カスタム属性を作成して、テストと実行計画の情報をカスタマイズします。
  • カスタム属性と要件プロパティのタイプ
    属性と要件プロパティのタイプの詳細について説明します。
  • カスタム属性を編集する
    カスタム属性を編集して、カスタマイズをテストのニーズに適用します。
  • カスタム属性を削除する
    カスタマイズした情報が不要になった場合に、カスタム属性を削除します。
  • [属性] ページ
    現在のプロジェクトに作成された属性を一覧表示します。
親トピック: テストと統合を設定する
親トピック: プロジェクト設定


カスタム属性を作成する

カスタム属性を作成するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 属性 タブをクリックして、現在の属性のリストを表示します。
  3. 属性の新規作成 をクリックします。 属性の新規作成 ダイアログ ボックスが表示されます。
  4. 新しい属性の名前を 名前 フィールドに入力します。属性が利用可能になったときに、この名前がリスト ボックスに表示されることになります。
  5. 新しい属性の説明を 説明 フィールドに入力します。
  6. 属性の タイプ を選択します。属性の各タイプの説明については、「カスタム属性と要件プロパティのタイプ」を参照してください。
  7. OK をクリックします。
親トピック: 属性
関連資料
カスタム属性と要件プロパティのタイプ


カスタム属性を編集する

カスタム属性を編集するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 属性 タブをクリックして、現在の属性のリストを表示します。
  3. 編集する属性の名前をクリックします。 属性の編集 ダイアログ ボックスが表示されます。
  4. 属性 名前 を編集します。 属性を使用できる場合は、フィルタ、実行計画、テストのリスト ボックスに名前が表示されます。属性は、テストと実行計画に適用でき、グローバル フィルタに使用して属性によってフィルタリングできます。
  5. 属性の 説明 を編集します。
  6. 属性の各タイプの説明については、「カスタム属性と要件プロパティのタイプ」を参照してください。属性のデータ タイプに応じて、異なる編集オプションがあります。
  7. OK をクリックします。 属性 リストに戻ります。
親トピック: 属性
関連概念
テスト属性
フィルタ
関連資料
カスタム属性と要件プロパティのタイプ


カスタム属性を削除する

カスタム属性を削除するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 属性 タブをクリックして、現在の属性のリストを表示します。
  3. 属性を削除するには、まず、それを無効にする必要があります。ステータス 列で アクティブ リンクまたはアイコンをクリックし、確認ダイアログ ボックスで はい をクリックしてその属性を無効にします。
  4. 属性が非アクティブになったら、属性の削除 をクリックして削除します。 削除の確認を求めるメッセージが確認ダイアログ ボックスに表示されます。
  5. はい をクリックすると選択した属性が削除され、いいえ をクリックすると削除が中止されます。
    はい をクリックした場合は、属性 ページに戻ります。削除した属性は表示されません。
  6. エラーが表示された場合は、選択した属性がどのテストまたは実行計画にも適用されておらず、どのグローバル フィルタでも使用されていないことを確認してください。削除できるのは、使用されていない属性だけです。
親トピック: 属性


[属性] ページ

プロジェクト:<プロジェクト名> > プロジェクト設定 > 属性

属性 ページには、現在のプロジェクトに作成されている属性が一覧表示されます。属性ごとに、次の列が 属性 ページに表示されます。

列 | 説明
アクション | この属性に対して実行できるアクション。
名前 | 属性の名前。属性を使用できる場合は、フィルタ、実行計画、テストのリスト ボックスに名前が表示されます。属性は、テストと実行計画に適用でき、グローバル フィルタに使用して属性によってフィルタリングできます。 属性名を編集するには、編集 アイコンをクリックします。
タイプ | 属性のタイプ。属性の各タイプの説明については、「カスタム属性と要件プロパティのタイプ」を参照してください。
ステータス | 属性のステータス（[アクティブ] または [非アクティブ]）。
レポート列 | LQM Reporting テーブルでの属性の列名。この列名を使用して、選択した属性を LQM Reporting テーブルから検索します。詳細については、データベース モデルのドキュメントを参照してください。
作成日時 | この属性が作成された日時。
作成者 | この属性を作成したユーザー。
変更日時 | この属性が最後に変更された日時。
変更者 | この属性を最後に変更したユーザー。
親トピック: 属性
関連資料
カスタム属性と要件プロパティのタイプ


データ駆動型テスト向けのデータ ソース

データ駆動型テストとは、スプレッドシートやデータベースなど、既存のデータ ソースに含まれる値を元に行うテストのことです。データ ソースは、プロジェクトごとの範囲で管理されます。
ヒント: Silk Central にデータ ソースの変更を認識させるには、データ ソースを更新または変更するたびに、データ ソース プロファイルとデータ ソースを同期する必要があります。
  • データ ソースの制約
    データ ソースによる過度なデータ生成により、Silk Central が不安定な状態に陥ることを避けるために、いくつかの制約があります。
  • JDBC データ ソースを設定する
    データ駆動型テスト用に JDBC データ ソースを設定して、Silk Central でのテストを同期します。
  • Microsoft Excel または CSV データ ソースを設定する
    データ駆動型テスト用に Microsoft Excel または CSV データ ソースを設定して、Silk Central でのテストを同期します。
  • データ ソースから Excel ファイルをダウンロードする
    Silk Central データ ソースから Excel ファイルをダウンロードします。
  • データ ソースを同期する
    関連するテストをデータ ソースの変更内容で更新するため、データ ソースを同期します。
  • 更新された Excel ファイルをデータ ソースにアップロードする
    更新された Excel ファイルをデータ ソースにアップロードして、現在アップロードされているファイルと置き換えます。
  • データ ソースを削除する
    データ ソースが不要になった場合に、完全に削除します。
  • [データ ソース設定] ページ
    データ駆動型テストを Silk Central に統合するために設定されたすべてのデータ ソースが一覧表示されます。
親トピック: テストと統合を設定する
親トピック: プロジェクト設定
関連概念
データ駆動型テスト
データ駆動型テストを作成する


データ ソースの制約

データ ソースによる過度なデータ生成により、Silk Central が不安定な状態に陥ることを避けるために、いくつかの制約があります。

アトミックなテストとアトミックでないテスト

Silk Central で利用できるデータ駆動型テスト タイプについての詳細は、「アトミックなデータ駆動型テストとアトミックでないデータ駆動型テスト」を参照してください。

制約

データ駆動型テストのデータ ソースには、次のデフォルトの制約があります。
  • アトミックでないテストの場合は 100 行
  • アトミックなテストの場合は 1000 行
  • XLSX データ ソースの場合は 20000 行 + セル（20000 は行の総数 + セルの総数です。たとえば、3000 行、6 列のシートであれば、その計算結果は 3000 + (3000 * 6) = 21000 となり、制約を超過します）
  • データ セット名（Excel シート名/テーブル名）は最大 220 文字
  • 列キー名は最大 220 文字
  • すべての主キーを連結した長さは最大 255 文字（JDBC、Excel 、CSV データ ソース）
  • セルは最大 2000 文字（超過した文字は切り詰められます）。データ駆動型 Silk Test Classic テストでは、データ ソース文字列を引用符で囲む必要があります。セルの文字列長が 2000 文字を超えた場合、文字列が切り詰められて、終わりの引用符が欠落すため、エラーになります。

デフォルトの制約の変更

デフォルトの制約は、必要に応じて変更できます。これらの値を変更する場合は、過度なデータ生成がなされないよう、十分注意してください。値を変更する前に、アプリケーション サーバーを停止し、変更を保存した後で再起動します。

アトミックなテストとアトミックでないテストの行の制約は、TmAppServerHomeConf.xml ファイルで設定できます。このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\AppServer になります。それぞれ、Config/DataDriven/MaxRowsAtomic および Config/DataDriven/MaxRows という XML タグの値を変更します。

XLSX セルの制約は、Excel データ ソース プラグイン（DS-Excel.zip）の configuration.properties で設定できます。このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Plugins になります。excel.importcelllimit プロパティの値を変更します。

親トピック: データ駆動型テスト向けのデータ ソース


JDBC データ ソースを設定する

注意:
JDBC データ ソースでは、すべての主キーを連結した長さが 255 文字を超えることはできません。

JDBC データ ソースを設定するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. データ ソース タブをクリックします。 データ ソース ページが表示され、システムで作成されているすべてのデータ ソースが一覧表示されます。
  3. データ ソースの新規作成 をクリックし、データ ソースの新規作成 ダイアログ ボックスを開きます。
  4. データ ソースの 名前 を入力します。
  5. データ ソース タイプ リスト ボックスから、JDBC を選択します。
    注: ODBC データ ソースを設定している場合は、ODBC ドライバ クラス と URL を手動で挿入する必要があります。たとえば、ドライバ クラス は、sun.jdbc.odbc.JdbcOdbcDriver、URL は、jdbc:odbc:MyDatabaseName を設定します。また、MS Windows の 管理ツール で、ODBC データ ソースを設定する必要もあります。詳細については、Microsoft Windows のヘルプを参照してください。フロントエンド サーバーとアプリケーション サーバーが異なるコンピュータ上にある場合は、Microsoft Windows で設定されているシステム データ ソースの名前が、ODBC データ ソースと同じであることを確認します。これらの名前は、大文字小文字が区別されます。
  6. データ ソース タイプ として JDBC を選択すると、ドライバ クラス フィールドが自動的に設定されます。URL フィールドで、ホスト名の値（<ホスト名>）を、データ ソースをホストしているコンピュータの名前に置き換え、データベース名の値（<データベース名>）を、ターゲット データベースの名前に置き換えます。
  7. ユーザー名 フィールドと パスワード フィールドに、データベースの有効な認証情報を入力します。
  8. 省略可能：複数のテーブルを含むデータベースを使用しており、データ ソースを特定のテーブルに絞り込む必要がある場合は、含める特定のテーブルを参照して選択できます。
    1. テーブル フィルタ フィールドの隣の [...] をクリックします。
    2. テーブル フィルタ の選択 ダイアログ ボックスが表示されます。データ ソースとして含めるテーブルを選択します。
    3. OK をクリックします。
  9. 省略可能：キー列 の選択は、データ ソース内のワークシート列で主キーとして使用するものを定義するために、テストによって使用されます。これは、データ ソースを編集する場合に役に立ちます。たとえば、ワークシート内に行を追加または削除する場合などです。データ ソースが編集中であっても、テストは使用する列または行を識別できます。データ駆動型データ ソースから作成されたテストは、列番号ではなくキー列の値を名前で使用します。 キー列を設定するには：
    1. キー列 フィールドの隣の [...] をクリックします。
    2. "キー列" の選択 ダイアログ ボックスが開きます。キー列として機能する列を、列のリストから選択します。
    3. OK をクリックします。
  10. データ ソースの新規作成 ダイアログ ボックスで OK をクリックします。
親トピック: データ駆動型テスト向けのデータ ソース


Microsoft Excel または CSV データ ソースを設定する

注意:
パスワード保護を使用する Excel のワークシートは、Silk Central のデータ ソースとして設定できません。データ駆動型テストのデータ ソースとして使用する場合は、ワークシートのパスワード保護をオフにしてください。Excel と CSV では、すべての主キーを連結した長さが 255 文字を超えることはできません。

Microsoft Excel または CSV データ ソースを設定するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. データ ソース タブをクリックします。 データ ソース ページが表示され、システムで作成されているすべてのデータ ソースが一覧表示されます。
  3. データ ソースの新規作成 をクリックし、データ ソースの新規作成 ダイアログ ボックスを開きます。
  4. データ ソースの 名前 を入力します。
  5. データ ソース タイプ リスト ボックスで、Microsoft Excel データ ソースを設定する場合は MS Excel を選択し、CSV データ ソースを設定する場合は CSV を選択します。
  6. ソース管理プロファイル リスト ボックスから、データ ファイルをホストする設定済みのソース管理プロファイルを選択します。ソース管理プロファイルの設定の詳細については、「ソース管理プロファイル」を参照してください。
  7. 参照 をクリックして、ソース管理パスの選択 ダイアログ ボックスを開きます。選択した種類のデータ ソース ファイルを、ソース管理パスで参照して選択します。
  8. 省略可能：MS Excel のみ。複数のワークシートを含む Excel スプレッドシートを使用しており、データ ソースを特定のワークシートに絞り込む必要がある場合は、含める特定のワークシートを参照して選択できます。それには、次の手順を実行します。
    1. ワークシート フィルタ フィールドの隣の [...] をクリックします。
    2. ワークシート フィルタ の選択 ダイアログ ボックスが表示されます。データ ソースとして含めるワークシートを選択します。
    3. OK をクリックします。
  9. 省略可能：キー列 の選択は、データ ソース内のワークシート列で主キーとして使用するものを定義するために、テストによって使用されます。これは、データ ソースを編集する場合に役に立ちます。たとえば、ワークシート内に行を追加または削除する場合などです。データ ソースが編集中であっても、テストは使用する列または行を識別できます。データ駆動型データ ソースから作成されたテストは、列番号ではなくキー列の値を名前で使用します。
    注: MS Excel のみ：データ ソースに複数のワークシートが含まれる場合は、同じ名前の列のみを、キー列としての定義に使用できます。

    キー列を設定するには：

    1. キー列 フィールドの隣の [...] をクリックします。
    2. "キー列" の選択 ダイアログ ボックスが開きます。キー列として機能する列を、列のリストから選択します。
    3. OK をクリックします。
  10. データ ソースの新規作成 ダイアログ ボックスで OK をクリックします。
親トピック: データ駆動型テスト向けのデータ ソース
関連概念
ソース管理プロファイル


データ ソースから Excel ファイルをダウンロードする

注: JDBC および ODBC のデータ ソースからはファイルをダウンロードできません。

データ ソースから Excel ファイルをダウンロードするには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. データ ソース タブをクリックします。 データ ソース ページが表示され、システムで作成されているすべてのデータ ソースが一覧表示されます。
  3. ダウンロード元となるデータ ソースの アクション 列で ダウンロード アイコンをクリックします。 ファイルのダウンロード ダイアログ ボックスが表示されます。
  4. 直ちにファイルを開く場合は 開く をクリックし、ファイルを保存するローカル システム上の場所を指定する場合は 保存 をクリックします。
親トピック: データ駆動型テスト向けのデータ ソース


データ ソースを同期する

Silk Central でデータ ソースの変化を認識する場合は、データ ソースを変更または更新するたびに、データ ソースを同期させる必要があります。 データ ソースを同期させると、最近の変更が関連するテストに反映されます。

更新されたデータ ソースを同期するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. データ ソース タブをクリックします。 データ ソース ページが表示され、システムで作成されているすべてのデータ ソースが一覧表示されます。
  3. 更新されたファイルを関連するテストに反映するデータ ソースに対応する アクション 列で、同期 アイコンをクリックします。
  4. 同期の確認を求めるメッセージが確認ダイアログ ボックスに表示されます。 すべてのテストと更新されたデータ ソースを同期する場合は はい をクリックし、同期を中止する場合は いいえ をクリックします。
    注意:
    データ ソースを同期する場合、このデータ ソースに依存する実行中のすべての実行が中止されます。 これらの実行で完了していないテストの結果は失われます。
  5. 成功メッセージのダイアログ ボックスで OK をクリックします。
親トピック: データ駆動型テスト向けのデータ ソース


更新された Excel ファイルをデータ ソースにアップロードする

注: JDBC および ODBC のデータ ソースにはファイルをアップロードできません。

更新された Excel ファイルをデータ ソースにアップロードするには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. データ ソース タブをクリックします。 データ ソース ページが表示され、システムで作成されているすべてのデータ ソースが一覧表示されます。
  3. アップロード元となるデータ ソースの アクション 列で、アップロード アイコンをクリックします。
  4. ファイルのアップロード ダイアログ ボックスの 参照... をクリックます。
  5. 現在アップロードされている Excel ファイルと置き換える、更新された Excel ファイルを選択します。 開く をクリックします。
  6. ファイルのアップロード ダイアログ ボックスの OK をクリックます。
  7. 既存ファイルの上書きの確認を求めるメッセージが確認ダイアログ ボックスに表示されます。 はい をクリックして続行します。
  8. 更新されたデータ ソース ファイルのアップロードが終了すると、別のダイアログ ボックスが表示され、テストと更新されたデータ ソースを同期させるかどうかの指定を求められます。 直ちに同期させる場合は はい をクリックし、後で同期を行う場合は いいえ をクリックします。
    注: 更新されたデータ ソース ファイルをアップロードした後は、データ ソースを同期させて、関連付けられたテストを更新する必要があります。
親トピック: データ駆動型テスト向けのデータ ソース


データ ソースを削除する

注: テストで使用中のデータ ソースは削除できません。

データ ソースを削除するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. データ ソース タブをクリックします。 データ ソース ページが表示され、システムで作成されているすべてのデータ ソースが一覧表示されます。
  3. 削除するデータ ソースの アクション 列で 削除 アイコンをクリックします。
  4. 確認ダイアログ ボックスが表示されます。 はい をクリックするとデータ ソースが削除され、いいえ をクリックすると削除が中止されます。
親トピック: データ駆動型テスト向けのデータ ソース


[データ ソース設定] ページ

プロジェクト:<プロジェクト名> > プロジェクト設定 > データ ソース

データ ソース ページには、データ駆動型テストを Silk Central に統合するために設定されたすべてのデータ ソースが一覧表示されます。データ ソースの新規作成 をクリックして、新しいデータ ソースを作成します。データ ソースごとに、以下の列がページに表示されます。

列 | 説明
名前 | Silk Central GUI およびレポートに表示されるデータ ソースの名前。名前をクリックして、データ ソースの設定を変更します。
タイプ データ ソースのタイプ。
  • CSV
  • JDBC
  • MS Excel
ファイル名 | データ ソースとして使用されるファイルの名前 (datasource.xlsx など)。
ソース管理プロファイル | データ ファイルをホストするソース管理プロファイルの名前。
作成日時 | データ ソースが作成された日時。
作成者 | このデータ ソースを作成したユーザー。
変更日時 | データ ソースが最後に変更された日時。
変更者 | このデータ ソースを最後に変更したユーザー。
アクション データ ソースに対して、以下のアクションを実行できます。
  • 削除
  • ダウンロード
  • アップロード
  • 同期
親トピック: データ駆動型テスト向けのデータ ソース


テスト資産を構造化する

Silk Central は、ある特定の製品のバージョンとビルドを関連させてテスト実行の結果をトラッキングします。このため、テストを作成する前に、製品 を定義する必要があります。

自動テストの場合は、テストを作成する前に、ソース管理プロファイル も準備する必要があります。 Silk Central の自動テストは、実際はソース管理システムにあるテスト スクリプトです。 ソース管理システムにアクセスするためには、ソース管理プロファイルを設定する必要があります。製品とソース管理プロファイルの情報の両方を テスト コンテナ レベルに指定するため、このノードは、テスト資産構造における最上位層のノードとなります。テスト コンテナ内で、テストの要求やプロセスに応じてテスト資産を構造化する場合は、フォルダを使用できます。

複数のテスト コンテナを作成できますが、テスト結果/ビルド/バージョン間の関連の制約により、1 つの実行計画は 1 つのテスト コンテナ内のテストだけを実行できます。このため、1 つの実行計画内で一緒に実行すべきテストを考慮しながら、テスト資産の構造を設計する必要があります。

  • テスト コンテナ
    テスト コンテナは、最上位層でテスト資産を構造化するために使用します。 Silk Central では、定義したソース管理プロファイルと製品をコンテナと関連付けるため、特定のコンテナのテストに対して行えることに影響を与えます。
  • テスト フォルダ
    フォルダは、コンテナ内のテストを構造化するために使用します。
  • テスト パッケージ
    テスト パッケージは、Silk Central 内からのサードパーティ テスト タイプの構造に対するサポートを提供するもので、パッケージ ルートと、スイート ノードおよびテスト ノードの任意の階層から構成されます。
親トピック: テスト


テスト コンテナ

テスト コンテナは、最上位層でテスト資産を構造化するために使用します。 Silk Central では、定義したソース管理プロファイルと製品をコンテナと関連付けるため、特定のコンテナのテストに対して行えることに影響を与えます。

テスト実行を計画する段階では、ある特定のコンテナのテストだけしか利用できないため、コンテナ数はできるだけ少なく抑えるよう考慮すべきです。

  • テスト コンテナを追加する
    プロジェクトに定義されているソース管理プロファイルではなく別のソース管理プロファイルを使用するには、テスト コンテナをテストに追加します。
  • コンテナにリンクを追加する
    テスト ツリーにリンクを追加し、同じプロジェクト内のコンテナを参照します。
  • テスト コンテナを編集する
    テスト コンテナのプロパティを編集します。
親トピック: テスト資産を構造化する


テスト コンテナを追加する

注: テスト コンテナによって製品がソース管理プロファイルにバインドされるため、テスト コンテナは注意して使用することをお勧めします。

テスト コンテナを新規に追加するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、新しいコンテナをサブノードとして追加するルート ノードを選択します。
    注: コンテナを入れ子にすることはできませんが、コンテナにサブ フォルダを追加することはできます。
  3. ツールバーの テスト コンテナの新規作成 をクリックするか、ノードを右クリックし、テスト コンテナの新規作成 を選択します。

    ノードを右クリックして、テスト コンテナの新規作成 を選択することもできます。

    新しいコンテナ ルート ノードが テスト ツリーに追加され、テスト コンテナの新規作成 ダイアログ ボックスが表示されます。
  4. コンテナの 名前 と 説明 を入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 製品 リスト ボックスから、このテスト コンテナに関連付ける定義済みの製品を選択します。製品プロファイルの追加の詳細については、「製品を追加する」を参照してください。
  6. ソース管理プロファイル リスト ボックスから、定義済みのソース管理プロファイルを選択します。 テスト コンテナでテスト ソースをチェックアウトしない場合は (手動テストのみの場合など) 、--- を選択します。
    注: Silk Central 実行サーバーは、コンテナに含まれているテストのプログラム ソースを、定義済みのソース管理プロファイルから取得します。ソース管理プロファイルで指定したパスによっては、テスト コンテナの ルート ノード フィールドにサブノードを使用するように指定できます。
  7. 省略可能：テストを実行する前に作業フォルダをクリアする チェック ボックスをオンにします。

    オンにした場合、ソース管理システムから削除されたファイルは、作業フォルダからも削除されることになります。デフォルトはオンです。

  8. コンテナの保存先となるデフォルトのルート パスを指定するには、参照... をクリックして、その場所に移動します。
  9. 省略可能：Silk Central が Silk Performer と統合されている場合は、カスタム データ ディレクトリ と カスタム インクルード ディレクトリ を定義できます。 Silk Performer では、インクルード ディレクトリは、システム インクルード ディレクトリと カスタム インクルード ディレクトリに分かれています。データ ディレクトリは、システム データ ディレクトリと カスタム データ ディレクトリに分かれています。その他の情報については、Silk Performer のドキュメントを参照してください。
  10. このダイアログ ボックスの プロパティを表示しないテスト タイプ フィールドを利用して、テスト コンテナの プロパティ ページ、およびこのコンテナ内のすべてのテスト フォルダの プロパティ ページに表示するテスト プロパティ タイプを指定できます。 これらの設定は、個々のテストの表示には影響を与えません。
  11. 編集 をクリックして、非表示のテスト プロパティ設定を調整します。 プロパティを表示しないテスト タイプ ダイアログ ボックスが表示されます。
  12. プロパティを表示するテスト タイプのチェック ボックスをすべてオフにします。
  13. 設定を保存して プロパティを表示しないテスト タイプ ダイアログ ボックスを閉じるには、OK をクリックします。
  14. 保存 をクリックして設定を保存します。
新しいコンテナが、テスト ツリーに追加されます。
親トピック: テスト コンテナ
関連概念
ソース管理プロファイル
関連タスク
製品を追加する


コンテナにリンクを追加する

テスト ツリーに、同じプロジェクト内のテスト コンテナへのリンクを追加できます。 リンクされたテスト コンテナは、ツリー内のリンクが挿入された位置に、読み取り専用モードで表示されます。

テスト コンテナへのリンクを追加するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、リンクされたテスト コンテナを下に追加するノードを右クリックします。
  3. 選択したノードの階層レベルでテスト コンテナをリンクする場合は、リンクの新規作成 を選択します。選択したノードより下位の階層でテスト コンテナをリンクする場合は、子リンクの新規作成 を選択します。 リンクするテスト コンテナの選択 ダイアログ ボックスが表示されます。
  4. 参照するテスト コンテナを選択します。
    注: 参照されるテスト コンテナおよびリンクを追加したコンテナで使用されるソース管理プロファイルが異なる場合、リンクを本当に作成するかどうかを確認するダイアログ ボックスが表示されます。 別のソース管理プロファイルを持つ別のテスト コンテナをテスト コンテナの内部にリンクすると、リンクされたコンテナ内にテストをダウンロードまたは実行した場合に、問題が発生することがあります。 いずれかのコンテナのカスタム インクルード ディレクトリをまず変更する場合は、いいえ をクリックします。変更せずにリンクを作成する場合は、はい をクリックします。
  5. OK をクリックし、選択内容を確定します。
リンクされたコンテナは、選択したコンテナ内に読み取り専用エンティティとして配置されます。 元のテスト コンテナへの変更はすべて、リンクされたコンテナにも反映されます。
親トピック: テスト コンテナ


テスト コンテナを編集する

テスト コンテナのプロパティを編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、編集するテスト コンテナを選択します。
  3. ツールバーの 編集 をクリックします。 テスト コンテナを右クリックして、編集 を選択することもできます。 テスト コンテナの編集 ダイアログ ボックスが表示されます。
  4. テスト コンテナのプロパティを編集します。
  5. OK をクリックして変更を適用します。
親トピック: テスト コンテナ
関連資料
テスト プロパティ


テスト フォルダ

フォルダは、コンテナ内のテストを構造化するために使用します。
  • テスト フォルダを追加する
    テスト ツリーに新しいテスト フォルダを追加します。
  • テストフォルダを編集する
    テスト フォルダのプロパティを編集します。
  • テスト フォルダをソートする
    テスト ツリー内でテスト フォルダを上または下に移動して、テストをソートします。
親トピック: テスト資産を構造化する
関連タスク
テスト要素を切り取り、コピー、貼り付け、または削除する


テスト フォルダを追加する

テスト フォルダを新規に追加するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、新しいフォルダが下に追加されるテスト要素を選択します。
  3. ツールバーで、 子テスト フォルダの新規作成 をクリックします。 要素を右クリックし、テスト フォルダの新規作成 を選択して、選択した要素の下に新しいフォルダを追加するか、子テスト フォルダの新規作成 を選択して、選択された要素のサブノードとして追加します。
    注: テスト コンテナの場合、テスト フォルダはサブノードとしてのみ追加できます。
    新規フォルダ ノードが テスト ツリーに追加され、フォルダの新規作成 ダイアログ ボックスが表示されます。
  4. [名前] フィールドと [説明] フィールドに、フォルダの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. OK をクリックして、設定を保存します。
新しいフォルダが、テスト ツリーに追加されます。
親トピック: テスト フォルダ


テストフォルダを編集する

テスト フォルダのプロパティを変更するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. ツリーでフォルダを選択します。
  3. ツールバーの 編集 をクリックします。 また、テスト フォルダを右クリックして、編集 を選択することもできます。 テスト フォルダの編集 ダイアログ ボックスが表示されます。
  4. 必要に応じて [名前] と [説明] を編集します。
  5. OK をクリックして変更を受け入れます。
親トピック: テスト フォルダ


テスト フォルダをソートする

テスト ツリーで、フォルダを上または下に移動するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. ツリーでフォルダを選択します。
  3. ツールバーで、 上へ移動 をクリックして、フォルダを 1 つ上に動かすか、 下へ移動 をクリックして、フォルダを 1 つ下に動かします。
親トピック: テスト フォルダ


テスト パッケージ

テスト パッケージは、Silk Central 内からのサードパーティ テスト タイプの構造に対するサポートを提供するもので、パッケージ ルートと、スイート ノードおよびテスト ノードの任意の階層から構成されます。

テスト パッケージは、テスト実行に関する詳細な情報もユーザーに提供します。テスト パッケージ、スイート ノード、およびテスト ノードは、固有の問題や添付ファイルと共に、個々に要件に割り当てることができます。その機能は、その他すべてのテストの機能と同様です。サードパーティ テストをテスト パッケージに変換した後、そのパッケージに含まれるテストはすべて個々に実行できます。テスト パッケージに含まれるテスト ノードおよびスイート ノードには、補足プロパティの 外部 ID が付いています。

テスト パッケージの利点は、構造がすべてのテスト実行それぞれに対して自動的に保持される点です。テスト パッケージの構造は、実行の結果に基づいて更新することができます。ファイル <Silk Central インストール フォルダ>\wwwroot\silkroot\xsl\output.xsd には、テスト パッケージの出力 XML ファイルの構造のための XML スキーマが記述されています。

テスト パッケージでは、個々のテストの全機能が可能ですが、次のような例外があります。

  • テスト パッケージを含むテスト コンテナにはリンクできません。
  • テスト パッケージは、データ駆動型プロパティを保持することができないため、データ駆動型にすることはできません。
  • テスト パッケージ ノードでは、すべての成功条件 (実行タイムアウトを除く) が無効になり非表示となっています。
注: Silk Performer テスト、Silk Test Classic テスト、および手動テストは、テスト パッケージに変換できません。これらのテストの構造が、デフォルトでは Silk Central でサポートされていないためです。

テスト パッケージの内部構造を提供する情報は固有のものであり、テスト パッケージをコピーすると一貫性がなくなります。テスト パッケージを再利用するには、テスト パッケージをコピーし、コピーしたパッケージを親テストに復元して、ニーズに合わせてそのテストを適用し、変更されたテストをテスト パッケージに変換する必要があります。

  • テスト パッケージを作成する
    サードパーティのテストからテスト パッケージを作成して、サードパーティのテスト タイプの構造を Silk Central に反映します。
  • 外部 ID の使用
    外部 ID を使用して、テスト パッケージ内でテスト メソッドを一意に識別します。
  • テスト パッケージを再利用する
    テスト パッケージの親ノードの情報を再利用して、新しいテスト パッケージを作成します。
  • テスト パッケージをテストに戻す
    テスト パッケージを元のテストに戻して、親ノードから別のテスト パッケージを作成します。
  • テスト パッケージをクリーンアップする
    テスト パッケージをクリーンアップして、テスト パッケージから未実行のテストを削除します。
親トピック: テスト資産を構造化する


テスト パッケージを作成する

サードパーティのテストから新しいテスト パッケージを作成するには：

  1. output.xml ファイルを作成するために、いったんテストを実行します。このファイルには、テスト パッケージの構造が含まれています。 テストの実行の詳細については、「テストを試験実行する」を参照してください。
  2. メニューで テスト > 詳細ビュー をクリックします。
  3. テスト ツリーでテストを右クリックし、そのコンテキスト メニューから テスト パッケージに変換 を選択します。 選択されていたテストが、最近の実行結果の構造を表現した階層へと変換されます。
親トピック: テスト パッケージ
関連タスク
テストを試験実行する


外部 ID の使用

外部 ID を使用すると、テスト パッケージ内のテスト ノードやスイート ノードを一意に識別できます。外部 ID は、各テスト ノードおよび各スイート ノードに対して 1 つのプロパティという形で提供されます。この自動的に生成される 外部 ID は、「~」が前に付いたクラスおよびメソッドの完全修飾名で、テスト メソッドを一意に識別します。

JUnit テストの場合、自動的に生成される 外部 ID では、~<package name>.<class name>#<method name> の形式が使用されます。

JUnit テスト クラスをリファクタリングする場合、外部 ID の自動生成は利用できません。これは、リファクタリング以前のテストの結果情報が、新しいテストを作成する際に失われてしまうためです。この場合、テストに対する 外部 ID は手動で定義する必要があります。リファクタリングされたメソッドを再度識別することは可能です。これは、JUnit テストが移動されたり、その名前が変更される間、外部 ID は変更されずそのままであるためです。外部 ID は、ソース コード内の注釈として手動で設定することが可能です。

以下のコード例は、JUnit テストのための注釈を表しています。

import java.lang.annotation.Retention;
import java.lang.annotation.RetentionPolicy;

@Retention(RetentionPolicy.RUNTIME)
public @interface ExternalId {
  String externalId();
}

この注釈は、以下のように、JUnit テスト内でクラスおよびテスト メソッドに注釈を付けるために使用されます。

import static org.junit.Assert.*;
import org.junit.Test;

import com.borland.runner.ExternalId;

@ExternalId(externalId="JUnit4test")
public class JUnit4test {

  @Test
  @ExternalId(externalId="MyExtId1")
  public void test1() {
    ...
  }

  @Test
  @ExternalId(externalId="MyExtId2")
  public void test2() {
    ...
  }
}

テスト メソッドに対して、JUnit ランナー「org.junit.runners.Parameterized」と共に 外部 ID を使用することは、サポートされていない点に注意してください。これは、1 つのメソッドを、異なるパラメータで繰り返し実行した場合、外部 ID が一意でなくなるためです。回避策としては、外部 ID をメソッド レベルでは省略し、クラス レベルで指定することができます。例は次のようになります。

@RunWith(Parameterized.class)
@ExternalId(externalId="parameterizedWithExtId")
public class TestCaseParameterizedWithExternalId {

  @Parameters
  public static Collection<Object[]> parameterFeeder() {
    return Arrays.asList(new Object[][] {
        { "param_name1", "param_value1" }, // set of parameters per run, type matching constructor must exist!
        { "param_name3", "param_value3" },
        { "param_name2", "param_value2" },
      }
    );
  }

  private String paramName;
  private String paramValue;

  public TestCaseParameterizedWithExternalId(String paramName, String paramValue) {
    this.paramName = paramName;
    this.paramValue = paramValue;
  }

  @Test
  public void testWithParams() {
    System.out.println(String.format("run with parameter: name='%s', value='%s'", paramName, paramValue));
  }

}
注: JUnit テスト用の 外部 ID の設定は、JUnit 4.4 以降を使用したテストに対してのみ可能です。
親トピック: テスト パッケージ


テスト パッケージを再利用する

テスト パッケージの内部構造を提供する情報は固有のものであり、テスト パッケージをコピーすると一貫性がなくなります。テスト パッケージを再利用するには、テスト パッケージをコピーし、コピーしたパッケージを親テストに復元して、ニーズに合わせてそのテストを適用し、変更されたテストをテスト パッケージに変換する必要があります。

テスト パッケージの情報を再利用するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで再利用するテスト パッケージを右クリックして、コピー を選択します。
  3. テスト ツリーで、コピーしたテスト パッケージを追加するノードを選択します。
  4. 選択したノードを右クリックし、貼り付け を選択して、コピーしたパッケージをツリーの同じレベルに追加するか、子として貼り付け を選択して、コピーしたパッケージを選択したノードのサブノードとして追加します。
    注意:
    コピーされたテスト パッケージに現在含まれている情報には、一貫性がありません。
  5. コピーされたパッケージを右クリックして、パッケージをテスト定義に戻す を選択します。 パッケージ情報が、親テストから削除されます。
  6. ニーズに会わせて適用できるように、テストを編集します。 詳細については、「テストを編集する」を参照してください。
  7. 編集したテストを右クリックして、テスト パッケージに変換 を選択します。
元のテスト パッケージの、異なるプロパティを持つコピーが作成されました。
親トピック: テスト パッケージ
関連タスク
テストを編集する


テスト パッケージをテストに戻す

テスト パッケージを元のテストに戻して、親ノードから別のテスト パッケージを作成します。
注: テスト パッケージをテストに戻すと、テスト レベルの実行結果情報は表示されなくなります。ただし、タイムライン ビューまたは結果ファイルからこの情報を見ることができます。

テスト パッケージを元のテストに戻すには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーでテスト パッケージを右クリックします。
  3. パッケージをテストに戻す をクリックします。
テスト パッケージが元のテストに戻ります。
親トピック: テスト パッケージ


テスト パッケージをクリーンアップする

テスト パッケージをクリーンアップするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーでテスト パッケージを右クリックします。
  3. テスト パッケージのクリーンアップ をクリックします。
テスト パッケージの前回の実行で実行されなかったすべてのテストがテスト パッケージから削除されます。
親トピック: テスト パッケージ


テストを管理する

テスト フレームワークに新しいテストを追加したり、既存のテストを設定します。
  • テスト タイプ
    Silk Central は、次のテスト タイプをサポートしています。
  • 共有テスト資産
    リポジトリ プロジェクトで管理されている共通のテスト資産やその割り当て済み要件を、他のプロジェクトから再利用することができます。
  • テストを編集する
    テストを編集して、テストのプロパティを変更します。
  • テストの印刷
    選択した順序でテストを印刷します。
  • [テスト] の [実行] ページ
    選択したテストのテスト実行結果が一覧表示されます。
  • [テスト] の [問題] ページ
    選択したテストに関係する問題の入力や追跡を行うことができます。
  • バージョン
    共有オブジェクトとテストのバージョンの使用方法について説明します。
親トピック: テスト


テスト タイプ

Silk Central は、次のテスト タイプをサポートしています。
  • 手動テスト
    手動テストは、テスト担当者に対してテストの手順を説明するものです。 Silk Central は、ビデオの記録、画面イメージのキャプチャなど、テストの実行中に行えるさまざまな機能を持った、手動テストを効率よく実行するための UI を提供します。必要に応じて、後から手動テストを自動テストに変換することもできます。
  • キーワード駆動テスト
    キーワード駆動テストは、テストする機能をキーワードを使ってシンボル化するソフトウェア テスト手法です。キーワード駆動テストは、テスト自動化フレームワークを作成するために使用できます。
  • Unified Functional Testing（UFT）テスト
    以前は HP QuickTest Professional（QTP）として知られていた Unified Functional Testing（UFT）ソフトウェアは、ソフトウェア アプリケーションに対する機能テストと回帰テストの自動化と環境を提供します。
  • JUnit テスト
    JUnit は、Java プログラム言語用の単体テスト フレームワークです。JUnit、Silk4J、Selenium テストに、このテストタイプを使用します。
  • MSTest テスト
    MSTest は、Visual Studio で作成した単体テストを実行するための、Microsoft のコマンド ライン ツールです。MSTest、Silk4NET テストに、このテストタイプを使用します。
  • NUnit テスト
    NUnit は、Microsoft .NET プログラム言語用の単体テスト フレームワークです。
  • ProcessExecutor テスト
    ProcessExecutor テスト タイプは、任意のコマンド ラインを実行するために使用できます。
  • Silk Performer .NET Explorer テスト
    Silk Performer .NET Explorer テスト タイプは、.NET Explorer スクリプトやスクリプトの特定のテスト ケースを実行するために使用します。
  • Silk Performer テスト
    Silk Performer プロジェクトは、Silk Central のテストに統合し、Silk Central を通じて直接実行することができます。これにより、強力なテスト結果分析とレポート作成が可能になります。また、無人テスト（あらかじめ構成されたスケジュールに基づいて Silk Central で自動的に実行されるテスト）も可能です。
  • Silk Test Classic テスト
    Silk Central の Silk Test Classic インターフェイスは、ユーザーに Silk Test Classic を自動化する信頼性の高い手段を提供します。Silk Test Classic スクリプトの各テストケースは、それぞれのテスト実行の中で実行され、それぞれに結果を作成します。
  • Silk Test Workbench テスト
    Silk Test Workbench は、複雑なアプリケーションの機能テストを推進するための自動テスト ツールです。Silk Test Workbench は、Java、.NET、ブラウザベースの Web アプリケーション、COM コンポーネント（ActiveX コントロールと自動オブジェクトの両方を含む）などのさまざまな開発ツールを使って開発されたアプリケーションのテストをサポートします。
  • Silk TestPartner テスト
    TestPartner は、Microsoft 技術を使用する Web ベースおよび Microsoft Windows ベースのアプリケーションをテストする Micro Focus の製品です。
  • Windows Script Host テスト
    Windows Script Host を使用してスクリプトをホストするための環境を作成する方法について説明します。
親トピック: テストを管理する


手動テスト

手動テストは、テスト担当者に対してテストの手順を説明するものです。 Silk Central は、ビデオの記録、画面イメージのキャプチャなど、テストの実行中に行えるさまざまな機能を持った、手動テストを効率よく実行するための UI を提供します。必要に応じて、後から手動テストを自動テストに変換することもできます。
  • 手動テストを作成または編集する
    手動テスト担当者に詳細なテスト手順を提供するために、手動テストを作成または編集します。
  • 手動テスト ステップの追加と編集
    ステップ ページを使用して、手動テスト ステップを追加または編集します。
  • 外部ツールを使った手動テストの作成
    オープン インターフェイスを使用して、Silk Central のユーザー インターフェイス以外から、手動テストを作成する方法について説明します。
  • 手動テストから自動テストへの変換
    テストを回帰に追加する前に、手動テストを自動テストに変換します。
  • 自動テストから手動テストへの変換
    自動テストを手動テストに変換します。たとえば、再度それを他のテスト タイプで自動化したい場合に使用できます。
  • [ステップ] ページ
    選択したテストまたは共有オブジェクトに含まれている手動テスト ステップがすべて一覧表示されます。
  • テストのエクスポート、更新、インポート
    テストをエクスポートして更新、またはインポートすることによってテストを変更する方法について説明します。
親トピック: テスト タイプ
関連概念
共有オブジェクトを管理する
バージョン
テストのエクスポート、更新、インポート


手動テストを作成または編集する

手動テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから 手動テスト を選択します。
  6. 予定時間 フィールドには、この手動テストの実行に予定されている時間の長さを入力します。
  7. 完了 をクリックします。
親トピック: 手動テスト
関連タスク
テストを試験実行する


手動テスト ステップの追加と編集

テストまたは共有オブジェクトの手動テスト ステップは、ステップ ページで追加または編集します。

手動テストのステップを追加または編集するには：

  1. 共有オブジェクトの場合は、メニューで テスト > ライブラリ をクリックします。テストの場合は、メニューの テスト > 詳細ビュー をクリックします。
  2. テスト または ライブラリ ツリーで、ステップを追加または編集するノードを選択します。
  3. ステップ タブをクリックします。
  4. 編集するテスト ステップをクリックするか、ステップ ツールバー上のアイコンを使用して新しいステップを挿入します。テスト ステップの詳細が、ステップの編集 ビューに表示されます。
  5. テスト ステップの名前、アクションの説明、期待される結果、およびステップ プロパティを、対応するフィールドで編集します。 パラメータの形式でデータ ソースのデータを手動テスト ステップに挿入できます (「手動テスト ステップにデータ ソース値を追加する」を参照)。パラメータは、${<名前>} という構文を使用します (${username} など)。手動テストをキーワード駆動テストに変換する際には、これらのパラメータは生成されたキーワードに自動的に追加されます。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  6. 次のいずれかの操作を実行して、テスト ステップの編集を完了します。
    • 適用して次のステップへ をクリックして、変更を保存し、現在のステップの後に新しいステップを追加します。
    • OK をクリックして、変更を保存します。
    • キャンセル をクリックして、変更を破棄します。
親トピック: 手動テスト
親トピック: 共有オブジェクトを管理する
関連タスク
手動テスト ステップにデータ ソース値を追加する


外部ツールを使った手動テストの作成

Silk Centralのオープン インターフェイスを使用すると、Silk Central のユーザー インターフェイス以外から、手動テストを作成できます。 Silk Central の Web サービス呼び出しを使用して、独自のソリューションを作成したり、手動テスト自動的に作成することができます。

手動テストを作成する際には、tmplanning の Web サービスの以下の呼び出しが役立ちます。

  • getTestContainers
  • addManualTest
  • getCustomStepPropertyNames
  • getChildNodes
  • getNodeDetails
  • addNode
  • updateNode
  • startExecution

これらの Web サービス呼び出しの詳細については、「利用可能な Web サービス」を参照してください。

親トピック: 手動テスト
関連資料
利用可能な Web サービス


手動テストから自動テストへの変換

サポートされている自動テスト タイプ (キーワード駆動、Silk Performer、Silk Test Classic、NUnit、JUnit、およびすべてのインストールされているプラグイン) のいずれかに手動テストを変換することができます。処理により、手動テストのパラメータが自動テストに引き継がれると共に、自動パラメータがその新しい自動テストに追加されます。

自動テストに引き継がれる手動テスト パラメータには以下のものがあります。
  • 名前
  • 説明
  • 割り当て済み要件
  • 割り当て済み実行計画
  • 割り当て済み問題
  • 添付情報
  • テスト ステップ

手動テストを自動テストに変換するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで手動テストを右クリックし、自動化... を選択します。
  3. コンテキスト メニューから自動テストのタイプを選択します。
  4. このダイアログの入力に関する情報については、「テストを作成する」の該当するトピックを参照してください。
親トピック: 手動テスト
関連概念
テストを管理する
関連タスク
自動テストを手動で実行する
キーワード駆動テスト


自動テストから手動テストへの変換

自動テストを手動テストに変換できます。この機能は、自動テストを他のテスト タイプに変換したい場合、たとえば、Silk Test Classic から Silk4J に変換したい場合に便利です。この場合、Silk Test Classic テストを手動テストに変換してから、それを Silk4J で自動化します。
注: 制限事項：自動テストの手動テストへの変換は、標準的な自動テストに対してのみ機能します。パッケージ ノードやデータ駆動型ノード、およびリンクノードは含まれません。
  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーでテストを右クリックし、手動テストに変換 を選択します。
  3. メッセージを了解します。
    注意:
    テストのテスト固有のプロパティは破棄されます。自動テストが現在実行中の場合、テスト実行の完了後にテスト結果は破棄されます。
親トピック: 手動テスト


[ステップ] ページ

テスト > 詳細ビュー > <手動テスト> > ステップ

テスト > ライブラリ > <共有オブジェクト> > ステップ

ステップ ページには、選択したテストまたは共有オブジェクトに含まれている手動テスト ステップがすべて一覧表示されます。このページでは、Windows Explorer スタイルの複数選択機能がサポートされます。

新しい共有オブジェクトを作成するには、共有するステップを選択し、 共有ステップの作成 をクリックします。

このページには、次のツールバー項目があります。

ツールバー項目 | 説明
ステップの新規作成 | リストの最後に新しいテスト ステップを追加します。
ステップの挿入 | 選択したステップの前に新しいテスト ステップを挿入します。
共有ステップへの呼び出しの新規作成 | 共有オブジェクトの呼び出しをリストの最後に追加します。
共有ステップへの呼び出しの挿入 | ライブラリからの共有ステップの呼び出しを選択したステップの前に挿入します。
削除 | 選択したテスト ステップをリストから削除します。
切り取り | 選択したテスト ステップをリストから切り取り、クリップボードに保存します。
コピー | 選択したテスト ステップをクリップボードにコピーします。
貼り付け | クリップボードに保存されているテスト ステップのコピーをリストで選択した行の上の行に貼り付けます。
上へ移動 | 選択したテスト ステップをリストの 1 つ上に移動します。
下へ移動 | 選択したテスト ステップをリストの 1 つ下に移動します。
添付情報の管理 添付情報 ダイアログ ボックスを開き、次のアクションを行うことができます。
ファイルのアップロード
選択したテスト ステップにファイルをアップロードして添付します。
リンクの添付
選択したテスト ステップにリンクを添付します。
すべてのファイルのダウンロード
選択したテスト ステップからすべての添付ファイルをダウンロードします。
削除
ファイルまたはリンクを削除します。
共有ステップの展開 | テストまたは共有オブジェクトのステップがライブラリ内の共有オブジェクトを呼び出す場合、ここをクリックすると、元のステップが表示されます。解決されたステップには矢印が付き、ステップ名をクリックしてアクセスできます。このビューが有効である間は、ステップを編集できません。
共有ステップの折りたたみ | ライブラリ内の共有オブジェクトから呼び出されたステップを単一のステップとして表示します。テスト ステップを編集するには、このビューを有効にします。
共有ステップの作成 | 選択したステップから共有オブジェクトを作成します。
ステップの抽出 | 他の共有オブジェクトから呼び出しを抽出します。グリッドで選択した呼び出しのすべてのステップを手動テストまたは共有オブジェクトにコピーします。
キー | アクション
- | 上へ移動
+ | 下へ移動
Ctrl+A | すべて選択
Ctrl+C | コピー
Ctrl+X | 切り取り
Ctrl+V | 貼り付け
Ins | 挿入
Del | 削除
ステップ ページでは、テスト要素用に以下のキーボード機能 (ショートカット) がサポートされています。

ステップには、次の列がグリッドに表示されます。

列 | 説明
順序 | 実行の流れにおける、このステップの番号。
名前 | このテスト ステップの名前。
アクションの説明 | このテスト ステップを実行するために行わなければならないアクション。
期待される結果 | テスト ステップで期待される結果。
添付情報 | テスト ステップに添付されているリンクまたはファイルの数。

ステップの編集 ビューには、選択したテスト ステップの詳細が表示され、テスト ステップの名前、アクションの説明、期待される結果、およびステップ プロパティを編集できます。

ステップの編集 ビューには、次のボタンがあります。

ボタン | 説明
適用して次のステップへ | 現在のステップの編集が完了し、変更を保存して、現在のステップの後に新しいステップを追加する場合にクリックします。
OK | 現在のステップの編集が完了し、変更を保存する場合にクリックします。
リセット | 変更を破棄する場合にクリックします。
親トピック: 手動テスト
親トピック: 共有オブジェクトを管理する


テストのエクスポート、更新、インポート

Silk Central と Excel の統合により、テストを変更するための 2 つのオプションを利用できます。次の設定が含まれます。

  • エクスポートして更新： このオプションでは、テストを Silk Central で作成し、Excel にエクスポートして変更を行い、Silk Central に戻して更新します。
  • インポート： このオプションでは、テストを Excel で作成してから Silk Central にインポートします。

いずれの場合も、Test Manager と Excel の列を同期するためにマッピング ファイルが必要です。

注: Silk Central では、現時点でインポート用に .xslx ファイルのみがサポートされており、インポートは手動テストに制限されています。
  • エクスポート、更新、インポートのルール
    インポート、エクスポート、更新時の動作について説明します。
  • テストのエクスポートと更新
    テストのエクスポートおよび更新方法について説明します。
  • テストのインポート
    Microsoft Excel からテストをインポートする方法について説明します。
  • マッピング ファイル
    テストの更新とインポート用のマッピング ファイルについて説明します。
  • テストのバージョン化
    Excel の更新またはインポート中のテストのバージョン化について説明します。
親トピック: 手動テスト
関連概念
手動テスト


エクスポート、更新、インポートのルール

エクスポート、更新、インポート処理では、次のルールが適用されます。

一般ルール

  • Excel のテスト行に TestID またはパスがない場合、新しいテストとみなされ、インポート機能が実行された、テストコンテナの下の新しいフォルダに作成されます。
  • 既存の TestID を追加して、更新時にテストを更新できます。また、既存の SharedStepID を追加して、インポート/更新時に新しい共有ステップを追加できます。
  • 新しい自動テストのインポートおよび更新はできません。
  • 継承した属性値はエクスポートされません。
  • Excel の別のフォルダ階層にテストを移動した場合、その移動は更新時に無視されます。
  • Excel 内にテストが見つからない (テストが削除された) 場合、そのテストは更新時に削除されません。
  • インポートは、(新しい) フォルダ名に パス 列を使用します。
  • カスタマイズされた列の名前として、A-Z は使用できません。これらは、Excel の A-Z として予約されており、マッピングに使用されます。

共有ステップ

  • インポートおよび更新時に追加されます。
  • 更新時に削除または順序が変更されます。
  • 更新されません。
  • Excel の SharedStepID が Silk Central に存在しない場合は、エラーが発生します。

データ駆動型テスト

  • データ駆動型の子テストはエクスポートできません。
  • すべてのテストがインポートされますが、データ駆動型プロパティは Excel からインポートおよびエクスポートされません。
  • 対象のフォルダにデータ駆動型テストが含まれていない場合にのみ、Excel から更新することができます。
親トピック: テストのエクスポート、更新、インポート


テストのエクスポートと更新

このセクションでは、Microsoft Excel から Silk Central にテストをエクスポートし、更新する方法について説明します。

既存のテストに対して一括編集を行う場合は、Excel へのエクスポート更新機能を使用します。

注: Excel では、Status、TestType、StepID、および StepOrder のフィールドは編集できません。

エクスポートと更新の概要

エクスポートと更新の概要を次に示します。

  • コンテナまたはフォルダを選択する。
  • Excel にエクスポートする。
  • Excel で変更する。
  • マッピング ファイルを確認/作成する。
  • Silk Central で更新する。
  • Excel にテストをエクスポートする
    テストを Excel にエクスポートする方法について説明します。
  • テストを Excel ファイルから更新する
    Silk Central から Excel へテストをダウンロードし、Excel でテストを更新します。
親トピック: テストのエクスポート、更新、インポート


Excel にテストをエクスポートする

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. エクスポートするテストが含まれるコンテナまたはテスト フォルダを右クリックします。
  3. Excel にエクスポート... を選択します。 Excel ファイルにテストをエクスポート ダイアログ ボックスが表示されます。
  4. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは TestPropertiesDefaultMapping.xml です。カスタマイズしたマッピング ファイルの作成の詳細については、「テストのマッピング ファイルを編集する」を参照してください。
  5. 省略可能： をクリックして、マッピング ファイルを編集します。 をクリックして、マッピング ファイルを削除します。
    注: これらのアクションを実行するには、Office インポート マッピング ファイルの編集/Office インポート マッピング ファイルの削除 アクセス許可がそれぞれ必要になります。
  6. OK をクリックします。
テスト情報が Excel ファイルに保存されますので、編集します。
親トピック: テストのエクスポートと更新
関連タスク
テストを Excel ファイルから更新する
テストのマッピング ファイルを編集する


テストを Excel ファイルから更新する

Excel からテストを更新する前に、まず、テストを Silk Central からエクスポートする必要があります。
  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 更新するテストが含まれるコンテナまたはフォルダを右クリックします。
  3. Excel から更新...を選択します。 Excel ファイルからテストを更新 ダイアログ ボックスが開きます。
  4. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは TestPropertiesDefaultMapping.xml です。カスタマイズしたマッピング ファイルの作成の詳細については、「テストのマッピング ファイルを編集する」を参照してください。
  5. 省略可能： をクリックして、マッピング ファイルを編集します。 をクリックして、マッピング ファイルを削除します。
    注: これらのアクションを実行するには、Office インポート マッピング ファイルの編集/Office インポート マッピング ファイルの削除 アクセス許可がそれぞれ必要になります。
  6. テスト ファイル (.xlsx) フィールドで、Excel ファイルを選択します。
  7. OK をクリックします。
親トピック: テストのエクスポートと更新
関連タスク
Excel にテストをエクスポートする
テストのマッピング ファイルを編集する


テストのインポート

このセクションでは、Microsoft Excel から Silk Central にテストをインポートする方法について説明します。

Silk Central を使用すると、Microsoft Excel (Excel) から テスト 領域のコンテナまたはフォルダにテストをインポートし、含まれているすべてのテストを Silk Central で管理および実行できます。手動テストのインポートは、1 回限りのイベントです。

テストをインポートする前に、Excel でテスト ファイルを作成する必要があります。詳細については、「テスト ファイル」を参照してください。

Silk Central は Excel ファイルとマッピング ファイルに格納されている情報を使用して、格納するデータを判別します。Silk Central はマッピング ファイルを使用して、Excel ファイル内のテストを テスト 領域のテストにマップします。TestPropertiesDefaultMapping.xml という名前のデフォルトのマッピング ファイルが、インポートのためにあらかじめ選択されます。独自にカスタマイズしたマッピング ファイルを選択して、テストをマップできます。マッピング ファイルの詳細については、「テストのマッピング ファイルを編集する」を参照してください。

  • テストを Excel ファイルからインポートする
    テストを Microsoft Excel ファイルからインポートして、テスト 領域に追加します。
  • テスト ファイル
    テストをインポートできるテスト Excel ファイルの内容について説明します。
親トピック: テストのエクスポート、更新、インポート
関連概念
テスト ファイル
関連タスク
テストのマッピング ファイルを編集する


テストを Excel ファイルからインポートする

テストを Excel ファイルから テスト 領域にインポートするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、インポートしたテストの親ノードとして使用するフォルダまたはコンテナを右クリックし、Excel からインポート を選択します。 Excel ファイルからテストをインポート ダイアログ ボックスが開きます。
  3. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは TestPropertiesDefaultMapping.xml です。カスタマイズしたマッピング ファイルの作成の詳細については、「テストのマッピング ファイルを編集する」を参照してください。
  4. 省略可能： をクリックして、マッピング ファイルを編集します。 をクリックして、マッピング ファイルを削除します。
    注: これらのアクションを実行するには、Office インポート マッピング ファイルの編集/Office インポート マッピング ファイルの削除 アクセス許可がそれぞれ必要になります。
  5. ルート フォルダを作成せずに選択したノードの直下にテストをインポートする場合は、ワンタイム インポート チェック ボックスをチェックします。
  6. テスト ファイルの完全修飾パスを テスト ファイル フィールドに入力するか、ファイルを選択 (または、参照) をクリックしてテスト ファイルを検索します。
  7. OK をクリックします。
親トピック: テストのインポート
関連概念
テスト ファイル
関連タスク
テストのマッピング ファイルを編集する


テスト ファイル

Excel でテスト ファイルを作成して、テストを Silk Central にインポートできます。テスト ファイルには、すべてのテストおよびテスト ステップに加えて、プロパティ、属性、およびパラメータを定義できます。

テスト ファイル内のテストを Silk Central のテストにマップするには、XML マッピング ファイルを使用します。マッピング ファイルは、テスト ファイルの要素の場所を Silk Central に定義します。テスト ファイルに含まれている項目は、マッピング ファイルで適切にマップしている限り、任意の名前を付けることができます。マッピング ファイルの詳細については、「テストのマッピング ファイルを編集する」を参照してください。

注: Silk Central では、現時点でインポート用に .xslx ファイルのみがサポートされており、インポートは手動テストに制限されています。

プロパティ マッピング

Excel ファイルからテストをインポート または Excel ファイルからテストを更新 ダイアログで、マッピングの編集 をクリックし、Excel ファイルのテストから Silk Central へのマッピングを次のようにに定義します。
  • ヘッダー行：プロパティとのマッピングに使用する列名を含んだ Excel テスト ファイルの行を指定します。
  • 最初のデータ行：最初のテストを含んだ行を指定します。この行とそれ以降のすべての行がテストとして読み取られます。
  • 区切り文字：プロパティ値内で区切り文字として解釈される文字を指定します。複数リスト プロパティとして使用されます。
  • 名前、説明：テスト名と説明にマップされるヘッダー行の列名をそれぞれ指定します。
  • 予定時間：この手動テストの実行に予定されている時間の長さ。
  • ステップ のプロパティ：テスト ステップの名前、アクションの説明、期待される結果。
  • 割り当て済み要件 ID:要件をテストに割り当てる場合、これらの要件の ID をカンマ区切りのリストで指定します。この列は、Excel ではテキスト形式で指定します。それ以外の形式では、割り当ては機能しません。
親トピック: テストのインポート
関連タスク
テストのマッピング ファイルを編集する


マッピング ファイル

マッピング ファイルは、エクスポート更新の更新プロセス中、およびデータを Excel から Silk Central に移行するインポート プロセス中に使用します。

  • テストのマッピング ファイルを編集する
    テストを Excel ファイルからインポートする場合に、テストのマッピング ファイルを GUI から直接編集します。
親トピック: テストのエクスポート、更新、インポート


テストのマッピング ファイルを編集する

マッピング ファイルの編集には、Office インポート マッピング ファイルの編集 アクセス許可が必要です。

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、インポートしたテストの親ノードとして使用するフォルダまたはコンテナを右クリックし、Excel からインポート を選択します。 Excel ファイルからテストをインポート ダイアログ ボックスが開きます。
  3. マッピングの編集 をクリックします。 マッピングの編集 ダイアログ ボックスが開きます。
  4. フィールドで、テスト ファイルの変数を編集します。
    注: テスト ファイルに含まれる変数の詳細については、「テスト ファイル」を参照してください。
  5. 省略可能： マッピング ファイルの名前を編集します。
  6. OK をクリックして変更内容を保存します。変更内容を取り消す場合は、キャンセル をクリックします。
親トピック: マッピング ファイル
関連概念
テスト ファイル


テストのバージョン化

Silk Central では、インポートおよび更新処理中にテストの新しいバージョンが作成されます。

Silk Central で Excel から更新を実行すると、テスト ツリーの新しいバージョンが 2 つ作成されます。バージョン化処理は、更新処理の前後のスナップショットが記録します。

エクスポート更新

テストが追加または変更されると、Excel から更新されたことを示すデフォルト コメントがテストに含まれます。

インポート

「作成されました。」というデフォルトコメントがテストに含まれます。

親トピック: テストのエクスポート、更新、インポート
関連タスク
テストを Excel ファイルから更新する


キーワード駆動テスト

キーワード駆動テスト は、テスト開発からテスト設計を分離するソフトウェア テスト手法です。 このため、テスト自動化プロセスにビジネス アナリストなどの専門家を含めることができます。Silk Central と Silk Test はキーワード駆動テストをサポートしており、Silk Test のキーワードの形式での共有資産として構成されるメンテナンス可能な自動化フレームワークを自動化エンジニアが開発することによって、自動化エンジニアとビジネス アナリスト間で密接な共同作業を行うことができます。その後、これらのキーワードは、Silk Test で新しいキーワード駆動テストを作成したり、Silk Central で既存の手動テスト資産を自動テストに変換したり、新しいキーワード駆動テストを作成するために、ビジネス アナリストが使用することができます。

  • キーワード駆動テスト は、実行可能なキーワードのコレクションです。キーワード駆動テストは、他のテストと同様に再生することができます。
  • キーワード シーケンスは、他のキーワードを組み合わせたものです。キーワード シーケンスは、頻繁に使用するキーワードの組み合わせを 1 つのキーワードにまとめることにより、メンテナンスの労力を低減し、テストを理解しやすくすることができます。
  • キーワード は、テスト オブジェクトに対する複数の操作の組み合わせを定義したものです。キーワードの実装は、さまざまなツールとプログラム言語 (Java や .NET など) を使用して行えます。

キーワード駆動テストの作成には、次の 2 つのフェーズがあります。
  1. テストの設計
  2. キーワードの実装
  • キーワード駆動テストの利点
    機能テストおよび回帰テストを行うためにキーワード駆動テスト手法を使用する利点を次に示します。
  • キーワード
    キーワード、およびその使い方について説明します。
  • テスト自動化の概要
    テスト自動化とテスト自動化フレームワークについて説明します。
  • Silk Central でキーワード駆動テストを作成する
    テスト自動化フレームワークのキーワード駆動テストを作成します。
  • 手動テストを自動化してキーワード駆動テストを作成する
    Silk Central の手動テストを自動化して、テスト自動化フレームワークのキーワード駆動テストに変換します。
  • テストのキーワードを管理する
    キーワード駆動テストのキーワードを操作のシーケンスを指定するために管理します。
  • ライブラリのキーワードを管理する
    キーワード シーケンスのキーワードを操作のシーケンスを指定するために管理します。
  • キーワード駆動テストを使用したクロス ブラウザ テスト
    パラメータを使用して複数のブラウザに対してキーワード駆動テストを実行します。
  • Java を使用したキーワード駆動ライブラリのビルド
    Java を使用して外部のキーワード駆動ライブラリをビルドし、Silk Central にアップロードします。これにより、Selenium テストなどの既存のテスト フレームワークと Silk Central を簡単に統合することができます。
  • コマンド ラインからのキーワード ライブラリの更新
    Java ベースのコマンド ラインから外部キーワード ライブラリをアップロードすることで、Silk Central とキーワード駆動テストを Jenkins などの継続的インテグレーション ビルド システムに統合することができます。
  • Silk4J/Silk4NET キーワード駆動テストをライブラリをアップロードせずに実行する
    Silk4J/Silk4NET キーワード駆動テストを、ライブラリをアップロードせずに Silk Central 上で実行します。
  • 例：パラメータを取るキーワード
    パラメータを取るキーワードを使用する方法について説明します。
  • Silk Central のキーワード レコメンド機能
    Silk Central がキーワード駆動テストに対するキーワードを推薦するのに使用する、基本的なレコメンド アルゴリズムについて説明します。
親トピック: テスト タイプ


キーワード駆動テストの利点

キーワード駆動テスト手法を使用する利点を次に示します。
  • キーワード駆動テストを使用すると、テスト自動化とテスト ケースのデザインが分離され、うまく分業できるようになり、キーワードを実装するテスト エンジニアとテスト ケースをデザインする専門家が共同作業できます。
  • テスト対象アプリケーションにアクセスすることなく、初期の段階からテストを開発でき、後からキーワードを実装できます。
  • プログラムの知識がなくてもテストを開発できます。
  • キーワード駆動テストは、長期的に見るとメンテナンス コストを低減できます。キーワードのメンテナンスが必要で、これらのキーワードを使用するすべてのキーワード駆動テストは自動的に更新されます。
  • テストケースが簡潔です。
  • 技術者でなくてもテスト ケースが読みやすく、理解しやすくなります。
  • テスト ケースの変更が簡単です。
  • 既存のキーワードを再利用して新しいテストを再利用できます。これにより、より広範囲なテスト カバレッジを実現しやすくなります。
  • キーワード実装の内部的な複雑性を、キーワード駆動テストを作成または実行するユーザーに対して隠蔽できます。
親トピック: キーワード駆動テスト


キーワード

キーワード は、テスト オブジェクトに対する複数の操作の組み合わせを定義したものです。キーワードの実装は、さまざまなツールとプログラム言語 (Java や .NET など) を使用して行えます。Silk Test で、キーワードは、アノテーション付きのテスト メソッド (@Keyword)です。キーワードは、キーワード資産として保存されます。

キーワード駆動テストとそれに関連したキーワードは、Silk Central で設計、管理することができますが、実際の実装は、機能テスト ツールで行います。Silk Central と Silk Test はキーワード駆動テストをサポートしており、Silk Test のキーワードの形式での共有資産として構成されるメンテナンス可能な自動化フレームワークを自動化エンジニアが開発することによって、自動化エンジニアとビジネス アナリスト間で密接な共同作業を行うことができます。その後、これらのキーワードは、Silk Test で新しいキーワード駆動テストを作成したり、Silk Central で既存の手動テスト資産を自動テストに変換したり、新しいキーワード駆動テストを作成するために、ビジネス アナリストが使用することができます。

キーワード シーケンスは、他のキーワードを組み合わせたものです。キーワード シーケンスは、頻繁に使用するキーワードの組み合わせを 1 つのキーワードにまとめることにより、メンテナンスの労力を低減し、テストを理解しやすくすることができます。

親トピック: キーワード駆動テスト


テスト自動化の概要

テスト自動化 とは、実行の実際の結果と期待する結果を比較する検証を使用して、テストの実行を制御するためにソフトウェアを使用する処理です。

テスト自動化フレームワーク とは、特定の製品の自動化の規則を集めた統合システムです。このシステムは、テスト、テスト データ ソース、オブジェクトの詳細、およびさまざまな再利用可能モジュールを統合します。これらのコンポーネントは、ビジネス プロセスを表現するために組み合わせて使用されます。フレームワークによって、テスト自動化の基礎が提供され、自動化の労力も低減されます。

親トピック: キーワード駆動テスト


Silk Central でキーワード駆動テストを作成する

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択します。
  3. ツールバーの 子テストの新規作成 (子テストの新規作成) をクリックするか、ツリー内を右クリックし、子テストの新規作成 を選択します。

    新規のテスト ノードがツリー ビューに追加され、テストの新規作成 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. タイプ リストから キーワード駆動テスト テスト タイプを選択します。
  6. 使用したいキーワードを含む ライブラリ を選択します。 ライブラリは、キーワード駆動テストが使用するキーワード群を格納するために必要です。
  7. 完了 をクリックします。
親トピック: キーワード駆動テスト


手動テストを自動化してキーワード駆動テストを作成する

Silk Central の手動テストをキーワード駆動テストに変換するには：
  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで手動テストを右クリックし、コンテキスト メニューから 自動化... > キーワード駆動テスト を選択します。 キーワード駆動テスト プロパティ ダイアログ ボックスが開きます。
  3. 使用したいキーワードを含む ライブラリ を選択します。 ライブラリは、キーワード駆動テストが使用するキーワード群を格納するために必要です。
  4. 終了 をクリックします。
手動テストを自動化する、次のようなキーワード駆動テストが生成されます。
  • 手動テストは、各テスト ステップに対してドラフト キーワードを含んだ自動化されたキーワード駆動テストに変換されます。これらのキーワードは、このテストに対して選択されたライブラリに追加されます。
  • テストに、すでにキーワード シーケンスとして存在する共有ステップへの呼び出しが含まれている場合、そのキーワード シーケンスが参照されます。
  • テストに、キーワード シーケンスとして存在しない共有ステップへの呼び出しが含まれている場合、その共有ステップ オブジェクトは、各テスト ステップに対してドラフト キーワードを含んだキーワード シーケンスに変換され、参照されます。これは、ネストした共有ステップ (他の共有ステップを参照する共有ステップ) にも適用されます。ネストした共有ステップの階層が 30 レベルを超えた深さの場合、そのレベル以下の共有ステップへの呼び出しに対してドラフト キーワードが作成されます。
  • テストが他のライブラリにある共有ステップへの呼び出しを含んでいる場合、そのステップに対するドラフト キーワードが作成され、参照されます。

テスト ステップに、生成したキーワードでアクセスしたいパラメータが含まれている場合、テスト ステップの アクションの説明 で、正しい文法を使用する必要があります。パラメータは、${<名前>} という構文を使用します (${username} など)。手動テストをキーワード駆動テストに変換する際には、これらのパラメータは生成されたキーワードに自動的に追加されます。

親トピック: キーワード駆動テスト


テストのキーワードを管理する

テスト > 詳細ビュー > <テスト> > キーワード
キーワード ページでは、選択したキーワード駆動テストのキーワードを管理できます。次のアクションを実行できます。
タスク | ステップ
テストまたはキーワード シーケンスを Silk Test で開く | Silk Test で開く をクリックして、選択したテストまたはキーワード シーケンスを Silk Test で開きます。
キーワードの追加
  1. キーワード リストの一番下にある 新しいキーワード をクリックするか、キーワードを右クリックして、コンテキスト メニューから キーワードを上に挿入 を選択します。
    注: キーワードの使用状況に基づいて、Silk Central にキーワードを推薦させることができます。推薦させるかどうかを切り替えるには、コンテキスト メニューの レコメンドの有効化 または レコメンドの無効化 を使用します。詳細については、「Silk Central が推薦するキーワード」を参照してください。
  2. 利用可能なキーワードのリストからキーワードを選択するか、新しいキーワードを作成します。
  3. 保存 をクリックします。
または、右側にある すべてのキーワード ペインから、既存のキーワードをダブル クリックするか、ドラッグ＆ドロップします。
ヒント: Ctrl + クリック を使用すると、複数のキーワードを選択できます。ドロップするとき、キーワードは選択した順番に並び替えられます。
キーワードの削除 | 削除するキーワードの アクション 列で 削除 をクリックします。保存 をクリックします。
キーワードの順序の変更 | キーワードを移動したい位置にドラッグ＆ドロップします。保存 をクリックします。
キーワード シーケンス (他のキーワードから構成されるキーワード) の作成
  1. キーワード リストから結合したいキーワードを選択します。行番号の列で Ctrl + クリック または Shift + クリック を使用すると、複数のキーワードを選択できます。
  2. 選択範囲を右クリックして、結合 をクリックします。
  3. 新しいキーワード シーケンスの 名前 と 説明 を指定します。
キーワード シーケンスからキーワードの抽出 | キーワード シーケンスを右クリックし、キーワードの抽出 を選択します。これによって、元のキーワード シーケンスがそれに含まれるキーワードによって置換されますが、ライブラリからは削除されません。保存 をクリックします。
テストまたはキーワード シーケンスへのキーワードのコピーと貼り付け
  1. キーワード リストからコピーしたいキーワードを選択します。行番号の列で Ctrl + クリック または Shift + クリック を使用すると、複数のキーワードを選択できます。
  2. Ctrl + C を押すと選択項目がコピーされます。キーワードを移動する場合には、Ctrl + X を押します。
  3. キーワードをコピーするテストまたはキーワード シーケンスを開き、キーワードを挿入する上の行を選択します。
  4. Ctrl + V を押します。
ヒント: 選択したキーワードを Excel に貼り付けて編集し、それをコピーしてテストまたはキーワード シーケンスに貼り付けることもできます。
キーワード シーケンスのパラメータの定義
  1. キーワード リスト上の パラメータ をクリックします。パラメータ ダイアログ ボックスが表示されます。
  2. パラメータの追加 をクリックします。
  3. 新しいパラメータに対して 名前 を指定します。パラメータが出力パラメータ (入力値を必要とするのではなく、値を戻します) の場合、出力 チェック ボックスをチェックします。
  4. OK をクリックします。
  5. 保存 をクリックします。
ドラフト キーワードの編集
  1. 編集するドラフト キーワードのアクション 列で、 編集 をクリックします。
  2. キーワードの グループ を選択するか、新しいグループを指定します。
  3. 説明 にキーワードの説明を入力します。この情報は、キーワードを実装するエンジニアにとって有益な情報です。
  4. OK をクリックします。
  5. 省略可能：パラメータ フィールドをクリックして、キーワードのパラメータを追加します。キーワードが Silk Test で実装されると、これらのパラメータは、生成されたコード スタブに現れます。
  6. 保存 をクリックします。
キーワードの検索
右側にある すべてのキーワード ペイン の検索フィールドを使用して、特定のキーワードを検索します。文字を入力するとリストが更新され、その文字に一致する既存のキーワードが動的に表示されます。検索のヒント：
  • 検索では大文字小文字は区別されません。doAction を入力すると、doaction や DOAction が表示されます。
  • 大文字のみを入力すると、いわゆる キャメルケース検索が実行されます。ECD を入力すると、Enter Car Details、Enter Contact Details、EnterContactDetails が表示されます。
  • キーワード名とグループ名が検索対象になります。test を入力すると、test を含むすべてのキーワードと、グループ名に test を含むグループのすべてのキーワードが表示されます。
  • ? は、0 または 1 文字と一致します。user?test を入力すると、userTest や usersTest が表示されます。
  • * は、0 または n 文字と一致します。my*keyword を入力すると、myKeyword や myNewKeyword や my_other_keyword が表示されます。
  • <文字列>. はグループ名のみを検索します。group. を入力すると、グループ名に group を含むグループのすべてのキーワードが表示されます。
  • .<文字列> はキーワード名のみを検索します。.keyword を入力すると、keyword を含むすべてのキーワードが表示されます。
  • <string>.<string> は特定のグループのキーワードを検索します。group.word を入力すると、myGroup グループの myKeyword が表示されます。
  • 引用符を使用して完全一致のみを検索します。'Keyword' を入力すると、Keyword やMyKeyword は表示されますが、keyword は表示されません。
ライブラリ内のドラフト キーワードの検索 | 選択したテストまたはキーワード シーケンスのドラフト キーワードを含むライブラリに移動したい場合、エディタ ページの右上にある ドラフト キーワード をクリックします。
親トピック: キーワード駆動テスト
関連概念
テストのデータ キャッシング
関連資料
ライブラリのキーワードを管理する
Silk Central のキーワード レコメンド機能


ライブラリのキーワードを管理する

キーワード ページでは、選択したオブジェクトに応じて、テスト > ライブラリ で 2 種類の異なるビューを提供します。

ライブラリ

選択したオブジェクトがライブラリの場合、このライブラリ内のすべてのキーワードとキーワード シーケンスがリストされます。アップロードしたキーワード ライブラリを含むライブラリは、 [image] アイコンで表示されます。次のアクションを実行できます。
タスク | ステップ
キーワードを実装する (テストでキーワードを実際に実行することができるコードを追加する) 前提条件：キーワードにパラメータが含まれる場合、キーワードを実装する前に各パラメータに値を指定する必要があります。
  1. 実装するキーワードのアクション 列で、 Silk Test で実装 (Silk Test で実装) をクリックします。
    注: 外部アプリケーションを開くときにブラウザーがセキュリティの警告を表示する場合、メッセージを確認します。
  2. Silk Test クライアントが開きます。詳細については、Silk Test クライアントのドキュメントを参照してください。
  3. キーワードを実装した後、Silk Central にアップロードします。
実装したキーワードを Silk Test で編集する | Silk Test で開く (Silk Test で開く) をクリックして、Silk Test クライアントでキーワードを開きます。詳細については、Silk Test クライアントのドキュメントを参照してください。
ドラフト キーワードのキーワード シーケンス (他のキーワードから構成されるキーワード) への変換 | キーワード シーケンスに変換するキーワードの アクション 列で キーワード シーケンスの作成 をクリックします。それから、元のキーワードが同じ名前を持つキーワード シーケンスで置き換えられ、キーワード エディタが開きます。
キーワード シーケンスをドラフト キーワードに変換 誤ってキーワード シーケンスを作成した場合、ドラフト キーワードに戻すことができます。変換するキーワード シーケンスのアクション 列で、 ドラフト キーワードに変換 (ドラフト キーワードに変換) をクリックします。
注: キーワード シーケンスをドラフト キーワードに変換すると、シーケンスおよびすべての含まれるキーワードは削除されます。このアクションは元に戻すことはできません。
キーワード シーケンスの編集 | 移動 をクリックして、キーワード エディタでキーワード シーケンスを開きます。
キーワードのグループ化 キーワードをライブラリで構造化するために、グループ化することができます。
  • Silk Central キーワード シーケンスは、サブフォルダになります。フォルダ名をグループ名として、キーワードはグループ化されてリストに表示されます。
  • 実装したキーワードのキーワード グループは、実装コードで定義されます。このグループ名は Silk Central で使用され、キーワードはグループ化されてリストに表示されます。
特定のキーワードまたはキーワード シーケンスを参照するテストおよびキーワード シーケンスの表示 | 特定のキーワードまたはキーワード シーケンスを参照するすべてのテストおよびキーワード シーケンスを表示するには、キーワード リストから適切な項目を選択します。すると、参照元 リストにすべての参照しているキーワード駆動テストとキーワード シーケンスが表示されます。名前をクリックすると対応する参照に移動します。
参照しているテストおよびキーワード シーケンスでのキーワードの置換 選択したキーワードまたはキーワード シーケンスへの参照を他で置換するには、キーワード リストから適切な項目を選択し、参照元 リストから参照を置換するオブジェクトを選択します。
  1. 置換するキーワードまたはキーワード シーケンスを選択します。
  2. 参照元 リストで、Ctrl + クリック または Shift + クリック を使用して参照を置換するオブジェクトを複数選択できます。
  3. 選択項目を右クリックして、選択した参照でのキーワードの置換 を選択します。参照の置換 ダイアログ ボックスが表示されます。
  4. キーワード リストから結合したいキーワードを選択します。
  5. 選択したキーワードにパラメータが含まれている場合、次へ をクリックします。 含まれていない場合は、OK をクリックして完了します。
  6. 選択したキーワードのパラメータが表示されます。それぞれのパラメータに対して、前のキーワードの対応するパラメータを選択するか、値を入力します。
  7. OK をクリックします。

キーワード シーケンス

選択したオブジェクトがキーワード シーケンス (他のキーワードから構成されるキーワード) の場合、キーワード ページにはキーワード エディタが表示され、選択したキーワード シーケンスのキーワードを管理できます。次のアクションを実行できます。
タスク | ステップ
テストまたはキーワード シーケンスを Silk Test で開く | Silk Test で開く をクリックして、選択したテストまたはキーワード シーケンスを Silk Test で開きます。
キーワードの追加
  1. キーワード リストの一番下にある 新しいキーワード をクリックするか、キーワードを右クリックして、コンテキスト メニューから キーワードを上に挿入 を選択します。
    注: キーワードの使用状況に基づいて、Silk Central にキーワードを推薦させることができます。推薦させるかどうかを切り替えるには、コンテキスト メニューの レコメンドの有効化 または レコメンドの無効化 を使用します。詳細については、「Silk Central が推薦するキーワード」を参照してください。
  2. 利用可能なキーワードのリストからキーワードを選択するか、新しいキーワードを作成します。
  3. 保存 をクリックします。
または、右側にある すべてのキーワード ペインから、既存のキーワードをダブル クリックするか、ドラッグ＆ドロップします。
ヒント: Ctrl + クリック を使用すると、複数のキーワードを選択できます。ドロップするとき、キーワードは選択した順番に並び替えられます。
キーワードの削除 | 削除するキーワードの アクション 列で 削除 をクリックします。保存 をクリックします。
キーワードの順序の変更 | キーワードを移動したい位置にドラッグ＆ドロップします。保存 をクリックします。
キーワード シーケンス (他のキーワードから構成されるキーワード) の作成
  1. キーワード リストから結合したいキーワードを選択します。行番号の列で Ctrl + クリック または Shift + クリック を使用すると、複数のキーワードを選択できます。
  2. 選択範囲を右クリックして、結合 をクリックします。
  3. 新しいキーワード シーケンスの 名前 と 説明 を指定します。
キーワード シーケンスからキーワードの抽出 | キーワード シーケンスを右クリックし、キーワードの抽出 を選択します。これによって、元のキーワード シーケンスがそれに含まれるキーワードによって置換されますが、ライブラリからは削除されません。保存 をクリックします。
キーワード シーケンスのパラメータの定義
  1. キーワード リスト上の パラメータ をクリックします。パラメータ ダイアログ ボックスが表示されます。
  2. パラメータの追加 をクリックします。
  3. 新しいパラメータに対して 名前 を指定します。パラメータが出力パラメータ (入力値を必要とするのではなく、値を戻します) の場合、出力 チェック ボックスをチェックします。
  4. OK をクリックします。
  5. 保存 をクリックします。
ドラフト キーワードの編集
  1. 編集するドラフト キーワードのアクション 列で、 編集 をクリックします。
  2. キーワードの グループ を選択するか、新しいグループを指定します。
  3. 説明 にキーワードの説明を入力します。この情報は、キーワードを実装するエンジニアにとって有益な情報です。
  4. OK をクリックします。
  5. 省略可能：パラメータ フィールドをクリックして、キーワードのパラメータを追加します。キーワードが Silk Test で実装されると、これらのパラメータは、生成されたコード スタブに現れます。
  6. 保存 をクリックします。
キーワードの検索
右側にある すべてのキーワード ペイン の検索フィールドを使用して、特定のキーワードを検索します。文字を入力するとリストが更新され、その文字に一致する既存のキーワードが動的に表示されます。検索のヒント：
  • 検索では大文字小文字は区別されません。doAction を入力すると、doaction や DOAction が表示されます。
  • 大文字のみを入力すると、いわゆる キャメルケース検索が実行されます。ECD を入力すると、Enter Car Details、Enter Contact Details、EnterContactDetails が表示されます。
  • キーワード名とグループ名が検索対象になります。test を入力すると、test を含むすべてのキーワードと、グループ名に test を含むグループのすべてのキーワードが表示されます。
  • ? は、0 または 1 文字と一致します。user?test を入力すると、userTest や usersTest が表示されます。
  • * は、0 または n 文字と一致します。my*keyword を入力すると、myKeyword や myNewKeyword や my_other_keyword が表示されます。
  • <文字列>. はグループ名のみを検索します。group. を入力すると、グループ名に group を含むグループのすべてのキーワードが表示されます。
  • .<文字列> はキーワード名のみを検索します。.keyword を入力すると、keyword を含むすべてのキーワードが表示されます。
  • <string>.<string> は特定のグループのキーワードを検索します。group.word を入力すると、myGroup グループの myKeyword が表示されます。
  • 引用符を使用して完全一致のみを検索します。'Keyword' を入力すると、Keyword やMyKeyword は表示されますが、keyword は表示されません。
ライブラリ内のドラフト キーワードの検索 | 選択したテストまたはキーワード シーケンスのドラフト キーワードを含むライブラリに移動したい場合、エディタ ページの右上にある ドラフト キーワード をクリックします。
親トピック: キーワード駆動テスト
親トピック: ライブラリ
関連概念
テストのデータ キャッシング
関連資料
テストのキーワードを管理する
Silk Central のキーワード レコメンド機能


キーワード駆動テストを使用したクロス ブラウザ テスト

Silk Test で実装され、BrowserBaseState を含むキーワード駆動テストは、Silk Central でパラメータ化することにより、複数のブラウザに対してテストを実行できます。テストするブラウザを設定するには：
  1. 構成スイートを作成し、複数のブラウザに対して実行するキーワード駆動テストを割り当てます。構成スイートの作成についての詳細は、「構成スイートを作成する」を参照してください。
  2. 構成 タブで パラメータの追加/削除 をクリックして、silktest.configurationName という名前の新しいパラメータを作成します。
  3. 構成の新規作成 をクリックして、テストする構成を追加します。それぞれの構成に対して、silktest.configurationName パラメータに、テストするブラウザに従って次の値のいずれかを入力します。
    • Internet Explorer
    • Firefox
    • Chrome
  4. 構成スイートを実行します。
親トピック: キーワード駆動テスト


Java を使用したキーワード駆動ライブラリのビルド

Java を使用して外部のキーワード駆動ライブラリをビルドし、Silk Central にアップロードします。これにより、Selenium テストなどの既存のテスト フレームワークと Silk Central を簡単に統合することができます。
  1. ヘルプ > ツール を選択し、Java キーワード ライブラリ ツール をダウンロードします。
  2. ダウンロードした com.borland.silk.keyworddriven.jar を Java プロジェクトのクラスパスに追加します。
  3. キーワードを含む Java クラスを作成します。
  4. キーワードとして使用する Java メソッドにアノテーションを指定します。1 つのキーワードを含むクラスは、次のサンプルのようになります。
    import com.borland.silk.keyworddriven.annotations.Argument;
import com.borland.silk.keyworddriven.annotations.Keyword;

public class Keywords {

  @Keyword("My Keyword")
  public void myKeyword(@Argument("Username") String name) {
    System.out.println(name);
  }
}
  5. ソースをコンパイルして、Java アーカイブ (jar) を作成します。
  6. ダウンロードした jarファイルに含まれるコマンド ライン ツールを次の引数で呼び出します。
    • java
    • -jar com.borland.silk.keyworddriven.jar
    • -build
    • 生成する ライブラリ名。
    • ライブラリ タイプ (現時点では、「Java」のみがサポートされています)。
    • キーワード ライブラリの jar ファイル (および他の必要なライブラリ) の存在する バイナリのパス。
    • 生成する出力ライブラリ パッケージ (zip アーカイブ) の 名前。
    キーワード ライブラリをビルドするコマンド ラインは次のようになります。
    java -jar com.borland.silk.keyworddriven.jar -build
MyLibrary Java ./output "./output/library.zip"
テスト > ライブラリ > <ライブラリ> > プロパティ を選択します。生成した zip アーカイブは、コマンド ライン ツールを使用するか、または キーワード ライブラリ セクションから Silk Central にアップロードできます。
親トピック: キーワード駆動テスト
親トピック: ライブラリ
関連概念
キーワード ライブラリとライブラリ プロパティを管理する
関連タスク
コマンド ラインからのキーワード ライブラリの更新


コマンド ラインからのキーワード ライブラリの更新

Java ベースのコマンド ラインから外部キーワード ライブラリをアップロードすることで、Silk Central とキーワード駆動テストを Jenkins などの継続的インテグレーション ビルド システムに統合することができます。
Java ベースのコマンド ラインからキーワード ライブラリをアップロードするには：
  1. ヘルプ > ツール を選択し、Java キーワード ライブラリ ツール をダウンロードします。
  2. ダウンロードした jarファイルに含まれるコマンド ライン ツールを次の引数で呼び出します。
    • java
    • -jar com.borland.silk.keyworddriven.jar
    • -upload
    • 更新または存在しない場合は作成される Silk Central のライブラリの ライブラリ名。
    • アップロードするライブラリ パッケージ (zip アーカイブ) の パッケージ名。
    • Silk Central フロントエンド サーバーのホスト名:ポート。
    • Silk Central ユーザーの ユーザー名。
    • Silk Central ユーザーの パスワード。
    • ライブラリに適用された変更を説明する 更新情報 (引用符で囲む)。
    • テストまたはキーワード シーケンスで使用されているキーワードの削除を許可するための [-allowUsedKeywordDeletion] フラグ (省略可能)。デフォルトでは、使用中のキーワードを削除しようとするとエラーが発生します。
    ライブラリを Silk Central にアップロードするコマンド ラインは次のようになります。
    java -jar com.borland.silk.keyworddriven.jar -upload
"My library" "./output/library.zip" silkcentral:19120 scLogin
scPassword "Build xy:Implemented missing keywords"
親トピック: キーワード駆動テスト
関連概念
オートメーション サーバーとの統合
Silk Central の Web サービス
関連タスク
Java を使用したキーワード駆動ライブラリのビルド


Silk4J/Silk4NET キーワード駆動テストをライブラリをアップロードせずに実行する

Silk4J または Silk4NET のキーワード駆動テストで構成される既存のテスト自動化フレームワークがあり、これを Silk Central から実行したい場合、Silk Central の JUnit およびテスト パッケージ機能を使用して行うことができます。実際に行うには、次のステップに従います。
  1. Silk Test プロジェクトの資産にアクセスできるようにソース管理プロファイルを作成します (「ソース管理プロファイル」を参照)。
  2. このソース管理プロファイルを使用するテスト コンテナを作成します (「テスト コンテナを追加する」を参照)。
  3. JUnit テストを作成し (「テストを作成する」を参照)、次のように設定します。
    • Silk4Jで実装されたキーワード駆動テストに対して：
      • クラスパスを設定します。デフォルトの Silk Test ビルド構造を使用している場合、.\output を指定します。
      • クラスパスとして指定したフォルダに、.kdt ファイルがある必要があります (.jar ファイルにパッケージされているか、クラスパスのフォルダ内にあるかのいずれか)。
    • Silk4NETで実装されたキーワード駆動テストに対して：
      • クラスパスに ./Keyword Driven Tests を指定します。

      • テストのテスト コンテナに silktest.keyworddriven.dotnetassembly というパラメータを作成し ([カスタム パラメータを作成する」を参照)、.NET アセンブリへのパス (\bin\Release\Silk4NETProject.dll など) を設定します。

      • .kdt ファイルを含んだ Keyword Driven Tests という名前の Silk Test フォルダは、ソース管理のルート フォルダに存在する必要があります。
  4. テストを実行計画に割り当てます (「割り当て済みテスト」を参照)。
  5. 省略可能：一度実行した後に、テストを右クリックして テスト パッケージに変換 を選択すると、パッケージ構造が得られます (「テスト パッケージを作成する」を参照)。
親トピック: キーワード駆動テスト


例：パラメータを取るキーワード

このトピックでは、パラメータを取るキーワードを使用する方法の例を紹介します。

最初の手順として、使用するキーワードを含んだキーワード駆動テストを作成します。これは、キーワード駆動テスト全体を記録するか、新しいキーワード駆動テストを作成してからキーワード駆動テスト エディターでキーワードを追加することによって行います。

この例では、キーワード駆動テストは次のつのキーワードを含んでいます。
Start application
これは、AUT を開始して基本状態を設定する標準キーワードです。
Login
これは、ユーザー名とパスワードで識別される特定のユーザーで AUT にログインするキーワードです。
GetCurrentUser
このキーワードは、AUT に現在ログインしているユーザーの名前を返します。
AssertEquals
このキーワードは、2 つの値を比較します。
Logout
これは、AUT からユーザーをログアウトするキーワードです。

次のステップでは、パラメータをキーワードに追加します。これを行うには、キーワードのテスト スクリプトを開き、メソッドにパラメータを追加します。

入力パラメータ UserName と Password をキーワード Login に追加するには、
@Keyword("Login")
public void login() {
  ...
}
を、次のように変更します。
@Keyword("Login")
public void login(String UserName, String Password) {
  ...
}
出力パラメータ UserName をキーワード GetCurrentUser に追加するには、
@Keyword("GetCurrentUser")
public void getCurrentUser() {
  ...
}
を、次のように変更します。
@Keyword("GetCurrentUser")
public void getCurrentUser(OutParameter CurrentUser) {
  ...
}

キーワード駆動テスト エディター 上のキーワード駆動テストは、次のようになります。

これで、キーワード駆動テスト エディター 上で入力パラメータの実際の値を指定できます。キーワード GetCurrentUser の出力パラメータ UserName の値を取得するには、${current user} のように、変数を指定します。その後のキーワードで、変数を指定して格納された値を渡すことができます。

親トピック: キーワード駆動テスト


Silk Central のキーワード レコメンド機能

キーワード駆動テスト エディター でキーワード駆動テストにキーワードを追加するとき、Silk Central は、そのテストの次のキーワードとして使用する可能性のある既存のキーワードを推薦します。推薦するキーワードはキーワード リストの上位にリストされ、Silk Central がどの程度そのキーワードを推薦しているかが、棒グラフの塗りつぶした長さによって示されます。

Silk Central は、次のアルゴリズムに基づいてキーワードを推薦します。

  • キーワード駆動テストまたはキーワード シーケンスに最初のキーワードを追加する場合、Silk Central は他のキーワード駆動テストまたはキーワード シーケンスの最初のキーワードとして使用されているのと同様なキーワードを検索します。最も頻繁に使用されるキーワードがより上位に推薦されます。
  • 既に他のキーワードを含んでいるキーワード駆動テストまたはキーワード シーケンスに、さらにキーワードを追加する場合、Silk Central は次のようにしてキーワードを推薦します。
    • 新しいキーワードを追加するキーワード駆動テストまたはキーワード シーケンスの位置の前にキーワードがある場合、Silk Central は前のキーワード群と、すべてのほかのキーワード駆動テストとキーワード シーケンスのキーワードの組み合わせとを比較し、最も頻繁に使用されているキーワードの組み合わせに続いて現れるキーワードを推薦します。
    • キーワード駆動テストまたはキーワード シーケンスの位置の前にキーワードがないが、現在の位置の後にキーワードがある場合、Silk Central は後のキーワード群と、すべてのほかのキーワード駆動テストとキーワード シーケンスのキーワードの組み合わせとを比較し、最も頻繁に使用されているキーワードの組み合わせの前に現れるキーワードを推薦します。
  • さらに、Silk Central は見つかったキーワードの類似性も考慮します。たとえば、2 つのキーワードの名前とグループの両方が一致する場合、Silk Central は名前だけが一致するキーワードよりもこれらをより上位に推薦します。
親トピック: キーワード駆動テスト
関連概念
テストのデータ キャッシング
関連資料
テストのキーワードを管理する
ライブラリのキーワードを管理する


Unified Functional Testing（UFT）テスト

以前は HP QuickTest Professional（QTP）として知られていた Unified Functional Testing（UFT）ソフトウェアは、ソフトウェア アプリケーションに対する機能テストと回帰テストの自動化と環境を提供します。
  • Unified Functional Testing (UFT) テストを作成または編集する
    Silk Central から UFT テストを実行するために、UFT テストを作成または編集します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


Unified Functional Testing (UFT) テストを作成または編集する

UFT テストを実行するには、Silk Central 実行サーバーがインストールされているのと同じコンピュータに Unified Functional Testing ソフトウェアがインストールされている必要があります。

UFT テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから Unified Functional Testing テスト を選択します。次へ をクリックします。

    Unified Functional Testing テスト プロパティ ダイアログ ボックスが開きます。

  6. テスト フィールドには、実行する UFT テストのソース管理の場所を選択します。
    ヒント: テストそのもの (.tsp) を選択することも、テストが存在するフォルダを選択することもできます。
  7. 省略可能：HPE UFT アドインの検証 オプションをオンにすると、選択した UFT テストのすべての指定したアドインが検証されます。
  8. 省略可能：HPE UFT アプリケーションの表示 オプションをオンにすると、テスト実行中にテスト対象アプリケーションが表示されます。
  9. 省略可能：デバッグ メッセージの記録 オプションをオンにすると、テストの実行結果にデバッグ メッセージが記録されます。
  10. 省略可能：親から継承 チェック ボックスをオンにすると、親の UFT テストから設定が継承されます。
  11. 完了 をクリックします。
注: UFT テスト内で定義されたテスト パラメータと同じ名前のパラメータを定義すると、そのパラメータは UFT テストに渡されます。

元の UFT の結果ファイルである run_results.xml とrun_results.html は、テスト実行の結果の ファイル タブから取得できます。

親トピック: Unified Functional Testing（UFT）テスト


JUnit テスト

JUnit は、Java プログラム言語用の単体テスト フレームワークです。JUnit、Silk4J、Selenium テストに、このテストタイプを使用します。
  • JUnit テストを作成または編集する
    Java の単体テストフレームワークを実行するために、JUnit テストを作成または編集します。
  • Java システム プロパティを通じて Silk Central パラメータにアクセスする
    JUnit テストで Java システム プロパティを通じてアクセスできる Silk Central パラメータを一覧表示します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


JUnit テストを作成または編集する

JUnit テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから JUnit テスト を選択します。次へ をクリックします。

    JUnit テスト プロパティ ダイアログ ボックスが開きます。

  6. 実行サーバー上で使用する有効な Java クラスパス を指定します。

    相対パスを使用することを推奨します。相対パスは、のちに実行サーバー上で完全クラスパスに展開されます。相対クラスパスを使用することで、ソース管理プロファイルの場所が変更されても、クラスパスへの追加変更が必要なくなります。

    相対クラスパスは、JUnit テストを保持しているテスト コンテナのルート ノード (JUnit_tests など) を指している必要があります。その後、実行サーバー上の相対クラスパスは、ソース管理プロファイルの作業フォルダ (C:\temp など) と、テスト ファイル名 (tests.jar など) を含むように展開されます。たとえば、テストを tests.jar という名前の JAR ファイルにアーカイブし、実行に必要なほかのファイルを lib フォルダ下に保存した場合、クラスパスは ./tests.jar;./lib/* のようになります。

    ユーザーは、完全修飾クラスパスを使用することもできます。クラスパスは、このテスト クラスが存在するアーカイブまたはフォルダを指していなければなりません (完全修飾パス)。

  7. 省略可能： テスト クラス フィールドには、JUnit テスト クラスの完全修飾名を入力します。フィールドを空のままにすると、クラスパス内にあるすべてのテストが実行されます。ただし、テストを含む JAR ファイルが クラスパス で明示的に設定されている必要があります。
  8. 省略可能： テスト メソッド フィールドに、適切なテスト メソッドの名前を入力します。
    このメソッドは、指定したテスト クラス内で利用可能なものでなければなりません。テスト メソッド フィールドが空欄の場合、そのスイート内にあるすべてのテストが実行されます。
  9. 省略可能： Java ホーム ディレクトリ には、Java Runtime Environment (JRE) のインストール パスを設定します。
    このパスは、テストを実行する実行サーバー上で有効でなければなりません。
    注: JUnit テストは、JRE 1.5 以降で実行できます。それより古い JRE を使用している場合は、java.lang.UnsupportedClassVersionError または Unrecognized option: -javaagent を含むメッセージがメッセージタブに表示されます。
  10. 省略可能： JVM オプション フィールドには、コマンド ライン オプションを指定できます。複数のオプションを指定できますが、正しい順序で入力する必要があります。たとえば、クライアント VM を使用し、ヒープの最大サイズを 512 MB に設定するには、-client -Xmx512m と入力します。-Xmx${MY_MEMORY} などの環境変数を使用することもできます。
  11. AUT カバレッジのみ記録 チェック ボックスをオンにすると、コード分析設定 セクション (Silk Central > 実行計画 > コード分析) 内の実行計画に対して定義されている、テスト対象アプリケーション (AUT) のコード カバレッジのみを取得します。 チェック ボックスをオフにすると、テストを実行する仮想マシンのコード カバレッジも記録されます。
  12. 省略可能： テスト カバレッジ パス フィールドには、コード カバレッジ情報を監視するための完全修飾 JAR ライブラリまたは特定のクラス ファイルを、完全修飾パスで入力します。ここで指定するのは、テスト対象アプリケーションのパスではなく、JUnit テストのカバレッジ パスであることにご注意ください。

    後から実行サーバー上で適切に展開される、テスト コンテナ ルート ノードからの相対カバレッジ パスを使用することを推奨します。ユーザーは、完全修飾パスを使用することもできます。複数の jar ファイルがある場合には、次の例に示すように、セミコロンを区切り文字に使用します。

    • tests.jar;C:\tests\testutils.jar
    • ${testenv}\tests.jar;${testenv}\testutils.jar
    注: カバレッジ パス設定は、外部 AUT カバレッジの記録 チェック ボックスがオンになっている場合は無視されます。
  13. 完了 をクリックします。
注: パラメータは、Java プロセスにシステム プロパティとして渡されます (例、-Dhost_under_test=10.5.2.133)。このシステム プロパティにアクセスするには、System.getProperty() メソッドを使用します。たとえば、前に渡された host_under_test にアクセスするには、System.getProperty(“host_under_test”); を使用します。
親トピック: JUnit テスト
関連タスク
テストを試験実行する


Java システム プロパティを通じて Silk Central パラメータにアクセスする

任意の JUnit テスト クラスから、Java のシステム プロパティとして、元のテストのテスト パラメータにアクセスすることができます。ランチャは、-D という VM 引数を使って、実行するマシンにこのパラメータを渡します。

カスタマー定義のパラメータに加えて、以下の Java システム プロパティを JUnit テストから常に呼び出すことができます。
パラメータ
説明
#sctm_execdef_name
現在実行されている実行計画の名前。実行が テスト 領域からトリガされた場合、パラメータは値 未割り当てテスト を持ちます。
#sctm_execdef_id
現在実行されている実行計画の数値識別子 (データベース キー)。
#sctm_product
実行されたテスト コンテナで定義された製品の名前。
#sctm_version
実行の結果が関連付けられているバージョンの名前。
#sctm_build
実行の結果が関連付けられているバージョンの名前。
#sctm_keywords
この実行計画に対して定義されているキーワードを含むカンマ区切りの一覧。
#sctm_test_results_dir
テストの結果ファイルが存在するディレクトリのパス。
#sctm_test_name
実行している Silk Central テストの名前。
#sctm_test_id
実行しているテストの数値識別子 (データベース キー)。
#sctm_source_root_dir
バージョン コントロール下にあるすべてのファイルが置かれているテスト コンテナのルート ディレクトリのローカル パス。
#external_id
実行されるテスト パッケージ内のテスト ケースの一意の識別子。テスト パッケージ内の特定のテスト ケースだけを実行させる場合のフィルタとして利用できます。

#is_test_package_root
true の場合、実行されるテストはテスト パッケージのルート ノードです (デフォルト)。false の場合、#external_id によって指定されたテスト パッケージ内の特定のテスト ケースだけが実行されます。
#sctm_data_driven_parent_test_name
親のテストの名前 (実行したテストがデータ駆動行の場合)。
#sctm_data_driven_parent_test_id
親のテストの数値識別子 (データベース キー) (実行したテストがデータ駆動行の場合)。
親トピック: JUnit テスト
関連概念
テスト パラメータ
関連資料
事前定義パラメータ


MSTest テスト

MSTest は、Visual Studio で作成した単体テストを実行するための、Microsoft のコマンド ライン ツールです。MSTest、Silk4NET テストに、このテストタイプを使用します。
  • MSTest テストを作成または編集する
    Visual Studio の単体テストフレームワークを実行するために、MSTest テストを作成または編集します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


MSTest テストを作成または編集する

注: MSTest プラグインは、単体テストのみのテスト タイプをサポートします。他のテスト タイプの結果は無視されます。

MSTest テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから MSTest テスト を選択します。次へ をクリックします。

    MSTest テスト プロパティ ダイアログ ボックスが開きます。

  6. 次の手順を実行することで、テスト コンテナ、テスト リスト、テスト クラス、単一のテストのメソッドを実行できます。
    • テスト コンテナを実行するには、テスト ファイル フィールドの横にある 参照 をクリックして .dll ファイルを選択します。テスト クラス のみ、または テスト クラス と テスト メソッド の両方を入力することで、実行を制限できます。
    • テスト リストを実行するには、テスト ファイル フィールドの横にある 参照 をクリックして .vsmdi ファイル (Visual Studio Test メタデータ) を選択します。テスト リスト名 フィールドに名前を入力します。テスト クラス および テスト メソッド の両方を入力することで、実行を制限できます。
  7. 完了 をクリックします。
注: 実行サーバーで MSTest を実行するには、Visual Studio Distribution または Visual Studio Test Agent のインストールが必要です。MSTest.exe を含むフォルダをパス変数に追加し、実行サーバーを再起動します。デフォルトのパスは次の通りです：C:\Program Files (x86)\Microsoft Visual Studio <バージョン>\Common7\IDE。現在、Microsoft Visual Studio/Visual Studio Test Agent 2012、2013、2015 で配布された MSTest がサポートされています。
親トピック: MSTest テスト
関連タスク
ローカル実行サーバー サービスを開始または停止する
テストを試験実行する


NUnit テスト

NUnit は、Microsoft .NET プログラム言語用の単体テスト フレームワークです。
  • NUnit テストを作成または編集する
    Microsoft .NET の単体テストフレームワークを実行するために、NUnit テストを作成または編集します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


NUnit テストを作成または編集する

注: NUnit インストールの .\bin フォルダを、システム パスに追加することをお勧めします。スタート > コントロール パネル > システム > 詳細設定 > 環境変数... をクリックして、C:\Program Files\NUnit 2.2\bin などのパスをシステム環境変数 PATH に追加します。

NUnit テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから NUnit テスト を選択します。次へ をクリックします。

    NUnit テスト プロパティ ダイアログ ボックスが開きます。

  6. 参照 をクリックし、テストを抽出する NUnit アセンブリを探して選択します。
  7. NUnit ディレクトリ フィールドに作業ディレクトリを入力します。

    NUnit 2 の場合、このディレクトリは、ファイル nunit-console.exe へのローカル パスです（C:\Program Files\NUnit 2.2\bin など）。NUnit 3 の場合、このディレクトリは、ファイル nunit3-console.exe への完全パスです（C:\Program Files (x86)\NUnit.org\nunit-console\nunit3-console.exe など）。

  8. NUnit オプション フィールドに、1 つ以上の NUnit コンソール コマンドライン オプションを入力し、NUnit テストを指定する方法を指定します。 たとえば、SilkTest.Ntf.Test.Flex にある Flex4TestApp NUnit テストを実行するように定義するには、以下のように run オプションを設定します。
    NUnit 2 の場合：
    /run:SilkTest.Ntf.Test.Flex.Flex4TestApp
    NUnit 3 の場合：
    /test:SilkTest.Ntf.Test.Flex.Flex4TestApp
    注: 複数のオプションを追加する場合は、フィールドの各行に 1 つのオプションを記述することによって、オプションを区切る必要があります。
  9. 完了 をクリックします。
親トピック: NUnit テスト
関連タスク
テストを試験実行する


ProcessExecutor テスト

ProcessExecutor テスト タイプは、任意のコマンド ラインを実行するために使用できます。
  • ProcessExecutor テストを作成または編集する
    実行可能ファイルを起動して実行するために、ProcessExecutor テストを作成または編集します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


ProcessExecutor テストを作成または編集する

ProcessExecutor テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから ProcessExecutor テスト を選択します。次へ をクリックします。 ProcessExecutor テスト プロパティ ダイアログ ボックスが開きます。
  6. 実行可能ファイル名 フィールドに、実行可能ファイルの完全修飾名を入力します。
  7. 引数リスト フィールドに、ProcessExecutor テスト メソッドのすべての引数を入力します。
    注: 複数の引数を入力する場合は、フィールド内に個別の行として入力します。
  8. 作業フォルダ を設定します。 これは、実行可能ファイルが実行されるフォルダです。
  9. 実行したコマンドが JUnit テスト結果ファイルを生成する場合 (Ant や Maven の JUnit 実行など)、JUnit 結果 XML ファイルを探すフォルダ パターンを指定できます。フォルダの場所は、作業ディレクトリに相対的です (test-results など)。検索を開始するルート フォルダは 作業フォルダ で、入力したパターンを含むパスを持つすべての JUnit 出力ファイルが取得されます。
実行可能ファイルの実行中に、次の 2 つの環境変数を使用できます。
環境変数
説明
SCTM_EXEC_RESULTSFOLDER
このフォルダ内のすべてのファイルは、Silk Central の結果ファイルとして保存されます。実行中にこのディレクトリに output.xml ファイルが作成されると、このファイルは Silk Central によって処理されます。
SCTM_EXEC_SOURCESFOLDER
これは、実行中に使用されるすべてのソース ファイルがあるフォルダです。

例

次の例は、/c スイッチと 2 つのパラメータを使用してコマンドラインから Windows Script Host を実行する ProcessExecutor テスト タイプを示しています。

ProcessExecutor テスト プロパティ

  • /c：実行後にコマンドラインを終了することを指定するコマンド。
  • cscript：Windows Script Host。
  • parareadwrite.js：parareadwrite.js という名前の JScript ファイル。
  • %SCTM_EXEC_RESULTSFOLDER%：実行サーバー マシン上の Result フォルダの場所を含む Silk Central 変数。この場所に保存されたファイルは自動的に Silk Central にアップロードされて、テストの実行 の ファイル タブで使用できます。この例では、parareadwrite.js スクリプトによって Result フォルダに output.xml ファイルが作成されて、Silk Central にアップロードされます。
親トピック: ProcessExecutor テスト
関連タスク
テストを試験実行する


Silk Performer .NET Explorer テスト

Silk Performer .NET Explorer テスト タイプは、.NET Explorer スクリプトやスクリプトの特定のテスト ケースを実行するために使用します。
  • Silk Performer .NET Explorer テストを作成または編集する
    .NET Explorer スクリプトやスクリプトの特定のテスト ケースを実行するために、Silk Performer .NET Explorer テストを作成または編集します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


Silk Performer .NET Explorer テストを作成または編集する

.NET Explorer テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから Silk Performer .NET Explorer テスト を選択します。次へ をクリックします。

    .NET Explorer テスト プロパティ ダイアログ ボックスが開きます。

  6. テストに適用する .NET Explorer スクリプトを参照し、選択します。 このスクリプトは .nef ファイルです。
  7. 実行サーバー上の NetExplorer.exe 実行可能ファイルへのパスを入力します。 たとえば、C:\Program Files\MyCustomSPFolder\DotNET Explorer\NetExplorer.exe などです。実行サーバー上で環境変数を定義して、それを参照させることもできます（${SP_HOME}\NetExplorer.exe など）。
  8. テスト ケース フィールドには、実行する .NET Explorer テスト ケースの名前を入力します。このフィールドが空のままにされた場合、そのスクリプト内のすべてのテスト ケースが実行されます。複数のテスト ケースを指定することはできません。
    注: InitTestCase テスト ケースと EndTestCase テスト ケースについては常に実行されます。
  9. 完了 をクリックします。
親トピック: Silk Performer .NET Explorer テスト
関連タスク
テストを試験実行する


Silk Performer テスト

  • Silk Performer テストを作成または編集する
    Silk Central から Silk Performer プロジェクトを実行するために、Silk Performer テストを作成または編集します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合
関連概念
Silk Performer プロジェクトで作業する
関連タスク
Silk Performer テストを作成または編集する


Silk Performer テストを作成または編集する

Silk Performer テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから Silk Performer テスト を選択します。次へ をクリックします。

    Silk Performer テスト プロパティ - プロジェクトの選択 ダイアログ ボックスが開きます。

  6. 参照 をクリックし、ローカルのファイル システムに保存された Silk Performer プロジェクトを選択し、次へ をクリックします。
  7. ワークロード リストからプロジェクトに対して定義されているワークロード プロファイルを 1 つ選択します。
  8. 完了 をクリックして、テスト ケースを作成します。
親トピック: Silk Performer テスト
関連概念
Silk Performer プロジェクトで作業する
Silk Performer テスト
関連タスク
テストを試験実行する


Silk Test Classic テスト

Silk Central の Silk Test Classic インターフェイスは、ユーザーに Silk Test Classic を自動化する信頼性の高い手段を提供します。Silk Test Classic スクリプトの各テストケースは、それぞれのテスト実行の中で実行され、それぞれに結果を作成します。

Silk Test Classic 計画テスト タイプは、Silk Test Classic テスト計画に対して使用できます。テスト計画は、通常、階層化されたドキュメントで、テスト要件が記述されており、そのテスト要件を実装するステートメント、4Test スクリプト、テスト ケースを含んでいます。

アクティビティ ページで、実行中の Silk Test Classic の実行を確認すると、現在実行中の実行計画には 詳細ビュー を開くハイパーリンクがあります。このビューを使って、現在実行中の実行計画の状態を詳しく監視することができます。Silk Test Classic テストの実行では、このビューの中央には、次の 2 種類の情報が表示されます。上部には、テスト、スクリプト、テスト ケース、テスト データについての一般的な情報が表示されます。下部には、Silk Test Classic が生成する出力メッセージ（深刻度を含む）がすべて表示されます。

Silk Central のこれまでのバージョンでは、Silk Test Classic の呼び出しはコマンドライン インターフェイスとして実装されていました。新しいインターフェイスはプロセス間通信で動作します。Silk Central の Silk Test Classic インターフェイスを使うかどうかは、テスト コンテナの設定で指定することができます。

Silk Central GUI で Silk Test Classic テスト プロパティとして定義されていないすべての Silk Test Classic テスト パラメータについては、Silk Test Classic のデフォルト設定が使用されます（partner.ini の設定など）。

  • Silk Test Classic テストを作成または編集する
    Silk Central から Silk Test Classic テストを実行するために、Silk Test Classic テストを作成または編集します。
  • Silk Test Classic 計画テストを作成または編集する
    テスト計画の構造を Silk Central にインポートするために、Silk Test Classic 計画テストを作成または編集します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合
関連概念
Silk Test Classic のテスト
関連タスク
Silk Test Classic テストを作成または編集する


Silk Test Classic テストを作成または編集する

Silk Test Classic テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから Silk Test Classic テスト を選択します。複数の Silk Test Classic テスト ケースをまとめてインポートする場合は、Silk Test Classic マルチテストケースのインポート を選択します。次へ をクリックします。

    テスト プロパティ - テスト スクリプトの選択 ダイアログ ボックスが開きます。

  6. 参照 をクリックし、定義した Silk Test Classic プロジェクト、またはソース管理ディレクトリのどちらかからテスト スクリプト ファイルを選択します。 ファイル拡張子 .t または .g.t を持つテスト スクリプトは、ソース管理プロファイルでテスト コンテナのルート ノードから相対的に定義します。たとえば、/<Silk Test Classic プロジェクト>/MyScript.t など。
  7. 次へ をクリックします。

    テスト プロパティ - テスト ケースの選択 ダイアログ ボックスが開きます。

    注: Silk Test Classic スクリプトがデータ駆動型 .g.t ファイルだった場合（例、SilkTestScript1.g.t）、データ ソースはこのスクリプト ファイルで完全に制御され、Silk Central のデータ駆動型プロパティは使用されません。データ駆動型スクリプト ファイルを使用する場合は、データ駆動型 チェック ボックスがデフォルトでオンになっています。データ駆動型 Silk Test Classic テストについてのさらなる情報については、Silk Test Classic ドキュメントを参照してください。
  8. テスト ケースを、定義したスクリプト ファイル内の利用可能なテスト ケースから選択するか、カスタム テスト ケースを指定します。カスタム テストケースのフィールドに既に値が入っている場合には、Silk Test Classic テストは自動的に生成されています (Silk Test Classic のエクスポート機能によって)。カスタム フィールドを使用してテスト ケースを指定する場合は、テストケース名の最後に括弧「()」を付けることができます。括弧の中には、テスト データ (パラメータを含む) を指定することができます。カスタム フィールドにデータを指定すると、テスト データ プロパティの値が上書きされます。
  9. 省略可能：テスト データ フィールドに追加の実行引数を入力します。 これらの引数は、テストの実行中に Silk Test Classic によって処理されます。Silk Test Classic に複数の引数を渡すときには、カンマ（,）で区切ります。String 引数を Silk Test Classic に渡す場合は、引数を二重引用符（"）で囲む必要があります。テスト データが複雑な場合には、テスト データ中で ${ParameterName} などのパラメータを使うことをお勧めします。パラメータは、テスト実行中に自動的に置き換えられます。
    注: このフィールドの最大長は 2000 文字です。
  10. テストで TrueLog を出力するかどうかを定義します。
    ヒント: Open Agent を使用してテストを実行しているとき、Silk Central と Silk Test の両方で、この設定をオンにする必要があります。そうでなければ、TrueLog 出力されません。データ駆動型テストの実行モードのデフォルトは計画ベースです。データ駆動型テストでスクリプト ベースの実行モードを使う場合には、SccExecServerBootConf.xml の Silk Test Classic 要素で DataDrivenScriptMode の設定を変更してください。さらなる情報については、Silk Test Classic ドキュメントを参照してください。
  11. 必要であれば、オプション セット ファイルを指定します。デフォルトでは、Silk Central は開いている Silk Test Classic オプション セット ファイルをすべて閉じます。オプション セット ファイルを指定するには、 ソース管理プロファイル内で、テスト コンテナのルート ノードに対する相対パスで、そのファイル名を指定します。
  12. 完了 をクリックして、Silk Test Classic テスト定義を作成します。
    注: 完了するまでの所要時間が 1 時間を超える Silk Test Classic テスト ケースがある場合は、Silk Central のタイムアウト設定を調整する必要があります。そうしないと、Silk Central は、実行時に問題が発生したと見なして実行を終了します。タイムアウト設定の詳細については、この『ヘルプ』の「管理」トピックを参照してください。
親トピック: Silk Test Classic テスト
関連概念
Silk Test Classic テスト
Silk Test Classic のテスト
テスト パラメータ
関連タスク
テストを試験実行する


Silk Test Classic 計画テストを作成または編集する

Silk Test Classic 計画テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから Silk Test Classic 計画 を選択します。次へ をクリックします。

    計画プロパティ ダイアログ ボックスが開きます。

  6. 計画ファイル フィールドに、実行されるテスト計画ファイル (.pln) の完全修飾名を入力します。
    参照 をクリックして、ファイルを参照します。
  7. プロジェクト ファイル フィールドに、ファイルと環境設定が含まれている Silk Test Classic プロジェクトの名前を入力します。 参照 をクリックして、プロジェクト ファイルを参照します。
  8. オプション セット フィールドに、環境設定が含まれているオプション セット ファイルの完全修飾名を入力します。
    参照 をクリックして、オプション セット ファイルを参照します。
  9. 属性とクエリのためのデータ ファイル フィールドに、テスト計画初期化ファイルのデフォルト パスを入力します。
    参照 をクリックして、テスト計画初期化ファイルを参照します。
  10. テスト計画クエリ名 フィールドに、保存されたテスト計画クエリの完全修飾名を入力します。
  11. 完了 をクリックします。

Silk Test Classic 計画テストの構造を Silk Central で維持するには、試験実行を実行します。試験実行が正しく完了すると、実行計画の実行の結果ファイルに output.xml ファイルが追加されます。これにより、テストをテスト パッケージに変換でき、テストの構造を完全に管理できます。

親トピック: Silk Test Classic テスト
関連タスク
テスト パッケージを作成する
テストを試験実行する


Silk Test Workbench テスト

Silk Test Workbench は、複雑なアプリケーションの機能テストを推進するための自動テスト ツールです。Silk Test Workbench は、Java、.NET、ブラウザベースの Web アプリケーション、COM コンポーネント（ActiveX コントロールと自動オブジェクトの両方を含む）などのさまざまな開発ツールを使って開発されたアプリケーションのテストをサポートします。
  • Silk Central から STW.EXE を実行するための前提条件
    Silk Central 実行サーバーから STW.EXE を実行するために必要な前提条件を示します。
  • Silk Test Workbench テストを作成または編集する
    Silk Central から Silk Test Workbench テストを実行するために、Silk Test Workbench テストを作成または編集します。
  • 結果ファイルのコンテキストで Silk Test Workbench を開く
    結果ファイルのコンテキストで Silk Test Workbench を開く方法について説明します。
  • ビジュアル テストの実行結果ファイルを表示する
    Silk Test Workbench を開いて、再生エラーが発生した場合にビジュアル テストの最後のスクリーンショットを表示する方法について説明します。
  • [テスト] の [パラメータ] ページ - Silk Test Workbench
    Silk Test Workbench のパラメータのデータ型マッピングについて説明します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


Silk Central から STW.EXE を実行するための前提条件

Silk Central 実行サーバーから STW.EXE を実行し、Silk Test Workbench データベースに正しく接続するには、次の前提条件を満たす必要があります。
  1. Silk Central 実行サーバーがサービスではなく、プロセスとして実行されている。
  2. Silk Test Workbench データベースへの接続にデータベース認証が使用されている。Silk Test Workbench では、Silk Test Workbench SQL Server データベースとの接続に Windows 認証とデータベース認証を使用できます。
  3. データベース サーバー インスタンスが静的ポートを使用するように構成されている。
これらの前提条件が満たされていない場合、Silk Test Workbench 実行サーバーから STW.EXE を実行しようとするときに Silk Central は次のエラーで終了する場合があります。
エラー 3：DSN、ユーザー名、パスワードのいずれかが正しくありません。
親トピック: Silk Test Workbench テスト


Silk Test Workbench テストを作成または編集する

Silk Test Workbench テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから Silk Test Workbench テスト を選択します。次へ をクリックします。

    Silk Test Workbench テスト プロパティ - テストの選択 ダイアログ ボックスが開きます。

  6. Silk Test Workbench テスト リスト ボックスから 1 つ以上のスクリプトを選択します。
  7. 定義済みの Silk Test Workbench 再生オプションの名前を 再生オプション フィールドに入力するか、デフォルト値であるシステム デフォルトのままにします。
    注: Silk Test Workbench テストに対して再生オプションを設定する必要があります。Silk Test Workbench テストで削除オプションを使用すると、再生オプションが、デフォルト値のシステム デフォルトにリセットされます。
  8. 完了 をクリックします。
親トピック: Silk Test Workbench テスト
関連タスク
テストを試験実行する


結果ファイルのコンテキストで Silk Test Workbench を開く

  1. メニューで 実行計画 をクリックします。
  2. 実行計画を選択します。
  3. 実行 タブをクリックします。
  4. 下部の テストの実行 グリッドで、詳細を表示するテストの 実行 ID をクリックします。 テストの実行結果 ダイアログ ボックスが開きます。
  5. ファイル タブをクリックします。
  6. 結果ファイルのコンテキストで Silk Test Workbench を開くには、result.stwx ファイルをクリックします。
    注: Silk Test Workbench は、ファイルを開こうとしているマシンにインストールされている必要があります。
親トピック: Silk Test Workbench テスト


ビジュアル テストの実行結果ファイルを表示する

  1. メニューで 実行計画 をクリックします。
  2. 実行計画を選択します。
  3. 実行 タブをクリックします。
  4. 最近の実行 領域で、該当する実行計画の 実行 ID をクリックし、テスト実行結果を表示します。
  5. アクション 列に Silk Test Workbench のすべてのアイコンとリンクが表示されます。
    • detail.htm - Silk Test Workbench の詳細ステップファイル。
    • result.stwx - クリックすると、Silk Test Workbench で結果が開きます。
    • error.png - クリックすると、最後のエラーのスクリーンショットに移動します。
親トピック: Silk Test Workbench テスト


[テスト] の [パラメータ] ページ - Silk Test Workbench

テスト > 詳細ビュー > <テスト要素> > データ セット

Silk Central テストから Silk Test Workbench テストにパラメータを渡す場合、これらのパラメータは Silk Test Workbench スクリプトの入力パラメータとして定義されており、その名前は、Silk Central での名前と同じである必要があります。次のデータ型を使用できます。

Silk Central | Silk Test Workbench
文字列 | テキスト
数値 | 数値（Long）
数値 | 数値（Long Long）
数値 | 列挙型
浮動小数点数 | 数値（Double）
論理値 | 論理値（True/False）
親トピック: Silk Test Workbench テスト
親トピック: テスト パラメータ


Silk TestPartner テスト

TestPartner は、Microsoft 技術を使用する Web ベースおよび Microsoft Windows ベースのアプリケーションをテストする Micro Focus の製品です。
  • Silk TestPartner テストを作成または編集する
    新しい TestPartner テストを作成するために、TestPartner テスト プロパティを設定する方法について説明します。
  • 複数の TestPartner テストを追加する
    新しい TestPartner テストを作成する場合は、複数の TestPartner テストを追加できます。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


Silk TestPartner テストを作成または編集する

TestPartner テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから Silk TestPartner テスト を選択します。次へ をクリックします。

    テスト プロパティ - テスト スクリプトの選択 ダイアログ ボックスが開きます。

  6. 参照 をクリックします。

    ファイルの選択 ダイアログ ボックスが開きます。このダイアログ ボックスで使用できる資産は、関連する TestPartner ソース管理プロファイルで定義された プロジェクト パス に基づいています。

  7. リストからスクリプトを選択して、OK をクリックします。
    注: 複数の TestPartner テストを追加するには、「複数の TestPartner テストを追加する」を参照してください。
  8. 定義済みの TestPartner 再生オプションの名前を 再生オプション フィールドに入力するか、デフォルト値であるシステム デフォルトのままにします。
  9. 完了 をクリックします。
親トピック: Silk TestPartner テスト
関連タスク
テストを試験実行する
複数の TestPartner テストを追加する


複数の TestPartner テストを追加する

複数の TestPartner テストを追加するには、まず、「Silk TestPartner テストを作成する」で説明されている手順を実行する必要があります。

複数の TestPartner テストを追加するには：

  1. テストの新規作成 ダイアログ ボックスで、TestPartner テスト を タイプ リスト ボックスから選択します。
  2. 次へ をクリックします。 テスト プロパティ - テスト スクリプトの選択 ダイアログ ボックスが開きます。
  3. 参照 をクリックします。

    ファイルの選択 ダイアログ ボックスが開きます。このダイアログ ボックスで使用できる資産は、関連する TestPartner ソース管理プロファイルで定義された プロジェクト パス に基づいています。

  4. 定義済みの TestPartner 再生オプションの名前を 再生オプション フィールドに入力するか、デフォルト値であるシステム デフォルトのままにします。
    注: インポートでは、インポートされたすべてのスクリプトに対して、定義済みの再生オプションが与えられます。スクリプトの再生オプションを変更する必要がある場合は、インポートの後、テストを編集します。
  5. 次へ をクリックします。

    テスト プロパティ - スクリプトの選択 ダイアログ ボックスが開きます。

  6. TestPartner スクリプト フィールドで Ctrl + クリックをクリックして、インポートするスクリプトを選択します。
  7. 完了 をクリックします。
親トピック: Silk TestPartner テスト
関連タスク
Silk TestPartner テストを作成または編集する


Windows Script Host テスト

Windows Script Host（WSH）は、Windows プラットフォームに含まれるもので、ホストとしてスクリプトを動かすための環境を作成します。実行サーバーでスクリプトを動かす場合、WSH がホストの役割を果たします。WSH は、スクリプトがオブジェクトやサービスを利用できるようにし、スクリプト実行のためのガイドラインも提供します。何よりも、WSH はセキュリティを管理し、適切なスクリプト エンジンを呼び出します。

  • Windows Script Host (WSH) テストを作成または編集する
    Windows Script Host (WSH) に準拠したテスト スクリプトを実行するために、Windows Script Host テストを作成または編集します。
  • サポートされているスクリプト言語
    WSH によってサポートされるスクリプト言語を一覧表示します。
  • WSH テスト プロパティ
    設定可能な WSH のプロパティについて説明します。
  • WSH テストでのパラメータの使用
    WSH テストでパラメータを使用する方法について説明します。
  • WSH から返される情報の表示
    テストで WSH から返される情報を表示する方法について説明します。
親トピック: テスト タイプ
親トピック: テスト自動化ツールとの統合


Windows Script Host (WSH) テストを作成または編集する

WSH テストを作成または編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 新しいテストを作成する場合は、タイプ リスト ボックスから Windows Script Host テスト を選択します。次へ をクリックします。

    Windows Script Host テスト プロパティ ダイアログ ボックスが開きます。

  6. 参照 をクリックして、Windows Script Host テスト スクリプトを選択します。
  7. スイッチ フィールドで、必要な追加パラメータの場所を指定します。
    注: このスクリプトに渡すその他のスイッチを追加することもできます。使用可能なスイッチの詳細については、「WSH テスト プロパティ」、および MS Scripting Host のドキュメントを参照してください。
  8. 完了 をクリックします。
親トピック: Windows Script Host テスト
関連タスク
テストを試験実行する


サポートされているスクリプト言語

WSH は、WSH 準拠のスクリプト エンジンについては、言語を気にせずに使うことができます。 Windows プラットフォームは、ネイティブで、Visual Basic Scripts (ファイル拡張子 .vbs) と Java Script 言語で書かれたスクリプト (ファイル拡張子 .js.js) をサポートしています。

それ以外のスクリプト言語については、実行サーバー上に専用のスクリプト インタプリタをインストールする必要があります。 たとえば、実行サーバーに Perl インタプリタをインストールすると、WSH 環境で .pls という拡張子用に Perl スクリプト エンジンが登録されます。 WSH ツール (実行可能ファイル cscript.execscript.exe) に拡張子が .pls のファイルを渡すと、ファイル拡張子に基づいて適切なインタプリタが呼び出されます。 そのため、WSH のクライアント (この場合は Silk Central 実行サーバー) は、Perl インタプリタのインストールについて意識する必要がありません。

注: スクリプト インタプリタ (Active Perl など) をインストールした後、Silk Central でスクリプトを実行する前に、WSH コマンドライン ツールでサンプル スクリプトを呼び出して、実行サーバーのローカルでスクリプトを実行してみてください。 そのためには、まず実行サーバーでコマンド シェルを開き、cscript <somescript> と入力します。ここで、<somescript> は実行サーバー上で利用可能な、選択したスクリプトへのパスです。 これは、実行サーバー上で WSH テストを実行したときに、まさに Silk Central が呼び出すものです。 スクリプトが動いたら、スクリプト エンジンは正しく登録されています。
以下のスクリプト言語は、WSH との互換性があります。
スクリプト言語
ファイル拡張子
Perl
.pls
Python
.py、.pyw
REXX
.REXX
TCL
.tcl
親トピック: Windows Script Host テスト


WSH テスト プロパティ

プロパティ | 説明
スクリプト | ファイルで使用しているスクリプト言語のスクリプト エンジンが登録されている任意のファイルを定義することができます。 ソース管理下にあるスクリプト ファイルは、自動的に実行サーバーに配置されます (他の種類のテストのテスト ソースに相当します)。
スイッチ テストの実行中に、以下の設定を入力して cscript.exe に渡すことができます。
//B
バッチ モードは、スクリプトからのコマンドライン以外のコンソール UI リクエストをすべて抑制します。 実行サーバーが無人で動いている場合には、スクリプトがユーザー入力を待つことがないよう、このオプションを指定することをお勧めします。
//U
コンソールからリダイレクトされる I/O には Unicode を使用することをお勧めします。
//T:nn
タイムアウト（秒単位）。 スクリプトを実行することができる最大の時間（デフォルトは制限なし）。 このオプションは、スクリプトが必要以上に実行されることを防ぐために使用されます。 タイマがセットされます。 実行時間が指定された値を超えると、Cscript は IActiveScript::InterruptThread メソッドを使ってスクリプト エンジンを中断し、プロセスを終了します。 コールバック フックが存在します。 タイムアウトが呼び出されると、クリーンアップのための OnTimeOut 関数が呼び出されます。 この機能を使うと無限ループになる可能性はありますが、その害を考えても有益な場合が多いでしょう。
//logo
実行時に実行バナーを表示します。これは log.txt ログ ファイルの先頭に含められます。 デフォルトの設定です。
//nologo
実行時に実行バナーを表示しません。
//D
アクティブ デバッグを有効にします。
//E:engine
スクリプトを実行するのに指定したエンジンを使用します。
//Job:xxxx
WSF ジョブを実行します。
//X
スクリプトをデバッガで実行します。
親トピック: Windows Script Host テスト


WSH テストでのパラメータの使用

WSH テストにパラメータを定義すると、追加の引数として名前と値のペアがコマンドラインに自動的に追加され、そのパラメータは呼び出されたプロセスの環境変数として設定されます。 この機能によって、テストに定義したすべてのパラメータに WSH スクリプトからアクセスすることができます。

たとえば、WSH テストは、myscript.js をスクリプト、//B をスイッチとして定義されます。 また、テストには、IPAddress というパラメータに値 192.168.1.5 を、Port という別のパラメータに値 1492 を指定する必要があります。 この例では、WSH 実行のためのコマンド ラインは結果として次のようになります。

csript myscript.js //B IPAddress=192.168.1.5 Port=1492
親トピック: Windows Script Host テスト


WSH から返される情報の表示

WSH 実行結果を知りたい場合には、WSH スクリプトで WSH テストの現在の作業ディレクトリに output.xml というファイルを生成する必要があります。 このディレクトリに含まれるすべてのファイルはデータベースに格納されるので、テスト実行のファイル一覧からダウンロードできます。 プロジェクト 領域の [結果で無視するファイル拡張子] プロパティに拡張子が定義されている場合、ファイルは格納対象外になります。

注: 現在の作業ディレクトリは、WSH を実行するたびに動的に作成されます。 ファイルを作成するときに絶対パスは使わないでください。 相対パスを使うと、現在の作業ディレクトリを正しく指すようになります。

スクリプトが WSH 標準出力に書き出した情報はすべて、現在の作業ディレクトリにある log.txt というテキスト ファイルに入れられます。 このファイルはデータベースに格納され、テスト実行のファイル一覧に含められるので、そこから表示することができます。

以下の例は、スクリプトからのログ情報を出力する方法を示しています。

 WScript.Echo "This info will be written to the log.txt file"

output.xml の XML 構造は ResultElement という名前の要素から始まります。この要素には TestItem という名前の属性が定義されており、そこで ResultElement の名前を指定します。

ResultElement には、ErrorCount という要素（必須）、WarningCount という要素（省略可能）、および Incident 要素のリストが含まれています。

ErrorCount 要素および WarningCount 要素には、ゼロまたは正の数が含まれている必要があります。 最上位の ResultElement の ErrorCount と WarningCount を元に成功条件を評価し、その結果によってテストの合否が判定されます。 XML ファイルには Silk Central GUI に表示されない要素が含まれている可能性があります。 ただし、出力された output.xml ファイルはデータベースに格納されており、実行されたテストのファイル一覧に含まれているため、見ることが可能です。

Incident 要素は WSH テストの実行時に発生したイベントを表します。 Message と Severity は Silk Central GUI のテスト実行のメッセージ一覧に表示されます。 Incident 要素には Message と Severity の要素が 1 つずつ含まれます。

Severity 要素は以下の値のいずれかを持ちます。

  • Info
  • Warning
  • Error（または Exception）
  • Failure

結果ファイルには追加情報を格納できます。 ResultElement には、任意の数のサブ ResultElement を含めることができるので、情報を簡単にグループ化できます。 サブ ResultElement を作成すると、結果ファイルが読みやすくなります。 ユニット テスト（JUnit、NUnit）に関して互換性を保つため、ResultElement には TestSuite または Test という名前を付けることができます。

ResultElement には、以下の追加要素を含めることができます。

  • FailureCount（エラー カウントと同様の扱い）
  • RunCount（テストが複数回実行された場合）
  • Timer（テストにかかった時間のためなど）
  • WasSuccess（NUnit 結果ファイルとの互換性のため）
  • Asserts（NUnit 結果ファイルとの互換性のため）

Incident 要素には Detail 要素のリストが含まれることがあります。

Detail 要素は Incident に関する詳細情報を表します。 この要素では、TestName と Info の要素を定義する必要があります。 TestName は、どこで Incident が発生したかの詳細情報を示すのに使用します。 Info 要素は Incident についての詳細情報を持ちます（スタック トレースなど）。

注: Silk Central 8.1 までは、Message と Info 要素の値は URL エンコード (ISO-8859-1) されている必要がありました。 バージョン 8.1.1 以降では、URL エンコードは許可されていません。

結果ファイルのサンプル

<ResultElement TestItem="WshOutputTest">
  <ErrorCount>1</ErrorCount>
  <WarningCount>1</WarningCount>
  <Incident>
    <Message>some unexpected result</Message>
    <Severity>Error</Severity>
    <Detail>
      <TestName>function main()</TestName>
      <Info>some additional info; eg. stacktrace</Info>
    </Detail>
  </Incident>
  <Incident>
    <Message>some warning message</Message>
    <Severity>Warning</Severity>
    <Detail>
      <TestName>function main()</TestName>
      <Info>some additional info; eg. stacktrace</Info>
    </Detail>
  </Incident>
</ResultElement>

Java Script のサンプル

以下のスクリプトは、結果ファイルのサンプルを生成するために使用したものです。 このスクリプトを動かしてみるには、.js という拡張子を付けて保存してください。

function dumpOutput(dumpFile)
{
  dumpFile.WriteLine("<ResultElement TestItem=\"WshOutputTest\">");
  dumpFile.WriteLine("  <ErrorCount>1</ErrorCount>");
  dumpFile.WriteLine("  <WarningCount>1</WarningCount>");
    dumpFile.WriteLine("  <Incident>");
    dumpFile.WriteLine("    <Message>some unexpected result</Message>");
    dumpFile.WriteLine("    <Severity>Error</Severity>");
    dumpFile.WriteLine("    <Detail>");
    dumpFile.WriteLine("      <TestName>function main()</TestName>");
    dumpFile.WriteLine("      <Info>some additional info; eg. stacktrace</Info>");
    dumpFile.WriteLine("    </Detail>");
    dumpFile.WriteLine("  </Incident>");
    dumpFile.WriteLine("  <Incident>");
    dumpFile.WriteLine("    <Message>some warning message</Message>");
    dumpFile.WriteLine("    <Severity>Warning</Severity>");
    dumpFile.WriteLine("    <Detail>");
    dumpFile.WriteLine("      <TestName>function main()</TestName>");
    dumpFile.WriteLine("      <Info>some additional info; eg. stacktrace</Info>");
    dumpFile.WriteLine("    </Detail>");
    dumpFile.WriteLine("  </Incident>");
  dumpFile.WriteLine("</ResultElement>");
}

function main()
{
  var outFile;
  var fso;
  fso = WScript.CreateObject("Scripting.FileSystemObject");
  outFile = fso.CreateTextFile("output.xml", true, true);
  outFile.WriteLine("<?xml version=\"1.0\" encoding=\"UTF-16\"?>");

  dumpOutput(outFile);
  outFile.Close();
  WScript.Echo("Test is completed");
}

main();
WScript.Quit(0);

Visual Basic Script のサンプル

以下の Visual Basic スクリプトもサンプル結果ファイルを生成し、Output.xml として保存します。 このスクリプトを動かしてみるには、.vbs という拡張子を付けて保存してください。

WScript.Echo "starting"

Dim outFile
Dim errCnt
Dim warningCnt

outFile = "output.xml"
errCnt = 1 ' retrieve that from your test results
warningCnt = 1 ' retrieve that from your test results

Set FSO = CreateObject("Scripting.FileSystemObject")
Set oTX = FSO.OpenTextFile(outFile, 2, True, -1) ' args: file, 8=append/2=overwrite, create, ASCII

oTX.WriteLine("<?xml version=""1.0"" encoding=""UTF-16""?>")
oTX.WriteLine("<ResultElement TestItem=""PerlTest"">")
oTX.WriteLine("  <ErrorCount>" & errCnt & "</ErrorCount>")
oTX.WriteLine("  <WarningCount>" & warningCnt & "</WarningCount>")
oTX.WriteLine("  <Incident>")
oTX.WriteLine("    <Message>some unexpected result</Message>")
oTX.WriteLine("    <Severity>Error</Severity>")
oTX.WriteLine("    <Detail>")
oTX.WriteLine("      <TestName>function main()</TestName>")
oTX.WriteLine("      <Info>some additional info; eg. stacktrace</Info>")
oTX.WriteLine("    </Detail>")
oTX.WriteLine("  </Incident>")
oTX.WriteLine("  <Incident>")
oTX.WriteLine("    <Message>some warning message</Message>")
oTX.WriteLine("    <Severity>Warning</Severity>")
oTX.WriteLine("    <Detail>")
oTX.WriteLine("      <TestName>function main()</TestName>")
oTX.WriteLine("      <Info>some additional info; eg. stacktrace</Info>")
oTX.WriteLine("    </Detail>")
oTX.WriteLine("  </Incident>")
oTX.WriteLine("</ResultElement>")
親トピック: Windows Script Host テスト


共有テスト資産

リポジトリ プロジェクトで管理されている共通のテスト資産やその割り当て済み要件を、他のプロジェクトから再利用することができます。

プロジェクトが特定のリポジトリ プロジェクトから資産を使用するように設定されている場合（「プロジェクトを追加する」を参照）、資産をプロジェクトに貼り付けることによって再利用できます。

  • リポジトリ プロジェクトのテスト資産の再利用
    共通テスト資産をリポジトリ プロジェクトでメンテナンスし、参照するプロジェクトから再利用できます。
  • 共有テストのバージョンをメンテナンスする
    リポジトリ プロジェクトの最新のバージョンのテストでテストを更新したり、テストの更新をリポジトリ プロジェクトにプッシュすることができます。
親トピック: テストを管理する


リポジトリ プロジェクトのテスト資産の再利用

共通テスト資産をリポジトリ プロジェクトでメンテナンスし、参照するプロジェクトから再利用できます。
プロジェクトが特定のリポジトリ プロジェクトから資産を使用するように設定されている場合（「プロジェクトを追加する」を参照）、資産をプロジェクトに貼り付けることによって再利用できます。
リポジトリ プロジェクトのテスト資産を再利用するには：
  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. リポジトリ プロジェクトを選択します。
  3. メニューで テスト > 詳細ビュー をクリックします。
  4. コピー をクリックして、要素をクリップボードにコピーします。
  5. メニューで プロジェクト > プロジェクト リスト をクリックします。
  6. 貼り付け先のプロジェクトを選択します。
  7. 貼り付け先のコンテナおよびフォルダを選択します。
  8. 貼り付け をクリックします。
    再利用テストのテスト プロパティの 共有テストの参照 には、元のテストへのリンクが表示されます。
注: 参照しているプロジェクトからリポジトリ プロジェクトへテストをコピーした場合にも、リポジトリ プロジェクトのテストへのリンクが作成され、そのテストは、他の参照しているプロジェクトで再利用することができます。テストを何回もコピーすると、参照リンクは最後にコピーしたテストになります。
リポジトリ プロジェクトのテスト資産の再利用時には、次のことに注意してください。
  • 貼り付け先のプロジェクトは、リポジトリ プロジェクトの資産を再利用するように設定されている必要があります。設定されていない場合は、コピーして貼り付けても、元の資産への参照は表示されません。
  • 既存のテスト コンテナにのみ資産を貼り付けることができます。
  • 割り当て済み要件を保持するには、貼り付け先のプロジェクトでリポジトリ プロジェクトと同じ要件システムが設定されている必要があります。
  • データ駆動型テストやテスト パッケージの子、またリンクしたテスト コンテナを再利用することはできません。
  • テスト プロパティ、パラメータ、属性の継承は、再利用テストでは考慮されません。継承が使用されている場合、元の資産での変更を適用すると、プロパティ、パラメータ、属性は再利用テストで削除されることになります。
  • 割り当て済み問題は、再利用テストにコピーされません。
  • テスト属性を使用する場合は、両方のプロジェクトで同じ名前とタイプが定義されている必要があります。
  • プロジェクトのコピーまたはベースライン化する場合は、リポジトリ プロジェクトへの参照は保持されます。プロジェクトをエクスポートすると、参照は削除されます。
  • 現時点では、一括エクスポート/更新インターフェイスと Web サービスでは、元の資産へのリンクは考慮されません。
  • フォルダをコピーして張り付けると、その階層もコピーされます。
親トピック: 共有テスト資産
親トピック: テスト ツリーで作業する
関連タスク
プロジェクトを追加する
プロジェクトとプロジェクト ベースラインを編集する


共有テストのバージョンをメンテナンスする

共通のテストをセントラル リポジトリ プロジェクトでメンテナンスし、他のプロジェクトから参照すると、複数のプロジェクトでテスト資産をメンテナンスする時間を節約できます。テストの新しいバージョンがリポジトリ プロジェクトに作成されると、対応するテストに 更新 フラグ（青い上矢印）が表示されます。参照しているプロジェクトでこのようなテストを右クリックして、共有テストの変更 > 変更の適用 を選択すると、最新のバージョンにテストを更新できます。 また、変更のスキップ を選択すると、更新フラグが消え、現在のバージョンが保持されます。その後、リポジトリ プロジェクトで新しいバージョンが作成された場合は、そのテストに再度フラグが表示されます。

参照しているプロジェクトで再利用テストを更新し、その変更をリポジトリ プロジェクトの元のテスト資産にプッシュしたい場合があります。このような場合には、参照しているプロジェクトのテストの 履歴 タブにある 共有テストに変更をプッシュ をクリックします。これにより、参照しているプロジェクトのテストに新しいバージョンが作成され、さらに、リポジトリ プロジェクトの共有テストには、復元ポイントと最新の変更を適用した新しいバージョンが作成されます。このテストを参照しているほかのプロジェクトには、更新通知が送られます。

親トピック: 共有テスト資産
関連概念
バージョン
関連タスク
バージョンを作成する
バージョンの表示
以前のバージョンの復元


テストを編集する

テストを編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 編集対象のテストまたはテスト パッケージを選択します。
  3. ツールバーの [image] (編集) をクリックします。

    または、プロパティ タブをクリックして、編集 をクリックするか、テストまたはテスト パッケージを右クリックして、編集 を選択します。

    テストの編集 ダイアログ ボックスが表示されます。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  4. 選択したテストの名前と説明を編集します。 選択したテストがテスト パッケージの場合、パッケージ構造を結果で更新 チェック ボックスが有効になります。テスト パッケージの構造を、テスト実行の実行結果に基づいて更新する場合は、パッケージ構造を結果で更新 チェック ボックスをオンにします。
  5. 「テストのプロパティを設定する」で説明されているテストタイプに応じて、テストまたはテスト パッケージのプロパティを構成します。
親トピック: テストを管理する
関連概念
テスト プロパティを設定する
テスト パッケージ


テストの印刷

テストを印刷するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. Ctrl + クリック または Shift + クリック を使用して、印刷するテストを選択します。
  3. 選択したテストを右クリックして、テストの詳細の印刷 を選択します。 テストの詳細 ダイアログ ボックスが表示されます。
  4. 印刷 または PDF としてダウンロード をクリックします。
ヒント: テスト ツリーでテストまたはフォルダを選択して、テストの詳細の印刷 を選択することもできます。
親トピック: テストを管理する


[テスト] の [実行] ページ

テスト > 詳細ビュー > <テスト> > 実行

実行 ページは、詳細ビュー のテスト ノードから利用可能となり、選択したテストのテスト実行結果が一覧表示されます。

実行 ページのデータのグリッド表現を使用すると、多数のテストのフィルタリング、ソート、およびグループ化を簡単に行うことができます。

実行ごとに、次の列がページに表示されます。

列 | 説明
アクション テストの実行に対して行うことができるアクション。
問題の新規作成
クリックすると 問題の新規作成 ダイアログ ボックスが開き、そのテストに対して新しい問題を作成できます。
既存の問題の割り当て
外部に構成されている問題追跡システムから問題をテストに割り当てます。
ステータス | 実行のステータス。実行中の実行計画の一部であるテストについては、テスト実行の現在のステータスに応じて、ステータスが更新されます。現在の実行が中止された場合には、ステータスは実行の前のステータスにリセットされます。
ステータスの理由 | 特定のテスト実行がステータス 合格、失敗、あるいは 未実行 を持つ理由。
実行 ID | テストの実行の ID。クリックすると、テスト実行の結果 ダイアログ ボックスが開きます。テストが実行中の場合には、クリックすると実行の詳細が表示されます。
実行タイプ | 実行タイプ 列には、各実行中のテストのタイプが表示されます。テストのタイプは、たとえばテストを手動から自動へ変換したときなど、2 つの実行の間で変わる場合があります。
開始日時 | 実行を開始した時間。テストが手動テストで現在実行されている場合には、Silk Central は、日時の後ろに (実行中) の文字を追加します。
実行時間 | テスト実行を行った実行時間 (h/mm/ss)。
実行計画 | 割り当てられている実行計画の名前。または、試験実行の場合や結果がアップロードされた場合は 未割り当てテスト と表示されます。クリックすると、実行計画が開きます。
実行者 | テストが実行された実行サーバー。
見つかった問題 | テストの実行に割り当てられている問題の数を表示します。テストの実行に割り当てられている問題がない場合、この列は空で表示されます。リンクをクリックすると、テスト > 詳細ビュー の 問題 ページにある問題にアクセスできます。
エラー数 | 実行中に発生したエラーの数。
警告数 | 実行中に発生した警告の数。
バージョン | テストの実行対象となったバージョン。
ビルド | テストの実行対象となったビルド番号。
実行計画の親 | 実行計画が実行されるコンテキスト内にある構成スイート、フォルダ、またはテスト サイクル。 クリックすると、実行計画 ツリー内のスイートまたはフォルダにアクセスできます。 構成スイートまたはフォルダに実行計画が含まれていない場合は、何も表示されません。
実行コメント | Silk Performer のテスト実行では、結果が読み込まれる際に、Silk Performer によってこの列が使用され、テスト実行に情報が追加されます。その他のすべてのテスト タイプでは、この列を使用して実行に情報を追加できます。

2 つ以上のテストの実行を比較するには、Ctrl または Shift を使用して、複数の実行を選択します。選択範囲を右クリックし、自動テスト結果の比較 または レポート > テスト実行の比較 をクリックします。

親トピック: テストを管理する
関連概念
テストの実行の比較レポート
関連タスク
複数のテスト実行のテスト結果の比較
既存の問題を割り当てる
関連資料
テスト実行の結果


[テスト] の [問題] ページ

テスト > 詳細ビュー > <テスト要素> > 問題

問題 ページでは、選択したテスト、コンテナ、またはフォルダに関係する問題の入力や追跡を行うことができます。

問題の新規作成
クリックして、選択されたテストに新しい問題を割り当てます。このボタンは、現在選択されているオブジェクトがテストである場合にのみ、表示されます。
既存の問題の割り当て
クリックして、問題を外部の問題追跡システムから選択したテストへ割り当てます。このボタンは、現在選択されているオブジェクトがテストである場合にのみ、表示されます。
問題の状態の更新
クリックして、問題の状態を更新します。

問題ごとに、次の列がページに表示されます。

列 | 説明
アクション | この問題に対して実行できるアクション。 をクリックして、問題を削除します。外部の問題は削除されません。
問題 ID | この問題に自動的に割り当てられた ID。クリックして、問題を編集します。
割り当て済みテスト | この問題に割り当てられているテスト。この列は、現在選択されているオブジェクトがコンテナもしくはフォルダである場合にのみ、表示されます。
概要 | この問題の概要。
ステータス | この問題のステータス。
外部 ID | この問題が外部の問題追跡システムで追跡されているかどうかを示します。外部問題番号をクリックして、外部の問題追跡システムに直接リンクすることもできます。
優先度 | 外部の問題追跡システムで定義されている問題の優先度。次の問題追跡システムはこの機能をサポートしています：Atlassian JIRA、Bugzilla、Silk Central Issue Manager、および StarTeam。
テスト実行 | 問題が割り当てられるテストの実行の ID です。ID をクリックすると、実行 領域にある テスト実行の結果 ダイアログ ボックスの 詳細 ページへアクセスできます。
作成日時 | この問題が作成された日時。
作成者 | この問題を作成したユーザー。
プロファイル | 問題追跡プロファイルの名前。Silk Central > 設定 > 問題追跡 で定義されます。
親トピック: テストを管理する
関連概念
問題
Issue Manager


バージョン

バージョンは、共有オブジェクト（ステップとキーワード）と、テストに対して作成できます。バージョンとは、ある状態における要素のリビジョンです。データ セットと継承したテスト プロパティ、パラメータ、属性は、テストのバージョンに含まれません。

共有オブジェクトやテストのバージョンを手動で作成するか、以前のバージョンに戻すことができます。共有オブジェクトおよびテストのすべてのバージョン一覧は、要素の 履歴 ページに表示されます。プロジェクトをコピーすると、バージョンもコピーされます。共有テストで作業する場合には、「共有テストのバージョンをメンテナンスする」を参照してください。

  • バージョンを作成する
    将来の変更を元に戻せるよう、共有オブジェクトまたはテストのバージョンを作成します。
  • バージョンの表示
    バージョンの詳細を表示して、バージョンがテストの要求を満たしているかどうかを確認できます。
  • バージョンを比較する
    2 つのバージョンの共有オブジェクトまたはテストの違いを表示するには、バージョンの比較を実行します。
  • 以前のバージョンの復元
    共有オブジェクトまたはテストの変更を元に戻すには、以前のバージョンを復元します。
  • 最近の変更点を表示する
    テストに対する最近の変更点を表示します。
  • テストの履歴を追跡する
    テストの履歴を追跡する方法について説明します。
  • [テスト] の [履歴] ページ
    選択されたテスト、テスト コンテナ、フォルダ、またはプロジェクトの改訂履歴が詳しく表示されます。
  • [ライブラリ] の [履歴] ページ
    選択した共有オブジェクトの履歴を表示します。
親トピック: テストを管理する
親トピック: ライブラリ
関連概念
共有テストのバージョンをメンテナンスする
関連タスク
バージョンを作成する
バージョンの表示
以前のバージョンの復元


バージョンを作成する

共有オブジェクトまたはテストの変更を元に戻せるようにするには、要素のバージョンを作成します。

共有オブジェクトまたはテストのバージョンを作成するには：

  1. 共有オブジェクトの場合は、メニューで テスト > ライブラリ をクリックします。テストの場合は、メニューの テスト > 詳細ビュー をクリックします。
  2. 共有オブジェクトを ライブラリ ツリーで選択するか、テストを テスト ツリーで選択します。
  3. ツールバーの バージョンの作成 をクリックします。 このアクションが有効になるのは、共有オブジェクトまたはテストが変更された場合だけです。 バージョンの作成 ダイアログ ボックスが表示されます。
  4. 省略可能：バージョンに関するコメントを コメント フィールドに入力します。
  5. OK をクリックします。新しいバージョンが 履歴 ページに表示されます。
親トピック: バージョン
関連概念
共有テストのバージョンをメンテナンスする
バージョン
関連タスク
バージョンの表示
以前のバージョンの復元


バージョンの表示

共有オブジェクトまたはテストの特定バージョンがテストの要求を満たしているかどうかを確認するために、バージョンの詳細を表示します。

共有オブジェクトまたはテストのバージョンの詳細を表示するには：

  1. 共有オブジェクトの場合は、メニューで テスト > ライブラリ をクリックします。テストの場合は、メニューの テスト > 詳細ビュー をクリックします。
  2. 共有オブジェクトを ライブラリ ツリーで選択するか、テストを テスト ツリーで選択します。
  3. 履歴 タブをクリックします。
  4. 詳細を表示するバージョンを右クリックします。
  5. バージョン <ID> の表示 をクリックします。
  6. バージョンの表示 ダイアログ ボックスが表示されます。バージョンに添付ファイルが含まれている場合、ステップ セクションの 添付ファイル 列で番号をクリックすると、添付ファイルを表示できます。
    注: 矢印を使用して、バージョン番号を変更し、追加のバージョンを表示します。
親トピック: バージョン
関連概念
共有テストのバージョンをメンテナンスする
バージョン
関連タスク
バージョンを作成する
以前のバージョンの復元


バージョンを比較する

2 つのバージョンの共有オブジェクトまたはテストの違いを表示するには、バージョンの比較を実行します。

2 つのバージョンの共有オブジェクトまたはテストを比較するには：

  1. 共有オブジェクトの場合は、メニューで テスト > ライブラリ をクリックします。テストの場合は、メニューの テスト > 詳細ビュー をクリックします。
  2. 共有オブジェクトを ライブラリ ツリーで選択するか、テストを テスト ツリーで選択します。
  3. 履歴 タブをクリックします。
  4. Ctrl + クリック を使用して、比較する 2 つのバージョンを選択します。
  5. 選択したバージョンを右クリックします。
  6. バージョン <x> と <y> の比較 を選択します。バージョンの比較 ダイアログ ボックスが表示され、追加、変更、および削除された内容がすべて表示されます。
    注: 矢印を使用して、バージョン番号を変更し、追加のバージョンを比較します。
親トピック: バージョン


以前のバージョンの復元

共有オブジェクトまたはテストの変更を元に戻すには、以前のバージョンを復元します。以前のバージョンに復元する際には、以下の特殊なケースにご注意ください。
  • 継承した属性の値が現在のバージョンと異なっている場合でも、復元したバージョンでは最新の値が継承されます。
  • 属性のタイプが現在のバージョンと異なっている場合は、復元したバージョンでは属性は無視されます。
  • リスト タイプの属性の値が現在のバージョンに存在しない場合は、元の値が属性に再び追加され、復元したバージョンで使用されます。

共有オブジェクトまたはテストを以前のバージョンに復元するには：

  1. 共有オブジェクトの場合は、メニューで テスト > ライブラリ をクリックします。テストの場合は、メニューの テスト > 詳細ビュー をクリックします。
  2. 共有オブジェクトを ライブラリ ツリーで選択するか、テストを テスト ツリーで選択します。
  3. 履歴 タブをクリックします。
  4. 復元する共有オブジェクトまたはテストのバージョンを右クリックします。
  5. バージョン <ID> の復元 をクリックします。
  6. 共有オブジェクトまたはテストは、選択したバージョンに復元され、新しいバージョンが 履歴 ページに作成されます。テストの場合、添付ファイル、およびデータ セットは復元されません。
親トピック: バージョン
関連概念
共有テストのバージョンをメンテナンスする
バージョン
関連タスク
バージョンを作成する
バージョンの表示


最近の変更点を表示する

テストに対する最近の変更点を表示するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 変更点のみ表示 をクリックして、最後に変更を承認してから変更されたものを除く、すべてのテスト要素をフィルタします。
    注: 最近の変更点フィルタが、フィルタ リスト ボックスで自動的に選択されます。
  3. 変更内容を確認したら、 承認 をクリックして、変更を承認できます。 [承認] 機能によって、"最近の変更点" フィルタはリセットされます。
  4. すべて表示 を再びクリックすると、フィルタが解除され、すべてのテストが表示されます。
注: テストが変更されると、テスト履歴にタイムスタンプ付きのエントリが生成されます。
親トピック: バージョン
関連概念
最近の変更点


テストの履歴を追跡する

Silk Central では、テストに加えられたすべての変更の完全な履歴が提供されます。履歴情報は読み取り専用で、編集したり完全に削除することはできません。

テスト要素の履歴を追跡するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーでテストを選択します。
  3. 履歴 タブをクリックします。
テストのプロパティが表形式で表示されます。
親トピック: バージョン


[テスト] の [履歴] ページ

テスト > 詳細ビュー > <テスト要素> > 履歴

履歴 ページには、選択したテスト、テスト コンテナ、フォルダ、あるいはプロジェクトの改訂履歴が詳しく表示されます。また、選択した要素を含むすべてのプロジェクト ベースラインのエントリも、ベースラインへのリンクおよびベースライン内の対応する要素と共に表示されます。選択した要素をプロジェクト ベースラインの一部として作成した場合には、履歴 ページの最初のエントリに、元のプロジェクトへのリンクおよび元のプロジェクト内の対応する要素が含まれます。このリンクを使用できるのは、アクティブ プロジェクトまたはベースラインにアクセスする場合のみです。プロジェクト ベースラインの詳細については、この『ヘルプ』の「管理」トピックを参照してください。

履歴 ページには、選択したテストの各バージョンのエントリも表示されます。このページでは、新規バージョンの作成、以前のバージョンの復元、および 2 つのバージョン間の変更点の表示ができます。

変更ごとに、次の列がページに表示されます。

列 | 説明
アクション | バージョン エントリの場合のみ。実行できるアクションは バージョンの表示、バージョン X に戻す、および バージョンの削除 です。
バージョン | バージョン エントリの場合のみ。テストのバージョン。
コメント | 変更についてのコメント。
作成日時 | 変更の日付と時刻。
作成者 | 変更を行ったユーザー。
注: ページに、一度に表示した場合に応答に影響が出るほど多くの要素がある場合、要素は順に表示されます。ページの下部にあるナビゲーション ツールバーを使用して、要素全体をブラウズすることができます。
親トピック: バージョン
関連概念
バージョン


テスト プロパティを設定する

属性、パラメータ、添付ファイル、成功条件などのテスト プロパティを設定します。
  • テスト プロパティ
    選択したテスト、テスト フォルダ、テスト パッケージ、またはテスト コンテナの全プロパティと関連情報が詳しく表示されます。
  • テスト属性
    属性とは、テストに適用できる自由に定義可能な特性です。テストのテスト領域を特定の属性でフィルタして、それらすべてのテストを実行計画に割り当てることができます。たとえば、製品コンポーネントに適用できる [プラットフォーム] 属性や、テストに適用できる [優先度] 属性などがあります。
  • テスト パラメータ
    パラメータとは、さまざまなテスト タイプに割り当ててさまざまな方法で使うことができる、自由に設定可能な入力値のことです。パラメータを使うことで、テスト データを定義し、それを使ってテストを設定することができます。
  • テストの添付情報
    添付情報 セクションには、選択されたテスト コンテナ、フォルダ、およびテストへの添付情報としてアップロードされているすべてのファイルやリンクが一覧表示されます。
  • データ駆動型テスト
    データ駆動型テストを操作する方法について説明します。
  • 成功条件
    テストが成功したかどうかを判別する方法について説明します。
親トピック: テスト
関連概念
テスト属性
テスト パラメータ
テストの添付情報
関連資料
テスト プロパティ


テスト プロパティ

テスト > 詳細ビュー > プロパティ

プロパティ ページには、選択したテスト、テスト フォルダ、テスト パッケージ、またはテスト コンテナの全プロパティと関連情報が詳しく表示されます。このページの各セクションは、必要に応じて展開したり、折りたたんだりすることがができます。これにより、個々のユーザーに必要な情報を表示するようにカスタマイズできます。テスト ノードの場合、以下のプロパティはテストの作成時に設定されます。

プロパティ | 説明
テスト名 | このテストの名前。
テスト ID | テストのデータベース識別子。
説明 テストの説明。
注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
ステータス
構成スイートに含まれているテストまたはテスト パッケージでは、ステータスは、そのスイート内のすべての構成の、すべてのステータスを集約したものとなります。
  • 構成スイートにのみ割り当てられているテストは、すべての構成で合格となった場合にのみ、ステータスが 合格 になります。すべての構成でステータスが 合格 でない場合、最も低い実行のステータスが反映されます。反映の優先度は次に示す順序 (上から下へ) となります。
    1. N/A
    2. 未実行
    3. 失敗
    4. 合格
    テストに割り当てられた要件のステータスは、そのテストが 1 つ以上の構成で失敗すると、失敗 になります。
  • 構成スイートと 1 つ以上の単純な実行計画にテストを割り当てることはお勧めしません。ただし、この場合は、1 つのステータスが構成ステータスの集約ステータスに、もう 1 つのステータスが実行計画の前回のステータスとなります。前回実行されたステータスがテストの前回のステータスとなります。
  • テストが単純な実行計画にのみ割り当てられている場合、ステータスは前回のテスト実行のステータスに応じて更新されます。
前回の実行 | このテストが最後に実行された日時。実行中の実行計画の一部であるテストについては、前回の実行は、現在のテスト実行をベースに更新されます。
割り当て済み実行計画 選択されたテストが割り当てられているすべての実行計画を一覧表示します。リスト内の実行計画ごとに、次の列がグリッドに表示されます。
列
説明
実行
実行計画の名前。クリックすると、実行計画を表示または編集できます。
ステータス
実行計画における、テストの前回の実行のステータス。実行計画の前回の実行でテストが実行されなかった場合、ステータスは未実行となります。データ駆動型のテストまたはテスト パッケージでは、すべての前回の実行のステータスが棒グラフで表示されます。
前回の実行
実行計画の一部としてテストが最後に実行された日時。
実行計画の親
実行計画が実行されるコンテキスト内にある構成スイート、フォルダ、またはテスト サイクル。 クリックすると、実行計画 ツリー内のスイートまたはフォルダにアクセスできます。 構成スイートまたはフォルダに実行計画が含まれていない場合は、何も表示されません。
作成日時 | テストが作成された日付と時刻。
作成者 | テストを作成したユーザーの名前。
変更日時 | テストが最後に変更された日付と時刻。
変更者 | テストを最後に変更したユーザーの名前。
予定時間 (hh:mm) | このテストの予定実行時刻。手動テストの場合のみです。
テスト プロパティ | テスト タイプに固有のテスト プロパティ。
成功条件 | テストに設定されているすべての成功条件。テスト パッケージ ノードでは、すべての成功条件（実行タイムアウトを除く）が無効になり非表示となっています。
デフォルト統合フォルダ | 外部の計画ツールからテストが作成される、デフォルトのコンテナまたはフォルダの名前を表示します。詳細については、「テスト ノードを外部アジャイル計画ツールのデフォルト統合フォルダとして設定する」を参照してください。
親トピック: テスト プロパティを設定する
関連概念
テスト プロパティを設定する
テスト属性
テスト パラメータ
テストの添付情報


テスト属性

属性とは、テストに適用できる自由に定義可能な特性です。テストのテスト領域を特定の属性でフィルタして、それらすべてのテストを実行計画に割り当てることができます。たとえば、製品コンポーネントに適用できる [プラットフォーム] 属性や、テストに適用できる [優先度] 属性などがあります。
注: 属性の継承は、プロパティや成功条件の継承と似ています。親ノードに割り当てられている属性は、すべてのサブフォルダや子テストにくまなく継承されます。
  • テストに属性を割り当てる
    テストに属性を割り当て、指定された属性によって特徴付けられるテスト カテゴリをフィルタ処理できるようにします。
  • テスト属性を編集する
    テスト属性を編集して、テストの特性を変更します。
  • テストから属性を削除する
    属性がテストの特徴を示さなくなった場合に、テストから属性を削除します。
親トピック: テスト プロパティを設定する
関連概念
属性
テスト プロパティを設定する
テスト パラメータ
テストの添付情報
関連資料
テスト プロパティ


テストに属性を割り当てる

テストに属性を割り当てるには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 属性を割り当てるテストを選択します。
  3. 属性 セクションで、属性の追加 をクリックします。属性の追加 ダイアログ ボックスが表示されます。
  4. 割り当てる属性の 追加 列で、 属性の追加 をクリックします。 選択した属性のタイプに応じて、属性の編集 ダイアログ ボックスが表示されます。ここでは、テストに割り当てる属性値を利用可能な属性値の中から指定できます。
  5. 属性値を選択して OK をクリックし、属性をテストに割り当てます。
親トピック: テスト属性


テスト属性を編集する

テスト属性を編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 編集対象の属性が割り当てられているテストを選択します。
  3. 属性 セクションで、編集する属性の 編集 アイコンをクリックします。 属性の編集 ダイアログ ボックスが表示されます。属性の編集 ダイアログ ボックスで利用可能なオプションは、選択した属性タイプによって異なります。
  4. 必要な値を選択し、OK をクリックして設定を保存します。
親トピック: テスト属性


テストから属性を削除する

テストから属性を削除するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 削除対象の属性が割り当てられているテストを選択します。
  3. 属性 セクションで、削除する属性の 削除 アイコンをクリックします。 属性の削除 確認ダイアログ ボックスが表示されます。
  4. はい をクリックして、属性を削除します。
    注: 親から継承した属性は削除できません。
親トピック: テスト属性


テスト パラメータ

パラメータとは、さまざまなテスト タイプに割り当ててさまざまな方法で使うことができる、自由に設定可能な入力値のことです。パラメータを使うことで、テスト データを定義し、それを使ってテストを設定することができます。

テストのプロパティ内に格納されているテスト パラメータ (たとえば、Silk Test Classic テストの test-data) が、最上部に一覧表示されます。使用されていないパラメータはリストの最後に付加され、薄いグレーで表示されます（無効状態に似ています）。

Silk Performer
これらのテストでは、選択した Silk Performer テストで定義されているプロジェクト属性を表す定義済みパラメータを使用することができます。
JUnit、Silk4J
JUnit および Silk4J のテストでは、任意の JUnit テスト クラスから、Java のシステム プロパティとして、元のテストのカスタム パラメータにアクセスすることができます。ランチャは、-D という VM 引数を使って、実行する仮想マシンにこのパラメータを渡します。テスト内では、パラメータの値に System.getProperty("myParam") を使用してアクセスできます。
NUnit、Silk4NET
NUnit および Silk4NET の各パラメータは、環境変数として設定されます。テスト内では、パラメータの値に Environment.GetEnvironmentVariable("myParam") を使用してアクセスできます。
Silk Test Classic
パラメータを Silk Test Classic に渡すには、Silk Central の Silk Test Classic テストの テスト プロパティ にある テスト データ フィールドで指定します。たとえば、Silk Central パラメータの値として Name と Password を Silk Test Classic に渡す場合は、テスト プロパティ の テスト データ フィールドで "${Name}", "${Password}" を指定します。Silk Test Classic スクリプトでは、指定した値を受信する 2 つのパラメータも必要です。
例：
[-] testcase ProcessParams(STRING name, STRING password)
   [ ] Print(name)
   [ ] Print(password)
外部プロセス
実行タスクが外部プロセス (WSH、Process Executor、NUnit、JUnit、MSTest、DotNetExplorer) で行われるテスト タイプでは、各パラメータがプロセスの環境変数として設定されます。これはパラメータ名がオペレーティング システム変数の名前と一致する場合にもあてはまるため、パラメータの値が空の文字列である場合の除き、システム変数の値はパラメータの値によって置き換えられます。
Silk Test Workbench
パラメータは Silk Test Workbench テストのものと同じ名前で定義し、Silk Central で実行する際に設定する必要があります。
構成テスト
テスト パラメータを実行計画で上書きできます。その他の情報については、「実行計画パラメータ」を参照してください。
カスタム テスト タイプ
カスタム テスト タイプの詳細については、『Silk Central API ヘルプ』を参照してください。
  • 事前定義パラメータ
    Silk Central は、 テスト実行中に、実行計画の実行プロパティに関する情報をパラメータとして提供します。
  • カスタム パラメータを作成する
    さまざまなテスト タイプの入力値を構成するために、カスタム パラメータを作成します。
  • Silk Performer テストに定義済みパラメータを追加する
    テストに定義済みパラメータを追加する方法について説明します。
  • 定義済みパラメータを編集する
    テストの記述が変更された場合に、定義済みパラメータの値を編集します。
  • 定義済みパラメータの割り当てを解除する
    パラメータによってテストが記述されなくなった場合に、定義済みパラメータの割り当てを解除します。
  • パラメータ値の中のパラメータ
    パラメータが含まれているパラメータ値の使用方法について説明します。
  • パラメータ表記
    サポートされるパラメータ表記について説明します。
  • 実行時のパラメータ トークンの置き換え
    実行時にパラメータとして入力された値によって、プレースホルダがどのように置き換えられるかについて説明します。
  • [テスト] の [パラメータ] ページ - Silk Test Workbench
    Silk Test Workbench のパラメータのデータ型マッピングについて説明します。
親トピック: テスト プロパティを設定する
関連概念
実行計画パラメータ
テスト プロパティを設定する
テスト属性
テストの添付情報
関連資料
事前定義パラメータ
Java システム プロパティを通じて Silk Central パラメータにアクセスする
テスト プロパティ


事前定義パラメータ

Silk Central は、 テスト実行中に、実行計画の実行プロパティに関する情報をパラメータとして提供します。
これらのパラメータは、テスト自動化ツールで、環境変数として読み込むことができます (「テスト パラメータ」を参照)。さらに、任意の JUnit テスト クラスから、Java のシステム プロパティとして、元のテストのテスト パラメータにアクセスすることができます（「Java システム プロパティを通じて Silk Central パラメータにアクセスする」を参照）。AttributeGet メソッドを使用して、これらのパラメータを Silk Performer スクリプトで読み取ることができます。

これらのパラメータの値は、プレースホルダで参照することもできます（「実行時のパラメータ トークンの置き換え」を参照）。

次の事前定義パラメータにアクセスできます。

パラメータ
説明
#sctm_execdef_name
現在実行されている実行計画の名前。実行が テスト 領域からトリガされた場合、パラメータは値 未割り当てテスト を持ちます。
#sctm_execdef_id
現在実行されている実行計画の数値識別子 (データベース キー)。
#sctm_product
実行されたテスト コンテナで定義された製品の名前。
#sctm_version
実行の結果が関連付けられているバージョンの名前。
#sctm_build
実行の結果が関連付けられているバージョンの名前。
#sctm_keywords
この実行計画に対して定義されているキーワードを含むカンマ区切りの一覧。
#sctm_test_results_dir
テストの結果ファイルが存在するディレクトリのパス。
#sctm_test_name
実行している Silk Central テストの名前。
#sctm_test_id
実行しているテストの数値識別子 (データベース キー)。
#sctm_source_root_dir
バージョン コントロール下にあるすべてのファイルが置かれているテスト コンテナのルート ディレクトリのローカル パス。
#external_id
実行されるテスト パッケージ内のテスト ケースの一意の識別子。テスト パッケージ内の特定のテスト ケースだけを実行させる場合のフィルタとして利用できます。

#is_test_package_root
true の場合、実行されるテストはテスト パッケージのルート ノードです (デフォルト)。false の場合、#external_id によって指定されたテスト パッケージ内の特定のテスト ケースだけが実行されます。
#sctm_data_driven_parent_test_name
親のテストの名前 (実行したテストがデータ駆動行の場合)。
#sctm_data_driven_parent_test_id
親のテストの数値識別子 (データベース キー) (実行したテストがデータ駆動行の場合)。
親トピック: テスト パラメータ
親トピック: 実行計画パラメータ
関連概念
テスト パラメータ
関連資料
Java システム プロパティを通じて Silk Central パラメータにアクセスする


カスタム パラメータを作成する

カスタム パラメータを作成するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規パラメータの作成先となるテスト ノードを選択します。
  3. パラメータ セクションで、カスタム パラメータの追加 をクリックします。 カスタム パラメータの設定 ダイアログ ボックスが表示されます。
  4. パラメータの名前を定義します。
  5. タイプ リスト ボックスで、パラメータのタイプを選択します。
    • 文字列
    • 数値
    • 浮動小数点数
    • ブール値
    • パスワード
    • 文字
  6. 選択したテストに割り当てるパラメータ値を定義します。
    注: 文字列型のパラメータを Silk Test Classic 実行で使用する場合は、その値を引用符 (") で囲んで設定する必要があります。
  7. OK をクリックします。
    注: パラメータは、そのパラメータが割り当てられたノードのすべてのサブフォルダと子テストに自動的に割り当てられます。
親トピック: テスト パラメータ


Silk Performer テストに定義済みパラメータを追加する

テストに定義済みパラメータを追加するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、定義済みパラメータを追加するテスト ノードを選択します。
  3. パラメータ セクションで、定義済みパラメータの追加 をクリックします。
    注: 定義済みパラメータの追加 ボタンは、プロジェクト のプロパティが既に定義されている Silk Performer テストに対してのみ利用できます。
    定義済みパラメータの追加 ダイアログ ボックスが表示され、プロジェクト ファイルで利用可能なすべてのプロジェクト属性が一覧表示されます。
  4. 一覧表示されたパラメータのいずれかを追加するには、そのパラメータに対応する [追加] アイコンをクリックします。
  5. 表示されるダイアログ ボックスに、そのパラメータの実際の値を指定します。
  6. 保存 をクリックして、アクティブな テスト ツリー ノードにパラメータを追加します。
親トピック: テスト パラメータ


定義済みパラメータを編集する

定義済みパラメータを編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 編集対象の既存パラメータを含むテスト ノードを選択します。
  3. パラメータ セクションで、編集するパラメータの 編集 アイコンをクリックします。 カスタム パラメータの設定 ダイアログ ボックスが表示されます。
  4. 必要に応じて、パラメータ値を編集します。
    注: 親から継承したパラメータは編集できません。親から継承 チェック ボックスをオフにすると、パラメータの 値 を編集できるようになります。パラメータの 名前 と タイプ の設定は編集できません。
親トピック: テスト パラメータ


定義済みパラメータの割り当てを解除する

定義済みパラメータの割り当てを解除するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、既存のパラメータの割り当てを解除するテスト ノードを選択します。
  3. パラメータ セクションで、削除するパラメータの アクション 列にある 削除 をクリックします。
    注: 親から継承したパラメータは削除できません。パラメータの設定 ダイアログ ボックスで 親から継承 チェック ボックスをオフにすると、親から継承したパラメータの削除が可能になります。
  4. パラメータの削除 ダイアログ ボックスで はい をクリックして、パラメータを削除します。
親トピック: テスト パラメータ


パラメータ値の中のパラメータ

パラメータを含むパラメータ値を使うことができます。 そういったパラメータ値の評価結果は、GUI 上で太字で表示されます。 以下の例に、そのようなパラメータの使用方法を示します。
parameterA := aaa
parameterB := bbb + ${parameterA}
評価結果：
parameterA = aaa
parameterB = bbb + aaa
親トピック: テスト パラメータ


パラメータ表記

以下のパラメータ表記がサポートされています。

すべてのテストの場合：
${<parameter>}

パラメータ名には、$、{、}、# を除くすべての文字を使うことができます。

手動テストで推奨されない表記：
#<parameter>#

手動テストの場合、次の文字をパラメータ名に使用できます：0-9、a-z、A-Z、および _。

Silk Test Classic テストでの追加表記：
$<parameter>

Silk Test Classic テストの場合、次の文字をパラメータ名に使用できます：0-9、a-z、A-Z、および _。

親トピック: テスト パラメータ


実行時のパラメータ トークンの置き換え

テストのプロパティとして文字列を入力するときには、${parametername} という表記でプレースホルダを含めることができます。このプレースホルダは、実行時に、その名前のパラメータに対して入力された値に置き換えられます。これによって、プロパティ中で繰り返し現れる文字列をカスタマイズしやすくなり、共通の定義も編集しやすくなります。

Silk Central で ${parametername} 表記のパラメータが見つかると、まず、そのパラメータが定義済みパラメータの中にあるかどうかを確認し、存在しない場合には、そのパラメータが実行サーバーの環境変数として定義されているかどうかを確認します。環境変数の値は、実行サーバーの起動時に定義されていたものが使用されます。Silk Central 変数名は、大文字小文字が完全に一致するか、またはすべての文字が小文字か大文字に統一されている場合にのみ、環境変数の名前と一致します。たとえば、Silk Central が環境変数 SilkHome と一致するとみなすのは、${SilkHome}、${silkhome}、${SILKHOME} で、${silkHome} は一致しません。

たとえば、JUnit クラスパス プロパティの値が junit.jar;${MyWorkingDir}/myclasses で、パラメータ MyWorkingDir の値が C:/Temp/MyWorking である場合、置き換えられた後の有効なプロパティ値は、junit.jar;C:/Temp/MyWorking/myclasses となります。

注: パラメータの値にも別のパラメータ プレースホルダを含むことができます。 そのため、同じ原理でネストが可能になります。
親トピック: テスト パラメータ


テストの添付情報

添付情報 セクションには、選択されたテスト コンテナ、フォルダ、およびテストへの添付情報としてアップロードされているすべてのファイルやリンクが一覧表示されます。

子要素の添付情報を含める チェック ボックスをオンにすると、選択したノードの子テスト、フォルダ、およびテスト コンテナのすべての添付情報が追加で表示されます。

  • テスト要素にファイルを添付する
    テスト要素にファイルを添付して、追加情報をテストに追加します。
  • テスト要素にリンクを添付する
    テスト要素にリンクを添付して、追加情報をテストに追加します。
  • テストの添付情報を表示する
    テストの添付情報を表示して、テストに関する追加情報を取得します。
  • テスト要素からのファイルのダウンロード
    テスト要素からすべての添付ファイルをローカル ディスクにダウンロードします。
  • テスト要素から添付を削除する
    追加情報が必要でなくなった場合に、テスト要素から添付情報を削除します。
親トピック: テスト プロパティを設定する
関連概念
テスト プロパティを設定する
テスト属性
テスト パラメータ
関連資料
テスト プロパティ


テスト要素にファイルを添付する

テスト要素にファイルを添付するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、コンテナ、フォルダ、またはテストを選択します。
  3. 添付情報 セクションで、ファイルのアップロード をクリックします。 ファイルのアップロード ダイアログ ボックスが表示されます。
  4. ファイルの選択 をクリックして、ローカルのファイル システムからファイルを選択します。
  5. 省略可能：説明 フィールドに添付ファイルに対する説明を入力します。
  6. OK をクリックして、添付ファイルをサーバーにアップロードし、選択されている要素にそれを関連付けます。
親トピック: テストの添付情報


テスト要素にリンクを添付する

テスト要素にリンクを添付するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、コンテナ、フォルダ、またはテストを選択します。
  3. 添付情報 セクションで、リンクの添付 をクリックします。 リンクの添付 ダイアログ ボックスが表示されます。
  4. リンク フィールドに URL を入力します。
  5. 省略可能：説明 フィールドに、添付するリンクの説明を入力します。
  6. OK をクリックして、選択中の要素にリンクを関連付けます。
親トピック: テストの添付情報


テストの添付情報を表示する

添付情報 ページには、選択したテスト要素の添付ファイルとリンクが一覧表示されます。添付情報は、デフォルトではアップロードされた順序で表示されますが、列によってソートできます。選択されている要素の子要素に関連付けられた添付情報を表示するには、子要素の添付情報を含める チェック ボックスをオンにします。

テストの添付情報を表示するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、添付情報を表示する要素を選択します。
  3. 添付情報 セクションで、添付情報の名前をクリックします。 一覧された各添付情報の名前はリンクとして使用できます。ファイル添付のリンクをクリックすると 名前を付けて保存 ダイアログ ボックスが開き、添付ファイルをローカルのファイル システムにダウンロードできます。リンク添付のリンクをクリックすると、新しいブラウザ ウィンドウが開き、直接リンク先が表示されます。
親トピック: テストの添付情報


テスト要素からのファイルのダウンロード

テスト要素からすべてのファイルをダウンロードするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、コンテナ、フォルダ、またはテストを選択します。
  3. 添付情報 タブをクリックします。
  4. 添付情報 セクションで、すべてのファイルのダウンロード をクリックします。 ブラウザのダウンロード設定がどのように設定されているかに依存して、すべての添付ファイルがローカル ディスクに zip アーカイブとしてダウンロードされます。
    注: 過度なダウンロードを防ぐため、子要素の添付情報を含める がオンの場合、すべてのファイルのダウンロード は無効になります。
親トピック: テストの添付情報


テスト要素から添付を削除する

テスト要素から添付情報を削除するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、添付情報を削除する要素を選択します。
  3. 添付情報 セクションで、削除する添付情報の アクション 列にある 削除 をクリックします。
  4. 確認ダイアログ ボックスで はい をクリックして、プロジェクトから添付情報を削除します。
    注: 1 度に 1 つの添付情報しか削除できません。
親トピック: テストの添付情報


データ駆動型テスト

データ駆動型テストとは、スプレッドシートやデータベースなど、既存のデータ ソースに含まれる値を元に行うテストのことです。データ駆動型テストを扱うには、まずデータ ソースを設定する必要があります。データソースの設定についての詳細は、「データ駆動型テスト向けのデータ ソース」を参照してください。

  • データ駆動型テストを作成する
    データ駆動型テストを作成します。
  • 手動テスト ステップにデータ ソース値を追加する
    手動テスト ステップにデータ ソース値を追加します。
  • データ ソースから CSV データをダウンロードする
    データ ソースから CSV データをダウンロードします。
  • データ駆動型プロパティを編集する
    データ駆動型プロパティを編集します。
  • データ駆動型プロパティを削除する
    データ駆動型プロパティの関連性が失われた場合、およびデータ ソースを削除する場合は、データ駆動型プロパティをすべて削除します。
  • アトミックなデータ駆動型テストとアトミックでないデータ駆動型テスト
    利用可能なデータ駆動型テスト タイプについて説明します。
  • ワークシートの扱い
    ワークシートをデータ駆動型テストのデータ ソースとして扱う方法について説明します。
  • データのインポートに関する留意事項
    外部データ ソースからデータをインポートする際の追加情報を提供します。
親トピック: テスト プロパティを設定する
関連概念
データ駆動型テスト向けのデータ ソース
データ駆動型テストを作成する
Silk Test Classic テスト


データ駆動型テストを作成する

データ駆動型テストを作成するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テストを新規作成します。 詳細については、「テストを作成する」を参照してください。
  3. 新しく作成したテストの プロパティ タブをクリックします。
  4. データ駆動型プロパティ セクションで、編集 をクリックします。 データ駆動型プロパティ ダイアログ ボックスが表示されます。
  5. データ ソース リストから構成済みのデータ ソースを選択します。データソースの設定についての詳細は、「データ駆動型テスト向けのデータ ソース」を参照してください。
    注: データ ソースには最大 100 行含めることができます。100 行を超える場合、データ駆動型プロパティ ダイアログ ボックスに最大 100 行を返すクエリを入力する必要があります。こうすることで、1 つのデータ ソースから 100 を超えるテストが生成されないようにします。
  6. 次へ をクリックし、続行します。
  7. データ セット リストから、データ セットを選択します。 Excel のデータ ソースの場合は、ワークシート名になります。データベースのデータ ソースの場合は、テーブル名になります。
  8. データ セット内の各行を、別々のテストと見なす場合は、各データ行を単一のテストにする チェック ボックスをオンにします（アトミックでないテスト）。データ セットのすべてのデータ行に対して単一のテストを作成する場合は、このチェック ボックスをオンにしません（アトミックなテスト）。詳細については、「アトミックなデータ駆動型テストとアトミックでないデータ駆動型テスト」を参照してください。
  9. 省略可能：フィルタ クエリ フィールドに SQL クエリを入力すると、SQL 構文に基づいてデータ セットをフィルタ処理できます。
    単純な WHERE 節のクエリのみがサポートされます。たとえば、City 列の Boston を含むデータ行だけが対象になるようにデータをフィルタするには、フィルタ クエリ に次のように入力します。
    City = 'Boston'
  10. データ駆動型プロパティを有効にする チェック ボックスをオンにして、データ駆動型機能を有効にします。設定したデータ ソースは、この設定を有効にしたこのテストに対してのみ使用されます。
  11. 完了 をクリックして、設定を保存します。
    注: データ駆動型プロパティの設定は、各テストの プロパティ ページの データ駆動型プロパティ に表示されます。
    注: Silk Performer スクリプトで Silk Central のデータ駆動型テスト機能を使用するには、対応する Silk Performer プロジェクト属性に列名が一致するデータ ソースを AttributeGet メソッドと共に使用する必要があります。
親トピック: データ駆動型テスト
関連概念
データ駆動型テスト向けのデータ ソース
データ駆動型テスト
関連タスク
テストを管理する


手動テスト ステップにデータ ソース値を追加する

手動テスト ステップにデータ ソース値を追加するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新しいデータ駆動型テストを作成します。 テスト タイプとして 手動 を選択し、テスト ステップを構成します。
    注: データ ソースに含まれる値を参照するには、そのテストの プロパティ ページの データ駆動型プロパティ セクションをクリックします。
  3. ステップ タブをクリックします。
  4. データ ソース値を参照するテスト ステップを選択します。
  5. アクションの説明 フィールドに、${<列名>} という構文で、データ ソース内の適切な列を参照するパラメータを入力します。 たとえば、テスト ステップで、Password という名前の列を含むスプレッドシートからパスワード パラメータを取得する場合は、${Password} というパラメータを記述します。この手動テスト ステップを実行する際、このパラメータは、対応するデータ駆動型データ ソース内の実際の値に置き換えられます。
親トピック: データ駆動型テスト
関連概念
手動テスト


データ ソースから CSV データをダウンロードする

データ ソースから CSV データをダウンロードするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. データのダウンロード元となるデータ ソースに依存するテストを選択します。
  3. プロパティ タブをクリックします。
  4. データ駆動型プロパティ セクションで、ダウンロード対象のデータを含むエンティティに応じて、データ ソースまたはデータ セットのいずれかの アクション 列にある ダウンロード をクリックします。
  5. データのダウンロード先となるローカル システム上の場所を指定します。
  6. OK をクリックして、CSV 形式でデータをダウンロードします。
親トピック: データ駆動型テスト
関連概念
手動テスト


データ駆動型プロパティを編集する

データ駆動型プロパティを編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 編集対象のプロパティを含むテストを選択します。
  3. プロパティ タブをクリックします。
  4. データ駆動型プロパティ セクションで、編集するプロパティの アクション 列にある 編集 をクリックします。
  5. 必要に応じてプロパティを編集します。
  6. OK をクリックして、変更を保存します。
親トピック: データ駆動型テスト


データ駆動型プロパティを削除する

データ駆動型プロパティの関連性が失われた場合、およびデータ ソースを削除する場合は、データ駆動型プロパティをすべて削除します。
データ駆動型プロパティを削除するには：
  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、データ駆動型プロパティを削除するノードを選択します。
  3. プロパティ タブをクリックします。
  4. データ駆動型プロパティ セクションで、削除 をクリックします。 すべてのデータ駆動型プロパティがノードから削除されます。
    注: データ駆動型プロパティは、ノードのプロパティを継承するすべてのサブノードからも削除されます。
親トピック: データ駆動型テスト


アトミックなデータ駆動型テストとアトミックでないデータ駆動型テスト

データ駆動型テストを計画するときには、まず、Silk Central では以下の 2 種類のデータ駆動型テストがあることを知っておく必要があります。
アトミックなデータ駆動型テスト
データ ソースのすべてのデータ行から 1 つのテスト結果が生成されます。つまり、各データ行の実行がすべて成功した場合にしか、テストは成功になりません。1 つのデータ行の実行が失敗になると、テスト全体が失敗とされます。
アトミックでないデータ駆動型テスト
データ ソースの各データ行が独立したテストとして表されます。つまり、データ行ごとに合格または失敗というテスト結果が出ることになります。たとえば、データ ソースが 4 行からなるスプレッドシートだとすると、親テストとして作成した元のテストの他に、4 つの子 (データ行ごとに 1 つずつ) が新たに作成されます。

データ駆動型テストの作成についての詳細は、「データ駆動型テストを作成する」を参照してください。

このプロセスで作成された親テストには、パラメータは関連付けられません。親テストは、子テストの構造を表すインスタンスとなるだけであり、実際のテストとしては機能しないからです。データ ソース内のすべての値は、親テストの データ駆動型プロパティ セクションに一覧表示されます。

親テストを要件に割り当てるときに、要件に対するリンクが継承されるのは、アトミックなデータ駆動型テストを使用する場合だけです。

アトミックでないデータ駆動型テストの親テストを、セットアップ用またはクリーンアップ用のテスト実行に割り当てることはできません。このような親ノードはフォルダとして扱われるからです。ただし、子ノードのいずれかを割り当てることは可能ですし、アトミックなデータ駆動型テストをセットアップ用またはクリーンアップ用のテスト実行に割り当てることもできます。

データ ソースの制約についての詳細は、「データ ソースの制約」を参照してください。

親トピック: データ駆動型テスト


ワークシートの扱い

データ ソースが Microsoft Excel のワークシートである場合、保守しやすいようにうまくデータ駆動型テストをセットアップするには、以下のガイドラインを守ってください。

  • 列にはそれだけで意味がわかる名前を付けます。 そうすることで、Silk Central におけるデータ ソースのセットアップが維持管理しやすくなります。
  • 複数のワークシートを使用する場合には、全ワークシートで一貫した列名を使います。 そうすると、データ ソースのセットアップで列を選択する際に、フィルタを適用しやすくなります。
  • 特定の列を「キー」列として使用します。 キー列を導入するとデータ ソース ファイルを保守することができます。また、Silk Central では、行の順序が変わった場合にもキー列の値を元に特定のデータ行を特定することができます。 キー列の値は一意でなければなりません。
親トピック: データ駆動型テスト


データのインポートに関する留意事項

Silk Central は、外部データ ソースからデータ行をインポートするときに、外部データ ソースで使用されていた行のソート機能を考慮しません。 そのため、Silk Central でのデータ行の順序は、外部データ ソースでの行の順序と異なる可能性があります。また、 Silk Central は外部データ ソースで適用されていた書式設定も無視します。 たとえば、Excel ワークシートで、特定の書式で日付を表示するようにデータ セルを設定していたとしても、Silk Central はその設定を無視し、どのデータ値も「YYYY.MM.DD HH:MM:SS.M」という基本の書式でインポートします。

注: データ ソースには最大 100 行含めることができます。 100 行を超える場合、データ駆動型プロパティ ダイアログ ボックスに最大 100 行を返すクエリを入力する必要があります。 こうすることで、1 つのデータ ソースから 100 を超えるテストが生成されないようにします。
親トピック: データ駆動型テスト


成功条件

成功条件を使用して、テストが成功したかどうかを判別します。テスト 領域の各テスト ノードまたはスイート ノードには、1 つ以上の成功条件を割り当てることができます。ある成功条件が、割り当てられているテストの実行中に満たされなかった場合、そのテストの実行は、[失敗] と記されます。実行タイムアウト成功条件の場合は例外で、テスト実行は [未実行] と記されます。テスト パッケージでは、すべての成功条件（実行タイムアウトを除く）が無効になり非表示となっています。

詳細ビュー の テスト ツリーでノードを選択すると、そのノードの プロパティ ページの 成功条件 テーブルに、選択されたノードに構成されているすべての成功条件が表示されます。テーブルには、各条件の名前、条件がアクティブであるかどうか、条件の最大値、および条件が継承されたものであるかどうかが含まれています。

成功条件は、それがアクティブになっている場合にのみ評価されます。成功条件をアクティブまたは非アクティブにする方法については、「成功条件を編集する」を参照してください。利用できる成功条件のタイプは、テストのタイプによって変わります。現在 Silk Central で利用可能な成功条件は以下のとおりです。

成功条件
説明
許容されるエラー数
そのテストで許容されるエラーの最大数。この成功条件は、デフォルトでアクティブになります。
許容される警告数
そのテストで許容される警告の最大数。
実行タイムアウト [秒]
そのテストで許容されるタイムアウトまでの最大時間（秒単位）。
ページ時間:平均ページ時間 [秒]
ページを読み込むのに許容される平均時間の最大数。
ページ時間:最大ページ時間 [秒]
ページを読み込むのに許容される最大時間の最大数。
トランザクション レスポンス時間:平均トランザクション（ビジー）OK [秒]
テストでの 1 トランザクションに許容される平均応答時間の最大数。
トランザクション レスポンス時間:最大トランザクション（ビジー）OK [秒]
テストでの 1 トランザクションに許容される最大応答時間の最大数。

成功条件の継承については、プロパティの継承と同様です。親ノードに割り当てられている成功条件は、すべてのサブフォルダや子テストにくまなく継承されます。

  • 成功条件を編集する
    成功条件を編集して、変化するテストのニーズを条件に反映させます。
親トピック: テスト プロパティを設定する


成功条件を編集する

詳細ビュー の テスト ツリーでノードを選択すると、ノードの プロパティ ページに、そのノードに関連付けられた成功条件が表示されます。成功条件 テーブルには、各条件の名前、条件がアクティブであるかどうか、条件の最大値、および条件が継承されたものであるかどうかが含まれています。

注: テスト パッケージ ノードでは、すべての成功条件（実行タイムアウトを除く）が無効になり非表示となっています。

テストの成功条件を編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、テスト コンテナ、テスト フォルダ、またはテストを選択します。
  3. プロパティ タブをクリックします。 プロパティ ページには、選択したツリー要素のプロパティが表示されます。
  4. 成功条件 の右側にある 編集 をクリックします。 成功条件の編集 ダイアログ ボックスが表示されます。
  5. 編集対象の成功条件の 親から継承 チェック ボックスをオフにします。
  6. 必要に応じて値を編集します。
  7. アクティブ チェック ボックスをオンまたはオフにすることにより、条件をアクティブにするかどうかを指定します。
  8. OK をクリックして、設定を保存します。
親トピック: 成功条件


テストを試験実行する

テストを試験実行して、テストが意図したとおりに動作するかどうかを確認できます。

テストを試験実行するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、試験実行するテストを右クリックします。
  3. 試験実行 を選択します。
  4. アクティビティへの移動 ダイアログ ボックスが表示されます。アクティビティ ページの結果を分析するには、はい をクリックします。現在の Web ページのままでよい場合は、いいえ をクリックします。 その他の情報については、「アクティビティ」を参照してください。
    注: 今後 アクティビティ ページへの切り替えを選択するダイアログを表示する必要がない場合は、このダイアログを再び表示しない（このログイン セッション中のみ） チェック ボックスをオンにします。この設定は、Silk Central をログアウトするときに破棄されます。

試験実行に成功したら、実行計画を作成する段階に入ります。

親トピック: テスト
関連概念
アクティビティ


ライブラリ

ライブラリは、複数のプロジェクトのテスト間で共有されるテスト ステップキーワードのコレクションです。

オブジェクトを共有することにより、テスト技術者が管理する必要があるステップやキーワードの数を削減できます。ライブラリは、ライブラリ ツリーという階層ツリー構造で表示、編成、および維持管理されます。ライブラリ ツリーでは、任意の数の階層レベルで、共有ステップやキーワードを体系的に整理することができます。ツリー内の任意のノードを編集または削除できます。ツリー内のノードを右クリックし、切り取りまたはコピーして別の場所に貼り付けます。表示設定 ページで、選択したライブラリを表示するプロジェクトを定義します。ライブラリ ツリーのルート ノードは、ライブラリ と呼ばれ、編集できません。

ツリーの各オブジェクトの利用状況 ページでは、選択したオブジェクトを使用するテスト、共有オブジェクト、キーワード、またはキーワード シーケンスがリストされ、オブジェクトに加える変更の影響を見積もることができます。

注: ライブラリ ユニット内のオブジェクトは、テスト管理者、テスト担当者、およびスーパーユーザーの各ロールを持つユーザーが作成、編集、および表示できます。テスト管理者とスーパーユーザーのロールを持つユーザーは、ライブラリ ユニットからオブジェクトを削除することもできます。プロジェクト マネージャ、アナリスト、または報告者のロールを持つユーザーは、ライブラリ ユニットのオブジェクトを表示できます。
  • ライブラリを作成する
    ライブラリを作成し、テストとプロジェクト間で共有される手動テスト ステップやキーワードのコレクションを挿入します。
  • キーワード ライブラリとライブラリ プロパティを管理する
    ライブラリ ツリーで選択したノードのキーワード ライブラリとプロパティを管理します。
  • ライブラリをプロジェクトからアクセス可能にする
    選択したライブラリの共有オブジェクトに、どのプロジェクトからアクセスできるようにするか管理します。
  • ライブラリのキーワードを管理する
    キーワード シーケンスのキーワードを操作のシーケンスを指定するために管理します。
  • Java を使用したキーワード駆動ライブラリのビルド
    Java を使用して外部のキーワード駆動ライブラリをビルドし、Silk Central にアップロードします。これにより、Selenium テストなどの既存のテスト フレームワークと Silk Central を簡単に統合することができます。
  • キーボード操作 (ライブラリ)
    ツリーでのキーボード操作と複数選択について説明します。
  • 共有オブジェクトを管理する
    Silk Central の共有オブジェクトの概念について説明します。
  • バージョン
    共有オブジェクトとテストのバージョンの使用方法について説明します。
親トピック: テスト
関連概念
プロジェクト ベースライン


ライブラリを作成する

  1. メニューで テスト > ライブラリ をクリックします。
  2. ライブラリ ツリーで、ライブラリ と呼ばれるルート ノードを選択します。
  3. ツールバーで、 ライブラリの新規作成 をクリックして新しいライブラリを作成します。
    注: また、ルート ノードを右クリックして、ライブラリの新規作成 をクリックしてもかまいません。
親トピック: ライブラリ


キーワード ライブラリとライブラリ プロパティを管理する

テスト > ライブラリ > <ライブラリ> > プロパティ

ライブラリ ツリー内のノードのプロパティを表示、更新するには、ノードを選択して プロパティ タブをクリックします。

キーワード ライブラリ セクションでは、アップロード ボタンや 削除 ボタンを使用して、外部キーワード ライブラリをアップロードしたり、削除したりすることができます。

親トピック: ライブラリ
関連タスク
Java を使用したキーワード駆動ライブラリのビルド


ライブラリをプロジェクトからアクセス可能にする

テスト > ライブラリ > <ライブラリ> > 表示設定

表示設定 ページで、選択したライブラリをすべてのプロジェクトで表示可能にしたり、選択した一部のプロジェクトだけに表示するように限定したりできます。プロジェクトに対する選択したライブラリの表示設定を変更するには、表示設定の編集 をクリックします。

表示設定の編集 ダイアログ ボックスには、現在のユーザーがライブラリに割り当てできるプロジェクトが表示されます。このダイアログ ボックスには、次の項目が含まれます。
項目 | 説明
すべてのプロジェクト | このオプション ボタンをクリックすると、すべてのプロジェクトがライブラリに割り当てられます。
選択したプロジェクト | このオプション ボタンをクリックすると、選択したプロジェクトがライブラリに割り当てられます。
すべて選択 | クリックすると、一覧表示されているすべてのプロジェクトがライブラリに割り当てられます。
すべて選択解除 | クリックすると、一覧表示されているすべてのプロジェクトがライブラリから割り当て解除されます。
注: 現在ライブラリを使用しているプロジェクトは薄いグレー表示になり、ライブラリから割り当て解除できません。

共有オブジェクトを使用するプロジェクトのベースラインが作成されると、これらのオブジェクトが含まれたライブラリは、デフォルトで新しいプロジェクト ベースラインに表示されます。プロジェクト ベースラインの詳細については、この『ヘルプ』の「管理」トピックを参照してください。

親トピック: ライブラリ
関連概念
管理


キーボード操作 (ライブラリ)

選択したノードでは、以下のアクションを実行できます。

キー | アクション
Up | 選択項目を上に移動
Down | 選択項目を下に移動
Right | 要素を展開
Left | 要素を折りたたみ
F2 | 要素を編集
Ctrl+C | 要素をコピー
Ctrl+X | 要素を切り取り
Ctrl+V | 要素を貼り付け
Del | 要素を削除
クリック | 要素を選択して、現在の要素として設定
Ctrl + クリック | クリックした要素の選択状況の切り替え、または他の要素をクリックして選択項目への追加/削除
Shift + クリック | 現在の選択要素から新規選択要素までの範囲の選択
Shift+Up | 上の要素を選択
Shift+Down | 下の要素を選択
親トピック: ライブラリ


共有オブジェクトを管理する

共有オブジェクトは、ライブラリに含まれる手動テスト ステップやキーワードのコレクションであり、複数のプロジェクトで複数のテストで使用できます。

  • 共有ステップの呼び出し
    ライブラリの共有オブジェクトを単一ステップとして手動テストまたは別の共有オブジェクトに追加する方法を説明します。
  • 共有オブジェクトを作成する
    手動テストまたは共有オブジェクトのテスト ステップを再利用するには、ステップ ページで共有オブジェクトを作成します。
  • ライブラリから共有ステップを抽出する
    手動テストまたは共有オブジェクトを他の共有オブジェクトから独立したものにするには、共有オブジェクトが含まれているライブラリからステップを抽出します。
  • 共有ステップ プロパティを管理する
    アクティブ プロジェクトで扱う手動テスト ステップに設定可能なすべてのプロパティを管理します。
  • 手動テスト ステップの追加と編集
    ステップ ページを使用して、手動テスト ステップを追加または編集します。
  • 共有ステップ オブジェクトのエクスポートと更新
    共有ステップ オブジェクトのエクスポートおよび更新方法について説明します。
  • [ステップ] ページ
    選択したテストまたは共有オブジェクトに含まれている手動テスト ステップがすべて一覧表示されます。
親トピック: ライブラリ


共有ステップの呼び出し

複数のテストおよびプロジェクトで、同じテスト ステップを管理する作業を軽減するために、ライブラリから共有ステップを単一ステップとしてテストまたは共有オブジェクトに追加できます。

共有オブジェクトのすべてのステップ（ステップは選択できません）への呼び出しのみ追加できます。共有オブジェクトへの呼び出しが追加されると、すべての共有ステップは単一ステップとして呼び出し元テストまたは共有オブジェクトに表示されます。追加のステップを呼び出し先ステップの前後に追加できます。共有ステップの最初の部分のみが、参照元テストの実行中に表示されます。共有オブジェクトは削除できません。共有オブジェクトを削除するには、最初にすべての呼び出しを削除する必要があります。

ステップが呼び出される共有オブジェクトの名前は、ステップの名前として ステップ ページに表示されます。呼び出し先共有オブジェクトにアクセスするには、名前をクリックします。

  • 共有ステップへの呼び出しを追加する
    手動テストまたは別の共有オブジェクトで共有ステップを使用するために、共有オブジェクトへの呼び出しを追加します。
  • [共有ステップへの呼び出し] ダイアログ ボックス
    共有ステップへの呼び出し ダイアログ ボックスでは、ライブラリ ツリーで共有オブジェクトを参照できます。
親トピック: 共有オブジェクトを管理する


共有ステップへの呼び出しを追加する

共有オブジェクトへの呼び出しを追加するには：

  1. メニューで テスト > 詳細ビュー をクリックして共有ステップをテストに追加するか、テスト > ライブラリ をクリックして共有ステップを別の共有オブジェクトに追加します。
  2. 対応するツリーで、共有ステップの追加先となるノードをクリックします。
  3. ステップ タブをクリックします。
  4. ステップ リストの最後に共有ステップを追加するには、 共有ステップへの呼び出しの新規作成 をクリックします。選択したステップの上に共有ステップを追加するには、 共有ステップへの呼び出しの挿入 をクリックします。 共有ステップへの呼び出し ダイアログ ボックスが開きます。
  5. 追加するステップの共有ステップ ノードをツリーから選択します。
    注: テストの場合、ツリーにはアクティブなプロジェクトに表示されるライブラリのみ表示されます。詳細については、「[表示設定] ページ」を参照してください。
  6. OK をクリックします。
親トピック: 共有ステップの呼び出し
関連資料
ライブラリをプロジェクトからアクセス可能にする


[共有ステップへの呼び出し] ダイアログ ボックス

共有ステップへの呼び出し ダイアログ ボックスでは、ライブラリ ツリーで共有オブジェクトを参照できます。ダイアログ ボックスを開くには、テスト ツリーで手動テストを選択するか、ライブラリ ツリーで共有オブジェクトを選択し、ステップ タブをクリックして、 共有ステップへの呼び出しの新規作成 をクリックします。

ライブラリ ツリーで既存のライブラリ、フォルダ、および共有オブジェクトを検索するには、ダイアログ ボックスの 検索 フィールドに検索する名前を入力して、Enter キーを押します。検索では、大文字/小文字が区別され、単語全体には限定されません。検索で返されるライブラリおよびフォルダは、全体のサブツリーと共に表示されます。

親トピック: 共有ステップの呼び出し


共有オブジェクトを作成する

手動テストまたは共有オブジェクトの ステップ ページで、共有オブジェクトを作成できます。

共有オブジェクトを作成するには：

  1. 共有オブジェクトの場合は、メニューで テスト > ライブラリ をクリックします。テストの場合は、メニューの テスト > 詳細ビュー をクリックします。
  2. 共有するステップを含む手動テストまたは共有オブジェクトの ステップ ページに移動します。
  3. Ctrl + クリック または Shift + クリック を使用して、ステップを選択します。
  4. 共有ステップの作成 をクリックします。
    共有ステップの新規作成 ダイアログ ボックスが表示されます。
  5. 名前 フィールドに、新しい共有オブジェクトの名前を入力します。
  6. ライブラリ ツリーでの新しい共有オブジェクトの配置場所を選択します。
  7. OK をクリックします。 共有オブジェクトが作成され、選択したステップが共有オブジェクトの呼び出しにより置き換えられます。
親トピック: 共有オブジェクトを管理する


ライブラリから共有ステップを抽出する

手動テストまたは共有オブジェクトを他の共有オブジェクトから独立したものにするには、共有オブジェクトが含まれているライブラリからステップを抽出します。これにより、呼び出されたすべてのステップは手動テストまたは共有オブジェクトにコピーされます。

手動テストまたは共有オブジェクトに含まれている共有ステップを抽出するには：

  1. 共有オブジェクトの場合は、メニューで テスト > ライブラリ をクリックします。テストの場合は、メニューの テスト > 詳細ビュー をクリックします。
  2. 対応するツリーで、共有ステップを解決するノードをクリックします。
  3. ステップ タブをクリックします。
  4. Ctrl + クリック または Shift + クリック を使用して、抽出するステップを選択します。
  5. ステップの抽出 をクリックして、メッセージ ボックスを確認します。
親トピック: 共有オブジェクトを管理する


共有ステップ プロパティを管理する

テスト > テスト ステップ プロパティ

テスト > ライブラリ > <ライブラリ> > ステップ プロパティ

ライブラリ ツリー内の共有オブジェクトのステップ プロパティを作成、編集、または表示するには、ライブラリを選択して ステップ プロパティ タブをクリックします。ステップ プロパティ ページには、アクティブ プロジェクトで扱う手動テスト ステップに設定可能なプロパティがすべて一覧表示されます。新しいステップ プロパティを作成するには、プロパティの新規作成 をクリックします。プロパティに対して実行できるアクションは、削除、上へ移動、下へ移動 です。

親トピック: 共有オブジェクトを管理する
関連概念
ステップ プロパティ


共有ステップ オブジェクトのエクスポートと更新

共有ステップ オブジェクトに対して一括編集を行う場合は、Excel へのエクスポート更新機能を使用します。

エクスポートと更新の概要

エクスポートと更新の概要を次に示します。

  • ライブラリを選択する。
  • Excel にエクスポートする。
  • Excel で変更する。
  • マッピング ファイルを確認/作成する。
  • Silk Central に戻して更新する。
  • Excel に共有ステップ オブジェクトをエクスポートする
    一括編集を行うために Excel に共有ステップ オブジェクトをエクスポートする方法について説明します。
  • Excel から共有ステップ オブジェクトを更新する
    Excel で共有ステップ オブジェクトを更新し、Silk Central にアップロードして戻して更新します。
親トピック: 共有オブジェクトを管理する


Excel に共有ステップ オブジェクトをエクスポートする

一括編集を行うために Excel に共有ステップ オブジェクトをエクスポートする方法について説明します。
  1. メニューで テスト > ライブラリ をクリックします。
  2. エクスポートする共有ステップ オブジェクトを含むライブラリを右クリックして、Excel にエクスポート を選択します。 Excel ファイルにライブラリをエクスポート ダイアログ ボックスが表示されます。
  3. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは LibraryPropertiesDefaultMapping.xml です。
  4. マッピングの編集 をクリックして、マッピング ファイルを編集します。 マッピングの編集 ダイアログ ボックスが表示されます。
  5. プロパティやステップ プロパティ (ステップ プロパティが存在する場合) にマップする Excel の列を指定します。 以下にマッピングの例を示します。

  6. 必要に応じて、名前を付けて保存 フィールドのマッピング ファイルの名前を変更します。OK をクリックします。 Excel ファイルにライブラリをエクスポート ダイアログ ボックスが表示されます。
  7. OK をクリックします。 Excel ファイルが作成され、ブラウザでダウンロードされます。
Excel ファイルを開き、共有ステップ オブジェクトを編集します。編集を終えたらファイルを保存して、Silk Central にアップロードして戻します。

制限事項：Excel ファイルで共有ステップ オブジェクトを作成、削除、移動しても、Silk Central にアップロードして戻したとき、これらの変更は無視されます。

親トピック: 共有ステップ オブジェクトのエクスポートと更新
関連タスク
Excel から共有ステップ オブジェクトを更新する
関連資料
共有ステップ プロパティを管理する


Excel から共有ステップ オブジェクトを更新する

Excel で共有ステップ オブジェクトを更新し、Silk Central にアップロードして戻して更新します。
  1. メニューで テスト > ライブラリ をクリックします。
  2. 更新する共有ステップ オブジェクトを含むライブラリを右クリックして、Excel から更新... を選択します。 Excel ファイルからライブラリを更新 ダイアログ ボックスが表示されます。
  3. マッピング ファイルの選択 リスト ボックスから、マッピング ファイルを選択します。 デフォルトのマッピング ファイルは LibraryPropertiesDefaultMapping.xml です。
  4. 省略可能：マッピングの編集 をクリックして、マッピング ファイルを編集します。この手順は、共有ステップ オブジェクトをエクスポートするのに使用したマッピング ファイルが変更された場合や、Excel ファイルの列ヘッダーを変更した場合にのみ必要です。マッピング プロパティとステップ プロパティについての詳細は、「Excel に共有ステップ オブジェクトをエクスポートする」を参照してください。
  5. ファイルの選択 をクリックして、ライブラリ ファイル (.xlsx) フィールドの Excel ファイルを選択します。
  6. OK をクリックします。 変更が Silk Central で更新されます。
親トピック: 共有ステップ オブジェクトのエクスポートと更新
関連タスク
Excel に共有ステップ オブジェクトをエクスポートする
関連資料
共有ステップ プロパティを管理する


[ライブラリ] の [履歴] ページ

履歴 ページには、選択した共有オブジェクトの履歴が表示されます。

履歴 ページには、選択した共有オブジェクトの各バージョンのエントリが表示されます。このページでは、新規バージョンの作成、バージョン詳細の表示、以前のバージョンの復元、および 2 つのバージョンの比較ができます。

履歴 ページにバージョンのみを表示するには、バージョン 列ヘッダーのコンテキスト メニューを開き、フィルタ を選択し、> フィールドに 0 を入力します。

ページには、各エントリについて次の項目が表示されます。

項目 | 説明
アクション | バージョン エントリの場合のみ。選択したバージョンに対して実行できるアクションは、バージョンの表示、バージョンの削除、および バージョン X に戻す です。
バージョン | バージョン エントリの場合のみ。共有オブジェクトのバージョン。
コメント | 変更についてのコメント。
作成日時 | この履歴の作成日時。
作成者 | この履歴エントリを作成したユーザーの名前。
親トピック: バージョン


要件とテストを関連付ける

要件とテストを関連付けることで、ソフトウェアが特定の要件をどの程度カバーしているかを測定することができます。
  • テストに要件を割り当てる
    テストで要件がカバーされる必要がある場合は、テストに要件を割り当てます。
  • 割り当て済み要件をソートする
    ニーズに合わせて 割り当て済み要件 ページを適用するために、割り当て済み要件をソートします。
  • 割り当て済み要件の場所を検索する
    割り当て可能な要件 ツリーで割り当て済み要件を検索して、テストに割り当てます。
  • 要件割り当てを削除する
    テストが要件をカバーしなくなった場合に、要件割り当てを削除します。
  • [テスト] の 割り当て済み要件 ページ
    選択されたテストまたはプロジェクトに割り当てられている要件を一覧表示します。
親トピック: テスト


テストに要件を割り当てる

要件を手動でテストに割り当てるには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、要件を割り当てるテストを選択します。
  3. 割り当て済み要件 タブをクリックします。
    注: 要件フィルタを作成した場合は、要件 ツリーの上にあるフィルタ リストから要件フィルタを選択できます。新しい要件フィルタを作成するには、メニューの 要件 > 詳細ビュー をクリックし、ツールバーの フィルタの新規作成 をクリックします。
    割り当て可能なすべての要件が、要件 ツリーに表示されます。
  4. 割り当てる要件を選択します。 キーボードの Ctrl または Shift キーを使用すると、標準ブラウザの複数選択機能を使用して、複数の要件を選択することができます。
  5. すべてのフィルタ済み要件の割り当て をクリックして、すべてのフィルタ済み要件を選択したテストに割り当てるか、選択した項目をドラッグして 割り当て済み要件 領域にドロップするか、要件の左側にある 割り当て をクリックして、要件を選択したテストに割り当てます。すべてのフィルタ済み要件の割り当ては、フィルタが選択されており、かつ 要件の管理 または 資産の管理 アクセス権のいずれかを持つ場合にのみ有効です。
    注: 要件からのテストの生成 ダイアログ ボックスで 新規に生成したテストを要件に割り当てる チェック ボックスをオンにすると、新規に生成したテストを生成元となった要件に自動的に割り当てることができます。これは、デフォルトの動作です。
親トピック: 要件とテストを関連付ける
関連タスク
詳細ビューからテストを生成する


割り当て済み要件をソートする

割り当て済み要件をソートするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、テストを選択します。
  3. 割り当て済み要件 タブをクリックします。
  4. 要件をソートする際のキーにするプロパティの列ヘッダーをクリックします。 小さな上矢印または下矢印は、その列がソート キーに利用されていることと、ソートの方向（昇順または降順）の両方を表します。
  5. 列ヘッダーを再度クリックすると、ソートの方法が逆になります。
親トピック: 要件とテストを関連付ける


割り当て済み要件の場所を検索する

割り当て可能な要件 ツリーで割り当て済み要件の場所を見つけるには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、テストを選択します。
  3. 割り当て済み要件 タブをクリックします。
  4. 要件の アクション 列で、 検索 をクリックして、その要件が保存されている 割り当て可能な要件 ツリーのノードを検索します。
該当する親要件ノードが展開されて、割り当て済み要件が強調表示されます。
親トピック: 要件とテストを関連付ける


要件割り当てを削除する

要件割り当てを削除するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、少なくとも 1 つの要件が割り当てられているテストを選択します。
  3. 割り当て済み要件 タブをクリックします。
  4. 割り当て済み要件の アクション 列で、 割り当ての削除 をクリックするか、Ctrl+クリック や Shift+クリック を使用して複数の要件を選択してから Del キーを押します。
    注: 選択されているテストからすべての要件割り当てを削除するには、すべて削除 をクリックします。
親トピック: 要件とテストを関連付ける


[テスト] の 割り当て済み要件 ページ

テスト > 詳細ビュー > <テスト要素> > 割り当て済み要件

割り当て済み要件 ページには、選択されたテストまたはプロジェクトに割り当てられている要件が一覧表示されます。また、追加の要件を割り当てることもできます。割り当て可能な要件 ツリーには、割り当て可能なすべての要件が一覧表示されます。

注: 要件フィルタを作成した場合は、要件 ツリーの上にあるフィルタ リストから要件フィルタを選択できます。新しい要件フィルタを作成するには、メニューの 要件 > 詳細ビュー をクリックし、ツールバーの フィルタの新規作成 をクリックします。

割り当て済み要件ごとに、次の列がページに表示されます。

列 | 説明
アクション | 選択した要件に対して行うことができるアクション。要件の削除、要件の検索、および 説明の表示。
要件 | 割り当てられている要件の名前。クリックすると、要件 > プロパティ ページが開きます。
優先度 | 要件の優先度。
リスク | 要件に関連する潜在的なリスク。
レビュー済み | 要件のレビュー ステータス。
親トピック: 要件とテストを関連付ける


テスト レポート

このセクションでは、Silk Central に同梱されているテスト関連のレポートについて説明します。 テスト レポートは、一定期間または一定の範囲のビルドにおける、テストの進捗や問題のステータスの概要を示します。

  • ステータス レポート
    テスト 領域で使用できるステータス レポートについて説明します。
  • 進捗レポート
    テスト 領域で使用できる進捗レポートについて説明します。
  • 手動テスト レポート
    テスト 領域で使用できる手動テスト レポートについて説明します。
  • ベースライン テストの比較レポート
    ベースライン テストの比較レポートは、ベースライン化されたプロジェクトとベースラインを比較し、変更、削除、および作成されたテストの数を表示します。
  • テストの実行の比較レポート
    テストの実行の比較レポートは、テストの前回と前々回の実行を比較します。比較情報として、コンテキスト、ステータス、エラー、警告、実行時間、プロパティ、属性、パラメータ、成功条件についての詳細な情報を提供します。
親トピック: テスト
親トピック: デフォルトのレポート


ステータス レポート

以下のステータス レポートは、テスト 領域で使用できます。
コンポーネントごとのテスト
コンポーネントのカバレッジの概要をテスト数で表します。テスト作業が必要な部分を特定しやすくなります。
実装済みテスト (コンポーネント単位)
コンポーネントのカバレッジの概要を、実装済み 属性が はい に設定されているテストの数で表します。
失敗したテスト (コンポーネント単位)
失敗したテストをコンポーネントごとに表します。環境内で最も危機的なコンポーネントを特定しやすくなります。
テスト (テスト コンテナ単位)
テスト コンテナごとの成功率を、合格したテストの数で表します。
品質目標計画レポート

各目標基準におけるテスト数、および目標基準達成までの合計予定時間が表示されます。

注: 予定時間の値は、手動テスト専用です。自動テストには予定時間はありません。

このレポートでは、プロジェクト内で定義された各品質目標について、3 種類の情報が表示されます。

  • テスト範囲：品質目標の各項目における、有効なテストの合計数と、テストの合計数または必要数とを比較します。
  • 必要な予定時間：品質目標内の項目における必要な予定時間を比較します。
  • 値テーブル：関連するメトリクスとともに、すべての品質目標項目 (有効なテスト、目標 (%)、必要なテスト、および手動テストの予定時間) を一覧表示します。
注: 複数選択された属性またはプロパティでは、テスト数は対象となるテストごとにカウントされます。
品質目標実行レポート
各目標の各項目に対して実行されたテストの数を視覚的に表示します。このレポートは、プロジェクト内で定義された各品質目標について、2 つのセクションに分類されます。
  • 実行ステータス グラフ：色分けされた実行ステータスと要約値で、各品質目標項目を一覧表示します。
  • 値テーブル：その実行メトリクスおよびすべての品質目標項目 (合格、失敗、未実行、N/A、総計、目標達成テスト数、および目標達成実行率) を一覧表示します。
テスト ステータス概要
すべてのテストのステータス概要を、[合格]、[失敗]、[未実行]、[N/A] という 4 つのステータスに分けて表します。
テスト ステータス概要 (テスト コンテナ単位)
特定のテスト コンテナに含まれるすべてのテストのステータス概要を、[合格]、[失敗]、[未実行]、[N/A] という 4 つのステータスに分けて表します。
親トピック: テスト レポート


進捗レポート

以下の進捗レポートは、テスト 領域で使用できます。
ビルド 'X' から 'Y' までのテストの進捗
ビルドの更新に沿ってテストのステータスを見たときのテストの進捗の傾向を表します。ユーザーは、開始ビルドと終了ビルドでビルドの範囲を指定する必要があります。
ビルド <x> 以降の手動テスト カバレッジ (累積)
ビルドの更新に沿ってテストのステータスを見たときの、すべての自動テストを除く、手動テストの進捗傾向を表します。ユーザーは、累積進捗を計算するためのベースとして使用される開始ビルド番号を指定する必要があります。
ビルドごとの自動テスト カバレッジ (非累積)
ビルドの更新に沿ってテストのステータスを見たときの、自動テストのカバレッジを表します。ユーザーはバージョンおよび製品を指定する必要があり、レポートには自動テストで達成可能なテスト カバレッジがビルドごとに表示されます。
過去 <x> 日間の特定フォルダ内のテストの進捗
指定 ID を持つテスト ツリー ノードのテスト ステータスを過去 <x> 日間で見たときの、テストの進捗傾向を表します。
過去 'X' 日間のテスト進捗
過去 'X' 日間にわたるテストのステータスを見たときの、テストの進捗傾向を表します。
今月のテストの進捗
今月のテストのステータスを見たときの、テストの進捗傾向を表します。
過去 'X' 日間のテスト合格率（コンポーネント単位）
過去 'X' 日間のテストの合格率をコンポーネントごとにパーセントで表します。環境内で最も危機的なコンポーネントを特定するのに役立ちます。
過去 'X' 日間に作成されたテスト (コンポーネント単位)
過去 'X' 日間に新規作成されたテストの一覧をコンポーネントごとに表します。テスト作業が足りないコンポーネントを特定するのに役立ちます。
親トピック: テスト レポート


手動テスト レポート

テスト 領域で使用できる手動テスト レポートは、次のとおりです。
実行時間の計画値と実績値の履歴 (ユーザー単位)
手動テストの完了に要した実行時間の計画値と実績値の概要を、特定の期間にわたってユーザーごとに表します。
実行時間の計画値と実績値 (ユーザーごとのステータス)
まだ完了していない手動テストについて、ユーザーごとに計画時間と実績時間で進捗を表します。手動テストは、試験結果がユーザーによって入力され、結果を入力したユーザーに割り当てられた場合にのみ考慮されます。
手動テスト結果文書
指定した実行計画に割り当てられた、すべてのテストの最新の結果に関する、手動テストケース レポート (印刷用)。
手動テスト結果文書 (Microsoft Word)
Microsoft Word ドキュメントの指定した実行計画に割り当てられた、すべてのテストの最新の結果に関する、手動テストケース レポート (印刷用)。
実行計画ごとの手動テスト結果
指定した実行計画フォルダやテスト サイクル内のすべての実行計画に割り当てられた、すべてのテストの最新の結果に関する、手動テストケース レポート (印刷用)。
手動テストの実行時間の計画値と実績値 (要約)
手動テストの実行時間の計画値と実績値の差異の概要を日単位で表します。
親トピック: テスト レポート


ベースライン テストの比較レポート

ベースライン テストの比較レポートは、ベースライン化されたプロジェクトとベースラインを比較し、変更、削除、および作成されたテストの数を表示します。

ベースライン テストの比較 レポートの入力パラメータは、プロジェクトおよびベースラインの識別子です。

親トピック: テスト レポート
関連タスク
プロジェクトとベースラインを比較する


テストの実行の比較レポート

テストの実行の比較レポートは、テストの前回と前々回の実行を比較します。比較情報として、コンテキスト、ステータス、エラー、警告、実行時間、プロパティ、属性、パラメータ、成功条件についての詳細な情報を提供します。
注: 実行の比較レポートは、手動テストを自動テストに対して比較するのには向いていません。レポートの名前に「(前回と前々回の実行)」が含まれている場合、実行計画またはテストの、最新の 2 つの実行のみの比較となります。
親トピック: テスト レポート


割り当て済み実行計画

テストを実行計画に割り当てると、開発とテストの期間中、絶えずテスト実行を管理することができます。
  • 割り当て済みの実行を表示する
    選択したテストが割り当てられているすべての実行計画を表示します。
親トピック: テスト


割り当て済みの実行を表示する

選択したテストが割り当てられているすべての実行計画を表示するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 実行計画の割り当てを表示するテストを選択します。
  3. プロパティ タブをクリックします。 実行 セクションで、テストが割り当てられているすべての実行のリストが、割り当て済み実行計画 グリッドに表示されます。
親トピック: 割り当て済み実行計画
関連資料
テスト プロパティ


テスト ビュー

Silk Central が提供するいくつかのビューとツールを使用して、テストの管理を行うことができます。

  • テスト ツリーで作業する
    テスト ツリーの使用方法について説明します。
  • [テスト] ツールバーの機能
    テストを管理するための重要なコマンドが用意されています。
  • テスト ドキュメント ビュー
    選択したプロジェクトで扱われているすべてのテストの最重要情報、ステータス、および前回の実行が一覧表示されます。
  • [グリッド ビュー] でテストを使用する
    このセクションでは、グリッド ビュー でテストを使用する方法について説明します。
親トピック: テスト


テスト ツリーで作業する

テスト > 詳細ビュー

要件と同様に、各テストは テスト ツリーという階層ツリー構造で表示、整理、および維持管理します。テスト ツリーでは、任意の数の階層レベルで、テストを体系的に整理することができます。ツリーの各ノードは、テスト、テスト フォルダ、テスト コンテナのいずれかを表します。

注: ページに、一度に表示した場合に応答に影響が出るほど多くの要素がある場合、要素は順に表示されます。ページの下部にあるナビゲーション ツールバーを使用して、要素全体をブラウズすることができます。
  • キーボード操作 (テスト)
    ツリーでのキーボード操作と複数選択について説明します。
  • テスト ツリーの展開と折りたたみ
    表示ニーズに応じて階層レベルを折りたたんだり展開したりするために、テスト ツリーの展開と折りたたみを行います。
  • テスト要素を切り取り、コピー、貼り付け、または削除する
    テスト要素を切り取り、コピー、貼り付け、または削除して、プロジェクトのテストを作成および管理します。
  • プロジェクト間でテスト要素をコピーまたは貼り付けする
    テスト要素をプロジェクト間でコピーして貼り付け、複数のプロジェクトで要素を再利用します。
  • リポジトリ プロジェクトのテスト資産の再利用
    共通テスト資産をリポジトリ プロジェクトでメンテナンスし、参照するプロジェクトから再利用できます。
  • テスト要素の順序を変更する
    テスト ツリーでテスト、テスト フォルダ、およびテスト コンテナの順序を変更して、ツリーにテストのニーズを反映させます。
  • テスト ノードを外部アジャイル計画ツールのデフォルト統合フォルダとして設定する
    テスト ノードをデフォルト統合フォルダとして設定し、外部アジャイル計画ツールを使用して Silk Central にテストを作成できるようにします。
  • フォルダまたはコンテナをフィルタする
    フォルダまたはコンテナをフィルタして、フォルダまたはコンテナの内容のみを表示します。
  • テスト プロパティ値を検索する
    特定のプロパティ値を検索して、その値が含まれているすべてのテストを見つけます。
  • テスト プロパティの置換
    特定のプロパティ値を検索して、その値が含まれているテストにおいて値を置換します。
  • [テスト] の [内容] ページ
    選択されたプロジェクト、テスト コンテナ、またはフォルダの子要素を表示します。
親トピック: テスト ビュー


キーボード操作 (テスト)

選択したノードでは、以下のアクションを実行できます。

キー | アクション
Up | 選択項目を上に移動
Down | 選択項目を下に移動
Right | 要素を展開
Left | 要素を折りたたみ
F2 | 要素を編集
Ctrl+C | 要素をコピー
Ctrl+X | 要素を切り取り
Ctrl+V | 要素を貼り付け
Del | 要素を削除
Ctrl+Up | 要素を上に移動
Ctrl+Down | 要素を下に移動
クリック | 要素を選択して、現在の要素として設定
Ctrl + クリック | クリックした要素の選択状況の切り替え、または他の要素をクリックして選択項目への追加/削除
Shift + クリック | 現在の選択要素から新規選択要素までの範囲の選択
Shift+Up | 上の要素を選択
Shift+Down | 下の要素を選択
Enter | 要素の割り当て（割り当てツリーでのみ）
親トピック: テスト ツリーで作業する


テスト ツリーの展開と折りたたみ

表示上の必要性に応じて、テスト ツリーのレベルを折りたたんだり、すべてのレベルを表示したりすることができます。

テスト ツリーのレベルの折りたたみや展開を行うには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーでテスト コンテナまたはテスト フォルダを選択して、以下のオプションのいずれかを行います。
    • テスト要素名の左側にある 展開 をクリックして、要素を展開します。
    • テスト要素名の左側にある 折りたたみ をクリックして、要素を折りたたみます。
    • 要素を右クリックして、展開 または 折りたたみ を選択します。
親トピック: テスト ツリーで作業する


テスト要素を切り取り、コピー、貼り付け、または削除する

テスト ユニットのツールバーを使用すると、現在のプロジェクトやプロジェクト間の テスト ツリー内で、テスト要素を簡単に切り取り、コピー、貼り付け、または削除できます。これらの編集機能によって、プロジェクトのテストの作成と管理のプロセスが簡単になります。

テストやテスト フォルダと一緒にコピーされるデータ タイプは、プロパティ、属性、パラメータ、および添付です。割り当て、問題、実行、および履歴はコピーされません。

注: コンテナはコピーまたは貼り付けできません。

テスト要素を切り取り、コピー、貼り付け、または削除するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、編集する要素を選択します。Ctrl + クリック または Shift + クリック を使用して複数の要素を選択できます。
  3. 適切なツールバー ボタンをクリックします。
    ボタン
    説明
    選択されている要素をツリーから削除します。
    選択されている要素をツリーから切り取り、クリップボードに移動します。
    選択されている要素をクリップボードにコピーします。
    クリップボードに保存されている要素のコピーを、現在選択されている要素と同じレベルに貼り付けます。
    クリップボードに保存されている要素のコピーを、現在選択されている要素のサブノードとして貼り付けます。
    注: コマンドは、テスト ツリーのコンテキスト メニューや、キーボード ショートカットを使用して利用することもできます。
親トピック: テスト ツリーで作業する
関連資料
[テスト] の [内容] ページ


プロジェクト間でテスト要素をコピーまたは貼り付けする

テスト フォルダやテストをプロジェクト間でコピーして貼り付けるには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. ソース プロジェクトを選択します。
  3. メニューで テスト > 詳細ビュー をクリックします。
  4. 切り取り をクリックして、要素をクリップボードに切り取るか、 コピー をクリックして、要素をクリップボードにコピーします。
  5. メニューで プロジェクト > プロジェクト リスト をクリックします。
  6. 貼り付け先のプロジェクトを選択します。
  7. 貼り付け先のコンテナおよびフォルダを選択します。
  8. 貼り付け をクリックします。
注: コマンドは、テスト ツリーのコンテキスト メニューや、キーボード ショートカットを使用して利用することもできます。
親トピック: テスト ツリーで作業する


テスト要素の順序を変更する

テスト、テスト フォルダ、またはテスト コンテナの順序を変更するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、順序を変更するテスト要素を選択します。
  3. テスト要素を 1 段階上へ移動するには、 上へ移動 をクリックし、テスト要素を 1 段階下へ移動するには、 下へ移動 をクリックします。
親トピック: テスト ツリーで作業する


テスト ノードを外部アジャイル計画ツールのデフォルト統合フォルダとして設定する

外部アジャイル計画ツールを介して、Silk Central 内にテストを作成するために、Web サービスの呼び出しを使用するには、テスト ツリー内のフォルダやコンテナを、Web サービスがテストを作成する場所となるデフォルト統合フォルダとして設定します。このデフォルト統合フォルダを指定しないと、エラー メッセージが表示されます。

デフォルト統合フォルダを テスト ツリーで指定するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、デフォルト統合フォルダとして設定するフォルダまたはコンテナを選択します。
  3. フォルダまたはコンテナを右クリックして、統合のデフォルトとして設定 を選択します。
    注: デフォルト統合フォルダがすでに存在する場合には、新しいフォルダに変更されます。
デフォルト統合フォルダが選択したノードに設定され、アジャイル計画ツールがこの場所へテストを作成できるようになります。
注: デフォルト統合フォルダは、そのノードがあるプロジェクトの プロパティ ページに表示されます。
親トピック: テスト ツリーで作業する
関連資料
テスト プロパティ


フォルダまたはコンテナをフィルタする

フォルダまたはコンテナをフィルタするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. ツリーでフィルタするフォルダまたはコンテナを右クリックして、サブツリーのフィルタ表示 を選択します。 選択されたフォルダまたはコンテナの内容、およびツリーのルート ノードまでの階層のみがツリーに表示されます。
注: フィルタ処理を削除して、すべての要素を表示するには、ツールバーの フィルタ リスト ボックスから <フィルタなし> を選択します。 空のフォルダは、フィルタが適用されたサブツリーには表示されません。
親トピック: テスト ツリーで作業する


テスト プロパティ値を検索する

テスト 領域の 検索 コマンドを使用すると、指定した検索条件を満たすテストのプロパティ値を検索できます。次へ、前へ、先頭へ、および 最後へ の各機能を利用して、指定したプロパティ値に対する検索の結果をたどっていくことができます。検索 は、すべての Silk Central プラグインと機能カテゴリで利用できます。

注: 検索 コマンドを使用すると、データ駆動型テスト プロパティ値を検索できます。
注: テスト ツリーにフィルタが適用されている場合、検索 はフィルタ処理後に テスト ツリーに表示されているテストに対してのみ実行されます。

特定のテスト プロパティ値を見つけるには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. ツールバーで、 検索 をクリックします。 検索 ダイアログ ボックスが開きます。
  3. カテゴリ リスト ボックスから、検索する Silk Central プラグインまたは機能カテゴリを選択します。
    ヒント: カスタムのプラグイン プロパティを定義すると、リストに自動的に追加されます。
  4. 検索範囲 リスト ボックスから、クエリで値を検索する範囲のプロパティを選択します。 このリストで利用できるプロパティは選択したカテゴリにより変わります。
  5. 検索文字列 フィールドに、クエリで検索する英数字の文字列を入力します。

    オプション設定はクエリを制限するために利用できます。以下の該当するチェック ボックスとオプション ボタンを設定します。

  6. テスト ツリーで、検索を開始する場所を選択します。 以下のオプションを利用できます。
    オプション ボタン
    説明
    選択位置から開始
    現在選択しているテスト要素から検索を開始するように指定します。
    先頭から開始
    テスト ツリーのルートから検索を開始するように指定します。
    サブツリー内のみを検索
    テスト ツリーで現在選択されている要素をルート ノードとして持つサブツリーでのみ検索を実行するように指定します。
  7. 適切なチェック ボックスをオンにして、さらにクエリを限定します。 以下のチェック ボックスを利用できます。
    チェック ボックス
    説明
    大文字/小文字を区別
    文字列検索時に大文字と小文字を区別するかどうかを指定します。
    注: 大文字/小文字を区別する SQL Server を利用する場合、大文字/小文字を区別しない検索は、次のフィールドに対してはサポートされません。
    • テストの説明
    • 手動ステップの説明
    • 手動ステップ アクションの説明
    • 手動ステップの期待される結果
    完全に一致するものを検索
    検索結果にはクエリ文字列の完全に一致するインスタンスのみ含めることを指定します。
    読み取り専用の値を含める
    検索結果に直接編集できないテキスト文字列を含めることを指定します。対象が、別のテストからの継承、リンクされたテスト コンテナからの参照、またはデータ駆動型テストの実行中のデータ ソースからの呼び出しである場合です。
  8. 検索 をクリックして、検索を開始し、クエリによって返された最初のテスト コンテナ、テスト フォルダ、またはテストに進みます。
  9. クエリが複数のテスト要素を返す場合、要素を順番に表示するオプションが提供されます。
    注: 検索 コマンドでは、検索文字列として継承値を指定してテスト要素を検索できます。
親トピック: テスト ツリーで作業する
関連タスク
テスト プロパティの置換


テスト プロパティの置換

置換 コマンドを使用すると、特定されたプロパティ値を新しい値で置換できます。置換 は、すべての Silk Central プラグインと機能カテゴリで利用できます。

注: データ駆動型テスト プロパティ値は、置換 コマンドを使用して置換できません。
注: テスト ツリーにフィルタが適用されている場合、置換 はフィルタ処理後に テスト ツリーに表示されているテストに対してのみ実行されます。

特定されたテスト プロパティ値を置換するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. ツールバーで、 置換 をクリックします。 置換 ダイアログ ボックスが開きます。
  3. カテゴリ リスト ボックスから、検索する Silk Central プラグインまたは機能カテゴリを選択します。
    ヒント: カスタムのプラグイン プロパティを定義すると、リストに自動的に追加されます。
  4. 検索範囲 リスト ボックスから、クエリで値を検索する範囲のプロパティを選択します。 このリストで利用できるプロパティは選択したカテゴリにより変わります。
  5. 検索文字列 フィールドに、クエリで検索する英数字の文字列を入力します。

    オプション設定はクエリを制限するために利用できます。以下の該当するチェック ボックスとオプション ボタンを設定します。

  6. 置換文字列 フィールドに、検索された値を置換する英数字の文字列を入力します。
  7. 検索 をクリックして、検索を開始し、クエリによって返された最初のテスト コンテナ、テスト フォルダ、またはテストに進みます。または すべて置換 をクリックしてクエリ文字列のすべてのインスタンスを置換文字列で置換します。
  8. クエリが複数のテスト要素を返す場合、要素を順番に表示するオプションが提供されます。
    注: 置換 コマンドでは、検索文字列として継承値を指定してテスト要素を検索することはできません。
親トピック: テスト ツリーで作業する
関連タスク
テスト プロパティ値を検索する


[テスト] の [内容] ページ

テスト > 詳細ビュー > 内容

内容 ページには、テスト ツリー内の選択されたプロジェクト、テスト コンテナ、またはフォルダの子要素が表示されます。このページでは、Windows Explorer スタイルの複数選択機能がサポートされます。

ヒント: 選択したフォルダまたはコンテナの中を掘り下げていくには、Enter を押すか、選択しているそのアイテムをダブルクリックします。Backspace を押すか、ツールバーの 上へ をクリックすると、一階層上へ移動します。
注: テスト コンテナのコピーまたは貼り付けはできません。
ヒント: テスト ツリーにリストされたテスト要素と同様に、内容 ページにリストされた要素を右クリックして、コンテキスト メニューからコンテキストに対応したコマンドを選択できます。利用できないコマンドは無効になっています（薄いグレー表示）。内容 ページにテスト要素を貼り付ける前に、アプリケーションのフォーカスを得るためにページ内で要素を明示的に選択する必要があります。
注: ページに、一度に表示した場合に応答に影響が出るほど多くの要素がある場合、要素は順に表示されます。ページの下部にあるナビゲーション ツールバーを使用して、要素全体をブラウズすることができます。

内容 ページでは、テスト要素に対して、以下のキーボード機能 (ショートカット) がサポートされます。

キー | アクション
Up | 選択項目を上に移動
Down | 選択項目を下に移動
Right | 選択を解除
Left | 選択を解除
F2 | 要素を編集
Ctrl+A | すべて選択
Ctrl+C | 要素をコピー
Ctrl+X | 要素を切り取り
Ctrl+V | 要素を貼り付け
Del | 要素を削除
Ctrl+Up | 要素を上に移動
Ctrl+Down | 要素を下に移動
クリック | 要素を選択して、現在の要素として設定
Ctrl+クリック | クリックした要素の選択状況の切り替え、または他の要素をクリックして選択項目への追加/削除
Shift+クリック | 現在の選択要素から新規選択要素までの範囲の選択
Shift+Up | 選択項目を上に拡張
Shift+Down | 選択項目を下に拡張
Pos1 | 1 番目の項目を選択
Shift+Pos1 | 1 番目の項目まで選択
End | 最後の項目を選択
Shift+End | 最後の項目まで選択
親トピック: テスト ツリーで作業する


[テスト] ツールバーの機能

テスト > 詳細ビュー

テスト ツールバーには、テストを管理するための重要なコマンドがあります。

注: テスト ツールバーのコマンドは、テスト ツリーのコンテキスト メニューからも利用できます。

テスト ツールバーには、以下のコマンドが含まれています。

コマンド | アイコン | 説明
ドキュメント ビュー | ドキュメント ビュー | ドキュメント ビュー が表示されます。すべてのテスト要素の選択したプロパティが単一のビューに表示されます。
詳細ビュー | テスト計画ビュー | 単一のテストのプロパティを詳しく表示できる、詳細ビュー を表示します。
グリッド ビュー | グリッド ビュー | グリッド ビュー が表示されます。グリッド内のすべてのテストが表示されます。
上へ | 上へ | 現在のカーソルのフォーカス場所に関係なく、ナビゲーション ツリーの階層を一階層上へ移動します。
テスト コンテナの新規作成 | テスト コンテナの新規作成 | 新しいテスト コンテナを作成できます。
子テスト フォルダの新規作成 | 子テスト フォルダの新規作成 | 選択したフォルダまたはコンテナのサブノードとして新しいテスト フォルダを作成できます。
子テストの新規作成 | 子テストの新規作成 | 選択したフォルダまたはコンテナのサブノードとして新しいテストを作成できます。
編集 | 編集 | 選択したテストの要素を編集します。
バージョンの作成 | バージョンの作成 | 選択した手動テストの新しいバージョンを作成します。
削除 | 削除 | 選択したテストの要素を削除します。
切り取り | 切り取り | テスト ツリーからテストの要素を切り取り、クリップボードに保存します。
コピー | コピー | テスト ツリーからクリップボードに、テストの要素をコピーします。
貼り付け | 貼り付け | クリップボードから テスト ツリーに、テストの要素を貼り付けます。
子として貼り付け | 子として貼り付け | テストの要素を、クリップボードから現在選択されているテストの要素に子要素として貼り付けます。
上へ移動 | 上へ移動 | テスト ツリー内で、テストの要素を上に移動します。
下へ移動 | 下へ移動 | テスト ツリー内で、テストの要素下に移動します。
検索 | 検索 | 設定可能なパラメータに基づいてアクティブ プロジェクトのすべてのテストの要素を検索します。
置換 | 置換 | 検出された値のインスタンスを新しい値で置き換えます。
フィルタの新規作成 | フィルタの新規作成 | テスト ツリーに対して、新しいカスタム フィルタを作成します。
フィルタ |  | テスト ツリーに使用できるフィルタを一覧表示します。
フィルタの編集 | フィルタの編集 | 現在選択されているカスタム フィルタを編集します。
フィルタの削除 |  | 現在選択されているカスタム フィルタを削除します。
フィルタのコピー | フィルタの削除 | 現在選択されているカスタム フィルタをコピーします。
変更点のみ表示 | 変更点のみ表示 | テストの最近の変更点を表示します。
承認 | 承認 | テストへの変更を承認します。
XLSX としてダウンロード | 承認 | この機能は、ドキュメント ビュー と グリッド ビュー で有効になります。ドキュメント ビュー では、現在表示されているすべての行が含まれる Excel シートが生成されます。グリッド ビュー では、表示されている行だけでなく、すべての行が含まれる Excel シートが生成されます。
親トピック: テスト ビュー


テスト ドキュメント ビュー

テスト > ドキュメント ビュー

ドキュメント ビュー には、選択したプロジェクトで扱われているすべてのテストの重要情報、ステータス、および前回の実行が一覧表示されます。

テスト コンテナ、テスト フォルダ、およびテストごとに、次の列が ドキュメント ビュー に表示されます。

項目 | 説明
前回の実行 | 選択されたテストまたはプロジェクトの前回の実行の日時。
ステータス 前回のテスト実行のステータス。実行が現在実行中の場合、ステータス 未実行 が表示されます。
  • 合格
  • 失敗
  • 未実行
  • N/A
テスト コンテナとテスト フォルダの場合、ステータス バーには、対応するステータスを持つテストの数が表示されます。
前回のビルド | 前回の実行が行われたビルド。
前回完了した実行 | 前回の手動テストの実行が完了した日時。自動テストの場合は、このステータスは 前回の実行 と同じです。
前回完了した実行のステータス | 前回の手動テストの実行が完了したステータス。自動テストの場合は、このステータスは ステータス と同じです。
前回完了した実行のビルド | 前回完了した手動テストの実行が行われたビルド。自動テストの場合は、このステータスは 前回のビルド と同じです。
テスト数 | テストの数。
予定時間 | 手動テストの合計 予定時間。
割り当て済み問題 | テストに割り当てられている問題の数。
変更日時 | 選択されたテスト要素が最後に変更された日時。
変更者 | 選択されたテスト要素を最後に変更したユーザー。
属性 | テストに割り当てられた属性がある場合、グリッドに表示するよう選択できます。属性とは、テストに適用できる自由に定義可能な特性です。フィルタやレポートに対して、属性を使用できます。
親トピック: テスト ビュー


[グリッド ビュー] でテストを使用する

テスト 領域の グリッド ビュー は、ドキュメント ビュー と 詳細ビュー を補完するもので、多数のテストのフィルタリング、ソート、およびグループ化を簡単に行えるようになっています。グリッド ビュー を使用すると、テスト間の一致点の識別や特定のテスト情報の検索が容易になります。また、Windows の標準キーボード ショートカットが使えるため、グリッド ビュー 内で複数のテストをたやすく選択したり操作することができます。グリッド ビュー から、テストの試験実行を行ったり、テストにアクセスすることができます。さらに、グリッド ビュー 内で、複数選択したテストから実行計画を作成することもできます。

グリッド ビュー には、多数のテストをより適切に管理するうえで役に立つ数々のビュー カスタマイズ機能が用意されています。列の表示や非表示、列幅の調整、ドラッグ アンド ドロップによる列の移動が行えます。多数のテストがある場合にパフォーマンスを向上させるため、ページ ビューは、それぞれ 50 件のテストを表示するビューに分割されます。最初のページ、最後のページ、次のページ、および 前のページ を使って、ページ間を移動することができます。または、ページ フィールドにページ番号を入力し、Enter を押して、特定のページにアクセスできます。ソート、グループ化、フィルタリングの各機能はコンテキスト メニュー コマンドを通じて利用でき、それぞれ、テストの体系的な整理、テストの分類、テスト間の一致点の特定に役立ちます。ビュー カスタマイズの設定はすべてプロジェクトと一緒に保存され、次回 グリッド ビュー を表示したときに利用できます。

  • グリッド ビュー からテストにアクセスする
    グリッド ビュー から直接 テスト ビューのテストにアクセスします。
  • グリッド ビュー で実行計画を作成する
    グリッド ビュー で実行計画を作成して、テストを実行計画に直接割り当てます。
  • 複数のテストのプロパティと属性の変更
    複数のテストのプロパティと属性値を変更する方法について説明します。
  • グリッド ビュー で列を表示する/非表示にする
    必要な情報を表示するために、グリッド ビュー で列の表示と非表示を切り替えます。
  • グリッド ビューでテストをグループ化する
    グリッド ビュー でテストをグループ化して、共通する値を持つテストの表示を見やすくします。
  • グリッド ビュー のテストのグループ化の解除
    グリッド ビュー のテストのグループ化を解除して、ソートされたテストを表示します。
  • グリッド ビュー でテストをソートする
    グリッド ビュー でテストをソートする方法について説明します。
  • グリッド ビュー で列の順序を変更する
    グリッド ビュー で列の順序を変更し、指定した順序で表示します。
  • グリッド ビュー で列のサイズを変更する
    列の幅を変更し、指定した幅で表示します。
  • グリッド ビュー でテストをフィルタする
    グリッド ビュー でテストをフィルタする方法について説明します。
  • グリッド ビュー のデフォルト設定を復元する
    プロジェクトの グリッド ビュー のデフォルト設定を復元する方法について説明します。
  • グリッド ビューで既存の問題をテストに割り当てる
    グリッド ビュー で 1 つまたは複数のテストに既存の問題を割り当てる方法を説明します。
親トピック: テスト ビュー


グリッド ビュー からテストにアクセスする

グリッド ビュー から直接、テスト ビュー内のテストにアクセスすることができます。

グリッド ビュー からテストの プロパティ ページにアクセスするには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. アクセスするテストの 名前 をクリックします。 または、テストの行を右クリックして、テストへ移動 を選択します。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビュー で実行計画を作成する

グリッド ビュー で実行計画を作成するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. グリッド ビュー の複数選択機能を使用して、実行計画に割り当てるテストを選択します。
  3. テストを右クリックして、実行計画の作成 を選択します。 実行計画の新規作成 ダイアログ ボックスが表示されます。
  4. 新たに作成する実行計画の仕様を入力します。
注: 選択されたテストはすべて同じコンテナ内になければなりません。 そうでない場合、実行計画は作成されず、エラー メッセージが表示されます。 テスト コンテナは 実行計画の新規作成 ダイアログ ボックスであらかじめ選択されており、変更できないようになっています。
親トピック: [グリッド ビュー] でテストを使用する
親トピック: 実行計画、フォルダ、構成スイートを管理する
関連タスク
実行計画を作成する


複数のテストのプロパティと属性の変更

複数のテストのプロパティまたは属性値を変更するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. プロパティまたは属性を編集するテストを選択します。Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。
  3. 右クリックして、一括編集 を選択します。 一括編集 ダイアログ ボックスが開きます。このダイアログで、選択したすべてのテストの選択したプロパティまたは属性の値を同じ値に設定できます。
    ヒント: 特定のプロパティまたは属性列のセルを右クリックすると、一括編集 ダイアログでこのプロパティまたは属性があらかじめ選択されます。
  4. カテゴリ リストから プロパティ または 属性 を選択します。
  5. 変更するプロパティまたは属性の 名前 を選択します。
  6. 選択したすべてのテストに適用するプロパティまたは属性の 値 を選択します。
  7. OK をクリックします。 選択したすべてのテストに選択したプロパティまたは属性値が適用されます。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビュー で列を表示する/非表示にする

グリッド ビュー で列を表示する/非表示にするには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. 列ヘッダーのコンテキスト メニューを開きます。
  3. カラム サブメニューを展開して、プロジェクトで使用可能な列をすべて表示します。
  4. グリッド ビュー に表示する列のすべてのチェック ボックスをオンにします。 列表示の設定は保存され、アクティブ プロジェクトを開くたびにその設定で表示されます。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビューでテストをグループ化する

単に列でソートするだけでなく、テストをいくつかのグループにまとめて見やすくすることができます。グループ化の基準になる列の値が共通するものが 1 つのグループになります。

グリッド ビュー でテストをグループ化するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. グループ化の基準になる列で、列ヘッダーのコンテキスト メニューを開き、このカラムでグルーピング を選択します。 選択した列の値が共通するテストが、グループにまとめられます。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビュー のテストのグループ化の解除

グリッド ビュー のテストのグループ化を解除するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. 任意の列ヘッダーのコンテキスト メニューを開きます。
  3. グルーピング チェック ボックスをオフにします。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビュー でテストをソートする

グリッド ビュー でテストをソートするには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. ソートするテストの列で、列ヘッダーのコンテキスト メニューを開きます。
  3. 昇順 を選択すると、テストは昇順でソートされ、降順 を選択すると、テストは降順でソートされます。 ソートの設定は保存され、アクティブ プロジェクトを開くたびにその設定で表示されます。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビュー で列の順序を変更する

グリッド ビュー で列の順序を変更するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. 移動する列の見出しを選択します。
  3. その列を希望する位置までドラッグして放します。 列順序の設定は保存され、アクティブ プロジェクトを開くたびにその設定で表示されます。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビュー で列のサイズを変更する

グリッド ビュー で列の幅を調整するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. 調整する列の見出しの仕切り線を選択します。
  3. 列の境界を希望する位置までドラッグして放します。 列幅の設定は保存され、アクティブ プロジェクトを開くたびにその設定で表示されます。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビュー でテストをフィルタする

列の値に基づいてテスト リストをフィルタすることができます。 次のフィルタを指定できます。
  • テキスト データ フィールドに適用されるフィルタ文字列。
  • 日付フィールドのカレンダー フィルタ（指定の値より前、指定の値より後、または 指定の値に等しい 演算子を使用）。
  • 数値フィールドの数値演算子 （>、<、または =）。
  • グリッド ビュー でテキスト値をフィルタする
    グリッド ビュー でテキスト値をフィルタして、フィルタ条件に一致するテストのみを表示します。
  • グリッド ビュー で日付値をフィルタする
    グリッド ビュー で日付値をフィルタして、フィルタ条件に一致するテストのみを表示します。
  • グリッド ビュー で数値をフィルタする
    グリッド ビュー で数値をフィルタして、フィルタ条件に一致するテストのみを表示します。
  • グリッド ビュー で論理値をフィルタする
    グリッド ビュー で論理値をフィルタして、フィルタ条件に一致するテストのみを表示します。
  • グリッド ビュー で定義済みリストを使って値をフィルタする
    グリッド ビュー で定義済みリストを使って値をフィルタし、フィルタ条件に一致するテストのみを表示します。
  • グリッド ビュー の特定のフィルタを削除する
    グリッド ビュー の列に適用されている特定のフィルタを削除して、除外されていたテストを表示します。
  • グリッド ビュー のすべてのフィルタを削除する
    グリッド ビュー の列に適用されているすべてのフィルタを削除して、すべてのテストを表示します。
親トピック: [グリッド ビュー] でテストを使用する
関連概念
フィルタ


グリッド ビュー でテキスト値をフィルタする

グリッド ビュー でテキスト値をフィルタするには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. フィルタリングの基準になるテキスト値の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ サブメニューを展開して、フィルタ フィールドを表示します。
  4. フィールドにテキスト文字列を入力します。
  5. Enter を押します。 フィルタ条件に一致するすべてのテスト (たとえば、テスト名の場合は、指定された文字列を含むすべてのテスト名) がフィルタ済みリストに動的に表示されます。
親トピック: グリッド ビュー でテストをフィルタする


グリッド ビュー で日付値をフィルタする

グリッド ビュー で日付値をフィルタするには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. フィルタリングの基準になる日付値の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ にカーソルを合わせると、指定の値より前、指定の値より後、指定の値に等しい の各サブメニューが表示されます。
  4. 指定の値より後 にカーソルを合わせ、それ以前の日付 (その日を含む) のすべてのテストを除外する場合の基準となる日付を定義します。指定の値より前 にカーソルを合わせ、それ以降の日付 (その日を含む) のすべてのテストを除外する場合の基準となる日付を定義できます。指定の値に等しい にカーソルを合わせ、指定した日付のものを除くすべてのテストを除外できます。 カレンダー ツールが表示されます。
  5. カレンダー ツールを使用して日付を選択します。または、今日 をクリックして今日の日付を指定します。
    ヒント: 日付に基づくフィルタリングの変更を有効にするには、カレンダー ツールで日付を明示的にクリックするか、Enter を押す必要があります。
    フィルタ条件に一致するすべてのテストがフィルタ済みリストに動的に表示されます。
親トピック: グリッド ビュー でテストをフィルタする


グリッド ビュー で数値をフィルタする

グリッド ビュー で数値をフィルタするには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. フィルタリングの基準になる数値の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ サブメニューを展開して、>、<、および = 演算子を表示します。
  4. > フィールドに数値を入力すると、その値以下のテストをすべて除外することを定義できます。< フィールドに数値を入力すると、その値以上のテストをすべて除外することを定義できます。= フィールドに数値を入力すると、指定した数値のテストを除くすべてのテストを除外できます。
    注: 数値は小数点以下 2 桁に丸められます。
  5. Enter を押します。 フィルタ条件に一致するすべてのテストがフィルタ済みリストに動的に表示されます。
親トピック: グリッド ビュー でテストをフィルタする


グリッド ビュー で論理値をフィルタする

グリッド ビュー で論理値をフィルタするには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. フィルタリングの基準になる論理値の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ サブメニューを展開して、選択可能な値を表示します。
  4. はい か いいえ のどちらかのオプション ボタンを選択します。 フィルタ条件に一致するすべてのテストがフィルタ済みリストに動的に表示されます。
親トピック: グリッド ビュー でテストをフィルタする


グリッド ビュー で定義済みリストを使って値をフィルタする

グリッド ビュー で定義済みリストを使って値をフィルタするには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. フィルタリングの基準になる定義済みのフィルタ値を持つ列 (ノード タイプ など) で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ サブメニューを展開して、選択可能な値を表示します。
  4. 対象となるフィルタ値のチェック ボックスをオンにします。 選択した条件を 1 つでも持つテストはすべて表示されます。
親トピック: グリッド ビュー でテストをフィルタする


グリッド ビュー の特定のフィルタを削除する

注: フィルタされている列は、タイトルが太字の斜体で表示されるので、タイトルで見分けることができます。列を非表示にすると、その列に適用されているフィルタはすべて削除されます。

特定の グリッド ビュー フィルタを削除するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. 削除するフィルタが適用されている列で、列ヘッダーのコンテキスト メニューを開きます。
  3. フィルタ チェック ボックスをオフにします。
親トピック: グリッド ビュー でテストをフィルタする


グリッド ビュー のすべてのフィルタを削除する

注: フィルタされている列は、タイトルが太字の斜体で表示されるので、タイトルで見分けることができます。列を非表示にすると、その列に適用されているフィルタはすべて削除されます。

すべての グリッド ビュー フィルタを削除するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. 任意の列ヘッダーのコンテキスト メニューを開き、フィルタのリセット を選択します。
親トピック: グリッド ビュー でテストをフィルタする


グリッド ビュー のデフォルト設定を復元する

グリッド ビュー のデフォルト設定を復元すると、現在のプロジェクトのすべてのユーザー定義設定がリセットされます。ユーザー定義設定は以下のとおりです。
  • 列の順序
  • 列の幅
  • 列の表示/非表示
  • 適用されるフィルタ
  • ソート
  • グループ化

グリッド ビュー のデフォルト設定を復元するには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. 任意の列ヘッダーのコンテキスト メニューを開き、表示のリセット を選択します。
親トピック: [グリッド ビュー] でテストを使用する


グリッド ビューで既存の問題をテストに割り当てる

既存の問題を 1 つまたは複数のテストに割り当てるには：
  1. メニューで テスト > グリッド ビュー をクリックします。
  2. テストを右クリックします。Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。
  3. 既存の問題の割り当て をクリックして プロファイル を選択してから、問題 ID フィールドに問題番号をカンマ区切りで入力します。
親トピック: [グリッド ビュー] でテストを使用する


実行計画

実行計画 領域を利用すると、開発とテストの期間中、絶えずテスト実行を管理することができます。この領域では、実行計画の構成、実行計画のスケジュール、実行計画へのテストの割り当て、実行計画の依存関係のセットアップ、および実行サーバーの配置の構成、キーワードによる動的なハードウェア プロビジョニングの構成などを行うことができます。 実行計画は、実行計画 ツリーという階層ツリー構造で表示、編成、および維持管理されます。各実行計画には、子テストをいくつでも関連付けることができます。実行計画 ツリーでは、任意の数の階層レベルで、実行計画をフォルダに体系的に整理することができます。

  • 手動実行計画
    手動実行計画と品質目標から実行計画を作成する方法について説明します。
  • 構成テスト
    Silk Central で構成のテストを実行する方法について説明します。
  • 実行計画、フォルダ、構成スイートを管理する
    Silk Central で実行計画を使用する方法について説明します。
  • 実行計画ビュー
    実行計画 領域で利用可能なビューについて説明します。
  • Silk Performer プロジェクトで作業する
    Silk Performer プロジェクトは、Silk Central のテストに統合し、Silk Central を通じて直接実行することができます。
  • Silk Test Classic のテスト
    Silk Test Classic でテストを実行する方法について説明します。
親トピック: Silk Central ヘルプ


手動実行計画

このページにアクセスするには、実行計画 > 手動実行計画 をクリックします。

手動テストを計画する際の一般的な課題は、テストが多すぎる一方で、リソースが不足していることです。 最も効果の高いテストを実行することが重要です。 手動実行計画 ページは 2 つのビューに分かれているため、分かりやすい操作が可能です。

テストの選択
手動テストを選択し、テスト サイクルにスケジューリングします。
テストの割り当て
手動テストの実行計画を詳細に立てます。 特定のテスト サイクルでどの手動テスト担当者がどのテストを実行するか決定します。

テストの選択 ビューにアクセスするには、実行計画 > 手動実行計画 をクリックします。

テストの割り当て ビューにアクセスするには、手動実行計画 ページの右上にある テストの割り当て をクリックします。 テストの選択ビューに戻るには、左上にあるテストの選択をクリックします。

  • ウォークスルー
    このウォークスルーでは、手動実行計画 の機能を例を使って示します。
  • テストの選択
    テストの選択 ビュー、テスト サイクルでの作業方法、フィルタをかける方法、手動テストを割り当てる方法について説明します。
  • テストの割り当て
    特定のテスト サイクルとテスト担当者に割り当てる手動テストの一覧を提供します。
  • 手動テスト
    Silk Central の手動テスト機能および 手動テスト ウィンドウで効果的に手動テストを実行する方法について説明します。
親トピック: 実行計画
関連資料
[テスト サイクルのプロパティ] ページ


ウォークスルー

このウォークスルーでは、手動実行計画 の機能を例を使って示します。例は以下の仮説を使用しています。

  • 要件は完全に文書化され、Risk プロパティによって分類されています。
  • 575 の手動テストが完全に文書化され、要件に割り当てられ、特定のテストの実行の必要性を定義する Importance 属性によって分類されています。
  • プロジェクト終了条件 とも呼ばれる品質目標は要件プロパティ Risk とテスト属性 Importance に基づいて定義されています。これらの品質目標は必要なテストのレベルです。
  • 計画するテストは品質目標を最もよく達成できるテストのみです。
  1. 概要 (ウォークスルー)
    [手動実行計画] ページの領域の概要を示します。
  2. テスト サイクルを作成する (ウォークスルー)
    開始日時、終了日時、および最大利用可能時間を定義し、テスト サイクルを作成する方法について説明します。
  3. 手動テスト担当者を追加する (ウォークスルー)
    手動テスト担当者をテスト サイクルに追加する方法と最大利用可能時間を定義する方法について説明します。
  4. テストを選択してスケジューリングする (ウォークスルー)
    テストをフィルタし、ソートし、グループ化する方法とそれらをテスト サイクルに割り当てる方法について説明します。
  5. 手動テスト担当者にテストを割り当てる (ウォークスルー)
    テスト サイクルのテストを手動テスト担当者に割り当てる方法について説明します。
親トピック: 手動実行計画


概要 (ウォークスルー)

手動実行計画 ページは 4 つの領域で構成され、2 つの画面に表示されます。最初の画面の テストの選択 画面では、テスト サイクルのテストを選択し、スケジュールすることができます。2 番目の画面の テストの割り当て 画面では、選択したテスト サイクルのテストを、実行するテスト担当者に割り当てることができます。

テストの選択 画面は以下の 3 つの領域に分かれています。

  • 左側の フィルタ条件 領域。フィルタ機能により、次の領域に表示するテストを絞り込むことができます。
  • 中央の 一致したテスト 領域。このリストには、使用可能なテストがすべて表示されます。フィルタを適用すると、フィルタ処理されたテストだけが表示されます。
  • 右側の テスト サイクル 領域。中央のリストからこの領域内の定義した期間を表すテスト サイクルにテストを割り当てることができます。

テストの割り当て 画面にアクセスするには、右上にある テストの割り当て >>> をクリックします。この画面は以下の 2 つの領域に分かれています。

  • 左側の テスト サイクル 領域。この領域は テストの選択 画面上の領域と同じです。つまり、両方の画面に表示されます。
  • 左側の 割り当て済みテスト 領域。このリストには、現在選択しているテスト サイクルに追加されたテストが表示されます。この領域のリストから テスト サイクル 領域にテストをドラッグし、テスト担当者にドロップすることができます。

親トピック: ウォークスルー
次のトピック: テスト サイクルを作成する (ウォークスルー)


テスト サイクルを作成する (ウォークスルー)

最初のステップでは、テスト サイクルを作成します。テスト サイクルとは、開始日時、終了日時、および手動テスト担当者のリストで構成される定義済みの期間です。テスト サイクルに 週21 という名前を付けます。
  1. メニューで、実行計画 > 手動実行計画 をクリックします。
  2. 右側の テスト サイクル 領域で、テスト サイクルの新規作成 をクリックします。 テスト サイクルの新規作成 ボックスが表示されます。
  3. テスト サイクルの名前を入力します。ここでは、週21 と入力しました。
  4. オプションで説明を入力します。
  5. 開始日 の横にある [image] をクリックし、テスト サイクルの開始日時を設定します。
  6. 終了日 の横にある [image] をクリックし、テスト サイクルの終了日時を設定します。
  7. hh:mm 形式で、このテスト サイクルに必要な時間 (最大利用可能時間) を入力します。ここでは、35:00 と入力しました。
  8. OK をクリックします。
テスト サイクル 領域にテスト サイクルが表示されます。現時点では、テスト担当者は割り当てられていません。次のステップでは、テスト担当者を割り当てます。

親トピック: ウォークスルー
前のトピック: 概要 (ウォークスルー)
次のトピック: 手動テスト担当者を追加する (ウォークスルー)


手動テスト担当者を追加する (ウォークスルー)

次のステップでは、手動テスト担当者をテスト サイクルに追加します。各手動テスト担当者がこのテスト サイクルで使用する最大利用可能時間も定義します。
  1. テスト サイクル 週21 のヘッダーで、... > 割り当て済みテスト担当者の編集 をクリックします。 割り当て済みテスト担当者の編集 ダイアログ ボックスが表示されます。
  2. テスト担当者の追加/削除 をクリックします。 テスト担当者の追加/削除 ダイアログ ボックスが表示されます。
  3. 選択可能 リストからユーザー グループを選択します。
  4. 選択可能 リストのユーザー グループから 1 つ以上のユーザーを選択します。
  5. 追加 または すべて追加 をクリックして、ユーザーを 選択済み リストに追加します。
  6. OK をクリックします。 ユーザーが 割り当て済みテスト担当者の編集 ダイアログ ボックスのリストに追加されました。
  7. 追加された各ユーザーに対して、テスト サイクルの最大利用可能時間を 最大利用可能時間 フィールドに hh:mm 形式で設定します。
  8. 閉じる をクリックします。
テスト サイクル全体および各手動テスト担当者の両方の利用可能なリソースがテスト サイクルに表示されます。未完了の割り当て済みテストがバーンダウン チャートに表示されます。テスト サイクルを作成し、手動テスト担当者を追加したら、実行するテストを次のステップで決定します。

親トピック: ウォークスルー
前のトピック: テスト サイクルを作成する (ウォークスルー)
次のトピック: テストを選択してスケジューリングする (ウォークスルー)


テストを選択してスケジューリングする (ウォークスルー)

このトピックでは、テストをテスト サイクルに割り当てる方法について説明します。目標は、定義された品質目標を最もよくカバーするテストを選択することです。品質目標は要件のリスクに基づく場合があります。一般的には、高リスクを持つ状態をまず最初にテストします。
  1. 左側の フィルタ条件 の 品質目標 で、Requirement Risk チェック ボックスをオンにします。 一致したテスト のリストを重要なテストに絞り込みます。
  2. 一致したテスト 領域で、列ヘッダーのコンテキスト メニューを開き、テストをソート、フィルタ、またはグループ化します。これにより、スケジュールが必要なテストを選択しやすくなります。
  3. 1 つまたは複数のテストを選択し、右側の テスト サイクル 領域にドラッグして、テスト サイクルにドロップします。 テスト サイクルにテストを追加すると、既に使用されているリソースのインジケータが更新されます。このインジケータの上にマウスを移動すると、総最大利用可能時間、予定時間、残り時間に関する詳細情報が表示されます。
  4. 最重要リスクを持つすべてのテストをスケジューリングしたら、高リスクを持つテストをスケジューリングします。その後、中リスクを持つテストをスケジューリングし、以下同様の手順を繰り返します。

テスト サイクルに割り当てられたテストが テスト担当者なし 行に移動しました。次のステップでは、手動テスト担当者を割り当てます。

親トピック: ウォークスルー
前のトピック: 手動テスト担当者を追加する (ウォークスルー)
次のトピック: 手動テスト担当者にテストを割り当てる (ウォークスルー)


手動テスト担当者にテストを割り当てる (ウォークスルー)

ここでテスト サイクルのテストを手動テスト担当者に割り当てます。
  1. 右上にある テストの割り当て >>> をクリックします。 テストの割り当て 画面が表示されます。
  2. 左側の テスト サイクル 領域で、テスト サイクルの テスト担当者なし 行をクリックします。 テスト担当者に割り当てられていないすべてのテストが、右側の 割り当て済みテスト 領域に表示されます。
  3. 1 つまたは複数のテストを選択し、左側の テスト サイクル 領域にドラッグして、手動テスト担当者にドロップします。 手動テスト担当者にテストを割り当てると、リソース インジケータが更新されます。このインジケータの上にマウスを移動すると、最大利用可能時間、予定時間、残り時間に関する詳細情報が表示されます。
  4. 手動テスト担当者へのテストの割り当てが完了したら、... > テスト サイクルの開始 をクリックしてテストを開始します。

テスト サイクルを開始すると、テストが割り当てられたことを示す電子メールが各手動テスト担当者に送信されます。テスト用受信トレイ (ユーザーに割り当てられた手動テスト) を個人のダッシュボードに追加することができます。ユーザーに割り当てられたすべてのテストがここに一覧表示されます。

親トピック: ウォークスルー
前のトピック: テストを選択してスケジューリングする (ウォークスルー)


テストの選択

テストの選択 ビューは、手動実行計画 ページにアクセスして始めに表示されるビューです。ここでは、フィルタと品質目標を使用した手動テストの一覧の絞り込み、テスト サイクルの作成と編集、フィルタ処理した手動テストのテスト サイクルへの割り当てを行えます。

テストの選択 ビューは以下の 3 つの領域に分かれています。
  • 左側の フィルタ条件 領域。フィルタ機能により、次の領域に表示するテストを絞り込むことができます。
  • 中央の 一致したテスト 領域。このリストには、使用可能なテストがすべて表示されます。フィルタを適用すると、フィルタ処理されたテストだけが表示されます。
  • 右側の テスト サイクル 領域。ここでは、中央のリストからテストをテスト サイクルに割り当てることができます。
  • フィルタ条件
    フィルタ条件 領域にフィルタと品質目標を適用する方法を説明します。
  • 一致したテスト
    一致したテスト 領域について説明します。
  • テスト サイクル
    テスト サイクルとは、開始日時、終了日時、および手動テスト担当者のリストで構成される定義済みの期間です。手動テストの特定のセットを計画し、実行するために、テスト サイクルを作成します。
親トピック: 手動実行計画


フィルタ条件

フィルタ条件 領域では、次のフィルタ オプションが提供されます。

フィルタの概要

そのページに適用されたすべてのフィルタを一覧表示します。

一覧からフィルタを削除するには、フィルタの横にある [image] をクリックします。

テスト フィルタ

現在のプロジェクトのすべてのテスト フィルタの一覧が含まれています。

テスト フィルタを選択します。フィルタ処理されたテストが 一致したテスト 領域に表示されます。

品質目標/割り当ての進捗状況

プロジェクトの品質目標の一覧と品質目標の値が表示されます。

1 つ以上の品質目標値を選択します。フィルタ処理されたテストが 一致したテスト 領域に表示されます。

各品質目標値が 割り当ての進捗状況 バーを備えています。このバーは、実行計画に割り当て済みのテスト数と、要割り当てテスト数を表示します。

重要: これらの数には、手動テストと自動テストの数が含まれています。

マウスをバーの上に移動すると、以下が表示されます。

  • 一致したテストの合計 の数。
  • 目標達成テスト の数。
  • 割り当て済みテスト の数。
  • 要割り当てテスト の数。

割り当て済みテスト の数が 目標達成テスト の数よりも多い場合、感嘆符が表示されます。これは、テストが必要数以上に割り当てられていることを意味します。

重要: これらの数には、手動テストと自動テストの数が含まれています。
コンテナ/フォルダ

コンテナ/フォルダ テスト階層を表示します。

コンテナまたはフォルダを選択すると、選択したノードの子のテストだけが 一致したテスト 領域に表示されます。

注: 品質目標ごとに 1 つのテスト フィルタと 1 つの目標値のみ選択することができます。

複数の品質目標値、つまり 1 つの品質目標値と 1 つのテスト フィルタを (異なる品質目標から) 選択する場合、すべての条件に一致するテストだけが 一致したテスト 領域に表示されます。

親トピック: テストの選択


一致したテスト

一致したテスト 領域は、選択したフィルタ条件に一致する手動テストを表示します。デフォルトでは品質目標やフィルタは選択されていませんので、すべての手動テストがグリッドに表示されます。

フィルタ条件 領域でフィルタと品質目標値を選択し、手動テストの一覧を絞り込みます。

一致したテスト グリッドのキャプションには以下が表示されます。

  • 現在選択しているテストの数。
  • 現在選択しているテストの合計予定時間。

このグリッドでは、以下のアクションを実行できます。

  • テスト サイクルに手動テストを割り当てるには、テストをテスト サイクルのヘッダーにドラッグします。
  • 手動テストを手動テスト担当者に割り当てるには、テストをテスト サイクルのテスト担当者にドラッグします。
  • 列ヘッダーのコンテキスト メニューを開くと、手動テストのソート、グループ化、フィルタ設定、列の追加と削除、フィルタまたは表示のリセットが行えます。
  • 手動テストを右クリックして、テストの詳細を表示したり、手動テストを印刷したりします。
  • Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。
  • 別のテスト サイクル/テスト担当者に複数のテストを割り当てることができます。テストが少なくとも 1 回割り当てられると、割り当て済み 列に緑色のチェック マークが付きます。
  • をクリックしてテストの詳細を表示します。
  • をクリックして テスト の 詳細ビュー でテストを表示します。
親トピック: テストの選択


テスト サイクル

テスト サイクルとは、開始日時、終了日時、および手動テスト担当者のリストで構成される定義済みの期間です。手動テストの特定のセットを計画し、実行するために、テスト サイクルを作成します。

現在のプロジェクトのすべてのテスト サイクルの一覧を提供する テスト サイクル 領域について説明します。これは 手動実行計画 ページの中核となる領域であり、テストの選択 ビューと テストの割り当て ビューの両方で表示されます。テスト サイクルは時間順に表示されます。

新しいテスト サイクルを作成するには、テスト サイクル 領域の上にある テスト サイクルの新規作成 をクリックします。テスト サイクルを非表示にしたい場合は、テスト サイクルの表示/非表示 をクリックします。さらに、検索 フィールドを使用すると、検索語を含んだテスト サイクルのみが表示されます。テスト サイクルを非表示にすると、テスト サイクル 領域を常に整理してパフォーマンスを向上できます。これは、テスト サイクルが多数ある場合に特に有効です。

テスト サイクルのヘッダーにある アクション (...) をクリックして、メニューにアクセスします。実行計画 ツリーのテスト サイクルに移動するには、 [image] をクリックします。

テスト サイクルで手動テスト担当者をクリックすると、 割り当てられているテストが 割り当て済みテスト 領域に表示されます。

テスト サイクルを選択するには、テスト サイクルのヘッダーをクリックします。テスト サイクル (特定の手動テスト担当者ではない) に割り当てられているテストが 割り当て済みテスト 領域に一覧表示されます。割り当て済みテスト 領域が表示されない場合は、右上の テストの割り当て をクリックします。

テスト サイクルのボックスには、次の項目が表示されます。

  • テスト サイクルの名前。
  • 開始日と終了日。
  • テストの進捗状況を視覚化するバーンダウン チャート。テスト サイクルの終了までに、すべてのテストが完了する可能性を示します。バーの上にマウスを移動すると、未完了テスト数が表示されます。
  • 最大利用可能時間の残り。この値は次のようにして計算されます。割り当て済みテストの予定時間の合計から、手動テスト担当者の最大利用可能時間の合計を引きます。この値は、テスト サイクルと個々のテスト担当者のどちらにも表示されます。テスト サイクルまたは手動テスト担当者にテストの負荷がかかりすぎると、緑色のボックスが赤に変ります。詳細情報を表示するには、このボックスの上にマウスを移動します。
  • テスト サイクルと個々のテスト担当者の両方の割り当て済みテストと完了したテストの数。詳細情報を表示するには、これらの数値の上にマウスを移動します。
  • 各テスト サイクルに割り当てられている手動テスト担当者。詳細情報を展開したり、折りたたんだりするには、割り当て済みテスト担当者の数をクリックします。
  • テスト サイクルを作成する
    手動実行計画 ページでテスト サイクルを作成する方法について説明します。
  • 手動テスト担当者をテスト サイクルに追加する
    手動テスト担当者をテスト サイクルに追加する方法と最大利用可能時間を設定する方法について説明します。
  • 割り当て済みテスト担当者を編集する
    手動テスト担当者をテスト サイクルとの間で追加/削除する方法と個々のテスト担当者の最大利用可能時間を定義する方法について説明します。
  • マイルストーンを追加する
    マイルストーンをテスト サイクルに追加する方法、テスト担当者の最大利用可能時間がテスト サイクルで均等に割り振られていない場合、どれが有用なのかを説明します。
  • テスト サイクルにテストを割り当てる
    手動実行計画 ページのテスト サイクルにテストを割り当てる方法について説明します。
  • 手動テスト担当者にテストを割り当てる
    テスト サイクルのテストを手動テスト担当者に割り当て、テスト担当者間のワークロードを配分する方法について説明します。
  • あるテスト サイクルから別のテスト サイクルにテストを移動する
    手動実行計画 ページのテスト サイクルで、あるテスト サイクルから別のテスト サイクルにテストを移動する方法について説明します。
  • あるテスト担当者から別のテスト担当者にテストを移動する
    テスト サイクル内でワークロードを配分するために、ある手動テスト担当者から最大利用可能時間に制限のない別のテスト担当者にテストを移動する方法について説明します。
  • テスト サイクルからテストを削除する
    手動実行計画 ページのテスト サイクルから割り当て済みテストを削除する方法について説明します。
  • 手動テスト担当者からテストを削除する
    手動実行計画 ページで手動テスト担当者から割り当て済みテストを削除する方法について説明します。
  • 実行計画からテストをインポートする
    手動テストを実行計画からテスト サイクルにインポートする方法について説明します。
  • テスト サイクルを同期する
    テスト サイクルの現在の実行を、割り当て済みテストに対して行った変更で更新したい場合に、テスト サイクルを同期します。
  • テスト サイクルを複製する
    テスト サイクルを複製する方法について説明します。
  • テスト サイクルを非表示にする
    テスト サイクルを非表示にして、手動実行計画 ページを常に整理してパフォーマンスを強化します。
  • テスト サイクルを開始する
    テスト サイクルを開始し、テスト サイクルに割り当てられているすべての手動テストを実行する方法について説明します。
  • テスト サイクルを完了する
    テスト サイクルを完了し、テスト サイクルに割り当てられているすべての手動テストを完了する方法について説明します。
  • テスト サイクルを削除する
    テスト サイクルを削除する方法について説明します。
親トピック: テストの選択
親トピック: テストの割り当て


テスト サイクルを作成する

注: 実行計画 の 詳細ビュー および ドキュメント ビュー で新しいテスト サイクルを作成することもできます。

テスト サイクルを作成するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクル 領域で、テスト サイクルの新規作成 をクリックします。 テスト サイクルの新規作成 ダイアログ ボックスが表示されます。
  3. テスト サイクルの 名前 を入力します。
  4. オプションで 説明 を入力します。
  5. 開始日 の横にある [image] をクリックし、テスト サイクルの開始日時を設定します。
  6. 終了日 の横にある [image] をクリックし、テスト サイクルの終了日時を設定します。
  7. hh:mm 形式で、このテスト サイクルに必要な時間 (最大利用可能時間) を入力します。

    この最大利用可能時間は、テスト担当者をテスト サイクルに追加するとすぐに、各テスト担当者の最大利用可能時間の合計に置換されます。

  8. OK をクリックします。 テスト サイクルが テスト サイクル 領域に追加されます。
親トピック: テスト サイクル


手動テスト担当者をテスト サイクルに追加する

テスト サイクルを作成すると、手動テスト担当者とその最大利用可能時間を追加できます。

手動テスト担当者は 実行計画 の 詳細ビュー でも追加できます。メニューで 実行計画 > 詳細ビュー をクリックします。左側のテスト サイクルをクリックし、プロパティ ページで テスト担当者の追加/削除 をクリックします。

手動テスト担当者をテスト サイクルに追加するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクル 領域のテスト サイクルのヘッダーで、 ... > 割り当て済みテスト担当者の編集 をクリックします。
    割り当て済みテスト担当者の編集 ダイアログ ボックスが表示されます。
  3. テスト担当者の追加/削除 をクリックします。 テスト担当者の追加/削除 ダイアログ ボックスが表示されます。
  4. 選択可能 リストから使用するユーザー グループを選択します。
  5. 選択可能 リストから 1 つ以上のユーザーを選択します。 Ctrl + クリック または Shift + クリック を使用して複数のユーザーを選択できます。
  6. 追加 または すべて追加 をクリックして、ユーザーを 選択済み リストに追加します。
  7. OK をクリックします。 テスト担当者リストにユーザーが追加されます。
  8. テスト サイクルの各ユーザーの最大利用可能時間を 最大利用可能時間 フィールドに hh:mm 形式で定義します。
  9. 閉じる をクリックします。 テスト サイクルの 最大利用可能時間 は、各手動テスト担当者の最大利用可能時間の累積値によって更新されます。
親トピック: テスト サイクル


割り当て済みテスト担当者を編集する

手動テスト担当者をテスト サイクルとの間で追加/削除することができ、個々のテスト担当者の最大利用可能時間を定義することができます。

割り当て済みテスト担当者を編集するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクルのヘッダーにある テスト サイクル 領域で、... > 割り当て済みテスト担当者の編集 をクリックします。 割り当て済みテスト担当者の編集 ダイアログ ボックスが表示されます。
  3. テスト担当者の追加/削除 をクリックします。 テスト担当者の追加/削除 ダイアログ ボックスが表示されます。
  4. 選択可能 リストから使用するユーザー グループを選択します。
  5. テスト担当者を追加/削除するには：
    • 選択可能 リストで 1 つ以上のユーザーを選択し、追加 または すべて追加 をクリックします。
    • 選択済み リストで 1 つ以上のユーザーを選択し、削除 または すべて削除 をクリックします。
    Ctrl + クリック または Shift + クリック を使用して複数のユーザーを選択できます。
  6. OK をクリックします。 ユーザーが 割り当て済みテスト担当者 リストに追加され、またはリストから削除されました。
  7. テスト サイクルの各ユーザーの最大利用可能時間を 最大利用可能時間 フィールドに hh:mm 形式で定義します。
  8. 閉じる をクリックします。 テスト サイクルの 最大利用可能時間 は、各手動テスト担当者の最大利用可能時間の累積値によって更新されます。
割り当て済みテスト担当者を 詳細ビュー で編集することもできます。メニューで 実行計画 > 詳細ビュー をクリックします。左側のテスト サイクルをクリックし、プロパティ ページで テスト担当者の追加/削除 をクリックします。
親トピック: テスト サイクル


マイルストーンを追加する

マイルストーンとは、指定した日付までに達成すべき目標です。マイルストーンは、テスト担当者の最大利用可能時間がテスト サイクルで均等に割り振られていない場合に有用です。これらのマイルストーンは、日付および最大利用可能時間に従って (ダッシュボードの) バーンアップ チャートにマークが表示されます。

テスト サイクルのコンテキスト内のマイルストーンの例を次に示します。

  • テストの最低 20 パーセントを 9 月 13 日までに完了する必要がある。
  • テストの最低 50 パーセントを 9 月 15 日までに完了する必要がある。
  • テストの 100 パーセントを 9 月 19 日までに完了する必要がある (テスト サイクルの終了)。

マイルストーンを追加するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクル 領域のテスト サイクルのヘッダーで、... > マイルストーンの編集 をクリックします。 マイルストーンの編集 ダイアログ ボックスが表示されます。
  3. マイルストーンの追加 をクリックし、期限と完了済みテストのパーセンテージを定義して OK をクリックします。
  4. マイルストーンを編集するには、 [image] をクリックします。マイルストーンを削除するには、 [image] をクリックします。
  5. さらにマイルストーンを追加してから、閉じる をクリックします。
注: テスト サイクルを複製した場合や、開始日と終了日を編集した場合は、マイルストーンがテスト サイクルの期間内に定義されていることを確認します。
親トピック: テスト サイクル


テスト サイクルにテストを割り当てる

テスト サイクルにテストを割り当てるには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. 一致したテスト 領域でテストを選択し、テスト サイクルのヘッダーにドラッグします。テスト担当者を右クリックして、選択したテストの <手動テスト担当者> への割り当て を選択して割り当てることもできます。 Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。 テスト サイクルにテストが追加されます。
注: テストは、異なるテスト サイクルやテスト担当者に何度も割り当てることができます。テストが少なくとも 1 回割り当てられると、一致したテスト 領域の 割り当て済み 列に緑色のチェック マークが付きます。
親トピック: テスト サイクル


手動テスト担当者にテストを割り当てる

注: テストを手動テスト担当者に割り当てる前に、手動テスト担当者をテスト サイクルに追加する必要があります。

テストを手動テスト担当者に割り当て、テスト担当者間のワークロードを配分します。

テストは、異なるテスト サイクルやテスト担当者に何度も割り当てることができます。テストが少なくとも 1 回割り当てられると、一致したテスト 領域の 割り当て済み 列に緑色のチェック マークが付きます。

テストの割り当て ビューでテストを手動テスト担当者に割り当てることもできます。右上にある テストの割り当て をクリックします。割り当て済みテスト 領域でテストを選択し、テスト サイクルの手動テスト担当者にドラッグします。

手動テスト担当者にテストを割り当てるには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクルで、<num> 人のテスト担当者が割り当てられています をクリックし、手動テスト担当者のリストを展開します。
  3. 一致したテスト 領域でテストを選択し、テスト サイクルの手動テスト担当者にドラッグします。テスト担当者を右クリックして、選択したテストの <手動テスト担当者> への割り当て を選択して割り当てることもできます。選択したテストを [image] アイコンにドロップすると、すべてのテスト担当者に割り当てられます。 Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。
親トピック: テスト サイクル


あるテスト サイクルから別のテスト サイクルにテストを移動する

あるテスト サイクルから別のテスト サイクルにテストを移動することができます。これは、すべてのテストを時間内に完了できなかったために、これらのテストを次のテスト サイクルに持ち越す場合に便利です。

あるテスト サイクルから別のテスト サイクルにテストを移動するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. 右上にある テストの割り当て をクリックします。 手動実行計画 ページが テストの割り当て ビューに切り替わります。
  3. 左側の テスト サイクル 領域で、テスト サイクルのヘッダーをクリックします。
  4. 割り当て済みテスト 領域でテストを選択し、他のテスト サイクルにドラッグします。テスト担当者を右クリックして、選択したテストの <手動テスト担当者> への割り当て を選択して割り当てることもできます。

    Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。

親トピック: テスト サイクル


あるテスト担当者から別のテスト担当者にテストを移動する

テスト サイクル内でワークロードを配分するために、ある手動テスト担当者から最大利用可能時間に制限のない別のテスト担当者にテストを移動することができます。

ある手動テスト担当者から別の手動テスト担当者にテストを移動するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. 右上にある テストの割り当て をクリックします。 手動実行計画 ページが テストの割り当て ビューに切り替わります。
  3. 左側の テスト サイクル 領域で、手動テスト担当者をクリックします。 手動テスト担当者に割り当てられているテストが 割り当て済みテスト 領域に一覧表示されます。
  4. 割り当て済みテスト 領域でテストを選択し、他の手動テスト担当者にドラッグします。テスト担当者を右クリックして、選択したテストの <手動テスト担当者> への割り当て を選択して割り当てることもできます。

    Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。

親トピック: テスト サイクル


テスト サイクルからテストを削除する

テスト サイクルからテストを削除するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. 右上にある テストの割り当て をクリックします。 手動実行計画 ページが テストの割り当て ビューに切り替わります。
  3. 左側の テスト サイクル 領域で、テスト サイクルのヘッダーをクリックします。 テスト サイクルに割り当てられているテストが 割り当て済みテスト 領域に一覧表示されます。
  4. をクリックして、テスト サイクルからテストを削除します。

    Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。

注: 完了したテスト サイクルからテストを削除することはできません。ドラッグすることで、別のテスト サイクルまたはテスト担当者に、完了したテスト サイクルからテストをコピーできます。
親トピック: テスト サイクル


手動テスト担当者からテストを削除する

手動テスト担当者からテストを削除するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. 右上にある テストの割り当て をクリックします。 手動実行計画 ページが テストの割り当て ビューに切り替わります。
  3. 左側の テスト サイクル 領域で、手動テスト担当者をクリックします。 手動テスト担当者に割り当てられているテストが 割り当て済みテスト 領域に一覧表示されます。
  4. テスト サイクルからテストを削除したり、テスト サイクルにテストを残したまま、手動テスト担当者からテストを削除したりできます。
    • 手動テスト担当者とテスト サイクルからテストを削除するには、 [image] をクリックします。
    • テスト サイクルにはテストを残したまま、手動テスト担当者からテストを削除するには：割り当て済みテスト 領域でテストをクリックし、テスト サイクル 領域の テスト担当者なし にドラッグします。

    Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。

注: 完了したテスト サイクルに割り当てられている手動テスト担当者からテストを削除することはできません。ドラッグすることで、別のテスト サイクルまたはテスト担当者に、完了したテスト サイクルからテストをコピーできます。
親トピック: テスト サイクル


実行計画からテストをインポートする

実行計画からテストをインポートするには、テスト サイクルと構成の管理 アクセス許可が必要です。
実行計画からテストをインポートするには：
  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクルのヘッダーにある テスト サイクル 領域で、... > 実行計画からテストをインポート をクリックします。 実行計画の選択 ダイアログ ボックスが表示されます。
  3. 実行計画を選択して OK をクリックします。 実行計画のすべてのテストが、テスト サイクルの テスト担当者なし に割り当てられます。
親トピック: テスト サイクル


テスト サイクルを同期する

テスト サイクルの現在の実行を、割り当て済みテストに対して行った変更で更新したい場合に、テスト サイクルを同期します。
テスト サイクルを同期するには、テスト サイクルと構成の管理 アクセス許可が必要です。
テスト サイクルを同期にするには：
  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクルのヘッダーにある テスト サイクル 領域で、... > テスト サイクルの同期 をクリックします。
  3. テスト サイクルの現在の実行を、割り当て済みテストに対して行った変更で更新するかどうかを確認するメッセージが表示されます。
親トピック: テスト サイクル


テスト サイクルを複製する

テスト サイクルを複製するには、テスト サイクルと構成の管理 アクセス許可が必要です。
テスト サイクルを複製するには：
  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクルのヘッダーにある テスト サイクル 領域で、... > テスト サイクルの複製 をクリックします。 テスト サイクルの複製 ダイアログ ボックスが開きます。プロパティ (名前、説明、開始日、終了日 および 最大利用可能時間) が複製され、フィールドに入力されます。
  3. 省略可能：テストの割り当てをコピーする方法を選択します。たとえば、合格したテスト をコピーしないように選択して、失敗したテスト と 未実行のテスト だけを持つテスト サイクルを再実行することができます。
  4. OK をクリックします。 すべての割り当てられたテストおよびテスト担当者を持つテスト サイクルが複製されます。
親トピック: テスト サイクル


テスト サイクルを非表示にする

手動実行計画 ページでテスト サイクルを非表示にし、ページを整理してパフォーマンスを強化できます。これは、テスト サイクルが多数ある場合に特に有効です。

テスト サイクルを非表示にするには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクル 領域で テスト サイクルの表示/非表示 をクリックします。さらに、検索 フィールドを使用すると、検索語を含んだテスト サイクルのみが表示されます。 テスト サイクルの表示設定 ダイアログ ボックスが表示されます。
  3. 非表示にするテスト サイクルをすべてオフにして OK をクリックします。すべての完了したテスト サイクルを非表示にするには、完了済みの選択解除 をクリックします。
    ヒント: 列ヘッダーのコンテキスト メニューを開き、テストをソート、フィルタ、またはグループ化します。複数のテスト サイクルを選択した状態で、スペース キーを押すと、一度に選択状態を切り替えることができます。
  4. 特定のテスト サイクルをすばやく非表示にするには、テストサイクルのヘッダーにある ... をクリックし、テスト サイクルの非表示 をクリックします。
  5. 非表示のテスト サイクルを表示するには、テスト サイクルの表示/非表示 を再度クリックし、テスト サイクルにマークを付けます。
手動実行計画 ページでテスト サイクルを非表示にする場合も、ダッシュボード パネルおよびレポートでだけでなく、詳細ビュー および ドキュメント ビュー の 実行計画 ツリーでも表示できます。表示設定はユーザーごとに行います。各ユーザーは、表示するテスト サイクルおよび非表示にするテスト サイクルを定義できます。
親トピック: テスト サイクル


テスト サイクルを開始する

注: テスト サイクルを開始する前に、テスト サイクルの開始日が現在の日付と一致していることを確認します。一致しない場合は、テスト サイクルを別の日に開始できることを確認してください。

テスト サイクルを開始するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクルのヘッダーにある テスト サイクル 領域で、... > テスト サイクルの開始 をクリックします。

    テスト サイクルを開始できるのは一度だけです。テスト サイクルが既に開始されている場合、このアクションは無効になります。実行中のテスト サイクルには、開始日と終了日の間に テストの進捗状況 が表示されます。まだ開始されていないテスト サイクルには、開始されていません と表示されます。完了したテスト サイクルには、完了しました と表示されます。

    テスト サイクルの開始 ダイアログ ボックスが開きます。
  3. テストする製品の バージョン と ビルド を選択します。割り当て済みテストのテスト コンテナで指定したすべての製品がリスト表示されます。
    注: テストを開始した後でバージョンとビルドを変更するには、... > バージョンとビルドの更新 をクリックします。
  4. OK をクリックします。

割り当てられた手動テストは、手動テスト担当者に配布されます。テスト担当者には電子メールで通知され、ダッシュボードの ユーザーに割り当てられた手動テスト パネルに通知されたテストが表示されます。

テスト サイクルが開始した後でも、実行中のテストの変更、製品のバージョンとビルドの変更、追加のテストの割り当て、テストの削除、テスト担当者間のテストの移動を行えます。

親トピック: テスト サイクル


テスト サイクルを完了する

注: テスト サイクルを完了する前に、テスト サイクルの終了日が現在の日付と一致していることを確認します。一致しない場合は、テスト サイクルを別の日に完了できることを確認してください。

テスト サイクルを完了するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクルのヘッダーにある テスト サイクル 領域で、... > テスト サイクルの完了 をクリックします。

    まだテスト サイクルが開始されていない場合、このアクションは無効になります。実行されていないテスト サイクルには、開始日と終了日の間に まだ開始していません と表示されます。実行中のテスト サイクルには、テストの進捗状況 が表示されます。完了したテスト サイクルには、完了しました と表示されます。

  3. テスト サイクルの完了 ダイアログ ボックスが開きます。未実行のテストを実行するアクションを選択し、完了 をクリックします。選択したステータスの変更は、ステータスの理由が設定されていない未実行テストにのみ適用されます。
注: 完了したテスト サイクルがロックされます。完了したテスト サイクルに対しては、テストまたはテスト担当者の追加、テストまたはテスト担当者の削除はできません。ドラッグすることで、別のテスト サイクルまたはテスト担当者に、完了したテスト サイクルからテストをコピーできます。
親トピック: テスト サイクル


テスト サイクルを削除する

注: 実行計画 の 詳細ビュー および ドキュメント ビュー でテスト サイクルを削除することもできます。テスト サイクルを右クリックし、削除 をクリックします。

テスト サイクルを削除するには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. テスト サイクル 領域のテスト サイクルのヘッダーで、... > テスト サイクルの削除 をクリックします。
  3. 削除確認 ダイアログ ボックスで、はい をクリックします。
親トピック: テスト サイクル


テストの割り当て

このページにアクセスするには、実行計画 > 手動実行計画 をクリックします。 右上にある テストの割り当て をクリックします。

テストの割り当て ビューは、手動実行計画 ページの 2 番目のビューです。 ここで、選択したテスト サイクルに割り当てられた手動テストを整理することができます。

  • テスト サイクル
    テスト サイクルとは、開始日時、終了日時、および手動テスト担当者のリストで構成される定義済みの期間です。手動テストの特定のセットを計画し、実行するために、テスト サイクルを作成します。
  • 割り当て済みテスト
    選択したテスト サイクルまたは手動テスト担当者に割り当てられた手動テストが表示されます。
  • 手動構成テスト
    割り当て済みテスト 領域の手動テストに構成を割り当てる方法について説明します。
親トピック: 手動実行計画


割り当て済みテスト

割り当て済みテスト 領域には、現在選択しているテスト サイクルまたは手動テスト担当者に割り当てられたテストが表示されます。テスト サイクルの複数のテスト担当者の割り当てられたテストを表示するには、Ctrl + クリック や Shift + クリック を使用してテスト サイクル内のテスト担当者を選択します。

割り当て済みテスト グリッドのキャプションには以下が表示されます。

  • 現在選択しているテスト サイクルの名前。
  • 現在選択しているテスト担当者の名前。

グリッドでは、以下のアクションを実行できます。

  • 手動テストを別のテスト サイクルに割り当てるには、テストをテスト サイクルのヘッダーにドラッグします。
  • 手動テストを (別の) 手動テスト担当者に割り当てるには、テストをテスト サイクルのテスト担当者にドラッグします。
  • 列ヘッダーのコンテキスト メニューを開くと、手動テストのソート、グループ化、フィルタ設定、列の追加と削除、フィルタまたは表示のリセットが行えます。
  • 手動テストを右クリックすると、テストの詳細の表示、テスト構成の指定、テスト サイクルからのテストの削除が行えます。
  • Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。
  • テスト サイクルから削除 をクリックして、テスト サイクルからテストを削除します。
  • テストの詳細の表示 をクリックして、テストの詳細を表示します。
  • 手動テスト結果の表示 をクリックして、手動テスト結果を表示します。
  • テストへ移動 をクリックして テスト の 詳細ビュー でテストを表示します。
  • テスト サイクルからではなく、手動テスト担当者からテストを削除するには、テスト サイクル内のテストを テスト担当者なし にドラッグします。
  • 実行順序を変更するには、順序 フィールドをクリックし、順番を示す番号を入力して Enter を押します。
    ヒント: 複数のテストコンテナまたは構成のテストを割り当てる場合、順序の番号は一意ではなくなります。この場合、テスト コンテナ または 構成 列でテストをグループ化できます。
注: フィルタ条件 領域にフィルタまたは品質目標値を適用すると、割り当て済みテスト グリッド内のフィルタに一致しないテストが無効になります。
親トピック: テストの割り当て


手動構成テスト

さまざまなソフトウェアおよびハードウェア構成で手動テストを実行することができます。

手動テストに構成を割り当てるには：

  1. メニューで、実行計画 > 手動実行計画 をクリックします。 手動実行計画 ページが表示されます。
  2. 右上にある テストの割り当て をクリックします。 手動実行計画 ページが テストの割り当て ビューに切り替わります。
  3. 割り当て済みテスト 領域でテストを右クリックします。

    Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。

  4. 構成の指定 をクリックします。 構成の指定 ダイアログ ボックスが表示されます。
  5. > または < をクリックして、選択した構成の割り当てまたは割り当ての解除を行います。構成の選択または入力 フィールドに新しい名前を入力して > をクリックすると、新しい構成を作成することができます。

    構成をより詳細に編集し、整理するには、実行計画 > 構成 を選択します。

    各構成に対して、テストのインスタンスが 割り当て済みテスト グリッドに追加されます。
    注: 構成の割り当てを解除すると、この構成は現在選択されているテスト担当者に対して無効になります。ただし、別のテスト担当者に割り当てられたインスタンスは削除されません。
  6. OK をクリックします。
新しいテストのインスタンスを、さまざまな手動テスト担当者およびテスト サイクルに割り当てることができます。
親トピック: テストの割り当て


手動テスト

Silk Central の手動テスト機能を使用すると、テスト担当者は効果的に手動テストを実行することができます。手動テスト ウィンドウには直感的で使いやすい UI が備わっており、実行プロセスで手動テスト担当者に関連する情報のみが表示されます。

手動テスト担当者はダッシュボードの ユーザーに割り当てられた手動テスト パネルから、すばやく 手動テスト ウィンドウにアクセスできます。ダッシュボードとパネルの詳細については、「ダッシュボード」を参照してください。手動テスト ウィンドウは、次のような構造になります。概要領域では、選択した実行計画またはテスト サイクルに含まれるテストが一覧されます。下のテスト ステップ領域には、選択したテストに設定されているステップのリストが表示されます。手動テスト担当者は、上から下にステップを処理していきます。

手動テスト担当者であれば、正常にテストおよびテスト ステップを実行した際にチェックしたり、結果テキストを記入したり、問題を作成および割り当てたり、結果ファイル添付したりできます。さらに、画面イメージをキャプチャしたり、ビデオを記録したりして、テストやテスト ステップの実行方法を図示したり、テスト プロセス中に発生した問題を表示したりできます。

統合されたタイマによりテストの実行に要した時間がわかり、バーにはテスト進捗が表示されます。テストブック (ダッシュボードに追加可能なパネル) には、プロジェクト内の手動テスト実行中に行われたすべてのアクティビティに関するリアルタイムの更新が表示されます。

  • [手動テスト] ウィンドウ
    手動テスト ウィンドウの基本的な構造と領域について説明します。
  • 画面イメージをキャプチャする
    画面イメージのキャプチャ方法およびキーボード コマンドを使用した スクリーン キャプチャ ウィンドウの使用方法について説明します。
  • ビデオを録画する
    手動テスト ウィンドウでビデオを録画する方法について説明します。
  • 結果ファイルを添付する
    結果ファイルの添付方法を説明します。
  • 問題を割り当てる、または作成する
    新しい問題の作成方法および既存の問題を割り当てる方法について説明します。
  • 手動テストのモバイル デバイスを選択する
    手動テストを実行するためのモバイル デバイス（物理デバイス、エミュレータ、シミュレータ）を選択します。
  • コード分析を開始する
    手動テスト ウィンドウでコード分析を開始する方法について説明します。
  • バージョンおよびビルドを編集する
    手動テスト ウィンドウでバージョンおよびビルドを編集する方法について説明します。
  • テストおよびテスト ステップのステータス
    ステップのステータスによってテスト ステータスを Silk Central がどのように自動的に計算するのか、また、ユーザーがテスト ステータスをどのように手動で設定できるのかを説明します。
  • 手動テストの印刷
    手動テストを印刷する、または PDF としてダウンロードする方法について説明します。印刷されたフォームを使用すると、テスト結果を手書きで記入できます。
  • テストブック
    テストブック の目的および機能について説明します。
  • オフライン手動テスト
    手動テストのアップロードとダウンロードの方法、およびオフラインでの作業について説明します。
親トピック: 手動実行計画
関連概念
ダッシュボード


[手動テスト] ウィンドウ

手動テスト ウィンドウを開くには、メニューで ホーム > マイ ダッシュボード をクリックし、ユーザーに割り当てられた手動テスト パネルで [image] (手動テストの続行) をクリックします。 ダッシュボードにこのパネルが表示されていない場合は、追加する必要があります。 ダッシュボードとパネルの詳細については、「ダッシュボード」を参照してください。

また、現在の実行 グリッドにある アクティビティ ページ (メニューで 追跡 > アクティビティ をクリック)、または 現在の実行 ページの 手動テスト ウィンドウ。

手動テスト ウィンドウには次の 2 つの領域が表示されます。
  • 上部に概要領域。
  • 下部にテスト ステップ領域。
  • 概要領域
    概要領域の構造と UI コントロールについて説明します。
  • テスト ステップ領域
    テスト ステップ領域の構造と UI コントロールについて説明します。
  • モバイル デバイス ユーザー インターフェイス
    手動テストの実行時にモバイル デバイスを選択すると、モバイル デバイス ユーザー インターフェイスが表示されます。
親トピック: 手動テスト
関連概念
ダッシュボード


概要領域

概要領域は、手動テスト ウィンドウ上部にある領域です。

概要領域には次の項目が表示されます。

項目 | ボタン | 説明
実行計画またはテスト サイクル | テストを含む実行計画またはテスト サイクルの名前。
設定の編集 ボタンをクリックし、次の設定を編集します。
  • テスト/ステップのステータスが変更されたとき、次のテスト/ステップが自動的に選択されるかどうかを設定できます。
  • 概要領域に表示する追加のテスト情報を設定できます。
  • 特定のアクション (バージョンおよびビルドの編集 アクションなど) を表示または非表示にできます。
  • ビデオをオーディオ付きで記録するかどうかを定義できます。
これらの設定は、ユーザーごとに個別に定義できます。
完了 | 完了 をクリックして、実行を完了します。未割り当てテスト、または実行計画に割り当てられているテストを開いた場合にのみ、このオプションが表示されます。テスト サイクルに割り当てられているテストを開いた場合は表示されません。 未実行のテストを実行するアクションを選択し、完了 をクリックします。選択したステータスの変更は、ステータスの理由が設定されていない未実行テストにのみ適用されます。
合格 | このボタンをクリックすると、現在選択しているテストに 合格 のマークを付けます。これはボタンのデフォルト設定です。
失敗 | このボタンをクリックすると、現在選択しているテストに 失敗 のマークを付けます。
テスト名 | 表示されるリストには、実行計画またはテスト サイクルのすべてのテストとその現在のステータスが表示されます。テストをクリックするか、または Up および Down キーを押して、テストおよびステップ全体を移動できます。特定の構成でテストの実行を指定した場合、構成名がテスト名の横に括弧付きで表示されます。詳細については、「手動構成テスト」を参照してください。 をクリックし、テスト 領域の 詳細ビュー にテストを表示します。
割り当てられた要件 | このボタンをクリックすると、テストに割り当てられた要件が表示されます。少なくとも 1 つの要件が割り当てられた場合にのみボタンが表示されます。ボタンの横の数字は割り当てられた要件の数を表します。
割り当てられた問題 | このボタンをクリックすると、テストに割り当てられた問題が表示されます。少なくとも 1 つの問題が割り当てられた場合にのみボタンが表示されます。ボタンの横の数字は割り当てられた問題の数を表します。問題 ダイアログ ボックスには、テストに割り当てられている問題と、テスト ステップに割り当てられている問題の両方が表示されます。
割り当てられた添付情報 | このボタンをクリックすると、テストに割り当てられた添付情報が表示されます。少なくとも 1 つの添付情報が割り当てられた場合にのみボタンが表示されます。ボタンの横の数字は割り当てられた添付情報の数を表します。
ブロック/ブロック解除 | このボタンをクリックすると、テストをブロック済み/ブロック解除状態に設定できます。IT インフラの問題などのある種の制約によって、テストを続行できないことを示すために、テストをブロック済みに設定すると便利です。
テスト ステータス | テストのステータス。自動にも手動にも設定できます。ステータス アイコンの横にある [image] をクリックして、ステータスを選択します。詳細については、「テストおよびテスト ステップのステータス」を参照してください。
バージョンおよびビルドの編集

このボタンをクリックするとバージョンとビルドを編集できます。詳細については、「バージョンおよびビルドの編集」を参照してください。
実行コメント | テスト実行に対して最上位のコメントを入力します。このコメントはテスト実行グリッドに表示されるので、テスト実行のレビュー プロセスの効率化に役立ちます。
スクリーン キャプチャ | このボタンをクリックすると、ユーザーの画像イメージをキャプチャし、テストに添付します。キャプチャされたイメージは添付情報 リストに追加されます。詳細については、「画面イメージをキャプチャする」を参照してください。
ビデオの録画 | このボタンをクリックすると、画面上のアクションのビデオを録画し、テストに添付します。ビデオは添付情報リストに追加され、ローカルのファイル システムに保存することができます。詳細については、「ビデオを録画する」を参照してください。
結果ファイルの添付 | このボタンをクリックすると、結果ファイルをテストに添付できます。詳細については、「結果ファイルを添付する」を参照してください。
問題の割り当て/作成 | このボタンをクリックすると、新しい問題を作成し、テストに添付したり、既存の問題を割り当てたりすることができます。詳細については、「問題を割り当てる、または作成する」を参照してください。
デバイスの選択 | 手動テストを実行するためのモバイル デバイス（物理デバイス、エミュレータ、シミュレータ）を選択します。詳細については、「モバイル デバイスを選択する」を参照してください。
コード分析の開始 | ボタンをクリックすると、分析プロセスを開始します。コード分析の開始 ダイアログ ボックスが表示されます。プロファイル を選択し、1 つ以上の ホスト名 を入力します。このテストにカバレッジ情報が既に存在する場合、チェックボックスをオンにすると置き換えることができます。コード分析の開始 をクリックすると、実際にプロセスが開始されます。コード分析の停止 をクリックすると、Silk Central ではコード分析情報がテスト実行に保存されます。
テスト実行の同期 | このボタンをクリックすると、テスト実行を適合したテストと同期します。テストの実行を開始し、その間に テスト ユニットでこのテストに変更を加えようとする場合、テストの実行を適合したテストと同期することができます。
注: ダイアログ ボックスを閉じる場合は、外部の任意の場所をクリックするか、 [image] (閉じる) をクリックします。
親トピック: [手動テスト] ウィンドウ
関連タスク
手動構成テスト
バージョンおよびビルドを編集する
画面イメージをキャプチャする
ビデオを録画する
結果ファイルを添付する
問題を割り当てる、または作成する
関連資料
テストおよびテスト ステップのステータス


テスト ステップ領域

テスト ステップ領域は、手動テスト ウィンドウの概要領域の下にあります。

テスト ステップ領域には次の項目が表示されます。

項目 | ボタン | 説明
使用時間の編集 |  | このボタンをクリックすると、テストの実行にかかった時間を手動で入力できます。手動テスト ウィンドウを開いた場合、または別のテストを選択した場合、タイマが自動的に開始されます。点滅するコロンは、タイマが実行中であることを示します。 をクリックするとタイマが一時停止し、 [image] をクリックするとタイマが開始されます。左側の数字は実際に使用した時間を、右側の数字は予定された時間を表します。
進捗バー |  | テストの進行状況を視覚化します。進捗バーには、実行済みのステップ数が表示されます。
テストブックへのメッセージの投稿 |  | このボタンをクリックすると、テストブック にメッセージを投稿できます。
合格 |  | このボタンをクリックすると、現在選択しているテスト ステップに 合格 のマークを付け、自動的に次のステップを選択します。これはボタンのデフォルト設定です。
失敗 |  | このボタンをクリックすると、現在選択しているテスト ステップに 失敗 のマークを付け、自動的に次のステップを選択します。これはボタンのデフォルト設定です。
詳細の表示/非表示 |  | このボタンをクリックすると、テスト ステップを展開し、アクションの説明 や 期待される結果 といった詳細情報と、すべてのボタンや結果フィールドを表示します。
ステップ名 |  | テスト ステップの名前です。未実行 ステータスのステップ名は太字で表示されます。
割り当てられた問題 |  | このボタンをクリックすると、テスト ステップに割り当てられている問題が表示されます。少なくとも 1 つの問題が割り当てられた場合にのみボタンが表示されます。ボタンの横の数字は割り当てられている問題の数を表します。
割り当てられた添付情報 |  | このボタンをクリックすると、テスト ステップに割り当てられている添付情報が表示されます。少なくとも 1 つの添付情報が割り当てられた場合にのみボタンが表示されます。ボタンの横の数字は割り当てられている添付情報の数を表します。
ステップ ステータス |  | ステップのステータス。ステータス アイコンの横にある [image] をクリックして、ステータスを選択します。Silk Central は自動的にステップ ステータスに基づいてテスト ステータスを計算します。詳細については、「テストおよびテスト ステップのステータス」を参照してください。
[結果] フィールド |  | このフィールドに結果テキストを入力します。外部の任意の場所をクリックすると、テキストが保存されます。
スクリーン キャプチャ |  | このボタンをクリックすると、ユーザーの画像イメージをキャプチャし、テスト ステップに添付します。キャプチャされたイメージは添付情報 リストに追加されます。詳細については、「画面イメージをキャプチャする」を参照してください。
ビデオの録画 |  | このボタンをクリックすると、画面上のアクションのビデオを録画し、テスト ステップに添付します。ビデオは添付情報リストに追加され、ローカルのファイル システムに保存することができます。詳細については、「ビデオを録画する」を参照してください。
結果ファイルの添付 |  | このボタンをクリックすると、結果ファイルをテスト ステップに添付できます。詳細については、「結果ファイルを添付する」を参照してください。
問題の割り当て/作成 |  | このボタンをクリックすると、新しい問題を作成し、テスト ステップに添付したり、既存の問題を割り当てたりすることができます。詳細については、「問題を割り当てる、または作成する」を参照してください。
注: ダイアログ ボックスを閉じる場合は、外部の任意の場所をクリックするか、 [image] (閉じる) をクリックします。
ヒント: テストを操作する際に、キーボードを使用できます。選択したテスト ステップのステータスを変更する場合は、ショートカット Ctrl + Shift + A (合格) と Ctrl + Shift + S (失敗) を使用します。これらの組み合わせは、片手で簡単に押すことができます。Up および Down キーを使うとステップを移動できますし、Right を押すとステップを展開し、Left の場合は折りたたむことができます。ダイアログ ボックスを閉じる場合は、Esc を押します。
親トピック: [手動テスト] ウィンドウ
関連タスク
画面イメージをキャプチャする
ビデオを録画する
結果ファイルを添付する
問題を割り当てる、または作成する
関連資料
テストおよびテスト ステップのステータス


モバイル デバイス ユーザー インターフェイス

手動テストの実行時にモバイル デバイスを選択すると、モバイル デバイス ユーザー インターフェイスが表示されます。

マウスを使用して、デバイスをエミュレートしたディスプレイに対して操作できます。ディスプレイの右側にあるアイコンを使用して、デバイスを回転したり、ピンチインやピンチアウトなどの操作をシミュレートできます。

テキスト アイコンを使用すると、現在フォーカスを持つフィールドにテキストを入力できます。テキスト アイコンを使用すると、IME を使用してマルチバイト文字を入力することもできます。

iOS の制限事項：
  • ユーザー セッションごとに 1 つのシミュレータのみ実行することができますが、複数の物理デバイスでは同時にテストを実行できます。
  • ホーム ボタンは、Sauce Labs デバイス上でのテストではサポートされません。
  • デバイスが利用できなった場合、デバイス ストリームを閉じて再起動してから、テストを続行してください。
親トピック: [手動テスト] ウィンドウ
関連タスク
手動テストのモバイル デバイスを選択する


画面イメージをキャプチャする

手動テスト ウィンドウでテストを実行する場合、画面のイメージをキャプチャすることができます。キャプチャされたイメージは、テストまたはテスト ステップに添付されます。これは、テスト ステップが失敗し、問題が発生した時間、場所、内容を説明する際に特に便利です。

Java Runtime Environment (JRE) がインストールされており、アプリケーションに実行が許可されていることを確認します。JRE は、Java SE Downloads からダウンロードできます。 ブラウザが NPAPI をサポートしていない場合は、この機能を有効化するために必要な JNLP ファイルを、Silk Central は自動的にダウンロードします（これをバックグラウンドで実行してください）。

画面イメージをキャプチャするには：

  1. 手動テスト ウィンドウが開きます。詳細については、「手動構成テスト ウィンドウ」を参照してください。
  2. 左側の [image] (詳細の表示) をクリックして、テスト ステップを展開します。
  3. (スクリーン キャプチャ) をクリックします。ブラウザが NPAPI をサポートしていない場合は、この機能を有効化するために必要な JNLP ファイルを、Silk Central は自動的にダウンロードします（これをバックグラウンドで実行してください）。 JNLP アプリケーションが起動したら、 [image] を再びクリックします。 スクリーン キャプチャ 機能を開始します。
  4. 次のアクションのいずれかを実行します。
    • マウスを使って四角形を描画し、キャプチャする領域を選択します。
    • Enter を押すと、画面全体をキャプチャします。モニタが複数ある場合は、すべてのモニタの画面がキャプチャされます。
    • Esc を押すとキャンセルします。
    スクリーン キャプチャ ウィンドウが表示されます。
  5. 希望通りにスクリーン キャプチャを編集します。テキストや、矢印および四角形といったグラフィカル アイテムを追加できます。エディタでキーボードを使用し、次のアクションを実行します。
    • 矢印キーを押すとオブジェクト (四角形、矢印など) を移動できます。Shift を押したまま矢印キーを押すと、位置を正確に調整できます。
    • 移動 ツールでオブジェクトを選択し、Backspace または Delete を押すとオブジェクトを削除できます。
    • テキスト ツールを使用する場合は、Shift + Enter を押すと入力が確定され、Esc を押すとキャンセルされます。
    • Ctrl + C を押すと、スクリーン キャプチャがクリップボードにコピーされます。
  6. アップロード をクリックします。 スクリーン キャプチャがテスト ステップに添付されます。
  7. 添付されたスクリーン キャプチャを表示するには、 [image] をクリックします。 添付情報 ダイアログ ボックスに、添付されたファイルのリストが表示されます。
  8. (結果ファイルの削除) をクリックすると添付されたファイルを削除でき、 [image] (開く) をクリックするとファイルを開くこともできます。
    注: このダイアログ ボックスでは、現在のテストの実行中に添付されたファイルのみを削除できます。テスト サイクル/実行計画が開始される前にテストに割り当てられたファイルは削除できません。
注: このトピックで説明しているタスクは、テスト レベルでもステップ レベルでも実行できます。
親トピック: 手動テスト
関連概念
[手動テスト] ウィンドウ


ビデオを録画する

手動テスト ウィンドウでテストを実行する際には、テスト プロセスをビデオに録画することができます。これは、テスト ステップが失敗し、問題が発生した時間、場所、内容を説明する際に特に便利です。

ビデオは録画を開始したテスト ステップに添付されます。例：録画をステップ 2 から始め、録画を続けたままステップ 3 および 4 と実行した場合、ビデオはステップ 2 に添付されることになります。

Java Runtime Environment (JRE) がインストールされており、アプリケーションに実行が許可されていることを確認します。JRE は、Java SE Downloads からダウンロードできます。 ブラウザが NPAPI をサポートしていない場合は、この機能を有効化するために必要な JNLP ファイルを、Silk Central は自動的にダウンロードします（これをバックグラウンドで実行してください）。

制限事項：
  • ビデオ録画は Microsoft Windows クライアント マシンでのみサポートされます。
  • Microsoft Windows 10 N および KN エディションでのビデオ キャプチャはサポートされません。
  • WPF ウィンドウのビデオ録画は Windows 7 のクラシック テーマではサポートされません。
  • 4K 解像度でのビデオ録画はサポートされません。

ビデオを録画するには：

  1. 手動テスト ウィンドウが開きます。詳細については、「手動構成テスト ウィンドウ」を参照してください。
  2. 左側の [image] (詳細の表示) をクリックして、テスト ステップを展開します。
  3. (ビデオの録画) をクリックします。ブラウザが NPAPI をサポートしていない場合は、この機能を有効化するために必要な JNLP ファイルを、Silk Central は自動的にダウンロードします（これをバックグラウンドで実行してください）。 JNLP アプリケーションが起動したら、 [image] を再びクリックします。 適切なオーディオ デバイスが検出された場合、ビデオをオーディオ付きで記録することができます。複数のデバイスが接続されている場合には、最初に検出されたデバイスが使用されます。 をクリックしてオーディオ設定を有効化します。この設定はデフォルトではオフになっています。この設定を変更した場合には、ビデオの録画を再開する必要があります。 ビデオの録画 ウィンドウが表示され、録画が自動的に開始されます。
  4. 録画が完了したら、ビデオ録画の停止 をクリックします。
  5. 結果ファイル名 を入力し、ファイルのアップロード をクリックしてビデオをテスト ステップに添付します。また、ファイルの保存 をクリックすれば、ローカル コンピュータにビデオを保存できます。
  6. 閉じる をクリックします。
  7. 添付されたビデオを表示するには、 [image] をクリックします。 添付情報 ダイアログ ボックスに、添付されたファイルのリストが表示されます。
  8. (結果ファイルの削除) をクリックすると添付されたファイルを削除でき、 [image] (開く) をクリックするとファイルを開くこともできます。
    注: このダイアログ ボックスでは、現在のテストの実行中に添付されたファイルのみを削除できます。テスト サイクル/実行計画が開始される前にテストに割り当てられたファイルは削除できません。
注: このトピックで説明しているタスクは、テスト レベルでもステップ レベルでも実行できます。
親トピック: 手動テスト
関連概念
概要領域
テスト ステップ領域
[手動テスト] ウィンドウ
関連資料
テストおよびテスト ステップのステータス


結果ファイルを添付する

手動テスト ウィンドウでテストを実行する場合、各ステップに結果ファイルを添付することができます。

結果ファイルを添付するには：

  1. 手動テスト ウィンドウが開きます。詳細については、「手動構成テスト ウィンドウ」を参照してください。
  2. 左側の [image] (詳細の表示) をクリックして、テスト ステップを展開します。
  3. (結果ファイルの添付) をクリックします。 システム ファイル マネージャが開きます。
  4. 添付するファイルを参照して確定します。 ファイルがテスト ステップに添付されます。
  5. 添付されたファイルを表示するには、 [image] をクリックします。 添付情報 ダイアログ ボックスに、添付されたファイルのリストが表示されます。
  6. (結果ファイルの削除) をクリックすると添付されたファイルを削除でき、 [image] (開く) をクリックするとファイルを開くこともできます。
    注: このダイアログ ボックスでは、現在のテストの実行中に添付されたファイルのみを削除できます。テスト サイクル/実行計画が開始される前にテストに割り当てられたファイルは削除できません。
注: テスト担当者がアップロードできる結果ファイルのサイズを制限できます。 詳細については、「ステップ結果ファイルの最大サイズを設定する」を参照してください。
注: このトピックで説明しているタスクは、テスト レベルでもステップ レベルでも実行できます。
親トピック: 手動テスト
関連概念
[手動テスト] ウィンドウ
関連タスク
ステップの結果ファイルの最大サイズを設定する


問題を割り当てる、または作成する

手動テスト ウィンドウでテストを実行する場合、各テスト ステップに問題を割り当てることができます。

問題を割り当てるには：

  1. 手動テスト ウィンドウが開きます。詳細については、「手動構成テスト ウィンドウ」を参照してください。
  2. 左側の [image] (詳細の表示) をクリックして、テスト ステップを展開します。
  3. (問題の割り当て/作成) をクリックします。 問題の割り当て/作成 ダイアログ ボックスが開きます。
  4. 既存の問題を割り当てる場合は、既存の問題の割り当て をクリックし、問題 ID フィールドにカンマ区切りで問題番号を入力します。
  5. 新しい問題を作成する場合は、問題の新規作成 をクリックします。 問題に関する情報をフィールドに入力し、リストから値を選択します。
  6. OK をクリックします。 問題がテスト ステップに割り当てられます。
  7. 割り当たられた問題を表示する場合は、 [image] をクリックします。 割り当てられたすべての問題のリストが表示された 問題 ダイアログ ボックスが開きます。
  8. (問題を開く) をクリックすると、外部の問題追跡ツールまたは Issue Manager に移動します。問題を削除するには、 [image] (問題の削除) をクリックします。
    注: このダイアログ ボックスでは、現在のテストの実行中に割り当てた問題のみを削除できます。テスト サイクル/実行計画が開始される前にテストに割り当てられたファイルは問題できません。
注: 問題を新規作成するとき、Silk Central では、そのステップまたはテストに現在割り当てられているすべての結果ファイルへのリンクが自動的に作成されます。これらのリンクは、問題追跡ツールの問題の説明に表示されます。これを利用すれば、問題追跡ツールから結果ファイルを直接ダウンロードできます。
注: このトピックで説明しているタスクは、テスト レベルでもステップ レベルでも実行できます。
親トピック: 手動テスト
関連概念
概要領域
テスト ステップ領域
[手動テスト] ウィンドウ
関連資料
テストおよびテスト ステップのステータス


手動テストのモバイル デバイスを選択する

手動テストを実行するためのモバイル デバイス（物理デバイス、エミュレータ、シミュレータ）を選択するまえに、デバイス プロバイダを設定する必要があります。デバイス プロバイダと現在のプロジェクトは、同じロケーションに割り当てられている必要があります。割り当てられていない場合は、デバイスは表示されません。詳細については、「デバイス プロバイダを管理する」を参照してください。
ヒント: 指定した URL を選択したデバイスのブラウザで開きたい場合は、silkTest.url という名前のパラメータを定義して、値 フィールドに URL を入力します。
モバイル デバイスを選択するには：
  1. 手動テスト ウィンドウが開きます。詳細については、「手動構成テスト ウィンドウ」を参照してください。
  2. (デバイスの選択) をクリックします。 デバイスの選択 ダイアログ ボックスが表示されます。
  3. モバイル デバイスを選択します。検索 フィールドや、左側にある プラットフォーム リストと アプリケーション リストを使用して、利用可能なデバイスのリストをフィルタできます。テストするネイティブ アプリをモバイル デバイスにインストールするには、ネイティブ アプリ を左側にある アプリケーション リストから選択し、以下のようにアプリへの URL または UNC パスを指定します（iOS では URL が必須です）。例：\\fileserver\apps\testapp.apk
    ヒント: エミュレータ や シミュレータ を検索する場合など、特定のデバイスの種類を検索するために、検索フィールドを使用できます。
  4. 省略可能：デバイスの選択からエミュレータやシミュレータを除外したい場合は、物理デバイスのみを使用する チェック ボックスをオンにします。
  5. 省略可能：使用中またはブロック中のデバイスを表示しない チェック ボックスをオフにすると、現在デバイスを誰が使用しているのかを確認できます。
  6. デバイスの開始 をクリックして、選択したデバイス上でテストの実行を開始します。
親トピック: 手動テスト
関連概念
[手動テスト] ウィンドウ
関連資料
モバイル デバイス ユーザー インターフェイス


コード分析を開始する

手動テスト ウィンドウでテストを実行するとき、コード分析を開始すると、手動テストによってカバーされたコードについての情報を収集できます。コード分析を有効化する方法については、「コード分析を有効にする」を参照してください。

Java Runtime Environment (JRE) がインストールされており、アプリケーションに実行が許可されていることを確認します。JRE は、Java SE Downloads からダウンロードできます。 ブラウザが NPAPI をサポートしていない場合は、この機能を有効化するために必要な JNLP ファイルを、Silk Central は自動的にダウンロードします（これをバックグラウンドで実行してください）。

コード分析を開始するには：

  1. 手動テスト ウィンドウが開きます。詳細については、「手動構成テスト ウィンドウ」を参照してください。
  2. 左側の [image] (詳細の表示) をクリックして、テスト ステップを展開します。
  3. コード分析の開始 (コード分析の開始) をクリックします。ブラウザが NPAPI をサポートしていない場合は、この機能を有効化するために必要な JNLP ファイルを、Silk Central は自動的にダウンロードします（これをバックグラウンドで実行してください）。 コード分析の開始 ダイアログ ボックスが表示されます。
  4. プロファイル を選択し、1 つ以上の ホスト名 を入力します。このテストにカバレッジ情報が既に存在する場合、チェックボックスをオンにすると置き換えることができます。コード分析の開始 をクリックすると、実際にプロセスが開始されます。
  5. 録画が完了したら、コード分析の停止 をクリックします。コード分析の情報が自動的にテスト実行に添付されます。
  6. 添付されたコード分析の情報を表示するには、 [image] をクリックします。コード分析レポートを表示するには、レポート > コード分析 を選択します。
注: このトピックで説明しているタスクは、テスト レベルでもステップ レベルでも実行できます。
親トピック: 手動テスト


バージョンおよびビルドを編集する

手動テスト ウィンドウでバージョンおよびビルドを編集するには、概要領域の [image] (バージョンおよびビルドの編集) をクリックします。 ボタンが表示されない場合は、 [image] (設定の編集) をクリックしてアクションを有効にします。

テスト サイクルのテストは 1 つのビルドだけでなく、複数のビルドで実行されることがあります。 特にテスト サイクルが長期間にわたり、多くのテストを実行するような場合に、そのような状況となることがあります。 例：テスト サイクルのテスト 1 および 2 はビルド 315 で実行され、同じテスト サイクルのテスト 3 はビルド 316 で実行される。

設定されたビルドおよびバージョンはテストごとに格納され、Silk Central 内のすべての関連グリッドに表示されます。

テストにビルドを設定する場合、このビルドは次のすべてのテストに自動的に設定されます。
  • ユーザーに割り当てられたテストまたは特定のテスト担当者に割り当てられていないテスト
  • まだ実行されていないテスト (未実行 ステータスのテスト)
  • 同じプロジェクトおよび製品に属するテスト。

したがって、その後実行していくテストのたびに、同じビルドを繰り返し設定する必要はありません。

親トピック: 手動テスト


テストおよびテスト ステップのステータス

手動テスト ウィンドウでテスト ステップのステータスを設定すると、テストのステータスが変更されます。次の表は、テスト ステップのステータスによってテスト ステータスを Silk Central が計算する方法を表しています。
ステータス | 説明
合格 | すべてのステップが合格した場合、テスト ステータスは 合格 になります。ステータスの理由はテスト ステップからテストのステータスに伝播されません。
失敗 | すべてのステップが実行され、少なくとも 1 つのステップが失敗した場合、テスト ステータスは 失敗 になります。最初の失敗したテスト ステップのステータスの理由は、テストに対する失敗のステータスの理由として使用されます。
未実行 | すべてのステップが実行されていなければ、テスト ステータスは 未実行 に設定されます。最初の未実行のテスト ステップのステータスの理由は、テストに対する未実行のステータスの理由として使用されます。 少なくとも 1 つのステップのステータスが変更されると、テスト ステータスは 実行中 に設定されます。
実行中 | すべてのステップが実行されるまで、テスト ステータスは 実行中 となります。

また、テスト ステータスを手動で設定することもできます。手動テスト ウィンドウの概要領域、またはテスト ステップのテスト ステップ領域で、ステータス アイコンの横にある [image] (ステータスの選択) をクリックし、ステータスを選択します。各ステータスに対する理由の定義に関する詳細については、「ステータスの理由」を参照してください。

テストのステータスとは別に、テストをブロック済みに設定することも可能です。IT インフラの問題などのある種の制約によって、テストを続行できないことを示すために、テストをブロック済みに設定すると便利です。

次の点に注意します。
  • 手動で設定したテスト ステータスは、自動で計算されたテスト ステータスを上書きします。
  • その後ステップ ステータスを変更した場合は、テスト ステータスが再度計算されます。
  • テスト ステータスを手動で [未実行] に戻して設定できます。ただし、Silk Central がテスト ステータスを自動で [未実行] に戻して設定することはありません。
  • ステップ ステータスを変更していなくても、テスト ステータスを手動で [実行中] に設定できます。
親トピック: 手動テスト
関連概念
概要領域
テスト ステップ領域
ステータスの理由
関連タスク
バージョンおよびビルドを編集する
画面イメージをキャプチャする
ビデオを録画する
結果ファイルを添付する
問題を割り当てる、または作成する


手動テストの印刷

各テストのフォームを印刷し、結果、使用時間、ステータス、他の情報を手書きで入力できます。

手動テストを印刷するには：

  1. メニューで ホーム > マイ ダッシュボード をクリックします。
  2. ユーザーに割り当てられた手動テスト パネルで、アクション 列の [image] (手動テスト結果の表示) をクリックします。 手動テスト結果ビュー が表示されます。
  3. 印刷 または PDF としてダウンロード をクリックします。
親トピック: 手動テスト


テストブック

テストブック は、手動テスト中に行われたすべてのアクティビティに関するリアルタイム更新を提供する、ダッシュボード パネルです。別のテスト サイクルや実行計画で誰が、いつ、何を行ったのかを表示します。テストブック は、テスト担当者テスト マネージャの調整と連携を簡単にします。

ユーザー、アクション、テスト サイクル別にエントリをフィルタできます。パネルには、1 つのプロジェクトのアクティビティのみが表示されます。パネルにプロジェクトを設定するには、パネルの見出しにある [image] (設定) をクリックします。別のプロジェクトでにアクティビティを表示するために、パネルを追加できます。パネルについての詳細は、「ダッシュボード」を参照してください。

各エントリに対して、ユーザー名と (ある場合は) フルネームが表示されます。意味のあるユーザー名を使用していない組織の場合、チーム内の他のユーザーにとってはフルネームの方が認識しやすいものです。

手動テスト ウィンドウでは、 [image] をクリックして テストブック にメッセージを送信できます。

60 日以前のエントリは自動的に削除されます。このデフォルト設定を変更するには、Conf\AppServer\TMAppserverHomeConf.xml というファイルを開き、次の設定を編集します： <MaximumActivityLogLifeTimeInDays>60</MaximumActivityLogLifeTimeInDays>

次のアクティビティが テストブック のログに記録されます。

アイコン | アクティビティ | アイコン | アクティビティ
 | 開始されたテスト サイクル |  | 追加されたテスト
 | 完了したテスト サイクル |  | 開始されたテスト
 | 削除されたテスト サイクル |  | 完了したテスト
 | 追加されたマイルストーン |  | 再割り当てされたテスト
 | 編集されたマイルストーン |  | 削除されたテスト
 | 削除されたマイルストーン |  | ブロックされたテスト
 | 選択されたモバイル デバイス |  | 送信されたメッセージ
親トピック: 手動テスト


オフライン手動テスト

オフライン手動テストを使用すると、テストをダウンロードして、オフラインで完了することができます。そして、その結果を Silk Central へアップロードして戻すこともできます。

テスト担当者は、ユーザーに割り当てられた手動テスト パネルを使用して、手動テストをダウンロードして、結果を Silk Central にアップロードして戻すことができます。テスト担当者は、オフライン手動テストの概要 パネルを使用して、ダウンロードしたテストの表示と管理を行うことができます。

注: 手動テスト ライセンスは、テストがオフライン実行用にダウンロードされたときにチェックアウトされます。このライセンスは結果をアップロードした時に戻されます。
  • 手動テストをオフライン実行用にダウンロードする
    手動テストをダウンロードしてオフラインで完了する方法について説明します。
  • オフライン手動テスト結果をアップロードする
    オフライン手動テストの結果をアップロードする方法について説明します。
親トピック: 手動テスト


手動テストをオフライン実行用にダウンロードする

このトピックでは、テストをダウンロードして、オフラインで ステータス、理由、そして 結果 を入力する方法について説明します。

  1. ホーム > マイ ダッシュボード へ移動します。ユーザーに割り当てられた手動テスト パネルが表示されていることを確認します。
  2. 1 つまたは複数のテストを選択します。選択箇所を右クリックして、選択した手動テストをオフライン実行用にダウンロード を選択します。単一のテストを選択して、関連する実行計画のすべての手動テストをオフライン実行用にダウンロード を選択することもできます。
    ヒント: １ ページあたりの行数 設定や、ソートおよびフィルタ機能を利用して、選択する必要のあるテストのリストを受け取ります。
  3. 手動テストをオフライン実行用にダウンロード ダイアログ ボックスで、Excel でテストをまとめる方法を次から指定します。
    • ステップのリストを持つテストごとに別のワークシートを作成する
    • ステップを持たないテストのリストを持つ単一のワークシートを作成する
  4. テストに属性が含まれている場合、属性を含める を選択します。すべての属性がダウンロードした Excel シートに含まれるため、これらの属性でテストをフィルタすることができます。
  5. 添付情報を含める を選択すると、選択したテストやテスト ステップに添付されたファイルもダウンロードできます。Silk Central へのアップロード時に、添付情報を戻すことはサポートされてません。
  6. ダウンロード をクリックします。 Excel ファイルをダウンロードして保存します。
  7. ファイルを開き、ダウンロードした Excel ファイルの形式に従って、ステータス、および 結果 または 使用時間 を、各ステップまたは各テストに対して入力します。
  8. ファイルを保存します。
親トピック: オフライン手動テスト
関連タスク
オフライン手動テスト結果をアップロードする


オフライン手動テスト結果をアップロードする

ダウンロードした手動テストを完了したら、次の手順に従って結果を Silk Central にアップロードします。

  1. ホーム > マイ ダッシュボード へ移動します。ユーザーに割り当てられた手動テスト パネルが表示されていることを確認します。
  2. オフライン手動テスト結果のアップロード をクリックします。 オフライン手動テスト結果のアップロード ダイアログ ボックスが表示されます。
  3. ファイルの選択 をクリックして、Excel ファイルを参照します。 開く ダイアログ ボックスが表示されます。
  4. アップロードするファイルを選択し、開く をクリックします。
  5. アップロード をクリックします。 アップロードのステータスを示すダイアログ ボックスが表示されます。
  6. OK をクリックします。
親トピック: オフライン手動テスト
関連タスク
手動テストをオフライン実行用にダウンロードする


構成テスト

構成テストは、サポートされる各ソフトウェア構成とハードウェア構成に関するシステムのテストを行う処理です。

実行 領域では、割り当て済みテストの再利用を有効にすることによって構成テストをサポートしています。構成スイートは、割り当て済みの一連のテストと共に作成できます。構成スイートに追加するすべての実行計画にも、一連のテストが割り当てられます。既存の実行計画から構成スイートを作成し、実行 ツリー内の実行計画を構成スイートにコピーするかまたは切り取って貼り付けることもできます。Silk Central を使用すると、パラメータ、キーワード、および手動テスト担当者を構成に追加したり、これらを構成から削除したりできます。既存の実行計画から構成スイートを作成すると、すべての実行計画の結果が構成スイートに保持されます。実行計画をコピーして既存の構成スイートに貼り付けた場合、これらの結果は保持されません。

構成スイートの各実行計画は、編集可能なグリッドに表示されます。特定のテストを含む実行計画または構成は、テストの プロパティ タブで表示できます。また、特定の要件に関連付けられた実行計画または構成は、要件の 割り当て済みテスト タブで表示できます。

自動テストの構成を定義するには、構成スイートの設定 ページを使用します。手動テストの構成を定義するには、構成 ページを使用します。

  • 構成スイートを作成する
    構成スイートを作成し、スイート内のすべての実行計画を、同じテストと特定のパラメータまたは配置設定を使用して実行します。
  • 実行計画から構成スイートを作成する
    実行計画から構成スイートを作成して、サポートされるソフトウェア構成とハードウェア構成の設定を追加します。
  • パラメータを構成に追加する
    パラメータを構成に追加し、パラメータを使用して対応する実行計画を実行します。
  • 構成からパラメータを削除する
    構成からパラメータを削除して、対応する実行計画をパラメータなしで実行します。
  • キーワードを構成に割り当てる
    実行環境を記述するために、キーワードを構成に割り当てます。
  • 構成からキーワードを削除する
    キーワードにより実行環境が記述されなくなった場合に、構成からキーワードを削除します。
  • 構成に手動テスト担当者を追加する
    手動テストを含む構成に手動テスト担当者を追加します。
  • 構成からテスト担当者の割り当てを削除する
    構成からテスト担当者の割り当てを削除します。
  • モバイル デバイスを構成に割り当てる
    実行計画を実行するためのモバイル デバイス（物理デバイス、エミュレータ、シミュレータ）を構成に割り当てます。
  • [構成スイートの設定] ページ
    構成スイートに含まれる構成を一覧表示します。自動テストの構成を定義するには、構成スイートの設定 ページを使用します。手動テストの場合は、構成 ページを使用します。
  • [構成] ページ
    構成 ページの概要を示します。手動テストでのみ 構成 ページで定義した構成を使用することができます。自動テストの構成を定義するには、構成スイートの設定 ページを使用します。
親トピック: 実行計画
関連概念
実行ステータスの概要レポート
関連資料
[実行計画] の [プロパティ] ページ
[実行] の [割り当て済みテスト] ページ
[スケジュール] ページ


構成スイートを作成する

構成スイートを作成するには：

  1. メニューで、実行計画 > 詳細ビュー または 実行計画 > ドキュメント ビュー をクリックします。
  2. ルート ノードまたは 実行 ツリーのフォルダを右クリックして 子構成スイートの新規作成 を選択するか、ツールバーの 子構成スイートの新規作成 をクリックします。 構成スイートの新規作成 ダイアログ ボックスが表示されます。
  3. 新しい構成スイートの 名前 と 説明 を入力します。
  4. リスト ボックスから テスト コンテナ を選択します。
  5. リスト ボックスから バージョン と ビルド を選択するか、ビルド情報ファイルからの読み込み チェック ボックスをオンにしてバージョンとビルドをファイルから読み込みます。
  6. 省略可能：自動化ファイルの最新バージョンの代わりに、前のバージョンがソース管理システムから取得されるよう、ソース管理ラベル フィールドに指定できます。
    注: ソース管理ラベル プロパティが有効になるのは、関連付けられているテスト コンテナでバージョン管理をサポートするソース管理プロファイルが使用される場合のみです。
  7. OK をクリックします。
親トピック: 構成テスト


実行計画から構成スイートを作成する

既存の実行計画から構成スイートを作成するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 ツリーで、構成スイートの作成元にする実行計画を右クリックして、構成スイートに変換 を選択します。 Silk Central は、選択した実行計画と同じ名前の新しい構成スイート ノードを 実行 ツリーに作成し、実行計画を構成サブノードとして構成スイートに追加します。
既存の実行計画から構成スイートを作成すると、すべての実行計画の結果が構成スイートに保持されます。実行計画をコピーして既存の構成スイートに貼り付けた場合、これらの結果は保持されません。
親トピック: 構成テスト


パラメータを構成に追加する

構成に定義済みパラメータを追加するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 ツリーで、パラメータを追加する構成ノードを選択します。
  3. 設定 タブをクリックします。
  4. パラメータの追加/削除 をクリックします。 パラメータの追加/削除 ダイアログ ボックスが開きます。ダイアログ ボックスの右側にある 割り当て済みパラメータ リスト ボックスに、構成に対して定義されているすべてのパラメータが一覧表示されます。
  5. パラメータの選択または入力 リスト ボックスで、実行環境の要件を反映するパラメータを選択します。 一般的なブラウザの複数選択機能である Ctrl + クリック または Shift + クリック を使用して、複数のパラメータを選択します。
  6. パラメータの選択または入力 リスト ボックスに一覧表示されたパラメータのいずれかを追加するには、パラメータを選択して > をクリックします。
  7. 新規パラメータを作成するには、パラメータの入力 フィールドにパラメータ名を入力して、Enter を押すか > をクリックします。
    ヒント: パラメータの入力 フィールドでは、オートコンプリート機能が有効になっています。このフィールドに英文字を入力すると、フィールドはその入力された文字に一致する既存のパラメータで動的に更新されます。複数のパラメータが パラメータの選択 または 割り当て済みパラメータ リスト ボックスで選択されている場合、このフィールドは無効になります。
  8. OK をクリックします。 パラメータの追加/削除 ダイアログ ボックスが閉じ、新規パラメータごとに新しい列がグリッドに追加されます。
親トピック: 構成テスト


構成からパラメータを削除する

定義済みパラメータを構成から削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 ツリーで、パラメータを削除する構成ノードを選択します。
  3. 設定 タブをクリックします。
  4. パラメータの追加/削除 をクリックします。 パラメータの追加/削除 ダイアログ ボックスが開きます。 ダイアログ ボックスの右側にあるリスト ボックスに、構成に対して定義されているパラメータがすべて一覧表示されます。
  5. リスト ボックスからパラメータを削除するには、パラメータを選択して < をクリックします。
  6. OK をクリックします。 パラメータの追加/削除 ダイアログ ボックスが閉じ、削除されたパラメータの列がグリッドから削除されます。
親トピック: 構成テスト


キーワードを構成に割り当てる

キーワードを構成に割り当てるには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する構成スイートを選択します。
  3. 設定 タブをクリックします。
  4. キーワードを追加する構成の キーワード 列をクリックします。 キーワードの割り当て ダイアログ ボックスが開きます。
  5. キーワードの選択または入力 リスト ボックスで、実行環境の要件を反映するキーワードを選択します。 一般的なブラウザの複数選択機能である Ctrl + クリック または Shift + クリック を使用して、複数のキーワードを選択します。
    ヒント: キーワードの入力 フィールドでは、オートコンプリート機能が有効になっています。このフィールドに英文字を入力すると、フィールドはその入力された文字に一致する既存のキーワードで動的に更新されます。複数のキーワードが キーワードの選択 または 割り当て済みキーワード リスト ボックスで選択されている場合、このフィールドは無効になります。
    ヒント: 自動実行計画の場合、数台の実行サーバーしかなく、ハードウェア プロビジョニングが必要ないときは、実行サーバーごとに作成されるデフォルトの予約済みキーワードを使用するだけで十分である可能性があります。その場合、新たにキーワードを選択する必要はありません。
  6. > をクリックして、キーワードを 割り当て済みキーワード リスト ボックスに移動します。
    注: 自動実行計画の場合、割り当てられたキーワードに一致する実行サーバーが、下の動的に更新される キーワードに一致した実行時に配置可能な実行サーバー リスト ボックスに表示されます。この一覧は、キーワードを追加/削除するたびに更新されます。実行サーバーにアクセスするには、管理 > 実行サーバー で、一覧の実行サーバーの名前をクリックします。
  7. OK をクリックしてキーワードを保存し、キーワードの割り当て ダイアログ ボックスを閉じます。
親トピック: 構成テスト


構成からキーワードを削除する

構成からキーワードの割り当てを削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する構成スイートを選択します。
  3. 設定 タブをクリックします。
  4. キーワードを削除する構成の キーワード 列をクリックします。 キーワードの割り当て ダイアログ ボックスが開きます。
  5. 割り当て済みキーワード リストで、不要になったキーワードを選択します。 Ctrl + クリック または Shift + クリック を使用すると、複数のキーワードを選択できます。
  6. < をクリックして、キーワードの割り当てを削除します。
  7. OK をクリックしてキーワードを保存し、キーワードの割り当て ダイアログ ボックスを閉じます。
注: 使われなくなったキーワードは、システムから自動的に削除されます。
親トピック: 構成テスト


構成に手動テスト担当者を追加する

手動テストを含む構成の場合は、設定 ページで、選択されている構成にユーザーを手動テスト担当者として割り当てることができます。 複数の手動テスト担当者を構成に割り当てることができます。

手動テスト担当者を構成に割り当てるには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する構成スイートを選択します。
  3. 設定 タブをクリックします。
  4. 手動テスト担当者を追加する構成の 手動テスト担当者 列をクリックします。 手動テスト担当者 ダイアログ ボックスが開きます。
  5. 選択可能 リスト ボックスで、テスト担当者が所属するユーザー グループを選択します。
    そのユーザー グループのすべてのメンバがリスト ボックスに表示されます。
  6. 手動テスト担当者として割り当てるユーザーの名前を選択します。
  7. 追加 をクリックして、ユーザーを 選択済み リスト ボックスに追加します。または、すべて追加 をクリックして、グループのすべてのメンバとテスト担当者を追加します。
  8. OK をクリックして、テスト担当者の追加/削除 ダイアログ ボックスを閉じます。
親トピック: 構成テスト


構成からテスト担当者の割り当てを削除する

構成からテスト担当者の割り当てを削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. テスト担当者の割り当てを削除する構成ノードを選択します。
  3. 設定 タブをクリックします。
  4. 手動テスト担当者を削除する構成の 手動テスト担当者 列をクリックします。 手動テスト担当者 ダイアログ ボックスが開きます。
  5. 選択済み リストから、削除する割り当て済みユーザーの名前を選択します。
  6. 削除 をクリックして、選択済み リストからユーザーを削除するか、すべて削除 をクリックして、テスト担当者の割り当てをすべて削除します。
  7. OK をクリックして、テスト担当者の追加/削除 ダイアログ ボックスを閉じます。
親トピック: 構成テスト


モバイル デバイスを構成に割り当てる

モバイル デバイスを構成に割り当てるには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する構成スイートを選択します。
  3. 設定 タブをクリックします。
  4. モバイル デバイス、デバイス フィルタ、またはネイティブ アプリを選択します。
    • 特定のデバイスを選択するには、右側にあるリストを使用します。
    • デバイス フィルタを選択するには、右側のリストにある 任意のデバイス を選択します。検索 フィールドと、左側にある プラットフォーム と アプリケーション リストを使用してこのフィルタを編集します。
      ヒント: エミュレータ や シミュレータ を検索する場合など、特定のデバイスの種類を検索するために、検索フィールドを使用できます。
    • テストするネイティブ アプリをモバイル デバイスにインストールするには、ネイティブ アプリ を左側にある アプリケーション リストから選択し、以下のようにアプリへの URL または UNC パスを指定します（iOS では URL が必須です）。例：\\fileserver\apps\testapp.apk
  5. 省略可能：デバイスの選択からエミュレータやシミュレータを除外したい場合は、物理デバイスのみを使用する チェック ボックスをオンにします。
  6. 省略可能：現在使用できるデバイスのみを表示したい場合は、使用中またはブロック中のデバイスを表示しない チェック ボックスをオンにします。手動テストや実行計画を直ちに実行したい場合に、この設定は役に立ちます。
  7. モバイル デバイスの選択を保存するには、OK をクリックします。
実行時に、選択したデバイス、またはフィルタに最初に意一致したデバイスが使用され、実行計画が完了するまでブロックされます。選択したデバイスが利用できない場合や、フィルタに一致する利用可能なデバイスが見つからない場合は、適切な実行サーバーおよびモバイル デバイスが利用可能になるまで、実行ジョブはキューで待機します。Sauce Labs デバイスは実際は単一のデバイスではなく、デバイスの種類であるため、実行中にブロックされることはありません。
親トピック: 構成テスト
関連概念
デバイス プロバイダを管理する
関連タスク
自動テストのモバイル デバイスを選択する
手動テストのモバイル デバイスを選択する
関連資料
デバイス プロバイダを設定する


[構成スイートの設定] ページ

このページにアクセスするには、実行計画 > 詳細ビュー > <構成スイート> > 構成 をクリックします。

構成 タブには、構成スイートに含まれる構成が表示されます。グリッドには、子実行計画の自動生成データが表示されます。

グリッドに各構成を追加すると、構成スイートで実行される新しい実行計画が作成されます。

新しい構成を定義する場合は、構成の新規作成 をクリックします。パラメータを追加/削除するには、パラメータの追加/削除 をクリックします。

一覧表示される構成ごとに、ページに次の列が表示されます。
列 | 説明
アクション
  • 構成を削除するには、 構成の削除 をクリックします。
  • 構成を複製するには、 構成の複製 をクリックします。
名前 | 構成の名前。変更するには、名前をクリックします。
キーワード | 構成に割り当てられた実行キーワードのリスト。リストを変更するには、リンクをクリックします。詳細については、「キーワードを構成に割り当てる」を参照してください。
手動テスト担当者 | 構成に割り当てられた手動テスト担当者のリスト。リストを変更するには、リンクをクリックします。詳細については、「構成に手動テスト担当者を追加する」を参照してください。
モバイル デバイスの選択 | 構成に割り当てられたモバイル デバイス（物理デバイス、エミュレータ、シミュレータ）。モバイル デバイスの選択を編集するには、リンクをクリックします。詳細については、「モバイル デバイスを構成に割り当てる」を参照してください。
パラメータ | グリッドに複数のパラメータ列を指定できます。グリッドにパラメータを追加したり、グリッドからパラメータを削除するには、パラメータの追加/削除 をクリックします。パラメータに値を追加するには、フィールドをクリックし、値を入力します。詳細については、「パラメータを構成に追加する」を参照してください。
親トピック: 構成テスト
関連概念
実行計画パラメータ
関連タスク
パラメータを構成に追加する
関連資料
[構成] ページ


[構成] ページ

このページにアクセスするには、実行計画 > 構成 をクリックします。

構成 ページには、定義された構成の一覧がグリッドで表示されます。手動テストでのみこれらの構成を使用することができます。自動テストの構成の定義については、構成スイートの設定 ページを参照してください。

新しい構成を定義する場合は、構成の新規作成 をクリックします。パラメータを追加/削除するには、パラメータの追加/削除 をクリックします。

一覧表示される構成ごとに、ページに次の列が表示されます。
列 | 説明
アクション
  • 構成を削除するには、 構成の削除 をクリックします。
  • 構成を複製するには、 構成の複製 をクリックします。
名前 | 構成の名前。変更するには、名前をクリックします。
モバイル デバイスの選択 | 構成に割り当てられたモバイル デバイス（物理デバイス、エミュレータ、シミュレータ）。モバイル デバイスの選択を編集するには、リンクをクリックします。詳細については、「モバイル デバイスを構成に割り当てる」を参照してください。
キーワード | 構成に割り当てられた実行キーワードのリスト。リストを変更するには、リンクをクリックします。詳細については、「キーワードを構成に割り当てる」を参照してください。
パラメータ | グリッドに複数のパラメータ列を指定できます。グリッドにパラメータを追加したり、グリッドからパラメータを削除するには、パラメータの追加/削除 をクリックします。パラメータに値を追加するには、フィールドをクリックし、値を入力します。詳細については、「パラメータを構成に追加する」を参照してください。
親トピック: 構成テスト
関連タスク
パラメータを構成に追加する
関連資料
[構成スイートの設定] ページ


実行計画、フォルダ、構成スイートを管理する

実行計画は、単一のテスト コンテナに格納されている割り当て済みテストの集まりです。 実行計画は、設定可能なスケジュールで実行することができるほか、指定した実行サーバーに配置することができます。フォルダを使用して、実行計画、構成スイート、テスト サイクルを構造化することができます。 フォルダ内にフォルダを作成することもできます。

実行計画の追加や編集の手順は、自動実行計画の場合も手動実行計画の場合も同じです。

  • 実行計画を作成する
    関連するテストをまとめて実行するために、実行を作成します。
  • グリッド ビュー で実行計画を作成する
    グリッド ビュー で実行計画を作成して、テストを実行計画に直接割り当てます。
  • テスト ステータスの計算
    実行計画のステータスの計算方法について説明します。
  • 実行計画属性
    属性とは、実行計画に適用できる自由に定義可能な特性です。フィルタやレポートに対して、属性を使用できます。
  • 実行計画パラメータ
    自由に設定できる入力値であるパラメータを実行計画に割り当てる方法について説明します。
  • セットアップおよびクリーンアップ用テスト
    テストに備えてテスト環境を準備するセットアップ用テスト、およびテスト終了後にテスト環境を元の状態に戻すクリーンアップ用テストを使用する方法について説明します。
  • 配置環境を設定する
    Silk Central を使用して配置環境を設定する方法について説明します。
  • 実行の依存関係を設定する
    ある実行計画を別の実行計画の結果に基づいて自動的に実行するように設定する方法について説明します。
  • 割り当て済みテスト
    実行計画にテストを割り当てる方法について説明します。
  • スケジュール
    実行計画、フォルダ、および構成スイートを実行するスケジュールを定義する方法について説明します。
  • 実行計画に割り当てられたテストを実行する
    Silk Central によって、実行計画に割り当てられたテストを実行する方法について説明します。
  • フィルタ
    フィルタを使用して、無関係な情報を除外しながら必要な情報を確実に見つける方法について説明します。
  • スクリーン キャプチャ
    スクリーン キャプチャを使用してテストのスクリーンショットを作成する方法について説明します。
  • ビデオ キャプチャ
    ビデオ キャプチャを使用してテストのビデオを作成する方法について説明します。
  • 結果と結果ファイルの自動削除
    実行計画の実行の古い結果と結果ファイルをクリーンアップするルールを定義して、データベース サイズを縮小し、実行計画の実行の管理の容易性を高めます。
親トピック: 実行計画


実行計画を作成する

実行計画を作成するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、フォルダまたはプロジェクト ノードを選択します。
  3. ツールバーで 子実行計画の新規作成 (子実行計画の新規作成) をクリックするか、フォルダ、テスト サイクル、またはノードを右クリックして 子実行計画の新規作成 をクリックします。 実行計画の新規作成 ダイアログ ボックスが表示されます。
  4. 実行計画の名前と説明を入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. テスト コンテナ リストからテスト コンテナを選択します。
    注: 1 つの実行計画には、1 つのテスト コンテナしか割り当てることはできません。このテスト コンテナから 1 つのテストのみを実行できます。
    このコンテナが属する製品で定義されている最新のバージョンとビルドが、バージョン リスト ボックスと ビルド リストに自動的にインポートされます。
  6. バージョン リストと ビルド リストから、製品のバージョンとビルドをそれぞれ選択します。 この実行計画の新規実行の開始時には、これらが使用されます。また、ビルド情報ファイルからの読み込み チェック ボックスをオンにすることもできます。この場合、バージョンおよびビルドは、各実行の開始時に、アプリケーション サーバーのビルド情報から読み込まれます。実行サーバー上でビルド情報ファイルが使用できる場合は、テスト実行時に、デフォルトでこのファイルが使用され、実行計画の新規作成 ダイアログ ボックスの設定が上書きされます。
  7. 優先度 リストから、実行計画の優先度を選択します。 自動実行計画の場合、複数の実行計画がキューに入れられたが、1 台の実行サーバーのみが使用可能な場合、優先度 によって、最初に実行される実行計画が決定されます。実行サーバーが使用可能でも、複数の実行計画が使用できないモバイル デバイスを必要としている場合も同様です。
  8. オプションとして、実行計画を最新バージョンよりも前のバージョンにするように、ソース管理ラベル フィールドに指定することができます。このラベルは、ソース管理システムで管理されている特定のバージョン (テスト コンテナが関連付けられているもの) を指す必要があります。このフィールドに何も指定されていない場合、実行計画の最新バージョンが取得されます。ソース管理ラベル プロパティが有効になるのは、関連付けられているテスト コンテナでバージョン管理をサポートするソース管理プロファイルが使用される場合のみです。ソース ファイルの複数のバージョンを扱う場合には、実行サーバーに十分な空きディスク領域があることを確認してください。どの実行サーバーでも各バージョンが専用のフォルダに保存されます。
    ヒント: 特定の実行計画に対して、リポジトリの特定のブランチをチェック アウトするには、各実行計画の ソース管理ラベル フィールドでブランチ名を指定します。
  9. OK をクリックして 実行 ツリーを更新すると、新規に作成した実行計画が表示されます。
親トピック: 実行計画、フォルダ、構成スイートを管理する
関連概念
ビルド情報
ソース管理プロファイル統合
関連タスク
グリッド ビュー で実行計画を作成する
実行計画ツリーの要素の編集
関連資料
[実行計画] の [プロパティ] ページ


テスト ステータスの計算

各実行計画のステータスは次のいずれかです。
ステータス
条件
合格
検討されたテスト実行計画はすべて [合格] ステータスです。
失敗
検討されたテスト実行計画の少なくとも 1 つが [失敗] ステータスですが、[未実行] ステータスの実行計画はありません。
未実行
検討されたテストの少なくとも 1 つが [未実行] ステータスです。

テストのステータスは、最新の実行計画の実行結果に基づいています。 最新の実行計画の実行のステータスを手動で変更すると、テストのステータスも変更されます。

注: 最近の実行計画の実行結果が削除された場合、テストのステータスも、最近の実行計画の実行結果に存在するステータスにリセットされます。 削除された実行計画の実行結果が唯一存在する実行計画の実行結果だった場合、テストのステータスは、新しく作成されたときのように [N/A] に設定されます。
親トピック: 実行計画、フォルダ、構成スイートを管理する


実行計画属性

属性とは、実行計画に適用できる自由に定義可能な特性です。フィルタやレポートに対して、属性を使用できます。
注: 属性の継承は、プロパティや成功条件の継承と似ています。親ノードに割り当てられている属性は、すべてのサブフォルダや子実行計画にくまなく継承されます。プロジェクト ノードや 未割り当てテスト ノードでは、属性を定義できません。
  • 実行計画に属性を割り当てる
    実行計画に属性を割り当てることによって、指定された属性によって特徴付けられたカテゴリでフィルタやレポートを作成できるようになります。
  • 実行計画属性を編集する
    実行計画属性を編集して、実行計画の特性を変更します。
  • 実行計画から属性を削除する
    属性が実行計画の特徴を示さなくなった場合に、実行計画から属性を削除します。
親トピック: 実行計画、フォルダ、構成スイートを管理する


実行計画に属性を割り当てる

実行計画に属性を割り当てるには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 属性を割り当てる実行計画を選択します。
  3. 属性 セクションで、属性の追加 をクリックします。属性の追加 ダイアログ ボックスが表示されます。
  4. 割り当てる属性の 追加 列で、 属性の追加 をクリックします。 選択した属性のタイプに応じて、属性の編集 ダイアログ ボックスが表示されます。ここでは、実行計画に割り当てる属性値を利用可能な属性値の中から指定できます。
  5. 属性値を選択して OK をクリックし、属性を実行計画に割り当てます。
親トピック: 実行計画属性


実行計画属性を編集する

実行計画属性を編集するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 編集対象の属性が割り当てられている実行計画を選択します。
  3. 属性 セクションで、編集する属性の 編集 アイコンをクリックします。 属性の編集 ダイアログ ボックスが表示されます。属性の編集 ダイアログ ボックスで利用可能なオプションは、選択した属性タイプによって異なります。
  4. 必要な値を選択し、OK をクリックして設定を保存します。
親トピック: 実行計画属性


実行計画から属性を削除する

実行計画から属性を削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 削除対象の属性が割り当てられている実行計画を選択します。
  3. 属性 セクションで、削除する属性の 削除 アイコンをクリックします。 属性の削除 確認ダイアログ ボックスが表示されます。
  4. はい をクリックして、属性を削除します。
    注: テストの実行で既に使用されている属性と継承した属性は、削除できません。
親トピック: 実行計画属性


実行計画パラメータ

特定の設定を実行計画に割り当てるため、実行計画の プロパティ ページの パラメータ セクションで、テストに割り当てたパラメータを上書きすることができます。テスト パラメータの詳細については、「テスト パラメータ」を参照してください。

  • 事前定義パラメータ
    Silk Central は、 テスト実行中に、実行計画の実行プロパティに関する情報をパラメータとして提供します。
  • 実行計画パラメータを作成する
    実行計画に新しいパラメータを追加する方法について説明します。
  • テスト パラメータを上書きする
    実行計画のテスト パラメータを上書きする方法について説明します。
  • 実行計画パラメータを削除する
    実行計画パラメータを実行計画から削除する方法について説明します。
親トピック: 実行計画、フォルダ、構成スイートを管理する
関連概念
テスト パラメータ


実行計画パラメータを作成する

実行計画に新しいパラメータを追加するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 ツリーで、新しいパラメータを追加する実行計画を選択します。
  3. パラメータ セクションで、実行計画パラメータの新規作成 をクリックします。 実行計画パラメータの新規作成 ダイアログ ボックスが表示されます。
  4. 新しいパラメータの 名前 と 値 を対応するフィールドに入力します。新しい実行計画パラメータは常に文字列型となり、異なるタイプは定義できません。
  5. OK をクリックして、パラメータを実行計画に追加します。
    注: 実行計画に含まれている既存のテストパラメータと同じ名前を使用して、実行計画パラメータを作成することはできません。
構成テストでは、同じテストを含む複数の実行計画を作成してから、パラメータ ページで異なる構成を定義することができます。異なるテストに含まれ、名前とタイプが同じパラメータは、ページに 1 回しか表示されません。異なるテストの複数パラメータが同じ名前である場合は、いずれか 1 つのパラメータのみを上書きできます。
親トピック: 実行計画パラメータ


テスト パラメータを上書きする

タイプは異なるが同じ名前のパラメータがテストに複数存在する場合、それらの一つだけを上書きすることができます。実行中に、名前とタイプが同じパラメータの値のみが、上書きする値に置き換えられます。

実行計画のテスト パラメータを上書きするには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 ツリーで、テスト パラメータを上書きする実行計画を選択します。
  3. パラメータ セクションで、上書きするパラメータの アクション 列にある パラメータ値の設定 をクリックします。 実行計画のパラメータ値の設定 ダイアログ ボックスが表示されます。
  4. 値 フィールドに新しい値を入力します。
  5. OK をクリックします。
注: 上書きを戻すには、パラメータの アクション 列で 実行計画パラメータの削除 をクリックします。
親トピック: 実行計画パラメータ


実行計画パラメータを削除する

注: 実行計画のテスト パラメータは削除できません。削除できるのは、実行計画パラメータのみです。

実行計画パラメータ削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 ツリーで、パラメータを削除する実行計画を選択します。
  3. パラメータ セクションで、削除するパラメータの アクション 列にある 実行計画パラメータの削除 をクリックします。
親トピック: 実行計画パラメータ


セットアップおよびクリーンアップ用テスト

Silk Central のテスト前セットアップおよびテスト後クリーンアップ機能により、実行計画ごとにセットアップ用テストとクリーンアップ用テストを定義することができます。セットアップ用テストは通常、テストに備えてテスト環境を準備するスクリプトや手動手順に基づいて作成されます。一方、クリーンアップ用テストは通常、テスト終了後にテスト環境を元の状態に戻すスクリプトや手動手順で構成されます。セットアップ用テストの実行が中止されると、通常のテストは実行されませんが、クリーンアップ用テストは実行され、テスト環境が元の状態に戻ります。

セットアップ用やクリーンアップ用のテストを実行計画に割り当てるには、まず、それらを作成する必要があります。多重データ駆動型テスト インスタンスの親テストを除けば、どのようなテストでも、セットアップ用またはクリーンアップ用のテストとして使用できます。特別な設定は要らず、自動テストでも手動テストでもかまいません。唯一の要件は、必要なセットアップ処理やクリーンアップ処理をテスト環境内で実行することです。自動テストの場合、これらは必要なセットアップ作業とクリーンアップ作業を実行するスクリプトです。一方、手動テストの場合、これらは手動で行うセットアップ作業とクリーンアップ作業です。

注: セットアップ用およびクリーンアップ用テストを実行する上での課題は、それらの実行結果が、通常のテストの実行結果と一緒にされないようにすることです。Silk Central では、セットアップ用およびクリーンアップ用テスト (自動と手動の両方) を独立した実行計画で実行し、それによって、実際のテスト結果を、セットアップ用およびクリーンアップ用テストの結果生じるおそれのある偶発的なパフォーマンス変動から切り離すことで、この懸念に対処しています。
  • 自動テストと手動テストを組み合わせる
    自動テストと手動テストを組み合わせた実行計画が Silk Central でどのようにサポートされているかについて説明します。
  • セットアップ実行とクリーンアップ実行を設定する
    テストに備えてテスト環境を準備するためにセットアップ用テストを設定し、テスト環境を元の状態に戻すためにクリーンアップ用テストを設定します。
親トピック: 実行計画、フォルダ、構成スイートを管理する


自動テストと手動テストを組み合わせる

Silk Central では、自動テストと手動テストを組み合わせた実行計画をサポートしています。このような実行計画の場合、Silk Central では、セットアップ用テストが完了するまで、通常のテスト (自動と手動の両方) を実行しません。また、Silk Central では、必ず通常のテストがすべて完了してからクリーンアップ用テストが実行されます。

手動テストが自動テストと組み合わされると、すべての実行サーバー上の自動テストはセットアップ処理が完了するまでは開始されません。手動のセットアップ用テストの場合は、必ず手動のセットアップ作業が完了してから通常の自動テストが開始されます。

親トピック: セットアップおよびクリーンアップ用テスト


セットアップ実行とクリーンアップ実行を設定する

テストをセットアップ用またはクリーンアップ用のテストとして定義するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. セットアップ用またはクリーンアップ用テストを設定する実行計画をクリックします。
  3. テスト実行セットアップ セクションで、セットアップ用またはクリーンアップ用テストを選択します。
    • セットアップ用テストを定義するには、セットアップ用テスト にある 編集 (編集) をクリックします。セットアップ用テストの編集 ダイアログ ボックスが表示されます。
    • クリーンアップ用テストを定義するには、クリーンアップ用テスト にある 編集 (編集) をクリックします。クリーンアップ用テストの編集 ダイアログ ボックスが表示されます。
    セットアップ用テストおよび通常またはクリーンアップ用テストの両方として、同じ実行計画にテストを割り当てることはできません。割り当てられるテストは、プロジェクト内の任意のテスト コンテナから得ることができます。そのため、ホスト実行計画と異なる製品およびソース管理プロファイルと関連付けられているテストを割り当てることができます。
  4. テスト ツリーで、テストを選択します。
  5. OK をクリックします。
失敗したテストを再実行すると、それに対応するセットアップ/クリーンアップ ルーチンも再実行されます。テストの 試験実行 は、実行計画とは関係ないため、セットアップ/クリーンアップ用テストは実行されません。
親トピック: セットアップおよびクリーンアップ用テスト


配置環境を設定する

  • [実行] の [配置] ページ
    実行定義に対して定義されているハードウェア プロビジョニング キーワード、手動テストの実行を割り当てられているユーザー、および Silk Test Classic テストの実行を割り当てられている Silk Test Classic AUT ホストがすべて表示されます。
  • 手動テスト担当者の追加と削除
    手動テストを含む実行計画で手動テスト担当者の追加と削除を行います。
  • キーワードを用いた動的ハードウェア プロビジョニング
    Silk Central のハードウェア プロビジョニング技術は、多数の実行サーバーが含まれているテスト環境の管理に役立ちます。各自動実行計画に対して実行サーバーを 1 対 1 で静的に割り当てなくても、キーワードによって Silk Central は各実行計画に最適な実行サーバーを自動的に選択することができます。これは、各実行計画のキーワード リストとすべてのアクティブな実行サーバーのキーワード リストを動的に比較することで実現されます。
  • 排他的実行
    排他的実行は、他の実行計画（排他的実行は無効）に割り当てられたテストが、同じ一致した実行サーバー上で同時に実行できるか（無効）、1 つの実行計画のテストだけを同時に実行できるか（有効）を定義します。
  • 分散実行
    分散実行は、選択した実行サーバー上で実行計画のテストが順番に実行されるか（無効）、すべての一致した実行サーバーに分散して並列に実行されるか（有効）を定義します。
  • 自動テストのモバイル デバイスを選択する
    実行計画を実行するためのモバイル デバイス（物理デバイス、エミュレータ、シミュレータ）を選択します。
  • コード分析
    Silk Central を使ったコード カバレッジの解析方法について説明します。
  • Silk Test Classic AUT ホストを追加する
    Silk Test Classic エージェントが実行サーバーとは異なるコンピュータ上に配置されている場合に、Silk Test Classic AUT ホストを追加します。
親トピック: 実行計画、フォルダ、構成スイートを管理する


[実行] の [配置] ページ

実行計画 > 詳細ビュー > <実行計画> > 配置

配置 ページには、この実行計画に対して定義されているハードウェア プロビジョニング キーワードがすべて表示されます。これらのキーワードは、実行計画に対する実行環境要件を記述するために使用されます。実行サーバーは、実行計画が要求するキーワードをすべて割り当てられている場合にのみ、選択されている自動実行計画にマッチします。また、配置 ページには、手動テストの実行を割り当てられているユーザー以外に、Silk Test Classic テストの実行を割り当てられている Silk Test Classic AUT ホストも表示されます。

注: 新しい実行サーバーのセットアップは、管理 > 実行サーバー で行います。実行サーバーの設定の詳細については、「実行サーバーを設定する」を参照してください。

手動テスト実行

この実行計画またはフォルダに割り当てられている手動テスト担当者をすべてリストします。手動テスト担当者のリストを編集するには、編集 をクリックします。詳細については、「手動テスト担当者の追加と削除」を参照してください。

自動テスト実行

配置 ページの 自動テスト実行 セクションには、次の項目が表示されます。
項目 | 説明
割り当て済みキーワード
実行計画に割り当てられたキーワードが一覧表示されます。
自動実行計画
キーワードは、各テスト実行に適切な実行サーバーを自動的に判断するために使用されます。
手動実行計画
キーワードは、手動テスト担当者によって、テスト環境に反映するために使用されます。
詳細については、「実行サーバーにキーワードを割り当てる」を参照してください。
キーワードに一致した実行時に配置可能な実行サーバー | この実行計画のキーワード リストと一致するキーワード リストを持っている、アクティブな実行サーバーを一覧表示します。この実行計画のキーワード リストにあるキーワードはすべて、実行サーバーのキーワード リストに含まれていなければなりません。実行サーバーのリストにアクセスするには、管理 > 実行サーバー で、一覧で実行サーバーの名前をクリックします。
割り当て済みテストの排他的実行 | 排他的実行は、他の実行計画（排他的実行は無効）に割り当てられたテストが、同じ一致した実行サーバー上で同時に実行できるか（無効）、1 つの実行計画のテストだけを同時に実行できるか（有効）を定義します。排他的実行を無効にすると、必要な実行時間を減らすことがきます。これは、モバイル テストの場合では、実行計画をデバイス プロバイダ上の複数のモバイル デバイスで同時に実行できるため特に有用です。排他的実行を無効にしても、現在の実行の構成を変更する必要はありません。 詳細については、「排他的実行」を参照してください。
割り当て済みテストの分散実行 | 分散実行は、選択した実行サーバー上で実行計画のテストが順番に実行されるか（無効）、すべての一致した実行サーバーに分散して並列に実行されるか（有効）を定義します。分散実行を有効にしても、現在の実行の構成を変更する必要はありません。 詳細については、「分散実行」を参照してください。
ビデオ録画
実行計画の実行中にビデオを録画するかどうかを定義します。この設定は、実行計画に割り当て済みの個別テストのビデオ録画設定を上書きします。次の値の 1 つを選択できます。
値
説明
---
recordVideo が設定されている割り当て済みテストを除き、ビデオ録画は無効です。
行わない
recordVideo が設定されている割り当て済みテストでも、ビデオ録画は常に無効です。
常に行う
実行計画を実行するたびに結果ファイルにビデオを録画します。
エラー時のみ
実行計画の実行中にエラーが発生すると、ビデオを録画します。
詳細については、「ビデオ キャプチャ」を参照してください。
スクリーン キャプチャ
実行計画の実行中にスクリーンショットをキャプチャするかどうかを定義します。この設定は、実行計画に割り当て済みの個別テストのスクリーン キャプチャ設定を上書きします。次の値の 1 つを選択できます。
値
説明
---
captureScreen パラメータが設定されている割り当て済みテストを除き、スクリーン キャプチャは無効です。
行わない
captureScreen パラメータが設定されている割り当て済みテストでも、スクリーン録画は常に無効です。
エラー時のみ
実行計画の実行中にエラーが発生すると、スクリーンショットをキャプチャします。
詳細については、「スクリーン キャプチャ」を参照してください。
実行停止条件
テストが失敗した場合、またはテストが実行されなかった場合に、実行を停止するかどうかを定義します。この設定は、1 つのテストが失敗しただけで残りのテストを続行する意味がない場合などに特に便利です。この設定を使用すると、リソースを保存したり、テストが失敗した際に早期に通知したりできます。次の値の 1 つを選択できます。
値
説明
---
テストが未実行または失敗しても実行を続行します。
エラー時のみ
最初にテストが失敗したときに実行を停止します。
未実行時のみ
最初にテストが未実行になったときに実行を停止します。
エラーまたは未実行時
最初にテストが失敗または未実行になったときに実行を停止します。
注: 実行が停止されると、正常に実行されたテストの結果が保存されます。テスト パッケージ (すべての下位のテストとともに) は常に最後に実行されます。これらは途中で停止されることはありません。ただし、データ駆動型テストは下位のテストが失敗した時点で停止します。
Silk Test Classic AUT ホスト名

この実行計画に対して定義されている Silk Test Classic AUT ホストをすべてリストします。Silk Test Classic AUT ホストのリストを編集するには、編集 をクリックします。詳細については、「Silk Test Classic AUT ホストを追加する」を参照してください。

モバイル デバイスの選択

選択した実行計画を実行するために選択されたモバイル デバイスを一覧します。編集 をクリックして、さまざまなデバイスを選択します。デバイス プロバイダと現在のプロジェクトは、同じロケーションに割り当てられている必要があります。割り当てられていない場合は、デバイスは表示されません。詳細については、「デバイス プロバイダを管理する」を参照してください。

コード分析設定

この実行計画に対して定義されているコード分析設定の詳細を指定します。この実行計画に対してコード分析を有効または無効にするには、アクティブ/非アクティブ を切り替えます。詳細については、「コード分析」を参照してください。

親トピック: 配置環境を設定する
関連概念
ビデオ キャプチャ


手動テスト担当者の追加と削除

手動テストを含む実行計画の場合は、配置 ページで、選択されている実行計画にユーザーを手動テスト担当者として割り当てることができます。複数の手動テスト担当者を実行計画に割り当てることができます。

手動テスト担当者を実行計画に割り当てたり、選択した実行計画から削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する実行計画を選択します。
  3. 配置 タブをクリックします。
  4. 手動テスト実行 セクションにある 編集 をクリックします。 テスト担当者の追加/削除 ダイアログ ボックスが表示されます。
  5. 選択可能 リストから使用するユーザー グループを選択します。
  6. テスト担当者を追加/削除するには：
    • 選択可能 リストで 1 つ以上のユーザーを選択し、追加 または すべて追加 をクリックします。
    • 選択済み リストで 1 つ以上のユーザーを選択し、削除 または すべて削除 をクリックします。
    Ctrl + クリック または Shift + クリック を使用して複数のユーザーを選択できます。
  7. OK をクリックして、テスト担当者の追加/削除 ダイアログ ボックスを閉じます。
親トピック: 配置環境を設定する


キーワードを用いた動的ハードウェア プロビジョニング

Silk Central のハードウェア プロビジョニング技術は、多数の実行サーバーが含まれているテスト環境の管理に役立ちます。各自動実行計画に対して実行サーバーを 1 対 1 で静的に割り当てなくても、キーワードによって Silk Central は各実行計画に最適な実行サーバーを自動的に選択することができます。これは、各実行計画のキーワード リストとすべてのアクティブな実行サーバーのキーワード リストを動的に比較することで実現されます。
  • キーワードの概念
    キーワードには通常、実行環境の要件（たとえば、プラットフォーム、オペレーティング システム、インストール済みのアプリケーションなど）を記述します。実行計画を自動で実行するか、手動で実行するかによって、キーワードの利用方法は異なってきます。
  • 新しいキーワードを作成する
    実行環境を記述するために、新しいキーワードを作成します。
  • 実行計画にキーワードを割り当てる
    実行環境を記述するために、実行計画にキーワードを割り当てます。
  • 実行計画からキーワードを削除する
    キーワードにより実行環境が記述されなくなった場合に、実行計画からキーワードを削除します。
親トピック: 配置環境を設定する


キーワードの概念

キーワードには通常、実行環境の要件（たとえば、プラットフォーム、オペレーティング システム、インストール済みのアプリケーションなど）を記述します。実行計画を自動で実行するか、手動で実行するかによって、キーワードの利用方法は異なってきます。
自動実行計画
Silk Central は実行計画の実行時に、その実行計画のキーワードと使用可能なすべての実行サーバーのキーワードを比較します。そして、一致するキーワード リストを持つ実行サーバーのうち、最初に見つかったサーバーの上で実行を行います。
手動実行計画
手動実行計画の場合、手動テスト担当者がキーワードを利用して、それをテスト環境に反映させます。

ある自動実行計画を複数の実行サーバー上で実行する必要がある場合には、実行計画のコピーを作成し、他の実行サーバーと一致するキーワードをその実行計画に追加で割り当ててください。

予約済みのキーワード

自動実行計画を実行するのにハードウェア プロビジョニングが必要でない場合は、実行サーバーごとに自動的に生成される予約済みキーワードを利用することができます。そのような場合は、実行サーバーにキーワードを手動で割り当てる必要はありません。その代わりに、各実行計画に実行サーバーを 1 対 1 で静的に割り当てることができます。

新規作成された各実行サーバーには予約済みキーワードが自動的に割り当てられます。予約済みキーワードは、次の形式で構成されます：#<execution server name>@<location name>

予約済みキーワードを利用できるのは実行計画にキーワードを割り当てるときだけです。

定義済みの実行サーバーごとに自動的にセットアップされる予約済みキーワードの他に、実行サーバーの種類ごとに以下の予約済みキーワードもセットアップされます。
#PHYSICAL
実行サーバー プロビジョニングを物理実行サーバーに限定します。
#VIRTUAL
実行サーバー プロビジョニングを仮想実行サーバーに限定します。

キーワードと仮想実行サーバー

仮想実行サーバーへのキーワードの割り当ては、物理実行サーバーへの割り当てと同様です。仮想実行サーバーを少なくとも 1 つ構成すると、#VIRTUAL キーワードが動的に生成され、どの実行計画にも割り当てられるようになります。実行計画が仮想マシンで実行されるようにする場合、その実行計画には #VIRTUAL キーワードを選択します。実行計画に #VIRTUAL キーワードも #PHYSICAL キーワードも割り当てられていない場合、実行環境の設定が同じであれば、その実行は仮想実行サーバーと物理実行サーバーのどちらで行われる可能性もあります。テストのキーワードが複数の仮想実行サーバーに一致する場合は、一致する仮想実行サーバーの中で最初に見つかったものが選択されます。

フォルダの実行

実行計画は実行フォルダにまとめることができます (フォルダは実行サブフォルダと実行計画を含むことができます)。実行計画の実行に対するオプションは、実行フォルダの実行に対しても利用できます。

フォルダを実行する場合、そこに含まれるサブフォルダと実行計画は次のように扱われます。
実行されるフォルダのキーワード | 含まれる実行計画/サブフォルダのキーワード | 含まれる実行計画/サブフォルダの実行
キーワードなし | キーワードなし | キーワードのない実行計画は、実行後、[未実行] のステータスになります。
キーワードなし | キーワードあり | 実行計画/サブフォルダのキーワードに基づいて実行サーバーが割り当てられます。
キーワードあり | キーワードなし | フォルダのキーワードに基づいて実行サーバーが割り当てられます。
キーワードあり | キーワードあり | フォルダのキーワードに基づいて実行サーバーが割り当てられます。
注: フォルダを手動で実行する際に、キーワードを割り当てられていない、もしくは、割り当てられたキーワードに合う実行サーバーがない場合、これらの実行計画は、未実行としてマークされます。
親トピック: キーワードを用いた動的ハードウェア プロビジョニング


新しいキーワードを作成する

新しいキーワードを作成するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する実行計画を選択します。
  3. 配置 タブをクリックします。
  4. このページの 実行環境 セクションにある 編集 をクリックします。 キーワードの割り当て ダイアログ ボックスが表示されます。ユーザーの実行環境に対して定義されているすべてのキーワードが、そこに一覧表示されます。
    注: 各実行サーバーに対してデフォルトで予約されるキーワード #<execution server name>@<location name> がそのリストに含まれています。
  5. 実効計画に必要な環境を表す英数字のキーワードを キーワード フィールドに入力します。

    たとえば、プラットフォーム、オペレーティング システム、インストール済みのアプリケーションの名前などをキーワードに指定できます。次の文字は、キーワードに使用できません：#$?*\,;'" 。

    注: キーワードでは、大文字/小文字は区別されません。たとえば、「Vista」および「vista」は同じキーワードとして扱われます。
  6. Enter を押します。 これで新しいキーワードが、割り当てに利用できるようになりました。
親トピック: キーワードを用いた動的ハードウェア プロビジョニング


実行計画にキーワードを割り当てる

実行計画にキーワードを割り当てるには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する実行計画を選択します。
  3. 配置 タブをクリックします。
  4. このページの 実行環境 セクションにある 編集 をクリックします。 キーワードの割り当て ダイアログ ボックスが表示されます。ユーザーの実行環境に対して定義されているすべてのキーワードが、そこに一覧表示されます。
    注: 各実行サーバーに対してデフォルトで予約されるキーワード #<execution server name>@<location name> がそのリストに含まれています。
  5. キーワードの選択または入力 リストでキーワードを選択するか、新しいキーワードを直接入力します。 Ctrl + クリック または Shift + クリック で複数のキーワードを選択します。
    ヒント: キーワードの選択または入力 フィールドでは、オートコンプリート機能が有効になっています。英文字を入力すると、フィールドはその入力された文字に一致する既存のキーワードで動的に更新されます。複数のキーワードが キーワードの選択または入力 または 割り当て済みキーワード リストで選択されている場合、このフィールドは無効になります。
    ヒント: 数台の実行サーバーしかなく、ハードウェア プロビジョニングが必要ないときは、実行サーバーごとに作成されるデフォルトの予約済みキーワードを使用するだけで十分である可能性があります。その場合、新たにキーワードを選択する必要はありません。
  6. > をクリックして、キーワードを 割り当て済みキーワード リストに移動します。< をクリックして、リストからキーワードを削除します。また、キーワードをダブルクリックすると、一方のリストから別のリストにキーワードを移動することができます。
    注: 割り当てられたキーワードに一致する実行サーバーが、下の動的に更新される キーワードに一致した実行時に配置可能な実行サーバー リストに表示されます。この一覧は、キーワードを追加/削除するたびに更新されます。実行サーバーにアクセスするには、管理 > 実行サーバー で、一覧の実行サーバーの名前をクリックします。
  7. OK をクリックしてキーワードを保存し、キーワードの割り当て ダイアログ ボックスを閉じます。
親トピック: キーワードを用いた動的ハードウェア プロビジョニング


実行計画からキーワードを削除する

実行計画のキーワード割り当てを削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する実行計画を選択します。
  3. 配置 タブをクリックします。
  4. このページの 実行環境 セクションにある 編集 をクリックします。 キーワードの割り当て ダイアログ ボックスが表示されます。ユーザーの実行環境に対して定義されているすべてのキーワードが、そこに一覧表示されます。
    注: 各実行サーバーに対してデフォルトで予約されるキーワード #<execution server name>@<location name> がそのリストに含まれています。
  5. 割り当て済みキーワード リストで、不要になったキーワードを選択します。 Ctrl + クリック または Shift + クリック を使用すると、複数のキーワードを選択できます。
  6. < をクリックして、キーワードの割り当てを削除します。
  7. OK をクリックしてキーワードを保存し、キーワードの割り当て ダイアログ ボックスを閉じます。
注: 使われなくなったキーワードは、システムから自動的に削除されます。
親トピック: キーワードを用いた動的ハードウェア プロビジョニング


排他的実行

排他的実行は、他の実行計画（排他的実行は無効）に割り当てられたテストが、同じ一致した実行サーバー上で同時に実行できるか（無効）、1 つの実行計画のテストだけを同時に実行できるか（有効）を定義します。排他的実行を無効にすると、必要な実行時間を減らすことがきます。これは、モバイル テストの場合では、実行計画をデバイス プロバイダ上の複数のモバイル デバイスで同時に実行できるため特に有用です。排他的実行を無効にしても、現在の実行の構成を変更する必要はありません。

並列実行を有効化する際に留意する点は次の通りです。
  • ほとんどの Silk Central テスト タイプは並列実行をサポートしていますが、Silk Test Classic、Silk Test Classic 計画、Silk Performer はサポートしていません。
  • 同じコンピュータ上で同時に実行するテスト スクリプトが、互いに影響を与えないようにする必要があります。たとえば、共通のフォルダにデータを書き出すべきではありません。また、テスト対象アプリケーションも同時に操作できるようになっている必要があります。
  • 使用するソース管理プロファイルの 共通作業フォルダ フィールドを、空にする必要があります。この設定により、Silk Central は一時的な作業フォルダを使用します。
  • 排他的実行が有効に設定された実行計画が実行サーバー上で実行されている場合、他の実行計画は、その設定に関わらず並列に実行されることはありません。
  • 並列実行中のほかの実行計画が既にビデオを録画している場合は、ビデオを利用できません。
  • Silk Test テストの並列実行についての詳細は、次のドキュメントを参照してください。
    • Silk Test Workbench テストを並列に実行する場合
    • Silk4J テストを並列に実行する場合
    • Silk4NET テストを並列に実行する場合
親トピック: 配置環境を設定する


分散実行

分散実行は、選択した実行サーバー上で実行計画のテストが順番に実行されるか（無効）、すべての一致した実行サーバーに分散して並列に実行されるか（有効）を定義します。分散実行を有効にしても、現在の実行の構成を変更する必要はありません。

分散実行を有効化する際に留意する点は次の通りです。
  • 実行計画の個々のテストの実行時間が短い場合、分散実行を有効にしても全体の実行時間は改善されない場合があります。これは、テストのデプロイ、ソース管理、結果のフェッチなどの管理タスクのオーバーヘッドが、テストの並列実行によるメリットを上回るためです。
  • すべての Silk Central テスト タイプが分散実行をサポートしていること。
  • 他のテストが同じ実行サーバー上でコード カバレッジ情報を記録している場合は、コード カバレッジ情報の記録を利用できません。
  • 他のテストが同じ実行サーバー上でビデオを録画している場合は、ビデオを利用できません。
  • テストの 1 つに実行停止条件が設定されており、この条件に合致する場合、実行中のテストとまだ開始されていないテストのすべてが停止されます。現在実行中のテストのステータスが 失敗 になると、まだ開始されていないテストのステータスは 未実行 に設定されます。この条件を満たす前に 合格 に設定されたテストのステータスは変わりません。
  • 仮想実行サーバーは、分散実行に使用できません。
親トピック: 配置環境を設定する


自動テストのモバイル デバイスを選択する

実行計画を実行するためのモバイル デバイス（物理デバイス、エミュレータ、シミュレータ）を選択するまえに、デバイス プロバイダを設定する必要があります。デバイス プロバイダと現在のプロジェクトは、同じロケーションに割り当てられている必要があります。割り当てられていない場合は、デバイスは表示されません。詳細については、「デバイス プロバイダを管理する」を参照してください。
モバイル デバイスを選択するには：
  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、モバイル デバイスを選択する実行計画を選択します。
  3. 配置 タブをクリックします。
  4. 手動デバイスの選択 セクションにある 編集 をクリックします。 デバイスの選択 ダイアログ ボックスが表示されます。
  5. モバイル デバイス、デバイス フィルタ、またはネイティブ アプリを選択します。
    • 特定のデバイスを選択するには、右側にあるリストを使用します。
    • デバイス フィルタを選択するには、右側のリストにある 任意のデバイス を選択します。検索 フィールドと、左側にある プラットフォーム と アプリケーション リストを使用してこのフィルタを編集します。
      ヒント: エミュレータ や シミュレータ を検索する場合など、特定のデバイスの種類を検索するために、検索フィールドを使用できます。
    • テストするネイティブ アプリをモバイル デバイスにインストールするには、ネイティブ アプリ を左側にある アプリケーション リストから選択し、以下のようにアプリへの URL または UNC パスを指定します（iOS では URL が必須です）。例：\\fileserver\apps\testapp.apk
  6. 省略可能：デバイスの選択からエミュレータやシミュレータを除外したい場合は、物理デバイスのみを使用する チェック ボックスをオンにします。
  7. 省略可能：現在使用できるデバイスのみを表示したい場合は、使用中またはブロック中のデバイスを表示しない チェック ボックスをオンにします。手動テストや実行計画を直ちに実行したい場合に、この設定は役に立ちます。
  8. モバイル デバイスの選択を保存するには、OK をクリックします。
実行時に、選択したデバイス、またはフィルタに最初に意一致したデバイスが使用され、実行計画が完了するまでブロックされます。選択したデバイスが利用できない場合や、フィルタに一致する利用可能なデバイスが見つからない場合は、適切な実行サーバーおよびモバイル デバイスが利用可能になるまで、実行ジョブはキューで待機します。Sauce Labs デバイスは実際は単一のデバイスではなく、デバイスの種類であるため、実行中にブロックされることはありません。

モバイル デバイスの選択を変更したり削除する場合は、編集 ボタンや 削除 ボタンを使用します。

親トピック: 配置環境を設定する


コード分析

従来のコード カバレッジの目的は、テストでどのようなコードがカバーされるかについての情報を提供することです。このアプローチは通常、ユニット テストのコード カバレッジ情報を取得するのに用いられます。Silk Central のコード分析機能はこれをはるかに凌ぐもので、管理された環境でのユニット テスト、機能テスト、負荷テスト（自動と手動の両方）のデータを提供します。コード カバレッジ測定結果は、テスト進捗の追跡やテスト計画作業の誘導に利用されます。Silk Central の革新的なコード カバレッジ アプローチは、特定のテストとテスト対象コードの関係に基づいています。このアプローチにより、テストの観点からコード変更の影響/依存関係の分析を行うことができます。また、特定のコード変更に最も関係のあるテスト実行の特定に役立つので、テストを最適化するのに役立ちます。

コード分析 ユニットは、AUT（Applications Under Test）、パッケージ/名前空間、クラス、メソッド、およびステートメントのコード カバレッジ データを提供し、特定のコードの変更に応じて実行すべきテストを決定するテスト影響分析と、特定のコードの変更を適切にカバーするために必要な自動テストと手動テストの時間数を決定する労力分析を実行できるようにします。これらのコード分析タスクはそれぞれ、設定済みのレポートを実行することによって開始することができます。ユニットを特徴付けているものは、選択したプロジェクトに対してそれまでに作成された製品をすべて一覧表示するナビゲーション ツリーです。製品階層を展開して、特定のバージョン（最も深いレベルでは特定のビルド）を選択することができます。

  • コード分析を有効にする
    Silk Central でコード分析を有効にする方法について説明します。
  • [コード分析] の [詳細] ページ
    選択した製品、バージョン、ビルドのコードカバレッジ情報が製品、パッケージ、クラスの各レベルで表示されます。
  • 最新ビルドおよびビルド バージョン
    カバーされている最新ビルドおよび最新バージョンのカバレッジ情報を取得する方法について説明します。
  • コード変更影響度レポートを生成する
    一連のクラスをカバーするすべてのテストを確認するために、コード変更影響度レポートを生成します。
  • [レポート対象クラスの選択] ダイアログ ボックス
    レポート対象クラスの選択 ダイアログ ボックスの内容について説明します。
  • パッケージ/名前空間のコード カバレッジ情報を表示する
    パッケージ/名前空間のコード カバレッジ情報を表示する方法について説明します。
親トピック: 配置環境を設定する
親トピック: レポート


コード分析を有効にする

テスト対象アプリケーションからコード カバレッジ データを収集するように Silk Central を構成する必要があります。実行 > 詳細ビュー > 配置 にリストされた実行計画はいくつでも構成できます。
ヒント: コード カバレッジを有効化したテストだけがテスト対象アプリケーションにアクセスし、他に同時に実行されているテストがないことを確認してください。これによって、コード カバレッジ データが正しく、後で指定したテストに割り当てられることが保証されます。
  • Java コード分析オプション
    サポートされている Java バージョンのコード分析オプションについて説明します。
  • .NET コード分析
    .NET コード分析の設定について説明します。
  • 実行計画でのコード分析を有効にする
    テスト進捗を追跡するために、実行計画でのコード分析を有効にします。
親トピック: コード分析


Java コード分析オプション

AUT に Java コード分析を使用するには、Java エージェントを使用して AUT の JVM を実行する必要があります。Java Runtime Environment (JRE) バージョン 5 以降が必要です。サポートされているすべての Java バージョンについて、以下のオプションを使用できます。
オプション
説明
port=19129
省略可能：コード カバレッジ サービスのポートポートを指定していない場合、ポート 19129 が使用されます。
coveragepath=[path1],[path2], ...
エージェントがカバーする、.jar ファイルへのパスです。パスの一部に空白を含む場合は、引用符を使用する必要があります。たとえば、coveragepath="C:\Program Files\YourApplication\" です。フォルダを指定した場合、エージェントは再帰的にこのフォルダ内のすべての .class ファイルを参照します。フォルダの末尾にワイルドカードを指定した場合、エージェントはこのフォルダの .jar ファイルを参照します。カバレッジパスを指定せずに実行したエージェントは無効です。
java -javaagent:agent.jar=coveragepath=
"C:Program Files\YourApplication\" Aut.jar
includes=[package1]:[package2]:[package3]: ...
省略可能：これらのパッケージに一致するパッケージだけがカバレッジと見なされます。含まれるパッケージの指定には、ワイルドカード (*) を使用できます。
java -javaagent:agent.jar=includes=com.borland.* AUT.jar
excludes=[package1]:[package2]:[package3]: ...
省略可能：除外オプションで指定されたパッケージは、コード カバレッジでは無視されます。除外パッケージの指定には、ワイルドカード (*) を使用できます。
java -javaagent:agent.jar=includes=com.borland.*;
excludes=com.borland.internal* AUT.jar
注: 包含と除外の両方がフィルタで指定されている場合は、除外が最初に評価されます。あるクラスがフィルタの包含と除外の両方に含まれる場合、そのクラスは除外され、カバレッジ データは生成されません。filter オプションが指定されていない場合は、使用したすべてのクラスに対してカバレッジ データが生成されます。ただし、coveragepath オプションが設定されている場合は、カバレッジ パスに指定されているすべてのクラスだけがカバレッジ データ生成の対象となります。

Java コード分析の例

Windows の例：
"<java_home_directory>\bin\java" -javaagent:agent.jar=port=19129;
coveragepath=C:\dev\deploy\lib\library1.jar,C:\dev\deploy\lib\library2.jar;
includes=com.borland.*;excludes=com.borland.internal.* com.borland.MyApplication
Linux の例（二重引用符を含む）：
"<java_home_directory>/bin/java" -javaagent:agent.jar="port=19129;
coveragepath=/tmp/dev/deploy/lib/library1.jar,/tmp/dev/deploy/lib/library2.jar;
includes=com.borland.*;excludes=com.borland.internal.*" com.borland.MyApplication
親トピック: コード分析を有効にする


.NET コード分析

  • Windows コード分析フレームワークと DevPartner 分析をインストールする
    Windows コード分析フレームワークおよび DevPartner 分析のインストール方法について説明します。
  • .NET コード分析と手動テスト
    DevPartner コード カバレッジを使用するための全般的な手順について説明します。
  • .NET コード分析と自動テスト
    自動テスト用のテストを作成する方法について説明します。
  • DPAnalysis.exe の使用
    dpanalysis.exe を使用する方法について説明します。
親トピック: コード分析を有効にする


Windows コード分析フレームワークと DevPartner 分析をインストールする

このタスクを実行する前に、コード分析フレームワークがインストールされているマシン (テストするアプリケーションをホストするマシン) に、Microsoft .NET Framework 3.5 がインストールされていることを確認してください。これより古いバージョンまたは新しいバージョンの Microsoft .NET Framework とでは動作しません。

  1. テスト対象アプリケーションをホストしているマシンに移動します。
  2. Silk Central を開きます。
  3. ヘルプ > ツール に進み、Windows Code Analysis Framework をクリックします。CAFramework.exe のダウンロードのプロンプトが表示されます。CAFramework.exe には、Code Analysis Framework および DevPartner Analytics パッケージのインストールが含まれます。
    注: 同じコード分析フレームワークに対して複数のテストを同時実行する、複数実行サーバーはサポートされていません。
  4. ダウンロード ファイルをクリックして、インストールを開始します。Windows Code Analysis Framework をインストールします。インストールの終わりに、DevPartner Analytics のプロンプトが表示されます。適切なインストール画面で DevPartner Analytics Installation チェック ボックスをオンにし、このコンポーネントをインストールします。 このインストールの終了時に、すべての必要なファイルがインストールされ、適切なサービスが開始されます。サービスの名前は Silk Central Code Analysis Service です。
親トピック: .NET コード分析


.NET コード分析と手動テスト

以降のセクションでは、Silk Central に同梱されている DevPartner .NET コード カバレッジ コンポーネントのインストールおよび使用に必要な手順について説明します。次に示す例では、手動テストおよび AUT 1 つを使用して開始します。自動テストを使用する場合は、まず次の手順を読んで理解してから、「.NET コード分析と自動テスト」というトピックを参照してください。

注: Silk Central/.NET コード カバレッジ機能を使用するためには、Micro FocusDevPartner Analytics コンポーネント バージョン 11.2 以降を使用する必要があります。
注: .NET コード分析では、.NET AUT のコンパイル時に生成される PDB ファイルがAUT 実行可能ファイルと同じディレクトリに存在する必要があります。AUT の PDB ファイルが利用できない場合は、.NET コード分析の機能は使用できません。

手動テストのワークフロー

  1. AUT を起動するために DPAnalysis を設定する
    AUT を起動するために DPAnalysis を設定する方法について説明します。
  2. コード分析用に Silk Central を設定する
    コード分析用に Silk Central を設定する方法について説明します。
親トピック: .NET コード分析


AUT を起動するために DPAnalysis を設定する

  1. DPAnalysis.exe を指す .BAT ファイルを作成します。 たとえば、次のようになります。
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe" /cov /USE_AUTOMATION_INTERFACE
/W "C:\Common\Development\MYAPP"
/P "C:\Common\Development\MYAPP\MyApp.exe"
  2. 上記の例では、読みやすくするために複数の行に分けられています。 作成する .BAT ファイルは 1 行にする必要があります。 次のように変更します。
    1. 1 行目が dpanalysis.exe へのインストール パスになるようにします。 スイッチ 2 つは必須です。
    2. 2 行目には、必須のスイッチが含まれ、実行可能ファイルおよび PDB へのパスを含める必要があります。
    3. 3 行目には、必須のスイッチが含まれ、テスト アプリケーションへの絶対パスおよびアプリケーション名を含める必要があります。
  3. .BAT ファイルをダブルクリックして、DPAnalysis にアプリケーションを起動させます。
DPAnalysis.exe の実行の詳細については、「DpAnalysis.exe の使用」というトピックを参照してください。 このトピックおよび関連トピックには、追加スイッチ、および複数のテスト対象アプリケーションがある場合の設定ファイルの使用方法についての情報が記載されています。
親トピック: .NET コード分析と手動テスト
次のトピック: コード分析用に Silk Central を設定する
関連概念
DPAnalysis.exe の使用


コード分析用に Silk Central を設定する

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. AUT の機能をテストするステップのある手動テストを含む既存の実行計画を開きます。
  3. 配置 タブをクリックします。
  4. コード分析設定 で、編集 をクリックして コード分析設定の編集 ダイアログ ボックスを表示します。
  5. コード分析を有効にする がオンになっていることを確認します。
  6. コード分析プロファイル リストから DevPartner .NET コード分析 を選択します。
  7. ホスト名 フィールドに、ホスト名、コロン、ポート番号の順に入力します。 たとえば、localhost:19129 などです。

    コード分析フレームワークのデフォルト ポートは 19129 です。 xml ファイルを使用すると、指定したポートでコード分析フレームワークが実行されるように設定できます。<install dir>\Code Analysis\CodeAnalysisConfig.xml

  8. OK をクリックします。
  9. 実行 領域の 実行 をクリックしてテストを実行します。
  10. 実行 ダイアログ ボックスで、すべてのテスト がオンになっていることを確認します。
  11. 実行計画に対するビルドの設定 で、実行計画の適切なビルドを選択します。
  12. OK をクリックします。
親トピック: .NET コード分析と手動テスト
前のトピック: AUT を起動するために DPAnalysis を設定する


.NET コード分析と自動テスト

このセクションでは、コード カバレッジを使用するテストを実行したときに発生する可能性がある 2 つのシナリオについて説明します。また、実行計画内でテストを作成するための適切な方法についても説明します。以下のトピックで取り上げる例は、DevPartner コード分析のものですが、構造は他のコード分析ツールでも同様です。たとえば、実行計画のセットアップ/クリーンアップ パラメータが異なるだけです。

注: AUT の開始とコード分析の開始のタイミングにズレがあるため、AUT の最初に実行されるコード部分が、コード分析によって記録されない場合があります。

自動テストのワークフロー

  • 1 つの AUT に対して 1 つまたは複数のテストを設定する
    1 つの実行計画内に 1 つまたは複数のテストがあり、1 つのテスト対象アプリケーション (AUT) に対してテストを実行するシナリオの場合、ここで説明されているようにテストを作成します。
  • 複数の AUT に対して 1 つまたは複数のテストを設定する
    1 つの実行計画内に 1 つまたは複数のテストがあり、複数のテスト対象アプリケーション (AUT) に対してテストを実行するシナリオの場合、ここで説明されているようにテストを作成します。
親トピック: .NET コード分析
関連タスク
ProcessExecutor テストを作成または編集する


1 つの AUT に対して 1 つまたは複数のテストを設定する

1 つの実行計画内に 1 つまたは複数のテストがあり、1 つの AUT に対してテストを実行するシナリオの場合、次のようにテストを作成します。

  1. コード分析アプリケーションを起動する ProcessExecutor テストを作成します。 ProcessExecutor の 引数リスト には、開始するコード分析プログラムを指定します。 たとえば、start cmd /c start cmd /c D:\sctm\dps\startDPS_Simple1.bat です。startDPS_Simple1.bat には以下が含まれます。
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe"
/cov
/USE_AUTOMATION_INTERFACE
/O "D:\SCTM\temp"
/W "D:\SCTM\DPS\TESTAPP\SCTMCodeAnalysisTestApp\bin\Debug"
/P "D:\SCTM\DPS\TESTAPP\SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe"
  2. 実行計画を作成します。
  3. 実行 > 詳細ビュー をクリックし、実行計画を選択して、セットアップ/クリーンアップ タブをクリックします。
  4. 作成済みのテストを セットアップ用テスト として追加します。
  5. 自動テスト ツールを使用して AUT を自動化する実行計画にテストを追加します。
  6. 省略可能：自動テスト ツールを使用して AUT を自動化する実行計画に別のテストを追加します。
  7. ProcessExecutor テストを作成します。
  8. 実行 > 詳細ビュー をクリックし、実行計画を選択して、セットアップ/クリーンアップ タブをクリックします。
  9. 作成済みのテストを クリーンアップ用テスト として追加します。
ProcessExecutor 引数リスト には、プログラムを終了させるために、次のように指定します: start cmd /c taskkill /IM SCTMCodeAnalysisTestApp.exe
親トピック: .NET コード分析と自動テスト


複数の AUT に対して 1 つまたは複数のテストを設定する

1 つの実行計画内に 1 つまたは複数のテストがあり、複数の AUT に対してテストを実行するシナリオの場合、次のようにテストを作成します。

  1. コード分析アプリケーションを起動する ProcessExecutor テストを作成します。 ProcessExecutor の 引数リスト には、開始するコード分析プログラムを指定します。 たとえば、start cmd /c start cmd /c D:\sctm\dps\two_app_dps.cmd です。two_app_dps.cmd には以下が含まれます。
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe"
/config D:\SCTM\DPS\configuration_file.xml
    configuration_file.xml には以下が含まれます。
    <?xml version="1.0" ?>
<ProductConfiguration>
    <RuntimeAnalysis Type="Coverage" MaximumSessionDuration="1000" NoUIMsg="true" />
    <Targets RunInParallel="true">
        <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NM_USE_AUTOMATION_INTERFACE="1" >
            <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
            <Path>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
          SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe</Path>
            <Arguments></Arguments>
            <WorkingDirectory>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug</WorkingDirectory>
        </Process>
        <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" >
            <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
            <Path>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\
         QADSCTMMigration\bin\QADSCTMMigration.exe</Path>
            <Arguments></Arguments>
            <WorkingDirectory>D:\SourceCode\SVNQAD\Development\Development\
         SOURCECODE\QADSCTMMigration\bin</WorkingDirectory>
        </Process>
    </Targets>
</ProductConfiguration>
  2. 実行計画を作成します。
  3. 実行 > 詳細ビュー をクリックし、実行計画を選択して、セットアップ/クリーンアップ タブをクリックします。
  4. 作成済みのテストを セットアップ用テスト として追加します。
  5. 自動テスト ツールを使用して最初の AUT を自動化する実行計画にテストを追加します。
  6. 自動テスト ツールを使用して 2 つ目の AUT を自動化する実行計画に別のテストを追加します。
  7. ProcessExecutor テストを作成します。
  8. 実行 > 詳細ビュー をクリックし、実行計画を選択して、セットアップ/クリーンアップ タブをクリックします。
  9. 作成済みのテストを クリーンアップ用テスト として追加します。
ProcessExecutor 引数リスト には、プログラムを終了させるために、次のように指定します: start cmd /c taskkill /IM application1.exe /IM Application2.exe
親トピック: .NET コード分析と自動テスト


DPAnalysis.exe の使用

DPAnalysis.exe は、.NET アプリケーションをプロファイルできる DevPartner コード カバレッジ アプリケーションです。 このアプリケーションはコマンドラインを使用して起動します。

このトピックなどに記述されている従来のスイッチを指定して使用したり、さらに設定ファイルを指定するスイッチを追加したりできます。 設定ファイルは、コマンドライン文字列が非常に長い場合、または単一のセッションで複数のアプリケーションを実行する場合に使用できます。

/USE_AUTOMATION_INTERFACE スイッチは必須です。 このスイッチにより、フレームワークと情報をやり取りするために必要な自動インターフェイス環境が確立されます。 また、ライセンスのチェックも省略されます。 このスイッチにパラメータはありません。

  • コマンドラインからの DPAnalysis.exe の実行
    コマンドラインから dpanalysis.exe を実行する方法について説明します。
親トピック: .NET コード分析


コマンドラインからの DPAnalysis.exe の実行

DevPartner Studio コード カバレッジ インストール環境には、\Program Files\Micro Focus\DevPartner Studio\Analysis\ ディレクトリにインストールされるコマンドライン実行可能ファイル DPAnalysis.exe が含まれています。

コマンドラインから DevPartner Studio コード カバレッジ ツールを実行するには、次の構文およびスイッチを使用します。

DPAnalysis  [/Cov] [/USE_AUTOMATION_INTERFACE] [/E|/D|/R]
[/W workingdirectory] [/PROJ_DIR] [/H hostmachine]
[/NOWAIT] [/NO_UI_MSG] [/N] [/F] [/A C:\temp1;C:\temp2]
[/NO_QUANTUM /NM_METHOD_GRANULARITY /EXCLUDE_SYSTEM_DLLS
/NM_ALLOW_INLINING /NO_OLEHOOKS /NM_TRACK_SYSTEM_OBJECTS]
{/P|/S} target [target arguments]

例

分析セッションを開始するスイッチを使用すると、コマンドラインから DPAnalysis.exe を直接使用できます。 たとえば、次のコマンドラインによって、アプリケーション SCTMCodeAnalysisTestApp.exe のコード カバレッジ セッションが開始されます。

dpanalysis.exe /cov /USE_AUTOMATION_INTERFACE /W "D:\SCTM\DPSCoverageIntegration\Test App\
SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\bin\Debug" /P
"D:\SCTM\DPSCoverageIntegration\Test App\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\bin
\Debug\SCTMCodeAnalysisTestApp.exe"
  • スイッチ
    dpanalysis のコマンドライン スイッチについて説明します。
  • DPAnalysis 設定ファイル
    dpanalysis の設定ファイル オプションについて説明します。
親トピック: DPAnalysis.exe の使用


スイッチ

  • 分析タイプ スイッチ
    分析タイプ スイッチについて説明します。
  • データ収集スイッチ
    dpanalysis のデータ収集スイッチについて説明します。
  • その他のスイッチ
    DPAnalysis.exe の他の省略可能なスイッチについて説明します。
  • 分析オプション
    分析オプションについて説明します。
  • 対象スイッチ
    dpanalysis.exe の対象スイッチについて説明します。
親トピック: コマンドラインからの DPAnalysis.exe の実行


分析タイプ スイッチ

名前 | 説明
/Cov[erage] | 分析タイプを DevPartner カバレッジ分析に設定します。
注: DPAnalysis.exe ではアンマネージド コードはインストゥルメントされません。 アンマネージド アプリケーションのパフォーマンス分析データまたはカバレッジ分析データを収集するには、最初にアプリケーションをインストゥルメントする必要があります。
親トピック: スイッチ


データ収集スイッチ

指定した対象のデータ収集を有効または無効にしますが、対象の起動は行いません。 省略可能。

名前 | 説明
/E[nable] | 指定したプロセスまたはサービスのデータ収集を有効にします。
/D[isable] | 指定したプロセスまたはサービスのデータ収集を無効にします。
/R[epeat] | /D スイッチを使用してプロファイリングを無効にするまで、指定したプロセスを実行するたびにプロファイリングが行われます。
親トピック: スイッチ


その他のスイッチ

これらのスイッチは省略可能です。

名前 | 説明
/W[orkingDir] | 対象プロセスまたは対象サービスの作業ディレクトリを指定します。
/PROJ_DIR | プレイリストの検索などに使用する、DevPartner Studio プロジェクトのディレクトリを指定します。
/N[ewconsole] | 専用のコマンド ウィンドウ内でプロセスを実行します。 DPAnalysis.exe を使用して、キーボード入力が必要なコンソール アプリケーションを分析する場合は、/NewConsole スイッチを使用して、入力できるコンソール ウィンドウを開く必要があります。
/INCLUSION_FILTER <filterFile>

/INCLUSION_FILTER スイッチは省略可能です。このスイッチを使用すると、包含フィルタ ファイルを指定できます。 このファイルは、カバレッジ データが Silk Central 固有の XML 形式でフレームワークに提供される場合に使用されます。 このスイッチによって、フィルタ ファイル内で指定されていないすべてのクラスが、レポート生成プログラムから除外されます。 このスイッチは単一のパラメータを取ります (次を参照)。

/INCLUSION_FILTER <filterFile>

ここで、<filterFile> はプログラム実行中に使用するフィルタ ファイルの完全修飾パスです。

次のサンプル Inclusion_Filter ファイルは、生成されるレポートに記載される一連のクラスを定義した簡単な XML ファイルです。 また、このファイルには <filterClasses> の値が含まれており、この値によってフィルタを適用するかどうかを指定します。

<!--D:\Public\SCTM Work\ProdAPI_Tester_CSharp_LINES.dpcov-->
<inclusionInfo>
  <filterClasses>false</filterClasses>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_MsgStream</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_RecvTask</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_TimeStamp</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_Tracer</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CMsgRegisterClientReqMB</includedClass>
</inclusionInfo>
/A[ssembly_dir] | カバレッジ分析専用。 参照される DLL/PDB ファイルを含むパスのリスト。 このスイッチを使用して、参照される DLL/PDB ファイルのうち、ロードされていないファイルを指定し、カバレッジ セッション ファイルに表示します。 複数のパスはセミコロン (;) で区切ります。
親トピック: スイッチ


分析オプション

分析オプションの例は次のとおりです。

<AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
列 | タイプ
/NM_USE_AUTOMATION_INTERFACE | 設定ファイルの分析オプション セクションの必須スイッチ。 値は必ず「1」とします。
/NO_QUANTUM | 他のスレッドで費やされた除外時間を無効にします。
/NM_ALLOW_INLINING | インライン メソッドの実行時インストゥルメントを有効にします（カバレッジおよびパフォーマンスのみ）。
/NO_OLEHOOKS | COM の収集を無効にします。
親トピック: スイッチ


対象スイッチ

追跡する対象は、プロセスまたはサービスのいずれかとして指定します。 必須。 1 つのみ選択します。 対象名またはパスに続くすべての引数が、その対象に対する引数となります。

名前 | 説明
/P[rocess] | 対象プロセスを指定します（続けてプロセスの引数を指定）。
/S[ervice] | 対象サービスを指定します（続けてサービスの引数を指定）。
/C[onfig] | 設定ファイルのパス。
親トピック: スイッチ
関連概念
DPAnalysis 設定ファイル


DPAnalysis 設定ファイル

XML 設定ファイルを使用して分析セッションを管理するには、/config スイッチおよび適切な構造を持つ XML 設定ファイルを対象に指定して、コマンドラインから DPAnalysis.exe を実行します。 例：

dpanalysis.exe /config c:\temp\configuration_file.xml

設定ファイルを使用すると、複数のプロセスまたはサービスをプロファイルおよび管理できます。 複数のプロセスをプロファイルする機能は、Web アプリケーションを分析する場合に特に有効です。

サンプル設定ファイル

<?xml version="1.0" ?>
<ProductConfiguration>
  <RuntimeAnalysis Type="Coverage" MaximumSessionDuration="1000" NoUIMsg="true" />
     <Targets RunInParallel="true">
          <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NM_USE_AUTOMATION_INTERFACE="1" >
               <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
               <Path>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe</Path>
               <Arguments></Arguments>
               <WorkingDirectory>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug</WorkingDirectory>
          </Process>
          <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" >
               <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
               <Path>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\QADSCTMMigration\bin\QADSCTMMigration.exe</Path>
               <Arguments></Arguments>
               <WorkingDirectory>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\QADSCTMMigration\bin</WorkingDirectory>
          </Process>
     </Targets>
</ProductConfiguration>
  • AnalysisOptions 要素
    dpanalysis.exe 設定ファイルの analysisoptions 要素について説明します。
  • Arguments 要素
    dpanalysis.exe 設定ファイルの arguments 要素について説明します。
  • ExcludeImages 要素
    dpanalysis.exe 設定ファイルの excludeimages 要素について説明します。
  • Host 要素
    dpanalysis.exe 設定ファイルの host 要素について説明します。
  • Name 要素
    dpanalysis.exe 設定ファイルの name 要素について説明します。
  • Path 要素
    dpanalysis.exe 設定ファイルの path 要素について説明します。
  • Process 要素
    dpanalysis.exe 設定ファイルの process 要素について説明します。
  • RuntimeAnalysis 要素
    dpanalysis.exe 設定ファイルの runtimeanalysis 要素について説明します。
  • Service 要素
    dpanalysis.exe 設定ファイルの service 要素について説明します。
  • Targets 要素
    dpanalysis.exe 設定ファイルの targets 要素について説明します。
  • WorkingDirectory 要素
    dpanalysis.exe 設定ファイルの workingdirectory 要素について説明します。
親トピック: コマンドラインからの DPAnalysis.exe の実行


AnalysisOptions 要素

AnalysisOptions で使用する属性は、実行する分析セッションのタイプによって異なります。

注: DPAnalysis.exe では、分析のタイプと一致しない属性を無視します。
<AnalysisOptions
    SESSION_DIR = "c:\MyDir"
    SESSION_FILENAME = "myfile.dpcov"
    NM_METHOD_GRANULARITY = "1"
    EXCLUDE_SYSTEM_DLLS = "1"
    NM_ALLOW_INLINING = "1"
    NO_OLEHOOKS = "1"
    NM_TRACK_SYSTEM_OBJECTS = "1"
 NO_QUANTUM="1"
    NO_MACH5 = "1"
    FORCE_PROFILING = "1"
 ASSEMBLY_DIR = "C:\TEMP1;C:\TEMP2"
/>

SESSION_DIR

省略可能。 カバレッジ、メモリ、パフォーマンス、およびパフォーマンス エキスパートで使用します。 プロファイルの対象によって生成されるセッション ファイルを保存するディレクトリを指定します。 この属性がない場合、生成されるセッション ファイルはユーザーの My Documents ディレクトリに配置されます。 SESSION_DIR および SESSION_FILENAME の両方がない場合、DPAnalysis.exe はセッションの最後に保存場所の入力を要求します。

SESSION_FILENAME

省略可能。 カバレッジ、メモリ、パフォーマンス、およびパフォーマンス エキスパートで使用します。 この対象によって生成されるセッション ファイルのセッション名を指定します。 この属性がない場合、DPAnalysis.exe は対象のイメージ名と番号を組み合わせて一意の名前を作成します（iexplore1.dpprf など）。 ディレクトリを指定せずに名前を指定した場合、ファイルはユーザーの My Documents ディレクトリに配置されます。 SESSION_FILENAME および SESSION_DIR の両方がない場合、DPAnalysis.exe はセッションの最後に保存場所の入力を要求します。

NM_METHOD_GRANULARITY

省略可能。 パフォーマンスで使用し、データ収集粒度をメソッドレベルに設定します（デフォルトは行レベル）。 属性を設定するには、1 の値を指定します。 この属性を省略すると、属性が無効になります。

EXCLUDE_SYSTEM_DLLS

省略可能。 パフォーマンスで使用し、システム イメージを除外します。 属性を設定するには、1 の値を指定します。 この属性を省略すると、属性が無効になります。

NM_ALLOW_INLINING

省略可能。 カバレッジおよびパフォーマンスで使用し、分析詳細のレベルを指定します。 インライン メソッドの実行時インストゥルメントを有効にします。 インライン関数をインストゥルメントする プロパティと同じです。 インライン関数をインストゥルメントするには、1 の値を指定します。 この属性を無効にするには、属性を省略します。

NO_OLEHOOKS

省略可能。 パフォーマンス分析で使用し、システム オブジェクトの追跡を有効化します。 属性を設定するには、1 の値を指定します。 この属性を省略すると、属性が無効になります。

NM_TRACK_SYSTEM_OBJECTS

省略可能。 メモリ分析で使用し、割り当てオブジェクトを追跡する場合に、システム オブジェクトまたはサードパーティ オブジェクトの割り当てを無視します。 属性を設定するには、1 の値を指定します。 この属性を省略すると、属性が無効になります。 デフォルトの状態（無効）では、アプリケーションがシステム リソースまたはプロファイルされていない他のリソースを使用する場合に行われるメモリ割り当てを確認できます。

NO_QUANTUM

省略可能。 パフォーマンス分析およびパフォーマンス エキスパート分析で使用し、他の実行中アプリケーションのスレッドで費やされた時間を除外します。 属性を設定するには、1 の値を指定します。 この属性を省略すると、属性が無効になります。

FORCE_PROFILING

省略可能。 パフォーマンス分析およびカバレッジ分析で使用し、マネージドコードまたは DevPartner Native C/C++ Instrumentation なしで記述されたアプリケーションのプロファイルを強制します。 属性を設定するには、1 の値を指定します。 この属性を省略すると、属性が無効になります。

ASSEMBLY_DIR

省略可能。 カバレッジ分析で使用し、カバレッジ セッション ファイルに表示する、参照済みで未ロードのアセンブリを含む絶対パスを指定します。 複数のロケーションはセミコロンで区切ります。 この属性を省略すると、属性が無効になります。

要素情報

出現回数
Process または Service ごとに 0 または 1 回
親要素
Process、Service
内容
なし

備考

省略可能。 指定した対象プロセスまたは対象サービスの実行時属性を定義します。 Visual Studio の [プロパティ] ウィンドウからアクセス可能な DevPartner の [カバレッジ]、[メモリ]、および [パフォーマンス] の各プロパティに対応する属性。

例

次に、Service 内で AnalysisOptions を使用する構造の例を示します。

<Service CollectData="true">
  <AnalysisOptions NM_METHOD_GRANULARITY="1" EXCLUDE_SYSTEM_DLLS="1" NM_ALLOW_INLINING="1"
  NO_OLEHOOKS="1" ASSEMBLY_DIR="C:\TEMP">
</Service>
親トピック: DPAnalysis 設定ファイル


Arguments 要素

構文

<Arguments>/arg1 /arg2 /arg3</Arguments>

属性

なし

要素情報

出現回数
Process または Service ごとに 0 または 1 回
親要素
Process、Service
内容
なし

備考

省略可能。 省略した場合のデフォルトはありません。 対象プロセスまたは対象サービスに渡される引数。

例

次に、Process 要素内で Arguments を使用する例を示します。

<Process CollectData="true">
 <Arguments>/arg1 /agr2 /arg3</Arguments>
</Process>
親トピック: DPAnalysis 設定ファイル


ExcludeImages 要素

構文

<ExcludeImages>
  <Image>ClassLibrary1.dll</Image>
  <Image>ClassLibrary2.dll</Image>
</ExcludeImages>

属性

なし

要素情報

出現回数
Process または Service ごとに 0 または 1 回
親要素
Process、Service
内容
Image

備考

省略可能。 省略した場合のデフォルトはありません。 イメージのリストを少なくとも 1 つ指定します（最大数なし）。対象プロセスまたは対象サービスがこのリストに含まれるイメージをロードしても、イメージのプロファイルは行われません。

例

次に、Process 要素内で ExcludeImages を使用する構造の例を示します。 Image 要素が ExcludeImages 内に含まれていることに注意してください。

<Process CollectData="true">
 <ExcludeImages>
   <Image>ClassLibrary1.dll</Image>
   <Image>ClassLibrary2.dll</Image>
 </ExcludeImages>
</Process>
親トピック: DPAnalysis 設定ファイル


Host 要素

構文

<Host>hostmachine</Host>

属性

なし

要素情報

出現回数
Process または Service ごとに 0 または 1 回
親要素
Process、Service
内容
ホスト マシンの名前

備考

省略可能。 省略した場合のデフォルトはありません。 対象プロセスまたは対象サービスのホスト マシンを設定します。

例

次に、Service 内で Host を使用する構造の例を示します。 この例には、必須の Name 要素が含まれていることに注意してください。

<Service CollectData="true">
  <Name>ServiceApp</Name>
  <Host>remotemachine</Host>
</Service>
親トピック: DPAnalysis 設定ファイル


Name 要素

構文

<Name>MyServiceName</Name>

属性

なし

要素情報

出現回数
1
親要素
Service
内容
サービス名

備考

必須。 サービス制御マネージャに登録されたサービスの名前。 この名前は、システムの NET START コマンドに使用する名前と同じです。

例

次に、Service 内で Name を使用する構造の例を示します。

<Service CollectData="true">
 <Name>ServiceApp</Name>
</Service>
親トピック: DPAnalysis 設定ファイル


Path 要素

構文

<Path> c:\MyDir\target.exe </Path>

属性

なし

要素情報

出現回数
1
親要素
Process
内容
実行可能ファイルのパス

備考

必須。 実行可能ファイルの完全修飾パスまたは相対パスを指定します。 実行可能ファイルが現在のディレクトリに存在する場合は、パスなしで実行可能ファイル名を指定できます。

例

次に、Process 要素内で Path を使用する構造の例を示します。

<Process CollectData="true">
  <Path>ClientApp.exe</Path>
</Process>
親トピック: DPAnalysis 設定ファイル


Process 要素

構文

<Process CollectData="true or false"
   Spawn="true or false"
      NoWaitForCompletion="true or false"
      NewConsole="true or false"
   RepeatInjection="true or false"> ...
</Process>

属性

/D スイッチを使用してプロファイリングを無効にするまで、指定したプロセスを実行するたびにプロファイリングが行われます。

CollectData
省略可能。 true または false を指定します。 省略した場合はデフォルトで true に設定されます。 対象プロセスのプロファイリングを有効にするかどうかを指定します。
Spawn
省略可能。 true または false を指定します。 省略した場合はデフォルトで true に設定されます。 指定された対象を、DPAnalysis.exe が生成するかどうかを指定します。 aspnet_wp.exe または w3wp.exe については true に設定しないでください。 DevPartner は ASP.NET ワーカー プロセスを直接生成できません。 ASP.NET ワーカー プロセスは対象 Web ページを開いて起動します。
NoWaitForCompletion
省略可能。 true または false を指定します。 省略した場合はデフォルトで false に設定されます。 デフォルトの場合は、プロセスが完了するまで待機します。 true に設定すると、DPAnalysis.exe は対象が実行を開始するまでのみ、待機します。 DPAnalysis.exe は（Host 要素を使用した）リモート マシン上のプロセスを待機しません。 RuntimeAnalysis 要素の MaximumSessionDuration 属性は NoWaitForCompletion より優先されます。
NewConsole

省略可能。 true または false を指定します。 省略した場合はデフォルトで false に設定されます。 DPAnalysis.exe は自身のコンソール ウィンドウ内で対象を実行します。 デフォルトの場合は、DPAnalysis.exe コマンドラインを入力したコンソールと同じコンソールが使用されます。 DPAnalysis.exe を使用して、キーボード入力が必要なコンソール アプリケーションを分析する場合は、/NewConsole スイッチを使用して、入力できるコンソール ウィンドウを開く必要があります。

RepeatInjection
省略可能。 true または false を指定します。 省略した場合はデフォルトで false に設定されます。 明示的に false を指定するまで、対象が実行されるたびに DPAnalysis.exe は対象をプロファイルします。

要素情報

出現回数
1 回以上
親要素
Target
内容
AnalysisOptions、Path、Arguments、WorkingDirectory、ExcludeImages

備考

対象の実行可能ファイルを指定します。

例

次に、Process を使用する構造の例を示します。この例には、AnalysisOptions、Path、Arguments、および WorkingDirectory の各タグが含まれています。

<Targets RunInParallel="true">
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NewConsole="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>ClientApp.exe</Path>
    <Arguments>/arg1 /agr2 /arg3</Arguments>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
</Targets>
親トピック: DPAnalysis 設定ファイル


RuntimeAnalysis 要素

構文

<RuntimeAnalysis Type="Coverage" NoUIMsg="false"
NM_INCLUSION_FILTER="Q:\AppDir\InclusionFilter.xml">

属性

タイプ
必須：指定可能な選択肢は Performance、Coverage、Memory、または Expert です。 一覧表示されるすべての対象の分析タイプを指定します。
MaximumSessionDuration

省略可能：省略した場合のデフォルトはありません。 指定した場合、DPAnalysis.exe はセッションの実行をこの期間に制限します。 たとえば、MaximiumSessionDuration="60" を指定してからサービスのプロファイリングを開始した場合 (サービスには RestartAtEndOfRun="true" を指定)、60 秒後に DPAnalysis.exe はサービスを停止して再起動します。

NoUIMsg

省略可能：省略した場合はデフォルトで false が使用されます。 true に設定すると、DPAnalysis.exe はセッション期間中に表示される UI エラー メッセージをすべて抑制します。 この属性を true に設定すると、セッションを無人実行する場合、または数多くのテストを連続で実行する場合に有効です。

NM_INCLUSION_FILTER

省略可能：Inclusion Filter ファイルの指定を可能にします。 このファイルは、カバレッジ データが Silk Central 固有の XML 形式でフレームワークに提供される場合に使用されます。 このスイッチによって、フィルタ ファイル内で指定されていないすべてのクラスが、レポート生成プログラムから除外されます。 このスイッチは単一のパラメータを取ります。

要素情報

出現回数
1
親要素
ProductConfiguration.
内容
なし

備考

必須。 分析のタイプおよび最大セッション時間を定義します。

例

次に、ProductConfiguration タグに続けて RuntimeAnalysis を使用する構造の例を示します。 この例では、Type 属性にパフォーマンス分析が指定され、最大期間が 1000 秒、および UI エラー メッセージを抑制するように設定されています。

<?xml version="1.0" ?>
<ProductConfiguration xmlns="http://www.microfocus.com/products">
<RuntimeAnalysis Type="Performance" MaximumSessionDuration="1000" NoUIMsg="true"/>
親トピック: DPAnalysis 設定ファイル


Service 要素

構文

<Service
      CollectData = "true or false"
      Start = "true or false"
      RestartIfRunning = "true or false"
      RestartAtEndOfRun = "true or false"
      RepeatInjection = "true or false"
      >
      ...
</Service>

属性

CollectData
省略可能。 true または false を指定します。 省略した場合はデフォルトで true に設定されます。 対象サービスのプロファイリングを有効にするかどうかを指定します。
Start

省略可能。 true または false を指定します。 省略した場合はデフォルトで true に設定されます。 指定された対象を、DPAnalysis.exe が起動するかどうかを指定します。 false に設定すると、この対象のプロファイリングは有効になりますが、対象は起動されません。プロファイリングが開始されるのは、サービスが次回起動したときになります（起動方法は問わず）。

RestartIfRunning

省略可能。 true または false を指定します。 省略した場合はデフォルトで false に設定されます。 RestartIfRunning を true に設定すると、指定したサービスがホスト コンピュータ上で動作している場合、DPAnalysis.exe はそのサービスの再起動を試みます。

RestartAtEndOfRun
省略可能。 true または false を指定します。 省略した場合はデフォルトで false に設定されます。 true を指定すると、DPAnalysis.exe は実行の最後に（セッション ファイルを生成して）サービスの再起動を試みます。 このサービスが、プロファイルされる唯一のプロセスである場合は、この属性を false に設定します。
RepeatInjection
省略可能。 true または false を指定します。 省略した場合はデフォルトで false に設定されます。 明示的に false を指定するまで、対象が実行されるたびに DPAnalysis.exe は対象をプロファイルします。

要素情報

出現回数
設定ファイルには少なくとも 1 つの Process 要素または 1 つの Service 要素が含まれている必要があります。
親要素
Targets
内容
AnalysisOptions、Path、Arguments、Working Directory、ExcludeImages、Name、Host

備考

対象サービスを指定します。

例

次に、Targets 要素内で Service を使用する構造の例を示します。

<Targets RunInParallel="true">
  <Service CollectData="true" Start="true" RestartIfRunning="true" RestartAtEndOfRun="true">
  <Name>ServiceApp</Name>
  </Service>
</Targets>
親トピック: DPAnalysis 設定ファイル


Targets 要素

構文

<Targets RunInParallel="true or false">   ...
</Targets>

属性

RunInParallel

省略可能。 true または false を指定します。 省略した場合はデフォルトで true に設定されます。 複数の対象を指定する場合は、対象の実行方法を定義します。 RunInParallel が true の場合、DPAnalysis は対象プロセスおよび対象サービスを連続して起動します。複数の対象が同時に実行されます（並列）。 false の場合、DPAnalysis はプロセス N が起動して終了した後にのみ、対象 N + 1 を起動します。一度に 1 つの対象が実行されます（逐次）。

要素情報

出現回数
1
親要素
RuntimeAnalysis
内容
Process、Service

備考

必須。 1 つまたは複数の <Process> エントリまたは <Service> エントリのブロックを開始します。 対象プロセスおよび対象サービスは、設定ファイルに表示されている順序で起動します。

例

次に、Targets を使用して 1 つの <Service> 要素および 2 つの <Process> 要素の分析を指定する構造の例を示します。 RunInParallel が true なので、この例では対象が並列に実行されることに注意してください。

<Targets RunInParallel="true">
  <Service CollectData="true" Start="true">
    <AnalysisOptions NM_METHOD_GRANULARITY="0" EXCLUDE_SYSTEM_DLLS="1" />
                <Name>ServiceApp</Name>
                <Host>remotemachine</Host>
  </Service>
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>ClientApp.exe</Path>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>TestApp02.exe</Path>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
</Targets>
親トピック: DPAnalysis 設定ファイル


WorkingDirectory 要素

構文

<WorkingDirectory> c:\MyWorkingDir </WorkingDirectory>

属性

なし

要素情報

出現回数
Process または Service ごとに 1 回
親要素
Process、Service
内容
対象ディレクトリへのパス

備考

省略可能。 省略した場合のデフォルトはありません。 対象プロセスまたは対象サービスの作業ディレクトリを設定します。

例

次に、親 Process 要素の入れ子にして WorkingDirectory を使用する構造の例を示します。

<Process CollectData="true">
<WorkingDirectory>c:\temp</WorkingDirectory>
</Process>
親トピック: DPAnalysis 設定ファイル


実行計画でのコード分析を有効にする

実行計画でのコード分析を有効にするには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 ツリーで、実行計画を選択します。
  3. 配置 タブをクリックします。
  4. 配置 ページの コード分析設定 セクションで、編集 をクリックします。 コード分析設定の編集 ダイアログ ボックスが表示されます。
  5. コード分析を有効にする チェック ボックスをオンにします。
  6. コード分析プロファイル リスト ボックスからプロファイルを選択します。
  7. ホスト名 フィールドに、コード分析情報を収集するホスト名 (デフォルト ポート 19129 を使用しない場合は、ポートを付けて) のカンマ区切りリストを入力します。

    例：labmachine1, labmachine2:8000, 198.68.0.1。実行計画ごとに、AUT が実行しているマシン リソースのホスト名を定義する必要があります。たとえば、クライアント/サーバー システムでは、クライアント（たいていは実行サーバーで直接実行されている）のコード カバレッジ情報を収集するだけでなく、サーバー（別のマシンで実行されている可能性のある）からもデータを収集する必要があります。このことは、すべてのマルチタイヤ アプリケーションに該当します。

    注: JUnit コード分析の実行の場合は、ホスト名を指定する必要はありません。
  8. OK をクリックして、設定を保存します。
注: 実行計画に対してコード分析を定義すると、それ以降に実行計画を実行するたびに、定義されているホスト名からコード カバレッジ情報が収集されます。アクティビティ ページで実行を監視していると、Silk Central がテストのソースを収集した後でテスト実行を開始する前にコード カバレッジの完全な情報を収集するのがわかります。実行中は、各 Silk Central 実行サーバーに統合されているコード カバレッジ コントローラが、定義されているすべてのホストを制御します。実行計画のテストごとに、コントローラは、すべての関連するインスタンスを開始および停止し、テストに対する XML ベースのコード カバレッジ ファイルを収集して、結果を 1 つのファイルにマージします。その後、テストは、マージされたコード カバレッジ ファイルを実行結果に保存します。
親トピック: コード分析を有効にする
関連資料
[実行] の [配置] ページ


[コード分析] の [詳細] ページ

レポート > コード分析 > 詳細

詳細 ページには、選択した製品、バージョン、ビルドのコードカバレッジ情報が製品、パッケージ、クラスの各レベルで表示されます。

製品 レベル ビューには、特定の製品や製品ビルドのパッケージのうち、コード分析でカバーされているものとそうでないものが一覧表示されます。 製品 ビューのパッケージ名をクリックすることで、さらに、そのパッケージに含まれているクラスのコードカバレッジ情報を表示できます。

製品 ビューには、選択した製品について以下の属性が表示されます。

属性 | 説明
名前 | 製品名
ステートメント | ステートメント総数
パッケージ/名前空間 以下の数値が含まれているヒストグラム バー表示
  • カバーされているパッケージ/名前空間の合計割合（%）
  • カバーされているパッケージ/名前空間の数（緑色の部分）
  • カバーされていないパッケージ/名前空間の数（赤色の部分）
クラス 以下の数値が含まれているヒストグラム バー表示
  • カバーされているクラスの合計割合（%）
  • カバーされているクラスの数（緑色の部分）
  • カバーされていないクラスの数（赤色の部分）
メソッド 以下の数値が含まれているヒストグラム バー表示
  • カバーされているメソッドの合計割合（%）
  • カバーされているメソッドの数（緑色の部分）
  • カバーされていないメソッドの数（赤色の部分）

パッケージ レベル ビューには、特定の製品や製品ビルドのクラスのうち、コード分析でカバーされているものとそうでないものが一覧表示されます。 パッケージ ビューのクラス名をクリックすることで、さらに、そのクラスに含まれているメソッドのコードカバレッジ情報を表示できます。

パッケージ ビューには、選択した製品の各パッケージの以下の属性が、複数行にわたって表示されます。

属性 | 説明
パッケージ | パッケージ名
ステートメント | ステートメント総数
クラス 以下の数値が含まれているヒストグラム バー表示
  • カバーされているクラスの合計割合（%）
  • カバーされているクラスの数（緑色の部分）
  • カバーされていないクラスの数（赤色の部分）
メソッド 以下の数値が含まれているヒストグラム バー表示
  • カバーされているメソッドの合計割合（%）
  • カバーされているメソッドの数（緑色の部分）
  • カバーされていないメソッドの数（赤色の部分）

クラス レベル ビューには、特定の製品や製品ビルドのメソッドのうち、コード分析でカバーされているものとそうでないものが一覧表示されます。

クラス ビューには、各メソッドの以下の属性が、複数行にわたって表示されます。

属性 | 説明
名前 | メソッド名
シグニチャ | メソッド シグニチャ
ステートメント | ステートメント総数
カバー メソッドの [カバー] ステータス
  • はい の場合はメソッドがカバーされていることを示します。
  • いいえ の場合はメソッドがカバーされていないことを示します。
注: ページに、一度に表示した場合に応答に影響が出るほど多くの要素がある場合、要素は順に表示されます。ページの下部にあるナビゲーション ツールバーを使用して、要素全体をブラウズすることができます。
親トピック: コード分析


最新ビルドおよびビルド バージョン

ナビゲーション ツリーで製品を選択すると、カバーされている最新バージョン（つまり、そのバージョンのカバー済み最新ビルド）のパッケージとクラスのリストおよびカバレッジ情報が自動的に表示されます。 ナビゲーション ツリーで製品バージョンを選択すると、そのバージョンのカバー済み最新ビルドのカバレッジ情報が自動的に表示されます。

注: 同じビルドから複数のアプリケーションを実行している場合は、すべてのアプリケーションからのカバレッジがマージされます。
注: 一連のビルドにわたるコード分析は、現在、Silk Central ではサポートされていません。
親トピック: コード分析


コード変更影響度レポートを生成する

コード変更影響度レポートを生成するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. コード カバレッジ データを分析するプロジェクトを選択します。
  3. メニューで レポート > コード分析 をクリックします。
  4. コード変更影響度レポートの作成 をクリックします。
    レポート対象クラスの選択 ダイアログ ボックスが表示されます。
  5. 選択済みの値を変更する場合は、製品 と バージョン を選択します。
  6. フィルタ フィールドに、パッケージ/名前空間をフィルタ処理する条件を入力します。
    たとえば、published という文字列を入力すると、名前に published という文字列が含まれるパッケージ/名前空間のみ表示されます。
  7. パッケージ/名前空間 リストからパッケージを選択します。
    Ctrl + クリック または Shift + クリック を使用して、複数のパッケージ/名前空間を選択します。 選択したパッケージ/名前空間で使用可能なクラスが、クラス リストに表示されます。
  8. クラス リストで、レポートにソースとして含めるクラスを選択します。
    Ctrl + クリック または Shift + クリック を使用して、複数のクラスを選択します。
  9. 追加 をクリックします。 選択したクラスが 選択したクラス リストに追加されます。
  10. 必要なクラスをすべて 選択したクラス リストに追加するまで、前述のステップを繰り返します。 選択したクラス リストからクラスを削除するには、エントリを選択して、削除 または すべて削除 をクリックします。
  11. レポートの選択 リストから、レポートを選択します。
  12. OK をクリックしてレポートを生成します。
親トピック: コード分析
関連概念
コード変更影響度レポート
関連資料
[レポート対象クラスの選択] ダイアログ ボックス


[レポート対象クラスの選択] ダイアログ ボックス

レポート > コード分析 > コード変更影響度レポートの作成

レポート対象クラスの選択 ダイアログ ボックスでは、コード変更影響度レポートにソースとして含めるクラス ファイルを選択することができます。ダイアログ ボックスには、次の要素が含まれます。

要素 | 説明
製品 | コード分析情報が必要な製品の名前。
バージョン | コード分析情報が必要な製品のバージョン。
フィルタ | パッケージのフィルタリング条件を入力します。たとえば、コード変更影響度レポートに published という文字列を入力すると、名前に「published」という文字列が含まれるパッケージのリストのみが表示されます。
パッケージ/名前空間 | 選択したバージョンでのカバレッジが指定された製品パッケージ/名前空間。
クラス | 選択したパッケージに含まれるすべてのクラス。
追加 | クリックすると、コード カバレッジ分析の対象となる選択済みクラスが追加されます。
選択したクラス | コード カバレッジ分析の対象となる選択済みクラスが表示されます。
削除 | クリックすると、選択したクラス リスト ボックスからすべての選択済みクラスが削除されます。
すべて削除 | クリックすると、選択したクラス リスト ボックスからすべてのクラスが削除されます。
レポートの選択 | コード変更影響度レポートのタイプ。
親トピック: コード分析


パッケージ/名前空間のコード カバレッジ情報を表示する

パッケージ/名前空間のコード カバレッジ情報を表示するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. コード カバレッジ情報を表示するプロジェクトを選択します。
  3. メニューで レポート > コード分析 をクリックします。
  4. コード分析 ツリーで、ナビゲーション ツリーのプロジェクト ノードを展開し、選択したプロジェクトで使用可能な製品を表示します。
  5. 製品ノードを展開して、その製品で使用可能なバージョンを表示します。
  6. バージョン ノードを展開して、そのバージョンで使用可能なビルドを表示します。
  7. 特定のビルドを選択します。 選択したビルドのコード カバレッジ情報が、詳細 ページに表示されます。
注: すべての製品のコード分析情報を表示するには、ツールバーの すべての製品を表示 をクリックします。 他のプロジェクトの製品は、他のプロジェクト ノードの下のリストに表示されます。
親トピック: コード分析
関連資料
[コード分析] の [詳細] ページ


Silk Test Classic AUT ホストを追加する

Silk Test Classic テストを実行する実行計画の場合は、Silk Test Classic エージェントを実行サーバーとは異なるコンピュータ上に配置するように設定できます。その場合は、Silk Test Classic エージェントの場所 (Silk Test Classic AUT (テスト対象エージェント) ホスト名) を定義できます。

選択されている実行計画に Silk Test Classic AUT ホストを追加するか、ホストを編集するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. Silk Test Classic AUT ホストを割り当てる実行計画を選択します。
  3. 配置 タブをクリックします。
  4. Silk Test Classic AUT ホスト名 セクションで、編集 をクリックします。
    SilkTest Classic AUT ホスト名の編集 ダイアログ ボックスが表示されます。
  5. ホスト名 フィールドに、Silk Test Classic エージェントを実行するコンピュータ名を入力します。 ここで、オプション ファイルの適切な設定が必要になります。コマンドライン オプション -m の詳細については、Silk Test Classic のドキュメントを参照してください。
  6. OK をクリックして、選択されている実行計画に Silk Test Classic AUT ホストを追加します。
親トピック: 配置環境を設定する
親トピック: Silk Test Classic のテスト
関連概念
テスト対象エージェント（AUT）の指定


実行の依存関係を設定する

実行の依存関係を利用すると、ある実行計画を別の実行計画の結果に基づいて自動的に実行するように設定することができます。 たとえば、実行計画 A が失敗したら、実行計画 B を自動的に実行するなどのように設定することができます。

  • 依存実行計画を追加する
    別の実行計画の結果に基づいて実行するように、依存実行計画を追加します。
  • 依存関係を編集する
    異なる条件に応じて依存実行のベースにするか、依存実行の配置を変更するために、依存関係を編集します。
  • 依存関係を削除する
    マスタ実行に基づいて依存実行を実行しないようにする場合に、依存関係を削除します。
  • [実行] の [依存関係] ページ
    選択した実行計画の依存実行計画とマスタ実行計画が一覧表示されます。
親トピック: 実行計画、フォルダ、構成スイートを管理する


依存実行計画を追加する

依存実行計画を追加するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. マスタ実行計画として動作する実行計画を選択します。
  3. 依存関係 タブをクリックします。
  4. 依存実行計画の追加 をクリックします。
    依存実行計画の追加 ダイアログ ボックスが表示されます。
  5. 条件 リストから、依存実行計画のトリガとなる条件を選択します。
    • 任意
    • 合格
    • 失敗
    • 未実行
    任意 は、直前のテスト実行のステータスに関係なく、依存テスト実行がトリガされることを意味します。
  6. 実行計画 ツリーから、実行計画を選択します。
  7. この依存実行計画を配置する場所を指定します。
    オプション
    説明
    依存実行計画で指定されているとおり
    この依存実行計画に割り当てられている自動テストは、配置 ページで依存実行計画に指定された実行サーバー上で実行されます。この依存実行計画に割り当てられている手動テストは、配置 ページで依存実行計画に指定されたユーザーに割り当てられます。
    <選択されている実行計画の実行サーバー> と同じ
    この依存実行計画に割り当てられている自動テストは、配置 ページでマスタ実行計画に指定された実行サーバー上で実行されます。この依存実行計画に割り当てられている手動テストは、配置 ページでマスタ実行計画に指定されたユーザーに割り当てられます。
    特定：実行サーバー/手動テスト担当者
    リスト ボックスから定義済みの実行サーバーと手動テスト担当者のいずれか、または両方を選択します。この依存実行計画に割り当てられている自動テストは、指定の実行サーバー上で実行されます。この依存実行計画に割り当てられている手動テストは、指定の手動テスト担当者に割り当てられます。手動テスト担当者のみが指定されていて、サーバーの指定がない場合は、手動テストのみが実行されます。実行サーバーのみが指定されていて、手動テスト担当者の指定がない場合は、自動テストのみが実行されます。
  8. OK をクリックして依存関係を作成します。
    注: Silk Central では、循環する実行依存関係は作成できません。手動テストを満たすための条件を選択することができます。たとえば、選択されている条件が 失敗 の場合に、すべての手動テストが合格で、一部の自動テストが失敗ならば、この依存実行計画に割り当てられている自動テストのみが実行されます。
親トピック: 実行の依存関係を設定する


依存関係を編集する

注: 既存の依存関係を編集するには、マスタ実行計画 (特定の条件のときに、依存実行計画の実行をトリガする実行計画) を選択する必要があります。依存実行計画から、依存関係の設定を編集することはできません。

以前設定した依存関係を編集するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する実行計画を選択します。
  3. 依存関係 タブをクリックします。
  4. 依存実行計画 セクションで、依存実行計画の アクション 列にある 設定の編集 をクリックします。
    依存関係の編集 ダイアログ ボックスが表示されます。
  5. 条件 リストから、依存実行計画のトリガとなる条件を選択します。
    • 任意
    • 合格
    • 失敗
    • 未実行
    任意 は、直前のテスト実行のステータスに関係なく、依存テスト実行がトリガされることを意味します。
  6. この依存実行計画を配置する場所を指定します。
    オプション
    説明
    依存実行計画で指定されているとおり
    この依存実行計画に割り当てられている自動テストは、配置 ページで依存実行計画に指定された実行サーバー上で実行されます。この依存実行計画に割り当てられている手動テストは、配置 ページで依存実行計画に指定されたユーザーに割り当てられます。
    <選択されている実行計画の実行サーバー> と同じ
    この依存実行計画に割り当てられている自動テストは、配置 ページでマスタ実行計画に指定された実行サーバー上で実行されます。この依存実行計画に割り当てられている手動テストは、配置 ページでマスタ実行計画に指定されたユーザーに割り当てられます。
    特定：実行サーバー/手動テスト担当者
    リスト ボックスから定義済みの実行サーバーと手動テスト担当者のいずれか、または両方を選択します。この依存実行計画に割り当てられている自動テストは、指定の実行サーバー上で実行されます。この依存実行計画に割り当てられている手動テストは、指定の手動テスト担当者に割り当てられます。手動テスト担当者のみが指定されていて、サーバーの指定がない場合は、手動テストのみが実行されます。実行サーバーのみが指定されていて、手動テスト担当者の指定がない場合は、自動テストのみが実行されます。
親トピック: 実行の依存関係を設定する


依存関係を削除する

依存関係を削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 削除対象の依存関係を含むマスタ実行計画を選択します。
  3. 依存関係 タブをクリックします。
  4. 依存実行計画 セクションで、依存実行計画の アクション 列にある 削除 をクリックします。
  5. 依存関係の削除 ダイアログ ボックスで はい をクリックして、依存関係を削除します。
親トピック: 実行の依存関係を設定する


[実行] の [依存関係] ページ

実行計画 > 詳細ビュー > <実行計画> > 依存関係
注: このページは、テスト サイクルに割り当てられている実行計画では表示されません。

依存関係 ページには、選択した実行計画の依存実行計画とマスタ実行計画が一覧表示されます。

このページは、2 つの部分に分かれています。マスタ実行計画 は、実行計画が特定の状態になったときに、選択した実行計画をトリガする実行計画です。依存実行計画 は、選択した実行計画が特定の状態になったときに、トリガされる実行計画です。

マスタ実行計画

リスト内の実行計画ごとに、以下の列がこのページに表示されます。
列 | 説明
名前 | 選択した実行計画の前提となるマスタ実行計画の名前。
条件 | 選択した実行計画がトリガされるためには、マスタ実行計画がどのような状態になる必要があるかを示します。

依存実行計画

リスト内の実行計画ごとに、以下の列がこのページに表示されます。
列 | 説明
名前 | 選択した実行計画をマスタとする依存実行計画の名前。
条件 | 依存実行計画がトリガされるためには、選択した実行計画がどのような状態になる必要があるかを示します。
実行サーバー/ユーザー | 依存実行計画が実行される実行サーバー、あるいは、手動テスト実行の場合には、手動テストを実行する手動テスト担当者。
アクション | 選択した依存関係に対して実行できるアクション。設定の編集 と 依存関係の削除。
親トピック: 実行の依存関係を設定する


割り当て済みテスト

このセクションでは、実行計画にテストを割り当てる方法について説明します。

  • グリッド ビューから実行計画にテストを割り当てる
    実行計画に含まれるテストに グリッド ビュー からテストを割り当てます。
  • 手動で実行計画に割り当てる
    テストを手動で実行計画に割り当て、実行するテストに含めます。
  • フィルタを使用してテストを実行計画に割り当てる
    実行計画に含まれるテストに、フィルタを使用してテストを追加します。
  • 実行計画に割り当てられたテストの検索
    テスト ツリーで手動で割り当てられたテストを検索する方法について説明します。
  • テストの割り当てを削除する
    テストが不要になった場合に、手動テストの割り当てを実行計画から削除します。
  • [実行] の [割り当て済みテスト] ページ
    選択した実行計画に割り当てられているテストをすべて一覧表示します。
親トピック: 実行計画、フォルダ、構成スイートを管理する


グリッド ビューから実行計画にテストを割り当てる

選択されている実行計画に割り当てられているテストは、割り当て済みテスト ページに一覧表示されます。

グリッド ビュー から 1 つまたは複数のテストを、1 つまたは複数の実行計画に割り当てるには：

  1. メニューで テスト > グリッド ビュー をクリックします。
  2. 実行計画に割り当てるテストを選択します。 Ctrl + クリック または Shift + クリック を使用して複数のテストを選択できます。
  3. 選択したテストを右クリックし、選択の保存 をクリックします。
  4. メニューで 実行計画 > 詳細ビュー をクリックします。
  5. 選択したテストを割り当てたい実行計画を選択します。
  6. 割り当て済みテスト タブをクリックします。
  7. 保存された選択の割り当て をクリックします。
    注: 実行計画のテスト コンテナに存在するテストのみ、挿入されます。選択したテストは、1 つ以上の実行計画に挿入することができます。これらは、別のプロジェクトの要件に割り当てることはできません。選択内容は、ユーザーが別の選択を保存するか Silk Central を閉じるまで保持されます。
親トピック: 割り当て済みテスト
関連タスク
フィルタを使用してテストを実行計画に割り当てる
手動で実行計画に割り当てる


手動で実行計画に割り当てる

選択されている実行計画に割り当てられているテストは、割り当て済みテスト ページに一覧表示されます。

テストを手動で実行計画に割り当てるには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 選択したテストを割り当てたい実行計画を選択します。
  3. 割り当て済みテスト タブをクリックします。
  4. 手動割り当て オプションをクリックします。 選択した実行に関連するテスト コンテナのすべてのテストは、テスト ツリーに表示されます。テスト フィルタを作成した場合は、テスト ツリーの上にあるフィルタ リストから選択できます。新しいテスト フィルタを作成するには、メニューの テスト をクリックし、ツールバーの [image] (フィルタの新規作成) をクリックします。
  5. 割り当てるテストを選択します。 キーボードの Ctrl または Shift キーを使用すると、標準ブラウザの複数選択機能を使用して、複数のテストを選択することができます。
  6. 選択した項目をドラッグし、割り当て済みテスト 領域にドロップするか、テストの左側にある 割り当て をクリックします。 フォルダまたはトップレベル コンテナを割り当てると、それを親とするすべての子テストが、選択されている実行計画に割り当てられます。
    ヒント: ノードを右クリックして展開、折りたたみを行います。
親トピック: 割り当て済みテスト
関連タスク
グリッド ビューから実行計画にテストを割り当てる
フィルタを使用してテストを実行計画に割り当てる


フィルタを使用してテストを実行計画に割り当てる

選択されている実行計画に割り当てられているテストは、割り当て済みテスト ページに一覧表示されます。

次の手順を実行する前に、テスト カテゴリのフィルタを作成する必要があります。 詳細については、「フィルタを作成する」を参照してください。 または既存のフィルタを選択します。

フィルタを利用して、1 つまたは複数のテストを実行計画に割り当てるには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. テストを割り当てる実行計画を選択します。
  3. 割り当て済みテスト タブをクリックします。
  4. フィルタによる割り当て オプションをクリックします。
  5. リストからフィルタを選択します。
注: テスト > グリッド ビュー でテストを実行計画に割り当てた場合は、テストの割り当てタイプは、自動的に 手動割り当て に設定されますが、その前にフィルタリングされたテストは、割り当て済みテスト ページでそのままになります。
親トピック: 割り当て済みテスト
関連タスク
グリッド ビューから実行計画にテストを割り当てる
手動で実行計画に割り当てる
フィルタを作成する


実行計画に割り当てられたテストの検索

テスト ツリーで手動で割り当てられたテストを検索するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 割り当てられたテストを検索する実行計画を選択します。
  3. 割り当て済みテスト タブをクリックします。
  4. 省略可能：手動割り当て が選択されていない場合は、選択します。
  5. テストの アクション 列で、 検索 をクリックして、どのテスト フォルダやコンテナにテストが格納されているか調べることができます。
対応する親フォルダがテスト ツリーで展開され、割り当て済みテストがブルーで強調表示されます。
親トピック: 割り当て済みテスト


テストの割り当てを削除する

手動で割り当てたテストを削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 割り当てを削除する実行計画を選択します。
  3. 割り当て済みテスト タブをクリックします。
  4. 割り当て済みテストの アクション 列で、 割り当ての削除 をクリックするか、Ctrl+クリック や Shift+クリック を使用して複数のテストを選択してから Del キーを押します。
    ヒント: 割り当てたテストすべてを削除するには、すべて削除 をクリックします。
親トピック: 割り当て済みテスト


[実行] の [割り当て済みテスト] ページ

実行計画 > 詳細ビュー > <実行要素> > 割り当て済みテスト
注: このページは、テスト サイクルに割り当てられている実行計画では表示されません。

割り当て済みテスト ページには、選択した実行計画または構成スイートに割り当てられているテストがすべて一覧表示されます。このページを利用することにより、実行計画または構成スイートに対する他のテストの割り当て、実行計画または構成スイートからのテストの削除、あるいは割り当て済みテストの実行順の変更などを行うことができます。

テスト フィルタを作成した場合は、テスト ツリーの上にあるフィルタ リストから選択できます。新しいテスト フィルタを作成するには、テスト 領域に移動し、ツールバーの フィルタの新規作成 をクリックします。

注: このページで行われたすべての変更は、直ちに適用されます。
注: 構成スイートのサブ要素からページにアクセスすると、ページが読み取り専用になります。

このページには、次の項目があります。

項目 | 説明
手動割り当て | テストを手動で実行計画または構成スイートに割り当てる場合にクリックします。
ツリーの順序を使用する | 割り当て済みテストの実行順を、テスト 領域上の実行順どおりになるように設定する場合にオンにします。
保存された選択の割り当て | テストの選択を テスト > グリッド ビュー から割り当てる場合にクリックします。
フィルタによる割り当て | 定義済みのフィルタに基づいて、テストを実行計画または構成スイートに自動的に割り当てる場合にクリックします。利用可能なフィルタは、リスト ボックスに表示されています。
割り当て済みテスト | 実行計画または構成スイートに割り当てられるテストの数量。
テスト サイクルの残り時間 (hh:mm) このフィールドは実行計画がテスト サイクル内にある場合に有効になります。テスト サイクルの 稼働時間 からすべてのテストの予定時間を一括して減算したテスト サイクルの残り時間を示します。
注: 予定時間 は、手動テスト用のみです。
予定時間 実行計画または構成スイートですべてのテストが実行される見積もり時間。構成スイートの場合、予定時間 は、スイートにあるすべての構成の予定時間の合計です。
注: 予定時間 は、手動テスト用のみです。
割り当て済みテストの一覧表示 割り当て済みテストごとに、ページに次の列が表示されます。
順序
テストの実行順序。実行順を変更する場合には、ツリーの順序を使用する チェック ボックスをオフにします。このフィールドをクリックし、テストの新しい順番を入力したら、Enter を押して変更を確定します。各フィールドの変更は、それぞれに Enter を押して確定する必要があります。複数のテストの順番を、それぞれ Enter を押さないで変更した場合、Enter を押す前の最後の変更のみが確定されます。
アクション
手動割り当て オプション ボタンがクリックされている場合、割り当て済みテストに対して次のアクションを実行できます。
アクション
説明
選択したテストをリストから削除します。
テスト ツリー内で選択したテストを検索します。
テスト
このテストの名前。クリックすると、テスト 領域内のテストにアクセスすることができます。
ステータス

実行計画または構成スイートのコンテキスト内にある、テストの最後の実行のステータス。テストが実行計画または構成スイートのコンテキスト外で実行されている場合、表示されるステータスは変わりません。テストが実行計画または構成スイートのコンテキスト内でまだ実行されていない場合、ステータスは N/A となります。

構成スイートに含まれているテストまたはテスト パッケージでは、ステータスは、そのスイート内のすべての構成の、すべてのステータスを集約したものとなります。
  • 構成スイートにのみ割り当てられているテストは、すべての構成で合格となった場合にのみ、ステータスが 合格 になります。すべての構成でステータスが 合格 でない場合、最も低い実行のステータスが反映されます。反映の優先度は次に示す順序 (上から下へ) となります。
    1. N/A
    2. 未実行
    3. 失敗
    4. 合格
    テストに割り当てられた要件のステータスは、そのテストが 1 つ以上の構成で失敗すると、失敗 になります。
  • 構成スイートと 1 つ以上の単純な実行計画にテストを割り当てることはお勧めしません。ただし、この場合は、1 つのステータスが構成ステータスの集約ステータスに、もう 1 つのステータスが実行計画の前回のステータスとなります。前回実行されたステータスがテストの前回のステータスとなります。
  • テストが単純な実行計画にのみ割り当てられている場合、ステータスは前回のテスト実行のステータスに応じて更新されます。
前回の実行
実行計画または構成スイートのコンテキスト内にある、テストの最後の実行の日時。テストが実行計画または構成スイートのコンテキスト外で実行されている場合、表示される日時は変わりません。
予定時間
このテストの見積もり実行時刻。
注: [予定時間] は、手動テスト用のみです。
テスト | 選択した実行計画または構成スイートへの割り当てに利用できるすべてのテストを、テスト ツリーに表示します。テストをダブルクリックするか、 割り当て を使用して、テストを実行計画または構成スイートに割り当てます。複数のテストを テスト 領域から実行計画または構成スイートに挿入する方法については、「実行計画にグリッド ビューからテストを割り当てる」を参照してください。
親トピック: 割り当て済みテスト
関連タスク
グリッド ビューから実行計画にテストを割り当てる


スケジュール

実行計画、フォルダ、または構成スイートに含めるテストを定義したら、スケジュール ページで、その実行計画、フォルダ、または構成スイートの実行スケジュールを定義できます。

以下の 3 つのスケジューリング オプションが選択可能です。
  • なし
  • グローバル
  • カスタム
注: 実行計画、フォルダ、または構成スイートのスケジュールを定義できます。スケジュールをフォルダまたは構成スイートに定義する場合、選択されたフォルダまたは構成スイートに含まれている実行計画はすべて、指定されたスケジュールで実行されます。キーワードが割り当てられていないすべての実行計画、フォルダ、または構成スイートには、実行がスケジューリングされた時点で、未実行 のステータスが与えられます。前回の実行ステータスが失われることを回避するために、プロジェクトのコピーまたはベースラインの部分に対するスケジュール オプションが「なし」に設定されます。プロジェクトのコピーとベースライン化についての詳細は、「プロジェクト ベースライン」および「プロジェクトまたはプロジェクト ベースラインをコピーする」を参照してください。

限定実行

限定実行 により、構成されたスケジュールに関係なく、テスト定義を実行する時間を定義できます。

  • カスタム スケジュールを作成する
    実行計画、フォルダ、または構成スイートに特殊なスケジューリングを必要とする場合に、カスタム スケジュールを作成します。
  • グローバル スケジュールを指定する
    実行計画、フォルダ、または構成スイートで実行するテストに基づいて、グローバル スケジュールを指定します。
  • スケジュールなしを指定する
    スケジュールに基づいてテストを実行しない場合は、実行計画、フォルダ、または構成スイートに対してスケジュールなしを指定します。
  • 除外期間
    スケジュールの除外期間を使用する方法について説明します。
  • 限定実行
    限定実行を使用する方法について説明します。
  • [スケジュール] ページ
    実行計画、フォルダ、構成スイート、レポート配信登録用のスケジュールを定義することができます。
親トピック: 実行計画、フォルダ、構成スイートを管理する
関連概念
グローバル スケジュールを設定する
プロジェクト ベースライン
関連タスク
プロジェクトまたはプロジェクト ベースラインをコピーする


カスタム スケジュールを作成する

選択されている実行計画、フォルダ、または構成スイートに対してカスタム スケジュールを作成するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. カスタム スケジュールを設定する実行計画、フォルダ、または構成スイートを選択します。
    注: グローバル スケジュールを編集してカスタム スケジュールとして保存するには、リスト ボックスからグローバル スケジュールを選択して、編集 をクリックします。これによって、グローバル スケジュールを編集して、その結果をカスタム スケジュールとして保存できます。
  3. スケジュール タブをクリックします。
  4. カスタム オプションをクリックして、スケジュールの制御を有効にします。
  5. 編集 をクリックします。
  6. 開始時間 フィールドの横にある 編集 をクリックし、カレンダー ツールを使用して、実行スケジュールの開始日時を指定します。
  7. テストの実行 間隔 を指定します。
  8. 実行 セクションで、スケジュールの終了日時を指定します。
    以下のいずれかのオプションを選択します。
    • 終了日時のないスケジュールを定義するには、期限なし をクリックします。
    • n 回 をクリックします。
    • 期限あり フィールドの横にある 編集 をクリックし、カレンダー ツールを使用して、実行スケジュールの終了日時を指定します。
  9. 省略可能：除外期間の追加 をクリックして、スケジュールされた要素が実行されない期間を定義します。
  10. 省略可能：限定実行の追加 をクリックして、スケジュールされていない実行計画を実行する期間を定義します。
  11. 保存 をクリックして、カスタム スケジュールを保存します。
親トピック: スケジュール
関連タスク
除外期間を追加する
限定実行を追加する


グローバル スケジュールを指定する

Silk Central には、グローバル スケジュールを定義する機能があります。グローバル スケジュールは、テストのスケジュールを定義する際に Silk Central で再利用できます。グローバル スケジュールを利用すると、テストのスケジューリング プロセスをスピードアップできます。テストごとに個別のスケジュールを定義するのは、特殊なスケジューリングを必要とするテストのみに限定できるからです。

Silk Central を使用してグローバルに利用できる定義済みのスケジュールを選択するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. スケジュールを設定する実行計画、フォルダ、または構成スイートを選択します。
  3. スケジュール タブをクリックします。
  4. グローバル オプション ボタンをクリックします。
  5. リスト ボックスから、必要な定義済みのスケジュールを選択します。 定義済みのスケジュールの詳細は、読み取り専用のカレンダー ビューに表示されます。グローバル スケジュールを編集して、カスタム スケジュールとして保存するには、編集 をクリックします。
    注: グローバル スケジュールは、管理 > スケジュール で設定できます。
親トピック: スケジュール
関連タスク
グローバル スケジュールを追加する
グローバル スケジュールを編集する


スケジュールなしを指定する

実行計画、フォルダ、または構成スイートに対してスケジュールを定義しないように指定するには：
  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. スケジュールに基づいて実行しないように定義する実行計画、フォルダ、または構成スイートを選択します。
  3. スケジュール タブをクリックします。
  4. なし オプション ボタンをクリックします。
親トピック: スケジュール


除外期間

スケジュールの除外期間とは、定期的に実行を一時停止する期間（週 1 回予定されているシステム ダウンタイムや週末など）のことです。除外期間は、スケジュールに必要なだけ追加できます。[除外期間] では、スケジュールの構成の有無にかかわらず、テストを実行しない曜日や時間帯を定義することができます。たとえば、週末はテストを実行したくない、といった場合が挙げられます。

  • 除外期間を追加する
    スケジュールが特定の時間に実行されないように、除外期間をカスタム スケジュールに追加します。
  • 除外期間を編集する
    除外期間を編集し、スケジュールを実行しない日時を変更します。
  • 除外期間を削除する
    除外された時間にスケジュールを実行できる場合に、除外期間を削除します。
親トピック: スケジュール


除外期間を追加する

注: グローバル スケジュールを編集するには、管理者権限が必要です。グローバル スケジュール用の除外期間を定義するには、管理 > スケジュール に移動します。

除外期間をカスタム スケジュールに追加するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 除外期間を追加する実行計画、フォルダ、構成スイートを選択します。
  3. スケジュール タブをクリックします。
  4. カスタム オプションをクリックして、スケジュールの制御を有効にします。
  5. 除外期間の追加 をクリックします。
  6. スケジュールの除外期間の設定 ページで、テストを実行しない曜日を選択します。
  7. これらの曜日で、テストを実行しない時間帯を定義します。
  8. OK をクリックします。 除外期間の設定が スケジュール ページに一覧表示されます。
  9. 保存 をクリックして除外期間を現在のスケジュールに追加するか、除外期間の追加を続行します。
親トピック: 除外期間
関連資料
[スケジュール] ページ


除外期間を編集する

除外期間を編集するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 編集対象の以前設定した除外期間を含む実行計画、フォルダ、または構成スイートを選択します。
  3. スケジュール タブをクリックします。
  4. 除外期間の アクション 列で、 除外期間の編集 をクリックします。
  5. 必要に応じて除外期間を編集し、OK をクリックします。
  6. 保存 をクリックします。
親トピック: 除外期間
関連資料
[スケジュール] ページ


除外期間を削除する

除外期間を削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 削除対象の以前設定した除外期間を含む実行計画、フォルダ、または構成スイートを選択します。
  3. スケジュール タブをクリックします。
  4. 除外期間の アクション 列で、 削除 をクリックします。
親トピック: 除外期間
関連資料
[スケジュール] ページ


限定実行

限定実行とは、実行計画、フォルダ、または構成スイートに設定されているスケジュールとは関係なく特定の時間に予定される実行計画、フォルダ、または構成スイートのことです。限定実行は、必要なだけ追加できます。

  • 限定実行を追加する
    スケジュールされた実行計画、フォルダ、または構成スイートを追加で 1 回実行する場合に、限定実行をカスタム スケジュールに追加します。
  • 限定実行を編集する
    限定実行を編集し、実行日時を変更します。
  • 限定実行を削除する
    実行が不要になったときに限定実行を削除します。
親トピック: スケジュール


限定実行を追加する

注: グローバル スケジュールを編集するには、管理者権限が必要です。グローバル スケジュール用の限定実行を定義するには、管理 > スケジュール に移動します。

限定実行をカスタム スケジュールに追加するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 限定実行を追加する実行計画、フォルダ、または構成スイートを選択します。
  3. スケジュール タブをクリックします。
  4. カスタム オプションをクリックして、スケジュールの制御を有効にします。
  5. 限定実行の追加 をクリックします。
  6. 限定実行の設定 ページで 編集 をクリックし、実行計画、フォルダ、または構成スイートを限定実行する日時を選択します。
  7. OK をクリックします。 限定実行の設定が スケジュール ページに一覧表示されます。
  8. 保存 をクリックして現在のスケジュールに限定実行を追加するか、限定実行の追加を続行します。
親トピック: 限定実行
関連資料
[スケジュール] ページ


限定実行を編集する

限定実行を編集するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 編集対象の以前設定した限定実行を含む実行計画、フォルダ、または構成スイートを選択します。
  3. スケジュール タブをクリックします。
  4. 限定実行の アクション 列で、 限定実行の編集 をクリックします。
  5. 必要に応じて限定実行の条件を編集して、保存 をクリックします。
親トピック: 限定実行
関連資料
[スケジュール] ページ


限定実行を削除する

限定実行を削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 削除対象の以前設定した限定実行を含む実行計画、フォルダ、または構成スイートを選択します。
  3. スケジュール タブをクリックします。
  4. 限定実行の アクション 列で、 限定実行の削除 をクリックします。
親トピック: 限定実行
関連資料
[スケジュール] ページ


[スケジュール] ページ

実行計画 > 詳細ビュー > <実行要素> > スケジュール
注: このページは、テスト サイクルに割り当てられている実行計画では表示されません。

スケジュール ページは、実行計画、フォルダ、構成スイート、レポート配信登録のスケジュールを定義するために使用します。

ページには、次のスケジュール タイプが表示されます。

スケジュール タイプ | 説明
なし | 資産がスケジュールに基づいて実行されないようにする場合は、このオプション ボタンをクリックします。プロジェクトのコピーまたはベースラインに含まれているスケジュールはすべて、最初は「なし」に設定されます。
グローバル | 資産のスケジュールとしてリスト ボックスから定義済みのスケジュールを選択する場合は、このオプション ボタンをクリックします。グローバル スケジュールを選択すると、グローバル スケジュールに定義されているスケジュールの除外期間や限定実行が含まれます。グローバル スケジュールの定義の詳細については、この『ヘルプ』の「管理」トピックを参照してください。グローバル スケジュールを選択すると、カスタム オプション ボタンの下にスケジュールの詳細が表示されます。
カスタム | 実行計画、フォルダ、または構成スイートのカスタム スケジュールを定義する場合は、このオプション ボタンをクリックします。編集 をクリックして、下の各フィールドにあるカスタム スケジュールを編集します。

選択したスケジュール タイプごとに、ページに詳細が表示されます。カスタム スケジュールの場合、詳細は編集可能です。

注意:
資産に割り当てられているテストが実行されない場合、その理由は、以前のスケジュールか、スケジュールの間隔が実行期間よりも短いため、資産が、まだ実行中である可能性があります。この場合は、スケジュールの間隔を長くするか、実行されるテストのパフォーマンスを改善するか、または実行計画からテストを削除します。アプリケーション サーバーのログファイルを表示するには、管理 > ログ ファイル にある アプリケーション サーバー ログ タブをクリックします。

スケジュールの詳細

このページには、選択したスケジュール タイプの詳細が表示され、カスタム スケジュールの場合は編集可能です。
項目 | 説明
開始日時 | 実行スケジュールの開始時期を指定します。指定する日時のとなりにある 編集 をクリックして、日付と時刻を変更します。
間隔 | 実行されるテストの実行間隔を指定します。
サマータイムを補正する このチェック ボックスをオンにすると、自動的にスケジュールでサマータイムが補正されます。
注: 1 時間戻したときに重複して実行されるのを避けるため、サマータイムの補正は 2 時間の倍数の間隔でのみ機能します。
実行 実行の終了時期を指定します。
期限なし
実行を停止しないよう指定する場合は、このオプション ボタンをクリックします。
回
特定の実行回数を定義する場合は、このオプション ボタンをクリックし、リスト ボックスから回数を選択します。
期限あり
テスト実行が終了する特定の日時を指定する場合は、このオプション ボタンをクリックします。指定する日時のとなりにある 編集 をクリックして、日付と時刻を変更します。
除外期間 | スケジュールに対して定義された除外期間。除外期間を追加するには、除外期間の追加 をクリックします。
限定実行 | スケジュールに対して定義された限定実行。限定実行を追加するには、限定実行の追加 をクリックします。選択する限定実行の [アクション] 列にある 編集 をクリックして、カレンダー ツールにアクセスし、限定実行を行う時期を指定します。
親トピック: スケジュール


実行計画に割り当てられたテストを実行する

このセクションでは、Silk Central によって、実行計画に割り当てられたテストを実行する方法について説明します。

個々の実行計画、フォルダ、および構成スイートを実行できます。すべての場合において、割り当てられたすべてのテストを実行するか、または特定のステータス基準に合致するテストだけを実行するかのいずれかを定義できます。自動テストを含む実行計画の開始後、中央実行キューに入れられ、テストの自動実行完遂に適切な実行サーバーが、キーワードの一致およびサーバーの可用性に基づいて選択されます。モバイル デバイス テストでは、この実行計画にモバイル デバイスの選択が設定されている場合、デバイスが選択され、実行用に予約されます。実行サーバー、またはモバイル デバイスが利用できない場合、適切な実行サーバーおよびモバイル デバイスが利用可能になるまで、実行ジョブはキューで待機します。

  • 実行計画を実行する
    スケジュールから独立して個々の実行計画を実行します。
  • [実行] ダイアログ ボックス
    実行 ダイアログ ボックスではフィルタ条件に基づいて実行する対象テストを指定し、テストを実行する対象製品ビルドを指定できます。
  • 自動テストを手動で実行する
    システム コンポーネントが原因で自動テストに失敗した場合、または自動テストの結果を検証する場合には、自動テストを手動で実行します。
親トピック: 実行計画、フォルダ、構成スイートを管理する


実行計画を実行する

スケジュールから独立して実行計画を実行するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、実行するプロジェクト、実行計画、または構成スイートを選択します。 ここでは、Ctrl+クリック や Shift+クリック を使用して、複数の要素を選択できます。
  3. ツールバーの [image] (実行) をクリックします。これは、テスト サイクル、テスト サイクル内の実行計画、未割り当てテストに対しては利用できません。 実行 ダイアログ ボックスが表示されます。
  4. 実行 ダイアログ ボックスで 実行するテストを定義します。
  5. アクティビティ ページへ移動 チェック ボックスをオンにすると、実行用のテストを定義した後に アクティビティ ページに進みます。
親トピック: 実行計画に割り当てられたテストを実行する
関連概念
割り当て済みテスト
関連資料
[アクティビティ] ページ
[実行] ダイアログ ボックス


[実行] ダイアログ ボックス

実行計画 > 詳細ビュー > <実行要素> > 実行

実行計画 > 詳細ビュー > <実行要素> > 実行

実行 ダイアログ ボックスではフィルタ条件に基づいて実行する対象テストを指定し、テストを実行する対象製品ビルドを指定できます。実行 ダイアログ ボックスを開くには、実行計画または実行フォルダを選択し、ツールバーの 実行 をクリックします。

項目 | 説明
すべてのテストの場合： このオプションを選択してすべてのテストを実行します。
テスト... 次のオプションのいずれかを満たすテストだけを実行するには、このオプションを選択します。
オプション
説明
失敗したステータスをもつ
チェックすると、失敗ステータスを持つ、選択された実行計画のすべてのテストを再実行します。
未実行ステータスをもつ
チェックすると、未実行ステータスを持つ、選択された実行計画のすべてのテストを再実行します。
ビルド ... 以降で実行されていない
チェックすると、選択されたビルドで未実行の、選択されたビルドのすべてのテストを再実行します。選択されたまたは以降のビルドで実行されたテストは、実行されません。
最後の実行以降に解決された問題をもつテスト | このオプションを選択すると、テストを最後に実行してから [解決] 状態に移行した問題があるテストのみを実行します。
実行計画に対するビルドの設定 | 実行計画に対するビルドの設定 リスト ボックスから過去のビルドを選択して、特定の過去のビルドに対してテストを実行します。このフィールドはデフォルトで最新のビルドになっています。実行計画でビルド番号をビルド情報ファイルから読み込む設定の場合は、このオプションが利用できないことに注意してください。実行フォルダ内に、複数の実行計画がそれぞれ違う製品バージョンを割り当てられて存在する場合、その実行フォルダの実行に対してビルドを選択することはできません。
実行タイプ | 指定した方法で実行 を選択すると、それぞれ各自のテスト タイプで、選択されたすべてのテストが実行され、自動テストを手動で実行 を選択すると、選択したすべてのテストが手動で再実行されます。
アクティビティ ページへ移動 | このチェック ボックスをオンにすると、実行用のテストを定義した後に アクティビティ ページに進みます。
親トピック: 実行計画に割り当てられたテストを実行する
関連概念
実行計画に割り当てられたテストを実行する


自動テストを手動で実行する

自動テストでは、環境の問題によって、予期しない結果が発生する場合があります。 システムで自動テストが失敗し、失敗の原因がシステム コンポーネントであるかどうかを検証する場合、または問題の原因が現在機能していないシステム コンポーネントであることがわかっている場合は、自動テストを手動で再実行できます。

自動テストを手動で実行するには、次のステップを実行します。

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、実行するプロジェクト、実行計画、または構成スイートを選択します。 ここでは、Ctrl+クリック や Shift+クリック を使用して、複数の要素を選択できます。
  3. ツールバーの [image] (実行) をクリックします。これは、テスト サイクル、テスト サイクル内の実行計画、未割り当てテストに対しては利用できません。 実行 ダイアログ ボックスが表示されます。
  4. 実行するテストを定義します。
  5. 実行タイプ リスト ボックスで 自動テストを手動で実行 を選択します。 選択したすべてのテストが手動テストとして処理され、現在の実行 ページが表示されます。
親トピック: 実行計画に割り当てられたテストを実行する
関連資料
[実行] ダイアログ ボックス


スクリーン キャプチャ

テスト要素や実行計画のスクリーン キャプチャを有効にできます。スクリーンショットは、 テスト実行の結果 ダイアログ ボックスの ファイル ページの結果ファイル、および タイムライン ページに追加されます。たとえばテスト中にエラーが発生した場合にスクリーンショットを分析できます。

実行計画の 配置 ページの スクリーン キャプチャ 設定は、実行計画に含まれる特定のテスト要素の設定を上書きします。

  • スクリーン キャプチャを有効にする
    スクリーン キャプチャを有効にして、テストのスクリーンショットを結果ファイルに追加します。
親トピック: 実行計画、フォルダ、構成スイートを管理する


スクリーン キャプチャを有効にする

テストのスクリーン キャプチャを有効にするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、コンテナ、フォルダ、またはテストを選択します。
  3. パラメータ タブをクリックします。
  4. カスタム パラメータの追加 をクリックします。 カスタム パラメータの設定 ダイアログ ボックスが開きます。
  5. 名前 フィールドに captureScreen と入力します。
  6. タイプ リスト ボックスから、文字列 を選択します。
  7. 値 フィールドに、次のいずれかの値を入力します。
    • 実行計画を実行してエラーが発生した場合に結果ファイルにスクリーンショットを追加する場合は、onError と入力します。
    • 結果ファイルにスクリーンショットを追加しない場合は、これ以外の文字列を入力するか、または何も入力しません。
親トピック: スクリーン キャプチャ


ビデオ キャプチャ

テスト要素や実行計画のビデオ キャプチャを有効にできます。ビデオは WMV ビデオ ファイルとして、テスト実行の結果 ダイアログ ボックスの ファイル ページの結果ファイルに追加されます。たとえばテスト中にエラーが発生した場合にビデオを分析できます。

実行計画の 配置 ページの ビデオ録画 設定は、実行計画に含まれる特定のテスト要素の設定を上書きします。

制限事項：
  • ビデオ録画は Microsoft Windows クライアント マシンでのみサポートされます。
  • Microsoft Windows 10 N および KN エディションでのビデオ キャプチャはサポートされません。
  • WPF ウィンドウのビデオ録画は Windows 7 のクラシック テーマではサポートされません。
  • 4K 解像度でのビデオ録画はサポートされません。
注: Windows Server 2008 実行サーバー上でビデオ キャプチャを使用するには、次のサーバー機能をインストールする必要があります。
  • デスクトップ エクスペリエンス
  • 高品質な Windows オーディオ ビデオ エクスペリエンス
Windows Server 2012 実行サーバー上でビデオ キャプチャを使用するには、次のサーバー機能をインストールする必要があります。
  • デスクトップ エクスペリエンス
  • メディア ファンデーション
重要: ビデオのキャプチャ処理では、CPU に大きな負荷がかかります。必要なときにだけ、この機能を使用します。この機能を使用するには、十分な CPU パワーを備えたシステム (たとえば、複数の CPU が搭載されたシステム) が必要です。

スイート内の個々テスト ケースのビデオ キャプチャは、設定なしに、JUnit 4 テストおよび Silk Test Classic 計画テストに対してサポートされます。他のテスト タイプでこの機能を使用するには、TestCaseStartFinishSocketClient インターフェイスのメソッドを使用します。詳細については、「ビデオ キャプチャの開始と終了を指示する」を参照してください。

  • ビデオ キャプチャを有効にする
    ビデオ キャプチャを有効にして、テストのビデオを結果ファイルに追加します。
親トピック: 実行計画、フォルダ、構成スイートを管理する
関連概念
ビデオ キャプチャの開始と終了を示す


ビデオ キャプチャを有効にする

テストのビデオ キャプチャを有効にするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、コンテナ、フォルダ、またはテストを選択します。
  3. パラメータ タブをクリックします。
  4. カスタム パラメータの追加 をクリックします。 カスタム パラメータの設定 ダイアログ ボックスが開きます。
  5. 名前 フィールドに recordVideo と入力します。
  6. タイプ リスト ボックスから、文字列 を選択します。
  7. 値 フィールドに、次のいずれかの値を入力します。
    • 実行計画を実行するたびに結果ファイルにビデオを追加する場合は、always と入力します。
    • 実行計画を実行してエラーが発生した場合に結果ファイルにビデオを追加する場合は、onError と入力します。
    • 結果ファイルにビデオを追加しない場合は、これ以外の文字列を入力するか、または何も入力しません。
親トピック: ビデオ キャプチャ


結果と結果ファイルの自動削除

実行計画の実行の古い結果と結果ファイルをクリーンアップするルールを定義して、データベース サイズを縮小し、実行計画の実行の管理の容易性を高めます。

この作業を実行するには、実行計画の実行の削除 アクセス許可が必要です。

実行計画を実行すると、結果と結果ファイルが収集され、その総量は徐々に増加していきます。しばらくたつと、ほとんどの結果はもはや意味を持たなくなり、重要な情報だけを残すことで結果を管理しやすくなります。Silk Central では、必要の無くなった結果と結果ファイルを自動的にクリーンアップするルールを定義できます。
  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、結果クリーンアップ ルールを設定するノードを選択します。すべての子ノードで定義したルールが継承されます。未割り当てテスト用のクリーンアップ ルールを定義するには、実行計画 ツリーで 未割り当てテスト ノードを選択します。未割り当てテストには、アップロードした Silk Performer テストや試験実行のような項目が含まれます。
  3. プロパティ ページの 結果クリーンアップ ルール セクションで、ルールの新規作成 をクリックします。 結果クリーンアップ ルールの新規作成 ダイアログ ボックスが表示されます。
  4. ルール タイプ を指定します。結果ファイルだけを削除するか、結果を含む実行全体を削除するかを選択できます。
  5. 次の経過後に削除 リストから、どのくらい時間が経過した後に、ルールが削除を実行するかを選択します。クリーンアップ ルールは、選択したノードに新しい結果が格納されたときに実行されます。
    注: 次のうちのいずれかの条件に合致すると、実行および結果ファイルは削除されません。
    • タグが設定されたビルドのテスト実行が含まれている
    • この実行計画のテストの最新の実行のテスト実行が含まれてる
    • このテストの最新の実行の未割り当てテストが含まれてる
    • 実行計画の実行が 1 つだけ存在する
  6. 結果ファイルの削除 ルール タイプを選択した場合、削除するファイルの種類 フィールドで、特定の種類のファイルだけを削除するように制限できます。ファイルの種類の拡張子を、bmp, png のようにカンマ区切りで指定します。このフィールドを空のままにすると、すべての結果ファイルが削除されます。
  7. OK をクリックします。
クリーンアップ ルールを削除または更新するには、削除 または 編集 アイコンをクリックします。ステータス を切り替えて、クリーンアップ ルールを非アクティブにすることもできます。継承したルールは編集できません。作成したノードでのみ編集できます。
親トピック: 実行計画、フォルダ、構成スイートを管理する
関連タスク
テスト実行の結果を削除する
実行計画の実行および結果ファイルを削除する
関連資料
[実行計画] の [プロパティ] ページ


実行計画ビュー

Silk Central が提供するいくつかのビューとツールを使用して、テストの計画と実行を行うことができます。

  • 実行計画 ツリーで作業する
    実行計画 ツリーの使用方法について説明します。
  • [実行計画] ツールバーの機能
    実行計画を管理するための重要なコマンドが用意されています。
  • [実行計画] の [プロパティ] ページ
    選択したプロジェクト、フォルダ、実行計画、テスト サイクルまたは構成スイートの全プロパティと関連情報が詳しく表示されます。
  • 実行計画 ドキュメント ビュー
    選択したプロジェクトで扱われているすべての実行計画、フォルダ、または構成スイートのプロパティが、読み取り専用情報として一覧表示されます。
  • [現在の実行] ページ
    選択した実行計画のアクティブなテスト実行に関するすべての情報が表示されます。
  • [実行計画] の [履歴] ページ
    選択したプロジェクトの実行計画の履歴が表示されます。
親トピック: 実行計画


実行計画 ツリーで作業する

実行計画 > 詳細ビュー

フォルダ、実行計画、構成スイーツおよびテスト サイクルは、実行計画 ツリーという階層ツリー構造で表示、編成、および維持管理されます。ツリー内では任意の数の階層レベルを使用できます。

注: ページに、一度に表示した場合に応答に影響が出るほど多くの要素がある場合、要素は順に表示されます。ページの下部にあるナビゲーション ツールバーを使用して、要素全体をブラウズすることができます。
  • キーボード操作 (実行計画)
    ツリーでのキーボード操作と複数選択について説明します。
  • 実行計画ツリーの展開と折りたたみ
    表示ニーズに応じて階層レベルを折りたたんだり展開したりするために、実行計画 ツリーの展開と折りたたみを行います。
  • 実行計画ツリーの要素の編集
    実行計画 の要素を編集し、変更されたテスト ニーズに実行定義を適用します。
  • 実行計画ツリーの要素のコピー
    割り当て済みテスト、フィルタ、スケジュール パラメータを再利用するために、実行計画 の要素をコピーして貼り付けます。
  • 実行計画ツリーの要素の削除
    要素に含まれている一連のテストが不要になった場合に、実行計画を削除します。
  • 実行計画ツリーにフィルタを適用する
    実行計画ツリーにフィルタを追加する方法について説明します。
  • 割り当て済みテストの印刷
    割り当て済みテストを PDF ドキュメントまたはローカル プリンターで印刷します。
  • [テスト サイクルのプロパティ] ページ
    [テスト サイクルのプロパティ] ページについて説明します。
親トピック: 実行計画ビュー


キーボード操作 (実行計画)

選択したノードでは、以下のアクションを実行できます。

キー | アクション
Up | 選択項目を上に移動
Down | 選択項目を下に移動
Right | 要素を展開
Left | 要素を折りたたみ
F2 | 要素を編集
Ctrl+C | 要素をコピー
Ctrl+X | 要素を切り取り
Ctrl+V | 要素を貼り付け
Del | 要素を削除
クリック | 要素を選択して、現在の要素として設定
Ctrl + クリック | クリックした要素の選択状況の切り替え、または他の要素をクリックして選択項目への追加/削除
Shift + クリック | 現在の選択要素から新規選択要素までの範囲の選択
Shift+Up | 上の要素を選択
Shift+Down | 下の要素を選択
Enter | 要素の割り当て（割り当てツリーでのみ）
親トピック: 実行計画 ツリーで作業する


実行計画ツリーの展開と折りたたみ

表示上の必要性に応じて、実行計画 ツリーの階層レベルを折りたたんだり、すべての階層レベルを表示したりすることができます。

実行計画 ツリーのレベルの折りたたみや展開を行うには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーでフォルダを選択し、引き続き次のいずれかのオプションを実行します。
    • フォルダ名の左にある 展開 をクリックして、フォルダを展開します。
    • フォルダ名の左にある 展開 をクリックして、フォルダを折りたたみます。
    • フォルダを右クリックして、展開 または 折りたたみ を選択します。
親トピック: 実行計画 ツリーで作業する


実行計画ツリーの要素の編集

既存の実行計画要素を編集するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 ツリーで、編集する実行計画、フォルダ、テスト サイクルまたは構成スイートを選択します。
  3. 詳細 セクションで、編集 をクリックします。 編集 ダイアログ ボックスが表示されます。
  4. ダイアログ ボックスの基準を変更し、要素を編集します。 実行計画では、実行もテストも実行計画に割り当てられていない場合、実行計画に対して代わりのテスト コンテナを、テスト コンテナ リスト ボックスから選択することができます。
  5. OK をクリックして、編集した要素を保存します。
親トピック: 実行計画 ツリーで作業する
関連タスク
実行計画を作成する
関連資料
[実行計画] の [プロパティ] ページ


実行計画ツリーの要素のコピー

実行計画、フォルダ、構成スイートをコピーして貼り付けるには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、コピーする要素を選択します。
  3. ツールバーの コピー をクリックするか、要素を右クリックし、コピー を選択します。
  4. 要素の貼り付け先のフォルダを選択します。
  5. ツールバーの 貼り付け をクリックするか、対象ノードを右クリックして 貼り付け を選択します。 実行計画 ツリーが更新され、貼り付けた要素のコピーが表示されます。 すべての割り当て済みテスト、フィルタ、スケジュール パラメータが、要素と一緒にコピーされます。
親トピック: 実行計画 ツリーで作業する


実行計画ツリーの要素の削除

実行計画、フォルダ、構成スイートを削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、削除する要素を選択します。
  3. ツールバーの 削除 をクリックするか、要素ノードを右クリックして 削除 を選択します。
  4. 削除確認ダイアログ ボックスで はい をクリックして、実行計画 ツリーから要素を削除します。

実行計画 ツリーの要素を削除する際、割り当て済みテストの実行結果も、一緒に削除されます。 テストの実行結果が、その後もレポートに表示される場合がありますが、それは、データベースに保存されており、要素の削除後すぐに更新されていないためです。

親トピック: 実行計画 ツリーで作業する


実行計画ツリーにフィルタを適用する

次の手順に従い、選択されたノードおよび子ノードのみが表示されるよう、実行計画 ツリーをフィルタします。 これは、実行計画のサブセットを PDF に印刷する場合などに便利です。
  1. 表示する実行計画を定義するカスタム フィルタを作成します。
  2. ツリー ビューからフォルダまたは構成スイートを選択し、サブツリーのフィルタ表示 を右クリックして選択します。
親トピック: 実行計画 ツリーで作業する


割り当て済みテストの印刷

実行計画 ツリーの実行計画それぞれに対して、実行計画に割り当てられているすべてのテストについての情報を含んだドキュメントを印刷できます。このドキュメントを PDF またはローカル プリンタに印刷できます。

実行計画に割り当てられたすべてのテストについての情報を印刷するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、実行計画を右クリックし、割り当て済みテストの詳細の印刷 をクリックします。 テストの詳細 ダイアログ ボックスが表示されます。
  3. 割り当て済みテストの情報をローカル プリンターに印刷するには、印刷 をクリックします。PDF ドキュメントとして情報を保存するには、PDF としてダウンロード をクリックします。
親トピック: 実行計画 ツリーで作業する


[テスト サイクルのプロパティ] ページ

実行計画 > 詳細ビュー > <テスト サイクル> > プロパティ

テスト サイクルのプロパティ ページは、実行計画 ツリーからテスト サイクルを選択して プロパティ をクリックすると表示されます。

プロパティの編集 をクリックして テスト サイクルの編集 ダイアログ ボックスを表示して、テスト サイクルの 名前、説明、および 予定時間 を編集することができます。

以下の表に、使用可能なテスト サイクルのプロパティを示します。

プロパティ | 説明
テスト サイクル名 | テスト サイクルの名前。テスト サイクルの編集 ダイアログ ボックスでこの値を編集します。手動実行計画 ユニットのテスト サイクルに移動するには、 [image] をクリックします。
テスト サイクル ID | テスト サイクルの一意の ID。
説明 | テスト サイクルの説明。テスト サイクルの編集 ダイアログ ボックスでこの値を編集します。
前回の実行のステータス | ステータスとはテスト サイクルの実行計画内の前回の実行のテスト ステータスを集約したものであり、次の値を取ります：合格、失敗、未実行、または N/A。
前回の実行の開始時間 | 前回の実行の開始時間。
テスト サイクル開始日 | テスト サイクルのスケジュールされた開始日。
テスト サイクル終了日 | テスト サイクルのスケジュールされた終了日。
最大利用可能時間 (hh:mm) | テスト サイクルにかかると予想される時間。テスト サイクルの編集 ダイアログ ボックスでこの値を編集します。 テスト サイクルに手動テスト担当者を割り当てる場合、最大利用可能時間 の値は各手動テスト担当者の 最大利用可能時間 の合計となります。
予定時間 (hh:mm) | テスト サイクルのすべての割り当て済み実行計画内のすべての手動テストの累積予定時間。
残り時間 (hh:mm) | 最大利用可能時間から予定時間を差し引いた残りの利用可能時間です。
作成日時 | テスト サイクルが作成された日時。
作成者 | テスト サイクルを作成したユーザー。
変更日時 | テスト サイクルが最後に変更された日時。
変更者 | 最後にテスト サイクルを変更したユーザー。

割り当て済み手動テスト担当者

このセクションでは、サイクルに含まれるすべての手動テスト担当者を一覧で示します。

プロパティ | 説明
テスト担当者 | テスト担当者の名前。
最大利用可能時間 | このテスト担当者がテスト サイクルに利用可能な時間を hh:mm 形式で入力します。各テスト担当者のすべての最大利用可能時間値の合計がテスト サイクルの 最大利用可能時間 の値となります。
テスト担当者の追加/削除 | クリックして、テスト担当者をテスト サイクルに追加するために使用する 手動テスト担当者 ダイアログ ボックスが開きます。
親トピック: 実行計画 ツリーで作業する
関連概念
手動実行計画
関連資料
[実行計画] の [プロパティ] ページ
[実行] の [実行] ページ


[実行計画] ツールバーの機能

実行計画 > 詳細ビュー

実行計画 > ドキュメント ビュー

実行ツールバーには、実行計画を管理するための重要なコマンドがあります。

注: 実行計画ツールバーの一部のコマンドは、実行計画 ツリーのコンテキスト メニューからも利用できます。

以下のコマンドが、[実行計画] ツールバーに含まれています。

コマンド | アイコン | 説明
詳細ビュー | 要件ビュー | 実行計画 ツリーの単一の要素のプロパティを詳しく表示できる、詳細ビュー を表示します。
ドキュメント ビュー | ドキュメント ビュー | すべての実行の選択したプロパティが単一のビューで示される、ドキュメント ビュー を表示します。
子フォルダの新規作成 | ドキュメント ビュー | 新しいフォルダを選択したプロジェクトまたはフォルダに追加します。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
子テスト サイクルの新規作成 | ドキュメント ビュー | 新しいテスト サイクルを選択したプロジェクトまたはフォルダに追加します。
子構成スイートの新規作成 | ドキュメント ビュー | 新しい構成スイートを選択したプロジェクトまたはフォルダに追加します。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
子実行計画の新規作成 | ドキュメント ビュー | 新しい実行計画を選択したプロジェクト、フォルダ、または構成スイートに追加します。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
編集 | 編集 | 実行計画 ツリーの選択した要素を開いて編集します。
削除 | 削除 | 実行計画 ツリーの選択した要素を削除します。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
切り取り | 切り取り | 実行計画 ツリーの要素を切り取り、クリップボードに保存します。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
コピー | コピー | 実行計画 ツリーの要素をクリップボードにコピーします。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
貼り付け | 貼り付け | クリップボードから 実行計画 ツリーに、要素を貼り付けます。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
子として貼り付け | 子として貼り付け | クリップボードから 実行計画 ツリーで現在選択されている要素に、子として要素を貼り付けます。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
実行 |  | 実行計画に割り当てられているテストの実行を開始します。 このコマンドは、テスト サイクルに割り当てられている実行計画では表示されません。
フィルタの新規作成 | フィルタの新規作成 | 実行計画 ツリーに新しいカスタム フィルタを作成します。
フィルタ |  | 実行計画 ツリーで利用可能なフィルタを一覧表示します。
フィルタの編集 | フィルタの編集 | 現在選択されているカスタム フィルタを編集します。
フィルタの削除 | フィルタの削除 | 現在選択されているカスタム フィルタを削除します。
フィルタのコピー | フィルタの削除 | 現在選択されているカスタム フィルタをコピーします。
PDF としてダウンロード | PDF としてダウンロード | この機能は、ドキュメント ビュー でのみ有効になります。 アクションによって、実行計画 ツリーで現在表示されているすべてのノードが含まれる PDF が生成されます。
親トピック: 実行計画ビュー


[実行計画] の [プロパティ] ページ

実行計画 > 詳細ビュー > <実行ツリー要素> > プロパティ

プロパティ ページには、選択したプロジェクト、フォルダ、実行計画、テスト サイクルまたは構成スイートの全プロパティと関連情報が詳しく表示されます。このページの各セクションは、必要に応じて展開したり、折りたたんだりすることがができます。これにより、個々のユーザーに必要な情報を表示するようにカスタマイズできます。

詳細

詳細 セクションには、選択した要素に関する基本情報が表示されます。詳細については、「実行計画を作成する」および「実行計画ツリーの要素の編集」を参照してください。

実行ステータス

実行ステータス セクションには、最新の実行に関する情報が表示されます。前回の実行のステータス には、フォルダまたは構成スイートに対して、実行計画の最新実行で累積されたテスト ステータス、または含まれるすべての実行計画で累積されたテスト ステータスが表示されます。実行時間 には、実行計画の最新実行の期間、または、フォルダか構成スイートの場合は、含まれているすべての実行計画の最新実行で累積された期間が表示されます。最も単純なケース (単一実行サーバーでの自動テストの場合や手動テストのみの場合) では、実行時間は 実行 ページに表示されている最新実行の時間になります。最新の実行で自動テストと手動テストが両方とも実行された場合は、テストが後で実行されるかどうかで、自動テストのみあるいは手動テストのみが考慮されます。実行計画に複数のテストが含まれている場合は、最初のテストの実行開始時点から最後のテストの実行完了時点までが実行時間になります。これにはオーバーヘッド時間、すなわち実行の合間にテストの停止/開始に必要な時間も含まれます。

その他の情報については、「テスト実行を分析する」を参照してください。

テスト実行セットアップ

テスト実行セットアップ セクションには、割り当て済みのテストやテスト担当者に関する情報が表示されます。詳細については、「実行計画、フォルダ、構成スイートを管理する」および「テストの割り当て」を参照してください。

属性

属性とは、実行計画に適用できる自由に定義可能な特性です。その他の情報については、「実行計画属性」を参照してください。

パラメータ

パラメータ セクションには、自由に設定できる入力値であるパラメータに関する情報が表示されます。その他の情報については、「実行計画パラメータ」を参照してください。

通知とレポート

通知とレポート セクションには、実行の結果に基づいた通知が必要かどうかを指定するためのチェック ボックスがあります。変更が機能するのは、電子メール サーバーが管理者によって設定されている場合だけです。アカウントの電子メール アドレスも、 <ユーザー名> > ユーザー設定 で指定する必要があります。さらに、実行の結果に基づいてレポート配信登録をトリガーすることができます。利用可能なレポートのリストは、配信登録が定義されたレポートに基づきます。詳細については、「レポート配信登録を管理する」を参照してください。

チェック ボックス | 説明
実行が正常に終了した時 | これにチェックをすると、実行が正常に終了するたびに、通知 E メールを受信します。
実行に合格しなかったテストが存在する時 | オンにすると、実行がステータス [未実行] または [失敗] で終わるたびに、通知電子メールを受信します。
実行で合格しなかったテスト数が変化した時 | これにチェックを付けると、実行が終了した際に、前の実行と比較して、「失敗」または「未実行」のテストの数が変わるたびに、通知 E メールを受信します。

結果クリーンアップ ルール

結果クリーンアップ ルール セクションを使用すると、実行計画の実行の古い結果と結果ファイルをクリーンアップするためのルールを定義できます。詳細については、「結果と結果ファイルの自動削除」を参照してください。

親トピック: 実行計画ビュー
関連概念
構成テスト
関連タスク
実行計画ツリーの要素の編集
実行計画を作成する
結果と結果ファイルの自動削除
レポート配信登録を管理する
関連資料
[実行] の [実行] ページ


実行計画 ドキュメント ビュー

実行計画 > ドキュメント ビュー

実行計画 領域は、実行プロパティの 2 種類のビューを提供します：ドキュメント ビュー および 詳細ビュー。ドキュメント ビュー では、選択したプロジェクトで扱われているすべての実行計画、フォルダ、および構成スイートの最新実行で定義されたプロパティおよび特性が、読み取り専用情報として一覧表示されます。ドキュメント ビュー を使用して、実行計画の実行を計画します。フィルタを使用すると、フィルタが適用された実行計画サブセットの実行時間の見積もりを取得できます。

この ドキュメント ビュー には、選択された要素の次の列が 実行計画 ツリーで表示されます。

列 | 説明
ステータス | フォルダまたは構成スイートに対して、実行計画の最新実行で累積されたテスト ステータス、または含まれるすべての実行計画で累積されたテスト ステータス。実行計画 ツリーにフィルタを適用した場合、テスト ステータスの合計はフィルタが適用された実行計画にのみ基づきます。
割り当て済みテスト | 割り当て済みテストの総数。実行計画 ツリーにフィルタを適用した場合、割り当て済みテストの量はフィルタが適用された実行計画にのみ基づきます。
ビルド | 実行計画の実行時に使用されるビルド。
バージョン | 実行計画の実行時に使用されるバージョン。
製品 | 関連テスト コンテナが基づいている製品。
優先度 | 自動実行計画の場合、複数の実行計画がキューに入れられたが、1 台の実行サーバーのみが使用可能な場合、優先度 によって、最初に実行される実行計画が決定されます。実行サーバーが使用可能でも、複数の実行計画が使用できないモバイル デバイスを必要としている場合も同様です。
前回の実行 | 実行計画が最後に開始された日時。
予定時間 | すべての手動テストの予定時間の合計。実行計画 ツリーにフィルタを適用した場合、予定時間はフィルタが適用された実行計画にのみ基づきます。
実行時間 | 実行計画の最新実行の期間。または、フォルダか構成スイートの場合は、含まれているすべての実行計画の最新実行で累積された期間。実行計画 ツリーにフィルタを適用した場合、実行時間はフィルタが適用された実行計画にのみ基づきます。
次回の実行 | 次に予定されている実行。
テスト コンテナ | この実行計画に割り当てることができるテストが含まれているテスト コンテナ。
属性 | 実行計画に割り当てられた属性がある場合、グリッドに表示するよう選択できます。属性とは、実行計画に適用できる自由に定義可能な特性です。フィルタやレポートに対して、属性を使用できます。
注: 実行計画の合計は、現在表示されているすべての実行計画に関して親レベルになります。実行計画 ツリーにフィルタを適用した場合、実行計画の合計はフィルタが適用された実行計画にのみ基づきます。たとえば、実行計画の合計にはフィルタによって選択されるすべての子実行計画からの実行が含まれ、プロジェクトの合計にはフィルタによって選択されるすべての実行計画からの実行が含まれます。
親トピック: 実行計画ビュー


[現在の実行] ページ

実行計画 > 詳細ビュー > <実行計画> > 現在の実行

実行計画の 現在の実行 ページにアクセスするには、実行計画 ツリーで実行計画をクリックし、現在の実行 タブをクリックします。現在の実行 ページには、選択した実行計画のアクティブなテスト実行に関するすべての情報が表示されます。手動テスト実行や自動テスト実行に応じて、さまざまなページが表示されます。

手動テスト実行

現在の実行 ページには、テスト実行が完了するまでアクティブな手動テストの実行が表示されます。テスト サイクルに割り当てられている手動テストでは、このページは 実行 ページに名前が変わります。この場合、実行 ページには、実行が完了するまで引き続き実行が表示されます。このページには 2 つのグリッド ビュー、割り当て済みテスト と テスト ステップ が装備されています。割り当て済みテスト には、アクティブな手動テストの実行に関する情報が表示され、テスト ステップ には、その手動テストの各ステップに関する情報が表示されます。割り当て済みテスト ビューでは、列を選択し、テストにフィルタをかけることができます。テストの詳細 ビューと ステップの詳細 ビューには、追加情報が表示されます。

再読み込みをクリックし、現在の実行 ページを更新します。実行計画でテストの割り当てを変更したり、テスト 領域でテストを更新した場合に、これらの変更を現在実行中のテストに反映させたい場合には、現在の実行を同期 をクリックします。これにより、現在実行中のすべての割り当て済みテストが更新されます。

現在の実行 が完了していない状態で、別の実行計画の実行が開始された場合、新しい実行が利用可能な旨を伝える注が表示されます。これら実行に関する情報は、アクティビティ ページで参照できます。

自動テスト実行

自動テストについては、現在の実行 ページで実行の進捗が表示されます。更新 をクリックすると、現在の実行 ページを更新できます。モバイル デバイス上で実行する自動テストでは、スクリーンキャストの表示 をクリックして、デバイス上の操作をライブ ストリーム表示することができます。Sauce Labs デバイスでは、ライブ ストリームを利用できません。

親トピック: 実行計画ビュー
関連タスク
既存の問題を割り当てる


[実行計画] の [履歴] ページ

実行計画 > 詳細ビュー > <プロジェクト> > 履歴

履歴 ページには、選択したプロジェクトの実行計画履歴が表示されます。列を表示または非表示にしたり、幅を調整したり、列をドラッグして移動し、順序を変更したりできます。列をクリックすると、グリッドの内容をフィルタできます。以下の作業を行うと、実行計画履歴に新たな記載が追加されます。

  • 実行計画、フォルダ、テスト サイクル、構成スイート、または構成を削除する
注: ページに、一度に表示した場合に応答に影響が出るほど多くの要素がある場合、要素は順に表示されます。ページの下部にあるナビゲーション ツールバーを使用して、要素全体をブラウズすることができます。
親トピック: 実行計画ビュー


Silk Performer プロジェクトで作業する

Silk Performer は Silk Central のテストおよび実行機能と完全に統合されています。Silk Performer プロジェクトは、Silk Central のテストに統合し、Silk Central を通じて直接実行することができます。これにより、強力なテスト結果分析とレポート作成が可能になります。また、無人テスト（あらかじめ構成されたスケジュールに基づいて Silk Central で自動的に実行されるテスト）も可能です。

Silk Performer と Silk Central の統合の設定に関する詳細については、『Silk Performer ヘルプ』を参照してください。

Silk Central から Silk Performer で Silk Performer プロジェクト ファイルを直接開き、スクリプトや設定を編集することができます。編集された Silk Performer プロジェクトをその後 Silk Central に再びチェックインして、以後のテスト実行に利用できるようにすることが可能です。

注: 「プロジェクト」という用語の使い方は、Silk Performer と Silk Central では異なります。Silk Performer プロジェクトは、Silk Central にアップロードされると、Silk Central テストの中核的な要素になります。Silk Central プロジェクトは、複数の Silk Performer プロジェクト、テスト、実行計画、要件を含むことができる上位レベルのエンティティです。
  • Silk Performer プロジェクトをダウンロードする
    Silk Central から独立して操作するために、Silk Performer プロジェクトをダウンロードします。
  • Silk Performer プロジェクトを開く
    Silk Central から Silk Performer プロジェクトを開き、Silk Performer で編集します。
  • 実行計画の実行プロパティへのアクセス
    Silk Central は、Silk Performer テスト実行中に、実行計画の実行プロパティに関する情報を提供します。
  • 有人 Silk Performer テストを実行する
    Silk Performer でテストを手動で実行するために、有人 Silk Performer テストを実行します。
  • Silk Performer テスト プロパティを編集する
    ニーズに合わせてテストを適用するために、Silk Performer テスト プロパティを編集します。
  • Silk Performer テスト結果を分析する
    Silk Performer テスト結果を分析する方法について説明します。
  • Silk Performer テスト結果パッケージをダウンロードする
    テスト実行の結果セット一式を分析するために、Silk Performer テスト結果パッケージをダウンロードします。
  • Silk Performer テスト結果をアップロードする
    Silk Performer テスト結果を Silk Central にアップロードし、結果をテストに関連付けます。
  • Silk Performance Explorer を使用する
    Silk Performance Explorer は、テスト実行の詳細な分析に使用します。
親トピック: 実行計画
関連概念
Silk Performer テスト
テスト パラメータ
関連タスク
Silk Performer テストを作成または編集する
関連資料
事前定義パラメータ
Java システム プロパティを通じて Silk Central パラメータにアクセスする


Silk Performer プロジェクトをダウンロードする

Silk Performer プロジェクトを開く場合は、ソース管理ツールからの Silk Performer プロジェクトのチェックアウト、Silk Performer でのプロジェクトの編集、Silk Central へのプロジェクトのチェックインが必要になることがあるのに対して、プロジェクトをダウンロードする場合は、プロジェクトのコピーをダウンロードし、それを Silk Central から独立して取り扱うことになります。 ダウンロードしたプロジェクトに変更を加えても、Silk Central に自動的には反映されません。

Silk Performer プロジェクトをダウンロードするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、Silk Performer テストを選択します。
  3. プロパティ タブをクリックします。
  4. Silk Performer テスト プロパティ セクションまでスクロールします。
  5. プロジェクトのダウンロード をクリックします。 [ファイルのダウンロード] ダイアログ ボックスが表示され、指定した Silk Performer プロジェクトをローカル システムにダウンロードするかどうか確認を求められます。
  6. 保存 をクリックして、ファイルを Silk Performer で開きます。 Silk Performer がまだバックグラウンドで開いていない場合は、ここで起動されます。
  7. ターゲット ディレクトリの選択 ダイアログ ボックスが表示され、指定した Silk Performer プロジェクトの保存先となるデフォルト ディレクトリ パスが選択されます。 指定されたパス名でよい場合は、OK をクリックします。そうでない場合は、参照 をクリックして代わりのパスを指定します。
    注: ソース管理インテグレーションが構成されていても、Silk Central から独立してこのファイルを取り扱っているため、Silk Performer プロジェクトをソース管理システムからチェックアウトするように指示されることはありません。
    注: Silk Central で利用される Silk Performer プロジェクトは、Silk Performer ユーザー インターフェイスから直接ダウンロードすることもできます。 その他の情報については、Silk Performer のドキュメントを参照してください。
親トピック: Silk Performer プロジェクトで作業する


Silk Performer プロジェクトを開く

Silk Central から Silk Performer プロジェクトを開くには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、Silk Performer テストを選択します。
  3. プロパティ タブをクリックします。
  4. Silk Performer テスト プロパティ セクションまでスクロールします。
  5. Silk Performer プロジェクトを開く... アイコンをクリックします。
    ファイルのダウンロード ダイアログ ボックスが表示され、指定した Silk Performer コマンド ファイル（.spwbcmd）を Silk Performer で開くかどうか確認を求められます。
  6. 開く をクリックして、ファイルを Silk Performer で開きます。Silk Performer がまだバックグラウンドで開いていない場合は、ここで起動されます。 ターゲット ディレクトリの選択 ダイアログ ボックスが開き、指定した Silk Performer プロジェクトの保存先となるデフォルト ディレクトリ パスが選択されます。
  7. 指定されたパス名でよい場合は、OK をクリックします。そうでない場合は、参照 をクリックして代わりのパスを指定します。
  8. Silk Central のソース管理インテグレーション（StarTeam など）を構成してある場合は、ソース管理クライアントのログイン画面が表示されます。有効なユーザー接続設定値を入力し、OK をクリックして続行します。
    注: Silk Central で利用される Silk Performer プロジェクトは、Silk Performer から直接開くこともできます。その他の情報については、Silk Performer のドキュメントを参照してください。
親トピック: Silk Performer プロジェクトで作業する


実行計画の実行プロパティへのアクセス

Silk Central は、Silk Performer テスト実行中に、実行計画の実行プロパティに関する情報を提供します。Silk Performer スクリプトで AttributeGet メソッドを使用して、実行計画の実行プロパティにアクセスしてください。スクリプトでは次のプロパティにアクセスできます。
パラメータ
説明
#sctm_execdef_name
現在実行されている実行計画の名前。実行が テスト 領域からトリガされた場合、パラメータは値 未割り当てテスト を持ちます。
#sctm_execdef_id
現在実行されている実行計画の数値識別子 (データベース キー)。
#sctm_product
実行されたテスト コンテナで定義された製品の名前。
#sctm_version
実行の結果が関連付けられているバージョンの名前。
#sctm_build
実行の結果が関連付けられているバージョンの名前。
#sctm_keywords
この実行計画に対して定義されているキーワードを含むカンマ区切りの一覧。
#sctm_test_results_dir
テストの結果ファイルが存在するディレクトリのパス。
#sctm_test_name
実行している Silk Central テストの名前。
#sctm_test_id
実行しているテストの数値識別子 (データベース キー)。
#sctm_source_root_dir
バージョン コントロール下にあるすべてのファイルが置かれているテスト コンテナのルート ディレクトリのローカル パス。
#external_id
実行されるテスト パッケージ内のテスト ケースの一意の識別子。テスト パッケージ内の特定のテスト ケースだけを実行させる場合のフィルタとして利用できます。

#is_test_package_root
true の場合、実行されるテストはテスト パッケージのルート ノードです (デフォルト)。false の場合、#external_id によって指定されたテスト パッケージ内の特定のテスト ケースだけが実行されます。
#sctm_data_driven_parent_test_name
親のテストの名前 (実行したテストがデータ駆動行の場合)。
#sctm_data_driven_parent_test_id
親のテストの数値識別子 (データベース キー) (実行したテストがデータ駆動行の場合)。
親トピック: Silk Performer プロジェクトで作業する


有人 Silk Performer テストを実行する

有人テストとは、Silk Performer で手動で実行され、Silk Central にあらかじめ定義されているスケジュールに基づいて自動的に実行されない Silk Performer テストのことです。

注: Silk Central のデータ駆動型テスト機能を Silk Performer スクリプトに対して使用するには、対応する Silk Performer プロジェクト属性に一致する列名を持つデータ ソースが AttributeGet メソッドと共に使用されなければなりません (password 属性を渡すことはできません。スクリプトで指定された値が常に使用されます)。

Silk Performer で有人テストを実行するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、Silk Performer テストを選択します。
  3. プロパティ タブをクリックします。
  4. Silk Performer テスト プロパティ セクションまでスクロールします。
  5. 有人実行 をクリックします。 ファイルのダウンロード ダイアログ ボックスが表示され、指定した Silk Performer コマンド ファイル（.spwbcmd）を実行するかどうか確認を求められます。
  6. 開く をクリックして、プロジェクトを Silk Performer で開きます。 Silk Performer がまだバックグラウンドで開いていない場合は、ここで起動されます。ターゲット ディレクトリの選択 ダイアログ ボックスが表示され、指定した Silk Performer プロジェクトの保存先となるデフォルト ディレクトリ パスが選択されます。
  7. 指定されたパス名でよい場合は、OK をクリックします。そうでない場合は、参照 をクリックして代わりのパスを指定します。 Silk Performer のワークロードの設定 ダイアログ ボックスが開き、Silk Performer プロジェクトに関連付けられているワークロード設定がすべて表示されます。
  8. ワークロード設定を必要に応じて編集した後、実行 をクリックしてテストを開始し、Silk Performer でテスト結果を監視します。
    注: ワークロード設定をまったく編集せずに 実行 をクリックすると、直接 Silk Central から無人テストとして実行された場合とまったく同じように Silk Performer テストが実行されます。
親トピック: Silk Performer プロジェクトで作業する


Silk Performer テスト プロパティを編集する

注: Silk Performer スクリプトで Silk Central のデータ駆動型テスト機能を使用するには、対応する Silk Performer プロジェクト属性に列名が一致するデータ ソースを AttributeGet メソッドと共に使用する必要があります。

Silk Performer テスト プロパティを編集するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、Silk Performer テストを選択します。
  3. プロパティ タブをクリックします。
  4. Silk Performer テスト プロパティ セクションまでスクロールします。
  5. Silk Performer テスト プロパティの編集 をクリックします。
  6. Silk Performer テストの設定に進みます。
親トピック: Silk Performer プロジェクトで作業する


Silk Performer テスト結果を分析する

Performance Explorer を利用すると、Silk Performer テスト結果の詳細な分析が可能になります。結果の分析 オプションでは、「結果パッケージのダウンロード」とは異なり、選択した結果のみダウンロードされます。最適化作業の結果を分析しやすくするため、Performance Explorer では、カスタム比較レポートで複数のテスト実行から得られた統計値を並べて比較できます。

Silk Central を利用して実行されたテストの結果は、テスト 領域の 実行 ページにあるコマンドを使って Performance Explorer に自動的にロードできます。

Performance Explorer の使用および Silk Performer と Silk Central との統合の詳細については、Silk Performer のドキュメントを参照してください。

Performance Explorer で Silk Performer テスト結果を開くには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 表示するテストを選択します。
  3. 実行 タブをクリックします。
  4. 結果のダウンロード対象となるテスト実行の アクション 列で、 結果の分析 をクリックします。 ファイルのダウンロード ダイアログ ボックスが表示され、ダウンロードしようとしている Performance Explorer コマンドファイル（.sppecmd）の名前が表示されます。
  5. 開く をクリックして、結果を Performance Explorer で開きます。または、保存 をクリックすると、結果をローカルに保存できます。
  6. インストールされている Silk Central に直接接続した状態で Performance Explorer が開き（まだバックグラウンドで開いていない場合）、選択したテスト実行の結果が取り出されます。
    注: 単一のレポートで複数のテスト実行の結果を比較するカスタム比較レポートの準備をする場合は、実行 ページからさらに他の実行の結果をダウンロードできます。追加でダウンロードした実行結果は、既に開いている Performance Explorer インスタンスの Silk Central リボンに表示されます。カスタム比較レポートの詳細については、Performance Explorer のドキュメントを参照してください。
親トピック: Silk Performer プロジェクトで作業する


Silk Performer テスト結果パッケージをダウンロードする

テスト実行の結果セット一式を分析する場合や、結果セット一式をオフライン分析用にダウンロードする場合は、結果パッケージをダウンロードするのが最もよいでしょう。 結果パッケージには大きい TrueLog On Error ファイルが含まれていることが多いので、結果パッケージを圧縮して .lrz ファイルとしてローカル ハード ディスクにダウンロードすることができます。 また、結果をローカルにダウンロードすると、低速のインターネット接続を使って作業している場合にも役に立つことがあります。

Silk Performer テスト結果をダウンロードするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーで、Silk Performer テストを選択します。
  3. 実行 タブをクリックします。
  4. 結果をダウンロードするテスト実行の アクション 列で、 結果をダウンロード をクリックします。 ファイル ダウンロード ダイアログ ボックスが開き、ダウンロードしようとしている圧縮済みの結果パッケージ ファイル（.ltz）の名前が表示されます。
  5. 開く をクリックして、結果を Performance Explorer で開きます。または、保存 をクリックすると、結果をローカルに保存できます。
  6. Performance Explorer がまだバックグラウンドで開いていない場合は、ここで開かれます。 プロジェクトのインポート ダイアログ ボックスが開き、結果の保存先となるターゲット ディレクトリが表示されます。 デフォルト パスをそのまま使用する場合は OK をクリックし、別のパスを選択する場合は 参照 をクリックします。 ダウンロードしたテスト結果は Performance Explorer に表示されます。
    注: デフォルト プロジェクト ディレクトリをそのまま使用すると、結果パッケージが保存されます (通常、この方法を推奨)。その場合、結果は他のすべての Silk Performer 結果と一緒に保存され、Performance Explorer の Add Loadtest Results コマンドを使用して簡単にアクセスできます。
親トピック: Silk Performer プロジェクトで作業する


Silk Performer テスト結果をアップロードする

Silk Performer で有人テストの実行が完了したら、そのテスト結果を Silk Central にアップロードし、テストに関連付けることができます。

有人 Silk Performer テストの結果をアップロードするには：

  1. 有人 Silk Performer テストを実行します。 詳細については、「有人 Silk Performer テストを実行する」を参照してください。
  2. テストが完了したら、結果 メニューから 結果を Silk Central へアップロード を選択します。 結果を Silk Central へアップロード ウィザードの ログイン 画面が表示されます。
  3. パスワード フィールドに値を入力し、次へ をクリックします。
    注: これは有人テストなので、結果のアップロード先となるテストの正しいホスト名（[ホスト名] フィールド）とユーザー名（[ユーザー名] フィールド）はウィザードには既にわかっています。
  4. Silk Performer 結果のアップロード先となる Silk Central プロジェクトを選択します（プロジェクト リストでデフォルトで選択されていない場合）。
  5. 結果のアップロード先となるテストを選択します (ツリー リストでデフォルトで選択されていない場合)。次へ をクリックします。
    注: ツリー内を右クリックし、コンテキスト メニューのコマンドを使用して、結果の保存先となるテスト、子テスト、テスト フォルダ、あるいは子テスト フォルダを新規作成することができます。
  6. その次の画面では、アップロードした結果が所属することになる割り当て済み製品のバージョン番号（[バージョン] フィールド）とビルド番号（[ビルド] フィールド）を指定することができます。また、Silk Performer テスト結果のステータス（[合格]、[失敗] など）を指定することもできます。
    注: テスト実行中にエラーが発生した場合、テスト結果ステータスはデフォルトで [失敗] に設定されます。
  7. 完了 をクリックすると、結果がアップロードされます。 アップロードされた結果は、テスト > 詳細ビュー > <Silk Performer テスト> > 実行 に表示されます。
親トピック: Silk Performer プロジェクトで作業する
関連タスク
有人 Silk Performer テストを実行する


Silk Performance Explorer を使用する

Silk Performance Explorer (Performance Explorer) は、テスト実行の詳細な分析に使用します。 Performance Explorer の結果分析は、Silk Central の 実行 領域と テスト 領域から 実行 ページの実行を通じて直接起動できます。また、Performance Explorer 自体から起動することもできます。 Performance Explorer と Silk Central のインテグレーションの詳細については、Performance Explorer のドキュメントを参照してください。

また、Silk Performer での負荷テストの実行結果を Silk Central にアップロードし、テストに関連付けることもできます。 詳細については、『Silk Performer ヘルプ』を参照してください。

Silk Central と Silk Performer のインテグレーションの詳細については、『Silk Performer ヘルプ』および『Performance Explorer ユーザー ガイド』を参照してください。

親トピック: Silk Performer プロジェクトで作業する
関連概念
Silk Performer プロジェクトで作業する


Silk Test Classic のテスト

このセクションでは、Silk Test Classic でテストを実行する方法について説明します。

  • Silk Test Classic AUT ホストを追加する
    Silk Test Classic エージェントが実行サーバーとは異なるコンピュータ上に配置されている場合に、Silk Test Classic AUT ホストを追加します。
  • Silk Test Classic テストの自動実行
    Silk Test Classic テストの自動実行について説明します。
  • データ駆動型 Silk Test Classic テストケースの自動実行
    データ駆動型 Silk Test Classic テストケースの実行モード オプションについて説明します。
  • テスト対象エージェント（AUT）の指定
    テスト対象の Silk Test Classic エージェントのホスト名とポートを指定する方法について説明します。
  • Silk Test Classic のタイムアウト設定
    Silk Test Classic のタイムアウト設定について説明します。
  • Silk Test Classic のログ
    テスト実行中に各テストケースについてデータのログを取るために、RMS ログ ファイルが使われます。
親トピック: 実行計画
関連概念
Silk Test Classic テスト
関連タスク
Silk Test Classic テストを作成または編集する


Silk Test Classic テストの自動実行

1 つの実行計画内のテストはすべて、同じSilk Test Classic インスタンスを使ってテストされます。 Silk Test Classic の GUI は、最初の Silk Test Classic テストが実行されるときに一度開き、最後の Silk Test Classic テストの実行が終わると自動的に閉じられます。 Silk Test Classic テスト実行ごとに結果が生成されます。 何らかの理由でテスト中に Silk Test Classic GUI が閉じた場合、GUI は次の Silk Test Classic テストが実行されるときに再び自動的に開きます。

親トピック: Silk Test Classic のテスト


データ駆動型 Silk Test Classic テストケースの自動実行

Silk Test Classic のテスト プロパティで データ駆動型 チェック ボックスをオンにすると、Silk Test Classic のテストは、外部データソースのデータ行ごとに 1 回ずつ繰り返されます。デフォルトでは、データ駆動型テストの実行モードは計画ベースです。つまり、すべてのデータ行の結果が、.res 結果ファイルの 1 つのノードの下に含められることになります。SccExecServerBootConf.xml で実行モードをスクリプトベースのデータ駆動型に変更すると、.res 結果ファイルにはデータ行ごとに 1 つの結果ノードが作成されます。

親トピック: Silk Test Classic のテスト


テスト対象エージェント（AUT）の指定

Silk Test Classic エージェントを Silk Central 実行サーバーと同じマシンで実行できない場合 (たとえば Windows 以外のプラットフォームでテストを実行する場合)、実行計画の 配置 ページの [Silk Test Classic AUT ホスト名] の設定でホスト名とポートが指定されている可能性があります。 そこで設定されていない場合には、Silk Test Classic のデフォルト値（たとえば partner.ini の設定など）が使われます。 AUT の構文は hostname:port です。 エージェントは、テスト実行の前に手動で起動し、指定されたポートをリスンするよう設定しておく必要があります。 デフォルトでは、Silk Test Classic インスタンスと Silk Test Classic エージェントの間の通信には TCP/IP プロトコルが使われます。 両方のプログラムが同じプロトコルを使うように設定されていることを確認してください。

注: 実行計画に複数の実行サーバーが割り当てられているときには注意が必要です。Silk Test Classic エージェントは一度に 1 つの Silk Test Classic インスタンスとしかやり取りできないからです。
親トピック: Silk Test Classic のテスト


Silk Test Classic のタイムアウト設定

完了するまでにかかる時間が 1 時間を超える Silk Test Classic テストケースがある場合は、Silk Central のタイムアウト設定を調整する必要があります。 そうしないと、Silk Central は、実行時に問題が発生したと見なして Silk Test Classic を終了します。 Silk Test Classic タイムアウト設定の詳細については、この『ヘルプ』の「管理」トピックを参照してください。

親トピック: Silk Test Classic のテスト


Silk Test Classic のログ

テスト実行中に各テストケースについてデータのログを取るために、Silk Test Classic の RMS ログ ファイルが使われます。 このファイルには、ステータス、メモリ、ユーザーという、3 種類のデータ レコードが書き込まれます。 RMS Remote Agent は、このファイルを監視して、各テスト実行の進捗を判断します。

PrintToRMSLog 4Test 関数を実行すると、独自のコメントをログ ファイルのユーザー レコードに書き込むことができます。

例：
PrintToRMSLog ("Error", "An intended error")
PrintToRMSLog ("Info", "testcase sleep1 started")
PrintToRMSLog ("Warning", "TestCase 1 started a second time")
rms.inc でのユーザー関数の定義：
PrintToRMSLog (STRING sMessageType, STRING sUserMessage)
以下の形式でログ ファイルに書き込みます。
U|{sTestCaseName}|{sScriptName}|{sArgStr}|{sUserMessage}|{sMessageType}
親トピック: Silk Test Classic のテスト


問題追跡と結果分析

テスト結果を分析し、発生した問題を作成したり追跡したり、さらに、レポートを使用して結果を文書化します。
  • テスト実行を分析する
    Silk Central を使用してテスト実行を分析する方法について説明します。
  • 追跡
    追跡領域の使用方法について説明します。
  • 問題
    このセクションでは、Silk Central で問題を管理する方法について説明します。
  • レポート
    Silk Central レポートで作業する方法について説明します。
親トピック: Silk Central ヘルプ


テスト実行を分析する

このセクションでは、Silk Central を使用してテスト実行を分析する方法について説明します。

  • 手動テストの結果の分析
    手動テスト結果 ビューを使用して、添付した問題や添付情報のようなすべての情報を含む手動テストの結果ビューを簡単に参照することができます。
  • 自動テスト結果を分析する
    実行計画の実行のテスト結果を表示し、拡張された根本原因分析を行ったり、複数の実行の結果をテストのステータスの変化を可視化して比較します。
  • 複数のテスト実行のテスト結果の比較
    1 つのテストの複数の実行の結果を比較して、テスト ステータスの差異を可視化できます。
  • テスト実行のステータスを変更する
    実行のステータスを手動で変更するために、特定のテスト実行のステータスを変更します。
  • テストの実行詳細を表示する
    テストの実行詳細を表示します。
  • テスト実行の結果を削除する
    特定のテスト実行の結果を削除します。
  • 実行計画の実行および結果ファイルを削除する
    実行計画の実行および結果ファイル、フォルダ、またはプロジェクトを削除する方法について説明します。
  • 実行計画の実行の結果
    実行計画の実行の詳細を一覧表示します。
  • テスト実行の結果
    テストまたは実行計画の実行詳細が一覧表示されます。
  • データ駆動型テストの実行アクティビティを表示する
    データ駆動型テストの実行アクティビティを表示して、テストが正常に実行するかどうかを確認します。
  • [実行] の [実行] ページ
    選択した実行計画の実行の統計値が表示されます。
親トピック: 問題追跡と結果分析


手動テストの結果の分析

完了または未完了のコンテキストのいずれかのテスト実行があるとき、手動テスト結果 ビューを使用して、添付した問題や添付情報のようなすべての情報を含む手動テストの結果ビューを簡単に参照することができます。この情報のすべては直ちに表示されます。同様に、PDF 版の印刷やダウンロードも可能です。

手動テスト結果 ビューは、左側にツリー ビューが、右側に詳細ビューがあります。ツリー ビューは結果ビューを開いた時に選択中の内容に基づきます。たとえば、テスト サイクルを選択した場合、すべての割り当て済みテスト担当者とそのテストが表示されます。特定のノードを選択すると、選択に応じた情報で詳細ビューが更新されます。

手動テスト結果 ビューを開くには、手動テストを参照するほぼすべてのコンテキストで、テストの 手動テスト結果の表示 アイコン ( [image]) をクリックします。これは、手動実行計画、ダッシュボード パネル、アクティビティ ページ、実行計画の 実行 グリッド、およびテストの 実行 グリッドから行うことができます。

親トピック: テスト実行を分析する


自動テスト結果を分析する

実行計画の実行のテスト結果を表示し、拡張された根本原因分析を行ったり、複数の実行の結果をテストのステータスの変化を可視化して比較します。

テスト結果 ビューと実行の比較 ビューは、結果の概要を読みやすくするために、完全なドリルダウン機能を提供します。結果ファイル、スクリーンショットのサムネイル、メッセージ、スタックトレースなどのすべての情報が含まれます。これによって、とくに、複数の実行結果を横に並べて比較することもできるため、失敗したテスト実行の根本原因をすばやく分析できます。

たとえば、次の興味深いタスクを実行できます。
  • 構成スイート内または構成を表す実行計画内のすべての構成の実行を分析する
  • 同じ実行計画の実行を比較する (ステータスが変更されたテストを見つけ出すためなど)
  • 実行計画のすべての失敗したテストを一度に表示する

自動テストの実行結果を分析するには：

  1. 実行の 実行 グリッドまたは アクティビティ > 最近の実行 グリッドで、1 つ以上の実行を選択します。
  2. 自動テスト結果を表示します アイコンをクリックして、単一実行の結果を分析するか、選択項目を右クリックして 自動テスト結果の比較 を選択し、複数の実行を比較します。
  3. ページの上部にあるアイコン、または特定のステータス アイコンをクリックして、結果ファイル、スクリーンショットのサムネイル、メッセージ、スタックトレースなどの詳細な情報にアクセスします。
    ヒント: 失敗したテストのみ表示 チェック ボックスを使用して、表示する結果を絞り込むことができます。
親トピック: テスト実行を分析する


複数のテスト実行のテスト結果の比較

1 つのテストの複数の実行の結果を比較して、テスト ステータスの差異を可視化できます。

テスト結果 ビューは、完全なドリルダウン機能をもつ最適化された結果の概要を提供します。結果ファイル、スクリーンショットのサムネイル、メッセージ、スタックトレースなどのすべての情報が含まれます。これによって、とくに、複数の実行結果を横に並べて比較することができるため、失敗したテスト実行の根本原因をすばやく分析できます。

  1. テスト実行 グリッドで (テスト > 詳細ビュー > <テスト> > 実行)、複数の実行を選択します。
  2. 選択項目を右クリックし、自動テスト結果の比較 を選択して、複数のテスト実行を比較します。
  3. ページの上部にあるアイコン、または特定のステータス アイコンをクリックして、結果ファイル、スクリーンショットのサムネイル、メッセージ、スタックトレースなどの詳細な情報にアクセスします。
    ヒント: 失敗したテストのみ表示 チェック ボックスを使用して、表示する結果を絞り込むことができます。
親トピック: テスト実行を分析する
関連資料
[テスト] の [実行] ページ


テスト実行のステータスを変更する

テスト実行のステータスを手動で変更するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する実行計画を選択します。
  3. 実行 タブをクリックします。
  4. 実行計画の実行を選択します。 実行 ページのテスト セクションには、テスト実行が一覧されます。
  5. テストの 実行 ID をクリックします。 テスト実行の結果 ダイアログ ボックスが表示されます。
  6. 詳細 タブをクリックします。
  7. ステータスの変更 をクリックします。 ステータスの変更 ダイアログ ボックスが開きます。
  8. 新しいステータス リスト ボックスから、このテスト実行に対する新しいステータスを選択します。
  9. コメント フィールドに、手動によるステータス変更に対する説明を入力します。
    注: コメントの入力は必須です。
  10. OK をクリックして、ステータスの変更を確認します。
注: ステータスを変更すると、履歴が変わります。テスト実行に対するすべてのステータス変更の履歴を表示するには、テスト実行の結果 ダイアログ ボックスで メッセージ タブをクリックします。
親トピック: テスト実行を分析する


テストの実行詳細を表示する

テストの実行詳細を表示するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、実行計画を選択します。
  3. 実行 タブをクリックします。
  4. 下部の テストの実行 グリッドで、詳細を表示するテストの 実行 ID をクリックします。 テスト実行の結果 ダイアログ ボックスが表示されます。
  5. 詳細 タブをクリックします。
親トピック: テスト実行を分析する


テスト実行の結果を削除する

特定のテスト実行の結果を削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで、編集する実行計画を選択します。
  3. 実行 タブをクリックします。
  4. 結果を削除するテスト実行の アクション 列で、 実行結果の削除 をクリックします。
  5. 続いて表示される確認ダイアログ ボックスで はい をクリックして、削除を完了します。
親トピック: テスト実行を分析する
関連タスク
実行計画の実行および結果ファイルを削除する
結果と結果ファイルの自動削除


実行計画の実行および結果ファイルを削除する

実行 (結果ファイルや実行に属する他のすべての項目および情報を含む) を削除するかどうか、または実行の結果ファイルのみを削除するかどうかを決定することができます。結果ファイルは、ビデオや画面イメージのようにデータベースのストレージを大量に必要とするファイルとなる場合があります。結果ファイルのみを削除すると、データベースをクリーンアップしてストレージ容量を開放することができますが、同時に実行に関する基本的な情報はすべて保存されたままになります。

実行または結果ファイルを削除するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行計画 ツリーで実行計画、フォルダ、構成スイートまたはプロジェクトを右クリックし、実行または結果ファイルの削除 を選択します。
  3. 実行または結果ファイルの削除 ダイアログ ボックスが表示されます。削除する項目を選択します。
    • すべての実行 (結果ファイルを含む) をクリックすると、すべての実行とすべての結果ファイルが削除されます。
    • すべての実行の結果ファイル をクリックすると結果ファイルが削除されますが、実行自体は削除されません。
  4. 期間の指定 をオンにすると、特定の期間の実行または結果ファイルのみが削除されます。
  5. 前回の実行を保持する をオンにすると、最新の実行を除くすべての実行 (期間を指定した場合は、その期間内) が削除されます。
  6. OK をクリックします。
注: タグ付けされたビルドの実行はこのアクションでは削除できません。タグ付けされたビルドの実行を削除するには、管理 > 製品/バージョン/ビルド > 製品 でビルドのタグを削除します。
注: 削除する項目が複数ある場合は、データベースから項目を削除する際に、UI の更新に若干遅延が発生することがあります。
注: プロジェクト ノードを右クリックしてプロジェクトのすべての実行または結果ファイルを削除する場合、すべての未割り当てテストの実行または結果ファイルも同様に削除されます。
親トピック: テスト実行を分析する
関連タスク
テスト実行の結果を削除する
結果と結果ファイルの自動削除


実行計画の実行の結果

追跡 > アクティビティ > 最近の実行 > 実行 ID

実行計画の実行結果 ダイアログ ボックスには、実行計画の実行結果の詳細が一覧表示されます。

実行計画 > 詳細ビュー からダイアログ ボックスにアクセスすることもできます。詳細を見たい実行計画を選択し、実行 タブをクリックし、実行を右クリックして、詳細の表示 を選択します。

ダイアログ ボックスに、次の項目に関する詳細情報が表示されます。

項目 | 説明
実行計画名 | 実行計画の名前。
実行計画 ID | 実行計画の一意の識別子。
実行計画の実行 ID | 実行計画の実行の識別子。
開始日時 | 実行を開始した時間。
実行時間 | 含まれているすべてのテストを実行するために費やされた時間。セットアップおよびクリーンアップ テストの時間、および自動化ファイルおよびコード カバレッジの取得、実行ツールの起動などのタスクに費やされた時間が含まれます。手動実行の場合、実行の開始から終了までの時間です。
実行サーバー | 実行計画に割り当てられている実行サーバー。
警告数/エラー数 | 実行の間に生成された警告/エラーの数。
ステータス | 合格、失敗、未実行のテストの数を棒グラフで表示します。
バージョン/ビルド | 実行に指定された製品のバージョン/ビルド番号。これらは、この実行計画のユーザーによって設定されるか、または、実行時にビルド情報ファイルから読み込まれます。ビルドがタグ付けされている場合、太字で表示され、 タグが設定されたビルド でマークされます。
Silk Test Classic AUT ホスト名 | Silk Test Classic AUT（テスト対象エージェント）ホストの名前。
セットアップ用テスト | テストに備えてテスト環境を準備するテスト。テストの名前をクリックすると、表示または編集できます。テストの実行の ID をクリックすると、テストの実行結果 ダイアログ ボックスが開きます。
クリーンアップ用テスト | テスト後にテスト環境を元の状態に戻すためのテスト。テストの名前をクリックすると、表示または編集できます。テストの実行の ID をクリックすると、テストの実行結果 ダイアログ ボックスが開きます。

実行計画の結果 ダイアログ ボックスでは、実行計画の実行の間に含まれたファイルや、生成されたメッセージに関する追加情報も提供します。また、その実行計画に対して割り当てられているテストをすべて一覧表示します。

手動テストについては、手動テストの結果 をクリックすると、現在の実行 ページの読み取り専用版を、その手動テストに関する詳細情報と共に取得できます。

割り当て済みテスト セクションには、この実行計画に割り当てられているテストがすべて一覧表示されます。テストの名前をクリックすると、それを表示または編集でき、テストの 実行 ID をクリックすると、テストの実行結果 ダイアログ ボックスが開きます。

親トピック: テスト実行を分析する
関連資料
テスト実行の結果


テスト実行の結果

テスト実行の結果 ページには、テストまたは実行計画の実行詳細が一覧表示されます。ページには、以下の場所からアクセスできます：

  • テスト > 詳細ビュー > <テスト> > 実行 > <実行 ID>
  • 実行計画 > 詳細ビュー > <実行計画> > 実行 > <実行 ID>
  • 実行計画 > 詳細ビュー > <実行計画> > 実行 > テストの実行<実行 ID>
  • 追跡 > アクティビティ > 最近の実行 > <実行 ID> > 割り当て済みテスト > <実行 ID>

テスト実行の結果 ページには、以下のタブ/セクションが表示されます。

タブ | 説明
詳細

実行の詳細を表示します。このテストの実行に含まれている実行計画の実行の 実行時間、実行パス、実行計画の実行 ID と、警告数/エラー数 (発生した場合)、実行コメント (コメントが実行に追加された場合) などが含まれます。このタブでは、テスト実行のステータスを変更することもできます。このオプションは、テスト実行のステータスを手動で変更する必要がある場合に有効です。

手動でステータスを変更すると、このタブの ステータス、ステータス変更日時、ステータス変更者、前のステータス、および ステータス変更コメント の各フィールドに変更が反映されます。
タイムライン

タイムライン タブには、次の組み合わせによって、テストの簡単な結果とエラー分析が可能なグリッドが表示されます。

  • 失敗数、エラー数、警告数など、output.xml ファイルが使用可能なテスト スイートの構造。
  • output.xml ファイルからのインシデント。
  • ログ エントリとメッセージ。
  • 結果ファイル。

エントリは時間順に一覧表示され、ビューには、異なるタイプの項目にフィルタを適用できるチェック ボックスが含まれます。

このタブは、テスト実行 グリッドの 結果の分析 アクションと エラーの分析 アクションからもアクセスできます。

注: タブは、手動テストと Silk Test Workbench テストを除くすべてのテスト タイプで表示されます。
特定 | Silk Test Classic、Silk Performer および手動テストに対してのみ表示されます。このタブには選択したテスト タイプに固有の詳細が示されます。たとえば、Silk Test Classic テストを選択した場合、このビューには、選択したテストケース、テスト データ、テスト実行時に出力された警告 (存在する場合) が表示されます。
ファイル この実行で生成されたすべてのファイル (ファイル サイズを含む) が一覧表示されます。Silk Test Classic .rex ファイルの名前はダウンロード リンクとして機能します。これらのファイルをダウンロードすれば、テキスト エディタで直接表示できます。

上の表には、結果ファイルや手動テスト用に手動でアップロードしたファイルなど、テストに関連付けられたファイルが一覧表示されます。下の表には、たとえば実行ログ ファイルやコード分析結果など、実行計画に関連付けられたファイルが一覧表示されます。

結果ファイル の アクション 列で、 結果ファイルの削除 をクリックして特定の結果ファイルを削除します。一部のファイルは保護されており、削除できません。

テストの実行によって生成されたすべての結果ファイルを zip されたパッケージの形でダウンロードするには、すべてのファイルのダウンロード をクリックします。

Silk Test Workbench の場合、結果ファイルのコンテキストで Silk Test Workbench を開くには、result.stwx ファイルをクリックします。

Silk Test Workbench の場合、再生エラーが発生した場合にビジュアル テストの最後のスクリーンショットを確認するには、error.png をクリックします。
メッセージ

この実行で生成されたすべてのメッセージ (タイムスタンプと深刻度を含む) が一覧表示されます。
成功条件 | 自動テストに対してのみ表示されます。このタブには、テスト計画プロセスの実施中にテスト > 詳細ビュー > <テスト> > プロパティ でテストに定義したすべての成功条件と、実行結果の値が表示されます。成功条件は、テストが [成功] したか [失敗] したかを判断するために用いられます。
データ駆動型 | データ セットのすべてのデータ行を単一のテストにするというオプションが指定されているデータ駆動型テストの場合にのみ、表示されます。このタブには、テストの実行の各インスタンス (データ行) のステータスが一覧表示されます。インスタンスをクリックすると、テスト実行の結果 ダイアログ ボックスがもう 1 つ開き、選択したインスタンスの実行詳細が表示されます。
属性 | このテストに設定されているすべての属性。
パラメータ | このテストに設定されているすべてのパラメータ。

以下の表では、テストの実行結果を順に調べるための UI 要素を一覧にしています。これらの要素は、実行計画から テスト実行の結果 ダイアログ ボックスにアクセスした場合にのみ表示されます。

項目 | 説明
合格をスキップ | 前の結果 および 次の結果 のボタンを使って閲覧する際に、どのテストの実行結果を表示するかを判断するために使われます。このオプションをオンにすると、ステータスが [合格] 以外であるテストのみが表示されます。
< 前の結果 | 選択した実行計画の実行の中で、前のテストの結果詳細に移動します。
次の結果 > | 選択した実行計画の実行の中で、次のテストの結果詳細に移動します。
親トピック: テスト実行を分析する
関連資料
実行計画の実行の結果


データ駆動型テストの実行アクティビティを表示する

データ駆動型テストの実行アクティビティを表示するには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. データ駆動型テストを基にしている実行計画を選択します。
  3. メニューで 追跡 > アクティビティ をクリックします。
  4. 関連する実行計画の 実行 ID をクリックします。
  5. 割り当て済みテスト テーブルに表示されているデータ駆動型テストの 実行 ID をクリックします。
    注: 多重データ駆動型テストを実行している場合は、データ ソース内のデータ行ごとに 1 つのテストが表示されます。
    そのテストの結果ページが開きます。
  6. データ駆動型 タブを選択します。このテストの実行済みインスタンスがすべて表示されます。
    注: このテストのデータ駆動型プロパティは、詳細 ページの データ駆動型プロパティ テーブルに一覧表示されます。
  7. インスタンス名をクリックすると、そのインスタンスのテスト実行の詳細が表示されます。
    注: 多重データ駆動型テスト インスタンスを扱っている場合は、データ ソース内のデータ行ごとに別々のインスタンスが作成されます。
  8. パラメータ タブをクリックすると、このテスト実行の際に使用されたデータ ソース値が表示されます。
親トピック: テスト実行を分析する
関連概念
データ駆動型テスト


[実行] の [実行] ページ

実行計画 > 詳細ビュー > <実行計画> > 実行

実行 ページには、選択した実行計画のすべての実行に関する統計値が表示されます。

構成スイートの場合は、含まれている構成のすべての実行が表示されます。

テスト サイクルの場合は、含まれている実行計画とフォルダのすべての実行が表示されます。

このページは 2 つのセクションに別れており、1 つ目には実行計画の実行が一覧され、2 つ目には、1 つ目のセクションで選択された実行計画の実行に対する、テストの実行が一覧されます。

グリッドはカスタマイズ可能です。列を表示または非表示にしたり、幅を調整したり、列をドラッグして移動し、順序を変更したりできます。列をクリックすると、グリッドの内容をソート、グループ化、またはフィルタできます。

実行計画の実行結果 ダイアログ ボックスを開くには、実行を右クリックして、詳細の表示 を選択します。複数の実行計画の実行を比較するには、Ctrl + クリック または Shift + クリック を使用して、実行を選択します。選択項目を右クリックして、自動テスト結果の比較 を選択します。

実行計画の実行セクションには、選択した実行計画の実行が一覧されます。このセクション下部のメニュー バーを使用して、ページごとに表示する行数を定義し、ページを移動します。このページには、各実行の以下の列が表示されます。

列 | 説明
アクション 実行計画に対して行うことができるアクション。
実行の削除
クリックすると、この実行の結果を削除します。選択した実行に対する結果を削除すると、Silk Central はその実行を、実行 ページから削除します。それらの実行は、バックグラウンド プロセスが削除を完了するまで灰色に変わります。代わりに、Delete を押してテスト実行結果を削除することも可能です。タグ付けされたビルドの場合は、結果の削除を確認する必要があります。
手動テスト結果の表示 (手動テストの場合のみ)
単一の手動テストの実行結果を分析するには、手動テスト結果 ページでクリックします。
自動テスト結果の表示 (自動テストの場合のみ)
単一の自動テストの実行結果を分析するには、テスト結果 ページでクリックします。
ID | 実行計画の識別子。
実行計画 | 実行された実行計画の名前。この列は構成スイートの場合にのみ表示されます。
ステータス | 実行のステータス概要。バーにより、合格/失敗/未実行の各テストの量を一覧表示します。各割り当て済みテストの実行ステータスは、ページの 2 つ目のセクションに表示されます。
実行 ID | 実行計画の実行の識別子。実行の結果にアクセスするには、これをクリックします。
キーワード | 実行計画に割り当てられたキーワード。
実行者 | 実行が実際に行われた実行サーバーの名前。手動テストの場合には、実行を行った担当者の名前が一覧表示されます。
製品 | テスト対象アプリケーション。
バージョン | この実行計画のユーザーによって設定されたか、実行時にビルド情報ファイルから読み取られたバージョン。この情報は、管理 > 製品/バージョン/ビルド > 製品 で設定できます。
ビルド | この実行計画のユーザーによって設定されたか、実行時にビルド情報ファイルから読み取られたビルド。この情報は、管理 > 製品/バージョン/ビルド > 製品 で設定できます。ビルドがタグ付けされている場合、太字で表示され、 タグ付けされたビルド でマークされます。
開始日時 | 実行を開始した時間。
継続期間 | 含まれているすべてのテストを実行するために費やされた時間。セットアップおよびクリーンアップ テストの時間、および自動化ファイルおよびコード カバレッジの取得、実行ツールの起動などのタスクに費やされた時間が含まれます。手動実行の場合、実行の開始から終了までの時間です。
開始タイプ | テスト実行がどのように開始されたかを表示します。手動、Web サービス、スケジュールなどがあります。
開始者 | 実行を開始したスケジュール、テスト担当者、Web サービス ユーザーの名前。
開始範囲 | 実行 ダイアログ ボックスで指定された範囲。
実行計画の親 | 実行計画の親の名前。
実行コメント | この列を使用して実行に情報を追加できます。コメントを編集するには、実行を右クリックして、実行コメントの編集 を選択します。
モバイル デバイスの選択 | 実行計画がモバイル デバイスで実行するように構成されていた場合、配置 ページで指定したデバイス フィルタ。
使用したデバイス | 実行計画がモバイル デバイスで実行するように構成されていた場合、デバイス フィルタに一致し、実際にテストで使用されたデバイス。手動テストでは、この実行計画のテスト担当者が最後に選択したデバイスが表示されます。
実行計画に割り当てられた属性がある場合、グリッドに表示するよう選択できます。属性とは、実行計画に適用できる自由に定義可能な特性です。フィルタやレポートに対して、属性を使用できます。

テストの実行 セクションには、選択された実行計画の実行に対するテストの実行が一覧されます。このセクション下部のメニュー バーを使用して、ページごとに表示する行数を定義し、ページを移動します。このページには、各実行の以下の列が表示されます。

列 | 説明
アクション テストの実行に対して行うことができるアクション。
結果の表示またはダウンロード
実行が属するテストが、結果ファイルを生成するテスト タイプだった場合、アイコンをクリックして、結果ファイルをここで参照またはダウンロードすることができます。
問題の新規作成
クリックすると 問題の新規作成 ダイアログ ボックスが開き、そのテストに対して新しい問題を作成できます。
既存の問題の割り当て
外部に構成されている問題追跡システムから問題をテストに割り当てます。
手動テスト結果の表示
クリックすると、現在の実行 ページが読み取り専用モードで表示されます。
ステータス | 実行のステータス概要。単一のテストの場合には、単一のステータスが表示されます。テスト パッケージまたはテスト スイートのノードに対しては、バーにより、合格/失敗/未実行の各テストの量を一覧表示します。
ステータスの理由 | 特定のテスト実行がステータス 合格、失敗、あるいは 未実行 を持つ理由。
実行 ID | テストの実行の識別子。クリックすると、テスト実行の結果 ダイアログ ボックスが開きます。
ID | テストの識別子。この列は、デフォルトで表示されません。
テスト | このテストの名前。クリックすると、テスト > 詳細ビュー のテストにアクセスします。アイコンはテスト タイプによって変わります。
バージョン | 実行の対象となったバージョン。
開始日時 | 実行を開始した日時。
継続期間 | テストの実行の継続時間。
実行者 | 実行が実際に行われた実行サーバーの名前。手動テストの場合には、実行を行った担当者の名前が一覧表示されます。
見つかった問題 | テストの実行に割り当てられている問題の数を表示します。テストの実行に割り当てられている問題がない場合、この列は空で表示されます。リンクをクリックすると、テスト > 詳細ビュー の 問題 ページにある問題にアクセスできます。
エラー数 | 実行で発生したエラーの数。
警告数 | 実行で発生した警告の数。
ビルド | 実行の対象となったビルド。
実行コメント | Silk Performer のテスト実行では、結果が読み込まれる際に、Silk Performer によってこの列が使用され、テスト実行に情報が追加されます。その他のすべてのテスト タイプでは、この列を使用して実行に情報を追加できます。コメントを編集するには、実行を右クリックして、実行コメントの編集 を選択します。
親トピック: テスト実行を分析する
関連概念
実行計画の実行の比較レポート
関連タスク
既存の問題を割り当てる
関連資料
[アクティビティ] ページ
テスト実行の結果


追跡

追跡 領域によって、アクティビティ、全プロジェクト アクティビティ、プロジェクト概要レポート、品質目標 などのプロジェクト レベル情報が提供されます。

  • アクティビティ
    テストの今後の実行、現在の実行、最近の実行を管理する方法を説明します。
  • プロジェクト概要レポート
    選択したプロジェクトのステータスの概要を示します。
  • Silk Central、リスク ベース テスト、および品質目標
    Silk Central がリスク ベース テストをサポートする方法について説明します。
親トピック: 問題追跡と結果分析


アクティビティ

テストの今後の実行、現在の実行、最近の実行を管理する方法を説明します。

  • 最近の実行を削除する
    実行結果を削除して、最近の実行 リストから実行を削除します。
  • [アクティビティ] ページで列の表示/非表示を切り替える
    適切なチェック ボックスをオンまたはオフにして、アクティビティ ページで列の表示/非表示を切り替えます。
  • [アクティビティ] ページから問題を入力する
    テスト実行時に問題が検出された場合に、アクティビティ ページで問題を直接入力します。
  • [アクティビティ] ページでテスト実行にフィルタを適用する
    アクティビティ ページでテスト結果と実行計画にフィルタを適用する方法について説明します。
  • [アクティビティ] ページでテスト実行をグループ化する
    アクティビティ ページで実行計画やテスト結果を見やすいようにグループ化する方法について説明します。
  • アクティビティのフィルタを削除する
    アクティビティ ページで列に適用されたフィルタを削除し、すべての列を表示します。
  • [アクティビティ] ページで列の順序を変更する
    アクティビティ ページで列の順序を変更し、アクティブ プロジェクトの表示をカスタマイズします。
  • [アクティビティ] ページで列のサイズを変更する
    アクティビティ ページで列の幅を変更し、アクティブ プロジェクトの表示をカスタマイズします。
  • [アクティビティ] ページの表示をデフォルト設定に復元する
    アクティビティ ページの表示をデフォルト設定に復元し、すべてのユーザー定義設定をリセットします。
  • [アクティビティ] ページでテスト実行をソートする
    アクティビティ ページでテスト実行をソートし、アクティブ プロジェクトの表示をカスタマイズします。
  • [アクティビティ] ページ
    プロジェクトに対して、テストの最近の実行、現在の実行および今後の実行を集中的に管理できます。
  • [全プロジェクト アクティビティ] ページ
    スーパーユーザー権限を持つユーザーは、プロジェクト間での実行に関連したすべてのアクティビティを確認できます。
親トピック: 追跡
関連概念
実行計画
関連資料
[全プロジェクト アクティビティ] ページ


最近の実行を削除する

最近の実行 リストから実行を削除するには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. アクティビティ ページの 最近の実行 領域で、削除するテスト実行を右クリックし、実行結果の削除 を選択します。
  3. OK をクリックして、削除を確定します。
親トピック: アクティビティ


[アクティビティ] ページで列の表示/非表示を切り替える

アクティビティ ページで列の表示/非表示を切り替えるには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. 列ヘッダーのコンテキスト メニューを開きます。
  3. カラム サブメニューを展開して、プロジェクトで使用可能な列をすべて表示します。
  4. 表示する列のチェック ボックスをすべて選択します。 列表示の設定は保存され、アクティブ プロジェクトを開くたびにその設定で表示されます。
親トピック: アクティビティ


[アクティビティ] ページから問題を入力する

新しい問題を直接 アクティビティ ページに入力できます。

アクティビティ ページから問題を入力するには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. 最近の実行 領域で、該当する実行計画の 実行 ID をクリックし、テスト実行結果を表示します。 実行と関連付けられている各テストが、ビューの下部にある 割り当て済みテスト の表に一覧表示されます。
  3. 問題を関連付けるテストの アクション 列で、問題の新規作成 をクリックします。
  4. 問題の定義に進みます。
親トピック: アクティビティ


[アクティビティ] ページでテスト実行にフィルタを適用する

アクティビティ ページのビューには、列の値に基づいてフィルタを適用することができます。フィルタ文字列は、次の項目に適用するよう指定できます。

  • テキスト データ フィールド。
  • 日付フィールドのカレンダー フィルタ（指定の値より前、指定の値より後、指定の値に等しい の各演算子を使用）。
  • 数値フィールドの数値演算子（>、<、および =）。
  • [アクティビティ] ページでテキスト値にフィルタを適用する
    アクティビティ ページでテキスト ベースの値にフィルタを適用し、フィルタ条件に一致するすべてのエントリを表示します。
  • [アクティビティ] ページで日付値にフィルタを適用する
    アクティビティ ページで日付値にフィルタを適用し、フィルタ条件に一致するすべてのエントリを表示します。
  • [アクティビティ] ページで数値にフィルタを適用する
    アクティビティ ページで数値にフィルタを適用し、フィルタ条件に一致するすべてのエントリを表示します。
  • [アクティビティ] ページで論理値にフィルタを適用する
    アクティビティ ページで論理値にフィルタを適用し、フィルタ条件に一致するすべてのエントリを表示します。
  • [アクティビティ] ページで定義済みリストを使用して値にフィルタを適用する
    アクティビティ ページで定義済みリストを使用して値にフィルタを適用し、フィルタ条件に一致するすべてのエントリを表示します。
親トピック: アクティビティ
関連概念
フィルタ


[アクティビティ] ページでテキスト値にフィルタを適用する

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. フィルタリングの基準になるテキスト値の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ サブメニューを展開して、フィルタ フィールドを表示します。
  4. そのフィールドにテキスト文字列を入力します。
  5. Enter を押します。 フィルタ条件に一致するすべてのエントリがフィルタ済みリストに動的に表示されます。
親トピック: [アクティビティ] ページでテスト実行にフィルタを適用する


[アクティビティ] ページで日付値にフィルタを適用する

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. フィルタリングの基準になる日付値の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ にカーソルを合わせると、指定の値より前、指定の値より後、または 指定の値に等しい のサブメニューが表示されます。
  4. 次の項目から選択します。
    1. 指定の値より後 にカーソルを合わせ、それ以前の日付（その日を含む）のすべてのエントリを除外する場合の基準となる日付を定義します。
    2. 指定の値より前 にカーソルを合わせ、それ以降の日付（その日を含む）のすべてのエントリを除外する場合の基準となる日付を定義できます。
    3. 指定の値に等しい にカーソルを合わせ、指定した日付のものを除くすべてのエントリを除外できます。
    カレンダー ツールが表示されます。
  5. カレンダー ツールを使って日付を選択します（あるいは、今日 をクリックして今日の日付を指定します）。
    ヒント: 日付に基づくフィルタリングの変更を有効にするには、カレンダー ツールで日付を明示的にクリックするか、Enter キーを押す必要があります。
    フィルタ条件に一致するすべてのエントリがフィルタ済みリストに動的に表示されます。
親トピック: [アクティビティ] ページでテスト実行にフィルタを適用する


[アクティビティ] ページで数値にフィルタを適用する

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. フィルタリングの基準になる数値の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ サブメニューを展開して、>（大なり）、<（小なり）、=（等しい） の各演算子を表示します。
  4. 次の項目から選択します。
    1. > フィールドに数値を入力すると、その値以下のエントリをすべて除外することを定義できます。
    2. < フィールドに数値を入力すると、その値以上のエントリをすべて除外することを定義できます。
    3. = フィールドに数値を入力すると、指定した数値のエントリを除くすべてのエントリを除外できます。
    注: 数値は小数点以下 2 桁に丸められます。
  5. Enter を押します。 フィルタ条件に一致するすべてのエントリがフィルタ済みリストに動的に表示されます。
親トピック: [アクティビティ] ページでテスト実行にフィルタを適用する


[アクティビティ] ページで論理値にフィルタを適用する

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. フィルタリングの基準になる論理値の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ サブメニューを展開して、選択可能な値を表示します。
  4. はい か いいえ のどちらかのオプション ボタンを選択します。 フィルタ条件に一致するすべてのエントリがフィルタ済みリストに動的に表示されます。
親トピック: [アクティビティ] ページでテスト実行にフィルタを適用する


[アクティビティ] ページで定義済みリストを使用して値にフィルタを適用する

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. フィルタリングの基準になる定義済みのフィルタ値を持つ列で、列ヘッダーのコンテキスト メニューを開きます。
  3. コンテキスト メニューの フィルタ サブメニューを展開して、フィルタ フィールドを表示します。
  4. 使用するフィルタの値のチェック ボックスをオンにします。 選択した条件を 1 つでも持つエントリはすべて表示されます。
親トピック: [アクティビティ] ページでテスト実行にフィルタを適用する


[アクティビティ] ページでテスト実行をグループ化する

単に列でソートするだけでなく、エントリをいくつかのグループにまとめて見やすくすることができます。グループ化の基準になる列の値が共通するものが 1 つのグループになります。

  • [アクティビティ] ページでテスト実行にグループを適用する
    アクティビティ ページで実行計画やテスト結果を見やすいようにグループ化します。
  • [アクティビティ] ページでテスト実行のグループ化を削除する
    アクティビティ ページでテスト実行のグループ化を削除し、すべてのテスト実行を単一のリストに表示します。
親トピック: アクティビティ


[アクティビティ] ページでテスト実行にグループを適用する

アクティビティ ページでエントリをグループ化するには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. グループ化の基準になる列で、列ヘッダーのコンテキスト メニューを開きます。
  3. このカラムでグルーピング を選択します。

    選択した列の値が共通するエントリがグループにまとめられます。

親トピック: [アクティビティ] ページでテスト実行をグループ化する


[アクティビティ] ページでテスト実行のグループ化を削除する

グループ化を解除するには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. 任意の列ヘッダーのコンテキスト メニューを開きます。
  3. グルーピング チェック ボックスをオフにします。
親トピック: [アクティビティ] ページでテスト実行をグループ化する


アクティビティのフィルタを削除する

注: 列を非表示にすると、その列に適用されているフィルタはすべて削除されます。

1 つまたは複数のフィルタを削除するには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. 削除するフィルタが適用されている列で、列ヘッダーのコンテキスト メニューを開きます。
    注: フィルタされている列は、タイトルが太字の斜体で表示されるので、タイトルで見分けることができます。
  3. 以下のいずれかの操作を実行します。
    1. 特定のフィルタを削除するには：フィルタ チェック ボックスをオフにします。
    2. すべてのフィルタを削除するには：フィルタのリセット を選択します。
親トピック: アクティビティ
関連概念
フィルタ


[アクティビティ] ページで列の順序を変更する

アクティビティ ページで列の順序を変更するには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. 移動する列の見出しを選択します。
  3. その列を希望する位置までドラッグして放します。

    列順序の設定は保存され、アクティブ プロジェクトを開くたびにその設定で表示されます。

親トピック: アクティビティ


[アクティビティ] ページで列のサイズを変更する

アクティビティ ページで列の幅を調整するには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. 調整する列の見出しの仕切り線を選択します。
  3. 列の境界を希望する位置までドラッグして放します。

    列幅の設定は保存され、アクティブ プロジェクトを開くたびにその設定で表示されます。

親トピック: アクティビティ


[アクティビティ] ページの表示をデフォルト設定に復元する

表示をデフォルト設定に復元すると、現在のプロジェクトのユーザー定義設定（列の順序、列の幅、列の表示/非表示、適用されているフィルタ、ソート、グループ化）はすべてリセットされます。

表示をデフォルト設定に復元するには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. 任意の列ヘッダーのコンテキスト メニューを開きます。
  3. 表示のリセット を選択します。
親トピック: アクティビティ


[アクティビティ] ページでテスト実行をソートする

アクティビティ ページでテスト実行をソートするには：

  1. メニューで 追跡 > アクティビティ をクリックします。
  2. ソートするテスト実行の列で、列ヘッダーのコンテキスト メニューを開きます。
  3. 昇順 を選択すると、テスト実行は昇順でソートされます。降順 を選択すると、テスト実行は降順でソートされます。 ソートの設定は保存され、アクティブ プロジェクトを開くたびにその設定で表示されます。
親トピック: アクティビティ


[アクティビティ] ページ

追跡 > アクティビティ

アクティビティ ページでは、プロジェクトに対して、テストの最近の実行、現在の実行および今後の実行を集中的に管理できます。アクティビティ ページのグリッド ビューには、フィルタ処理、並べ替え、グループ化などのオプションが提供されており、これらはユーザーごとに構成できます。列の表示や非表示、列幅の調整、クリック アンド ドラッグによる列の移動を行うことができます。

アクティビティ ページは、3 つのセクションに分割されています：今後の実行、現在の実行、最近の実行。ビューの間のセパレータをドラッグして、グリッド ビューのサイズを変更できます。

状況依存のメニュー コマンドは各テスト実行で利用できます。これらのコマンドにより、リストされた実行計画への直接リンク、手動テストの続行、テスト実行の結果の管理などが可能になります。

アクティビティ ページを使用すると、実行計画間の一致点の特定や特定の実行計画情報の検索が容易になります。Windows の標準キーボード ショートカットを使用して、テスト実行エントリを選択し、特定の実行計画とテスト結果セットを簡単に選択し、操作できます。ソート、グループ化、フィルタの各機能はコンテキスト メニュー コマンドから利用でき、それぞれ、テスト実行のグループ化と組織化に役立ちます。ビュー カスタマイズの設定はすべてプロジェクトと一緒に保存され、アクティビティ ページにアクセスするたびに利用できます。

注: アクティビティ ページのデータは自動的に更新されません。各ビューの下部にあるページ移動ボタンのそばにある 再読み込み をクリックして、ページの内容を更新します。
注: Ctrl + クリック を使用して、複数のキューにたまっている実行の選択や、それらをワンクリックで中止することもできます。

今後の実行

今後の実行 ビューには、今後実行が計画されている実行計画が一覧表示されます。多くの実行計画があるときにパフォーマンスを向上させるために、今後の 50 の実行計画のみが表示されます。利用可能なフィルタ機能を使用して、他の将来の実行計画にアクセスできます。実行計画を編集するには、実行計画を右クリックして 実行計画へ移動 を選択するか、実行計画の名前の左にある矢印をクリックします。これにより 実行 領域に移動し、実行計画の詳細情報を表示および編集できます。

デフォルトでは、すべての実行計画は 開始日時 でソートされます。今後の実行 ビューの各列はソートやグループ化できません。

今後の実行 ビューは、ビューのタイトル バーの右端にある二重の矢印ボタンをクリックして、折りたたみおよび展開できます。

今後の実行 ビューには、実行計画ごとに以下の列が表示されます。

列 | 説明
ID | スケジュールを設定された実行計画の識別子。この列は、デフォルトで表示されません。
実行計画/フォルダ | スケジュールを設定された実行計画またはフォルダの名前。
キーワード | スケジュールを設定された実行計画に割り当てられたキーワード。
手動テスト担当者 | 手動テストの場合、この列にはテストに割り当てられた手動テスト担当者の名前が表示されます。テストの手動テスト担当者がいない場合は、この列に値がありません。
優先度 | この実行計画に設定されている優先度。
開始日時 | スケジュール設定されたテスト実行の開始時間。
実行計画の親 | 実行計画が実行されるコンテキスト内にある構成スイート、フォルダ、またはテスト サイクル。 クリックすると、実行計画 ツリー内のスイートまたはフォルダにアクセスできます。 構成スイートまたはフォルダに実行計画が含まれていない場合は、何も表示されません。

現在の実行

現在の実行 ビューでは、現在実行されている実行計画 (自動テスト実行と手動テスト実行の両方) が一覧表示されます。

実行中の実行計画を中止するには、実行計画の アクション 列にある 中止 をクリックします。実行計画を表示または編集するには、実行計画を右クリックして 実行計画へ移動 を選択するか、実行計画の名前の左にある矢印をクリックします。実行の進捗を表示するには、自動化された実行計画を右クリックして 詳細の表示 を選択するか、実行計画の 実行 ID/タスク ID リンクをクリックします。モバイル デバイス上で実行する自動テストでは、詳細ビューにデバイス上の操作をライブ ストリーム表示することもできます。Sauce Labs デバイスでは、ライブ ストリームを利用できません。

手動テストが未確定のままになっている間は、対応する実行計画も、現在の実行 リストの中に 保留 というステータスで残されます。アクション 列の 手動テストの続行 をクリックし、手動テスト ウィンドウを開きます。

手動テストの結果を表示するには、手動実行計画を右クリックして 詳細の表示 を選択するか、実行計画の 実行 ID/タスク ID リンクをクリックして、実行計画の結果 ページを開きます。そこで、割り当て済みテスト セクションで手動テスト名をクリックすると、結果 ダイアログ ボックスが開きます。手動テストの結果の詳細が表示されます。実行計画の結果 ページに戻り、手動テストの結果 をクリックすると、手動テスト ビューが開き、割り当て済みの手動テストのステータス情報が表示されます。

現在の実行のページ ビューは 20 の実行計画ごとに分割されます。現在の実行 ビューの下部分にある 最初のページ、最後のページ、次のページ、前のページ の各ボタンを使って、ページ間を移動できます。あるいは、ページ フィールドにページ番号を入力し、Enter キーを押してもかまいません。

現在の実行 ビューには、実行計画ごとに以下の列が表示されます。

列 | 説明
アクション 以下のアクションを実行計画に対して実行できます。
中止
クリックすると、現在の実行をキャンセルします。または、Delete キーを押します。実行を中止した場合、それらの実行は、バックグラウンド プロセスが削除を完了するまで灰色に変わります。
注: 実行がテスト サイクルの一部である場合、中止アクションは無効になります。 アイコンとコンテキスト メニューのエントリがグレー表示され、複数の実行を中止するときにこれらの実行は無視されます。
手動テストの続行
クリックすると、手動テスト ウィンドウが開きます。
手動テスト結果の表示
クリックすると、現在の実行 ページが読み取り専用モードで表示されます。
ID | 実行計画の識別子。この列は、デフォルトで表示されません。
実行計画 | 実行計画の名前。
実行 ID/タスク ID | 手動テストでは、実行時に 実行 ID を受け取ります。手動テストが完了すると、実行 ID が 最近の実行 ビューに渡されます。自動テストでは、実行時に タスク ID を受け取ります。タスク ID は、最近の実行 ビューに渡されません。完了した実行計画は、実行 ID を 最近の実行 ビューで受け取ります。
ステータス | アクティブな実行計画や手動テストのステータス。自動テストでは、ステータスは、テキストベースの値で示されます。手動テストでは、ステータスは色の付いたヒストグラムで示されます。自動テストのステータスはテキストで記述され、フィルタ処理できます。手動テストは、フィルタ サブメニューの関連プロパティをオンにしてフィルタ処理できます。
キーワード | 実行計画に割り当てられたキーワード。
実行者
  • 手動テストの場合、この列には手動テストの実行を担当するユーザーが表示されます。テストの手動テスト担当者がいない場合は、この列に値がありません。
  • 自動実行の場合、この列には実行サーバー名が表示されます。
優先度 | 自動実行計画の場合、複数の実行計画がキューに入れられたが、1 台の実行サーバーのみが使用可能な場合、優先度 によって、最初に実行される実行計画が決定されます。実行サーバーが使用可能でも、複数の実行計画が使用できないモバイル デバイスを必要としている場合も同様です。
開始日時 | 実行計画の実行が開始される時刻。
残り時間 | テストが完了するまでの残り時間。見積もり時間がない手動テストの場合は、この列の値は [不明] です。
開始タイプ テスト実行がどのように開始されたかを表示します。
  • 手動
  • Web サービス
  • スケジュール
  • 依存関係
開始者 | 実行を開始したスケジュール、テスト担当者、Web サービス ユーザーの名前。
開始範囲 | 実行 ダイアログ ボックスで定義された範囲。
実行計画の親 | 実行計画が実行されるコンテキスト内にある構成スイート、フォルダ、またはテスト サイクル。 クリックすると、実行計画 ツリー内のスイートまたはフォルダにアクセスできます。 構成スイートまたはフォルダに実行計画が含まれていない場合は、何も表示されません。
実行計画に割り当てられた属性がある場合、グリッドに表示するよう選択できます。属性とは、実行計画に適用できる自由に定義可能な特性です。フィルタやレポートに対して、属性を使用できます。

最近の実行

最近の実行 ビューでは、過去のすべての実行計画の実行を一覧できます。このリストは、開始時間などによってフィルタおよびソートできます。

実行計画を表示または編集するには、実行計画の実行を右クリックして 実行計画へ移動 を選択するか、実行計画の名前の左にある矢印をクリックします。実行計画の実行の 実行計画の結果 ページを表示するには、実行を右クリックして 詳細の表示 を選択するか、実行計画の 実行 ID リンクをクリックします。このページには、選択した実行計画の実行の詳細が、実行中に生成されたファイルやメッセージを含めて表示されます。テストの 結果 ダイアログ ボックスを開くには、実行計画の結果 ページの 割り当て済みテスト セクションで、テストの 実行 ID をクリックします。

2 つの実行計画の実行を比較するには、Ctrl + クリック を使用して複数の実行を選択します。選択箇所を右クリックし、自動テストの場合は 自動テスト結果の比較 を、手動テストの場合は レポート > 実行の比較... をクリックします。

実行計画を右クリックし、実行計画の実行 をクリックして、実行計画を実行します。Silk Central は、実行計画に現在割り当てられているすべてのテストが、選択した実行計画の実行に元々割り当てられていたテストではないと考えます。

実行計画の実行を削除するには、実行エントリを右クリックして 結果の削除 を選択するか、実行の アクション 列の 削除 をクリックします。

テスト結果ページ ビューは、20 のテスト結果ごとに分割されます。最近の実行 ビューの下部にある 最初のページ、最後のページ、次のページ、前のページ の各ボタンを使って、ページ間を移動できます。あるいは、ページ フィールドにページ番号を入力し、Enter キーを押してもかまいません。

最近の実行 ビューは、ビューのタイトル バーの右端にある二重の矢印ボタンをクリックして、折りたたみ/展開できます。

最近の実行 ビューには、実行計画ごとに以下の列が表示されます。

列 | 説明
アクション 以下のアクションを実行計画に対して実行できます。
削除
クリックすると、実行計画の実行結果が削除されます。実行を削除した場合、それらの実行は、バックグラウンド プロセスが削除を完了するまで灰色に変わります。または、Delete を推して実行計画の実行を削除します。タグ付けされたビルドの場合は、結果の削除を確認する必要があります。
手動テスト結果の表示
クリックすると、現在の実行 ページが読み取り専用モードで表示されます。
ID | 実行された実行計画の識別子。担当のいないテストは、ID 値が [N/A] になります。この列は、デフォルトで表示されません。
実行計画 | 実行された実行計画の名前。名前の横にあるボタンをクリックし、実行計画 ユニットの実行計画を表示します。
実行 ID | テスト実行に割り当てられた ID。リンクをクリックするとテスト実行の詳細が表示されます。
ステータス | 合格、失敗、未実行のテストの数を棒グラフで表示します。この列には、フィルタ処理、ソート、グループ化は使用できません。
キーワード | 実行時に実行計画に割り当てられたキーワード。
実行者
  • 手動テストの場合、この列には手動テストの実行を担当するユーザーが表示されます。テストの手動テスト担当者がいない場合は、この列に値がありません。
  • 自動実行の場合、この列には実行サーバー名が表示されます。
開始日時 | 実行計画の実行が開始される時刻。
実行時間 | 含まれているすべてのテストを実行するために費やされた時間。セットアップおよびクリーンアップ テストの時間、および自動化ファイルおよびコード カバレッジの取得、実行ツールの起動などのタスクに費やされた時間が含まれます。手動実行の場合、実行の開始から終了までの時間です。
製品 | テスト対象の製品。この列は、デフォルトで表示されません。
バージョン | この実行計画のユーザーによって設定されたか、実行時にビルド情報ファイルから読み取られたバージョン。この列は、デフォルトで表示されません。
ビルド | この実行計画のユーザーによって設定されたか、実行時にビルド情報ファイルから読み取られたビルド。ビルドがタグ付けされている場合、太字で表示され、 タグ付けされたビルド でマークされます。
開始タイプ | テスト実行がどのように開始されたかを表示します。手動、Web サービス、スケジュールなどがあります。
開始者 | 実行を開始したスケジュール、テスト担当者、Web サービス ユーザーの名前。
開始範囲 | 実行 ダイアログ ボックスで定義された範囲。
実行計画の親 | 実行計画が実行されるコンテキスト内にある構成スイート、フォルダ、またはテスト サイクル。 クリックすると、実行計画 ツリー内のスイートまたはフォルダにアクセスできます。 構成スイートまたはフォルダに実行計画が含まれていない場合は、何も表示されません。
モバイル デバイスの選択 | 実行計画がモバイル デバイスで実行するように構成されていた場合、配置 ページで指定したデバイス フィルタ。
使用したデバイス | 実行計画がモバイル デバイスで実行するように構成されていた場合、デバイス フィルタに一致し、実際にテストで使用されたデバイス。手動テストでは、この実行計画のテスト担当者が最後に選択したデバイスが表示されます。
実行計画に割り当てられた属性がある場合、グリッドに表示するよう選択できます。属性とは、実行計画に適用できる自由に定義可能な特性です。フィルタやレポートに対して、属性を使用できます。
親トピック: アクティビティ


[全プロジェクト アクティビティ] ページ

追跡 > 全プロジェクト アクティビティ

全プロジェクト アクティビティ ページでは、スーパーユーザー権限を持つユーザーは、プロジェクト間での実行に関連したすべてのアクティビティを確認できます。このページには アクティビティ ページにあるすべてのオプションがあり、プロジェクト間のオプションも追加されています。これにより、実行キューに関する一部の結果も表示できます。スーパーユーザーはキューから実行を削除して、ボトルネックを解消することができます。

全プロジェクト アクティビティ ページは、スーパーユーザーに対してのみ表示されます。このページは、アクティビティ ページと同様に、今後の実行、現在の実行、最近の実行 という 3 つのセクションに分かれています。3 つのすべてのセクションに、プロジェクト ID という列が追加されています。

項目 | 説明
プロジェクト ID | 実行計画が属するプロジェクトの ID。
親トピック: アクティビティ


プロジェクト概要レポート

Silk Central > 追跡 > プロジェクト概要レポート

プロジェクト概要レポート には、選択したプロジェクトのステータスの概要が含まれます。

親トピック: 追跡
親トピック: デフォルトのレポート
関連資料
プロジェクト概要レポート


Silk Central、リスク ベース テスト、および品質目標

ソフトウェアの開発中には、テスト範囲、時間、およびコストの間で頻繁に均衡をとる必要があります。 この均衡を決定するために一般に使用される方法がリスク ベース テストです。

リスク ベース テストの主なプロセスは、品質およびアプリケーションのエンド ユーザーにとって重要な要因に基づいてテスト資産を分類することです。

この分類プロセスに基づき、品質担当者が利用可能な時間および目的とする品質プロセス目標に応じた、適切なテストのセットを決定できます。 テストのサブセットの実行には、一定のリスクが含まれます。 このリスクを適切な方法で定量化することによって、関係者にプロセス全体が周知されます。このことは、リスク ベース テスト実施の成功に不可欠です。

Silk Central では、リスク ベース テストに使用される要素は、品質目標 を使用して完全にカスタマイズ可能です。 任意のリストタイプのカスタム属性または要件プロパティに対して、テスト資産の分類に使用される品質目標を作成できます。 これにより、ユーザーは、プロジェクトが特定の品質基準を満たすために実施する必要があるテストのサブセットを定義できます。 品質目標レポートによって、ユーザーは、テスト資産に関するテスト計画と実行プロセス、関連範囲、時間、および品質指標を関係者に通知できます。

  • 品質目標
    プロジェクトの品質目標について説明します。
  • 品質目標を使用したリスク ベース テスト アプローチの実装
    Silk Central では、リスク ベース テスト アプローチに、品質目標を使用します。
親トピック: 追跡
関連概念
品質目標
関連資料
ステータス レポート


品質目標

品質目標 (終了条件) は、品質が十分であると見なされるためにプロジェクトが満たす必要のある、定義可能な一連のテスト指標です。 各 Silk Central プロジェクトには、1 つまたは複数の品質目標を含めることができます。 Silk Central では、リスク ベース テストを実施する主要な手段として品質目標を使用し、特定のテスト サイクルで最も重要なテストのみを計画、テスト、レポートできます。

Silk Central の品質目標は、次の 2 つの要素で構成されます。

  • 要件またはテスト
  • 以下のいずれか
    • 対応するパーセンテージ値が設定された、リスト タイプのカスタム属性またはカスタム プロパティ
    • 以下のいずれかのデフォルト要件プロパティ。優先度、レビュー済み、またはリスク (対応するパーセント値を持つ)。

品質目標の例

要件に、高、中、および 低 という値を持つプロパティ MyCustomRisk がある場合は、次の品質目標を定義できます。

要件の目標：MyCustomRisk
高 = 100%
中 = 50%
低 = 10%

100% というのは、(属性値 高 を持つ要件にリンクされた) 条件に一致するテストを実行したときに、すべてのテストが成功して目標を満たす必要があることを示します。

アクセス許可

品質目標は、アクセス許可に基づいています。 アクセス許可の詳細については、「品質目標のアクセス許可」を参照してください。

  • [品質目標] ページ
    選択した Silk Central プロジェクトに関連付けられたすべての品質目標の一覧を表示します。
  • 品質目標を追加する
    品質目標を追加する方法について説明します。
  • 品質目標を削除する
    品質目標を削除する方法について説明します。
親トピック: Silk Central、リスク ベース テスト、および品質目標
関連資料
品質目標のアクセス許可
ステータス レポート


[品質目標] ページ

追跡 > 品質目標

品質目標 タブには、次のコントロールが用意されています。このコントロールを使用すると、プロジェクトの品質目標を作成、編集、または削除できます。

[品質目標] グリッド

列 | 説明
目標名 | 目標の名前。 列名のドロップダウン リストを選択してから グルーピング を選択し、リスト内のすべての目標を表示します。
名前 | 名前 列には、リスト タイプの属性またはプロパティのそれぞれの値が表示されます。
目標 (%) | このテキスト フィールドには 0 から 100 までの数値が入ります。 この値は、定義された品質目標を満たすために必要なテストの割合を表します。

ボタン

  • 目標の管理：クリックすると、品質目標の管理 ダイアログ ボックスが表示されます。
  • 計画レポート：クリックすると、品質目標計画レポート が表示されます。
  • 実行レポート：クリックすると、品質目標実行レポート が表示されます。
親トピック: 品質目標


品質目標を追加する

品質目標を作成する前に、品質目標に使用する、リスト タイプのテストのカスタム属性または要件のカスタム プロパティを作成する必要があります。 または、優先度、レビュー済み、または リスク の要件フィールドを使用できます。

たとえば、高、中、および 低 の値が設定される要件のカスタム プロパティを追跡する品質目標が必要な場合は、まず プロジェクト:<プロジェクト名> > プロジェクト設定 > 要件プロパティ に移動して、これらの値を含む リスト タイプのカスタム プロパティを作成します。

注: プロパティまたは属性は、品質目標としてプロジェクトごとに 1 回のみ使用できます。
  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. プロジェクトを選択します。
  3. 追跡 > 品質目標 をクリックします。
  4. 目標の管理 をクリックします。 品質目標の管理 ダイアログ ボックスが開きます。
  5. 新しい目標名 フィールドに、目標の名前を入力します。
  6. 属性/カスタム プロパティ リストから、品質目標に使用する値を含む項目を選択します。 リストには、次のタイプの項目が含まれます。
    • リスト タイプの要件プロパティ
    • 優先度、レビュー済み、または リスク のデフォルト要件プロパティ
    • リスト タイプのテスト属性
  7. 新しい目標の追加 をクリックします。
  8. 閉じる をクリックします。 品質目標の管理 ダイアログ ボックスが閉じ、新しい目標が 品質目標 グリッドに追加されます。
  9. リスト内の値ごとに、目標 (%) に 0 から 100 までの数値を入力します。
親トピック: 品質目標
関連資料
カスタム属性と要件プロパティのタイプ


品質目標を削除する

品質目標を削除するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. プロジェクトを選択します。
  3. 追跡 > 品質目標 をクリックします。
  4. 目標の管理 をクリックします。 品質目標の管理 ダイアログ ボックスが開きます。
  5. 削除する品質目標の隣の 削除 アイコンをクリックします。
親トピック: 品質目標


品質目標を使用したリスク ベース テスト アプローチの実装

指定されたプロジェクトで、テストの範囲と時間との間でバランスをとりながら、アプリケーションの品質を受け入れ可能なものにすると想定します。 次のステップで、リスク ベース テスト アプローチを実装するために、品質目標を使用するワークフローの概要について説明します。

このプロジェクトで、関係者は、十分なテスト シナリオが実行されると同時に、最も重要な要件が十分にテストされるようにしたいと考えています。 以下の例のデータは、Silk Central の新規バージョンに含まれている Demo プロジェクトにも含まれています。

  1. プロジェクトを選択します。
  2. 要件プロパティ リスト を作成し、要件の重要性をキャプチャします。 この例では、値を指定して要件プロパティ Business Value を作成します。
    • Low
    • Medium
    • High
  3. テスト属性 リスト タイプを作成し、このテストの目的のタイプをキャプチャします。 この例では、値を指定してテスト属性 Level を作成します。
    • Full
    • Regression
    • Smoke
  4. 追跡 > 品質目標 をクリックします。
  5. 新しい品質目標を作成します。 この例では、次の 目標 (%) を要件プロパティに指定して、品質目標 Business Value を作成します。
    • High-100%
    • Medium-75%
    • Low-50%
  6. 新しい品質目標を作成します。 この例では、次の 目標 (%) をテスト属性に指定して、品質目標 Test Objectives を作成します。
    • Full-80%
    • Regression-50%
    • Smoke-100%
  7. テスト資産の開発後、属性/プロパティを要件およびテストに割り当てます。
  8. テスト範囲を決定し、テスト範囲について関係者間で合意するには、レポート > 詳細ビュー をクリックします。
  9. テスト > ステータス レポート > 品質目標計画レポート をクリックします。

    このレポートでは、品質目標値ごとのテストの数とパーセンテージ、手動テストの合計計画時間、および、プロジェクトで使用可能なテスト数に対する目標を満たすために 必要なテスト数を示します。

    品質目標計画レポート
  10. 計画について合意を形成し、テスト実行を介してプロジェクトが進行すると、品質目標のテスト ステータスは、品質目標実行レポート を使用して簡単に評価できます。
  11. テスト > ステータス レポート > 品質目標実行レポート をクリックします。 品質目標実行レポート
親トピック: Silk Central、リスク ベース テスト、および品質目標


問題

Silk Central で問題を管理する方法について説明します。

  • 問題を新規作成する
    問題を新規作成してテストに追加する方法について説明します。
  • [ドキュメント ビュー] で問題統計を表示する
    ドキュメント ビュー で問題統計を表示します。
  • [問題] の [ドキュメント ビュー]
    ドキュメント ビュー を開いて、選択したプロジェクトの問題の統計情報を表形式で表示します。
  • [詳細ビュー] で問題統計を表示する
    詳細ビュー を開いて、問題統計を表示します。
  • [問題] ページ
    選択したプロジェクトに対して設定されたすべての問題追跡システムから問題を一覧表示します。
  • 既存の問題を割り当てる
    既存の問題をテストに割り当てます。
  • 問題の状態を更新する
    Silk Central と問題追跡システムとの間で問題のステータスを同期させる方法について説明します。
  • 問題を削除する (問題の参照)
    Silk Central の問題参照を削除する方法について説明します。
  • Issue Manager
    Issue Manager の概要について説明します。
親トピック: 問題追跡と結果分析


問題を新規作成する

問題 ページを利用すると、選択されているテストに関連する問題を簡単に作成できます。

問題を新規作成するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規の問題を作成するテストを選択します。
  3. 問題 タブをクリックします。
  4. 問題の新規作成 をクリックして、問題の新規作成 ダイアログ ボックスを開きます。
  5. 問題の提出先となる問題追跡システムの プロファイル を選択します。
    注: ここで選択したプロファイルが、今後新規の問題を入力する際のデフォルトの選択になります。 問題追跡システムに新規の問題を追加する場合は、問題追跡システムへのログイン情報の入力を要求されます。 ここで提供したログイン情報は、今後自動的に選択されます。
  6. 概要 フィールドに、この問題の簡単な概要を入力します。
  7. 説明 フィールドに、この問題の説明を入力します。
  8. ダイアログ ボックス右側の UI コントロールを使用して、問題に関する情報を入力します。
    注: これらの UI コントロールは、選択した プロファイル によって異なります。 例：Bugzilla で処理する問題を作成したい場合、製品、コンポーネントなどを指定する必要があります。 問題を JIRA で処理する場合は、問題の種類や優先度など、他の値を指定する必要があります。
  9. OK をクリックして問題を作成します。
親トピック: 問題


[ドキュメント ビュー] で問題統計を表示する

ドキュメント ビュー で問題統計を表示するには：

  1. メニューで 問題 > ダッシュボード ビュー をクリックします。
  2. 問題 ツリーで、統計を表示するプロジェクト、問題追跡システム、または製品を選択します。
親トピック: 問題


[問題] の [ドキュメント ビュー]

問題 > ドキュメント ビュー

ドキュメント ビュー は、選択したプロジェクトの問題の統計情報を表形式で表示します。

列 | 説明
日時 | 問題の詳細が更新された日時。
対応開始 | 選択したプロジェクト、データベース、または製品に含まれる、ステータスが [対応開始] である問題の数。
解決 | 選択したプロジェクト、データベース、または製品に含まれる、ステータスが [解決] である問題の数。
検証終了 | 選択したプロジェクト、データベース、または製品に含まれる、ステータスが [検証終了] である問題の数。
対応完了 | 選択したプロジェクト、データベース、または製品に含まれる、ステータスが [対応完了] である問題の数。
先送り | 選択したプロジェクト、データベース、または製品に含まれる、ステータスが [先送り] である問題の数。
親トピック: 問題


[詳細ビュー] で問題統計を表示する

詳細ビュー で問題統計を表示するには：

  1. メニューで 問題 > 詳細ビュー をクリックします。
  2. 問題 ツリーで、統計を表示するプロジェクト、問題追跡システム、または製品を選択します。
  3. カレンダー ツール機能を利用すると、問題統計を表示する期間を指定できます。期間の日付のリンクをクリックすると、カレンダー ツールが表示されます。
  4. カレンダーの 開始時間 リスト ボックスと 終了時間 リスト ボックスを使用して、問題統計の開始日時と終了日時を指定します。
  5. 更新 をクリックしてグラフ ビューを更新し、指定した期間に応じた統計を表示します。
親トピック: 問題


[問題] ページ

問題 > 詳細ビュー > 問題

問題 ページでは、選択したプロジェクトに対して設定されたすべての問題追跡システムから問題を一覧表示します。このページには、次の項目があります。

項目 | 説明
カレンダー ツール | ユーザーは、問題を報告する対象の期間を指定できます。期間の日付のリンクをクリックすると、カレンダーが表示されます。
更新 | 変更したカレンダーに合わせて 問題ビュー を更新します。ボタンは、変更が存在する場合にのみ表示されます。
親トピック: 問題


既存の問題を割り当てる

問題 ページを利用すると、選択されているテストに、問題追跡システムから問題を割り当てることができます。

テストに問題を割り当てるには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 問題の割り当て先となるテスト ノードを選択します。
  3. 問題 タブをクリックします。
  4. 既存の問題の割り当て をクリックして、既存の問題の割り当て ダイアログ ボックスを開きます。
  5. 問題の追跡を行っている、事前に設定された問題追跡システムのプロファイルを選択します。
  6. 問題 ID フィールドに問題番号をカンマ区切りで入力します。
  7. OK をクリックします。
注: 現在の実行 ページ、実行 ページ (実行計画 内)、および テストの実行 ページ (テスト 内) では、現在実行中の実行計画に既存の問題を割り当てることもできます。
親トピック: 問題
関連資料
[現在の実行] ページ
[実行] の [実行] ページ
[テスト] の [実行] ページ


問題の状態を更新する

Silk Central と問題追跡システムとの間で問題のステータスを同期させるには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 更新対象の問題を含むテスト ノードを選択します。
  3. 問題 タブをクリックします。
  4. 問題の状態の更新 をクリックして、Silk Central 内の問題のステータスと、問題追跡システム内の対応する問題のステータスを同期させます。
親トピック: 問題


問題を削除する (問題の参照)

問題参照を削除するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 問題を削除するテストを選択します。
  3. 問題 タブをクリックします。
  4. アクション 列で 削除 をクリックします。
  5. 問題の削除 ダイアログ ボックスで はい をクリックして、削除を確定します。
重要: このアクションにより、Silk Central の問題参照だけが削除されます。 問題追跡システムで問題そのものが削除されることはありません。
親トピック: 問題


Issue Manager

Issue Manager へようこそ。

Issue Manager は、問題を自動的に追跡するための総合的なツールです。 Issue Manager を使って、自分の組織のワークフローに合わせた方法で、問題を入力し、処理し、管理することができます。

また、Issue Manager は、ソフトウェアのバグや、ドキュメントに関する問題、機能拡張要求などの管理にも役立ちます。 アプリケーション開発者、QA エンジニア、技術サポート担当者、ドキュメント専門家、マネージャ、IT 担当者など、さまざまなユーザーのニーズを満たせるように作られています。

Issue Manager は、アクション駆動型ワークフローと呼ばれる技術を使用しています。 このワークフロー技術により、業務のワークフローに合わせてカスタマイズできるユーザーのアクションや問題の状態に基づいて、問題がそのライフサイクルに沿って自動的に移動します。 問題が報告されてからその対応が完了するまで、ユーザーがその問題に対してアクションを取るたびに、Issue Manager が自動的に問題のルーティングを行います。

管理者は、ユーザーやグループに割り当てられた受信箱の間で問題を自動的に進めていくためのルーティング ルールやワークフローを設定します。 特別なセキュリティ権限を持ったユーザーは、問題についてあらかじめ定義されたルーティングを上書きすることができます。

Issue Manager では以下のタスクを実行できます。

  • Web インターフェイスを介した問題の報告
  • 問題の追加、確認、再割り当て、解決、検証、対応完了
  • 任意の問題の詳細情報の表示
  • ユーザー アカウントと受信箱の表示
  • 問題に一定の変化が起きるたびの電子メールの受信
  • クエリの実行によるデータベースからの問題情報の取得
  • レポートやグラフの生成
  • 問題のアーカイブ化
  • Issue Manager 入門
    Issue Manager での作業を開始する方法について説明します。
  • Issue Manager を使用する
    Issue Manager を簡単に説明します。
  • Issue Manager 管理
    Issue Manager と Silk Central の関係について説明します。
親トピック: 問題


Issue Manager 入門

エンド ユーザーの場合

エンド ユーザーのタスクに慣れます。

組織の本番データベースを作成および設定する前に、サンプル データベースを作成します。その他の情報については、「 データベース」を参照してください。

管理者の場合

Issue Manager で作業する前に、データベースをセットアップする必要があります。その他の情報については、「 データベース」を参照してください。

  • サンプル データベースの探索
    管理者としてサンプル データベースを探索し、Issue Manager の機能に慣れます。
  • Issue Manager でできること
    Issue Manager の機能の概要を示します。
親トピック: Issue Manager
関連概念
データベース


サンプル データベースの探索

管理者としてサンプル データベースを探索し、Issue Manager の機能に慣れます。 サンプル データベースを探索するには：
  1. Issue Manager を起動し、無制限のアクセス許可を持つ 開発 ユーザーである dhart としてサンプル データベースにログインします。
  2. 既存の製品の問題を入力します。
  3. その問題を保存します。 Issue Manager によって、問題の詳細 ページの自動フィールドや 履歴 タブに値が自動的に設定されます。
  4. その問題に対して何らかのアクションを取り、対応するアクション ダイアログ ボックスに必要な値を入力します。 問題の詳細 ページが変化します。 このプロセスに慣れるまで、他のアクションを実行してみます。
  5. いくつかのユーザー アカウントを表示します。
    1. それらのユーザーがどのグループに割り当てられているかに注目します。
    2. ユーザーのセキュリティ権限を調べます。
    3. ユーザーのデフォルト受信箱に注目します。
  6. グループを追加します。
    1. セキュリティ権限を割り当てます。
  7. 新しいユーザーの受信箱を追加します。
    1. その受信箱を新しいグループに関連付けます。
  8. 新しいユーザーのアカウントを追加します。
    1. 新しい受信箱をそのユーザーに割り当てます。
    2. 他にもセキュリティ権限があれば、それらもこのユーザー アカウントに割り当てます。
  9. ルーティング ルールも含め、新しい製品を追加します。
    1. その製品の 1 つまたは 2 つのリリースを追加します。
    2. 各リリースを 1 つまたは 2 つのプラットフォームに関連付けます。
  10. システムからログアウトします。
  11. 新しいユーザーでログインします。
  12. ワークフローを通じて問題がどう処理されるのか確かめるために、新しい製品の問題を入力し保存します。
    1. ルーティング ルールで指定した受信箱の 1 つに問題が送られたことを、割り当て先 フィールドで確かめます。 バグが 開発準備完了 状態にあることに注意します。 履歴 タブを選択し、その中のエントリに注目します。
    2. 履歴 タブを選択し、その中のエントリに注目します。
    3. 別の開発者に問題を再割り当てします。
    4. このアクションが 履歴 タブにどう反映されるか確かめます。
    5. この問題に対して 解決 を設定し、次の状態に進ませます。 状態 フィールドが QA 準備完了 に代わり、割り当て先 フィールドがルーティング ルールで指定した受信箱に変わります。 これが QA エンジニア受信箱になると仮定します。
    6. 問題を 検証 に設定します。 つまり、バグが修正されたことを QA エンジニアが確認したということです。 問題は 対応完了 状態に移るはずです。 再度 履歴 タブを調べます。 どう変わったでしょうか。
  13. 新しい製品のコンポーネントを 2 つ追加します。
  14. それらのコンポーネントのルーティング ルールをセットアップし、製品全体の受信箱とは異なる受信箱を指定します。
  15. 特定の製品コンポーネントに対して別の問題を入力します。 ステップ 12 で説明しているサブステップを繰り返し、ルーティングがどう変わるかを確かめます。
    注: どの問題の場合もワークフローは同じなので、経過する状態はすべての問題に共通です。
  16. 問題の詳細 ページに表示されるフィールドのラベルを変更します。
  17. 製品コード を 製品 に変更します。
  18. 既存の 問題の詳細 ページを開いて、ラベルが変わったことを確認します。
  19. カスタム タブ 1 に新しいフィールドを追加します。
  20. 既存の 問題の詳細 ページを開き、カスタム タブを選択して新しいフィールドを確かめます。
  21. レポート ユニットで利用可能な定義済みのレポートやグラフをいくつか生成します。
親トピック: Issue Manager 入門


Issue Manager でできること

問題の追跡に関するニーズに完全にこたえるソリューションとして、Issue Manager は以下の機能を提供しています。
  • 問題の新規作成：
  • 問題のインポート： Silk Test を使うことで、Silk Test テスト ケースの詳細情報を Issue Manager に転送し、それを元に新しい問題を作成できます。同様に Silk Central の実行結果で注意が必要なものがあれば、それを元に簡単に新しい問題を作成することができます。
  • 問題の処理：Issue Manager では、問題の確認、再割り当て、修正、検証、対応完了を行うことができます (ユーザー タイプによって権限は変わります)。
  • ファイルと Issue Manager の問題との関連付け： 問題を再現するのに必要なファイルを持っている (または顧客が持っている) 場合には、そのファイルを Issue Manager にアップロードし、問題に添付することができます。そうしておけば、バグを確認、修正、検証するのに必要なファイルを簡単に見つけることができます。
  • システム内の各問題の完全な履歴の表示：Issue Manager はユーザーが問題に対して取ったアクションをすべて記録します。問題履歴には、デフォルトで、問題に対して取ったアクション、そのアクションを取ったユーザー、アクションについてのメモが含まれます。
  • ワークグループとのやり取り： Issue Manager 管理者は、組織内にワークグループを設定して、その中で権限や、アクセス許可、受信箱、割り当てを共有させることができます。こうすることで、個人のユーザーとやり取りするだけでなく、同じような仕事の責任を持つグループでも同様にやり取りすることができます。
  • 検索条件に合う問題情報のシステムに対する問い合わせ：あらかじめ定義されたクエリを使ったり、例を元にクエリを構築したり、(SQL に詳しい場合には) 詳細クエリを作成できます。
  • レポートとグラフの生成： 問題の条件に基づいてあらかじめ定義されたレポートを作成したり、SQL で詳細レポートを作成したりできます。
  • 通知の定義： 問題のステータスまたは割り当てが変更されたときに通知を受け取るように定義します。
  • 問題データベースとのリモートでのやり取り： Web 経由によりリモートで問題を入力し、クエリを行います。
  • 問題へのテストの割り当て： Silk Central を使用します
親トピック: Issue Manager 入門


Issue Manager を使用する

Issue Manager の『ヘルプ』では、Issue Manager を使用し、ソフトウェア開発環境のニーズを満たすために問題を追跡するときに役立つ情報とガイドラインを提供します。

  • 概要
    Issue Manager の概要について説明します。
  • 問題を入力する
    Issue Manager で問題を作成および編集する方法について説明します。
  • 問題を使った作業
    問題で作業する方法について説明します。
  • メール通知
    電子メール通知を使用する方法について説明します。
  • レポート (Issue Manager)
    Issue Manager レポートについて説明します。
  • プロジェクト (Issue Manager)
    Issue Manager のプロジェクトに基づくワークフローについて説明します。
親トピック: Issue Manager


概要

このセクションでは、Issue Manager UI の概要を説明します。 ここには、問題追跡 ページ、問題の詳細 ページ、問題の詳細 タブ、問題追跡 ツールバーが含まれます。

  • [問題追跡] ページ
    問題追跡 ページについて説明します。
  • [問題の詳細] ページ
    問題の詳細 ページについて説明します。
親トピック: Issue Manager を使用する


[問題追跡] ページ

メニューで、問題 > 問題追跡 をクリックします。

概要

問題追跡 ページに、ユーザーの受信箱の問題のリストが表示されます。別の受信箱を表示する場合は、ツールバーの 表示 リストから選択します。受信箱はグループごとに構成されています。ある グループ の受信箱だけを表示するには、ツールバーのリストからグループを選択します。列の表示/非表示を切り替えたり、幅を調整したり、列をドラッグして順番を変更することができます。列をクリックすると、グリッドの内容をソート、グループ化、またはフィルタできます。グリッドの [image] (問題の表示) をクリックすると、問題の詳細 ページに問題の詳細が表示されます。Up キーと Down キーを使用してリストをナビゲートし、Enter キーを押して問題の詳細を表示することもできます。

表示 リストを使用して、表示する問題を選択できます。
  • すべての対応中の問題：完了した状態にないすべての受信箱のすべての問題を表示します。
  • すべての問題：完了した状態の問題を含むすべての受信箱のすべての問題を表示します。
  • <受信箱名>: 選択された受信箱に割り当てられているすべての問題を表示します。

ツールバー

ツールバーにある該当ボタンをクリックして、以下のアクションを実行します。
  • (マイ受信箱) をクリックすると、ユーザーの受信箱の問題のリストが表示されます。
  • 問題の新規作成 をクリックすると、新しい問題を追加できます。
  • XLSX としてダウンロード （XLSX としてダウンロード）をクリックすると、Excel シートに問題のリストをエクスポートできます。
  • 問題番号を 問題へ移動 ツールバー フィールドに入力して、Enter キーを押すと、特定の問題にすばやく移動できます。
  • (Silk Test Classic Intelligent Assistant を開く) をクリックします。このアイコンは、SRFrontendBootConf.xml ファイルの ShowSilkTestAssistant タグのコメントが解除され、true に設定されている場合にのみ表示されます。詳細については、「Silk Test Intelligent Assistant」を参照してください。

一括編集

キーボードの Ctrl または Shift キーを使用すると、標準ブラウザの複数選択機能を使用して、複数の問題を選択することができます。ユーザーのアクセス許可に応じて、選択項目を右クリックすることで、複数の問題に対して以下のアクションを実行できます。
  • 問題の再割り当て： 完了した状態の問題が選択されていない場合。
  • ワークフロー アクション： 選択した問題の種類と状態が同じ場合。選択した問題の製品が同じ場合にのみ、製品に依存したフィールドを使用するワークフロー アクションが有効になります。
親トピック: 概要
関連概念
Silk Test Intelligent Assistant


[問題の詳細] ページ

メニューで、問題 > 問題追跡 をクリックし、ツールバーのリストから 受信箱 を選択し、グリッドで [image] (問題の表示) をクリックします。問題の詳細 ページには、問題の詳細情報が表示されます。

ツールバー

ページの上部にあるツールバーにアクションのリストが表示されます。リンクをクリックすると特定の問題に関する作業を行えます。使用可能なリンクは、問題の状態やユーザーに割り当てられた許可や権限によって変わります。使用可能なすべてのリンクのリストについては、「問題の処理の際のアクション」を参照してください。

（受信箱に戻る）をクリックすると、問題追跡 ページの問題のリストに戻ることができます。代わりに、Backspace キーも使用できます。

問題番号を 問題へ移動 ツールバー フィールドに入力して、Enter キーを押すと、特定の問題にすばやく移動できます。

問題の詳細

アクション リンクの下には、問題に関する重要な情報が表示されます。また、ここで添付情報の追加や通知の設定を行えます。問題の概要の下にある 添付情報 アイコンと 通知 アイコンを使用して、添付情報の追加と通知の設定を行います。
名前 | 説明
受信箱の前の問題 | 選択した受信箱の問題リスト内の前の問題のデータを表示します。代わりに、Up キーと Left キーも使用できます。
受信箱の次の問題 | 選択した受信箱の問題リスト内の次の問題のデータを表示します。代わりに 、Down キーと Right キーも使用できます。
添付情報 | ユーザーは問題に関する追加情報が含まれるファイルを追加できます。アクション 列にあるボタンを使用して、ファイルを編集および削除できます。編集 をクリックする必要はありません。
通知 | ユーザーは電子メール通知を設定できます。Issue Manager は、問題の値が変化したときに、電子メール経由で通知します。編集 をクリックする必要はありません。
印刷可能バージョンの表示 | 選択した問題のデータの印刷可能ビューを表示します。

[問題の詳細] タブ

[問題の詳細] タブは、問題の詳細 ページにある問題の詳細の下に表示されます。（顧客の追加や説明の更新など）タブの値を編集する前に、問題の詳細 ページの 編集 をクリックする必要があります。代わりに、F2 キーも使用できます。以下のタブを利用できます。
名前 | 説明
説明 | 問題の 概要 および 説明 が表示されます。 注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
履歴 | 問題に関するすべての変更を追跡します。例：問題が作成された時期、その作成者、再割り当て、修正、検証などのアクション、顧客、ファイル、テストケースの追加など。
顧客 | ユーザーは、問題を報告した顧客に関する情報を追加できます。アクション 列にあるボタンを使用して、その顧客を編集および削除できます。
トレーサビリティ | Issue Manager の問題に関連付けられたテストを表示します。Silk Central の認証情報を入力し、このタブを有効にします。テストの名前をクリックし、テスト詳細ビュー に移動します。テスト詳細ビュー の 問題 タブでは、そのテストに割り当てられたすべての問題を確認できます。
カスタム | カスタム フィールドを含み、Issue Manager 管理者セットアップを一覧表示します。
テストケース | ユーザーは Silk Test テストケースを追加できます。QA 担当者および開発担当者は、アクション 列の [image] (テストケースの実行) をクリックして、テストケースを直接実行できます。また、Silk Test テストケースは、Silk Test Intelligent Assistant を使ってインポートすることもできます。このタブは、SRFrontendBootConf.xml ファイルの ShowTestcasesTab タグのコメントが解除され、true に設定されている場合にのみ表示されます。
親トピック: 概要
関連タスク
問題に対するアクションの実施
関連資料
問題を使った作業のアクション


問題を入力する

この章では、Issue Manager で問題を作成および編集する方法、Silk Test Intelligent Assistant を使用して Silk Test 結果ファイルから問題を作成する方法、および結果を Silk Test からエクスポートする方法について説明します。

  • 問題を作成する (Issue Manager)
    問題を Issue Manager で新規作成する方法について説明します。
  • 問題の編集 (Issue Manager)
    Issue Manager で問題を編集する方法について説明します。
  • Silk Test Intelligent Assistant
    Silk Test Intelligent Assistant について説明します。
  • Silk Test 結果を Issue Manager にインポートする
    Silk Test テストの結果を Issue Manager にインポートする方法について説明します。
  • Silk Test から結果をエクスポートする
    結果を Silk Test からエクスポートする方法について説明します。
  • 変更案
    テストケース結果や Silk Test テストケースを問題と関連付けるとき、Issue Manager が問題の状態の変更を提案する仕組みについて説明します。
親トピック: Issue Manager を使用する


問題を作成する (Issue Manager)

問題を Issue Manager で新規作成するには：
  1. メニューで、問題 > 問題追跡 をクリックします。
  2. ツールバーの [image] (問題の新規作成) をクリックします。
  3. 問題の種類、製品、リリース、プラットフォーム、コンポーネント、深刻度 の値を選択します。
    注: 強調表示されたフィールドおよびリストは必須です。
    値を入力すると、Issue Manager では設定されたルールに基づいて問題に受信箱と初期状態が動的に割り当てられます。
  4. 概要 および 説明 を入力します。この問題と他の問題の間にリンクを作成するには、関連付ける問題の問題番号または概要を リンクした問題 フィールドに入力します (自動補完が有効です)。リンクした問題は、履歴 タブにリストされます。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. 省略可能：問題に詳細情報を追加します。タブをクリックしてから、以下のボタンをクリックします。
    • 顧客の追加：問題を報告した顧客位についての情報を追跡します。
    • ファイルの追加：問題に関する追加情報が記載されたファイルを追加します。
    • テストケースの追加：QA 担当者および開発担当者は、テストケース タブの アクション 列にある [image] (テストケースの実行) をクリックして、追加された Silk Test テストケースを直接実行できます。また、Silk Test テストケースは、Silk Test Intelligent Assistant を使ってインポートすることもできます。
    • 通知の追加：問題の特定の値が変化したときに、電子メール経由で通知を受けるように設定します。
  6. OK をクリックします。
問題の詳細 ページが表示されます。受信箱の問題のリスト (問題追跡 ページ) に戻るには、 [image] (マイ受信箱) をクリックします。
親トピック: 問題を入力する


問題の編集 (Issue Manager)

Issue Manager で問題を編集するには：
  1. メニューで、問題 > 問題追跡 をクリックします。
  2. グリッドの [image] (問題の表示) をクリックします。 問題の詳細 ページが表示されます。
  3. 編集 をクリックします。
  4. リストおよびフィールドの値を編集します。
  5. タブをクリックし、問題の詳細を編集します。
  6. OK をクリックします。
変更は履歴で追跡されます。 変更を表示するには、履歴 タブをクリックします。
親トピック: 問題を入力する


Silk Test Intelligent Assistant

Silk Test Intelligent Assistant は Silk Test 結果ファイル (.rex) のテストケースを分析します。次にアシスタントは Issue Manager で追跡可能なテストケースの問題を作成します。
注: Silk Test Classic Intelligent Assistant を開く アイコンは、SRFrontendBootConf.xml ファイルの ShowSilkTestAssistant タグのコメントが解除され、true に設定されている場合にのみ表示されます。

テストケース結果に基づき、問題を新規作成したり、既存の問題を更新したりできます。たとえば、テストケースを実行してそれが失敗に終わった場合、Intelligent Assistant は新しい問題を作成してテストケースを添付することができます。その後、QA エンジニアは添付されたテストケースを Issue Manager から直接実行し、問題が修正されたかどうかを判断できます。

1 つまたは複数のテストケースを 1 つの問題に割り当てることができます。ただし、同じテストケースを複数の問題に割り当てることはできません。Intelligent Assistant は、スクリプト名とテストケース名と引数が同じなら、同じテストケースであると判断します。

注: 1 つのテストケースを異なる複数のプラットフォームで実行した場合に、それを別々のテストケースとみなすよう Intelligent Assistant を設定できます。Intelligent Assistant は、すべてのプラットフォームでそのテストケースが合格するまで、修正されたとは見なしません。
親トピック: 問題を入力する
関連資料
[問題追跡] ページ


Silk Test 結果を Issue Manager にインポートする

Silk Test テストの結果をインポートするのは：
  1. メニューで、問題 > 問題追跡 をクリックします。
  2. ツールバーのリストから 受信箱 を選択します。
  3. ツールバーの [image] (Silk Test Classic Intelligent Assistant を開く) をクリックします。
  4. コンピュータ上で .rex ファイルを参照します。
  5. リストからプラットフォームを選択し、統合ロジックの一要素としてテストの実行対象であるプラットフォームを使用します。
  6. チェック ボックスをオンにして、エラーがなく、まだ問題に関連付けられていないテストを含め、次へ をクリックします。
  7. チェック ボックスをクリックしてテストケースを選択し、次のボタンのいずれかをクリックします。
    • 問題を新規作成し、それにテストケースを割り当てるには、問題の新規作成 をクリックします。 詳細については、「問題の作成 (Issue Manager)」を参照してください。
    • テストケースを問題に割り当てるには、既存の問題 をクリックして問題番号を入力します。
    割り当てられたテストケースは、リストには表示されなくなります。
  8. Next をクリックします。
  9. 提案されたアクションを確認し、完了 をクリックします。
テストケースが問題に割り当てられます。 テストケースを実行または編集するには、テストケース タブの アクション タブにあるボタンをクリックします。
親トピック: 問題を入力する


Silk Test から結果をエクスポートする

結果を Silk Test からエクスポートするには：
  1. Silk Test で 結果 > Send to Issue Manager をクリックします。 Send Results to Issue Manager ダイアログ ボックスが開きます。
  2. 結果ファイル (.res) を選択します。
  3. OK をクリックします。 Intelligent Assistant が起動します。 Intelligent Assistant タブが開きます。 このタブの エクスポートされたテスト結果 (.rex) フィールドには、結果ファイルのパスが既に表示されています。
  4. Next をクリックします。 テストを問題と関連付ける ダイアログが表示されます。
「Issue Manager に Silk Test の結果をインポートする」のステップに従います。
親トピック: 問題を入力する


変更案

テストケースの結果や Silk Test テストケースを問題に関連付けると、Silk Test Intelligent Assistant はその結果と問題に関する現在の情報を比較し、問題の変更案のリストを作成します。

このリストには、問題に対するアクション案と、問題の新しい状態、アクションを承認したときに生じる理由コードが含まれます。 アクション案は、各問題の現在の状態と理由コード、そして関連するテストケースの結果を元に決められます。

Silk Test Intelligent Assistant は、次の式を使って変更案のリストを作成します。

[現在の状態と理由コード] + [テスト結果] = [特別なアクション、新しい状態、理由コード]

たとえば、問題の現在の状態が QA 準備完了 で理由コードが 解決 であり、問題に関連付けられたテストケースが失敗の場合、Intelligent Assistant は 自動修正却下 のアクションを提案します。 そのアクションを取ると、欠陥の状態は 開発準備完了 に、理由コードは 却下 に変更されます。 この例をまとめると次のような式になります。

[QA 準備完了かつ解決] + [テスト失敗] = [自動修正却下、開発準備完了、却下]

親トピック: 問題を入力する


問題を使った作業

Issue Manager は、問題での作業を可能にするさまざまなアクションを提供します。 たとえば、問題を解決または実装済みとしてマークしたり、追加情報が必要だと示したり、問題が失効した問題だと示したりできます。

これらのアクションのボタンは、問題の詳細 ページの右側に表示されます。 使用可能なすべてのアクションのリストについては、「問題の処理の際のアクション」を参照してください。 問題のリストは、問題の状態や特定のユーザーの権限によって変わります。 Issue Manager の管理者は、多くのアクションを設定およびカスタマイズできます。

  • 問題を使った作業のアクション
    問題に関する作業を行うときに使用できるすべてのアクションを説明します。アクションのリストは、問題の状態や権限によって異なります。
  • 問題に対するアクションの実施
    問題に対するアクションの実施方法について説明します。
  • 問題検証の優先設定を設定する
    問題検証の優先設定とその設定方法について説明します。
親トピック: Issue Manager を使用する


問題を使った作業のアクション

問題の詳細 ページの上部には、アクションのリストが表示されます。リンクをクリックすると特定の問題に関する作業を行えます。アクションは、問題の状態やユーザーに割り当てられた許可や権限によって変わります。

以下のアクションを実行できます。
アクション | 説明
受け付け | 問題に記述された機能拡張やドキュメントの問題が、受け付けられ、今後開発される予定であることを示します。
コメントの追加 | 問題に対して取っているアクションについてのコメントを入力できます。
回避策の追加 | 問題はすぐには修正されないが、回避策を文書化することを示します。
対応済み | 問題が既に解決していることを示します。
調停 | 問題の状態について意見が一致していないことを示します。開発担当者、ドキュメント担当者、QA 担当者の間で問題およびその状態を話し合う必要があります。
設計どおり | 機能が設計どおりに動作しているため、問題が実際には問題でないことを示します。
実現不能 | 機能拡張要求が実装不可能であることを示します。
解決不能 | 問題が解決不可能であることを示します。原因は、問題修正のリスクが高すぎるか、修正に時間がかかりすぎるためと考えられます。
バグとして確認 | 問題は、実際に問題であり、修正が必要なことを示します。
プロジェクトへコピー | 問題を別のプロジェクトにコピーできます。顧客や添付ファイルやテストケースはすべて、問題と一緒にコピーされます。通知はコピーされません。ボタンをクリックし、リストから プロジェクト を選択して OK をクリックします。フィールドやリストに元の問題から値が入力されます。必要に応じて値を編集し、OK をクリックします。
先送り | 問題を後のリリースに先送りできます。
編集 | 問題の詳細 ページの 問題の詳細 タブにあるフィールドやリストの値を編集できます。
解決 | 問題が解決していることを示します。問題が解決したビルドまたはリリースを指定します。
実装済み | 機能拡張が実装されていることを示します。
重複として指定 | 他の問題の重複として、問題に印を付けます。重複先の問題の問題番号を指定します。その問題は、対応開始のままになります。
追加情報が必要 | 開発担当が QA 担当から追加情報を必要としていることを示します。バグが再現できない場合や、記述が明確でない場合が考えられます。
失効した問題 | 問題が古く無効になっていることを示します。新しい機能や別のバグ フィックスによって問題が解決された場合が考えられます。
非バグ | この問題がバグなのではなく、報告者が機能を誤解しているだけであることを示します。
再現不能 | 問題が再現不能であることを示します。
再割り当て | 問題を別の受信箱に割り当てることができます。
却下 次のいずれかであることを示します。
  • 問題は修正されたが、検証できないため却下された。
  • 機能拡張要求が承認されなかった。
バグ対応再開 | QA 担当者が問題の対応を再開したことを示します。前のビルドで修正した問題が後のビルドになって再発した場合が考えられます。
検証 | 問題が修正され、その修正が承認されたことを示します。
親トピック: 問題を使った作業
関連タスク
問題に対するアクションの実施
関連資料
[問題の詳細] ページ


問題に対するアクションの実施

既存の問題に対してアクションを実施するには：
  1. メニューで、問題 > 問題追跡 をクリックします。
  2. (マイ受信箱) をクリックするか、ツールバーのリストから グループ および 受信箱 を選択します。
  3. グリッドの [image] (問題の表示) をクリックします。 問題の詳細 ページが表示されます。ページの上部にアクションのリストが表示されます。
  4. アクション リンクをクリックし、ダイアログ ボックスに必須の値を入力します。
使用可能なすべてのアクションのリストについては、「問題の処理の際のアクション」を参照してください。
親トピック: 問題を使った作業
関連資料
[問題の詳細] ページ
問題を使った作業のアクション


問題検証の優先設定を設定する

問題検証の優先設定を使用すると、新規に問題を作成したり、既存の問題で作業したりするたびに使用する問題の検証方法を設定できます。

問題検証の優先設定を設定するには：

  1. メニューで 問題 > 設定 をクリックします。
  2. 設定 をクリックします。
  3. 以下のいずれかのオプションを選択します。
    • 常に標準のルーティングを使用する をクリックします。これはデフォルトのシステム ルーティングです。
    • 常に自分の問題を検証する をクリックすると、入力した問題をすべての自分にルーティングして検証します。
    • 新規の問題ごとに指定する をクリックすると、個々のケースごとに問題を自分にルーティングするか、標準のルーティングを使用するかを決定します。
注: 優先設定を設定するには、問題検証の優先設定 セキュリティ権限が必要です。 Issue Manager 管理者がこの権限をユーザーに割り当てることができます。 この権限を持っていない場合は、オプション ボタンは無効になります。
親トピック: 問題を使った作業


メール通知

事前に設定したイベントが発生したときに通知されるように Issue Manager を設定できます。次のイベントに対して設定できます。
  • 再割り当て：状態を変更しないまま問題を再割り当てしたとき。
  • 状態変化：問題の状態が変わったとき。
  • 任意の変更：問題に対して履歴のエントリが新しく生成されるような変更。
Issue Manager 管理者は特定のイベントに対して追加のルールを定義できます。ルールを定義したら、ユーザーは通知をセットアップできます。システム全体の通知や特定の問題に対する通知を定義できます。これらのアクションには、次のセキュリティ権限が必要です。
アクション | 必要なセキュリティ権限
通知ルールを定義する | 電子メール通知ルールとシステム全体の通知
電子メール通知を定義する | 問題ごとの電子メール通知
システム全体の通知を定義する | 電子メール通知ルールとシステム全体の通知

Silk Central システム管理者は、電子メール サーバー設定を行う必要があります。設定が行われないと、電子メール通知は機能しません。

割り当てられた許可に関係なく、すべてのユーザーが基本の電子メール通知を定義できます。この基本的な通知を設定すると、別のユーザーが自分の受信箱の問題に変更を加えたり、受信箱に新しい問題を割り当てたりしたときに、Issue Manager によって通知されます。

  • 通知ルールの定義
    通知ルールを定義する方法について説明します。
  • 電子メール通知の定義
    電子メール通知を定義する方法について説明します。
  • 基本の電子メール通知を設定する
    ユーザーによって自分の受信箱に問題が割り当てられた場合や、受信箱の問題が変更された場合に通知されるように Issue Manager を設定する方法について説明します。
親トピック: Issue Manager を使用する
関連概念
電子メール通知ルールのセットアップ


通知ルールの定義

Issue Manager は、3 つのデフォルトの通知ルールを提供します：任意の変更、再割り当て、状態変化。追加の通知ルールを定義するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 左側の 通知ルール をクリックします。
  3. ルールの追加 をクリックします。 通知ルールの新規作成 ダイアログ ボックスが表示されます。
  4. ルール名、説明、WHERE 句 を入力します。詳細については、「電子メール通知ルールの定義」を参照してください。
  5. アクティブ チェック ボックスをオンにして、ルールをアクティブにします。
  6. OK をクリックします。
通知ルールがリストに追加されます。
注: 通知ルールを定義するには、電子メール通知ルールとシステム全体の通知 のセキュリティ権限が必要です。
親トピック: メール通知
関連タスク
電子メール通知ルールの定義


電子メール通知の定義

電子メール通知を定義するには：
  1. メニューで、問題 > 問題追跡 をクリックします。
  2. (マイ受信箱) をクリックするか、ツールバーのリストから グループ および 受信箱 を選択します。
  3. グリッドの [image] (問題の表示) をクリックします。問題の詳細 ページが表示されます。
  4. 通知 アイコンをクリックします。
  5. 通知の追加 をクリックします。 通知の追加 ダイアログ ボックスが表示されます。
  6. 必要な値を入力し、OK をクリックします。 通知がリストに追加されます。
通知を編集するには、 [image] (通知の編集) をクリックし、通知を削除するには、アクション 列の [image] (通知の削除) をクリックします。システム全体の通知の設定についての詳細は、「システム全体の通知を管理する」を参照してください。
親トピック: メール通知
関連概念
システム全体の通知を管理する
関連タスク
システム全体の通知を追加する


基本の電子メール通知を設定する

基本の電子メール通知を設定するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 左側の 設定をクリックします。
  3. 自分に問題が割り当てられたり自分の受信箱に入っている問題が変更されたときに通知する チェック ボックスをオンにします。
注: 割り当てられた許可に関係なく、すべてのユーザーが基本の電子メール通知を定義できます。 基本の電子メール通知の件名と内容は、SRFrontendBootConf.xml ファイルで設定できます。
親トピック: メール通知


レポート (Issue Manager)

高度にカスタマイズ可能な Issue Manager レポートを使用すると、データをわかりやすいグラフに変換することができます。Issue Manager には、3 つのカテゴリに分類できる、設定済みのレポートが多数用意されています。これらのカテゴリは レポート ツリーに表示されます。
  • 一般レポート
  • テキスト検索
  • 管理レポート

テキスト検索とは、レポート データを表形式で返すクエリです。レポートのテンプレートは、BIRT Report Designer (Eclipse 上で動くオープン ソースのレポート ツール) または Microsoft Excel を使って作成します。

選択したプロジェクトにデータがない場合、または正しい Issue Manager データベースに接続していない場合は、空白のレポートが生成されます。

GUI ベースのツールを使用するか、手動で SQL コードを記述することでレポートを作成することができます。この高度な手法を用いると、さまざまなデータの問い合わせやレポートでの表示をほぼ制限なく行うことができます。

レポートでの作業の詳細については、「レポート」を参照してください。

  • レポートを作成する
    レポートを Issue Manager で作成する方法について説明します。
  • サブレポートを追加する
    複数のレポートから結果を集計するサブレポートを追加する方法を説明します。
  • レポートのプロパティを編集する
    レポートのプロパティを編集する方法について説明します。
  • レポートのパラメータを編集する
    レポートのパラメータを編集する方法について説明します。
  • Issue Manager の SOAP API
    サード パーティ製のツールから SOAP API を使用して Issue Manager リポジトリにアクセスする方法について説明します。
親トピック: Issue Manager を使用する
関連概念
レポート


レポートを作成する

Issue Manager レポートを作成するには：
  1. メニューで 問題 > レポート をクリックします。
  2. レポート ツリーでフォルダを選択します。
  3. ツールバーの [image] (子レポートの新規作成) をクリックします。 レポートの新規作成 ダイアログ ボックスが表示されます。
  4. 名前 および 説明 を入力します。
  5. このレポートを他のユーザーと共有する 場合は、このチェック ボックスをオンにします。
  6. タイムアウト [秒] を入力し、レポート実行の完了を Issue Manager が待つ時間を定義します。
  7. リストから デフォルト タブ と 結果カテゴリ を選択します。 コンテキスト メニューを使用してレポートを評価する場合 (たとえば、テストを右クリックした場合)、定義済みの デフォルト タブ に移動します。
  8. リストから 選択基準、プロパティ、演算子、値 を選択します。 文字列で利用できるワイルドカードは、* (任意の数の文字) および ? (必ず 1 つの文字に一致) です。
  9. さらに表示 をクリックし、追加のクエリ文字列を作成したり、クエリ文字列を組み合わせる AND または OR 演算子を選択したりします。 (削除) をクリックし、クエリ文字列を削除します。
  10. 次へ をクリックし、レポートの列を設定します。 列の追加、すべて削除 の他、 [image] (上へ移動) または [image] (下へ移動) をクリックして順序を設定したり、 [image] (削除) をクリックして 1 つの列を削除したり、ソート オプションやグループ化オプションを設定したり、エイリアス を入力したりできます。
  11. 完了 をクリックします。

また、手動で SQL コードを記述してレポートを作成することもできます。 レポートの新規作成 ダイアログ ボックスで 詳細 をクリックし、SQL コードを入力または貼り付けます。 詳細については、「SQL で高度なクエリを作成する」を参照してください。 使用可能なすべてのプレースホルダーのリストについては、「カスタム レポート用の SQL 関数」を参照してください。

親トピック: レポート (Issue Manager)
関連概念
カスタム レポート用の SQL 関数


サブレポートを追加する

複数のレポートの結果を現在選択しているレポートに集約するために、サブレポートを追加することができます。サブ レポートの結果の列と行は、選択したレポートの結果に連結されます。

サブレポートを追加するには：

  1. メニューで 問題 > レポート をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. プロパティ タブをクリックします。
  4. サブレポートの追加 をクリックします。 サブレポートの追加 ダイアログ ボックスが表示されます。
  5. レポート ツリーから、現在のレポートに追加するサブレポートを選択します。
  6. OK をクリックします。 関連するレポートの プロパティ ページの サブレポート セクションに、サブレポートが表示されます。
サブレポートを削除するには、アクション 列の [image] (削除) をクリックします。
親トピック: レポート (Issue Manager)


レポートのプロパティを編集する

レポートのプロパティを編集するには：
  1. メニューで 問題 > レポート をクリックします。
  2. レポート ツリーからレポートを選択します。
  3. ツールバーの [image] (編集) をクリックします。 レポートの編集 ダイアログ ボックスが表示されます。
  4. 必要に応じて、値を編集します。
  5. 完了 をクリックします。
このダイアログ ボックスの UI コントロールの詳細については、「レポートを作成する」を参照してください。
親トピック: レポート (Issue Manager)


レポートのパラメータを編集する

レポートのパラメータを編集するには：
  1. メニューで 問題 > レポート をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. パラメータ タブをクリックします。 レポートにパラメータが定義されている場合は、ここに一覧表示されます。
  4. パラメータの編集 をクリックします。 パラメータの編集 ダイアログ ボックスが表示されます。
  5. 必要に応じて、一覧表示されたパラメータの ラベル や 値 を編集します。
  6. 使用方法 リストから、パラメータの使用方法の種類を選択します。
    • 定数値
    • 開始日
    • 終了日
  7. OK をクリックします。
レポートのパラメータの詳細については、「[レポートのパラメータ] ページ」を参照してください。
親トピック: レポート (Issue Manager)
関連資料
[レポート] の [パラメータ] ページ


Issue Manager の SOAP API

Issue Manager は、サード パーティ製のアプリケーションから欠陥を登録するなどの目的で Issue Manager リポジトリにアクセスできるよう、API (Application Programmable Interface) を公開しています。

WSDL がベースとしているインターフェイスを以下に記載してあります。 このインターフェイスには、メソッドのドキュメントも含まれています。

/**
* A Project object has a ProjectID and a ProjectName. The ProjectID
is used for all further methods
* for specifying the Issue Manager project you want to work on.
* @param sessionID
* @return Array of initialized Issue Manager projects available
for the user used for generating the sessionID
* @throws SQLException
*/

public Project[] getProjects(long sessionID) throws SQLException;

/**
* @param sessionId
* @param projectID
* @return the names of the 3 issue types
*/

public String[] getIssueTypes(long sessionId, int projectID)
throws RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @return Array of ProductNames that are configured for the
provided Issue Manager project
*/

public String[] getProducts(long sessionId, int projectID)
throws RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @param product
* @return Array of ReleaseNames that are configured for the
provided product
*/

public String[] getReleases(long sessionId, int projectID,
String product) throws RemoteException, MissingValueException,
SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @return Array of available PlatformNames
*/

public String[] getPlatforms(long sessionId, int projectID) throws
RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @param product
* @return Array of ComponentNames that are configured for the
provided product
*/

public String[] getComponents(long sessionId, int projectID,
String product) throws RemoteException, MissingValueException,
SQLException, LoginException;

/**
* The list of Severities can be grouped by IssueType or Product.
If the list is grouped by IssueType the
* parameter issueType has to be provided and the product parameter
can be empty. If the list is grouped by
* product issueType can be empty and the product has to be selected.
* @param sessionId
* @param projectID
* @param product
* @param issueType
* @return Array of values that can be used for entering an issue in
the given project when the provided
* IssueType/Product is selected.
*/

public String[] getSeverities(long sessionId, int projectID,String
product,String issueType) throws RemoteException,
MissingValueException, SQLException, LoginException,
NotExistingValueException;

/**
* @param sessionId
* @param projectID has to be a ProjectID delivered by
the method getProjects
* @param issueType has to be a values delivered by
the method getIssueTypes
* @param product has to be a values delivered by
the method getProducts
* @param release has to be a values delivered by
the method getReleases for the selected product
* @param platform has to be a values delivered by
the method getPlatforms
* @param component has to be a values delivered by
the method getComponents for the selected product
* @param severity has to be a values delivered by
the method getSeverities for the selected projectID
and IssueType/Product
* @param synopsis the Synopsis for the new issue
* @param description the Description for the new issue
* @return the Issue Number of the new issue
*/

public int saveNewIssue(long sessionId, int projectID,
String issueType, String product, String release, String
platform, String component, String severity, String
synopsis, String description) throws RemoteException,
MissingValueException, NotExistingValueException,
SQLException, LoginException;
親トピック: レポート (Issue Manager)


プロジェクト (Issue Manager)

Issue Manager はプロジェクト ベースのワークフローを使用します。 表示や処理の対象になるのは、アクティブ プロジェクトに関連付けられている問題だけです。 個々の問題にアクセスするには、プロジェクトを選択する必要があります。 メニューで、問題 > プロジェクト リスト をクリックし、アクティブ化するプロジェクトの名前をクリックします。 別のプロジェクトを選択するまで、選択したプロジェクトがアクティブのままになります。

  • リポジトリ構成の初期化
    使い始める前に、Issue Manager 用のプロジェクトを初期化する必要があります。
親トピック: Issue Manager を使用する


リポジトリ構成の初期化

使い始める前に、Issue Manager 用のプロジェクトを初期化する必要があります。

初期化されたプロジェクトでは、アクション 列に 初期化済み が表示されます。

プロジェクトを初期化するには：

  1. メニューで 問題 > プロジェクト リスト をクリックします。
  2. アクション 列の [image] (プロジェクト <プロジェクト名> のリポジトリ設定の初期化) をクリックします。 リポジトリの初期化 ダイアログ ボックスが表示されます。
  3. 省略可能：初期化しているデータベースのサンプル データを作成するには、サンプル データの作成 をクリックします。
  4. OK をクリックし、初期化を開始します。 設定ウィザードの開始 ダイアログ ボックスが表示されます。
  5. はい をクリックして 設定ウィザード に進むか、プロジェクトを後で設定する予定である場合は いいえ をクリックします。
Issue Manager の設定方法についての詳細は、「Issue Manager の管理」を参照してください。
親トピック: プロジェクト (Issue Manager)
関連概念
Issue Manager 管理


Issue Manager 管理

ユーザー アカウント管理などの管理作業の他、Issue Manager ではデータベース リポジトリも Silk Central と共有します。Issue Manager プロジェクトも Silk Central 管理 ユニットで作成、設定、管理されます。これにより、Issue Manager プロジェクトと Silk Central プロジェクトの統合が可能になります。

Issue Manager を Silk Central と組み合わせて使う場合には、要件、テスト、実行定義など、問題の他にさまざまな要素がプロジェクトに含まれる場合があります。

Issue Manager プロジェクト

Issue Manager はプロジェクト ベースのワークフローを使用します。表示や処理の対象になるのは、アクティブ プロジェクトに関連付けられている問題だけです。個々の問題にアクセスするには、まず Issue Manager プロジェクトを (プロジェクト ユニットで) 選択する必要があります。そこで選択したプロジェクトは、Issue Manager にアクセスするたびに、デフォルトとして選択されます。 ただし、別のプロジェクトを作業対象に選択すると、それ以降は新たに選択したプロジェクトがデフォルトになります。

データベース構成の初期化

プロジェクトを作成した後、Issue Manager プロジェクトとして使用するには、プロジェクトのデータベース接続を初期化する必要があります。

  • データのセットアップ
    組織に関する情報をデータベースに入力する方法について説明します。
  • 日常的な管理作業
    Issue Manager に対して実行する必要がある、日常的な管理作業について説明します。
  • オプション機能
    Issue Manager で利用できるオプション機能について説明します。
  • グループのセットアップ
    Issue Manager でユーザー グループをセットアップする方法について説明します。
  • 受信箱のセットアップ
    Issue Manager で受信箱をセットアップする方法について説明します。
  • ユーザー アカウントのセットアップ
    問題管理用のユーザー アカウントをセットアップする方法について説明します。
  • 製品設定を定義する
    製品設定を定義する方法について説明します。
  • ルーティング ルールのセットアップ
    ルーティング ルールを定義して、ライフサイクル中の問題の送り先を決定する方法について説明します。
  • 問題の詳細ページのカスタマイズ
    問題関連ページの外見や動作を変更する方法について説明します。
  • ワークフローのカスタマイズ
    ワークフローのカスタマイズ方法について説明します。
  • 問題のアーカイブ化
    問題のアーカイブ化について説明します。
  • 電子メール通知ルールのセットアップ
    電子メール通知ルールとシステム全体の通知について説明します。
親トピック: Issue Manager


データのセットアップ

Issue Manager の使用に慣れたら、組織に関する情報をデータベースに入力します。 この情報は、設定 ページで入力できます。 設定 ページを開くには、問題 > 設定 をクリックします。

まず行うべきことは、組織の作業プロセスに関する情報の収集です。 時間をかけて慎重に計画を立ててください。 組織で Issue Manager を効率的に利用するには、次の主要領域に関する情報を収集する必要があります。
  • 人員
  • 製品
  • 問題追跡 ページ、アクション ダイアログ ボックス、および Issue Manager のワークフローの組織に対する適合性。
次のアクティビティをここに示す順序で完了します。
  1. 組織の人員に関する情報の収集
  2. 製品に関する情報の収集
  3. 省略可能：Issue Manager のインターフェイスとワークフローへのアクセス 問題追跡 ページ、アクション ダイアログ ボックス、深刻度リスト、ワークフローは、設定 ページでカスタマイズできます。
  4. 独自のデータベースを作成し、そこにセットアップ データを入力します。
  • 組織の人員に関する情報を収集する
    組織の人員に関する情報を収集し、組織で Issue Manager を効率的に使用します。
  • 製品に関する情報を収集する
    組織内の製品に関する情報を収集し、組織で Issue Manager を効率的に使用します。
  • 省略可能：インターフェイスとワークフローの評価
    Issue Manager のインターフェイスとワークフローを評価し、組織内で Issue Manager を効率的に使用します。
親トピック: Issue Manager 管理
関連概念
データベース


組織の人員に関する情報を収集する

組織の人員に関する情報を収集するには：
  1. グループのリストを作成します。
  2. 各グループのすべてのメンバに適している、セキュリティ権限と問題の初期状態を決定します。
  3. アカウントのリストを作成します。 Issue Manager にログインするユーザーには、それぞれアカウントが必要です。
  4. アカウントの命名スキームを決定します。 割り当てられるグループの他、必要であれば 1 つ以上の受信箱も指定します。 次の質問を検討してみます：
    • グループの権限でカバーされない特別なセキュリティ権限が必要なアカウントはどれでしょうか。
    • そのアカウントについては、問題の初期状態をグループと異なるものにすべきでしょうか。
    • ログインにはパスワードが必要でしょうか。
  5. ユーザー アカウントのリストを見直しながら、どのユーザーに受信箱が必要かを書き留めます。 グループにも受信箱が必要でしょうか。 受信箱の命名スキームを決定します。
  6. すべてのユーザーのデフォルト ビューをカスタマイズすることもできます。 受信箱のデフォルト ビューは、すべてのユーザーに共通です。 ビューには、8 列にわたって情報が表示されます。
親トピック: データのセットアップ


製品に関する情報を収集する

組織内の製品に関する情報を収集するには：
  1. 製品、各製品のリリース、および各リリースのプラットフォームのリストを作成します。
  2. 作成したプラットフォーム リストと 管理 > プラットフォーム にあるリストを比較します。
  3. 各製品のソフトウェア コンポーネントおよびドキュメント コンポーネントのリストを作成します。 コンポーネント (機能領域) は必須ではありませんが、その情報があれば、製品、リリース、プラットフォーム、およびコンポーネントに基づいて問題を追跡し、問題のルーティングをより細かく制御することができます。
  4. 問題の深刻度のリストを作成します。 このリストの値が、問題追跡 ページの 深刻度 列に表示されます。 このリストを製品または問題種別で分類することもできますし、すべての製品および問題種別に対応する汎用のリストを用意することもできます。
  5. このリストを 管理 > 値リスト にあるリストと比較します。
  6. ある特定の製品、コンポーネント、リリース、プラットフォームに関係する問題をどの受信箱で受け取るかを決定します。 これらがルーティング ルールです。
親トピック: データのセットアップ


省略可能：インターフェイスとワークフローの評価

Issue Manager のインターフェイスとワークフローを評価するには：
  1. 問題追跡 ページの外見と動作を評価して、以下のタスクの実行が必要かどうかを判断します。
    • デフォルトの列のラベルの変更。
    • 列の追加による付加的情報の獲得。
    • アクション ダイアログ ボックスのフィールドの変更または独自フィールドの追加。
    変更内容のリストを残しておいてください。 自らの加えた変更内容は、自分で責任を持って組織内のユーザーに知らせる必要があります。
  2. デフォルト ワークフローを評価して、それらが組織のニーズをモデリングしているかどうかを判断します。 各状態とその状態に有効なアクションを調べます。 それらのアクションのデフォルト グループ アクセス許可は十分なものですか。
親トピック: データのセットアップ


日常的な管理作業

初期セットアップの完了後、Issue Manager を最新の状態に保つため、折に触れて日常的な管理作業を実行する必要があります。 最も一般的な作業は以下のとおりです。

新しいユーザーの追加

新しいユーザーについては、次の作業を実行する必要があります。
  • アカウントをセットアップする前に、必要に応じて受信箱を作成する。
  • 新しいアカウントをセットアップし、そのアカウントを既存のグループと必要ならデフォルトの受信箱に関連付ける。
  • ユーザーが自動ルーティングで問題を受信する必要がある場合は、ユーザーの受信箱をルーティング ルールに追加する。

ユーザーの削除

ユーザーが組織を辞めたときは、次の作業を実行する必要があります。
  • ユーザーのアカウントを直ちに停止し、ログインできないようにする。 そのユーザーが問題の作成や変更を行ったことがある場合は、アカウントを削除することはできません。
  • ルーティング ルールでユーザーの受信箱を参照している箇所をすべて別の受信箱に置き換える。 この処置により、この受信箱に新しい問題が送られないようにすることができます。
    注: ルーティング ルールの変更は、Issue Manager に他のユーザーがログインしていないときに行う必要があります。
  • ユーザーの受信箱に含まれている問題を他の受信箱に再割り当てすることで、ユーザーの受信箱を空にする。
  • ユーザーの受信箱を削除する。

作業割り当ての移行

ユーザーの任務が変わったときは、グループ割り当てを更新する必要があります。 たとえば、QA エンジニアの Sarah が開発部門に移ったとしましょう。 また、新しい責務に合った問題をユーザーが受信できるように、ルーティング ルールを変更することも必要です。 たとえば、Sarah は QA 部門ではなく開発部門に注意を払ってもらう必要のある問題を受信できるようになっていなければなりません。

ユーザーのプロジェクトが変わったときは、ユーザーの現在の責務を反映するようにルーティング ルールを変更する必要があります。 さらに、それでもデフォルトの受信箱が必ず適切なものになるようにする必要があります。 たとえば、Judy はドキュメント ライターで、それまで Product A のドキュメントを書いていましたが、現在は Product B のドキュメントを書いているとしましょう。 Judy のデフォルト受信箱 Judy - Doc (Product A) は、Judy - Doc (Product B) に変更されなければなりません。

新製品情報の追加

場合により、次の作業を実行する必要があります。
  • 新しい製品を追加する。
  • 既存製品に追加のリリース、プラットフォーム、コンポーネントを追加する。
  • ルーティング ルールを一部変更して、新しい製品、コンポーネント、リリース、プラットフォームに対応できるようにする。
親トピック: Issue Manager 管理


オプション機能

いったんデータベースをセットアップし Issue Manager の利用にも慣れたら、以下のオプション機能の使用を検討してみてください。

電子メール通知

電子メール通知機能を利用すれば、Issue Manager ユーザーは、ある問題に特定のイベント、たとえば、再割り当てや状態変化が発生するたびに、電子メールが送られてくるようにすることができます。管理者は 電子メール通知ルールとシステム全体の通知 というセキュリティ権限を持っているので、電子メールが送信される状況を追加定義することができます。電子メールを受信したい状況について、ユーザーの意見を聞いてみましょう。

問題のアーカイブ化

データベースに含まれている問題が増えれば増えるほど、たとえばクエリなどのアクションの実行に時間がかかる可能性があります。全体的なパフォーマンスの向上に役立つように、Issue Manager では、組織の活動にもう関係のない問題をアーカイブ化することができます。問題をアーカイブ化すると、データベース内でそれらの問題が切り離されることになるので、たとえば、アクティブな問題に対してのみクエリを実行することができます。

親トピック: Issue Manager 管理
関連概念
電子メール通知ルールのセットアップ
関連タスク
問題のアーカイブ化


グループのセットアップ

ユーザーの組織に応じて、グループが部門全体になったり、複数の部門にまたがるプロジェクト チームや部門内チームになったりします。

各グループは、それぞれ異なるセキュリティ権限とアクセス許可を持つことができます。 また、Issue Manager グループのメンバから報告された問題がワークフローのどこで処理されるかは、そのグループによって決まります。 ユーザーが Issue Manager で行えることは所属グループによって決まり、ユーザーから報告された問題のルーティングも所属グループによって左右されます。

サンプル データベースには以下のデフォルト グループが用意されています。
  • Corporate
  • Development
  • Documentation
  • Quality Assurance
  • R&D Management
  • Technical Support

Issue Manager ユーザーはすべて、実行する作業にかかわらず、グループに割り当てられている必要があります。 ユーザーは一度に 1 つのグループにのみ所属できます。

グループのセットアップは、受信箱やユーザー アカウントをセットアップする前に行う必要があります。それぞれの受信箱やユーザーにはグループを関連付ける必要があるためです。

注: グループは、管理 > ユーザー管理 の グループ タブで作成、編集、削除を行うことができます。また、Issue Manager 固有のグループ設定は、問題 > 設定 > グループ で設定します。
  • グループのプロパティ
    Issue Manager のグループのプロパティについて説明します。
親トピック: Issue Manager 管理
関連概念
ユーザー アカウントのセットアップ


グループのプロパティ

グループには多数のプロパティがあります。 たとえばグループ名などの基本のグループ情報は、管理 > ユーザー管理 の グループ タブで指定されます。 たとえば、問題の初期情報や特定のセキュリティ権限といった Issue Manager に固有のグループ設定は 問題 > 設定 の グループ タブで指定します。

注: Issue Manager に固有のグループ設定を変更する前に、グループを作成する必要があります。
  • グループ情報
    管理ユーザー管理 でグループに設定できるプロパティを一覧表示します。
  • 問題の初期状態
    グループの問題の初期状態について説明します。
  • グループのセキュリティ設定
    グループのセキュリティ設定について説明します。
親トピック: グループのセットアップ
関連概念
ユーザー アカウントのプロパティ


グループ情報

次の表では、管理 > ユーザー管理 でグループに設定できるプロパティを一覧表示します。
プロパティ | 説明
名前 | たとえば Documentation など、グループに必須の一意の名前。 入力できるのは最大 20 文字です。
説明 | 省略可能：たとえば、「Documentation produces all technical publications, including manuals and release notes」など、グループの説明。 入力できるのは最大 80 文字です。
アカウントおよびロールの割り当て | ユーザーには、特定のロールを割り当てる必要があります。
プロジェクトの割り当て | 少なくとも 1 つのプロジェクトにグループを割り当てる必要があります。 あるグループに割り当てられているユーザーは、そのグループに割り当てられているプロジェクトにのみアクセスすることができます。
親トピック: グループのプロパティ


問題の初期状態

問題の初期状態とは、あるグループのメンバからバグ、機能拡張、あるいはドキュメントの問題が提起されたときに、それに割り当てられる最初の状態のことです。 同じタイプの問題でも、グループが異なれば初期状態も異なる可能性があります。 さらに、1 つのグループ内でも、問題の種類、バグ、機能拡張、ドキュメントの問題ごとに、初期状態が異なることがあります。

たとえば、開発者なら実際にどの部分がソフトウェア バグなのか的確に評価できるはずだと思って、Development グループのメンバから提起されたソフトウェア バグに 開発準備完了 という初期状態を割り当てる、といったことが考えられます。 一方、Corporate グループのメンバから提起されたソフトウェア バグを Development グループに送って修正してもらう前に、その問題が本当に新しいバグなのかどうかまず確かめたいので、その問題に レビュー未完了 という初期状態を割り当てる、といった場合もあるでしょう。

Issue Manager には、選択肢となる多数のデフォルト状態が用意されています。 また、組織内にグループをセットアップする前に、独自の問題の状態を作成することもできます。

問題の初期状態はグループのすべてのメンバに適用されますが、特定のユーザーについて、これらの設定を明示的にオーバーライドできます。

親トピック: グループのプロパティ
関連概念
ユーザー アカウントのセットアップ
ワークフローのカスタマイズ
問題の初期状態


グループのセキュリティ設定

セキュリティ権限は、グループ内のすべてのユーザーがどのアクティビティを実行できるかを定義するものです。ユーザー アカウントを編集することで、グループ内の特定のユーザーに追加の権限を割り当てることができますが、ユーザーの所属グループに付与されている権限を解除することはできません。

グループのセキュリティ権限を割り当てるには、問題 > 設定 > グループ の グループ設定の定義 をクリックします。チェック ボックスをオンにして、対応する権限をグループに割り当てます。グループにスーパーユーザー権限を付与するには、すべてのチェック ボックスをオンにします。

次の表では、グループ メンバが特定のカスタマイズ タスクを実行できるようにする権限を一覧表示します。
チェック ボックス | 説明
グループ、受信箱、ユーザー アカウント | セキュリティ権限を含む、グループ、受信箱、ユーザー アカウントの作成や編集
製品 | 製品、リリース、プラットフォーム、コンポーネントの作成や編集。プラットフォーム リストなどのリストを編集します。
ルーティング ルール | ある受信箱から別の受信箱に問題がどのように移動するかを、その問題の登録対象となった製品、リリース、プラットフォーム、コンポーネントに基づいて定義
GUI のカスタマイズ | 問題追跡 ページのフィールドやタブのカスタマイズ
ワークフローのカスタマイズ | 問題の状態と、アクション、アクション許可、ヘルプ テキスト、およびアクション ダイアログ ボックスの外観と使用方法を定義
電子メール通知ルールとシステム全体の通知 | 電子メール通知ルールの定義と、データベース内のすべての問題に適用される電子メール通知の追加
問題のアーカイブ化 | 選択した問題を問題およびその問題に関連するテーブルから削除し、[アーカイブ化] および [アーカイブ化] に関連するテーブルに格納
次の表では、問題および電子メール通知に影響を及ぼす権限を一覧表示します。
チェック ボックス | 説明
問題の再割り当て | 受信箱間での問題の移動
問題検証の優先設定 | 通常のルーティング ルールをオーバーライドする場合にオン
問題ごとの電子メール通知 | 個々の問題に対する電子メール通知を追加
問題の入力と編集 | 問題の入力や編集の許可
親トピック: グループのプロパティ
関連概念
ユーザー アカウントのセットアップ
ユーザーのセキュリティ設定
自動ルーティングのオーバーライド設定


受信箱のセットアップ

受信箱はメール ボックスに似ています。 特定のユーザーまたはユーザー グループに送られた (割り当てられた) 対応中でアクティブな問題はすべて受信箱に配信されます。 受信箱とユーザー アカウントを混同しないようにすることが重要です。 問題は、特定のユーザーではなく必ず受信箱に割り当てられます。

注: アーカイブ化された問題は受信箱には表示されません。

受信箱への問題のルーティング方法

Issue Manager のルーティング ルールによって、問題は自動的に適切な受信箱にディスパッチされます。 ユーザーが対処するまで (開発者がバグを修正するなど)、問題は受信箱に残っています。 対処が済むと、Issue Manager は、ワークフローとルーティング ルールに基づいて、問題を次の受信箱に自動的にディスパッチします。 最後に、問題の対応が完了すると、Issue Manager は最後の受信箱から問題を削除します。

ユーザーが 問題の再割り当て セキュリティ権限を持っている場合には、問題を手動で再割り当てして別の受信箱に送ることもできます。

受信箱が必要なユーザー

問題に対してアクションを取るユーザーには、受信箱が必要です。 開発者、QA エンジニア、テクニカル ライターなどがその例です。 バグを報告したり見たりするだけのユーザーには、受信箱は必要ありません。 顧客が発見したバグを日常的に報告はしても、バグの対処は行わない技術サポート担当者は、こちらに含まれるでしょう。

1 人のユーザーに必要な受信箱の数

1 人のユーザーが複数の受信箱を所有することができます。 たとえば、開発者は、2 つの異なる製品についてのバグ レポートを受け取るために、2 つの受信箱が必要な場合があります。 この場合、Dan - Dev (Product A) と Dan - Dev (Product B) の 2 つの受信箱をセットアップすることになることがあります。

個人の受信箱とグループの受信箱

受信箱は、個別のユーザー、ユーザーのグループ、または問題のサブセットに対してセットアップできます。 たとえば、QA エンジニアの Sarah と Mike が、異なる製品のバグ修正の検証を担当しているものとします。 このような場合は、2 つの受信箱 (Sarah - QA と Mike - QA) をセットアップすることになります。

ユーザー間で受信箱を共有することもできます。 たとえば、製品管理（PM） グループでは、1 つの受信箱にすべての機能拡張要求をまとめておき、定期的にグループ全員が集まって提案された改善を検討しているとします。 このような場合は、PM - 受信箱 といった名前の受信箱を 1 つだけセットアップすることになります。

受信箱のもう 1 つの用途は、問題のサブセットを保持する場所としてです。 たとえば、Product C について先送りされているすべての問題を含めるための受信箱を作成するとします。 このような場合は、Deferred (Product C) という名前の受信箱を作成するとよいでしょう。

ユーザーのデフォルト受信箱を割り当てる

ユーザー アカウントをセットアップする際には、受信箱をユーザー アカウントに割り当てます。 この受信箱がそのユーザーのデフォルト受信箱となります。 ユーザーが持つことのできるデフォルト受信箱は 1 つだけです。

デフォルト受信箱と他の受信箱の表示

問題 > 問題追跡 を選択すると、自分のデフォルト受信箱が表示されます。 デフォルト受信箱が表示されない場合は、ツールバーの マイ受信箱 をクリックします。

デフォルト以外の受信箱を表示するには、受信箱 リスト ボックスで別の受信箱を選択します。 どのユーザーもすべての受信箱を見ることができますが、問題に対処したり、問題を割り当て直したりできるのは、適切な権限とアクセス許可を持つユーザーだけです。

システム デフォルト ビュー

Issue Manager では、全ユーザー用に受信箱の初期デフォルト ビューが用意されています。 すべてのユーザーに対するデフォルト ビューのカスタマイズが可能です。

  • 受信箱の追加
    受信箱をユーザーに追加して、問題をそのユーザーに割り当てます。
  • 受信箱の編集
    受信箱を編集し、変更されたユーザー ロールに適用します。
  • 受信箱の削除
    問題が含まれず、ルーティング ルールで参照されていず、ユーザーのデフォルト受信箱になっていない受信箱を削除します。
  • 受信箱の初期デフォルト ビューのセットアップ
    Issue Manager の受信箱の初期デフォルト ビューをセットアップする方法について説明します。
親トピック: Issue Manager 管理
関連概念
ユーザー アカウントのセットアップ


受信箱の追加

問題に対処するすべてのユーザーそれぞれに、少なくとも 1 つの受信箱を追加する必要があります。

注: メモ： 受信箱を追加、編集、または削除するには、グループ、受信箱、ユーザー アカウント のセキュリティ権限が必要です。

受信箱を追加するには：

  1. メニューで 問題 > 設定 をクリックします。
  2. 受信箱をクリックします。 受信箱 ページが開きます。
  3. 受信箱を追加 をクリックします。 受信箱設定 ダイアログ ボックスが開きます。
  4. 受信箱の名前を 名前 フィールドに入力します。
    各受信箱には、最大 50 文字までの一意の名前が必要です。受信箱名の例を次に示します。
    • Dave (Dev)
    • PM 受信箱
    • Jesse - ドキュメント
    • Dan - Dev (製品 A)
    • Dan - Dev (製品 B)
    受信箱の名前はどのような形式でもかまいませんが、一貫した形式を保つ必要があります。形式の例を次に示します。
    • ユーザー (グループ)
    • ユーザー - グループ
    • ユーザー - グループ (製品名)
    • ユーザー
    グループ受信箱の名前も、たとえば次の例のように一貫した形式に従う必要があります。
    • グループ
    • グループ (製品名)

    特殊文字は使用できません。[受信箱] ページでは、受信箱の名前は ASCII のソート順 (大文字が先) で表示されます。

  5. グループ リスト ボックスで、この受信箱に関連付けるグループを選択します。 ユーザーは、この関連に基づいて、Issue Manager で個々の問題を割り当て直すことができます。たとえば、Documentation グループの Denise が、自分の受信箱の中のある問題を割り当て直すとします。Issue Manager が開く 問題番号 <番号> の再割り当て ダイアログ ボックスでは、デフォルトのグループとして Documentation が設定されています。これにより、Denise は、受信箱の一覧全体を探さなくても、新しい受信箱 リスト ボックスから Documentation グループの別のメンバを選択できます。
  6. 省略可能：説明 フィールドに受信箱の説明を入力します。 説明の長さには最大 80 文字まで使用できます。たとえば、開発者 David Hanson の受信箱 や 製品 B の問題用の dhart の受信箱 などです。
  7. デフォルトでは、アクティブ チェック ボックスはオンになっています。
    注: 受信箱がルーティング ルールで使用されている場合は、アクティブ チェック ボックスをオフにできません。
  8. OK をクリックして、新しい受信箱を作成します。
親トピック: 受信箱のセットアップ


受信箱の編集

注: メモ： 受信箱を追加、編集、または削除するには、グループ、受信箱、ユーザー アカウント のセキュリティ権限が必要です。

受信箱を編集するには：

  1. メニューで 問題 > 設定 をクリックします。
  2. 受信箱をクリックします。 受信箱 ページが開きます。
  3. 編集する受信箱の名前をクリックします。 受信箱設定 ダイアログ ボックスが開きます。
  4. 受信箱の名前を編集します。
  5. グループ リスト ボックスから別のグループを選択します。
  6. 受信箱の説明を編集します。
  7. アクティブ チェック ボックスをオンまたはオフにします。
    注: 受信箱がルーティング ルールで使用されている場合は、アクティブ チェック ボックスをオフにできません。
  8. OK をクリックして、変更を保存します。
親トピック: 受信箱のセットアップ


受信箱の削除

削除できるのは、問題が含まれず、ルーティング ルールで参照されていず、ユーザーのデフォルト受信箱になっていない受信箱だけです。 ルーティング ルールを編集して新しい問題が受信箱に送られないようにし、その後、受信箱にある既存の問題を割り当て直してから、受信箱を削除してください。

注: メモ： 受信箱を追加、編集、または削除するには、グループ、受信箱、ユーザー アカウント のセキュリティ権限が必要です。

受信箱を削除するには：

  1. メニューで 問題 > 設定 をクリックします。
  2. 受信箱をクリックします。 受信箱 ページが開きます。
  3. 削除する受信箱の アクション 列で、 [image] をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックしてシステムから受信箱を削除します。
親トピック: 受信箱のセットアップ
親トピック: 電子メール通知ルールのセットアップ


受信箱の初期デフォルト ビューのセットアップ

Issue Manager をインストールした時点では、受信箱の初期デフォルト ビューは、次の 8 つの列で構成されています。
  • 深刻度
  • 問題番号
  • 製品
  • コンポーネント
  • リリース
  • 概要
  • 作成者
  • 変更者
すべてのユーザーの受信箱の初期デフォルト ビューに対して、次のカスタマイズ タスクを実行できます。
  • 表示する列の追加または削除
  • 列のラベルの編集
  • 列のソート順序の変更

個々のユーザーが受信箱の初期ビューをカスタマイズできます。

  • デフォルト受信箱ビューの変更
    初期デフォルト受信箱ビューを変更して、表示される列を変更します。
親トピック: 受信箱のセットアップ


デフォルト受信箱ビューの変更

注: メモ： 受信箱を追加、編集、または削除するには、グループ、受信箱、ユーザー アカウント のセキュリティ権限が必要です。
初期デフォルト受信箱ビューを変更するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 受信箱ビュー をクリックします。 受信箱ビュー ページが開きます。このページには、選択して受信箱ビューに表示できるすべてのフィールドが表示されます。ほとんどのフィールドは、問題の詳細 ページに表示されるものです。それ以外、たとえば 履歴数、事例数、添付ファイル数、テストケース数、および 通知数 は、問題の詳細 ページにあるそれぞれ 履歴、顧客、添付情報、テストケース、および 通知 ページに項目数が示されます。また、受信箱ビューには、各列のスキーマ、つまり DB フィールド名 も表示されます。
  3. ユーザーのビュー リスト ボックスから、システム デフォルト を選択します。 他のユーザーの受信箱ビューを変更するには、対応するユーザーを代わりに選択します。
  4. 受信箱に列を追加するには、使用できるフィールド一覧 の列に対応する Select Column をクリックします。
  5. 受信箱から列を削除するには、受信箱列の一覧にある列に対応する Deselect Column をクリックします。
  6. 列のラベルおよびソート順を変更するには、次のステップを実行します。
    1. 受信箱の列のラベル にある受信箱の列の名前をクリックします。 受信箱の列のプロパティ ダイアログ ボックスが開きます。
    2. 受信箱の列のラベル フィールドに列の新しいラベルを入力します。
    3. ソート順を変更するには、該当するオプション ボタンをクリックします。
    4. OK をクリックします。
  7. 受信箱の左に列を移動するには、 Move Up をクリックします。受信箱の右に列を移動するには、 Move Down をクリックします。
  8. 受信箱を表示 をクリックして 問題追跡 ページに戻ります。
    注: システム デフォルトの受信箱ビューまたは他のユーザーのビューを変更した場合には、その変更は、対応するユーザーがログアウトし、再び戻ってきたときに適用されます。
親トピック: 受信箱の初期デフォルト ビューのセットアップ


ユーザー アカウントのセットアップ

ユーザー アカウントとは、特定のユーザーに関する情報を集めたものです。 各ユーザーはグループに割り当てられます。 また、問題に対処するユーザーの場合は受信箱にも割り当てられます。 ユーザー アカウントはパスワードで保護できます。 問題を報告したり、問題に対処したり、単に閲覧したりするためには、システムにログインするすべてのユーザーに、ユーザー アカウントが必要です。

注: 管理 > ユーザー管理 の アカウント タブで、ユーザー アカウントを作成、編集、または削除できます。

ユーザーは、そのグループのセキュリティ権限と問題の初期状態を継承します。 個別のユーザーについて、権限を追加したり、問題の初期状態を変更したりするには、ユーザーのアカウントを編集する必要があります。 これらを設定するには、問題 > 設定 の ユーザー アカウント タブを使用します。

注: ユーザー アカウントをセットアップする前に、グループと受信箱をセットアップしておく必要があります。
  • ユーザー アカウントのプロパティ
    ユーザー アカウントの、問題に関連するプロパティについて説明します。
  • 問題の初期状態
    ユーザーの問題の初期状態について説明します。
  • ユーザーのセキュリティ設定
    ユーザー アカウントのセキュリティ設定について説明します。
  • ユーザー アカウントの編集
    ユーザー アカウントを編集し、ユーザーのセキュリティ権限を変更します。
親トピック: Issue Manager 管理
関連概念
日常的な管理作業


ユーザー アカウントのプロパティ

ユーザー アカウントの、問題に関連するプロパティは、問題 > 設定 の ユーザー アカウント タブで指定します。

注: 問題に関連するアカウント プロパティを表示または編集する前に、ユーザー アカウントを作成する必要があります。

ユーザー アカウント タブのユーザー名をクリックし、問題に関連するアカウント プロパティを編集します。

以下の表には、問題に関連するアカウント プロパティが一覧されています。
プロパティ | 説明
ログイン | 必須のユーザー固有ログイン名。 入力できるのは最大 30 文字です。 特殊文字は使用できません。 注: Issue Manager ではログイン名を編集できません。
受信箱 | ユーザーのデフォルトの受信箱。 受信箱 リスト ボックスから、ユーザーの代わりのデフォルト受信箱を選択できます。
グループの設定 | 必須。 このユーザーが属するグループ。 グループの設定 リスト ボックスからグループを選択すると、Issue Manager は自動的に問題の初期状態とセキュリティ設定に関するグループのデフォルト値を、そのユーザーに割り当てます。
親トピック: ユーザー アカウントのセットアップ
関連概念
グループのプロパティ


問題の初期状態

問題の初期状態は、ユーザーから提出されたバグ、機能拡張、またはドキュメントの問題に最初に割り当てられる状態です。 デフォルト値は、グループのデフォルト、つまりユーザーが属するグループに割り当てられている値です。

あるユーザーの技術的能力が特に高い場合などには、ユーザー アカウントについて問題の初期状態のデフォルトを変更することができます。 たとえば、非技術系のマネージャのグループで、1 人のマネージャが明らかに技術系であるような場合です。 このようなユーザーの入力する問題は、Issue Manager でワークフローのもっと先の状態に取り込むことができます。

親トピック: ユーザー アカウントのセットアップ
関連概念
問題の初期状態


ユーザーのセキュリティ設定

セキュリティ権限では、このユーザーが実行できるアクティビティを定義します。ユーザーのデフォルトのセキュリティ権限は、そのユーザーが属するグループのセキュリティ権限です。ユーザー アカウントを編集することで、グループ内の特定のユーザーに追加の権限を割り当てることができますが、ユーザーの所属グループに付与されている権限を解除することはできません。デフォルトで認められているセキュリティ権限は、読み取り専用になっています。

ユーザー アカウントにセキュリティ権限を割り当てるには、問題 > 設定 > ユーザー アカウント のユーザー名をクリックします。該当するチェック ボックスをオンにして、対応する権限をユーザーに割り当てます。

次の表では、ユーザーが特定のカスタマイズ タスクを実行できるようにする権限を一覧表示します。
チェック ボックス | 説明
グループ、受信箱、ユーザー アカウント | セキュリティ権限を含む、グループ、受信箱、ユーザー アカウントの作成や編集
製品 | 製品、リリース、プラットフォーム、コンポーネントの作成や編集。プラットフォーム リストなどのリストを編集します。
ルーティング ルール | ある受信箱から別の受信箱に問題がどのように移動するかを、その問題の登録対象となった製品、リリース、プラットフォーム、コンポーネントに基づいて定義
GUI のカスタマイズ | 問題追跡 ページのフィールドやタブのカスタマイズ
ワークフローのカスタマイズ | 問題の状態と、アクション、アクション許可、ヘルプ テキスト、およびアクション ダイアログ ボックスの外観と使用方法を定義
電子メール通知ルールとシステム全体の通知 | 電子メール通知ルールの定義と、データベース内のすべての問題に適用される電子メール通知の追加
問題のアーカイブ化 | 選択した問題を問題およびその問題に関連するテーブルから削除し、[アーカイブ化] および [アーカイブ化] に関連するテーブルに格納
次の表では、問題および電子メール通知に影響を及ぼす権限を一覧表示します。
チェック ボックス | 説明
問題の再割り当て | 受信箱間での問題の移動
問題検証の優先設定 | 通常のルーティング ルールをオーバーライドする場合にオン
問題ごとの電子メール通知 | 個々の問題に対する電子メール通知を追加
問題の入力と編集 | 問題の入力や編集の許可
親トピック: ユーザー アカウントのセットアップ
関連概念
グループのセキュリティ設定


ユーザー アカウントの編集

注: ユーザー アカウントを編集するには、グループ、受信箱、ユーザー アカウント のセキュリティ権限が必要です。
セキュリティ権限およびユーザー アカウントの問題の初期状態を編集します。
  1. メニューで 問題 > 設定 をクリックします。
  2. ユーザー アカウント をクリックします。 ユーザー アカウント ページが開きます。
  3. セキュリティ権限を編集するユーザーの名前をクリックします。 ユーザーの設定 ダイアログ ボックスが開きます。
  4. ユーザーのセキュリティ権限および問題の初期状態を変更します。
  5. 変更を保存する場合は、OK をクリックします。 変更を行わないで終了する場合は、キャンセル をクリックします。
親トピック: ユーザー アカウントのセットアップ
関連概念
ユーザーのセキュリティ設定
問題の初期状態


製品設定を定義する

特定の製品の問題の追跡以外にも、Issue Manager では次の問題を追跡します。
  • 製品の特定のバージョン
  • 製品バージョンの対象となる特定のプラットフォーム
  • 特定の製品コンポーネント

多くの場合、特定のアプリケーションのコードは、製品チームの複数の担当者が作成します。Issue Manager では、製品およびコンポーネントを特定の受信箱にリンクすることができます。さらに、Issue Manager は製品、コンポーネント、リリースおよびプラットフォームに基づいて、新しい問題を適切な開発者に自動的に割り当てます。

注: Silk Central の 管理 ユニットでは、製品、コンポーネント、バージョン、ビルド、プラットフォームを作成および編集できます。Issue Manager で設定できるプロパティは、製品受信箱の設定のみです。
製品とコンポーネントを区別する方法は管理者が決定します。ある組織では別の組織のコンポーネントとして製品を定義することがあります。次の基本的な定義が便利です。
製品
製品とは、同梱されていることがある他のソフトウェアとは独立して動作可能な 1 つのソフトウェアのことです。必要に応じて個別に販売することができます。製品では、実行可能プログラムはコード ベースと区別されます。製品は複数のコンポーネントで構成される場合があります。
コンポーネント
コンポーネントとは、製品の機能領域のことです。コンポーネントは個別に購入することができず、ユーザーには個別の製品とは認識されません。製品には、1 つ以上のコンポーネントが関連付けられている場合があります。
リリース
リリースとは、特定の製品の特定のバージョンやソフトウェア ビルドのことです。リリースは、組織内の開発ビルドの場合もあれば、顧客に出荷されたビルドの場合もあります。製品には、複数のリリースが関連付けられている場合があります。製品の特定のリリースは、複数のプラットフォームで利用できる場合があります。
プラットフォーム
プラットフォームは、製品が実行される環境のことです。プラットフォームは、次の要素のいずれかの組み合わせで構成されます。
  • ハードウェア。
  • オペレーティング システム (Microsoft Windows など)。
  • オペレーティング システム リリース (8.1 など)。
製品、リリース、プラットフォーム、コンポーネントの値として定義されているものの多くは、製品 ページ (問題 > 設定 > 製品) に表示されます。
  • プロジェクトの受信箱設定を定義する
    具体的なプロジェクトの受信箱設定を定義し、受信箱にどの問題を送るのかを設定します。
  • 製品の削除
    Issue Manager で製品を削除し、選択したプロジェクトからデタッチします。
親トピック: Issue Manager 管理
関連概念
ルーティング ルールのセットアップ


プロジェクトの受信箱設定を定義する

具体的な製品の受信箱設定を Issue Manager で定義するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 製品 をクリックします。 製品 ページが開きます。
  3. 製品設定の定義 をクリックします。 製品設定 ダイアログ ボックスが開きます。
  4. 製品 リスト ボックスから、受信箱設定を定義する製品を選択します。
    注: プロジェクトで扱われている問題に既に割り当てられている製品の名前を 製品 ページでクリックすることで、このステップを省略できます。
  5. QA 用受信箱 リスト ボックスから、品質管理グループに割り当てられ与えられた製品に関して定義されている問題の送り先となる定義済み受信箱を選択します。
  6. 開発用受信箱 リスト ボックスから、開発グループに割り当てられ与えられた製品に関して定義されている問題の送り先となる定義済み受信箱を選択します。
  7. 機能拡張用受信箱 リスト ボックスから、機能拡張要求に該当し与えられた製品に関して定義されている問題の送り先となる定義済み受信箱を選択します。
  8. ドキュメント用受信箱 リスト ボックスから、ドキュメントに割り当てられ、現在の製品に関して定義されている問題の送り先となる定義済み受信箱を選択します。
  9. OK をクリックします。
親トピック: 製品設定を定義する


製品の削除

Issue Manager で製品を削除しても、実際にリポジトリから製品が削除されるわけではなく、選択されたプロジェクトから製品が切り離されます。 その結果、Issue Manager からその製品にはアクセスできなくなります。
注: 製品を削除できるのは、その特定の製品について入力されている問題がない場合だけです。

アクティブ プロジェクトから製品を削除するには：

  1. メニューで 問題 > 設定 をクリックします。
  2. 製品 をクリックします。 製品 ページが開きます。
  3. 削除する製品の アクション 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックして、削除を完了します。
親トピック: 製品設定を定義する


ルーティング ルールのセットアップ

Issue Manager では、定義済みのルーティング ルール、各問題の現在の状態、および対応する状態所有者に基づいて、問題のライフサイクルにおける問題の送信先となる受信箱を決定します。 この高度なルーティング メカニズムにより、面倒な作業であった問題のディスパッチを代行できます。

問題の状態とは、その問題の現況です。 Issue Manager のデフォルト ワークフローには多数の状態が用意されています。 状態の所有者とは組織内のロールの 1 つで、与えられた状態にある問題の対処を担当する人のことです。

次に、デフォルト ワークフローの問題の状態と所有者の例を示します。
レビュー未完了
この問題が本当にバグやドキュメントの誤りなのかどうかを誰かが決定する必要があります。 通常、この状態は QA エンジニアが所有します。
開発準備完了
いつでもコードの作成に取りかかることができます。 この状態は通常、開発者が所有します。
QA 準備完了
バグが本当に修正されているかどうかを誰かが確かめる必要があります。 通常、この状態は QA エンジニアが所有します。

問題を誰が提起するかによって、同じタイプの異なる問題を異なる状態でワークフローに入れることができます。 ルーティングはそれに応じて変わります。 たとえば、開発者によって提起された問題は開発準備完了の状態でワークフローに入るため、開発者の受信箱に送られます。 一方、社内ユーザーによって提起された問題はレビュー未完了の状態でワークフローに入るため、QA エンジニアの受信箱に送られます。 いわゆる問題の初期状態は、グループ設定を通じて割り当てられます。

ユーザーが問題に対してアクションを取ると、その問題はワークフローの中である状態から次の状態に移行します。 たとえば、報告されたままでまだレビューされていない問題が確かにバグであると QA エンジニアが確認すると、その問題はレビュー未完了の状態から開発準備完了の状態に移行します。 ここでルーティング ロジックを用いる主な目的は、問題がバグであるといったん QA エンジニアが判断すると、その問題が自動的にそのエンジニアの受信箱から適切な開発者の受信箱に必ず移動するようにすることです。

  • ルーティング ルール
    問題のルーティングが基づくルールについて説明します。
  • ルールの指定
    ルーティング ルールを指定する方法について説明します。
  • ルーティング ルールの追加
    ルーティング ルールを追加して、問題の分配方法を定義します。
  • ルーティング ルールを編集する
    既存のルーティング ルールを編集し、問題の分配方法を変更します。
  • ルーティング ルールを削除する
    ルーティング ルールを削除して、問題の分配方法を変更します。
  • ルーティング ルールの順序変更
    ルーティング ルールの順序を変更し、順序を変えます。
  • 自動ルーティングのオーバーライド設定
    組織における問題検証の通常ルーティングを、個々のユーザーやグループ全体でオーバーライドできるようにする方法を説明します。
親トピック: Issue Manager 管理
関連概念
ワークフローのカスタマイズ
グループのセットアップ


ルーティング ルール

問題のルーティングは、製品およびそれに関連するリリース、プラットフォーム、コンポーネントについて定義されるルールに基づいて行われます。 このルールベースのメカニズムにより、問題の割り当てをきめ細かく制御できます。これは、問題のルーティングが 1 つには次の基準の組み合わせに基づいて行われるためです。
  • 製品
  • コンポーネント
  • リリース
  • プラットフォーム
  • 問題の状態
  • 状態の所有者
基準セットごとに次の 4 つの受信箱を割り当てる必要があります。
  • 問題の検証を担当する受信箱。通常は QA 用受信箱。
  • 問題の修正を担当する受信箱。通常は開発用受信箱。
  • ドキュメントに関する問題の処理を担当する受信箱。通常はドキュメント用受信箱。
  • 機能拡張要求を担当する受信箱。通常は機能拡張用受信箱。

例

Product A に関するバグのうち、Installer コンポーネントに関係し Motif プラットフォームに関連するものはすべて、ある受信箱群に送ることができるのに対して、Windows プラットフォーム用の Installer コンポーネントに関係する Product A のバグはすべて別の受信箱群に送ることができます。

デフォルト ルーティング

細かいルーティング ルールだけでなく、Issue Manager では、製品全体を対象とする 1 つのルーティング ルール、すなわち、デフォルト ルーティングを定義する必要があります。 デフォルト ルーティングでは、特定製品のすべてのコンポーネント、リリース、プラットフォームについての問題が、指定された受信箱群 (4 つの受信箱から成る) に送られます。

各受信箱は次の領域のいずれかをカバーします。
  • QA
  • 開発
  • ドキュメント
  • 機能拡張要求
たとえば、Product X のすべての機能拡張要求は、個々のコンポーネント、プラットフォーム、リリースに関係なく、割り当てられた 1 つの機能拡張用受信箱に送られます。

Issue Manager では、他のルーティング ルールが存在しないか適用できない場合にのみ、デフォルト ルーティング ルールを使用します。 つまり、デフォルト ルーティング ルールは特定のルールが当てはまらないか指定されていない場合にのみ適用されます。

デフォルト ルーティングは、Issue Manager 製品のセットアップ時に設定されます。

組織のプロセスを分析する

組織における作業の詳細を分析します。 製品、リリース、プラットフォームのリストを見直し、今度はそのリストに照らして各コンポーネントを検討します。 次の質問を検討してみます。

このプラットフォーム上のこのリリースに含まれるこのコンポーネントについては、誰 (すなわち、どの受信箱) が各アクション (たとえば、検証、修正など) を担当するのか?
その後、次の 4 つの基準のさまざまな組み合わせに必要なだけルールを定義します。
  • 製品
  • リリース
  • プラットフォーム
  • コンポーネント
親トピック: ルーティング ルールのセットアップ
関連タスク
ルーティング ルールの追加
ルーティング ルールを編集する


ルールの指定

各ルールは、問題 > 設定 > ルーティング ルール にある ルーティング ルール ページに入力します。

注: ルーティング ルールの新規作成 ダイアログ ボックスは if-then 形式のレイアウトです。 問題が特定の条件に一致した場合、つまり、特定のリリース、プラットフォーム、コンポーネント、問題タイプに関係している場合、指定した 4 つの受信箱のいずれかに送られます。 4 つの受信箱のどれが選ばれるかは、問題の現在の状態と所有者によって決まります。

ワイルドカード % 記号

ルーティング ルールの新規作成 ダイアログ ボックスの リリース、プラットフォーム、および コンポーネント フィールドのパーセント記号 (%) は、すべての文字に一致するワイルドカード文字の役割になります。 3 つのフィールド全部でこのパーセント記号を単独で使用した場合、デフォルト ルーティングと同じことになります。 すなわち、リリース、プラットフォーム、コンポーネントの値にかかわらず、すべて、このダイアログ ボックスで指定されている 4 つの受信箱に送られます。

ヒント: ワイルドカード指定を活用するには、リリース名、コンポーネント名、プラットフォーム名を、一貫性を保ちながら指定する必要があります。

ルールは、いったん保存されると、[ルーティング ルール] ページに入力されます。 このページは基本的に、特定の製品のルーティング テーブルです。 別の製品を選択するには、ページ最上部の 製品 リスト ボックスを使用します。

ルールの順序が重要

コンポーネントのルールの順序はきわめて重要です。 Issue Manager では、問題のルーティングに当たって、問題の現在の状態 (たとえば、[レビュー未完了] など) をテーブル内の各ルールに順に照らして評価します。 一致するルールが見つかったら、それが Issue Manager によって実行されます。 一致するルールがなければ、デフォルト ルールに従って問題がルーティングされます。 デフォルト ルーティング ルールは、与えられた製品についての他のすべてのルールが適用された後でのみ適用されます。

例

リリース フィールドに「Release 4.%」と入力すると、4.0、4.1、4.1.1 などのすべての Release 4 リリースに一致します。

例：ルーティング ルールの読み方

たとえば、すべてのリリースとすべてのプラットフォームでの Product A に関係する問題は、それが開発準備完了の状態にある場合は Sonja - Dev の受信箱に、QA 準備完了の状態にある場合は QA エンジニアである Mike の受信箱 Mike - QA に、機能拡張要求が提出された場合は Product A の機能拡張要求用受信箱 Dan -- Dev (Product A) に、Show me コンポーネントのドキュメントに関する問題が報告された場合は Judy -Doc の受信箱にそれぞれ送ります。

親トピック: ルーティング ルールのセットアップ
関連概念
状態の所有者


ルーティング ルールの追加

ルーティング ルールを追加するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 製品 をクリックします。 製品 ページが開きます。
  3. 製品 リスト ボックスから、ルーティング ルールを設定する製品を選択します。
  4. ルーティング ルールの新規作成 をクリックします。 ルーティング ルールの新規作成 ダイアログ ボックスが開きます。
  5. 該当するラジオ ボタンを選択して、問題が バグ または 機能拡張 (SOFT) であるか ドキュメントの問題 (DOC) であるかを指定します。
  6. 定義済みリリースを リリース リスト ボックスから選択します。または、定義済みリリースを 特定のマッチコード フィールドに入力します。あらゆるリリースを考慮しなければならない場合は、何も選択しません。つまり、破線を選択します。
  7. プラットフォーム リスト ボックスから定義済みプラットフォームを選択します。または、定義済みプラットフォームを 特定のマッチコード フィールドに入力します。あらゆるリリースを考慮しなければならない場合は、何も選択しません。つまり、破線を選択します。
  8. コンポーネント リスト ボックスから定義済みコンポーネントを選択します。または、定義済みコンポーネントを 特定のマッチコード フィールドに入力します。あらゆるリリースを考慮しなければならない場合は、何も選択しません。つまり、破線を選択します。
    注: リリース、プラットフォーム、コンポーネントの少なくとも 1 つについて値を選択する必要があります。どれも選択しない場合、新しいルーティング ルールはデフォルト ルールと同じルールになります。
  9. ダイアログ ボックスの 以下の受信箱にルーティングする 領域で、次の 4 つの受信箱カテゴリのそれぞれについて、定義済みの受信箱を選択します。
    • QA 用受信箱
    • 開発用受信箱
    • 機能拡張用受信箱
    • ドキュメント用受信箱
  10. OK をクリックします。 ルールが保存され、ルーティング テーブルに追加されます。
    注: ルーティング テーブルに変更を加えた場合、Issue Manager はルーティング ルールを保存し再設定しますが、それに多少時間がかかる場合があります。
親トピック: ルーティング ルールのセットアップ


ルーティング ルールを編集する

既存のルーティング ルールを編集するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 製品 をクリックします。 製品 ページが開きます。
  3. 製品 リスト ボックスから、ルーティング ルールを設定する製品を選択します。
  4. 編集するルールの アクション 列で、 Edit Routing Rule をクリックします。 ルーティング ルールの編集 ダイアログ ボックスが開きます。
  5. 該当するラジオ ボタンを選択して、問題が バグ または 機能拡張 (SOFT) であるか ドキュメントの問題 (DOC) であるかを指定します。
  6. 定義済みリリースを リリース リスト ボックスから選択します。または、定義済みリリースを 特定のマッチコード フィールドに入力します。あらゆるリリースを考慮しなければならない場合は、何も選択しません。つまり、破線を選択します。
  7. プラットフォーム リスト ボックスから定義済みプラットフォームを選択します。または、定義済みプラットフォームを 特定のマッチコード フィールドに入力します。あらゆるリリースを考慮しなければならない場合は、何も選択しません。つまり、破線を選択します。
  8. コンポーネント リスト ボックスから定義済みコンポーネントを選択します。または、定義済みコンポーネントを 特定のマッチコード フィールドに入力します。あらゆるリリースを考慮しなければならない場合は、何も選択しません。つまり、破線を選択します。
    注: リリース、プラットフォーム、コンポーネントの少なくとも 1 つについて値を選択する必要があります。どれも選択しない場合、新しいルーティング ルールはデフォルト ルールと同じルールになります。
  9. ダイアログ ボックスの 以下の受信箱にルーティングする 領域で、次の 4 つの受信箱カテゴリのそれぞれについて、定義済みの受信箱を選択します。
    • QA 用受信箱
    • 開発用受信箱
    • 機能拡張用受信箱
    • ドキュメント用受信箱
  10. OK をクリックします。 ルールが保存され、ルーティング テーブルに追加されます。
    注: ルーティング テーブルに変更を加えた場合、Issue Manager はルーティング ルールを保存し再設定しますが、それに多少時間がかかる場合があります。
親トピック: ルーティング ルールのセットアップ


ルーティング ルールを削除する

既存のルーティング ルールを削除するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 製品 をクリックします。 製品 ページが開きます。
  3. 製品 リスト ボックスから、ルーティング ルールを設定する製品を選択します。
  4. 削除するルールの アクション 列で、 ルーティング ルールの削除 をクリックします。 ルーティング ルールの削除 確認ダイアログ ボックスが開きます。
  5. はい をクリックして、削除を完了します。
親トピック: ルーティング ルールのセットアップ


ルーティング ルールの順序変更

ルーティング ルールの順序を変更するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 製品 をクリックします。 製品 ページが開きます。
  3. 製品 リスト ボックスから、ルーティング ルールを設定する製品を選択します。
  4. 順序を変更するルールの アクション 列で、次のいずれかをクリックします。
    • リスト内でルールを上に移動するには 上へ移動 をクリックします。
    • リスト内でルールを下に移動するには [image] をクリックします。
親トピック: ルーティング ルールのセットアップ


自動ルーティングのオーバーライド設定

組織で通常使用される問題検証用のルーティングを、個々のユーザーやグループ全体でオーバーライドできるようにすることが可能です。 たとえば、報告した問題が修正されたかどうかをユーザーが確かめたい場合もあるでしょう。

このようなオーバーライドを許可するには、問題検証の優先設定 権限をユーザーまたはグループに割り当てます。 このセキュリティ権限があれば、ユーザーは 問題 > 設定 > 優先設定 から、以下の 3 つの戦略のいずれかを選択できます。
戦略
説明
常に標準のルーティングを使用する
検証用の標準ルーティング。 問題は適切な QA 用受信箱に送られます。
常に自分の問題を検証する
Issue Manager により、ユーザーが提起した問題が通常の QA 用受信箱ではなく、ユーザー自身の受信箱に送られて検証されるように指定します。
新規の問題ごとに指定する
Issue Manager により、問題が報告されるたびに、通常のルーティングをオーバーライドするオプションがユーザーに提示されるように指定します。

再割り当てによる自動ルーティングのオーバーライド

問題の再割り当ては、自動ルーティング メカニズムをオーバーライドする手動ルーティングの手段の 1 つです。 ユーザーは明示的に再割り当てアクションを取って、問題を別のユーザー (通常は同じグループ内のユーザー) の受信箱に送ることができます。 たとえば、開発者 Bill はこれから休暇を取るので、開発準備完了状態のバグを同僚の開発者 Dan に再割り当てするといった場合です。 このバグは開発準備完了状態のままですが、再割り当てされています。

再割り当てされた問題がワークフローにおける以前の状態に戻ったとき (たとえば、Dan がバグ修正を却下した場合など)、Issue Manager はその再割り当てを記憶しておき、後でその問題が当初送られた受信箱 (この場合は Bill の受信箱) ではなく、手動で送られた受信箱 (この場合は Dan の受信箱) に問題を戻します。

例

再割り当てがいかに効率的に動作するかを理解するために、ある例について考えます。 この例では、バグが 2 回 ([開発準備完了] 状態のときに 1 回、[QA 準備完了] 状態のときに 1 回) 再割り当てされ、QA エンジニアがバグ修正を却下して、バグをワークフローにおける以前の状態に戻します。
  1. 新しいバグが [開発準備完了] 状態でワークフローに入ります。 ルーティング ルールにより、このバグが開発者 Bill の受信箱に自動的に送られます。
  2. Bill は、このバグを開発者 Dan の受信箱に再割り当てします。
  3. Dan はこのバグを修正した主張し、その結果、バグが [QA 準備完了] 状態に移行します。
  4. ルーティング ルールにより、このバグが QA エンジニア Mike の受信箱に自動的に送られて検証を受けます。
  5. Mike は、このバグを同僚の Sarah の受信箱に再割り当てします。
  6. Sarah は修正結果を却下し、その結果、バグが [開発準備完了] 状態に戻ります。
  7. Issue Manager は、この [開発準備完了] 状態のバグを Dan の受信箱に送り返します。 その状態のバグを最後に処理した開発者は Dan だからです。
  8. Dan はこのバグを再度修正し、[QA 準備完了] 状態に戻します。
  9. Issue Manager は、この [QA 準備完了] 状態のバグを Sarah の受信箱に送り返します。 その状態のバグを最後に処理した QA エンジニア開発者は Sarah だからです。

機能強化されたルーティングがなければ、[開発準備完了] 状態の問題 (ステップ 7) は Bill の受信箱に送られ、そのあと Bill が問題を再度 Dan に再割り当てしているでしょう。 同様に、[QA 準備完了] 状態の問題 (ステップ 9) は Mike の受信箱に送られ、そのあと Mike が問題を再度 Sarah に再割り当てしていることでしょう。

親トピック: ルーティング ルールのセットアップ
関連概念
グループのセキュリティ設定


問題の詳細ページのカスタマイズ

Issue Manager では、問題の新規作成 ページおよび既存の 問題の詳細 ページの外観と動作を変更できます。たとえば、フィールド ラベルをもっと組織に適した表現に変更できます (たとえば、リリースではなくビルドなど)。

問題の詳細 ページのラベルに対する変更は、 Issue Managerの カスタマイズ を通して呼び出される他のほとんどのページとダイアログ ボックスに反映されます。

Issue Manager では、問題の詳細 ページに対して次の変更を行うことができます。
  • 問題に関する基本的な情報を指定するフィールドのラベルを編集し、プロパティを変更します。たとえば、ラベル [概要] を [ようやく] に変更できます。
  • 自動フィールド 領域のフィールドのラベルを編集します。
  • タブのラベルを編集します。
  • [カスタム タブ 1] および [カスタム タブ 2] のフィールドを定義します。これらのフィールドを変更または削除したり、独自のフィールドを追加したりできます。デフォルトでは、[カスタム タブ 1] には 4 つのフィールドが含まれます。
次の表では、問題の標準フィールド ラベルおよび問題の標準フィールド内容のカスタマイズに関する情報の参照先を示します。
名前 | フィールドのラベルの編集 | フィールドのプロパティのカスタマイズ
問題の種類 | フィールドとタブ ラベルをカスタマイズする | 可能。
製品 | フィールドとタブ ラベルをカスタマイズする | 可能。「製品を編集する」を参照。
リリース | フィールドとタブ ラベルをカスタマイズする | 可能。「バージョンを編集する」を参照。
プラットフォーム | フィールドとタブ ラベルをカスタマイズする | 可能。「プラットフォームを編集する」を参照。
コンポーネント | フィールドとタブ ラベルをカスタマイズする | 可能。「コンポーネントを編集する」を参照。
深刻度 | フィールドとタブ ラベルをカスタマイズする | 可能。
概要 | フィールドとタブ ラベルをカスタマイズする | 不可能。 ユーザーが概要を入力します。
問題番号 | フィールドとタブ ラベルをカスタマイズする | 不可能。問題番号はカスタマイズできません。
割り当て先 | フィールドとタブ ラベルをカスタマイズする | 可能。「ルーティング ルール」を参照。
状態 | フィールドとタブ ラベルをカスタマイズする | 可能。「ワークフローの状態のカスタマイズ」を参照。
理由コード | フィールドとタブ ラベルをカスタマイズする | 可能。「理由コード」を参照。
アクション リリース | アクションのプロパティ | 可能。
次の表では、タブ ラベルおよびタブのフィールドのカスタマイズに関する情報の参照先を示します。
名前 | タブのラベルの編集 | タブのフィールドをカスタマイズするか ?
説明 | フィールドとタブ ラベルをカスタマイズする | 不可能。 ユーザーが説明タブを入力します。
履歴 | フィールドとタブ ラベルをカスタマイズする | 不可能。 Issue Manager が 履歴 タブを設定します。 ただし、アクション 列はカスタマイズできます。「現在の状態に関する情報」を参照。
顧客 | フィールドとタブ ラベルをカスタマイズする | 不可能。 ユーザーは定義済みの顧客の追加アクションを実行できます。
カスタム タブ | カスタム タブを作成する | 可能。「カスタム フィールドを編集する」を参照。
  • フィールドとタブ ラベルをカスタマイズする
    問題の標準のフィールド、タブ ラベル、自動フィールドをカスタマイズする方法について説明します。
  • GUI のカスタマイズのプロパティ
    問題の詳細 ページのフィールドの外観と使用を決定するプロパティを一覧表示します。
  • カスタム タブとフィールド
    Issue Manager のカスタム タブとフィールドについて説明します。
親トピック: Issue Manager 管理
関連概念
ルーティング ルール
理由コード
アクションのプロパティ
現在の状態に関する情報
カスタム タブとフィールド
[アクションのユーザー定義フィールド] タブ
関連タスク
ワークフローの状態のカスタマイズ
製品を編集する
バージョンを編集する
プラットフォームを編集する
コンポーネントを編集する


フィールドとタブ ラベルをカスタマイズする

注: このトピックで説明しているアクションを実行するには、GUI customization 権限が必要です。
このトピックでは、問題の標準のフィールド、タブ ラベル、および自動フィールドをカスタマイズする方法について説明します。ただし、アクション リリース フィールドは除きます アクション リリース フィールドのカスタマイズについては、「[アクションの標準フィールド] タブ」を参照してください。 これらのフィールドを削除したり、フィールドを追加したりすることはできません。 ただし、フィールドのプロパティは変更可能です。 たとえば、ラベルの編集、モードの選択、フィールドの入力または変更のアクセス許可を持つグループの制限などを行うことができます。

問題の標準のフィールドとタブ ラベルを変更するには：

  1. メニューで 問題 > 設定 をクリックします。
  2. 問題の標準フィールド をクリックします。 問題の標準フィールド ページが開きます。
    注: 問題の標準フィールド ページは、問題の詳細 ページと同じようにレイアウトされています。
  3. タブ ラベルの名前を変更する場合は、次のアクションを実行します。
    1. 編集するタブのリンクをクリックします。 ラベルの編集 ダイアログ ボックスが開きます。
    2. 必要に応じてタブの名前を変更します。
    3. OK をクリックします。
  4. フィールドのプロパティを編集する場合は、次のアクションを実行します。
    1. 編集するフィールドのリンクをクリックします。 フィールドのプロパティの編集 ダイアログが開きます。
    2. 必要に応じてフィールドのプロパティを変更します。
    3. OK をクリックします。
親トピック: 問題の詳細ページのカスタマイズ
関連資料
[アクションの標準フィールド] タブ
GUI のカスタマイズのプロパティ


GUI のカスタマイズのプロパティ

問題の詳細 ページのフィールドには、外観と使用方法を決定するプロパティがあります。たとえば、プロパティは、フィールドがチェック ボックスなのかテキスト フィールドなのかなど、フィールドのラベルとコントロールの種類を指定します。フィールドのプロパティの編集 ダイアログ ボックスで、フィールドのプロパティを表示して編集できます。フィールドのプロパティの編集 ダイアログ ボックスにアクセスするには、問題 > 設定 > 問題のカスタム タブ または 問題 > 設定 > カスタム フィールド プール にある、編集するフィールドのリンクをクリックします。
次のプロパティを変更できます。
プロパティ
説明
ラベル
フィールド ラベルのテキスト（20 文字以下）。ラベルとそれに関連する内容を区切る場合は、コロンを追加します。特殊文字は使用できません。
コントロールの種類
ユーザー定義フィールドを作成しているときにのみ有効。コントロールの種類は、チェック ボックス、日付、テキスト フィールド、または ポップアップ リスト です。
大文字/小文字の指定
コントロールの種類が テキスト フィールド のときにのみ有効。ユーザーがテキスト フィールドに入力する文字の大小を決定します。指定できる値は、大文字、小文字、および なし です。
リスト名
ユーザー定義のポップアップ リストに対してのみ有効。このポップアップ リストの値を定義するカスタム リストの名前を選択します。
新しい問題またはアクション - モード
ユーザーが新しい問題をレポートするときのフィールドの役割を説明します。
値 | 説明
必須 | 値が必要です。
省略可能 | 値を指定しても、ブランクでもかまいません。
読み取り専用 | 編集できません。
新しい問題またはアクション - グループのアクセス許可
モードが 必須 または 省略可能 のときに有効。アクセス許可は、このフィールドに値を入力できるグループを定義します。
  • すべて は、すべてのグループにアクセス許可を与えます。
  • 選択 は、リスト ボックスから選択したグループだけにアクセス許可を与えます。フィールドが [必須] または [省略可能] で、アクセス許可を選択したグループに制限すると、他のすべてのグループにはそのフィールドは読み取り専用になります。
既存の問題またはアクション - モード
ユーザーが既存の問題を編集するときのフィールドの役割を説明します。
値 | 説明
必須 | 値が必要です。
省略可能 | 値を指定しても、ブランクでもかまいません。
読み取り専用 | 編集できません。
ヒント: チェック ボックスは必須フィールドにはできません。フィールドを必須にする必要がある場合は、反対の意味の 2 つの値 (はい と いいえ など) を持つポップアップ リストを定義してみてください。
既存の問題またはアクション - グループのアクセス許可
モードが 必須 または 省略可能 のときに有効。アクセス許可は、このフィールドに値を入力できるグループを定義します。
  • すべて は、すべてのグループにアクセス許可を与えます。
  • 選択 は、リスト ボックスから選択したグループだけにアクセス許可を与えます。フィールドが [必須] または [省略可能] で、アクセス許可を選択したグループに制限すると、他のすべてのグループにはそのフィールドは読み取り専用になります。
入力された最後の問題の値を記憶する
このチェック ボックスをオンにすると、問題の詳細 ページには最後に選択されていた問題が表示されます。たとえば、製品 フィールドに対してこのチェック ボックスをオンにするとします。問題を報告するユーザーが最初に 製品 ドロップダウン リストから値 (たとえば QA パートナー) を選択すると、その値が記憶されて、次にユーザーが問題を報告するときには 製品 フィールドにデフォルトで QA パートナーが表示されます。
親トピック: 問題の詳細ページのカスタマイズ


カスタム タブとフィールド

Issue Manager では、カスタム タブ ごとにそれぞれに最大 10 個のユーザー定義フィールドを定義できます。

カスタム タブ

問題の詳細 ページの カスタム タブ 1 には、デフォルトで 3 つのフィールドがあります。このタブにフィールドを追加したり、デフォルトのフィールドを編集したり、フィールドを削除して何もない状態から始めたりできます。

次の表では、カスタム タブ 1 のデフォルト フィールドについて説明します。
フィールド | 内容 | モード | コントロールの種類/値
自動? | 問題が回帰テストで自動か手動かを示します。 | 省略可能 | チェック ボックス。デフォルトはオフ。
リリース ノートに追加する | この問題についての項目を製品のリリース ノートに追加する必要があるかどうかを示します。 | 省略可能 | チェック ボックス。デフォルトはオフ。
ドキュメントを更新する | この問題に関連するドキュメントを更新する必要があるかどうかを示します。 | 省略可能 | チェック ボックス。デフォルトはオフ。

カスタム タブ の 2 から 4 は空です。

カスタム フィールド

カスタム フィールドは、次の 2 つの場所で使用できます。
  • 問題の詳細 ページのカスタム タブ
  • アクション ダイアログ。ユーザーが問題に対してアクションを実施すると表示されます
カスタム フィールドを作成または編集するには：
  1. メニューで 問題 > 設定 をクリックします。
  2. 問題のカスタム タブ をクリックします。問題のカスタム タブ ページが開きます。
  3. 編集するカスタム フィールドをクリックします。「GUI のカスタマイズのプロパティ」の説明に従って進んでください。
親トピック: 問題の詳細ページのカスタマイズ
関連概念
問題の詳細ページのカスタマイズ


ワークフローのカスタマイズ

このセクションのトピックでは、Issue Manager でのワークフローに関連する主な概念を説明します。 また、3 つのデフォルト ワークフローを示し、これらを編集する方法を説明します。

  • アクション駆動型ワークフロー
    概念の簡単な説明 フラグメントとして記述する必要があります。 含めるのは 2 文以下にします。
  • デフォルト ワークフロー
    デフォルト ワークフローについて説明します。
  • 独自のワークフローの作成
    独自のワークフローを作成する方法について説明するトピックが掲載されています。
  • ワークフローの状態のカスタマイズ
    ワークフローの状態をカスタマイズする方法について説明します。
  • アクション、理由コード、アクション ダイアログのカスタマイズ
    アクション、理由コード、アクション ダイアログをカスタマイズする方法について説明します。
  • アクションのプロパティ
    アクションのプロパティを説明します。
  • Intelligent Assistant
    状態/理由コードのデフォルトのセットについて説明します。
親トピック: Issue Manager 管理


アクション駆動型ワークフロー

Issue Manager は、アクション駆動型ワークフローを通じてライフ サイクル全体の問題を管理します。 アクション駆動型ワークフローとは、問題が終端つまり終了状態に達するまで、ある状態から別の状態へとユーザーのアクションによって駆動されることを意味します。

注: ワークフローには、最終状態つまりワークフローの最後の状態が少なくとも 1 つは必要です。

例

デフォルトのワークフローでは、カスタマー サポートによって報告されたばかりのソフトウェア バグは、レビュー未完了状態と見なされます。 この状態は、"問題" が本当にバグであることをだれも確認していないことを意味します。 QA エンジニアが状況を評価し、問題がバグであることを確認すると、問題は修正のために開発者に送ることができる状態になります。 この例では、初期状態をレビュー未完了、実行されるアクションをバグとして確認、次の状態を開発準備完了とします。

一方、同じ問題が既に入力されている場合は、このレビュー未完了の問題に対して実行されるアクションは重複として指定であり、次の状態はおそらく対応完了です。 したがって、このレビュー未完了の問題に対して実行されるアクションが異なると、問題が送られる次の状態が異なり、この例では対応完了になります。

場合によっては、問題に対してアクションが実行された後でも、アクションが現在の状態を維持することがあります。 たとえば、既存の問題の説明にコメントを追加できるコメントの追加の場合は、これに該当します。

システムが提供するアクション

Issue Manager では、各ワークフローの各状態に対して 2 つの定義済みアクションがあります。
再割り当て
問題を別の受信箱に送ることができます。
編集
問題の詳細 ページのフィールドを変更できます。

これらのアクションを実行してもワークフロー内で問題は移動しないので、問題の現在の状態は変化しません。

アクションの情報

ワークフローでは、ある状態に対して実行できる有効なアクションのセットが定義されています。 これらのアクションは、ワークフロー ページで確認できます。 実行できるアクションは、リストで選択されている [問題の種類] と [状態] により異なります。

問題の詳細 ページでは、アクションはボタンの形式で使用できます。 使用できるボタン (アクション) は、問題の種類と現在の状態により異なります。

状態の情報

状態の情報は、Issue Manager のすべての場所で表示されます。 たとえば、各グループと各ユーザー アカウントには、問題の種類 ([バグ]、[機能拡張]、[ドキュメント]) ごとに 1 つ、計 3 つの初期状態が割り当てられています。

問題のライフ サイクルに影響を与える初期状態

問題の初期状態は、問題を報告したユーザーがその種類の問題に関してどの程度の知識を持っているかによって異なります。 たとえば、技術サポート グループのメンバがドキュメントの問題を報告した場合は、正確に評価されていて修正できる状態になっているものと考えられるので、問題には [対応中ドキュメント] の初期状態が割り当てられます。 一方、同じメンバがソフトウェアのバグを提出した場合は、正確ではない可能性があるため、ワークフローでの初期状態は [レビュー未完了] になります。 同じタイプの問題でも、グループが異なれば初期状態も異なる可能性があります。 問題の初期状態の詳細については、「問題の初期状態」を参照してください。

ユーザーが問題を保存するとき、Issue Manager は、ユーザーに割り当てられている初期状態を基にして、問題に初期状態を自動的に割り当てます。 テクニカル ライターがドキュメントの問題を記録すると、問題の詳細ページの [状態] フィールドの値は [対応中ドキュメント] になります。 [状態] フィールドは自動フィールドなので、ユーザーではなく Issue Manager が、ワークフローおよび他の情報に基づいて設定します。

  • 状態の所有者
    状態の所有者について説明します。
  • 理由コード
    理由コードについて説明します。
親トピック: ワークフローのカスタマイズ


状態の所有者

ワークフローの最終以外の各状態には、厳密に 1 人の所有者がいます。 所有者とは組織内のロールの 1 つで、特定の状態にある問題の対処を担当します。 レビュー未完了のバグについて考えると、レビュー未完了のソフトウェアの問題を確認または拒否するのは、通常は、QA ロールを実行する人物です。 したがって、レビュー未完了のバグの状態の所有者は QA ロールです。

ワークフローの最終状態には、所有者はいません。 これは、この状態の問題には、アクションを実行する担当者は必要ないからです。

Issue Manager では、最終以外の状態の所有者を、次の 4 つの候補から選択します。

  • QA
  • 開発
  • ドキュメント
  • 機能拡張
注: 状態の所有者は、特定の QA エンジニアや特定の受信箱ではありません。 また、特定の製品、コンポーネント、リリース、またはプラットフォームとも関係ありません。 状態の所有者は、ある状態に関する機能的な責任を一般的に指定するものです。

状態の所有者とルーティング ルールの組み合わせによって、問題を受け取る特定の受信箱が決まるので、所有者は、状態の重要なプロパティです (ルーティング ルールについては「ルーティング ルールのセットアップ」を参照)。 ここでは、Issue Manager がルーティング ルール、状態、および状態の所有者を使用して、特定の受信箱に問題を移動する様子を例として示します。

特定の製品やコンポーネントなどに関係なく、すべてのソフトウェア バグの レビュー未完了 状態の所有者を QA ロールにするとします。 このロールのユーザーは、報告された問題が実際にバグであることを確認します。 そのため、レビュー未完了 状態の 状態のプロパティ ダイアログで、QA がこの状態を所有 ラジオ ボタンを選択します。 この 状態のプロパティ ダイアログにアクセスするには、問題 > 設定 > ワークフロー に移動し、状態の編集 をクリックします。

次に、特定の製品に対するルーティング ルールについて考えます。 ルーティング ルールをセットアップする場合は (問題 > 設定 > ルーティング ルール)、製品、コンポーネント、リリース、およびプラットフォームの組み合わせごとに 4 つの特定の受信箱を指定します。 4 つの状態所有者ラジオ ボタンはそれぞれ、ルーティング ルール ページの 4 つの受信箱、つまり QA 用受信箱、開発用受信箱、機能拡張用受信箱、および ドキュメント用受信箱 に対応します。

例

任意のプラットフォームの Product C の任意のリリースの Email コンポーネントにバグが関係している場合は、そのバグを受信箱 Mike - QA、Sonja - Dev、Dan - Dev (Product C)、または Judy - Doc のいずれかに送ることを、ルーティング ルールに記述します。

問題の現在の状態とその状態の所有者という 2 つの要素に基づいて、4 つの受信箱から 1 つが選択されます。 バグの現在の状態が レビュー未完了 で、QA ロールがレビュー未完了の問題を所有するものと指定されている場合は、問題は自動的に Mike の受信箱 Mike - QA に送られます。

Mike がこの問題に対処すると、実際には、彼は、ライフ サイクルに従ってこの問題を別の状態 (別の所有者を持つ) に移動します。 Issue Manager は、再び、この問題の現在の状態、その状態の所有者、および特定の製品、コンポーネント、リリース、プラットフォームに該当するルーティング ルールに基づいて、適切な受信箱を決定します。

親トピック: アクション駆動型ワークフロー
関連概念
ルーティング ルールのセットアップ


理由コード

Issue Manager は、特定のアクションが実行されたときに問題の状態が変化した理由を説明する、省略可能でカスタマイズ可能なキーワードです。

異なるアクションによって問題が同じ状態に移動する場合があります。 たとえば、問題が完了するには、再現不能、重複、非バグなどさまざまな理由があります。 理由コードによって追加情報が提供されないと、ユーザーは問題のライフ サイクルを完全に把握できません。

理由コードは、ワークフローの状態数をできる限り少なくするのにも役立ちます。 たとえば、複数の最終状態 (非バグ、再現不能、重複) を定義する代わりに、対応完了 という名前の最終状態を 1 つ用意して、問題が完了した理由を示すさまざまな理由コードと組み合わせれば十分です (たとえば、対応完了/非バグ)。

理由コードは、問題の詳細 ページおよびアクション ダイアログに表示されます。 たとえば、テクニカル ライターの Judy が、ドキュメントの問題を自分の受信箱で受け取ったとします。 説明を読んだ彼女は、問題が既に報告されていたことを思い出します。 そして、その問題に重複の印を付けます。 重複として指定 ダイアログ ボックスを開くと、問題が 対応中ドキュメント から 対応完了/重複 に移動していることがわかります。 対応完了 が新しい状態で、重複 は理由コードです。

理由コードの割り当て、クリア、維持

特定のアクションが実行されると、Issue Manager は理由コードをそのアクションに割り当てて、問題を新しい状態に渡します。 それ以降のアクションでは、その理由コードをクリアするか、または単にその理由コードを維持します。 一般に、いったん設定された理由コードは、ワークフローの最終状態に達するまで問題と共に移動します。

開発者がバグを解決した後に、解決 アクションを実行してバグが解決されたことを主張する場合について考えます。 このアクションにより、バグは 開発準備完了 から QA 準備完了 に移動し、理由コードには 解決 が設定されます。 開発者の主張を検証する QA エンジニアは、検証 アクションを実行してバグ修正を承認します。 このアクションにより 解決 理由コードは維持され、バグと共に 対応完了 状態に移動します。

ただし、たとえば問題が最終状態に向かって先に進むのではなくワークフローの前の状態に戻るような場合は、理由コードをクリアできます。 たとえば、QA エンジニアが開発者の主張に異議を唱えて 却下 アクションを実行すると、問題は 開発準備完了 状態に差し戻されます。 解決 理由コードは意味がなくなるので、却下 アクションに対しては理由コードをクリアできます。

理由コードが、割り当てられるか、クリアされるか、維持されるかは、状態 "<状態名>" のアクションの新規作成 ダイアログの設定で決まります。 このダイアログについては、「理由コード」で説明します。 状態 "<状態名>" のアクションの新規作成 ダイアログ ボックスを表示するには、 問題 > 設定 > ワークフロー をクリックしてから アクションの追加 をクリックします。

親トピック: アクション駆動型ワークフロー


デフォルト ワークフロー

Issue Manager には、バグ、ドキュメントの問題、および機能拡張に対して 3 種類のデフォルト ワークフローが用意されています。 デフォルトのワークフローを変更したり、独自のワークフローを作成したりする場合は、「独自のワークフローの作成」を参照してください。

  • デフォルトのバグ ワークフロー
    デフォルトのバグ ワークフローの図を掲載しています。
  • デフォルトの機能拡張ワークフロー
    機能拡張ワークフローについて説明します。
  • デフォルトのドキュメント ワークフロー
    デフォルトのドキュメント ワークフローについて説明します。
親トピック: ワークフローのカスタマイズ
関連概念
独自のワークフローの作成


デフォルトのバグ ワークフロー

次の図は、デフォルトのバグ ワークフローを示したものです。

[編集]、[再割り当て]、[コメントの追加]、および [回避策の追加] の各アクションは、図から省略されています。

  • [編集] と [再割り当て] は各状態に対してあらかじめ定義されており、変更できません。 これらのアクションは、問題の状態を変更しません。
  • [コメントの追加] はすべての状態に対して定義されており、問題の状態を変更しません。
  • [回避策の追加] は、[開発準備完了]、[QA 準備完了]、[QA やり直し]、および [対応完了] に対して定義されており、問題の状態を変更しません。

バグ ワークフローのデフォルトの理由コード

デフォルトのバグ ワークフローで提供されているすべての理由コードを確認するには、問題 > 設定 > ワークフロー をクリックします。 問題の種類として [バグ] を選択すると、その有効なアクションと理由コードが表示されます。

例

デフォルトのバグ ワークフローの一般的な処理パスについて考えます。 報告されたバグは、[レビュー未完了] の状態でワークフローに入り、QA エンジニアの受信箱に送られます。 バグは、確認された後、開発者の受信箱 ([開発準備完了] 状態) に送られます。 開発者は、バグを解決したことを宣言し、[解決] アクションを実施します。 [解決] アクションは、理由コード [解決] を添えて、[QA 準備完了] にバグを送ります。 問題を受け取った QA エンジニアは、バグが修正されていることを検証します。 つまり、[検証] アクションが実施されて、バグは [対応完了] 状態に送られ、理由コードは [解決] が維持されます。

次に、前の例を少しだけ変更してみます。 QA エンジニアは、バグが修正されたという開発者の主張を却下するものとします。 バグは開発者の受信箱に戻されますが、今度は理由コードが [却下] になっています。 開発者は問題を再現できないため、[追加情報が必要] アクションを実施します。 バグは [QA やり直し] に送られます。 これに対し、QA エンジニアは、[重複として指定] アクションまたは [失効した問題] アクションのいずれかを実施して問題を完了させるか、または問題を明らかにしてからバグを [開発準備完了] に差し戻すことができます。

親トピック: デフォルト ワークフロー


デフォルトの機能拡張ワークフロー

次の図は、機能拡張ワークフローを示したものです。

[編集]、[再割り当て]、[コメントの追加]、および [回避策の追加] の各アクションは、図から省略されています。

  • [編集] と [再割り当て] は各状態に対してあらかじめ定義されており、変更できません。これらのアクションは、問題の状態を変更しません。
  • [コメントの追加] はこのワークフローのすべての状態に対して定義されており、問題の状態を変更しません。
  • [回避策の追加] は、[レビュー未完了] を除くすべての状態に対して定義されており、状態に影響を与えません。

機能拡張ワークフローのデフォルトの理由コード

デフォルトの機能拡張ワークフローで提供されているすべての理由コードを確認するには、問題 > 設定 > ワークフロー をクリックします。問題の種類として [機能拡張] を選択すると、その有効なアクションと理由コードが表示されます。

例

機能拡張要求が承認されて、初期レビュー担当者 ([レビュー未完了] 状態) によりまたは管理チーム ([管理呼び出し] 状態) により、開発部門 ([開発準備完了]) に送られるものとします。初期レビュー担当者が [可能性] アクションを実施すると、管理チームが機能拡張要求を受け取ります。

初期レビュー担当者または管理チームが機能拡張要求を却下すると、問題は [却下] の理由コードで完了します。この [却下] アクションは、[QA 準備完了] 状態の問題に対して実施される [却下] アクションとは異なります。この場合は、開発アクション ([実装済み]、[実現不能]、[対応済み]、または [重複として指定]) が議論されます。

親トピック: デフォルト ワークフロー


デフォルトのドキュメント ワークフロー

次の図は、デフォルトのドキュメント ワークフローを示したものです。

[編集]、[再割り当て]、および [コメントの追加] の各アクションは、図から省略されています。

  • [編集] と [再割り当て] は各状態に対してあらかじめ定義されており、変更できません。これらのアクションは、問題の状態を変更しません。
  • [コメントの追加] は、[QA 準備完了] を除くこのワークフローのすべての状態に対して定義されており、問題の状態を変更しません。

ドキュメント ワークフローのデフォルトの理由コード

デフォルトのドキュメント ワークフローで提供されているすべての理由コードを確認するには、問題 > 設定 > ワークフロー をクリックします。問題の種類として [ドキュメントの問題] を選択すると、その有効なアクションと理由コードが表示されます。

例

ドキュメントの問題が、[レビュー未完了] 状態でワークフローに入るものとします。この時点で、レビュー担当者は 3 種類のアクションを実施できます。つまり、問題を承認するか、却下するか、別の問題と同じものとして指定するかです。却下された問題、または重複することが判明した問題は、完了処理されて、理由コードは [却下] または [重複] になります。レビュー担当者が修正の必要なドキュメントの問題であると判断した問題は、[対応中ドキュメント] 状態に移動し、ドキュメント受信箱に送られます。ドキュメント スペシャリストは、この時点で、[解決] アクションまたは [重複として指定] アクションのどちらかを実施できます。

  • [解決] アクションは、[解決] 理由コードを添えて [QA 準備完了] 状態に問題を送ります。
  • [重複として指定] アクションは、[重複] の理由コードを添えて [対応完了] 状態に問題を送ります。

後で修正が検証されると、問題は [解決済み] の理由コードで [対応完了] 状態に移動されます。一方、修正が却下されると、問題は [却下] の理由コードでドキュメント受信箱に戻されます。

親トピック: デフォルト ワークフロー


独自のワークフローの作成

独自のワークフローを作成する場合、最も簡単で信頼できる方法は、デフォルトのワークフローに簡単な変更を行うことです (たとえば、状態名を編集する)。 何もない状態から新しいワークフローを作成するのではなく、デフォルトのワークフローを変更することを強くお勧めします。 概念に関する経験が少ない場合、またはまったくない場合は、特にそうです。

カスタマイズできるのは以下のものです。

  • 問題が通過する状態の数と名前。
  • 特定の状態で有効なアクション。 これらのアクションは、[ワークフロー] ウィンドウに表示されます。
  • 現在の状態に対する各アクションによってもたらされる状態。
    Current State ---- Action 1 ---> New State 1
Current State ---- Action 2 ---> New State 2
  • 各アクションを実行するアクセス許可を持つグループ。
  • ユーザーが問題に対するアクションを実施するときに表示されるアクション ダイアログの外観。

前提条件

状態図とアクション (状態遷移とも呼ばれます) の概念に習熟していること。

  • 状態図の作成
    状態図を作成する方法について説明します。
  • 動詞を含むアクション名の設定
    理解しやすいワークフローをモデル化するためにアクションに動詞を割り当てます。
  • ワークフローの最適化
    ワークフローを最適化する方法について説明します。
  • 状態の所有者とアクセス許可の追加
    状態の所有者とアクセス許可を追加しなければならない理由を説明します。
  • データ入力シートの準備
    データ入力シートとはどのようなものなのかを説明します。
親トピック: ワークフローのカスタマイズ


状態図の作成

ホワイトボードまたは紙に状態図を描きます。各状態を箱の中に記述し、各状態の間には十分なスペースを設けます。

一方の端だけに矢印が付いた線として、状態間の有効な各アクションを描画します。1 本の矢印が 1 個の個別のアクションです。

例

次に示す例は、独自のワークフローに組み込む状態のサンプルです。新しいバグが入ってくると、組織内のだれかが、レビューのためにそのバグを適切な QA エンジニアにディスパッチします。QA エンジニアが報告された動作が新しいバグであることに同意すると、バグは修正のために開発部門に送られます。開発部門では、バグに対していくつかのアクションを実施できます。

  • バグ レポートに記述されている動作は設計どおりの動作なので、問題はバグではない。
  • 次のリリースまでバグの修正を先送りする。
  • バグを再現できない。
  • バグは修正済み。

もちろん、これらは開発者の主張でしかなく、まだ検証を受けていません。ワークフロー モデルでは、このような主張を、解決、先送り、再現不能、非バグ という状態で反映させます。疑問符は、これらの主張がまだ QA エンジニアによる検証を受けていないことを意味します。

親トピック: 独自のワークフローの作成


動詞を含むアクション名の設定

各アクションには動詞を割り当てることをお勧めします。ワークフローで前の状態にバグが戻る場合について考えます。このような負のアクションをモデル化します。たとえば、QA エンジニアは開発者の主張を却下する場合があり、問題は開発部門に戻されます。

また、問題がたどる各過程の検討中に、正のアクションが不足していることがわかる場合もあります。たとえば、QA エンジニアも問題レポートを却下し、結果としてその問題を完了させる場合もあります。次に示す例の図では、QA エンジニアによる [バグの却下] アクションにより、[非バグ] 状態に移行します。すべてのアクションが最終的には最終状態に至ることを確認します。

修正後の例

親トピック: 独自のワークフローの作成


ワークフローの最適化

見るとわかるように、前の図は複雑すぎて役に立ちません。ワークフローを簡単にするために、[ディスパッチ] アクションを除去できます。 これは、正しい受信箱へのバグの配布を、Issue Manager のルーティング ルールが処理するからです。前の図では、[新規バグ] 状態と [ディスパッチ] アクションを削除し、QA エンジニアがバグをレビューできる状態からバグを開始できます。この状態は、[レビュー未完了] と呼ぶことができます。

このワークフローのもう 1 つの欠点は、実質的に状態が反復していることです。Issue Manager の方法論を使用すると、理由コードをアクションに割り当てることで、冗長な状態を除去できます。理由コードが必要な各アクションについて、簡単で内容がわかるキーワードを考えます。理由コードの詳細については、「理由コード」を参照してください。冗長な箇所を特定するには、ワークフローで繰り返されているパターンを探します。たとえば、前の図では、最後の状態の行 ([非バグ]、[先送り]、[再現不能]、[解決]) は、アクションごとに異なる理由コードを使用する 1 つの状態 [対応完了] にまとめることができます (たとえば、[対応完了/非バグ]、[対応完了/解決] など)。

最後から 1 つ前の行も、開発者の主張を検証する QA のロールを認識する 1 つの状態にまとめることができます。この状態は、[QA 準備完了] と呼ぶことができます。ここでも理由コードを使用して、バグの状態が変化した理由を示すことができます (たとえば、[解決] または [先送り] の理由コードでバグが [QA 準備完了] 状態に到着するなど)。QA が実施する 4 つの [却下] アクションは、1 つの [却下] アクションにまとめることができます。同様に、QA が実施する 4 つの [検証済み] アクションは、1 つの [検証済み] アクションにまとめることができます。

例

親トピック: 独自のワークフローの作成


状態の所有者とアクセス許可の追加

問題はその状態と所有者に従って送られます。 状態の所有者とは、組織内で、特定の状態にある問題を担当するロールです。 たとえば、デフォルトのワークフローでは、QA は[レビュー未完了] 状態の問題を担当します。

次に、最終的な図の各状態に所有者を割り当てる必要があります。 最後に、各アクションを実施するアクセス許可を持つグループを決定します。 たとえば、デフォルトのワークフローでは、開発部門のユーザーだけが問題を修正できます (つまり、[解決] アクションを実施できます)。

親トピック: 独自のワークフローの作成


データ入力シートの準備

必要に応じて、Issue Manager へのデータ入力を容易にするシートを準備します。ワークフローの情報は状態別に入力されるので、最初の列は現在の状態と所有者 にします。それから、以下の列見出しを追加します。

  • 現在の状態に対して許可されているアクション
  • 各アクションの結果である新しい状態
  • 理由コード (該当する場合)
  • アクセス許可 - 各アクションの実施を許可されているグループ

データ入力シートは次のようになります。

状態/所有者 | アクション | 新しい状態 | アクセス許可
親トピック: 独自のワークフローの作成


ワークフローの状態のカスタマイズ

デフォルト ワークフローの状態の名前、所有者、および説明を変更できます。 すべての状態を一度に入力または変更した後、各状態に対してすべてのアクションを追加できます。 または、1 つの状態とそのすべてのアクションを入力してから、次の状態とそのアクションに移ることもできます。

  • 状態のプロパティ
    状態のプロパティについて説明します。
  • ワークフローの状態のカスタマイズ
    ワークフローの状態のカスタマイズ手順について説明します。
親トピック: ワークフローのカスタマイズ


状態のプロパティ

状態には以下のプロパティがあります。

状態名
状態の一意な名前 (必須、最大 20 文字)。 特殊文字は使用できません。
説明
状態の説明 (省略可能、字数制限なし)。
状態の所有者
該当するオプションを選び、状態の所有者を選択します。
  • QA がこの状態を所有
  • 開発がこの状態を所有
  • ドキュメントがこの状態を所有
  • 機能拡張の状態
  • 所有者なし (最終状態)
親トピック: ワークフローの状態のカスタマイズ


ワークフローの状態のカスタマイズ

以下のタスクを実行するには、ワークフローのカスタマイズ のセキュリティ権限が必要です。
  1. 問題 > 設定 > ワークフロー をクリックします。 [ワークフロー] ページが表示されます。
  2. カスタマイズするワークフローを表す 問題の種類 を選択します。
  3. 次に示すタスクを実行します。
    このワークフローに状態を追加する

    状態を追加 ボタンをクリックします。 ステップ 4 に進みます。

    このワークフローの状態を編集する

    状態 の一覧から、編集する状態を選択します。 状態を編集 ボタンをクリックします。 ステップ 4 に進みます。

    このワークフローの状態にアクションを追加する

    「アクション、理由コード、アクション ダイアログのカスタマイズ」を参照してください。 ステップ 3 の手順を開始します。

    このワークフローの状態を削除する

    状態 の一覧から、削除する状態を選択します。 削除 ボタンをクリックします。 確認ダイアログで はい を選択します。 Issue Manager では、問題によって参照されていない状態だけが削除されます。

    別のワークフローを変更する
    ステップ 2 に戻ります。
  4. 「状態のプロパティ」で説明されている情報を使用して、状態のプロパティを指定または変更します。
親トピック: ワークフローの状態のカスタマイズ
関連タスク
アクション、理由コード、アクション ダイアログのカスタマイズ


アクション、理由コード、アクション ダイアログのカスタマイズ

このセクションは、デフォルト ワークフローのアクションを変更する場合にのみ参照してください。 デフォルト ワークフローについては、「デフォルト ワークフローの理解」で説明しています。 先に進む前に、まず「アクションのプロパティ」に目を通してください。
  1. 問題 > 設定 > ワークフロー をクリックします。
  2. 問題の種類 リストで、カスタマイズするワークフローを選択します。
  3. 変更したいアクションのある状態を 状態 リストから選択します。
  4. ワークフロー ページには、この手順で入力する以下の情報が表示されます。
    • この状態に適用されるすべてのアクション (ボタン ラベル 列に表示されます)
    • 現在の状態で特定のアクションを取ったときに移行する新しい状態
    • 有効な各アクションの理由コード (該当する場合)
    注: [編集] アクションと [再割り当て] アクションは、Issue Manager ですべての状態に対してあらかじめ定義されているものであり、変更できないので、ダイアログには表示されません。
  5. 次に示すタスクを実行します。
    現在の状態にアクションを追加する
    アクションの追加 をクリックし、ステップ 6 に進みます。
    現在の状態のアクションを編集する
    編集するアクションを ボタン ラベル 列で選択します。
    このワークフローに新しい状態を追加する
    「ワークフローの状態をカスタマイズする方法」のステップ 3 に戻ります。
    このワークフローにおけるアクションのソート順序を変更する

    リスト内で上または下に移動するアクションの 上へ移動 ボタンまたは 下へ移動 ボタン (アクション 列内) をクリックします。

    別のワークフローからアクションを削除する
    削除するアクションの 削除 ボタン (アクション 列内) をクリックします。 確認ダイアログで はい をクリックします。
    注: Issue Manager では、問題によって参照していないアクションだけが削除されます。
    別のワークフローのアクションを変更する
    ステップ 2 に戻ります。
    別のワークフローの状態を変更する
    「ワークフローの状態をカスタマイズする方法」のステップ 2 に戻ります。
  6. アクションの新規作成の場合は、状態 "<状態名>" のアクションの新規作成 ダイアログ ボックスで新規アクションのプロパティを指定します。 アクションの編集の場合は、[状態 "<状態名>" のアクションの編集] ダイアログ ボックスで既存アクションのプロパティを変更します。 「アクションのプロパティ」を参考にしてください。
親トピック: ワークフローのカスタマイズ
関連概念
アクションのプロパティ
関連タスク
ワークフローの状態のカスタマイズ


アクションのプロパティ

ワークフローの状態を定義した後は、各状態に関連付けられるアクションを定義する必要があります。 たとえば、デフォルト バグ ワークフローの開発準備完了状態の場合、開発者は解決や解決不能などのアクションを取ることができます。

各アクションには、一連のプロパティが関連付けられています。

一般プロパティ

アクションのプロパティにはさまざまなものがあり、その範囲は以下のとおりです。

  • 問題の詳細 ページに表示される ボタン ラベル
  • 履歴 タブに表示されるアクションの説明
  • このアクションの結果生じる新しい状態
  • 理由コード
  • アクション ダイアログの外見と使用方法
  • このアクションを取ることを許されているグループ
  • このアクションのソート順序

[状態 "<状態名>" のアクションの編集] ダイアログ ボックス

アクションのプロパティは、状態 "<状態名>" のアクションの編集 ダイアログ ボックスで設定します (問題 > 設定 > ワークフロー)。

  • 現在の状態に関する情報
    現在の状態に関する情報を説明します。
  • 新しい状態リスト
    新しい状態リストについて説明します。
  • [アクションの標準フィールド] タブ
    アクション プロパティの [アクションの標準フィールド] タブについて説明します。
  • [アクションのユーザー定義フィールド] タブ
    アクション プロパティのユーザー定義フィールド タブについて説明します。
  • [アクセス許可] タブ
    アクション プロパティの [アクセス許可] タブについて説明します。
親トピック: ワークフローのカスタマイズ
関連タスク
アクション、理由コード、アクション ダイアログのカスタマイズ


現在の状態に関する情報

名前
編集できません。 アクションの定義対象または変更対象となっている現在の状態の名前が表示されます (たとえば、[状態 "レビュー未完了" のアクションの編集])。
ボタン ラベル
このアクションを実行するボタン (問題の詳細 ページに存在) の表示名で、最大 30 文字までです。
履歴アクション コード
このアクションが実行された場合に記載されるアクションの簡潔な説明 (20 文字以内)。 たとえば、検証済み (英字の場合は、大文字を使用することをお勧めします)。 このコードは、問題の詳細 ページの 履歴 タブの アクション 列に表示されます。
ツールヒント
このアクション ボタンの上でカーソルを静止させたときにツール ヒントとして表示されるテキスト (省略可能)。
説明
このアクションの説明 (省略可能)。
親トピック: アクションのプロパティ


新しい状態リスト

名前
問題に対してこのアクションを取ったときの、ワークフローにおける次の状態の名前。 たとえば、デフォルト ワークフローでは、レビュー未完了 の問題は、バグとして確認されると、Issue Manager では 開発準備完了 という次の状態に移行します。
[理由コード]
このアクションを取ったときに問題が現在の状態から新しい状態に変化する理由を説明するキーワード (省略可能)。 該当するオプションを選択します。
[変更なし]
[変更なし] は、問題が新しい状態に移行してもキーワードがそのまま変わらないことを示します。 このキーワードは、問題の詳細ページの [理由コード] フィールドに表示されます。 たとえば、以下のワークフローでは、あるバグを修正したと開発者が主張すると、そのバグは解決という理由コードで QA 準備完了状態に移行することを示しています。 その主張が正しいことを QA エンジニアが確認すると、バグは解決という理由コードのまま対応完了状態に移行します。 問題を閲覧するユーザーは誰でも、理由コードを見ることで、バグの対応完了理由が簡単にわかります。
[クリア]
問題が新しい状態に移行するときに現在の状態の理由コードが削除されることを示します。 問題がワークフローにおける前の状態に戻るときは、[クリア] を選択するのが妥当です。 たとえば、バグを修正したと開発者が主張すると、バグは [解決] という理由コードで QA 準備完了 状態に移行します。 しかし、その "修正" が却下されると、問題は開発 (開発準備完了) 状態に差し戻されます。 また、主張に異議が唱えられたため、解決 という理由コードは削除されます。 クリア を選択すると、ワークフロー ページの 理由コード フィールドには クリア と表示されます。 ただし、問題の詳細 ページの 理由コード フィールドには何も表示されません。
設定

このアクションに理由コードを関連付けることができることを示します。 20 文字以内でキーワードを入力します。 英字の場合は、すべて大文字にすることをお勧めします。 アクションの結果、理由コードの必要な新しい状態に問題が移行する場合は、[設定] を使用して理由コードを指定します。 一般に、開発者が取るすべてのアクションには理由コードを割り当てなければなりません。

たとえば、デフォルト ワークフローでは、開発準備完了 状態で 解決 アクションを取ると、問題は 解決 という理由コードで QA 準備完了 状態に移行します。 人間行動の点から見ると、これは、バグを修正したと開発者が主張し、それを QA エンジニアに渡すと、QA エンジニアのほうでは、問題の詳細 ページをざっと見て、自分の受信箱にそのバグが入っている理由をたやすく知ることができるということです (他には、開発者がバグを修正できない、あるいはソフトウェアが設計どおりに動作しているという理由でその受信箱にバグが入っている場合もあるでしょう)。

理由コードを使用しない場合

理由コードは、ワークフローにおける状態の数をできるだけ少なくするのに役立つキーワード (省略可能) です。 たとえば、問題が 対応完了 状態になっている理由を説明するのに理由コードが役に立つので、複数の対応完了状態 (非バグ、再現不能、再現不能、重複として指定) を定義しなくても、1 つの最終状態で十分です。 理由コードを使用しないことにした場合は、複数の最終状態を定義する必要があるかもしれません。 ある状態を最終状態にするには、状態のプロパティ ダイアログで、状態所有者 の選択肢として表示される 所有者なし (最終状態) ラジオ ボタンを選択します。

親トピック: アクションのプロパティ


[アクションの標準フィールド] タブ

[状態 "<状態名>" のアクションの新規作成] ダイアログの [アクションの標準フィールド] タブでは、特に、アクション ダイアログの使用方法と外見に関係する以下のプロパティを定義します。

  • アクション ダイアログの アクション メモ フィールド。
  • アクション ダイアログの リリース情報。
  • アクション ダイアログの関連する問題の 関連する問題番号。
アクション メモ
[使用しない]
ユーザーがこのアクションを取ったときは、アクション ダイアログ ボックスに アクション メモ フィールドは表示されません。
省略可能
アクション ダイアログ ボックスに アクション メモ フィールドが表示されます。 ユーザーは、取ろうとしているアクションについての追加情報を必要に応じて入力できます。
[必須]
アクション ダイアログ ボックスには、必須の アクション メモ フィールドが表示されます。 ユーザーは、アクションに関する追加情報をこのフィールドに入力する必要があります。
リリース情報
このグループでは、このアクションを取るリリースをユーザー側で選択できるリストをアクション ダイアログに表示するかどうかを指定できます。 ユーザーが選択したリリースは、問題の詳細 ページの自動フィールドの 1 つにも表示されます。 この情報は、ある種のアクション (たとえば、問題の確認、解決、検証に関係するアクションなど) には特に役立ちます。 現在の状態を変更しないアクションには役に立ちません。 リリース情報 フィールドで指定できる値は、次の 4 つの値のうちいずれかです。
[使用しない]
アクション ダイアログにはリストが表示されません。 コメントの追加 アクションにはリリース情報は必要ないため、コメントの追加 アクションのアクション ダイアログには、リリース情報のリスト ボックスは表示されません。

たとえば、使用しない を選択した場合、ユーザーがアクション ダイアログの省略可能なリスト ボックスに情報を指定しない場合、あるいはリスト ボックスを使用するアクションがまだ取られていない場合は、問題の詳細 ページの アクション リリース フィールドは空欄になります。

[省略可能] または [必須]
アクション ダイアログには、ユーザーがリリースを選択する 省略可能 または 必須 リストが表示されます。 問題の詳細 ページの最後の自動フィールドには、アクションが取られたリリースが表示されます。 アクションに合わせて、リストの ラベル を指定する必要があります。 ラベルの文字数は、末尾のコロンを含めて 20 文字以内です。 デフォルトのフィールド ラベルは、確認アクションの場合は 確認したリリース：、解決アクションの場合は 解決したリリース：、検証アクションの場合は 検証したリリース：です。 このラベルは、アクション ダイアログにも 問題の詳細 ページにも表示されます。 リストの値は、管理モジュールで指定されたリリース リストから取得されます。
[クリア]
問題の詳細 ページの最後の自動フィールドに入力されている既存の値は削除され、フィールドのラベルはデフォルトの アクション リリース に戻ります。 リリース情報 グループの ラベル フィールドは無効になります。 [クリア] は、アクションの結果、問題がワークフローにおける前の状態に戻る場合に適した選択肢です。 デフォルト ワークフローでは、却下 アクションや バグ対応再開 アクションなどがこれに該当します。 たとえば、開発者が 解決 アクションを取り、解決したリリース フィールドに特定のリリース番号を入力するとしましょう。 このアクションの結果、問題は QA 準備完了 状態になります。 この問題を担当する QA エンジニアは、バグを修正したとする開発者の主張を却下します。 却下 アクションの結果、問題は現在の状態である QA 準備完了 から、ワークフローにおける前の状態である 開発準備完了 に戻ります。

アクションの理由コードをクリアする場合、リリース情報 フィールドの値として クリア を選択することを検討します。

アクション ダイアログでユーザーが選択したリリースは、問題の詳細 ページに表示されます。 たとえば、ユーザーが 解決 アクションを取り、[解決したリリース] リスト ボックスからリリースとして 4.1:prod を選択して、[OK] をクリックするとしましょう。 問題の詳細ページが再表示されると、[解決したリリース] フィールドには選択したリリースが表示されます。

関連する問題番号
[関連する問題番号] フィールドを利用すると、重複した問題や関連する問題の番号をユーザー側で入力できるテキスト フィールドをアクション ダイアログに配置することができます。 この情報は、バグ ワークフローで 重複として指定 アクションを取る場合や、機能拡張ワークフローで 対応済み アクションを取る場合に役に立ちます。
[使用しない]
テキスト フィールドはアクション ダイアログに表示されません。
[省略可能] または [必須]

省略可能または必須テキスト フィールドが、アクション ダイアログに表示されます。 この場合、テキスト フィールドのラベルを指定する必要があります。 ラベルの文字数は、末尾のコロンを含めて 20 文字以内です。 バグ ワークフローにおけるデフォルトのフィールド ラベルは、同じバグの番号 です。 機能拡張ワークフローにおけるデフォルトのフィールド ラベルは、次も参照 です。

アクション ダイアログでユーザーが指定した問題番号は、問題の詳細 ページの 履歴 タブの メモ フィールドに表示されます。 たとえば、ユーザーが問題番号 8 に対して 重複として指定 アクションを取り、重複した問題として問題番号 6 を指定して、OK をクリックするとしましょう。 問題の詳細 ページが再表示されると、メモ フィールドには、同じバグの番号: n と表示されます。 ここで、n は、同じバグの番号 フィールドの値です。 同じバグの番号 フィールドが省略可能で、ユーザーが値を指定しない場合は、メモ フィールドには アクション メモ フィールドの内容が表示されます。

親トピック: アクションのプロパティ


[アクションのユーザー定義フィールド] タブ

状態 "<状態名>" のアクションの新規作成 ダイアログの アクションのユーザー定義フィールド タブを利用すると、特定のアクションのアクション ダイアログにフィールドを追加できます。

8 つのフィールドの位置
これらのフィールドは、アクションの標準フィールドに加えて、アクション ダイアログに表示されます。フィールド 1 から フィールド 4 までは、アクション ダイアログの左下に表示されます。フィールド 5 から フィールド 8 までは右下に表示されます。たとえば、リストから選択した 解決に要した時間 フィールドが、開発準備完了 状態に対する 解決 アクションのアクション ダイアログの第 1 フィールド位置 (フィールド 1) に表示されるといった具合です。
ソース
アクションのユーザー定義フィールド タブのリスト ボックスにフィールドが表示される場合、その理由は以下のいずれかです。
  • 問題の詳細の カスタム タブに表示されるカスタム フィールドを定義するために、問題 > 設定 > 問題のカスタム タブ でカスタム フィールドが定義された。
  • 問題 > 設定 > カスタム フィールド プール で、アクションに関連付けるためのカスタム フィールドが定義された。
アクション ダイアログのフィールド定義
  1. 問題の詳細の カスタム タブに表示されるカスタム フィールドを定義するために、問題 > 設定 > 問題のカスタム タブ をクリックします。問題 > 設定 > カスタム フィールド プール で、アクションに関連付けるために作成したカスタム フィールドを使用することもできます。
  2. 「GUI のカスタマイズのプロパティ」の説明に従って、フィールドのプロパティを設定します。
  3. 作成したカスタム フィールドは、アクションのユーザー定義フィールド タブのリスト ボックスから選択することができます。
親トピック: アクションのプロパティ
関連概念
問題の詳細ページのカスタマイズ


[アクセス許可] タブ

[アクセス許可] タブでは、個々のアクションのセキュリティを設定することで、アクションの使用を選択したユーザー グループのみに制限できます。

デフォルトでは、セキュリティを適用 フィールドの値は いいえ になっています (つまり、すべてのグループにすべてのアクションを実行する権限があります)。 この設定は、ワークフロー ページでは [(すべてのグループ)] と表示されます。 セキュリティを設定するには、はい オプションを選択してから、アクションを取ることが許されるグループを 1 つ以上選択します。

ここに示す、アクションに対してセキュリティを定義する例を考慮してください：開発者が 開発準備完了 状態にあるバグの 問題の詳細 ページを開くと、解決不能 アクションを使用できます。 ただし、開発者以外のユーザーが同じバグの 問題の詳細 ページを開いても、このアクションは表示されません。

親トピック: アクションのプロパティ


Intelligent Assistant

テスト結果を処理するため、Intelligent Assistant では、デフォルトのバグ ワークフローで定義されている 4 つの一般的な状態に対応する 4 つの状態/理由コードのペアから成るデフォルト セットを使用します。

デフォルトの状態と理由コードを表示するには：

  1. 設定 > Intelligent Assistant をクリックします。
  2. 一般的なバグ状態と特定の Issue Manager コードとのマッピングをカスタマイズします。

    問題のデフォルト ワークフローをカスタマイズした場合は、結果の処理に使用する状態と理由コードもカスタマイズする必要があります。 たとえば、解決済みと主張されている問題にレビュー未完了の状態が割り当てられるようにデフォルト ワークフローを変更する場合、管理者は、[解決済みとマーク付けされたがまだテストされていない問題] の [状態] に指定されている値も [QA 準備完了] から [レビュー未完了] に変更する必要があります。

    Intelligent Assistant では、[Intelligent Assistant] ページで指定されている問題状態と理由コードに加えて、問題のワークフローに定義されている最終状態も使用します。 最終状態は、[ワークフロー] ページで定義されます。 デフォルトの最終状態は 対応完了 です。

親トピック: ワークフローのカスタマイズ


問題のアーカイブ化

Issue Manager をしばらく使用していると、自分の活動にもう関係のない問題 (対応が完了した問題やサポート対象外の製品に関係する問題など) がデータベースに含まれていたということがあります。 データベースに含まれている問題が増えれば増えるほど、アクション（たとえば、クエリなど）の実行に時間がかかるようになります。 パフォーマンスの向上に役立つように、問題をアーカイブ化することができます。 そうすれば、より少ないアクティブな（アーカイブ化されていない）問題に対してアクションを実行できるようになります。

問題をアーカイブ化すると、Issue Manager は、DEFECT およびその関連テーブルから ARCHIVE およびその関連テーブルに問題を移動します。 問題に関する情報はすべて保存されます (ちなみに、アクティブな問題は DEFECT テーブルに留まるので、ユーザーはそれらに対して通常のアクションを取ることができます)。

ユーザーはアーカイブ化された問題を 問題の詳細 ページで参照できますが、それらは読み取り専用であり、それらに対してアクションを取ることはできません。 アーカイブ化された問題は、ユーザーの受信箱には表示されません。 ただし、アーカイブ化された問題に対してクエリ、レポート作成、グラフ作成を実行することは可能です。 アーカイブ化することで問題はデータベースから "見えなくなり" ますが、削除されるわけではありません。

注: 問題を手動で削除すると、データの整合性が破壊されるおそれがあるので、絶対に行わないでください。

一方、元のデータベースからアクティブな問題と関連情報のみをインポートしたカスタム データベースを新規作成することで、本稼働データベースを小さくするとよい場合もあります。

ユーザーのデスクトップに表示中 (編集中ではない) の問題をアーカイブ化した場合、ユーザーに初めてその変更がわかるのは、ユーザーがログアウトしてログインし直した後、終了してから再起動した後、あるいは、その問題に対して何らかのアクションを取ろうとしたときで、それまではわかりません。

注: Issue Manager では、アーカイブ化された問題に対してアクションを取れないことをユーザーに警告します。
  • 問題のアーカイブ化
    問題をアーカイブ化する方法を説明します。
親トピック: Issue Manager 管理


問題のアーカイブ化

問題をアーカイブ化するには：

  1. メニューで 問題 > 設定 > アーカイブ化 をクリックします。
  2. アーカイブ化する問題に関係する製品を選択します。
  3. リリース フィールドには、選択された製品に関係するリリースが自動的に表示されます。アーカイブ化する問題に関係する特定のリリースを選択します。 複数のリリースを選択することで、それら複数のリリースに関係する問題をアーカイブ化することができます。Ctrl キーを押しながらクリックすると、複数のリリースを 1 つずつ選択できますし、Shift キーを押しながらクリックすると、一定の範囲のリリースを一括して選択できます。
  4. アーカイブ ボタンをクリックします。
  5. 確認ダイアログで はい をクリックして、アーカイブ処理を開始します。
親トピック: 問題のアーカイブ化


電子メール通知ルールのセットアップ

電子メール通知機能では、問題のステータス変化などの重要なイベントが発生したときに自分や組織内の誰かに自動的に通知するように Issue Manager を設定できます。

電子メール通知ルール

ユーザーは、以下のイベントが発生するたびに電子メールが送られてくるようにすることができます。

  • 問題が別の受信箱に再割り当てされる。
  • 問題が、あるワークフロー状態から別のワークフロー状態に (たとえば、レビュー未完了 から 開発準備完了 に) 移行する。
  • 問題の履歴に新たな記載が追加されるような変更 (たとえば、問題の報告対象であるコンポーネントが変わるなど) が問題に加えられる。
  • その他任意に定義される特別なイベント (たとえば、Technical Support グループであれば、個々のバグが修正されたら電子メールを受信したいと考えるでしょう)。

上記のイベントは ルールと呼ばれます。最初の 3 つのルールはあらかじめ定義されているもので、変更できません。特別なイベントのルールは、必要なだけ追加定義することができます。

通知

電子メール通知は、問題に特定のイベントが発生するたびに、Issue Manager にメールを送信させます。通知は、イベントを指定する電子メール送信ルール、電子メールの送信者と受信者、メッセージ本文のほか、省略可能な件名行、前文、および末文で構成されます。

ユーザーは、関心のある問題ごとに通知を適用する必要があります。個々の問題に通知を追加できるのは、問題ごとの電子メール通知 権限を持つユーザーだけです。

問題の通知を確認するには、その 問題の詳細 ページの 通知 アイコンをクリックします。

ルールは、データベース内のすべての問題に適用される通知で使用することもできます。 これらはシステム全体の通知と呼ばれます。

システム全体の通知を追加できるのは、電子メール通知ルールとシステム全体の通知 というセキュリティ権限を持つユーザーだけです。
  • 電子メール通知ルールの定義
    電子メール通知ルールを定義する方法について説明します。
  • 電子メール通知ルールの管理
    電子メール通知ルールを管理する方法について説明します。
  • 受信箱の削除
    問題が含まれず、ルーティング ルールで参照されていず、ユーザーのデフォルト受信箱になっていない受信箱を削除します。
  • システム全体の通知を管理する
    システム全体の通知を管理する方法について説明します。
親トピック: Issue Manager 管理
関連概念
メール通知


電子メール通知ルールの定義

前提条件

独自のルールを定義するには、以下の条件を満たす必要があります。

  • 電子メール通知ルールとシステム全体の通知 権限を持っている。
  • SQL、特に WHERE 句の書き方を熟知している。
  • データベース スキーマ、特に問題に関連するビューとテーブル IM_V_Defects および IM_DefectHistory の列を熟知している。
  • ワークフローとワークフローで使用される値を熟知している。

SQL WHERE 句の書き方のヒント

構文的にも意味的にも正しい WHERE 句を書く上で役に立つ重要なヒントを、ここでいくつか紹介しておきましょう。

IM_V_Defects と IM_DefectHistory 双方への参照

SQL WHERE 句には、おそらく IM_V_Defects と IM_DefectHistory 双方への参照が必要になるでしょう。IM_V_Defects ビューには、問題の最新情報が格納されるのに対して、IM_DefectHistory テーブルには、問題に対して取られたすべてのアクションのほか、それらの変更の結果、問題のいくつかのフィールドにどのような影響があったかが記録されます。

たとえば、IM_DefectHistory には、アクションが取られる前と後の問題の受信箱割り当てが格納されます。これらの列は、アクション実行前の受信箱割り当てについては AssignedIN、新しい受信箱については AssignedOUT です。

問題に対して取られたアクションはすべて、IM_DefectHistory テーブルの ActionCode フィールドに記録されます。これらのアクションは、履歴 タブの アクション 列にアクション コードとして表示されます。たとえば、サンプル データベースでは、"解決" や "検証済み" といったコードが表示されます。

自分のデータベースで使用されているアクションの大半について、そのアクション コードを確認するには、各状態の 状態 "<状態名>" のアクションの編集 ダイアログ ボックスを開きます ("入力"、"再割り当て"、"変更" はハードコードされていて表示されないので除きます)。ある状態の 状態 "<状態名>" のアクションの編集 ダイアログにアクセスするには、問題 > 設定 > ワークフロー ページを開き、ボタン ラベル 列に表示されているアクション名をクリックします。[履歴アクション コード] フィールドの値を確認します。

エイリアスの使用
ビューとテーブルにはエイリアスが定義されています。IM_V_Defects ビューを参照するにはエイリアス D を、IM_DefectHistory テーブルを参照するにはエイリアス DH をそれぞれ使用する必要があります。
カスタム フィールドの識別

IM_V_Defects ビューでは、カスタム フィールドは、タブ上の位置によって Custom1、Custom2 などで識別されます。各カスタム タブにはフィールドが最大 10 個あります (1 から 10、11 から 20 など)。カスタム タブ 1 では、最初の 5 つのフィールドが左側の列に降順に表示され、フィールド 6 からフィールド 10 までが右側の列に降順に表示されます。

個々のカスタム フィールドのスキーマ名を調べるには、問題 > 設定 > 問題のカスタム タブ を選択します。たとえば、サンプル データベースのダイアログでは、カスタム タブ 1 の左列の第 4 フィールドが リリース ノートに追加する チェック ボックスになっており、これは問題テーブルの Custom4 に当たります。

注: カスタム フィールドの位置を変更した場合、そのフィールドを参照している電子メール通知ルールをすべて更新する必要があります。
カスタム フィールドの変更は追跡の対象外
Issue Manager では、IM_DefectHistory テーブル内のカスタム フィールドの変更を追跡しません。カスタム フィールドの現在の値を確かめることはできますが、以前の値を参照することはできません。たとえば、WHERE 句では、リリース ノートに追加する チェック ボックスが選択されているかどうかを検査することはできますが、そのチェック ボックスの値がオフからオンに変化したのを捉えることはできません。
チェック ボックス値へのアクセス

選択されていないチェック ボックスの値は '.'(ピリオド) です。選択されているチェック ボックスの値は 'X' (大文字の X) です。

たとえば、リリース ノートに追加する チェック ボックスがオンの問題をすべて取得するには、WHERE 句の一部に以下のように指定します。

D.Custom4 = 'X'

ルールの例

ここで、ルールを新規作成する状況を 4 つ紹介しましょう。最初の 2 つの状況は、個々の問題の通知でルールが使用される場合です。後の 2 つの状況は、システム全体の通知でルールが使用される場合です。各例の後に、サンプル データベースを対象とした WHERE 句を示します。

例 1

Technical Support などのグループは、特定のバグ修正がいつ修正済みと確認されたかを知る必要があります。

この場合、WHERE 句は以下のようになります。

DH.ActionCode = 'VERIFIED'

IM_DefectHistory テーブル内の ActionCode の値はユーザーがアクションを取るたびに更新されるので、Technical Support グループは、"検証" アクションの結果、アクション コード "検証済み" が IM_DefectHistory テーブルと [履歴] タブに入力されたときに 1 回だけ電子メールを受信します。

代わりに、理由コード (データベースでは Disposition) への参照を使ってこの句を書いた場合、以下のようになります。

D.Disposition = 'FIXED'

この場合、データベースでは理由コードが "解決" のままなので、Technical Support グループはほぼ間違いなく複数回電子メールを受け取ることになるでしょう。その後ユーザーが問題にコメントを追加したり問題を保存しても、ルールがやはり一致するので、電子メールがトリガされることになります。

例 2

平均的なユーザーは自分ではバグに対処しないので、自分の報告したバグがどうなったかを知りたくなる場合があります。特に、バグが開発者の注意を引いたときに電子メールを受け取りたいと思います。ワークフロー的に言えば、これは問題がちょうど 開発準備完了 状態を抜けたことを意味するので、WHERE 句では、アクション実行後の状態変化を検査する必要があります。

この場合、WHERE 句は以下のようになります。

DH.StatusIN = 'Dev-Ready'
AND DH.StatusOUT <> 'Dev-Ready'

アクションの実行前は 開発準備完了 状態でしたが、開発者がアクションを取った後、バグは別の状態に移行しました。

例 3

ドキュメント部門では、Issue Manager のドキュメント関連の問題をすべて、ユーザーの受信箱 Judy -- Doc ではなくグループの受信箱 Doc (Product A) に送ってもらっています。ドキュメント管理者は、グループの受信箱に問題が入ったときに電子メールを受け取りたいと考えています。

この場合、WHERE 句は以下のようになります。

DH.AssignedIN <> 'Doc (Product A)'
AND DH.AssignedOUT = 'Doc (Product A)'

これは、アクション実行前には Doc (Product A) でなかった 受信箱がアクション実行後には Doc (Product A) になったときに電子メールを送信するように指定しています。電子メールは、ドキュメント関連の問題が Doc (Product A) に送られたときに 1 回だけ送信されます。

なお、WHERE 句の最初の部分がなければ、ドキュメント関連の問題が "Doc (Product A)" に割り当てられている段階でも、それに対して何かアクションが取られたらドキュメント管理者が電子メールを受信することになります。通知をシステム全体に適用する必要があるので、このルールは大量の電子メールを生成しそうですが、WHERE 句の 2 行が相まってルールを単一のイベント、すなわち受信箱が Doc (Product A) になったときに制限しています。

ルールでは、問題の種類を "ドキュメントの問題" に限定して指定する必要がありません。 Doc (Product A) はドキュメント関連の問題だけを保持しているので、それでも不正確にはなりません。

例 4

リリース マネージャは、メジャー リリース前の来月一杯、修正できない最も深刻なバグに関する電子メールを受け取りたいと考えています。WHERE 句では、深刻度、"Product B"、そして開発者が "解決不能" アクションを取ったときに割り当てられる "解決不能" アクション コードを検査する必要があります。

この場合、WHERE 句は以下のようになります。

D.Severity = '1: Fatal/Data Loss'
AND DH.ActionCode = 'Cannot-Fix'
AND D.ProductCode = 'Product B'

深刻度はユーザーが明示的に変更するまで変わらないので、WHERE 句で深刻度だけを検査した場合、問題が変更され保存されるたびにルールが一致するため、こういった制限が必要になります。

特にこのルールがシステム全体の通知で適用された場合、リリース マネージャは、大量の電子メールを受け取る可能性があります。ただし、リリース マネージャはリリース サイクルが終了した後で通知を容易に削除することができます。

WHERE 句の書き方のヒント

一般的なものから特定のものへと取り組みます。まず、電子メール通知ルールが必要になりそうな一般的なビジネス状況を検討します。問題に関する電子メールをいつ受け取りたいかを Issue Manager ユーザー全員に尋ねてみてもよいでしょう。各ユーザーがその電子メールからどのような情報を収集したいと思っているかを正確に把握します。たとえば、ユーザーは、バグがいつ修正されたかを知りたいと言うかもしれません。さらに話を聞いてみると、本当は、修正がいつ QA エンジニアによって検証されたかを知りたいのだということがわかるかもしれません。このわずかな変化で、必要な WHERE 句が変わる可能性があります。

次に、ユーザーの希望を十分理解したと思ったら、その状況を、所属組織のワークフローの言葉に翻訳します。

最後に、SQL WHERE 句を作成します。高度なクエリを通じて WHERE 句をテストしてみて、ちょうど意図したとおりに条件を指定しているかどうかを確かめます。

一般的に言えば、個々の問題に関する通知を対象としたルールは簡単かつ包括的なものとして作成しなければならないのに対して、システム全体の通知向けのルールは、過剰な電子メールを避けるためにできるだけ正確かつ限定的なものにしなければなりません。

ユーザーが希望する通知の受信頻度 (1 回だけなのか、変化が生じるたびか) について考えます。ユーザーが 1 回だけの通知を希望する場合は、ルールをより限定的なものにします。

親トピック: 電子メール通知ルールのセットアップ
関連タスク
通知ルールの定義


電子メール通知ルールの管理

電子メール通知ルールを追加、編集、または削除するには、電子メール通知ルールとシステム全体の通知のセキュリティ権限が必要です。
電子メール通知ルールを追加、編集、削除するには：
  1. 問題 > 設定 > 通知ルール をクリックします。
  2. 実行する作業に応じて、以下に示した概要に沿って続行します。
    ルールの追加

    ルールの追加 ボタンをクリックします。通知ルールの新規作成 ダイアログが表示されます。ステップ 3 に進みます。

    定義済みルールの編集
    あらかじめ定義されているルールは編集できません。
    定義済みルールの削除
    あらかじめ定義されているルールは削除できません。
    作成したルールの編集

    編集するルールの 編集アイコン (アクション 列内) をクリックします。ステップ 3 に進みます。

    作成したルールの削除

    削除するルールの 削除 アイコン (アクション 列内) をクリックします。確認ダイアログで OK をクリックして、削除を実行します。

  3. 表示されたダイアログ ボックス (新規作成の場合は 通知ルールの新規作成、編集の場合は [通知ルールの編集]) で、以下のプロパティを指定 (新規作成の場合) または変更 (編集の場合) します。
    ルール名
    ルールの一意な名前 (必須、最大 30 文字まで)。ユーザーはルールの割り当てを名前で判断するので、できるだけ内容を表す名前を付けます。
    説明
    トリガとなるイベントの説明 (省略可能、最大 250 文字まで)。
    WHERE 句
    トリガとなるイベントを指定する SQL WHERE 句 (必須、最大 250 文字まで)。WHERE キーワードを入力しないでください。
  4. OK をクリックして、設定を保存します。 設定を保存せずにダイアログを閉じる場合は、キャンセル をクリックします。

ルールをいったん定義したら、必ず以下のことを行いましょう。

すべてのユーザーの電子メール アドレスを指定する
電子メール通知を利用するには、自分のユーザー アカウントに有効な電子メール アドレスが指定されている必要があります。
データベース管理者に電子メール通知を有効にしてもらう
機能が有効化されると、問題の詳細 ページに 通知 アイコンが表示されます。
ユーザーを教育する
利用可能なルールと各ルールで遂行できることについて、ユーザーに知らせてください。ユーザーは 問題 > 設定 > 通知ルール を選択するとこで、ルールを確認できます。
親トピック: 電子メール通知ルールのセットアップ
関連タスク
ユーザー アカウントのセットアップ


システム全体の通知を管理する

次のセクションでは、システム全体の通知を管理する方法について説明しています。

注: システム全体の通知を追加、編集、または削除するには、電子メール通知ルールとシステム全体の通知 のセキュリティ権限が必要です。
  • システム全体の通知を追加する
    システム全体の通知を追加する方法を説明します。
  • システム全体の通知を編集する
    既存のシステム全体の通知を編集する方法について説明します。
  • システム全体の通知を削除する
    システム全体の通知を削除する方法について説明します。
  • 通知の件名にパラメータを入力する
    通知の件名フィールドで使用できるパラメータについて説明します。
  • 基本の電子メール通知を有効にする
    基本の電子メール通知を有効にする方法について説明します。
  • システム全体の通知を表示する
    システム全体の通知を表示する方法について説明します。
親トピック: 電子メール通知ルールのセットアップ
関連タスク
電子メール通知の定義
システム全体の通知を追加する


システム全体の通知を追加する

  1. 問題 > 設定 > システム全体の通知 の順にクリックします。 すべての既存のシステム全体の通知が一覧表示されます。
  2. システム全体の通知を追加 をクリックします。
  3. 通知の追加 ダイアログ ボックスで、リストからルール名を選択します。
  4. ダイアログ ボックスの 差出人 セクションでラジオ ボタンを選択して、返信用アドレスを以下のどれにするかを指定します。
    • 問題を編集した (結果として通知を引き起こした) ユーザー。
    • その他のユーザー (リストからユーザーを選択)。
  5. 受信者の電子メール アドレスを 宛先 フィールドに入力します。 複数を入力する場合はカンマで区切ります。アドレスの追加 リストからユーザーを選択することもできます。
    注: 宛先 フィールドには任意の電子メール アドレスを入力することができますが、アドレスの追加 リストに表示されるのは、ユーザー アカウントに電子メール アドレスが指定されているユーザーだけです。このため、すべてのユーザー アカウントに電子メール アドレスを定義しておくことをお勧めします。
  6. 省略可能な以下のメッセージ テキスト フィールドにも入力することができます。
    • 件名 は省略可能な件名行です (最大 80 文字まで入力可能)。
    • 前文 は省略可能な前書きテキストです (最大 250 文字まで入力可能)。
  7. 以下の中から、メッセージ内容のタイプを選択します。
    • [内容] は以下のいずれかです。
      • 問題の要約：問題の詳細ページの上半分に表示される情報（これがデフォルト）。
      • 問題の要約と説明：問題の要約と、[説明] タブに表示される情報。
      • 問題の完全な詳細：問題に関するすべての情報。
    • [末文] は省略可能な署名フィールドです (最大 250 文字まで入力可能)。
  8. OK をクリックして通知を保存し、ダイアログを閉じます。
通知を編集するには、ルール名 をクリックします。通知を削除するには、アクション 列の [image] (システム全体の通知を削除) をクリックします。通知をコピーするには、 [image] をクリックします。
注: システム全体の通知を定義するには、電子メール通知ルールとシステム全体の通知 のセキュリティ権限が必要です。
親トピック: システム全体の通知を管理する
関連概念
通知の件名にパラメータを入力する
システム全体の通知を管理する
関連タスク
電子メール通知の定義


システム全体の通知を編集する

  1. 問題 > 設定 > システム全体の通知 の順にクリックします。 すべての既存のシステム全体の通知が一覧表示されます。
  2. 編集する通知の アクション 列にある 編集 アイコンをクリックします。
  3. 通知の追加 ダイアログ ボックスで、リストからルール名を選択します。
  4. ダイアログ ボックスの 差出人 セクションでラジオ ボタンを選択して、返信用アドレスを以下のどれにするかを指定します。
    • 問題を編集した (結果として通知を引き起こした) ユーザー。
    • その他のユーザー (リストからユーザーを選択)。
  5. 受信者の電子メール アドレスを 宛先 フィールドに入力します。 複数を入力する場合はカンマで区切ります。アドレスの追加 リストからユーザーを選択することもできます。
    注: 宛先 フィールドには任意の電子メール アドレスを入力することができますが、アドレスの追加 リストに表示されるのは、ユーザー アカウントに電子メール アドレスが指定されているユーザーだけです。このため、すべてのユーザー アカウントに電子メール アドレスを定義しておくことをお勧めします。
  6. 省略可能な以下のメッセージ テキスト フィールドにも入力することができます。
    • 件名 は省略可能な件名行です (最大 80 文字まで入力可能)。
    • 前文 は省略可能な前書きテキストです (最大 250 文字まで入力可能)。
  7. 以下の中から、メッセージ内容のタイプを選択します。
    • [内容] は以下のいずれかです。
      • 問題の要約：問題の詳細ページの上半分に表示される情報（これがデフォルト）。
      • 問題の要約と説明：問題の要約と、[説明] タブに表示される情報。
      • 問題の完全な詳細：問題に関するすべての情報。
    • [末文] は省略可能な署名フィールドです (最大 250 文字まで入力可能)。
  8. OK をクリックして通知を保存し、ダイアログを閉じます。
親トピック: システム全体の通知を管理する


システム全体の通知を削除する

  1. 問題 > 設定 > システム全体の通知 の順にクリックします。 すべての既存のシステム全体の通知が一覧表示されます。
  2. 削除する通知の アクション 列で 削除 をクリックします。
  3. 確認ダイアログ ボックスで はい をクリックして、削除を実行します。
親トピック: システム全体の通知を管理する


通知の件名にパラメータを入力する

通知の件名フィールドにパラメータを入力して、電子メール通知の件名を動的に生成することができます。

件名フィールドに入力可能なパラメータは以下のとおりです。

{ID}
欠陥番号を返します。
{PROJ}
プロジェクト名を返します。
{PROD}
製品を返します。
{COMP}
コンポーネントを返します。
{USER}
問題を変更したユーザーを返します。
{RULE}
通知をトリガーしたルールの名前を返します。
{SYN}
概要を返します。
{STATE}
問題の現在の状態を返します。
{SEV}
深刻度を返します。
{REASON}
問題の現在の理由コードを返します。
{CUSTOM1-40}
指定された番号のカスタム フィールドを返します。 たとえば、{CUSTOM3} は 3 番目のカスタム フィールドに格納されている値を返します。

たとえば、問題の状態が変わるたびにユーザーに通知する電子メール通知を作成する場合は、件名フィールドに以下のようなテキストを追加すればよいでしょう。

State of issue {ID} was changed by {user}.

現在未解決の問題 2 を Bill が修正した場合は、以下のような件名の電子メール通知を受け取ることになります。

State of issue 2 was changed by bpetersson.
親トピック: システム全体の通知を管理する


基本の電子メール通知を有効にする

割り当てられているアクセス許可に関係なく、どのユーザーからでも有効にできる基本的な通知設定のおかげで、自分の受信箱に入っている問題に別のユーザーが変更を加えたり、自分に新しい問題が割り当てられたときに、ユーザーは通知を受け取ることができます。

注: 件名と通知内容は SRFrontendBootConf.xml ファイルで設定できます。
  1. 設定 > 優先設定 をクリックします。
  2. 自分に問題が割り当てられたり自分の受信箱に入っている問題が変更されたときに通知する チェック ボックスをオンにします。
親トピック: システム全体の通知を管理する


システム全体の通知を表示する

ユーザーが システム全体の通知を各問題の [通知] ダイアログに表示する チェック ボックス (問題 > 設定 > 優先設定) をオンにすると、それぞれの問題の 通知 ダイアログにすべてのシステム全体の通知が一覧表示されます。アクティブな問題に割り当てられた通知もすべて一覧に含められます。

  1. 問題 > 設定 > 優先設定 をクリックします。
  2. システム全体の通知を各問題の [通知] ダイアログに表示する チェック ボックスをオンにします。
親トピック: システム全体の通知を管理する


レポート

  • レポート データマート
    レポート データマートとそれを使用してどのようにレポートを容易に素早く作成できるかについて説明します。
  • レポート領域
    レポート領域のレポートのトピックについて説明します。
  • コード分析
    Silk Central を使ったコード カバレッジの解析方法について説明します。
  • デフォルトのレポート
    デフォルトのレポートについて説明します。
親トピック: 問題追跡と結果分析
関連概念
レポート (Issue Manager)


レポート データマート

Silk Central は、最も重要なデータに容易にアクセスできるようにするために、データマートを提供します。これによって、レポートの作成が容易になり、より単純な SQL クエリで実行できるため、パフォーマンスが改善されます。

  • 概要
    レポート データマートの利点について説明します。
  • アーキテクチャ
    レポート データマートのアーキテクチャについて説明します。
  • データマートを使用してレポートを作成する方法
    データマート ビューを使用してレポートを作成する方法について現実的な例を使って説明します。
  • トラブルシューティング
    データマートに関する質問に対して回答します。
  • 参考： データマート テーブルとビュー
    レポート作成時に容易に素早く利用できるデータマート テーブルとビューについて説明します。
親トピック: レポート


概要

Silk Central レポート データマートは、レポート目的のデータへのアクセスを容易にします。運用テーブルから詳細レポートの作成に使用される専用のビューにデータを移動します。利点は次の通りです。
  • テーブルとビューの名前が明確で、検索するデータの場所を素早く見つけることができます。
  • 前処理済みのデータによって、自分で計算せずに集計済みデータにアクセスすることができます。
  • レポートがより単純化され、SQL クエリが高速化されるため、パフォーマンスが改善されます。
  • 運用データベースの負荷に対する依存性が低下し、パフォーマンスが改善され、負荷スパイクが削除されます。
データマートの現在のバージョンは結果領域をカバーします。レポートの他の領域については、将来のリリースでデータマートに追加される予定です。以下のテーブルとビューが現在利用可能です。
  • DM_TestStatus テーブルは、ステータス関連ビューの基礎です。
  • RV_TestStatusExtended ビューは、あるテスト実行に対する詳細な情報を提供します。
  • RV_LatestTestStatus ビューは、実行計画とビルドのコンテキスト内でテストの最後のテスト実行のステータスと拡張情報を提供します。
  • RV_MaxTestRunID ビューは、すべてのテスト、実行計画、およびビルドの組み合わせに対する最後のテスト実行 ID を取得するために役立つビューです。
  • RV_TestingCycleStatus ビューは、テスト サイクルのステータス情報を提供します。
  • RV_ExecutionPlanStatusPerBuild ビューは、ビルドのコンテキストにおいて、すべての実行計画に対する最後のテスト ステータスの合計数を取得します。
  • RV_ExecutionPlanStatusRollup ビューは、ビルドのコンテキストにおいて、実行計画またはフォルダごとの合計、失敗、未実行テストの合計数を取得します。
  • RV_ConfigurationSuiteStatus ビューは、すべての構成スイートとビルドごとの構成に対するステータスの合計数を一覧します。
親トピック: レポート データマート


アーキテクチャ

運用データベースのテーブルからバックグラウンドで定期的にデータを抽出し、データマート テーブルとビューに読み込むことで、簡単で高速なクエリを実現します。データベースの読み込みが高価でない場合は、通常は変更がコミットされた後数分以内にこのデータは利用可能になります。Silk Central システム管理者としてログインしている場合、http://<サーバー>:<ポート>/sctm/check/db を実行して、DM_TestStatus Table を確認することで、データ読み込み処理の現在の状態を確認することができます。

注: データマートを含まない Silk Central のバージョン (バージョン 13.0 より前) からアップデートする場合、データマート テーブルとビューは運用システムからのデータで最初に更新されます。データベースのサイズに応じて、この処理にかかる時間は変わります。この処理が完了すると、データにアクセスできるようになります。

親トピック: レポート データマート


データマートを使用してレポートを作成する方法

以下の例を用いて、データマート ビューを使用して便利なレポートを作成する方法について説明します。

  • データマート クエリを作成する
    レポート用に高度な SQL クエリを作成します。
  • 実行計画におけるテストの信頼性
    テストの結果が時間の経過とともにどのように変化したかを確認するために、特定の実行計画のコンテキストにおいて特定のテストに対する結果を一覧するレポートを作成する方法について説明します。
  • 実行フォルダにおけるすべての失敗したテスト
    実行フォルダにおけるすべての失敗したテストをリストするレポートを作成する方法を説明します。
  • テスト サイクルのステータス
    テスト サイクルの現在のステータスをテスト担当者とビルドごとに表示するレポートを作成する方法を説明します。
  • 実行ツリーのステータス
    指定した実行計画フォルダに対してビルドで分類した合格、失敗、未実行の数を返すレポートを作成する方法を説明します。
  • 構成スイートのステータス
    ビルドごとの各構成に対して合格、失敗、未実行の数を返すレポートを作成する方法を説明します。
親トピック: レポート データマート


データマート クエリを作成する

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーで、新しいレポートを追加するフォルダを選択します。 これにより、ディレクトリ ツリー内でレポートが保存される場所が決まります。
  3. ツールバーの 子レポートの新規作成 をクリックします。 レポートの新規作成 ダイアログ ボックスが開きます。
  4. 新しいレポートの名前を入力します。 この名前は、レポート ツリーに表示されます。
  5. 他のユーザーもこのレポートを使用できるようにする場合は、このレポートを他のユーザーと共有する チェック ボックスをオンにします。
  6. 説明 フィールドにレポートの説明を入力します。
  7. 詳細クエリ モード をクリックすると、レポート データ クエリ フィールドが開きます。既に記述したコードをこのフィールドに挿入するか、新しいコードを直接書き込みます。
    プレースホルダの挿入 リストは、定義済みの関数プレースホルダを使用して SQL クエリを編集するときに便利です。詳細については、「カスタム レポート用の SQL 関数」を参照してください。
    注: クエリの SQL コードを手作業で編集する場合は、SQL のチェック をクリックして作業を確認します。
  8. 完了 をクリックして、設定を保存します。
親トピック: データマートを使用してレポートを作成する方法


実行計画におけるテストの信頼性

問題

デイリー ビルドをテストするため、およびテスト対象アプリケーションの品質を保証するために、継続的な統合環境において、テストは理想的には 1 日に少なくとも 1 度は実行されるべきです。テスト セットが AUT の品質を計測するためにどの程度信頼できるかを理解するために、時間の経過とともに結果がどのように変化しているかを観察することが時に必要になります。たとえば、頻繁にステータスが変更されるテスト がテスト セットに含まれている場合、品質を測る本来の尺度にはなりえません。

解決策

指定した実行計画のコンテキストにおいて指定したテストに対する結果を一覧するレポートを作成するために、RV_TestStatusExtended データマート ビューを使用します。これを利用して、時間の経過と共にテストの結果がどのように変化したかをを観察することができます。便宜上、タグが設定されたビルドに関連したものに結果のリストを限定することによって、テスト対象アプリケーションの特定のマイルストーン ビルドを観察します。このレポートは、実行計画とビルドのコンテキストにおけるテストに対するテスト結果データを収集します。クエリは次のようになります。

  • このビューから表示したい列を選択します。
  • 調査したいテストの ID とそのテストが属する実行計画の ID によって結果を絞り込みます。
  • タグが設定されたビルドのみを調査するために定数を追加します。
SELECT TestName, ExecutionPlanName, VersionName, BuildName, TestRunID,
  PassedCount, FailedCount, NotExecutedCount
FROM RV_TestStatusExtended
WHERE TestID = ${TESTID|1|Test ID} AND ExecutionPlanID = ${EXECUTIONPLANID|1|Execution Plan ID} AND BuildIsTagged = 1
ORDER BY BuildOrderNumber
SQL クエリの結果は、選択した実行計画内の選択したテストに対するすべてのテストの実行になります。以下の例では、ビルド 579_Drop2 に対して再実行されたテストを確認できます：
TestName | Execution PlanName | Version Name | BuildName | TestRunID | Passed Count | FailedCount | NotExecutedCount
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 579_Drop02 | 7741797 | 59 | 5 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 579_Drop02 | 7745078 | 63 | 1 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 593_Drop03 | 7787437 | 63 | 1 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 605_Drop04 | 7848720 | 63 | 1 | 0
親トピック: データマートを使用してレポートを作成する方法


実行フォルダにおけるすべての失敗したテスト

問題

通常、すべての実行計画はフォルダ階層に構造化されています。各フォルダは実行計画やそのテストが関連するさまざまな分野や目的によって分類されます。複数の実行計画が継続的な統合環境で定期的に実行されたり、ときにはリリース期間に実行され、洗練された実行統計情報を得ることができますが、残念ながら単一の実行計画毎の情報になります。

しかし、特定の分野や目的に応じて実行したすべてのテストがどのような点で脆弱かを知るために全体的な情報が必要になる場合があります。

解決策

データマート ビュー RV_LatestTestStatus を使用して、特定の実行計画の階層レベルに対してすべての失敗したテストのリストを返すレポートを作成します。

以下のクエリは、実行計画フォルダ内のテストを選択し、実行計画名とビルド名などのコンテキスト情報を取得します。

SELECT TestID, TestName, ExecutionPlanID, ExecutionPlanName, BuildName
FROM RV_LatestTestStatus lts
INNER JOIN TM_ExecTreePaths ON lts.ExecutionPlanID = TM_ExecTreePaths.NodeID_pk_fk
WHERE TM_ExecTreePaths.ParentNodeID_pk_fk = ${executionFolderID|2179|Execution Folder ID}
  AND StatusID = 2
ORDER BY TestName
クエリは次の動作を行います。
  • ビュー RV_LatestTestStatus を使用して最新のテスト実行の結果を取得します。
  • 階層内のすべての実行計画からすべてのテストをクエリできるようにするために、実行ツリー階層 (TM_ExecTreePaths) を含めます。
  • トップ レベルのフォルダ ID を使って、一致する ParentNodeID_pk_fk のノードから分析を開始します。
  • 失敗したテストだけ (StatusID = 2) を含めます。

StatusID をテーブル TM_TestDefStatusNames から検索します。

SQL クエリの結果は、選択した実行フォルダ内の最後の実行に失敗したすべてのテストになります。
TestID | TestName | ExecutionPlanID | ExecutionPlanName | BuildName
14073 | JUnitTestPackage | 2184 | CI Testing | 352
14107 | Volatile Tests | 2191 | Volatile Test | 352
親トピック: データマートを使用してレポートを作成する方法


テスト サイクルのステータス

問題

テスト サイクルは手動テスト担当者、テスト、製品のさまざまなビルドやバージョン、そして場合によっては構成についての情報さえ含まれるため、複雑なオブジェクトになり得ます。テスト サイクルの状況を見失わないようにするため、次のような質問に回答することは重要です。

  • いくつのテストが完了したか。
  • そのうちいくつのテストがビルドに対して合格あるいは失敗したか。
  • 手動テスト担当者は忙しいか、または追加の作業を行うことが可能か。

解決策

データマート ビュー RV_TestingCycleStatus を使用して、テスト サイクルのステータスをテスト担当者とビルドごとに表示するレポートを作成します。このレポートは、いくつのテストが合格、失敗、未実行かを手動テスト担当者、構成、ビルドによってグループ化された概要を提供します。

SELECT BuildName, TesterLogin, TesterExecutionName,
  PassedCount, FailedCount, NotExecutedCount
FROM RV_TestingCycleStatus
WHERE TestingCycleID = ${testingCycleID|3|Testing Cycle ID}
ORDER BY BuildOrderNumber, TesterLogin
クエリは次の動作を行います。
  • RV_TestingCycleStatus ビューをデータ ソースとして使用します。このビューには、BuildName、TesterLogin、および TesterExecutionName (テスト担当者、構成、およびテストを反映した自動生成された名前) が含まれています。
  • データを表示したいテスト サイクル ID で制限します。
SQL クエリの結果は、ビルドとテスト担当者ごとのステータスを表示します。
BuildName | TesterLogin | TesterExecutionName | PassedCount | FailedCount | NotExecuted Count
352 |  | No specific tester (Test Assets) | 0 | 0 | 1
351 | admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 1 | 0
352 | admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 0 | 1
352 | gmazzuchelli | gmazzuchelli (English|Oracle10g|IE8|Tomcat - Test Assets) | 0 | 1 | 1
352 | jallen | jallen (German|Oracle11g|FF|Tomcat - Test Assets) | 1 | 1 | 0
352 | smiller | smiller (German|SQL2008|IE8|IIS - Test Assets) | 1 | 1 | 0

未割り当てテストに対して、「テスト担当者なし」グループが列 (TesterLogin、TesterFirstName、TesterLastName) に対して空の値で作成されます。

テスト サイクルが手動テスト担当者のパフォーマンスによってどのくらい行われているかを表示したい場合、次の多少異なるクエリが役立ちます。
SELECT TesterLogin, TesterExecutionName, SUM(PassedCount) PassedCount,
  SUM(FailedCount) FailedCount, SUM(NotExecutedCount) NotExecutedCount
FROM RV_TestingCycleStatus
WHERE TestingCycleID = ${testingCycleID|3|Testing Cycle ID}
GROUP BY TesterLogin, TesterExecutionName
ORDER BY TesterLogin
クエリは次の点が拡張されています。
  • GROUP BY TesterLogin, TesterExecutionName 残りの列を表示するため。
  • SUM() 数値をカウンタに合計するため。
TesterLogin | TesterExecution Name | PassedCount | FailedCount | NotExecutedCount
 | No specific tester (Test Assets) | 0 | 0 | 1
admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 1 | 1
gmazzuchelli | gmazzuchelli (English|Oracle10g|IE8|Tomcat - Test Assets) | 0 | 1 | 1
jallen | jallen (German|Oracle11g|FF|Tomcat - Test Assets) | 1 | 1 | 0
smiller | smiller (German|SQL2008|IE8|IIS - Test Assets) | 1 | 1 | 0
親トピック: データマートを使用してレポートを作成する方法


実行ツリーのステータス

問題

一般的に、実行計画はさまざまなテスト領域や目的を表す階層構造になります。テスト ステータス、さらに領域や目的の品質を知るために、合格、失敗、未実行の全体の数を知りたい場合があります。

解決策

指定した実行計画フォルダに対してビルドで分類した合格、失敗、未実行の数を返すレポートを作成するために、RV_ExecutionPlanStatusRollup データマート ビューを使用します。

SELECT BuildName, PassedCount, FailedCount, NotExecutedCount
FROM RV_ExecutionPlanStatusRollup
WHERE ExecutionFolderID = ${executionPlanID|43|Execution Plan ID}
クエリは次の動作を行います。
  • BuildName を選択し、ステータスを RV_ExecutionPlanStatusRollup ビューから計算します。
  • ステータスを取得したいトップ レベルのフォルダを指定します (ExecutionFolderID)。
SQL クエリの結果は、ビルドごとに集約され、選択したフォルダのすべての実行計画のテスト実行のステータスを表示します。
BuildName | PassedCount | FailedCount | NotExecutedCount
351 | 0 | 0 | 2
352 | 15 | 7 | 1
選択した階層内の各実行計画に対するステータスの数のように、より詳細について知りたい場合は、RV_ExecutionPlanStatusPerBuild データマート ビューを使用できます。
SELECT eps.BuildName, eps.ExecutionPlanID, SUM(eps.PassedCount) PassedCount,
  SUM(eps.FailedCount) FailedCount, SUM(eps.NotExecutedCount) NotExecutedCount
FROM RV_ExecutionPlanStatusPerBuild eps
INNER JOIN TM_ExecTreePaths etp ON eps.ExecutionPlanID = etp.NodeID_pk_fk
WHERE etp.ParentNodeID_pk_fk = ${execFolderID|44|Execution Folder ID}
GROUP BY eps.ExecutionPlanID, eps.BuildOrderNumber, eps.BuildName
ORDER BY eps.BuildOrderNumber, eps.ExecutionPlanID
クエリは次の動作を行います。
  • RV_ExecutionPlanStatusPerBuild ビューを使用して、実行計画固有のデータにアクセスします (ExecutionPlanID および ExecutionPlanName)。実行計画だけでなく、フォルダ ノードに対する結果も取得する必要があるため、前で使用した RV_ExecutionPlanStatusRollup ビューは、あらかじめ集計済みのデータ (合計したデータ) を含んでおり、ここでの目的には適していません。
  • 階層情報を取り入れるため、JOIN テーブルの TM_ExecTreePath を使用して指定したフォルダ内のすべてのノードを選択します。
  • ExecutionFolderID を使ってトップ レベルのフォルダを指定します。テーブル TM_ExecutionTreePaths もすべての実行計画に対する自己参照を含んでいるため、ParentNodeID_pk_fk に対する実行計画 ID を使ってこのクエリを実行することもできます。
  • ORDER BY BuildOrderNumber と ExecutionPlanID を追加して、古いビルドとその実行計画を最初に表示するように結果を分かりやすく並べ替えます。
SQL クエリの結果は、選択したフォルダのすべての実行計画のテスト実行のステータスを表示します。
BuildName | ExecutionPlanID | PassedCount | FailedCount | NotExecutedCount
351 | 2307 | 0 | 0 | 2
352 | 2184 | 11 | 2 | 0
352 | 2185 | 0 | 3 | 0
352 | 2186 | 2 | 1 | 0
352 | 2187 | 1 | 0 | 0
352 | 2191 | 0 | 1 | 0
352 | 2307 | 1 | 0 | 1
親トピック: データマートを使用してレポートを作成する方法


構成スイートのステータス

問題

構成スイートを使用すると、複数のブラウザやオペレーティング システムといった複数の構成に対して同じテスト セットを実行することができます。テスト対象アプリケーションの品質と信頼性に関して適切な状態に保つことができるようにするために、個々それぞれの構成に対する結果を把握することを考えます。

解決策

データマート ビュー RV_ConfigurationSuiteStatus を使用して、ビルドごとの各構成に対して合格、失敗、未実行の数を返すレポートを作成します。

SELECT BuildName, ConfigurationName, PassedCount, FailedCount, NotExecutedCount
FROM RV_ConfigurationSuiteStatus
WHERE ConfigurationSuiteID = ${configSuiteID|97|Configuration Suite ID}
ORDER BY BuildOrderNumber, ConfigurationName
クエリは次の動作を行います。
  • RV_ConfigurationSuiteStatus ビューからテスト事項のビルドごとのステータスの数を取得します。
  • 構成スイート（ConfigurationSuiteID）で結果を絞り込みます。
SQL クエリの結果は、それぞれの構成に対するテスト実行のステータスを表示します。
BuildName | ConfigurationName | PassedCount | FailedCount | NotExecutedCount
350 | Chrome | 0 | 1 | 0
350 | Firefox | 0 | 1 | 0
350 | Internet Explorer | 0 | 1 | 0
351 | Chrome | 1 | 0 | 0
351 | Firefox | 1 | 0 | 0
351 | Internet Explorer | 0 | 1 | 0
352 | Chrome | 1 | 0 | 0
352 | Firefox | 1 | 0 | 0
352 | Internet Explorer | 1 | 0 | 0
この例では、すべての構成を取得するために構成スイートの ID を使用します。特定のビルドを指定して結果を絞り込むことも可能です。この場合、where 節に BuildID、BuildName、または BuildOrderNumber を指定する必要があります。
注: RV_ConfigurationSuiteStatus ビューは、テスト固有のデータは持たず、ステータスの数の合計のみを含みます。さらにテスト固有のデータを取得するには、RV_LatestTestStatus ビューなどを使用することができます。
親トピック: データマートを使用してレポートを作成する方法


トラブルシューティング

  • 間違ったまたは欠落したデータ
    データマート テーブルやビューからクエリしたデータが間違っているまたは欠落しているように見える場合があります。
  • データマートがシステム速度を低下させる
    データマートがシステム パフォーマンスに悪影響を与えるように感じられます。
親トピック: レポート データマート


間違ったまたは欠落したデータ

問題

データマート テーブルやビューからデータをクエリする場合、一覧された結果が最新でないかったり欠落していることがあります。

解決策

データマート テーブルとビューは、バックグラウンドで定期的に更新されますが、リアルタイムではありません。このため、データがデータマート テーブルにロードされるまでに数秒から数分かかります。システムが高負荷状態で実行されている場合、こもデータをロードするバックグラウンド処理のパフォーマンスに影響を及ぼします。他のプロセスがより高い優先度を持っていたり、DataMartUpdater バックグラウンド ジョブが一時的にブロックされてりする可能性があるためです。しばらく時間をおいてから再びクエリを実行して、更新されたデータを取得してください。

Silk Central システム管理者としてログインしている場合、http://<サーバー>:<ポート>/sctm/check/db を実行して、DM_TestStatus Table を確認することで、データ読み込み処理の現在の状態を確認することができます。

注: テスト担当者と依存するテスト実行はテストが削除されるとデータマートから削除されます。これは、テスト パッケージをクリーンアップするために削除されたテストにも適用されます。
親トピック: トラブルシューティング


データマートがシステム速度を低下させる

問題

データマートを実行して以来、システム全体のパフォーマンスが悪くなった、または動作が不安定になったように感じられます。

解決策

このような状態が発生すべきではありませんが、実際にデータマートが影響を与えているのかどうかを確認するために、データマートを無効化することができます。
  1. インスタンス管理 ページで、変更するインスタンスのアプリケーション サーバーを停止します。
  2. TmAppServerHomeConf.xml ファイルをテキスト エディタで開きます。このファイルのデフォルト パスは、アプリケーション サーバー上の C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Conf\AppServer になります。
  3. Config/DataMart/Enabled XML タグに移動し、その値を false に設定します。
  4. XML ファイルを保存して閉じます。
  5. アプリケーション サーバーを再起動します。
親トピック: トラブルシューティング


参考： データマート テーブルとビュー

以下のデータマート テーブルとビューは、レポート作成時に容易に素早く利用できます。

  • DM_TestStatus
    DM_TestStatus テーブルは、ステータス関連ビューの基礎です。
  • RV_TestStatusExtended ビュー
    RV_TestStatusExtended ビューは、あるテスト実行に対する詳細な情報を提供します。
  • RV_LatestTestStatus ビュー
    RV_LatestTestStatus ビューは、実行計画とビルドのコンテキスト内でテストの最後のテスト実行のステータスと拡張情報を提供します。
  • RV_MaxTestRunID ビュー
    RV_MaxTestRunID ビューは、すべてのテスト、実行計画、およびビルドの組み合わせに対する最後のテスト実行 ID を取得するために役立つビューです。
  • RV_TestingCycleStatus
    RV_TestingCycleStatus ビューは、テスト サイクルのステータス情報を提供します。
  • RV_ExecutionPlanStatusPerBuild
    RV_ExecutionPlanStatusPerBuild ビューは、ビルドのコンテキストにおいて、すべての実行計画に対する最後のテスト ステータスの合計数を取得します。
  • RV_ExecutionPlanStatusRollup
    RV_ExecutionPlanStatusRollup ビューは、ビルドのコンテキストにおいて、実行計画またはフォルダごとの合計、失敗、未実行テストの合計数を取得します。
  • RV_ConfigurationSuiteStatus
    RV_ConfigurationSuiteStatus ビューは、すべての構成スイートとビルドごとの構成に対するステータスの合計数を一覧します。
親トピック: レポート データマート


DM_TestStatus

DM_TestStatus テーブルは、ステータス関連ビューの基礎です。

このテーブルからは、テストの名前などの情報へ直接アクセスすることができないため、通常は他のデータマート ビューで、詳細データへの簡易アクセスを提供します。このテーブルのキーは TestID、ExecutionPlanID、BuildID、およびTestRunID 列の組み合わせです。

行 | 説明
TestID | テストの識別子。
ExecutionPlanID | 実行計画の識別子。
BuildID | ビルドの識別子。
TestRunID | テストの実行の識別子。
ExecutionRunID | この結果を生成した実行計画の実行の識別子。
StatusID | このテストの実行のステータス (TM_TestDefStatusNames を参照)。
ReasonID | このテストの実行のステータスの理由 (TM_ResultStatusReasons を参照)。null になる場合があります。
PassedCount | すべての合格したテストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
FailedCount | すべての失敗したテストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
NotExecutedCount | すべての未実行テストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
ProjectID | この行が属するプロジェクトの ID。
TestStartTime | テストの実行が開始された時間 (UTC)。
ExecutionStartTime | テストの実行計画の実行が開始された時間 (UTC)。
TestDurationInMilliseconds | テストの実行の継続時間 (ミリ秒)。
IsBlocked | テストの実行がブロックされているか、ブロック解除されているかのフラグ。
DbChangedAt | この行がレポート データマートによって最後に更新された日時。
親トピック: 参考： データマート テーブルとビュー


RV_TestStatusExtended ビュー

RV_TestStatusExtended ビューは、あるテスト実行に対する詳細な情報を提供します。

RV_LatestTestStatus ビューは実行計画と特定のビルドのコンテキスト内でのテストの最後のテスト実行のみを含みますが、このビューはすべてのテスト実行を含みます。タグが設定されたビルドのすべてのテスト実行をリストするレポート を作成するためにこのビューを使用できます。このテーブルのキーは TestID、ExecutionPlanID、BuildID、およびTestRunID 列の組み合わせです。

注: テスト担当者と依存するテスト実行はテストが削除されるとデータマートから削除されます。これは、テスト パッケージをクリーンアップするために削除されたテストにも適用されます。
行 | 説明
TestID | テストの識別子。
ExecutionPlanID | 実行計画の識別子。
BuildID | ビルドの識別子。
TestRunID | テストの実行の識別子。
ExecutionRunID | この結果を生成した実行計画の実行の識別子。
StatusID | このテストの実行のステータス (TM_TestDefStatusNames を参照)。
ReasonID | このテストの実行のステータスの理由 (TM_ResultStatusReasons を参照)。null になる場合があります。
PassedCount | すべての合格したテストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
FailedCount | すべての失敗したテストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
NotExecutedCount | すべての未実行テストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
ProjectID | この行が属するプロジェクトの ID。
TestStartTime | テストの実行が開始された時間 (UTC)。
ExecutionStartTime | テストの実行計画の実行が開始された時間 (UTC)。
TestDurationInMilliseconds | テストの実行の継続時間 (ミリ秒)。
IsBlocked | テストの実行がブロックされているか、ブロック解除されているかのフラグ。
DbChangedAt | この行がレポート データマートによって最後に更新された日時。
TestName | このテストの名前。
TestDescription | テストの説明。
TestParentID | テストの親の ID。
PlannedTimeInMinutes | このテストの予定時間 (分)。
Reason | 理由の名前。その間に削除された理由も含まれます。
ExecutionPlanName | 実行計画の名前。
ExecutionPlanDescription | 実行計画の説明。
ExecutionParentFolderID | 実行計画の親の ID。
Priority | 実行計画の優先度。0 = 低、1 = 中、2 = 高。
BuildName | このテスト実行に使用したビルドの名前。
BuildDescription | ビルドの説明。
BuildOrderNumber | ビルドの順位番号。
BuildIsTagged | ビルドにタグが設定されている場合は 1 を、そうでない場合は、0。
VersionID | ビルドが属するバージョンの ID。
VersionName | バージョンの名前。
VersionDescription | バージョンの説明。
VersionOrderNumber | バージョンの順位番号。
ProductID | ビルドが属する製品の ID。
ProductCode | 製品の名前。
ProductDescription | 製品の説明。
ProductOrderNumber | 製品の順位番号。
親トピック: 参考： データマート テーブルとビュー


RV_LatestTestStatus ビュー

RV_LatestTestStatus ビューは、実行計画とビルドのコンテキスト内でテストの最後のテスト実行のステータスと拡張情報を提供します。

RV_TestStatusExtended ビューを使用して、すべてのテスト実行についての情報を取得します。実行フォルダにおけるすべての失敗したテストをリストするレポート を作成する方法を説明します。このテーブルのキーは TestID、ExecutionPlanID、BuildID、およびTestRunID 列の組み合わせです。

行 | 説明
TestID | テストの識別子。
ExecutionPlanID | 実行計画の識別子。
BuildID | ビルドの識別子。
TestRunID | テストの実行の識別子。
ExecutionRunID | この結果を生成した実行計画の実行の識別子。
StatusID | このテストの実行のステータス (TM_TestDefStatusNames を参照)。
ReasonID | このテストの実行のステータスの理由 (TM_ResultStatusReasons を参照)。null になる場合があります。
PassedCount | すべての合格したテストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
FailedCount | すべての失敗したテストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
NotExecutedCount | すべての未実行テストの合計数。通常のテストでは 0 か 1 ですが、パッケージ テストのルートではそれ以上になる場合があります。
ProjectID | この行が属するプロジェクトの ID。
TestStartTime | テストの実行が開始された時間 (UTC)。
ExecutionStartTime | テストの実行計画の実行が開始された時間 (UTC)。
TestDurationInMilliseconds | テストの実行の継続時間 (ミリ秒)。
IsBlocked | テストの実行がブロックされているか、ブロック解除されているかのフラグ。
DbChangedAt | この行がレポート データマートによって最後に更新された日時。
TestName | このテストの名前。
TestDescription | テストの説明。
TestParentID | テストの親の ID。
PlannedTimeInMinutes | このテストの予定時間 (分)。
Reason | 理由の名前。その間に削除された理由も含まれます。
ExecutionPlanName | 実行計画の名前。
ExecutionPlanDescription | 実行計画の説明。
ExecutionParentFolderID | 実行計画の親の ID。
Priority | 実行計画の優先度。0 = 低、1 = 中、2 = 高。
BuildName | このテスト実行に使用したビルドの名前。
BuildDescription | ビルドの説明。
BuildOrderNumber | ビルドの順位番号。
BuildIsTagged | ビルドにタグが設定されている場合は 1 を、そうでない場合は、0。
VersionID | ビルドが属するバージョンの ID。
VersionName | バージョンの名前。
VersionDescription | バージョンの説明。
VersionOrderNumber | バージョンの順位番号。
ProductID | ビルドが属する製品の ID。
ProductCode | 製品の名前。
ProductDescription | 製品の説明。
ProductOrderNumber | 製品の順位番号。
親トピック: 参考： データマート テーブルとビュー


RV_MaxTestRunID ビュー

RV_MaxTestRunID ビューは、すべてのテスト、実行計画、およびビルドの組み合わせに対する最後のテスト実行 ID を取得するために役立つビューです。

このテーブルのキーは TestID、ExecutionPlanID、およびBuildID 列の組み合わせです。

行 | 説明
TestID | テストの識別子。
ExecutionPlanID | 実行計画の識別子。
BuildID | ビルドの識別子。
MaxTestRunID | 実行計画とビルドのコンテキスト内にある、最後のテスト実行を識別します。
親トピック: 参考： データマート テーブルとビュー


RV_TestingCycleStatus

RV_TestingCycleStatus ビューは、テスト サイクルのステータス情報を提供します。

テスト サイクルの現在のステータスを表示するレポートを作成するためにこのビューを使用できます。

TestingCycleID はテスト サイクルを表し、TesterExecutionID (同様にTesterExecutionName、UserID、CapacityInCycle、TesterLogin、TesterFirstName、TesterLastName) は、テスト サイクルに割り当てられたテスト担当者を識別するために使用されます。特定のテスト担当者が割り当てられていないテストの場合、UserID、CapacityInCycle、TesterLogin、TesterFirstName、およびTesterLastName は null になります。このテーブルのキーは TesterExecutionID、およびBuildID 列の組み合わせです。

行 | 説明
TestingCycleID | テスト サイクルの識別子。
TesterExecutionID | 特定のテスト担当者に割り当てられているテストのグループを識別します。
TesterExecutionName | 特定のテスト担当者に割り当てられているテストのグループに対して生成した名前。
UserID | テスト担当者のユーザー ID。
CapacityInCycleInMinutes | このテスト サイクルでのこのユーザーの最大利用可能時間 (秒)
TesterLogin | テスト担当者のログイン名。
TesterFirstName | テスト担当者の名前。
TesterLastName | テスト担当者の姓。
PassedCount | すべての合格したテストの合計数。
FailedCount | すべての失敗したテストの合計数。
NotExecutedCount | すべての未実行のテストの合計数。
ProjectID | プロジェクトの識別子。
BuildID | ビルドの識別子。
BuildName | このテスト実行に使用したビルドの名前。
BuildDescription | ビルドの説明。
BuildOrderNumber | ビルドの順位番号。
BuildIsTagged | ビルドにタグが設定されている場合は 1 を、そうでない場合は、0。
VersionID | ビルドが属するバージョンの ID。
VersionName | バージョンの名前。
VersionDescription | バージョンの説明。
VersionOrderNumber | バージョンの順位番号。
ProductID | ビルドが属する製品の ID。
ProductCode | 製品の名前。
ProductDescription | 製品の説明。
ProductOrderNumber | 製品の順位番号。
親トピック: 参考： データマート テーブルとビュー


RV_ExecutionPlanStatusPerBuild

RV_ExecutionPlanStatusPerBuild ビューは、ビルドのコンテキストにおいて、すべての実行計画に対する最後のテスト ステータスの合計数を取得します。

フォルダと子ノードは対象としません。フォルダの各実行計画に対して、テスト実行のステータスを表示するレポートを作成するためにこのビューを使用できます。RV_ExecutionPlanStatusRollup とは異なり、データの取得において階層を考慮しないため、このビューのパフォーマンス上の利点はほとんどありません。このテーブルのキーは ExecutionPlanID、およびBuildID 列の組み合わせです。

行 | 説明
ExecutionPlanID | 実行計画の識別子。
BuildID | ビルドの識別子。
ExecutionPlanName | 実行計画の名前。
ExecutionParentFolderID | 実行計画の親の ID。
PassedCount | すべての合格したテストの合計数。
FailedCount | すべての失敗したテストの合計数。
NotExecutedCount | すべての未実行のテストの合計数。
ProjectID | 実行計画が属するプロジェクトの ID。
BuildName | このテスト実行に使用したビルドの名前。
BuildDescription | ビルドの説明。
BuildOrderNumber | ビルドの順位番号。
BuildIsTagged | ビルドにタグが設定されている場合は 1 を、そうでない場合は、0。
VersionID | ビルドが属するバージョンの ID。
VersionName | バージョンの名前。
VersionDescription | バージョンの説明。
VersionOrderNumber | バージョンの順位番号。
ProductID | ビルドが属する製品の ID。
ProductCode | 製品の名前。
ProductDescription | 製品の説明。
ProductOrderNumber | 製品の順位番号。
親トピック: 参考： データマート テーブルとビュー


RV_ExecutionPlanStatusRollup

RV_ExecutionPlanStatusRollup ビューは、ビルドのコンテキストにおいて、実行計画またはフォルダごとの合計、失敗、未実行テストの合計数を取得します。

フォルダの場合、カウンタにはすべての子の数値が含まれます。フォルダのすべてのテスト実行のステータスを表示するレポートを作成するためにこのビューを使用できます。このテーブルのキーは ExecutionFolderID、およびBuildID 列の組み合わせです。

行 | 説明
ExecutionFolderID | 実行計画の識別子。
BuildID | ビルドの識別子。
PassedCount | すべての合格したテストの合計数。
FailedCount | すべての失敗したテストの合計数。
NotExecutedCount | すべての未実行のテストの合計数。
ProjectID | 実行計画が属するプロジェクトの ID。
BuildName | このテスト実行に使用したビルドの名前。
BuildDescription | ビルドの説明。
BuildOrderNumber | ビルドの順位番号。
BuildIsTagged | ビルドにタグが設定されている場合は 1 を、そうでない場合は、0。
VersionID | ビルドが属するバージョンの ID。
VersionName | バージョンの名前。
VersionDescription | バージョンの説明。
VersionOrderNumber | バージョンの順位番号。
ProductID | ビルドが属する製品の ID。
ProductCode | 製品の名前。
ProductDescription | 製品の説明。
ProductOrderNumber | 製品の順位番号。
親トピック: 参考： データマート テーブルとビュー


RV_ConfigurationSuiteStatus

RV_ConfigurationSuiteStatus ビューは、すべての構成スイートとビルドごとの構成に対するステータスの合計数を一覧します。

構成スイートの各構成に対して、すべてのテスト実行のステータスを表示するレポートを作成するためにこのビューを使用できます。このテーブルのキーは ConfigurationID、およびBuildID 列の組み合わせです。

行 | 説明
ConfigurationSuiteID | 構成スイートの識別子。
ConfigurationID | 構成の識別子。
ConfigurationName | 構成の名前。
BuildID | ビルドの識別子。
PassedCount | すべての合格したテストの合計数。
FailedCount | すべての失敗したテストの合計数。
NotExecutedCount | すべての未実行のテストの合計数。
ProjectID | この行が属するプロジェクトの ID。
BuildName | このテスト実行に使用したビルドの名前。
BuildDescription | ビルドの説明。
BuildOrderNumber | ビルドの順位番号。
BuildIsTagged | ビルドにタグが設定されている場合は 1 を、そうでない場合は、0。
VersionID | ビルドが属するバージョンの ID。
VersionName | バージョンの名前。
VersionDescription | バージョンの説明。
VersionOrderNumber | バージョンの順位番号。
ProductID | ビルドが属する製品の ID。
ProductCode | 製品の名前。
ProductDescription | 製品の説明。
ProductOrderNumber | 製品の順位番号。
親トピック: 参考： データマート テーブルとビュー


レポート領域

  • 概要
    Silk Centralレポートの概念を説明します。
  • レポートの作成とカスタマイズ
    レポートを作成し、カスタマイズする方法について説明します。
  • レポートを表示する
    レポートを生成して、表示します。
  • レポートを保存する
    レポートを保存します。
  • レポートをお気に入りに追加する
    ユーザーが 1 クリックでレポートを表示できるようにするため、レポートをお気に入りに追加します。
  • レポートを PDF 形式で表示する
    レポートを PDF 形式で表示します。
  • 最近使った（MRU）レポートにアクセスする
    最近表示されたレポートにアクセスします。
  • [レポート] ツールバーの機能
    レポート ツールバーには、レポートを管理するための重要なコマンドがあります。
  • レポートのプロパティ
    レポートのプロパティを操作する方法について説明します。
  • レポートのパラメータ
    レポートのパラメータを操作する方法について説明します。
  • [レポート] の [データ] ページ
    選択したレポートの結果のパラメータと値を表形式で表示する、読み取り専用の結果プレビューの役割を果たします。
  • [レポート] ページ
    書式設定されたレポートとしてデータを表示します。
  • プロジェクト概要レポート
    選択したプロジェクトのステータスの概要を示します。
親トピック: レポート


概要

Silk Central に同梱されたデフォルト レポートは、すべてのプロジェクトで表示可能で、レポート ツリーの グローバル レポート の下に一覧されます。これらのレポートは変更できませんが、必要に応じてコピーを作成してカスタマイズすることができます。ユーザー独自のカスタム レポートを グローバル レポート ツリー内に作成すると、そのレポートもすべてのプロジェクトに対して利用可能にすることができます。また、プロジェクト ツリーと グローバル レポート ツリー間でレポートをコピーすることもできます。グローバル レポートの概念によって、Silk Central 内のすべてのプロジェクトで利用できるレポートを柔軟に管理することができます。

制限事項：
  • グローバル レポートはプロジェクトのコンテキストにないため、詳細レポート（SQL）でなければなりません。
  • グローバル レポートをプロジェクト レポートのサブレポートにすることはできません。また、サブレポートはグローバル レポート セクションで利用できません。

共有グローバル レポートのアクセス許可

共有グローバル レポートは、すべてのユーザーのすべてのプロジェクトで利用可能であるため、更新したり削除したりできるユーザー ロールとして、共有グローバル レポートの管理 および 共有グローバル レポートの削除 の特別なアクセス許可が必要です、共有グローバル レポートで使用するレポート テンプレートに対しても、これらのアクセス許可が適用されます。非共有グローバル レポートとレポート テンプレートは、レポートの更新や削除といった標準レポートのアクセス許可を持つユーザー ロールによって更新および削除することができます。これは次の特殊なシナリオを生じさせます。
  • オプション このレポートを他のユーザーと共有する は、ユーザーが 共有グローバル レポートの管理 アクセス権を持たない場合、グローバル レポートとフォルダでは無効化されます。
  • コピーした共有レポートを グローバル レポート ツリーに貼り付けるときに、共有グローバル レポートの管理 アクセス権を持たない場合は、貼り付けたレポートは非共有に設定されます。
親トピック: レポート領域


レポートの作成とカスタマイズ

  • レポートを作成する
    Silk Central におけるレポートの作成方法について説明します。
  • サブレポートで作業する
    サブレポートで作業する方法について説明します。
  • レポート テンプレート
    レポート テンプレートを操作する方法について説明します。
  • レポート配信登録
    レポート配信登録を操作する方法について説明します。
  • グラフで作業する
    レポートでグラフを使用する方法について説明します。
  • レポートをカスタマイズする
    Silk Central レポートのカスタマイズ方法について説明します。
親トピック: レポート領域


レポートを作成する

Silk Central は、データを直感的にわかりやすいグラフにすばやく簡単に変換するレポートを提供しています。組み込み済みレポートは、要件 ユニット、テスト ユニット、および 問題 領域で利用できます。

レポートは、オープン ソースの Ecllipse ベースのレポート ツールの BIRT Report Designer、や Microsoft Word または Microsoft Excel を使用して作成したレポート テンプレートから作成されます。 Silk Central は BIRT Report Designer と強固に統合されているため、テスト管理データを使用したレポートの生成を簡単に行えます。Silk Central のレポート作成機能は、非常に細かくカスタマイズできます。数多くのレポートやレポート テンプレートがあらかじめ組み込まれているため、追加設定なしで幅広いレポートのニーズに応えることができます。簡単な GUI ベースのツールを使用して、既に組み込まれているレポートを編集し、独自のレポートを作成することができます。SQL の知識がある人なら、さまざまなデータの問い合わせやカスタム レポートでの表示をほぼ制限なく行うことができます。

ヒント: 空のレポートが生成された場合、選択したプロジェクトにデータが含まれていないか、適切な Silk Central データベースに接続していない可能性があります。Silk Central データベースがローカルで利用できるのでない限り、オフラインでレポートを生成することはできません。
  • 新しいレポートを作成する
    レポートを新規作成します。
  • カスタム レポート用の SQL 関数
    使用可能な関数プレースホルダについて説明します。
  • SQL で高度なクエリを作成する
    レポート用に高度な SQL クエリを作成します。
親トピック: レポートの作成とカスタマイズ


新しいレポートを作成する

新しいレポートを作成するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーで、新しいレポートを追加するフォルダを選択します。 これにより、ディレクトリ ツリー内でレポートが保存される場所が決まります。
  3. ツールバーの 子レポートの新規作成 をクリックします。 レポートの新規作成 ダイアログ ボックスが開きます。
  4. 新しいレポートの名前を入力します。 この名前は、レポート ツリーに表示されます。
  5. 他のユーザーもこのレポートを使用できるようにする場合は、このレポートを他のユーザーと共有する チェック ボックスをオンにします。
  6. タイムアウト [秒] フィールドに、Silk Central が SQL クエリが完了するまで待機する最長時間を秒数で指定します。
  7. デフォルト タブ リストから、状況依存のレポート リストからレポートを選択した場合に移動するタブを選択します。
  8. 結果カテゴリ リストから、対応する結果の種類を選択します。 この設定では、レポート作成時にフィルタ対象になるデータベース テーブルおよびビューを指定します。選択できる結果の種類は次のとおりです。
    結果の種類
    説明
    要件
    要件 モジュールで使用できる要件のうち、照会条件を満たすものを返します。
    テスト
    テスト 領域で使用できるテストのうち、照会条件を満たすものを返します。
    テストの実行
    実行 領域から、照会条件を満たす実行済みテスト結果を返します。
    実行計画
    実行領域から実行計画を返します。
    問題
    問題を返します (インポートされた問題を含む)。
    要件進捗 (ビルド単位)
    ビルドごとの要件の進捗に関する情報が含まれます。ビルド間での要件の開発状況がわかります。
    要件進捗 (日単位)
    [要件進捗 (ビルド単位)] と同じですが、日ベースで開発状況を示します。
    テスト進捗 (ビルド単位)
    ビルド間でのテストの開発状況を示します。
    テスト進捗 (日単位)
    [テスト定義進捗 (ビルド単位)] と同じですが、日ベースで開発状況を示します。

    結果種別ごとに一連の選択基準が提供されています。選択した結果カテゴリに合わせて、レポートで使用する 選択基準 を指定します。通常、これらの選択基準では、ビューやその他の直感的なグループ化 (カスタム プロパティなど) によって、プロパティが分類されます。

  9. プロパティ リストから、フィルタを適用するプロパティを選択します。 選択基準の中には、プロパティが動的なものもあります。
  10. クエリの 演算子 を選択します。 選択可能な演算子はプロパティによって異なります。演算子の例としては、=、不一致、部分一致、部分不一致 などがあります。文字列の比較は常に小文字で行われます。文字列で利用できるワイルド カードは "*" と "?" です (* は任意の数の文字に、? は必ず 1 つの文字に一致します)。
  11. クエリの絞り込み対象となる 値 を選択または指定します。 日付に基づくプロパティの場合は、値 フィールドは特定の日付を選択するために使用するカレンダー ツールに置き換えられます。
  12. 省略可能：レポートにクエリ文字列を追加するには、1 つ追加 をクリックします。既存のクエリ文字列は、文字列の 削除 ボタンをクリックすると削除できます。複数のクエリ文字列が定義されている場合には、1 つ追加 ボタンの横に AND と OR のオプション ボタンが表示されます。このオプション ボタンを使用して、累積的にクエリを行うのか、クエリ文字列の基準の 1 つだけを満たせばよいのかを定義します。
  13. 次へ をクリックし、レポートの新規作成 ダイアログ ボックスでレポートの列を構成します。
  14. 列の追加 をクリックします。 列の追加 ダイアログ ボックスに、使用できるレポートの列がすべて表示されます。
  15. レポートに含める列を選択し、OK をクリックします。 Ctrl + クリック を使用すると、複数の列を選択できます。
    注: テスト計画レポートの場合、使用できる列名のリストが、LQM_V_Tests テーブルの列名で拡張されています。
    選択した列が、レポートの新規作成 ダイアログ ボックスに表形式で表示されます。
  16. 省略可能：各レポート列の表示方法を設定します。列ごとに、ソート 列の上下の矢印を使って、ソートの方向 (昇順、降順、ソートなし) を指定します。
  17. 複数の列をソート対象に選択すると、ソート順序 の列にリスト ボックスが表示されるので、それを使用して列のソート順をさらに簡単に指定できます。必要に応じて番号を設定します。
  18. 各列に エイリアス を指定します。 これは、生成されたレポートで列のラベルとなる名前です。
  19. グループ化することで、SQL の集約機能を利用できます (複数の要素の選択、合計値の問い合わせなど)。グループ化 チェック ボックスをオンにし、SQL の GROUP BY 機能を適用することを指定します。
  20. SQL の GROUP BY 機能の対象に選択されていない列は、デフォルトにより集約に設定されます (つまり、合計値が 1 つ計算されます)。集約 リストから、適切な集約タイプを選択します。 利用可能なタイプは、
    • 総数
    • 総計
    • 平均値
    • 最小値
    • 最大値
  21. アクション 列では、ビューの中で列のリストを上下に移動したり、列を削除したりできます。
  22. 完了 をクリックして、レポートの新規作成を終了します。
親トピック: レポートを作成する


カスタム レポート用の SQL 関数

詳細クエリを記述する際に、関数ごとに提供されているプレースホルダを利用することができます。関数プレースホルダは、実行時に SQL コードに置き換えられます。関数はパラメータのように使用することができますが、関数名の先頭には $（ドル記号）が付きます。プレースホルダはパラメータとは異なり、実行ごとにカスタマイズすることができない定義済みのレポート要素です。

使用可能な関数プレースホルダの一覧を以下の表に示します。

関数 | 機能 | 例
$TODAY | データベース サーバー上の現在のシステム日付を返します。$TODAY-1（前日）や $TODAY-7（1 週間前）のように記述することもできます。 | CreatedAt > ${$TODAY}
$DATE(列) | 日付を返します（時間は含みません）。 |
$DATE('文字列') | 渡された文字列をデータベース日付に変換します。 | CreatedAt > ${$DATE('01/10/2005')}
$DAYS[p1;p2] | 渡された 2 つのパラメータの間の日数の差を計算します。2 つのパラメータは、テーブル/ビューの列でも $TODAY でもかまいません。 | 以下の例は、この 1 週間以内に作成された行を返します： ${$DAYS[CreatedAt;$TODAY]} < 7
$WEEK(パラメータ) | 渡されたパラメータの週番号を返します。パラメータは $TODAY や列で指定します。 |
$MONTH(パラメータ) | 渡されたパラメータの月を数字で返します。パラメータは $TODAY や列で指定します。 |
$YEAR(パラメータ) | 渡されたパラメータの年を数字で返します。パラメータは $TODAY や列で指定します。 |
$USERID | 現在ログインしているユーザーの ID。 |
$USERNAME | 現在ログインしているユーザーの名前。 |
$PROJECTID | 現在選択しているプロジェクトの ID。 |
$PROJECTNAME | 現在選択しているプロジェクトの名前。 |
$REPORTNAME | 現在選択しているレポートの名前。 |
$REPORTID | 現在選択しているレポートの ID。 |

以下に示すのは、あらかじめインストールされている 要件と子要件 というレポートのコードです。このレポートでは、選択した要件がその要件 ID と共に表示されます。その要件の子要件に関する詳細が表示されます。これはカスタム レポートではありませんが、$PROJECTID 関数が使われているため、例として役に立ちます。また、2 つのパラメータ reqID（要件 ID）と reqProp_Obsolete_0（古い要件を表示）も含まれています。

SELECT r.ReqID, r.ReqCreated, r.ReqName, r.TreeOrder
   FROM RTM_V_Requirements r INNER JOIN
   TM_ReqTreePaths rtp ON (rtp.ReqNodeID_pk_fk = r.ReqID)
   WHERE rtp.ParentNodeID_pk_fk=${reqID|22322|Requirement ID} AND
   r.ProjectID = ${$PROJECTID} AND
   r.MarkedAsObsolete=${reqProp_Obsolete_0|0|Show obsolete Requirements}
   ORDER BY r.TreeOrder ASC
親トピック: レポートを作成する


SQL で高度なクエリを作成する

手作業で SQL をコーディングすると、高度なレポートを作成することができます。データベース スキーマがわかっている場合には、ほとんどどのようなレポートでも作成できます。詳細クエリ モード をクリックすると、クエリ文字列のリスト ボックスが消え、レポート データ クエリ フィールドが表示されます。このフィールドで、既存のコードを挿入したり、新しい SQL コードを作成したりできます。
制約事項: SQL 文 select top はサポートされていません。

1 つの方法としては、「新しいレポートを作成する」で説明したようにリスト ボックスを使用してクエリ文字列を作成します。レポート基準が有効であれば、それに相当する SQL 文が生成されて表示され、詳細クエリ モードに移動してさらに修正を行います。

注: 詳細モードから簡易モードに戻すと、コード内の変更が失われます。

SQL で高度なクエリを直接記述するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーで、新しいレポートを追加するフォルダを選択します。 これにより、ディレクトリ ツリー内でレポートが保存される場所が決まります。
  3. ツールバーの 子レポートの新規作成 をクリックします。 レポートの新規作成 ダイアログ ボックスが開きます。
  4. 新しいレポートの名前を入力します。 この名前は、レポート ツリーに表示されます。
  5. 他のユーザーもこのレポートを使用できるようにする場合は、このレポートを他のユーザーと共有する チェック ボックスをオンにします。
  6. 説明 フィールドにレポートの説明を入力します。
  7. 詳細クエリ モード をクリックすると、レポート データ クエリ フィールドが開きます。既に記述したコードをこのフィールドに挿入するか、新しいコードを直接書き込みます。
    プレースホルダの挿入 リストは、定義済みの関数プレースホルダを使用して SQL クエリを編集するときに便利です。詳細については、「カスタム レポート用の SQL 関数」を参照してください。
    注: クエリの SQL コードを手作業で編集する場合は、SQL のチェック をクリックして作業を確認します。
  8. 完了 をクリックして、設定を保存します。
親トピック: レポートを作成する
関連概念
カスタム レポート用の SQL 関数
関連タスク
新しいレポートを作成する


サブレポートで作業する

  • サブレポートを追加する
    現在選択しているレポートに複数のレポートの結果を集計するために、サブレポートを追加します。
  • サブレポートを削除する
    レポートに集計するサブレポートの結果が不要になった場合に、レポートからサブレポートを削除します。
親トピック: レポートの作成とカスタマイズ


サブレポートを追加する

複数のレポートの結果を現在選択しているレポートに集約するために、サブレポートを追加することができます。レポートをサブレポートとして追加すると、サブレポートの結果の列と行は、選択したレポートの結果に連結されます。

レポートをサブレポートとして追加するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. プロパティ タブをクリックします。
  4. サブレポートの追加 をクリックします。 サブレポートの追加 ダイアログ ボックスが表示されます。
  5. レポート ツリーから、現在のレポートに追加するサブレポートを選択します。
  6. OK をクリックして、サブレポートの追加を完了します。 関連するレポートの プロパティ ページの サブレポート セクションに、サブレポートが表示されます。
親トピック: サブレポートで作業する


サブレポートを削除する

サブレポートを削除するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. 削除するサブレポートが関連付けられているレポートを、レポート ツリーで選択します。
  3. プロパティ タブをクリックします。
  4. 削除するサブレポートの アクション 列で、 削除 をクリックします。
  5. 確認ダイアログ ボックスで はい をクリックして、削除を確定します。
親トピック: サブレポートで作業する


レポート テンプレート

レポート テンプレートは、レポート データのレンダリングを定義します。レポート テンプレートの管理についての詳細は、「レポート テンプレートを管理する」を参照してください。

共有グローバル レポートは、すべてのユーザーのすべてのプロジェクトで利用可能であるため、更新したり削除したりできるユーザー ロールとして、共有グローバル レポートの管理 および 共有グローバル レポートの削除 の特別なアクセス許可が必要です、共有グローバル レポートで使用するレポート テンプレートに対しても、これらのアクセス許可が適用されます。非共有グローバル レポートとレポート テンプレートは、レポートの更新や削除といった標準レポートのアクセス許可を持つユーザー ロールによって更新および削除することができます。

  • レポート テンプレートを選択またはアップロードする
    ローカル システムでレポート テンプレートを作成したら、テンプレートを Silk Central にアップロードできます。
  • レポート テンプレートをダウンロードする
    レポート テンプレートをダウンロードし、レポート データを独自のニーズに合った書式で表示します。
  • レポート テンプレートを削除する
    現在のレポートのテンプレートを削除します。
親トピック: レポートの作成とカスタマイズ


レポート テンプレートを選択またはアップロードする

レポート テンプレートを選択するか、ローカル システムからテンプレートをアップロードするには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. テンプレートを関連付けるレポートを選択します。
  3. レポート タブをクリックします。
  4. テンプレートをアップロードするには、ここをクリックすると、新しいレポート テンプレートをアップロードできます リンクをクリックして、レポート テンプレートのアップロード ダイアログ ボックスを開きます。
    1. テンプレートのわかりやすい 名前 と 説明 を入力します。
    2. プロジェクト リスト ボックスで、テンプレートを利用できるようにするプロジェクトを選択します。すべてのプロジェクトにテンプレートを関連付けるには、すべてのプロジェクト を選択します。
    3. 参照 をクリックして、ローカル システムのテンプレートを探して選択します。
    4. OK をクリックして、テンプレートをアップロードします。
  5. 既存のテンプレートを選択するには、ここをクリックすると、レポート テンプレートを選択できます リンクをクリックして、レポート テンプレートの選択 ダイアログ ボックスを開きます。
    1. 選択したレポートのデータを適切にレンダリングするようにデザインされたテンプレートをリストから選択します。
    2. OK をクリックして、テンプレートを使用します。
親トピック: レポート テンプレート
関連タスク
レポート テンプレートをダウンロードする


レポート テンプレートをダウンロードする

Silk Central のレポート テンプレートを使用すると、レポート データを独自のニーズに合った書式で表示することができます。テンプレートには、Word のドキュメント、Excel のスプレッドシート、BIRT Report Designer のテンプレート、XML、または CSV ファイルの形式のものがあります。Silk Central レポート テンプレートをユーザーのローカル システムにダウンロードすると、BIRT Report Designer または Microsoft Excel または Word でテンプレートを編集できます。レポートをダウンロードして編集した後で、別のユーザーが利用できるようにアップロードできます。詳細については、関連手順「レポート テンプレートをアップロードする」を参照してください。

編集用に既存のレポート テンプレートをダウンロードするには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. 変更するテンプレートを利用しているレポートを、レポート ツリーから選択します。
  3. プロパティ タブをクリックします。
  4. ダウンロードしたいテンプレートのダウンロード リンクをクリックします。 利用可能なダウンロード リンクは次のとおりです。
    空の BIRT レポート テンプレートの生成
    空の汎用 BIRT レポート テンプレートとしてレポート データを受け取ります。データソースはすでに構成済みです。
    XLS/XLSX レポート テンプレートの生成
    データを含んだシートを持つ Excel のファイルを受け取ります。図などのその他の情報を他のシートで指定できます。
    Word レポート テンプレート (サンプル) のダウンロード
    Word docx ファイルを受け取り、これを使用してカスタム Word レポートを作成できます。Word ファイルには、レポートに必要なデータを追加するためのテンプレートをカスタマイズする方法のサンプルが含まれています。
    レポート データのダウンロード (CSV)
    レポート データは CSV (Comma Separated Values) ファイルとして受け取ります。ローカルの設定によって、区切り文字は "," または ";" になります。日付もユーザーの設定に合わせた書式になります。
    レポート データのダウンロード (XML)
    XML としてレポート データを受け取ります。この形式が CSV よりも優れているのは、サブレポートのデータもすべて取得できる点です。Silk Central の外部のデータへのアクセス：次の書式を使うと、レポート データを提供している特定の URL を呼び出すことができます。
    http://server/servicesExchange?hid=reportData&userName=<username>
&passWord=<password>&reportFilterID=<ID of the report>&type=<csv|xml>
&projectID=<ID of the project>
    。
  5. ファイルのダウンロード ダイアログ ボックスが表示されます。保存 をクリックするとレポート ファイルがローカル システムにダウンロードされます。ファイルの拡張子は、ダウンロードするレポートのタイプにより、.rptdesign、docx、xlsx、xls となります。
  6. rptdesign ファイルには BIRT Report Designer、docx ファイルには Word、xls/xlsx ファイルには Excel を使用して、必要に応じてレポートを編集します。
親トピック: レポート テンプレート
関連タスク
レポート テンプレートを選択またはアップロードする


レポート テンプレートを削除する

現在のレポートのテンプレートを削除するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーで、テンプレートを削除するレポートを選択します。
  3. レポート タブをクリックします。
  4. レポート テンプレートの削除 をクリックします。
  5. 続いて表示される確認ダイアログ ボックスで はい をクリックします。
親トピック: レポート テンプレート


レポート配信登録

レポート ユニットの配信登録 タブで、レポートの配信登録を作成することができます。レポートを受信する時間と場所と方法をカスタマイズでき、さらにレポートのパラメータも変更できます。レポートは選択したスケジュールごとにアプリケーション サーバーのバックグラウンドで作成されます。 配信登録者に電子メールでレポートが送信されるか、または、ダッシュボード パネルに表示させることができます。また、外部サイトから URL を介してアクセスすることもできます。

  • レポート配信登録を管理する
    レポート配信登録を管理する方法、およびレポートに対して配信登録する方法を説明します。
  • ダッシュボード パネルにレポートを追加する
    レポートを作成し、ダッシュボード パネルに追加する方法について説明します。
親トピック: レポートの作成とカスタマイズ


レポート配信登録を管理する

配信登録を操作する場合には次の点にご注意ください。
  • レポートを作成したユーザーが削除された場合、レポートのスケジュールは削除され、レポートは無効になります。他のユーザーが配信登録を変更して、再度アクティブにする必要があります。
  • プロジェクトのコピーおよびベースライン作成時に配信登録はコピーされません。
  • プロジェクトのエクスポート時に配信登録はエクスポートされません。
  • 配信登録を作成した後、アクション 列のアイコンを使って編集または削除することができます。
  • ダッシュボード パネルおよび外部からレポートにアクセスする場合は、最後のレポートの結果だけが保存され、履歴は利用できません。
  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. 配信登録 タブをクリックします。
  4. 配信登録の追加 をクリックします。 配信登録の編集 ダイアログ ボックスが開きます。
  5. 名前 フィールドで配信登録の名前を指定します。
  6. 配信登録でパラメータを変更するには、パラメータの編集 をクリックします。 パラメータの編集 ダイアログ ボックスが開きます。値 を変更して、OK をクリックします。
  7. スケジュール リストからスケジュールを選択します。希望するスケジュールが存在しない場合は、作成する必要があります。スケジュールを選択せずに、テスト実行の結果に基づいてトリガーされるだけの配信登録を作成することもできます。
  8. 結果の処理方法 領域で、以下のいずれかの方法を選択します。
    • 電子メールでレポートを送信したい場合には、電子メールで送信 をクリックし、形式 としてレポート テンプレート (Excel、BIRT)、PDF (データ表)、または XLSX (データ表) を選択します。選択可能なオプションは、設定済みのテンプレートの種類によって異なります。そして、レポートの送信先となる 電子メール アドレス を入力します。カンマ、セミコロン、または空白で複数の電子メール アドレスを指定して、複数の宛先にレポートを送信することができます。
    • レポートをダッシュボードで、または外部サイトから利用できようにしたい場合は、ダッシュボードと外部アクセス をクリックします。このオプションを選択すると、レポート配信登録 ダッシュボード パネルでレポートが利用可能になり、さらに提供したリンクを Web サイトや電子メールなどに埋め込むことができます。このリンクは変更されない永続的なもので、アクセスする際にログインやライセンスは必要ありません。テンプレートを使用している場合は、BIRT テンプレートのみがグラフで表示されます。他のテンプレートは、データ表として表示されます。
  9. OK をクリックします。 新しい配信登録が 配信登録 リストに表示されます。
すべてのレポート配信登録を管理するには、グローバル レポート ノードまたはプロジェクトのルート ノードを選択します。レポート配信登録を編集または削除するには、アクション 列のアイコンを使用します。共有グローバル レポートは、すべてのユーザーのすべてのプロジェクトで利用可能であるため、更新したり削除したりできるユーザー ロールとして、共有グローバル レポートの管理 および 共有グローバル レポートの削除 の特別なアクセス許可が必要です、共有グローバル レポートで使用するレポート テンプレートに対しても、これらのアクセス許可が適用されます。非共有グローバル レポートとレポート テンプレートは、レポートの更新や削除といった標準レポートのアクセス許可を持つユーザー ロールによって更新および削除することができます。

例：IFrame に外部アクセス リンクを埋め込む

<html>
...
<body>
...
<iframe src="http://<front-end server>:19120/servicesExchange?hid=reportOutput&linkId=ec36a037-a59a-4899-a98c-5a4a4644811f"
 width="700" height="500"></iframe>
...
</body>
</html>
親トピック: レポート配信登録
関連資料
[スケジュール] ページ
[実行計画] の [プロパティ] ページ


グラフで作業する

  • グラフを表示する
    グラフを表示する方法について説明します。
  • グラフを印刷する
    グラフを印刷します。
  • グラフを削除する
    選択されているレポートから現在のグラフ テンプレートを削除します。
  • [レポート] の [グラフ] ページ
    データ分析のためのグラフを定義できます。
親トピック: レポートの作成とカスタマイズ


グラフを表示する

グラフを表示するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. グラフ タブをクリックして、デフォルトのグラフを表示します。
  4. 別のグラフの種類を選択するには、 グラフの種類の選択 をクリックします。 グラフの種類の選択 ダイアログが表示されます。
  5. グラフの種類 リストからグラフの種類を選択します。
  6. グラフに適用する表示プロパティをオンにします。
    • 三次元表示
    • 横のグリッド線を表示
    • 縦のグリッド線を表示
    • 凡例を表示
  7. グラフ オプションを保存する方法を指定します。
    • 現在のユーザーのみ オプションをクリックすると、現在のユーザーがこのグラフを表示するときには常に、このグラフ設定がレポートの標準設定より優先されます。
    • レポートの標準とする オプションをクリックすると、優先するユーザー設定を定義していないすべてのユーザーに対し、このグラフ設定が表示されます。 この設定は、個々のユーザーの設定には影響しません。
  8. OK をクリックすると、新しいグラフの種類が表示されます。
    注: ここで定義したグラフ設定は、このレポートのデフォルトになります。 標準のグラフでは必要なデータが得られない場合、または必要な形式でデータを表示できない場合は、Silk Central のレポート機能を使用して、問い合わせたデータの表示をカスタマイズできます。 現在のグラフを別のブラウザ ウィンドウで開くには、グラフ ページの一番上にある 新しいウィンドウで開く をクリックします。
親トピック: グラフで作業する


グラフを印刷する

現在のグラフを印刷するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. グラフ タブをクリックします。
  4. 印刷 をクリックします。 グラフのデータが、印刷可能な形式で新しいウィンドウに表示されます。システムの [印刷] ダイアログ ボックスも表示されます。
  5. 必要に応じて印刷の設定を行い、OK をクリックしてグラフを印刷します。
親トピック: グラフで作業する


グラフを削除する

グラフを削除すると、現在選択されているグラフ テンプレートが現在のレポートから削除されるだけです。 グラフ テンプレートが完全に削除されることはありません。

選択されているレポートから現在のグラフ テンプレートを削除するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. グラフ タブをクリックします。
  4. グラフの種類の削除 をクリックします。 グラフの削除 ダイアログ ボックスが開きます。
  5. 以下のいずれかを選択します。
    • 現在のユーザーのグラフ設定をグラフと共に削除するには、ユーザー設定を削除 (およびレポートの標準に戻す) を選択します。 それ以降、グラフはレポートの標準設定で表示されます。 標準設定が定義されていない場合は、グラフを表示できません。
      注: このオプションを使用できるのは、現在のユーザーが特定のグラフ設定を定義している場合のみです。
    • 標準設定をグラフと共に削除するには、レポートの標準グラフ設定を削除 を選択します。 このオプションでは、ユーザー固有の設定は影響を受けません。
      注: このオプションを使用できるのは、レポートに標準のグラフ設定が定義されている場合のみです。
  6. OK をクリックするとグラフ テンプレートが削除されます。 必要に応じて、<ここをクリックすると、グラフの種類を選択できます> リンクをクリックし、選択したレポートに新しいグラフ テンプレートを割り当てることができます。
親トピック: グラフで作業する


[レポート] の [グラフ] ページ

レポート > 詳細ビュー > グラフ

グラフ ページでは、データ分析のためのグラフを定義できます。このページでは、Silk Central 内部のレポート エンジンを使用して、選択したレポート クエリで取得したデータから標準のグラフを作成します。

以下の標準のグラフが利用可能です。
  • 面グラフ
  • 棒グラフ
  • 水平帯グラフ
  • 折れ線グラフ
  • 円グラフ
  • 帯グラフ
親トピック: グラフで作業する


レポートをカスタマイズする

  • BIRT レポート テンプレートをカスタマイズする
    BIRT Report Designer を使用して、カスタム レポート テンプレートを作成します。
  • Word レポート テンプレートをカスタマイズする
    Word レポート テンプレートをダウンロードし、カスタマイズする方法について説明します。
親トピック: レポートの作成とカスタマイズ


BIRT レポート テンプレートをカスタマイズする

BIRT Report Designer (BIRT) を使用すると、Silk Central にあらかじめ組み込まれたレポート テンプレートをカスタマイズしたり、カスタム レポート テンプレートを作成したりできます。BIRT の使用の詳細については、この『ヘルプ』の「管理」トピックおよび BIRT Report Designer のドキュメントを参照してください。

編集用に既存のテンプレートをダウンロードするには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. BIRT レポート テンプレートを利用するレポートを選択します。
  3. プロパティ タブをクリックします。
  4. 空の BIRT レポート テンプレートの生成 をクリックします。 空の汎用 BIRT レポート テンプレートとしてレポート データを受け取ります。データソースはすでに構成済みです。
  5. ローカル システムにテンプレートを保存した後、必要に応じて変更を加えます。 BIRT レポート テンプレートの設定については、この『ヘルプ』の「管理」トピックを参照してください。
  6. 変更したレポート テンプレートをアップロードするには、メニューで 管理 > レポート テンプレート をクリックし、アップロード をクリックします。
親トピック: レポートをカスタマイズする
関連概念
カスタム レポート テンプレートを BIRT で管理する


Word レポート テンプレートをカスタマイズする

Word レポート テンプレートを使用して、ニーズに合ったカスタム レポートを作成します。

編集用に既存のテンプレートをダウンロードするには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポートを選択します。
  3. プロパティ タブをクリックします。
  4. サンプル Word レポート テンプレートのダウンロード リンクをクリックします。 ブラウザを使用して、ファイルをローカルに保存します。
  5. レポートの使用可能な結果列を利用し、「Word レポート テンプレート」に含まれるコマンドに従って好みに合わせてレポートをカスタマイズします。
  6. 変更したレポート テンプレートをアップロードするには、メニューで 管理 > レポート テンプレート をクリックし、アップロード をクリックします。
  • Word レポート テンプレート
    完全にカスタマイズされたサンプル テンプレートだけでなく、Word レポート テンプレートを変更する方法について説明します。
親トピック: レポートをカスタマイズする


Word レポート テンプレート

テンプレートについて

カスタマイズされたレポートを作成するには、Word レポート テンプレートを使用します。テンプレートでは、Word マージ フィールドを使用して必要なデータを取得します。テンプレートは docx ファイル用に設計されており、doc はサポートしません。ここで、作業を開始するにあたってのヒントをご紹介します。
  • Microsoft Word にマージ フィールドを挿入するには、挿入 > クイック パーツ > フィールド > MergeField をクリックするか、Ctrl+F9 を押します。
  • マージ フィールドを編集するには、フィールドを右クリックしてから フィールドの編集 を選択します。
  • レポートではマージ フィールドに加えて標準テキストをミックス アンド マッチできます。
  • マージ フィールドは、次の形式になります：« value »

レポートの一般情報

次にレポートの見出しで使用できるデータを示します。

フィールド | 説明
${report.name} | レポートの名前。
${report.projectName} | レポートを実行するプロジェクトの名前。
${report.description} | レポートの説明。
${report.executedBy} | レポートを実行したユーザーのログイン名。
${report.generatedOn} | レポートが実行された日時。
${report.generatedOnWeek} | レポートが実行された週番号。

データへのアクセス

次のセクションでは、レポートのさまざまなデータにアクセスして表示する方法について説明します。

インデックス別
«${rows[0].cols[3]}»
名前別
«${rows[0].ReqName}»
リスト内
標準的な事例は各行で繰り返され、各行の列情報を表示します。データのリストを取得するには、次を実行します：
«[#list rows as r]»
«${r.TestDefID}» - «${r.TestName}»
«[/#list]»

ループの開始は [#list rows as r] で定義され、[/#list] によって終了されます。ループ内の行データは、r を使用して参照され、ループ内の Test Name は ${r.TestName} で参照することによって取得できます。

上の例では、すべての行で繰り返しが行われ、レンダリングされたレポートは、ID と名前付きでテストのリストを表示します。

テーブル内
テーブルの行でループの開始と終了を定義するには、テーブル内での繰り返しを続行するための追加のコマンドが必要です。ループのための list コマンドをテーブルの最初の行に配置し、@before-row という接頭辞を付ける必要があります。リストを完成するには、@after-row を使用する必要があります。次の表にその方法を示します。
«${headers[3]}»|«${headers[3].@name}» | «${headers[4]}»|«${headers[4].@index}»
«@before-row[#list rows as r]»«${r.ReqName}»«@after-row[/#list]» | «${r.ReqDescription.@html}»
見出しと HTML
  • データの見出しには、headers という名前のマージ フィールドでアクセスできます。
  • .@elementName または .@name または .@index を追加することで、見出しをさまざまな方法で表示できます。
  • 一部の Silk Central データは、多くの 説明 フィールドと同様に、HTML として保存されます。HTML エンコードされたテキストをタグに基づいて表示したい場合は、属性 .@html を追加します。この属性を追加しない場合もテキストは表示されますが、HTML マークアップが含まれています。たとえば、ソース データが <b>レポートの説明</b> で、.@html を使用すると、レポートの説明 が表示されます。追加しない場合は、<b>レポートの説明</b> が表示されます。次の HTML タグがサポートされています：<b>, <strong>, <i>, <u>, <br>, <p>, and <a>
サブレポート
サブレポートには、sub キーワードを使用してアクセスできます。sub1、sub2 のように、アクセスするサブレポートの番号を追加します。
例：ProjectID がメイン レポートの最初の行にある場合、«${rows[0].ProjectID}» のようにして参照します。TestID が最初のサブ レポートの最初の行にある場合、«${sub1.rows[0].TestID}» のようにして参照します。最初のサブ レポートのすべての行全体を繰り返して、TestID 列と 2 番目の列を表示するには：
«[#list sub1.rows as sr]»
  «${sr.TestID}» «${sr.cols[1]}»
«[/#list]»

トラブルシューティング

レポートに間違ったデータが表示される
列をインデックス別に参照していますか。もしそうであれば、最初の列がインデックス 1 ではなく、インデックス 0 に参照されていることを確認します。
マイ レポートをダウンロードするとき、特定のフィールドを示すエラーが表示されるのは何故ですか。テンプレートにこのフィールドが表示されません。

フィールドのラベルを変更したものの、電子メール マージ参照の値が元のままになっている可能性があります。たとえば、フィールド ${r.requirementName} は存在しません、といったエラーを受け取る可能性があります。ドキュメントにはフィールド ${r.reqName} があります。このフィールドを右クリックして フィールドの編集 を選択すると、参照が ${r.requirementName} のままになっていることがわかります。編集フィールド を使用して電子メール マージ フィールドを変更することを忘れないでください。

サンプル レポート

次のサンプル Word レポートでは、ステップを含む手動テストとともにレポートが表示されます。

注: このサンプルをこのままコピーして貼り付けることはできません。サンプルは、レポートのさまざまなセクションに対してレポート作成コードを使用する各種の方法を表示するように設計されています。以下に示すサンプルは、レポート テンプレート に ManualTestResults.docx という名前で含まれています。
Report generated: «${report.generatedOn}» «${report.generatedOnWeek}»
«${report.name}»

Project Name          «${report.projectName}»
Report Description    «${report.description}»
Report Executed By    «${report.executedBy}»

«[#list rows as r]»«[#assign firstRow=(r_index==0 || rows[r_index-1].ManualTestDefID != r.ManualTestDefID)]»«[#if firstRow]»

«${r.TestDefinitionName}»
«${r.TestDefinitionDescription.@html}»

Status: «${r.StatusName}»

Planned Time [hh:mm]: «[#if r.PlannedTime!="null"]»«${r.PlannedTime}»«[#else]»00:00«[/#if]»
Used Time [hh:mm]: «[#if r.UsedTime!="null"]»«${r.UsedTime}»«[#else]»00:00«[/#if]»
Build: «${r.BuildName}»
Version: «${r.VersionName}»
Execution Plan: «${r.ExecDefName}»
Changed By: «${r.ChangedBy.@text}»
Changed On: «${r.ChangedAt.@text}»

«[/#if]»«[#if r.StepName != "null"]»«[#if firstRow]» Test Step Details:«[/#if]»
Step Name: «${r.StepName}»
Description: «${r.StepDescr.@html}»
Status: «${r.StepStatus}»
Result Info: «${r.StepResultInfo.@html}»
Expected Result: «${r.ExpectedResult.@html}»
«[/#if]»«[/#list]»
親トピック: Word レポート テンプレートをカスタマイズする


レポートを表示する

それぞれのテンプレートでは役に立つグラフを作成するために特定のデータ形式を想定しているため、すべてのテンプレートをすべてのレポート クエリに適用できるわけではありません。 互換性のないレポート テンプレートを使ってレポートを生成しようとすると、エラー メッセージが返されます。 たとえば、1 行 4 値 (横棒グラフ表示) テンプレートを選択して 要件ステータス概要 レポートを表示できるのは、レポート クエリによって返される 4 つの値 ([失敗]、[成功]、[未実行]、[未カバー]) が、この Microsoft Excel のテンプレートによって厳密に要求されるためです。

レポートを生成するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーで、生成するレポートを選択します。
  3. レポート タブをクリックします。
  4. <ここをクリックすると、レポート テンプレートを選択できます> リンクをクリックします。 レポート テンプレートの選択 ダイアログ ボックスが表示されます。
  5. 使用するテンプレートを選択します。
  6. OK をクリックしてレポートを表示します。
親トピック: レポート領域


レポートを保存する

レポートをローカルに保存する方法は、BIRT のレポート テンプレートを選択している場合と Excel または Word テンプレートを選択している場合とでは異なります。 Excel テンプレートを選択した場合は、選択したレポートの プロパティ ページで Excel レポート テンプレートのダウンロード リンクをクリックします。 ローカル コンピュータで Microsoft Excel が起動し、自動的にレポートが読み込まれます。 同様に、Word を選択した場合は、サンプル Word レポート テンプレートのダウンロード をクリックします。

BIRT レポート テンプレートを選択した場合は、以下の手順を使用してレポートを保存します。

現在の BIRT レポートを PDF としてエクスポートするには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーで、保存するレポートを選択します。
  3. レポート タブをクリックします。
  4. レポート ビュー ツールバーの PDF ドキュメントで表示 をクリックします。
  5. ファイルのダウンロード ダイアログ ボックスで、保存 をクリックして、選択した場所に PDF ドキュメントを保存します。
親トピック: レポート領域


レポートをお気に入りに追加する

ブックマーク ボタンは、現在表示されているレポートを パラメータ ページで設定したパラメータを含めてお気に入りに追加します。 ブックマーク URL を別の Silk Central ユーザーに送信すると、ユーザーは 1 クリックでレポートを表示できます。

ブックマーク URL には接頭辞 rp_ が付いたパラメータが含まれます。 URL では、日付値は UTC の相関する Long 値として表されます。

親トピック: レポート領域


レポートを PDF 形式で表示する

レポート ブラウザのフレーム内で現在のレポートを PDF 形式で表示するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーで、表示するレポートを選択します。
  3. レポート タブをクリックします。
  4. レポート ビュー ツールバーの PDF ドキュメントで表示 をクリックします。 レポートが PDF 形式で表示されます。
親トピック: レポート領域


最近使った（MRU）レポートにアクセスする

最近表示されたレポートを選択するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツールバーで、最近使ったレポート リスト ボックスを展開します。
  3. 表示したいレポートを選択します。
親トピック: レポート領域


[レポート] ツールバーの機能

Silk Central > レポート

レポート ツールバーには、レポートを管理するための重要なコマンドがあります。 このツールバーには、次の項目があります。

項目 | アイコン | 説明
子フォルダの新規作成 | 子フォルダの新規作成 | 新しいレポート フォルダを作成できます。 子フォルダの新規作成 をクリックして、新しいフォルダの名前とオプションの説明を定義します。 新しいフォルダは、レポート ツリーで現在選択されているノードの子として表示されます。
子レポートの新規作成 | 子レポートの新規作成 | 新しいレポートを作成できます。 子レポートの新規作成 をクリックして、レポートの新規作成 ダイアログ ボックスで新しいレポートを定義します。 新しいレポートは、レポート ツリーで現在選択されているノードの子として表示されます。
編集 | 編集 | レポートを編集します。
削除 | 削除 | レポートを削除します。
切り取り | 切り取り | レポートを切り取り、クリップボードに追加します。
コピー | コピー | レポートをクリップボードにコピーします。
貼り付け | 貼り付け | レポートをクリップボードから レポート ツリーに貼り付けます。
子として貼り付け | 子として貼り付け | 選択したノードのサブノードとして、レポートをクリップボードから レポート ツリーに貼り付けます。
上へ移動 | 上へ移動 | レポート ツリー内でレポートを上に移動します。
下へ移動 | 下へ移動 | レポート ツリー内でレポートを下に移動します。
最近使ったレポート |  | 日時の降順で最近使った (MRU) レポートを一覧表示します。 リストからレポート名を選択すると、そのレポートが表示されます。 データ タブ、グラフ タブ、または レポート タブをクリックしてレポートにアクセスするたびに、そのレポートがリスト ボックスの先頭に追加されます。 レポートの プロパティ タブまたは パラメータ タブにアクセスしても、最近使ったレポート リスト ボックスには追加されません。 最近使ったレポート リスト ボックスは、新規ユーザーやレポートをまだ生成していないユーザーでは空になります。 このリストに表示されるレポート数は、管理者が設定できます。 詳細については、この『ヘルプ』の「管理」トピックを参照してください。
親トピック: レポート領域


レポートのプロパティ

  • レポートのプロパティを編集する
    レポートのプロパティを編集します。
  • [レポート] の [プロパティ] ページ
    選択したレポートの基本プロパティが表示されます。
親トピック: レポート領域


レポートのプロパティを編集する

レポートのプロパティを編集するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. プロパティ タブをクリックします。
  4. 編集 をクリックします。 レポートの編集 ダイアログ ボックスが表示されます。
  5. 必要に応じて、レポートの 名前、説明、タイムアウト [秒] を変更します。
  6. 他のユーザーもこのレポートを使用できるようにする場合は、このレポートを他のユーザーと共有する チェック ボックスをオンにします。
  7. デフォルト タブ リストから、状況依存のレポート リストからレポートを選択した場合に移動するタブを選択します。
  8. レポートは次の 2 つの方法で編集できます。
    • 簡易レポート：選択基準、プロパティ、演算子、値 を使用して、SQL クエリを作成します。さらに表示 をクリックすると、さらにクエリ文字列を追加したり、クエリを組み合わせる AND または OR 演算子を選択したりできます。 をクリックすると、クエリ文字列が削除されます。
    • 詳細レポート：SQL を使い慣れている場合には、クエリ コードを編集することができます。詳細クエリ モード をクリックして、レポート データ クエリ フィールド内のクエリ コードを変更します。プレースホルダの挿入 リストは、定義済みの関数プレースホルダを使用して SQL クエリを編集するときに便利です。簡易モード をクリックすると、簡易モードに戻ります。
    注: クエリの SQL コードを手作業で編集する場合は、編集後に SQL のチェック をクリックして作業を確認してください。
  9. 完了 をクリックして変更を保存します。
親トピック: レポートのプロパティ


[レポート] の [プロパティ] ページ

レポート > 詳細ビュー > プロパティ

プロパティ ページには、選択したレポートの基本プロパティが一覧表示され、これらのプロパティまたはレポート テンプレートを編集することができます。また、レポートにサブレポートを追加することもきます。

このページには、次の項目があります。

項目 | 説明
レポート名 | レポートの名前 (カスタマイズ可)。
レポート ID | システムが定義したレポートの ID。
説明 | レポートの説明 (カスタマイズ可)。
作成日時 | レポートが作成された日付。デフォルトのレポートは、データベースを作成し接続した時点で作成されます。
作成者 | レポートを作成したユーザー。デフォルトのレポートは、Admin ユーザーによって作成されます。
変更日時 | レポートが最後に変更された日時。
変更者 | レポートを最後に変更したユーザー。
レンダラ | レポートに現在割り当てられているレポート テンプレート。
[デフォルト] タブ | コンテキスト センシティブのレポート一覧からレポートを選択した場合に、ユーザーが移動するタブです。
編集 | クリックすると、レポートの編集 ダイアログ ボックスが開きます。
サブレポートの追加 | クリックすると、レポートにサブレポートを追加します。
レポート テンプレート インストール時に同梱されている利用可能なレポート テンプレート：
空の BIRT レポート テンプレートの生成
空の汎用 BIRT レポート テンプレートとしてレポート データを受け取ります。データソースはすでに構成済みです。
XLS/XLSX レポート テンプレートの生成
データを含んだシートを持つ Excel のファイルを受け取ります。図などのその他の情報を他のシートで指定できます。
Word レポート テンプレート (サンプル) のダウンロード
Word docx ファイルを受け取り、これを使用してカスタム Word レポートを作成できます。Word ファイルには、レポートに必要なデータを追加するためのテンプレートをカスタマイズする方法のサンプルが含まれています。
レポート データのダウンロード (CSV)
レポート データは CSV (Comma Separated Values) ファイルとして受け取ります。ローカルの設定によって、区切り文字は "," または ";" になります。日付もユーザーの設定に合わせた書式になります。
レポート データのダウンロード (XML)
XML としてレポート データを受け取ります。この形式が CSV よりも優れているのは、サブレポートのデータもすべて取得できる点です。Silk Central の外部のデータへのアクセス：次の書式を使うと、レポート データを提供している特定の URL を呼び出すことができます。
http://server/servicesExchange?hid=reportData&userName=<username>
&passWord=<password>&reportFilterID=<ID of the report>&type=<csv|xml>
&projectID=<ID of the project>
。
親トピック: レポートのプロパティ


レポートのパラメータ

  • レポートのパラメータを編集する
    レポートのパラメータを編集します。
  • [レポート] の [パラメータ] ページ
    カスタマイズ可能な文の要素が一覧表示されます。
親トピック: レポート領域


レポートのパラメータを編集する

レポートのパラメータを編集するには：

  1. メニューで レポート > 詳細ビュー をクリックします。
  2. レポート ツリーでレポートを選択します。
  3. パラメータ タブをクリックします。 レポートにパラメータが定義されている場合には、そのパラメータのリストが表示されます。
  4. パラメータの編集 をクリックします。 パラメータの編集 ダイアログ ボックスが表示されます。
  5. 必要に応じて、一覧表示されたパラメータの ラベル や 値 を編集します。
  6. 使用方法 リストから、パラメータの使用方法の種類を選択します。
    • 定数値
    • 開始日
    • 終了日
  7. OK をクリックします。
親トピック: レポートのパラメータ


[レポート] の [パラメータ] ページ

レポート > 詳細ビュー > パラメータ

パラメータ ページには、カスタマイズ可能な文の要素が一覧表示されます。パラメータ ページで変更するだけで、レポートを実行する前の任意のタイミングでパラメータを定義できます。パラメータの構文は ${parametername|defaultvalue|guiname} です。defaultvalue と guiname は省略可能です。パラメータ名に空白文字を含めることはできません。

レポートにパラメータが設定されている場合、レポート作成のたびに実行前にパラメータの値を編集することが可能です。パラメータの値は、現在のユーザー コンテキストに保存されます。つまり、編集した値は編集を行ったユーザーに対してのみ有効です。レポートを実行したときにパラメータの値が指定されていなければ、レポート定義のデフォルト値が使われます。

使用方法 リスト ボックスでは、パラメータの使用方法の種類を選択できます。有効な値は、[定数値]、[開始日]、[終了日] です。[開始日] と [終了日] は、特定の日付範囲をクエリするレポートでも使用されます。

レポートにサブレポートが関連付けられている場合、サブレポートのパラメータも パラメータ ページに表示され、その値は選択したレポートのコンテキストにのみ保存されます。つまり、その値は現在のサブレポート構成でのみ使用されます。新しいレポートを作成する場合には、レポートの新規作成 ダイアログ ボックスの 選択基準 領域で定義した値がパラメータになります。

親トピック: レポートのパラメータ


[レポート] の [データ] ページ

レポート > 詳細ビュー > データ

データ ページは、選択したレポートの結果を、動的にソート、フィルタすることができるグリッドで表示する、読み取り専用の結果プレビューの役割を果たします。表示できるデータは、ダウンロード データ (.xlsx) ボタンを使って Excel にエクスポートできます。

問い合わせた要件、テスト、実行計画、および Issue Manager 問題に、データ ページの結果リストから直接アクセスできます。これを行うには、クエリに ProjectID 列とリンク先要素の相応する ID を含める必要があります。
ID
説明
RequID
この列を問い合わせると、レポートの データ ページで要件へのリンクが有効になります。
TestDefID
この列を問い合わせると、レポートの データ ページでテストへのリンクが有効になります。
ExecDefID
この列を問い合わせると、レポートの データ ページで実行計画へのリンクが有効になります。
DefectID
この列を問い合わせると、レポートの データ ページで Issue Manager 問題へのリンクが有効になります。

クエリの結果に ProjectID と、RequID、TestDefID、ExecDefID または DefectID のいずれかが両方含まれており、列名としてこれらの用語を正確に使用している場合は、その要素 ID の列の値が データ ページにリンクとして表示されます。

親トピック: レポート領域


[レポート] ページ

レポート > 詳細ビュー > レポート

レポート ページは、書式設定されたレポートとしてデータを表示するために使用されます。まだ自分のレポートにテンプレートを割り当ててない場合には、レポート ページでいずれか 1 つを選択することができます。

リスト ボックスに利用可能なレポート テンプレートの選択肢が含まれます。システムによってインストールされた多数のテンプレートの他に、 管理レポート テンプレート からアップロードしたカスタム レポート テンプレートもここで利用できます。

また、プロパティ タブをクリックし、現在作業しているレポートの書式に対応するダウンロード リンクをクリックして、既存のテンプレートをダウンロードすることもできます。そのテンプレートを自分のニーズに合わせてカスタマイズしてください。

注: レポートは、レポートのパフォーマンスを向上させるため、キャッシュされます。レポート データを直ちに更新するには、更新 をクリックします。
親トピック: レポート領域


プロジェクト概要レポート

レポート > プロジェクト概要レポート

選択したプロジェクトのステータスの概要を含む プロジェクト概要レポート が表示されます。プロジェクト概要レポート には、以下のセクションがあります。

セクション | 説明
レポートの一般情報 | 作業中のプロジェクトの名前、レポートの説明、リリース予定日、といった一般的な情報。
要件 | 要件のテスト カバレッジ ステータス。すべての要件と優先度の高い要件の両方について、テスト カバレッジの割合を図表形式で表示します。
テスト | テスト タイプの分布およびテスト実行結果によって、テストの図表形式が決定されます。
親トピック: レポート領域
関連概念
プロジェクト概要レポート
コード分析


デフォルトのレポート

  • 状況依存のレポート
    動的に生成される、要件、テスト計画、実行に特有のレポート リストについて説明します。
  • 要件レポート
    要件レポートは、開発中に達成すべき機能的な要件（互換性要件、GUI 要件、機能要件など）のステータスの詳細を示します。
  • テスト レポート
    テスト関連のレポートについて説明します。
  • 実行計画レポート
    このセクションでは、実行計画関連のレポートについて説明します。
  • コンポーネントごとの問題レポート
    コンポーネントごとの問題 レポートでは、各コンポーネントに関連するすべての問題の概要を示します。
  • コード カバレッジ レポート
    コード カバレッジ レポートについて説明します。
  • パフォーマンス傾向レポート
    パフォーマンス傾向レポートは、テストのパフォーマンスにおけるアプリケーションの変化を、指定した期間にわたって示します。
  • プロジェクト概要レポート
    選択したプロジェクトのステータスの概要を示します。
親トピック: レポート


状況依存のレポート

要件、テスト計画、実行 の各領域では、各ユニット特有のレポート リストが動的に生成されて表示されます。 現在のアクティビティに直接関係した種類のレポートが表示されるため、状況依存レポート リストは有益です。

要件
要件 ツリーの状況依存レポート リストには、要件 ID を入力パラメータとして受け付けるレポートがすべて含まれます。
テスト
テスト ツリーの状況依存レポート リストには、テスト ID を入力パラメータとして受け付けるレポートがすべて含まれます。
実行
実行計画 ツリーの状況依存レポート リストには、実行計画 ID を入力パラメータとして受け付けるレポートがすべて含まれます。 実行計画の 実行 タブでは、以下の構成となっているすべてのレポートが状況依存レポート リストに表示されます。
  • 結果カテゴリ = 実行計画
  • 選択基準 = 実行計画の実行
  • プロパティ = ID

状況依存レポート リストでレポートを選択すると、画面は レポート 領域のそのレポートのデフォルト タブに直接移動します。 このデフォルトの移動先タブは、各レポートの レポートの編集 ダイアログ ボックスで構成することができます。

状況依存レポート リストに表示されるリストには、これまでにアクセスしたことのあるレポートと、まだアクセスしたことのないレポートの 2 種類があります。 これまでにアクセスしたことのあるレポートは、メニュー中の区切り線の上に表示されます。 これらのレポートの並びは年代順で、直前にアクセスしたレポートがリストの一番上に置かれます。 利用可能だけれどもまだアクセスされていない、その他のデフォルトのレポートは、区切り線の下に表示されます。

デフォルトで設定された状況依存レポートの他に、新規または既存のレポートを各領域の状況依存レポート リストに追加するよう設定することができます。 状況依存レポートへの追加は、ユーザーごと、レポートごとでしか設定できません。

  • 状況依存の実行レポートにアクセスする
    状況依存の実行計画レポートにアクセスします。
  • 状況依存の実行計画の実行レポートにアクセスする
    状況依存の実行計画の実行レポートにアクセスします。
  • 状況依存の要件レポートにアクセスする
    状況依存の要件レポートにアクセスします。
  • 状況依存のテスト レポートにアクセスする
    状況依存のテスト レポートにアクセスします。
  • 状況依存の実行レポートを有効にする
    状況依存のレポート リストで、実行計画レポートと実行計画の実行レポートの表示を有効にします。
  • 詳細な状況依存の実行レポートを有効にする
    実行計画 ツリー または 実行 ページの状況依存レポート リストで詳細レポート表示を有効にします。
  • 状況依存の要件レポートを有効にする
    状況依存のレポート リストでの要件レポート表示を有効にします。
  • 詳細な状況依存の要件レポートを有効にする
    要件 領域の状況依存レポート リストで詳細レポート表示を有効にします。
  • 状況依存のテスト レポートを有効にする
    状況依存のレポート リストでのテスト レポート表示を有効にします。
  • 詳細な状況依存のテスト レポートを有効にする
    テスト 領域の状況依存レポート リストで詳細レポート表示を有効にします。
親トピック: デフォルトのレポート


状況依存の実行レポートにアクセスする

注: 実行 領域で利用できるようにするため、状況依存のレポートとしてレポートを有効にする必要があります。

状況依存の実行計画レポートにアクセスするには：

  1. メニューで 実行計画 をクリックします。
  2. 実行計画 ツリーで実行計画を右クリックし、レポート を選択します。
  3. レポート サブメニューからレポートを選択します。

    レポート 領域の選択したレポートの パラメータ タブに移動します。ここでは、実行計画の ID が値として事前に入力されています。

    注: 各レポートの レポートの編集 ダイアログ ボックスを使用すると、対象タブのリンク動作を構成できます。
  4. 必要に応じて、レポートのパラメータを編集します。
  5. データ、レポート、または グラフ ページでレポートの設定を完成させます。
親トピック: 状況依存のレポート


状況依存の実行計画の実行レポートにアクセスする

注: 実行 領域で利用できるようにするため、状況依存のレポートとしてレポートを有効にする必要があります。

状況依存の実行計画の実行レポートにアクセスするには：

  1. メニューで 実行計画 > 詳細ビュー をクリックします。
  2. 実行 タブをクリックします。
  3. 実行を右クリックし、レポート を選択します。
  4. レポート サブメニューからレポートを選択します。

    レポート 領域の選択したレポートの パラメータ ページに移動します。ここでは、実行の ID が値として事前に入力されています。

    注: 各レポートの レポートの編集 ダイアログ ボックスを使用すると、対象タブのリンク動作を構成できます。
  5. 必要に応じて、レポートのパラメータを編集します。
  6. データ、レポート、または グラフ ページでレポートの設定を完成させます。
親トピック: 状況依存のレポート


状況依存の要件レポートにアクセスする

注: 要件 ID を入力パラメータとして受け付けるレポートに対してのみ、要件 領域で状況依存のレポートが利用できます。

状況依存の要件レポートにアクセスするには：

  1. メニューで 要件 > 詳細ビュー をクリックします。
  2. 要件 ツリーで要件を右クリックし、レポート を選択します。
  3. レポート サブメニューからレポートを選択します。

    レポート 領域の選択したレポートの パラメータ ページに移動します。ここでは、要件の ID が値として事前に入力されています。

    注: 各レポートの レポートの編集 ダイアログ ボックスを使用すると、対象タブのリンク動作を構成できます。
  4. 必要に応じて、レポートのパラメータを編集します。
  5. データ、レポート、または グラフ ページでレポートの設定を完成させます。
親トピック: 状況依存のレポート


状況依存のテスト レポートにアクセスする

注: テスト ID を入力パラメータとして受け付けるレポートに対してのみ、テスト 領域で状況依存のレポートが利用できます。

状況依存のテスト レポートにアクセスするには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. テスト ツリーまたは グリッド ビュー でテスト、フォルダ、またはテスト コンテナを右クリックし、レポート を選択します。
    注: グリッド ビュー でテストを複数選択している場合、この状況依存のレポートは無効になります。
  3. レポート サブメニューからレポートを選択します。

    レポート ユニットの選択したレポートの パラメータ ページに移動します。ここでは、テストの ID が値として事前に入力されています。

    注: 各レポートの レポートの編集 ダイアログ ボックスを使用すると、対象タブのリンク動作を構成できます。
  4. 必要に応じて、レポートのパラメータを編集します。
  5. データ、レポート、または グラフ ページでレポートの設定を完成させます。
親トピック: 状況依存のレポート


状況依存の実行レポートを有効にする

状況依存のレポート リストで、実行計画レポートと実行計画の実行レポートの表示を有効にする方法について説明します。

実行 ツリー または 実行 ページの状況依存レポート リストで簡易レポート表示を有効にするには：

  1. レポートを新規作成します。 その他の情報については、「新しいレポートを作成する」を参照してください。
  2. 結果カテゴリ リスト ボックスから、実行計画 を選択します。
  3. 状況依存レポートの 選択基準 を選択します。
  4. プロパティ リスト ボックスから、ID を選択します。
  5. 値 フィールドに値を入力します。 たとえば、既存の実行計画や既存の実行計画実行の ID 番号を入力します。
  6. 完了 をクリックします。
親トピック: 状況依存のレポート
関連タスク
新しいレポートを作成する


詳細な状況依存の実行レポートを有効にする

実行計画 ツリー または 実行 ページの状況依存レポート リストで詳細レポート表示を有効にします。

  1. 以下のいずれかを含むレポートを作成します。
    • 実行計画の ID を、実行計画 ツリーに表示されるレポートの入力パラメータとして。
    • 実行計画の実行 ID を、実行 ページに表示されるレポートの入力パラメータとして。

    その他の情報については、「新しいレポートを作成する」と「SQL で高度なクエリを作成する」を参照してください。

  2. 実行 領域のコンテキスト メニューで詳細クエリを利用可能にするには、パラメータ名 execProp_Id_0 を ExecDef_ID_pk_fk の入力として挿入します。 たとえば、レポートの SQL 文には、データベースカラムの値が ExecDef_ID_pk_fk = 68 のようにハードコードで定義されているとします。列名の値を動的に受け付けるようにこのレポートを編集するには、${execProp_Id_0 | 68} で静的な値 68 を置き換えます。
親トピック: 状況依存のレポート
関連タスク
新しいレポートを作成する
SQL で高度なクエリを作成する


状況依存の要件レポートを有効にする

状況依存のレポート リストで要件レポート表示を有効にする方法について説明します。

要件 領域の状況依存のレポート リストで簡易レポート表示を有効にするには：

  1. レポートを新規作成します。 その他の情報については、「新しいレポートを作成する」を参照してください。
  2. 結果カテゴリ リスト ボックスから、要件 を選択します。
  3. 状況依存レポートの 選択基準 を選択します。
  4. 値 フィールドに値を入力します。 たとえば、既存の要件の ID 番号を入力します。
親トピック: 状況依存のレポート
関連タスク
新しいレポートを作成する


詳細な状況依存の要件レポートを有効にする

要件 領域の状況依存レポート リストで詳細レポート表示を有効にするには：

  1. 入力パラメータとして要件 ID を含むレポートを作成します。

    その他の情報については、「新しいレポートを作成する」と「SQL で高度なクエリを作成する」を参照してください。

  2. 要件 ユニットのコンテキスト メニューで詳細クエリを利用可能にするには、パラメータ名 reqProp_Id_0 を Req_ID_pk_fk の入力として挿入します。 たとえば、レポートの SQL 文には、データベースカラムの値が Req_ID_pk_fk = 68 のようにハードコードで定義されているとします。列名の値を動的に受け付けるようにこのレポートを編集するには、${reqProp_Id_0 | 68} で静的な値 68 を置き換えます。
親トピック: 状況依存のレポート
関連タスク
新しいレポートを作成する
SQL で高度なクエリを作成する


状況依存のテスト レポートを有効にする

状況依存のレポート リストでテスト レポート表示を有効にする方法について説明します。

テスト 領域の状況依存のレポート リストで簡易レポート表示を有効にするには：

  1. レポートを新規作成します。 その他の情報については、「新しいレポートを作成する」を参照してください。
  2. 結果カテゴリ リスト ボックスから、テスト を選択します。
  3. 状況依存レポートの 選択基準 を選択します。
  4. 値 フィールドに値を入力します。 たとえば、既存のテストの ID 番号を入力します。
親トピック: 状況依存のレポート
関連タスク
新しいレポートを作成する


詳細な状況依存のテスト レポートを有効にする

テスト 領域の状況依存レポート リストで詳細レポート表示を有効にするには：

  1. 入力パラメータとしてテスト ID、テスト フォルダ ID、またはテスト コンテナ ID を含むレポートを作成します。

    その他の情報については、「新しいレポートを作成する」と「SQL で高度なクエリを作成する」を参照してください。

  2. テスト 領域のコンテキスト メニューで詳細クエリを利用可能にするには、パラメータ名 tdProp_Id_0 をテスト ID の入力として、または tfProp_Id をテスト フォルダ ID またはテスト コンテナ ID の入力として挿入します。 たとえば、レポートの SQL 文には、データベースカラムの値が TestDef_ID_pk_fk = 68 のようにハードコードで定義されているとします。列名の値を動的に受け付けるようにこのレポートを編集するには、${tdProp_Id_0 | 68} で静的な値 68 を置き換えます。
親トピック: 状況依存のレポート
関連タスク
新しいレポートを作成する
SQL で高度なクエリを作成する


実行計画レポート

このセクションでは、Silk Central に同梱されている実行計画レポートについて説明します。結果をより簡単に評価できるようにするため、実行計画レポートでは、一定の期間または一定のビルドにおける、テスト実行の進捗や問題のステータスの詳細なサマリーが提供されます。

  • 実行計画の実行の比較レポート
    実行計画の実行の比較レポートは、2 つの実行計画の実行結果を比較し、概要を提示します。
  • 実行計画の実行エラー レポート
    実行計画の 実行エラー レポートには、実行計画の実行が成功しなかったすべてのテストの詳細リストと、成功しなかった理由が表示されます。
  • 合格しなかったテスト レポート
    合格しなかったテスト レポートには、実行 領域内のフォルダまたはプロジェクトの合格しなかったすべてのテストの概要が表示されます。
  • 実行計画ごとの合格しなかったテスト レポート
    実行計画ごとの合格しなかったテスト レポートには、すべての合格しなかったテストの概要が、実行 領域内の構成スイートの構成ごと、あるいはフォルダまたはプロジェクトの実行計画ごとに表示されます。
  • 実行ステータスの概要レポート
    実行ステータスの概要 レポートは、選択されたノードにの実行計画に割り当てられたすべてのテストの最新の実行ステータスの概要を表示します。
親トピック: デフォルトのレポート


実行計画の実行の比較レポート

実行計画の実行の比較レポートは、2 つの実行計画の実行結果を比較し、概要を提示します。
注: 実行の比較レポートは、手動テストを自動テストに対して比較するのには向いていません。レポートの名前に「(前回と前々回の実行)」が含まれている場合、実行計画またはテストの、最新の 2 つの実行のみの比較となります。
次のレポートは、2 つの実行計画の実行結果を比較します。
実行計画の実行の比較レポート

2 つの実行計画の実行結果を比較する、デフォルトの実行計画の実行の比較レポート。

実行計画の実行の比較 - ステータス変更

2 つの実行計画の実行の、ステータスが変更されたテストのみを比較します。

実行計画の実行の比較 - 新しい方の実行で失敗

2 つの実行計画の実行の、失敗したテストのみを比較します。

実行計画の実行の比較レポートには、以下の情報が表示されます。
  • 実行計画のステータスに対する変更
  • エラーの数
  • 警告の数
  • 実行計画が実行されたコンテキスト
  • 割り当てられたテストの実行時間
注: 割り当てられたテストのステータスが比較されている実行間で [失敗] に変更された場合、テストは赤でマークされます。割り当てられたテストのステータスが比較されている実行間で [成功] に変更された場合、テストは緑でマークされます。
親トピック: 実行計画レポート


実行計画の実行エラー レポート

実行計画の 実行エラー レポートには、実行計画の実行が成功しなかったすべてのテストの詳細リストと、成功しなかった理由が表示されます。

実行計画を走らせている間に発生したすべてのエラーが、このレポート内に一覧表示されます。ユーザーは、結果を迅速に評価することができ、実行計画の実行中に発生した望ましくない結果を簡単に判断することができます。実行計画の 実行エラー レポートの入力パラメータは、実行される実行計画の識別子です。

親トピック: 実行計画レポート


合格しなかったテスト レポート

合格しなかったテスト レポートには、実行 領域内のフォルダまたはプロジェクトの合格しなかったすべてのテストの概要が表示されます。

このレポートは、構成のテスト時などに、エラー分析のために使用できます。合格しなかったテスト レポートの入力パラメータは、構成スイート、フォルダ、またはプロジェクトの識別子です。

親トピック: 実行計画レポート


実行計画ごとの合格しなかったテスト レポート

実行計画ごとの合格しなかったテスト レポートには、すべての合格しなかったテストの概要が、実行 領域内の構成スイートの構成ごと、あるいはフォルダまたはプロジェクトの実行計画ごとに表示されます。

このレポートは、構成のテスト時などに、エラー分析のために使用できます。実行計画ごとの合格しなかったテスト レポートの入力パラメータは、構成スイート、フォルダ、またはプロジェクトの識別子です。

親トピック: 実行計画レポート
関連タスク
状況依存の実行レポートにアクセスする


実行ステータスの概要レポート

実行ステータスの概要 レポートは、選択されたノードにの実行計画に割り当てられたすべてのテストの最新の実行ステータスの概要を表示します。

実行ステータスの概要 レポートの入力パラメータは、実行計画 ツリーにあるノードの識別子です。

親トピック: 実行計画レポート


コンポーネントごとの問題レポート

コンポーネントごとの問題 レポートでは、各コンポーネントに関連するすべての問題の概要を示します。

このレポートは、基本的な問題追跡ができるだけでなく、各コンポーネントの問題の全体傾向を監視する上でも役に立ちます。

親トピック: デフォルトのレポート


コード カバレッジ レポート

このセクションでは、Silk Central に同梱されているコード カバレッジ レポートについて説明します。 コード カバレッジ レポートは、一定期間もしくは一定の範囲のビルドにおける、製品のコード カバレッジについての詳細情報を提供します。

  • コード変更影響度レポート
    テスト影響度分析、労力分析、リスク分析を行うことができます。
  • コード カバレッジ傾向レポート
    1 つの製品メソッド、クラス、およびパッケージに対するコード カバレッジの改善傾向を、選択した範囲の一連のビルドに渡って表示します。
  • メソッド カバレッジ比較レポート
    2 つの製品ビルドに含まれているすべてのパッケージ/名前空間に対するメソッド カバレッジを比較します。
親トピック: デフォルトのレポート


コード変更影響度レポート

コード変更影響度レポートを使用すると、テスト影響度分析、労力分析、リスク分析を行うことができます。分析対象となるクラスを選択し、レポート テンプレートを適用することで、選択したクラスの変更がテストにどのような影響を与えるかを判断する上で役に立つレポートを生成することができます。 選択したクラスに対して、コード変更によるテストへの影響を分析するレポート テンプレートを選択することができます。

コード変更影響度 - テスト レポートは、コード変更後に再実行が必要なテストを特定するのに役に立ちます。カバレッジの指標として、このテストでカバーされた指定したクラスのメソッドの数 / 指定したクラスのメソッドの総数が表示されます。

コード変更影響度 - 実行計画 レポートは、コード変更後に再実行が必要な実行計画を特定するのに役に立ちます。

レポートの使用例

以下のコード変更影響度に関する一般的な問題は、コード変更影響度レポートで対処できます。
テスト影響度分析
コードに特定の変更を加えた結果、どのテストを実行することが必要となるかを確認する場合。
  • 特定のクラスを選択します。
  • コード変更影響度 - テスト レポートを選択して実行します。
  • このバージョンで影響を受けたクラスをカバーしているテストの一覧を確認します。
労力分析
一連のコード変更を適切にカバーするのに必要な、自動テストおよび手動テストの時間を確認する場合。
  • 特定のクラスを選択します。
  • コード変更影響度 - 実行計画 レポートを選択して実行します。
  • 自動テストおよび手動テストの所要時間（コスト）を確認します。
親トピック: コード カバレッジ レポート


コード カバレッジ傾向レポート

1 つの製品メソッド、クラス、およびパッケージに対するコード カバレッジの改善傾向を、選択した範囲の一連のビルドに渡って表示します。

コード カバレッジ傾向グラフ

選択した製品のコード カバレッジの総合的な割合を、選択した範囲の一連のビルドに渡って表示します。特定のパッケージ/名前空間、クラス、およびメソッドのコード カバレッジが、個々に表示されます。

コード カバレッジ傾向の詳細

コード カバレッジ傾向グラフ からの情報を、表形式で表示します。

親トピック: コード カバレッジ レポート


メソッド カバレッジ比較レポート

2 つの製品ビルドに含まれているすべてのパッケージ/名前空間に対するメソッド カバレッジを比較します。

Threshold パラメータを使用して、レポートに表示されるパッケージ/名前空間の、結果の変更量の最小値を指定します。変更の割合がより少ないパッケージ/名前空間が、レポートに表示されなくなります。この閾値の範囲は、0 から 100 パーセントです。

親トピック: コード カバレッジ レポート


パフォーマンス傾向レポート

パフォーマンス傾向レポートは、テストのパフォーマンスにおけるアプリケーションの変化を、指定した期間にわたって示します。

パフォーマンス レポートの入力データは、Silk Performer の負荷テストから提供されます。

  • 平均ページ時間傾向レポート
    指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、ページ当たりのページ時間を示します。
  • 平均トランザクション ビジー時間傾向レポート
    指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、トランザクション当たりのトランザクションのビジー時間を示します。
  • 総ページ時間傾向レポート
    指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、すべてのユーザー タイプで集計された、総ページ時間を示します。
  • 総トランザクション ビジー時間傾向レポート
    指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、すべてのユーザー タイプで集計された、総トランザクションのビジー時間を示します。
  • カスタム測定値傾向レポート
    指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、定義 (複数) 測定値の平均、最小、最大値を示します。
親トピック: デフォルトのレポート


平均ページ時間傾向レポート

指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、ページ当たりのページ時間を示します。テストされたページに対するページ時間のパフォーマンス傾向が、グラフで表示されます。

入力パラメータ

平均ページ時間傾向 レポートの入力パラメータは、次のとおりです。
パラメータ
説明
Date From (DD-MON-YYYY)
時間範囲の開始日。たとえば、06-DEZ-2008。
Date To (DD-MON-YYYY)
時間範囲の終了日。たとえば、16-JAN-2009。
Exclude Runs with more than <nnn> Errors
ここで指定された数値以上のエラーを発生させた実行を、レポートから除外します。この設定は、異常値が傾向曲線をゆがめてしまうのを避けるために使用します。
Maximum Value for y-Axis
グラフの Y 軸を指定値までに制限します。この値を超えるトランザクション ビジー時間は、上部でカットされます。この設定は、異常時によって発生する線の平坦化をさけるのに役立ちます。
Measure Filter
指定した文字列が名前に含まれているもののみに、測定値を絞ります。このフィールドへの入力は必須です。利用可能なすべての測定値を表示するには、この測定値フィルタに % を設定します。たとえば、名前のいずれかの箇所に単語「unit」を含む測定値のみを表示する場合には、測定値フィルタに %unit% と設定します。
Test ID
レポートを表示させたいテストの識別子。
親トピック: パフォーマンス傾向レポート


平均トランザクション ビジー時間傾向レポート

指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、トランザクション当たりのトランザクションのビジー時間を示します。テストされたトランザクションに対するトランザクション ビジー時間のパフォーマンス傾向が、グラフで表示されます。

入力パラメータ

平均トランザクション ビジー時間傾向 レポートの入力パラメータは、次のとおりです。
パラメータ
説明
Date From (DD-MON-YYYY)
時間範囲の開始日。たとえば、06-DEZ-2008。
Date To (DD-MON-YYYY)
時間範囲の終了日。たとえば、16-JAN-2009。
Exclude Runs with more than <nnn> Errors
ここで指定された数値以上のエラーを発生させた実行を、レポートから除外します。この設定は、異常値が傾向曲線をゆがめてしまうのを避けるために使用します。
Maximum Value for y-Axis
グラフの Y 軸を指定値までに制限します。この値を超えるトランザクション ビジー時間は、上部でカットされます。この設定は、異常時によって発生する線の平坦化をさけるのに役立ちます。
Test ID
レポートを表示させたいテストの識別子。
Transaction Filter
指定した文字列が名前に含まれているもののみに、トランザクションを絞ります。このフィールドへの入力は必須です。利用可能なすべてのトランザクションを表示させるには、このトランザクション フィルタに % を設定します。たとえば、名前のいずれかの箇所に単語「unit」を含むトランザクションのみを表示させる場合には、トランザクション フィルタに %unit% と設定します。
親トピック: パフォーマンス傾向レポート


総ページ時間傾向レポート

指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、すべてのユーザー タイプで集計された、総ページ時間を示します。テストされたページに対するページ時間のパフォーマンス傾向が、グラフで表示されます。

入力パラメータ

総ページ時間傾向 レポートの入力パラメータは、次のとおりです。
パラメータ
説明
Date From (DD-MON-YYYY)
時間範囲の開始日。たとえば、06-DEZ-2008。
Date To (DD-MON-YYYY)
時間範囲の終了日。たとえば、16-JAN-2009。
Exclude Runs with more than <nnn> Errors
ここで指定された数値以上のエラーを発生させた実行を、レポートから除外します。この設定は、異常値が傾向曲線をゆがめてしまうのを避けるために使用します。
Maximum Value for y-Axis
グラフの Y 軸を指定値までに制限します。この値を超えるトランザクション ビジー時間は、上部でカットされます。この設定は、異常時によって発生する線の平坦化をさけるのに役立ちます。
Test ID
レポートを表示させたいテストの識別子。
親トピック: パフォーマンス傾向レポート


総トランザクション ビジー時間傾向レポート

指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、すべてのユーザー タイプで集計された、総トランザクションのビジー時間を示します。テストされたトランザクションに対するトランザクション ビジー時間のパフォーマンス傾向が、グラフで表示されます。

入力パラメータ

総トランザクション ビジー時間傾向 レポートの入力パラメータは、次のとおりです。
パラメータ
説明
Date From (DD-MON-YYYY)
時間範囲の開始日。たとえば、06-DEZ-2008。
Date To (DD-MON-YYYY)
時間範囲の終了日。たとえば、16-JAN-2009。
Exclude Runs with more than <nnn> Errors
ここで指定された数値以上のエラーを発生させた実行を、レポートから除外します。この設定は、異常値が傾向曲線をゆがめてしまうのを避けるために使用します。
Maximum Value for y-Axis
グラフの Y 軸を指定値までに制限します。この値を超えるトランザクション ビジー時間は、上部でカットされます。この設定は、異常時によって発生する線の平坦化をさけるのに役立ちます。
Test ID
レポートを表示させたいテストの識別子。
親トピック: パフォーマンス傾向レポート


カスタム測定値傾向レポート

指定した時間の範囲内で、対象テストに対して実行されたすべてのテストの、定義 (複数) 測定値の平均、最小、最大値を示します。テストされた測定値それぞれに対して値のパフォーマンス傾向が、グラフで表示されます。

入力パラメータ

カスタム測定値傾向 レポートの入力パラメータは、次のとおりです。
パラメータ
説明
Date From (DD-MON-YYYY)
時間範囲の開始日。たとえば、06-DEZ-2008。
Date To (DD-MON-YYYY)
時間範囲の終了日。たとえば、16-JAN-2009。
Exclude Runs with more than <nnn> Errors
ここで指定された数値以上のエラーを発生させた実行を、レポートから除外します。この設定は、異常値が傾向曲線をゆがめてしまうのを避けるために使用します。
Maximum Value for y-Axis

グラフの Y 軸を指定値までに制限します。この値を超える測定値は、上部でカットされます。この設定は、異常時によって発生する線の平坦化をさけるのに役立ちます。

Measure Name

レポートを表示させたいカスタム測定値の名前。例：CreateTestDefinition。

Measure Type

カスタム測定値のタイプ。例：Transaction(BusyTime)[s]。

Test ID
レポートを表示させたいテストの識別子。
親トピック: パフォーマンス傾向レポート


管理

Silk Central の初期設定（インスタンス構成）が完了したら、次のセクションに従って、ユーザー アカウント、プロジェクト、ロケーション、実行サーバーなどのセットアップに必要なステップを実行できます。この作業は、管理者が実行する必要があります。
  • ユーザー ロールとアクセス許可
    Silk Central で各種ユーザー ロールおよびアクセス許可を使用する方法について説明します。
  • ユーザー アカウントとグループ
    Silk Central におけるユーザー アカウントとグループの概念的な背景について説明します。
  • 実行環境
    Silk Central の実行環境の概念的な背景について説明します。
  • レポート テンプレートを管理する
    Silk Central でレポート テンプレートを使用する方法について説明します。
  • 監査ログ
    管理者が監査ログを使用して、Silk Central ユーザーの記録されている全アクティビティを確認する方法について説明します。
  • サーバー ログ ファイル
    サーバー ログ ファイルは、エラー分析のための貴重な情報を管理者に提供します。
  • タスク管理ツールを統合する
    外部のタスク管理ツールと Silk Central を統合する方法について説明します。
  • 製品、コンポーネント、バージョン、ビルドを管理する
    製品、製品コンポーネント、製品バージョン、および製品バージョンのビルド番号を作成および整理する方法について説明します。
  • 値リストをメンテナンスする
    値リストを使用して、Issue Manager 向けに構成できる [問題のカスタム タブ] のカスタム プロパティに値を設定する方法について説明します。
  • グローバル スケジュールを設定する
    実行計画のスケジュールを設定するために Silk Central で再利用できるグローバル スケジュールを定義する方法について説明します。
  • タイム ゾーン
    Silk Central でのタイム ゾーンの処理について説明します。
  • プロジェクトを管理する
    Silk Central のプロジェクトは、通常、会社のソフトウェア プロジェクトを反映したもので、開発チームの作業それぞれに対して、共通のリリース日、ソース管理システム、要件などがあります。
  • 統合
    Silk Central で利用可能な統合について説明します。
親トピック: Silk Central ヘルプ


ユーザー ロールとアクセス許可

Silk Central で作業する場合は、割り当てられたプロジェクトへのアクセス権を持つユーザーの グループ に、タスクが割り当てられます。 グループ内では、ユーザーは、それらのプロジェクト内の特定のロールを許可されます。 ユーザーのアクセス許可は、ユーザー ロールのタイプと、所属するグループに基づいて設定されます。 ここでは、アクセス許可のタイプを定義し、ユーザー ロールに関連付けられた特定のアクセス許可の詳細について説明します。

各ユーザー アカウントは、1 つ以上のグループに所属できます。 1 つのグループでは、そのグループ内のユーザーが持つロールが定義されています。 グループはプロジェクトに割り当てられます。 したがって、個々のユーザーが持つアクセス許可は、プロジェクトに対して定義されているグループ/ロール割り当てから継承されます。 定義済みのアクセス許可は、各ユーザーのグループ/ロール割り当てを含むグループに割り当てられたプロジェクトにのみ適用されます。

  • ユーザー ロール
    Silk Central で利用できるユーザー ロールについて説明します。
  • アクセス許可の定義
    ユーザーがタスクを実行したり、Silk Central 内のセキュアな領域にアクセスできるかどうかを決定するアクセス許可について説明します。
親トピック: 管理
関連概念
グループをメンテナンスする
ロケーションを管理する
スーパー ユーザー
ユーザー ロール
関連タスク
プロジェクトを追加する
Issue Manager プロジェクトとしてプロジェクトを初期化する
プロジェクトとプロジェクト ベースラインを編集する


ユーザー ロール

次のユーザー ロールは Silk Central であらかじめ定義されています。
  • スーパーユーザー
  • システム管理者
  • プロジェクト マネージャ
  • テスト管理者
  • テスト担当者
  • アナリスト
  • 報告者
  • ロール割り当て管理者

これらのロールを変更したり削除することはできません。ただし、これらのロールをコピーして、ロールをカスタマイズする際のベースとして使用することはできます。

スーパーユーザー

スーパーユーザー ロールは、Silk Central の全アプリケーションにて、すべての権限が許可される特殊なロールです。

システム管理者

システム管理者のタスクには、アプリケーション サーバー、Web サーバー、チャート サーバーのロケーションの構成、リポジトリと通知設定のセットアップと管理、アカウントの作成、ロケーションと実行サーバーの構成などが含まれます。

システム管理者には、Silk Central および Issue Manager のすべての権限が許可されています。

プロジェクト マネージャ

プロジェクト マネージャは、担当するプロジェクトを管理します。プロジェクト マネージャには、Silk Central 管理 ユニットへの書き込みアクセス権限はありません。プロジェクト マネージャは、プロジェクト マネージャとして自分に割り当てられたプロジェクトにのみアクセスでき、 担当するプロジェクトについては、プロジェクトに関連するすべての機能への完全な書き込みアクセス権限を持ちます。また、プロジェクト マネージャは、自分に割り当てられたプロジェクトについては、Issue Manager のすべてのアクセス許可を持ちます。

テスト管理者

テスト管理者の責務には、テストの計画と実行が含まれます。これには、テストの削除も含まれます。また、テスト管理者は、Silk Central の共有ステップやキーワードのライブラリ への完全なアクセス権限と、要件 領域への完全な読み取りアクセス権限も持ちます。

テスト担当者

テスト担当者ロールは、Silk Central の権限に関係します。テスト担当者のタスクには、テストの計画と実行が含まれますが、テスト担当者はテストを削除することはできません。また、テスト担当者は、要件 領域への完全な読み取りアクセス権限を持ち、共有ステップやキーワードのライブラリのすべてのオブジェクトを表示、作成、および編集することもできます。

アナリスト

アナリストは、自分に割り当てられたプロジェクトの結果を分析します。プロジェクト設定やスケジュールを変更することはできず、読み取り専用の権限を持ちます。

報告者

報告者には、アナリスト のすべての権限に加えて、詳細クエリ モードでレポートを編集および削除する権限があります。詳細モードでは、報告者は、詳細レポート用の SQL 文の入力、変更、および削除ができます。詳細レポートの詳細については、Silk Central ヘルプを参照してください。

ロール割り当て管理者

ロール割り当て管理者は、グループの既存のユーザーへのロールの割り当ておよび解除を行うためのアクセス許可を持ちます。割り当てを行えるのは、自身に割り当てられているロールだけです。グループにメンバーを追加したり削除することはできません。自身がロール割り当て管理者として定義されているグループ内のロール割り当てだけを変更できます。

  • ユーザー ロールを追加する
    新しいユーザー ロールを追加します。
  • ユーザー ロールを編集する
    ユーザー ロールを編集します。
  • ユーザー ロールをコピーする
    ユーザー ロールをコピーして、カスタム ユーザー ロールを作成します。
  • ユーザー ロールを削除する
    ユーザー ロールを削除します。
  • [ロールの設定] ページ
    ユーザー ロールの設定に使用します。
親トピック: ユーザー ロールとアクセス許可
関連概念
スーパー ユーザー
ユーザー ロールとアクセス許可


ユーザー ロールを追加する

ユーザー ロールを追加するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. ロール タブをクリックします。
  3. ロールの新規作成 をクリックします。

    新しいロールの追加 ページが表示されます。

  4. 名前 に新しいロール名を入力します。
  5. 省略可能：説明 にロールの説明を入力します。
  6. アクセス許可の設定 リストで、このロールに付与するすべてのアクセス許可の 許可 フィールドをオンにします。
    注: 最上位レベルの親タスクを選択すると、自動的にその親タスクのすべての子タスクが選択されます。親タスクの (すべてではなく) 一部の子タスクを選択した場合、親タスクには薄いグレーのチェック マークが付けられます。これは、その部分に関しては限定的なアクセス許可であることを示します。
  7. 保存 をクリックして、このロールのアクセス許可設定を保存します。
親トピック: ユーザー ロール


ユーザー ロールを編集する

注: あらかじめ定義されているユーザー ロールは編集できません。 カスタム ユーザー ロールは編集できます。

ユーザー ロールを編集するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. ロール タブをクリックします。
  3. ロール リストで、編集するロールの名前をクリックします。

    ロールの編集 ページが表示されます。

  4. ロールの 名前 を必要に応じて編集します。
  5. ロールの 説明 を必要に応じて編集します。
  6. アクセス許可の設定 リストで、このロールに付与するすべてのアクセス許可の 許可 チェック ボックスをオンにします。 このロールに付与しないアクセス許可のチェック ボックスをオフにします。
    注: 最上位レベルの親タスクを選択すると、自動的にその親タスクのすべての子タスクが選択されます。親タスクの (すべてではなく) 一部の子タスクを選択した場合、親タスクには薄いグレーのチェック マークが付けられます。これは、その部分に関しては限定的なアクセス許可であることを示します。
  7. 保存 をクリックして、このロールのアクセス許可設定を保存します。
親トピック: ユーザー ロール


ユーザー ロールをコピーする

ヒント: 既存のユーザー ロールをコピーすることは、カスタム ユーザー ロールを作成するための最初の手順です。 既存のロールをコピーしたら、名前を変更し、必要に応じてアクセス許可を編集します。

ユーザー ロールをコピーするには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. ロール タブをクリックします。
  3. コピーするユーザー ロールの アクション 列で、ロールの複製 をクリックします。 そのロールのコピーが、ユーザー ロールのリストに表示されます。コピーされたロールの名前を変更して、必要に応じてカスタマイズすることができます。
親トピック: ユーザー ロール


ユーザー ロールを削除する

注: あらかじめ定義されているユーザー ロールは削除できません。 カスタム ユーザー ロールは削除できます。

ユーザー ロールを削除するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. ロール タブをクリックします。
  3. 削除するユーザー ロールの アクション 列で、削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックすると操作が続行され、いいえ をクリックすると中止されます。 はい を選択した場合は、ユーザー ロールのリストに戻ります。削除したロールは表示されません。
親トピック: ユーザー ロール


[ロールの設定] ページ

管理 > ユーザー管理 > ロール

ロールの設定 ページは、ユーザー ロールの設定に使用します。このページには、次の項目があります。

項目 | 説明
アクション | ロールの複製 をクリックして、ロールを複製します。複製したロールを基礎として新しいカスタム ロールを作成できます。 ロールの削除 をクリックして、ユーザー ロールを削除します。
名前 | GUI に表示されるユーザー ロール名。
新しい割り当てを許可 | 既存のユーザー ロールへの新しいユーザーの割り当てを許可または禁止する場合にクリックします。ユーザー ロールの使用を中止したときに、一部のユーザー アカウントがまだそのロールを保持している場合に役に立ちます。
説明 | ユーザー ロールの説明。
作成日時 | ロールが作成された日時。
作成者 | ロールを作成したユーザー。
親トピック: ユーザー ロール


アクセス許可の定義

Silk Central でアクセス許可を表示するには：メニューで、管理 > ユーザーの管理 をクリックします。 ロール タブをクリックします。 グリッド内のロールをクリックします。 そのロールのアクセス許可が表示されます。

ここでは、ユーザーがタスクを実行したり、Silk Central 内のセキュアな領域にアクセスできるかどうかを決定するアクセス許可について説明します。 アクセス許可カテゴリごとにリストが分かれています。

注: 定義済みロールのアクセス許可を編集することはできません。
  • 要件のアクセス許可
    要件に利用可能なアクセス許可を一覧表示します。
  • ライブラリのアクセス許可
    ライブラリに利用可能なアクセス許可を一覧表示します。
  • テストと実行のアクセス許可
    テストと実行に利用可能なアクセス許可を一覧表示します。
  • 手動実行計画のアクセス許可
    手動実行計画で利用可能なアクセス許可を一覧表示します。
  • 問題のアクセス許可
    問題に利用可能なアクセス許可を一覧表示します。
  • 品質目標のアクセス許可
    品質目標に利用可能なアクセス許可を一覧表示します。
  • レポートのアクセス許可
    レポートに利用可能なアクセス許可の一覧を提供します。
  • プロジェクトのアクセス許可
    プロジェクトに利用可能なアクセス許可を一覧表示します。
  • プロジェクト設定のアクセス許可
    プロジェクト設定に利用可能なアクセス許可を一覧表示します。
  • 管理用のアクセス許可
    管理に利用できるアクセス許可の一覧を示します。
  • ダッシュボード パネルのアクセス許可
    特定のパネルの内容を表示、編集するのに必要なアクセス許可を説明します。
親トピック: ユーザー ロールとアクセス許可
関連資料
クライアントのアクセス許可


要件のアクセス許可

要件に利用可能なアクセス許可は以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
要件の表示 |  | X |  | X | X | X | X
要件の管理 |  | X |  |  |  |  |
要件の削除 |  | X |  |  |  |  |
要件管理インテグレーションの管理 |  | X |  |  |  | X |
要件管理インテグレーションの削除 |  | X |  |  |  |  |
親トピック: アクセス許可の定義


ライブラリのアクセス許可

ライブラリに利用可能なアクセス許可は以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
ライブラリの表示 |  | X |  | X | X | X | X
ライブラリの管理 |  |  |  |  | X | X |
ライブラリの削除 |  |  |  |  |  | X |
親トピック: アクセス許可の定義


テストと実行のアクセス許可

テストと実行に利用可能なアクセス許可は以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
資産の表示 |  | X |  | X | X | X | X
資産の管理 |  |  |  |  | X | X |
資産の削除 |  |  |  |  |  | X |
実行の開始 |  |  |  |  | X | X |
実行の完了 |  |  |  |  | X | X |
テストの実行 |  |  |  |  | X | X |
手動テストの実行の同期 |  |  |  |  | X | X |
実行計画の実行の削除 |  |  |  |  | X | X |
ソース管理インテグレーションの管理 |  | X |  |  |  | X |
ソース管理インテグレーションの削除 |  | X |  |  |  | X |
親トピック: アクセス許可の定義


手動実行計画のアクセス許可

手動実行計画で利用可能なアクセス許可は以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
テスト サイクルと構成の表示 |  | X |  | X | X | X | X
テスト サイクルと構成の管理 |  |  |  |  |  | X |
テスト サイクルと構成の削除 |  |  |  |  |  | X |
親トピック: アクセス許可の定義


問題のアクセス許可

問題に利用可能なアクセス許可は以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
問題追跡インテグレーションの管理 |  | X |  |  |  | X |
問題追跡インテグレーションの削除 |  | X |  |  |  | X |
親トピック: アクセス許可の定義


品質目標のアクセス許可

品質目標に利用可能なアクセス許可は、以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
品質目標の表示 |  | X |  | X | X | X | X
品質目標の管理 |  | X |  |  |  | X |
品質目標の削除 |  | X |  |  |  | X |
親トピック: アクセス許可の定義


レポートのアクセス許可

レポートに利用可能なアクセス許可は以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
レポートの表示 |  | X |  | X | X | X | X
レポートの管理 |  | X |  |  | X | X | X
詳細レポートの管理 |  |  |  |  |  |  | X
レポートの削除 |  | X |  |  | X | X | X
共有グローバル レポートの管理 |  |  |  |  |  |  | X
共有グローバル レポートの削除 |  |  |  |  |  |  | X

共有グローバル レポートのアクセス許可

共有グローバル レポートは、すべてのユーザーのすべてのプロジェクトで利用可能であるため、更新したり削除したりできるユーザー ロールとして、共有グローバル レポートの管理 および 共有グローバル レポートの削除 の特別なアクセス許可が必要です、共有グローバル レポートで使用するレポート テンプレートに対しても、これらのアクセス許可が適用されます。非共有グローバル レポートとレポート テンプレートは、レポートの更新や削除といった標準レポートのアクセス許可を持つユーザー ロールによって更新および削除することができます。これは次の特殊なシナリオを生じさせます。
  • オプション このレポートを他のユーザーと共有する は、ユーザーが 共有グローバル レポートの管理 アクセス権を持たない場合、グローバル レポートとフォルダでは無効化されます。
  • コピーした共有レポートを グローバル レポート ツリーに貼り付けるときに、共有グローバル レポートの管理 アクセス権を持たない場合は、貼り付けたレポートは非共有に設定されます。
親トピック: アクセス許可の定義


プロジェクトのアクセス許可

プロジェクトに利用可能なアクセス許可は以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
プロジェクトの管理 |  | X |  |  |  | X |
プロジェクトの削除 |  | X |  |  |  | X |
親トピック: アクセス許可の定義


プロジェクト設定のアクセス許可

プロジェクト設定に利用可能なアクセス許可は以下のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
プロジェクト設定の表示 |  | X |  | X | X | X | X
プロジェクト設定の管理 |  | X |  |  | X | X |
プロジェクト設定の削除 |  | X |  |  |  | X |
フィルタの管理 |  | X |  |  | X | X |
フィルタの削除 |  | X |  |  | X | X |
他のユーザーの非公開フィルタの編集 |  | X |  |  |  | X |
他のユーザーの非公開フィルタの削除 |  | X |  |  |  | X |
Office インポート マッピング ファイルの編集 |  | X |  |  |  | X |
親トピック: アクセス許可の定義


管理用のアクセス許可

管理に利用できるアクセス許可は次のとおりです。

 | システム管理者 | プロジェクト マネージャ | ロール割り当て管理者 | アナリスト | テスト担当者 | テスト管理者 | 報告者
システム設定の表示 | X | X |  |  |  | X | X
システム設定の管理 | X |  |  |  |  |  |
管理設定の表示 | X | X | X |  |  | X | X
管理設定の管理 | X |  |  |  |  |  |
ユーザーのロール割り当ての管理 | X |  | X |  |  |  |
管理設定の削除 | X |  |  |  |  |  |
ログ ファイルの表示と削除 | X | X |  |  |  | X | X
実行サーバーの管理 | X |  |  |  |  |  |
実行サーバーの削除 | X |  |  |  |  |  |
実行サーバーのアクティブ化と非アクティブ化 | X |  |  |  |  |  |
製品/バージョン/ビルドの表示 | X | X |  |  |  | X | X
製品/バージョン/ビルドの管理 | X |  |  |  |  |  |
製品/バージョン/ビルドの削除 | X |  |  |  |  |  |
親トピック: アクセス許可の定義


ユーザー アカウントとグループ

ユーザー アカウントは、Silk Central で作業するユーザーごとに作成する必要があります。1 つ以上のユーザー グループが特定のプロジェクトに割り当てられます。ユーザー アカウントがあり、ユーザー ロールとグループが割り当てられれば、ユーザーは Silk Central プロジェクトで作業できます。

  • ユーザー アカウントをメンテナンスする
    ユーザー アカウントをメンテナンスする方法について説明します。
  • グループをメンテナンスする
    グループをメンテナンスする方法について説明します。
親トピック: 管理


ユーザー アカウントをメンテナンスする

ユーザー アカウントは、個々のユーザーのログイン データと設定を追跡します。 また、ユーザー アカウントによってユーザー ログインが可能になります。 通常、ユーザー アカウントは、特定のプロジェクト用の特定のユーザー ロールを持つグループ アカウントに割り当てられます。 アプリケーション サーバー、Web サーバー、およびチャート サーバーのロケーションを設定したり、リポジトリと通知設定のセットアップと管理ができるユーザー ロールは、スーパーユーザーだけです。

注意:
スーパーユーザー アカウントの admin にはすべての管理権限があるため、このユーザーに新しいパスワードを直ちに作成して、それらの権限が無制限に行使されないようにする必要があります。パスワードを変更する方法の詳細については、「システム管理者アカウントのパスワードを変更する」を参照してください。
  • ユーザー アカウントを追加する
    Silk Central でユーザー アカウントを作成します。
  • ユーザー アカウントを編集する
    Silk Central でユーザー アカウントを編集します。
  • ユーザー アカウントを削除する
    ユーザー アカウントを削除します。
  • [ユーザーの設定] ページ
    ユーザー アカウントの設定に使用します。
親トピック: ユーザー アカウントとグループ


ユーザー アカウントを追加する

ユーザー アカウントを追加するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. アカウント タブをクリックします。 このページには、利用可能なすべてのユーザー アカウントが表示されます。このページに初めてアクセスしたときには、スーパーユーザー アカウントの admin ユーザーのみが表示されます。
  3. ユーザーの新規作成 をクリックします。 新しいユーザー アカウントの追加 ページが表示されます。
  4. ユーザーのユーザー名とパスワードを入力します。 パスワードを再度入力して確認します。
  5. LDAP とローカル認証情報ベースの認証を両方有効にするには、混合モード認証 (LDAP) チェック ボックスをオンにします。
  6. ユーザーのログインを許可しない場合は、ロック チェック ボックスをオンにします。
  7. ユーザーの姓、名、および電子メール アドレスを入力します。
  8. ユーザーのローカル タイム ゾーンを入力し、日付形式、短い日付形式、および週の最初の曜日を選択します。
  9. ページ更新時間 (秒単位)、CSV 区切り文字列、および デフォルト実行サーバー を入力します。
  10. グループおよびロール定義をそれぞれのリスト ボックスから選択します。
  11. 割り当ての追加 をクリックして、ユーザー アカウントにグループとロールの組み合わせを追加します。
  12. 前の 2 つのステップを繰り返して、必要なすべてのグループとロールの組み合わせをユーザー アカウントに割り当てます。
  13. 現在のユーザー アカウントからグループとロールの組み合わせを削除するには、アクション 列の 削除 アイコンをクリックします。
  14. 保存 をクリックして設定を保存します。
親トピック: ユーザー アカウントをメンテナンスする
関連概念
日時の書式
関連タスク
ユーザー アカウントを編集する
ユーザー アカウントを削除する


ユーザー アカウントを編集する

ユーザー アカウントを設定すると、ログイン 名を除き、すべてのパラメータを編集できます。

注: ユーザー アカウントを変更すると、変更されたユーザー アカウントの次のログイン時にアクティブになります。 対象ユーザーに、ログアウトして再びログインするように通知します。

ユーザー アカウントを編集するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. アカウント タブをクリックします。 このページには、利用可能なすべてのユーザー アカウントが表示されます。このページに初めてアクセスしたときには、スーパーユーザー アカウントの admin ユーザーのみが表示されます。
  3. 編集するユーザー アカウントの ログイン 名をクリックします。 既存のユーザーの設定 ページが表示されます。
  4. 必要に応じて、[パスワード] でユーザーのパスワードを編集します。 パスワードを再度入力して確認します。
  5. LDAP とローカル認証情報ベースの認証を両方有効にするには、混合モード認証 (LDAP) チェック ボックスをオンにします。
  6. 必要に応じてその他のユーザー設定を編集します。
  7. グループおよびロール定義をそれぞれのリスト ボックスから選択します。
  8. 割り当ての追加 をクリックして、ユーザー アカウントにグループとロールの組み合わせを追加します。
  9. 前の 2 つのステップを繰り返して、必要なすべてのグループとロールの組み合わせをユーザー アカウントに割り当てます。
  10. 現在のユーザー アカウントからグループとロールの組み合わせを削除するには、アクション 列の 削除 をクリックします。
  11. 保存 をクリックして設定を保存します。
親トピック: ユーザー アカウントをメンテナンスする
関連概念
日時の書式
関連タスク
ユーザー アカウントを追加する
ユーザー アカウントを削除する


ユーザー アカウントを削除する

注意:
ユーザー アカウントを削除すると、回復できません。 一時的にアカウントを利用できないようにする場合は、削除ではなく、ユーザー アカウントをロックできます。 ユーザー アカウントをロックする方法の詳細については、「ユーザー アカウントを編集する」を参照してください。

ユーザー アカウントを削除するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. アカウント タブをクリックします。 このページには、利用可能なすべてのユーザー アカウントが表示されます。このページに初めてアクセスしたときには、スーパーユーザー アカウントの admin ユーザーのみが表示されます。
  3. 削除するユーザー アカウントの アクション 列で、削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックすると操作が続行され、いいえ をクリックすると中止されます。 はい を選択した場合は、ユーザー アカウントのリストに戻ります。削除したアカウントは表示されません。
親トピック: ユーザー アカウントをメンテナンスする
関連概念
日時の書式
関連タスク
ユーザー アカウントを追加する
ユーザー アカウントを編集する


[ユーザーの設定] ページ

管理 > ユーザー管理 > アカウント > ユーザーの新規作成/ユーザー アカウントの編集

ユーザーの設定 ページは、ユーザー アカウントの設定に使用します。ユーザー アカウントの設定は、グループ アカウントの設定と密接に関連しています。

メニューでユーザー名をクリックすると、ログインしたユーザーの ユーザーの設定 ページにアクセスできます。

注: ユーザー アカウントを保存するには、少なくとも 1 つのグループとロールの割り当てを定義する必要があります。
[ログイン データ] 項目 | 説明
ログイン | Silk Central リポジトリに保存されるユーザー名です。後で説明する 混合モード認証 (LDAP) をオンにする場合は、定義されている LDAP ユーザー名と一致するユーザー名を入力する必要があります。
パスワード | ログイン に入力したユーザーの有効なパスワードを入力します。このパスワードは、LDAP のパスワードとは関係ありません。
パスワードの確認 | もう一度パスワードを入力して確認します。
混合モード認証 (LDAP) | LDAP とローカル認証情報ベースの認証を両方とも有効にするには、このチェック ボックスをオンにします。LDAP サーバーが存在する場合、このチェック ボックスをオフにすると、LDAP のみの認証になります。
ロック | 指定した認証情報によるユーザーのログインを許可しない場合は、このチェック ボックスをオンにします。ユーザー アカウントは非アクティブになります。
[一般データ] 項目 | 説明
名 | ユーザーの名を入力します。この情報は、Silk Central の動作には影響を与えません。ユーザーの連絡先情報を追跡するためにのみ使用されます。
姓 | ユーザーの姓を入力します。この情報は、Silk Central の動作には影響を与えません。ユーザーの連絡先情報を追跡するためにのみ使用されます。
電子メール | ユーザーの電子メール アドレスを入力します。この情報は通知の目的で使用されます。
テーマ | Silk Central のバージョンを選択すると、対応する配色が Silk Central の UI に設定され、選択したユーザーに対して表示されます。
タイム ゾーン | ユーザーのローカル タイム ゾーンです。タイム ゾーン情報は、日付をユーザーのローカル タイム ゾーンで表示するために使用されます。
日付形式 | 選択した日付形式は、Silk Central の長い日付形式を表示するリスト、レポート、およびカレンダーで、ユーザーに対して使用されます。
短い日付形式 | 選択した日付形式は、Silk Central の短い日付形式を表示するリスト、レポート、およびカレンダーで、ユーザーに対して使用されます。
週の最初の曜日 | 週の最初の曜日により、レポートの週単位の表示が決まります。
CSV 区切り文字列 | この文字列は、ユーザーがダウンロードする CSV ファイルの行区切り文字として使用されます。レポートは CSV ファイルとしてダウンロードできます。
デフォルト実行サーバー | デフォルト実行サーバーは、自動テストの試験実行に使用されます。
[グループとロールの割り当て] 項目 | 説明
[グループとロールの割り当て] の表 | ユーザーの既存のユーザー グループ/ユーザー ロールの全割り当てのリストが表示されます。グループとロールの割り当てを削除することもできます。そのためには、削除する割り当ての隣にある 削除 をクリックします。
グループ | ユーザーを割り当てるグループを選択します。このリスト ボックスには、Silk Central 管理者が定義したユーザー グループのリストが表示されます。LDAP サーバーからインポートしたグループだけがリストされます（ユーザーがそのグループに割り当てられている場合）。
ユーザー ロール | 選択したグループに割り当てるユーザーのユーザー ロールを選択します。 このリストは、あらかじめ定義されたシステム ロールとカスタムのユーザー ロールで構成されます。
の追加 | このボタンをクリックすると、選択したグループとユーザー ロールで、新しいユーザー グループ/ユーザー ロールの割り当てが作成されます。
親トピック: ユーザー アカウントをメンテナンスする


グループをメンテナンスする

グループは、特定のプロジェクトへのアクセス権を定義します。各ユーザーは、1 つ以上のグループ と関連付けることができ、そのグループに定義されているプロジェクトへのアクセス権を継承します。

注: ユーザーを、複数のロールを持つグループに追加することもできます。これによって、ユーザーのアクセス許可を詳細に設定できます。
  • グループを追加する
    グループを作成します。
  • LDAP サーバーからグループをインポートする
    LDAP サーバーからグループをインポートして、自動的に作成した Silk Central ユーザーを割り当てることができます。
  • LDAP グループの自動同期スケジュールを作成する
    Silk Central システムで LDAP サーバーからユーザー グループをインポートした場合、LDAP サーバー上で行われた変更で Silk Central グループを自動的に同期するスケジュールを指定できます。
  • グループを編集する
    グループを編集します。
  • グループを削除する
    グループを削除します。
  • [グループ] 設定ページ
    ユーザー グループの設定に使用します。
親トピック: ユーザー アカウントとグループ
関連概念
ロケーションを管理する
ユーザー ロールとアクセス許可
関連タスク
プロジェクトを追加する
Issue Manager プロジェクトとしてプロジェクトを初期化する
プロジェクトとプロジェクト ベースラインを編集する


グループを追加する

グループを追加するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. グループ タブをクリックします。
  3. グループの新規作成 をクリックします。
  4. グループ名 フィールドに、新しいグループの名前を入力します。
  5. 説明 フィールドに、新しいグループの説明を入力します。
  6. ユーザーおよびロールの割り当てをそれぞれのリスト ボックスから選択し、選択項目の追加 をクリックして、新しいグループにユーザーとロールの組み合わせを追加します。
    注: 新しいユーザーの割り当てを受け付けないように定義されているユーザー ロールは、このリストに表示されません。これらの設定は、管理 > ユーザー管理 > ロール の 新しい割り当てを許可 ボタンで制御できます。

    LDAP サーバーからインポートしたグループに対しては、ロール割り当てをユーザーに追加したり削除することはできますが、ユーザーごとに最低 1 つのロール割り当てを残す必要があります。LDAP からインポートしたグループからのユーザーの削除は、LDAP サーバー上でのみ行うことができます。

  7. 前のステップを繰り返して、必要なすべてのユーザーとロールの組み合わせをグループに割り当てます。
    ヒント: ロール割り当て管理者 ロールをグループ内の複数のユーザーに割り当てると便利です。ロール割り当て管理者は、グループの既存のユーザーへのロールの割り当ておよび解除を行うためのアクセス許可を持ちます。割り当てを行えるのは、自身に割り当てられているロールだけです。グループにメンバーを追加したり削除することはできません。自身がロール割り当て管理者として定義されているグループ内のロール割り当てだけを変更できます。
  8. 現在のグループからユーザーとロールの組み合わせを削除するには、アクション 列の 削除 をクリックします。
  9. プロジェクトの割り当て セクションでは、任意の既存プロジェクトをこのグループに割り当てることができます。
  10. 保存 をクリックします。
親トピック: グループをメンテナンスする


LDAP サーバーからグループをインポートする

LDAP サーバーからグループをインポートして、自動的に作成した Silk Central ユーザーを割り当てることができます。
LDAP サーバーからグループをインポートする前に、LDAP サーバーの設定を行う必要があります。詳細については、「LDAP サーバーを追加する」を参照してください。
LDAP グループとその関連するユーザーを Silk Central にインポートするには：
  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. グループ タブをクリックします。
  3. LDAP グループのインポート をクリックします。 LDAP グループのインポート ダイアログ ボックスが表示されます。
  4. LDAP サーバーの設定がドメインを使用するように設定されており、インポートしたユーザーが <ドメイン>\<ユーザー名> 形式で Silk Central にログインする必要がある場合は、LDAP ドメイン を選択します。インポートしたドメイン名を入力せずにインポートしたユーザーが Silk Central にログインする場合は、デフォルト ドメインを選択します。
  5. インポートする LDAP グループ を選択します。
  6. Silk Central デフォルト ロール を選択します。選択した LDAP グループ のすべてのユーザーに対してこのロールが設定されます。
  7. OK をクリックします。
LDAP からグループをインポートした後で、グループの設定、特にプロジェクトの割り当てを確認することを推奨します。インポートした LDAP グループにユーザーを割り当てたり、削除することはできません。この割り当ては、LDAP サーバーを通して管理されます。ただし、個々のユーザーのロールは変更できます。
ヒント: ロール割り当て管理者 ロールをグループ内の複数のユーザーに割り当てると便利です。ロール割り当て管理者は、グループの既存のユーザーへのロールの割り当ておよび解除を行うためのアクセス許可を持ちます。割り当てを行えるのは、自身に割り当てられているロールだけです。グループにメンバーを追加したり削除することはできません。自身がロール割り当て管理者として定義されているグループ内のロール割り当てだけを変更できます。

LDAP サーバーからインポートされたグループは、同期スケジュールによって自動的に更新されます。このスケジュールを変更したり無効にする方法については、「LDAP グループの自動同期スケジュールを作成する」を参照してください。

親トピック: グループをメンテナンスする
関連タスク
プロジェクトを追加する
プロジェクトとプロジェクト ベースラインを編集する
LDAP サーバーを追加する
LDAP グループの自動同期スケジュールを作成する


グループを編集する

グループを編集するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. グループ タブをクリックします。
  3. 編集するグループの名前を [グループ名] でクリックします。 既存ユーザー グループの設定 ページが表示されます。
  4. グループ名 フィールドで、必要に応じて名前を編集します。このフィールドは、LDAP サーバーからインポートしたグループでは編集できません。
  5. 説明 フィールドで、必要に応じてグループの説明を編集します。
  6. ユーザーおよびロールの割り当てをそれぞれのリスト ボックスから選択し、選択項目の追加 をクリックして、新しいグループにユーザーとロールの組み合わせを追加します。
    注: 新しいユーザーの割り当てを受け付けないように定義されているユーザー ロールは、このリストに表示されません。これらの設定は、管理 > ユーザー管理 > ロール の 新しい割り当てを許可 ボタンで制御できます。

    LDAP サーバーからインポートしたグループに対しては、ロール割り当てをユーザーに追加したり削除することはできますが、ユーザーごとに最低 1 つのロール割り当てを残す必要があります。LDAP からインポートしたグループからのユーザーの削除は、LDAP サーバー上でのみ行うことができます。

  7. 前のステップを繰り返して、必要なすべてのユーザーとロールの組み合わせをグループに割り当てます。
    ヒント: ロール割り当て管理者 ロールをグループ内の複数のユーザーに割り当てると便利です。ロール割り当て管理者は、グループの既存のユーザーへのロールの割り当ておよび解除を行うためのアクセス許可を持ちます。割り当てを行えるのは、自身に割り当てられているロールだけです。グループにメンバーを追加したり削除することはできません。自身がロール割り当て管理者として定義されているグループ内のロール割り当てだけを変更できます。
  8. 現在のグループからユーザーとロールの組み合わせを削除するには、アクション 列の 削除 をクリックします。
  9. LDAP サーバーからインポートしたグループの場合は、LDAP と同期 をクリックして、Silk Central を LDAP サーバー上の変更と同期をとることができます。 ユーザーが LDAP 上のグループから削除された場合は、すべてのそのロール割り当てがグループから削除されます。ユーザーが LDAP に追加された場合は、新しいロール割り当てがデフォルトのロールで作成されます。すべてのほかのロール割り当てはそのまま残ります。
    注: グループ割り当ては、ユーザーが Silk Central にログインしたときに自動的に同期されます。
  10. プロジェクトの割り当て セクションでは、任意の既存プロジェクトをこのグループに割り当てることができます。
  11. 保存 をクリックして グループ ページに戻ります。
親トピック: グループをメンテナンスする
関連タスク
グループを削除する


グループを削除する

グループを削除する前に、対象グループからすべてのユーザーとロールの割り当てを削除する必要があります。この制約は、LDAP サーバーからインポートしたグループには適用されません。グループを変更する方法の詳細については、「グループを編集する」を参照してください。

グループを削除するには：

  1. メニューで 管理 > ユーザー管理 をクリックします。
  2. グループ タブをクリックします。
  3. 削除するグループの アクション 列で、 グループの削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックすると操作が続行され、いいえ をクリックすると中止されます。
注: LDAP サーバーからインポートしたグループを削除する場合は、すべてのユーザーとロール割り当ても削除されます。削除したグループのユーザーに対して他のグループでの割り当てが無い場合は、そのユーザーは Silk Central から削除されます。
親トピック: グループをメンテナンスする
関連タスク
グループを編集する


[グループ] 設定ページ

管理 > ユーザー管理 > グループ > グループの新規作成/編集

グループの設定 ページは、ユーザー グループの設定に使用します。グループの設定は、ユーザー アカウントの設定と密接に関連しています。このページには、次の項目があります。

項目 | 説明
グループ名 | GUI に表示されるグループの名前を指定します。任意のグループ名を定義できます。
説明 | グループの説明です。任意の説明文を入力できます。
アカウントおよびロールの割り当て | グループの既存のユーザー/ロールの全割り当てのリストが表示されます。ユーザーとロールの割り当てを削除することもできます。そのためには、削除する割り当ての隣にある 削除 をクリックします。
ユーザー | このリスト ボックスには、管理者が定義したユーザー アカウントのリストが表示されます。グループに割り当てるユーザーを選択します。
ロール定義 | このリストは、あらかじめ定義されたシステム ロールとカスタムのユーザー ロールで構成されます。 グループに割り当てるユーザーのユーザー ロールを選択します。
選択項目の追加 | 選択したユーザーとユーザー ロールを使用して、新しいユーザー アカウントとユーザー ロールの割り当てを作成する場合にクリックします。
プロジェクトの割り当て | 既存の全プロジェクトのリストが表示され、それぞれがグループ アカウントに割り当てられているかどうかが示されます。プロジェクトの隣のチェック ボックスをオンにすると、プロジェクトがグループ アカウントに割り当てられます。プロジェクトが存在しない場合は、後でプロジェクトを作成してから割り当てることができます。
すべて選択 | リストに表示されているすべてのプロジェクトのチェック ボックスをオンにします。
すべて選択解除 | リストに表示されているすべてのプロジェクトのチェック ボックスをオフにします。
親トピック: グループをメンテナンスする


実行環境

Silk Central テストが実行される場所を指定するために、実行環境を管理します。Silk Central の実行環境は、物理実行サーバーと仮想実行サーバー (クラウド上にホストされたもの) で構成され、ロケーション と呼ばれる論理コンテナにグループ化されます。

ロケーションとは、実行サーバーの論理的なコンテナです。実行サーバーを設定する方法については、「実行サーバーを設定する」を参照してください。Silk Central では PoP（Points of Presence）の世界的な分散（実行サーバーの分散）がサポートされているため、実行サーバーをグループ化して複数のロケーションに配置することが理想的です。ロケーションは、物理的な位置である必要は無く、単に実行サーバーを管理可能な単位にグループ化するために使用できます。

Silk Central の実行サーバーは、スケジュール設定されたテスト (たとえば、Silk Test Classic スクリプトや Silk Performer スクリプトなど) の実行を担当します。実行サーバーは、物理マシンか仮想マシン (クラウド ホスト型) のいずれかになります。

  • ロケーションを管理する
    Silk Central でのロケーションの概念的な背景について説明します。
  • 実行サーバーを設定する
    Silk Central における実行サーバーの概念的背景について説明します。
  • クラウド統合
    パブリックまたはプライベートなクラウド サービスのプロバイダと統合するためにクラウド プロファイルを設定する方法を説明します。
  • デバイス プロバイダを管理する
    デバイス プロバイダは、モバイル エミュレータやシミュレータをホストする、または接続された物理モバイル デバイスを持つコンピュータであり、テストを実行するためにアクセスできます。
親トピック: 管理


ロケーションを管理する

ロケーションとは、実行サーバーの論理的なコンテナです。実行サーバーを設定する方法については、「実行サーバーを設定する」を参照してください。Silk Central では PoP（Points of Presence）の世界的な分散（実行サーバーの分散）がサポートされているため、実行サーバーをグループ化して複数のロケーションに配置することが理想的です。ロケーションは、物理的な位置である必要は無く、単に実行サーバーを管理可能な単位にグループ化するために使用できます。

注: Silk Central は、ローカル と呼ばれるデフォルトのロケーションを自動的に作成します。
  • ロケーションを追加する
    新しいロケーションを作成して、実行サーバーの論理的なコンテナを追加します。
  • ロケーションを編集する
    ロケーションを編集します。
  • ロケーションを削除する
    既存のロケーションを削除します。
  • [ロケーションの新規作成] ダイアログ ボックス
    このダイアログ ボックスは、ロケーションの設定に使用します。
親トピック: 実行環境
関連概念
実行サーバーを設定する
グループをメンテナンスする
ユーザー ロールとアクセス許可
関連タスク
プロジェクトを追加する
Issue Manager プロジェクトとしてプロジェクトを初期化する
プロジェクトとプロジェクト ベースラインを編集する


ロケーションを追加する

新しいロケーションを追加するには：

  1. メニューで 管理 > 実行環境 をクリックします。
  2. ロケーションの新規作成 をクリックします。

    ロケーションの新規作成 ダイアログ ボックスが表示されます。

  3. 名前 にロケーション名を入力します。
  4. プロキシ サーバーのロケーションを指定した場合は、システム プロキシを使用 チェック ボックスをオンにします。 詳細については、「システム プロキシを設定する」を参照してください。
  5. ロケーション プロキシ セクションで、このロケーションの実行サーバーがアプリケーション サーバーと通信する場合に経由するプロキシ サーバーを定義できます。
  6. ホスト フィールドに、プロキシ サービスのホストとなるコンピュータ名を入力します。
  7. ポート フィールドに、プロキシ ホストのポート番号を入力します。
  8. プロキシ サーバーでユーザー名/パスワード認証が必要な場合は、ユーザー名 フィールドおよび パスワード フィールドに有効な認証情報を入力します。
  9. プロジェクト セクションには、既存プロジェクトのリストが含まれます。このロケーションに割り当てるプロジェクトの 割り当て済み チェック ボックスをオンにします。
  10. OK をクリックして新しいロケーションを追加します。
親トピック: ロケーションを管理する
関連タスク
システム プロキシを設定する


ロケーションを編集する

ロケーションを編集する方法を説明します。

ロケーションを編集するには：

  1. メニューで 管理 > 実行環境 をクリックします。
  2. 変更したいロケーションを選択し、 編集 をクリックします。

    ロケーションの編集 ダイアログ ボックスが表示されます。

  3. 名前 を必要に応じて変更します。
  4. プロキシ サーバーのロケーションを指定した場合は、システム プロキシを使用 チェック ボックスをオンにします。 詳細については、「システム プロキシを設定する」を参照してください。
  5. ロケーション プロキシ セクションで、このロケーションの実行サーバーがアプリケーション サーバーと通信する場合に経由するプロキシ サーバーを定義できます。
  6. ホスト フィールドに、プロキシ サービスのホストとなるコンピュータ名を入力します。
  7. ポート フィールドに、プロキシ ホストのポート番号を入力します。
  8. プロキシ サーバーでユーザー名/パスワード認証が必要な場合は、ユーザー名 フィールドおよび パスワード フィールドに有効な認証情報を入力します。
  9. プロジェクト セクションには、既存プロジェクトのリストが含まれます。このロケーションに割り当てるプロジェクトの 割り当て済み チェック ボックスをオンにします。
  10. OK をクリックします。
親トピック: ロケーションを管理する
関連タスク
システム プロキシを設定する


ロケーションを削除する

ヒント: ロケーションを削除する前に、割り当てられているすべての実行サーバーをそのロケーションから削除する必要があります。詳細については、「実行サーバーを削除する」を参照してください。

ロケーションを削除するには：

  1. メニューで 管理 > 実行環境 をクリックします。
  2. 削除したいロケーションを選択し、 削除 をクリックします。 削除の確認を求めるメッセージが確認ダイアログ ボックスに表示されます。
  3. はい をクリックするとロケーションが削除され、いいえ をクリックすると削除が中止されます。
親トピック: ロケーションを管理する
関連タスク
実行サーバーを削除する


[ロケーションの新規作成] ダイアログ ボックス

管理 > 実行環境 > 実行サーバー > ロケーションの新規作成

ロケーションの新規作成 ダイアログ ボックスは、ロケーションの設定に使用します。

項目 | 説明
名前 | GUI とレポートに表示されるロケーションの名前を指定します。
システム プロキシを使用 | この設定を有効にすると、そのロケーションのすべての実行サーバーが、強制的に定義済みのシステム プロキシを通してアプリケーション サーバーと通信するようになります。この設定が有効でない場合、ロケーション プロキシを定義しない限り、アプリケーション サーバーは実行サーバーと直接通信します。システム プロキシが定義されていない場合、このチェック ボックスは無効になります。
ロケーション プロキシ

この領域では、このロケーションの実行サーバーがアプリケーション サーバーと通信するときに経由するプロキシ サーバーを定義します。このロケーションの実行サーバーをアプリケーション サーバーと直接通信させる場合、または システム プロキシを使用 オプションをオンにした場合は、このフィールドを空欄のままにします。また、システム プロキシとロケーション プロキシを両方とも定義することもできます。その場合は、通信は両方のプロキシを通してトンネルされます。

SSL（Secure Sockets Layer）がサポートされるロケーション プロキシのみを定義できます。すべての実行サーバーは、プロキシの SSL ポートを使用する必要があります。実行サーバーの設定の詳細については、「実行サーバーを設定する」を参照してください。
ホスト名 | プロキシ サービスをホストするコンピュータの名前。
ポート | プロキシ ホストのポート番号。デフォルトのポートは 443 です。
ユーザー名 | プロキシ サーバーでユーザー名/パスワード認証が必要な場合は、有効なユーザー名を入力します。
パスワード | プロキシ サーバーでユーザー名/パスワード認証が必要な場合は、ユーザー名 フィールドで指定したユーザーの有効なパスワードを入力します。
割り当て先プロジェクト | 既存の全プロジェクトのリストが表示されます。プロジェクトの隣のチェック ボックスをオンにすると、プロジェクトがロケーションに割り当てられます。プロジェクトが存在しない場合は、後でプロジェクトを作成してから割り当てることができます。詳細については、「プロジェクトを追加する」を参照してください。選択したプロジェクトは、そのロケーションの実行サーバーにアクセスできるようになります。
すべて選択 | リストに表示されているすべてのプロジェクトのチェック ボックスをオンにします。
すべて選択解除 | リストに表示されているすべてのプロジェクトのチェック ボックスをオフにします。
親トピック: ロケーションを管理する
関連タスク
実行サーバーを設定する
プロジェクトを追加する


実行サーバーを設定する

Silk Central の実行サーバーは、スケジュール設定されたテスト (たとえば、Silk Test Classic スクリプトや Silk Performer スクリプトなど) の実行を担当します。実行サーバーは、物理マシンか仮想マシン (クラウド ホスト型) のいずれかになります。

Silk Test Classic テストや Silk Performer テストを実行するには、Silk Central の実行サーバーがインストールされているのと同じコンピュータに Silk Test Classic または Silk Performer のソフトウェアがインストールされている必要があります。

マルチバイト アプリケーションや Web ページに対して Silk Performer スクリプトを実行する際は、Silk Performer のヘルプの「マルチバイト サポート」セクションに目を通してください。

実行サーバーのインストールに関する詳細については、「Silk Central のインストール」を参照してください。また、Silk Test Classic と Silk Performer については、それぞれの製品のドキュメントを参照してください。

  • キーワードを用いたハードウェア プロビジョニング
    多数の実行サーバーが存在するテスト環境を管理する方法について説明します。
  • 物理実行サーバーを設定する
    物理実行サーバーを設定します。
  • クラウド ホスト型実行サーバーを設定する
    クラウド ホスト型実行サーバーを設定します。
  • 実行サーバーのキーワードの作成と割り当て
    新しい実行サーバーのキーワードを作成して、実行サーバーに割り当て、サーバーで実行する実行を定義します。
  • 実行サーバーをアクティブまたは非アクティブにする
    ロケーション内で既存の実行サーバーをアクティブまたは非アクティブにします。
  • 実行サーバーを削除する
    既存の実行サーバーを削除してインストールから切断します。
  • 実行サーバーの標準ではない SSL ポートを設定する
    アプリケーション サーバーが実行サーバーと通信するためのカスタム SSL ポートを設定します。
  • [実行サーバーの新規作成/実行サーバーの編集] ダイアログ ボックス
    ロケーション内の実行サーバーを構成します。
親トピック: 実行環境
関連概念
Silk Central のインストール
関連タスク
Windows 実行サーバーをインストールする
Linux 実行サーバーをインストールする


キーワードを用いたハードウェア プロビジョニング

Silk Central のハードウェア プロビジョニング技術は、多数の実行サーバーが含まれているテスト環境の管理に役立ちます。各実行サーバーと実行計画の間に 1 対 1 の直接的関係を構成しなくても、キーワードによって Silk Central は各実行計画に最適な実行サーバーを選択することができます。これは、実行計画のキーワード リストとすべてのアクティブ実行サーバーのキーワード リストを動的に比較することで実現されます。

キーワードには通常、実行サーバーの環境（たとえば、プラットフォーム、オペレーティング システム、インストール済みのアプリケーションなど）を記述します。Silk Central は実行計画の実行時に、その実行計画のキーワードと使用可能なすべての実行サーバーのキーワードを比較します。次に、実行計画のキーワード リストに一致する実行サーバーで実行が行われます。一致する実行サーバーがなければ、実行は行われません。キーワード リストの一致する実行サーバーが複数ある場合は、最初に見つかった実行サーバーで実行が行われます。

Silk Test がインストールされている物理実行サーバーに対して、Silk Central はインストール済みのブラウザーと接続されたモバイル デバイスに従ってキーワードを自動的に割り当てます。

予約済みのデフォルト キーワード

ハードウェア プロビジョニングが必要でない場合は、実行サーバーごとに自動的に生成される予約済みキーワードを利用することができます。そのような場合は、実行サーバーにキーワードを手動で割り当てる必要はありません。その代わりに、各実行計画に実行サーバーを 1 対 1 で静的に割り当てることができます。

新規作成された各実行サーバーには予約済みキーワードが自動的に割り当てられます。予約済みキーワードは、次の形式で構成されます。
 #<execution server name>@<location name>

予約済みキーワードは、実行計画にキーワードを割り当てる際に利用できます。実行サーバーにキーワードを割り当てる際には利用も適用もできません。

定義済みの実行サーバーごとに自動的にセットアップされる予約済みキーワードの他に、実行サーバーの種類ごとに以下の予約済みキーワードもセットアップされます。

#PHYSICAL

実行サーバー プロビジョニングを物理実行サーバーに限定します。

#VIRTUAL

実行サーバー プロビジョニングを仮想実行サーバーに限定します。

キーワードと仮想実行サーバー

仮想実行サーバーへのキーワードの割り当ては、物理実行サーバーへの割り当てと同様です。仮想実行サーバーを少なくとも 1 つ構成すると、#VIRTUAL キーワードが動的に生成され、どの実行計画にも割り当てられるようになります。実行が仮想マシンで実行されるようにする場合、その実行計画には #VIRTUAL キーワードを選択します。実行計画に #VIRTUAL キーワードと #PHYSICAL キーワードが両方とも割り当てられていない (あるいは、割り当てられている) 場合、実行環境の設定が同じと仮定すると、その実行は仮想実行サーバーか物理実行サーバーのどちらかで行われる可能性があります。実行計画のキーワードが複数の仮想実行サーバーに一致する場合は、一致する仮想実行サーバーの中で最初に見つかったものが選択されます。

親トピック: 実行サーバーを設定する


物理実行サーバーを設定する

物理実行サーバーは、物理コンピュータ上、または仮想マシン (VM) 上で実行されます。物理実行サーバーを設定するには：

  1. メニューで 管理 > 実行環境 をクリックします。
  2. 実行サーバーを設定するロケーションを選択します。
    • 新しい実行サーバーを作成するには、物理実行サーバーの新規作成 をクリックします。
    • 既存の実行サーバーを編集するには、アクション 列でそれぞれ対応する 編集 ボタンをクリックします。
    注: これらのプロパティを編集する前に、実行サーバーを非アクティブにしておく必要があります。ただし、アクティブになっている実行サーバーのキーワード リストを実際には編集できます。
  3. ホスト名または IP アドレス フィールドに有効なホスト名または IP アドレスを入力します。
  4. 実行サーバーの名前を 名前 フィールドに入力します。
  5. キーワード をクリックしてリストからキーワードを選択するか、実行サーバーを説明する新しいキーワードを入力します。 これらのキーワードは、各実行に適切なサーバーを動的に選択するために、実行時に分析されます。詳細については、「実行サーバーのキーワードの作成と割り当て」を参照してください。
  6. 詳細 セクションにある設定は、デフォルトの設定を使用していない場合にのみ変更する必要があります。ポート フィールドに実行サーバーがリスンするポートを指定します。
    注: SSL を使用して実行サーバーに接続する場合は、SSL を使用する チェック ボックスをオンにします。
    ヒント: 標準でない SSL ポートから実行サーバーに接続する場合は、「実行サーバーの標準ではない SSL ポートを設定する」を参照してください。
  7. 省略可能：応答タイムアウト [秒] フィールドに、応答タイムアウト（秒単位）を入力します。実行サーバーが指定した時間内にアクセス可能にならない場合は、Silk Central の管理者に電子メールが送信されます。このような場合に電子メールを Silk Central に送信させたくない場合は、0 を入力します。
  8. 省略可能：必要に応じて、この実行サーバー上の 最大同時実行数 を変更します。これは、実行計画で並列実行を有効にした場合に、この実行サーバー上で同時に実行できる実行計画の最大数になります。同時実行数が多すぎると、実行サーバーのパフォーマンスに深刻な影響を及ぼし、テストの実行が失敗する可能性もあります。
  9. OK をクリックして、設定を保存します。エラー メッセージが表示される場合は、設定が正しいこと、ネットワークが適切に構成されていること、および設定している実行サーバーに必要なソフトウェアがインストールされていることを確認してください。
    重要: 実行サーバーのインストールには管理者権限が必要なため、UAC が有効化されていると、実行サーバーの自動アップグレードは失敗します。実行サーバーをホストするすべてのコンピュータで UAC を無効化してください。
    注: 実行サーバーのバージョンが不適切な古いバージョンであっても、それが SilkCentral Test Manager 2009 SP1 よりも後である場合、その実行サーバーは最新の Silk Central バージョンに自動的にアップグレードされます。実行サーバーのリストの 情報 列に、アップグレードに関するメッセージが Silk Central によって表示されます。アップグレード手順が完了しない限り、そのアップグレード中の実行サーバーは使用されません。
親トピック: 実行サーバーを設定する
関連タスク
実行サーバーの標準ではない SSL ポートを設定する
実行サーバーのキーワードの作成と割り当て


クラウド ホスト型実行サーバーを設定する

クラウド ホスト型実行サーバーは、VMware vCloud のようなクラウド プロバイダ上で実行されます。クラウド ホスト型実行サーバーを設定するには：

  1. メニューで 管理 > 実行環境 をクリックします。
  2. 実行サーバーを設定するロケーションを選択します。
    • 新しい実行サーバーを作成するには、仮想実行サーバーの新規作成 をクリックします。
    • 既存の実行サーバーを編集するには、アクション 列でそれぞれ対応する 編集 ボタンをクリックします。
    • クラウド プロバイダからテンプレートを使用する実行サーバーのリストを同期するには、クラウド プロバイダ タブを選択します。アクション 列の [image] をクリックして、このクラウド プロバイダのテンプレートを使用する実行サーバーのリストの同期を取ります。これは、存在しないテンプレートが割り当てられたこのプロファイルのすべての仮想実行サーバーを削除します。ホットフィックスを適用した後では、自動的に作成された仮想実行サーバーのテンプレートも更新します。
    注: これらのプロパティを編集する前に、実行サーバーを非アクティブにしておく必要があります。ただし、アクティブになっている実行サーバーのキーワード リストを実際には編集できます。
  3. クラウド プロバイダ リストで、設定済みのクラウド プロバイダ プロファイルのリストから選択します。これにより、実行サーバーが自動テストの実行に使用されるときにデプロイされる仮想環境を含むクラウドが決定されます。
  4. 仮想イメージ テンプレート リストで、各自動テストの実行に対して新しいインスタンスが作成されるイメージ テンプレートを選択します。クラウド プロバイダに依存しますが、イメージ テンプレートは最低 1 つの仮想マシンのイメージで構成されます。Silk Central 実行サーバーは 1 つの仮想マシン イメージで実行されなければなりません。実行サーバーのバージョンが古い場合は、自動テスト実行用に仮想環境がデプロイされた後に、サーバーは自動的にアップグレードされます。デプロイの進行は、VM イメージが現在の実行サーバーのバージョンで既に実行されていれば、より早くなります。
  5. 実行サーバーの名前を 名前 フィールドに入力します。
  6. キーワード をクリックしてリストからキーワードを選択するか、実行サーバーを説明する新しいキーワードを入力します。 これらのキーワードは、各実行に適切なサーバーを動的に選択するために、実行時に分析されます。詳細については、「実行サーバーのキーワードの作成と割り当て」を参照してください。
  7. 詳細 セクションにある設定は、デフォルトの設定を使用していない場合にのみ変更する必要があります。ポート フィールドに実行サーバーがリスンするポートを指定します。
    注: SSL を使用して実行サーバーに接続する場合は、SSL を使用する チェック ボックスをオンにします。
    ヒント: 標準でない SSL ポートから実行サーバーに接続する場合は、「実行サーバーの標準ではない SSL ポートを設定する」を参照してください。
  8. 省略可能：応答タイムアウト [秒] フィールドに、応答タイムアウト（秒単位）を入力します。クラウド プロバイダ上の実行サーバーが指定した時間内にアクセス可能にならない場合は、VM がシャットダウンされます。このような場合にシャットダウンしたくない場合には、0 を入力します（VM に到達できなくなる場合、テスト実行を手動で中止する必要があります）。
  9. OK をクリックして設定を保存することで、指定したキーワードに従って実行サーバーが自動実行できるようになります。エラー メッセージが表示される場合は、ポートの設定が正しいこと、実行サーバーが仮想マシンのイメージにインストールされていることを確認してください。インストールされた実行サーバーのバージョンが無効であるエラー メッセージが表示される場合は、サーバーは各自動テストの実行時に自動的にアップグレードされるため、エラーを無視できます。
親トピック: 実行サーバーを設定する
関連概念
クラウド統合
クラウド統合
関連タスク
クラウド プロファイルを追加する
実行サーバーの標準ではない SSL ポートを設定する
実行サーバーのキーワードの作成と割り当て


実行サーバーのキーワードの作成と割り当て

実行サーバーのキーワードを作成して割り当てるには：

  1. メニューで 管理 > 実行環境 をクリックします。
  2. ロケーションを選択して、そのロケーションに定義されている実行サーバーのリストを表示します。
  3. あらかじめ定義された実行サーバーの アクション 列で、 編集 をクリックするか、または 物理実行サーバーの新規作成 または 仮想実行サーバーの新規作成 をクリックして、新しい実行サーバーに対してキーワードを作成します。
    注: Silk Test がインストールされている物理実行サーバーに対して、Silk Central はインストール済みのブラウザーと接続されたモバイル デバイスに従ってキーワードを自動的に割り当てます。アクション 列の [image] をクリックして、割り当て済みキーワードのリストを更新します。
  4. キーワード をクリックします。 キーワードの割り当て ダイアログ ボックスが表示されます。
  5. キーワードの選択または入力 フィールドに新しいキーワードを入力するか、あるいは既存のキーワードを選択します。キーワードは、実行サーバー上の環境 (プラットフォーム、オペレーティング システム、あらかじめインストールされているアプリケーションなど) を表します。次の文字は、キーワードに使用できません。# $ ?* \ , ; ' "
    注: ただし、新しくインストールした Silk Central で作業している場合は、選択可能なキーワードが表示されないことがあります。キーワードの割り当て ダイアログ ボックスには表示されませんが、システムに構成されている実行サーバーごとに予約済みキーワードが作成されます。これらの予約済みキーワードは、実行計画にキーワードを割り当てる際にのみ利用できます。
    Windows の標準的な複数選択機能である Ctrl + クリック または Shift + クリック を使用して、複数のキーワードを選択できます。キーワードの選択または入力 フィールドは、リストで複数のキーワードが選択されていると無効になることにご注意ください。 ハードウェア プロビジョニングが必要でない場合は、実行サーバーごとに生成される予約済みのデフォルト キーワードを使用することができます。そのような場合は、実行サーバーにそれ以上キーワードを割り当てる必要はありません。
  6. 追加 (>) をクリックして、キーワードを 割り当て済みキーワード 一覧に移動します。
  7. OK をクリックしてキーワードを保存し、キーワードの割り当て ダイアログ ボックスを閉じます。
親トピック: 実行サーバーを設定する
関連タスク
実行サーバーの標準ではない SSL ポートを設定する


実行サーバーをアクティブまたは非アクティブにする

  1. メニューで 管理 > 実行環境 をクリックします。
  2. ロケーションを選択して、そのロケーションに定義されている実行サーバーのリストを表示します。
  3. アクティブまたは非アクティブにする実行サーバーの ステータス 列で、アクティブ/非アクティブ をクリックします。
    重要: 実行サーバーのインストールには管理者権限が必要なため、UAC が有効化されていると、実行サーバーの自動アップグレードは失敗します。実行サーバーをホストするすべてのコンピュータで UAC を無効化してください。
    注: 実行サーバーのバージョンが不適切な古いバージョンであっても、それが SilkCentral Test Manager 2009 SP1 よりも後である場合、その実行サーバーは最新の Silk Central バージョンに自動的にアップグレードされます。実行サーバーのリストの 情報 列に、アップグレードに関するメッセージが Silk Central によって表示されます。アップグレード手順が完了しない限り、そのアップグレード中の実行サーバーは使用されません。
親トピック: 実行サーバーを設定する
関連タスク
実行サーバーを削除する


実行サーバーを削除する

ヒント: データの整合性を維持するには、実行サーバーを削除する前に非アクティブにする必要があります。その他の情報については、「実行サーバーアクティブおよび非アクティブにする」を参照してください。
注: 実行サーバーを削除した場合でも、実際にインストールされたソフトウェアが削除されるわけではありません。削除により単に実行サーバーと接続が切断されます。前に削除した実行サーバーを再び追加できます。実行サーバーを他のアプリケーション サーバーに割り当てるには、実行サーバーをインストールしたコンピュータ上で次のファイルを削除する必要があります：C:\ProgramData\SilkCentral\AgentBase\ItemObjects.ser
  1. メニューで 管理 > 実行環境 をクリックします。
  2. ロケーションを選択して、そのロケーションに定義されている実行サーバーのリストを表示します。
  3. 削除する実行サーバーの アクション 列で、 削除 をクリックします。
親トピック: 実行サーバーを設定する
関連タスク
実行サーバーをアクティブまたは非アクティブにする


[実行サーバーの新規作成/実行サーバーの編集] ダイアログ ボックス

管理 > 実行環境 > 実行サーバー > 実行サーバーの新規作成/実行サーバーの編集

ロケーション内で実行サーバーを構成するには、実行サーバーの新規作成/実行サーバーの編集 ダイアログ ボックスを使用します。

項目 | 説明
名前 | 実行サーバーの名前を定義します。この名前は、この特定のコンピュータからの実行に対するすべてのテーブルと結果レポートに表示されます。入力できるのは 100 文字までです。
説明 | 実行サーバーの説明です。任意の説明文を入力できます。
物理実行サーバー | このオプションを選択して物理マシンを実行サーバーとして指定します。
ホストまたは IP アドレス

実行サーバーをインストールするコンピュータのホスト名または IP アドレスを指定します。

ネットワークによっては、ドメイン名を含むホストの完全な名前（例：MyHost.MyDomain）を指定しないと、実行サーバーが検出されない場合があります。
ポート | ホストまたは IP アドレス フィールドで定義したコンピュータで、実行サーバーがリスンするポートを指定します。デフォルトのポートは 19124 です。
SSL を使用する

アプリケーション サーバーを実行サーバーに接続するときに SSL (Secure Sockets Layer) を使用する場合は、このチェック ボックスをオンにします。デフォルトの SSL ポートは 19125 です。

実行サーバーが割り当てられているロケーションに対してプロキシ サーバーを使用するように選択した場合は、SSL を使用する チェック ボックスをオンにして、ポートに 443 を指定する必要があります。
応答タイムアウト [秒]

仮想実行サーバーの場合：応答タイムアウト [秒] フィールドに、応答タイムアウト（秒単位）を入力します。クラウド プロバイダ上の実行サーバーが指定した時間内にアクセス可能にならない場合は、VM がシャットダウンされます。このような場合にシャットダウンしたくない場合には、0 を入力します（VM に到達できなくなる場合、テスト実行を手動で中止する必要があります）。

物理実行サーバーの場合：応答タイムアウト [秒] フィールドに、応答タイムアウト（秒単位）を入力します。実行サーバーが指定した時間内にアクセス可能にならない場合は、Silk Central の管理者に電子メールが送信されます。このような場合に電子メールを Silk Central に送信させたくない場合は、0 を入力します。
キーワード | この実行サーバーに定義されているキーワードの一覧。キーワードにより、各テスト実行に対して最も適切な実行サーバーを動的に判断する、Silk Central のハードウェア プロビジョニング技術が利用できます。この実行サーバーに対するキーワード一覧を編集するには、キーワード をクリックしてください。
親トピック: 実行サーバーを設定する


クラウド統合

Silk Central は、クラウド プロバイダ プロファイルを設定することで、パブリックまたはプライベートなクラウド サービスのプロバイダと統合することができます。クラウド プロファイルは、プラグインの概念に基づいており、特定のクラウド プロバイダに対する独自のプラグインをユーザーが作成することができます。クラウド プロバイダ プラグインは、各自動テストが実行される前に仮想環境をデプロイします。
注: クラウド API は、Silk Central の将来のバージョンで変更される可能性があります。この API を使用する場合は、Silk Central の将来のバージョンにアップグレードする際に、実装も更新する必要となる可能性があります。
  • クラウド プロファイルを追加する
    パブリックまたはプライベートなクラウド サービスのプロバイダと統合するためにクラウド プロファイルを追加します。
  • クラウド プロファイルを編集する
    パブリックまたはプライベートなクラウド サービスのプロバイダにアクセスする方法を変更するために、クラウド プロファイルを編集します。
  • クラウド プロファイルを削除する
    パブリックまたはプライベートなクラウド サービスの特定のプロバイダにアクセスする必要がなくなった場合、クラウド プロファイルを削除します。
  • VMware vCloud との統合
    VMware vCloud 固有の情報と制限事項の一覧を表示します。
  • クラウド プロバイダ ページ
    システムに構成されているクラウド プロバイダ プロファイルのリストが表示されます。
親トピック: 実行環境
関連概念
クラウド統合
関連タスク
クラウド ホスト型実行サーバーを設定する


クラウド プロファイルを追加する

パブリックまたはプライベートなクラウド サービスのプロバイダと統合するためにクラウド プロファイルを追加します。
  1. メニューで 管理 > 実行環境 をクリックします。
  2. クラウド プロバイダ タブをクリックします。
  3. プロファイルの新規作成 をクリックします。 クラウド プロバイダ プロファイルの新規作成 ダイアログ ボックスが開きます。
  4. インストール済みのプラグインの タイプ リストからアクセスしたいクラウド プロバイダを選択します。VMware vCloud および Amazon Web Services は、組み込みでサポートされています。
  5. 名前 フィールドに、プロファイルの名前を入力します。この名前は、クラウドにホストした実行サーバーを作成するときに、プロファイルのリストに表示されます。
  6. クラウド システムにリモート アクセスする際に必要な有効な認証情報を、ユーザー名 および パスワード フィールドに入力します。Amazon Web Services の場合は、アクセス キー および 秘密キー になります。
  7. VMware vCloud プロファイルを設定するには (他のプロファイルを設定する場合はこのステップは飛ばします)：
    1. Web ブラウザでシステムにアクセスする際に使用する /cloud/org/<組織名> を追加せずに、ホスト名のみを持つ URL を入力します。例：https://vdirectorweb.
    2. 省略可能： バージョン：VMware vCloud Director 5.5 (デフォルト) を使用している場合は、フィールドを空のままにしてください。vCloud Director 5.1 を使用している場合は、V5.1 を入力します。
    3. [Organization]：dev_org などの、アクセスする vCloud の組織名を入力します。
  8. Amazon Web Services プロファイルを設定するには (他のプロファイルを設定する場合はこのステップは飛ばします)：
    1. リージョン：インスタンスをデプロイしたいリージョンを選択します。
    2. インスタンス タイプ：Amazon が提供するインスタンス タイプ。たとえば、インスタンスがどの程度の RAM と CPU を持つかなどを定義します。これは、リース代にも影響します。 詳細については、『Amazon EC2 インスタンス』ページを参照してください。
    3. 接続エラー時にインスタンスのキープアライブを行う：アプリケーション サーバーと Amazon インスタンス間の接続が切断されたときに、インスタンスを生かし続けたい場合に true を選択します。
  9. 入力した情報を使用してクラウド プロバイダとの接続のテストを実行するには、接続のテスト をクリックします。
  10. OK をクリックして、設定を保存します。
選択したクラウド プロバイダが "Micro FocusSilk Central Execution Server 18.5.0.x" という名前のテンプレートを持つ場合、これらのテンプレートは仮想実行サーバーとして自動的にインポートされます。Silk Central を実行中の環境と完全に同じバージョンのテンプレートだけがインポートされます (ヘルプ > バージョン情報 を参照)。
親トピック: クラウド統合
関連タスク
クラウド ホスト型実行サーバーを設定する


クラウド プロファイルを編集する

パブリックまたはプライベートなクラウド サービスのプロバイダにアクセスする方法を変更するために、クラウド プロファイルを編集します。
重要: このプロファイルに基づく仮想環境がすでにデプロイされている場合 (グリッドのデプロイ済みインスタンス 列)、設定を変更すると、Silk Central はこのような未使用の環境を自動的に削除できなくなる可能性があります。
  1. メニューで 管理 > 実行環境 をクリックします。
  2. クラウド プロバイダ タブをクリックします。
  3. アクション 列の [image] をクリックして、このクラウド プロバイダのテンプレートを使用する実行サーバーのリストの同期を取ります。これは、存在しないテンプレートが割り当てられたこのプロファイルのすべての仮想実行サーバーを削除します。ホットフィックスを適用した後では、自動的に作成された仮想実行サーバーのテンプレートも更新します。
  4. 編集するプロファイルの アクション 列で [image] （編集）をクリックします。 クラウド プロバイダ プロファイルの編集 ダイアログ ボックスが開きます。
  5. 名前 フィールドに、プロファイルの名前を入力します。この名前は、クラウドにホストした実行サーバーを作成するときに、プロファイルのリストに表示されます。
  6. クラウド システムにリモート アクセスする際に必要な有効な認証情報を、ユーザー名 および パスワード フィールドに入力します。Amazon Web Services の場合は、アクセス キー および 秘密キー になります。
  7. VMware vCloud プロファイルを設定するには (他のプロファイルを設定する場合はこのステップは飛ばします)：
    1. Web ブラウザでシステムにアクセスする際に使用する /cloud/org/<組織名> を追加せずに、ホスト名のみを持つ URL を入力します。例：https://vdirectorweb.
    2. 省略可能： バージョン：VMware vCloud Director 5.5 (デフォルト) を使用している場合は、フィールドを空のままにしてください。vCloud Director 5.1 を使用している場合は、V5.1 を入力します。
    3. [Organization]：dev_org などの、アクセスする vCloud の組織名を入力します。
  8. Amazon Web Services プロファイルを設定するには (他のプロファイルを設定する場合はこのステップは飛ばします)：
    1. リージョン：インスタンスをデプロイしたいリージョンを選択します。
    2. インスタンス タイプ：Amazon が提供するインスタンス タイプ。たとえば、インスタンスがどの程度の RAM と CPU を持つかなどを定義します。これは、リース代にも影響します。 詳細については、『Amazon EC2 インスタンス』ページを参照してください。
    3. 接続エラー時にインスタンスのキープアライブを行う：アプリケーション サーバーと Amazon インスタンス間の接続が切断されたときに、インスタンスを生かし続けたい場合に true を選択します。
  9. 入力した情報を使用してクラウド プロバイダとの接続のテストを実行するには、接続のテスト をクリックします。
  10. OK をクリックして、設定を保存します。
親トピック: クラウド統合


クラウド プロファイルを削除する

パブリックまたはプライベートなクラウド サービスの特定のプロバイダにアクセスする必要がなくなった場合、クラウド プロファイルを削除します。
重要: プロファイルを削除すると、このプロファイルを使用するすべての実行サーバーも削除され、これらの実行サーバーを現在使用しているすべての実行も中止されます。 このプロファイルに基づく仮想環境がすでにデプロイされている場合 (グリッドのデプロイ済みインスタンス 列)、設定を変更すると、Silk Central はこのような未使用の環境を自動的に削除できなくなる可能性があります。
  1. メニューで 管理 > 実行環境 をクリックします。
  2. クラウド プロバイダ タブをクリックします。
  3. 削除するプロファイルの アクション 列で [image] （削除）をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックして削除を実行します。または、いいえ をクリックして削除を中止します。
親トピック: クラウド統合


VMware vCloud との統合

マッピング

vClound 実行サーバーとして利用可能なテンプレートは、vCloud のローカル (パブリックでない) カタログにある vApp テンプレートに相当します。それらは、<カタログ名> - <vApp テンプレート名> として表示されます。

テスト実行に対する仮想環境をデプロイすると、新しい vApp が vCloud Director に作成されます。 その名前は、テンプレート名をベースに - for Silk Central <タイムスタンプ> を末尾に追加したものになります。

ゲスト OS のカスタマイズ要件

Silk Central 実行サーバーが正しく起動できるようにするために、以下に示すように 、ゲスト OS のカスタマイズを vCloud Director の vApp テンプレート仮想マシン プロパティでアクティブ化され、設定されている必要があります。実行サーバーがユーザー セッションで開始されるように、VM リブートがゲスト OS のカスタマイズによって行われた後、Windows ログインが一度だけ行われるようにする必要があります。
  • ローカル管理者パスワードを許可 と 管理者として自動的にログイン を有効化する
  • パスワードを指定するか、vCloud に新たに生成させる
  • 初回ログイン時にパスワードの変更を管理者に要求 を無効化する
  • Windows 自身で、自動ログイン がアクティブになっていないとこを確認する (カスタマイズ リブートによりログインと実行サーバーの開始が二重に行われるため)

制限事項

  • Silk Central vCloud との統合は、ローカル (パブリックでない) カタログにある vApp テンプレートのみ利用することができます。パブリック カタログは、組織をまたいでテンプレートをコピーしたり移動する際に使用することができますが、そこに含まれたテンプレートを Silk Central で使用することはできません。テンプレートが他の組織で作成された場合、パブリック カタログにあるテンプレートから vApp を作成する際に潜在的問題が存在することが、この制限事項の理由です。テンプレートに関連した vDC と ネットワークが他の組織では有効でないためにこの問題が発生します。
  • フェンス機能はサポートされません。Silk Central は、vApp 内の複数の VM が既知の IP アドレスを持ち、互いに通信しあうことはサポートしません。これは、デプロイされた VM それぞれが動的に新しい IP アドレスを取得するためです。
  • Create Identical Copy 設定を持った vApp テンプレートはサポートされません。Silk Central で利用できるように vApp テンプレートを作成する場合は、vApp テンプレートのプロパティで、オプション Customize VM settings が有効になっていることを確認してください。このオプションをIdentical Copy に設定すると、Silk Central がこのテンプレートから vApp をデプロイしようとする際にエラーが発生します。このオプションは、vApp テンプレートを作成するときにのみ設定できることにご注意ください。
  • vCloud REST API を公開する商用サービス プロバイダへのアクセスはテストされていませんが、機能する可能性があります。この統合は、プライベート クラウドとしてインストールされた VMware vCloud Director 5.5 を使用してテストされました。
  • IP アドレスの競合を避けるため、ネットワーク アダプタを DHCP IP モードで設定した vApp テンプレートを格納してください。この設定がなされていないと、デプロイ後に最初に VM がブートしたときに、vApp マシンは、テンプレートを格納したときの古い静的 IP を持つことになります。VMware がゲスト OS のカスタマイズを行うときに、IP 設定が変更されてリブートされ、正しい IP が得られます。テンプレートでどんな設定がされていても、Silk Central は常に静的 IP プール モード (ゲスト OS のカスタマイズの後に適用される) を設定します、
  • 仮想データ センター (vDC) で複数のネットワークを使用している場合、格納した vApp テンプレートで使用されるようにネットワークを設定します。Silk Central は、新しい vApp をデプロイするときに、正しい vDC ネットワークを選択するために、テンプレートの VM ネットワークで設定されたネットワークの名前と vDC ネットワークの名前を一致させます。
  • テンプレート VM にインストールされている実行サーバーがバージョン 15.0 よりも古い場合、 As Process モードで実行する必要があります。
親トピック: クラウド統合


クラウド プロバイダ ページ

管理 > 実行環境 > クラウド プロバイダ

クラウド プロバイダ ページには、構成されているすべてのクラウド プロバイダ プロファイルのリストが表示されます。このページは、クラウド プロバイダ プロファイルの管理に使用します。

このページでは、次のアクションを実行できます。

  • プロファイルの新規作成 をクリックして、新しいクラウド プロバイダ プロファイルを作成します。
  • 設定を編集する場合は、アクション 列の [image] (編集) をクリックします。
  • アクション 列で 削除 (削除) をクリックして、クラウド プロバイダ プロファイルを削除します。
  • アクション 列の [image] をクリックして、このクラウド プロバイダのテンプレートを使用する実行サーバーのリストの同期を取ります。これは、存在しないテンプレートが割り当てられたこのプロファイルのすべての仮想実行サーバーを削除します。ホットフィックスを適用した後では、自動的に作成された仮想実行サーバーのテンプレートも更新します。
親トピック: クラウド統合


デバイス プロバイダを管理する

デバイス プロバイダは、モバイル エミュレータやシミュレータをホストする、または接続された物理モバイル デバイスを持つコンピュータであり、テストを実行するためにアクセスできます。

デバイス プロバイダに接続された物理モバイル デバイスや、インストールされたエミュレータやシミュレータを、テスト担当者やテスト計画で利用可能にすることができます。その後、手動テストと自動テストを、これらのモバイル デバイス上で直接実行できます。

今日のソフトウェアは、通常、複数のプラットフォーム上で、またすべての種類のモバイル デバイス上で実行することが必要とされるため、ユーザーのソフトウェアがサポートするすべてのプラットフォームとデバイスを対象とした構成テストを実行する場合に、この機能は特に役立ちます。

  • デバイス プロバイダを設定する
    モバイル デバイス（物理デバイス、エミュレータ、シミュレータ）上のアプリケーションをテストするには、デバイス プロバイダを設定します。
  • Silk Test Information Service を Mac にインストールする
    Information Service を Mac にインストールし、Silk Test を使用して iOS 上の Apple Safari やモバイル アプリケーションをテストできます。
  • デバイス プロバイダを削除する
    接続したデバイスがテスト実行で使用されなくなった場合に、デバイス プロバイダを削除します。
親トピック: 実行環境
関連タスク
モバイル デバイスを構成に割り当てる
自動テストのモバイル デバイスを選択する
手動テストのモバイル デバイスを選択する
関連資料
デバイス プロバイダを設定する
ライセンスの扱い


デバイス プロバイダを設定する

モバイル デバイス（物理デバイス、エミュレータ、シミュレータ）上のアプリケーションをテストするには、デバイス プロバイダを設定します。

デバイス プロバイダを設定する前に、次の前提条件を満たしていることを確認してください。
  • Silk Test Information Service：デバイス プロバイダを使用するには、モバイル デバイスをホストするコンピュータ上に Silk Test Information Service をあらかじめインストールしておく必要があります。
    1. セットアップ ファイルを、Micro Focus SupportLine からダウンロードします。
    2. セットアップ ファイルを実行して、インストール ウィザードに従ってインストールしてください。Mac 上でのデバイス プロバイダの設定についての情報は、「Silk Test Information Service を Mac にインストールする」を参照してください。
  • Mobile Center と Sauce Labs：Silk Test のドキュメントを参照してください。
    • Silk Test Workbench を使用してモバイル アプリケーションをテストする場合
    • Silk4J を使用してモバイル アプリケーションをテストする場合
    • Silk4NET を使用してモバイル アプリケーションをテストする場合

デバイス プロバイダを設定するには：

  1. メニューで 管理 > 実行環境 をクリックします。
  2. デバイス プロバイダ タブをクリックします。
  3. デバイス プロバイダを設定するロケーションを選択します。
    • 新しいデバイス プロバイダを作成するには、デバイス プロバイダの新規作成 をクリックします。
    • 既存のデバイス プロバイダを編集するには、アクション 列でそれぞれ対応する 編集 ボタンをクリックします。
    注: 同じデバイス プロバイダを複数のロケーションに追加できます。
  4. デバイス プロバイダの種類 を選択します。
    • Silk Test Information Service：モバイル デバイスをホストするコンピュータの Silk Test Information Service URL を入力します。このフィールドには、IP アドレス、URL、またはホスト名を指定できます（http://<コンピュータ名>:22901 など）。ポートが指定されていない場合、デフォルトのポート 22901 が追加されます。
    • Sauce Labs：Sauce Labs ユーザー の名前と Sauce Labs の アクセス キー を入力します。 アクセス キーは、https://saucelabs.com にログインして My Account を選択すると表示されます。 手動テストで Sauce Labs デバイスを使用する場合は、Silk Test Information Service をリストから選択する必要があります。Silk Test Information Service を選択しない場合は、Sauce Labs デバイスは自動テストに対してのみ使用できます。
    • Mobile Center：Mobile Center の URL、ユーザー の名前、および パスワード を入力します。
  5. 名前 フィールドに、デバイス プロバイダの名前を入力します。
  6. 接続のテスト をクリックします。接続のテストが成功した場合は、OK をクリックします。
親トピック: デバイス プロバイダを管理する
関連概念
デバイス プロバイダを管理する
関連タスク
モバイル デバイスを構成に割り当てる
自動テストのモバイル デバイスを選択する
手動テストのモバイル デバイスを選択する


Silk Test Information Service を Mac にインストールする

注: Information Service を Mac にインストールするには、Mac の管理者権限が必要です。

Mac 上の Apple Safari や、Mac に接続されている iOS や Android デバイス上のモバイル アプリケーションに対するテストを作成して実行するには、Mac に Silk Test Information Service (Information Service) をインストールしてから、リモート ロケーション ダイアログ ボックスを使用して、Silk Test をインストールした Windows マシンと Mac を接続する必要があります。

Information Service を Mac にインストールするには：

  1. Java JDK が Mac 上にインストールされていることを確認します。
  2. iOS デバイス上でモバイル アプリケーションをテストする場合は、Xcode が Mac 上にインストールされていることを確認します。
  3. Information Service セットアップ ファイル（SilkTestInformationService<バージョン>-<ビルド番号>.pkg にアクセスします。
    • Silk Test のインストール時に Information Service セットアップ ファイルをダウンロードした場合は、Silk Test インストール ディレクトリ（C:\Program Files (x86)\Silk\SilkTest など）の macOS フォルダを開きます。
    • Silk Test のインストール時に Information Service セットアップ ファイルをダウンロードしなかった場合は、Micro Focus SupportLine からセットアップ ファイルをダウンロードできます。
  4. SilkTestInformationService<バージョン>-<ビルド番号>.pkg ファイルを Mac にコピーします。
  5. SilkTestInformationService<バージョン>-<ビルド番号>.pkg を実行して、Information Service をインストールします。
  6. インストール ウィザードの指示に従います。
  7. パスワードを尋ねられた場合、現在サインインしている Mac ユーザーのパスワードを入力します。
  8. Apple Safari が開き、SafariDriver を信頼するかどうかを尋ねるメッセージ ボックスが表示されたら、信頼 をクリックします。
    注: リモート接続ではなく、直接 Mac にログインしている場合には、SafariDriver だけをインストールできます。
インストールを完了するために、現在の Mac ユーザーをログアウトします。Information Service が正しくインストールされていることを確認するには、Mac にログインし、画面の右上隅にある Silk Test アイコンをクリックして、利用可能なデバイスとブラウザーを表示させます。
ヒント: Silk Test アイコンが表示されない場合は、Mac を再起動してください。
親トピック: デバイス プロバイダを管理する


デバイス プロバイダを削除する

接続したデバイスがテスト実行で使用されなくなった場合に、デバイス プロバイダを削除します。
  1. メニューで 管理 > 実行環境 をクリックします。
  2. ロケーションを選択して、そのロケーションに定義されているデバイス プロバイダのリストを表示します。
  3. 削除するデバイス プロバイダの アクション 列で、 削除 をクリックします。
親トピック: デバイス プロバイダを管理する


レポート テンプレートを管理する

Silk Central には、各種レポートが事前に組み込まれていて、データをプレゼンテーションに利用できる分析情報にすばやく簡単に変換できます。デフォルトのレポートは、Microsoft Excel、Microsoft Word、または BIRT (Eclipse 上で動くオープン ソースの Web アプリケーション用レポート ツール) のいずれかを使用してカスタマイズできます。またはこれらのツールを使用して、新しいレポートを一から作成できます。

共有グローバル レポートは、すべてのユーザーのすべてのプロジェクトで利用可能であるため、更新したり削除したりできるユーザー ロールとして、共有グローバル レポートの管理 および 共有グローバル レポートの削除 の特別なアクセス許可が必要です、共有グローバル レポートで使用するレポート テンプレートに対しても、これらのアクセス許可が適用されます。非共有グローバル レポートとレポート テンプレートは、レポートの更新や削除といった標準レポートのアクセス許可を持つユーザー ロールによって更新および削除することができます。

Silk Central のレポートではビットマップ画像ファイル形式 (.bmp) をサポートしません。正確に表示するには、JPEG、GIF または PNG 形式の画像が必要です。

  • カスタム レポート テンプレートを BIRT で管理する
    Silk Central で BIRT を使用する方法について説明します。
  • 既存のレポート テンプレートを導入する
    既存の BIRT レポート テンプレートを導入してカスタム レポートを作成します。
  • レポート テンプレートのプロパティを編集する
    名前、説明、あるいはどのモジュールでテンプレートを使用するかなどの Silk Central レポート テンプレートのプロパティを編集できます。
  • レポート テンプレートをダウンロードする
    Silk Central レポート テンプレートをダウンロードして、BIRT Report Designer または Microsoft Excel で編集します。
  • レポート テンプレートをアップロードする
    カスタマイズした Silk Central レポート テンプレートをアップロードして、他のユーザーと共有します。
  • レポート ソースを更新する
    変更したテンプレート ファイルでレポート テンプレートを更新し、カスタマイズしたレポートを Silk Central に移動します。
  • レポート テンプレートを削除する
    レポート テンプレートを削除して、利用可能なレポートのリストから削除します。
  • [レポート テンプレート] ページ
    レポート テンプレートの管理に使用します。
親トピック: 管理


カスタム レポート テンプレートを BIRT で管理する

Silk Central は BIRT（Business Intelligence and Reporting Tools）Report Designer と緊密に統合されているため、テスト データ、ビルド データ、欠陥データ、および要件データのレポートを簡単に作成できます。

BIRT Report Designer をダウンロードした後は、コア Silk Central レポートをカスタマイズして、独自のレポートを追加できます。レポートの実行とカスタマイズについては、アプリケーションのヘルプを参照してください。

BIRT Report Designer の詳細については、BIRT Report Designer のオンライン ヘルプ システムを参照してください。BIRT Report Designer の詳細情報、例、およびデモンストレーションは、http://www.eclipse.org/birt で提供されています。活発なニュースグループ（news.eclipse.org）も利用できます。

BIRT カスタム レポートを使用するためのソフトウェア要件は以下のとおりです。

  • BIRT Report Designer
  • 管理者権限での Silk Central へのアクセス
注: Silk Central のレポートではビットマップ画像ファイル形式 (.bmp) をサポートしません。正確に表示するには、JPEG、GIF または PNG 形式の画像が必要です。
  • Silk Central から BIRT をインストールする
    BIRT を Silk Central からインストールして、Silk Central に必要なすべての設定を適用します。
  • 新規レポート テンプレート用のデータベース アクセスを確立する
    BIRT Report Designer から Silk Central データベースへのデータベース アクセスを確立して、新しいレポート テンプレートを作成します。
  • BIRT データ ソース設定
    BIRT から Silk Central へのアクセスを確立するために必要な設定について説明します。
親トピック: レポート テンプレートを管理する
関連タスク
BIRT レポート テンプレートをカスタマイズする


Silk Central から BIRT をインストールする

この手順では、BIRT Report Designer を Silk Central からインストールする方法について説明します。BIRT をこのようにインストールすることによって、Silk Central に対して必要なすべての設定が自動的に実行されます。

BIRT を Silk Central からインストールするには：

  1. ヘルプ > ツール に移動します。
  2. BIRT RCP Report Designer リンクをクリックします。
  3. 圧縮したインストーラ パッケージをローカル システムにダウンロードした後に、圧縮ファイルをローカル システムのディレクトリ（C:\BIRT など）に展開します。
    注: Windows の圧縮フォルダ機能を使用してインストーラ ファイルを展開したときにエラーが発生する場合は、圧縮ツール (WinZip、WinRAR など) を使用して、ファイルを展開してください。
  4. ファイルを展開したディレクトリから BIRT.exe を起動します。
親トピック: カスタム レポート テンプレートを BIRT で管理する


新規レポート テンプレート用のデータベース アクセスを確立する

BIRT Report Designer で新しいレポート テンプレートを作成する前に、クエリを実行する Silk Central リポジトリへのデータベース アクセスを確立する必要があります。

新規レポート テンプレート用のデータベース アクセスを確立するには：

  1. BIRT Report Designer 内から、 File > New > New Report を選択します。
  2. New Report ウィザードのステップに従います。
  3. Resource Explorer を開きます。
  4. Resource Explorer で、Shared Resources > conf > birt > library.rptlibrary > Data Sources > Data Source をクリックし、必須データソースをレポートの Data Sources ディレクトリ（Outline ウィンドウの中）にドラッグします。
  5. Resource Explorer で、Shared Resources > conf > birt > library.rptlibrary > Report Parameters をクリックし、4 つのレポート パラメータ sourceUser、sourcePassword、sourceURL、および sourceDriver をレポートの Report Parameters ディレクトリ（Outline ウィンドウの中）にドラッグします。
  6. 新しくインポートされたデータ ソースをダブルクリックして、Edit Data Source ダイアログ ボックスを開きます。
  7. Driver Class と Database URL に有効な値を入力します。 詳細については、「BIRT データ ソース設定」を参照してください。
  8. Test Connection をクリックして、設定をテストします。 データベース接続が確立された場合は、新しいレポート テンプレートの設計を開始できます。
  9. OK をクリックします。
親トピック: カスタム レポート テンプレートを BIRT で管理する


BIRT データ ソース設定

BIRT の New JDBC Data Source Profile ダイアログ ボックスを使用して、既存の Silk Central リポジトリへのデータベース アクセスを確立します。New JDBC Data Source Profile ダイアログ ボックスにアクセスするには、Outline ペインの Data Sources を右クリックし、New Data Source をクリックし、JDBC Data Source を選択して Next をクリックします。

MS SQL Server または MS SQL Server Express データベースに接続するには、次の認証情報を使用します。

項目 | 文字列
ドライバ クラス | net.sourceforge.jtds.jdbc.Driver
ドライバの URL
MS SQL Server
jdbc:jtds:sqlserver://<ホスト>:<ポート>/<データベース>
Microsoft SQL Server Express
jdbc:jtds:sqlserver://<ホスト>:<ポート>/<データベース>;instance=<インスタンス名>
ホスト
データベース サーバーをホストしているコンピュータのホスト名（または IP アドレス）。
ポート
データベース管理システムのポート番号。デフォルトは 1433 です。
データベース
データベースの名前。
インスタンス名
MS SQL Server Express の場合のみ。データベース インスタンスのインスタンス名。デフォルトの Microsoft SQL Server Express インスタンスは、localhost\SQLExpress です。

Oracle データベースに接続するには、次の認証情報を使用します。

項目 | 文字列
ドライバ クラス | oracle.jdbc.OracleDriver
ドライバの URL jdbc:oracle:thin:@<ホスト>:<ポート>:<データベース>
ホスト
データベース サーバーをホストしているコンピュータのホスト名（または IP アドレス）。
ポート
データベース管理システムのポート番号。デフォルトは 1521 です。
データベース
Oracle SID。
親トピック: カスタム レポート テンプレートを BIRT で管理する


既存のレポート テンプレートを導入する

Silk Central により、ユーザーは Silk Central モジュールを使用して、カスタム レポート テンプレートを作成するために必要なすべての情報を含む BIRT レポート テンプレートをダウンロードし導入できます。

注: Silk Central のレポートではビットマップ画像ファイル形式 (.bmp) をサポートしません。正確に表示するには、JPEG、GIF または PNG 形式の画像が必要です。

Silk Central テンプレートを基にしたレポートを作成するには：

  1. メニューで 管理 > レポート テンプレート をクリックします。 レポート テンプレート ページに、アップロードされたすべてのレポート テンプレートが一覧表示されます。
  2. アクション 列の レポート テンプレートのダウンロード をクリックします。
  3. テンプレート ファイル (<ファイル名>.rptdesign) をローカル システムに保存します。
  4. ダウンロードしたテンプレート ファイルを BIRT Report Designer で開きます。
  5. 必要な場合、レポートのデザインを変更します。 レポートのデザインの詳細については、BIRT Report Designer のオンライン ヘルプ システムを参照してください。
  6. レポートをプレビューするには、Run メニューから View Report > As HTML を選択します。 レポートをプレビューするブラウザは、次のようにして指定できます。
    • Window > Preferences > Web Browser をクリックし、Use external web browser を選択してブラウザを選びます。
    • Window > Preferences > Report Design > Preview をクリックし、Always use external browsers チェック ボックスをオンにします。
  7. 初めてレポートをプレビューするときは、Enter Parameters ダイアログ ボックスが開くので、有効なセッション ID を指定する必要があります。セッション ID を生成するには、Web ブラウザで次の URL を実行します。 http://<ホスト>:<ポート>/services/sccsystem?method=logonUser&userName=<ユーザー名>&plainPasswd=<パスワード>
    パラメータ
    説明
    ホスト
    Silk Central をホストしているコンピュータのホスト名（または IP アドレス）。
    ポート
    Silk Central フロントエンド サーバーのポート番号。デフォルト設定は、19120（スタンドアロン Web サーバーから Silk Central へアクセスする場合）および 80（IIS から Silk Central へアクセスする場合）です。
    ユーザー名/パスワード
    Silk Central ユーザーの有効な認証情報。
    注: 有効な認証情報 USERNAME/PASSWORD の順番はとても重要です。
  8. レポートを編集している途中でデータが表示されない場合、可能性が高い原因はセッション ID のタイムアウトです (タイムアウト値は 10 分)。ブラウザ ウィンドウを閉じ、再び Run メニューから View Report > As HTML を選択します。新しいセッション ID を生成するには、前のステップを繰り返します。
親トピック: レポート テンプレートを管理する


レポート テンプレートのプロパティを編集する

BIRT Report Designer、Word、Excel を使用して新しいカスタム レポート テンプレートを作成し、Silk Central にアップロードしたら、名前、説明、あるいはどのモジュールでテンプレートを使用するかなどのテンプレートのプロパティを編集できます。

  1. メニューで 管理 > レポート テンプレート をクリックします。 レポート テンプレート ページに、アップロードされたすべてのレポート テンプレートが一覧表示されます。
  2. アクセス許可や関連を設定または編集するレポート テンプレートの名前をクリックします。 レポート テンプレートの編集 ダイアログ ボックスが表示されます。
  3. 名前、ファイル名、説明 フィールドを使用して、テンプレートのプロパティを編集します。
  4. モジュール リストで、レポート テンプレートを Issue Manager レポートで使用するか、Test Manager レポートで使用するか（あるいはその両方か）、を選択できます。
  5. 編集を完了したら、OK をクリックしてレポート テンプレートへの変更を保存します。 編集内容はすぐに適用されます。ユーザーが次にアクセスしたとき、またはレポート リストを更新したときに、変更が表示されます。
親トピック: レポート テンプレートを管理する


レポート テンプレートをダウンロードする

選択したレポートのレポート テンプレート（レイアウトも含む）をダウンロードします。Silk Central レポート テンプレートをユーザーのローカル システムにダウンロードして編集できます。レポートをダウンロードして編集した後で、別のユーザーが利用できるようにアップロードできます。詳細については、「レポート テンプレートをアップロードする」を参照してください。

Silk Central レポート テンプレートをダウンロードするには：

  1. メニューで 管理 > レポート テンプレート をクリックします。 レポート テンプレート ページに、アップロードされたすべてのレポート テンプレートが一覧表示されます。
  2. ダウンロードするレポートの アクション 列で、 レポート テンプレートのダウンロード をクリックします。 ファイルのダウンロード ダイアログ ボックスが表示されます。
  3. 保存 をクリックするとレポート ファイルがローカル システムにダウンロードされます。ファイル形式は、ダウンロードするレポートのタイプにより異なります。
  4. ダウンロードしたファイル形式に応じて、rptdesign ファイルは BIRT Report Designer、docx ファイルは Word、xls/xlsx ファイルは Excel を使用してレポートを編集します。
親トピック: レポート テンプレートを管理する


レポート テンプレートをアップロードする

Silk Central のレポート テンプレートをアップロードすると、他のユーザーが利用できるようになります。場合により、BIRT Report Designer、Microsoft Word、または Microsoft Excel で編集した後で、レポート テンプレートをアップロードする必要があります。レポートが関連付けられているモジュールとプロジェクトへのアクセス権がある場合のみ、レポートを実行できます。

ヒント: テンプレートには、Silk Central にアップロードしたときに識別できるように、付加情報を構成する必要があります。
注: Silk Central のレポートではビットマップ画像ファイル形式 (.bmp) をサポートしません。正確に表示するには、JPEG、GIF または PNG 形式の画像が必要です。

カスタマイズしたテンプレートを新しいレポートとしてアップロードするには：

  1. メニューで 管理 > レポート テンプレート をクリックします。 レポート テンプレート ページに、アップロードされたすべてのレポート テンプレートが一覧表示されます。
  2. ページ下部の アップロード をクリックします。 レポート テンプレートのアップロード ダイアログ ボックスが表示されます。
  3. 名前 にレポートの名前を入力します。
  4. 省略可能：説明 にレポートの説明を入力します。
  5. モジュール リスト ボックスで、レポートに関連付けるモジュールを選択します。 複数のモジュールを選択するには、Ctrl キーを押したままにします。
  6. ファイル フィールドの横にある 参照 をクリックします。
  7. レポート テンプレートの基礎として使用するテンプレート ファイルを参照して選択します。 選択するファイルの拡張子は、rptdesign、docx、xlsx、または xls です。
  8. OK をクリックして、レポート テンプレートを使用できるように Silk Central にアップロードします。
親トピック: レポート テンプレートを管理する


レポート ソースを更新する

既存の Silk Central のレポート テンプレートを更新すると、BIRT Report Designer、Microsoft Word、または Microsoft Excel でカスタマイズしたレポートを Silk Central に移動でき、別のユーザーが利用できるようになります。

注意:
Silk Central に同梱のレポート テンプレートは、新しいバージョンにアップグレードしたときに、自動的に更新されます。したがって、カスタマイズしたレポート テンプレートは専用のカスタム フォルダに保存すること、または新しいテンプレートとしてカスタマイズしたレポート テンプレートをアップロードすることが重要です。詳細については、「レポート テンプレートをアップロードする」を参照してください。

変更したテンプレート ファイルでレポート テンプレートを更新するには：

  1. メニューで 管理 > レポート テンプレート をクリックします。 レポート テンプレート ページに、アップロードされたすべてのレポート テンプレートが一覧表示されます。
  2. 更新するレポートの アクション 列で、 更新 をクリックします。
  3. レポート テンプレート ファイルの更新 ダイアログ ボックスの 参照 をクリックして、既存のテンプレート ファイルを上書きするテンプレート ファイルを参照して選択します。 選択するファイルの拡張子は、rptdesign、docx、xlsx、または xls です。
  4. OK をクリックしてファイルをアップロードし、今までレポート テンプレートの基準として使用されていたファイルを上書きします。
親トピック: レポート テンプレートを管理する


レポート テンプレートを削除する

利用可能なレポートのリストから Silk Central レポートを削除できます。

Silk Central レポートを削除するには：

  1. メニューで 管理 > レポート テンプレート をクリックします。 レポート テンプレート ページに、アップロードされたすべてのレポート テンプレートが一覧表示されます。
  2. 削除するレポートの アクション 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  3. はい をクリックしてリストからレポートを削除します。
親トピック: レポート テンプレートを管理する


[レポート テンプレート] ページ

管理 > レポート テンプレート

レポート テンプレート ページを使用して、Silk Central によるレポートのために利用可能にするレポート テンプレートを管理します。レポート テンプレートはすべてのプロジェクトにわたるすべてのレポートに対してグローバルに利用可能です。

アップロード をクリックして、新しいレポート テンプレートをハード ディスクまたは UNC から Silk Central にアップロードします。

リスト内のレポートごとに、次の列がページに表示されます。

列 | 説明
タイトル | アプリケーションの GUI に表示されるレポート テンプレートの名前。
ファイル名 | レポート テンプレートの物理ファイル名。
アップロード日時 | レポート テンプレートが Silk Central にアップロードされた日時。
アップロード者 | このレポート テンプレートを Silk Central にアップロードしたユーザー。
モジュール | レポート テンプレートにアクセスできる Silk Central アプリケーション。テンプレートがどのモジュールにも割り当てられていない場合は、どのアプリケーションでもこのテンプレートを使用できます。
アクション この列にはアクションのアイコンが含まれ、ユーザーはレポート テンプレートについて次のアクションを実行できます。
更新
現在アップロードされているテンプレートを新しいテンプレートで置き換えます。
ダウンロード
テンプレートをローカル コンピュータにダウンロードします。
削除
テンプレートを完全に削除します。
親トピック: レポート テンプレートを管理する


監査ログ

管理 > ログ ファイル > 監査ログ

管理者は、監査ログを使用することで、Silk Central ユーザーの記録されている全アクティビティを見ることができます。ログ ファイルには、ログインとログアウトの全情報、および Silk Central データベース（プロジェクト、テスト、スケジュールなど）に対するすべての変更が保存されます。

利用可能な機能を使用することで、情報ニーズに合うように一覧のログ エントリを管理できます。

列によるデータのソート

列の見出しをクリックすると、一覧のすべてのデータがその列でソートされます。同じ列見出しを繰り返しクリックすると、ソート順が昇順または降順に切り替わります。

カレンダーからの範囲の選択

表示されている時間範囲をクリックすると、カレンダーが開きます。カレンダーの 開始時間 行と 終了時間 行で、表示するデータの期間の開始と終了を指定できます。リスト ボックスで 開始時間 と 終了時間 を指定した後、更新 をクリックすると、新しい時間範囲に基づいて監査ログが更新されます。

日、週、月、四半期、過去 7 日間を選択、過去 31 日間を選択 の各リンクを使用すると、カレンダーを使用せずに、設定されている期間の情報を表示できます。

また、以降 および 以前 の矢印を使用して、選択されている範囲を次の間隔で後および前に移動できます。
  • 1 日
  • 1 週
  • 1 月
  • 1 四半期

拡大 および 縮小 を使用すると、監査ログの対象の時間範囲を広げたり狭めたりできます。 拡大 を 1 回クリックすると、期間が 50% 広くなります。 縮小 を 1 回クリックすると、期間が 50% 狭くなります。

カレンダーがカスタム期間（たとえば、拡大または縮小した後）を表示しているときに、左端の矢印（以前 および 以降）をクリックすると、表示範囲が、選択されている期間の半分だけ前方または後方に移動します。

ヒント: 新しい期間を指定した後、更新 をクリックすると、レポートが更新されます。

データのフィルタリング

フィルタ オプションを使用すると、解析する監査ログ情報を絞り込むことができます。

次の項目によりリスト表示データをフィルタ処理できます。
ログイン
指定したユーザー ログインのアクションを表示します。
オブジェクト
指定したデータベース項目（プロジェクト、ロケーションなど）に対して実行されたアクションを表示します。
操作
選択した操作（ログイン、ログオフ、作成、削除など）を表示します。
  • 監査ログにアクセスして表示する
    監査ログにアクセスして表示し、記録されている全ユーザー アクティビティを確認します。
  • [監査ログ] ページ
    このページは、Silk Central ユーザーの記録されている全アクティビティの表示に使用します。
親トピック: 管理


監査ログにアクセスして表示する

監査ログを表示するには：

  1. メニューで 管理 > ログ ファイル をクリックします。
  2. 監査ログ タブをクリックします。
  3. カレンダーで範囲を選択して、示されるログ エントリを限定します。
  4. フィルタ オプションを使って、解析する監査ログ情報を絞り込みます。
親トピック: 監査ログ


[監査ログ] ページ

管理 > ログ ファイル > 監査ログ

監査ログ ページは、Silk Central ユーザーの記録されている全アクティビティの表示に使用します。

項目 | 説明
カレンダー領域 | カレンダーで範囲を選択して、示されるログ エントリを限定します。
フィルタ領域 | フィルタ オプションを使って、解析する監査ログ情報を絞り込みます。 更新 をクリックして、リストをフィルタ設定に従ってリフレッシュします。
結果領域 | このセクションには、ログに記録された情報が表示されます。 ページ間を移動するには、ページ番号を使用します。 列の見出しをクリックすると、その列でソートされます。

カレンダーおよびフィルタ オプションの詳細については、「監査ログ」を参照してください。

親トピック: 監査ログ


サーバー ログ ファイル

フロントエンド サーバー、アプリケーション サーバー、および実行サーバーはログ ファイルに記録します。 これらのファイルには、エラー解析に役立つ情報が含まれています。 Silk Central では、管理者は、これらのファイルを Web インターフェイスから直接、表示、検索、およびダウンロードできます。

  • サーバー ログ ファイルをダウンロードする
    サーバー ログ ファイルをローカル コンピュータにダウンロードして、Microsoft Excel などでデータを詳しく解析します。
  • サーバー ログ ファイルを解析する
    サーバー ログ ファイルを解析して、サーバー アクティビティでエラーが発生したかどうかを確認します。
  • サーバー ログ ファイルを削除する
    情報が不要になったときに、既存のサーバー ログ ファイルを削除します。
  • ログ ファイルの管理
    サーバー ログ ファイルに書き出す詳細レベルをカスタマイズする方法について説明します。
  • [フロントエンド サーバー ログ] ページ
    このページは、Silk Central フロントエンド サーバー サービスのログ情報の表示に使用します。
  • [アプリケーション サーバー ログ] ページ
    Silk Central アプリケーション サーバー サービスのログ情報の表示に使用します。
  • [実行サーバー ログ] ページ
    このページは、Silk Central 実行サーバー サービスのログ情報の表示に使用します。
親トピック: 管理


サーバー ログ ファイルをダウンロードする

サーバー ログ ファイルをローカル コンピュータに CSV 形式でダウンロードできます。 これにより Microsoft Excel などでさらにデータ解析が可能です。

サーバー ログ ファイルをダウンロードするには：

  1. メニューで 管理 > ログ ファイル をクリックします。
  2. ログ ファイルが属するサーバーのタブをクリックします。
    • フロントエンド サーバー ログ
    • アプリケーション サーバー ログ
    • 実行サーバー ログ
    ログ ファイルのリストが時間順に表示されます。ログ ファイル名は、サーバー コンポーネント名とそれに続くタイムスタンプで構成されます。最新のログ ファイルの名前は、FrontendServer.log、AppServer.log、および ExecServer.log です。
    注: 実行サーバー ログ ファイルを見つけるには、ロケーションから個別の実行サーバーに移動します。
  3. ログ ファイルの アクション 列で、 ダウンロード をクリックします。 代替方法：ダウンロードする前にログ ファイルの内容を表示するには、ダウンロード対象のログ ファイル名をクリックします。 選択したログ ファイルが表示されます。 このときログ エントリは時間順になっています。 ページ下部の CSV としてダウンロード をクリックします。
  4. 表計算プログラムにデータを表示するには、続いて表示されるダイアログ ボックスで 開く を選択します。 データをハード ドライブに保存するには、表示されたダイアログ ボックスで 保存 を選択します。
親トピック: サーバー ログ ファイル


サーバー ログ ファイルを解析する

サーバー ログ ファイルを解析するには：

  1. メニューで 管理 > ログ ファイル をクリックします。
  2. ログ ファイルが属するサーバーのタブをクリックします。
    • フロントエンド サーバー ログ
    • アプリケーション サーバー ログ
    • 実行サーバー ログ
    ログ ファイルのリストが時間順に表示されます。ログ ファイル名は、サーバー コンポーネント名とそれに続くタイムスタンプで構成されます。最新のログ ファイルの名前は、FrontendServer.log、AppServer.log、および ExecServer.log です。
    注: 実行サーバー ログ ファイルを見つけるには、ロケーションから個別の実行サーバーに移動します。
  3. 表示するログ ファイルの名前をクリックします。 選択したログ ファイルが表示されます。このときログ エントリは時間順になっています。
  4. フィルタ オプションにより、記録されたログ情報のページを表示できます。
    次の項目によりリスト表示データをフィルタ処理できます。
    深刻度
    選択した深刻度のイベントを表示します。
    ログ レベル
    選択したログ レベルに一致するイベントを表示します。サーバーに応じたログ レベルを設定したときのみ、さらに詳しいログ情報を表示できます。サーバーのログ レベルの設定についての詳細は、「ログ レベル」を参照してください。
    モジュール
    選択したモジュールのログ情報を表示します。ログ エントリを表示できるのは、該当製品（各モジュール）がインストールされ、アクセスするフロントエンド サーバーに接続されているときのみです。
親トピック: サーバー ログ ファイル


サーバー ログ ファイルを削除する

注意:
ログ ファイルを削除すると、サーバーからファイルが恒久的に削除されます。 削除したファイルからログ データを表示できません。

サーバー ログ ファイルを削除するには：

  1. メニューで 管理 > ログ ファイル をクリックします。
  2. ログ ファイルが属するサーバーのタブをクリックします。
    • フロントエンド サーバー ログ
    • アプリケーション サーバー ログ
    • 実行サーバー ログ
    ログ ファイルのリストが時間順に表示されます。ログ ファイル名は、サーバー コンポーネント名とそれに続くタイムスタンプで構成されます。最新のログ ファイルの名前は、FrontendServer.log、AppServer.log、および ExecServer.log です。
    注: 実行サーバー ログ ファイルを見つけるには、ロケーションから個別の実行サーバーに移動します。
  3. 削除するログ ファイルの アクション 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  4. いいえ をクリックするとログ ファイルの削除が中止され、はい をクリックすると、リストからログ ファイルが削除されます。 はい をクリックすると、ログ ファイルのリストが再表示されます。削除したログ ファイルは表示されません。
親トピック: サーバー ログ ファイル


ログ ファイルの管理

Silk Central の各サーバーは、それぞれのアクティビティをログ ファイルに書き出します。Silk Central サーバーの詳細については、「Silk Central のアーキテクチャ」を参照してください。アプリケーション エラーやシステム障害が発生したときには、これらのログ ファイルが問題の根本原因を究明するための貴重な情報となります。サーバー ログ ファイルに書き出す詳細レベルをカスタマイズすることができます。

Silk Central サーバーのログ ファイルには、管理 > ログ ファイル からアクセスできます。

  • Silk Central サーバーのログ レベルを変更する
    Silk Central サーバーのログの詳細レベルを変更して、ログ ファイルに情報を含めたり、ログ ファイルから情報を除外したりします。
親トピック: サーバー ログ ファイル
関連資料
Silk Central のアーキテクチャ


Silk Central サーバーのログ レベルを変更する

ログ ファイルを生成するのは次のサーバーです。
  • フロントエンド サーバー
  • アプリケーション サーバー
  • 実行サーバー

Silk Central サーバーのログ レベルを変更するには：

  1. ログ レベルを変更するサーバーを停止します。
  2. ログ レベルを変更するサーバー に対応する次のファイルをテキスト エディタで開きます。
    フロントエンド サーバー
    SccFrontendBootConf.xml。フロントエンド サーバー上の Silk Central ディレクトリの /conf/frontendserver フォルダにあります。
    アプリケーション サーバー
    SccAppServerBootConf.xml。アプリケーション サーバー上の Silk Central ディレクトリの /conf/appserver フォルダにあります。
    実行サーバー
    SccExecServerBootConf.xml。実行サーバー上の Silk Central ディレクトリの /conf/execserver フォルダにあります。
  3. ファイルの <Log> セクションで <LogLevel> という XML タグを探します。
  4. サーバーが情報を書き出すログ レベルの値を設定します。 次のログ レベルがあります。
    値 | ログ レベル | 説明
    0 | 概要 | サーバーによって、最も重要な情報のみがログ ファイルに書き出されます。 デフォルトの設定です。
    1 詳細 サーバーは次の情報を追加でログ ファイルに書き出します。
    フロントエンド サーバー
    接続とイベントのディスパッチ情報
    アプリケーション サーバー
    結果の書き出しと取り出しの作業
    実行サーバー
    トランザクション実行の作業
    2 冗長 サーバーは次の情報を追加でログ ファイルに書き出します。
    フロントエンド サーバー
    ユーザー管理情報 (Cookie 管理など)
    アプリケーション サーバー
    結果の書き出しと取り出しの詳細情報
    実行サーバー
    トランザクション実行と帯域幅の詳細情報
    3 | デバッグ | もっとも詳細なログ レベルです。深刻な問題をデバッグするとき以外は使うべきではありません。
  5. XML ファイルを保存して閉じたら、サーバーを再起動します。
親トピック: ログ ファイルの管理


[フロントエンド サーバー ログ] ページ

管理 > ログ ファイル > フロントエンド サーバー ログ

このページは、Silk Central フロントエンド サーバー サービスのログ情報の表示に使用します。

ログ ファイルごとに、次の列がページに表示されます。

列 | 説明
アクション | (削除) および [image] (ダウンロード) のボタンをクリックして、ログ ファイルを削除またはダウンロードします。
名前 | ログ ファイルの名前。
サイズ | ログ ファイルの物理的サイズ。
日時 | ログ ファイルが最後に物理的に保存された日時。

管理 > ログ ファイル > フロントエンド サーバー ログ > フロントエンド サーバー ログのファイル名

ログ ファイルの名前をクリックすると、ログの詳細リストが表示されます。 リストには、次の項目が含まれます。

項目 | 説明
フィルタ領域 | フィルタ オプションを使用して、深刻度、ログ レベル、およびモジュールごとにログ リスト情報をフィルタ処理します。更新 をクリックして、リストをフィルタ設定に従ってリフレッシュします。
表領域 次のログ情報が表示されます。
深刻度
イベントの深刻度：
  • 情報
  • 警告
  • エラー
ログ レベル
イベントのログ レベル：
  • OV = 概要
  • DT = 詳細
  • VB = 冗長
  • DB = デバッグ

フロントエンド サーバー ログ ページに戻るには、戻る をクリックします。 ログ ファイルを CSV ファイルとしてローカル コンピュータにダウンロードするには、CSV としてダウンロード をクリックします。

親トピック: サーバー ログ ファイル


[アプリケーション サーバー ログ] ページ

管理 > ログ ファイル > アプリケーション サーバー ログ

Silk Central アプリケーション サーバー サービスのログ情報の表示に使用します。

ログ ファイルごとに、次の列がページに表示されます。

列 | 説明
アクション | (削除) および [image] (ダウンロード) のボタンをクリックして、ログ ファイルを削除またはダウンロードします。
名前 | ログ ファイルの名前。
サイズ | ログ ファイルの物理的サイズ。
日時 | ログ ファイルが最後に物理的に保存された日時。

管理 > ログ ファイル > アプリケーション サーバー ログ > アプリケーション サーバー ログのファイル名

ログ ファイルの名前をクリックすると、ログの詳細リストが表示されます。リストには、次の項目が含まれます。

項目 | 説明
フィルタ領域 | フィルタ オプションを使用して、深刻度、ログ レベル、およびモジュールごとにログ リスト情報をフィルタ処理します。更新 をクリックして、リストをフィルタ設定に従ってリフレッシュします。
表領域 次のログ情報が表示されます。
深刻度
イベントの深刻度：
  • 情報
  • 警告
  • エラー
ログ レベル
イベントのログ レベル：
  • OV = 概要
  • DT = 詳細
  • VB = 冗長
  • DB = デバッグ

アプリケーション サーバー ログ ページに戻るには、戻る をクリックします。ログ ファイルを CSV ファイルとしてローカル コンピュータにダウンロードするには、CSV としてダウンロード をクリックします。

親トピック: サーバー ログ ファイル


[実行サーバー ログ] ページ

管理 > ログ ファイル > 実行サーバー ログ

このページは、Silk Central 実行サーバー サービスのログ情報の表示に使用します。

ロケーションごとに、次の列がページに表示されます。

列 | 説明
ロケーション | すべての利用可能なロケーションを表示します。
実行サーバー | ロケーションごとの実行サーバー数を表示します。
ステータス | ロケーションにおける実行サーバーのステータスの概要を表示します。

管理 > ログ ファイル > 実行サーバー ログ > ロケーション名

ロケーションの名前をクリックすると、選択されたロケーションの実行サーバー リストが表示されます。リストには、実行サーバーごとに次の列が表示されます。

列 | 説明
実行サーバー名 | 実行サーバーの名前。
ホスト | 実行サーバーをホストするコンピュータの名前。
タイプ | 実行サーバーの構成対象である Silk Central アプリケーション。Silk Central の場合は、タイプは常に Silk Central です。
割り当て済みタスク数 | この実行サーバーに現在スケジュールされているタスクの数。
ステータス | 実行サーバーのステータス。アクティブ または 非アクティブ。

ロケーションのリストに戻るには、戻る をクリックします。

管理 > ログ ファイル > 実行サーバー ログ > ロケーション名 > 実行サーバー名

実行サーバーの名前をクリックすると、選択された実行サーバーのログ ファイルのリストが表示されます。ログ ファイルごとに、次の列がページに表示されます。
列 | 説明
アクション | (削除) および [image] (ダウンロード) のボタンをクリックして、ログ ファイルを削除またはダウンロードします。
名前 | ログ ファイルの名前。
サイズ | ログ ファイルの物理的サイズ。
日時 | ログ ファイルが最後に物理的に保存された日時。

実行サーバーのリストに戻るには、戻る をクリックします。

管理 > ログ ファイル > 実行サーバー ログ > ロケーション名 > 実行サーバー名 > 実行サーバーのログ ファイル名

ログ ファイルの名前をクリックすると、ログの詳細リストが表示されます。リストには、次の項目が含まれます。

項目 | 説明
フィルタ領域 | フィルタ オプションを使用して、深刻度、ログ レベル、およびモジュールごとにログ リスト情報をフィルタ処理します。更新 をクリックして、リストをフィルタ設定に従ってリフレッシュします。
表領域 次のログ情報が表示されます。
深刻度
イベントの深刻度：
  • 情報
  • 警告
  • エラー
ログ レベル
イベントのログ レベル：
  • OV = 概要
  • DT = 詳細
  • VB = 冗長
  • DB = デバッグ

実行サーバー ログ ページに戻るには、戻る をクリックします。ログ ファイルを CSV ファイルとしてローカル コンピュータにダウンロードするには、CSV としてダウンロード をクリックします。

親トピック: サーバー ログ ファイル


タスク管理ツールを統合する

アジャイル プロジェクト テンプレートを使用して、さまざまな外部タスク管理ツールがテストを Silk Central に統合することができます。

アジャイル プロジェクト テンプレートは、あらかじめ選択されている属性リリースとスプリントを持った、Silk Central のプロジェクトです。 アジャイル プロジェクト テンプレートに基づいてプロジェクトを作成すると、新しいプロジェクトに対して、空のサブフォルダやテスト コンテナが作成されます。 そして、外部タスク管理ツールは、そのテンプレート内にテストを挿入していくことができます。 アジャイル プロジェクト テンプレートに基づいてプロジェクトを作成する方法については、「プロジェクトを追加する」を参照してください。

Silk Central で現在サポートされていて特別な設定をせずにそのまま使用できるタスク管理ツールは、次のとおりです。

タスク管理 ツール
説明
VersionOne

VersionOne は、プロジェクト計画および管理ツールで、特にアジャイル ソフトウェア開発のために設計されています。 リリース管理、イテレーションの計画とトラッキング、ユーザー ストーリーやバックログ アイテムの管理、タスク管理など、アジャイルおよびインタラクティブ管理のための実践機能を持っています。

  • Silk Central と VersionOne を統合する
    VersionOne からのテストを統合して、Silk Central でそれらを管理します。
親トピック: 管理


Silk Central と VersionOne を統合する

VersionOne からのテストを Silk Central に統合するには：
  1. 新しい Silk Central プロジェクトを追加し、アジャイル プロジェクト テンプレートをプロジェクトに適用します。 アジャイル テンプレートに基づいたプロジェクトを Silk Central に追加する方法については、「プロジェクトを追加する」を参照してください。
  2. ファイル エクスプローラを開きます。
  3. VersionOne の設定 XML ファイルである VersionOneConfig.xml まで移動します。 ファイルのデフォルト パスは C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<インスタンス番号>_<インスタンス名>\wwwrootAS\VersionOneIntegration です。
  4. VersionOne の設定 XML ファイルをエディタで開きます。
  5. VersionOne の設定 XML ファイルを、適切な内容で設定します。 VersionOne の設定 XML ファイルにおける設定の詳細については、VersionOneConfig.xml 内のコメントを参照してください。
  6. 設定ファイルを保存の上、閉じます。
    注: 設定ファイルを編集した後、このファイルは自動的に更新されるので、アプリケーション サーバーを再起動する必要はありません。
  7. Silk Central で、テスト 領域まで移動します。 空のテスト コンテナが、未完成の状態で表示されます。これは、製品を選択する必要があるためです。
  8. コンテナをクリックし、プロパティ タブを選択し、製品リンクをクリックして目的の製品を参照します。

これで VersionOne は Silk Central に統合されます。VersionOne 内の新しいテスト タスクが、定義されている適切なユーザーのために、定義されている Silk Central プロジェクト内のデフォルトのインテグレーション フォルダに手動テストとして挿入されます。テストのステータスが Silk Central と VersionOne の間でやり取りされるようになります。

VersionOne インテグレーションへの変更に関する情報については、VersionOneIntegration.log ログ ファイルを参照してください。ログ ファイルのデフォルト パスは、C:\ProgramData\SilkCentral\instance_<インスタンス番号>_<インスタンス名>\log\ です。

注: VersionOne を日本語の Silk Central と統合するには、レジストリ内のアプリケーション サーバー サービスの start オプションを -Dfile.encoding=utf-8 に変更します。
親トピック: タスク管理ツールを統合する


値リストをメンテナンスする

値リストを使用して、Issue Manager 向けに構成できる [問題のカスタム タブ] のカスタム プロパティに値を設定します(問題 > 設定)。問題のカスタム プロパティおよびタブの詳細については、この『ヘルプ』の「Issue Manager」トピックを参照してください。

  • 値リストを追加する
    新しい値リストを追加して、問題のカスタム タブのカスタム プロパティに値を設定します。
  • 値リストを編集する
    既存の値リストを編集します。
  • 個別の値を編集する
    値リスト内の個別の値を編集します。
  • 値リストをアクティブまたは非アクティブにする
    Silk Central で既存の値リストをアクティブまたは非アクティブにします。
  • 個別の値をアクティブまたは非アクティブにする
    値リスト内の個別の値をアクティブまたは非アクティブにします。
  • 値リスト内で値をソートする
    値をリスト内で上下に移動したり、値リストをアルファベット順にソートしたりします。
  • 値リストを削除する
    既存の値リストを削除します。
  • 個別の値を削除する
    値リスト内の個別の値を削除します。
  • [値リスト] 設定ページ
    このページは、値リストの設定に使用します。
親トピック: 管理


値リストを追加する

新しい値リストを追加するには：

  1. メニューで 管理 > 値リスト をクリックします。
  2. リストの新規作成 をクリックします。 値リストの新規作成 ダイアログ ボックスが表示されます。
  3. 名前 フィールドに新しい値リストの名前を入力し、説明 フィールドに値リストの説明を入力します。
  4. グループ化基準 リスト ボックスから、このリストをグループ化するパラメータを選択します。

    この選択は限定的であり、新しいリストを保存した後では編集できません。値のグループ化とは、リスト内の各値に、グループ化基準 リスト ボックスで選択したリストの値を割り当てる必要があることを意味します。値をグループ化しないと、カスタム値を手作業で定義できます。

  5. 値の新規作成 をクリックして、リストに値を追加します。 値の新規作成 ダイアログ ボックスが表示されます。
  6. 名前 フィールドと 説明 フィールドに、新しい値の名前と説明をそれぞれ入力します。
  7. グループ化基準 で選択した項目に対応するリスト ボックスから値を選択します（該当する場合）。
  8. 挿入位置 (後に挿入) リスト ボックスから既存値のリスト内での新しい値の位置を選択するか、<最後の値> を選択してリストの最後に新しい値を追加します。
  9. OK をクリックして値を保存します。 値リストの新規作成 ダイアログ ボックスに、新たに追加された値が表示されます。
  10. 値リストを完成させるために必要なすべての値を追加します。
  11. OK をクリックして値リストを保存します。
親トピック: 値リストをメンテナンスする


値リストを編集する

既存の値リストを編集するには：

  1. メニューで 管理 > 値リスト をクリックします。
  2. 編集する値リストの名前をクリックします。 値リストの編集 ダイアログ ボックスが表示されます。
  3. 選択した値リストの 名前、説明、および グループ化基準 の設定を変更し、OK をクリックします。
    注: リストに設定されている個々の値を個別に編集することもできます。 個別の値を編集する方法の詳細については、「個別の値を編集する」を参照してください。
親トピック: 値リストをメンテナンスする


個別の値を編集する

値リスト内の個別の値を編集するには：

  1. メニューで 管理 > 値リスト をクリックします。
  2. 編集する値リストの名前をクリックします。 値リストの編集 ダイアログ ボックスが表示されます。
  3. 編集する値の名前をクリックします。 値の編集 ダイアログ ボックスが表示されます。
  4. 必要に応じて、値の 名前 と 説明 を編集します。
  5. OK をクリックして、変更を保存します。
親トピック: 値リストをメンテナンスする


値リストをアクティブまたは非アクティブにする

注: 値リスト 問題種別 は Issue Manager に必要なので、このリストを非アクティブにすることはできません。

既存の値リストをアクティブまたは非アクティブにするには：

  1. メニューで 管理 > 値リスト をクリックします。
  2. アクティブまたは非アクティブにする値リストに関連付けられた ステータス アイコンをクリックします。 確認ダイアログ ボックスに、アクティブ化/非アクティブ化を確認するメッセージが表示されます。
  3. メッセージを確認して、値リストのステータスを [アクティブ] と [非アクティブ] で切り替えます。
    注: リストに設定されている個々の値を個別にアクティブまたは非アクティブにすることもできます。 個別の値をアクティブまたは非アクティブにする方法の詳細については、「個別の値をアクティブまたは非アクティブにする」を参照してください。
親トピック: 値リストをメンテナンスする


個別の値をアクティブまたは非アクティブにする

値リスト内の個別の値をアクティブまたは非アクティブにするには：

  1. メニューで 管理 > 値リスト をクリックします。
  2. アクティブまたは非アクティブにする値を含む値リストの名前をクリックします。 値リストの編集 ダイアログ ボックスが表示されます。
  3. アクティブまたは非アクティブにする値に関連付けられた ステータス アイコンをクリックします。 確認ダイアログ ボックスが表示されます。
  4. OK をクリックして更新された値リストを保存します。
親トピック: 値リストをメンテナンスする


値リスト内で値をソートする

値を値リスト内で上下に移動したり、値リストを値名のアルファベット順にソートしたりするには：

  1. メニューで 管理 > 値リスト をクリックします。
  2. ソートする値を含む値リストの名前をクリックします。 値リストの編集 ダイアログ ボックスが表示されます。
  3. 移動する項目の アクション 列で、 上へ移動 または 下へ移動 をクリックします。
  4. 値リストを値名のアルファベット順にソートするには、値でソート をクリックします。 値でソート ダイアログ ボックスが表示されます。
  5. ソート順（昇順 または 降順）を選択し、OK をクリックします。
  6. 値リストの編集 ダイアログ ボックスの OK をクリックして、更新した値リストを保存します。
親トピック: 値リストをメンテナンスする


値リストを削除する

既存の値リストを削除するには：

  1. メニューで 管理 > 値リスト をクリックします。
  2. 削除対象の値リストを非アクティブにします。 詳細については、「値リストアクティブおよび非アクティブにする」を参照してください。
  3. 削除する値リストの [アクション] 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックして削除を実行します。または、いいえ をクリックして削除を中止します。
    注: リストに設定されている個々の値を個別に削除することもできます。個別の値を削除する方法の詳細については、「個別の値を削除する」を参照してください。
親トピック: 値リストをメンテナンスする


個別の値を削除する

値リスト内の個別の値を削除するには：

  1. メニューで 管理 > 値リスト をクリックします。
  2. 削除する値を含む値リストの名前をクリックします。 値リストの編集 ダイアログ ボックスが表示されます。
  3. 削除対象の値を非アクティブにします。 詳細については、「個別の値をアクティブおよび非アクティブにする」を参照してください。
  4. 削除する値の アクション 列で、 削除 をクリックします。
  5. 値リストの編集 ダイアログ ボックスの OK をクリックして、更新した値リストを保存します。
親トピック: 値リストをメンテナンスする


[値リスト] 設定ページ

管理 > 値のリスト

このページは、値リストの設定に使用します。リスト内の値リストごとに、次の列がページに表示されます。

列 | 説明
名前 | GUI およびレポートに表示される値リストの名前。値リストの名前をクリックして名前、説明、および値リストの値を変更します。
グループ化基準 | 値リストが [製品] または [問題種別] でグループ化されているか、あるいは [非グループ化] であるかを示します。
ステータス | 値リストのステータス（[アクティブ] または [非アクティブ]）。ステータスをクリックして、[アクティブ] と [非アクティブ] を切り替えます。デフォルトの値リストである問題種別は、Issue Manager で使用される主要なコンポーネントであるため、非アクティブにできません。
作成日時 | 値リストが作成された日時。
作成者 | この値リストを作成したユーザー。
変更日時 | 値リストが最後に変更された日時。
変更者 | この値リストを最後に変更したユーザー。
アクション
値リストに対して次のアクションを実行できます。
値リストを完全に削除します。値リストは削除する前に無効にする必要があります。値リストが既に問題に関連付けられている場合は削除できません。

新しい値リストを作成するには、リストの新規作成 をクリックします。

親トピック: 値リストをメンテナンスする


グローバル スケジュールを設定する

実行計画のスケジュールを設定するために Silk Central で再利用できるグローバル スケジュールを定義できます。グローバル スケジュールを利用すると、実行計画のスケジューリング プロセスをスピードアップできます。個別のスケジュールを定義するのは、特殊なスケジューリングを必要とする実行計画のみに限定できるからです。スケジュールの適用について詳細な情報は、「スケジュール」を参照してください。

除外期間

テストを実行しない曜日や時間帯を定義できます。たとえば、週末にはテストを実行しないように定義できます。

限定実行

設定されたスケジュールに関係なくテストを実行する必要がある時間を定義できます。

  • グローバル スケジュールを追加する
    Silk Central で新しいグローバル スケジュールを追加して、実行計画のスケジュールを設定します。
  • グローバル スケジュールを編集する
    既存のグローバル スケジュールを編集します。
  • グローバル スケジュールをアクティブまたは非アクティブにする
    Silk Central で既存のグローバル スケジュールをアクティブまたは非アクティブにします。
  • グローバル スケジュールを削除する
    既存のグローバル スケジュールを削除します。
  • スケジュールの除外期間を作成する
    スケジュールの除外期間を作成して、スケジュール設定されたテスト を実行しない期間を定義します。
  • 限定実行のスケジュールを作成する
    限定実行のスケジュールを作成して、テスト を実行する必要がある時点を定義します。
  • [スケジュール] 設定ページ
    このページは、Silk Central のグローバル スケジュールの設定に使用します。
親トピック: 管理
関連概念
スケジュール


グローバル スケジュールを追加する

新しいグローバル スケジュールを追加するには：

  1. メニューで 管理 > スケジュール をクリックします。 スケジュール ページに、既存のすべてのグローバル スケジュールが一覧表示されます。
  2. スケジュールの新規作成 をクリックします。 スケジュールの設定 ページが表示されます。
  3. 名前 フィールドに、新しいスケジュールの名前を入力します。 実際に実行される時間をユーザーがわかるように、「毎日午後 6 時 EST」のように名前にタイムゾーンを含めると良いでしょう。
  4. 説明 フィールドに、スケジュールの説明を入力します。
  5. 開始日時 の横にある 編集 をクリックして、スケジュールの開始日時を定義します。すべての日時値は、GMT でデータベースに保存されます。値の表現は、ユーザー設定で指定される タイム ゾーン に基づいて設定されます。たとえば、ニューヨークにいる管理者が毎日午後 6 時に実行するグローバル スケジュールを作成した場合、パリにいるユーザーがこのスケジュールを実行計画に適用すると、真夜中に実行されることになります。
  6. 間隔 で、実行の繰り返し間隔を定義します。 設定できる時間範囲は 1 分から 36 日までです。
  7. サマータイムを補正する チェック ボックスをオンにすると、スケジュールによる実行が自動的にサマータイムに合わせて調整されます。
  8. 実行の横にある 編集 をクリックして、実行を停止する日時を定義します。期限なし をクリックして期限なしで実行するか、または 期限あり をクリックして定義済みの期間まで実行します。
  9. テスト を実行しない曜日や時間帯を定義するには、除外期間の追加 をクリックします。 詳細については、「スケジュールの除外期間を作成する」を参照してください。
  10. テスト を実行する必要がある時点を定義するには、限定実行の追加 をクリックします。 詳細については、「限定実行のスケジュールを作成する」を参照してください。
  11. スケジュールの定義が完了したら、保存 をクリックします。
親トピック: グローバル スケジュールを設定する
関連タスク
限定実行のスケジュールを作成する
スケジュールの除外期間を作成する
グローバル スケジュールを指定する


グローバル スケジュールを編集する

グローバル スケジュールを変更するには：

  1. メニューで 管理 > スケジュール をクリックします。 スケジュール ページに、既存のすべてのグローバル スケジュールが一覧表示されます。
  2. 編集対象のスケジュールの名前をクリックします。 スケジュールの設定 ページが表示されます。
  3. 名前 フィールドでスケジュールの名前を変更します。実際に実行される時間をユーザーがわかるように、「毎日午後 6 時 EST」のように名前にタイムゾーンを含めると良いでしょう。
  4. 説明 フィールドでスケジュールの説明を変更します。
  5. 開始時間 の横にある 編集 をクリックして、スケジュールの新しい開始日時を定義します。すべての日時値は、GMT でデータベースに保存されます。値の表現は、ユーザー設定で指定される タイム ゾーン に基づいて設定されます。たとえば、ニューヨークにいる管理者が毎日午後 6 時に実行するグローバル スケジュールを作成した場合、パリにいるユーザーがこのスケジュールを実行計画に適用すると、真夜中に実行されることになります。
  6. 間隔 で、実行の繰り返し間隔を変更します。 設定できる時間範囲は 1 分から 36 日までです。
  7. サマータイムを補正する チェック ボックスをオンにすると、スケジュールによる実行が自動的にサマータイムに合わせて調整されます。
  8. 実行の横にある 編集 をクリックして、実行を停止する日時を定義します。期限なし をクリックして期限なしで実行するか、または 期限あり をクリックして定義済みの期間まで実行します。
  9. テスト を実行しない曜日や時間帯を定義するには、除外期間の追加 をクリックします。 詳細については、「スケジュールの除外期間を作成する」を参照してください。
  10. テスト を実行する必要がある時点を定義するには、限定実行の追加 をクリックします。 詳細については、「限定実行のスケジュールを作成する」を参照してください。
  11. スケジュールの変更が完了したら、保存 をクリックします。
親トピック: グローバル スケジュールを設定する
関連タスク
限定実行のスケジュールを作成する
スケジュールの除外期間を作成する
グローバル スケジュールを指定する


グローバル スケジュールをアクティブまたは非アクティブにする

既存の製品をアクティブまたは非アクティブにするには：

  1. メニューで 管理 > スケジュール をクリックします。 スケジュール ページに、既存のすべてのグローバル スケジュールが一覧表示されます。
  2. アクティブまたは非アクティブにするスケジュールに関連付けられた ステータス アイコンをクリックします。 確認ダイアログ ボックスに、アクティブ化/非アクティブ化を確認するメッセージが表示されます。
  3. メッセージを確認して、スケジュールのステータスを [アクティブ] と [非アクティブ] で切り替えます。
親トピック: グローバル スケジュールを設定する


グローバル スケジュールを削除する

既存のグローバル スケジュールを削除するには：

  1. メニューで 管理 > スケジュール をクリックします。 スケジュール ページに、既存のすべてのグローバル スケジュールが一覧表示されます。
  2. 削除するスケジュールの アクション 列で、 削除 をクリックします。 確認ダイアログ ボックスが表示されます。
  3. はい をクリックすると現在のスケジュールが削除され、いいえ をクリックすると削除が中止されます。
    注: グローバル スケジュールがテスト に一度でも使用されていると、スケジュールを削除できません。 最初にすべてのテスト で別のスケジュールを使うように設定し直す必要があります。
親トピック: グローバル スケジュールを設定する


スケジュールの除外期間を作成する

スケジュールの除外期間を作成するには：

  1. メニューで 管理 > スケジュール をクリックします。 スケジュール ページに、既存のすべてのグローバル スケジュールが一覧表示されます。
  2. 編集対象のスケジュールの名前をクリックします。
  3. スケジュールの設定 ページで、除外期間の追加 をクリックします。
  4. スケジュールの除外期間の設定 ページで、テスト を実行しない曜日を選択します。
  5. これらの曜日で、テスト定義を実行しない時間帯を定義します。
  6. OK をクリックして除外期間の設定定義を完了するか、キャンセル をクリックして中止します。 これで、除外期間の設定が スケジュールの設定 ページに一覧表示されます。
  7. 保存 をクリックして除外期間を現在のスケジュールに追加するか、除外期間の追加を続行します。
    ヒント: 対象の除外期間の アクション 列で 編集 または 削除 をクリックして、除外期間を編集または削除できます。
親トピック: グローバル スケジュールを設定する


限定実行のスケジュールを作成する

限定実行のスケジュールを作成するには：

  1. メニューで 管理 > スケジュール をクリックします。 スケジュール ページに、既存のすべてのグローバル スケジュールが一覧表示されます。
  2. 編集対象のスケジュールの名前をクリックします。
  3. スケジュールの設定 ページで、限定実行の追加 をクリックします。
  4. 限定実行の設定 ページで 編集 をクリックして、限定実行の開始時刻を定義します。
  5. OK をクリックして限定実行の定義を完了するか、キャンセル をクリックして中止します。 これで、限定実行の設定が スケジュールの設定 ページに一覧表示されます。
  6. 保存 をクリックして限定実行を現在のスケジュールに追加するか、または限定実行の追加を続行します。
    ヒント: 対象の限定実行の アクション 列で 編集 または [image] 削除 をクリックして、限定実行を編集または削除できます。
親トピック: グローバル スケジュールを設定する


[スケジュール] 設定ページ

管理 > スケジュール

このページは、Silk Central のグローバル スケジュールの設定に使用します。スケジュールごとに、次の列がページに表示されます。

列 | 説明
アクション この列にはアクションのアイコンが含まれ、ユーザーはスケジュールについて次のアクションを実行できます。
スケジュールを完全に削除します。スケジュールが実行計画に既に関連付けられている場合は削除できません。
名前 | GUI およびレポートに表示されるスケジュールの名前。スケジュールの名前をクリックしてスケジュールの名前、説明、およびステータスを変更します。
説明 | スケジュールのテキスト説明。
ステータス | スケジュールのステータス（[アクティブ] または [非アクティブ]）。ステータスをクリックして、ステータスを [アクティブ] と [非アクティブ] で切り替えます。
作成日時 | スケジュールが作成された日時。
作成者 | このスケジュールを作成したユーザー。

スケジュールの新規作成 をクリックして、新しいスケジュールを作成します。

親トピック: グローバル スケジュールを設定する


タイム ゾーン

Silk Central は、実行サーバーのネットワークに対してテスト を実行するように設計されています。インターネットによって、このようなネットワークを、複数のタイム ゾーンをまたいで世界中に広げることが可能となったため、Silk Central でのタイム ゾーンの処理方法を理解することは重要です。

すべての日時値は、GMT でデータベースに保存されます。値の表現は、ユーザー設定で指定される タイム ゾーン に基づいて設定されます。グローバルで利用可能なスケジュールを作成する場合は、特に考慮する必要があります。たとえば、ニューヨークにいる管理者が毎日午後 6 時に実行するグローバル スケジュールを作成した場合、パリにいるユーザーがこのスケジュールを実行計画に適用すると、真夜中に実行されることになります。実際に実行される時間をユーザーがわかるように、「毎日午後 6 時 EST」のように名前にタイムゾーンを含めると良いでしょう。

タイムゾーンの設定についての詳細は、「ユーザー アカウントを追加する」を参照してください。

以下の要件が適用されます。

  • アプリケーション サーバーとフロントエンド サーバーは、同じタイム ゾーンに存在する必要があります。アプリケーション サーバーは 1 つ以上のフロントエンド サーバーと緊密に通信するので、これらのサーバーを WAN 内でローカルに分離しても意味がありません。また、フロントエンド サーバーもアプリケーション サーバーも、データベースに直接アクセスします。
  • 実行サーバーは、アプリケーション サーバーとも他の実行サーバーとも別の、異なるタイム ゾーンに存在してもかまいません。
親トピック: 管理
関連タスク
ユーザー アカウントを追加する


プロジェクトを管理する

Silk Central のプロジェクトは、通常、会社のソフトウェア プロジェクトを反映したもので、開発チームの作業それぞれに対して、共通のリリース日、ソース管理システム、要件などがあります。

プロジェクト 領域では、Silk Central のすべてのプロジェクトの高レベルなビューを提供します。 また、アクティブに設定された最近使ったプロジェクトのリストが表示され、プロジェクトを簡単に切り替えることができます。ユーザーにスーパーユーザー、システム管理者、または、プロジェクト マネージャの権限がある場合、Silk Central プロジェクトのプロジェクト全体の設定を指定できます。グローバル プロジェクト設定を定義すると、そのプロジェクトへのアクセス権を持つすべてのユーザーがその設定を利用できます。

  • プロジェクトで作業する
    Silk Central でのプロジェクトの概念的な背景について説明します。
  • ビルド情報
    このセクションでは、ビルド情報ファイルを使用する方法について説明します。
  • プロジェクトとベースラインを比較する
    プロジェクトとプロジェクトのベースラインを比較するには、状況依存のレポートを使用します。
  • プロジェクトを選択する
    プロジェクト ユニットでプロジェクトを選択して有効化します。
  • プロジェクト リスト
    お使いの Silk Central インストールに関連付けられているすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  • 最近アクセスしたプロジェクトに切り替える
    最近アクセスした 5 つのプロジェクトのうちの 1 つに切り替える方法について説明します。
  • プロジェクト設定
    このセクションでは、プロジェクト設定の構成方法について説明します。
  • プロジェクト テンプレート
    Silk Central におけるプロジェクト テンプレートの概念的背景について説明します。
親トピック: 管理
関連概念
Silk Central のアーキテクチャ


プロジェクトで作業する

このトピックでは、Silk Central でのプロジェクトの概念的な背景について説明します。

Silk Central は要件、テスト、およびその実行と結果を、プロジェクトに関連付けて管理します。 よって、まずはじめにプロジェクトを作成する必要があります。プロジェクトは、関連のあるタスクと結果のセットに対するコンテナとして機能します。プロジェクト マネージャやアナリストなどのリソースは、ユーザー グループに割り当てられることで、プロジェクトに割り当てられます。ユーザー グループには、特定のプロジェクトに対するアクセス権が与えられています。

  • プロジェクトを追加する
    プロジェクトを作成して、Silk Central での作業を始めます。
  • プロジェクト ベースライン
    Silk Central におけるプロジェクト ベースラインの概念的背景について説明します。
  • プロジェクトとプロジェクト ベースラインを編集する
    既存のプロジェクトまたはプロジェクト ベースラインを編集します。
  • プロジェクトとプロジェクト ベースラインをアクティブまたは非アクティブにする
    既存のプロジェクトまたはプロジェクト ベースラインをアクティブまたは非アクティブにします。
  • プロジェクトまたはプロジェクト ベースラインをコピーする
    既存のプロジェクトまたはプロジェクト ベースラインを新しいプロジェクトにコピーします。
  • プロジェクトとプロジェクト ベースラインを削除する
    既存のプロジェクトまたはプロジェクト ベースラインを削除します。
  • プロジェクトをエクスポートする
    プロジェクトをエクスポートして、Silk Central の外部にプロジェクト データをアーカイブ化する方法について説明します。
  • プロジェクトをインポートする
    事前に Silk Central からエクスポートしたプロジェクトを再インポートする方法について説明します。
  • [プロジェクトのコピー] ダイアログ ボックス
    このダイアログ ボックスは、既存のプロジェクトを新しいプロジェクトにコピーするために使用します。
  • [プロジェクト設定] ページ
    プロジェクトの設定に使用します。
  • Issue Manager プロジェクトとしてプロジェクトを初期化する
    Issue Manager プロジェクトとしてプロジェクトを初期化する方法について説明します。
親トピック: プロジェクトを管理する


プロジェクトを追加する

プロジェクトを作成するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. プロジェクトの新規作成 をクリックします。 プロジェクト設定 ページが表示されます。
  3. プロジェクト名 と 説明 に入力します。
  4. プロジェクトの所有者 を選択します。
  5. 省略可能：プロジェクトに対する タグ を入力します。多くのプロジェクトがある場合、プロジェクト タグを使用すると、プロジェクト リスト ページの タグ 列を使用してフィルタすることができます。
  6. 省略可能：アジャイル プロジェクト テンプレートに基づいてプロジェクトを作成するには、アジャイル プロジェクト テンプレート を プロジェクト テンプレート リスト ボックスから選択します。
  7. プロジェクトを Issue Manager プロジェクトとして初期化するには、新しいプロジェクトの初期化 または 既存のプロジェクトの再利用 をクリックします。詳細については、「プロジェクトを Issue Manager プロジェクトとして初期化する」を参照してください。
  8. 共有テスト セクションで、プロジェクトがリポジトリ プロジェクトであるかどうかを定義します。以下のオプションのいずれかを選択します。
    • テストを共有しない：このプロジェクトは他のプロジェクトのテストを参照しません。また、このプロジェクトのテストが他のプロジェクトから参照されることもありません。
    • テストを共有する：このプロジェクトをリポジトリ プロジェクトとして、テストを他のプロジェクトから参照できるように設定します。
    • 共有テストの参照元：このプロジェクトがテストを参照するリポジトリ プロジェクトを選択します。
  9. グループ セクションには、利用可能なグループと割り当て済みグループのリストが表示されます。グループの割り当ては必須です。Ctrl + クリック または Shift + クリック を使用すると、複数のグループを選択できます。LDAP グループのインポート をクリックして、LDAP サーバーからグループをインポートすることもできます。詳細については、「LDAP サーバーからグループをインポートする」を参照してください。ユーザー グループが存在しない場合は、後でユーザー グループを作成してから割り当てることができます。また、グループ/プロジェクトの割り当ては、グループの設定 ページで設定することもできます。権限は、ユーザー ロールによって異なります。ユーザー権限については、「ユーザー ロールとアクセス許可」を参照してください。
  10. ロケーション セクションには、利用可能なロケーションと割り当て済みロケーションのリストが表示されます。ロケーションの割り当ては必須です。Ctrl + クリック または Shift + クリック を使用すると、複数のロケーションを選択できます。ロケーションが存在しない場合は、後でロケーションを作成してから割り当てることができます。また、ロケーション/プロジェクトの割り当ては、ロケーション設定 ページで設定することもできます。詳細については、「ロケーションを管理する」を参照してください。
  11. 保存 をクリックして設定を保存します。
    プロジェクト リスト ページに戻ります。新しいプロジェクトが一覧表示されます。
親トピック: プロジェクトで作業する
関連概念
グループをメンテナンスする
ロケーションを管理する
ユーザー ロールとアクセス許可
関連タスク
Issue Manager プロジェクトとしてプロジェクトを初期化する
プロジェクトとプロジェクト ベースラインを編集する
LDAP サーバーからグループをインポートする
LDAP サーバーを追加する
リポジトリ プロジェクトのテスト資産の再利用


プロジェクト ベースライン

このトピックでは、Silk Central でのプロジェクト ベースラインの概念的な背景について説明します。

プロジェクト ベースラインはある時間におけるプロジェクトのスナップショットで、任意のプロジェクトまたは別のプロジェクト ベースラインに対して作成できます。プロジェクト ベースラインには、プロジェクトの各実行計画の前回の実行も含まれます。プロジェクト ベースラインに含まれているスケジュール オプションは、前回の実行の実行ステータスが失われることを回避するために、最初は「なし」に設定されます。プロジェクト ベースラインは、たとえば、リリース直後のプロジェクトのスナップショットを保存するために使用します。Silk Central のベースラインの比較レポートには、プロジェクト内で、プロジェクト ベースラインと比較して現在異なっているテスト数が示されます。レポートの詳細については、Silk Central ヘルプ を参照してください。

テスト 領域の要素を含む新しいプロジェクト ベースラインのそれぞれについて、その要素の 履歴 ページに、プロジェクト ベースラインへのリンクおよびプロジェクト ベースライン内の対応する要素を含むエントリが示されます。要素をプロジェクト ベースラインの一部として作成した場合には、履歴 ページの最初のエントリに、元のプロジェクトへのリンクおよび元のプロジェクト内の対応する要素が含まれます。

元のプロジェクトのテストにライブラリの共有ステップ オブジェクトの呼び出しやキーワードが含まれている場合、プロジェクト ベースラインの作成時に、すべての呼び出しを解決または保持するかを定義できます。プロジェクト ベースラインのライブラリ上の表示設定は、元のプロジェクトと同じになります。共有ステップ オブジェクトおよびキーワードの詳細については、『Silk Central ヘルプ』の「ライブラリ」を参照してください。

注: プロジェクト ベースラインは、管理者、プロジェクト マネージャ、およびスーパーユーザーの各ロールで作成できます。
  • プロジェクトのベースラインを作成する
    既存のプロジェクトのベースラインを作成して、ある時点のプロジェクトのスナップショットを取ります。
親トピック: プロジェクトで作業する
関連概念
ライブラリ


プロジェクトのベースラインを作成する

注意:
プロジェクトのベースラインを作成すると、ベースラインを作成するプロジェクトのサイズによりますが、数分間データベースがロックされます。プロジェクトのベースラインの作成は、サービス停止時間中、Silk Central でユーザーの作業が最小限のときに実行することをお勧めします。
注: 元のプロジェクトにスケジュールが含まれている場合、前回の実行ステータスが失われるのを防ぐため、新しいベースラインのスケジューリング オプションが「なし」に設定されます。ベースラインを作成すると、ベースラインに含まれる各 テスト の 履歴 ページが、ベースラインのエントリで更新されます。

プロジェクトのベースラインを作成するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. ベースラインを作成するプロジェクトの アクション 列で、 プロジェクトのベースライン化 をクリックします。 プロジェクトのベースライン化 ダイアログ ボックスが表示されます。
  3. 新しいベースラインの名前と説明を入力します。
  4. 省略可能：プロジェクトにライブラリからの共有ステップまたはキーワードを使用するテストが含まれている場合は、ライブラリ資産の処理方法 セクションで共有ステップの処理方法を定義します。
    • ライブラリ資産をコピーする をクリックすると、元のライブラリにある共有ステップやキーワードへすべての参照が解除され、ベースラインにこれらのライブラリのコピーが新しく作成されれ、そのコピー内の資産を参照します。このオプションを選択して、履歴または監査を目的とするプロジェクト ベースラインを作成します。
    • ライブラリ資産への参照を保持する をクリックすると、元のライブラリにある共有ステップやキーワードへのすべての参照が保持されます。このオプションを選択して、たとえばプロジェクトの新バージョンのような、実行中のテストを目的とする作業コピーを作成します。
  5. 省略可能：プロジェクトに手動テストまたはキーワード駆動テストが含まれている場合は、テスト資産のバージョン化 セクションで、元のプロジェクトおよびベースラインに対して新しいバージョンを作成するかどうかを定義します。
    • 元のプロジェクトで手動およびキーワード駆動資産の新しいバージョンを作成する チェック ボックスをオンにすると、共有ステップを持つすべての手動テストおよびキーワード駆動テストに対する新しいバージョンが元のプロジェクトに作成されます。
    • 新しいベースラインで手動およびキーワード駆動資産の新しいバージョンを作成する チェック ボックスをオンにすると、共有ステップを持つすべての手動テストおよびキーワード駆動テストに対する新しいバージョンがベースラインに作成されます。ライブラリ資産をコピーする を選択した場合、コピーしたライブラリ内のすべての資産に対しても、新しいバージョンが作成されます。
    注: データ駆動型インスタンスに対してはバージョンは作成されません。
  6. OK をクリックします。 プロジェクトのベースライン化 ダイアログ ボックスが表示され、操作の完了に数分かかることが示されます。
  7. はい をクリックして続行します。 プロジェクトのベースライン化 - プロジェクト設定の適用 ダイアログ ボックスが表示されます。このダイアログ ボックスには、元のプロジェクトに対して構成されたすべてのソース管理プロファイルと共に、要件インテグレーション設定が表示されます。
  8. 対応する 編集 ボタンをクリックして、ソース管理プロファイル内の適切なベースライン、ブランチ、ラベル、または他の参照箇所にプロジェクト ベースラインをリンクするか、要件インテグレーション設定を変更します。
    注: ソース管理プロファイルの編集の詳細については、Silk Central ヘルプを参照してください。
  9. 完了 をクリックして、ベースラインの作成を完了します。
  10. プロジェクトのベースライン化 ダイアログ ボックスで はい をクリックして、新しいベースラインをアクティブにします。
親トピック: プロジェクト ベースライン


プロジェクトとプロジェクト ベースラインを編集する

既存のプロジェクトまたはプロジェクト ベースラインを編集するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. 編集するプロジェクトまたはプロジェクト ベースラインのプロジェクト名のアクション列で、 編集 をクリックします。
    注: プロジェクトまたはプロジェクト ベースラインは、非アクティブである必要があります。
  3. 必要に応じて、プロジェクト名 と 説明 を編集します。
  4. プロジェクトの所有者 を必要に応じて変更します。
  5. アクティブ チェック ボックスをオンにして、プロジェクトまたはプロジェクト ベースラインをアクティブにします。
  6. 省略可能：プロジェクトに対する タグ を入力します。多くのプロジェクトがある場合、プロジェクト タグを使用すると、プロジェクト リスト ページの タグ 列を使用してフィルタすることができます。
  7. 共有テスト セクションで、プロジェクトがリポジトリ プロジェクトであるかどうかを定義します。以下のオプションのいずれかを選択します。
    • テストを共有しない：このプロジェクトは他のプロジェクトのテストを参照しません。また、このプロジェクトのテストが他のプロジェクトから参照されることもありません。
    • テストを共有する：このプロジェクトをリポジトリ プロジェクトとして、テストを他のプロジェクトから参照できるように設定します。
    • 共有テストの参照元：このプロジェクトがテストを参照するリポジトリ プロジェクトを選択します。
  8. グループ セクションには、利用可能なグループと割り当て済みグループのリストが表示されます。グループの割り当ては必須です。Ctrl + クリック または Shift + クリック を使用すると、複数のグループを選択できます。LDAP グループのインポート をクリックして、LDAP サーバーからグループをインポートすることもできます。詳細については、「LDAP サーバーからグループをインポートする」を参照してください。ユーザー グループが存在しない場合は、後でユーザー グループを作成してから割り当てることができます。また、グループ/プロジェクトの割り当ては、グループの設定 ページで設定することもできます。権限は、ユーザー ロールによって異なります。ユーザー権限については、「ユーザー ロールとアクセス許可」を参照してください。
  9. ロケーション セクションには、利用可能なロケーションと割り当て済みロケーションのリストが表示されます。ロケーションの割り当ては必須です。Ctrl + クリック または Shift + クリック を使用すると、複数のロケーションを選択できます。ロケーションが存在しない場合は、後でロケーションを作成してから割り当てることができます。また、ロケーション/プロジェクトの割り当ては、ロケーション設定 ページで設定することもできます。詳細については、「ロケーションを管理する」を参照してください。
  10. 保存 をクリックして設定を保存します。
    プロジェクト リスト ページに戻ります。
親トピック: プロジェクトで作業する
関連概念
グループをメンテナンスする
ロケーションを管理する
ユーザー ロールとアクセス許可
関連タスク
プロジェクトを追加する
Issue Manager プロジェクトとしてプロジェクトを初期化する
LDAP サーバーからグループをインポートする
LDAP サーバーを追加する
リポジトリ プロジェクトのテスト資産の再利用
プロジェクトとプロジェクト ベースラインをアクティブまたは非アクティブにする


プロジェクトとプロジェクト ベースラインをアクティブまたは非アクティブにする

注: プロジェクト リスト ページから既存のプロジェクトまたはプロジェクト ベースラインをアクティブまたは非アクティブにすることもできます。 詳細については、「プロジェクトを編集する」を参照してください。

既存のプロジェクトまたはプロジェクト ベースラインをアクティブまたは非アクティブにするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. アクティブまたは非アクティブにするプロジェクトまたはプロジェクト ベースラインの ステータス 列で、アクティブ/非アクティブ をクリックします。 確認ダイアログ ボックスに、アクティブ化/非アクティブ化を確認するメッセージが表示されます。
  3. メッセージを確認して、プロジェクトのステータスを [アクティブ] と [非アクティブ] で切り替えます。
親トピック: プロジェクトで作業する
関連タスク
プロジェクトとプロジェクト ベースラインを編集する


プロジェクトまたはプロジェクト ベースラインをコピーする

既存のプロジェクトまたはプロジェクト ベースラインを新しいプロジェクトにコピーします。

元のプロジェクトまたはプロジェクト ベースラインが含まれている場合、コピー中はスケジューリング オプションが「なし」に設定されます。

注意:
プロジェクトまたはプロジェクト ベースラインをコピーすると、コピーするプロジェクトまたはプロジェクト ベースラインのサイズによりますが、数分間データベースがロックされます。プロジェクトまたはプロジェクト ベースラインのコピーは、サービス停止時間中、Silk Central でユーザーの作業が最小限のときに実行することをお勧めします。
ヒント: 特に大規模なプロジェクトがデータベースに書き込まれると、データベースのパフォーマンスが著しく低下する可能性があります。次回のメンテナンス時に Silk Central データベース スキーマのフル インデックスを再構築することを強く推奨します。

プロジェクトまたはプロジェクト ベースラインをコピーするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. コピーするプロジェクトまたはプロジェクト ベースラインの アクション 列で、 プロジェクトのコピー をクリックします。 プロジェクトのコピー ダイアログ ボックスが表示されます。
  3. 新しいプロジェクト名 フィールドに、新しいプロジェクトの名前を入力します。
  4. [コピーする追加情報] の各チェック ボックス (新しいプロジェクトと共にコピーする情報に対応) をオンにします。テスト履歴 チェック ボックスをオンにすると、バージョンもコピーされます。 チェック ボックスの詳細については、「[プロジェクトのコピー] ダイアログ ボックス」を参照してください。
  5. OK をクリックします。
  6. コピーしているプロジェクトに対して Issue Manager プロジェクトが初期化されていない場合、ステップ 10 に進んでください。Issue Manager プロジェクトが初期化されている場合、次のダイアログ ボックスが表示されます。
    • 既存の Issue Manager プロジェクトを再利用する場合は、はい をクリックしてステップ 10 に進みます。
    • 既存の Issue Manager プロジェクトを再利用はしないがコピーする場合は、いいえ をクリックしてステップ 7 に進みます。
  7. 問題のコピー チェック ボックスをオンにして、ソース プロジェクトの既存の問題すべてを新しいプロジェクトにコピーします。
  8. アーカイブされた問題のコピー チェック ボックスをオンにして、ソース プロジェクトのアーカイブ済みの問題すべてを新しいプロジェクトにコピーします。
  9. OK をクリックします。
  10. プロジェクトのコピー ダイアログ ボックスで はい をクリックして、コピー処理を開始することを確認します。このとき、処理に数分かかることが示されます。
    コピー処理が完了したら、コピーされた内容がダイアログ ボックスに表示され、プロジェクトをアクティブにするか確認メッセージが表示されます。これにより Silk Central の [プロジェクト] ビューでプロジェクトを利用できます。
親トピック: プロジェクトで作業する


プロジェクトとプロジェクト ベースラインを削除する

注意:
プロジェクトまたはプロジェクト ベースラインを削除すると、リポジトリからすべての関連する結果が恒久的に削除されます。プロジェクトまたはプロジェクト ベースラインに関連付けられたすべてのコンテンツも破棄されます。結果を保持する場合は、プロジェクトまたはプロジェクト ベースラインを削除するのではなく、非アクティブに設定することをお勧めします。プロジェクトとプロジェクト ベースラインを非アクティブにする方法については、「プロジェクトまたはプロジェクト ベースラインをアクティブまたは非アクティブにする」を参照してください。

プロジェクトまたはプロジェクト ベースラインを削除するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. 削除するプロジェクトまたはプロジェクト ベースラインの アクション 列で、 削除 をクリックします。
    注: プロジェクトまたはプロジェクト ベースラインは、非アクティブである必要があります。
    削除の確認を求めるメッセージが確認ダイアログ ボックスに表示されます。
  3. はい をクリックするとプロジェクトまたはプロジェクト ベースラインが削除され、いいえ をクリックすると削除が中止されます。 はい を選択した場合は、プロジェクトのリストに戻ります。削除したプロジェクトまたはプロジェクト ベースラインは表示されません。
親トピック: プロジェクトで作業する


プロジェクトをエクスポートする

プロジェクトをすべてのプロジェクト データを含む .zip ファイルとしてローカル コンピュータにエクスポートできます。これは、Silk Central の外部にデータをアーカイブ化する場合に特に便利です。

プロジェクトをエクスポートするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. アクション 列の [image] (プロジェクトのエクスポート) をクリックします。
  3. 確認ダイアログ ボックスで OK をクリックします。
  4. コンピュータの場所を指定して、プロジェクト データを保存します。 Silk Central はプロジェクト データを .zip ファイルに保存します。
重要: プロジェクトのエクスポートまたはインポートを開始する前に、以下の推奨事項をよくお読みください。
  • プロジェクト データを大量に保有する大型プロジェクトをエクスポートまたはインポートするとき、エクスポートおよびインポート プロセスには長時間 (最長では数時間) かかることがあります。
  • ファイル サイズは、多くの要因から影響を受け、プロジェクトごとに大きく異なります。たとえば、資産数、実行数、添付情報、コード カバレッジ統計情報、そして最も重要な結果ファイルなどが影響を与える要因となります。
  • エクスポートを行う前に、プロジェクトのサイズを最小限にすることをお勧めします。したがって、不要なデータ、特に使用しない結果ファイルを削除する必要があります。プロジェクトのサイズが 1.2 GB を超えている場合、Request entity is too large（要求のエンティティが大きすぎました） というエラーがインポート時に発生することがあります。プロジェクトのサイズをこれ以上小さくできない場合には、nginx.conf.template ファイル（C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf）の client_max_body_size プロパティの値を変更して、アップロード サイズの制限を増やすことができます。
  • 特に大規模なプロジェクトがデータベースに書き込まれると、データベースのパフォーマンスが著しく低下する可能性があります。次回のメンテナンス時に Silk Central データベース スキーマのフル インデックスを再構築することを強く推奨します。
  • Internet Explorer などのブラウザーでは、ファイルのアップロードに制限があります。インポートするプロジェクトがこのサイズを超えている場合、インポートは失敗します。この問題を避けるには、他のブラウザーを使用してください。
  • エクスポートまたはインポート プロセスによって、Silk Central およびデータベース サーバーには大きな負荷がかかることに注意します。エクスポートまたはインポート アクションは、ユーザーのいない時間帯 (たとえば、夜間や週末)、あるいは少なくとも Silk Central の利用率が低く、ユーザーがログインしていないときに実行する必要があります。
  • データのエクスポートおよびインポートは、データベースおよびその内容に密接に関係します。データベースに既にデータの不整合が含まれていると、プロジェクトのインポートに失敗する可能性があります。したがって、あらゆるバックアップ プロセスにおいて、エクスポートを行ったらただちに再インポートを行い、妥当性、データの整合性、回復可能性を確認することを強くお勧めします。
  • プロジェクト データを再インポートするには、エクスポートした .zip ファイルと同じものを使用します。他のファイル形式は使用できません。データのエクスポートに使用したのと同じ Silk Central およびデータベース バージョンにのみデータをインポートできます。
  • エクスポートおよびインポート プロセスに関して不明な点は、カスタマー サポートに遠慮なくお問い合わせください。
親トピック: プロジェクトで作業する


プロジェクトをインポートする

Silk Central プロジェクトはエクスポートして、Silk Central 外部にプロジェクト データをアーカイブ化することができます。データ、すべての結果、レポートなどを表示するには、プロジェクトを再度インポートする必要があります。

プロジェクト データをインポートするときは、データのエクスポートに使用したのと同じ Silk Central バージョンおよび同じデータベース バージョンを使用する必要があります。ただし、プロジェクト データを、データのエクスポートに使用したのと同じデータベース サーバーまたは別のデータベース サーバーにインポートすることができます。

プロジェクトをインポートするには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. 最上部の プロジェクトのインポート をクリックします。 プロジェクトのインポート ダイアログ ボックスが表示されます。
  3. コンピュータ上で適切な .zip ファイルを参照し、OK をクリックします。 Silk Central がデータをアップロードします。
    注: .zip ファイルは、事前に Silk Central からエクスポートされたファイルである必要があります。
    注: .zip ファイルは、データベースにインポートされる前に、フロントエンド サーバーにアップロードされます。そのため、フロントエンド サーバーには .zip ファイルを格納するだけの十分なディスク空き容量が必要となります。
  4. はい をクリックして、インポートを開始します。 次の点に注意します。
    • Silk Central は 1 度に 1 つのインポートのみを処理します。
    • Silk Central は、インポートの開始、終了、失敗時に監査ログを書き込みます。
    • インポートはバックグラウンドで処理されます。インポートの完了時には、電子メールで通知されます。インポートを開始する前に、電子メール アドレスと電子メール サーバーが設定されていることを確認してください。設定されていないと通知されません。詳細については、「電子メール サーバーを設定する」および「ユーザーの設定ページ」を参照してください。
    • インポートが完了すると、プロジェクトがプロジェクト リストに表示されます。
重要: プロジェクトのエクスポートまたはインポートを開始する前に、以下の推奨事項をよくお読みください。
  • プロジェクト データを大量に保有する大型プロジェクトをエクスポートまたはインポートするとき、エクスポートおよびインポート プロセスには長時間 (最長では数時間) かかることがあります。
  • ファイル サイズは、多くの要因から影響を受け、プロジェクトごとに大きく異なります。たとえば、資産数、実行数、添付情報、コード カバレッジ統計情報、そして最も重要な結果ファイルなどが影響を与える要因となります。
  • エクスポートを行う前に、プロジェクトのサイズを最小限にすることをお勧めします。したがって、不要なデータ、特に使用しない結果ファイルを削除する必要があります。プロジェクトのサイズが 1.2 GB を超えている場合、Request entity is too large（要求のエンティティが大きすぎました） というエラーがインポート時に発生することがあります。プロジェクトのサイズをこれ以上小さくできない場合には、nginx.conf.template ファイル（C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf）の client_max_body_size プロパティの値を変更して、アップロード サイズの制限を増やすことができます。
  • 特に大規模なプロジェクトがデータベースに書き込まれると、データベースのパフォーマンスが著しく低下する可能性があります。次回のメンテナンス時に Silk Central データベース スキーマのフル インデックスを再構築することを強く推奨します。
  • Internet Explorer などのブラウザーでは、ファイルのアップロードに制限があります。インポートするプロジェクトがこのサイズを超えている場合、インポートは失敗します。この問題を避けるには、他のブラウザーを使用してください。
  • エクスポートまたはインポート プロセスによって、Silk Central およびデータベース サーバーには大きな負荷がかかることに注意します。エクスポートまたはインポート アクションは、ユーザーのいない時間帯 (たとえば、夜間や週末)、あるいは少なくとも Silk Central の利用率が低く、ユーザーがログインしていないときに実行する必要があります。
  • データのエクスポートおよびインポートは、データベースおよびその内容に密接に関係します。データベースに既にデータの不整合が含まれていると、プロジェクトのインポートに失敗する可能性があります。したがって、あらゆるバックアップ プロセスにおいて、エクスポートを行ったらただちに再インポートを行い、妥当性、データの整合性、回復可能性を確認することを強くお勧めします。
  • プロジェクト データを再インポートするには、エクスポートした .zip ファイルと同じものを使用します。他のファイル形式は使用できません。データのエクスポートに使用したのと同じ Silk Central およびデータベース バージョンにのみデータをインポートできます。
  • エクスポートおよびインポート プロセスに関して不明な点は、カスタマー サポートに遠慮なくお問い合わせください。
親トピック: プロジェクトで作業する
関連タスク
電子メールサーバーを設定する
関連資料
[ユーザーの設定] ページ


[プロジェクトのコピー] ダイアログ ボックス

プロジェクト > プロジェクト リスト > プロジェクトのコピー

このダイアログ ボックスは、既存のプロジェクトを新しいプロジェクトにコピーするために使用します。

注: [コピーする追加情報] の各チェック ボックス (新しいプロジェクトと共にコピーする情報に対応) をオンにします。追加情報の種類を選択しないと、グループ割り当て、ロケーション割り当て、プロジェクト設定だけが行われている空のプロジェクトがコピーされます。
項目 | 説明
新しいプロジェクト名 | 既存のプロジェクトをコピーする新しいプロジェクトの名前を指定します。
新しいプロジェクトの説明 | 既存のプロジェクトをコピーする新しいプロジェクトの説明を指定します。
設定 | プロジェクトの設定、フィルタ、属性、カスタム要件プロパティ、変更通知、および統合構成情報を新しいプロジェクトにコピーするには、このチェック ボックスをオンにします。サードパーティ インテグレーションの構成設定情報はコピーされません。
要件ツリー (要件設定を含む) | 要件ごとのすべての情報（プロパティ、添付ファイルなど）と共に、要件ツリーをコピーするには、このチェック ボックスをオンにします。サードパーティ要件情報はコピーされません。プロジェクトを外部の要件管理システム用に設定してある場合は、RMS の設定をプロジェクトのコピーに転送するかどうかの指定を求められます。
要件履歴 | 要件ごとの履歴情報をコピーするには、このチェック ボックスをオンにします。このオプションは、要件ツリー (要件設定を含む) をオンにした場合にのみ指定できます。
テスト ツリー (テスト設定を含む) | テスト ごとのすべての情報と共に、テスト ツリーをコピーするには、このチェック ボックスをオンにします。要件ツリー (要件設定を含む) および テスト ツリー (テスト設定を含む) の両方をオンにすると、前記の情報に加えて、要件とテスト の間の関係に関連する情報 (割り当て済み要件と割り当て済みテスト ) もコピーされます。
テスト履歴 | テストごとの履歴情報をコピーするには、このチェック ボックスをオンにします。このオプションは、テスト ツリー (テスト設定を含む) をオンにした場合にのみ指定できます。
実行計画ツリー (テスト ツリーを含む) | 実行計画ごとのすべての情報と共に、実行ツリーをコピーするには、このチェック ボックスをオンにします。
テストの最近の実行 | テスト ごとの前回の実行をコピーするには、このチェック ボックスをオンにします。このオプションは、実行計画ツリー (テスト ツリーを含む) をオンにした場合にのみ指定できます。要件ツリー (要件設定を含む)、実行計画ツリー (テスト ツリーを含む)、および テスト定義の最近の実行 をオンにすると、すべてのツリーがそっくりコピーされます。ツリー間の関係も確立されます。
レポート | プロジェクト関連のすべてのレポートを新しいプロジェクトにコピーするには、このチェック ボックスをオンにします。

Issue Manager の場合、ダイアログ ボックスには次のチェック ボックスも別途表示されます。

[プロジェクトのコピー — Issue Manager] ダイアログ項目 | 説明
問題のコピー | このチェック ボックスをオンにすると、ソース プロジェクトの既存の問題がすべて、新しいプロジェクトにコピーされます。
アーカイブされた問題のコピー | このチェック ボックスをオンにすると、ソース プロジェクトのアーカイブされた問題がすべて、新しいプロジェクトにコピーされます。

どちらのチェック ボックスもオンにしないと、問題データは新しいプロジェクトにコピーされません。

ソース プロジェクトの設定は、新しいプロジェクトに自動的にコピーされます。次の設定が含まれます。

  • 製品
  • GUI 設定
  • 通知ルールとシステム全体のトリガ
  • ルーティング ルール
  • ワークフロー
  • 受信箱のユーザー ビュー
  • ワークグループ
  • 受信箱
  • ユーザー アカウントの設定
親トピック: プロジェクトで作業する


[プロジェクト設定] ページ

プロジェクト > 新しいプロジェクト

プロジェクト設定 ページは、プロジェクトの設定に使用します。このページには、次の項目があります。

項目 | 説明
プロジェクト名 | GUI とレポートに表示されるプロジェクトの名前を指定します。
説明 | プロジェクトの説明です。任意の説明文を入力できます。
プロジェクトの所有者 | プロジェクトの所有者を指定します。選択したユーザー アカウントに特別な権限が与えられることはありません。 この設定は単に情報を提供するものです。
アクティブ | プロジェクトを有効にするには、このチェック ボックスをオンにします。非アクティブのプロジェクトは、アプリケーションに表示されません。
タグ | 多くのプロジェクトがある場合、プロジェクト タグを使用すると、プロジェクト リスト ページの タグ 列を使用してフィルタすることができます。
プロジェクト テンプレート | このリスト ボックスでは、プロジェクトがアジャイル テンプレートに基づいているかどうかを定義します。アジャイル プロジェクト テンプレート を選択して、アジャイル プロジェクト管理ツールのためのテンプレートに基づいたプロジェクトを作成するか、<なし> を選択して、シンプルなプロジェクトを作成します。
Issue Manager との統合 以下のオプションのいずれかを選択します。
  • プロジェクトなし：Issue Manager インテグレーションが作成されていません。
  • 新しいプロジェクトの初期化：新しいプロジェクトが Issue Manager プロジェクトとして初期化されます。ページ下部の 保存 をクリックするとダイアログ ボックスが表示され、プロジェクトのすべての必須設定 (グループ、受信箱、製品、など) を設定できます。
  • 既存のプロジェクトの再利用：既存のプロジェクトが使用されます。リストからプロジェクトを選択します。プロジェクトが Issue Manager プロジェクトとしてまだ設定されていない場合、すべての必要な設定を行う必要があります。保存 をクリックすると、ダイアログ ボックスが表示されます。プロジェクトが既に Issue Manager プロジェクトとして設定されている場合は、認証情報およびステータス マッピングのみを設定する必要があります。
共有テスト 以下のオプションのいずれかを選択します。
  • テストを共有しない：このプロジェクトは他のプロジェクトのテストを参照しません。また、このプロジェクトのテストが他のプロジェクトから参照されることもありません。
  • テストを共有する：このプロジェクトをリポジトリ プロジェクトとして、テストを他のプロジェクトから参照できるように設定します。
  • 共有テストの参照元：このプロジェクトがテストを参照するリポジトリ プロジェクトを選択します。
グループ | グループ セクションには、利用可能なグループと割り当て済みグループのリストが表示されます。グループの割り当ては必須です。Ctrl + クリック または Shift + クリック を使用すると、複数のグループを選択できます。LDAP グループのインポート をクリックして、LDAP サーバーからグループをインポートすることもできます。詳細については、「LDAP サーバーからグループをインポートする」を参照してください。ユーザー グループが存在しない場合は、後でユーザー グループを作成してから割り当てることができます。また、グループ/プロジェクトの割り当ては、グループの設定 ページで設定することもできます。権限は、ユーザー ロールによって異なります。ユーザー権限については、「ユーザー ロールとアクセス許可」を参照してください。
ロケーション | ロケーション セクションには、利用可能なロケーションと割り当て済みロケーションのリストが表示されます。ロケーションの割り当ては必須です。Ctrl + クリック または Shift + クリック を使用すると、複数のロケーションを選択できます。ロケーションが存在しない場合は、後でロケーションを作成してから割り当てることができます。また、ロケーション/プロジェクトの割り当ては、ロケーション設定 ページで設定することもできます。詳細については、「ロケーションを管理する」を参照してください。
親トピック: プロジェクトで作業する


Issue Manager プロジェクトとしてプロジェクトを初期化する

Silk Central でプロジェクトを新規作成するとき、プロジェクトを Issue Manager プロジェクトと統合できます。
  1. メニューで プロジェクト > プロジェクト リスト をクリックします。 プロジェクト ページに、既存のすべてのプロジェクトとプロジェクト ベースラインが一覧表示されます。
  2. プロジェクトの新規作成 をクリックします。 プロジェクト設定 ページが表示されます。
  3. 設定を行います。詳細については、「プロジェクトを追加する」を参照してください。
  4. Issue Manager インテグレーション 行で、以下を選択できます。
    • 新しいプロジェクトの初期化：新しい Issue Manager プロジェクトを初期化し、新規作成した Silk Central プロジェクトと統合します。
    • 既存のプロジェクトの再利用：既存の Issue Manager プロジェクトが新規作成した Silk Central プロジェクトと統合されます。リストからプロジェクトを選択します。認証情報とステータスのマッピングを設定する必要があります。
  5. ページ下部の 保存 をクリックします。 プロジェクトが新規作成され、プロジェクト リスト に表示されます。Issue Manager プロジェクトの設定 ダイアログ ボックスが表示されます。
  6. グループ設定を行い、次へ をクリックします。
  7. 受信箱の追加 をクリックし、受信箱をプロジェクトに手動で追加します。受信箱の生成 をクリックすると、プロジェクトに割り当てられているすべてのユーザーに対して受信箱が自動的に生成されます。チェックボックスをオンにして、今後割り当てられるユーザーおよびユーザーグループに対して受信箱を自動的に生成されるようにできます。次へ をクリックします。
  8. 製品設定を定義し、閉じる をクリックします。
  9. デフォルトの認証情報を入力し、OK をクリックします。入力するユーザー名は、プロジェクトに割り当てたユーザー グループの一部になっている必要があります。
  10. 外部および内部プロパティをマップする方法を設定し、OK をクリックします。
注: 初期化プロセスはいつでもキャンセルできます。ただし、後で初期化を完了するには、問題追跡プロファイル ページ、Issue Managerプロジェクト リスト ページ、Issue Manager 設定 ページでこれらの設定を行う必要があります。
親トピック: プロジェクトで作業する


ビルド情報

ビルド情報ファイルには、テスト実行に使用されるバージョン情報とビルド情報が記載されています。 ビルド情報ファイルは、一般的に、実行が行われる実行サーバー上に格納され、そこで検索されます。 実行サーバー上でビルド情報ファイルが見つからない場合は、アプリケーション サーバー上でファイルが検索されます。 この動作は、実行サーバーが複数あり、それらすべての実行サーバーで単一のビルド情報ファイルを共用する場合に役立ちます。 アプリケーション サーバー上のただ 1 つのビルド情報ファイルを管理するだけで十分です。 実行サーバーが割り当てられていない自動テスト用のビルド情報ファイル、およびすべての手動テスト用のビルド情報ファイルは、アプリケーション サーバー上で直ちに検索されます。

Silk Central では、テスト結果とビルド情報を照合し、特定のビルド番号に対応するテスト結果を表示することができます。

  • ビルド情報の更新
    ビルド情報を更新する方法について説明します。
  • ビルド情報ファイルを作成する
    Silk Central プロジェクトのビルド情報を保存するため、ビルド情報ファイルを作成します。
親トピック: プロジェクトを管理する


ビルド情報の更新

ビルド情報ファイルは手動で作成および設定する必要があります。 実行サーバー上で新しいビルドがテストに使用できるようになるたびに、ビルド情報を更新して新しいビルド番号を反映してください。

ビルド情報は、2 とおりの方法で更新できます。

  • 手動：新しいビルドがインストールされるたびにファイルを編集します。
  • 自動：自動ビルド更新プロセス（VBScript などによる）を用いて、ビルド情報ファイルを更新します。
親トピック: ビルド情報


ビルド情報ファイルを作成する

ビルド情報ファイルを作成するには：
  1. アプリケーション サーバーで、次のフォルダに移動します：C:\ProgramData\SilkCentral\instance_<インスタンス番号>_<インスタンス名>\BuildInfos。
  2. テンプレート ファイル BuildInfoExample.xml に基づいて、プロジェクト用のビルド情報ファイルを作成します。テンプレート ファイルには、以下のコードが含まれます。
    <ProjectBuildInfo>
  <BuildEntryList>
       <BuildEntry name="Demo Product">
            <Version>3.1</Version>
            <BuildNr>350</BuildNr>
    </BuildEntry>
       <BuildEntry name="Product2">
            <Version>4.2</Version>
            <BuildNr>613</BuildNr>
    </BuildEntry>
  </BuildEntryList>
</ProjectBuildInfo>
    注: BuildEntryList 要素には、BuildEntry 要素のリストが含まれます。BuildEntry タグは、BuildEntry 要素の name 属性で定義されている特定の製品を参照します。
  3. 実際の環境に合わせて、ファイルの内容を変更します。
    Version
    現在、テストに使用できるバージョン番号です。この番号は、各実行サーバーと同じである必要はありません。
    BuildNr
    現在、テストに使用できるビルド番号です。この番号は、各実行サーバーと同じである必要はありません。
  4. 省略可能：特定の実行サーバーで異なるバージョンよビルド番号情報を使用する必要がある場合には、変更したビルド情報ファイルを実行サーバーの C:\ProgramData\SilkCentral\BuildInfos に作成します。Linux 実行サーバーの場合は、ユーザー ホームの ~/.LinuxExecServer-18.5.0/BuildInfos/ にファイルを保存する必要があります。
  5. ビルド情報ファイルを作成したら、対応するプロジェクトの設定でファイル名を指定する必要があります。プロジェクト:<プロジェクト名> > プロジェクト リスト をクリックして、自分に割り当てられているプロジェクトのリストを表示します。ビルド情報をリンクするプロジェクトを選択します。
    注: プロジェクトに対してテストをスケジュールする前に、これを行う必要があります。リンクを設定する前にスケジュールしたテストは、更新されません。
  6. プロジェクト設定 タブをクリックします。
  7. 編集 をクリックし、選択したプロジェクトのプロジェクト設定を編集します。
    プロジェクト設定の編集 ダイアログ ボックスが表示されます。
  8. ビルド情報ファイル名 フィールドで、作成済みの XML ファイルの名前を指定します。
  9. OK をクリックして情報を更新します。これ以降に実行するすべてのテストでは、Silk Central は対応するファイルからビルド情報を読み取り、テスト結果とその情報を対応させます。
親トピック: ビルド情報


プロジェクトとベースラインを比較する

ベースライン化されたプロジェクトの場合、ベースラインの比較レポートを使用して、プロジェクトがベースライン化されてからプロジェクトのテストに加えられたすべての変更を確認できます。

レポートを表示するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. Ctrl + クリック を使用して、比較するプロジェクトとプロジェクトのベースラインを選択します。
    ヒント: 複数のベースラインを選択する場合は、ベースラインの名前をクリックしないでください。その代わりに別の列をクリックします。
  3. 選択したバージョンを右クリックします。
  4. レポート > ベースライン テストの比較 を選択します。
    注: ベースラインの比較レポートをコンテキスト メニューに表示するには、レポートを 1 回実行する必要があります。レポートがグレー表示されている場合は、レポート 領域でレポートを 1 回実行します。
親トピック: プロジェクトを管理する


プロジェクトを選択する

プロジェクトを選択するには：

  1. メニューで プロジェクト > プロジェクト リスト をクリックします。
  2. プロジェクトの名前をクリックして選択します。
    注: 選択できるのは、アクティブなプロジェクトだけです。
親トピック: プロジェクトを管理する


プロジェクト リスト

プロジェクト:<プロジェクト名> > プロジェクト リスト

プロジェクト リスト ページでは、お使いの Silk Central インストールに関連付けられているすべてのプロジェクトとプロジェクト ベースラインがアルファベット順に表示されます。このページでは、フィルタ処理はサポートされていますが、ソートはサポートされていません。表示されるプロジェクトは、名前別にソートされます。非アクティブなプロジェクトと非アクティブなプロジェクト ベースラインは無効になっています。

プロジェクト ベースラインは、作成日別にソートされ、特別なアイコンが付き、元のプロジェクトの子ノードとして表示されます。

詳細については、「プロジェクトを管理する」を参照してください。

プロジェクトおよびプロジェクト ベースラインごとに、以下の列が表示されます。

列 | 説明
アクション | 削除 プロジェクトの編集 プロジェクトのコピー プロジェクトのベースライン化 プロジェクトのエクスポート 注: 現在のユーザーがプロジェクトの変更/削除権限を持っていない場合は、この列は非表示となります。
プロジェクト | プロジェクトの名前。クリックして、プロジェクトをアクティブなプロジェクトとして設定します。
プロジェクト ID | プロジェクトの識別子。
ステータス | アクティブ または 非アクティブ。クリックしてステータスを切り替えます。
説明 | プロジェクトの説明。
プロジェクトの所有者 | プロジェクトの所有者を指定します。選択したユーザー アカウントに特別な権限が与えられることはありません。 この設定は単に情報を提供するものです。
リリース日 | プロジェクトの予定されているリリース日を指定します。
作成日時 | プロジェクトが作成された日付と時刻。
作成者 | このプロジェクトを作成したユーザー。
変更日時 | プロジェクトが最後に変更された日付と時刻。
変更者 | プロジェクトを最後に変更したユーザー。
タグ | 多くのプロジェクトがある場合、プロジェクト タグを使用すると、プロジェクト リスト ページの タグ 列を使用してフィルタすることができます。 Ctrl + クリック または Shift + クリック を使用して複数のプロジェクトを選択し、選択箇所を右クリックして タグの編集 をクリックすると、複数のプロジェクトのタグを一度に管理できます。 注: タグによるフィルタリングには OR 条件が使用されます。つまり、指定したタグのいずれかを含んだプロジェクトがすべて表示されます。
親トピック: プロジェクトを管理する
関連概念
プロジェクトで作業する


最近アクセスしたプロジェクトに切り替える

最近アクセスした 5 つの Silk Central プロジェクトをすばやく切り替えることができます。

最近開いた 5 つのプロジェクトのうち 1 つを開くには：

  1. メニューの プロジェクト をクリックします。
  2. 最近使ったプロジェクト リストで、アクセスするプロジェクトの名前をクリックします。 選択したプロジェクトで引き続き作業できます。
親トピック: プロジェクトを管理する


プロジェクト設定

プロジェクト設定とは、プロジェクト リリース日などのプロジェクトに固有の設定のことです。

  • プロジェクトを設定する
    プロジェクトを設定して、カスタマイズします。
  • フィルタ
    フィルタを使用して、無関係な情報を除外しながら必要な情報を確実に見つける方法について説明します。
  • 属性
    カスタム属性を使用して、テストと実行計画の情報をカスタマイズする方法について説明します。
  • 要件のプロパティ
    利用可能な要件プロパティのタイプを説明します。
  • ステップ プロパティ
    ステップ プロパティを使用して手動テスト ステップを追加プロパティで拡張する方法について説明します。
  • 変更通知
    要件やテストが他のユーザーによって変更されたときの電子メール通知の設定方法について説明します。
  • 要件管理ツールとの統合
    外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。
  • 問題追跡プロファイル統合
    Silk Central を外部の問題追跡システムと統合する方法について説明します。
  • ソース管理プロファイル
    ソース管理プロファイルにより、Silk Central を外部のソース管理システムと統合できます。ソース管理プロファイルを定義することで、Silk Central の実行サーバーがテスト実行用のプログラム ソースを取得する場所を定義できます。
  • データ駆動型テスト向けのデータ ソース
    データ駆動型テストとは、スプレッドシートやデータベースなど、既存のデータ ソースに含まれる値を元に行うテストのことです。データ ソースは、プロジェクトごとの範囲で管理されます。
  • ステータスの理由
    ステータスの理由が手動テスト実行のステータスを限定する方法について説明します。
  • [プロジェクト設定] ページ
    アクティブ プロジェクトの全般的な詳細情報が一覧表示されます。
親トピック: プロジェクトを管理する


プロジェクトを設定する

プロジェクト設定をカスタマイズするには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. プロジェクト設定 タブを選択して、現在の設定を表示します。 プロジェクト設定 ページが開きます。
  3. 現在のプロジェクト設定を変更する場合は、編集 をクリックします。
  4. プロジェクト設定の編集 ダイアログ ボックスが表示されます。次の情報を指定できます。
    ビルド情報ファイル名
    ビルド情報ファイルには、ビルド番号、ビルド ログの場所、エラー ログの場所、ビルドの場所などのプロジェクト情報が記載されています。このフィールドには、プロジェクトのビルド情報ファイルの名前を入力します。テスト実行ではすべて、指定されたこのファイルからビルド情報を読み取ります。
    プロジェクト リリース日
    プロジェクトの予定されているリリース日を指定します。
    結果で無視するファイル拡張子
    テスト実行の結果として保存しないファイルのタイプを指定します。
    注: ファイル拡張子はカンマで区切る必要があります（xlg, *_, res など）。ビルド情報ファイル名 や 結果で無視するファイル拡張子 を変更しても、スケジュール設定されたテストには影響ありません。タスクを実行サーバーに再割り当てするには、テストのスケジュールを定義し直すか、データベースとの接続をいったん解除してから接続し直す必要があります。
  5. プロジェクト設定を保存するには、OK をクリックします。
親トピック: プロジェクト設定
関連概念
ビルド情報


問題追跡プロファイル統合

問題追跡プロファイルにより、Silk Central は外部の問題追跡システムを統合することができます。

カスタム プラグインをインストールすることにより、その他の問題追跡システムを構成することができます。詳細については、「問題追跡システムとの統合」を参照してください。問題追跡プロファイルを定義することにより、テスト 領域内のテストを、サードパーティの問題追跡システム内にある問題へ、リンク付けすることができます。リンクされている問題の状態は、サードパーティ製の問題追跡システムによって定期的に更新されます。

  • 問題の状態をマップする
    内部と外部の問題を照会した場合に、Silk Central で問題リストが正しく表示されるようにするため、外部の問題追跡システムに既にある問題の状態を Silk Central の問題の状態にマップします。
  • Atlassian JIRA
    Silk Central と統合するために Atlassian JIRA の問題追跡プロファイルを構成する方法について説明します。
  • Bugzilla
    Silk Central と統合するために Bugzilla の問題追跡プロファイルを構成する方法について説明します。
  • IBM Rational ClearQuest
    Silk Central と統合するために IBM Rational ClearQuest の問題追跡プロファイルを構成する方法について説明します。
  • Issue Manager
    Silk Central の問題追跡ツールである Issue Manager について説明します。
  • SAP Solution Manager との統合
    Silk Central と SAP Solution Manager を統合する方法について説明します。
  • Microsoft Team Foundation Server
    Silk Central と統合するために Team Foundation Server の問題追跡プロファイルを構成する方法について説明します。
  • StarTeam 問題追跡プロファイル
    Silk Central と統合するために StarTeam の問題追跡プロファイルを構成する方法について説明します。
  • 問題追跡プロファイルを削除する
    プロファイルが不要になった場合に、既存の問題追跡プロファイルを削除します。
  • [問題追跡プロファイル] ページ
    外部の問題追跡システムを Silk Central に統合するために構成された問題追跡プロファイルがすべて一覧表示されます。
親トピック: プロジェクト設定
親トピック: 統合
関連概念
問題追跡システムとの統合


問題の状態をマップする

新しい問題追跡プロファイルを定義した後は、外部の問題追跡システムに既にある問題状態を Silk Central の問題の状態にマップする必要があります。 これを行うことで、内部と外部の両方の問題にクエリをかけた際、Silk Central が正しい問題リストを表示できるようになります。

問題の状態をマップするには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 問題追跡 タブをクリックします。 問題追跡 ページに、システムで作成されているすべての問題追跡プロファイルが一覧表示されます。
  3. 編集する問題追跡プロファイルの アクション 列で、問題追跡プロファイルのマッピングを編集... をクリックします。 ステータス マッピングの編集 ダイアログ ボックスが開きます。
  4. 内部の問題の状態を対応する外部の問題の状態にマップします。リスト ボックスから対応するエントリを選択します。 外部の問題追跡ソフトウェアの既存の問題の状態は、外部 列に一覧表示されます。 Silk Central の内部の問題の状態は、内部 列のリスト ボックスで利用できます。
  5. 外部の問題の状態を内部の問題の状態にそれぞれマップしたら、OK をクリックして設定内容を保存します。キャンセル をクリックすると、処理が中止されます。
親トピック: 問題追跡プロファイル統合


Atlassian JIRA

Silk Central と統合するために Atlassian JIRA (JIRA) の問題追跡プロファイルを構成する方法について説明します。

JIRA プラグインは、JIRA の REST API を使用した Silk Central の統合用 Java API に依存しています。

Silk Central の統合が現在サポートしているバージョンは次の通りです： Atlassian JIRA 6、7

テストに外部 JIRA 問題を割り当てる場合は、プロジェクト キーとともに、またはプロジェクト キーなしで問題 ID を入力します。例：PROJECT-13、または単に 13。

Silk Central は、次の JIRA フィールド タイプをサポートします。
  • Text Field (< 255 characters) /Free Text Field (unlimited text)
  • Select List (single choice) /Select List (multiple choices)
  • Date Picker /Date Time Picker
    注: これらのタイプは、テキスト フィールドとして表示され、JIRA の次のような形式で入力する必要があります。Date Picker：dd/MMM/yy (24/Mar/16 など)、Date Time Picker：dd/MMM/yy h:mm a (24/Mar/16 4:11 AM など)
  • Group Picker (single group) /Group Picker (multiple groups)
  • Project Picker (single project)
  • User Picker (single user) /User Picker (multiple users)
    注: JIRA バージョン 5 以前では、デフォルトの jira-users グループにのみ属しているユーザーは表示されません。
  • Version Picker (single version) / Version Picker (multiple versions)
他の JIRA フィールド タイプは、Silk Central の単一行のテキスト フィールドとして表示されます。

次の JIRA システム フィールドはサポートされません：Original Estimate、Remaining Estimate、Attachment、Labels。

  • Atlassian JIRA の問題追跡プロファイルを追加する
    JIRA の問題追跡プロファイルを作成して、テスト 領域内のテストを JIRA の問題にリンクします。
  • Atlassian JIRA の問題追跡プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の JIRA の問題追跡プロファイルを変更します。
親トピック: 問題追跡プロファイル統合


Atlassian JIRA の問題追跡プロファイルを追加する

JIRA の問題追跡プロファイルを追加するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. プロファイルの新規作成 をクリックして、問題追跡プロファイルの新規作成 ダイアログ ボックスを開きます。
  3. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  4. 新しいプロファイルの 説明 を入力します。
  5. Atlassian JIRA を タイプ リストから選択します。
  6. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。ユーザー名には、有効な JIRA ユーザー プロファイル名を指定してください。 これらの認証情報は、JIRA 問題追跡システムへのアクセスに使用されます。
    重要: JIRA の権限が不足していると、プラグインがこのアカウントを使用して問題を追加/更新する際に不整合が発生する可能性があるため、十分な権限を持った JIRA アカウントの資格情報を使用してください。JIRA アカウントには、Silk Central で使用するプロジェクトそれぞれに対して次の権限が必要です。
    • プロジェクトの参照
    • 課題の作成
    • 割り当て可能なユーザー
    • 報告者の修正

    さらに、JIRA アカウントで、JIRA　アプリケーションにアクセス（ログイン）できる必要もあります。

  7. URL フィールドに JIRA サーバーのホスト名と、サーバーへの接続に使用するポートを入力します。
  8. プロジェクトの読み込み をクリックすると、サーバーからすべてのプロジェクトがロードされ、プロジェクト リスト ボックスに表示されます。プロジェクト リスト ボックスからプロジェクトを選択します。
  9. 省略可能：問題ダイアログで利用可能なすべての JIRA フィールドを表示するには、すべてのフィールドを表示 で true を選択します。 false を選択すると、必須フィールドだけが表示されます。true を選択する場合、問題追跡プロファイルに定義する JIRA ユーザーには JIRA 管理用のアクセス許可を付与する必要があります。
  10. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  11. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: Atlassian JIRA
関連タスク
問題の状態をマップする


Atlassian JIRA の問題追跡プロファイルを編集する

ユーザーの問題追跡システムのサーバーまたはログイン認証情報が変わったとき、変更に応じて問題追跡プロファイルを編集する必要があります。

既存の Atlassian JIRA の問題追跡プロファイルを編集するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. 問題追跡プロファイルの名前をクリックします。 問題追跡プロファイルの編集 ダイアログ ボックスが開きます。
  3. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  4. プロファイルの 説明 を編集します。
  5. 省略可能：問題追跡プロファイルの新しい タイプ をリスト ボックスから選択します。
  6. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。ユーザー名には、有効な JIRA ユーザー プロファイル名を指定してください。 これらの認証情報は、JIRA 問題追跡システムへのアクセスに使用されます。
    重要: JIRA の権限が不足していると、プラグインがこのアカウントを使用して問題を追加/更新する際に不整合が発生する可能性があるため、十分な権限を持った JIRA アカウントの資格情報を使用してください。JIRA アカウントには、Silk Central で使用するプロジェクトそれぞれに対して次の権限が必要です。
    • プロジェクトの参照
    • 課題の作成
    • 割り当て可能なユーザー
    • 報告者の修正

    さらに、JIRA アカウントで、JIRA　アプリケーションにアクセス（ログイン）できる必要もあります。

  7. URL フィールドで、JIRA サーバーのホスト名とサーバーと接続するために使用するポートを編集します。
  8. JIRA プロジェクトを変更するには、プロジェクトの読み込み をクリックします。サーバーからすべてのプロジェクトがロードされ、プロジェクト リスト ボックスに表示されます。プロジェクト リスト ボックスからプロジェクトを選択します。
  9. 省略可能：問題ダイアログで利用可能なすべての JIRA フィールドを表示するには、すべてのフィールドを表示 で true を選択します。 false を選択すると、必須フィールドだけが表示されます。true を選択する場合、問題追跡プロファイルに定義する JIRA ユーザーには JIRA 管理用のアクセス許可を付与する必要があります。
  10. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  11. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: Atlassian JIRA
関連タスク
問題の状態をマップする


Bugzilla

Silk Central と統合するために Bugzilla の問題追跡プロファイルを構成する方法について説明します。

Bugzilla プラグインは、統合する Silk Central Java API に依存します。Silk Central は、Redstone XML-RPC ライブラリを使用して、Bugzilla 3.0 で提供されている XML-RPC Bugzilla の Web サービスを介して Bugzilla と通信します。Bugzilla の統合を有効にするには、Web サーバー用に SOAP::Lite パッケージがインストールされていることを確認してください。たとえば、Debian の配布では libsoap-lite-perl パッケージがインストールされます。

Silk Central の統合が現在サポートしているバージョンは次の通りです： Bugzilla 4.4.12、5.0.3

  • Bugzilla 問題追跡プロファイルを追加する
    Bugzilla の問題追跡プロファイルを作成して、テスト 領域内のテストを Bugzilla の問題にリンクします。
  • Bugzilla 問題追跡プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の Bugzilla 問題追跡プロファイルを変更します。
親トピック: 問題追跡プロファイル統合


Bugzilla 問題追跡プロファイルを追加する

Bugzilla の問題追跡プロファイルを追加するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. プロファイルの新規作成 をクリックして、問題追跡プロファイルの新規作成 ダイアログ ボックスを開きます。
  3. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  4. 新しいプロファイルの 説明 を入力します。
  5. Bugzilla を タイプ リスト ボックスから選択します。
  6. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  7. インストールした Bugzilla プログラムの URL を入力します (例： http://bugzillaserver/bugzilla)。
  8. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  9. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: Bugzilla
関連タスク
問題の状態をマップする


Bugzilla 問題追跡プロファイルを編集する

ユーザーの問題追跡システムのサーバーまたはログイン認証情報が変わったとき、変更に応じて問題追跡プロファイルを編集する必要があります。

既存の Bugzilla 問題追跡プロファイルを編集するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. 問題追跡プロファイルの名前をクリックします。 問題追跡プロファイルの編集 ダイアログ ボックスが開きます。
  3. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  4. プロファイルの 説明 を編集します。
  5. 省略可能：問題追跡プロファイルの新しい タイプ をリスト ボックスから選択します。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  7. インストールした Bugzilla プログラムの URL を編集します
  8. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  9. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: Bugzilla
関連タスク
問題の状態をマップする


IBM Rational ClearQuest

Silk Central と統合するために IBM Rational ClearQuest の問題追跡プロファイルを構成する方法について説明します。

IBM Rational ClearQuest 製品により、欠陥および変更追跡を柔軟に行い、ワークフローのサポートを自動化します。2 種類のキーとなる製品は、IBM Rational ClearQuest (ClearQuest) および IBM Rational ClearQuest MultiSite (ClearQuest Multisite) です。ClearQuest プロファイルを操作するには、Silk Central フロントエンド サーバーを実行するコンピュータに ClearQuest のクライアント ソフトウェアをインストールしておく必要があります。ClearQuest のインストールの詳細については、ClearQuest のドキュメントを参照してください。

Silk Central の統合が現在サポートしているバージョンは次の通りです： IBM Rational ClearQuest 8.0

  • ClearQuest 問題追跡プロファイルを追加する
    ClearQuest の問題追跡プロファイルを作成して、テスト 領域内のテストを ClearQuest の問題にリンクします。
  • ClearQuest 問題追跡プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の ClearQuest 問題追跡プロファイルを変更します。
親トピック: 問題追跡プロファイル統合


ClearQuest 問題追跡プロファイルを追加する

ClearQuest の問題追跡プロファイルを追加するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. プロファイルの新規作成 をクリックして、問題追跡プロファイルの新規作成 ダイアログ ボックスを開きます。
  3. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  4. 新しいプロファイルの 説明 を入力します。
  5. IBM Rational ClearQuest を タイプ リスト ボックスから選択します。
  6. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  7. ユーザーの ClearQuest の リポジトリ情報 を入力します。 これは ClearQuest のクライアント ソフトウェアで定義したデータベース名です。サンプル データベースの名前は、SAMPL です。
    注: 2 つ以上の ClearQuest スキーマ リポジトリを使用することはできません。Silk Central は、デフォルトの ClearQuest リポジトリに接続します。
  8. レコード タイプ（ClearQuest の問題タイプ）を指定します。 Silk Central に問題を入力すると、ClearQuest によりこのフィールドで定義した問題タイプで問題が保存されます。デフォルトの問題タイプは Defect です。
  9. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  10. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: IBM Rational ClearQuest
関連タスク
問題の状態をマップする


ClearQuest 問題追跡プロファイルを編集する

ユーザーの問題追跡システムのサーバーまたはログイン認証情報が変わったとき、変更に応じて問題追跡プロファイルを編集する必要があります。

既存の ClearQuest 問題追跡プロファイルを編集するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. 問題追跡プロファイルの名前をクリックします。 問題追跡プロファイルの編集 ダイアログ ボックスが開きます。
  3. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  4. プロファイルの 説明 を編集します。
  5. 省略可能：問題追跡プロファイルの新しい タイプ をリスト ボックスから選択します。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  7. ユーザーの ClearQuest の リポジトリ情報 を編集します。 これは ClearQuest のクライアント ソフトウェアで定義したデータベース名です。サンプル データベースの名前は、SAMPL です。
    注: 2 つ以上の ClearQuest スキーマ リポジトリを使用することはできません。Silk Central は、デフォルトの ClearQuest リポジトリに接続します。
  8. レコード タイプ（ClearQuest の問題タイプ）を変更します。 Silk Central に問題を入力したとき、ClearQuest によりこのフィールドで定義した問題タイプで問題が保存されます。
  9. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  10. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: IBM Rational ClearQuest
関連タスク
問題の状態をマップする


Issue Manager

Issue Manager には、Silk Central の問題追跡ツールであるが Silk Central に完全に統合されており、ユーザーは問題をシステム要件や実行されたテストと関連付けることができます。

テスト問題は、テスト > 詳細ビュー > 問題のメニューで、追加および管理できます。 詳細については、この『ヘルプ』の「Issue Manager」トピックを参照してください。

  • Issue Manager の問題追跡プロファイルを追加する
    Issue Manager の問題追跡プロファイルを作成して、テスト 領域内のテストを Issue Manager の問題にリンクします。
  • Issue Manager の問題追跡プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の Issue Manager の問題追跡プロファイルを変更します。
親トピック: 問題追跡プロファイル統合
関連概念
API ヘルプ


Issue Manager の問題追跡プロファイルを追加する

Issue Manager の問題追跡プロファイルを追加するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. プロファイルの新規作成 をクリックして、問題追跡プロファイルの新規作成 ダイアログ ボックスを開きます。
  3. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  4. 新しいプロファイルの 説明 を入力します。
  5. Issue Manager を タイプ リスト ボックスから選択します。
  6. Silk Central インスタンスの一部として統合されている Issue Manager プロファイルを使用する場合は、ローカル リポジトリ チェック ボックスをオンにします。外部の Issue Manager システムに接続する場合は、このオプションをオフにして、システムにアクセスするためのログイン資格情報を指定する必要があります。
  7. Issue Manager の URL にユーザーの Issue Manager の URL を入力します。これは Issue Manager にログインするために使う URL ですが、login を最後に付けません。ローカル リポジトリ オプションをオンにした場合は、デフォルトの URL のままにします。 例：ユーザーの標準 Issue Manager の URL が http://IssueManager/login の場合、正しいサービスの URL は http://IssueManager です。
  8. 省略可能：ユーザーが Web ユーザー インターフェイスにアクセスするのに使用する URL 以外の URL を使用して、Issue Manager がフロントエンド サーバーと通信する必要がある場合は、Web サービス URL フィールドに URL を入力します。ユーザーがプロキシを介して Web ユーザー インターフェイスにアクセスする場合など、Issue Manager はフロントエンド サーバーの内部 URL や IP アドレスを使用するため、必要になります。
  9. 次を実行します。
    1. プロジェクトの読み込み をクリックします。これにより プロジェクト リスト ボックスに、指定ユーザーがアクセスできるすべての初期化済み Issue Manager プロジェクトが表示されます。Issue Manager のユーザー グループが定義したプロジェクトのみが表示され、定義ユーザーが少なくとも 1 つのユーザー グループのメンバであることに注意してください。
    2. プロジェクト を選択します。ここで Issue Manager の問題が管理されます。
    注意:
    Issue Manager と Silk Central で同じプロジェクトを使わないことをお勧めします。将来別のプロジェクトで両方のツールを使う場合に柔軟性がなくなるためです。
  10. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  11. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: Issue Manager
関連タスク
問題の状態をマップする


Issue Manager の問題追跡プロファイルを編集する

ユーザーの問題追跡システムのサーバーまたはログイン認証情報が変わったとき、変更に応じて問題追跡プロファイルを編集する必要があります。

既存の Issue Manager の問題追跡プロファイルを編集するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. 問題追跡プロファイルの名前をクリックします。 問題追跡プロファイルの編集 ダイアログ ボックスが開きます。
  3. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  4. プロファイルの 説明 を編集します。
  5. 省略可能：問題追跡プロファイルの新しい タイプ をリスト ボックスから選択します。
  6. Silk Central インスタンスの一部として統合されている Issue Manager プロファイルを使用する場合は、ローカル リポジトリ チェック ボックスをオンにします。外部の Issue Manager システムに接続する場合は、このオプションをオフにして、システムにアクセスするためのログイン資格情報を指定する必要があります。
  7. Issue Manager のインストール場所が変わった場合、Issue Manager の URL を必要に応じて編集します。 これは Issue Manager にログインするために使う URL ですが、login を最後に付けません。例：ユーザーの標準 Issue Manager の URL が http://IssueManager/login の場合、正しいサービスの URL は http://IssueManager です。
  8. 省略可能：ユーザーが Web ユーザー インターフェイスにアクセスするのに使用する URL 以外の URL を使用して、Issue Manager がフロントエンド サーバーと通信する必要がある場合は、Web サービス URL フィールドに URL を入力します。ユーザーがプロキシを介して Web ユーザー インターフェイスにアクセスする場合など、Issue Manager はフロントエンド サーバーの内部 URL や IP アドレスを使用するため、必要になります。
  9. Issue Manager プロジェクトを変更するには、プロジェクトの読み込み をクリックします。サーバーからすべてのプロジェクトがロードされ、プロジェクト リスト ボックスに表示されます。プロジェクト リスト ボックスからプロジェクトを選択します。
  10. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  11. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: Issue Manager
関連タスク
問題の状態をマップする


Microsoft Team Foundation Server

Silk Central と統合するために Team Foundation Server (TFS) の問題追跡プロファイルを構成する方法について説明します。

Silk Central の統合が現在サポートしているバージョンは次の通りです：Team Foundation Server 2012、2013、2015

  • Team Foundation Server Web サービス プロキシをインストールする
    TFS へのインターフェイスとして Team Foundation Server Web サービス プロキシをインストールします。
  • TFS 問題追跡プロファイルを追加する
    TFS の問題追跡プロファイルを作成して、テスト 領域内のテストを TFS の問題にリンクします。
  • TFS 問題追跡プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の TFS 問題追跡プロファイルを変更します。
親トピック: 問題追跡プロファイル統合


Team Foundation Server Web サービス プロキシをインストールする

TFS と通信するには、TFS へのインターフェイスとして Team Foundation Server Web サービス プロキシをインストールする必要があります。

TFS プロキシ サービスをインストールするには：

  1. http://www.microsoft.com/downloads/details.aspx?FamilyID=fe4f9904-0480-4c9d-a264-02fedd78ab38 から Microsoft Visual Studio Team Explorer をインストールします。
  2. http://www.microsoft.com/web/downloads/default.aspx から Web プラットフォーム インストーラなどを使用して、IIS と Web 配置ツールをインストールします。
  3. Team Foundation Server Web サービス プロキシを ヘルプ > ツール からダウンロードします。
  4. ダウンロードされたパッケージを解凍します。
  5. コマンド シェルを開き、DotNetTfsWebServiceProxy.deploy.cmd /Y と入力して、プロキシ サービスをインストールします。ASP.NET 4 が必要であることを示すエラー メッセージ ボックスが表示された場合は、http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx を参照してください。
  6. IIS マネージャを開きます。
  7. 新しい Web サイトが存在することを確認します。
  8. 仮想ディレクトリのルート フォルダで、Web.config ファイルを開きます。
  9. ファイルの appSettings セクションで、キー WorkItemTrackingCacheRoot の値をローカル ディレクトリに変更します。 例：
    <appSettings>
  <add key="WorkItemTrackingCacheRoot" value="C:\temp" />
</appSettings>
  10. 指定したディレクトリが存在しない場合は、作成します。
  11. 指定したディレクトリで、Everyone にすべての権限を付与します。
ASP.NET Web アプリケーションの配置の詳細については、http://msdn.microsoft.com/en-us/library/ee942158.aspx を参照してください。
注: Silk Central 16.5 以前のバージョンからアップグレードした場合、TFS プロキシ サービスをデプロイしなおす必要があります。 既存の TFS プロキシ サービスを削除し、上記ステップ 3 からの手順に従ってください。作業を終えたら、IIS を再起動します。
親トピック: Microsoft Team Foundation Server


TFS 問題追跡プロファイルを追加する

Silk Central が TFS の問題にアクセスできるようにするには、Micro Focus から提供されている Team Foundation Server Web サービス プロキシを設定する必要があります。
重要: これは Microsoft から提供されている Team Foundation Server プロキシではありません。

TFS 問題追跡プロファイルを追加するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. プロファイルの新規作成 をクリックして、問題追跡プロファイルの新規作成 ダイアログ ボックスを開きます。
  3. 新しいプロファイルの 名前 を入力します。 この名前は、プロファイルを選択することができる一覧上に、表示されます。
  4. 新しいプロファイルの 説明 を入力します。
  5. Team Foundation Server <バージョン> を タイプ リスト ボックスから選択します。
  6. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  7. TFS ユーザーの ドメイン を入力します。
  8. インストールした TFS の URL を入力します たとえば、http://tfsserver:8080/tfs などです。
  9. プロジェクトが属している コレクション を入力します。 たとえば、DefaultCollection などです。 コレクション内のすべてのプロジェクトが、プロジェクト リスト ボックスに表示されます。
  10. リスト ボックスから プロジェクト を選択します。
  11. TFS プロキシの URL を入力します。たとえば、http://tfsproxyserver/DotNetTfsWebServiceProxy_deploy/TfsWebServiceProxy.asmx などです。
  12. 作業項目の種類の読み込み をクリックします。 使用可能な作業項目の種類が、作業項目の種類 リスト ボックスに表示されます。
  13. 作業項目の種類 をリスト ボックスから選択します。
  14. 初期状態の読み込み をクリックします。 初期状態 リスト ボックスには、選択した作業項目タイプで使用可能な状態が表示されます。
  15. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  16. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: Microsoft Team Foundation Server
関連タスク
問題の状態をマップする


TFS 問題追跡プロファイルを編集する

ユーザーの問題追跡システムのサーバーまたはログイン認証情報が変わったとき、変更に応じて問題追跡プロファイルを編集する必要があります。

既存の TFS 問題追跡プロファイルを編集するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. 問題追跡プロファイルの名前をクリックします。 問題追跡プロファイルの編集 ダイアログ ボックスが開きます。
  3. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  4. プロファイルの 説明 を編集します。
  5. 省略可能：問題追跡プロファイルの新しい タイプ をリスト ボックスから選択します。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  7. TFS ユーザーの ドメイン を編集します。
  8. TFS インストールの URL と コレクション を編集します。
  9. 異なる プロジェクト を選択します。
  10. TFS プロキシの URL とポートを編集します。
  11. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
親トピック: Microsoft Team Foundation Server


StarTeam 問題追跡プロファイル

Silk Central と統合するために StarTeam の問題追跡プロファイルを構成する方法について説明します。

ソフトウェア変更管理および構成管理ツールである StarTeam により、ソフトウェア納品プロセスの調整および管理が可能になります。

StarTeam プロファイルを操作し、StarTeam における変更要求に対する移動リンク機能を使用するには、ブラウザを実行するコンピュータに StarTeam クロスプラットフォーム クライアント ソフトウェアをインストールしておく必要があります。

Silk Central の統合が現在サポートしているバージョンは次の通りです： StarTeam 15.x、16.x

  • StarTeam の問題追跡プロファイルを追加する
    StarTeam の問題追跡プロファイルを作成して、テスト 領域内のテストを StarTeam の問題にリンクします。
  • StarTeam の問題追跡プロファイルを編集する
    サーバーまたはログイン認証情報が変更された場合に、既存の StarTeam の問題追跡プロファイルを変更します。
親トピック: 問題追跡プロファイル統合


StarTeam の問題追跡プロファイルを追加する

StarTeam の問題追跡プロファイルを追加するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. プロファイルの新規作成 をクリックして、問題追跡プロファイルの新規作成 ダイアログ ボックスを開きます。
  3. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  4. 新しいプロファイルの 説明 を入力します。
  5. StarTeam を タイプ リスト ボックスから選択します。
  6. ユーザー名 と パスワード に有効なユーザー名とパスワードを入力します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  7. ホスト名 に StarTeam サーバーのホスト名を、ポート にサーバーと接続するために使用するポート番号を入力します。 この設定が変更されていない場合、デフォルト ポート 49201 を使用します。
  8. プロファイルがサポートする 暗号化 のタイプを指定します。
  9. プロジェクトの読み込み をクリックすると、サーバーからすべてのプロジェクトがロードされ、プロジェクト リスト ボックスに表示されます。プロジェクト リスト ボックスからプロジェクトを選択します。
  10. ビューの読み込み をクリックすると、選択したプロジェクトのすべてのビューがロードされ、ビュー リスト ボックスに表示されます。続いて、ビュー リスト ボックスからビューを選択します。
  11. ステータス フィールドの読み込み をクリックすると、変更要求に付随するすべてのフィールドがロードされ、ステータス フィールド リスト ボックスに表示されます。続いて、ステータス フィールド リスト ボックスからステータス フィールドを選択します。 StarTeam でカスタム ワークフローを使用している場合には、このフィールドは StarTeam でワークフロー駆動型フィールドとなり、Silk Central の問題の状態にマッピングされます。
  12. リンク タイプ リスト ボックスからリンクのタイプを選択します。
    starteam://
    問題 タブの 外部 ID リンクがクロス プラットフォーム クライアントを開きます。
    http://
    問題 タブの 外部 ID リンクが StarTeam Web UI の問題を開きます。
  13. http:// (リンク タイプ リスト ボックスにあります) を選択した場合、StarTeam Web UI の Web サーバーのアドレスを Web サーバー フィールドに入力します。
  14. ワークフロー フィールドで Yes または No を選択します。Yes を選択して、選択済みの ビュー のワークフローに指定する必須フィールドを表示します。
  15. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  16. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: StarTeam 問題追跡プロファイル
関連タスク
問題の状態をマップする


StarTeam の問題追跡プロファイルを編集する

ユーザーの問題追跡システムのサーバーまたはログイン認証情報が変わったとき、変更に応じて問題追跡プロファイルを編集する必要があります。

既存の StarTeam の問題追跡プロファイルを編集するには：

  1. メニューで、問題 > 問題追跡インテグレーション をクリックします。 システムに対して作成されている問題追跡プロファイルがすべて一覧で表示される 問題追跡 ページが開きます。
  2. 問題追跡プロファイルの名前をクリックします。 問題追跡プロファイルの編集 ダイアログ ボックスが開きます。
  3. プロファイルの 名前 を編集します。 この名前は、プロファイルを選択することができる一覧上に表示されます。
  4. プロファイルの 説明 を編集します。
  5. 省略可能：問題追跡プロファイルの新しい タイプ をリスト ボックスから選択します。
  6. ユーザー名 と パスワード を編集します。 これらの認証情報は、問題追跡システムへのアクセスに使用されます。
  7. StarTeam サーバーの ホスト名 と、 サーバーと接続するために使用する ポート を編集します。
  8. プロファイルがサポートする 暗号化 のタイプを変更します。
  9. StarTeam プロジェクトを変更するには、プロジェクトの読み込み をクリックします。サーバーからすべてのプロジェクトがロードされ、プロジェクト リスト ボックスに表示されます。プロジェクト リスト ボックスからプロジェクトを選択します。
  10. ビューを変更する場合、ビューの読み込み をクリックすると、選択したプロジェクトのすべてのビューがロードされ、ビュー リスト ボックスに表示されます。続いて、ビュー リスト ボックスからビューを選択します。
  11. ワークフロー駆動型フィールドを変更する場合、ステータス フィールドの読み込み をクリックすると、変更された要求に付随するすべてのフィールドがロードされ、ステータス フィールド リスト ボックスに表示されます。続いて、ステータス フィールド リスト ボックスからステータス フィールドを選択します。 StarTeam でカスタム ワークフローを使用している場合には、このフィールドは StarTeam でワークフロー駆動型フィールドとなり、Silk Central の問題の状態にマッピングされます。
  12. リンク タイプ リスト ボックスからリンクのタイプを選択します。
    starteam://
    問題 タブの 外部 ID リンクがクロス プラットフォーム クライアントを開きます。
    http://
    問題 タブの 外部 ID リンクが StarTeam Web UI の問題を開きます。
  13. http:// (リンク タイプ リスト ボックスにあります) を選択した場合、StarTeam Web UI の Web サーバーのアドレスを Web サーバー フィールドに入力します。
  14. ワークフロー フィールドで Yes または No を選択します。Yes を選択して、選択済みの ビュー のワークフローに指定する必須フィールドを表示します。
  15. OK をクリックします。

    Silk Central は、入力された情報を使用して、外部システムへの接続を試みます。

    注: エラーが発生した場合は、入力した情報を見直すか、管理者に問い合わせてください。
  16. テスト接続に成功すると、確認ダイアログ ボックスが表示され、内部の問題の状態を新しく定義したプロファイルの状態にマップするかどうかを確認する確認ダイアログ ボックスが表示されます。
    • はい をクリックし、関連手順「問題の状態をマップする」を続いて実行します。
    • 後で問題の状態をマップする場合は、いいえ をクリックします。
親トピック: StarTeam 問題追跡プロファイル
関連タスク
問題の状態をマップする


問題追跡プロファイルを削除する

問題追跡プロファイルを削除するには：

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. 問題追跡 タブをクリックします。 問題追跡 ページに、システムで作成されているすべての問題追跡プロファイルが一覧表示されます。
  3. 削除する問題追跡プロファイルの アクション 列で、問題追跡プロファイルを削除... をクリックします。 確認ダイアログ ボックスが表示されます。
  4. はい をクリックします。
親トピック: 問題追跡プロファイル統合


[問題追跡プロファイル] ページ

プロジェクト:<プロジェクト名> > プロジェクト設定 > 問題追跡

このページは、外部の問題追跡システムを Silk Central に統合するためのプロファイル構成に使用します。 プロファイルの新規作成 をクリックして、新しい問題追跡プロファイルを作成します。 問題追跡プロファイルごとに、以下の列がページに表示されます。

列 | 説明
名前 | Silk Central GUI およびレポートに表示されるプロファイルの名前。 名前をクリックしてプロファイルを編集します。
タイプ | 外部の問題追跡システム。
ログイン | Silk Central が接続する問題追跡システムのログイン名。
リポジトリ情報 | 問題追跡システムの物理的ロケーション。 ホスト名または URL。
作成日時 | 問題追跡プロファイルが作成された日時。
作成者 | この問題追跡プロファイルを作成したユーザー。
アクション
問題追跡プロファイルでは、以下のアクションを実行できます。
  • 問題追跡プロファイルの削除
  • 問題追跡プロファイルのマッピングの編集
親トピック: 問題追跡プロファイル統合


ステータスの理由

ステータスの理由が手動テスト実行のステータスを限定する方法について説明します。特定のテスト実行がステータス 合格、失敗、あるいは 未実行 を持つ理由を指定することができます。各ステータスごとに、5 個までの理由を定義することができます。デフォルトでは、理由 未サポート が、ステータス 合格, に追加され、理由 未解決 が、ステータス 失敗 に追加されます。.各ステータスに対してさらに理由を追加することにより、テスト実行のステータスを限定するのに役立ちます。たとえば、ステータスに対して次の理由を定義することがでます。
  • 合格：未サポート
  • 失敗：未解決、システム クラッシュ、バグ、ヘルプが使用できません、クライアント システムが応答しません
  • 未実行：保留中 - 内部、保留中 - 顧客、テスト環境が使用できません
  • ステータスの理由を定義する
    ステータスの理由を定義して、テスト実行のステータスを限定します。
親トピック: プロジェクト設定
関連資料
テストおよびテスト ステップのステータス
テストと実行のアクセス許可


ステータスの理由を定義する

ステータスの理由を追加/更新するには、資産の管理 アクセス許可が、ステータスの理由を削除するには、資産の削除 アクセス許可が必要です。詳細については、テストと実行のアクセス許可 を参照してください。

  1. メニューで プロジェクト:<プロジェクト名> > プロジェクト設定 をクリックします。
  2. ステータスの理由 タブをクリックします。
  3. 新しい理由を追加したいステータスの下にある ステータスの理由の追加 をクリックします。 新しいステータスの理由が理由のリストに追加されます。
  4. 新しいステータスの理由フィールドをクリックして、説明するテキストを入力します。
  5. Enter を押して、ステータスの理由テキストを保存します。
既存のステータスの理由テキストは、ステータスの理由フィールドをクリックして編集することもできます。説明するテキストを入力したら Enter を押して保存します。
親トピック: ステータスの理由


[プロジェクト設定] ページ

プロジェクト:<プロジェクト名> > プロジェクト設定 > プロジェクト設定

プロジェクト設定 ページには、アクティブ プロジェクトの全般的な詳細情報が一覧表示されます。

項目 | 説明
ビルド情報ファイル名 | ビルド情報ファイルには、ビルド番号、ビルド ログの場所、エラー ログの場所、ビルドの場所などのプロジェクト情報が記載されています。 このフィールドには、アクティブ プロジェクトのビルド情報ファイルの名前を入力します。 テスト実行ではすべて、指定されたこのファイルからビルド情報を読み取ります。
プロジェクト リリース日 | アクティブ プロジェクトのリリース予定日（MM/DD/YYYY 形式）。
結果で無視するファイル拡張子 | テスト実行の結果として保存しないファイルのタイプ。
親トピック: プロジェクト設定
関連概念
ビルド情報


プロジェクト テンプレート

このトピックでは、Silk Central でのプロジェクト テンプレートの概念的な背景について説明します。

アジャイル プロジェクト テンプレートは、Silk Central と VersionOne または他のアジャイル プロジェクト管理ツールとのやり取りをサポートするために使用されます。 テンプレートは、特定の属性スプリントやリリースを持ったプロジェクトです。 このテンプレートに基づいて新しいプロジェクトを作成すると、デフォルト テスト コンテナおよびデフォルト フォルダも作成されます。 プロジェクト管理ツールがテストを作成すると、そのテストがこのデフォルト フォルダに追加されていきます。 このテスト コンテナやフォルダに対してソース管理プロファイルや製品は指定されていないため、これらは不完全としてマーク付けされます。

親トピック: プロジェクトを管理する


統合

Silk Central は、さまざまな用途に使用するさまざまなツールと統合されます。

  • コード分析ツール統合
    コード分析ツールとの統合について説明します。
  • 問題追跡プロファイル統合
    Silk Central を外部の問題追跡システムと統合する方法について説明します。
  • 要件管理ツールとの統合
    外部要件管理を統合することによって、Silk Central の要件管理機能と既に使用している他のツールを連携させることができます。
  • ソース管理プロファイル統合
    ソース管理プロファイルの統合について説明します。
  • テスト自動化ツールとの統合
    テスト自動化ツールとの統合について説明します。
  • オートメーション サーバーとの統合
    Silk Central と Jenkins などのオートメーション サーバーと統合すると、テスト実行を CI ビルド システムに統合することができます。
  • SSL による外部システムとの通信
    自己署名証明書を持つホストと SSL 経由で通信するには、デフォルトの Java キーストアに自己署名証明書を追加します。
親トピック: 管理


コード分析ツール統合

  • DevPartner コード カバレッジ統合
    DevPartner Studio のコード分析コンポーネントとの統合について説明します。
親トピック: 統合


DevPartner コード カバレッジ統合

Silk Central は、DevPartner Studio の コード分析 コンポーネントと統合されます。この統合を利用して、.NET アプリケーションのコード分析を実行できます。

詳細については、「.NET コード分析」を参照してください。

親トピック: コード分析ツール統合
関連概念
.NET コード分析


ソース管理プロファイル統合

  • AccuRev
    AccuRev ソース管理プロファイルを構成する方法について説明します。
  • Apache Commons 仮想ファイルシステム
    仮想ファイル システムのソース管理プロファイルを構成する方法について説明します。
  • Git
    Git ソース管理プロファイルを構成する方法について説明します。
  • Microsoft Team Foundation Server
    Team Foundation Server ソース管理プロファイルを構成する方法について説明します。
  • Silk Test Workbench
    Silk Test Workbench ソース管理プロファイルを構成する方法について説明します。
  • StarTeam
    StarTeam ソース管理プロファイルを構成する方法について説明します。
  • Subversion
    Subversion ソース管理プロファイルを設定する方法について説明します。
  • Silk TestPartner
    TestPartner ソース管理プロファイルを構成する方法について説明します。
  • Universal Naming Convention
    Universal Naming Convention ソース管理プロファイルを構成する方法について説明します。
親トピック: 統合


テスト自動化ツールとの統合

  • Unified Functional Testing（UFT）テスト
    以前は HP QuickTest Professional（QTP）として知られていた Unified Functional Testing（UFT）ソフトウェアは、ソフトウェア アプリケーションに対する機能テストと回帰テストの自動化と環境を提供します。
  • JUnit テスト
    JUnit は、Java プログラム言語用の単体テスト フレームワークです。JUnit、Silk4J、Selenium テストに、このテストタイプを使用します。
  • MSTest テスト
    MSTest は、Visual Studio で作成した単体テストを実行するための、Microsoft のコマンド ライン ツールです。MSTest、Silk4NET テストに、このテストタイプを使用します。
  • NUnit テスト
    NUnit は、Microsoft .NET プログラム言語用の単体テスト フレームワークです。
  • ProcessExecutor テスト
    ProcessExecutor テスト タイプは、任意のコマンド ラインを実行するために使用できます。
  • Silk Performer .NET Explorer テスト
    Silk Performer .NET Explorer テスト タイプは、.NET Explorer スクリプトやスクリプトの特定のテスト ケースを実行するために使用します。
  • Silk Performer テスト
    Silk Performer プロジェクトは、Silk Central のテストに統合し、Silk Central を通じて直接実行することができます。これにより、強力なテスト結果分析とレポート作成が可能になります。また、無人テスト（あらかじめ構成されたスケジュールに基づいて Silk Central で自動的に実行されるテスト）も可能です。
  • Silk Test Classic テスト
    Silk Central の Silk Test Classic インターフェイスは、ユーザーに Silk Test Classic を自動化する信頼性の高い手段を提供します。Silk Test Classic スクリプトの各テストケースは、それぞれのテスト実行の中で実行され、それぞれに結果を作成します。
  • Silk Test Workbench テスト
    Silk Test Workbench は、複雑なアプリケーションの機能テストを推進するための自動テスト ツールです。Silk Test Workbench は、Java、.NET、ブラウザベースの Web アプリケーション、COM コンポーネント（ActiveX コントロールと自動オブジェクトの両方を含む）などのさまざまな開発ツールを使って開発されたアプリケーションのテストをサポートします。
  • Silk TestPartner テスト
    TestPartner は、Microsoft 技術を使用する Web ベースおよび Microsoft Windows ベースのアプリケーションをテストする Micro Focus の製品です。
  • Windows Script Host テスト
    Windows Script Host を使用してスクリプトをホストするための環境を作成する方法について説明します。
親トピック: 統合


オートメーション サーバーとの統合

Silk Central Web サービスを使用して、テスト実行を CI ビルド システムに統合することができます。オートメーション サーバーとして Jenkins を使用している場合、Jenkins プラグイン ページから Silk Central 統合プラグインを直接ダウンロードできます。

親トピック: 統合
関連概念
Silk Central の Web サービス
関連タスク
コマンド ラインからのキーワード ライブラリの更新


API ヘルプ

API ヘルプでは、サードパーティ ツールを Silk Central に統合するプラグインを、作成/運用していくために必要となる情報を提供していきます。 主に、Web サービスの仕様、API の説明、そしてプラグインを Silk Central に統合する方法についての説明などが含まれます。

  • はじめに
    このヘルプでは、サードパーティ アプリケーションと Silk Central とを統合するために実装された API の概要を提供します。
  • プラグインを作成する
    すべてのタイプのプラグインの作成に共通するタスクについて説明します。
  • コード カバレッジとの統合
    コード カバレッジとの統合に必要な API について説明します。
  • ソース管理との統合
    Silk Central に対して、カスタム ソース管理プラグインを構成する方法について説明します。
  • 問題追跡システムとの統合
    このセクションでは、サードパーティ製 (外部) 問題追跡システムの統合を可能にするプラグインの作成方法について説明します。
  • 要件管理システムとの統合
    Silk Central の要件管理機能を、サードパーティの要件管理システムへ統合する方法について説明します。
  • サードパーティ テスト タイプとの統合
    このセクションでは、最初から利用可能なテスト タイプの標準セット以外のテスト タイプ（Silk Performer、Silk Test Classic、マニュアル テスト、NUnit、JUnit、Windows Scripting（WSH）など）のためのカスタム プラグインを作成する方法について説明します。
  • クラウド統合
    パブリックまたはプライベートなクラウド サービスのプロバイダと Silk Central を統合する方法を説明します。
  • Silk Central の Web サービス
    利用可能なWeb サービス インターフェイスについて説明します。


はじめに

本書では、サードパーティ ツールを Silk Central に統合するプラグインを、作成および運用していくために必要となる情報を提供していきます。 主に、Web サービスの仕様、API の説明、そしてプラグインを Silk Central に統合する方法についての説明などが含まれます。

注: 本書では、読者が Web サービスの実装と利用に精通していると想定しています。

概要

Silk Central では、サードパーティ アプリケーションとの統合のための API を提供しています。 Silk Central の API を使うことにより、既存のソース管理、問題追跡、要件管理などの各ツールを、Silk Central プラグインを設定することで統合できます。 Silk Central には、数多くのサンプル プラグインが同梱されています。

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

Silk Central 統合プラグイン

Silk Central プラグインは、「そのまま」提供されているものであり、すべての不具合も含み、なんら保証されるものではありません。 Micro Focus は、市販性、特定目的との適合性、ウィルスがないこと、正確性または完全性、権限、平穏享有権、平穏所有権、権利侵害のないことなどを含む (ただし必ずしもこれらに限定されない) あらゆるものに関して、明示的、黙示的、または平和的にかかわらず、すべての保証および条件を、放棄します。

プラグインのご利用は、ご自身の責任において行ってください。 Micro Focus は、プラグインを使用することによって生じる利益損失を含む (ただし必ずしもこれらに限定されない)、直接的、間接的、および特別のあらゆる種の偶発的または付随的な損害に対して、責任を負いません。

親トピック: API ヘルプ


プラグインを作成する

概要

このセクションでは、Silk Central に対してプラグインを作成する方法について説明します。 すべてのタイプのプラグインに共通するタスクについてのみ、ここでは説明します。

プラグインの種

Silk Central は、複数のプラグイン API を提供しています。 各 API は、種 (species) として捉えられます。

コンパイル

プラグインの開発やコンパイルにおいて、適切な Java バージョンについては、Silk Central のリリースノートを参照してください。 このことは、Silk Central の Java ランタイム環境と互換性を確保するために重要となります。

デプロイメント

プラグイン クラスを作成し、API の種を実装したら、プラグイン パッケージ (jar や zip) を作成することができます。

  • 作成するプラグインが他に依存していない場合 (もしくは、既に Silk Central 内にあるライブラリとのみ依存関係がある場合) は、単に、作成したクラスが含まれた JAR ファイルを作成します。
  • 作成したプラグインが追加ライブラリに依存する場合、それらのライブラリを、サブディレクトリ lib に置き、すべてのライブラリを 1 つの ZIP アーカイブにパッケージします。

作成したファイルを、<application server installation directory>\plugins\ にあるプラグイン ディレクトリに置きます。

注: 新しくデプロイしたプラグインを Silk Central で利用可能にするには、アプリケーション サーバーとフロントエンド サーバーを再起動する必要があります。 サーバーの再起動の詳細については、この『ヘルプ』の「管理」トピックを参照してください。

配信

プラグインの種のタイプが Silk Central によって認識されているのと同様、どのサーバー (実行サーバー、アプリケーション サーバー、およびフロントエンド サーバー) でどの種が必要であるかも認識されています。 各プラグインはアプリケーション サーバーにインストールすることができます。そして、 Silk Central が各サーバーへ適切なプラグインを自動配信します。

親トピック: API ヘルプ
関連概念
ソース管理との統合
問題追跡システムとの統合
要件管理システムとの統合
サードパーティ テスト タイプとの統合
コード カバレッジとの統合
クラウド統合


コード カバレッジとの統合

このセクションで説明する Java API インターフェイスは、サードパーティ製 (外部) コード カバレッジ ツールの統合を実現する、Silk Central 用プラグインを作成する場合に必要となります。

コード カバレッジ ツールを使用すると、テストでどのようなコードがカバーされるかについての情報を取得できます。 Silk Central には、次のコード カバレッジ ツールがあらかじめ組み込まれています。
  • Silk Central Java コード分析 (Java コード分析エージェント)
  • DevPartner Studio.NET コード分析 (Windows コード分析フレームワーク)
注: テスト対象アプリケーションが Linux 上で動作する場合は、トピック「Linux AUT 環境にコード分析フレームワークをインストールする」を参照してください。

前出の 2 つのツールで十分でない場合は、独自のコード カバレッジとの統合を作成してデプロイできます。 独自のコード カバレッジ プラグインを作成するを参照してください。

注: アプリケーション サーバーにカスタム アプリケーションをデプロイする (「プラグインの作成」トピックを参照) 以外に、コード分析フレームワーク サーバーにもカスタム アプリケーションをデプロイする必要があります。 コード分析フレームワーク サーバーには、AUT およびコード カバレッジ ツールが配置されます。 パスは次のようになります：\Silk\Silk Central <version>\Plugins
  • 独自のコード カバレッジ プラグインを作成する
    コード カバレッジ プラグインを作成する方法について説明します。
  • Linux AUT 環境にコード分析フレームワークをインストールする
    Linux AUT 環境にコード分析フレームワークをインストールする方法について説明します。
親トピック: API ヘルプ
関連概念
プラグインを作成する
ソース管理との統合
問題追跡システムとの統合
要件管理システムとの統合
サードパーティ テスト タイプとの統合
デプロイメント


独自のコード カバレッジ プラグインを作成する

このトピックでは、コード カバレッジ プラグインを作成する方法について説明します。Silk Central のベースラインの概念をよく理解している必要があります。Silk Central では、各実行の前にベースラインが必要です。ベースラインには、テスト アプリケーションのすべての名前空間/パッケージ/クラス/メソッドが含まれています。

注: コード カバレッジを実行したら、Silk Central API には XML ファイルを返す必要があります。したがって、コード カバレッジ情報をデータベースに格納するコード カバレッジ ツールの場合は、データを取り出す追加手順を実行する必要があります。
注: 同じコード分析フレームワークに対して複数のテストを同時実行する、複数実行サーバーはサポートされていません。
  1. ライブラリ scc.jar には拡張が必要なインターフェイス群が含まれているため、このライブラリをクラスパスに追加します。この JAR ファイルは、Silk Central のインストール ディレクトリ以下の lib ディレクトリ内にあります。
  2. 次の 2 つのインポート文を追加します。
    import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfile;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfileException;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisResult;
  3. CodeAnalysisProfile を実装するクラスを作成します。
  4. 以降の手順で記述されているコード カバレッジ インターフェイスから、必要なメソッドをすべて追加します。「サンプル インターフェイス クラス」を参照して定義を確認し、メソッドを手作業で実装するか、または、インポートおよびメソッドが定義されているトピック「サンプル プロファイル クラス」からコピーして貼り付けます。
    注: 以降の手順でコーディングするメソッドは、実際には、必要に応じて Silk Central によって呼び出されます。つまり、ユーザーはこれらのメソッドを直接呼び出しません。
  5. getBaseline をコーディングします。このメソッドは、アプリケーションの名前空間/パッケージ/クラス/メソッドをすべて含む XML ファイルを返す必要があります。ファイルの形式については、「サンプル XML データ」トピック ファイルを参照してください。XML は、サンプル XSD ファイルを使用して検証する必要があります。XSD については、「コード カバレッジ XSD」トピックを参照してください。

    この関数は、カバレッジを開始する前に呼び出されます。テスト実行を開始する Silk Central 実行サーバーによってトリガされるとコード分析が開始され、カバーされるすべてのオブジェクトが返されます。この出力は、CA-Framework インストール フォルダに格納されている XML スキーマで指定された形式を使用して、XML に変換する必要があります。

  6. startCoverage をコーディングします。このメソッドを呼び出すことで、コード カバレッジ ツールにデータの収集開始を指示します。開始すると true が返されます。

    これは、getBaseLine() メソッドが完了した後、Silk Central コード カバレッジ フレームワークによって呼び出されます。コード カバレッジ ツールは、ここでコード カバレッジ データの収集を開始する必要があります。

  7. stopCoverage をコーディングします。このメソッドを呼び出すことで、コード カバレッジ ツールにデータの収集停止を指示します。成功すると true が返されます。

    これは、startCoverage の後に呼び出され、コード分析を停止するために、テスト実行を完了した Silk Central 実行サーバーによってトリガーされます。

  8. getCoverage をコーディングします。このメソッドは、startCoverage メソッドと stopCoverage メソッドの間に収集されたデータを含む XML ファイルを返します。ファイルの形式については、「サンプル XML データ」トピックを参照してください。XML は、サンプル XSD ファイルを使用して検証する必要があります。XSD については、「コード カバレッジ XSD」トピックを参照してください。

    この関数は sstopCoverage() の後に呼び出され、収集されたすべてのカバレッジ データを返します。この出力は、XML スキーマで指定された形式を使用して、XML に変換する必要があります。

  9. GetName をコーディングします。このメソッドによって、コード カバレッジ ツールの参照に使用される名前が提供されます。たとえば、この値は コード分析設定の編集 ダイアログ ボックスの、コード分析プロファイル リスト内の値の 1 つとして使用されます。

    このメソッドは、最初は Silk Central コード カバレッジ フレームワークによって呼び出されます。プラグインの名前は、Silk Central のコード カバレッジ リストに表示されます。

  10. プラグインをビルドして jar ファイルを作成し、その jar ファイルを zip ファイルに格納します。
  11. 次のロケーションにプラグインをデプロイします。
    • Silk Central インストール フォルダの Plugins ディレクトリ
    • CA-Framework インストール フォルダの Plugins ディレクトリ
  • サンプル プロファイル クラス
    サンプル プロファイル クラスについて説明します。
  • コード カバレッジ XSD
    コード カバレッジ XSD ファイルについて説明します。
  • サンプル XML データ
    コード カバレッジ統合 API 用のサンプル XML データについて説明します。
親トピック: コード カバレッジとの統合


サンプル プロファイル クラス

次のサンプル ファイルは、コード カバレッジ プラグインに必要なすべてのメソッド、インポート、および実装の概要を示しています。

//Add the library scc.jar to your classpath as it contains the interfaces that
//must be extended. The JAR file can be found in the lib directory of the Test
//Manager installation directory.
//
//make sure to include these imports after adding the scc.jar external reference
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfile;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfileException;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisResult;

public class myProfileClass implements CodeAnalysisProfile{

  // This function is called first by the Silk Central Code Coverage framework
  // The name of the plug-in is displayed in the code coverage drop down in Silk Central
  @Override
  public String getName() {
    // The name of the plugin cannot be an empty string
    return "my plugin name";
  }

  // This function is called before starting coverage,
  // this should return all of the objects to be covered and needs to be
  // converted into xml using the format specified in the XML schema
  // CodeCoverage.xsd included in the CA-Framework installation folder.
  // This is triggered by the Silk Central Execution Server starting a test run
  // to start code analysis.
  @Override
  public CodeAnalysisResult getBaseline() throws CodeAnalysisProfileException {
    CodeAnalysisResult result = new CodeAnalysisResult();
    try{
      String baselineData = MyCodeCoverageTool.getAllCoveredObjectsData();
      String xmlString = xmltransformXML(baselineData);
      result.Xml(xmlString);
      String myCustomLogMessage = "Code Coverage baseline successfully retrieved.";
      result.AddLogMsg(myCustomLogMessage);
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
    return result;
  }

  //This function is called by the Silk Central Code Coverage Framework after the getBaseLine() method is complete
  //this is where you should start my code coverage tool
  //collecting code coverage data

  @Override
  public boolean startCoverage() throws CodeAnalysisProfileException {
    try{
      MyCodeCoverageTool.StartCollectingCoverageData();
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
  }
  //This function is called after startCoverage,
  //This is triggered by the Silk Central Execution Server finishing a test run
  //to stop code analysis
  //Call to my code coverage tool to stop collecting data here.
  @Override
  public boolean stopCoverage() throws CodeAnalysisProfileException {
    try{
      MyCodeCoverageTool.StopCollectingCoverageData();
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
  }
  // This function is called after stopCoverage(),
  // and should return all the coverage data collected and needs to be
  // converted into xml using the format specified in the XML schema
  // CCoverage.xsd included in the CA-Framework installation folder

  @Override
  public CodeAnalysisResult getCoverage() throws CodeAnalysisProfileException {
    CodeAnalysisResult result = new CodeAnalysisResult();
    try{
      String coverageData = MyCodeCoverageTool.getActualCoverageData();
      String xmlString = xmltransformXML(coverageData);
      result.Xml(xmlString);
      String myCustomLogMessage = "Code Coverage successfully retrieved.";
      result.AddLogMsg(myCustomLogMessage);
    }catch(Exception e){
     throw new CodeAnalysisProfileException(e);
    }

    return result;
  }

  private String transformXML(String myData){
    //code to transform from my data to the Silk CentralM needed xml
    ...
    return xmlString;
  }

}
親トピック: 独自のコード カバレッジ プラグインを作成する


コード カバレッジ XSD

次に、コード カバレッジ ツールによって生成された XML の検証に使用するコード カバレッジ XSD を示します。 このドキュメントがある場所は、<CA Framework installation>\CodeAnalysis\CodeCoverage.xsd です。

<xs:schema id="data" xmlns="" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:element name="coverage">
    <xs:complexType>
      <!--type will be method when defined as a child to class or line when defined as a child to method-->
      <xs:attribute name="type" type="xs:string" />
      <!--hits for the definition file will be 0, the update file will define the hits count-->
      <xs:attribute name="hits" type="xs:string" />
      <!--the total count will be sent with both the definition and update file, both counts will match-->
      <xs:attribute name="total" type="xs:string" />
      <!--this will be an empty string for the definition file, the line numbers will be sent in the update file delimited by a colon-->
      <xs:attribute name="lines" type="xs:string" />
    </xs:complexType>
  </xs:element>
  <xs:element name="data">
    <xs:complexType>
      <xs:choice minOccurs="0" maxOccurs="unbounded">
        <xs:element ref="coverage" />
        <xs:element name="class">
          <xs:complexType>
            <xs:sequence>
              <xs:element name="sourcefile" minOccurs="0" maxOccurs="unbounded">
                <xs:complexType>
                  <!--full path to the code file-->
                  <xs:attribute name="name" type="xs:string" />
                </xs:complexType>
              </xs:element>
              <xs:element ref="coverage" minOccurs="0" maxOccurs="unbounded" />
              <xs:element name="method" minOccurs="0" maxOccurs="unbounded">
                <xs:complexType>
                  <xs:sequence>
                    <xs:element ref="coverage" minOccurs="0" maxOccurs="unbounded" />
                  </xs:sequence>
                  <!--
                      <field_signature> ::= <field_type>
                      <field_type>      ::= <base_type>|<object_type>|<array_type>
                      <base_type>       ::= B|C|D|F|I|J|S|Z
                      <object_type>     ::= L<fullclassname>;
                      <array_type>      ::= [<field_type>

                      The meaning of the base types is as follows:
                      B byte signed byte
                      C char character
                      D double double precision IEEE float
                      F float single precision IEEE float
                      I int integer
                      J long long integer
                      L<fullclassname>; ... an object of the given class
                      S short signed short
                      Z boolean true or false
                      [<field sig> ... array

                      example signature for a java method 'doctypeDecl' with 3 string params and a return type void

                          doctypeDecl : (Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;)V

                      refer to org.apache.bcel.classfile.Utility for more information on signatureToString
                  -->
                  <xs:attribute name="name" type="xs:string" />
                  <!--method invokation count, this will be 0 for the definition file-->
                  <xs:attribute name="inv" type="xs:string" />
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="name" type="xs:string" />
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:complexType>
  </xs:element>
</xs:schema>
親トピック: 独自のコード カバレッジ プラグインを作成する


サンプル XML データ

コード カバレッジ API では、次の形式の XML を想定しています。

XML の検証に提供されているサンプル XSD ドキュメントも使用できます。

<!--  Generated by 'MyPluginTool'at '2010-11-05T16:11:09'
 -->
<data>
  <class name="ProjectA.ClassA1">
    <sourcefile name="C:\Users\TestApp\ProjectA\ClassA1.cs"/>
    <coverage hits="8" total="8" type="method"/>
    <coverage hits="30" total="30" type="line"/>
    <method inv="2" name="ClassA1  : ()V">
      <coverage hits="3" lines="11:2,12:2,14:2" total="3" type="line"/>
    </method>
    <method inv="2" name="BoolByteMethod  : (LSystem/Boolean;LSystem/SByte;)V">
      <coverage hits="3" lines="17:2,18:2,19:2" total="3" type="line"/>
    </method>
    <method inv="1" name="CharStringMethod  : (LSystem/Char;LSystem/String;)V">
      <coverage hits="3" lines="38:1,39:1,40:1" total="3" type="line"/>
    </method>
    <method inv="2" name="DateMethod  : (LSystem/DateTime;)V">
      <coverage hits="3" lines="22:2,23:2,24:2" total="3" type="line"/>
    </method>
    <method inv="1" name="DecimalMethod  : (LSystem/Decimal;LSystem/Single;LSystem/Double;)V">
      <coverage hits="4" lines="27:1,28:1,29:1,30:1" total="4" type="line"/>
    </method>
    <method inv="1" name="IntMethod  : (LSystem/Int32;LSystem/Int64;LSystem/Int16;)V">
      <coverage hits="3" lines="33:1,34:1,35:1" total="3" type="line"/>
    </method>
    <method inv="1" name="passMeArrays  : (LSystem/Int32[];LSystem/Decimal[];)V">
      <coverage hits="6" lines="51:1,52:1,53:1,55:1,56:1,58:1" total="6" type="line"/>
    </method>
    <method inv="1" name="passMeObjects  : (LSystem/Object;LSystem/Object/ClassA1;)V">
      <coverage hits="5" lines="43:1,44:1,45:1,46:1,48:1" total="5" type="line"/>
    </method>
  </class>
  <class name="TestApp.Form1">
    <sourcefile name="C:\Users\TestApp\Form1.Designer.cs"/>
    <coverage hits="2" total="10" type="method"/>
    <coverage hits="24" total="110" type="line"/>
    <method inv="1" name="btnClassA_Click  : (LSystem/Object;LSystem/Object/EventArgs;)V">
      <coverage hits="3" lines="25:1,26:1,27:1" total="3" type="line"/>
    </method>
    <method inv="1" name="CallAllClassAMethods  : ()V">
      <coverage hits="21" lines="35:1,36:1,37:1,38:1,39:1,40:1,41:1,42:1,43:1,44:1,45:1,46:1,48:1,49:1,50:1,51:1,52:1,53:1,54:1,55:1,56:1" total="21" type="line"/>
    </method>
  </class>
</data>
親トピック: 独自のコード カバレッジ プラグインを作成する


Linux AUT 環境にコード分析フレームワークをインストールする

作成するコード カバレッジ プラグインが、Linux オペレーティング システム上の .NET テスト対象アプリケーションと情報をやり取りする場合は、次の手順を実行する必要があります。

  1. Linux 用のコード分析フレームワークは、ヘルプ > ツール > Linux コード分析フレームワーク から入手できます。これをダウンロードして、Linux マシン上のルート フォルダまたは他の任意のフォルダにコピーします。
  2. テスト対象アプリケーションのあるマシンに Java Runtime Environment (JRE) 8 がインストールされていることを確認します。
  3. CA-Framework.tar.gz を抽出します。
  4. コード分析プラグインを、<install dir>/Silk Central 18.5/Plugins フォルダに配置します。
  5. ディレクトリを、<install dir>/Silk Central 18.5/Code Analysis に変更します。
  6. CA-Framework プロセスを実行する startCodeAnalysisFramework.sh シェル スクリプトを見つけます。
  7. 次のコマンドを実行して、ファイルを UNIX 形式に変換します：dos2unix startCodeAnalysisFramework.sh
  8. 次のコマンドを実行して、シェル スクリプトの実行に必要なアクセス許可を設定します：chmod 775 startCodeAnalysisFramework.sh
  9. 次のシェル スクリプトを実行して、CAFramework プロセスを実行します：./startCodeAnalysisFramework.sh。
これで、Silk Central からコード分析フレームワークを使用できるようになります。
親トピック: コード カバレッジとの統合


ソース管理との統合

ソース管理プロファイルにより、Silk Central を外部のソース管理システムと統合できます。

カスタム ソース管理プラグインは、一度デプロイされると、 上で構成できるようになります。これにより、Silk Central 実行サーバーが、テストを実行するためにどこからプログラム ソースを取得するかを定義することができます。

C:\Program Files (x86)\\Silk\instance_<インスタンス番号>_<インスタンス名>\Plugins\subversion.zip にある com.segue.scc.vcs.subversion パッケージのソース コードを参照して、実際の実装方法の参考にしてください。

  • ソース管理との統合のインターフェイス
    ソース管理インテグレーションで使用されるインターフェイスの一覧を提供します。
  • ソース管理との統合の慣習
    各実装でデフォルト コンストラクタを提供する必要があること、および、各インターフェイス メソッドで SourceControlException を指定する必要があることについて説明します。
親トピック: API ヘルプ
関連概念
プラグインを作成する
問題追跡システムとの統合
要件管理システムとの統合
サードパーティ テスト タイプとの統合
コード カバレッジとの統合


ソース管理との統合のインターフェイス

Silk Central では SourceControlProfile と VersionControlProfile が区別されます。 SourceControlProfile はバージョン付けがなく、VersionControlProfile はバージョン付けがある点が異なります。

次は、ソース管理インテグレーションで使用される Silk Central インターフェイスです：
  • SourceControlProfile
  • VersionControlProfile
  • SourceControlProfileData
  • SourceControlException
  • SourceControlInfo

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

親トピック: ソース管理との統合


ソース管理との統合の慣習

各実装は、デフォルト コンストラクタと、SourceControlProfileData をパラメータに持つコンストラクタを提供する必要があります。パラメータ付きのコンストラクタは任意です。 このコンストラクタを提供しない場合には、代わりに SourceControlProfileData のための Bean 設定メソッドを用意する必要があります。

各インターフェイス メソッドでは、例外として SourceControlException が指定されているため、インターフェイスで使用されているメソッドでは、いずれも RuntimeException を送出することは許されていません。

親トピック: ソース管理との統合


問題追跡システムとの統合

本セクションで言及されるインターフェイスは、サードパーティ製 (外部) 問題追跡システム (ITS：Issue Tracking System) の統合を実現する、Silk Central 用プラグインを作成する際に必要となります。

問題追跡プロファイルを定義することにより、テスト領域内のテストを、サードパーティの問題追跡システム内にある問題へ、リンク付けすることができます。リンク付けされた問題の状態は、サードパーティの問題追跡システムから定期的に更新されます。

C:\Program Files (x86)\Silk\Silk Central18.5\instance_<インスタンス番号>_<インスタンス名>\Plugins\Bugzilla3.zip にある com.segue.scc.issuetracking.bugzilla3 パッケージのソース コードを参照して、実際の実装方法の参考にしてください。

  • Java インターフェイス
    Java API を使用して問題追跡システムとの統合を実装する方法について説明します。
親トピック: API ヘルプ
関連概念
プラグインを作成する
ソース管理との統合
要件管理システムとの統合
サードパーティ テスト タイプとの統合
コード カバレッジとの統合
問題追跡プロファイル統合


Java インターフェイス

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

ビルド環境

ライブラリ scc.jar に拡張する必要のあるインターフェイス群が含まれているため、このライブラリをクラスパスに追加します。この JAR ファイルは、Silk Central のインストール ディレクトリ以下の lib ディレクトリ内にあります。

2 つの インターフェイス/クラスを拡張する必要があります：
  • com.segue.scc.published.api.issuetracking82.IssueTrackingProfile
  • com.segue.scc.published.api.issuetracking.Issue

クラス/インターフェイス

  • IssueTrackingProfile
  • IssueTrackingData
  • Issue
  • IssueTrackingField
  • IssueTrackingProfileException
親トピック: 問題追跡システムとの統合


要件管理システムとの統合

Silk Central は、サードパーティの要件管理システム (RMS) ツールと統合し、要件間のリンク付けや同期化を行うことができます。

このセクションでは、Silk Central 上の要件を、サードパーティの要件管理システム上の要件と同期化するための、サードパーティ製プラグインの実装に使用する、Java アプリケーション プログラミング インターフェイスについて説明します。 このセクションでは、要件プラグインとそのデプロイメントを識別するインターフェイスについて説明します。

JAR または ZIP ファイルは、Silk Central の標準プラグインの概念に適合する形で提供されます。つまり、すべてのフロントエンド サーバーに対して自動的にデプロイされ、設定や同期化のためのサードパーティ ツールにアクセスできるようになります。 このプラグインは特定のインターフェイスを実装しており、これにより Silk Central は、そのプラグインが要件プラグインであると識別でき、サードパーティ ツールへログインするために必要な、ログイン プロパティを提供します。

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

追加プラグインの詳細については、カスタマー サポートにお問い合わせください。

  • Java インターフェイス
    要件プラグイン API のインターフェイスの一覧を提供します。
親トピック: API ヘルプ
関連概念
プラグインを作成する
ソース管理との統合
問題追跡システムとの統合
サードパーティ テスト タイプとの統合
コード カバレッジとの統合
デプロイメント


Java インターフェイス

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

最初に取り扱う基本インターフェイスは RMPluginProfile（com.segue.tm.published.api.requirements.javaplugin）です。 RMPluginProfile で、このプラグインが要件プラグインとして指定されています。

要件 Java プラグイン API には、次の追加インターフェイスが含まれます。
  • RMAction
  • RMAttachment
  • RMDataProvider
  • 省略可能：RMIconProvider
  • RMNode
  • RMNodeType
  • RMPluginProfile
  • RMProject
  • RMTest
  • RMTestParameter
  • 省略可能：RMTestProvider
  • RMTestStep
親トピック: 要件管理システムとの統合
関連概念
デプロイメント


サードパーティ テスト タイプとの統合

Silk Central では、最初から利用可能なテスト タイプの標準セット以外のテスト タイプ --- Silk Performer、Silk Test Classic、手動テスト、NUnit、JUnit、Windows Scripting Host（WSH）など --- のためのカスタム プラグインを作成することができます。 新しいテスト タイプ プラグインを作成すると、そのカスタム テスト タイプが、Silk Central における新しいテストの作成に使用できる標準テスト タイプと一緒に、テストの新規作成 ダイアログ ボックスの タイプ リスト ボックスから利用できるようになります。

プラグインは、テストを定義したり、テスト実行を実装したりするために必須のプロパティを指定します。 プロパティに関するメタ情報は、「XML ファイルの設定」によって定義されます。

このプラグイン アプローチの目的は、共通テスト フレームワーク（JUnit、NUnit、スクリプト言語（WSH）など）をベースとするテストをサポートし、ユーザー固有のテスト環境に合わせた容易な Silk Central のカスタマイゼーションを可能にすることです。 Silk Central の洗練されたパブリック API により、ユーザー固有の自動化テストのニーズに見合ったソリューションを実装することができます。 Silk Central は、オープンであり、Java 実装またはコマンドライン呼び出しから呼び出すことのできるサードパーティ ツールに対して拡張することができます。

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

Javadoc に記述されたクラスは、tm-testlaunchapi.jar ファイルに含まれています。

追加プラグインの詳細については、カスタマー サポートにお問い合わせください。

このセクションには、process executor テスト タイプを実装するコード サンプルが含まれています。 process executor は、あらゆる実行可能ファイルの起動に使用することができ、処理テスト ランチャ クラスを拡張します。 その他の情報については、ヘルプ > ツール から テスト起動プラグイン サンプル をダウンロードし、Readme.txt をお読みください。

  • プラグイン実装
    API の原則と、そのコールバック インターフェイスについて説明します。
  • API の構造
    API for サードパーティ テスト タイプ統合のための API の構造について説明します。
  • サンプル コード
    あらゆる実行可能ファイルの起動に使用することができる process executor テストタイプを実装するサンプル コードを紹介します。これは、公開 ExtProcessTestLaunchBean クラスを拡張します。
  • 設定 XML ファイル
    サードパーティ テスト タイプ プラグインについてのメタ情報が含まれている、設定 XML ファイルについて説明します。
  • カスタム アイコン
    カスタム テスト タイプに対してカスタム アイコンをデザインし、作成したテスト タイプが識別しやすいものにする方法について説明します。
  • デプロイメント
    サードパーティ テスト タイプ プラグインのデプロイ方法について説明します。
  • ビデオ キャプチャの開始と終了を示す
    サード パーティ テストの特定のテスト ケースのキャプチャを、Silk Central に定義する方法について説明します。
親トピック: API ヘルプ
関連概念
プラグインを作成する
ソース管理との統合
問題追跡システムとの統合
要件管理システムとの統合
コード カバレッジとの統合


プラグイン実装

この API の原則は、よく知られている Java Beans の概念を元にしています。 これにより、開発者が容易にテスト起動プラグインを実装できるようになっています。 テキスト形式の情報を Java コードに入れなくてもすむように、プロパティに関するメタ情報は、XML ファイル内で定義することができます。

プラグインの実装では、統合されるためのコールバック インターフェイスを実装し、ZIP アーカイブ内にパッケージングします。 他のインターフェイスは、代わりにプラグイン フレームワークで提供されており、プラグイン実装は情報にアクセスしたり、結果を取得したりすることができます。

  • パッケージング
    プラグインのパッケージ方法について説明します。
  • プラグインへパラメータを渡す
    どのパラメータ タイプにプラグインがアクセスできるのか、またそのプラグインへパラメータを渡す方法について説明します。
親トピック: サードパーティ テスト タイプとの統合


パッケージング

プラグインは、Java コードベースと XML 設定ファイルを持つ ZIP アーカイブにパッケージングします。 このアーカイブには、テスト起動プラグイン実装も一部含まれます。 このコードベースは、Java アーカイブ ファイル（.jar）に収めるか、Java のパッケージ構造をそのまま表すフォルダ階層内のクラス ファイル（.class）に直接入れます。

TestLaunchBean プラグイン クラスは、Bean の標準どおり、TestLaunchBean インターフェイスを実装しています。 .zip アーカイブ内の XML 設定ファイルには、このクラスと同じ名前を付けます。 これにより、複数のプラグインと XML ファイルを、1つのアーカイブ内にパッケージングすることができます。

親トピック: プラグイン実装


プラグインへパラメータを渡す

ExtProcessTestLaunchBean クラスに基づいたプラグインの場合、プラグインによって開始されたプロセスにおいて、各パラメータは環境変数として自動的に設定されます。 これはパラメータ名がシステム変数の名前と一致する場合にもあてはまるため、パラメータの値が空の文字列である場合の除き、システム変数の値はパラメータの値によって置き換えられます。

プラグイン インターフェイスは、Silk Central テスト 領域で定義されている、すべてのカスタム パラメータへのフルアクセスを提供します。 カスタム パラメータは、サードパーティのテスト タイプに対してのみサポートされています。 プラグインは、事前定義パラメータを指定することができないので、特定のテストに対して、パラメータが定義されているか、どのように定義されるかは、プラグイン実装によって決まります。

TestLaunchPluginContext インターフェイスにある getParameterValueStrings() メソッドを使用して、パラメータ名（キー）からそれに対応する値（String で表されます）へのマッピングを保持するコンテナを取得します。

JUnit テスト タイプでは、任意の JUnit テスト クラスから、Java のシステム プロパティとして、元のテストのカスタム パラメータにアクセスすることができます。ランチャは、-D という VM 引数を使って、実行する仮想マシンにこのパラメータを渡します。

親トピック: プラグイン実装


API の構造

次の画像は、API for サードパーティ テスト タイプ インテグレーションのための API の構造を表したものです。

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

利用可能なインターフェイス

  • TestLaunchBean
  • ExtProcessTestLaunchBean
  • TestLaunchPluginContext
  • TestSourceContext
  • TestLaunchResultDrain
親トピック: サードパーティ テスト タイプとの統合


サンプル コード

このサンプル コード ブロックは、あらゆる実行可能ファイルの起動に使用することができる process executor テストタイプを実装しています。これは、公開 ExtProcessTestLaunchBean クラスを拡張します。

package com.borland.sctm.testlauncher;

import java.io.File;
import java.io.IOException;
import java.util.ArrayList;

import com.segue.tm.published.api.testlaunch.ExtProcessTestLaunchBean;
import com.segue.tm.published.api.testlaunch.TestLaunchResultDrain;

/**
 * Implements an Silk Central test type that can be used to launch
 * any executables, for example from a command line.
 * Extends Silk Central published process test launcher class,
 * see Silk Central API Specification (in Help -> Documentation) for
 * further details.
 */
public class ProcessExecutor extends ExtProcessTestLaunchBean {

  // test properties that will be set by Silk Central using appropriate setter
  // methods (bean convention),
  // property names must conform to property tags used in the XML file

  /**
   * Represents property <command> defined in ProcessExecutor.xml.
   */
  private String command;

  /**
   * Represents property <arguments> defined in ProcessExecutor.xml.
   */
  private String arguments;

  /**
   * Represents property <workingfolder> defined in ProcessExecutor.xml.
   */
  private String workingfolder;

  /**
   * Java Bean compliant setter used by Silk Central to forward the command to be
   * executed.
   * Conforms to property <command> defined in ProcessExecutor.xml.
   */
  public void setCommand(String command) {
    this.command = command;
  }

  /**
   * Java Bean compliant setter used by Silk Central to forward the arguments
   * that will be passed to the command.
   * Conforms to property <arguments> defined in ProcessExecutor.xml.
   */
  public void setArguments(String arguments) {
    this.arguments = arguments;
  }

  /**
   * Java Bean compliant setter used by Silk Central to forward the working
   * folder where the command will be executed.
   * Conforms to property <workingfolder> defined in
   * ProcessExecutor.xml.
   */
  public void setWorkingfolder(String workingfolder) {
    this.workingfolder = workingfolder;
  }

  /**
   * Main plug-in method. See Silk Central API Specification
   * (in Help &gt; Documentation) for further details.
   */
  @Override
  public boolean execute(long time, TestLaunchResultDrain context)
    throws InterruptedException {
    try {
      String[] cmd = getCommandArgs(context);
      File workingDir = getWorkingFolderFile(context);
      String[] envVariables = getEnviromentVariables(context);

      int processExitCode = runExternalProcess(cmd, envVariables, workingDir,
        context.getLog());

      boolean outputXmlFound = handleOutputXmlIfExists(context);

      if (! outputXmlFound && processExitCode != 0) {
        // if no output.xml file was produced, the exit code indicates
        // success or failure
        context.publishMessage(TestLaunchResultDrain.SEVERITY_ERROR,
          "Process exited with return code "
          + String.valueOf(processExitCode));
        context.updateErrors(1, 0);
        // set error, test will get status 'failed'
      }
    } catch (IOException e) {
      // prints exception message to Messages tab in Test Run
      // Results
      context.publishMessage(TestLaunchResultDrain.SEVERITY_FATAL,
        e.getMessage());
      // prints exception stack trace to 'log.txt' that can be viewed in Files
      // tab
      e.printStackTrace(context.getLog());
      context.publishErrors(1, 0);
      return false; // set test status to 'not executed'
    }
    return true;
  }

  /**
   * Initializes environment variables to be set additionally to those
   * inherited from the system environment of the Execution Server.
   * @param context the test execution context
   * @return String array containing the set environment variables
   * @throws IOException
   */
  private String[] getEnviromentVariables(TestLaunchResultDrain context)
    throws IOException {
    String[] envVariables = {
      "SCTM_EXEC_RESULTSFOLDER="
      + context.getTempResultsDir().getAbsolutePath(),
      "SCTM_EXEC_SOURCESFOLDER="
      + sourceAccess().getTestContainerRootDir().getAbsolutePath(),
    };
    return envVariables;
  }

  /**
   * Let Silk Central parse the standard report xml file (output.xml) if exists.
   * See also Silk Central Web Help - Creating a Test Package. A XSD file
   * can be found in Silk Central Help -&gt; Tools -&gt; Test Package XML Schema
   * Definition File
   * @param context the test execution context
   * @return true if output.xml exists
   * @throws IOException
   */
  private boolean handleOutputXmlIfExists(TestLaunchResultDrain context)
    throws IOException {
    String outputFileName = context.getTempResultsDir().getAbsolutePath()
    + File.separator + TestLaunchResultDrain.OUTPUT_XML_RESULT_FILE;
    File outputfile = new File(outputFileName);
    boolean outputXmlExists = outputfile.exists();
    if (outputXmlExists) {
      context.parseStdResultFile(outputfile);
      context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
        String.format("output.xml parsed from '%s'", outputFileName));
    }
    return outputXmlExists;
  }

  /**
   * Retrieves the working folder on the Execution Server. If not configured
   * the results directory is used as working folder.
   * @param context the test execution context
   * @return the working folder file object
   * @throws IOException
   */
  private File getWorkingFolderFile(TestLaunchResultDrain context)
    throws IOException {
    final File workingFolderFile;
    if (workingfolder != null) {
      workingFolderFile = new File(workingfolder);
    } else {
      workingFolderFile = context.getTempResultsDir();
    }
    context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
      String.format("process is exectued in working folder '%s'",
        workingFolderFile.getAbsolutePath()));
    return workingFolderFile;
  }

  /**
   * Retrieves the command line arguments specified.
   * @param context the test execution context
   * @return an array of command line arguments
   */
  private String[] getCommandArgs(TestLaunchResultDrain context) {
    final ArrayList<String> cmdList = new ArrayList<String>();
    final StringBuilder cmd = new StringBuilder();
    cmdList.add(command);
    cmd.append(command);
    if (arguments != null) {
      String[] lines = arguments.split("[\\r\\n]+");
      for (String line : lines) {
        cmdList.add(line);
        cmd.append(" ").append(line);
      }
    }
    context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
      String.format("executed command '%s'", cmd.toString()));
    context.getLog().printf("start '%s'%n", cmd.toString());
    return (String[]) cmdList.toArray(new String[cmdList.size()]);
  }
}
親トピック: サードパーティ テスト タイプとの統合


設定 XML ファイル

サードパーティ テスト タイプ プラグインについてのメタ情報が含まれている、設定 XML ファイルについて説明します。

  • プラグインのメタ情報
    プラグイン メタ情報は、概して、そのプラグインとテストのタイプに関する情報を提供します。
  • 一般プロパティのメタ情報
    編集可能プロパティに共通の一般的な情報について説明します。
  • 文字列プロパティのメタ情報
    プラグインで利用できる文字列プロパティのメタ情報のタイプを一覧します。
  • ファイル プロパティのメタ情報
    プラグインで利用できるファイル プロパティのメタ情報のタイプを一覧します。
親トピック: サードパーティ テスト タイプとの統合


プラグインのメタ情報

プラグイン メタ情報は、概して、そのプラグインとテストのタイプに関する情報を提供します。 利用可能な情報タイプは、次のとおりです。

タイプ | 説明
id | インストールされているすべてのプラグイン内で一意の内部文字列で、タイプを識別します。
label | 選択リストや編集ダイアログに表示される、このタイプ用 GUI テキスト。
description | このテスト タイプを説明する補足テキスト情報。
version | タイプの個々のバージョンを区別するためのもの。
親トピック: 設定 XML ファイル


一般プロパティのメタ情報

編集可能プロパティには、各プロパティ タイプで同じ一般情報があります（このほかに、タイプ固有の情報があります）。 プロパティの名前は、コード内で get<<propertyname>> メソッドによって定義されている名前と一致しなければなりません。このときその名前の最初の文字は小文字でなければなりません。

タイプ | 説明
label | GUI に表示されるテキスト。
description | プロパティを説明する補足テキスト情報。
isOptional | 値が true の場合、ユーザー入力は必須ではない、ということを意味します。
default | 新しいテストを作成する際に使用される、このプロパティのデフォルト値。 この値は、プロパティ タイプに合っている必要があります。
親トピック: 設定 XML ファイル


文字列プロパティのメタ情報

次は、プラグインで利用できる文字列プロパティのメタ情報のタイプの一覧です。

タイプ | 説明
maxLength | ユーザーが入力できる最大長を示します。
editMultiLine | 編集フィールドが複数行持てるのかどうかを示します。
isPassword | 値が true の場合、ユーザー入力が *** で隠蔽されます。
親トピック: 設定 XML ファイル


ファイル プロパティのメタ情報

次は、プラグインで利用できるファイル プロパティのメタ情報のタイプの一覧です。

特定のファイルの値では、実行サーバー上の絶対パスを持つ非バージョン管理下のファイルと、バージョン管理化のファイルは区別されます。 ソース管理下にあるファイルは、常にテスト コンテナのルート ディレクトリに対して相対的であり、大抵は、実行されるテスト ソースを指定する際に使用されます。 絶対パスも実行サーバー上に存在する必要があり、大抵、実行サーバー上でテストを起動するために使用される、ツールやリソースを指定するのに使用されます。

タイプ | 説明
openBrowser | 値が true の場合、テスト コンテナ内のファイル群からファイルを選択するためのブラウザが開かれることを示します。
isSourceControl | 値が true の場合、ファイルはソース管理システム上にあります。
fileNameSpec | 標準 Windows ファイル参照ダイアログで分かる、許容ファイル名に対する制限を示します。
親トピック: 設定 XML ファイル


カスタム アイコン

カスタム テスト タイプに対してカスタム アイコンをデザインし、作成したテスト タイプが識別しやすいものにすることができます。 構成 XML ファイルで識別子 PluginId を定義してあるプラグインに対してアイコンを定義するには、そのプラグイン ZIP コンテナのルート ディレクトリに、次の 4 つのアイコンを置く必要があります。

名前 | 説明
<PluginId>.gif | 作成したテスト タイプのデフォルト アイコン。 たとえば、ProcessExecutor.gif のようになります。
<PluginId>_package.gif | テスト パッケージ ルートおよびスイート ノードに使用されるアイコン (特定のテスト タイプのテストを、テスト パッケージに変換した場合) たとえば、ProcessExecutor_package.gif のようになります。
<PluginId>_linked.gif | テストの親フォルダが、リンク付けされたテスト コンテナだった場合に使用されるアイコン。 たとえば、ProcessExecutor_linked.gif のようになります。
<PluginId>_incomplete.gif | 製品またはテストの親テスト コンテナのソース管理プロファイルが未定義の場合に使用されるアイコン。
テスト タイプ用に新しいアイコンをデザインする場合は、次のルールを適用します。
  • GIF タイプのアイコンのみを使用します。 ファイル拡張子は大文字/小文字を区別し、必ず小文字の .gif である必要があります。
  • <Silk Central deploy folder>\wwwroot\silkroot\img\PluginIcons から古いアイコンや無効なアイコンを削除します。そうしないと、プラグイン ZIP コンテナのルート ディレクトリにある新しいアイコンでアイコンが更新されません。
  • アイコンのサイズは 16 x 16 ピクセルです。
  • アイコンに許容される最大色数は 256 色です。
  • アイコンは 1 ビットの透過性を持ちます。
親トピック: サードパーティ テスト タイプとの統合


デプロイメント

プラグインの ZIP アーカイブは、Silk Central インストール ディレクトリ下にある、Plugins サブディレクトリの中になければなりません。 このディレクトリに置いたプラグインを統合するには、アプリケーション サーバーとフロントエンド サーバーを、Silk Central Service Manager を使用して再起動します。
注: ホット デプロイメントはサポートされていません。

アーカイブを変更するたびに、これら 2 つのサーバーは再起動する必要があります。 このアーカイブは、実行サーバーへ自動的にアップロードされます。

注: 一旦プラグインをベースとしたテストを作成したら、そのプラグイン アーカイブを削除してはいけません。 存在しなくなってしまったプラグイン アーカイブをベースとしたテストは、変更もしくは実行された際に、不明なエラーを送出します。
親トピック: サードパーティ テスト タイプとの統合


ビデオ キャプチャの開始と終了を示す

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

Silk Central で、新しいサード パーティ テスト プラグインを作成し、単一のテスト実行で複数のテスト ケースの処理をサポートするサード パーティ テスト タイプの場合に、キャプチャされるビデオを特定のテスト ケースに関連付ける場合、次の 2 つの方法で処理できます。

プラグインで実行中のサード パーティ テスト

これらのテストでは、TestLaunchResultDrain クラスの indicateTestStart メソッドおよび indicateTestStop メソッドの使用を推奨します。

外部処理で実行中のサード パーティ テスト

これらのテストでは、TCP/IP ベースのサービスを使用して START メッセージおよび FINISH メッセージを Silk Central 実行サーバーのポートに送信できます。使用するポート番号は、プラグイン内で ExecutionContextInfo.ExecProperty#PORT_TESTCASE_START_FINISH を使用して問い合わせできます。プラグインが ExtProcessTestLaunchBean を拡張している場合、テスト プロセスの #sctm_portTestCaseStartFinish という環境変数からポート番号を取得することもできます。これらのメッセージ タイプによって、テストのテスト ケースが開始されたか、またはそれぞれ終了したことが、実行サーバーに通知されます。メッセージは、Unicode (UTF8) 形式または ASCII 形式でエンコードする必要があります。
メッセージ タイプ
書式
START
START <Test Name>, <Test ID> <LF>。 LF は ASCII コード 10 です。
FINISH
FINISH <Test Name>, <Test ID>, <Passed> LF。 LF は ASCII コード 10 です。 Passed には True または False を指定します。ビデオ キャプチャが、エラー時のみ に実行されるよう設定されている場合、Passed に False が設定されていれば、ビデオは結果にのみ保存されます。

要求が認識された場合、実行サーバーはメッセージ OK で応答します。これ以外の場合は、実行サーバーはエラー メッセージで応答します。常に、実行サーバーの応答を待ってから、次のテスト ケースを実行します。これを行わなかった場合、記録されたビデオは、実際のテスト ケースに一致しない場合があります。

テストを実行している外部プロセスが、Java 環境に基づいている場合、TestCaseStartFinishSocketClient クラスの indicateTestStart メソッドおよび indicateTestStop メソッドを使用することを推奨します。このクラスは、tm-testlaunchapi.jar ファイルに含まれています。

親トピック: サードパーティ テスト タイプとの統合
関連概念
ビデオ キャプチャ


クラウド統合

Silk Central は、クラウド プロバイダ プロファイルを設定することで、パブリックまたはプライベートなクラウド サービスのプロバイダと統合することができます。クラウド プロファイルは、プラグインの概念に基づいており、特定のクラウド プロバイダに対する独自のプラグインをユーザーが作成することができます。クラウド プロバイダ プラグインは、各自動テストが実行される前に仮想環境をデプロイします。
注: クラウド API は、Silk Central の将来のバージョンで変更される可能性があります。この API を使用する場合は、Silk Central の将来のバージョンにアップグレードする際に、実装も更新する必要となる可能性があります。

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

最初に取り扱う基本インターフェイスは CloudProviderProfile（com.segue.scc.published.api.cloud）です。CloudProviderProfile は、外部のクラウド システムへのアクセスと制御を指定します。クラウド プロバイダ プラグインの実装には、以下の事項を行う必要があります。
  • この種類のプロバイダにリモート アクセスするためにクラウド プロバイダ プロファイルで設定する必要のあるプロパティを公開する
  • プロファイル プロパティを検証し、クラウド プロバイダとの接続を確認する
  • 利用可能なイメージ テンプレートのリストをクラウド プロバイダから取得する
  • 選択したイメージ テンプレートを基に仮想環境をデプロイし、外部からアクセス可能なホスト アドレスを公開する
  • 仮想環境がデプロイされ実行中であることを確認する
  • 特定の仮想環境を削除する
親トピック: API ヘルプ
関連概念
クラウド統合
プラグインを作成する
関連タスク
クラウド ホスト型実行サーバーを設定する


Silk Central の Web サービス

Web サービスにセットアップは必要なく、デフォルトで各フロントエンド サーバー上で有効になっています。たとえば、http://www.yourFrontend.com/login が Silk Central のアクセスに使用する URL である場合、http://www.yourFrontend.com/Services1.0/jaxws/system（従来のサービス： http://www.yourFrontend.com/Services1.0/services）および http://www.yourFrontend.com/AlmServices1.0/services が、利用可能な Web サービスのアクセスに使用するベース URL になります。

ブラウザでこのベース URL へアクセスすると、利用可能なすべての Web サービスの簡単な HTML リストが表示されます。このリストは、JAX-WS によって提供されています。 Silk Central が使用する SOAP スタックは、https://jax-ws.java.net/ です。

この基本 URL では WSDL (Web サービス定義言語: Web Service Definition Language) 標準 XML ファイルへのリンクが掲載されており、各ファイルでは、それぞれ 1 つの Web サービスのインターフェイスが記述されています。これらのファイルは、可読形式ではありません。このため、SOAP が有効化されたクライアント (たとえば、Silk Performer Java Explorer) が、WSDL ファイルを読み取り、そこから、そのファイルに対応する Web サービス上にあるメソッドを呼び出すために必要な情報を取得します。

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

注: バージョン 2008 より前の Silk Central に実装されたオリジナルの Web サービスも、引き続き http://hostname:port/services から利用できます。

  • Web サービス クイック スタート
    前提条件、サンプル例、その他 Web サービスのインテグレーションに関連するトピックが提供されます。
  • セッション処理
    Web サービスを介した認証がどのようにセッション識別子を返し、セッションを参照するかについて説明します。
  • 利用可能な Web サービス
    利用可能な Web サービスの一覧を提供します。
  • Services Exchange
    このセクションでは、Services Exchange における HTTP ベースのインターフェイスについて説明します。これらは、レポート、添付ファイル、テスト計画、実行、およびライブラリを処理する際に使用されます。
  • Web サービス デモ クライアント
    Web サービス デモ クライアントについて説明します。これは、Silk Central Web サービスの使用方法をデモンストレーションするためのツールです。
親トピック: API ヘルプ


Web サービス クイック スタート

このセクションでは、前提条件、サンプル例、その他 Web サービスのインテグレーションに関連するトピックが提供されます。

  • 前提条件
    Web サービス クライアントを開発する前に、知っておく必要のある事柄について説明します。
  • Web サービス入門
    このタスクでは、Web サービス ライブラリのダウンロード、jar の展開、そして自動生成される Java クラス YourWebService を見つける方法について説明します。
  • Web サービス クライアントの概要
    Web サービス クライアントをどのように構築するか、SOAP エンベロープ、WSDL、WSDL2 Java ツールについても含めて、概要を提供します。
  • サンプル事例：要件を追加する
    前のステップで行ったことの詳細をこのセクションでフォローアップし、Silk Central へ要件を追加するサンプル事例を完了させます。
親トピック: Silk Central の Web サービス


前提条件

次の前提条件は、Web サービス クライアントを開発する前に検討される必要があります。

  • オブジェクト指向プログラミング（OOP）の基本知識。 サンプル例は Java 言語で記述されているため、Java の経験は理解の助けとなるでしょう。 Java の経験はなくても、C++、C#、Python、または Perl に関する経験がある開発者は、より簡単にこのサンプル例についていくことができるはずです。 HashMaps や Lists といったコレクションの操作に関する経験があると、より望ましいです。
  • JUnit テストについては簡単に言及されています。 この Java テスト フレームワークについては必須ではありませんが、知識があると理解の助けとなるでしょう。
  • Web サービス技術への入門的な経験。 このヘルプ ドキュメントは、Web サービスや SOAP などの教育コースとなることを意図したものではありません。 最低限、「Hello World!」Web サービス クライアントくらいは、コーディングし、実行に成功している必要があります。
  • Silk Central Web サービス アーキテクチャに関する知識。
親トピック: Web サービス クイック スタート
関連概念
Silk Central の Web サービス


Web サービス入門

適切なバージョンの SDK がインストールされ、それが PATH にあるかどうかを確認するには、『Silk Central リリース ノート』を参照してください。

JUnit jar がクラスパスにあると便利でしょう。JUnit.jar ファイルは、http://www.junit.org/index.htm からダウンロードすることができます。

  1. Java SDK の bin ディレクトリが PATH に含まれていることを確認します。
  2. 目的の Web サービスの WSDL を指定しながら、以下のコマンドを実行します。
    wsimport -s <生成したファイルを保存するパス> -Xnocompile
-p <yourWebService クライアントで使用するパッケージ構造>
http://<サービスの URL>/yourWebService?wsdl
  3. 自動生成された Java クラス YourWebService を探します。 このクラスは、YourWebService が提供するすべてのメソッドを使用できるようになっています。
親トピック: Web サービス クイック スタート


Web サービス クライアントの概要

Web サービスは大抵の場合、SOAP over HTTP プロトコルを使用します。このシナリオで、SOAP エンベロープは送信されます。コレクションやその他複雑なオブジェクトが SOAP エンベロープにバンドルされている場合、ASCII データ構造を読み書きしづらくなる可能性があります。開発者は、SOAP エンベロープを直接操作して Web サービス クライアントをビルドしようとしてはなりません。経験豊富な開発者は、大抵 Web サービス クライアントのビルドを、SOAP エンベロープのレベルでは行いません。これを行うことは、面倒であり間違いの元でもあります。このため、すべての主なプログラミング言語で、Web サービス開発キットが提供されています。Silk Central では、SOAP メッセージを使用して通信する Web サービスやクライアントの構築に Java API for XML Web Services (JAX-WS) を使用しています。

実装言語（Java、C++、C#、Perl、Python）にかかわらず、Web サービス クライアントの構築の場合、大抵の場合、同じパターンに従います。

  1. 開発キット ツールに Web サービス WSDL を指定
  2. ステップ 1 で返されたクライアント スタブを取得
  3. ステップ 2 で生成されたクライアント スタブを編集して、完全なクライアントを取得
JAX-WS は、このパターンに従います。ここで、WSDL からクライアント スタブを構築するのに、wsimport ツール（JDK にバンドル）を使用します。wsimport の使用方法の詳細については、『JDK Tools and Utilities』を参照してください。 先ほどの概要部分で使用されていたスイッチの簡単な説明は以下のとおりです。
  • -s：クライアント スタブの出力ディレクトリ
  • -p：ターゲットのパッケージ。このパッケージ構造にデプロイされます。

例：wsimport -s <生成するスタブの場所> -p <ターゲット パッケージ> <WSDL>

wsimport ツールは、Web サービスのクライアントをサポートするために、複数のクラスを生成します。サービス名が YourWebService である場合、次のクラス群が出力されることになります。

  • YourWebService：YourWebService を表すインターフェイス
  • YourWebServiceService：利用可能なポートの一覧を取得するなど、YourWebService ロケーターを表す生成クラス（サービス エンドポイント インターフェイス）
  • WSFaultException：wsdl:fault からマップされた例外クラス
  • WsFaultBean：レスポンス wsdl:message から派生した非同期レスポンス
  • Serializeable Objects：YourWebService が使用するオブジェクトに対応するクライアント側のオブジェクト

Silk Central Web サービスにアクセスする JAX-WS クライアントを生成するには、YourWebServiceClient という新しい Java クラスを作成します。Web サービスにはポートを介してバインドする必要があります。ポートは、リモート サービスのプロキシとして動作するローカル オブジェクトです。ポートは、上記手順で示した wsimport ツールの実行によって作成されます。このプロキシを取得するには、getRequirementsServicePort メソッドをサービスに対して呼び出します。

// Bind to the Requirements service
  RequirementsServiceService port = new RequirementsServiceService
    (new URL("http", mHost, mPort, "/Services1.0/jaxws/requirements?wsdl"));
  RequirementsService requirementsService = port.getRequirementsServicePort();

その後、ユーザー名とパスワードを指定してサービスの logonUser メソッドを呼び出してセッション ID を得ることができます。

// Login to Silk Central and get session ID
  String sessionId = requirementsService.logonUser(mUsername, mPassword);
親トピック: Web サービス クイック スタート


サンプル事例：要件を追加する

前のステップで行ったことの詳細をこのセクションでフォローアップし、Silk Central へ要件を追加するサンプル事例を完了させます。

先に進む前に、次の事前要件を満たしている必要があります。

  • requirements Web サービスについて説明している各ステップを完了している。
  • バインド、ログイン メソッドを持った、作業 POJO や JUnit クラスが作成されている。
  • 他の Silk Central API ヘルプ トピックを読んでいる。
  1. ユーザーの資格情報を指定するログイン メソッドを使用してサービスにバインドします。
  2. 以前のステップで取得したセッション ID を保存します。
  3. 希望するデータを保持する要件オブジェクトを構築します。
  4. セッション ID、プロジェクト ID、および生成した要件オブジェクトを使用して、updateRequirement メソッドを呼び出します。
  5. updateRequirement メソッドによって返された要件 ID を保存します。
  6. 要件プロパティの PropertyValue 配列を作成します。
  7. 前で作成された配列を使用して、updateProperties メソッドを呼び出します。
wsimport は、上述の Web サービス オブジェクトを作成します。
  • Requirement
  • PropertyValue

上記のオブジェクトの OOP メソッドを利用するだけで、Web サービスを使用していくことができます。SOAP エンベロープの構築は必要ありません。以下は、このユース ケースを完了させるために必要なコードの抜粋です。

/** project ID of Silk Central project */
private static final int PROJECT_ID = 0;

/** propertyID for requirement risk */
public static final String PROPERTY_RISK = "Risk";

/** propertyID for requirement reviewed */
public static final String PROPERTY_REVIEWED = "Reviewed";

/** propertyID for requirement priority */
public static final String PROPERTY_PRIORITY = "Priority";

/** propertyID for requirement obsolete property */
public static final String PROPERTY_OBSOLETE = "Obsolete";

// Get the Requirements service
RequirementsService service = getRequirementsService();

// Login to Silk Central
String sessionId = login(service);

// Construct Top Level Requirement
Requirement topLevelRequirement = new Requirement();
topLevelRequirement.setName("tmReqMgt TopLevelReq");
topLevelRequirement.setDescription("tmReqMgt TopLevel Desc");

PropertyValue propRisk = new PropertyValue();
propRisk.setPropertyId(PROPERTY_RISK);
propRisk.setValue("2");
PropertyValue propPriority = new PropertyValue();
propPriority.setPropertyId(PROPERTY_PRIORITY);
propPriority.setValue("3");
PropertyValue[] properties = new PropertyValue[] {propRisk, propPriority};

/*
* First add requirement skeleton, get its ID
* service is a binding stub, see above getRequirementsService() snippet
* sessionId is the stored session ID, see above login() snippet
*/
int requirementID = service.updateRequirement(sessionId, PROJECT_ID, topLevelRequirement, -1);

// Now loop through and set properties
for (PropertyValue propValue : properties) {
propValue.setRequirementId(requirementID);
service.updateProperty(sessionId, requirementID, propValue);
}

// Add Child Requirement
Requirement childRequirement = new Requirement();
childRequirement.setName("tmReqMgt ChildReq");
childRequirement.setDescription("tmReqMgt ChildLevel Desc");
childRequirement.setParentId(requirementID);
propRisk = new PropertyValue();
propRisk.setPropertyId(PROPERTY_RISK);
propRisk.setValue("1");
propPriority = new PropertyValue();
propPriority.setPropertyId(PROPERTY_PRIORITY);
propPriority.setValue("1");
properties = new PropertyValue[] {propRisk, propPriority};

int childReqID = service.updateRequirement(sessionId, PROJECT_ID, childRequirement, -1);

// Now loop through and set properties
for (PropertyValue propValue : properties) {
propValue.setRequirementId(requirementID);
service.updateProperty(sessionId, childReqID, propValue);
}

// Print Results
System.out.println("Login Successful with mSessionID: " + sessionId);
System.out.println("Top Level Requirement ID: " + requirementID);
System.out.println("Child Requirement ID: " + childReqID);
注: このサンプル コードは、Web サービスのデモ クライアント クラスである com.microfocus.silkcentral.democlient.samples.AddingRequirement からも利用できす。
親トピック: Web サービス クイック スタート


セッション処理

Silk Central のデータは、未許可のアクセスから保護されています。データ アクセスの許可の前に、まずログイン認証が提供されなければなりません。これは、HTML フロントエンドで作業するときだけでなく、SOAP 呼び出しを介して Silk Central と通信するときにも当てはまります。

データに対してクエリをかけたり、Silk Central に対して設定変更を適用する際にも、まず最初の手順は認証です。認証が成功したら、ユーザー セッションが作成され、そのユーザー ログインのコンテキスト内で、以降のオペレーションを実行できるようになります。

Web ブラウザを介して Silk Central へアクセスしている場合には、セッション情報はユーザーに対して表示されません。ブラウザがクッキーを使用して、セッション情報をハンドリングします。HTML を介して Silk Central を使用している場合に比べ、SOAP 呼び出しはセッション情報を手動で処理する必要があります。

サービスを介した認証は、必要な Web サービスの logonUser SOAP 呼び出しによって行われます。このメソッド呼び出しはセッション識別子を返します。このセッション識別子は、サーバー上に作成されたセッションを参照していると共に、そのセッションのコンテキスト内で Silk Central へアクセスするためのキーとしても使用されます。

実行にセッションが必要なそれ以降の各 SOAP 呼び出しは、このような返り値の識別子をパラメータの 1 つに取り、その妥当性をチェックし、そのセッションのコンテキスト内で実行します。

以下の Java コード サンプルは、Web サービスを介した Silk Central へのシンプルなアクセスと、セッション識別子の利用方法を示しています。
long sessionID = systemService.logonUser("admin", "admin");
Project[] projects = sccentities.getProjects(sessionID);

Web サービスを介して作成された Silk Central セッションは、明示的に終了させることはできません。代わりにセッションは、一定時間使用されないと、自動的に終了されます。サーバー上でセッションがタイムアウトするとすぐに、そのセッションを使用しようとするそれ以降の SOAP 呼び出しは例外を投げるようになります。

デモ クライアントは、Silk Central のメニューの ヘルプ > ツール > Web サービス デモ クライアント ダウンロードできます。このデモ プロジェクトは Silk Central の tests Web サービスを利用しており、ユーザーが Web サービス インターフェイスに慣れるのに役立ちます。

親トピック: Silk Central の Web サービス


利用可能な Web サービス

以下の表には、利用可能な Silk Central Web サービスが一覧されています。HTTP ベースのインターフェイスを介して Silk Central にアクセスすることもできます。詳細については、「Services Exchange」を参照してください。

注: また、WSDL URL には、Web サービス クライアントの作成には使用しない、システム内部 Web サービスも一覧されています。本ドキュメントでは、公開 Web サービスのみを記載していきます。

利用可能な Java クラスやメソッドに関する詳細については、Javadoc を参照してください。このリンクが動作しなかった場合には、Silk Central メニューの ヘルプ > ドキュメント > Silk Central API 仕様 を選択して、Javadoc を開いてください。

注: Web サービスで作業する場合、システムから返される時間はすべて協定世界時 (UTC) です。Web サービスでの作業では、すべての時間参照に UTC を使用してください。
WS 名 (インターフェイス) | WSDL URL | 説明
system (SystemService) | /Services1.0/jaxws/system?wsdl | これはルート サービスであり、認証機能と、基本的なユーティリティ メソッドを提供します。
administration (AdministrationService) | /Services1.0/jaxws/administration?wsdl | このサービスは、Silk Central の プロジェクト エンティティと 製品 エンティティへのアクセスを提供します。
requirements (RequirementsService) | /Services1.0/jaxws/requirements?wsdl | このサービスは、Silk Central の 要件 領域へのアクセスを提供します。
tests (TestsService) | /Services1.0/jaxws/tests?wsdl | このサービスは、Silk Central の テスト 領域へのアクセスを提供します。
executionplanning (ExecutionPlanningService) | /Services1.0/jaxws/executionplanning?wsdl | このサービスは、Silk Central の 実行計画 領域へのアクセスを提供します。
filter (FilterService) | /Services1.0/jaxws/filter?wsdl | このサービスを使用すると、フィルタの作成、読み取り、更新、および削除を行うことができます。
issuemanager (IssueManagerService) | /Services1.0/jaxws/issuemanager?wsdl | このサービスは、Issue Manager へのアクセスを提供します。
親トピック: Silk Central の Web サービス


Services Exchange

このセクションでは、Services Exchange における HTTP ベースのインターフェイスについて説明します。これらは、レポート、添付ファイル、テスト計画、実行、およびライブラリを処理する際に使用されます。

Web サービスを介して Silk Central にアクセスすることもできます。詳細については、「利用可能な Web サービス」を参照してください。

注: Web サービスで作業する場合、システムから返される時間はすべて協定世界時 (UTC) です。Web サービスでの作業では、すべての時間参照に UTC を使用してください。
  • reportData インターフェイス
    reportData インターフェイスのパラメータの一覧を提供します。reportData インターフェイスは、レポートのデータを要求する際に使用されます。
  • TMAttach インターフェイス
    TMAttach インターフェイスのパラメータの一覧を提供します。
  • createTestPlan インターフェイス
    createTestPlan インターフェイスのパラメータの一覧を提供します。
  • exportTestPlan インターフェイス
    exportTestPlan インターフェイスのパラメータの一覧を提供します。
  • updateTestPlan インターフェイス
    updateTestPlan インターフェイスのパラメータの一覧を提供します。
  • createRequirements インターフェイス
    createRequirements インターフェイスのパラメータの一覧を提供します。
  • exportRequirements インターフェイス
    exportRequirements インターフェイスのパラメータの一覧を提供します。
  • updateRequirements インターフェイス
    updateRequirements インターフェイスのパラメータの一覧を提供します。
  • updateRequirementsByExtID インターフェイス
    updateRequirementsByExtID インターフェイスのパラメータの一覧を提供します。
  • createExecutionDefinitions インターフェイス
    createExecutionDefinitions インターフェイスのパラメータの一覧を提供します。
  • exportExecutionDefinitions インターフェイス
    exportExecutionDefinitions インターフェイスのパラメータの一覧を提供します。
  • updateExecutionDefinitions インターフェイス
    updateExecutionDefinitions インターフェイスのパラメータの一覧を提供します。
  • createLibraries インターフェイス
    createLibraries インターフェイスのパラメータの一覧を提供します。
  • exportLibraryStructure インターフェイス
    exportLibraryStructure インターフェイスのパラメータの一覧を提供します。
  • exportLibraryStructureWithoutSteps インターフェイス
    exportLibraryStructureWithoutSteps インターフェイスのパラメータの一覧を提供します。
  • getLibraryInfoByName インターフェイス
    getLibraryInfoByName インターフェイスのパラメータの一覧を提供します。
親トピック: Silk Central の Web サービス


reportData インターフェイス

reportData インターフェイスは、レポートのデータを要求する際に使用されます。次の表は、reportData インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=reportData | sid | セッション ID： ユーザー認証
 | reportFilterID | レポート フィルタ ID
 | type | 本体形式を返す: (csv または xml)
 | includeHeaders | レポート ヘッダのインクルードの有無 (true または false)
 | userName | (任意) ユーザー名： 次の代わりに使用：sid
 | passWord | (任意) ユーザー パスワード： 次の代わりに使用：sid
 | projectID | プロジェクトの ID

例：http://<front-end URL>/servicesExchange?hid=reportData&reportFilterID=<id>&type=<csv or xml>&includeHeaders=<true or false>&userName=<user>&passWord=<password>&projectID=<id>

reportData インターフェイスの例

String reportID = "<id>";
   String user = "<user>";
   String pwd = "<pwd>";
   String host = "<any_host>";

    URL report = new URL("http", host, 19120,
    "/servicesExchange?hid=reportData" +
     "&type=xml" + // or csv
     "&userName=" + user +
     "&passWord=" + pwd +
     "&reportFilterID=" + reportID +
     "&includeHeaders=true" +
     "&rp_execNode_Id_0=1" +
     "&projectID=27);

   BufferedReader in = new BufferedReader(new InputStreamReader(report.openStream(), "UTF-8"));

   StringBuilder builder = new StringBuilder();
   String line = "";

   while ((line = in.readLine()) != null) {
       builder.append(line + "\n");
   }

   String text = builder.toString();
   System.out.println(text);
 }
レポートにパラメータが必要な場合は、各パラメータについて、レポート URL に次のコードを追加する必要があります。
 "&rp_parametername=parametervalue"
この例で、パラメータ rp_execNode_Id_0 の値は 1 に設定されています。
注: reportData サービスに渡されるパラメータの名前は rp_ で始まる必要があります。例：/servicesExchange?hid=reportData&type=xml&sid=<...>&reportFilterID=<...>&projectID=<...>&rp_TestID=<...>
親トピック: Services Exchange


TMAttach インターフェイス

TMAttach インターフェイスは、テストや要件に対する添付ファイルのアップロードに使用されます。次の表は、TMAttach インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=TMAttach | sid | セッション ID： ユーザー認証
 | entityType | 対象エンティティ タイプ： (テスト、要件、または TestStepParent)
 | entityID | 対象エンティティ ID： (テスト ID、要件 ID、または手動テスト ID)
 | description | 添付情報の説明。 URL エンコード テキストで、添付ファイルの記述に使用されます。
 | isURL | true の場合、添付ファイルは URL です。false の場合、添付ファイルはファイルです。
 | URL | (任意) 添付される URL。
 | stepPosition | (任意) テスト ステップの順。手動テストのステップを識別します (たとえば、最初のステップの順は 1 です)。entityType が TestStepParent だった場合、順は必須となります。
 | userName | (任意) ユーザー名： 次の代わりに使用：sid
 | passWord | (任意) ユーザー パスワード： 次の代わりに使用：sid

例：http://<front-end URL>/servicesExchange?hid=TMAttach&entityType=<test, requirement, or TestStepParent>&entityID=<id>&description=<text>&isURL=<true or false>&URL=<URL>&stepPosition=<number>&userName=<user>&passWord=<password>

TMAttach Web サービスの例

次のコードは、バイナリの添付ファイルをアップロードするために、便利な HTTP-POST API を取得するのに Apache HtmlClient を使用しています。リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。

リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

import org.apache.commons.httpclient.*; // Apache HttpClient

    String sessionID = null;
    String testNodeID = null; // receiving test
    File fileToUpload = null; // attachment
    String AttachmentDescription = ""; // descriptive text

    HttpClient client = new HttpClient();
    String formURL = "http://localhost:19120/
        servicesExchange?hid=TMAttach" +
        "&sid=" + sessionID +
        "&entityID=" + testNodeID +
        "&entityType=Test" +
        "&isURL=false";
    PostMethod filePost = new PostMethod(formURL);
    Part[] parts = {
        new StringPart("description", attachmentDescription),
        new FilePart(fileToUpload.getName(), fileToUpload)
    };
    filePost.setRequestEntity(new MultipartRequestEntity(parts,
        filePost.getParams()));
    client.getHttpConnectionManager().
        getParams().setConnectionTimeout(60000);
    // Execute and check for success
    int status = client.executeMethod(filePost);
    // verify http return code...
    // if(status == httpStatus.SC_OK) ...
親トピック: Services Exchange


createTestPlan インターフェイス

createTestPlan インターフェイスは、新しいテストを作成するために使用されます。すべての呼び出しの HTTP の応答には、変更されたテストの XML 構造が含まれます。新しいコードの識別子は、更新された XML テストの構造から取得できます。

次の表は、createTestPlan インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=createTestPlan | sid | セッション ID – ユーザー認証
 | parentNodeID | テスト ツリーにおいて新しいテストが追加されるコンテナの ID
 | userName | 省略可能：ユーザー名 - sid の代わりに使用
 | passWord | 省略可能：ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=createTestPlan&parentNodeID=<id>&userName=<user>&passWord=<password>

テスト計画を検証するために使用される XML スキーマ定義ファイルは、フロントエンド サーバー URL http://<フロントエンド URL>/silkroot/xsl/testplan.xsd を使用してダウンロードするか、フロントエンド サーバーのインストール フォルダ <Silk Central インストール フォルダ>/wwwroot/silkroot/xsl/testplan.xsd からコピーできます。

createTestPlan Web サービスの例

以下のコードでは、Apache HttpClient を使用して、テストが作成されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createTestPlan", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadTestPlanUtf8("testPlan.xml");
StringPart xmlFileItem = new StringPart("testPlan", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

テストの例

次のコードは、createTestPlan サービス、および updateTestPlan サービスを使用して Silk Central へアップロードすることができるテストの例を示しています。

  <TestPlan xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/testplan.xsd">

  <Folder name="Folder1" id="5438">
    <Description>Description of the folder</Description>
    <Property name="property1">
      <propertyValue>value1</propertyValue>
    </Property>
    <Test name="TestDef1" type="plugin.SilkTest">
      <Description>Description of the test</Description>
      <Property name="property2">
        <propertyValue>value2</propertyValue>
      </Property>
      <Property name="property3">
           <propertyValue>value3</propertyValue>
           <propertyValue>value4</propertyValue>
      </Property>
      <Parameter name="param1" type="string">string1</Parameter>
      <Parameter name="param2" type="boolean">true</Parameter>
                        <Parameter name="paramDate" type="date">01.01.2001</Parameter>
      <Parameter name="paramInherited" type="string"
        inherited="true">
        inheritedValue1
      </Parameter>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
    </Test>
    <Test name="ManualTest1" id="5441" type="_ManualTestType"
      plannedTime="03:45">
      <Description>Description of the manual test</Description>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
      <Step id="3" name="StepC">
        <ActionDescription>do it now"</ActionDescription>
        <ExpectedResult>
          everything should come as you wish
        </ExpectedResult>
      </Step>
    </Test>
    <Folder name="Folder2" id="5439">
      <Description>Description of the folder</Description>
      <Property name="property4">
        <propertyValue>value5</propertyValue>
      </Property>
      <Parameter name="param3" type="number">123</Parameter>
      <Folder name="Folder2_1" id="5442">
        <Description>Description of the folder</Description>
        <Test name="TestDef2" type="plugin.SilkPerformer">
          <Description>Description of the test</Description>
          <Property name="_sp_Project File">
            <propertyValue>ApplicationAccess.ltp</propertyValue>
          </Property>
          <Property name="_sp_Workload">
            <propertyValue>Workload1</propertyValue>
          </Property>
        </Test>
        <Test name="TestDef3" type="JUnitTestType"
          externalId="com.borland.MyTest">
          <Description>Description of the test</Description>
          <Property name="_junit_ClassFile">
            <propertyValue>com.borland.MyTest</propertyValue>
          </Property>
          <Property name="_junit_TestMethod">
            <propertyValue>testMethod</propertyValue>
          </Property>
          <Step id="1" name="StepA">
            <ActionDescription>do it</ActionDescription>
            <ExpectedResult>everything</ExpectedResult>
          </Step>
          <Step id="2" name="StepB">
            <ActionDescription>and</ActionDescription>
            <ExpectedResult>everything should come</ExpectedResult>
          </Step>
        </Test>
      </Folder>
    </Folder>
  </Folder>
</TestPlan>
親トピック: Services Exchange


exportTestPlan インターフェイス

exportTestPlan インターフェイスは、テスト計画を XML ファイルにエクスポートするために使用されます。次の表は、exportTestPlan インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=exportTestPlan | sid | セッション ID – ユーザー認証
 | nodeID | この ID のノードと、このノードの子ノードすべてが、再帰的にエクスポートされます。
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=exportTestPlan&nodeID=<id>&userName=<user>&passWord=<password>

exportTestPlan Web サービスの例

以下のコードでは、Apache HttpClient を使用して、テストがエクスポートされます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportTestPlan", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

親トピック: Services Exchange


updateTestPlan インターフェイス

updateTestPlan インターフェイスは、XML ファイルから既存のルート ノードに対してテストを更新します。すべての呼び出しの HTTP の応答には、変更されたテストの XML 構造が含まれます。新しいコードの識別子は、更新された XML テストの構造から取得できます。

次の表は、updateTestPlan インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=updateTestPlan | sid | セッション ID – ユーザー認証
 | userName | 省略可能：ユーザー名 - sid の代わりに使用
 | passWord | 省略可能：ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=updateTestPlan&userName=<user>&passWord=<password>

テスト計画を検証するために使用される XML スキーマ定義ファイルは、フロントエンド サーバー URL http://<フロントエンド URL>/silkroot/xsl/testplan.xsd を使用してダウンロードするか、フロントエンド サーバーのインストール フォルダ <Silk Central インストール フォルダ>/wwwroot/silkroot/xsl/testplan.xsd からコピーできます。

updateTestPlan Web サービスの例

以下のコードでは、Apache HttpClient を使用して、テストが更新されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
String xml = loadTestPlanUtf8(DEMO_TEST_PLAN_XML);
HttpClient client = new HttpClient();

URL webServiceUrl = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateTestPlan",
    sessionID));
StringPart testPlanXml = new StringPart(DEMO_TEST_PLAN_XML, xml,
  "UTF-8");
testPlanXml.setContentType("text/xml");
Part[] parts = {testPlanXml};
PostMethod filePost = new PostMethod(webServiceUrl.toExternalForm());
filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

テストの例

次のコードは、createTestPlan サービス、および updateTestPlan サービスを使用して Silk Central へアップロードすることができるテストの例を示しています。

  <TestPlan xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/testplan.xsd">

  <Folder name="Folder1" id="5438">
    <Description>Description of the folder</Description>
    <Property name="property1">
      <propertyValue>value1</propertyValue>
    </Property>
    <Test name="TestDef1" type="plugin.SilkTest">
      <Description>Description of the test</Description>
      <Property name="property2">
        <propertyValue>value2</propertyValue>
      </Property>
      <Property name="property3">
           <propertyValue>value3</propertyValue>
           <propertyValue>value4</propertyValue>
      </Property>
      <Parameter name="param1" type="string">string1</Parameter>
      <Parameter name="param2" type="boolean">true</Parameter>
                        <Parameter name="paramDate" type="date">01.01.2001</Parameter>
      <Parameter name="paramInherited" type="string"
        inherited="true">
        inheritedValue1
      </Parameter>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
    </Test>
    <Test name="ManualTest1" id="5441" type="_ManualTestType"
      plannedTime="03:45">
      <Description>Description of the manual test</Description>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
      <Step id="3" name="StepC">
        <ActionDescription>do it now"</ActionDescription>
        <ExpectedResult>
          everything should come as you wish
        </ExpectedResult>
      </Step>
    </Test>
    <Folder name="Folder2" id="5439">
      <Description>Description of the folder</Description>
      <Property name="property4">
        <propertyValue>value5</propertyValue>
      </Property>
      <Parameter name="param3" type="number">123</Parameter>
      <Folder name="Folder2_1" id="5442">
        <Description>Description of the folder</Description>
        <Test name="TestDef2" type="plugin.SilkPerformer">
          <Description>Description of the test</Description>
          <Property name="_sp_Project File">
            <propertyValue>ApplicationAccess.ltp</propertyValue>
          </Property>
          <Property name="_sp_Workload">
            <propertyValue>Workload1</propertyValue>
          </Property>
        </Test>
        <Test name="TestDef3" type="JUnitTestType"
          externalId="com.borland.MyTest">
          <Description>Description of the test</Description>
          <Property name="_junit_ClassFile">
            <propertyValue>com.borland.MyTest</propertyValue>
          </Property>
          <Property name="_junit_TestMethod">
            <propertyValue>testMethod</propertyValue>
          </Property>
          <Step id="1" name="StepA">
            <ActionDescription>do it</ActionDescription>
            <ExpectedResult>everything</ExpectedResult>
          </Step>
          <Step id="2" name="StepB">
            <ActionDescription>and</ActionDescription>
            <ExpectedResult>everything should come</ExpectedResult>
          </Step>
        </Test>
      </Folder>
    </Folder>
  </Folder>
</TestPlan>
親トピック: Services Exchange


createRequirements インターフェイス

createRequirements インターフェイスは、新しい要件を作成するために使用されます。すべての呼び出しの HTTP の応答には、変更された要件の XML 構造が含まれます。新しいコードの識別子は、更新された XML 要件の構造から取得できます。

次の表は、createRequirements インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=createRequirements | sid | セッション ID – ユーザー認証
 | parentNodeID | 要件ツリーにおいて新しい要件が追加されるコンテナの ID
 | userName | 省略可能：ユーザー名 - sid の代わりに使用
 | passWord | 省略可能：ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=createRequirements&parentNodeID=<id>&userName=<user>&passWord=<password>

要件を検証するために使用される XML スキーマ定義ファイルは、フロントエンド サーバー URL http://<フロントエンド URL>/silkroot/xsl/requirements.xsd を使用してダウンロードするか、フロントエンド サーバーのインストール フォルダ <Silk Central インストール フォルダ>/wwwroot/silkroot/xsl/requirements.xsd からコピーできます。

createRequirements Web サービスの例

以下のコードでは、Apache HttpClient を使用して、要件が作成されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createRequirements", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadRequirementsUtf8("requirements.xml");
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

要件の例

次のコードは、createRequirements サービス、updateRequirements サービス、および updateRequirementsByExtID サービスを使用して、Silk Central へアップロードすることができる要件の例を示しています。

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
親トピック: Services Exchange


exportRequirements インターフェイス

exportRequirements インターフェイスは、要件を XML ファイルにエクスポートするために使用されます。次の表は、exportRequirements インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=exportRequirements | sid | セッション ID – ユーザー認証
 | nodeID | この ID のノードと、このノードの子ノードすべてが、再帰的にエクスポートされます。
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用
 | includeObsolete | 省略可能： true または false を指定します。省略した場合はデフォルトで true に設定されます。廃止した要件を除外する場合は false を指定します。

例：http://<front-end URL>/servicesExchange?hid=exportRequirements&nodeID=<id>&userName=<user>&passWord=<password>

exportRequirements Web サービスの例

以下のコードでは、Apache HttpClient を使用して、要件がエクスポートされます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportRequirements", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedRequirementResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedRequirementResponse);

Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

親トピック: Services Exchange


updateRequirements インターフェイス

updateRequirements インターフェイスは、XML ファイルから既存のルート ノードに対して要件を更新します。要件は、要件ツリーにおける内部 Silk Central ノード ID で識別されます。要件ツリー ノードと、そのノードのすべての子が更新されます。Silk Central において、新しいノードは追加され、紛失しているノードは廃止 (obsolete) となり、移動されたノードは単純に移動されます。すべての呼び出しの HTTP の応答には、変更された要件の XML 構造が含まれます。新しいコードの識別子は、更新された XML 要件の構造から取得できます。

次の表は、updateRequirements インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=updateRequirements | sid | セッション ID – ユーザー認証
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=updateRequirements&userName=<user>&passWord=<password>

要件を検証するために使用される XML スキーマ定義ファイルは、フロントエンド サーバー URL http://<フロントエンド URL>/silkroot/xsl/requirements.xsd を使用してダウンロードするか、フロントエンド サーバーのインストール フォルダ <Silk Central インストール フォルダ>/wwwroot/silkroot/xsl/requirements.xsd からコピーできます。

updateRequirements Web サービスの例

以下のコードでは、Apache HttpClient を使用して、要件が更新されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateRequirements", sessionID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
string xmlFile = loadRequirementsUtf8(fileName);
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

要件の例

次のコードは、createRequirements サービス、updateRequirements サービス、および updateRequirementsByExtID サービスを使用して、Silk Central へアップロードすることができる要件の例を示しています。

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
親トピック: Services Exchange


updateRequirementsByExtID インターフェイス

updateRequirementsByExtID インターフェイスは、XML ファイルから既存のルート ノードに対して要件を更新します。要件は、外部 ID で識別されます。要件ツリー ノードと、そのノードのすべての子が更新されます。Silk Central において、新しいノードは追加され、紛失しているノードは廃止 (obsolete) となり、移動されたノードは単純に移動されます。すべての呼び出しの HTTP の応答には、変更された要件の XML 構造が含まれます。新しいコードの識別子は、更新された XML 要件の構造から取得できます。

次の表は、updateRequirementsByExtID インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=updateRequirementsByExtID | sid | セッション ID – ユーザー認証
 | nodeID | 更新される要件ツリー内のノード ID
 | userName | 省略可能：ユーザー名 - sid の代わりに使用
 | passWord | 省略可能：ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=updateRequirementsByExtID&nodeID=<id>&userName=<user>&passWord=<password>

要件を検証するために使用される XML スキーマ定義ファイルは、フロントエンド サーバー URL http://<フロントエンド URL>/silkroot/xsl/requirements.xsd を使用してダウンロードするか、フロントエンド サーバーのインストール フォルダ <Silk Central インストール フォルダ>/wwwroot/silkroot/xsl/requirements.xsd からコピーできます。

updateRequirementsByExtID Web サービスの例

以下のコードでは、Apache HttpClient を使用して、要件が更新されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",&nodeID=%s",
    "updateRequirementsByExtID",
    sessionID, rootNodeId));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
string xmlFile = loadRequirementsUtf8(fileName);
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

要件の例

次のコードは、createRequirements サービス、updateRequirements サービス、および updateRequirementsByExtID サービスを使用して、Silk Central へアップロードすることができる要件の例を示しています。

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
親トピック: Services Exchange


createExecutionDefinitions インターフェイス

createExecutionDefinitions インターフェイスは、新しい実行計画を作成するために使用されます。すべての呼び出しの HTTP の応答には、変更された実行計画の XML 構造が含まれます。新しいコードの識別子は、更新された XML 実行計画の構造から取得できます。

次の表は、createExecutionDefinitions インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=createExecutionDefinitions | sid | セッション ID – ユーザー認証
 | parentNodeID | 新しい実行計画を追加する実行ツリー ノードの ID
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=createExecutionDefinitions&parentNodeID=<id>&userName=<user>&passWord=<password>

実行を検証するために使用される XML スキーマ定義ファイルは、フロントエンド サーバー URL http://<フロントエンド URL>/silkroot/xsl/executionplan.xsd を使用してダウンロードするか、フロントエンド サーバーのインストール フォルダ <Silk Central インストール フォルダ>/wwwroot/silkroot/xsl/executionplan.xsd からコピーできます。

createExecutionDefinitions Web サービスの例

以下のコードでは、Apache HttpClient を使用して、実行計画が作成されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createExecutionDefinitions", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadExecutionDefinitionsUtf8("executionplan.xml");
StringPart xmlFileItem = new StringPart("executionplan", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

実行計画の例

次のコードは、createExecutionDefinitions サービス、および updateExecutionDefinitions サービスを使用して Silk Central へアップロードすることができる実行計画の例を示しています。この例では、実行計画の 1 つにカスタム スケジュールを作成し、テストを実行計画に割り当てます (共に、手動割り当てとフィルタを使用)。この例では、構成を含んだ構成スイートも作成されます。

<ExecutionPlan xmlns="http://www.borland.com/ExecPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/executionplan.xsd">

  <Folder name="Folder1">
    <Description>Description of the folder</Description>
    <ExecDef name="ExecutionDefinition1" TestContainerId="1">
      <Description>Description1</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <forever>true</forever>
        </end>
        <Interval day="1" hour="2" minute="3"></Interval>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>
      <ReadFromBuildInfoFile>true</ReadFromBuildInfoFile>
      <Priority>High</Priority>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ExecDef>
    <ExecDef name="ExecutionDefinition2" TestContainerId="1">
      <Description>Description2</Description>
      <Build>1</Build>
      <Version>1</Version>
      <Priority>Low</Priority>
      <SourceControlLabel>Label1</SourceControlLabel>
      <DependentExecDef id="65">
        <Condition>Passed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Server" id="1"/>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="70">
        <Condition>Failed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="68">
        <Condition>Any</Condition>
        <Deployment>
          <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
        </Deployment>
      </DependentExecDef>
    </ExecDef>

    <ConfigSuite name="ConfigSuite1" TestContainerId="1">
      <Description>ConfigSuite1 desc</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <times>1</times>
        </end>
        <Interval day="1" hour="2" minute="3"/>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>

      <ConfigExecDef name="Config1">
        <Description>Config1 desc</Description>
        <Priority>Medium</Priority>
      </ConfigExecDef>

      <ConfigExecDef name="Config2">
        <Priority>Medium</Priority>
        <DependentExecDef id="69">
          <Condition>Any</Condition>
          <Deployment>
            <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
          </Deployment>
        </DependentExecDef>
      </ConfigExecDef>

      <Build>8</Build>
      <Version>2</Version>
      <SourceControlLabel>ConfigSuite1 label</SourceControlLabel>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ConfigSuite>
  </Folder>
</ExecutionPlan>
親トピック: Services Exchange


exportExecutionDefinitions インターフェイス

exportExecutionDefinitions インターフェイスは、実行計画を XML ファイルにエクスポートするために使用されます。次の表は、exportExecutionDefinitions インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=exportExecutionDefinitions | sid | セッション ID – ユーザー認証
 | nodeID | この ID のノードと、このノードの子ノードすべてが、再帰的にエクスポートされます。
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=exportExecutionDefinitions&nodeID=<id>&userName=<user>&passWord=<password>

exportExecutionDefinitions Web サービスの例

以下のコードでは、Apache HttpClient を使用して、実行計画がエクスポートされます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportExecutionDefinitions", sessionID,
  NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedExecutionPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedExecutionPlanResponse);

Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

親トピック: Services Exchange


updateExecutionDefinitions インターフェイス

updateExecutionDefinitions インターフェイスは、XML ファイルから実行計画を更新するために使用します。すべての呼び出しの HTTP の応答には、変更された実行計画の XML 構造が含まれます。新しいコードの識別子は、更新された XML 実行計画の構造から取得できます。

次の表は、updateExecutionDefinitions インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=updateExecutionDefinitions | sid | セッション ID – ユーザー認証
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=updateExecutionDefinitions&userName=<user>&passWord=<password>

実行を検証するために使用される XML スキーマ定義ファイルは、フロントエンド サーバー URL http://<フロントエンド URL>/silkroot/xsl/executionplan.xsd を使用してダウンロードするか、フロントエンド サーバーのインストール フォルダ <Silk Central インストール フォルダ>/wwwroot/silkroot/xsl/executionplan.xsd からコピーできます。

updateExecutionDefinitions Web サービスの例

以下のコードでは、Apache HttpClient を使用して、実行計画が更新されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
string xml = loadExecutionPlanUtf8(DEMO_EXECUTION_PLAN_XML);
HttpClient client = new HttpClient();

URL webServiceUrl = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateExecutionDefinitions",
    sessionID));
StringPart ExecutionPlanXml = new StringPart(DEMO_EXECUTION_PLAN_XML, xml,
  "UTF-8");
ExecutionPlanXml.setContentType("text/xml");
Part[] parts = {ExecutionPlanXml};
PostMethod filePost = new PostMethod(webServiceUrl.toExternalForm());
filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

リクエスト毎に 1 つの添付ファイルのみアップロードすることができます。Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

実行計画の例

次のコードは、createExecutionDefinitions サービス、および updateExecutionDefinitions サービスを使用して Silk Central へアップロードすることができる実行計画の例を示しています。この例では、実行計画の 1 つにカスタム スケジュールを作成し、テストを実行計画に割り当てます (共に、手動割り当てとフィルタを使用)。この例では、構成を含んだ構成スイートも作成されます。

<ExecutionPlan xmlns="http://www.borland.com/ExecPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/executionplan.xsd">

  <Folder name="Folder1">
    <Description>Description of the folder</Description>
    <ExecDef name="ExecutionDefinition1" TestContainerId="1">
      <Description>Description1</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <forever>true</forever>
        </end>
        <Interval day="1" hour="2" minute="3"></Interval>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>
      <ReadFromBuildInfoFile>true</ReadFromBuildInfoFile>
      <Priority>High</Priority>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ExecDef>
    <ExecDef name="ExecutionDefinition2" TestContainerId="1">
      <Description>Description2</Description>
      <Build>1</Build>
      <Version>1</Version>
      <Priority>Low</Priority>
      <SourceControlLabel>Label1</SourceControlLabel>
      <DependentExecDef id="65">
        <Condition>Passed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Server" id="1"/>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="70">
        <Condition>Failed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="68">
        <Condition>Any</Condition>
        <Deployment>
          <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
        </Deployment>
      </DependentExecDef>
    </ExecDef>

    <ConfigSuite name="ConfigSuite1" TestContainerId="1">
      <Description>ConfigSuite1 desc</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <times>1</times>
        </end>
        <Interval day="1" hour="2" minute="3"/>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>

      <ConfigExecDef name="Config1">
        <Description>Config1 desc</Description>
        <Priority>Medium</Priority>
      </ConfigExecDef>

      <ConfigExecDef name="Config2">
        <Priority>Medium</Priority>
        <DependentExecDef id="69">
          <Condition>Any</Condition>
          <Deployment>
            <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
          </Deployment>
        </DependentExecDef>
      </ConfigExecDef>

      <Build>8</Build>
      <Version>2</Version>
      <SourceControlLabel>ConfigSuite1 label</SourceControlLabel>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ConfigSuite>
  </Folder>
</ExecutionPlan>
親トピック: Services Exchange


createLibraries インターフェイス

createLibraries インターフェイスは、新しいライブラリを作成するために使用されます。すべての呼び出しの HTTP の応答には、変更されたライブラリの XML 構造が含まれます。新しいコードの識別子は、更新された XML ライブラリの構造から取得できます。

次の表は、createLibraries インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=createLibraries | sid | セッション ID – ユーザー認証
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用

例：http://<front-end URL>/servicesExchange?hid=createLibraries&userName=<user>&passWord=<password>

ライブラリを検証するために使用される XML スキーマ定義ファイルは、フロントエンド サーバー URL http://<フロントエンド URL>/silkroot/xsl/libraries.xsd を使用してダウンロードするか、フロントエンド サーバーのインストール フォルダ <Silk Central インストール フォルダ>/wwwroot/silkroot/xsl/libraries.xsd からコピーできます。

createLibraries Web サービスの例

以下のコードでは、Apache HttpClient を使用して、ライブラリが作成されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s",
  "createLibraries", sessionID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadTestPlanUtf8("libraries.xml");
StringPart xmlFileItem = new StringPart("libraries", xmlFile, "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts, filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

ライブラリの例

次のコードは、createLibraries サービスを使用して Silk Central へアップロードすることができるライブラリの例を示しています。GrantedProjects セクションで 1 つまたは複数のプロジェクトが定義されている場合を除き、新しいライブラリは特定のプロジェクトでの使用に限定されません。

<LibraryStructure xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/libraries.xsd">

  <Library name="Library 1">
    <Folder name="Folder 1">
      <Folder name="Folder 1.1">
        <SharedSteps name="Basic create user steps">
          <Step name="Login">
            <ActionDescription>
              Login with user admin.
            </ActionDescription>
            <ExpectedResult>Succesful login.</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
          <Step name="Create User">
            <ActionDescription>Create user tester</ActionDescription>
            <ExpectedResult>User created</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
          <Step name="Logout">
            <ActionDescription>
              Logout using start menu
            </ActionDescription>
            <ExpectedResult>Logged out.</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
        </SharedSteps>
      </Folder>
    </Folder>
    <GrantedProjects>
      <ProjectId>0</ProjectId>
      <ProjectId>1</ProjectId>
    </GrantedProjects>
  </Library>
</LibraryStructure>
親トピック: Services Exchange


exportLibraryStructure インターフェイス

exportLibraryStructure インターフェイスは、ライブラリ、フォルダ、および共有ステップ オブジェクトを XML ファイルとしてエクスポートするために使用します。次の表は、exportLibraryStructure インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=exportLibraryStructure | sid | セッション ID – ユーザー認証
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用
 | nodeID | エクスポートされるライブラリ ツリー内のライブラリ ノードまたはフォルダ。共有ステップ ノードの ID は使用できません。

例：http://<front-end URL>/servicesExchange?hid=exportLibraryStructure&userName=<user>&passWord=<password>&nodeID=<id>

exportLibraryStructure Web サービスの例

以下のコードでは、Apache HttpClient を使用して、ライブラリがエクスポートされます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportLibraryStructure", sessionID, NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

親トピック: Services Exchange


exportLibraryStructureWithoutSteps インターフェイス

exportLibraryStructureWithoutSteps インターフェイスは、ライブラリ、フォルダ、および共有ステップ オブジェクトを XML ファイルとしてエクスポートするために使用します。共有ステップ オブジェクトに含まれているステップはエクスポートされません。次の表は、exportLibraryStructureWithoutSteps インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=exportLibraryStructureWithoutSteps | sid | セッション ID – ユーザー認証
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用
 | nodeID | エクスポートされるライブラリ ツリー内のライブラリ ノードまたはフォルダ。共有ステップ ノードの ID は使用できません。

例：http://<front-end URL>/servicesExchange?hid=exportLibraryStructureWithoutSteps&userName=<user>&passWord=<password>&nodeID=<id>

exportLibraryStructureWithoutSteps Web サービスの例

以下のコードでは、Apache HttpClient を使用して、ライブラリがエクスポートされます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportLibraryStructureWithoutSteps", sessionID, NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

親トピック: Services Exchange


getLibraryInfoByName インターフェイス

getLibraryInfoByName インターフェイスは、指定された名前を持つすべてのライブラリの ID、名前、および説明を返します。このインターフェイスは、ライブラリの構造ではなく、プロパティのみを返します。次の表は、getLibraryInfoByName インターフェイスのパラメータを表しています。

インターフェイス URL | パラメータ | 説明
http://<front-end URL>/servicesExchange?hid=getLibraryInfoByName | sid | セッション ID – ユーザー認証
 | userName | 省略可能： ユーザー名 - sid の代わりに使用
 | passWord | 省略可能： ユーザー パスワード - sid の代わりに使用
 | libraryName | ライブラリの名前

例：http://<front-end URL>/servicesExchange?hid=getLibraryInfoByName&userName=<user>&passWord=<password>&libraryName=<name>

getLibraryInfoByName Web サービスの例

以下のコードでは、Apache HttpClient を使用して、ライブラリ情報が取得されます。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s",
  "getLibraryInfoByName", sessionID, LIBRARY_NAME));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String response = fileGet.getResponseBodyAsString();
System.out.println(response);

Apache HttpComponents をダウンロードするには、http://hc.apache.org/downloads.cgi を参照してください。必要なライブラリについては、コンポーネントのドキュメントを参照してください。

親トピック: Services Exchange


Web サービス デモ クライアント

Web サービス デモ クライアントは、Silk Central Web サービスの使用方法をデモンストレーションするためのツールです。 クライアントを ヘルプ > ツール からダウンロードします。

Web サービス デモ クライアントでは、テスト > テスト属性 で利用できるすべての属性をテストごとに、すべてのプロパティを利用可能なテスト タイプごとに表示します。
重要: Web サービス デモ クライアントは、Web サービスの使用方法をデモンストレーションするために設計されました。 このデモ クライアントを運用環境では使用しないでください。
親トピック: Silk Central の Web サービス


Micro Focus へのお問い合わせ

Micro Focus は、世界的規模のテクニカル サポートおよびコンサルティング サービスを提供します。すべての顧客のビジネスを成功に導くために、信頼できるサービスをタイムリーに提供するように、Micro Focus はワールドワイドのサポート体制を整えています。

保守およびサポート契約を結んだすべてのお客様、および製品を評価中のお客様は、カスタマー サポートを受けることができます。高度なトレーニングを積んだスタッフが、お客様の質問にできる限り迅速かつ専門的にお答えします。

http://supportline.microfocus.com/assistedservices.asp にアクセスするか、またはメールを supportline@microfocus.com に送信して、Micro Focus SupportLine と直接連絡できます。

また、http://supportline.microfocus.com の Micro Focus SupportLine では、 最新のサポートに関するニュースや、さまざまなサポート情報を得ることができます。 このサイトに初めてアクセスした場合は、ユーザー登録が必要な場合があります。

  • Micro Focus SupportLine が必要とする情報
    お客様の問題を解決するために役立つ Micro Focus SupportLine が必要とする情報について説明します。
  • システム診断
    システム診断を表示およびダウンロードする方法について説明します。


Micro Focus SupportLine が必要とする情報

Micro Focus SupportLine をご利用の場合は、可能な限り次の情報を提供ください。情報が多ければ多いほど、Micro Focus SupportLine はお客様に適切なサービスを提供できます。

  • 問題の原因と思われるすべての製品の名前およびバージョン番号
  • 使用しているコンピュータの製造元およびモデル
  • システム情報 (オペレーティング システムの名前やバージョン、プロセッサやメモリの詳細など)
  • 問題の詳細な説明 (問題の再現手順など)
  • 発生したエラー メッセージ
  • お客様のシリアル番号

これらの番号は、Micro Focus から受け取った Electronic Product Delivery Notice 電子メールの件名および本文に記述されています。

親トピック: Micro Focus へのお問い合わせ
関連概念
システム診断


HTML 応答の圧縮の有効化/無効化を切り替える

HTML 応答の圧縮の有効化/無効化を切り替えるには：

  1. インスタンス管理 ページで、変更するインスタンスのフロントエンド サーバーを停止します。
  2. Server.xml ファイルをテキスト エディタで開きます。 このファイルは、フロントエンド サーバー上の Silk Central ディレクトリの /conf/frontendserver フォルダにあります。
  3. Connector という XML タグを探します。
  4. compression="on" および compressableMimeType="text/html,text/xml,text/plain,text/css,text/javascript,application/xml" をコネクタに追加します。
    サーブレットが応答を gzip で圧縮するようになります。 gzip は、Apache Tomcat Native から取得します。
  5. XML ファイルを保存して閉じます。
  6. フロントエンド サーバーを再起動します。
関連タスク
インスタンスの管理


Reuse_Creating or Editing Tests

テストを新規作成するには：

  1. メニューで テスト > 詳細ビュー をクリックします。
  2. 新規のテストの挿入先となるコンテナまたはフォルダを、テスト ツリーから選択するか、編集するテストを選択します。
  3. ツールバーで 子テストの新規作成 (子テストの新規作成) をクリックするか、 [image] (編集) をクリックします。

    テストの新規作成、または テストの編集 ダイアログ ボックスが表示されます。

  4. [名前] フィールドと [説明] フィールドに、テストの名前と説明をそれぞれ入力します。
    注: Silk Central では、HTML 書式をサポートしており、説明 フィールドへの HTML コンテンツの切り取り/貼り付けが可能です。
  5. タイプ リストからテスト タイプを選択します。
  6. 次へ をクリックして、「テストのプロパティを設定する」の、選択したテスト タイプに該当するトピックに進みます。
注: 明確に定義された Silk Central の公開 API を使用して、ユーザーの自動テストの要求を満たすような独自のソリューションを実装できます。 Silk Central はオープンであり、Java 実装から呼び出されたり、コマンド ライン呼び出しを介して実行される外部ツールに対して拡張可能です。
注: テスト設定プロセスの全体を通して、すべてのテスト タイプには 親から継承 チェック ボックスがあります。これによって、既存の任意の親エンティティの設定を継承できます。