欢迎使用 Silk Central 18.5

欢迎使用 Silk Central

  • 体系结构
  • 许可
  • UI 教程
  • 快速启动任务
  • 安装帮助

新增功能

  • Silk Central 的新增功能
  • 发行说明

特色部分

  • 我的仪表板
  • 手动执行计划
  • 质量目标

教程和演示

  • 快速启动任务
  • 手动执行计划演练
  • 我们培训商店中的免费 Web 培训

代码示例

  • API 帮助

联机资源

  • Micro Focus 主页
  • Micro Focus YouTube 频道
  • Micro Focus 在线文档
  • Micro Focus SupportLine
  • Micro Focus 产品更新
  • Silk Central 知识库
  • Silk Central 社区论坛
  • Micro Focus 按需培训

提供反馈

  • 联系Micro Focus
  • 有关此帮助，请通过电子邮件向我们发送反馈


安装和系统配置帮助

安装和系统配置帮助提供安装和卸载 Silk Central 所需的全部信息。它还会引导您设置 Silk Central 基础架构。

  • Silk Central 体系结构
    本节提供 Silk Central 的体系结构概述。
  • 安装 Silk Central
    Silk Central 安装 DVD 和安装程序使您能够安装所有的 Silk Central 软件组件。
  • 配置和管理基础架构
    实例及其 Silk Central 服务是通过称为实例管理的常用用户界面来管理的，您只能在安装 Silk Central 的服务器上访问该界面（使用 URL http://localhost:19100）。


Silk Central 体系结构

本节提供 Silk Central 的体系结构概述。

Silk Central 服务器

执行 Silk Central 安装程序的服务器。

实例管理

实例及其 Silk Central 服务是通过称为实例管理的常用用户界面来管理的，您只能在安装 Silk Central 的服务器上访问该界面（使用 URL http://localhost:19100）。

实例

实例是指一组独立的 Silk Central 服务（应用程序服务器 (AS)、前端服务器 (FE) 和图表服务器 (CS)），这些服务拥有自己的数据库和执行服务器 (ES) 连接。默认情况下，Silk Central 为您创建一个名为 silk 的实例。默认 URL 为 http://<计算机名称>:19120/login（如果 Silk Central 在 IIS 上运行，则无需提供端口信息）。如果您需要以物理方式将不同客户端的测试数据和进程分开，以便提高数据安全性并减少独立用户组对彼此（如部门）的影响，可以创建附加实例。有了客户端的帮助，您可从逻辑上将一个实例的数据进一步分隔到一个数据库中。

代理

代理服务安装在 Silk Central 服务器上，以便控制对不同实例的访问。每个实例的服务都在指定端口上运行，但出于安全和提高灵活性考虑，代理会将实例名称传送给 http://<Silk Central 服务器>:19120/<实例名称> 形式的实际 URL。

应用程序服务器 (AS)

应用程序服务器可同步任务，例如，计划的分发、执行服务器的控制以及数据库配置的管理。这些任务需要集中式代理来确保一致、可靠的应用程序行为。应用程序服务器还会评估结果、将结果保存到数据库中并根据成功条件发送警报。应用程序服务器对默认实例使用端口 19122。每增加一个实例，该值增加 100。

前端服务器 (FE)

前端服务器负责图形用户界面。此服务器基于 HTML，可通过任何 Web 浏览器（例如 Internet Explorer、Firefox 和 Chrome）来访问。用户将适当的 HTTP 请求发送到前端服务器之后，将收到登录页面以进行身份验证。成功登录后，用户可根据各自的用户权限使用相应的应用程序。前端服务器可作为独立 HTTP 服务器工作，也可以将它连接到 Web 服务器，例如 IIS。前端服务器对默认实例使用端口 19110。第二个实例使用端口 19220，每增加一个实例，该值增加 100。对于使用 SSL 的安全连接，服务器还会使用端口 443。前端服务器可以通过 URL http://<Silk Central 服务器>:19120/<实例名称> 来访问（默认实例不需要实例名称）。

图表服务器 (CS)

图表服务器用于生成在报告中查看的图表。系统允许配置图表服务器池。内置负载平衡机制使用池来分发图表生成。图表服务器还可用于生成报告并将其直接提供给最终用户以在浏览器中进行查看。图表服务器对默认实例使用端口 19126。每增加一个实例，该值增加 100。

执行服务器 (ES)

执行服务器用于执行由授权用户计划的自动测试。用户负责正确配置测试执行所需的执行服务器以及其他资源。系统允许安装和配置彼此独立工作的多个执行服务器。执行服务器对默认实例使用端口 19124。对于使用 SSL 的安全连接，服务器还会使用端口 19125。

代理计算机：

可从控制器计算机的可用代理计算机池中将 Silk Test Classic 和 代理计算机分配到特定 或 Silk Performer 项目。与 Silk Central 结合使用时，控制器计算机可用作执行服务器。
Silk Performer 代理
Silk Performer 代理计算机用于托管负载测试期间运行的虚拟用户。可根据需要将尽可能多的代理计算机添加到 Silk Performer 项目，以便运行所需数量的虚拟用户。代理配置通过 Silk Performer 完成。有关配置代理的详细信息，请参阅 Silk Performer 文档。
Silk Test Classic 代理
适用于 Silk Test Classic 代理的相同规则也适用于 代理，但 代理主机 Silk Performer 测试除外。

数据库服务器 (DB)

系统持久性使用 RDBMS（关系数据库管理系统）来实现。数据库服务器使用端口 1433 (SQL Server) 或 1521 (Oracle)。

Silk Meter 许可证服务器

Silk Meter 是 Silk 产品随附的许可软件，用于决定您可以访问的 Silk Central 应用程序功能。有关许可的更多信息，请参阅各产品的安装指南。Silk Meter 使用端口 5461。

客户端

客户端是 Silk Central 实例中的不同单元。例如，公司内部的客户端可以是客户，也可以是部门。客户端可以增强安全性，但与实例相比，它们共享相同的数据库和 Silk Central 服务。 每个客户端包含以下主要实体：
  • 用户角色和权限
  • 用户组和用户帐户
  • 项目
  • 位置、执行服务器和代理计算机
  • 带有组件的产品、版本和内部版本
  • 全局计划

项目

Silk Central 中的项目通常会反映出贵公司中的软件项目，分别是开发团队的工作，有通用的发行日期、通用的源代码管理系统、通用需求等。 每个项目包含以下主要实体：
  • 筛选器
  • 属性
  • 需求属性
  • 步骤属性
  • 通知
  • 集成需求和问题跟踪工具
  • 集成源代码管理系统
  • 数据源
  • 状态原因

重要的文件位置

  • 实例管理和执行服务器日志文件：C:\ProgramData\SilkCentral\log
  • 应用程序、前端和图表服务器的日志文件：C:\ProgramData\SilkCentral\instance_<实例编号>_<实例名称>\log
  • 修补程序的位置：C:\Program Files (x86)\18.5\Silk\hotfixes
  • 配置文件：C:\Program Files (x86)\18.5\Silk\instance_<实例编号>_<实例名称>\Conf
  • 插件：C:\Program Files (x86)\18.5\Silk\instance_<实例编号>_<实例名称>\Plugins
  • Office 导入映射文件：C:\ProgramData\SilkCentral\instance_<实例编号>_<实例名称>\OfficeImportMappingFiles
父主题： 安装和系统配置帮助
相关任务
管理实例
管理客户端
管理项目


安装 Silk Central

Silk Central 安装 DVD 和安装程序使您能够安装所有的 Silk Central 软件组件。

要安装 Silk Central，您的计算机系统必须满足最低要求。安装程序将检查您的系统并选择性地安装任何必需的软件。

注： 您必须具有计算机的管理权限才能安装 Silk Central。
  • 系统要求和先决条件
    为了获得 Silk Central 的最佳性能，我们建议使用本节概述的配置。
  • 安装 Silk Central 进行评估
    设置独立安装，将所有功能安装在单个计算机上。此安装类型仅用于评估或演示目的。
  • 安装 Silk Central
    安装 DVD 和安装程序使您能够安装所有的 Silk Central 软件组件。
  • 安装 Windows 执行服务器
    安装 Windows 执行服务器以在远程计算机上执行测试。
  • 安装 Linux 执行服务器
    安装 Linux 执行服务器以在远程计算机上执行测试。
  • 安装修补程序
    有修补程序可用时，请使用最新修补程序更新您的实例。
  • 升级到 Silk Central18.5
    升级到 Silk Central18.5，以便从增强功能中获益。
  • Silk Central 许可
    获取许可证策略并授予产品许可，以获得完整的 Silk Central 功能和支持。
  • 已测试和支持的软件
    列出已测试 Silk Central 18.5 的软件以及 Silk Central 支持的软件。
父主题： 安装和系统配置帮助
相关概念
系统要求和先决条件


系统要求和先决条件

为了获得 Silk Central 的最佳性能，我们建议使用本节概述的配置。

服务器系统需求

系统领域 | 需求
CPU | Intel Core i5 或更高
内存 | 最小 8 GB
可用光盘空间 | 最小 30 GB，数据库服务器除外
网络 | 100 Mbit
操作系统，数据库管理系统，Web 服务器 | 请参阅已测试和支持的软件。
电源 | 适用于所有环境的不间断电源 (UPS)，以降低停电风险
对于您添加的各个附加实例，至少需要 10 GB 的额外磁盘空间及以下最小初始内存：
  • 前端服务器：500 MB
  • 应用程序服务器：300 MB
  • 图表服务器：200 MB
根据您的工作负载，这些值可能需要增加。

有关 Silk Central 最佳配置的更多信息，请联系技术支持人员或技术客户团队。

执行服务器需求

执行服务器的实际需求和先决条件取决于被测应用程序 (AUT) 和测试类型。

有关负载测试，请参阅 Silk Performer 的环境需求。运行具有最小配置的负载测试可能会导致结果不准确。

有关功能测试，请参阅 Silk Test 的环境需求。我们建议密集测试的主内存最小为 2048 MB，例如 Web 浏览器回放。

Linux 执行服务器需要 Java Runtime Environment (JRE) 8。

代理服务器需求

如果您计划对 Silk Central 使用 Microsoft IIS，请在安装 Silk Central 之前安装以下 IIS 扩展：
  • 应用程序请求路由 (ARR)
  • URL 重写
您可从 IIS 下载页中下载这些扩展的最新版本。

虚拟化

测试 Silk Central 以便在 VMware vSphere 服务器虚拟基础结构环境中运行。

客户端系统需求

系统领域 | 需求
处理器 | Intel Core i3 或更高
内存 | 2 GB
Web 浏览器
  • Google Chrome
  • Internet Explorer 10 或更高版本（无兼容模式）
  • Mozilla Firefox
  • Microsoft Edge

手动测试 UI 需要 Java Runtime Environment (JRE) 7 Update 79 或更高版本。

父主题： 安装 Silk Central


安装 Silk Central 进行评估

在开始之前，请先下载 Silk Central 可执行文件，或将 Silk Central DVD 插入驱动器。
注： 因为安装 Microsoft SQL Server Express 需要管理权限，如果已启用 UAC，安装将会失败。在想要安装 Silk Central 以进行评估的计算机上禁用 UAC。

设置独立安装，将所有功能安装在单个计算机上。独立安装并不提供 Silk Central 的全部性能。此安装类型仅用于评估或演示目的。

注： 在 Microsoft Windows Server 2008 R2、Microsoft Windows Server 2008 R2 SP1 或 Microsoft Windows Server 2012 上安装 Silk Central 的过程中，不能执行 .NET Framework 3.5 SP1 安装。如果您的系统上未安装 .NET Framework 3.5 SP1，您的操作系统是 Microsoft Windows Server 2008 R2、Microsoft Windows Server 2008 R2 SP1 或 Microsoft Windows Server 2012，并且您想要安装 的评估版本，请先通过 Windows Server Manager 在您的系统上安装 .NET Framework 3.5 SP1，然后再安装 Silk Central。
  1. 找到并双击 Silk Central 可执行文件。
    InstallShield 向导将会打开。
  2. 按照安装向导指示，在每个对话框中单击Next或OK，确认所有默认设置。
  3. 在选择许可模式对话框上，保留默认设置（Evaluation）。 Silk Central 需要一个数据库存储库。为了便于评估，我们推荐您使用作为 Silk Central 的一部分安装的 Microsoft SQL Server Express。确保选中Install Microsoft SQL Server 2008 Express SP1 复选框。
  4. 单击Next来完成安装。
父主题： 安装 Silk Central
相关概念
系统要求和先决条件
Silk Central 许可


安装 Silk Central

在开始之前，请先下载 Silk Central 可执行文件，或将 Silk Central DVD 插入驱动器。 确保您的系统满足系统需求和前提条件。

  1. 找到并双击 Silk Central 可执行文件。
    如果您有 Silk Central DVD，请插入您的 DVD。如果安装程序未自动启动，请手动启动 Silk Central 安装程序，方法是选择开始 > 运行并输入 <DVD 驱动盘>:\setup.exe。 InstallShield 向导将会打开。
  2. 向导的欢迎使用页面将会打开。向导将指导您完成安装过程。单击下一步以继续。
  3. 选择要使用的语言，然后单击下一步。 此时将打开许可协议。
  4. 仔细阅读许可协议。如果您接受协议条款，请单击我接受许可协议的条款。
    此时将打开安装类型页面。
  5. 要安装 Silk Central 执行服务器，请选中Install Execution Server 复选框。要使用 Microsoft Internet Information Services (IIS)，请选中Use Microsoft Internet Information Services 复选框。 默认安装目标位置将显示在安装类型页面的目标位置路径部分。要更改默认安装路径，请执行以下步骤：
    1. 单击浏览。 此时将打开选择文件夹对话框。
    2. 指定要在其中安装 Silk Central 的文件夹，然后单击确定以返回安装类型页面。
    注： Silk Central 必须安装在本地驱动器上。如果您指定了无效的安装目标位置，则会显示一则错误消息。
  6. 单击下一步以继续。 安装选项摘要页面将列出您选择的设置。
  7. 复查所提供的信息并执行以下步骤之一：
    • 要更改任何设置，请单击返回以返回相应的页面。
    • 如果您对设置感到满意，请单击下一步以开始安装过程。
    安装状态页面上的状态栏提供有关安装进度的信息。完成后，将打开选择许可模式页面。
  8. 单击以下选项按钮之一：
    • 评估 – 安装 Silk Central 的评估版本，它在 45 天内为您提供完整的产品功能。限于 10 个 Silk Central 用户和 10 个 Issue Manager 用户使用。要在以后的时间升级到完整版本，请联系您的销售代表。选中安装 Microsoft SQL Server 2008 Express SP1 复选框以另外安装 Microsoft SQL Server 2008 Express SP1。
    • 已许可 – 安装需要许可证的 Silk Central 无限制版本。
  9. 单击下一步。
    根据您为安装选择的组件，将打开相应的许可页面。如果您未安装任何需要许可的组件并且未打开此页面，请继续执行下一步。 要安装许可证文件，请执行以下步骤：
    1. 单击确定以指定许可证文件的位置。 许可证实用程序将检查本地系统中是否存在 Silk Meter 许可证服务器配置文件。如果找到文件，则会显示许可证服务器的配置和类型，并将其用于许可。如果未找到任何配置数据，则选择 Silk Meter 许可证服务器页面将显示默认设置。 此页面提供有关 Silk Meter 许可的一般信息。有关 Silk Meter 许可的详细信息，请单击打开 Silk Meter 自述文件。此操作将会在默认浏览器中打开 Silk Meter 文档。
      注： 如果安装源目录中未提供该文档，则无法使用打开 Silk Meter 自述文件。当安装 Silk Central Web 程序包时，该文档通常不可用。
    2. 从应用程序列表框中，选择 Silk Central 作为您要许可的应用程序。
    3. 单击以下选项按钮之一：
      使用本地或远程服务器
      在许可证服务器主机文本框中，键入在其上安装 Silk Meter 的计算机的名称。请不要修改默认端口号 5461，除非您的网络管理员定义了不同的端口。单击应用以生成许可证服务器配置。单击测试连接以验证是否可以通过指定的主机和端口访问 Silk Meter 服务器。在安装过程中，可能无法测试与许可证服务器的连接，这是因为稍后随软件程序包一起安装的系统库可能不可用。
      注： 在某些情况下，可能无法在许可证服务器主机文本框中指定许可证服务器的简单名称，例如 licenseserver。此时将会打开一个消息框，指明无许可证服务器在指定的主机名上运行。要解决此问题，请使用完全限定的名称指定主机名，例如 licenseserver.mycompany.com。
      未使用服务器（独立模式）
      运行 Silk Meter 独立模式。系统将提示您导入 Silk Meter 许可证文件。单击是以指定许可证文件的位置。
    4. 单击关闭以返回 InstallShield 向导。
  10. 单击完成以完成安装。
    注： 如果在安装过程中由于系统库被 Windows 锁定而导致 InstallShield 向导无法更新文件，或者如果 InstallShield 向导检测到必须重新启动系统，则系统将提示您重新启动计算机。如果您未重新启动计算机，则在访问 Silk Central 时可能会遇到问题。

实例管理页随即出现，您可以在其中配置 Silk Central 安装。有关其他信息，请参阅管理实例。

父主题： 安装 Silk Central
相关概念
系统要求和先决条件
Silk Central 许可
管理实例


安装 Windows 执行服务器

在您要用作远程 Silk Central 执行服务器的每个存在点 (POP) 上安装执行服务器。执行服务器在远程计算机上执行 Silk Central 测试。

  1. 在 Silk Central 菜单中，单击帮助 > 工具 > Windows 执行服务器，然后下载 Windows 执行服务器程序包。
  2. 找到并双击 Silk Central 可执行文件。
    InstallShield 向导将会打开。
  3. 请遵循“安装向导”上的说明。
  4. 单击完成以完成安装。
    注： 如果在安装过程中由于系统库被 Windows 锁定而导致 InstallShield 向导无法更新文件，或者如果 InstallShield 向导检测到必须重新启动系统，则系统将提示您重新启动计算机。如果您未重新启动计算机，则在访问 Silk Central 时可能会遇到问题。
父主题： 安装 Silk Central
相关概念
设置执行服务器
系统要求和先决条件
相关任务
安装 Linux 执行服务器


安装 Linux 执行服务器

此任务面向使用 Linux 的 Silk Central 用户。

在您要用作远程 Silk Central 执行服务器的每个存在点 (POP) 上安装执行服务器。执行服务器在远程计算机上执行 Silk Central 测试。

  1. 在 Silk Central 菜单中，单击帮助 > 工具 > Linux 执行服务器，然后下载 Linux 执行服务器程序包。
    注： Linux 执行服务器程序包不含 JRE。确保已安装 Java Runtime Environment (JRE) 8。您可以从 Java SE 下载 下载 JRE。
  2. 使用以下命令解压程序包文件 tar.gz：
    gzip -d <程序包文件名>.tar.gz

    然后使用以下命令解压 tar：

    tar xfz <程序包文件名>.tar

    程序包文件名为 LinuxExecServer-<版本>。

  3. 使用以下命令导航至提取程序包文件的目录：
    cd LinuxExecServer
  4. 使用以下命令启动执行服务器：
    ./startExecServer.sh
    注： 缓存信息和日志文件存储在主目录的隐藏文件夹 ~/.LinuxExecServer-<版本> 中。也可通过 Silk Central Web 界面访问 ExecServer.log 日志文件。
注： Linux 执行服务器目前支持的源代码管理系统包括 Subversion、Git 和 Apache Commons 虚拟文件系统 (VFS)。
不支持在 Linux 执行服务器上执行使用以下技术创建的测试：
  • 所有 Silk Test 技术
  • .NET Explorer
  • Unified Functional Testing
  • MSTest
  • NUnit
  • Silk Performer
  • TestPartner
  • Windows 脚本宿主
这些测试类型特定于 Microsoft Windows 操作系统的平台。
父主题： 安装 Silk Central
相关概念
设置执行服务器
相关任务
安装 Windows 执行服务器


安装修补程序

有修补程序可用时，请使用最新修补程序更新您的实例。
  1. 在安装 Silk Central 的计算机上，找到安装文件并双击它。
  2. 请遵循“安装向导”上的说明。
  3. 安装完毕后，打开浏览器并导航到 URL http://localhost:19100/（若未自动打开）。
    注： 无法从远程计算机中访问实例管理页。
    将出现实例管理页。此时，您应重置浏览器缓存，否则 JavaScript 和样式表中的修复可能不会激活。
  4. 在版本列中，单击安装修补程序 <版本> 链接以开始升级。 将出现一个对话框，供您激活维护模式。
  5. 输入用户在尝试访问 Silk Central 时会看到的通知文本，例如：Silk Central 当前不可用，因为我们正在执行更新。系统很快会恢复。单击是激活维护模式并开始升级。
  6. 完成更新后，单击 启动 来重新启动实例。
为要升级的每个实例重复实例管理步骤。
提示： 提醒您的用户重置浏览器缓存，否则 JavaScript 和样式表中的修复可能不会激活。
父主题： 安装 Silk Central
父主题： 管理实例


升级到 Silk Central18.5

Silk Central 18.5 安装程序会自动删除现有的安装，然后升级至 Silk Central 18.5。请勿使用 Windows 的添加或删除程序功能删除先前的 Silk Central 安装，因为这样做会删除您的自定义配置文件。

  1. 在开始升级到新版本之前，请先备份 Silk Central 数据库。
  2. 如果启用了 SSL，请制作一个证书文件的备份副本。根据运行前端服务器所用的模式，需要将证书重新导入以下某个 keystore：
    • 对于 64 位模式：C:\Program Files (x86)\18.5\Silk CentralSilk\instance_<实例编号>_<实例名称>\lib\jre64\lib\security\cacerts
    • 对于 32 位模式：C:\Program Files (x86)\18.5\Silk CentralSilk\instance_<实例编号>_<实例名称>\lib\jre\lib\security\cacerts
    有关附加信息，请参阅启用使用 SSL 的安全 Web 服务器连接。
  3. 安装 Silk Central。这将安装 NGINX 代理和实例管理。 要将执行服务器安装在与上述其中一个组件相同的计算机上，请将执行服务器和其他组件一起安装。 数据库设置会自动更新。有关配置文件中高级设置的详细信息，请参阅配置高级设置帮助。
    注： 对于大数据库，数据库事务日志的大小如果较小，可能导致更新期间出现错误。要避免错误，请将数据库事务日志的大小设为 5 GB。
  4. 安装完毕后，打开浏览器并导航到 URL http://localhost:19100/（若未自动打开）。
    注： 无法从远程计算机中访问实例管理页。
    将出现实例管理页。此时，您应重置浏览器缓存，否则 JavaScript 和样式表中的修复可能不会激活。
  5. 在版本列中，单击升级至 <版本> 链接以开始升级。 将出现一个对话框，供您激活维护模式。
  6. 输入用户在尝试访问 Silk Central 时会看到的通知文本，例如：Silk Central 当前不可用，因为我们正在执行更新。系统很快会恢复。 单击是激活维护模式并开始更新。
  7. 完成更新后，单击 启动 来重新启动实例。
为要升级的每个实例重复实例管理步骤。
提示： 提醒您的用户重置浏览器缓存，否则 JavaScript 和样式表中的修复可能不会激活。
父主题： 安装 Silk Central
相关概念
连接到数据库
相关任务
安装 Silk Central
安装 Windows 执行服务器
安装 Linux 执行服务器


Silk Central 许可

此部分介绍如何获取 Silk Central 的许可证策略以及如何安装 Silk Meter。 您必须拥有管理员权限才能安装 Silk Meter。

注： Silk Central 需要 Silk Meter 2008 或更高版本以及 Silk Central 许可证策略。

在每个许可证服务器上安装一次 Silk Meter。 如果您具有多个许可证服务器，则需要多个许可证策略文件，每个分别与特定许可证服务器关联。 单个 Silk Meter 许可证服务器可以管理多个产品的许可证策略。

如果您已收到 Silk Central 许可证策略，请在您的许可证服务器上安装许可证策略。 如果您未收到许可证策略，请生成许可证策略。

  • 许可证处理
    介绍 Silk Central 中使用的许可证类型以及何时签出或签入许可证。
  • 生成 Silk Central 许可证策略
    生成可导入 Silk Meter 的 Silk Central 许可证策略。
  • 查找主机 ID
    查找您希望安装许可证的计算机的主机 ID。您需要主机 ID 才能获得 Silk Central 许可证策略文件。
  • Silk Meter 安装
    说明您在安装 Silk Meter 许可证服务器软件前需要了解的信息。
  • Silk Meter 许可证服务器配置
    说明 Silk Meter 许可证服务器配置。
  • 修改许可证服务器配置
    如果 Silk Meter 许可证服务器的主机名称或端口发生更改，则可修改许可证服务器配置。
父主题： 安装 Silk Central
相关任务
在许可证服务器上安装 Silk Meter


许可证处理

Silk Central 提供不同的许可证类型。

每用户许可证

一旦用户进入 Silk Central 的某个区域，将从许可证服务器中签出这些许可证：

许可证类型 | 区域
Test Manager | 当您在登录后首次访问测试管理区域时，将签出此许可证。Silk Central 测试管理区域包括：需求、测试、执行计划、跟踪、问题（Issue Manager 区域除外）和报告。
手动测试 | 当您打开手动测试窗口时，将签出此许可证。 为脱机执行而下载测试时，将签出手动测试许可证。上载结果时，该许可证将重新签入。
问题跟踪 | 当您访问 Issue Manager 时，将签出此许可证。
请注意以下事项：
  • 除非已经为脱机测试签出手动测试许可证，否则当您单击注销（用户 > 注销）时，许可证将再次签入许可证服务器。
  • 如果您不注销（只关闭浏览器窗口），则许可证只会在会话过期时签入。

关于页面（帮助 > 关于）显示当前使用的许可证数量，以及您当前登录到的客户端上可用的许可证数量。

站点许可证

这些许可证支持所有用户无限制地使用特定的功能集：

许可证类型 | 区域
移动测试 | 这种许可证支持在移动设备（物理设备、仿真器和模拟器）上执行测试，包括手动测试、自动测试和配置测试。
父主题： Silk Central 许可
父主题： 客户端
相关概念
管理设备提供程序
相关任务
创建客户端
编辑客户端


生成 Silk Central 许可证策略

要使用 Silk Central 运行，您需要具备有效的许可证。如果您已购买 Silk Central，可以使用我们的在线许可证生成器来生成许可证策略文件。在线许可证生成器需要支持 SSL 的浏览器，如 Firefox 或 Internet Explorer。您将收到一封说明如何生成许可证策略文件的电子邮件。如果您未收到这些说明，请通过 http://support.microfocus.com 联系客户服务部门。

父主题： Silk Central 许可
相关概念
安装 Silk Central
相关任务
在许可证服务器上安装 Silk Meter


查找主机 ID

要获得许可证策略文件，您需要了解希望安装许可证的计算机的主机 ID。对于浮动许可证，这应该是一台安装了 Silk Meter 的许可证服务器。对于节点锁定许可证，这通常是一台控制器计算机。

  1. 在许可证服务器上，打开命令提示符并输入命令 ipconfig/all。 此时将列出网络适配器和附加信息。
  2. 记下主机 ID，这是 LAN 卡的 MAC 地址或物理地址，例如 00-BF-00-1C-D3-3D。
    提示： 根据系统设置的不同（包括虚拟机和 VPN 连接），计算机可能具有多个使用不同 MAC 地址的网络适配器。务必记下物理 LAN 卡的主机 ID。
父主题： Silk Central 许可


Silk Meter 安装

如果您有 Silk Central 许可证策略，则可以在安装 Silk Meter 时进行安装。如果您没有有效的 Silk Central 许可证，请访问在线许可证生成器来生成许可证策略文件。

无需任何许可证策略文件即可在您的许可证服务器上安装并运行 Silk Meter。但是，您必须首先导入许可证策略文件，然后才能使用Silk Central 。您可以使用 Silk Meter策略管理器 导入许可证策略文件。

如果您具有多个许可证服务器，则需要多个许可证策略文件，每个分别与特定许可证服务器关联。单个 Silk Meter 许可证服务器可以管理多个产品的许可证策略文件。

Silk Meter 许可证服务器需求

安装 Silk Meter 前，请参阅发行说明以确保许可证服务器符合需求。

  • 卸载早期版本的 Silk Meter
    安装最新版本前先卸载 Silk Meter。
  • 在许可证服务器上安装 Silk Meter
    安装 Silk Meter 许可软件以许可您的 Silk 产品。
父主题： Silk Central 许可
相关任务
生成 Silk Central 许可证策略


卸载早期版本的 Silk Meter

如果 Silk Meter 安装在许可证服务器上，则必须在安装 Silk Meter 的最新版本前将其卸载。

  1. 选择开始 > 程序 > Silk > Silk Meter > 卸载。
  2. 单击是以卸载 Silk Meter。 此时将打开删除设置对话框。
  3. 单击否以保留 Silk Meter 设置。
    注意： 您必须单击否以保留 Silk Meter 许可证服务器中当前存在的许可证策略。
  4. 重新启动计算机。
Silk Meter 已卸载，您现在可以安装 Silk Meter 的最新版本。
父主题： Silk Meter 安装


在许可证服务器上安装 Silk Meter

在安装 Silk Meter 之前，请验证以下信息：
  • 您的用户帐户具有管理员权限。
  • 您的许可证服务器上未安装 Silk Meter 的实例。
  1. 访问产品更新站点并搜索Silk Meter。
  2. 下载并保存最新的Silk Meter安装文件。
  3. 导航到您保存 .exe 文件的位置，双击文件。 对于标准安装，请遵循 Silk Meter 安装向导，使用默认选项即可。
    重要： 如果安装程序提示您重新启动计算机，请务必这么做。
父主题： Silk Meter 安装
相关任务
生成 Silk Central 许可证策略


Silk Meter 许可证服务器配置

要运行任何版本的 Silk Central，必须在网络内的计算上安装和配置 Silk Meter。

Silk Central 和 Silk Meter 之间的通信进程依赖于以下文件和变量：
  • SILK_CONFIG_PATH 环境变量
  • CosLicensingService.ref 文件
  • CosPropertyService.ref 文件
  • ls_segue.ref 文件
  • silkmeter.cfg 文件
重要： 不要删除这些文件。

Silk Central 安装程序根据您在选择 Silk Meter 许可证服务器实用程序的文本框中输入的值创建这些对象。

父主题： Silk Central 许可
相关概念
安装 Silk Central


修改许可证服务器配置

使用选择 Silk Meter 许可证服务器实用程序修改或修复您的许可证服务器配置。此实用工具将随您的Silk Central 安装一起安装。

  1. 选择开始 > 程序 > Silk > Silk Central 18.5 > 管理工具 > 更改您的许可证服务器配置。 此时将打开选择 Silk Meter 许可证服务器实用程序。
  2. 在应用程序列表框中，选择要为其配置许可证服务器的产品。
  3. 单击使用本地或远程服务器选项按钮以配置 Silk Meter 许可证服务器。
  4. 在许可证服务器主机文本框中，键入 Silk Meter 许可证服务器的计算机名称。 除非您的网络管理员已定义其他端口，否则不要更改端口号。
  5. 单击应用以激活许可证服务器配置。
  6. 单击测试连接以验证是否可以通过指定的主机和端口访问 Silk Meter 服务器。 如果连接成功，则状态文本框将显示成功消息。
    注： 在某些情况下，可能无法在许可证服务器主机文本框中指定许可证服务器的简单名称，例如 licenseserver。此时将会打开一个消息框，指明 Connection to Silk Meter license server failed。要解决此问题，请使用完全限定的名称指定主机名，例如 licenseserver.mycompany.com。
  7. 单击关闭以完成许可证服务器配置。
父主题： Silk Central 许可


已测试和支持的软件

本部分列出已测试 Silk Central18.5 的软件以及 Silk Central 支持的软件。

操作系统支持

  • Microsoft Windows 服务器 2012
  • Microsoft Windows 服务器 2012 R2
  • Microsoft Windows 服务器 2016
  • Microsoft Windows 7 （32 位/64 位）Service Pack 1（执行服务器）
  • Microsoft Windows 8.1 32 位/64 位（执行服务器）
  • Microsoft Windows 10 32 位/64 位（执行服务器）
  • Android 4.4、5.x、6.x、7.x、8.x（移动设备测试）
  • iOS 9.3、10.x、11.x（移动设备测试）
重要： 所有 Microsoft Windows 操作系统都需要此：在 Windows 中的通用 C 运行库的更新对于 Microsoft Windows Server 2016，需要使用安装选项 Windows Server (Server with Desktop Experience)。

Linux 操作系统支持

Silk Central 支持仅适用于执行服务器的 Linux 操作系统。

  • Debian
  • Redhat Enterprise Linux
  • Suse Linux
  • Ubuntu

Web 浏览器支持

  • Google Chrome
  • Internet Explorer 10 或更高版本（无兼容模式）
  • Mozilla Firefox
  • Microsoft Edge

Web 服务器支持

  • IIS 8 32 位/64 位
  • IIS 10 32 位/64 位

数据库管理系统支持

  • Microsoft SQL Server 2012 Service Pack 3
  • Microsoft SQL Server 2014 Service Pack 2
  • Microsoft SQL Server 2016
  • Oracle 11g （版本 11.2.0.4）
  • Oracle 12c (版本 12.1.0.2)

集成 Micro Focus 软件支持

  • AccuRev 6.2
  • Caliber 11.4、11.5
  • Mobile Center 2.51 或更高版本
  • Silk Performer 18.5
  • Silk Test 18.5
  • StarTeam 15.x、16.x
  • Silk TestPartner 6.3
  • Unified Functional Testing（UFT）14.0

集成第三方软件支持

  • VFS（Apache Commons Virtual File System）
  • Atlassian JIRA 6、7
  • Bugzilla 4.4.12、5.0.3
  • CA Agile Central
  • Git 2.14.2
  • IBM Rational ClearQuest 8.0
  • IBM Rational DOORS 9.5、9.6
  • IBM Rational DOORS Next Generation 6.0
  • IBM Rational RequisitePro 7.1.3、7.1.4
  • JUnit 4.11 或更高版本
  • 用于导入测试和需求的 Microsoft Office Excel (.xlsx)
  • 用于导入需求的 Microsoft Office Word（.doc，docx）
  • Microsoft Visual Studio/Visual Studio Test Agent 2012、2013、2015
  • NUnit 2.6.4、3.4.1
  • SAP Solution Manager 7.1
  • Subversion 1.9
  • Team Foundation Server 2012、2013、2015
  • VersionOne Enterprise Edition
  • VMware vCloud Director 5.5
父主题： 安装 Silk Central


配置和管理基础架构

实例是指一组独立的 Silk Central 服务（应用程序服务器 (AS)、前端服务器 (FE) 和图表服务器 (CS)），这些服务拥有自己的数据库和执行服务器 (ES) 连接。默认情况下，Silk Central 为您创建一个名为 silk 的实例。默认 URL 为 http://<计算机名称>:19120/login（如果 Silk Central 在 IIS 上运行，则无需提供端口信息）。

  • 设置安全的 Silk Central 系统
    此部分介绍如何设置安全的 Silk Central 系统。
  • 管理实例
    添加、删除或维护 Silk Central 实例。
  • 管理客户端
    系统管理区域是用于配置 Silk Central 客户端的特定环境。
  • 配置高级设置
    介绍如何配置高级设置，以自定义您的 Silk Central 系统。
父主题： 安装和系统配置帮助


设置安全的 Silk Central 系统

此部分介绍如何设置安全的 Silk Central 系统。
  • 通用指南
    安装完 Silk Central 后，您应考虑按照以下指南在安全环境中设置 Silk Central。
  • 启用使用 SSL 的安全 Web 服务器连接
    如果要让用户仅通过安全连接 (SSL) 访问 Silk Central，请启用 Silk Central 来使用安全套接字层 (SSL)。
  • 在 SSL 环境中启用 BIRT 报告
    将 Silk Central 配置为使用采用 SSL 的安全 Web 服务器连接之后，启用要在此环境中运用的 BIRT 报告。
  • 配置执行服务器的非标准 SSL 端口
    配置应用程序服务器与执行服务器通信所用的自定义 SSL 端口。
  • 禁用执行服务器上未使用的端口
    禁用未由执行服务器使用的端口。
  • 通过 SSL 与外部系统通信
    将自签名证书添加到默认 Java Keystore 以通过 SSL 与具有自签名证书的主机进行通信。
父主题： 配置和管理基础架构


通用指南

安装完 Silk Central 后，您应考虑按照以下指南在安全环境中设置 Silk Central。
  • 首先，更改 sysadmin 用户的默认密码。有关详细信息，请咨询系统管理员。
  • 将 LDAP 身份验证配置为支持通过 LDAP 服务器进行 Silk Central 登录。有关详细信息，请参阅 LDAP 身份验证。
  • 如果多个组将使用 Silk Central，请通过创建实例和客户端确保您的用户只能访问其应当查看的数据。有关详细信息，请参阅管理实例和管理客户端。
  • 为确保使用高级查询运行报告不会更改数据库中的任何数据，请考虑创建并使用只读数据库用户。有关详细信息，请参阅数据库页面。
  • 配置防火墙，以使只有 Silk Central 需要的端口开放。有关 Silk Central 所用端口的详细信息，请参阅 Silk Central 体系结构。
  • 定期备份数据库。
  • 使用最新的、支持的操作系统版本，并确保定期应用更新。
  • 使用 Silk Central 的最新版本和修补程序。通过 http://supportline.microfocus.com 注册 Micro Focus SupportLine，以获取最新支持新闻并访问其他支持信息。
父主题： 设置安全的 Silk Central 系统


启用使用 SSL 的安全 Web 服务器连接

如果要让用户仅通过安全连接 (SSL) 访问 Silk Central，请启用 Silk Central 来使用安全套接字层 (SSL)。

有关其他信息，另请参阅通过 SSL 与外部系统通信、在 SSL 环境中启用 BIRT 报告和配置执行服务器的非标准 SSL 端口。

  1. 将您的证书和密钥文件复制到前端服务器计算机。
  2. 用文本编辑器打开 C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf 中的 nginx.conf.template 文件。
  3. 通过删除 #，取消以下行的注释：
    #listen   443 ssl;
#ssl_protocols TLSv1.2 TLSv1.1 TLSv1;
#ssl_certificate    "C:/.../ssl/host.cert";
#ssl_certificate_key    "C:/.../ssl/host.key";
#add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
  4. 将 ssl_certificate 和 ssl_certificate_key 的路径设置为将证书和密钥文件复制到其中的路径。使用斜杠指定路径，不要使用反斜杠。
  5. 如果您只想允许使用 SSL 连接，请通过添加 # 注释掉 listen 19120; 行。
  6. 可选：要配置从非安全端口重定向至安全端口，请使用以下语法添加新 server 部分：
    server {
  listen <非安全端口>;
  server_name localhost;
  return 301 https://$host$request_uri;
  }
  7. 通过使用 Windows 服务管理器，重新启动 Silk Central 实例管理服务。
父主题： 设置安全的 Silk Central 系统


在 SSL 环境中启用 BIRT 报告

将 Silk Central 配置为使用采用 SSL 的安全 Web 服务器连接之后，启用要在此环境中运用的 BIRT 报告。
  1. 使用实例管理页面停止要配置的实例的图表服务器服务。
  2. 通过以下命令行使用 OpenSSL 创建 PKCS #12 密钥存储库：openssl pkcs12 -export -in ./host.cert -inkey ./host.key > ./host.p12 示例：
    openssl pkcs12 -export -in C:/ProgramData/SilkCentral/ssl/host.cert -inkey
C:/ProgramData/SilkCentral/ssl/host.key > C:/ProgramData/SilkCentral/ssl/host.p12
  3. 使用以下命令行将密钥存储库 host.p12 转换为 Java 密钥存储库：keytool.exe -importkeystore -srckeystore ./host.p12 -destkeystore ./host.jks -srcstoretype pkcs12 示例：
    "C:\Program Files (x86)\Silk\Silk Central
18.5\instance_1_silk\lib\jre\bin\keytool.exe"
-importkeystore -srckeystore C:/ProgramData/SilkCentral/ssl/host.p12 -destkeystore
C:/ProgramData/SilkCentral/ssl/host.jks -srcstoretype pkcs12
  4. 在图表服务器的进程配置文件 sc_ChartServer.processconfig（位于 C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<实例编号>_<实例名称>\Conf）中添加以下行：
    <Service>
  <SystemProperties>
          ...
             <SystemProperty name="javax.net.ssl.trustStore" value="<host.jks 文件路径>" />
             <SystemProperty name="javax.net.ssl.trustStorePassword" value="<密码>" />
        </SystemProperties>
</Service>
    示例：
    <Service>
  <SystemProperties>
          ...
             <SystemProperty name="javax.net.ssl.trustStore" value="C:/ProgramData/SilkCentral/ssl/host.jks" />
             <SystemProperty name="javax.net.ssl.trustStorePassword" value="changeit" />
        </SystemProperties>
</Service>
  5. 重新启动图表服务器服务。
父主题： 设置安全的 Silk Central 系统


配置执行服务器的非标准 SSL 端口

应用程序服务器与执行服务器通信所用的默认 SSL 端口是 19125。

注： 需要为每台要通过非标准 SSL 端口连接的执行服务器执行此过程。

配置执行服务器的非标准 SSL 端口：

  1. 停用要为其配置非标准 SSL 端口的执行服务器。
  2. 停止执行服务器。
  3. 使用文本编辑器打开 SccExecServerBootConf.xml 文件。 此文件位于执行服务器上 Silk Central 目录的 /conf/execserver 文件夹中。
  4. 找到 <SSLPort> XML 标记。 默认情况下，此标记设置为 <19125>。 将该值设置为要用于 SSL 通信的端口号。
  5. 保存并关闭 XML 文件。
  6. 在 Silk Central 中，将执行服务器的 SSL 端口设置为已在 XML 文件中指定的值。
  7. 重新启动执行服务器。
  8. 重新激活执行服务器。
父主题： 设置安全的 Silk Central 系统
父主题： 设置执行服务器
相关任务
启动或停止本地执行服务器服务
激活或停用执行服务器
配置物理执行服务器


禁用执行服务器上未使用的端口

根据应用程序服务器与执行服务器之间使用的是 SSL 还是不安全通信，您可能希望禁用相应的未使用端口。您还可以禁用默认 Tomcat 端口，Silk Central 从未使用过该端口。

对于要在其上禁用未使用端口的每个执行服务器，您需要执行以下步骤。

要禁用执行服务器上未使用的端口：

  1. 停止执行服务器。
  2. 使用文本编辑器打开 SccExecServerBootConf.xml 文件。 此文件在执行服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5 Execution Server\conf\execserver。
  3. 在文件的 RmiProxy 部分找到 InsecurePort 和 SSLPort XML 标记。
  4. 根据应用程序服务器与执行服务器之间使用的是 SSL 还是不安全通信，按以下说明操作：
    SSL 通信
    将 InsecurePort 的值设置为 0。
    不安全通信
    将 SSLPort 的值设置为 0。
  5. 保存并关闭 XML 文件。
  6. 重新启动执行服务器。
父主题： 设置安全的 Silk Central 系统
父主题： 配置高级设置
相关任务
管理实例


通过 SSL 与外部系统通信

如果要连接的主机具有自签名证书，您可能会收到以下错误消息：
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
注： 对于有效证书（即，证书颁发机构签署的证书），则不会显示此错误消息。

要使用具有自签名证书的服务器，您需要执行以下步骤：

  1. 从服务器下载 SSL 证书。 使用浏览器查看证书并将其导出。例如，在 Mozilla Firefox 中，导航到工具 > 页面信息 > 安全性 > 查看证书 > 详细信息 > 导出。
  2. 启动密钥和证书管理工具 Keytool。 Keytool 是 JRE 安装的一部分，位于 JRE 安装文件夹中，例如 C:\Program Files (x86)\Silk\Silk Central <版本>\instance_<实例编号>_<实例名称>\lib\jre\bin。有关 Keytool 的其他信息，请参阅 Java SE 技术文档。
  3. 要将证书添加到前端服务器和应用程序服务器上的默认 Java Keystore，请在 Keytool 中键入诸如以下命令：
    keytool
  -importcert
  -file CERTIFICATE.crt
  -keystore "C:\Program Files (x86)\Silk\Silk Central <version>\
   instance_<instance number>_<instance name>\lib\jre\lib\security\cacerts"
    系统将提示您键入密码。
  4. 键入默认 Keystore 密码 changeit。
  5. 重新启动前端服务器和应用程序服务器以重新加载 Keystore。
父主题： 设置安全的 Silk Central 系统
父主题： 集成


管理实例

如果您需要以物理方式将不同客户端的测试数据和进程分开，以便提高数据安全性并减少独立用户组对彼此（如部门）的影响，可以创建附加实例。有了客户端的帮助，您可从逻辑上将一个实例的数据进一步分隔到一个数据库中。

管理实例

实例及其 Silk Central 服务是通过称为实例管理的常用用户界面来管理的，您只能在安装 Silk Central 的服务器上访问该界面（使用 URL http://localhost:19100）。 无法从远程计算机中访问实例管理页。您可对一个实例或单个服务执行以下操作：
  • 单击 停止 或 启动 单独停止或启动服务。如果停止或启动某个实例，也会分别停止或启动该实例的所有服务。
  • 单击 删除实例 来删除实例。仅当您确定不再需要某实例时使用该选项！该操作并不会删除数据库中的数据。
    注： 要将执行服务器分配到不同的应用程序服务器，需要在安装执行服务器的计算机上删除以下文件：C:\ProgramData\SilkCentral\AgentBase\ItemObjects.ser.
  • 单击 设置 以配置实例设置。

维护模式

在用户不再能访问 Silk Central 实例的期间（例如在安装新的修补程序或调整服务设置时）内执行实例维护之前，您可以通知 Silk Central 用户实例正在维护中：
  1. 在实例管理页中，单击 设置 打开设置对话框。
  2. 在维护选项卡中，选中激活维护模式复选框。
  3. 输入用户在尝试访问 Silk Central 时会看到的通知文本，例如：Silk Central 当前不可用，因为我们正在执行更新。系统很快会恢复。
  4. 单击确定。
  5. 完成维护并且所有服务重新运行后，请停用维护模式以允许用户重新访问 Silk Central。

32 位/64 位模式

  1. 在实例管理页中，单击 设置 打开设置对话框。
  2. 在实例中，使用模式列表选择前端、应用程序和图表服务器服务应在 32 位还是 64 位模式下运行。请注意，64 位操作系统必须在 64 位模式下运行服务。更改此模式需要重新启动实例服务。
  3. 单击确定。

JMX 测量

要通过 JMX 访问信息或执行操作，您需要使用 JMX 连接字符串。单击 设置 打开设置对话框。在服务器选项卡中，选择所需的服务器并复制 JMX 连接字符串。有关更多信息，请参阅配置 JMX 设置。

创建新实例

单击新建实例可创建其他实例。确保您为实例提供一个有意义的名称，因为此实例名称将用于识别实例的服务和文件，是用户用来访问实例的 URL 的组成部分。

对于您添加的各个附加实例，至少需要 10 GB 的额外磁盘空间及以下最小初始内存：
  • 前端服务器：500 MB
  • 应用程序服务器：300 MB
  • 图表服务器：200 MB
根据您的工作负载，这些值可能需要增加。

有关 Silk Central 最佳配置的更多信息，请联系技术支持人员或技术客户团队。

  • 安装修补程序
    有修补程序可用时，请使用最新修补程序更新您的实例。
  • 启动或停止本地执行服务器服务
    使用 Silk Central 服务管理器启动或停止本地安装的执行服务器服务。
  • 前端服务器负载平衡
    负载平衡用于在多个服务器上分担负载（网站流量），这样可提高性能和可靠性，因此能改善用户体验。
父主题： 配置和管理基础架构
相关概念
Silk Central 体系结构


启动或停止本地执行服务器服务

使用 Silk Central 服务管理器启动或停止本地安装的执行服务器服务。
  1. 双击 Windows 任务栏中的 Silk Central 服务管理器托盘图标。 随即出现 Silk Central 服务管理器对话框。
  2. 单击启动或停止以启动或停止执行服务器服务。
  3. 单击查询状态以检查服务的当前状态。
  4. 如果您希望监控实时活动，请通过控制台窗口启动 Silk Central 执行服务器：
    1. 选中从控制台启动复选框。
    2. 单击停止。
    3. 单击启动。
  5. 单击执行服务器日志文件链接以查看日志文件。 日志文件在已注册的文本编辑器中打开。
  6. 单击确定以完成管理执行服务器服务。 服务管理器关闭，但在系统托盘中仍保持活动状态。
父主题： 管理实例


前端服务器负载平衡

负载平衡用于在多个服务器上分担负载（网站流量），这样可提高性能和可靠性，因此能改善用户体验。

为了确保 Silk Central 的前端服务器实现负载平衡，可以将额外的前端服务器信息添加到 NGINX 代理配置中，而 NGINX 将在这些前端服务器上分担负载。

  • 配置前端服务器负载平衡
    介绍如何设置和配置额外的前端服务器以实现负载平衡。
父主题： 管理实例


配置前端服务器负载平衡

如果您有正在运行的 Silk Central 实例，并且由于负载增加导致该实例的用户遇到性能问题，您可以设置额外的前端服务器来分担负载。

最初的情况：
  • 您已在服务器 A 上安装 Silk Central。
  • 您拥有性能欠佳的运行中实例。
  • 您希望添加额外的前端服务器以分担负载。

添加额外的前端服务器以实现该实例的负载平衡：

  1. 使用 Silk Central 的安装程序在服务器 B 上安装 Silk Central。
  2. 安装程序完成后，导航至服务器 B 上的实例管理 (http://localhost:19100)。
  3. 由于您只需一个前端服务器，请停止您要用于负载平衡的实例的应用程序服务器和图表服务器。
  4. 单击 设置 打开此实例的设置对话框。在服务器选项卡中，选择前端服务器并复制前端服务器端口。
  5. 切换至服务器 A 并导航至实例管理 (http://localhost:19100)。
  6. 单击 设置 打开性能欠佳的实例的设置对话框，然后激活维护模式。
  7. 在文件系统中，打开 NGINX 自定义属性文件 (C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf\nginxCustom.properties)，然后使用复制的前端服务器端口添加前端服务器在服务器 B (<SERVER_NAME>:<PORT>) 上的 URL。 表示法：frontendservers.<INSTANCE_NAME>=<FE_URL1>{,<FE_URL2>,...,<FE_URLX>}

    例如：frontendservers.silk=localhost:19110,silkserver2:19320

    注意： 由于 NGINX 限制，无法使用前端服务器的 19120 端口。如步骤 4 中所述，始终都从“设置”对话框中获取该端口。
  8. 返回实例管理页，然后单击 设置 ，打开性能欠佳的实例的设置对话框。在服务器选项卡中，选择应用程序服务器并复制应用程序服务器端口。
  9. 要在服务器 B 上的前端服务器与实例在服务器 A 上的应用程序服务器之间建立连接，请打开 Web 浏览器，然后使用 http://<服务器 B>:<前端服务器端口> 直接导航至服务器 B 的前端服务器。确保您使用“设置”对话框中的端口，而不是端口 19120！
  10. 在“应用程序服务器连接”页中，请输入服务器 A 的主机或 IP 地址以及复制的应用程序服务器端口。
  11. 返回实例管理页，然后停用维护模式。该操作将会更新 NGINX 配置。

如果您的用户现在可以使用与之前相同的 URL 访问实例，便会在服务器 A 和服务器 B 上的前端服务器之间自动平衡它们。

父主题： 前端服务器负载平衡


管理客户端

使用系统管理区域配置 Silk Central 的客户端。配置客户端包括以下活动：

  • 创建、连接和断开连接数据库。
  • 创建和管理客户端。
  • 配置 Silk Central 客户端的基础结构（图表服务器、电子邮件服务器和代理连接）。
  • 通过分析诊断信息和系统日志文件维护系统服务。
  • 系统管理员
    介绍系统管理员的角色和用途。
  • 数据库
    介绍 Silk Central 中的数据库使用。
  • 客户端
    客户端是 Silk Central 实例中的不同单元。例如，公司内部的客户端可以是客户，也可以是部门。客户端可以增强安全性，但与实例相比，它们共享相同的数据库和 Silk Central 服务。
  • 基础结构
    介绍组成系统基础结构的图表服务器、电子邮件服务器以及系统代理。
  • 系统诊断
    介绍系统诊断选项卡。
父主题： 配置和管理基础架构
相关概念
Silk Central 体系结构


系统管理员

系统管理员是有权访问系统管理区域的唯一用户，并且只可访问此区域。 此用户无权访问实际的 Silk Central 用户界面。

通过使用以下凭据登录来访问系统管理区域：
  • 用户名：sysadmin
  • 密码：sysadmin
重要： 尽快更改此默认密码。 我们建议您首次连接到 Silk Central 数据库后执行此操作。 要更改密码，请单击系统管理区域（右上角）的菜单中的更改密码。 无法更改用户名。

如果未连接数据库，系统管理员将会自动定向到系统管理区域。

父主题： 管理客户端


数据库

Silk Central 使用数据库来存储、维护和分析数据。您必须建立数据库连接才能使用 Silk Central。您可建立多个数据库，但一次只能连接一个数据库。要连接新数据库，您必须首先断开当前数据库。

要配置数据库连接，请转到系统管理区域中的数据库页面。只有系统管理员可以访问此页面。有关更多信息，请参阅系统管理员。

任何需要断开数据库的管理任务都应在非工作时间执行。务必将不可用情况及其持续时间通知用户。有关配置数据库的更多信息，请联系 SupportLine。如果您使用的是 Microsoft SQL Server，建议您查看 Silk Central MSSQL Server 推荐。

  • 选择关系数据库管理系统
    选择关系数据库管理系统 (RDBMS) 以用作您的存储库。
  • 数据库用户权限
    向数据库用户分配特定角色，以使其能够执行特定任务。
  • 创建数据库
    介绍如何创建新数据库。
  • 连接到数据库
    介绍如何连接到 Silk Central 数据库。
  • 从数据库断开连接
    介绍如何从 Silk Central 数据库断开连接。
  • ALM 存储库 ID
    介绍如何确定存储库。
  • ALM URI
    介绍如何使用 ALM URI。
  • 数据库页面
    介绍如何使用数据库页面连接和断开数据库。
父主题： 管理客户端
相关概念
系统管理员
相关参考
数据库页面


选择关系数据库管理系统

按照关系数据库管理系统 (RDBMS) 文档中的说明安装和设置 Oracle 或 Microsoft 的 SQL Server。

Silk Central 支持以下数据库管理系统：
  • Microsoft SQL Server 2012 Service Pack 3
  • Microsoft SQL Server 2014 Service Pack 2
  • Microsoft SQL Server 2016
  • Oracle 11g （版本 11.2.0.4）
  • Oracle 12c (版本 12.1.0.2)

下表介绍每种数据库类型的要求。

RDBMS 准备就绪
Oracle
  • Oracle 表空间。
  • 服务器主机名和端口号，或单客户端访问名称 (SCAN)。默认端口为 1521。
  • Oracle 实例 ($ORACLE_SID) 的名称。
  • 您的 Silk Central 数据库用户的名称和密码。用户必须拥有配额和足够权限。
如有必要，请向 Oracle 管理员寻求帮助。
注： Oracle 不会创建数据库，而是创建分配到特定用户名的架构。因此，分配到 Oracle 数据库的不是数据库名称而是用户名。Silk Central 将此类用户名视为数据库名称。
Microsoft SQL Server
  • 服务器主机名和端口号。
  • MS SQL Server 系统用户名和密码。
  • 您的 Silk Central 数据库的名称。
  • 您的 Silk Central 数据库用户的名称和密码。
注： Silk Central 仅支持设置为不区分大小写的 Microsoft SQL Server 服务器。请不要将 Microsoft SQL Server Express 用于生产环境，因为与完整的数据库服务器安装相比，它具有的功能有限。
父主题： 数据库


数据库用户权限

由于存在安全风险，我们建议您不要使用数据库管理员用户来维护您的 Silk Central 数据库。本主题列出可用于特定任务的数据库角色，如下所示：

Microsoft SQL Server
如果 Microsoft SQL Server 是 Silk Central 的 DBMS，则您的 Silk Central 数据库需要以下数据库用户角色/权限：
是： 或：
  • db_owner
  • db_ddladmin
  • VIEW SERVER STATE
  • db_datareader
  • db_datawriter
  • db_ddladmin
  • EXECUTE
  • VIEW SERVER STATE
这些角色/权限都允许创建和配置数据库表、使用先前创建的数据库以及安装和升级软件。
注： Silk Central 数据库用户需要这些角色/权限。否则，将发生错误。
Oracle
如果 Oracle 是 Silk Central 的 DBMS，请设置以下 Oracle 数据库用户权限以使用 Silk Central：
  • CREATE SESSION
  • CREATE PROCEDURE
  • CREATE SEQUENCE
  • CREATE TABLE
  • CREATE TRIGGER
  • CREATE VIEW
注： Silk Central 数据库用户需要所有上述权限。否则，将发生错误。要在系统诊断中获取所有与数据库相关的分析数据，我们还建议将 SELECT_CATALOG_ROLE 分配给您的数据库用户。
注： Oracle 用户必须拥有足够配额才能使用 Silk Central。
设置 Silk Central 的 Oracle DBMS 时，请确保 Oracle 环境满足以下要求：
  • 至少有 2 GB 临时表空间可用。
  • 具有足够的磁盘空间来处理临时表空间的大小。
父主题： 数据库


创建数据库

如果 Silk Central 当前已连接到数据库，您必须断开该数据库才能创建新数据库。

注： 如果使用评估安装包安装 Silk Central，将自动创建和连接一个名为 demodb 的演示数据库。在这种情况下，您不必执行以下步骤。

创建新数据库：

  1. 如果已设置 Silk Central 应用程序服务器，将在浏览器窗口中显示数据库页面，然后您可继续步骤 3。
    提示： 或者，您也可使用 Web 浏览器浏览到您的 Silk Central 站点。默认 URL 为 http://<计算机名称>:19120/login（如果 Silk Central 在 IIS 上运行，则无需提供端口信息）。 使用标准安装选项安装 Silk Central 时，连接到应用程序后将立即显示数据库页面。在安装前端服务器的计算机上，您也可以选择开始 > 程序 > Silk > Silk Central > Silk Central18.5 > Silk Central 主页.
  2. 以系统管理员身份登录 Silk Central。 有关更多信息，请参阅系统管理员。
  3. 在菜单中，单击数据库。
  4. 配置新数据库的设置。 有关更多信息，请参阅数据库页面。 您可在本地安装的 Microsoft SQL Server 2008 Express SP1、本地安装的 Microsoft SQL Server 或 Oracle 安装，或已安装 MS SQL Server 或 Oracle 的网络服务器上创建数据库。Silk Central 支持：
    • Microsoft SQL Server 2012 Service Pack 3
    • Microsoft SQL Server 2014 Service Pack 2
    • Microsoft SQL Server 2016
    • Oracle 11g （版本 11.2.0.4）
    • Oracle 12c (版本 12.1.0.2)
  5. 单击连接数据库，然后单击是。 将显示创建新数据库对话框。
  6. 键入数据库管理员凭据，然后单击确定。
    提示： 如果要创建本地或网络 Microsoft SQL Server 或 Oracle 数据库，请输入数据库管理员为您提供的登录信息。
    将显示创建 ALM 存储库 ID 对话框。
  7. 键入唯一的 ALM 存储库 ID，然后单击确定。
  8. 您将收到表明存储库已成功创建的通知。单击确定。 将显示登录页面。
将创建并连接数据库。现在，您可使用您的用户名和密码登录到 Silk Central。
父主题： 数据库
相关概念
系统管理员
相关参考
数据库页面


连接到数据库

连接到数据库：

  1. 使用 Web 浏览器浏览到 Silk Central 站点。 默认 URL 为 http://<计算机名称>:19120/login（如果 Silk Central 在 IIS 上运行，则无需提供端口信息）。
    注： 如果当前未连接任何数据库，您将自动转到系统管理区域。
  2. 以系统管理员身份登录 Silk Central。 有关更多信息，请参阅系统管理员。
  3. 在菜单中，单击数据库。
  4. 单击断开数据库以断开当前数据库。 您将转至数据库页面。
  5. 根据需要更改设置。 有关更多信息，请参阅数据库页面。
  6. 单击连接数据库。
建立数据库连接可能需要几分钟到几个小时。建立连接后，将出现一个对话框。单击确定。将显示 Silk Central 登录页面。
父主题： 数据库
相关概念
系统管理员
相关参考
数据库页面


从数据库断开连接

要从数据库断开连接：

  1. 通过 Web 浏览器浏览到 Silk Central 站点。 默认 URL 为 http://<计算机名称>:19120/login（如果 Silk Central 在 IIS 上运行，则无需提供端口信息）。
  2. 以系统管理员身份登录 Silk Central。 有关更多信息，请参阅系统管理员。
  3. 在菜单中，单击数据库。
  4. 单击断开数据库以断开当前数据库。 您将转至数据库页面。
父主题： 数据库
相关概念
系统管理员
相关参考
数据库页面


ALM 存储库 ID

每个 Silk Central 数据库都必须具有唯一的存储库 ID。 此 ID 用于在 ALM URI 中唯一标识跨多个 Silk Central 存储库的 Silk Central 需求和测试。 存储库 ID 在公司的 Silk Central 安装中必须是唯一的。 提供的存储库 ID 将成为 ALM URI 的一部分。 有关 ALM URI 的更多信息，请参阅 ALM URI。 最好使用说明性 ID，例如，将 USCA01 用于美国加利福利亚存储库 01 或将 GEBE02 用于德国柏林存储库 02。 允许的字符包括字母、数字、句点 (.) 和减号 (-)。 ID 的长度必须为 1 到 20 个字符。

警告：
设置存储库 ID 后，无法对其进行更改。
父主题： 数据库
相关概念
ALM URI


ALM URI

存储库 ID 集成到应用程序生命周期管理统一资源标识符 (ALM URI) 中。 ALM URI 提供了一种跨 ALM Server 平台处理元素的方法以及在应用程序之间区分和跟踪元素的能力。 此外，ALM URI 还可用于唯一标识跨多个 Silk Central 存储库的 Silk Central 需求和测试。

ALM 元素 URI 语法如下所示：

<ALM URI> = alm://<source project>/<source element path>[?<source version>]
 <source project> = <source type>!<project identity>

对于 Silk Central，<source type> = sctm。 对于 Issue Manager，<source type> = scim。

项目标识构建如下：

<project identity> = <repository ID>_<project ID>

<repository ID> 是每个 Silk Central 和 Issue Manager 存储库的唯一标识符。 每个存储库都会生成存储于存储库中的唯一标识符。 必须保证所有已安装存储库的唯一性。 <project ID> 是 Silk Central 或 Issue Manager 项目的标识符。 此标识符在每个存储库的上下文中是唯一的。

源元素路径：

对于 Silk Central 和 Issue Manager，使用以下引用项目的语法：

Silk Central 本机需求（即，未与外部需求管理系统链接的需求）使用以下语法：

<source element path> = /<requirement ID>;ns=requirement

Silk Central 测试使用以下语法：

<source element path> = /<test ID>;ns=test

Silk Central 和 Issue Manager 问题使用以下语法：

<source element path> = /<issue ID>;ns=issue
示例 ALM URI：
alm://sctm!USCA01_23/602;ns=test

Silk Central 存储库 USCA01、项目 ID 23、元素 ID 602、元素类型 test。

父主题： 数据库
相关概念
ALM 存储库 ID


数据库页面

在数据库页面上，您可使用 Silk Central 连接数据库并再次断开数据库。

如果未连接任何数据库，您将自动转到数据库页面。

如果已连接数据库，您必须以系统管理员身份登录，然后单击数据库以访问数据库页面。有关更多信息，请参阅系统管理员。

使用以下 UI 控件配置数据库连接：

项 | 说明
DBMS 主机名或 IP 地址 托管 DBMS（数据库管理系统）的计算机名称。按照<计算机名称>\<实例名称>的格式输入名称。
数据库系统
主机名说明
Microsoft SQL Server
<计算机名称>\<实例名称>.例如：localhost。
注： 仅在使用实例安装 DBMS 时需要提供实例名称。
Oracle 服务器
<计算机名称> 或 单客户端访问名称 (SCAN)。例如：MyDBMSHost.如果您计划通过直接数据库访问创建自定义报告，请定义在整个网络上可用的 DBMS 主机名。
DBMS 类型 | 要访问的 DBMS 类型，MS SQL Server 或 Oracle。
端口

DBMS 的侦听端口。Microsoft SQL Server（包括 Express）的默认端口是 1433。Oracle 的默认端口是 1521。
数据库/SID

MS SQL Server 数据库名称或由 Oracle 管理员提供的 Oracle SID。要连接到 Oracle RAC 环境，请在 SID 前面加上一个斜杠 (/)。

对于 Oracle 数据库管理员：配置 Oracle SID 以使用 UTF-8 字符集。
用户名/密码
Microsoft SQL Server，包括 Express
具有足够凭据的数据库用户，或有效的 Windows 域用户（域\用户名）。使用 Windows 身份验证时，数据库服务器必须支持 Lmv2 和 NTLMv2。未指定用户的单一登录不受支持。
注： 如果您正在评估 Silk Central，默认凭据为 sa/SilkCentral12!34。
Oracle 服务器
具有足够凭据的数据库用户（由 Oracle 管理员提供）。
重要： 对于 Oracle 服务器，数据库用户名一定不能包含句点 (.)。
只读用户名 对指定数据库中所有表和视图拥有只读权限的可选数据库用户。该用户用于仅要求读取权限的操作，例如执行报告。这将确保具有高级查询的运行报告不会更改数据库中的任何数据，因为执行高级查询可能对数据产生不利影响。以只读用户访问数据库也会对性能产生积极的影响。

如果您的 DBMS 是 Microsoft SQL Server，则 Silk Central 将在您指定名称和密码时自动创建此用户。如果您的 DBMS 是 Oracle，则数据库管理员需要在 Oracle 中创建用户，并且 Silk Central 管理员需要将该用户添加到 Silk Central。
只读密码

指定只读用户名的有效密码。
DBMS 版本信息

显示 DBMS 和操作系统版本信息。
ALM 存储库 ID | 显示存储库的 ALM URI。
连接数据库/断开数据库

单击此按钮以连接或断开 DBMS。
注： 如果执行服务器的版本为无效旧版本，但版本比 SilkCentral Test Manager 2009 SP1 新，执行服务器将自动升级为最新的 Silk Central 版本。Silk Central 将在执行服务器列表的信息列中显示一条有关升级的消息。只要升级流程尚未完成，将不会使用升级执行服务器。
父主题： 数据库
相关概念
系统管理员


客户端

客户端是 Silk Central 实例中的不同单元。例如，公司内部的客户端可以是客户，也可以是部门。客户端可以增强安全性，但与实例相比，它们共享相同的数据库和 Silk Central 服务。

您可使用系统管理区域生成客户端。您可配置各种客户端设置，这将影响分配到该客户端的项目。从总可用许可证池中，您可以指定每个客户端可使用的许可证数量上限。如果您登录到某个客户端，则只能访问该客户端的数据。在客户端中，可以在所有项目中访问所有资产。

安装 Silk Central 时，将自动创建默认客户端。当您从旧版升级 Silk Central 时，所有现有项目和用户都会分配到此默认客户端。将为每个客户端创建一位高级用户。有关更多信息，请参阅超级用户。您可删除所有客户端，但至少需要一个客户端才能创建项目和用户以及使用 Silk Central。

  • 超级用户
    介绍在客户端中具有所有权限的超级用户。
  • 创建客户端
    介绍如何创建客户端。
  • 编辑客户端
    介绍如何编辑客户端的设置。
  • 删除客户端
    介绍如何删除客户端。
  • 默认客户端
    介绍自动创建的默认客户端背后的概念、客户端的默认状态是什么以及如何设置和取消设置该默认状态。
  • 许可证处理
    介绍 Silk Central 中使用的许可证类型以及何时签出或签入许可证。
  • 客户端页面
    介绍客户端页面。
  • 客户端权限
    包含客户端的服务器和报告权限。
父主题： 管理客户端


超级用户

超级用户在客户端中具有所有权限。相比之下，系统管理员只能管理 Silk Central 安装的各种客户端，但不能访问实际 Silk Central UI。

系统管理员创建新客户端时，将为此客户端自动创建超级用户。

使用以下默认凭据作为超级用户登录：

  • 用户名：管理
  • 密码：管理
重要： 尽快更改此默认密码。要更改密码，请单击菜单中的管理 > 用户管理，并单击帐户选项卡，然后单击网格中的 admin。无法更改用户名。

有关所有可用的用户角色和权限列表，请参阅用户角色和权限。

父主题： 客户端
相关概念
登录选项
用户角色和权限
用户角色
相关任务
登录 Silk Central


创建客户端

创建客户端：
  1. 以系统管理员身份登录 Silk Central。 有关更多信息，请参阅系统管理员。
  2. 在菜单中，单击客户端。
  3. 单击新建客户端。 将显示新建客户端对话框。
  4. 输入客户端名称和说明。
  5. 在许可证限制部分中，指定此客户端可以并发使用的许可证最大数量。使用的许可证数量达到指定数量后，其他用户将无法在选定客户端上获得许可证。如果希望确保较为重要的客户端获得充足的可用许可证，同时限制重要性较低的客户端，这种方法将非常有用。 以下规则适用：
    • 未指定值：未应用许可证限制，客户端可以利用全部可用许可证。
    • 0（零）：客户端不可使用任何许可证，这实际上就是停用了选定许可证的所有相关功能。
    • 任意数量：客户端可以使用的许可证数量。如果数量大于可用许可证的总数，则客户端可以使用全部可用许可证。
    提示： 可用许可证总数显示在客户端页面的底部。
  6. 单击确定。

以超级用户身份登录客户端，执行客户端特定管理任务。有关更多信息，请参阅超级用户。

父主题： 客户端
相关概念
系统管理员
许可证处理
超级用户
相关参考
数据库页面


编辑客户端

要编辑客户端的设置：
  1. 以系统管理员身份登录 Silk Central。 有关更多信息，请参阅系统管理员。
  2. 在菜单中，单击客户端。
  3. 单击操作列中的 [image] （编辑）。 此时将显示编辑客户端对话框。
  4. 编辑客户端名称和说明。
  5. 在许可证限制部分中，指定此客户端可以并发使用的许可证最大数量。使用的许可证数量达到指定数量后，其他用户将无法在选定客户端上获得许可证。如果希望确保较为重要的客户端获得充足的可用许可证，同时限制重要性较低的客户端，这种方法将非常有用。 以下规则适用：
    • 未指定值：未应用许可证限制，客户端可以利用全部可用许可证。
    • 0（零）：客户端不可使用任何许可证，这实际上就是停用了选定许可证的所有相关功能。
    • 任意数量：客户端可以使用的许可证数量。如果数量大于可用许可证的总数，则客户端可以使用全部可用许可证。
    提示： 可用许可证总数显示在客户端页面的底部。
  6. 单击确定。
注： 如果您更改了客户端名称，请通知 Silk Central 用户。Silk Central 用户需要在登录页面上输入正确的客户端名称。

以超级用户身份登录客户端，执行客户端特定管理任务。有关更多信息，请参阅超级用户。

父主题： 客户端
相关概念
系统管理员
许可证处理
超级用户
相关参考
数据库页面


删除客户端

删除客户端：
  1. 以系统管理员身份登录 Silk Central。 有关更多信息，请参阅系统管理员。
  2. 在菜单中，单击客户端。
  3. 单击操作列中的 [image] （删除）。
  4. 单击是确认。
父主题： 客户端
相关概念
系统管理员
相关参考
数据库页面


默认客户端

安装 Silk Central 时，将自动创建客户端（名为默认）并将此客户端的状态设置为默认值。 要定义具有默认状态的客户端，请以系统管理员身份登录 Silk Central，然后单击客户端。 有关更多信息，请参阅系统管理员。

要将客户端设置为默认值，请单击设为默认值。 要取消设置默认状态，请单击取消设置默认值。 图标 [image] 将显示当前的默认客户端。 另外，也可能未定义默认客户端，但一次只有一个客户端可以具有默认状态。

默认客户端的目的是简化登录：使用默认客户端的用户登录 Silk Central 时，您可省略客户端名称。 只需输入您的用户名。 这对于只有一个客户端的 Silk Central 安装特别有用。 当您从较早版本升级 Silk Central 时，登录行为与以前相同。

父主题： 客户端
相关概念
系统管理员
相关参考
数据库页面


客户端页面

要访问此页面，请以系统管理员身份登录 Silk Central，然后单击客户端。有关更多信息，请参阅系统管理员。

使用此页面创建和管理客户端。单击新建客户端以创建新客户端。单击设为默认值或取消设置默认值以更改客户端的默认状态。图标 [image] 将显示当前的默认客户端。

页面上的网格包含以下列：

列 | 说明
操作 | 单击 [image] 和 [image] 按钮以删除或编辑客户端。
ID | 客户端的标识符。
名称 | 客户端的名称。单击 [image] 以编辑名称。如果更改了客户端名称，请通知 Silk Central 用户。Silk Central 用户需要在登录页面上输入正确的客户端名称。
说明 | 更详细地说明客户端。单击 [image] 以编辑说明。
Test Manager | 可以并发使用的 Test Manager 许可证的最大数量。
手动测试 | 可以并发使用的手动测试许可证的最大数量。
问题跟踪 | 可以并发使用的问题跟踪许可证的最大数量。
自动测试 | 可以并发使用的自动测试许可证的最大数量。
创建日期 | 创建客户端的日期。
创建者 | 创建客户端的用户。
更改时间 | 修改客户端的日期。
更改者 | 修改客户端的用户。
父主题： 客户端
相关概念
系统管理员


客户端权限

使用此页面修改客户端的系统设置和权限。

项目 | 说明
显示客户端用户的前端服务器和应用程序服务器日志视图。 | 选中此项时，将在用户界面中显示前端服务器和应用程序服务器日志选项卡（日志可能包含客户端特定数据）。
允许客户端用户的高级报告。 | 选中此项时，将启用报告的高级查询。如果未选中此项，您仍可执行报告，但不能创建新报告或编辑报告。
允许客户端用户的报告模板管理。 | 选中此项时，将启用报告模板上载、编辑、更新和删除。报告模板可能包含任意 SQL 和其他客户端的读取数据。
父主题： 客户端
相关概念
权限定义


基础结构

包含图表服务器、电子邮件服务器和系统代理的设置。

  • 图表服务器
    介绍图表服务器的作用及其如何连接到 Silk Central。
  • 电子邮件服务器
    介绍如何配置电子邮件服务器。
  • 系统代理
    介绍如何配置系统代理。 然后执行服务器可以通过代理与应用程序服务器通信。
  • 应用程序服务器位置
    介绍 Silk Central 应用程序服务器的基础知识。
  • LDAP 身份验证
    介绍如何将 LDAP 身份验证配置为支持通过 LDAP 服务器进行 Silk Central 登录。
  • Silk Performer 加载测试代理群集
    介绍 Silk Performer 加载测试代理群集及其对多个测试代理中的动态工作负载分配的支持。
父主题： 管理客户端


图表服务器

图表服务器是用于计算数据和生成图表的服务。 这些图表会显示在 Silk Central 应用程序中。 您可使用 Silk Central 安装程序将此服务安装在所选计算机上。 您必须配置图表服务器连接以显示图表。

注： 您可根据需要配置任意数量的图表服务器连接。 Silk Central 会为图表生成自动实施负载平衡机制。
  • 配置图表服务器连接
    介绍如何配置图表服务器连接。
  • 编辑图表服务器连接
    介绍如何编辑图表服务器连接。
  • 删除图表服务器连接
    介绍如何删除图表服务器连接。
  • 图表服务器页面
    介绍图表服务器页面。
父主题： 基础结构


配置图表服务器连接

配置图表服务器连接：

  1. 在菜单中，单击基础结构 > 图表服务器
  2. 如果图表服务器与应用程序服务器安装在同一台计算机上，则将自动配置本地主机的图表服务器连接。
  3. 可选：如果图表服务器需要通过不同于用户访问 Web 用户界面的 URL 与前端服务器通信，请单击配置 Web 服务 URL，并在文本字段中键入 URL。例如，用户通过代理访问 Web 用户界面，而图表服务器需要前端服务器的内部 URL 或 IP 地址，此时就必须采用这种方法。
  4. 单击新建图表服务器。 将显示新建图表服务器对话框。
  5. 输入主机名或 IP 地址、端口和图表服务安装位置的 URL。默认端口为 19126，默认 URL 为 ChartServer。
  6. 单击检查建立到图表服务器的测试连接。 此时将显示图表服务器检查对话框。
    注： 如果测试成功，将显示测试图像。如果测试失败，将显示错误消息。检查输入的数据并验证是否在目标机器上安装了图表服务器。
  7. 单击关闭。如果测试连接成功，请选中活动复选框，然后单击确定。

您可根据需要配置任意数量的图表服务器连接。Silk Central会为图表生成自动实施负载平衡机制。

注： 如果图表服务器服务安装在目标计算机上，则您只能配置一个图表服务器连接。有关更多信息，请参阅 Silk Central 应用程序的安装说明。
父主题： 图表服务器


编辑图表服务器连接

要编辑图表服务器连接：

  1. 在菜单中，单击基础结构 > 图表服务器
  2. 可选：如果图表服务器需要通过不同于用户访问 Web 用户界面的 URL 与前端服务器通信，请单击配置 Web 服务 URL，并在文本字段中键入 URL。例如，用户通过代理访问 Web 用户界面，而图表服务器需要前端服务器的内部 URL 或 IP 地址，此时就必须采用这种方法。
  3. 单击操作列中的 [image] （编辑）。 此时将显示编辑图表服务器对话框。
  4. 编辑主机名或 IP 地址、端口或在其处安装图表服务的 URL。默认端口为 19126，默认 URL 为 ChartServer。
  5. 选中/取消选中活动复选框以激活/停用服务器。
  6. 单击检查建立到图表服务器的测试连接。 此时将显示图表服务器检查对话框。
    注： 如果测试成功，将显示测试图像。如果测试失败，将显示错误消息。检查输入的数据并验证是否在目标机器上安装了图表服务器。
  7. 单击关闭，然后单击确定。
父主题： 图表服务器


删除图表服务器连接

删除图表服务器连接：

  1. 在菜单中，单击基础结构 > 图表服务器
  2. 单击操作列中的 [image] （编辑）。 此时将显示编辑图表服务器对话框。
  3. 取消选中活动复选框并单击确定。
  4. 单击操作列中的 Delete （删除）。
  5. 单击是确认。
注： 这将会删除与服务器的连接。 不会删除服务器本身。
父主题： 图表服务器


图表服务器页面

要访问此页面，请以系统管理员身份登录 Silk Central，然后单击基础结构 > 图表服务器。有关更多信息，请参阅系统管理员。

使用此页面管理图表服务器的连接。单击新建图表服务器以配置新的图表服务器连接。配置 Web 服务 URL 允许您配置图表服务器连接到前端服务器的备用 URL。页面上的网格包含以下列：

列 | 说明
操作 | 单击 [image] 和 [image] 按钮以删除或编辑图表服务器连接。删除连接之前，您必须将其停用。
图表服务器 URL | 显示图表服务器的 URL。语法：http://<computer name or IP address>:<port>/ChartServer。默认端口为 19126。单击 [image] 以编辑 URL。
状态 | 显示图表服务器的连接是活动状态还是非活动状态。单击 [image] （编辑）以更改连接的状态。
创建时间 | 创建图表服务器连接的日期。
创建者 | 创建图表服务器连接的用户。
更改时间 | 修改图表服务器连接的日期。
更改者 | 修改图表服务器连接的用户。
父主题： 图表服务器


电子邮件服务器

当您配置电子邮件服务器时，Silk Central 可以向您通知来自应用程序的结果。

  • 配置电子邮件服务器
    介绍如何配置电子邮件服务器。
  • 电子邮件服务器页面
    介绍电子邮件服务器页面。
父主题： 基础结构


配置电子邮件服务器

配置最多三个电子邮件服务器：
  1. 以系统管理员身份登录 Silk Central。 有关更多信息，请参阅系统管理员。
  2. 单击基础结构 > 电子邮件服务器。
  3. 在系统管理员的电子邮件地址字段中输入电子邮件地址。 Silk Central 会将通知发送到此地址。
  4. 在用于电子邮件的“发件人”地址字段中输入电子邮件地址。 此地址将在通知中显示为发送方。
  5. 在服务器字段中，输入电子邮件服务器的主机名和 IP 地址。 您可配置最多三个电子邮件服务器。
  6. 如果服务器需要凭据，请在用户名和密码字段中将其输入。
  7. 单击检查以测试服务器的连接。 Silk Central 会将测试电子邮件发送到您在第三步中输入的电子邮件地址。
  8. 如果显示错误消息或者没有收到电子邮件，请检查您的电子邮件设置。确保电子邮件服务器的主机名正确并且 SMTP 协议在该计算机上运行。
    注： 目前不支持具有 TLS 的 SMTP。
  9. 如果收到测试电子邮件，则测试成功。单击保存。
父主题： 电子邮件服务器


电子邮件服务器页面

要访问此页面，请以系统管理员身份登录到 Silk Central，然后单击基础结构 > 电子邮件服务器。 有关更多信息，请参阅系统管理员。

使用此页面最多可配置三个电子邮件服务器。 此页面显示以下项目：

项目 | 说明
系统管理员的电子邮件地址 | 指定 Silk Central 系统管理员的电子邮件地址。
用于电子邮件的“发件人”地址 | 指定当某人接收来自系统的电子邮件时在发件人字段中显示的名称。 这可以是任何电子邮件地址，例如 System_message@mycompany.com。
服务器 1 服务器 2 服务器 3 | 指定您发送电子邮件的服务器的主机名称或 IP 地址。 对于许多公司，此服务器简称为邮件。 如果您的电子邮件服务器使用 SMTP 身份验证 (LOGIN PLAIN)，则您必须为电子邮件服务器输入有效的用户和密码。 如果您不知道登录凭据，请与您的邮件服务器管理员联系。
检查 | 向系统管理员的电子邮件地址字段中定义的收件人发送测试电子邮件。
保存 | 保存您的设置。
重置 | 清除字段中的所有值。
父主题： 电子邮件服务器


系统代理

某个位置的执行服务器可以通过代理与应用程序服务器通信。 您（作为系统管理员）配置代理服务器后，客户端可以启用代理。 为此，客户端必须单击菜单中的管理 > 执行服务器，单击操作列中的 [image] （编辑），并选中使用系统代理复选框。

  • 配置系统代理
    介绍系统代理的配置方式和位置。
  • 系统代理页面
    介绍系统代理页面。
父主题： 基础结构


配置系统代理

配置系统代理：
  1. 以系统管理员身份登录 Silk Central。 有关更多信息，请参阅系统管理员。
  2. 单击基础结构 > 系统代理。
  3. 输入代理服务器的主机和端口。
  4. 输入用户名和密码（如果要求）。
  5. 单击检查以测试代理服务器的连接。 测试结果将显示在对话框中。
  6. 如果无法建立连接，请确保您的设置正确。
  7. 如果可以建立连接，请单击保存。 现在即可使用系统代理。
父主题： 系统代理


系统代理页面

要访问此页，请以系统管理员身份登录 Silk Central 并单击基础结构 > 系统代理。 有关更多信息，请咨询系统管理员。

使用此页面配置系统代理。 页面显示以下项目：

项目 | 说明
主机 | 用作系统代理的计算机的主机名或 IP 地址。
端口 | 系统代理侦听的端口号。 默认端口为 8080。
用户名（可选） | 如果代理服务器需要登录凭据，请输入有效的用户名。
密码（可选） | 输入用户名的有效密码。
检查 | 使用您提供的凭据测试与代理的连接。
保存 | 保存设置。
重置 | 清除此页的所有项。
父主题： 系统代理


应用程序服务器位置

应用程序服务器可同步任务，例如，计划的分发、执行服务器的控制以及数据库配置的管理。开始使用 Silk Central 之前，您需要指定应用程序服务器的位置。

  • 指定应用程序服务器的位置
    指定应用程序服务器的位置（若未自动配置）。
父主题： 基础结构


指定应用程序服务器的位置

连接到默认 Silk Central 实例时，您无需指定应用程序服务器位置。安装程序会自动将本地主机配置为应用程序服务器。在这种情况下，您可跳过此步骤。有关安装选项的其他信息，请参阅应用程序的安装说明。

指定应用程序服务器的位置：

  1. 安装 Silk Central 软件后，请使用 Web 浏览器连接到 Silk Central。
    提示： 默认 URL 为 http://<计算机名称>:19120/login（如果 Silk Central 在 IIS 上运行，则无需提供端口信息）。

    您将收到一则确认信息，说明应用程序服务器连接尚未定义。

  2. 输入应用程序服务器的主机或 IP 地址以及端口。 应用程序服务器是您安装 Silk Central 的应用程序服务器组件的计算机。默认端口为 19122。
  3. 单击登录继续。 如果规格正确并且相应的计算机运行已安装的软件，则您将返回登录页面。
此时将显示数据库管理页面。
父主题： 应用程序服务器位置
相关参考
数据库页面


LDAP 身份验证

将 LDAP 身份验证配置为支持通过 LDAP 服务器进行 Silk Central 登录。

轻型目录访问协议 (LDAP) 是开放的网络协议标准，它用于提供对目录服务的访问。 LDAP 提供对位于目录信息树 (DIT) 中的信息进行查看和修改的机制。 目录信息树通常包含有关不同类型的网络对象（包括用户、打印机、应用程序和其他网络资源）的各种信息。

  • Silk Central LDAP 集成
    介绍 Silk Central 中的 LDAP 集成。
  • LDAP 身份验证逻辑
    介绍可用于 LDAP 身份验证的身份验证模式。
  • 添加 LDAP 服务器
    添加 LDAP 服务器以将其用于 Silk Central。
  • 编辑 LDAP 服务器
    如果需要更改配置，请编辑 LDAP 服务器配置文件。
  • 测试 LDAP 服务器
    测试到 LDAP 服务器的连接以查看服务器是否可用于您的系统。
  • 删除 LDAP 服务器
    从配置文件列表中删除 LDAP 服务器配置文件。
  • LDAP 服务器页面
    列出为您的系统配置的 LDAP 服务器。
父主题： 基础结构
相关概念
登录和注销


Silk Central LDAP 集成

Silk Central 中的 LDAP 集成的最重要方面就是用户身份验证。在大多数目录中，均无法检索用户密码，因此当每次需要对用户进行身份验证时，都必须访问 LDAP。

Silk Central LDAP 集成支持纯文本身份验证和 SSL 身份验证。目录服务必须允许匿名查询或必须提供对目录具有读取权限的用户。

父主题： LDAP 身份验证


LDAP 身份验证逻辑

标准模式身份验证表示用户只能对 LDAP 进行身份验证（如果已定义 LDAP 服务器并且它处于活动状态）。混合模式身份验证表示用户可以使用 LDAP 或本地凭据登录。如果用户在 LDAP 服务器上为已知，但凭据不正确，则访问将被拒绝。

注： 对于任一身份验证模式，用户都只能在 Silk Central 数据库中存在其用户名时才可登录。

标准模式身份验证

当至少一个 LDAP 服务器处于活动状态时，标准模式身份验证将启用。检查每个已定义的 LDAP 服务器以确定是否可以对用户（具有特定用户名和密码）进行身份验证。如果在其中一个服务器上成功进行身份验证，将授予访问权限。

混合模式身份验证

如果未定义 LDAP 服务器，则用户只能使用本地凭据登录。如果至少一个 LDAP 服务器处于活动状态并且用户帐户设置为使用混合模式身份验证，则会检查每个已定义的 LDAP 服务器以确定是否可以对用户（具有特定用户名和密码）进行身份验证。如果用户在所有已定义的 LDAP 服务器上均为未知，则将尝试进行本地数据库身份验证。如果基于本地凭据的用户也未知，则访问将被拒绝。如果用户在 LDAP 服务器上为已知，但凭据不正确，则访问将被拒绝。

父主题： LDAP 身份验证


添加 LDAP 服务器

配置 LDAP 服务器以用于 Silk Central：

  1. 在菜单中，单击管理 > 系统设置。
  2. 单击 LDAP 服务器选项卡。
  3. 单击新建 LDAP 服务器。 将显示新建 LDAP 服务器对话框。
  4. 键入服务器的名称，还可选择键入说明。您可以为 LDAP 服务器定义任何名称；此字段对实际 LDAP 设置无任何影响。
  5. 选中活动复选框以激活与 Silk Central 配合使用的服务器。如果未选中，则 LDAP 服务器的服务对 Silk Central 不可用。
  6. 键入 LDAP 服务器的主机名或 IP 地址，以及用于 LDAP 服务的端口。默认端口为 389。使用 SSL 时，默认 LDAP 端口为 636。
  7. 选中使用 SSL 复选框以通过 SSL 连接到服务器。此复选框与端口字段中定义的设置密切相关。有关设置与 SSL 通信的其他信息，请参阅通过 SSL 与外部系统通信。
  8. 可选：如果您的用户应使用 <域>\<用户名> 模式登录Silk Central，请指定域。如果您的用户应在不输入域名的情况下登录 Silk Central，请将此字段留空。如果您的 Silk Central 安装包含多个客户端，请确保指定的 LDAP 域名与任何客户端名称均不冲突，因为 <域>\<用户名> 模式也用于登录特定客户端。
  9. 可选：在绑定 DN 字段中，键入要用于绑定到 LDAP 服务的用户的域名。此用户必须拥有从基 DN 根读取目录的权限。如果将此字段留空，则将使用匿名访问，除非 LDAP 服务器不支持匿名访问。
  10. 键入绑定 DN 所定义的用户密码。如果允许匿名访问，则无需使用该密码。
  11. 键入 LDAP 查询的基 DN 根。例如，DC=yourcompany,DC=com。
  12. 可选：键入要用于查询 LDAP 的用户筛选器。

    示例： (memberOf=CN=Development,CN=Users,DC=yourcompany,DC=com)

    此示例查询 LDAP 服务器，查找已登录 Silk Central、但属于 Development 团队成员的用户。某些情况下这可能非常有用。例如，您启用了自动帐户创建，但是希望 Silk Central 只为某个特定 LDAP 组的成员创建帐户。

  13. 可选：要按特定组筛选 LDAP 查询，请指定组筛选器。该语法与用户筛选器字段使用的语法相同。
  14. 单击配置 LDAP 属性，以将 LDAP 属性映射至 Silk Central 的用户和组设置。此设置在您打算将用户从 LDAP 服务器导入 Silk Central 时非常重要。
  15. 可选：可以让 Silk Central 在用户首次登录到 Silk Central 时自动创建 Silk Central 用户帐户。如果 Silk Central 中不存在使用所输入的登录名的用户帐户，那么将对照 LDAP 服务器来验证输入的凭据。如果验证成功，那么将在 Silk Central 中以提供的登录名和密码创建新帐户。新创建的帐户最初从所选的 Silk Central 用户（用作模板）复制常规设置，其中包括仪表板设置。名字、姓氏和电子邮件地址查询自 LDAP 值。要执行此操作，请单击用户帐户创建旁边的配置。在用户帐户创建对话框中，从列表中选择 Silk Central 用户。根据 LDAP 配置，可能需要调整名字、姓氏和电子邮件地址的 LDAP 值。
  16. 单击测试以执行 LDAP 服务器的测试连接。 有关更多信息，请参阅测试 LDAP 服务器。
  17. 单击确定以保存您的设置。
  18. 如果使用多个 LDAP 服务器：指定顺序号来排定查询 LDAP 服务器进行身份验证的顺序。
父主题： LDAP 身份验证
相关任务
从 LDAP 服务器导入组
添加项目
编辑项目和项目基线
编辑 LDAP 服务器
测试 LDAP 服务器


编辑 LDAP 服务器

要编辑 LDAP 服务器配置文件：

  1. 在菜单中，单击管理 > 系统设置。
  2. 单击 LDAP 服务器选项卡。
  3. 单击要编辑的 LDAP 服务器配置文件的名称。 此时将显示编辑 LDAP 服务器对话框。
  4. 键入服务器的名称，还可选择键入说明。您可以为 LDAP 服务器定义任何名称；此字段对实际 LDAP 设置无任何影响。
  5. 选中活动复选框以激活与 Silk Central 配合使用的服务器。如果未选中，则 LDAP 服务器的服务对 Silk Central 不可用。
  6. 键入 LDAP 服务器的主机名或 IP 地址，以及用于 LDAP 服务的端口。默认端口为 389。使用 SSL 时，默认 LDAP 端口为 636。
  7. 选中使用 SSL 复选框以通过 SSL 连接到服务器。此复选框与端口字段中定义的设置密切相关。有关设置与 SSL 通信的其他信息，请参阅通过 SSL 与外部系统通信。
  8. 可选：如果您的用户应使用 <域>\<用户名> 模式登录Silk Central，请指定域。如果您的用户应在不输入域名的情况下登录 Silk Central，请将此字段留空。如果您的 Silk Central 安装包含多个客户端，请确保指定的 LDAP 域名与任何客户端名称均不冲突，因为 <域>\<用户名> 模式也用于登录特定客户端。
  9. 可选：在绑定 DN 字段中，键入要用于绑定到 LDAP 服务的用户的域名。此用户必须拥有从基 DN 根读取目录的权限。如果将此字段留空，则将使用匿名访问，除非 LDAP 服务器不支持匿名访问。
  10. 键入绑定 DN 所定义的用户密码。如果允许匿名访问，则无需使用该密码。
  11. 键入 LDAP 查询的基 DN 根。例如，DC=yourcompany,DC=com。
  12. 可选：键入要用于查询 LDAP 的用户筛选器。

    示例： (memberOf=CN=Development,CN=Users,DC=yourcompany,DC=com)

    此示例查询 LDAP 服务器，查找已登录 Silk Central、但属于 Development 团队成员的用户。某些情况下这可能非常有用。例如，您启用了自动帐户创建，但是希望 Silk Central 只为某个特定 LDAP 组的成员创建帐户。

  13. 可选：要按特定组筛选 LDAP 查询，请指定组筛选器。该语法与用户筛选器字段使用的语法相同。
  14. 单击配置 LDAP 属性，以将 LDAP 属性映射至 Silk Central 的用户和组设置。此设置在您打算将用户从 LDAP 服务器导入 Silk Central 时非常重要。
  15. 可选：可以让 Silk Central 在用户首次登录到 Silk Central 时自动创建 Silk Central 用户帐户。如果 Silk Central 中不存在使用所输入的登录名的用户帐户，那么将对照 LDAP 服务器来验证输入的凭据。如果验证成功，那么将在 Silk Central 中以提供的登录名和密码创建新帐户。新创建的帐户最初从所选的 Silk Central 用户（用作模板）复制常规设置，其中包括仪表板设置。名字、姓氏和电子邮件地址查询自 LDAP 值。要执行此操作，请单击用户帐户创建旁边的配置。在用户帐户创建对话框中，从列表中选择 Silk Central 用户。根据 LDAP 配置，可能需要调整名字、姓氏和电子邮件地址的 LDAP 值。
  16. 单击测试以执行 LDAP 服务器的测试连接。 有关更多信息，请参阅测试 LDAP 服务器。
  17. 单击确定以保存您的设置。
父主题： LDAP 身份验证
相关任务
添加 LDAP 服务器
测试 LDAP 服务器


测试 LDAP 服务器

测试到 LDAP 服务器的连接：

  1. 在 Silk Central 中添加或编辑 LDAP 服务器配置文件时，添加 LDAP 服务器和编辑 LDAP 服务器对话框会分别显示测试按钮。
  2. 单击测试以显示测试 LDAP 配置对话框。
  3. 在测试用户名字段中，输入用于测试 LDAP 身份验证的用户名。
  4. 填写与用于测试 LDAP 身份验证的用户关联的测试密码。
  5. 单击测试以执行身份验证测试。
    注： 测试失败时将包含 LDAP 错误代码。
    对话框将向您显示测试是否成功。
  6. 单击关闭以分别返回到添加 LDAP 服务器对话框和编辑 LDAP 服务器对话框。 如果测试连接未成功，请编辑设置或向系统管理员请求帮助。 然后重新从第 2 步开始。
父主题： LDAP 身份验证
相关任务
添加 LDAP 服务器
编辑 LDAP 服务器


删除 LDAP 服务器

要删除 LDAP 服务器配置文件：

  1. 在菜单中，单击管理 > 系统设置。
  2. 单击 LDAP 服务器选项卡。
  3. 如果 LDAP 服务器处于活动状态，您需要先停用它，然后再进行删除。单击要删除的 LDAP 服务器配置文件的名称。 此时将显示编辑 LDAP 服务器对话框。
  4. 取消选中活动复选框以停用服务器并单击确定。
  5. 单击要删除的 LDAP 服务器的操作列中的 删除 （删除）。
  6. 单击是以确认删除。
父主题： LDAP 身份验证


LDAP 服务器页面

管理 > 系统 > LDAP 服务器

LDAP 服务器页面列出所有已配置的 LDAP 服务器。可使用此页面管理您的 LDAP 服务器。

在此页面中，您可以执行以下操作：

  • 单击新建 LDAP 服务器以配置新的 LDAP 服务器。
  • 指定顺序号来排定查询 LDAP 服务器进行身份验证的顺序。
  • 单击列表中的现有 LDAP 服务器以编辑设置。
  • 在操作列中单击 删除 （删除）以删除 LDAP 服务器（您事先需要停用 LDAP 服务器）。
父主题： LDAP 身份验证
相关任务
添加 LDAP 服务器
编辑 LDAP 服务器
测试 LDAP 服务器


Silk Performer 加载测试代理群集

除了将工作负载分配给各个代理外，您还可以将 Silk Performer 工作负载分配给具有已定义功能的代理群集。 Silk Performer 的动态工作负载分配功能符合负载测试对执行期间可用代理计算机的重播功能的特定要求。 在 Silk Performer 中为测试代理定义的功能用于优化工作负载至代理分配。 例如，如果测试需要仅由具有 SAPGUI 客户端的代理计算机提供的工作负载，则动态工作负载分配功能可以确保测试的工作负载仅分配给具有 SAPGUI 客户端的可用代理。 此外，还可以配置所需工作负载百分比或分配给每个代理的虚拟用户，从而确保推送的代理不会超过其容量。

在执行 Silk Performer 测试时，Silk Central 负载测试代理群集 XML 文件将从相应的执行服务器中签出，并在执行期间用于动态工作负载分配。 您必须通过 管理 > 系统 设置指定项目负载测试代理群集 XML 文件的位置。

将工作负载动态分配给负载测试代理群集的优势在于无需维持静态测试执行环境即可成功执行测试。 Silk Performer 可在具有相同功能的相同群集中将不可用代理的工作负载动态分配给可用代理。 根据 Silk Central 中的预定义计划管理和执行 Silk Performer 负载测试时，此功能具有特定值。 从 Silk Central 角度来说，在代理间平衡工作负载的方式和各个代理的运行状况不是需要考虑的问题。

有关动态工作负载分配的详细信息，请参阅 Silk Performer 帮助。

  • 上载加载测试代理群集文件
    添加或更改项目的加载测试代理群集文件，以支持 Silk Performer 动态工作负载分配。
  • 删除加载测试代理群集文件
    删除加载测试代理群集文件以将其从应用程序服务器中删除。
  • 编辑加载测试代理群集文件
    编辑您项目的加载测试代理群集文件以支持 Silk Performer 动态工作负载分配。
  • 加载测试代理群集页面
    显示当前加载测试代理群集 XML 文件
父主题： 基础结构


上载加载测试代理群集文件

介绍如何添加或更改项目的加载测试代理群集文件，以支持 Silk Performer 动态工作负载分配。

更改项目的代理群集文件定义：

  1. 在菜单中，单击管理 > 系统设置。
  2. 单击加载测试代理群集选项卡。
  3. 单击上载。
  4. 在上载代理群集文件对话框中，浏览到本地磁盘中代理群集文件的位置。 上载文件时，它会显示在加载测试代理群集页面中。
  5. 单击确定以确认您的选择。
父主题： Silk Performer 加载测试代理群集
相关任务
编辑加载测试代理群集文件


删除加载测试代理群集文件

删除加载测试代理群集文件以将其从应用程序服务器中删除。

要删除加载测试代理群集文件：

  1. 在菜单中，单击管理 > 系统设置。
  2. 单击加载测试代理群集选项卡。
  3. 单击删除。
  4. 单击是进行确认。
父主题： Silk Performer 加载测试代理群集


编辑加载测试代理群集文件

要编辑您项目的代理群集文件定义：

  1. 在菜单中，单击管理 > 系统设置。
  2. 单击加载测试代理群集选项卡。
  3. 单击要更改的加载测试代理群集文件的名称。
  4. 下载文件。
  5. 在编辑器中编辑文件。
  6. 上载文件。 有关更多信息，请参阅上载加载测试代理群集文件。
父主题： Silk Performer 加载测试代理群集
相关任务
上载加载测试代理群集文件


加载测试代理群集页面

管理 > 系统设置 > 加载测试代理群集

加载测试代理群集页面显示当前配置的加载测试代理群集 XML 文件。 使用此页面可以管理 Silk Performer 加载测试代理群集文件，以支持动态工作负载分配。

您可以在此页面中执行以下操作：

  • 单击上载以上载加载测试代理群集 XML 文件。
  • 单击删除以删除现有的加载测试代理群集 XML 文件。
  • 单击加载测试代理群集文件的名称以下载和编辑该文件。
父主题： Silk Performer 加载测试代理群集


系统诊断

使用系统诊断选项卡检索诊断信息和系统日志文件。

  • 系统诊断
    介绍如何查看和下载系统诊断。
  • 前端服务器日志
    介绍前端服务器日志文件。
  • 应用程序服务器日志
    介绍应用程序服务器日志文件。
父主题： 管理客户端
相关概念
Micro Focus SupportLine 所需的信息


系统诊断

系统诊断页面提供检索以下系统信息的方法：

  • 产品版本。
  • 数据库的版本和类型。
  • 使用的集成。
  • 系统环境信息和系统属性。
  • JDBC 信息。
  • 数据库统计信息：项目、测试类型、索引、触发器和约束的数量。
  • 应用程序服务器和前端服务器日志。

单击下载按钮可以将页面压缩和下载到本地文件系统。您可以通过复选框选择应下载的服务器日志。

  1. 您可以远程访问系统诊断页面。或者，如果您无法再登录系统，您也可以在运行前端服务器的计算机上本地访问该页面。
    • 对于远程访问：
      1. 以系统管理员身份登录。
      2. 单击系统诊断 > 系统诊断。
      3. 单击打开系统诊断。
    • 如果无法远程访问：
      1. 在运行前端服务器的计算机上导航到 http://localhost:19120/systemdiagnostics 或 http://127.0.0.1:19120/systemdiagnostics（请不要使用主机名或服务器的外部 IP 地址）。
  2. 通过复选框选择应下载的 Silk Central 服务器日志。
  3. 单击下载以将数据压缩和下载到本地文件系统。
父主题： 系统诊断
父主题： 联系Micro Focus


前端服务器日志

要访问此页面，以系统管理员身份登录系统，然后单击系统诊断 > 前端服务器日志。 有关更多信息，请参阅系统管理员。

使用此页面来查看 Silk Central 前端服务器服务的日志信息。

对于每个日志文件，此页面将显示以下列：

列 | 说明
操作 | 单击 [image] 和 [image] 按钮以删除或下载日志文件。
名称 | 日志文件的名称。
大小 | 日志文件的物理大小。
日期 | 日志文件最后以物理方式保存的日期。
父主题： 系统诊断
相关概念
系统管理员


应用程序服务器日志

要访问此页面，请以系统管理员身份登录，然后单击系统诊断 > 应用程序服务器日志。 有关更多信息，请参阅“系统管理员”。

使用此页面以通过 Silk Central 应用程序服务器服务查看日志信息。

对于每个日志文件，此页面将显示以下列：

列 | 说明
操作 | 单击 [image] 和 [image] 按钮以删除或下载日志文件。
名称 | 日志文件的名称。
大小 | 日志文件的物理大小。
日期 | 日志文件最后以物理方式保存的日期。
父主题： 系统诊断
相关概念
系统管理员


配置高级设置

本节介绍如何配置高级设置，以自定义您的 Silk Central 系统。

  • 登录选项
    介绍增强的登录配置。
  • 可疑执行持续时间
    介绍在执行时间太长时如何通过电子邮件通知管理员。
  • 禁用外部问题统计信息的更新
    介绍如何禁用外部问题跟踪配置文件的问题统计信息的更新。
  • 日期和时间格式
    介绍如何使用 Silk Central 提供的用户定义日期和时间格式设置。
  • 主机名称显示
    介绍如何在 Web 浏览器的标题栏中显示前端服务器的主机名称。
  • 在文件系统中存储附件和结果文件
    默认情况下，Silk Central 会将所有附件和结果文件存储在数据库中，但您可以配置Silk Central，以将这些文件存储在应用程序服务器的文件系统中。
  • 配置 LQM 报告更新程序
    配置更新 LQM 报告表（LQM 报告更新程序）的线程的间隔和其他设置。
  • 计划自动 LDAP 组同步
    如果已将用户组从 LADP 服务器导入 Silk Central 系统中，则可指定计划，以自动同步您的 Silk Central 组和 LADP 服务器上所做的更改。
  • 测试中的数据缓存
    介绍 Silk Central 如何使用缓存提高前端服务器的可扩展性和降低数据库负载。
  • 配置 JMX 设置
    介绍配置 JMX 设置的位置。
  • 执行服务器主机名称解析
    如果执行服务器的 IP 地址更改，执行服务器可能不再能被应用程序服务器识别。
  • 在 Issue Manager 中配置 Silk Central 位置
    在 Issue Manager 中配置 Silk Central 安装的位置，以便通过问题跟踪相关测试。
  • 禁用执行服务器上未使用的端口
    禁用未由执行服务器使用的端口。
  • 设置 MRU 报告的最大数目
    配置最近使用 (MRU) 报告的最大数目，这些报告显示在报告单元的上次使用的报告列表框中。
  • Silk Central 服务器的内存设置
    介绍 Silk Central 服务器的内存设置。
  • 设置步骤结果文件的最大大小
    介绍如何在手动测试执行期间，限制测试人员附加到测试步骤的结果文件的大小。
  • 为 Silk Performer 结果存储百分点标记数据
    如果希望访问此信息，请启用为 Silk Performer 结果存储百分点标记数据。
父主题： 配置和管理基础架构


登录选项

提供以下两个增强的登录配置：

记住登录

在 Silk Central 登录页面上更改记住登录选项的默认设置。

通常，当用户使用多个浏览器窗口时，每个浏览器会话都会签出唯一许可证。启动记住登录可允许单个用户在单个计算机上使用多个浏览器会话，同时仅签出一个许可证。

每个用户都可根据需要启用或禁用记住登录选项，而管理员则可以设置默认设置。

Cookie 持续时间

当用户每次访问 Silk Central 时，将创建包含编码登录信息的 Cookie。当用户注销或会话超时时，这些 Cookie 将被销毁。但是，如果启用记住登录选项，则当会话超时时，Cookie 不会被销毁。相反，它们将在一段时间内保持活动状态。这使用户可以继续使用 Silk Central，而无需在每次会话超时后重新输入登录信息。默认情况下，Cookie 将在 30 天内保持活动状态。管理员可以调整持续时间设置。

  • 配置记住登录选项
    配置记住登录选项，以在具有多个浏览器会话的一台计算机上作为个人工作，同时仅签出一个许可证。
  • 调整 Cookie 持续时间
    调整登录 Cookie 的持续时间，以更改系统记住登录的时间。
父主题： 配置高级设置
相关概念
超级用户
相关任务
登录 Silk Central


配置记住登录选项

启用或禁用记住登录选项：
  1. 在实例管理页面上，停止要修改的实例的前端服务器。
  2. 使用文本编辑器打开 SccFrontendBootConf.xml 文件。 此文件在前端服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\FontendServer。
  3. 找到 BootConf\Options\Login\RememberLogin XML 标记。 默认情况下，此标记设置为 <RememberLogin>true</RememberLogin>。
  4. 将值设置为 false 以使登录页面打开时记住登录复选框默认为未选中状态。将值设置为 true 以使登录页面打开时记住登录复选框默认为选中状态。
  5. 保存并关闭 XML 文件。
  6. 重新启动前端服务器。
父主题： 登录选项
相关任务
管理实例


调整 Cookie 持续时间

设置登录 Cookie 的持续时间：

  1. 在实例管理页面上，停止要修改的实例的前端服务器。
  2. 使用文本编辑器打开 SccFrontendBootConf.xml 文件。 此文件在前端服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\FontendServer。
  3. 找到 BootConf\Options\Login\MaxCookieAge XML 标记。 默认情况下，此标记设置为 <MaxCookieAge>30</MaxCookieAge>。
  4. 将值设置为想要登录 Cookie 在用户计算机上保持活动状态的天数。
  5. 保存并关闭 XML 文件。
  6. 重新启动前端服务器。
父主题： 登录选项
相关任务
管理实例


可疑执行持续时间

测试 的执行持续时间不同，但是，如果执行时间太长，上次对执行计划做出更改的用户可以获得电子邮件通知。

Silk Central 在 测试 执行时间超过一定时间时发送通知。用户可以定义发送电子邮件前 测试 执行可能要花费的时间。

注： 您也可以在测试区域的成功条件部分设置 执行超时 [秒] 属性，来为每个特定测试设置超时。
  • 设置可疑执行持续时间
    设置可疑执行持续时间，以定义 Silk Central 向管理员发送通知之前允许测试执行的持续时间。
父主题： 配置高级设置


设置可疑执行持续时间

设置可疑执行持续时间：

  1. 在实例管理页面上，停止要修改的实例的应用程序服务器。
  2. 使用文本编辑器打开 TmAppServerHomeConf.xml 文件。
    此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\AppServer。
  3. 找到 Config\ExecutionTracking\SuspicousDuration XML 标记。 默认情况下，此标记设置为 <SuspicousDuration>360</SuspicousDuration>。
  4. 将持续时间值设为分钟数，在这段时间之后，Silk Central 应通知管理员测试执行的时间过长。
  5. 保存并关闭 XML 文件。
  6. 重新启动应用程序服务器。
父主题： 可疑执行持续时间
相关任务
管理实例


禁用外部问题统计信息的更新

更新外部问题跟踪配置文件的问题统计信息可能会占用较多内存。这也可能降低性能。要禁用更新：
  1. 在实例管理页面上，停止要修改的实例的应用程序服务器。
  2. 使用文本编辑器打开 TmAppServerHomeConf.xml 文件。
    此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\AppServer。
  3. 找到 Config/IssueStateUpdate/UpdateIssueUnitStatistics XML 标记。 默认情况下，此标记设为 true。
  4. 将值设置为 false 可禁用更新。
  5. 保存并关闭 XML 文件。
  6. 重新启动应用程序服务器。
父主题： 配置高级设置
相关任务
管理实例


日期和时间格式

Silk Central 提供用户定义日期和时间格式设置。每个 Silk Central 用户都能更改其用户设置，包括用于显示自定义日期格式（长日期或短日期格式）的选项。有关更多信息，请参阅编辑用户帐户。

Silk Central 提供可供用户选择的预定义日期和时间格式列表。Silk Central 管理员可使用自定义格式填充这些列表。

模式定义

日期和时间格式由日期和时间模式字符串指定。在日期和时间模式字符串中，未加引号的字母“A”到“Z”以及“a”到“z”被解释为表示日期或时间字符串组件的模式字母。文本可加上单引号 (') 以避免解释。“''”表示一个单引号。所有其他字符都不会被解释；这些字符只会在格式化过程中复制到输出字符串或在分析过程中与输入字符串相匹配。

以下模式字母已定义。从“A”到“Z”以及“a”到“z”的所有其他字符会被保留：
字母 | 日期或时间组件 | 表示 | 示例
G | 纪元标志符 | 文本 | AD
y | 年份 | 年份 | 1996; 96
M | 年中的月份 | 月 | July; Jul; 07
w | 年中的周数 | 数字 | 27
三 | 月份中的周数 | 数字 | 2
D | 年中的天数 | 数字 | 189
d | 月份中的天数 | 数字 | 10
五 | 月份中的星期 | 数字 | 2
E | 星期中的天数 | 文本 | Tuesday; Tue
a | Am/pm 标记 | 文本 | 下午
H | 一天中的小时数 (0-23) | 数字 | 0
k | 一天中的小时数 (1-24) | 数字 | 24
K | 以 am/pm 表示的小时数 (0-11) | 数字 | 0
h | 以 am/pm 表示的小时数 (1-12) | 数字 | 12
m | 小时中的分钟数 | 数字 | 30
s | 分钟中的秒数 | 数字 | 55
六 | 毫秒 | 数字 | 978
z | 时区 | 通用时区 | Pacific Standard Time; PST; GMT-08:00
Z | 时区 | RFC 822 时区 | -0800

模式字母通常被重复，因为其数量决定确切的表示。

以下列表介绍上表的表示列中的项目：
项
说明
文本
对于格式化而言，当模式字母数量为 4 个或更多时，使用完整形式；否则，使用缩写形式（可用时）。对于分析而言，无论模式字母的数量如何，这两种形式均可接受。
数字
对于格式化而言，模式字母的数量是最小位数，较短的数字使用零补够此数量。对于分析而言，模式字母的数量将被忽略，除非需要将其分隔成两个相邻字段。
年份
对于格式化而言，当模式字母的数量为 2 时，年份将被截断为两位数，否则会将其解释为一个数字。
月
当模式字母的数量为 3 或更多时，月份将被解释为文本；否则，会将其解释为一个数字。
通用时区
当时区具有名称时，会将其解释为文本。当模式字母的数量少于 4 时，将显示时区缩写，例如 PST。当模式字母的数量为 4 或更多时，将显示全名，例如 Pacific Standard Time。
RFC 822 时区
使用 RFC 822 4 位数时区格式，例如 -0800。

示例

以下示例显示在美国如何解释日期和时间模式。给定日期和时间是 2001-07-04 12:08:56 本地时间，太平洋标准时区。
日期和时间模式 | 结果
"yyyy.MM.dd G 'at' HH:mm:ss z" | 2001.07.04 AD at 12:08:56 PDT
"EEE, MMM d, ''yy" | Wed, Jul 4, '01
"h:mm a" | 12:08 PM
"hh 'o''clock' a, zzzz" | 12 o'clock PM, Pacific Daylight Time
"K:mm a, z" | 0:08 PM, PDT
"yyyyy.MMMMM.dd GGG hh:mm aaa" | 02001.July.04 AD 12:08 PM
"EEE, d MMM yyyy HH:mm:ss Z" | Wed, 4 Jul 2001 12:08:56 -0700
"yyMMddHHmmssZ" | 010704120856-0700
  • 自定义日期和时间格式
    自定义日期和时间格式设置以根据需要显示日期。
父主题： 配置高级设置
相关任务
添加用户帐户
编辑用户帐户
删除用户帐户


自定义日期和时间格式

要自定义日期和时间格式，请执行以下操作：

  1. 在实例管理页面上，停止要修改的实例的前端服务器。
  2. 使用文本编辑器打开 SccFrontendBootConf.xml 文件。 此文件在前端服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\FontendServer。
  3. 找到 DateFormats XML 标记。 默认情况下，XML 标记 <LongDateFormats> 和 <ShortDateFormats> 显示可用日期格式。您可添加或删除要对用户来说可用或不可用的任何格式。
  4. 键入时间格式，如日期和时间格式中所述。
  5. 保存并关闭 XML 文件。
  6. 重新启动前端服务器。
父主题： 日期和时间格式
相关任务
管理实例


主机名称显示

使用多个前端服务器上的 Web 应用程序时，了解使用的主机非常有用。 Silk Central 提供的设置用于在 Web 浏览器的标题栏中显示前端服务器的主机名称。

  • 在 Web 浏览器的选项卡名称中显示或隐藏主机名称
    在 Web 浏览器的选项卡名称中显示或隐藏 Silk Central 前端服务器的主机名称。
父主题： 配置高级设置


在 Web 浏览器的选项卡名称中显示或隐藏主机名称

要在 Web 浏览器的选项卡名称中显示或隐藏主机名称：

  1. 在实例管理页面上，停止要修改的实例的前端服务器。
  2. 使用文本编辑器打开 SccFrontendBootConf.xml 文件。 此文件在前端服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\FontendServer。
  3. 在 Options 文件的部分找到 DisplayHostNameInTitleBar XML 标记。
  4. 如果将值设置为真，则在访问 Silk Central 时，前端服务器的主机名称将显示在 Web 浏览器的选项卡名称中。如果将值设置为假（默认值），则不会显示主机名称；如果将值设置为任何其他字符串，则会显示所指定的字符串。始终显示 Silk Central 中当前选择的单元。

    例如，当 XML 标记设置为真时，浏览器将显示：<单元中> | HOSTNAME.

    当该标记设置为假时，浏览器将显示：<单元中> | Silk Central.

    当输入自定义文本（例如 MyCustomText）时，浏览器将显示：<单元中> | 自定义文本.

    当该标记留空时，浏览器将显示：<单元中>.

  5. 保存并关闭 XML 文件。
  6. 重新启动前端服务器。
父主题： 主机名称显示
相关任务
管理实例


在文件系统中存储附件和结果文件

默认情况下，Silk Central 会将所有附件和结果文件存储在数据库中，但您可以配置Silk Central，以将这些文件存储在应用程序服务器的文件系统中。
虽然不建议将附件和结果文件与其他数据分开保存，但您有合理的理由采用这种方法（例如，数据库空间成本）。此方法的一个弊端是必须维护双份数据，这意味着必须备份您的数据库还有文件系统。恢复数据库备份时，您还需要恢复文件系统。
警告：
如果启用将文件保存至文件系统这一选项，请确保永远不要更改此位置的结构，也不要直接移动、更新或删除文件。只有 Silk Central 服务及您备份和恢复使用的系统应具备指定文件存储根目录的写入权限。
  1. 在实例管理页面上，激活要修改的实例的维护模式。有关其他信息，请参阅维护模式。
  2. 以系统管理员身份登录您的实例并断开数据库连接。有关其他信息，请参阅从数据库断开连接。
  3. 在实例管理页面上，停止要修改的实例。
  4. 使用文本编辑器打开 SccAppServerBootConf.xml 文件。 此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\AppServer。
  5. 在文件的 <Config>/<RdbmsSpecifics> 部分找到 <StoreFilesOnFileSystem> XML 标记。将此标记的值设置为 true。
  6. 保存并关闭 XML 文件。
  7. 在实例管理页面上，重新启动该实例。
  8. 再次以系统管理员身份登录实例。在数据库页面上，您将会看到一个名为文件存储根目录的新字段，您必须在该字段中定义本地路径（例如“c:/sc_files/testdb”），此路径将用于存储附件和结果文件。此路径需要已存在，且前端和应用程序服务器服务需要具备此文件夹的完全权限。
  9. 单击连接数据库。
现在，所有附件和结果文件都将保存在指定位置。连接数据库中已保存附件和结果文件将陆续移至文件系统。如果文件系统不可用，Silk Central 会将文件存储在数据库 blob 表中，并稍后在文件系统再次可用时将文件移至文件系统。

请注意，目前尚没有自动将文件重新移回数据库的方法。请仅在打算永久将文件存储在文件系统中时启用此选项。

父主题： 配置高级设置


配置 LQM 报告更新程序

介绍如何配置更新 LQM 报告表（LQM 报告更新程序）的线程的间隔和其他设置。

配置 LQM 报告更新程序设置：

  1. 在实例管理页面上，停止要修改的实例的应用程序服务器。
  2. 使用文本编辑器打开 TmAppServerHomeConf.xml 文件。
    此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\AppServer。
  3. 找到 LQMReporting XML 标记。 您可修改以下设置：
    UpdateInterval
    定义使用最新数据更新 LQM 报告表的时间间隔（以秒为单位）。
    MSSqlUpdateBatchSize
    一次处理的测试表数量。批大小决定应用程序服务器上用于更新进程的内存和处理器资源大小。此设置仅影响 MS SQL Server 数据库。
    OracleUpdateBatchsize
    与 MSSqlUpdateBatchSize 类似，但仅适用于 Oracle 数据库。
    QueryTimeout
    指定在其后中止 LQM 报告更新进程中的查询的超时时间（以秒为单位）。0 或负值指定查询永远不会超时。
    OracleCheckForUpdateStrategy
    确定如何从源表中读取更新进程。允许的值为 NOWAIT 和 WAIT。
    • NOWAIT：当更新进程要从源表进行读取并且另一进程当前正在写入这些表时，更新进程会终止并在下一次调用时重试。
    • WAIT：更新进程将获取表锁并等到其他进程完成对表的访问之后从源表进行读取。其优点是始终能够执行该进程，因为它无需等到表解锁。不足之处是，试图在 LQM 更新进程后访问表的所有其他进程将被阻止，并且必须等到该进程释放表锁。
  4. 保存并关闭 XML 文件。
  5. 重新启动应用程序服务器。
父主题： 配置高级设置
相关任务
管理实例


计划自动 LDAP 组同步

如果已将用户组从 LADP 服务器导入 Silk Central 系统中，则可指定计划，以自动同步您的 Silk Central 组和 LADP 服务器上所做的更改。
要定义计划以同步 Silk Central 组和 LDAP 服务器上所做的更改，请执行以下操作：
  1. 在实例管理页面上，停止要修改的实例的应用程序服务器。
  2. 使用文本编辑器打开 TmAppServerHomeConf.xml 文件。
    此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\AppServer。
  3. 找到 LdapUpdate XML 标记。 您可修改以下设置：
    ScheduledTime
    时间戳（hh:mm，24 小时制），即第一次更新 LDAP 数据的时间。ScheduledTime 跟随应用程序服务器系统环境的时区。将此设置留空可禁用自动同步。
    UpdateIntervalInMinutes
    此时间间隔（分钟）指定 LDAP 组与用户同步的频率，相对于从 ScheduledTime 开始。最小值为 1。
  4. 保存并关闭 XML 文件。
  5. 重新启动应用程序服务器。
父主题： 配置高级设置
父主题： 管理组
相关任务
从 LDAP 服务器导入组


测试中的数据缓存

当多个用户同时处理同一个项目时，Silk Central 将在测试中使用缓存来提高前端服务器的可扩展性和降低数据库负载。测试树和测试筛选器对前端服务器和数据库服务器具有重大影响。由于特定项目的测试树和筛选器中的信息可在用户之间共享，因此这些区域非常适合缓存。

测试树缓存

测试树缓存会保留当前在内存中使用的项目的所有树信息并定期检查数据库中的树更改。管理员可通过在 TMFrontendBootConf.xml 配置文件中设置 Cache/TestPlanTree/CheckForChangesInterval 来影响缓存的行为。这是树信息处于已过期状态的最大时间间隔（以秒为单位）。无论此设置如何，如果同一台前端服务器上的测试、文件夹或容器发生更改，则缓存将使用更改立即更新。当其他前端服务器上发生更改时，Cache/TestPlanTree/CheckForChangesInterval 设置才适用。当用户超过一个小时不使用项目时，将清除整个项目树缓存并在用户下次访问该项目时重新加载项目。

测试筛选器缓存

使用筛选器缓存时，与特定筛选器的条件匹配的测试 ID 将根据最小缓存时间设置和每个筛选器的执行时间缓存指定的一段时间。管理员可通过设置 TMFrontendBootConf.xml 配置文件中 Cache/FilterCache/ 处的两个属性来影响此行为。

第一个属性 MinimalLifeTime 定义可从缓存中删除筛选器结果之前的最小时间（以秒为单位）。第二个属性 LifeTimeMultiplier 让此最小设置依赖于执行筛选器查询的时间。例如，如果您定义了一个 > 0 的乘数，则结果可在缓存中保留的最大时间为 MinimalLifeTime 或查询执行时间乘以 LifeTimeMultiplier。因此，如果您拥有 1 秒钟即可执行的筛选器查询，并且使用默认值（MinimalLifeTime 和 LifeTimeMultiplier 均使用 30），则筛选器结果将缓存 30 秒。如果筛选器查询的执行时间为二分之一秒，则筛选器结果仍将缓存 30 秒。但是，如果筛选器查询的执行时间为 2 秒，则筛选器结果将缓存 60 秒。

推荐引擎缓存

在关键字驱动的测试编辑器中将关键字添加到关键字驱动的测试或关键字序列时，Silk Central 会推荐您可能要用作测试中的下一个关键字的现有关键字。推荐的关键字列在关键字列表的最上面，并由条形图指出，条形图填充的部分对应于 Silk Central 推荐该关键字的推荐度。

管理员可在 TMFrontendBootConf.xml 配置文件中设置 RecommendationCache/ExpireAfterWrite 属性来影响推荐缓存的刷新时间间隔。

用于缓存的 JMX 度量

Silk Central 提供 JMX 读取测量来监视基础 Java 进程和其他特定于进程的测量。用于测试树缓存的 JMX 信息以及测试筛选器缓存位于 borland.com/Frontend/TM 处的 JMX 度量树中。

注： Silk Performance Explorer 和其他工具可用于跟踪这些及其他测量。
  • 测试中的 JMX 缓存测量
    可以在 JMX 度量树 (borland.com/Frontend/TM) 的前端服务器中找到用于测试树缓存和筛选器缓存的 JMX 信息
父主题： 配置高级设置
相关参考
在 内的测试中管理关键字
管理库中的关键字
Silk Central 推荐哪些关键字？


测试中的 JMX 缓存测量

可以在 JMX 度量树 (borland.com/Frontend/TM) 的前端服务器中找到用于测试树缓存和筛选器缓存的 JMX 信息

测试树缓存测量

有两个主测量可用于测试树缓存。TestPlanTreeCache 仅提供测量 NumberOfCachedProjects，用于测量当前缓存的项目数量。项目缓存的所有详细信息都可从第二个测量 TestPlanTreeCache_<number> 中获取。此测量实际上包含以下测量：

度量 | 说明
点击数 | 缓存已使用且无需数据库请求的次数。
LastUpdateCheckDurationInMillis | 上次更新所花的时间（毫秒），参见 LastUpdateCheckTime，用于检查数据库中的更新。
LastUpdateCheckTime | 上次更新检查发生的时间。
LastUpdateDurationInMillis | 上次更新所花的时间（毫秒），参见 LastUpdateTime，用于在发生更改后更新缓存。
LastUpdateTime | 由测试树中的更改所导致的上次缓存更新发生的时间。
TreeInitializationTimeInMillis | 将整个项目树加载到缓存所花的时间（毫秒）。只要加载项目缓存，此值将保持不变。
TreeSize | 测试节点的数量，它们是指项目中的测试容器、测试文件夹和测试。
UpdateChecks | 自初始化项目树缓存以来，该项目测试树的更改检查次数。
更新 | 由于测试树中的更改所导致的缓存树更新的次数。

测试筛选器缓存测量

TestPlanFilterCache 测量包含以下三个测量：

度量 | 说明
点击数 | 缓存已使用且不需要在数据库上单独执行筛选的次数。
缺失数 | 未使用筛选器缓存，但已对数据库执行筛选的次数。
大小 | 缓存筛选器结果的当前数量。
父主题： 测试中的数据缓存
父主题： 配置 JMX 设置


配置 JMX 设置

Silk Central 提供了一组用于配置 JMX 设置的默认端口。

配置 JMX 设置的可用位置

默认端口上的通信默认为未加密，这意味着没有运行 SSL。
重要： Micro Focus 不对您的 JMX 安全设置负责。请确保 IT 部门相应地配置 JMX 安全。
设置 | 说明
com.sun.management.jmxremote.ssl | 默认情况下，SSL 设置为 false。
com.sun.management.jmxremote.authenticate | 默认情况下，身份验证设置为 false。
您可在位于 C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<实例编号>_<实例名称>\Conf 的 processconfig 文件中修改这些设置。请注意，只要上述其中任一设置设为 false，JMX 连接就不安全。

要通过 JMX 访问信息或执行操作，您需要使用 JMX 连接字符串。单击 设置 打开设置对话框。在服务器选项卡中，选择所需的服务器并复制 JMX 连接字符串。 有关其他信息，请参阅管理实例。

  • 测试中的 JMX 缓存测量
    可以在 JMX 度量树 (borland.com/Frontend/TM) 的前端服务器中找到用于测试树缓存和筛选器缓存的 JMX 信息
  • 用于监视 LQM 报告更新程序的 JMX 测量
    可在位于 borland.com/LQMReporting/TM 的 JMX 测量树中的应用程序服务器上的 LQM 报告更新程序中找到 JMX 信息。
  • DataMart 的 JMX 测量
    可在位于 borland.com/DataMart 的 JMX 测量树中的应用程序服务器上找到有关 DataMart 的 JMX 信息。
  • LDAP 同步的 JMX 测量
    可在位于 borland.com/LdapUpdater 的 JMX 测量树中的应用程序服务器上找到有关 LDAP 同步的 JMX 信息。
父主题： 配置高级设置


用于监视 LQM 报告更新程序的 JMX 测量

LQM 报告更新程序测量

提供以下测量：

测量 | 说明
LastDataLoadResetTime | 提供上次对 LQM 报告表执行重置的时间。如果属性为空，则表示在进程的生存期内未执行重置。
LastDeleteDurationInMillis | 从 LQM 报告表中移除已删除的节点所花的时间。
LastDeleteTestsCnt | 在上次运行中删除的测试数。
LastInsertLQMTestsDuration | 在 LQM_Tests 表中插入新测试所花的时间。
LastInsertLQMTestPDAsDuration | 在 LQM_TestPDAs 表中插入新测试所花的时间。
LastInsertLQMTestUDAsDuration | 在 LQM_TestUDAs 表中插入新测试所花的时间。
LastRunFromDate | 提供当前更新周期的处理开始时间范围。
LastRunToDate | 提供当前更新周期的处理结束时间范围。
LastSelectChangedDataIterateDurationInMillis | 循环访问已更改数据所用的时间。
LastSelectChangedDataQueryDurationInMillis | 查询已更改数据所花的时间。
LastTotalUpdateDurationInMillis | 运行上次更新所花的总时间。
LastUpdateFixedAttributesDurationInMillis | 上次更新已修复属性所花的时间。
LastUpdatePDAttributesDurationInMillis | 上次更新 LQM_TestPDAs 表所用的时间。
LastUpdatesNeededCheckDurationInMillis | 上次对新数据或已更改数据进行检查所花的时间（毫秒）。
LastUpdatesNeededCheckOracleWaitForTableLocksDuration | 检查更新测试时，Oracle 要求特殊处理。可能需要等待其他进程完成测试表上的事务。等待这些事务的时间由该属性进行测量。
LastUpdateTestsDurationInMillis | 上次更新 LQM_Tests 表中的属性所花的时间。
LastUpdateUDAttributesDurationInMillis | 上次更新 LQM_TestUDAs 表所用的时间。
父主题： 配置 JMX 设置


DataMart 的 JMX 测量

DataMart 更新程序测量

可在位于 borland.com/DataMart/TM 的 JMX 测量树中的应用程序服务器上找到有关 DataMart 更新程序的 JMX 信息。

测量 | 说明
AverageCheckDurationInMilliseconds | 用于检查已更新行的平均时间（毫秒）
AverageUpdateDurationInMilliseconds | 用于更新行的平均时间（毫秒）
FailedCheckCount | 检查更新失败的次数
FailedUpdateCount | 更新失败的次数
FastestCheckInMilliseconds | 用于检查已更新行的最短时间（毫秒）
FastestUpdateInMilliseconds | 用于更新行的最短时间（毫秒）
Id | DataMart 更新程序的 ID
IntervalInMilliseconds | 定义 DataMart 更新程序运行频率的间隔（毫秒）
LastBlockedRunDate | 最后一次阻止执行的时间（等待独占访问失败）
LastFailedRunDate | 最后一次执行失败的时间
LastSuccessfulRunDate | 最后一次执行成功完成的时间
LatestDataLoadInfo | 关于最新数据加载的信息
SlowestCheckInMilliseconds | 用于检查已更新行的最长时间（毫秒）
SlowestUpdateInMilliseconds | 用于更新行的最长时间（毫秒）
SlowestWaitForExclusiveAccessInMilliseconds | 用于等待独占访问的最长时间（毫秒）
StartupDate | DataMart 更新程序初始化的时间
SuccessfulCheckCount | 成功检查更新的次数
SuccessfulUpdateCount | 成功更新的次数

DataMart 服务测量

可在位于 borland.com/DataMart/Service 的 JMX 测量树中的应用程序服务器上找到有关 DataMart 服务的 JMX 信息。

测量/操作 | 说明
已启用 | 显示是启用还是禁用 DataMart 服务。
disable() | 禁用 DataMart 服务。
enable() | 启用 DataMart 服务。
isEnabled() | 查询是启用还是禁用 DataMart 服务。
父主题： 配置 JMX 设置


LDAP 同步的 JMX 测量

可在位于 borland.com/LdapUpdater 的 JMX 测量树中的应用程序服务器上找到有关 LDAP 同步的 JMX 信息。
测量/操作 | 说明
已启用 | 显示是启用还是禁用自动 LDAP 同步。
LastDurationInMillis | 上次 LDAP 同步的持续时间（毫秒）。
enable() | 启用自动 LDAP 同步。
disable() | 禁用自动 LDAP 同步。
父主题： 配置 JMX 设置


执行服务器主机名称解析

如果执行服务器的 IP 地址更改，执行服务器可能不再能被应用程序服务器识别。重新启动应用程序服务器意味着执行服务器将被再次识别。

Java 使用缓存来存储主机名称解析以防止 DNS 欺骗攻击。在 Silk Central 中，会始终缓存正确的主机名称解析的结果，但可通过编辑应用程序服务器上的文件 java.security 来进行更改。这使应用程序服务器可识别执行服务器，即便其 IP 地址已更改。

有关此 Java 设置的更多信息，请访问网络属性页面。

  • 禁用主机名称解析的缓存
    禁用主机名称解析 (DNS) 的缓存以指定永不缓存主机名称解析。
父主题： 配置高级设置


禁用主机名称解析的缓存

要指定永不缓存主机名称解析：

  1. 在实例管理页面上，停止要修改的实例的应用程序服务器。
  2. 使用文本编辑器打开 java.security 文件。 此文件在应用程序服务器上的默认路径为 C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<实例编号>_<实例名称>\lib\jre\lib\security。如果您的应用程序服务器运行的是 64 位模式，请改用 jre64\lib\security 文件夹。
  3. 找到行 #networkaddress.cache.ttl=-1 并将其更改为 networkaddress.cache.ttl=0。
    注： 需要删除“#”字符以取消此行的注释。
    警告：
    应与您的网络管理员讨论此更改，因为这样做可能涉及安全问题。
  4. 保存并关闭文件。
  5. 重新启动应用程序服务器。
父主题： 执行服务器主机名称解析
相关任务
管理实例


在 Issue Manager 中配置 Silk Central 位置

介绍如何在 Issue Manager 中配置 Silk Central 安装的位置。这样便能够通过 Issue Manager 中的问题跟踪 Silk Central 中的相关测试。有关使用可跟踪性功能的更多信息，请参阅 Issue Manager 文档。

在 Issue Manager 中配置 Silk Central 位置：

  1. 在实例管理页面上，停止要修改的实例的前端服务器。
  2. 使用文本编辑器打开 SRFrontendBootConf.xml 文件。 此文件在前端服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\FontendServer。
  3. 找到 Alm\ElementServiceEndpoint 和 Alm\LinkServiceEndpoint XML 标记。
  4. 在这两个标记中，将默认值 localhost:19120 替换为 Silk Central 安装的主机和端口信息。 如果 Silk Central 安装与 Issue Manager 安装使用相同的前端服务器，您可使用具有默认端口的 Tomcat Web 服务器，然后保留默认值。
  5. 保存并关闭 XML 文件。
  6. 如果不使用默认端口，请编辑位于 \instance_<实例编号>_<实例名称>\wwwroot\AlmServices1.0 中的文件 configuration.xml。找到 connectString XML 标记，将其设为正确端口。 示例：
    <properties>
   <name>connectString</name>
   <!-- value>com.borland.tm.system.endpoint=http://gershwin:19120/services/sccsystem;
      com.borland.tm.spi.endpoint=http://gershwin:19120/services/SpiService</value  -->
   <value>com.borland.tm.system.endpoint=http://MyHost:8555/services/sccsystem;
      com.borland.tm.spi.endpoint=http://MyHost:8555/services/SpiService</value>
</properties>
  7. 重新启动前端服务器。
父主题： 配置高级设置
相关任务
管理实例


设置 MRU 报告的最大数目

设置上次使用的报告列表框中显示的 MRU 报告的最大数目：

  1. 在实例管理页面上，停止要修改的实例的前端服务器。
  2. 使用文本编辑器打开 SccFrontendBootConf.xml 文件。 此文件在前端服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\FontendServer。
  3. 在 <Report> 文件的部分找到 <MRUListSize> XML 标记。 此标记的默认值为 10。
  4. 将此值设为您要在上次使用的报告列表框中显示的报告的最大数目。
  5. 保存并关闭 XML 文件。
  6. 重新启动前端服务器。
父主题： 配置高级设置


Silk Central 服务器的内存设置

此部分介绍当出现内存不足错误时如何更改 Silk Central 服务器的内存设置。

Silk Central 前端服务器和应用程序服务器的 Java 堆大小默认设置为 512 MB（64 位前端服务器为 2048 MB）。如果您遇到内存不足的错误，例如在 Silk Central 中复制项目，请尝试增加前端服务器或应用程序服务器上的堆大小。

下列错误表明 Java 堆大小太小：java.lang.RuntimeException: java.lang.OutOfMemoryError: com.segue.scc.webgui.module.console.ProjectsUnit$CopyProjectThread.run(ProjectsUnit.java:1473) 处的 Java 堆空间。原因： java.lang.OutOfMemoryError: Java 堆空间。此错误在前端服务器或应用程序服务器的日志文件中报告。另一个指示是错误消息系统即将接近其容量。由于安全原因，不允许更多用户登录，它在您尝试登录 Silk Central 时显示。

  • 增加 Silk Central 服务器上的 Java 堆大小
    增加 Silk Central 服务器上的 Java 堆大小以避免内存不足错误。
父主题： 配置高级设置


增加 Silk Central 服务器上的 Java 堆大小

接收到内存不足错误时，请增加 Silk Central 服务器上的 Java 堆大小。

要增加前端或应用程序服务器上的 Java 堆大小：

  1. 在实例管理页面上，停止要修改的实例。
  2. 用文本编辑器打开要更改内存设置的服务器的 sc_<服务器>.processconfig 文件。这些文件的默认路径为 C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<实例编号>_<实例名称>\Conf。
  3. 对于 32 位 JVM，在 <JvmOptions32bit> 下的 <JvmOption32bit name="-Xmx" 标记中设置值。对于 64 位 JVM，在 <JvmOptions> 下的 <JvmOption name="-Xmx" 标记中设置值。
  4. 保存并关闭 XML 文件。
  5. 再次启动实例。
父主题： Silk Central 服务器的内存设置


设置步骤结果文件的最大大小

您可以在手动测试窗口中限制手动测试执行期间，测试人员附加到测试步骤的结果文件的大小。有关更多信息，请参阅附加结果文件。

设置步骤结果文件的最大大小：

  1. 在实例管理页面上，停止要修改的实例的前端服务器。
  2. 使用文本编辑器打开 SccFrontendBootConf.xml 文件。 此文件在前端服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\FontendServer。
  3. 找到 <MaximumResultFileSizeInBytes> XML 标记。此标记的默认值为 104857600；即 100 MB。
  4. 将此值设为您允许的最大文件大小。输入以字节为单位的文件大小。
  5. 保存并关闭 XML 文件。
  6. 重新启动前端服务器。
父主题： 配置高级设置
相关概念
手动测试窗口
相关任务
附加结果文件


为 Silk Performer 结果存储百分点标记数据

Silk Performer 结果包含大量百分点标记数据，将耗用大量数据库空间（表TM_PerfReportPercentileMarker）。因此，默认情况下，禁用此信息存储功能。要在无论是否存储 Silk Performer 结果的情况下均启用百分点标记数据存储，请按下列步骤操作：
  1. 在实例管理页面上，停止要修改的实例的应用程序服务器。
  2. 使用文本编辑器打开 TmAppServerHomeConf.xml 文件。
    此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\AppServer。
  3. 找到 Config/SilkPerformerResultStorage/StorePercentileMarkerData XML 标记。默认情况下，此标记设为 false。
  4. 将该值设置为 true。
  5. 保存并关闭 XML 文件。
  6. 重新启动应用程序服务器。
父主题： 配置高级设置


Silk Central 帮助

Silk Central 是一款功能强大且全面的软件测试管理工具。Silk Central 将质量和效率因素融入了测试过程，加快了成功软件项目的交付，同时最大限度地降低了应用程序失败的风险。它在单个可扩展且基于 Web 的测试系统中合并了所有关键软件测试阶段，可使您的本地和分布式软件开发团队分享经验、资源和关键信息。

  • Silk Central 18.5 的新增功能
    Silk Central 18.5 介绍重要的增强功能和更改。
  • 开始
    本部分介绍有关 Silk Central 的概述。
  • 需求
    说明如何管理 Silk Central 中的需求。
  • 测试
    说明如何管理 Silk Central 中的测试。
  • 执行计划
    介绍如何在 Silk Central 中执行测试。
  • 问题跟踪和结果分析
    分析测试结果，创建和跟踪已发生的问题以及使用报告记录结果。
  • 管理
    完成 Silk Central 的初始配置（实例配置）后，本节将引导您完成设置用户帐户、项目、位置和执行服务器等所需的步骤。这些任务必须由管理员执行。


Silk Central 18.5 的新增功能

Silk Central 18.5 介绍重要的增强功能和更改。

  • 管理
    列出 Silk Central 管理区域所作的增强
  • 执行计划和测试执行
    列出 Silk Central 执行计划和测试执行区域所作的增强
  • 测试
    列出 Silk Central 测试用例区域所作的增强
  • Issue Manager 增强功能
    Issue Manager、Silk Central 的内置问题跟踪解决方案，已在 Silk Central 18.5 中得到显著增强。
  • 集成
    列出对 Silk Central 中的集成所做的增强功能。
父主题： Silk Central 帮助


管理

  • 本地系统诊断访问
    如果 Silk Central 因过载而拒绝登录或不再响应，您现在仍可在前端服务器计算机上本地访问系统诊断页面（通过 http://localhost:19120/systemdiagnostics），以收集重要信息进行根本原因分析。
父主题： Silk Central 18.5 的新增功能


本地系统诊断访问

如果 Silk Central 因过载而拒绝登录或不再响应，您现在仍可在前端服务器计算机上本地访问系统诊断页面（通过 http://localhost:19120/systemdiagnostics），以收集重要信息进行根本原因分析。
父主题： 管理
相关任务
系统诊断


执行计划和测试执行

  • 分布执行
    现在，Silk Central 通过在所有匹配执行服务器上并行运行测试，支持分布执行单个执行计划的已分配测试。
  • 执行计划属性
    Silk Central 的 SOAP API 中现已考虑执行计划属性。有关详细信息，请参阅 Silk Central 的 Javadoc。
父主题： Silk Central 18.5 的新增功能


分布执行

现在，Silk Central 通过在所有匹配执行服务器上并行运行测试，支持分布执行单个执行计划的已分配测试。

为防止您的执行服务器过载，您现在还可以配置每个执行服务器最大并行执行数的数量。此数量是允许在一个特定执行服务器上并行运行的最大执行计划数量（独占执行设置禁用）。

分布执行还有一个主要优点，即可在自动测试执行的活动和当前运行网格中立即显示执行进度。而在以前，在整个执行计划运行完成后才能查看进度。

父主题： 执行计划和测试执行
相关概念
分布执行
相关任务
配置物理执行服务器


执行计划属性

Silk Central 的 SOAP API 中现已考虑执行计划属性。有关详细信息，请参阅 Silk Central 的 Javadoc。
注： Silk Central 的批量导出/更新接口中尚未考虑执行计划属性。
父主题： 执行计划和测试执行
相关参考
可用 Web 服务


测试

  • 共享测试资产
    现在，项目可共享测试以在其他项目中使用，从而能够高效地集中管理重复性测试。在其他项目中重复使用的测试将维护对其原始测试的引用，以接收任何更新（测试版本）信息，可以接受更新，也可跳过更新。此外，重用测试还将分配至所在项目中的现有需求，与其原始测试的需求分配完全相同。
  • 在测试文档视图中显示自定义属性
    现可在测试 > 文档视图中显示自定义属性。您可将属性用于筛选和报告用途。
  • 使用只读权限复制测试资产
    现在，拥有项目只读权限的用户可以复制测试资产。之后可将这些资产粘贴到用户拥有写入权限的项目中。
父主题： Silk Central 18.5 的新增功能


共享测试资产

现在，项目可共享测试以在其他项目中使用，从而能够高效地集中管理重复性测试。在其他项目中重复使用的测试将维护对其原始测试的引用，以接收任何更新（测试版本）信息，可以接受更新，也可跳过更新。此外，重用测试还将分配至所在项目中的现有需求，与其原始测试的需求分配完全相同。

扩展测试版本

测试版本在测试资产共享过程中发挥着至关重要的作用。因此，测试版本现加入了参数、属性、特性、成功条件和继承信息。

父主题： 测试
相关概念
共享测试资产
版本
相关任务
重复使用存储库项目的测试资产
添加项目
相关参考
项目设置页面


在测试文档视图中显示自定义属性

现可在测试 > 文档视图中显示自定义属性。您可将属性用于筛选和报告用途。
父主题： 测试
相关参考
测试文档视图


使用只读权限复制测试资产

现在，拥有项目只读权限的用户可以复制测试资产。之后可将这些资产粘贴到用户拥有写入权限的项目中。
父主题： 测试


Issue Manager 增强功能

Issue Manager、Silk Central 的内置问题跟踪解决方案，已在 Silk Central 18.5 中得到显著增强。

无缝集成

通过选择性地重复使用已存在的用户上下文登录本地 Issue Manager 实例，Issue Manager 朝着无缝集成的目标又迈进了一步。

用户界面更新

问题详细信息页面经过重新设计，可让用户一眼查看问题的相关信息，更高效地处理问题。

父主题： Silk Central 18.5 的新增功能
相关任务
添加 Issue Manager 问题跟踪配置文件
相关参考
“问题详细信息”页面
问题跟踪页面


集成

  • 集成的 Mobile Center 支持
    Silk Central18.5 现与 Mobile Center 集成，适用于在移动设备上执行自动功能测试，并向用于创建和执行自动功能测试的 Silk Test 额外提供这些移动设备。
  • 在 Git 源代码管理配置文件中指定分支
    现在，您可在 Git 源代码管理配置文件中定义特定分支，并于之后为使用此配置文件的所有执行计划签出此分支。通过在相应执行计划的源代码管理标签字段中指定分支名称，您仍可对特定执行计划使用其他分支。
父主题： Silk Central 18.5 的新增功能


集成的 Mobile Center 支持

Silk Central18.5 现与 Mobile Center 集成，适用于在移动设备上执行自动功能测试，并向用于创建和执行自动功能测试的 Silk Test 额外提供这些移动设备。
父主题： 集成
相关任务
配置设备提供程序


在 Git 源代码管理配置文件中指定分支

现在，您可在 Git 源代码管理配置文件中定义特定分支，并于之后为使用此配置文件的所有执行计划签出此分支。通过在相应执行计划的源代码管理标签字段中指定分支名称，您仍可对特定执行计划使用其他分支。
父主题： 集成
相关任务
添加 Git 源代码管理配置文件


开始

Silk Central 可提高开发周期过程中的产品质量。

如今，电子商务系统日益复杂，其可靠性也日益重要。 因此，确保开发周期过程中的产品质量是取得成功的一个关键因素。 随着时间的推移，检查产品质量的最佳方法是每天对关键指标进行测试。就这一点而言， Silk Central 有助于在产品开发和部署后过程中自动按照可自由配置的计划自动测试执行。 提供不同详细信息级别的报告以及检查开发中的产品状态就如在 Web 浏览器中检查 HTML 报告一样简单。

如果是复杂的软件项目，则彻底测试新的内部版本尤为重要。 Silk Central 可自动完成此流程，从而节省了时间和工时。

  • 安装和许可 Silk Central
    介绍如何安装和许可 Silk Central。
  • Silk Central 的概念
    本部分将介绍 Silk Central 的基本概念，其中包括基本工作流、可用资产及其使用对象。
  • 用户界面
    提供 Silk Central 用户界面的概述。
  • 快速启动任务
    快速启动任务是对您可能需要使用 Silk Central 执行的主要任务的高级概述。
父主题： Silk Central 帮助


安装和许可 Silk Central

有关安装和许可 Silk Central 的信息，请参阅 Silk Central 安装帮助，也可以从 Silk Central 安装 DVD 和 Silk Central 下载网站获取相关信息。

父主题： 开始
相关概念
安装和系统配置帮助


Silk Central 的概念

本部分将介绍 Silk Central 的基本概念，其中包括基本工作流、可用资产及其使用对象。
  • 工作流
    Silk Central 的测试管理工作流包含以下四种主要活动：定义需求、设计测试、执行计划和执行测试、跟踪和分析测试结果。
  • 需求
    需求是用户完成特定任务所需的条件或能力，必须由受测试应用程序 (AUT) 来满足。
  • 测试
    测试或测试用例是一组输入值、执行前提条件、预计结果和执行前提条件，是专为特定目标或测试条件而开发的，例如执行特定的程序路径或验证与特定需求的兼容性 [IEEE 610 之后]。
  • 执行计划
    执行计划区域使您可在开发和测试过程中维持对测试执行的控制。此区域包含如下一些活动：配置执行计划、安排执行计划、分配测试至执行计划、设置执行计划的依赖关系、配置执行服务器部署以及使用关键字配置动态硬件配置。
父主题： 开始


工作流

Silk Central 的测试管理工作流包含以下四种主要活动：定义需求、设计测试、执行计划和执行测试、跟踪和分析测试结果。

定义需求

设计测试

执行计划和执行测试

跟踪和分析测试结果

父主题： Silk Central 的概念


需求

需求是用户完成特定任务所需的条件或能力，必须由受测试应用程序 (AUT) 来满足。将需求与测试关联，确保测量软件涵盖指定需求的程度。多个测试可以包含同一个需求，而一个测试也可以包含多个需求。

父主题： Silk Central 的概念


测试

测试 |  | 测试或测试用例是一组输入值、执行前提条件、预计结果和执行前提条件，是专为特定目标或测试条件而开发的，例如执行特定的程序路径或验证与特定需求的兼容性 [IEEE 610 之后]。Silk Central 支持各种测试类型，可以通过多种方式构建测试。
 | 测试类型
 | 手动测试 | 手动测试是指为测试人员提供的分步说明。Silk Central 提供了一个 UI，可以有效执行手动测试，其中包含在测试执行期间录制视频和捕获屏幕图像的选项。如果需要，稍后可以将手动测试转换为自动测试。
 | 关键字驱动的测试 | 关键字驱动的测试就是一个关键字序列。关键字驱动的测试可像其他任何测试一样回放。 Silk Central 和 Silk Test 支持关键字驱动的测试方法，让自动化工程师能开发出由共享资产（采用 Silk Test 中的关键字形式）组成、易于维护的自动化框架，从而支持业务分析师与工程师之间开展密切协作。随后，业务分析师 Silk Test 中使用这些关键字新建关键字驱动的测试，或者在 Silk Central 中利用这些关键字将其现有手动测试资产转换为自动化测试，或是新建关键字驱动的测试。
 | UFT 测试 | Unified Functional Testing (UFT) 软件，以前称为 HP QuickTest Professional (QTP)，为软件应用程序和环境提供功能和回归测试自动化。
 | JUnit 测试 | Nunit 是用于 Java 编程语言的单位测试框架。将此测试类型用于JUnit、Silk4J 和 Selenium 测试。
 | NUnit 测试 | Nunit 是用于 Microsoft .NET 编程语言的单位测试框架。
 | MSTest 测试 | MSTest 是 中的命令行实用工具，用于执行在 Microsoft 中创建的单位测试。将此测试类型用于 MSTest 和 Silk4NET 测试。
 | ProcessExecutor 测试 | ProcessExecutor 测试类型可用于执行任何命令行。
 | .NET Explorer 测试 | 测试类型用于执行 Silk Performer .NET Explorer 脚本或脚本的特定测试用例。
 | Silk Performer 测试 | Silk Performer 项目可以集成到 Silk Central 测试并通过 Silk Central 直接执行。这可实现强大的测试结果分析和报告。它还可启用无人值守的测试，这意味着测试由 Silk Central 根据预配置计划自动运行。
 | Silk Test Workbench 测试 | Silk Test Workbench 是一种自动化测试工具，可加快复杂应用程序的功能测试。Silk Test Workbench 可为使用各种开发工具开发的测试应用程序提供支持，这些工具包括 Java、.NET、基于浏览器的 Web 应用程序，以及包括 ActiveX 控件和自动化对象的 COM 组件。
 | Silk Test Classic 测试 | Silk Central 的 Silk Test Classic 界面提供自动化 Silk Test Classic 用户的可靠方法。Silk Test Classic 脚本的每个测试用例在自己的测试执行内执行，并产生自身的结果。
 | Silk Test Classic 计划测试 | Silk Test Classic 计划测试类型用于 Silk Test Classic 测试计划。测试计划通常是分层结构的文档，描述测试需求并且包含实施测试需求的语句、4Test 脚本和测试用例。
 | Silk TestPartner 测试 | TestPartner 是一款 Micro Focus 产品，用于测试使用 Microsoft 技术的 Web 和 Microsoft Windows 应用程序。
 | 测试结构
 |  | 测试容器用于构建顶层的测试资产。Silk Central 按容器关联已定义的源代码管理配置文件和产品，这会影响您可以在特定容器内对测试执行的操作。
 |  | 使用文件夹在容器中构建测试。
 |  | 测试包为 Silk Central 中第三方测试类型的结构提供支持，由包根和套件节点与测试节点的任意层次结构组成。
父主题： Silk Central 的概念


执行计划

执行计划区域使您可在开发和测试过程中维持对测试执行的控制。此区域包含如下一些活动：配置执行计划、安排执行计划、分配测试至执行计划、设置执行计划的依赖关系、配置执行服务器部署以及使用关键字配置动态硬件配置。

执行计划是指单个测试容器中存储的已分配测试的集合。 执行计划可以按照可配置的计划运行，并且部署在指定的执行服务器上。

配置测试是指使用每个受支持的软件和硬件配置对系统进行测试的过程。 您可创建具有一组已分配测试的配置套件，并且这组测试也将分配到您添加到配置套件的所有执行计划。

测试周期是定义的时间段，包含开始日期、结束日期和手动测试人员列表。创建测试周期来计划和执行特定的手动计划集。

使用文件夹构建执行计划、配置套件和测试周期。 您可以在文件夹内嵌套文件夹。

父主题： Silk Central 的概念


用户界面

本节提供 Silk Central 用户界面的概述。

  • UI 教程
    提供 Silk Central 用户界面的概述。
  • 仪表板
    介绍 Silk Central 用户的个性化开始区域。
  • 浏览器设置
    介绍如何调整浏览器设置，以优化 Silk Central 的功能和性能。
  • 登录和注销
    介绍如何登录 Silk Central 和从中注销。
父主题： 开始


UI 教程

本主题提供 Silk Central用户界面的概述。

基本 UI 结构

Silk Central 的 UI 包括：

  • 菜单：置于用户界面的顶部。它可让您快速访问 Silk Central 的功能单元。
  • 工作区：在本示例中，工作区是显示当前选定 Silk Central单元功能工作区域的选项卡式区域。此视图根据您工作的单元而改变。

Silk Central 的单元

菜单可让您快速访问 Silk Central 的功能单元。它包括以下主要部分：

主页

显示仪表板，这是您的个人起始区域。您可以添加和安排不同的面板来自定义仪表板，以便为您提供日常工作所需的信息。

需求

显示并使您在开发期间保持对项目需求的控制。您可以执行以下任务：

  • 创建、修改和删除需求。
  • 将测试与需求关联。
  • 跟踪需求的更改历史记录。
  • 从需求列表中生成测试计划。
您还可以访问和管理以下内容：
  • 需求的属性。
  • 集成外部需求管理工具。
  • 需求筛选器。
  • 通知您需求更改的通知。

测试

可使您创建并管理自动和手动测试。您还可以访问和管理以下内容：

  • 库，其中的常用手动测试、测试步骤和关键字可以重用。
  • 手动测试的单个测试步骤属性。
  • 关键字驱动测试的关键字属性。
  • 测试属性。
  • 可用于测试的数据源。
  • 源代码管理配置文件，其中存储了这些测试。
  • 测试筛选器。
  • 通知您测试更改的通知。
  • 通过特定测试所测试的产品版本和内部版本。

执行计划

显示并允许您管理执行测试的执行。您可以执行以下任务：

  • 配置执行计划。
  • 将测试分配给执行计划。
  • 设置执行计划依赖关系。
  • 配置执行服务器部署，包括测试在此执行的执行服务器。
  • 计划和管理测试的手动执行。
您还可以访问和管理以下内容：
  • 执行筛选器。
  • 执行计划。
  • 通过测试的特定执行所测试的产品版本和内部版本。
  • 通知您执行进程更改的通知。

跟踪

显示活动页面、跨项目活动页面、项目概述报告和质量目标。

活动页面根据每个项目显示最近执行计划、当前执行计划和即将执行计划的活动。

问题

显示并使您可以管理与活动项目有关的问题。

您还可以访问和管理以下内容：
  • Issue Manager 中的项目，当问题驻留在 Issue Manager 中时。
  • 外部问题跟踪配置文件，问题可能驻留在其中。

报告

显示并使您可以管理提供需求、测试和执行计划相关信息的报告。您可以执行以下任务：
  • 生成报告。
  • 下载报告模板。
  • 编辑报告参数。
  • 根据预安装模板创建新报告。

还提供对代码分析功能信息的访问，您可以借此评估测试用例覆盖被测应用程序 (AUT) 中的代码的程度。然后您可以对与特定代码更改有关的工作、成本和风险做出可靠估计。

全局搜索

在 Silk Central 中，搜索字段允许您跨多种资产执行搜索。提交全局搜索时，应考虑以下资产：
  • 需求及其属性
  • 测试、文件夹、测试容器及其属性值、属性和参数
  • 测试步骤及其属性
  • 执行计划、配置套件、测试周期、文件夹及其参数
  • 库文件夹、步骤和共享步骤
  • 问题（按摘要和说明搜索）
注： 搜索索引定期在后台更新。搜索结果可能偶尔略有过期。
搜索规则：
  • 搜索不区分大小写。
  • 单独搜索所有输入的词语。如果找到至少一个词语，则项目与搜索匹配，与查询匹配的词语越多，匹配项的排位越高。
  • 将 + 置于必须与查询匹配的词语之前。例如，“+test +type”将仅返回同时匹配“test”和“type”的结果。
  • 将 - 置于不可与查询匹配的词语之前。例如，“test -copy”将返回与“test”匹配，而不是与“copy of test”匹配的结果。
  • 要搜索精确匹配项，请将搜索词放入引号内，例如，"customer account management"。
  • 要将搜索限定为项目名称或说明，请分别将 name: 或 description: 置于搜索词之前。例如，name:test 将仅返回项目 name 中包含 test 一词的结果。
  • 常用英文字 'a'、'the'、'and' 会忽略。
示例：
name:"test item" -description:closed
此搜索将返回名称中包含 "test item" 一词，且说明中不含 "closed" 一词的项目。

项目

显示并使您可以从高级测试经理的视图中管理 Silk Central 安装中的所有项目。还使您可在项目之间切换以及管理项目设置。

用户

显示并使您可以管理用户设置。还可实现以下操作：
  • 注销 Silk Central。
  • 打印当前 Silk Central 页面。
  • 制作当前 Silk Central 页面书签。这对将报告添加为书签尤其有用，当前参数会保存在添加为书签的 URL 中。

管理

显示并使您可以管理管理设置。有关其他信息，请参阅本帮助中的管理主题。

帮助

单击以查看当前页面的上下文相关帮助。还提供对以下内容的访问：
  • Silk Central 文档。
  • Silk Central 随附的工具。
  • 关于。显示版本和许可证信息。

上下文菜单命令

Silk Central 在许多测试管理元素中支持 Windows 样式的上下文菜单，例如测试、需求、执行文件、文件夹、容器和报告等。通过右键单击鼠标使用，上下文菜单命令通常包括每个单元的工具栏中提供的命令。对于树视图中列出的元素，上下文菜单提供展开和折叠树视图元素的命令。不可用于选定元素的命令被禁用。

父主题： 用户界面


仪表板

Silk Central 中的仪表板是您的个人开始区域。您可添加和排列为您提供日常工作所需信息的各种面板，以自定义仪表板。

首次登录 Silk Central 时，仪表板仅显示简介面板。顶部显示您上次登录的日期和时间。通过单击此链接，您可快速从离开的位置继续。

单击顶部的按钮以执行以下操作：
  • 单击添加面板以将更多面板添加到仪表板。
  • 单击更改布局以更改仪表板的布局。
  • 单击重置仪表板以将仪表板设置为默认视图。您添加的所有面板和您的自定义设置都将删除。

要排列您的仪表板，请单击仪表板标题并将其拖至所需位置。您可通过拖动面板页脚调整面板大小（只有包含列表的面板可调整大小）。

单击面板标题中的按钮以执行以下操作：
  • 单击 [image] 以从仪表板中删除面板。
  • 单击 [image] 以配置面板的设置。
  • 单击 [image] 以将面板的内容另存为 PDF。
  • 单击 [image] 以打印面板的内容。

您需要一定权限才能查看或编辑不同面板的内容。

  • 将面板添加到仪表板
    介绍如何将面板添加到仪表板。
  • 仪表板面板
    介绍可添加到仪表板的面板。
  • Silk Central Connect
    描述 Silk Central Connect 的定义及其使用方式。
  • 仪表板面板权限
    介绍查看或编辑某个面板的内容所需的权限。
  • 向仪表板面板添加报告
    介绍如何创建报告并将其添加到仪表板面板。
父主题： 用户界面


将面板添加到仪表板

将面板添加到仪表板：

  1. 在菜单中，单击主页 > 我的仪表板。
  2. 单击左上方的添加面板。 将显示添加面板对话框，列出可用面板以及每个面板的简短说明。
  3. 选择面板。
  4. 单击确定。
  5. 如果需要，请从面板中选择项目和时间范围。从面板中选择 <使用当前项目>，始终显示当前活动项目的数据。
  6. 单击确定。

对于大多数面板，您需要配置项目，因为面板只会显示某个项目的数据。您可以添加多个面板以为其他项目并行显示适当的数据，或者为面板配置 <使用当前项目> 以始终显示当前活动项目的数据。单击面板标题中的 [image] （配置），以配置不同的项目。您需要一定权限才能查看或编辑不同面板的内容。

父主题： 仪表板


仪表板面板

对于大多数面板，您需要配置项目，因为面板只会显示某个项目的数据。您可以添加多个面板以为其他项目并行显示适当的数据，或者为面板配置 <使用当前项目> 以始终显示当前活动项目的数据。单击面板标题中的 [image] （配置），以配置不同的项目。您需要一定权限才能查看或编辑不同面板的内容。

您可将以下面板添加到仪表板：

面板 | 说明
已分配的问题 | 此面板显示所选项目的所有问题（已分配到测试）。如果单击外部 ID，则将在外部问题跟踪系统中打开问题。
自定义信息 | 此面板显示某个项目的可定制信息。具有管理项目权限的用户可将文本、图像或超链接等内容添加到面板。单击编辑内容以打开 HTML 编辑器。没有管理项目权限的用户将只能看到内容。面板可用于显示与项目相关的新闻、说明或任何其他类型的信息。
简介 | 此面板向您快速介绍 Silk Central。单击新增功能下方的链接，获得有关 Silk Central 最新功能的更多信息。您也可加入 Micro Focus 社区或联系 Micro Focus SupportLine。
问题生命周期 | 此面板显示已定义问题跟踪配置文件的未解决、已修复、已验证、已关闭和已推迟问题的数量。从列表中选择产品。要定义问题跟踪配置文件，请在菜单中依次单击问题、问题跟踪集成和新建配置文件。如果存在已定义的配置文件，则面板将只显示数据。
每个测试工程师创建的问题 | 此面板以条形图显示测试工程师创建的问题的数量。当打印或下载为 PDF 时，这些数字还将显示在表格中。
分配给我的手动测试

此面板显示所选项目中已分配给您的所有测试。

如果借助测试周期组织手动测试执行，该列表还包括手动执行计划页面上已分配到无特定测试工程师的所有测试。然而，这仅适用于您被分配为测试工程师的测试周期。这是典型的团队合作情况，测试工程师自己决定要执行的测试。

如果借助执行计划组织手动测试执行，该列表还包括所有执行计划中未分配测试工程师的测试。

单击 [image] （继续手动测试）以打开手动测试窗口。

单击 [image] （查看手动测试结果）打开视图，查看有关测试的所有数据和附件。

单击 [image] 以获取关于测试、执行计划或父级执行计划的详细信息。

右键单击测试，再单击 [image] 下载手动测试（Excel 格式）以脱机执行（可使用 Ctrl+单击或 Shift+单击选择多个测试）。执行测试后，单击上载脱机手动测试结果按钮以上载结果。

如果在开始日期之前开始测试周期（在手动执行计划页面上），则此测试周期的测试已显示在面板中。您可让这些测试在到达开始日期之前在面板中不可见：单击面板标题中的 [image] ，然后选中隐藏将来的测试周期。
脱机手动测试概述 | 此面板显示测试工程师下载的测试，允许测试经理取消脱机执行以释放许可证。
计划与 实际执行时间 | 此面板显示测试周期的测试工程师是否遵循测试执行计划。如果实际所用时间与剩余计划时间的总和大于容量，则测试周期存在不能按时完成的风险。
质量目标进度 | 此面板为所选质量目标的每个值显示包括两个条形的图。上方的条形显示必须执行以满足质量目标的测试数量。下方的条形显示具有该目标值的通过、失败、未执行和不适用（不可用）测试的数量。如果下方的条形比上方的条形短，则分配到执行计划的测试太少。这意味着不能达到质量目标。从列表中选择质量目标。
报告订阅 | 此面板显示报告订阅的结果。报告订阅必须已经定义，您需要选择编辑订阅对话框中的提供仪表板和外部访问，以保证其可用。
需求覆盖率状态 | 此面板显示所选项目的需求覆盖率，分为通过、失败、未执行和未覆盖需求。单击 [image] 以转到需求文档视图。
Silk Central Connect
Silk Central Connect 将测试执行管理和配置测试的各个方面组合到一个易用界面，这将带来以下几点益处：
  • 简化执行对各种配置的所有自动单元测试，组合操作系统与 Web 浏览器。
  • 充分利用 Amazon Web 服务的优势，让您轻松访问各种配置，免去前期投资。
  • 紧密集成 Silk Central Connect 和 Silk4J，轻松创建、维护和执行测试。
  • 并行结果分析让您能够对比不同配置的所有测试结果。

有关详细信息，请参阅 Silk Central Connect。
Silk Performer 性能趋势 | Silk Performer 性能趋势面板显示所选 Silk Performer 负载测试及其可用结果的当前状态，包括过去几次运行的趋势信息。
当前正在运行的手动测试的状态 | 此面板显示指定项目中所有当前运行的手动测试的状态。测试经理可以查看当前阻止了哪些测试，还可以监视正在运行的执行中已执行测试的状态。
Testbook | 此面板为您显示关于手动测试期间发生的所有活动的实时更新。Testbook 中记录的活动有开始和结束测试，以及编辑正在运行的测试周期。有关更多信息，请参阅 Testbook。
测试周期进度 | 此面板显示已定义测试周期内的通过、失败、进行中和未执行测试的燃尽图。它还会使用方块显示里程碑（如果您已指定）。从列表中选择测试周期。
测试周期结果摘要 | 此面板显示所选测试周期的状态以及分配到测试周期的单个测试工程师的进度状态。条形显示顺序如下：已失败测试、剩余测试和已通过测试的数量。拥有最多已失败测试的测试工程师显示在列表顶部。条形右侧的数字显示已完成的测试（左侧数字）和已分配的测试（右侧数字）。无特定测试工程师与所有其他测试工程师的处理和排序方式相同。单击 [image] 以转到手动执行计划页面的测试分配视图。
测试周期时间线 | 此面板将所选项目的所有测试周期显示为时间线上的条形。单击条形时，您将转到手动执行计划页面。这些条形具有不同颜色，具体取决于测试周期的当前状态：蓝色（进行中）、橙色（尚未开始）、灰色（已完成）。将鼠标移至条形上方，以获取关于测试周期的详细信息。
跨测试周期的测试进度 | 此面板显示已计划测试（用线条显示）以及进行中和已完成测试（用叠加区域显示）的时间（以小时为单位）。该面板可帮助测试管理人员预测该测试团队能否及时完成测试。图表的开始日期是第一个测试周期的开始日期。图表的结束日期是最后一个测试周期的结束日期。该面板不会显示测试团队执行测试所用的实际时间长度。
易变测试 | 此面板显示测试在执行计划中更改其状态的频率。没有状态更改的测试以及测试包不会显示在面板中。测试根据所选项目和时间范围进行显示。测试管理人员可通过此面板了解此类易变测试，这表明测试不稳定或测试区域中经常发生错误。
父主题： 仪表板


Silk Central Connect

Silk Central Connect 将测试执行管理和配置测试的各个方面组合到一个易用界面，这将带来以下几点益处：
  • 简化执行对各种配置的所有自动单元测试，组合操作系统与 Web 浏览器。
  • 充分利用 Amazon Web 服务的优势，让您轻松访问各种配置，免去前期投资。
  • 紧密集成 Silk Central Connect 和 Silk4J，轻松创建、维护和执行测试。
  • 并行结果分析让您能够对比不同配置的所有测试结果。
  • 概述
    描述 Silk Central Connect 的定义及其使用方式。
  • Silk Central Connect 体系结构
    本节提供 Silk Central Connect 的体系结构概述。
  • 先决条件
    列出使用 Silk Central Connect 所需的先决条件。
  • 配置源代码管理
    将 Silk Central Connect 与 Subversion 源代码管理系统集成以支持 Silk Central Connect 存储项目数据。
  • 创建 Web 应用程序测试
    创建测试，然后验证 Web 应用程序在您的默认位置可以使用的浏览器上的表现。
  • 自定义 Web 应用程序测试
    创建测试集以测试 Web 应用程序的功能。
  • 在多个浏览器上并行运行 Web 应用程序测试
    增强测试环境，以为多个浏览器上的 Web 应用程序并行执行测试。
  • 分析测试结果
    运行测试后分析测试结果。
  • 计划测试连续执行
    计划项目在每天的指定时间执行。
  • 常见问题
    为有关 Silk Central Connect 的常见问题提供答案。
父主题： 仪表板


概述

Silk Central Connect 为利用云功能测试桌面和移动 Web 浏览器中的 Web 应用程序提供了一个新方式，利用此方式可避免设置或配置烦恼。Silk Central Connect：
  • 跨浏览器测试所需的时间和工作减少达到 80%
  • 因无需为不同浏览器设置硬件，从而降低了总拥有成本
  • 通过可见性识别应用程序在不同浏览器出现故障的位置，解决问题的速度更快

有关 Silk4J 的信息，请参阅 Silk4J 用户手册。

有关配置测试环境的信息，请参阅设置执行服务器。

父主题： Silk Central Connect


Silk Central Connect 体系结构

Silk Central Connect 基于 Silk Central 的体系结构。而且，它允许使用基于云的执行服务器。如果您在使用基于云的执行服务器的内部网上测试内部 Web 应用程序，则可以为本地内部网网站测试配置隧道设置。使用此设置，Silk Central 应用程序服务器将打开一个通往基于云的执行服务器的隧道，并作为代理允许在您的本地内部网中测试网站。请注意，此选项比直接连接速度慢，所以仅在需要时选择。

父主题： Silk Central Connect


先决条件

要使用 Silk Central Connect，必须满足下列先决条件：
  • Silk Central 需要安装在您的环境中。
  • Silk4J 是 Eclipse 的 Silk Test 插件，需要安装在您的环境中。
父主题： Silk Central Connect


配置源代码管理

要使 Silk Central Connect 能够存储终端执行测试，您必须将Silk Central Connect 与 Subversion (SVN) 源代码管理系统集成。

  1. 在 Silk Central Connect 面板上，单击配置 Subversion 源代码管理。
  2. 将 Subversion 存储库的 URL 键入 URL 字段中。如果未配置 SVN 存储库，Silk Central Connect 将自动配置基于文件的存储库。
    重要： 基于文件的存储库仅限评估目的，不应用于生产。此外，只能在本地计算机上访问此存储库，并且 Silk4J 必须安装在此计算机上。

    例如，如果 Subversion 服务器的位置是 http://svn.mycompany.com，并且存储库位于 TestAutomation/trunk 下，请将 http://svn.mycompany.com/TestAutomation/trunk 键入 URL 字段中。

  3. 键入有效的用户名和密码。这些凭据将用于访问您所有项目的存储库。如果您正在使用基于文件的存储库，则不需要用户名和密码。
  4. 单击保存。
父主题： Silk Central Connect


创建 Web 应用程序测试

安装 Silk Central Connect 并配置 Subversion 后，便可以为 Web 应用程序新建项目。然后，可以使用内置验证运行在您的本地计算机上可以使用的每一个浏览器中截取 Web 应用程序的第一个屏幕快照。

  1. 在 Silk Central Connect 面板上，单击新建项目。 此时将显示新建项目对话框。
  2. 如果您正在完整的 Silk Central 环境中使用 Silk Central Connect，可以选择将您的新 Silk4J 项目添加到现有 Silk Central 项目或新建 Silk Central 项目。
  3. 如果您正在新建项目，请将新项目名称键入项目名称字段。
  4. 将测试应用程序的 URL 键入 URL 字段中。
  5. 单击确定。
  6. 可选：如果您正在使用基于云的执行服务器的内部网上测试内部 Web 应用程序，请单击隧道设置，然后选择本地内部网网站。 使用此设置，Silk Central 应用程序服务器将打开一个通往基于云的执行服务器的隧道，并作为代理允许在您的本地内部网中测试网站。请注意，此选项比直接连接速度慢，所以仅在需要时选择。
  7. 单击运行测试。
  8. 选择所有可用配置。
  9. 单击运行测试。
  10. 单击刷新以查看是否完成执行。
  11. 完成执行时，请单击开始时间链接。 您可以查看每个配置的测试结果。默认测试用例称为 validateAppearance。
  12. 单击第一个配置的测试结果。 您可以查看测试结果的详细信息，包括测试应用程序的屏幕快照。您可以单击屏幕快照予以放大。
  13. 单击浏览结果以查看应用程序在所有配置上的表现。

    提示： 您可以使用向左和向右键盘键切换各项结果。
父主题： Silk Central Connect


自定义 Web 应用程序测试

要执行本主题中介绍的操作，必须满足下列先决条件：
  • 为了能够使用 Silk4J 录制测试，需要在系统上安装当前版本的 Internet Explorer。有关受支持版本的列表，请参阅 发行说明。
  • 有关用于重新播放的受支持浏览器的列表，请参阅 Silk Test 发行说明。
  • 要测试移动浏览器，需要在您的系统上安装仿真器或将移动设备连接至您的系统。有关测试移动 Web 应用程序的更多信息，请参阅移动测试教程。
为 Web 应用程序创建项目后，可以添加其他测试或增强现有测试，以测试 Web 应用程序的其他功能。
  1. 要在 Eclipse 中打开项目，请执行下列操作之一：
    • 在 Silk Central Connect 面板上，单击与项目对应的操作列中的打开方式 Silk4J。
    • 在项目的概述页面上，单击打开方式Silk4J。
    创建 Silk Central Connect 项目时，将为指定源代码管理提交一个 Eclipse 项目模板，包含下列资产：
    • src 文件夹：存储新测试的位置
    • Lib 文件夹：要在 Silk4J 项目中使用其他 java 库，请将其添加到此文件夹。执行测试时，Silk Central Connect 将位于此文件夹中的所有 jar 文件添加到 classpath。
    • build.xml：执行前，Silk Central Connect 用于构建测试的预配置 ANT 构建文件。
    • 其他 Eclipse 相关文件
  2. 在 Silk4J 中录制其他测试。
    1. 在程序包管理器中，选择要向其添加新测试的项目。
    2. 在工具栏上，单击录制操作。
      • 如果在 Eclipse 中已打开 Silk4J 测试类，录制的操作将录制到此文件中。
      • 如果在 Eclipse 中未打开 Silk4J 测试类，录制的操作将录制到新 Silk4J 测试类文件中。

      随即将打开 Web 应用程序和录制窗口。Silk4J 创建基态并开始录制。

    3. 执行要通过 AUT 录制的步骤。
    4. 单击停止录制。此时，录制完成对话框将打开。

    5. 源文件夹字段将自动填充选定项目的源文件位置。要使用不同的源文件夹，请单击选择，然后导航至要使用的文件夹。
    6. 可选：在程序包文本框中，指定程序包名称。 要使用现有程序包，请单击选择，然后选择要使用的程序包。
    7. 在测试类文本框中，指定测试类的名称。
    8. 在测试方法文本框中，指定测试方法的名称。
    9. 单击确定。

    有关 Silk4J 的信息，请参阅 Silk4J 用户手册。

  3. 确保测试如 Silk4J 中的预期一样工作。
    1. 在 Silk4J 工具栏上，单击运行选定 Silk4J 测试。
    2. 在选择浏览器对话框上，选择重新播放测试所要使用的浏览器。

    3. 单击运行 (Run)。 如果测试通过，且测试结果达到预期，您可以在 Silk Central Connect 中将测试添加到测试集。
  4. 在 Silk4J 工具栏上，单击提交以将项目中的更改提交到存储库中。
  5. 要返回 Silk Central Connect 中项目的概述页面，请单击运行测试以在项目中执行所有测试。
  6. 选择配置。

  7. 单击运行测试。
  8. 完成执行时，请单击开始时间链接。 您可以查看每个测试和每个配置的测试结果。

如果在所有配置上的所有测试运行道道预期效果，您可以进一步增强测试集或安排项目重复执行测试。

父主题： Silk Central Connect


在多个浏览器上并行运行 Web 应用程序测试

当您已验证 Web 应用程序在本地计算机上的所有可用浏览器上如期表现时，便可向测试环境添加其他执行服务器，以为多个浏览器上的 Web 应用程序并行执行测试。

要在其他浏览器上测试 Web 应用程序，您有下列三个选项：

  1. 在现有执行服务器上安装其他浏览器。 该选项使您可以测试其他浏览器，但会增加在测应用程序运行测试集所需的时间，因为需要在执行服务器上按顺序测试浏览器。
  2. 将其他执行服务器添加到测试环境。 该选择使您可以测试其他浏览器，而不会显著增加测试集的执行时间。测试根据每个服务器上的可用浏览器在执行服务器之间分发。但是，该选项会增加硬件要求。有关将执行服务器添加到测试环境的其他信息，请参阅配置物理执行服务器。
  3. 连接到云。
    注： 要能够在云中执行测试，您需要一个云提供商帐户。

    该选项使您能够测试大量浏览器，而不增加测试集的执行时间，也不要求其他硬件。其他成本直接与您的测试工作有关，包括执行测试集的频率和测试集的大小。

有关配置测试环境的信息，请参阅设置执行服务器。

有关跨多个浏览器运行关键字驱动的测试的信息，请参阅使用关键字驱动的测试进行跨浏览器测试

父主题： Silk Central Connect


分析测试结果

运行测试后，可以审阅测试结果。

  1. 在 Silk Central Connect 面板上，可以查看所有项目最后一次测试运行的状态。

  2. 要查看所有测试的结果以及特定项目的所有测试运行，请单击项目名称。

    将打开项目概述页面。

  3. 在测试结果页面上，单击特定测试结果的状态以查看每个配置的测试运行结果。

  4. 在测试结果页面上，单击测试的状态以查看详细信息，包括错误日志和 TrueLog 文件。

父主题： Silk Central Connect


计划测试连续执行

您可以制定项目计划以在每天的相同时间执行项目中的所有测试。
注： 如果您在完整 Silk Central 环境中使用 Silk Central Connect，则可以在执行计划 > 详细信息视图 > 计划中使用更高级的计划功能
。
  1. 在 Silk Central Connect 面板上，单击您要为每天执行计划的项目名称。
  2. 在项目的概述页面上，单击计划测试。
  3. 在计划测试对话框中，指定每天应开始测试执行的时间。

  4. 从可用配置列表中，选择应执行测试的配置。 如果您已执行项目中的测试，将预先选择上次运行使用的配置。如果您尚未执行测试，则预先选择所有配置。
  5. 单击保存。
项目中的所有测试将在选定配置上以及每天的指定时间执行。计划的时间将显示在项目的概述页面中。通过单击计划旁边的删除按钮卡可以删除计划。
父主题： Silk Central Connect


常见问题

本节为有关 Silk Central Connect 的常见问题提供答案。

  • 我的 Silk4J 测试为什么失败？
    刷新 Silk Central Connect 并重新启动 Eclipse 以确保 Silk Central Connect 与 Silk4J 之间的连接正常。
父主题： Silk Central Connect


我的 Silk4J 测试为什么失败？

如果无法从 Silk Central Connect 执行 Silk4J，Silk Central Connect 与 Silk4J 之间的连接可能无法工作。您可以尝试下列步骤以建立连接：如果在 Silk Central Connect 之前已安装 Silk4J，请重新启动 Eclipse 或 Open Agent。

父主题： 常见问题


仪表板面板权限

要查看或编辑某个仪表板面板的内容，您需要以下权限：
面板 | 所需权限
已分配的问题 | 查看测试和执行。
自定义信息 | 需要管理项目权限才能进行编辑。 无需任何权限即可进行查看。
简介 | 无需任何权限。
问题生命周期 | 查看项目设置。
每个测试工程师创建的问题 | 查看测试和执行。
分配给我的手动测试 | 执行测试。
计划与 实际执行时间 | 查看测试周期和配置。
质量目标进度 | 查看质量目标。
报告订阅 | 无需任何权限。
需求覆盖率状态 | 查看需求。
Silk Central Connect | 在面板中显示信息所需的查看测试和执行权限。从面板访问 Silk Central 其他区域所需的其他权限。
Silk Performer 性能趋势 | 查看测试和执行
当前正在运行的手动测试的状态 | 查看测试和执行
Testbook | 无需任何权限。
测试周期进度 | 查看测试周期和配置。
测试周期结果摘要 | 查看测试周期和配置。
测试周期时间线 | 查看测试周期和配置。
跨测试周期的测试进度 | 查看测试周期和配置。
易变测试 | 查看测试和执行。
父主题： 仪表板
父主题： 权限定义


向仪表板面板添加报告

仪表板的报告订阅面板允许您使用报告单元中可用的任何报来显示现有报告。首先，创建和配置报告，然后向仪表板添加面板。
  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中选择报告。
  3. 单击订阅选项卡。
  4. 单击添加订阅。 此时将打开编辑订阅对话框。
  5. 在名称字段中指定订阅的名称。
  6. 若要修改订阅参数，单击编辑参数。 此时将打开编辑参数对话框。更改值，然后单击确定。
  7. 从计划列表中选择计划。如果您需要的计划不存在，您需要自行创建。您也可以选择无计划，例如，仅根据测试执行结果才会触发的订阅。
  8. 单击提供给仪表板和外部访问使报告可以在仪表板面板中使用。
  9. 单击确定。 新订阅将列入订阅列表。
  10. 在菜单中，单击主页 > 我的仪表板。
  11. 单击左上方的添加面板。 将显示添加面板对话框，列出可用面板以及每个面板的简短说明。
  12. 选择报告订阅。 随即将显示配置面板对话框，列出所有可用报告订阅。
  13. 从列表中选择报告订阅，然后单击确定。 面板将添加到您的仪表板。
父主题： 仪表板
父主题： 报告订阅


浏览器设置

要优化 Silk Central 的功能和性能，请在浏览器中调整以下设置：

  • 确保您已启用浏览器的缓存。
  • 如果您在通过浏览器访问 Silk Central 时遇到问题，请在浏览器中将 Silk Central 服务器添加到受信任站点列表。

有关受支持浏览器的列表，请参阅“发行说明”。 在菜单中，单击帮助 > 文档 。 单击 Silk Central 18.5 发行说明。

父主题： 用户界面


登录和注销

此部分中的步骤介绍如何登录 Silk Central 和从中注销。

  • 登录 Silk Central
    介绍如何导航至 Silk Central 安装以及如何使用帐户凭据登录。
  • 从 Silk Central 注销
    介绍如何从 Silk Central 注销。
父主题： 用户界面
相关概念
LDAP 身份验证


登录 Silk Central

登录 Silk Central：

  1. 导航至 Silk Central 安装的 URL。
  2. 在 Silk Central 登录页面上，以 <客户端>\<用户名> 的形式输入用户名和密码。 当您以默认客户端用户的身份登录 Silk Central 时，无需输入客户端名称。只需输入您的用户名。

    使用以下默认凭据作为超级用户登录：

    • 用户名：管理
    • 密码：管理
  3. 如果选中记住登录复选框，您将保持登录状态，直到您关闭浏览器选项卡。下次您访问 Silk Central 时，系统将自动为您重新登录。
  4. 单击登录。
您将定向到个人仪表板。您可以快速继续在上次访问的区域工作，方法是单击仪表板页面顶部的此链接。
父主题： 登录和注销
相关概念
登录选项
超级用户


从 Silk Central 注销

从 Silk Central 注销：

  1. 在菜单中，转至用户：<用户名>。
  2. 单击注销。
父主题： 登录和注销


快速启动任务

快速启动任务是对您可能需要使用 Silk Central 执行的主要任务的高级概述。这些任务可作为逐步指导您最佳利用 Silk Central 核心功能的教程。有关更多信息，请参阅本帮助中的相关部分：需求、测试、执行计划以及问题跟踪和结果分析。

  • 配置所需的资产 - 快速启动任务
    开始构建测试框架之前，您需要先配置至少一个项目和一个产品，如果您计划创建自动测试，则还需要配置一个源代码管理配置文件。
  • 定义需求 - 快速开始任务
    管理您的需求，便于将它们与测试相关联，确保测量您的软件涵盖指定需求的程度。集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。
  • 设计测试 - 快速开始任务
    设计您的测试以涵盖所有相关功能和有用的测试。
  • 执行计划和执行测试 - 快速开始任务
    计划并执行您的测试来获取所需的测试数据。
  • 跟踪和分析测试结果 - 快速启动任务
    可以通过多种方式在 Silk Central 中分析测试结果，具体取决于您查找的信息以及您执行的测试类型。
父主题： 开始


配置所需的资产 - 快速启动任务

开始构建测试框架之前，您需要先配置至少一个项目和一个产品，如果您计划创建自动测试，则还需要配置一个源代码管理配置文件。您可能还需要配置一些其他设置，例如筛选器、属性等。您必须拥有超级用户、管理员或项目经理权限才能执行这些任务。

要配置所需的资产，您需要执行以下任务。

  1. 添加项目
    Silk Central 在项目上下文中管理需求、测试及其执行和结果。 因此，您首先要创建一个项目。
  2. 添加产品
    Silk Central 在一种特定产品的版本和内部版本上下文中跟踪测试执行结果。因此，必须先定义产品，然后才能创建测试。
  3. 配置源代码管理配置文件
    对于自动测试，创建测试的另一个需求是源代码管理配置文件。 Silk Central 中的自动测试实际上表示源代码管理系统中的测试脚本，您可以通过此类源代码管理配置文件访问这些脚本。
父主题： 快速启动任务


添加项目

Silk Central 在项目上下文中管理需求、测试及其执行和结果。 因此，您首先要创建一个项目。

创建项目：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 单击新建项目。 将显示项目设置页面。
  3. 键入项目名称和说明。
  4. 选择项目负责人。
  5. 可选：输入您项目的标记。如果您有许多项目，请使用项目列表页面上的标记列，项目标记可帮助您筛选项目。
  6. 可选：要基于 Agile 项目模板创建项目，请从项目模板列表框中选择 Agile 项目模板。
  7. 要将项目初始化为 Issue Manager 项目，请单击初始化新项目或重用现有项目。有关更多信息，请参阅将项目初始化为 Issue Manager 项目。
  8. 在共享测试部分，定义项目是否是存储库项目。选择以下选项之一：
    • 不共享测试：此项目不使用其他项目的测试，且其测试也不可由其他项目使用。
    • 共享测试：此项目配置为存储库项目，以使其他项目可以使用此项目的测试。
    • 使用以下项目中的共享测试：选中此项目使用的共享测试来自的存储库项目。
  9. 组部分包含可用组和已分配组的列表。根据需要分配组。使用 Ctrl+单击或 Shift+单击选择多个组。您还可单击导入 LDAP 组，以从 LDAP 服务器导入组。有关详细信息，请参阅从 LDAP 服务器导入组。如果用户组不存在，您可能要在创建用户组后再对其分配。您也可以在组设置页面配置组/项目分配。权限因用户角色而异。有关用户权限的信息，请参阅用户角色和权限。
  10. 位置部分包含可用位置和已分配位置的列表。根据需要分配位置。使用 Ctrl+单击或 Shift+单击选择多个位置。如果位置不存在，您可能要在创建位置后再对其分配。您也可以在位置设置页面配置位置/项目分配。有关详细信息，请参阅管理位置。
  11. 单击保存以保存您的设置。 您将返回到其中列出新项目的项目列表页面。
父主题： 配置所需的资产 - 快速启动任务
下一主题： 添加产品


添加产品

Silk Central 在一种特定产品的版本和内部版本上下文中跟踪测试执行结果。因此，必须先定义产品，然后才能创建测试。

添加新产品：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击新建产品。 将显示新建产品对话框。
  4. 在名称文本框中键入新产品的名称。
  5. 在说明文本框中键入产品的说明。
  6. 选中活动复选框，以使此产品可与 测试 关联。
  7. 单击确定以保存产品。
    注： 创建产品时，Silk Central 会为新产品自动创建新默认版本 1.0 和新默认内部版本 1。
父主题： 配置所需的资产 - 快速启动任务
上一主题： 添加项目
下一主题： 配置源代码管理配置文件


配置源代码管理配置文件

对于自动测试，创建测试的另一个需求是源代码管理配置文件。 Silk Central 中的自动测试实际上表示源代码管理系统中的测试脚本，您可以通过此类源代码管理配置文件访问这些脚本。
有关源代码管理配置文件配置的详细信息，请参阅源代码管理配置文件。
父主题： 配置所需的资产 - 快速启动任务
上一主题： 添加产品


定义需求 - 快速开始任务

管理您的需求，便于将它们与测试相关联，确保测量您的软件涵盖指定需求的程度。集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。

要管理需求，您需要执行以下部分或全部任务。

  1. 创建需求
    将需求与测试关联，确保测量软件涵盖指定需求的程度。
  2. 从需求生成测试
    您可从需求树直接生成测试并将测试分配到特定需求。需求树用作新测试树的测试文件夹/测试结构的模板。
  3. 集成外部需求管理工具
    集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。
父主题： 快速启动任务


创建需求

将需求与测试关联，确保测量软件涵盖指定需求的程度。

要创建新需求，请执行以下操作：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 在需求树中，选择需求或根节点。
  3. 单击工具栏中的 [image] （新建需求）在同一层上创建新需求，或单击 [image] （新建子需求）在所选需求下方创建需求。 将显示新建需求对话框。
  4. 键入需求的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 可选： 取消选中从父级继承复选框。在此情况下，子需求将不会从父需求继承属性。默认情况下，所有复选框均处于选中状态。
    注： 在属性页面上的详细信息视图中和文档视图中，继承的属性用星号 (*) 标记。
  6. 从列表中选择适当的优先级、风险和已审阅状态。
  7. 如果已定义自定义需求，这些需求将列于已审阅列表下。在相应字段中，键入要使用此需求进行跟踪的任何自定义属性数据。可以为继承属性禁用此项。有关创建、编辑和删除自定义需求属性的详细信息，请参阅自定义需求属性。
  8. 完成新需求的创建：
    • 单击确定以创建需求并关闭对话框。
    • 单击确定和新建需求以创建需求并保持对话框打开以输入其他需求的数据。
    • 单击确定和新建子需求以创建需求并保持对话框打开以输入子需求的数据。
父主题： 定义需求 - 快速开始任务
下一主题： 从需求生成测试


从需求生成测试

您可从需求树直接生成测试并将测试分配到特定需求。需求树用作新测试树的测试文件夹/测试结构的模板。

要从详细信息视图生成新测试：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 右键单击要将其转化成测试的需求或项目节点，然后选择生成测试。 此时将显示从需求生成测试对话框。此对话框使您可指定是否将所选需求子树的树叶（即最低级别的节点）转化成测试或测试文件夹，以及是否将树生成到新的测试容器或现有容器。
  3. 在输入名称字段输入新测试容器的名称，然后从选择产品列表中选择产品以在活动 Silk Central 项目中创建容器。 选择产品列表由项目经理配置的产品填充。有关详细信息，请参阅管理产品或咨询您的项目经理。
  4. 如果已定义源代码管理配置文件，则从选择源代码管理配置文件列表中选择用于管理测试源代码的源代码管理配置文件。 有关源代码管理配置文件的详细信息，请参阅源代码管理配置文件或咨询您的 Silk Central 管理员。
  5. 要在测试中包括所选需求的所有子需求，请选中包括子需求复选框。 复选框默认为选中。
  6. 要将新测试自动分配到其从中创建的需求，请选中将新生成的测试分配到需求复选框。 如果未选择此选项，则必须手动将测试与需求关联。
    注： 选中从需求树叶中生成测试文件夹时，此选项不可用。
  7. 单击确定以创建测试。 新测试与需求树具有相同的结构。
  8. 此时将显示消息框。单击是查看测试区域的测试，或单击否保持在需求区域。
父主题： 定义需求 - 快速开始任务
上一主题： 创建需求
下一主题： 集成外部需求管理工具


集成外部需求管理工具

集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。

有关集成外部需求管理工具的详细信息，请参阅需求管理工具。

父主题： 定义需求 - 快速开始任务
上一主题： 从需求生成测试


设计测试 - 快速开始任务

设计您的测试以涵盖所有相关功能和有用的测试。

要设计测试，您需要执行以下部分或所有任务。

  1. 构建测试资产
    产品和源代码管理配置文件信息都是在测试容器层指定的，因此这些信息代表着测试资产结构中的顶层节点。
  2. 创建测试
    创建测试来测试特定的软件功能。
  3. 将需求分配到测试
    将需求与测试关联，确保测量软件涵盖指定需求的程度。
父主题： 快速启动任务


构建测试资产

Silk Central 在一种特定产品的版本和内部版本上下文中跟踪测试执行结果。因此，必须先定义产品，然后才能创建测试。对于自动测试，创建测试的另一个需求是源代码管理配置文件。 Silk Central 中的自动测试实际上表示源代码管理系统中的测试脚本，您可以通过此类源代码管理配置文件访问这些脚本。产品和源代码管理配置文件信息都是在测试容器层指定的，因此这些信息代表着测试资产结构中的顶层节点。

只需创建一个容器即可开始使用：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要向其中添加新容器作为子节点的根节点。
    注： 无法嵌套容器，但可以向容器添加子文件夹。
  3. 单击工具栏上的 新建测试容器 或右键单击节点并选择新建测试容器。

    您也可右键单击节点节点并选择新建测试容器。

    新容器根节点将添加到测试树，并将显示新建测试容器对话框。
  4. 键入容器的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 从列表框中选择与此测试容器关联的任何预定义产品。有关添加产品配置文件的详细信息，请参阅添加产品。
  6. 从源代码管理配置文件列表框中选择预定义源代码管理配置文件。 如果不想为测试容器检出任何测试源（例如，如果只有手动测试），请选择 ---。
    注： Silk Central 执行服务器会从预定义源代码管理配置文件为容器中包括的测试检索程序源代码。根据源代码控制配置文件中的指定路径，您可进行指定，以使用测试容器根节点字段中的子节点。
  7. 可选：选中每次测试执行前清理工作文件夹复选框。

    如果选中，从源代码管理中删除文件的也将同时从工作文件夹中删除。默认为选中状态。

  8. 要指定保存容器的默认根路径，请单击浏览...并导航至位置。
  9. 可选：当 Silk Central 与 Silk Performer集成时，您可定义自定义数据目录和自定义包括目录。 在Silk Performer 中，Include 目录分为一个 System Include 目录和一个 Custom Include 目录。Data 目录分为一个 System Data 目录和一个 Custom Data 目录。有关其他信息，请参阅 Silk Performer 文档。
  10. 您可通过对话框的隐藏测试属性部分指定要显示在测试容器的属性页面上的测试属性类型，以及容器内所有测试文件夹的属性页面。 这些设置不会影响单个测试的显示。
  11. 单击编辑以调整隐藏测试属性设置。 将显示隐藏测试属性对话框。
  12. 取消选中要显示其属性的所有测试类型的复选框。
  13. 单击确定以保存您的设置并关闭隐藏测试属性对话框。
  14. 单击保存以保存您的设置。
父主题： 设计测试 - 快速开始任务
下一主题： 创建测试


创建测试

创建测试来测试特定的软件功能。
Silk Central 支持多种开箱即用的测试类型。请参阅管理测试，并选择您想要创建的测试类型，然后按照参考主题中的说明执行操作。
父主题： 设计测试 - 快速开始任务
上一主题： 构建测试资产
下一主题： 将需求分配到测试


将需求分配到测试

将需求与测试关联，确保测量软件涵盖指定需求的程度。
将需求手动分配到测试：
  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要分配需求的测试。
  3. 单击已分配的需求选项卡。
    注： 如果您已创建需求筛选器，则可以在需求树上方的筛选器列表中进行选择。要创建新需求筛选器，请单击菜单中的需求 > 详细信息视图 ，然后单击工具栏中的 新建筛选器 。
    可用于分配的所有需求都显示在需求树中。
  4. 选择要分配的需求。 您可使用键盘的 Ctrl 和 Shift 键，以通过标准浏览器多选功能选择多个需求。
  5. 单击分配所有已筛选项，以便将所有已筛选需求分配给所选测试，或将所选内容拖放到已分配的需求区域，或单击任意需求左边的 分配 。只有在您具备管理需求或管理资产权限时，分配所有已筛选需求的功能才会启用。
    注： 选中从需求生成测试对话框上的将新生成的测试分配到需求复选框可将新生成的测试自动分配到从其中生成这些测试的需求。这是默认行为。
父主题： 设计测试 - 快速开始任务
上一主题： 创建测试


执行计划和执行测试 - 快速开始任务

要计划并执行测试，您需要执行以下部分或所有任务。

  • 计划和执行自动测试
    创建执行计划以同时执行相关测试。
  • 计划和执行手动测试
    此演练通过示例向您展示手动执行计划的功能。
父主题： 快速启动任务


计划和执行自动测试

创建执行计划以同时执行相关测试。
  1. 创建执行计划
    创建执行计划以同时执行相关测试。
  2. 手动将测试分配至执行计划
    手动将测试分配至执行计划以将其添加到所包含的测试中。
  3. 开始执行计划
    执行单个执行计划，以便独立于计划运行它们。
父主题： 执行计划和执行测试 - 快速开始任务


创建执行计划

创建执行计划以同时执行相关测试。
  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择文件夹或项目节点。
  3. 在工具栏上单击 新建子执行计划 （新建子执行计划），或右键单击文件夹、测试周期或节点并单击新建子执行计划。 将显示新建执行计划对话框。
  4. 键入执行计划的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 从测试容器列表中选择测试容器。
    注： 您仅可向一个执行计划分配一个测试容器。仅可执行来自此测试容器的测试。
    容器所属产品中定义的最新版本和内部版本将自动填充到版本和内部版本列表中。
  6. 从列表中选择产品版本和内部版本。 开始此执行计划的新运行时，将使用这些信息。或者，您可选中从内部版本信息文件中读取复选框。在此情况下，将在每个运行开始时从应用程序服务器上的内部版本信息文件中读取版本和内部版本。如果内部版本信息文件在执行服务器上可用，则此文件默认为用于测试运行，从而覆盖新建执行计划对话框上的设置。
  7. 从列表中选择执行计划的优先级。 对于自动执行计划，如果多个执行计划在排队等候，但只有一个执行服务器可用，则优先级将确定先执行的执行计划。如果执行服务器可用，但多个执行计划所需的移动设备不可用，情况也是如此。
  8. 在源代码管理标签文本框中，您可以选择指定执行计划的版本早于最新版本。该标签必须引用与测试容器关联的源代码管理系统中的版本。如果将此文本框留空，则将获取执行计划的最新版本。仅当关联测试容器使用支持版本控制的源代码管理配置文件时，源代码管理标签属性才启用。当使用多个版本的源代码文件时，确保执行服务器上具有足够的可用磁盘空间。每个版本都将保存在其位于各个执行服务器上的文件夹中。
    提示： 如果您想要为特定执行计划签出存储库的特定分支，请在相应执行计划的源代码管理标签字段中指定分支名称。
  9. 单击确定以使用新创建的执行计划更新执行树。
父主题： 计划和执行自动测试
下一主题： 手动将测试分配至执行计划


手动将测试分配至执行计划

手动将测试分配至执行计划以将其添加到所包含的测试中。
  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择您要将所选测试分配至的执行计划。
  3. 单击已分配的测试选项卡。
  4. 单击手动分配选项。 与所选执行关联的测试容器的所有测试都将显示在测试树中。如果您已创建测试筛选器，则可以从测试树上方的筛选器列表中选择它。要创建新的测试筛选器，请在菜单中单击测试，然后在工具栏中单击 [image] （新建筛选器）。
  5. 选择要分配的测试。 您可使用键盘的 Ctrl 和 Shift 键，以通过标准浏览器多选功能选择多个测试。
  6. 将所选内容拖放到已分配的测试区域，或单击任意测试左边的 分配 。 通过分配文件夹或顶层容器，可将父项的所有子测试分配至所选执行计划。
    提示： 右键单击一个节点以进行展开和折叠。
父主题： 计划和执行自动测试
上一主题： 创建执行计划
下一主题： 开始执行计划


开始执行计划

执行单个执行计划，以便独立于计划运行它们。
  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您想要执行的项目、执行计划、文件夹或配置套件，或使用 Ctrl+单击或 Shift+单击选择多个元素。
  3. 单击工具栏上的 [image] （运行）。可以为测试周期、测试周期内的执行计划和未分配测试禁用此项。 此时将显示运行对话框。
  4. 定义您要在运行对话框中执行的测试。
  5. 为执行定义测试后，选中转到活动页面复选框可前往活动页面。
父主题： 计划和执行自动测试
上一主题： 手动将测试分配至执行计划


计划和执行手动测试

此演练通过示例向您展示手动执行计划的功能。示例假设包括：

  • 根据 Risk 属性完全记录和分类需求。
  • 根据定义执行特定测试必要性的 Importance 属性来完全记录 575 个手动测试、将其分配给需求并进行分类。
  • 已根据需求属性 Risk 和测试属性 Importance 定义质量目标，也称为项目退出条件。这些质量目标指定所需的测试级别。
  • 要计划的测试仅限最能满足质量目标的那些测试。
  1. 概述
    提供“手动执行计划”页面的区域概述。
  2. 创建测试周期
    介绍如何通过定义开始日期、结束日期和容量来创建测试周期。
  3. 添加手动测试工程师
    介绍如何将手动测试人员添加到测试周期以及如何定义容量。
  4. 选择测试与计划
    介绍如何筛选、排序并分组测试，以及如何将其分配给测试周期。
  5. 将测试分配到手动测试人员
    介绍如何将测试周期的测试分配到手动测试人员。
  6. 执行手动测试
    既然您已启动执行计划，便可使用手动测试窗口来执行手动测试。
父主题： 执行计划和执行测试 - 快速开始任务


概述

手动执行计划页面包含四个区域，它们显示在两个屏幕上。在第一个屏幕（即测试选择屏幕）上，您可以为测试周期选择和计划测试。在第二个屏幕（测试分配屏幕）上，您可以将所选测试周期的测试分配至将执行测试的测试人员。

测试选择屏幕分为三个区域：

  • 左侧的筛选条件区域。通过筛选器功能，您可以缩小在下一区域中显示的测试范围。
  • 中间的匹配测试区域。此列表显示所有可用测试。应用筛选器后，只显示筛选后的测试。
  • 右侧的测试周期区域。在此处，您可以将中部列表中的测试分配至特定测试周期，它是已定义的时间期限。

要访问测试分配屏幕，请单击右上角的测试分配 >>>。此屏幕分为两个区域：

  • 左侧的测试周期区域。这与测试选择屏幕上的区域相同，它显示在两个屏幕上。
  • 右侧的已分配的测试区域。此列表显示已添加至当前所选测试周期的测试。在此处，您可以将列表中的测试拖到测试周期区域，然后将其放到测试人员上。

父主题： 计划和执行手动测试
下一主题： 创建测试周期


创建测试周期

第一步是创建测试周期。测试周期是定义的时间段，包含开始日期、结束日期和手动测试人员列表。我们将我们的测试周期命名为 第 21 周 - 团队 A。
  1. 在菜单中，单击执行计划 > 手动执行计划。
  2. 在右侧的测试周期区域中，单击新建测试周期。 将显示新建测试周期对话框。
  3. 输入测试周期的名称，此示例中为 第 21 周 - 团队 A。
  4. 输入说明（可选）。
  5. 单击开始日期旁边的 [image] 以设置测试周期的开始日期。
  6. 单击结束日期旁边的 [image] 以设置测试周期的结束日期。
  7. 以 hh:mm 格式输入要为此测试周期提供的时间长度（容量），我们在此示例中输入 35:00。
  8. 单击确定。
我们的测试周期此时显示在测试周期区域中。它显示当前未分配任何测试人员。下一步是分配测试人员。

父主题： 计划和执行手动测试
上一主题： 概述
下一主题： 添加手动测试工程师


添加手动测试工程师

下一步将手动测试人员添加到我们的测试周期。我们还将定义此测试周期中每个手动测试人员拥有的容量。
  1. 在我们的测试周期标题第 21 周 - 团队 A 中，单击 ... > 编辑已分配的测试人员。 此时将显示编辑已分配的测试程序对话框。
  2. 单击添加/删除测试程序。 此时将显示添加/删除测试程序对话框。
  3. 从可用列表中选择用户组。
  4. 从可用列表中的用户组选择一个或多个用户。
  5. 单击添加或全部添加以将用户添加到已选定列表。
  6. 单击确定。 用户现在将添加到编辑已分配的测试人员对话框中的列表。
  7. 对于已添加的每个用户，请在容量字段中使用 hh:mm 格式提供测试周期的容量。
  8. 单击关闭。
此时，我们的测试周期会显示适用于整个测试周期以及每个手动测试人员的可用资源。燃尽图将显示尚未完成的已分配测试。创建我们的测试周期和添加手动测试人员之后，我们可确定下一步需要完成的测试。

父主题： 计划和执行手动测试
上一主题： 创建测试周期
下一主题： 选择测试与计划


选择测试与计划

本主题介绍如何将测试分配给我们的测试周期。目标是选择最佳覆盖已定义质量目标的测试。其中一个质量目标基于需求风险。典型做法是首先测试高风险事物。
  1. 在左侧的筛选条件区域，请选中质量目标下的需求风险复选框。 将匹配测试列表的范围缩小到关键的测试。
  2. 在匹配测试区域，打开列标题的上下文菜单，对测试进行排序、筛选或分组。这有助于选择应计划的测试。
  3. 选择一个或多个测试，将其拖到右侧的测试周期区域，然后将其拖到我们的测试周期。 将测试添加到测试周期时，将更新已使用资源的指示器。在指示器上移动鼠标，以了解有关总容量、计划时间和剩余时间的详细信息。
  4. 计划具有严重风险的所有测试后，再计划高风险测试。之后计划中等风险的测试，以此类推。

分配给我们测试周期的测试已移到无特定测试人员行。在下一步中，我们会将测试分配给手动测试人员。

父主题： 计划和执行手动测试
上一主题： 添加手动测试工程师
下一主题： 将测试分配到手动测试人员


将测试分配到手动测试人员

现在，我们将测试周期中的测试分配到手动测试人员。
  1. 单击右上方的测试分配 >>>。 将出现测试分配屏幕。
  2. 在左侧的测试周期区域中，单击我们的测试周期中的无特定测试人员行。 所有未分配到测试人员的测试将显示在右侧的已分配的测试区域中。
  3. 选择一个或多个测试并将其拖至左侧的测试周期区域，然后将其放至手动测试人员。 将测试分配到手动测试人员时，会更新资源指示符。将鼠标移至此指示符上方，以查看有关容量、计划时间和剩余时间的详细信息。
  4. 将测试分配给手动测试人员之后，请单击 ... > 开始测试周期以开始测试。

测试周期开始时，每个手动测试人员会收到关于已分配测试的电子邮件通知。您可将测试收件箱（分配给我的手动测试）添加到您的个人仪表板。分配给您的所有测试都列在此处。

父主题： 计划和执行手动测试
上一主题： 选择测试与计划
下一主题： 执行手动测试


执行手动测试

既然您已启动执行计划，便可使用手动测试窗口来执行手动测试。
要打开手动测试窗口，请在菜单中单击主页 > 我的仪表板，然后在分配给我的手动测试面板中单击 [image] （继续手动测试）。如果仪表板上未显示此面板，您必须添加此面板。有关仪表板和面板的更多信息，请参阅仪表板。

手动测试窗口直观易用，但若您需要有关手动测试的详细信息，请参阅手动测试。

父主题： 计划和执行手动测试
上一主题： 将测试分配到手动测试人员


跟踪和分析测试结果 - 快速启动任务

可以通过多种方式在 Silk Central 中分析测试结果，具体取决于您查找的信息以及您执行的测试类型。
要了解有关 Silk Central 结果分析功能（包括报告以及问题和活动跟踪）的更多信息，请参阅问题跟踪和结果分析。
  • 分析自动测试结果
    查看执行计划运行的测试结果，以了解高级根本原因分析，或者比较多个运行的结果，实现测试状态区别可视化。
  • 分析手动测试结果
    使用手动测试结果视图，提供易于阅读的手动测试结果视图，包括附加问题和附件等所有信息。
  • 仪表板面板
    Silk Central 中的仪表板是您的个人开始区域。您可添加和排列为您提供日常工作所需信息的各种面板，以自定义仪表板。
  • 报告
    使用 Silk Central 的报告功能分析测试结果。
父主题： 快速启动任务


分析自动测试结果

测试结果视图和运行比较视图提供了易于读取的结果概览，带有完整的向下钻取功能。其中包含所有信息，例如结果文件、缩略图屏幕快照、消息和堆栈跟踪。这允许您快速分析测试运行失败的根本原因，特别是可以并行比较多次运行的结果。

例如，您可能想要执行以下任务：
  • 分析配置套件或表示多种配置的执行计划内所有配置的运行
  • 比较相同执行计划的多次运行，例如为找到是否有任何测试状态发生了变化
  • 一次性显示一个执行计划的全部失败测试

分析自动测试运行的结果：

  1. 在执行运行网格或活动 > 上次执行网格中，选择一个或多个执行。
  2. 单击查看自动测试结果图标，以分析单个执行的结果，也可右键单击您选择的项目，然后选择比较自动测试结果来比较多次执行。
  3. 单击页面顶端的图标或特定状态图标可以访问详细信息，例如结果文件、缩略图屏幕快照、消息和堆栈跟踪。
    提示： 使用仅显示失败的测试复选框缩小显示结果的范围。
父主题： 跟踪和分析测试结果 - 快速启动任务


分析手动测试结果

如果您的测试运行处于已完成或未完成上下文之中，使用手动测试结果视图可提供易于阅读的手动测试结果视图，其中包括附加问题和附件等所有信息。您可立即看到所有这些信息。还可以打印和下载 PDF 版本。

手动测试结果视图包含左侧的树视图和右侧的详细信息视图。树视图基于在其中打开结果视图的选择的上下文。例如，如果您选择了一个测试周期，则可看到所有已分配的测试工程师及其测试。选择特定节点时，将使用所选内容的恰当信息更新详细信息视图。

几乎在所有查看手动测试的上下文中，您都可以单击测试的查看手动测试结果图标 ( [image]) 来打开手动测试结果视图。此类上下文包括手动执行计划、仪表板面板、活动页面和执行运行网格以及测试运行网格。

父主题： 跟踪和分析测试结果 - 快速启动任务


仪表板面板

Silk Central 中的仪表板是您的个人开始区域。您可添加和排列为您提供日常工作所需信息的各种面板，以自定义仪表板。

有关仪表板面板的详细信息，请参阅仪表板。

父主题： 跟踪和分析测试结果 - 快速启动任务


报告

有关报告的详细信息，请参阅报告。

父主题： 跟踪和分析测试结果 - 快速启动任务


需求

本部分说明如何管理 Silk Central 中的需求。

需求是用户完成特定任务所需的条件或能力，必须由受测试应用程序 (AUT) 来满足。将需求与测试关联，确保测量软件涵盖指定需求的程度。多个测试可以包含同一个需求，而一个测试也可以包含多个需求。集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。 需求区域使可您在开发期间管理和控制系统需求。您可以创建、修改和删除需求，将测试和需求关联，在历史记录中跟踪更改，并从需求列表中直接生成测试。

  • 配置需求设置和集成
    如果您计划在 Silk Central 中管理需求，则可以配置需求属性、筛选器和更改通知设置。如果您在其他系统中管理需求，可以将其与 Silk Central 集成，以便使用 Silk Central 的需求管理功能，例如需求和测试覆盖率。您必须拥有超级用户、管理员或项目经理权限才能执行这些任务。
  • 管理需求
    添加或编辑需求，就技术和非技术需求在客户与开发人员之间创建并维护协议。
  • 配置需求属性
    配置需求属性、附件、标记和覆盖率。
  • 将测试与需求关联
    将需求与测试关联，确保测量软件涵盖指定需求的程度。
  • 需求导入
    介绍如何从 Microsoft Word 或 Excel 导入需求。
  • 需求视图
    介绍需求区域中的可用视图。
父主题： Silk Central 帮助


配置需求设置和集成

如果您计划在 Silk Central 中管理需求，则可以配置需求属性、筛选器和更改通知设置。如果您在其他系统中管理需求，可以将其与 Silk Central 集成，以便使用 Silk Central 的需求管理功能，例如需求和测试覆盖率。您必须拥有超级用户、管理员或项目经理权限才能执行这些任务。
  • 需求属性
    介绍可用的需求属性类型。
  • 需求管理工具集成
    集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。
  • 筛选器
    介绍如何使用筛选器查找需要的准确信息，同时排除无关详细信息。
  • 更改通知
    介绍如何设置其他用户更改需求或测试时的电子邮件通知。
父主题： 需求


需求属性

以下部分介绍可用需求属性的两种类型。

  • 需求属性页面
    列出了可用于活动项目的自定义需求属性和计算属性。
  • 计算属性
    包含介绍如何使用计算需求属性的主题。
  • 自定义需求属性
    介绍如何使用所选项目中所有需求的自定义属性字段。
父主题： 配置需求设置和集成
父主题： 项目设置


需求属性页面

项目：<项目名称> > 项目设置 > 需求属性

需求属性页面列出了可用于活动项目的自定义需求属性和计算属性。

计算属性

列 | 说明
操作 | 可对计算属性执行的可用操作。
名称 | 计算属性的名称。 单击编辑图标可编辑计算属性。
公式 | 包含计算属性的实际公式。
分类 | 列出了计算属性的分类。
创建于 | 创建属性的时间。
创建者 | 创建属性的用户。
更改时间 | 最近修改属性的时间。
更改者 | 最近修改属性的用户。

自定义属性

列 | 说明
操作 | 可在自定义属性上执行的可用操作。
名称 | 需求属性的名称。 单击编辑图标可编辑需求属性。
类型 | 属性类型。有关每个属性类型的说明，请参阅测试属性和需求属性类型主题。
创建于 | 创建属性的时间。
创建者 | 创建属性的用户。
更改时间 | 最近修改属性的时间。
更改者 | 最近修改属性的用户。
父主题： 需求属性


计算属性

计算属性用于根据用户定义公式从内部或自定义属性值创建一个值。然后将此值放入名为分类的标记范围中。计算属性的目标是能够在网格中查看分类名称。每次显示自定义属性值时（例如，文档视图）都会显示计算属性的值。计算属性也可用于筛选器和质量目标中（如其他内部或自定义需求属性）。

每个计算属性都具有不设下限的默认分类。所有其他分类都必须具有下限。您可通过分类设置计算属性值的名称和范围。分类的名称表示值在网格中的显示方式。如果未设置公式中所用的一个或多个属性值，或根据特殊需求评估公式失败（例如，除数为零），--- 将显示为计算属性的值。

您可在公式中将项目中任何内部或自定义属性用于计算属性。内部或自定义属性类型必须为具有单个选择的数字、文本或列表。您可在公式中使用以下运算符：+ - * / ()

限制： 每个项目现支持最多五个计算属性。不能在计算属性中使用其他计算属性。
  • 创建计算属性
    介绍如何创建计算属性。
  • 计算属性页面
    介绍计算属性页面。
  • 内部属性值
    介绍多个内部属性的值。
父主题： 需求属性


创建计算属性

计算属性用于创建基于一系列值的属性。此过程将引导您创建具有三种分类（低、中和高）的名为自定义风险的计算属性。我们将使用内部属性风险和名为影响且类型为数字的自定义属性（您应提前创建该属性）。

  1. 单击需求 > 需求属性。
  2. 单击新建计算属性。
  3. 在名称字段中，键入自定义风险。
  4. 在说明字段中，键入使用风险和影响（L、M、H）计算的属性。
  5. 从插入属性列表中选择业务影响。 ${Business Impact} 将添加到公式字段。
  6. 从插入运算符列表中选择 *。 ${Business Impact}* 将添加到公式字段。
  7. 从插入属性列表中选择业务风险。 ${Business Impact}*${Business Risk} 将添加到公式字段。
  8. 在默认的分类网格行上，将条目重命名为低。由于所有计算属性必须包含不设下限的默认分类，因此将使用此值。
  9. 单击添加分类。 一个新行将添加到分类网格。
  10. 将分类命名为中并添加下限 10。
  11. 单击添加分类。 一个新行将添加到分类网格。
  12. 将分类命名为高并添加下限 20。
  13. 单击确定。
此时将创建计算属性，当为需求设置了影响和风险属性时，将使用低、中或高填充计算属性。
父主题： 计算属性


计算属性页面

计算属性页面用于添加或编辑项目的计算属性。要访问此页面，请单击需求 > 需求属性，然后单击现有计算属性或新建计算属性。

名称
包含计算属性的名称。
说明
输入有意义的计算属性说明（可引用公式或分类）。
公式
包含计算属性的公式。要实现此操作，您可手动键入公式或使用插入属性和插入运算符列表。如果您手动键入公式，则字段名称应包含在以下结构中：${}。运算符位于此结构中。
插入属性
将光标置于公式字段中显示属性的位置，然后从列表中选择一种系统或自定义属性进行添加。
插入运算符
将光标置于公式字段中显示运算符的位置，然后选择运算符。
分类网格
分类网格用于设置计算属性值的变化范围。单击添加分类在网格中创建新行。使用名称字段来标识分类，并使用下限字段来确定计算属性的最低值。关于分类，有一点很重要：显示在网格中的是分类的名称而不是计算属性的值。例如，如果您的分类名称是中（下限是 5）且您的计算属性值是 7，则只要您的下一个分类下限值大于 7，计算值将显示为中。
父主题： 计算属性


内部属性值

可在计算属性的公式中使用多个内部属性的值。 受支持属性的值如下所示。

风险

值名称 | 内部值
低 | 1
中 | 2
高 | 3
关键 | 4

优先级

值名称 | 内部值
低 | 1
中 | 2
高 | 3
关键 | 4

已审阅

值名称 | 内部值
否 | 0
是 | 1
父主题： 计算属性


自定义需求属性

您可在需求 > 需求属性中添加所选项目中所有需求的自定义属性字段。随后可在编辑需求对话框中将自定义属性与默认属性一起编辑。自定义属性将显示在需求 > 详细信息视图 > 属性中。如果属性的唯一值是 URL，Silk Central 会自动将其显示为一个链接，便于您直接从 Silk Central 中访问其他 Web 应用程序。

  • 创建自定义需求属性
    创建新的自定义需求属性，以使其可用于活动项目中的所有需求。
  • 自定义属性和需求属性类型
    详述属性和需求属性的类型。
  • 编辑自定义需求属性
    编辑自定义需求属性。
  • 删除自定义需求属性
    删除自定义需求属性以将其从属性列表中删除。
父主题： 需求属性
相关参考
需求属性页面


创建自定义需求属性

创建新的自定义需求属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击需求属性选项卡。
  3. 单击新建需求属性以显示新建需求属性对话框。
  4. 在名称字段中键入新属性的名称。
  5. 从类型列表中选择新属性的数据类型。 有关每种属性类型的说明，请参阅测试属性和需求属性类型主题。
  6. 单击确定。
您的自定义属性将可用于活动项目中的所有需求。
父主题： 自定义需求属性
相关参考
自定义属性和需求属性类型


自定义属性和需求属性类型

Silk Central 支持以下类型的属性和需求属性：

日期

日期类型支持日期值。

列表

列表类型支持单选或多选列表。它包含以下控件：

  • 新建项目：允许您在列表中创建条目。单击以显示新建项目对话框。输入列表项目的名称和数值权重并单击确定。
    注： 如果筛选器条件使用以下任意运算符，则会在筛选期间使用数值权重字段的值：>、>=、< 或 <=。当筛选条件使用 = 或 not 运算符时，名称字段的值将用于比较。
  • 顺序：使用此列中的字段排序属性。
  • 允许多选：单击此复选框允许用户从列表中选择多个值。
    注： 您可以将现有单选列表更新为多选列表。多选列表无法通过更改成为单选列表。
  • 操作：使用此行中的图标删除或编辑列表中的每个项目。
编号

数字类型支持整数或小数数值。它包含以下字段：

  • 最小值：表示您可以在字段中输入的最小值。
  • 最大值：表示您可以在字段中输入的最大值。
  • 小数位数：用于定义小数点右侧有效的值数。若为整数值则选择 0，若为小数值则选择 1、2、3 或 4。
注： 如果对自定义属性和需求属性的定义做出更新（例如更改最小值或最大值），则它们会显示当前值。要应用新定义，请打开并保存资产。
文本

文本类型支持任何字母数字值。它包含以下字段：

  • 最大长度：表示可以在字段中输入的最大字符数。输入 0 或将此字段留空以使长度不受限制（仅限需求属性）。
父主题： 自定义需求属性
父主题： 属性


编辑自定义需求属性

要编辑以前创建的自定义需求属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击需求属性选项卡。
  3. 单击要编辑的属性的名称。 此时将显示编辑需求属性对话框。
  4. 在名称字段中编辑属性的名称。 如果属性可供使用，则名称将显示在筛选器和需求的列表中。 可在按需求属性进行筛选的全局筛选器中使用属性，并且可应用到需求。
  5. 编辑属性的说明。
  6. 请参阅测试属性和需求属性类型主题以获取有关每种类型的需求属性的说明。 您具有不同的编辑选项，具体取决于属性数据类型。
  7. 单击确定以保存您所做的更改。
父主题： 自定义需求属性
相关概念
筛选器
相关参考
自定义属性和需求属性类型


删除自定义需求属性

要删除以前创建的自定义需求属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击需求属性选项卡。
  3. 单击 删除 。 此时将显示确认对话框。
  4. 单击是以确认删除。
父主题： 自定义需求属性


需求管理工具集成

重要： 从 Silk Central 15.0 或早期版本升级到当前版本之前，执行全部同步以将您的全部需求与集成的需求管理工具同步。
集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。集成在项目：<项目名称> > 项目设置的需求管理页面中配置。
注： 您可以通过 Silk Central 创建、编辑和删除需求，而不是仅通过集成工具支持修改。您可以直接通过 Test Manager 的 UI 和/或 Silk Central 的 Web 服务进行修改，只需选中各自的允许创建、编辑和删除需求... 复选框即可。

Silk Central 支持通过其开放接口与外部需求管理系统 (RMS) 的集成。创建插件并将其集成到 Silk Central，这样允许集成任何 RMS。有关启用正确的外部 RMS 集成的接口信息，请参阅 Silk Central API 帮助。

  • 同步需求
    介绍如何同步 Silk Central 和外部需求管理工具之间的需求属性字段。
  • Atlassian JIRA Agile 集成
    介绍如何将 Atlassian JIRA Agile 与 Silk Central 集成。
  • CA Agile Central 集成
    介绍如何集成 CA Agile Central 与 Silk Central。
  • Caliber 集成
    介绍如何将 Caliber 与 Silk Central 集成。
  • IBM Rational DOORS 集成
    介绍如何集成 Silk Central 与 IBM Rational DOORS。
  • IBM Rational DOORS Next Generation 集成
    介绍如何集成 Silk Central 与 IBM Rational DOORS Next Generation。
  • IBM Rational RequisitePro 集成
    介绍如何将 IBM Rational RequisitePro 与 Silk Central 集成。
  • SAP Solution Manager 集成
    介绍如何集成 Silk Central 与 SAP Solution Manager。
  • 使用外部属性
    介绍如何在 Silk Central 中使用外部属性。
  • 编辑属性映射
    映射 Silk Central 与外部需求管理工具之间的属性字段以确保在项目之间正确填充需求属性字段。
  • 删除属性-映射值对
    删除属性-映射值对。
  • 禁用需求管理集成
    禁用外部需求管理工具的集成以禁用所有集成数据和功能。
  • 删除需求管理集成
    使用外部需求管理工具删除集成，以清除所有相关数据的数据库。
父主题： 配置需求设置和集成
父主题： 项目设置
父主题： 集成
相关参考
需求属性页面


同步需求

启用 Silk Central 和外部 RMS 之间的需求同步，可使 Silk Central 在执行同步时接收外部 RMS 中发生的更改。如果项目启用外部 RMS 集成，需求的主系统将自动为外部系统。这意味着始终从外部 RMS 工具同步到 Silk Central。无法再在 Silk Central 中编辑需求。一种异常情况是外部工具中不存在的新建需求，仅在设置 > 需求管理中启用选项启用上载需求时才会上载到外部（主）系统。

属性映射功能可使您在 Silk Central 和外部需求工具之间映射属性字段。例如，Silk Central 中称作 User 的自定义字段可能等同于 Caliber 中称作 Field_2 的属性字段。属性映射功能可确保需求属性字段的更改在项目之间准确刷新。如果您未使用属性映射功能，则仅映射需求的名称和说明。有关更多信息，请参阅编辑属性映射。

可使用以下方法之一同步需求：
手动同步
单击属性页面中根文件夹级别的同步更改，仅同步自上次同步后更改的需求。此选项不可用于 IBM Rational RequisitePro。
强制手动同步
单击属性页面中根文件夹级别的全部同步，可强制同步所有需求。
自动计划同步
根据全局定义的 Silk Central 计划。
自动在线同步
需求的更改自动在工具之间传播。此选项仅用于 Caliber。它要求在应用程序服务器上安装 Caliber 客户端,并在 Caliber 服务器上启用 MPX（有关启用 MPX 的详细信息，请参阅 Caliber 安装指南）。要启用 Caliber 和 Silk Central 之间的自动同步，请将 ss.jar 文件添加到 Program Files\Silk\Silk Central <version>\lib 处的应用程序服务器，并重新启动应用程序服务器。请联系客户服务以获取文件。在 Caliber 中做出更改时将在 Silk Central 中自动更新需求数据，在 Silk Central 中执行测试分配更改时会更新 Caliber 中的跟踪。此类在线同步仅在使用当前基线配置项目时可用。

可根据全局计划配置 Silk Central 和外部需求管理工具之间的需求自动同步。有关配置全局计划的详细信息，请参阅本帮助中的管理主题。

注： 打开 Caliber 按钮可打开注册用于打开扩展名为 .crm 的文件的默认程序。在某些机器上，这可能是需求查看器，而非 Caliber。此行为可以由管理员更改。客户端程序称为 caliberrm.exe。正确配置后，程序将打开到 Silk Central 中选定的需求。
需求树项目节点的活页夹图标表示项目的 RM 集成状态：
无配置
RM 集成不可用。
手动配置
若要导入、上载和同步需求，只能单击需求 > 需求视图 > 属性中项目节点上的相应按钮。
在项目级别，属性页面包括以下属性：
属性 | 说明
系统 | 启用集成的外部工具。
状态 | 是否已启用集成。
项目名称 | Silk Central 项目关联的外部项目的名称。
需求类型 | 项目间共享的需求类型。
上次同步 | 上次同步的日期和时间。
上次同步状态 | 上次同步状态包括已创建、已更新和已删除的项目数。
注： 启用 Caliber 和 Silk Central 之间的集成与自动在线同步时，项目节点将显示在线需求更改侦听器的当前状态。此类项目的三种可能状态为：已连接（已同步）、已重新连接（建议同步）和断开连接。
  • 在工具之间同步需求
    在 Silk Central 和外部配置的需求管理工具之间同步需求。
  • 根据计划同步需求
    定义全局计划以同步 Silk Central 和外部配置的需求管理工具之间的需求。
  • 为自动同步事件定义电子邮件通知
    定义要在 Silk Central 与外部需求管理工具之间的自动需求同步过程中发生错误时发送的电子邮件通知。
父主题： 需求管理工具集成
相关任务
编辑属性映射


在工具之间同步需求

注： 使用属性映射功能映射属性字段。 如果您未使用属性映射功能，则仅映射需求的名称和说明。 有关更多信息，请参阅编辑属性映射。

在 Silk Central 和外部配置的需求管理工具之间同步需求

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的项目节点。
  3. 单击属性选项卡。 属性页面将显示选定树元素的属性。
  4. 单击同步更改。
  5. 单击同步需求确认对话框中的是开始同步。 对话框在同步完成时打开，显示同步统计信息，其中包括已创建、已更新和已删除的需求数。
  6. 单击确定完成同步。 在外部配置的需求管理工具中，对映射需求做出的任何更新现已反映在需求树中。
父主题： 同步需求
相关任务
编辑属性映射


根据计划同步需求

您可以配置全局计划，以自动同步 Silk Central 和外部需求管理工具之间的需求。要启用 Caliber 和 Silk Central 之间的自动同步，请将文件 ss.jar 添加到位于 Program Files\Silk\Silk Central <版本>\lib 的应用程序服务器，并重新启动应用程序服务器。要获取文件，请联系客户服务。

根据全局定义的计划同步需求：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击需求管理选项卡。
  3. 单击编辑计划。 编辑计划对话框将会打开。
  4. 从同步更改列表中选择一个预定义全局计划，以定义外部系统中的更改与Silk Central 应同步的时间。
  5. 从全部同步列表中选择一个预定义全局计划，以定义外部系统中的所有需求与Silk Central 应同步的时间。
  6. 单击确定。
有关创建全局计划的信息，请参阅添加全局计划。
父主题： 同步需求


为自动同步事件定义电子邮件通知

您可以定义电子邮件通知以在 Silk Central 与外部需求管理工具之间的自动需求同步过程中发生错误时提醒用户。所有通知收件人都会收到同步日志文件的副本。

要为自动同步事件定义电子邮件通知：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击需求管理选项卡。
  3. 单击编辑通知。 此时将显示编辑通知对话框。
  4. 选中启用通知复选框。
  5. 从用户名列表框中选择用户名。
  6. 如果需要，请在其他电子邮件地址文本框中为其他收件人添加其他电子邮件地址。使用分号分隔多个电子邮件地址。
  7. 单击确定。
父主题： 同步需求


Atlassian JIRA Agile 集成

Silk Central 提供与 Atlassian JIRA Agile 的需求集成，该集成基于项目和问题跟踪系统 JIRA。所有问题类型（JIRA 中的通用对象类）均可同步。Atlassian JIRA Agile 支持创建自定义问题类型，因此您可在要同步的 Silk Central 中指定 Atlassian JIRA Agile 问题类型列表，例如缺陷或改进。

目前支持与 Silk Central 集成的 Atlassian JIRA Agile 版本：Atlassian JIRA 6、7

限制：同步 JIRA 需求只对配置的 JIRA 项目的需求起作用。如果需求链接到位于其他 JIRA 项目中的需求（叙述），这些需求将不会同步。

  • 启用与 Atlassian JIRA Agile 的集成
    启用与 Atlassian JIRA Agile 的集成以同步需求。
  • Atlassian JIRA Agile 属性映射
    介绍 Atlassian JIRA Agile 属性（如积压工作和优先级 在 Silk Central 中如何映射，以及如何查看和自定义这些属性。
父主题： 需求管理工具集成


启用与 Atlassian JIRA Agile 的集成

要启用与 Atlassian JIRA Agile 的集成：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择您要建立集成的项目。
  3. 在菜单中，单击项目：<项目名称> > 项目设置。
  4. 单击需求管理选项卡。
  5. 单击新建集成。
    注： 您可以通过 Silk Central 创建、编辑和删除需求，而不是仅通过集成工具支持修改。您可以直接通过 Test Manager 的 UI 和/或 Silk Central 的 Web 服务进行修改，只需选中各自的允许创建、编辑和删除需求... 复选框即可。
    将打开新建集成对话框。
  6. 从列表中选择 Atlassian JIRA Agile，然后单击下一步。 将打开编辑配置对话框。
  7. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  8. 输入JIRA Agile 服务器的 URL。
  9. 键入 JIRA Agile 的有效用户名和密码凭据。用户名必须是有效的 JIRA 用户配置文件名称。
  10. 在问题类型字段中，指定要同步的问题类型，使用分号 (;) 分隔多个类型。 所有问题类型（JIRA 中的通用对象类）均可同步。Atlassian JIRA Agile 支持创建自定义问题类型，因此您可在要同步的 Silk Central 中指定 Atlassian JIRA Agile 问题类型列表，例如缺陷或改进。
  11. 可选：要限制同步的需求量，您可以使用自定义 JQL 字段在需求同步之前预筛选需求。使用 有关 JQL 的详细信息，请访问 Atlassian 的高级搜索文档。 查询语言 (JQL) 在您的 JIRA Agile 系统内创建查询，然后将字符串复制并粘贴到自定义 JQL 字段。JIRA
    提示：
    • 请勿在 JQL 查询中使用 ORDER BY 语句。
    • JQL 字符串不能超过 128 个字符。
    • 此外，JQL 查询还用于已配置的项目和问题类型，而不会否决这些设置。
  12. 单击测试连接以确认您输入的主机和用户凭据是否正确。 如果设置正确，则会显示连接成功消息框。单击确定继续。
    注： 如果您无法建立连接，请咨询您的系统管理员。
  13. 单击加载。 项目列表将使用 JIRA Agile 中您拥有权限的所有项目进行填充。
  14. 从项目列表中，选择要与 Silk Central 项目集成的外部项目。
  15. 单击确定以保存您的设置。
父主题： Atlassian JIRA Agile 集成


Atlassian JIRA Agile 属性映射

以下属性在 JIRA Agile 与 Silk Central 之间有默认映射：
  • JIRA Agile 的 积压工作内的用户案例在 Silk Central 中表现为设置为积压工作的 Sprint 属性值。这让您能通过创建筛选器轻松执行搜索。
  • JIRA Agile 用户案例的默认优先级值映射为 Silk Central 的优先级属性。如果您要使用的不是 JIRA Agile 的默认优先级值，可以自定义此映射。

查看 Silk Central 中的 JIRA Agile 积压工作案例

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 使用以下条件创建新筛选器：
    • 选择条件：外部自定义属性
    • 属性：Sprint
    • 值：积压工作
  3. 单击应用立即应用筛选器，或者单击保存并应用保存筛选器，以备将来使用。

将 JIRA Agile 的优先级值映射为 Silk Central 的优先级

JIRA Agile 用户案例的默认优先级值映射为 Silk Central 的优先级属性，如下所示：
  • Blocker=SC_Priority_Critical
  • Critical=SC_Priority_High
  • Major=SC_Priority_Medium
  • Minor=SC_Priority_Low
  • Trivial=SC_Priority_Low
如果您要使用的不是 JIRA Agile 的默认优先级值，或者希望自定义映射，您的 Silk Central 管理员应如下自定义设置：
  1. 停止应用程序服务器。
  2. 使用文本编辑器打开 propertyMappings.properties 文件。此文件位于应用程序服务器上 plugins 文件夹的 JIRA Agile plugin-file JIRAAgile.zip中。
  3. 搜索SC_Priority=Priority，可以在其下方自定义 JIRA Agile 的优先级值到 Silk Central 优先级的映射。
    注： Silk Central 优先级值需要使用 SC_Priority_ 前缀。
  4. 保存并关闭文件
  5. 重新启动应用程序服务器。
父主题： Atlassian JIRA Agile 集成
相关任务
创建筛选器
启动或停止本地执行服务器服务


CA Agile Central 集成

集成项目管理工具 CA Agile Central 可使您定义之后在 Silk Central 中用作需求的用户情景。然后，您可以在 Silk Central 中创建测试来覆盖这些需求。要使用对 CA Agile Central 中相应用户情景做出的任何更改来更新您创建的测试，请同步需求。

Silk Central 附带的混合功能允许您在 CA Agile Central 中显示来自 Silk Central 的与用户案例相关的测试覆盖率信息。您可以将 Silk Central 中的每个测试链接到 CA Agile Central 中的一个或多个用户案例。要将测试链接到用户案例，请将 CA Agile Central 中具有格式化用户案例 ID 值的属性分配给每个测试。

以下用户情景属性从 CA Agile Central REST Service 同步。如果在集成配置中指定了自定义字段，这些字段也会同步。您可以使用这些属性来帮助筛选用户情景并对其分类：
属性
说明
名称
CA Agile Central 中用户情景的名称。
CA Agile Central ID
CA Agile Central 中用户情景的标识符。此属性是 Silk Central 中需求的外部 ID。
说明
CA Agile Central 中用户情景的说明。
迭代
其中包含用户情景的 CA Agile Central 的迭代。
项目
其中包含用户情景的 CA Agile Central 项目。
发布
其中包含用户情景的项目发布。
状态
CA Agile Central 中用户情景的进度状态。以下状态可用：
  • 已定义
  • 正在进行
  • 已完成
  • 已接受
计划预计（情景点）
CA Agile Central 中要完成的用户情景的预计时间。时间根据情景点预计。
  • 启用与 CA Agile Central 的集成
    启用与 CA Agile Central 的集成以同步需求。
  • 在 CA Agile Central 中创建自定义 HTML 应用程序
    使用 HTML 或 JavaScript 代码在 CA Agile Central 中创建自定义应用程序，以显示与用户案例相关的测试覆盖率信息。
  • 将用户案例从 CA Agile Central 链接到测试
    将 CA Agile Central 的 User Stories 链接到 Silk Central 中的测试
父主题： 需求管理工具集成


启用与 CA Agile Central 的集成

要启用与 CA Agile Central 的集成：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择您要建立集成的项目。
  3. 在菜单中，单击项目：<项目名称> > 项目设置。
  4. 单击需求管理选项卡。
  5. 单击新建集成。
    注： 您可以通过 Silk Central 创建、编辑和删除需求，而不是仅通过集成工具支持修改。您可以直接通过 Test Manager 的 UI 和/或 Silk Central 的 Web 服务进行修改，只需选中各自的允许创建、编辑和删除需求... 复选框即可。
    将打开新建集成对话框。
  6. 从列表中选择 CA Agile Central，然后单击下一步。 将打开编辑配置对话框。
  7. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  8. 键入 URL。
  9. 为 CA Agile Central 键入有效的用户名和密码凭据，或者键入有效的 API 键。API 键可用于访问您的 CA Agile Central 订阅数据，而且无需使用您的用户名和密码。 有关 CA Agile Central API 键的更多信息，请参阅 CA Agile Central Application Manager 页面。
  10. 可选： 如果直接访问 Internet 受限，并且 CA Agile Central REST Service 位于内部网络范围外的机器中，请使用代理主机和代理端口字段指定 Silk Central 可通过其连接到 CA Agile Central 的代理。
    注： 要使用代理连接到 CA Agile Central，您需要填写代理主机和代理端口字段。
  11. 可选： 如果您想要同步自定义字段，在自定义字段字段中键入其名称，用逗号分隔。此时必须使用内部字段名称，而非显示名称。
  12. 单击测试连接以确认您输入的主机和用户凭据是否正确。 如果设置正确，则会显示连接成功消息框。单击确定继续。
    注： 如果您无法建立连接，请咨询您的系统管理员。
  13. 单击确定。
  14. 单击加载。 项目列表框将使用 CA Agile Central 中您拥有权限的所有工作区内的所有项目进行填充。
  15. 从项目列表框中，选择要与 Silk Central 项目集成的外部项目。
  16. 单击确定以保存您的设置。
父主题： CA Agile Central 集成


在 CA Agile Central 中创建自定义 HTML 应用程序

使用 HTML 或 JavaScript 在 CA Agile Central 中创建自定义应用程序，以显示与用户案例相关的测试覆盖率信息。

创建自定义 HTML 应用程序：

  1. 在 CA Agile Central 中导航到您的自定义应用程序应处于的选项卡。
  2. 单击自定义页面，再单击添加应用程序。 此时将显示应用程序目录。
  3. 单击自定义下的自定义 HTML，然后单击添加此应用程序。
  4. 输入标题，然后切换到 Silk Central。
  5. 在菜单中，单击 帮助 > 工具 。
  6. 单击 CA Agile Central 迭代状态混合，复制 HTML 代码。
  7. 切换回 CA Agile Central，将 HTML 代码粘贴到 HTML 字段中。
  8. 配置该字段中的脚本，以符合您的 Silk Central 环境：
    • 检查是否已设置有效脚本源，例如 <script type="text/javascript" src="http://localhost:19120/silkroot/script/sctm-toolkit.js"></script>。
    • 检查是否已为 Silk Central 设置有效 URL，例如 var SCTM_URL = "http://localhost:19120/"。
    • 检查是否已设置有效的 Silk Central 项目 ID，例如 var SCTM_PROJECT_ID = 0。
    • 检查是否已设置有效的属性名称，例如 var SCTM_ATTRIBUTE_FOR_RALLY_US = "rallyattr"。
    • 确保能够使用 CA Agile Central 中的 FormattedID，并且 var USE_FORMATTED_ID = true。
  9. 单击保存。 这样就在 CA Agile Central 中创建了自定义 HTML 应用程序。
父主题： CA Agile Central 集成


将用户案例从 CA Agile Central 链接到测试

要将 CA Agile Central 的 User Stories 链接到 Silk Central 测试：

  1. 在 Silk Central 中选择其中包含要将 CA Agile Central 的 User Stories 链接到的测试的项目。
  2. 在菜单中，单击项目：<项目名称> > 项目设置。
  3. 单击属性选项卡。
  4. 单击新建属性。 将显示新建属性对话框。
  5. 在名称字段中键入 rallyattr。
  6. 从类型列表中选择文本。
  7. 单击确定以创建新属性。
  8. 将新属性分配给要将 CA Agile Central 的 User Stories 链接到的每个测试。
  9. 将属性值设置为每个测试的相应 CA Agile Central User Story 的 FormattedID 值。如果您将多个 User Stories 分配给单个测试，请使用逗号隔开 ID，并且不要在中间加空格。例如，US10,US12,US14。
父主题： CA Agile Central 集成


Caliber 集成

本节介绍如何将 Caliber 与 Silk Central 集成。

在配置 Caliber 集成前，您必须在 Silk Central 应用程序服务器和前端服务器上安装 Caliber 客户端。此外，确保在 Caliber 中启用 MPX 支持。配置与 Caliber 的集成要求定义 Caliber 登录凭据。在 Silk Central 和 Caliber 之间同步需求时，这些凭据用于登录到 Silk Central，从而签出 Silk Central 许可证。许可证会在同步进程完成时立即设为可用。我们建议创建专用 Silk Central 用户进行同步，并且所有 Silk Central 需求集成都应使用此用户。这可确保只有一个 Caliber 许可证用于同步进程。

目前支持与 Silk Central 集成的 Caliber 版本：Caliber 11.4、11.5

注： Caliber 用户定义属性多选用户列表和多选组列表必须映射到 Silk Central 文本属性类型而非列表类型。
  • 启用与 Caliber 的集成
    启用与 Caliber 的集成以同步需求。
  • Caliber 集成的基线支持
    介绍如何为 Caliber 集成选择当前基线或现有用户定义基线。
  • 在 Caliber 中处理测试分配
    介绍 Caliber 如何在 Silk Central 中处理测试分配。
  • 复制 Caliber 集成项目
    管理 Caliber 基线以复制 Caliber 集成项目。
  • 创建 Caliber 集成项目的基线
    管理 Caliber 基线以创建 Caliber 集成 Silk Central 项目的基线。
  • 基于方案和模拟生成测试
    基于 Caliber 对象方案和模拟生成测试。
父主题： 需求管理工具集成


启用与 Caliber 的集成

要启用与 Caliber 的集成：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择您要建立集成的项目。
  3. 在菜单中，单击项目：<项目名称> > 项目设置。
  4. 单击需求管理选项卡。
  5. 单击新建集成。
    注： 您可以通过 Silk Central 创建、编辑和删除需求，而不是仅通过集成工具支持修改。您可以直接通过 Test Manager 的 UI 和/或 Silk Central 的 Web 服务进行修改，只需选中各自的允许创建、编辑和删除需求... 复选框即可。
    将打开新建集成对话框。
  6. 从列表中选择 Caliber，然后单击下一步。 将打开编辑配置对话框。
  7. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  8. 键入安装外部服务器的机器的主机名。
  9. 为需求管理服务器键入有效的用户名和密码凭据。
  10. 单击测试连接以确认您输入的主机和用户凭据是否正确。 如果设置正确，则会显示连接成功消息框。单击确定继续。
    注： 如果您无法建立连接，请咨询您的系统管理员。
  11. 单击确定。
  12. 从项目列表框中，选择要与 Silk Central 项目集成的外部项目。 对所选项目可用的需求类型将自动填充到需求类型字段。对所选项目可用的基线将自动填充到基线字段。
  13. 从应该与 Silk Central 项目集成的外部项目中选择基线。 您的选择将显示在编辑配置对话框上。
  14. 单击确定。
  15. 从应该与 Silk Central 项目集成的外部项目中选择一个或多个需求类型。 使用 Ctrl+单击可选择多个需求类型。
  16. 单击确定以保存您的设置。
父主题： Caliber 集成


Caliber 集成的基线支持

您可为 Caliber 集成选择当前基线或现有用户定义基线。您不能将已修改的基线需求导入 Silk Central 中。如果用于基线的需求版本已更改，则仅可在 Caliber 中更改不具备当前基线的需求。执行手动或计划同步时，只会在 Silk Central 需求中更新此类更改。

您可在将基线导入 Silk Central 之后对其进行更改。您可将已配置的基线更改为其他用户定义基线或当前基线。执行此更改后，基线的下一次手动或计划同步将更新 Silk Central 项目，并可根据需要更新、创建或删除需求。当基线更改时，将显示消息，表明这些更改将在下一次同步之后生效。

父主题： Caliber 集成


在 Caliber 中处理测试分配

已分配的测试在 Caliber 中显示、管理并创建为同步需求的跟踪（“跟踪到”）。

必须为 Caliber 管理员中的 Caliber 项目启用 Silk Central 的外部可跟踪性，并且必须配置正确的 Silk Central 前端服务器。 单击 Caliber 管理员中正确项目的 Silk Central 外部可跟踪性的编辑。

当某个项目与 Silk Central 项目同步时，同步 Silk Central 需求的已分配测试将显示为 Caliber 需求的跟踪（“跟踪到”）。 如果您在 Silk Central 中编辑这些分配，则更改将立即反映在 Caliber 中。

父主题： Caliber 集成


复制 Caliber 集成项目

在复制 Caliber 项目时管理 Silk Central 基线：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击需求管理选项卡。
  3. 验证要保存的基线是否已选定。
    注： 如果基线发生更改，则在复制相关 Silk Central 项目之前，您必须执行同步以使用基线更改来更新项目需求。仅在您选择当前基线以外的基线时才会复制集成配置。如果您选择当前基线，则需要指定是在原始项目中保留集成配置还是将其移至复制的项目中。
  4. 如果未选择要保存的基线，请单击编辑配置。 将显示编辑配置对话框。
  5. 单击项目名称文本框旁边的浏览。 将打开浏览项目对话框。
  6. 选择要保存的基线，然后确认您的选择。
  7. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  8. 单击 复制项目 。
    注： 有关复制项目的完整详细信息，请参阅本帮助中的管理主题。
    将显示复制项目对话框。
  9. 选择要复制到新项目中的项目，然后确认您的选择。
  10. 将要继续使用的基线应用到 Silk Central 项目。
    注： 复制项目后，原始项目和副本是相同的。通过应用相应的基线来定义将继续使用的基线。
父主题： Caliber 集成


创建 Caliber 集成项目的基线

创建 Caliber 集成 Silk Central 项目的基线：

  1. 创建 Silk Central 项目的基线。 在此过程中将显示 Silk Central 消息框，询问您是否要启用新基线的 Caliber 集成。
  2. 单击是。 新基线创建后，将打开基线项目 - 调整项目设置对话框。
  3. 单击编辑以更改需求集成设置。

    将打开编辑配置对话框。

  4. 单击项目名称文本框旁边的浏览。 将打开浏览项目对话框。
  5. 选择用于同步的 Caliber 项目、基线和需求类型。
  6. 单击确定以关闭浏览项目对话框。
  7. 单击确定以关闭编辑配置对话框。
  8. 单击完成以关闭基线项目 - 调整项目设置对话框。
父主题： Caliber 集成


基于方案和模拟生成测试

基于 Caliber 对象方案和模拟生成测试。

要基于 Caliber 对象方案和模拟生成测试，请执行以下操作：

  1. 建立与 Caliber 的集成。 有关其他信息，请参阅启用与 Caliber 的集成。
  2. 选择要从其中生成测试的需求树中的方案或模拟。
  3. 在属性选项卡中，请单击生成测试。 此时将显示生成测试对话框。
  4. 使用 Ctrl+单击或 Shift+单击选择要生成的测试。
  5. 单击全部生成生成所有测试，或单击生成选定项生成选定的测试。 此时将显示测试树。
  6. 选择要在其中添加所生成的测试的文件夹。
    注： 所选目标文件夹中已经存在的测试未被创建，但已更新。文件夹中的测试均未被删除。
  7. 单击确定。
父主题： Caliber 集成
相关任务
在工具之间同步需求
启用与 Caliber 的集成


IBM Rational DOORS 集成

本节介绍如何集成 Silk Central 与 IBM Rational DOORS。Silk Central18.5 为 IBM Rational DOORS 提供了现成支持，无需在您的 DOORS 安装中执行任何自定义。如果您是从 Silk Central 15.5 或更早的版本升级，并且使用的是自定义的 dxl 文件，则需要使用自定义的 dxl 文件，覆盖您的 Silk Central 安装文件夹的 lib\dxl 文件夹内的 dxl 文件。

目前支持与 Silk Central 集成的 IBM Rational DOORS 版本：IBM Rational DOORS 9.5、9.6

  • 启用与 IBM Rational DOORS 的集成
    启用与 IBM Rational DOORS 的集成以同步需求。
父主题： 需求管理工具集成


启用与 IBM Rational DOORS 的集成

要集成Silk Central 和 DOORS，请在 Silk Central 前端服务器上安装 DOORS 客户端。如果您使用多台前端服务器机器，则必须在已经配置为集成 DOORS 的每台前端服务器上安装 DOORS 客户端。

要启用与 DOORS 的集成：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择您要建立集成的项目。
  3. 在菜单中，单击项目：<项目名称> > 项目设置。
  4. 单击需求管理选项卡。
  5. 单击新建集成。
    注： 您可以通过 Silk Central 创建、编辑和删除需求，而不是仅通过集成工具支持修改。您可以直接通过 Test Manager 的 UI 和/或 Silk Central 的 Web 服务进行修改，只需选中各自的允许创建、编辑和删除需求... 复选框即可。
    将打开新建集成对话框。
  6. 从列表中选择 IBM Rational DOORS，然后单击下一步。 将打开编辑配置对话框。
  7. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  8. 在 RM 服务 URL 文本框中，键入 Silk Central DOORS 需求 Web 服务的 URL。 默认值应已指向正确的位置。例如 http://MySCTMHost:19120/services/doorsrequirementsmanagement。
  9. 为需求管理服务器键入有效的用户名和密码凭据。
  10. 默认 DOORS 客户端安装路径显示在 DOORS 安装路径文本框中。如果此路径不正确，请输入前端服务器目录结构中的正确目标路径。
  11. 单击测试连接以确认您输入的主机和用户凭据是否正确。 如果设置正确，则会显示连接成功消息框。单击确定继续。
    注： 如果您无法建立连接，请咨询您的系统管理员。
  12. 单击项目名称文本框旁边的浏览，以打开浏览需求类型对话框。从项目文本框中，选择要与 Silk Central 项目同步的外部项目。

    对所选项目可用的需求类型将自动填充到需求类型字段。选择要同步的需求类型，然后单击确定。使用 Ctrl+单击可选择多个需求类型。

    您的选择此时显示在编辑配置对话框上。
  13. 单击确定以保存您的设置。
    警告：
    如果将 DOORS 应用程序对象用于通信，并且此对象不支持登录数据而是需要正在运行的 DOORS 客户端，则 Silk Central 将使用提供的登录数据开始每个 DOORS 客户端进程，然后将相同数据用于随后的所有应用程序对象。因此，一次只能将一组 DOORS 登录凭据用于通信。建议您将相同 DOORS 凭据用于所有配置，以便在前端服务器上同时为所有项目执行集成任务。使用第二组凭据时，这些凭据仅在使用第一组凭据的所有会话超时之后才能生效。
父主题： IBM Rational DOORS 集成


IBM Rational DOORS Next Generation 集成

本节介绍如何集成 Silk Central 与 IBM Rational DOORS Next Generation。Silk Central 18.5 为 IBM Rational DOORS Next Generation 提供了现成支持，无需在您的 DOORS 安装中执行任何自定义。
注： 项目的所有工件都会同步，除了 DOORS 集合工件模块和集合自身。

目前支持与 Silk Central 集成的 IBM Rational DOORS Next Generation 版本：IBM Rational DOORS Next Generation 6.0

  • 启用与 IBM Rational DOORS Next Generation 的集成
    启用与 IBM Rational DOORS Next Generation 的集成以同步需求。
父主题： 需求管理工具集成


启用与 IBM Rational DOORS Next Generation 的集成

要启用与 IBM Rational DOORS Next Generation 的集成：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择您要建立集成的项目。
  3. 在菜单中，单击项目：<项目名称> > 项目设置。
  4. 单击需求管理选项卡。
  5. 单击新建集成。
    注： 您可以通过 Silk Central 创建、编辑和删除需求，而不是仅通过集成工具支持修改。您可以直接通过 Test Manager 的 UI 和/或 Silk Central 的 Web 服务进行修改，只需选中各自的允许创建、编辑和删除需求... 复选框即可。
    将打开新建集成对话框。
  6. 从列表中选择 IBM Rational DOORS Next Generation，然后单击下一步。 将打开编辑配置对话框。
  7. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  8. 在 DOORS 下一代 URL 字段中，键入 IBM Rational DOORS Next Generation 服务器的完全限定的 URL，例如 https://MyDOORSHost.MyDomain.com:9443/rm。
  9. 在身份验证 URL 字段中，键入 IBM Rational Jazz Team Server 的完全限定的 URL，例如 https://MyDOORSHost.MyDomain.com:9443/jts。
    注： 身份验证不支持新的 IBM Rational Authentication Server，仅支持 IBM Rational Jazz Team Server。
  10. 为 IBM Rational DOORS Next Generation 服务器键入有效的用户名和密码凭据。
  11. 单击测试连接以确认您输入的主机和用户凭据是否正确。 如果设置正确，则会显示连接成功消息框。单击确定继续。
    注： 如果您无法建立连接，请咨询您的系统管理员。
  12. 单击项目名称列表旁边的加载，用可用的 DOORS 项目填充该列表。请选择 Silk Central 项目与其同步的外部项目。
  13. 单击确定以保存您的设置。
父主题： IBM Rational DOORS Next Generation 集成


IBM Rational RequisitePro 集成

本节的主题介绍 IBM Rational RequisitePro 和 Silk Central 之间的集成。

在配置 IBM Rational RequisitePro 集成前，您必须在 Silk Central 前端服务器上安装 IBM Rational RequisitePro 客户端。

目前支持与 Silk Central 集成的 IBM Rational RequisitePro 版本：IBM Rational RequisitePro 7.1.3、7.1.4

  • 启用与 IBM Rational RequisitePro 的集成
    启用与 IBM Rational RequisitePro 的集成以同步需求。
父主题： 需求管理工具集成


启用与 IBM Rational RequisitePro 的集成

注： 您可以仅为每个项目配置一个 IBM Rational RequisitePro 集成。

要启用与 IBM Rational RequisitePro 的集成：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择您要建立集成的项目。
  3. 在菜单中，单击项目：<项目名称> > 项目设置。
  4. 单击需求管理选项卡。
  5. 单击新建集成。
    注： 您可以通过 Silk Central 创建、编辑和删除需求，而不是仅通过集成工具支持修改。您可以直接通过 Test Manager 的 UI 和/或 Silk Central 的 Web 服务进行修改，只需选中各自的允许创建、编辑和删除需求... 复选框即可。
    将打开新建集成对话框。
  6. 从列表中选择 IBM Rational RequisitePro，然后单击下一步。 将打开编辑配置对话框。
  7. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  8. 键入安装外部服务器的机器的项目路径 (UNC)。
  9. 键入安装外部服务器的机器的有效 UNC 用户名和 UNC 密码凭据。
  10. 为需求管理服务器键入有效的用户名和密码凭据。
  11. 单击测试连接以确认您输入的主机和用户凭据是否正确。 如果设置正确，则会显示连接成功消息框。单击确定继续。
    注： 如果您无法建立连接，请咨询您的系统管理员。
  12. 单击编辑程序包和需求类型。

    您的选择随后将显示在编辑配置对话框上。

    注： 仅同步明确选定的程序包的需求。选择父程序包不会选择它的子程序包。
    此时将打开浏览程序包和需求类型对话框。对所选项目可用的程序包和需求类型将自动填充到程序包和需求类型列表框。
  13. 在程序包列表中，从应该与 Silk Central 项目集成的外部项目中选择一个或多个程序包。 使用 Ctrl+单击可选择多个程序包。
  14. 在需求类型列表中，从应该与 Silk Central 项目集成的外部项目中选择一个或多个需求类型。 使用 Ctrl+单击可选择多个需求类型。
  15. 单击确定。 此时将关闭浏览程序包和需求类型对话框。
  16. 单击确定以保存您的设置。
父主题： IBM Rational RequisitePro 集成


SAP Solution Manager 集成

要购买 SAP Solution Manager 插件，请与您的销售代表联系。

SAP Solution Manager 可促进对分布式系统的技术支持，包含解决方案部署、操作和持续改进。SAP Solution Manager 是健全集中的应用程序管理解决方案，将工具、内容和对 SAP 的直接访问权限相结合，以提高解决方案的可靠性，同时降低总拥有成本。有关 SAP Solution Manager 的其他信息，请参阅 SAP Solution Manager 文档。

Silk Central 和 SAP Solution Manager 之间的集成允许将 SAP Solution Manager 业务流程和事件同步为 Silk Central 需求和问题。

  • SAP Solution Manager 集成的系统需求
    介绍 SAP Solution Manager 集成插件的系统需求。
  • 配置 SAP Solution Manager
    介绍您可从何处获取信息来配置 SAP Solution Manager 以与 Silk Central 集成。
  • 添加 SAP Solution Manager 问题跟踪配置文件
    介绍如何为 SAP Solution Manager 创建问题跟踪配置文件。
  • 启用与 SAP Solution Manager 的需求集成
    介绍如何启用与 SAP Solution Manager 的需求集成。
父主题： 需求管理工具集成
父主题： 问题跟踪配置文件集成


SAP Solution Manager 集成的系统需求

以下是 SAP Solution Manager 集成插件的系统需求：

  • Silk Central 12.1 或更高版本
  • SAP Solution Manager 7.1
  • Silk Central Integration Hub for SAP Solution Manager 必须安装在 SAP Solution Manager 上。
父主题： SAP Solution Manager 集成


配置 SAP Solution Manager

配置 SAP Solution Manager 以启用与 Silk Central 的集成。

有关更多信息，请参阅 SAP Solution Manager 插件中包括的 Configuration_Guide_SilkCentral_Integration_Hub_for_SAP.pdf 和 User_Guide_SilkCentral_Integration_Hub_for_SAP.pdf。

为了让此集成获取从 SAP Solution Manager 到 Silk Central 的有效链接，Silk Central 的前端服务器计算机必须具有一个有效的完全限定名称。

父主题： SAP Solution Manager 集成


添加 SAP Solution Manager 问题跟踪配置文件

添加 SAP Solution Manager 问题跟踪配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击问题跟踪选项卡。 此时将打开问题跟踪页面，列出已为系统创建的所有问题跟踪配置文件。
  3. 单击新建配置文件以打开新建问题跟踪配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 为新配置文件键入说明。
  6. 从类型列表框中选择 SAP Solution Manager。
  7. 键入有效的用户名和密码。 这些凭据将用于访问问题跟踪系统。
  8. 键入 SAP Solution Manager 的 Z-SCTM_ADAPTER Web 服务 URL。
  9. 单击加载项目以从服务器加载所有项目，填充项目列表框，然后从项目列表框中选择项目。
  10. 单击加载默认事件类型以加载所有可能的事件类型并填充默认事件类型列表框。
  11. 从默认事件类型列表框中选择事件类型。 如果要在 SAP Solution Manager 中创建现有事件的链接并且未指定事件类型，则将使用此类型。
  12. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  13. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： SAP Solution Manager 集成


启用与 SAP Solution Manager 的需求集成

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择您要建立集成的项目。
  3. 在菜单中，单击项目：<项目名称> > 项目设置。
  4. 单击需求管理选项卡。
  5. 在 SAP Solution Manager 部分，单击配置。
  6. 输入 SAP Solution Manager 的 Z_SCTM_ADAPTER Web 服务的 URL。
  7. 输入用户名和密码。
  8. 单击测试连接以确认您输入的主机和用户凭据准确无误。 如果设置正确，则会显示已成功测试连接消息。
  9. 单击加载以加载所有可用项目并选择正确的项目。
  10. 可选：选中启用创建未分配的需求复选框以在为集成而配置的 Silk Central 项目中启用创建和编辑未映射的需求。
  11. 单击确定以进行确认并关闭对话框。
父主题： SAP Solution Manager 集成


使用外部属性

本部分说明如何在 Silk Central 中使用外部属性。

  • 编辑外部属性
    编辑外部属性。
  • 查看外部属性
    查看外部属性。
父主题： 需求管理工具集成


编辑外部属性

要编辑外部属性：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择要为其编辑外部属性的需求。
  3. 单击属性选项卡。 属性页面将显示选定树元素的属性。
  4. 单击编辑外部属性。 此时将显示编辑外部属性对话框。 此处将显示外部需求的所有属性。 根据需要编辑所有属性。
    注： 此对话框上可编辑的属性为您提供了用于编辑属性的输入字段和控件。 如果属性存在映射规则，则该属性尾部将标记有星号 (*)。
  5. 单击确定以保存您所做的更改并关闭对话框。
父主题： 使用外部属性


查看外部属性

查看外部属性：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求。
  3. 单击属性选项卡。 属性页面将显示选定树元素的属性。
  4. 单击查看外部属性。 此时将显示查看外部属性对话框。 此处显示外部需求的所有属性。
  5. 关闭对话框。
父主题： 使用外部属性


编辑属性映射

属性映射功能允许您映射 Silk Central 与外部需求管理工具之间的属性字段。例如，Silk Central 中名为 User 的自定义需求属性等效于 Caliber 中名为 User_ID 的自定义属性。属性映射功能可确保在上载和导入需求的过程中，在项目之间正确填充需求属性字段。如果有多个需求类型，则您必须单独映射每个类型。

注： 如果您未使用属性映射功能，则仅映射需求的名称和说明。

要编辑属性映射：

注： 以下项适用于采用布尔值同步的属性：由于 Silk Central 不支持布尔值数据类型，因此您需要使用以下两个列表项创建一个选择列表：
  • 名称 = 是，数值权重 = 1
  • 名称 = 否，数值权重 = 0
注： 当您映射列表时，对于每个列表项，两个产品的需求属性需要具有相同名称的选项，并且它们区分大小写。
  1. 选择项目。
  2. 在菜单中，单击项目：<项目名称> > 项目设置。
  3. 单击需求管理选项卡。
  4. 单击编辑属性映射以获得配置的外部工具。 此时将打开编辑属性映射对话框。
  5. 从需求类型列表中选择外部需求类型。该类型的所有自定义需求随后都会显示在选择框的下方。
  6. 选择要为其建立映射的自定义需求属性。
  7. 从右侧的列表框中，选择 Silk Central 自定义属性以建立与所选的外部自定义属性的映射。
  8. 单击添加映射以映射需求。 结果将显示在自定义属性映射框中。
  9. 系统属性映射框将显示两个预先配置的需求名称和说明映射，您不能删除这两个映射。
  10. 单击确定以保存您所做的更改。
父主题： 需求管理工具集成


删除属性-映射值对

要删除属性-映射值对：

  1. 选择项目。
  2. 在菜单中，单击项目：<项目名称> > 项目设置。
  3. 单击需求管理选项卡。
  4. 单击编辑属性映射以获得配置的外部工具。 此时将打开编辑属性映射对话框。
  5. 在自定义属性映射选择框中选择属性-映射值对。
  6. 单击删除映射。
  7. 单击确定以保存您所做的更改。
父主题： 需求管理工具集成


禁用需求管理集成

要禁用需求管理集成配置：

  1. 选择项目。
  2. 在菜单中，单击项目：<项目名称> > 项目设置。
  3. 单击需求管理选项卡。
  4. 单击要为其禁用集成的需求管理工具的禁用配置按钮。
所有集成数据和功能都将禁用，但不会从项目中删除。
父主题： 需求管理工具集成


删除需求管理集成

删除需求管理集成：

  1. 选择项目。
  2. 在菜单中，单击项目：<项目名称> > 项目设置。
  3. 单击需求管理选项卡。
  4. 单击您要删除集成的需求管理工具的删除配置。 此按钮仅在禁用配置时才启用。 此时将显示删除外部关联对话框。
  5. 单击是。
将从数据库中删除所有相关数据。
父主题： 需求管理工具集成


筛选器

筛选器可提供有效方式来查找需要的准确信息，同时排除无关的细节。筛选器将仅突出显示与需要相关的元素，可使您快速整理需求、测试元素和执行计划。通过定义全局筛选器，您可定义在整个 Silk Central 中可用的复杂筛选器条件，而无需在每次需要筛选列表时定义筛选器条件。

您可根据需要在项目级别创建新的筛选器、编辑现有筛选器、选择筛选器、删除筛选器或关闭筛选。项目不包含默认筛选器。您可从 Silk Central 单元的工具栏和从项目设置单元访问和编辑筛选器。

注： 筛选器不应用于报告。最新更改筛选器使您可查看自上次更改确认后其他用户对测试所做的项目级更改和添加操作。测试区域的显示更改/全部显示开关按钮和确认按钮可帮助您找出其他用户所做的更改。系统管理员可以配置电子邮件通知，提醒您对测试设置做出的更改。电子邮件提醒包括使您直接转到最新更改视图的链接。
  • 创建筛选器
    创建筛选器以限制显示的信息。
  • 创建高级筛选器
    介绍如何创建高级自定义筛选器。
  • 编辑筛选器
    编辑筛选器以限制所显示的信息。
  • 复制筛选器
    复制筛选器以对其进行编辑并从副本创建新筛选器。
  • 删除筛选器
    如果不再需要信息子集，则可删除筛选器。
  • 全局筛选器详细信息
    提供全局筛选器的详细信息。
  • 最新更改
    可使您自上次更改确认后有效查看和确认其他用户对项目范围内的需求、测试或执行计划做出的更改和添加。
  • 应用筛选器
    将自定义筛选器应用到所选树。
父主题： 配置需求设置和集成
父主题： 配置测试设置和集成
父主题： 管理执行计划、文件夹和配置套件
父主题： 项目设置


创建筛选器

要创建筛选器，请执行以下操作：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击筛选器选项卡以查看可用筛选器列表。
  3. 单击新建筛选器。 将显示新建筛选器对话框。
  4. 键入新筛选器的名称。 当筛选器可用时，此名称将显示在列表框中。
  5. 从列表中选择类别，以使筛选器在 Silk Central 的需求、测试或执行计划区域中可用。
  6. 可选：键入新筛选器的说明。
  7. 可选：选中对其他用户可见复选框，以允许其他用户看见筛选器。
  8. 可选：选中其他用户可编辑复选框，以允许其他用户编辑筛选器。
    注： 如果选中对其他用户可见和其他用户可编辑，则筛选器为公用筛选器。要删除非公用（专用）筛选器，您必须是筛选器的所有者或者需要删除其他用户的专用筛选器权限。
  9. 从选择条件列表中选择筛选条件的类别。可用类别取决于您选择的常规筛选器类别。
    注： 您可以选择嵌套测试筛选器或嵌套需求筛选器来合并筛选器。选择其中一个类别可使您将现有筛选器包括在新筛选器中。
  10. 从各自的列表中选择筛选器的属性、运算符和值。
    属性
    可用属性取决于您在上一步中选择的筛选器类别。定义您要为之定义筛选器设置的属性。如果您选择了属性类别，则属性列表包括对其查询的自定义属性。
    运算符
    指定筛选器运算符。运算符取决于您选择的属性类型。例如，如果您选择了基于字符串字段类型的属性，则以下运算符可用：
    运算符 | 说明
    = 字符串等于定义值。
    不 | 字符串与定义值不同。
    包含 | 字符串包含定义值。
    不包含 | 字符串不包含定义值。
    值
    输入您要筛选掉的值。根据您选择的属性类型，值将为您在字段中输入的字符串，或您从列表框中选择的一系列预定义值。字符串允许使用的通配符包括 *（任意数量的字符）和 ?（仅一个字符）。
  11. 可选：如果要将多个筛选器类别添加到新筛选器，请单击更多。重复此步骤以定义新类别。
    注： 如果定义多个筛选器类别，您必须定义除了现有类别（AND 关系）之外是否需要满足其他类别，或者筛选器是否会在满足筛选器类别之一（OR 关系）时返回 true。选择 AND 或者 OR 以定义筛选器类别关系。您可定义嵌套式 AND、OR 关系。
  12. 可选：要删除筛选器类别，请单击更少。这将删除最后的筛选器类别。
  13. 单击确定以保存新筛选器，或单击取消以中止操作。
父主题： 筛选器


创建高级筛选器

您可使用高级自定义筛选器合并简单筛选器，以创建同时应用多个筛选器条件的复杂筛选器。

创建高级自定义筛选器：

  1. 在菜单中，选择相应的区域：需求、测试或执行计划。
  2. 单击工具栏中的 [image] （新建筛选器）。 将显示新建筛选器对话框。
  3. 如有必要，请单击高级以显示整个对话框。
  4. 单击更多，以显示第二组筛选器参数字段，可用于定义第二组筛选器参数。
  5. 为筛选查询的应用程序选择逻辑运算符。 例如，如果使用运算符 and，则已筛选元素必须同时满足两组条件，如果使用运算符 or，则已筛选元素必须满足一组而非两组条件。
  6. 要删除筛选器参数字符串，请单击 删除 。
  7. 要显示其他筛选器参数字段和创建其他筛选器查询，请单击更多。 要删除过多的筛选器参数集，请单击更少。
父主题： 筛选器


编辑筛选器

要编辑筛选器：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击筛选器选项卡以查看可用筛选器列表。
  3. 单击要编辑的筛选器的名称。 此时将显示编辑筛选器对话框。
  4. 编辑筛选器的名称和说明。
  5. 从选择条件列表中选择筛选条件的类别。可用类别取决于您选择的常规筛选器类别。
    注： 您可以选择嵌套测试筛选器或嵌套需求筛选器来合并筛选器。选择其中一个类别可使您将现有筛选器包括在新筛选器中。
  6. 从各自的列表中选择筛选器的属性、运算符和值。
    属性
    可用属性取决于您在上一步中选择的筛选器类别。定义您要为之定义筛选器设置的属性。如果您选择了属性类别，则属性列表包括对其查询的自定义属性。
    运算符
    指定筛选器运算符。运算符取决于您选择的属性类型。例如，如果您选择了基于字符串字段类型的属性，则以下运算符可用：
    运算符 | 说明
    = 字符串等于定义值。
    不 | 字符串与定义值不同。
    包含 | 字符串包含定义值。
    不包含 | 字符串不包含定义值。
    值
    输入您要筛选掉的值。根据您选择的属性类型，值将为您在字段中输入的字符串，或您从列表框中选择的一系列预定义值。字符串允许使用的通配符包括 *（任意数量的字符）和 ?（仅一个字符）。
  7. 单击确定以保存编辑过的筛选器定义。
父主题： 筛选器


复制筛选器

通过复制现有筛选器和更改设置来创建新筛选器。

  1. 在菜单中，选择相应的区域：需求、测试或执行计划。
  2. 在所选区域的工具栏中，从列表框中选择筛选器。
  3. 单击 复制筛选器 。 将打开编辑筛选器对话框以及原始筛选器的设置。
  4. 编辑筛选器的属性，然后单击确定。
父主题： 筛选器


删除筛选器

要删除筛选器：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击筛选器选项卡以查看可用筛选器列表。
  3. 单击要删除的筛选器的删除筛选器。 此时将显示确认对话框，要求您确认删除。
  4. 单击是以删除选定的筛选器或单击否以中止操作。 如果您单击是，您将返回筛选器列表，已删除的筛选器将不再显示。
父主题： 筛选器


全局筛选器详细信息

全局筛选器使您可快速处理 Silk Central 区域中的元素，仅突出显示与您的需要相关的元素。

要查看全局筛选器的详细信息，单击菜单中的项目：<项目名称> > 项目设置 > 筛选器，然后单击筛选器的名称。

通过选择常规筛选器类别可定义其中提供新筛选器的特定 Silk Central 区域。

每个全局筛选器必须具有来自相应列表框的属性、运算符和值：

属性
提供的属性取决于筛选器的类别。它可定义将为其定义筛选器设置的属性。如果选择属性类别，则属性列表将包括要查询的自定义属性。
运算符
指定筛选器运算符。运算符取决于属性类型。例如，如果选择基于字符串字段类型的属性，则提供的运算符为 =（等于定义值）、not（不同于定义值）、包含（字符串中包含定义值）和不包含（字符串中不包含定义值）。
值
要筛选的值。根据您选择的属性类型，值将为您在字段中输入的字符串，或您从列表框中选择的一系列预定义值。
父主题： 筛选器


最新更改

最新更改筛选器可使您自上次更改确认后有效查看和确认其他用户对项目范围内的需求、测试或执行计划做出的更改和添加。

工具栏最右边的两个按钮（即显示更改/全部显示切换按钮和确认按钮）可帮助您查找其他用户做出的更改。

注： 系统管理员可以配置电子邮件通知，提醒您对测试设置做出的更改。 电子邮件提醒包括使您直接转到最新更改视图的链接。
父主题： 筛选器


应用筛选器

创建并存储自定义筛选器之后，您可将该筛选器应用到所选树。 自定义筛选器可应用于需求、测试和执行计划。 只有符合已应用筛选器条件的元素才会显示在树中。

注： 已筛选需求以只读形式返回，并且无法进行编辑。 已筛选需求的编辑属性按钮将禁用。

应用存储的筛选器：

  1. 在菜单中，选择相应的区域：需求、测试或执行计划。
  2. 从工具栏上的筛选器列表框中选择所需筛选器。
  3. 将显示符合筛选器条件的所有元素。
    注： 要删除筛选和显示所有元素，请从工具栏上的筛选器列表框中选择 <无筛选器>。
父主题： 筛选器


更改通知

当其他用户更改需求或测试时，Silk Central 可通过电子邮件通知您。每个用户都可以选择激活更改通知。启用通知后，请执行初始确认。此后，您可查看和确认自上次确认起发生的更改。为了避免大量通知，无论其他用户在您上次确认后执行了多少次更改，您只会在发生更改时收到一封电子邮件提醒。电子邮件提醒包括使您直接转到最新更改视图的链接。

激活需求或测试的更改通知之前，您必须在 Silk Central 的用户设置中配置您的电子邮件地址。

注： 更改通知只有在管理员已配置电子邮件服务器的情况下才能正常使用。如果更改通知尚未启用，请联系您的 Silk Central 管理员。
  • 启用更改通知
    启用更改通知以在其他用户更改需求或测试时接收电子邮件通知。
  • 禁用更改通知
    禁用更改通知以在其他用户更改需求或测试时不再接收电子邮件通知。
  • 更改触发更改通知
    列出引起更改通知的更改。
  • 通知页面
    列出活动项目的通知事件。
父主题： 配置需求设置和集成
父主题： 配置测试设置和集成
父主题： 项目设置


启用更改通知

要启用更改通知：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击通知选项卡。
  3. 单击配置电子邮件通知以打开配置电子邮件通知对话框：
  4. 如果您希望在对当前所选项目中的需求进行更改时接收通知，请选中需求更改复选框。
  5. 如果您希望在对当前所选项目中的测试进行更改时接收通知，请选中测试更改复选框。
  6. 单击确定以保存通知设置，或单击取消以中止操作而不保存更改。
您将通过电子邮件接收有关为其激活通知的更改。
父主题： 更改通知


禁用更改通知

要禁用更改通知：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击通知选项卡。
  3. 单击配置电子邮件通知以打开配置电子邮件通知对话框。
  4. 如果您不希望在对当前所选项目中的需求进行更改时接收通知，请取消选中需求更改复选框。
  5. 如果您不希望在对当前所选项目中的测试进行更改时接收通知，请取消选中测试更改复选框。
  6. 单击确定以保存通知设置，或单击取消以中止操作而不保存更改。
父主题： 更改通知


更改触发更改通知

如果已激活更改通知以通知您对需求或测试所做的更改，您将在注销后收到电子邮件提醒。如果以下一种或多种设置发生更改，您将收到电子邮件提醒：
区域 变更
需求
  • 已创建或删除需求。
  • 已编辑需求的名称或说明。
  • 已编辑系统属性。
  • 已将需求设置为过时。
  • 已恢复需求。
  • 已将测试分配到需求或从需求中删除测试。
  • 已创建、编辑或删除需求的自定义属性。
测试
  • 已创建或编辑容器。
  • 已编辑产品。
  • 已编辑源代码管理配置文件。
  • 已编辑“清理工作文件夹”。
  • 已编辑根节点。
  • 已编辑自定义数据目录。
  • 已编辑包括目录。
  • 已编辑隐藏测试属性。
  • 已编辑 Silk Test Classic 界面。
  • 已创建、编辑或删除测试文件夹。
  • 已创建、编辑或删除测试。
  • 已编辑计划时间。
  • 已添加或编辑测试步骤。
父主题： 更改通知


通知页面

项目：<项目名称> > 项目设置 > 通知

通知页面将列出活动项目的通知事件。对于每个通知事件，通知页面将显示以下列：

列 | 说明
通知事件 | 为活动项目设置的通知事件的名称。
状态 | 通知事件的状态。活动或非活动。

单击每部分的配置...按钮以编辑值。

电子邮件

当激活电子邮件通知事件时，首次更改其中一个特定设置时，通知电子邮件将发送给激活该事件的用户。

注： 您必须指定电子邮件地址才能接收电子邮件通知。

需求标记

您可以按不同方式为内部需求和外部需求配置通知。默认情况下，将启用所有需求标记。有关更多信息，请参阅标记主题。

父主题： 更改通知


管理需求

添加或编辑需求，就技术和非技术需求在客户与开发人员之间创建并维护协议。
  • 创建需求
    介绍如何在 Silk Central 中直接创建需求以及子需求如何从其父需求继承属性。
  • 编辑需求
    介绍如何编辑需求的属性。
  • 将需求标记为过时
    如果当前不需要需求并且不希望删除它，则可以将该需求标记为过时。
  • 恢复过时的需求
    将过时的需求转换为活动状态以便再次使用。
  • 永久删除过时的需求
    如果您不打算重新激活过时的需求，则可以永久删除它。
  • 需求报告
    需求报告详述了功能需求的状态，例如兼容性需求、GUI 需求或特性需求，必须在开发期间满足这些需求。
  • 覆盖率
    介绍如何使用测试覆盖需求。
  • 标记
    介绍如何使用标记。
父主题： 需求


创建需求

要创建新需求，请执行以下操作：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 在需求树中，选择需求或根节点。
  3. 单击工具栏中的 [image] （新建需求）在同一层上创建新需求，或单击 [image] （新建子需求）在所选需求下方创建需求。 将显示新建需求对话框。
  4. 键入需求的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 可选： 取消选中从父级继承复选框。在此情况下，子需求将不会从父需求继承属性。默认情况下，所有复选框均处于选中状态。
    注： 在属性页面上的详细信息视图中和文档视图中，继承的属性用星号 (*) 标记。
  6. 从列表中选择适当的优先级、风险和已审阅状态。
  7. 如果已定义自定义需求，这些需求将列于已审阅列表下。在相应字段中，键入要使用此需求进行跟踪的任何自定义属性数据。可以为继承属性禁用此项。有关创建、编辑和删除自定义需求属性的详细信息，请参阅自定义需求属性。
  8. 完成新需求的创建：
    • 单击确定以创建需求并关闭对话框。
    • 单击确定和新建需求以创建需求并保持对话框打开以输入其他需求的数据。
    • 单击确定和新建子需求以创建需求并保持对话框打开以输入子需求的数据。
父主题： 管理需求
相关概念
自定义需求属性


编辑需求

要编辑需求的属性：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 在需求树中，选择需求。
  3. 单击工具栏中的 [image] （编辑）。 您还可以右键单击需求并单击编辑，或单击属性选项卡并单击编辑属性。 此时将显示编辑需求对话框。
  4. 键入需求的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 可选： 取消选中从父级继承复选框。在此情况下，子需求将不会从父需求继承属性。默认情况下，所有复选框均处于选中状态。
    注： 在属性页面上的详细信息视图中和文档视图中，继承的属性用星号 (*) 标记。
  6. 从列表中选择适当的优先级、风险和已审阅状态。
  7. 如果已定义自定义需求，这些需求将列于已审阅列表下。在相应字段中，键入要使用此需求进行跟踪的任何自定义属性数据。可以为继承属性禁用此项。有关创建、编辑和删除自定义需求属性的详细信息，请参阅自定义需求属性。
  8. 单击确定以保存您所做的更改。
父主题： 管理需求
相关概念
自定义需求属性


将需求标记为过时

删除需求将会永久销毁它们。有时最好将需求标记为过时。可隐藏、显示和恢复过时的需求。

要将需求标记为过时：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 在需求树中，选择需求。
  3. 单击工具栏中的 删除 （删除），或右键单击需求并单击删除。 此时将显示对话框。
  4. 单击是。
    注： 默认未选中永久销毁复选框。
注： 过时的需求将以斜体显示在需求树中。

要显示过时的需求，请在需求树中右键单击任意需求，然后单击显示过时的需求。

要隐藏过时的需求，请在需求树中右键单击任意需求，然后单击隐藏过时的需求。

父主题： 管理需求


恢复过时的需求

恢复过时的需求：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 如果过时的需求被隐藏，请右键单击需求树中的任意需求，然后单击显示过时的需求。
  3. 右键单击需求树中过时的需求，然后单击恢复。
注： 过时的需求将以斜体显示在需求树中。

要再次隐藏过时的需求，请右键单击需求树中的任意需求，然后单击隐藏过时的需求。

父主题： 管理需求


永久删除过时的需求

要永久删除过时的需求：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 如果过时的需求被隐藏，请右键单击需求树中的任意需求，然后单击显示过时的需求。
  3. 在需求树中，选择过时的需求。
  4. 单击工具栏中的 删除 （删除），或右键单击需求并单击删除。 此时将显示对话框。
  5. 单击是以永久删除需求。
注： 过时的需求将以斜体显示在需求树中。

要再次隐藏过时的需求，请右键单击需求树中的任意需求，然后单击隐藏过时的需求。

父主题： 管理需求


需求报告

需求报告详述了功能需求的状态，例如兼容性需求、GUI 需求或特性需求，必须在开发期间满足这些需求。

需求还可能与产品管理目标相关，例如可靠性、可扩展性和性能。需求管理报告可帮助管理人员确定是否建立了足够的测试覆盖率来验证开发期间是否满足系统需求。当报告引用包含 HTML 格式内容的需求时，此内容将在报告中呈现。

  • 状态报告
    介绍可用于需求区域的状态报告。
  • 进度报告
    介绍可用于需求区域的进度报告。
  • 文档报告
    介绍对需求可用的文档报告。
  • 所有相关问题报告
    提供与需求的已分配测试相关的所有问题详细列表。
父主题： 管理需求
父主题： 默认报告


状态报告

以下状态报告可用于需求区域：
需求状态概述
按当前需求覆盖率表示所有需求的分组摘要。覆盖率由通过、失败、未执行和未覆盖状态表示。
顶层需求覆盖率
表示所有顶层需求的列表。对于每个需求，将显示测试已覆盖和未覆盖的子需求数。
优先级高于“X”的需求状态
按当前需求覆盖率显示所有需求的摘要。返回的需求组受 Priority 参数的限制，其中指定了在数据中考虑的最低需求优先级。
需求影响分析报告
显示按与需求关联的执行计划分组的测试详细信息。此报告允许用户深入洞悉可能受需求更改影响的测试资产。报告包含上次执行的名称、状态和日期/时间、手动测试人员、计划时间和每个测试问题。将使用以下状态：
通过
测试通过。
失败
测试失败。
不适用
测试与需求关联，但不提交测试供执行。
未执行
测试与需求关联并已提交供执行，但尚未执行。
项目需求可跟踪性报告
显示项目中的所有需求及其关联的测试和问题。将使用以下状态：
通过
测试通过。
失败
测试失败。
不适用
测试与需求关联，但不提交测试供执行。
未执行
测试与需求关联并已提交供执行，但尚未执行。
父主题： 需求报告


进度报告

以下进度报告可用于需求区域：
跨内部版本“X”和“Y”的需求覆盖率
按当前需求覆盖率显示所有需求的摘要。返回的需求组受 Priority 参数的限制，其中指定了在数据中考虑的最低需求优先级。
过去“X”天的需求覆盖率
表示通过考虑过去“X”天的总体需求覆盖率的需求覆盖率趋势。
过去“X”天的特定需求覆盖率
表示通过考虑过去“X”天的特定需求覆盖率的需求覆盖率趋势。
父主题： 需求报告


文档报告

以下文档报告对需求可用：
所有需求
所有需求都以完整的需求信息表示。
具有子需求的需求
所选需求将与其需求 ID 一起显示。将显示有关需求的子需求的详细信息。
父主题： 需求报告


所有相关问题报告

所有相关问题报告提供与需求的已分配测试相关的所有问题详细列表，并介绍需求之间的关系、已分配的测试以及发生过的问题。所有相关问题报告的输入参数是需求的标识符。

父主题： 需求报告


覆盖率

本节介绍如何使用测试覆盖需求。

  • 覆盖率模式
    介绍可用于需求的覆盖率模式。
  • 在覆盖模式之间切换
    在完整覆盖模式和直接覆盖模式之间切换，以便分别包含或排除测试覆盖率计算中的子需求。
  • 覆盖率页面
    显示已分配到需求的所有测试的状态。
父主题： 管理需求


覆盖率模式

Silk Central 提供了两种覆盖率模式。 完整覆盖率和直接覆盖率。 完整覆盖率模式中的需求状态将参考子需求的状态并提供覆盖需求的测试的累计视图。 如果一个或多个子需求的状态是未覆盖，则所选需求的完整覆盖率状态也是未覆盖，即使需求的覆盖率状态为已覆盖也是如此。 完整覆盖率模式可轻松评估需求是否由测试覆盖。

直接覆盖率模式中的需求状态仅根据直接分配到需求的测试的状态进行计算。 计算中不考虑子需求。

父主题： 覆盖率


在覆盖模式之间切换

在完整覆盖模式和直接覆盖模式之间切换：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 单击 显示直接覆盖 / 显示完整覆盖 以分别查看直接覆盖或完整覆盖。
父主题： 覆盖率


覆盖率页面

需求 > 详细信息视图 > 覆盖率

覆盖率页面（仅可在详细信息视图中访问）显示所选需求或项目的基本属性。同时还显示已分配到需求的所有测试的状态，包括通过、失败、未执行和未覆盖测试的数量和百分比。所有已分配测试的摘要列在总计下方。测试未覆盖的需求列为未覆盖。

详细信息视图页面在“热字段”图表中显示相同覆盖率状态信息。

要查看分配到所选需求的子需求以及直接分配到需求的所有测试的状态，请选中完整覆盖复选框。

注： 在详细信息视图和覆盖率页面中，测试总计会累积到父级。例如，需求总计包括来自子需求的测试，而项目总计包括来自所有需求的测试。

覆盖率页面显示每个所选需求或项目的以下属性：

属性 | 说明

需求名称

项目名称

 所选需求或项目的名称。
优先级 | 已分配到所选需求的优先级。
风险 | 已分配到所选需求的风险。
# 个需求（计算） | 所有已覆盖需求的总数。此数量不包括没有分配测试的未覆盖需求和文件夹。例如，继承其子需求的覆盖率但实际上本身并非需求的文件夹。
# 个需求（总计） | 所选实体下的所有需求的总数，包括文件夹。

需求状态

项目状态

 所选需求或项目的状态。
  • 通过
  • 失败
  • 未执行
  • 未覆盖
# 个需求已通过 | 项目中具有已通过测试的需求的总数和百分比。
# 个需求失败 | 项目中具有失败测试的需求的总数和百分比。
# 个需求未执行 | 项目中具有未执行测试的需求的总数和百分比。
# 个需求未覆盖 | 项目中测试未覆盖的需求的总数和百分比。
总计 | 项目中的需求总数。
父主题： 覆盖率
相关参考
需求文档视图


标记

标记表明需求已更改或需要审阅。 带标记的需求出现在带有标记图标的需求树中。 需求属性中也有一个部分可查看标记信息。

您可根据需要添加和删除标记，其他人在查看需求时可看到此标记。 您还可标记需求及其所有子需求。 每次只能在一个项目上设置一个标记，在已具有标记的项目上设置标记将会覆盖此标记。 对需求标记的更改保留在需求更改历史记录中。

如果与外部需求管理工具集成，您还可看到新的或更新后的外部需求的标记。 以下为与如何将标记应用到集成需求的相关方案：

  • 如果在初始同步后将需求添加到需求管理工具，则会执行随后同步，当将新需求添加到 Silk Central，将显示已添加标记以表明它是在更新期间创建的。
  • 如果编辑已同步到 Silk Central 的需求，Silk Central 中的需求将具有已更新标记以表明其已更新。
  • 设置标记
    在需求上设置标记，以向他人指示需求已更改或需要审阅。
  • 清除标记
    确认所有更改或审阅需求后，从需求中清除标记。
  • 创建已标记需求的筛选器
    创建已标记需求的筛选器，以仅查看需求树中满足筛选器条件的需求。
父主题： 管理需求
相关参考
通知页面


设置标记

在需求上设置标记，以向他人指示需求已更改或需要审阅。

在需求上设置标记：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 右键单击需求并选择标记 > 设置标记。 此时将打开设置标记对话框。
  4. 在注释文本框中键入标记的注释。
  5. 要为当前选定需求的所有子需求设置标记，请单击在子需求上设置标记复选框。
  6. 单击确定。
    注： 可在需求的属性页面上查看标记信息。
父主题： 标记
相关参考
需求属性页面


清除标记

确认所有更改或审阅需求后，从需求中清除标记。

从需求中清除标记：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 要清除单个标记，请执行以下操作：右键单击需求并选择标记 > 清除标记。
  4. 要清除所选需求的所有子级的标记，请执行以下操作：右键单击需求并选择标记 > 清除标记 - 包括子项。 标记信息将从需求的属性页面删除。
注： 您也可通过单击需求的属性页面上的清除标记来清除标记。
父主题： 标记
相关参考
需求属性页面


创建已标记需求的筛选器

创建已标记需求的筛选器，以仅查看需求树中满足筛选器条件的需求。

创建已标记需求的筛选器：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 单击新建筛选器。 将打开新建筛选器对话框。
  3. 从选择条件列表中选择需求属性。
  4. 从属性列表中选择需求状态。
  5. 从运算符列表中选择 =。
  6. 从值列表中选择以下值之一：
    无
    未选择任何标记
    已标记为手动
    用户已将标记手动添加到需求。
    已标记为新建
    已创建需求。
    已标记为更新
    已更新需求。
    过时
    已将需求标记为过时。
  7. 单击保存和应用。
    注： 如果已标记子需求但未标记一个或多个父需求，将显示已标记子需求的完整路径，但会禁用父需求。您不能设置或清除处于此状态的父需求的标记。
父主题： 标记
相关参考
需求属性页面


配置需求属性

配置需求属性、附件、标记和覆盖率。

除给定的默认属性外，您还可以在 Silk Central 中创建自身的需求属性。这些自定义属性可在编辑需求对话框中编辑，类似于默认属性。

要为活动项目创建自定义属性，请在菜单中单击需求 > 需求属性，然后单击新建需求属性。

自定义属性在属性页面的需求详细信息视图和需求文档视图中显示。

有关自定义需求属性的其他信息，请参阅自定义需求属性。

  • 替换需求属性
    介绍如何替换一个或多个需求的属性值。
  • 查找需求属性
    使用查找定位满足搜索条件的需求属性。
  • 需求属性页面
    显示选定需求或项目的高级信息。
  • 需求附件
    介绍如何使用需求附件。
父主题： 需求
相关概念
自定义需求属性


替换需求属性

替换一个或多个需求的属性值：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 单击工具栏中的 替换 （替换），或右键单击需求，然后单击替换。 此时将显示替换对话框。
  3. 从查找位置列表中选择需求属性。 此列表包含所有默认和自定义属性。
  4. 在查找内容区域定义搜索条件。 查找内容区域的 UI 控件因选定的属性而异。例如：如果您选择风险属性，则显示两个列表，如果您选择说明属性，则显示文本字段和两个复选框。
  5. 在替换为区域，请输入要替换已识别数据的值。
  6. 可选：选中区分大小写复选框，以考虑大小写字母。
  7. 可选：选中仅全字匹配复选框可仅包括整个独立的字符串实例。
  8. 单击确定。 符合搜索条件的第一个需求在需求树中突出显示。
  9. 请单击下列选项之一：
    • 替换：替换突出显示的需求的属性值。
    • 全部替换：替换包含定义值的所有需求的属性值。
    • 查找下一个：突出显示包含定义值的下一个需求。
    • 查找上一个：突出显示包含定义值的上一个需求。
    • 新建替换：再次打开替换对话框，在其中可以设置新值。
    • 关闭：关闭对话框。
    注： 如果您单击全部替换，所有继承的属性将会被覆盖。 在这种情况下，子需求也会丢失其继承设置。 如果您希望子需求继承新值，则仅对父需求使用替换。
父主题： 配置需求属性


查找需求属性

在需求区域，您可以使用查找命令来定位符合某个搜索条件的需求。您也可以使用替换命令将识别的属性数据替换为您指定的备用数据。两个命令都提供查找下一个和查找上一个功能，允许您逐个查看所有识别的属性。

要查找需求：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择工具栏中的 查找 以打开查找对话框。
    注： 此命令也可通过右键单击需求并选择查找来执行。
  3. 从查找位置列表中选择需求属性。 此列表包含所有默认和自定义属性。
  4. 在查找内容区域定义搜索条件。 查找内容区域的 UI 控件因选定的属性而异。例如：如果您选择风险属性，则显示两个列表，如果您选择说明属性，则显示文本字段和两个复选框。
  5. 单击确定可开始搜索。 满足搜索条件的第一个需求将会在树视图中突出显示。 满足搜索条件的第一个需求将会在树视图中突出显示。
  6. 单击查找对话框中的查找下一个可前进至列表中满足搜索条件的下一个需求。 单击查找对话框中的查找上一个可返回至列表中满足搜索条件的上一个需求。
    注： 当搜索满足搜索条件的最后一个或第一个需求时，分别单击查找下一个或查找上一个，将会从起始处开始搜索。
父主题： 配置需求属性


需求属性页面

需求 > 详细信息视图 > 属性

需求属性页面显示选定需求或项目的高级信息。

需求与外部需求管理系统同步时，项目有时会用叹号 (!) 标记。这意味着标记的字段未映射到外部需求管理系统。使用属性映射功能映射属性字段。如果您未使用属性映射功能，则仅映射需求的名称和说明。有关更多信息，请参阅编辑属性映射。

用星号 (*) 标记的项目值是从父需求继承的值。

单击编辑需求属性可编辑显示的属性。

下表仅适用于设置有标记的需求。

项 | 说明
标记者 | 表示设置标记的人员和时间。
注释 | 表示标记的注释。
清除标记 | 单击可删除标记。

下表列出了属性页面上显示的选定需求或项目的属性。

属性 | 说明
需求名称 | 需求的名称。
需求 ID | 需求的标识符。
说明 | 需求的说明。
优先级 | 为需求配置的优先级。
风险 | 为需求配置的风险。
已审阅 | 需求的当前审阅状态。是或否。
自定义属性 | 如果已为需求配置自定义属性，则会将其列在此处。
文档 | 此需求从中派生的源文档（若有）。
创建于 | 创建此需求的日期。
创建者 | 创建此需求的用户名称。
更改时间 | 上次更新此需求的日期。
更改者 | 上次更新此需求的用户名称。
父主题： 配置需求属性
相关概念
同步需求
相关任务
编辑属性映射


需求附件

您可以将多个文件或链接作为附件上载到需求，或删除附件。剪切或粘贴带附件的需求时，附件将自动附带副本。

以下附件类型可用：

  • 已上载文件
  • UNC 路径的引用
  • URL 的引用，包括 StarTeam URL
  • 将文件附加到需求
    将文件附加到需求，以将更多信息添加到需求。
  • 将链接附加到需求
    将链接附加到需求，以将更多信息添加到需求。
  • 查看需求附件
    查看需求附件以获取需求的其他信息。
  • 从需求下载文件
    将所有附加的文件从需求下载到本地磁盘。
  • 从需求中删除附件
    如果不再需要附件中的信息，则可删除需求附件。
  • 需求附件页面
    列出了附加到选定需求的文件和链接。
父主题： 配置需求属性


将文件附加到需求

将文件附加到需求：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 单击附件选项卡。

    如果已在 Silk Central 项目和 Caliber 项目之间启用需求管理集成，则附件页面包括打开 Caliber 按钮，此按钮可使您在 Caliber 中直接管理需求附件。

  4. 单击上载文件。 将出现上载文件对话框。
  5. 单击选择文件并选择要从本地文件系统附加的文件。
  6. 键入附件的说明。
  7. 单击确定。 附件会上载到服务器并与所选需求关联。
父主题： 需求附件


将链接附加到需求

将链接附加到需求：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 单击附件选项卡。

    如果已在 Silk Central 项目和 Caliber 项目之间启用需求管理集成，则附件页面包括打开 Caliber 按钮，此按钮可使您在 Caliber 中直接管理需求附件。

  4. 单击附加链接。 将出现附加链接对话框。
  5. 在链接字段中键入 URL。
  6. 键入附加链接的说明。
  7. 单击确定。 该链接将与所选需求关联。
父主题： 需求附件


查看需求附件

查看需求附件：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 单击附件选项卡。

    如果已在 Silk Central 项目和 Caliber 项目之间启用需求管理集成，则附件页面包括打开 Caliber 按钮，此按钮可使您在 Caliber 中直接管理需求附件。

此时将打开与需求关联的所有附件列表。每个附件名称充当链接。文件附件链接可打开另存为对话框，使您可以将附件下载到本地文件系统。链接附件在新生成的浏览器窗口中直接链接到链接目标。
父主题： 需求附件


从需求下载文件

从需求下载所有文件：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 单击附件选项卡。

    如果已在 Silk Central 项目和 Caliber 项目之间启用需求管理集成，则附件页面包括打开 Caliber 按钮，此按钮可使您在 Caliber 中直接管理需求附件。

  4. 在附件部分，单击下载所有文件。 根据配置的浏览器下载设置，所有附加的文件将作为 zip 存档下载到本地磁盘。
    注： 为了防止过度下载，如果选中了包括子附件，则下载所有文件将禁用。
父主题： 需求附件


从需求中删除附件

要删除需求附件：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 单击附件选项卡。

    如果已在 Silk Central 项目和 Caliber 项目之间启用需求管理集成，则附件页面包括打开 Caliber 按钮，此按钮可使您在 Caliber 中直接管理需求附件。

  4. 单击要删除的附件的操作列中的 删除 。
  5. 单击确认对话框上的是以从项目中删除附件。
    注： 每次只能删除一个附件。
父主题： 需求附件


需求附件页面

需求 > 详细信息视图 > 附件

附件页面列出了附加到选定需求的文件和链接。虽然附件列表可以按名称、创建时间和创建者属性排序，但是附件按其上载的顺序显示。

注： 要显示与选定需求的子需求关联的任何附件，请选中包括子附件复选框。
注： 文件图标表示文档是否直接附加到选定需求，或是否附加到选定需求的子需求。
单一图标
文件直接附加到选定的需求。
双重图标
文件附加到选定需求的子需求。

附件页面显示每个列出附件的以下列：

列 | 说明
操作 | 单击 删除 可删除附件。
附件图标 | 取决于附件的类型。
名称 | 附件的名称。
大小 | 附件的大小。
说明 | 附件的说明。
创建于 | 创建附件的时间。
创建者 | 创建附件的用户。
父主题： 需求附件


将测试与需求关联

将需求与测试关联，确保测量软件涵盖指定需求的程度。
  • 从网格视图将测试分配到需求
    从网格视图将测试分配到需求，以显示需求的测试覆盖率。
  • 将测试手动分配到需求
    将测试手动分配到需求，以显示需求的测试覆盖率。
  • 在测试树中查找已分配的测试
    在测试树中查找已分配的测试以确定该测试所属的测试文件夹或容器。
  • 删除测试分配
    当测试不再与需求相关时，从需求中删除已分配的测试。
  • 从需求详细信息视图生成测试
    从需求区域的详细信息视图生成新的测试以将测试分配到特定需求。
  • “已分配的测试”页面
    列出分配到所选需求的所有测试。
父主题： 需求


从网格视图将测试分配到需求

从测试区域网格视图将一个或多个测试分配到一个或多个需求：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 单击工具栏上的 网格视图 。
  3. 选择要分配到需求的测试。 您可使用键盘的 Ctrl 和 Shift 键，以通过标准浏览器多选功能选择多个测试。
  4. 右键单击所选测试并选择保存所选内容。
  5. 在菜单中，单击需求 > 详细信息视图。
  6. 选择要向其分配所选测试的需求。
  7. 单击已分配的测试选项卡。
  8. 单击分配已保存的选定内容。
    注： 只会分配需求测试容器中的测试。您可将所选测试分配到多个需求，但不能将其分配到不同项目中的需求。在您做出其他选择或关闭 Silk Central 之前，所选内容仍然保持不变。
父主题： 将测试与需求关联


将测试手动分配到需求

将测试手动分配到需求：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 单击已分配的测试选项卡。 可用于分配的所有测试都显示在测试窗口中。
  4. 如果已创建测试筛选器，则可从测试窗口上方的筛选器列表中选择该筛选器。 要创建新的测试筛选器，请导航至测试区域并单击工具栏上的新建筛选器。
  5. 选择要分配的测试。 您可使用键盘的 Ctrl 和 Shift 键，以通过标准浏览器多选功能选择多个测试。
  6. 将所选内容拖放到已分配的测试区域，或单击任意测试左边的 分配 。 通过分配测试容器或测试文件夹，可将这些容器或文件夹中的所有测试分配到所选需求。此外，还会分配位于这些容器和文件夹的子文件夹中的测试。
    提示： 右键单击一个节点以进行展开和折叠。
父主题： 将测试与需求关联


在测试树中查找已分配的测试

要在测试树中查找已分配的测试：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 单击工具栏中的 需求视图 。
  3. 在需求树中选择至少分配有一个测试的需求。
  4. 单击已分配的测试选项卡。
  5. 在测试的操作列中，单击 查找 以找出测试存储在哪个测试文件夹或容器中。 相应的测试文件夹或容器将在测试窗口中突出显示。
父主题： 将测试与需求关联


删除测试分配

删除测试分配：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 单击工具栏中的 需求视图 。
  3. 在需求树中选择至少分配有一个测试的需求。
  4. 在想要删除的已分配测试的操作列中，单击 删除 或使用 Ctrl+单击或 Shift+单击以选择多个测试，然后按 Del 键。
    注： 要从选定的需求中删除所有测试分配，请单击全部删除。
父主题： 将测试与需求关联


从需求详细信息视图生成测试

您可从需求树直接生成测试并将测试分配到特定需求。需求树用作新测试树的测试文件夹/测试结构的模板。

要从详细信息视图生成新测试：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 右键单击要将其转化成测试的需求或项目节点，然后选择生成测试。 此时将显示从需求生成测试对话框。此对话框使您可指定是否将所选需求子树的树叶（即最低级别的节点）转化成测试或测试文件夹，以及是否将树生成到新的测试容器或现有容器。
  3. 在输入名称字段输入新测试容器的名称，然后从选择产品列表中选择产品以在活动 Silk Central 项目中创建容器。 选择产品列表由项目经理配置的产品填充。有关详细信息，请参阅管理产品或咨询您的项目经理。
  4. 如果已定义源代码管理配置文件，则从选择源代码管理配置文件列表中选择用于管理测试源代码的源代码管理配置文件。 有关源代码管理配置文件的详细信息，请参阅源代码管理配置文件或咨询您的 Silk Central 管理员。
  5. 要在测试中包括所选需求的所有子需求，请选中包括子需求复选框。 复选框默认为选中。
  6. 要将新测试自动分配到其从中创建的需求，请选中将新生成的测试分配到需求复选框。 如果未选择此选项，则必须手动将测试与需求关联。
    注： 选中从需求树叶中生成测试文件夹时，此选项不可用。
  7. 单击确定以创建测试。 新测试与需求树具有相同的结构。
  8. 此时将显示消息框。单击是查看测试区域的测试，或单击否保持在需求区域。
父主题： 将测试与需求关联
相关概念
管理产品
源代码管理配置文件


“已分配的测试”页面

需求 > 详细信息视图 > 已分配的测试

已分配的测试页面列出分配到所选需求的所有测试。如果测试已分配到多个执行计划并已选中在执行上下文中显示复选框，则每个执行计划的测试将显示在单独的网格行中。

可用于分配的所有测试将显示在右侧的测试树中。要将测试分配到所选需求，请双击树中的条目或单击条目左侧的 分配 。

如果您已创建测试筛选器，则可以从测试树上方的筛选器列表中选择它。要创建新的测试筛选器，请导航至测试区域并单击工具栏上的新建筛选器。

要将新生成的测试自动分配到从其中生成测试的需求，请选中从需求生成测试对话框上的将新生成的测试分配到需求复选框。

默认视图只显示直接分配到所选需求的测试。选中完整覆盖复选框还可显示分配到所选需求的子需求的所有测试。选中完整覆盖时，未分配到所选需求但已分配到该需求的子需求的测试会在测试类型图标上方显示覆盖图。

如果已将一组测试从测试 > 网格视图复制到剪贴板，请单击分配已保存的选定内容以将整个组分配到所选需求。单击全部删除以从需求中删除所有已分配的测试。

要直接在网格中将现有问题分配到一个或多个测试，请右键单击测试，然后单击分配现有问题。您可使用 Ctrl+单击或 Shift+单击选择多个测试。

每个所列测试的已分配的测试页面都会显示以下列：

列 | 说明
操作 您可对已分配的测试执行以下操作：
  • 单击 删除 以从需求中删除已分配的测试。
  • 单击 定位 以在右侧测试树中找到已分配的测试。
测试 | 已分配的测试的名称。单击以查看和编辑测试。对于配置测试，每个配置的测试会单独列出。
执行计划 | 只有选中在执行上下文中显示复选框才会显示此列。包括已分配测试的执行计划名称。适用于配置测试。
执行计划父项 | 执行计划在其中执行的上下文中的配置套件、文件夹或测试周期。 单击可访问执行计划树中的套件或文件夹。 如果配置套件或文件夹中未包含执行计划，则不显示任何内容。
状态 向其分配测试的每个执行计划中的已分配测试状态。要显示每个执行计划中所显示测试的所有运行状态，请选中在执行上下文中显示复选框。
  • 通过
  • 失败
  • 未执行
  • 不适用
对于配置套件中包括的测试或测试包，状态是套件中所有配置的所有状态的聚合：
  • 如果测试仅分配给配置套件，则只有测试在所有配置中均为通过时状态才为通过。如果不是所有配置中的状态均为通过，则传播最差运行的状态，且采用以下由上而下的优先级：
    1. 不适用
    2. 未执行
    3. 失败
    4. 通过
    如果一个或多个配置中的测试失败，则分配给测试的需求状态为失败。
  • 我们不建议将测试分配给配置套件，以及一个或多个简单的执行计划。但是在这种情况下，配置状态的聚合是一个状态，而执行计划的上次状态为其他状态。上次执行的状态确定测试的最后状态。
  • 如果测试仅分配给简单的执行计划，则会更新状态来响应上次测试运行的状态。
上次执行 | 最后执行测试的时间和日期。
问题 | 只有未选中在执行上下文中显示复选框的情况下才会显示此列。与此测试关联的问题。
父主题： 将测试与需求关联
相关概念
自定义图标


需求导入

Silk Central 允许您从 Microsoft Word 或 Excel 导入需求。您可以将需求导入到需求区域，然后在 Silk Central 中维护所有包含的需求。导入是一次性事件。

  • 从 Word 文件中导入需求
    从 Microsoft Word 文件中导入需求以保留 Silk Central 中的需求。
  • 从 Word 文件更新需求
    从 Microsoft Word 文件更新需求以应用对 Word 文件做出的更改。
  • Word 需求文件
    介绍您可从中将需求导入到 Silk Central 的 Word 需求文件的内容。
  • 从 Excel 文件导入需求
    从 Microsoft Excel 文件中导入需求以保留 Silk Central 中的需求。
  • 从 Excel 文件更新需求
    从 Microsoft Excel 文件更新需求以应用对 Excel 文件做出的更改。
  • Excel 需求和映射文件
    介绍 Excel 需求文件和 Silk Central 中对应映射的内容。
父主题： 需求


从 Word 文件中导入需求

在导入需求前，您需要在 Word 中创建需求文件。有关更多信息，请参阅 Word 需求文件。

Test Manager 使用 Word 文件和映射文件中存储的信息，确定要存储哪些数据，仅捕获映射为特定样式的信息。Test Manager 使用映射文件将 Word 文件内的需求映射到 Silk Central 需求。预先选择名为 RequirementsPropertiesDefaultMapping.xml 的默认映射文件进行导入。您可以选择自己的自定义映射文件来映射需求。

docx 功能：docx 的功能与 doc 相同，但具有以下改进：
  • 可检测到图像和任何其他嵌入式对象 (OLE)（如 PDF、Excel），并作为附件导入到需求。
  • 说明可能包含超链接。

要将需求从 Word 文件中导入到需求单元：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 右键单击您要用作已导入需求的父节点的需求，并选择从 Word 导入.... 此时将打开从 Word 文件导入需求对话框。
  3. 从选择映射文件列表框中选择映射文件。 默认映射文件为 RequirementsPropertiesDefaultMapping.xml。
  4. 可选：单击 [image] 可编辑映射文件。单击 [image] 可删除映射文件。有关更多信息，请参阅 Word 需求文件。
    注： 若要执行这两项操作，分别需要具备修改 Office 导入映射文件/删除 Office 导入映射文件的权限。
  5. 如果这是一次性的批量需求导入，请选中一次性导入复选框，导入后仅在 Silk Central 中维护。选中此选项会直接在选定节点下导入需求，不创建共用的根文件夹。此后您无法使用从 Word 更新...选项来更新导入的需求。
  6. 将需求文件的完全限定路径键入需求文件字段，或单击选择文件搜索需求文件。
  7. 单击确定。 如果导入成功，将会有消息通知您。单击确定关闭消息。
父主题： 需求导入
相关概念
Word 需求文件
相关任务
从 Word 文件更新需求


从 Word 文件更新需求

Silk Central 允许您更新从 Microsoft Word 中导入的需求。您可以更改 Word 文档中的需求，然后在需求区域更新需求。您也可以更改映射文件，以便在需求区域更改需求的映射。
注： 您只能更新在先前导入的 Word 文件中定义了唯一外部 ID 的需求。Silk Central 需要使用此 ID 识别需要更新的需求。
  1. 在菜单中，单击需求 > 详细信息视图。
  2. 右键单击先前导入的需求（例如，导入自文件“RequirementExample.docx”）的父节点，选择从 Word 更新...。 此时将打开从 Word 文件更新需求对话框。
  3. 从选择映射文件列表框中选择映射文件。 默认映射文件为 RequirementsPropertiesDefaultMapping.xml。
  4. 可选：单击 [image] 可编辑映射文件。单击 [image] 可删除映射文件。有关更多信息，请参阅 Word 需求文件。
    注： 若要执行这两项操作，分别需要具备修改 Office 导入映射文件/删除 Office 导入映射文件的权限。
  5. 将完全限定的需求文件路径键入需求文件字段，或单击浏览搜索需求文件。
  6. 单击确定。 如果更新成功，将会有消息通知您。单击确定关闭消息。
父主题： 需求导入
相关概念
Word 需求文件
相关任务
从 Word 文件中导入需求


Word 需求文件

在 Word 中创建需求，以便将需求导入 Silk Central 或者执行更新。在需求文件中，可以定义需求及其层次结构、优先级、风险、审视状态和自定义属性。

要将需求文件中的需求映射到 Silk Central 中的需求，请使用 XML 映射文件。映射文件将 Word 文档中的样式映射到 Silk Central 中的需求属性。您可以根据需要命名 Word 样式，只要您在映射文件中适当地对其进行映射。

如果您希望能够更新需求，则必须定义外部 ID 的样式，并向需求文件中的每个需求分配唯一的外部 ID。以下示例显示了示例需求，即两个子需求和相应的外部 ID：
Word 文件 应用的样式
Customer Account Management - Basics
ID_1
As user of the web shop I want to be able to ...
Medium
High
No

Customer Account Management - Personal Details
ID_1.1
As user of the web shop I want to be able to ...
Medium
Medium
No

Customer Account Management - Shipping Details
ID_1.2
As user of the web shop I want to be able to ...
Medium
Medium
No

Formatted with Word style "Heading 1"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

Formatted with Word style "Heading 2"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

Formatted with Word style "Heading 2"
Formatted with Word style "ExternalID"
Formatted with Word style "Description"
Formatted with Word style "Priority"
Formatted with Word style "Risk"
Formatted with Word style "Reviewed"

（可选）在另存为字段中更改映射文件的名称。此文件将保存到应用服务器的 <Silk Central 数据目录>\OfficeImportMappingFiles\requirements\<客户端 ID> 目录中，例如 C:\ProgramData\SilkCentral\instance_<实例编号>_<实例名称>\OfficeImportMappingFiles。

父主题： 需求导入
相关任务
从 Word 文件中导入需求
从 Word 文件更新需求


从 Excel 文件导入需求

在导入需求前，您需要在 Excel 中创建需求文件。有关更多信息，请参阅 Excel 需求和映射文件。

Test Manager 使用 Excel 文件和映射文件中存储的信息，确定要存储哪些数据，仅捕获映射为特定列名的信息。Test Manager 使用映射文件将 Excel 文件内的需求映射到 Silk Central 需求。预先选择名为 RequirementPropertiesXlsxDefaultMapping.xml 的默认映射文件进行导入。您可以选择自己的自定义映射文件来映射需求。

注： 不支持导入附件（图像、图片）。

将需求从 Excel 文件中导入到需求单元：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 右键单击您要用作已导入需求的父节点的需求，并选择从 Excel 导入.... 此时将打开从 Excel 文件导入需求对话框。
  3. 从选择映射文件列表框中选择映射文件。 默认映射文件为 RequirementPropertiesXlsxDefaultMapping.xml。
  4. 可选：单击 [image] 可编辑映射文件。单击 [image] 可删除映射文件。有关更多信息，请参阅 Excel 需求和映射文件。
    注： 若要执行这两项操作，分别需要具备修改 Office 导入映射文件/删除 Office 导入映射文件的权限。
  5. 如果这是一次性的批量需求导入，请选中一次性导入复选框，导入后仅在 Silk Central 中维护。选中此选项会直接在选定节点下导入需求，不创建共用的根文件夹。此后您无法使用从 Excel 更新...选项来更新导入的需求。
  6. 将需求文件的完全限定路径键入需求文件字段，或单击选择文件搜索需求文件。
  7. 单击确定。 如果导入成功，将会有消息通知您。单击确定关闭消息。
父主题： 需求导入
相关任务
从 Excel 文件更新需求
相关参考
Excel 需求和映射文件


从 Excel 文件更新需求

Silk Central 允许您更新从 Microsoft Excel 中导入的需求。您可以更改 Excel 文档中的需求，然后在需求区域更新需求。您也可以更改映射文件，以便在需求区域更改需求的映射。
注： 您只能更新在先前导入的 Excel 文件中定义了唯一外部 ID 的需求。Silk Central 需要使用此 ID 识别需要更新的需求。
  1. 在菜单中，单击需求 > 详细信息视图。
  2. 右键单击先前导入的需求（例如，导入自文件“RequirementExample.xslx”）的父节点，选择从 Excel 更新...。 此时将打开从 Excel 文件更新需求对话框。
  3. 从选择映射文件列表框中选择映射文件。 默认映射文件为 RequirementPropertiesXlsxDefaultMapping.xml。
  4. 可选：单击 [image] 可编辑映射文件。单击 [image] 可删除映射文件。有关更多信息，请参阅 Excel 需求和映射文件。
    注： 若要执行这两项操作，分别需要具备修改 Office 导入映射文件/删除 Office 导入映射文件的权限。
  5. 将完全限定的需求文件路径键入需求文件字段，或单击浏览搜索需求文件。
  6. 单击确定。 如果更新成功，将会有消息通知您。单击确定关闭消息。
父主题： 需求导入
相关任务
从 Excel 文件导入需求
相关参考
Excel 需求和映射文件


Excel 需求和映射文件

在 Excel 中创建需求文件，以便将需求导入 Silk Central 或者执行更新。在需求文件中，可以定义需求及其层次结构、优先级、风险、审视状态和自定义属性。

要将需求文件中的需求映射到 Silk Central 中的需求，请使用 XML 映射文件。映射文件将 Excel 文档中的列映射到 Silk Central 中的需求属性。您需要修改 Office 导入映射文件权限才能编辑映射文件。

属性映射

单击从 Excel 文件导入需求或从 Excel 文件更新需求对话框中的编辑映射，将 Excel 文件中的需求映射到 Silk Central，如下所示：
  • 标题行：在 Excel 需求文件中，指定包含要在属性映射中使用的列名的行。
  • 第一个数据行：指定包含第一条需求的行。该行及其下方的所有行均将解释为需求。
  • 分隔符：指定应解释为属性值中分隔符的字符。适用于多重列表属性。
  • 名称、说明：分别指定标题行中映射到需求名称和说明的列名。
  • 外部 GUID：指定标题行中包含需求文件内各需求唯一 ID 的列名。这些 ID 可在外部父 GUID 中使用，用于创建需求层次结构。
  • 外部父 GUID：在标题行中指定包含需求父项的列名。在需求文件中，输入父项的外部 GUID，指定需求的父项。如果此单元格未包含数据，需求将直接添加到已生成的根需求。以下规则适用：
    • 如果需求未设置父 ID，则将作为子项添加到已生成的根需求
    • 如果需求没有有效的父 ID，则将作为子项添加到已生成的根需求
    • 如果需求设置了自己的外部 ID 作为父 ID，则将作为子项添加到已生成的根需求
    • 如果两个或多个需求通过父 ID 存在循环依赖关系，这些需求将不会导入到Silk Central
  • 优先级、风险、已审阅：指定标题行中映射到这些属性的本地化值的列名。
  • 如果您定义了自定义属性，应在标题行中为各自定义属性指定列名，以确保正确映射。
  • 另存为：指定要保存映射信息的文件名称。此文件将保存到应用服务器的 <Silk Central 数据目录>\OfficeImportMappingFiles\requirements\xlsx\<客户端 ID> 目录中，例如 C:\ProgramData\SilkCentral\instance_<实例编号>_<实例名称>\OfficeImportMappingFiles\requirements\xlsx\1。

示例 Excel 需求文件

以下示例显示了示例需求，即两个子需求和相应的外部 ID。这个示例 Excel 需求文件匹配默认属性映射。
1 | RequirementName | RequirementDescription | ID | ParentID | 优先级 | 风险 | 已审阅
2 | 客户帐户管理 - 基本 | 作为网上商店的用户，我希望能够... | ID_1 |  | 中 | 高 | 否
3 | 客户帐户管理 - 个人详细信息 | 作为网上商店的用户，我希望能够... | ID_1.1 | ID_1 | 中 | 中 | 否
4 | 客户帐户管理 - 发货详细信息 | 作为网上商店的用户，我希望能够... | ID_1.2 | ID_1 | 中 | 中 | 否
父主题： 需求导入
相关任务
从 Excel 文件导入需求
从 Excel 文件更新需求


需求视图

Silk Central 提供了多种视图和工具来管理您的需求。

  • 需求树
    介绍需求树。
  • 需求工具栏功能
    提供管理需求的重要命令。
  • 需求文档视图
    显示分配到“热字段”图表中的活动项目的所有测试状态。
  • 需求历史记录
    介绍如何使用需求历史记录跟踪对需求做出的所有更改。
父主题： 需求


需求树

通过层次树结构需求树显示、组织和保留需求。 需求树中的每个节点表示一个需求。 每个需求可以关联任何数量的子需求。 需求树可使您以任何数量的层次级别组织需求。

注： 在不影响响应时间的情况下，如果需求树包括的元素过多而无法同时显示，则以递增方式显示元素。 选项卡底部的页码链接可使您一次一页浏览树中包括的元素。 要将所有元素显示为单个列表，请选择 [All] 链接。
  • 键盘功能（需求）
    树提供键盘支持。
  • 折叠或展开需求树
    折叠和展开需求树，以根据您的查看需求整合和显示层次结构级别。
  • 筛选需求树
    介绍如何为需求树添加筛选器。
父主题： 需求视图


键盘功能（需求）

可对所选节点执行以下操作：

键 | 操作
向上 | 将选定内容上移
向下 | 将选定内容下移
右 | 展开元素
左 | 折叠元素
F2 | 编辑元素
Ctrl+C | 复制元素
Ctrl+X | 剪切元素
Ctrl+V | 粘贴元素
Del | 删除元素
Ctrl+向上 | 向上移动元素
Ctrl+向下 | 向下移动元素
单击 | 选择一个元素并将其标记为当前元素。
Ctrl+单击 | 切换所单击元素的选择状态，通过多次单击添加/删除其他元素。
Shift+单击 | 选择从当前所选元素到新选择元素的范围。
Shift+向上 | 选择上面的元素。
Shift+向下 | 选择下面的元素。
输入 | 分配元素（仅在分配树中）
父主题： 需求树


折叠或展开需求树

折叠或展开需求树：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求文件夹，然后继续执行以下选项之一：
    • 单击需求文件夹名称左侧的 展开 以展开文件夹。
    • 单击需求文件夹名称左侧的 折叠 以折叠文件夹。
    • 右键单击文件夹并选择展开或折叠。 您可使用上下文菜单中的命令一次性展开两个、三个或所有级别
父主题： 需求树


筛选需求树

如果筛选子树，则仅显示所选节点和子节点。 所有其他节点都暂时隐藏。 这在您要使用所有需求的子集生成 PDF 时非常有用。

要筛选需求树的子集：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 右键单击需求树中的需求，然后单击筛选子树。
    注： 这将在工具栏中的筛选器列表中自动创建自定义筛选器。 您可通过单击 [image] （编辑筛选器）、单击高级并输入筛选器名称来保存此筛选器。
  3. 要禁用此筛选器，请从工具栏中的筛选器列表中选择 <无筛选器>。
父主题： 需求树
相关概念
筛选器


需求工具栏功能

需求 > 详细信息视图

需求 > 文档视图

需求工具栏提供管理需求的重要命令。

注： 需求树中的上下文菜单也提供需求工具栏中的某些命令。

以下命令包括在需求工具栏中：

命令 | 图标 | 说明
详细信息视图 | 需求视图 | 显示详细信息视图，可让您详细查看单个需求的属性。
文档视图 | 文档视图 | 显示文档视图，以便在单个视图中显示所有需求的选定属性。
新建需求 | 新建需求 | 向活动项目添加新需求。
新建子需求 | 新建子需求 | 向选定的需求添加新的子需求。
编辑 | 编辑 | 编辑选定的需求。
删除 | 删除 | 将选定的需求标记为已过时，或将其永久销毁。 可隐藏、显示和恢复过时的需求。
剪切 | 剪切 | 从需求树中剪切需求并将其保存到剪贴板。
复制 | 复制 | 将需求从需求树复制到剪贴板。
粘贴 | 粘贴 | 将需求从剪贴板粘贴到需求树。
粘贴为子项 | 粘贴为子项 | 将剪贴板中的需求作为子需求粘贴到当前选定的需求。
上移 | 上移 | 在需求树中上移需求。
下移 | 下移 | 在需求树中下移需求。
查找 | 查找 | 根据可配置的参数在活动项目中搜索所有需求。
替换 | 替换 | 将找到的值的实例替换为新值。
新建筛选器 | 新建筛选器 | 为需求树创建新筛选器。
筛选器 |  | 列出了需求树的可用筛选器。
编辑筛选器 | 编辑筛选器 | 编辑选定的筛选器。
删除筛选器 | 删除筛选器 | 删除选定的筛选器。
复制筛选器 | 删除筛选器 | 复制选定的筛选器。
显示更改 | 显示更改 | 显示对需求及其属性的最新更改。
确认 | 确认 | 确认对需求及其属性的更改。
显示直接覆盖 显示完整覆盖 |  | 在直接覆盖模式和完整覆盖模式之间切换。 此按钮在详细视图中处于禁用状态。
下载为 PDF | 下载为 PDF | 使用需求树中当前可见的所有节点生成和下载 PDF。 此按钮在详细视图中处于禁用状态。
父主题： 需求视图


需求文档视图

需求 > 文档视图

文档视图显示分配到活动项目的所有测试的状态，包括通过、失败、未执行和未覆盖测试的数量和百分比。文档视图在“热字段”图表中显示此覆盖率状态信息，用以下颜色表示：

颜色 | 说明
绿色 | 通过的测试。
红色 | 失败的测试。
橙色 | 尚未执行的测试。
灰色 | 其他状态的测试。

测试未覆盖的需求列为未覆盖。

文档视图以列显示所有自定义需求属性。

注： 针对当前显示的所有测试，测试总数将累积到父层级。如果您将筛选器应用到需求树，则测试总数仅基于筛选的需求。例如，需求总数包括用筛选器选定的所有子需求中的测试，项目总数包括用筛选器选定的所有需求中的测试。

文档视图单独保存每个用户和每个项目的显示设置。

父主题： 需求视图


需求历史记录

Silk Central 提供对需求做出的所有更改的完整历史记录。历史记录信息为只读，无法编辑或永久删除。

最新更改筛选器（可通过单击工具栏上的 显示更改 访问）可使您有效查看和确认对需求做出的最新更改和添加。

注： 使用永久销毁选项删除需求时，您将会删除标记为已过时的需求，或者，如果您确认所有最新更改，将向需求所属的项目历史记录文件中添加一个更改历史记录条目。
  • 查看最新更改
    查看需求的最新更改。
  • 跟踪需求的历史记录
    介绍如何跟踪需求的历史记录。
  • 需求历史记录页面
    详细列出了选定需求或项目修订历史记录。
父主题： 需求视图


查看最新更改

查看需求的最新更改：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 单击 显示更改 以筛选掉所有需求，但上次更改确认后已更改的测试元素除外。
    注： 在筛选器列表框中自动选择最新更改筛选器。
  3. 审阅更改后，您可以单击 确认 接受更改。 确认功能将重置最近更改的筛选器。
  4. 再次单击 全部显示 以删除筛选并查看所有需求。
父主题： 需求历史记录
相关概念
最新更改


跟踪需求的历史记录

查看需求的历史记录：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 选择需求树中的需求。
  3. 单击历史记录选项卡。
  4. 可选：启用 Silk Central 项目和 Caliber 项目之间的需求管理集成时，您可以单击历史记录页面中的打开 Caliber，以便在 Caliber 中直接查看已同步需求的历史记录。
Silk Central 已记录的所有修订版本的属性以表格格式显示。
父主题： 需求历史记录


需求历史记录页面

需求 > 详细信息视图 > <需求> > 历史记录

历史记录页面详细列出了选定需求或项目的修订历史记录。以下操作可生成需求历史记录条目：

  • 添加新需求
  • 编辑需求
  • 将需求标记为已过时
  • 将附件添加到需求
  • 从需求中删除附件
  • 通过 MS Word 或 MS Excel 导入或更新需求

对于每个更改，页面显示以下列：

列 | 说明
修订 | 修订号。1-n。
更改时间 | 更改的日期和时间。
更改者 | 做出更改的用户。
备注 | 自动生成的更改说明。例如“已删除”或“已创建”。
注： 如果页面包括的元素数量过多，无法在不影响响应时间的情况下一次性显示，这些元素将以递增的方式显示。使用页面底部的导航工具栏可浏览元素。
父主题： 需求历史记录


测试

本部分说明如何管理 Silk Central 中的测试。

测试或测试用例是一组输入值、执行前提条件、预计结果和执行前提条件，是专为特定目标或测试条件而开发的，例如执行特定的程序路径或验证与特定需求的兼容性 [IEEE 610 之后]。Silk Central 支持各种测试类型，可以通过多种方式构建测试。 测试区域可使您在系统开发生命周期中保持对测试的控制。您可以创建、计划和管理自动测试和手动测试。您可以将文件和链接作为附件上载并关联到测试容器和测试。您可以轻松将发现的问题与导致发现的测试关联。您也可以在区域中跟踪测试的完整更改历史记录。

  • 配置测试设置和集成
    开始构建测试框架之前，您需要先配置至少一个项目和一个产品，如果您计划创建自动测试，则还需要配置一个源代码管理配置文件。
  • 构建测试资产
    Silk Central 在一种特定产品的版本和内部版本上下文中跟踪测试执行结果。因此，必须先定义产品，然后才能创建测试。
  • 管理测试
    将新测试添加到测试框架或配置现有测试。
  • 配置测试属性
    配置属性、参数、附件、成功条件等测试属性。
  • 执行测试的试运行
    执行测试的试运行以检查测试是否按预期工作。
  • 库
    库就是多个项目中的测试所共享的一组测试步骤和关键字的集合。
  • 将需求与测试关联
    将需求与测试关联，确保测量软件涵盖指定需求的程度。
  • 测试报告
    介绍测试相关的报告。
  • 已分配的执行计划
    将测试分配给执行计划，以便在开发和测试过程中维持对测试执行的控制。
  • 测试视图
    介绍测试区域中的可用视图。
父主题： Silk Central 帮助


配置测试设置和集成

开始构建测试框架之前，您需要先配置至少一个项目和一个产品，如果您计划创建自动测试，则还需要配置一个源代码管理配置文件。您可能还需要配置一些其他设置，例如筛选器、属性等。您必须拥有超级用户、管理员或项目经理权限才能执行这些任务。

  • 管理产品、组件、版本和内部版本
    介绍如何创建和组织产品、产品组件、产品版本和产品版本的内部版本号。
  • 源代码管理配置文件
    源代码管理配置文件可使 Silk Central 与外部源代码管理系统集成。定义源代码管理配置文件允许您定义 Silk Central 执行服务器应检索程序来源以执行测试的位置。
  • 步骤属性
    介绍如何使用步骤属性展开具有其他属性的手动测试步骤。
  • 属性
    介绍如何使用自定义属性来自定义测试和执行计划信息。
  • 用于数据驱动测试的数据源
    数据驱动测试是源自现有数据源（例如，电子表格或数据库）中的值的测试。数据源在项目特定范围内进行管理。
  • 筛选器
    介绍如何使用筛选器查找需要的准确信息，同时排除无关详细信息。
  • 更改通知
    介绍如何设置其他用户更改需求或测试时的电子邮件通知。
父主题： 测试


管理产品、组件、版本和内部版本

Silk Central 允许您创建和组织产品、产品组件、产品版本和产品版本的内部版本号。产品规范随后可与测试相关联，版本和内部版本可与执行计划相关联。您甚至可以导入之前在 Issue Manager 中定义的产品和组件。

  • 组件是离散的产品元素，可出于测试目的单独对其进行跟踪。
  • 版本是指出于开发和测试目的单独跟踪的产品版本。
  • 内部版本是指出于开发和测试目的单独跟踪的版本迭代。

Silk Central 还允许您为测试设置平台指派，例如操作系统。与产品、版本和内部版本设置一样，可以为平台指定名称、说明以及活动/非活动状态。

  • 管理产品
    介绍如何在 Silk Central 中配置产品。
  • 管理组件
    介绍如何配置产品中的组件。
  • 管理版本
    介绍如何配置产品中的版本。
  • 管理内部版本
    介绍如何管理版本中的内部版本。
  • 管理平台
    介绍如何在 Silk Central 中配置平台。
父主题： 配置测试设置和集成
父主题： 管理


管理产品

介绍如何在 Silk Central 中配置产品。

  • 添加产品
    添加新产品，以将其与 测试 关联。
  • 编辑产品
    编辑现有产品。
  • 激活和停用产品
    介绍如何激活或停用 Silk Central 中的现有产品。
  • 对产品列表排序
    在列表中将产品上移或下移，并按字母顺序对产品列表排序。
  • 删除产品
    删除现有产品以将其从产品列表中永久删除。
  • 产品配置页面
    使用此页配置产品、组件、版本和内部版本。
父主题： 管理产品、组件、版本和内部版本


添加产品

添加新产品：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击新建产品。 将显示新建产品对话框。
  4. 在名称文本框中键入新产品的名称。
  5. 在说明文本框中键入产品的说明。
  6. 选中活动复选框，以使此产品可与 测试 关联。
  7. 单击确定以保存产品。
    注： 创建产品时，Silk Central 会为新产品自动创建新默认版本 1.0 和新默认内部版本 1。
父主题： 管理产品


编辑产品

要编辑现有产品：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 在要编辑的产品的操作列中，单击 编辑 。 此时将显示编辑产品对话框。
  4. 对所选产品的名称、说明和活动状态进行所有必要更改，然后单击确定。
父主题： 管理产品


激活和停用产品

激活或停用现有产品：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击与要激活或停用的产品关联的状态图标。 将显示确认对话框，询问您是否确实要激活或停用。
  4. 确认消息以将产品状态切换为活动或非活动。
父主题： 管理产品
父主题： 管理版本


对产品列表排序

在列表中将产品上移或下移，或按名称的字母顺序对产品列表排序：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 在要移动项目的操作列中，单击 上移 或 下移 。
  4. 要按名称的字母顺序对列表进行排序，请单击按名称排序。
父主题： 管理产品


删除产品

要删除现有产品：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 停用要删除的产品。 有关其他信息，请参阅激活和停用产品。
  4. 在要删除的产品的操作列中，单击 删除 。 此时将显示确认对话框。
  5. 单击是以继续删除或单击否以中止删除。
父主题： 管理产品
相关任务
激活和停用产品


产品配置页面

管理 > 产品、版本和内部版本 > 产品

使用此页配置产品、组件、版本和内部版本。

单击新建产品可创建新产品。单击按名称排序可按名称的字母顺序对产品排序。

对于每个列出的产品，页面显示以下列：

列 | 说明
操作 您可以对产品执行以下操作：
在列表中将产品上移一行。
在列表中将产品下移一行。
编辑产品的名称、说明和状态。
永久删除产品。删除产品前需要使其处于非活动状态，如果产品已与测试关联，则不允许删除。
名称 | 在 GUI 和报告中显示的产品名称。单击产品名称可修改产品的组件、版本和内部版本。
说明 | 产品的文字介绍。
状态 | 产品的状态，活动或非活动。单击状态可在活动和非活动之间切换。
创建于 | 创建产品的日期。
创建者 | 创建产品的用户。

对于选定的产品，页面显示了所包含组件、版本和内部版本的详细信息。

页面显示了产品组件的以下列：

列 | 说明
操作 | 您可以在此列中删除组件。
名称 | 组件的名称。单击可打开编辑组件对话框。
说明 | 组件的说明。
创建于 | 创建组件的日期。
创建者 | 创建组件的用户。
状态 | 组件的状态。活动或非活动。单击可切换状态。

单击新建组件可创建新组件。单击按名称排序可按名称的字母顺序对组件排序。单击更新可更新组件列表。

页面显示了产品版本的以下项目：

项 | 说明
操作 | 您可以在此列中删除版本，或在列表中将版本上移或下移。
名称 | 版本的名称。单击可打开编辑版本对话框。
说明 | 版本的说明。
创建于 | 创建版本的日期。
创建者 | 创建版本的用户。
状态 | 版本的状态。活动或非活动。单击可切换状态。

单击新建版本可创建新版本。单击按名称排序可按名称的字母顺序对版本排序。

页面显示了产品内部版本的以下项目：

项 | 说明
操作 | 您可以删除或标记内部版本。
名称 | 内部版本的名称。单击可打开编辑内部版本对话框。
说明 | 内部版本的说明。
创建于 | 创建内部版本的日期。
创建者 | 创建内部版本的用户。
状态 | 内部版本的状态。活动或非活动。单击可切换状态。

单击新建内部版本可创建新内部版本。单击按名称排序可按名称的字母顺序对内部版本排序。单击更新可更新组件列表。

注： 您必须在内部版本列表框中选择特定版本才可启用这些按钮。

单击返回可返回产品列表。

父主题： 管理产品


管理组件

组件是离散的产品元素，可出于测试目的单独对其进行跟踪。

  • 添加组件
    添加新组件，以在测试产品时对其进行单独跟踪。
  • 编辑组件
    编辑产品内的现有组件。
  • 激活和停用组件
    激活或停用产品的现有组件。
  • 对组件列表排序
    在列表中将组件上移或下移，并按字母顺序对组件列表排序。
  • 删除组件
    从产品中删除现有组件。
父主题： 管理产品、组件、版本和内部版本


添加组件

向产品添加新组件：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 单击新建组件。 将显示新建组件对话框。
  5. 在名称文本框中键入新组件的名称。
  6. 在说明文本框中键入组件的说明。
  7. 选择组件的类型。 可用值有 Software 和 Documentation。
  8. 选中活动复选框，以使此组件可与产品关联。
  9. 单击确定以保存组件，或单击取消以中止操作。
父主题： 管理组件


编辑组件

要编辑产品内的现有组件：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 选择要编辑的组件。
  5. 此时将显示编辑组件对话框，提供有关所选组件的名称、说明和活动状态的详细信息。 进行所有必要更改，然后单击确定。
    注： 只有先停用组件，然后才能编辑该组件的类型。 有关其他信息，请参阅激活和停用组件。
父主题： 管理组件


激活和停用组件

激活或停用现有组件：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 单击与要激活或停用的组件关联的状态图标。 将显示确认对话框，询问您是否确实要激活或停用。
  5. 确认消息以将组件状态切换为活动或非活动。
父主题： 管理组件


对组件列表排序

在列表中将组件上移或下移，或按名称的字母顺序对组件列表排序：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 在组件类型列表框中，选择您要查看的组件的组件类型。
  5. 在要移动项目的操作列中，单击 上移 或 下移 。
  6. 要按名称的字母顺序对列表进行排序，请单击按名称排序。
父主题： 管理组件


删除组件

要从产品中删除现有组件：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 停用要删除的组件。 有关其他信息，请参阅激活和停用组件。
  5. 在组件的操作列中，单击 删除 。 此时将显示确认对话框。
  6. 单击是以继续删除或单击否以中止删除。
父主题： 管理组件


管理版本

版本是指出于开发和测试目的单独跟踪的产品版本。

  • 添加版本
    向产品添加新版本，以出于开发和测试目的分别跟踪特定版本。
  • 编辑版本
    编辑产品内的现有版本。
  • 激活和停用产品
    介绍如何激活或停用 Silk Central 中的现有产品。
  • 对版本列表排序
    在列表中将版本上移或下移，并按字母顺序对版本列表排序。
  • 删除版本
    从产品中删除现有版本以将其从产品列表中永久删除。
父主题： 管理产品、组件、版本和内部版本


添加版本

向产品添加新版本：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 单击新建版本。 将显示新建版本对话框。
  5. 在名称文本框中键入新版本的名称。
  6. 在说明文本框中键入版本的说明。
  7. 选中活动复选框，以使此版本可与产品关联。
  8. 单击确定以保存版本，或单击取消以中止操作。
父主题： 管理版本


编辑版本

要编辑产品内的现有版本：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 选择要编辑的版本。 此时将显示编辑版本对话框。
  5. 对所选版本的名称、说明和活动状态进行所有必要更改，然后单击确定。
父主题： 管理版本


对版本列表排序

在列表中将版本上移或下移，或按名称的字母顺序对版本列表排序：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 在要移动项目的操作列中，单击 上移 或 下移 。
  5. 要按名称的字母顺序对列表进行排序，请单击按名称排序。
父主题： 管理版本


删除版本

要从产品中删除现有版本：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 停用要删除的版本。 有关其他信息，请参阅激活和停用版本。
  5. 在要删除的产品的操作列中，单击 删除 。 此时将显示确认对话框。
  6. 单击是以继续删除或单击否以中止删除。
父主题： 管理版本


管理内部版本

内部版本是指出于开发和测试目的单独跟踪的版本迭代。

  • 添加内部版本
    添加新内部版本，以测试版本的特定迭代。
  • 编辑内部版本
    编辑版本内的现有内部版本。
  • 激活和停用内部版本
    激活或停用版本的现有内部版本。
  • 对内部版本列表排序
    在列表中将内部版本上移或下移，并按字母顺序对内部版本列表排序。
  • 标记内部版本
    标记可使您识别内部版本的特定测试运行。
  • 删除内部版本
    从版本中删除现有的内部版本。
父主题： 管理产品、组件、版本和内部版本


添加内部版本

向版本添加新内部版本：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 在版本的内部版本列表框中，选择要为其添加内部版本的版本。
  5. 单击新建内部版本。 将显示新建内部版本对话框。
  6. 在名称文本框中键入新内部版本的名称。
  7. 在说明文本框中键入内部版本的说明。
  8. 选中活动复选框，以使此内部版本可与版本关联。
  9. 单击确定以保存内部版本，或单击取消以中止操作。
父主题： 管理内部版本


编辑内部版本

要编辑版本内的现有内部版本：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 选择要编辑的内部版本。
  5. 此时将显示编辑内部版本对话框，提供有关所选内部版本的名称、说明和活动状态的详细信息。 进行所有必要更改，然后单击确定。
  6. 选中已标记复选框以标记内部版本。
父主题： 管理内部版本


激活和停用内部版本

激活或停用现有内部版本：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 单击与要激活或停用的内部版本关联的状态图标。 将显示确认对话框，询问您是否确实要激活或停用。
  5. 确认消息以将内部版本状态切换为活动或非活动。
父主题： 管理内部版本


对内部版本列表排序

在列表中将内部版本上移或下移，或按名称的字母顺序对内部版本列表排序：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 在版本的内部版本列表框中，选择您要查看其内部版本的版本。
  5. 在要移动项目的操作列中，单击 上移 或 下移 。
  6. 要按名称的字母顺序对列表进行排序，请单击按名称排序。
父主题： 管理内部版本


标记内部版本

您可以删除带标记的内部版本的运行。如果您尝试删除的运行选定内容包含带标记的内部版本，您会收到警告，而且您必须确认操作。如果您右键单击执行节点来执行批量删除（所有或特定时间范围），则不会删除带标记的内部版本。

标记现有内部版本：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 在内部版本部分，单击您要标记的内部版本的操作列中的 标记内部版本 。 此时将显示确认对话框。
  5. 单击是继续标记或单击否中止标记。
父主题： 管理内部版本


删除内部版本

要从版本中删除现有的内部版本：
  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击产品选项卡。 将显示产品页面，列出所有现有产品。
  3. 单击产品名称。 将打开产品的产品详细信息页面。
  4. 停用要删除的内部版本。 有关其他信息，请参阅激活和停用内部版本。
  5. 在内部版本的操作列中，单击 删除 。 此时将显示确认对话框。
  6. 单击是以继续删除或单击否以中止删除。
父主题： 管理内部版本


管理平台

为 测试 设置平台指派，例如操作系统。与产品、版本和内部版本设置一样，可以为平台指定名称、说明以及活动或非活动状态。

  • 添加平台
    添加为 测试 指定的新平台。
  • 编辑平台
    编辑现有平台。
  • 激活和停用平台
    激活或停用 Silk Central 中的现有平台。
  • 对平台列表排序
    在列表中将平台上移或下移，并按字母顺序对平台列表排序。
  • 删除平台
    删除现有平台以将其从平台列表中永久删除。
  • 平台配置页面
    使用此页配置平台。
父主题： 管理产品、组件、版本和内部版本


添加平台

添加新平台：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击平台选项卡。 将显示平台页面，列出所有现有平台。
  3. 单击新建平台。 将显示新建平台对话框。
  4. 在名称文本框中键入新平台的名称。
  5. 在说明文本框中键入平台的说明。
  6. 选中活动复选框，以使此平台可与 测试 关联。
  7. 单击确定以保存平台。
父主题： 管理平台


编辑平台

要编辑现有平台：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击平台选项卡。 将显示平台页面，列出所有现有平台。
  3. 在要编辑的平台的操作列中，单击 编辑 。
  4. 此时将显示编辑平台对话框，提供有关所选平台的名称、说明和活动状态的详细信息。 进行所有必要更改，然后单击确定。
父主题： 管理平台


激活和停用平台

注： 无法停用与 测试 关联的平台。

激活或停用现有平台：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击平台选项卡。 将显示平台页面，列出所有现有平台。
  3. 单击与要激活或停用的平台关联的状态图标。 将显示确认对话框，询问您是否确实要激活或停用。
  4. 确认消息以将平台状态切换为活动或非活动。
父主题： 管理平台


对平台列表排序

在列表中将平台上移或下移，或按名称的字母顺序对平台列表排序：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击平台选项卡。 将显示平台页面，列出所有现有平台。
  3. 在要移动项目的操作列中，单击 上移 或 下移 。
  4. 要按名称的字母顺序对平台列表排序，请单击按名称排序。
父主题： 管理平台


删除平台

要删除现有平台：

  1. 在菜单中，单击管理 > 产品、版本和内部版本。
  2. 单击平台选项卡。 将显示平台页面，列出所有现有平台。
  3. 停用要删除的平台。 有关其他信息，请参阅激活和停用平台。
  4. 在要删除的平台的操作列中，单击 删除 。 此时将显示确认对话框。
  5. 单击是以继续删除或单击否以中止删除。
父主题： 管理平台
相关任务
激活和停用平台


平台配置页面

管理 > 平台

使用此页配置平台。

要创建新平台，请单击新建平台。有关其他信息，请参阅添加平台。

要按名称的字母顺序对平台列表排序，请单击按名称排序。有关其他信息，请参阅对平台列表排序。

对于每个列出的平台，页面显示以下列：

列 | 说明
操作 用户可以在平台上执行以下操作：
在列表中将平台上移一行。
在列表中将平台下移一行。
永久删除平台。删除平台前需要使其处于非活动状态，如果平台已与测试关联，则不允许删除。
名称 | 在 GUI 和报告中显示的平台名称。单击平台名称可修改平台的名称、说明和状态。
说明 | 平台的文字介绍。
状态 | 平台的状态，活动或非活动。单击状态可在活动和非活动之间切换。
创建于 | 创建平台的日期。
创建者 | 创建平台的用户。
父主题： 管理平台
相关任务
添加平台
对平台列表排序


源代码管理配置文件

源代码管理配置文件可使 Silk Central 与外部源代码管理系统集成。定义源代码管理配置文件允许您定义 Silk Central 执行服务器应检索程序来源以执行测试的位置。

您需要将执行服务器中的可用磁盘空间翻倍以容纳源文件，因为 Silk Central 将签出源代码管理树，并通过可执行源文件生成工作目录。

其他源代码管理系统可以通过安装自定义插件配置。有关详细信息，请参阅 Silk Central API 帮助。以下是 Silk Central 目前“现成”支持的源代码管理系统：

  • AccuRev
    介绍如何配置 AccuRev 源代码管理配置文件。
  • Apache Commons 虚拟文件系统
    介绍如何配置虚拟文件系统源代码管理配置文件。
  • Git
    介绍如何配置 Git 源代码管理配置文件。
  • Microsoft Team Foundation Server
    介绍如何配置 Team Foundation Server 源代码管理配置文件。
  • Silk Test Workbench
    介绍如何配置 Silk Test Workbench 源代码管理配置文件。
  • StarTeam
    介绍如何配置 StarTeam 源代码管理配置文件。
  • 子版本
    介绍如何配置子版本源代码管理配置文件。
  • SilkTestPartner
    介绍如何配置 TestPartner 源代码管理配置文件。
  • 通用命名约定
    介绍如何配置通用命名约定源代码管理配置文件。
  • 删除源代码管理配置文件
    如果不再需要配置文件，则可删除现有的源代码管理配置文件。
  • 源代码管理配置文件页面
    列出了为将外部源代码管理系统集成到 Silk Central 而配置的所有问题跟踪配置文件。
父主题： 配置测试设置和集成
父主题： 项目设置
相关概念
API 帮助


AccuRev

本部分介绍如何配置 AccuRev 源代码管理配置文件。

AccuRev 是一种软件配置管理工具，它凭借其基于流的体系结构，解决了复杂的并行和分布式开发环境难题，从而加快开发过程，并改进资产重用。

目前支持与 AccuRev 集成的 Silk Central 版本：AccuRev 6.2

  • 添加 AccuRev 源代码管理配置文件
    创建 AccuRev 源代码管理配置文件，以从 AccuRev 检索用于测试执行的程序源代码。
  • 编辑 AccuRev 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 AccuRev 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加 AccuRev 源代码管理配置文件

创建 AccuRev 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建源代码管理配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框中选择 AccuRev。
  6. 如果需要，键入有效的 AccuRev 用户名和密码。
  7. 键入要访问的 AccuRev 服务器的 AccuRev 服务器名称。如果不使用 AccuRev 的默认端口，请键入 <服务器名称>:<端口号>。
  8. 输入 AccuRevStream 的名称，如 backing stream。
  9. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  10. 键入希望此配置文件使用的项目路径。单击浏览以显示选择项目路径对话框。 此时将打开选择项目路径对话框。在树视图中选择所需的项目路径，然后单击确定。通过将此文本框留空，可将项目路径设置为根目录。
  11. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： AccuRev


编辑 AccuRev 源代码管理配置文件

要修改 AccuRev 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 编辑用户名和密码。 这些凭据用于访问您的存储库。
  6. 编辑要访问的 AccuRev 服务器的 AccuRev 服务器名称。如果不使用 AccuRev 的默认端口，请键入 <服务器名称>:<端口号>。
  7. 编辑 AccuRevStream 的名称，例如 backing stream。
  8. 可选：编辑 Silk Central 执行服务器将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  9. 编辑希望此配置文件使用的项目路径。
  10. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： AccuRev


Apache Commons 虚拟文件系统

本节介绍如何配置虚拟文件系统 (VFS) 源代码管理配置文件。

VFS 是更具体的文件系统之上的一个抽象层。VFS 旨在允许客户端应用程序以统一的方式访问不同类型的具体文件系统。Apache Commons VFS 提供了一个 API 来访问各种文件系统。它为各种来源的文件提供了统一的视图。Silk Central 当前支持 VFS 的协议包括：

协议
说明
http
复制给定文件。此协议类型也支持复制和解压 ZIP、JAR 或其他压缩文件。需要在 http 服务器上指定 .zip 文件。例如 zip:http://myTestServer/myTests.zip。.zip 文件将在执行服务器上进行解压。
ftp
复制给定文件。此协议类型也支持复制和解压 ZIP、JAR 或其他压缩文件。
smb
服务器消息块 (smb) 可复制所有文件和文件夹。此协议可用于代替 UNC 配置文件。例如，VFS smb 路径 smb://server-name/shared-resource-path 相当于 UNC 路径 \\server-name\shared-resource-path。
注： 创建将 VFS 用于源代码管理的新 ProcessExecutor 测试时，您需要在可执行文件名文本框中指定可执行文件的完整路径。
  • 添加 VFS 源代码管理配置文件
    创建 VFS 源代码管理配置文件，以从 VFS 检索用于测试执行的程序源代码。
  • 编辑 VFS 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 VFS 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加 VFS 源代码管理配置文件

创建 VFS 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建源代码管理配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框中选择 VFS。
  6. 键入要访问的 VFS 存储库的 URL。此字段区分大小写。 在 URL 中指定相应的协议类型：
    FTP
    ftp://<FTP 服务器 URL>
    HTTP
    http://<HTTP 服务器 URL>
    SMB
    smb://<Samba 服务器 URL>
    注： HTTP、FTP 和 SMB 也支持压缩文件。为了指向压缩文件，URL 必须调整为 <压缩文件类型>:<协议>://<指向压缩文件的服务器 URL> 以包括压缩文件的类型。例如，zip:http://193.80.200.135/<路径>/archive.zip 或 jar:http://193.80.200.135/<路径>/archive.jar。
  7. 键入有效的 VFS 用户名和密码。 这些凭据将用于访问您的 VFS 存储库。SMB 协议允许在用户名中包括以下格式的域名：domain/username。
  8. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  9. 键入希望此配置文件使用的项目路径。单击浏览以显示选择项目路径对话框。 此时将打开选择项目路径对话框。在树视图中选择所需的项目路径，然后单击确定。通过将此文本框留空，可将项目路径设置为根目录。
  10. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： Apache Commons 虚拟文件系统


编辑 VFS 源代码管理配置文件

要修改 VFS 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 编辑您要访问的 VFS 存储库的 URL。
    注： 此字段区分大小写。
  6. 编辑用户名和密码。 这些凭据用于访问您的存储库。
  7. 可选：编辑 Silk Central 执行服务器将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  8. 编辑希望此配置文件使用的项目路径。
  9. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： Apache Commons 虚拟文件系统


Git

本部分介绍如何配置 Git 源代码管理配置文件。

Git 是一个分布式修订控制和源代码管理 (SCM) 系统，着重于速度。每一个 Git 工作目录都是一个全面性存储库，具有完整的历史记录和全版本跟踪功能，不依赖于网络访问或中心服务器。

  • 添加 Git 源代码管理配置文件
    创建 Git 源代码管理配置文件，以从 Git 检索用于测试执行的程序源代码。
  • 编辑 Git 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 Git 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加 Git 源代码管理配置文件

创建 Git 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建源代码管理配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框中选择 Git。
  6. 键入要访问的 Git存储库的 URL。
    注： 此字段区分大小写。
  7. 如果需要，键入有效的 Git 用户名和密码。
  8. 可选：指定分支可签出特定分支。将此字段留空可签出主分支。
  9. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  10. 键入希望此配置文件使用的项目路径。单击浏览以显示选择项目路径对话框。 此时将打开选择项目路径对话框。在树视图中选择所需的项目路径，然后单击确定。通过将此文本框留空，可将项目路径设置为根目录。
  11. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

提示： 如果您想要为特定执行计划签出存储库的特定分支，请在相应执行计划的源代码管理标签字段中指定分支名称。请参阅创建执行计划，了解详细信息。此操作会覆盖 Git 源代码管理配置文件中指定的分支。
父主题： Git
相关任务
创建执行计划


编辑 Git 源代码管理配置文件

要修改 Git 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 键入要访问的 Git存储库的 URL。
    注： 此字段区分大小写。
  6. 编辑用户名和密码。 这些凭据用于访问您的存储库。
  7. 可选：指定分支可签出特定分支。将此字段留空可签出主分支。
  8. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  9. 键入希望此配置文件使用的项目路径。单击浏览以显示选择项目路径对话框。 此时将打开选择项目路径对话框。在树视图中选择所需的项目路径，然后单击确定。通过将此文本框留空，可将项目路径设置为根目录。
  10. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

提示： 如果您想要为特定执行计划签出存储库的特定分支，请在相应执行计划的源代码管理标签字段中指定分支名称。请参阅创建执行计划，了解详细信息。此操作会覆盖 Git 源代码管理配置文件中指定的分支。
父主题： Git
相关任务
创建执行计划


Microsoft Team Foundation Server

此部分介绍如何配置 Team Foundation Server (TFS) 源代码管理配置文件。

目前支持与 Silk Central 集成的 TFS 版本： Team Foundation Server 2012、2013、2015

注： 要添加 TFS 源代码管理配置文件，Microsoft Visual Studio Team Explorer Everywhere 2015 命令行客户端（英语版）需要安装在您要在其上使用源代码管理配置文件的前端服务器和每个执行服务器上。您可以从 Microsoft 下载中心下载 CLC。您必须运行 Team Explorer Everywhere 并接受许可协议才能执行集成工作。有关更多信息，请参阅此知识库文章。
  • 添加 TFS 源代码管理配置文件
    创建 TFS 源代码管理配置文件，以从 TFS 检索用于测试执行的程序源代码。
  • 编辑 TFS 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 TFS 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加 TFS 源代码管理配置文件

要添加 TFS 源代码管理配置文件，Microsoft Visual Studio Team Explorer Everywhere 2015 命令行客户端（英语版）需要安装在您要在其上使用源代码管理配置文件的前端服务器和每个执行服务器上。您可以从 Microsoft 下载中心下载 CLC。您必须运行 Team Explorer Everywhere 并接受许可协议才能执行集成工作。有关更多信息，请参阅此知识库文章。

创建 TFS 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建源代码管理配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框选择 Team Foundation Server。
  6. 输入 TFS 安装的 URL。 例如，http://tfsserver:8080/tfs。
  7. 键入 TFS 用户的域。
  8. 键入有效的用户名和密码。 这些凭据将用于访问您的存储库。
  9. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  10. 键入希望此配置文件使用的项目路径。单击浏览以显示选择项目路径对话框。 此时将打开选择项目路径对话框。在树视图中选择所需的项目路径，然后单击确定。通过将此文本框留空，可将项目路径设置为根目录。
  11. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： Microsoft Team Foundation Server


编辑 TFS 源代码管理配置文件

要添加 TFS 源代码管理配置文件，Microsoft Visual Studio Team Explorer Everywhere 2015 命令行客户端（英语版）需要安装在您要在其上使用源代码管理配置文件的前端服务器和每个执行服务器上。您可以从 Microsoft 下载中心下载 CLC。您必须运行 Team Explorer Everywhere 并接受许可协议才能执行集成工作。有关更多信息，请参阅此知识库文章。

要修改 TFS 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 编辑您要访问的 TFS 存储库的 URL。
  6. 编辑用户名和密码。 这些凭据用于访问您的存储库。
  7. 可选：编辑 Silk Central 执行服务器将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  8. 编辑希望此配置文件使用的项目路径。
  9. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： Microsoft Team Foundation Server


Silk Test Workbench

本部分介绍如何配置 Silk Test Workbench 源代码管理配置文件。

Silk Test Workbench 是一种自动化测试工具，可加快复杂应用程序的功能测试。Silk Test Workbench可为使用各种开发工具开发的测试应用程序提供支持，这些工具包括 Java、.NET、基于浏览器的 Web 应用程序，以及包括 ActiveX 控件和自动化对象的 COM 组件。通过 Silk Test Workbench，您可以使用应用程序记录用户会话以创建测试，通过添加验证和测试逻辑增强测试，还可回放测试以确保应用程按预期工作。

注： 要添加 Silk Test Workbench 源代码管理配置文件，必须在您要使用源代码管理配置文件的每个执行服务器上安装 Silk Test Workbench 客户端。
  • 添加 Silk Test Workbench 源代码管理配置文件
    创建 Silk Test Workbench 源代码管理配置文件，以从 Silk Test Workbench 检索用于测试执行的程序源代码。
  • 编辑 Silk Test Workbench 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 Silk Test Workbench 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加 Silk Test Workbench 源代码管理配置文件

创建 Silk Test Workbench 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建问题跟踪配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框中选择 Silk Test Workbench 测试。
  6. 从数据库类型列表框中选择数据库类型，SQL Server 或 Oracle。
    注： 不支持 Microsoft Office Access 数据库类型。连接到 Silk Test Workbench Oracle 数据库时，Silk Test Workbench 要求 TNS 名称必须与主服务器名称相同。
  7. 在数据库服务器文本框中，输入 Silk Test Workbench 数据库服务器的名称。
  8. 在数据库名称文本框中，输入 Silk Test Workbench 数据库的名称。
  9. 在数据库端口文本框中，输入 Silk Test Workbench 数据库服务器的端口号。
  10. 在数据库架构/所有者名称文本框中，输入 Silk Test Workbench 数据库架构或所有者名称。
  11. 在数据库用户文本框中，输入数据库用户的名称。
  12. 在数据库密码文本框中，键入数据库用户的密码。
  13. 可选：在 Silk Test Workbench 用户名和 Silk Test Workbench 密码字段中，输入有效 Silk Test Workbench 用户的用户名和密码。如果这些字段留空，则将使用运行执行服务器服务的 Windows 用户。
  14. 单击检索。 所有项目都会列于项目列表中。
  15. 选择一个或多个项目。
  16. 单击确定。
父主题： Silk Test Workbench


编辑 Silk Test Workbench 源代码管理配置文件

要修改 Silk Test Workbench 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 编辑 Silk Test Workbench 数据库类型。
    注： 不支持 Microsoft Office Access 数据库类型。
  6. 根据需要编辑其他设置。
  7. 单击确定。
父主题： Silk Test Workbench


StarTeam

本部分介绍如何配置 StarTeam 源代码管理配置文件。

StarTeam 可通过集中控制所有项目资产促进团队沟通和协作。受保护的灵活访问可确保团队成员通过广泛选择（例如 Web、桌面、IDE 和命令行客户端）随时随地工作。StarTeam 提供独特全面的解决方案，包括集成需求管理、更改管理、缺陷跟踪、文件版本控制、线程讨论以及项目和任务管理。

目前支持与 StarTeam 集成的 Silk Central 版本：StarTeam 15.x、16.x

  • 添加 StarTeam 源代码管理配置文件
    创建 StarTeam 源代码管理配置文件，以从 StarTeam 检索用于测试执行的程序源代码。
  • 编辑 StarTeam 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 StarTeam 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加 StarTeam 源代码管理配置文件

创建 StarTeam 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建源代码管理配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框中选择 StarTeam。
  6. 加入 StarTeam 服务器的主机名。
  7. 键入用于连接到 StarTeam 服务器的端口。 如果端口未发生更改，请使用默认端口 49201。
  8. 键入有效的用户名和密码。 这些凭据将用于访问您的存储库。
  9. 指定配置文件是否支持加密。
  10. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  11. 键入希望此配置文件使用的项目路径。单击浏览以显示选择项目路径对话框。 此时将打开选择项目路径对话框。在树视图中选择所需的项目路径，然后单击确定。通过将此文本框留空，可将项目路径设置为根目录。
  12. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： StarTeam


编辑 StarTeam 源代码管理配置文件

要修改 StarTeam 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从以下选项中进行选择：
    • 编辑 StarTeam 服务器的主机名。
    • 编辑用于连接到 StarTeam 服务器的端口。 如果端口未发生更改，请使用默认端口 49201。
    • 指定配置文件是否支持加密。
  6. 编辑希望此配置文件使用的项目路径。
  7. 编辑用户名和密码。 这些凭据用于访问您的存储库。
  8. 可选：编辑 Silk Central 执行服务器将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  9. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： StarTeam


子版本

本部分介绍如何配置子版本 (SVN) 源代码管理配置文件。

子版本 (SVN) 是并发版本系统 (CVS) 的后续。 子版本利用事务号管理版本。 每次提交后事务号都会递增。

其他源代码管理系统称为标签的内容，子版本将其称为标记。 这些标记在子版本 URL 中编码。 例如，http://MyHost/svn/MyApp/trunk 是子版本 URL，http://MyHost/svn/MyApp/tags/build1012 是子版本标记。

Silk Central 支持子版本标记。 如果子版本 URL 包含 trunk 目录，则您可以定义标签 tags/build1012。 此标签将替换子版本 URL 中的 trunk。

注： 如果子版本 URL 不包含 trunk，并且您定义了标签，则 Silk Central 将抛出错误。
  • 添加子版本源代码管理配置文件
    创建子版本源代码管理配置文件，以从 Subversion 检索用于测试执行的程序源代码。
  • 编辑 Subversion 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 Subversion 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加子版本源代码管理配置文件

创建子版本源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建源代码管理配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框中选择子版本。
  6. 键入要访问的子版本存储库的 URL。
    如果不知道存储库的 URL，请咨询您的子版本管理员。
    注： 要使用 SSH，请将 ssh 添加到 URL，例如 svn+ssh://<hostname>:<port>。
  7. 键入有效的用户名和密码。 这些凭据将用于访问您的存储库。
  8. 键入有效的 SSH 用户名和 SSH 密码或 SSH keyfile。 这些凭据用于访问 SSH 服务器。密码将覆盖 keyfile，因此如果您只有 keyfile，请将 SSH 密码文本框留空。如果您使用 keyfile，则 keyfile 的路径必须在每个使用源代码管理配置文件的执行服务器上均有效。
  9. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  10. 键入希望此配置文件使用的项目路径。单击浏览以显示选择项目路径对话框。 此时将打开选择项目路径对话框。在树视图中选择所需的项目路径，然后单击确定。通过将此文本框留空，可将项目路径设置为根目录。
  11. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： 子版本


编辑 Subversion 源代码管理配置文件

要修改 Subversion 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 编辑您要访问的 Subversion 存储库的 URL。 如果您不知道存储库的 URL，请咨询您的 Subversion 管理员。
    注： 当编辑 Subversion 存储库的 URL 时，如果您不能签出文件，请删除执行服务器上的源代码管理控制镜像目录。 例如 C:\ProgramData\SilkCentral\SrcCtrlMirrors。
    注： 要使用 SSH，请将 ssh 添加到 URL，例如 svn+ssh://<hostname>:<port>。
  6. 编辑用户名和密码。 这些凭据用于访问您的存储库。
  7. 键入有效的 SSH 用户名和 SSH 密码或 SSH keyfile。 这些凭据用于访问 SSH 服务器。密码将覆盖 keyfile，因此如果您只有 keyfile，请将 SSH 密码文本框留空。如果您使用 keyfile，则 keyfile 的路径必须在每个使用源代码管理配置文件的执行服务器上均有效。
  8. 可选：编辑 Silk Central 执行服务器将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。
  9. 编辑希望此配置文件使用的项目路径。
  10. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： 子版本


SilkTestPartner

本部分介绍如何配置 TestPartner 源代码管理配置文件。

TestPartner 是一款 Micro Focus 产品，用于测试使用 Microsoft 技术的 Web 和 Microsoft Windows 应用程序。TestPartner 记录用户操作以便快速产生强大的测试。每个记录的测试以清晰简明的步骤显示为一系列操作，所有测试工程师（从新手到专家）都可以轻松理解。您可以使用应用程序记录用户会话、添加验证函数并且随后回放会话，以确保应用程序按预期工作。

注： 要添加 TestPartner 源代码管理配置文件，必须在您要使用源代码管理配置文件的每个执行服务器上安装 TestPartner 客户端。
  • 添加 TestPartner 源代码管理配置文件
    创建 TestPartner 源代码管理配置文件，以从 TestPartner 检索用于测试执行的程序源代码。
  • 编辑 TestPartner 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 TestPartner 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加 TestPartner 源代码管理配置文件

创建 TestPartner 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建源代码管理配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框中选择 TestPartner。
    注： 连接到 TestPartner Oracle 数据库时，TestPartner 要求 TNS 名称必须与主服务器名称相同。
  6. 从数据库类型列表框中选择数据库类型，SQL Server 或 Oracle。
  7. 在数据库服务器文本框中键入数据库服务器的名称。
  8. 在数据库名称文本框中，键入数据库的名称。
  9. 在数据库端口文本框中，键入数据库服务器的端口号。
  10. 在数据库架构/所有者名称文本框中，键入数据库架构或所有者名称。
  11. 在数据库用户文本框中，键入数据库用户的名称。
  12. 在数据库密码文本框中，键入数据库用户的密码。
  13. 键入有效的用户名和密码。 这些凭据将用于访问您的存储库。
  14. 使用项目路径文本框筛选数据库中可用作测试的脚本。单击浏览以显示选择项目路径对话框。
    选择项目路径对话框提供了一个三层的树，您可从其中进行选择：
    第一层
    整个 TestPartner 数据库。请注意，如果选择此层，项目路径文本框将保留空白。
    第二层
    TestPartner 项目。
    第三层
    指定 TestPartner 项目中的脚本类型。

    选择前面的选项之一，然后单击确定。路径将添加到项目路径文本框。

  15. 单击确定。
父主题： SilkTestPartner


编辑 TestPartner 源代码管理配置文件

要修改 TestPartner 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从以下选项中进行选择：
    • 编辑 TestPartner 数据库类型。
    • 编辑 TestPartner 数据库服务器。
    • 编辑 TestPartner 数据库名称。
    • 编辑 TestPartner 数据库服务器的 TestPartner 号。
    • 编辑 TestPartner 数据库架构/所有者名称。
    • 编辑 TestPartner 数据库用户。
    • 编辑 TestPartner 数据库密码。
  6. 编辑用户名和密码。 这些凭据用于访问您的存储库。
  7. 编辑希望此配置文件使用的项目路径。
  8. 单击确定。
父主题： SilkTestPartner


通用命名约定

本部分介绍如何配置通用命名约定 (UNC) 源代码管理配置文件。

UNC 是通用命名约定的简称，是一种 PC 格式，用于指定局域网络 (LAN) 中的资源位置。UNC 使用以下格式：\\server-name\shared-resource-pathname。

例如，要访问共享服务器 silo 上目录 examples 中的文件 test.txt，您要写入：\\silo\examples\test.txt。

您也可以使用 UNC 识别打印机等共享外围设备。UNC 的理念旨在提供一个格式，以便每个共享资源可以使用唯一地址识别。

仅 Microsoft Windows 操作系统支持 UNC。如果您计划使用非 Windows 执行服务器，则可以使用 Apache Commons VFS 源代码管理配置文件代替。

  • 添加 UNC 源代码管理配置文件
    创建 UNC 源代码管理配置文件，以从 UNC 检索用于测试执行的程序源代码。
  • 编辑 UNC 源代码管理配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 UNC 源代码管理配置文件。
父主题： 源代码管理配置文件
父主题： 源代码管理配置文件集成


添加 UNC 源代码管理配置文件

创建 UNC 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击新建配置文件以打开新建源代码管理配置文件对话框。
  4. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 从源代码管理系统列表框中选择 UNC。
  6. 键入要访问的 UNC 路径。 此路径是测试源所在位置的路径。
    提示： 为避免检出不必要的文件，请在测试执行实际需要的源代码所在的层次结构级别指定文件夹。
  7. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。如果不需要静态工作文件夹，请确保该文件夹没有位于指定的 UNC 路径内，否则将会导致递归检出。
  8. 键入有效的 UNC 用户名和 UNC 密码。 需要这些凭据才能访问配置文件的 UNC 路径。
  9. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： 通用命名约定


编辑 UNC 源代码管理配置文件

要修改 UNC 源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 单击要修改的源代码管理配置文件的名称。 此时将打开编辑源代码管理配置文件对话框。
  4. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  5. 键入要访问的 UNC 路径。 此路径是测试源所在位置的路径。
    提示： 为避免检出不必要的文件，请在测试执行实际需要的源代码所在的层次结构级别指定文件夹。
  6. 可选：键入 Silk Central 执行服务器应将源代码文件复制到的常用工作文件夹。 工作文件夹必须为本地路径。例如 C:\TempSources\。
    警告： 建议将此字段留空，让 Silk Central 改用临时工作文件夹。指定静态工作文件夹可能导致运行并行执行时出现意外结果。临时位置可通过预定义参数 #sctm_source_root_dir 查询。如果不需要静态工作文件夹，请确保该文件夹没有位于指定的 UNC 路径内，否则将会导致递归检出。
  7. 编辑 UNC 用户名和 UNC 密码。 需要这些凭据才能访问配置文件的 UNC 路径。
  8. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。

如果测试连接成功，您将返回源代码管理页面。

父主题： 通用命名约定


删除源代码管理配置文件

要删除源代码管理配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击源代码管理选项卡。 此时将打开源代码管理页面，列出已为系统创建的所有源代码管理配置文件。
  3. 在要删除的源代码管理配置文件的操作列中，单击删除源代码管理配置文件...。 此时将显示确认对话框。
  4. 单击是。 您将返回源代码管理页面。
父主题： 源代码管理配置文件


源代码管理配置文件页面

项目：<项目名称> > 项目设置 > 源代码管理

使用此页配置配置文件，以便使外部源代码管理系统与 Silk Central 集成。单击新建配置文件以创建新的源代码管理配置文件。对于每个源代码管理配置文件，页面显示以下列：

项 | 说明
名称 | 在 Silk Central GUI 和报告中显示的配置文件名称。单击名称可编辑配置文件。
类型 | 外部源代码管理系统。
工作文件夹 | 临时来源签出到的本地或映射工作文件夹。
创建于 | 创建源代码管理配置文件的日期。
创建者 | 创建源代码管理配置文件的用户。
更改时间 | 上次修改源代码管理配置文件的日期。
更改者 | 上次修改源代码管理配置文件的用户。
操作 | 删除源代码管理配置文件
父主题： 源代码管理配置文件


步骤属性

使用步骤属性展开具有其他属性的手动测试步骤。 在项目：<项目名称> > 项目设置中将自定义步骤属性添加到项目，以便将属性添加到项目中的所有手动测试步骤。 将自定义步骤属性添加到库树中的库，以便将自定义步骤属性添加到库中的所有手动测试步骤。 随后可以在编辑手动测试步骤对话框中编辑步骤属性以及默认属性。

  • 创建步骤属性
    创建步骤属性以扩展手动测试步骤。
  • 编辑步骤属性
    介绍如何编辑步骤属性。
  • 删除步骤属性
    介绍如何删除步骤属性。
  • 步骤属性页面
    列出了在整个活动项目中可填充到手动测试步骤的所有属性。
父主题： 配置测试设置和集成
父主题： 项目设置


创建步骤属性

创建新步骤属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击步骤属性选项卡。
  3. 单击新建属性。 将打开新建步骤属性对话框。
  4. 在名称文本框中输入新属性的名称。
    注： 步骤属性字段始终声明为字符串类型。
  5. 单击确定以使您的属性可用于所选 Silk Central 项目中的所有手动测试步骤。
    注： 要为库创建步骤属性，请在库树中选择库节点，然后继续第二步。
父主题： 步骤属性


编辑步骤属性

要编辑以前创建的步骤属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击步骤属性选项卡。
  3. 单击要编辑的属性的名称。 此时将打开编辑步骤属性对话框。
  4. 在名称字段中编辑属性的名称。
  5. 单击确定以保存您所做的更改，或单击取消以中止操作而不保存更改。
父主题： 步骤属性


删除步骤属性

要删除以前创建的步骤属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击步骤属性选项卡。
  3. 单击要删除的属性的操作列中的删除属性。 此时将显示确认对话框，要求您确认删除。
  4. 单击是以完成操作，或单击否以中止。
父主题： 步骤属性


步骤属性页面

项目：<项目名称> > 项目设置 > 步骤属性

步骤属性页面列出了在整个活动项目中可填充到手动测试步骤的所有属性。 对于每个自定义步骤属性，步骤属性页面显示以下列：

列 | 说明
名称 | 步骤属性的名称。
操作 可以对属性执行以下操作：
  • 删除属性
  • 上移
  • 下移
父主题： 步骤属性


属性

您可使用自定义属性自定义测试和执行计划信息。虽然部分属性通过 Silk Central 的集成功能提供（例如，优先级、组件和平台），但建议您定义自定义属性，以根据需要对测试进行分类或使测试与特定测试用例兼容。

  • 创建自定义属性
    创建自定义属性以自定义测试和执行计划信息。
  • 自定义属性和需求属性类型
    详述属性和需求属性的类型。
  • 编辑自定义属性
    编辑自定义属性以根据测试需要应用自定义。
  • 删除自定义属性
    如果不再需要自定义信息，则可删除自定义属性。
  • 属性页面
    列出已为当前项目创建的属性。
父主题： 配置测试设置和集成
父主题： 项目设置


创建自定义属性

创建自定义属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击属性选项卡以查看当前属性列表。
  3. 单击新建属性。 将显示新建属性对话框。
  4. 键入新属性的名称。当属性可用时，此名称将显示在列表框中。
  5. 键入新属性的说明。
  6. 选择属性类型。有关每个属性类型的说明，请参阅自定义属性和需求属性类型主题。
  7. 单击确定。
父主题： 属性
相关参考
自定义属性和需求属性类型


编辑自定义属性

要编辑自定义属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击属性选项卡以查看当前属性列表。
  3. 单击要编辑的属性的名称。 此时将显示编辑属性对话框。
  4. 编辑属性的名称。 如果属性可供使用，则名称将显示在筛选器、执行计划和测试的列表框中。可在按属性进行筛选的全局筛选器中使用属性，并且可应用到测试和执行计划。
  5. 编辑属性的说明。
  6. 有关每个属性类型的说明，请参阅自定义属性和需求属性类型主题。您有不同的编辑选项，具体取决于属性数据类型。
  7. 单击确定。 您将返回属性列表。
父主题： 属性
相关概念
测试属性
筛选器
相关参考
自定义属性和需求属性类型


删除自定义属性

要删除自定义属性：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击属性选项卡以查看当前属性列表。
  3. 在删除属性之前，您必须先停用它。在状态列中，单击活动链接或图标，然后单击确认对话框上的是以停用属性。
  4. 一旦属性处于非活动状态，单击删除属性即可删除它。 此时将显示确认对话框，要求您确认删除。
  5. 单击是以删除选定的属性；或者单击否以中止操作。 如果您单击是，您将返回属性页面，已删除的属性将不再显示在该页面上。
  6. 如果显示错误，请确保所选属性未应用于任何测试或执行计划，或未在任何全局筛选器中使用。您只能删除未使用的属性。
父主题： 属性


属性页面

项目：<项目名称> > 项目设置 > 属性

属性页面会列出已为当前项目创建的属性。对于每种属性，属性页面会显示以下列：

列 | 说明
操作 | 可对属性执行的可用操作。
名称 | 属性的名称。如果属性可供使用，则名称将显示在筛选器、执行计划和测试的列表框中。可在按测试属性进行筛选的全局筛选器中使用属性，并且可应用到测试和执行计划。 单击编辑图标以编辑属性的名称。
类型 | 属性类型。有关每个属性类型的说明，请参阅自定义属性和需求属性类型主题。
状态 | 属性的状态，活动或非活动。
报告列 | LQM Reporting 表中的属性列名称。使用此列名称在 LQM Reporting 表中查询所选属性。有关详细信息，请参阅数据库模型文档。
创建于 | 创建属性的时间。
创建者 | 创建属性的用户。
更改时间 | 最近修改属性的时间。
更改者 | 最近修改属性的用户。
父主题： 属性
相关参考
自定义属性和需求属性类型


用于数据驱动测试的数据源

数据驱动测试是源自现有数据源（例如，电子表格或数据库）中的值的测试。数据源在项目特定范围内进行管理。
提示： 要将数据源中的更改确认至 Silk Central，您必须在更新或更改数据源时将数据源配置文件与数据源进行同步。
  • 数据源限制
    数据源具有特定的限制，以防 Silk Central 由于生成过多数据而进入不稳定状态。
  • 配置 JDBC 数据源
    为数据驱动测试配置 JDBC 数据源，以在 Silk Central 中同步测试。
  • 配置 Microsoft Excel 或 CSV 数据源
    为数据驱动测试配置 Microsoft Excel 或 CSV 数据源，以在 Silk Central 中同步测试。
  • 从数据源下载 Excel 文件
    从 Silk Central 数据源下载 Excel 文件。
  • 同步数据源
    同步数据源，以使用数据源中的更改更新相关测试。
  • 将更新的 Excel 文件上载到数据源
    将更新的 Excel 文件上载到数据源以替换当前上载的文件。
  • 删除数据源
    如果不再需要，则可永久删除数据源。
  • 数据源配置页面
    列出为实现数据驱动测试与 Silk Central 集成而配置的所有数据源。
父主题： 配置测试设置和集成
父主题： 项目设置
相关概念
数据驱动测试
创建数据驱动测试


数据源限制

数据源具有特定的限制，以防 Silk Central 由于生成过多数据而进入不稳定状态。

原子测试与非原子测试

有关 Silk Central 中可用的数据驱动测试类型的详细信息，请参阅原子和非原子数据驱动测试。

限制

数据驱动测试的数据源具有以下默认限制：
  • 非原子测试不能超过 100 行
  • 原子测试不能超过 1000 行
  • XLSX 数据源不能超过 20000 行 + 单元格（20000 指行数量与单元格数量之和。例如：如果您有 3000 行、6 列，则计算数量为 3000 + (3000 * 6) = 21000，因此超出了限制。）
  • 数据集名称（Excel 工作表名称/表名称）不能超过 220 个字符
  • 列键名称不能超过 220 个字符
  • JDBC、Excel 和 CSV 数据源的所有主键的串联长度不能超过 255 个字符
  • 每个单元格不能超过 2000 个字符（超过此长度的字符串将被截断）。请注意，数据驱动型 Silk Test Classic 测试仅接受用引号引起来的数据源字符串。如果某个单元格中的字符串长度超过 2000 个字符，则字符串将被截断，并且尾部引号将会丢失，从而导致错误。

修改默认限制

如果需要，您可修改默认限制。但请谨慎修改这些值，以免生成过多数据。在尝试修改这些默认值之前，请停止应用程序服务器，并在保存更改后重新启动服务器。

原子和非原子测试的行限制可在 TmAppServerHomeConf.xml 文件中配置。此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\AppServer。分别修改 Config/DataDriven/MaxRowsAtomic 和 Config/DataDriven/MaxRows XML 标记的值。

XLSX 单元格限制可在 Excel 数据源插件 (DS-Excel.zip) 的 configuration.properties 文件中配置。此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Plugins。相应地修改 excel.importcelllimit 属性的值。

父主题： 用于数据驱动测试的数据源


配置 JDBC 数据源

警告：
JDBC 数据源的所有主键的串联长度不能超过 255 个字符。

配置 JDBC 数据源：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击数据源选项卡。 此时将显示数据源页面，列出已为系统创建的所有数据源。
  3. 单击新建数据源以打开新建数据源对话框。
  4. 为数据源键入名称。
  5. 从数据源类型列表框中，选择 JDBC。
    注： 如果要设置 ODBC 数据源，您需要手动插入 ODBC 驱动程序类和 URL。例如，驱动程序类：sun.jdbc.odbc.JdbcOdbcDriver, URL：jdbc:odbc:MyDatabaseName。您还必须在 MS Windows 的管理工具中设置 ODBC 数据源。有关更多信息，请参阅 Microsoft Windows 帮助。如果前端服务器和应用程序服务器位于不同计算机上，请确保在 Microsoft Windows 中设置的系统数据源名称与 ODBC 数据源相同。这些名称区分大小写。
  6. 如果选择 JDBC 作为数据源类型，将自动填充驱动程序类文本框。在 URL 文本框中，将主机名值 <hostname> 替换为托管数据源的计算机名称，并将数据库名称值 <databasename> 替换为目标数据库名称。
  7. 在用户名和密码文本框中，输入有效数据库凭据。
  8. 可选：如果使用包括多个表的数据库并且想要将数据源缩小至特定表，您可浏览至要包括的特定表并选中：
    1. 单击表筛选器文本框旁边的 [...]。
    2. 将显示选择表筛选器对话框。选择要包括为数据源的表。
    3. 单击确定。
  9. 可选：测试使用关键列选项来定义数据源中用作主键的工作表列。如果数据源将进行编辑（例如，在工作表中添加或删除行），这会非常有用。即使数据源已编辑，测试仍然能够确定应使用的列或行。从数据驱动数据源创建的测试在其名称中使用关键列值而非列号。 配置关键列：
    1. 单击关键列文本框旁边的 [...]。
    2. 将显示选择关键列对话框。从列列表中选择用作关键列的列。
    3. 单击确定。
  10. 在新建数据源对话框上，单击确定。
父主题： 用于数据驱动测试的数据源


配置 Microsoft Excel 或 CSV 数据源

警告：
使用密码保护的 Excel 工作表不能配置为 Silk Central 的数据源。关闭工作表的密码保护，以将其用作数据驱动测试的数据源。Excel 和 CSV 的所有主键的串联长度也不能超过 255 个字符。

配置 Microsoft Excel 或 CSV 数据源：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击数据源选项卡。 此时将显示数据源页面，列出已为系统创建的所有数据源。
  3. 单击新建数据源以打开新建数据源对话框。
  4. 为数据源键入名称。
  5. 从数据源类型列表框中，选择 MS Excel 以配置 Microsoft Excel 数据源，或选择 CSV 以配置 CSV 数据源。
  6. 从源代码管理配置文件列表框中，选择托管数据文件的预先配置源代码管理配置文件。有关源代码管理配置文件的详细信息，请参阅源代码管理配置文件。
  7. 单击浏览以打开选择源代码管理路径对话框。浏览至并选择源代码管理路径中所选类型的数据源文件。
  8. 可选：仅限 MS Excel。如果使用包括多个工作表的 Excel 电子表格并且想要将数据源缩小至特定工作表，您可浏览至要包括的特定工作表并选中。为此请执行以下操作：
    1. 单击工作表筛选器文本框旁边的 [...]。
    2. 将显示选择工作表筛选器对话框。选择要包括为数据源的工作表。
    3. 单击确定。
  9. 可选：测试使用关键列选项来定义数据源中用作主键的工作表列。如果数据源将进行编辑（例如，在工作表中添加或删除行），这会非常有用。即使数据源已编辑，测试仍然能够确定应使用的列或行。从数据驱动数据源创建的测试在其名称中使用关键列值而非列号。
    注： 仅限 MS Excel：如果数据源包括多个工作表，则仅可将具有相同名称的列定义为关键列。

    配置关键列：

    1. 单击关键列文本框旁边的 [...]。
    2. 将显示选择关键列对话框。从列列表中选择用作关键列的列。
    3. 单击确定。
  10. 在新建数据源对话框上，单击确定。
父主题： 用于数据驱动测试的数据源
相关概念
源代码管理配置文件


从数据源下载 Excel 文件

注： 无法从 JDBC 和 ODBC 数据源下载文件。

要从数据源下载 Excel 文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击数据源选项卡。 此时将显示数据源页面，列出已为系统创建的所有数据源。
  3. 单击要从中下载的数据源的操作列中的下载图标。 此时将显示文件下载对话框。
  4. 单击打开以立即打开文件，或单击保存以指定要保存文件的本地系统目标位置。
父主题： 用于数据驱动测试的数据源


同步数据源

如果您要使 Silk Central 了解更改，则必须每次在更改或更新数据源时使其同步。 同步数据源可将最新更改传播到相关测试。

同步更新的数据源：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击数据源选项卡。 此时将显示数据源页面，列出已为系统创建的所有数据源。
  3. 单击对应于数据源的操作列中的同步图标，以将更新的文件传播到相关测试。
  4. 此时将显示确认对话框，要求您确认同步。 单击是将所有测试与更新的数据源同步，或单击否中止同步。
    警告：
    同步数据源时，将中止依赖于此数据源的所有运行执行。 这些执行中未完成的测试结果将丢失。
  5. 单击成功消息对话框中的确定。
父主题： 用于数据驱动测试的数据源


将更新的 Excel 文件上载到数据源

注： 文件无法上载到 JDBC 和 ODBC 数据源。

将更新的 Excel 文件上载到数据源：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击数据源选项卡。 此时将显示数据源页面，列出已为系统创建的所有数据源。
  3. 单击您要从中下载的数据源的操作列中的上载图标。
  4. 单击上载文件对话框中的浏览...。
  5. 选择您要用于替换当前上载的 Excel 文件的已更新 Excel 文件。 单击打开。
  6. 单击上载文件对话框中的确定。
  7. 此时将显示确认对话框，要求您确认覆盖现有文件。 单击是以继续。
  8. 上载更新的数据源文件后，将显示另一个对话框，询问您是否同步测试与更新后的数据源。 单击是立即同步，如果您想稍后同步，则单击否。
    注： 上载更新的数据源文件后，您必须同步数据源，以便更新关联的测试。
父主题： 用于数据驱动测试的数据源


删除数据源

注： 无法删除正由测试使用的数据源。

要删除数据源：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击数据源选项卡。 此时将显示数据源页面，列出已为系统创建的所有数据源。
  3. 单击要删除的数据源的操作列中的删除图标。
  4. 此时将显示确认对话框。 单击是以删除数据源；或者单击否以中止删除。
父主题： 用于数据驱动测试的数据源


数据源配置页面

项目：<项目名称> > 项目设置 > 数据源

数据源页面列出为实现数据驱动测试与 Silk Central 集成而配置的所有数据源。单击新建数据源以创建新数据源。对于每个数据源，该页面会显示以下列：

列 | 说明
名称 | 显示在 Silk Central GUI 和报告中的数据源名称。单击该名称以修改数据源设置。
类型 数据源类型：
  • CSV
  • JDBC
  • MS Excel
文件名 | 用作数据源的文件的名称，例如 datasource.xlsx。
源代码管理配置文件 | 托管数据文件的源代码管理配置文件的名称。
创建于 | 创建数据源的日期。
创建者 | 创建数据源的用户。
更改时间 | 最后修改数据源的日期。
更改者 | 最后修改数据源的用户。
操作 您可对数据源执行以下操作：
  • 删除
  • 下载
  • 上传
  • 同步
父主题： 用于数据驱动测试的数据源


构建测试资产

Silk Central 在一种特定产品的版本和内部版本上下文中跟踪测试执行结果。因此，必须先定义产品，然后才能创建测试。

对于自动测试，创建测试的另一个需求是源代码管理配置文件。 Silk Central 中的自动测试实际上表示源代码管理系统中的测试脚本，您可以通过此类源代码管理配置文件访问这些脚本。产品和源代码管理配置文件信息都是在测试容器层指定的，因此这些信息代表着测试资产结构中的顶层节点。随后，您可以在测试容器中使用文件夹，根据测试需求和进程构建测试资产。

请记住，虽然您可以使用多个测试容器，但由于测试结果/内部版本/版本关系，一个执行计划只能执行一个测试容器的测试。因此，请根据您想通过一个执行计划来执行的测试设计测试资产结构。

  • 测试容器
    测试容器用于构建顶层的测试资产。Silk Central 按容器关联已定义的源代码管理配置文件和产品，这会影响您可以在特定容器内对测试执行的操作。
  • 测试文件夹
    使用文件夹在容器中构建测试。
  • 测试包
    测试包为 Silk Central 中第三方测试类型的结构提供支持，由包根和套件节点与测试节点的任意层次结构组成。
父主题： 测试


测试容器

测试容器用于构建顶层的测试资产。Silk Central 按容器关联已定义的源代码管理配置文件和产品，这会影响您可以在特定容器内对测试执行的操作。

达到测试执行的计划阶段时，只能使用一个特定容器的测试，因此您可能会考虑保留尽可能少的指定容器量。

  • 添加测试容器
    将测试容器添加到测试，以使用为项目定义的源代码管理配置文件以外的其他源代码管理配置文件。
  • 添加容器链接
    向测试树中添加链接，以引用相同项目中的容器。
  • 编辑测试容器
    编辑测试容器的属性。
父主题： 构建测试资产


添加测试容器

注： 我们建议小心使用测试容器，因为它们将产品绑定到源代码管理配置文件。

添加新测试容器：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要向其中添加新容器作为子节点的根节点。
    注： 无法嵌套容器，但可以向容器添加子文件夹。
  3. 单击工具栏上的 新建测试容器 或右键单击节点并选择新建测试容器。

    您也可右键单击节点节点并选择新建测试容器。

    新容器根节点将添加到测试树，并将显示新建测试容器对话框。
  4. 键入容器的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 从列表框中选择与此测试容器关联的任何预定义产品。有关添加产品配置文件的详细信息，请参阅添加产品。
  6. 从源代码管理配置文件列表框中选择预定义源代码管理配置文件。 如果不想为测试容器检出任何测试源（例如，如果只有手动测试），请选择 ---。
    注： Silk Central 执行服务器会从预定义源代码管理配置文件为容器中包括的测试检索程序源代码。根据源代码控制配置文件中的指定路径，您可进行指定，以使用测试容器根节点字段中的子节点。
  7. 可选：选中每次测试执行前清理工作文件夹复选框。

    如果选中，从源代码管理中删除文件的也将同时从工作文件夹中删除。默认为选中状态。

  8. 要指定保存容器的默认根路径，请单击浏览...并导航至位置。
  9. 可选：当 Silk Central 与 Silk Performer集成时，您可定义自定义数据目录和自定义包括目录。 在Silk Performer 中，Include 目录分为一个 System Include 目录和一个 Custom Include 目录。Data 目录分为一个 System Data 目录和一个 Custom Data 目录。有关其他信息，请参阅 Silk Performer 文档。
  10. 您可通过对话框的隐藏测试属性部分指定要显示在测试容器的属性页面上的测试属性类型，以及容器内所有测试文件夹的属性页面。 这些设置不会影响单个测试的显示。
  11. 单击编辑以调整隐藏测试属性设置。 将显示隐藏测试属性对话框。
  12. 取消选中要显示其属性的所有测试类型的复选框。
  13. 单击确定以保存您的设置并关闭隐藏测试属性对话框。
  14. 单击保存以保存您的设置。
新容器将添加到测试树。
父主题： 测试容器
相关概念
源代码管理配置文件
相关任务
添加产品


添加容器链接

在测试树中，您可在相同项目中添加测试容器链接。 已链接测试容器将以只读模式显示在树中插入链接的位置。

添加测试容器链接：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 右键单击要在其下方显示已链接测试容器的测试树中的节点。
  3. 如果要在所选节点的层次结构级别链接测试容器，请选择新建链接，或选择新建子链接以在所选节点的下一级链接测试容器。 将显示选择测试容器进行链接对话框。
  4. 选择要引用的测试容器。
    注： 如果引用的测试容器和您在其中添加链接的容器使用不同源代码管理配置文件，将显示确认对话框，询问您是否确实要创建链接。 当您在已链接容器中下载或执行测试时，测试容器中与其他具有不同源代码管理配置文件的测试容器的链接可能导致问题。 如果要先更改其中一个容器的自定义（包括目录），请单击否，或者，如果无论如何都要创建链接，请单击是。
  5. 单击确定以确认您的选择。
链接的容器作为只读实体放置于所选容器中。 对原始测试容器的任何更改都将反映在链接的容器中。
父主题： 测试容器


编辑测试容器

要编辑测试容器的属性：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要编辑的测试容器。
  3. 单击工具栏中的 编辑 。 您还可以右键单击测试容器，然后选择编辑。 此时将显示编辑测试容器对话框。
  4. 编辑测试容器的属性。
  5. 单击确定以应用您所做的更改。
父主题： 测试容器
相关参考
测试属性


测试文件夹

使用文件夹在容器中构建测试。
  • 添加测试文件夹
    将新测试文件夹添加到测试树。
  • 编辑测试文件夹
    编辑测试文件夹的属性。
  • 对测试文件夹排序
    在测试树中将测试文件夹上移或下移，以便对测试排序。
父主题： 构建测试资产
相关任务
剪切、复制、粘贴和删除测试元素


添加测试文件夹

添加新测试文件夹：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要在其后添加新文件夹的测试元素。
  3. 单击工具栏中的 新建子测试文件夹 。 您也可右键单击元素并选择新建测试文件夹以在所选元素后添加新文件夹，或选择新建子测试文件夹作为所选元素的子节点。
    注： 对于测试容器，您只能将测试文件夹添加为子节点。
    新文件夹节点将追加到测试树，并将显示新建文件夹对话框。
  4. 提供文件夹的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 单击确定以保存您的设置。
新文件夹将添加到测试树。
父主题： 测试文件夹


编辑测试文件夹

要修改测试文件夹属性：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择树中的文件夹。
  3. 单击工具栏中的 编辑 。 您还可以右键单击测试文件夹，然后选择编辑。 此时将显示编辑测试文件夹对话框。
  4. 根据需要编辑文件夹的名称和说明。
  5. 单击确定以接受您所做的更改。
父主题： 测试文件夹


对测试文件夹排序

在测试树中将文件夹上移或下移：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择树中的文件夹。
  3. 单击工具栏上的 上移 将树中的文件夹上移一步，或 下移 将文件夹下移一步。
父主题： 测试文件夹


测试包

测试包为 Silk Central 中第三方测试类型的结构提供支持，由包根和套件节点与测试节点的任意层次结构组成。

测试包还可为用户提供有关测试执行运行的详细信息。可以将测试包、套件节点和测试节点及其问题和附件单独分配给需求。此功能类似于每个其他测试的功能。将第三方测试转换为测试包后，测试包中包含的所有测试都可单独运行。测试包包含的测试节点和套件节点与其他属性外部 ID 一起提供。

测试包的优势在于可以随每个测试执行自动维护结构。测试包的结构可以根据运行的结果更新。文件 <Silk Central 安装目录>\wwwroot\silkroot\xsl\output.xsd 包含用于测试包的输出 XML 文件结构的 XML 架构。

测试包可启用单个测试的全部功能，但以下内容除外：

  • 无法链接包含测试包的测试容器。
  • 测试包不能靠数据驱动，因为它们不具有数据驱动属性。
  • 对测试包节点禁用和隐藏除执行超时外的所有成功条件。
注： Silk Performer 测试、Silk Test Classic 测试和手动测试无法转换为测试包，因为 Silk Central 默认支持这些测试的结构。

提供测试包内部结构的信息具有特定性，复制测试包时将不再一致。要重新使用测试包，您必须复制测试包，将复制的测试包还原为父测试，根据需要应用测试，然后将更改的测试转换为测试包。

  • 创建测试包
    从第三方测试创建测试包，以将第三方测试类型的结构映射到 Silk Central。
  • 使用外部 ID
    使用外部 ID 唯一标识测试包中的测试方法。
  • 重新使用测试包
    重新使用测试包父节点中的信息，以创建新测试包。
  • 将测试包还原为测试
    将测试包还原为原始测试，以在父节点之外创建不同的测试包。
  • 清理测试包
    清理测试包以删除测试包中的未执行测试。
父主题： 构建测试资产


创建测试包

从第三方测试创建新测试包：

  1. 运行一次测试，以创建包含测试包结构的 output.xml 文件。 有关执行测试的更多信息，请参阅执行测试的试运行。
  2. 在菜单中，单击测试 > 详细信息视图。
  3. 在测试树中，右键单击测试并选择转换为测试包。 所选测试将转换为表示上次执行结果结构的层次结构。
父主题： 测试包
相关任务
执行测试的试运行


使用外部 ID

您可以使用外部 ID 唯一标识测试包中的测试节点和套件节点。外部 ID 作为每个测试节点和每个套件节点的属性提供。自动生成的外部 ID 通过类和方法的完全限定名称（带前置的“~”）来标识唯一测试方法。

对于 JUnit 测试，以下架构用于自动生成的外部 ID：~<程序包名称>.<类名>#<方法名称>。

重构 JUnit 测试类时，外部 ID 的自动生成不适用，因为创建新测试时，重构前的测试结果信息将丢失。在这种情况下，必须手动定义测试的外部 ID。重构方法可重新识别，因为在移动 JUnit 测试或更改其名称时，其外部 ID 保持不变。外部 ID 可在源代码中手动设置为批注。

以下代码示例显示了 JUnit 测试的此批注：

import java.lang.annotation.Retention;
import java.lang.annotation.RetentionPolicy;

@Retention(RetentionPolicy.RUNTIME)
public @interface ExternalId {
  String externalId();
}

可在 JUnit 测试中使用批注功能来批注类别和测试方法，如下所示：

import static org.junit.Assert.*;
import org.junit.Test;

import com.borland.runner.ExternalId;

@ExternalId(externalId="JUnit4test")
public class JUnit4test {

  @Test
  @ExternalId(externalId="MyExtId1")
  public void test1() {
    ...
  }

  @Test
  @ExternalId(externalId="MyExtId2")
  public void test2() {
    ...
  }
}

注意，测试方法不支持将外部 ID 与 JUnit 运行器“org.junit.runners.Parameterized”一起使用，因为对于某个具有不同参数的方法的重复运行，外部 ID 并非唯一。一种解决方法是，可以在类级别上指定外部 ID，但必须在方法级别上忽略。如下所示：

@RunWith(Parameterized.class)
@ExternalId(externalId="parameterizedWithExtId")
public class TestCaseParameterizedWithExternalId {

  @Parameters
  public static Collection<Object[]> parameterFeeder() {
    return Arrays.asList(new Object[][] {
        { "param_name1", "param_value1" }, // set of parameters per run, type matching constructor must exist!
        { "param_name3", "param_value3" },
        { "param_name2", "param_value2" },
      }
    );
  }

  private String paramName;
  private String paramValue;

  public TestCaseParameterizedWithExternalId(String paramName, String paramValue) {
    this.paramName = paramName;
    this.paramValue = paramValue;
  }

  @Test
  public void testWithParams() {
    System.out.println(String.format("run with parameter: name='%s', value='%s'", paramName, paramValue));
  }

}
注： JUnit 测试的外部 ID 设置仅可用于使用 JUnit 4.4 或更高版本的测试。
父主题： 测试包


重新使用测试包

提供测试包内部结构的信息具有特定性，复制测试包时将不再一致。要重新使用测试包，您必须复制测试包，将复制的测试包还原为父测试，根据需要应用测试，然后将更改的测试转换为测试包。

重新使用测试包的信息：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 右键单击您要在测试树中重新使用的测试包，并选择复制。
  3. 在测试树中选择您要将复制的测试包添加到其中的节点。
  4. 右键单击选定的节点并选择粘贴，以将复制的测试包添加到树中的相同级别，或选择粘贴为子项，将复制的测试包作为子节点添加到选定的节点。
    警告：
    复制的测试包中现在包含的信息不一致。
  5. 右键单击复制的程序包，并选择将程序包还原为测试。 程序包信息将从父测试中删除。
  6. 编辑测试以便根据需要进行应用。 有关其他信息，请参阅编辑测试。
  7. 右键单击编辑的测试，并选择转换为测试包。
您现在具有带不同属性的原始测试包副本。
父主题： 测试包
相关任务
编辑测试


将测试包还原为测试

将测试包还原为原始测试，以在父节点之外创建不同的测试包。
注： 将测试包还原为一个测试将在测试级别隐藏运行结果信息。但是，您仍可以在时间线视图或结果文件中看到该信息。

将测试包还原为原始测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 右键单击测试树中的测试包。
  3. 单击将程序包还原为测试。
测试包将还原为原始测试。
父主题： 测试包


清理测试包

清理测试包：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 右键单击测试树中的测试包。
  3. 单击清理测试包。
在上次执行测试包期间未执行的所有测试都将从测试包中删除。
父主题： 测试包


管理测试

将新测试添加到测试框架或配置现有测试。
  • 测试类型
    Silk Central 支持以下开箱即用的测试类型：
  • 共享测试资产
    在存储库项目中进行管理的常用测试资产及其分配到的需求可在目标项目中重复使用。
  • 编辑测试
    编辑测试以更改测试的属性。
  • 打印测试
    按选定的顺序打印测试。
  • 测试运行页面
    列出了选定测试的测试执行结果。
  • 测试问题页面
    可使您输入和跟踪与选定测试有关的问题。
  • 版本
    介绍如何使用共享对象和测试的版本。
父主题： 测试


测试类型

Silk Central 支持以下开箱即用的测试类型：
  • 手动测试
    手动测试是指为测试人员提供的分步说明。Silk Central 提供了一个 UI，可以有效执行手动测试，其中包含在测试执行期间录制视频和捕获屏幕图像的选项。如果需要，稍后可以将手动测试转换为自动测试。
  • 关键字驱动的测试
    关键字驱动的测试是一种软件测试方法，使用关键字来象征待测试的功能。关键字驱动的测试可用于创建测试自动化框架。
  • Unified Functional Testing (UFT) 测试
    Unified Functional Testing (UFT) 软件，以前称为 HP QuickTest Professional (QTP)，为软件应用程序和环境提供功能和回归测试自动化。
  • JUnit 测试
    Nunit 是用于 Java 编程语言的单位测试框架。将此测试类型用于JUnit、Silk4J 和 Selenium 测试。
  • MSTest 测试
    MSTest 是 中的命令行实用工具，用于执行在 Microsoft 中创建的单位测试。将此测试类型用于 MSTest 和 Silk4NET 测试。
  • NUnit 测试
    Nunit 是用于 Microsoft .NET 编程语言的单位测试框架。
  • ProcessExecutor 测试
    ProcessExecutor 测试类型可用于执行任何命令行。
  • Silk Performer .NET Explorer 测试
    测试类型用于执行 Silk Performer .NET Explorer 脚本或脚本的特定测试用例。
  • Silk Performer 测试
    Silk Performer 项目可以集成到 Silk Central 测试并通过 Silk Central 直接执行。这可实现强大的测试结果分析和报告。它还可启用无人值守的测试，这意味着测试由 Silk Central 根据预配置计划自动运行。
  • Silk Test Classic 测试
    Silk Central 的 Silk Test Classic 界面提供自动化 Silk Test Classic 用户的可靠方法。Silk Test Classic 脚本的每个测试用例在自己的测试执行内执行，并产生自身的结果。
  • Silk Test Workbench 测试
    Silk Test Workbench 是一种自动化测试工具，可加快复杂应用程序的功能测试。Silk Test Workbench 可为使用各种开发工具开发的测试应用程序提供支持，这些工具包括 Java、.NET、基于浏览器的 Web 应用程序，以及包括 ActiveX 控件和自动化对象的 COM 组件。
  • SilkTestPartner 测试
    TestPartner 是一款 Micro Focus 产品，用于测试使用 Microsoft 技术的 Web 和 Microsoft Windows 应用程序。
  • Windows 脚本宿主测试
    介绍如何通过 Windows 脚本宿主创建用于宿主脚本的环境。
父主题： 管理测试


手动测试

手动测试是指为测试人员提供的分步说明。Silk Central 提供了一个 UI，可以有效执行手动测试，其中包含在测试执行期间录制视频和捕获屏幕图像的选项。如果需要，稍后可以将手动测试转换为自动测试。
  • 创建或编辑手动测试
    创建或编辑手动测试，为手动测试人员提供详细说明。
  • 添加或编辑手动测试步骤
    使用步骤页面添加或编辑手动测试步骤。
  • 使用外部工具创建手动测试
    介绍如何使用开放接口在 Silk Central 用户界面之外创建手动测试。
  • 将手动测试转换为自动测试
    在您将测试添加到回归之前，应将手动测试转换为自动测试。
  • 将自动测试转换为手动测试
    将自动测试转换为手动测试，例如，为了用另一种自动测试类型再次转为自动测试。
  • 步骤页面
    列出了选定测试或共享对象中包括的所有手动测试步骤。
  • 测试导出、更新和导入
    介绍如何通过导出、更新或导入测试来修改测试。
父主题： 测试类型
相关概念
管理共享对象
版本
测试导出、更新和导入


创建或编辑手动测试

要创建或编辑手动测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择手动测试。
  6. 在计划时间字段中，键入用于执行此手动步骤的预计时间。
  7. 单击完成。
父主题： 手动测试
相关任务
执行测试的试运行


添加或编辑手动测试步骤

在步骤页面中添加或编辑测试或共享对象的手动测试步骤。

要添加或编辑手动测试步骤，请执行以下操作：

  1. 对于共享对象，请单击菜单中的测试 > 库。对于测试，请单击菜单中的测试 > 详细信息视图。
  2. 在测试或库树中选择要添加或编辑步骤的节点。
  3. 单击步骤选项卡。
  4. 单击您想要编辑的测试步骤，或使用步骤工具栏中的图标插入新步骤。测试步骤的详细信息将显示在编辑步骤视图中。
  5. 在相应的文本框中编辑测试步骤的名称、操作说明、预期结果和步骤属性。 您可以将来自数据源的值以参数的形式插入到手动测试步骤中（请参见将数据源值添加到手动测试步骤）。参数使用 ${<name>} 语法，例如 ${username}。在将手动测试转换为关键字驱动的测试时，这些参数将自动添加到所生成的关键字。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  6. 执行以下操作之一以完成编辑测试步骤：
    • 单击确定和新建步骤以保存您所做的更改并在当前步骤后添加一个新步骤。
    • 单击确定以保存您所做的更改。
    • 单击取消以还原您的更改。
父主题： 手动测试
父主题： 管理共享对象
相关任务
将数据源值添加到手动测试步骤


使用外部工具创建手动测试

您可以使用 Silk Central 的开放接口在 Silk Central 用户界面之外创建手动测试。 您可以使用 Silk Central 的 Web 服务调用来创建自己的解决方案，并自动创建手动测试。

tmplanning Web 服务中的以下调用可协助您创建手动测试：

  • getTestContainers
  • addManualTest
  • getCustomStepPropertyNames
  • getChildNodes
  • getNodeDetails
  • addNode
  • updateNode
  • startExecution

有关这些 Web 服务调用的详细说明，请参阅可用的 Web 服务。

父主题： 手动测试
相关参考
可用 Web 服务


将手动测试转换为自动测试

您可将手动测试转换为受支持的自动测试类型（例如，关键字驱动、Silk Performer、Silk Test Classic、NUnit、JUnit 以及所有已安装插件）之一。该过程会将手动测试参数传递到自动测试，并将自动参数添加到新的自动测试。

将传递到自动测试的手动测试参数包括：
  • 名称
  • 说明
  • 已分配的需求
  • 已分配的执行计划
  • 已分配的问题
  • 附件
  • 测试步骤

将手动测试转换为自动测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中右键单击手动测试，然后选择自动化方式...。
  3. 从上下文菜单中选择自动测试类型。
  4. 有关填写对话框的信息，请参阅创建测试中的相应主题。
父主题： 手动测试
相关概念
管理测试
相关任务
手动执行自动测试
关键字驱动的测试


将自动测试转换为手动测试

您可将自动测试转换为手动测试。例如，假如您希望将自动测试转换为另一种测试类型，如从 Silk Test Classic 转为 Silk4J，该功能会非常有用。在这种情况下，您可将 Silk Test Classic 测试转换为手动测试，然后再使用 Silk4J 转为自动测试。
注： 限制：自动测试到手动测试的转换仅适用于不含包节点、数据驱动节点和链接节点的标准自动测试。
  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中右键单击测试，然后选择转换为手动测试。
  3. 确认消息。
    警告：
    特定于测试类型的属性将被放弃。如果自动测试目前正在运行，测试结果将在测试运行完成后被放弃。
父主题： 手动测试


步骤页面

测试 > 详细信息视图 > <手动测试> > 步骤

测试 > 库 > <共享对象> > 步骤

步骤页面列出了选定测试或共享对象中包括的所有手动测试步骤。该页面支持标准 Windows 资源管理器风格的多选功能。

要创建新的共享对象，请选择您要共享的步骤，并单击 创建共享步骤 。

页面包括以下工具栏项目：

工具栏项目 | 说明
新建步骤 | 将新的测试步骤添加到列表末尾。
插入步骤 | 在选定的步骤前插入新的测试步骤。
新建调用共享步骤 | 将新的调用共享添加到列表末尾。
插入调用共享步骤 | 在选定的步骤前从库中添加调用共享步骤。
删除 | 从列表中删除选定的测试步骤。
剪切 | 从列表中剪切选定的测试步骤，并将其移到剪贴板。
复制 | 将选定的测试步骤复制到剪贴板。
粘贴 | 将剪贴板上保留的测试步骤副本粘贴到列表中选定内容以上的行。
上移 | 将列表中选定的测试步骤上移一个位置。
下移 | 将列表中选定的测试步骤下移一个位置。
管理附件 打开附件对话框，在此您可以执行以下操作：
上载文件
上载文件并将其附加到选定的测试步骤。
附加链接
将链接附加到选定的测试步骤。
下载所有文件
从选定的测试步骤下载所有附加的文件。
删除
删除文件或链接。
展开共享步骤 | 当测试步骤或共享对象调用库中的共享对象时，单击此处可查看原始步骤。已解决的步骤用箭头标记，您可以单击其名称进行访问。启用此视图时无法编辑步骤。
折叠共享步骤 | 将从库中共享对象调用的步骤作为单个步骤查看。启用此视图可编辑测试步骤。
创建共享步骤 | 创建选定步骤之外的共享对象。
从库中提取 | 从其他共享对象提取调用。将在网格中选择的调用中的所有步骤复制到手动测试或共享对象。
键 | 操作
- | 上移
+ | 下移
Ctrl+A | 全选
Ctrl+C | 复制
Ctrl+X | 剪切
Ctrl+V | 粘贴
Ins | 插入
Del | 删除
步骤页面支持对测试元素执行以下键盘功能（快捷方式）：

步骤显示在具有以下列的网格中：

列 | 说明
顺序 | 执行顺序中的步骤号。
名称 | 测试步骤的名称。
操作说明 | 执行测试步骤必须执行的操作。
预期结果 | 测试步骤的预期结果。
附件 | 附加到测试步骤的链接或文件数。

编辑步骤视图显示选定测试步骤的详细信息，可使您编辑测试步骤的名称、操作说明、预期结果和步骤属性。

编辑步骤视图中提供以下按钮：

按钮 | 说明
确定和新建步骤 | 完成编辑当前步骤并且希望保存更改，然后在当前步骤之后添加新步骤时单击此按钮。
确定 | 完成编辑当前步骤并希望保存更改时单击此按钮。
重置 | 单击可还原更改。
父主题： 手动测试
父主题： 管理共享对象


测试导出、更新和导入

Silk Central/Excel 集成允许您使用两种不同选项来修改测试。其中包括：

  • 导出并更新：此选项可使您在 Silk Central 中创建测试，导出到 Excel 进行更改，然后将其更新回 Silk Central。
  • 导入：此选项可使您在 Excel 中创建测试，然后将其导入到 Silk Central。

在两个方案中，您需要映射文件来同步两个产品之间的列。

注： 目前，Silk Central 仅支持导入 .xslx文件，并且导入限于手动测试。
  • 导出、更新和导入规则
    介绍导入、导出和更新过程中的行为。
  • 测试导出和更新
    介绍如何导出和更新测试。
  • 测试导入
    介绍如何从 Microsoft Excel 导入测试。
  • 映射文件
    介绍用于测试更新和导入的映射文件。
  • 测试版本控制
    介绍 Excel 更新或导入期间的版本控制测试。
父主题： 手动测试
相关概念
手动测试


导出、更新和导入规则

在导出、更新和导入过程中将应用以下业务规则：

常规规则

  • 如果 Excel 中的测试行没有 TestID 或 Path，则视为新测试，并在从中执行导入功能的测试容器下的新文件夹中创建。
  • 您可添加现有的 TestID 以在更新时更新测试，并且您还可添加现有的 SharedStepID 以在导入/更新时添加新的共享步骤。
  • 新的自动测试不会导入和更新。
  • 继承属性值不会导出。
  • 如果将测试移至 Excel 中的不同文件夹层次结构，则此移动在更新过程中将被忽略。
  • 如果 Excel 中缺少测试（已被删除），则此测试在更新过程中不会被删除。
  • 对于（新）文件夹名称，导入使用 Path 列。
  • A-Z 不能用作自定义列名称。这些将为 Excel 的 A-Z 保留，可在映射时使用。

共享步骤

  • 已添加用于导入和更新。
  • 已删除和重新排序用于更新。
  • 将不会更新。
  • 如果 Silk Central 中没有 Excel SharedStepID，则会报告一个错误。

数据驱动测试

  • 非原子数据驱动的子测试不会导出。
  • 可以导入所有测试，但不能将数据驱动的属性导出至 Excel 或从中导入。
  • 如果目标文件夹不包含数据驱动的测试，则仅支持从 Excel 更新。
父主题： 测试导出、更新和导入


测试导出和更新

本部分介绍如何将测试从 Microsoft Excel 导出并更新到 Silk Central。

如果您要对现有测试执行批量编辑，则使用导出-更新到 Excel 功能。

注： 以下字段在 Excel 中不可编辑：状态、测试类型、步骤 ID 和步骤顺序。

导出和更新概述

以下是导出和更新的高级概述：

  • 选择容器或文件夹。
  • 导出到 Excel。
  • 在 Excel 中进行更改。
  • 验证/创建映射文件。
  • 更新回 Silk Central。
  • 将测试导出到 Excel
    介绍如何将测试导出到 Excel。
  • 从 Excel 中更新测试
    将测试从 Silk Central 下载到 Excel 以在 Excel 中更新测试。
父主题： 测试导出、更新和导入


将测试导出到 Excel

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 右键单击包括要导出测试的测试容器或测试文件夹。
  3. 选择导出到 Excel... 此时将显示将测试导出到 Excel 文件对话框。
  4. 从选择映射文件列表框中选择映射文件。 默认映射文件为 TestPropertiesDefaultMapping.xml。有关创建自定义映射文件的信息，请参阅编辑测试映射文件。
  5. 可选：单击 [image] 可编辑映射文件。单击 [image] 可删除映射文件。
    注： 若要执行这两项操作，分别需要具备修改 Office 导入映射文件/删除 Office 导入映射文件的权限。
  6. 单击确定。
测试信息已保存至 Excel 文件中，您可进行编辑。
父主题： 测试导出和更新
相关任务
从 Excel 中更新测试
编辑测试映射文件


从 Excel 中更新测试

在从 Excel 中更新测试前，您首先需要从 Silk Central 中导出测试。
  1. 在菜单中，单击测试 > 详细信息视图。
  2. 右键单击包括您要更新的测试的测试容器或文件夹。
  3. 选择从 Excel 更新... 此时将打开从 Excel 文件更新测试对话框。
  4. 从选择映射文件列表框中选择映射文件。 默认映射文件为 TestPropertiesDefaultMapping.xml。有关创建自定义映射文件的信息，请参阅编辑测试映射文件。
  5. 可选：单击 [image] 可编辑映射文件。单击 [image] 可删除映射文件。
    注： 若要执行这两项操作，分别需要具备修改 Office 导入映射文件/删除 Office 导入映射文件的权限。
  6. 选择测试文件 (.xlsx) 字段中的 Excel 文件。
  7. 单击确定。
父主题： 测试导出和更新
相关任务
将测试导出到 Excel
编辑测试映射文件


测试导入

本部分介绍如何将测试从 Microsoft Excel 导入到 Silk Central。

Silk Central 允许您将测试从 Microsoft Excel (Excel) 导入到测试区域的任何容器或文件夹，然后维护和执行 Silk Central 中所有包括的测试。导入是一次性事件。

在导入测试前，您需要在 Excel 中创建测试文件。有关更多信息，请参阅测试文件。

Silk Central 使用 Excel 文件和映射文件中存储的信息来确定要存储的数据。Silk Central 使用映射文件将 Excel 文件中的测试映射到测试区域的测试。预先选择名为 TestPropertiesDefaultMapping.xml 的默认映射文件进行导入。您可以选择自己的自定义映射文件来映射测试。有关映射文件的更多信息，请参阅编辑测试映射文件。

  • 从 Excel 文件中导入测试
    从 Microsoft Excel 文件中导入测试以将其添加到测试区域。
  • 测试文件
    介绍您可以从中导入测试的测试 Excel 文件的内容。
父主题： 测试导出、更新和导入
相关概念
测试文件
相关任务
编辑测试映射文件


从 Excel 文件中导入测试

要从 Excel 文件中将测试导入到测试区域：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，右键单击您要用作已导入测试的父节点的文件夹或容器，并选择从 Excel 文件导入。 此时将打开从 Excel 文件导入测试对话框。
  3. 从选择映射文件列表框中选择映射文件。 默认映射文件为 TestPropertiesDefaultMapping.xml。有关创建自定义映射文件的信息，请参阅编辑测试映射文件。
  4. 可选：单击 [image] 可编辑映射文件。单击 [image] 可删除映射文件。
    注： 若要执行这两项操作，分别需要具备修改 Office 导入映射文件/删除 Office 导入映射文件的权限。
  5. 选中一次性导入复选框，直接在选定节点下导入测试，不创建共用根文件夹。
  6. 将测试文件的完全限定路径键入测试文件字段，或单击选择文件搜索测试文件。
  7. 单击确定。
父主题： 测试导入
相关概念
测试文件
相关任务
编辑测试映射文件


测试文件

您可以在 Excel 中创建测试文件以将测试导入 Silk Central。在测试文件中，您可以定义所有测试和测试步骤，及其属性和参数。

要将测试文件中的测试映射到 Silk Central 中的测试，请使用 XML 映射文件。映射文件可将测试文件中元素的位置定义到 Silk Central。您可以将测试文件中包含的项目命名为您喜欢的任何名称，只要您可以在映射文件中适当地映射它们。有关映射文件的更多信息，请参阅编辑测试映射文件。

注： 目前，Silk Central 仅支持导入 .xslx文件，并且导入限于手动测试。

属性映射

单击从 Excel 文件导入测试或从 Excel 文件更新测试对话框中的编辑映射，将 Excel 文件中的测试映射到 Silk Central，如下所示：
  • 标题行：在 Excel 文件中，指定包含要在属性映射中使用的列名的行。
  • 第一个数据行：指定包含第一个测试的行。该行及其下方的所有行均将解释为测试。
  • 分隔符：指定应解释为属性值中分隔符的字符。适用于多重列表属性。
  • 名称、说明：分别指定标题行中映射到测试名称和说明的列名。
  • 计划时间：执行此手动测试的预计时间。
  • 步骤属性：测试步骤的名称、操作说明和预计结果。
  • 已分配的需求 ID：如果应将需求分配给测试，请将这些需求的 ID 指定为逗号分隔的列表。确保将此列格式化为 Excel 中的“文本”，否则分配无效。
父主题： 测试导入
相关任务
编辑测试映射文件


映射文件

当数据从 Excel 导入 Silk Central 时，映射文件在导出-更新的更新流程和导入流程中使用。

  • 编辑测试映射文件
    当您从 Excel 文件导入测试时，可直接从 GUI 编辑测试映射文件。
父主题： 测试导出、更新和导入


编辑测试映射文件

您需要修改 Office 导入映射文件权限才能编辑映射文件：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，右键单击您要用作已导入测试的父节点的文件夹或容器，并选择从 Excel 文件导入。 此时将打开从 Excel 文件导入测试对话框。
  3. 单击编辑映射。 此时将打开编辑映射对话框。
  4. 在文本框中编辑测试文件的变量。
    注： 有关测试文件中所含变量的信息，请参阅测试文件。
  5. 可选： 编辑映射文件的名称。
  6. 单击确定以保存您所做的更改或单击取消以取消更改。
父主题： 映射文件
相关概念
测试文件


测试版本控制

Silk Central 在导入和更新过程中创建测试的新版本。

执行从 Excel 到 Silk Central 的更新时，将创建测试树的两个新版本。版本控制进程将记录更新过程前后的快照。

导出-更新

测试将包含默认注释，以注明它们已从 Excel 中更新（如果已添加或修改测试）。

导入

测试包含已创建的默认注释。

父主题： 测试导出、更新和导入
相关任务
从 Excel 中更新测试


关键字驱动的测试

关键字驱动的测试是一种软件测试方法，它将测试设计与测试开发分离开来，因此允许其他专业小组参与测试自动化流程，例如业务分析师。Silk Central 和 Silk Test 支持关键字驱动的测试方法，让自动化工程师能开发出由共享资产（采用 Silk Test 中的关键字形式）组成、易于维护的自动化框架，从而支持业务分析师与工程师之间开展密切协作。随后，业务分析师 Silk Test 中使用这些关键字新建关键字驱动的测试，或者在 Silk Central 中利用这些关键字将其现有手动测试资产转换为自动化测试，或是新建关键字驱动的测试。

  • 关键字驱动的测试就是一个关键字序列。关键字驱动的测试可像其他任何测试一样回放。
  • 关键字序列就是由其他关键字组合而成的关键字。关键字序列通常将遇到的关键字组合捆绑为一个关键字，这有助于您减少维护工作量并确保测试组织有序。
  • 关键字就是针对一个测试对象的一项或多项操作的既定组合。关键字可以使用多种工具和编程语言实施，例如 Java 或 .NET。

关键字驱动的测试的创建需要两个阶段：
  1. 设计测试。
  2. 实施关键字。
  • 关键字驱动的测试的优势
    列举使用关键字驱动的测试方法执行功能和回归测试的优势。
  • 关键字
    描述关键字及其使用方式。
  • 测试自动概述
    描述测试自动化和测试自动化框架。
  • 在 Silk Central 中创建关键字驱动的测试
    为测试自动化框架创建关键字驱动的测试。
  • 通过自动化手动测试创建关键字驱动的测试
    为您的测试自动化框架将 Silk Central 中的手动测试转换为自动化、关键字驱动的测试。
  • 在 内的测试中管理关键字
    管理您的关键字驱动测试中的关键字，以指定操作序列。
  • 管理库中的关键字
    管理您的关键字序列中的关键字，以指定操作序列。
  • 使用关键字驱动的测试进行跨浏览器测试
    利用参数，跨多个浏览器运行关键字驱动的测试。
  • 使用 Java 构建关键字驱动的库
    使用 Java 构建外部关键字驱动的库并将其上载到 Silk Central。这能让您轻松将现有测试框架集成到 Silk Central 中，例如您已经有现有的 Selenium 测试。
  • 通过命令行将关键字库上载
    通过基于 Java 的命令行将外部关键字库上载，以将 Silk Central 和关键字驱动的测试集成到持续集成构建系统，例如 Jenkins。
  • 执行 Silk4J/Silk4NET 关键字驱动的测试而不上载库
    在 Silk Central 中执行 Silk4J/Silk4NET 关键字驱动的测试而不上载关键字库。
  • 示例：带参数的关键字
    说明如何使用带参数的关键字。
  • Silk Central 推荐哪些关键字？
    介绍 Silk Central 用来为关键字驱动的测试推荐关键字的基本推荐算法。
父主题： 测试类型


关键字驱动的测试的优势

使用关键字驱动的测试方法的优势如下：
  • 关键字驱动的测试会将测试自动化与测试用例设计分离开来，从而支持技术人员（实施关键字的测试工程师）与非技术人员（设计测试用例的主题专家）之间的更好分工合作。
  • 可以提前开发测试，无需访问所测试的应用程序，关键字可以稍后再予实施。
  • 不具备编程知识也能开发测试。
  • 从长期角度来看，关键字驱动的测试所需维护更少。您需要维护关键字，所有使用这些关键字的关键字驱动的测试都将自动更新。
  • 测试用例简明扼要。
  • 测试用例更易于非技术受众阅读和理解。
  • 测试用例易于修改。
  • 新测试用例可以重复使用现有关键字，这种做法的优势之一就是更容易提高测试覆盖率。
  • 关键字实施的内在复杂性对于需要创建或执行关键字驱动的测试的用户而言不可见。
父主题： 关键字驱动的测试


关键字

关键字就是针对一个测试对象的一项或多项操作的既定组合。关键字可以使用多种工具和编程语言实施，例如 Java 或 .NET。在 Silk Test 中，关键字是带批注的测试方法 (@Keyword)。关键字将以关键字资产的形式保存。

关键字驱动测试和相关的关键字可在 Silk Central 中设计和管理，但实际实施是在功能测试工具中完成的。Silk Central 和 Silk Test 支持关键字驱动的测试方法，让自动化工程师能开发出由共享资产（采用 Silk Test 中的关键字形式）组成、易于维护的自动化框架，从而支持业务分析师与工程师之间开展密切协作。随后，业务分析师 Silk Test 中使用这些关键字新建关键字驱动的测试，或者在 Silk Central 中利用这些关键字将其现有手动测试资产转换为自动化测试，或是新建关键字驱动的测试。

关键字序列就是由其他关键字组合而成的关键字。关键字序列通常将遇到的关键字组合捆绑为一个关键字，这有助于您减少维护工作量并确保测试组织有序。

父主题： 关键字驱动的测试


测试自动概述

测试自动化是通过使用验证来比较实际执行结果与预期结果，从而利用软件控制测试执行的过程。

测试自动化框架是一种设置特定产品的自动化规则的集成化系统。该系统集成了测试、测试数据源、对象详细信息和各种可重复使用的模块。这些组件需要装配在一起才能代表业务流程。框架提供测试自动化的基础，可简化自动化工作。

父主题： 关键字驱动的测试


在 Silk Central 中创建关键字驱动的测试

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点。
  3. 在工具栏上单击 新建子测试 （新建子测试），或在树中单击右键并选择新建子测试。

    新测试节点将追加到树视图，并且将显示新建测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 从类型列表中选择关键字驱动的测试测试类型。
  6. 选择包含要使用的关键字的库。 必须使用库来存储关键字驱动的测试所使用的一组关键字。
  7. 单击完成。
父主题： 关键字驱动的测试


通过自动化手动测试创建关键字驱动的测试

在 Silk Central 中将手动测试转换为关键字驱动的测试；
  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中右键单击手动测试，从上下文菜单中选择自动化方式... > 关键字驱动的测试。 将显示关键字驱动的测试属性对话框。
  3. 选择包含要使用的关键字的库。 必须使用库来存储关键字驱动的测试所使用的一组关键字。
  4. 单击完成。
将手动测试自动化为关键字驱动的测试将产生以下结果：
  • 手动测试转换为自动化关键字驱动的测试，包含针对每个测试步骤的草拟关键字。这些关键字将添加到为该测试选定的库中。
  • 如果测试包含对已经为关键字序列存在的共享步骤的调用，则将引用这些关键字序列。
  • 如果测试包含对并非为关键字序列的共享步骤的调用，将引用这些共享步骤对象，并将其增强为关键字序列，包含针对每个测试步骤的草拟关键字。这同样适用于嵌套的共享步骤（引用其他共享步骤的共享步骤）。如果嵌套共享步骤的层次结构深度超过 30 级，将为低于该级别的共享步骤的调用创建草拟关键字。
  • 如果测试包含对不同库中的共享步骤的调用，则创建并引用这些步骤的草拟关键字。

如果您的测试步骤包含您想在生成的关键字中访问的参数，测试步骤的操作说明必须使用正确的语法。参数使用 ${<name>} 语法，例如 ${username}。在将手动测试转换为关键字驱动的测试时，这些参数将自动添加到所生成的关键字。

父主题： 关键字驱动的测试


在 内的测试中管理关键字

测试 > 详细信息视图 > <测试> > 关键字
关键字页面使您可以管理选定关键字驱动测试的关键字。可以执行以下操作：
任务 | 步骤
在 Silk Test 中打开测试或关键字序列 | 单击打开Silk Test打开 Silk Test　中选定的测试或关键字序列。
添加关键字
  1. 单击关键字列表底部的新建关键字，或者右键单击关键字，然后从上下文菜单中选择在上面插入关键字。
    注： 可以让 Silk Central 根据关键字用量推荐关键字。用上下文菜单中的启用建议或禁用建议打开或关闭建议。有关更多信息，请参阅 Silk Central 推荐哪些关键字？。
  2. 从可用关键字列表中选择一个关键字，或者键入新名称来创建新的关键字。
  3. 单击保存。
也可以双击或拖放右侧所有关键字窗格中的现有关键字。
提示： 您可使用 Ctrl+单击选择多个关键字。在拖动时，这些关键字将按照您的选择顺序排列。
删除关键字 | 单击希望删除的关键字的操作列中的 删除 。单击保存。
更改关键字顺序 | 将关键字拖放到所需位置。单击保存。
创建关键字序列（一个由其他关键字组成的关键字）
  1. 在关键字列表中选择您希望组合的关键字。在行号列上使用 Ctrl + 单击或 Shift + 单击以选择多个关键字。
  2. 右键单击选定内容并单击组合。
  3. 为新关键字序列指定名称和说明。
从关键字序列中提取关键字 | 右键单击一个关键字序列，单击提取关键字。随后，原始关键字序列将被其中包含的各关键字所取代，但不会从库中删除。单击保存。
将关键字复制并粘贴到测试或关键字序列中
  1. 在关键字列表中选择您想要复制的关键字。在行号列上使用 Ctrl + 单击或 Shift + 单击以选择多个关键字。
  2. 按下 Ctrl+C 以复制您的选择，或按下 Ctrl+X 以移动关键字。
  3. 打开您想要将关键字复制到的测试或关键字序列，然后选择将在其上方插入关键字的行。
  4. 按下 Ctrl+V。
提示： 您还可以将选定的关键字粘贴到 Excel 中，然后将其从 Excel 中复制并粘贴到测试或关键字序列中。
为关键字序列定义参数
  1. 单击关键字列表上方的参数。此时将显示参数对话框。
  2. 单击添加参数。
  3. 为新参数指定名称。如果参数为对外参数（提供一个值，但不需要输入参数），请选中输出复选框。
  4. 单击确定。
  5. 单击保存。
编辑草拟的关键字
  1. 单击希望编辑的草拟关键字的操作列中的 编辑 。
  2. 为关键字选择一个组或者指定一个新组。
  3. 键入关键字的说明。这些信息对于将来负责实施关键字的工程师十分有用。
  4. 单击确定。
  5. 可选：在一个参数字段内单击，为该关键字添加参数。如果关键字使用 Silk Test 实施，则这些参数将出现在所生成的代码存根中。
  6. 单击保存。
搜索关键字
使用右侧的所有关键字窗格查找特定关键字。当您输入字母数字字符时，列表将使用所有现有匹配项动态更新。搜索技巧：
  • 搜索不区分大小写：doAction 将找到 doaction 和 DOAction。
  • 只输入大写字母执行所谓的驼峰大小写搜索：ECD 会找到 Enter Car Details、Enter Contact Details 和 EnterContactDetails。
  • 搜索时会考虑关键字和组名称：test 将找到包含 test 的所有关键字以及组名称中包含 test 的组中的所有关键字。
  • ? 用于取代 0-1 个字符：user?test 将找到 userTest 和 usersTest。
  • * 用于取代 0-n 个字符：my*keyword 将找到 myKeyword、myNewKeyword 和 my_other_keyword。
  • <字符串>. 仅在组名称中搜索：group. 将找到组名称包含 group 的组中的所有关键字。
  • .<字符串> 仅在关键字名称中搜索：.keyword 将找到包含 keyword 的所有关键字。
  • <字符串>.<字符串> 搜索特定组中的关键字：group.word 将找到 myGroup 组中的 myKeyword。
  • 使用引号搜索完全匹配的项：'Keyword' 会找到 Keyword 和 MyKeyword，但不会找到 keyword。
查找库中的草稿关键字 | 如果要切换到包含草稿关键字（也就是您所选测试或关键字序列的草稿关键字）的库，请单击编辑器页面右上角的草稿关键字。
父主题： 关键字驱动的测试
相关概念
测试中的数据缓存
相关参考
管理库中的关键字
Silk Central 推荐哪些关键字？


管理库中的关键字

根据所选对象的不同，关键字页面将提供两种不同的测试 > 库视图。

库

如果您选择的对象为库，将列出该库中的所有关键字和关键字序列。包含已上载关键字库的库将显示符号 [image] 。可以执行以下操作：
任务 | 步骤
实施关键字（添加能够在测试中实际运行关键字的代码） 先决条件：如果关键字包含参数，那么在实施关键字前，需要为每个参数指定一个值。
  1. 在要实施的关键字的操作列中，单击 用 Silk Test 实施 （用 Silk Test 实施）。
    注： 如果浏览器报告打开外部应用程序的安全警告，请确认消息。
  2. Silk Test 客户端随即打开。有关详细信息，请参阅 Silk Test 客户端文档。
  3. 在实施了关键字后，将其上载回 Silk Central。
在 Silk Test 中编辑实施的关键字 | 单击 用 Silk Test 打开 （用 Silk Test 打开）在 Silk Test 客户端中打开关键字。有关详细信息，请参阅 Silk Test 客户端文档。
将草拟关键字转换为关键字序列（一个由其他关键字组成的关键字） | 单击希望转换为关键字序列的关键字的操作列中的 创建关键字序列 。随后，原关键字将被同名关键字序列所取代，关键字编辑器随即打开。
将关键字序列转换为草稿关键字 如果意外创建了一个关键字序列，您可能想将其重新转换为草稿关键字。在要转换的关键字序列的操作列中，单击 转换为草稿关键字 （转换为草稿关键字）。
注： 将关键字序列转换为草稿将删除该序列以及包含的所有关键字。此操作无法撤消。
编辑关键字序列 | 单击 转到 在关键字编辑器中打开关键字序列。
分组关键字 为了更好地设置关键字在库中的结构，您可以对其进行分组：
  • Silk Central 关键字序列可放在子文件夹中。文件夹名称与组名称相同，您的关键字将相应地在列表中分组。
  • 已实施关键字的关键字组在已实施的代码中定义。这些组名称供 Silk Central 使用，您的关键字将相应地在列表中分组。
查看引用特定关键字或关键字序列的测试和关键字序列 | 要查看引用特定关键字或关键字序列的所有测试和关键字序列，请在关键字列表中选择相应的条目，然后引用依据列表将显示所有引用该关键字或关键字序列的关键字驱动的测试和关键字序列。只要单击名称即可跳转到相应的引用。
替换进行引用的测试和关键字序列中的关键字 要将对所选关键字或关键字序列的引用替换为对其他关键字或关键字序列的引用，请在关键字列表中选择相应的条目，然后使用引用依据列表选择要在其中替换引用的对象。
  1. 选择要替换的关键字或关键字序列。
  2. 在引用依据列表中，使用 Ctrl+单击或 Shift+单击选择要在其中替换引用的对象。
  3. 右键单击选中的对象，然后选择替换所选引用中的关键字。替换引用对话框随即出现。
  4. 选择要替换当前关键字的关键字。
  5. 如果所选关键字包含参数，请单击下一步，否则单击确定即告完成。
  6. 所选关键字的参数会列出。对于每个参数，选择上一个关键字的匹配参数，或者输入值。
  7. 单击确定。

关键字序列

如果您选定的对象为关键字序列（一个由其他关键字组成的关键字），关键字页面将显示关键字编辑器，让您可以管理选定关键字序列的关键字。可以执行以下操作：
任务 | 步骤
在 Silk Test 中打开测试或关键字序列 | 单击打开Silk Test打开 Silk Test　中选定的测试或关键字序列。
添加关键字
  1. 单击关键字列表底部的新建关键字，或者右键单击关键字，然后从上下文菜单中选择在上面插入关键字。
    注： 可以让 Silk Central 根据关键字用量推荐关键字。用上下文菜单中的启用建议或禁用建议打开或关闭建议。有关更多信息，请参阅 Silk Central 推荐哪些关键字？。
  2. 从可用关键字列表中选择一个关键字，或者键入新名称来创建新的关键字。
  3. 单击保存。
也可以双击或拖放右侧所有关键字窗格中的现有关键字。
提示： 您可使用 Ctrl+单击选择多个关键字。在拖动时，这些关键字将按照您的选择顺序排列。
删除关键字 | 单击希望删除的关键字的操作列中的 删除 。单击保存。
更改关键字顺序 | 将关键字拖放到所需位置。单击保存。
创建关键字序列（一个由其他关键字组成的关键字）
  1. 在关键字列表中选择您希望组合的关键字。在行号列上使用 Ctrl + 单击或 Shift + 单击以选择多个关键字。
  2. 右键单击选定内容并单击组合。
  3. 为新关键字序列指定名称和说明。
从关键字序列中提取关键字 | 右键单击一个关键字序列，单击提取关键字。随后，原始关键字序列将被其中包含的各关键字所取代，但不会从库中删除。单击保存。
为关键字序列定义参数
  1. 单击关键字列表上方的参数。此时将显示参数对话框。
  2. 单击添加参数。
  3. 为新参数指定名称。如果参数为对外参数（提供一个值，但不需要输入参数），请选中输出复选框。
  4. 单击确定。
  5. 单击保存。
编辑草拟的关键字
  1. 单击希望编辑的草拟关键字的操作列中的 编辑 。
  2. 为关键字选择一个组或者指定一个新组。
  3. 键入关键字的说明。这些信息对于将来负责实施关键字的工程师十分有用。
  4. 单击确定。
  5. 可选：在一个参数字段内单击，为该关键字添加参数。如果关键字使用 Silk Test 实施，则这些参数将出现在所生成的代码存根中。
  6. 单击保存。
搜索关键字
使用右侧的所有关键字窗格查找特定关键字。当您输入字母数字字符时，列表将使用所有现有匹配项动态更新。搜索技巧：
  • 搜索不区分大小写：doAction 将找到 doaction 和 DOAction。
  • 只输入大写字母执行所谓的驼峰大小写搜索：ECD 会找到 Enter Car Details、Enter Contact Details 和 EnterContactDetails。
  • 搜索时会考虑关键字和组名称：test 将找到包含 test 的所有关键字以及组名称中包含 test 的组中的所有关键字。
  • ? 用于取代 0-1 个字符：user?test 将找到 userTest 和 usersTest。
  • * 用于取代 0-n 个字符：my*keyword 将找到 myKeyword、myNewKeyword 和 my_other_keyword。
  • <字符串>. 仅在组名称中搜索：group. 将找到组名称包含 group 的组中的所有关键字。
  • .<字符串> 仅在关键字名称中搜索：.keyword 将找到包含 keyword 的所有关键字。
  • <字符串>.<字符串> 搜索特定组中的关键字：group.word 将找到 myGroup 组中的 myKeyword。
  • 使用引号搜索完全匹配的项：'Keyword' 会找到 Keyword 和 MyKeyword，但不会找到 keyword。
查找库中的草稿关键字 | 如果要切换到包含草稿关键字（也就是您所选测试或关键字序列的草稿关键字）的库，请单击编辑器页面右上角的草稿关键字。
父主题： 关键字驱动的测试
父主题： 库
相关概念
测试中的数据缓存
相关参考
在 内的测试中管理关键字
Silk Central 推荐哪些关键字？


使用关键字驱动的测试进行跨浏览器测试

使用 Silk Test 实施、包含 BrowserBaseState 的关键字驱动的测试可以在 Silk Central 中参数化，使您可以跨多个浏览器运行这些测试。配置要测试的浏览器：
  1. 创建一个配置套件，指定您想要在多个浏览器上运行的关键字驱动的测试。有关创建配置套件的详细信息，请参见创建配置套件。
  2. 在配置选项卡上，单击添加/删除参数，新建一个名为 silktest.configurationName 的新参数。
  3. 单击新建配置添加您要测试的配置。对于每个配置，输入 silktest.configurationName 参数的以下值之一，指定您要测试的浏览器：
    • Internet Explorer
    • Firefox
    • Chrome
  4. 运行配置套件。
父主题： 关键字驱动的测试


使用 Java 构建关键字驱动的库

使用 Java 构建外部关键字驱动的库并将其上载到 Silk Central。这能让您轻松将现有测试框架集成到 Silk Central 中，例如您已经有现有的 Selenium 测试。
  1. 选择帮助 > 工具，然后下载 Java 关键字库工具。
  2. 将下载的 com.borland.silk.keyworddriven.jar 添加到 Java 项目的类路径。
  3. 创建将包含关键字的 Java 类。
  4. 注释您希望用作关键字的 Java 方法。以下示例给出了包含一个关键字的类。
    import com.borland.silk.keyworddriven.annotations.Argument;
import com.borland.silk.keyworddriven.annotations.Keyword;

public class Keywords {

  @Keyword("My Keyword")
  public void myKeyword(@Argument("Username") String name) {
    System.out.println(name);
  }
}
  5. 编译源代码，创建 Java 存档 (jar)。
  6. 使用以下参数，调用所下载的 jar 文件中包含的命令行工具：
    • java
    • -jar com.borland.silk.keyworddriven.jar
    • -build
    • 要生成的库名称。
    • 库类型，目前只支持 Java。
    • 二进制路径，您的关键字库 jar 文件所在的路径，如果适用，其中还包含其他任何必要的库。
    • 要生成的输出库文件包（zip 存档）的名称。
    下面的示例概列了构建关键字库的命令行：
    java -jar com.borland.silk.keyworddriven.jar -build
MyLibrary Java ./output "./output/library.zip"
选择测试 > 库 > <库> > 属性生成的 zip 存档可通过命令行工具上载到 Silk Central 或关键字库部分。
父主题： 关键字驱动的测试
父主题： 库
相关概念
管理关键字库和库属性
相关任务
通过命令行将关键字库上载


通过命令行将关键字库上载

通过基于 Java 的命令行将外部关键字库上载，以将 Silk Central 和关键字驱动的测试集成到持续集成构建系统，例如 Jenkins。
若要通过基于 Java 的命令行将关键字库上载：
  1. 选择 帮助 > 工具，然后下载 Java 关键字库工具。
  2. 使用以下参数，调用所下载的 jar 文件中包含的命令行工具：
    • java
    • -jar com.borland.silk.keyworddriven.jar
    • -upload
    • Silk Central 中要更新的库的库名称，如果尚不存在，则创建一个。
    • 要上载的库文件包（zip 存档）的包名称。
    • Silk Central 前端服务器的主机名:端口。
    • Silk Central 用户的用户名。
    • Silk Central 用户的密码。
    • 括在引号中的更新信息，描述应用于库的更改。
    • [-allowUsedKeywordDeletion]，可选标志，允许删除在测试或关键字序列中使用的关键字。默认情况下，如果试图删除已用的关键字，则会引起错误。
    下面的示例概列了将库上载到 Silk Central 的命令行：
    java -jar com.borland.silk.keyworddriven.jar -upload
"My library" "./output/library.zip" silkcentral:19120 scLogin
scPassword "Build xy:Implemented missing keywords"
父主题： 关键字驱动的测试
相关概念
自动化服务器集成
Silk Central Web 服务
相关任务
使用 Java 构建关键字驱动的库


执行 Silk4J/Silk4NET 关键字驱动的测试而不上载库

如果您有包含 Silk4J 或 Silk4NET 关键字驱动的测试的现有测试自动化框架，并且您想从 Silk Central 执行这些测试，那么可以使用 Silk Central 的 JUnit 和测试包功能来执行。要做到这一点，请执行以下步骤：
  1. 创建一个指向 Silk Test 项目工件的源代码管理配置文件（请参阅源代码管理配置文件）。
  2. 创建一个使用此源代码管理配置文件的测试容器（请参阅添加测试容器）。
  3. 创建一个 JUnit 测试（请参阅创建测试）并配置以下项目：
    • 对于在 Silk4J 中实现的关键字驱动的测试：
      • 指定类路径。如果使用默认的 Silk Test 构建结构，请指定 .\output。
      • .kdt 文件需要位于指定为类路径的文件夹中（或打包到 .jar 文件中，或在类路径中的文件夹内）。
    • 对于在 Silk4NET 中实现的关键字驱动的测试：
      • 将 ./Keyword Driven Tests 指定为类路径。

      • 用 .Net 程序集的相对路径（例如 \bin\Release\Silk4NETProject.dll）为测试的测试容器创建一个称为 silktest.keyworddriven.dotnetassembly 的参数（请参阅创建自定义参数）。

      • 名为 Keyword Driven Tests 且包含 .kdt 文件的 Silk Test 文件夹必须位于源代码管理的根文件夹。
  4. 将测试分配给执行计划（请参阅已分配的测试）。
  5. 可选：执行后，可以右键单击测试，然后选择转换为测试包来获得包结构（请参阅创建测试包）。
父主题： 关键字驱动的测试


示例：带参数的关键字

本主题提供了如何使用带参数的关键字的示例。

作为第一步，先创建一个关键字驱动的测试，该测试包含您要使用的关键字。可以录制整个关键字驱动的测试，或者创建新的关键字驱动的测试，然后将关键字添加在关键字驱动的测试编辑器中，这样即可创建所要的测试。

在此示例中，关键字驱动的测试包含以下关键字：
Start application
这是启动 AUT 并设置基态的标准关键字。
Login
此关键字将特定用户（由用户名和密码标识）登录到 AUT。
GetCurrentUser
此关键字返回当前登录到 AUT 的用户名。
AssertEquals
此关键字比较两个值。
Logout
此关键字将该用户从 AUT 注销。

下一步是将参数添加到关键字。为此，打开关键字的测试脚本，然后将参数添加到方法。

为了将输入参数 UserName 和 Password 添加到关键字 Login，请更改
@Keyword("Login")
public void login() {
  ...
}
到
@Keyword("Login")
public void login(String UserName, String Password) {
  ...
}
为了将输出参数 UserName 添加到关键字 GetCurrentUser，请更改
@Keyword("GetCurrentUser")
public void getCurrentUser() {
  ...
}
到
@Keyword("GetCurrentUser")
public void getCurrentUser(OutParameter CurrentUser) {
  ...
}

关键字驱动的测试编辑器中的关键字驱动的测试应类似下面这样：

现在，可以在关键字驱动的测试编辑器中指定输入参数的实际值。若要检索关键字 GetCurrentUser 的输出参数 UserName 的值，请提供一个变量，例如 ${current user}。然后可以将存储在变量中的值传给后续关键字。

父主题： 关键字驱动的测试


Silk Central 推荐哪些关键字？

在关键字驱动的测试编辑器中将关键字添加到关键字驱动的测试或关键字序列时，Silk Central 会推荐您可能要用作测试中的下一个关键字的现有关键字。推荐的关键字列在关键字列表的最上面，并由条形图指出，条形图填充的部分对应于 Silk Central 推荐该关键字的推荐度。

Silk Central 根据以下条件推荐关键字：

  • 在第一个关键字添加到关键字驱动的测试或关键字序列时，Silk Central 搜索用作其他关键字驱动的测试或关键字序列中的第一个关键字的相似关键字。最常用的关键字推荐度更高。
  • 在将更多关键字添加到已经包含其他关键字的关键字驱动的测试或关键字序列时，Silk Central 如下推荐关键字：
    • 如果在关键字驱动的测试或关键字序列中，在您添加新关键字的位置前面已有关键字，那么 Silk Central 将把前面的关键字与所有其他关键字驱动的测试和关键字序列中的关键字组合进行比较，然后推荐在前面的关键字组合后面最常出现的关键字。
    • 如果在关键字驱动的测试或关键字序列中，在该位置前面没有关键字，但是在当前位置后面有关键字，那么 Silk Central 将把后续关键字与所有其他关键字驱动的测试和关键字序列中的关键字组合进行比较，然后推荐在后续关键字组合前面最常出现的关键字。
  • 此外，Silk Central 会考虑发现的关键字的相似程度。例如，如果两个关键字的名称和组都匹配，那么相比只有名称匹配的两个关键字，Silk Central 推荐前两个关键字的可能性更高。
父主题： 关键字驱动的测试
相关概念
测试中的数据缓存
相关参考
在 内的测试中管理关键字
管理库中的关键字


Unified Functional Testing (UFT) 测试

Unified Functional Testing (UFT) 软件，以前称为 HP QuickTest Professional (QTP)，为软件应用程序和环境提供功能和回归测试自动化。
  • 创建或编辑 Unified Functional Testing (UFT) 测试
    创建或编辑 UFT 测试，以在 UFT 中执行 UFT 测试。
父主题： 测试类型
父主题： 测试自动化工具集成


创建或编辑 Unified Functional Testing (UFT) 测试

要执行 UFT 测试，Unified Functional Testing 软件必须安装在已安装 Silk Central 执行服务器的相同计算机上。

要创建或编辑 UFT 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 Unified Functional Testing 测试。单击下一步。

    此时将打开 Unified Functional Testing 测试属性对话框。

  6. 在测试字段中，选择要执行的 UFT 测试的源代码管理位置。
    提示： 您可选择测试 (.tsp) 本身，或选择测试所在文件夹。
  7. 可选：选中验证 HPE UFT 加载项选项可验证所选 UFT 测试的所有指定加载项。
  8. 可选：选中显示 HPE UFT 应用程序选项可在测试执行期间显示被测应用程序。
  9. 可选：选中记录调试消息选项可在测试运行结果中记录调试消息。
  10. 可选：使用从父级继承复选框可继承父 UFT 测试的设置。
  11. 单击完成。
注： 使用与 UFT 测试本身中定义的测试参数相同的名称定义参数，以将参数传递至 UFT 测试。

原始 UFT 结果文件、run_results.xml 和 run_results.html 在测试运行结果的文件选项卡中提供。

父主题： Unified Functional Testing (UFT) 测试


JUnit 测试

Nunit 是用于 Java 编程语言的单位测试框架。将此测试类型用于JUnit、Silk4J 和 Selenium 测试。
  • 创建或编辑 JUnit 测试
    为 Java 单元测试框架创建或编辑 JUnit 测试。
  • 通过 Java 系统属性访问 Silk Central 参数
    列出您可在 JUnit 测试中通过 Java 系统属性访问的 Silk Central 参数。
父主题： 测试类型
父主题： 测试自动化工具集成


创建或编辑 JUnit 测试

要创建或编辑 JUnit 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 JUnit 测试。单击下一步。

    将打开 JUnit 测试属性对话框。

  6. 指定要在执行服务器上使用的有效 Java 类路径。

    我们建议使用相对类路径。该相对类路径随后会在执行服务器上扩展至完整类路径。通过使用相对类路径，对源代码管理配置文件位置做出更改时，无需对类路径做出额外的更改。

    相对类路径必须指向包含 JUnit 测试的测试容器根节点，例如 JUnit_tests。执行服务器上的相对类路径随后将扩展至包括源代码管理配置文件的工作文件夹（例如 C:\temp）以及测试文件名称（例如 tests.jar）。例如，如果测试打包在名为 tests.jar 的 jar 文件中，而执行所需要的其他 jar 文件存储在子文件夹 lib 中，那么类路径就是 ./tests.jar;./lib/*。

    您也可使用完全限定的类路径。完全限定类路径必须指向测试类所在的存档或文件夹。

  7. 可选： 在测试类字段中，键入 JUnit 测试类的完全限定名称。如果该字段留空，那么类路径中的所有测试都会执行，但是只有在包含测试的 jar 文件显式配置在 Classpath 中的情况下才会如此。
  8. 可选： 在测试方法字段中，键入相应测试方法的名称。 该方法必须是测试类中的可用方法。如果测试方法字段留空，将执行套件中包括的所有测试。
  9. 可选： 将 Java 主目录设置为 Java Runtime Environment (JRE) 的安装路径。 该路径必须是测试运行所在执行服务器上的有效路径。
    注： JUnit 测试可在 JRE 1.5 或更高版本中执行。如果使用较旧版本的 JRE，包含 java.lang.UnsupportedClassVersionError 或 Unrecognized option: -javaagent 的消息将显示在消息选项卡中。
  10. 可选： 在 JVM 选项字段中，可以指定命令行选项。您可指定多个选项，但必须按正确的顺序将其键入。例如，要使用客户端 VM 并将堆的最大大小设置为 512MB，请键入 -client -Xmx512m。您还可以使用环境变量，例如 -Xmx${MY_MEMORY}。
  11. 选中记录外部 AUT 覆盖率复选框，以只获取在 Silk Central > 执行计划 > 代码分析的代码分析设置部分中为执行计划定义的受测试应用程序的代码覆盖率。 如果不选中该复选框，则还要记录来自执行该测试的虚拟机的代码覆盖率。
  12. 可选： 在测试覆盖路径字段中，键入 JAR 库或特定类文件以监视代码覆盖率信息。请注意，JUnit 测试的覆盖路径在这里指定，而不是受测试应用程序的路径。

    我们建议使用测试容器根目录中的相对覆盖路径，该路径随后可在执行服务器上扩展。您也可使用完全限定的路径。用分号分隔多个 jar 文件，示例如下：

    • tests.jar;C:\tests\testutils.jar
    • ${testenv}\tests.jar;${testenv}\testutils.jar
    注： 如果选中记录外部 AUT 覆盖率复选框，将忽略覆盖路径设置。
  13. 单击完成。
注： 参数将作为系统属性传递到 Java 进程，例如 -Dhost_under_test=10.5.2.133。使用 System.getProperty() 方法访问系统属性。例如，要访问先前通过的 host_under_test，请使用 System.getProperty(“host_under_test”);。
父主题： JUnit 测试
相关任务
执行测试的试运行


通过 Java 系统属性访问 Silk Central 参数

任何 JUnit 测试类均可作为 Java 系统属性访问底层测试的测试参数；启动程序使用“-D”VM 参数将这些参数传递到执行计算机。

除客户定义的参数之外，您始终能够从 JUnit 测试调用以下 Java 系统属性：
参数
说明
#sctm_execdef_name
当前执行的执行计划的名称。如果从测试区域触发执行，则参数值是未分配的测试。
#sctm_execdef_id
当前执行的执行计划的数字标识符（数据库密钥）。
#sctm_product
已执行测试容器中定义的产品的名称。
#sctm_version
与执行结果关联的版本的名称。
#sctm_build
与执行结果关联的版本的名称。
#sctm_keywords
用逗号分隔的列表，其中包含为此执行计划定义的关键字。
#sctm_test_results_dir
测试的结果文件所在目录的路径。
#sctm_test_name
正在执行的 Silk Central 测试的名称。
#sctm_test_id
正在执行的测试的数字标识符（数据库密钥）。
#sctm_source_root_dir
测试容器根目录的本地路径，所有受版本控制的文件都驻留在此处。
#external_id
测试包中要执行的测试用例的唯一标识符。如果只应该执行测试包中的特定测试用例，那么可以用作筛选器。

#is_test_package_root
如果为 true，则执行的测试为测试包的根节点（默认）。如果为 false，则只执行测试包中由 #external_id 指定的特定测试用例。
#sctm_data_driven_parent_test_name
如果执行的测试是数据驱动的行，则为父测试的名称。
#sctm_data_driven_parent_test_id
如果执行的测试是数据驱动的行，则为父测试的数字标识符（数据库键）。
父主题： JUnit 测试
相关概念
测试参数
相关参考
预定义参数


MSTest 测试

MSTest 是 中的命令行实用工具，用于执行在 Microsoft 中创建的单位测试。将此测试类型用于 MSTest 和 Silk4NET 测试。
  • 创建或编辑 MSTest 测试
    为 Visual Studio 单位测试框架创建或编辑 MSTest 测试。
父主题： 测试类型
父主题： 测试自动化工具集成


创建或编辑 MSTest 测试

注： MSTest 插件仅支持测试类型单元测试。其他测试类型的结果将被忽略。

要创建或编辑 MSTest 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 MSTest 测试。单击下一步。

    将显示 MSTest 测试属性对话框。

  6. 您可运行测试容器、测试列表、测试类或单个测试方法：
    • 要运行测试容器，请单击测试文件字段旁边的浏览，然后选择 .dll 文件。您可通过只键入测试类或同时键入测试类和测试方法对运行加以限制。
    • 要运行测试列表，请单击测试文件字段旁边的浏览，然后选择 .vsmdi 文件（Visual Studio 测试元数据）。在测试列表名称字段中键入名称。您可通过同时键入测试类和测试方法对运行加以限制。
  7. 单击完成。
注： 要在执行服务器上运行 MSTest，必须安装 Visual Studio 分发或 Visual Studio Test Agent。将包含 MSTest.exe 的文件夹添加到您的路径变量，然后重新启动执行服务器。默认路径为：C:\Program Files (x86)\Microsoft Visual Studio <版本>\Common7\IDE。当前，支持 Microsoft Visual Studio/Visual Studio Test Agent 2012、2013、2015 分发的 MSTest。
父主题： MSTest 测试
相关任务
启动或停止本地执行服务器服务
执行测试的试运行


NUnit 测试

Nunit 是用于 Microsoft .NET 编程语言的单位测试框架。
  • 创建或编辑 NUnit 测试
    为 Microsoft .NET 单位测试框架创建或编辑 NUnit 测试。
父主题： 测试类型
父主题： 测试自动化工具集成


创建或编辑 NUnit 测试

注： 我们建议您将 NUnit 安装的 .\bin 文件夹添加到系统路径单击开始 > 控制面板 > 系统 > 高级 > 环境变量，以将类似 C:\Program Files\NUnit 2.2\bin 的路径添加到系统环境变量 PATH 中。

要创建或编辑 NUnit 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 Nunit 测试。单击下一步。

    将打开 NUnit 测试属性对话框。

  6. 单击浏览以找到并选择要从其中提取测试的 NUnit 程序集。
  7. 在 NUnit 目录文本框中键入工作目录。

    对于 NUnit 2，此目录是 nunit-console.exe 文件的本地路径，例如 C:\Program Files\NUnit 2.2\bin。对于 NUnit 3，此目录是 nunit3-console.exe 文件的完整路径，例如 C:\Program Files (x86)\NUnit.org\nunit-console\nunit3-console.exe。

  8. 在 NUnit 选项文本框中，键入一个或多个 NUnit 控制台命令行选项，以指定 NUnit 测试的指定方式。 例如，要定义应执行位于 SilkTest.Ntf.Test.Flex 中的 Flex4TestApp NUnit 测试，请如下设置运行选项：
    对于 NUnit 2：
    /run:SilkTest.Ntf.Test.Flex.Flex4TestApp
    对于 NUnit 3：
    /test:SilkTest.Ntf.Test.Flex.Flex4TestApp
    注： 添加多个选项时，您必须通过在文本框的每行中写入一个选项来分隔这些选项。
  9. 单击完成。
父主题： NUnit 测试
相关任务
执行测试的试运行


ProcessExecutor 测试

ProcessExecutor 测试类型可用于执行任何命令行。
  • 创建或编辑 ProcessExecutor 测试
    创建或编辑 ProcessExecutor 测试以启动可执行文件。
父主题： 测试类型
父主题： 测试自动化工具集成


创建或编辑 ProcessExecutor 测试

要创建或编辑 ProcessExecutor 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 ProcessExecutor 测试。单击下一步。 将打开 ProcessExecutor 测试属性对话框。
  6. 在可执行文件名文本框中，键入可执行文件的完全限定名称。
  7. 在参数列表文本框中，键入流程执行器测试方法的所有参数。
    注： 多个参数必须位于文本框中的单独行中。
  8. 设置工作文件夹。 此文件夹是执行可执行文件的文件夹。
  9. 如果所执行的命令生成 JUnit 测试结果文件，例如 eAnt 或 Maven JUnit 执行，您可以指定扫描 JUnit 结果 xml 文件的文件夹模式。文件夹位置与工作目录相关，例如 test-results。作为搜索开始位置的根文件夹是 Working Folder，路径中包含所输入模式的所有 JUnit 输出文件均在此处检索。
在执行可执行文件期间，可以使用以下两种环境变量：
环境变量
说明
SCTM_EXEC_RESULTSFOLDER
此文件夹中所有文件都将在 Silk Central 另存为结果文件。如果执行期间在此目录中创建 output.xml 文件，将使用 Silk Central 处理该文件。
SCTM_EXEC_SOURCESFOLDER
这是执行期间所有源文件所在的文件夹。

示例

以下示例包含通过命令行（包括 /c 开关和两个参数）运行 Windows Script Host 的 ProcessExecutor 测试类型：

  • /c - 用于指定应在执行后终止的命令行的命令。
  • cscript - Windows Script Host。
  • parareadwrite.js - 名为 parareadwrite.js 的 jscript 文件
  • %SCTM_EXEC_RESULTSFOLDER% - 执行服务器计算机上包含 Result 文件夹位置的 Silk Central 变量。存储在此位置的文件将自动上载到 Silk Central 并显示在测试运行的文件选项卡中。在此示例中，parareadwrite.js 脚本会生成一个写入 Result 文件夹并上传回 Silk Central 的 output.xml 文件。
父主题： ProcessExecutor 测试
相关任务
执行测试的试运行


Silk Performer .NET Explorer 测试

测试类型用于执行 Silk Performer .NET Explorer 脚本或脚本的特定测试用例。
  • 创建或编辑 Silk Performer .NET Explorer 测试
    创建或编辑 测试来执行 Silk Performer .NET Explorer 脚本或脚本的特定测试用例。
父主题： 测试类型
父主题： 测试自动化工具集成


创建或编辑 Silk Performer .NET Explorer 测试

要创建或编辑 .NET Explorer 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 Silk Performer .NET Explorer 测试。单击下一步。

    将打开 .NET Explorer 测试属性对话框。

  6. 浏览至并选择 .NET Explorer 脚本以应用到测试。 该脚本是一个 .nef 文件。
  7. 将路径输入到执行服务器上的 NetExplorer.exe 可执行文件中。 例如 C:\Program Files\MyCustomSPFolder\DotNET Explorer\NetExplorer.exe。您还可以在执行服务器上定义环境变量并引用它，例如 ${SP_HOME}\NetExplorer.exe。
  8. 在测试用例字段中，键入要执行的 .NET Explorer 测试用例的名称。如果此文本框保留空白，则将执行脚本中所有测试用例。不能指定多个测试用例。
    注： 始终执行测试用例 InitTestCase 和 EndTestCase。
  9. 单击完成。
父主题： Silk Performer .NET Explorer 测试
相关任务
执行测试的试运行


Silk Performer 测试

  • 创建或编辑 Silk Performer 测试
    创建或编辑 Silk Performer 测试，以便在 Silk Central 中执行 Silk Performer 项目。
父主题： 测试类型
父主题： 测试自动化工具集成
相关概念
使用 Silk Performer 项目
相关任务
创建或编辑 Silk Performer 测试


创建或编辑 Silk Performer 测试

要创建或编辑 Silk Performer 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 Silk Performer 测试。单击下一步。

    将打开Silk Performer 测试属性 - 选择项目对话框。

  6. 单击浏览以选择已保存到文件系统的 Silk Performer 项目，然后单击下一步。
  7. 从工作负载列表中选择已为项目定义的工作负载配置文件之一。
  8. 单击完成以创建测试用例。
父主题： Silk Performer 测试
相关概念
使用 Silk Performer 项目
Silk Performer 测试
相关任务
执行测试的试运行


Silk Test Classic 测试

Silk Central 的 Silk Test Classic 界面提供自动化 Silk Test Classic 用户的可靠方法。Silk Test Classic 脚本的每个测试用例在自己的测试执行内执行，并产生自身的结果。

Silk Test Classic 计划测试类型用于 Silk Test Classic 测试计划。测试计划通常是分层结构的文档，描述测试需求并且包含实施测试需求的语句、4Test 脚本和测试用例。

在活动页面上观察运行的 Silk Test Classic 执行时，当前运行的执行计划将提供可打开详细信息视图的超链接。此视图可使您密切监视当前运行的执行计划的状态。对于 Silk Test Classic 测试执行，此视图的中心组件由两个部分组成：上半部分显示有关测试、脚本、测试用例和测试数据的常规信息。下半部分显示 Silk Test Classic 生成的所有输出消息及其严重性。

在 Silk Central 的早期版本中，Silk Test Classic 调用通过命令行接口实施。新接口可通过进程间通信工作。通过配置测试容器设置，您可以指定是否应使用 Silk Central 的 Silk Test Classic 界面。

对于未通过 Silk Central GUI 中的 Silk Test Classic 测试属性定义的所有 Silk Test Classic 测试参数，它们则使用 Silk Test Classic 默认设置，例如来自 partner.ini 的设置。

  • 创建或编辑 Silk Test Classic 测试
    创建或编辑 Silk Test Classic 测试，以便在 Silk Central 中执行 Silk Test Classic 测试。
  • 创建或编辑 Silk Test Classic 计划测试
    创建或编辑 Silk Test Classic 计划测试以便将计划测试的结构导入到 Silk Central。
父主题： 测试类型
父主题： 测试自动化工具集成
相关概念
Silk Test Classic 测试
相关任务
创建或编辑 Silk Test Classic 测试


创建或编辑 Silk Test Classic 测试

要创建或编辑 Silk Test Classic 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 Silk Test Classic 测试。要同时导入多个 Silk Test Classic 测试用例，请选择 Silk Test Classic 多测试用例导入。单击下一步。

    此时将打开测试属性 - 选择测试脚本对话框。

  6. 单击浏览，从已定义的 Silk Test Classic 项目或源代码管理目录中选择测试脚本文件。 文件扩展名为 .t 或 .g.t 的测试脚本被定义为与源代码管理配置文件中的测试容器根节点相关。例如，/<Silk Test Classic project>/MyScript.t。
  7. 单击下一步。

    将打开测试属性 - 选择测试用例对话框。

    注： 如果 Silk Test Classic 脚本是数据驱动 .g.t 文件（例如 SilkTestScript1.g.t），则数据源将完全控制在脚本文件中，而不是通过 Silk Central 的数据驱动属性控制。使用数据驱动脚本文件时，默认选中数据驱动复选框。有关数据驱动 Silk Test Classic 测试的更多信息，请参阅 Silk Test Classic 文档。
  8. 从已定义脚本文件中的可用测试用例中选择测试用例或指定自定义测试用例。填充好自定义测试用例字段后，Silk Test Classic 测试将通过 Silk Test Classic 中的导出功能自动创建。使用自定义字段指定测试用例时，可以使用括号“()”终止测试用例名称。在括号中，您可以指定包括参数的测试数据。在自定义字段中指定数据将覆盖测试数据属性的值。
  9. 可选：将其他执行参数键入测试数据文本框中。 在测试执行期间，这些参数由 Silk Test Classic 进行处理。如果将多个参数传递到 Silk Test Classic，则必须用逗号 (,) 分隔。如果将 String 参数传递到 Silk Test Classic，则必须将参数放在引号 (“) 中间。如果测试数据过于复杂，建议您在测试数据中使用参数，例如 ${ParameterName}。参数会在测试执行中自动被替换。
    注： 此字段的最大长度为 2000 个字符。
  10. 定义测试是否应提供 TrueLog。
    提示： 使用开放代理运行测试时，必须同时在Silk Central 和 Silk Test 中打开此项设置，否则，不会提供 TrueLog。数据驱动测试的默认执行模式基于计划。如果将基于脚本的执行模式用于数据驱动测试，请更改 SccExecServerBootConf.xml 的 Silk Test Classic 元素中的 DataDrivenScriptMode 设置。有关详细信息，请参阅 Silk Test Classic 文档。
  11. 如果要求，请指定选项集文件。默认情况下，Silk Central 关闭所有打开的 Silk Test Classic 选项集文件。要指定选项集文件，请指定与源代码管理配置文件中的测试容器根节点相关的文件名。
  12. 单击完成以创建 Silk Test Classic 测试。
    注： 如果拥有需要一个小时以上才能完成的 Silk Test Classic 测试用例，请调整 Silk Central 的超时设置。否则，Silk Central 会假定发生了错误并终止执行。有关超时设置的详细信息，请参阅本帮助中的管理主题。
父主题： Silk Test Classic 测试
相关概念
Silk Test Classic 测试
Silk Test Classic 测试
测试参数
相关任务
执行测试的试运行


创建或编辑 Silk Test Classic 计划测试

要创建或编辑 Silk Test Classic 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 Silk Test Classic 计划。单击下一步。

    将打开计划属性对话框。

  6. 在计划文件字段中，键入要执行的测试计划文件 (.pln)的完全限定名称。 单击浏览以浏览至该文件。
  7. 在 项目文件文本框中，键入包含该文件和环境设置的 Silk Test Classic 项目的名称。 单击浏览以浏览至项目文件。
  8. 在选项集文本框中，键入包含环境设置的选项集文件的完全限定名称。 单击浏览以浏览至选项集文件。
  9. 在属性和查询的数据文件文本框中，键入测试计划初始化文件的默认路径。 单击浏览以浏览至测试计划初始化文件。
  10. 在测试计划查询名称文本框中，键入已保存测试计划查询的完全限定名称。
  11. 单击完成。

要在 Silk Central 中保持 Silk Test Classic 计划测试的结构，请执行试运行。在试运行成功完成后，output.xml 文件会添加到执行计划运行的结果文件中。这样您就可以将测试转换为测试包，让您完全控制测试的结构。

父主题： Silk Test Classic 测试
相关任务
创建测试包
执行测试的试运行


Silk Test Workbench 测试

Silk Test Workbench 是一种自动化测试工具，可加快复杂应用程序的功能测试。Silk Test Workbench 可为使用各种开发工具开发的测试应用程序提供支持，这些工具包括 Java、.NET、基于浏览器的 Web 应用程序，以及包括 ActiveX 控件和自动化对象的 COM 组件。
  • 通过 Silk Central 运行 STW.EXE 的先决条件
    列出通过 Silk Central 执行服务器运行 STW.EXE 所需的先决条件。
  • 创建或编辑 Silk Test Workbench 测试
    创建或编辑 Silk Test Workbench 测试，以便在 Silk Central 中执行 Silk Test Workbench 测试。
  • 在结果文件的上下文中打开 Silk Test Workbench
    介绍如何在结果文件的上下文中打开 Silk Test Workbench。
  • 查看 Visual Test 的执行结果文件
    介绍如何在发生回放错误时打开 Silk Test Workbench 查看 Visual Test 的最后屏幕截图。
  • 测试参数页面 - Silk Test Workbench
    介绍 Silk Test Workbench 参数的数据类型映射。
父主题： 测试类型
父主题： 测试自动化工具集成


通过 Silk Central 运行 STW.EXE 的先决条件

要通过 Silk Central 执行服务器运行 STW.EXE 并成功连接到 Silk Test Workbench 数据库，需要满足以下先决条件：
  1. 将 Silk Central 执行服务器作为进程运行，而不是作为服务。
  2. 使用数据库身份验证连接到 Silk Test Workbench 数据库。Silk Test Workbench 在连接到 Silk Test Workbench SQL Server 数据库时可以使用 Windows 身份验证或数据库身份验证。
  3. 配置数据库服务器实例以使用静态端口。
如果不满足这些先决条件，Silk Test Workbench 在尝试通过 Silk Central 执行服务器运行 STW.EXE 时可能会返回以下错误：
错误 3：DSN、用户名或密码不正确。
父主题： Silk Test Workbench 测试


创建或编辑 Silk Test Workbench 测试

要创建或编辑 Silk Test Workbench 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 Silk Test Workbench 测试。单击下一步。

    将打开Silk Test Workbench 测试属性 - 选择测试对话框。

  6. 从Silk Test Workbench 测试列表中选择一个或多个脚本。
  7. 在回放选项文本框中，键入预定义 Silk Test Workbench 回放选项的名称，或保留系统默认的默认值。
    注： 必须为 Silk Test Workbench 测试设置回放选项。Silk Test Workbench 测试上的删除选项会将回放选项重置为系统默认的默认值。
  8. 单击完成。
父主题： Silk Test Workbench 测试
相关任务
执行测试的试运行


在结果文件的上下文中打开 Silk Test Workbench

  1. 在菜单中，单击执行计划。
  2. 选择执行计划。
  3. 单击运行选项卡。
  4. 在底部的测试运行网格中，单击您要查看其详细信息的测试运行 ID。 此时将打开测试运行结果对话框。
  5. 单击文件选项卡。
  6. 单击 result.stwx 文件，以在结果文件的上下文中打开 Silk Test Workbench。
    注： 您尝试在其上打开文件的计算机上必须已安装 Silk Test Workbench。
父主题： Silk Test Workbench 测试


查看 Visual Test 的执行结果文件

  1. 在菜单中，单击执行计划。
  2. 选择执行计划。
  3. 单击运行选项卡。
  4. 在上次执行区域中，单击相关执行计划的运行 ID，以查看测试执行结果。
  5. 操作列显示 Silk Test Workbench 的所有图标和链接：
    • detail.htm - Silk Test Workbench 的详细步骤文件。
    • result.stwx - 单击以在 Silk Test Workbench 中打开结果。
    • error.png - 单击以转到最后错误的屏幕截图。
父主题： Silk Test Workbench 测试


测试参数页面 - Silk Test Workbench

测试 > 详细信息视图 > <测试元素> > 数据集

将参数从 Silk Central 测试传送至Silk Test Workbench 测试时，必须在 Silk Test Workbench 脚本中将这些参数定义为输入参数，而且必须在 Silk Central 中有与脚本相同的名称。应使用下列数据类型：

Silk Central | Silk Test Workbench
字符串 | 文本
数字 | 数字（长整型）
数字 | 数字（长长整型）
数字 | 枚举
浮点值 | 数字（双精度型）
布尔值 | 布尔值 (True/False)
父主题： Silk Test Workbench 测试
父主题： 测试参数


SilkTestPartner 测试

TestPartner 是一款 Micro Focus 产品，用于测试使用 Microsoft 技术的 Web 和 Microsoft Windows 应用程序。
  • 创建或编辑 SilkTestPartner 测试
    配置 SilkTest Classic 测试属性以创建新的 TestPartner 测试。
  • 添加多个 TestPartner 测试
    创建新 TestPartner 测试时，您可添加多个 TestPartner 测试。
父主题： 测试类型
父主题： 测试自动化工具集成


创建或编辑 SilkTestPartner 测试

要创建或编辑 TestPartner 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 SilkTestPartner 测试。单击下一步。

    此时将出现测试属性 - 选择测试脚本对话框。

  6. 单击浏览。

    此时将打开选择文件对话框。此对话框中可用的资产基于相关 TestPartner 源代码管理配置文件中定义的项目路径。

  7. 从列表中选择脚本，然后单击确定。
    注： 要添加多个 TestPartner 测试，请参阅添加多个 TestPartner 测试。
  8. 在回放选项文本框中，键入预定义 TestPartner 回放选项的名称，或保留系统默认的默认值。
  9. 单击完成。
父主题： SilkTestPartner 测试
相关任务
执行测试的试运行
添加多个 TestPartner 测试


添加多个 TestPartner 测试

要添加多个 TestPartner 测试，您必须先按照创建 SilkTestPartner 测试中介绍的步骤进行操作。

添加多个 TestPartner 测试：

  1. 在新建测试对话框上，从类型列表框中选择 TestPartner 测试。
  2. 单击下一步。 此时将打开测试属性 - 选择测试脚本对话框。
  3. 单击浏览。

    此时将打开选择文件对话框。此对话框中可用的资产基于相关 TestPartner 源代码管理配置文件中定义的项目路径。

  4. 在回放选项文本框中，键入预定义 TestPartner 回放选项的名称，或保留系统默认的默认值。
    注： 导入操作会将定义的回放选项分配到所有已导入脚本。如果需要更改任何脚本的回放选项，请在导入后编辑测试。
  5. 单击下一步。

    将打开测试属性 - 选择脚本对话框。

  6. 在 TestPartner 脚本文本框中，通过单击 Ctrl+单击选择要导入的脚本。
  7. 单击完成。
父主题： SilkTestPartner 测试
相关任务
创建或编辑 SilkTestPartner 测试


Windows 脚本宿主测试

Windows 脚本宿主 (WSH) 是 Windows 平台的一部分，可为宿主脚本创建环境。脚本在执行服务器中运行时，WSH 扮演宿主角色。它会向脚本提供对象和服务，并提供一组执行脚本的指南。此外，WSH 还管理安全并调用相应的脚本引擎。

  • 创建或编辑 Windows 脚本宿主 (WSH) 测试
    为符合 WSH 标准的测试脚本创建或编辑 Windows 脚本宿主 (WSH) 测试。
  • 支持的脚本语言
    列出了 WSH 支持的脚本语言。
  • WSH 测试属性
    介绍您可以为 WSH 配置的属性。
  • 使用 WSH 测试中的参数
    介绍如何使用 WSH 测试中的参数。
  • 查看 WSH 中返回的信息
    介绍如何查看 WSH 在测试中返回的信息。
父主题： 测试类型
父主题： 测试自动化工具集成


创建或编辑 Windows 脚本宿主 (WSH) 测试

要创建或编辑 WSH 测试，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 如果您创建新测试，请从类型列表框中选择 Windows 脚本宿主测试。单击下一步。

    将打开 Windows Scripting 测试属性对话框。

  6. 单击浏览并选择 Windows 脚本测试脚本。
  7. 在开关文本框中，指定任何其他所需参数的位置。
    注： 您可添加要传递到脚本的开关。有关可用开关的更多详情，请参阅 WSH 测试属性以及 MS 脚本宿主文档。
  8. 单击完成。
父主题： Windows 脚本宿主测试
相关任务
执行测试的试运行


支持的脚本语言

对于 WSH 兼容的脚本引擎，WSH 不依赖语言。 Windows 平台本身支持文件扩展名为 .vbs 的 Visual Basic 脚本，以及以 Java 脚本语言编写、文件扩展名为 .js 的脚本。

对于其他脚本语言，在执行服务器上必须安装专用脚本解释器。 例如，如果您在执行服务器上安装 Perl 解释器，这会在 WSH 环境中注册扩展名为 .pls 的 Perl 脚本引擎。 将扩展名为 .pls 的文件传递到 WSH 工具时，由于此文件扩展名，可通过可执行文件 cscript.exe 调用相应的解释器。 因此，WSH 的客户端，此处指 Silk Central 执行服务器，不需要了解 Perl 解释器的安装。

注： 安装脚本解释器后，例如 Active Perl，通过在 Silk Central 中执行脚本前使用简单脚本调用 WSH 命令行工具，来尝试在执行服务器上本地执行脚本。 为此，请打开执行服务器上的命令行解释器并键入 cscript <somescript>，其中 <somescript> 是您选择的脚本路径（在执行服务器上可用）。 这正是在执行服务器上执行 WSH 测试时 Silk Central 将调用的内容。 如果已执行脚本，则脚本引擎已成功注册。
以下脚本语言兼容 WSH：
脚本语言
文件扩展名
Perl
.pls
Python
.py 和 .pyw
REXX
.REXX
TCL
.tcl
父主题： Windows 脚本宿主测试


WSH 测试属性

属性 | 说明
脚本 | 您可以定义其中为文件包含的脚本语言注册脚本引擎的任何文件。 与其他测试类型的测试源相比，受源代码管理的脚本文件会自动部署到执行服务器。
命令行开关 您可以在测试执行期间输入以下设置，并将其传递到 cscript.exe：
//B
批处理模式抑制来自脚本的所有非命令行控制台 UI 请求。 我们建议您在执行服务器的无人值守执行期间使用此选项，以避免脚本等待用户输入。
//U
我们建议对控制台的重定向 I/O 使用 unicode。
//T:nn
超时，以秒为单位 脚本可以运行的最大时间，默认 = 无限制。 此选项用于防止脚本过度执行。 可设置计时器。 执行时间超过指定值时，Cscript 将使用 IActiveScript::InterruptThread 方法中断脚本引擎并终止进程。 有回调挂钩。 如果调用超时，将调用 OnTimeOut 函数来允许清理。 尽管使用此功能有可能产生无限循环，但利大于弊。
//logo
执行时显示执行标题，可在 log.txt 日志文件开始处看到。 这是默认设置。
//nologo
防止在执行时显示执行标题。
//D
启用活动调试。
//E:engine
使用引擎执行脚本。
//Job:xxxx
执行 WSF 工作。
//X
在调试器中执行脚本。
父主题： Windows 脚本宿主测试


使用 WSH 测试中的参数

为 WSH 测试定义的参数会将名称和值对作为附加参数自动添加到命令行，并将参数设为调用进程的环境变量。 此功能允许您访问 WSH 脚本中为测试定义的所有参数。

例如，WSH 测试可通过将 myscript.js 作为脚本和将 //B 作为命令行开关进行定义。 此外，测试需要称作 IPAddress 的参数（值为 192.168.1.5）和称作 Port 的另一个参数（值为 1492）。 本示例中 WSH 执行产生的命令行是：

csript myscript.js //B IPAddress=192.168.1.5 Port=1492
父主题： Windows 脚本宿主测试


查看 WSH 中返回的信息

要收集 WSH 执行的结果，WSH 脚本必须在 WSH 测试的当前工作目录中生成称作 output.xml 的文件。 此目录中的所有文件都存储在数据库中，并可通过文件列表下载来执行测试。 当文件的扩展名在文件扩展名下定义以在项目区域的结果属性中忽略时，将从存储中排除文件。

注： 为每个 WSH 执行动态创建当前工作目录。 创建文件时不要使用绝对路径。 使用的任何相关路径都会正确引用当前工作目录。

脚本写入 WSH 标准输出的任何信息都将进入当前工作目录中的 log.txt 文本文件。 此文件存储在数据库中并且可以查看，因为它包括在测试执行的文件列表中。

以下示例显示如何从脚本打印日志信息：

 WScript.Echo "This info will be written to the log.txt file"

output.xml 的 XML 结构以定义名为 TestItem 属性的元素 ResultElement 开头，此 TestItem 指定了 ResultElement 的名称。

ResultElement 必须包含名为 ErrorCount 的元素或名为 WarningCount 的元素，以及事件元素的列表。

ErrorCount 和 WarningCount 元素必须包含正数或零。 顶级 ResultElement 的 ErrorCount 和 WarningCount 用于评估成功条件，以确定测试是否成功或失败。 XML 文件可能包含 Silk Central GUI 中不可见的其他元素。 但是，output.xml 文件存储在数据库中并且可查看，因为它包括在执行测试的文件列表中。

事件元素表示 WSH 测试执行期间发生的事件。 消息和严重性显示在 Silk Central GUI 中测试执行的消息列表中。 事件元素必须包含消息和严重性元素。

严重性元素必须具有以下值之一：

  • 信息
  • 警告
  • 错误（或异常）
  • 失败

您可以在结果文件中存储其他信息。 ResultElement 可能包含任何数量的子 ResultElement，因此可以轻松对信息分组。 子 ResultElement 使结果文件更易于读取。 由于与单元测试、JUnit 和 NUnit 有关的兼容性原因，ResultElement 可以命名为 TestSuite 或 Test。

ResultElement 可能包含以下其他元素：

  • FailureCount，与错误计数的处理方法相同
  • RunCount，如果测试运行多次
  • Timer，例如测试的持续时间
  • WasSuccess，用于与 NUnit 结果文件的兼容性
  • Asserts，用于与 NUnit 结果文件的兼容性

事件元素可能包含详细信息元素的列表。

详细信息元素表示有关事件的详细信息。 它必须定义 TestName 元素和信息元素。 TestName 用于提供事件发生位置的详细信息。 信息元素保留有关事件的详细信息，例如堆栈跟踪。

注： 在 Silk Central 8.1 中，消息和信息元素的值必须为 URL 编码 (ISO-8859-1)。 从版本 8.1.1 开始，不再允许 URL 编码。

示例结果文件

<ResultElement TestItem="WshOutputTest">
  <ErrorCount>1</ErrorCount>
  <WarningCount>1</WarningCount>
  <Incident>
    <Message>some unexpected result</Message>
    <Severity>Error</Severity>
    <Detail>
      <TestName>function main()</TestName>
      <Info>some additional info; eg. stacktrace</Info>
    </Detail>
  </Incident>
  <Incident>
    <Message>some warning message</Message>
    <Severity>Warning</Severity>
    <Detail>
      <TestName>function main()</TestName>
      <Info>some additional info; eg. stacktrace</Info>
    </Detail>
  </Incident>
</ResultElement>

Java 脚本示例

以下脚本用于生成示例结果文件。 要尝试此脚本，请以 .js 扩展名保存。

function dumpOutput(dumpFile)
{
  dumpFile.WriteLine("<ResultElement TestItem=\"WshOutputTest\">");
  dumpFile.WriteLine("  <ErrorCount>1</ErrorCount>");
  dumpFile.WriteLine("  <WarningCount>1</WarningCount>");
    dumpFile.WriteLine("  <Incident>");
    dumpFile.WriteLine("    <Message>some unexpected result</Message>");
    dumpFile.WriteLine("    <Severity>Error</Severity>");
    dumpFile.WriteLine("    <Detail>");
    dumpFile.WriteLine("      <TestName>function main()</TestName>");
    dumpFile.WriteLine("      <Info>some additional info; eg. stacktrace</Info>");
    dumpFile.WriteLine("    </Detail>");
    dumpFile.WriteLine("  </Incident>");
    dumpFile.WriteLine("  <Incident>");
    dumpFile.WriteLine("    <Message>some warning message</Message>");
    dumpFile.WriteLine("    <Severity>Warning</Severity>");
    dumpFile.WriteLine("    <Detail>");
    dumpFile.WriteLine("      <TestName>function main()</TestName>");
    dumpFile.WriteLine("      <Info>some additional info; eg. stacktrace</Info>");
    dumpFile.WriteLine("    </Detail>");
    dumpFile.WriteLine("  </Incident>");
  dumpFile.WriteLine("</ResultElement>");
}

function main()
{
  var outFile;
  var fso;
  fso = WScript.CreateObject("Scripting.FileSystemObject");
  outFile = fso.CreateTextFile("output.xml", true, true);
  outFile.WriteLine("<?xml version=\"1.0\" encoding=\"UTF-16\"?>");

  dumpOutput(outFile);
  outFile.Close();
  WScript.Echo("Test is completed");
}

main();
WScript.Quit(0);

Visual Basic 脚本示例

以下 Visual Basic 脚本也会生成示例结果文件，并将其另存为 Output.xml。 要尝试此脚本，请以 .vbs 扩展名保存。

WScript.Echo "starting"

Dim outFile
Dim errCnt
Dim warningCnt

outFile = "output.xml"
errCnt = 1 ' retrieve that from your test results
warningCnt = 1 ' retrieve that from your test results

Set FSO = CreateObject("Scripting.FileSystemObject")
Set oTX = FSO.OpenTextFile(outFile, 2, True, -1) ' args: file, 8=append/2=overwrite, create, ASCII

oTX.WriteLine("<?xml version=""1.0"" encoding=""UTF-16""?>")
oTX.WriteLine("<ResultElement TestItem=""PerlTest"">")
oTX.WriteLine("  <ErrorCount>" & errCnt & "</ErrorCount>")
oTX.WriteLine("  <WarningCount>" & warningCnt & "</WarningCount>")
oTX.WriteLine("  <Incident>")
oTX.WriteLine("    <Message>some unexpected result</Message>")
oTX.WriteLine("    <Severity>Error</Severity>")
oTX.WriteLine("    <Detail>")
oTX.WriteLine("      <TestName>function main()</TestName>")
oTX.WriteLine("      <Info>some additional info; eg. stacktrace</Info>")
oTX.WriteLine("    </Detail>")
oTX.WriteLine("  </Incident>")
oTX.WriteLine("  <Incident>")
oTX.WriteLine("    <Message>some warning message</Message>")
oTX.WriteLine("    <Severity>Warning</Severity>")
oTX.WriteLine("    <Detail>")
oTX.WriteLine("      <TestName>function main()</TestName>")
oTX.WriteLine("      <Info>some additional info; eg. stacktrace</Info>")
oTX.WriteLine("    </Detail>")
oTX.WriteLine("  </Incident>")
oTX.WriteLine("</ResultElement>")
父主题： Windows 脚本宿主测试


共享测试资产

在存储库项目中进行管理的常用测试资产及其分配到的需求可在目标项目中重复使用。

如果您将项目配置为使用特定存储库项目的资产（参阅添加项目），则您可通过将资产粘贴到目标项目来重复使用资产。

  • 重复使用存储库项目的测试资产
    在存储库项目中维护常用测试资产，并在正在使用的项目中重复使用这些资产。
  • 维护共享测试版本
    将测试更新为存储库项目中的最新版本测试，或将测试更新推送至存储库项目。
父主题： 管理测试


重复使用存储库项目的测试资产

在存储库项目中维护常用测试资产，并在正在使用的项目中重复使用这些资产。
如果您将项目配置为使用特定存储库项目的资产（参阅添加项目），则您可通过将资产粘贴到目标项目来重复使用资产。
要重复使用存储库项目的测试资产，请执行以下操作：
  1. 在菜单中，单击项目 > 项目列表。
  2. 选择存储库项目。
  3. 在菜单中，单击测试 > 详细信息视图。
  4. 单击 复制 以将元素复制到剪贴板。
  5. 在菜单中，单击项目 > 项目列表。
  6. 选择目标项目。
  7. 选择目标容器和文件夹。
  8. 单击 粘贴 。 重用测试的测试属性显示定向至共享测试引用下原始测试的链接。
注： 将正在使用的项目的测试复制到存储库项目还会创建定向至存储项目中测试的链接，并使测试可在其他正在使用的项目中重复使用。如果多次复制某个测试，系统会创建指向上一个副本的链接。
重复使用存储库项目的测试资产时，请注意以下事项：
  • 必须将正在使用的项目配置为重复使用存储库项目的资产，否则复制和粘贴操作不会引用原始资产。
  • 仅可将资产粘贴到现有测试容器。
  • 要保留已分配的需求，正在使用的项目必须将相同需求系统配置为存储库项目。
  • 数据驱动子项、测试包子项和链接测试容器无法重复使用。
  • 重用测试中不考虑继承的测试特性、参数和属性。请注意，如果正在使用继承，接受原始资产更改可能会导致从重用测试中删除特性、参数和属性。
  • 已分配问题不能复制到重用测试。
  • 如果使用测试属性，则两个项目中的属性必须具有相同的名称和类型。
  • 复制项目或设置项目基线时，系统将保留对存储库项目的引用。但导出项目时将删除引用。
  • 批量导出/更新接口和 Web 服务尚未考虑原始资产的链接。
  • 您还可以复制和粘贴文件夹，包括其整个层次结构。
父主题： 共享测试资产
父主题： 使用测试树
相关任务
添加项目
编辑项目和项目基线


维护共享测试版本

在中央存储库项目中维护常用测试并在正在使用的项目中重复使用这些测试，可为您节省在多个项目中维护测试资产的时间。每当在存储库项目中创建新版本测试时，此测试就会被标记为已更新（使用朝上蓝色箭头标记）。右键单击正在使用的项目中的此类测试，然后选择共享测试更改 > 接受更改以将测试更新为最新版本，或选择跳过更改以保留当前版本并删除更新标记。以后在存储库项目中创建新版本时，测试会被再次标记。

您也可能会遇到这样的情况：您更新了正在使用的项目中的重用测试，之后您想将这些更改推送至存储库项目中的原始测试资产。要执行此操作，请单击正在使用的项目中的测试对应的历史记录选项卡中的推送更改至共享测试。这会在正在使用的项目创建一个新版本测试，在存储库项目共享测试中创建一个还原点，以及创建具有您的最新更改的新版本共享测试。重复使用此测试的其他项目之后将会接收更新通知。

父主题： 共享测试资产
相关概念
版本
相关任务
创建版本
查看版本
还原为早期版本


编辑测试

要编辑测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要编辑的测试或测试包。
  3. 单击工具栏上的 [image] （编辑）。

    您还可以单击属性选项卡并单击编辑，或右键单击测试或测试包并选择编辑。

    此时将显示编辑测试对话框。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  4. 编辑所选测试的名称和说明。 如果所选测试为测试包，则根据结果更新程序包结构复选框可用。如果您希望根据测试执行运行的结果更新测试包结构，请选中根据结果更新程序包结构复选框。
  5. 按照配置测试属性中的说明，根据测试类型配置测试或测试包的属性。
父主题： 管理测试
相关概念
配置测试属性
测试包


打印测试

打印测试：

  1. 在菜单中，单击测试 > 网格视图。
  2. 使用 Ctrl+单击或 Shift+单击选择您要打印的测试。
  3. 右键单击所选内容，然后选择打印测试详细信息。 此时将出现测试详细信息对话框。
  4. 单击打印或下载为 PDF。
提示： 您还可以在测试树中选择测试或文件夹，然后选择打印测试详细信息。
父主题： 管理测试


测试运行页面

测试 > 详细信息视图 > <测试> > 运行

运行页面可在详细信息视图中的测试节点查看，并提供选定测试的测试执行结果的列表。

运行页面的数据网格表示有助于对大量测试运行进行筛选、排序和分组。

对于每次运行，页面显示以下列：

列 | 说明
操作 可以对测试运行执行的操作。
新问题
单击可打开新问题对话框，并为测试创建新问题。
分配现有问题
将问题从外部配置的问题跟踪系统分配到测试。
状态 | 执行的状态。对于属于正在运行的执行计划组成部分的测试，将更新状态来响应测试运行的当前状态。如果当前运行已中止，状态将会重置到运行前的状态。
状态原因 | 特定测试运行状态为通过、失败或未执行的原因。
运行 ID | 测试运行的 ID。单击可打开测试运行结果对话框。如果测试正在运行，单击可查看执行的详细信息。
运行类型 | 运行类型列显示每次运行期间的测试类型。测试类型可能会在两次运行间改变，例如将测试从手动转换为自动时。
开始时间 | 开始运行的时间。如果测试是手动测试且当前正在运行，则 Silk Central 将（正在运行）添加到日期和时间。
持续时间 | 测试运行的持续时间（采用 h/mm/ss 格式）。
执行计划 | 已分配执行计划的名称，或未分配的测试 - 如果执行是尝试运行或已上载结果。单击可打开执行计划。
执行者 | 从中运行测试的执行服务器。
发现的问题 | 显示分配给测试运行的问题数。当未向测试运行分配问题时，列为空。单击链接可访问测试 > 详细信息视图的问题页面中的问题。
错误 | 运行期间生成的错误数。
警告 | 运行期间生成的警告数。
版本 | 测试运行的版本。
内部版本 | 测试运行的内部版本号。
执行计划父项 | 执行计划在其中执行的上下文中的配置套件、文件夹或测试周期。 单击可访问执行计划树中的套件或文件夹。 如果配置套件或文件夹中未包含执行计划，则不显示任何内容。
运行注释 | 对于 Silk Performer 测试运行，Silk Performer 在上载结果时使用此列将信息添加到测试运行。对于所有其他测试类型，您可以使用此列将信息添加到运行。

要比较两次或更多测试运行，请使用 Ctrl 或 Shift 选择运行。右键单击您的选择，然后单击比较自动测试结果或报告 > 测试运行比较。

父主题： 管理测试
相关概念
测试运行比较报告
相关任务
比较多次测试运行的测试结果
分配现有问题
相关参考
测试运行结果


测试问题页面

测试 > 详细信息视图 > <测试元素> > 问题

问题页面可使您输入和跟踪与选定测试、容器或文件夹有关的问题。

新问题
单击可将新问题分配到选定测试。此按钮仅在当前选定的对象是测试时显示。
分配现有问题
单击可将问题从外部问题跟踪系统分配到选定测试。此按钮仅在当前选定的对象是测试时显示。
更新问题状态
单击以更新问题状态。

对于每个问题，页面显示以下列：

列 | 说明
操作 | 可以对问题执行的操作。单击 [image] 以删除问题。外部问题不会被删除。
问题 ID | 自动分配给问题的 ID。单击以编辑问题。
已分配测试 | 分配给问题的测试。此列仅在当前选定的对象是容器或文件夹时显示。
摘要 | 问题的摘要。
状态 | 问题的状态。
外部 ID | 表示问题是否由外部问题跟踪系统跟踪。单击外部问题号可直接链接到外部问题跟踪系统。
优先级 | 外部问题跟踪系统内定义的问题优先级。以下问题跟踪系统支持此功能：Atlassian JIRA、Bugzilla、Silk Central Issue Manager 和 StarTeam。
测试运行 | 问题被分配到的测试运行的 ID。单击 ID 可访问执行区域中测试运行结果对话框的详细信息页面。
创建于 | 创建问题的时间。
创建者 | 创建问题的用户。
配置文件 | 问题跟踪配置文件的名称，在 Silk Central > 设置 > 问题跟踪中定义。
父主题： 管理测试
相关概念
问题
Issue Manager


版本

可为共享对象（步骤和关键字）和测试创建版本。版本是某个元素处于特定状态的修订。测试版本中不包含数据集以及继承的测试特性、参数和属性。

您可以手动创建共享对象和测试的版本，或还原为早期版本。共享对象或测试的所有版本均列在元素的历史记录页面中。复制项目时，也会复制版本。如果您使用的是共享测试，另请参阅维护共享测试版本。

  • 创建版本
    创建共享对象或测试的版本，以便您能够还原将来的更改。
  • 查看版本
    查看版本的详细信息，以了解版本是否符合您的测试需求。
  • 比较版本
    要查看共享对象或测试的两个版本之间的差异，请比较这些版本。
  • 还原为早期版本
    要撤消对共享对象或测试的更改，请还原为早期版本。
  • 查看最新更改
    查看测试的最新更改。
  • 跟踪测试的历史记录
    介绍如何跟踪测试的历史记录。
  • 测试历史记录页面
    详述选定测试、测试容器、文件夹或项目的修订历史记录。
  • 库历史记录页面
    显示所选共享对象的历史记录。
父主题： 管理测试
父主题： 库
相关概念
维护共享测试版本
相关任务
创建版本
查看版本
还原为早期版本


创建版本

为了能够还原要应用到共享对象或测试的一组更改，应创建元素的版本。

创建共享对象或测试的版本：

  1. 对于共享对象，请单击菜单中的测试 > 库。对于测试，请单击菜单中的测试 > 详细信息视图。
  2. 选择库树中的共享对象，或选择测试树中的测试。
  3. 单击工具栏中的 创建版本 。 仅在已更改共享对象或测试时，才会启用此操作。 将打开创建版本对话框。
  4. 可选：在注释文本框中，输入版本的注释。
  5. 单击确定。新版本将显示在历史记录页面中。
父主题： 版本
相关概念
维护共享测试版本
版本
相关任务
查看版本
还原为早期版本


查看版本

要查看共享对象或测试的特定版本是否符合您的测试需求，请查看版本的详细信息。

查看共享对象或测试的版本详细信息：

  1. 对于共享对象，请单击菜单中的测试 > 库。对于测试，请单击菜单中的测试 > 详细信息视图。
  2. 选择库树中的共享对象，或选择测试树中的测试。
  3. 单击历史记录选项卡。
  4. 右键单击您要查看其详细信息的版本。
  5. 单击查看版本<ID>。
  6. 此时将打开查看版本对话框。如果版本包括附件，则可通过单击步骤部分的附件列的附件数来查看附件。
    注： 使用箭头更改版本号和查看其他版本。
父主题： 版本
相关概念
维护共享测试版本
版本
相关任务
创建版本
还原为早期版本


比较版本

要查看共享对象或测试的两个版本之间的差异，请比较这些版本。

比较共享对象或测试的两个版本：

  1. 对于共享对象，请单击菜单中的测试 > 库。对于测试，请单击菜单中的测试 > 详细信息视图。
  2. 选择库树中的共享对象，或选择测试树中的测试。
  3. 单击历史记录选项卡。
  4. 使用 Ctrl+单击选择要比较的两个版本。
  5. 右键单击所选内容。
  6. 选择比较版本 <x> 和 <y>.将打开比较版本对话框，显示所有已添加、已更改和已删除内容。
    注： 使用箭头更改版本号和比较其他版本。
父主题： 版本


还原为早期版本

要撤消对共享对象或测试的更改，请还原为早期版本。还原为早前版本时请注意以下特殊情况：
  • 如果继承属性的值与当前版本相比已更改，则还原版本中将会重新继承最新的值。
  • 如果某个属性的类型与当前版本相比已更改，则还原版本中将忽略该属性。
  • 如果当前版本中不再存在列表类型属性的值，则向属性重新添加原始值并在还原版本中使用。

将共享对象或测试还原为早期版本：

  1. 对于共享对象，请单击菜单中的测试 > 库。对于测试，请单击菜单中的测试 > 详细信息视图。
  2. 选择库树中的共享对象，或选择测试树中的测试。
  3. 单击历史记录选项卡。
  4. 右键单击要将共享对象或测试还原到的版本。
  5. 单击还原为版本 <ID>。
  6. 共享对象或测试将还原为选定的版本，并且在历史记录页面中创建新版本。附件和数据集不会为测试而还原。
父主题： 版本
相关概念
维护共享测试版本
版本
相关任务
创建版本
查看版本


查看最新更改

查看测试的最新更改：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 单击 显示更改 以筛选掉所有测试元素，但上次更改确认后已更改的测试元素除外。
    注： 在筛选器列表框中自动选择最新更改筛选器。
  3. 审阅更改后，您可以单击 确认 接受更改。 确认功能将重置最近更改的筛选器。
  4. 再次单击 全部显示 以删除筛选并查看所有测试。
注： 所有测试更改在测试历史记录中生成含时间戳的条目。
父主题： 版本
相关概念
最新更改


跟踪测试的历史记录

Silk Central 提供对测试做出的所有更改的完整历史记录。历史记录信息为只读，无法编辑或永久删除。

跟踪测试元素的历史记录：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择测试树中的测试。
  3. 单击历史记录选项卡。
测试的属性以表格格式显示。
父主题： 版本


测试历史记录页面

测试 > 详细信息视图 > <测试元素> > 历史记录

历史记录页面详述选定测试、测试容器、文件夹或项目的修订历史记录。其中还包括包含选定元素的每个项目基线的条目，以及到基线和基线中相应元素的链接。如果选定元素作为项目基线的一部分创建，则历史记录页面中的第一个条目包括与原始项目及其相应元素的链接。您只能使用链接访问活动项目或基线。有关项目基线的更多信息，请参阅本帮助中的管理主题。

历史记录页面还包括每个选定测试版本的条目，允许您创建新版本、还原为先前版本，以及查看两个选定版本之间的更改。

对于每个更改，页面显示以下列：

列 | 说明
操作 | 仅限于版本条目。可以执行的操作为查看版本、还原为版本和删除版本。
版本 | 仅限于版本条目。测试的版本。
注释 | 更改的注释。
创建于 | 更改的日期和时间。
创建者 | 做出更改的用户。
注： 如果页面包括的元素数量过多，无法在不影响响应时间的情况下一次性显示，这些元素将以递增的方式显示。使用页面底部的导航工具栏可浏览元素。
父主题： 版本
相关概念
版本


配置测试属性

配置属性、参数、附件、成功条件等测试属性。
  • 测试属性
    详述选定测试、测试文件夹、测试包或测试容器的所有属性和相关信息。
  • 测试属性
    属性是能应用于测试的可自由定义的特征。您可以筛选测试区域来查找具有特定属性的测试，并将所有此类测试分配给执行计划。示例包括可以应用到产品组件的平台属性，以及可以应用到测试的优先级属性。
  • 测试参数
    参数是可自由配置的输入值，可分配给不同测试类型并且以多种方式使用。它们可通过定义测试数据来协助定义测试。
  • 测试附件
    附件部分列出了作为附件已上载到选定测试容器、文件夹或测试的所有文件和链接。
  • 数据驱动测试
    介绍如何使用数据驱动测试。
  • 成功条件
    介绍如何确定测试是否成功。
父主题： 测试
相关概念
测试属性
测试参数
测试附件
相关参考
测试属性


测试属性

测试 > 详细信息视图 > 属性

属性页面提供所有属性的详细信息，以及选定测试、测试文件夹、测试包或测试容器的相关信息。在此页的每个部分，都有展开和折叠信息的选项。这样您就能根据自己的特定需求，自定义看到的信息。对于测试节点，创建测试时将配置以下属性：

属性 | 说明
测试名称 | 测试的名称。
测试 ID | 测试的数据库标识符。
说明 测试的说明。
注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
状态
对于配置套件中包括的测试或测试包，状态是套件中所有配置的所有状态的聚合：
  • 如果测试仅分配给配置套件，则只有测试在所有配置中均为通过时状态才为通过。如果不是所有配置中的状态均为通过，则传播最差运行的状态，且采用以下由上而下的优先级：
    1. 不适用
    2. 未执行
    3. 失败
    4. 通过
    如果一个或多个配置中的测试失败，则分配给测试的需求状态为失败。
  • 我们不建议将测试分配给配置套件，以及一个或多个简单的执行计划。但是在这种情况下，配置状态的聚合是一个状态，而执行计划的上次状态为其他状态。上次执行的状态确定测试的最后状态。
  • 如果测试仅分配给简单的执行计划，则会更新状态来响应上次测试运行的状态。
上次执行 | 上次执行的测试。对于属于运行执行计划组成部分的测试，将根据当前测试运行更新上次执行。
已分配的执行 列出了选定测试分配到的所有执行计划。对于列表中的每个执行计划，网格显示以下列：
列
说明
执行
执行计划的名称。单击可查看或编辑执行计划。
状态
执行计划中测试上次运行的状态。如果测试未在执行计划的上次运行中执行，则状态为未执行。对于数据驱动测试或测试包，所有上次运行的状态显示在条形图中。
上次执行
上次作为执行计划的组成部分执行的测试。
执行计划父项
执行计划在其中执行的上下文中的配置套件、文件夹或测试周期。 单击可访问执行计划树中的套件或文件夹。 如果配置套件或文件夹中未包含执行计划，则不显示任何内容。
创建时间 | 创建测试的日期和时间。
创建者 | 创建测试的用户名称。
更改时间 | 上次更改测试的日期和时间。
更改者 | 上次更改测试的用户名称。
计划时间 [hh:mm] | 测试的计划执行时间。仅限于手动测试。
测试属性 | 特定于测试类型的测试属性。
成功条件 | 已为测试配置的所有成功条件。对于测试包节点，将禁用和隐藏除执行超时外的所有成功条件。
默认集成文件夹 | 显示通过外部计划工具创建的测试所在的默认容器或文件夹的名称。有关详细信息，请参阅将测试节点设为外部 Agile 计划工具的集成默认值。
父主题： 配置测试属性
相关概念
配置测试属性
测试属性
测试参数
测试附件


测试属性

属性是能应用于测试的可自由定义的特征。您可以筛选测试区域来查找具有特定属性的测试，并将所有此类测试分配给执行计划。示例包括可以应用到产品组件的平台属性，以及可以应用到测试的优先级属性。
注： 属性的继承类似于属性和成功条件的继承。分配给父节点的属性在所有子文件夹和子测试中继承。
  • 将属性分配到测试
    将属性分配到测试以筛选具有指定属性的测试类别。
  • 编辑测试属性
    编辑测试属性以更改测试的特征。
  • 从测试中删除属性
    如果测试不再以某个属性为特征，则可删除该属性。
父主题： 配置测试属性
相关概念
属性
配置测试属性
测试参数
测试附件
相关参考
测试属性


将属性分配到测试

将属性分配到测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要向其分配属性的测试。
  3. 在属性部分中，单击添加属性。将出现添加属性对话框。
  4. 在要分配属性的添加列中，单击 添加属性 。 根据选择的属性类型，将出现编辑属性对话框，您可在其中指定要分配到测试的可用属性值。
  5. 选择属性值，然后单击确定以将属性分配到测试。
父主题： 测试属性


编辑测试属性

要编辑测试属性：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要为其编辑已分配属性的测试。
  3. 在属性部分，单击要编辑的属性的编辑图标。 此时将显示编辑属性对话框。编辑属性对话框中的可用选项根据您选择的属性类型而变化。
  4. 选择所需的值，然后单击确定以保存您的设置。
父主题： 测试属性


从测试中删除属性

要从测试中删除属性：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要从中删除已分配属性的测试。
  3. 在属性部分，单击要删除的属性的删除图标。 此时将显示删除属性确认对话框。
  4. 单击是以删除属性。
    注： 无法删除继承的属性。
父主题： 测试属性


测试参数

参数是可自由配置的输入值，可分配给不同测试类型并且以多种方式使用。它们可通过定义测试数据来协助定义测试。

测试属性中包含的测试参数（例如 Silk Test Classic 测试的测试数据）列在顶部。未使用的参数附加到列表底部并显示为灰色，类似于禁用状态。

Silk Performer
这些测试使用预定义参数来表示选定 Silk Performer 测试中定义的项目属性。
JUnit，Silk4J
任何 JUnit 和 Silk4J 测试类都可以访问作为 Java 系统属性的基础测试的自定义参数；启动程序可将这些参数传递到使用 -D VM 参数的执行虚拟机。在测试中，可使用 System.getProperty("myParam") 访问参数值。
NUnit，Silk4NET
对于 NUnit 和 Silk4NET，每个参数都将设置为环境变量。在测试中，可使用 Environment.GetEnvironmentVariable("myParam") 访问参数值。
Silk Test Classic
在 Silk Central 的 Silk Test Classic 测试中，通过在测试属性部分的测试数据字段中指定参数，可以将参数传递至 Silk Test Classic。例如，如果将 Silk Central 参数 Name 和 Password 的值传递至 Silk Test Classic，则在测试属性的测试数据字段中指定 "${Name}", "${Password}"。您的 Silk Test Classic 脚本还需要两个参数，用来接收指定的值。
示例：
[-] testcase ProcessParams(STRING name, STRING password)
   [ ] Print(name)
   [ ] Print(password)
外部进程
对于外部进程（WSH、Process Executor、NUnit、JUnitMSTest 和 DotNetExplorer）中执行的任何测试类型，每个参数都将设为进程的环境变量。参数名称与操作系统变量的名称匹配时也会出现这种情况，因此系统变量的值将替换为参数值，但参数值为空字符串时除外。
Silk Test Workbench
参数需要使用 Silk Test Workbench 测试中的相同名称定义，在 Silk Central 中执行时设置。
配置测试
您可以替代执行计划中的测试参数。有关其他信息，请参阅执行计划参数。
自定义测试类型
有关自定义测试类型的详细信息，请参阅 Silk Central API 帮助。
  • 预定义参数
    Silk Central 以参数的形式提供测试执行期间有关执行计划运行属性的信息。
  • 创建自定义参数
    创建自定义参数，以配置不同测试类型的输入值。
  • 将预定义参数添加到 Silk Performer 测试
    介绍如何将预定义参数添加到测试。
  • 编辑预定义参数
    当测试说明发生更改时，编辑预定义参数的值。
  • 删除预定义参数分配
    如果测试不再由参数进行描述，则可删除预定义参数分配。
  • 参数值内的参数
    介绍使用包含参数的参数值。
  • 参数表示法
    介绍支持的参数表示法。
  • 在执行时替换参数令牌
    介绍在执行时占位符如何由为参数输入的值替换。
  • 测试参数页面 - Silk Test Workbench
    介绍 Silk Test Workbench 参数的数据类型映射。
父主题： 配置测试属性
相关概念
执行计划参数
配置测试属性
测试属性
测试附件
相关参考
预定义参数
通过 Java 系统属性访问 Silk Central 参数
测试属性


预定义参数

Silk Central 以参数的形式提供测试执行期间有关执行计划运行属性的信息。
您的测试自动化工具可将这些参数作为环境变量读取（请参见测试参数）。此外，任何 JUnit 测试类都可以将基础测试的测试参数作为 Java 系统属性访问（请参阅通过 Java 系统属性访问 Silk Central 参数）。使用 AttributeGet 方法在 Silk Performer 脚本中读取这些参数。

按照在执行时替换参数令牌中的说明，也可在占位符中引用这些参数值。

可以访问以下预定义参数：

参数
说明
#sctm_execdef_name
当前执行的执行计划的名称。如果从测试区域触发执行，则参数值是未分配的测试。
#sctm_execdef_id
当前执行的执行计划的数字标识符（数据库密钥）。
#sctm_product
已执行测试容器中定义的产品的名称。
#sctm_version
与执行结果关联的版本的名称。
#sctm_build
与执行结果关联的版本的名称。
#sctm_keywords
用逗号分隔的列表，其中包含为此执行计划定义的关键字。
#sctm_test_results_dir
测试的结果文件所在目录的路径。
#sctm_test_name
正在执行的 Silk Central 测试的名称。
#sctm_test_id
正在执行的测试的数字标识符（数据库密钥）。
#sctm_source_root_dir
测试容器根目录的本地路径，所有受版本控制的文件都驻留在此处。
#external_id
测试包中要执行的测试用例的唯一标识符。如果只应该执行测试包中的特定测试用例，那么可以用作筛选器。

#is_test_package_root
如果为 true，则执行的测试为测试包的根节点（默认）。如果为 false，则只执行测试包中由 #external_id 指定的特定测试用例。
#sctm_data_driven_parent_test_name
如果执行的测试是数据驱动的行，则为父测试的名称。
#sctm_data_driven_parent_test_id
如果执行的测试是数据驱动的行，则为父测试的数字标识符（数据库键）。
父主题： 测试参数
父主题： 执行计划参数
相关概念
测试参数
相关参考
通过 Java 系统属性访问 Silk Central 参数


创建自定义参数

要创建自定义参数，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要为其创建新参数的测试节点。
  3. 在参数部分中，单击添加自定义参数。 此时将显示设置自定义参数对话框。
  4. 提供参数名称。
  5. 在类型列表框中，选择参数类型。
    • 字符串
    • 编号
    • 浮点值
    • 布尔
    • 密码
    • 字符
  6. 定义要分配到所选测试的参数值。
    注： 如果要在 Silk Test Classic 执行中使用参数，则“字符串”类型的参数值必须置于引号 (“) 中。
  7. 单击确定。
    注： 参数将自动分配到所有子文件夹以及已向其分配参数的节点的子测试。
父主题： 测试参数


将预定义参数添加到 Silk Performer 测试

将预定义参数添加到测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要向其中添加预定义参数的测试节点。
  3. 在参数部分中，单击添加预定义参数。
    注： 已定义项目属性时，添加预定义参数按钮仅适用于 Silk Performer 测试。
    将显示添加预定义参数对话框，其中列出项目文件中可用的所有项目属性。
  4. 要添加任何所列参数，请单击相应的添加图标。
  5. 在显示的对话框上，指定参数的实际值。
  6. 单击保存以将参数添加到活动的测试树节点。
父主题： 测试参数


编辑预定义参数

要编辑预定义参数：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要为其编辑现有参数的测试节点。
  3. 在参数部分，单击要编辑的参数的编辑图标。 此时将显示设置自定义参数对话框。
  4. 根据需要编辑参数值。
    注： 无法编辑继承的参数。取消选中从父级继承复选框以启用对参数值设置的编辑。无法编辑参数名称和类型设置。
父主题： 测试参数


删除预定义参数分配

要删除预定义参数分配：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要删除其现有参数分配的测试节点。
  3. 在参数部分，在要删除的参数的操作列中，单击删除。
    注： 无法删除继承的参数。取消选中设置参数对话框上的从父级继承复选框可删除继承的参数。
  4. 单击删除参数对话框上的是以删除参数。
父主题： 测试参数


参数值内的参数

您可以使用包含参数的参数值。 此类参数值的评估结果以粗体显示在 GUI 中。 以下示例显示如何使用此类参数：
parameterA := aaa
parameterB := bbb + ${parameterA}
评估的值：
parameterA = aaa
parameterB = bbb + aaa
父主题： 测试参数


参数表示法

支持以下参数表示法：

对于所有测试：
${<parameter>}

参数名称中允许使用除 $、{, } 和 # 之外的所有字符。

对于手动测试，不推荐使用的表示法：
#<parameter>#

对于手动测试，参数名称中允许使用以下字符：0-9、a-z、A-Z 和 _。

Silk Test Classic 测试的其他表示法：
$<parameter>

对于 Silk Test Classic 测试，参数名称中允许使用以下字符：0-9、a-z、A-Z 和 _。

父主题： 测试参数


在执行时替换参数令牌

测试属性的任何字符串输入可能包含以下形式的占位符：${parametername}。parametername 必须与为该测试定义或继承的参数名匹配。在执行时，占位符将由为具有标注名称的参数输入的值替换。这使得属性中的重复字符串具有更高的可自定义性并且便于编辑常用定义。

在 Silk Central 查找包含 ${parametername} 表示法的参数时，它先检查该参数是否包含在定义的参数中。如果不是，它会检查该参数是否定义为执行服务器上的环境变量。环境变量值按照执行服务器启动时的定义来使用。Silk Central 变量名只有在以下情况下才与环境变量名匹配：大小写完全相同，或者所有字符都为小写或都为大写。示例：Silk Central 视环境变量 SilkHome 与 ${SilkHome}、${silkhome} 和 ${SILKHOME} 匹配，但不匹配 ${silkHome}。

例如，如果 JUnit 类路径属性的值是 junit.jar;${MyWorkingDir}/myclasses，且参数 MyWorkingDir 的值为 C:/Temp/MyWorking，那么最终得到的有效属性值为 junit.jar;C:/Temp/MyWorking/myclasses。

注： 参数值还可能包含其他参数占位符，它允许根据相同的原则进行嵌套。
父主题： 测试参数


测试附件

附件部分列出了作为附件已上载到选定测试容器、文件夹或测试的所有文件和链接。

选中包括子附件复选框，以便进一步显示选定节点的子测试、文件夹和测试容器的所有附件。

  • 将文件附加到测试元素
    将文件附加到测试元素，以将更多信息添加到测试。
  • 将链接附加到测试元素
    将链接附加到测试元素，以将更多信息添加到测试。
  • 查看测试附件
    查看测试附件以获取测试的其他信息。
  • 从测试元素下载文件
    将所有附加的文件从测试元素下载到本地磁盘。
  • 从测试元素中删除附件
    如果不再需要附加信息，则可从测试元素中删除附件。
父主题： 配置测试属性
相关概念
配置测试属性
测试属性
测试参数
相关参考
测试属性


将文件附加到测试元素

将文件附加到测试元素：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择容器、文件夹或测试。
  3. 在附件部分中，单击上载文件。 将出现上载文件对话框。
  4. 单击选择文件从您的本地文件系统选择文件。
  5. 可选：键入附件的说明。
  6. 单击确定以将附件上载到服务器并将其与所选元素关联。
父主题： 测试附件


将链接附加到测试元素

将链接附加到测试元素：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择容器、文件夹或测试。
  3. 在附件部分中，单击附加链接。 将出现附加链接对话框。
  4. 在链接字段中键入 URL。
  5. 可选：键入附加链接的说明。
  6. 单击确定以将链接与所选元素关联。
父主题： 测试附件


查看测试附件

对于选定的测试元素，附件页面列出了附加的文件和链接。默认情况下，附件按上载的顺序显示，但您可以按列对附件排序。要显示与选定元素的子元素关联的附件，请选中包括子附件复选框。

要查看测试附件：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择您要查看其附件的元素。
  3. 在附件部分，单击附件的名称。 每个列出的附件名称充当链接。文件附件链接可打开另存为对话框，使您可以将附件下载到本地文件系统。链接附件在新的浏览器窗口中直接链接到链接目标。
父主题： 测试附件


从测试元素下载文件

从测试元素下载所有文件：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择容器、文件夹或测试。
  3. 单击附件选项卡。
  4. 在附件部分，单击下载所有文件。 根据配置的浏览器下载设置，所有附加的文件将作为 zip 存档下载到本地磁盘。
    注： 为了防止过度下载，如果选中了包括子附件，则下载所有文件将禁用。
父主题： 测试附件


从测试元素中删除附件

要从测试元素中删除附件：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要从中删除附件的元素。
  3. 在附件部分，在要删除的附件的操作列中，单击 删除 。
  4. 单击确认对话框上的是以从项目中删除附件。
    注： 每次只能删除一个附件。
父主题： 测试附件


数据驱动测试

数据驱动测试是源自现有数据源（例如，电子表格或数据库）中的值的测试。使用数据驱动测试之前，您需要配置数据源。有关配置数据源的信息，请参阅用于数据驱动测试的数据源。

  • 创建数据驱动测试
    创建数据驱动测试。
  • 将数据源值添加到手动测试步骤
    将数据源值添加到手动测试步骤。
  • 从数据源下载 CSV 数据
    从数据源下载 CSV 数据。
  • 编辑数据驱动属性
    编辑数据驱动属性。
  • 删除数据驱动属性
    当数据驱动属性不再相关并且您要删除数据源时，删除所有数据驱动属性。
  • 原子和非原子数据驱动测试
    介绍可用的数据驱动测试类型。
  • 工作表处理
    介绍如何将工作表作为数据驱动测试的数据源进行处理。
  • 数据导入注意事项
    提供关于从外部数据源导入数据的更多信息。
父主题： 配置测试属性
相关概念
用于数据驱动测试的数据源
创建数据驱动测试
Silk Test Classic 测试


创建数据驱动测试

创建数据驱动测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 创建新测试。 有关更多信息，请参阅创建测试。
  3. 单击新创建测试的属性选项卡。
  4. 在数据驱动属性部分，单击编辑。 将显示数据驱动属性对话框。
  5. 从数据源列表中选择预配置的数据源。有关配置数据源的信息，请参阅用于数据驱动测试的数据源。
    注： 数据源最多可包含 100 行。如果包含 100 行以上，您需要在最多返回 100 行的数据驱动属性对话框中输入查询。这可防止在一个数据源外生成 100 个以上的测试。
  6. 单击下一步以继续。
  7. 从数据集列表中选择数据集。 对于 Excel 数据源，这是工作表名称。对于数据库数据源，这是表名称。
  8. 选中每个数据行是一个测试复选框将数据集中的每行视为一个单独的测试（非原子测试），或者不选中此复选框为数据集的所有数据行创建一个测试（原子测试）。有关详细信息，请参阅原子和非原子驱动测试。
  9. 可选：在筛选器查询字段中输入 SQL 查询，以根据 SQL 语法查询筛选您的数据集。
    仅支持简单的 WHERE 子句查询。例如，要筛选数据，使其只剩下在 City 列中包含 Boston 的数据行，请输入以下筛选器查询：
    City = 'Boston'
  10. 选中启用数据驱动属性复选框以启用数据驱动功能。如果启用此设置，那么配置的数据源将仅用于此测试。
  11. 单击完成以保存设置。
    注： 数据驱动属性设置显示在每个测试的属性页的数据驱动属性部分中。
    注： 要将 Silk Central 的数据驱动测试功能与 Silk Performer 脚本一起使用，必须将列名称与相应 Silk Performer 项目属性匹配的数据源和 AttributeGet 方法结合使用。
父主题： 数据驱动测试
相关概念
用于数据驱动测试的数据源
数据驱动测试
相关任务
管理测试


将数据源值添加到手动测试步骤

将数据源值添加到手动测试步骤：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 创建新数据驱动测试。 选择手动作为测试类型，并配置测试步骤。
    注： 要查看数据源中包含的值，请展开测试的属性页上的数据驱动属性部分。
  3. 单击步骤选项卡。
  4. 选择应引用数据源值的测试步骤。
  5. 在操作说明文本框中，使用语法 ${<列名称>} 输入引用数据源中相关列的参数。 例如，如果想要测试步骤从具有名为密码的列的电子表格中检索密码参数，您应将参数写作 ${Password}。执行手动测试步骤时，参数将替换为相应数据驱动数据源中的实际值。
父主题： 数据驱动测试
相关概念
手动测试


从数据源下载 CSV 数据

要从数据源下载 CSV 数据：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择依赖于要从中下载数据的数据源的测试。
  3. 单击属性选项卡。
  4. 在数据驱动属性部分，在数据源或数据集（具体取决于哪种实体包含要下载的数据）的操作列中，单击 下载 。
  5. 指定要下载数据的本地系统目标位置。
  6. 单击确定以下载 CSV 格式的数据。
父主题： 数据驱动测试
相关概念
手动测试


编辑数据驱动属性

要编辑数据驱动属性：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择具有您要编辑的属性的测试。
  3. 单击属性选项卡。
  4. 在数据驱动属性部分，在要编辑的属性的操作列中，单击 编辑 。
  5. 根据需要编辑属性。
  6. 单击确定以保存您所做的更改。
父主题： 数据驱动测试


删除数据驱动属性

当数据驱动属性不再相关并且您要删除数据源时，删除所有数据驱动属性。
删除数据驱动属性：
  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择您要从中删除数据驱动属性的节点。
  3. 单击属性选项卡。
  4. 在数据驱动属性部分，单击删除。 将从节点中删除所有数据驱动属性。
    注： 也会从继承节点属性的所有子节点中删除数据驱动属性。
父主题： 数据驱动测试


原子和非原子数据驱动测试

计划数据驱动测试时，您应先了解 Silk Central 中提供的以下两种不同数据驱动测试类型：
原子数据驱动测试
为数据源的所有数据行生成单个测试结果。这意味着测试只有在每个数据行都执行成功时才会成功。如果某个数据行的执行失败，整个测试将标记为失败。
非原子数据驱动测试
数据源的每个数据行以其自身的测试表示。这意味着每个数据行将产生失败或通过的测试结果。例如，如果数据源是包含四行的电子表格，除四个新子测试外（其中每个数据行对应一个子测试），您还必须将所创建的原始测试作为父测试。

有关创建数据驱动测试的详细信息，请参阅创建数据驱动测试。

此进程中创建的父测试未关联参数，因为它仅表示其子测试的构建实例，不再像实际测试一样工作。数据源中发现的所有值将列在父测试的数据驱动属性部分中。

将父测试分配给需求时，仅在使用原子数据驱动测试时才继承需求的链接。

您无法将非原子数据驱动测试的父测试分配给安装或清理测试执行，因为此类父节点被视为文件夹。但是，您可以分配其中一个子节点，并且还可以将原子数据驱动测试分配给安装或清理测试执行。

有关数据源限制的详细信息，请参阅数据源限制。

父主题： 数据驱动测试


工作表处理

如果您的数据源是 Microsoft Excel 工作表，应按照以下指南操作，以确保数据驱动测试安装成功并可维护：

  • 将您的列名称设为自我描述性名称。 这会使 Silk Central 中的数据源安装更易维护。
  • 如果您使用多个工作表，则在多个工作表中使用一致的列名称。 这会方便您应用筛选器，以便为数据源安装选择列。
  • 将某些列用作“关键”列。 关键列可让您维护数据源文件，尽管行顺序发生更改，Silk Central 仍可根据关键列中的值识别特定数据行。 关键列中的值应是唯一的。
父主题： 数据驱动测试


数据导入注意事项

从外部数据源导入数据行时，Silk Central 不会考虑在外部数据源中使用的行排序功能。 因此，Silk Central 中的数据行顺序可能与外部数据源中的行顺序不同。 Silk Central 还会忽略已在外部数据源中应用的任何格式设置。 例如，如果您将 Excel 工作表中的日期单元格格式设置为以特定方式显示日期，Silk Central 将忽略此设置并以基本格式“YYYY.MM.DD HH:MM:SS.M”导入任何日期值。

注： 您的数据源可包含最多 100 行。 如果它包含超过 100 行，您需要在返回最多 100 行的数据驱动属性对话框上输入查询。 这将阻止从一个数据源生成超过 100 个测试。
父主题： 数据驱动测试


成功条件

使用成功条件确定测试是否成功。您可以将一个或多个成功条件分配给测试区域中的每个测试节点或套件节点。如果在执行成功条件分配到的测试时不满足成功条件，则执行运行将标记为失败，但执行超时成功条件除外，测试执行对此条件将标记为未执行。对于测试包，将禁用和隐藏除执行超时外的所有成功条件。

在详细信息视图中，选择测试树中的节点时，节点的属性页面中的成功条件表将显示为选定节点配置的所有成功条件。表包括每个条件的名称、条件是否为活动状态、条件的最大值以及是否继承条件。

成功条件仅在处于活动状态时评估。要激活和停用成功条件，请参阅编辑成功条件。可用的成功条件类型因测试类型而异。Silk Central 中当前包含以下成功条件：

成功条件
说明
允许的错误
测试允许的最大错误数。默认情况下，此成功条件处于活动状态。
允许的警告
测试允许的最大警告数。
执行超时 [秒]
测试允许的最大超时（以秒为单位）。
页面时间：平均页面时间 [秒]
加载页面允许的最大平均时间。
页面时间：最大页面时间 [s]
加载页面允许的最大时间。
事务响应时间：平均Trans(Busy)ok [s]
测试中的事务允许的最大平均响应时间。
事务响应时间：最大 Trans(Busy)ok [s]
测试中的事务允许的最大响应时间。

成功条件的继承类似于属性的继承。分配给父节点的成功条件在所有子文件夹和子测试中继承。

  • 编辑成功条件
    编辑成功条件以根据不断变化的测试需要应用条件。
父主题： 配置测试属性


编辑成功条件

在详细信息视图中，如果您在测试树中选择节点，则节点的属性页面将显示与节点关联的成功条件。成功条件表包含每个条件的名称、条件是否处于活动状态、条件的最大值以及是否已继承条件。

注： 对于测试包节点，将禁用和隐藏除执行超时外的所有成功条件。

要编辑测试的成功条件：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择测试容器、测试文件夹或测试。
  3. 单击属性选项卡。 属性页面将显示选定树元素的属性。
  4. 单击成功条件右侧的 编辑 。 此时将显示编辑成功条件对话框。
  5. 取消选中您所编辑的任何成功条件的从父级继承复选框。
  6. 根据需要编辑值。
  7. 通过选中或取消选中条件的活动复选框，指定条件应处于活动还是非活动状态。
  8. 单击确定以保存您的设置。
父主题： 成功条件


执行测试的试运行

您可以执行测试的试运行以检查测试是否按预期工作。

要执行测试的试运行；

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中右键单击要尝试使用的测试。
  3. 选择试运行。
  4. 此时将显示转到活动对话框。如果您要在活动页面上分析结果，请单击是；或者如果要保留在当前网页上，请单击否。 有关其他信息，请参阅活动。
    注： 如果您不希望以后系统再次询问您是否切换到活动页面，请选中不再显示此对话框（在此登录会话期间）复选框。注销 Silk Central 时将会放弃此设置。

成功完成试运行后，您准备开始计划执行。

父主题： 测试
相关概念
活动


库

库就是多个项目中的测试所共享的一组测试步骤和关键字的集合。

共享对象可减少测试工程师需要维护的步骤和关键字数量。通过称作库树的层次树结构显示、组织和保留库。库树可使您以任何数量的层次级别组织共享步骤和关键字。您可以编辑或删除树中的任何节点。右键单击树中的节点可剪切节点或将其复制并粘贴到其他位置。使用可见性页面定义选定库对其可见的项目。库树的根节点称作库，不能编辑。

树中各对象的使用情况页面列出了使用选定对象的测试、共享对象、关键字或关键字序列，让您能估计更改对象所产生的影响。

注： 测试经理、测试工程师和超级用户角色可以创建、编辑和查看库单元中的对象。测试经理和超级用户角色还可以从库单元中删除对象。角色为项目经理、分析员或报告人员的用户可以查看库单元中的对象。
  • 创建库
    创建库，以插入要在测试和项目之间共享的手动测试步骤或关键字的集合。
  • 管理关键字库和库属性
    管理关键字库以及库树中选定节点的属性。
  • 使库可供项目访问
    管理哪些项目可以访问选定库中的共享对象。
  • 管理库中的关键字
    管理您的关键字序列中的关键字，以指定操作序列。
  • 使用 Java 构建关键字驱动的库
    使用 Java 构建外部关键字驱动的库并将其上载到 Silk Central。这能让您轻松将现有测试框架集成到 Silk Central 中，例如您已经有现有的 Selenium 测试。
  • 键盘功能（库）
    树提供键盘和多选支持。
  • 管理共享对象
    介绍 Silk Central 中共享对象的概念。
  • 版本
    介绍如何使用共享对象和测试的版本。
父主题： 测试
相关概念
项目基线


创建库

  1. 在菜单中，单击测试 > 库。
  2. 在库树中，选择名为库的根节点。
  3. 在工具栏中，单击 新建库 创建新库。
    注： 您也可右键单击根节点，然后单击新建库。
父主题： 库


管理关键字库和库属性

测试 > 库 > <库> > 属性

要查看或更新库树中节点的属性，请选择节点并单击属性选项卡。

在关键字库部分中，使用上载和删除按钮上载或删除外部关键字库。

父主题： 库
相关任务
使用 Java 构建关键字驱动的库


使库可供项目访问

测试 > 库 > <库> > 可见性

在可见性页面上，您可以使选定库对所有项目可见，或者限制其对于一系列特定选项的可见性。要更改所选库在项目中的可见性，请单击编辑可见性。

编辑可见性对话框显示可由当前用户分配至库的项目。该对话框包含以下项目：
项 | 说明
所有项目 | 单击此选项按钮可将所有项目分配至库。
选定的项目 | 单击此选项按钮可将列表中选定的项目分配至库。
全选 | 单击以将所有列出的项目分配至库。
取消全选 | 单击以从库中取消分配所有列出的项目。
注： 当前正在使用库的项目将变灰，您不能从库中取消分配它们。

创建使用共享对象的项目基线时，默认情况下，包含这些对象的库将在新的项目基线中可见。有关项目基线的更多信息，请参阅本帮助中的管理主题。

父主题： 库
相关概念
管理


键盘功能（库）

可对所选节点执行以下操作：

键 | 操作
向上 | 将选定内容上移
向下 | 将选定内容下移
右 | 展开元素
左 | 折叠元素
F2 | 编辑元素
Ctrl+C | 复制元素
Ctrl+X | 剪切元素
Ctrl+V | 粘贴元素
Del | 删除元素
单击 | 选择一个元素并将其标记为当前元素。
Ctrl+单击 | 切换所单击元素的选择状态，通过多次单击添加/删除其他元素。
Shift+单击 | 选择从当前所选元素到新选择元素的范围。
Shift+向上 | 选择上面的元素。
Shift+向下 | 选择下面的元素。
父主题： 库


管理共享对象

共享对象是包含于一个库中的手动测试步骤和/或关键字集合，可供多个项目中的多个测试使用。

  • 调用共享步骤
    介绍从库中将共享对象作为一个步骤添加到手动测试或其他共享对象。
  • 创建共享对象
    要重复使用手动测试或共享对象中的一组测试步骤，请在步骤页面中创建共享对象。
  • 从库中提取共享步骤
    为使手动测试或共享对象独立于其他共享对象，请将步骤从包含共享对象的库中提取出来。
  • 管理共享步骤属性
    管理在整个活动项目中可填充到手动测试步骤的所有属性。
  • 添加或编辑手动测试步骤
    使用步骤页面添加或编辑手动测试步骤。
  • 导出和更新共享步骤对象
    说明如何导出和更新共享步骤对象。
  • 步骤页面
    列出了选定测试或共享对象中包括的所有手动测试步骤。
父主题： 库


调用共享步骤

要减少在不同测试和项目中维护相同测试步骤的工作，您可从库中将共享步骤作为一个步骤添加到测试或共享对象。

您仅可在共享对象中添加对所有步骤的一个调用，而非其中部分步骤。添加调用共享对象时，所有共享步骤都将作为一个步骤显示在调用测试或共享对象中，您可在调用的步骤前面或后面添加其他步骤。初始共享步骤仅在引用测试的执行过程中显示。无法删除共享对象。要删除共享对象，首先必须删除其所有调用。

调用其步骤的共享对象的名称显示为步骤页面中的步骤名称。单击该名称以访问调用的共享对象。

  • 添加调用共享步骤
    添加调用共享对象，以在手动测试或其他共享对象中使用共享步骤。
  • 调用共享步骤对话框
    您可通过调用共享步骤对话框浏览库树中的共享对象。
父主题： 管理共享对象


添加调用共享步骤

添加调用共享对象：

  1. 在菜单中，单击测试 > 详细信息视图以将共享步骤添加到测试，或单击测试 > 库以将共享步骤添加到其他共享对象。
  2. 在相应的树中，单击要向其添加共享步骤的节点。
  3. 单击步骤选项卡。
  4. 要将共享步骤添加到步骤列表末尾，请单击 新建调用共享步骤 。要将其插入所选步骤上方，请单击 插入调用共享步骤 。 将打开调用共享步骤对话框。
  5. 从树中选择要添加其步骤的共享步骤节点。
    注： 对于测试，树仅显示对活动项目可见的库。有关更多信息，请参阅可见性页面。
  6. 单击确定。
父主题： 调用共享步骤
相关参考
使库可供项目访问


调用共享步骤对话框

您可通过调用共享步骤对话框浏览库树中的共享对象。要打开对话框，请选择测试树中的手动测试或库树中的共享对象，单击步骤选项卡，再单击 新建调用共享步骤 。

要在库树中搜索现有库、文件夹和共享对象，请在对话框的查找文本框中键入要搜索的名称，然后按 Enter。搜索不区分大小写并且不局限于整个单词。搜索返回的库和文件夹将与其整个子树一起显示。

父主题： 调用共享步骤


创建共享对象

您可在任何手动测试或共享对象的步骤页面中创建共享对象。

创建共享对象：

  1. 对于共享对象，请单击菜单中的测试 > 库。对于测试，请单击菜单中的测试 > 详细信息视图。
  2. 导航到包括要共享步骤的手动测试或共享对象的步骤页面。
  3. 使用 Ctrl+单击或 Shift+单击 选择步骤。
  4. 单击 创建共享步骤 。 将打开创建共享步骤对话框。
  5. 在名称字段中，输入新共享对象的名称。
  6. 在库树中，选择要放置新共享对象的位置。
  7. 单击确定。 将创建共享对象并将所选步骤替换为调用共享对象。
父主题： 管理共享对象


从库中提取共享步骤

为使手动测试或共享对象独立于其他共享对象，请将步骤从包含共享对象的库中提取出来。随后所有调用的步骤都将复制到手动测试或共享对象。

提取手动测试或共享对象中所含的共享步骤：

  1. 对于共享对象，请单击菜单中的测试 > 库。对于测试，请单击菜单中的测试 > 详细信息视图。
  2. 在相应的树中，单击要在其中解析共享步骤的节点。
  3. 单击步骤选项卡。
  4. 使用 Ctrl+单击或 Shift+单击选择要提取的步骤。
  5. 单击 与库分离 并确认消息框。
父主题： 管理共享对象


管理共享步骤属性

测试 > 测试步骤属性

测试 > 库 > <库> > 步骤属性

要创建、编辑或查看库树中共享对象的步骤属性，请选择库并单击步骤属性选项卡。步骤属性页面列出了在整个活动项目中可填充到手动测试步骤的所有属性。要创建新的步骤属性，请单击新建属性。可以对属性执行的操作为删除、上移和下移。

父主题： 管理共享对象
相关概念
步骤属性


导出和更新共享步骤对象

如果要对共享步骤对象执行批量编辑，可使用导出-更新到 Excel 功能。

导出和更新概述

以下是导出和更新的高级概述：

  • 选择库。
  • 导出到 Excel。
  • 在 Excel 中进行更改。
  • 验证/创建映射文件。
  • 更新回 Silk Central。
  • 将共享步骤对象导出到 Excel
    将共享步骤对象导出到 Excel 来执行批量编辑。
  • 从 Excel 更新共享步骤对象
    在 Excel 中更新共享步骤对象后，将它们更新回 Silk Central。
父主题： 管理共享对象


将共享步骤对象导出到 Excel

将共享步骤对象导出到 Excel 来执行批量编辑。
  1. 在菜单中，单击测试 > 库。
  2. 右键单击包含要导出的共享步骤对象的库，然后选择导出到 Excel。 此时会显示将库导出到 Excel 文件对话框。
  3. 从选择映射文件列表框中选择映射文件。 默认映射文件为 LibraryPropertiesDefaultMapping.xml。
  4. 单击编辑映射编辑映射文件。 此时将打开编辑映射对话框。
  5. 指定应映射到属性和步骤属性（如果存在步骤属性）的 Excel 列。 下面的示例解释了映射：

  6. （可选）在另存为字段中更改映射文件的名称。单击确定。 此时会显示将库导出到 Excel 文件对话框。
  7. 单击确定。 Excel 文件随即创建并在浏览器中下载。
打开 Excel 文件，然后编辑共享步骤对象。完成后保存文件，以便上载回 Silk Central。

限制：如果在 Excel 文件中创建、删除或移动了共享步骤对象，那么在将其更新回 Silk Central 后，这些更改将被忽略。

父主题： 导出和更新共享步骤对象
相关任务
从 Excel 更新共享步骤对象
相关参考
管理共享步骤属性


从 Excel 更新共享步骤对象

在 Excel 中更新共享步骤对象后，将它们更新回 Silk Central。
  1. 在菜单中，单击测试 > 库。
  2. 右键单击包含要更新的共享步骤对象的库，然后选择从 Excel 更新...。 此时会显示从 Excel 文件更新库对话框。
  3. 从选择映射文件列表框中选择映射文件。 默认映射文件为 LibraryPropertiesDefaultMapping.xml。
  4. 可选：单击编辑映射编辑映射文件。只有在以下情况下，这才是必要的：用于导出共享步骤对象的映射文件已修改，或者列标题在 Excel 文件中已修改。有关映射属性和步骤属性的详细信息，请参阅将共享步骤对象导出到 Excel。
  5. 单击选择文件在库文件 (.xlsx) 字段中选择 Excel 文件。
  6. 单击确定。 您的更改随即在 Silk Central 中更新。
父主题： 导出和更新共享步骤对象
相关任务
将共享步骤对象导出到 Excel
相关参考
管理共享步骤属性


库历史记录页面

历史记录页面显示所选共享对象的历史记录。

历史记录页面包含每个版本的所选共享对象的条目，允许您创建新版本、查看版本详细信息、还原为先前版本以及查看版本之间的差异。

要在历史记录页面中仅显示版本，而没有其他条目，请打开版本列标题的上下文菜单，选择筛选器，然后在 > 字段中键入 0。

该页面将显示每个所列条目的以下项目：

项 | 说明
操作 | 仅限于版本条目。您可以对所选版本执行的操作包括查看版本、删除版本和还原为版本。
版本 | 仅限于版本条目。共享对象的版本。
注释 | 更改的注释。
创建于 | 创建此历史记录条目的日期和时间。
创建者 | 创建此历史记录条目的用户名。
父主题： 版本


将需求与测试关联

将需求与测试关联，确保测量软件涵盖指定需求的程度。
  • 将需求分配到测试
    当需求应由测试覆盖时将需求分配到测试。
  • 对已分配的需求排序
    对已分配的需求排序，以便根据需要应用已分配的需求页面。
  • 查找已分配的需求
    在可用需求树中查找已分配的需求以将其分配给测试。
  • 删除需求分配
    当测试不再覆盖需求时删除需求分配。
  • 测试已分配的需求页面
    列出了分配给选定测试或项目的需求。
父主题： 测试


将需求分配到测试

将需求手动分配到测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择要分配需求的测试。
  3. 单击已分配的需求选项卡。
    注： 如果您已创建需求筛选器，则可以在需求树上方的筛选器列表中进行选择。要创建新需求筛选器，请单击菜单中的需求 > 详细信息视图 ，然后单击工具栏中的 新建筛选器 。
    可用于分配的所有需求都显示在需求树中。
  4. 选择要分配的需求。 您可使用键盘的 Ctrl 和 Shift 键，以通过标准浏览器多选功能选择多个需求。
  5. 单击分配所有已筛选项，以便将所有已筛选需求分配给所选测试，或将所选内容拖放到已分配的需求区域，或单击任意需求左边的 分配 。只有在您具备管理需求或管理资产权限时，分配所有已筛选需求的功能才会启用。
    注： 选中从需求生成测试对话框上的将新生成的测试分配到需求复选框可将新生成的测试自动分配到从其中生成这些测试的需求。这是默认行为。
父主题： 将需求与测试关联
相关任务
从需求详细信息视图生成测试


对已分配的需求排序

对已分配的需求排序：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中选择测试。
  3. 单击已分配的需求选项卡。
  4. 单击您要按其对需求排序的属性的列标题。 向上或向下的小箭头表示排序基于的列和排序的方向（升序或降序）。
  5. 如果需要，请再次单击列标题以反转排序的方向。
父主题： 将需求与测试关联


查找已分配的需求

要在可用需求树中查找已分配的需求：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择测试。
  3. 单击已分配的需求选项卡。
  4. 在需求的操作列中，单击 查找 以找出需求存储在可用需求树的哪个节点中。
相应的父需求节点将展开，并且已分配的需求将突出显示。
父主题： 将需求与测试关联


删除需求分配

删除需求分配：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择至少向其分配了一个需求的测试。
  3. 单击已分配的需求选项卡。
  4. 在已分配需求的操作列中，单击 删除 或使用 Ctrl+单击或 Shift+单击以选择多个需求，然后按 Del 键。
    注： 要从选定的测试中删除所有需求分配，请单击全部删除。
父主题： 将需求与测试关联


测试已分配的需求页面

测试 > 详细信息视图 > <测试元素t> > 已分配的需求

已分配的需求页面列出了分配给选定测试或项目的需求，让您可以分配其他需求。可用的需求树列出了可以分配的所有需求。

注： 如果您已创建需求筛选器，则可以在需求树上方的筛选器列表中进行选择。要创建新需求筛选器，请单击菜单中的需求 > 详细信息视图 ，然后单击工具栏中的 新建筛选器 。

对于每个已分配的需求，页面显示以下列：

列 | 说明
操作 | 您可以对选定需求执行的操作。删除需求、定位和查看说明。
需求 | 已分配需求的名称。单击可打开需求 > 属性页面。
优先级 | 需求的优先级。
风险 | 与需求相关的潜在风险。
已审阅 | 需求的审阅状态。
父主题： 将需求与测试关联


测试报告

本部分说明 Silk Central 随附的测试相关报告。 测试报告向您概述一段时间内或一系列内部版本中测试的进度和缺陷状态。

  • 状态报告
    介绍可用于测试区域的状态报告。
  • 进度报告
    介绍可用于测试区域的进度报告。
  • 手动测试报告
    介绍测试区域提供的手动测试报告。
  • 基线测试比较报告
    基线测试比较报告比较基线项目与基线并显示已更改、已删除和已创建测试的数量。
  • 测试运行比较报告
    测试运行比较报告可以比较最近两次运行的测试，它会提供关于上下文、状态、错误、警告、持续时间、特性、属性、参数和成功条件的详细信息。
父主题： 测试
父主题： 默认报告


状态报告

以下状态报告可用于测试区域：
每个组件的测试
表示按测试划分的组件覆盖率概述；更易于了解需要测试活动的位置。
已实施测试（按组件）
表示按测试划分的组件覆盖率的概述，这些测试已将实施的属性设为是。
失败的测试（按组件）
表示按组件划分的失败测试的概述；更易于识别环境中最关键的组件。
测试（按测试容器）
通过列出通过的测试数表示每个测试容器的成功率。
质量目标计划报告

表示每个目标条件中的测试数，以及上卷到目标条件的计划时间。

注： 计划时间值仅限于手动测试。自动测试没有计划时间。

针对项目中定义的每个质量目标，可使用以下三种方法拆分本报告：

  • 测试范围 - 根据质量目标中每个项目的总数或所需测试数比较可用的测试总数。
  • 所需计划时间 - 比较质量目标中项目所需的计划时间。
  • 值表 - 列出了所有质量目标项目及相关指标：可用测试、目标 (%)、所需测试和手动测试的计划时间。
注： 对于多重选择属性，将对每个匹配事件计数测试。
质量目标执行报告
直观显示了对每个目标的每个项目执行的测试数。本报告针对项目中定义的每个质量目标拆分为两部分：
  • 执行状态图 - 列出了具有彩色编码执行状态和汇总值的每个质量目标项。
  • 值表 - 列出了所有质量目标项目及其执行指标：通过、失败、未执行、不适用、总计、符合目标的测试和目标的执行百分比。
测试状态概述
表示所有测试的状态概述，由通过、失败、未执行和不适用等状态构成。
测试状态概述（按测试容器）
表示特定测试容器中包含的所有测试的状态概述，由通过、失败、未执行和不适用等状态构成。
父主题： 测试报告


进度报告

以下进度报告可用于测试区域：
跨内部版本“X”和“Y”的测试进度
表示因查看内部版本上下文中的测试状态而得到的测试进度趋势。用户必须指定包括开始和结束内部版本的内部版本范围。
自内部版本 <x>后的手动测试覆盖率（累计）
表示因查看内部版本上下文中的测试状态而得到的手动测试进度趋势（不包括各种自动测试）。用户必须指定开始内部版本号，以用作计算累计进度的基础。
内部版本的自动测试覆盖率（非累计）
表示因查看内部版本上下文中的测试状态而得到的自动测试覆盖率。用户必须指定版本和产品，并且报告显示通过每个内部版本的自动测试可实现的测试覆盖率。
过去 <x> 天特定文件夹中的测试进度
表示因查看具有给定 ID 的测试树节点和过去 <x> 天的测试状态而得到的测试进度趋势。
过去“X”天的测试进度
表示通过考虑过去“X”天的测试状态的测试进度趋势。
本月的测试进度
表示因查看当月测试状态而得到的测试进度趋势
过去“X”天测试成功的百分比（每个组件）
表示每个组件过去“X”天成功测试列表的百分比；有助于标识最关键环境中的组件。
过去“X”天创建的测试（每个组件）
表示每个组件过去“X”天的新测试列表。有助于识别缺少测试活动的组件。
父主题： 测试报告


手动测试报告

测试区域提供以下手动测试报告。
历史计划与 实际执行时间（每个用户）
表示特定时段内每个用户完成的手动测试的计划执行时间和实际所需执行时间的概述。
计划与 实际执行时间（每个用户的状态）
表示每个用户当前挂起的手动测试的计划小时数与实际小时数进度。只有测试结果已由用户输入并分配到输入结果的用户，才会考虑手动测试。
手动测试结果文档
易于打印的手动测试案例报告，用于分配到指定执行计划的所有测试的最新结果。
手动测试结果文档 (Microsoft Word)
易于打印的手动测试案例报告，反映已分配到 Microsoft Word 文档中指定执行计划的所有测试的最新结果。
按执行计划划分的手动测试结果
易于打印的手动测试案例报告，用于分配到指定执行计划文件夹或测试周期的所有测试的最新结果。
手动测试的计划与 实际执行时间（摘要）
表示手动测试执行的计划时间和实际时间之间的偏差概述，按天查看。
父主题： 测试报告


基线测试比较报告

基线测试比较报告比较基线项目与基线并显示已更改、已删除和已创建测试的数量。

基线测试比较报告的输入参数是项目和基线的标识符。

父主题： 测试报告
相关任务
比较项目与基线


测试运行比较报告

测试运行比较报告可以比较最近两次运行的测试，它会提供关于上下文、状态、错误、警告、持续时间、特性、属性、参数和成功条件的详细信息。
注： 运行比较报告不适合比较手动测试和自动测试。当报告的名称包括（上两次运行）时，您只可以比较执行计划或测试的上两次运行。
父主题： 测试报告


已分配的执行计划

将测试分配给执行计划，以便在开发和测试过程中维持对测试执行的控制。
  • 查看已分配的执行
    查看选定测试分配到的执行计划。
父主题： 测试


查看已分配的执行

要查看选定测试分配到的执行计划，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择您要查看其执行计划分配的测试。
  3. 单击属性选项卡。 在执行部分中，测试被分配到的完整执行计划列表显示在已分配的执行计划网格中。
父主题： 已分配的执行计划
相关参考
测试属性


测试视图

Silk Central 提供了多种视图和工具来管理您的测试。

  • 使用测试树
    介绍如何使用测试树。
  • 测试工具栏功能
    提供管理测试的重要命令。
  • 测试文档视图
    提供选定项目中所有测试的重要信息、状态和上次执行的高级视图。
  • 在网格视图使用测试
    本部分说明如何在网格视图中使用测试。
父主题： 测试


使用测试树

测试 > 详细信息视图

和需求一样，通过层次树结构测试树显示、组织和维护测试。测试树可使您以任意数量的层次级别管理测试。树中的每个节点表示一个测试、一个测试文件夹或一个测试容器。

注： 如果页面包括的元素数量过多，无法在不影响响应时间的情况下一次性显示，这些元素将以递增的方式显示。使用页面底部的导航工具栏可浏览元素。
  • 键盘功能（测试）
    树提供键盘和多选支持。
  • 展开或折叠测试树
    展开和折叠测试树以根据查看需要来整合和显示层级级别。
  • 剪切、复制、粘贴和删除测试元素
    剪切、复制、粘贴和删除测试元素以构建和管理项目的测试。
  • 将测试元素从一个项目复制和粘贴到另一个项目
    将测试元素从一个项目复制和粘贴到另一个项目，以在多个项目中重复使用该元素。
  • 重复使用存储库项目的测试资产
    在存储库项目中维护常用测试资产，并在正在使用的项目中重复使用这些资产。
  • 对测试元素重新排序
    对测试树中的测试、测试文件夹和测试容器重新排序，以便根据您的测试需求应用树。
  • 将测试节点设为外部 Agile 计划工具的集成默认值
    将测试节点设为集成默认节点，以便通过外部 Agile 计划工具在 Silk Central 中启用测试创建。
  • 在文件夹或容器上筛选
    在文件夹或容器上筛选可仅显示文件夹或容器的内容。
  • 查找测试属性
    搜索特定属性值可查找包含此值的所有测试。
  • 替换测试属性
    搜索特定属性值以便在包含此值的测试中将其替换。
  • 测试内容页面
    显示选定项目、测试容器或文件夹的子元素。
父主题： 测试视图


键盘功能（测试）

可对所选节点执行以下操作：

键 | 操作
向上 | 将选定内容上移
向下 | 将选定内容下移
右 | 展开元素
左 | 折叠元素
F2 | 编辑元素
Ctrl+C | 复制元素
Ctrl+X | 剪切元素
Ctrl+V | 粘贴元素
Del | 删除元素
Ctrl+向上 | 向上移动元素
Ctrl+向下 | 向下移动元素
单击 | 选择一个元素并将其标记为当前元素。
Ctrl+单击 | 切换所单击元素的选择状态，通过多次单击添加/删除其他元素。
Shift+单击 | 选择从当前所选元素到新选择元素的范围。
Shift+向上 | 选择上面的元素。
Shift+向下 | 选择下面的元素。
输入 | 分配元素（仅在分配树中）
父主题： 使用测试树


展开或折叠测试树

您可根据查看需要来整合测试树的级别或显示树的所有级别。

要折叠或展开测试树的级别：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择测试树中的测试容器或测试文件夹，然后继续选择以下选项之一：
    • 单击测试元素名称左侧的 展开 可展开元素。
    • 单击测试元素名称左侧的 折叠 可折叠元素。
    • 右键单击元素并选择展开或折叠。
父主题： 使用测试树


剪切、复制、粘贴和删除测试元素

您可通过测试区域中的工具栏轻松剪切、复制、粘贴和删除测试树中的测试元素，包括当前项目中以及项目之间的元素。这些编辑功能简化了项目的测试构建和管理流程。

与测试和测试文件夹一起复制的数据类型包括属性、参数和附件。不会复制分配、问题、运行和历史记录。

注： 容器无法复制或粘贴。

要剪切、复制、粘贴或删除测试元素，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择您要编辑的元素。您可使用 Ctrl+单击或 Shift+单击选择多个元素。
  3. 单击相应的工具栏按钮：
    按钮
    说明
    从树中删除所选元素。
    从树中剪切所选元素并将其移至剪贴板。
    将所选元素复制到剪贴板。
    将剪贴板上的元素副本粘贴到当前所选元素的相同级别上。
    将剪贴板上的元素副本粘贴为当前所选元素的子节点。
    注： 命令也通过测试树中的上下文菜单和键盘快捷方式提供。
父主题： 使用测试树
相关参考
测试内容页面


将测试元素从一个项目复制和粘贴到另一个项目

在项目之间复制和粘贴测试文件夹或测试：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择源项目。
  3. 在菜单中，单击测试 > 详细信息视图。
  4. 单击 剪切 或 复制 以将元素剪切或复制到剪贴板。
  5. 在菜单中，单击项目 > 项目列表。
  6. 选择目标项目。
  7. 选择目标容器和文件夹。
  8. 单击 粘贴 。
注： 命令也通过测试树中的上下文菜单和键盘快捷方式提供。
父主题： 使用测试树


对测试元素重新排序

对测试、测试文件夹或测试容器重新排序：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择您要重新排序的测试元素。
  3. 单击 上移 将测试元素向上移动一步，或者单击 下移 将测试元素向下移动一步。
父主题： 使用测试树


将测试节点设为外部 Agile 计划工具的集成默认值

要使用 Web 服务调用通过外部 Agile 计划工具在 Silk Central 中创建测试，请将测试树中的文件夹或容器设为集成默认节点，Web 服务将在此创建测试。如果您未指定集成默认节点，将显示错误消息框。

指定测试树中的集成默认节点：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择您要将其设为集成默认节点的文件夹或容器。
  3. 右键单击文件夹或容器，并选择设为集成默认值。
    注： 如果集成默认节点已存在，则默认节点将更改为新节点。
将集成默认节点设为选定的节点，以使 Agile 计划工具在此位置创建测试。
注： 集成默认节点显示在节点所在项目的属性页面。
父主题： 使用测试树
相关参考
测试属性


在文件夹或容器上筛选

要在文件夹或容器上进行筛选：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 右键单击要筛选的树中的文件夹或容器，然后选择筛选子树。 此树将仅显示所选文件夹或容器的内容和不超过树的根节点的层次结构。
注： 要删除筛选并显示所有元素，请从工具栏中的筛选器列表中选择 <无筛选器>。 已筛选的子树中不会显示空文件夹。
父主题： 使用测试树


查找测试属性

测试区域的查找命令使您可找到满足指定搜索条件的测试属性值。使用下一个、上一个、第一个和最后一个功能可逐步浏览指定属性值的搜索结果。所有 Silk Central 插件和功能类别中都启用了查找。

注： 可使用查找命令查找数据驱动测试属性。
注： 如果测试树被筛选器所约束，则仅可对筛选后出现在测试树中的测试进行查找。

要查找特定测试属性值：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 单击工具栏上的 查找 。 此时将打开查找对话框。
  3. 从类别列表框中，选择您要在其中搜索的功能类别或 Silk Central 插件。
    提示： 定义自定义插件属性时，它会自动添加到列表。
  4. 从查找位置列表框中，选择查询应在其中搜索值的属性。 此列表中的可用属性因所选类别而异。
  5. 在查找内容文本框中，键入查询应搜索的字母数字字符串。

    可选设置可用于进一步限定查询。选中相应设置的复选框：

  6. 在测试树中选择开始搜索的位置。 提供以下选项：
    选项按钮
    说明
    从选定内容开始
    指定搜索从当前所选测试元素开始。
    从顶部开始
    指定搜索从测试树的根开始。
    仅在子树中查找
    指定仅在具有当前所选测试树元素及其根节点的子树中运行搜索。
  7. 选中相应的复选框以进一步限定查询。 提供以下复选框：
    复选框
    说明
    区分大小写
    指定搜索字符串时区分大小写。
    注： 如果使用区分大小写 SQL Server，则以下字段不支持不区分大小写搜索：
    • 测试说明
    • 手动步骤说明
    • 手动步骤操作说明
    • 手动步骤预期结果
    仅全字匹配
    指定搜索结果仅包括查询字符串的完整独立实例。
    包括只读值
    指定搜索结果包括无法直接编辑的字符串，因为它们是从其他测试继承、从链接的测试容器引用或从数据驱动型测试过程中的数据源调用。
  8. 单击查找开始搜索并前进到查询返回的第一个测试容器、测试文件夹或测试。
  9. 如果查询返回多个测试元素，则会向您提供进一步处理元素的选项。
    注： 查找命令使您可搜索其搜索字符串为继承值的测试元素。
父主题： 使用测试树
相关任务
替换测试属性


替换测试属性

替换命令可让您使用新值替换识别的属性值。所有 Silk Central 插件和功能类别中都启用了替换。

注： 无法使用替换命令替换数据驱动测试属性值。
注： 测试树受筛选器约束时，仅对筛选后显示在测试树中的测试执行替换。

替换识别的测试属性值：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 单击工具栏上的 替换 。 此时将打开替换对话框。
  3. 从类别列表框中，选择您要在其中搜索的功能类别或 Silk Central 插件。
    提示： 定义自定义插件属性时，它会自动添加到列表。
  4. 从查找位置列表框中，选择查询应在其中搜索值的属性。 此列表中的可用属性因所选类别而异。
  5. 在查找内容文本框中，键入查询应搜索的字母数字字符串。

    可选设置可用于进一步限定查询。选中相应设置的复选框：

  6. 在替换为文本框中，键入您要替换找到的值的字母数字字符串。
  7. 单击查找开始搜索并前进到查询返回的第一个测试容器、测试文件夹或测试。或者，单击全部替换将所有查询字符串实例替换为替换字符串。
  8. 如果查询返回多个测试元素，则会向您提供进一步处理元素的选项。
    注： 替换命令不允许您搜索其中搜索字符串是继承值的测试元素。
父主题： 使用测试树
相关任务
查找测试属性


测试内容页面

测试 > 详细信息视图 > 内容

内容页面显示测试树中选定项目、测试容器或文件夹的子元素。该页面支持标准 Windows 资源管理器风格的多选功能。

提示： 要深入到选定文件夹或容器，请按 Enter 或双击选定的项目。请按 Backspace 或单击工具栏中的 向上 以导航到上一级。
注： 您无法复制或粘贴测试容器。
提示： 和列在测试树中的测试元素一样，您可以右键单击列在内容页面上的元素，以通过上下文菜单访问上下文相关的命令。不可用的命令显示为灰色。必须首先在页面上明确选择元素以获得应用程序的焦点，之后才能将测试元素粘贴到内容页面。
注： 如果页面包括的元素数量过多，无法在不影响响应时间的情况下一次性显示，这些元素将以递增的方式显示。使用页面底部的导航工具栏可浏览元素。

内容页面支持以下测试元素键盘功能（快捷方式）：

键 | 操作
上移 | 将选定内容上移
下移 | 将选定内容下移
右 | 取消选择
左 | 取消选择
F2 | 编辑元素
Ctrl+A | 全选
Ctrl+C | 复制元素
Ctrl+X | 剪切元素
Ctrl+V | 粘贴元素
Del | 删除元素
Ctrl+向上 | 向上移动元素
Ctrl+向下 | 向下移动元素
单击 | 选择一个元素并将其标记为当前元素。
Ctrl+单击 | 切换所单击元素的选择状态，通过多次单击添加/删除其他元素。
Shift+单击 | 选择从当前所选元素到新选择元素的范围。
Shift+向上 | 向上扩展选定内容
Shift+向下 | 向下扩展选定内容
Pos1 | 选择第一项
Shift+Pos1 | 向上选择到第一项
End | 选择最后一项
Shift+End | 向下选择到最后一项
父主题： 使用测试树


测试工具栏功能

测试 > 详细信息视图

测试工具栏提供管理测试的重要命令。

注： 测试工具栏中的命令也可通过测试树中的上下文菜单提供。

测试工具栏中包括以下命令：

命令 | 图标 | 说明
文档视图 | 文档视图 | 显示文档视图，以便在单个视图中显示所有测试元素的选定属性。
详细信息视图 | 测试计划视图 | 显示详细信息视图，可让您深入查看单个测试的属性。
网格视图 | 网格视图 | 显示网格视图，以便在网格中显示所有测试。
向上 | 向上 | 在导航树的层次结构中导航到上一级，不管当前光标位于何处。
新建测试容器 | 新建测试容器 | 允许创建新的测试容器。
新建子测试文件夹 | 新建子测试文件夹 | 允许将新测试文件夹创建为选定文件夹或容器的子节点。
新建子测试 | 新建子测试 | 允许将新测试创建为选定文件夹或容器的子节点。
编辑 | 编辑 | 编辑选定的测试元素。
创建版本 | 创建版本 | 创建选定手动测试的新版本。
删除 | 删除 | 删除选定的测试元素。
剪切 | 剪切 | 从测试树中剪切测试元素并将其保存到剪贴板。
复制 | 复制 | 将测试元素从测试树复制到剪贴板。
粘贴 | 粘贴 | 将测试元素从剪贴板粘贴到测试树。
粘贴为子项 | 粘贴为子项 | 将测试元素作为子元素从剪贴板粘贴到当前选定的测试元素。
上移 | 上移 | 在测试树中将测试元素上移。
下移 | 下移 | 在测试树中将测试元素下移。
查找 | 查找 | 根据可配置的参数在活动项目中搜索所有测试元素。
替换 | 替换 | 将找到的值的实例替换为新值。
新建筛选器 | 新建筛选器 | 为测试树创建新的自定义筛选器。
筛选器 |  | 列出了测试树的可用筛选器
编辑筛选器 | 编辑筛选器 | 编辑当前选定的自定义筛选器。
删除筛选器 |  | 删除当前选定的自定义筛选器。
复制筛选器 | 删除筛选器 | 复制当前选定的自定义筛选器。
显示更改 | 显示更改 | 显示测试的最新更改。
确认 | 确认 | 确认对测试的更改。
下载为 XLSX | 确认 | 此功能在文档视图和网格视图中处于启用状态。在文档视图中，该操作会生成 Excel 表，包括所有当前可见的行。在网格视图中，该操作会生成 Excel 表，包括所有行，而不只是可见的行。
父主题： 测试视图


测试文档视图

测试 > 文档视图

文档视图提供选定项目中所有测试的重要信息、状态和上次执行的高级视图。

对于每个测试容器、测试文件夹和测试，文档视图显示以下列：

项 | 说明
上次执行 | 选定测试或项目的上次执行时间。
状态 上次测试执行的状态。如果执行当前正在运行，则将显示未执行状态。
  • 通过
  • 失败
  • 未执行
  • 不适用
对于测试容器和文件夹，状态栏显示相应状态的测试数。
上次创建 | 在其上执行上次执行的内部版本。
最后完成执行 | 上次完成的手动测试执行的时间。对于自动测试，此状态与上次执行相同。
最后完成执行状态 | 上次完成的手动测试执行的状态。对于自动测试，此状态与状态相同。
最后完成执行内部版本 | 在其中执行上次完成的手动测试执行的内部版本。对于自动测试，此状态与上次内部版本相同。
测试数 | 测试数目。
计划时间 | 向上滚动手动测试的计划时间。
已分配的问题 | 分配给测试的问题数。
更改时间 | 更改选定测试元素的最后时间。
更改者 | 上次更改选定测试元素的用户。
属性 | 如果已将属性分配到测试，您可选择在网格中显示属性。属性是能应用于测试的可自由定义的特征。您可将属性用于筛选和报告用途。
父主题： 测试视图


在网格视图使用测试

测试区域中的网格视图通过促进大量测试的筛选、排序和分组来补充文档视图和详细信息视图。网格视图有助于识别测试之间的匹配点和查找特定测试信息。可使用标准 Windows 键盘快捷方式，以便轻松选择和操作网格视图中的特定测试集。您可以执行测试的试运行并从网格视图访问测试。您也可以通过在网格视图中选择多个测试来创建执行计划。

网格视图提供许多视图自定义功能，有助于您更好地管理大量测试。您可以显示或隐藏列，调整列的宽度，以及使用拖放功能四下移动列。为了提高执行大量测试的效率，页面视图被分为每个视图 50 个测试。您可以使用第一个、最后一个、下一个和上一个浏览页面。您也可以在页面文本框中输入页码，并按 Enter 访问指定的页面。上下文菜单命令提供排序、分组和筛选功能，有助于您更好地组织测试、分组测试，并识别测试之间的匹配点。所有视图自定义首选项与项目一起保存，并在下次访问网格视图时可用。

  • 从网格视图访问测试
    直接从网格视图访问测试视图中的测试。
  • 在网格视图中创建执行计划
    在网格视图中创建执行计划，以将测试直接分配到执行计划。
  • Modifying Properties and Attributes for Multiple Tests
    Describes how to modify property and attribute values for more than one test.
  • 显示和隐藏网格视图中的列
    显示和隐藏网格视图中的列以显示所需的信息。
  • 在网格视图中分组测试
    在网格视图中分组测试，以轻松查看具有通用值的测试。
  • 删除网格视图中的测试分组
    删除网格视图中的测试分组以查看排序后的测试。
  • 在网格视图中对测试排序
    介绍如何在网格视图中对测试排序。
  • 对网格视图中的列重新排序
    对网格视图中的列重新排序，以将其按您喜欢的顺序显示。
  • 调整网格视图中列的大小
    更改列宽，以将其按您喜欢的宽度显示。
  • 在网格视图中筛选测试
    介绍如何在网格视图中筛选测试。
  • 还原默认网格视图设置
    说明如何还原项目的默认网格视图设置。
  • 在网格视图中将现有问题分配到测试
    介绍如何在网格视图中将现有问题分配到一个或多个测试。
父主题： 测试视图


从网格视图访问测试

您可直接从网格视图访问测试视图中的测试。

从网格视图访问测试的属性页面：

  1. 在菜单中，单击测试 > 网格视图。
  2. 单击要访问的测试的名称。 或者，右键单击测试行并选择转到测试。
父主题： 在网格视图使用测试


在网格视图中创建执行计划

在网格视图中创建执行计划：

  1. 在菜单中，单击测试 > 网格视图。
  2. 通过使用网格视图的多选功能选择要分配到执行计划的测试。
  3. 右键单击测试并选择创建执行计划。 将显示新建执行计划对话框。
  4. 输入新执行计划的规范。
注： 所有选定测试必须位于相同容器中。 否则，将不会创建执行计划，并且会显示错误消息。 测试容器已在新建执行计划对话框中预先选定并且无法更改。
父主题： 在网格视图使用测试
父主题： 管理执行计划、文件夹和配置套件
相关任务
创建执行计划


Modifying Properties and Attributes for Multiple Tests

To modify property or attribute values for multiple tests:

  1. 在菜单中，单击测试 > 网格视图。
  2. Select the tests for which you want to edit the properties or attributes. You can select multiple tests with Ctrl+Click or Shift+Click.
  3. Right click and select Multi-Edit. The Multi-Edit dialog box opens. This dialog lets you set the value of the selected property or attribute to the same value for all selected tests.
    提示： Right-clicking on a cell of a specific property or attribute column pre-selects this property or attribute in the Multi-Edit dialog box.
  4. Select Properties or Attributes from the Category list.
  5. Select the Name of the property or attribute to modify.
  6. Select the Value of the property or attribute that will apply to all selected tests.
  7. Click OK. The selected property or attribute value is applied to all selected tests.
父主题： 在网格视图使用测试


显示和隐藏网格视图中的列

要显示和隐藏网格视图中的列：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开列标题的上下文菜单。
  3. 展开列子菜单以查看项目中可用的所有列。
  4. 选中要在网格视图中显示的所有列的复选框。 当您每次打开活动项目时，都会保存和显示列显示首选项。
父主题： 在网格视图使用测试


在网格视图中分组测试

除了简单地按列分类外，您可将测试分块至组以便查看。组基于作为分组依据的列中的通用共享值。

要在网格视图中分组测试：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开要作为分组依据的列的列标题上下文菜单，然后选择按此字段分组。 根据所选列中的通用共享值，将测试组织到组。
父主题： 在网格视图使用测试


删除网格视图中的测试分组

删除网格视图中的测试分组：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开任何列标题的上下文菜单。
  3. 取消选中按组显示复选框。
父主题： 在网格视图使用测试


在网格视图中对测试排序

在网格视图中对测试排序：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开要作为测试排序依据的列的列标题上下文菜单。
  3. 选择升序排序将按升序对测试排序，或选择降序排序按降序对测试排序。 将保存您的排序首选项，每次打开活动项目时将按此显示。
父主题： 在网格视图使用测试


对网格视图中的列重新排序

对网格视图中的列重新排序：

  1. 在菜单中，单击测试 > 网格视图。
  2. 选择您要移动的列的列标题。
  3. 将列拖到所需位置，然后将其释放。 将保存您的列顺序首选项，每次打开活动项目时将按此显示。
父主题： 在网格视图使用测试


调整网格视图中列的大小

调整网格视图中列的宽度：

  1. 在菜单中，单击测试 > 网格视图。
  2. 选择您要调整的列的垂直列标题分隔线。
  3. 将列边界拖到所需位置，然后将其释放。 将保存您的列宽首选项，每次打开活动项目时将按此显示。
父主题： 在网格视图使用测试


在网格视图中筛选测试

您可根据列的值筛选测试列表。 您可指定以下项目：
  • 要应用到基于文本的数据字段的筛选字符串。
  • 基于日期的字段的日历筛选器，使用之前、之后或当天运算符。
  • 数据运算符，用于基于数字的字段。 >、< 和 =。
  • 在网格视图中筛选基于文本的值
    在网格视图中筛选基于文本的值可仅显示与筛选条件匹配的测试。
  • 在网格视图中筛选基于日期的值
    在网格视图中筛选基于日期的值将仅显示与筛选器条件匹配的测试。
  • 在网格视图中筛选基于数字的值
    在网格视图中筛选基于数字的值可仅显示与筛选条件匹配的测试。
  • 在网格视图中筛选布尔值
    在网格视图中筛选布尔值将仅显示与筛选器条件匹配的测试。
  • 使用网格视图中的预定义列表筛选值
    使用网格视图中的预定义列表筛选值可仅显示与筛选条件匹配的测试。
  • 删除特定的网格视图筛选器
    删除应用到网格视图中的列的特定筛选器以显示排除的测试。
  • 删除所有网格视图筛选器
    删除应用到网格视图中的列的所有筛选器以显示所有测试。
父主题： 在网格视图使用测试
相关概念
筛选器


在网格视图中筛选基于文本的值

要在网格视图中筛选基于文本的值：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开基于文本且要作为筛选器依据的列的列标题上下文菜单。
  3. 展开上下文菜单上的筛选器子菜单可显示筛选器文本框。
  4. 在文本框中键入文本字符串。
  5. 按下 Enter。 与筛选条件匹配的所有测试，以测试名称为例，包含指定字符串的所有测试名称都将动态显示在已筛选列表中。
父主题： 在网格视图中筛选测试


在网格视图中筛选基于日期的值

要在网格视图中筛选基于日期的值：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开基于日期且要作为筛选器依据的列的列标题上下文菜单。
  3. 将光标停留在上下文菜单的筛选器上可显示之前、之后和当天子菜单。
  4. 将光标保持在之后上可定义应该排除其之前（并包括该日期）的所有测试的日期。将光标保持在之前上可定义应该排除其之后（并包括该日期）的所有测试的日期。将光标停留在当天上可排除具有指定日期的测试之外的所有测试。 此时将显示日历工具。
  5. 使用日历工具选择日期或单击今天来指定为当天日期。
    提示： 您必须明确单击日历工具上的日期，或单击输入来激活基于日期的筛选更改。
    与筛选器条件匹配的所有测试将动态显示在已筛选列表中。
父主题： 在网格视图中筛选测试


在网格视图中筛选基于数字的值

要在网格视图中筛选基于数字的值：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开基于数字且要作为筛选器依据的列的列标题上下文菜单。
  3. 展开上下文菜单中的筛选器子菜单，以显示 >、< 和 = 运算符。
  4. 在 > 文本框中输入一个数字，以定义一个数字，小于（或等于）该数字的所有测试都应排除。在 < 文本框中输入一个数字，以定义一个数字，大于（或等于）该数字的所有测试都应排除。在 = 文本框中输入一个数字，以排除具有指定数字的测试之外的所有测试。
    注： 数字值舍入到两位小数。
  5. 按下 Enter。 与筛选器条件匹配的所有测试将动态显示在已筛选列表中。
父主题： 在网格视图中筛选测试


在网格视图中筛选布尔值

要在网格视图中筛选布尔值：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开基于布尔值且要作为筛选器依据的列的列标题上下文菜单。
  3. 展开上下文菜单上的筛选器子菜单可显示可用值。
  4. 单击是或否选项按钮。 与筛选器条件匹配的所有测试将动态显示在已筛选列表中。
父主题： 在网格视图中筛选测试


使用网格视图中的预定义列表筛选值

要使用网格视图中的预定义列表筛选值：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开以下列的列标题上下文菜单：该列有要作为筛选器依据的预定义筛选器值，例如 NodeType。
  3. 展开上下文菜单上的筛选器子菜单可显示可用值。
  4. 选中感兴趣的筛选器值的复选框。 此时将显示具有所选条件之一的所有测试。
父主题： 在网格视图中筛选测试


删除特定的网格视图筛选器

注： 您可以按标题识别筛选的列，这些标题以粗体和倾斜文本显示。隐藏列将删除应用到该列的所有筛选器。

删除特定的网格视图筛选器：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开含有要删除的筛选器的列的列标题上下文菜单。
  3. 取消选中筛选器复选框。
父主题： 在网格视图中筛选测试


删除所有网格视图筛选器

注： 您可以按标题识别筛选的列，这些标题以粗体和倾斜文本显示。隐藏列将删除应用到该列的所有筛选器。

删除所有网格视图筛选器：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开任何列标题的上下文菜单，然后选择重置筛选器。
父主题： 在网格视图中筛选测试


还原默认网格视图设置

还原默认网格视图设置将重置当前项目的所有用户定义的设置。用户定义的设置如下：
  • 列顺序
  • 列宽度
  • 显示和隐藏列
  • 应用筛选器
  • 正在排序
  • 分组

还原默认网格视图设置：

  1. 在菜单中，单击测试 > 网格视图。
  2. 打开任何列标题的上下文菜单，然后选择重置视图。
父主题： 在网格视图使用测试


在网格视图中将现有问题分配到测试

将现有问题分配到一个或多个测试：
  1. 在菜单中，单击测试 > 网格视图。
  2. 右键单击测试。您可使用 Ctrl+单击或 Shift+单击选择多个测试。
  3. 单击分配现有问题，选择配置文件，然后在问题 ID 字段中键入问题编号（以逗号隔开）。
父主题： 在网格视图使用测试


执行计划

执行计划区域使您可在开发和测试过程中维持对测试执行的控制。此区域包含如下一些活动：配置执行计划、安排执行计划、分配测试至执行计划、设置执行计划的依赖关系、配置执行服务器部署以及使用关键字配置动态硬件配置。 执行计划通过层次树结构 - 执行计划树来显示、组织和维持。每个执行计划可能具有与其关联的任意数目的子测试。执行计划树使您可以在任意数目的层次级别中组织文件夹内的执行计划。

  • 手动执行计划
    介绍手动执行计划以及如何从质量目标创建执行计划。
  • 配置测试
    介绍如何在 Silk Central中执行配置测试。
  • 管理执行计划、文件夹和配置套件
    介绍如何在 Silk Central 中使用执行计划。
  • 执行计划视图
    介绍执行计划区域中的可用视图。
  • 使用 Silk Performer 项目
    Silk Performer 项目可以集成到 Silk Central 测试并通过 Silk Central 直接执行。
  • Silk Test Classic 测试
    介绍如何在 Silk Test Classic 中执行测试。
父主题： Silk Central 帮助


手动执行计划

要访问此页面，请单击执行计划 > 手动执行计划。

计划手动测试通常面临的挑战是测试太多，而资源却不足。 在执行测试时实现最大益处非常重要。 为此，手动执行计划页面分为两个视图：

测试选择
选择手动测试并在测试周期中计划它们。
测试分配
计划详细的手动测试执行。 确定手动测试人员需要在特定测试周期中执行哪个测试。

要访问测试选择视图，请单击执行计划 > 手动执行计划。

要访问测试分配视图，请单击手动执行计划页面右上角的测试分配。 要返回测试选择视图，请单击左上角的测试选择。

  • 演练
    此演练通过示例向您展示手动执行计划的功能。
  • 测试选择
    介绍测试选择视图、如何使用测试周期以及如何筛选和分配手动测试。
  • 测试分配
    列出了分配给特定测试周期和测试人员的手动测试。
  • 手动测试
    介绍 Silk Central 的手动测试功能以及如何在手动测试窗口中有效执行手动测试。
父主题： 执行计划
相关参考
测试周期属性页面


演练

此演练通过示例向您展示手动执行计划的功能。示例假设包括：

  • 根据 Risk 属性完全记录和分类需求。
  • 根据定义执行特定测试必要性的 Importance 属性来完全记录 575 个手动测试、将其分配给需求并进行分类。
  • 已根据需求属性 Risk 和测试属性 Importance 定义质量目标，也称为项目退出条件。这些质量目标指定所需的测试级别。
  • 要计划的测试仅限最能满足质量目标的那些测试。
  1. 概述（演练）
    提供“手动执行计划”页面的区域概述。
  2. 创建测试周期（演练）
    介绍如何通过定义开始日期、结束日期和容量来创建测试周期。
  3. 添加手动测试人员（演练）
    介绍如何将手动测试人员添加到测试周期以及如何定义容量。
  4. 选择测试与计划（预排）
    介绍如何筛选、排序并分组测试，以及如何将其分配给测试周期。
  5. 将测试分配到手动测试人员（演练）
    介绍如何将测试周期的测试分配到手动测试人员。
父主题： 手动执行计划


概述（演练）

手动执行计划页面包含四个区域，它们显示在两个屏幕上。在第一个屏幕（即测试选择屏幕）上，您可以为测试周期选择和计划测试。在第二个屏幕（测试分配屏幕）上，您可以将所选测试周期的测试分配至将执行测试的测试人员。

测试选择屏幕分为三个区域：

  • 左侧的筛选条件区域。通过筛选器功能，您可以缩小在下一区域中显示的测试范围。
  • 中间的匹配测试区域。此列表显示所有可用测试。应用筛选器后，只显示筛选后的测试。
  • 右侧的测试周期区域。在此处，您可以将中部列表中的测试分配至特定测试周期，它是已定义的时间期限。

要访问测试分配屏幕，请单击右上角的测试分配 >>>。此屏幕分为两个区域：

  • 左侧的测试周期区域。这与测试选择屏幕上的区域相同，它显示在两个屏幕上。
  • 右侧的已分配的测试区域。此列表显示已添加至当前所选测试周期的测试。在此处，您可以将列表中的测试拖到测试周期区域，然后将其放到测试人员上。

父主题： 演练
下一主题： 创建测试周期（演练）


创建测试周期（演练）

第一步是创建测试周期。测试周期是定义的时间段，包含开始日期、结束日期和手动测试人员列表。我们将我们的测试周期命名为 第 21 周 - 团队 A。
  1. 在菜单中，单击执行计划 > 手动执行计划。
  2. 在右侧的测试周期区域中，单击新建测试周期。 将显示新建测试周期对话框。
  3. 输入测试周期的名称，此示例中为 第 21 周 - 团队 A。
  4. 输入说明（可选）。
  5. 单击开始日期旁边的 [image] 以设置测试周期的开始日期。
  6. 单击结束日期旁边的 [image] 以设置测试周期的结束日期。
  7. 以 hh:mm 格式输入要为此测试周期提供的时间长度（容量），我们在此示例中输入 35:00。
  8. 单击确定。
我们的测试周期此时显示在测试周期区域中。它显示当前未分配任何测试人员。下一步是分配测试人员。

父主题： 演练
上一主题： 概述（演练）
下一主题： 添加手动测试人员（演练）


添加手动测试人员（演练）

下一步将手动测试人员添加到我们的测试周期。我们还将定义此测试周期中每个手动测试人员拥有的容量。
  1. 在我们的测试周期标题第 21 周 - 团队 A 中，单击 ... > 编辑已分配的测试人员。 此时将显示编辑已分配的测试程序对话框。
  2. 单击添加/删除测试程序。 此时将显示添加/删除测试程序对话框。
  3. 从可用列表中选择用户组。
  4. 从可用列表中的用户组选择一个或多个用户。
  5. 单击添加或全部添加以将用户添加到已选定列表。
  6. 单击确定。 用户现在将添加到编辑已分配的测试人员对话框中的列表。
  7. 对于已添加的每个用户，请在容量字段中使用 hh:mm 格式提供测试周期的容量。
  8. 单击关闭。
此时，我们的测试周期会显示适用于整个测试周期以及每个手动测试人员的可用资源。燃尽图将显示尚未完成的已分配测试。创建我们的测试周期和添加手动测试人员之后，我们可确定下一步需要完成的测试。

父主题： 演练
上一主题： 创建测试周期（演练）
下一主题： 选择测试与计划（预排）


选择测试与计划（预排）

本主题介绍如何将测试分配给我们的测试周期。目标是选择最佳覆盖已定义质量目标的测试。其中一个质量目标基于需求风险。典型做法是首先测试高风险事物。
  1. 在左侧的筛选条件区域，请选中质量目标下的需求风险复选框。 将匹配测试列表的范围缩小到关键的测试。
  2. 在匹配测试区域，打开列标题的上下文菜单，对测试进行排序、筛选或分组。这有助于选择应计划的测试。
  3. 选择一个或多个测试，将其拖到右侧的测试周期区域，然后将其拖到我们的测试周期。 将测试添加到测试周期时，将更新已使用资源的指示器。在指示器上移动鼠标，以了解有关总容量、计划时间和剩余时间的详细信息。
  4. 计划具有严重风险的所有测试后，再计划高风险测试。之后计划中等风险的测试，以此类推。

分配给我们测试周期的测试已移到无特定测试人员行。在下一步中，我们会将测试分配给手动测试人员。

父主题： 演练
上一主题： 添加手动测试人员（演练）
下一主题： 将测试分配到手动测试人员（演练）


将测试分配到手动测试人员（演练）

现在，我们将测试周期中的测试分配到手动测试人员。
  1. 单击右上方的测试分配 >>>。 将出现测试分配屏幕。
  2. 在左侧的测试周期区域中，单击我们的测试周期中的无特定测试人员行。 所有未分配到测试人员的测试将显示在右侧的已分配的测试区域中。
  3. 选择一个或多个测试并将其拖至左侧的测试周期区域，然后将其放至手动测试人员。 将测试分配到手动测试人员时，会更新资源指示符。将鼠标移至此指示符上方，以查看有关容量、计划时间和剩余时间的详细信息。
  4. 将测试分配给手动测试人员之后，请单击 ... > 开始测试周期以开始测试。

测试周期开始时，每个手动测试人员会收到关于已分配测试的电子邮件通知。您可将测试收件箱（分配给我的手动测试）添加到您的个人仪表板。分配给您的所有测试都列在此处。

父主题： 演练
上一主题： 选择测试与计划（预排）


测试选择

测试选择视图是您进入手动执行计划页面时显示的初始视图。您可在此使用筛选器和质量目标缩小手动测试列表、创建和编辑测试周期，以及将筛选的手动测试分配到测试周期。

测试选择视图被划分为三个区域：
  • 左侧的筛选条件区域。通过筛选器，您可以缩小下一个区域中显示的测试范围。
  • 中间的匹配测试区域。此列表显示所有可用测试。应用筛选器后，只显示筛选后的测试。
  • 右侧的测试周期区域。您可在此将测试从中间的列表分配到测试周期。
  • 筛选器条件
    介绍如何在筛选器条件区域中应用筛选器和质量目标。
  • 匹配测试
    介绍匹配测试区域。
  • 测试周期
    测试周期是定义的时间段，包含开始日期、结束日期和手动测试人员列表。创建测试周期来计划和执行特定的手动计划集。
父主题： 手动执行计划


筛选器条件

筛选器条件区域提供了以下筛选选项：

筛选器摘要

列出应用于页面的所有筛选器。

单击筛选器旁边的 [image] 可将筛选器从列表中删除。

测试筛选器

包含当前项目的所有测试筛选器列表。

选择测试筛选器。已筛选的测试将在匹配测试区域显示。

质量目标/分配任务进度

显示项目中的质量目标列表和质量目标值。

选择一个或多个质量目标值。已筛选的测试将在匹配测试区域显示。

每个质量目标值都具有分配任务进度条。进度条将显示已分配的测试数和尚未分配至执行计划的测试数。

注意： 这些数目包含手动和自动测试。

将鼠标在进度条上移动可显示：

  • 匹配测试总数。
  • 要达到目标的测试数。
  • 已分配的测试数。
  • 尚未分配的测试数。

如果已分配的测试数大于要达到目标的测试数，则会出现感叹号。这意味着分配的测试多于所需的测试。

注意： 这些数目包含手动和自动测试。
容器/文件夹

显示容器/文件夹测试层次结构。

选择某个容器或文件夹将在匹配测试区域中只显示所选节点的子测试。

注： 您只能为每个质量目标选择一个测试筛选器和一个目标值。

如果您选择多个质量目标值（从不同的质量目标）或一个质量目标值和一个测试筛选器，则仅与所有条件匹配的测试才会在匹配测试区域显示。

父主题： 测试选择


匹配测试

匹配测试区域显示符合所选筛选器条件的手动测试。默认情况下，不会选择质量目标或筛选器，因此所有手动测试都将显示网格中。

在筛选器条件区域中选择筛选器和质量目标值以缩小手动测试列表。

匹配测试网格的标题显示：

  • 当前所选测试的数量。
  • 当前所选测试的总计划时间。

您可以在网格中执行以下操作：

  • 要将手动测试分配至测试周期，请将该测试拖到测试周期的标题上。
  • 要将手动测试分配至手动测试人员，请将该测试拖到测试周期的测试人员中。
  • 打开列标题的上下文菜单，对手动测试进行排序、分组和筛选，添加或删除列以及重置筛选器或视图。
  • 右键单击手动测试可显示测试详细信息或打印手动测试。
  • 您可使用 Ctrl+单击或 Shift+单击选择多个测试。
  • 您可以多次将测试分配至不同的测试周期/测试程序。如果测试至少分配一次，则已分配将显示绿色复选标记。
  • 单击 [image] 以显示测试详细信息。
  • 单击 [image] 以在测试 详细信息视图中显示测试。
父主题： 测试选择


测试周期

测试周期是定义的时间段，包含开始日期、结束日期和手动测试人员列表。创建测试周期来计划和执行特定的手动计划集。

测试周期区域列出了当前项目的所有测试周期。这是手动执行计划页面的中心部分，并显示在测试选择和测试分配视图中。测试周期按时间顺序排序。

单击测试周期区域顶部的新建测试周期以创建新测试周期。如果要隐藏测试周期，请单击显示/隐藏测试周期。此外，还可使用搜索字段仅显示包含搜索词的测试周期。隐藏测试周期有助于您保持测试周期区域整洁和提高性能。当您有很多测试周期时，这会非常有用。

在测试周期标题中，单击操作 (...) 来访问该菜单。单击 [image] 可在执行计划树中查找测试周期。

在测试周期中，单击手动测试人员可在已分配的测试区域显示已分配的测试。

单击测试周期的标题进行选择。分配给测试周期（而非特定手动测试人员）的测试列在已分配的测试区域。如果已分配的测试区域未显示，请单击右上角的测试分配。

测试周期框显示：

  • 测试周期的名称。
  • 开始和结束日期。
  • 可视化测试进度的燃尽图。此图显示所有测试在测试周期结束时完成的可能性。将鼠标移到其中一栏上可显示未完成的测试数。
  • 剩余容量。该值的计算方式如下：已分配测试的总计划时间减去手动测试人员的总容量。该值针对测试周期和各个测试人员显示。如果测试周期或手动测试人员的测试重载，绿框将变成红框。将鼠标移到此框上可获得详细信息。
  • 已分配的测试和已完成的测试数量（对于测试周期和各个测试人员）。将鼠标移到这些数值上可获得详细信息。
  • 已分配给每个测试周期的手动测试人员。单击已分配测试人员的数量可展开或折叠详细信息。
  • 创建测试周期
    介绍如何在手动执行计划页面中创建测试周期。
  • 将手动测试人员添加到测试周期
    介绍如何将手动测试人员添加到测试周期以及如何提供容量。
  • 编辑已分配的测试程序
    介绍如何在测试周期中添加/删除手动测试人员以及如何定义各个测试人员的容量。
  • 添加里程碑
    介绍如何将里程碑添加到测试周期，这在整个测试周期内的测试人员容量分布不均时将非常有用。
  • 将测试分配到测试周期
    介绍如何在手动执行计划页面上将测试分配到测试周期。
  • 将测试分配到手动测试人员
    介绍如何将测试周期中的测试分配到手动测试人员，以分配测试人员的工作量。
  • 将测试从一个测试周期移到另一个
    介绍如何在手动执行计划页面上将测试从一个测试周期移到另一个。
  • 将测试从一个测试人员移到另一个
    介绍如何将测试从一个手动测试人员转移到另一个具有可用容量的测试人员，以在测试周期内分配工作负载。
  • 从测试周期中删除测试
    介绍如何从手动执行计划页面上的测试周期中删除已分配的测试。
  • 从手动测试人员删除测试
    介绍如何从手动执行计划页面上的手动测试人员删除已分配的测试。
  • 从执行计划中导入测试
    介绍如何从执行计划中将手动测试导入测试周期。
  • 同步测试周期
    如果要用对已分配测试所做的更改更新测试周期的当前运行，您可以同步测试周期。
  • 复制测试周期
    介绍如何复制测试周期。
  • 隐藏测试周期
    介绍如何隐藏测试周期以保持手动执行计划页面整洁和提高性能。
  • 开始测试周期
    介绍如何开始测试周期，以执行分配到测试周期的手动测试。
  • 完成测试周期
    介绍如何完成测试周期以完成分配至测试周期的所有手动测试。
  • 删除测试周期
    介绍如何删除测试周期。
父主题： 测试选择
父主题： 测试分配


创建测试周期

注： 您也可在执行计划详细信息视图和文档视图中创建新测试周期。

创建测试周期：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域中，单击新建测试周期。 将显示新建测试周期对话框。
  3. 输入测试周期的名称。
  4. 输入说明（可选）。
  5. 单击开始日期旁边的 [image] 以设置测试周期的开始日期。
  6. 单击结束日期旁边的 [image] 以设置测试周期的结束日期。
  7. 以 hh:mm 格式输入要为测试周期提供的时间长度（容量）。

    将测试人员添加到测试周期后，此容量将替换为测试人员容量的总和。

  8. 单击确定。 测试周期将添加到测试周期区域。
父主题： 测试周期


将手动测试人员添加到测试周期

创建测试周期后，您可能想要向其添加手动测试人员以及容量。

您也可在执行计划详细信息视图中添加手动测试人员。在菜单中，单击执行计划 > 详细信息视图。单击左侧的测试周期，然后单击属性页面上的添加/删除测试程序。

将手动测试人员添加到测试周期：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ... > 编辑已分配的测试人员。 此时将显示编辑已分配的测试程序对话框。
  3. 单击添加/删除测试程序。 此时将显示添加/删除测试程序对话框。
  4. 从可用列表中选择要使用的用户组。
  5. 从可用列表中选择一个或多个用户。 您可以使用 Ctrl+单击或 Shift+单击选择多个用户。
  6. 单击添加或全部添加以将用户添加到已选定列表。
  7. 单击确定。 用户将添加到测试人员列表。
  8. 使用 hh:mm 格式在容量字段中为测试周期的每个用户定义容量。
  9. 单击关闭。 测试周期容量将使用每个手动测试人员的累计容量值进行更新。
父主题： 测试周期


编辑已分配的测试程序

您可以在测试周期中添加/删除手动测试人员并定义各个测试人员的容量。

要编辑已分配的测试程序：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ... > 编辑已分配的测试程序。 此时将显示编辑已分配的测试程序对话框。
  3. 单击添加/删除测试程序。 此时将显示添加/删除测试程序对话框。
  4. 从可用列表中选择要使用的用户组。
  5. 添加或删除测试程序：
    • 在可用列表中选择一个或多个用户，然后单击添加或全部添加。
    • 在已选定列表中选择一个或多个用户，然后单击删除或全部删除。
    您可以使用 Ctrl+单击或 Shift+单击选择多个用户。
  6. 单击确定。 用户现在将添加至已分配测试程序列表或从该列表中删除。
  7. 使用 hh:mm 格式在容量字段中为测试周期的每个用户定义容量。
  8. 单击关闭。 测试周期容量将使用每个手动测试人员的累计容量值进行更新。
您还可以在详细信息视图中编辑已分配的测试程序。在菜单中，单击执行计划 > 详细信息视图。单击左侧的测试周期，然后单击属性页面上的添加/删除测试程序。
父主题： 测试周期


添加里程碑

里程碑是在指定日期必须达到的目标。当整个测试周期内的测试人员容量分布不均时，里程碑将非常有用。这些里程碑通过燃尽图（位于仪表板上）上按日期和容量分布的标记来表示。

下面是测试周期上下文中的里程碑示例：

  • 到 9 月 13 日，必须完成至少 20% 的测试。
  • 到 9 月 15 日，必须完成至少 50% 的测试。
  • 到 9 月 19 日（测试周期结束），必须完成所有测试。

添加里程碑：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ... > 编辑里程碑。 此时将显示编辑里程碑对话框。
  3. 单击添加里程碑，定义截止日期和已完成测试的百分比，然后单击确定。
  4. 要编辑里程碑，请单击 [image] 。要删除里程碑，请单击 [image] 。
  5. 添加其他里程碑，然后单击关闭。
注： 如果复制测试周期或编辑开始和结束日期，请确保里程碑仍然处于测试周期的定义时间段内。
父主题： 测试周期


将测试分配到测试周期

将测试分配到测试周期：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在匹配测试区域中选择测试，然后将它们拖至测试周期的标题上。您也可右键单击测试工程师，然后选择将所选测试分配到 <手动测试工程师>。 您可使用 Ctrl+单击或 Shift+单击选择多个测试。 这些测试将添加到测试周期。
注： 您可将测试多次分配到不同测试周期/测试人员。如果测试至少已分配一次，则匹配测试区域中的已分配列会显示绿色复选标记。
父主题： 测试周期


将测试分配到手动测试人员

注： 将测试分配到手动测试人员之前，您需要将手动测试人员添加到测试周期。

将测试分配到手动测试人员，以分配测试人员的工作量。

您可将测试多次分配到不同测试周期/测试人员。如果测试至少已分配一次，则匹配测试区域中的已分配列会显示绿色复选标记。

您也可在测试分配视图中将测试分配到手动测试人员。单击右上方的测试分配。选择已分配的测试区域中的测试并将其拖至测试周期中的手动测试人员。

将测试分配到手动测试人员：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期中，单击已分配的测试人员以展开手动测试人员列表。
  3. 选择匹配测试区域中的测试并将其拖至测试周期中的手动测试人员。您也可右键单击测试工程师，然后选择将所选测试分配到 <手动测试工程师>。将所选测试拖放到 [image] 图标上，将它们分配给所有测试人员。 您可使用 Ctrl+单击或 Shift+单击选择多个测试。
父主题： 测试周期


将测试从一个测试周期移到另一个

您可以将测试从一个测试周期移到另一个测试周期。如果您无法及时完成所有测试并且希望将这些测试移到下一个测试周期，则这可能有用。

要将测试从一个测试周期移到另一个测试周期：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 单击右上方的测试分配。 手动执行计划页面将切换为测试分配视图。
  3. 在左侧的测试周期区域，单击测试周期的标题。
  4. 在已分配测试区域中选择测试，然后将它们拖至其他测试周期。您也可右键单击测试工程师，然后选择将所选测试分配到 <手动测试工程师>。

    您可使用 Ctrl+单击或 Shift+单击选择多个测试。

父主题： 测试周期


将测试从一个测试人员移到另一个

您可以将测试从一个手动测试人员移到另一个具有可用容量的测试人员，以在测试周期内分配工作负载。

要将测试从一个手动测试人员转移到另一个手动测试人员：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 单击右上方的测试分配。 手动执行计划页面将切换为测试分配视图。
  3. 在左侧的测试周期区域，单击手动测试人员。 分配到手动测试人员的测试将显示在已分配的测试区域。
  4. 在已分配测试区域中选择测试，然后将它们拖至其他手动测试工程师。您也可右键单击测试工程师，然后选择将所选测试分配到 <手动测试工程师>。

    您可使用 Ctrl+单击或 Shift+单击选择多个测试。

父主题： 测试周期


从测试周期中删除测试

从测试周期中删除测试：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 单击右上方的测试分配。 手动执行计划页面将切换为测试分配视图。
  3. 在左侧的测试周期区域，单击测试周期的标题。 分配到测试周期的测试将显示在已分配的测试区域。
  4. 单击 [image] 从测试周期中删除测试。

    您可使用 Ctrl+单击或 Shift+单击选择多个测试。

注： 您无法从已完成的测试周期中删除测试。您可以将测试拖到其他测试周期或测试人员，来从已完成的测试周期复制测试。
父主题： 测试周期


从手动测试人员删除测试

从手动测试人员删除测试：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 单击右上方的测试分配。 手动执行计划页面将切换为测试分配视图。
  3. 在左侧的测试周期区域，单击手动测试人员。 分配到手动测试人员的测试将显示在已分配的测试区域。
  4. 您可以从测试周期删除测试，或仅从手动测试人员删除测试，但将其保留在测试周期中：
    • 要从手动测试人员和测试周期删除测试：请单击 [image] 。
    • 要从手动测试人员删除测试，但将其保留在测试周期中：请单击已分配的测试区域中的测试，并将其拖到测试周期区域中的无特定测试人员。

    您可使用 Ctrl+单击或 Shift+单击选择多个测试。

注： 您无法从分配到已完成测试周期的手动测试人员删除测试。您可以将测试拖到其他测试周期或测试人员，来从已完成的测试周期复制测试。
父主题： 测试周期


从执行计划中导入测试

您需要具有从执行计划中导入测试的管理测试周期和配置权限。
要从执行计划中导入测试：
  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ... > 从执行计划中导入测试。 此时将显示选择执行计划对话框。
  3. 选择执行计划，然后单击确定。 执行计划的所有测试都将分配到测试周期的无特定测试程序中。
父主题： 测试周期


同步测试周期

如果要用对已分配测试所做的更改更新测试周期的当前运行，您可以同步测试周期。
您需要具备管理测试周期和配置权限才能同步测试周期。
要同步测试周期，请执行以下操作：
  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ... > 同步测试周期。
  3. 如果您确定要用对已分配测试所做的更改更新测试周期的当前运行，请确认消息。
父主题： 测试周期


复制测试周期

您需要管理测试周期和配置权限才能复制测试周期。
要复制测试周期：
  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ... > 复制测试周期。 此时将显示复制测试周期对话框。将复制属性（名称、说明、开始日期、结束日期和容量）并在字段中填写。
  3. 可选：选择准备复制测试分配的方式。例如，可以选择不复制通过测试，使您仅重新运行失败和未执行测试。
  4. 单击确定。 测试周期将以所有分配的测试和测试程序重复。
父主题： 测试周期


隐藏测试周期

您可在手动执行计划页面上隐藏测试周期，以保持页面整洁和提高性能。当您有很多测试周期时，这会非常有用。

隐藏测试周期：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域中，单击显示/隐藏测试周期。此外，还可使用搜索字段仅显示包含搜索词的测试周期。 此时将显示可见测试周期对话框。
  3. 取消选中将隐藏的所有测试周期，然后单击确定。要隐藏所有完成的测试周期，请单击取消选择完成项。
    提示： 打开列标题的上下文菜单，对测试周期进行排序、筛选或分组。选择了多个测试周期时，您可使用空格键切换选定项目。
  4. 要快速隐藏某个测试周期，您也可单击测试周期标题中的 ...，然后单击隐藏测试周期。
  5. 要显示隐藏的测试周期，请再次单击显示/隐藏测试周期，然后标记测试周期。
如果您在手动执行计划页面上隐藏某个测试周期，您仍可在详细信息视图和文档视图的执行计划树中以及仪表板面板和报告中看到该测试周期。每个用户都要进行可见性设置。每个用户都可定义要显示的测试周期和要隐藏的测试周期。
父主题： 测试周期


开始测试周期

注： 开始测试周期前，请确认测试周期的开始日期与当前日期一致。如果不一致，请确保您能够在不同的日期开始测试周期。

开始测试周期：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ... > 开始测试周期。

    测试周期只能开始一次。如果测试周期已开始，此操作被禁用。运行的测试周期将显示开始日期和结束日期之间的测试进度。尚未开始的测试周期将显示未开始。已完成的测试周期将显示已完成。

    此时将显示开始测试周期对话框。
  3. 选择要测试的产品的版本和内部版本。在已分配测试测试容器中指定的所有产品都会列出。
    注： 要在测试周期开始后更改版本和内部版本，请单击 ... > 更新版本和内部版本。
  4. 单击确定。

已分配的手动测试将被分发到手动测试人员。将通过电子邮件通知测试人员，并且测试将在仪表板的分配给我的手动测试面板中显示。

在测试周期开始后，仍然可以更改运行的测试、更改产品版本和内部版本、分配其他测试、删除测试或在测试人员之间移动测试。

父主题： 测试周期


完成测试周期

注： 在完成测试周期之前，验证测试周期的结束日期与当前日期相对应。如果不是，确保可在不同日期完成测试周期。

要完成测试周期：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ... > 完成测试周期。

    如果测试周期尚未开始，则此操作将被禁用。未运行的测试周期在开始和结束日期之间显示尚未开始。正在运行的测试周期显示测试进度。已完成的测试周期将显示已完成。

  3. 此时将显示完成测试周期对话框。选择要对尚未执行的测试执行的操作，然后单击完成。选定状态更改仅应用于状态原因尚未设置的未执行测试。
注： 已完成的测试周期将被锁定。无法将测试或测试程序添加到已完成的测试周期/无法从已完成的测试周期删除测试或测试程序。您可以将测试拖到其他测试周期或测试人员，来从已完成的测试周期复制测试。
父主题： 测试周期


删除测试周期

注： 您还可以在执行计划、详细信息视图和文档视图中删除测试周期。右键单击测试周期，然后单击删除。

要删除测试周期：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 在测试周期区域的测试周期标题中，单击 ...删除测试周期。
  3. 单击删除确认对话框上的是。
父主题： 测试周期


测试分配

要访问此页，请单击执行计划 > 手动执行计划 。 单击右上角的测试分配。

测试分配视图是手动执行计划页面的第二个视图。 您可以在此组织分配给选定测试周期的手动测试。

  • 测试周期
    测试周期是定义的时间段，包含开始日期、结束日期和手动测试人员列表。创建测试周期来计划和执行特定的手动计划集。
  • 已分配的测试
    显示分配到所选测试周期或手动测试人员的手动测试。
  • 手动配置测试
    介绍如何在已分配的测试区域中为手动测试分配配置。
父主题： 手动执行计划


已分配的测试

已分配的测试区域显示当前所选测试周期或手动测试人员的已分配测试。要显示一个测试周期中多个测试人员的已分配测试，请使用 Ctrl+单击或 Shift+单击在测试周期内选择多个测试人员。

已分配的测试网格的标题显示：

  • 当前所选测试周期的名称。
  • 当前所选测试人员的名称。

您可在网格中执行以下操作：

  • 要将手动测试分配到其他测试周期，请将测试拖至测试周期的标题。
  • 要将手动测试分配到（其他）手动测试人员，请将测试拖至测试周期中的测试人员。
  • 打开列标题的上下文菜单，对手动测试进行排序、分组和筛选，添加或删除列以及重置筛选器或视图。
  • 右键单击手动测试，以显示测试详细信息、为测试指定配置或从测试周期中删除测试。
  • 您可使用 Ctrl+单击或 Shift+单击选择多个测试。
  • 单击 从测试周期中删除 将测试从测试周期中删除。
  • 单击 显示测试详细信息 来显示测试详细信息。
  • 单击 查看手动测试结果 来查看手动测试结果。
  • 单击 转到测试 在测试详细信息视图中显示测试。
  • 要从手动测试人员而非测试周期删除测试，请将测试拖至测试周期中的无特定测试人员。
  • 要更改执行顺序，请单击顺序字段，然后键入次序编号，再按 Enter。
    提示： 如果您分配了多个测试容器或配置的测试，则次序编号并不唯一。在这种情况下，您可以按照测试容器或配置列分组测试。
注： 如果要在筛选器条件区域应用筛选器或质量目标值，则将禁用已分配的测试网格中与筛选器不匹配的测试。
父主题： 测试分配


手动配置测试

您可以使用不同的软件和硬件配置执行手动测试。

要为手动测试分配配置：

  1. 在菜单中，单击执行计划 > 手动执行计划。 此时将显示手动执行计划页面。
  2. 单击右上方的测试分配。 手动执行计划页面将切换为测试分配视图。
  3. 在已分配的测试区域中右键单击测试。

    您可使用 Ctrl+单击或 Shift+单击选择多个测试。

  4. 单击指定配置。 此时将显示指定配置对话框。
  5. 单击 > 或 < 分配或取消分配所选的配置。您还可以在选择或输入配置字段中输入新名称，然后单击 > 来创建新配置。

    要编辑和组织更详细的配置，请单击执行计划 > 配置。

    对于每个配置，测试实例将添加到已分配的测试网格。
    注： 如果取消分配配置，那么此配置将对当前选定的测试人员禁用。但是，不会删除为其他测试程序分配的实例。
  6. 单击确定。
您可以为不同的手动测试人员和测试周期分配新测试实例。
父主题： 测试分配


手动测试

Silk Central 的手动测试功能允许测试人员高效地执行手动测试。手动测试窗口提供直观、易于使用的 UI 以及仅与执行流程中的手动测试人员相关的信息。

手动测试人员可通过分配给我的手动测试仪表板来快速访问手动测试窗口。有关仪表板和面板的更多信息，请参阅仪表板。手动测试窗口的结构如下所示：在概述区，列出了选定执行计划或测试周期所包含的测试。在下方的测试步骤区域中，显示为选定测试配置的步骤列表。手动测试人员可以从上到下执行步骤。

作为手动测试人员，您可以勾出已成功执行的测试和测试步骤、编写结果文本、创建和分配问题以及附加结果文件。此外，您还可以捕获屏幕图像和录制视频以说明如何执行某个测试或测试步骤，或者显示测试过程中发生的问题。

集成的计时器会为您显示执行测试所用的时间，并且进度条会显示测试进度。Testbook（这是可添加到仪表板的一个面板）为您显示在项目中进行手动测试期间发生的所有活动的实时更新。

  • 手动测试窗口
    介绍手动测试窗口的基本结构和区域。
  • 捕获屏幕图像
    介绍如何通过键盘命令捕获屏幕图像和使用屏幕捕获窗口。
  • 录制视频
    介绍如何在手动测试窗口中录制视频。
  • 附加结果文件
    介绍如何附加结果文件。
  • 分配或创建问题
    介绍如何创建新问题以及如何分配现有问题。
  • 为手动测试选择移动设备
    选择要在其上执行手动测试的移动设备（物理设备、仿真器或模拟器）。
  • 启动代码分析
    介绍如何在手动测试窗口中启动代码分析。
  • 编辑版本和内部版本
    介绍如何在手动测试窗口中编辑版本和内部版本。
  • 测试和测试步骤的状态
    介绍 Silk Central 如何根据步骤状态自动计算测试状态，以及如何手动设置测试状态。
  • 打印手动测试
    介绍如何打印手动测试或将其下载为 PDF。您可以使用印刷表单手动填写测试结果。
  • Testbook
    介绍 Testbook 的目的和功能。
  • 脱机手动测试
    说明如何上载和下载手动测试并脱机工作。
父主题： 手动执行计划
相关概念
仪表板


手动测试窗口

要打开手动测试窗口，请在菜单中单击主页 > 我的仪表板，然后在分配给我的手动测试面板中单击 [image] （继续手动测试）。 如果仪表板上未显示此面板，您必须添加此面板。 有关仪表板和面板的更多信息，请参阅仪表板。

您也可在当前执行网格中或当前运行页面上的活动页面（在菜单中，单击跟踪 > 活动）上访问手动测试窗口。

手动测试窗口显示两个区域：
  • 位于顶部的概述区域。
  • 位于底部的测试步骤区域。
  • 概述区域
    介绍概述区域的结构和 UI 控件。
  • 测试步骤区域
    介绍测试步骤区域的结构和 UI 控件。
  • 移动设备用户界面
    当您选择一台移动设备执行手动测试时，将为您提供移动设备用户界面。
父主题： 手动测试
相关概念
仪表板


概述区域

概述区域是位于手动测试窗口顶部的区域。

概述区域显示：

项 | 按钮 | 说明
执行计划或测试周期 | 包含测试的执行计划或测试周期的名称。
编辑设置 单击此按钮可编辑以下设置：
  • 当测试/步骤状态发生更改时，您可配置是否应自动选择下一个测试/下一步。
  • 您可配置应在概述区域中显示哪些其他测试信息。
  • 您可隐藏或显示某些操作（例如编辑版本和内部版本操作）。
  • 您可定义是否应录制带有或不带音频的视频。
可为每个用户单独定义这些设置。
完成 | 单击完成以完成运行。仅当您打开未分配的测试或已分配至执行计划的测试时，才会显示此选项。如果您打开已分配至测试周期的测试，则它不会显示。 选择要对尚未执行的测试执行的操作，然后单击完成。选定状态更改仅应用于状态原因尚未设置的未执行测试。
通过 | 单击此按钮可将当前选定测试的状态标记为通过并自动选择下一测试。这是按钮的默认设置。
失败 | 单击此按钮可将当前选定测试的状态标记为失败并自动选择下一测试。
测试名称 | 出现的列表显示执行计划或测试周期的所有测试机器当前状态。单击测试或按向上和向下键以导航测试及其步骤。如果您指定运行具有特定配置的测试，配置名称将显示在测试名称旁边（括号内）。有关更多信息，请参阅手动配置测试。单击 [image] 以在测试区域的详细信息视图中显示测试。
已分配的需求 | 单击按钮以查看已分配至测试的需求。仅当至少存在一个已分配的需求时，才会显示该按钮。按钮旁边的数字显示已分配的需求数量。
已分配的问题 | 单击按钮以查看已分配至测试的问题。此按钮仅在至少分配有一个问题时显示。按钮旁边的数字显示已分配的问题数量。问题对话框显示已分配至测试的问题以及已分配至测试步骤的问题。
已分配的附件 | 单击按钮以查看已分配至测试的附件。此按钮仅在至少有一个分配的附件时显示。按钮旁边的数字显示已分配的附件数量。
阻止/取消阻止 | 单击此按钮可将测试设置为已阻止/取消阻止。将测试设置为已阻止可表明该测试因某些限制而无法继续，例如 IT 基础结构存在问题。
测试状态 | 测试的状态。可自动或手动设置。单击状态图标旁边的 [image] 以选择状态。有关更多信息，请参阅测试和测试步骤的状态。
编辑版本和内部版本

单击此按钮可编辑版本和内部版本。有关更多信息，请参阅编辑版本和内部版本。
运行注释 | 为测试运行输入高级注释。这有助于加快测试执行审查过程，因为注释显示在测试运行网格中。
捕获屏幕 | 单击此按钮可捕获屏幕图像并将其附加到测试。捕获的图像会被添加到附件列表。有关更多信息，请参阅捕获屏幕图像。
录制视频 | 单击此按钮可对屏幕上的操作录制视频，并将其附加到测试。视频会被添加到附件列表，您可以将其保存到本地文件系统。有关更多信息，请参阅录制视频。
附加结果文件 | 单击此按钮可将结果文件附加到测试。有关更多信息，请参阅附加结果文件。
分配或创建问题 | 单击此按钮可创建新问题并将其附加到测试，或分配现有问题。有关更多信息，请参阅分配或创建问题。
选择设备 | 选择要在其上执行手动测试的移动设备（物理设备、仿真器或模拟器）。有关更多信息，请参阅选择移动设备。
启动代码分析 | 单击此按钮可开始分析过程。此时将显示开始代码分析对话框。选择配置文件，然后输入一个或多个主机名。如果此测试的覆盖率信息已存在，您可选中复选框以将其替换。单击开始代码分析以真正开始该过程。当您单击停止代码分析时，Silk Central 会将代码分析信息存储到测试运行。
同步测试运行 | 单击此按钮可将测试运行与已调整的测试同步。如果您已开始执行测试，同时决定在测试单元中对此测试进行更改，您可将测试运行与已调整的测试同步。
注： 要关闭对话框，请单击对话框外的任意位置或单击 [image] （关闭）。
父主题： 手动测试窗口
相关任务
手动配置测试
编辑版本和内部版本
捕获屏幕图像
录制视频
附加结果文件
分配或创建问题
相关参考
测试和测试步骤的状态


测试步骤区域

测试步骤区域位于手动测试窗口的概述区域下方。

测试步骤区域显示：

项 | 按钮 | 说明
编辑所用时间 |  | 单击此按钮可手动输入您执行测试所用的时间。打开手动测试窗口或选择其他测试时，计时器将自动启动。闪烁的冒号表示计时器正在运行。单击 [image] 暂停计时器，单击 [image] 启动计时器。左侧的数字显示实际所用时间，右侧的数字显示计划时间。
进度条 |  | 可视化测试进度。进度条显示您已执行的步骤数。
将消息发布到 Testbook |  | 单击此按钮可将消息发布到 Testbook。
通过 |  | 单击此按钮可将当前选定测试的状态标记为通过并自动选择下一步骤。这是按钮的默认设置。
失败 |  | 单击此按钮可将当前选定测试的状态标记为失败并自动选择下一步骤。这是按钮的默认设置。
显示/隐藏详细信息 |  | 单击此按钮可展开测试步骤和显示详细信息，如操作说明或预期结果以及所有按钮和结果字段。
步骤名称 |  | 测试步骤的名称。状态为未执行的步骤名称为粗体。
已分配的问题 |  | 单击此按钮可查看分配给测试步骤的问题。此按钮仅在至少分配有一个问题时显示。此按钮旁边的数字显示分配的问题数。
已分配的附件 |  | 单击此按钮可查看分配给测试步骤的附件。此按钮仅在至少有一个分配的附件时显示。此按钮旁边的数字显示分配的附件数。
步骤状态 |  | 步骤的状态。单击状态图标旁边的 [image] 以选择状态。Silk Central 将根据步骤状态自动计算测试状态。有关更多信息，请参阅测试和测试步骤的状态。
结果字段 |  | 将结果文本输入到字段。单击字段外的任意位置可保存文本。
捕获屏幕 |  | 单击此按钮可捕获屏幕图像并将其附加到测试步骤。捕获的图像会被添加到附件列表。有关更多信息，请参阅捕获屏幕图像。
录制视频 |  | 单击此按钮可对屏幕上的操作录制视频，并将其附加到测试步骤。视频会被添加到附件列表，您可以将其保存到本地文件系统。有关更多信息，请参阅录制视频。
附加结果文件 |  | 单击此按钮可将结果文件附加到测试步骤。有关更多信息，请参阅附加结果文件。
分配或创建问题 |  | 单击此按钮可创建新问题并将其附加到测试步骤，或分配现有问题。有关更多信息，请参阅分配或创建问题。
注： 要关闭对话框，请单击对话框外的任意位置或单击 [image] （关闭）。
提示： 处理测试时，您可以使用键盘：要更改选定测试步骤的状态，请使用快捷方式 Ctrl+Shift+A（通过）和 Ctrl+Shift+S（失败）。用一只手便可轻松按这些组合键。按向上和向下键导航测试及其步骤，按向右展开步骤，向左折叠步骤。要关闭对话框，请按 Esc。
父主题： 手动测试窗口
相关任务
捕获屏幕图像
录制视频
附加结果文件
分配或创建问题
相关参考
测试和测试步骤的状态


移动设备用户界面

当您选择一台移动设备执行手动测试时，将为您提供移动设备用户界面。

可通过鼠标与设备的模拟显示屏交互。使用显示屏右侧的图标可以旋转设备，或模拟缩小和放大操作。

使用文本图标在当前聚焦的字段中输入文本。文本图标也支持通过输入法编辑器 (IME) 来输入多字节字符。

iOS 限制：
  • 每个用户会话只能运行一个模拟器，但多个物理设备可以同时执行测试。
  • 测试 Sauce Labs 设备时，主页按钮不受支持。
  • 如果某个设备不可用，请关闭并重新启动该设备以继续测试。
父主题： 手动测试窗口
相关任务
为手动测试选择移动设备


捕获屏幕图像

在手动测试窗口中执行测试时，您可捕获屏幕图像。捕获的图像将附加到测试或测试步骤。在测试步骤失败并且您要概述问题发生的时间、位置和方式时，这尤其有用。

确保您安装了 Java Runtime Environment (JRE)，并允许此应用程序运行。您可以从 Java SE 下载 下载 JRE。 如果您的浏览器不支持 NPAPI，Silk Central 会自动提供下载并运行 JNLP 文件，启用该功能时需要使用 JNLP 文件。

捕获屏幕图像：

  1. 打开手动测试窗口。有关更多信息，请参阅手动测试窗口。
  2. 单击左侧的 [image] （显示详细信息）以展开测试步骤。
  3. 单击 [image] （捕获屏幕）。如果您的浏览器不支持 NPAPI，Silk Central 会自动提供下载并运行 JNLP 文件，启用该功能时需要使用 JNLP 文件。 在 JNLP 应用程序运行后，再次单击 [image] 。 此时将启动屏幕截图功能。
  4. 执行以下操作之一：
    • 用鼠标绘制一个矩形，以选择要捕获的区域。
    • 按 Enter 捕获整个屏幕。如果您有多个监视器，所有监视器屏幕都将被捕获。
    • 按 Esc 取消。
    此时将显示屏幕捕获窗口。
  5. 根据需要编辑屏幕截图。您可添加文本和图形项目（如箭头和矩形）。在编辑器中，您可使用键盘执行以下操作：
    • 按箭头键移动对象（如矩形或箭头）。按住 Shift 并按箭头键精确调整位置。
    • 使用移动工具选择对象并按 Backspace 或 Delete 删除对象。
    • 如果您使用文本工具，则可按 Shift+Enter 确认输出或按 Esc 取消。
    • 按 Ctrl+C 将屏幕截图复制到剪贴板。
  6. 单击上载。 屏幕截图将附加到测试步骤。
  7. 要查看附加的屏幕截图，请单击 [image] 。 将出现附件对话框，其中包括所有附加文件列表。
  8. 您可单击 [image] （删除结果文件）以删除附加的文件，或单击 [image] （打开）以打开文件。
    注： 在此对话框中，您仅可删除在当前测试运行期间附加的文件。您不能删除在测试周期/执行计划开始之前分配到测试的文件。
注： 您可在测试级别和步骤级别执行本主题中所描述的任务。
父主题： 手动测试
相关概念
手动测试窗口


录制视频

在手动测试窗口中执行测试时，您可以录制测试进程的视频。在测试步骤失败并且您要概述问题发生的时间、位置和方式时，这尤其有用。

视频将附加到您从中开始录制的测试步骤。例如：如果您从第二步开始录制，并且在录制仍在运行时继续第三步和第四步，则视频将仍然附加到第二步。

确保您安装了 Java Runtime Environment (JRE)，并允许此应用程序运行。您可以从 Java SE 下载 下载 JRE。 如果您的浏览器不支持 NPAPI，Silk Central 会自动提供下载并运行 JNLP 文件，启用该功能时需要使用 JNLP 文件。

限制：
  • 仅 Microsoft Windows 客户端机器支持视频录制。
  • 在 Microsoft Windows 10 N 和 KN 版本上不支持视频捕获。
  • Windows 7 经典主题不支持 WPF 窗口的视频录制。
  • 不支持录制 4K 分辨率的视频。

录制视频：

  1. 打开手动测试窗口。有关更多信息，请参阅手动测试窗口。
  2. 单击左侧的 [image] （显示详细信息）以展开测试步骤。
  3. 单击 [image] （录制视频）。如果您的浏览器不支持 NPAPI，Silk Central 会自动提供下载并运行 JNLP 文件，启用该功能时需要使用 JNLP 文件。 在 JNLP 应用程序运行后，再次单击 [image] 。 如果检测到合适的音频设备，则将录制带音频的视频。如果连接多个设备，则将使用检测到的第一个设备。单击 [image] 以启用音频设置，因为此设置默认关闭。更改此设置后，您需要重新启动视频录制。 此时将显示视频录制窗口并自动开始录制。
  4. 完成后，请单击停止视频录制。
  5. 输入结果文件名，然后单击上载文件以将视频附加到测试步骤。您也可单击保存文件以将其保存到您的本地计算机。
  6. 单击关闭。
  7. 要查看附加的视频，请单击 [image] 。 将出现附件对话框，其中包括所有附加文件列表。
  8. 您可单击 [image] （删除结果文件）以删除附加的文件，或单击 [image] （打开）以打开文件。
    注： 在此对话框中，您仅可删除在当前测试运行期间附加的文件。您不能删除在测试周期/执行计划开始之前分配到测试的文件。
注： 您可在测试级别和步骤级别执行本主题中所描述的任务。
父主题： 手动测试
相关概念
概述区域
测试步骤区域
手动测试窗口
相关参考
测试和测试步骤的状态


附加结果文件

在手动测试窗口中执行测试时，您可将结果文件附加到每个测试步骤。

附加结果文件：

  1. 打开手动测试窗口。有关更多信息，请参阅手动测试窗口。
  2. 单击左侧的 [image] （显示详细信息）以展开测试步骤。
  3. 单击 [image] （附加结果文件）。 将打开系统文件管理器。
  4. 浏览要附加的文件并确认。 文件将附加到测试步骤。
  5. 要查看附加的文件，请单击 [image] 。 将出现附件对话框，其中包括所有附加文件列表。
  6. 您可单击 [image] （删除结果文件）以删除附加的文件，或单击 [image] （打开）以打开文件。
    注： 在此对话框中，您仅可删除在当前测试运行期间附加的文件。您不能删除在测试周期/执行计划开始之前分配到测试的文件。
注： 您可限制允许测试人员上载的结果文件大小。 有关更多信息，请参阅设置步骤结果文件的最大大小。
注： 您可在测试级别和步骤级别执行本主题中所描述的任务。
父主题： 手动测试
相关概念
手动测试窗口
相关任务
设置步骤结果文件的最大大小


分配或创建问题

在手动测试窗口中执行测试时，可将问题分配到每个测试步骤。

分配问题：

  1. 打开手动测试窗口。有关更多信息，请参阅手动测试窗口。
  2. 单击左侧的 [image] （显示详细信息）以展开测试步骤。
  3. 单击 [image] （分配或创建问题）。 此时将显示分配或创建问题对话框。
  4. 如果要分配现有问题，请单击分配现有问题，并在问题 ID 字段中键入问题编号（以逗号隔开）。
  5. 如果创建新问题，请单击创建新问题。 在字段中输入有关问题的信息并从列表中选择值。
  6. 单击确定。 问题将分配到测试步骤。
  7. 要查看分配的问题，请单击 [image] 。 将出现问题对话框，其中包括所有附加问题列表。
  8. 如果单击 [image] （打开问题），您将转到外部问题跟踪工具或 Issue Manager。要删除问题，请单击 [image] （删除问题）。
    注： 在此对话框中，您只能删除在当前测试运行期间分配的问题。您不能删除在测试周期/执行计划开始之前分配到测试的问题。
注： 创建新问题时，Silk Central 将自动创建当前已分配到步骤或测试的所有结果文件的链接。这些链接将显示在问题跟踪工具中的问题描述中。通过这种方式，您可从问题跟踪工具中直接下载结果文件。
注： 您可在测试级别和步骤级别执行本主题中所描述的任务。
父主题： 手动测试
相关概念
概述区域
测试步骤区域
手动测试窗口
相关参考
测试和测试步骤的状态


为手动测试选择移动设备

在可以选择要执行手动测试的移动设备（物理设备、仿真器或模拟器）之前，需要配置设备提供程序。请注意，设备提供程序和当前项目必须分配到相同的位置，否则设备不会显示在列表中。有关附加信息，请参阅管理设备提供程序。
提示： 如果要在所选设备上使用特定的 URL 打开浏览器，请定义名为 silkTest.url 的参数，然后在值字段中输入 URL。
要选择移动设备：
  1. 打开手动测试窗口。有关更多信息，请参阅手动测试窗口。
  2. 单击 [image] （选择设备）。 将显示选择设备对话框。
  3. 选择移动设备。使用左侧的搜索字段、平台和应用程序列表来筛选可用设备列表。要在移动设备上安装本机应用程序以进行测试，请在左侧的应用程序列表中选择本机应用程序，然后在下面字段中指定该应用程序的 URL 或 UNC 路径（iOS 需要 URL）。示例：\\fileserver\apps\testapp.apk
    提示： 使用搜索字段搜索特定设备类型，例如搜索仿真器或模拟器。
  4. 可选：如果要为设备选择排除仿真器和模拟器，请选中仅使用物理设备复选框。
  5. 可选：取消选中隐藏已使用或阻止的设备复选框来查看当前正在使用设备的用户。
  6. 单击启动设备开始在所选设备上执行测试。
父主题： 手动测试
相关概念
手动测试窗口
相关参考
移动设备用户界面


启动代码分析

在手动测试窗口中执行测试时，可以启动代码分析来提供有关手动测试包含哪些代码的信息。有关如何启用代码分析的信息，请参阅启用代码分析。

确保您安装了 Java Runtime Environment (JRE)，并允许此应用程序运行。您可以从 Java SE 下载 下载 JRE。 如果您的浏览器不支持 NPAPI，Silk Central 会自动提供下载并运行 JNLP 文件，启用该功能时需要使用 JNLP 文件。

要启动代码分析，请执行以下操作：

  1. 打开手动测试窗口。有关更多信息，请参阅手动测试窗口。
  2. 单击左侧的 [image] （显示详细信息）以展开测试步骤。
  3. 单击 启动代码分析 （启动代码分析）。如果您的浏览器不支持 NPAPI，Silk Central 会自动提供下载并运行 JNLP 文件，启用该功能时需要使用 JNLP 文件。 此时将显示开始代码分析对话框。
  4. 选择配置文件，然后输入一个或多个主机名。如果此测试的覆盖率信息已存在，您可选中复选框以将其替换。单击开始代码分析以真正开始该过程。
  5. 完成后，请单击停止代码分析。代码分析信息自动附加到测试运行中。
  6. 要查看附加的代码分析信息，请单击 [image] 。要查看代码分析报告，请选择报告 > 代码分析。
注： 您可在测试级别和步骤级别执行本主题中所描述的任务。
父主题： 手动测试


编辑版本和内部版本

要在手动测试窗口中编辑版本和内部版本，请单击概述区域中的 [image] （编辑版本和内部版本）。 如果未显示该按钮，请单击 [image] （编辑设置）并启用该操作。

测试周期的测试可能不止使用一个内部版本，而是使用几个内部版本执行。 如果您拥有包括许多测试的长测试周期，尤其可能出现这种情况。 例如：测试周期的测试 1 和 2 使用内部版本 315 执行，而同一测试周期的测试 3 则使用内部版本 316 执行。

每个测试的已配置内部版本和版本都将存储并显示在 Silk Central 中的所有相关网格中。

当您为测试设置内部版本时，将自动为...
  • 已分配给您或未分配给任何特定测试人员的所有测试，以及
  • 尚未执行的所有测试（状态为未执行的测试），以及
  • 属于相同项目和产品的所有测试设置此内部版本。

因此，您不必为随后执行的每个测试反复设置相同的内部版本。

父主题： 手动测试


测试和测试步骤的状态

在手动测试窗口设置测试步骤的状态时，测试状态将改变。下表显示 Silk Central 如何根据测试步骤的状态计算测试状态：
状态 | 说明
通过 | 如果所有步骤通过，测试状态将设为通过。测试步骤不会向测试状态传播任何状态原因。
失败 | 如果已执行所有步骤但至少一个步骤失败，测试状态将设为失败。第一个失败测试步骤的状态原因将用作该测试的失败状态原因。
未执行 | 只要所有步骤未执行，测试状态将设为未执行。第一个未执行测试步骤的状态原因将用作该测试的未执行状态原因。 如果更改至少一个步骤的状态，测试状态将设为进行中。
进行中 | 在每个步骤都执行完毕之前，测试状态都将设为进行中。

您也可手动设置测试状态。在手动测试窗口的概述区域或者测试步骤的测试步骤区域中，单击状态图标旁边的 [image] （选择状态），然后选择状态：请参阅状态原因，了解为各状态定义原因的详细信息。

除测试状态之外，您还可以将测试设置为已阻止。将测试设置为已阻止可表明该测试因某些限制而无法继续，例如 IT 基础结构存在问题。

请注意以下事项：
  • 手动设置的测试状态将覆盖自动计算的测试状态。
  • 如果以后更改步骤状态，将重新计算测试状态。
  • 您可手动将测试状态设置回未执行。但是，Silk Central 绝不会自动将测试状态设置回未执行。
  • 您可手动将测试状态设置为进行中，即使您未更改任何步骤状态也是如此。
父主题： 手动测试
相关概念
概述区域
测试步骤区域
状态原因
相关任务
编辑版本和内部版本
捕获屏幕图像
录制视频
附加结果文件
分配或创建问题


打印手动测试

您可以打印每个测试的表单，然后手动填写结果、使用时间、状态和其他信息。

打印手动测试：

  1. 在菜单中，单击主页 > 我的仪表板。
  2. 在分配给我的手动测试面板中，单击操作列中的 [image] （查看手动测试结果）。 此时将显示手动测试结果视图。
  3. 单击打印或下载为 PDF。
父主题： 手动测试


Testbook

Testbook 是一个仪表板面板，可为您提供关于手动测试期间发生的所有活动的实时更新。它会为您显示在不同测试周期和执行计划中执行操作的人员、执行的操作以及执行时间。Testbook 简化了测试人员和测试经理之间的协调与合作。

您可按用户、操作和测试周期筛选条目。该面板仅显示一个项目的活动。要为面板配置项目，请单击面板标题中的 [image] （配置）。要查看其他项目中的活动，您可添加更多面板。有关面板的更多信息，请参阅面板。

对于每个条目，将显示用户名以及全名（如果有）。对于未使用有意义用户名的组织，用户的全名更易于团队中其他用户识别。

在手动测试窗口中，您可通过单击 [image] 将消息发布到 Testbook。

60 天以前的条目会自动删除。要更改此默认设置，请打开文件 Conf\AppServer\TMAppserverHomeConf.xml，然后编辑以下设置：<MaximumActivityLogLifeTimeInDays>60</MaximumActivityLogLifeTimeInDays>

Testbook 中将记录以下活动：

图标 | 活动 | 图标 | 活动
 | 已开始的测试周期 |  | 已添加的测试
 | 已完成的测试周期 |  | 已开始的测试
 | 已删除的测试周期 |  | 已完成的测试
 | 已添加的里程碑 |  | 已重新分配的测试
 | 已编辑的里程碑 |  | 已删除的测试
 | 已删除的里程碑 |  | 已阻止的测试
 | 已选择的移动设备 |  | 已发布的消息
父主题： 手动测试


脱机手动测试

脱机手动测试允许您下载测试并脱机完成这些测试。您还可将结果上载回 Silk Central。

测试工程师可使用分配给我的手动测试面板下载手动测试并将结果上载回 Silk Central。测试经理可使用脱机手动测试概述面板查看和管理已下载的测试。

注： 为脱机执行而下载测试时，将签出手动测试许可证。上载结果时，该许可证将重新签入。
  • 下载手动测试以脱机执行
    说明如何下载手动测试并脱机完成这些测试。
  • 上载脱机手动测试结果
    介绍如何上载脱机手动测试的结果。
父主题： 手动测试


下载手动测试以脱机执行

本主题将介绍如何下载测试，并在脱机状态下输入状态、原因和结果。

  1. 转到主页 > 我的仪表板。确保分配给我的手动测试面板可见。
  2. 选择一个或多个测试。右键单击所选测试，选择下载选定手动测试以脱机执行。您还可以选择一个测试，并选择下载相关执行计划的所有手动测试用于脱机执行。
    提示： 利用每页行数设置和排序与筛选功能，获得需要选择的测试列表。
  3. 在下载手动测试用于脱机执行对话框中，指定您希望在 Excel 中组织测试的方式：
    • 为各测试创建单独的工作表，在其中包含步骤列表
    • 创建单独一个工作表，包含所有测试的列表，不含步骤
  4. 如果测试包含属性，请选择包括属性。所有属性都包含在下载的 Excel 电子表格中，这使您能根据每个属性筛选测试。
  5. 选择包括附件还将下载附加于所选测试和测试步骤的文件。请注意，不支持将附件上载回 Silk Central。
  6. 单击下载。 下载并保存 Excel 文件。
  7. 打开文件，根据您下载 Excel 文件时使用的格式，输入各步骤或者各测试的状态和结果或所用时间。
  8. 保存文件。
父主题： 脱机手动测试
相关任务
上载脱机手动测试结果


上载脱机手动测试结果

您下载的手动测试执行完成后，请按照以下步骤将结果上载到 Silk Central。

  1. 转到主页 > 我的仪表板。确保分配给我的手动测试面板可见。
  2. 单击上载脱机手动测试结果。 此时将显示上载脱机手动测试结果对话框。
  3. 单击选择文件，浏览至您的 Excel 文件。 此时将显示打开对话框。
  4. 选择需要上载的文件，单击打开。
  5. 单击上载。 此时将显示一个表明上载状态的对话框。
  6. 单击确定。
父主题： 脱机手动测试
相关任务
下载手动测试以脱机执行


配置测试

配置测试是指使用每个受支持的软件和硬件配置对系统进行测试的过程。

执行区域通过允许重复使用已分配的测试来支持配置测试。您可创建具有一组已分配测试的配置套件，并且这组测试也将分配到您添加到配置套件的所有执行计划。您也可从现有执行计划创建配置套件，并将执行树中的执行计划复制粘贴或剪切粘贴到配置套件中。Silk Central 让您能够将参数、关键字和手动测试人员添加到配置或从配置中删除。从现有执行计划创建配置套件时，执行计划的所有结果都会保留在配置套件中。如果将执行计划复制粘贴到现有配置套件，则不会保留这些结果。

配置套件中的每个执行计划都会显示在可编辑网格中。您可在测试的属性选项卡中查看包含特定测试的执行计划或配置。您也可在需求的已分配的测试选项卡中查看与特定需求关联的执行计划或配置。

要定义自动测试的配置，请使用配置套件配置页面。要定义手动测试的配置，请使用配置页面。

  • 创建配置套件
    创建配置套件，以执行套件中具有相同测试和特定参数或部署设置的所有执行计划。
  • 从执行计划中创建配置套件
    从执行计划中创建配置套件，以添加受支持软件和硬件配置的其他配置。
  • 将参数添加到配置
    将参数添加到配置，以使用参数执行相应的执行计划。
  • 从配置中删除参数
    从配置中删除参数以执行无参数的相应执行计划。
  • 将关键字分配到配置
    将关键字分配到配置以描述执行环境。
  • 从配置中删除关键字
    当关键字不再介绍执行环境时，从配置中删除关键字。
  • 将手动测试人员添加到配置
    将手动测试人员添加到包含手动测试的配置。
  • 从配置中删除测试人员分配
    从配置中删除测试人员分配。
  • 将移动设备分配到配置
    将移动设备（物理设备、仿真器或模拟器）分配到要用于运行执行计划的配置。
  • 配置套件配置页面
    列出配置套件中包括的配置。要定义自动测试的配置，请使用配置套件配置页面。对于手动测试，请使用配置页面。
  • 配置页面
    提供配置页面的概述。您仅可将配置页面上定义的配置用于手动测试。要定义自动测试的配置，请使用配置套件配置页面。
父主题： 执行计划
相关概念
执行状态概述报告
相关参考
执行计划属性页面
执行已分配的测试页面
计划页面


创建配置套件

创建配置套件：

  1. 在菜单中，单击执行计划 > 详细信息视图或执行计划 > 文档视图。
  2. 在执行树中右键单击根节点或文件夹，然后选择新建子配置套件或单击工具栏中的 新建子配置套件 。 将显示新建配置套件对话框。
  3. 键入新配置套件的名称和说明。
  4. 从列表框中选择测试容器。
  5. 从列表框中选择版本和内部版本，或选中从内部版本信息文件中读取复选框以从文件中读取版本和内部版本。
  6. 可选：在源代码管理标签字段，您可指定从源代码管理系统提取的自动文件的早期版本，而非最新版本。
    注： 仅当关联测试容器使用支持版本控制的源代码管理配置文件时，源代码管理标签属性才启用。
  7. 单击确定。
父主题： 配置测试


从执行计划中创建配置套件

从现有执行计划中创建配置套件：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行树中，右键单击要从其中创建配置套件的执行计划，然后选择转换为配置套件。 Silk Central 将在执行树中创建与所选执行计划同名的新配置套件节点，然后将执行计划作为配置子节点添加到配置套件中。
从现有执行计划创建配置套件时，执行计划的所有结果都会保留在配置套件中。如果将执行计划复制粘贴到现有配置套件，则不会保留这些结果。
父主题： 配置测试


将参数添加到配置

预定义参数添加到配置：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行树中，选择要向其添加参数的配置节点。
  3. 单击配置选项卡。
  4. 单击添加/删除参数。 此时将打开添加/删除参数对话框。对话框右侧的已分配的参数列表框将列出为配置定义的所有参数。
  5. 在选择或输入参数列表框中选择反映执行环境需求的参数。 使用 Ctrl+单击或 Shift+单击，以通过标准浏览器多选功能选择多个参数。
  6. 要添加选择或输入参数列表框中列出的任意参数，请选择参数并单击 >。
  7. 要创建新参数，请在输入参数文本框中键入参数名称，然后按 Enter 或单击 >。
    提示： 输入参数文本框已启用自动完成功能。当您在此字段中输入字母数字字符时，该字段会使用与输入的字符匹配的现有参数动态更新。在选择参数或已分配的参数列表框中选择多个参数时，文本框会禁用。
  8. 单击确定。 添加/删除参数对话框会关闭，并且会在每个新参数的网格中添加一个新列。
父主题： 配置测试


从配置中删除参数

从配置中删除预定义参数：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行树中，选择您要从中删除参数的配置节点。
  3. 单击配置选项卡。
  4. 单击添加/删除参数。 此时将打开添加/删除参数对话框。 对话框右侧的列表框将列出为配置定义的所有参数。
  5. 要从列表框中删除参数，请选择参数并单击 <。
  6. 单击确定。 此时将关闭添加/删除参数对话框，并从网格中删除已删除的参数列。
父主题： 配置测试


将关键字分配到配置

将关键字分配到配置：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的配置套件。
  3. 单击配置选项卡。
  4. 点击进入要添加关键字的配置的关键字列。 此时将打开分配关键字对话框。
  5. 在反映执行环境需求的选择关键字列表框中选择关键字。 通过标准的浏览器多选功能，使用 Ctrl+单击或 Shift+单击选择多个关键字。
    提示： 输入关键字文本框已启用自动完成功能。当您在此字段中输入字母数字字符时，该字段会使用与输入的字符匹配的现有关键字动态更新。在选择关键字或已分配的关键字列表框中选择多个关键字时，文本框会禁用。
    提示： 对于自动执行计划，如果您只有几台执行服务器并且不需要硬件配置，则使用为每台执行服务器创建的默认保留关键字可能已经足够。在此情况下，不必选择其他关键字。
  6. 单击 > 将关键字移到已分配的关键字列表框中。
    注： 对于自动执行计划，与已分配的关键字匹配的执行服务器列示于下面动态更新的匹配执行服务器列表框中。此列表会在每次添加或删除关键字时进行更新。单击列表中的执行服务器名称，以在管理 > 执行服务器中访问执行服务器。
  7. 单击确定可保存关键字并关闭分配关键字对话框。
父主题： 配置测试


从配置中删除关键字

从配置中删除关键字分配：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的配置套件。
  3. 单击配置选项卡。
  4. 单击进入您要从中删除关键字的配置的关键字列。 此时将打开分配关键字对话框。
  5. 选择已分配的关键字列表中不再需要的关键字。 使用 Ctrl+单击或 Shift+单击可选择多个关键字。
  6. 单击 < 删除关键字分配。
  7. 单击确定可保存关键字并关闭分配关键字对话框。
注： 将从系统中自动删除不再使用的关键字。
父主题： 配置测试


将手动测试人员添加到配置

对于包含手动测试的配置，您可通过配置页面将用户作为手动测试人员分配到所选配置。 您可将多个手动测试人员分配到配置。

将手动测试人员分配到配置：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的配置套件。
  3. 单击配置选项卡。
  4. 单击进入要向其中添加手动测试人员的配置的手动测试人员列。 将打开手动测试人员对话框。
  5. 在可用列表框中，选择测试人员所在的用户组。 列表框将使用所有用户组成员填充。
  6. 选择要分配为手动测试人员的用户名。
  7. 单击添加以将用户添加到已选定列表框；或单击全部添加以添加所有组成员和测试人员。
  8. 单击确定关闭添加/删除测试工程师对话框。
父主题： 配置测试


从配置中删除测试人员分配

从配置中删除测试人员分配：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择您要从中删除测试人员分配的配置节点。
  3. 单击配置选项卡。
  4. 单击进入您要从中删除手动测试人员的配置的手动测试人员列。 此时将打开手动测试人员对话框。
  5. 从已选定列表，选择您要删除的已分配用户的名称。
  6. 单击删除从已选定列表中删除用户；或单击全部删除以删除所有测试工程师分配。
  7. 单击确定关闭添加/删除测试工程师对话框。
父主题： 配置测试


将移动设备分配到配置

要将移动设备分配到配置：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的配置套件。
  3. 单击配置选项卡。
  4. 选择移动设备、设备筛选器或本机应用程序：
    • 要选择特定设备，请使用右侧的列表。
    • 要选择设备筛选器，请使用右侧列表中的任何设备。使用左侧的搜索字段、平台和应用程序列表编辑此筛选器。
      提示： 使用搜索字段搜索特定设备类型，例如搜索仿真器或模拟器。
    • 要在移动设备上安装本机应用程序以进行测试，请在左侧的应用程序列表中选择本机应用程序，然后在下面字段中指定该应用程序的 URL 或 UNC 路径（iOS 需要 URL）。示例：\\fileserver\apps\testapp.apk
  5. 可选：如果要为设备选择排除仿真器和模拟器，请选中仅使用物理设备复选框。
  6. 可选：选中隐藏已使用或阻止的设备复选框，仅列出当前可用的设备。如果您要执行手动测试，或者如果您要立即运行执行计划，此功能特别很有帮助。
  7. 单击确定保存移动设备选择。
在执行期间，将使用并阻止所选设备或筛选器的第一个匹配设备，直至完成执行计划为止。如果所选设备不可用，或筛选器没有匹配到任何可用设备，执行作业将保留在队列中，直至有合适的执行服务器和移动设备变得可用为止。Sauce Labs 设备实际上并不是单个设备，而是设备类型，因此在执行过程中不会被阻止。
父主题： 配置测试
相关概念
管理设备提供程序
相关任务
为自动测试选择移动设备
为手动测试选择移动设备
相关参考
配置设备提供程序


配置套件配置页面

要访问此页面，请单击执行计划 > 详细信息视图 > <配置套件> > 配置。

配置选项卡显示配置套件中包括的配置。该网格提供用于自动生成子执行计划的数据。

您添加到网格中的每个配置都会生成使用配置套件执行的新执行计划。

要定义新配置，请单击新建配置。要添加或删除参数，请单击添加/删除参数。

对于所列的每个配置，该页面会显示以下列：
列 | 说明
操作
  • 单击 删除配置 以删除配置。
  • 单击 重复配置 以重复配置。
名称 | 配置的名称。单击该名称以对其进行更改。
关键字 | 分配到配置的执行关键字列表。单击该链接以更改列表。有关其他信息，请参阅将关键字分配到配置。
手动测试工程师 | 分配到配置的手动测试人员列表。单击该链接以更改列表。有关其他信息，请参阅将手动测试人员添加到配置。
移动设备选择 | 分配到配置的移动设备（物理设备、仿真器或模拟器）。单击链接以编辑移动设备选择。有关其他信息，请参阅将移动设备分配到配置。
参数 | 该网格可包含多个参数列。单击添加/删除参数以将参数添加到网格或从网格中删除。要将值添加到参数，请单击该字段并键入值。有关其他信息，请参阅将参数添加到配置。
父主题： 配置测试
相关概念
执行计划参数
相关任务
将参数添加到配置
相关参考
配置页面


配置页面

要访问此页面，请单击执行计划 > 配置。

配置页面在网格中显示已定义配置的列表。您仅可将这些配置用于手动测试。要定义自动测试的配置，请参阅配置套件配置页面。

要定义新配置，请单击新建配置。要添加或删除参数，请单击添加/删除参数。

对于所列的每个配置，该页面会显示以下列：
列 | 说明
操作
  • 单击 删除配置 以删除配置。
  • 单击 重复配置 以重复配置。
名称 | 配置的名称。单击该名称以对其进行更改。
移动设备选择 | 分配到配置的移动设备（物理设备、仿真器或模拟器）。单击链接以编辑移动设备选择。有关附加信息，请参阅将移动设备分配到配置。
关键字 | 分配到配置的执行关键字列表。单击该链接以更改列表。有关其他信息，请参阅将关键字分配到配置。
参数 | 该网格可包含多个参数列。单击添加/删除参数以将参数添加到网格或从网格中删除。要将值添加到参数，请单击该字段并键入值。有关其他信息，请参阅将参数添加到配置。
父主题： 配置测试
相关任务
将参数添加到配置
相关参考
配置套件配置页面


管理执行计划、文件夹和配置套件

执行计划是指单个测试容器中存储的已分配测试的集合。 执行计划可以按照可配置的计划运行，并且部署在指定的执行服务器上。使用文件夹构建执行计划、配置套件和测试周期。 您可以在文件夹内嵌套文件夹。

对于自动执行计划和手动执行计划，添加和编辑执行计划的流程相同。

  • 创建执行计划
    创建执行计划以同时执行相关测试。
  • 在网格视图中创建执行计划
    在网格视图中创建执行计划，以将测试直接分配到执行计划。
  • 测试状态计算
    介绍如何计算执行计划的状态。
  • 执行计划属性
    属性是能应用于执行计划的可自由定义的特征。您可将属性用于筛选和报告用途。
  • 执行计划参数
    介绍如何将参数（即可自由配置的输入值）分配到执行计划。
  • 安装和清理测试
    介绍如何使用安装测试来准备预期测试的测试环境，以及使用清理测试以便在测试后将测试环境还原为其初始状态。
  • 配置部署环境
    介绍如何使用 Silk Central 配置部署环境。
  • 配置执行依赖关系
    介绍如何配置一个执行计划根据另一个执行计划结果的自动执行。
  • 已分配的测试
    介绍如何将测试分配到执行计划。
  • 计划
    介绍如何定义按其执行执行计划、文件夹和配置套件的计划。
  • 执行分配至执行计划的测试
    介绍如何使用 Silk Central 运行分配到执行计划的测试。
  • 筛选器
    介绍如何使用筛选器查找需要的准确信息，同时排除无关详细信息。
  • 屏幕捕获
    介绍如何使用屏幕捕获在测试外创建屏幕截图。
  • 视频捕获
    介绍如何使用视频捕获创建测试视频。
  • 自动删除结果和结果文件
    定义规则来清理执行计划运行的旧结果和结果文件，以减少数据库大小并提高执行计划运行的可管理性。
父主题： 执行计划


创建执行计划

要创建执行计划，请执行以下操作：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择文件夹或项目节点。
  3. 在工具栏上单击 新建子执行计划 （新建子执行计划），或右键单击文件夹、测试周期或节点并单击新建子执行计划。 将显示新建执行计划对话框。
  4. 键入执行计划的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 从测试容器列表中选择测试容器。
    注： 您仅可向一个执行计划分配一个测试容器。仅可执行来自此测试容器的测试。
    容器所属产品中定义的最新版本和内部版本将自动填充到版本和内部版本列表中。
  6. 从列表中选择产品版本和内部版本。 开始此执行计划的新运行时，将使用这些信息。或者，您可选中从内部版本信息文件中读取复选框。在此情况下，将在每个运行开始时从应用程序服务器上的内部版本信息文件中读取版本和内部版本。如果内部版本信息文件在执行服务器上可用，则此文件默认为用于测试运行，从而覆盖新建执行计划对话框上的设置。
  7. 从列表中选择执行计划的优先级。 对于自动执行计划，如果多个执行计划在排队等候，但只有一个执行服务器可用，则优先级将确定先执行的执行计划。如果执行服务器可用，但多个执行计划所需的移动设备不可用，情况也是如此。
  8. 在源代码管理标签文本框中，您可以选择指定执行计划的版本早于最新版本。该标签必须引用与测试容器关联的源代码管理系统中的版本。如果将此文本框留空，则将获取执行计划的最新版本。仅当关联测试容器使用支持版本控制的源代码管理配置文件时，源代码管理标签属性才启用。当使用多个版本的源代码文件时，确保执行服务器上具有足够的可用磁盘空间。每个版本都将保存在其位于各个执行服务器上的文件夹中。
    提示： 如果您想要为特定执行计划签出存储库的特定分支，请在相应执行计划的源代码管理标签字段中指定分支名称。
  9. 单击确定以使用新创建的执行计划更新执行树。
父主题： 管理执行计划、文件夹和配置套件
相关概念
内部版本信息
源代码管理配置文件集成
相关任务
在网格视图中创建执行计划
编辑执行计划树的元素
相关参考
执行计划属性页面


测试状态计算

每个执行计划具有以下状态条件之一：
状态
条件
通过
所有考虑的测试执行计划的状态都为通过。
失败
至少有一个考虑的测试执行计划的状态为失败，但没有任何执行计划的状态为未执行。
未执行
至少有一个考虑的测试的状态为未执行。

测试将从最新执行计划运行的结果中获取其状态。 如果您手动更改最新执行计划运行的状态，则测试状态也会改变。

注： 如果删除最新执行计划运行，则测试状态将重置为现有执行计划运行的最新状态。 如果删除的执行计划运行是唯一的现有执行计划运行，则将测试的状态设为不适用，如同新建测试一样。
父主题： 管理执行计划、文件夹和配置套件


执行计划属性

属性是能应用于执行计划的可自由定义的特征。您可将属性用于筛选和报告用途。
注： 属性的继承类似于属性和成功条件的继承。分配给父节点的属性在所有子文件夹和子执行计划中继承。无法为项目节点和未分配的测试节点定义属性。
  • 将属性分配到执行计划
    将属性分配到执行计划以筛选和报告具有指定属性的类别。
  • 编辑执行计划属性
    编辑执行计划属性以更改执行计划的特征。
  • 从执行计划中删除属性
    如果执行计划不再以某个属性为特征，则可从该执行计划中删除该属性。
父主题： 管理执行计划、文件夹和配置套件


将属性分配到执行计划

要将属性分配到执行计划，请执行以下操作：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要向其分配属性的执行计划。
  3. 在属性部分中，单击添加属性。将出现添加属性对话框。
  4. 在要分配属性的添加列中，单击 添加属性 。 根据选择的属性类型，将出现编辑属性对话框，您可在其中指定要分配到执行计划的可用属性值。
  5. 选择属性值，然后单击确定以将属性分配到执行计划。
父主题： 执行计划属性


编辑执行计划属性

要编辑执行计划属性，请执行以下操作：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要为其编辑已分配属性的执行计划。
  3. 在属性部分，单击要编辑的属性的编辑图标。 此时将显示编辑属性对话框。编辑属性对话框中的可用选项根据您选择的属性类型而变化。
  4. 选择所需的值，然后单击确定以保存您的设置。
父主题： 执行计划属性


从执行计划中删除属性

要从执行计划中删除属性，请执行以下操作：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要从其删除已分配的属性的执行计划。
  3. 在属性部分，单击要删除的属性的删除图标。 此时将显示删除属性确认对话框。
  4. 单击是以删除属性。
    注： 测试运行中已使用的继承属性和属性不可删除。
父主题： 执行计划属性


执行计划参数

要将特定配置应用到执行计划，可以在执行计划属性页上的参数部分中覆盖已分配到测试的参数。有关测试参数的其他信息，请参阅测试参数。

  • 预定义参数
    Silk Central 以参数的形式提供测试执行期间有关执行计划运行属性的信息。
  • 创建执行计划参数
    介绍如何将新参数添加到执行计划。
  • 覆盖测试参数
    介绍如何在执行计划中覆盖测试参数。
  • 删除执行计划参数
    介绍如何从执行计划中删除执行计划参数。
父主题： 管理执行计划、文件夹和配置套件
相关概念
测试参数


创建执行计划参数

将新参数添加到执行计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行树中，选择要向其添加新参数的执行计划。
  3. 在参数部分中，单击新建执行计划参数。 将显示新建执行计划参数对话框。
  4. 将新参数的名称和值键入对应的字段中。新执行计划参数始终为字符串类型，您不能定义其他类型。
  5. 单击确定将参数添加到执行计划。
    注： 您不能创建与执行计划中包括的现有测试参数同名的执行计划参数。
对于配置测试，您可以创建多个包含相同测试的执行计划，然后在参数页面中定义不同的配置。具有相同名称和类型的来自不同测试的参数只会在页面上显示一次。如果来自不同测试的多个参数具有相同名称，则您只能覆盖其中一个参数。
父主题： 执行计划参数


覆盖测试参数

如果测试中存在多个类型不同、名称相同的参数，您只能覆盖其中一个参数。在执行期间，只有具有相同类型和名称的参数才会被覆盖值替换。

在执行计划中覆盖测试参数：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行树中，选择要在其中覆盖测试参数的执行计划。
  3. 在参数部分，在要覆盖的参数的操作列中，单击 设置参数值 。 此时将显示设置执行计划参数值对话框。
  4. 在文本框中键入新值。
  5. 单击确定。
注： 在要撤消覆盖的参数的操作列中，单击 删除执行定义参数 。
父主题： 执行计划参数


删除执行计划参数

注： 您无法删除执行计划中的测试参数。您只能删除执行计划参数。

删除执行计划参数：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行树中，选择要从中删除参数的执行计划。
  3. 在参数部分，在要删除的参数的操作列中，单击 删除执行计划参数 。
父主题： 执行计划参数


安装和清理测试

Silk Central 的测试前安装和测试后清理功能使您可以为每个执行计划定义安装测试和清理测试。安装测试通常基于为预期测试准备测试环境的脚本或手动程序建立。清理测试通常包括测试后将测试环境还原为初始状态的脚本或手动程序。中止安装测试后，不执行常规测试，但一定会执行清理测试以将测试环境还原为其初始状态。

您必须先创建安装和清理测试才可将其分配给执行计划。除多个数据驱动测试实例的父测试外，任何测试都可用作安装或清理测试。它们无需特殊配置，可以为自动或手动测试。唯一的要求是它们必须在您的测试环境中执行所需的安装和清理过程。对于自动测试，这指的是执行所需安装和清理任务的脚本。对于手动测试，这指的是手动安装和清理任务。

注： 执行安装和清理测试的难点在于避免其结果与所支持的常规测试结果聚合。Silk Central 解决此问题的方法是，在独立的执行计划中运行安装和清理测试（自动和手动），从而使实际测试结果与安装和清理测试可能导致的偶然性能波动分隔开来。
  • 结合自动和手动测试
    介绍 Silk Central 如何支持包括自动测试和手动测试组合的执行计划。
  • 配置安装和清理执行
    配置安装测试以准备测试环境，以便让测试和安装测试将测试环境恢复到其原始状态。
父主题： 管理执行计划、文件夹和配置套件


结合自动和手动测试

Silk Central 支持包括自动测试和手动测试组合的执行计划。对于此类执行计划，Silk Central 将阻止常规测试（手动和自动）的执行，直至完成安装测试。Silk Central 还会在运行清理测试之前确保所有常规测试已完成。

手动测试与自动测试相结合时，所有执行服务器上的自动测试都将在安装过程完成后开始。就手动安装测试而言，常规自动测试只会在手动安装程序完成后开始。

父主题： 安装和清理测试


配置安装和清理执行

将测试定义为安装或清理测试：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 单击要为其配置安装或清理测试的执行计划。
  3. 在测试执行安装部分中，选择安装测试或清理测试：
    • 要定义安装测试，请单击安装测试中的 编辑 （编辑）。将显示编辑安装测试对话框。
    • 要定义清理测试，请单击清理测试中的 编辑 （编辑）。将显示编辑清理测试对话框。
    您不能将测试分配至与设置测试和常规或清理测试相同的执行计划。已分配的测试可来自项目内的任何测试容器。因此，可分配具有关联产品和源代码管理配置文件的测试，它们会随其主机执行计划的变化而变化。
  4. 在测试树中选择测试。
  5. 单击确定。
当重新运行失败的测试时，也会重新运行相应的设置/清理例程。设置/清理测试不与尝试运行测试运行一起运行，因为此执行不依赖执行计划。
父主题： 安装和清理测试


配置部署环境

  • 执行部署页面
    显示为执行计划定义的所有硬件配置关键字、指定为执行手动测试的用户以及指定为执行 Silk Test Classic 测试的 Silk Test Classic AUT 主机。
  • 添加或移除手动测试工程师
    在包含手动测试的执行计划中添加或移除手动测试工程师。
  • 使用关键字执行动态硬件配置
    Silk Central 的硬件配置技术可帮助您管理包含多个执行服务器的测试环境。无须为每个自动执行计划配置一对一的静态执行服务器分配，关键字使 Silk Central 能够自动为每个执行计划选择最合适的执行服务器。这是通过将每个执行计划的关键字列表与所有活动执行服务器的关键字列表进行比较来完成的。
  • 独占执行
    独占执行定义是在同一匹配执行服务器上可同时执行禁用此设置的其他执行计划的已分配测试（已禁用），还是仅可同时运行一个执行计划的测试（已启用）。
  • 分布执行
    分布执行定义是在所选执行服务器上按顺序执行执行计划的测试（已禁用），还是将测试分布到所有匹配执行服务器上并行运行（已启用）。
  • 为自动测试选择移动设备
    选择要运行执行计划的移动设备（物理设备、仿真器或模拟器）。
  • 代码分析
    介绍如何使用 Silk Central 分析代码覆盖率。
  • 添加 Silk Test Classic AUT 主机
    当 Silk Test Classic 代理位于执行服务器以外的其他计算机上时，添加 Silk Test Classic AUT 主机。
父主题： 管理执行计划、文件夹和配置套件


执行部署页面

执行计划 > 详细信息视图 > <执行计划> > 部署

部署页面显示为此执行计划定义的所有硬件配置关键字。这些关键字用于描述执行计划的执行环境需求。执行服务器仅匹配所选的自动执行计划（如果它已分配执行计划所需的所有关键字）。部署页面还显示指定为执行手动测试的用户以及指定为执行 Silk Test Classic 测试的 Silk Test Classic AUT 主机。

注： 可在管理 > 执行服务器中设置新的执行服务器。有关如何设置执行服务器的详细信息，请参阅设置执行服务器。

手动测试执行

列出为此执行计划或文件夹分配的所有手动测试人员。单击编辑可编辑手动测试人员列表。有关其他信息，请参阅添加或移除手动测试人员。

自动测试执行

部署页面在自动测试执行部分显示以下项目：
项 | 说明
已分配的关键字
列出已分配至执行计划的关键字。
自动执行计划
关键字用于自动识别每个测试执行的相应执行服务器。
手动执行计划
手动测试人员使用关键字反映测试环境。
有关其他信息，请参阅将关键字分配到执行计划。
在执行时用于部署的潜在执行服务器的关键字相关列表 | 列出活动执行服务器，其具有与此执行计划的关键字列表匹配的关键字列表。执行计划关键字列表中的所有关键字都必须包含在执行服务器的关键字列表中。单击列表中的执行服务器名称可访问管理 > 执行服务器中的执行服务器列表。
独占执行已分配测试 | 独占执行定义是在同一匹配执行服务器上可同时执行禁用此设置的其他执行计划的已分配测试（已禁用），还是仅可同时运行一个执行计划的测试（已启用）。启用独占执行可减少所需的执行时间，对于移动测试尤为有用，因为执行计划可在设备提供商的多个设备上同时执行。禁用独占执行功能无需更改您当前的执行配置。 有关其他信息，请参阅独占执行。
分布执行已分配测试 | 分布执行定义是在所选执行服务器上按顺序执行执行计划的测试（已禁用），还是将测试分布到所有匹配执行服务器上并行运行（已启用）。开启分布执行功能无需更改您当前的执行配置。 有关其他信息，请参阅分布执行。
视频录制
定义在执行执行计划的过程中是否录制视频。此设置将覆盖分配至执行计划的单个测试的视频录制设置。您可以选择以下值之一：
值
说明
---
将禁用视频录制，设置了 recordVideo 的已分配测试除外。
从不
将始终禁用视频录制，即使是设置了 recordVideo 的已分配测试也是如此。
始终
在每次执行执行计划时录制视频。
出错
在执行计划的执行过程中出现错误时录制视频。
有关其他信息，请参阅视频捕获。
屏幕捕获
定义在执行计划的执行过程中是否捕获屏幕截图。此设置将覆盖分配至执行计划的单个测试的屏幕捕获设置。您可以选择以下值之一：
值
说明
---
将禁用屏幕捕获，在其中设置 captureScreen 参数的已分配测试除外。
从不
将始终禁用屏幕录制，即使是在其中设置 captureScreen 参数的已分配测试也是如此。
出错
在执行计划的执行过程中出现错误时捕获屏幕截图。
有关其他信息，请参阅屏幕捕获。
执行停止条件
定义当测试失败或未执行测试时是否停止执行。如果即使一个测试失败，使一组测试保持运行就没有任何意义，此设置将非常有用。使用此设置可保存资源并提前获知测试是否失败。您可以选择以下值之一：
值
说明
---
将继续执行，即使某个测试未执行或失败。
出错
第一个测试失败时，该执行会停止。
未执行
第一个测试未执行时，该执行会停止。
出错或未执行
第一个测试失败或未执行时，该执行会停止。
注： 如果执行已停止，则成功执行的测试的结果将会保留。测试程序包（含所有从属测试）将始终执行到最后。它们不会间歇性停止。但是，数据驱动型测试将在从属测试失败后立即停止。
Silk Test Classic AUT 主机名

列出为此执行计划定义的所有 Silk Test Classic AUT 主机。单击编辑可编辑 Silk Test Classic AUT 主机列表。有关其他信息，请参阅添加 Silk Test Classic AUT 主机。

移动设备选择

列出选定用来执行所选执行计划的移动设备。单击编辑选择不同的设备。请注意，设备提供程序和当前项目必须分配到相同的位置，否则设备不会显示在列表中。有关附加信息，请参阅管理设备提供程序。

代码分析设置

详细说明为此执行计划定义的代码分析设置。单击活动/非活动以启用或禁用此执行计划的代码分析。有关其他信息，请参阅代码分析。

父主题： 配置部署环境
相关概念
视频捕获


添加或移除手动测试工程师

对于包含手动测试的执行计划，您可通过部署页面将用户作为手动测试工程师分配到所选执行计划。您可将多个手动测试工程师分配到执行计划。

将手动测试工程师分配到执行计划，或者从所选执行计划中移除测试工程师：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的执行计划。
  3. 单击部署选项卡。
  4. 单击手动测试执行部分中的编辑。 此时将显示添加/删除测试程序对话框。
  5. 从可用列表中选择要使用的用户组。
  6. 添加或删除测试程序：
    • 在可用列表中选择一个或多个用户，然后单击添加或全部添加。
    • 在已选定列表中选择一个或多个用户，然后单击删除或全部删除。
    您可以使用 Ctrl+单击或 Shift+单击选择多个用户。
  7. 单击确定关闭添加/删除测试工程师对话框。
父主题： 配置部署环境


使用关键字执行动态硬件配置

Silk Central 的硬件配置技术可帮助您管理包含多个执行服务器的测试环境。无须为每个自动执行计划配置一对一的静态执行服务器分配，关键字使 Silk Central 能够自动为每个执行计划选择最合适的执行服务器。这是通过将每个执行计划的关键字列表与所有活动执行服务器的关键字列表进行比较来完成的。
  • 关键字概念
    关键字通常描述了您的执行环境需求，例如平台、操作系统和预安装的应用程序。关键字有各种用法，具体取决于是自动还是手动执行执行计划。
  • 创建新关键字
    创建新关键字以描述执行环境。
  • 将关键字分配到执行计划
    将关键字分配到执行计划以描述执行环境。
  • 从执行计划中删除关键字
    当关键字不再能说明执行环境时，从执行计划中删除关键字。
父主题： 配置部署环境


关键字概念

关键字通常描述了您的执行环境需求，例如平台、操作系统和预安装的应用程序。关键字有各种用法，具体取决于是自动还是手动执行执行计划。
自动执行计划
当执行自动执行计划时，Silk Central 会将执行计划的关键字与所有可用执行服务器的关键字进行比较。随后执行会在具有匹配关键字列表的首先识别的执行服务器上运行。
手动执行计划
对于手动执行计划，手动测试工程师可以使用关键字反映测试环境。

如果您需要在多个执行服务器上运行自动执行计划，请创建执行计划的副本并为匹配其他执行服务器的执行计划分配其他关键字。

保留关键字

如果您不需要硬件配置来执行自动执行计划，则您可以使用为每个执行服务器自动创建的保留关键字。在这种情况下，无需手动将关键字分配至执行服务器。相反，您可以为每个执行计划配置一对一的静态执行服务器分配。

保留关键字将自动分配至每个新创建的执行服务器。保留关键字采用以下结构形式：#<execution server name>@<location name>。

仅当为执行计划分配关键字时，保留的关键字才可用。

除了为每个定义的执行服务器自动设置保留关键字以外，还会为每个执行服务器类型设置保留关键字：
#PHYSICAL
将执行服务器配置限制为物理执行服务器。
#VIRTUAL
将执行服务器配置限制为虚拟执行服务器。

关键字和虚拟执行服务器

为虚拟执行服务器分配关键字的方式与为物理执行服务器分配关键字的方式相同。当您配置至少一个虚拟执行服务器时，#VIRTUAL 关键字将自动创建并且可分配至所有执行计划。如果想要在虚拟机上对执行计划予以执行，请为执行计划选择 #VIRTUAL 关键字。如果执行计划的关键字既不是 #VIRTUAL 也不是 #PHYSICAL，则表示可在虚拟或物理执行服务器上执行（假定执行环境的设置相同）。如果测试关键字匹配多个虚拟执行服务器，则将选择所识别的第一个匹配虚拟执行服务器。

文件夹执行

执行计划可组合到执行文件夹内，其中文件夹可包含执行子文件夹和执行计划。用于执行计划的执行选项也可用于执行文件夹的执行。

当执行文件夹时，所含的子文件夹和执行计划将视为：
已执行文件夹的关键字 | 所含执行计划/子文件夹的关键字 | 组合执行计划/子文件夹的执行
没有关键字 | 没有关键字 | 无关键字的执行计划将在执行后获取“未执行”状态
没有关键字 | 具有关键字 | 执行服务器将根据执行计划/子文件夹关键字进行分配
具有关键字 | 没有关键字 | 执行服务器将根据文件夹关键字进行分配
具有关键字 | 具有关键字 | 执行服务器将根据文件夹关键字进行分配
注： 如果手动执行文件夹并且没有分配关键字，或者已分配的关键字不存在执行服务器，则这些执行计划将标记为未执行。
父主题： 使用关键字执行动态硬件配置


创建新关键字

要创建新关键字，请执行以下操作：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的执行计划。
  3. 单击部署选项卡。
  4. 在页面的执行环境部分，单击编辑。 此时将显示分配关键字。此处将列出为执行环境定义的所有关键字。
    注： 列表中包含各执行服务器的默认保留关键字 #<execution server name>@<location name>。
  5. 在描述执行计划所需环境的关键字文本框中，键入字母数字关键字。

    例如，关键字可能是平台、操作系统或预装应用程序的名称。关键字中不能使用以下字符：#$?*\,;'"。

    注： 关键字不区分大小写。例如，“Vista”和“vista”会处理为相同关键字。
  6. 按下 Enter。 该新关键字此时可用于分配。
父主题： 使用关键字执行动态硬件配置


将关键字分配到执行计划

将关键字分配到执行计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的执行计划。
  3. 单击部署选项卡。
  4. 在页面的执行环境部分，单击编辑。 此时将显示分配关键字。此处将列出为执行环境定义的所有关键字。
    注： 列表中包含各执行服务器的默认保留关键字 #<execution server name>@<location name>。
  5. 在选择或输入关键字列表中选择关键字或直接输入新关键字。 使用 Ctrl+单击或 Shift+单击选择多个关键字。
    提示： 选择或输入关键字字段已启用自动完成功能。当您输入字母数字字符时，该字段会使用与输入的字符匹配的现有关键字动态更新。在选择或输入关键字或已分配的关键字列表中选择多个关键字时，此字段会禁用。
    提示： 如果您只有几台执行服务器并且不需要硬件配置，则使用为每台执行服务器创建的默认保留关键字可能已经足够。在此情况下，不必选择其他关键字。
  6. 单击 > 将关键字移到已分配的关键字列表中。单击 < 从列表中删除关键字。您也可双击关键字以将其从一个列表移到另一个列表。
    注： 与已分配的关键字匹配的执行服务器列在下面动态更新的匹配执行服务器列表中。此列表会在每次添加或删除关键字时进行更新。单击列表中的执行服务器名称，以在管理 > 执行服务器中访问执行服务器。
  7. 单击确定可保存关键字并关闭分配关键字对话框。
父主题： 使用关键字执行动态硬件配置


从执行计划中删除关键字

删除执行计划关键字分配：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的执行计划。
  3. 单击部署选项卡。
  4. 在页面的执行环境部分，单击编辑。 此时将显示分配关键字。此处将列出为执行环境定义的所有关键字。
    注： 列表中包含各执行服务器的默认保留关键字 #<execution server name>@<location name>。
  5. 选择已分配的关键字列表中不再需要的关键字。 使用 Ctrl+单击或 Shift+单击可选择多个关键字。
  6. 单击 < 删除关键字分配。
  7. 单击确定可保存关键字并关闭分配关键字对话框。
注： 将从系统中自动删除不再使用的关键字。
父主题： 使用关键字执行动态硬件配置


独占执行

独占执行定义是在同一匹配执行服务器上可同时执行禁用此设置的其他执行计划的已分配测试（已禁用），还是仅可同时运行一个执行计划的测试（已启用）。启用独占执行可减少所需的执行时间，对于移动测试尤为有用，因为执行计划可在设备提供商的多个设备上同时执行。禁用独占执行功能无需更改您当前的执行配置。

启用独占执行之前，请注意以下几点：
  • 所有 Silk Central 测试类型均支持并行执行，Silk Test Classic、Silk Test Classic 计划和 Silk Performer 除外。
  • 在同一计算机上同时执行时，您的测试脚本不能彼此干扰。这意味着，测试脚本不能向常用文件夹写入数据，且受测试应用程序必须支持并行脚本执行操作。
  • 所用源代码管理配置文件中的常用工作文件夹必须为空。这允许 Silk Central 使用临时工作文件夹。
  • 如果一个测试计划在执行服务器上运行，且为其启用了独占执行设置，则不允许并行执行其他执行计划，无论这些执行计划的设置如何。
  • 如果另一个执行计划已在并行执行期间录制，则不会显示任何视频。
  • 有关并行执行 Silk Test 测试的其他信息，请参阅以下文档：
    • 并行运行 Silk Test Workbench 测试
    • 并行运行 Silk4J 测试
    • 并行运行 Silk4NET 测试
父主题： 配置部署环境


分布执行

分布执行定义是在所选执行服务器上按顺序执行执行计划的测试（已禁用），还是将测试分布到所有匹配执行服务器上并行运行（已启用）。开启分布执行功能无需更改您当前的执行配置。

启用分布执行之前，请注意以下几点：
  • 如果分配测试的执行时间非常短，分布式执行并不会提高整体执行时间，因为测试部署，源控制管理和结果提取的管理开销将超过并行测试执行的优势。
  • 所有 Silk Central 测试类型均支持分布执行。
  • 如果另一个测试已在同一执行服务器上进行录制，则不会提供任何代码覆盖率信息。
  • 如果另一个测试已在同一执行服务器上进行录制，则不会提供任何视频。
  • 如果其中一个测试具有执行停止条件，若满足此条件，当前正在运行的和尚未开始运行的所有测试都将停止。当前正在运行的测试将设置为失败，而尚未开始运行的测试将设置为未执行。在满足条件之前已设置为通过的测试仍将保持此状态。
  • 不考虑使用虚拟执行服务器进行分布执行。
父主题： 配置部署环境


为自动测试选择移动设备

在可以选择要运行执行计划的移动设备（物理设备、仿真器或模拟器）之前，需要配置设备提供程序。请注意，设备提供程序和当前项目必须分配到相同的位置，否则设备不会显示在列表中。有关附加信息，请参阅管理设备提供程序。
要选择移动设备：
  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择要为其选择移动设备的执行计划。
  3. 单击部署选项卡。
  4. 在移动设备选择部分中单击编辑。 将显示选择设备对话框。
  5. 选择移动设备、设备筛选器或本机应用程序：
    • 要选择特定设备，请使用右侧的列表。
    • 要选择设备筛选器，请使用右侧列表中的任何设备。使用左侧的搜索字段、平台和应用程序列表编辑此筛选器。
      提示： 使用搜索字段搜索特定设备类型，例如搜索仿真器或模拟器。
    • 要在移动设备上安装本机应用程序以进行测试，请在左侧的应用程序列表中选择本机应用程序，然后在下面字段中指定该应用程序的 URL 或 UNC 路径（iOS 需要 URL）。示例：\\fileserver\apps\testapp.apk
  6. 可选：如果要为设备选择排除仿真器和模拟器，请选中仅使用物理设备复选框。
  7. 可选：选中隐藏已使用或阻止的设备复选框，仅列出当前可用的设备。如果您要执行手动测试，或者如果您要立即运行执行计划，此功能特别很有帮助。
  8. 单击确定保存移动设备选择。
在执行期间，将使用并阻止所选设备或筛选器的第一个匹配设备，直至完成执行计划为止。如果所选设备不可用，或筛选器没有匹配到任何可用设备，执行作业将保留在队列中，直至有合适的执行服务器和移动设备变得可用为止。Sauce Labs 设备实际上并不是单个设备，而是设备类型，因此在执行过程中不会被阻止。

要在稍后更改或删除移动设备选择，请相应使用编辑和删除按钮。

父主题： 配置部署环境


代码分析

传统代码覆盖率的目标是提供关于测试覆盖哪些代码的信息。此方法通常用于获取单元测试的代码覆盖率信息。Silk Central 中的代码分析功能远远不止于此，它还能在受管理环境中以自动和手动方式提供单元测试、功能测试和负载测试数据。代码覆盖率测量用于跟踪测试进度和指导测试计划。Silk Central 中的这种创新代码覆盖率方法可提取特定测试与所测试代码之间的关系。您可通过此方法从测试角度执行代码更改的影响/依赖关系分析。它还能帮助您识别与特定代码更改最相关的测试运行，从而优化测试。

代码分析单元提供了 AUT（正在测试的应用程序）、程序包/命名空间、类、方法和语句的代码覆盖率数据，从而让您能够执行测试影响分析（这将决定应根据特定代码更改运行的测试）和工作分析（这将决定要完全覆盖特定代码更改所需的自动测试和手动测试小时数）。这些代码分析任务均可通过运行预先配置的报告来执行。单元具有导航树，可列出为所选项目创建的所有产品。您可向下钻取到产品以选择特定版本，并在最深级别选择特定内部版本。

  • 启用代码分析
    介绍如何使用 Silk Central 启用代码分析。
  • 代码分析详细信息页面
    在产品、程序包和类级别显示所选产品、版本和内部版本的代码覆盖率信息。
  • 最新内部版本和版本
    介绍如何获取有关最新覆盖的内部版本和版本的覆盖率信息。
  • 生成代码更改影响报告
    生成代码更改影响报告以查看包括类集的所有测试。
  • 选择报告类对话框
    介绍选择报告类对话框的内容。
  • 查看程序包/命名空间的代码覆盖率信息
    如何查看程序包/命名空间的代码覆盖率信息。
父主题： 配置部署环境
父主题： 报告


启用代码分析

您必须配置 Silk Central 以从正在测试的应用程序收集代码覆盖率数据。您可以配置执行 > 详细信息视图 > 部署中所列的任意数目的执行计划。
提示： 请确保仅有启用了代码覆盖率的测试访问正在测试的应用程序，未执行任何并行测试。这能保证代码覆盖率数据正确无误，而且这些数据稍后能分配到特定测试。
  • Java 代码分析选项
    介绍受支持的 Java 版本的代码分析选项。
  • .NET 代码分析
    介绍 .NET 代码分析的配置。
  • 为执行计划启用代码分析
    为执行计划启用代码分析以跟踪测试进度。
父主题： 代码分析


Java 代码分析选项

要将 Java 代码分析用于 AUT，您必须使用 Java 代理运行 AUT 的 JVM。需要 Java Runtime Environment (JRE) 5 或更高版本。对于所有受支持的 Java 版本，您可以使用以下选项：
选项
说明
port=19129
可选：代码覆盖率服务的端口。如果未指定任何端口，则使用 19129 端口。
coveragepath=[path1],[path2], ...
代理覆盖的 .jar 文件的路径。如果部分路径包含空格，则必须使用引号。例如：coveragepath="C:\Program Files\YourApplication\"。如果已指定文件夹，则代理会递归查找此文件夹中所有 .class 文件。如果已指定带有尾部通配符的文件夹，则代理将查找此文件夹中的 .jar 文件。在未指定覆盖路径的情况下运行代理无效。
java -javaagent:agent.jar=coveragepath=
"C:Program Files\YourApplication\" Aut.jar
includes=[package1]:[package2]:[package3]: ...
可选：仅与这些程序包匹配的程序包才会被视为覆盖。允许使用通配符 (*) 指定包括的程序包。
java -javaagent:agent.jar=includes=com.borland.* AUT.jar
excludes=[package1]:[package2]:[package3]: ...
可选：排除选项中指定的程序包将从代码覆盖率中忽略。允许使用通配符 (*) 指定排除的程序包。
java -javaagent:agent.jar=includes=com.borland.*;
excludes=com.borland.internal* AUT.jar
注： 如果已在筛选器中指定包含和排除，则先评估排除。如果包含类并通过筛选器排除类，系统将排除此类，并且不会为此类生成任何覆盖率数据。如果未指定筛选器选项，将为所有使用的类生成覆盖率数据，除非已设置覆盖路径选项，在这种情况下，将为覆盖路径中的所有类生成覆盖率数据。

Java 代码分析示例

Windows 示例：
"<java_home_directory>\bin\java" -javaagent:agent.jar=port=19129;
coveragepath=C:\dev\deploy\lib\library1.jar,C:\dev\deploy\lib\library2.jar;
includes=com.borland.*;excludes=com.borland.internal.* com.borland.MyApplication
Linux 示例（包括引号）：
"<java_home_directory>/bin/java" -javaagent:agent.jar="port=19129;
coveragepath=/tmp/dev/deploy/lib/library1.jar,/tmp/dev/deploy/lib/library2.jar;
includes=com.borland.*;excludes=com.borland.internal.*" com.borland.MyApplication
父主题： 启用代码分析


.NET 代码分析

  • 安装 Windows 代码分析框架和 DevPartner 分析
    介绍如何安装 Windows 代码分析框架和 DevPartner 分析。
  • .NET 代码分析和手动测试
    介绍使用 DevPartner 代码覆盖率的高级步骤。
  • .NET 代码分析和自动测试
    介绍如何组织自动测试的结构。
  • 使用 DPAnalysis.exe
    介绍如何使用 dpanalysis.exe。
父主题： 启用代码分析


安装 Windows 代码分析框架和 DevPartner 分析

执行该任务之前，确保在将安装代码分析框架的计算机（即，承载要测试的应用程序的计算机）上安装了 Microsoft .NET Framework 3.5。更早或更新版本的 Microsoft .NET Framework 都无效！

  1. 转到托管要测试的应用程序的机器。
  2. 打开 Silk Central。
  3. 转至帮助 > 工具，然后单击 Windows 代码分析框架。此时将提示下载 CAFramework.exe。CAFramework.exe 包含 Code Analysis Framework 和 DevPartner Analytics 程序包的安装。
    注： 不支持多个执行服务器根据同一代码分析框架运行测试。
  4. 双击下载文件以开始安装。完成 Windows 代码分析框架的安装。在安装结束时，系统将提示您安装 DevPartner Analytics。确保在相应的安装屏幕上选中 DevPartner 分析安装复选框，并安装此组件。 在此安装结束时，将安装所有必需文件并启动正确的服务。该服务的名称为 Silk Central Code Analysis Service。
父主题： .NET 代码分析


.NET 代码分析和手动测试

以下章节详细介绍安装和使用 Silk Central 随附的 DevPartner .NET 代码覆盖率组件所需的步骤。以下示例将通过使用手动测试和单个 AUT 带您入门。如果您计划使用自动测试，请先阅读和了解以下步骤，然后再查看标题为 .NET 代码分析和自动测试的主题。

注： 要使用 Silk Central/.NET 代码覆盖率功能，必须使用 Micro FocusDevPartner Analytics 组件版本 11.2 或更高版本。
注： .NET 代码分析要求在编译要测试的 .NET 应用程序 (AUT) 时所生成的 PDB 文件与 AUT 的可执行文件位于相同目录中。如果 AUT 的 PDB 不可用，则不可能利用 .NET 代码分析功能。

手动测试工作流

  1. 配置 DPAnalysis 以启动您的 AUT
    介绍如何配置 DPAnalysis 以启动您的 AUT。
  2. 配置 Silk Central 以进行代码分析
    介绍如何配置 Silk Central 以进行代码分析。
父主题： .NET 代码分析


配置 DPAnalysis 以启动您的 AUT

  1. 创建一个指向 DPAnalysis.exe 的 .BAT 文件。 示例如下：
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe" /cov /USE_AUTOMATION_INTERFACE
/W "C:\Common\Development\MYAPP"
/P "C:\Common\Development\MYAPP\MyApp.exe"
  2. 为了便于阅读，上述示例分多行显示。 您的 .BAT 文件应在一行上。 进行以下修改：
    1. 确保第一行是 dpanalysis.exe 的安装路径。 这两个开关都是强制性的。
    2. 第二行包含一个强制开关，并且需要包括可执行文件路径和 PDB。
    3. 第三行包括一个强制开关，并且需要包括测试应用程序的绝对路径和应用程序名称。
  3. 双击 .BAT 文件以通过 DPAnalysis 启动您的应用程序。
有关运行 DPAnalysis.exe 的更多信息，请参阅标题为使用 DpAnalysis.exe 的主题。 该主题及相关主题包含关于其他开关的信息以及如何在有多个应用程序要测试时使用配置文件。
父主题： .NET 代码分析和手动测试
下一主题： 配置 Silk Central 以进行代码分析
相关概念
使用 DPAnalysis.exe


配置 Silk Central 以进行代码分析

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 使用测试 AUT 功能所用的步骤打开包含手动测试的现有执行计划。
  3. 单击部署选项卡。
  4. 在代码分析设置下，单击编辑以查看编辑代码分析设置对话框。
  5. 确保已选中启用代码分析。
  6. 从代码分析配置文件列表中选择 DevPartner .NET 代码分析。
  7. 对于主机名字段，请键入主机名，后接冒号和端口号。 例如：localhost:19129。

    默认代码分析框架端口是 19129。 您可配置代码分析框架，以使用以下 xml 文件在给定端口上运行：<install dir>\Code Analysis\CodeAnalysisConfig.xml

  8. 单击确定。
  9. 单击执行区域中的运行以运行测试。
  10. 在运行对话框上，确保已选中所有测试。
  11. 在设置执行计划的内部版本中，选择执行计划的正确内部版本。
  12. 单击确定。
父主题： .NET 代码分析和手动测试
上一主题： 配置 DPAnalysis 以启动您的 AUT


.NET 代码分析和自动测试

本节介绍您在执行使用代码覆盖率的测试时可能遇到的两种情况。同时还提供了在执行计划中组织测试的正确方法。以下主题中所用示例特定于 DevPartner 代码分析，但结构与其他代码分析工具类似。例如，您将在执行计划中拥有不同的启动/清理参数。

注： AUT 启动与代码分析启动之间可能会有延迟，从而可能导致代码分析无法录制部分 AUT 启动代码。

自动测试工作流

  • 配置具有一个 AUT 的一个或多个测试
    如果您在一个执行计划中拥有一个或多个测试并对一个被测试应用程序进行测试，请按照此处所述步骤组织您的测试。
  • 配置具有多个 AUT 的一个或多个测试
    如果您在一个执行计划中拥有一个或多个测试并对多个被测试应用程序进行测试，请按照此处所述步骤组织您的测试。
父主题： .NET 代码分析
相关任务
创建或编辑 ProcessExecutor 测试


配置具有一个 AUT 的一个或多个测试

如果您在一个执行计划中拥有一个或多个测试并对一个被测试应用程序进行测试，您应按以下步骤组织您的测试：

  1. 创建将启动代码分析应用程序的 ProcessExecutor 测试。 ProcessExecutor 参数列表将会启动您的代码分析程序。 例如：start cmd /c start cmd /c D:\sctm\dps\startDPS_Simple1.bat，其中 startDPS_Simple1.bat 包含：
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe"
/cov
/USE_AUTOMATION_INTERFACE
/O "D:\SCTM\temp"
/W "D:\SCTM\DPS\TESTAPP\SCTMCodeAnalysisTestApp\bin\Debug"
/P "D:\SCTM\DPS\TESTAPP\SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe"
  2. 创建执行计划。
  3. 单击执行 > 详细信息视图，选择执行计划，然后单击安装/清理选项卡。
  4. 将先前创建的测试添加为安装测试。
  5. 将测试添加到使用自动测试工具自动执行被测试应用程序的执行计划。
  6. 可选：将另一个测试添加到使用自动测试工具自动执行被测试应用程序的执行计划。
  7. 创建 ProcessExecutor 测试。
  8. 单击执行 > 详细信息视图，选择执行计划，然后单击安装/清理选项卡。
  9. 将先前创建的测试添加为清理测试。
ProcessExecutor 参数列表将会关闭您的程序：start cmd /c taskkill /IM SCTMCodeAnalysisTestApp.exe。
父主题： .NET 代码分析和自动测试


配置具有多个 AUT 的一个或多个测试

如果您在一个执行计划中拥有一个或多个测试并对多个 AUT 进行测试，您应按以下步骤组织您的测试：

  1. 创建将启动代码分析应用程序的 ProcessExecutor 测试。 ProcessExecutor 参数列表将会启动您的代码分析程序。 例如：start cmd /c start cmd /c D:\sctm\dps\two_app_dps.cmd，其中 two_app_dps.cmd 包含：
    "C:\Program Files\Micro Focus\DevPartner\Analysis\dpanalysis.exe"
/config D:\SCTM\DPS\configuration_file.xml
    并且 configuration_file.xml 包含：
    <?xml version="1.0" ?>
<ProductConfiguration>
    <RuntimeAnalysis Type="Coverage" MaximumSessionDuration="1000" NoUIMsg="true" />
    <Targets RunInParallel="true">
        <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NM_USE_AUTOMATION_INTERFACE="1" >
            <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
            <Path>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
          SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe</Path>
            <Arguments></Arguments>
            <WorkingDirectory>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug</WorkingDirectory>
        </Process>
        <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" >
            <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
            <Path>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\
         QADSCTMMigration\bin\QADSCTMMigration.exe</Path>
            <Arguments></Arguments>
            <WorkingDirectory>D:\SourceCode\SVNQAD\Development\Development\
         SOURCECODE\QADSCTMMigration\bin</WorkingDirectory>
        </Process>
    </Targets>
</ProductConfiguration>
  2. 创建执行计划。
  3. 单击执行 > 详细信息视图，选择执行计划，然后单击安装/清理选项卡。
  4. 将先前创建的测试添加为安装测试。
  5. 将测试添加到使用自动测试工具自动执行第一个被测试应用程序的执行计划。
  6. 将另一个测试添加到使用自动测试工具自动执行第二个被测试应用程序的执行计划。
  7. 创建 ProcessExecutor 测试。
  8. 单击执行 > 详细信息视图，选择执行计划，然后单击安装/清理选项卡。
  9. 将先前创建的测试添加为清理测试。
ProcessExecutor 参数列表将会关闭您的程序：start cmd /c taskkill /IM application1.exe /IM Application2.exe。
父主题： .NET 代码分析和自动测试


使用 DPAnalysis.exe

DPAnalysis.exe 是 DevPartner 代码覆盖率应用程序，让您可以分析 .NET 应用程序。 应用程序使用命令行启动。

您可以将应用程序与这些主题中记录的传统命令行开关一起使用，或添加指向配置文件的其他传统命令行。 如果您的命令行字符串过长，或在单个会话中运行多个应用程序，则可能希望使用配置文件。

/USE_AUTOMATION_INTERFACE 命令行开关是必需的。 它会导致建立与框架交互所需的自动化接口环境。 它还会导致避开许可检查。 此命令行开关不接受任何参数。

  • 从命令行运行 DPAnalysis.exe
    介绍如何从命令行运行 dpanalysis.exe。
父主题： .NET 代码分析


从命令行运行 DPAnalysis.exe

DevPartner Studio 代码覆盖率安装包括 DPAnalysis.exe，即在 \Program Files\Micro Focus\DevPartner Studio\Analysis\ 目录中安装的命令行可执行文件。

使用以下语法和命令开关从命令行运行 DevPartner Studio 代码覆盖率工具：

DPAnalysis  [/Cov] [/USE_AUTOMATION_INTERFACE] [/E|/D|/R]
[/W workingdirectory] [/PROJ_DIR] [/H hostmachine]
[/NOWAIT] [/NO_UI_MSG] [/N] [/F] [/A C:\temp1;C:\temp2]
[/NO_QUANTUM /NM_METHOD_GRANULARITY /EXCLUDE_SYSTEM_DLLS
/NM_ALLOW_INLINING /NO_OLEHOOKS /NM_TRACK_SYSTEM_OBJECTS]
{/P|/S} target [target arguments]

示例

您可以直接从命令行使用 DPAnalysis.exe，通过命令开关引导分析会话。 例如，以下命令行可启动 SCTMCodeAnalysisTestApp.exe 应用程序的代码覆盖率会话。

dpanalysis.exe /cov /USE_AUTOMATION_INTERFACE /W "D:\SCTM\DPSCoverageIntegration\Test App\
SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\bin\Debug" /P
"D:\SCTM\DPSCoverageIntegration\Test App\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\bin
\Debug\SCTMCodeAnalysisTestApp.exe"
  • 命令行开关
    介绍 dpsanalysis 的命令行开关。
  • DPAnalysis 配置文件
    介绍 dpanalysis 的配置文件选项。
父主题： 使用 DPAnalysis.exe


命令行开关

  • 分析类型开关
    介绍分析类型开关。
  • 数据收集开关
    介绍用于摘要的数据收集开关。
  • 其他开关
    介绍 DPAnalysis.exe 的其他可选开关。
  • 分析选项
    介绍分析选项。
  • 目标开关
    介绍 dpanalysis.exe 的目标开关。
父主题： 从命令行运行 DPAnalysis.exe


分析类型开关

名称 | 说明
/Cov[erage] | 将分析类型设置为 DevPartner 覆盖率分析
注： DPAnalysis.exe 不会检测不受管理的代码。 要收集不受管理的应用程序的性能或覆盖率分析数据，必须首先检测应用程序。
父主题： 命令行开关


数据收集开关

启用或禁用给定目标的数据收集，但不会启动目标。 可选。

名称 | 说明
/E[nable] | 启用指定进程或服务的数据收集。
/D[isable] | 禁用指定进程或服务的数据收集。
/R[epeat] | 您无论何时运行指定进程都会进行分析，直至您使用 /D 开关禁用分析。
父主题： 命令行开关


其他开关

这些开关为可选。

名称 | 说明
/W[orkingDir] | 指定目标进程或服务的工作目录。
/PROJ_DIR | 指定用于查找播放列表等内容的 DevPartner Studio 项目的目录。
/N[ewconsole] | 在其自身的命令窗口中运行进程。 如果您使用 DPAnalysis.exe 分析需要键盘输入的控制台应用程序，则必须使用 /NewConsole 开关打开控制台窗口以接受输入。
/INCLUSION_FILTER <filterFile>

/INCLUSION_FILTER 开关为可选，它允许指定 Inclusion Filter 文件。 此文件仅在覆盖率数据提供给 Silk Central 特定 XML 格式的框架时使用。 这会导致报告生成程序筛选掉筛选器文件中未指定的所有类。 此开关需要单个参数，如此处所示。

/INCLUSION_FILTER <filterFile>

其中 <filterFile> 是在程序运行期间使用的筛选器文件的完全限定路径。

下方的示例 Inclusion_Filter 文件是一个示例 XML 文件，它包含要包括在已生成的报告中的类集。 它还包含一个值 <filterClasses>，它指明是否应用筛选器。

<!--D:\Public\SCTM Work\ProdAPI_Tester_CSharp_LINES.dpcov-->
<inclusionInfo>
  <filterClasses>false</filterClasses>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_MsgStream</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_RecvTask</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_TimeStamp</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CTCS_Tracer</includedClass>
  <includedClass>MicroFocus.Products.Tools.TCS_TraceMechanism.CMsgRegisterClientReqMB</includedClass>
</inclusionInfo>
/A[ssembly_dir] | 仅用于覆盖率分析。 包含参考 DLL/PDB 文件的路径列表。 使用此开关可指定要在覆盖率会话文件中显示的任何参考 DLL/PDB 文件，而不是加载的 DLL/PDB 文件。 使用分号 (;) 分隔多个路径。
父主题： 命令行开关


分析选项

分析选项的示例如下：

<AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
列 | 类型
/NM_USE_AUTOMATION_INTERFACE | 配置文件的分析选项部分中的必需开关。 值必须等于“1”。
/NO_QUANTUM | 禁用花费在其他线程上的排除时间。
/NM_ALLOW_INLINING | 启用内联方法的运行时检测（仅限覆盖率和性能）。
/NO_OLEHOOKS | 禁用 COM 的收集。
父主题： 命令行开关


目标开关

将要遵循的目标识别为进程或服务。 必填。 只选择一个。 目标名称或路径后的所有参数将为目标参数。

名称 | 说明
/P[rocess] | 指定目标进程（后接进程参数）
/S[ervice] | 指定目标服务（后接服务参数）
/C[onfig] | 配置文件的路径
父主题： 命令行开关
相关概念
DPAnalysis 配置文件


DPAnalysis 配置文件

要使用 XML 配置文件管理分析会话，请通过 /config 开关和作为其目标的正确结构化 XML 配置文件从命令行运行 DPAnalysis.exe。 例如：

dpanalysis.exe /config c:\temp\configuration_file.xml

通过使用配置文件，您可以配置和管理多个进程或服务。 用于配置多个进程的功能在分析 Web 应用程序时非常有用。

示例配置文件

<?xml version="1.0" ?>
<ProductConfiguration>
  <RuntimeAnalysis Type="Coverage" MaximumSessionDuration="1000" NoUIMsg="true" />
     <Targets RunInParallel="true">
          <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NM_USE_AUTOMATION_INTERFACE="1" >
               <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
               <Path>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug\SCTMCodeAnalysisTestApp.exe</Path>
               <Arguments></Arguments>
               <WorkingDirectory>D:\SCTM\DPS\SCTMCodeAnalysisTestApp\SCTMCodeAnalysisTestApp\
        SCTMCodeAnalysisTestApp\bin\Debug</WorkingDirectory>
          </Process>
          <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" >
               <AnalysisOptions NM_USE_AUTOMATION_INTERFACE="1" NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\temp" />
               <Path>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\QADSCTMMigration\bin\QADSCTMMigration.exe</Path>
               <Arguments></Arguments>
               <WorkingDirectory>D:\SourceCode\SVNQAD\Development\Development\SOURCECODE\QADSCTMMigration\bin</WorkingDirectory>
          </Process>
     </Targets>
</ProductConfiguration>
  • AnalysisOptions 元素
    介绍 dpanalysis.exe 配置文件的 analysisoptions 元素。
  • 参数元素
    介绍 dpanalysis.exe 配置文件的参数元素。
  • ExcludeImages 元素
    介绍 dpanalysis.exe 配置文件的 excludeimages 元素。
  • 主机元素
    介绍 dpanalysis.exe 配置文件的主机元素。
  • 名称元素
    介绍 dpanalysis.exe 配置文件的名称元素。
  • 路径元素
    介绍 dpanalysis.exe 配置文件的路径元素。
  • Process 元素
    介绍 dpanalysis.exe 配置文件的 Process 元素。
  • RuntimeAnalysis 元素
    介绍 dpanalysis.exe 配置文件的 runtimeanalysis 元素。
  • 服务元素
    介绍 dpanalysis.exe 配置文件的服务元素。
  • 目标元素
    介绍 dpanalysis.exe 配置文件的目标元素。
  • WorkingDirectory 元素
    介绍 dpanalysis.exe 配置文件的 Workingdirectory 元素。
父主题： 从命令行运行 DPAnalysis.exe


AnalysisOptions 元素

使用 AnalysisOptions 的属性因运行的分析会话类型而不同。

注： DPAnalysis.exe 会忽略与分析类型不匹配的属性。
<AnalysisOptions
    SESSION_DIR = "c:\MyDir"
    SESSION_FILENAME = "myfile.dpcov"
    NM_METHOD_GRANULARITY = "1"
    EXCLUDE_SYSTEM_DLLS = "1"
    NM_ALLOW_INLINING = "1"
    NO_OLEHOOKS = "1"
    NM_TRACK_SYSTEM_OBJECTS = "1"
 NO_QUANTUM="1"
    NO_MACH5 = "1"
    FORCE_PROFILING = "1"
 ASSEMBLY_DIR = "C:\TEMP1;C:\TEMP2"
/>

SESSION_DIR

可选。 与覆盖率、内存、性能和性能专家结合使用。 指定用于保存分析目标生成的会话文件的目录。 如果没有此属性，产生的会话文件将放置于用户的 My Documents 目录中。 如果 SESSION_DIR 和 SESSION_FILENAME 均不存在，DPAnalysis.exe 将在会话结束时提示您保存位置。

SESSION_FILENAME

可选。 与覆盖率、内存、性能和性能专家结合使用。 为此目标所生成的会话文件指定会话名称。 如果没有此属性，DPAnalysis.exe 会通过结合目标的映像名称与数字来创建唯一的名称（例如，iexplore1.dpprf）。 如果指定了名称但未指定目录，文件将放置于用户的 My Documents 目录中。 如果 SESSION_FILENAME 和 SESSION_DIR 均不存在，DPAnalysis.exe 将在会话结束时提示您保存位置。

NM_METHOD_GRANULARITY

可选。 与性能结合使用，以将数据收集粒度设置为方法级（默认为行级）。 指定值 1 以设置该属性。 省略该属性会将其禁用。

EXCLUDE_SYSTEM_DLLS

可选。 与性能结合使用，以排除系统映像。 指定值 1 以设置该属性。 省略该属性会将其禁用。

NM_ALLOW_INLINING

可选。 与覆盖率和性能结合使用，以指定分析详细信息的级别。 启用内联方法的运行时检测。 相当于检测内联函数属性。 指定值 1 以检测内联函数。 省略该属性以将其禁用。

NO_OLEHOOKS

可选。 与性能分析结合使用，以激活系统对象跟踪。 指定值 1 以设置该属性。 省略该属性会将其禁用。

NM_TRACK_SYSTEM_OBJECTS

可选。 与内存分析结合使用，以在跟踪已分配对象时忽略系统或第三方对象分配。 指定值 1 以设置该属性。 省略该属性会将其禁用。 当应用程序使用系统或其他未分析的资源时，您可通过默认状态（已禁用）查看内存分配情况。

NO_QUANTUM

可选。 与性能和性能专家分析结合使用，以排除其他运行应用程序的线程所花费的时间。 指定值 1 以设置该属性。 省略该属性会将其禁用。

FORCE_PROFILING

可选。 与性能和覆盖率分析结合使用，以对不含托管代码或 DevPartner Native C/C++ 分析的编写应用程序进行强制分析。 指定值 1 以设置该属性。 省略该属性会将其禁用。

ASSEMBLY_DIR

可选。 与覆盖率分析结合使用，以指定绝对路径，其中包含要显示在覆盖率会话文件中的引用程序集，但不含已加载程序集。 用分号分隔多个位置。 省略该属性会将其禁用。

元素信息

出现次数
每个 Process 或 Service 0 或 1。
父元素
Process、Service
内容
无

备注

可选。 为指定目标进程或服务定义运行时属性。 与 DevPartner 覆盖率、内存和性能属性相对应的属性可从 Visual Studio 中的“属性”窗口访问。

示例

以下示例显示在服务中使用 AnalysisOptions 的构造。

<Service CollectData="true">
  <AnalysisOptions NM_METHOD_GRANULARITY="1" EXCLUDE_SYSTEM_DLLS="1" NM_ALLOW_INLINING="1"
  NO_OLEHOOKS="1" ASSEMBLY_DIR="C:\TEMP">
</Service>
父主题： DPAnalysis 配置文件


参数元素

语法

<Arguments>/arg1 /arg2 /arg3</Arguments>

属性

无

元素信息

出现次数
每个 Process 或 Service 0 或 1。
父元素
Process、Service
内容
无

备注

可选。 如果省略，则没有默认值。 要传递到目标进程或服务的参数。

示例

以下示例在 Process 元素中使用 Arguments。

<Process CollectData="true">
 <Arguments>/arg1 /agr2 /arg3</Arguments>
</Process>
父主题： DPAnalysis 配置文件


ExcludeImages 元素

语法

<ExcludeImages>
  <Image>ClassLibrary1.dll</Image>
  <Image>ClassLibrary2.dll</Image>
</ExcludeImages>

属性

无。

元素信息

出现次数
每 Process 或 Service 为 0 或 1。
父元素
Process、Service
内容
Image

备注

可选。 如果忽略，则无默认值。 提供包含至少一个图像（无最大值）的列表，如果由目标进程或服务加载，则不会对其进行配置。

示例

以下示例显示进程元素中使用 ExcludeImages 的结构。 请注意 ExcludeImages 中所含的图像元素。

<Process CollectData="true">
 <ExcludeImages>
   <Image>ClassLibrary1.dll</Image>
   <Image>ClassLibrary2.dll</Image>
 </ExcludeImages>
</Process>
父主题： DPAnalysis 配置文件


主机元素

语法

<Host>hostmachine</Host>

属性

无

元素信息

出现次数
每 Process 或 Service 为 0 或 1。
父元素
Process、Service。
内容
主机名称。

备注

可选。 如果忽略，则无默认值。 设置目标进程或服务的主机。

示例

以下示例显示了在 Service 中使用 Host 的构造。 注意，示例包括所需的 Name 元素。

<Service CollectData="true">
  <Name>ServiceApp</Name>
  <Host>remotemachine</Host>
</Service>
父主题： DPAnalysis 配置文件


名称元素

语法

<Name>MyServiceName</Name>

属性

无。

元素信息

出现次数
1.
父元素
Service.
内容
服务名称。

备注

必填。 使用服务控制管理器注册的服务名称。 这与您用于系统 NET START 命令的名称相同。

示例

以下示例显示了在 Service 中使用 Name 的构造。

<Service CollectData="true">
 <Name>ServiceApp</Name>
</Service>
父主题： DPAnalysis 配置文件


路径元素

语法

<Path> c:\MyDir\target.exe </Path>

属性

无。

元素信息

出现次数
1.
父元素
Process。
内容
可执行文件的路径。

备注

必填。 指定可执行文件的完全限定路径或相对路径。 如果当前目录中已存在可执行文件，则您可以指定可执行文件的名称，而不是路径。

示例

以下示例显示进程元素中使用“路径”的结构。

<Process CollectData="true">
  <Path>ClientApp.exe</Path>
</Process>
父主题： DPAnalysis 配置文件


Process 元素

语法

<Process CollectData="true or false"
   Spawn="true or false"
      NoWaitForCompletion="true or false"
      NewConsole="true or false"
   RepeatInjection="true or false"> ...
</Process>

属性

运行指定进程时就会发生分析，除非您使用 /D 命令行开关禁用分析。

CollectData
可选。 指定 true 或 false。 如果忽略，则默认为 true。 指定是否为目标进程启用分析。
Spawn
可选。 指定 true 或 false。 如果忽略，则默认为 true。 指定 DPAnalysis.exe 是否生成指定目标。 不要为 aspnet_wp.exe 或 w3wp.exe 设置为 true。 DevPartner 无法直接生成 ASP.NET 工作进程。 通过打开目标网页启动 ASP.NET 工作进程。
NoWaitForCompletion
可选。 指定 true 或 false。 如果忽略，则默认为 false。 默认为等到进程完成。 如果设置为 true，则仅会导致 DPAnalysis.exe 等待，直至目标开始执行。 DPAnalysis.exe 不会在远程计算机上等待进程（使用 Host 元素）。 RuntimeAnalysis 元素中的 MaximumSessionDuration 属性替代 NoWaitForCompletion。
NewConsole

可选。 指定 true 或 false。 如果忽略，则默认为 false。 导致 DPAnalysis.exe 在自身的控制台窗口运行目标。 默认为使用您在其中键入 DPAnalysis.exe 命令行的相同控制台。 如果您使用 DPAnalysis.exe 分析需要键盘输入的控制台应用程序，则必须使用 /NewConsole 开关打开控制台窗口才可接受输入。

RepeatInjection
可选。 指定 true 或 false。 如果忽略，则默认为 false。 导致 DPAnalysis.exe 在每次运行时分析目标，直至您明确指定 false。

元素信息

发生次数
1 次或多次。
父元素
Target。
内容
AnalysisOptions、路径、参数、WorkingDirectory 和 ExcludeImages。

备注

指定目标可执行文件。

示例

以下示例显示了使用 Process 的构造，并且包括 AnalysisOptions、路径、参数、WorkingDirectory 标记。

<Targets RunInParallel="true">
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true" NewConsole="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>ClientApp.exe</Path>
    <Arguments>/arg1 /agr2 /arg3</Arguments>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
</Targets>
父主题： DPAnalysis 配置文件


RuntimeAnalysis 元素

语法

<RuntimeAnalysis Type="Coverage" NoUIMsg="false"
NM_INCLUSION_FILTER="Q:\AppDir\InclusionFilter.xml">

属性

类型
必需：可能的选项为：Performance；Coverage；Memory 或 Expert。 为列出的所有目标指定分析类型。
MaximumSessionDuration

可选：如果忽略，则不使用默认值。 如果指定，DPAnalysis.exe 将对此时间量限制会话运行。 例如，如果您指定 MaximiumSessionDuration="60" 然后开始分析服务（服务的 RestartAtEndOfRun="true" ），60 秒后，DPAnalysis.exe 将停止服务然后重新启动服务。

NoUIMsg

可选：如果忽略，将默认使用 false。 如果设置为 true，DPAnalysis.exe 会抑制会话持续期间可能出现的所有 UI 错误消息。 将此设置为 true 在会话以无人值守的方式运行，或运行大量连续测试时有用。

NM_INCLUSION_FILTER

可选：允许指定“包含筛选器”文件。 此文件仅在覆盖率数据提供给 Silk Central 特定 XML 格式的框架时使用。 这会导致报告生成程序筛选掉筛选器文件中未指定的所有类。 此切换接受单个参数。

元素信息

发生次数
1.
父元素
ProductConfiguration。
内容
无。

备注

必填。 定义分析类型和最大会话时间。

示例

以下示例显示使用 RuntimeAnalysis 和 ProductConfiguration 标记的构造。 在本示例中，类型属性指定最长持续时间为 1000 秒和抑制 UI 错误消息的性能分析。

<?xml version="1.0" ?>
<ProductConfiguration xmlns="http://www.microfocus.com/products">
<RuntimeAnalysis Type="Performance" MaximumSessionDuration="1000" NoUIMsg="true"/>
父主题： DPAnalysis 配置文件


服务元素

语法

<Service
      CollectData = "true or false"
      Start = "true or false"
      RestartIfRunning = "true or false"
      RestartAtEndOfRun = "true or false"
      RepeatInjection = "true or false"
      >
      ...
</Service>

属性

CollectData
可选。 指定 true 或 false。 如果忽略，则默认为 true。 指定是否为目标服务启用分析。
开始

可选。 指定 true 或 false。 如果忽略，则默认为 true。 指定 DPAnalysis.exe 是否启动指定目标。 如果设置为 false，则为此目标启用分析，但不会开始；下次启动服务时则开始分析（不管用何种方法）。

RestartIfRunning

可选。 指定 true 或 false。 如果忽略，则默认为 false。 将 RestartIfRunning 设置为 true 时，如果 DPAnalysis.exe 在主机计算机上运行，则将尝试重新启动指定的服务。

RestartAtEndOfRun
可选。 指定 true 或 false。 如果忽略，则默认为 false。 指定 true 时，DPAnalysis.exe 将在运行结束时重新启动服务（生成会话文件）。 如果服务是要进行分析的唯一进程，则将此属性设置为 false。
RepeatInjection
可选。 指定 true 或 false。 如果忽略，则默认为 false。 导致 DPAnalysis.exe 在每次运行时分析目标，直至您明确指定 false。

元素信息

发生次数
配置文件必须至少包含 1 个 Process 或 1 个 Service 元素。
父元素
Targets。
内容
AnalysisOptions、路径、参数、工作目录、ExcludeImages、名称和主机。

备注

指定目标服务。

示例

以下示例显示了目标元素中使用服务的构造。

<Targets RunInParallel="true">
  <Service CollectData="true" Start="true" RestartIfRunning="true" RestartAtEndOfRun="true">
  <Name>ServiceApp</Name>
  </Service>
</Targets>
父主题： DPAnalysis 配置文件


目标元素

语法

<Targets RunInParallel="true or false">   ...
</Targets>

属性

RunInParallel

可选。 指定 true 或 false。 如果忽略，则默认为 true。 如果您指定多个目标，请定义目标的运行方式。 当 RunInParallel 为 true 时，DPAnalysis 将逐个启动目标进程和服务；多个目标将同时运行（并行）。 否则，DPAnalysis 仅在进程 N 启动和退出后启动目标 N + 1；目标每次运行一个（串行）。

元素信息

发生次数
1.
父元素
RuntimeAnalysis。
内容
进程，服务。

备注

必填。 开始一块一个或多个 <Process> 或 <Service> 条目。 目标进程和服务按其在配置文件中所列的顺序启动。

示例

以下示例显示了使用目标的构造，以指定分析一个 <服务> 和两个 <进程> 元素。 注意，RunInParallel 为 true，因此对于此示例，目标将并行运行。

<Targets RunInParallel="true">
  <Service CollectData="true" Start="true">
    <AnalysisOptions NM_METHOD_GRANULARITY="0" EXCLUDE_SYSTEM_DLLS="1" />
                <Name>ServiceApp</Name>
                <Host>remotemachine</Host>
  </Service>
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>ClientApp.exe</Path>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
  <Process CollectData="true" Spawn="true" NoWaitForCompletion="true">
    <AnalysisOptions NO_MACH5="1" NM_METHOD_GRANULARITY="1" SESSION_DIR="c:\MyDir" />
    <Path>TestApp02.exe</Path>
    <WorkingDirectory>c:\temp</WorkingDirectory>
  </Process>
</Targets>
父主题： DPAnalysis 配置文件


WorkingDirectory 元素

语法

<WorkingDirectory> c:\MyWorkingDir </WorkingDirectory>

属性

无。

元素信息

发生次数
每 Process 或 Service 1 个。
父元素
Process，Service。
内容
目标目录的路径。

备注

可选。 如果忽略，则不使用默认值。 设置目标进程或服务的工作目录。

示例

以下示例显示了使用嵌套在 Process 父元素中的 WorkingDirectory 的构造。

<Process CollectData="true">
<WorkingDirectory>c:\temp</WorkingDirectory>
</Process>
父主题： DPAnalysis 配置文件


为执行计划启用代码分析

要为执行计划启用代码分析：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行树中，选择执行计划。
  3. 单击部署选项卡。
  4. 在部署页面的代码分析设置部分，单击编辑。 此时将显示编辑代码分析设置对话框。
  5. 选中启用代码分析复选框。
  6. 从代码分析配置文件列表框中选择配置文件。
  7. 在主机名文本框中，输入逗号分隔的主机名称列表及端口（如果未使用从中收集代码分析信息的默认端口 19129）。

    例如 labmachine1、labmachine2:8000、198.68.0.1。对于每个执行计划，您需要定义在其中运行 AUT 的机器资源的主机名称。例如，对于客户端/服务器系统，您不仅需要收集有关可能直接在执行服务器上运行的客户端的代码覆盖率信息，而且还要收集可能在其他机器上运行的服务器的相关信息。这适用于所有多层应用程序。

    注： 对于 JUnit 代码分析运行，您无需指定主机名。
  8. 单击确定以保存您的设置。
注： 为执行计划定义代码分析后，以后每次运行执行计划时都会从定义的主机名称收集代码覆盖率信息。在活动页面上监视执行时，您将看到在收集测试的源代码后，Silk Central 将收集完整的代码覆盖率信息，然后再开始运行测试。集成到每个 Silk Central 执行服务器的代码覆盖率控制器可在执行的运行过程中控制所有已定义的主机。对于执行计划的每个测试，控制器将启动和停止所有关联实例、为测试收集基于 XML 的代码覆盖率文件以及将结果合并到单个文件。随后测试会将合并的代码覆盖率文件保存到其执行结果。
父主题： 启用代码分析
相关参考
执行部署页面


代码分析详细信息页面

报告 > 代码分析 > 详细信息

详细信息页面在产品、程序包和类级别显示所选产品、版本和内部版本的代码覆盖率信息。

产品级别视图显示特定产品和产品内部版本的已覆盖和未覆盖程序包。 通过单击产品视图中的程序包名称，您可向下钻取以查看该程序包中所包括类的代码覆盖率信息。

产品视图显示所选产品的以下属性：

属性 | 说明
名称 | 产品名称
语句 | 语句总数
程序包/命名空间 包括以下数字的直方图条形视图：
  • 已覆盖程序包/命名空间的总百分比
  • 已覆盖程序包/命名空间的数量，显示为绿色
  • 未覆盖程序包/命名空间的数量，显示为红色
类 包括以下数字的直方图条形视图：
  • 已覆盖类的总百分比
  • 已覆盖类的数量，显示为绿色
  • 未覆盖类的数量，显示为红色
方法 包括以下数字的直方图条形视图：
  • 已覆盖方法的总百分比
  • 已覆盖方法的数量，显示为绿色
  • 未覆盖方法的数量，显示为红色

程序包级别视图显示特定产品和产品内部版本的已覆盖和未覆盖类。 通过单击程序包视图中的类名称，您可向下钻取以查看该类中所包括方法的代码覆盖率信息。

程序包视图跨多行显示所选产品中每个程序包的属性：

属性 | 说明
程序包 | 程序包名称
语句 | 语句总数
类 包括以下数字的直方图条形视图：
  • 已覆盖类的总百分比
  • 已覆盖类的数量，显示为绿色
  • 未覆盖类的数量，显示为红色
方法 包括以下数字的直方图条形视图：
  • 已覆盖方法的总百分比
  • 已覆盖方法的数量，显示为绿色
  • 未覆盖方法的数量，显示为红色

类级别视图显示特定产品和产品内部版本的已覆盖和未覆盖方法。

类视图跨多行显示每种方法的以下属性：

属性 | 说明
名称 | 方法名称
签名 | 方法签名
语句 | 语句总数
已覆盖 方法的已覆盖状态：
  • True 表示方法已覆盖
  • False 表示方法未覆盖
注： 如果页面包括的元素数量过多，无法在不影响响应时间的情况下一次性显示，这些元素将以递增的方式显示。使用页面底部的导航工具栏可浏览元素。
父主题： 代码分析


最新内部版本和版本

在导航树中选择产品时，将自动显示具有最新覆盖版本（它表示版本的最新覆盖内部版本）的覆盖率信息的程序包和类列表。 在导航树中选择产品版本时，将自动显示版本的最新覆盖内部版本的覆盖率信息。

注： 如果您针对同一内部版本运行多个应用程序，则所有应用程序的覆盖率将合并在一起。
注： Silk Central 目前不支持在多个内部版本间进行代码分析。
父主题： 代码分析


生成代码更改影响报告

要生成代码更改影响报告：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择要为其分析代码覆盖率数据的项目。
  3. 在菜单中，单击报告 > 代码分析。
  4. 单击创建代码更改影响报告。 此时将显示选择报告类对话框。
  5. 如果您要更改预选值，请选择产品和版本。
  6. 在筛选器字段，键入筛选程序包/命名空间的条件。 例如，输入已发布将仅列出其名称中包含字符串已发布的程序包/命名空间。
  7. 从程序包/命名空间列表选择程序包。 使用 Ctrl+单击或 Shift+单击选择多个程序包/命名空间。 所选程序包/命名空间中提供的类将显示在类列表中。
  8. 在类列表中，选择要包括在内作为报告源的类。 使用 Ctrl+单击或 Shift+单击选择多个类。
  9. 单击添加。 所选类已添加到选定的类列表。
  10. 重复前面的步骤，直到将所有需要的类添加到选定的类列表。 您可通过选择条目并单击删除或单击全部删除来从选定的类列表中删除类。
  11. 从选择报告列表中选择报告。
  12. 单击确定可生成报告。
父主题： 代码分析
相关概念
代码更改影响报告
相关参考
选择报告类对话框


选择报告类对话框

报告 > 代码分析 > 创建代码更改影响报告

选择报告类对话框可使您选择作为源包括在代码更改影响报告中的类文件。对话框包括以下元素：

元素 | 说明
产品 | 需要代码分析信息的产品名称。
版本 | 需要代码分析信息的产品版本。
筛选器 | 输入筛选程序包的条件。例如，如果您键入字符串已发布，代码更改影响报告将只显示名称中包含字符串“已发布”的程序包。
程序包/命名空间 | 选定版本中为覆盖率指定的产品程序包/命名空间。
类 | 选定程序包中包括的所有类。
添加 | 单击可添加为代码覆盖率分析选定的类。
选定的类 | 显示已为代码覆盖率分析选定的类。
移除 | 单击可从选定的类列表框中删除选定的类。
全部删除 | 单击可从选定的类列表框中删除所有类。
选择报告 | 代码更改影响报告的类型。
父主题： 代码分析


查看程序包/命名空间的代码覆盖率信息

查看程序包/命名空间的代码覆盖率信息：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择您要查看其代码覆盖率信息的项目：
  3. 在菜单中，单击报告 > 代码分析。
  4. 在代码分析树中，展开导航树中的项目节点，以显示可用于选定项目的产品。
  5. 展开产品节点以显示可用于此产品的版本。
  6. 展开版本节点以显示可用于此版本的内部版本。
  7. 选择特定的内部版本。 选定内部版本的代码覆盖率信息显示在详细信息页面。
注： 要查看所有产品的代码分析信息，请单击工具栏上的显示所有产品。 然后其他项目的产品会列在其他项目节点下。
父主题： 代码分析
相关参考
代码分析详细信息页面


添加 Silk Test Classic AUT 主机

对于运行 Silk Test Classic 测试的执行计划，设置情况可能是 Silk Test Classic 代理位于执行服务器以外的其他计算机上。在此情况下，您可定义 Silk Test Classic 代理的位置，即 Silk Test Classic AUT（测试中的代理）主机名。

将 Silk Test Classic AUT 主机添加到所选执行计划或编辑主机：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要向其分配 Silk Test Classic AUT 主机的执行计划。
  3. 单击部署选项卡。
  4. 在 Silk Test Classic AUT 主机名部分，单击编辑。 将显示编辑 Silk Test Classic AUT 主机名对话框。
  5. 在主机名文本框中，键入运行 Silk Test Classic 代理的计算机的名称。 需要正确配置选项文件。有关命令行选项 -m 的详细信息，请参阅 Silk Test Classic 文档。
  6. 单击确定以将 Silk Test Classic AUT 主机添加到所选执行计划。
父主题： 配置部署环境
父主题： Silk Test Classic 测试
相关概念
指定测试中的代理 (AUT)


配置执行依赖关系

您可通过执行依赖关系配置一个执行计划根据另一个执行计划结果的自动执行。 例如，如果执行计划“A”失败，将自动执行执行计划“B”。

  • 添加依赖执行计划
    添加以另一个执行计划的结果为执行依据的依赖执行计划。
  • 编辑依赖关系
    编辑依赖关系以使依赖执行基于不同条件，或更改依赖执行的部署。
  • 删除依赖关系
    如果应不再根据主执行来执行依赖执行，请删除依赖关系。
  • 执行依赖关系页面
    列出所选执行计划的依赖执行计划和主要执行计划。
父主题： 管理执行计划、文件夹和配置套件


添加依赖执行计划

添加依赖执行计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择将用作主执行计划的执行计划。
  3. 单击依赖关系选项卡。
  4. 单击添加依赖执行计划。 将显示添加依赖执行计划对话框。
  5. 从条件列表，选择触发依赖执行计划的条件。
    • 任何
    • 通过
    • 失败
    • 未执行
    任何状态意味着无论上一个测试执行的状态如何都会触发依赖测试执行。
  6. 从执行计划树选择执行计划。
  7. 指定要部署依赖执行计划的位置。
    选项
    说明
    按照依赖执行计划中的指定
    分配至依赖执行计划的自动测试将在部署页面上为依赖执行计划指定的执行服务器上执行。分配至依赖执行计划的手动测试将分配至部署页面上为依赖执行计划指定的用户。
    与 <所选的执行计划的执行服务器> 相同
    分配至依赖执行计划的自动测试将在部署页面上为主执行计划指定的执行服务器上执行。分配至依赖执行计划的手动测试将分配至部署页面上为主执行计划指定的用户。
    特定：执行服务器/手动测试工程师
    从列表框中选择预先配置的执行服务器和/或手动测试工程师。分配至依赖执行计划的自动测试将在指定的执行服务器上执行。分配至依赖执行计划的手动测试将分配至指定的手动测试工程师。如果只定义特定手动测试工程师而无服务器，则将仅执行手动测试。如果只定义特定执行服务器而无手动测试工程师，则将仅执行自动测试。
  8. 单击确定以创建依赖关系。
    注： Silk Central 将不允许您创建循环执行依赖关系。您可选择手动测试的执行条件。例如，如果所选条件为失败并且所有手动测试均已通过，但部分自动测试失败，则只会执行分配到依赖执行计划的自动测试。
父主题： 配置执行依赖关系


编辑依赖关系

注： 要编辑现有依赖关系，您必须选择主要执行计划，这是将触发执行依赖执行计划的特定条件的定义。您不能从依赖执行计划中编辑依赖关系设置。

要编辑以前配置的依赖关系：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的执行计划。
  3. 单击依赖关系选项卡。
  4. 在依赖执行计划部分，单击 编辑设置 （位于依赖执行计划的操作列中）。 此时将打开编辑依赖关系对话框。
  5. 从条件列表，选择触发依赖执行计划的条件。
    • 任何
    • 通过
    • 失败
    • 未执行
    任何状态意味着无论上一个测试执行的状态如何都会触发依赖测试执行。
  6. 指定要部署依赖执行计划的位置。
    选项
    说明
    按照依赖执行计划中的指定
    分配至依赖执行计划的自动测试将在部署页面上为依赖执行计划指定的执行服务器上执行。分配至依赖执行计划的手动测试将分配至部署页面上为依赖执行计划指定的用户。
    与 <所选的执行计划的执行服务器> 相同
    分配至依赖执行计划的自动测试将在部署页面上为主执行计划指定的执行服务器上执行。分配至依赖执行计划的手动测试将分配至部署页面上为主执行计划指定的用户。
    特定：执行服务器/手动测试工程师
    从列表框中选择预先配置的执行服务器和/或手动测试工程师。分配至依赖执行计划的自动测试将在指定的执行服务器上执行。分配至依赖执行计划的手动测试将分配至指定的手动测试工程师。如果只定义特定手动测试工程师而无服务器，则将仅执行手动测试。如果只定义特定执行服务器而无手动测试工程师，则将仅执行自动测试。
父主题： 配置执行依赖关系


删除依赖关系

要删除依赖关系：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要从中删除依赖关系的主要执行计划。
  3. 单击依赖关系选项卡。
  4. 在依赖执行计划部分，单击 删除 ，这个选项位于依赖执行计划的操作列中。
  5. 单击删除依赖关系对话框上的是以删除依赖关系。
父主题： 配置执行依赖关系


执行依赖关系页面

执行计划 > 详细信息视图 > <执行计划> > 依赖关系
注： 对于分配至测试周期的执行计划，此页面将不会显示。

依赖关系页面列出所选执行计划的依赖执行计划和主要执行计划。

此页面分为两部分。主要执行计划是特定条件为其触发所选执行计划的执行计划。依赖执行计划是所选执行计划导致出现特定条件时将会触发的执行计划。

主要执行计划

对于列表中的每个执行计划，该页面显示以下列：
列 | 说明
名称 | 所选执行计划所依赖的主要执行计划的名称。
条件 | 触发所选执行计划所必须满足的主要执行计划的条件。

依赖执行计划

对于列表中的每个执行计划，该页面显示以下列：
列 | 说明
名称 | 将所选执行计划用作主要计划的依赖执行计划的名称。
条件 | 触发依赖执行计划所必须满足的所选执行计划的条件。
执行服务器/用户 | 在其上运行依赖执行计划的执行服务器，或者如果是手动测试执行，则为执行手动测试的手动测试工程师。
操作 | 可对所选依赖关系执行的操作。编辑设置和删除依赖关系。
父主题： 配置执行依赖关系


已分配的测试

本节介绍如何将测试分配到执行计划。

  • 从网格视图将测试分配到执行计划
    从网格视图将测试添加到执行计划中包括的测试。
  • 手动将测试分配至执行计划
    手动将测试分配至执行计划以将其添加到所包含的测试中。
  • 通过筛选器将测试分配到执行计划
    使用筛选器将测试添加到执行计划中包括的测试。
  • 查找分配至执行计划的测试
    介绍如何在测试树中查找手动分配的测试。
  • 删除测试分配
    当不再需要测试时，从执行计划中删除手动测试分配。
  • 执行已分配的测试页面
    列出已分配至所选执行计划的所有测试。
父主题： 管理执行计划、文件夹和配置套件


从网格视图将测试分配到执行计划

分配至所选执行计划的测试列在已分配的测试页面上。

从网格视图将一个或多个测试分配到一个或多个执行计划：

  1. 在菜单中，单击测试 > 网格视图。
  2. 选择要分配到执行计划的测试。 您可使用 Ctrl+单击或 Shift+单击选择多个测试。
  3. 右键单击所选测试并单击保存所选内容。
  4. 在菜单中，单击执行计划 > 详细信息视图。
  5. 选择您要将所选测试分配至的执行计划。
  6. 单击已分配的测试选项卡。
  7. 单击分配已保存的选定内容。
    注： 只会插入执行计划测试容器中的测试。您可将所选测试插入多个执行计划。但不能将其插入不同项目中的需求。在您做出其他选择或关闭 Silk Central 之前，所选内容仍然保持不变。
父主题： 已分配的测试
相关任务
通过筛选器将测试分配到执行计划
手动将测试分配至执行计划


手动将测试分配至执行计划

分配至所选执行计划的测试列在已分配的测试页面上。

要手动将测试分配至执行计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择您要将所选测试分配至的执行计划。
  3. 单击已分配的测试选项卡。
  4. 单击手动分配选项。 与所选执行关联的测试容器的所有测试都将显示在测试树中。如果您已创建测试筛选器，则可以从测试树上方的筛选器列表中选择它。要创建新的测试筛选器，请在菜单中单击测试，然后在工具栏中单击 [image] （新建筛选器）。
  5. 选择要分配的测试。 您可使用键盘的 Ctrl 和 Shift 键，以通过标准浏览器多选功能选择多个测试。
  6. 将所选内容拖放到已分配的测试区域，或单击任意测试左边的 分配 。 通过分配文件夹或顶层容器，可将父项的所有子测试分配至所选执行计划。
    提示： 右键单击一个节点以进行展开和折叠。
父主题： 已分配的测试
相关任务
从网格视图将测试分配到执行计划
通过筛选器将测试分配到执行计划


通过筛选器将测试分配到执行计划

分配至所选执行计划的测试列在已分配的测试页面上。

您必须使用类别测试创建筛选器才能执行以下步骤。 有关详细信息，请参阅创建筛选器。 或者选择现有筛选器。

使用筛选器将一个或多个测试分配到执行计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要向其分配测试的执行计划。
  3. 单击已分配的测试选项卡。
  4. 单击按筛选器分配选项。
  5. 从列表中选择筛选器。
注： 如果在 测试 > 网格视图 中将测试分配到执行计划，则测试分配类型会自动设置为手动分配，但先前已筛选的测试会留在已分配的测试页面。
父主题： 已分配的测试
相关任务
从网格视图将测试分配到执行计划
手动将测试分配至执行计划
创建筛选器


查找分配至执行计划的测试

要在测试树中查找手动分配的测试：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要查找其已分配测试的执行计划。
  3. 单击已分配的测试选项卡。
  4. 可选：选择手动分配（如果未选择）。
  5. 在测试的操作列中，单击 定位 查找测试存储在哪个测试文件夹或容器内。
相应的父文件夹将在测试树中展开，并且已分配的测试将以蓝色突出显示。
父主题： 已分配的测试


删除测试分配

删除手动分配的测试：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择您要从中删除分配的执行计划。
  3. 单击已分配的测试选项卡。
  4. 在已分配测试的操作列中，单击 删除测试定义分配 或使用 Ctrl+单击或 Shift+单击以选择多个测试，然后按 Del 键。
    提示： 要删除所有已分配的测试，请单击全部删除。
父主题： 已分配的测试


执行已分配的测试页面

执行计划 > 详细信息视图 > <执行元素> > 已分配的测试
注： 对于分配至测试周期的执行计划，此页面将不会显示。

已分配的测试页面列出已分配至所选执行计划或配置套件的所有测试。使用此页面可将其他测试分配至执行计划或配置套件、从执行计划或配置套件中删除测试或更改已分配测试的执行顺序。

如果您已创建测试筛选器，则可以从测试树上方的筛选器列表中选择它。要创建新的测试筛选器，请导航至测试区域并单击工具栏上的新建筛选器。

注： 将立即应用此页面中的所有更改。
注： 当您从配置套件的子元素中访问该页面时，它将为只读。

此页面包含以下项目：

项 | 说明
手动分配 | 单击可手动将测试分配至执行计划或配置套件。
使用树顺序 | 选中可将已分配测试的执行顺序设置为遵循测试区域中的执行顺序。
分配已保存的选定内容 | 单击可从测试 > 网格视图中分配测试选择。
按筛选器分配 | 单击可根据预定义的筛选器自动将测试分配至执行计划或配置套件。可用的筛选器将在列表框中列出。
已分配的测试 | 分配至执行计划或配置套件的测试数。
测试周期的剩余时间 [hh:mm] 当执行计划处于测试周期中时，此字段可用。它表示测试周期的剩余小时数，它等于测试周期的可用时间与所有测试的总计划时间之差。
注： 计划时间仅限于手动测试。
计划时间 执行计划或配置套件中的所有测试的预计执行时间。对于配置套件，计划时间是指套件中所有配置的计划时间的总和。
注： 计划时间仅限于手动测试。
已分配的测试列表 对于每个已分配的测试，此页面将显示以下列：
顺序
测试的执行顺序。取消选中使用树顺序复选框可更改执行顺序。在文本框中单击，键入测试的新顺序，然后按 Enter 以确认所做的更改。每个文本框中的每次更改都必须通过按 Enter 来确认。如果您更改多个测试的顺序，而没有每次都按 Enter，则只有按 Enter 之前的最后一次更改才会生效。
操作
单击手动分配选项按钮时，您可以对已分配的测试执行以下操作：
操作
说明
从列表中删除选定的测试。
在测试树中定位选定的测试。
测试
测试的名称。单击可在测试区域中访问测试。
状态

在执行计划或配置套件的上下文中上次运行测试的状态。如果在执行计划或配置套件上下文的外部执行测试，则所显示的状态将保持不变。如果尚未在执行计划或配置套件的上下文中执行测试，则状态将为不适用。

对于配置套件中包括的测试或测试包，状态是套件中所有配置的所有状态的聚合：
  • 如果测试仅分配给配置套件，则只有测试在所有配置中均为通过时状态才为通过。如果不是所有配置中的状态均为通过，则传播最差运行的状态，且采用以下由上而下的优先级：
    1. 不适用
    2. 未执行
    3. 失败
    4. 通过
    如果一个或多个配置中的测试失败，则分配给测试的需求状态为失败。
  • 我们不建议将测试分配给配置套件，以及一个或多个简单的执行计划。但是在这种情况下，配置状态的聚合是一个状态，而执行计划的上次状态为其他状态。上次执行的状态确定测试的最后状态。
  • 如果测试仅分配给简单的执行计划，则会更新状态来响应上次测试运行的状态。
上次执行
在执行计划或配置套件的上下文中上次运行测试的日期和时间。如果在执行计划或配置套件上下文的外部执行测试，则所显示的时间和日期将保持不变。
计划时间
执行测试的预计时间。
注： 计划时间仅限于手动测试。
测试 | 在测试树中显示可分配至所选执行计划或配置套件的所有测试。双击测试或使用 分配 将测试分配至执行计划或配置套件。有关将测试区域中的多个测试插入执行计划或配置套件的信息，请参阅将测试从网格视图分配至执行计划。
父主题： 已分配的测试
相关任务
从网格视图将测试分配到执行计划


计划

在计划页面中，定义要包括在执行计划、文件夹或配置套件中的测试后，您可以定义要按其执行执行计划、文件夹或配置套件的计划。

三个计划选项可用：
  • 无
  • 全局
  • 自定义
注： 您可以为执行计划、文件夹或配置套件定义计划。如果为文件夹或配置套件定义计划，选定文件夹或配置套件中包括的所有执行计划将按指定计划执行。未分配关键字的所有执行计划、文件夹或配置套件在计划中执行时将得到未执行状态。项目副本或基线组成部分的计划选项设置为无，以防止丢失上次执行状态。有关项目的副本和基线的更多信息，请参阅项目基线和复制项目或项目基线。

确定运行

确定运行可使您定义执行测试的时间，无论是否配置了计划。

  • 创建自定义计划
    在执行计划、文件夹或配置套件需要特殊计划时，创建自定义计划。
  • 指定全局计划
    指定您要据以在执行计划、文件夹或配置套件中运行测试的全局计划。
  • 指定无计划
    在不应根据计划执行测试时，为执行计划、文件夹或配置套件指定“无”计划。
  • 计划排除
    介绍如何使用计划排除。
  • 确定运行
    介绍如何使用确定运行。
  • 计划页面
    使您可为执行计划、文件夹、配置套件和报告订阅定义计划。
父主题： 管理执行计划、文件夹和配置套件
相关概念
配置全局计划
项目基线
相关任务
复制项目或项目基线


创建自定义计划

为所选执行计划、文件夹或配置套件创建自定计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要为其配置自定义计划的执行计划、文件夹或配置套件。
    注： 要将已编辑的全局计划版本另存为自定义计划，请在列表框中选择全局计划的同时单击编辑。这使您能够编辑全局计划并将结果另存为自定义计划。
  3. 单击计划选项卡。
  4. 单击自定义选项可启用计划控件。
  5. 单击编辑。
  6. 单击 编辑 （位于开始字段旁边），并使用日历工具指定执行计划的开始时间和日期。
  7. 指定执行测试的间隔。
  8. 在运行部分中，指定计划的结束时间。 请选择以下选项之一：
    • 单击始终以定义没有结束时间的计划。
    • 单击 n 次。
    • 单击 编辑 （位于直到字段旁边），并使用日历工具指定执行计划的结束时间和日期。
  9. 可选：单击添加排除以定义不应执行计划元素的时间。
  10. 可选：单击添加确定运行以定义应执行未计划执行的时间。
  11. 单击保存以保存您的自定义计划。
父主题： 计划
相关任务
添加排除
添加确定运行


指定全局计划

Silk Central 允许您定义全局计划，可在 Silk Central 中重新使用此计划来计划测试。全局计划可以加快计划测试的进程，因为不再需要针对每个测试定义单个计划，只需为需要特殊计划的测试定义计划即可。

选择在整个 Silk Central 中可用的预定义计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择您要为其配置计划的执行计划、文件夹或配置套件。
  3. 单击计划选项卡。
  4. 单击全局选项按钮。
  5. 从列表框中选择所需的预定义计划。 预定义计划的详细信息在只读日历视图中显示。要将全局计划的编辑版本另存为自定义计划，请单击编辑。
    注： 您可以在管理 > 计划中配置全局计划。
父主题： 计划
相关任务
添加全局计划
编辑全局计划


指定无计划

指定不应为执行计划、文件夹或配置套件定义计划：
  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择您要定义不根据计划执行的执行计划、文件夹或配置套件。
  3. 单击计划选项卡。
  4. 单击无选项按钮。
父主题： 计划


计划排除

计划排除是定期重复的时间段，在此期间会挂起执行操作，例如周计划系统停机时间或周末期间。您可以根据需要向计划添加多个排除。排除可使您定义在此期间不执行测试的工作日和时间间隔，无论是否配置了计划。例如，您可能不希望在周末执行测试。

  • 添加排除
    将排除添加到自定义计划，以防止计划在某个时候运行。
  • 编辑排除
    编辑排除以更改不应执行计划的日期和时间。
  • 删除排除
    如果可在排除的时间执行计划，则可删除排除。
父主题： 计划


添加排除

注： 要编辑全局计划，您必须拥有管理员权限。要定义全局计划的计划排除，请导航到管理 > 计划。

将排除添加到自定义计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要为其添加计划排除的执行计划、文件夹或配置套件。
  3. 单击计划选项卡。
  4. 单击自定义选项可启用计划控件。
  5. 单击添加排除。
  6. 在配置计划排除页面上，选择应抑制测试的工作日。
  7. 定义应在这些工作日抑制执行的特定时间间隔。
  8. 单击确定。 您的排除设置现在将列在计划页面上。
  9. 单击保存将排除添加到当前计划，或继续添加其他排除。
父主题： 计划排除
相关参考
计划页面


编辑排除

要编辑排除：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要为其编辑以前配置的排除的执行计划、文件夹或配置套件。
  3. 单击计划选项卡。
  4. 在排除的操作列中，单击 编辑排除 。
  5. 根据需要编辑排除，然后单击确定。
  6. 单击保存。
父主题： 计划排除
相关参考
计划页面


删除排除

要删除排除：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要为其删除以前配置的排除的执行计划、文件夹或配置套件。
  3. 单击计划选项卡。
  4. 在排除的操作列中，单击 删除 。
父主题： 计划排除
相关参考
计划页面


确定运行

确定运行是指您计划在特定时间运行的执行计划、文件夹或配置套件，它与为执行计划、文件夹或配置套件配置的计划无关。您可以根据需要为计划添加任何数量的确定运行。

  • 添加确定运行
    当您要另外一次性执行已计划的执行计划、文件夹或配置套件时，请将确定运行添加到自定义计划。
  • 编辑确定运行
    编辑确定运行以更改运行的日期和时间。
  • 删除确定运行
    如果不再需要确定运行，则可删除该运行。
父主题： 计划


添加确定运行

注： 要编辑全局计划，您必须拥有管理员权限。要定义全局计划的确定运行，请导航到管理 > 计划。

将确定运行添加到自定义计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要为其添加确定运行的执行计划、文件夹或配置套件。
  3. 单击计划选项卡。
  4. 单击自定义选项可启用计划控件。
  5. 单击添加确定运行。
  6. 在配置确定运行页面上，单击 编辑 ，然后选择确定运行执行计划、文件夹或配置套件的日期和时间。
  7. 单击确定。 您的确定运行设置列在计划页面上。
  8. 单击保存以将确定运行添加到当前计划，或继续添加确定运行。
父主题： 确定运行
相关参考
计划页面


编辑确定运行

要编辑确定运行：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要为其编辑以前配置的确定运行的执行计划、文件夹或配置套件。
  3. 单击计划选项卡。
  4. 在确定运行的操作列中，单击 编辑确定运行 。
  5. 根据需要编辑确定运行条件，然后单击保存。
父主题： 确定运行
相关参考
计划页面


删除确定运行

要删除确定运行：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择要为其删除以前配置的确定运行的执行计划、文件夹或配置套件。
  3. 单击计划选项卡。
  4. 在确定运行的操作列中，单击 删除确定运行 。
父主题： 确定运行
相关参考
计划页面


计划页面

执行计划 > 详细信息视图 > <执行元素> > 计划
注： 对于分配至测试周期的执行计划，此页面将不会显示。

计划页面用于为执行计划、文件夹、配置套件和报告订阅定义计划。

页面提供以下计划类型：

计划类型 | 说明
无 | 单击此选项按钮将使资产不根据计划执行。项目的副本或基线中包含的所有计划最初设置为无。
全局 | 单击此选项按钮可从列表框中为资产选择预定义计划。选择全局计划将包括全局计划中定义的计划排除和确定运行。有关定义全局计划的信息，请参阅本帮助中的管理主题。选择全局计划将在自定义选项按钮下面显示计划详细信息。
自定义 | 单击此选项按钮可为执行计划、文件夹或配置套件定义自定义计划。单击编辑可在以下字段中编辑自定义计划。

对于每个选定的计划类型，页面将显示详细信息。对于自定义计划，详细信息可编辑。

警告：
如果分配给资产的测试未执行，则原因可能是资产因计划提前而继续执行，并且计划间隔比执行的持续时间更短。在这种情况下，可增加计划间隔、提高执行测试的性能或从执行计划中删除测试。要查看应用程序服务器日志文件，请单击管理 > 日志文件中的应用程序服务器日志选项卡。

计划详细信息

页面显示选定计划类型的详细信息，对于自定义计划来说可编辑。
项 | 说明
从 | 指定执行计划开始的时间。单击指定日期旁边的 编辑 可更改日期和时间。
间隔 | 指定执行测试的间隔。
将计划调整到夏令时 选中此复选框可将计划自动调整到夏令时。
注： 夏令时调整仅适用于两小时倍数的间隔，以免在将时间设回一小时的时候重复运行。
运行 指定执行结束的时间：
始终
单击此选项按钮可指定执行一直运行。
次
单击此选项按钮并从列表框中选择数值来定义特定的执行数。
直到
单击此选项按钮可选择测试执行结束的特定时间。单击指定日期旁边的 编辑 可更改日期和时间。
排除 | 为计划定义的排除。要添加排除，请单击添加排除。
确定运行 | 为计划定义的确定运行。要添加确定运行，请单击添加确定运行。单击选定确定运行的操作列中的 编辑 可访问日历工具，并指定确定运行发生的时间。
父主题： 计划


执行分配至执行计划的测试

此部分介绍如何使用 Silk Central 运行分配到执行计划的测试。

您可以运行单个执行计划、文件夹和配置套件。在任何情况下，您都可以定义应执行所有已分配的测试还是仅执行符合特定状态条件的测试。在开始包含自动测试的执行计划后，它将处于中心执行队列中，并且将选择相应的执行服务器，以根据匹配的关键字和服务器可用性来完成测试的自动执行。对于移动设备测试，如果为此执行计划配置了移动设备选择，则会选择设备并保留用于执行。如果没有可用的执行服务器或移动设备，执行作业将保留在队列中，直至有合适的执行服务器和移动设备变得可用为止。

  • 开始执行计划
    执行单个执行计划，以便独立于计划运行它们。
  • 运行对话框
    运行对话框可使您根据筛选条件指定您要执行的测试，并指定测试应运行的产品内部版本。
  • 手动执行自动测试
    如果自动测试因系统组件而失败，或者如果您要验证自动测试的结果，则可以手动执行自动测试。
父主题： 管理执行计划、文件夹和配置套件


开始执行计划

运行与计划无关的执行计划：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您想要执行的项目、执行计划、文件夹或配置套件，或使用 Ctrl+单击或 Shift+单击选择多个元素。
  3. 单击工具栏上的 [image] （运行）。可以为测试周期、测试周期内的执行计划和未分配测试禁用此项。 此时将显示运行对话框。
  4. 定义您要在运行对话框中执行的测试。
  5. 为执行定义测试后，选中转到活动页面复选框可前往活动页面。
父主题： 执行分配至执行计划的测试
相关概念
已分配的测试
相关参考
活动页面
运行对话框


运行对话框

执行计划 > 详细信息视图 > <执行元素> > 运行

执行计划 > 文档视图 > <执行元素> > 运行

运行对话框可使您根据筛选条件指定您要执行的测试，并指定测试应运行的产品内部版本。要打开运行对话框，请选择执行计划或执行文件夹，然后单击工具栏上的运行。

项 | 说明
所有测试 | 选择此选项可执行所有测试。
测试... 选择此选项仅执行符合以下选项之一的测试：
选项
说明
状态为失败
选中可重新执行选定执行计划中状态为失败的所有测试。
状态为“未执行”
选中可重新执行选定执行计划中状态为未执行的所有测试。
未运行内部版本...
选中可重新执行选定内部版本中未执行的所有测试。选定或更高内部版本中执行的测试不会重新执行。
自上次运行后已修复问题的测试 | 选择此选项可仅执行自测试的上次执行后已将问题推进到已修复状态的测试。
设置执行计划的内部版本 | 从设置执行计划的内部版本列表框中选择以前的内部版本，以便对以前的特定内部版本运行测试。此字段默认为当前内部版本。注意，如果执行计划配置为从内部版本信息文件中读取内部版本号，则此选项不可用。如果执行文件夹包含的每个执行计划分配有不同的产品版本，则无法选择内部版本来执行执行文件夹。
运行类型 | 选择按指定运行可运行具有各自测试类型的所有选定测试，或选择手动运行自动测试以手动重新运行所有选定的测试。
转到活动页面 | 为执行定义测试后，选中此复选框可前进到活动页面。
父主题： 执行分配至执行计划的测试
相关概念
执行分配至执行计划的测试


手动执行自动测试

自动测试有时可能因环境问题提供意外结果。 如果在系统进行此类测试失败，并且您要验证该失败是否由系统组件所导致，或者您知道该问题由当前功能失调的系统组件引起，则可以重新手动运行自动测试。

要手动运行自动测试，请执行以下步骤：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您想要执行的项目、执行计划、文件夹或配置套件，或使用 Ctrl+单击或 Shift+单击选择多个元素。
  3. 单击工具栏上的 [image] （运行）。可以为测试周期、测试周期内的执行计划和未分配测试禁用此项。 此时将显示运行对话框。
  4. 定义要执行的测试。
  5. 在运行类型列表框中选择手动运行自动测试。 所有选定的测试随后都被视为手动测试，并且当前运行页面将打开。
父主题： 执行分配至执行计划的测试
相关参考
运行对话框


屏幕捕获

您可以为测试元素或执行计划启用屏幕捕获。屏幕截图被添加到测试运行结果对话框的文件页面和时间线页面的结果文件中。然后您可以分析屏幕截图，例如测试期间是否发生错误。

执行计划的部署页面中的屏幕捕获设置可以替代执行计划中包含的特定测试元素的设置。

  • 启用屏幕捕获
    启用屏幕捕获以将测试的屏幕截图添加到结果文件。
父主题： 管理执行计划、文件夹和配置套件


启用屏幕捕获

要为测试启用屏幕捕获：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择容器、文件夹或测试。
  3. 单击参数选项卡。
  4. 单击添加自定义参数。 此时将打开设置自定义参数对话框。
  5. 在名称文本框中，键入 captureScreen。
  6. 从类型列表框中，选择字符串。
  7. 在值文本框中，键入以下项之一：
    • onError - 如果您希望在执行计划的执行过程中出现错误时将屏幕截图添加到结果文件。
    • 任何其他字符串或无字符串 - 如果您不希望将屏幕截图添加到结果文件。
父主题： 屏幕捕获


视频捕获

您可以为测试元素或执行计划启用视频捕获。将视频作为 WMV 视频文件添加到测试运行结果对话框的文件页面中的结果文件。然后您可以分析视频，例如测试期间是否发生错误。

执行计划部署页面中的视频捕获设置可以替代包括在执行计划中的特定测试元素的设置。

限制：
  • 仅 Microsoft Windows 客户端机器支持视频录制。
  • 在 Microsoft Windows 10 N 和 KN 版本上不支持视频捕获。
  • Windows 7 经典主题不支持 WPF 窗口的视频录制。
  • 不支持录制 4K 分辨率的视频。
注： 要在 Windows Server 2008 执行服务器上使用视频捕获，您需要安装以下服务器功能：
  • Desktop Experience
  • Quality Windows Audio Video Experience
要在 Windows Server 2012 执行服务器上使用视频捕获，您需要安装以下服务器功能：
  • Desktop Experience
  • Media Foundation
注意： 捕获视频的进程要消耗大量 CPU 资源。仅在需要时使用此功能。要使用此功能，您需要具有足够 CPU 功能的系统，例如具有多个 CPU 的系统。

对于 JUnit 4 测试和 Silk Test Classic 计划测试，“现成”支持为套件中的每个测试用例捕获视频。要为其他测试类型使用此功能，请使用 TestCaseStartFinishSocketClient 接口中的方法。有关其他信息，请参阅表示视频捕获的开始和完成。

  • 启用视频捕获
    启用视频捕获以将测试视频添加到结果文件。
父主题： 管理执行计划、文件夹和配置套件
相关概念
为视频捕获表示开始和完成


启用视频捕获

要为测试启用视频捕获：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中，选择容器、文件夹或测试。
  3. 单击参数选项卡。
  4. 单击添加自定义参数。 此时将打开设置自定义参数对话框。
  5. 在名称文本框中，键入 recordVideo。
  6. 从类型列表框中，选择字符串。
  7. 在值文本框中，键入以下项之一：
    • 始终 - 如果您希望在每次执行执行计划时将视频添加到结果文件。
    • onError - 如果您希望在执行计划的执行过程中出现错误时将视频添加到结果文件。
    • 任何其他字符串或无字符串 - 如果您不希望将视频添加到结果文件。
父主题： 视频捕获


自动删除结果和结果文件

定义规则来清理执行计划运行的旧结果和结果文件，以减少数据库大小并提高执行计划运行的可管理性。

执行此任务需要删除执行计划运行权限。

运行执行计划时，收集的结果和结果文件的数量会随着时间而增长。不久以后，某些结果可能不再相关，如果只保留重要信息，管理结果会更加容易。在 Silk Central 中，可以定义规则来自动清理不再需要的结果和结果文件。
  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中选择要配置结果清理规则的节点。所有子节点继承定义的规则。要专门为未分配的测试定义清理规则，请在执行计划树中选择未分配的测试节点。未分配的测试包括上载的 Silk Performer 测试和试运行等项。
  3. 在属性页上的结果清理规则部分中，单击新建规则。 新建结果清理规则对话框随即出现。
  4. 指定规则类型。可以选择只删除结果文件或删除整个运行，后者也包括结果。
  5. 在删除条件列表中，选择在多少时间后，该规则将触发删除。清理规则只在为所选节点存储新结果时触发。
    注： 如果以下某一情况适用，则不会删除运行和结果文件：
    • 包含测试运行，且该测试运行有标记的内部版本
    • 包含测试运行，该测试运行是此测试在这个执行计划中最新的运行
    • 包含未分配的测试，这是此测试的最新运行
    • 只有一个执行计划运行
  6. 如果选择了规则类型删除结果文件，可以在只删除该类型的文件字段中限制只删除特定文件类型的文件。以逗号分隔列表的形式输入文件类型扩展名，如 bmp, png。将此字段留空即删除所有结果文件。
  7. 单击确定。
要更新或移除清理规则，请单击删除或编辑图标。您还可以切换状态来停用清理规则。继承的规则只能在创建这些规则时所在的顶级节点上修改。
父主题： 管理执行计划、文件夹和配置套件
相关任务
删除测试运行结果
删除执行计划的运行和结果文件
相关参考
执行计划属性页面


执行计划视图

Silk Central 提供了多种视图和工具来计划和执行您的测试。

  • 使用执行计划树
    介绍如何使用执行计划树。
  • 执行计划工具栏功能
    提供管理执行计划的重要命令。
  • 执行计划属性页面
    详细说明所选项目、文件夹、执行计划、测试周期或配置套件的所有属性和相关信息。
  • 执行计划文档视图
    为所选项目中的所有执行计划、文件夹和配置套件提供高级只读属性视图。
  • 当前运行页面
    显示与所选执行计划的活动测试运行相关的所有信息。
  • 执行计划历史记录页面
    详细列出选定项目的执行计划历史记录。
父主题： 执行计划


使用执行计划树

执行计划 > 详细信息视图

通过层次树结构执行计划树显示、组织和维护文件夹、执行计划、配置套件和测试周期。您可以在树中使用任意数量的层次级别。

注： 如果页面包括的元素数量过多，无法在不影响响应时间的情况下一次性显示，这些元素将以递增的方式显示。使用页面底部的导航工具栏可浏览元素。
  • 键盘功能（执行计划）
    树提供键盘和多选支持。
  • 展开或折叠执行计划树
    展开和折叠执行计划树以根据查看需要来整合和显示层级级别。
  • 编辑执行计划树的元素
    编辑执行计划树的元素以根据变化的测试需要进行应用。
  • 复制执行计划树的元素
    复制和粘贴执行计划树的元素，以重复使用已分配的测试、筛选器和计划参数。
  • 删除执行计划树的元素
    如果不再需要元素中所含的测试集，则可删除执行计划树的元素。
  • 筛选执行计划树
    介绍如何为执行计划树添加筛选器。
  • 打印已分配的测试
    将已分配的测试打印到 PDF 文档或本地打印机。
  • 测试周期属性页面
    介绍测试周期属性页面。
父主题： 执行计划视图


键盘功能（执行计划）

可对所选节点执行以下操作：

键 | 操作
向上 | 将选定内容上移
向下 | 将选定内容下移
右 | 展开元素
左 | 折叠元素
F2 | 编辑元素
Ctrl+C | 复制元素
Ctrl+X | 剪切元素
Ctrl+V | 粘贴元素
Del | 删除元素
单击 | 选择一个元素并将其标记为当前元素。
Ctrl+单击 | 切换所单击元素的选择状态，通过多次单击添加/删除其他元素。
Shift+单击 | 选择从当前所选元素到新选择元素的范围。
Shift+向上 | 选择上面的元素。
Shift+向下 | 选择下面的元素。
输入 | 分配元素（仅在分配树中）
父主题： 使用执行计划树


展开或折叠执行计划树

您可根据查看需要来整合执行计划树的级别或显示所有层次级别。

要折叠或展开执行计划树的级别：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择执行计划树中的文件夹，然后继续选择以下选项之一：
    • 单击文件夹名称左侧的 展开 可展开文件夹。
    • 单击文件夹名称左侧的 折叠 可折叠文件夹。
    • 右键单击文件夹并选择展开或折叠。
父主题： 使用执行计划树


编辑执行计划树的元素

要编辑现有执行计划元素：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的执行计划、文件夹、测试周期或配置套件。
  3. 在详细信息部分，单击编辑。 此时将显示编辑对话框。
  4. 通过在对话框中修改条件来编辑元素。 对于执行计划，如果没有为执行计划分配运行和测试，则您可以从测试容器列表框中为测试计划选择其他测试容器。
  5. 单击确定以保存编辑过的元素。
父主题： 使用执行计划树
相关任务
创建执行计划
相关参考
执行计划属性页面


复制执行计划树的元素

复制和粘贴执行计划、文件夹或配置套件：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择要复制的元素。
  3. 单击工具栏上的 复制 或右键单击元素并选择复制。
  4. 选择粘贴元素的目标文件夹。
  5. 单击工具栏上的 粘贴 或右键单击目标节点并选择粘贴。 执行计划树将使用已粘贴元素的副本进行更新。 所有已分配的测试、筛选器和计划参数都将与元素一起复制。
父主题： 使用执行计划树


删除执行计划树的元素

要删除执行计划、文件夹或配置套件：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要删除的元素。
  3. 单击工具栏上的 删除 或右键单击元素节点并选择删除。
  4. 单击确认删除对话框上的是以从执行计划树中删除元素。

当删除执行计划树的元素时，也会删除已分配测试的运行结果。 测试运行结果可能仍显示在报告中，因为它们存储在数据库中，在删除元素后不会立即得到更新。

父主题： 使用执行计划树


筛选执行计划树

遵照以下步骤筛选执行计划树，以便仅显示所选节点和子节点。 这在您要将执行计划的子集打印为 PDF 时非常有用。
  1. 创建将定义要查看的执行计划的自定义筛选器。
  2. 选择树视图中的文件夹或配置套件，然后右键单击并选择筛选子树。
父主题： 使用执行计划树


打印已分配的测试

对于执行计划树中的每个执行计划，可以打印相应的文档，文档中包含有关分配到执行计划的所有测试的信息。您可以将此文档打印到 PDF 或本地打印机。

打印分配到执行计划的所有测试的信息：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，右键单击执行计划，然后单击打印已分配测试的详细信息。 此时将出现测试详细信息对话框。
  3. 要将已分配的测试信息打印到本地打印机，请单击打印。要将信息另存为 PDF 文档，请单击下载为 PDF。
父主题： 使用执行计划树


测试周期属性页面

执行计划 > 详细信息视图 > <测试周期> > 属性

当您从执行计划树中选择任何测试周期并单击属性时，将出现测试周期属性页面。

单击编辑属性以显示编辑测试周期对话框，您可在此编辑测试周期的名称、说明和计划时间的位置。

下表显示可用的测试周期属性。

属性 | 说明
测试周期名称 | 测试周期的名称。在编辑测试周期对话框中编辑此值。单击 [image] 可在手动执行计划单元中查找测试周期。
测试周期 ID | 测试周期的唯一 ID。
说明 | 测试周期的说明。在编辑测试周期对话框中编辑此值。
上次运行的状态 | 状态是测试周期的执行计划中所有测试状态上次运行的聚合：通过、失败、未执行或不适用。
上次运行的开始时间 | 上次运行的开始时间。
测试周期开始日期 | 测试周期的计划开始日期。
测试周期结束日期 | 测试周期的计划结束日期。
容量 [hh:mm] | 您预期测试周期花费的时间。在编辑测试周期对话框中编辑此值。 如果您将手动测试工程师分配给测试周期，则容量值是每个手动测试工程师的容量总和。
计划时间 [hh:mm] | 在测试周期的所有已分配执行计划中，所有手动测试的累计计划时间。
剩余时间 [hh:mm] | 这是从容量减去计划时间后剩余的可用时间。
创建于 | 创建测试周期的日期。
创建者 | 创建测试周期的用户。
更改时间 | 上次修改测试周期的日期。
更改者 | 上次修改测试周期的用户。

已分配手动测试工程师

本部分列出了周期中包括的所有手动测试工程师。

属性 | 说明
测试工程师 | 测试工程师的姓名。
容量 | 输入此测试工程师可用于测试周期的时间量（采用 hh:mm 格式）。每个测试工程师的所有容量值的总和为测试周期的容量值。
添加/删除测试工程师 | 单击此项可显示手动测试人员对话框，您可使用此对话框将测试工程师添加到测试周期。
父主题： 使用执行计划树
相关概念
手动执行计划
相关参考
执行计划属性页面
执行运行页面


执行计划工具栏功能

执行计划 > 详细信息视图

执行计划 > 文档视图

执行工具栏可提供管理执行计划的重要命令。

注： 执行计划工具栏中的某些命令也可通过执行计划树中的上下文菜单获取。

执行计划工具栏中包含以下命令：

命令 | 图标 | 说明
详细信息视图 | 需求视图 | 显示详细信息视图，使您可深入了解执行计划树的单个元素的属性。
文档视图 | 文档视图 | 显示文档视图，可在单个视图中显示所有执行的选定属性。
新建子文件夹 | 文档视图 | 添加新的文件夹至所选项目或文件夹。 对于分配至测试周期的执行计划，此命令将被禁用。
新建子测试周期 | 文档视图 | 添加新的测试周期至所选项目或文件夹。
新建子配置套件 | 文档视图 | 添加新的配置套件至所选项目或文件夹。 对于分配至测试周期的执行计划，此命令将被禁用。
新建子执行计划 | 文档视图 | 添加新的执行计划至所选项目、文件夹或配置套件。 对于分配至测试周期的执行计划，此命令将被禁用。
编辑 | 编辑 | 打开执行计划树的选定元素进行编辑。
删除 | 删除 | 删除执行计划树的选定元素。 对于分配至测试周期的执行计划，此命令将被禁用。
剪切 | 剪切 | 剪切执行计划树的某一元素并将其保存至剪贴板。 对于分配至测试周期的执行计划，此命令将被禁用。
复制 | 复制 | 复制执行计划树的某一元素至剪贴板。 对于分配至测试周期的执行计划，此命令将被禁用。
粘贴 | 粘贴 | 粘贴剪贴板上的某一元素至执行计划树。 对于分配至测试周期的执行计划，此命令将被禁用。
粘贴为子项 | 粘贴为子项 | 将剪贴板上的某一元素作为子项粘贴至执行计划树的当前所选元素。 对于分配至测试周期的执行计划，此命令将被禁用。
运行 |  | 启动分配至执行计划的测试执行。 对于分配至测试周期的执行计划，此命令将被禁用。
新建筛选器 | 新建筛选器 | 为执行计划树创建新的自定义筛选器。
筛选器 |  | 列出执行计划树的可用筛选器。
编辑筛选器 | 编辑筛选器 | 编辑当前所选的自定义筛选器。
删除筛选器 | 删除筛选器 | 删除当前所选的自定义筛选器。
复制筛选器 | 删除筛选器 | 复制当前所选的自定义筛选器。
下载为 PDF | 下载为 PDF | 此功能仅在文档视图中可用。 此操作将生成包括执行计划树所有当前可见节点的 PDF。
父主题： 执行计划视图


执行计划属性页面

执行计划 > 详细信息视图 > <执行树元素> > 属性

属性页面提供所有属性的详细信息，以及所选项目、文件夹、执行计划、测试周期或配置套件的相关信息。在此页的每个部分，都有展开和折叠信息的选项。这样您就能根据自己的特定需求，自定义看到的信息。

详细信息

详细信息部分显示有关所选元素的基本信息。有关其他信息，请参阅创建执行计划和编辑执行计划树的元素。

执行状态

执行状态部分显示有关最新运行的信息。上次运行的状态显示文件夹或配置套件的最新运行执行计划的累计测试状态或所有包含的执行计划的累计测试状态。持续时间显示最新运行的执行计划的持续时间。或者，如果是文件夹或配置套件，则显示最新运行的所有包含的执行计划的累计持续时间。举个最简单的案例，对于单个执行服务器上的自动测试或仅手动测试，持续时间是指运行页面上显示的最新运行时间。如果上次执行涉及自动和手动测试，则只会根据在后面执行的测试来考虑自动或手动测试。如果执行计划包含多个测试，则持续时间将为从开始执行第一个测试到完成最后一个测试的时间。这包含在执行之间停止/开始测试所需的额外时间。

有关更多信息，请参阅分析测试运行。

测试执行设置

测试执行设置部分显示有关分配的测试或测试人员的信息。有关其他信息，请参阅管理执行计划文件夹和配置套件以及测试分配。

属性

属性是能应用于执行计划的可自由定义的特征。有关其他信息，请参阅执行计划属性。

参数

参数部分显示有关参数（可自由配置的执行计划输入值）的信息。有关其他信息，请参阅执行计划参数。

通知和报告

通知和报告部分所含的复选框可让您选择是否要根据执行结果收到通知。仅当您的管理员已配置电子邮件服务器时，通知才可工作。您还必须在 <用户名> > 用户设置中指定帐户的电子邮件地址。此外，您还可以根据执行结果触发报告订阅。可用报告列表基于已定义订阅的报告。有关其他信息，请参阅管理报告订阅。

复选框 | 说明
成功完成执行 | 选中可在每次成功完成执行运行时接收通知电子邮件。
执行完成，但未通过测试 | 选中可在每次完成执行且状态为未执行或失败时接收通知电子邮件。
执行完成，但未通过的测试数发生改变 | 选中可在执行完成时与上次运行相比失败或未执行的测试数量每次发生更改时接收通知电子邮件。

结果清理规则

使用结果清理规则部分定义规则来清理执行计划运行的旧结果和结果文件。有关其他信息，请参阅自动删除结果和结果文件。

父主题： 执行计划视图
相关概念
配置测试
相关任务
编辑执行计划树的元素
创建执行计划
自动删除结果和结果文件
管理报告订阅
相关参考
执行运行页面


执行计划文档视图

执行计划 > 文档视图

执行计划区域提供两个执行属性视图：文档视图和详细信息视图。文档视图为所选项目中最新运行的所有执行计划、文件夹和配置套件提供已定义属性和特征的高级只读视图。使用文档视图来计划执行计划的执行。您可以使用筛选器来获取已筛选执行计划子集的执行持续时间预估。

文档视图为执行计划树中的所选元素显示以下列：

列 | 说明
状态 | 文件夹或配置套件的最新运行执行计划的累计测试状态或所有包含的执行计划的累计测试状态。如果对执行计划树应用筛选器，测试状态总数则仅基于已筛选的执行计划。
已分配的测试 | 已分配的测试总数。如果对执行计划树应用筛选器，已分配的测试数则仅基于已筛选的执行计划。
内部版本 | 执行执行计划时使用的内部版本。
版本 | 执行执行计划时使用的版本。
产品 | 已关联的测试容器所基于的产品。
优先级 | 对于自动执行计划，如果多个执行计划在排队等候，但只有一个执行服务器可用，则优先级将确定先执行的执行计划。如果执行服务器可用，但多个执行计划所需的移动设备不可用，情况也是如此。
上次执行 | 上次启动执行计划的时间。
计划时间 | 所有手动测试的总计划时间。如果对执行计划树应用筛选器，计划时间则仅基于已筛选的执行计划。
持续时间 | 最新运行的执行计划的持续时间，或者如果是文件夹或配置套件，最新运行的所有包含的执行计划的累计持续时间。如果对执行计划树应用筛选器，持续时间则仅基于已筛选的执行计划。
下次执行 | 下次安排的执行。
测试容器 | 包含分配至此执行计划的测试容器。
属性 | 如果已将属性分配到执行计划，您可选择在网格中显示属性。属性是能应用于执行计划的可自由定义的特征。您可将属性用于筛选和报告用途。
注： 对于当前显示的所有执行计划，执行计划总数累计到父级别。如果对执行计划树应用筛选器，执行计划总数则仅基于已筛选的执行计划。例如，执行计划总数包括使用筛选器选定的所有子执行计划的执行运行，项目总数包括使用筛选器选定的所有执行计划的执行运行。
父主题： 执行计划视图


当前运行页面

执行计划 > 详细信息视图 > <执行计划> > 当前运行

要访问执行计划的当前运行页面，请在执行计划树中选择执行计划，然后单击当前运行选项卡。当前运行页面显示与所选执行计划的活动测试运行相关的所有信息。手动和自动测试运行显示不同页面。

手动测试运行

当前运行页面显示活动的手动测试运行，直至测试运行完成。对于分配到测试周期的手动测试，此页面将重命名为运行页面。在此情况下，运行页面将在运行完成后继续显示运行。该页面具有两种网格视图，已分配的测试和测试步骤。已分配的测试显示关于活动手动测试运行的信息，而测试步骤显示手动测试中每个步骤的信息。您可在已分配的测试视图中按所选列筛选测试运行。测试详细信息和步骤详细信息视图显示其他信息。

单击重新加载以刷新当前运行页面。如果您更改了执行计划的测试分配，或在测试区域中更新了测试，并且想要在当前运行中体现这些更改，请单击同步当前运行。这样会更新当前运行的所有已分配测试。

如果在当前运行尚未完成时开始其他执行计划运行，系统将显示通知，表明有较新的运行可用。您可在活动页面中查看关于这些运行的信息。

自动测试运行

对于自动测试，当前运行页面将显示执行的进度。单击更新以刷新当前运行页面。对于移动设备上运行的自动测试，单击显示屏幕截图以查看设备上各种活动的实时流。实时流不适用于 Sauce Labs 设备。

父主题： 执行计划视图
相关任务
分配现有问题


执行计划历史记录页面

执行计划 > 详细信息视图 > <项目> > 历史记录

历史记录页面详细列出选定项目的执行计划历史记录。您可显示或隐藏列、调整宽度以及拖动列来更改其顺序。在网格中单击要对内容进行筛选的列。以下操作可生成执行计划历史记录条目：

  • 删除执行计划、文件夹、测试周期、配置套件或配置
注： 如果页面包括的元素数量过多，无法在不影响响应时间的情况下一次性显示，这些元素将以递增的方式显示。使用页面底部的导航工具栏可浏览元素。
父主题： 执行计划视图


使用 Silk Performer 项目

Silk Performer 与 Silk Central 的测试和执行功能完全集成。Silk Performer 项目可以集成到 Silk Central 测试并通过 Silk Central 直接执行。这可实现强大的测试结果分析和报告。它还可启用无人值守的测试，这意味着测试由 Silk Central 根据预配置计划自动运行。

有关配置 Silk Performer 与 Silk Performer 集成的详细信息，请参阅 Silk Central 帮助。

可以在 Silk Performer 的 Silk Performer 中直接打开 Silk Central 项目文件，在此可编辑脚本和设置。随后可将编辑后的 Silk Performer 项目再次登入 Silk Central，以供将来执行测试使用。

注： 术语“项目”在 Silk Performer 中与 Silk Central 中的用法不同。上载到 Silk Performer 的 Silk Central 项目将成为 Silk Central 测试的核心元素。Silk Central 项目是包括多个 Silk Performer 项目、测试、执行计划和需求的高级实体。
  • 下载 Silk Performer 项目
    下载 Silk Performer 项目以独立于 Silk Central 进行处理。
  • 打开Silk Performer 项目
    从 Silk Central 中打开Silk Performer 项目，以在Silk Performer 中进行编辑。
  • 访问执行计划运行属性
    Silk Central 提供 Silk Performer 测试执行期间有关执行计划运行属性的信息。
  • 执行有人值守的 Silk Performer 测试
    执行有人值守的 Silk Performer 测试以在 Silk Performer 中手动执行测试。
  • 编辑 Silk Performer 测试属性
    编辑 Silk Performer 测试属性以根据您的需要应用测试。
  • 分析 Silk Performer 测试结果
    介绍如何分析 Silk Performer 测试结果。
  • 下载 Silk Performer 测试结果包
    下载 Silk Performer 测试结果包以分析测试运行的完整结果集。
  • 上载 Silk Performer 测试结果
    将 Silk Performer 测试结果上载到 Silk Central 以将结果与测试关联。
  • 使用 Silk Performance Explorer
    Silk Performance Explorer 用于深入分析测试运行。
父主题： 执行计划
相关概念
Silk Performer 测试
测试参数
相关任务
创建或编辑 Silk Performer 测试
相关参考
预定义参数
通过 Java 系统属性访问 Silk Central 参数


下载 Silk Performer 项目

打开 Silk Performer 项目可能涉及从源代码管理工具签出 Silk Performer 项目、在 Silk Performer 中编辑项目以及将项目签回 Silk Central，而下载项目则涉及下载项目的副本以及独立于 Silk Central 进行处理。 对已下载项目所做的更改不会自动迁移回 Silk Central。

要下载 Silk Performer 项目：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中选择 Silk Performer 测试。
  3. 单击属性选项卡。
  4. 向下滚动到 Silk Performer 测试属性部分。
  5. 单击 下载项目 。 此时将显示文件下载对话框，要求您确认希望将特定的 Silk Performer 项目下载到本地系统。
  6. 单击保存以在 Silk Performer 中打开文件。 如果尚未在后台打开，将调用 Silk Performer。
  7. 此时将打开选择目标目录对话框，并加载有特定 Silk Performer 项目将保存到的默认目录路径。 如果接受该特定的路径名，请单击确定，否则单击浏览以指定其他路径。
    注： 即使您已配置源代码管理集成，系统也不会提示您从源代码管理系统签出 Silk Performer 项目，因为您将独立于 Silk Central 使用该文件。
    注： 也可以从 Silk Performer 用户界面直接下载由 Silk Central 使用的 Silk Performer 项目。 有关其他信息，请参阅 Silk Performer 文档。
父主题： 使用 Silk Performer 项目


打开Silk Performer 项目

从 Silk Central 中打开 Silk Performer 项目：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中选择 Silk Performer 测试。
  3. 单击属性选项卡。
  4. 向下滚动到 Silk Performer 测试属性部分。
  5. 单击 打开 SilkPerformer 项目 。 此时将显示文件下载对话框，询问您是否要在 Silk Performer 中打开指定的 Silk Performer命令文件 (.spwbcmd)。
  6. 单击打开以在 Silk Performer 中打开文件。如果尚未在后台打开，将调用 Silk Performer。 此时将打开选择目标目录对话框，并加载有特定 Silk Performer 项目将保存到的默认目录路径。
  7. 如果接受该特定的路径名，请单击确定，否则单击浏览以指定其他路径。
  8. 如果您已为 Silk Central 配置源代码管理集成，例如StarTeam，则会提供源代码管理客户端的登录屏幕。输入有效的用户连接设置并单击确定以继续。
    注： Silk Central 利用的Silk Performer 项目也可以从Silk Performer 直接打开。有关其他信息，请参阅 Silk Performer 文档。
父主题： 使用 Silk Performer 项目


访问执行计划运行属性

Silk Central 提供 Silk Performer 测试执行期间有关执行计划运行属性的信息。使用 AttributeGet 方法访问 Silk Performer 脚本中的执行计划运行属性。您可以访问脚本的以下属性：
参数
说明
#sctm_execdef_name
当前执行的执行计划的名称。如果从测试区域触发执行，则参数值是未分配的测试。
#sctm_execdef_id
当前执行的执行计划的数字标识符（数据库密钥）。
#sctm_product
已执行测试容器中定义的产品的名称。
#sctm_version
与执行结果关联的版本的名称。
#sctm_build
与执行结果关联的版本的名称。
#sctm_keywords
用逗号分隔的列表，其中包含为此执行计划定义的关键字。
#sctm_test_results_dir
测试的结果文件所在目录的路径。
#sctm_test_name
正在执行的 Silk Central 测试的名称。
#sctm_test_id
正在执行的测试的数字标识符（数据库密钥）。
#sctm_source_root_dir
测试容器根目录的本地路径，所有受版本控制的文件都驻留在此处。
#external_id
测试包中要执行的测试用例的唯一标识符。如果只应该执行测试包中的特定测试用例，那么可以用作筛选器。

#is_test_package_root
如果为 true，则执行的测试为测试包的根节点（默认）。如果为 false，则只执行测试包中由 #external_id 指定的特定测试用例。
#sctm_data_driven_parent_test_name
如果执行的测试是数据驱动的行，则为父测试的名称。
#sctm_data_driven_parent_test_id
如果执行的测试是数据驱动的行，则为父测试的数字标识符（数据库键）。
父主题： 使用 Silk Performer 项目


执行有人值守的 Silk Performer 测试

有人值守的测试是指可在 Silk Performer 中手动执行的 Silk Performer 测试，它不会根据 Silk Central 中的预定义计划来自动执行。

注： 要将 Silk Central 的数据驱动而是功能与 Silk Performer 脚本配合使用，具有与相应 Silk Performer 项目属性相匹配的列名称的数据源必须与 AttributeGet 方法一起使用（密码属性无法通过，并且始终使用在脚本中指定的值）。

在 Silk Performer 中执行有人值守的测试运行：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中选择 Silk Performer 测试。
  3. 单击属性选项卡。
  4. 向下滚动到 Silk Performer 测试属性部分。
  5. 单击 运行有人值守 。 此时将显示文件下载对话框，询问您是否要运行指定的 Silk Performer 命令文件 (.spwbcmd)。
  6. 单击打开以在 Silk Performer 中打开项目。 如果尚未在后台打开，将调用 Silk Performer。此时将显示选择目标目录对话框，并加载有特定 Silk Performer 项目将保存到的默认目录路径。
  7. 如果接受该特定的路径名，请单击确定，否则单击浏览以指定其他路径。 此时将打开 Silk Performer 工作负载配置对话框，并显示与 Silk Performer 项目关联的所有工作负载设置。
  8. 根据需要编辑工作负载设置，然后单击运行以开始测试并使用 Silk Performer 监视测试结果。
    注： 在不编辑任何工作负载设置的情况下单击运行将会执行 Silk Performer 测试，如同该测试作为无人值守的测试直接从 Silk Central 中执行一样。
父主题： 使用 Silk Performer 项目


编辑 Silk Performer 测试属性

注： 要将 Silk Central 的数据驱动测试功能与 Silk Performer 脚本配合使用，您必须将具有与相应 Silk Performer 项目属性相匹配的列名称的数据源与 AttributeGet 方法一起使用。

要编辑 Silk Performer 测试属性：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中选择 Silk Performer 测试。
  3. 单击属性选项卡。
  4. 向下滚动到 Silk Performer 测试属性部分。
  5. 单击编辑 Silk Performer 测试属性。
  6. 继续配置您的 Silk Performer 测试。
父主题： 使用 Silk Performer 项目


分析 Silk Performer 测试结果

Performance Explorer 能够深入分析 Silk Performer 测试结果。与“下载结果包”相比，分析结果选项只会下载所选结果。为帮助您分析优化工作的结果，您甚至可使用 Performance Explorer 在自定义比较报告中并排比较多个测试运行的统计信息。

使用 Silk Central 运行的测试结果可通过测试区域中运行页面上的命令自动加载到 Performance Explorer。

有关使用 Performance Explorer 以及集成 Silk Performer 与 Silk Central 的完整详情，请参阅 Silk Performer 文档。

在 Performance Explorer 中打开 Silk Performer 测试结果：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择有兴趣查看的测试。
  3. 单击运行选项卡。
  4. 单击要为其下载结果的测试执行的操作列中的 分析结果 。 将显示文件下载对话框，为您显示将要下载的 Performance Explorer 命令文件的名称 .sppecmd。
  5. 单击打开可打开 Performance Explorer 中的结果。另外，您可单击保存来本地保存结果。
  6. 如果尚未在后台打开 Performance Explorer，此时会将其打开（直接连接到您的 Silk Central 安装）并获取所选执行运行的结果。
    注： 要在一个报告中准备比较多个执行结果的自定义比较报告，您可从运行页面下载其他执行的结果。其他执行结果显示在 Silk Central 功能区 Performance Explorer 的现有实例中。有关自定义比较报告的其他详细信息，请参阅 Performance Explorer 文档。
父主题： 使用 Silk Performer 项目


下载 Silk Performer 测试结果包

如果您要分析测试运行的完整结果集，或者要下载完整结果集以进行离线分析，则下载结果包是一个理想选择。 由于结果包通常包含大型 TrueLog On Error 文件，可压缩结果包并将其以 .lrz 文件下载到您的本地硬盘。 如果您使用的 Internet 连接速度较慢，则将结果下载到本地也很有帮助。

要下载 Silk Performer 测试结果：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在测试树中选择 Silk Performer 测试。
  3. 单击运行选项卡。
  4. 在要下载其结果的测试执行的操作列中，单击 下载结果 。 此时将显示文件下载对话框，显示您要下载的压缩结果包文件 .ltz 的名称。
  5. 单击打开可打开 Performance Explorer 中的结果。另外，您可单击保存来本地保存结果。
  6. 如果尚未在后台打开，则将立即打开 Performance Explorer。 此时将显示导入项目对话框，它指定了要将结果保存到的目标目录。 单击确定以接受默认路径，或单击浏览以选择其他路径。 已下载的结果将显示在 Performance Explorer 中。
    注： 如果您接受通常在其中存储结果包的默认项目目录，则该结果将与所有其他 Silk Performer 结果存储在一起，并且可通过 Performance Explorer 添加 Loadtest 结果命令轻松进行访问。
父主题： 使用 Silk Performer 项目


上载 Silk Performer 测试结果

在 Silk Performer 中完成运行有人值守的测试后，您可将测试结果上载到 Silk Central 并将结果与测试关联。

从有人值守的 Silk Performer 测试上载结果：

  1. 运行有人值守的 Silk Performer 测试。 有关其他信息，请参阅执行有人值守的 Silk Performer 测试。
  2. 测试完成后，从结果菜单中选择将结果上载到 Silk Central。 此时将显示将结果上载到 Silk Central 向导的登录屏幕。
  3. 输入密码并单击下一步。
    注： 因为这是有人值守的测试，所以向导已知道这些结果将上载到的测试的相应主机名和用户名。
  4. 如果默认情况下未在项目列表中选择，则选择您要将 Silk Central 结果上载到的 Silk Performer 项目。
  5. 如果默认情况下未在树列表中选择，则选择您要将结果上载到的测试。单击下一步。
    注： 您可以右键单击树，并使用上下文菜单中的命令创建可用于保存结果的新测试、子测试、测试文件夹或子测试文件夹。
  6. 在后续屏幕上，您可以指定上载结果所属的已分配产品的版本和内部版本号。还可指定 Silk Performer 测试结果状态，例如通过和失败。
    注： 如果测试运行期间出现任何错误，默认情况下，测试结果状态被设为失败。
  7. 单击完成以上载结果。 上载的结果显示在测试 > 详细信息视图 > <Silk Performer 测试> > 运行中。
父主题： 使用 Silk Performer 项目
相关任务
执行有人值守的 Silk Performer 测试


使用 Silk Performance Explorer

Silk Performance Explorer（Performance Explorer）用于深入分析测试运行。 Performance Explorer结果分析可通过运行页面上的执行运行，直接从Silk Central的执行区域和测试区域启动，或从 Performance Explorer本身直接启动。 有关 Performance Explorer 与Silk Central集成的详细信息，请参阅 Performance Explorer 文档。

也可将Silk Performer 中加载测试运行的结果上载到Silk Central并与测试关联。 有关更多详细信息，请参阅 Silk Performer 帮助。

有关Silk Central集成与 Silk Performer 集成的其他信息，请参阅 Silk Performer 帮助和 Performance Explorer 用户手册。

父主题： 使用 Silk Performer 项目
相关概念
使用 Silk Performer 项目


Silk Test Classic 测试

本部分介绍如何在 Silk Test Classic 中执行测试。

  • 添加 Silk Test Classic AUT 主机
    当 Silk Test Classic 代理位于执行服务器以外的其他计算机上时，添加 Silk Test Classic AUT 主机。
  • Silk Test Classic 测试的自动执行
    介绍 Silk Test Classic 测试的自动执行。
  • 数据驱动 Silk Test Classic 测试用例的自动执行
    介绍数据驱动 Silk Test Classic 测试用例的执行模式选项。
  • 指定测试中的代理 (AUT)
    介绍如何指定测试中 Silk Test Classic 代理的主机名和端口。
  • Silk Test Classic 超时设置
    有关设置 Silk Test Classic 超时设置的信息。
  • Silk Test Classic 日志
    RMS 日志文件用于在测试运行进行时记录每个测试用例的数据。
父主题： 执行计划
相关概念
Silk Test Classic 测试
相关任务
创建或编辑 Silk Test Classic 测试


Silk Test Classic 测试的自动执行

执行计划中所有测试均使用相同 Silk Test Classic 实例进行测试。 Silk Test Classic GUI 将在第一次执行 Silk Test Classic 测试时打开并在最后一次执行 Silk Test Classic 测试后自动关闭。 每个 Silk Test Classic 测试执行都会产生其自己的结果。 如果 Silk Test Classic GUI 在测试过程中出于任何原因关闭，它将在下一次执行 Silk Test Classic 测试时自动重新打开。

父主题： Silk Test Classic 测试


数据驱动 Silk Test Classic 测试用例的自动执行

如果选中 Silk Test Classic 测试属性中的数据驱动复选框，则每个 Silk Test Classic 测试都将在外部数据源的每个数据行中重复一次。默认情况下，基于计划的执行模式用于数据驱动测试。这意味着所有数据行的结果都将列于 .res 结果文件中的一个节点下方。如果在 SccExecServerBootConf.xml 中将执行模式切换为基于脚本的数据驱动，则将在 .res 结果文件中为每个数据行创建一个结果节点。

父主题： Silk Test Classic 测试


指定测试中的代理 (AUT)

当 Silk Test Classic 代理无法在与运行 Silk Central 执行服务器相同的机器上运行时，例如测试在非 Windows 的平台上运行时，主机名和端口可能由执行计划部署页面中的 Silk Test Classic AUT 主机名设置指定。 如果未定义设置，则使用 Silk Test Classic 默认值，例如从 partner.ini。 AUT 的语法为 hostname:port。 必须在测试执行前手动启动代理并将其配置为在指定端口侦听。 默认情况下，TCP/IP 协议用于 Silk Test Classic 实例和 Silk Test Classic 代理之间的通信。 确保两个程序已配置为使用相同的协议。

注： 将多个执行服务器分配给执行计划时一定要小心，因为 Silk Test Classic 代理一次只能与一个 Silk Test Classic 实例一起工作。
父主题： Silk Test Classic 测试


Silk Test Classic 超时设置

如果您的 Silk Test Classic 测试用例需要 1 小时以上才可完成，则必须在 Silk Central 中调整超时设置。 否则，Silk Central 会假定执行出错并终止 Silk Test Classic。 有关设置 Silk Test Classic 超时的详细信息，请参阅本帮助中的管理主题。

父主题： Silk Test Classic 测试


Silk Test Classic 日志

Silk Test Classic 中的 RMS 日志文件用于在测试运行进行时记录每个测试用例的数据。 有三种类型的数据记录会写入此文件：状态、内存和用户记录。 通过监视此文件，RMS Remote Agent 得以确定每个测试运行的进度。

您可以通过执行 PrintToRMSLog 4Test 功能，将自己的注释写入日志文件的用户记录。

示例：
PrintToRMSLog ("Error", "An intended error")
PrintToRMSLog ("Info", "testcase sleep1 started")
PrintToRMSLog ("Warning", "TestCase 1 started a second time")
rms.inc 中的用户功能定义：
PrintToRMSLog (STRING sMessageType, STRING sUserMessage)
以下列格式写入日志文件：
U|{sTestCaseName}|{sScriptName}|{sArgStr}|{sUserMessage}|{sMessageType}
父主题： Silk Test Classic 测试


问题跟踪和结果分析

分析测试结果，创建和跟踪已发生的问题以及使用报告记录结果。
  • 分析测试运行
    介绍如何使用 Silk Central 分析测试运行。
  • 跟踪
    介绍如何使用跟踪区域。
  • 问题
    此部分介绍如何在 Silk Central 中处理问题。
  • 报告
    介绍如何使用 Silk Central 报告。
父主题： Silk Central 帮助


分析测试运行

本节介绍如何使用 Silk Central 分析测试运行。

  • 分析手动测试结果
    使用手动测试结果视图，提供易于阅读的手动测试结果视图，包括附加问题和附件等所有信息。
  • 分析自动测试结果
    查看执行计划运行的测试结果，以了解高级根本原因分析，或者比较多个运行的结果，实现测试状态区别可视化。
  • 比较多次测试运行的测试结果
    比较一个测试的多次运行的结果以实现测试状态区别可视化。
  • 更改测试运行的状态
    更改特定测试运行的状态，以手动否决运行状态。
  • 查看测试运行详细信息
    查看测试运行的详细信息。
  • 删除测试运行结果
    删除特定测试运行的结果。
  • 删除执行计划的运行和结果文件
    介绍如何删除执行计划、文件夹或项目的运行和结果文件。
  • 执行计划运行结果
    列出执行计划运行的详细信息。
  • 测试运行结果
    列出了测试或执行计划详细信息。
  • 查看数据驱动测试的执行活动
    查看数据驱动测试的执行活动，以了解测试是否正确执行。
  • 执行运行页面
    显示所选执行计划的运行统计信息。
父主题： 问题跟踪和结果分析


分析手动测试结果

如果您的测试运行处于已完成或未完成上下文之中，使用手动测试结果视图可提供易于阅读的手动测试结果视图，其中包括附加问题和附件等所有信息。您可立即看到所有这些信息。还可以打印和下载 PDF 版本。

手动测试结果视图包含左侧的树视图和右侧的详细信息视图。树视图基于在其中打开结果视图的选择的上下文。例如，如果您选择了一个测试周期，则可看到所有已分配的测试工程师及其测试。选择特定节点时，将使用所选内容的恰当信息更新详细信息视图。

几乎在所有查看手动测试的上下文中，您都可以单击测试的查看手动测试结果图标 ( [image]) 来打开手动测试结果视图。此类上下文包括手动执行计划、仪表板面板、活动页面和执行运行网格以及测试运行网格。

父主题： 分析测试运行


分析自动测试结果

查看执行计划运行的测试结果，以了解高级根本原因分析，或者比较多个运行的结果，实现测试状态区别可视化。

测试结果视图和运行比较视图提供了易于读取的结果概览，带有完整的向下钻取功能。其中包含所有信息，例如结果文件、缩略图屏幕快照、消息和堆栈跟踪。这允许您快速分析测试运行失败的根本原因，特别是可以并行比较多次运行的结果。

例如，您可能想要执行以下任务：
  • 分析配置套件或表示多种配置的执行计划内所有配置的运行
  • 比较相同执行计划的多次运行，例如为找到是否有任何测试状态发生了变化
  • 一次性显示一个执行计划的全部失败测试

分析自动测试运行的结果：

  1. 在执行运行网格或活动 > 上次执行网格中，选择一个或多个执行。
  2. 单击查看自动测试结果图标，以分析单个执行的结果，也可右键单击您选择的项目，然后选择比较自动测试结果来比较多次执行。
  3. 单击页面顶端的图标或特定状态图标可以访问详细信息，例如结果文件、缩略图屏幕快照、消息和堆栈跟踪。
    提示： 使用仅显示失败的测试复选框缩小显示结果的范围。
父主题： 分析测试运行


比较多次测试运行的测试结果

比较一个测试的多次运行的结果以实现测试状态区别可视化。

测试结果视图提供完整的向下钻取功能的优化结果概览。其中包含所有信息，例如结果文件、缩略图屏幕快照、消息和堆栈跟踪。这允许您快速分析测试运行失败的根本原因，特别是可以并行比较多次运行的结果。

  1. 在测试运行网格（测试 > 详细信息视图 > <测试> > 运行）中，选择两次或多次运行。
  2. 右键单击您的选择并选择比较自动测试结果以比较多次测试运行。
  3. 单击页面顶端的图标或特定状态图标可以访问详细信息，例如结果文件、缩略图屏幕快照、消息和堆栈跟踪。
    提示： 使用仅显示失败的测试复选框缩小显示结果的范围。
父主题： 分析测试运行
相关参考
测试运行页面


更改测试运行的状态

手动更改测试运行的状态：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的执行计划。
  3. 单击运行选项卡。
  4. 选择执行计划运行。 运行页面的测试部分列出了测试运行。
  5. 单击测试的运行 ID。 将显示测试运行结果对话框。
  6. 单击详细信息选项卡。
  7. 单击更改状态。 将打开更改状态对话框。
  8. 从新状态列表框中选择测试运行的新状态。
  9. 在注释文本框中键入手动状态更改的说明。
    注： 必须插入注释。
  10. 单击确定以确认状态更改。
注： 状态更改会引起历史记录更改。要查看测试运行的所有状态更改历史记录，请单击测试运行结果对话框中的消息选项卡。
父主题： 分析测试运行


查看测试运行详细信息

查看测试运行的详细信息：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择执行计划树中的执行计划。
  3. 单击运行选项卡。
  4. 在底部的测试运行网格中，单击您要查看其详细信息的测试运行 ID。 此时将出现测试运行结果对话框。
  5. 单击详细信息选项卡。
父主题： 分析测试运行


删除测试运行结果

要删除特定测试运行的结果：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中，选择您要编辑的执行计划。
  3. 单击运行选项卡。
  4. 在要删除其结果的测试运行的操作列中，单击 删除运行结果 。
  5. 在随后出现的确认对话框上单击是以完成删除。
父主题： 分析测试运行
相关任务
删除执行计划的运行和结果文件
自动删除结果和结果文件


删除执行计划的运行和结果文件

您可以确定要删除运行（包括结果文件以及所有属于该运行的其他项目和信息）还是仅删除运行的结果文件。结果文件是指在数据库中需要大量存储空间的文件，例如视频或屏幕图像。通过仅删除结果文件，您可以清理数据库并释放存储空间，而同时可保留有关运行的所有基本信息。

要删除运行或结果文件：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 在执行计划树中右键单击执行计划、文件夹、配置套件或项目，然后选择删除运行或结果文件。
  3. 此时将显示删除运行或结果文件对话框。选择要删除的内容：
    • 单击所有运行（包括结果文件）以删除所有运行及全部结果文件。
    • 单击所有运行的结果文件以仅删除结果文件，而不删除运行本身。
  4. 选中从 ... 至 ... 时间范围内以仅删除特定时间周期内的运行或结果文件。
  5. 选中保留上次运行以删除除上次运行以外的所有运行（如果指定了时间范围，则为该时间范围内的所有运行）。
  6. 单击确定。
注： 此操作将不会删除带标记的内部版本的运行。要删除带标记的内部版本的运行，请在管理 > 产品、版本和内部版本 > 产品中取消标记内部版本。
注： 如果要删除多个项目，则从数据库中删除项目时 UI 更新可能会稍微延迟。
注： 如果您右键单击项目节点，删除项目的所有运行或结果文件，所有未分配测试的运行或结果文件都将同时删除。
父主题： 分析测试运行
相关任务
删除测试运行结果
自动删除结果和结果文件


执行计划运行结果

跟踪 > 活动 > 上次执行 > 运行 ID

执行计划运行结果对话框列出执行计划运行的详细信息。

您还可以从执行计划 > 详细信息视图中访问该对话框。选择要查看其详细信息的执行计划，单击运行选项卡，右键单击运行并选择查看详细信息。

该对话框显示有关以下项目的详细信息：

项目 | 说明
执行计划名称 | 执行计划的名称。
执行计划 ID | 执行计划的唯一标识符。
执行计划运行 ID | 执行计划运行的标识符。
开始时间 | 运行开始的时间。
持续时间 | 执行所有包含的测试所花的时间。包括设置和清理测试的持续时间以及提取自动文件和代码覆盖率、启动执行工具和其他任务所花的时间。对于手动执行，此为开始和完成执行之间的时间。
执行服务器 | 分配至执行计划的执行服务器。
警告/错误 | 在运行过程中生成的警告和错误数。
状态 | 在条形图中显示已通过的测试、失败的测试以及未执行的测试。
版本/内部版本 | 为运行指定的产品版本和内部版本。它们由此执行计划的用户设置，或者在执行时从内部版本信息文件中读取。如果内部版本已标记，其会标记为粗体且具有 带标记的内部版本 。
Silk Test Classic AUT 主机名称 | Silk Test Classic AUT（测试中的代理）主机的名称。
安装测试 | 为预期测试准备测试环境的测试。单击测试名称以查看或编辑测试。单击测试运行的 ID 可打开测试运行结果对话框。
清理测试 | 在完成测试后，将测试环境还原为原始状态的测试。单击测试名称以查看或编辑测试。单击测试运行的 ID 可打开测试运行结果对话框。

执行计划运行结果对话框提供有关所含文件和在执行计划运行过程中所生成消息的其他信息。其中还会列出执行计划的所有已分配测试。

对于手动测试，请单击手动测试结果以获取只读版本的当前运行页面，以及有关手动测试的详细信息。

已分配的测试部分列出已分配至此执行计划的所有测试。单击测试名称以查看或编辑测试，或者单击测试的运行 ID 以打开测试运行结果对话框。

父主题： 分析测试运行
相关参考
测试运行结果


测试运行结果

测试运行结果页面列出测试或执行计划详细信息。您可以从以下位置访问此页面：

  • 测试 > 详细信息视图 > <测试> > 运行 > <运行 ID>
  • 执行计划 > 详细信息视图 > <执行计划> > 运行 > <运行 ID>
  • 执行计划 > 详细信息视图 > <执行计划> > 运行 > 测试运行<运行 ID>
  • 跟踪 > 活动 > 上次执行 > <运行 ID> > 已分配的测试 > <运行 ID>

测试运行结果页面显示以下选项卡/部分：

选项卡 | 说明
详细信息

显示运行详细信息，包括其持续时间、执行路径、包括此测试运行的执行计划运行的执行计划运行 ID、任何警告/错误和运行注释（如果向运行添加了注释）。此选项卡还使您可更改测试运行的状态。如果您需要手动否决测试运行的状态，则可使用此选项。

执行手动状态更改时，更改的详细信息反映在此选项卡的状态、状态更改时间、状态更改者、上一个状态和状态更改注释字段中。
时间线

时间线选项卡显示的网格使您可以通过结合以下内容轻松分析测试运行的结果和错误：

  • 测试套件的结构（如果包括失败/错误/警告计数的 output.xml 文件可用）。
  • output.xml 文件中的事件。
  • 日志条目和消息。
  • 结果文件。

条目按时间顺序列出，并且视图包含允许您筛选不同类型项目的复选框。

您也可以通过测试运行网格中的分析结果和分析错误操作访问此选项卡。

注： 此选项卡对除手动测试和 Silk Test Workbench 测试外的所有测试类型显示。
特定 | 仅对 Silk Test Classic、Silk Performer 和手动测试显示。此选项卡包括特定于选定测试类型的详细信息。例如，选择 Silk Test Classic 测试时，此视图包括选定测试用例、测试数据和测试运行期间显示的任何警告。
文件 列出了此运行生成的所有文件及其文件大小。Silk Test Classic .rex 文件的名称充当下载链接。下载文件后，可以在文本编辑器中直接查看。

上表列出了与测试关联的文件，例如结果文件或为手动测试而手动上载的文件。下表列出了与执行计划关联的文件，例如执行日志文件或代码分析结果。

在结果文件的操作列中，单击 删除运行结果 以删除特定结果文件。请注意，部分文件受到保护，无法删除。

单击下载所有文件可使用压缩包的形式下载测试运行生成的所有结果文件。

对于 Silk Test Workbench，单击 result.stwx 文件可在结果文件的上下文中打开 Silk Test Workbench。

对于 Silk Test Workbench，单击 error.png 可在发生回放错误时查看 Visual Test 的最后屏幕截图。
消息

列出了此运行生成的所有消息及其时间戳和严重性。
成功条件 | 仅对自动测试显示。此选项卡显示测试计划进程期间为测试 > 详细信息视图 > <测试> > 属性中的测试定义的所有成功条件，以及执行运行的结果值。成功条件用于确定测试是通过还是失败。
数据驱动 | 仅对数据驱动测试显示，可以选择对数据集中的所有数据行使用单个测试。此选项卡列出了测试的每个实例（数据行）运行的状态。单击实例可打开测试运行结果对话框的其他实例，以及选定实例的运行详细信息。
属性 | 为测试配置的任何属性。
参数 | 为测试配置的任何参数。

下表列出了用于逐步查看执行运行的测试结果的 UI 元素。这些元素仅在从执行计划访问测试运行结果对话框时可见。

项 | 说明
跳过“通过” | 用于确定在使用上一个结果和下一个结果按钮浏览时应显示的测试运行结果。选中此选项仅显示状态不是通过的测试。
<上一个结果?? | 跳转到选定执行计划运行中上一个测试的结果详细信息。
下一个结果> | 跳转到选定执行计划运行中下一个测试的结果详细信息。
父主题： 分析测试运行
相关参考
执行计划运行结果


查看数据驱动测试的执行活动

查看数据驱动测试的执行活动：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 选择基于数据驱动测试的执行计划。
  3. 在菜单中，单击跟踪 > 活动。
  4. 单击相关执行计划的运行 ID。
  5. 在已分配的测试表中，单击数据驱动测试的运行 ID。
    注： 如果您运行多个数据驱动测试，您会在数据源中看到每个数据行有一个测试。
    此时将打开此特殊测试的结果页面。
  6. 单击数据驱动选项卡。您可以在此查看已执行测试的所有实例。
    注： 测试的数据驱动属性列在数据驱动属性表的详细信息页面中。
  7. 单击实例名称以查看此特定实例的测试运行详细信息。
    注： 如果您使用多个数据驱动测试实例，则会为数据源中的每个数据行创建单独的实例。
  8. 单击参数选项卡以查看此特定测试运行期间已使用的数据源值。
父主题： 分析测试运行
相关概念
数据驱动测试


执行运行页面

执行计划 > 详细信息视图 > <执行计划> > 运行

运行页面显示与所选执行计划的所有运行相关的统计信息。

对于配置套件，页面显示所包含的配置的所有运行。

对于测试周期，页面显示所包含的执行计划的所有运行和文件夹。

页面分为两个单独的部分，第一部分列出执行计划运行，第二部分列出在第一部分所选的执行计划运行的测试运行。

网格可进行自定义：您可显示或隐藏列、调整宽度以及拖动列来更改其顺序。在网格中单击要对内容进行排序、分组或筛选的列。

要打开执行计划运行结果对话框，右键单击运行，然后选择视图详细信息。要比较多个执行计划运行，请使用 Ctrl+单击或 Shift+单击来选择两个运行。右键单击所选内容，选择比较自动测试结果。

执行计划运行部分将列出所选执行计划的运行。使用此部分底部的菜单栏来定义每页显示的行数以及浏览各个页面。此页面将显示每个运行的以下列：

列 | 说明
操作 可对执行计划执行的操作。
删除运行
单击可删除此运行的结果。如果删除所选运行的结果，Silk Central 会从运行页面中删除运行。在后台处理完成删除之前，运行将变灰。另外，按下 Delete 可删除测试运行结果。对于带标记的内部版本，您必须确定要删除结果。
查看手动测试结果（仅适用于手动测试）
在手动测试结果页面上单击以分析一项手动测试运行的结果。
查看自动测试结果（仅适用于自动测试）
在测试结果页面上单击以分析一项自动测试运行的结果。
ID | 执行计划的标识符。
执行计划 | 已执行的执行计划名称。此列仅针对配置套件显示。
状态 | 运行的状态摘要。一个条形将列出通过、失败和未执行测试的数目。每个已分配测试的运行状态在页面的第二部分显示。
运行 ID | 执行计划运行的标识符。单击可访问运行的结果。
关键字 | 分配至执行计划的关键字。
执行者 | 执行运行的执行服务器名称。对于手动测试，将列出执行运行的用户名称。
产品 | 正在测试的应用程序。
版本 | 此版本可由此执行计划的用户设置，或在执行时通过内部版本信息读取。此信息可在管理 > 产品、版本和内部版本 > 产品中设置。
内部版本 | 此内部版本可由此执行计划的用户设置，或在执行时通过内部版本信息读取。此信息可在管理 > 产品、版本和内部版本 > 产品中设置。如果内部版本已标记，其会标记为粗体且具有 带标记的内部版本 。
开始时间 | 开始运行的时间。
持续时间 | 执行所有包含的测试所花的时间。包括设置和清理测试的持续时间以及提取自动文件和代码覆盖率、启动执行工具和其他任务所花的时间。对于手动执行，此为开始和完成执行之间的时间。
开始类型 | 显示测试运行的开始方式。手动、通过 Web 服务或通过计划。
开始程序名称 | 开始执行的计划、测试工程师或 Web 服务用户的名称。
开始范围 | 运行对话框中指定的范围。
执行计划父项 | 父级执行计划的名称。
运行注释 | 您可使用此列来为运行添加信息。要编辑注释，右键单击运行，然后选择编辑运行注释。
移动设备选择 | 部署页面上指定的设备筛选器（如果执行计划配置为在移动设备上运行）。
已使用的设备 | 与设备筛选器匹配且实际用来执行测试的设备（如果执行计划配置为在移动设备上运行）。对于手动测试，将显示在此执行计划中测试工程师上次选择的设备。
如果已将属性分配到执行计划，您可选择在网格中显示属性。属性是能应用于执行计划的可自由定义的特征。您可将属性用于筛选和报告用途。

测试运行部分将列出所选执行计划运行的测试运行。使用此部分底部的菜单栏来定义每页显示的行数以及浏览各个页面。此页面将显示每个运行的以下列：

列 | 说明
操作 可以对测试运行执行的操作。
查看或下载结果
如果运行所属的测试为可生成结果文件的测试类型，单击图标可查看或下载结果文件。
新问题
单击可打开新问题对话框，并为测试创建新问题。
分配现有问题
将问题从外部配置的问题跟踪系统分配到测试。
查看手动测试结果
单击可以只读模式查看当前运行页面。
状态 | 运行的状态摘要。对于单个测试，显示为单个状态。栏将列出测试包或套件节点的通过、失败和未执行测试的数目。
状态原因 | 特定测试运行状态为通过、失败或未执行的原因。
运行 ID | 测试运行的标识符。单击可打开测试运行结果对话框。
ID | 测试的标识符。此列默认为隐藏。
测试 | 测试的名称。单击可访问测试 > 详细信息试图中的测试。此图标对应测试类型。
版本 | 执行运行所依据的版本。
开始时间 | 运行开始的日期和时间。
持续时间 | 测试运行的持续时间。
执行者 | 执行运行的执行服务器名称。对于手动测试，将列出执行运行的用户名称。
发现的问题 | 显示分配给测试运行的问题数。当未向测试运行分配问题时，列为空。单击链接可访问测试 > 详细信息视图的问题页面中的问题。
错误 | 运行中发生的错误数。
警告 | 运行中发生的警告数。
内部版本 | 执行运行所依据的内部版本。
运行注释 | 对于 Silk Performer 测试运行，Silk Performer 在上载结果时使用此列将信息添加到测试运行。对于所有其他测试类型，您可以使用此列将信息添加到运行。要编辑注释，右键单击运行，然后选择编辑运行注释。
父主题： 分析测试运行
相关概念
执行计划运行比较报告
相关任务
分配现有问题
相关参考
活动页面
测试运行结果


跟踪

跟踪区域提供项目级信息，包括活动、跨项目活动、项目概述报告和质量目标。

  • 活动
    本节介绍如何管理即将执行、当前执行和最近执行的测试运行。
  • 项目概述报告
    提供了选定项目状态的高级概述。
  • Silk Central、基于风险的测试和质量目标
    介绍 Silk Central 如何支持基于风险的测试。
父主题： 问题跟踪和结果分析


活动

本节介绍如何管理即将执行、当前执行和最近执行的测试运行。

  • 删除上次执行运行
    删除运行结果以从上次执行列表中删除运行。
  • 在活动页面上显示或隐藏列
    选中或取消选中相应的复选框以在活动页面上显示或隐藏列。
  • 在活动页面上输入问题
    如果您在运行测试执行的过程中发现问题，可以直接在活动页面上输入问题。
  • 在活动页面筛选测试运行
    介绍如何在活动页面筛选测试结果和执行计划。
  • 在活动页面分组测试运行
    介绍如何分组执行计划或测试结果，以简化在活动页面上的查看。
  • 删除活动筛选器
    删除应用到活动页面上的列的筛选器以查看所有列。
  • 在活动页面上对列重新排序
    在活动页面上对列重新排序，以自定义活动项目的显示。
  • 调整活动页面上列的大小
    更改活动页面上列的宽度，以自定义活动项目的显示。
  • 还原默认活动页面视图设置
    还原活动页面上的默认视图设置，以重置所有用户定义的设置。
  • 在活动页面上对测试运行排序
    在活动页面上对测试运行排序，以自定义活动项目的显示。
  • 活动页面
    提供了一个集中位置，您可从该位置对项目的即将执行、当前执行和最近执行的测试运行进行管理。
  • 跨项目活动页面
    授予用户“超级用户”权限，以查看跨项目的所有执行相关活动。
父主题： 跟踪
相关概念
执行计划
相关参考
跨项目活动页面


删除上次执行运行

要从上次执行列表中删除运行：

  1. 在菜单中，单击跟踪 > 活动。
  2. 在活动页面的上次执行区域中，右键单击要删除的测试运行，然后选择删除运行结果。
  3. 通过单击确定确认删除。
父主题： 活动


在活动页面上显示或隐藏列

要在活动页面上显示或隐藏列：

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开列标题的上下文菜单。
  3. 展开列子菜单以查看项目中可用的所有列。
  4. 选中要显示的所有列的复选框。 当您每次打开活动项目时，都会保存和显示列显示首选项。
父主题： 活动


在活动页面上输入问题

可以直接在活动页面上输入新问题。

要在活动页面上输入问题：

  1. 在菜单中，单击跟踪 > 活动。
  2. 在上次执行区域中，单击相关执行计划的运行 ID，以查看测试执行结果。 与执行运行关联的每个测试都将在视图下部的已分配的测试表中列出。
  3. 在要与问题关联的测试的操作列中，单击新建问题。
  4. 继续定义问题。
父主题： 活动


在活动页面筛选测试运行

您可根据列的值在活动页面上筛选视图。您可指定要应用的筛选字符串：

  • 基于文本的数据字段。
  • 基于日期的字段的日历筛选器（使用之前、之后或当天运算符）。
  • 数据运算符（>、< 和 =），用于基于数字的字段。
  • 在活动页面筛选基于文本的值
    在活动页面筛选基于文本的值可显示与筛选器条件匹配的所有条目。
  • 在活动页面筛选基于日期的值
    在活动页面筛选基于日期的值可显示与筛选器条件匹配的所有条目。
  • 在活动页面筛选基于数字的值
    在活动页面筛选基于数字的值可显示与筛选器条件匹配的所有条目。
  • 在活动页面筛选布尔值
    在活动页面筛选基于布尔值的值，可显示与筛选器条件匹配的所有条目。
  • 使用活动页面上的预定义列表筛选值
    使用活动页面的预定义列表筛选值可显示与筛选器条件匹配的所有条目。
父主题： 活动
相关概念
筛选器


在活动页面筛选基于文本的值

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开基于文本且要作为筛选器依据的列的列标题上下文菜单。
  3. 展开上下文菜单中的筛选器子菜单，以显示筛选器文本框。
  4. 将文本字符串输入文本框中。
  5. 按下 Enter。 与筛选器条件匹配的所有条目将动态显示在已筛选列表中。
父主题： 在活动页面筛选测试运行


在活动页面筛选基于日期的值

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开基于日期且要作为筛选器依据的列的列标题上下文菜单。
  3. 将光标停留在上下文菜单的筛选器上可显示之前、之后或当天子菜单。
  4. 从以下项选择：
    1. 将光标保持在之后上可定义应该排除其之前（并包括该日期）的所有条目的日期。
    2. 将光标保持在之前上可定义应该排除其之后（并包括该日期）的所有条目的日期。
    3. 将光标停留在当天上可排除具有指定日期的条目之外的所有条目。
    此时将显示日历工具。
  5. 使用日历工具选择日期（或单击今天来指定为当天日期）。
    提示： 您必须明确单击日历工具上的日期，或按输入来激活基于日期的筛选更改。
    与筛选器条件匹配的所有条目将动态显示在已筛选列表中。
父主题： 在活动页面筛选测试运行


在活动页面筛选基于数字的值

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开基于数字且要作为筛选器依据的列的列标题上下文菜单。
  3. 展开上下文菜单上的筛选器子菜单，以显示 >（大于）、<（小于）和 =（等于）运算符。
  4. 从以下项选择：
    1. 在 > 文本框中输入一个数字，以定义一个数字，小于（或等于）该数字的所有条目都应排除。
    2. 在 < 文本框中输入一个数字，以定义一个数字，大于（或等于）该数字的所有条目都应排除。
    3. 在 = 文本框中输入一个数字，以排除具有指定数字的条目之外的所有条目。
    注： 数字值舍入到两位小数。
  5. 按下 Enter。 与筛选器条件匹配的所有条目将动态显示在已筛选列表中。
父主题： 在活动页面筛选测试运行


在活动页面筛选布尔值

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开基于布尔值且要作为筛选器依据的列的列标题上下文菜单。
  3. 展开上下文菜单中的筛选器子菜单，以显示可用值。
  4. 单击是或否选项按钮。 与筛选器条件匹配的所有条目将动态显示在已筛选列表中。
父主题： 在活动页面筛选测试运行


使用活动页面上的预定义列表筛选值

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开以下列的列标题上下文菜单：该列有要作为筛选器依据的预定义筛选器值。
  3. 展开上下文菜单中的筛选器子菜单，以显示筛选器文本框。
  4. 选中要使用的筛选器值的复选框。 此时将显示具有所选条件之一的所有条目。
父主题： 在活动页面筛选测试运行


在活动页面分组测试运行

除了简单地按列分类外，您可将条目分块至组以便查看。组基于作为分组依据的列中的通用共享值。

  • 在活动页面上将组应用到测试运行
    在活动页面上对执行计划或测试结果进行分组，以便于查看。
  • 在活动页面上删除测试运行分组
    在活动页面上删除测试运行分组，以查看单个列表中的所有测试运行。
父主题： 活动


在活动页面上将组应用到测试运行

在活动页面上对条目进行分组：

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开要排序依据列的列标题的上下文菜单。
  3. 选择按此字段分组。

    然后，将根据所选列中经常共享的值对条目进行分组。

父主题： 在活动页面分组测试运行


在活动页面上删除测试运行分组

删除分组：

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开任何列标题的上下文菜单。
  3. 取消选中按组显示复选框。
父主题： 在活动页面分组测试运行


删除活动筛选器

注： 隐藏列将删除应用到该列的所有筛选器。

删除一个或多个筛选器：

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开含有要删除的筛选器的列的列标题上下文菜单。
    注： 您可以按标题识别筛选的列，这些标题以粗体和倾斜文本显示。
  3. 请执行以下操作之一：
    1. 要删除特定筛选器：取消选中筛选器复选框。
    2. 要删除所有筛选器：请选择重置筛选器。
父主题： 活动
相关概念
筛选器


在活动页面上对列重新排序

在活动页面上对列重新排序：

  1. 在菜单中，单击跟踪 > 活动。
  2. 选择您要移动的列的列标题。
  3. 将列拖到所需位置，然后将其释放。

    将保存您的列顺序首选项，每次打开活动项目时将按此显示。

父主题： 活动


调整活动页面上列的大小

调整活动页面上列的宽度：

  1. 在菜单中，单击跟踪 > 活动。
  2. 选择您要调整的列的垂直列标题分隔线。
  3. 将列边界拖到所需位置，然后将其释放。

    将保存您的列宽首选项，每次打开活动项目时将按此显示。

父主题： 活动


还原默认活动页面视图设置

还原默认视图设置将重置当前项目的所有用户定义的设置，即列顺序、列宽度、显示/隐藏列、应用筛选器、排序和分组。

还原默认视图设置：

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开任何列标题的上下文菜单。
  3. 选择重置视图。
父主题： 活动


在活动页面上对测试运行排序

在活动页面上对测试运行排序：

  1. 在菜单中，单击跟踪 > 活动。
  2. 打开要作为测试运行排序依据的列的列标题上下文菜单。
  3. 选择升序排序将按升序对测试运行排序，或选择降序排序按降序对测试运行排序。 将保存您的排序首选项，每次打开活动项目时将按此显示。
父主题： 活动


活动页面

跟踪 > 活动

活动页面提供了一个集中位置，您可从该位置对项目的即将执行、当前执行和最近执行的测试运行进行管理。活动页面上的网格视图提供了每位用户可单独配置的筛选、排序和分组选项。您可使用点击和拖动操作显示或隐藏列、调整列宽和移动列。

活动页面分为三部分：下次执行、当前执行和上次执行。可通过拖动视图之间的分隔符来调整网格视图大小。

上下文相关菜单命令适用于每个测试运行。您可使用这些命令直接链接到所列的执行计划、继续手动测试、管理测试运行结果等。

您可通过活动页面更轻松地确定执行计划之间的匹配点和查找特定执行计划信息。标准 Windows 键盘快捷键可用于选择测试运行条目，因此可轻松选择和操作特定执行计划组及测试结果。排序、分组和筛选功能通过上下文菜单命令提供，以帮助您更好地对测试运行进行组织和分组。您的所有视图自定义首选项都与项目一起保存，并可在您每次访问活动页面时使用。

注： 活动页面上的数据不会自动刷新。单击每个视图下部的分页按钮旁边的重新加载可刷新页面内容。
注： 您可使用 Ctrl+单击 选择多个已排队的执行，然后通过一次单击全部放弃。

下次执行

下次执行视图列出了计划在未来运行的执行计划。为了提高性能，当您拥有多个执行计划时，仅显示即将运行的 50 个执行计划。您可使用可用的筛选功能访问其他未来执行计划。要编辑执行计划，请右键单击执行计划并选择转到执行计划或单击执行计划名称左侧的箭头。此操作会将您带到执行区域，您可在此区域查看和编辑执行计划的详细信息。

默认情况下，所有执行计划都按开始时间进行排序。下次执行视图中的列不能进行排序或分组。

下次执行视图可通过单击视图标题栏右侧的双箭头按钮进行折叠和展开。

对于每个执行计划，下次执行视图会显示以下列：

列 | 说明
ID | 已计划执行计划的标识符。此列默认为隐藏。
执行计划/文件夹 | 已计划执行计划或文件夹的名称。
关键字 | 分配到已计划执行计划的关键字。
手动测试工程师 | 对于手动测试，此列包含分配到测试的手动测试工程师的名称。未向测试分配任何手动测试工程师时，此列为空。
优先级 | 已分配到执行计划的优先级。
开始时间 | 测试运行的计划开始时间。
执行计划父项 | 执行计划在其中执行的上下文中的配置套件、文件夹或测试周期。 单击可访问执行计划树中的套件或文件夹。 如果配置套件或文件夹中未包含执行计划，则不显示任何内容。

当前执行

当前执行视图列出了当前运行的执行计划（自动和手动测试运行）。

要中止当前正在进行的执行计划，请单击执行计划的操作列中的中止。要查看或编辑执行计划，请右键单击执行计划并选择转到执行计划或单击执行计划名称左侧的箭头。要查看执行的进度，请右键单击自动执行计划并选择查看详细信息或单击执行计划的运行 ID/任务 ID 链接。对于移动设备上运行的自动测试，详细信息视图还支持查看设备上各种活动的实时流。实时流不适用于 Sauce Labs 设备。

只要某个手动测试仍处于打开状态，当前执行列表中其余的相应执行计划将处于待定状态。单击操作列中的继续手动测试，以打开手动测试窗口。

要查看手动测试结果，请右键单击手动执行计划并选择查看详细信息，或单击执行计划的运行 ID/任务 ID 链接，以打开执行计划结果页面。在此页面中，单击已分配的测试部分中的手动测试名称，以打开结果对话框。手动测试的详细结果将显示于此。返回执行计划结果页面，单击手动测试结果以转到手动测试视图，您可在此获得有关已分配手动测试的状态的信息。

当前执行的页面视图分为各自包含 20 个执行计划的多个视图。您可使用位于当前执行视图下部的第一个、最后一个、下一个和上一个浏览各页面。或者，您也可在页面文本框中键入页码，然后按 Enter。

对于每个执行计划，当前执行视图会显示以下列：

列 | 说明
操作 您可对执行计划执行以下操作：
中止
单击以取消当前执行。或者按删除。当您中止执行时，这些执行会呈灰色，直至后台处理完成删除。
注： 如果执行是测试周期的一部分，将禁用中止操作。上下文菜单中的 [image] 图标和条目将呈灰色，并且会在您中止多个运行时忽略此类运行。
继续手动测试
单击以打开手动测试窗口。
查看手动测试结果
单击可以只读模式查看当前运行页面。
ID | 执行计划的标识符。此列默认为隐藏。
执行计划 | 执行计划的名称。
运行 ID/任务 ID | 手动测试在执行期间会收到运行 ID。手动测试完成时，运行 ID 会传递到上次执行视图。自动测试在执行期间会收到任务 ID。任务 ID 不会传递到上次执行视图。已完成的执行计划会在上次执行视图中收到运行 ID。
状态 | 活动执行计划或手动测试的状态。对于自动测试，使用基于文本的值表示状态。对于手动测试，使用彩色直方图表示状态。自动测试状态使用文本描述并可进行筛选。手动测试可通过选中筛选器子菜单上的相关属性进行筛选。
关键字 | 分配到执行计划的关键字。
执行者
  • 对于手动测试，此列显示被分配执行手动测试的用户。未向测试分配任何手动测试工程师时，此列为空。
  • 对于自动执行，此列显示执行服务器的名称。
优先级 | 对于自动执行计划，如果多个执行计划在排队等候，但只有一个执行服务器可用，则优先级将确定先执行的执行计划。如果执行服务器可用，但多个执行计划所需的移动设备不可用，情况也是如此。
开始时间 | 执行计划运行开始的时间。
剩余时间 | 测试完成之前剩余的时间。对于没有预计时间的手动测试，此列的值为未知。
开始类型 显示测试运行的开始方式。
  • 手动
  • 通过 Web 服务
  • 通过计划
  • 通过依赖关系
开始程序名称 | 开始执行的计划、测试工程师或 Web 服务用户的名称。
开始范围 | 运行对话框中定义的范围。
执行计划父项 | 执行计划在其中执行的上下文中的配置套件、文件夹或测试周期。 单击可访问执行计划树中的套件或文件夹。 如果配置套件或文件夹中未包含执行计划，则不显示任何内容。
如果已将属性分配到执行计划，您可选择在网格中显示属性。属性是能应用于执行计划的可自由定义的特征。您可将属性用于筛选和报告用途。

上次执行

上次执行视图列出以前的所有执行计划运行。此列表可以筛选和排序，例如按照开始时间筛选和排序。

要查看或编辑执行计划，请右键单击执行计划运行并选择转到执行计划，或单击执行计划名称左侧的箭头。要显示执行计划运行的执行计划结果页面，请右键单击运行并选择查看详细信息，或单击执行计划的运行 ID 链接。此页面显示所选执行计划运行的详细信息，并包括执行期间生成的任何文件和消息。要打开测试的结果对话框，请单击测试的运行 ID（位于执行结果页面的已分配的测试部分）。

要比较执行计划运行，请使用 Ctrl+单击 选择多个运行。右键单击所选项，然后单击比较自动测试结果执行自动测试， 或者单击报告 > 运行比较...执行手动测试。

右键单击执行计划，然后单击运行执行计划以运行执行计划。Silk Central 考虑当前分配至执行计划的所有测试，而不是选定执行计划运行最初分配的测试。

要删除执行计划运行，请右键单击运行条目并选择删除结果或单击运行的操作列中的删除。

测试结果页面视图分为各自包含 20 个测试结果的多个视图。您可使用位于上次执行视图底部的第一个、最后一个、下一个、上一个浏览各页面。或者，您也可在页面文本框中键入页码，然后按 Enter。

上次执行视图可通过单击视图标题栏右侧的双箭头按钮进行折叠/展开。

对于每个执行计划，下次执行视图会显示以下列：

列 | 说明
操作 您可对执行计划执行以下操作：
删除
单击以删除执行计划运行结果。当您删除执行时，这些执行会呈灰色，直至后台处理完成删除。或者，按删除以删除执行计划运行。对于带标记的内部版本，您必须确定要删除结果。
查看手动测试结果
单击可以只读模式查看当前运行页面。
ID | 已执行执行计划的标识符。未分配的测试的 ID 值为 N/A。此列默认为隐藏。
执行计划 | 已执行执行计划的名称。单击名称旁边的按钮，以在执行计划单元中查看执行计划。
运行 ID | 分配到测试运行的 ID。单击链接以查看测试运行的详细信息。
状态 | 在条形图中显示已通过的测试、失败的测试以及未执行的测试。筛选、排序和分组不适用于此列。
关键字 | 在执行时分配到执行计划的关键字。
执行者
  • 对于手动测试，此列显示被分配执行手动测试的用户。未向测试分配任何手动测试工程师时，此列为空。
  • 对于自动执行，此列显示执行服务器的名称。
开始时间 | 执行计划运行开始的时间。
持续时间 | 执行所有包含的测试所花的时间。包括设置和清理测试的持续时间以及提取自动文件和代码覆盖率、启动执行工具和其他任务所花的时间。对于手动执行，此为开始和完成执行之间的时间。
产品 | 测试中的产品。此列默认为隐藏。
版本 | 版本由此执行计划的用户设置，或在执行时从内部版本信息文件读取。此列默认为隐藏。
内部版本 | 内部版本由此执行计划的用户设置，或在执行时从内部版本信息文件读取。如果内部版本已标记，其会标记为粗体且具有 带标记的内部版本 。
开始类型 | 显示测试运行的开始方式。手动、通过 Web 服务或通过计划。
开始程序名称 | 开始执行的计划、测试工程师或 Web 服务用户的名称。
开始范围 | 运行对话框中定义的范围。
执行计划父项 | 执行计划在其中执行的上下文中的配置套件、文件夹或测试周期。 单击可访问执行计划树中的套件或文件夹。 如果配置套件或文件夹中未包含执行计划，则不显示任何内容。
移动设备选择 | 部署页面上指定的设备筛选器（如果执行计划配置为在移动设备上运行）。
已使用的设备 | 与设备筛选器匹配且实际用来执行测试的设备（如果执行计划配置为在移动设备上运行）。对于手动测试，将显示在此执行计划中测试工程师上次选择的设备。
如果已将属性分配到执行计划，您可选择在网格中显示属性。属性是能应用于执行计划的可自由定义的特征。您可将属性用于筛选和报告用途。
父主题： 活动


跨项目活动页面

跟踪 > 跨项目活动

跨项目活动页面可授予用户“超级用户”权限，以查看跨项目的所有执行相关活动。它还提供了活动页面提供的所有选项以及其他跨项目选项。这允许对执行队列做出结论。超级用户可从队列中删除执行以解决瓶颈问题。

跨项目活动仅对超级用户可见。该页面分成与活动页面相同的三个部分：下次执行、当前执行和上次执行。所有这三个部分还包括一个具有项目 ID 的列。

项目 | 说明
项目 ID | 执行计划所属项目的 ID。
父主题： 活动


项目概述报告

Silk Central > 跟踪 > 项目概述报告

项目概述报告包含选定项目状态的高级概述。

父主题： 跟踪
父主题： 默认报告
相关参考
项目概述报告


Silk Central、基于风险的测试和质量目标

通常在软件开发期间，必须在测试范围、时间和成本之间实现平衡。 确定此平衡的一个常用方法是基于风险的测试。

基于风险测试的关键实践是，根据对质量和应用程序最终用户来说重要的因素，对测试资产进行分类的过程。

基于此分类过程，质量实践者可根据质量过程的可用时间和预期目标来确定合适的测试集。 执行测试子集有一定的风险。 以相关方式量化此风险可确保在整个过程中通知相关人员，这是成功实施基于风险的测试的关键。

在 Silk Central 中，基于风险的测试所使用的因素可使用质量目标完全自定义。 可以为任何列表类型的自定义属性或需求属性创建质量目标，以用于对测试资产分类。 这可让用户定义需要执行的测试子集，以使项目符合特定的质量条件。 质量目标报告可使用户向相关人员传达有关测试资产的测试计划、执行进程、相关范围、时间和质量度量标准。

  • 质量目标
    介绍项目的质量目标。
  • 使用质量目标执行基于风险的测试方法
    使用质量目标以在 Silk Central 中执行基于风险的测试方法。
父主题： 跟踪
相关概念
质量目标
相关参考
状态报告


质量目标

质量目标（退出条件）是项目必须达到的一组可定义的测试度量标准，以使质量视为可接受。 每个 Silk Central 项目可以包含一个或多个质量目标。 Silk Central 将质量目标用作实施基于风险测试的主要方法，这样允许您在给定的测试周期仅计划、测试和报告最重要的测试。

在 Silk Central 中，质量目标由以下两个元素组成：

  • 需求或测试。
  • 以下之一：
    • 具有相应百分比值的列表类型的自定义属性。
    • 以下默认需求属性之一：具有相应百分比值的优先级、已审阅或风险。

质量目标示例

如果需求的 MyCustomRisk 属性具有高、中和低值，则可以定义以下内容的质量目标：

质量目标 - MyCustomRisk
高 = 100%
中 = 50%
低 = 10%

100% 表示符合此条件（链接到与具有高属性值的需求）的所有测试必须执行和通过才能符合此目标。

权限

质量目标基于权限。 有关权限的详细信息，请参阅质量目标权限。

  • 质量目标页面
    列出了与您选定的 Silk Central 项目关联的所有质量目标。
  • 添加质量目标
    介绍如何添加质量目标。
  • 删除质量目标
    介绍如何删除质量目标。
父主题： Silk Central、基于风险的测试和质量目标
相关参考
质量目标权限
状态报告


质量目标页面

跟踪 > 质量目标

可在质量目标选项卡上执行以下控制，以便您创建、编辑或删除项目的质量目标：

质量目标网格

列 | 说明
目标名称 | 目标的名称。 在列名上选择下拉列表，然后选择按组排列以显示列表中的所有目标。
名称 | 名称列中详细列出了每个属性列表类型的值。
目标 (%) | 此文本字段必须包含 0 到 100 的一个数值。 此值表示达到定义的质量目标所需的测试百分比。

按钮

  • 管理目标 - 单击可显示管理质量目标对话框。
  • 计划报告 - 单击可显示质量目标计划报告。
  • 执行报告 - 单击可显示质量目标执行报告。
父主题： 质量目标


添加质量目标

创建质量目前之前，您需要创建要用于质量目标的类型列表的测试自定义属性或需求自定义属性。 或者，您可以使用优先级、已审阅或风险的需求字段。

例如，如果希望质量目标跟踪值为高、中和低的需求自定义属性，请先转到项目：<项目名称> > 项目设置 > 需求属性，然后创建包含这些值的列表类型自定义属性。

注： 您只能在每个项目中将属性用作质量目标一次。
  1. 在菜单中，单击项目 > 项目列表。
  2. 选择项目。
  3. 单击跟踪 > 质量目标。
  4. 单击管理目标。 将打开管理质量目标对话框。
  5. 在新目标名称字段中，输入目标的名称。
  6. 在属性/自定义属性列表中，选择包含要用于质量目标的值的项目。 列表包含以下类型的项目：
    • 类型列表的需求属性。
    • 优先级、已审阅或风险的默认需求属性。
    • 类型列表的测试属性。
  7. 单击添加新目标。
  8. 单击关闭。 管理质量目标对话框将关闭，并且新目标将添加到质量目标网格。
  9. 对于列表中的每个值，请在达到目标所需的测试百分比中输入 0 至 100 之间的数值。
父主题： 质量目标
相关参考
自定义属性和需求属性类型


删除质量目标

要删除质量目标：

  1. 在菜单中，单击项目 > 项目列表。
  2. 选择一个项目。
  3. 单击跟踪 > 质量目标。
  4. 单击管理目标。 此时将打开管理质量目标对话框。
  5. 单击要删除的质量目标旁边的删除图标。
父主题： 质量目标


使用质量目标执行基于风险的测试方法

对于给定项目，用户要平衡测试范围和时间，同时还需确保应用程序的质量可被接受。 以下步骤阐明了用户如何使用质量目标以执行基于风险的测试方法的高级工作流。

在此项目中，相关人员对确保执行足够的测试台以及确保充分测试最重要的需求感兴趣。 以下示例中的数据也包括在 Demo 项目中，该项目包括新版本的 Silk Central。

  1. 选择一个项目。
  2. 创建类型列表的需求属性以捕获需求的重要性。 对于此示例，请使用以下值创建需求属性业务值：
    • 低
    • 中
    • 高
  3. 创建类型列表的测试属性以捕获测试目标的类型。 对于此示例，请使用以下值创建测试属性级别：
    • 完整
    • 回归
    • 冒烟
  4. 单击跟踪 > 质量目标。
  5. 创建新的质量目标。 对于此示例，请使用以下目标 % 为需求属性创建质量目标业务值：
    • 高 - 100%
    • 中 - 75%
    • 低 - 50%
  6. 创建新的质量目标。 对于此示例，请用以下目标 % 为测试属性创建质量目标测试目标：
    • 完整 - 80%
    • 回归 - 50%
    • 冒烟 - 100%
  7. 开发测试资产后，将特性/属性分配到需求和测试。
  8. 要确定测试范围并确保相关人员协议在测试范围内，请单击报告 > 详细信息视图。
  9. 单击测试 > 状态报告 > 质量目标计划报告。

    此报告将显示每个质量目标值的数字和百分比、手动测试的总计划时间和满足目标所需的测试数与 在此项目中可用的测试数。

    质量目标计划报告
  10. 计划获准后，如果项目正在进行测试执行，则可使用质量目标执行报告轻松评估质量目标的测试状态。
  11. 单击测试 > 状态报告 > 质量目标计划报告。 质量目标执行报告
父主题： Silk Central、基于风险的测试和质量目标


问题

介绍如何在 Silk Central 中处理问题。

  • 创建新问题
    介绍如何创建新问题以将其添加到测试。
  • 以文档视图查看问题统计信息
    以文档视图查看问题统计信息。
  • 问题 文档视图
    打开文档视图，以表格格式查看所选项目的问题统计信息。
  • 以详细信息视图查看问题统计信息
    打开详细信息视图以查看问题统计信息。
  • 问题页面
    列出为所选项目配置的所有问题跟踪系统中的问题。
  • 分配现有问题
    将现有问题分配到测试。
  • 更新问题状态
    介绍如何同步 Silk Central 和问题跟踪系统之间的问题状态。
  • 删除问题（问题引用）
    介绍如何删除 Silk Central 中的问题引用。
  • Issue Manager
    提供 Issue Manager 的概述。
父主题： 问题跟踪和结果分析


创建新问题

您可通过问题页面轻松创建与所选测试相关的问题。

要创建新问题，请执行以下操作：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要为其创建新问题的测试。
  3. 单击问题选项卡。
  4. 单击新建问题以打开新建问题对话框。
  5. 选择要向其提交问题的问题跟踪系统的配置文件。
    注： 您在此选择的配置文件将成为将来输入新问题时的默认选择。 将新问题添加到问题跟踪系统时，系统会提示您提供问题跟踪系统的登录凭据。 将来会自动预先选定您所提供的凭据。
  6. 输入问题的简短摘要。
  7. 输入有意义的问题说明。
  8. 使用对话框右侧的 UI 控件提供关于问题的信息。
    注： 这些 UI 控件因所选配置文件而异。 例如：如果要创建将使用 Bugzilla 处理的问题，则需要指定产品、组件等等。 如果将使用 JIRA 处理问题，则需要指定其他值，如问题类型或优先级。
  9. 单击确定以创建问题。
父主题： 问题


以文档视图查看问题统计信息

以文档视图查看问题统计信息：

  1. 在菜单中，单击问题 > 文档视图。
  2. 在问题树中，选择要查看其统计信息的项目、问题跟踪系统或产品。
父主题： 问题


问题 文档视图

问题 > 文档视图

文档视图以表格格式显示所选项目的问题统计信息。

列 | 说明
日期 | 更新问题详细信息的日期和时间。
未解决 | 所选项目、数据库或产品中状态为未解决的问题数。
已修复 | 所选项目、数据库或产品中状态为已修复的问题数。
已验证 | 所选项目、数据库或产品中状态为已验证的问题数。
已关闭 | 所选项目、数据库或产品中状态为已关闭的问题数。
已推迟 | 所选项目、数据库或产品中状态为已推迟的问题数。
父主题： 问题


以详细信息视图查看问题统计信息

以详细信息视图查看问题统计信息：

  1. 在菜单中，单击问题 > 详细信息视图。
  2. 在问题树中，选择要查看其统计信息的项目、问题跟踪系统或产品。
  3. 日历工具功能使您可以指定您要查看问题统计信息的时间段。单击时间范围的日期链接可展开日历。
  4. 使用日历的开始日期和结束日期列表框，来指定问题统计信息的开始时间和结束时间。
  5. 单击更新以根据指定的时间范围更新图表视图。
父主题： 问题


问题页面

问题 > 详细信息视图 > 问题

问题页面列出为所选项目配置的所有问题跟踪系统中的问题。此页面包含以下项目：

项目 | 说明
日历工具 | 允许您指定应报告问题的时间范围。单击时间范围日期链接可展开日历工具。
更新 | 根据日历更改更新问题视图。仅当存在更改时才会显示按钮。
父主题： 问题


分配现有问题

您可通过问题页面从问题跟踪系统将问题分配到所选测试。

将现有问题分配到测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要为其分配问题的测试节点。
  3. 单击问题选项卡。
  4. 单击分配现有问题以打开分配现有问题对话框。
  5. 选择在其中跟踪问题的预先配置问题跟踪系统的配置文件。
  6. 在问题 ID 字段中键入问题编号（以逗号隔开）。
  7. 单击确定。
注： 您也可以在当前运行页面、执行运行页面（位于执行计划中）和测试运行页面（位于测试中）将现有问题分配到当前运行的执行计划。
父主题： 问题
相关参考
当前运行页面
执行运行页面
测试运行页面


更新问题状态

同步 Silk Central 和问题跟踪系统之间的问题状态：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择您要为其更新相应问题的测试节点。
  3. 单击问题选项卡。
  4. 单击更新问题状态，以将 Silk Central 中列出的问题状态与问题跟踪系统中的相应问题同步。
父主题： 问题


删除问题（问题引用）

删除问题引用：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 选择要从中删除问题的测试。
  3. 单击问题选项卡。
  4. 在操作列中，单击 删除 。
  5. 单击删除问题选项卡上的是以确认删除。
重要： 此操作仅删除 Silk Central 中的问题引用。 而不会删除问题跟踪系统中的问题本身。
父主题： 问题


Issue Manager

欢迎使用 Issue Manager！

Issue Manager 是用于自动跟踪问题的综合工具。 借助 Issue Manager，您可以通过为组织工作流建模的方式输入、处理和管理问题。

Issue Manager 可协助您管理软件缺陷、文档问题、增强请求等。 它旨在满足应用程序开发人员、质保部工程师、技术支持、文档专家、经理和 IT 人员等广大用户的需求。

Issue Manager 采用称为行为驱动工作流的技术。 此工作流技术可根据用户行为和问题状态在整个生命周期内自动移动问题，它可自定义为您企业的工作流。 从报告问题到关闭问题，当用户对该问题执行操作时，Issue Manager 将自动处理问题路由。

您的管理员可将路由规则和工作流设置为在分配给单个用户或组的收件箱之间自动推进问题。 具有特殊安全权限的用户可以覆盖预定义的问题路由。

Issue Manager 允许您执行以下任务：

  • 通过 Web 界面报告问题。
  • 添加、审查、重新分配、修复、验证和关闭问题。
  • 查看有关任何问题的详细信息。
  • 查看用户帐户和收件箱。
  • 当问题发生特定更改时接收电子邮件。
  • 通过运行查询，从数据库中检索问题信息。
  • 生成报告和图表。
  • 存档问题。
  • Issue Manager 使用入门
    介绍如何使用 Issue Manager。
  • 使用 Issue Manager
    提供 Issue Manager 的简介。
  • Issue Manager 管理
    介绍 Issue Manager 和 Silk Central 之间的关系。
父主题： 问题


Issue Manager 使用入门

作为最终用户

熟悉最终用户的任务。

先创建示例数据库，然后再创建和配置组织的生产数据库。有关其他信息，请参阅数据库。

作为管理员

开始使用 Issue Manager 之前，需要设置数据库。有关其他信息，请参阅数据库。

  • 浏览示例数据库
    以管理员身份浏览示例数据库以熟悉 Issue Manager 的功能。
  • 使用 Issue Manager 可执行的操作
    概述 Issue Manager 的功能。
父主题： Issue Manager
相关概念
数据库


浏览示例数据库

以管理员身份浏览示例数据库以熟悉 Issue Manager 的功能。 要浏览示例数据库：
  1. 启动 Issue Manager 并以 dhart（无限制权限的开发用户）登录到示例数据库。
  2. 输入现有产品的问题。
  3. 保存问题。 Issue Manager 填写问题详细信息页面的自动字段和历史记录选项卡。
  4. 对问题执行操作并完成相应的操作对话框。 此时将更改问题详细信息页面。 执行其他操作，直到您对进程感到满意。
  5. 查看多个用户帐户。
    1. 注意用户分配至的组。
    2. 查看用户的安全权限。
    3. 注意用户的默认收件箱。
  6. 添加组。
    1. 分配安全权限。
  7. 为新用户添加收件箱。
    1. 将收件箱与新建组关联。
  8. 为新用户添加帐户。
    1. 将新的收件箱分配至用户。
    2. 将任何剩余的安全权限分配至此用户帐户。
  9. 添加新产品，包括其路由规则。
    1. 为产品添加一个或多个版本。
    2. 将每个版本与一个或两个平台关联。
  10. 退出系统。
  11. 以新用户登录。
  12. 要查看问题如何通过工作流处理，请输入并保存新产品的问题。
    1. 在已分配到字段中，问题已路由到路由规则中指定的其中一个收件箱。 缺陷处于开发部准备就绪状态。 选择历史记录选项卡并注意此处的条目。
    2. 选择历史记录选项卡并注意此处的条目。
    3. 将问题重新分配至其他开发人员。
    4. 查看历史记录选项卡如何反映此操作。
    5. 将问题设置为已修复以使其前进至下一个状态。 状态字段将变为质保部准备就绪且已分配到字段将更改至路由规则中指定的收件箱中。 假设此为质保部工程师的收件箱。
    6. 将问题设置为验证，这就意味着质保部工程师已验证此缺陷已修复。 此问题应移至已关闭状态。 再次查看历史记录选项卡。 它有何变化？
  13. 为新产品添加两个组件。
  14. 为部件设置路由规则，为整个产品指定不同的收件箱。
  15. 输入特定产品组件的另一个问题。 重复步骤 12 中所述的子步骤，以查看路由有何变化。
    注： 因为所有问题的工作流相同，所以问题通过的状态保持相同。
  16. 更改问题详细信息页面上的字段标签。
  17. 将产品代码更改为产品。
  18. 打开现有问题的问题详细信息可查看更改。
  19. 添加新字段至自定义选项卡 1。
  20. 打开现有问题的问题详细信息选项卡，然后选择自定义选项卡可查看新的字段。
  21. 生成几个在报告单元可用的预定义报告和图表。
父主题： Issue Manager 使用入门


使用 Issue Manager 可执行的操作

作为针对问题跟踪需求的完整解决方案，Issue Manager 使您可以：
  • 创建新问题：
  • 导入问题： Silk Test Assistent 使您可将 Silk Test 测试用例的详细信息作为新问题的基础直接转发到 Issue Manager。同样，当您发现需要关注的 Silk Central 执行结果时，您也可轻易将结果用作新问题的基础。
  • 进程问题：Issue Manager 使您可审阅、重新分配、修复、验证和关闭问题（权限因用户类型而异）。
  • 将文件与 Issue Manager 问题关联： 如果您或客户拥有问题重现所需的文件，可以将这些文件上载到 Issue Manager 并将其附加到问题。在这种情况下，您可以轻易查找需要确认、修复或验证缺陷的文件。
  • 查看系统中每个问题的完整历史记录：Issue Manager 记录用户对问题执行的每项操作。默认问题历史记录条目包括对问题执行的操作、执行操作的用户以及说明操作的注释。
  • 与工作组交互： 您的 Issue Manager 管理员可以在组织中设置工作组，以便共享特权、权限、收件箱和分配。在这种情况下，您可以与每个用户和组中的用户交互，以分担相似的工作职责。
  • 查询系统以获取符合条件的问题信息：您可以使用预先定义的查询，按照示例构建查询或通过 SQL 创建高级查询。
  • 生成报告和图表： 根据您指定的问题条件创建预定义报告，或通过 SQL 创建高级查询。
  • 定义通知： 定义问题状态或分配更改时发送通知。
  • 与问题数据库远程交互： 通过 Web 远程输入和查询问题。
  • 将测试分配到问题： 使用 Silk Central
父主题： Issue Manager 使用入门


使用 Issue Manager

Issue Manager 帮助提供信息和指导，有助于您通过 Issue Manager 跟踪问题以满足软件开发环境的需求。

  • 概述
    提供 Issue Manager 的概述。
  • 输入问题
    介绍如何在 Issue Manager 中创建和编辑问题。
  • 处理问题
    介绍如何处理问题。
  • 电子邮件通知
    介绍如何使用电子邮件通知。
  • 报告 (Issue Manager)
    介绍 Issue Manager 报告。
  • 项目 (Issue Manager)
    介绍 Issue Manager 的基于项目的工作流。
父主题： Issue Manager


概述

此部分提供 Issue Manager UI 的概述。 它包含问题跟踪页面、问题详细信息页面、问题详细信息选项卡和问题跟踪工具栏。

  • 问题跟踪页面
    介绍问题跟踪页面。
  • “问题详细信息”页面
    介绍问题详细信息页面。
父主题： 使用 Issue Manager


问题跟踪页面

在菜单中，单击问题 > 问题跟踪。

概述

此时问题跟踪页面将显示收件箱的问题列表。要查看其他收件箱，请从工具栏的显示列表中选择一个。收件箱可以按组进行组织。要仅显示特定组的收件箱，请从工具栏的列表中选择一个。您可显示或隐藏列、调整宽度以及拖动列来更改其顺序。在网格中单击要对内容进行排序、分组或筛选的列。单击网格中的 [image] （查看问题）以在问题详细信息页面上显示问题的详细信息。您也可以使用键盘上的向上和向下键浏览列表，并按 Enter 显示问题的详细信息。

使用显示列表定义您希望看到的问题：
  • 所有未解决的问题：显示未处于终结状态的所有收件箱的所有问题。
  • 所有问题：显示所有收件箱的所有问题，包括已关闭的问题。
  • <收件箱名称>：显示当前分配到选定收件箱的所有问题。

工具栏

单击工具栏中的按钮以执行以下操作：
  • 单击 [image] （我的收件箱）以显示收件箱的问题列表。
  • 单击新问题以添加新问题。
  • 单击 确认 （下载为 XLSX）以将问题列表导出为 Excel 表。
  • 在转到问题号工具栏字段中输入问题号，然后按 Enter 以快速移到特定问题。
  • 单击 [image] （打开 Silk Test Classic 智能助理）。仅当 SRFrontendBootConf.xml 文件中的 ShowSilkTestAssistant 标记取消注释并设置为 true 时，此图标才会显示。有关更多信息，请参阅 Silk Test 智能助理。

批量更新

您可使用键盘的 Ctrl 和 Shift 键，以通过标准浏览器多选功能选择多个问题。根据用户的权限，可以通过右键单击选定项对多个问题执行以下操作：
  • 重新分配问题，前提是未选择任何已关闭的问题。
  • 工作流操作，前提是所选问题的类型和状态均相同。请注意，如果所选问题具有相同产品，则只能启用使用产品相关字段的工作流操作。
父主题： 概述
相关概念
Silk Test 智能助理


“问题详细信息”页面

在菜单中，单击问题 > 问题跟踪，从工具栏的列表中选择收件箱，然后在网格中单击 [image] （查看问题）。此时问题详细信息页面将显示有关问题的详细信息。

工具栏

页面顶部的工具栏中显示操作列表。单击链接可处理某个问题。可用链接根据问题状态和您的权限而变化。有关所有可用链接的列表，请参阅处理问题的操作。

单击 [image] （返回收件箱）以返回问题跟踪页面上的问题列表。您也可以使用退格键完成此操作。

在转到问题号工具栏字段中输入问题号，然后按 Enter 以快速移到特定问题。

问题详细信息

操作链接下方显示有关问题的最重要信息，您可添加附件和配置通知。使用问题摘要下方的附件和通知图标可添加附件和配置通知 。
名称 | 说明
收件箱中的上一个问题 | 显示所选收件箱的问题列表中上一个问题的数据。您也可以使用向上和向左键完成此操作。
收件箱中的下一个问题 | 显示所选收件箱的问题列表中下一个问题的数据。您也可以使用向下和向右键完成此操作。
附件 | 允许您添加包含与问题相关的其他信息的文件。您可以使用操作列中的按钮编辑和移除文件。无需先单击编辑。
通知 | 允许您配置电子邮件通知。Issue Manager 在问题的特定值发生更改时通知您。无需先单击编辑。
显示可打印版本 | 显示所选问题的可打印数据视图。

问题详细信息选项卡

问题详细信息选项卡显示在问题详细信息页面的问题详细信息下方。在编辑选项卡上的值（如添加客户或更新说明）之前，您需要单击问题详细信息页面上的编辑。您也可以使用 F2 键完成此操作。提供以下选项卡：
名称 | 说明
说明 | 包含问题的摘要和说明。 注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
历史记录 | 跟踪与问题有关的所有更改。例如：问题创建时间、问题创建者，以及重新分配、修复、验证、添加客户、文件、测试用例等操作。
客户 | 允许您添加报告问题的客户的相关信息。您可以使用操作列中的按钮编辑和移除客户。
可跟踪性 | 显示与 Issue Manager 问题相关联的测试。输入您的 Silk Central 凭据以激活此选项卡。单击测试名称以转到测试详细信息视图。在测试详细信息的问题选项卡上，您可以查看为测试分配的所有问题。
自定义 | 包含 Issue Manager 管理员设置的任何自定义字段和列表。
测试用例 | 允许您添加 Silk Test 测试用例。质保部和开发人员可以通过单击操作列中的 [image] （运行测试用例）来直接执行测试用例。Silk Test 测试用例还可以使用 Silk Test 智能助理进行导入。仅当 SRFrontendBootConf.xml 文件中的 ShowTestcasesTab 标记取消注释并设置为 true 时，此选项卡才会显示。
父主题： 概述
相关任务
对问题执行操作
相关参考
处理问题的操作


输入问题

本章介绍如何在 Issue Manager 中创建和编辑问题、如何使用 Silk Test 智能助理创建 Silk Test 结果文件之外的问题以及如何从 Silk Test 导出结果。

  • 创建问题 (Issue Manager)
    介绍如何在 Issue Manager 中创建新问题。
  • 编辑问题 (Issue Manager)
    介绍如何在 Issue Manager 中编辑问题。
  • Silk Test 智能助理
    介绍 Silk Test 智能助理。
  • 将 Silk Test 结果导入到 Issue Manager
    介绍如何将 Silk Test 测试的结果导入到 Issue Manager。
  • 从 Silk Test 中导出结果
    介绍如何从 Silk Test 中导出结果
  • 建议的更改
    介绍在将测试用例结果和 Silk Test 测试用例与问题关联时，Issue Manager 如何针对问题状态建议更改。
父主题： 使用 Issue Manager


创建问题 (Issue Manager)

在 Issue Manager 中创建新问题：
  1. 在菜单中，单击问题 > 问题跟踪。
  2. 在工具栏中，单击 [image] （新建问题）。
  3. 选择问题类型、产品、版本、平台、组件和严重性的值。
    注： 突出显示的字段和列表是必需的。
    当您输入值时，Issue Manager 会根据已配置的规则动态分配收件箱和问题的初始状态。
  4. 输入摘要和说明。要创建此问题与其他问题的链接，请将相关问题的问题编号或摘要键入已链接问题字段（启用自动建议）。已链接问题列在历史记录选项卡中。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 可选：添加问题的更多详细信息。单击选项卡，然后单击以下按钮：
    • 添加客户：跟踪关于报告问题的客户的信息。
    • 添加文件：添加包含关于问题的其他信息的文件。
    • 添加测试用例：质保部和开发人员可通过单击测试用例选项卡上的操作列中的 [image] （运行测试用例）直接执行已添加的 Silk Test 测试用例。Silk Test 测试用例还可以使用 Silk Test 智能助理进行导入。
    • 添加通知：配置为当问题的某些值发生更改时使用电子邮件进行通知。
  6. 单击确定。
此时将显示问题详细信息页面。要返回收件箱的问题列表（问题跟踪页面），请单击 [image] （我的收件箱）。
父主题： 输入问题


编辑问题 (Issue Manager)

要在 Issue Manager 中编辑问题：
  1. 在菜单中，单击问题 > 问题跟踪。
  2. 在网格中单击 [image] （查看问题）。 此时将显示问题详细信息页面。
  3. 单击编辑。
  4. 编辑列表和字段的值。
  5. 单击选项卡以编辑问题的更多详细信息。
  6. 单击确定。
可在历史记录中跟踪更改。 单击历史记录选项卡以查看更改。
父主题： 输入问题


Silk Test 智能助理

Silk Test 智能助理分析 Silk Test 结果文件 (.rex) 中的测试用例。然后助理将创建可以通过 Issue Manager 跟踪的测试用例问题。
注： 仅当 SRFrontendBootConf.xml 文件中的 ShowSilkTestAssistant 标记取消注释并设置为 true 时，打开 Silk Test Classic 智能助理图标才会显示。

根据测试用例结果，您可以创建新问题或更新现有问题。例如：如果您运行测试用例后失败，智能助理可将测试用例附加到新问题。质保部工程师随后可以直接从 Issue Manager 执行附加的测试用例，并确定问题是否已修复。

您可以将一个或多个测试用例分配给一个问题。但是，您不能将一个测试用例分配给多个问题。如果两个测试用例的脚本名称、测试用例名称和参数相同，则智能助理会将其视为相同。

注： 您可以指示智能助理将不同平台上运行的相同测试用例视为单独的测试用例。智能助理不会提出要修复的测试用例，直至测试用例在所有平台上传递。
父主题： 输入问题
相关参考
问题跟踪页面


将 Silk Test 结果导入到 Issue Manager

要导入 Silk Test 测试的结果：
  1. 在菜单中，单击问题 > 问题跟踪。
  2. 从工具栏中的列表中选择收件箱。
  3. 单击工具栏中的 [image] （打开 Silk Test Classic 智能助理）。
  4. 浏览到计算机中的 .rex 文件。
  5. 从列表中选择平台以将测试所运行的平台用作合并逻辑中的因子。
  6. 单击复选框以包括无错误且未与问题关联的测试，然后单击下一步。
  7. 单击复选框以选择测试库，然后单击以下按钮之一：
    • 单击新问题以创建新问题并为其分配测试用例。 有关更多信息，请参阅创建问题 (Issue Manager)。
    • 单击现有问题，然后输入问题号以为其分配测试用例。
    已分配的测试用例将不再显示在列表中。
  8. 单击下一步。
  9. 确认建议的操作，然后单击完成。
测试用例将分配到问题。 要运行或编辑测试用例，请单击测试用例选项卡上操作列中的按钮。
父主题： 输入问题


从 Silk Test 中导出结果

要从 Silk Test 中导出结果：
  1. 在 Silk Test 中，单击结果 > 发送到 Issue Manager。 此时将显示将问题发送到 Issue Manager 对话框。
  2. 选择结果文件 (.res)。
  3. 单击确定。 此时将启动智能助理。 智能助手选项卡将显示已下载至已导出测试结果 (.rex) 字段的结果文件的路径。
  4. 单击下一步。 此时将显示将测试和问题关联对话。
遵照将 Silk Test 结果导入到 Issue Manager 中的步骤。
父主题： 输入问题


建议的更改

在将测试用例结果和 Silk Test 测试用例与问题关联时，Silk Test 智能助理会比较问题的结果和当前信息，以生成问题的建议更改列表。

列表包括问题的建议操作，以及您确认操作后将导致的新问题状态和原因代码。 每个建议的操作基于每个问题的当前状态和原因代码，以及关联测试用例的结果。

要创建建议的更改列表，Silk Test 智能助理使用以下公式：

[当前状态和原因代码] + [测试结果] = [特别操作、新状态和原因代码]

例如：如果问题的当前状态为质保部准备就绪及其原因代码为已修复，并且与此问题关联的测试用例失败，则智能助理将建议 AutoRejectFix 操作，这会将问题的状态更改为质保部准备就绪，并将其原因代码更改为已拒绝。 以下公式总结了此示例：

[质保部准备就绪和已修复] + [失败的测试] = [AutoRejectFix、质保部准备就绪和已拒绝]

父主题： 输入问题


处理问题

Issue Manager 提供了一系列可供您处理问题的操作。 例如，您可以将问题标记为已修复或已实施，您可以指示需要更多信息或问题不再是问题等。

这些操作的按钮显示在问题详细信息页面的右侧。 有关所有可用操作的列表，请参阅处理问题的操作。 问题列表因问题的状态和特定用户的权限而异。 许多操作可由 Issue Manager 管理员配置和自定义。

  • 处理问题的操作
    介绍在处理问题时可以使用的所有操作。操作列表因问题的状态和您的权限而不同。
  • 对问题执行操作
    介绍如何使用操作处理问题。
  • 设置问题验证首选项
    介绍问题验证首选项以及如何设置它们。
父主题： 使用 Issue Manager


处理问题的操作

问题详细信息页面顶部显示操作列表。单击链接可处理某个问题。操作根据问题状态和您的权限而变化。

您可执行以下操作：
操作 | 说明
接受 | 表示问题中描述的增强或文档问题已获批，可进一步处理。
添加注释 | 允许您添加关于正在对问题采取的操作的注释。
添加解决方法 | 表示不会立即修复问题，但会产生解决方法。
已完成 | 表示问题已修复。
仲裁 | 表示存在关于问题状态的分歧。开发部、文档部或质保部需要讨论问题及其状态。
保留原样 | 表示问题实际上并非问题，因为功能可按预期正常运行。
不能执行 | 表示不能实施所请求的增强。
无法修复 | 表示问题无法修复。这可能是因为它太危险或可能太耗时。
确认为缺陷 | 表示问题确实是一个问题，需要进行修复。
复制到项目 | 允许您将问题复制到另一个项目。所有客户、附加文件和测试用例会随问题一起复制。不会复制通知。单击按钮，再从列表中选择项目，然后单击确定。字段和列表中会填充来自源问题的值。根据需要编辑这些值，然后单击确定。
延期进行 | 允许您将问题延期到以后的版本。
编辑 | 允许您编辑字段中的值以及问题详细信息页面和问题详细信息选项卡上的列表。
已修复 | 表示问题已修复。指定已在其中修复问题的内部版本或版本。
已实施 | 表示已实施增强。
标记为重复 | 将问题标记为另一个问题的副本。指定匹配问题的问题号。问题将保持打开。
需要更多信息 | 表示开发部需要来自质保部的关于此问题的更多信息。当缺陷无法重现或描述不清楚时便可能发生此情况。
不再是问题 | 表示问题已过期。当新功能或另一个缺陷修复已解决问题时便可能发生此情况。
不是缺陷 | 表示问题并不是缺陷，而是问题报告人员对功能有所误解。
不可再生 | 表示问题无法重现。
重新分配 | 允许您将问题分配到其他收件箱。
拒绝 表示以下情况之一：
  • 问题已修复，但无法验证，因此被拒绝。
  • 请求的增强功能未获批。
重新打开缺陷 | 表示质保部已重新打开问题。当问题已在先前的内部版本中得到修复并在更高内部版本中再次提出时，便可能发生此情况。
验证 | 表示问题已修复并接受为已修复。
父主题： 处理问题
相关任务
对问题执行操作
相关参考
“问题详细信息”页面


对问题执行操作

对现有问题执行操作：
  1. 在菜单中，单击问题 > 问题跟踪。
  2. 单击 [image] （我的收件箱）或从工具栏中的列表中选择组和收件箱。
  3. 单击网格中的 [image] （查看问题）。 此时将显示问题详细信息页面。页面顶部显示操作列表。
  4. 单击操作链接并在对话框中输入所需值。
有关所有可用操作的列表，请参阅处理问题的操作。
父主题： 处理问题
相关参考
“问题详细信息”页面
处理问题的操作


设置问题验证首选项

通过问题验证首选项，每次创建新问题或使用现有问题时，您都可以配置验证问题的方式。

设置问题验证首选项：

  1. 在菜单中，单击问题 > 配置。
  2. 单击首选项。
  3. 请选择以下选项之一：
    • 单击始终使用普通路由：这是默认系统路由。
    • 单击始终验证自己的问题：将向您返回所有输入的问题以便您进行验证。
    • 单击提示每个新问题：确定针对各个情况，是将问题返回给您还是问题使用标准路由。
注： 您需要问题验证首选项安全权限才可设置首选项。 Issue Manager 管理员可以将此权限分配给您。 如果您没有此权限，此选项按钮将被禁用。
父主题： 处理问题


电子邮件通知

您可以将 Issue Manager 配置为在发生预定义事件时通知您。这些事件为：
  • 重新分配：重新分配问题且状态不发生更改。
  • StateChange：问题更改其状态。
  • AnyChange：对生成新历史记录条目的问题进行更改。
Issue Manager 管理员可以为特定事件定义其他规则。定义规则后，用户可以设置电子邮件通知。您可以为特定问题定义系统级通知或通知。对于这些操作，您需要以下安全权限：
操作 | 必需的安全权限
定义通知规则 | 电子邮件通知规则和系统级通知
定义电子邮件通知 | 每个问题的电子邮件通知
定义系统级通知 | 电子邮件通知规则和系统级通知

系统管理员必须配置电子邮件服务器设置。否则，电子邮件通知将无法工作。

任何用户均可定义基本电子邮件通知，无论分配的权限如何。如果您设置基本通知，Issue Manager 将在其他用户对您收件箱中的问题进行更改或将新问题分配至您的收件箱时通知您。

  • 定义通知规则
    介绍如何定义通知规则。
  • 定义电子邮件通知
    介绍如何定义电子邮件通知。
  • 配置基本电子邮件通知
    介绍如何配置 Issue Manager 以在用户将问题分配到您的收件箱或更改您收件箱中的问题时通知您。
父主题： 使用 Issue Manager
相关概念
设置电子邮件通知规则


定义通知规则

Issue Manager 提供三种默认通知规则：任意更改、重新分配和状态更改。要定义其他通知规则：
  1. 在菜单中，单击问题 > 配置。
  2. 单击左侧的通知规则。
  3. 单击添加规则。 此时将显示新建通知规则。
  4. 输入规则名称、说明和 WHERE 子句。如需了解其他信息，请参见定义电子邮件通知规则。
  5. 选中处于活动状态复选框以激活规则。
  6. 单击确定。
通知规则将添加到列表。
注： 您需要拥有电子邮件通知规则和系统级通知安全权限才能定义通知规则。
父主题： 电子邮件通知
相关任务
定义电子邮件通知规则


定义电子邮件通知

要定义电子邮件通知，请执行以下操作：
  1. 在菜单中，单击问题 > 问题跟踪。
  2. 单击 [image] （我的收件箱）或从工具栏中的列表中选择组和收件箱。
  3. 单击网格中的 [image] （查看问题）。此时将显示问题详细信息页面。
  4. 单击通知图标。
  5. 单击添加通知。 此时将显示添加通知对话框。
  6. 输入所需的值，然后单击确定。 通知将添加到列表。
要编辑通知，请单击 [image] （编辑通知）；要删除通知，请单击操作列中的 [image] （删除通知）。有关配置系统级通知的信息，请参阅管理系统级通知。
父主题： 电子邮件通知
相关概念
管理系统级通知
相关任务
添加系统级通知


配置基本电子邮件通知

配置基本电子邮件通知：
  1. 在菜单中，单击问题 > 配置。
  2. 单击左侧的首选项。
  3. 选中当用户向我分配问题或对我的收件箱中的问题做出更改时通知我复选框。
注： 不管分配的权限如何，任何用户均可定义基本电子邮件通知。 基本电子邮件通知的主题行和内容均可在 SRFrontendBootConf.xml 文件中进行配置。
父主题： 电子邮件通知


报告 (Issue Manager)

通过可高度自定义的 Issue Manager 报告，您可以将数据转换为有意义的图表。Issue Manager 提供多个预配置报告，划分为三个类别。这些类别显示在报告树中：
  • 常用报告
  • 文本搜索
  • 管理报告

文本搜索是以表格格式返回报告数据的查询。报告模板使用 BIRT Report Designer（一种基于 Eclipse 的开源报告工具）或 Microsoft Excel 创建。

如果选定的项目中没有任何数据，或您未连接到正确的 Issue Manager 数据库，则生成空报告。

您可以使用基于 GUI 的工具或手动写入 SQL 代码创建报告。使用此高级方法，对如何查询数据并在报告中显示数据几乎没有限制。

有关如何使用报告的更多信息，请参阅报告。

  • 创建报告
    介绍如何在 Issue Manager 中创建报告。
  • 添加子报告
    介绍如何添加从多个报告汇总结果的子报告。
  • 编辑报告属性
    介绍如何编辑报告的属性。
  • 编辑报告参数
    介绍如何编辑报告的参数。
  • Issue Manager SOAP API
    介绍如何使用 SOAP API 通过第三方工具访问 Issue Manager 存储库。
父主题： 使用 Issue Manager
相关概念
报告


创建报告

创建 Issue Manager 报告：
  1. 在菜单中，单击问题 > 报告。
  2. 在报告树中选择文件夹。
  3. 在工具栏中，单击 [image] （新建子报告）。 将显示创建新报告对话框。
  4. 输入名称和说明。
  5. 如果要与其他用户共享此报告，请选中此复选框。
  6. 输入超时 [秒] 以定义 Issue Manager 等待报告执行完成的时间。
  7. 从列表中选择默认选项卡和结果类别。 如果使用上下文菜单（例如，右键单击测试时）访问报告，您将直接转到定义的默认选项卡。
  8. 从列表中选择选择条件、属性、运算符和值。 字符串允许使用的通配符包括 *（任意数量的字符）和 ? （仅一个字符）。
  9. 单击更多以创建其他查询字符串，然后选择 AND 或 OR 运算符以连接查询字符串。 单击 [image] （删除）以删除查询字符串。
  10. 单击下一步以配置报告的列。 您可添加列、全部删除、通过单击 [image] （上移）或 [image] （下移）设置顺序、通过单击 [image] （删除）删除单列、设置排序和分组选项以及输入别名。
  11. 单击完成。

您也可通过手动编写 SQL 代码来创建报告。 在创建新报告对话框上单击高级，然后输入或粘贴您的 SQL 代码。 有关更多信息，请参阅使用 SQL 编写高级查询。 有关所有可用函数占位符的列表，请参阅自定义报告的 SQL 函数。

父主题： 报告 (Issue Manager)
相关概念
自定义报告的 SQL 函数


添加子报告

要将多个报告的结果汇总到当前所选报告中，您可添加子报告。子报告的结果列和行会串联到所选报告的结果。

添加子报告：

  1. 在菜单中，单击问题 > 报告。
  2. 在报告树中选择报告。
  3. 单击属性选项卡。
  4. 单击添加子报告。 将显示添加子报告对话框。
  5. 从报告树中，选择要追加到当前报告的子报告。
  6. 单击确定。 子报告将显示在子报告部分中相关报告的属性页面上。
要删除子报告，请单击操作列中的 [image] （删除）。
父主题： 报告 (Issue Manager)


编辑报告属性

要编辑报告的属性：
  1. 在菜单中，单击问题 > 报告。
  2. 从报告树中选择报告。
  3. 单击工具栏中的 [image] （编辑）。 此时将显示编辑报告对话框。
  4. 根据需要编辑值。
  5. 单击完成。
有关此对话框的 UI 控件的更多信息，请参阅创建报告。
父主题： 报告 (Issue Manager)


编辑报告参数

要编辑报告的参数：
  1. 在菜单中，单击问题 > 报告。
  2. 在报告树中选择报告。
  3. 单击参数选项卡。 如果已为报告定义任何参数，则此处将列出这些参数。
  4. 单击编辑参数。 此时将显示编辑参数对话框。
  5. 根据需要编辑所列参数的标签或值。
  6. 从使用情况列表中，选择参数的使用类型。
    • 常数值
    • 开始时间
    • 结束时间
  7. 单击确定。
有关报告参数的更多信息，请参阅报告参数页面。
父主题： 报告 (Issue Manager)
相关参考
报告参数页面


Issue Manager SOAP API

Issue Manager 提供开放式 API（应用程序编程接口），允许从第三方应用程序访问 Issue Manager 存储库，例如提交缺陷。

WSDL 所基于的接口显示在下方。 此接口还包含这些方法的文档：

/**
* A Project object has a ProjectID and a ProjectName. The ProjectID
is used for all further methods
* for specifying the Issue Manager project you want to work on.
* @param sessionID
* @return Array of initialized Issue Manager projects available
for the user used for generating the sessionID
* @throws SQLException
*/

public Project[] getProjects(long sessionID) throws SQLException;

/**
* @param sessionId
* @param projectID
* @return the names of the 3 issue types
*/

public String[] getIssueTypes(long sessionId, int projectID)
throws RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @return Array of ProductNames that are configured for the
provided Issue Manager project
*/

public String[] getProducts(long sessionId, int projectID)
throws RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @param product
* @return Array of ReleaseNames that are configured for the
provided product
*/

public String[] getReleases(long sessionId, int projectID,
String product) throws RemoteException, MissingValueException,
SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @return Array of available PlatformNames
*/

public String[] getPlatforms(long sessionId, int projectID) throws
RemoteException, SQLException, LoginException;

/**
* @param sessionId
* @param projectID
* @param product
* @return Array of ComponentNames that are configured for the
provided product
*/

public String[] getComponents(long sessionId, int projectID,
String product) throws RemoteException, MissingValueException,
SQLException, LoginException;

/**
* The list of Severities can be grouped by IssueType or Product.
If the list is grouped by IssueType the
* parameter issueType has to be provided and the product parameter
can be empty. If the list is grouped by
* product issueType can be empty and the product has to be selected.
* @param sessionId
* @param projectID
* @param product
* @param issueType
* @return Array of values that can be used for entering an issue in
the given project when the provided
* IssueType/Product is selected.
*/

public String[] getSeverities(long sessionId, int projectID,String
product,String issueType) throws RemoteException,
MissingValueException, SQLException, LoginException,
NotExistingValueException;

/**
* @param sessionId
* @param projectID has to be a ProjectID delivered by
the method getProjects
* @param issueType has to be a values delivered by
the method getIssueTypes
* @param product has to be a values delivered by
the method getProducts
* @param release has to be a values delivered by
the method getReleases for the selected product
* @param platform has to be a values delivered by
the method getPlatforms
* @param component has to be a values delivered by
the method getComponents for the selected product
* @param severity has to be a values delivered by
the method getSeverities for the selected projectID
and IssueType/Product
* @param synopsis the Synopsis for the new issue
* @param description the Description for the new issue
* @return the Issue Number of the new issue
*/

public int saveNewIssue(long sessionId, int projectID,
String issueType, String product, String release, String
platform, String component, String severity, String
synopsis, String description) throws RemoteException,
MissingValueException, NotExistingValueException,
SQLException, LoginException;
父主题： 报告 (Issue Manager)


项目 (Issue Manager)

Issue Manager 使用基于项目的工作流。 仅可查看或处理与活动项目关联的问题。 要访问各个问题，您需要选择项目。 在菜单中，单击问题 > 项目列表，然后单击项目名称将其激活。 在您选择其他项目前，选定的项目会保持活动状态。

  • 初始化存储库配置
    您需要先为 Issue Manager 初始化一个项目，之后才能使用它。
父主题： 使用 Issue Manager


初始化存储库配置

您需要先为 Issue Manager 初始化一个项目，之后才能使用它。

已初始化的项目显示在操作列的初始化中。

要初始化项目：

  1. 在菜单中，单击问题 > 项目列表。
  2. 单击操作列中的 [image] （初始化项目<项目名称>的存储库配置）。 此时将显示初始化存储库对话框。
  3. 可选：单击创建示例数据，为您要初始化的数据库创建示例数据。
  4. 单击确定以开始初始化。 此时将显示启动配置向导对话框。
  5. 单击是以继续配置向导，或者如果您计划以后配置项目，请单击否。
有关如何配置 Issue Manager 的更多信息，请参阅 Issue Manager 管理。
父主题： 项目 (Issue Manager)
相关概念
Issue Manager 管理


Issue Manager 管理

除了管理用户帐户和其他管理任务外，Issue Manager 还与 Silk Central 共享其数据库存储库。Issue Manager 项目也是在 Silk Central 管理单元中创建、配置和管理的。这样可将 Issue Manager 项目与 Silk Central 项目进行完全集成。

将 Issue Manager 与 Silk Central 一起使用时，除了问题外，项目可能还包含许多元素，其中包括需求、测试和执行定义。

Issue Manager 项目

Issue Manager 使用基于项目的工作流。仅可查看或处理与活动项目关联的问题。在授予单个问题的访问权限之前，您必须选择 Issue Manager 项目（通过项目单元）。所选项目将保持为您每次访问 Issue Manager 时的默认选定项目，直到您选择要使用的其他项目，此时新选择的项目将变成默认项目。

初始化数据库配置

在创建项目后，必须先初始化它的数据库连接，然后才能将其用作 Issue Manager 项目。

  • 设置数据
    介绍如何将组织信息输入到数据库。
  • 例程管理任务
    介绍您必须为 Issue Manager 执行的例程管理任务。
  • 可选功能
    列出 Issue Manager 可用的可选功能。
  • 设置组
    介绍如何在 Issue Manager 中设置用户组。
  • 设置收件箱
    介绍如何在 Issue Manager 中设置收件箱。
  • 设置用户帐户
    介绍如何设置用户帐户来管理问题。
  • 定义产品设置
    介绍如何定义产品设置。
  • 设置路由规则
    介绍如何定义路由规则，来确定在问题的生命周期内将问题路由到哪个收件箱。
  • 自定义问题详细信息页面
    介绍如何更改问题相关页面的外观和行为。
  • 自定义工作流
    介绍如何自定义工作流。
  • 问题存档
    介绍问题存档。
  • 设置电子邮件通知规则
    介绍电子邮件通知规则和通知。
父主题： Issue Manager


设置数据

熟练使用 Issue Manager 后，您可将组织信息输入到数据库。 您可以在配置页面输入此信息。 要打开配置页面，请单击问题 > 配置。

您首先应收集有关组织工作流程的信息。 花时间仔细计划。 要在组织中有效使用 Issue Manager，您必须收集有关以下主要区域的信息：
  • 人员。
  • 产品。
  • 问题跟踪页面的适用性、操作对话框和组织的 Issue Manager 工作流。
按以下顺序完成以下活动：
  1. 收集组织人员的信息。
  2. 收集产品信息。
  3. 可选：评估 Issue Manager 的接口和工作流。 您可以自定义问题跟踪页面、操作对话框、严重性列表和配置页面中的工作流。
  4. 创建您自己的数据库并用设置数据填充。
  • 收集组织中的人员信息
    收集组织中的人员信息可有效使用组织中的 Issue Manager。
  • 收集产品信息
    收集组织中的产品信息可有效使用组织中的 Issue Manager。
  • 可选：评估界面和工作流
    评估 Issue Manager 的界面和工作流，以在您的组织中有效地使用 Issue Manager。
父主题： Issue Manager 管理
相关概念
数据库


收集组织中的人员信息

要收集组织中的人员信息：
  1. 拟定组列表。
  2. 确定适合每组所有成员的安全权限和初始问题状态。
  3. 拟定帐户列表。 每个登录到 Issue Manager 的用户均需要具有帐户。
  4. 确定帐户的命名方案。 包括已分配的组和一个或多个收件箱（如果必要）。 询问您自己以下问题：
    • 哪些帐户需要组权限未包括的额外安全权限？
    • 此帐户的初始问题状态是否应与组中其他账户不同？
    • 您是否希望需要密码才能登录？
  5. 审阅用户帐户列表时，记下需要收件箱的用户。 组是否也需要收件箱？ 确定收件箱命名方案。
  6. 您可自定义所有用户的默认视图。 所有用户都具有相同的默认收件箱视图。 视图包括八列信息。
父主题： 设置数据


收集产品信息

要收集组织中的产品信息：
  1. 拟定产品、每个产品的版本和每个版本的平台列表。
  2. 将平台列表与管理 > 平台中的列表进行比较。
  3. 拟定每个产品的软件和文档组件列表。 无需组件（功能区域）；但是，它们使您可根据产品、版本、平台和组件跟踪问题并对问题路由进行更精确的控制。
  4. 拟定问题严重性列表。 此列表上的值将显示在问题跟踪页面上的严重性列。 您可按照产品或问题类型将此列表分类，或提供所有产品和问题类型的通用列表。
  5. 将您的列表与管理 > 值列表中的列表进行对比。
  6. 确定接收与产品、组件、版本和平台相关的问题的收件箱。 这些是路由规则。
父主题： 设置数据


可选：评估界面和工作流

评估 Issue Manager 的界面和工作流：
  1. 评估问题跟踪页面的外观和行为，以确定是否要执行以下任务：
    • 修改默认列标签。
    • 添加列以获取更多信息。
    • 修改操作对话框上的字段，或添加您自己的字段。
    保留您的修改列表。 您有责任将所做修改通知您所在组织的用户。
  2. 评估默认工作流，以确定其是否满足您所在组织的需求。 查看每种状态及其有效操作。 操作的默认组权限是否符合要求？
父主题： 设置数据


例程管理任务

有时，初始安装完成后，您需要执行例程管理任务来确保 Issue Manager 保持最新。 以下是最常用的任务：

添加新用户

对于新用户，您需要执行以下任务：
  • 如果需要，在设置帐户前创建收件箱。
  • 设置新帐户并将帐户与现有组和默认收件箱（如果需要）关联。
  • 如果用户需要通过自动路由接收问题，则将用户的收件箱添加到路由规则。

删除用户

用户离开组织后，您应执行以下任务：
  • 立即停用用户帐户，使用户无法再登录。 如果用户已创建或已修改问题，则您无法删除帐户。
  • 将路由规则中对用户收件箱的任何引用替换为其他收件箱。 此步骤阻止将新问题发送到此收件箱。
    注： 您应仅在无其他用户登录 Issue Manager 时对路由规则做出更改。
  • 将问题重新分配到其他收件箱可清除用户的收件箱。
  • 删除用户的收件箱。

转移工作分配

您需要在用户更换工作时更新组分配。 比如，质保部工程师 Sarah 转到开发部。 您也需要修改路由规则，以便用户接收适合其新职责的问题。 例如，Sarah 现在应接收需要开发部而非质保部关注的问题。

用户更改项目时，您需要修改路由规则以反映其当前职责。 您也需要确保默认收件箱仍适用。 比如，Judy 过去是为产品 A 编写手册的作者，但现在为产品 B 编写文档。 Judy 的默认收件箱 Judy - Doc（产品 A）应更改为 Judy - Doc（产品 B）。

添加新产品信息

有时您需要执行以下任务：
  • 添加新产品。
  • 为现有产品添加其他版本、平台和组件。
  • 更改路由规则以适应新的产品、组件、版本和平台。
父主题： Issue Manager 管理


可选功能

在设置数据库并且学会使用 Issue Manager 后，请考虑使用以下可选功能：

电子邮件通知

电子邮件通知功能允许在问题出现特定事件（例如重新分配或状态更改）时向 Issue Manager 用户发送电子邮件。拥有电子邮件通知规则和系统级通知安全权限的用户可以定义发送电子邮件的其他情况。请询问您的用户他们希望在什么情况下接收电子邮件。

存档问题

数据库中的问题数越多，执行操作（例如查询）所需的时间可能越长。为帮助您提高整体性能，Issue Manager 允许您将不再与组织工作相关的问题存档。存档问题将会在数据库中隔离它们，举例来说，这样您就能够仅针对活动问题运行查询。

父主题： Issue Manager 管理
相关概念
设置电子邮件通知规则
相关任务
存档问题


设置组

组可以是整个部门、跨部门项目团队或部门内部团队，具体取决于您的组织。

每个组都有明确的安全权限。 Issue Manager 组也确定组成员报告的问题进入工作流的位置。 用户组确定用户可以在 Issue Manager 中执行的操作，并影响用户所报告问题的路由方式。

示例数据库提供以下默认组：
  • 企业
  • 开发部
  • 文档部
  • 质保部
  • 研发管理部
  • 技术支持部

所有 Issue Manager 用户必须分配到组，无论他们执行什么任务。 用户一次只能位于一个组。

必须在设置收件箱和用户帐户前设置组，因为每个收件箱和用户必须与组关联。

注： 可在管理 > 用户管理的组选项卡中创建、编辑和删除组，但特定于 Issue Manager 的组设置在问题 > 配置 > 组中配置。
  • 组属性
    介绍 Issue Manager 中的组的属性。
父主题： Issue Manager 管理
相关概念
设置用户帐户


组属性

组具有多个属性。 基本组信息（例如组的名称）在管理 > 用户管理中的组选项卡中指定。 特定于 Issue Manager 的组设置（例如初始问题状态和某些安全权限）在问题 > 配置中的组选项卡中指定。

注： 必须先创建组，然后才可修改特定于 Issue Manager 的组设置。
  • 组信息
    列出为管理 > 用户管理中的组设置的属性。
  • 初始问题状态
    为组介绍初始问题状态。
  • 组安全设置
    介绍组的安全设置。
父主题： 设置组
相关概念
用户帐户属性


组信息

下表列出了为管理 > 用户管理中的组设置的属性：
属性 | 说明
Name | 需要组的唯一名称，例如文档。 可包含最多 20 个字符。
Description | 可选：组的说明，例如文档可产生所有技术出版物，包括手册和发行说明。 可包含最多 80 个字符。
Account and Role Assignment | 用户自身必须分配有某些角色。
Project Assignment | 一个组必须分配到最少一个项目。 分配至组的用户只能访问分配至各自组的项目。
父主题： 组属性


初始问题状态

初始问题状态是指在给定组成员提交时为缺陷、增强请求或文档问题分配的第一个状态。 不同的组可拥有相同类型问题的不同初始问题状态。 此外，在一个组内，每个问题类型、缺陷、加强和文档问题可具有不同的初始状态。

例如，您可能会为开发组成员提交的软件缺陷分配初始状态开发部准备就绪，因为您假设开发人员可以正确评估真正的软件缺陷。 另一方面，您可能会为公司组成员提交的软件缺陷分配初始状态未审阅，因为您可能希望先验证该问题是否真正为新缺陷，然后再将其发送到开发部门进行修复。

Issue Manager 提供了各种默认状态供您选择。 在您的组织中设置组之前，您还可以创建自己的问题状态。

虽然初始状态适用于组的每个成员，但您可以为特定用户覆盖这些设置。

父主题： 组属性
相关概念
设置用户帐户
自定义工作流
初始问题状态


组安全设置

安全权限可定义组中所有用户可执行的活动。您可以通过编辑组中给定用户的帐户来为其分配其他权限，但您无法收回已授予用户组的权限。

要为组分配安全权限，单击问题 > 配置 > 组中的定义组设置。选中复选框以将相应权限分配至组。要授予组超级用户的权限，则选中所有复选框。

下表列出了允许组成员执行特定自定义任务的权限：
复选框 | 说明
组、收件箱和用户帐户 | 创建并编辑组、收件箱和用户帐户，包括安全权限。
产品 | 创建并编辑产品、版本、平台和组件。编辑平台列表和其他列表。
路由规则 | 定义如何根据所记录问题的产品、版本、平台和组件将问题从一个收件箱移动到另一个收件箱。
GUI 自定义 | 自定义问题跟踪页面中的字段和选项卡。
工作流自定义 | 定义问题状态和操作、操作权限、帮助文本以及操作对话框的外观和使用。
电子邮件通知规则和系统级通知 | 定义应用到数据库中所有问题的电子邮件通知规则并添加电子邮件通知。
存档问题 | 将所选问题从与此问题相关的问题和表中删除，并将其放置在与存档相关的存档和表中。
下表列出了影响问题路由和电子邮件通知的权限：
复选框 | 说明
重新分配问题 | 将问题从一个收件箱移动到另一个收件箱。
问题验证首选项 | 选中以覆盖普通路由规则。
每个问题的电子邮件通知 | 将电子邮件通知添加到单个问题。
输入/编辑问题 | 输入和编辑问题的权限。
父主题： 组属性
相关概念
设置用户帐户
用户安全设置
自动路由覆盖首选项


设置收件箱

收件箱类似于邮箱。 所有发往（分配）到特定用户或用户组的未解决问题均传送到收件箱。 请一定不要混淆收件箱和用户帐户。 问题通常被分配到收件箱，而非特定用户。

注： 已存档问题不显示在收件箱中。

如何将问题路由到收件箱？

Issue Manager 的路由规则将问题自动发送到相应的收件箱。 问题将保留在收件箱中，直至用户对其执行操作，例如开发人员修复缺陷时。 然后 Issue Manager 根据工作流和路由规则，将问题自动分发到下一收件箱。 最后关闭问题时，Issue Manager 会从最后的收件箱中删除问题。

当具有重新分配问题安全权限的用户将问题手动重新分配到其他收件箱时，也可将问题路由到其他收件箱。

哪些用户需要收件箱？

对问题执行操作的用户应具有收件箱。 开发人员、质保部工程师和技术文档作者处于此类别。 仅报告或查看缺陷的用户不需要收件箱。 定期报告客户发现的缺陷但不对缺陷执行操作的技术支持人员可能处于此类别。

用户需要多少个收件箱？

用户可以有多个收件箱。 例如，开发人员可能需要两个单独的收件箱来接收两种不同产品的缺陷报告。 在这种情况下，您可能要设置 Dan - 开发部（产品 A）和 Dan - 开发部（产品 B）这两个收件箱。

单个收件箱和组收件箱

您可以为单个用户、用户组或问题子集设置收件箱。 例如，质保部工程师 Sarah 和 Mike 可能负责验证不同产品的缺陷修复。 在这种情况下，您要设置 Sarah - 质保部和 Mike - 质保部这两个收件箱。

用户也可共享收件箱。 例如，产品管理组可能只需要一个接收所有增强请求的收件箱；整个组可能会定期一起来审阅建议的改进。 在这种情况下，您可能要设置称作 PM - 收件箱的单个收件箱。

收件箱的另一个用途可以是为问题的子集保留位置。 例如，您可能希望为产品 C 的所有推迟问题创建收件箱。 在这种情况下，可能可以创建称作已推迟（产品 C）的收件箱。

分配用户的默认收件箱

设置用户帐户时，将收件箱分配给用户帐户。 此收件箱是用户的默认收件箱。 用户只能有一个默认收件箱。

查看默认收件箱和其他收件箱

您可以选择问题 > 问题跟踪来查看默认收件箱。 如果未显示默认收件箱，请单击工具栏中的我的收件箱。

要查看非默认收件箱的收件箱，请选择收件箱列表框中列出的其他收件箱。 任何用户都可以查看收件箱，但仅具有正确权限的用户才可以对问题执行操作或重新分配问题。

系统默认视图

Issue Manager 为所有用户提供收件箱的初始默认视图。 您可以为所有用户自定义收件箱的默认视图。

  • 添加收件箱
    将收件箱添加到用户，以向用户分配问题。
  • 编辑收件箱
    编辑收件箱以使其适应更改后的用户角色。
  • 删除收件箱
    如果收件箱不包含任何问题、未在路由规则中引用并且不是用户的默认收件箱，则可以删除该收件箱。
  • 设置初始默认收件箱视图
    介绍如何设置 Issue Manager 的初始默认收件箱视图。
父主题： Issue Manager 管理
相关概念
设置用户帐户


添加收件箱

您应为操作问题的每位用户添加至少一个收件箱。

注： 您需要组、收件箱和用户帐户安全权限才可添加、编辑或删除收件箱。

添加收件箱：

  1. 在菜单中，单击问题 > 配置。
  2. 单击收件箱。 此时将打开收件箱页面。
  3. 单击添加收件箱。 此时将打开收件箱设置对话框。
  4. 在名称字段中键入收件箱的名称。
    每个收件箱需要一个包含最多 50 个字符的唯一名称。以下是示例收件箱名称：
    • Dave（开发部）
    • PM 收件箱
    • Jesse - 文档部
    • Dan - 开发部（产品 A）
    • Dan - 开发部（产品 B）
    用户收件箱名称可以是您选择的任何格式，但应遵循一致的格式。以下是示例格式：
    • 用户（组）
    • 用户 - 组
    • 用户 - 组（产品-名称）
    • user
    组收件箱也应遵循一致的格式，例如以下格式之一：
    • 组
    • 组（产品-名称）

    不允许特殊字符。收件箱名称按 ASCII 排序顺序（大写字母优先）显示在收件箱页面上。

  5. 从组列表框中，选择与此收件箱关联的组。 基于此关联，Issue Manager 可帮助用户选择性地重新分配问题。例如，假设文档部小组成员 Denise 在其收件箱中重新分配了一个问题。Issue Manager 将打开问题重新分配对话框，并将文档部作为默认组。然后，Denise 可从新收件箱列表框中选择其他文档部小组成员，而无需扫描整个收件箱列表。
  6. 可选：在说明字段中输入收件箱说明。 说明长度可包含最多 80 个字符。例如，开发人员 David Hanson 的收件箱或 dhart 用于产品 B 问题的收件箱。
  7. 处于活动状态复选框默认为选中。
    注： 如果路由规则中使用了收件箱，则您无法取消选中处于活动状态复选框。
  8. 单击确定以创建新收件箱。
父主题： 设置收件箱


编辑收件箱

注： 您需要组、收件箱和用户帐户安全权限才可添加、编辑或删除收件箱。

要编辑收件箱：

  1. 在菜单中，单击问题 > 配置。
  2. 单击收件箱。 此时将打开收件箱页面。
  3. 单击要编辑的收件箱的名称。 此时将打开收件箱设置对话框。
  4. 编辑收件箱的名称。
  5. 从组列表框中选择其他组。
  6. 编辑收件箱的说明。
  7. 选中或取消选中处于活动状态复选框。
    注： 如果路由规则中使用了收件箱，则您无法取消选中处于活动状态复选框。
  8. 单击确定以保存您所做的更改。
父主题： 设置收件箱


删除收件箱

仅当收件箱不包含任何问题、未在路由规则中引用并且不是用户的默认收件箱时，您才能删除该收件箱。 在您尝试删除收件箱之前，编辑路由规则以防止新问题路由到该收件箱，然后在收件箱中重新分配现有问题。

注： 您需要组、收件箱和用户帐户安全权限才可添加、编辑或删除收件箱。

要删除收件箱：

  1. 在菜单中，单击问题 > 配置。
  2. 单击收件箱。 此时将打开收件箱页面。
  3. 在要删除的收件箱的操作列中，单击 [image] 。 此时将打开确认对话框。
  4. 单击是以从系统中删除收件箱。
父主题： 设置收件箱
父主题： 设置电子邮件通知规则


设置初始默认收件箱视图

安装 Issue Manager 时，初始默认收件箱视图由以下八列组成：
  • 严重性
  • 问题号
  • 产品
  • 组件
  • 版本
  • 摘要
  • 创建者
  • 更改者
您可以对所有用户的初始默认收件箱视图执行以下自定义任务：
  • 从显示视图中添加或删除列。
  • 编辑列的标签。
  • 更改列的排序顺序。

单个用户可以创建收件箱的自定义初始视图。

  • 修改默认收件箱视图
    修改初始默认收件箱视图以更改显示的列。
父主题： 设置收件箱


修改默认收件箱视图

注： 您需要组、收件箱和用户帐户安全权限才可添加、编辑或删除收件箱。
要修改初始默认收件箱视图：
  1. 在菜单中，单击问题 > 配置。
  2. 单击收件箱视图。 此时将打开收件箱视图页面。此页面显示可选择在收件箱视图中显示的所有字段。大部分字段都可从问题详细信息页面中识别。其他字段（例如 NumHistory、NumCases, NumAttaches、NumTestcases 和 NumNotify）是指问题详细信息页面上的相应历史记录、客户、附件、测试用例和通知页面上的条目数。收件箱视图页面还显示每个列的架构或数据库字段名称。
  3. 从用户视图列表框中，选择系统默认。 要更新其他用户的收件箱视图，请选择相应用户。
  4. 要将列添加至收件箱，请单击与可用字段列表中的列对应的 Select Column 。
  5. 要从收件箱中删除列，请单击与收件箱列列表中的列对应的 Deselect Column 。
  6. 要更改列标签和排序次序，请执行以下步骤：
    1. 在收件箱列标签列中单击收件箱列的名称。 此时将打开收件箱列属性对话框。
    2. 将列的新标签键入收件箱列标签字段中。
    3. 单击相应的选项按钮以更改排序次序。
    4. 单击确定。
  7. 要将列移到收件箱的左侧，请单击 Move Up 。要将列移到收件箱的右侧，请单击 Move Down 。
  8. 单击查看收件箱返回到问题跟踪页面。
    注： 如果您更新了系统默认收件箱视图或其他用户的视图，更改将在相应用户注销并重新登录后才会生效。
父主题： 设置初始默认收件箱视图


设置用户帐户

用户帐户是有关给定用户的信息集合。 每个用户都会分配到组，如果用户对问题执行操作，则被分配一个收件箱。 用户帐户可以带密码保护。 登录系统来报告问题、对问题执行操作或只是浏览问题的每个人均需要用户帐户。

注： 您可以在管理 > 用户管理的帐户选项卡中创建、编辑或删除用户帐户。

用户继承所在组的安全权限和初始问题状态。 要为单个用户提供增强的权限或其他初始问题状态，您必须编辑此用户的帐户。 要配置这些设置，请使用问题 > 配置中的用户帐户选项卡。

注： 在设置用户帐户之前，您必须已设置组和收件箱。
  • 用户帐户属性
    介绍用户帐户的问题相关属性。
  • 初始问题状态
    为用户介绍初始问题状态。
  • 用户安全设置
    介绍用户帐户的安全设置。
  • 编辑用户帐户
    编辑用户帐户以更改用户拥有的安全权限。
父主题： Issue Manager 管理
相关概念
例程管理任务


用户帐户属性

用户帐户的问题相关属性在问题 > 配置的用户帐户选项卡中指定。

注： 在查看或编辑问题相关帐户属性前，您必须创建用户帐户。

单击用户帐户选项卡中的用户名称以编辑问题相关的帐户属性。

下表列出了问题相关的帐户属性：
属性 | 说明
Login | 用户必需的唯一登录名称。 最多可包含 30 个字符。 不允许特殊字符。 注： 您无法在 Issue Manager 中编辑登录名称。
Inbox | 用户的默认收件箱。 您可以从收件箱列表框中选择用户的备用默认收件箱。
Setting Group | 必填。 此用户所属的组。 从设置组列表框中选择组时，Issue Manager 会将组的初始问题状态和组安全设置默认值自动分配给用户。
父主题： 设置用户帐户
相关概念
组属性


初始问题状态

初始问题状态是指在用户提交时为缺陷、增强请求或文档问题分配的第一个状态。 默认值为分配至用户所属组的组默认值。

例如，如果用户具有较高级别的技术能力，则您可能希望为用户帐户更改默认初始问题状态。 例如，假设在一组非技术经理中，有一位经理的技术能力明显高出一筹。 您可能希望在工作流中将此用户的问题进一步输入 Issue Manager。

父主题： 设置用户帐户
相关概念
初始问题状态


用户安全设置

安全权限定义用户可以执行的活动。用户的默认安全权限是用户所属组的安全权限。您可以通过编辑组中给定用户的帐户来为其分配其他权限，但您无法收回已授予用户组的权限。默认安全权限为只读。

要将安全权限分配给用户帐户，请单击问题 > 配置 > 用户帐户中的用户名称。选中相应复选框以将相应权限分配给用户。

下表列出了允许用户执行特定自定义任务的权限：
复选框 | 说明
组、收件箱和用户帐户 | 创建并编辑组、收件箱和用户帐户，包括安全权限。
产品 | 创建并编辑产品、版本、平台和组件。编辑平台列表和其他列表。
路由规则 | 定义如何根据所记录问题的产品、版本、平台和组件将问题从一个收件箱移动到另一个收件箱。
GUI 自定义 | 自定义问题跟踪页面中的字段和选项卡。
工作流自定义 | 定义问题状态和操作、操作权限、帮助文本以及操作对话框的外观和使用。
电子邮件通知规则和系统级通知 | 定义应用到数据库中所有问题的电子邮件通知规则并添加电子邮件通知。
存档问题 | 将所选问题从与此问题相关的问题和表中删除，并将其放置在与存档相关的存档和表中。
下表列出了影响问题路由和电子邮件通知的权限：
复选框 | 说明
重新分配问题 | 将问题从一个收件箱移动到另一个收件箱。
问题验证首选项 | 选中以覆盖普通路由规则。
每个问题的电子邮件通知 | 将电子邮件通知添加到单个问题。
输入/编辑问题 | 输入和编辑问题的权限。
父主题： 设置用户帐户
相关概念
组安全设置


编辑用户帐户

注： 您需要组、收件箱和用户帐户安全权限才能编辑用户帐户。
要编辑用户帐户的安全权限和初始问题状态：
  1. 在菜单中，单击问题 > 配置。
  2. 单击用户帐户。 此时将打开用户帐户页面。
  3. 单击要编辑其安全权限的用户的名称。 此时将打开用户设置对话框。
  4. 更改用户的安全权限和初始问题状态。
  5. 单击确定以保存您所做的更改，或单击取消以退出而不进行更改。
父主题： 设置用户帐户
相关概念
用户安全设置
初始问题状态


定义产品设置

除了跟踪特定产品的问题外，Issue Manager 还可以跟踪以下项的问题：
  • 产品的特定版本。
  • 与产品版本关联的特定平台。
  • 特定产品组件。

产品团队通常有多名人员为给定的应用程序编写代码。Issue Manager 允许您将产品和组件与特定收件箱相链接。此外，Issue Manager 还可根据产品、组件、版本和平台，自动将新问题分配给相应的开发人员。

注： 您可在 Silk Central 的管理单元中创建和编辑产品、组件、版本、内部版本和平台。产品收件箱设置是唯一可通过 Issue Manager 进行配置的属性。
您可以根据需要定义如何将产品与组件区分开来。某个组织中的产品可能在另一个组织内定义为组件。以下基本定义可能对您有所帮助：
产品
产品是指一套可与随其提供的其他软件分开运行的软件。如果需要，它可以单独出售。在产品中，可执行程序与代码库分开。产品可能包含多个组件。
组件
组件是指产品的功能区。组件无法单独出售，并且用户不会将组件视为明确的产品。产品可能具有一个或多个与其关联的组件。
发布
版本是指特定产品的特定版本或特定软件内部版本。版本可以是内部开发版本，也可以是向客户提供的版本。产品可能具有多个与其关联的版本。产品的特定版本可能在多个平台上可用。
平台
平台是指产品运行的环境。平台包含以下任何元素的组合：
  • 硬件。
  • 操作系统。例如 Microsoft Windows。
  • 操作系统版本。例如 8.1。
为产品、版本、平台和组件定义的多个值显示在问题 > 配置 > 产品的产品页面上。
  • 为项目定义收件箱设置
    为特定项目定义收件箱设置以设置问题应路由到的收件箱。
  • 删除产品
    删除 Issue Manager 中的产品以将其从所选项目中分离。
父主题： Issue Manager 管理
相关概念
设置路由规则


为项目定义收件箱设置

要在 Issue Manager 中为特定产品定义收件箱设置：
  1. 在菜单中，单击问题 > 配置。
  2. 单击产品。 此时将打开产品页面。
  3. 单击定义产品设置。 此时将打开产品设置对话框。
  4. 从产品列表框中，选择要为其定义收件箱设置的产品。
    注： 通过在产品页面中单击已分配给问题的产品名称，您可以跳过此步骤。
  5. 从质保部收件箱列表框中，选择分配给质保部并使用给定产品定义的问题应该路由到的预定义收件箱。
  6. 从开发部收件箱列表框中，选择分配给开发部并使用给定产品定义的问题应该路由到的预定义收件箱。
  7. 从增强请求收件箱列表框中，选择使用给定产品定义的增强请求问题应该路由到的预定义收件箱。
  8. 从文档部收件箱列表框中，选择分配给文档部并使用当前产品定义的问题应该路由到的预定义收件箱。
  9. 单击确定。
父主题： 定义产品设置


删除产品

删除 Issue Manager 中的产品不会从存储库中实际删除产品，而是会将该产品从所选项目中分离，因此无法再从 Issue Manager 访问该产品。
注： 您只能删除没有为该特定产品输入任何问题的产品。

要从活动项目中删除产品：

  1. 在菜单中，单击问题 > 配置。
  2. 单击产品。 此时将打开产品页面。
  3. 在要删除的产品的操作列中，单击 删除 。 此时将打开确认对话框。
  4. 单击是以完成删除。
父主题： 定义产品设置


设置路由规则

Issue Manager 依赖于定义的路由规则、每个问题的当前状态和相应的状态所有者，来确定问题的生命周期内将问题路由到的收件箱。 这种复杂的路由机制可取代问题调度人员的沉闷任务。

问题的状态为问题的当前情形。 状态数在 Issue Manager 的默认工作流中提供。 状态所有者是组织中负责对给定状态的问题执行操作的角色。

以下是默认问题工作流中问题状态和所有者的示例：
未审阅
某人需要确定此问题是否确实为缺陷或文档错误。 质保部工程师通常拥有此角色。
开发部准备就绪
代码已就绪，可供解决问题。 开发人员通常拥有此角色。
质保部准备就绪
某人需要验证缺陷实际上已修复。 质保部工程师通常拥有此角色。

相同类型的不同问题可以进入不同状态的工作流，具体取决于提交此问题的人员。 路由也会相应受影响。 例如，开发人员提交的问题进入“开发部准备就绪”状态的工作流，因此会路由到开发人员的收件箱。 企业用户提交的问题进入“未审阅”状态的工作流，因此会路由到质保部工程师的收件箱。 所谓的初始问题状态通过组设置分配。

用户对此问题执行操作时，问题会从工作流中的一个状态移到另一个状态。 例如，当质保部工程师确认已报告但未审阅的问题确实为缺陷时，问题将从“未审阅”状态移到“开发部准备就绪”状态。 在此使用路由逻辑的主要目标是，确保问题被质保部工程判定为缺陷后，问题从质保部工程师的收件箱移到相应的开发人员收件箱，而无需手动干预。

  • 路由规则
    介绍问题路由基于的规则。
  • 指定规则
    介绍如何指定路由规则。
  • 添加路由规则
    添加路由规则，以定义分发问题的方式。
  • 编辑路由规则
    编辑现有路由规则以更改分发问题的方式。
  • 删除路由规则
    删除路由规则以更改分发问题的方式。
  • 对路由规则重新排序
    对路由规则重新排序以更改其顺序。
  • 自动路由覆盖首选项
    介绍如何允许单个用户或整个用户组覆盖普通路由，以验证组织中的问题。
父主题： Issue Manager 管理
相关概念
自定义工作流
设置组


路由规则

问题路由基于您为产品及其关联版本、平台和组件定义的规则。 这种基于规则的机制可让您很好地控制问题的分布，因为路由问题部分基于以下条件的组合：
  • 产品
  • 组件
  • 版本
  • 平台
  • 问题状态
  • 状态所有者
您需要为每组条件分配以下四个收件箱：
  • 负责验证问题的收件箱，通常为质保部收件箱。
  • 负责解决问题的收件箱，通常为开发部收件箱。
  • 处理文档问题的收件箱，即文档部收件箱。
  • 用于增强请求的收件箱，通常为产品管理收件箱。

示例

与 Installer 组件相关且与 Motif 平台关联的所有产品 A 缺陷可以路由到一组收件箱，同时与 Windows 平台的 Installer 组件相关的所有产品 A 缺陷可以发送到另一组收件箱。

默认路由

除详细的路由规则外，Issue Manager 需要您从整体上定义产品的路由规则，即默认路由。 在默认路由中，特定产品的所有组件、版本和平台问题将路由到指定的四个收件箱。

每个收件箱覆盖以下区域之一：
  • 质保部
  • 开发部
  • 文档部
  • 增强请求
例如，产品 X 的所有增强请求定向到您分配的一个增强请求收件箱，无论是单个组件、平台还是版本。

Issue Manager 仅在其他路由规则不存在或不适用时使用默认路由规则。 换言之，默认路由规则仅在特定规则不匹配或未指定时应用。

默认路由在 Issue Manager 产品安装期间设置。

分析组织中的进程

分析组织中的工作分解。 审阅产品、版本和平台列表，并根据此列表依次考虑每个组件。 问自己如下问题：

对于此版本和平台中的组件，谁（即哪个收件箱）负责每项操作，例如验证和解决等？
然后为以下四个条件的不同组合定义所需的各种规则：
  • 产品
  • 版本
  • 平台
  • 组件
父主题： 设置路由规则
相关任务
添加路由规则
编辑路由规则


指定规则

将每个规则输入到路由规则页面，此页面位于问题 > 配置 > 路由规则。

注： 新建路由规则对话框采用条件式布局。 如果问题与特定条件匹配，即问题与特定版本、平台、组件和问题类型有关，则问题将被路由到四个指定收件箱之一。 选择四个收件箱中的哪一个收件箱由问题的当前状态和所有者确定。

% 符号的通配符

新建路由规则对话框的版本、平台和组件字段中的百分号 (%) 用作与所有字符匹配的通配符。 在所有三个字段中单独使用百分号将与默认路由相同；任何问题都会路由到对话框中指定的四个收件箱，而不考虑版本、平台和组件的值。

提示： 您必须始终指定版本、组件和平台名称才可利用通配符。

规则保存后将输入到路由规则页面。 此页面实质上是特定产品的路由表。 可使用页面顶部的产品列表框选择替代产品。

规则的顺序很关键

组件规则的顺序很关键。 Issue Manager 通过根据表中按顺序排列的每个规则评估当前状态（例如未审阅）来路由问题。 Issue Manager 找到匹配项后立即执行规则。 如果没有匹配项，将根据默认规则路由问题。 默认路由规则只有在应用给定产品的所有其他规则后才应用。

示例

版本字段中的 Release 4.% 将与所有 Release 4 版本匹配：4.0、4.1 和 4.1.1 等。

示例：如何阅读路由规则

例如，当为开发部准备好问题时，将与所有版本和平台的产品 A 有关的问题发送到 Sonja - 开发部收件箱；当为质保部准备好问题时，则发送到 Mike - 质保部收件箱；当提交增强请求时，则发送到产品 A 增强请求收件箱 Dan - 开发部（产品 A）；当报告与向我显示组件有关的文档问题时，则发送到 Judy -文档部收件箱。

父主题： 设置路由规则
相关概念
状态所有者


添加路由规则

添加路由规则：
  1. 在菜单中，单击问题 > 配置。
  2. 单击产品。 此时将打开产品页面。
  3. 从产品列表框中，选择您要为其配置路由规则的产品。
  4. 单击新建路由规则。 将打开新建路由规则对话框。
  5. 单击相应的选项按钮，以定义问题是否为 BUG 或 ENHANCEMENT (SOFT)，或问题是否为 DOC-ISSUE (DOC)。
  6. 从版本列表框中选择预定义版本。或在特定匹配代码字段中键入预定义版本。如果应考虑任何版本，则不选择任何内容，即用虚线表示。
  7. 从平台列表框中选择预定义平台。或在特定匹配代码字段中键入预定义平台。如果应考虑任何版本，则不选择任何内容，即用虚线表示。
  8. 从组件列表框中选择预定义组件。或在特定匹配代码字段中键入预定义组件。如果应考虑任何版本，则不选择任何内容，即用虚线表示。
    注： 您必须至少为一个版本、平台或组件选择一个值。否则，新路由规则将按照与默认规则相同的规则操作。
  9. 在对话框的则路由到这些收件箱区域中，为以下四个收件箱类别中的每个类别选择预定义收件箱：
    • 质保部收件箱
    • 开发部收件箱
    • 增强请求收件箱
    • 文档部收件箱
  10. 单击确定。 路由将保存并添加到路由表。
    注： 如果您对路由表做出了更改，Issue Manager 会保存和重新配置路由规则，这可能需要一些时间。
父主题： 设置路由规则


编辑路由规则

要编辑现有路由规则：
  1. 在菜单中，单击问题 > 配置。
  2. 单击产品。 此时将打开产品页面。
  3. 从产品列表框中，选择您要为其配置路由规则的产品。
  4. 在要编辑的规则的操作列中，单击 Edit Routing Rule 。 此时将打开编辑路由规则对话框。
  5. 单击相应的选项按钮，以定义问题是否为 BUG 或 ENHANCEMENT (SOFT)，或问题是否为 DOC-ISSUE (DOC)。
  6. 从版本列表框中选择预定义版本。或在特定匹配代码字段中键入预定义版本。如果应考虑任何版本，则不选择任何内容，即用虚线表示。
  7. 从平台列表框中选择预定义平台。或在特定匹配代码字段中键入预定义平台。如果应考虑任何版本，则不选择任何内容，即用虚线表示。
  8. 从组件列表框中选择预定义组件。或在特定匹配代码字段中键入预定义组件。如果应考虑任何版本，则不选择任何内容，即用虚线表示。
    注： 您必须至少为一个版本、平台或组件选择一个值。否则，新路由规则将按照与默认规则相同的规则操作。
  9. 在对话框的则路由到这些收件箱区域中，为以下四个收件箱类别中的每个类别选择预定义收件箱：
    • 质保部收件箱
    • 开发部收件箱
    • 增强请求收件箱
    • 文档部收件箱
  10. 单击确定。 路由将保存并添加到路由表。
    注： 如果您对路由表做出了更改，Issue Manager 会保存和重新配置路由规则，这可能需要一些时间。
父主题： 设置路由规则


删除路由规则

要删除现有路由规则：
  1. 在菜单中，单击问题 > 配置。
  2. 单击产品。 此时将打开产品页面。
  3. 从产品列表框中，选择您要为其配置路由规则的产品。
  4. 在要删除的规则的操作列中，单击 删除路由规则 。 此时将打开删除路由规则确认对话框。
  5. 单击是以完成删除。
父主题： 设置路由规则


对路由规则重新排序

对路由规则重新排序：
  1. 在菜单中，单击问题 > 配置。
  2. 单击产品。 此时将打开产品页面。
  3. 从产品列表框中，选择您要为其配置路由规则的产品。
  4. 在您要重新排序的规则的操作列中，请单击下列选项之一：
    • 要在列表中将规则上移，请单击 上移 。
    • 要在列表中将规则下移，请单击 [image] 。
父主题： 设置路由规则


自动路由覆盖首选项

您可允许单个用户或整个用户组覆盖普通路由，以验证组织中的问题。 例如，用户可能要验证报告的问题是否已修复。

要允许此覆盖，请向用户或用户组授予问题验证首选项权限。 借助此安全权限，用户便可从问题 > 配置 > 首选项中选择以下三个策略之一：
策略
说明
始终使用普通路由
验证的普通路由。 问题将路由至相应的质保部收件箱。
始终验证自己的问题
让 Issue Manager 将用户提交的问题路由到其自己的收件箱而非典型的质保部收件箱进行验证。
提示每个新问题
让 Issue Manager 为用户提供在每次报告问题时覆盖普通路由的选项。

重新分配覆盖自动路由

重新分配问题是一种覆盖自动路由机制的手动路由方法。 用户可明确采用“重新分配”操作将问题路由到其他用户（通常是同组用户）的收件箱。 例如，开发人员 Bill 将去度假，他可能会将“开发部准备就绪”缺陷重新分配到其开发部同事 Dan。 虽然该缺陷已重新分配，但仍处于“开发部准备就绪”状态。

当已重新分配的问题返回到工作流中的先前状态时，例如，如果 Dan 拒绝缺陷修复，Issue Manager 会记住重新分配并稍后将问题返回到手动向其路由问题的收件箱（在此情况下为 Dan 的收件箱）而非最初向其路由问题的收件箱（在此情况下为 Bill 的收件箱）。

示例

要了解重新分配如何有效工作，请看将缺陷发送回工作流中较早状态的示例，在此示例中，缺陷重新分配了两次（一次是“开发部准备就绪”状态，另一次是“质保部准备就绪”状态）并且质保部工程师拒绝缺陷修复。
  1. 新缺陷以开发部准备就绪状态进入工作流。 路由规则将缺陷自动发送到开发人员 Bill 的收件箱。
  2. Bill 将缺陷重新分配到开发人员 Dan 的收件箱。
  3. Dan 声称已修复缺陷，这会将缺陷发送到质保部准备就绪状态。
  4. 路由规则将缺陷自动路由到质保部工程师 Mike 的收件箱以进行验证。
  5. Mike 将缺陷重新分配到其同事 Sarah 的收件箱。
  6. Sarah 拒绝修复，这会将缺陷发送回“开发部准备就绪”状态。
  7. Issue Manager 将“开发部准备就绪”缺陷路由回 Dan 的收件箱，因为他是在该状态下最后对缺陷采取操作的开发人员。
  8. Dan 再次修复缺陷并将其发送回“质保部准备就绪”状态。
  9. Issue Manager 将“质保部准备就绪”缺陷路由回 Sarah 的收件箱，因为她是在该状态下最后对缺陷采取操作的质保部工程师。

如果没有增强路由，处于“开发部准备就绪”状态的问题（步骤 7）可能会路由到 Bill 的收件箱，而 Bill 可能再次将该问题重新分配到 Dan。 同样，处于“质保部准备就绪”状态的问题（步骤 9）可能会路由到 Mike 的收件箱，而 Mike 可能再次将该问题重新分配到 Sarah。

父主题： 设置路由规则
相关概念
组安全设置


自定义问题详细信息页面

Issue Manager 允许您更改现有问题的新建问题页面和问题详细信息页面的外观和行为。例如，您可能想要让某个字段标签与您的组织更相关，如“内部版本”而非“版本”。

您对问题详细信息页面上的标签所做的更改将传播到通过 Issue Manager 的自定义调用的大部分其他页面和对话框。

Issue Manager 允许您对问题详细信息页面进行以下更改：
  • 编辑标签并修改指定问题基本信息的字段属性。例如，您可能想要将标签“Synopsis”更改为“Summary”。
  • 在自动字段区域中编辑字段的标签。
  • 编辑选项卡标签。
  • 定义“自定义选项卡 1”和“自定义选项卡 2”上的字段。您可修改或删除这些字段或添加您自己的字段。默认情况下，“自定义选项卡 1”包含四个字段。
下表介绍何处可以查找与自定义标准问题字段标签和标准问题字段内容相关的信息：
名称 | 编辑字段标签？ | 自定义字段属性？
问题类型 | 自定义字段和选项卡标签 | 是。
产品 | 自定义字段和选项卡标签 | 是。请参阅编辑产品。
发行 | 自定义字段和选项卡标签 | 是。请参阅编辑版本。
平台 | 自定义字段和选项卡标签 | 是。请参阅编辑平台。
组件 | 自定义字段和选项卡标签 | 是。请参阅编辑组件。
严重性 | 自定义字段和选项卡标签 | 是。
摘要 | 自定义字段和选项卡标签 | 否。用户填写摘要。
问题号 | 自定义字段和选项卡标签 | 否。问题号无法自定义。
已分配到 | 自定义字段和选项卡标签 | 是。请参阅路由规则。
状态 | 自定义字段和选项卡标签 | 是。请参阅自定义工作流状态。
原因代码 | 自定义字段和选项卡标签 | 是。请参阅原因代码。
操作版本 | 操作属性 | 是。
下表介绍何处可以查找与自定义选项卡标签和选项卡上的字段相关的信息：
名称 | 编辑选项卡标签？ | 自定义选项卡上的字段？
说明 | 自定义字段和选项卡标签 | 否。用户填写说明选项卡。
历史记录 | 自定义字段和选项卡标签 | 否。Issue Manager 填写历史记录选项卡，但您可自定义操作列。请参阅当前状态信息。
客户 | 自定义字段和选项卡标签 | 否。用户可采取预定义的添加客户操作。
自定义选项卡 | 创建自定义选项卡 | 是。请参阅编辑自定义字段。
  • 自定义字段和选项卡标签
    介绍如何自定义标准问题字段、选项卡标签和自动字段。
  • GUI 自定义属性
    列出确定问题详细信息页面上的字段外观和使用的属性。
  • 自定义选项卡和字段
    介绍 Issue Manager 中的自定义选项卡和字段。
父主题： Issue Manager 管理
相关概念
路由规则
原因代码
操作属性
当前状态信息
自定义选项卡和字段
用户定义的操作字段选项卡
相关任务
自定义工作流状态
编辑产品
编辑版本
编辑平台
编辑组件


自定义字段和选项卡标签

注： 您需要 GUI customization 权限才可执行本主题中介绍的操作。
本主题介绍如何自定义标准问题字段、选项卡标签和自动字段（操作版本字段除外）。 有关自定义操作版本字段的信息，请参阅标准操作字段选项卡。 您不能删除这些字段，也不能添加字段。 但是，您可更改这些字段的属性。 例如，您可编辑其标签，选择其模式以及限制有权填充或修改这些字段的组。

修改标准问题字段和选项卡标签：

  1. 在菜单中，单击问题 > 配置。
  2. 单击标准问题字段。 此时将打开标准问题字段页面。
    注： 标准问题字段页面和问题详细信息页面的布局类似。
  3. 如果要重命名选项卡标签，请执行以下操作：
    1. 单击要编辑的选项卡的链接。 将打开编辑标签对话框。
    2. 根据需要修改选项卡的名称。
    3. 单击确定。
  4. 如果要编辑字段的属性，请执行以下操作：
    1. 单击要编辑的任何字段的链接。 将打开编辑字段属性对话框。
    2. 根据需要修改字段的属性。
    3. 单击确定。
父主题： 自定义问题详细信息页面
相关参考
标准操作字段选项卡
GUI 自定义属性


GUI 自定义属性

问题详细信息页面上的字段具有确定其外观和使用的属性。例如，属性可指定字段的标签和控件类型（如字段为复选框还是文本字段）。您可在编辑字段属性对话框中查看和编辑字段的属性。要访问编辑字段属性对话框，请在问题 > 配置 > 自定义问题选项卡或问题 > 配置 > 自定义字段池中，单击要编辑的字段链接。
可更改以下属性：
属性
说明
标签
字段标签文本，最多 20 个字符。如果要将标签与其关联内容分离，请添加一个冒号。不允许特殊字符。
控件类型
仅当创建用户定义的字段时才处于活动状态。控件类型可为复选框、日期、文本字段或弹出列表。
用例映射
仅当控件类型为文本字段时才处于活动状态。确定用户输入到文本字段的字符的用例。可用值为上、下和无。
列表名称
仅针对用户定义的弹出列表才处于活动状态。选择为此弹出列表定义值的自定义列表名称。
新问题或操作 - 模式
介绍用户报告新问题时的字段角色。
值 | 说明
必填 | 必须具有值。
可选 | 可以有值，也可以为空。
只读 | 无法编辑。
新问题或操作 - 组权限
当模式为必填或可选时处于活动状态。权限定义可在此字段中输入值的组。
  • 全部将权限授予所有组。
  • 选定将权限限制到从列表框中选择的组。如果字段为必填或可选且权限限制到已选定的组，则该字段对于所有剩余组均为只读。
现有问题或操作 - 模式
介绍用户编辑现有问题时的字段角色。
值 | 说明
必填 | 必须具有值。
可选 | 可以有值，也可以为空。
只读 | 无法编辑。
提示： 复选框不能为必填字段。如果需要必填字段，则考虑将其定义为具有两个相对值（如，是和否）的弹出列表。
现有问题或操作 - 组权限
当模式为必填或可选时处于活动状态。权限定义可在此字段中输入值的组。
  • 全部将权限授予所有组。
  • 选定将权限限制到从列表框中选择的组。如果字段为必填或可选且权限限制到已选定的组，则该字段对于所有剩余组均为只读。
记住上一个问题输入的值
选中此复选框以使问题详细信息页面显示最后选择的值。例如，假定已选中产品字段复选框。当用户报告问题时，首先从保留该值的产品列表框中选择一个值（例如质保部合作伙伴），以便在用户下次报告问题时，产品字段默认显示为质保部合作伙伴。
父主题： 自定义问题详细信息页面


自定义选项卡和字段

Issue Manager 允许您为每个自定义选项卡最多定义 10 个用户定义字段。

自定义选项卡

默认情况下，问题详细信息页面上的自定义选项卡 1 包含三个字段。您可向此选项卡添加字段、编辑默认字段或删除字段并从头开始。

下表介绍自定义选项卡 1 上的默认字段：
字段 | 指定 | 模式 | 控制类型/值
自动？ | 问题在回归测试中是自动还是手动。 | 可选 | 复选框。默认为未选中状态。
添加发行说明？ | 是否需要将此问题上的项目添加到产品的发行说明。 | 可选 | 复选框。默认为未选中状态。
更新文档？ | 是否需要更新与此问题相关的文档。 | 可选 | 复选框。默认为未选中状态。

自定义选项卡 2 至 4 为空。

自定义字段

自定义字段可显示在以下两个位置：
  • 问题详细信息页面的自定义选项卡上。
  • 当用户对问题采取操作时打开的操作对话框上。
要创建或编辑自定义字段，请执行以下操作：
  1. 在菜单中，单击问题 > 配置。
  2. 单击自定义问题选项卡。此时将打开自定义问题选项卡页面。
  3. 单击要编辑的自定义字段。按照 GUI 自定义属性中的说明继续操作。
父主题： 自定义问题详细信息页面
相关概念
自定义问题详细信息页面


自定义工作流

本节中的主题介绍与 Issue Manager 中的工作流相关的关键概念。 同时还介绍了三种默认工作流以及如何编辑这些工作流。

  • 操作驱动的工作流
    简单介绍概念。 应作为一个片段写入。 包含不多于两个句子。
  • 默认工作流
    介绍默认工作流。
  • 开发您自己的工作流
    包含介绍如何开发您自己的工作流的主题。
  • 工作流状态自定义
    介绍如何自定义工作流状态
  • 自定义操作、原因代码和操作对话框
    介绍如何自定义操作、原因代码和操作对话框。
  • 操作属性
    介绍操作属性。
  • 智能助理
    介绍一组默认的状态/原因代码。
父主题： Issue Manager 管理


操作驱动的工作流

Issue Manager 通过操作驱动的工作流管理其整个生命周期内的问题。 操作驱动的工作流意味着通过用户操作将问题从一种状态（条件）推进到另一种状态（条件），直至问题到达终端或结束状态。

注： 工作流必须至少有一种终端状态，即，工作流中的最后状态。

示例

在默认工作流中，客户支持所报告的新缺陷会被视为处于未审阅状态，这种情况意味着没有任何人确认该“问题”是一个真正的缺陷。 评估情况之后，质保部工程师确认该问题是一个缺陷并准备将其发送给开发人员进行修复。 在此示例中，初始状态是未审阅，采取的操作是确认并且下一个状态是开发部准备就绪。

另一方面，如果已输入相同的问题，则将对此未审阅问题采取的操作是标记为重复，并且下一个状态将可能是已关闭。 因此，对此未审阅问题采取的不同操作会将问题发送到不同状态，在此情况下是已关闭。

有时候，即使已对问题采取操作，它们仍保持其当前状态。 事实确实如此，例如，允许用户向现有问题的说明添加注释的添加注释。

系统提供的操作

Issue Manager 为每个工作流中的每种状态提供了两种预定义操作：
重新分配
允许用户将问题路由到另一个收件箱。
编辑
允许用户修改问题详细信息页面上的字段。

这些操作不会在工作流中移动问题，因此它们不会更改问题的当前状态。

操作信息

工作流定义了可在状态上执行的一组有效操作。 这些操作可在工作流页面上进行查看。 可用操作根据从列表中选择的问题类型和当前状态而不同。

操作以按钮形式显示在问题详细信息页面上。 可用按钮（操作）因问题的类型和当前状态而不同。

状态信息

状态信息贯穿整个 Issue Manager。 例如，每个组和用户帐户分配有三个初始问题状态，每个问题类型一个状态：缺陷、增强和文档问题。

初始问题状态影响问题生命周期

问题的初始状态取决于报告问题的用户对此类问题的了解程度。 例如，当技术支持组成员报告文档问题时，假定已正确评估并准备好修复，则为其分配的初始状态是开放文档。 但是，当相同人员提交软件缺陷时，不必假定其正确，因此，它在工作流中的第一个状态是未审阅。 对于相同类型的问题，不同组可拥有不同初始状态。 有关初始问题状态的更多信息，请参阅“初始问题状态”。

当用户保存问题时，Issue Manager 会根据分配给用户的初始问题状态自动分配问题的初始状态。 当技术作者记录文档问题时，“问题详细信息”页面上的状态字段的值是开放文档。 状态字段是一个自动字段，表示由 Issue Manager 而不是用户根据工作流和其他信息填充此字段。

  • 状态所有者
    介绍状态所有者。
  • 原因代码
    介绍原因代码。
父主题： 自定义工作流


状态所有者

工作流中的每个非终端状态均有一个确切的所有者。 所有者是组织中负责对给定状态的问题执行操作的角色。 考虑未审阅的缺陷：确认或拒绝未审阅软件问题的用户极有可能是执行质保部角色的用户。 因此，未审阅缺陷的状态所有者为质保部角色。

工作流中的终端状态没有所有者，因为此状态的问题不需要用户负责对其执行操作。

在 Issue Manager 中，您可以为非终端状态选择以下四种所有者之一：

  • 质保部
  • 开发部
  • 文档部
  • 增强部
注： 状态所有者不是特定的质保部工程师或特定的收件箱；也与特定产品、组件、版本或平台无关。 状态所有者是状态相关职责的统称。

所有者是状态的重要属性，因为状态所有者和路由规则一起确定接收问题的特定收件箱（路由规则在设置路由规则中有详细说明）。 以下是 Issue Manager 如何使用路由规则、状态和状态所有者将问题移到特定收件箱的示例。

比如，您确定所有软件缺陷未审阅状态的所有者应为质保部角色，而不考虑特定产品和组件等。 履行此角色的用户将确认报告的问题确实是缺陷。 因此，在未审阅状态的状态属性对话框中，选择质保部负责此状态单选按钮。 要访问此状态属性对话框，请转到问题 > 配置 > 工作流，然后单击编辑状态。

现在来考虑特定产品的路由规则。 设置路由规则（问题 > 配置 > 路由规则）时，为产品、组件、版本和平台的每个组合指定四个特定收件箱。 四个状态所有者单选按钮分别对应路由规则页面中的四个收件箱：质保部、开发部、增强部和文档部。

示例

路由规则规定，当缺陷与任何平台上任何版本的产品 C 中的电子邮件组件有关时，将缺陷路由到以下收件箱之一：Mike - 质保部、Sonja - 开发部、Dan - 开发部（产品 C）或 Judy - 文档部。

根据以下两个因素选择四个收件箱之一：问题的当前状态和此状态的所有者。 假设缺陷的当前状态为未审阅，并且您指定了质保部角色负责未审阅的问题，则问题将自动路由到 Mike 的收件箱 Mike - 质保部。

Mike 对问题执行操作时，实际上他会将问题沿其生命周期移到具有其他所有者的其他状态。 Issue Manager 将根据问题的当前状态、状态所有者和特定产品、组件、版本和平台的适用路由规则，重新确定相应的收件箱。

父主题： 操作驱动的工作流
相关概念
设置路由规则


原因代码

Issue Manager 原因代码是可选且可自定义的关键字，用于介绍在执行给定操作时问题状态变化的原因。

许多操作都可导致问题移到相同的状态。 例如，问题可能因各种问题而关闭：不可再生、重复、不是缺陷。 如果没有原因代码提供的额外信息，用户将无法完全了解问题的生命周期。

原因代码也可帮助您减少工作流中的状态数。 例如，用一个称作已关闭的终结状态和各种原因代码足以表示表示操作关闭的原因（如已关闭/不是缺陷），而不用定义多个终结状态 - 不是缺陷、不可再生、重复。

用户可在问题详细信息页面和操作对话框中查看原因代码。 例如，技术文档作者 Judy 的收件箱中收到了文档问题。 阅读说明时，她想起已报告了此问题。 她将问题标记为重复。 打开标记为重复对话框时，她可以看到此问题已从开放文档移至已关闭/重复。 已关闭是新状态，重复是原因代码。

分配、清除或保留原因代码

执行某些操作时，Issue Manager 会将原因代码分配到操作，并将其传递到新状态。 后续操作可能会清除或保留原因代码。 通常，设置原因代码后，它会随问题一起传送，直至其达到工作流中的终结状态。

考虑一下这种情况：开发人员修复缺陷，然后执行已修复操作来声称缺陷已修复。 此操作将缺陷从开发部准备就绪移到质保部准备就绪，并将原因代码设置为已修复。 验证开发人员声称的质保部工程师通过执行已验证操作来接受缺陷修复。 此操作保留已修复原因代码，并将缺陷移到已关闭状态。

但是，当问题返回到工作流中的早期状态时，您可能想清除原因代码，而不是继续进入终结状态。 比如，质保部工程师对开发人员的声称提出争议，并执行拒绝操作，这会将问题发送到开发部准备就绪状态。 已修复原因代码不再有意义，因此您可能想清除拒绝操作的原因代码。

是否分配、清除或保留原因代码均由状态的新建操作对话框中的设置决定，这会在原因代码中说明。 单击 问题 > 配置 > 工作流，然后单击添加操作以查看状态的新建操作对话框

父主题： 操作驱动的工作流


默认工作流

Issue Manager 提供三种默认工作流—针对缺陷、文档问题和增强功能。 如果您要修改默认工作流或创建您自己的工作流，请参阅开发您自己的工作流。

  • 默认缺陷工作流
    包含一个默认缺陷工作流示意图。
  • 默认增强工作流程
    介绍增强工作流程
  • 默认文档工作流
    介绍默认文档工作流。
父主题： 自定义工作流
相关概念
开发您自己的工作流


默认缺陷工作流

下图包含默认缺陷工作流：

此示意图中已省略“编辑”、“重新分配”、“添加注释”和“添加解决方法”操作。

  • “编辑”和“重新分配”是每种状态的预定义操作，不能进行修改。 这些操作不会更改问题的状态。
  • “添加注释”是为所有状态定义的操作，不会更改问题的状态。
  • “添加解决方法”是为“开发部准备就绪”、“质保部准备就绪”、“质保部重新处理”和“已关闭”定义的操作，不会更改问题的状态。

缺陷工作流中的默认原因代码

要查看默认缺陷工作流中提供的所有原因代码，请单击问题 > 配置 > 工作流。 选择 BUG 作为问题类型，然后查看其有效操作和原因代码。

示例

考虑通过默认缺陷工作流的常见路径。 报告缺陷，输入未审阅状态，然后将其发送至质保部工程师的收件箱。 确认缺陷并将其发送至开发人员的收件箱（开发部准备就绪状态）。 开发人员声明修复缺陷并采取已修复操作。 已修复操作将缺陷发送至质保部就绪，并附上原因代码已修复。 收到问题的质保部工程师会验证该缺陷是否已修复。 换言之，他会采取验证操作，该操作会将缺陷发送至已关闭状态，保留已修复原因代码。

现在考虑上述示例中的少许更改。 假设质保部工程师拒绝开发人员声称的已修复缺陷。 缺陷将返回到开发人员的收件箱，但此时的原因代码是已拒绝。 开发人员无法重现问题，因此采取需要更多信息操作。 缺陷转到质保部重新处理。 此时，质保部工程师可采取以下两种操作之一关闭问题—标记为重复或不再是问题，或者质保部工程师可阐明问题并将缺陷发送回开发部准备就绪。

父主题： 默认工作流


默认增强工作流程

下面介绍增强工作流。

此示意图中已省略编辑、重新分配、添加注释和添加解决方法操作。

  • 编辑和重新分配是每种状态的预定义操作，不能进行修改。这些操作不会更改问题的状态。
  • 添加注释是为此工作流中的所有状态定义的操作，不会更改问题的状态。
  • 添加解决方法是为所有状态（未审阅除外）定义的操作，不会影响状态。

增强工作流的默认原因代码

要查看默认增强工作流中提供的所有原因代码，请单击问题 > 配置 > 工作流。选择 ENHANCEMENT 作为问题类型，然后查看其有效操作和原因代码。

示例

假设增强请求已获接受并由最初的一组审阅者（未审阅状态）或管理团队（管理层调用状态）发送到开发部（开发部准备就绪）。如果最初的审阅者采取可能操作，则管理团队会收到增强请求。

如果最初的审阅者或管理团队拒绝增强请求，将关闭问题并附上原因代码已拒绝。此拒绝操作不同于质保部准备就绪状态中的拒绝操作。在后一种情况下，开发操作（已实施、不能执行、已完成或标记为重复）将存在争议。

父主题： 默认工作流


默认文档工作流

下图包含默认文档工作流：

此示意图中已省略编辑、重新分配和添加注释操作。

  • 编辑和重新分配是每种状态的预定义操作，不能进行修改。这些操作不会更改问题的状态。
  • 添加注释是为此工作流中除质保部准备就绪以外的所有状态定义的操作，不会更改问题的状态。

文档工作流中的默认原因代码

要查看默认文档工作流中提供的所有原因代码，请单击问题 > 配置 > 工作流。选择 DOC-ISSUE 作为问题类型，然后查看其有效操作和原因代码。

示例

假设文档问题进入未审阅状态。此时，审阅者可采取三种操作。他可接受问题、拒绝问题或将其标记为另一个问题的副本。如果问题被拒绝或发现是重复的，则将关闭问题并附上原因代码已拒绝或重复。如果审阅者将问题视为需要修复的文档问题，则会将问题移至开放文档状态和文档部收件箱。此时，文档专家可采取以下两种操作之一：采取已修复操作或标记为重复操作。

  • 已修复操作会将问题发送至质保部准备就绪状态，并附上原因代码已修复。
  • 标记为重复操作会将问题发送至已关闭状态，并附上原因代码重复。

如果修复稍后得到验证，则问题将移至已关闭状态，并附上原因代码已解决。另一方面，如果修复被拒绝，则问题将返回到文档部收件箱，并附上原因代码已拒绝。

父主题： 默认工作流


开发您自己的工作流

如果您要开发自己的工作流，最简单可靠的方法就是对默认工作流进行简单修改（例如编辑状态名称）。 强烈建议您修改默认工作流，而不是从头开始创建新工作流，尤其是当您对这些概念的经验不多或没有任何经验时。

您可以自定义的内容包括：

  • 问题通过的状态数量和名称。
  • 对特定状态有效的操作。 这些操作将显示在“工作流”窗口中。
  • 对当前状态执行各项操作所产生的状态；即：
    Current State ---- Action 1 ---> New State 1
Current State ---- Action 2 ---> New State 2
  • 有权执行各项操作的组。
  • 当用户对问题执行操作时所显示的操作对话框的外观。

前提条件

让自己熟悉状态图和操作（也称为状态过渡）的概念。

  • 绘制状态图
    介绍如何绘制状态图。
  • 使用动词为操作命名
    为操作指定动词，以建立易于理解的工作流模型。
  • 优化工作流
    介绍如何优化工作流。
  • 添加状态负责人和权限
    介绍添加状态负责人和权限的原因。
  • 准备数据输入表
    介绍自定义工作流的数据输入表的外观。
父主题： 自定义工作流


绘制状态图

在白板或纸张上绘制状态图。确保在框内绘制每个状态，并使每个状态之间保持充足间距。

将状态之间的每项合法操作绘制为带单个箭头的线条。每个方向即为一项明确的操作。

示例

以下示例是您自己的工作流中可能具有的状态的小规模示例。在输入新缺陷后，您组织内的某个人员会将该缺陷分配给相应的质保部工程师以进行审查。如果质保部工程师同意所报告的行为是新缺陷，则它会发送到开发部以进行修复。开发部可对该缺陷执行多种可能的操作。

  • 缺陷报告中描述的行为是预期行为，因此该问题不是缺陷。
  • 该缺陷应推迟到下一次发行。
  • 该缺陷无法重现。
  • 该缺陷已修复。

当然，这些只是开发人员的声明，尚未得到验证。您的工作流模型可能会通过以下状态来反映这些声明：已修复？、已推迟？、无法重现？和不是缺陷？问号表示这些声明尚未经过质保部工程师的验证。

父主题： 开发您自己的工作流


使用动词为操作命名

建议您为每个操作指定一个动词。考虑缺陷返回工作流中的上一状态的时间。为这些负操作建模。例如，质保部工程师可能会拒绝开发人员的声明，这样会将问题返回给开发部。

在考虑问题可能经历的每种方式时，您可能还会发现缺少的正操作。例如，您意识到质保部工程师也拒绝了某些问题报告，这实际上关闭了问题。在以下示例图中，由质保部工程师执行的“拒绝缺陷”操作导致出现“不是缺陷”状态。确保所有操作最终均导致终端状态。

修订的状态

父主题： 开发您自己的工作流


优化工作流

正如您所看到的，前面的图在使用时太过复杂。要简化工作流，您可以消除“分发”操作，因为 Issue Manager 中的路由规则会负责将缺陷分发到正确的收件箱。在前面的图中，您可以删除“新缺陷”状态和“分发”操作，并以质保部工程师可以审查的状态开始缺陷。您可调用此“未审阅”状态。

工作流中的另一个缺点就是虚拟重复状态。使用 Issue Manager 的方法，您可以通过为操作分配原因代码来消除冗余状态。对于需要原因代码的每个操作，请设计简短的说明性关键字。对于原因代码的完整说明，请阅读“原因代码”。要识别冗余，请在工作流中查找重复模式。例如，在前面的图中，最后一行的状态（不是缺陷、已推迟、不可重现和已修复）可以折叠到一个状态“关闭”，并显示每个操作的不同原因代码（例如已关闭/不是缺陷、已关闭/已修复）。

倒数第二行也可以折叠到单个状态，它可在验证开发部的声明时识别质保部的角色。您可以将此状态称为“质保部准备就绪”。您可以在此处使用原因代码来说明缺陷更改状态的原因（例如缺陷进入“质保部准备就绪”状态，并显示原因代码“已修复”或“已推迟”）。由质保部执行的四个“已拒绝”操作可以折叠到单个“已拒绝”操作。同样，由于质保部执行的四个“已验证”操作可以折叠到单个“已验证”操作。

示例

父主题： 开发您自己的工作流


添加状态负责人和权限

问题会根据问题状态和状态负责人进行路由。 状态负责人是组织中的一种角色，负责处于给定状态的问题。 例如，在默认工作流中，质保部负责处于“未审阅”状态的问题。

现在，您必须为最终图表中的每种状态分配所有者。 最后，决定有权采取每个操作的组。 例如，在默认工作流中，只有开发部的用户允许修复问题（即，采取“已修复”操作）。

父主题： 开发您自己的工作流


准备数据输入表

也可以准备表来促进到 Issue Manager 的数据输入。按状态输入工作流信息，因此第一列应为当前状态和所有者。然后添加以下列标题：

  • 当前状态下允许的操作。
  • 每项操作所产生的新状态。
  • 原因代码（如果适用）。
  • 权限 - 允许执行每项操作的组。

您的数据输入表应类似于下表：

状态/所有者 | 操作 | 新状态 | 权限
父主题： 开发您自己的工作流


工作流状态自定义

您可以在默认工作流中修改状态的名称、所有者和说明。 您可以立即输入或修改所有状态，然后添加每个状态的所有操作。 您也可以在进入下一状态或操作前输入一个状态及其所有操作。

  • 状态属性
    介绍状态属性。
  • 自定义工作流状态
    介绍自定义工作流状态的过程。
父主题： 自定义工作流


状态属性

状态具有以下属性：

状态名称
所需的唯一状态名称，最长 20 个字符。 不允许特殊字符。
说明
状态的可选说明；无实际长度限制。
状态所有者
通过选择相应的选项来选择状态所有者：
  • 质保部负责此状态
  • 开发部负责此状态
  • 文档部负责此状态
  • 增强状态
  • 无人（终端状态）
父主题： 工作流状态自定义


自定义工作流状态

您必须拥有 Workflow customization 安全权限才能执行这些任务。
  1. 单击问题 > 配置 > 工作流。 将显示工作流页面。
  2. 选择表示要自定义的工作流的问题类型。
  3. 按下述操作继续处理任务：
    将新状态添加到此工作流

    单击添加状态按钮。 继续执行步骤 4。

    编辑此工作流中的状态

    从状态列表中选择要编辑的状态。 单击编辑状态按钮。 继续执行步骤 4。

    为此工作流中的状态添加操作

    请参阅自定义操作、原因代码和操作对话框。 从步骤 3 开始此过程。

    删除此工作流中的状态

    从状态列表中选择要删除的状态。 单击删除按钮。 选择确认对话框上的是。 Issue Manager 只会删除问题从未引用过的状态。

    修改其他工作流
    返回步骤 2。
  4. 使用状态属性中所述的信息引导您指定或修改状态的属性。
父主题： 工作流状态自定义
相关任务
自定义操作、原因代码和操作对话框


自定义操作、原因代码和操作对话框

仅当您想要修改了解默认工作流中所述默认工作流中的操作时阅读本节。 继续之前，请阅读操作属性。
  1. 单击问题 > 配置 > 工作流。
  2. 从问题类型列表中选择要自定义的工作流。
  3. 从状态列表中选择具有要修改操作的状态。
  4. 工作流页面此时显示您将在此过程中输入的信息：
    • 适用于此状态的所有操作（它们显示在 ButtonLabel 列中）。
    • 采取给定操作时遵循当前状态的状态。
    • 每个有效操作的原因代码（如果适用）。
    注： Issue Manager 为所有状态预定义的“编辑”和“重新分配”操作无法修改，因此不会显示在对话框中。
  5. 按下述操作继续处理任务：
    为当前状态添加操作
    单击添加操作并继续执行步骤 6。
    为当前状态编辑操作
    从按钮标签列中选择要编辑的操作。
    将新状态添加到此工作流
    返回如何自定义工作流状态的步骤 3。
    更改工作流中的操作排序次序

    在列表中单击要上移或下移的操作的上移和下移按钮（位于操作列中）。

    删除其他工作流中的操作
    单击待删除操作的删除按钮（位于操作列中）。 然后单击确认对话框上的是。
    注： Issue Manager 只会删除问题从未引用过的操作。
    修改其他工作流中的操作
    返回步骤 2。
    修改其他工作流中的状态
    返回如何自定义工作流状态的步骤 2。
  6. 在状态的新操作对话框上指定或修改现有操作的属性。 将操作属性中的信息用作指南。
父主题： 自定义工作流
相关概念
操作属性
相关任务
自定义工作流状态


操作属性

定义工作流中的状态之后，您必须定义与每种状态相关操作。 例如，对于默认缺陷工作流中的开发部准备就绪状态，开发人员可采取已修复操作、无法修复操作，等等。

每个操作都有一组与其相关的属性。

常规属性

操作的属性各不相同，并且涵盖以下方面：

  • 显示在问题详细信息页面上的按钮标签。
  • 显示在历史记录选项卡上的操作说明。
  • 由此操作产生的新状态。
  • 原因代码。
  • 操作对话框的外观和使用。
  • 允许采取此操作的组。
  • 此操作的排序次序。

“状态的操作”对话框。

操作属性可在状态的编辑操作对话框中进行设置。 （问题 > 配置 > 工作流）。

  • 当前状态信息
    介绍当前状态信息。
  • 新状态列表
    介绍新状态列表。
  • 标准操作字段选项卡
    介绍操作属性的标准操作字段选项卡。
  • 用户定义的操作字段选项卡
    介绍操作属性的用户定义操作字段选项卡。
  • 权限选项卡
    介绍操作属性的权限选项卡。
父主题： 自定义工作流
相关任务
自定义操作、原因代码和操作对话框


当前状态信息

名称
无法编辑。 显示您正在定义或修改操作的当前状态的名称（例如，状态的编辑操作 - 未审阅）。
按钮标签
这是执行此操作的按钮上显示的名称，位于问题详细信息页面上且长度为最多 30 个字符。
历史记录操作代码
已采取操作的简短语句，长度为最多 20 个字符。 建议您使用大写字母（例如，VERIFIED）。 此代码显示在问题详细信息页面的历史记录选项卡上的操作列中。
工具提示
在用户将光标扫过此操作按钮时将显示为工具提示的可选文本。
说明
此操作的可选说明。
父主题： 操作属性


新状态列表

名称
对问题执行此操作时，工作流中的下一状态名称。 例如，在默认工作流中，如果未审阅的问题确认为缺陷，则 Issue Manager 会将问题移到下一状态，即开发部准备就绪。
原因代码
可选关键字，用于说明当执行此操作时某个问题从当前状态更改为新状态的原因。 选择相应的选项：
无更改
“无更改”表明当问题移到新状态时关键字得以保留。 它显示在“问题详细信息”页面的“原因代码”字段中。 例如，以下工作流显示当开发人员声明已修复缺陷时，该缺陷将移到“质保部准备就绪”，并显示原因代码“已修复”。 如果质保部工程师已验证该声明，则该缺陷将移到“关闭”状态，同时保留“已修复”原因代码。 浏览问题的任何用户通过查看原因代码即可了解关闭缺陷的原因。
清除
表明当问题移到新状态时将清除当前状态的原因代码。 当问题返回工作流中的上一状态时（例如，当开发人员声明已修复缺陷时，该缺陷将移到质保部准备就绪，并显示原因代码“已修复”），“清除”是一个合理的选择。 但是，如果“修复”被拒绝，则该问题将发回开发部（开发部准备就绪）并且将删除已修复原因代码，因为此声明具有争议。 当您选择清除时，工作流将在原因代码字段中显示清除；但是，用户将在问题详细信息页面上看到空的原因代码字段。
设置为

表明您可以将原因代码与此操作关联。 输入最多包含 20 个字符的关键字。 建议使用全大写字母。 使用设置为可在操作将问题移到需要原因代码的新状态时指定原因代码。 一般来说，您应该为开发人员执行的所有操作分配原因代码。

例如，在默认工作流中，开发部准备就绪状态的已修复操作会将问题发送到质保部准备就绪状态，并且原因代码为已修复。 在人员行为方面，这意味着当开发人员声明已修复缺陷后，他会将其交给质保部工程师，现在后者可以轻松扫视问题详细信息页面以查看该缺陷为何发送到他/她的收件箱（如果开发人员无法修复它或者软件是按设计工作，缺陷也可能位于此处）。

如果您未使用原因代码

原因代码是有助于最大程度减少工作流中的状态数的可选关键字。 例如，如果原因代码有助于说明问题处于关闭状态的原因，一个终端状态就已足够，而无需定义多个关闭状态（不是缺陷、不可再生、无法重现和重复）。 如果您决定不使用原因代码，则您可能需要具有多个终端状态。 通过选择称为无人（终端状态）的单选按钮，（它将在状态属性对话框的状态所有者字段中显示为选择），可将某个状态设为终端状态。

父主题： 操作属性


标准操作字段选项卡

状态的新建操作对话框上的标准操作字段选项卡定义与操作对话框的使用和外观相关的属性，具体为：

  • 操作对话框上的操作注释字段。
  • 操作对话框上的版本信息。
  • 操作对话框上相关问题的相关问题号。
操作注释
未使用
用户执行此操作时，操作对话框不会显示操作注释字段。
可选
操作对话框将显示操作注释字段。 用户可以选择输入与其执行的操作有关的额外信息。
必填
操作对话框显示操作注释的必填字段。 用户必须在此字段中输入有关操作的额外信息。
版本信息
此组允许您将列表显示在操作对话框上，用户可从此对话框中选择在其中执行此操作的版本。 用户选择的版本也会出现在问题详细信息页面的一个自动字段中。 此信息对某些操作（例如与确认、修复和验证问题相关的操作）尤其有用。 此信息对不更改当前状态的操作没有用。 版本信息字段具有以下四个值之一：
未使用
操作对话框不显示列表。 添加注释操作的操作对话框没有版本信息的列表框，因为添加注释操作不需要版本信息。

如果您选择未使用，例如，如果用户没有在操作对话框上的可选列表框中提供信息，或尚未执行使用列表的操作，则问题详细信息页面将显示空的操作版本字段。

可选或必填
操作对话框将显示用户从中选择版本的可选或必填列表。 问题详细信息页面中的上个自动字段将显示在其中执行操作的版本。 您需要指定列表标签才可使之适合操作。 标签长度最多 20 个字符，包括尾部冒号。 默认字段标签为确认位置：用于确认操作；修复于：用于修复操作；以及验证位置：用于验证操作。 标签同时出现在操作对话框和问题详细信息页面上。 列表值从管理模块中指定的版本列表中派生。
已清除
问题详细信息页面的上个自动字段中的前一个值将被删除，并且字段标签还原为默认值，即操作版本。 版本信息组中的标签字段被禁用。 当操作导致问题返回工作流的上一个状态时，已清除是不错的选择。 默认工作流中的示例为拒绝和重新打开缺陷操作。 例如，开发人员执行已修复操作，并在修复于字段中填写特定版本号。 此操作会将问题发送到质保部准备就绪状态。 负责问题的质保部工程师拒绝开发人员对缺陷已修复的声称。 拒绝操作可将问题从当前状态（质保部准备就绪）移到工作流中的上一个状态（开发部准备就绪）。

清除操作的原因代码时，请考虑将已清除选为版本信息字段的值。

用户在操作对话框上选择的版本将出现在问题详细信息页面上。 例如，用户执行已修复操作时，从“修复于”列表框中将 4.1:prod 选择为版本，并单击“确定”。 当问题详细信息页面重新出现时，“修复于”字段将显示选定的版本。

相关问题号
允许您将文本字段置于操作对话框上，用户可从中输入副本或相关问题的编号。 当用户在缺陷工作流中执行标记为重复操作，或在增强工作流中执行已完成操作时，此信息非常有用。
未使用
文本字段不会出现在操作对话框中。
可选或必填

可选或必填文本字段将出现在操作对话框中。 您需要指定文本字段标签。 标签长度最多 20 个字符，包括尾部冒号。 缺陷工作流中的默认字段标签为编号副本。 增强工作流中的默认字段标签为另请参阅。

用户在操作对话框中指定的问题号将出现在问题详细信息页面的历史记录选项卡的注释字段中。 例如，用户对 8 号问题执行标记为重复操作时，将 6 号问题指定为重复，并单击确定。 问题详细信息页面重新出现时，注释字段将显示短语与问题号 n 相关，此处 n 是编号副本字段的值。 如果编号副本字段可选，并且用户未填写此字段，则注释字段将显示操作注释字段的内容。

父主题： 操作属性


用户定义的操作字段选项卡

状态的新建操作对话框的用户定义的操作字段选项卡让您可以将字段添加到给定操作的操作对话框。

八个字段位置
这些字段出现在操作对话框中，标准操作字段除外。字段 1 - 字段 4 出现在操作对话框的左下角。字段 5 - 字段 8 出现在右下角。例如，对处于开发部准备就绪状态下的已修复操作，可以从操作对话框第一个字段位置（字段 1）中出现的列表选择修复所需的小时数字段。
来源
由于以下两个原因之一，字段出现在用户定义的操作字段选项卡的列表框中：
  • 自定义字段通过问题 > 配置 > 自定义问题选项卡创建，以定义还会在自定义选项卡的问题详细信息中显示的自定义字段。
  • 自定义字段通过问题 > 配置 > 自定义字段池创建，这些字段仅与操作相关。
在操作对话框中定义字段
  1. 单击问题 > 配置 > 自定义问题选项卡以定义字段，这些字段也会在自定义选项卡的问题详细信息中显示。您也可以使用通过问题 > 配置 > 自定义字段池创建的自定义字段，这些字段仅与操作相关。
  2. 按 GUI 自定义属性中的说明配置字段属性。
  3. 然后可以从用户定义的操作字段选项卡的列表框中选择您创建的自定义字段。
父主题： 操作属性
相关概念
自定义问题详细信息页面


权限选项卡

在权限选项卡上，您可以为单个操作设置安全性，从而限制选定用户组的操作。

默认情况下，应用安全性的值为否（这意味着所有组有权限执行所有操作）。 此设置出现在工作流页面（作为所有组）。 您可以通过选择是选项，然后选择有权限执行此操作的一个或多个组来设置安全性。

请考虑该定义操作安全性的示例：开发人员打开开发部准备就绪状态的缺陷的问题详细信息页面时，无法修复操作可用。 但是，非开发人员的用户打开相同缺陷的问题详细信息页面时，此操作被隐藏。

父主题： 操作属性


智能助理

为处理测试结果，智能助理使用一组默认的四对状态/原因代码，它们与默认缺陷工作流定义的四种一般状态相对应。

要查看这些默认状态和原因代码：

  1. 单击配置 > 智能助理。
  2. 一般缺陷状态和特定 Issue Manager 代码之间的自定义映射。

    如果已自定义问题的默认工作流，则也必须自定义用于处理结果的状态和原因代码。 例如，如果管理员更改默认工作流以便为声称已修复的问题分配状态未审阅，则他还必须将声称已修复但尚未测试的缺陷的状态条目从质保部准备就绪更改为未审阅。

    除了在“智能助理”页面上指定的问题状态和原因代码外，智能助理还使用为问题工作流定义的终端状态。 终端状态在“工作流”页面上定义。 默认终端状态为已关闭。

父主题： 自定义工作流


问题存档

在使用 Issue Manager 一段时间后，您可能会发现数据库中存在与您的工作不相关的问题（例如已关闭或与不受支持产品相关的问题）。 数据库中的问题越多，执行操作（例如查询）的时间就越长。 为帮助您提高性能，您可以存档问题。 您随后可以对较少的活动（非存档）问题执行操作。

当您存档问题时，Issue Manager 会将问题从 DEFECT 和相关表格移到 ARCHIVE 和相关表格。 所有问题信息都会保留。 （通过比较，活动问题将保留在 DEFECT 表中，用户可以对其执行常规操作。）

用户可以在问题详细信息页面上查看已存档的问题，但是不能对其执行任何操作，因为它们为只读。 已存档的问题不会显示在用户的收件箱中。 但是，用户仍可以对已存档的问题运行查询、报告和图形。 存档会在数据库中“隐藏”问题，但不会删除它们。

注： 强烈建议您不要手动删除问题，因为这样做可能会破坏数据的完整性。

但是，您可能希望通过创建仅从原始数据库中导入活动问题或相关信息的新自定义数据库，使生产数据库变得更小。

如果您将用户桌面上显示（但未编辑）的问题存档，用户将无法知道所做的更改，除非注销并重新登录、退出并重新启动或尝试对问题执行操作。

注： Issue Manager 将警告用户不能对已存档的问题执行任何操作。
  • 存档问题
    介绍如何存档问题
父主题： Issue Manager 管理


存档问题

存档问题：

  1. 在菜单中，单击问题 > 配置 > 存档。
  2. 选择与要存档问题相关的产品。
  3. 版本字段会自动填充与所选产品相关的版本。选择与要存档问题相关的特定版本。 您可通过选择多个版本存档与多个版本相关的问题。使用 Ctrl+单击选择单个版本，或使用 Shift+单击选择一系列版本。
  4. 单击存档按钮。
  5. 单击确认对话框上的是以开始存档过程。
父主题： 问题存档


设置电子邮件通知规则

通过电子邮件通知，您可以指示 Issue Manager 在感兴趣的事件发生时（例如问题更改状态时）自动通知您或组织中的其他人。

电子邮件通知规则

发生以下事件时，用户可请求向其发送电子邮件：

  • 将问题重新分配到其他收件箱。
  • 将问题从一个工作流状态移到另一个（例如，从未审阅到开发部准备就绪。
  • 对在问题历史记录中生成新条目的问题做出任何更改（例如，报告问题所针对的组件发生改变）。
  • 您定义的任何其他特殊事件（例如，技术支持人员希望在修复特定缺陷时收到电子邮件）。

以上所列事件简称为规则。前三个规则为预定义规则，无法修改。您可以为所需的特殊事件定义各种其他规则。

通知

电子邮件通知可指示 Issue Manager 在问题发生特定事件时发送电子邮件。通知由指定事件的电子邮件通知规则、电子邮件的发件人和收件人、邮件正文、可选主题行、简介和追踪者组成。

用户必须将通知应用到每个感兴趣的问题。只有拥有每个问题的电子邮件通知权限的用户可以向单个问题添加通知。

要查看问题的通知，请单击问题的问题详细信息页面的通知图标。

规则也可在应用到数据库中所有问题的通知中使用；这些是系统级通知。

只有拥有电子邮件通知规则和系统级通知安全权限的用户可以添加系统级通知。
  • 定义电子邮件通知规则
    介绍如何定义电子邮件通知规则。
  • 管理电子邮件通知规则
    介绍如何管理电子邮件通知规则。
  • 删除收件箱
    如果收件箱不包含任何问题、未在路由规则中引用并且不是用户的默认收件箱，则可以删除该收件箱。
  • 管理系统级通知
    介绍如何管理系统级通知。
父主题： Issue Manager 管理
相关概念
电子邮件通知


定义电子邮件通知规则

先决条件

要定义您自己的规则，您必须：

  • 拥有电子邮件通知规则和系统级通知权限。
  • 熟悉 SQL，尤其是如何编写 WHERE 子句。
  • 熟悉数据库架构，特别是问题相关视图和表的列、IM_V_Defects 和 IM_DefectHistory。
  • 熟悉您的工作流和工作流中的值。

编写 SQL WHERE 子句的提示

此处提供一些重要提示，它们将帮助您编写在语法和语义上均正确的 WHERE 子句。

引用 IM_V_Defects 和 IM_DefectHistory

您的 SQL WHERE 子句可能需要引用 IM_V_Defects 和 IM_DefectHistory。IM_V_Defects 视图存储有关问题的最新信息，而 IM_DefectHistory 表则保留针对某个问题所执行的所有操作记录，以及对某些问题字段执行相关更改所产生的影响。

例如，IM_DefectHistory 存储执行操作之前问题的收件箱分配以及执行操作之后的收件箱分配。对于执行操作之前的收件箱分配，这些列为 AssignedIN，而对于新收件箱则为 AssignedOUT。

对问题执行的所有操作都将记录在 IM_DefectHistory 表的 ActionCode 字段中。这些操作将在历史记录选项卡的操作列中显示为操作代码。您可能在示例数据库中注意到诸如“已修复”和“已验证”之类的代码。

要在数据库中查看大多数操作的操作代码，请查看每个状态（“已输入”、“已重新分配”和“已修改”除外，它们采用硬编码，无法进行查看）的状态的编辑操作对话框。要访问某个状态的状态的编辑操作对话框，请转至问题 > 配置 > 工作流，然后单击按钮标签列中的状态名称。在历史记录操作代码字段中查看值。

使用别名
视图和表已有别名。您必须使用别名 D 来引用 IM_V_Defects 视图，并使用别名 DH 来引用 IM_DefectHistory 表。
标识自定义字段

自定义字段在 IM_V_Defects 视图中标识为 Custom1、Custom2 等，具体取决于其在表中的位置。每个自定义选项卡最多具有 10 个字段，1-10 、11-20，以此类推。在自定义选项卡 1 上，前 5 个字段在左列按降序显示；字段 6 至字段 10 在右列按降序显示。

要找出特定自定义字段的架构名称，请转至问题 > 配置 > 自定义问题选项卡。例如，在示例数据库的对话框中，添加发行说明？复选框是自定义选项卡 1 左列中的第四个字段，问题表中的 Custom4 也是如此。

注： 如果您更改自定义字段的位置，那么您需要更新引用该字段的任何电子邮件通知规则。
不会跟踪对自定义字段所做的更改
Issue Manager 不会跟踪对 IM_DefectHistory 表中的自定义字段所做的更改。您可以检查自定义字段的当前值，但是不能引用上一个值。例如，WHERE 子句可测试是否已选中添加发行说明？复选框，但是不能捕获复选框值的更改（从未选中变为选中）。
访问复选框值

取消选中的复选框的值为“’.”（句点）。选中的复选框的值为“X”（大写 X）。

例如，要检索已选中添加发行说明？的所有问题，可按以下方式指定 WHERE 子句的一部分：

D.Custom4 = 'X'

规则示例

此处提供您可能希望创建新规则的四种情况。前两种情况建议在单个问题的通知中使用的规则。后两种情况建议在系统级通知中使用的规则。以下每个示例均为根据示例数据库编写的 WHERE 子句。

示例 1

技术支持和其他组想要了解将特定缺陷修复验证为“已修复”的时间。

WHERE 子句类似于：

DH.ActionCode = 'VERIFIED'

IM_DefectHistory 表中的 ActionCode 值将会在用户执行操作时得到更新；因此，当“验证”操作导致 IM_DefectHistory 在表和“历史记录”选项卡中输入“已验证”时，技术支持将只会收到一次邮件。

如果子句是通过引用原因代码（在数据库中称为 Disposition）编写的：

D.Disposition = 'FIXED'

几乎可以确定的是，技术支持将多次收到邮件，因为“原因代码”在数据库中仍为“已修复”。随后添加注释或保存问题的用户将触发电子邮件，因为规则仍匹配。

示例 2

未对缺陷执行操作的普通用户希望了解对其输入的缺陷执行的操作。他尤其希望在缺陷得到开发人员的注意时收到电子邮件。在工作流方面，这表示问题仍处于开发部准备就绪状态，因此 WHERE 子句必须测试执行操作后的状态更改。

此 WHERE 子句为：

DH.StatusIN = 'Dev-Ready'
AND DH.StatusOUT <> 'Dev-Ready'

在执行操作之前，状态为开发部准备就绪，但在开发人员执行操作之后，该缺陷将进入其他状态。

示例 3

文档部门已将所有文档问题发送给组收件箱文档部（产品 A），而不是用户的邮箱 Judy -- 文档部。文档部经理希望在问题进入组收件箱时收到电子邮件。

此 WHERE 子句为：

DH.AssignedIN <> 'Doc (Product A)'
AND DH.AssignedOUT = 'Doc (Product A)'

它指定在以下情况下应发送电子邮件：在执行操作之前收件箱并非为文档部（产品 A），但在执行操作之后为文档部（产品 A）。当文档问题路由到文档部（产品 A）时，该电子邮件将只发送一次。

请注意，无 WHERE 子句的第一部分，文档部经理将在对已分配给“文档部（产品 A）”的文档问题执行任何操作时收到电子邮件。虽然该规则很有可能生成大量邮件，但是由于需要在系统级应用通知，两行 WHERE 子句会将规则限制为单个事件：当收件箱变为文档部（产品 A）时。

此规则无需将问题类型指定为 DOC-ISSUE，尽管这可能不正确，因为文档部（产品 A）仅保留与文档相关的问题。

示例 4

发行经理希望在下个月针对无法修复的最严重缺陷发布主要版本之前收到电子邮件。当开发人员执行“无法修复”操作时，WHERE 子句必须测试严重性、产品 B 和已分配的“无法修复”操作代码。

此 WHERE 子句为：

D.Severity = '1: Fatal/Data Loss'
AND DH.ActionCode = 'Cannot-Fix'
AND D.ProductCode = 'Product B'

这些限制是必需的，因为如果 WHERE 子句仅测试严重性，则规则将在任何时候更改和保存问题时匹配，除非用户明确更改严重性，否则严重性不会发生改变。

发行经理可能会收到大量邮件，尤其是在系统级通知中应用此规则时。但是，他可以在发行周期结束后轻松删除通知。

编写 SQL WHERE 子句的提示

从常规到特定情况的使用。首先，请考虑需要使用电子邮件通知规则的常规业务情况。您可能会询问所有 Issue Manager 用户希望何时收到关于问题的电子邮件。具体了解每个用户希望从电子邮件中获取什么信息。例如，某个用户可能告诉您他想要了解缺陷的修复时间。在进一步讨论后，您可能发现他真正想知道的是质保部工程师验证修复的时间。此细微变化可能需要不同的 WHERE 子句。

其次，如果您满意自己掌握的用户需求信息，请根据组织的工作流转换该情况。

最后，编写 SQL WHERE 子句。尝试通过高级查询测试 WHERE 子句，以确保准确指定所需的条件。

一般而言，用于单个问题通知的规则应该采用简单且常规的方式进行编写，而用于系统级通知的规则则应该准确并且尽可能严格以防止出现过多的电子邮件。

询问您自己用户希望接收通知的频率：仅在一次发生更改后或在每次发生更改后。如果用户希望仅触发一次邮件，则需要使规则变得更加严格。

父主题： 设置电子邮件通知规则
相关任务
定义通知规则


管理电子邮件通知规则

您需要拥有电子邮件通知规则和系统级通知安全权限才能添加、编辑或删除电子邮件通知规则。
要添加、编辑或删除电子邮件通知规则：
  1. 单击问题 > 配置 > 通知规则。
  2. 根据您希望执行的任务，按照下述说明继续操作：
    添加规则

    单击添加规则按钮。此时将显示新建通知规则对话框。继续执行步骤 3。

    编辑预定义规则
    无法编辑预定义规则。
    删除预定义规则
    无法删除预定义规则。
    编辑已创建的规则

    单击要编辑的规则的编辑图标（在操作列中）。按照步骤 3 中的说明继续操作。

    删除已创建的规则

    单击要删除的规则的删除图标（在操作列中）。单击确认对话框上的确定以执行删除。

  3. 在新建通知规则对话框上指定或修改以下属性：
    规则名称
    需要提供最多包含 30 个字符的唯一名称。让名称尽可能具有说明性，因为用户将按名称分配规则。
    说明
    最多包含 250 个字符的触发事件的可选说明。
    WHERE 子句
    需要用于指定触发事件的 SQL WHERE 子句，最多 250 个字符。请不要键入 WHERE 关键字
  4. 单击确定以保存您的设置，或单击取消以退出而不保存。

在定义规则后，请确保：

为所有用户指定电子邮件地址
要使用电子邮件通知，用户必须在他/她的用户帐户中指定有效的电子邮件地址。
让您的数据库管理员启用电子邮件通知
启用该功能后，通知图标将显示在问题详细信息页面上。
指导您的用户
向您的用户通知可用的规则以及每个规则完成的操作。用户可通过选择问题 > 配置 > 通知规则来查看规则。
父主题： 设置电子邮件通知规则
相关任务
设置用户帐户


管理系统级通知

以下部分介绍如何管理系统级通知。

注： 您需要拥有电子邮件通知规则和系统级通知安全权限才能添加、编辑或删除系统级通知。
  • 添加系统级通知
    介绍如何添加系统级通知。
  • 编辑系统级通知
    介绍如何编辑现有系统级通知。
  • 删除系统级通知
    介绍如何删除系统级通知。
  • 在通知主题中输入参数
    介绍您可以在通知主题字段中使用的参数。
  • 启用基本电子邮件通知
    介绍如何启用基本电子邮件通知。
  • 显示系统级通知
    介绍如何显示系统级通知。
父主题： 设置电子邮件通知规则
相关任务
定义电子邮件通知
添加系统级通知


添加系统级通知

  1. 单击问题 > 配置 > 系统级通知。 此处列出了所有现有系统级通知。
  2. 单击添加系统级触发器。
  3. 在添加通知对话框上，从列表中选择规则名称。
  4. 在对话框的发件人区域中选择单选按钮，以指明返回地址是否应为：
    • 编辑问题的用户（从而开始通知）。
    • 其他用户（从列表中选择用户）。
  5. 在收件人字段中键入收件人的电子邮件地址，用逗号分隔多个条目。您可从添加地址列表选择用户。
    注： 虽然您可在收件人字段中输入任何电子邮件地址，但只有在其用户帐户中指定了电子邮件地址的用户才会显示在添加地址列表中。因此，建议为所有用户帐户定义电子邮件地址。
  6. 您可填写可选的消息文本字段：
    • 主题是可选主题行（最多 80 个字符）。
    • 简介是可选介绍文本（最多 250 个字符）
  7. 选择消息的内容类型：
    • 内容可以是：
      • 问题摘要：“问题详细信息”页面上半部分的信息。
      • 具有说明的问题摘要：问题摘要及“说明”选项卡中的信息。
      • 完整问题详细信息：所有问题信息（这是默认值）。
    • 追踪者是可选签名字段（长度为最多 250 个字符）。
  8. 单击确定以保存通知并关闭对话框。
要编辑通知，请单击规则名称。要删除通知，请单击操作列中的 [image] （删除系统级通知）。要创建通知副本，请单击 [image] 。
注： 您需要拥有电子邮件通知规则和系统级通知安全权限才能定义系统级通知。
父主题： 管理系统级通知
相关概念
在通知主题中输入参数
管理系统级通知
相关任务
定义电子邮件通知


编辑系统级通知

  1. 单击问题 > 配置 > 系统级通知。 此处列出了所有现有系统级通知。
  2. 单击要编辑的通知的操作列中的编辑图标。
  3. 在添加通知对话框上，从列表中选择规则名称。
  4. 在对话框的发件人区域中选择单选按钮，以指明返回地址是否应为：
    • 编辑问题的用户（从而开始通知）。
    • 其他用户（从列表中选择用户）。
  5. 在收件人字段中键入收件人的电子邮件地址，用逗号分隔多个条目。您可从添加地址列表选择用户。
    注： 虽然您可在收件人字段中输入任何电子邮件地址，但只有在其用户帐户中指定了电子邮件地址的用户才会显示在添加地址列表中。因此，建议为所有用户帐户定义电子邮件地址。
  6. 您可填写可选的消息文本字段：
    • 主题是可选主题行（最多 80 个字符）。
    • 简介是可选介绍文本（最多 250 个字符）
  7. 选择消息的内容类型：
    • 内容可以是：
      • 问题摘要：“问题详细信息”页面上半部分的信息。
      • 具有说明的问题摘要：问题摘要及“说明”选项卡中的信息。
      • 完整问题详细信息：所有问题信息（这是默认值）。
    • 追踪者是可选签名字段（长度为最多 250 个字符）。
  8. 单击确定以保存通知并关闭对话框。
父主题： 管理系统级通知


删除系统级通知

  1. 单击问题 > 配置 > 系统级通知。 此处列出了所有现有系统级通知。
  2. 单击要删除的通知的操作列中的删除图标。
  3. 单击确认对话框上的是以执行删除。
父主题： 管理系统级通知


在通知主题中输入参数

您可以在通知的主题字段中输入参数，以为电子邮件通知生成动态主题。

可以在主题字段中输入以下参数：

{ID}
返回缺陷数
{PROJ}
返回项目名称
{PROD}
返回产品
{COMP}
返回组件
{USER}
返回修改问题的用户
{RULE}
返回触发通知的规则的名称
{SYN}
返回摘要
{STATE}
返回问题的当前状态
{SEV}
返回严重性
{REASON}
返回问题的当前原因代码
{CUSTOM1-40}
返回指定数值的自定义字段，例如 {CUSTOM3} 返回自定义字段 3 中存储的值。

例如，如果您希望创建在问题状态发生更改时向您发出通知的电子邮件通知，您可以将以下文本添加到主题字段：

State of issue {ID} was changed by {user}.

如果 Bill 将修复当前处于活动状态的问题 2，您将收到具有以下主题的电子邮件通知：

State of issue 2 was changed by bpetersson.
父主题： 管理系统级通知


启用基本电子邮件通知

可由任何用户激活的基本通知设置（无论分配的权限如何）允许用户在其他用户对其收件箱中的问题进行更改或将新问题分配至其收件箱时收到通知。

注： 可在 SRFrontendBootConf.xml 文件中配置这些通知的主题行和内容。
  1. 单击配置 > 首选项。
  2. 选中当用户向我分配问题或对我的收件箱中的问题做出更改时通知我复选框。
父主题： 管理系统级通知


显示系统级通知

当用户选中在每个问题的通知对话框中显示系统级通知复选框（问题 > 配置 > 首选项）时，每个问题的通知对话框中将列出所有系统级通知。分配至活动问题的任何通知也会列出。

  1. 单击问题 > 配置 > 首选项。
  2. 选中在每个问题的通知对话框中显示系统级通知复选框。
父主题： 管理系统级通知


报告

  • 报告数据集市
    介绍报告数据集市以及如何利用它快速轻松地创建报告。
  • 报告区域
    介绍报告区域的报告主题。
  • 代码分析
    介绍如何使用 Silk Central 分析代码覆盖率。
  • 默认报告
    介绍默认报告。
父主题： 问题跟踪和结果分析
相关概念
报告 (Issue Manager)


报告数据集市

Silk Central 提供了数据集市，支持轻松访问最重要的数据。由于 SQL 查询得到大幅简化，因此简化了报告的创建，性能也得到了提升。

  • 概述
    介绍报告数据集市的优势。
  • 体系结构
    介绍报告数据集市的体系结构。
  • 如何使用数据集市创建报告
    通过真实示例介绍如何使用数据集市视图创建报告。
  • 故障排除
    解答您在数据集市方面可能遇到的问题。
  • 参考：数据集市表和视图
    介绍可简化和加速报告的数据集市表和视图。
父主题： 报告


概述

Silk Central 报告数据集市使得出于报告目的访问数据更加轻松。它可将数据从生产表移至用于创建高级报告的专用视图。优势包括：
  • 清晰的表和视图命名，允许您迅速找到所需数据。
  • 经过预处理的数据，让您可以访问聚合数据，而无需自行计算。
  • 性能提升，因为报告可以使用更简单、快速的 SQL 查询。
  • 更少的生产数据库负载依赖关系，这也能提高性能，消除负载峰值。
当前版本的数据集市已覆盖结果区域。未来版本的数据集市中将添加更多报告区域。当前提供的表和视图如下：
  • DM_TestStatus 表，这是状态相关视图的基础。
  • RV_TestStatusExtended 视图，提供特定测试执行的详细信息。
  • RV_LatestTestStatus 视图，在执行计划和特定内部版本的上下文中，提供一个测试的最新测试运行的状态和扩展信息。
  • RV_MaxTestRunID 视图，该帮助工具用于检索各测试、执行计划和内部版本组合的最新测试运行 ID。
  • RV_TestingCycleStatus 视图，提供测试周期的状态信息。
  • RV_ExecutionPlanStatusPerBuild 视图，在内部版本的上下文中，检索各执行计划的最新测试状态汇总。
  • RV_ExecutionPlanStatusRollup 视图，在内部版本的上下文中，检索各执行计划或文件夹的通过、失败和未执行测试汇总。
  • RV_ConfigurationSuiteStatus 视图，列出所有配置套件和各内部版本配置的状态计数。
父主题： 报告数据集市


体系结构

定期在后台提取生产数据库表中的数据，并将其加载到数据集市表和视图中，以简化和加速查询。只要数据库负载不过高，通常即可在提交更改后的一分钟之内得到此数据。如果您作为系统管理员登录，可以导航到 http://<server>:<port>/sctm/check/db，检查 DM_TestStatus 表，以查看数据加载过程的当前状态。

注： 如果您从不包含数据集市的 Silk Central 版本（13.0 之前的版本）更新，数据集市表和视图将使用生产系统的数据进行初始填充。此过程可能需要一些时间，具体取决于数据库的大小。此过程完成后即可访问数据。

父主题： 报告数据集市


如何使用数据集市创建报告

以下示例演示了如何使用数据集市视图创建有用的报告。

  • 编写数据集市查询
    编写高级 SQL 查询，以执行报告。
  • 执行计划中的测试可靠性
    说明如何创建报告，列出特定执行计划上下文中特定测试的结果，以允许您查看该测试的结果随着时间推移而变化的情况。
  • 执行文件夹中的所有失败测试
    介绍如何创建报告，列出执行文件夹内的所有失败测试。
  • 测试周期状态
    介绍如何创建按测试工程师和内部版本显示测试周期当前状态的报告。
  • 执行树状态
    介绍如何为特定执行计划文件夹创建报告，以返回按内部版本分组的通过、失败和未执行计数。
  • 配置套件状态
    介绍如何创建为每个内部版本的各配置返回通过、失败和未执行计数的报告。
父主题： 报告数据集市


编写数据集市查询

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中，选择您要新报告在其中显示的文件夹。 这将确定在目录树中存储报告的位置。
  3. 单击工具栏上的 新建子报告 。 此时将打开创建新报告对话框。
  4. 键入新报告的名称。 这是在报告树中显示的名称。
  5. 如果您要将此报告用于其他用户，请选中与其他用户共享此报告复选框。
  6. 在说明字段中键入报告的说明。
  7. 单击高级查询可打开报告数据查询字段。插入先前编写的代码或在字段中直接编写新代码。 插入占位符列表有助于您使用预定义的函数占位符编辑 SQL 查询。有关详细信息，请参阅自定义报告的 SQL 函数。
    注： 如果您手动编辑查询的 SQL 代码，请单击检查 SQL 以确认操作。
  8. 单击完成以保存设置。
父主题： 如何使用数据集市创建报告


执行计划中的测试可靠性

问题

在持续集成环境中，最理想的测试方式是每天至少对每日内部版本执行一次测试，确保所测试应用程序的质量。为了解您的测试集在度量 AUT 质量方面的可靠程度，有时必须要查看结果随着时间推移而变化的情况。例如，您的测试集中可能存在状态频繁更改的测试，因此不具备真正的质量测量。

解决方案

使用数据集市视图 RV_TestStatusExtended创建报告，列出特定执行计划上下文中特定测试的结果。这允许您查看该测试的结果随着时间推移而变化的情况。为方便起见，我们将结果列表缩小至与带标记的内部版本相关的结果，因而可以仅查看所测试应用程序的特定里程碑内部版本。此报告将在执行计划和内部版本的上下文中收集各个测试的测试结果数据。在以下查询中：

  • 选择要从视图中显示的列。
  • 按照希望调查的测试的 ID 以及该测试所属执行计划的 ID 缩小结果范围。
  • 添加约束，以仅考虑带标记的内部版本。
SELECT TestName, ExecutionPlanName, VersionName, BuildName, TestRunID,
  PassedCount, FailedCount, NotExecutedCount
FROM RV_TestStatusExtended
WHERE TestID = ${TESTID|1|Test ID} AND ExecutionPlanID = ${EXECUTIONPLANID|1|Execution Plan ID} AND BuildIsTagged = 1
ORDER BY BuildOrderNumber
SQL 查询的结果将得到选定执行计划内选定测试的所有测试运行。在以下示例中，可以看到对内部版本 579_Drop2 重新运行了测试：
TestName | Execution PlanName | Version Name | BuildName | TestRunID | Passed Count | FailedCount | NotExecutedCount
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 579_Drop02 | 7741797 | 59 | 5 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 579_Drop02 | 7745078 | 63 | 1 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 593_Drop03 | 7787437 | 63 | 1 | 0
UI Tests | EN|SQL2012|IE9|IIS | 3.0 | 605_Drop04 | 7848720 | 63 | 1 | 0
父主题： 如何使用数据集市创建报告


执行文件夹中的所有失败测试

问题

通常所有执行计划都组织在文件夹层次结构中，用于识别执行计划及其测试的不同相关区域或目的。执行计划在持续集成环境中定期触发，或在发布时间范围内不定时触发，以得到理想的执行统计信息 – 遗憾的是，这些信息仅限于每一个单独的执行计划。

有时，您需要获得为特定区域或目的而执行的所有测试的整体信息，以识别薄弱环节。

解决方案

使用数据集市视图 RV_LatestTestStatus创建报告，返回特定执行计划层次级别的所有失败测试列表。

以下查询使用执行计划名称和内部版本名称等上下文信息，选择执行计划文件夹内的失败测试：

SELECT TestID, TestName, ExecutionPlanID, ExecutionPlanName, BuildName
FROM RV_LatestTestStatus lts
INNER JOIN TM_ExecTreePaths ON lts.ExecutionPlanID = TM_ExecTreePaths.NodeID_pk_fk
WHERE TM_ExecTreePaths.ParentNodeID_pk_fk = ${executionFolderID|2179|Execution Folder ID}
  AND StatusID = 2
ORDER BY TestName
该查询执行以下操作：
  • 使用视图 RV_LatestTestStatus 检索最新测试运行结果。
  • 包含执行树层次结构 (TM_ExecTreePaths)，以查询该层次结构内所有执行计划的所有测试。
  • 将应作为分析开始位置的顶层文件夹 ID 用作ParentNodeID_pk_fk。
  • 仅包含失败的测试 (StatusID = 2)。

可以在 TM_TestDefStatusNames 表中查找 StatusID。

SQL 查询的结果将得到选定执行文件夹内上次运行失败的所有测试。
TestID | TestName | ExecutionPlanID | ExecutionPlanName | BuildName
14073 | JUnitTestPackage | 2184 | CI Testing | 352
14107 | Volatile Tests | 2191 | Volatile Test | 352
父主题： 如何使用数据集市创建报告


测试周期状态

问题

测试周期属于复杂的对象，因为其中包含有关手动测试工程师、测试、产品的不同内部版本和版本的信息，甚至还可能包含配置信息。为确保掌控测试周期，必须解答下面这些问题：

  • 已经完成了多少测试？
  • 每个内部版本通过或失败的测试有多少？
  • 我的手动测试工程师是否已满负荷工作？他们能否再承担额外的工作？

解决方案

使用数据集市视图 RV_TestingCycleStatus，创建按测试工程师和内部版本显示测试周期状态的报告，这让您能获得有关按手动测试工程师、配置和内部版本分组的通过、失败、未执行测试数量的概述信息。

SELECT BuildName, TesterLogin, TesterExecutionName,
  PassedCount, FailedCount, NotExecutedCount
FROM RV_TestingCycleStatus
WHERE TestingCycleID = ${testingCycleID|3|Testing Cycle ID}
ORDER BY BuildOrderNumber, TesterLogin
该查询执行以下操作：
  • 使用 RV_TestingCycleStatus 视图作为数据源，其中包含 BuildName、TesterLogin 和 TesterExecutionName，即为反映测试工程师、配置和测试而生成的名称。
  • 将数据限制在您关注的测试周期 ID 范围内。
SQL 查询结果将显示各内部版本和测试工程师的状态。
BuildName | TesterLogin | TesterExecutionName | PassedCount | FailedCount | NotExecuted Count
352 |  | No specific tester (Test Assets) | 0 | 0 | 1
351 | admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 1 | 0
352 | admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 0 | 1
352 | gmazzuchelli | gmazzuchelli (English|Oracle10g|IE8|Tomcat - Test Assets) | 0 | 1 | 1
352 | jallen | jallen (German|Oracle11g|FF|Tomcat - Test Assets) | 1 | 1 | 0
352 | smiller | smiller (German|SQL2008|IE8|IIS - Test Assets) | 1 | 1 | 0

对于未分配的测试，将创建一个“无特定测试工程师”组，并且以下几个值为空值：TesterLogin、TesterFirstName 和 TesterLastName。

如果您想根据手动测试工程师的绩效了解测试周期的情况，可对查询略作修改：
SELECT TesterLogin, TesterExecutionName, SUM(PassedCount) PassedCount,
  SUM(FailedCount) FailedCount, SUM(NotExecutedCount) NotExecutedCount
FROM RV_TestingCycleStatus
WHERE TestingCycleID = ${testingCycleID|3|Testing Cycle ID}
GROUP BY TesterLogin, TesterExecutionName
ORDER BY TesterLogin
查询进行了如下扩展：
  • GROUP BY TesterLogin, TesterExecutionName 表示剩余列。
  • SUM() 是用于聚合数字的计数器。
TesterLogin | TesterExecution Name | PassedCount | FailedCount | NotExecutedCount
 | No specific tester (Test Assets) | 0 | 0 | 1
admin | admin (English|SQL2008|FF|Tomcat - Test Assets) | 0 | 1 | 1
gmazzuchelli | gmazzuchelli (English|Oracle10g|IE8|Tomcat - Test Assets) | 0 | 1 | 1
jallen | jallen (German|Oracle11g|FF|Tomcat - Test Assets) | 1 | 1 | 0
smiller | smiller (German|SQL2008|IE8|IIS - Test Assets) | 1 | 1 | 0
父主题： 如何使用数据集市创建报告


执行树状态

问题

常见的做法是将执行计划置于表示不同测试区域或目的的层次结构中。在某些情况下，例如要了解测试状态，进而确定一个区域或目的的质量，您需要了解总体通过、失败和未执行计数。

解决方案

使用数据集市视图 RV_ExecutionPlanStatusRollup 为特定执行计划文件夹创建报告，以返回按内部版本分组的通过、失败和未执行计数。

SELECT BuildName, PassedCount, FailedCount, NotExecutedCount
FROM RV_ExecutionPlanStatusRollup
WHERE ExecutionFolderID = ${executionPlanID|43|Execution Plan ID}
该查询执行以下操作：
  • 从 BuildName 视图选择 RV_ExecutionPlanStatusRollup 和状态计数。
  • 指定您希望从中获取状态的顶层文件夹 (ExecutionFolderID)。
SQL 查询结果将显示选定文件夹所有执行计划内的测试运行状态，结果按内部版本聚合。
BuildName | PassedCount | FailedCount | NotExecutedCount
351 | 0 | 0 | 2
352 | 15 | 7 | 1
如果您想查看更多详细信息，例如选定层次结构内各执行计划的状态计数，可使用数据集市视图 RV_ExecutionPlanStatusPerBuild：
SELECT eps.BuildName, eps.ExecutionPlanID, SUM(eps.PassedCount) PassedCount,
  SUM(eps.FailedCount) FailedCount, SUM(eps.NotExecutedCount) NotExecutedCount
FROM RV_ExecutionPlanStatusPerBuild eps
INNER JOIN TM_ExecTreePaths etp ON eps.ExecutionPlanID = etp.NodeID_pk_fk
WHERE etp.ParentNodeID_pk_fk = ${execFolderID|44|Execution Folder ID}
GROUP BY eps.ExecutionPlanID, eps.BuildOrderNumber, eps.BuildName
ORDER BY eps.BuildOrderNumber, eps.ExecutionPlanID
该查询执行以下操作：
  • 使用 RV_ExecutionPlanStatusPerBuild 视图访问特定于执行计划的数据（ExecutionPlanID 和 ExecutionPlanName）。先前使用的 RV_ExecutionPlanStatusRollup 视图包含预先聚合的数据（已汇总数据），不仅包含执行计划的结果，还包括文件夹节点的结果，因此不适于此目的。
  • 对 JOIN 表执行 TM_ExecTreePath 操作，选定特定文件夹内的所有节点，以获取层次结构信息。
  • 通过 ExecutionFolderID 指定顶层文件夹。TM_ExecutionTreePaths 表中还包含各执行计划的自引用，因此也可以使用 ParentNodeID_pk_fk 的执行计划 ID 运行此查询，以返回与特定执行计划对应的行。
  • 添加 ORDER BY BuildOrderNumber 和 ExecutionPlanID 获取经过排序的结果，此时最早的内部版本及其执行计划将显示在最前。
SQL 查询结果将显示选定文件夹所有执行计划内的测试运行状态。
BuildName | ExecutionPlanID | PassedCount | FailedCount | NotExecutedCount
351 | 2307 | 0 | 0 | 2
352 | 2184 | 11 | 2 | 0
352 | 2185 | 0 | 3 | 0
352 | 2186 | 2 | 1 | 0
352 | 2187 | 1 | 0 | 0
352 | 2191 | 0 | 1 | 0
352 | 2307 | 1 | 0 | 1
父主题： 如何使用数据集市创建报告


配置套件状态

问题

配置套件允许您对多种配置（例如多种浏览器或操作系统）执行相同的一组测试。为了合理判断所测试应用程序的质量和可靠性，您需要跟踪每种配置的结果。

解决方案

使用数据集市视图 RV_ConfigurationSuiteStatus创建为每个内部版本的各配置返回通过、失败和未执行计数的报告。

SELECT BuildName, ConfigurationName, PassedCount, FailedCount, NotExecutedCount
FROM RV_ConfigurationSuiteStatus
WHERE ConfigurationSuiteID = ${configSuiteID|97|Configuration Suite ID}
ORDER BY BuildOrderNumber, ConfigurationName
该查询执行以下操作：
  • 从 RV_ConfigurationSuiteStatus 视图检索测试运行的每个内部版本的状态计数。
  • 将结果缩小到配置套件 (ConfigurationSuiteID)。
SQL 查询的结果显示每种配置的测试运行状态。
BuildName | ConfigurationName | PassedCount | FailedCount | NotExecutedCount
350 | Chrome | 0 | 1 | 0
350 | Firefox | 0 | 1 | 0
350 | Internet Explorer | 0 | 1 | 0
351 | Chrome | 1 | 0 | 0
351 | Firefox | 1 | 0 | 0
351 | Internet Explorer | 0 | 1 | 0
352 | Chrome | 1 | 0 | 0
352 | Firefox | 1 | 0 | 0
352 | Internet Explorer | 1 | 0 | 0
在本示例中，我们使用配置套件 ID 获取所有配置。另外也可以将结果限制为特定内部版本，此时必须在 where 子句中包含 BuildID、BuildName 或 BuildOrderNumber。
注： RV_ConfigurationSuiteStatus 视图仅包含聚合状态计数，不含任何特定于测试的数据。若要检索其他特定于测试的数据，可以使用 RV_LatestTestStatus 等视图。
父主题： 如何使用数据集市创建报告


故障排除

  • 错误或缺失的数据
    从数据集市表或视图中查询的数据似乎错误或有缺失。
  • 数据集市降低系统性能
    数据集市似乎会对系统性能产生负面影响。
父主题： 报告数据集市


错误或缺失的数据

问题

在从数据集市表或视图中查询数据时，所列出的结果并非最新或有缺失。

解决方案

数据集市表和视图在后台定期更新，而非实时更新。因此，数据可能要等待几秒钟或者几分钟后才能载入数据集市表。如果您的系统负载较重，会对加载数据的后台进程的性能产生影响。原因在于其他进程的优先级更高，可能会临时阻止 DataMartUpdater 后台作业。请稍后再次运行查询，检索更新后的数据。

如果您作为系统管理员登录，可以导航到 http://<server>:<port>/sctm/check/db，检查 DM_TestStatus 表，以查看数据加载过程的当前状态。

注： 如果删除了一个测试，测试和依赖测试的测试运行都会从数据集市中删除。这同样适用于因清理测试包而删除的测试。
父主题： 故障排除


数据集市降低系统性能

问题

运行数据集市后，系统整体性能似乎有所降低，或者存在不一致的行为。

解决方案

尽管不应该采取这种做法，但您可以关闭数据集市，检查问题是否能得到解决：
  1. 在实例管理页面上，停止要修改的实例的应用程序服务器。
  2. 使用文本编辑器打开 TmAppServerHomeConf.xml 文件。此文件在应用程序服务器中的默认路径为 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Conf\AppServer。
  3. 找到 Config/DataMart/Enabled XML 标记，将值设置为 false。
  4. 保存并关闭 XML 文件。
  5. 重新启动应用程序服务器。
父主题： 故障排除


参考：数据集市表和视图

以下数据集市表和视图可用于简化和加速报告。

  • DM_TestStatus
    DM_TestStatus 表，这是状态相关视图的基础。
  • RV_TestStatusExtended 视图
    RV_TestStatusExtended 视图，提供特定测试执行的详细信息。
  • RV_LatestTestStatus 视图
    RV_LatestTestStatus 视图，在执行计划和特定内部版本的上下文中，提供一个测试的最新测试运行的状态和扩展信息。
  • RV_MaxTestRunID 视图
    RV_MaxTestRunID 视图，该帮助工具用于检索各测试、执行计划和内部版本组合的最新测试运行 ID。
  • RV_TestingCycleStatus
    RV_TestingCycleStatus 视图，提供测试周期的状态信息。
  • RV_ExecutionPlanStatusPerBuild
    RV_ExecutionPlanStatusPerBuild 视图，在内部版本的上下文中，检索各执行计划的最新测试状态汇总。
  • RV_ExecutionPlanStatusRollup
    RV_ExecutionPlanStatusRollup 视图，在内部版本的上下文中，检索各执行计划或文件夹的通过、失败和未执行测试汇总。
  • RV_ConfigurationSuiteStatus
    RV_ConfigurationSuiteStatus 视图，列出所有配置套件和各内部版本配置的状态计数。
父主题： 报告数据集市


DM_TestStatus

DM_TestStatus 表，这是状态相关视图的基础。

其他数据集市视图通常提供对详细信息数据的便捷访问，此表未提供测试名称等信息的直接访问。此表的键是 TestID、ExecutionPlanID、BuildID 和 TestRunID 列的组合。

行 | 说明
TestID | 测试的标识符。
ExecutionPlanID | 执行计划的标识符。
BuildID | 内部版本的标识符。
TestRunID | 测试运行的标识符。
ExecutionRunID | 识别此结果将在哪个执行运行中生成。
StatusID | 此测试运行的状态（请查看 TM_TestDefStatusNames）。
ReasonID | 此测试运行的状态原因（请查看 TM_ResultStatusReasons）。可以为空。
PassedCount | 所有通过的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
FailedCount | 所有失败的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
NotExecutedCount | 所有未执行的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
ProjectID | 此行所属项目的 ID。
TestStartTime | 测试运行的开始时间 (UTC)。
ExecutionStartTime | 执行运行的开始时间 (UTC)。
TestDurationInMilliseconds | 测试运行的持续时间（毫秒）。
IsBlocked | 表示测试运行已阻止/取消阻止的标记
DbChangedAt | 报告数据集市最后更新此行的时间。
父主题： 参考：数据集市表和视图


RV_TestStatusExtended 视图

RV_TestStatusExtended 视图，提供特定测试执行的详细信息。

此视图包含所有测试运行，而 RV_LatestTestStatus 视图仅包含一个执行计划、一个特定内部版本上下文中一个测试的最新测试运行。例如，您可以使用此视图创建列出带标记内部版本的所有测试运行的报告。此表的键是 TestID、ExecutionPlanID、BuildID 和 TestRunID 列的组合。

注： 如果删除了一个测试，测试和依赖测试的测试运行都会从数据集市中删除。这同样适用于因清理测试包而删除的测试。
行 | 说明
TestID | 测试的标识符。
ExecutionPlanID | 执行计划的标识符。
BuildID | 内部版本的标识符。
TestRunID | 测试运行的标识符。
ExecutionRunID | 识别此结果将在哪个执行运行中生成。
StatusID | 此测试运行的状态（请查看 TM_TestDefStatusNames）。
ReasonID | 此测试运行的状态（请查看 TM_ResultStatusReasons）。可以为空。
PassedCount | 所有通过的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
FailedCount | 所有失败的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
NotExecutedCount | 所有未执行的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
ProjectID | 此行所属项目的 ID。
TestStartTime | 测试运行的开始时间 (UTC)。
ExecutionStartTime | 执行运行的开始时间 (UTC)。
TestDurationInMilliseconds | 测试运行的持续时间（毫秒）。
IsBlocked | 表示测试运行已阻止/取消阻止的标记
DbChangedAt | 报告数据集市最后更新此行的时间。
TestName | 测试的名称。
TestDescription | 测试的说明。
TestParentID | 测试父项的 ID。
PlannedTimeInMinutes | 此测试的计划时间（分钟）。
Reason | 原因的名称。可以包含同时已删除的原因。
ExecutionPlanName | 执行计划的名称。
ExecutionPlanDescription | 执行计划的说明。
ExecutionParentFolderID | 执行计划父项的 ID。
Priority | 执行计划的优先级。0 = 低，1 = 中，2 = 高。
BuildName | 用于此测试运行的内部版本的名称。
BuildDescription | 内部版本的说明。
BuildOrderNumber | 内部版本的序号。
BuildIsTagged | 若内部版本带标记，则为 1，其他均为 0。
VersionID | 内部版本所属版本的 ID。
VersionName | 版本名称。
VersionDescription | 版本说明。
VersionOrderNumber | 版本的序号。
ProductID | 内部版本所属产品的 ID。
ProductCode | 产品的名称。
ProductDescription | 产品说明。
ProductOrderNumber | 产品的序号。
父主题： 参考：数据集市表和视图


RV_LatestTestStatus 视图

RV_LatestTestStatus 视图，在执行计划和特定内部版本的上下文中，提供一个测试的最新测试运行的状态和扩展信息。

使用 RV_TestStatusExtended视图检索有关所有测试运行的信息。您可以使用此视图创建列出执行文件夹内所有失败测试的报告。此表的键是 TestID、ExecutionPlanID、BuildID 和 TestRunID 列的组合。

行 | 说明
TestID | 测试的标识符。
ExecutionPlanID | 执行计划的标识符。
BuildID | 内部版本的标识符。
TestRunID | 测试运行的标识符。
ExecutionRunID | 识别此结果将在哪个执行运行中生成。
StatusID | 此测试运行的状态（请查看 TM_TestDefStatusNames）。
ReasonID | 此测试运行的状态（请查看 TM_ResultStatusReasons）。可以为空。
PassedCount | 所有通过的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
FailedCount | 所有失败的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
NotExecutedCount | 所有未执行的测试的总和，对于通用测试为 0 或 1，程序包测试根的此值可能更大。
ProjectID | 此行所属项目的 ID。
TestStartTime | 测试运行的开始时间 (UTC)。
ExecutionStartTime | 执行运行的开始时间 (UTC)。
TestDurationInMilliseconds | 测试运行的持续时间（毫秒）。
IsBlocked | 表示测试运行已阻止/取消阻止的标记
DbChangedAt | 报告数据集市最后更新此行的时间。
TestName | 测试的名称。
TestDescription | 测试的说明。
TestParentID | 测试父项的 ID。
PlannedTimeInMinutes | 此测试的计划时间（分钟）。
Reason | 原因的名称。可以同时包含已删除的原因。
ExecutionPlanName | 执行计划的名称。
ExecutionPlanDescription | 执行计划的说明。
ExecutionParentFolderID | 执行计划父项的 ID。
Priority | 执行计划的优先级。0 = 低，1 = 中，2 = 高。
BuildName | 用于此测试运行的内部版本的名称。
BuildDescription | 内部版本的说明。
BuildOrderNumber | 内部版本的序号。
BuildIsTagged | 若内部版本带标记，则为 1，其他均为 0。
VersionID | 内部版本所属版本的 ID。
VersionName | 版本名称。
VersionDescription | 版本说明。
VersionOrderNumber | 版本的序号。
ProductID | 内部版本所属产品的 ID。
ProductCode | 产品的名称。
ProductDescription | 产品说明。
ProductOrderNumber | 产品的序号。
父主题： 参考：数据集市表和视图


RV_MaxTestRunID 视图

RV_MaxTestRunID 视图，该帮助工具用于检索各测试、执行计划和内部版本组合的最新测试运行 ID。

此表的键是 TestID、ExecutionPlanID 和 BuildID 列的组合。

行 | 说明
TestID | 测试的标识符。
ExecutionPlanID | 执行计划的标识符。
BuildID | 内部版本的标识符。
MaxTestRunID | 标识在执行计划和内部版本上下文中测试的最新测试运行。
父主题： 参考：数据集市表和视图


RV_TestingCycleStatus

RV_TestingCycleStatus 视图，提供测试周期的状态信息。

您可使用此视图创建显示测试周期当前状态的报告。

TestingCycleID 表示测试周期，TesterExecutionID（以及 TesterExecutionName、UserID、CapacityInCycle、TesterLogin、TesterFirstName 和 TesterLastName）用于识别测试周期中已分配的测试工程师。对于尚未分配到特定测试工程师的测试，UserID、CapacityInCycle、TesterLogin、TesterFirstName 和 TesterLastName 为 null。此表的键是 TesterExecutionID 和 BuildID 列的组合。

行 | 说明
TestingCycleID | 测试周期的标识符。
TesterExecutionID | 标识分配到特定测试工程师的测试组。
TesterExecutionName | 为分配到特定测试工程师的测试组生成的名称。
UserID | 测试工程师的用户 ID。
CapacityInCycleInMinutes | 此用户在这个测试周期中的容量（分钟）。
TesterLogin | 测试工程师的登录名称。
TesterFirstName | 测试工程师的名字。
TesterLastName | 测试工程师的姓氏。
PassedCount | 所有已通过测试的汇总。
FailedCount | 所有失败测试的汇总。
NotExecutedCount | 所有未执行测试的汇总。
ProjectID | 项目标识符。
BuildID | 内部版本的标识符。
BuildName | 用于此测试运行的内部版本的名称。
BuildDescription | 内部版本的说明。
BuildOrderNumber | 内部版本的序号。
BuildIsTagged | 若内部版本带标记，则为 1，其他均为 0。
VersionID | 内部版本所属版本的 ID。
VersionName | 版本名称。
VersionDescription | 版本说明。
VersionOrderNumber | 版本的序号。
ProductID | 内部版本所属产品的 ID。
ProductCode | 产品的名称。
ProductDescription | 产品说明。
ProductOrderNumber | 产品的序号。
父主题： 参考：数据集市表和视图


RV_ExecutionPlanStatusPerBuild

RV_ExecutionPlanStatusPerBuild 视图，在内部版本的上下文中，检索各执行计划的最新测试状态汇总。

不考虑文件夹和子节点。您可使用此视图创建显示文件夹内各执行计划的测试运行状态的报告。与 RV_ExecutionPlanStatusRollup 相比，此视图略有性能优势，因为在检索数据时不考虑层次结构。此表的键是 ExecutionPlanID 和 BuildID 列的组合。

行 | 说明
ExecutionPlanID | 执行计划的标识符。
BuildID | 内部版本的标识符。
ExecutionPlanName | 执行计划的名称。
ExecutionParentFolderID | 执行计划父项的 ID。
PassedCount | 所有已通过测试的汇总。
FailedCount | 所有失败测试的汇总。
NotExecutedCount | 所有未执行测试的汇总。
ProjectID | 执行计划所属项目的 ID。
BuildName | 用于此测试运行的内部版本的名称。
BuildDescription | 内部版本的说明。
BuildOrderNumber | 内部版本的序号。
BuildIsTagged | 若内部版本带标记，则为 1，其他均为 0。
VersionID | 内部版本所属版本的 ID。
VersionName | 版本名称。
VersionDescription | 版本说明。
VersionOrderNumber | 版本的序号。
ProductID | 内部版本所属产品的 ID。
ProductCode | 产品的名称。
ProductDescription | 产品说明。
ProductOrderNumber | 产品的序号。
父主题： 参考：数据集市表和视图


RV_ExecutionPlanStatusRollup

RV_ExecutionPlanStatusRollup 视图，在内部版本的上下文中，检索各执行计划或文件夹的通过、失败和未执行测试汇总。

对于文件夹，计数器包含所有子文件夹的数字。您可使用此视图创建显示文件夹内所有测试运行状态的报告。此表的键是 ExecutionFolderID 和 BuildID 列的组合。

行 | 说明
ExecutionFolderID | 执行计划的标识符。
BuildID | 内部版本的标识符。
PassedCount | 所有已通过测试的汇总。
FailedCount | 所有失败测试的汇总。
NotExecutedCount | 所有未执行测试的汇总。
ProjectID | 执行计划所属项目的 ID。
BuildName | 用于此测试运行的内部版本的名称。
BuildDescription | 内部版本的说明。
BuildOrderNumber | 内部版本的序号。
BuildIsTagged | 若内部版本带标记，则为 1，其他均为 0。
VersionID | 内部版本所属版本的 ID。
VersionName | 版本名称。
VersionDescription | 版本说明。
VersionOrderNumber | 版本的序号。
ProductID | 内部版本所属产品的 ID。
ProductCode | 产品的名称。
ProductDescription | 产品说明。
ProductOrderNumber | 产品的序号。
父主题： 参考：数据集市表和视图


RV_ConfigurationSuiteStatus

RV_ConfigurationSuiteStatus 视图，列出所有配置套件和各内部版本配置的状态计数。

您可使用此视图创建显示配置套件内各配置的所有测试运行的状态的报告。此表的键是 ConfigurationID 和 BuildID 列的组合。

行 | 说明
ConfigurationSuiteID | 配置套件的标识符。
ConfigurationID | 配置的标识符。
ConfigurationName | 配置名称。
BuildID | 内部版本的标识符。
PassedCount | 所有已通过测试的汇总。
FailedCount | 所有失败测试的汇总。
NotExecutedCount | 所有未执行测试的汇总。
ProjectID | 此行所属项目的 ID。
BuildName | 用于此测试运行的内部版本的名称。
BuildDescription | 内部版本的说明。
BuildOrderNumber | 内部版本的序号。
BuildIsTagged | 若内部版本带标记，则为 1，其他均为 0。
VersionID | 内部版本所属版本的 ID。
VersionName | 版本名称。
VersionDescription | 版本说明。
VersionOrderNumber | 版本的序号。
ProductID | 内部版本所属产品的 ID。
ProductCode | 产品的名称。
ProductDescription | 产品说明。
ProductOrderNumber | 产品的序号。
父主题： 参考：数据集市表和视图


报告区域

  • 概述
    介绍 Silk Central 报告的概念。
  • 创建和自定义报告
    介绍如何创建和自定义报告。
  • 查看报告
    生成报告进行查看。
  • 保存报告
    保存报告。
  • 制作报告书签
    制作报告书签，以允许其他用户只需单击即可查看报告。
  • 作为 PDF 查看报告
    以 PDF 格式查看报告。
  • 访问最近使用 (MRU) 的报告
    访问最近查看的报告。
  • 报告工具栏功能
    报告工具栏为报告管理提供重要命令。
  • 报告属性
    介绍如何使用报告属性。
  • 报告参数
    介绍如何使用报告参数。
  • 报告数据页面
    用作以表格格式显示选定报告的结果参数和值的只读结果预览。
  • 报告页面
    将数据显示为带格式报告。
  • 项目概述报告
    提供了选定项目状态的高级概述。
父主题： 报告


概述

Silk Central 附带的默认报告在所有项目中可见，列于报告树的全局报告下方。这些报告不能修改，但您可以复制其副本，以根据自己的需求进行自定义。在全局报告树中创建自己的自定义报告也会使您的报告对所有项目可用。您还可以在项目树与全局报告树之间复制报告。全局报告的概念允许您在 Silk Central 的所有项目间灵活管理报告。

限制：
  • 由于全局报告并非以项目为上下文，因此必须是高级报告 (SQL)。
  • 全局报告不能是项目报告的子报告，子报告在全局报告部分中不可用。

共享全局报告权限

共享全局报告在所有项目中对所有用户可用，因此能够更新和删除此类报告的用户角色需要具备特殊权限：管理共享全局报告和删除共享全局报告。这些权限同样适用于共享全局报告中使用的报告模板。具备更新和删除报告的标准报告权限的用户角色可以更新和删除非共享全局报告和报告模板。这表示存在以下特殊情况：
  • 如果用户不具备管理共享全局报告权限，则全局报告和文件夹中的与其他用户共享此报告选项将禁用。
  • 将复制的共享报告粘贴到全局报告树时，如果不具备管理共享全局报告权限，所粘贴的报告将设置为非共享
父主题： 报告区域


创建和自定义报告

  • 创建报告
    介绍如何在 Silk Central 中创建报告。
  • 使用子报告
    介绍如何使用子报告。
  • 报告模板
    介绍如何使用报告模板。
  • 报告订阅
    介绍如何使用报告订阅。
  • 使用图表
    介绍如何在报告中使用图表。
  • 自定义报告
    介绍如何自定义 Silk Central 报告。
父主题： 报告区域


创建报告

Silk Central 提供了可快速轻松地将数据转换为直观图表和图形的报告。预装报告适用于需求、测试和问题区域。

报告使用 BIRT Report Designer、开放源代码、基于 Eclipse 的报告工具或 Microsoft Word 或 Microsoft Excel 报告模板进行创建。Silk Central 与 BIRT Report Designer 紧密集成，从而使您能够轻松生成测试管理数据的报告。Silk Central 具有高度可定制的报告功能。众多预装报告和报告模板提供了立即可用的选项，以满足广泛的报告需求。基于 GUI 的简单工具让您能够编辑预装报告和创建自己的报告。对于了解 SQL 的用户而言，数据的查询方式及其在自定义报告中的显示方式几乎没有任何限制。

提示： 如果生成空白报告，则可能是所选项目中没有任何数据，或者未连接到相应的 Silk Central 数据库。报告不可脱机使用，除非 Silk Central 数据库可从本地访问。
  • 创建新报告
    创建新报告。
  • 自定义报告的 SQL 函数
    介绍可用的函数占位符。
  • 通过 SQL 编写高级查询
    编写高级 SQL 查询，以执行报告。
父主题： 创建和自定义报告


创建新报告

要创建新报告，请执行以下操作：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中，选择您要新报告在其中显示的文件夹。 这将确定在目录树中存储报告的位置。
  3. 单击工具栏上的 新建子报告 。 此时将打开创建新报告对话框。
  4. 键入新报告的名称。 这是在报告树中显示的名称。
  5. 如果您要将此报告用于其他用户，请选中与其他用户共享此报告复选框。
  6. 在超时 [秒] 字段中，键入 Silk Central 应等待 SQL 查询完成的最大时间周期。
  7. 从默认选项卡列表中，选择要在从其中一个上下文相关报告列表中选择此报告时转至的选项卡。
  8. 从结果类别列表中选择相应结果类型。 此设置指定要为报告筛选的数据库表和视图。可用的结果类型如下：
    结果类型
    说明
    需求
    在需求模块中返回满足查询条件的可用需求。
    测试
    在测试区域中返回满足查询条件的可用测试。
    测试执行
    从执行区域返回满足查询条件的已执行测试结果。
    执行计划
    从执行区域返回执行计划。
    问题
    返回问题，其中包括导入的问题。
    需求进度生成数
    包含每个内部版本的需求进度信息，以便您能够看见跨内部版本的需求发展情况。
    需求进度天数
    与需求进度内部版本数相同，但显示每日进展。
    测试进度生成数
    显示跨内部版本的测试发展情况。
    测试进度天数
    与上面相同，但显示每日进展。

    每种结果类型提供一组选择条件。根据所选结果类型，为报告指定相应的选择条件。这些条件通常基于视图或一些其他直观分组（例如，自定义属性）对属性进行分组。

  9. 从属性列表中，选择要用于筛选的属性。 对于某些选择条件，属性是动态的。
  10. 选择查询的运算符。 可用运算符视属性而定。示例运算符包括 =、not、like 和 not like。字符串始终为比较小写。字符串允许使用通配符“*”和“?”，其中 * 与任何字符匹配，而 ? 与一个字符精确匹配。
  11. 选择或指定用于筛选查询的值。 对于基于日期的属性，值字段将替换为可用于选择特定日期的日历工具。
  12. 可选：要将其他查询字符串添加到此报告，请单击更多。可通过单击字符串的删除按钮删除现有查询字符串。定义多个查询字符串时，更多旁边将显示 AND 和 OR 选项按钮。使用这些选项按钮来定义是否应将这些查询累积考虑，或者只需满足一个查询字符串的条件。
  13. 单击下一步以配置新建报告对话框上的报告列。
  14. 单击添加列。 添加列对话框会列出所有可用报告列。
  15. 选择要在报告中包括的列，然后单击确定。 您可使用 Ctrl+单击选择多列。
    注： 对于测试计划报告，可用列名称列表将使用 LQM_V_Tests 表中的列名称进行增强。
    所选列以表格式显示在新建报告对话框上。
  16. 可选：配置每个报告列的显示方式。对于每一列，请使用排序列中的上/下箭头指定排序方向（升序、降序或未排序）。
  17. 选择多列进行排序时，将在排序次序列中显示列表框，以便您更轻松地编辑列排序顺序。根据需要设置这些数字。
  18. 为每列提供一个别名。 这是每列在生成的报告中的标签名称。
  19. 使用分组时（例如，选择一些元素或查询值汇总时），您可利用 SQL 汇总功能。选中分组方式复选框，以指定要应用 SQL 分组方式函数。
  20. 默认情况下，SQL 分组方式函数未选择的列将设置为汇总，这意味着将计算单个汇总值。从汇总列表中，选择适当的汇总类型。 可用的类型如下：
    • 计数
    • 小计
    • 平均
    • 最小
    • 最大
  21. 您可通过操作列在视图中向上或向下移动列列表，或删除列。
  22. 单击完成以完成新报告。
父主题： 创建报告


自定义报告的 SQL 函数

要帮助编写高级查询，每个函数必须具有占位符。执行时函数占位符会被替换为 SQL 代码。函数和参数的用法类似，但函数的名称以 $（美元符号）作为前缀。和参数不同的是，占位符是已定义的报告元素，无法按执行进行自定义。

下表列出了所有可用的函数占位符：

函数 | 作用 | 示例
$TODAY | 在数据库服务器上返回当前系统日期。您也可以将昨天编写为 $TODAY-1 或将一周前编写为 $TODAY-7。 | CreatedAt > ${$TODAY}
$DATE（列） | 返回日期，但不返回时间。 |
$DATE（“字符串”） | 将给定的字符串转换为数据库日期。 | CreatedAt > ${$DATE('01/10/2005')}
$DAYS[p1;p2] | 计算两个给定参数之间的天数差异。两个参数可以为表/视图中的列或 $TODAY。 | 以下示例返回上周创建的行： ${$DAYS[CreatedAt;$TODAY]} < 7
$WEEK（参数） | 返回给定参数的周数，此参数可为 $TODAY 或列。 |
$MONTH（参数） | 将月份返回为给定参数的数值，此参数可为 $TODAY 或列。 |
$YEAR（参数） | 将年份返回为给定参数的数值，此参数可为 $TODAY 或列。 |
$USERID | 当前登录用户的 ID。 |
$USERNAME | 当前登录用户的姓名。 |
$PROJECTID | 当前选定项目的 ID。 |
$PROJECTNAME | 当前选定项目的名称。 |
$REPORTNAME | 当前选定报告的名称。 |
$REPORTID | 当前选定报告的 ID。 |

以下是预安装的具有子需求的需求报告的代码。使用此报告将显示选定需求及其需求 ID。还显示有关需求的子需求的完整详细信息。尽管此报告不是自定义报告，但非常有用，因为它利用 $PROJECTID 函数。它还包括 reqID（需求 ID）和 reqProp_Obsolete_0 （显示过时的需求）两个参数。

SELECT r.ReqID, r.ReqCreated, r.ReqName, r.TreeOrder
   FROM RTM_V_Requirements r INNER JOIN
   TM_ReqTreePaths rtp ON (rtp.ReqNodeID_pk_fk = r.ReqID)
   WHERE rtp.ParentNodeID_pk_fk=${reqID|22322|Requirement ID} AND
   r.ProjectID = ${$PROJECTID} AND
   r.MarkedAsObsolete=${reqProp_Obsolete_0|0|Show obsolete Requirements}
   ORDER BY r.TreeOrder ASC
父主题： 创建报告


通过 SQL 编写高级查询

可以使用手动 SQL 编码创建高级报告。如果您知道数据库架构，则实际上任何报告选项都可用。单击高级查询可隐藏查询字符串列表框，并打开报告数据查询字段，在其中可插入现有代码或编写新的 SQL 代码。
限制： 不支持 SQL 语句 select top。

一种方法是使用创建新报告中概述的列表框开始查询字符串构造。如果报告条件有效，则会生成和显示等效的 SQL 语句，然后移到高级模式以便进一步修改。

注： 如果您从高级模式切换回简单模式，则您在代码中所做的更改将丢失。

在 SQL 中直接编写高级查询：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中，选择您要新报告在其中显示的文件夹。 这将确定在目录树中存储报告的位置。
  3. 单击工具栏上的 新建子报告 。 此时将打开创建新报告对话框。
  4. 键入新报告的名称。 这是在报告树中显示的名称。
  5. 如果您要将此报告用于其他用户，请选中与其他用户共享此报告复选框。
  6. 在说明字段中键入报告的说明。
  7. 单击高级查询可打开报告数据查询字段。插入先前编写的代码或在字段中直接编写新代码。 插入占位符列表有助于您使用预定义的函数占位符编辑 SQL 查询。有关详细信息，请参阅自定义报告的 SQL 函数。
    注： 如果您手动编辑查询的 SQL 代码，请单击检查 SQL 以确认操作。
  8. 单击完成以保存设置。
父主题： 创建报告
相关概念
自定义报告的 SQL 函数
相关任务
创建新报告


使用子报告

  • 添加子报告
    添加子报告，以将多个报告的结果汇总到当前所选报告中。
  • 删除子报告
    如果您不再希望子报告的结果聚合到报告，则可从报告中删除子报告。
父主题： 创建和自定义报告


添加子报告

要将多个报告的结果汇总到当前所选报告中，您可添加子报告。添加报告作为子报告时，子报告的结果列和行会串联到所选报告的结果。

添加报告作为子报告：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中选择报告。
  3. 单击属性选项卡。
  4. 单击添加子报告。 将显示添加子报告对话框。
  5. 从报告树中，选择要追加到当前报告的子报告。
  6. 单击确定以完成子报告的添加。 子报告将显示在子报告部分中相关报告的属性页面上。
父主题： 使用子报告


删除子报告

要删除子报告：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在与要删除的子报告关联的报告树中选择报告。
  3. 单击属性选项卡。
  4. 单击要删除的子报告的操作列中的 删除 。
  5. 单击确认对话框上的是以确认删除。
父主题： 使用子报告


报告模板

报告模板定义报告数据的呈现方式。有关管理报告模板的详细信息，请参阅管理报告模板。

共享全局报告在所有项目中对所有用户可用，因此能够更新和删除此类报告的用户角色需要具备特殊权限：管理共享全局报告和删除共享全局报告。这些权限同样适用于共享全局报告中使用的报告模板。具备更新和删除报告的标准报告权限的用户角色可以更新和删除非共享全局报告和报告模板。

  • 选择或上传报告模板
    在本地系统上创建报告模板后，您可将模板上传到 Silk Central。
  • 下载报告模板
    下载报告模板以使报告数据以符合您特定需求的格式进行呈现。
  • 删除报告模板
    删除当前报告的模板。
父主题： 创建和自定义报告


选择或上传报告模板

要从本地系统选择报告模板或上传模板，请执行以下操作：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 选择您要将模板与其关联的报告。
  3. 单击报告选项卡。
  4. 要上传模板，请单击单击此处上传新报告模板链接以打开上传模板对话框。
    1. 为模板提供有意义的名称和说明。
    2. 在项目列表框中，选择您希望使用模板的项目，或选择所有项目以将模板与所有项目关联。
    3. 单击浏览以浏览到本地系统中的模板并选择。
    4. 单击确定以上载模板。
  5. 要选择现有模板，请单击单击此处选择报告模板链接以打开选择报告模板对话框。
    1. 从列表中选择一个设计用于正确呈现所选报告的数据的模板。
    2. 单击确定以使用模板。
父主题： 报告模板
相关任务
下载报告模板


下载报告模板

Silk Central 报告模板可使报告数据以符合您特定需求的格式进行呈现。模板可采用 Word 文档、Excel 电子数据表、BIRT Report Designer 模板、XML 或 CSV 文件格式。通过将 Silk Central 报告模板下载到您的本地系统，您可以通过 BIRT Report Designer 或 Microsoft Excel 或 Word 进行编辑。在下载和编辑报告后，您可以上载它以使其对其他用户可用。有关详细信息，请参阅相关的上载报告模板步骤。

要下载现有报告模板以进行编辑：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 从报告树中选择使用您要修改的模板的报告。
  3. 单击属性选项卡。
  4. 单击要下载的模板的下载链接。 可用的下载链接为：
    生成空 BIRT 报告模板
    您将会收到作为空通用 BIRT 报告模板的报告数据。数据源已配置。
    生成 .XLS/.XLSX 报告模板
    您将会收到一个 Excel 文件，带有含数据的工作表。您可以在邻接工作表中指定其他信息，例如图示。
    下载示例 Word 报告模板
    您将会收到可用于创建自定义 Word 报告的 Word docx 文件。Word 文件包含如何自定义模板以添加报告所需数据的示例。
    以 .CSV 格式文件下载报告数据
    您将会收到逗号分隔值 (CSV) 文件形式的报告数据。根据您的本地设置，您将收到“,”或“;”作为分隔符。日期也会根据用户设置格式化。
    以 .XML 格式文件下载报告数据
    您将收到 XML 格式的报告数据。此方法相较于 CSV 的优势是您可以保留所有子报告数据。访问 Silk Central 之外的数据 - 您可以使用以下格式调用提供报告数据的特定 URL：
    http://server/servicesExchange?hid=reportData&userName=<username>
&passWord=<password>&reportFilterID=<ID of the report>&type=<csv|xml>
&projectID=<ID of the project>
    。
  5. 此时将显示文件下载对话框。单击保存并将报告文件作为 rptdesign、docx、xlsx 或 xls 文件下载到您的本地系统，具体取决于您下载的报告类型。
  6. 可根据您的需要使用 BIRT Report Designer（rptdesign 文件）、Word（docx）或 Excel（xls/xlsx 文件）来编辑报告。
父主题： 报告模板
相关任务
选择或上传报告模板


删除报告模板

删除当前报告的模板：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中，选择您要从中删除模板的报告。
  3. 单击报告选项卡。
  4. 单击 删除报告模板 。
  5. 单击后续确认对话框中的是。
父主题： 报告模板


报告订阅

报告单元中的订阅选项卡允许您订阅报告。您可以自定义希望在何时、何处、如何接收报告，还可以修改报告参数。报告将按照选定的计划在应用程序服务器后台创建，订阅者将通过电子邮件收到报告，还可以在仪表板面板中显示报告或者通过 URL 从外部网站访问报告。

  • 管理报告订阅
    描述如何管理报告订阅及如何订阅报告。
  • 向仪表板面板添加报告
    介绍如何创建报告并将其添加到仪表板面板。
父主题： 创建和自定义报告


管理报告订阅

在使用订阅时，请注意以下事项：
  • 如果创建报告的用户已删除，该报告的计划也会删除，该报告将禁用。其他用户必须修改订阅才能重新激活订阅。
  • 在您复制项目或项目基线时，不能复制订阅。
  • 在您导出项目时，不能导出订阅。
  • 创建订阅后，您可以使用操作列中的图标编辑或删除订阅。
  • 对于仪表板面板和外部访问报告，仅存储最新报告结果，无法使用历史记录。
  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中选择报告。
  3. 单击订阅选项卡。
  4. 单击添加订阅。 此时将打开编辑订阅对话框。
  5. 在名称字段中指定订阅的名称。
  6. 若要修改订阅参数，单击编辑参数。 此时将打开编辑参数对话框。更改值，然后单击确定。
  7. 从计划列表中选择计划。如果您需要的计划不存在，您需要自行创建。您也可以选择无计划，例如，仅根据测试执行结果才会触发的订阅。
  8. 在结果处理区域中，选择以下选项之一：
    • 如果您希望以电子邮件的形式发送报告，单击作为电子邮件发送并选择格式：报告模板（Excel、BIRT）、PDF（数据表）或 XLSX（数据表）。可用的选项取决于是否存在已配置的模板。随后，输入要将报告发送到的电子邮件地址。您可以同时将报告发送到多个电子邮件地址，只需使用逗号、分号或空格分隔各电子邮件地址即可。
    • 如果您希望在仪表板面板或外部网站上提供报告，单击提供仪表板和外部访问。选择此选项将使报告在报告订阅仪表板面板中可用，您也可以将所提供的链接嵌入网站、电子邮件等位置。这是一个永久链接，不会发生更改，无需登录或许可证即可访问。请注意，在使用模板时，仅以图形方式提供 BIRT 模板。其他模板显示为数据表。
  9. 单击确定。 新订阅将列入订阅列表。
要管理所有报告订阅，请选择全局报告节点或项目的根节点。使用操作列图标编辑或删除报告订阅。共享全局报告在所有项目中对所有用户可用，因此能够更新和删除此类报告的用户角色需要具备特殊权限：管理共享全局报告和删除共享全局报告。这些权限同样适用于共享全局报告中使用的报告模板。具备更新和删除报告的标准报告权限的用户角色可以更新和删除非共享全局报告和报告模板。

示例：在 IFrame 中嵌入外部访问链接

<html>
...
<body>
...
<iframe src="http://<front-end server>:19120/servicesExchange?hid=reportOutput&linkId=ec36a037-a59a-4899-a98c-5a4a4644811f"
 width="700" height="500"></iframe>
...
</body>
</html>
父主题： 报告订阅
相关参考
计划页面
执行计划属性页面


使用图表

  • 显示图表
    介绍如何显示图表。
  • 打印图表
    打印图表。
  • 删除图表
    从选定的报告中删除当前图表模板。
  • 报告图表页面
    可使您为数据分析定义图表和图形。
父主题： 创建和自定义报告


显示图表

要显示图表：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中选择报告。
  3. 单击图表选项卡以显示默认图表。
  4. 要选择其他图表类型，请单击 选择图表类型 。 此时将显示选择图表类型对话框。
  5. 从图表类型列表中选择图表类型。
  6. 检查要应用到图表的视图属性：
    • 3D 视图
    • 显示水平网格线
    • 显示垂直网格线
    • 显示图例
  7. 指定保存这些图表选项的方式：
    • 单击仅针对当前用户选项以在当前用户查看此视图时使用这些图表设置覆盖报告的标准设置。
    • 单击作为报告标准选项以对未定义覆盖用户设置的所有用户显示这些图表设置。 此设置不会影响单个用户设置。
  8. 单击确定以显示新图表类型。
    注： 您在此处定义的图表配置将成为此报告的默认配置。 如果标准图表和图形无法为您提供所需的特定数据，或者如果它们无法以所需格式显示数据，您可以使用 Silk Central 报告功能自定义所查询数据的外观。 要在单独的浏览器窗口中打开当前图表，请单击图表页面顶部的 在新窗口中打开 。
父主题： 使用图表


打印图表

打印当前图表：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中选择报告。
  3. 单击图表选项卡。
  4. 单击打印。 图表数据以可打印格式显示在新窗口中。也显示您系统的打印对话框。
  5. 根据需要配置打印设置，然后单击确定以打印图表。
父主题： 使用图表


删除图表

删除图表仅从选定的报告中删除当前选定的图表模板，而不会完全删除图表模板。

从选定的报告中删除当前图表模板：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中选择报告。
  3. 单击图表选项卡。
  4. 单击删除图表类型。 此时将打开删除图表对话框。
  5. 请选择以下选项之一：
    • 选择删除用户设置（并还原为报告标准）可将当前用户的图表设置与图表一起删除。 随后将根据报告的标准设置显示图表。 如果未定义标准设置，则无法显示图表。
      注： 此选项仅在当前用户已定义特定图表设置时可用。
    • 选择删除报告的标准图表设置可将任何标准设置与图表一起删除。 用户特定的设置不受此选项影响。
      注： 此选项仅在为报告定义标准图表设置后可用。
  6. 单击确定删除图表模板。 如果需要，您可以单击<单击此处选择图表类型>链接，以将新图表模板分配到选定的报告。
父主题： 使用图表


报告图表页面

报告 > 详细信息视图 > 图表

图表页面可使您为数据分析定义图表和图形。页面依赖于 Silk Central 的内部报告引擎，以便从选定报告查询检索到的数据创建标准图表和图形。

以下标准图表类型可用：
  • 面积图
  • 条形图
  • 水平堆叠条形图
  • 折线图
  • 饼图
  • 堆叠条形图
父主题： 使用图表


自定义报告

  • 自定义 BIRT 报告模板
    使用 BIRT Report Designer 创建自定义报告模板。
  • 自定义 Word 报告模板
    介绍如何下载和自定义 Word 报告模板。
父主题： 创建和自定义报告


自定义 BIRT 报告模板

借助 BIRT Report Designer (BIRT)，您可自定义 Silk Central 的预装报告模板和创建自定义报告模板。有关使用 BIRT 的详细信息，请参阅本帮助中的管理主题和 BIRT Report Designer 文档。

下载现有模板进行编辑：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 选择使用 BIRT 报告模板的报告。
  3. 单击属性选项卡。
  4. 单击生成空 BIRT 报告模板。 您将会收到作为空通用 BIRT 报告模板的报告数据。数据源已配置。
  5. 将模板保存到本地系统后，您可根据需要对其进行修改。 有关配置 BIRT 报告模板的详细信息，请参阅本帮助中的管理主题。
  6. 要上载已修改的报告模板，请在菜单中单击管理 > 报告模板，然后单击上载。
父主题： 自定义报告
相关概念
使用 BIRT 管理自定义报告模板


自定义 Word 报告模板

使用 Word 报告模板创建满足您需求的自定义报告。

下载现有模板进行编辑：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 选择报告。
  3. 单击属性选项卡。
  4. 单击下载示例 Word 报告模板链接。 使用浏览器在本地保存文件。
  5. 使用报告中的可用结果列，您可通过 Word 报告模板中包含的命令根据您的喜好自定义报告。
  6. 要上载已修改的报告模板，请在菜单中单击管理 > 报告模板，然后单击上载。
  • Word 报告模板
    介绍如何修改 Word 报告模板以及完全自定义的示例报告。
父主题： 自定义报告


Word 报告模板

关于模板

使用 Word 报告模板创建自定义报告。该模板使用 Word 合并字段获取所需数据。该模板专为 docx 文件设计，不支持 doc。下面介绍一些入门技巧：
  • 要在 Microsoft Word 中插入合并字段，请单击插入 > 快速部件 > 字段 > 合并字段或单击 Ctrl+F9。
  • 要编辑合并字段，请右键单击字段，然后选择编辑字段。
  • 除了合并字段以外，您还能在报告中混合和匹配标准文本。
  • 合并字段采用以下形式：« value »。

常规报告信息

下面是您可能要在报告标题中使用的数据：

字段 | 说明
${report.name} | 报告的名称。
${report.projectName} | 在其中执行报告的项目的名称。
${report.description} | 报告的说明。
${report.executedBy} | 执行报告的用户的登录名。
${report.generatedOn} | 执行报告的日期和时间。
${report.generatedOnWeek} | 执行报告的周数。

访问数据

以下部分介绍如何访问和显示报告的不同数据。

按索引
«${rows[0].cols[3]}»
按名称
«${rows[0].ReqName}»
在列表中
典型的使用案例可能是循环访问每行并显示每行的列信息。要获取数据列表，请执行以下操作：
«[#list rows as r]»
«${r.TestDefID}» - «${r.TestName}»
«[/#list]»

循环的开始由 [#list rows as r] 定义，而其结束由 [/#list] 定义。循环中的行数据使用 r 进行引用，这使您能够通过使用 ${r.TestName} 进行引用来获取循环中的 Test Name。

上面的示例将循环访问所有行，并且呈现的报告将显示测试列表以及测试 ID 和名称。

在表中
在表行中定义循环开始和结束需要其他命令才能在表中继续迭代。您必须将循环的 list 命令放置在表中第一列并以 @before-row 开头。您需要使用 @after-row 完成列表。下表显示如何执行此操作。
«${headers[3]}»|«${headers[3].@name}» | «${headers[4]}»|«${headers[4].@index}»
«@before-row[#list rows as r]»«${r.ReqName}»«@after-row[/#list]» | «${r.ReqDescription.@html}»
标题和 HTML
  • 数据的标题可使用名为 headers 的合并字段进行访问。
  • 标题可通过附加 .@elementName 或 .@name 或 .@index 以不同方式显示。
  • 部分 Silk Central 数据（如许多说明字段）存储为 HTML。如果要根据标记显示 HTML 编码文本，请附加属性 .@html。如果不添加此属性，您仍然可以看到文本，但它将包含 HTML 标记。例如：如果源数据是<b>我的报告说明</b>，并且使用 .@html，您将看到我的报告说明。否则，您将看到：<b>我的报告说明</b>。支持的 HTML 标记如下：<b>, <strong>, <i>, <u>, <br>, <p>, and <a>。
子报告
可以用关键字 sub 来访问子报告。附加您要访问的子报告的编号，例如 sub1、sub2 等。
示例：如果 ProjectID 位于主报告的第一列，那么使用 «${rows[0].ProjectID}» 来引用。如果 TestID 位于第一个子报告的第一列，那么使用 «${sub1.rows[0].TestID}» 来引用。循环访问第一个子报告的所有行，并显示 TestID 列及第二列：
«[#list sub1.rows as sr]»
  «${sr.TestID}» «${sr.cols[1]}»
«[/#list]»

疑难解答

我的报告为什么显示数据错误？
您是否按索引引用列？如果是，请注意第一列使用索引 0 而非 1 进行引用。
下载我的报告时，我为何收到提及特定字段的错误？我并未在我的模板中看到此字段？

您可能已更改字段的标签，但邮件合并引用仍然是其原始值。例如，您可能收到错误消息，表明字段 ${r.requirementName} 不存在。在您的文档中，您看到了字段 ${r.reqName}。当您右键单击此字段并选择编辑字段时，您将看到引用仍然是 ${r.requirementName}。请不要忘记通过编辑字段更改邮件合并字段。

示例报告

以下示例 Word 报告显示具有包含步骤的手动测试的报告。

注： 您不能按原样复制和粘贴此实例。其目的是向您展示将报告代码用于报告中各部分的不同方法。以下示例在报告模板中包括为 ManualTestResults.docx。
Report generated: «${report.generatedOn}» «${report.generatedOnWeek}»
«${report.name}»

Project Name          «${report.projectName}»
Report Description    «${report.description}»
Report Executed By    «${report.executedBy}»

«[#list rows as r]»«[#assign firstRow=(r_index==0 || rows[r_index-1].ManualTestDefID != r.ManualTestDefID)]»«[#if firstRow]»

«${r.TestDefinitionName}»
«${r.TestDefinitionDescription.@html}»

Status: «${r.StatusName}»

Planned Time [hh:mm]: «[#if r.PlannedTime!="null"]»«${r.PlannedTime}»«[#else]»00:00«[/#if]»
Used Time [hh:mm]: «[#if r.UsedTime!="null"]»«${r.UsedTime}»«[#else]»00:00«[/#if]»
Build: «${r.BuildName}»
Version: «${r.VersionName}»
Execution Plan: «${r.ExecDefName}»
Changed By: «${r.ChangedBy.@text}»
Changed On: «${r.ChangedAt.@text}»

«[/#if]»«[#if r.StepName != "null"]»«[#if firstRow]» Test Step Details:«[/#if]»
Step Name: «${r.StepName}»
Description: «${r.StepDescr.@html}»
Status: «${r.StepStatus}»
Result Info: «${r.StepResultInfo.@html}»
Expected Result: «${r.ExpectedResult.@html}»
«[/#if]»«[/#list]»
父主题： 自定义 Word 报告模板


查看报告

因为每个模板预期特定的数据格式以产生有用的图表，所以并非所有模板都可应用到所有报告查询。 如果您尝试通过不兼容的报告模板生成报告，则会收到错误消息。 例如，选择每行四个值 - 以水平条显示模板可显示需求状态概述报告工作，因为此特殊 Microsoft Excel 模板正好需要报告查询提供的四个值：失败、通过、未执行和未覆盖。

生成报告：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中，选择您要生成的报告。
  3. 单击报告选项卡。
  4. 单击链接<单击此处选择报告模板>。 此时将显示选择报告模板对话框。
  5. 选择您希望使用的模板。
  6. 单击确定以显示报告。
父主题： 报告区域


保存报告

如何在本地保存报告取决于您选择的是 BIRT 报告模板还是 Excel 或 Word 模板。 如果您选择了 Excel 模板，请单击选定报告的属性页面中的下载 Excel 报告模板链接。 这将在本地计算机上调用 Microsoft Excel，并且自动加载报告。 同样，如果选择 Word，请单击下载示例 Word 报告模板。

如果您选择了 BIRT 报告模板，请使用以下步骤保存报告。

将当前 BIRT 报告导出为 PDF：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中，选择您要保存的报告。
  3. 单击报告选项卡。
  4. 单击报告视图工具栏上的 显示为 PDF 文档 。
  5. 在文件下载对话框中，单击保存以将 PDF 文档保存到所选的位置。
父主题： 报告区域


制作报告书签

书签按钮可为当前显示的报告制作书签，包括您在参数页面中设置的参数。 您可将书签 URL 发送到其他 Silk Central 用户，从而使他们只需单击即可查看报告。

书签 URL 包含以 rp_ 为前缀的参数。 日期值在 URL 中表示为相关 Long 值（世界标准时间）。

父主题： 报告区域


作为 PDF 查看报告

在报告浏览器框架中以 PDF 格式查看当前报告：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中，选择您要查看的报告。
  3. 单击报告选项卡。
  4. 单击报告视图工具栏上的 显示为 PDF 文档 。 报告以 PDF 格式显示。
父主题： 报告区域


访问最近使用 (MRU) 的报告

选择最近查看的报告：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告工具栏上，展开上次使用的报告列表框。
  3. 选择要查看的报告。
父主题： 报告区域


报告工具栏功能

Silk Central > 报告

报告工具栏为报告管理提供重要命令。 工具栏包括以下项目：

项目 | 图标 | 说明
新建子文件夹 | 新建子文件夹 | 启用新报告文件夹的创建。 单击新建子文件夹可定义新文件夹的名称和可选说明。 新文件夹在报告树中显示为当前选定节点的子项。
新建子报告 | 新建子报告 | 启用新报告的创建。 单击新建子报告可使用创建新报告对话框定义新报告。 新报告在报告树中显示为当前选定节点的子项。
编辑 | 编辑 | 编辑报告。
删除 | 删除 | 删除报告。
剪切 | 剪切 | 剪切报告并将其添加到剪贴板。
复制 | 复制 | 将报告复制到剪贴板。
粘贴 | 粘贴 | 将报告从剪贴板粘贴到报告树。
粘贴为子项 | 粘贴为子项 | 将报告从剪贴板粘贴到报告树，作为选定节点的子节点。
上移 | 上移 | 在报告树中将报告上移。
下移 | 下移 | 在报告树中将报告下移。
上次使用的报告 |  | 按日期/时间以降序列出了最近使用 (MRU) 的报告。 从列表中选择报告名称可前进到此报告。 每次通过单击数据、图表或报告选项卡访问报告时，会将此报告添加到列表框的顶部。 访问报告的属性或参数选项卡不会使报告添加到上次使用的报告列表框。 对于新用户和尚未生成报告的用户，上次使用的报告列表框为空。 此列表中显示的报告数可由管理员配置。 有关更多信息，请参阅本帮助中的管理主题。
父主题： 报告区域


报告属性

  • 编辑报告属性
    编辑报告的属性。
  • 报告属性页面
    显示了选定报告的基本属性。
父主题： 报告区域


编辑报告属性

要编辑报告的属性：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中选择报告。
  3. 单击属性选项卡。
  4. 单击编辑。 此时将显示编辑报告对话框。
  5. 根据需要修改报告的名称、说明和超时 [秒]。
  6. 如果您要将此报告用于其他用户，请选中与其他用户共享此报告复选框。
  7. 从默认选项卡列表中，选择要在从其中一个上下文相关报告列表中选择此报告时转至的选项卡。
  8. 您可以通过两种方式编辑报告：
    • 创建简单报告：使用选择条件、属性、运算符和值列表来生成 SQL 查询。单击更多以添加更多查询字符串，并选择运算符 AND 或 OR 来组合查询。单击 [image] 以删除查询字符串。
    • 创建高级报告：如果您熟悉 SQL，您可能希望编辑查询代码。单击高级查询并修改报告数据查询字段内的查询代码。插入占位符列表有助于您使用预定义的函数占位符编辑 SQL 查询。单击简单以返回简单模式。
    注： 如果您手动编辑查询的 SQL 代码，请在完成后单击检查 SQL 以确认您所做的工作。
  9. 单击完成以保存您所做的更改。
父主题： 报告属性


报告属性页面

报告 > 详细信息视图 > 属性

属性页面显示了选定报告的基本属性，使您能编辑这些属性或报告模板。您也可以将子报告添加到报告。

页面显示以下项目：

项目 | 说明
报告名称 | 报告的名称（可自定义）
报告 ID | 报告的系统定义标识符
说明 | 报告的说明（可自定义）
创建于 | 创建报告的日期。创建和连接到数据库时会创建默认报告。
创建者 | 创建报告的用户。默认报告由用户管理员创建。
更改时间 | 上次修改报告的日期。
更改者 | 上次修改报告的用户。
呈现器 | 当前分配给报告的报告模板。
默认选项卡 | 从其中一个上下文相关报告列表中选择此报告时，系统将您定向到的选项卡。
编辑 | 单击可打开编辑报告对话框。
添加子报告 | 单击可将子报告添加到报告。
报告模板 可用的预安装报告模板为：
生成空 BIRT 报告模板
您将会收到作为空通用 BIRT 报告模板的报告数据。数据源已配置。
生成 .XLS/.XLSX 报告模板
您将会收到一个 Excel 文件，带有含数据的工作表。您可以在邻接工作表中指定其他信息，例如图示。
下载示例 Word 报告模板
您将会收到可用于创建自定义 Word 报告的 Word docx 文件。Word 文件包含如何自定义模板以添加报告所需数据的示例。
以 .CSV 格式文件下载报告数据
您将会收到逗号分隔值 (CSV) 文件形式的报告数据。根据您的本地设置，您将收到“,”或“;”作为分隔符。日期也会根据用户设置格式化。
以 .XML 格式文件下载报告数据
您将收到 XML 格式的报告数据。此方法相较于 CSV 的优势是您可以保留所有子报告数据。访问 Silk Central 之外的数据 - 您可以使用以下格式调用提供报告数据的特定 URL：
http://server/servicesExchange?hid=reportData&userName=<username>
&passWord=<password>&reportFilterID=<ID of the report>&type=<csv|xml>
&projectID=<ID of the project>
。
父主题： 报告属性


报告参数

  • 编辑报告参数
    编辑报告的参数。
  • 报告参数页面
    列出了可自定义的语句元素。
父主题： 报告区域


编辑报告参数

要编辑报告的参数：

  1. 在菜单中，单击报告 > 详细信息视图。
  2. 在报告树中选择报告。
  3. 单击参数选项卡。 如果已为报告定义参数，则此处将列出该参数。
  4. 单击编辑参数。 此时将显示编辑参数对话框。
  5. 根据需要编辑所列参数的标签或值。
  6. 从使用情况列表中，选择参数的使用类型。
    • 常数值
    • 开始时间
    • 结束时间
  7. 单击确定。
父主题： 报告参数


报告参数页面

报告 > 详细信息视图 > 参数

参数页面列出了可自定义的语句元素。只需在参数页面中更改参数，即可在报告执行前随时定义参数。参数的语法为：${parametername|defaultvalue|guiname}。defaultvalue 和 guiname 可选。参数名称不能包含空白字符。

当报告与参数关联后，可在每次执行报告前编辑参数值。参数值存储在当前用户上下文中，这意味着编辑值只可用于执行编辑的用户。如果没有为给定的报告执行指定参数值，则使用报告定义的默认值。

您可以使用使用情况列表框选择参数的使用类型。可能的值是常数值、开始时间和结束时间。开始时间和结束时间用于查询特定日期范围的报告。

当报告分配有子报告时，这些子报告的参数也会显示在参数页面，但值仅存储在选定报告的上下文中。例如，值仅与当前子报告配置一起使用。创建新报告时，参数是在选择条件区域的创建新报告对话框中定义的值。

父主题： 报告参数


报告数据页面

报告 > 详细信息视图 > 数据

数据页面用作只读结果预览，以带有排序和筛选功能的动态网格形式显示选定报告的结果。可以使用下载数据 (.xlsx) 按钮将看到的数据导出到 Excel。

您可以直接从数据页面的结果列表中访问所查询的需求、测试、执行计划和 Issue Manager 问题。为此，查询必须包含您要链接到的元素的 ProjectID 列和相应 ID。
ID
说明
RequID
查询此列以链接到报告的数据页面上的需求。
TestDefID
查询此列以链接到报告的数据页面上的测试。
ExecDefID
查询此列以链接到报告的数据页面上的执行计划。
DefectID
查询此列以链接到报告的数据页面上的 Issue Manager 问题。

如果查询结果包括 ProjectID、RequID、TestDefID、ExecDefID 或 DefectID 这些术语作为列名的结果，数据页面会将元素 ID 列中的值显示为链接。

父主题： 报告区域


报告页面

报告 > 详细信息视图 > 报告

报告页面用于将数据显示为带格式的报告。如果您尚未为报告分配模板，则可在报告页面中选择一个。

列表框提供了所有可用报告模板供您选择。除了许多系统安装的模板外，此处还提供从管理 > 报告模板中上载的任何自定义报告模板。

您还可以下载现有模板，方法是单击属性选项卡，然后单击与您使用的报告格式相应的下载链接。您可以从这里根据需求自定义模板。

注： 将通过缓存报告来提高报告性能。单击更新可立即更新报告数据。
父主题： 报告区域


项目概述报告

报告 > 项目概述报告

显示项目概述报告，其中提供了选定项目状态的高级概述。项目概述报告包括以下部分：

部分 | 说明
常规报告信息 | 当前项目名称、报告说明和计划发布日期等常规信息。
需求 | 需求的测试覆盖率状态。以表格和图表格式显示所有需求和高优先级需求的测试覆盖率百分比。
测试 | 以图表和表格形式显示的测试类型分发和测试执行结果。
父主题： 报告区域
相关概念
项目概述报告
代码分析


默认报告

  • 上下文相关报告
    介绍动态生成的特定于需求、测试和执行的报告列表。
  • 需求报告
    需求报告详述了功能需求的状态，例如兼容性需求、GUI 需求或特性需求，必须在开发期间满足这些需求。
  • 测试报告
    介绍测试相关的报告。
  • 执行计划报告
    此部分介绍执行计划相关的报告。
  • 每个组件的问题报告
    每个组件的问题报告提供与每个组件相关的所有问题的概述。
  • 代码覆盖率报告
    介绍代码覆盖率报告。
  • 性能趋势报告
    性能趋势报告显示所测试的应用程序在特定时期内的性能评估。
  • 项目概述报告
    提供了选定项目状态的高级概述。
父主题： 报告


上下文相关报告

需求、测试和执行区域提供了动态生成的特定于每个单元的报告列表。 上下文相关报告列表非常有用，因为它们提供了与当前活动直接相关的报告类型。

需求
需求树中的上下文相关报告列表提供了将需求 ID 作为输入参数的所有报告。
测试
测试树中的上下文相关报告列表提供了将测试 ID 作为输入参数的所有报告。
执行
执行计划树中的上下文相关报告列表提供了将执行计划 ID 作为输入参数的所有报告。 在执行计划运行选项卡上，上下文相关报告列表提供了具有以下配置的所有报告：
  • 结果类别 = 执行计划
  • 选择条件 = 执行计划运行
  • 属性 = ID

从上下文相关报告列表中选择报告时，您将在报告区域中直接转到该报告的默认选项卡。 此默认的目标选项卡行为可使用每个报告的编辑报告对话框进行配置。

上下文相关报告列表中显示两种类型的报告：已访问的报告和尚未访问的报告。 您先前访问的报告显示在菜单中的行分隔符上方。 这些报告按时间顺序排列，并且最近查看的报告位于列表顶部。 其他可用但尚未访问的默认报告显示在行分隔符下方。

除了默认配置的上下文相关报告之外，您也可将新报告和现有报告配置为包括在每个区域的上下文相关报告列表中。 上下文相关性仅按每个用户、每个报告添加到报告中。

  • 访问上下文相关执行报告
    访问上下文相关执行计划报告。
  • 访问上下文相关执行计划运行报告
    访问上下文相关执行计划运行报告。
  • 访问上下文相关需求报告
    访问上下文相关需求报告。
  • 访问上下文相关测试报告
    访问上下文相关测试报告。
  • 启用上下文相关执行报告
    启用要在上下文相关报告列表中显示的执行计划和执行计划运行报告。
  • 启用高级上下文相关执行报告
    启用要在执行计划树或运行页面的上下文相关报告列表中显示的高级报告。
  • 启用上下文相关需求报告
    启用要在上下文相关报告列表中显示的需求报告。
  • 启用高级上下文相关需求报告
    启用要在需求区域的上下文相关报告列表中显示的高级报告。
  • 启用上下文相关测试报告
    启用要在上下文相关报告列表中显示的测试报告。
  • 启用高级上下文相关测试报告
    启用要在测试区域的上下文相关报告列表中显示的高级报告。
父主题： 默认报告


访问上下文相关执行报告

注： 必须将报告启用为上下文相关报告，以使其在执行区域中可用。

访问上下文相关执行计划报告：

  1. 在菜单中，单击执行计划。
  2. 右键单击执行计划树中的执行计划并选择报告。
  3. 从报告子菜单中选择报告。

    您将转到报告区域（其中，执行计划 ID 会作为值预先填充）中所选报告的参数选项卡。

    注： 您可以使用每个报告的编辑报告对话框来配置此目标选项卡链接行为。
  4. 编辑所需的报告参数。
  5. 在数据、报告或图表页面完成报告配置。
父主题： 上下文相关报告


访问上下文相关执行计划运行报告

注： 必须将报告启用为上下文相关报告，以使其在执行区域中可用。

访问上下文相关执行计划运行报告：

  1. 在菜单中，单击执行计划 > 详细信息视图。
  2. 单击运行选项卡。
  3. 右键单击运行并选择报告。
  4. 从报告子菜单中选择报告。

    您将转到报告区域（其中，运行 ID 会作为值预先填充）中所选报告的参数页面。

    注： 您可以使用每个报告的编辑报告对话框来配置此目标选项卡链接行为。
  5. 编辑所需的报告参数。
  6. 在数据、报告或图表页面完成报告配置。
父主题： 上下文相关报告


访问上下文相关需求报告

注： 只有接受需求 ID 作为输入参数的报告所在的需求区域中才具有上下文相关报告。

访问上下文相关需求报告：

  1. 在菜单中，单击需求 > 详细信息视图。
  2. 右键单击需求树中的需求并选择报告。
  3. 从报告子菜单中选择报告。

    您将转到报告区域（其中，需求 ID 会作为值预先填充）中所选报告的参数页面。

    注： 您可以使用每个报告的编辑报告对话框来配置此目标选项卡链接行为。
  4. 编辑所需的报告参数。
  5. 在数据、报告或图表页面完成报告配置。
父主题： 上下文相关报告


访问上下文相关测试报告

注： 只有接受测试 ID 作为输入参数的报告所在的测试区域中才具有上下文相关报告。

访问上下文相关测试报告：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 右键单击测试树或网格视图中的测试、文件夹或测试容器，并选择报告。
    注： 在网格视图中选择多个测试时，会禁用上下文相关报告。
  3. 从报告子菜单中选择报告。

    您将转到报告单元（其中，测试 ID 会作为值预先填充）中所选报告的参数页面。

    注： 您可以使用每个报告的编辑报告对话框来配置此目标选项卡链接行为。
  4. 编辑所需的报告参数。
  5. 在数据、报告或图表页面完成报告配置。
父主题： 上下文相关报告


启用上下文相关执行报告

介绍如何启用要在上下文相关报告列表中显示的执行计划和执行计划运行报告。

要启用要在执行树或运行页面的上下文相关报告列表中显示的简单报告：

  1. 创建新报告。 有关其他信息，请参阅创建新报告。
  2. 从结果类别列表框中选择执行计划。
  3. 选择上下文相关报告的选择条件。
  4. 从属性列表框中选择 ID。
  5. 在值文本框中键入值。 例如，现有执行计划或现有执行计划运行的 ID 编号。
  6. 单击完成。
父主题： 上下文相关报告
相关任务
创建新报告


启用高级上下文相关执行报告

要启用要在执行计划树或运行页面的上下文相关报告列表中显示的高级报告：

  1. 创建包含以下项之一的报告：
    • 执行计划 ID，它作为要在执行计划树中显示的报告的输入参数。
    • 执行计划运行 ID，它作为要在运行页面上显示的报告的输入参数。

    有关其他信息，请参阅创建新报告和使用 SQL 编写高级查询。

  2. 要使高级查询在执行区域的上下文菜单中可用，请将参数名称 execProp_Id_0 作为 ExecDef_ID_pk_fk 的输入进行插入。 例如，报告的 SQL 语句可能已定义硬编码数据库列值，例如 ExecDef_ID_pk_fk = 68。要编辑此报告以便它动态接收列名称值，请使用 68 替换静态值 ${execProp_Id_0 | 68}。
父主题： 上下文相关报告
相关任务
创建新报告
通过 SQL 编写高级查询


启用上下文相关需求报告

介绍如何在上下文相关报告列表中启用需求报告。

要启用要在需求区域的上下文相关报告列表中显示的简单报告：

  1. 创建新报告。 有关其他信息，请参阅创建新报告。
  2. 从结果类别列表框中选择需求。
  3. 选择上下文相关报告的选择条件。
  4. 在值文本框中键入值。 例如，现有需求的 ID 编号。
父主题： 上下文相关报告
相关任务
创建新报告


启用高级上下文相关需求报告

要启用要在需求区域的上下文相关报告列表中显示的高级报告：

  1. 创建包含作为输入参数的需求 ID 的报告。

    有关其他信息，请参阅创建新报告和使用 SQL 编写高级查询。

  2. 要使高级查询在需求单元的上下文菜单中可用，请将参数名称 reqProp_Id_0 作为 Req_ID_pk_fk 的输入进行插入。 例如，报告的 SQL 语句可能已定义硬编码数据库列值，例如 Req_ID_pk_fk = 68。要编辑此报告以便它动态接收列名称值，请使用 68 替换静态值 ${reqProp_Id_0 | 68}。
父主题： 上下文相关报告
相关任务
创建新报告
通过 SQL 编写高级查询


启用上下文相关测试报告

介绍如何在上下文相关报告列表中启用测试报告。

要启用要在测试区域的上下文相关报告列表中显示的简单报告：

  1. 创建新报告。 有关其他信息，请参阅创建新报告。
  2. 从结果类别列表框中选择测试。
  3. 选择上下文相关报告的选择条件。
  4. 在值文本框中键入值。 例如，现有测试的 ID 编号。
父主题： 上下文相关报告
相关任务
创建新报告


启用高级上下文相关测试报告

要启用要在测试区域的上下文相关报告列表中显示的高级报告：

  1. 创建将测试 ID、测试文件夹 ID 或测试容器 ID 作为输入参数的报告。

    有关其他信息，请参阅创建新报告和使用 SQL 编写高级查询。

  2. 要使高级查询在测试区域的上下文菜单中可用，请将参数名称 tdProp_Id_0 作为测试 ID 的输入插入，或将参数名称 tfProp_Id 作为测试文件夹 ID 或测试容器 ID 的输入插入。 例如，报告的 SQL 语句可能已定义硬编码数据库列值，例如 TestDef_ID_pk_fk = 68。要编辑此报告以便它动态接收列名称值，请使用 68 替换静态值 ${tdProp_Id_0 | 68}。
父主题： 上下文相关报告
相关任务
创建新报告
通过 SQL 编写高级查询


执行计划报告

此部分介绍 Silk Central 附带的执行计划报告。为了简化结果评估，执行计划报告将为您提供在一段时间或内部版本范围内的测试执行进度和缺陷状态的详细概述。

  • 执行计划运行比较报告
    执行计划运行比较报告提供两个执行计划运行之间的比较概述。
  • 执行计划运行错误报告
    执行计划运行错误报告提供未通过执行计划运行的所有测试的详细列表以及未通过的原因。
  • 未通过的测试报告
    未通过的测试报告在执行区域中提供文件夹或项目的所有未通过测试的概述。
  • 每个执行计划未通过的测试报告
    每个执行计划未通过的测试报告在执行区域中提供配置套件的每个配置或者文件夹或项目的每个执行计划未通过的所有测试的概述。
  • 执行状态概述报告
    执行状态概述报告显示分配到所选节点的执行计划的所有测试的上次运行状态概述。
父主题： 默认报告


执行计划运行比较报告

执行计划运行比较报告提供两个执行计划运行之间的比较概述。
注： 运行比较报告不适合比较手动测试和自动测试。当报告的名称包括（上两次运行）时，您只可以比较执行计划或测试的上两次运行。
以下报告将比较两个执行计划的运行：
执行计划运行比较报告

对两个执行计划的运行进行比较的默认执行计划运行比较报告。

执行计划运行比较报告 – 已更改状态

仅对两个执行计划运行的已发生状态更改的测试进行比较。

执行计划运行比较报告 – 在较新的运行中失败

仅比较两个执行计划运行的失败测试。

执行计划运行比较报告提供以下信息：
  • 对执行计划状态所做的更改
  • 错误数
  • 警告数
  • 在其中执行执行计划的上下文
  • 已分配测试的执行持续时间
注： 当所比较运行之间的已分配测试的状态更改为失败时，测试将标记为红色。当所比较运行之间的已分配测试的状态更改为通过时，测试将标记为绿色。
父主题： 执行计划报告


执行计划运行错误报告

执行计划运行错误报告提供未通过执行计划运行的所有测试的详细列表以及未通过的原因。

在执行计划运行过程中发生的所有错误都会在此报告中列出。用户可以快速访问结果并轻松识别执行计划运行中的不必要影响。执行计划运行错误报告的输入参数是执行计划运行的标识符。

父主题： 执行计划报告


未通过的测试报告

未通过的测试报告在执行区域中提供文件夹或项目的所有未通过测试的概述。

您可以使用此报告进行错误分析，例如在配置测试过程中。未通过的测试报告的输入参数是配置套件、文件夹或项目的标识符。

父主题： 执行计划报告


每个执行计划未通过的测试报告

每个执行计划未通过的测试报告在执行区域中提供配置套件的每个配置或者文件夹或项目的每个执行计划未通过的所有测试的概述。

您可以使用此报告进行错误分析，例如在配置测试过程中。每个执行计划未通过的测试报告的输入参数是配置套件、文件夹或项目的标识符。

父主题： 执行计划报告
相关任务
访问上下文相关执行报告


执行状态概述报告

执行状态概述报告显示分配到所选节点的执行计划的所有测试的上次运行状态概述。

执行状态概述报告的输入参数是执行计划树中节点的标识符。

父主题： 执行计划报告


每个组件的问题报告

每个组件的问题报告提供与每个组件相关的所有问题的概述。

除提供基本问题跟踪外，此报告有助于监视每个组件的总体问题趋势。

父主题： 默认报告


代码覆盖率报告

本节介绍 Silk Central 随附的代码覆盖率报告。 代码覆盖率报告详细概述了一段时间内或内部版本范围内的产品代码覆盖率。

  • 代码更改影响报告
    使您能够执行测试影响分析、工作分析和风险分析。
  • 代码覆盖率趋势报告
    显示选定的内部版本范围内产品的方法、类别和程序包的代码覆盖率的改进趋势。
  • 方法覆盖率比较报告
    比较两个产品内部版本所包含的所有程序包/命名空间的方法覆盖率。
父主题： 默认报告


代码更改影响报告

您可通过代码更改影响报告执行测试影响分析、工作分析和风险分析。您可选择感兴趣的类并通过应用报告模板生成报告，以帮助您确定更改所选类将产生的测试影响。对于所选类，您可从分析建议代码更改测试影响的报告模板中进行选择。

代码更改影响 - 测试报告确定需要重新运行以下代码更改的测试。覆盖率指数显示指定类的测试所覆盖的方法数/指定类的总方法数。

代码更改影响 - 执行计划报告确定需要重新运行以下代码更改的执行计划。

报告的使用案例

以下典型代码更改影响问题均可使用代码更改影响报告进行解决：
测试影响分析
您想知道作为代码特定更改的结果应运行哪些测试。
  • 选择特定类。
  • 选择并执行代码更改影响 - 测试报告。
  • 查看覆盖此版本中所涉及类的测试列表。
工作分析
您想知道正确覆盖一组特定代码更改所需的自动和手动测试小时数。
  • 选择特定类。
  • 选择并执行代码更改影响 - 执行计划报告。
  • 查看自动和手动测试所需的时间（成本）。
父主题： 代码覆盖率报告


代码覆盖率趋势报告

显示选定的内部版本范围内产品的方法、类别和程序包的代码覆盖率的改进趋势。

代码覆盖率趋势图

显示选定内部版本范围内所选产品的代码覆盖率的总体百分比。特定程序包/命名空间、类和方法的代码覆盖率单独显示。

代码覆盖率趋势详细信息

以表格形式显示代码覆盖率趋势图中的信息。

父主题： 代码覆盖率报告


方法覆盖率比较报告

比较两个产品内部版本所包含的所有程序包/命名空间的方法覆盖率。

使用阈值参数可指定使程序包/命名空间在报告中显示的最小更改量。具有更小更改百分比的程序包/命名空间不会显示在报告中。阀值范围为 0 至 100%。

父主题： 代码覆盖率报告


性能趋势报告

性能趋势报告显示所测试的应用程序在特定时期内的性能评估。

性能报告的输入数据由 Silk Performer 负载测试提供。

  • 平均页面时间趋势报告
    显示在指定时间范围内指定测试的所有已执行测试的每页页面时间。
  • 平均事务繁忙时间趋势报告
    显示在指定时间范围内指定测试的所有已执行测试的每个事务的事务繁忙时间。
  • 总体页面时间趋势报告
    显示在指定时间范围内指定测试的所有已执行测试的总体页面时间（在所有用户类型上累计）。
  • 总体事务繁忙时间趋势报告
    显示在指定时间范围内指定测试的所有已执行测试的总体事务繁忙时间（在所有用户类型上累计）。
  • 自定义度量趋势报告
    显示在指定时间范围内指定测试的所有已执行测试的定义度量的平均值、最小值和最大值。
父主题： 默认报告


平均页面时间趋势报告

显示在指定时间范围内指定测试的所有已执行测试的每页页面时间。已测试页面的页面时间性能趋势以图表显示。

输入参数

平均页面时间趋势报告的输入参数包括：
参数
说明
开始日期 (DD-MON-YYYY)
时间范围的开始日期。例如 06-DEC-2008。
结束日期 (DD-MON-YYYY)
时间范围的结束日期。例如 16-JAN-2009。
排除超过 <nnn> 个错误的运行
报告不包含生成的错误多于此处指定错误数的运行。使用此设置可避免离群值使趋势曲线倾斜。
y 轴的最大值
将图表的 y 轴限定为指定值。超过此值的事务繁忙时间会在顶部被切断。此设置用于阻止离群值导致线条变平。
度量筛选器
显示的度量仅限于其名称中包括指定字符串的度量。必须填写此字段。要显示所有可用度量，请将度量筛选器设置为 %。例如，若要仅显示在名称中任意位置包括单词“unit”的度量，请将度量筛选器设置为 %unit%。
测试 ID
您要为其查看报告的测试的标识符。
父主题： 性能趋势报告


平均事务繁忙时间趋势报告

显示在指定时间范围内指定测试的所有已执行测试的每个事务的事务繁忙时间。已测试事务的事务繁忙时间性能趋势以趋势图显示。

输入参数

平均事务繁忙时间趋势报告的输入参数包括：
参数
说明
开始日期 (DD-MON-YYYY)
时间范围的开始日期。例如 06-DEC-2008。
结束日期 (DD-MON-YYYY)
时间范围的结束日期。例如 16-JAN-2009。
排除超过 <nnn> 个错误的运行
报告不包含生成的错误多于此处指定错误数的运行。使用此设置可避免离群值使趋势曲线倾斜。
y 轴的最大值
将图表的 y 轴限定为指定值。超过此值的事务繁忙时间会在顶部被切断。此设置用于阻止离群值导致线条变平。
测试 ID
您要为其查看报告的测试的标识符。
事务筛选器
显示的事务仅限于其名称中包含指定字符串的事务。必须填写此字段。要显示所有可用的事务，请将事务筛选器设置为 %。例如，要只显示名称中的任何位置包括“unit”字样的事务，请将事务筛选器设置为 %unit%。
父主题： 性能趋势报告


总体页面时间趋势报告

显示在指定时间范围内指定测试的所有已执行测试的总体页面时间（在所有用户类型上累计）。所测试页面的页面时间性能趋势显示在图中。

输入参数

总体页面时间趋势报告的输入参数包括：
参数
说明
开始日期 (DD-MON-YYYY)
时间范围的开始日期。例如 06-DEC-2008。
结束日期 (DD-MON-YYYY)
时间范围的结束日期。例如 16-JAN-2009。
排除超过 <nnn> 个错误的运行
报告不包含生成的错误多于此处指定错误数的运行。使用此设置可避免离群值使趋势曲线倾斜。
y 轴的最大值
将图表的 y 轴限定为指定值。超过此值的事务繁忙时间会在顶部被切断。此设置用于阻止离群值导致线条变平。
测试 ID
您要为其查看报告的测试的标识符。
父主题： 性能趋势报告


总体事务繁忙时间趋势报告

显示在指定时间范围内指定测试的所有已执行测试的总体事务繁忙时间（在所有用户类型上累计）。所测试事务的事务繁忙时间性能趋势显示在趋势图表中。

输入参数

总体事务繁忙时间趋势报告的输入参数包括：
参数
说明
开始日期 (DD-MON-YYYY)
时间范围的开始日期。例如 06-DEC-2008。
结束日期 (DD-MON-YYYY)
时间范围的结束日期。例如 16-JAN-2009。
排除超过 <nnn> 个错误的运行
报告不包含生成的错误多于此处指定错误数的运行。使用此设置可避免离群值使趋势曲线倾斜。
y 轴的最大值
将图表的 y 轴限定为指定值。超过此值的事务繁忙时间会在顶部被切断。此设置用于阻止离群值导致线条变平。
测试 ID
您要为其查看报告的测试的标识符。
父主题： 性能趋势报告


自定义度量趋势报告

显示在指定时间范围内指定测试的所有已执行测试的定义度量的平均值、最小值和最大值。每个已测试度量值的性能趋势以图表显示。

输入参数

自定义度量趋势报告的输入参数包括：
参数
说明
开始日期 (DD-MON-YYYY)
时间范围的开始日期。例如 06-DEC-2008。
结束日期 (DD-MON-YYYY)
时间范围的结束日期。例如 16-JAN-2009。
排除超过 <nnn> 个错误的运行
报告不包含生成的错误多于此处指定错误数的运行。使用此设置可避免离群值使趋势曲线倾斜。
y 轴的最大值

将图表的 y 轴限定为指定值。超过此值的度量将从顶部截断。此设置用于阻止离群值导致线条变平。

度量名称

要查看其报告的自定义度量的名称。例如 CreateTestDefinition。

度量类型

自定义度量的类型。例如 Transaction(BusyTime)[s]。

测试 ID
您要为其查看报告的测试的标识符。
父主题： 性能趋势报告


管理

完成 Silk Central 的初始配置（实例配置）后，本节将引导您完成设置用户帐户、项目、位置和执行服务器等所需的步骤。这些任务必须由管理员执行。
  • 用户角色和权限
    介绍如何在 Silk Central 中使用不同用户角色和权限。
  • 用户帐户和组
    介绍 Silk Central 中用户帐户和组的概念背景。
  • 执行环境
    介绍 Silk Central 中执行环境的概念背景。
  • 管理报告模板
    介绍如何在 Silk Central 中使用报告模板。
  • 审核日志
    介绍管理员如何使用审核日志查看所有已记录的 Silk Central 用户活动。
  • 服务器日志文件
    服务器日志文件为管理员提供有价值的信息，以便进行错误分析。
  • 集成任务管理工具
    介绍如何将外部任务管理工具与 Silk Central 集成。
  • 管理产品、组件、版本和内部版本
    介绍如何创建和组织产品、产品组件、产品版本和产品版本的内部版本号。
  • 维护值列表
    介绍如何使用值列表填充可为 Issue Manager 配置的自定义问题选项卡中的自定义属性。
  • 配置全局计划
    介绍如何定义可在 Silk Central 中重复用于执行计划安排的全局计划。
  • 时区
    介绍 Silk Central 中的时区处理。
  • 管理项目
    Silk Central 中的项目通常会反映出贵公司中的软件项目，分别是开发团队的工作，有通用的发行日期、通用的源代码管理系统、通用需求等。
  • 集成
    介绍 Silk Central 中的可用集成。
父主题： Silk Central 帮助


用户角色和权限

使用 Silk Central 时，任务被分配给有权访问已分配项目的指定用户组。 在组中，用户是项目中的授权特定角色。 根据用户角色类型和组成员配置用户权限。 本主题定义每个权限类型，并详述与每个用户角色关联的特定权限。

每个用户帐户可以属于一个或多个组。 组指定用户在此组中具有的角色。 组被分配给项目。 因此，每个用户具有的权限从为其定义的组/角色分配中派生。 定义的权限仅应用到已分配给组的项目，每个用户在组中都具有组/角色分配。

  • 用户角色
    介绍 Silk Central 中提供的用户角色。
  • 权限定义
    介绍控制用户执行任务和访问 Silk Central 中的安全区域的权限。
父主题： 管理
相关概念
管理组
管理位置
超级用户
用户角色
相关任务
添加项目
将项目初始化为 Issue Manager 项目
编辑项目和项目基线


用户角色

Silk Central 中已预定义以下用户角色：
  • 超级用户
  • 管理员
  • 项目经理
  • Test Manager
  • 测试工程师
  • 分析员
  • 报告程序
  • 角色分配经理

这些角色无法修改或删除。但是可以复制，因此可用作自定义角色的基础。

超级用户

超级用户角色是在 Silk Central 中被授予所有权限的特殊角色。

管理员

管理员任务包括配置应用程序服务器、Web 服务器和图表服务器的位置；设置和维护存储库与通知设置；创建帐户；配置位置和执行服务器等。

管理员被授予 Silk Central 和 Issue Manager 中的所有权限。

项目经理

项目经理维护他们负责的项目。项目经理对 Silk Central 管理单元不具有写入访问权限。项目经理只能访问作为项目经理被分配的项目，在这些项目中，他们对所有相关项目功能具有完全写入访问权限。项目经理也对分配给他们的项目具有所有 Issue Manager 权限。

Test Manager

测试经理的职责包括计划和执行测试，其中包括删除测试。测试经理也对共享步骤和关键字库具有完全访问权限，并对 Silk Central 中的需求区域具有完全读取权限。

测试工程师

测试人员角色与 Silk Central 权限有关。测试人员的任务包括计划和执行测试，但是测试人员不能删除测试。测试人员还对需求区域具有完全读取权限，可以查看、创建和编辑共享步骤和关键字库中的所有对象。

分析员

分析员可分析已分配给他们的项目的结果。他们不能修改项目设置或计划，仅具有只读权限。

报告程序

除具有分析员的所有权限外，报告人员还有权在高级模式下编辑和删除报告。高级模式允许报告人员输入、修改和删除高级报告的 SQL 语句。有关高级报告的详细信息，请参阅 Silk Central 帮助。

角色分配经理

角色分配经理仅具备为组中现有用户分配/取消分配角色的权限，且仅限于已分配给其本人的用户角色。他们无法在组中添加或删除成员，而只能更改其指定为角色分配经理所属的组中的角色分配权限。

  • 添加用户角色
    添加新用户角色。
  • 编辑用户角色
    编辑用户角色。
  • 复制用户角色
    复制用户角色以创建自定义用户角色。
  • 删除用户角色
    删除用户角色。
  • 角色设置页面
    使用此页配置用户角色。
父主题： 用户角色和权限
相关概念
超级用户
用户角色和权限


添加用户角色

添加用户角色：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击角色选项卡。
  3. 单击新建角色。

    将显示新建角色页面。

  4. 键入新角色的名称。
  5. 可选：键入角色的说明。
  6. 在权限设置列表中，选中要授予此角色的所有权限的允许文本框。
    注： 检查顶层父任务将自动检查该父任务的所有子任务。选择父任务的部分而非所有子任务时，父任务会用灰色复选标记选中，从而表示在该区域具有部分权限。
  7. 单击保存以保存此角色的权限设置。
父主题： 用户角色


编辑用户角色

注： 无法编辑预定义用户角色。 可以编辑自定义用户角色。

要编辑用户角色：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击角色选项卡。
  3. 在角色列表中单击要编辑的角色的名称。

    此时将显示编辑角色页面。

  4. 根据需要编辑角色的名称。
  5. 根据需要编辑角色的说明。
  6. 在权限设置列表中，单击要向此角色授予的所有权限的允许复选框。 取消选中任何不向此角色授予的所选权限。
    注： 检查顶层父任务将自动检查该父任务的所有子任务。选择父任务的部分而非所有子任务时，父任务会用灰色复选标记选中，从而表示在该区域具有部分权限。
  7. 单击保存以保存此角色的权限设置。
父主题： 用户角色


复制用户角色

提示： 复制现有用户角色是创建自定义用户角色的第一步。 复制现有角色后，将其重命名并编辑其权限以满足您的需求。

复制用户角色：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击角色选项卡。
  3. 在要复制的用户角色的操作列中，单击复制角色。 然后，角色副本将显示在用户角色列表中，您可根据需要在此对其进行重命名和自定义。
父主题： 用户角色


删除用户角色

注： 无法删除预定义用户角色。 可以删除自定义用户角色。

要删除用户角色：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击角色选项卡。
  3. 在要删除的用户角色的操作列中，单击删除。 此时将显示确认对话框。
  4. 单击是以确认操作；单击否以中止。 如果您选择是，您将返回用户角色列表，已删除的角色将不再列出。
父主题： 用户角色


角色设置页面

管理 > 用户管理 > 角色

角色设置页面用于配置用户角色。页面显示以下项目：

项 | 说明
操作 | 单击 复制角色 可复制角色，并将其用作新自定义角色的基础。 单击 删除角色 可删除用户角色。
名称 | 在 GUI 中显示的用户角色的名称。
允许新分配 | 单击可允许或阻止现有用户角色接受新用户分配。当用户角色被中止但某些用户帐户仍保留此角色时，这会很有用。
说明 | 用户角色的说明。
创建于 | 创建角色的日期。
创建者 | 创建角色的用户。
父主题： 用户角色


权限定义

要在 Silk Central 中显示权限：在菜单中，单击管理 > 用户管理。 单击角色选项卡。 单击网格中的角色。 此时将显示该角色的权限。

此部分介绍控制用户执行任务和访问 Silk Central 中安全区域的能力的权限。 每个权限类别都有一个单独的列表。

注： 无法编辑预定义角色的权限。
  • 需求权限
    列出了可用于需求的权限。
  • 库权限
    列出对库可用的权限。
  • 测试和执行权限
    列出了可用于测试和执行的权限。
  • 手动执行计划权限
    列出对手动执行计划可用的权限。
  • 问题权限
    列出对问题可用的权限。
  • 质量目标权限
    列出了可用于质量目标的权限。
  • 报告权限
    列出了可用于报告的权限。
  • 项目权限
    列出了可用于项目的权限。
  • 项目设置权限
    列出了可用于项目设置的权限。
  • 管理权限
    列出可用的管理权限。
  • 仪表板面板权限
    介绍查看或编辑某个面板的内容所需的权限。
父主题： 用户角色和权限
相关参考
客户端权限


需求权限

以下权限可用于需求：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
查看需求 |  | X |  | X | X | X | X
管理需求 |  | X |  |  |  |  |
删除需求 |  | X |  |  |  |  |
管理需求管理集成 |  | X |  |  |  | X |
删除需求管理集成 |  | X |  |  |  |  |
父主题： 权限定义


库权限

以下权限对库可用：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
查看库 |  | X |  | X | X | X | X
管理库 |  |  |  |  | X | X |
删除库 |  |  |  |  |  | X |
父主题： 权限定义


测试和执行权限

以下权限可用于测试和执行：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
查看资产 |  | X |  | X | X | X | X
管理资产 |  |  |  |  | X | X |
删除资产 |  |  |  |  |  | X |
开始执行 |  |  |  |  | X | X |
完成执行 |  |  |  |  | X | X |
执行测试 |  |  |  |  | X | X |
同步手动测试运行 |  |  |  |  | X | X |
删除执行计划运行 |  |  |  |  | X | X |
管理源代码管理集成 |  | X |  |  |  | X |
删除源代码管理集成 |  | X |  |  |  | X |
父主题： 权限定义


手动执行计划权限

以下权限对手动执行计划可用：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
查看测试周期和配置 |  | X |  | X | X | X | X
管理测试周期和配置 |  |  |  |  |  | X |
删除测试周期和配置 |  |  |  |  |  | X |
父主题： 权限定义


问题权限

以下权限对问题可用：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
管理问题跟踪集成 |  | X |  |  |  | X |
删除问题跟踪集成 |  | X |  |  |  | X |
父主题： 权限定义


质量目标权限

以下权限可用于质量目标：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
查看质量目标 |  | X |  | X | X | X | X
管理质量目标 |  | X |  |  |  | X |
删除质量目标 |  | X |  |  |  | X |
父主题： 权限定义


报告权限

以下权限可用于报告：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
查看报告 |  | X |  | X | X | X | X
管理报告 |  | X |  |  | X | X | X
管理高级报告 |  |  |  |  |  |  | X
删除报告 |  | X |  |  | X | X | X
管理共享全局报告 |  |  |  |  |  |  | X
删除共享全局报告 |  |  |  |  |  |  | X

共享全局报告权限

共享全局报告在所有项目中对所有用户可用，因此能够更新和删除此类报告的用户角色需要具备特殊权限：管理共享全局报告和删除共享全局报告。这些权限同样适用于共享全局报告中使用的报告模板。具备更新和删除报告的标准报告权限的用户角色可以更新和删除非共享全局报告和报告模板。这表示存在以下特殊情况：
  • 如果用户不具备管理共享全局报告权限，则全局报告和文件夹中的与其他用户共享此报告选项将禁用。
  • 将复制的共享报告粘贴到全局报告树时，如果不具备管理共享全局报告权限，所粘贴的报告将设置为非共享
父主题： 权限定义


项目权限

以下权限可用于项目：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
管理项目 |  | X |  |  |  | X |
删除项目 |  | X |  |  |  | X |
父主题： 权限定义


项目设置权限

以下权限可用于项目设置：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
查看项目设置 |  | X |  | X | X | X | X
管理项目设置 |  | X |  |  | X | X |
删除项目设置 |  | X |  |  |  | X |
管理筛选器 |  | X |  |  | X | X |
删除筛选器 |  | X |  |  | X | X |
修改其他用户的专用筛选器 |  | X |  |  |  | X |
删除其他用户的专用筛选器 |  | X |  |  |  | X |
修改 Office 导入映射文件 |  | X |  |  |  | X |
父主题： 权限定义


管理权限

以下权限可用于管理：

 | 管理员 | 项目经理 | 角色分配经理 | 分析员 | 测试工程师 | Test Manager | 报告程序
查看系统设置 | X | X |  |  |  | X | X
管理系统设置 | X |  |  |  |  |  |
查看管理设置 | X | X | X |  |  | X | X
管理管理设置 | X |  |  |  |  |  |
管理用户的角色分配 | X |  | X |  |  |  |
删除管理设置 | X |  |  |  |  |  |
查看和删除日志文件 | X | X |  |  |  | X | X
管理执行服务器 | X |  |  |  |  |  |
删除执行服务器 | X |  |  |  |  |  |
激活和停用执行服务器 | X |  |  |  |  |  |
查看产品、版本和内部版本 | X | X |  |  |  | X | X
管理产品、版本和内部版本 | X |  |  |  |  |  |
删除产品、版本和内部版本 | X |  |  |  |  |  |
父主题： 权限定义


用户帐户和组

必须为使用 Silk Central 的每个用户创建用户帐户。可将用户的一个或多个组分配给特定项目。只有具有用户帐户、用户角色和组分配，用户才能使用 Silk Central 项目。

  • 维护用户帐户
    介绍如何维护用户帐户。
  • 管理组
    介绍如何维护组。
父主题： 管理


维护用户帐户

用户帐户可跟踪各个用户的登录数据和配置设置。 它们还可以启用用户登录。 用户帐户通常分配给组帐户，并且每个特定项目具有一个或多个特定的用户角色。 超级用户是唯一能够配置应用程序、Web 和图表服务器位置以及设置和维护存储库及通知设置的用户角色。

警告：
由于超级用户帐户 admin 拥有所有管理权限，您应立即为此用户创建新密码以防止对这些权限的无限制访问。有关更改密码的更多信息，请参阅更改系统管理员帐户的密码。
  • 添加用户帐户
    在 Silk Central 中创建用户帐户。
  • 编辑用户帐户
    在 Silk Central 中编辑用户帐户。
  • 删除用户帐户
    删除用户帐户。
  • 用户设置页面
    使用此页配置用户帐户。
父主题： 用户帐户和组


添加用户帐户

添加用户帐户：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击帐户选项卡。 该页面将显示所有可用的用户帐户。首次访问此页面时，超级用户帐户 admin 是列出的唯一用户。
  3. 单击新建用户。 将显示添加新用户帐户页面。
  4. 键入用户的用户名和密码。 重新键入密码以进行确认。
  5. 选中混合模式验证 (LDAP) 复选框以启用 LDAP 和基于本地凭据的验证。
  6. 如果要防止用户登录，请将登录设置为已锁定。
  7. 键入用户的名字、姓氏和电子邮件地址。
  8. 键入用户的本地时区并选择日期格式、短日期格式和一周的第一天。
  9. 键入页面刷新时间（以秒为单位）、CSV 分隔符字符串和默认执行服务器。
  10. 从相应的列表框中选择组和角色定义。
  11. 单击添加分配以将组和角色组合添加到用户帐户。
  12. 重复前两个步骤以将所有需要的组和角色组合分配给用户帐户。
  13. 要从当前用户帐户中删除组和角色组合，请单击操作列中的删除图标。
  14. 单击保存以保存您的设置。
父主题： 维护用户帐户
相关概念
日期和时间格式
相关任务
编辑用户帐户
删除用户帐户


编辑用户帐户

在设置用户帐户后，您可以编辑除登录名称以外的任何参数。

注： 当已更改的用户帐户下次登录时，对用户帐户所做的更改将生效。 请通知用户注销并重新登录。

要编辑用户帐户：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击帐户选项卡。 该页面将显示所有可用的用户帐户。首次访问此页面时，超级用户帐户 admin 是列出的唯一用户。
  3. 单击要编辑的用户帐户的登录名称。 此时将显示配置现有用户页面。
  4. 根据需要编辑用户的密码。 重新键入密码以进行确认。
  5. 选中混合模式验证 (LDAP) 复选框以启用 LDAP 和基于本地凭据的验证。
  6. 根据需要编辑其他用户设置。
  7. 从相应的列表框中选择组和角色定义。
  8. 单击添加分配以将组和角色组合添加到用户帐户。
  9. 重复前两个步骤以将所有需要的组和角色组合分配给用户帐户。
  10. 要从当前用户帐户中删除组和角色组合，请单击操作列中的删除。
  11. 单击保存以保存您的设置。
父主题： 维护用户帐户
相关概念
日期和时间格式
相关任务
添加用户帐户
删除用户帐户


删除用户帐户

警告：
删除用户帐户操作是不可逆的。 如果您希望使帐户临时不可用，您可以锁定用户帐户。 有关锁定用户帐户的其他信息，请参阅编辑用户帐户。

要删除用户帐户：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击帐户选项卡。 该页面将显示所有可用的用户帐户。首次访问此页面时，超级用户帐户 admin 是列出的唯一用户。
  3. 在要删除的用户帐户的操作列中，单击删除。 此时将显示确认对话框。
  4. 单击是以确认操作；单击否以中止。 如果您选择是，您将返回用户帐户列表，已删除的帐户将不再列出。
父主题： 维护用户帐户
相关概念
日期和时间格式
相关任务
添加用户帐户
编辑用户帐户


用户设置页面

管理 > 用户管理 > 帐户 > 新建/编辑用户

使用用户设置页面配置用户帐户。用户帐户设置与组帐户设置密切相关。

您可以单击菜单中的用户名称以访问登录用户的用户设置页面。

注： 您必须至少定义一个组和角色分配才可保存用户帐户。
登录数据项 | 说明
登录 | 存储在 Silk Central 存储库中的用户名。如果您选中以下混合模式验证 (LDAP)，则输入的用户名必须匹配定义的 LDAP 用户名。
密码 | 输入您登录的有效密码。此密码与 LDAP 密码无关。
确认密码 | 重新输入密码进行确认。
混合模式验证 (LDAP) | 选中此复选框可启用 LDAP 和基于本地凭据的验证。如果 LDAP 服务器已存在，不选中此复选框将导致仅 LDAP 验证。
已锁定 | 如果您要防止用户使用给定凭据登录，则选中此复选框。这会使用户帐户处于非活动状态。
一般数据项 | 说明
名字 | 键入用户的名字。此信息不影响 Silk Central 的行为；它只跟踪用户联系信息。
姓氏 | 键入用户的姓氏。此信息不影响 Silk Central 的行为；它只跟踪用户联系信息。
电子邮件 | 键入用户的电子邮件地址。此信息用于通知目的。
主题 | 选择一个 Silk Central 版本，以设置 Silk Central 的 UI 将向所选用户显示的相应配色方案。
时区 | 用户的当地时区。时区信息用于显示用户当地时区的显示时间和日期。
日期格式 | 当 Silk Central 显示长日期格式时，选定的日期格式将提供给列表、报告和日历中的用户。
短日期格式 | 当 Silk Central 显示短日期格式时，选定的日期格式将提供给列表、报告和日历中的用户。
一周的第一天 | 一周的第一天确定报告中的周视图。
CSV 分隔符字符串 | 此字符串用作用户已下载的 CSV 文件的行分隔符。报告可以下载为 CSV 文件。
默认执行服务器 | 默认执行服务器用于尝试运行自动测试。
组和角色分配项 | 说明
组和角色分配表 | 列出用户的所有现有用户组/用户角色分配。您也可以单击要删除的分配旁边的 删除 来删除组和角色分配。
组 | 选择要将用户分配到的组。此列表框列出了 Silk Central 管理员定义的用户组。如果已将用户分配到组，则仅列出从 LDAP 服务器导入的组。
用户角色 | 选择与用户一起分配给选定组的用户角色。 列表用预定义系统角色和自定义用户角色填充。
添加 | 单击此按钮可通过您选择的组和用户角色来创建新用户组/用户角色分配。
父主题： 维护用户帐户


管理组

组可定义特定项目的访问权限。每个用户都可与一个或多个组关联，它们可从中继承为所选组定义的项目的访问权限。

注： 用户可以添加到具有多个角色的组，允许进行高级用户权限配置。
  • 添加组
    创建组。
  • 从 LDAP 服务器导入组
    从 LDAP 服务器导入组和自动创建 Silk Central 用户。
  • 计划自动 LDAP 组同步
    如果已将用户组从 LADP 服务器导入 Silk Central 系统中，则可指定计划，以自动同步您的 Silk Central 组和 LADP 服务器上所做的更改。
  • 编辑组
    编辑组。
  • 删除组
    删除组。
  • 组设置页面
    使用此页配置用户组。
父主题： 用户帐户和组
相关概念
管理位置
用户角色和权限
相关任务
添加项目
将项目初始化为 Issue Manager 项目
编辑项目和项目基线


添加组

添加组：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击组选项卡。
  3. 单击新建组。
  4. 在组名文本框中，键入新组的组名。
  5. 在说明文本框中，输入新组的说明。
  6. 使用各列表框中的角色分配选择用户，然后单击添加选定内容以将用户和角色组合添加到新的组。
    注： 任何已定义为不接受新用户分配的用户角色都不会显示在此列表中。这些设置通过管理 > 用户管理 > 角色中的允许新分配按钮进行控制。

    对于从 LDAP 服务器导入的组，可向用户添加其他角色分配，也可删除角色分配，但每个用户必须至少保留一个角色分配。从通过 LDAP 导入的组中删除用户这一操作只能在 LDAP 服务器上完成。

  7. 重复上一步以将所有需要的用户和角色组合添加到组。
    提示： 将角色分配经理角色分配给组中的一个或多个用户可能会很有用。角色分配经理仅具备为组中现有用户分配/取消分配角色的权限，且仅限于已分配给其本人的用户角色。他们无法在组中添加或删除成员，而只能更改其指定为角色分配经理所属的组中的角色分配权限。
  8. 要从当前组中删除用户和角色组合，请单击操作列中的 删除 。
  9. 在项目分配部分，您可将任何现有项目分配到此组。
  10. 单击保存。
父主题： 管理组


从 LDAP 服务器导入组

从 LDAP 服务器导入组和自动创建 Silk Central 用户。
必须配置 LDAP 服务器才能从 LADP 服务器导入组。有关详细信息，请参阅添加 LDAP 服务器。
要将 LDAP 组及其关联用户导入 Silk Central，请执行以下操作：
  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击组选项卡。
  3. 单击导入 LDAP 组。 此时将显示导入 LDAP 组对话框。
  4. 如果您的 LDAP 服务器配置已设置为使用域，且已导入用户应使用 <域>\<用户名> 模式登录 Silk Central，请选择一个 LDAP 域。如果已导入用户应在不输入域名的情况下登录 Silk Central，请选择默认域。
  5. 选择要导入的 LDAP 组。
  6. 选择 Silk Central 默认角色。所选 LDAP 组的所有用户都将使用此角色进行设置。
  7. 单击确定。
从 LDAP 导入组后，建议检查组设置，尤其是项目分配。请注意，不能在已导入的 LDAP 组中添加或删除用户，因为此分配通过 LDAP 服务器严格处理。但是，您可修改单个用户的角色。
提示： 将角色分配经理角色分配给组中的一个或多个用户可能会很有用。角色分配经理仅具备为组中现有用户分配/取消分配角色的权限，且仅限于已分配给其本人的用户角色。他们无法在组中添加或删除成员，而只能更改其指定为角色分配经理所属的组中的角色分配权限。

所有通过 LDAP 服务器导入的组都将按照计划自动更新。有关更改或者停用此项计划，请参阅 “计划自动 LDAP 组同步“。

父主题： 管理组
相关任务
添加项目
编辑项目和项目基线
添加 LDAP 服务器
计划自动 LDAP 组同步


编辑组

要编辑组，请执行以下操作：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击组选项卡。
  3. 单击要编辑的组的组名称。 此时将显示配置现有用户组页面。
  4. 在组名称文本框中，根据需要编辑名称。从 LDAP 服务器导入的组的此字段不可编辑。
  5. 在说明文本框中，根据需要编辑组的说明。
  6. 使用各列表框中的角色分配选择用户，然后单击添加选定内容以将用户和角色组合添加到新的组。
    注： 任何已定义为不接受新用户分配的用户角色都不会显示在此列表中。这些设置通过管理 > 用户管理 > 角色中的允许新分配按钮进行控制。

    对于从 LDAP 服务器导入的组，可向用户添加其他角色分配，也可删除角色分配，但每个用户必须至少保留一个角色分配。从通过 LDAP 导入的组中删除用户这一操作只能在 LDAP 服务器上完成。

  7. 重复上一步以将所有需要的用户和角色组合添加到组。
    提示： 将角色分配经理角色分配给组中的一个或多个用户可能会很有用。角色分配经理仅具备为组中现有用户分配/取消分配角色的权限，且仅限于已分配给其本人的用户角色。他们无法在组中添加或删除成员，而只能更改其指定为角色分配经理所属的组中的角色分配权限。
  8. 要从当前组中删除用户和角色组合，请单击操作列中的 删除 。
  9. 对于从 LDAP 服务器导入的组，单击与 LDAP 同步，以同步 LDAP 服务器上的更改和 Silk Central。 如果用户已从 LDAP 组中删除，则其所有的角色分配也会从组中删除。如果已在 LDAP 中添加用户，则会创建具有默认角色的新角色分配。所有其他角色分配保持不变。
    注： 当用户登录 Silk Central 时，组分配会自动同步。
  10. 在项目分配部分，您可将任何现有项目分配到此组。
  11. 单击保存以返回组页面。
父主题： 管理组
相关任务
删除组


删除组

在删除组之前，您必须从组中删除所有用户和角色分配。此限制不适用于从 LDAP 服务器导入的组。有关修改组的其他信息，请参阅编辑组。

要删除组：

  1. 在菜单中，单击管理员 > 用户管理。
  2. 单击组选项卡。
  3. 在要删除的组的操作列中，单击 删除组 。 此时将显示确认对话框。
  4. 单击是以确认操作；单击否以中止。
注： 删除从 LDAP 服务器导入的组时，同时也会删除所有用户/角色分配。如果已删除组的用户在任何其他组中没有分配，则用户将在 Silk Central 中删除。
父主题： 管理组
相关任务
编辑组


组设置页面

管理 > 用户管理 > 组 > 新建/编辑组

使用组设置页面配置用户组。组设置与用户帐户设置密切相关。页面显示以下项目：

项 | 说明
组名 | 指定组的名称，因为其将显示在 GUI 中。可为组定义任何名称。
说明 | 组的说明。您可以输入任何说明文本。
帐户和角色分配 | 列出组的所有现有用户/角色分配。您还可通过单击要删除的分配旁边的 删除 来删除用户和角色分配。
用户 | 此列表列出了管理员已定义的用户帐户。选择要分配到组的用户。
角色定义 | 列表用预定义系统角色和自定义用户角色填充。 选择与用户一起分配给选定组的用户角色。
添加选定内容 | 单击以用选定的用户和用户角色创建新的用户帐户和用户角色分配。
项目分配 | 列出所有现有项目以及是否将其分配到组帐户。选中项目旁边的复选框以将项目分配到组帐户。如果不存在项目，您可在创建后再对其进行分配。
全选 | 选中所有列出项目的复选框。
取消全选 | 取消选中所有列出项目的复选框。
父主题： 管理组


执行环境

管理执行环境，指定在何处执行 Silk Central 测试。Silk Central 的执行环境包含物理和虚拟（云托管）执行服务器，分组在称为位置的逻辑容器中。

位置是执行服务器的逻辑容器。有关设置执行服务器的信息，请参阅设置执行服务器。由于 Silk Central 支持存在点 (PoP) 的全球分布 - 执行服务器的分布，因此最好按照位置分组执行服务器。位置不一定是实际位置，只是用于将执行服务器分组为易于管理的单元。

Silk Central 执行服务器负责执行计划 测试，例如 Silk Test Classic 和 Silk Performer 脚本。执行服务器可以是物理计算机，也可以是虚拟（云托管）计算机。

  • 管理位置
    介绍 Silk Central 中位置的概念背景。
  • 设置执行服务器
    介绍 Silk Central 中执行服务器的概念背景。
  • 云集成
    介绍如何配置云配置文件，以便与公共云或私有云服务提供程序集成。
  • 管理设备提供程序
    设备提供程序是指承载移动仿真器和模拟器的计算机和/或已连接物理移动设备的计算机，可通过访问这些计算机来执行测试。
父主题： 管理


管理位置

位置是执行服务器的逻辑容器。有关设置执行服务器的信息，请参阅设置执行服务器。由于 Silk Central 支持存在点 (PoP) 的全球分布 - 执行服务器的分布，因此最好按照位置分组执行服务器。位置不一定是实际位置，只是用于将执行服务器分组为易于管理的单元。

注： Silk Central 将自动创建称为本地的默认位置。
  • 添加位置
    创建新位置以添加执行服务器的逻辑容器。
  • 编辑位置
    编辑位置。
  • 删除位置
    删除现有位置。
  • “新建位置”对话框
    使用此对话框可配置位置设置。
父主题： 执行环境
相关概念
设置执行服务器
管理组
用户角色和权限
相关任务
添加项目
将项目初始化为 Issue Manager 项目
编辑项目和项目基线


添加位置

添加新位置：

  1. 在菜单中，单击管理 > 执行环境。
  2. 单击新建位置。

    将显示新建位置对话框。

  3. 键入位置名称。
  4. 如果已指定代理服务器的位置，请选中相应的复选框以选择使用系统代理。 有关更多信息，请参阅配置系统代理。
  5. 在位置代理部分，您可定义此位置的执行服务器与应用程序服务器通信所用的代理服务器。
  6. 在主机文本框中，键入托管代理服务的计算机的名称。
  7. 在端口文本框中，键入代理主机的端口号。
  8. 如果代理服务器需要用户名/密码身份验证，请在用户名和密码文本框中键入有效凭据。
  9. 项目部分包括现有项目列表。选中要分配到此位置的项目的已分配复选框。
  10. 单击确定以添加新位置。
父主题： 管理位置
相关任务
配置系统代理


编辑位置

介绍如何编辑位置。

要编辑位置：

  1. 在菜单中，单击管理 > 执行环境。
  2. 选择要修改的位置，单击 编辑 。

    此时将显示编辑位置对话框。

  3. 根据需要修改位置名称。
  4. 如果已指定代理服务器的位置，请选中相应的复选框以选择使用系统代理。 有关更多信息，请参阅配置系统代理。
  5. 在位置代理部分，您可定义此位置的执行服务器与应用程序服务器通信所用的代理服务器。
  6. 在主机文本框中，键入托管代理服务的计算机的名称。
  7. 在端口文本框中，键入代理主机的端口号。
  8. 如果代理服务器需要用户名/密码身份验证，请在用户名和密码文本框中键入有效凭据。
  9. 项目部分包括现有项目列表。选中要分配到此位置的项目的已分配复选框。
  10. 单击确定。
父主题： 管理位置
相关任务
配置系统代理


删除位置

提示： 在删除位置之前，您必须先从该位置删除所有已分配的执行服务器。有关更多信息，请参阅删除执行服务器。

要删除位置：

  1. 在菜单中，单击管理 > 执行环境。
  2. 选择要删除的位置，单击 删除 。 此时将显示确认对话框，要求您确认删除。
  3. 单击是以删除位置，或单击否以中止操作。
父主题： 管理位置
相关任务
删除执行服务器


“新建位置”对话框

管理 > 执行环境 > 执行服务器 > 新建位置

使用新建位置对话框可配置位置。

项 | 说明
名称 | 指定在 GUI 和报告中显示的位置名称。
使用系统代理 | 启用此设置将强制此位置的所有执行服务器通过定义的系统代理与应用程序服务器通信。如果未启用此设置，应用程序服务器将直接与执行服务器通信，除非您定义位置代理。如果未定义任何系统代理，则此复选框将被禁用。
位置代理 | 使用此区域定义此位置的执行服务器通过其与应用程序服务器通信的代理服务器。如果您希望此位置的执行服务器直接与应用程序服务器通信，或者如果已选中使用系统代理选项，请将该字段留空。您还可以定义系统代理和位置代理，在这种情况下，将通过这两个代理进行通信。 您只能定义支持安全套接字层 (SSL) 的位置代理。所有执行服务器都必须使用该代理的 SSL 端口。有关执行服务器设置的详细信息，请参阅设置执行服务器。
主机名 | 托管代理服务的计算机名称。
端口 | 代理主机的端口号。默认为端口 443。
用户名 | 如果代理服务器要求用户名/密码验证，请输入有效的用户名。
密码 | 如果代理服务器要求用户名/密码验证，请为用户名文本框中指定的用户输入有效密码。
已分配的项目 | 列出所有现有项目。选中项目旁边的复选框以将项目分配到位置。如果不存在项目，您可在创建后再对其进行分配。有关更多信息，请参阅添加项目。所选项目可访问此位置的执行服务器。
全选 | 选中所有列出项目的复选框。
取消全选 | 取消选中所有列出项目的复选框。
父主题： 管理位置
相关任务
设置执行服务器
添加项目


设置执行服务器

Silk Central 执行服务器负责执行计划 测试，例如 Silk Test Classic 和 Silk Performer 脚本。执行服务器可以是物理计算机，也可以是虚拟（云托管）计算机。

要执行 Silk Test Classic 和 Silk Performer 测试，Silk Test Classic 或 Silk Performer 软件必须安装在安装 Silk Central 执行服务器的相同计算机上。

对多字节应用程序或网页执行 Silk Performer 脚本时，请查看 Silk Performer 帮助中的多字节支持部分。

如需了解执行服务器安装的更多详细信息，请参阅安装 Silk Central。有关 Silk Test Classic 和 Silk Performer 的信息，请参阅其各自的产品文档。

  • 使用关键字执行硬件配置
    介绍如何管理具有大量执行服务器的测试环境。
  • 配置物理执行服务器
    配置物理执行服务器。
  • 配置云托管的执行服务器
    配置云托管的执行服务器。
  • 创建和分配执行服务器关键字
    新建执行服务器关键字，并将其分配到执行服务器，以定义要在该服务器上执行的执行。
  • 激活或停用执行服务器
    激活或停用位置内的现有执行服务器。
  • 删除执行服务器
    删除现有执行服务器以从安装中断开执行服务器。
  • 配置执行服务器的非标准 SSL 端口
    配置应用程序服务器与执行服务器通信所用的自定义 SSL 端口。
  • 新建/编辑执行服务器对话框
    配置位置内的执行服务器。
父主题： 执行环境
相关概念
安装 Silk Central
相关任务
安装 Windows 执行服务器
安装 Linux 执行服务器


使用关键字执行硬件配置

Silk Central 的硬件配置技术可帮助您管理包含多个执行服务器的测试环境。无须在每个执行服务器与执行计划之间配置一对一直接关系，关键字使 Silk Central 能够选择为每个执行计划选择最适合的执行服务器。这是通过将执行计划的关键字列表与所有活动执行服务器的关键字列表进行动态比较来完成的。

关键字通常描述了执行服务器的环境，例如平台、操作系统和预安装应用程序。当执行执行计划时，Silk Central 会将执行计划的关键字与所有可用执行服务器的关键字进行比较。随后执行会在与执行计划关键字列表匹配的执行服务器上运行。如果没有匹配的执行服务器，则执行不会运行。如果存在多个具有匹配关键字列表的执行服务器，则执行将在最先识别的执行服务器上运行。

对于安装 Silk Test 的物理执行服务器，Silk Central 根据已安装的浏览器和连接的移动设备自动分配关键字。

保留的默认关键字

如果您不需要硬件配置，您可以依赖为每个执行服务器自动创建的保留关键字。在这种情况下，无需手动将关键字分配至执行服务器。相反，您可以为每个执行计划配置一对一的静态执行服务器分配。

保留关键字将自动分配至每个新创建的执行服务器。保留关键字采用以下结构形式：
 #<execution server name>@<location name>

当为执行计划分配关键字时，保留关键字可用。当为执行服务器分配关键字时，它们既不可用也不适用。

除了为每个定义的执行服务器自动设置保留关键字以外，还会为每个执行服务器类型设置保留关键字：

#PHYSICAL

将执行服务器配置限制为物理执行服务器。

#VIRTUAL

将执行服务器配置限制为虚拟执行服务器。

关键字和虚拟执行服务器

为虚拟执行服务器分配关键字的方式与为物理执行服务器分配关键字的方式相同。当您配置至少一个虚拟执行服务器时，#VIRTUAL 关键字将自动创建并且可分配至所有执行计划。如果您希望在虚拟机上运行执行，请为执行计划选择 #VIRTUAL 关键字。如果执行计划没有 #VIRTUAL 或 #PHYSICAL 关键字（或都没有），则可能将在虚拟或物理执行服务器上执行（假设执行环境的设置相同）。如果执行计划的关键字与多个虚拟执行服务器匹配，则将选择识别出的第一个匹配的虚拟执行服务器。

父主题： 设置执行服务器


配置物理执行服务器

物理执行服务器在物理计算机或虚拟机 (VM) 上运行。配置物理执行服务器：

  1. 在菜单中，单击管理 > 执行环境。
  2. 选择要配置执行服务器的位置。
    • 要创建新执行服务器，请单击新建物理执行服务器。
    • 要编辑现有执行服务器，请单击操作列中的相应编辑按钮。
    注： 必须停用执行服务器才能编辑其属性。但活动执行服务器的关键字列表可进行编辑。
  3. 在主机名或 IP 地址文本框中输入有效的 IP 地址或主机名。
  4. 在名称字段中输入执行服务器的名称。
  5. 单击关键字以从列表中选择关键字或添加描述执行服务器的新关键字。 将在执行时分析这些关键字，以便为每次执行动态选择相应的服务器。有关更多信息，请参阅创建和分配执行服务器关键字。
  6. 如果您不使用默认设置，则只需修改高级部分的设置。在端口文本框中指定执行服务器的侦听端口。
    注： 如果要通过 SSL 连接到执行服务器，请选中使用 SSL 复选框。
    提示： 要通过非标准 SSL 端口连接到执行服务器，请参阅配置执行服务器的非标准 SSL 端口。
  7. 可选：在响应超时文本框中键入响应超时时间（以秒为单位）。如果执行服务器在指定时间内无法访问，Silk Central 管理员将收到电子邮件通知。如果不希望 Silk Central 在此类情况下发送电子邮件，请输入 0。
  8. 可选：如果需要，请更改此执行服务器上最大并行执行数的数量。如果您启用了执行计划的并行执行功能，则此数量为允许在此执行服务器上并行运行的最大执行计划数量。请注意，允许过多并行执行会严重影响执行服务器的性能，并可能会导致测试执行失败。
  9. 单击确定以保存您的设置。如果您收到错误消息，请确保设置正确，网络适当配置且已在您设置的执行服务器上安装了所需软件。
    重要： 因为安装执行服务器需要管理权限，如果已启用 UAC，将无法自动升级执行服务器。在托管执行服务器的所有计算机上禁用 UAC。
    注： 如果执行服务器的版本为无效旧版本，但版本比 SilkCentral Test Manager 2009 SP1 新，执行服务器将自动升级为最新的 Silk Central 版本。Silk Central 将在执行服务器列表的信息列中显示一条有关升级的消息。只要升级流程尚未完成，将不会使用升级执行服务器。
父主题： 设置执行服务器
相关任务
配置执行服务器的非标准 SSL 端口
创建和分配执行服务器关键字


配置云托管的执行服务器

云托管的执行服务器在云提供程序（如 VMware vCloud）上运行。要配置云托管的执行服务器，请执行以下操作：

  1. 在菜单中，单击管理 > 执行环境。
  2. 选择要配置执行服务器的位置。
    • 要创建新执行服务器，请单击新建虚拟执行服务器。
    • 要编辑现有执行服务器，请单击操作列中的相应编辑按钮。
    • 要同步使用云提供程序的模板的执行服务器列表，请选择云提供程序选项卡。单击操作列中的 [image] ，同步使用此云提供程序的模板的执行服务器列表。这将删除具有已分配不再存在的模板的此配置文件的所有虚拟执行服务器。应用 Hotfix 以后，还会更新自动创建的虚拟执行服务器的模板。
    注： 必须停用执行服务器才能编辑其属性。但活动执行服务器的关键字列表可进行编辑。
  3. 在云提供程序列表中，从已配置云提供程序配置文件中进行选择，确定将此执行服务器用于自动运行时，将虚拟环境部署到哪个云中。
  4. 在虚拟映像模板列表中，选择用于为各自动运行创建新实例的映像模板。根据云提供程序的不同，映像模板至少包含一个虚拟机映像。Silk Central 执行服务器必须在某个虚拟机映像内运行。如果执行服务器版本已过期，在为各自动运行部署虚拟环境后，服务器将自动升级。如果 VM 映像运行的是当前执行服务器版本，部署过程将更快。
  5. 在名称字段中输入执行服务器的名称。
  6. 单击关键字以从列表中选择关键字或添加描述执行服务器的新关键字。 将在执行时分析这些关键字，以便为每次执行动态选择相应的服务器。有关更多信息，请参阅创建和分配执行服务器关键字。
  7. 如果您不使用默认设置，则只需修改高级部分的设置。在端口文本框中指定执行服务器的侦听端口。
    注： 如果要通过 SSL 连接到执行服务器，请选中使用 SSL 复选框。
    提示： 要通过非标准 SSL 端口连接到执行服务器，请参阅配置执行服务器的非标准 SSL 端口。
  8. 可选：在响应超时文本框中键入响应超时时间（以秒为单位）。如果云提供程序上的执行服务器在指定时间内无法访问，虚拟机将会关闭。如果不希望在此类情况下关闭虚拟机，请输入 0（如果永远无法访问虚拟机，则将需要您手动中止测试运行）。
  9. 单击确定保存您的设置，允许执行服务器根据指定的关键字自动运行。如果收到错误消息，请确保端口设置正确，并且已在虚拟机映像上安装执行服务器。如果错误消息表明已安装的执行服务器版本无效，则可忽略此错误，因为每次自动运行都将自动升级服务器。
父主题： 设置执行服务器
相关概念
云集成
云集成
相关任务
添加云配置文件
配置执行服务器的非标准 SSL 端口
创建和分配执行服务器关键字


创建和分配执行服务器关键字

创建和分配执行服务器关键字：

  1. 在菜单中，单击管理 > 执行环境。
  2. 选择一个位置，以访问该位置的已定义执行服务器列表。
  3. 在预定义执行服务器的操作列中，单击 编辑 ，或者单击新建物理执行服务器或新建虚拟执行服务器，以为新执行服务器创建关键字。
    注： 对于安装 Silk Test 的物理执行服务器，Silk Central 根据已安装的浏览器和连接的移动设备自动分配关键字。单击操作列中的 [image] 以刷新已分配关键字列表。
  4. 单击关键字。 此时将显示分配关键字对话框。
  5. 在选择或输入关键字字段中输入新关键字，或者选择一个描述执行服务器环境（例如，平台、操作系统或预装应用程序）的现有关键字。关键字中不能使用以下字符：# $ ?* \ , ; ' "
    注： 如果使用新的 Silk Central 安装，则可能无法看见任何可用关键字。虽然关键字在分配关键字对话框中不可见，但仍将为系统所配置的每台执行服务器创建保留关键字。这些保留关键字仅在将关键字分配到执行计划时可用。
    您可使用 Ctrl+单击或 Shift+单击，以通过标准 Windows 多选功能选择多个关键字。注意，如果在列表中选择多个关键字，选择或输入关键字字段将被禁用。 如果不需要硬件配置，您可使用为每台执行服务器创建的默认保留关键字。在此情况下，不必将其他关键字分配到执行服务器。
  6. 单击添加 (>) 以将关键字移到已分配的关键字列表中。
  7. 单击确定可保存关键字并关闭分配关键字对话框。
父主题： 设置执行服务器
相关任务
配置执行服务器的非标准 SSL 端口


激活或停用执行服务器

  1. 在菜单中，单击管理 > 执行环境。
  2. 选择一个位置，以访问为该位置定义的执行服务器列表。
  3. 在要激活或停用的执行服务器的状态列中，单击非活动/活动。
    重要： 因为安装执行服务器需要管理权限，如果已启用 UAC，将无法自动升级执行服务器。在托管执行服务器的所有计算机上禁用 UAC。
    注： 如果执行服务器的版本为无效旧版本，但版本比 SilkCentral Test Manager 2009 SP1 新，执行服务器将自动升级为最新的 Silk Central 版本。Silk Central 将在执行服务器列表的信息列中显示一条有关升级的消息。只要升级流程尚未完成，将不会使用升级执行服务器。
父主题： 设置执行服务器
相关任务
删除执行服务器


删除执行服务器

提示： 要防止数据不一致，您需要先停用执行服务器，然后再删除它。有关其他信息，请参阅激活或停用执行服务器。
注： 删除执行服务器不会删除实际的软件安装。删除操作只会断开执行服务器的连接。您可以重新添加之前删除的执行服务器。要将执行服务器分配到不同的应用程序服务器，需要在安装执行服务器的计算机上删除以下文件：C:\ProgramData\SilkCentral\AgentBase\ItemObjects.ser.
  1. 在菜单中，单击管理 > 执行环境。
  2. 选择一个位置，以访问为该位置定义的执行服务器列表。
  3. 在要删除的执行服务器的操作列中，单击 删除 。
父主题： 设置执行服务器
相关任务
激活或停用执行服务器


新建/编辑执行服务器对话框

管理 > 执行环境 > 执行服务器 > 新建/编辑执行服务器

使用新建/编辑执行服务器对话框来配置某个位置中的执行服务器。

项 | 说明
名称 | 为执行服务器定义名称。此名称将出现在指定计算机执行的所有表和结果报告中。您最多可输入 100 个字符。
说明 | 执行服务器的说明。您可以输入任何说明文本。
物理执行服务器 | 选择此选项可将物理机指定为执行服务器。
主机或 IP 地址

指定安装执行服务器的计算机的主机名称或 IP 地址。

某些网络仅可在您指定完整的主机名称（包括域名，例如 MyHost.MyDomain）时才能查找执行服务器。
端口 | 指定在执行服务器侦听的主机或 IP 地址文本框中定义的计算机端口。默认端口为 19124。
使用 SSL

如果您要通过安全套接字层 (SSL) 将应用程序服务器连接至执行服务器，则选中此复选框。默认 SSL 端口为 19125。

如果您选择为此执行服务器分配到的位置使用代理服务器，则必须通过端口 443 选择使用 SSL。
响应超时 [秒]

对于虚拟执行服务器：在响应超时文本框中键入响应超时时间（以秒为单位）。如果云提供程序上的执行服务器在指定时间内无法访问，虚拟机将会关闭。如果不希望在此类情况下关闭虚拟机，请输入 0（如果永远无法访问虚拟机，则将需要您手动中止测试运行）。

对于物理执行服务器：在响应超时文本框中键入响应超时时间（以秒为单位）。如果执行服务器在指定时间内无法访问，Silk Central 管理员将收到电子邮件通知。如果不希望 Silk Central 在此类情况下发送电子邮件，请输入 0。
关键字 | 列出为此执行服务器定义的关键字。关键字启用了 Silk Central 硬件配置技术，以动态识别每个测试执行的最适合的执行服务器。单击关键字可编辑该执行服务器的关键字列表。
父主题： 设置执行服务器


云集成

Silk Central 使您可以配置云提供程序配置文件，以便与公共云或私有云服务提供程序集成。云配置文件基于插件概念，让您能为特定云提供程序编写自己的插件。云提供程序插件将在每次自动测试运行之前部署虚拟环境。
注： 云 API 在即将推出的 Silk Central 版本中可能会有所更改。如果您在使用此 API，升级到将来版本的 Silk Central 后可能需要更新实施。
  • 添加云配置文件
    添加云配置文件，以便与公共云或私有云服务提供程序集成。
  • 编辑云配置文件
    编辑云配置文件，以修改访问公共云或私有云服务提供程序的方式。
  • 删除云配置文件
    如果您不再需要访问特定公共云或私有云服务提供程序，可删除云配置文件。
  • VMware vCloud 集成
    列出特定于 VMware vCloud 的信息和限制。
  • 云提供程序页面
    列出为您的系统配置的云提供程序配置文件。
父主题： 执行环境
相关概念
云集成
相关任务
配置云托管的执行服务器


添加云配置文件

添加云配置文件，以便与公共云或私有云服务提供程序集成。
  1. 在菜单中，单击管理 > 执行环境。
  2. 单击云提供程序选项卡。
  3. 单击新建配置文件。 此时将打开新建云提供程序配置文件对话框。
  4. 从已安装插件的类型列表中选择您要访问的云提供程序。VMware vCloud 和 Amazon Web 服务均直接受支持。
  5. 在名称字段中，输入配置文件名称。在创建云托管的执行服务器时，此名称将显示在配置文件列表中。
  6. 在用户名和密码字段中输入有效凭据，以远程访问云系统。对于 Amazon Web 服务，则分别是访问密钥和密钥。
  7. 要配置 VMware vCloud 配置文件（若要配置其他配置文件，请跳过此步骤）：
    1. 输入仅包含主机名的 URL，不要附加通过 Web 浏览器访问系统时使用的 /cloud/org/<组织名称>。示例：https://vdirectorweb。
    2. 可选：版本：如果您使用的是 VMware vCloud Director 5.5（默认），请将此字段留空。如果您使用的是 vCloud Director 5.1，请输入 V5.1。
    3. 组织：请输入要访问的 vCloud 组织的名称，例如 dev_org。
  8. 要配置 Amazon Web 服务配置文件（若要配置其他配置文件，请跳过此步骤）：
    1. 区域：选择您要在其中部署实例的区域。
    2. 实例类型：Amazon 提供的实例类型。它定义了实例的 RAM 和 CPU 功率等特征。请注意，这可能会对租赁成本产生影响。有关更多信息，请参阅 Amazon EC2 实例页。
    3. 在连接出错时保持实例处于活动状态：如果您希望在应用程序服务器与 Amazon 实例之间的连接断开时，实例依然保持活动状态，请选择真。
  9. 单击测试连接，使用您输入的信息测试与云提供程序的连接。
  10. 单击确定以保存您的设置。
如果所选云提供程序有名为“Micro Focus Silk Central 执行服务器 18.5.0.x”的模板，这些模板将自动导入为虚拟执行服务器。仅有版本与您正在运行的 Silk Central 环境版本（参见帮助 > 关于）完全相同的模板会被导入。
父主题： 云集成
相关任务
配置云托管的执行服务器


编辑云配置文件

编辑云配置文件，以修改访问公共云或私有云服务提供程序的方式。
重要： 如果基于此配置文件的虚拟环境已经部署（请参见网格中的已部署实例列），更改此项设置可能导致 Silk Central 无法再自动删除这些未使用的环境。
  1. 在菜单中，单击管理 > 执行环境。
  2. 单击云提供程序选项卡。
  3. 单击操作列中的 [image] ，同步使用此云提供程序的模板的执行服务器列表。这将删除具有已分配不再存在的模板的此配置文件的所有虚拟执行服务器。应用 Hotfix 以后，还会更新自动创建的虚拟执行服务器的模板。
  4. 在要编辑的配置文件的操作列中，单击 [image] （编辑）。 此时将打开编辑云提供程序配置文件对话框。
  5. 在名称字段中，输入配置文件名称。在创建云托管的执行服务器时，此名称将显示在配置文件列表中。
  6. 在用户名和密码字段中输入有效凭据，以远程访问云系统。对于 Amazon Web 服务，则分别是访问密钥和密钥。
  7. 要配置 VMware vCloud 配置文件（若要配置其他配置文件，请跳过此步骤）：
    1. 输入仅包含主机名的 URL，不要附加通过 Web 浏览器访问系统时使用的 /cloud/org/<组织名称>。示例：https://vdirectorweb。
    2. 可选：版本：如果您使用的是 VMware vCloud Director 5.5（默认），请将此字段留空。如果您使用的是 vCloud Director 5.1，请输入 V5.1。
    3. 组织：请输入要访问的 vCloud 组织的名称，例如 dev_org。
  8. 要配置 Amazon Web 服务配置文件（若要配置其他配置文件，请跳过此步骤）：
    1. 区域：选择您要在其中部署实例的区域。
    2. 实例类型：Amazon 提供的实例类型。它定义了实例的 RAM 和 CPU 功率等特征。请注意，这可能会对租赁成本产生影响。有关更多信息，请参阅 Amazon EC2 实例页。
    3. 在连接出错时保持实例处于活动状态：如果您希望在应用程序服务器与 Amazon 实例之间的连接断开时，实例依然保持活动状态，请选择真。
  9. 单击测试连接，使用您输入的信息测试与云提供程序的连接。
  10. 单击确定以保存您的设置。
父主题： 云集成


删除云配置文件

如果您不再需要访问特定公共云或私有云服务提供程序，可删除云配置文件。
重要： 删除配置文件时，使用此配置文件的所有执行服务器将同时被删除，当前使用这些执行服务器的所有执行都将中止。 如果基于此配置文件的虚拟环境已经部署（请参见网格中的已部署实例列），更改此项设置可能导致 Silk Central 无法再自动删除这些未使用的环境。
  1. 在菜单中，单击管理 > 执行环境。
  2. 单击云提供程序选项卡。
  3. 在要删除的配置文件的操作列中，单击 [image] （删除）。 此时将显示确认对话框。
  4. 单击是以继续删除或单击否以中止删除。
父主题： 云集成


VMware vCloud 集成

映射

vCloud 执行服务器可用的模板对应于 vCloud 本地目录（而非公共目录）中的 vApp 模板。其显示为<目录名称> - <vApp 模板名称>。

为测试运行部署虚拟环境将在 vCloud Director 中创建新的 vApp，其名称基于模板名称，并带有后缀 - for Silk Central <时间戳>。

访客操作系统自定义要求

为使 Silk Central 执行服务器能正确启动，必须在 vCloud Director 的 vApp 模板虚拟机属性中激活并配置访客操作系统自定义，具体如下所述。由于执行服务器在用户会话中启动，Windows 登录只能在访客操作系统自定义初始化 VM 重新启动后进行。
  • 启用允许本地管理员密码和自动作为管理员登录
  • 指定密码，或者让 vCloud 生成一个新密码
  • 禁用管理员必须在初次登录时更改密码
  • 确保在 Windows 中，未激活音频登录，否则会导致重复登录，致使执行服务器因自定义重新启动而启动

限制

  • Silk Central vCloud 集成仅允许使用本地目录（而非公共目录）中的 vApp 模板。公共目录仍然可用于在组织间复制和移动模板，但其中包含的模板在 Silk Central 中不可用。之所以存在这样的限制，原因在于若基于公共目录中最初来自另一个组织的模板创建 vApp，有可能产生问题。这是因为与模板关联的 vDC 和网络在其他组织中无效。
  • 无防护支持。Silk Central 不支持 vApp 内的多个 VM 使用已知 IP 地址相互通信，因为每个已部署 VM 都会动态获得新 IP。
  • 不支持包含 Create Identical Copy 设置的 vApp 模板。创建可在 Silk Central 中使用的 vApp 模板时，请确保 vApp 模板属性中的 Customize VM settings 选项已启用。如果将此选项设置为 Identical Copy，Silk Central 尝试从此模板部署 vApp 时会出错。请注意，只能在创建 vApp 模板时设置这个选项。
  • 对公开 vCloud REST API 的商业服务提供程序的访问未经测试，但可能可以实现。集成使用以私有云形式安装的 VMware vCloud Director 5.5 进行了测试。
  • 要防止 IP 分配冲突，请以为网络适配器配置的 DHCP IP 模式存储 vApp 模板。如果未进行相应配置，部署后首次引导 VM 会造成 vApp 计算机获取存储模板时的旧静态 IP。正确的 IP 在 VMware 进行访客操作系统自定义时得到更新，调整 IP 配置并启动重新启动。Silk Central 始终配置静态 IP 池模式（自定义访客操作系统后应用），不论模板如何配置。
  • 如果在虚拟数据中心 (vDC) 中使用多个网络，请配置要用于存储的 vApp 模板的网络。Silk Central 将在模板 VM 网络适配器中设置的网络名称与 vDC 网络名称匹配，以在部署新 vApp 时选择正确的 vDC 网络。
  • 如果在模板 VM 上安装了早于版本 15.0 的执行服务器，则必须在作为过程模式下运行
父主题： 云集成


云提供程序页面

管理 > 执行环境 > 云提供程序

云提供程序页面列出所有已配置的云提供程序配置文件。使用此页面管理云提供程序配置文件。

您可以在此页面中执行以下操作：

  • 单击新建配置文件以创建新的云提供程序配置文件。
  • 单击操作列中的 [image] （编辑），以编辑设置。
  • 单击 删除 操作列中的（删除），以删除云提供程序配置文件。
  • 单击操作列中的 [image] ，同步使用此云提供程序的模板的执行服务器列表。这将删除具有已分配不再存在的模板的此配置文件的所有虚拟执行服务器。应用 Hotfix 以后，还会更新自动创建的虚拟执行服务器的模板。
父主题： 云集成


管理设备提供程序

设备提供程序是指承载移动仿真器和模拟器的计算机和/或已连接物理移动设备的计算机，可通过访问这些计算机来执行测试。

连接至所谓的设备提供程序或在其上安装的物理移动设备、仿真器和模拟器均可供测试工程师和测试计划使用。而且，可直接在这些移动设备上执行手动测试和自动测试。

时下的软件通常需要在多个平台和各种移动设备上运行，因此这项功能特别适用于跨软件支持的所有平台和设备执行配置测试。

  • 配置设备提供程序
    要在移动设备（物理设备、仿真器和模拟器）上测试您的应用程序，请配置设备提供程序。
  • 在 Mac 上安装 Silk Test 信息服务
    在 Mac 上安装信息服务以测试 Apple Safari 或在安装有 Silk Test 的 iOS 上测试移动应用程序。
  • 删除设备提供程序
    如果所连接的设备不再用于执行测试，删除设备提供程序。
父主题： 执行环境
相关任务
将移动设备分配到配置
为自动测试选择移动设备
为手动测试选择移动设备
相关参考
配置设备提供程序
许可证处理


配置设备提供程序

要在移动设备（物理设备、仿真器和模拟器）上测试您的应用程序，请配置设备提供程序。

在配置特定设备提供程序之前，确保满足安装先决条件：
  • Silk Test 信息服务：设备商首先需要在安插移动设备的电脑上安装 Silk Test 信息服务。
    1. 从 Micro Focus SupportLine 下载安装文件。
    2. 执行 setup 文件，并且遵循安装向导上的提示完成安装。有关在 Mac 上设置设备提供程序的信息，请参阅在 Mac 上安装 Silk Test 信息服务。
  • Mobile Center 和 Sauce Labs：请参阅 Silk Test 文档：
    • 使用 Silk Test Workbench 测试移动应用程序
    • 使用 Silk4J 测试移动应用程序
    • 使用 Silk4NET 测试移动应用程序

要配置设备提供程序：

  1. 在菜单中，单击管理 > 执行环境。
  2. 单击设备提供程序选项卡。
  3. 选择要为其配置设备提供程序的位置。
    • 要创建新的设备提供程序，请单击新设备提供程序。
    • 要编辑现有的设备提供程序，请在操作列中单击相应的编辑按钮。
    注： 可以将相同的设备提供程序添加到多个位置。
  4. 选择设备提供程序类型。
    • Silk Test 信息服务：输入承载移动设备的计算机的 Silk Test信息服务 URL。这可以是 IP 地址、URL 或主机名，例如 http://<计算机名称>:22901。若未指定端口，将附加默认端口 22901。
    • Sauce Labs：输入您的 Sauce Labs 用户名和 Sauce Labs 访问密钥。 要查找访问密钥，请登录 https://saucelabs.com 并选择 My Account。 如果要使用 Sauce Labs 设备进行手动测试，则必须从列表中选择一项 Silk Test 信息服务。如果不选择 Silk Test 信息服务，则 Sauce Labs 设备只能用于自动测试。
    • Mobile Center：输入您的 Mobile CenterURL、用户名和密码。
  5. 在名称字段中，输入设备提供程序的称呼。
  6. 单击测试连接。如果测试连接成功，请单击确定。
父主题： 管理设备提供程序
相关概念
管理设备提供程序
相关任务
将移动设备分配到配置
为自动测试选择移动设备
为手动测试选择移动设备


在 Mac 上安装 Silk Test 信息服务

注： 要在 Mac 上安装信息服务，您需要具备对 Mac 的管理权限。

要在 Mac 上对 Apple Safari 或者在 iOS 或 Android 设备上对移动应用程序创建并执行测试，请在 Mac 上安装 Silk Test 信息服务（简称“信息服务”），然后使用远程位置对话框连接安装有 Silk Test 的 Windows 计算机与 Mac。

要在 Mac 上安装信息服务，请执行以下操作：

  1. 确保 Mac 上已安装 Java JDK。
  2. 如果要在 iOS 设备上对移动应用程序进行测试，请确保 Mac 上已安装 Xcode。
  3. 访问信息服务设置文件 SilkTestInformationService<版本>-<内部版本号>.pkg。
    • 如果您已在安装 Silk Test 的过程中下载了信息服务设置文件，请打开 Silk Test 安装目录（例如 C:\Program Files (x86)\Silk\SilkTest）中的文件夹 macOS。
    • 如果您在安装 Silk Test 的过程中未下载信息服务设置文件，您可从 Micro Focus SupportLine 下载设置文件。
  4. 将文件 SilkTestInformationService<版本>-<内部版本号>.pkg 复制到 Mac。
  5. 执行 SilkTestInformationService<版本>-<内部版本号>.pkg 以安装信息服务。
  6. 请遵循安装向导上的说明。
  7. 当系统询问密码时，提供当前登录的 Mac 用户的密码。
  8. 在 Apple Safari 打开后、消息框询问是否信任 SafariDriver 时，请单击信任。
    注： 若要直接登录 Mac，而不通过远程连接进行连接，则您只能安装 SafariDriver。
为完成安装，安装程序会注销当前 Mac 用户。要验证信息服务安装正确与否，请登录 Mac 并单击屏幕右上角的 Silk Test 图标，查看可用的设备和浏览器。
提示： 如果 Silk Test 图标未显示，请重新启动 Mac。
父主题： 管理设备提供程序


删除设备提供程序

如果所连接的设备不再用于执行测试，删除设备提供程序。
  1. 在菜单中，单击管理 > 执行环境。
  2. 选择一个位置来访问为此位置定义的设备提供程序的列表。
  3. 在要删除的设备提供程序的操作列中，单击 删除 。
父主题： 管理设备提供程序


管理报告模板

Silk Central 提供各种预安装报告，允许您快速轻松地将数据转换为演示质量信息以便进行分析。可使用 Microsoft Excel、Microsoft Word 或 BIRT（它是适用于 Web 应用程序、基于 Eclipse 的开放源码报告工具）自定义默认报告。您还可以使用这些工具创建全新报告。

共享全局报告在所有项目中对所有用户可用，因此能够更新和删除此类报告的用户角色需要具备特殊权限：管理共享全局报告和删除共享全局报告。这些权限同样适用于共享全局报告中使用的报告模板。具备更新和删除报告的标准报告权限的用户角色可以更新和删除非共享全局报告和报告模板。

Silk Central 报告不支持位图 (.bmp) 图像文件格式。要正确显示，图像必须为 JPEG、GIF 或 PNG 格式。

  • 使用 BIRT 管理自定义报告模板
    介绍如何在 Silk Central 中使用 BIRT。
  • 调整现有报告模板
    调整现有 BIRT 报告模板以创建自定义报告。
  • 编辑报告模板属性
    编辑 Silk Central 报告模板的属性，如模板的名称、说明或可使用模板的模块。
  • 下载报告模板
    下载 Silk Central 报告模板以使用 BIRT Report Designer 或 Microsoft Excel 进行编辑。
  • 上载报告模板
    上载自定义 Silk Central 报告模板以便与其他用户共享。
  • 更新报告来源
    通过修改的模板文件更新报告模板，以将自定义报告移到 Silk Central。
  • 删除报告模板
    删除报告模板以将其从可用报告中删除。
  • 报告模板页面
    使用此页面管理报告模板。
父主题： 管理


使用 BIRT 管理自定义报告模板

Silk Central 与商业智能和报告工具 (BIRT) Report Designer 紧密集成，可让您更加轻松地为测试、内部版本、缺陷和需求数据生成报告。

下载 BIRT Report Designer 的副本后，您可以自定核心 Silk Central 报告和添加您自己的报告。有关运行和自定义报告的信息，请参阅应用程序的帮助。

有关 BIRT Report Designer 的附加信息，请参阅 BIRT Report Designer 的联机帮助系统。您可以在 http://www.eclipse.org/birt 上找到有关 BIRT Report Designer 的更多信息、示例和演示。同时提供了活动新闻组 (news.eclipse.org)。

使用 BIRT 自定义报告的软件前提条件包括：

  • BIRT Report Designer
  • 可通过管理员权限访问 Silk Central
注： Silk Central 报告不支持位图 (.bmp) 图像文件格式。要正确显示，图像必须为 JPEG、GIF 或 PNG 格式。
  • 从 Silk Central 中安装 BIRT
    从 Silk Central 中安装 BIRT 以自动为 Silk Central 应用所有必要的配置。
  • 为新报告模板建立数据库访问
    建立从 BIRT Report Designer 到 Silk Central 数据库的数据库访问，以创建新报告模板。
  • BIRT 数据源设置
    介绍您必须配置的设置，以从 BIRT 访问 Silk Central。
父主题： 管理报告模板
相关任务
自定义 BIRT 报告模板


从 Silk Central 中安装 BIRT

此步骤介绍如何从 Silk Central 安装中安装 BIRT Report Designer。通过这种方式安装 BIRT，可自动完成 Silk Central 的所有必要配置。

要从 Silk Central 中安装 BIRT：

  1. 导航至帮助 > 工具。
  2. 单击 BIRT RCP Report Designer 链接。
  3. 将压缩的安装程序包下载到本地系统后，将压缩文件解压到系统目录，例如 C:\BIRT。
    注： 如果在使用 Windows 压缩文件夹功能解压安装程序文件时遇到错误，请改用 WinZip 或 WinRAR 等解压工具解压文件。
  4. 从解压文件的目录中启动 BIRT.exe。
父主题： 使用 BIRT 管理自定义报告模板


为新报告模板建立数据库访问

在使用 BIRT Report Designer 创建新报告模板之前，您需要建立与要查询的 Silk Central 存储库的数据库访问。

要为新报告模板建立数据库访问：

  1. 从 BIRT Report Designer 中，选择菜单文件 > 新建 > 新建报告。
  2. 按照新建报告向导中的步骤执行操作。
  3. 打开资源管理器。
  4. 在资源管理器中，单击共享资源 > conf > birt > library.rptlibrary > 数据源 > 数据源，然后将所需的数据源拖放到报告的数据源目录（位于大纲窗口中）。
  5. 在资源管理器中，单击共享资源 > conf > birt > library.rptlibrary > 报告参数，然后将四个报告参数 sourceUser、sourcePassword、sourceURL 和 sourceDriver 拖放到报告的报告参数目录（位于大纲窗口中）。
  6. 右键单击新导入的数据源以打开编辑数据源对话框。
  7. 键入有效的驱动程序类和数据库 URL。 有关其他信息，请参阅 BIRT 数据源设置主题。
  8. 单击测试连接以测试您的设置。 如果已建立数据库连接，则您可以继续设计新报告模板。
  9. 单击确定。
父主题： 使用 BIRT 管理自定义报告模板


BIRT 数据源设置

使用 BIRT 新建 JDBC 数据源配置文件对话框建立对现有 Silk Central 存储库的数据库访问。要访问新建 JDBC 数据源配置文件对话框，请右键单击大纲窗格中的数据源，单击新建数据源，选择 JDBC 数据源，然后单击下一步 >。

要连接到 MS SQL Server 或 MS SQL Server Express 数据库，请使用以下凭据：

项 | 字符串
驱动程序类 | net.sourceforge.jtds.jdbc.Driver
驱动程序 URL
MS SQL Server
jdbc:jtds:sqlserver://<HOST>:<PORT>/<DATABASE>
MS SQL Server Express
jdbc:jtds:sqlserver://<HOST>:<PORT>/<DATABASE>;instance=<INSTANCENAME>
HOST
托管数据库服务器的计算机的主机名或 IP 地址。
PORT
数据库管理系统的端口号。默认为 1433。
DATABASE
数据库的名称。
INSTANCENAME
仅适用于 MS SQL Server Express。数据库实例的实例名称。默认 MS SQL Server Express 实例为 localhost\SQLExpress。

要连接到 Oracle 数据库，请使用以下凭据：

项 | 字符串
驱动程序类 | oracle.jdbc.OracleDriver
驱动程序 URL jdbc:oracle:thin:@<HOST>:<PORT>:<DATABASE>
HOST
托管数据库服务器的计算机的主机名或 IP 地址。
PORT
数据库管理系统的端口号。默认为 1521。
DATABASE
Oracle SID。
父主题： 使用 BIRT 管理自定义报告模板


调整现有报告模板

SilkCentralBMC TM ART Central 允许您下载和调整包含创建自定义报告模板所需全部信息的 BIRT 报告模板，以用于 Silk Central 模块。

注： Silk Central 报告不支持位图 (.bmp) 图像文件格式。要正确显示，图像必须为 JPEG、GIF 或 PNG 格式。

基于 Silk Central 模板创建报告：

  1. 在菜单中，单击管理 > 报告模板。 此时将显示报告模板页面，它会列出已上载的所有报告模板。
  2. 单击操作列中的 下载报告模板 。
  3. 将模板文件 <文件名>.rptdesign 保存到您的本地系统。
  4. 在 BIRT Report Designer 中打开已下载的模板文件。
  5. 必要时重新设计报告。 有关报告设计的说明，请参阅 BIRT Report Designer 的联机帮助系统。
  6. 要预览报告，请选择从 Run 菜单中选择 View Report > As HTML。 可以如下指定要用来预览报告的浏览器：
    • 单击 Window > Preferences > Web Browser，选择 Use external web browser，然后选择浏览器。
    • 单击 Window > Preferences > Report Design > Preview，然后选中 Always use external browsers 复选框。
  7. 如果首次预览报告，这会打开输入参数对话框，您需要在此对话框中指定有效的会话 ID。要生成会话 ID，请在 Web 浏览器中执行以下 URL。 http://<主机>:<端口>/services/sccsystem?method=logonUser&userName=<用户名>&plainPasswd=<密码>.
    参数
    说明
    HOST
    托管 Silk Central 的计算机的主机名或 IP 地址。
    PORT
    Silk Central 前端服务器的端口号。如果通过独立 Web 服务器访问 SilkCentralBMC TM ART Central，默认为 19120，如果通过 IIS 访问 Silk Central，则为 80。
    USERNAME/PASSWORD
    Silk Central 用户的有效凭据。
    注： 有效凭据 USERNAME 和 PASSWORD 的顺序非常重要。
  8. 如果在某些时候您编辑的报告未返回任何数据，则很可能是会话 ID 已超时（超时为 10 分钟）。关闭浏览器窗口，再次从 Run 菜单中选择 View Report > As HTML。要生成新会话 ID，请重复前面的步骤。
父主题： 管理报告模板


编辑报告模板属性

在您使用 BIRT Report Designer、Word 或 Excel 创建新的自定义报告模板并将其上传到 Silk Central 后，您可以编辑模板属性，如模板的名称、说明或可使用模块的模块。

  1. 在菜单中，单击管理 > 报告模板。 此时将显示报告模板页面，它会列出已上载的所有报告模板。
  2. 单击您要为其编辑或设置权限和关联的报告模板的名称。 此时将显示编辑报告模板对话框。
  3. 使用名称、文件名和说明字段编辑模板属性。
  4. 在模块列表中，您可选择报告模板是否可用于 Issue Manager 和/或 Test Manager 报告。
  5. 完成编辑后，单击确定以保存对报告模板所做的更改。 您所做的编辑立即应用。用户将在下次访问或刷新报告列表时看到更改。
父主题： 管理报告模板


下载报告模板

将下载所选报告的报告模板（包含布局）。将 Silk Central 报告模板下载到本地系统，即可对其进行编辑。在下载和编辑报告后，您可以上载它以使其对其他用户可用。有关更多信息，请参阅上载报告模板。

要下载 Silk Central 报告模板：

  1. 在菜单中，单击管理 > 报告模板。 此时将显示报告模板页面，它会列出已上载的所有报告模板。
  2. 单击要下载的报告的操作列中的 下载报告模板 。 此时将显示文件下载对话框。
  3. 单击保存并将报告文件下载到本地系统，具体取决于您下载的报告类型。
  4. 现在，可根据您的需要使用 BIRT Report Designer（rptdesign 文件）、Word（docx 文件）或 Excel（xls/xlsx 文件）来编辑报告。
父主题： 管理报告模板


上载报告模板

上载 Silk Central 报告模板可使其供其他用户使用。您可能想在使用 BIRT Report Designer、Microsoft Word 或 Microsoft Excel 编辑报告模板后将其上载。您只有在有权访问与报告关联的项目和模板时才可运行报告。

提示： 必须使用其他信息配置模板，以便在模板上载到 Silk Central 后可以识别模版。
注： Silk Central 报告不支持位图 (.bmp) 图像文件格式。要正确显示，图像必须为 JPEG、GIF 或 PNG 格式。

将自定义模板作为新报告上载：

  1. 在菜单中，单击管理 > 报告模板。 此时将显示报告模板页面，它会列出已上载的所有报告模板。
  2. 单击页面底部的上载。 此时将显示上载报告模板对话框。
  3. 键入报告的名称。
  4. 可选：键入报告的说明。
  5. 从模块列表框中，选择与报告关联的模块。 按住 Ctrl 键可选择多个模块。
  6. 单击文件字段旁边的浏览。
  7. 浏览到用作报告模板基础的模板文件并选择。 您所选文件的扩展名必须为 rptdesign、docx、xlsx 或 xls。
  8. 单击确定上载报告模板以便在 Silk Central 中使用。
父主题： 管理报告模板


更新报告来源

更新现有 Silk Central 报告模板可让您将已通过 Silk Central、Microsoft Word 或 Microsoft Excel 自定义的报告移到 BIRT Report Designer，并可供其他用户使用。

警告：
Silk Central 随附的报告模板将在您升级到新版本时自动修补。因此请务必在专用自定义文件夹中保存自定义报告模板，或将自定义报告模板作为新模板上载。有关更多信息，请参阅上载报告模板。

通过修改的模板文件更新报告模板：

  1. 在菜单中，单击管理 > 报告模板。 此时将显示报告模板页面，它会列出已上载的所有报告模板。
  2. 单击您要更新报告的操作列中的 更新 。
  3. 单击更新报告模板对话框中的浏览，以浏览到要覆盖现有模板文件的模板文件并选择。 您所选文件的扩展名必须为 rptdesign、docx、xlsx 或 xls。
  4. 单击确定上载文件，从而覆盖报告模板先前基于的文件。
父主题： 管理报告模板


删除报告模板

您可以从可用报告列表中删除 Silk Central 报告。

要删除 Silk Central 报告：

  1. 在菜单中，单击管理 > 报告模板。 此时将显示报告模板页面，它会列出已上载的所有报告模板。
  2. 单击要删除的报告的操作列中的 删除 。 此时将显示确认对话框。
  3. 单击是以从列表中删除报告。
父主题： 管理报告模板


报告模板页面

管理 > 报告模板

使用报告模板页面管理您希望可供 Silk Central 应用程序用于报告的报告模板。报告模板跨所有项目对所有报告全局可用。

单击上载将新报告模板从硬盘或 UNC 上载到 Silk Central。

对于每个列出的报告，页面显示以下列：

列 | 说明
标题 | 在应用程序 GUI 中显示的报告模板名称。
文件名 | 报告模板的物理文件名。
上载时间 | 报告模板上载到 Silk Central 的日期。
上载者 | 将报告模板上载到 Silk Central 的用户。
模块 | 可能访问报告模板的 Silk Central 应用程序。如果未将模板分配到模块，则任何应用程序都可使用此模板。如果未将模板分配到模块，则任何应用程序都可使用此模板。
操作 此列包含允许用户对报告模板执行以下操作的操作图标：
更新
将当前上载的模板替换为新模板。
下载
将模板下载到本地计算机。
删除
永久删除模板。
父主题： 管理报告模板


审核日志

管理 > 日志文件 > 审核日志

管理员可使用审核日志查看所有已记录的 Silk Central 用户活动。日志文件会存储所有登录和注销信息以及 Silk Central 数据库的所有更改，例如，项目、测试和计划。

您可通过可用功能来管理列出的日志条目，以满足您的信息需求。

按列对数据进行排序

单击列标题可按该列对所有列出的数据进行排序。多次单击同一列标题可在升序和降序之间切换排序次序。

从日历选择范围

单击显示的时间范围以展开日历。您可通过日历的开始和结束行指定要查看数据的时段的开始和结束时间。使用列表框指定开始和结束时间后，单击更新以根据新时间范围更新审核日志。

您可使用天、周、月、季度、[过去 7 天]、[过去 31 天]链接而不使用日历来查看设定时段的信息。

您也可使用向前和向后箭头按以下时间间隔增大和减小所选时间范围：
  • 一天
  • 一周
  • 一个月
  • 一个季度

使用 增加 和 减少 来增加和减少审核日志覆盖的时间范围。单击一次 增加 会将时段增大 50%。单击一次 减少 会将时段减小 50%。

当日历显示自定义时间间隔时（例如，放大或缩小后），您可使用最左边的箭头（更早和更晚）按所选时间间隔的一半时间向前或向后移动所选时段。

提示： 指定新的时段之后，单击更新以更新报告。

筛选数据

您可使用筛选器选项更好地定位您要分析的审核日志信息。

您可按以下方式筛选列出的数据：
登录
显示指定用户登录的操作。
对象
显示对指定数据库项目采取的操作，例如，项目或位置。
操作
显示所选操作，例如，登录、注销、创建或删除。
  • 访问和查看审核日志
    访问和查看审核日志以查看所有已记录的用户活动。
  • 审核日志页面
    使用此页面查看所有已记录的 Silk Central 用户活动。
父主题： 管理


访问和查看审核日志

查看审核日志：

  1. 在菜单中，单击管理 > 日志文件。
  2. 单击审核日志选项卡。
  3. 选择日历范围以限制列出的日志条目。
  4. 使用筛选器选项更好地定位您要分析的审核日志信息。
父主题： 审核日志


审核日志页面

管理 > 日志文件 > 审核日志

使用审核日志页面查看所有已记录的 Silk Central 用户活动。

项目 | 说明
日历区域 | 选择日历范围以限制列出的日志条目。
筛选器区域 | 使用筛选器选项更好地定位您要分析的审核日志信息。 单击更新以根据筛选器设置刷新列表。
结果区域 | 此部分显示已记录的信息。 使用页码在页面之间进行移动。 单击列标题以按定义的列进行排序。

有关日历和筛选选项的详细信息，请参阅审核日志。

父主题： 审核日志


服务器日志文件

前端服务器、应用程序服务器和执行服务器均写入日志文件。 这些文件提供有价值的信息，以便进行错误分析。 Silk Central 可使管理员直接从 Web 界面查看、搜索和下载这些文件。

  • 下载服务器日志文件
    将服务器日志文件下载到您的本地计算机以进一步分析数据，例如在 Microsoft Excel 中分析。
  • 分析服务器日志文件
    分析服务器日志文件，以查看服务器活动是否存在错误。
  • 删除服务器日志文件
    如果不再需要信息，则可删除现有的服务器日志文件。
  • 日志文件管理
    介绍如何自定义写入服务器日志文件的详细信息级别以及。
  • 前端服务器日志页面
    使用此页面来查看 Silk Central 前端服务器服务的日志信息。
  • 应用程序服务器日志页面
    使用此页面以通过 Silk Central 应用程序服务器服务查看日志信息。
  • 执行服务器日志页面
    使用此页面来查看 Silk Central 执行服务器服务的日志信息。
父主题： 管理


下载服务器日志文件

您可用 CSV 格式将服务器日志文件下载您的本地计算机，以便进一步分析数据，例如在 Microsoft Excel 中分析。

要下载服务器日志文件：

  1. 在菜单中，单击管理 > 日志文件。
  2. 单击日志文件所属服务器的选项卡。
    • 前端服务器日志
    • 应用程序服务器日志
    • 执行服务器日志
    将按时间顺序显示日志文件列表。日志文件名由服务器组件名称和带时间戳的后缀组成。当前日志文件名为FrontendServer.log、AppServer.log 和 ExecServer.log。
    注： 要查找执行服务器日志文件，请通过执行服务器位置导航到相应执行服务器。
  3. 在日志文件的操作列中，单击 下载 。 可选：要在下载之前查看日志文件的内容，请单击要下载的日志文件的名称。 将显示选定的日志文件以及按时间顺序存储的日志条目。 单击页面底部的下载为 CSV。
  4. 要在电子数据表程序中查看数据，请在随后出现的对话框上选择打开。 要在硬盘上保存数据，请在随后出现的对话框上选择保存。
父主题： 服务器日志文件


分析服务器日志文件

分析服务器日志文件：

  1. 在菜单中，单击管理 > 日志文件。
  2. 单击日志文件所属服务器的选项卡。
    • 前端服务器日志
    • 应用程序服务器日志
    • 执行服务器日志
    将按时间顺序显示日志文件列表。日志文件名由服务器组件名称和带时间戳的后缀组成。当前日志文件名为FrontendServer.log、AppServer.log 和 ExecServer.log。
    注： 要查找执行服务器日志文件，请通过执行服务器位置导航到相应执行服务器。
  3. 单击要查看的日志文件的名称。 将显示所选日志文件以及按时间顺序排列的日志条目。
  4. 您可通过筛选器选项将记录的日志信息进行分页。
    您可按以下方式筛选列出的数据：
    严重性
    显示具有所选严重性的事件。
    日志级别
    显示与所选日志级别匹配的事件。只有在服务器上设置相应日志级别，才能显示更详细的日志信息。有关配置服务器日志级别的更多信息，请参阅日志级别。
    模块
    显示所选模块的日志信息。只有已安装各自的产品（模块）并连接到正在访问的前端服务器时，才会显示日志条目。
父主题： 服务器日志文件


删除服务器日志文件

警告：
删除日志文件将会永久删除服务器中的文件。 您将不可再从已删除的文件中查看日志数据。

要删除服务器日志文件：

  1. 在菜单中，单击管理 > 日志文件。
  2. 单击日志文件所属服务器的选项卡。
    • 前端服务器日志
    • 应用程序服务器日志
    • 执行服务器日志
    将按时间顺序显示日志文件列表。日志文件名由服务器组件名称和带时间戳的后缀组成。当前日志文件名为FrontendServer.log、AppServer.log 和 ExecServer.log。
    注： 要查找执行服务器日志文件，请通过执行服务器位置导航到相应执行服务器。
  3. 在要删除的日志文件的操作列中，单击 删除 。 此时将显示确认对话框。
  4. 单击否以避免删除日志文件；或单击是以从列表中删除日志文件。 如果您选择是，则会重新显示日志文件的列表，已删除的日志文件将不再列出。
父主题： 服务器日志文件


日志文件管理

各 Silk Central 服务器将其活动写入日志文件。有关 Silk Central 服务器的更多信息，请参阅 Silk Central 体系结构。当应用程序错误或系统故障发生时，这些日志文件可提供有关问题根本原因的重要信息。您可以自定义写入服务器日志文件的详细信息级别和。

Silk Central 服务器日志可通过管理 > 日志文件访问。

  • 更改 Silk Central 服务器的日志级别
    更改 Silk Central 服务器的详细信息级别以在日志文件中包括或排除信息。
父主题： 服务器日志文件
相关参考
Silk Central 体系结构


更改 Silk Central 服务器的日志级别

以下服务器生成日志文件：
  • 前端服务器
  • 应用程序服务器
  • 执行服务器

更改 Silk Central 服务器的日志级别：

  1. 停止要更改日志级别的服务器。
  2. 使用文本编辑器打开相应的文件，具体取决于要更改日志级别的服务器 ：
    前端服务器
    SccFrontendBootConf.xml，位于前端服务器上 Silk Central 目录的 /conf/frontendserver 文件夹中。
    应用程序服务器
    SccAppServerBootConf.xml，位于应用程序服务器上 Silk Central 目录的 /conf/appserver 文件夹中。
    执行服务器
    SccExecServerBootConf.xml，位于执行服务器上 Silk Central 目录的 /conf/execserver 文件夹中。
  3. 在 <Log> 文件的部分找到 <LogLevel> XML 标记。
  4. 将值设置为服务器写入信息的日志级别。 可用日志级别如下：
    值 | 日志级别 | 说明
    0 | 概述 | 服务器只将最重要的信息写入日志文件。 这是默认设置。
    1 详细 服务器将其他信息写入日志文件：
    前端服务器
    连接和事件调度程序信息。
    应用程序服务器
    结果写入程序和结果提取程序活动。
    执行服务器
    交易执行活动。
    2 详细 服务器将其他信息写入日志文件：
    前端服务器
    用户管理信息，例如 cookie 管理。
    应用程序服务器
    详细的结果写入程序和结果提取程序信息。
    执行服务器
    详细的交易执行和带宽信息。
    3 | 调试 | 这是最详细的日志级别，仅可用于调试严重问题。
  5. 保存并关闭该 XML 文件，然后重新启动服务器。
父主题： 日志文件管理


前端服务器日志页面

管理 > 日志文件 > 前端服务器日志

使用此页面来查看 Silk Central 前端服务器服务的日志信息。

对于每个日志文件，此页面将显示以下列：

列 | 说明
操作 | 单击 [image] 和 [image] 按钮以删除或下载日志文件。
名称 | 日志文件的名称。
大小 | 日志文件的物理大小。
日期 | 日志文件最后以物理方式保存的日期。

管理 > 日志文件 > 前端服务器日志 > 前端服务器日志文件名称 。

如果单击日志文件名称，将会显示日志详细信息列表。 此列表包含以下项目：

项 | 说明
筛选区域 | 使用筛选器选项可按照严重性、日志级别和模块筛选日志列表信息。单击更新可根据筛选器设置刷新列表。
表区域 显示以下日志信息：
严重性
事件的严重性：
  • 信息
  • 警告
  • 错误
日志级别
事件的日志级别：
  • OV = 概述
  • DT = 详细
  • VB = 详尽
  • DB = 调试

单击返回可返回至前端服务器日志页面。 单击下载为 CSV 可将日志文件作为 CSV 文件下载至本地计算机。

父主题： 服务器日志文件


应用程序服务器日志页面

管理 > 日志文件 > 应用程序服务器日志

使用此页面以通过 Silk Central 应用程序服务器服务查看日志信息。

对于每个日志文件，此页面将显示以下列：

列 | 说明
操作 | 单击 [image] 和 [image] 按钮以删除或下载日志文件。
名称 | 日志文件的名称。
大小 | 日志文件的物理大小。
日期 | 日志文件最后以物理方式保存的日期。

管理 > 日志文件 > 应用程序服务器日志 > 应用程序服务器日志文件名。

如果单击日志文件名称，将会显示日志详细信息列表。此列表包含以下项目：

项 | 说明
筛选区域 | 使用筛选器选项可按照严重性、日志级别和模块筛选日志列表信息。单击更新可根据筛选器设置刷新列表。
表区域 显示以下日志信息：
严重性
事件的严重性：
  • 信息
  • 警告
  • 错误
日志级别
事件的日志级别：
  • OV = 概述
  • DT = 详细
  • VB = 详尽
  • DB = 调试

单击返回以返回应用程序服务器日志页面。单击下载为 CSV 可将日志文件作为 CSV 文件下载至本地计算机。

父主题： 服务器日志文件


执行服务器日志页面

管理 > 日志文件 > 执行服务器日志

使用此页面来查看 Silk Central 执行服务器服务的日志信息。

对于每个位置，此页面将显示以下列：

列 | 说明
位置 | 显示所有可用位置。
执行服务器 | 显示每个位置的执行服务器数。
状态 | 显示相应位置的执行服务器的摘要状态。

管理 > 日志文件 > 执行服务器日志 > 位置名称

如果单击位置名称，将会显示所选位置中的执行服务器列表。此列表将显示每个执行服务器的以下列：

列 | 说明
执行服务器名称 | 执行服务器的名称。
主机 | 托管执行服务器的计算机名称。
类型 | 为其配置执行服务器的 Silk Central 应用程序。对于 Silk Central，类型始终为 Silk Central。
已分配的任务 | 执行服务器上当前安排的任务数。
状态 | 执行服务器的状态。活动或非活动。

单击返回可返回至位置列表。

管理 > 日志文件 > 执行服务器日志 > 位置名称 > 执行服务器名称

如果单击执行服务器名称，将会显示所选执行服务器的日志文件列表。对于每个日志文件，此页面将显示以下列：
列 | 说明
操作 | 单击 [image] 和 [image] 按钮以删除或下载日志文件。
名称 | 日志文件的名称。
大小 | 日志文件的物理大小。
日期 | 日志文件最后以物理方式保存的日期。

单击返回可返回至执行服务器列表。

管理 > 日志文件 > 执行服务器日志 > 位置名称 > 执行服务器名称 > 执行服务器日志文件名称

如果单击日志文件名称，将会显示日志详细信息列表。此列表包含以下项目：

项 | 说明
筛选区域 | 使用筛选器选项可按照严重性、日志级别和模块筛选日志列表信息。单击更新可根据筛选器设置刷新列表。
表区域 显示以下日志信息：
严重性
事件的严重性：
  • 信息
  • 警告
  • 错误
日志级别
事件的日志级别：
  • OV = 概述
  • DT = 详细
  • VB = 详尽
  • DB = 调试

单击返回可返回至执行服务器日志页面。单击下载为 CSV 可将日志文件作为 CSV 文件下载至本地计算机。

父主题： 服务器日志文件


集成任务管理工具

各种外部任务管理工具可通过 Agile 项目模板将其测试与 Silk Central 集成。

Agile 项目模板是具有预选属性发布和 Sprint 的 Silk Central 项目。 当您创建基于 Agile 项目模板的项目时，将为新项目创建空的子文件夹和测试容器。 然后外部任务管理工具可将测试插入模板中。 有关如何创建基于 Agile 项目模板的项目的信息，请参阅添加项目。

目前受 Silk Central 支持的“自带”任务管理工具包括：

任务管理工具
说明
VersionOne

VersionOne 是专为敏捷软件开发设计的项目计划和管理工具。 它采用敏捷迭代管理实践，例如发布计划、迭代计划和跟踪、用户案例或积压项目管理以及任务管理。

  • 在 Silk Central 中集成 VersionOne
    集成 VersionOne 中的测试以使用 Silk Central 进行管理。
父主题： 管理


在 Silk Central 中集成 VersionOne

要将 VersionOne 中的测试集成到 Silk Central：
  1. 添加新的 Silk Central 项目并将 Agile 项目模板应用到该项目。 有关如何将基于 Agile 模板的项目添加到 Silk Central 的信息，请参阅添加项目。
  2. 打开文件浏览器。
  3. 导航至 VersionOne 配置 XML 文件 VersionOneConfig.xml。 该文件的默认路径为 C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<实例编号>_<实例名称>\wwwrootAS\VersionOneIntegration。
  4. 使用编辑器打开 VersionOne 配置 XML 文件。
  5. 使用相应的设置配置 VersionOne 配置 XML 文件。 有关 VersionOne 配置 XML 文件中的设置的详细信息，请参阅 VersionOneConfig.xml 中的注释。
  6. 保存并关闭配置文件。
    注： 在编辑配置文件后，您无需重新启动应用程序服务器，因为该文件将自动更新。
  7. 在 Silk Central 中，导航至测试区域。 空测试容器将显示为不完整，因为您需要选择产品。
  8. 单击容器，选择属性选项卡，然后单击产品链接以浏览产品。

VersionOne 现在将与 Silk Central 集成。您在 VersionOne 中为相应用户定义的新测试任务将作为手动测试插入已定义 Silk Central 项目的默认集成文件夹中。测试状态现在将在 Silk Central 与 VersionOne 之间交换。

请参阅 C:\ProgramData\SilkCentral\instance_<instance number>_<instance name>\log\ 日志文件了解有关 VersionOne 集成变化的信息。日志文件的默认路径是 C:\ProgramData\SilkCentral\instance_<实例编号>_<实例名称>\log\。

注： 要将 VersionOne 与日语 Silk Central 集成，请将注册表中的应用程序服务器服务的启动选项更改为 -Dfile.encoding=utf-8。
父主题： 集成任务管理工具


维护值列表

值列表用于填充在问题 > 配置内可为 Issue Manager 配置的自定义问题选项卡中的自定义属性。有关自定义问题属性和选项卡的详细信息，请参阅本帮助文档中的 Issue Manager 主题。

  • 添加值列表
    添加新值列表以在自定义问题选项卡中插入自定义属性。
  • 编辑值列表
    编辑现有值列表。
  • 编辑单个值
    编辑值列表中的单个值。
  • 激活和停用值列表
    激活或停用 Silk Central 中的现有值列表。
  • 激活和停用个别值
    激活或停用值列表中的个别值
  • 对值列表中的值排序
    在列表中将值上移或下移，并按字母顺序对值列表排序。
  • 删除值列表
    删除现有值列表。
  • 删除单个值
    删除值列表中的单个值。
  • 值列表配置页面
    使用此页面配置值列表。
父主题： 管理


添加值列表

添加新值列表：

  1. 在菜单中，单击管理 > 值列表。
  2. 单击新建列表。 将显示新建值列表对话框。
  3. 在名称文本框中键入新值列表的名称，并在说明文本框中键入值列表的说明。
  4. 从分组方式列表框中，选择对此列表进行分组所用的参数。

    此选择是确定的，不能在保存新列表之后进行编辑。分组值意味着列表中每个值都必须分配为分组方式列表框中所选列表的值。不分组值意味着您可手动定义自定义值。

  5. 单击新建值以将值添加到列表。 将显示新建值对话框。
  6. 键入新值的名称和说明。
  7. 如果适用，请从分组方式列表框中选择值。
  8. 从在其后插入列表框中选择新值在现有值列表中所处的位置，或选择 <最后一个条目> 以将新值添加到列表末尾。
  9. 单击确定以保存值。 新建值列表对话框会显示新添加的值。
  10. 根据需要添加尽可能多的值，以完成值列表。
  11. 单击确定以保存值列表。
父主题： 维护值列表


编辑值列表

要编辑现有值列表：

  1. 在菜单中，单击管理 > 值列表。
  2. 单击要编辑的值列表的名称。 此时将显示编辑值列表对话框。
  3. 更改所选值列表的名称、说明和分组方式设置，然后单击确定。
    注： 也可以编辑为列表配置的各个值。 有关编辑单个值的详细信息，请参阅编辑单个值。
父主题： 维护值列表


编辑单个值

要编辑值列表中的单个值：

  1. 在菜单中，单击管理 > 值列表。
  2. 单击要编辑的值列表的名称。 此时将显示编辑值列表对话框。
  3. 单击要编辑的值的名称。 此时将显示编辑值对话框。
  4. 根据需要编辑值的名称和说明。
  5. 单击确定以保存您所做的更改。
父主题： 维护值列表


激活和停用值列表

注： 您无法停用问题类型值列表，因为此列表是 Issue Manager 所要求的。

激活或停用现有值列表：

  1. 在菜单中，单击管理 > 值列表。
  2. 单击与要激活或停用的值列表关联的状态图标。 将显示确认对话框，询问您是否确实要激活或停用。
  3. 确认消息以将值列表状态切换为活动或非活动。
    注： 也可激活或停用为列表配置的个别值。 有关激活或停用个别值的详细信息，请参阅激活和停用个别值。
父主题： 维护值列表


激活和停用个别值

激活或停用值列表中的个别值：

  1. 在菜单中，单击管理 > 值列表。
  2. 单击包括要激活或停用的值的值列表名称。 将显示编辑值列表对话框。
  3. 单击与要激活或停用的值关联的状态图标。 将显示确认对话框。
  4. 单击确定以保存更新的值列表。
父主题： 维护值列表


对值列表中的值排序

在值列表中将值上移或下移，或按值名称的字母顺序对值列表排序：

  1. 在菜单中，单击管理 > 值列表。
  2. 单击包括您要排序的值的值列表名称。 此时将显示编辑值列表对话框。
  3. 在要移动项目的操作列中，单击 上移 或 下移 。
  4. 要按值名称的字母顺序对值列表排序，请单击按值排序。 此时将显示按值排序对话框。
  5. 选择排序次序，升序或降序，然后单击确定。
  6. 单击编辑值列表对话框中的确定以保存更新的值列表。
父主题： 维护值列表


删除值列表

要删除现有值列表：

  1. 在菜单中，单击管理 > 值列表。
  2. 停用要删除的值列表。 有关其他信息，请参阅激活和停用值列表。
  3. 在要删除的值列表的“操作”列中，单击 删除 。 此时将显示确认对话框。
  4. 单击是以继续删除或单击否以中止删除。
    注： 也可以删除为列表配置的各个值。有关删除单个值的详细信息，请参阅删除单个值。
父主题： 维护值列表


删除单个值

要删除值列表中的单个值：

  1. 在菜单中，单击管理 > 值列表。
  2. 单击包含要删除的值的值列表名称。 此时将显示编辑值列表对话框。
  3. 停用要删除的值。 有关其他信息，请参阅激活和停用单个值。
  4. 在要删除的值的操作列中，单击 删除 。
  5. 单击编辑值列表对话框中的确定以保存更新的值列表。
父主题： 维护值列表


值列表配置页面

管理 > 值列表

使用此页面配置值列表。对于所列的每个值列表，该页面显示以下列：

列 | 说明
名称 | 在 GUI 和报告中显示的值列表名称。单击值列表名称以显示值列表的名称、说明和值。
分组方式 | 显示值列表按产品还是按问题类型分组，或者是否未分组。
状态 | 值列表的状态，即活动或非活动。单击状态可在活动和非活动之间切换。不能停用默认值列表问题类型，因为它是 Issue Manager 中使用的重要组件。
创建于 | 创建值列表的日期。
创建者 | 创建值列表的用户。
更改时间 | 上次修改值列表的日期。
更改者 | 上次修改值列表的用户。
操作
您可以对值列表执行以下操作：
永久删除值列表。在删除之前，值列表必须处于非活动状态。如果值列表已与问题关联，则不允许删除它。

单击新建列表可创建新的值列表。

父主题： 维护值列表


配置全局计划

您可定义可在 Silk Central 中重复用于执行计划安排的全局计划。由于全局计划将定义个别计划的需要减少为只需定义需要特殊安排的执行计划，因此可加快执行计划的安排进程。有关如何应用计划的详细信息，请参阅计划。

排除

您可定义在其间不执行测试的工作日和当日时间间隔。例如，您可能想要测试发生在周末。

确定运行

不管配置的计划如何，您都可定义必须执行测试的时间点。

  • 添加全局计划
    添加新全局计划，以计划 Silk Central 中的执行计划。
  • 编辑全局计划
    编辑现有的全局计划。
  • 激活和停用全局计划
    激活或停用 Silk Central 中的现有全局计划。
  • 删除全局计划
    删除现有的全局计划。
  • 计划排除
    计划排除以定义不执行计划测试的时间。
  • 计划确定运行
    计划确定运行以定义测试必须执行的时间点。
  • 计划配置页面
    使用此页面为 Silk Central 配置全局计划。
父主题： 管理
相关概念
计划


添加全局计划

添加新全局计划：

  1. 在菜单中，单击管理 > 计划。 将显示计划页面，列出所有现有全局计划。
  2. 单击新建计划。 此时将显示配置计划页面。
  3. 在名称文本框中键入新计划的名称。好的做法是，将时区包含在名称中，例如“东部标准时间每天下午 6 点”，这样用户就能知道该计划的实际运行时间。
  4. 在说明文本框中键入计划的说明。
  5. 单击从旁边的 编辑 ，以定义计划的开始日期和时间。所有日期和时间值均以 GMT 格式保存到数据库。根据用户设置中指定的时区设置来设置值表示。 例如，如果位于纽约的管理员创建了一个每天下午 6 点运行的全球计划，那么对位于巴黎的用户来说，如果他将此计划应用到自己的执行计划，那么该计划将在午夜运行。
  6. 定义重复执行的间隔。 可用时间范围为 1 分钟至 36 天。
  7. 选中将计划调整到夏令时复选框，以根据夏令时变化自动调整计划的执行。
  8. 单击运行旁边的 编辑 ，以定义执行的结束日期和时间。单击始终以在未定义期限内执行，或单击直到以在定义期限内执行。
  9. 要定义不执行 测试 的工作日和当日时间间隔，请单击添加排除。 有关更多信息，请参阅计划排除。
  10. 要定义必须执行 测试 的时间点，请单击添加确定运行。 有关更多信息，请参阅计划确定运行。
  11. 完成计划定义后，单击保存。
父主题： 配置全局计划
相关任务
计划确定运行
计划排除
指定全局计划


编辑全局计划

要修改全局计划：

  1. 在菜单中，单击管理 > 计划。 将显示计划页面，列出所有现有全局计划。
  2. 单击您要编辑的计划名称。 此时将显示配置计划页面。
  3. 在名称文本框中更改计划的名称。好的做法是，将时区包含在名称中，例如“东部标准时间每天下午 6 点”，这样用户就能知道该计划的实际运行时间。
  4. 在说明文本框中更改计划的说明。
  5. 单击从旁边的 编辑 ，为计划定义新的开始日期和时间。所有日期和时间值均以 GMT 格式保存到数据库。根据用户设置中指定的时区设置来设置值表示。 例如，如果位于纽约的管理员创建了一个每天下午 6 点运行的全球计划，那么对位于巴黎的用户来说，如果他将此计划应用到自己的执行计划，那么该计划将在午夜运行。
  6. 更改应重复执行的间隔。 可用时间范围为 1 分钟至 36 天。
  7. 选中将计划调整到夏令时复选框，以根据夏令时变化自动调整计划的执行。
  8. 单击运行旁边的 编辑 ，以定义执行的结束日期和时间。单击始终以在未定义期限内执行，或单击直到以在定义期限内执行。
  9. 要定义不执行 测试 的工作日和当日时间间隔，请单击添加排除。 有关更多信息，请参阅计划排除。
  10. 要定义必须执行 测试 的时间点，请单击添加确定运行。 有关更多信息，请参阅计划确定运行。
  11. 在完成修改计划后，单击保存。
父主题： 配置全局计划
相关任务
计划确定运行
计划排除
指定全局计划


激活和停用全局计划

激活或停用现有产品：

  1. 在菜单中，单击管理 > 计划。 将显示计划页面，列出所有现有全局计划。
  2. 单击与要激活或停用的计划关联的状态图标。 将显示确认对话框，询问您是否确实要激活或停用。
  3. 确认消息以将计划状态切换为活动或非活动。
父主题： 配置全局计划


删除全局计划

要删除现有的全局计划：

  1. 在菜单中，单击管理 > 计划。 将显示计划页面，列出所有现有全局计划。
  2. 在要删除的计划的操作列中，单击 删除 。 此时将显示确认对话框。
  3. 单击是以删除当前计划（包括所有排除和确定运行），或单击否以中止操作。
    注： 当全局计划正被 测试 使用时，您不能删除它。 您必须先将所有 测试 重新安排到其他计划。
父主题： 配置全局计划


计划排除

计划排除：

  1. 在菜单中，单击管理 > 计划。 将显示计划页面，列出所有现有全局计划。
  2. 单击您要编辑的计划名称。
  3. 在配置计划页面上，单击添加排除。
  4. 在配置计划排除页面上，选择应抑制测试的工作日。
  5. 定义应在这些天抑制执行的特定时间间隔。
  6. 排除设置定义完成后单击确定，或单击取消中止。 排除设置现已列在配置计划页面上。
  7. 单击保存将排除添加到当前计划，或继续添加其他排除。
    提示： 您可以单击要修改的排除的操作列中的 编辑 或 删除 来编辑和删除排除。
父主题： 配置全局计划


计划确定运行

计划确定运行：

  1. 在菜单中，单击管理 > 计划。 将显示计划页面，列出所有现有全局计划。
  2. 单击您要编辑的计划名称。
  3. 在配置计划页面上，单击添加确定运行。
  4. 在配置确定运行页面上，单击 编辑 以定义确定运行的时间点。
  5. 确定运行定义完成后单击确定，或单击取消中止。 确定运行设置现已列在配置计划页面上。
  6. 单击保存将确定运行添加到当前计划，或继续添加其他确定运行。
    提示： 您可以单击要修改的确定运行的操作列中的 编辑 或 删除 来编辑和删除确定运行。
父主题： 配置全局计划


计划配置页面

管理 > 计划

使用此页面为 Silk Central 配置全局计划。对于每个计划，页面显示以下列：

列 | 说明
操作 此列包含允许用户对计划执行以下操作的操作图标：
永久删除计划。如果计划已与执行计划关联，则不允许删除。
名称 | 在 GUI 和报告中显示的计划名称。单击计划名称可修改计划的名称、说明和状态。
说明 | 计划的文字介绍。
状态 | 计划的状态，活动或非活动。单击状态可在活动和非活动之间切换。
创建于 | 创建计划的日期。
创建者 | 创建计划的用户。

单击新建计划可创建新计划。

父主题： 配置全局计划


时区

Silk Central 专用于在执行服务器的网络中执行 测试。由于 Internet 使此类网络可在全球范围内跨多个时区延伸，因此一定要了解 Silk Central 中的时区处理。

所有日期和时间值均以 GMT 格式保存到数据库。根据用户设置中指定的时区设置来设置值表示。在创建全球可用的计划时，尤其需要考虑这一点。例如，如果位于纽约的管理员创建了一个每天下午 6 点运行的全球计划，那么对位于巴黎的用户来说，如果他将此计划应用到自己的执行计划，那么该计划将在午夜运行。好的做法是，将时区包含在名称中，例如“东部标准时间每天下午 6 点”，这样用户就能知道该计划的实际运行时间。

有关时区设置的详细信息，请参阅添加用户帐户。

以下需求适用：

  • 应用程序服务器和前端服务器应位于同一时区。在 WAN 中将这些服务器从本地分开毫无意义，因为应用程序服务器与一个或几个前端服务器密切通信。另外，前端服务器和应用程序服务器还可直接访问数据库。
  • 执行服务器可能位于不同时区，与应用程序服务器和其他执行服务器分开。
父主题： 管理
相关任务
添加用户帐户


管理项目

Silk Central 中的项目通常会反映出贵公司中的软件项目，分别是开发团队的工作，有通用的发行日期、通用的源代码管理系统、通用需求等。

项目区域提供了 Silk Central 安装中所有项目的高级测试经理视图，包括已设置为活动的最新项目的列表，并使您能在项目之间移动。如果您具有超级用户、管理员或项目经理权限，则可以为 Silk Central 项目指定项目范围内的设置。定义全局项目设置后，设置对有权访问项目的所有用户均可用。

  • 使用项目
    介绍 Silk Central 中项目的概念背景。
  • 内部版本信息
    本节介绍如何使用内部版本信息文件。
  • 比较项目与基线
    使用上下文相关报告比较项目与项目的基线。
  • 选择项目
    在项目单元中选择项目以将其激活。
  • 项目列表
    列出了与 Silk Central 安装关联的所有项目和项目基线。
  • 切换到最近访问的项目
    介绍如何快速切换到五个最近访问的项目之一。
  • 项目设置
    本部分介绍如何配置项目设置。
  • 项目模板
    介绍 Silk Central 中项目模板的概念背景。
父主题： 管理
相关概念
Silk Central 体系结构


使用项目

此主题介绍 Silk Central 中项目的概念背景。

Silk Central 在项目上下文中管理需求、测试及其执行和结果。 因此，您首先要创建一个项目。项目可用作相关任务和结果集的容器。通过将项目经理和分析人员等资源分配给具有特定项目访问权限的用户组，可以将他们分配给项目。

  • 添加项目
    创建项目以开始使用 Silk Central。
  • 项目基线
    介绍 Silk Central 中项目基线的概念背景。
  • 编辑项目和项目基线
    编辑现有的项目或项目基线。
  • 激活或停用项目和项目基线
    激活或停用现有项目或项目基线。
  • 复制项目或项目基线
    将现有项目或项目基线复制到新项目。
  • 删除项目和项目基线
    删除现有的项目或项目基线。
  • 导出项目
    介绍如何导出项目以将项目数据在 Silk Central 外存档。
  • 导入项目
    介绍如何重新导入事先从 Silk Central 中导出的项目。
  • 复制项目对话框
    使用此对话框将现有项目复制到新项目。
  • 项目设置页面
    使用此页面配置项目设置。
  • 将项目初始化为 Issue Manager 项目
    介绍如何将项目初始化为 Issue Manager 项目。
父主题： 管理项目


添加项目

创建项目：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 单击新建项目。 将显示项目设置页面。
  3. 键入项目名称和说明。
  4. 选择项目负责人。
  5. 可选：输入您项目的标记。如果您有许多项目，请使用项目列表页面上的标记列，项目标记可帮助您筛选项目。
  6. 可选：要基于 Agile 项目模板创建项目，请从项目模板列表框中选择 Agile 项目模板。
  7. 要将项目初始化为 Issue Manager 项目，请单击初始化新项目或重用现有项目。有关更多信息，请参阅将项目初始化为 Issue Manager 项目。
  8. 在共享测试部分，定义项目是否是存储库项目。选择以下选项之一：
    • 不共享测试：此项目不使用其他项目的测试，且其测试也不可由其他项目使用。
    • 共享测试：此项目配置为存储库项目，以使其他项目可以使用此项目的测试。
    • 使用以下项目中的共享测试：选中此项目使用的共享测试来自的存储库项目。
  9. 组部分包含可用组和已分配组的列表。根据需要分配组。使用 Ctrl+单击或 Shift+单击选择多个组。您还可单击导入 LDAP 组，以从 LDAP 服务器导入组。有关详细信息，请参阅从 LDAP 服务器导入组。如果用户组不存在，您可能要在创建用户组后再对其分配。您也可以在组设置页面配置组/项目分配。权限因用户角色而异。有关用户权限的信息，请参阅用户角色和权限。
  10. 位置部分包含可用位置和已分配位置的列表。根据需要分配位置。使用 Ctrl+单击或 Shift+单击选择多个位置。如果位置不存在，您可能要在创建位置后再对其分配。您也可以在位置设置页面配置位置/项目分配。有关详细信息，请参阅管理位置。
  11. 单击保存以保存您的设置。 您将返回到其中列出新项目的项目列表页面。
父主题： 使用项目
相关概念
管理组
管理位置
用户角色和权限
相关任务
将项目初始化为 Issue Manager 项目
编辑项目和项目基线
从 LDAP 服务器导入组
添加 LDAP 服务器
重复使用存储库项目的测试资产


项目基线

本主题介绍 Silk Central 中项目基线的概念背景。

项目基线是给定时间的项目快照，可为任何项目创建项目基线，甚至创建其他项目基线。项目中每个执行计划的上次运行也包括在项目基线中。项目基线中包含的计划选项最初设置为无，以防止丢失上次运行的执行状态。例如，项目基线可用于在发布后立即保存项目快照。中的基线比较报告显示了目前项目中相较于项目基线而不同的 Silk Central 数。有关报告的更多信息，请参阅 Silk Central 帮助。

对于包括测试区域的元素的每个新项目基线，该元素的历史记录页面包括链接到项目基线及其相应元素的条目。如果元素本身作为项目基线的一部分创建，则历史记录页面中的第一个条目包括与原始项目及其相应元素的链接。

当原始项目中的测试包括库中的调用共享步骤对象或关键字时，您可以在创建项目基线期间定义是否解决或保留所有调用。项目基线和原始项目对库具有相同的可见性。有关共享步骤对象和关键字的更多信息，请参阅 Silk Central 帮助中的库。

注： 项目基线可由管理员、项目经理和超级用户角色创建。
  • 创建项目基线
    为现有项目创建基线，以获得给定时间的项目快照。
父主题： 使用项目
相关概念
库


创建项目基线

警告：
创建项目基线可将数据库锁定几分钟，具体取决于要为其创建项目基线的项目的大小。我们建议在非工作时间（Silk Central 上的用户活动最少时）创建项目基线。
注： 如果原始项目包括计划，则新基线中的计划选项将设置为无，以防止丢失上次执行状态。创建基线时，基线中所包括的每个测试项目的历史记录页面将使用基线条目进行更新。

创建项目基线：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 在要为其创建基线的项目的操作列中，单击 基线项目 。 此时将显示基线项目对话框。
  3. 键入新基线的名称和说明。
  4. 可选：如果项目包含使用库中共享步骤或关键字的测试，请在库资产处理部分中定义共享步骤的处理方式：
    • 单击复制库资产分离原始库中所有对共享步骤和关键字的引用，转为引用这些库在基线中新建副本中的资产。选择此选项，以出于历史或审计目的创建项目基线。
    • 单击保留库资产引用保留原始库中对共享步骤和关键字的所有引用。选择此选项，以出于正在进行的测试目的（例如项目的新版本）创建工作副本。
  5. 可选：如果项目包含手动测试或关键字驱动的测试，请在测试资产版本控制部分中定义是否应在原始项目和/或基线中为测试创建新版本。
    • 选中在原始项目中创建手动资产和关键字驱动资产的新版本复选框，以在原始项目中使用共享对象为所有手动测试和关键字驱动的测试创建新版本。
    • 选中在新基线中创建手动资产和关键字驱动资产的新版本复选框，以在基线中使用共享对象为所有手动测试和关键字驱动的测试创建新版本。如果选择了复制库资产，还会在复制的库中为所有资产创建新版本。
    注： 不会为数据驱动实例创建版本。
  6. 单击确定。 将显示基线项目对话框，并通知您该操作可能需要几分钟才能完成。
  7. 单击是以继续。 将打开基线项目 - 调整项目设置对话框。该对话框将显示需求集成设置以及为原始项目配置的所有源代码管理配置文件。
  8. 单击相应的编辑按钮，以将项目基线链接到源代码管理配置文件中相应的基线、分支、标签或其他引用点，或更改需求集成设置。
    注： 有关编辑源代码管理配置文件的更多信息，请参阅 Silk Central 帮助。
  9. 单击完成以完成基线的创建。
  10. 在基线项目对话框中，单击是以激活新基线。
父主题： 项目基线


编辑项目和项目基线

要编辑现有的项目或项目基线：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 在要编辑的项目或项目基线的项目名称的“操作”列中单击 编辑 。
    注： 项目或项目基线必须处于非活动状态。
  3. 根据需要编辑项目名称和说明。
  4. 根据需要更改项目负责人。
  5. 选中活动复选框以激活项目或项目基线。
  6. 可选：输入您项目的标记。如果您有许多项目，请使用项目列表页面上的标记列，项目标记可帮助您筛选项目。
  7. 在共享测试部分，定义项目是否是存储库项目。选择以下选项之一：
    • 不共享测试：此项目不使用其他项目的测试，且其测试也不可由其他项目使用。
    • 共享测试：此项目配置为存储库项目，以使其他项目可以使用此项目的测试。
    • 使用以下项目中的共享测试：选中此项目使用的共享测试来自的存储库项目。
  8. 组部分包含可用组和已分配组的列表。根据需要分配组。使用 Ctrl+单击或 Shift+单击选择多个组。您还可单击导入 LDAP 组，以从 LDAP 服务器导入组。有关详细信息，请参阅从 LDAP 服务器导入组。如果用户组不存在，您可能要在创建用户组后再对其分配。您也可以在组设置页面配置组/项目分配。权限因用户角色而异。有关用户权限的信息，请参阅用户角色和权限。
  9. 位置部分包含可用位置和已分配位置的列表。根据需要分配位置。使用 Ctrl+单击或 Shift+单击选择多个位置。如果位置不存在，您可能要在创建位置后再对其分配。您也可以在位置设置页面配置位置/项目分配。有关详细信息，请参阅管理位置。
  10. 单击保存以保存您的设置。 您将返回项目列表页面。
父主题： 使用项目
相关概念
管理组
管理位置
用户角色和权限
相关任务
添加项目
将项目初始化为 Issue Manager 项目
从 LDAP 服务器导入组
添加 LDAP 服务器
重复使用存储库项目的测试资产
激活或停用项目和项目基线


激活或停用项目和项目基线

注： 您也可从项目列表页面激活或停用现有项目或项目基线。 有关更多信息，请参阅编辑项目。

激活或停用现有项目或项目基线：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 单击要激活或停用的项目或项目基线的状态列中的活动/非活动。 将显示确认对话框，询问您是否确实要激活或停用。
  3. 确认以将项目状态切换为活动或非活动。
父主题： 使用项目
相关任务
编辑项目和项目基线


复制项目或项目基线

将现有项目或项目基线复制到新项目。

如果原始项目或基线包括计划，则在复制过程中计划选项会设置为无。

警告：
复制项目或项目基线会将数据库锁定几分钟，具体取决于正在复制的项目或项目基线的大小。建议在非工作时间（Silk Central 上的用户活动最少时）复制项目或项目基线。
提示： 特别是在将大项目写入数据库时，可能会显著降低数据库的性能。我们强烈建议您在下一个维护窗口中为 Silk Central 数据库架构执行完整索引重建。

复制项目或项目基线：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 单击要复制的项目或项目基线的操作列中的 复制项目 。 将显示复制项目对话框。
  3. 在新建项目名称文本框中，键入新项目的名称。
  4. 选中要随新项目一起复制的任何其他信息类型的复选框。选中测试历史记录复选框时，还会复制版本。 有关这些复选框的详细信息，请参阅复制项目对话框。
  5. 单击确定。
  6. 如果未针对要复制的项目初始化任何 Issue Manager 项目，请继续执行步骤 10。如果已初始化 Issue Manager 项目，将显示对话框：
    • 如果要重复使用现有 Issue Manager 项目，请单击是并继续执行步骤 10。
    • 如果不想重复使用但想复制现有 Issue Manager 项目，请单击否并继续执行步骤 7。
  7. 选中复制问题复选框，以将源项目的所有现有问题复制到新项目。
  8. 选中复制存档问题复选框，以将源项目的所有存档问题复制到新项目。
  9. 单击确定。
  10. 在复制项目对话框上单击是，以确认要开始复制过程并且知道该过程可能需要几分钟。 复制过程完成时，将显示对话框通知您已复制的内容并且询问您是否要激活该项目，从而让该项目在 Silk Central 的项目视图中处于可用状态。
父主题： 使用项目


删除项目和项目基线

警告：
当您删除项目或项目基线时，您将从存储库中永久删除所有相关的结果。您还可以销毁与项目或项目基线相关的所有内容。如果您想要保留结果，我们建议您将项目或项目基线设置为非活动，而不是删除它。有关停用项目和项目基线的信息，请参阅激活或停用项目或项目基线。

要删除项目或项目基线：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 单击要删除的项目或项目基线的操作列中的 删除 。
    注： 项目或项目基线必须处于非活动状态。
    此时将显示确认对话框，要求您确认删除。
  3. 单击是以删除项目或项目基线；或单击否以中止操作。 如果您选择是，您将返回项目列表，已删除的项目或项目基线将不再列出。
父主题： 使用项目


导出项目

您可将项目（包括将所有项目数据）作为 .zip 文件导出到本地计算机。这在您要将数据在 Silk Central 外存档时非常有用。

要导出项目：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 单击操作列中的 [image] （导出项目）。
  3. 单击确认对话框上的确定。
  4. 在计算机中指定保存项目数据的位置。 Silk Central 将项目数据保存为 .zip 文件。
注意： 开始导出或导入项目之前，请仔细阅读以下建议。
  • 导出/导入具有大量项目数据的大项目时，导出/导入过程可能需要很长时间（长达几个小时）。
  • 各项目间的文件大小差异巨大，取决于很多因素，例如：资产数量、运行数量、附件、代码覆盖率统计以及最重要的结果文件。
  • 我们建议在导出项目之前尽量减小项目的大小。因此，您应删除不需要的数据，尤其是未使用的结果文件。如果您的项目大小超过 1.2 GB，您在尝试导入该项目时会收到Request entity is too large错误。如果无法再减少项目的大小，您可修改 client_max_body_size 属性的值，以增加文件 nginx.conf.template（位于 C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf）中的上传限制。
  • 特别是在将大项目写入数据库时，可能会显著降低数据库的性能。我们强烈建议您在下一个维护窗口中为 Silk Central 数据库架构执行完整索引重建。
  • 某些浏览器有文件上载限制，例如 Internet Explorer。如果要导入的项目超过该大小，导入就会失败。请使用其他浏览器避免此类问题发生。
  • 请注意，导出/导入过程会在 Silk Central 和数据库服务器上添加相当大的负载。导出/导入操作应在非工作时间（例如，夜间或周末）执行，或至少在 Silk Central 使用率低且没有用户登录时执行。
  • 导出和导入数据取决于数据库及其内容并与其紧密相关。如果数据库已包含任何数据不一致情况，则导入项目可能失败。因此，我们强烈建议在导出后立即重新导入以确保有效性、数据一致性和可恢复性，这是每个备份过程的良好做法。
  • 如果您要重新导入项目数据，请使用已导出的同一个 .zip 文件。其他文件格式将不会被接受。您可将数据仅导入到与用于导出数据的相同 Silk Central 和数据库版本。
  • 如果您有任何关于导出/导入过程的问题，请随时联系客户支持。
父主题： 使用项目


导入项目

Silk Central 项目可被导出以将项目数据在 Silk Central 外存档。要查看数据、所有结果、报告等，必须重新导入项目。

导入项目数据时，您必须使用用于导出数据的相同 Silk Central 版本和数据库版版本。但是，您可使用用于导出数据的相同版本将项目数据导入相同或不同数据库服务器。

要导入项目：

  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 单击顶部的导入项目。 此时将显示导入项目对话框。
  3. 浏览到计算机上的相应 .zip 文件，然后单击确定。 Silk Central 将上载数据。
    注： .zip 文件必须为事先从 Silk Central 中导出的文件。
    注： .zip 文件将在导入到数据库之前上载至前端服务器。因此，前端服务器需要提供适当的可用磁盘空间来存储 .zip 文件。
  4. 单击是开始导入。 请注意以下事项：
    • Silk Central 一次只处理一个导入。
    • Silk Central 会在导入开始、结束或失败时写入审核日志。
    • 导入在后台进行处理。导入完成时，您将收到电子邮件通知。请确保您在开始导入之前已配置电子邮件地址和电子邮件服务器。否则，您将不会收到通知。有关更多信息，请参阅配置电子邮件服务器和用户设置页面。
    • 导入完成时，项目将显示在项目列表中。
注意： 开始导出或导入项目之前，请仔细阅读以下建议。
  • 导出/导入具有大量项目数据的大项目时，导出/导入过程可能需要很长时间（长达几个小时）。
  • 各项目间的文件大小差异巨大，取决于很多因素，例如：资产数量、运行数量、附件、代码覆盖率统计以及最重要的结果文件。
  • 我们建议在导出项目之前尽量减小项目的大小。因此，您应删除不需要的数据，尤其是未使用的结果文件。如果您的项目大小超过 1.2 GB，您在尝试导入该项目时会收到Request entity is too large错误。如果无法再减少项目的大小，您可修改 client_max_body_size 属性的值，以增加文件 nginx.conf.template（位于 C:\ProgramData\SilkCentral\InstanceAdministration\nginx\conf）中的上传限制。
  • 特别是在将大项目写入数据库时，可能会显著降低数据库的性能。我们强烈建议您在下一个维护窗口中为 Silk Central 数据库架构执行完整索引重建。
  • 某些浏览器有文件上载限制，例如 Internet Explorer。如果要导入的项目超过该大小，导入就会失败。请使用其他浏览器避免此类问题发生。
  • 请注意，导出/导入过程会在 Silk Central 和数据库服务器上添加相当大的负载。导出/导入操作应在非工作时间（例如，夜间或周末）执行，或至少在 Silk Central 使用率低且没有用户登录时执行。
  • 导出和导入数据取决于数据库及其内容并与其紧密相关。如果数据库已包含任何数据不一致情况，则导入项目可能失败。因此，我们强烈建议在导出后立即重新导入以确保有效性、数据一致性和可恢复性，这是每个备份过程的良好做法。
  • 如果您要重新导入项目数据，请使用已导出的同一个 .zip 文件。其他文件格式将不会被接受。您可将数据仅导入到与用于导出数据的相同 Silk Central 和数据库版本。
  • 如果您有任何关于导出/导入过程的问题，请随时联系客户支持。
父主题： 使用项目
相关任务
配置电子邮件服务器
相关参考
用户设置页面


复制项目对话框

项目 > 项目列表 > 复制项目

使用此对话框将现有项目复制到新项目。

注： 选中要随新项目一起复制的任何其他信息类型的复选框。如果未选择其他信息类型，则将复制仅带有组分配、位置分配和项目设置的空项目。
项 | 说明
新建项目名称 | 指定现有项目要复制到的新项目的名称。
新建项目说明 | 指定现有项目要复制到的新项目的说明。
设置 | 选中此复选框，以将项目设置、筛选器、属性、自定义需求属性、更改通知和集成配置设置信息复制到新项目。不会复制第三方集成配置设置信息。
需求树（包括需求设置） | 选中此复选框，以复制需求树以及每个需求的所有信息，例如，属性、附件和其他。不会复制第三方需求信息。为外部需求管理系统配置项目后，系统将询问您是否要将 RMS 设置传输到项目副本。
需求历史记录 | 选中此复选框，以复制每个需求的历史信息。此选项仅在选中需求树时可用。
测试树（包括测试设置） | 选中此复选框，以复制测试树以及每个测试的所有信息。同时选中需求树和测试树时，除了上面列出的信息之外，还会复制与需求和测试（已分配的需求和已分配的测试）之间的关系相关的信息
测试历史记录 | 选中此复选框，以复制每个测试的历史信息。此选项仅在选中测试树时可用。
执行计划树（包括测试树） | 选中此复选框，以复制执行树以及每个执行计划的所有信息。
测试的上次运行 | 选中此复选框，以复制每个测试的上次运行。此选项仅在选中执行计划树时可用。选中需求树、执行计划树和测试的上次运行时，将复制其中的所有树。同时建立这些树之间的关系。
报告 | 选中此复选框，以将所有与项目相关的报告复制到新项目。

对于 Issue Manager，该对话框将显示以下其他复选框：

复制项目 — Issue Manager 对话框项目 | 说明
复制问题 | 选中此复选框，以将所有源项目的现有问题复制到新项目。
复制存档问题 | 选中此复选框，以将所有源项目的存档问题复制到新项目。

如果未选中这两个复选框之一，问题数据将不会复制到新项目。

源项目配置将自动复制到新项目。其中包括：

  • 产品
  • GUI 配置
  • 通知规则和系统级触发器
  • 路由规则
  • 工作流
  • 收件箱中的用户视图
  • 工作组
  • 收件箱
  • 用户帐户配置
父主题： 使用项目


项目设置页面

项目 > 新建项目

使用项目设置页面配置项目。页面显示以下项目：

项 | 说明
项目名称 | 指定应出现在 GUI 和报告中的项目名称。
说明 | 项目的说明。您可以输入任何说明文本。
项目负责人 | 指定项目负责人。选定的用户帐户没有任何特殊权限；此设置仅为参考信息。
活动 | 选中此复选框可激活项目。非活动项目在应用程序中不可见。
标记 | 如果您有许多项目，请使用项目列表页面上的标记列，项目标记可帮助您筛选项目。
项目模板 | 此列表框定义项目是否基于 Agile 项目模板。选择 Agile 项目模板 使项目基于 Agile 项目管理工具的模板，或选择 <无> 创建简单项目。
Issue Manager 集成 选择以下选项之一：
  • 无项目：未创建任何 Issue Manager 集成。
  • 初始化新项目：新项目初始化为 Issue Manager 项目。单击页面底部的保存时，将显示对话框，您可在此配置项目的所有必要设置（组、收件箱、产品等）。
  • 重复使用现有项目：使用现有项目。从列表中选择项目。如果之前未将项目配置为 Issue Manager 项目，则您必须配置所有必要设置。单击保存时，将显示对话框。如果之前已将项目配置为 Issue Manager 项目，则您只需配置凭据和状态映射。
共享测试 选择以下选项之一：
  • 不共享测试：此项目不使用其他项目的测试，且其测试也不可由其他项目使用。
  • 共享测试：此项目配置为存储库项目，以使其他项目可以使用此项目的测试。
  • 使用以下项目中的共享测试：选中此项目使用的共享测试来自的存储库项目。
组 | 组部分包含可用组和已分配组的列表。根据需要分配组。使用 Ctrl+单击或 Shift+单击选择多个组。您还可单击导入 LDAP 组，以从 LDAP 服务器导入组。有关详细信息，请参阅从 LDAP 服务器导入组。如果用户组不存在，您可能要在创建用户组后再对其分配。您也可以在组设置页面配置组/项目分配。权限因用户角色而异。有关用户权限的信息，请参阅用户角色和权限。
位置 | 位置部分包含可用位置和已分配位置的列表。根据需要分配位置。使用 Ctrl+单击或 Shift+单击选择多个位置。如果位置不存在，您可能要在创建位置后再对其分配。您也可以在位置设置页面配置位置/项目分配。有关详细信息，请参阅管理位置。
父主题： 使用项目


将项目初始化为 Issue Manager 项目

在 Silk Central 中创建新项目时，您可将该项目与 Issue Manager 项目集成：
  1. 在菜单中，单击项目 > 项目列表。 此时将显示项目页面，此页面将列出所有现有的项目和项目基线。
  2. 单击新建项目。 将显示项目设置页面。
  3. 配置设置。有关更多信息，请参阅添加项目。
  4. 在 Issue Manager 集成行中，您可选择：
    • 初始化新项目：初始化新 Issue Manager 项目并将其与新创建的 Silk Central 项目集成。
    • 重复使用现有项目：现有 Issue Manager 项目将与新创建的 Silk Central 项目集成。从列表中选择项目。您必须配置凭据和状态映射。
  5. 单击页面底部的保存。 新项目将创建并显示在项目列表中。此时将显示配置 Issue Manager 项目对话框。
  6. 配置您的组设置，然后单击下一步。
  7. 单击添加收件箱以将收件箱手动添加到项目。单击生成收件箱以自动为分配到项目的所有用户生成收件箱。您可选中该复选框，以自动为将来分配的用户和用户组生成收件箱。单击下一步。
  8. 定义产品设置，然后单击关闭。
  9. 提供默认凭据，然后单击确定。您输入的用户名需要是您分配到项目的用户组的一部分。
  10. 配置外部和内部属性的映射方式，然后单击确定。
注： 您可随时取消初始化过程。但是，要稍后完成初始化，您必须在问题跟踪配置文件页面、Issue Manager 项目列表页面和 Issue Manager 配置页面上配置这些设置。
父主题： 使用项目


内部版本信息

内部版本信息文件包含用于执行运行的版本和内部版本信息。 通常在执行运行的执行服务器上存储和搜索内部版本信息文件。 如果未在执行服务器上找到内部版本信息文件，将在应用程序服务器上搜索该文件。 当您拥有多台执行服务器并在所有执行服务器之间使用一个内部版本信息文件时，此行为会非常有用。 您只需在应用程序服务器上维护一个内部版本信息文件。 将在应用程序服务器上立即搜索未分配执行服务器的自动测试以及所有手动测试的内部版本信息文件。

Silk Central 能够将测试结果与内部版本信息进行匹配并显示特定内部版本号的测试结果。

  • 内部版本信息更新
    介绍如何更新内部版本信息。
  • 创建内部版本信息文件
    创建内部版本信息文件，以存储 Silk Central 项目的内部版本信息。
父主题： 管理项目


内部版本信息更新

必须手动创建和配置内部版本信息文件。 每当有新的内部版本可用于执行服务器上的测试时，请更新内部版本信息以反映新的内部版本号。

您可通过两种不同方式更新内部版本信息：

  • 通过在每次安装新的内部版本时编辑文件来手动更新。
  • 如果您使用自动内部版本更新流程来更新内部版本信息文件（例如，通过 VB 脚本），则可自动更新。
父主题： 内部版本信息


创建内部版本信息文件

创建内部版本信息文件：
  1. 在应用程序服务器上，导航到：C:\ProgramData\SilkCentral\instance_<实例编号>_<实例名称>\BuildInfos。
  2. 基于模板文件 BuildInfoExample.xml 创建项目的内部版本信息文件。模板文件包含以下代码：
    <ProjectBuildInfo>
  <BuildEntryList>
       <BuildEntry name="Demo Product">
            <Version>3.1</Version>
            <BuildNr>350</BuildNr>
    </BuildEntry>
       <BuildEntry name="Product2">
            <Version>4.2</Version>
            <BuildNr>613</BuildNr>
    </BuildEntry>
  </BuildEntryList>
</ProjectBuildInfo>
    注： 名为 BuildEntryList 的元素包含 BuildEntry 元素列表。BuildEntry 标记表示 BuildEntry 元素的名称属性所定义的特定产品。
  3. 修改文件内容以符合您的环境。
    Version
    当前可用于测试的版本数量。每台执行服务器的数量不必须相同。
    BuildNr
    当前可用于测试的内部版本数量。每台执行服务器的数量不必须相同。
  4. 可选：如果您要求特定执行服务器使用不同版本和内部版本信息，请将修改后的内部版本信息文件分发到 C:\ProgramData\SilkCentral\BuildInfos 下的执行服务器。对于 Linux 执行服务器，该文件需要存储在用户主目录的 ~/.LinuxExecServer-18.5.0/BuildInfos/ 路径下。
  5. 创建内部版本信息文件之后，您必须在相应项目的设置中指定文件名。单击项目：<项目名称> > 项目列表以查看分配给您的项目列表。选择要链接内部版本信息的项目。
    注： 必须在计划项目的任何测试之前执行此操作。否则，将不会更新先前计划的测试。
  6. 单击项目设置选项卡。
  7. 单击编辑以编辑所选项目的项目设置。 将打开编辑项目设置对话框。
  8. 在内部版本信息文件名文本框中，指定先前创建的 XML 文件的名称。
  9. 单击确定以更新信息。对于将来所有测试执行，Silk Central 将从相应文件读取内部版本信息并将测试结果与该信息进行匹配。
父主题： 内部版本信息


比较项目与基线

对于基线项目，您可使用基线比较报告查看项目中自项目成为基线项目起的所有测试更改。

查看报告：

  1. 在菜单中，单击项目 > 项目列表。
  2. 使用 Ctrl+单击选择要比较的项目和项目的基线。
    提示： 为了更易于选择基线，请不要单击基线名称。而是点进另一列。
  3. 右键单击所选内容。
  4. 选择报告 > 基线测试比较。
    注： 基线比较报告必须执行一次才会显示在上下文菜单中。如果报告呈灰色，请在报告区域中执行一次报告。
父主题： 管理项目


选择项目

选择项目：

  1. 在菜单中，单击项目 > 项目列表。
  2. 单击项目名称进行选择。
    注： 您只能选择活动项目。
父主题： 管理项目


项目列表

项目：<项目名称> > 项目列表

项目列表页面按字母顺序显示了与 Silk Central 安装关联的所有项目和项目基线。页面支持筛选，但不支持排序。显示的项目按名称排序。非活动项目和项目基线会禁用。

项目基线按创建日期排序，用特殊图标标记，并显示为原始项目的子节点。

有关更多信息，请参阅管理项目。

将为每个项目和项目基线显示以下列：

列 | 说明
操作 | 删除 编辑项目 复制项目 基线项目 导出项目 注： 如果当前用户不具有修改/删除项目的权限，将隐藏此列。
项目 | 项目名称。单击可将项目设置为活动项目。
项目 ID | 项目的标识符。
状态 | 活动或非活动。单击可切换状态。
说明 | 项目说明。
项目负责人 | 指定项目负责人。选定的用户帐户没有任何特殊权限；此设置仅为参考信息。
发布日期 | 指定项目的计划发布日期。
创建于 | 创建项目的日期和时间。
创建者 | 创建项目的用户。
更改时间 | 上次更改项目的日期和时间。
更改者 | 上次更改项目的用户。
标记 | 如果您有许多项目，请使用项目列表页面上的标记列，项目标记可帮助您筛选项目。 使用 Ctrl+单击或 Shift+单击选择多个项目，然后右键单击选定项并单击编辑标记，可一次性管理多个项目的标记。 注： 使用 OR 条件按标记进行筛选，这意味着将显示包含其中一个所选标记的所有项目。
父主题： 管理项目
相关概念
使用项目


切换到最近访问的项目

您可以在最近访问的五个 Silk Central 项目之间快速切换。

打开您最近打开的五个项目之一：

  1. 在菜单中，单击项目。
  2. 在最近的项目列表中，单击您要访问的项目名称。 您可以继续使用选定的项目。
父主题： 管理项目


项目设置

项目设置是特定于项目的设置，例如项目发布日期。

  • 配置项目设置
    配置项目设置以对其进行自定义。
  • 筛选器
    介绍如何使用筛选器查找需要的准确信息，同时排除无关详细信息。
  • 属性
    介绍如何使用自定义属性来自定义测试和执行计划信息。
  • 需求属性
    介绍可用的需求属性类型。
  • 步骤属性
    介绍如何使用步骤属性展开具有其他属性的手动测试步骤。
  • 更改通知
    介绍如何设置其他用户更改需求或测试时的电子邮件通知。
  • 需求管理工具集成
    集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。
  • 问题跟踪配置文件集成
    介绍如何将 Silk Central 与外部问题跟踪系统相集成。
  • 源代码管理配置文件
    源代码管理配置文件可使 Silk Central 与外部源代码管理系统集成。定义源代码管理配置文件允许您定义 Silk Central 执行服务器应检索程序来源以执行测试的位置。
  • 用于数据驱动测试的数据源
    数据驱动测试是源自现有数据源（例如，电子表格或数据库）中的值的测试。数据源在项目特定范围内进行管理。
  • 状态原因
    解释状态原因如何限定手动测试运行的状态。
  • 项目设置页面
    列出了活动项目的高级详细信息。
父主题： 管理项目


配置项目设置

自定义项目设置：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击项目设置选项卡以查看当前设置。 将打开项目设置页面。
  3. 单击编辑以修改当前项目设置。
  4. 将显示编辑项目设置对话框。您可指定以下信息：
    内部版本信息文件名
    内部版本信息文件包含项目信息，其中包括内部版本号、生成日志位置、错误日志位置和生成位置。在此文本框中输入项目的内部版本信息文件名称。所有测试执行从该指定文件中读取内部版本信息。
    项目发布日期
    指定项目的计划发布日期。
    要在结果中忽略的文件扩展名
    指定不应另存为测试执行结果的结果文件类型或其他文件类型。
    注： 文件扩展名必须用逗号分隔，例如 xlg, *_, res。内部版本信息文件名和要在结果中忽略的文件扩展名字段中所做的更改将不会影响计划测试。要将任务重新分发到执行服务器，您必须重新计划任务或断开并重新连接到数据库。
  5. 单击确定以保存您的项目设置。
父主题： 项目设置
相关概念
内部版本信息


问题跟踪配置文件集成

问题跟踪配置文件可使 Silk Central 与外部问题跟踪系统集成。

可以通过安装自定义插件来配置其他问题跟踪系统。有关其他信息，请参阅问题跟踪集成。通过定义问题跟踪配置文件，您可以将测试区域内的测试链接到第三方问题跟踪系统中的问题。链接的问题状态将定期从第三方问题跟踪系统进行更新。

  • 映射问题状态
    将外部问题跟踪系统的现有问题状态映射至 Silk Central 的问题状态，以使 Silk Central 在查询内部和外部问题时正确列出问题。
  • Atlassian JIRA
    介绍如何配置 Atlassian JIRA 问题跟踪配置文件来与 Silk Central 集成。
  • Bugzilla
    介绍如何配置 Bugzilla 问题跟踪配置文件以与 Silk Central 集成。
  • IBM Rational ClearQuest
    介绍如何配置 IBM Rational ClearQuest 问题跟踪配置文件来与 Silk Central 集成。
  • Issue Manager
    介绍 Silk Central 的问题跟踪工具 Issue Manager。
  • SAP Solution Manager 集成
    介绍如何集成 Silk Central 与 SAP Solution Manager。
  • Microsoft Team Foundation Server
    介绍如何配置 Team Foundation Server 问题跟踪配置文件来与 Silk Central 集成。
  • StarTeam 问题跟踪配置文件
    介绍如何配置 StarTeam 问题跟踪配置文件来与 Silk Central 集成。
  • 删除问题跟踪配置文件
    如果不再需要配置文件，则可删除现有的问题跟踪配置文件。
  • 问题跟踪配置文件页面
    列出为将外部问题跟踪系统集成到 Silk Central 而配置的所有问题跟踪配置文件。
父主题： 项目设置
父主题： 集成
相关概念
问题跟踪集成


映射问题状态

在定义新问题跟踪配置文件后，您应该将外部问题跟踪系统的现有问题状态映射到 Silk Central 的问题状态。 执行此操作可使 Silk Central 在查询内部和外部问题时正确列出问题。

要映射问题状态：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击问题跟踪选项卡。 此时将打开问题跟踪页面，列出已为系统创建的所有问题跟踪配置文件。
  3. 在要编辑的问题跟踪配置文件的操作列中，单击 编辑问题跟踪配置文件的映射...。 此时将打开编辑状态映射对话框。
  4. 通过从列表框中选择相应的条目，可将内部问题状态映射到相应的外部系统状态。 外部问题跟踪软件的现有问题状态将在外部列中列出。 Silk Central 的内部问题状态在内部列的列表框中可用。
  5. 将每个外部问题状态映射到内部状态后，单击确定以保存您的设置，或者单击取消以中止操作。
父主题： 问题跟踪配置文件集成


Atlassian JIRA

本部分介绍如何配置 Atlassian JIRA (JIRA) 问题跟踪配置文件来与 Silk Central 集成。

JIRA 插件依赖 Silk Central Java API 实现集成，并使用 JIRA 的 REST API。

目前支持与 Silk Central 集成的版本： Atlassian JIRA 6、7

如果已将外部 JIRA 问题分配到测试，则可输入带项目关键字或不带项目关键字的问题 ID。例如：PROJECT-13 或仅 13。

Silk Central 支持以下 JIRA 字段类型：
  • Text Field (< 255 characters) /Free Text Field (unlimited text)
  • Select List (single choice) /Select List (multiple choices)
  • Date Picker /Date Time Picker
    注： 这些类型是作为文本字段提供的，需要按照 JIRA 中那样进行格式化：Date Picker：dd/MMM/yy（例如 24/Mar/16），Date Time Picker：dd/MMM/yy h:mm a（例如 24/Mar/16 4:11 AM）
  • Group Picker (single group) /Group Picker (multiple groups)
  • Project Picker (single project)
  • User Picker (single user) /User Picker (multiple users)
    注： 对于 JIRA 版本 5 和更低版本，仅属于默认 jira-users 组的用户不会显示出来。
  • Version Picker (single version)/版本选择器（多版本）
其他 JIRA 字段类型在 Silk Central 中呈现为单行文本字段。

不支持以下 JIRA 系统字段：Original Estimate、Remaining Estimate、Attachment 和 Labels。

  • 添加 Atlassian JIRA 问题跟踪配置文件
    创建 JIRA 问题跟踪配置文件，以将测试区域中的测试链接到 JIRA 中的问题。
  • 编辑 Atlassian JIRA 问题跟踪配置文件
    如果服务器或登录凭据发生更改，则可修改现有 JIRA 问题跟踪配置文件。
父主题： 问题跟踪配置文件集成


添加 Atlassian JIRA 问题跟踪配置文件

添加 JIRA 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击新建配置文件以打开新建问题跟踪配置文件对话框。
  3. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 为新配置文件键入说明。
  5. 从类型列表中选择Atlassian JIRA。
  6. 键入有效的用户名和密码。用户名必须是有效的 JIRA 用户配置文件名称。 这些凭据用于访问您的 JIRA 问题跟踪系统。
    重要： 使用具备足够权限的 JIRA 帐户的凭据，因为在插件尝试通过此帐户添加或更新问题时，JIRA 中缺少权限可能会造成不一致。JIRA 帐户需要具备 Silk Central 中所用每个项目的以下权限：
    • 浏览项目
    • 创建问题
    • 可分配用户
    • 修改报告人员

    此外，JIRA 帐户还需要能够访问（登录）您的 JIRA 应用程序。

  7. 在 URL 字段中，键入 JIRA 服务器的主机名以及用于连接到服务器的端口。
  8. 单击加载项目以从服务器加载所有项目，填充项目列表框，然后从项目列表框中选择项目。
  9. 可选：从显示所有字段列表中选择真将在问题对话框中显示所有可用的 JIRA 字段，否则只显示所需的字段。如果已选择“真”，则为问题跟踪配置文件定义的 JIRA 用户必须拥有 JIRA 管理权限。
  10. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  11. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： Atlassian JIRA
相关任务
映射问题状态


编辑 Atlassian JIRA 问题跟踪配置文件

如果问题跟踪系统的服务器或登录凭据发生更改，您必须相应地编辑问题跟踪配置文件。

要编辑现有的 Atlassian JIRA 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击要修改的问题跟踪配置文件的名称。 此时将打开编辑问题跟踪配置文件对话框。
  3. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 编辑配置文件的说明。
  5. 可选：从列表框中为问题跟踪配置文件选择新类型。
  6. 键入有效的用户名和密码。用户名必须是有效的 JIRA 用户配置文件名称。 这些凭据用于访问您的 JIRA 问题跟踪系统。
    重要： 使用具备足够权限的 JIRA 帐户的凭据，因为在插件尝试通过此帐户添加或更新问题时，JIRA 中缺少权限可能会造成不一致。JIRA 帐户需要具备 Silk Central 中所用每个项目的以下权限：
    • 浏览项目
    • 创建问题
    • 可分配用户
    • 修改报告人员

    此外，JIRA 帐户还需要能够访问（登录）您的 JIRA 应用程序。

  7. 在 URL 字段中，编辑 JIRA 服务器的主机名和用于连接到服务器的端口。
  8. 要更改 JIRA 项目，请单击加载项目以从服务器加载所有项目，更新项目列表框，然后从项目列表框中选择项目。
  9. 可选：从显示所有字段列表中选择真将在问题对话框中显示所有可用的 JIRA 字段，否则只显示所需的字段。如果已选择“真”，则为问题跟踪配置文件定义的 JIRA 用户必须拥有 JIRA 管理权限。
  10. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  11. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： Atlassian JIRA
相关任务
映射问题状态


Bugzilla

本节介绍如何配置 Bugzilla 问题跟踪配置文件以与 Silk Central 集成。

Bugzilla 插件依赖 Silk Central Java API 实现集成。通过使用 Redstone XML-RPC 库，Silk Central 可借助 Bugzilla 3.0 随附的 XML-RPC Bugzilla Web 服务与 Bugzilla 进行通信。要实现 Bugzilla 集成，请确保您已安装适用于 Web 服务器的 SOAP::Lite 程序包。例如，为 Debian 分发安装 libsoap-lite-perl 程序包。

目前支持与 Silk Central 集成的版本： Bugzilla 4.4.12、5.0.3

  • 添加 Bugzilla 问题跟踪配置文件
    创建 Bugzilla 问题跟踪配置文件，以将测试区域中的测试链接到 Bugzilla 中的问题。
  • 编辑 Bugzilla 问题跟踪配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 Bugzilla 问题跟踪配置文件。
父主题： 问题跟踪配置文件集成


添加 Bugzilla 问题跟踪配置文件

添加 Bugzilla 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击新建配置文件以打开新建问题跟踪配置文件对话框。
  3. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 为新配置文件键入说明。
  5. 从类型列表框中选择 Bugzilla。
  6. 键入有效的用户名和密码。 这些凭据将用于访问问题跟踪系统。
  7. 输入 Bugzilla 安装的 URL。例如，http://bugzillaserver/bugzilla。
  8. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  9. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： Bugzilla
相关任务
映射问题状态


编辑 Bugzilla 问题跟踪配置文件

如果问题跟踪系统的服务器或登录凭据发生更改，您必须相应地编辑问题跟踪配置文件。

要编辑现有的 Bugzilla 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击要修改的问题跟踪配置文件的名称。 此时将打开编辑问题跟踪配置文件对话框。
  3. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 编辑配置文件的说明。
  5. 可选：从列表框中为问题跟踪配置文件选择新类型。
  6. 编辑用户名和密码。 这些凭据用于访问您的问题跟踪系统。
  7. 编辑 Bugzilla 安装的 URL。
  8. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  9. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： Bugzilla
相关任务
映射问题状态


IBM Rational ClearQuest

本部分介绍如何配置 IBM Rational ClearQuest 问题跟踪配置文件来与 Silk Central 集成。

IBM Rational ClearQuest 产品可提供可变缺陷/更改跟踪和自动工作流支持。两个关键产品为 IBM Rational ClearQuest (ClearQuest) 和 IBM Rational ClearQuest MultiSite (ClearQuest Multisite)。要使用 ClearQuest 配置文件，在运行 Silk Central 前端服务器的计算机上必须安装了 ClearQuest 客户端软件。有关安装 ClearQuest 的详细信息，请参阅 ClearQuest 文档。

目前支持与 Silk Central 集成的版本： IBM Rational ClearQuest 8.0

  • 添加 ClearQuest 问题跟踪配置文件
    创建 ClearQuest 问题跟踪配置文件，以将测试区域中的测试链接到 ClearQuest 中的问题。
  • 编辑 ClearQuest 问题跟踪配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 ClearQuest 问题跟踪配置文件。
父主题： 问题跟踪配置文件集成


添加 ClearQuest 问题跟踪配置文件

添加 ClearQuest 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击新建配置文件以打开新建问题跟踪配置文件对话框。
  3. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 为新配置文件键入说明。
  5. 从类型列表框中选择 IBM Rational ClearQuest。
  6. 键入有效的用户名和密码。 这些凭据将用于访问问题跟踪系统。
  7. 输入 ClearQuest 安装的存储库信息。 这是在 ClearQuest 客户端软件中定义的数据库名称。示例数据库的名称为 SAMPL。
    注： 不能使用一个以上的 ClearQuest 架构存储库。Silk Central 将连接到默认 ClearQuest 存储库。
  8. 指定记录类型，即 ClearQuest 的问题类型。 在 Silk Central 中输入问题时，ClearQuest 将保存问题以及您在此文本框中定义的问题类型。默认问题类型为 Defect。
  9. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  10. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： IBM Rational ClearQuest
相关任务
映射问题状态


编辑 ClearQuest 问题跟踪配置文件

如果问题跟踪系统的服务器或登录凭据发生更改，您必须相应地编辑问题跟踪配置文件。

要编辑现有的 ClearQuest 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击要修改的问题跟踪配置文件的名称。 此时将打开编辑问题跟踪配置文件对话框。
  3. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 编辑配置文件的说明。
  5. 可选：从列表框中为问题跟踪配置文件选择新类型。
  6. 编辑用户名和密码。 这些凭据用于访问您的问题跟踪系统。
  7. 编辑 ClearQuest 安装的存储库信息。 这是在 ClearQuest 客户端软件中定义的数据库名称。示例数据库的名称为 SAMPL。
    注： 不能使用一个以上的 ClearQuest 架构存储库。Silk Central将连接到默认 ClearQuest 存储库。
  8. 更改作为 ClearQuest 的问题类型的记录类型。 在 Silk Central 中输入问题时，ClearQuest 将使用您在此字段中定义的问题类型保存问题。
  9. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  10. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： IBM Rational ClearQuest
相关任务
映射问题状态


Issue Manager

Silk Central 的问题跟踪工具 Issue Manager 与 Silk Central 完全集成，可使您将问题与系统需求和已执行的测试关联。

可通过测试 > 详细信息视图 > 问题在菜单中添加和管理测试问题。 有关更多信息，请参阅本帮助中的 Issue Manager 主题。

  • 添加 Issue Manager 问题跟踪配置文件
    创建 Issue Manager 问题跟踪配置文件，以将测试区域中的测试链接到 Issue Manager 中的问题。
  • 编辑 Issue Manager 问题跟踪配置文件
    如果服务器或登录凭据发生更改，则可修改现有 Issue Manager 问题跟踪配置文件。
父主题： 问题跟踪配置文件集成
相关概念
API 帮助


添加 Issue Manager 问题跟踪配置文件

添加 Issue Manager 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击新建配置文件以打开新建问题跟踪配置文件对话框。
  3. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 为新配置文件键入说明。
  5. 从类型列表框中选择 Issue Manager。
  6. 选中本地存储库复选框，以使用集成的 Issue Manager 配置文件（属于您的 Silk Central 实例的一部分）。要连接到外部 Issue Manager 系统，请取消选中此选项，在这种情况下，您将需要提供有效的登录凭据才能访问系统。
  7. 键入您的 Issue Manager 安装的 Issue Manager URL。这是用于登录到 Issue Manager 的 URL，但其末尾没有 login 扩展名。如果选中本地存储库选项，请保留默认 URL。 例如，如果您的标准 Issue Manager URL 是 http://IssueManager/login，则正确的服务 URL 是 http://IssueManager。
  8. 可选：如果 Issue Manager 需要通过不同于用户访问 Web 用户界面的 URL 与前端服务器进行通信，请在 Web 服务 URL 字段中键入此 URL。例如，用户通过代理访问 Web 用户界面，而 Issue Manager 需要前端服务器的内部 URL 或 IP 地址，此时就必须采用这种方法。
  9. 请继续以下操作：
    1. 单击加载项目。此操作会使用指定用户有权访问的所有已初始化 Issue Manager 项目填充项目列表框。请注意，只会显示 Issue Manager 用户组已为其定义的项目，并且已定义的用户是至少一个用户组的成员。
    2. 选择存在 Issue Manager 问题的项目。
    警告：
    我们建议不要将相同项目用于 Issue Manager 和 Silk Central，因为这会限制将来使用这两种工具处理不同项目的灵活性。
  10. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  11. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： Issue Manager
相关任务
映射问题状态


编辑 Issue Manager 问题跟踪配置文件

如果问题跟踪系统的服务器或登录凭据发生更改，您必须相应地编辑问题跟踪配置文件。

要编辑现有的 Issue Manager 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击要修改的问题跟踪配置文件的名称。 此时将打开编辑问题跟踪配置文件对话框。
  3. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 编辑配置文件的说明。
  5. 可选：从列表框中为问题跟踪配置文件选择新类型。
  6. 选中本地存储库复选框，以使用集成的 Issue Manager 配置文件（属于您的 Silk Central 实例的一部分）。要连接到外部 Issue Manager 系统，请取消选中此选项，在这种情况下，您将需要提供有效的登录凭据才能访问系统。
  7. 如果位置已发生更改，请编辑 Issue Manager 安装的 Issue Manager URL。 这是用于登录到 Issue Manager 的 URL，但其末尾没有 login 扩展名。例如，如果您的标准 Issue Manager URL 是 http://IssueManager/login，则正确的服务 URL 是 http://IssueManager。
  8. 可选：如果 Issue Manager 需要通过不同于用户访问 Web 用户界面的 URL 与前端服务器进行通信，请在 Web 服务 URL 字段中键入此 URL。例如，用户通过代理访问 Web 用户界面，而 Issue Manager 需要前端服务器的内部 URL 或 IP 地址，此时就必须采用这种方法。
  9. 要更改 Issue Manager 项目，请单击加载项目以从服务器加载所有项目，更新项目列表框，然后从项目列表框中选择项目。
  10. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  11. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： Issue Manager
相关任务
映射问题状态


Microsoft Team Foundation Server

本部分介绍如何配置 Team Foundation Server (TFS) 问题跟踪配置文件来与 Silk Central 集成。

目前支持与 Silk Central 集成的版本：Team Foundation Server 2012、2013、2015

  • 安装 Team Foundation Server Web 服务代理
    安装 Team Foundation Server Web 服务代理作为 TFS 的接口
  • 添加 TFS 问题跟踪配置文件
    创建 TFS 问题跟踪配置文件，以将测试区域中的测试链接到 TFS 中的问题。
  • 编辑 TFS 问题跟踪配置文件
    如果服务器或登录凭据发生更改，则可修改现有的 TFS 问题跟踪配置文件。
父主题： 问题跟踪配置文件集成


安装 Team Foundation Server Web 服务代理

要与 TFS 进行通信，您需要安装 Team Foundation Server Web 服务代理作为 TFS 的接口。

要安装 TFS 代理服务：

  1. 从 http://www.microsoft.com/downloads/details.aspx?FamilyID=fe4f9904-0480-4c9d-a264-02fedd78ab38 中安装 Microsoft Visual Studio Team Explorer。
  2. 安装 IIS 和 Web 部署工具，例如使用 http://www.microsoft.com/web/downloads/default.aspx 中的 Web Platform Installer。
  3. 从帮助 > 工具中下载 Team Foundation Server Web 服务代理。
  4. 解压下载的程序包。
  5. 打开命令外壳并键入 DotNetTfsWebServiceProxy.deploy.cmd /Y 以安装代理服务。如果显示错误消息框，指明需要 ASP.NET 4，请参阅 http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx。
  6. 打开 IIS Manager。
  7. 验证新网站是否存在。
  8. 在虚拟目录的根文件夹中，打开 Web.config 文件。
  9. 在文件的 appSettings 部分，将键 WorkItemTrackingCacheRoot 的值修改为本地目录。 例如：
    <appSettings>
  <add key="WorkItemTrackingCacheRoot" value="C:\temp" />
</appSettings>
  10. 如果您指定的目录不存在，请创建它。
  11. 为任何人授予指定目录的完整权限。
有关部署 ASP.NET Web 应用程序的其他信息，请参阅 http://msdn.microsoft.com/en-us/library/ee942158.aspx。
注： 如果您从版本 16.5 或更早版本升级 Silk Central，则需要重新部署 TFS 代理服务。 删除现有的 TFS 代理服务，然后继续上面的第 3 步。完成操作后，请重新启动 IIS。
父主题： Microsoft Team Foundation Server


添加 TFS 问题跟踪配置文件

您需要配置 Micro Focus 提供的 Team Foundation Server Web 服务代理，以使 Silk Central 能够访问 TFS 问题。
重要： 这不是 Microsoft 提供的 Team Foundation Server 代理。

添加 TFS 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击新建配置文件以打开新建问题跟踪配置文件对话框。
  3. 为新配置文件键入名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 为新配置文件键入说明。
  5. 从类型列表框中选择 Team Foundation Server <版本>。
  6. 键入有效的用户名和密码。 这些凭据将用于访问问题跟踪系统。
  7. 键入 TFS 用户的域。
  8. 输入 TFS 安装的 URL。 例如，http://tfsserver:8080/tfs。
  9. 键入项目所属的集合。 例如 DefaultCollection。 集合中所有项目都会列在项目列表框中。
  10. 从列表框中选择项目。
  11. 键入 TFS 代理的 URL。例如 http://tfsproxyserver/DotNetTfsWebServiceProxy_deploy/TfsWebServiceProxy.asmx。
  12. 单击加载工作项类型。 工作项类型列表框将使用可用工作项类型进行填充。
  13. 从列表框中选择工作项类型。
  14. 单击加载初始状态。 初始状态列表框将使用所选工作项类型允许的状态进行填充。
  15. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  16. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： Microsoft Team Foundation Server
相关任务
映射问题状态


编辑 TFS 问题跟踪配置文件

如果问题跟踪系统的服务器或登录凭据发生更改，您必须相应地编辑问题跟踪配置文件。

要编辑现有的 TFS 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击要修改的问题跟踪配置文件的名称。 此时将打开编辑问题跟踪配置文件对话框。
  3. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 编辑配置文件的说明。
  5. 可选：从列表框中为问题跟踪配置文件选择新类型。
  6. 编辑用户名和密码。 这些凭据用于访问您的问题跟踪系统。
  7. 编辑 TFS 用户的 Domain。
  8. 编辑 TFS 安装的 URL 和 Collection。
  9. 选择其他项目。
  10. 编辑 TFS 代理的 URL 和端口。
  11. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
父主题： Microsoft Team Foundation Server


StarTeam 问题跟踪配置文件

本部分介绍如何配置 StarTeam 问题跟踪配置文件来与 Silk Central 集成。

StarTeam 是软件更改管理和配置管理工具，能够协调和管理软件交付过程。

要使用 StarTeam 配置文件并在 StarTeam 中将转到链接功能用于更改请求，您必须在浏览器所运行的计算机上安装 StarTeam Cross-Platform Client 软件。

目前支持与 Silk Central 集成的版本： StarTeam 15.x、16.x

  • 添加 StarTeam 问题跟踪配置文件
    创建 StarTeam 问题跟踪配置文件，以将测试区域中的测试链接到 StarTeam 中的问题。
  • 编辑 StarTeam 问题跟踪配置文件
    如果服务器或登录凭据发生更改，则可修改现有 StarTeam 问题跟踪配置文件。
父主题： 问题跟踪配置文件集成


添加 StarTeam 问题跟踪配置文件

添加 StarTeam 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击新建配置文件以打开新建问题跟踪配置文件对话框。
  3. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 为新配置文件键入说明。
  5. 从类型列表框中选择 StarTeam
  6. 键入有效的用户名和密码。 这些凭据将用于访问问题跟踪系统。
  7. 键入 StarTeam 服务器的主机名以及用于连接到服务器的端口。 如果尚未更改此设置，则使用默认端口 49201。
  8. 指定配置文件支持的加密类型。
  9. 单击加载项目以从服务器加载所有项目，填充项目列表框，然后从项目列表框中选择项目。
  10. 单击加载视图以加载所选项目的所有视图并填充视图列表框，然后从视图列表框中选择视图。
  11. 单击加载状态字段以加载更改请求的所有枚举字段并填充状态字段列表框，然后从状态字段列表框中选择状态字段。 如果在 StarTeam 中使用自定义工作流，则此字段是 StarTeam 中映射到 Silk Central 问题状态的工作流驱动程序字段。
  12. 从链接类型列表框中选择链接类型。
    starteam://
    问题选项卡上的外部 ID 链接将打开交叉平台客户端。
    http://
    问题选项卡上的外部 ID 将在 StarTeam Web UI 中打开问题。
  13. 如果您已在链接类型列表框中选择 http://，请在 WebServer 字段中输入 StarTeam Web UI 的 Web 服务器地址。
  14. 在工作流字段中选择 Yes 或 No。选择 Yes 以显示在所选视图的工作流中指定的必填字段。
  15. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  16. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： StarTeam 问题跟踪配置文件
相关任务
映射问题状态


编辑 StarTeam 问题跟踪配置文件

如果问题跟踪系统的服务器或登录凭据发生更改，您必须相应地编辑问题跟踪配置文件。

要编辑现有的 StarTeam 问题跟踪配置文件：

  1. 在菜单中，单击问题 > 问题跟踪集成。 此时将显示问题跟踪页面，其中列出了为系统创建的所有问题跟踪配置文件。
  2. 单击要修改的问题跟踪配置文件的名称。 此时将打开编辑问题跟踪配置文件对话框。
  3. 编辑配置文件的名称。 这是可在其中选择配置文件的列表中显示的名称。
  4. 编辑配置文件的说明。
  5. 可选：从列表框中为问题跟踪配置文件选择新类型。
  6. 编辑用户名和密码。 这些凭据用于访问您的问题跟踪系统。
  7. 编辑 StarTeam 服务器的主机名和用于连接到服务器的端口。
  8. 修改配置文件支持的加密类型。
  9. 要更改 StarTeam 项目，请单击加载项目以从服务器加载所有项目，更新项目列表框，然后从项目列表框中选择项目。
  10. 要更改视图，请单击加载视图以加载所选项目的所有视图并填充视图列表框，然后从视图列表框中选择视图。
  11. 要更改工作流驱动器字段，请单击加载状态字段以加载更改请求的所有枚举字段并填充状态字段列表框，然后从状态字段列表框中选择状态字段。 如果您在 StarTeam 中使用自定义工作流，则此字段为映射到 Silk Central 问题状态的 StarTeam 中的工作流驱动器。
  12. 从链接类型列表框中选择链接类型。
    starteam://
    问题选项卡上的外部 ID 链接将打开交叉平台客户端。
    http://
    问题选项卡上的外部 ID 将在 StarTeam Web UI 中打开问题。
  13. 如果您已在链接类型列表框中选择 http://，请在 WebServer 字段中输入 StarTeam Web UI 的 Web 服务器地址。
  14. 在工作流字段中选择 Yes 或 No。选择 Yes 以显示在所选视图的工作流中指定的必填字段。
  15. 单击确定。

    Silk Central 将尝试使用您提供的信息与外部系统进行测试连接。

    注： 如果发生错误，请复查您提供的信息，或咨询您的管理员。
  16. 如果测试连接成功，则会显示确认对话框，询问您是否要将内部问题状态映射为新定义配置文件的状态。
    • 单击是继续相关映射问题状态过程。
    • 单击否稍后映射问题状态。
父主题： StarTeam 问题跟踪配置文件
相关任务
映射问题状态


删除问题跟踪配置文件

要删除问题跟踪配置文件：

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击问题跟踪选项卡。 此时将打开问题跟踪页面，列出已为系统创建的所有问题跟踪配置文件。
  3. 在要删除的问题跟踪配置文件的操作列中，单击删除问题跟踪配置文件...。 此时将显示确认对话框。
  4. 单击是。
父主题： 问题跟踪配置文件集成


问题跟踪配置文件页面

项目：<项目名称> > 项目设置 > 问题跟踪

使用此页面可以配置配置文件，以将外部问题跟踪系统集成到 Silk Central。 单击新建配置文件以创建新的问题跟踪配置文件。 对于每个问题跟踪配置文件，该页面将显示以下列：

列 | 说明
名称 | 在 Silk Central GUI 和报告中显示的配置文件名称。 单击名称可编辑配置文件。
类型 | 外部问题跟踪系统。
登录 | 用于将 Silk Central 连接至问题跟踪系统的登录名称。
存储库信息 | 问题跟踪系统的物理位置。 主机名或 URL。
创建时间 | 创建问题跟踪配置文件的日期。
创建者 | 创建问题跟踪配置文件的用户。
操作
可以对问题跟踪配置文件执行以下操作：
  • 删除问题跟踪配置文件
  • 编辑问题跟踪配置文件的映射
父主题： 问题跟踪配置文件集成


状态原因

状态原因限定手动测试运行的状态。这允许您指定特定测试运行状态为通过、失败或未执行的原因。您最多可以为每个状态定义五个原因。按照默认设置，不支持将添加到通过状态，未解决原因将添加到失败状态。为各状态添加额外的原因有助于限定测试运行的状态，例如，您可以为状态定义以下原因：
  • 通过：不支持
  • 失败：未解决、系统崩溃、缺陷、帮助不可用、客户端系统未响应
  • 未执行：待定 - 内部、待定 - 客户、测试环境不可用
  • 定义状态原因
    定义状态原因以限定测试运行的状态。
父主题： 项目设置
相关参考
测试和测试步骤的状态
测试和执行权限


定义状态原因

要添加或删除状态原因，您需要具备管理资产权限；要删除状态原因，您需要具备删除资产权限。请参阅测试和执行权限，了解详细信息。

  1. 在菜单中，单击项目：<项目名称> > 项目设置。
  2. 单击状态原因选项卡。
  3. 在您希望添加新原因的状态下方，单击添加状态原因。 新状态原因将添加到原因列表中。
  4. 在新状态原因字段中单击，输入说明文本。
  5. 按 Enter 保存状态原因文本。
现有状态原因文本也可修改，方法是在状态原因字段中单击并输入说明文本，然后按 Enter。
父主题： 状态原因


项目设置页面

项目：<项目名称> > 项目设置 > 项目设置

项目设置页面列出了以下活动项目的高级详细信息：

项目 | 说明
内部版本信息文件名 | 内部版本信息文件包含项目信息，其中包括内部版本号、生成日志位置、错误日志位置和生成位置。 在此字段中输入活动项目内部版本信息文件的名称。 所有测试执行从该指定文件中读取内部版本信息。
项目发布日期 | 已计划的活动项目的发布日期，采用 MM/DD/YYYY 格式。
要在结果中忽略的文件扩展名 | 不应另存为测试执行结果的结果文件类型或其他文件类型。
父主题： 项目设置
相关概念
内部版本信息


项目模板

本主题介绍 Silk Central 中项目模板的概念背景。

Agile 项目模板用于支持 Silk Central 和 VersionOne 或其他 Agile 项目管理工具之间的交互。 模板是具有特定属性 sprint 和版本的项目。 根据此模板创建新项目时，也会创建默认测试容器和默认文件夹。 项目管理工具创建测试时，测试会被添加到默认文件夹。 未为测试容器和文件夹指定源代码管理配置文件和产品，因此它们被标记为未完成。

父主题： 管理项目


集成

Silk Central 可与许多其他工具集成以用于各种目的。

  • 代码分析工具集成
    介绍与代码分析工具的集成。
  • 问题跟踪配置文件集成
    介绍如何将 Silk Central 与外部问题跟踪系统相集成。
  • 需求管理工具集成
    集成外部需求管理可让您使用可能已在使用的其他工具协调 Silk Central 的需求管理功能。
  • 源代码管理配置文件集成
    介绍源代码管理配置文件的集成。
  • 测试自动化工具集成
    介绍与测试自动化工具的集成。
  • 自动化服务器集成
    集成 Silk Central 与自动化服务器（例如 Jenkins）能让您将测试执行集成至持续集成构建系统。
  • 通过 SSL 与外部系统通信
    将自签名证书添加到默认 Java Keystore 以通过 SSL 与具有自签名证书的主机进行通信。
父主题： 管理


代码分析工具集成

  • DevPartner 代码覆盖率集成
    介绍 DevPartner Studio 的代码分析组件的集成。
父主题： 集成


DevPartner 代码覆盖率集成

Silk Central 与 DevPartner Studio 的代码分析组件集成。您可以使用此集成对 .NET 应用程序执行代码分析。

有关其他信息，请参阅.NET 代码分析。

父主题： 代码分析工具集成
相关概念
.NET 代码分析


源代码管理配置文件集成

  • AccuRev
    介绍如何配置 AccuRev 源代码管理配置文件。
  • Apache Commons 虚拟文件系统
    介绍如何配置虚拟文件系统源代码管理配置文件。
  • Git
    介绍如何配置 Git 源代码管理配置文件。
  • Microsoft Team Foundation Server
    介绍如何配置 Team Foundation Server 源代码管理配置文件。
  • Silk Test Workbench
    介绍如何配置 Silk Test Workbench 源代码管理配置文件。
  • StarTeam
    介绍如何配置 StarTeam 源代码管理配置文件。
  • 子版本
    介绍如何配置子版本源代码管理配置文件。
  • SilkTestPartner
    介绍如何配置 TestPartner 源代码管理配置文件。
  • 通用命名约定
    介绍如何配置通用命名约定源代码管理配置文件。
父主题： 集成


测试自动化工具集成

  • Unified Functional Testing (UFT) 测试
    Unified Functional Testing (UFT) 软件，以前称为 HP QuickTest Professional (QTP)，为软件应用程序和环境提供功能和回归测试自动化。
  • JUnit 测试
    Nunit 是用于 Java 编程语言的单位测试框架。将此测试类型用于JUnit、Silk4J 和 Selenium 测试。
  • MSTest 测试
    MSTest 是 中的命令行实用工具，用于执行在 Microsoft 中创建的单位测试。将此测试类型用于 MSTest 和 Silk4NET 测试。
  • NUnit 测试
    Nunit 是用于 Microsoft .NET 编程语言的单位测试框架。
  • ProcessExecutor 测试
    ProcessExecutor 测试类型可用于执行任何命令行。
  • Silk Performer .NET Explorer 测试
    测试类型用于执行 Silk Performer .NET Explorer 脚本或脚本的特定测试用例。
  • Silk Performer 测试
    Silk Performer 项目可以集成到 Silk Central 测试并通过 Silk Central 直接执行。这可实现强大的测试结果分析和报告。它还可启用无人值守的测试，这意味着测试由 Silk Central 根据预配置计划自动运行。
  • Silk Test Classic 测试
    Silk Central 的 Silk Test Classic 界面提供自动化 Silk Test Classic 用户的可靠方法。Silk Test Classic 脚本的每个测试用例在自己的测试执行内执行，并产生自身的结果。
  • Silk Test Workbench 测试
    Silk Test Workbench 是一种自动化测试工具，可加快复杂应用程序的功能测试。Silk Test Workbench 可为使用各种开发工具开发的测试应用程序提供支持，这些工具包括 Java、.NET、基于浏览器的 Web 应用程序，以及包括 ActiveX 控件和自动化对象的 COM 组件。
  • SilkTestPartner 测试
    TestPartner 是一款 Micro Focus 产品，用于测试使用 Microsoft 技术的 Web 和 Microsoft Windows 应用程序。
  • Windows 脚本宿主测试
    介绍如何通过 Windows 脚本宿主创建用于宿主脚本的环境。
父主题： 集成


自动化服务器集成

通过使用 Silk Central Web 服务，您可将测试执行集成至持续集成构建系统。如果您使用 Jenkins 作为自动化服务器，您可直接从 Jenkins 插件页面下载Silk Central 集成插件。

父主题： 集成
相关概念
Silk Central Web 服务
相关任务
通过命令行将关键字库上载


API 帮助

API 帮助提供了创建和部署插件以将第三方工具集成到 Silk Central 中所需的信息。 它包含 Web 服务规范和 API 说明，并且介绍了如何将插件集成到 Silk Central。

  • 简介
    此帮助提供 API 的概述，这些 API 已针对第三方应用程序与 Silk Central 的集成进行了实施。
  • 创建插件
    介绍创建所有插件类型的通用任务。
  • 代码覆盖率集成
    介绍代码覆盖率集成所需的 API。
  • 源代码管理集成
    说明如何为 Silk Central 配置自定义源代码管理插件。
  • 问题跟踪集成
    此部分介绍如何创建可启用第三方（外部）问题跟踪系统集成的插件。
  • 需求管理集成
    说明如何将 Silk Central 需求管理功能与第三方需求管理系统集成。
  • 第三方测试类型集成
    本部分说明如何为可用测试类型（Silk Performer、Silk Test Classic、手动测试、NUnit、JUnit 和 Windows 脚本宿主 (WSH)）标准集之外的测试类型创建自定义插件。
  • 云集成
    介绍如何将 Silk Central 与公共云或私有云服务提供程序集成。
  • Silk Central Web 服务
    说明可用的 Web 服务接口。


简介

本指南提供创建和部署插件以将第三方工具集成到 Silk Central 所需的信息。 它包含 Web 服务规范和 API 说明，并且介绍了如何将插件集成到 Silk Central。

注： 本指南假设您熟悉 Web 服务的实施和使用。

概述

Silk Central 提供用于集成第三方应用程序的 API。 借助 Silk Central API，您可以通过配置 Silk Central 插件来集成现有的源代码管理、问题跟踪和需求管理工具。 Silk Central 附带各种示例插件。

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

Silk Central 集成插件

Silk Central 插件“按原样”提供，它包含所有缺陷并且不提供任何保证。对于任何事宜，包括但不限于任何保证、义务、条件或适销性、特定目的之适用性、不含病毒、准确性或完整性、标题、平静行使权、平静占有权和非侵权， Micro Focus 在此声明无任何明示、暗示或法定的保证和条件。

您在使用插件时需自行承担风险。 在任何情况下，对于由使用插件导致或引起的任何类型的直接、间接、特殊、意外或结果性损失（包括但不限于利益损失），Micro Focus 概不承担任何责任。

父主题： API 帮助


创建插件

概述

本节介绍如何为 Silk Central 创建插件。 此处仅介绍所有插件类型的通用任务。

插件种类

Silk Central 提供几种插件 API。 每种 API 被视为一个种类。

编译

有关开发和编译插件的信息，请参阅相应 Java 版本的 Silk Central 发行说明。 这对于与 Silk Central Java Runtime Environment 的兼容性非常重要。

部署

创建插件类和实施种类 API 之后，您可创建插件包（JAR 或 ZIP 文件）。

  • 如果插件没有进一步的依赖关系（或依赖于已成为 Silk Central 一部分的库），则只需创建包含类的 JAR 文件。
  • 如果插件依赖于其他库，请将这些库放入子目录 lib 中，然后将所有库一起打包成 ZIP 存档。

将已创建的文件置于 <application server installation directory>\plugins\ 处的插件目录中。

注： 您必须重新启动应用程序服务器和前端服务器，以使新部署的插件在 Silk Central 中可用。 有关重新启动服务器的更多信息，请参阅本帮助中的管理主题。

分发

由于 Silk Central 知道插件种类的类型，因此也知道哪些服务器（执行服务器、应用程序服务器和前端服务器）需要哪些种类。 每种插件均可安装在应用程序服务器上。 Silk Central 会将正确插件自动分配到每个服务器。

父主题： API 帮助
相关概念
源代码管理集成
问题跟踪集成
需求管理集成
第三方测试类型集成
代码覆盖率集成
云集成


代码覆盖率集成

本章节介绍的 Java API 接口是为支持第三方（外部）代码覆盖率工具集成的 Silk Central 创建插件所必需的。

您可通过代码覆盖率工具提供关于测试覆盖哪些代码的信息。 Silk Central 提供了以下现成的代码覆盖率工具：
  • Silk Central Java 代码分析 (Java Code Analysis Agent )
  • DevPartner Studio .NET 代码分析 (Windows Code Analysis Framework)
注： 如果被测应用程序运行于 Linux 上，请参阅主题在 Linux AUT 环境中安装代码分析框架。

如果前面两种工具还不够，您可创建和部署自己的代码覆盖率集成。 请参阅 Creating Your Own Code Coverage Plugin。

注： 除了在应用程序服务器上部署自定义应用程序之外（请参阅创建插件主题），您还需要在代码分析框架服务器上部署自定义应用程序。 这是您的 AUT 和代码覆盖率工具所在位置。 路径如下：\Silk\Silk Central <version>\Plugins
  • 创建您自己的代码覆盖率插件
    介绍如何创建代码覆盖率插件。
  • 在 Linux AUT 环境中安装代码分析框架
    介绍如何在 Linux AUT 环境中安装代码分析框架。
父主题： API 帮助
相关概念
创建插件
源代码管理集成
问题跟踪集成
需求管理集成
第三方测试类型集成
部署


创建您自己的代码覆盖率插件

本主题介绍如何创建代码覆盖率插件。您应熟悉 Silk Central 基线概念。在 Silk Central 中，每次运行之前都需要基线。基线包括测试应用程序中的所有命名空间/程序包/类/方法。

注： Silk Central API 需要返回用于代码覆盖率运行的 XML 文件。这意味着，如果代码覆盖率工具在数据库中存储其代码覆盖率信息，您将需要采取其他步骤检索数据。
注： 不支持多个执行服务器根据同一代码分析框架运行测试。
  1. 将库 scc.jar 添加到您的类路径，因为它包含必须扩展的接口。可以在 Silk Central 安装目录的 lib 目录中找到 JAR 文件。
  2. 添加以下两个导入语句：
    import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfile;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfileException;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisResult;
  3. 创建实现 CodeAnalysisProfile 的类。
  4. 从代码覆盖率界面中添加所有需要的方法，如以下步骤所示。您可参阅示例接口类了解解其定义并手动实现方法，也可复制和粘贴为您提供了导入和方法定义的主题示例配置文件类。
    注： 您将写入的下述步骤中的方法实际上会在 Silk Central 需要时调用。这意味着您将无法直接调用这些方法。
  5. 代码 getBaseline。此方法应返回包含应用程序中所有命名空间/程序包/类/方法的 XML 文件。请参阅示例 XML 数据主题文件，以了解文件格式。您应使用示例 XSD 文件验证 XML。请参阅代码覆盖率 XSD 主题，以了解 XSD。

    此函数将在开始覆盖之前调用并由开始测试运行的 Silk Central 执行服务器触发，以开始代码分析并返回所有要覆盖的对象。输出结果需要使用 CA-Framework 安装文件夹中包含的 XML 架构中指定的格式转换为 XML。

  6. 代码 startCoverage。此调用将命令代码覆盖率工具开始收集数据。如果已开始，则返回 true。

    Silk Central 代码覆盖率框架将在完成 getBaseLine() 方法之后调用此函数。您应在此让代码覆盖率工具开始收集代码覆盖率数据。

  7. 代码 stopCoverage。此调用将命令代码覆盖率工具停止收集数据。如果成功，则返回 true。

    此函数将在 startCoverage 之后调用，由完成测试运行的 Silk Central 执行服务器触发，以停止代码分析。

  8. 代码 getCoverage。此函数将返回 XML 文件，其中包括从 startCoverage 和 stopCoverage 方法之间收集到的数据。请参阅示例 XML 数据主题，以了解文件格式。您应使用示例 XSD 文件验证 XML。请参阅代码覆盖率 XSD 主题，以了解 XSD。

    此函数将在 stopCoverage() 之后调用并返回已收集的所有覆盖率数据。输出结果需要使用 XML 架构中指定的格式转换为 XML。

  9. 代码 GetName。此函数将提供用于引用代码覆盖率工具的名称。例如，此值将用作编辑代码分析设置对话框上的代码分析配置文件列表中的一个值。

    此函数首先由 Silk Central 代码覆盖率框架调用。插件名称显示在 Silk Central 中的代码覆盖率列表中。

  10. 将插件生成 jar 文件，然后将 jar 文件压缩成 zip 文件。
  11. 将插件部署到以下位置：
    • Silk Central 安装文件夹的 Plugins 目录中。
    • CA-Framework 安装的 Plugins 目录中。
  • 示例配置文件类
    介绍示例配置文件类。
  • 代码覆盖率 XSD
    介绍代码覆盖率 XSD 文件。
  • 示例 XML 数据
    介绍代码覆盖率集成 API 的示例 XML 数据。
父主题： 代码覆盖率集成


示例配置文件类

此示例文件概述代码覆盖率插件的所有必要方法、导入和实施。

//Add the library scc.jar to your classpath as it contains the interfaces that
//must be extended. The JAR file can be found in the lib directory of the Test
//Manager installation directory.
//
//make sure to include these imports after adding the scc.jar external reference
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfile;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisProfileException;
import com.segue.scc.published.api.codeanalysis.CodeAnalysisResult;

public class myProfileClass implements CodeAnalysisProfile{

  // This function is called first by the Silk Central Code Coverage framework
  // The name of the plug-in is displayed in the code coverage drop down in Silk Central
  @Override
  public String getName() {
    // The name of the plugin cannot be an empty string
    return "my plugin name";
  }

  // This function is called before starting coverage,
  // this should return all of the objects to be covered and needs to be
  // converted into xml using the format specified in the XML schema
  // CodeCoverage.xsd included in the CA-Framework installation folder.
  // This is triggered by the Silk Central Execution Server starting a test run
  // to start code analysis.
  @Override
  public CodeAnalysisResult getBaseline() throws CodeAnalysisProfileException {
    CodeAnalysisResult result = new CodeAnalysisResult();
    try{
      String baselineData = MyCodeCoverageTool.getAllCoveredObjectsData();
      String xmlString = xmltransformXML(baselineData);
      result.Xml(xmlString);
      String myCustomLogMessage = "Code Coverage baseline successfully retrieved.";
      result.AddLogMsg(myCustomLogMessage);
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
    return result;
  }

  //This function is called by the Silk Central Code Coverage Framework after the getBaseLine() method is complete
  //this is where you should start my code coverage tool
  //collecting code coverage data

  @Override
  public boolean startCoverage() throws CodeAnalysisProfileException {
    try{
      MyCodeCoverageTool.StartCollectingCoverageData();
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
  }
  //This function is called after startCoverage,
  //This is triggered by the Silk Central Execution Server finishing a test run
  //to stop code analysis
  //Call to my code coverage tool to stop collecting data here.
  @Override
  public boolean stopCoverage() throws CodeAnalysisProfileException {
    try{
      MyCodeCoverageTool.StopCollectingCoverageData();
    }catch(Exception e){
      throw new CodeAnalysisProfileException(e);
    }
  }
  // This function is called after stopCoverage(),
  // and should return all the coverage data collected and needs to be
  // converted into xml using the format specified in the XML schema
  // CCoverage.xsd included in the CA-Framework installation folder

  @Override
  public CodeAnalysisResult getCoverage() throws CodeAnalysisProfileException {
    CodeAnalysisResult result = new CodeAnalysisResult();
    try{
      String coverageData = MyCodeCoverageTool.getActualCoverageData();
      String xmlString = xmltransformXML(coverageData);
      result.Xml(xmlString);
      String myCustomLogMessage = "Code Coverage successfully retrieved.";
      result.AddLogMsg(myCustomLogMessage);
    }catch(Exception e){
     throw new CodeAnalysisProfileException(e);
    }

    return result;
  }

  private String transformXML(String myData){
    //code to transform from my data to the Silk CentralM needed xml
    ...
    return xmlString;
  }

}
父主题： 创建您自己的代码覆盖率插件


代码覆盖率 XSD

下面是用于验证代码覆盖率工具生成的 XML 的代码覆盖率 XSD。 本文档位于以下位置：<CA Framework installation>\CodeAnalysis\CodeCoverage.xsd。

<xs:schema id="data" xmlns="" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:element name="coverage">
    <xs:complexType>
      <!--type will be method when defined as a child to class or line when defined as a child to method-->
      <xs:attribute name="type" type="xs:string" />
      <!--hits for the definition file will be 0, the update file will define the hits count-->
      <xs:attribute name="hits" type="xs:string" />
      <!--the total count will be sent with both the definition and update file, both counts will match-->
      <xs:attribute name="total" type="xs:string" />
      <!--this will be an empty string for the definition file, the line numbers will be sent in the update file delimited by a colon-->
      <xs:attribute name="lines" type="xs:string" />
    </xs:complexType>
  </xs:element>
  <xs:element name="data">
    <xs:complexType>
      <xs:choice minOccurs="0" maxOccurs="unbounded">
        <xs:element ref="coverage" />
        <xs:element name="class">
          <xs:complexType>
            <xs:sequence>
              <xs:element name="sourcefile" minOccurs="0" maxOccurs="unbounded">
                <xs:complexType>
                  <!--full path to the code file-->
                  <xs:attribute name="name" type="xs:string" />
                </xs:complexType>
              </xs:element>
              <xs:element ref="coverage" minOccurs="0" maxOccurs="unbounded" />
              <xs:element name="method" minOccurs="0" maxOccurs="unbounded">
                <xs:complexType>
                  <xs:sequence>
                    <xs:element ref="coverage" minOccurs="0" maxOccurs="unbounded" />
                  </xs:sequence>
                  <!--
                      <field_signature> ::= <field_type>
                      <field_type>      ::= <base_type>|<object_type>|<array_type>
                      <base_type>       ::= B|C|D|F|I|J|S|Z
                      <object_type>     ::= L<fullclassname>;
                      <array_type>      ::= [<field_type>

                      The meaning of the base types is as follows:
                      B byte signed byte
                      C char character
                      D double double precision IEEE float
                      F float single precision IEEE float
                      I int integer
                      J long long integer
                      L<fullclassname>; ... an object of the given class
                      S short signed short
                      Z boolean true or false
                      [<field sig> ... array

                      example signature for a java method 'doctypeDecl' with 3 string params and a return type void

                          doctypeDecl : (Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;)V

                      refer to org.apache.bcel.classfile.Utility for more information on signatureToString
                  -->
                  <xs:attribute name="name" type="xs:string" />
                  <!--method invokation count, this will be 0 for the definition file-->
                  <xs:attribute name="inv" type="xs:string" />
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="name" type="xs:string" />
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:complexType>
  </xs:element>
</xs:schema>
父主题： 创建您自己的代码覆盖率插件


示例 XML 数据

代码覆盖率 API 需要以下格式的 XML。

您也可以使用提供的示例 XSD 文档验证 XML。

<!--  Generated by 'MyPluginTool'at '2010-11-05T16:11:09'
 -->
<data>
  <class name="ProjectA.ClassA1">
    <sourcefile name="C:\Users\TestApp\ProjectA\ClassA1.cs"/>
    <coverage hits="8" total="8" type="method"/>
    <coverage hits="30" total="30" type="line"/>
    <method inv="2" name="ClassA1  : ()V">
      <coverage hits="3" lines="11:2,12:2,14:2" total="3" type="line"/>
    </method>
    <method inv="2" name="BoolByteMethod  : (LSystem/Boolean;LSystem/SByte;)V">
      <coverage hits="3" lines="17:2,18:2,19:2" total="3" type="line"/>
    </method>
    <method inv="1" name="CharStringMethod  : (LSystem/Char;LSystem/String;)V">
      <coverage hits="3" lines="38:1,39:1,40:1" total="3" type="line"/>
    </method>
    <method inv="2" name="DateMethod  : (LSystem/DateTime;)V">
      <coverage hits="3" lines="22:2,23:2,24:2" total="3" type="line"/>
    </method>
    <method inv="1" name="DecimalMethod  : (LSystem/Decimal;LSystem/Single;LSystem/Double;)V">
      <coverage hits="4" lines="27:1,28:1,29:1,30:1" total="4" type="line"/>
    </method>
    <method inv="1" name="IntMethod  : (LSystem/Int32;LSystem/Int64;LSystem/Int16;)V">
      <coverage hits="3" lines="33:1,34:1,35:1" total="3" type="line"/>
    </method>
    <method inv="1" name="passMeArrays  : (LSystem/Int32[];LSystem/Decimal[];)V">
      <coverage hits="6" lines="51:1,52:1,53:1,55:1,56:1,58:1" total="6" type="line"/>
    </method>
    <method inv="1" name="passMeObjects  : (LSystem/Object;LSystem/Object/ClassA1;)V">
      <coverage hits="5" lines="43:1,44:1,45:1,46:1,48:1" total="5" type="line"/>
    </method>
  </class>
  <class name="TestApp.Form1">
    <sourcefile name="C:\Users\TestApp\Form1.Designer.cs"/>
    <coverage hits="2" total="10" type="method"/>
    <coverage hits="24" total="110" type="line"/>
    <method inv="1" name="btnClassA_Click  : (LSystem/Object;LSystem/Object/EventArgs;)V">
      <coverage hits="3" lines="25:1,26:1,27:1" total="3" type="line"/>
    </method>
    <method inv="1" name="CallAllClassAMethods  : ()V">
      <coverage hits="21" lines="35:1,36:1,37:1,38:1,39:1,40:1,41:1,42:1,43:1,44:1,45:1,46:1,48:1,49:1,50:1,51:1,52:1,53:1,54:1,55:1,56:1" total="21" type="line"/>
    </method>
  </class>
</data>
父主题： 创建您自己的代码覆盖率插件


在 Linux AUT 环境中安装代码分析框架

如果您创建的代码覆盖率插件将与在 Linux 操作系统下测试的 .NET 应用程序进行交互，则应执行以下步骤。

  1. 用于 Linux 的代码分析框架可从帮助 > 工具 > Linux 代码分析框架获取。下载并将其复制到 Linux 机器上的根文件夹或任何其他文件夹。
  2. 确保已在测试应用程序的机器上安装 Java Runtime Environment (JRE) 8。
  3. 解压 CA-Framework.tar.gz。
  4. 将代码分析插件置于 <install dir>/18.5Silk Central/Plugins 文件夹中。
  5. 将目录更改为 <install dir>/18.5Silk Central/Code Analysis。
  6. 查找将运行 CA-Framework 进程的 startCodeAnalysisFramework.sh 外壳脚本。
  7. 运行以下命令以将文件转换为 Unix 格式：dos2unix startCodeAnalysisFramework.sh。
  8. 运行以下命令以设置执行外壳脚本所需的权限：chmod 775 startCodeAnalysisFramework.sh。
  9. 运行以下外壳脚本以运行 CAFramework 进程：./startCodeAnalysisFramework.sh。
代码分析框架已准备就绪，可从 Silk Central 中使用它。
父主题： 代码覆盖率集成


源代码管理集成

源代码管理配置文件可使 Silk Central 与外部源代码管理系统集成。

部署后，自定义源代码管理插件可在 Silk Central 中配置，允许您定义 Silk Central 执行服务器应检索程序源代码以执行测试的位置。

查看 C:\Program Files (x86)\Silk\Silk Central 18.5\instance_<实例编号>_<实例名称>\Plugins\subversion.zip 中的数据包 com.segue.scc.vcs.subversion 的来源，了解这些元素如何相结合。

  • 源代码管理集成接口
    列出了用于源代码管理集成的接口。
  • 源代码管理集成约定
    说明每次实施必须提供默认构造函数，并且每个接口方法指定 SourceControlException。
父主题： API 帮助
相关概念
创建插件
问题跟踪集成
需求管理集成
第三方测试类型集成
代码覆盖率集成


源代码管理集成接口

Silk Central 区分 SourceControlProfile 和 VersionControlProfile。 区别在于 SourceControlProfile 没有版本管理，而 VersionControlProfile 有版本管理。

以下是用于源代码管理集成的 Silk Central 接口：
  • SourceControlProfile
  • VersionControlProfile
  • SourceControlProfileData
  • SourceControlException
  • SourceControlInfo

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

父主题： 源代码管理集成


源代码管理集成约定

每次实施必须提供默认构造函数，或者将 SourceControlProfileData 作为参数的构造函数。 如果未提供此构造函数，则必须提供 SourceControlProfileData 的 bean setter。

由于每个接口方法指定了要抛出的 SourceControlException，因此不允许以接口使用的任何方法抛出 RuntimeException。

父主题： 源代码管理集成


问题跟踪集成

为 Silk Central 创建可启用第三方（外部）问题跟踪系统 (ITS) 集成的插件需要使用本章中讨论的界面。

通过定义问题跟踪配置文件，您可以将测试区域内的测试链接到第三方问题跟踪系统中的问题。链接的问题状态将定期从第三方问题跟踪系统进行更新。

查看 C:\Program Files (x86)\Silk\Silk Central18.5\instance_<实例编号>_<实例名称>\Plugins\Bugzilla3.zip 中的数据包 com.segue.scc.issuetracking.bugzilla3 的来源，了解这些元素如何相结合。

  • Java 接口
    介绍如何基于 Java API 实施问题跟踪集成。
父主题： API 帮助
相关概念
创建插件
源代码管理集成
需求管理集成
第三方测试类型集成
代码覆盖率集成
问题跟踪配置文件集成


Java 接口

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

构建环境

将库 scc.jar 添加到 classpath，因为它包含必须扩展的接口。可以在 Silk Central 安装目录的 lib 目录中找到 JAR 文件。

您必须扩展两个接口/类：
  • com.segue.scc.published.api.issuetracking82.IssueTrackingProfile
  • com.segue.scc.published.api.issuetracking.Issue

类/接口

  • IssueTrackingProfile
  • IssueTrackingData
  • Issue
  • IssueTrackingField
  • IssueTrackingProfileException
父主题： 问题跟踪集成


需求管理集成

Silk Central 可与第三方需求管理系统 (RMS) 工具集成来链接和同步需求。

本部分介绍可使您实施第三方插件的 Java 应用程序编程接口，以便将 Silk Central 中的需求与第三方需求管理系统的需求同步。 本部分介绍识别需求插件及其部署的接口。

在标准 Silk Central 的插件概念之后将提供 JAR 或 ZIP 文件，此文件会自动部署到所有前端服务器，以便访问第三方工具来进行配置和同步。 此插件实施指定接口，允许 Silk Central 将其识别为需求插件，并提供所需的登录属性来登录第三方工具。

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

有关其他插件的信息，请联系客户支持。

  • Java 接口
    列出需求插件 API 的接口。
父主题： API 帮助
相关概念
创建插件
源代码管理集成
问题跟踪集成
第三方测试类型集成
代码覆盖率集成
部署


Java 接口

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

最初に取り?う基本インタ?フェイスは RMPluginProfile（com.segue.tm.published.api.requirements.javaplugin）です。RMPluginProfile で、このプラグインが要件プラグインとして指定されています。

需求 Java 插件 API 包含以下附加接口：
  • RMAction
  • RMAttachment
  • RMDataProvider
  • 可选：RMIconProvider
  • RMNode
  • RMNodeType
  • RMPluginProfile
  • RMProject
  • RMTest
  • RMTestParameter
  • 可选：RMTestProvider
  • RMTestStep
父主题： 需求管理集成
相关概念
部署


第三方测试类型集成

Silk Central 可使您为可用测试类型（包括 Silk Performer、Silk Test Classic、手动测试、NUnit、JUnit 和 Windows 脚本宿主 (WSH)）标准集之外的测试类型创建自定义插件。 创建新测试类型插件后，您的自定义测试类型将在新建测试对话框的类型列表框中可用，以及可用于在 Silk Central 中创建新测试的标准测试类型。

插件指定配置测试和实施测试执行所需的属性。 属性的元信息通过配置 XML 文件定义。

插件方法的目的是根据常用测试框架（例如 JUnit、NUnit 或脚本语言 (WSH)）支持测试，以便根据特定测试环境轻松自定义 Silk Central。 定义完善的 Silk Central 公共 API 使您可实施符合自动测试需求的专用解决方案。 Silk Central 向可从 Java 实施或通过命令行调用的任何第三方工具开放和扩展。

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

Javadoc 中介绍的类别包括在文件 tm-testlaunchapi.jar 中。

有关其他插件的信息，请联系客户支持。

本部分包括实施 Process Executor 测试类型的代码示例。 Process Executor 可用于启动任何可执行文件，并扩展发布的进程测试启动程序类。 有关其他信息，请从帮助 > 工具中下载测试启动插件示例并阅读 Readme.txt 文件。

  • 插件实施
    介绍 API 及其回调接口的原则。
  • API 结构
    详述第三方测试类型集成的 API 结构。
  • 示例代码
    包括实施 Process Executor 测试类型的代码示例，可用于启动任何可执行文件和扩展已发布的 ExtProcessTestLaunchBean 类。
  • 配置 XML 文件
    说明配置 XML 文件包含关于第三方测试类型插件的元信息。
  • 自定义图标
    显示如何为自定义测试类型设计自定义图标，以使测试类型可识别。
  • 部署
    介绍如何部署第三方测试类型插件。
  • 为视频捕获表示开始和完成
    介绍如何定义要捕获第三方测试的特定测试用例的 Silk Central。
父主题： API 帮助
相关概念
创建插件
源代码管理集成
问题跟踪集成
需求管理集成
代码覆盖率集成


插件实施

API 的原则基于著名的 Java Beans 概念。 这可让开发人员轻松实施测试启动插件。 为避免将文本信息放入 Java 代码中，有关属性的元信息在 XML 文件中进行了定义。

插件实施在 zip 存档中打包，并实施回调接口来实现集成。 其他接口依次由插件框架提供，并允许实施访问信息或返回结果。

  • 打包
    说明插件的打包方式。
  • 将参数传递至插件
    介绍插件可访问的参数类型以及如何将参数传递至插件。
父主题： 第三方测试类型集成


打包

该插件打包在 zip 存档中，它包含 Java 代码库和 XML 配置文件。 存档还包含某些测试启动插件实施。 代码库可能包含在 Java 存档文件 (.jar) 中，或直接位于表示 Java 软件包结构的文件夹内的 .class 文件中。

TestLaunchBean 插件类遵循 Bean 标准并且实施了 TestLaunchBean 接口。 .zip 存档中的 XML 配置文件具有与此类相同的名称。 它允许您在单个存档中打包多个插件和 XML 文件。

父主题： 插件实施


将参数传递至插件

如果插件基于 ExtProcessTestLaunchBean 类，则每个参数在由插件启动的进程中都将自动设置为环境变量。 如果参数名称与系统变量名称一致，也会出现这种情况。除非参数值为空字符串，否则系统变量的值将由参数值替换。

插件接口提供对在 Silk Central 测试区域中定义的所有自定义参数的完全访问权限。 第三方测试类型仅支持自定义参数。 插件不能指定预定义参数；插件实施确定是否以及如何为特定测试定义参数。

在 TestLaunchPluginContext 接口中使用 getParameterValueStrings() 方法获取容器，它具有从参数值（密钥）到其表示为 String 的值的映射。

对于 JUnit 测试类型，任何 JUnit 测试类都可以访问作为 Java 系统属性的基础测试的自定义参数；启动器会使用 "-D" VM 参数将这些参数传递至执行虚拟机。

父主题： 插件实施


API 结构

该图详述第三方测试类型集成的 API 结构。

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

可用的接口

  • TestLaunchBean
  • ExtProcessTestLaunchBean
  • TestLaunchPluginContext
  • TestSourceContext
  • TestLaunchResultDrain
父主题： 第三方测试类型集成


示例代码

此示例代码块实施 Process Executor 测试类型，可用于启动任何可执行文件和扩展已发布的 ExtProcessTestLaunchBean 类。

package com.borland.sctm.testlauncher;

import java.io.File;
import java.io.IOException;
import java.util.ArrayList;

import com.segue.tm.published.api.testlaunch.ExtProcessTestLaunchBean;
import com.segue.tm.published.api.testlaunch.TestLaunchResultDrain;

/**
 * Implements an Silk Central test type that can be used to launch
 * any executables, for example from a command line.
 * Extends Silk Central published process test launcher class,
 * see Silk Central API Specification (in Help -> Documentation) for
 * further details.
 */
public class ProcessExecutor extends ExtProcessTestLaunchBean {

  // test properties that will be set by Silk Central using appropriate setter
  // methods (bean convention),
  // property names must conform to property tags used in the XML file

  /**
   * Represents property <command> defined in ProcessExecutor.xml.
   */
  private String command;

  /**
   * Represents property <arguments> defined in ProcessExecutor.xml.
   */
  private String arguments;

  /**
   * Represents property <workingfolder> defined in ProcessExecutor.xml.
   */
  private String workingfolder;

  /**
   * Java Bean compliant setter used by Silk Central to forward the command to be
   * executed.
   * Conforms to property <command> defined in ProcessExecutor.xml.
   */
  public void setCommand(String command) {
    this.command = command;
  }

  /**
   * Java Bean compliant setter used by Silk Central to forward the arguments
   * that will be passed to the command.
   * Conforms to property <arguments> defined in ProcessExecutor.xml.
   */
  public void setArguments(String arguments) {
    this.arguments = arguments;
  }

  /**
   * Java Bean compliant setter used by Silk Central to forward the working
   * folder where the command will be executed.
   * Conforms to property <workingfolder> defined in
   * ProcessExecutor.xml.
   */
  public void setWorkingfolder(String workingfolder) {
    this.workingfolder = workingfolder;
  }

  /**
   * Main plug-in method. See Silk Central API Specification
   * (in Help &gt; Documentation) for further details.
   */
  @Override
  public boolean execute(long time, TestLaunchResultDrain context)
    throws InterruptedException {
    try {
      String[] cmd = getCommandArgs(context);
      File workingDir = getWorkingFolderFile(context);
      String[] envVariables = getEnviromentVariables(context);

      int processExitCode = runExternalProcess(cmd, envVariables, workingDir,
        context.getLog());

      boolean outputXmlFound = handleOutputXmlIfExists(context);

      if (! outputXmlFound && processExitCode != 0) {
        // if no output.xml file was produced, the exit code indicates
        // success or failure
        context.publishMessage(TestLaunchResultDrain.SEVERITY_ERROR,
          "Process exited with return code "
          + String.valueOf(processExitCode));
        context.updateErrors(1, 0);
        // set error, test will get status 'failed'
      }
    } catch (IOException e) {
      // prints exception message to Messages tab in Test Run
      // Results
      context.publishMessage(TestLaunchResultDrain.SEVERITY_FATAL,
        e.getMessage());
      // prints exception stack trace to 'log.txt' that can be viewed in Files
      // tab
      e.printStackTrace(context.getLog());
      context.publishErrors(1, 0);
      return false; // set test status to 'not executed'
    }
    return true;
  }

  /**
   * Initializes environment variables to be set additionally to those
   * inherited from the system environment of the Execution Server.
   * @param context the test execution context
   * @return String array containing the set environment variables
   * @throws IOException
   */
  private String[] getEnviromentVariables(TestLaunchResultDrain context)
    throws IOException {
    String[] envVariables = {
      "SCTM_EXEC_RESULTSFOLDER="
      + context.getTempResultsDir().getAbsolutePath(),
      "SCTM_EXEC_SOURCESFOLDER="
      + sourceAccess().getTestContainerRootDir().getAbsolutePath(),
    };
    return envVariables;
  }

  /**
   * Let Silk Central parse the standard report xml file (output.xml) if exists.
   * See also Silk Central Web Help - Creating a Test Package. A XSD file
   * can be found in Silk Central Help -&gt; Tools -&gt; Test Package XML Schema
   * Definition File
   * @param context the test execution context
   * @return true if output.xml exists
   * @throws IOException
   */
  private boolean handleOutputXmlIfExists(TestLaunchResultDrain context)
    throws IOException {
    String outputFileName = context.getTempResultsDir().getAbsolutePath()
    + File.separator + TestLaunchResultDrain.OUTPUT_XML_RESULT_FILE;
    File outputfile = new File(outputFileName);
    boolean outputXmlExists = outputfile.exists();
    if (outputXmlExists) {
      context.parseStdResultFile(outputfile);
      context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
        String.format("output.xml parsed from '%s'", outputFileName));
    }
    return outputXmlExists;
  }

  /**
   * Retrieves the working folder on the Execution Server. If not configured
   * the results directory is used as working folder.
   * @param context the test execution context
   * @return the working folder file object
   * @throws IOException
   */
  private File getWorkingFolderFile(TestLaunchResultDrain context)
    throws IOException {
    final File workingFolderFile;
    if (workingfolder != null) {
      workingFolderFile = new File(workingfolder);
    } else {
      workingFolderFile = context.getTempResultsDir();
    }
    context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
      String.format("process is exectued in working folder '%s'",
        workingFolderFile.getAbsolutePath()));
    return workingFolderFile;
  }

  /**
   * Retrieves the command line arguments specified.
   * @param context the test execution context
   * @return an array of command line arguments
   */
  private String[] getCommandArgs(TestLaunchResultDrain context) {
    final ArrayList<String> cmdList = new ArrayList<String>();
    final StringBuilder cmd = new StringBuilder();
    cmdList.add(command);
    cmd.append(command);
    if (arguments != null) {
      String[] lines = arguments.split("[\\r\\n]+");
      for (String line : lines) {
        cmdList.add(line);
        cmd.append(" ").append(line);
      }
    }
    context.publishMessage(TestLaunchResultDrain.SEVERITY_INFO,
      String.format("executed command '%s'", cmd.toString()));
    context.getLog().printf("start '%s'%n", cmd.toString());
    return (String[]) cmdList.toArray(new String[cmdList.size()]);
  }
}
父主题： 第三方测试类型集成


配置 XML 文件

配置 XML 文件包含关于第三方测试类型插件的元信息。

  • 插件元信息
    插件元信息通常提供有关插件和测试类型的信息。
  • 一般属性元信息
    介绍与每个可编辑属性相同的一般信息。
  • 字符串属性元信息
    列出了插件中提供的字符串属性元信息的类型。
  • 文件属性元信息
    列出插件中可用的文件属性元信息的类型。
父主题： 第三方测试类型集成


插件元信息

插件元信息通常提供有关插件和测试类型的信息。 以下列出了可用的信息类型。

类型 | 说明
id | 所有已安装插件中唯一识别此类型的内部字符串。
label | 此类型的选项列表和编辑对话框中显示的 GUI 文本。
description | 介绍此测试类型的其他文本信息。
version | 区分一种类型的不同版本。
父主题： 配置 XML 文件


一般属性元信息

对于可编辑属性，除特定类型信息外，每个属性类型还存在相同的一般信息。 属性名称必须与通过 get<<propertyname>> 方法在代码中定义的名称匹配，第一个字符应为小写字母。

类型 | 说明
label | GUI 中显示的文本。
description | 说明属性的其他文本信息。
isOptional | 如果值为真，表明无需用户输入。
default | 创建新测试时属性的默认值。 此值必须与属性类型匹配。
父主题： 配置 XML 文件


字符串属性元信息

以下是插件中提供的字符串属性元信息的类型。

类型 | 说明
maxLength | 表示用户可以输入的最大长度。
editMultiLine | 表示编辑字段是否应有多行。
isPassword | true 的值将用户输入隐藏为 ***。
父主题： 配置 XML 文件


文件属性元信息

此处提供插件中可用的文件属性元信息的类型。

对于指定的文件值，执行服务器上具有绝对路径的非版本控制文件应与版本控制文件区分开来。 源代码管理文件始终相对于测试容器的根目录，通常用于指定要执行的测试源代码。 执行服务器上需存在绝对路径，通常指定工具或资源，用于调用执行服务器上的测试。

类型 | 说明
openBrowser | 如果值为真，则表明应打开浏览器从测试容器中的文件里选择文件。
isSourceControl | 如果值为真，则表明文件源于源代码管理系统。
fileNameSpec | 指示标准 Windows 文件浏览器对话框中已知的允许文件名的限制。
父主题： 配置 XML 文件


自定义图标

您可为测试类型设计自定义图标，以使测试类型可识别。 要为已在配置 XML 文件中定义标识符 PluginId 的插件定义这些图标，您必须将以下四种图标放入插件 ZIP 容器的根目录中。

名称 | 说明
<PluginId>.gif | 测试类型的默认图标。 例如 ProcessExecutor.gif。
<PluginId>_package.gif | 如果您将具有指定测试类型的测试转换为测试包，该图标将用于测试包根目录和套件节点。 例如 ProcessExecutor_package.gif。
<PluginId>_linked.gif | 如果测试的父文件夹是已链接的测试容器，则使用该图标。 例如 ProcessExecutor_linked.gif。
<PluginId>_incomplete.gif | 如果未定义测试的父测试容器的产品或源代码管理配置文件，则使用该图标。
为测试类型设计新图标时，请应用以下规则：
  • 仅使用 GIF 类型的图标。 文件扩展名区分大小写，并且必须始终为小写字母 (.gif)。
  • 从 <Silk Central deploy folder>\wwwroot\silkroot\img\PluginIcons 删除旧图标或无效图标，否则将不会使用插件 ZIP 容器根目录中的新图标更新这些图标。
  • 图标的大小为 16x16 像素。
  • 图标允许的最大颜色数量为 256。
  • 图标包括 1 位透明度。
父主题： 第三方测试类型集成


部署

插件 ZIP 存档必须位于 Silk Central 安装目录的 Plugins 子目录中。 要集成此目录中的插件，请通过 Silk Central Service Manager 重新启动应用程序服务器和前端服务器。
注： 不支持热部署。

当每次修改存档时，必须重新启动这两个服务器。 该存档将自动上载到执行服务器。

注： 请勿在基于已创建的插件进行测试后删除插件。 基于不再存在的插件存档的测试将导致在更改或执行时出现未知错误。
父主题： 第三方测试类型集成


为视频捕获表示开始和完成

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

当为 Silk Central 创建新的第三方测试插件时，如果第三方测试类型支持在单个测试执行中处理多个测试用例，且您要将捕获的视频关联到特定测试用例，则可按两种方式进行操作。

插件中运行的第三方测试

对于这些测试，建议使用 TestLaunchResultDrain 类的 indicateTestStart 和 indicateTestStop 方法。

外部进程中运行的第三方测试

对于这些测试，可使用基于 TCP/IP 的服务向 Silk Central 执行服务器的端口发送 START 和 FINISH 消息。要使用的端口号可通过插件中的 ExecutionContextInfo.ExecProperty#PORT_TESTCASE_START_FINISH 查询。如果插件扩展了 ExtProcessTestLaunchBean，则端口还能被用作称为 #sctm_portTestCaseStartFinish 的环境变量。这些消息类型将通知执行服务器，测试中的测试用例已开始或分别完成。消息必须以 Unicode (UTF8) 或 ASCII 格式编码。
消息类型
格式
开始
START <Test Name>, <Test ID> <LF>，其中，LF 的 ASCII 代码为 10。
完成
FINISH <Test Name>, <Test ID>, <Passed> LF，其中，LF 的 ASCII 代码为 10。Passed 可以是 True，也可以是 False。如果视频捕获设置为在出错时执行，当 Passed 设置为 False 时，视频将仅保存到结果。

如果请求被识别，执行服务器将会以确定作出响应，否则，执行服务器将会以错误消息作出响应。请始终等待执行服务器响应，然后再执行下一个测试用例，因为如果不按此操作，录制的视频可能与实际测试用例不匹配。

如果执行测试的外部进程基于 Java 环境，建议使用包括在文件 tm-testlaunchapi.jar 中的 TestCaseStartFinishSocketClient 类的 indicateTestStart 和 indicateTestStop 方法。

父主题： 第三方测试类型集成
相关概念
视频捕获


云集成

Silk Central 使您可以配置云提供程序配置文件，以便与公共云或私有云服务提供程序集成。云配置文件基于插件概念，让您能为特定云提供程序编写自己的插件。云提供程序插件将在每次自动测试运行之前部署虚拟环境。
注： 云 API 在即将推出的 Silk Central 版本中可能会有所更改。如果您在使用此 API，升级到将来版本的 Silk Central 后可能需要更新实施。

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

首先应使用的基本接口是 CloudProviderProfile (com.segue.scc.published.api.cloud)。CloudProviderProfile指定外部云系统的访问和控制。云提供程序插件实施需要执行以下步骤：
  • 公开云提供程序配置文件中必须配置哪些属性，以远程访问此类提供程序
  • 验证配置文件属性，检查与云提供程序的连接
  • 从云提供程序检索可用映像模板列表
  • 部署基于选定映像模板的虚拟环境，公开可从外部访问的主机地址
  • 检查虚拟环境是否已配置和运行
  • 删除特定虚拟环境
父主题： API 帮助
相关概念
云集成
创建插件
相关任务
配置云托管的执行服务器


Silk Central Web 服务

Web 服务不需要安装，默认情况下，已在每个前端服务器上启用。例如，如果 http://www.yourFrontend.com/login 是您用于访问 Silk Central 的 URL，则 http://www.yourFrontend.com/Services1.0/jaxws/system（原有服务位于 http://www.yourFrontend.com/Services1.0/services）和 http://www.yourFrontend.com/AlmServices1.0/services 是您用于访问可用 Web 服务的基本 URL。

使用浏览器访问基本 URL 时，将会向您提供所有可用 Web 服务的简单 HTML 列表。此列表由 JAX-WS 提供。Silk Central 使用的 SOAP 堆栈是 https://jax-ws.java.net/。

基本 URL 提供到 WSDL（Web 服务定义语言）标准化 XML 文件的链接，此处每个文件均介绍单个 Web 服务的接口。不可人工读取这些文件。因此，启用 SOAP 的客户端（例如 Silk Performer Java Explorer）将读取 WSDL 文件，从而检索调用相应 Web 服务的方法所需的信息。

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

注： 于 2008 版之前在 Silk Central 中实施的原始 Web 服务仍可在 http://hostname:port/services 获取。

  • Web 服务快速启动
    包括与 Web 服务集成有关的先决条件、用例示例和其他主题。
  • 会话处理
    说明通过 Web 服务的身份验证如何返回会话标识符并引用会话。
  • 可用 Web 服务
    列出可用 Web 服务。
  • 服务交换
    本部分介绍基于 HTTP 的接口，用于处理 Services Exchange 中的报告、附件、测试计划、执行和库。
  • Web Service Demo Client
    介绍 Web Service Demo Client，这是一种演示如何使用 Silk Central Web 服务的工具。
父主题： API 帮助


Web 服务快速启动

本部分包括与 Web 服务集成有关的先决条件、用例示例和其他主题。

  • 先决条件
    尝试开发 Web 服务客户端前需要了解的详细信息。
  • Web 服务使用入门
    本任务介绍如何下载 Web 服务库、解压 Jar 和查找自动生成的 Java 类 YourWebService。
  • Web 服务客户端概述
    提供有关如何构建 Web 服务客户端（包括 SOAP 信封、WSDL 和 WSDL2Java 工具）的概述。
  • 示例使用案例：添加需求
    作为本节前面详述步骤的后续步骤，本主题将完成将需求添加到 Silk Central 的使用案例。
父主题： Silk Central Web 服务


先决条件

尝试开发 Web 服务客户端前必须考虑以下先决条件：

  • 面向对象编程 (OOP) 的基础知识。 拥有 Java 经验会有帮助，因为示例将以此语言提供。 没有 Java 经验但有 C++、C#、Python 或 Perl 经验的开发人员仍可以轻松按照示例操作。 拥有操作 HashMap 和 List 集合经验尤佳。
  • 简述 JUnit 测试。 不要求 Java 测试框架，但如果了解会有帮助。
  • 介绍 Web 服务技术。 本帮助不提供 Web 服务或 SOAP 的入门课程。 您至少应拥有编码和成功运行“Hello World!” Web 服务客户端的经验。
  • Silk Central Web 服务结构的知识。
父主题： Web 服务快速启动
相关概念
Silk Central Web 服务


Web 服务使用入门

请参阅 Silk Central 发行说明，确保在 PATH 中安装适合的 SDK 版本。

它有助于在 classpath 中保留 JUnit Jar。您可从 http://www.junit.org/index.htm 下载 JUnit.jar 文件。

  1. 确保 Java SDK 的 bin 目录位于您的 PATH 中。
  2. 运行以下命令，指向所需 Web 服务的 WSDL。
    wsimport -s <所生成文件的保存路径> -Xnocompile
-p <要用于您的客户端 yourWebService 的程序包结构>
http://<您的服务 URL>/yourWebService?wsdl
  3. 查找自动生成的 Java 类 YourWebService。 此类已准备就绪，可使用 YourWebService 提供的所有方法。
父主题： Web 服务快速启动


Web 服务客户端概述

Web 服务通常通过 HTTP 协议使用 SOAP。在此情况下，将发送 SOAP 信封。集合和其他复杂对象在 SOAP 信封中捆绑时，ASCII 数据结构会变得难以读取和编辑。初级开发人员不应尝试直接操作 SOAP 信封来构建 Web 服务客户端。经验丰富的开发人员通常不会在 SOAP 信封级别构建 Web 服务客户端。这样操作很枯燥，且容易出错。因此，所有主要的编程语言均提供 Web 服务开发包。在 Silk Central 中，Java API for XML Web Services (JAX-WS) 用于构建使用 SOAP 消息进行通信的 Web 服务和客户端。

无论是哪一种实施语言（Java、C++、C#、Perl 或 Python），构建 Web 服务客户端通常遵循相同的模式：

  1. 指定 Web 服务 WSDL 的开发工具包工具。
  2. 返回客户端存根。
  3. 编辑步骤 2 中生成的客户端存根以获取成熟的客户端。
JAX-WS 遵循这种模式。此处，wsimport 工具（与 JDK 捆绑在一起）用于从 WSDL 构建客户端存根。可以在 JDK 工具和实用程序文档中找到有关如何使用 wsimport 的详细信息。 下文简述了以上总结中使用的命令行开关：
  • -s：客户端存根的输出目录
  • -p：目标包。部署至此包结构

示例：wsimport -s <生成的存根位置> -p <目标包> <WSDL>

wsimport 工具生成多种类，以支持 Web 服务的客户端。如果 YourWebService是服务的名称，则可以预期以下类别输出：

  • YourWebService：表示 YourWebService 的接口。
  • YourWebServiceService：生成的类，表示 YourWebService 定位器，例如，用于获取可用端口（服务端点接口）列表
  • WSFaultException：从 wsdl:fault 映射的异常类
  • WsFaultBean：从响应 wsdl:message 派生的异步响应 Bean
  • Serializeable Objects：与对象 YourWebService 使用相应的客户端对象。

要生成 JAX-WS 客户端以访问 Silk Central Web 服务，请创建一个名为 YourWebServiceClient 的新 Java 类。必须通过一个端口绑定到 Web 服务；端口是本地对象，用作远程服务代理。请注意，端口是通过在上一步中执行 wsimport 工具创建的。要检索此代理，请对服务调用 getRequirementsServicePort 方法：

// Bind to the Requirements service
  RequirementsServiceService port = new RequirementsServiceService
    (new URL("http", mHost, mPort, "/Services1.0/jaxws/requirements?wsdl"));
  RequirementsService requirementsService = port.getRequirementsServicePort();

之后，您可传递用户名和密码获取会话 ID，以调用服务的 logonUser 方法。

// Login to Silk Central and get session ID
  String sessionId = requirementsService.logonUser(mUsername, mPassword);
父主题： Web 服务快速启动


示例使用案例：添加需求

作为本节前面详述步骤的后续步骤，本主题将完成将需求添加到 Silk Central 的使用案例。

在继续操作之前，必须满足以下前提条件：

  • 您已完成针对 requirements Web 服务详述的步骤。
  • 已创建采用绑定和登录方法的工作 POJO 或 JUnit 类。
  • 您已经熟悉了其他 Silk Central API 帮助主题。
  1. 使用包含用户凭据的登录方法来绑定到服务。
  2. 保存从之前步骤中获取的会话 ID。
  3. 构建包含所需数据的需求对象。
  4. 使用已生成的会话 ID、项目 ID 和需求对象来调用 updateRequirement 方法。
  5. 保存由 updateRequirement 方法返回的需求 ID。
  6. 创建需求属性的 PropertyValue 数组。
  7. 使用之前创建的数组调用 updateProperties 方法。
wsimport 将创建上述 Web 服务对象：
  • Requirement
  • PropertyValue

您现在可以通过上述对象的 OOP 方法来使用 Web 服务。无需使用 SOAP 信封结构。以下是完成此使用案例所需代码的摘要。

/** project ID of Silk Central project */
private static final int PROJECT_ID = 0;

/** propertyID for requirement risk */
public static final String PROPERTY_RISK = "Risk";

/** propertyID for requirement reviewed */
public static final String PROPERTY_REVIEWED = "Reviewed";

/** propertyID for requirement priority */
public static final String PROPERTY_PRIORITY = "Priority";

/** propertyID for requirement obsolete property */
public static final String PROPERTY_OBSOLETE = "Obsolete";

// Get the Requirements service
RequirementsService service = getRequirementsService();

// Login to Silk Central
String sessionId = login(service);

// Construct Top Level Requirement
Requirement topLevelRequirement = new Requirement();
topLevelRequirement.setName("tmReqMgt TopLevelReq");
topLevelRequirement.setDescription("tmReqMgt TopLevel Desc");

PropertyValue propRisk = new PropertyValue();
propRisk.setPropertyId(PROPERTY_RISK);
propRisk.setValue("2");
PropertyValue propPriority = new PropertyValue();
propPriority.setPropertyId(PROPERTY_PRIORITY);
propPriority.setValue("3");
PropertyValue[] properties = new PropertyValue[] {propRisk, propPriority};

/*
* First add requirement skeleton, get its ID
* service is a binding stub, see above getRequirementsService() snippet
* sessionId is the stored session ID, see above login() snippet
*/
int requirementID = service.updateRequirement(sessionId, PROJECT_ID, topLevelRequirement, -1);

// Now loop through and set properties
for (PropertyValue propValue : properties) {
propValue.setRequirementId(requirementID);
service.updateProperty(sessionId, requirementID, propValue);
}

// Add Child Requirement
Requirement childRequirement = new Requirement();
childRequirement.setName("tmReqMgt ChildReq");
childRequirement.setDescription("tmReqMgt ChildLevel Desc");
childRequirement.setParentId(requirementID);
propRisk = new PropertyValue();
propRisk.setPropertyId(PROPERTY_RISK);
propRisk.setValue("1");
propPriority = new PropertyValue();
propPriority.setPropertyId(PROPERTY_PRIORITY);
propPriority.setValue("1");
properties = new PropertyValue[] {propRisk, propPriority};

int childReqID = service.updateRequirement(sessionId, PROJECT_ID, childRequirement, -1);

// Now loop through and set properties
for (PropertyValue propValue : properties) {
propValue.setRequirementId(requirementID);
service.updateProperty(sessionId, childReqID, propValue);
}

// Print Results
System.out.println("Login Successful with mSessionID: " + sessionId);
System.out.println("Top Level Requirement ID: " + requirementID);
System.out.println("Child Requirement ID: " + childReqID);
注： 此示例代码也适用于 Web Service Demo Client 的类 com.microfocus.silkcentral.democlient.samples.AddingRequirement。
父主题： Web 服务快速启动


会话处理

Silk Central 数据受到针对非授权访问的保护。在授权数据访问权限之前，必须先提供登录凭据。这适用于使用 HTML 前端的情况，也适用于通过 SOAP 调用与 Silk Central 的通信。

查询数据或应用 Silk Central 配置更改的第一步是身份验证。身份验证成功时，将创建用户会话，以允许在用户登录的上下文中执行后续操作。

通过 Web 浏览器访问 Silk Central 时，会话信息对用户不可见。浏览器使用 cookie 处理会话信息。与通过 HTML 使用 Silk Central 相比，SOAP 调用必须手动处理会话信息。

通过 Web 服务的身份验证可通过所需 Web 服务的 logonUser SOAP 调用完成。方法调用返回的会话标识符引用服务器上创建的会话，同时用作会话上下文中访问 Silk Central 的密匙。

每个需要会话来执行的后续 SOAP 调用将返回的标识符作为其中一个参数，检查其有效性，并在相应会话的上下文中执行。

以下 Java 代码示例通过 Web 服务和使用会话标识符演示了对 Silk Central 的简单访问：
long sessionID = systemService.logonUser("admin", "admin");
Project[] projects = sccentities.getProjects(sessionID);

通过 Web 服务创建的 Silk Central 会话无法显式结束。相反，会话在一段时间不使用时自动结束。服务器上的会话一旦超时，尝试使用会话的后续 SOAP 调用将抛出异常。

通过 Silk Central 的帮助 > 工具 > Web 服务演示客户端可以找到可供下载的演示客户端。此演示项目使用 Silk Centraltests Web 服务，以帮助您熟悉 Web 服务接口。

父主题： Silk Central Web 服务


可用 Web 服务

下表列出了可用 Silk Central Web 服务。您还可以通过基于 HTTP 的接口访问 Silk Central。如需了解其他信息，请参见服务交换。

注： WSDL URL 还列出了不是用于创建 Web 服务客户端的系统内部 Web 服务。本文档只介绍已发布的 Web 服务。

有关可用 Java 类和方法的完整详细信息，请参阅 Javadoc。如果链接无效，请单击 Silk Central 菜单中的帮助 > 文档 > Silk Central API 规范以打开 Javadoc。

注： 使用 Web 服务时，系统返回的所有时间均为协调世界时 (UTC)。在您使用的 Web 服务的所有时间引用中也使用 UTC。
WS 名称（接口） | WSDL URL | 说明
system (SystemService) | /Services1.0/jaxws/system?wsdl | 这是提供身份验证和简单实用工具方法的根服务。
administration (AdministrationService) | /Services1.0/jaxws/administration?wsdl | 此服务提供对 Silk Central 的项目和产品实体的访问。
requirements (RequirementsService) | /Services1.0/jaxws/requirements?wsdl | 此服务提供对 Silk Central 的需求区域的访问。
tests (TestsService) | /Services1.0/jaxws/tests?wsdl | 此服务提供对 Silk Central 的测试区域的访问。
executionplanning (ExecutionPlanningService) | /Services1.0/jaxws/executionplanning?wsdl | 此服务提供对 Silk Central 的执行计划区域的访问。
filter (FilterService) | /Services1.0/jaxws/filter?wsdl | 此服务允许您创建、读取、更新和删除筛选器。
issuemanager (IssueManagerService) | /Services1.0/jaxws/issuemanager?wsdl | 此服务提供对 Issue Manager 的访问。
父主题： Silk Central Web 服务


服务交换

本部分介绍基于 HTTP 的接口，用于处理 Services Exchange 中的报告、附件、测试计划、执行和库。

您还可以通过 Web 服务访问 Silk Central。有关其他信息，请参阅可用 Web 服务。

注： 使用 Web 服务时，系统返回的所有时间均为协调世界时 (UTC)。在您使用的 Web 服务的所有时间引用中也使用 UTC。
  • reportData 接口
    列出 reportData 接口的参数。reportData 接口用于请求报告的数据。
  • TMAttach 接口
    列出 TMAttach 接口的参数。
  • createTestPlan 接口
    列出 createTestPlan 接口的参数。
  • exportTestPlan 接口
    列出 exportTestPlan 接口的参数。
  • updateTestPlan 接口
    列出 updateTestPlan 接口的参数。
  • createRequirements 接口
    列出 createRequirements 接口的参数。
  • exportRequirements 接口
    列出 exportRequirements 接口的参数。
  • updateRequirements 接口
    列出 updateRequirements 接口的参数。
  • updateRequirementsByExtID 接口
    列出 updateRequirementsByExtID 接口的参数。
  • createExecutionDefinitions 接口
    列出 createExecutionDefinitions 接口的参数。
  • exportExecutionDefinitions 接口
    列出 exportExecutionDefinitions 接口的参数。
  • updateExecutionDefinitions 接口
    列出 updateExecutionDefinitions 接口的参数。
  • createLibraries 接口
    列出 createLibraries 接口的参数。
  • exportLibraryStructure 接口
    列出 exportLibraryStructure 接口的参数。
  • exportLibraryStructureWithoutSteps 接口
    列出 exportLibraryStructureWithoutSteps 接口的参数。
  • getLibraryInfoByName 接口
    列出 getLibraryInfoByName 接口的参数。
父主题： Silk Central Web 服务


reportData 接口

reportData 接口用于请求报告的数据。下表显示了 reportData 接口的参数：

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=reportData | sid | 会话 ID： 用户身份验证
 | reportFilterID | 报告筛选器 ID
 | type | 响应正文格式： （csv 或 xml）
 | includeHeaders | 是否包括报告页眉。 （true 或 false）
 | userName | （可选）用户名： 不要使用 sid
 | passWord | （可选）用户密码： 不要使用 sid
 | projectID | 项目 ID

示例：http://<front-end URL>/servicesExchange?hid=reportData&reportFilterID=<id>&type=<csv or xml>&includeHeaders=<true or false>&userName=<user>&passWord=<password>&projectID=<id>

reportData 接口示例

String reportID = "<id>";
   String user = "<user>";
   String pwd = "<pwd>";
   String host = "<any_host>";

    URL report = new URL("http", host, 19120,
    "/servicesExchange?hid=reportData" +
     "&type=xml" + // or csv
     "&userName=" + user +
     "&passWord=" + pwd +
     "&reportFilterID=" + reportID +
     "&includeHeaders=true" +
     "&rp_execNode_Id_0=1" +
     "&projectID=27);

   BufferedReader in = new BufferedReader(new InputStreamReader(report.openStream(), "UTF-8"));

   StringBuilder builder = new StringBuilder();
   String line = "";

   while ((line = in.readLine()) != null) {
       builder.append(line + "\n");
   }

   String text = builder.toString();
   System.out.println(text);
 }
如果报告需要参数，您需要将以下代码添加到每个参数的报告 URL：
 "&rp_parametername=parametervalue"
在示例中，参数 rp_execNode_Id_0 设置为值 1。
注： 传递给 reportData 服务的参数名称必须使用 rp_ 前缀。示例：/servicesExchange?hid=reportData&type=xml&sid=<...>&reportFilterID=<...>&projectID=<...>&rp_TestID=<...>
父主题： 服务交换


TMAttach 接口

TMAttach 接口用于将附件上载到测试或需求。下表显示了 TMAttach 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=TMAttach | sid | 会话 ID： 用户身份验证
 | entityType | 目标实体类型： （测试、需求或 TestStepParent）
 | entityID | 目标实体 ID： （测试 ID、需求 ID 或手动测试 ID）
 | description | 附件说明： URL 编码文本，用于描述附件。
 | isURL | 如果为 true，则附件为 URL。如果为 false，则附件为文件。
 | URL | 可选 - 要附加的 URL。
 | stepPosition | 可选 - 测试步骤顺序。标识手动测试的步骤（例如，顺序第一步是 1）。如果 entityType 是 TestStepParent，则必须遵循顺序。
 | userName | （可选）用户名： 不要使用 sid
 | passWord | （可选）用户密码： 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=TMAttach&entityType=<test, requirement, or TestStepParent>&entityID=<id>&description=<text>&isURL=<true or false>&URL=<URL>&stepPosition=<number>&userName=<user>&passWord=<password>

TMAttach Web 服务示例

以下代码使用 Apache HtmlClient 获取便捷的 HTTP-POST API，以便上载二进制附件。每个请求仅可上载一个附件。

每个请求仅可上载一个附件。要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

import org.apache.commons.httpclient.*; // Apache HttpClient

    String sessionID = null;
    String testNodeID = null; // receiving test
    File fileToUpload = null; // attachment
    String AttachmentDescription = ""; // descriptive text

    HttpClient client = new HttpClient();
    String formURL = "http://localhost:19120/
        servicesExchange?hid=TMAttach" +
        "&sid=" + sessionID +
        "&entityID=" + testNodeID +
        "&entityType=Test" +
        "&isURL=false";
    PostMethod filePost = new PostMethod(formURL);
    Part[] parts = {
        new StringPart("description", attachmentDescription),
        new FilePart(fileToUpload.getName(), fileToUpload)
    };
    filePost.setRequestEntity(new MultipartRequestEntity(parts,
        filePost.getParams()));
    client.getHttpConnectionManager().
        getParams().setConnectionTimeout(60000);
    // Execute and check for success
    int status = client.executeMethod(filePost);
    // verify http return code...
    // if(status == httpStatus.SC_OK) ...
父主题： 服务交换


createTestPlan 接口

createTestPlan 接口用于创建新测试。调用的 HTTP 响应包含已更改测试的 XML 结构。您可以从更新后的 XML 测试结构中获取新节点的标识符。

下表显示了 createTestPlan 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=createTestPlan | sid | 会话 ID – 用户身份验证
 | parentNodeID | 测试树中要添加新测试的容器的 ID
 | userName | 可选：用户名 – 不要使用 sid
 | passWord | 可选：用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=createTestPlan&parentNodeID=<id>&userName=<user>&passWord=<password>

XML 架构定义文件，用于验证测试计划可使用前端服务器 URL http://<前端服务器 URL>/silkroot/xsl/testplan.xsd下载，或是从前端服务器安装文件夹 <Silk Central installation folder>/wwwroot/silkroot/xsl/testplan.xsd 复制。

createTestPlan Web 服务示例

以下代码使用 Apache HttpClient 创建测试。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createTestPlan", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadTestPlanUtf8("testPlan.xml");
StringPart xmlFileItem = new StringPart("testPlan", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

每个请求仅可上载一个附件。要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

测试示例

以下代码显示可通过 createTestPlan 和 updateTestPlan 服务上载至 Silk Central 的示例测试。

  <TestPlan xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/testplan.xsd">

  <Folder name="Folder1" id="5438">
    <Description>Description of the folder</Description>
    <Property name="property1">
      <propertyValue>value1</propertyValue>
    </Property>
    <Test name="TestDef1" type="plugin.SilkTest">
      <Description>Description of the test</Description>
      <Property name="property2">
        <propertyValue>value2</propertyValue>
      </Property>
      <Property name="property3">
           <propertyValue>value3</propertyValue>
           <propertyValue>value4</propertyValue>
      </Property>
      <Parameter name="param1" type="string">string1</Parameter>
      <Parameter name="param2" type="boolean">true</Parameter>
                        <Parameter name="paramDate" type="date">01.01.2001</Parameter>
      <Parameter name="paramInherited" type="string"
        inherited="true">
        inheritedValue1
      </Parameter>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
    </Test>
    <Test name="ManualTest1" id="5441" type="_ManualTestType"
      plannedTime="03:45">
      <Description>Description of the manual test</Description>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
      <Step id="3" name="StepC">
        <ActionDescription>do it now"</ActionDescription>
        <ExpectedResult>
          everything should come as you wish
        </ExpectedResult>
      </Step>
    </Test>
    <Folder name="Folder2" id="5439">
      <Description>Description of the folder</Description>
      <Property name="property4">
        <propertyValue>value5</propertyValue>
      </Property>
      <Parameter name="param3" type="number">123</Parameter>
      <Folder name="Folder2_1" id="5442">
        <Description>Description of the folder</Description>
        <Test name="TestDef2" type="plugin.SilkPerformer">
          <Description>Description of the test</Description>
          <Property name="_sp_Project File">
            <propertyValue>ApplicationAccess.ltp</propertyValue>
          </Property>
          <Property name="_sp_Workload">
            <propertyValue>Workload1</propertyValue>
          </Property>
        </Test>
        <Test name="TestDef3" type="JUnitTestType"
          externalId="com.borland.MyTest">
          <Description>Description of the test</Description>
          <Property name="_junit_ClassFile">
            <propertyValue>com.borland.MyTest</propertyValue>
          </Property>
          <Property name="_junit_TestMethod">
            <propertyValue>testMethod</propertyValue>
          </Property>
          <Step id="1" name="StepA">
            <ActionDescription>do it</ActionDescription>
            <ExpectedResult>everything</ExpectedResult>
          </Step>
          <Step id="2" name="StepB">
            <ActionDescription>and</ActionDescription>
            <ExpectedResult>everything should come</ExpectedResult>
          </Step>
        </Test>
      </Folder>
    </Folder>
  </Folder>
</TestPlan>
父主题： 服务交换


exportTestPlan 接口

exportTestPlan 接口用于将测试计划导出为 XML 文件。下表显示了 exportTestPlan 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=exportTestPlan | sid | 会话 ID – 用户身份验证
 | nodeID | 具有此 ID 的节点以及此节点下的所有递归子节点都将被导出
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=exportTestPlan&nodeID=<id>&userName=<user>&passWord=<password>

exportTestPlan Web 服务示例

以下代码使用 Apache HttpClient 来导出测试。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportTestPlan", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

父主题： 服务交换


updateTestPlan 接口

updateTestPlan 接口用于通过 XML 文件中的现有根节点更新测试。调用的 HTTP 响应包含已更改测试的 XML 结构。您可以从更新后的 XML 测试结构中获取新节点的标识符。

下表显示了 updateTestPlan 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=updateTestPlan | sid | 会话 ID – 用户身份验证
 | userName | 可选：用户名 – 不要使用 sid
 | passWord | 可选：用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=updateTestPlan&userName=<user>&passWord=<password>

XML 架构定义文件，用于验证测试计划可使用前端服务器 URL http://<前端服务器 URL>/silkroot/xsl/testplan.xsd下载，或是从前端服务器安装文件夹 <Silk Central installation folder>/wwwroot/silkroot/xsl/testplan.xsd 复制。

updateTestPlan Web 服务示例

以下代码使用 Apache HttpClient 更新测试。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
String xml = loadTestPlanUtf8(DEMO_TEST_PLAN_XML);
HttpClient client = new HttpClient();

URL webServiceUrl = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateTestPlan",
    sessionID));
StringPart testPlanXml = new StringPart(DEMO_TEST_PLAN_XML, xml,
  "UTF-8");
testPlanXml.setContentType("text/xml");
Part[] parts = {testPlanXml};
PostMethod filePost = new PostMethod(webServiceUrl.toExternalForm());
filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

每个请求仅可上载一个附件。要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

测试示例

以下代码显示可通过 createTestPlan 和 updateTestPlan 服务上载至 Silk Central 的示例测试。

  <TestPlan xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/testplan.xsd">

  <Folder name="Folder1" id="5438">
    <Description>Description of the folder</Description>
    <Property name="property1">
      <propertyValue>value1</propertyValue>
    </Property>
    <Test name="TestDef1" type="plugin.SilkTest">
      <Description>Description of the test</Description>
      <Property name="property2">
        <propertyValue>value2</propertyValue>
      </Property>
      <Property name="property3">
           <propertyValue>value3</propertyValue>
           <propertyValue>value4</propertyValue>
      </Property>
      <Parameter name="param1" type="string">string1</Parameter>
      <Parameter name="param2" type="boolean">true</Parameter>
                        <Parameter name="paramDate" type="date">01.01.2001</Parameter>
      <Parameter name="paramInherited" type="string"
        inherited="true">
        inheritedValue1
      </Parameter>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
    </Test>
    <Test name="ManualTest1" id="5441" type="_ManualTestType"
      plannedTime="03:45">
      <Description>Description of the manual test</Description>
      <Step id="1" name="StepA">
        <ActionDescription>do it</ActionDescription>
        <ExpectedResult>everything</ExpectedResult>
      </Step>
      <Step id="2" name="StepB">
        <ActionDescription>and</ActionDescription>
        <ExpectedResult>everything should come</ExpectedResult>
      </Step>
      <Step id="3" name="StepC">
        <ActionDescription>do it now"</ActionDescription>
        <ExpectedResult>
          everything should come as you wish
        </ExpectedResult>
      </Step>
    </Test>
    <Folder name="Folder2" id="5439">
      <Description>Description of the folder</Description>
      <Property name="property4">
        <propertyValue>value5</propertyValue>
      </Property>
      <Parameter name="param3" type="number">123</Parameter>
      <Folder name="Folder2_1" id="5442">
        <Description>Description of the folder</Description>
        <Test name="TestDef2" type="plugin.SilkPerformer">
          <Description>Description of the test</Description>
          <Property name="_sp_Project File">
            <propertyValue>ApplicationAccess.ltp</propertyValue>
          </Property>
          <Property name="_sp_Workload">
            <propertyValue>Workload1</propertyValue>
          </Property>
        </Test>
        <Test name="TestDef3" type="JUnitTestType"
          externalId="com.borland.MyTest">
          <Description>Description of the test</Description>
          <Property name="_junit_ClassFile">
            <propertyValue>com.borland.MyTest</propertyValue>
          </Property>
          <Property name="_junit_TestMethod">
            <propertyValue>testMethod</propertyValue>
          </Property>
          <Step id="1" name="StepA">
            <ActionDescription>do it</ActionDescription>
            <ExpectedResult>everything</ExpectedResult>
          </Step>
          <Step id="2" name="StepB">
            <ActionDescription>and</ActionDescription>
            <ExpectedResult>everything should come</ExpectedResult>
          </Step>
        </Test>
      </Folder>
    </Folder>
  </Folder>
</TestPlan>
父主题： 服务交换


createRequirements 接口

createRequirements 接口用于创建新需求。调用的 HTTP 响应包含更改需求的 XML 结构。您可以从更新后的 XML 需求结构中获取新节点的标识符。

下表显示了 createRequirements 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=createRequirements | sid | 会话 ID – 用户身份验证
 | parentNodeID | 需求树中要添加新需求的容器的 ID
 | userName | 可选：用户名 – 不要使用 sid
 | passWord | 可选：用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=createRequirements&parentNodeID=<id>&userName=<user>&passWord=<password>

用于验证需求的 XML 架构定义文件可以使用前端服务器 URL http://<前端服务器 URL>/silkroot/xsl/requirements.xsd 下载或从前端服务器安装文件夹 <Silk Central installation folder>/wwwroot/silkroot/xsl/requirements.xsd 复制。

createRequirements Web 服务示例

以下代码使用 Apache HttpClient 创建需求。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createRequirements", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadRequirementsUtf8("requirements.xml");
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

每个请求仅可上载一个附件。要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

需求示例

以下代码显示可通过 createRequirements、updateRequirements 和 updateRequirementsByExtID 服务上载至 Silk Central 的示例需求。

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
父主题： 服务交换


exportRequirements 接口

exportRequirements 接口用于将需求导出为 XML 文件。下表显示了 exportRequirements 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=exportRequirements | sid | 会话 ID – 用户身份验证
 | nodeID | 具有此 ID 的节点以及此节点下的所有递归子节点都将被导出
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid
 | includeObsolete | 可选： 指定 true 或 false。如果忽略，则默认为 true。指定 false 以排除过时的需求。

示例：http://<front-end URL>/servicesExchange?hid=exportRequirements&nodeID=<id>&userName=<user>&passWord=<password>

exportRequirements Web 服务示例

以下代码使用 Apache HttpClient 来导出需求。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportRequirements", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedRequirementResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedRequirementResponse);

要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

父主题： 服务交换


updateRequirements 接口

updateRequirements 接口用于通过 XML 文件中的现有根节点更新需求。需求由需求树中的内部 Silk Central 节点 ID 标识。更新需求树节点和所有节点的子项。添加新节点，将丢失的节点设置为过时，移动的节点也同样在 Silk Central 中移动。调用的 HTTP 响应包含更改需求的 XML 结构。您可以从更新后的 XML 需求结构中获取新节点的标识符。

下表显示了 updateRequirements 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=updateRequirements | sid | 会话 ID – 用户身份验证
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=updateRequirements&userName=<user>&passWord=<password>

用于验证需求的 XML 架构定义文件可以使用前端服务器 URL http://<前端服务器 URL>/silkroot/xsl/requirements.xsd 下载或从前端服务器安装文件夹 <Silk Central installation folder>/wwwroot/silkroot/xsl/requirements.xsd 复制。

updateRequirements Web 服务示例

以下代码使用 Apache HttpClient 来更新需求。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateRequirements", sessionID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
string xmlFile = loadRequirementsUtf8(fileName);
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

每个请求仅可上载一个附件。要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

需求示例

以下代码显示可通过 createRequirements、updateRequirements 和 updateRequirementsByExtID 服务上载至 Silk Central 的示例需求。

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
父主题： 服务交换


updateRequirementsByExtID 接口

updateRequirementsByExtID 接口用于通过 XML 文件中的现有根节点更新需求。需求由外部 ID 标识。更新需求树节点和所有节点的子项。添加新节点，将丢失的节点设置为过时，移动的节点也同样在 Silk Central 中移动。调用的 HTTP 响应包含更改需求的 XML 结构。您可以从更新后的 XML 需求结构中获取新节点的标识符。

下表显示了 updateRequirementsByExtID 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=updateRequirementsByExtID | sid | 会话 ID – 用户身份验证
 | nodeID | 需求树中要更新的节点的 ID。
 | userName | 可选：用户名 – 不要使用 sid
 | passWord | 可选：用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=updateRequirementsByExtID&nodeID=<id>&userName=<user>&passWord=<password>

用于验证需求的 XML 架构定义文件可以使用前端服务器 URL http://<前端服务器 URL>/silkroot/xsl/requirements.xsd 下载或从前端服务器安装文件夹 <Silk Central installation folder>/wwwroot/silkroot/xsl/requirements.xsd 复制。

updateRequirementsByExtID Web 服务示例

以下代码使用 Apache HttpClient 来更新需求。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",&nodeID=%s",
    "updateRequirementsByExtID",
    sessionID, rootNodeId));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
string xmlFile = loadRequirementsUtf8(fileName);
StringPart xmlFileItem = new StringPart("requirements", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

每个请求仅可上载一个附件。要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

需求示例

以下代码显示可通过 createRequirements、updateRequirements 和 updateRequirementsByExtID 服务上载至 Silk Central 的示例需求。

<Requirement id="0" name="name" xmlns="http://www.borland.com/RequirementsSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/requirements.xsd">
    <ExternalId>myExtId1</ExternalId>
    <Description>Description</Description>
    <Priority value="Low" inherited="false"/>
    <Risk value="Critical" inherited="false"/>
    <Reviewed value="true" inherited="false"/>
    <Property inherited="false" name="Document" type="string">MyDocument1.doc</Property>
    <Requirement id="1" name="name" />
    <Requirement id="2" name="name1">
        <Requirement id="3" name="name" />
        <Requirement id="4" name="name1">
            <Requirement id="5" name="name" />
      <Requirement id="6" name="name1">
        <ExternalId>myExtId2</ExternalId>
        <Description>Another Description</Description>
        <Priority value="Medium" inherited="false"/>
        <Risk value="Critical" inherited="false"/>
        <Reviewed value="true" inherited="false"/>
        <Property inherited="false" name="Document" type="string">MyDocument2.doc</Property>
            </Requirement>
        </Requirement>
    </Requirement>
</Requirement>
父主题： 服务交换


createExecutionDefinitions 接口

createExecutionDefinitions 接口用于创建新执行计划。调用的 HTTP 响应包含更改后的执行计划的 XML 结构。您可以从更新 XML 执行计划结构中获取新节点的标识符。

下表显示了 createExecutionDefinitions 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=createExecutionDefinitions | sid | 会话 ID – 用户身份验证
 | parentNodeID | 执行计划树中要添加新执行计划的节点的 ID
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=createExecutionDefinitions&parentNodeID=<id>&userName=<user>&passWord=<password>

用于验证执行的 XML 架构定义文件可以使用前端服务器 URL http://<前端服务器 URL>/silkroot/xsl/executionplan.xsd 下载，或从前端服务器安装文件夹 <Silk Central installation folder>/wwwroot/silkroot/xsl/executionplan.xsd 复制。

createExecutionDefinitions Web 服务示例

以下代码使用 Apache HttpClient 创建执行计划。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&parentNodeID=%d",
  "createExecutionDefinitions", sessionID,
  PARENT_NODE_ID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadExecutionDefinitionsUtf8("executionplan.xml");
StringPart xmlFileItem = new StringPart("executionplan", xmlFile,
  "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

每个请求仅可上载一个附件。要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

执行计划示例

以下代码显示可通过 createExecutionDefinitions 和 updateExecutionDefinitions 服务上载至 Silk Central 的示例执行计划。该示例为其中一个执行定义创建自定义计划，并通过手动分配和筛选器将测试分配到执行计划。该示例还会创建一个包含这些配置的配置套件。

<ExecutionPlan xmlns="http://www.borland.com/ExecPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/executionplan.xsd">

  <Folder name="Folder1">
    <Description>Description of the folder</Description>
    <ExecDef name="ExecutionDefinition1" TestContainerId="1">
      <Description>Description1</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <forever>true</forever>
        </end>
        <Interval day="1" hour="2" minute="3"></Interval>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>
      <ReadFromBuildInfoFile>true</ReadFromBuildInfoFile>
      <Priority>High</Priority>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ExecDef>
    <ExecDef name="ExecutionDefinition2" TestContainerId="1">
      <Description>Description2</Description>
      <Build>1</Build>
      <Version>1</Version>
      <Priority>Low</Priority>
      <SourceControlLabel>Label1</SourceControlLabel>
      <DependentExecDef id="65">
        <Condition>Passed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Server" id="1"/>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="70">
        <Condition>Failed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="68">
        <Condition>Any</Condition>
        <Deployment>
          <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
        </Deployment>
      </DependentExecDef>
    </ExecDef>

    <ConfigSuite name="ConfigSuite1" TestContainerId="1">
      <Description>ConfigSuite1 desc</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <times>1</times>
        </end>
        <Interval day="1" hour="2" minute="3"/>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>

      <ConfigExecDef name="Config1">
        <Description>Config1 desc</Description>
        <Priority>Medium</Priority>
      </ConfigExecDef>

      <ConfigExecDef name="Config2">
        <Priority>Medium</Priority>
        <DependentExecDef id="69">
          <Condition>Any</Condition>
          <Deployment>
            <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
          </Deployment>
        </DependentExecDef>
      </ConfigExecDef>

      <Build>8</Build>
      <Version>2</Version>
      <SourceControlLabel>ConfigSuite1 label</SourceControlLabel>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ConfigSuite>
  </Folder>
</ExecutionPlan>
父主题： 服务交换


exportExecutionDefinitions 接口

exportExecutionDefinitions 接口用于将执行计划导出为 XML 文件。下表显示了 exportExecutionDefinitions 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=exportExecutionDefinitions | sid | 会话 ID – 用户身份验证
 | nodeID | 具有此 ID 的节点以及此节点下的所有递归子节点都将被导出
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=exportExecutionDefinitions&nodeID=<id>&userName=<user>&passWord=<password>

exportExecutionDefinitions Web 服务示例

以下代码使用 Apache HttpClient 来导出执行计划。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportExecutionDefinitions", sessionID,
  NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedExecutionPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedExecutionPlanResponse);

要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

父主题： 服务交换


updateExecutionDefinitions 接口

updateExecutionDefinitions 接口用于从 XML 文件更新执行计划。调用的 HTTP 响应包含更改后的执行计划的 XML 结构。您可以从更新 XML 执行计划结构中获取新节点的标识符。

下表显示了 updateExecutionDefinitions 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=updateExecutionDefinitions | sid | 会话 ID – 用户身份验证
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=updateExecutionDefinitions&userName=<user>&passWord=<password>

用于验证执行的 XML 架构定义文件可以使用前端服务器 URL http://<前端服务器 URL>/silkroot/xsl/executionplan.xsd 下载，或从前端服务器安装文件夹 <Silk Central installation folder>/wwwroot/silkroot/xsl/executionplan.xsd 复制。

updateExecutionDefinitions Web 服务示例

以下代码使用 Apache HttpClient 更新执行计划。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();
string xml = loadExecutionPlanUtf8(DEMO_EXECUTION_PLAN_XML);
HttpClient client = new HttpClient();

URL webServiceUrl = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(),
  String.format("/servicesExchange?hid=%s&sid=%s",
    "updateExecutionDefinitions",
    sessionID));
StringPart ExecutionPlanXml = new StringPart(DEMO_EXECUTION_PLAN_XML, xml,
  "UTF-8");
ExecutionPlanXml.setContentType("text/xml");
Part[] parts = {ExecutionPlanXml};
PostMethod filePost = new PostMethod(webServiceUrl.toExternalForm());
filePost.setRequestEntity(new MultipartRequestEntity(parts,
  filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

String responseXml = filePost.getResponseBodyAsString();

每个请求仅可上载一个附件。要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

执行计划示例

以下代码显示可通过 createExecutionDefinitions 和 updateExecutionDefinitions 服务上载至 Silk Central 的示例执行计划。该示例为其中一个执行定义创建自定义计划，并通过手动分配和筛选器将测试分配到执行计划。该示例还会创建一个包含这些配置的配置套件。

<ExecutionPlan xmlns="http://www.borland.com/ExecPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/executionplan.xsd">

  <Folder name="Folder1">
    <Description>Description of the folder</Description>
    <ExecDef name="ExecutionDefinition1" TestContainerId="1">
      <Description>Description1</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <forever>true</forever>
        </end>
        <Interval day="1" hour="2" minute="3"></Interval>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>
      <ReadFromBuildInfoFile>true</ReadFromBuildInfoFile>
      <Priority>High</Priority>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ExecDef>
    <ExecDef name="ExecutionDefinition2" TestContainerId="1">
      <Description>Description2</Description>
      <Build>1</Build>
      <Version>1</Version>
      <Priority>Low</Priority>
      <SourceControlLabel>Label1</SourceControlLabel>
      <DependentExecDef id="65">
        <Condition>Passed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Server" id="1"/>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="70">
        <Condition>Failed</Condition>
        <Deployment>
          <Specific>
            <Execution type="Tester" id="0"/>
          </Specific>
        </Deployment>
      </DependentExecDef>
      <DependentExecDef id="68">
        <Condition>Any</Condition>
        <Deployment>
          <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
        </Deployment>
      </DependentExecDef>
    </ExecDef>

    <ConfigSuite name="ConfigSuite1" TestContainerId="1">
      <Description>ConfigSuite1 desc</Description>
      <CustomSchedule>
        <start>2009-11-26T21:32:52</start>
        <end>
          <times>1</times>
        </end>
        <Interval day="1" hour="2" minute="3"/>
        <adjustDaylightSaving>false</adjustDaylightSaving>
        <exclusions>
          <days>Monday</days>
          <days>Wednesday</days>
          <from>21:32:52</from>
          <to>22:32:52</to>
        </exclusions>
        <definiteRun>2009-11-27T21:35:12</definiteRun>
      </CustomSchedule>

      <ConfigExecDef name="Config1">
        <Description>Config1 desc</Description>
        <Priority>Medium</Priority>
      </ConfigExecDef>

      <ConfigExecDef name="Config2">
        <Priority>Medium</Priority>
        <DependentExecDef id="69">
          <Condition>Any</Condition>
          <Deployment>
            <UseFromCurrentExedDef>true</UseFromCurrentExedDef>
          </Deployment>
        </DependentExecDef>
      </ConfigExecDef>

      <Build>8</Build>
      <Version>2</Version>
      <SourceControlLabel>ConfigSuite1 label</SourceControlLabel>
      <SetupTestDefinition>73</SetupTestDefinition>
      <CleanupTestDefinition>65</CleanupTestDefinition>
      <AssignedTestDefinitions>
        <ManualAssignment useTestPlanOrder="true">
          <TestId>6</TestId>
          <TestId>5</TestId>
        </ManualAssignment>
      </AssignedTestDefinitions>
    </ConfigSuite>
  </Folder>
</ExecutionPlan>
父主题： 服务交换


createLibraries 接口

createLibraries 接口用于创建新库。调用的 HTTP 响应包含已更改库的 XML 结构。您可从已更新的 XML 库结构中获取新节点的标识符。

下表显示了 createLibraries 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=createLibraries | sid | 会话 ID – 用户身份验证
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid

示例：http://<front-end URL>/servicesExchange?hid=createLibraries&userName=<user>&passWord=<password>

用于验证库的 XML 架构定义文件可以使用前端服务器 URL http://<前端服务器 URL>/silkroot/xsl/libraries.xsd 下载或从前端服务器安装文件夹 <Silk Central installation folder>/wwwroot/silkroot/xsl/libraries.xsd 复制。

createLibraries Web 服务示例

以下代码使用 Apache HttpClient 创建库。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s",
  "createLibraries", sessionID));

HttpClient client = new HttpClient();
PostMethod filePost = new PostMethod(service.toExternalForm());
String xmlFile = loadTestPlanUtf8("libraries.xml");
StringPart xmlFileItem = new StringPart("libraries", xmlFile, "UTF-8");
xmlFileItem.setContentType("text/xml");
Part[] parts = {xmlFileItem};

filePost.setRequestEntity(new MultipartRequestEntity(parts, filePost.getParams()));
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
int status = client.executeMethod(filePost);
System.out.println(filePost.getStatusLine());

要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

库示例

以下代码显示可通过 createLibraries 服务上载至 Silk Central 的示例库。除非在 GrantedProjects 部分中定义了一个或多个项目，否则新库并不仅限于在某些项目中使用。

<LibraryStructure xmlns="http://www.borland.com/TestPlanSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://<front-end URL>/silkroot/xsl/libraries.xsd">

  <Library name="Library 1">
    <Folder name="Folder 1">
      <Folder name="Folder 1.1">
        <SharedSteps name="Basic create user steps">
          <Step name="Login">
            <ActionDescription>
              Login with user admin.
            </ActionDescription>
            <ExpectedResult>Succesful login.</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
          <Step name="Create User">
            <ActionDescription>Create user tester</ActionDescription>
            <ExpectedResult>User created</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
          <Step name="Logout">
            <ActionDescription>
              Logout using start menu
            </ActionDescription>
            <ExpectedResult>Logged out.</ExpectedResult>
            <CustomStepProperty name="Step Property 1">
                        <propertyValue>Step Property Value</propertyValue>
            </CustomStepProperty>
          </Step>
        </SharedSteps>
      </Folder>
    </Folder>
    <GrantedProjects>
      <ProjectId>0</ProjectId>
      <ProjectId>1</ProjectId>
    </GrantedProjects>
  </Library>
</LibraryStructure>
父主题： 服务交换


exportLibraryStructure 接口

exportLibraryStructure 接口用于将库、文件夹和共享步骤对象导出为 XML 文件。下表显示了 exportLibraryStructure 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=exportLibraryStructure | sid | 会话 ID – 用户身份验证
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid
 | nodeID | 要导出的库树中的库节点或文件夹。不允许共享步骤节点的 ID。

示例：http://<front-end URL>/servicesExchange?hid=exportLibraryStructure&userName=<user>&passWord=<password>&nodeID=<id>

exportLibraryStructure Web 服务示例

以下代码使用 Apache HttpClient 来导出库。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportLibraryStructure", sessionID, NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

父主题： 服务交换


exportLibraryStructureWithoutSteps 接口

exportLibraryStructureWithoutSteps 接口用于将库、文件夹和共享步骤对象导出为 XML 文件。包括在共享步骤对象中的步骤未被导出。下表显示了 exportLibraryStructureWithoutSteps 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=exportLibraryStructureWithoutSteps | sid | 会话 ID – 用户身份验证
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid
 | nodeID | 要导出的库树中的库节点或文件夹。不允许共享步骤节点的 ID。

示例：http://<front-end URL>/servicesExchange?hid=exportLibraryStructureWithoutSteps&userName=<user>&passWord=<password>&nodeID=<id>

exportLibraryStructureWithoutSteps Web 服务示例

以下代码使用 Apache HttpClient 来导出库。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s&nodeID=%d",
  "exportLibraryStructureWithoutSteps", sessionID, NODE_ID));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String exportedTestPlanResponse = fileGet.getResponseBodyAsString();
System.out.println(exportedTestPlanResponse);

要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

父主题： 服务交换


getLibraryInfoByName 接口

getLibraryInfoByName 接口将返回所有具有指定名称的库的 ID、名称和说明。界面仅返回库的属性，未返回其结构。下表显示了 getLibraryInfoByName 接口的参数。

接口 URL | 参数 | 说明
http://<front-end URL>/servicesExchange?hid=getLibraryInfoByName | sid | 会话 ID – 用户身份验证
 | userName | 可选： 用户名 – 不要使用 sid
 | passWord | 可选： 用户密码 – 不要使用 sid
 | libraryName | 库的名称

示例：http://<front-end URL>/servicesExchange?hid=getLibraryInfoByName&userName=<user>&passWord=<password>&libraryName=<name>

getLibraryInfoByName Web 服务示例

以下代码使用 Apache HttpClient 获取库信息。

import org.apache.commons.httpclient.*; // Apache HttpClient

long sessionID = mWebServiceHelper.getSessionId();

URL service = new URL("http", mWebServiceHelper.getHost(),
  mWebServiceHelper.getPort(), String.format("/servicesExchange?hid=%s&sid=%s",
  "getLibraryInfoByName", sessionID, LIBRARY_NAME));

HttpClient client = new HttpClient();
client.getHttpConnectionManager().getParams().setConnectionTimeout(60000);
HttpMethod fileGet = new GetMethod(service.toExternalForm());
int status = client.executeMethod(fileGet);
System.out.println(fileGet.getStatusLine());
String response = fileGet.getResponseBodyAsString();
System.out.println(response);

要下载 Apache HttpComponents，请访问 http://hc.apache.org/downloads.cgi。请参阅组件文档，了解所需的库。

父主题： 服务交换


Web Service Demo Client

Web Service Demo Client 是一种演示如何使用Silk Central Web 服务的工具。 从帮助 > 工具中下载客户端。

Web Service Demo Client 显示每个测试在测试 > 管理测试属性中可用的所有属性，以及每个可用测试类型的所有属性。
注意： Web Service Demo Client 专为演示 Web 服务的使用而设计。 请勿在生产环境下使用演示客户端。
父主题： Silk Central Web 服务


联系Micro Focus

Micro Focus 致力于为客户提供世界一流的技术支持和咨询服务。Micro Focus 提供全球支持，从而能够提供及时可靠的服务以确保每个客户的业务成功。

拥有维护和支持合同的所有客户以及正在评估产品的潜在客户都有资格获得客户支持。我们训练有素的员工会尽可能迅速专业地响应您的请求。

请访问 http://supportline.microfocus.com/assistedservices.asp 直接与 Micro Focus SupportLine 沟通以解决问题，或发送电子邮件至 supportline@microfocus.com。

请通过 http://supportline.microfocus.com 访问 Micro Focus SupportLine 以获取最新支持新闻并访问其他支持信息。首次使用的用户可能需要注册该站点。

  • Micro Focus SupportLine 所需的信息
    列出 Micro Focus SupportLine 为帮助解决客户问题而需要的信息。
  • 系统诊断
    介绍如何查看和下载系统诊断。


Micro Focus SupportLine 所需的信息

联系 Micro Focus SupportLine 时，请提供以下信息（如有可能）。提供的信息越多，Micro Focus SupportLine 越能更好地帮助您。

  • 您认为的所有产品的名称和版本号可能会导致问题。
  • 您的计算机品牌和型号。
  • 系统信息，如操作系统的名称和版本、处理器和内存详细信息。
  • 问题的任何详细说明，包括重现问题的步骤。
  • 涉及的任何错误消息的准确词句。
  • 您的序列号。

要查找这些号码，请，在从 Micro Focus 接收到的电子产品发送通知电子邮件的主题行和正文中进行查找。

父主题： 联系Micro Focus
相关概念
系统诊断


启用或禁用 HTML 响应压缩

要启用或禁用 HTML 响应压缩：

  1. 在实例管理页面上，停止要修改的实例的前端服务器。
  2. 使用文本编辑器打开 Server.xml 文件。 此文件位于前端服务器的 Silk Central 目录的 /conf/frontendserver 文件夹中。
  3. 找到 Connector XML 标记。
  4. 将 compression="on" 和 compressableMimeType="text/html,text/xml,text/plain,text/css,text/javascript,application/xml" 添加到连接器。 Servlet 将压缩 gzip 的任何响应。 Gzip 来源于 Apache Tomcat Native。
  5. 保存并关闭 XML 文件。
  6. 重新启动前端服务器。
相关任务
管理实例


Reuse_Creating or Editing Tests

创建新测试：

  1. 在菜单中，单击测试 > 详细信息视图。
  2. 在要插入新测试的测试树中，选择容器或文件夹节点，或选择要编辑的测试。
  3. 单击工具栏中的 新建子测试 （新建子测试），或单击 [image] （编辑）。

    将显示新建测试/编辑测试对话框。

  4. 键入测试的名称和说明。
    注： Silk Central 支持 HTML 格式，并可剪切和粘贴 HTML 内容以用于说明文本框。
  5. 从类型列表中选择测试类型。
  6. 单击下一步以继续配置测试属性中所选测试类型的相应主题。
注： 定义完善的 Silk Central 公共 API 使您可实施符合自动测试需求的专用解决方案。Silk Central 是开放式的，并可扩展至能够通过 Java 实现或命令行调用进行调用的任何外部工具。
注： 在整个测试配置过程以及所有测试类型中，将在适用时提供从父级继承复选框选项，从而使您能够接受任何现有父实体的设置。